First Topic

>> Help for Asix v.7

www.asix.com.pl

Asix.Evo - Types of Archival Data Aggregates

Doc. No ENH7E000

Version: 2012-09-14


Types of Archival Data Aggregates

Whenever the access to the aggregated historical data is required in the Asix.Evo application, it is necessary to specify the aggregate name. This applies to the Chart object, HorizonAggregate function and RangeAggregate, interfaces of scripting model.

Name | Meaning
none | no aggregation
start | The value at the beginning of the interval.
end | The value at the end of the interval.
delta | The difference of a values at the end and beginning of the interval.
min | The minimum value within the interval.
max | The maximum value within the interval.
range | The difference between the maximum and the minimum value within the interval.
total | The time-weighted sum of values within the interval (a time integral).
average | The average of time-weighted values within the interval.
average0 | The average of time-weighted values within the interval. Within the periods in which a value is not available for calculations, the 0 value is used.
sumup | The sum of positive changes from the last known value prior to the start, to the last value before the end of the sampling interval.
sumdown | The sum of the absolute values of the negative changes from the last known value prior to the start, to the last value before the end of the sampling interval.
prevknown | The last known (good or uncertain) value before the start of the sampling interval. Yields the last value, even if it occurred a long time ago.
last | The last known (good or uncertain) value within the sampling interval excluding the end of the interval - to distinguish from the end aggregate, which includes the interval end.
stdev | The time-weighted standard deviation within the sampling interval.
rms | The time-weighted RMS within the sampling interval.
avglk | The time-weighted average within the sampling interval. Last known value is inserted in place of corrupt or missing values.
totallk | The integral over the sampling interval, with the time calculated in seconds. Last known value is inserted in place of corrupt or missing values.

The detailed description of the aggregates and their parameterization can be found in the documentation of the Aspad archiving module.