Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 8

www.asix.com.pl

Moduł AsAlert -

System powiadamiania o ważnych zdarzeniach

Dok. Nr PLW8003

Wersja: 2015-01-20


1. AsAlert - system powiadamiania o ważnych zdarzeniach

Zadaniem systemu alertowania jest zdalne powiadamianie wybranych osób o ważnych zdarzeniach. Komunikaty mogą docierać do adresatów jako poczta elektroniczna (email) lub jako komunikat SMS sieci GSM. Oba rodzaje przesyłek mogą być przekazywane z wykorzystaniem różnych metod przesyłu - zarówno poprzez Internet, jak i sieć komórkową GSM. Sprzężenie systemu wysyłania alertów z mechanizmem generowania alarmów Asixa pozwala na automatyczne wysyłanie alertów w reakcji na wykrycie zmiany stanu wybranych alarmów.

Do wysyłki alertów z zastosowaniem różnych mediów i metod transmisji służą moduły komunikacyjne. Ich zakres funkcjonalny obejmuje między innymi:

  • wysyłkę alertów w postaci poczty elektronicznej poprzez Internet i protokół SMTP,

  • wysyłkę alertów w postaci komunikatów SMS do urządzeń odbiorczych sieci komórkowej (np. telefony komórkowe) poprzez sieć GSM,

  • wysyłkę alertów z wykorzystaniem protokołu OAP lub dedykowanego protokołu firmy Kontel dla urządzeń Ascom.

System alterowania funkcjonuje w strukturze klient - serwer. Aplikacje klienckie żądające wysyłki alertów mogą pracować na stacjach sieciowych. Połączenie z AsAlertem uzyskują po pomyślnym zweryfikowaniu przez system AsAlert ich praw dostępu (w tym celu AsAlert utrzymuje listę nazw użytkowników wraz z ich hasłami).

Wszelkie informacje dotyczące użytkowników, adresatów oraz wysyłanych informacji przechowywane są w relacyjnych bazach danych. Standardowo obsługiwane są bazy Microsoft Jet (pliki MDB) i Microsoft SQL.


AsAlert_Ascom

1.1 Współpraca AsAlert z systemem alarmowo-telefonicznym firmy Ascom

Moduł AsAlert może być wykorzystywany do rozsyłania alertów za pośrednictwem systemu alarmowo-telefonicznego firmy Ascom. System ten daje możliwość przesyłania alarmów na telefony użytkowników z dowolnych systemów w zakładzie. Dzięki systemowi automatycznej eskalacji Ascom daje 100% pewność, że alarm dotrze do właściwej osoby w najkrótszym możliwym czasie oraz że osoba odbierze alarm i podejmie odpowiednie działania. Jeżeli pracownik nie zareaguje na alarm, system automatycznie przesyła wiadomość do kolejnych pracowników lub informuje przełożonego. System daje możliwość zaprogramowania dowolnych scenariuszy powiadomień, w zależności od problemu.

Komunikacja pomiędzy modułem AsAlert a systemem Ascom odbywa się za pośrednictwem protokołu OAP (1 wariant) lub dedykowanego protokołu firmy Kontel (2 wariant).

W przypadku 1 wariantu (AsAlert - OAP - Ascom) komunikacja odbywa się na sieci LAN za pomocą TCP i znaczników XML, gdzie serwer OAP znajduje się po stronie systemu Ascom a system zewnętrzny jest klientem. Do jednego serwera OAP może być podpiętych do 50 klientów. Poniżej schemat komunikacji dla wariantu AsAlert - OAP - Ascom. AsAlert posiada zaimplementowany protokół OAP umożliwiający komunikację z telefonami bezprzewodowymi systemu Ascom. Serwer OAP przekazuje wiadomość wysłaną przez aplikację kliencką (AsAlert) do protokołu używanego przez system alarmowo-telefoniczny (Ascom IP-DECT system).

Wariant AsAlert - OAP - Ascom wymaga: serwera OAP oraz systemu Ascom IP-DECT, dostarczanych przez firmę Kontel.

Rys. Komunikacja pomiędzy modułem AsAlert a bezprzewodowym systemem alarmowo-telefonicznym Ascomm (wariant z OAP).

Źródło: Opracowane na podstawie materiałów Ascom/Kontel.

W przypadku 2 wariantu (AsAlert - protokół Kontel - Ascom) komunikacja odbywa się w sieci LAN za pomocą TCP i znaczników XML, gdzie serwer Unite znajduje się po stronie systemu Ascom, a system zewnętrzny jest klientem. Do jednego serwera Unite może być podpiętych do 5 klientów.

Poniżej schemat komunikacji dla wariantu AsAlert &endash; protokół Kontel - Ascom.

Rys. Komunikacja pomiędzy modułem AsAlert a bezprzewodowym systemem przywoławczym Ascomm (wariant bez OAP).

Źródło: Opracowane na podstawie materiałów Ascom/Kontel.

AsAlert posiada zaimplementowany protokół XML umożliwiający komunikację z telefonami bezprzewodowymi systemu Ascom.

Serwer UNITE przekazuje wiadomość wysłaną przez aplikację kliencką (AsAlert) do użytkowników systemu alarmowego Ascom przy pomocy przemysłowej radiowej technologii IP-DECT.

Wariant AsAlert - protokół Kontel - Ascom wymaga: serwera UNITE oraz systemu Ascom IP-DECT, dostarczanych przez firmę Kontel.

***

Różnica pomiędzy wariantem 1 a 2 polega na możliwości przesyłania alarmów na telefony użytkowników końcowych.

W wariancie 1 o scenariuszu powiadomień decyduje klient (AsAlert). Serwer OAP przekazuje jedynie alarm na telefon pracownika, którego wybrał AsAlert. Informacja może zostać wysłana do pojedynczej osoby lub grupy osób, ale jest to informacja jednokierunkowa. Nie ma możliwości weryfikacji, czy alarm został przyjęty. Nie ma również możliwości eskalacji alarmu do kolejnych osób. Wariant 1 nie zapewnia 100% pewności, że informacja zostanie odebrana.

W wariancie 2 o scenariusz powiadomień decyduje serwer Unite. Na serwerze Unite można ułożyć dowolny scenariusz powiadomień w zależności od zaistniałego problemu. Klient (AsAlert) przesyła tylko informację o kodzie alarmu, a serwer Unite na tej podstawie oraz na podstawie zaprogramowanego scenariusza przesyła informację do właściwych osób. Ponieważ jest to komunikacja dwustronna można sprawdzić, czy dana osoba przyjęła alarm. Jeżeli alarm nie zostanie odebrany w określonym czasie, jest eskalowany do kolejnych pracowników, aż do skutecznego powiadomienia o zaistniałym problemie. W wariancie tym serwer Unite automatycznie kontroluje przepływ informacji i dzięki temu zapewnia, że każdy alarm zostanie odebrany przez właściwe osoby.

***

System alarmowo-telefoniczny IP-DECT firmy Ascom stanowi połączenie sprawdzonego standardu DECT z VoIP, umożliwiając zarówno przesyłanie pakietu danych jak i wysokiej jakości połączeń głosowych - w tej samej sieci. Elementami składowymi systemu są:

- stacje bazowe IP-DECT,

- bramy (gateway) IP-DECT,

- UPAC lub IMS,

- bramy (gateway) VoIP (cyfrowe lub analogowe),

- istniejące "stare" stacje bazowe.

System IP-DECT firmy Ascom posiada w pełni modularną budowę, konfigurowaną indywidualnie do potrzeb klienta. System może liczyć do 2.000 stacji bazowych IP-DECT i 10.000 telefonów. Każda stacja bazowa IP-DECT obsługuje 8 rozmów naraz i jest wpięta bezpośrednio w sieć LAN. Można też zainstalować IP-DECT tam, gdzie nie ma sieci IP: brama IP-DECT pozwala na podłączenie 16 'tradycyjnych' stacji bazowych DECT (na kablach do 1,5 km) i razem z bazami IP-DECT tworzy jeden system. Ascom IP-DECT integruje się z niemal dowolną centralą telefoniczną, stanowiąc alternatywę dla telefonii WLAN, szczególnie tam gdzie wdrożenie WiFi sprawia problemy techniczne. Dystrybutorem systemu IP-DECT jest firma Kontel.

Rys. Schemat konfiguracji systemu alarmowo-telefonicznego IP-DECT firmy Ascom.

Źródło: Opracowane na podstawie materiałów Ascom/Kontel.


2. Struktura modułu AsAlert

Serwer modułu AsAlert

Moduły transmisji komunikatów

Konfigurator

Moduł AsAlert składa się z następujących części:

  • serwer AsAlert obsługujący podstawowe funkcje związane z wysyłaniem komunikatów i obsługą bazy danych,

  • moduły transmisji komunikatów,

  • aplikacja kliencka pozwalająca na konfigurowanie AsAlerta oraz przegląd historii zdarzeń (historii wysłanych komunikatów). Aplikacja ta będzie dalej nazywana - Konfiguratorem.

Serwer modułu AsAlert

Serwer modułu AsAlert jest serwerem Automation, w związku z czym udostępnia on interfejsy umożliwiające innym aplikacjom klienckim (w tym skryptom) realizację funkcji związanych z:

  • nadawaniem alertów,

  • konfigurowaniem AsAlerta.

Klientem może być dowolny program, który potrafi wywołać funkcje Serwera poprzez mechanizm Automation. Technologie, możliwe do wykorzystania:

  • kompilowany program EXE napisany w Visual Basic, C++, C, Delhi, itd.,

  • skrytp w języku JScript lub VBScript,

  • skrytp wbudowany w stronę ASP pozwalający na wysyłanie alertów za pośrednictwem aplikacji internetowej.

Aplikacja kliencka może korzystać ze wszystkich interfejsów udostępnianych przez serwer, jednak najczęściej są to funkcje związane z nadawaniem alertów. Szczególnym przypadkiem aplikacji klienckiej jest Konfigurator, który wykorzystuje wszystkie funkcje udostępniane przez serwer Automation.

Serwer nie posiada własnego graficznego interfejsu użytkownika poza wyświetlaniem komunikatów o błędach fatalnych (np. błędna konfiguracja). Graficzny sposób dostępu do funkcji serwera oraz jego konfigurację zapewnia w systemie Asix - Konfigurator.

Zadaniem serwera modułu AsAlert jest:

  • obsługa baz danych adresatów, komunikatów wysłanych,

  • wysyłka komunikatów.

Moduły transmisji komunikatów

Serwer AsAlert korzysta z następujących modułów transmisji komunikatów (pliki .DLL):

  • Moduł OAP,

  • Moduł SMS,

  • Modu SMTP.

Moduł OAP

Moduł OAP jest wykorzystywany przez program AsAlert do wysyłania alertów w postaci SMSów za pomocą protokołu OAP

Moduł SMS

Moduł SMS jest wykorzystywany przez program AsAlert do wysyłania alertów za pomocą modemów GSM. Alerty są wysyłane jako komunikaty SMS.

Modu SMTP

Modu SMTP jest wykorzystywany przez program AsAlert do wysyłania alertów za pomocą protokołu poczty elektronicznej SMTP.

Konfigurator

Zadaniem tego modułu jest udostępnienie graficznego interfejsu, umożliwiającego użytkownikowi konfigurację oraz podgląd pracy serwera. Konfigurator może komunikować się z serwerem lokalnym lub pracującym na zdalnej stacji.

Zadania modułu:

  • wyświetlanie ogólnych informacji o serwerze: numer wersji, ilość wysłanych komunikatów, ilość komunikatów w kolejce,

  • dostęp do bazy danych komunikatów wysłanych,

  • "ręczne" wysyłanie komunikatów,

  • konfiguracja serwera i modułów transmisji komunikatów,

  • zatrzymywanie i wznawianie pracy serwera,

  • definiowanie listy użytkowników uprawnionych do korzystania z serwera oraz haseł dostępu.


3. Konfiguracja modułu AsAlert

Do konfiguracji AsAlerta służy program AlerterCfg (Kofigurator). Program pozwala konfigurować AsAlerta pracującego na stanowisku lokalnym oraz na stacjach sieciowych. Ponadto umożliwia również:

  • wysyłkę alertów,

  • zatrzymywanie i uruchamianie modułu AsAlert,

  • podgląd zawartości bazy danych alertów oraz sortowanie i wyszukiwanie alertów.

Główne okno programu AlerterCfg zostało przedstawione na poniższym rysunku.

Rysunek: Główne okno programu AlerterCfg.

Główne menu programu Konfigurator zawiera pozycje:

  • Alerter

Połącz z... - pozwala wprowadzić nazwę stacji, która została zdefiniowana w ustawieniach sieciowych;

Uruchom - uruchamia serwer;

Zatrzymaj - zatrzymuje serwer;

Wyślij alert... - służy do edycji i wysłania wiadomości;

Zakończ - zamyka program Konfigurator;

  • Widok

Odśwież - funkcja odświeżania;

Pokaż - powoduje otwarcie okna pokazującego pełną zawartość komunikatu (bez możliwości wprowadzania zmian);

Znajdź... - pozwala zdefiniować kryterium wyszukiwania oraz znajduje pierwszy komunikat spełniający to kryterium;

Znajdź następny - wyszukuje następny komunikat spełniający kryteria wyszukiwania;

Kolumny... - pozwala zdefiniować, które pola (kolumny) komunikatów będą pokazywane w panelu komunikatów;

  • Ustawienia

Bazy danych... - pozwala zdefiniować lokalizację baz danych;

Logowanie... - logowanie do funkcji AsAlert;

Użytkownicy... - definiuje użytkowników (w tym użytkowników z uprawnieniami do konfiguracji);

Adresaci... - definiuje adresatów i grupy adresatów;

Komunikacja... - pozwala wybrać moduł transmisji komunikatów SMS i poczty elektronicznej oraz dokonać ich parametryzacji;

  • Pomoc

Dolny panel głównego okna zawiera listę komunikatów - zawartość bazy komunikatów. Komunikaty są wstępnie uporządkowane wg czasu ich wygenerowania. Kliknięcie w obszarze nagłówka danej kolumny powoduje uporządkowanie komunikatów wg zawartości tej kolumny. Wybranie z menu Widok pozycji Znajdź... pozwala zdefiniować kryterium wyszukiwania komunikatów w postaci łańcucha znaków. Wyszukiwane są komunikaty zawierające zdefiniowany łańcuch znaków w: treści, temacie, nazwie nadawcy lub w liście adresatów.

Konfiguracja obejmuje następujące zagadnienia omówione w kolejnych rozdziałach:

  1. Autoryzacja dostępu do AsAlerta.

  2. Konfiguracja baz danych:

    • konfiguracja bazy danych adresatów i bazy danych komunikatów.

  3. Parametryzacja modułów komunikacyjnych.

  4. Konfiguracja do pracy sieciowej.

5. Sprzężenie AsAlerta z systemem alarmów Asixa (dla Asixa w wersji Evo i w wersji klasycznej).


3.1. Autoryzacja dostępu do AsAlert

3.1. Autoryzacja dostępu do AsAlerta

Konfigurator uzyskuje dostęp do funkcji AsAlerta na podstawie ustawień zdefiniowanych w oknie danych autoryzacyjnych, otwieranym po wybraniu pozycji Ustawienia > Logowanie. Okno pozwala na podanie identyfikatora (nazwy) użytkownika oraz hasła. Zmiana konfiguracji AsAlerta, a także jego uruchamianie i zatrzymywanie za pomocą Konfiguratora jest możliwe tylko wtedy, gdy podany identyfikator określa użytkownika z uprawnieniami konfiguracyjnymi. Informacje autoryzacyjne można zmienić także w czasie trwania połączenia.

Dostęp do funkcji AsAlerta mają tylko zdefiniowani użytkownicy. Wyjątkiem od tej reguły jest sytuacja, gdy po zainstalowaniu modułu AsAlert nie jest jeszcze zdefiniowany żaden użytkownik - wówczas dostęp do modułu nie jest w żaden sposób ograniczony.

Do definiowania użytkowników służy okno ’Użytkownicy’, wywoływane po wybraniu opcji Ustawienia > Użytkownicy. Okno pozwala na określenie zbioru użytkowników mogących korzystać z usług AsAlerta. Ponadto umożliwia zdefiniowanie użytkowników, którzy posiadają uprawnienia do zmiany konfiguracji AsAlerta, w tym do modyfikacji danych o użytkownikach. Okno użytkowników posiada również pole przeznaczone do zdefiniowania maksymalnej ilości alertów, jaką pojedynczy użytkownik może wysłać w ciągu jednej minuty. Zerowa wartość tego ograniczenia powoduje wyłączenie kontroli częstości wysyłania alertów.

Przycisk Dodaj wywołuje okno ’Informacje o użytkowniku’, służące do definiowania użytkownika identyfikowanego po nazwie i haśle z lub bez opcji Uprawnienia do konfiguracji.

Rysunek: Okno umożliwiające określenie zbioru użytkowników mogących korzystać z usług AsAlerta. Okno definiowania użytkownika.

Okno identyfikacji użytkownika uruchamiane jest poleceniem Ustawienia > Logowanie:

Rysunek: Oko identyfikacji użytkownika.


3.2. Konfiguracja baz danych

  • Konfiguracja bazy danych adresatów i bazy danych komunikatów

  • Parametryzacja bazy danych adresatów

Konfiguracja bazy danych adresatów i bazy danych komunikatów

Serwer AsAlert pracuje w oparciu o dwie bazy danych:

  • bazę adresatów,

  • bazę komunikatów wysłanych.

Do parametryzacji baz danych służy okno 'Bazy danych alertera’, otwierane za pomocą pozycji Ustawienia/Bazy danych w menu głównym Konfiguratora. Obie bazy danych konfigurowane są w ten sam sposób. Okno selekcji baz danych zawiera pola edycyjne po jednym dla każdej bazy. Pola te powinny zawierać łańcuch połączenia do bazy danych (ang. Connection string). Do pól tych można również wprowadzić ścieżkę do pliku bazy danych Microsoft Jet lub nazwę bazy Microsoft SQL. Jeżeli wprowadzony tekst zawiera znak "\" lub "..", to jest on interpretowany jako ścieżka pliku danych bazy Microsoft Jet, w przeciwnym wypadku - jako nazwa bazy danych SQL na stanowisku lokalnym.

Rysunek: Okno parametryzacji baz danych programu AsAlert.

Obok pól edycyjnych znajdują się przyciski Wybierz. Wybranie jednego z tych przycisków powoduje otwarcie okna umożliwiającego wybór metody selekcji:

  • za pomocą pliku UDL (ang. Universal Data Link),

  • za pomocą łańcucha połączenia (ang. Connection string).

Rysunek: Okno umożliwiające wybór metody selekcji bazy danych.

Konfigurator umożliwia również tworzenie nowych baz danych. W tym celu w oknie 'Bazy danych alertera’ należy wybrać przycisk Utwórz, który uruchamia okno 'Typ bazy danych’.

Rysunek: Okno wyboru typu bazy danych.

Standardowo tworzone są bazy danych Microsoft Jet oraz SQL.

W przypadku tworzenia bazy SQL należy podać nazwę bazy danych oraz opcjonalnie nazwę stacji sieciowej, na której ma zostać utworzona. Przyciśnięcie przycisku Ustawienia zaawansowane powoduje otwarcie okna pozwalającego na pełniejszą parametryzację nowej bazy danych.

Rysunek: Okno tworzenia baz danych SQL.

Rysunek: Okno ustawień zaawansowanych parametryzowanej bazy SQL.

W celu utworzenia bazy Microsoft Jet należy podać pełną ścieżkę i nazwę nowego pliku bazy danych. Przyciśnięcie przycisku Ustawienia zaawansowane powoduje otwarcie okna pozwalającego na pełniejszą parametryzację nowej bazy danych.

Rysunek: Okno tworzenia baz danych Jet.

Rysunek: Okno ustawień zaawansowanych parametryzowanej bazy Jet.

W obu przypadkach można zaznaczyć pozycję Usuń poprzednią zawartość bazy, co spowoduje usunięcie poprzedniej bazy danych o tej samej nazwie.

Pozycja Maksymalna ilość alertów w oknie 'Bazy danych alertera’ pozwala określić maksymalną ilość zapisów w bazie danych alertów. Po przekroczeniu tej ilości, AsAlert usunie 10% najstarszych alertów. Jeśli zostanie wprowadzona wartość 0, to alerty nie będą usuwane z bazy danych.

Parametryzacja bazy danych adresatów

AsAlert wysyła alerty tylko do adresatów zawartych w bazie danych adresatów.

Istnieją trzy rodzaje adresatów:

  • osoby,

  • grupy,

  • harmonogramy.

Osoby to adresaci indywidualni posiadający swój własny adres poczty elektronicznej lub numer telefonii komórkowej.

Grupy to zbiór adresatów. Wysłanie alertu do adresata, który jest grupą, powoduje wysłanie alertów do wszystkich adresatów indywidualnych zawartych w grupie.

Harmonogram to również grupa adresatów - z tym że, alert wysyłany jest do różnych członków tej grupy w zależności od czasu wysyłki alertu. Harmonogram definiuje sekwencje odcinków czasu i powiązaną z każdym odcinkiem grupę adresatów wiadomości. Rozróżniane są dwa rodzaje harmonogramów:

  • harmonogramy cykliczne,

  • harmonogramy absolutne.

Harmonogramy cykliczne nie posiadają określonego końca ważności. Ostatnia pozycja takiego harmonogramu określa początek odcinka czasu, którego koniec określony jest przez pierwszą pozycję harmonogramu. Harmonogramy cykliczne składają się z pozycji, których czas rozpoczęcia zdefiniowany jest jedynie przez czas bez daty.

Przykład 1 parametryzacji harmonogramu cyklicznego:

Harmonogram składający się z następujących pozycji:

06:00:00 - zbiór adresatów nr 1

14:00:00 - zbiór adresatów nr 2

22:00:00 - zbiór adresatów nr 3

oznacza, że:

- alert wysłany pomiędzy godziną 6 i 14 każdego dnia zostanie wysłany do zbioru adresatów nr 1;

- alert wysłany pomiędzy godziną 14 i 22 każdego dnia zostanie wysłany do zbioru adresatów nr 2;

- alert wysłany pomiędzy godziną 22 i 6 następnego dnia zostanie wysłany do zbioru adresatów nr 3;

- itd.

Dopuszcza się przypadek, w którym pierwsza pozycja harmonogramu cyklicznego określana jest zarówno przez czas i datę. Wówczas pierwsza pozycja określa jednocześnie moment rozpoczęcia pierwszego cyklu.

Przykład 2 parametryzacji harmonogramu cyklicznego:

13-07-2003 06:00:00 - zbiór adresatów nr 1

14:00:00 - zbiór adresatów nr 2

22:00:00 - zbiór adresatów nr 3

06:00:00 - zbiór adresatów nr 4

14:00:00 - zbiór adresatów nr 5

22:00:00 - zbiór adresatów nr 6

Harmonogram absolutny zawiera pozycje określone zarówno przez datę jak i czas. Ostatnia pozycja takiego harmonogramu definiuje początek nieskończonego odcinka czasu.

Do parametryzacji baz danych służy okno adresatów. Jest ono otwierane po wybraniu pozycji Ustawienia/Adresaci w menu głównym Konfiguratora.

Rysunek: Okno do parametryzacji bazy danych adresatów.

Okno adresatów składa się z dwóch części. Po jego lewej stronie wyświetlana jest w postaci drzewa zawartość bazy adresatów. Główne "gałęzie" tego drzewa to osoby, grupy i harmonogramy. Zaznaczenie określonej osoby lub harmonogramu spowoduje, że po prawej stronie okna adresatów wyświetlane są szczegółowe informacje o wybranym adresacie.

Okno adresatów pozwala wykonać następujące zadania:

Tworzenie nowego adresata

Na drzewie adresatów należy zaznaczyć pozycję Osoby, Grupy lub Harmonogramy i przycisnąć przycisk Dodaj lub wybrać pozycję Dodaj z menu kontekstowego. Zostanie wówczas utworzony nowy adresat o nazwie odpowiednio: 'Nowa osoba', 'Nowa grupa' lub 'Nowy harmonogram' oraz włączony tryb edycji nowej nazwy. Jednocześnie po prawej stronie okna ’Adresaci’ pojawi się panel pozwalający na wprowadzanie szczegółowych informacji na temat nowego adresata (tylko dla osób i harmonogramów).

Usunięcie istniejącego adresata

Na drzewie adresatów należy zaznaczyć wybranego adresata oraz przycisnąć przycisk Usuń, wybrać pozycję Usuń z menu kontekstowego lub przycisnąć klawisz Del.

Zmiana nazwy adresata

Na drzewie adresatów należy zaznaczyć wybranego adresata oraz przycisnąć przycisk F2 lub kliknąć lewym klawiszem myszy. Zostanie wówczas uruchomiony tryb edycji nazwy. Zmianę nazwy osoby lub harmonogramu można także przeprowadzić poprzez edycję pola nazwy znajdującego się po prawej stronie okna adresatów.

Dodanie nowego członka grupy adresatów

Na drzewie adresatów należy zaznaczyć wybraną grupę, a następnie przycisnąć przycisk Dodaj lub wybrać pozycję Dodaj z menu kontekstowego. Zostanie wtedy otwarte okno pozwalające na wybór dodawanego adresata. Dodanie nowego członka grupy można również przeprowadzić poprzez przeciągniecie myszką nowego członka grupy z odpowiedniej pozycji drzewa adresatów do pozycji określonej grupy (lewy klawisz myszki). Ten sam efekt można osiągnąć wykorzystując przycisk Dodaj do grupy lub przeciągając odpowiednią pozycję grupy z drzewa adresatów (prawy klawisz myszki) w obszar pola Przynależność do grup panelu szczegółowych informacji dotyczących danego adresata indywidualnego.

Usunięcie członka grupy adresatów

Na drzewie adresatów należy zaznaczyć członka grupy i przycisnąć przycisk Usuń, wybrać pozycję Usuń z menu kontekstowego lub przycisnąć klawisz Del. To samo można wykonać w panelu informacji szczegółowych osoby po prawej stronie okna.

Edycja danych osoby

Należy wybrać osobę w drzewie adresatów. Po prawej stronie zostaną wyświetlone informacje szczegółowe na temat wybranej osoby:

  • nazwa adresata (np. nazwisko i imię),

  • adres poczty elektronicznej,

  • numer telefonu komórkowego,

  • pole wyboru określające, czy alert powinien zostać wysłany na adres poczty elektronicznej, czy jako komunikat SMS (w przypadku, gdy wysyłka może zostać zrealizowana przy wykorzystaniu obu tych metod),

  • przynależność do grup &endash; lista nazw grup, do których należy wybrana osoba.

Przycisk Dodaj do grupy spowoduje wyświetlenie okna pozwalającego na wybór grupy adresatów. To samo można wykonać przeciągając myszką wybraną grupę w drzewie adresatów i upuszczając ją na listę grup, do których należy adresat. Przeciąganie należy zrealizować za pomocą prawego klawisza myszki.

Zaznaczenie pozycji w liście grup, do których należy adresat oraz przyciśniecie przycisku Usuń z grupy lub klawisza Del spowoduje usunięcie osoby z wybranej grupy adresatów.

Edycja danych harmonogramu

Należy wybrać harmonogram na drzewie adresatów. Po prawej stronie zostaną wyświetlone informacje szczegółowe na temat wybranego harmonogramu:

  • nazwa harmonogramu,

  • lista pozycji harmonogramu.

Rysunek: Okno umożliwiające edycję danych harmonogramu.

Przycisk Dodaj służy do dodania nowej pozycji harmonogramu. To samo można uzyskać przeciągając wybranego adresata prawym klawiszem myszki w miejsce pustej pozycji harmonogramu. Upuszczenie adresata do istniejącej pozycji harmonogramu spowoduje dodanie go do grupy adresatów danego odcinka czasu.

Przycisk Usuń usuwa wybraną pozycję harmonogramu. Ten sam efekt można uzyskać klawiszem Del.

Przycisk Edycja umożliwia edycję danych wybranej pozycji harmonogramu. Okno edycji pozycji harmonogramu pozwala na określenie czasu początku odcinka czasu oraz listy adresatów związanych z tym odcinkiem czasu. Pole daty zawiera zaznaczenie decydujące o tym, czy początek odcinka czasu jest określony jedynie jako punkt doby, czy też poprzez datę i czas.


3.3. Parametryzacja modułów komunikacyjnych

Realizacja wysyłki alertów przez moduł AsAlert odbywa się przy wykorzystaniu modułów komunikacyjnych. W zależności od sposobu otrzymywania przez adresatów alertów moduły komunikacyjne dzielą się na dwa rodzaje:

  • moduły umożliwiające odbiór alertów w postaci poczty elektronicznej (email),

  • moduły umożliwiające odbiór alertów w postaci komunikatów SMS.

Do parametryzacji modułów komunikacyjnych służy okno otwierane po wybraniu pozycji Ustawienia/Komunikacja menu głównego AsAlert. Okno pozwala na wybór określonego modułu dla poczty elektronicznej oraz komunikatów SMS. Lista dostępnych modułów zależy od tego, jakie moduły zostały zainstalowane. Przycisk "..." obok wybranego modułu służy do dalszej parametryzacji modułu komunikacyjnego.

Okno ’Moduły komunikacyjne’:

Rysunek: Okno wyboru modułów komunikacyjnych do parametryzacji.

Przykładowa parametryzacja modułu SMTP do wysyłania alertów za pomocą protokołu poczty elektronicznej

1. Uruchom konfiguratora modułów komunikacyjnych:

Ustawienia > Moduły komunikacyjne...

2. Z listy modułów poczty elektronicznej wyselekcjonuj pozycję 'Moduł komunikacyjny poczty elektronicznej (SMTP)':

3. W oknie parametrów modułu SMTP określ adres serwera poczty elektronicznej, numer portu wykorzystywanego przez serwer do obsługi protokołu SMTP oraz adres i nazwę nadawcy (bez określania maksymalnego czasu oczekiwania na odpowiedź serwera SMTP oraz uwierzytelnienia użytkownika przez serwer SMTP):

Rysunek: Okno parametrów modułu SMTP.


Moduł komunikacji poczty elektronicznej

3.3.1. Moduł komunikacji poczty elektronicznej (SMTP)

Moduł SMTP jest wykorzystywany przez program AsAlert do wysyłania alertów za pomocą protokołu poczty elektronicznej SMTP.

Rysunek: Okno parametryzacji modułu wysyłania komunikatów za pomocą protokołu poczty elektronicznej SMTP.

Parametry konfiguracyjne

Serwer - parametr określa adres serwera poczty elektronicznej. Adres ten należy uzyskać od dostawcy usług internetowych lub od administratora sieci lokalnej.

Port - parametr określa numer portu wykorzystywany przez serwer do obsługi protokołu SMTP. Jeśli parametr jest pominięty, przyjmowana jest wartość 25. Wartość parametru należy uzyskać od dostawcy usług internetowych lub od administratora sieci lokalnej.

Nazwa nadawcy - dowolny tekst określający nadawcę alertu. Jeśli pole jest pominięte, to nazwa nadawcy będzie taka sama jak Adres nadawcy (chyba że w oknie edycyjnym do wysyłania alertów zdefiniowana zostanie inna nazwa nadawcy).

Adres nadawcy - adres pocztowy email nadawcy alertu.

Timeout - maksymalny czas oczekiwania na odpowiedź serwera SMTP. Podanie wartości 0 spowoduje nieograniczony okres oczekiwania na odpowiedź.

Serwer wymaga uwierzytelnienia - w przypadku gdy serwer SMTP wymaga uwierzytelnienia użytkownika konta, należy opcję załączyć i wpisać nazwę i hasło użytkownika konta.


Moduł komunikacji OAP

3.3.2. Moduł komunikacji OAP

Moduł OAP jest wykorzystywany przez program AsAlert do wysyłania alertów za pomocą protokołów dla urządzeń Ascom:

- protokołu OAP (1 wariant);

- lub dedykowanego protokołu firmy Kontel (2 wariant).

Szczegóły na temat komunikacji z urzadzeniami firmy Ascom znajduja się w rozdziale

1.1 Współpraca AsAlert z systemem alarmowo-telefonicznym firmy Ascom.

Rysunek: Okno parametryzacji modułu wysyłania komunikatów za pomocą protokołu OAP/Kontel.

Parametry konfiguracyjne

Serwer - parametr określa adres serwera modułu OAP.

Port - parametr określa numer portu wykorzystywany przez serwer do obsługi protokołu OAP.

Użyj protokołu OAP - parametr załącza wykorzystanie protokołu OAP do wysyłania alertów; gdy opcja nie jest zaznaczona, użyty zostanie dedykowany urządzeniom Ascom protokół firmy Kontel.


Moduł komunikacji SMS (GSM)

3.3.3. Moduł komunikacji SMS (GSM)

Moduł komunikacji SMS jest wykorzystywany przez program AsAlert do wysyłania alertów za pomocą modemów GSM.

Rysunek: Okno parametryzacji modułu wysyłania komunikatów za pomocą modemów GSM.

Parametry konfiguracyjne

Port szeregowy - parametr definiuje port szeregowy, do którego przyłączony jest modem GSM. Można podać numer portu lub pełną nazwę portu szeregowego np. '2" lub "COM2". Jest to jedyny obowiązkowy parametr modułu komunikacji GSM.

Szybkość - parametr określa szybkość komunikacji z modemem GSM w bitach na sekundę.

Bity danych - parametr określa długość słowa danych w czasie komunikacji z modemem GSM.

Parzystość - parametr określa typ kontroli parzystości.

Bity stopu - parametr określa ilość bitów stopu.

Numer Centrum SMS - numer telefoniczny Centrum Wiadomości SMS wykorzystywany do wysyłania wiadomości SMS. Numer ten uzyskuje się od operatora sieci GSM. Parametr można pominąć, jeśli jest on zawarty w konfiguracji sprzętowej modemu GSM. Jeśli jako modem GSM jest wykorzystywany telefon komórkowy, to zazwyczaj jest on już odpowiednio skonfigurowany.

Zawartość komunikatu SMS - parametr określa sposób tworzenia tekstu komunikatu SMS na podstawie zawartości alertu. Tekst komunikatu SMS może składać się z tematu alertu, jego treści lub obu tych elementów.

Maksymalna długość SMS - parametr określa maksymalną długość komunikatu SMS. Jeśli długość ta jest przekroczona, to nadmiarowe znaki są odrzucane.

Dodatkowe polecenia inicjalizujące - parametr określa dodatkowe polecenia (komendy AT), które zostaną wysłane do modemu GSM w chwili jego inicjalizacji. Łańcuch określający dodatkowe komendy nie powinien rozpoczynać się od znaków AT.


3.4. Konfiguracja do pracy sieciowej

AsAlert jest serwerem COM (ang. Component Object Model) i aby był możliwy dostęp do jego funkcji z odległych stacji, należy odpowiednio skonfigurować "usługi składowe" systemu operacyjnego. Sposób uruchamiania konfiguratora usług składowych zależy od systemu operacyjnego, zazwyczaj jednak wystarczy uruchomić program dcomcnfg.exe. Po jego uruchomieniu należy odszukać i otworzyć pozycję Alerter application, po czym skonfigurować tożsamość serwera AsAlert. Zaleca się wybrać pozycję Ten użytkownik i odpowiednie konto użytkownika, pod jakim będzie uruchamiany AsAlert. Należy przy tym pamiętać, że AsAlert musi posiadać uprawnienia administracyjne. Po ustaleniu tożsamości, stosownie do potrzeb należy skonfigurować uprawnienia uruchamiania i uprawnienia dostępu. Jeśli wbudowany w AsAlert mechanizm kontroli dostępu w oparciu o zdefiniowanych użytkowników (Patrz: Autoryzacja dostępu do Alertera ) jest wystarczający, uprawnienia do uruchamiania i dostępu do funkcji AsAlert można przypisać do grupy użytkowników Wszyscy.


4. Uruchamianie i zatrzymanie

4. Uruchamianie i zatrzymanie AsAlerta

W celu uruchomienia AsAlerta wybrać pozycję Alerter > Uruchom menu głównego Konfiguratora. Uruchomienie jest możliwe tylko w przypadku poprawnej parametryzacji AsAlerta:

  • musi być poprawnie zdefiniowana baza danych alertów,

  • musi być poprawnie zdefiniowana baza danych adresatów oraz musi ona zawierać przynajmniej jednego adresata,

  • musi być zdefiniowany oraz poprawnie skonfigurowany przynajmniej jeden moduł komunikacyjny.

W celu zatrzymania AsAlerta należy wybrać pozycję Alerter > Zatrzymaj menu głównego Konfiguratora.


5. Wysyłanie alertów

Wybranie pozycji Alerter > Wyślij alert... powoduje otwarcie okna pozwalającego na wysłanie alertu. Adresaci wybierani są za pomocą okna selekcji adresatów otwieranego przyciskiem Adresaci.

Rysunek: Okno umożliwiające wysyłanie alertu.

Wysłany alert pojawia się na liście komunikatów okna 'Alerter’ Konfiguratora.

Rysunek: Lista wysłanych alertów w oknie 'Alerter’ Konfiguratora.

W przypadku sprzężenia systemu wysyłania alertów z systemem alarmów Asixa, alerty wysyłane są automatycznie w momencie wykrycia alarmu, dla którego ustawione zostało żądanie wysłania powiadomienia.


6. Przeglądanie wysłanych alertów

Dolną część głównego okna Konfiguratora zajmuje lista wysłanych alertów.

Rysunek: AsAlert - lista wysłanych alertów.

Zakres wyświetlanych informacji można zmienić za pomocą pozycji Widok > Kolumny... menu głównego, która uruchamia okno 'Widoczne pola alertu'.

Rysunek: Okno definiujące zakres wyświetlanych informacji.

Pozycja Widok > Znajdź... służy do wyszukania pierwszego alertu zawierającego określony ciąg znaków. Pozycja Widok/Znajdź następny powoduje wyszukanie kolejnego alertu spełniającego kryterium wyszukiwania.

Rysunek: Okno do wyszukiwania pierwszego alertu zawierającego określony ciąg znaków.

Pozycja Widok > Pokaż powoduje otwarcie okna pokazującego szczegóły dotyczące alertu - w tym informacje o błędach, które wystąpiły w trakcie wysyłki alertu. Pozycja ta jest aktywna tylko wtedy, gdy na liście alertów jest wybrany jakiś element. To samo można uzyskać klikając podwójnie myszką na wybranym alercie.

Rysunek: Okno informacyjne na temat alerta.


7. Sprzężenie AsAlerta z systemem alarmów asixa

7. Sprzężenie AsAlerta z systemem alarmów Asix.Evo

Program AsAlert może współpracować z systemem alarmów Asix.Evo, co pozwala na automatyczne wysyłanie alertów w reakcji na wykrycie zmiany stanu wybranych alarmów. Parametryzacja sprzęgu wykonywana jest dwustopniowo w programie AsixEvo.exe. W pierwszym kroku deklarowane są podstawowe parametry komunikacyjne. Służy do tego pokazany poniżej fragment zakładki Ustawienia.

powiększ >>

Rysunek: Konfiguracja sprzęgu AsAlert - AsixEvo. Okno AsixEvo.exe > Ustawienia systemu alarmów.

Rysunek: AsixEvo.exe > ustawienia AsAlerta.

Znaczenie parametrów jest następujące:

Stanowisko

Określenie stanowiska aplikacji Asix.Evo, które będzie inicjowało wysłanie powiadomienia. Może to być nazwa dowolnego stanowiska uczestniczącego w pracy domeny. Można też wybrać opcję, w której powiadomienia wysyła zawsze aktywny kontroler. Właściwy wybór zależy od konfiguracji systemu. W każdym przypadku stanowisko powinno być włączone przez cały czas. Dlatego zazwyczaj alerty wysyłane są ze stanowisk kontrolerów. Jeżeli AsAlert jest zainstalowany na komputerze jednego z kontrolerów, to z reguły powiadomienia powinno wysyłać to stanowisko. W przeciwnym wypadku z reguły lepsza jest opcja aktywnego kontrolera.

Lokalizacja

Systemowa nazwa komputera, na którym zainstalowany jest program AsAlert. W przypadku korzystania z lokalnej instalacji należy parametr pozostawić pusty.

Użytkownik

Nazwa użytkownika programu AsAlert na konto, którego będą wysyłane powiadomienia.

Hasło

Hasło użytkownika programu AsAlert na konto, którego będą wysyłane powiadomienia.

Nazwa źródła

Dowolny tekst, który w wysłanym alercie zostanie użyty jako nadawca wiadomości.

Nagłówek

Dowolny tekst, który w wysłanym alercie zostanie użyty jako tytuł wiadomości.

Drugim krokiem w parametryzacji sprzęgu jest odpowiednie zdefiniowanie atrybutów TrybAlertów i Adresaci Alertów w definicji każdego alarmu, dla którego mają być wysyłane alerty. Tryb alertów pozwala wybrać - kiedy alerty są wysyłane: możliwe jest wysyłanie w momentach początku i/lub końcu alarmu. W atrybucie AdresaciAlertów należy podać nazwy adresatów zdefiniowanych w programie AsAlert, do których powiadomienie ma być wysłane.


AsAlert_Asix_klasyczny

8. Sprzężenie AsAlerta z systemem alarmów klasycznej wersji Asixa

Program AsAlert może współpracować z systemem alarmów klasycznej wersji Asix, co pozwala na automatyczne wysyłanie alertów w reakcji na wykrycie zmiany stanu wybranych alarmów. Szczegóły dotyczące parametryzacji sprzęgu omówiono w kolejnych rozdziałach.


7.1. Format alertu

8.1. Format alertu

Każdy wysyłany alert składa się z nagłówka(tytułu) i treści. Nagłówek ma następującą postać:

Alert nazwa_źródła

Zawartość pola nazwa_źródła jest podawana przez projektanta w pliku konfiguracyjnym sprzęgu.

Treść alertu ma następującą postać:

rodzaj_zdarzenia data_czas tekst_alarmu

Pole rodzaj_zdarzenia jest tekstem Start lub Koniec w zależności od stanu alarmu, który spowodował wysłanie alertu. Pole data_czas zawiera czas zdarzenia alarmowego. Pole tekst_alarmu zawiera treść komunikatu alarmowego, która jest identyczna z tekstem alarmu w aplikacji Asixa.


7.2. Parametryzacja sprzęgu

8.2. Parametryzacja sprzęgu

Włączenie modułu sprzęgu wymaga zadeklarowania opcji AsAlert w programie Architekt:

Architekt > System alarmów > zakładka Sygnalizacja / Alerty:

opcja AsAlert - należy opcję załączyć i zadeklarować nazwę pliku konfigurującego sprzęg pomiędzy AsAlertem i Asixem

Sprzęg jest uruchamiany tylko w trybie operatorskim systemu alarmów.

Plik konfiguracyjny sprzęgu tworzony jest w formacie XML za pomocą konfiguratora pakietu Asix (patrz: 8.3. Program konfiguracyjny) i określa wszystkie parametry pracy. Struktura pliku jest następująca:

<?xml version="1.0"?>

<asixalerts name="nazwa"
 host="xxxx" user="xxxx" password="xxxx"
 trace="yes" inifile="plik_ini">

<on>

<alarm>numery_alarmów</alarm>

<group>identyfikatory_grup</group>

<addressee>nazwy_adresatów</addressee>

</on>

<off>

&ldots;.

</off>

<onoff>

&ldots;.

</onoff>

</asixalerts>

Atrybuty węzła asixalerts mają następujące znaczenie:

name - służy do podania nazwy źródła pochodzenia alertów. Nazwa jest przesyłana w nagłówku każdego alertu.

host - nazwa komputera, na którym zainstalowany jest AsAlert. Brak parametru oznacza uruchomienie AsAlerta na komputerze lokalnym.

user - nazwa użytkownika AsAlerta, pod którego kątem będzie pracował moduł sprzęgu.

password - hasło użytkownika AsAlerta.

trace - jeżeli atrybut jest użyty i jest równy tekstowi yes, to do pliku logu Asixa wysyłane są dodatkowe komunikaty rejestrujące pracę modułu sprzęgu.

inifile - nazwa pliku konfiguracyjnego aplikacji Asixa, atrybut używany jest wyłącznie przez program konfiguracyjny.

Węzły on, off i onoff służą do definiowania grup alertów rozsyłanych w reakcji na zdarzenie - odpowiednio: pojawienia, zaniku, pojawienia i zaniku alarmu. Węzły mogą wystąpić wielokrotnie.

Węzeł alarm służy do podania numerów kontrolowanych alarmów. Mogą to być oddzielone przecinkami numery alarmów lub zakresy od-do alarmów.

Węzeł group służy do podania nazw grup kontrolowanych alarmów. Należy podać oddzielone przecinkami identyfikatory grup alarmów z aplikacji Asixa.

Można jednocześnie stosować wybór alarmów przez grupy i numery.

Węzeł addresses służy do podania nazw adresatów, do których należy wysłać alert. Jest to lista oddzielonych przecinkiem nazw adresatów, grup adresatów lub nazw harmonogramów zdefiniowanych w bazie AsAlerta.

Monitorowane są zmiany pliku konfiguracyjnego. Jeżeli plik zostanie zmieniony, moduł sprzęgu podlega automatycznemu przekonfigurowaniu. Nie są uwzględniane tylko parametry host, user i password, których zmiana wymaga restartowania aplikacji.


7.3. Program konfiguracyjny

8.3. Program konfiguracyjny

Plik konfiguracyjny sprzęgu może być tworzony przy pomocy interaktywnego programu AsixAlertConfig. Poniżej pokazane jest główne okno tego programu.

Konfigurator dostępny jest z poziomu menu Start > Programy > Asix > Konfigurator alertów

Rysunek: Okno główne programu AsixAlertConfig.

Znaczenie parametrów w sekcji Parametry ogólne jest następujące:

Plik inicjacyjny aplikacji - parametr ma znaczenie tylko dla pracy programu konfiguracyjnego. Pozwala on określenie nazw grup alarmów i tekstów alarmów używanych w aplikacji Asixa. Informacje te są używane w innych oknach programu konfiguracyjnego.

Nazwa źródła alertów - informacyjny tekst wysyłany w nagłówku każdego alertu, identyfikujący źródło alertu.

Lokalizacja Alertera - nazwa komputera, na którym jest zainstalowany AsAlert. Puste pole oznacza korzystanie z AsAlert zainstalowanego na lokalnym komputerze.

Nazwa użytkownika i Hasło - nazwa i hasło użytkownika zdefiniowanego w bazie AsAlert, na którego konto będą wykonywane wszystkie operacje modułu sprzęgającego.

Włączone śledzenie - ustawienie tej opcji powoduje, że będzie wykonywana rozszerzona diagnostyka pracy modułu sprzęgającego.

Poniżej sekcji Parametry ogólne znajduje się lista kontrolowanych alarmów. Poszczególne kolumny mają następujące znaczenie:

Tryb - określa typ kontrolowanego zdarzenia. Możliwe jest wysyłanie alertu w momencie wykrycia alarmu, jego zaniku lub obu tych zdarzeń.

Numery - podaje numery kontrolowanych alarmów.

Grupy - podaje nazwy grup kontrolowanych alarmów. Użycie nazwy grupy powoduje, że alert jest rozsyłany dla każdego alarmu należącego do grupy. Informacje z kolumn Numery i Grupy są stosowane jako suma logiczna.

Adresaci - nazwy adresatów zdefiniowanych w bazie AsAlert, do których należy wysłać alert.

Operacje dodawania, modyfikowania i usuwania pozycji z listy alertów wykonywane są poprzez polecenia z menu Alert lub menu kontekstowego. Dodanie lub modyfikacja linii na liście alertów powoduje otwarcie kolejno okien: 'Wybierz nazwę komputera', a następnie 'Parametry alertu'.

Rysunek: Okno 'Wybierz nazwę alertu'.

Rysunek: Okno ’Parametry alertu’.

W oknie 'Wybierz nazwę komputera' należy wskazać nazwę stacji (zdefiniowanej w pliku konfiguracyjnym aplikacji asixa w kategorii 'Obszary i komputery'), na której uruchomiona jest aplikacja Asixa z załączonym sprzęgiem z modułem AsAlert.

W grupie opcji Tryb i polach edycyjnych okna 'Parametry alertu' należy wprowadzić parametry alertów. W przypadku pól edycyjnych można skorzystać ze skojarzonych okien dialogowych, które pozwalają interakcyjnie określić parametry alertu poprzez wybór z list obiektów zdefiniowanych w aplikacji Asixa lub bazie AsAlert.

Dla działania wspomnianych okien konieczne jest określenie nazwy pliku konfiguracyjnego aplikacji Asixa i parametrów dostępu do AsAlert.


7.4. Wysyłanie alertów sprzężonych z systemem alarmów asixa

8.4. Wysyłanie alertów sprzężonych

Przykład konfiguracji mechanizmu wysyłania alertów w odpowiedzi na zmiany stanu alarmów systemu Asix

Konfiguracja dotyczy sprzężenia modułu AsAlert z systemem alarmów testowej aplikacji Fabryka (standardowo dołączanej do pakietu Asix) dla stacji operatorskiej o nazwie 'StacjaSO1'. Zarówno aplikacja jak i AsAlert zainstalowane zostały na tym samym komputerze. Alerty przewidziano jako wiadomości rozsyłane pocztą elektroniczną. Poniższy przykład zrealizowano na wersji 6 Asixa.

1. W pierwszej kolejności skonfiguruj moduł AsAlert, definiując użytkowników modułu AsAlert, bazę danych alertów i adresatów oraz ustawienia modułu komunikacyjnego, za pomocą którego będą rozsyłane alerty:

1a. Użytkownicy

Wybierz konfigurator modułu AsAlert > menu Ustawienia > polecenie Uzytkownicy...

W oknie 'Użytkownicy' dodaj użytkownika:

Nazwa: Operator1 (z uprawnieniami do konfiguracji)

Hasło: askom

Rysunek: Konfiguracja użytkownika modułu AsAlert.

1b. Baza danych alertów

Wybierz konfigurator modułu AsAlert > menu Ustawienia > polecenie Bazy danych...

W oknie 'Bazy danych alertera' utwórz bazy danych dla alertów (typ bazy danych: Microsoft SQL):

- kliknij przycisk Utwórz;

- wybierz typ bazy: Microsoft SQL;

- w oknie 'Baza danych SQL' zdefiniuj parametry bazy:

Nazwa bazy danych: BazaAlertow1

Nazwa serwera: <nazwa komputera, na którym zainstalowany jest AsAlert>

Rysunek: Konfiguracja bazy danych alertów.

1c. Baza danych adresatów

Wybierz konfigurator modułu AsAlert > menu Ustawienia > polecenie Bazy danych...

W oknie 'Bazy danych alertera' utwórz bazy danych dla adresatów (typ bazy danych: Microsoft SQL):

- kliknij przycisk Utwórz;

- wybierz typ bazy: Microsoft SQL;

- w oknie 'Baza danych SQL' zdefiniuj parametry bazy:

Nazwa bazy danych: BazaAdresatowAlertow1

Nazwa serwera: <nazwa komputera, na którym zainstalowany jest AsAlert>

Rysunek: Konfiguracja bazy danych adresatów.

1d. Adresat alertów

Wybierz konfigurator modułu AsAlert > menu Ustawienia > polecenie Adresaci...

W oknie 'Adresaci' dodaj nowego adresata:

Nazwa: Rozdzielnia1

E-mail: <dla przykładu wpisz swój adres e-mailowy>

Rysunek: Konfiguracja adresata alertów.

1e. Ustawienia modułu komunikacyjnego

Wybierz konfigurator modułu AsAlert > menu Ustawienia > polecenie Moduły komunikacyjne...

W oknie 'Moduły komunikacyjne' skonfiguruj moduł komunikacyjny poczty elektronicznej [SMTP]:

- w polu Moduł poczty elektronicznej wybierz pozycję 'Moduł komunikacyjny poczty elektronicznej [SMTP]';

- w oknie parametrów modułu SMTP uruchamianym przyciskiem '...' zdefiniuj następujące parametry konta e-mailowego, które wykorzystywane będzie do rozsyłania alertów (dla przykładu wpisz parametry swojego konta e-mailowego):

Serwer: <adres serwera poczty wychodzącej (SMTP)>

Port: <numer portu serwera wychodzącego (SMTP)>

Nazwa nadawcy: Operator1

Adres nadawcy: <adres pocztowy email nadawcy alertu>

Jeśli serwer poczty wychodzącej wymaga uwierzytelnienia, należy podać nazwę i hasło użytkownika konta.

Rysunek: Konfiguracja modułu komunikacyjnego.

1e. Test konfiguracji modułu AsAlert

Uruchom moduł AsAlert. W tym celu wybierz polecenie Start z menu Alerter konfiguratora.

Zaloguj sie jako użytkownik 'Operator1':

- z menu Ustawienia wybierz polecenie Logowanie... i zaloguj się zgodnie z utworzoną przez siebie nazwą i hasłem użytkownika;

Nazwa: Operator1

Hasło: askom

Wyślij testowego alerta do użytkownika 'Rozdzielnia1';

- z menu Alerter wybierz polecenie Wyślij alert...;

- w oknie edycyjnym alerta wybierz z bazy nazwę adresata 'Rozdzielnia1', wpisz temat i treść alertu (np. test); w polu Nadawca automatycznie powinien pojawić się 'Operator1' - zgodnie z ustawieniami modułu komunikacyjnego;

- klinik przycisk Wyślij;

Sprawdź w swojej skrzynce mailowej, czy otrzymałeś maila od nadawcy Operator1. Jeśli tak, oznacza to, że moduł AsAlert został prawidłowo skonfigurowany.

2. W kolejnym kroku skonfiguruj sprzęg pomiędzy modułem AsAlert a systemem alarmów aplikacji (w przykładzie jest to testowa aplikacja Fabryka):

Uruchom konfigurator sprzegu AsAlert - Alarmy.

Skonfiguruj połączenie, deklarując w odpowiednich polach następujące parametry:

- Plik inicjalizacyjny aplikacji: C:\Asix\Aplikacje\Fabryka\Fabryka.xml (podaj swoją ścieżkę instalacyjną do pakietu Asix);

- Nazwa źródła alertów: FabrykaDemo; jeżeli w tym miejscu nie podasz żadnej nazwy - jako nadawca wiadomości (alertu) będzie podawana nazwa nadawcy zadeklarowanego w module komunikacyjnym wykorzystywanym do rozsyłania alertów;

- Lokalizacja Alertera: (pozostaw pole puste - domyślnie oznaczać to będzie korzystanie z AsAlert zainstalowanego na lokalnym komputerze);

- Nazwa użytkownika: Operator1 Hasło: askom

- Zapisz konfigurację w pliku o nazwie asalert_sprzeg.XML w katalogu aplikacji Fabryka, używając polecenia Zapisz jako... z menu Plik.

Rysunek: Konfiguracja sprzęgu AsAlert - Alarmy.

3. Zadeklaruj sprzęg z modułem AsAlert w pliku konfiguracyjnym aplikacji:

Uruchom program Architekt z załadowanym plikiem konfiguracyjnym aplikacji Fabryka.

Przejdź do wariantu aplikacji dla stacji 'StacjaSO1':

- kliknij na pozycję 'Stacja_SO1' w polu Obszary i komputery okna Architekt.

W kategorii parametrów System alarmów, na zakładce Sygnalizacja / Alerty załącz opcję AsAlert z podaniem nazwy pliku konfigurującego sprzęg asalert_sprzeg.xml, utworzonego w poprzednim punkcie.

Zapisz zmiany w pliku konfiguracyjnym aplikacji.

Rysunek: Dołączenie sprzęgu AsAlert- Aalrmy do parametrów konfigurujących pracę aplikacji.

4. Zdefiniuj alert:

Uruchom konfigurator sprzegu AsAlert - Alarmy. Otwórz plik konfigurujący sprzęg AsAlert - alarmy 'asalert_sprzeg.xml'.

Wybierz polecenie Dodaj... z menu Alert.

W oknie 'Wybierz nazwę komputera' wybierz nazwę zestawu parametrów aplikacji Fabryka, przewidzianego dla komputera 'StacjaSO1' - nazwa 'Stacja_SO1' z pola Obszary i komputery programu Architekt. Zatwierdź wybór przyciskiem OK.

Rysunek: Wybór komputera, którego aplikacja sprzężona została z modułem AsAlert.

W oknie 'Parametry alertu' zdefiniuj następujące parametry:

- Tryb: Start i Koniec;

- Numery: 217;

- Adresaci: 'Rozdzielnia1'.

- Kliknij przycisk OK.

Zapisz wprowadzone zmiany za pomocą polecenia Zapisz w menu Plik.

Rysunek: Parametry alertu sprzężonego z systemem alarmów aplikacji asix.

5. Przetestuj wysyłanie alertów w odpowiedzi na zamianę stanu alarmu sprzężonego z modułem AsAlert:

Uruchom moduł AsAlert i zaloguj się jako użytkownik 'Operator1':

- w tym celu wybierz polecenie Start z menu Alerter konfiguratora modułu AsAlert.

- z menu Ustawienia wybierz polecenie Logowanie... i zaloguj się zgodnie z utworzoną przez siebie nazwą i hasłem użytkownika;

Nazwa: Operator1

Hasło: askom

Uruchom aplikację Fabryka dla stacji 'StacjaSO1':

- uruchom Architekta;

- otwórz plik Fabryka.xml;

- kliknij na pozycję 'Stacja_SO1' w polu Obszary i komputery;

- uruchom aplikację poleceniem Uruchom system Asix z menu Plik.

Wygeneruj alarm 217:

- w tym celu kliknij na przycisk 'GENERACJA ALARMU ZA POMOCĄ SKRYPTU', znajdujący się na głównej masce aplikacji Fabryka. Po chwili wyłącz alarm poniższym przyciskiem 'Kasowanie'.

Sprawdź w swojej skrzynce mailowej, czy otrzymałeś 2 maile od nadawcy 'FabrykaDemo': jeden informujący o załączeniu alarmu, drugi- o dezaktywacji alarmu. Jeśli tak, oznacza to, że system wysyłania alertów sprzężony z systemem alarmów Asixa działa prawidłowo.

Rysunek: Alerty w postaci e-maili.


8.1. AsAlert jako system Automation

9.1. AsAlert jako system Automation

AsAlert jest serwerem Automation i udostępnia interfejs pozwalający innym aplikacjom, w tym skryptom, na wysyłkę Alertów. Poniżej podano przykład skryptu w języku VBScript realizującego wysyłkę alertu do adresata o nazwie AKP:

Dim Alerter, Alert

Set Alerter = CreateObject("Alerter.Alerter")

Alerter.User = "Kocioł"

Set Alert = Alerter.NewAlert

Alert.To = "AKP"

Alert.Subject = "Przekroczona maksymalna wartość temperatury"

Alert.Body = "Temperatura wynosi 120 stopni"

Alerter.Send Alert

Należy pamiętać, że realizacja funkcji AsAlerta może powodować generację wyjątków (błędów) np.: "brak autoryzacji", "niekompletna postać alertu", itp. Do obsługi tych sytuacji należy wykorzystać stosowne mechanizmy użytego języka programowania (np. instrukcja On error i obiekt Err języka VBScript).


8.2. Obiekt Alerter

9.2. Obiekt Alerter

Podstawowym udostępnianym obiektem Automation jest obiekt Alerter o identyfikatorze programowym Alerter.Alerter. Przed użyciem metod i własności tego obiektu należy podać nazwę i hasło użytkownika (ustawienie własności User oraz Password stosownie do parametryzacji AsAlerta - patrz: Autoryzacja dostępu do AsAlerta). Poniżej podano własności oraz metody obiektu Alerter.

Authorized - własność posiada wartość True, gdy własności User oraz Password zostały poprawnie ustawione oraz wartość False w przeciwnym wypadku. (Tylko do odczytu).

MajorVersion - własność posiada wartość równą głównemu składnikowi numeru wersji AsAlert. (Tylko do odczytu).

MinorVersion - własność posiada wartość równą pomocniczemu składnikowi numeru wersji AsAlert. (Tylko do odczytu).

NewAlert - metoda powoduje utworzenie i zwrócenie obiektu Alert. Metoda nie wymaga podania żadnych parametrów.

Password - własność - hasło dostępu do AsAlert dla użytkownika określonego własnością User. (Odczyt/zapis).

Send - metoda powoduje weryfikację uprawnień użytkownika oraz poprawności alertu, a następnie zainicjowanie wysyłki alertu. Parametrem tej metody jest obiekt Alert zwrócony przez metodę NewAlert. Pomyślne zakończenie wywołania tej metody nie oznacza fizycznego wysłania alertu, a jedynie zainicjowanie procesu wysyłki.

User - własność - nazwa użytkownika. (Odczyt/zapis).


8.3. Obiekt alert

9.3. Obiekt alert

Obiekt Alert zwracany jest przez metodę NewAlert obiektu Alerter. Reprezentuje on pojedynczy alert. Obiekt posiada następujące własności i metody.

Body - wartością własności jest tekst stanowiący treść alertu. Treść alertu może składać się z wielu linii. Poszczególne linie należy oddzielać znakiem o kodzie 13 (w kodzie dziesiętnym). Np.:"Temperatura wody = 150" & Chr(13) & "Temperatura powietrza=90".(Odczyt/zapis).

From - wartością własności jest tekst określający nadawcę Alertu. (Odczyt/zapis).

Subject - wartością alertu jest tekst określający temat alertu. (Odczyt/zapis).

To - własność określająca adresatów alertu. Wartością własności jest tekst zawierający nazwy poszczególnych adresatów oddzielone średnikami. Można podawać tylko nazwy adresatów występujące w bazie danych adresatów. (Odczyt/zapis).