Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 7

www.asix.com.pl

AsPortal -

Wizualizacja i nadzór nad realizacją procesów przemysłowych z wykorzystaniem przeglądarki internetowej

Dok. Nr PLH7023

Wersja: 2013-09-16


AsPortal - Portal Informacji Procesowych

1. AsPortal - Portal Informacji Procesowych

Portal danych procesowych umożliwia przeglądanie wszystkich danych procesowych tj. bazy definicji zmiennych aplikacji, wartości bieżących i archiwalnych pomiarów, archiwum alarmów historycznych oraz listę alarmów aktywnych w postaci tabelarycznej oraz danych historycznych w postaci wykresów. Portal jest aplikacją uniwersalną i aby ją podłączyć do dowolnej aplikacji systemu A six, wystarczy skonfigurować ścieżkę do bazy definicji zmiennych.

Webowy Portal Informacji Procesowych, będący gotową do natychmiastowego użycia uniwersalną aplikacją pozwalającą przeglądać w Internecie dane procesowe z dowolnej aplikacji systemu Asix, jest również dostępny na urządzeniach mobilnych tablet lub smartphone, pracujących pod kontrolą systemów: Android, iOS lub Linux.

Rysunek: Strona główna programu AsPortal wyświetlona na komputerze.

Rysunek: Strona główna programu AsPortal wyświetlona na tablecie.


Konfiguracja

1.1 Konfiguracja

Proces konfigurowania aplikacji AsPortal realizowany jest w systemie A six przez Konfigurator aplikacji AsPortal, wbudowany w moduł Architekt. Konfigurator automatycznie tworzy kanał AsixConnect, parametryzuje plik Web.Config i nadaje prawa dostępu do katalogu bazy definicji zmiennych oraz umożliwia ustawienie dostępu do przeglądania i modyfikowania wartości zmiennych (Patrz: Architekt – podręcznik użytkownika, rozdz. 4.19. Konfigurator aplikacji AsPortal).


Konfigurator aplikacji AsPortal

1.1.1 Konfigurator aplikacji AsPortal

Wbudowany w program Architekt - konfigurator aplikacji AsPortal pozwala łatwo uruchomić portal informacji procesowych zaprojektowanej aplikacji.

Konfigurator aplikacji AsPortal uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsPortal

Obsługa Konfiguratora sprowadza się do użycia przycisków: Konfiguruj, Ustaw oraz Uruchom AsPortal.

1. Przycisk Konfiguruj na zakładce Konfiguracja serwera tworzy kanał AsixConnect, parametryzuje plik Web.Config, nadaje prawa dostępu do katalogu bazy definicji zmiennych. Aby komenda zadziała, należy w pierwszej kolejności zainstalować moduł Asix4Internt z instalatora pakietu A six.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

2. Kilka przycisków Ustaw umożliwiających konfigurację dostępu do aplikacji znajduje się na zakładkach Ustawienia dostępu:

- aplikację można skonfigurować w taki sposób, aby dostęp do niej był anonimowy lub oparty o uwierzytelnianie systemu Windows.

- dla aplikacji AsPortal oznacza to możliwość ustawienia:

a) dostępu do przeglądania wartości zmiennych

lub

b) dostępu do modyfikowania wartości zmiennych.

Uwierzytelnianie systemu Windows

Aby ustanowić dostęp do przeglądania wartości zmiennych, należy ustawić dla aplikacji AsPortal uwierzytelnianie systemu Windows (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu > opcja Uwierzytelnianie Windows).

Rys. Ustawienie funkcji uwierzytelniania systemu Windows dla aplikacji AsPortal.

UWAGA: Załączenie mechanizmu uwierzytelniania dla AsPortala wymaga uprzedniego załączenia funkcji systemu Windows: 'Uwierzytelnianie Windows'.

Rys. Załączenie funkcji uwierzytelniania Windows.

Rys. Funkcja uwierzytelniania systemu Windows dla aplikacji AsPortal.

Ustawienie dostępu do przeglądania wartości zmiennych

Ustanowienie dostępu do przeglądania/modyfikowania wartości zmiennych wymaga ustawienia dla aplikacji AsPortal uwierzytelniania systemu Windows (patrz wyżej), a w bazie definicji zmiennych dodania atrybutu Grupa uprawnień odczytu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienOdczytu). Następnie dla każdej zmiennej należy podać w bazie definicji zmiennych, jako wartość atrybutu Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do przeglądania wartości zmiennej.

UWAGA:

Pozostawienie pustego pola dla atrybutu Grupa uprawnień odczytu dla danej zmiennej będzie oznaczać, że zmienna ta będzie niewidoczna dla wszystkich użytkowników.

PRZYKŁAD

Rys. Nadanie grupie użytkowników 'TEST' uprawnienia odczytu zmiennej 'A046'.

Rys. AsPortal - dostęp do zmiennej 'A046' przez użytkownika z grupy 'TEST'.

Ustawienie dostępu do modyfikowania wartości zmiennych

Aby ustanowić dostęp do modyfikowania wartości zmiennych, należy:

- ustawić uwierzytelnianie systemu Windows dla aplikacji AsPortal (patrz powyżej),

- załączyć funkcję modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Funkcja modyfikowania wartości zmiennych jest dostępna),

- zadeklarować nazwę grupy użytkowników systemu Windows, którzy będą mieć uprawnienie do modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Nazwa grupy uprawnionych użytkowników).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, ale NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości zmiennych - to wszyscy mają dostęp do modyfikacji zmiennych.

Dostęp do modyfikowania wartości zmiennych można dodatkowo zawęzić umieszczając w bazie definicji zmiennych atrybut Grupa uprawnień zapisu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienZapisu), a następnie wpisując grupę użytkowników podaną w polu Nazwa grupy uprawionych użytkowników bezpośrednio do pola atrybutu Grupa uprawnień zapisu tylko dla tych zmiennych, które mają być dostępne do modyfikacji dla danej grupy użytkowników (pozostałych zmiennych nie będzie można modyfikować).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, a w bazie definicji zmiennych zostanie dodany atrybut Grupa uprawnień zapisu, ale dla poszczególnych zmiennych w polu atrybutu Grupa uprawnień zapisu NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości tych zmiennych - to nikt nie będzie mieć prawa do modyfikowania zmiennych.

UWAGA:

Jeśli oprócz pola Nazwa grupy uprawionych użytkowników i/lub atrybutu Grupa uprawnień zapisu w bazie definicji zmiennych zostanie zadeklarowany atrybut Grupa uprawnień odczytu - użytkownik będzie miał możliwość modyfikowania wartości zmiennej pod warunkiem, że będzie należał do grupy użytkowników uprawnionych do zapisu wartości zmiennej oraz do grupy użytkowników uprawnionych do odczytu wartości danej zmiennej.

Rys. Deklaracja dostępu do odczytu i zapisu zmiennych w bazie definicji zmiennych.

Rys. Dostęp do zapisu zmiennej w AsPortal.

3. Przycisk Uruchom AsPortal na zakładce Klient - pozwala uruchomić AsPortal z dostępem do danych procesowych pracującej aplikacji

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsPortal

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsPortal


Plik konfiguracyjny Web.config

1.1.2 Plik konfiguracyjny Web.config

AsPortal używa pliku konfiguracyjnego o nazwie Web.Config do:

1. przechowywania domyślnej nazwy kanału (jako zbioru opcji konfiguracyjnych serwerów pakietu AsixConnect, opcji połączeń z serwerem systemu Asix i opcji bazy definicji zmiennych);

2. do definiowania listy wyświetlanych na stronach AsPortala atrybutów zmiennych;

3. do deklarowania połączeń z programami: AsTrend, AsAlarm, serwerem raportów MS SQL Reporting Services i aplikacjami systemu Asix w wersji WWW.

Plik Web.Config znajduje się w katalogu c:\AsixApp\AsPortal. Sposób definiowania kanałów opisany jest w dokumentacji pakietu AsixConnect.

ad.1

Domyślną nazwę kanału definiują atrybuty key i value. Atrybut key ma nadaną wartość „DefaultChannelName”. Drugiemu atrybutowi value należy nadać wartość będącą nazwą kanału (nazwę kanału należy ująć w cudzysłowy).

PRZYKŁAD

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="DefaultChannelName" value="AsEmis" />
</appSettings>

Przy definiowaniu kanału należy włączyć opcje Zmienna kontrolna i Limity zmiennych.

ad.2

AsPortal umożliwia zdefiniowanie listy wyświetlanych atrybutów osobno dla danych bieżących, archiwalnych oraz bazy definicji zmiennych i okna wyboru zmiennych. W tym celu należy podać listy atrybutów w odpowiednich pozycjach pliku Web.config:

CTTableAttributesList – atrybuty w oknie danych bieżących,

HTTableAttributesList – atrybuty w oknie danych archiwalnych prezentowanych w postaci tabeli,

HTTableLegendList – atrybuty wyświetlane w legendzie na stronie wydruku tabeli danych archiwalnych,

HTTableHeaderList – atrybuty wyświetlane w nagłówkach tabeli zawierającej wartości archiwalne,

HTChartsAttributesList – atrybuty w oknie danych archiwalnych prezentowanych w postaci wykresu,

HTChartsLegendList – atrybuty wyświetlane w legendzie na stronie wydruku wykresu danych archiwalnych,

CurrentDataAttributesList – atrybuty wyświetlane w oknie wyboru zmiennych oraz w bazie zmiennych.

Istnieją dwa specjalne nazwy atrybutów. W przypadku danych bieżących jest nią ValueCV, która oznacza bieżącą wartość pomiarów. W oknach danych historycznych szczególną nazwą atrybutu jest Aggregate oznaczająca kolumnę agregatów.

W pakiecie A six istnieje możliwość skonfigurowania listy wyświetlanych atrybutów (wraz z liczbą wierszy na stronie) za pomocą Edytora wyglądu aplikacji AsPortal, wbudowanego w program Architekt. (Patrz: Konfigurator wyglądu aplikacji AsPortal).

PRZYKŁAD

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<appSettings>

<add key = "CurrentDataAttributesList" value = "Nazwa,Opis,Jednostka,NazwaAKPiA" />

<add key = "CTTableAttributesList" value = "Nazwa,NazwaAKPiA,Opis,ValueCV,Jednostka " />

<add key = "HTTableAttributesList" value = "Nazwa, Aggregate, Opis"/>

<add key = "HTChartsAttributesList" value = "Nazwa, Aggregate, ZakresPomiarowyLo " />

</appSettings>

W pliku Web.config można ustawić liczbę wierszy na stronie raportów. Określa to pozycja ReportsPagiSize.

PRZYKŁAD

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<appSettings>

<add key = "ReportsPageSize" value = "0" />

</appSettings>

ad.3

Deklaracja połączeń z programami: AsTrend, AsAlarm, serwerem raportów MS SQL Reporting Services i maskami aplikacji systemu Asix w wersji WWW wymaga podania wartości następujących atrybutów:

key="AsixWwwUrl" value="/Fabryka_WWW"/ - adres aplikacji systemu Asix w wersji WWW

key="AsTrendUrl" value="/AsTrend"/ - adres internetowej wersji programu AsTrend

key="AsAlarmUrl" value="/AsAlarmNet"/ - adres internetowej wersji programu AsAlarm

key="ReportServerUrl" value="ReportServer_SQLEXPRESS"/ - adres serwera raportów środowiska raportowego MS SQL Reporting Services

Zadeklarowania pustego tekstu dla atrybutu value oznacza blokadę dostępu do danego programu.

W przypadku zadeklarowania pustego tekstu dla atrybutu value dla wszystkich programów, zostanie zablokowane wyświetlanie strony 'Aplikacje'.

PRZYKŁAD

<?xml version="1.0"?>

<configuration>

<appSettings>

<add key="AsixWwwUrl" value="/Fabryka_WWW"/>

<add key="AsTrendUrl" value="/AsTrend"/>

<add key="AsAlarmUrl" value="/AsAlarmNet"/>

<add key="ReportServerUrl" value="ReportServer_SQLEXPRESS"/>

</appSettings>


Konfigurator wyglądu aplikacji AsPortal

1.1.3 Konfigurator wyglądu aplikacji AsPortal

Zakres wyświetlanych informacji na temat zmiennych procesowych można określić wykorzystując Edytor wyglądu aplikacji AsPortal dostępny w programie Architekt, uruchamiany poleceniem:

menu Aplikacje > Konfiguruj wygląd aplikacji AsPortal

Edytor pozwala określić listę atrybutów wyświetlanych:

- w tabeli danych bieżących (zakładka Dane bieżące);

- w tabeli zmiennych, w nagłówkach tabeli wynikowej, w legendzie na stronie wydruku - dla danych prezentowanych w formie tabelarycznej (zakładka Dane archiwalne - tabela);

- w tabeli zmiennych, w legendzie na stronie wydruku - dla danych prezentowanych w postaci wykresów (zakładka Dane archiwalne - wykres).

Dodatkowo, zakładka Aplikacje umożliwia skonfigurowanie adresów aplikacji internetowych, które można uruchamiać z poziomu portalu AsPortal.


Pliki definicji raportów

1.1.4 Pliki definicji raportów

Na stronie raportów znajduje się drzewo służące do grupowania raportów (dotyczy raportów tworzonych przy użyciu ASTEL/ASTER oraz raportów skryptowych). Elementy drzewa tworzone są na podstawie analizy nagłówków informacyjnych plików definicji raportów, utworzonych w danej aplikacji. Aby raporty były prawidłowo grupowane, należy dodać do plików definicji raportów następujący wiersz (nagłówek informacyjny):

znak_komentarza REPORT_INFO=GROUP:Wartosc1; PERIOD:Wartosc2

gdzie:

GROUP – nazwa grupy raportów (odpowiada węzłom drzewa);

PERIOD – długość okresu czasu generowania raportu (odpowiada „liściom” drzewa). Dostępne wartości to:

  • D - dzień

  • W - tydzień

  • M - miesiąc

  • Q - kwartał

  • Y - rok

  • O – inny

PRZYKŁAD

Poniżej fragment kodu raportu z definicją nagłówka.

/ REPORT_INFO = GROUP:Zduny; PERIOD:D

PRZYKŁAD

Poniżej fragment kodu raportu z definicją nagłówka.

Rysunek: Fragment kodu raportu z definicją nagłówka.


Udostępnienie aplikacji na serwerze WWW

1.1.5 Udostępnienie aplikacji na serwerze WWW

Aby udostępnić aplikację, należy wykonać następujące kroki:

  • utworzyć nową aplikację, podając jako alias nazwę - AsPortal, jako ścieżka fizyczna - katalog c:\AsixApp\AsPortal i jako pula aplikacji - Askom (pula używająca .NET 2.0 i mająca włączoną obsługę aplikacji 32-bitowych).

  • jeżeli użytkownicy aplikacji nie mają skonfigurowanego prawa logowania do serwera Windows, to należy w opcjach uwierzytelniania aplikacji włączyć dostęp anonimowy.

Po wykonaniu powyższych kroków aplikacja jest dostępna lokalnie po wpisaniu w przeglądarce IE adresu:

http://localhost/AsPortal

Aplikacja jest dostępna w sieci lokalnej pod adresem

http://<nazwa komputera w systemie Windows>/AsPortal

PRZYKŁAD

Na przykład dla komputera o nazwie AsixWeb adresem aplikacji jest:

http://AsixWeb/AsPortal


Przełączenia widoku aplikacji AsPortal

1.2.1. Przełączenie widoku aplikacji AsPortal

Menu górne daje użytkownikowi możliwość wyboru języka UI aplikacji oraz układu strony (wersja dedykowana komputerom lub wersja dla tabletów/smartphonów).

Pozycje w menu:

  • Pomoc online;

  • Mapa witryny;

  • asix.com.pl - przełączenie na witrynę systemu Asix;

  • Wygląd - wybór dostępnych szablonów wyglądu portalu;

  • Ustawienia - wybór języka i układu strony.


Dane bieżące

1.2.2 Dane bieżące

Okno danych bieżących służy do prezentacji atrybutów i wartość bieżących zmiennych systemu A six. Dane bieżące prezentowane są w postaci tabeli. Kolumna zawierająca aktualne wartości zmiennych jest formatowana w zależności od jakości pomiaru.

Dla jakości dobrej:

  • przy przekroczonym limicie ostrzegawczym wartość wyświetlana jest czerwoną czcionką,

  • przy przekroczonym limicie alarmowym wartość wyświetlana jest czerwoną czcionką na żółtym tle.

Dla jakości złej:

  • wartość wyświetlana jest białą czcionką na czerwonym tle,

  • w przypadku wykrycia uszkodzenia czujnika w miejscu wartości wyświetlane jest ”??",

  • w przypadku błędu komunikacji, wyświetlana jest ostatnia znana wartość ze znakiem ”?",

  • w pozostałych przypadkach wyświetlany jest znak ”?".

Dostępne operacje, jakie można wykonać w tym oknie to:

  • Dodaj – otwiera okno wyboru nowych zmiennych (szerzej opisane w punkcie 1.2.7 Okno wyboru zmiennych);

  • Usuń wszystkie – usuwa zmienne;

  • Odśwież – pobiera aktualne wartości zmiennych i wyświetla je na ekranie;

  • Odświeżaj stale - uruchamia mechanizm automatycznego odświeżania danych;

  • Drukuj / Eksportuj - drukowanie wartości zmiennych; eksport danych do pliku formatu: pdf, xls, xlsx, rtf, mht, text, csv, image;

  • wymiana zmiennej - kliknięcie na nazwę zmiennej otwiera okno wyboru zmiennych, nowo wybrana zmienna wstawiana jest w miejsce starej;

  • Usuń - link umieszczony po prawej stronie rekordu zmiennej usuwa rekord danej zmiennej z tabeli;

  • zmiana wartości zmiennej (pod warunkiem, że ustawiony został dostęp do zmiany wartości zmiennych - patrz szczegóły: 1.1.3. Konfigurator aplikacji AsPortal) - kliknięcie na wartość zmiennej umożliwia wprowadzenie nowej wartości.

Rysunek: AsPortal - widok danych bieżących.


Dane archiwalne

1.2.3 Dane archiwalne - tabela

Okna danych archiwalnych pozwalają na prezentacje historycznych wartości pomiarów w postaci tabeli lub wykresu.

Aby wyświetlić dane archiwalne w postaci tabeli, należy ustawić następujące pola określające okres czytania danych:

Data / Godzina / Długość / Interwał.

Przyciski w menu mają następujące funkcje:

„<<" – przesunięcie czasu o długość okresu w tył,

„>>" – przesunięcie czasu o długość okresu w przód

„>|" – ustawienie koniec wykresu na chwile bieżącą.

Dostępne operacje, jakie można wykonać w oknie danych archiwalnych to:

  • Dodaj – otwiera okno wyboru nowych zmiennych (szerzej opisane w punkcie 1.2.7 Okno wyboru zmiennych),

  • Usuń wszystkie – usuwa wszystkie zmienne,

  • Pokaż dane - powoduje wyświetlenie danych w postaci tabeli,

  • Drukuj/ eksportuj - powoduje wyświetlenie danych w postaci przeznaczonej do wydruku lub eksportu do wybranego formatu pliku (np. PDF, Csv).

  • Usuń – usuwa zmienną,

  • wymiana zmiennej - kliknięcie na nazwę zmiennej otwiera okno wyboru zmiennych, nowo wybrana zmienna wstawiana jest w miejsce starej.

Dane archiwalne prezentowane w postaci tabeli

Rysunek: AsPortal - dane archiwalne w postaci tabeli.

Rysunek: AsPortal - widok danych archiwalnych w postaci tabelarycznej do wydruku.


Wykresy

1.2.4. Dane archiwalne - wykres

Aby wyświetlić dane archiwalne w postaci wykresu, należy ustawić następujące pola określające okres czytania danych:

Wykres / Data / Godzina / Długość / Interwał.

Przyciski w menu mają następujące funkcje:

„<<" – przesunięcie czasu o długość okresu w tył,

„>>" – przesunięcie czasu o długość okresu w przód

„>|" – ustawienie koniec wykresu na chwile bieżącą.

Dostępne operacje, jakie można wykonać w oknie danych archiwalnych to:

  • Dodaj – otwiera okno wyboru nowych zmiennych (szerzej opisane w punkcie 1.2.7 Okno wyboru zmiennych),

  • Usuń wszystkie – usuwa wszystkie zmienne,

  • Pokaż wykres – zastosowanie wprowadzonych zmian i wyświetlenie tabeli/wykresu,

  • Drukuj/ Eksportuj - powoduje wyświetlenie danych w postaci przeznaczonej do wydruku lub eksportu do wybranego formatu pliku (np. PDF, Csv)

  • Usuń – usuwa zmienną,

  • wymiana zmiennej - kliknięcie na nazwę zmiennej otwiera okno wyboru zmiennych, nowo wybrana zmienna wstawiana jest w miejsce starej.

Dane archiwalne prezentowane w postaci wykresu

Ustawienie interwału agregowania na wartość auto powoduje automatyczne ustawienie jego wartości na 1/360 długości okresu wyświetlania. Jeżeli okres archiwizacji danej zmiennej jest większy niż wyliczona wartość interwału, to wartość interwału dla zmiennej jest zwiększana do okresu archiwizacji.

Rysunek: AsPortal - dane archiwalne w postaci wykresu.


Alarmy

1.2.5 Alarmy

Aplikacja umożliwia prezentację bieżących alarmów występujących w systemie, oraz przeglądanie alarmów historycznych. Tekst alarmu wyświetlany jest w kolorze zależnym od typu alarmu:

Systemowy

Komunikat

Ostrzeżenie

Alarm

Ważny alarm

Istnieje możliwość filtrowania wyświetlanych alarmów. Po naciśnięciu przycisku Filtr rozwijane jest okno z dostępnymi opcjami filtrowania. Można filtrować alarmy ze względu na typ, status, grupę oraz zawarty tekst.

Naciśnięcie przycisku Odśwież powoduje odświeżenie danych.

Drukuj/Eksportuj - powoduje wyświetlenie danych w postaci przeznaczonej do wydruku lub eksportu do wybranego formatu pliku (np. PDF, Csv).

W oknie alarmów historycznych należy ustawić horyzont wyświetlania danych (czas początkowy oraz długość okresu).

Poniższe rysunki prezentują okna alarmów – odpowiednio alarmów aktywnych z włączoną opcją filtrów oraz alarmów historycznych.

Rysunek: AsPortal - podgląd alarmów aktywnych.

Rysunek: AsPortal - podgląd alarmów historycznych.


Baza zmiennych

1.2.6 Baza definicji zmiennych

Baza definicji zmiennych umożliwia przeglądanie wszystkich zmiennych systemu A six.

Rysunek: AsPortal - widok bazy definicji zmiennych.


Okno wyboru zmiennych

1.2.7 Okno wyboru zmiennych

W oknie wyboru zmiennych wszystkie dostępne zmienne podzielone są na grupy. Możliwe jest wybranie wielu zmiennych z różnych grup.

Rysunek: AsPortal - okno wyboru zmiennych.


Raporty

1.2.8 Raporty

Portal pozwala na dostęp w sposób interaktywny do raportów wygenerowanych w aplikacji systemu A six (uwaga: dotyczy raportów klasycznych systemu Asix). Po otworzeniu strony widoczne jest drzewo grup raportów oraz tabela ze szczegółowymi informacjami.

Rysunek: AsPortal - zestawienie raportów.

Aby wyszukać żądane raporty, należy wybrać odpowiednią pozycję z drzewa grup raportów oraz ustawić następujące opcje filtrowania:

Przedział czasowy z którego pochodzą raporty

Zaznaczenie pola powoduje, że w przypadku gdy istnieje kilka raportów z danego okresu, wyświetlany będzie tylko najbardziej aktualny (ostatni) raport.

Dostępne operacje w oknie raportów:

  • Filtrowanie wg pól tabeli wyświetlającej zestawienie raportów;

  • Drukuj – po wybraniu raportu (wyświetleniu podglądu) możliwe jest otworzenie nowego okna z raportem gotowym do wydruku;

  • Wybierz – ( [image]) wyświetlenie podglądu danego raportu.

Rysunek: AsPortal - podgląd wybranego raportu.


Projekty

1.2.9 Projekty

Aplikacja AsPortal umożliwia tworzenie projektów danych bieżących, archiwalnych oraz alarmów. W ramach projektu przechowywane są informacje o wybranych zmiennych (alarmach). Dla danych archiwalnych pamiętane są dodatkowo agregaty, interwał agregowania, przedział czasu oraz w przypadku wykresu jego typ.

Do obsługi projektów służy menu znajdujące się w lewej części ekranu:

Rysunek: Widok menu projektów.

Polecenia menu projektów mają następujące działanie:

Nowy – utworzenie nowego (pustego) projektu,

Zapisz – zapisanie zmian w projekcie,

Zapisz jako – zapisanie projektu pod wybraną nazwą,

Usuń – usunięcie projektu,

Ustaw jako startowy – ustawienie startowego projektu, który będzie ładowany automatycznie po otworzeniu strony.


Aplikacje

12.10. Aplikacje

Strona Aplikacje zawiera łącza do kolejnych wyspecjalizowanych aplikacji internetowych: AsTrend, AsAlarm, serwera raportów MS SQL Reporting Services i masek aplikacji systemu Asix w wersji WWW.

Rys. Strona z łączami do wyspecjalizowanych aplikacji internetowych systemu Asix.