Witamy

Home > Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 8

www.asix.com.pl

Asix.Klasyczny

Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji

Architekt - Parametryzacja aplikacji

Dok. Nr PLH8001

Wersja: 2016-07-11


Wstęp

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 1. Wstęp

1. Wstęp

Podstawę systemu Asix stanowi moduł AS. W trakcie pracy systemu Asix w trybie konstrukcyjnym program AS przybiera postać okna Konstruktora i udostępnia zestaw komend i obiektów służących do projektowania aplikacji. Konstruktor pozwala zaprojektować, sparametryzować okna aplikacji i uruchomić aplikację. W momencie startu programu AS w trybie wykonania aplikacji automatycznie aktywowane jest okno Panelu Kontrolnego. Jest to centralne okno aplikacji, które udostępnia zestaw komend służących do kontroli pracy aplikacji oraz pokazuje i przechowuje komunikaty dotyczące wewnętrznej pracy systemu Asix.


2. System pomocy i podpowiedzi

System pomocy dla pakietu Asix obejmuje pliki *.chm odpowiadające poszczególnym modułom pakietu.

Podstawą systemu pomocy jest plik Asix.Klasyczny.chm.

Okno pliku pomocy zawiera trzy zakładki o nazwach: 'Spis treści', ’Indeks’ i ’Szukaj’.

Zakładka 'Spis treści' umożliwia przeglądanie wszystkich tematów dokumentacji.

Rysunek: Asix - plik pomocy.

Okno ’Indeks’ zawiera listę słów kluczowych.

Rysunek: Asix plik pomocy - zakładka ’Indeks’.

Okno ’Szukaj’ umożliwia wyszukanie dowolnego tekstu w dokumentacji.

Rysunek: Asix plik pomocy - zakładka ’Szukaj’.


3.1. Wymagania sprzętowe i programowe

Dla prawidłowego działania system wizualizacji Asix powinien być uruchomiony w środowisku jednego z następujących systemów operacyjnych Microsoft: Microsoft Windows 7 SP1, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows Server 2008R2 SP1, Microsoft Windows Server 2012 (użycie którejś z wcześniejszych wersji systemu Windows nie gwarantuje uzyskania pełnej funkcjonalności produktu) na sprzęcie spełniającym wymagania zainstalowanego systemu operacyjnego. Dla działania oprogramowania pakietu Asix wymagana jest instalacja platformy Microsoft .NET Framework 4.5 Full. Uruchomienie aplikacji w trybie przeglądarkowym wymaga przeglądarki Internet Explorer w wersji 8 lub nowszej lub przeglądarek Firefox, Opera, Chrome z dodatkiem IE Tab.

W przypadku użycia funkcji pakietuAsix, które wymagają zastosowania bazy danych typu SQL wymagana jest instalacja darmowej wersji MS SQL Express 2008 / 2012 / 2014 (dla baz danych do 10GB) lub pełnych serwerów Microsoft SQL Server 2008 R2, Microsoft SQL Server 2012 lub Microsoft SQL Server 2014.


3.3. Uruchomienie

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 3. Instalacja i konfiguracja systemu Asix > 3.2. Uruchomienie

3.2. Uruchomienie

Uruchamianie Asixa w poszczególnych trybach sprowadza się do kliknięcia na wcześniej utworzonej ikonie skrótu do aplikacji.

Aby utworzyć skrót do Konstruktora, należy w oknie Właściwości/skrót/Element docelowy wybrać z kartoteki instalacyjnej program AS32.exe z pełną ścieżką dostępu. W polu Rozpocznij w: wpisujemy roboczą kartotekę aplikacji.

Aby ze skrótu uruchomić aplikację, należy jako parametr wywołania AS32.exe podać nazwę pliku konfiguracyjnego aplikacji *.xml.

Rysunek: Ustawienia skrótu uruchamiającego aplikację systemu Asix.

PRZYKŁAD parametryzacji skrótu:

kartoteka instalacyjna - c:\Asix

kartoteka robocza - c:\Asix\Aplikacje\Wytwornia_Kwasu

plik inicjujący - Wytwornia Kwasu.xml

Patrz też: Architekt > Uruchomienie aplikacji > Jak utworzyć ikonę skrótu uruchamiającą aplikację systemu Asix?


3.4. Deinstalacja

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 3. Instalacja i konfiguracja systemu Asix > 3.3. Deinstalacja

3.3. Deinstalacja

Deinstalację systemu Asix można wykonać dwojako:

  • wywołując program deinstalacyjny z okna Panelu Sterowania (program Dodaj/Usuń.Programy);

  • przy pomocy ponownego uruchomienia instalatora pakietu Asix - zostanie uruchomione okno ’Konserwacja aplikacji’ z opcją Usuń, która powoduje odinstalowanie składników pakietu Asix.


4. Metodyka tworzenia aplikacji

W rozdziale tym opisane zostaną ogólnie kolejne kroki tworzenia aplikacji w systemie Asix. W trakcie realizacji rzeczywistego projektu na pewno nie uda się ściśle zachować przedstawionej sekwencji operacji. W miarę rozbudowywania aplikacji wielokrotnie trzeba będzie wracać do wcześniejszych punktów w celu uzupełnienia parametryzacji. Zapoznanie się z poniższymi punktami pozwoli jednak na zorientowanie się w całokształcie procesu tworzenia aplikacji.

W systemie Asix można wyróżnić pewne samodzielne moduły, które wykonują operacje wspomagające działanie głównej części systemu. Moduły są zrealizowane jako biblioteki DLL i są automatycznie startowane w zależności od potrzeb. Są to:

  • Asmen - Menedżer Komunikacyjny Asmen odpowiada za przesył danych między komputerem, na którym został uruchomiony, a sterownikami obsługującymi kontrolowany proces.

  • Aspad - Moduł Archiwizacji Danych. Zadaniem Aspada jest zapamiętywanie danych dotyczących kontrolowanego procesu w długoterminowych archiwach.

  • Aslink - Moduł Sieciowy Aslink jest używany w instalacjach sieciowych Asixa. Odpowiada on za wymianę informacji pomiędzy poszczególnymi stanowiskami systemu. Wymaga obecności oprogramowania realizującego usługi NETBIOSa (dalej nazywanego emulatorem NETBIOS).

Omawiana metodyka projektowania i realizacji aplikacji obejmuje następujące punkty, które zostaną opisane w kolejnych podrozdziałach:

  1. Zdefiniowanie danych procesowych Asmena.

  2. Zdefiniowanie danych archiwizowanych.

  3. Tworzenie pliku konfiguracyjnego aplikacji.

  4. Tworzenie bazy definicji zmiennych.

  5. Tworzenie masek wizualizacyjnych.

  6. Określenie sposobu obsługi aplikacji.

  7. Zdefiniowanie parametrów pracy aplikacji.

  8. Uruchomienie aplikacji.

  9. Instalacje sieciowe.


4.1. Zdefiniowanie danych procesowych Asmena

Pierwszą operacją, od której należy zacząć projekt aplikacji - jest określenie zestawu danych procesowych, na podstawie których aplikacja będzie realizowana. Wszystkie dane służące do wizualizacji stanu procesu przemysłowego są odczytywane przy pomocy programu Asmen. Należy więc odpowiednio sparametryzować ten moduł. Dwa podstawowe elementy tej parametryzacji to:

  • określenie kanałów transmisyjnych służących do odczytu i zapisu danych procesowych, co wiąże się z określeniem środków sprzętowych służących do zapewnienia połączenia ze źródłem danych;

  • zdefiniowanie zmiennych procesowych: ich adresów, częstości odświeżania, sposobu przeliczania itd.

Parametryzacja Asmena odbywa się poprzez zdefiniowanie kanałów komunikacyjnych w pliku konfiguracyjnym oraz utworzenie bazy z definicjami zmiennych procesowych, do których będziemy się odwoływać w procesie tworzenia aplikacji.

Obecnie zaleca się przygotowanie danych o zmiennych procesowych przy użyciu narzędzi takich jak arkusz kalkulacyjny lub baza danych i następnie wygenerowanie z tych danych bazy definicji zmiennych systemu Asix. Możliwe jest również generowanie bazy definicji zmiennych z danych znajdujących się w pliku tekstowym.

Do generacji Bazy Definicji Zmiennych służy program Architekt. Użycie arkusza Excel pozwala na przygotowanie pełnego zestawu danych (nazywanych atrybutami) o zmiennych procesowych takich jak: Nazwa, Opis, Symbol, Symbol KKS, jednostka, ZakresPomiarowy, Dane montażowe itp.

Aktualnie zaleca się przechowywanie definicji zmiennych w bazie typy SQL lub Jet (Access) lub bezpośrednio w arkuszach kalkulacyjnych Excel (na etapie projektowania aplikacji).

Operacja, którą trzeba koniecznie wykonać, to określenie nazw logicznych wszystkich używanych zmiennych procesowych. Nazwy te są potrzebne do tworzenia diagramów wizualizacyjnych.

Patrz: Architekt > Konfiguracja parametrów danych bieżących > Definicja kanałów komunikacyjnych

Patrz: Architekt > cały rozdział Obsluga baz definicji zmiennych aplikacji systemu Asix

Patrz: Architekt > Załącznik 1. Lista atrybutów systemowych Bazy Definicji Zmiennych definiujących zmienne procesowe

Patrz: Deklarowanie zmiennych procesowych


4.2. Zdefiniowanie danych archiwizowanych

Kolejnym krokiem jest zdefiniowanie zmiennych procesowych, które mają być archiwizowane. Zmienne te są potrzebne do liczenia raportów oraz do prezentacji przebiegu wartości zmiennych na wykresach i trendach. Wszystkie dane archiwizowane są obsługiwane przez moduł Aspad. Parametryzacja Aspada polega na określeniu zestawu zmiennych procesowych Asmena, które mają być archiwizowane oraz podaniu okresu ich archiwizacji. Parametryzacja zmiennych przeznaczonych do archiwizacji umieszczona jest w Bazie Definicji Zmiennych. Dodatkowo należy w pliku konfiguracyjnym aplikacji zdefiniować ogólne parametry pracy programu Aspad.

Patrz: Aspad - Program Archiwizacji Danych

Patrz: Architekt > cały rozdział Obsluga baz definicji zmiennych aplikacji systemu Asix

Patrz: Architekt > Załącznik 1. Lista atrybutów systemowych Bazy Definicji Zmiennych definiujących zmienne procesowe

Patrz: Parametry archiwizacji zmiennych


4.3. Tworzenie pliku konfiguracyjnego aplikacji

Podstawą działania aplikacji jest plik konfiguracyjny w formacie XML (ang. Extensible Markup Language), opisujący zarówno dane dotyczące bazy definicji zmiennych, jak i wartości parametrów określajacych pracę aplikacji.

Utworzenie pliku konfiguracyjnego projektowanej aplikacji stanowi zatem krok poprzedzający etap konfigurowania bazy definicji zmiennych oraz konfigurowania aplikacji.

Jeśli baza definicji zmiennych przygotowywana jest w arkuszu kalkulacyjnym Excel, z którego następnie generowana będzie baza w formacie MSSQL lub Jet - utworzenie pliku konfiguracyjnego aplikacji należy poprzedzić przygotowaniem definicji zmiennych w arkuszu Excel.

Patrz: Architekt > Generowanie bazy definicji zmiennych z arkusza Excel

Patrz: Architekt > Praca ze skoroszytem Excel jako źródłem danych o atrybutach zmiennych bez generowania bazy definicji zmiennych

Patrz: Architekt > Przygotowanie zewnętrznego źródła danych - arkusz Excel

Patrz: Architekt > Szablon bazy definicji zmiennych (w pliku Excel)

Patrz: Architekt > Utworzenie pliku konfiguracyjnego nowej aplikacji


4.4. Tworzenie bazy definicji zmiennych

W systemie wizualizacji Asix dane bazy definicji zmiennych mogą być przechowywane w bazie Jet, MSSQL, bezpośrednio w plikach Excel, lub w formatach wykorzystywanych w starszych wersjach Asixa (w plikach tekstowych).

W systemie Asix definicje zmiennych mogą być pobierane z bazy danych typu Paradox lub plików tekstowych ze względu na kompatybilność z wcześniejszymi wersjami systemu. Stosowanie wspomnianych formatów przechowywania definicji zmiennych nie jest jednak aktualnie zalecane.

Przygotowanie bazy definicji zmiennych w arkuszu kalkulacyjnym jest wygodne na etapie projektowania aplikacji. Dane przechowywane w arkuszach są czytelne i łatwe do edycji.

Obsługa bazy definicji zmiennych - w tym, tworzenie i edytowanie jej struktury i zawartości odbywa się przy użyciu programu Architekt. Dane definicji zmiennych przechowywane na etapie projektowania aplikacji w arkuszach Excel stanowią źródło do wygenerowania bazy definicji zmiennych w formacie MSSQL lub Jet, w oparciu o którą docelowo będzie pracowała aplikacja.

Patrz: Architekt > cały rozdział Obsługa baz definicji zmiennych aplikacji systemu Asix


4.5. Tworzenie masek wizualizacyjnych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 4. Metodyka tworzenia aplikacji > 4.5. Tworzenie diagramów wizualizacyjnych

4.5. Tworzenie diagramów wizualizacyjnych

W chwili, gdy zdefiniowane zostało przynajmniej nazewnictwo zmiennych procesowych i archiwizowanych, można przejść do projektowania części wizualizacyjnej aplikacji. W tym celu należy wystartować program AS32 w trybie Konstruktora. W systemie Windows XP / 2000 / NT 4.0 należy w tym celu utworzyć skrót do programu AS32.exe ( [image] Patrz: 3.2. Uruchomienie), podając jako parametr plik konfiguracyjny aplikacji. (Plik konfiguracyjny tworzony jest za pomocą programu Architekt - [image] patrz: Architekt > Utworzenie pliku konfiguracyjnego nowej aplikacji).

Drugi sposób na uruchomienie aplikacji w trybie Konstruktora wymaga użycia komendy Uruchom system Asix - konstruktor z poziomu Architekta:

Architekt > menu Aplikacja > Uruchom system Asix - konstruktor (przy otwartym pliku konfiguracyjnym XML uruchamianej aplikacji)

Zestaw diagramów (nazywanych tez maskami) wizualizacyjnych stanowi zasadniczą część każdej aplikacji. Diagramy służą do graficznego przedstawienia stanu kontrolowanego procesu przemysłowego. Projektowanie pojedynczego diagramu składa się generalnie z dwóch etapów:

  • zdefiniowania parametrów ogólnych, takich jak: rozmiar, położenie, sposób aktywizacji;

  • dołączenie do diagramu obiektów wizualizacyjnych, które w różnorodny sposób pokazują stan procesu, ewentualnie pozwalają na wykonywanie operacji sterujących.

Projektowanie diagramów jest główną czynnością wykonywaną na etapie tworzenia aplikacji.


4.6. Określenie sposobu obsługi aplikacji

Oprócz utworzenia diagramów wizualizacyjnych, bardzo istotnym elementem aplikacji jest zapewnienie jej właściwej struktury logicznej. Sprowadza się to do określenia sposobów przechodzenia między diagramami. Program AS ze swojej strony zapewnia pewne standardowe mechanizmy przełączania diagramów, które jednak należy traktować jako jedynie pomocnicze.

Projektant może wpływać na sposób obsługi aplikacji poprzez udostępnianie operatorowi tak zwanych akcji operatorskich. Pośród wielu typów akcji, najważniejsze na tym etapie projektowania są akcje otwarcia i zamknięcia diagramów. Projektant musi zdefiniować dwa elementy:

  • pełną treść akcji,

  • sposób wykonania akcji.

Na etapie realizacji, akcje mogą być wykonywane poprzez kliknięcie myszką w odpowiednim miejscu diagramu lub przyciśnięcie odpowiedniej kombinacji klawiszy na klawiaturze. Pierwszy sposób wywołania wymaga od operatora umieszczenia na diagramie obiektów klasy PRZYCISK z odpowiednio zdefiniowanymi akcjami. Drugi sposób jest parametryzowany dwoma metodami. Jeżeli akcja już jest zdefiniowana w obiekcie PRZYCISK, to można jej jednocześnie przyporządkować alternatywną kombinację klawiszy (w definicji obiektu). Drugą metodą wywołań przy pomocy klawiatury jest użycie zestawów klawiszy. Są to elementy aplikacji, których parametryzacja polega na podaniu listy różnych kombinacji klawiszy wraz z odpowiadającymi im akcjami operatorskimi. Tak przygotowane zestawy mogą być dołączane do diagramów. Charakterystyczną cechą użycia klawiszy (w obu wariantach) jest to, że wybrane kombinacje są aktywne przez cały czas obecności diagramów (do których są dołączone) na ekranie. Nie ma znaczenia, który diagram jest aktywny.

Kolejnym elementem, który należy zdefiniować - jest określenie stanu początkowego, to znaczy diagramów, które mają być otwarte na starcie aplikacji. Odbywa się to poprzez zadeklarowanie nazw diagramów poprzez program Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Maski otwierane > opcja Maski otwierane


4.7. Zdefiniowanie parametrów pracy aplikacji

Ostatnim krokiem wymaganym do pełnego opisania aplikacji jest zdefiniowanie parametrów potrzebnych dla pracy różnych podsystemów programu AS oraz samej aplikacji. Elementami wymagającymi parametryzacji są:

  • System obsługi alarmów

Parametryzacja wymaga zadeklarowania trybu pracy bazy definicji alarmów oraz określenia parametrów za pomocą:

program Architekt > Bazy danych > Baza definicji zmiennych

Architekt > Obszary i komputery > moduł System alarmów

Więcej informacji patrz:

Asix > cały rozdział System alarmów

Architekt > cały rozdział Konfiguracja systemu alarmów

Architekt > Baza definicji alarmów - konfiguracja

  • Raporty

Definicje raportów przygotowywane w plikach tekstowych oraz parametryzacja sposobu obsługi definicji raportów.

Więcej informacji patrz:

Asix > System generacji raportów

Architekt > Deklaracja obsługi definicji raportów

  • Obługa trendów

Parametryzacja polega na wygenerowaniu zestawów trendów za pomocą programu AsTrend.

Więcej informacji patrz:

podręcznik AsTrend

  • Parametry pracy aplikacji

Więcej informacji patrz:

Architekt > cały rozdział Konfigurowanie aplikacji systemu Asix


4.8. Uruchomienie aplikacji

Ostatnim krokiem, który należy wykonać jest wystartowanie programu AS32 w trybie aplikacyjnym. Należy utworzyć skrót (shortcut) z odpowiednią ikoną Asixa.

Parametr wywołania programu AS32.exe jest nazwą istniejącego pliku konfiguracyjnego aplikacji wraz z nazwą komputera, zadeklarowaną w pliku konfiguracyjnym. W linii startowej aplikacji można również umieścić parametry opcjonalne (patrz: poniżej).

Rysunek: Linia wywołania aplikacji systemu Asix.

Można wyróżnić trzy metody uruchomienia aplikacji, które różnią się sposobem pobierania danych procesowych. Pozwalają one na stopniowe przetestowanie elementów aplikacji.

Dane wewnętrznie symulowane

Pierwszy etap testowania utworzonej aplikacji. Nie jest do niego potrzebny żaden program oprócz programu AS32. Aby wyłączyć działanie programów Asmen i Aspad, należy włączyć dla nich parametr Symulacja:

Architekt > moduł Dane bieżące > zakładka Standardowe

Architekt > moduł Dane archiwalne > zakładka Standardowe

Ten sposób uruchomienia pozwala na sprawdzenie logicznej struktury aplikacji (sposobu przełączania diagramów).

Dane symulowane przez Asmena

W kolejnym etapie korzysta się z danych dostarczanych przez Asmena. Dopiero w tym punkcie wymagane jest pełne zdefiniowanie danych procesowych. Poprzez przedefiniowanie kanałów transmisyjnych na typ NONE powodujemy, że Asmen nie pobiera danych rzeczywistych, lecz wewnętrznie je symuluje. Dodatkowo można ustawić indywidualny sposób symulacji dla każdej zmiennej, w sposób zbliżony do jej przewidywanej charakterystyki. Na tym etapie można już uruchomić program Aspad, który będzie archiwizował dane symulowane.

Etap symulacji danych przez Asmena jest ostatnim etapem, który może być wykonywany bezpośrednio na komputerze projektanta, bez dostępu do procesu przemysłowego. Na tym etapie testowana jest przede wszystkim zgodność definicji zmiennych procesowych Asmena ze zmiennymi używanymi na diagramach procesowych.

Rzeczywiste dane procesu przemysłowego

Ostateczny efekt tworzenia aplikacji. Kanały transmisyjne Asmena są zdefiniowane w sposób powodujący pobieranie rzeczywistych danych z procesu. Oczywiście wiąże się to z konfiguracją odpowiednich środków sprzętowych. Pozostaje do przetestowania, czy dane procesowe Asmena są zdefiniowane poprawnie (czy adresują właściwe dane w sterowniku).

W linii startowej aplikacji można umieścić następujące opcjonalne parametry:

  • /RESET - powoduje on, że w przypadku upadku programu nastąpi całkowite przeładowanie systemu operacyjnego;

  • /ilość_sekund - oznacza, że program zostanie wystartowany z opóźnieniem podanym w parametrze. Może to być przydatne, gdy program jest uruchamiany z auto-startu i potrzebny jest czas na całkowite załadowanie systemu operacyjnego. W czasie startowania programu na ekranie ukaże się okno:

Rysunek: Okno ’Opóźnienie startu’.

  • /PROTECT - dodanie przełącznika w komendzie startowej aplikacji systemu Asix spowoduje natychmiastowe domyślne uruchomienie systemu zabezpieczeń dynamicznych w fazie uruchamiania programu as32.exe. Więcej szczegółów - [image] patrz: 9.7. Mechanizm zabezpieczeń systemowych.

W linii startowej programu as32 opcje mogą być wpisywane w dowolnej kolejności.

Patrz: Architekt > Uruchomienie aplikacji > Jak utworzyć ikonę skrótu uruchamiającą aplikację systemu Asix?

Patrz: Uruchomienie


4.9. Instalacje sieciowe

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 4. Metodyka tworzenia aplikacji > 4.9. Instalacje sieciowe / typy stanowisk

4.9. Instalacje sieciowe / typy stanowiosk

W systemie Asix istnieją dwa zasadnicze typy stanowisk.

  • Stanowiska operatorskie (stacje i serwery) przeznaczone do bezpośredniej obsługi procesu.

Podstawowe ich cechy to:

  • praca 24 godziny na dobę,

  • bezpośredni dostęp do sterowników kontrolujących proces przemysłowy,

  • aktywne gromadzenie archiwum zmiennych procesowych,

  • możliwość sterowania procesem,

  • obsługa alarmów na bieżąco z możliwością ich potwierdzania.

  • Stanowiska kontrolne (terminale sieciowe) przeznaczone dla służb kontrolnych.

Podstawowe ich cechy to:

  • włączane tylko okresowo,

  • dostęp do zmiennych poprzez połączenia sieciowe z komputerami operatorskimi,

  • dane archiwalne pobierane z aktywnego archiwum komputera operatorskiego,

  • domyślny brak możliwości sterowania procesem,

  • alarmy obsługiwane tylko poprzez pasywne przeglądanie plików historii alarmów.

Od powyższych charakterystyk dopuszczalne są odstępstwa stwarzające możliwość tworzenia stanowisk, które są hybrydami dwóch podstawowych typów stanowisk.

W szczególny sposób traktowane są instalacje sieciowe, w których używanych jest kilka stanowisk operatorskich. Charakteryzują się one następującymi cechami:

  • w momencie startu stanowiska operatorskiego uaktualniane są archiwa zmiennych procesowych, do stanu w jakim znajduje się archiwum na stanowisku operatorskim uruchomionym wcześniej;

  • w podobny sposób uaktualniane są pliki archiwalne alarmów;

  • alarmy są obsługiwane w sposób jednolity na wszystkich stanowiskach operatorskich; potwierdzenie, wykluczenie lub filtrowanie alarmu na jednym stanowisku powoduje automatycznie taką samą akcję na pozostałych stanowiskach operatorskich.

Szczegółowe zasady parametryzacji programów systemu Asix zostaną podane w następnych rozdziałach, przy opisie modułów Asmen i Aspad oraz modułu obsługi alarmów programu AS32.


5. Wybór języka pracy systemu Asix

Pakiet programowy Asix posiada możliwość przełączania języka pracy pomiędzy językami polskim i angielskim przy pomocy programu SelectLanguage.exe, umieszczanego w folderze głównym zainstalowanego pakietu. Dzięki takiemu rozwiązaniu użytkownik może w szybki i wygodny sposób określić język, w którym będzie wykonywana aplikacja docelowa.

Czynność przełączenia języka pracy systemu Asix polega na określeniu opcji w kolejno wyświetlanych oknach dialogowych.

Na wstępie użytkownik proszony jest o określenie wersji językowej, w której będą wyświetlane instrukcje programu SelectLanguage.exe.

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 1.

Kolejne dwa okna mają charakter informacyjny:

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 2.

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 3.

Wybór języka interfejsu użytkownika systemu Asix powoduje wyświetlanie okien (w tym komunikatów i opisów błędów) w wybranym języku. Jedynie język dokumentacji pakietu nie podlega przełączaniu - dokumentacja w postaci plików PDF i HLP dostępna jest w języku, w którym pierwotnie został zainstalowany pakiet.

Zrealizowanie aplikacji anglojęzycznej wymaga przełączenia się na język angielski.

Istotne znaczenie mają ustawienia językowe dokonane w poniższych dwóch oknach - pierwsze z nich określa wersję językową dla aktualnie zalogowanego użytkownika (w poniższym przykładzie mst), drugie - ustawienia systemowe, które będą obowiązywać wszystkich pozostałych użytkowników (jeśli nie zostaną dla nich określone indywidualne ustawienia).

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 4.

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 5.

W obu przypadkach (ustawienia dla zalogowanego użytkownika bądź ogólne systemowe ustawienia determinujące globalnie język pracy systemu ASIX) istnieje możliwość określenia języka przy pomocy poniższych opcji:

- język jak w systemie operacyjnym;

- język polski;

- język angielski.

W przypadku opcji Język jak w systemie operacyjnym - o języku decydują ustawienia w systemie operacyjnym. Jeśli językiem systemu operacyjnego jest j. polski, Asix będzie domyślnie pracował w języku polskim, w każdym innym przypadku - językiem pracy Asixa domyślnie będzie j. angielski.

Na zakończenie program SelectLanguage przedstawia do zatwierdzenia aktualne ustawienia dotyczące języka pracy pakietu Asix oraz wynikający z nich język interfejsu zalogowanego użytkownika. W pierwszej kolejności brane są pod uwagę ustawienia dla aktualnie zalogowanego użytkownika. Ustawienia systemowe obowiązują w przypadku uruchamiania programów Asix przez innych użytkowników, którzy nie posiadają indywidualnych ustawień.

Rysunek: ’Wybór interfejsu użytkownika aplikacji firmy ASKOM’ - okno 6.

Wybór języka pracy przy użyciu programu Architekt:

program Architekt > menu Narzędzia > Wybór języka


6. Menedżer komunikacyjny Asmen

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny

6. Asmen - Menedżer komunikacyjny

Wymiana informacji pomiędzy systemem wizualizacji i sterownikiem obiektu technologicznego może odbywać się przy użyciu łączy szeregowych lub sieci lokalnych. Wybór rodzaju połączenia zależy od konfiguracji sprzętowej oraz wymagań stawianych systemowi wizualizacji odnośnie liczby wymienianych danych oraz częstości przeprowadzania transmisji.

Wymiana informacji między komputerami systemu Asix może odbywać się za pośrednictwem sieci lokalnej. Taki rodzaj połączenia nazywany będzie kanałem sieciowym. Umożliwia on udostępnianie wartości zmiennych bieżących oraz archiwalnych Asixa komputerom nie posiadającym fizycznego połączenia ze sterownikiem. Oczywiście co najmniej jeden komputer w sieci lokalnej musi mieć fizyczne połączenie ze sterownikiem lub też ich siecią (np. SINECL2), aby móc pracować jako serwer danych dla pozostałych komputerów.

Systemy cechujące się dużą liczbą wymienianych informacji wymagają z reguły wykorzystania sieci lokalnych, natomiast w przypadku pozostałych systemów można ograniczyć się do zastosowania sprzęgów na łączach szeregowych.

Projektowanie systemu Asix w zakresie dostępu do danych obiektowych polega na przygotowaniu deklaracji:

kanałów transmisji - kanałem transmisji jest fizycznie zrealizowane połączenie pomiędzy komputerem systemu Asix i sterownikiem na obiekcie, określone przez nazwę drajwera działającego według określonego protokołu wraz z listą określonych parametrów. Kanał transmisji może stanowić również połączenie między komputerami systemu Asix przy użyciu sieci lokalnej. Ten typ połączenia stosuje się głównie w celu przekazania danych do komputerów pracujących jako tzw. terminale sieciowe, które nie posiadają połączenia ze sterownikami i nie tworzą zazwyczaj własnego archiwum. Istnieje również możliwość specyfikowania symulowanego kanału transmisji, który nie wymaga połączenia z obiektem. Opcja ta jest szczególnie przydatna na etapie projektowania i testowania aplikacji.

zmiennych procesowych - zmienną procesową jest przetworzona informacja opisująca stan określonego parametru technologicznego, powstała na bazie informacji odczytanych z obiektu;

Aktualnie zaleca się przechowywanie definicji zmiennych w bazie typy SQL lub Jet (Access) lub bezpośrednio w arkuszach kalkulacyjnych Excel - szczegóły [image] patrz: Architekt > Typ i format bazy danych.

Istnieje również możliwość specyfikowania zmiennych procesowych, które służą wyłącznie dla wewnętrznych potrzeb aplikacji i nie posiadają powiązań z obiektem.

W oparciu o specyfikacje w plikach konfiguracyjnych tworzone jest repozytorium bieżących wartości zmiennych procesowych (przechowywane przez moduł Asmen w pamięci operacyjnej komputera), do którego mają dostęp wszystkie komponenty systemu Asix. Wartości przechowywanych zmiennych procesowych są na bieżąco aktualizowane poprzez cykliczny odczyt z obiektu. Informacje z obiektu przesyłane są najczęściej w postaci surowej i z tego powodu wymagają wstępnego przetworzenia. Przetworzenie to realizowane jest przy wykorzystaniu funkcji przeliczających, deklarowanych przez projektanta dla każdej zmiennej procesowej z osobna.

W systemie Asix wszystkie operacje związane z dostępem do zmiennych procesowych są realizowane przez moduł Asmen. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych procesowych w bazie danych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery pracujące pod kontrolą Asmena. Zestaw drajwerów wykorzystywanych w systemie wizualizacji zależy każdorazowo od sposobu połączenia danego systemu z obiektem.

Szczególnym trybem pracy modułu Asmen jest działanie w trybie symulacji. Polega ono na tym, że wartości zmiennych procesowych nie są określane w oparciu o dane pochodzące z fizycznego kanału transmisji, lecz są generowane przy użyciu specyficznych funkcji przeliczających, zaprojektowanych pod kątem symulowania pracy z obiektem. Tryb symulacji jest szczególnie przydatny na etapie projektowania aplikacji, gdy połączenie z obiektem jest najczęściej niemożliwe.

Parametry pracy modułu Asmen deklaruje się w programie Architekt:

program Architekt > Obszary i komputery > moduł Dane bieżące

Patrz: Architekt > Konfiguracja parametrów danych bieżących

Możliwe jest zdefiniowanie następujących parametrów:

  • deklaracje kanałów transmisji,

  • sygnalizacja przeciążeń (opcja Przeciążenia),

  • działanie Asmena w trybie symulacji,

  • wstępne odświeżenie zmiennych na etapie instalacji Asmena,

  • redundancja kanałów transmisyjnych,

  • deklaracja numerów alarmów uaktywnianych w momencie zerwania i przywrócenia połączenia w danym kanale,

  • zezwolenie na zdalny odczyt danych z kanału przez inne komputery,

  • zezwolenie na zdalny zapis w kanale przez inne komputery,

  • blokada lokalnego zapisu do kanału,

  • czas ważności danych,

  • długość domyślnego cyklu odświeżania danych,

  • deklaracja ścieżki dla funkcji TABELA,

  • deklaracja formatu statusów zgodnym z OPC,

  • liczba prób dostępu do zmiennych sieciowych na serwerze,

  • deklaracja sterowania asynchronicznego,

  • ustawienie priorytetu wątków Asmena.


6.1. Deklarowanie kanałów transmisji

Deklaracje kanałów transmisji pozwalają na przekazanie do menedżera Asmen listy drajwerów używanych przez aplikację oraz parametrów pracy tych drajwerów. Deklaracje kanałów transmisji wymagają określenia następujących parametrów:

nazwa_logiczna - nazwa logiczna kanału transmisji; długość nazwy logicznej nie może przekroczyć 9 znaków; znakami zastrzeżonymi są spacja, przecinek oraz znak tabulacji;

nazwa_drajwera - nazwa drajwera łącza fizycznego używanego w danym kanale transmisji; można użyć nazwę NONE, która oznacza protokół symulujący łącze fizyczne, oraz nazwę NETWORK, która oznacza kanał sieciowy;

parametry - lista parametrów, specyficzna dla każdego z realizowanych przez określone drajwery protokołów łącza fizycznego; protokół symulujący łącze fizyczne (NONE) oraz protokół sieciowy (NETWORK) nie wymagają podania parametrów.

Kanały transmisji deklarowane są w pliku konfiguracyjnym za pośrednictwem programu Architekt:

Architekt > moduł Dane Bieżące

Każdy kanał posiada swoją definicję, która jest dodawana do modułu Dane bieżące poprzez kliknięcie prawym klawiszem myszy na wspomnianym module i wybranie komendy Dodaj kanał.

Patrz: Architekt > Definicja kanałów komunikacyjnych.

Kolejność umieszczenia deklaracji kanałów transmisji nie jest istotna. Kluczową rolę w definicji kanału odgrywa natomiast wybór protokołu (realizowanego przez drajwer), według którego będzie realizowana transmisja danych. Protokół ten wynika oczywiście z tego, jak jest zrealizowane sprzętowo połączenie komputera systemu Asix ze sterownikiem obiektu.

Specyficznym rodzajem protokołu jest protokół o nazwie NETWORK. Nie realizuje on fizycznego połączenia ze sterownikiem, a jedynie połączenie z innym komputerem, który takie połączenie ma. Drajwer kanału sieciowego po nawiązaniu połączenia wysyła zapytanie do wszystkich serwerów podając nazwę logiczną kanału. Odpowiadają na to pytanie jedynie serwery, które posiadają zadeklarowany taki kanał. Jeżeli odpowie więcej niż jeden serwer, to wtedy do nawiązania połączenia wybiera się serwer najmniej obciążony. Jeżeli w czasie pracy nastąpi wyłączenie serwera, wówczas drajwer kanału sieciowego przełączy się na inny serwer.

Kanał sieciowy może być zastosowany w celu realizacji terminali sieciowych wykorzystujących bieżące zmienne systemu Asix.

Innym specyficznym rodzajem protokołu jest obsługiwany wewnętrznie przez Asmena protokół o nazwie NONE. Protokół ten nie realizuje fizycznego połączenia ze sterownikiem. Może być zastosowany w celu:

  • testowania aplikacji w trybie symulacji,

  • umożliwienia wymiany informacji pomiędzy programami systemu Asix za pomocą zmiennych procesowych.

Symulacja zmian wartości zmiennych procesowych korzystających z protokołu NONE może być realizowana w oparciu o specyficzne funkcje przeliczające lub też poprzez odrębny program symulacyjny modyfikujący wartości zmiennych procesowych według żądanego przez projektanta algorytmu. W celu wykorzystania protokołu NONE dla przetestowania aplikacji należy:

  • usunąć deklaracje fizycznych kanałów transmisji,

  • utworzyć nowe deklaracje kanałów transmisji o nazwach logicznych identycznych z tymi, jakie były użyte w oryginalnych deklaracjach kanałów transmisji. Jako protokół należy zadeklarować protokół o nazwie NONE,

  • po zakończeniu testów należy powrócić do oryginalnych deklaracji kanałów transmisji.

Powyższy schemat postępowania można uzupełnić o dodanie do definicji zmiennych procesowych funkcji przeliczających przeznaczonych do symulacji przebiegów wartości zmiennych. Funkcje te zapewniają samoczynną zmianę wartości zmiennych zgodnie z algorytmem specyficznym dla konkretnej funkcji. W pakiecie systemu Asix znajdują się aktualnie dwie symulacyjne funkcje przeliczające: ON/OFF i PILA.

Wymiana danych poprzez zmienne procesowe kanału typu NONE polega na tym, że jeden z programów systemu Asix wypracowuje wartości zmiennych i wpisuje je do bazy danych Asmena. Pozostałe elementy systemu (program archiwizacji, obiekty wizualizacyjne) mogą pobierać te dane w normalny sposób, nie zdając sobie sprawy z tego, że dane te nie są transmitowane ze sterownika obiektu. Elementami systemu Asix, które pozwalają na generowanie wartości zmiennych kanału NONE jest obiekt wizualizacyjny klasy PRZELICZNIK. PRZELICZNIK ustawia wartość wybranej zmiennej na podstawie cyklicznie obliczanego dowolnego wyrażenia arytmetycznego.

W pozycji opisującej protokół typu NONE nie podaje się żadnych dodatkowych parametrów.

Zmienne tablicowe z kanału NONE są traktowane jako jedna zmienna.

Istnieje możliwość zadeklarowania dla kanałów typu NONE sposobu dostępu do zmiennych polegającego na tym, że zmienne otrzymują wartości w efekcie wykonania operacji zapisu - wymagającej podania nie tylko wartości ale również czasu i statusu. W tym celu należy jako drajwer komunikacyjny zadeklarować dla danego kanału drajwer o nazwie NONE i włączyć opcję Zapis czasu i statusu. Rozwiązanie to zostało stworzone w celu umożliwienia importu (np. z wykorzystaniem mechanizmu skryptu) wartości zmiennych z aplikacji zewnętrznych, np. arkusza kalkulacyjnego i przekazania ich do archiwum modułu Aspad. Domyślnie wartości zmiennych kanału NONE pozbawione są stempla czasu i statusu, przez co nie jest możliwa ich archiwizacja - dopiero użycie opcji Zapis czasu i statusu pozwala zapisać wartości tych zmiennych w archiwum Aspada.

Rysunek: Deklaracja zapisu czasu i statusu dla kanału none.

W chwili wystartowania program Asmen wymaga, aby drajwery wszystkich protokołów zadeklarowanych w pliku konfiguracyjnym aplikacji znajdowały się w kartotece, z której startuje system Asix. Wyjątkiem jest drajwer protokołu symulującego łącze fizyczne (NONE), który jest wbudowany w moduł Asmen. Sposób ładowania poszczególnych drajwerów jest podany przy opisie drajwerów dostępnych w systemie Asix.


Wyłączanie kanałów z obsługi

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.2 Wyłączanie kanałów z obsługi

6.2. Wyłączanie kanałów z obsługi

Aby wyłączyć kanał komunikacyjny z obsługi:

1. dla każdego kanału, który chcemy wyłączać/włączać z obsługi należy utworzyć zmienną kontrolną, której nazwa jest zbudowana wg zasady: 2 podkreślenia + nazwa kanału + 2 podkreślenia, np. dla kanału TEST zmienna kontrolna ma nazwę __TEST__

2. zmienna kontrolna musi być zadeklarowana w kanale NONE i używać funkcji przeliczającej NIC

3. wyłączenie kanału z obsługi wymaga ustawienia wartości zmiennej kontrolnej na 0

4. włączenie kanału do obsługi wymaga ustawienia wartości zmiennej kontrolnej na != 0

5. jeśli kanał jest wyłączony z obsługi, to wszystkie operacje na zmiennych z tego kanału (odświeżanie, odczyt, zapis) są kończone z błędem na poziomie Asmena (bez wykonywania operacji przez drajwer)

6. domyślnie kanał jest włączony do obsługi, a wartość zmiennej kontrolnej jest ustawiana przez Asmena na 1

7. wyłączenie/włączenie kanału jest kwitowane wpisem do panelu operatorskiego

Jeśli kanał ma być wyłączony z obsługi już na starcie aplikacji, to należy skorzystać z opcji wpisanej w Architekcie, w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio:

Nazwa sekcji: ASMEN

Nazwa opcji: WYLACZENIE_KANALU

Wartość opcji: nazwa_ kanału_Asmena


6.2. Deklarowanie zmiennych procesowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.3. Deklarowanie zmiennych procesowych

6.3. Deklarowanie zmiennych procesowych

Zaleca się deklarowanie zmiennych procesowych w bazie definicji zmiennych.

Zaleca się przechowywanie definicji zmiennych w bazie typy SQL lub Jet (Access) lub bezpośrednio w arkuszach kalkulacyjnych Excel - szczegóły na ten temat [image] patrz: Architekt > Typ i format bazy danych.

Parametry definiujące zmienne w bazie definicji zmiennych zawarte są w polach o następujących nazwach:

Parametr Pole

Nazwa zmiennej Nazwa

Opis zmiennej Opis

Adres zmiennej Adres

Deklaracja kanału transmisji Kanal

Rozmiar zmiennej LiczbaElementow

Częstość odświeżania OkresProbkowania

Funkcja przeliczająca FunkcjaPrzeliczajaca

Parametry funkcji przeliczającej:

Zakres wejściowy od.. ZakresFunkcjiAsmenLo

Zakres wejściowy ..do ZakresFunkcjiAsmenHi

Zakres wyjściowy od.. ZakresPomiarowyLo

Zakres wyjściowy ..do ZakresPomiarowyHi

Patrz: Pełna lista atrybutów systemowych bazy definicji zmiennych znajduje się w Architekt > Załącznik 1. Lista atrybutów systemowych Bazy Definicji Zmiennych definiujących zmienne procesowe .

Przy deklarowaniu zmiennych procesowych nie określa się ich typu. Typ zmiennej procesowej w postaci surowej (odczytywanej lub zapisywanej do sterownika) wynika z protokołu transmisji oraz adresu symbolicznego. Typ zmiennej procesowej w postaci przetworzonej (przekazywanej przez Asmena do aplikacji lub z aplikacji do Asmena) wynika z zastosowanej funkcji przeliczającej. Zmienne procesowe mogą przyjmować następującą postać:

  • liczba 16-bitowa bez znaku (WORD),

  • liczba 16-bitowa ze znakiem (INTEGER),

  • liczba 32-bitowa bez znaku (DWORD),

  • liczba 32-bitowa ze znakiem (LONG),

  • liczba zmiennoprzecinkowa (FLOAT).

Moduł Asmen korzysta z następujących parametrów zmiennych:

nazwa_zmiennej - nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca zmienną dla wszystkich komponentów systemu Asix (długość nazwy nie może przekroczyć 50 znaków, a nazwa nie może zawierać spacji, dwukropków, kropki, wszelkiego typu nawiasów oraz przecinka);

opis_zmiennej - dowolny tekst zawierający np. technologiczny opis zmiennej procesowej (w aktualnej wersji nie może zawierać przecinków);

adres - adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu Asix; jest on używany przez drajwer w celu lokalizacji zmiennej w sterowniku;

kanał - nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji);

ilość - liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą); np w przypadku bloków danych db specyfikuje się liczbę słów danych dw, których wartości zostaną w formie tablicy przypisane zmiennej procesowej (dla protokołów sterowników SIMATIC); w typowym przypadku liczba elementów wynosi 1;

częstość - częstość aktualizacji wartości zmiennej procesowej (w sekundach);

funkcja - nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu Asix; w trakcie inicjalizacji zmiennych procesowych sprawdzana jest zgodność typu zmiennej pobieranej ze sterownika (określana przez drajwer) z typem zmiennej wejściowej funkcji przeliczającej; w przypadku rozbieżności, zmienna procesowa nie jest inicjowana; dopuszczalne jest zamienne używanie typów integer, word, dword oraz long;

parametry - lista parametrów funkcji przeliczającej przypisanych danej zmiennej; w przypadku, gdy nie jest podana pełna lista parametrów, to pominiętym parametrom zostaną nadane wartości domyślne, specyficzne dla każdej z funkcji przeliczających;

Adres symboliczny jest używany dla jednoznacznego określenia zmiennej w sterowniku, której wartość zostanie przypisana zmiennej procesowej w systemie Asix. Na podstawie adresu symbolicznego określany jest typ zmiennej oraz jej lokalizacja w pamięci sterownika. Sposób tworzenia adresu jest specyficzny dla typu kanału, w którym zmienna się znajduje.


6.3. Uruchamianie modułu Asmen

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.4. Uruchamianie modułu Asmen

6.4. Uruchamianie modułu Asmen

Asmen jest ładowany automatycznie w trakcie ładowania Asixa, a parametry jego działania pobierane są z pliku konfiguracyjnego aplikacji. Parametryzacja modułu Asmen musi uwzględniać wszystkie zmienne używane w systemie.


6.4. Parametry konfiguracyjne modułu Asmen

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.5. Parametry konfiguracyjne modułu Asmen

6.5. Parametry konfiguracyjne modułu Asmen

Parametry Asmena są zadawane w pliku konfiguracyjnym aplikacji XML za pośrednictwem programu Architekt.

Patrz: Architekt > Konfiguracja parametrów danych bieżących.


6.5. Funkcje przeliczające

6.6. Funkcje przeliczające

Funkcje przeliczające są używane przez moduł Asmen przy przekształcaniu wartości zmiennych procesowych z postaci surowej na postać rzeczywistą. Każda zmienna posiada indywidualnie deklarowaną funkcję przeliczającą. Niektóre z udostępnionych funkcji przeliczających pozwalają na symulowanie zmian wartości zmiennych według zadanego algorytmu.

System Asix zawiera następujące funkcje przeliczające (nazwy funkcji należy pisać wielkimi literami):

  • ANALOG, ANALOG_FP - przekształcenie liniowe

  • ANALOG12STATUS - przekształcenie liniowe z uwzględnieniem bitów statusu pomiaru

  • ANALOGWORD_FP - specjalne przekształcenie liniowe

  • BIT0_Z_N - sklejanie słowa z zerowych bitów n zmiennych

  • BITN_Z_N - sklejanie słowa z zerowych bitów n zmiennych

  • CAMAC6_1, CAMAC6_2 - specjalna obsługa interfejsu CAMAC

  • CZAS - dokonuje konwersji wartości zmiennej procesowej

  • CZAS_SEK - zamienia przy odczycie wartość zmiennej procesowej

  • CZAS_MSEK - zamienia przy odczycie wartość zmiennej procesowej

  • CYRK1 - konwersja bit - liczba

  • DATACZAS - konwersja liczby sekund na łańcuch

  • DATACZAS_MEC - konwersja czasu licznika MEC na łańcuch

  • DW2FP - funkcja pozwala na zmianę zmiennych typu DWORD na zmienne typu FLOAT

  • GRADIENT - obliczanie gradientu

  • ILORAZ - skalowanie

  • ILORAZ_DW - skalowanie

  • LICZ - konwersja z formatu BCD

  • MASKA - iloczyn logiczny wartości zmiennej i parametru funkcji

  • MAXIMUM_Z_N, MINIMUM_Z_N - ekstremum wartości n zmiennych

  • MNOZNIK_KG - konwersja typów zmiennopozycyjnych

  • MNOZNIK_FP - konwersja typów zmiennopozycyjnych

  • MNOZNIK_DW - konwersja typów zmiennopozycyjnych

  • MNOZNIK, MNOZNIK_INT, MNOZNIK_LONG - przekształcenie liniowe

  • NEGBIT_BYTE, NEGBIT, NEGBIT_DW - negacja wybranych bitów odpowiednio w bajcie, słowie i podwójnym słowie

  • NIC, NIC_DW, NIC_DD, NIC_DOUBLE, NIC_FP - przekazanie wartości bez zmiany

  • NIC_BYTE, NIC_INT, NIC_INT64, NIC_LONG - przekazanie wartości bez zmiany

  • NIC_KG, NIC_TEXT - przekazanie wartości bez zmiany

  • ON/OFF - symulacja zmian dwustanowych

  • PILA, PILA_FP, PILA_INT64, PILA_DOUBLE - symulacja przebiegu piłokształtnego

  • PROCENT, PROCENT_FP - przeliczanie na wartość procentową

  • PRZESUN_L - przesunięcie wartości zmiennej w lewo

  • PRZESUN_P - przesunięcie wartości zmiennej w prawo

  • SREDNIA - średnia typu "ruchome okienko"

  • SREDNIA_Z_N - aktualna wartość średniej arytmetycznej listy zmiennych

  • STALA, STALA_FP - nadanie wartości stałej zmiennej Asmena

  • STATUS - aktualny status zmiennej

  • SUMA_Z_N - suma wartości n zmiennych

  • SUWAK, SUWAK1, SUWAK1_FP - funkcja pomocnicza dla obiektów wizualizacyjnych klasy SUWAK

  • TAB2DOUBLE - zwraca double zbudowany na bazie wartości zmiennej tablicowej

  • TABELA - przekształcenie nieliniowe

  • WEZ_CZAS_DW - znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji

  • WEZ_CZAS_FP - znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji

  • WEZ_CZAS_LONG - znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji

  • WEZ_STCZAS_DW - status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji; znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji

  • WEZ_STCZAS_FP - status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji; znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji

  • WEZ_STCZAS_LONG - status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji; znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji

  • WSREDNIA_Z_N - aktualna wartość średniej ważonej listy zmiennych.

  • ZAKRES - konwersja zmiennej procesowej odczytanej ze sterownika.

  • ZCZAS - wartość i status są kopią wartości i statusu zmiennej, której nazwa jest pierwszym parametrem funkcji, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji.

  • ZCZAS_DW - wartość i status są kopią wartości i statusu zmiennej, której nazwa jest pierwszym parametrem funkcji, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji.

  • ZSTATUS - wartość zmiennej jest kopią statusu zmiennej, będącej parametrem funkcji'

  • ZSTATUS_CZAS - wartość jest kopią wartości zmiennej będącej pierwszym parametrem, status jest kopią statusu zmiennej będącej drugim parametrem, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest trzecim parametrem funkcji

Poniżej opisane zostały wszystkie funkcje przeliczające systemu Asix. Dla każdej funkcji przeliczającej podano:

  • typ zmiennej czytanej/pisanej z/do ze sterownika (typ zmiennej PLC);

  • typ zmiennej przekazywanej do/z programu użytkownika (typ zmiennej PC);

  • listę parametrów (wraz z ich typami oraz wartościami domyślnymi) według kolejności występowania w linii deklaracji zmiennej.

  • Funkcja ANALOG

Funkcja ANALOG dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = MinPCVal + (PLCVal - MinPLCVal) * k

oraz konwersji wartości zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = MinPLCVal + (PCVal - MinPCVal) * k

Współczynnik k jest wyliczany następująco:

k = (MaxPCVal - MinPCVal)/(MaxPLCVal - MinPLCVal)

typ zmiennej PLC - INTEGER

typ zmiennej PC - INTEGER

Parametry:

MinPLCVal - INTEGER (wartość domyślna - 0)

MaxPLCVal - INTEGER (wartość domyślna - 2048)

MinPCVal - INTEGER (wartość domyślna - 0)

MaxPCVal - INTEGER (wartość domyślna - 2048)

  • Funkcja ANALOG_FP

Funkcja ANALOG_FP dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = MinPCVal + (PLCVal - MinPLCVal) * k

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = MinPLCVal + (PCVal - MinPCVal) * k

Współczynnik k jest wyliczany następująco:

k = (MaxPCVal - MinPCVal)/(MaxPLCVal - MinPLCVal)

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 2048)

MinPCVal - FLOAT (wartość domyślna 0.0)

MaxPCVal - FLOAT (wartość domyślna 2048.0)

1. Funkcja ANALOG_FP działa jak funkcja NIC_FP w przypadku użycia ich dla zmiennych z kanału NONE.
2. Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem.

  • Funkcja ANALOG12STATUS

Funkcja ANALOG12STATUS dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = MinPCVal + (PLCVal - MinPLCVal) * k

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = MinPLCVal + (PCVal - MinPCVal) * k

Współczynnik k jest wyliczany następująco:

k = (MaxPCVal - MinPCVal)/(MaxPLCVal - MinPLCVal)

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 2048)

MinPCVal - FLOAT (wartość domyślna 0.0)

MaxPCVal - FLOAT (wartość domyślna 2048.0)

W parametrach funkcji nie trzeba uwzględniać faktu, że odczytana wartość analogu jest przesunięta o 3 bity w lewo.

Funkcja znajduje zastosowanie do wszystkich urządzeń obsługujących 12-bitowe wartości pomiarów, w których na trzech najmłodszych bitach umieszczane są bity statusu pomiaru
(dane w formacie SIEMENS z diagnostyką wewnątrz słowa statusowego), np. do modułów SIMATIC S5 , BECHOFF, WAGO.

Funkcja działa jak funkcja ANALOG_FP, ale dodatkowo ustawiany jest status stosownie do stanu bitów statusowych czytanych z modułu AI:
a/ bit1 = 0, bit0 = 1 - przekroczenie zakresu górnego;zwracany jest status OPC_LIMIT_HIGH (lub AVD_BAD, jeśli Asmen nie jest w trybie OPC);
b/ bit1 = 1, bit0 = 1 - przekroczenie zakresu dolnego; zwracany jest status
OPC_LIMIT_LOW (lub AVD_BAD, jeśli Asmen nie jest w trybie OPC);
c/ dla pozostałych kombinacji bitów statusowych zwracany jest status
OPC_QUALITY_GOOD (lub AVD_GOOD, jeśli Asmen nie jest w trybie OPC).

  • Funkcja ANALOGWORD_FP

Funkcja ANALOGWORD_FP dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według następujących zasad.

Funkcja ANALOG_FP dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = MinPCVal + (PLCVal - MinPLCVal) * k + offset

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = MinPLCVal + (PCVal – MinPCVal - offset) * k

Współczynnik k jest wyliczany następująco:

k = (MaxPCVal - MinPCVal)/(MaxPLCVal - MinPLCVal)

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 2048)

MinPCVal - FLOAT (wartość domyślna 0.0)

MaxPCVal - FLOAT (wartość domyślna 2048.0)

offset - FLOAT (wartość domyślna 0.0)

Funkcja ANALOGWORD_FP działa jak funkcja NIC_FP w przypadku użycia ich dla zmiennych z kanału NONE.

Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem (włączony parametr 'Zapis czasu i statusu’).

  • BIT0_Z_N

BIT0_Z_N konstruuje liczbę 16-bitową bez znaku (WORD), w której wartości poszczególnych bitów są równe wartości najmłodszych bitów (bitu 0) aktualnych wartości zmiennych, wymienionych w liście. Z wartości zmiennej będącej na pierwszym miejscu w liście buduje się bit 0, drugim miejscu listy - bit 1 itd. Liczba parametrów funkcji jest ograniczona do 16.

typ zmiennej PLC - BYTE, WORD, DWORD

typ zmiennej PC - WORD

parametry:

k, to minimalna liczba zmiennych poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji; wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

Val_1 .. Val_n nazwy zmiennych Asmena oddzielone spacją , n<=16

W przypadku zadeklarowania jako jednej ze zmiennych Val_i zmiennej typu FLOAT przed wykonaniem funkcji wartość zmiennej jest konwertowana na WORD (funkcja ma sens dla zmiennych binarnych, których wartości drajwer zwraca jako FLOAT).

  • BITN_Z_N

BITN_Z_N stanowi rozszerzenie funkcjonalności funkcji Bit0_Z_N poprzez:

1. możliwość wyboru dowolnego bitu wartości zmiennej

2. możliwość forsowania wartości bitu poprzez użycie parametru 0 lub 1 zamiast nazwy zmiennej

3. możliwość zanegowania wartości bitu zmiennej poprzez użycie suffixa NOT

Przykład:

ZM_MASKA, , XX, TEST, 1, 1, BITN_Z_N, 4, ZM_01:3 ZM_02:8:NOT ZM_03:4 0 1 ZM_04:1:NOT 1

Poszczególne bity zmiennej ZM_MASKA mają następujące wartości:

bit 0 - bit 3 zmiennej ZM_01

bit 1 - zanegowana wartość bitu 8 zmiennej ZM_02

bit 2 - bit 4 zmiennej ZM_03

bit 3 - 0

bit 4 - 1

bit 5 - zanegowana wartość bitu 1 zmiennej ZM_04

bit 6 - 1

  • Funkcja CAMAC6_1

Funkcja CAMAC6_1 dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według następujących zasad:

dla PLCVall >= 2048

PLCVal = (PLCVal - 2048)/2048

dla PLCVall < 2048

PLCVal = (2048 - PLCVal)/2048

PCVal = PLCVal * (MaxPCVal - MinPCVal) + MinPCVal

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 4096)

MinPCVal - FLOAT (wartość domyślna -75.0)

MaxPCVal - FLOAT (wartość domyślna 300.0)

  • Funkcja CAMAC6_2

Funkcja CAMAC6_2 liczy średnią z próbek wartości zmiennej procesowej odczytywanych ze sterownika według następujących zasad:

dla PLCVall >= 2048

PLCVal = (PLCVal - 2048)/2048

dla PLCVall < 2048

PLCVal = (2048 - PLCVal)/2048

PCVal = PLCVal * (MaxPCVal - MinPCVal) + MinPCVal

Średnia liczona jest za okres Okres (podawany w minutach), a wynik uznawany jest za poprawny, jeśli stopa procentowa poprawnie odczytanych próbek wynosi Stopa.

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 4096)

MinPCVal - FLOAT (wartość domyślna -75.0)

MaxPCVal - FLOAT (wartość domyślna 300.0)

Okres - INTEGER (wartość domyślna 5)

Stopa - INTEGER (wartość domyślna 80)

  • Funkcja CZAS

Funkcja CZAS dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika (traktowanej jako licznik czasu w formacie STEP5) na liczbę obrazującą czas w jednostkach określonych przez parametr funkcji CZAS.

Przy zapisie wartości zmiennej procesowej do sterownika dokonywana jest konwersja liczby obrazującej czas w jednostkach użytkownika na licznik czasu w formacie STEP5.

Typy formatu czasu użytkownika podane są poniżej:

typ 0 - czas w 0.01 sek

typ 1 - czas w 0.1 sek

typ 2 - czas w sekundach

typ 3 - czas w minutach

typ 4 - czas w godzinach

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametry:

format czasu - WORD (wartość domyślna 2)

  • Funkcja CZAS_SEK

Funkcja CZAS_SEK zamienia przy odczycie wartość zmiennej procesowej typu WORD (traktowanej jako liczba sekund) na łańcuch znaków ASCII o formacie:

mm:ss

gdzie:

mm - minuty

ss - sekundy

Funkcja CZAS_SEK zamienia przy zapisie łańcuch znaków ASCII o formacie:

mm:ss

gdzie:

mm - minuty

ss - sekundy

na liczbę sekund w formacie WORD.

Zmienna procesowa wykorzystująca przedmiotowe funkcje nie może należeć do kanału NONE. Funkcja nie może być stosowana do zmiennych tablicowych.

  • Funkcja CZAS_MSEK

Funkcja CZAS_MSEK zamienia przy odczycie wartość zmiennej procesowej typu DWORD (traktowanej jako liczba milisekund) na łańcuch znaków ASCII o formacie:

hh:mm:ss

gdzie:

hh - godziny

mm - minuty

ss - sekundy

Funkcja CZAS_MSEK zamienia przy zapisie łańcuch znaków ASCII o formacie:

hh:mm:ss

gdzie:

hh - godziny

mm - minuty

ss - sekundy

na liczbę milisekund w formacie DWORD.

Zmienna procesowa wykorzystująca przedmiotowe funkcje nie może należeć do kanału NONE. Funkcja nie może być stosowana do zmiennych tablicowych.

  • Funkcja CYRK1

Funkcja CYRK1 dokonuje przekształcenia wartości zmiennej procesowej odczytanej ze sterownika na jedną z liczb 16-bitowych bez znaku znajdujących się w tablicy przypisanej danej zmiennej procesowej. Zawartość oraz rozmiar tablicy określany jest na podstawie deklaracji zmiennej procesowej. Przekształcenie polega na odnalezieniu pozycji pierwszego niezerowego bitu w 16 bitowej liczbie odczytanej ze sterownika i użycia tej pozycji jako indeksu przy odczycie z tablicy. Poszukiwanie niezerowego bitu rozpoczyna się od bitu podanego w deklaracji zmiennej i kontynuuje w stronę malejących rangą bitów. Liczba testowanych bitów podana jest w deklaracji zmiennej. W przypadku, gdy odczytane słowo jest równe 0, to jako wartość zwracany jest ostatni parametr, podany przy deklaracji zmiennej procesowej.

W przypadku pisania do sterownika funkcja CYRK1 przeszukuje tablicę przypisaną zmiennej procesowej w celu odnalezienia w niej wzorca identycznego z wartością przekazaną do funkcji. W przypadku odnalezienia wzorca do sterownika przekazywana jest liczba 16-bitowa składająca się z 1 na pozycji odpowiadającej indeksowi odnalezionego wzorca i zer na pozostałych pozycjach. Wyjątek stanowi wzorzec odnaleziony na najstarszej pozycji tablicy - w takim przypadku do sterownika przekazywane jest 0. W przypadku, gdy wzorzec nie zostanie odnaleziony, funkcja zwraca błąd.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametry:

numer bitu, od którego rozpoczyna się poszukiwania - WORD

liczba przeszukiwanych bitów - WORD

kolejne elementy tablicy wzorców

maks. 16 + 1 (ostatni dla 0) elementów - WORD

  • Funkcja DATACZAS

Funkcja DATACZAS zamienia liczbę sekund przekazaną w postaci liczby typu DWORD na łańcuch ASCII o postaci:

DD-MM-YYYYbHH:NN:SS

gdzie:

DD - dwie cyfry dnia

MM - dwie cyfry miesiąca

YYYY - cztery cyfry roku

HH - dwie cyfry godziny

NN - dwie cyfry minut

SS - dwie cyfry sekund

b - spacja

Może być wykorzystywana wyłącznie w przypadku drajwera NONE.

Funkcja nie ma parametrów.

  • Funkcja DATACZAS_MEC

Funkcja DATACZAS_MEC zamienia czas licznika MEC podany jako liczbę sekund przekazaną w postaci łańcucha 17 bajtów na łańcuch ASCII o postaci:

YYYY-MM-DD HH:MM

Czas MEC`a przekazywany jest na indeksie 0

Funkcja nie ma parametrów.

  • Funkcja DATACZAS_MUZ

Funkcja DATACZAS_MUZ konwertuje znacznik czasu MultiMuza (double) na łańcuch ASCII w formacie:

yyyy-mm-dd hh:nn:ss.zzz

  • Funkcja DW2FP

Funkcja pozwala na zamianę zmiennych typu DWORD na zmienną typu FLOAT.

  • GRADIENT

GRADIENT zwraca wartość zmiennej wyliczoną wg. wzoru:

y = {(t2 - t1) / T}*m

gdzie:

t2 - wartość bieżąca wyliczona jako średnia ważona

t1 - wartość z chwili t0-T wyliczona jako średnia ważona

T - okres, za który liczony jest gradient (w sekundach)

średnia ważona t = t-1*(1-k) + tb*(k)

k - waga w zakresie (0 – 1)

t-1 - wartość t wyliczona w poprzednim cyklu

tb - wartość w danej chwili

m - mnożnik

typ zmiennej PC - FLOAT

Parametry:

T - WORD

k - FLOAT

m - FLOAT

Wartością źródłową dla funkcji GRADIENT może być zmienna surowa w sterowniku, jak i zmienna systemu Asix zadeklarowana w module Asmen.

PRZYKŁAD

Przykładowa deklaracja zmiennej adresowanej w sterowniku i przeliczanej funkcją gradient

ZMIENNA1,gradient zmiennej w sterowniku,ED100.0,KANAL,1,1,GRADIENT,15,0.1,60

Znaczenie parametrów:

Adres zmiennej - DB 100, DW0

Okres T - 15 sekund

Współczynnik k - 0.1

Przeliczenie m - 60 sekund

ZMIENNA1 - jest wyliczoną szybkością zmian zmiennej o adresie ED100.0 w jednostkach sterownika na minutę.

Zmienna w sterowniku musi być podawana w jednostkach rzeczywistych.

PRZYKŁAD

Przykładowa deklaracja zmiennej systemu Asix przeliczanej funkcją gradient:

ZMIENNA2,gradient zmiennej ,,NONE,1,1,GRADIENT,15,0.1,60,ZMIENNA3

Znaczenie parametrów:

Okres T - 15 sekund

Współczynnik k - 0.1

Przeliczenie m - 60 sekund

Zmienna źródłowa - ZMIENNA3

ZMIENNA2 - jest wyliczoną szybkością zmian zmiennej ZMIENNA3 w jednostkach ZMIENNEJ3 na minutę.

  • Funkcja ILORAZ

Funkcja ILORAZ dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = PLCVal / k

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = PCVal * k

gdzie k (DZIELNIK) jest parametrem funkcji.

typ zmiennej PLC - WORD

typ zmiennej PC - FLOAT

Parametry:

dzielnik - FLOAT (wartość domyślna 10.0)

  • Funkcja ILORAZ_DW

Funkcja ILORAZ_DW dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = PLCVal / k

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = PCVal * k

gdzie k (DZIELNIK) jest parametrem funkcji.

typ zmiennej PLC - DWORD

typ zmiennej PC - FLOAT

Parametry:

dzielnik - FLOAT (wartość domyślna 10.0)

  • Funkcja LICZ

Funkcja LICZ dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika (traktowanej jako stan licznika w formacie BCD z 3-ma dekadami) na 16-bitową liczbę bez znaku.

Przy zapisie wartości zmiennej procesowej do sterownika dokonywana jest konwersja 16-bitowej liczby bez znaku na liczbę w formacie BCD z 3-ma dekadami.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

nie posiada parametrów

  • Funkcja MASKA

Funkcja MASKA przy odczycie wykonuje operację iloczynu logicznego wartości zmiennej odczytanej ze sterownika i parametru funkcji MASKA, podanego w deklaracji zmiennej.

Przy zapisie do sterownika wartość zmiennej nie jest modyfikowana.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametr:

liczba w formacie heksadecymalnym (wartość domyślna FFFF).

  • MAXIMUM_Z_N

MAXIMUM_Z_N zwraca największą wartość ze zmiennych, wymienionych w liście jako parametry i przeznaczona jest do użycia ze zmienną zadeklarowaną w kanale typu NONE. Zmienne wymienione w liście parametrów mogą być różnego typu, wartość funkcji jest konwertowana na typ FLOAT. Nie ogranicza się liczby zmiennych ani ich kolejności w deklaracji zmiennej, do której przypisano funkcję MAXIMUM_Z_N. W przypadku, gdy deklaracja nie mieści się w jednej linii z powodu długiej listy nazw zmiennych, to należy ją rozdzielić na kilka linii, które (poza ostatnią) mają na końcu znak kontynuacji "\".

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

k to minimalna liczba zmiennych poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji, wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

Val_1,..Val_n dowolnego typu, nazwy zmiennych Asmena.

Wartość funkcji jest obliczana następująco:

PCVal=max(Val_1,Val_2,..,Val_n)

  • MINIMUM_Z_N

MINIMUM_Z_N zwraca najmniejszą wartość ze zmiennych, wymienionych w liście jako parametry i przeznaczona jest do użycia ze zmienną zadeklarowaną w kanale typu NONE. Zmienne wymienione w liście parametrów mogą być różnego typu, wartość funkcji jest konwertowana na typ FLOAT. Nie ogranicza się liczby zmiennych ani ich kolejności w deklaracji zmiennej, do której przypisano funkcję MINIMUM_Z_N. W przypadku, gdy deklaracja nie mieści się w jednej linii z powodu długiej listy nazw zmiennych, to należy ją rozdzielić na kilka linii, które (poza ostatnią) mają na końcu znak kontynuacji "\".

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

k to minimalna liczba zmiennych poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji, wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

Val_1,..Val_n dowolnego typu, nazwy zmiennych Asmena.

Wartość funkcji jest obliczana następująco:

PCVal=min(Val_1,Val_2,..,Val_n)

  • Funkcja MNOZNIK_FP

Funkcja MNOZNIK_FP dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal= A * PLCVal + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = ( PCVal - B ) / A

typ zmiennej PLC - FLOAT

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

#ABS - użytkownik dostaje wartość absolutną

Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem.

  • Funkcja MNOZNIK_KG

Funkcja MNOZNIK_KG dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal(IEEE 754) = A * PLCVal(KG) + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal(KG) = ( PCVal(IEEE 754) - B ) / A

Przy odczycie zmiennej ze sterownika funkcja przeliczająca MNOZNIK_KG dokonuje konwersji z formatu zmiennoprzecinkowego KG na format zmiennoprzecinkowy zgodny z IEEE 754. Przy zapisie dokonywana jest konwersja z formatu zmiennoprzecinkowego zgodnego z IEEE 754 na format zmiennoprzecinkowy KG.

typ zmiennej PLC - FLOAT (KG)

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem.

  • Funkcja MNOZNIK_DW

Funkcja MNOZNIK_DW dokonuje konwersji wartości zmiennej procesowej typu dword (liczba 32-bitowa bez znaku) odczytanej ze sterownika według równania:

PCVal = A * PLCVal + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = ( PCVal - B ) / A

typ zmiennej PLC - DWORD

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

  • Funkcja MNOZNIK

Funkcja MNOZNIK dokonuje konwersji wartości zmiennej procesowej typu word (liczba 16-bitowa bez znaku) odczytanej ze sterownika według równania:

PCVal = A * PLCVal + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = ( PCVal - B ) / A

typ zmiennej PLC - WORD

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

  • Funkcja MNOZNIK_INT

Funkcja MNOZNIK_INT dokonuje konwersji wartości zmiennej procesowej (liczba 16-bitowa ze znakiem) odczytanej ze sterownika według równania:

PCVal = A * PLCVal + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = ( PCVal - B ) / A

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

  • Funkcja MNOZNIK_LONG

Funkcja MNOZNIK_LONG dokonuje konwersji wartości zmiennej procesowej (liczba 32-bitowa ze znakiem) odczytanej ze sterownika według równania:

PCVal = A * PLCVal + B

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = ( PCVal - B ) / A

typ zmiennej PLC - LONG

typ zmiennej PC - FLOAT

Parametry:

A - FLOAT (wartość domyślna 1.0)

B - FLOAT (wartość domyślna 0.0)

  • Funkcja NEGBIT_BYTE

Funkcja NEGBIT_BYTE przekazuje użytkownikowi 8-bitową wartość odczytanej zmiennej procesowej po zanegowaniu bitów zgodnie z maską.

typ zmiennej PLC - BYTE

typ zmiennej PC - BYTE

Parametr:

8-bitowa maska negowanych bitów w postaci heksdecymalnej

  • Funkcja NEGBIT

Funkcja NEGBIT przekazuje użytkownikowi 16-bitową wartość odczytanej zmiennej po zanegowaniu bitów zgodnie z maską.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametr:

16-bitowa maska negowanych bitów w postaci heksdecymalnej

  • Funkcja NEGBIT_DW

Funkcja NEGBIT_DW przekazuje użytkownikowi 32-bitową wartość odczytanej zmiennej po zanegowaniu bitów zgodnie z maską.

typ zmiennej PLC - DWORD

typ zmiennej PC - DWORD

Parametr:

32-bitowa maska negowanych bitów w postaci heksdecymalnej

  • Funkcja NIC

Funkcja NIC przekazuje użytkownikowi 16-bitową wartość zmiennej procesowej w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_BYTE

Funkcja NIC_BYTE przekazuje użytkownikowi wartość zmiennej procesowej w postaci liczby 8-bitowej w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - BYTE

typ zmiennej PC - BYTE

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_DD

Funkcja NIC_DD przekazuje użytkownikowi wartość zmiennej procesowej, reprezentowaną w sterowniku przez podwójne słowo, dokonując w nim zamiany miejscami starszego i młodszego słowa.

typ zmiennej PLC - DWORD

typ zmiennej PC - DWORD

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_DOUBLE

Funkcja NIC_DOUBLE przekazuje użytkownikowi wartość zmiennej procesowej tylu double w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - DOUBLE

typ zmiennej PC - DOUBLE

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

przetwarzanej.

  • Funkcja NIC_DW

Funkcja NIC_DW przekazuje użytkownikowi 32-bitową wartość zmiennej procesowej w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - DWORD

typ zmiennej PC - DWORD

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_FP

Funkcja NIC_FP przekazuje użytkownikowi wartość zmiennej procesowej typu float w postaci przekazanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - FLOAT

typ zmiennej PC - FLOAT

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

  • Funkcja NIC_INT

Funkcja NIC_INT przekazuje użytkownikowi wartość zmiennej procesowej w formie liczby 16-bitowej ze znakiem w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - INTEGER

typ zmiennej PC - INTEGER

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_INT64

Funkcja NIC_INT64 przekazuje użytkownikowi wartość zmiennej procesowej w formie liczby 64-bitowej ze znakiem w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - INTEGER 64

typ zmiennej PC - INTEGER 64

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_LONG

Funkcja NIC_LONG przekazuje użytkownikowi wartość zmiennej procesowej w formie liczby 32-bitowej ze znakiem w postaci odczytanej przez drajwer, nie dokonując żadnych dodatkowych przekształceń.

typ zmiennej PLC - LONG

typ zmiennej PC - LONG

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_KG

Funkcja NIC_KG przekazuje użytkownikowi wartość zmiennej procesowej odczytanej ze sterownika w formacie zmiennoprzecinkowym KG (specyficzny format sterowników firmy SIEMENS) i zamienionej na format zmiennoprzecinkowy zgodny z IEEE 754. Przy zapisie dokonywana jest konwersja z formatu IEEE 754 na format KG.

typ zmiennej PLC - FLOAT (KG)

typ zmiennej PC - FLOAT

Parametry:

MIN - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej;

MAX - liczba typu jak zmienna PC, nie wpływa na przeliczenie wartości, służy do określenia zakresu zmian zmiennej przetwarzanej.

  • Funkcja NIC_TEXT

Funkcja NIC_TEXT przekazuje użytkownikowi wartość zmiennej procesowej w postaci łańcucha znaków ASCII zakończonego zerem.

typ zmiennej PLC - BYTE

typ zmiennej PC - BYTE

nie posiada parametrów

  • Funkcja ON/OFF

Funkcja ON/OFF została opracowana dla celów testów prowadzonych bez udziału sterownika (przy użyciu kanału typu NONE). Pozwala ona generować przebiegi dwustanowe o zadanych wartościach.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametry:

wartość ON - WORD (wartość domyślna 1)

wartość OFF - WORD (wartość domyślna 0)

wartość początkowa - WORD (wartość domyślna 0)

  • Funkcja PILA

Funkcja PILA została opracowana dla celów testów prowadzonych bez udziału sterownika i przy użyciu kanału typu NONE. Pozwala ona generować przebiegi piłokształtne o zadanych wartościach granicznych oraz zadanym kroku zmiany wartości. Zmienna procesowa przyjmuje wartości typu INTEGER.

typ zmiennej PLC - INTEGER

typ zmiennej PC - INTEGER

Parametry:

początkowy kierunek narastania (1 - w górę, 0 - w dół) - INTEGER (wartość domyślna 1)

krok - INTEGER (wartość domyślna 1)

maksimum - INTEGER (wartość domyślna 100)

minimum - INTEGER (wartość domyślna -100)

wartość początkowa - INTEGER (wartość domyślna 0)

  • Funkcja PILA_DOUBLE

Funkcja PILA_DOUBLE została opracowana dla celów testów prowadzonych bez udziału sterownika i przy użyciu kanału typu NONE. Pozwala ona generować przebiegi piłokształtne o zadanych wartościach granicznych oraz zadanym kroku zmiany wartości. Zmienna procesowa przyjmuje wartości typu DOUBLE.

typ zmiennej PLC - DOUBLE

typ zmiennej PC - DOUBLE

Parametry:

początkowy kierunek narastania (1 - w górę, 0 - w dół) - DOUBLE (wartość domyślna 1)

krok - DOUBLE (wartość domyślna 1.0)

maksimum - DOUBLE (wartość domyślna 100.0)

minimum - DOUBLE (wartość domyślna -100.0)

wartość początkowa - DOUBLE (wartość domyślna 0.0)

  • Funkcja PILA_FP

Funkcja PILA_FP została opracowana dla celów testów prowadzonych bez udziału sterownika i przy użyciu kanału typu NONE. Pozwala ona generować przebiegi piłokształtne o zadanych wartościach granicznych oraz zadanym kroku zmiany wartości. Zmienna procesowa przyjmuje wartości typu FLOAT.

typ zmiennej PLC - FLOAT

typ zmiennej PC - FLOAT

Parametry:

początkowy kierunek narastania (1 - w górę, 0 - w dół) - INTEGER (wartość domyślna 1)

krok - FLOAT (wartość domyślna 1.0)

maksimum - FLOAT (wartość domyślna 100.0)

minimum - FLOAT (wartość domyślna -100.0)

wartość początkowa - FLOAT (wartość domyślna 0.0)

  • Funkcja PILA_INT64

Funkcja PILA_INT64 została opracowana dla celów testów prowadzonych bez udziału sterownika i przy użyciu kanału typu NONE. Pozwala ona generować przebiegi piłokształtne o zadanych wartościach granicznych oraz zadanym kroku zmiany wartości. Zmienna procesowa przyjmuje wartości typu INTEGER 64.

typ zmiennej PLC - INTEGER 64

typ zmiennej PC - INTEGER 64

Parametry:

początkowy kierunek narastania (1 - w górę, 0 - w dół) - INTEGER 64 (wartość domyślna 1)

krok - INTEGER 64 (wartość domyślna 1)

maksimum - INTEGER 64 (wartość domyślna 100)

minimum - INTEGER 64 (wartość domyślna -100)

wartość początkowa - INTEGER 64 (wartość domyślna 0)

  • Funkcja PROCENT

Funkcja PROCENT dokonuje konwersji wartości zmiennej procesowej typu INTEGER odczytanej ze sterownika do postaci typu FLOAT według równania:

PCVal = (PLCVal / k) * 100.0

oraz konwersji wartości zmiennej procesowej pisanej do sterownika z postaci FLOAT na wartość typu INTEGER według równania:

PLCVal = (PCVal / 100.0) * k

gdzie k jest parametrem funkcji.

typ zmiennej PLC - INTEGER

typ zmiennej PC - FLOAT

Parametry:

wartość odniesienia - FLOAT (wartość domyślna 2048.0)

  • Funkcja PROCENT_FP

Funkcja PROCENT_FP operuje na zmiennej procesowej typu FLOAT. Funkcja dokonuje konwersji zmiennoprzecinkowej wartości zmiennej procesowej odczytanej ze sterownika według równania:

PCVal = (PLCVal / k) * 100.0

oraz konwersji wartości zmiennoprzecinkowej pisanej do sterownika według równania:

PLCVal = (PCVal / 100.0) * k

gdzie k jest parametrem funkcji.

typ zmiennej PLC - FLOAT

typ zmiennej PC - FLOAT

Parametry:

wartość odniesienia - FLOAT (wartość domyślna 2048.0)

  • Funkcja PRZESUN_L

Funkcja PRZESUN_L przy odczycie przesuwa w lewo wartość odczytaną ze sterownika o liczbę bitów określoną przez pierwszy parametr funkcji, a następnie wykonuje operację iloczynu logicznego przesuniętej wartości i drugiego parametru funkcji.

Przy zapisie do sterownika wartość zmiennej nie jest modyfikowana.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametr:

przesunięcie (liczba z zakresu 0 - 16) (wartość domyślna 0)

liczba w formacie heksadecymalnym (wartość domyślna FFFF)

  • Funkcja PRZESUN_P

Funkcja PRZESUN_P przy odczycie przesuwa w prawo wartość odczytaną ze sterownika o liczbę bitów określoną przez pierwszy parametr funkcji, a następnie wykonuje operację iloczynu logicznego przesuniętej wartości i drugiego parametru funkcji.

Przy zapisie do sterownika wartość zmiennej nie jest modyfikowana.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametr:

przesunięcie (liczba z zakresu 0 - 16) (wartość domyślna 0)

liczba w formacie heksadecymalnym (wartość domyślna FFFF)

  • Funkcja SREDNIA

Funkcja SREDNIA liczy średnią z próbek wartości zmiennej procesowej odczytywanych ze sterownika według następujących zasad:

PCVal = MinPCVal + (PLCVal - MinPLCVal) * k

oraz konwersji zmiennej procesowej przesyłanej do sterownika według równania:

PLCVal = MinPLCVal + (PCVal - MinPCVal) * k

Współczynnik k jest wyliczany następująco:

k = (MaxPCVal - MinPCVal)/(MaxPLCVal - MinPLCVal)

Średnia liczona jest za okres Okres (podawany w minutach), a wynik uznawany jest za poprawny, jeśli stopa procentowa poprawnie odczytanych próbek wynosi Stopa.

Parametrem funkcji może być WYŁĄCZNIE liczba (wyrażona w minutach), która spełnia jeden z poniższych warunków:

dzieli godzinę na równe odcinki czasu,

dzieli dobę na równe odcinki czasu będące wielokrotnością godziny.

Wywołania Aspada muszą być zsynchronizowane z zegarem systemowym, a nie z chwilą uruchomienia asixa.

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

MinPLCVal - nie dotyczy

MaxPLCVal - nie dotyczy

MinPCVal - FLOAT (wartość domyślna 0.0)

MaxPCVal - FLOAT (wartość domyślna 2048.0)

okres - INTEGER (wartość domyślna 5)

stopa - INTEGER (wartość domyślna 80)

  • SREDNIA_Z_N

SREDNIA_Z_N zwraca aktualną wartość średniej arytmetycznej zmiennych, wymienionych w liście jako parametry i przeznaczona jest do użycia ze zmienną zadeklarowaną w kanale typu NONE. Zmienne wymienione w liście parametrów mogą być różnego typu, wartość funkcji jest konwertowana na typ FLOAT. Nie ogranicza się liczby zmiennych ani ich kolejności w deklaracji zmiennej, do której przypisano funkcję SREDNIA_Z_N. W przypadku, gdy deklaracja nie mieści się w jednej linii z powodu długiej listy nazw zmiennych, to należy ją rozdzielić na kilka linii, które (poza ostatnią) mają na końcu znak kontynuacji "\".

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

k - to minimalna liczba zmiennych poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji, wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

Val_1,..Val_n dowolnego typu, nazwy zmiennych Asmena.

Wartość funkcji jest obliczana następująco:

PCVal=(Val_1+Val_2+..+Val_n)/n

  • Funkcja STALA

Jeśli parametrem funkcji jest liczba typu INTEGER, to funkcja STALA przypisuje zmiennej procesowej wartość liczby.

Jeśli parametrem funkcji jest nazwa zmiennej procesowej, to funkcja STALA przypisuje zmiennej procesowej aktualną wartość zmiennej-parametru. Typem rzeczywistym zmiennej-parametru musi być INTEGER.

Funkcja służy tylko od odczytu.

typ zmiennej PC - INTEGER

Parametry:

IntegerVal - INTEGER (wartość domyślna 0)

lub

nazwa - STRING

  • Funkcja STALA_FP

Jeśli parametrem funkcji jest liczba typu FLOAT, to funkcja STALA_FP przypisuje zmiennej procesowej wartość liczby.

Jeśli parametrem funkcji jest nazwa zmiennej procesowej, to funkcja STALA_FP przypisuje zmiennej procesowej aktualną wartość zmiennej-parametru. Typem rzeczywistym zmiennej-parametru musi być FLOAT.

Funkcja służy tylko od odczytu.

typ zmiennej PC - FLOAT

Parametry:

FloatVal - FLOAT (wartość domyślna 0)

lub

nazwa - STRING

  • Funkcja STATUS

STATUS zwraca aktualny status zmiennej będącej parametrem funkcji.

Zmienna, która używa funkcji STATUS, musi być zdefiniowana w kanale NONE lub NETSRV.

Funkcja zezwala wyłącznie na operacje odczytu.

PRZYKŁAD

VAL, zmienna ze sterownika, KANAL_PLC,1,1,NIC

STAT, zmienna pokazująca status zmiennej VAL1,KANAL_NONE,1,1,STATUS,VAL

  • SUMA_Z_N

SUMA_Z_N zwraca aktualną wartość sumy zmiennych, wymienionych w liście jako parametry i przeznaczona jest do użycia ze zmienną zadeklarowaną w kanale typu NONE. Zmienne wymienione w liście parametrów mogą być różnego typu, wartość funkcji jest konwertowana na typ FLOAT. Nie ogranicza się liczby zmiennych ani ich kolejności w deklaracji zmiennej, do której przypisano funkcję SUMA_Z_N. W przypadku, gdy deklaracja nie mieści się w jednej linii z powodu długiej listy nazw zmiennych, to należy ją rozdzielić na kilka linii, które (poza ostatnią) mają na końcu znak kontynuacji "\".

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

k - to minimalna liczba zmiennych poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji, wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

Val_1,..Val_n dowolnego typu, nazwy zmiennych Asmena.

Wartość funkcji jest obliczana następująco:

PCVal=Val_1+Val_2+..+Val_n

  • Funkcja SUWAK

Funkcja SUWAK zeruje najstarszy bit przy odczycie wartości zmiennej procesowej ze sterownika, natomiast ustawia 1 na najstarszym bicie przy zapisie wartości zmiennej do sterownika.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

nie posiada parametrów

Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem.

  • Funkcja SUWAK1

Funkcja SUWAK1 działa podobnie do funkcji ANALOG z następującymi różnicami:

  • przy odczycie ze sterownika najstarszy bit wartości zmiennej procesowej zostaje wstępnie wyzerowany,

  • przed zapisem do sterownika najstarszy bit wartości zmiennej procesowej zostaje ustawiony na 1.

typ zmiennej PLC - WORD

typ zmiennej PC - WORD

Parametry (jak dla funkcji ANALOG):

MinPLCVal - INTEGER (wartość domyślna - 0)

MaxPLCVal - INTEGER (wartość domyślna - 2048)

MinPCVal - INTEGER (wartość domyślna - 0)

MaxPCVal - INTEGER (wartość domyślna - 2048)

Funkcja nie wykonuje operacji zapisu, jeśli została użyta dla zmiennej procesowej z kanału NONE, dla którego NIE zadeklarowano zapisu z czasem i statusem.

  • Funkcja SUWAK1_FP

Funkcja SUWAK1_FP działa podobnie do funkcji ANALOG_FP z następującymi różnicami:

  • przy odczycie ze sterownika najstarszy bit wartości zmiennej procesowej zostaje wstępnie wyzerowany,

  • przed zapisem do sterownika najstarszy bit wartości zmiennej procesowej zostaje ustawiony na 1.

typ zmiennej PLC - WORD

typ zmiennej PC - FLOAT

Parametry (jak dla funkcji ANALOG_FP):

MinPLCVal - INTEGER (wartość domyślna 0)

MaxPLCVal - INTEGER (wartość domyślna 2048)

MinPCVal - FLOAT (wartość domyślna 0.0)

MaxPCVal - FLOAT (wartość domyślna 2048.0)

  • Funkcja TAB2DOUBLE

Funkcja TAB2DOUBLE - zwraca double zbudowany na bazie wartości zmiennej tablicowej.

Parametry funkcji (oddzielone przecinkami):

a/ nazwa zmiennej tablicowej (rozmiar zmiennej tablicowej musi wynosić 8 bajtów)

b/ identyfikator typu konwersji (na razie tylko typ 1 – SENTRON)

c/ dzielnik (domyślnie 1)

UWAGA:

- zmienna korzystająca z funkcji TAB2DOUBLE musi być w kanale NONE lub NETWORK,

- funkcja może być wykorzystana wyłącznie do odczytu.

Przykład

Przykłady użycia funkcji TAB2DOUBLE:

# tablica 4-ech rejestrów HR jest rzutowana na DOUBLE

#

XXTAB, ,HR802, SENTRON, 4, 1, NIC

XXDBL, ,xxxx, NONE, 1, 1, TAB2DOUBLE, XXTAB, 1, 1000

# tablica 2-ch podwójnych rejestrów HRLM jest rzutowana na DOUBLE

#

XXTAB1, ,HRLM834, SENTRON, 2, 1, NIC_DW

XXDBL1, ,xxxx, NONE, 1, 1, TAB2DOUBLE, XXTAB1, 1, 1000

  • TABELA

TABELA przekształca wartość zmiennej źródłowej wg funkcji nieliniowej opisanej w tabeli przekazanej w pliku tekstowym, którego każda linia składa się z wartości zmiennej oraz przyporządkowanej jej wartości rzeczywistej. Linie rozpoczynające się od znaku # lub ; są ignorowane (mogą zawierać komentarz). Wartości pośrednie podlegają linearyzacji, w przypadku, gdy wartość źródłowa jest poza zakresem zadeklarowanym w pliku definicji funkcja zwraca błąd pomiaru. Zmienna, której przypisano funkcję TABELA musi być w kanale typu NONE.

Możliwe jest zadeklarowanie w sekcji Asmena ścieżki do kartoteki, w której będą przechowywane wszystkie tabele, używane przez funkcje przeliczające danej aplikacji - służy do tego celu pozycja:

SCIEZKA_TABEL=<ścieżka>

Funkcja zwraca wartość:

PCVal=f(PCVal_1)

gdzie:

PCVAL_1 - to nazwa wcześniej zadeklarowanej zmiennej Asmena;

f(x) - funkcja zdefiniowana tabelarycznie w pliku tekstowym.

typ zmiennej PC - FLOAT

Parametry:

PCVAL_1 - FLOAT|LONG|DWORD|WORD|INT16

plik_definicji - tekst

PRZYKŁAD

Przykład deklaracji zmiennej:

AAA, Opis - zmienna AAA zależna od BBB, , NONE, 1, 1, TABELA,BBB,tablica1.txt

Przykład zawartości pliku tablica1.txt definiującego tabelę:

10 15.7

20 21

30 26.4

40 32

50 37.1

Jako separatora należy użyć spacji lub tabulatora. Dla liczb ułamkowych jako separator dziesiętny musi być użyta kropka.

  • WEZ_CZAS_DW

Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Zakłada się, że:

- wartość surowa zmiennej jest typu DWORD,

- wartość zmiennej będącej pierwszym parametrem funkcji jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980,

- typ znacznika czasu określa drugi parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 2

Parametr1 = Nazwa zmiennej, której wartość (musi być typu DWORD) zostanie skonwertowana na znacznik czasu zmiennej

Parametr2 = Typ czasu przekazanego w Parametr1 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WEZ_CZAS_FP

Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Zakłada się, że:

- wartość surowa zmiennej jest typu FLOAT,

- wartość zmiennej będącej pierwszym parametrem funkcji jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980,

- typ znacznika czasu określa drugi parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 2

Parametr1 = Nazwa zmiennej, której wartość (musi być typu DWORD) zostanie skonwertowana na znacznik czasu zmiennej

Parametr2 = Typ czasu przekazanego w Parametr1 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WEZ_CZAS_LONG

Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Zakłada się, że:

- wartość surowa zmiennej jest typu LONG,

- wartość zmiennej będącej pierwszym parametrem funkcji jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980,

- typ znacznika czasu określa drugi parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 2

Parametr1 = Nazwa zmiennej, której wartość (musi być typu DWORD) zostanie skonwertowana na znacznik czasu zmiennej

Parametr2 = Typ czasu przekazanego w Parametr1 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WEZ_STCZAS_DW

Status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji.

Zakłada się, że surowa zmienna jest typu DWORD.

LiczbaParametrow = 3

Parametr1 = Nazwa zmiennej, której wartość będzie zwrócona jako status OPC. Zmienna musi być typu BYTE

Parametr2 = Nazwa zmiennej, której wartość zawiera liczbę sekund od 1.1.1970 lub 1.1.1980 (w UTC). Zmienna musi byc typu DWORD

Parametr3 = Typ czasu przekazanego w Parametr2 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WEZ_STCZAS_FP

Status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji.

Zakłada się, że surowa zmienna jest typu FLOAT.

LiczbaParametrow = 3

Parametr1 = Nazwa zmiennej, której wartość będzie zwrócona jako status OPC (zmienna musi być typu BYTE)

Parametr2 = Nazwa zmiennej, której wartość (musi byc typu DWORD) zawiera liczbę sekund od 1.1.1970 lub 1.1.1980 (w UTC)

Parametr3 = Typ czasu przekazanego w Parametr2 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WEZ_STCZAS_LONG

Status zmiennej jest równy wartości zmiennej, której nazwa jest pierwszym parametrem funkcji. Znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji.

Zakłada się, że wartość surowa zmiennej jest typu LONG.

LiczbaParametrow = 3

Parametr1 = Nazwa zmiennej, której wartość będzie zwrócona jako status OPC. Zmienna musi być typu BYTE

Parametr2 = Nazwa zmiennej, której wartość zawiera liczbę sekund od 1.1.1970 lub 1.1.1980 (w UTC). Zmienna musi byc typu DWORD

Parametr3 = Typ czasu przekazanego w Parametr2 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • WSREDNIA_Z_N

WSREDNIA_Z_N zwraca aktualną wartość średniej ważonej zmiennych, wymienionych w liście jako parametry wraz z ich wagami. Parametry używa się parami: waga_zmiennej/wartość_zmiennej. Dodatkowym parametrem poprzedzającym listę wag i zmiennych, jest liczba określająca minimalną ilość par waga/zmienna, które muszą być prawidłowo odczytane, aby wynik funkcji miał status poprawny. Zmienne wymienione w liście parametrów mogą być różnego typu. Wartość funkcji jest konwertowana na typ FLOAT. Nie ogranicza się liczby zmiennych ani ich kolejności w deklaracji zmiennej, do której przypisano funkcję WSREDNIA_Z_N. Kolejne zmienne oddzielane są spacjami. W przypadku, gdy deklaracja nie mieści się w jednej linii z powodu długiej listy nazw zmiennych, to należy ją rozdzielić na kilka linii, które (poza ostatnią) mają na końcu znak kontynuacji "\".

typ zmiennej PLC - dowolny

typ zmiennej PC - FLOAT

Parametry:

k - to minimalna liczba par waga/zmienna poprawnie odczytanych ze sterownika, przy której uznaje się poprawność wartościowania funkcji, wartość 0 oznacza, że wszystkie zmienne muszą być odczytane poprawnie. Gdy liczba poprawnie odczytanych zmiennych jest mniejsza od zadeklarowanej, to funkcja zwraca wartość przypadkową ze statusem błędu.

waga_1,wart_1,..wart_n,waga_n dowolnego typu, nazwy zmiennych Asmena.

Wartość funkcji jest obliczana następująco:

PCVal=(waga_1*wart_1+waga_2*wart_2+..+waga_n*wart_n)/(waga_1+waga_2+..+waga_n)

Przykład

Przykład deklaracji zmiennej Asmena:

SREDNIA_WAZONA, I0.2, KANAL1, 1, 1, WSREDNIA_Z_N, 0, WAGA_1 WART_1 WAGA_2 WART_2 WAGA_3 WART_3

  • ZAKRES

Funkcja ZAKRES dokonuje konwersji wartości zmiennej procesowej odczytanej ze sterownika wg równania:

PCVal = MinPLCVal + (PLCVal - MinPCVal) * k

oraz konwersji wartości zmiennej procesowej przesyłanej do sterownika wg równania:

PLCVal = MinPCVal + (PCVal - MinPLCVal) / k

gdzie:

k = (MaxPLCVal - MinPLCVal)/(MaxPCVal - MinPCVal)

PLCVal - zmienna w PLC

PCVal - zmienna w PC

typ zmiennej PLC - FLOAT

typ zmiennej PC - FLOAT

Parametry wg kolejności:

wartości min zakresu PC - FLOAT

wartości max zakresu PC - FLOAT

wartości min zakresu PLC - FLOAT

wartości max zakresu PLC - FLOAT

Przy użyciu kanału NONE, typ zmiennej jest ustawiany na FLOAT.

  • ZCZAS

Wartość i status są kopią wartości i statusu zmiennej, której nazwa jest pierwszym parametrem funkcji, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji. Zakłada się, że wartość drugiej zmiennej jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980, typ znacznika czasu określa trzeci parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 3

Parametr1 = Nazwa zmiennej, której status i wartość będą zwrócone jako status i wartość

Parametr2 = Nazwa zmiennej (musi byc typu DWORD), której wartość zostanie skonwertowana na znacznik czasu zmiennej

Parametr3 = Typ czasu przekazanego w Parametr2 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • ZCZAS_DW

Wartość i status są kopią wartości i statusu zmiennej, której nazwa jest pierwszym parametrem funkcji, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest drugim parametrem funkcji. Zakłada się, że:

- wartość zmiennej określonej przez pierwszy parametr jest typu DWORD

- wartość drugiej zmiennej jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980,

- typ znacznika czasu określa trzeci parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 3

Parametr1 = Nazwa zmiennej, której status i wartość będą zwrócone jako status i wartość (zmienna musi być typu DWORD)

Parametr2 = Nazwa zmiennej, której wartość (musi być typu DWORD) zostanie skonwertowana na znacznik czasu zmiennej

Parametr3 = Typ czasu przekazanego w Parametr2 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

  • ZSTATUS

Wartość zmiennej jest kopią statusu zmiennej, będącej parametrem funkcji.

LiczbaParametrow = 1

Parametr1 = Nazwa zmiennej, której status będzie zwrócony jako wartość funkcji

  • ZSTATUS_CZAS

Wartość jest kopią wartości zmiennej będącej pierwszym parametrem, status jest kopią statusu zmiennej będącej drugim parametrem, znacznik czasu jest tworzony z wartości zmiennej, której nazwa jest trzecim parametrem funkcji. Zakłada się, że wartość trzeciej zmiennej jest typu DWORD i zawiera liczbę sekund od 1.1.1970 lub 1.1.1980, typ znacznika czasu określa czwarty parametr funkcji (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)

LiczbaParametrow = 4

Parametr1 = Nazwa zmiennej, której wartość będzie zwrócona jako wartość zmiennej

Parametr2 = Nazwa zmiennej, której status będzie zwrócony jako status zmiennej

Parametr3 = Nazwa zmiennej (musi byc typu DWORD), której wartość zostanie skonwertowana na znacznik czasu zmiennej

Parametr4 = Typ czasu przekazanego w Parametr3 (0 - sekundy od 1.1.1970, 1 - sekundy od 1.1.1980)


6.6. Diagnostyka poprawnego formatu liczb odczytywanych ze

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.7. Diagnostyka poprawnego formatu liczb odczytywanych ze

6.7. Diagnostyka poprawnego formatu liczb odczytywanych ze sterowników

Moduł Asmen sprawdza, czy odczytywane ze sterowników liczby FLOAT są zgodne z formatem IEEE 754.

Jeśli zostanie znaleziona liczba o wartości NAN lub INF, to zmiennej (przypisanej do tej liczby) zostaje nadana wartość 0 oraz status błędu AVD_BAD. Równolegle wyprowadzany jest komunikat w oknie panelu kontrolnego zawierający typ błędu (NAN lub INF) oraz nazwę zmiennej o złym formacie. O ile został zadeklarowany plik logu dla danej aplikacji, wówczas powyższy komunikat zostanie tam zapisany.


6.7. Drajwery komunikacyjne

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.8. Drajwery komunikacyjne

6.8. Drajwery komunikacyjne

W skład systemu Asix wchodzą drajwery obsługujące następujące typy połączeń ze sterownikami obiektu przemysłowego.

Zestaw dostępnych protokołów jest systematycznie powiększany. Firma ASKOM podejmuje się, na życzenie klienta, opracowania dowolnego protokołu transmisji na zasadach określonych w cenniku systemu Asix.

Szczegółowe omówienie drajwerów komunikacyjnych znajduje się w odrębnym pliku pomocy ”Asmen - drajwery i protokoły komunikacyjne” (DrajweryKomunikacyjne.chm/pdf) - poniższej zamieszczone zostały linki, które umożliwiają wyświetlenie opisu wybranego drajwera bezpośrednio z tego pliku.

Drajwer

Protokół

ADAM

-

protokół dla sterowników ADAM firmy ADVANTECH

AGGREGATE

-

drajwer Aggregate pozwala definiować zmienne, których wartości powstają w wyniku przeliczania wartości innych zmiennych systemu Asix

AirPointer

-

komunikacja odbywa się przy pomocy protokołu HTTP przy wykorzystaniu stron info.php i download.php serwera webowego stacji monitoringu

AK

-

protokół AK dla analizatorów MLT2 f-my Emerson

AM_SA85

-

protokół do łączności z siecią Modbus Plus firmy Schneider Automation

Areva

-

protokół do komunikacji z urządzeniami MiCOM

AS511

-

protokół wykorzystujący interfejs programatora sterowników serii SIMATIC firmy SIEMENS

AS512

-

protokół procesorów komunikacyjnych CP524/525 sterowników serii SIMATIC firmy SIEMENS

AS512S7

-

protokół procesora komunikacyjnego CP340 sterowników SIMATIC S7 firmy SIEMENS

BACnetIP

protokół BACnet/ IP

BASKI

-

drajwer jest przeznaczony do importu danych z systemu imisji BASKI zainstalowanego w El. Bełchatów do systemu Asix

BAZA

-

drajwer pozwala na import danych z baz danych do systemu Asix

BUFOR

-

uniwersalny protokół wymieniający informacje z programem użytkownika poprzez wspólną pamięć

CALEC

-

drajwer Calec służy do pobierania bieżących wartości zmiennych z urządzenia CALEC MCP firmy Aquametro zgodnie z protokołem opisanym w dokumencie ”MCP Datenauslesung mit dem lowlevel Protokoll"

CAN_AC_PCI

-

protokół wymiany danych pomiędzy sterownikami SELECONTROL MAS firmy Selectron Lyss AG oraz komputerem systemu Asix

CANOPEN

-

protokół sieci CANOPEN sterowników SELECTRON MAS firmy Selectron Lyss AG

CipAB

-

protokół sterownikówserii Logix5000 firmy Allen-Bradley

COMLI

-

protokół (COMunication Link) do komunikacji ze sterownikami typu SattCon, AC 800C, AC 800M, AC 250 firmy ABB. Wymiana danych poprzez łącze szeregowe RS-232 lub RS-485

CPIII

-

protokół do komunikacji z panelami kontrolnymi CP-III/E, wykorzystywanymi do sterowania sprężarkami firmy MYCOM (MAYEKAWA)

CZAZ

-

protokół do komunikacji z urządzeniami CZAZ-U oraz CZAZ-UM

DATAPAF

-

protokół do łączności z licznikiem energii DataPAF

DDE

-

drajwer DDE służy do definiowania kanału modułu Asmen, odwołującego się do zmiennych udostępnianych przez drajwer sterownika przemysłowego zaimplementowanego w postaci serwera DDE (zwanego dalej krótko serwerem DDE)

Diva

-

protokół kamer przemysłowych DIVA firmy VDG Security B.V.

Dlms

-

protokół liczników energii elektrycznej rodziny ZxD/ZxG/ZxQ firmy Landys&Gyr

DlmsTcpip

-

protokół DLMS; do komunikacji jest wykorzystywany Ethernet

DMS285

-

protokół komputerów emisji D-MS285

DMS500

-

protokół komputerów emisji D-MS500 (poprzednia nazwa - DURAG)

DNP3

-

protokół stosowany w elektroenergetycznych systemach sterowania i nadzoru

DP

-

protokół urządzeń zgodnych z PROFIBUS DP przy wykorzystaniu karty PROFIboard

DP5412

-

protokół urządzeń zgodnych z PROFIBUS DP przy wykorzystaniu kart firmy Siemens

DSC

-

protokół do wymiany danych pomiędzy komputerem systemu Asix i sterownikiem DSC 2000

DXF351

-

protokół do komunikacji z urządzeniami Compart DXF351 firmy Endress+Hauser

Ecl

-

protokół do komunikacji z regulatorami ECL Comfort 210/310 produkowanymi przez firmę Danfoss

E2tangoTcpip

-

protokół sterowników polowych e2TANGO produkowanych przez firmę Elektrometal Energetyka

EcoMUZ

-

protokół urządzeń zabezpieczających ecoMUZ firmy JM Tronik

EcoMUZ2

-

protokół urządzeń zabezpieczających ecoMUZ-2 firmy JM Tronik

EQABP

-

protokół liczników energii elektrycznej EQABP firmy POZYTON

EQM

-

protokół liczników energii elektrycznej typu EQM firmy POZYTON w Częstochowie

Esser

-

protokół centrali p-poż Esser 8008 firmy Honeywell

FESTO

-

protokół wykorzystujący interfejs diagnostyczny dla sterowników firmy FESTO

FILE2ASIX

-

drajwer FILE2ASIX jest przeznaczony do importu danych do systemu Asix z plików tekstowych mających określoną strukturę

FP1001

-

protokół monitorów przepływu wody i pary firmy METRONIC Kraków

GFCAN

-

protokół sieci CAN przy użyciu karty komunikacyjnej firmy Garz & Fricke Industrieautomation GmbH

Global

-

drajwer CtGlobal służy do wymiany danych pomiędzy aplikacją systemu Asix a tzw. plikiem wymiany, będącym kontenerem na aktualne parametry zmiennych drajwera (nazwa, status, wartość, znacznik czasu). W aplikacji składającej się z wielu komputerów zawartość pliku wymiany może być synchronizowana pomiędzy poszczególnymi komputerami. W ten sposób można propagować na wszystkie komputery zmiany wartości zmiennych dokonywane na jednym z nich

IEC61850

-

protokół IEC61850

K3N

-

protokół wymiany danych pomiędzy sterownikami serii K3N firmy OMRON oraz komputerem systemu Asix

K-BUS

-

protokół K-BUS jest wykorzystywany do wymiany danych pomiędzy regulatorami kotłów serii Dekamatic f-my VIESSMANN dołączonymi do koncentratora Dekatel-G (lub Vitocom 200) oraz komputerem systemu Asix

LG

-

protokół sterowników LG Master-K i Glofa GM

Logo

-

protokół do wymiany danych pomiędzy systemem Asix i sterownikiem Logo OBA5 firmy SIEMENS za pomocą łącza programatora przedmiotowego sterownika

LUMBUS

-

protokół wymiany danych pomiędzy regulatorami RG72 produkowanymi przez Lubuskie Zakłady Aparatów Elektrycznych "LUMEL" w Zielonej Górze oraz komputerem systemu Asix

LZQM

-

wymiana danych z licznikami energii elektrycznej typu LZQM, produkowanymi przez Zakład Elektronicznych Urządzeń Pomiarowych POZYTON sp. z o.o. w Częstochowie. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie CLO

M200

-

drajwer komputera przepływu Spirax Sarco M200

MACMAT

-

protokół GAZ-MODEM korektorów przepływu gazu MACMAT

CtMax1000

-

komunikacja w oparciu o tzw. 'protokół sieciowy' z systemem MAX 1000 firmy ULTRAK zarządzającym pracą kamer. Drajwer realizuje wyłącznie funkcje przełączania kamer oraz synchronizacji czasu (drajwer jest źródłem czasu)

M-BUS

-

podzbiór standardowego protokołu do odczytu danych z urządzeń pomiarowych, wykorzystywany między innymi przez mierniki ciepła MULTICAL firmy KAMSTRUP A/S

MEC

-

protokół wymiany danych pomiędzy systemem Asix i licznikami ciepła MEC07 i MEC08 wyprodukowanymi przez Instytut Techniki Cieplnej w Łodzi. Wymiana danych odbywa się przy pomocy łączy szeregowych w standardzie RS-232.

MegaMuz

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany interfejs RS-485 zabezpieczeń.

MegaMuz2

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU przy pomocy łącza szeregowego.

MegaMuz_TCPIP

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany Ethernet.

MegaMuz2_TCPIP

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz2, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany Ethernet.

MELSECA

-

protokół procesora komunikacyjnego A1SJ71C24-R2 sterowników serii MELSEC-A

MEVAS

-

protokół wymiany danych pomiędzy komputerem emisyjnym MEVAS produkowanymi przez Lubuskie Zakłady Aparatów Elektrycznych "LUMEL" w Zielonej Górze oraz komputerem systemu Asix

MicroSmart

-

protokół wykorzystywany do wymiany danych ze sterownikami MicroSmart firmy IDEC

MODBUS

-

podzbiór standardowego protokołu komunikacyjnego wykorzystywany między innymi przez sterowniki Modicon firmy AEG oraz sterowniki firmy GE Fanuc

MODBUS_TCPIP

-

protokół wymiany danych pomiędzy systemem Asix i innymi komputerami/urządzeniami za pomocą protokołu MODBUS, zrealizowanego w oparciu o sieć Ethernet z protokołem TCP/IP

MODBUSSLV

-

protokół MODBUS, w którym Asix działa jako SLAVE

MPI

-

protokół interfejsu MPI sterowników SIMATIC S7 firmy SIEMENS; łącze szeregowe

MPS

-

protokół łącza szeregowego mierników parametrów sieci energetycznej MPS firmy OBR Metrologii Elektrycznej w Zielonej Górze

MSP1X

-

protokół MSP1X jest wykorzystywany do wymiany danych pomiędzy sterownikami MSP1X f-my ELMONTEX oraz komputerem systemu Asix.

Muel

-

protokół do wymiany danych pomiędzy systemem Asix i komputerem technicznym systemu MUEL

MultiMuz

-

protokół służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz_tcpip

-

protokół do komunikacji z urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz3

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz3_TCPIP

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie

MUPASZ

-

protokół kanału pustego (wirtualnego)

Mupasz710_RS

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie

MupaszRtu

-

protokół do wymiany danych pomiędzy systemem Asix i urządzeniami Mupasz2001G, Mupasz07 oraz Mupasz Compact G01 - produkowanymi przez ITR Warszawa.

MupaszRtu_TCPIP

-

protokół do wymiany danych pomiędzy systemem ASIX i mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU na łączu Ethernet poprzez port 502.

Mus04

-

protokół do wymiany danych z mikroprocesorowymi urządzeniami sterującymi MUS-04 firmy ELEKTROMETAL S.A. w Cieszynie

MUZ

-

protokół do wymiany danych pomiędzy
Mikroprocesorowymi Urządzeniami Zabezpieczającymi MUZ typu MUZ-RO

NCP

-

protokół do wymiany danych pomiędzy systemem Asix i sterownikami serii MN firmy Invensys (dawniej Satchwell)

NetLink

-

protokół MPI/Profibus do komunikacji z urządzeniami SIMATIC S7 z wykorzystaniem modułu NetLink Lite SYSTEME HELMHOLZ

NetLinkPro

-

protokół do komunikacji ze sterownikami S7 przy pomocy gateway’a NetLinkPRO (gateway Ethernet <-> MPI/Profibus). Producentem NetLinkPro jest SYSTEME HELMHOLZ

NONE

-

protokół NONE; nie realizuje fizycznego połączenia ze sterownikiem. Może być zastosowany w celu:

  • testowania aplikacji w trybie symulacji,

  • umożliwienia wymiany informacji pomiędzy programami systemu Asix za pomocą zmiennych procesowych

NordicRF

-

wymiana danych z czytnikiem kodów kreskowych Nordic ID RF 601. Komunikacja odbywa się przy wykorzystaniu łącza szeregowego RS-232 stacji bazowej

OMRON

-

do wymiany danych ze sterownikami OMRON

OmronTcpip

-

protokół FINS

OPC

-

protokół do wymiany danych między systemem Asix a dowolnym sterownikiem przemysłowym lub programem klasy SCADA, dla którego dostępny jest serwer danych zgodny ze specyfikacją OPC 1.0 lub OPC 2.05

PA5

-

drajwer protokołu liczników przepływu PA5

PD21

-

protokół do komunikacji z koncentratorem PD21 produkowanym przez LUMEL S.A. Zielona Góra

Pmc4000

-

służy do wymiany danych pomiędzy systemem Asix i centralą ppoż POLON 4800 wg protokołu PMC-4000

PPI

-

protokół dla sterowników SIEMENS S7 serii 200

Protherm300

-

driver do wymiany danych pomiędzy systemem Asix i sterownikiem Protherm 300 DIFF firmy Process-Electronic GmbH

PROTRONICPS

-

PROTRONIC PS firmy Hartmann & Braun

S700

-

protokół S700 jest wykorzystywany do wymiany danych pomiędzy analizatorami gazu serii S700 firmy Maihak oraz komputerem systemu Asix.

S7_TCPIP

-

protokół wykorzystywany do wymiany danych ze sterownikami SIMATIC serii S7 poprzez łącze Ethernet przy wykorzystaniu standardowej karty sieciowej komputera

SAPIS7

-

protokół sterowników SIMATIC S7 poprzez łącze MPI lub poprzez procesor komunikacyjny magistrali PROFIBUS (implementacja funkcji S7)

S-BUS

-

protokół S-BUS jest wykorzystywany do wymiany danych pomiędzy sterownikami PCD firmy SAIA Burgess Electronics oraz komputerem systemu Asix

SbusTcpip

-

do wymiany danych pomiędzy systemem Asix i rodziną sterowników PCD SAIA-Burgess przy wykorzystaniu protokołu Ethernet S-Bus

SINECH1

-

protokół procesora komunikacyjnego CP1430 sterowników SIMATIC S5 (Ethernet)

SINECL2

-

protokół procesorów komunikacyjnych CP5430 sterowników serii SIMATIC firmy SIEMENS

Si400

-

protokół przeznaczony do wymiany danych pomiędzy systemem Asix i centralą alarmową Sintony SI 400 firmy SIEMENS

SNG

-

protokół do komunikacji z urządzeniami instalacji SNG firmy Synergia Tech z Warszawy

SNMP

-

drajwer umożliwia odczyt i zapis wartości obiektów protokołu SNMPv1 i SNMPv2c - zarządzania różnymi elementami sieci telekomunikacyjnych, takimi jak routery, przełączniki, komputery czy centrale telefoniczne. Drajwer realizuje swoje funkcje za pomocą SNMP Management API

SNPX

-

służy do wymiany danych pomiędzy systemem Asix i jednostkami centralnymi sterowników serii 90-30 oraz modułami CMM i PCM serii 90 firmy GE Fanuc

Sp100H

-

protokół sterowników SP-100H centrali deszczowej Aqua Center Industrial 100 H 14-60 firmy MARLEy Polska Sp. z o.o.

SPA

-

protokół wykorzystywany do komunikacji z urządzeniami podłączonymi do magistrali SPA firmy ABB

Srio

-

wymiana danych z koncentratorem SRIO 500M (prod. ABB) komunikującym system nadrzędny z urządzeniami podłączonymi do magistrali SPA, np. zabezpieczeniami przekaźnikowymi i urządzeniami sygnalizacyjnymi. Komunikacja z koncentratorem jest realizowana przy pomocy łączy szeregowych w standardzie RS232, warstwa transportu danych - w oparciu o protokół ANSI X3.28 w trybie full-duplex z sumą kontrolną BCC

SRTP

-

drajwer jest przeznaczony do wymiany danych pomiędzy systemem Asix i sterownikami firmy GE Fanuc Automation serii VersaMax Nano/Micro przy wykorzystaniu konwertera IC200SET001 oraz sterownikami serii WersaMax i Series 90, przy wykorzystaniu modułu komunikacyjnego IC693CMM321, po sieci Ethernet z protokołem TCP/IP.

TALAS

-

protokół komputerów emisji TALAS

TwinCAT

-

przeznaczony do wymiany danych pomiędzy systemem Asix i systemem TwinCAT firmy Beckhoff Industrie Elektronik

Wago

-

protokół do wymiany danych ze sterownikami Wago

Vantage

-

protokół stacji pogodowych rodziny Vantage Pro produkowanych przez Davis Instruments Corp. USA

ZDARZENIE ZMIENNA

-

drajwer do generowania zmiennych procesowych typu WORD (słowo 16 bitowe) na podstawie bieżących wartości zdarzeń alarmowych w systemie Asix

ZxD400

-

drajwer protokołu liczników energii serii ZxD400 f-my Landys & Gyr


6.8. Wymiana danych poprzez lokalną sieć komputerową

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.9. Wymiana danych poprzez lokalną sieć komputerową

6.9. Wymiana danych poprzez lokalną sieć komputerową

Lokalna sieć komputerowa może być wykorzystana do stworzenia takiej konfiguracji systemu A six, w której tylko część komputerów (serwery danych) ma bezpośrednie połączenie ze sterownikami, natomiast pozostałe komputery (stacje robocze) korzystają z informacji udostępnianych przez serwery danych za pośrednictwem lokalnej sieci komputerowej.

Kanały transmisji systemu Asix służące do pozyskiwania danych poprzez lokalną sieć komputerową noszą nazwę kanału sieciowego.

Wymiana danych w lokalnej sieci komputerowej pomiędzy stacjami systemu A six jest realizowana przez moduł NETSRV. Moduł ten jest ładowany automatycznie przy instalacji A sixa.

Konfiguracji sieci dokonuje się za pomocą programu Architekt w pliku konfiguracyjnym aplikacji.

Patrz: Architekt > Konfiguracja parametrów danych bieżących dotyczących serwera sieci .


6.8.1. Deklaracja kanału sieciowego

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.9. Wymiana danych poprzez lokalną sieć komputerową > 6.9.1. Deklaracja kanału sieciowego

6.9.1. Deklaracja kanału sieciowego

Parametry służące do deklaracji kanałów sieciowych obejmują:

Nazwa - nazwa logiczna kanału sieciowego,

NETWORK - nazwa drajwera,

Sieciowa nazwa serwera - nazwa komputera, który może pełnić rolę serwera danych (opcja).

program Architekt > Obszary i komputery > Dane bieżące > dodana pozycja kanału dla drajwera NETWORK > zakładka Standardowe > Parametry:

Nazwa

Drajwer: NETWORK

Rysunek: Deklaracja kanału NETWORK.

Architekt > Obszary i komputery > Dane bieżące > dodana pozycja kanału dla drajwera NETWORK > zakładka Network> Parametry:

Sieciowa nazwa serwera

Rysunek: Deklaracja komputerów pełniących rolę serwerów danych.

Deklaracja oznacza, że wartości zmiennych procesowych zadeklarowanych w kanale sieciowym nazwa_logiczna, będą pochodziły z serwera danych, na którym zadeklarowano kanał transmisji mający identyczną nazwę logiczną, jak przedmiotowy kanał sieciowy. Przedmiotowy kanał transmisji serwera danych musi spełniać jeden z poniższych warunków:

- obsługuje bezpośrednie połączenie ze sterownikiem,

- jest kanałem typu NONE,

- jest kanałem sieciowym komputera działającego w trybie POMOST ( [image] Patrz: Praca stacji roboczej w trybie POMOST).

Jeśli w deklaracji kanału sieciowego nie podano nazw serwerów danych, to stacja robocza będzie się mogła przyłączyć do dowolnego serwera danych, dysponującego wymaganym kanałem transmisji. W przeciwnym razie zakres serwerów będzie ograniczony do tych komputerów, których nazwy umieszczono w deklaracji kanału sieciowego.

W nazwach komputerów sieciowych nie są rozróżniane duże i małe litery.


Deklaracja zmiennych procesowych w kanałach sieciowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.9. Wymiana danych poprzez lokalną sieć komputerową > 6.9.2 Deklaracja zmiennych procesowych w kanałach sieciowych

6.9.2 Deklaracja zmiennych procesowych w kanałach sieciowych

Aby stacja robocza mogła uzyskać zmienną procesową z serwera danych, muszą być spełnione następujące warunki:

  • zmienna procesowa używana na stacji roboczej musi być zadeklarowana na serwerze danych,

  • deklaracja zmiennej procesowej na serwerze danych i deklaracja zmiennej procesowej na stacji roboczej muszą być identyczne.

Jeśli jeden z tych warunków nie będzie spełniony, to na etapie logowania się do serwera danych na panelu operatorskim stacji roboczej zostanie wyprowadzony komunikat o błędnie zadeklarowanej zmiennej procesowej.


6.8.3. Praca stacji roboczej w trybie POMOST

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.9. Wymiana danych poprzez lokalną sieć komputerową > 6.9.3. Praca stacji roboczej w trybie POMOST

6.9.3. Praca stacji roboczej w trybie POMOST

W typowych zastosowaniach systemu Asix serwery danych udostępniają jedynie te dane, które pochodzą z kanałów fizycznych (bezpośrednie połączenie ze sterownikiem). Istnieją jednak specyficzne rozwiązania, w których stacja robocza musi pełnić rolę serwera danych dla innych stacji roboczych. Sytuacja taka jest typowa w konfiguracjach, w których stacja robocza systemu Asix jest pomostem (gateway) pomiędzy dwiema lokalnymi sieciami komputerowymi. W takim przypadku kanały sieciowe stacji roboczej muszą być traktowane na równi z kanałami fizycznymi w zakresie udostępniania danych w lokalnej sieci komputerowej. Ten tryb pracy stacji roboczej jest określany mianem pracy w trybie POMOST.

Praca stacji roboczej w trybie POMOST deklarowana jest przy użyciu parametru Tryb Pomost:

Architekt > Obszary i komputery > moduł Dane bieżące - serwer sieci > zakładka Standardowe.

W sekcji tej deklaruje się wszystkie opcje pracy programu netsrv.dll, który realizuje pracę Asixa w trybie pomost (gateway).

Rysunek: Deklaracja pracy stacji w trybie POMOST.


6.8.4. Redundancja

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 6. Asmen - Menedżer komunikacyjny > 6.9. Wymiana danych poprzez lokalną sieć komputerową > 6.9.4. Redundancja

6.9.4. Redundancja

W celu podniesienia niezawodności komunikacji ze sterownikami w systemie Asix zaimplementowano redundantne kanały transmisji. Pozwalają one na dostęp do źródła danych zastępczym kanałem sieciowym w sytuacji, kiedy podstawowy kanał transmisji nie działa poprawnie.

Rys. Klasyczne archiwum - archiwizacja danych z modułu Asmen.

Rys. Klasyczne archiwum - redundancja (dwa lub więcej serwerów).

Redundancja może być deklarowana jedynie dla kanałów fizycznych, tzn. takich, które wykorzystują bezpośrednie połączenie ze sterownikiem.

Parametry, służące do deklaracji kanałów redundantnych, deklarowane są za pomocą opcji Redundancja dla każdego kanału indywidualnie. Opcja dostępna jest w:

Architekt > Obszary i komputery > moduł Dane bieżące > pozycja zadeklarowanego kanału > zakładka Zaawansowane:

opcja Redundancja:

serwer_1, serwer_2, ..., serwer_n

gdzie:

serwer_i - nazwa komputera systemu Asix, na którym należy szukać kanału zastępczego

Deklaracja opcji Redundancja oznacza, że w przypadku błędów transmisji w kanale transmisji nazwa_logiczna, dane pomiarowe będą pochodziły z serwera danych, na którym zadeklarowano kanał transmisji mający identyczną nazwę nazwa_logiczna.

Jeśli w deklaracji kanału redundantnego nie podano nazw serwerów danych, to kanał zastępczy będzie mógł być udostępniony przez dowolny serwer danych, dysponujący wymaganym kanałem transmisji. W przeciwnym razie kanał zastępczy będzie poszukiwany jedynie na tych serwerach danych, których nazwy umieszczono w deklaracji kanału redundantnego.

Na stacji Asixa st1, poprzez którą są realizowane sterowania z innej stacji Asixa st2, w przypadku redundancji, powinno być zadeklarowanie zezwolenie wykonania tych sterowań:

Architekt > Obszary i komputery > moduł Dane bieżące > pozycja zadeklarowanego kanału > zakładka Zaawansowane:

opcja Zezwolenie zapisu:

stacja_1, stacja_2, ..., stacja_n

gdzie:

stacja_i - nazwa komputera systemu Asix, która posiada uprawnienia do zdalnego sterowania w tym kanale


7. Program Archiwizacji Danych Aspad

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad

7. Aspad - Program Archiwizacji Danych

Aspad jest modułem systemu Asix przeznaczonym do rejestracji i późniejszego odtwarzania przebiegów czasowych zmiennych. W systemie Asix przebiegi te są wykorzystywane przy tworzeniu wykresów i raportów, a także mogą być użyte przez przeliczniki do obliczania syntetycznych zmiennych oraz eksportowane za pośrednictwem programu AsixConnect w formacie DDE lub OLE do innych programów, np. EXCEL.


7.1.1. Podstawowe cechy programu Aspad

Program Aspad dla wersji pakietu Asix charakteryzuje się następującymi cechami:

  • Pozwala na archiwizację zmiennych każdego typu dozwolonego w module Asmen, pod warunkiem, że są to zmienne skalarne. Mogą to być zarówno zmienne procesowe, jak i uzyskiwane w wyniku przeliczeń lub symulacji. W obecnej wersji nie można archiwizować tablic.

  • Oprócz wartości i czasu przechowuje także status wartości zgodny ze standardem OPC.

  • Gromadzi dane zarówno w plikach o specjalnie zaprojektowanej strukturze (archiwum D, M, Y z podziałem na pliki odpowiednio dobowe, miesięczne lub roczne), jak i w typowych bazach danych (archiwum B).

  • Dla typu B umożliwia pozyskiwanie danych historycznych z urządzeń z pamięcią.

  • Dla typu B pozwala na archiwizację danych napływających asynchronicznie i niesekwencyjnie, np. z systemów telemetrycznych.

  • Umożliwia budowanie mniej lub bardziej złożonych warunków archiwizacji poszczególnych zmiennych.

  • Dla typów D, M i Y oszczędza pamięć dyskową, zapamiętując jedynie istotne zmiany archiwizowanych wartości oraz stosując proste metody kompresji.

  • Dzięki odpowiedniej strukturze wewnętrznej plików umożliwia szybki dostęp do danych pochodzących z dowolnego okresu.

  • Pozwala na podział archiwum na pliki dobowe, miesięczne lub roczne.

  • Umożliwia deklarowanie czasu przechowywania plików typu D, M i Y, po którym stare pliki będą automatycznie usuwane (przy czym przez 10 % zadanego czasu są jeszcze zachowywane ich tymczasowe kopie, dla uniknięcia problemów przy przypadkowych zmianach czasu komputera).

  • Używa konwencji nazw plików, z dołączoną nazwą zasobu i czytelnym kodowaniem czasu aż do 9999 roku.

  • Może aktywnie archiwizować lub tylko odtwarzać stare dane.

  • Udostępnia dane w sieci.

  • Pozwala na podział zmiennych archiwizowanych na grupy przypisane do oddzielnych zasobów archiwizowanych w oddzielnych plikach, w oddzielnych lokalizacjach, oddzielnie parametryzowanych i zarządzanych.

  • Umożliwia określenie, z której stacji w sieci należy pobierać dane dla określonych zasobów,

  • Zezwala na automatyczne tworzenie kopii zapasowych plików archiwalnych oddzielnie dla każdego zasobu i rodzaju pliku. Można określać, ile ostatnich plików ma się znaleźć na nośniku zapasowym.

  • Za pośrednictwem modułu AsixConnect udostępnia dane niezależnym programom działającym w systemie Windows.

  • Pozwala na przygotowanie i późniejsze odtwarzanie przebiegów wzorcowych.

  • Umożliwia pracę w trybie gorącej rezerwy, uzupełniając dane z innych stacji o identycznym archiwum.

  • Pozwala na określenie, którym stacjom w sieci mogą być udostępnione zgromadzone dane.

  • Udostępnia interfejs programowy dla dynamicznej parametryzacji w trakcie działania oprogramowania Asix.

  • Umożliwia zadawanie parametrów archiwizacji przebiegów bezpośrednio z bazy zmiennych systemu Asix.

  • W pakiecie udostępniony jest także program AspadTools, który pozwala na:

  • zmianę konwencji nazw ze starej (Aspad 5) na nową (Aspad 6) i odwrotnie;

  • konwersję archiwum na inny typ (np. M na D);

  • eksport do pliku tekstowego;

  • sprawdzenie i naprawę archiwum;

  • zbieranie statystyk dotyczących wielkości danych dla poszczególnych zarchiwizowanych przebiegów zmiennych;

  • zmianę nazwy lub usuwanie zmiennej z pliku archiwalnego.

Opis programu AspadTools można znaleźć w podręczniku AspadTools.pdf.


7.1.3. Parametry konfiguracyjne modułu Aspad

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.2. Parametry konfiguracyjne modułu Aspad

7.1.2. Parametry konfiguracyjne modułu Aspad

Parametry Aspada są deklarowane w pliku konfiguracyjnym aplikacji przy użyciu programu Architekt:

Architekt > Obszary i komputery > moduł Dane Archiwalne

Patrz: część "Architekt - Parametryzacja aplikacji", rozdz. 4.8 Konfiguracja danych archiwalnych


7.1.2. Podstawowe rodzaje i typy archiwum Aspada

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.3. Podstawowe rodzaje i typy archiwum Aspada

7.1.3. Podstawowe rodzaje i typy archiwum Aspada

Podstawowym rodzajem archiwum jest STANDARD. Archiwum to jest zapisywane w binarnych plikach na dysku.

Drugim rodzajem archiwum jest MSSQL. Jest to archiwum zapisywane w bazie danych MS SQL.

Aspad gromadzi dane w plikach zawierających przebiegi z jednego okresu dobowego, miesięcznego lub rocznego odpowiednio do typu archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

Aspad zapewnia dostęp do danych ze wszystkich okresów, których pliki znajdują się w kartotekach wskazanych przy parametryzacji.

Archiwa typu H (z horyzontem - ang. horizon) są przechowywane w jednym pliku dla określonej grupy zmiennych. Dane starsze niż zadany horyzont są automatycznie zapominane, a miejsce w pliku jest odzyskiwane do dalszej archiwizacji. Ten typ archiwum można stosować do tymczasowej archiwizacji dodatkowych przebiegów, np. do szybkiej rejestracji niektórych przebiegów w celach diagnostycznych. W obecnej wersji zaleca się w tym celu stosowanie archiwum D z zadanym horyzontem przechowywania plików, a archiwum H zachowano jedynie dla zachowania zgodności z poprzednimi wersjami programu Aspad.

Archiwizacja dla typu B to gromadzenie wartości w bazie danych. Aktualnie są to bazy danych w standardzie MS SQL. Nadaje się on do rejestracji wartości z małą częstotliwością dając w zamian dużą elastyczność przy korzystaniu z takiej bazy danych, a także możliwość uzupełniania danych w archiwum.

Oprócz wymienionych sposobów archiwizacji można także generować przebiegi wzorcowe, traktując je później podobnie jak archiwum. Przebiegi tego typu oznaczone są literą P (ang. pattern).

Można jeszcze wyróżnić podział archiwum ze względu na sposób udostępniania danych:

Archiwum do zapisu - podstawowe archiwum pozwalające na zapis i odczyt danych z plików archiwalnych;

Archiwum do odczytu - to archiwum pozwalające tylko na odczyt danych z plików archiwalnych;

Archiwum sieciowe - to archiwum pozwalające na odczyt danych przez sieć z innego komputera;

Archiwum pomocnicze - to archiwum pozwalające na zapis i odczyt danych, służące jako redundancja archiwum podstawowego na innym komputerze;

Archiwum replikowane - archiwum pozwalające na zapis i odczyt danych z archiwum; dane do archiwum pobierane są z archiwum innego komputera.

Patrz: sposób parametryzacji poszczególnych archiwów w Architekt > Parametryzacja archiwum .

Archiwum pomocnicze jest to archiwum do zapisu umieszczane na serwerze pomocniczym danego zasobu. Archiwum pomocnicze powinno stanowić redundancję archiwum podstawowego na serwerze podstawowym. Różnica między archiwum pomocniczym a archiwum podstawowym polega na preferencjach dla archiwum podstawowego podczas przyłączania klientów sieciowych. Klient przyłączy się do archiwum pomocniczego tylko wtedy, gdy w sieci nie znajdzie archiwum podstawowego.

Archiwum pomocnicze jest stosowane w celu zapewnienia tymczasowej redundancji na czas konserwacji lub awarii serwera podstawowego. Można np. zadeklarować archiwum podstawowe ze 100-dniowym horyzontem i archiwum pomocnicze z horyzontem 10-dniowym. Pozwoli to na uzupełnienie archiwum podstawowego za okres przerwy nie przekraczającej 10 dni, przy czym w obecności serwera podstawowego klienty przyłączą się do niego, zapewniając obserwację danych z horyzontem 100-dniowym.

Archiwum replikowane ma być stosowane na serwerach, na których Asmen nie ma kanałów fizycznych dla danych archiwizowanych w danym zasobie, a równocześnie w sieci dostępne jest inne archiwum, z którego można pozyskać dane historyczne. Dla archiwum replikowanego Aspad nie pobiera danych bieżących z Asmena. W zamian stale pozyskuje dane historyczne z innego serwera, na którym archiwizowane są dane z kanałów fizycznych, zapisując je we własnym archiwum. Typowym zastosowaniem będą serwery pośredniczące.

Sposób działania nieco się różni dla archiwum standardowego i SQL.

Archiwum standardowe

Dla archiwum standardowego Aspad po uzupełnieniu danych przy starcie systemu, kontynuuje to uzupełnianie, cyklicznie sprawdzając nowe dane pojawiające się na drugim serwerze. Nawet dłuższe przerwy w komunikacji są na bieżąco nadrabiane po uzyskaniu łączności, aż do ograniczenia podanego w deklaracji: program Architekt > Obszary i komputery > Dane archiwalne > <zadeklarowane archiwum> > zakładka Uzupełnianie > opcja Minimalny okres uzupełniania.

Także w zakładce Uzupełnianie można określić nazwy serwerów, z których mają być pobierane dane do replikacji.

Opcja Bez uzupełniania na zakładce Uzupełnianie dla takiego archiwum nie ma sensu i jest ignorowana.

Archiwum SQL

Jeżeli dla danego zasobu nie podano deklaracji synchronizacji archiwum SQL, to archiwum replikowane działa tak samo, jak standardowe.

Jeżeli zadeklarowano opcję Synchronizacja w Architekt > Obszary i komputery > Dane archiwalne > <archiwum> > zakładka Synchronizacja, to dane są tylko synchronizowane na poziomie baz danych SQL, a wyłączone jest zarówno pobieranie danych bieżących z Asmena, jak i uzupełnianie przez Aslinka.

Synchronizacja ma tą przewagę nad zwykłym uzupełnianiem, że uwzględnia wszystkie zmiany w archiwum, także dane historyczne dopisywane lub zmieniane z opóźnieniem.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.3. Podstawowe rodzaje i typy archiwum Aspada > 7.1.3.1. Archiwum replikowane

7.1.3.1. Archiwum replikowane

Jak działa archiwum replikowane?

Archiwum replikowane ma zastosowanie na serwerach, na których Asmen nie ma kanałów fizycznych dla danych archiwizowanych w danym zasobie, a równocześnie w sieci dostępne jest inne archiwum, z którego można pozyskać dane historyczne. Dla archiwum replikowanego Aspad nie pobiera danych bieżących z Asmena. W zamian stale pozyskuje dane historyczne z innego serwera, na którym archiwizowane są dane z kanałów fizycznych, zapisując je we własnym archiwum. Typowym zastosowaniem są serwery pośredniczące.

Sposób działania nieco się różni dla archiwum standardowego i SQL.

Archiwum standardowe

Dla archiwum standardowego Aspad po uzupełnieniu danych przy starcie systemu, kontynuuje to uzupełnianie (replikuje dane), cyklicznie sprawdzając nowe dane pojawiające się na drugim serwerze. Nawet dłuższe przerwy w komunikacji są na bieżąco nadrabiane po uzyskaniu łączności, aż do ograniczenia podanego w deklaracji Minimalny okres uzupełniania na zakładce Uzupełnianie w parametrach danego archiwum.

Także na wspomnianej zakładce Uzupełnianie można określić nazwy serwerów, z których mają być pobierane dane do replikacji.

Rys. Klasyczne archiwum - archiwizacja danych z modułu Asmen.

Rys. Archiwum replikowane - realizacja architektury kolektor-serwer.

Archiwum SQL

Jeżeli dla danego zasobu nie podano deklaracji synchronizacji archiwum SQL, to archiwum replikowane działa tak samo, jak standardowe.

Jeżeli zadeklarowano opcję Synchronizacja w Architekt > Obszary i komputery > Dane archiwalne > <archiwum> > zakładka Synchronizacja, to dane są tylko synchronizowane na poziomie baz danych SQL, a wyłączone jest zarówno pobieranie danych bieżących z Asmena, jak i uzupełnianie przez Aslinka.

Rys. Synchronizacja na poziomie baz danych SQL.

Synchronizacja ma tę przewagę nad zwykłym uzupełnianiem, że uwzględnia wszystkie zmiany w archiwum, także dane historyczne dopisywane lub zmieniane z opóźnieniem.

Deklaracja

Deklaracja wygląda dokładnie tak samo, jak archiwum do zapisu:

Architekt > Obszary i komputery > Dane archiwalne > <dodana pozycja archiwum> > zakładka Standardowe > opcja Archiwum replikowane

Jakie problemy pozwala wyeliminować archiwum replikowane?

Przy zastosowaniu pozostałych dostępnych typów archiwum moduł Aspad pozyskuje dane do archiwizacji na 3 sposoby:

1. Dane bieżące lub historyczne pobiera z modułu Asmen.

2. Podczas startu uzupełnia brakujące dane z innego serwera za czas wyłączenia Asixa.

3. Synchronizuje dane archiwum SQL z innym serwerem, jeżeli podano dla tego archiwum deklarację synchronizacji.

Na serwerach, gdzie ASMEN nie ma swoich kanałów fizycznych takie rozwiązanie ma kilka wad:

1. Archiwizowane dane muszą być dostarczane kanałami sieciowymi Asmena nie rzadziej niż okres archiwizacji. W konsekwencji:

a. jeżeli Asmen nie zdąży przekazać danych z takim cyklem, to ma tylko jeden dodatkowy cykl na nadrobienie zaległości; później pojawia się dziura w archiwum;

b. jeżeli okres odświeżania Asmena jest krótszy niż Aspada, to dane są dostarczane częściej niż jest to potrzebne.

2. Przy chwilowym braku komunikacji z źródłem danych powstaje dziura w archiwum, która nie jest uzupełniana. Wyjątkiem jest archiwum SQL z deklaracją synchronizacji.

3. Jeżeli zadeklarowano Archiwum do zapisu oraz zadeklarowano synchronizację, to dane do archiwum SQL dostarczane są podwójnie: pierwszy raz jako dane bieżące Asmena, a drugi jako dane z synchronizacji z drugim archiwum.

Archiwum replikowane powstało w celu wyeliminowania powyższych niedogodności.

Gdzie stosować archiwum replikowane?

Wybór pomiędzy archiwum replikowanym a zwykłym archiwum do zapisu zależy głównie od 2 czynników: czy na danej stacji Asmen dostarcza dane z kanałów fizycznych, czy też sieciowych oraz jak szybko dane historyczne mają się pojawiać na wykresach w przelicznikach, skryptach, itd.

Dane z kanałów fizycznych, czy sieciowych

Jeżeli zastosujemy archiwum replikowane, to dane do archiwizacji będą zawsze pobierane z archiwum innego komputera. Będzie tak nawet wtedy, gdy chwilowo ten inny komputer jest wyłączony, co oznacza, że w naszym archiwum znajdą się tylko te dane, które były wcześniej zarchiwizowane w innym i będzie brakowało danych za czas jego wyłączenia. Utracilibyśmy w ten sposób zdolność korzystania z redundantnych kanałów Asmena na naszym komputerze.

Wnioski:

1. Archiwum replikowane zwykle nadaje się do zastosowania na serwerach pośredniczących (z uwagą o opóźnieniu dostarczanych danych).

2. Archiwum replikowanego nie należy stosować na redundantnych stacjach operatorskich.

3. Archiwum replikowane może być zastosowane na stacji operatorskiej, na której wszystkie dane tego archiwum pochodzą z kanałów sieciowych i mogą być pobrane z bliźniaczego archiwum komputera, który posiada kanały fizyczne dla tych danych.

Opóźnienie danych

Dane archiwizowane z dostarczanych danych bieżących (w pozostałych typach archiwum) są dostępne praktycznie natychmiast, czyli mogą być na bieżąco obserwowane na wykresach, czy też użyte w skryptach lub przelicznikach.

W przypadku danych replikowanych serwer wysyła dane nie częściej niż raz na dziesięć sekund, a w przypadku archiwum SQL nie częściej niż podano w deklaracji synchronizacji (o ile taką deklarację zastosowano). Dopiero po ich dostarczeniu dane będą dostępne na stacji z archiwum replikowanym.

Dane będą przy tym opatrzone prawidłowymi znacznikami czasu, a jedynie opóźni się ich pojawienie w archiwum.

Wnioski:

1. Archiwum replikowane można stosować tam, gdzie nie jest istotne opóźnienie pojawienia się danych historycznych w stosunku do danych bieżących.

2. Nie wolno stosować archiwum replikowanego na stacjach, na których wykres musi nadążać z dokładnością do sekund za danymi bieżącymi.

3. Nie wolno stosować archiwum replikowanego na stacjach, na których skrypty lub przeliczniki nie są odporne na opóźnione pojawienie się danych historycznych.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.4. Cechy archiwizacji prowadzonej w plikach o dedykowanym formacie

7.1.4. Cechy archiwizacji prowadzonej w plikach o dedykowanym formacie

Cechy archiwizacji prowadzonej w plikach o dedykowanym formacie:

• nielimitowana liczba zmiennych rejestrowanych;

• maksymalna częstotliwość próbkowania = 1 s;

• kompresja danych – surowa próbka (10 bajtów) podlega kompresji, co wielokrotnie zmniejsza jej pojemność; stosowane są dwa rodzaje kompresji:

• w pierwszej kolejności pomijane są próbki z nieistotną zmianą wartości (tzw. strefa nieczułości);

• w drugim etapie zapisana próbka poddawana jest kompresji, zmniejszającej jej objętość typowo do 1-3 bajtów;

• typy danych archiwalnych: bajt, pojedyncze/podwójne słowo, zmienny przecinek;

• automatyczne zarządzanie biblioteką archiwum;

• wyliczanie i archiwizowanie szeregu predefiniowanych agregatów radykalnie przyśpieszających zaawansowaną analizę danych; efekt przyśpieszenia jest szczególnie zauważalny w instalacjach sieciowych, gdzie wiele stanowisk jednocześnie korzysta z zasobów jednego serwera;

• uzupełnianie „w locie” luk w archiwum, jeśli tylko w sieci zidentyfikowany został (samoczynnie) inny komputer posiadający w swoim archiwum brakujące dane. Mechanizm ten umożliwiaa realizację systemów, w którym centralna baza danych procesowych przechowywana w dedykowanym formacie plików A six, zostanie wcześniej czy później automatycznie uzupełniona o brakujące informacje.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.5. Cechy archiwizacji prowadzonej w relacyjnej bazie danych SQL

7.1.5. Cechy archiwizacji prowadzonej w relacyjnej bazie danych SQL

Archiwizacja danych prowadzona w relacyjnej bazie danych SQL:

• nielimitowana liczba zmiennych rejestrowanych;

• maksymalna częstotliwość próbkowania = 1 s;

• wsteczne uzupełnianie danych historycznych wymagane np.:

• w systemach dyspozytorskich ze zbieraniem danych na łączach modemowych, w paczkach za określony przedział czasu;

• w komunikacji z urządzeniami umożliwiającymi buforowanie danych pomiarowych, po przerwie spowodowanej brakiem

komunikacji.

• typy danych archiwalnych: bajt, pojedyncze/podwójne słowo, zmienny przecinek.


Agregacja danych w systemie Asix

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.1. Ogólna charakterystyka programu Aspad > 7.1.6. Agregacja danych w systemie Asix

7.1.6. Agregacja danych w systemie Asix

Od wersji 5 systemu Asix dostępny jest mechanizm wyliczania i archiwizowania predefiniowanych agregatów radykalnie przyśpieszających zaawansowana analizę danych archiwalnych. Efekt przyśpieszenia jest szczególnie zauważalny w instalacjach sieciowych, gdzie wiele stanowisk jednocześnie korzysta z zasobów jednego serwera ( [image] patrz: 7.10. Agregacja danych archiwalnych).


7.2. Moduły związane z Aspadem

W skład modułów Aspada wchodzą:

ASPAD.DLL - podstawowy moduł programu Aspad,

ASBDE.DLL - moduł dostępu do bazy danych typu Paradox - wymagana wersja zgodna z modułem ASPAD.DLL,

PGEN.EXE - program generacji przebiegów wzorcowych,

BBROWSE.EXE - program przeglądarki bazy danych,

ASPADTOOLS.EXE - narzędzia do konserwacji plików archiwalnych,

ASSQL.DLL - moduł dostępu do bazy danych typu SQL.


7.3. Wymagania systemowe

Aspad jest przeznaczony do współpracy z innymi modułami systemu Asix działającymi w systemach: Microsoft Windows 7 SP1, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows Server 2008R2 SP1, Microsoft Windows Server 2012. Jest on dostarczany jako biblioteka DLL. Ładowanie biblioteki odbywa się automatycznie podczas ładowania Asixa.

Dla zapewnienia poprawnej pracy Aspada konieczne jest, by Asmen został sparametryzowany tak, aby dostarczał wszystkie archiwizowane dane.

Dla prawidłowej pracy w sieci wymagany jest także moduł Aslink wraz z oprogramowaniem sieciowym.

Dodatkowo w przypadku pracy z archiwum B i przebiegami wzorcowymi P pakiet zapewnia instalację dodatkowego komponentu w postaci serwera baz danych MSDE. Wymieniony moduł dołączany jest do pakietu instalacyjnego Asixa.

Konfiguracja modułu Aspad pod kątem realizacji archiwizacji typu B opisana została w punkcie Dodatkowe wymagania archiwum typu B.

W części Pamięć operacyjna podano metody oszacowania wielkości pamięci operacyjnej i dyskowej wymaganej dla pracy modułu archiwizacji Aspad w zależności od liczby zmiennych archiwizowanych i typów archiwum.


7.3.1. Pamięć operacyjna

Obszar pamięci potrzebny modułowi Aspad jest sumą wielkości kodu i danych oraz przydzielonych obszarów roboczych.

Obszar pamięci operacyjnej przydzielanej dynamicznie zależy głównie od liczby archiwizowanych przebiegów zmiennych. Struktury danych związane z każdym przebiegiem archiwizowanym w sposób D, M lub Y zajmują od około 0.8 KB do 1.3 KB, a dla typu B około 0.3 KB. Jeżeli zmienna jest archiwizowana na kilka sposobów, to należy ją uwzględnić dla każdego sposobu oddzielnie.

Aspad przydziela pamięć w miarę potrzeby w trakcie działania systemu. Początkowa zajętość pamięci dla archiwum D, M lub Y wynosi zwykle 0.8 KB na zmienną i nie może być traktowana jako całkowite zapotrzebowanie pamięci. W przypadku, gdy bufor o wielkości 0.5 KB przypisany do każdej zmiennej zostanie zapełniony danymi, jest inicjowana operacja jego zapisu na dysk, a dla nowych danych przydzielany jest nowy bufor. W efekcie, do momentu zakończenia zapisu, zmienna zajmuje 1.3 KB. Jeżeli taka operacja zostanie zainicjowana dla wielu zmiennych równocześnie, to może chwilowo wzrosnąć zajętość pamięci. Zjawisko takie zachodzi w chwili przechodzenia do nowego pliku, np. na początku nowej doby, gdy opisana operacja jest wykonywana dla wszystkich przebiegów typu D.

PRZYKŁAD

Dla struktur danych 5000 zmiennych w archiwum D i 5000 zmiennych w archiwum M należy w sumie przewidzieć około 13 MB niestronicowanej pamięci RAM.


7.3.2. Pamięć dyskowa dla archiwum D, M, Y i H

Wielkość potrzebnej pamięci dyskowej zależy w głównej mierze od liczby i wielkości przechowywanych rekordów zawierających kolejne punkty wszystkich archiwizowanych przebiegów zmiennych.

Dla archiwum typu H należy przewidzieć miejsce na dane pochodzące z okresu dwukrotnie dłuższego niż zadany horyzont czasowy.

Dla archiwum typu D, M i Y należy zapewnić obszar wystarczający dla danych z tylu plików danego typu, ile będzie przechowywanych równocześnie na dysku.

Dodatkowo w plikach zapamiętywane są informacje organizujące wewnętrzną strukturę plików. W archiwum D, M, Y i H te dodatkowe informacje zajmują ponad 10 % pliku dla przebiegów zawierających bardzo dużą liczbę danych (rzędu kilkudziesięciu KB dla jednej zmiennej). Dla mniejszej liczby danych udział ten rośnie.

Oszacowanie wielkości pamięci dyskowej zajmowanej przez rekordy danych nie może być jednoznaczne, gdyż dane te poddawane są kompresji, której efektywność zależy od charakteru przebiegu i sposobu parametryzacji archiwum. Każdy rekord przed kompresją składa się z 1 bajta statusu opisującego rekord (np. odróżniającego dziurę od danych), 4 bajtów znacznika czasu, 2 bajtów jakości zmiennej (zgodnej ze standardem OPC) i od 1 do 4 bajtów wartości zmiennej, w zależności od jej typu. Do pliku zapisywane są tylko te rekordy, dla których wartość zmieniła się w istotny sposób, tzn. o więcej niż zadaną przy parametryzacji dokładność rejestracji. Dla przebiegów wolnozmiennych (w odniesieniu do zadanej częstotliwości próbkowania) rejestracji podlegają tylko niektóre rekordy. W trakcie kompresji większość znaczników czasu zostaje zredukowana do 1 bajta lub nawet całkowicie pomijana, zostawiając jedynie ślad w bajcie statusu. Kompresja jest tym lepsza, im mniejsza jest wymagana dokładność rejestracji czasu. Kompresja pozwala także na redukcję większości wartości zmiennej do 1 lub 0 bajtów. Jedynie dla wartości zmieniających się skokowo o wartości dużo większe niż zadana dokładność rejestracji, kompresja może nie być tak skuteczna. Słowo jakości jest zapisywane tylko w razie jego zmiany. Także bajt statusu może zostać pominięty, jeżeli w kolejnych rekordach rozmiary zredukowanego znacznika czasu i wartości zmiennej są takie same.

W efekcie przy archiwizacji liczb stałoprzecinkowych lub zmiennoprzecinkowych z zadaną dokładnością rejestracji typowa wielkość rekordu po kompresji wynosi 1-2 bajty. Ta sama wielkość rekordu jest osiągana także dla liczb zmiennoprzecinkowych bez zadanej dokładności rejestracji przy niektórych funkcjach przeliczających Asmena, dla których wartość surowa jest liczbą stałoprzecinkową. Dla innych liczb zmiennoprzecinkowych typowa wielkość rekordu wynosi 3-5 bajtów.

Także dziury w archiwum włączone są do kompresji i zajmują 1-2 bajty.


7.3.3. Pamięć dyskowa dla archiwum B

W przypadku stosowania baz danych typu SQL. Baza oprócz samych danych, zawiera też indeksy, pola ograniczające rekordy oraz puste obszary, wynikające ze sposobu rozmieszczania danych w plikach. Dodatkowo tworzony jest też plik logu transakcji. Szacunkowo wielkość samej bazy danych, bez logu transakcji, wynosi:

  • 142 bajty na próbkę dla pełnego rekordu z wszystkimi polami opcjonalnymi;

  • 113 bajtów na próbkę dla rekordu bez pól opcjonalnych.

Archiwum B nie nadaje się do gromadzenia dużej ilości danych. Jego zaletą jest jednak stosowanie standardowych plików bazy danych. Jest też jedynym archiwum, w którym można uzupełniać braki danych.


7.4. Pliki tworzone przez programy modułu Aspad

Programy modułu Aspad samodzielnie tworzą szereg plików o różnym przeznaczeniu, umieszczając je w kartotekach zadanych w pliku konfiguracyjnym. Zawierają one dane, informacje o konfiguracji, raporty z przetwarzania plików archiwalnych, kopie oryginalnych plików archiwalnych po ich ewentualnym przetwarzaniu oraz komunikaty diagnostyczne.


7.4.1. Pliki archiwalne D, M, Y i H

Podział archiwum na pliki pod kątem czasu

Podział plików na zasoby

Konwencja nazw plików

Przykłady

Podział archiwum na pliki pod kątem czasu

Przebiegi archiwalne typu D, M, Y i H gromadzone są w czterech rodzajach plików różniących się czasem gromadzonych danych. Każda zmienna może być archiwizowana równocześnie w kilku typach plików. Dla przebiegów D, M i Y tworzone są pliki zawierające dane z określonego okresu: doby (D), miesiąca (M) lub roku (Y).

Na początku każdego okresu tworzony jest nowy plik o unikatowej nazwie. Pliki z poprzednich okresów przechowywane są do momentu, gdy minie okres zadany w parametrach archiwum. Niektóre pliki mogą zostać programowo zabezpieczone przed automatycznym usuwaniem, co jest określane w parametrach systemu Asix. Takie pliki mogą być usunięte podczas konserwacji systemu. Najstarsze pliki są też usuwane automatycznie w przypadku braku miejsca na dysku. Wcześniej cyklicznie wysyłane są ostrzeżenia, co pozwala na świadomą reakcję, np. kopiowanie archiwum na nośnik zapasowy.

Takie podejście pozwala na elastyczny podział archiwum na części. Pliki dobowe są najmniejsze, co ułatwia ich konserwację, składowanie, czy selektywne usuwanie. Zwykle jednak korzystanie z plików dobowych jest uzasadnione tylko dla często próbkowanych i zmieniających się danych. Zastosowanie ich np. do danych godzinnych wiąże się ze stratą pamięci dyskowej, bowiem deklaracja zmiennej w nowym pliku zajmuje około 40 bajtów, a pamięć dyskowa dla danych przebiegu zmiennej jest przydzielana porcjami po 512. Zapamiętanie 24 rekordów, które zwykle po kompresji zajmują 1-2 bajty na rekord, spowoduje konieczność zajęcia 552 bajtów na zapamiętanie kilkudziesięciu punktów.

Przykładem efektywnego wykorzystania dysku jest archiwizacja danych chwilowych w plikach dobowych, średnich 5-minutowych w miesięcznych, a średnich godzinnych w rocznych.

Pliki archiwum H nie są dzielone na okresy, a miejsce zwalniane przez stare dane jest ponownie wykorzystywane przez nowe.

Podział plików na zasoby

W pliku inicjującym poszczególne grupy zmiennych przypisuje się do nazwanych zasobów parametryzowanych w deklaracjach ARCHIWUM, a każdy zasób jest archiwizowany w oddzielnych plikach o deklarowanej dla każdego zasobu oddzielnie lokalizacji. Nazwa zasobu jest częścią nazwy pliku.

Konwencja nazw plików

Aktualna konwencja nazw plików wykorzystuje długie nazwy plików, pozwala na kodowanie dowolnej daty i stosuje, zgodnie z konwencją Windows, jednolite rozszerzenie nazwy pliku. Została ona wprowadzona w wersji 6 programu Aspad, zapewniając dostosowanie nazw plików do nowych cech Aspada i wymogów systemu Windows.

Nazwa pliku jest zbudowana z kilku członów wg wzorca:

Trrrrmmdd-zasób.ahf

gdzie:

T - jednoliterowa nazwa rodzaju archiwum (D,M,Y,H);

rrrr - 4-cyfrowy rok, dla archiwum H zastępowany tekstem xxxx;

mm - 2-cyfrowy miesiąc, dla archiwum H i Y zastępowany tekstem xx;

dd - 2-cyfrowy dzień miesiąca, dla archiwum H, M i Y zastępowany tekstem xx;

zasób - zadeklarowana w pliku inicjującym nazwa zasobu;

.ahf - stały tekst rozszerzenia (ang. ASPAD Historical File).

Przykłady

M200005xx-BLOK.ahf - oznacza plik miesięczny z maja 2000 dla zasobu BLOK,

D20000416-ZAKL1.ahf - oznacza plik dobowy z 2000-04-16 dla zasobu ZAKL1.


7.4.2. Pliki archiwum B i P

W trakcie działania archiwum B i P moduł ASSQL.dll tworzy bazy danych w domyślnym katalogu serwera SQL. Zawartość baz danych może być w tym przypadku przeglądana przy wykorzystaniu standardowych narzędzi przeznaczonych do przeglądania baz danych typu SQL.


7.5. Konfigurowanie systemu przy instalacji modułu Aspad

Przed uruchomieniem modułu Aspad należy:

  • odpowiednio sformatować dysk i zainstalować system Windows - ze względu na niezawodność i wydajność zaleca się archiwizację tylko na partycji NTFS,

  • tworzyć pliki konfiguracyjne Aspada (pliki konfiguracyjne zawierające opisy warunków przy archiwizacji warunkowej),

  • odpowiednio sparametryzować programy Aslink i Asmen, aby mogły współpracować z Aspadem, dostarczając mu dane do archiwizacji.

Nie trzeba tworzyć ręcznie kartotek zawierających archiwum, gdyż Aspad może je utworzyć sam w momencie uruchomienia.


7.6. Konfigurowanie i uruchomienie modułu Aspad

Aspad jest ładowany automatycznie w trakcie ładowania Asixa, a parametry jego działania pobierane są z pliku konfiguracyjnego aplikacji XML. Ładowanie Aspada może zostać pominięte, jeżeli zostanie załączona opcja Symulacja:

Architekt > Obszary i komputery > moduł Dane archiwalne > zakładka Standardowe


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.1. Specyfikacja odcinków czasu w plikach konfiguracyjnych

7.6.1. Specyfikacja odcinków czasu w plikach konfiguracyjnych

W plikach konfiguracyjnych często zachodzi potrzeba określenia horyzontu czasowego, częstotliwości lub okresu wykonywania określonych akcji. W parametryzacji Aspada zastosowano jednolity sposób ich specyfikacji. Opis czasu podaje się w następującej formie:

<liczba><jednostka> [<liczba><jednostka> [...]]

gdzie:

<liczba> - jest liczbą podanych po niej jednostek czasu, mieszczącą się w granicach od 1 do 32767,

<jednostka> - określa jednostkę czasu, którą może być:

s - sekunda,

m - minuta,

g lub h - godzina,

d - doba.

PRZYKŁAD

3600s lub 1g = 1 godzina

1g30m lub 1g 30m lub 90m = 1 godzina 30 minut

48h lub 48g lub 2d = 2 doby


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.2. Zadawanie podstawowych parametrów archiwizacji

7.6.2. Zadawanie podstawowych parametrów archiwizacji

Przy startowaniu archiwizacji konieczne jest określenie kilku jej globalnych parametrów. Do ich specyfikacji służy moduł Dane archiwalne w programie Architekt. Dokładne opisy poszczególnych opcji podano w:

Architekt > Konfiguracja danych archiwalnych

Archiwum Aspada dzieli się na zasoby:

Archiwum do odczytu,

Archiwum do zapisu,

Archiwum pomocnicze,

Archiwum sieciowe.

Przebiegi zmiennych danego zasobu są zapisywane lub czytane do/z plików archiwalnych umieszczonych w kartotekach określonych dla powyższych rodzajów archiwum.

Archiwum definiowane jest przez następujące parametry:

zasób - logiczna nazwa archiwum,

rodzaj - rodzaj parametryzowanego zasobu:

STANDARD - archiwizacja w plikach,

ASBDE - archiwizacja w bazie danych,

MSSQL - archiwizacja w bazie danych,

dodatkowe parametry - parametry zależne od rodzaju zasobu.

Patrz: Architekt > Parametryzacja archiwum


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.3. Automatyczne tworzenie kopii zapasowych

7.6.3. Automatyczne tworzenie kopii zapasowych

Aspad może cyklicznie tworzyć kopie zapasowe plików archiwalnych typu D, M i Y na dodatkowym dysku. Do tego celu służy opcja Kopia określająca, które pliki i kiedy należy kopiować.

Patrz: Architekt > Parametryzacja archiwum > Parametry określające sposób tworzenia kopii zapasowej archiwum


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.4. Automatyczne kasowanie najstarszych plików

7.6.4. Automatyczne kasowanie najstarszych plików

Możliwe jest zadawanie czasu, po jakim określone pliki danego zasobu mają być automatycznie usunięte. Stwarza to możliwość przechowywania przebiegów, które mają być zapominane po określonym czasie, wyrażonym w dniach.

Przypadkowa, nawet chwilowa, duża zmiana czasu komputera mogłaby doprowadzić do automatycznego usunięcia ważnych plików. W celu uniknięcia takiej sytuacji, po upływie terminu ważności pliku, jego nazwa *.ahf zamieniana jest na *.ahr, a ten jest jeszcze przechowywany przez kolejne 10% okresu ważności pliku.

Patrz: Architekt > Parametryzacja archiwum > Parametry standardowe


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.5. Sieciowy dostęp do danych Aspada

7.6.5. Sieciowy dostęp do danych Aspada

Aspad, w obecności programu Aslink, udostępnia w sieci komputerowej dane zgromadzone w swoich plikach archiwalnych (warunkiem jest jeszcze posiadanie klucza z uprawnieniami serwera). Aspad jest wtedy serwerem sieciowym tych zasobów. Udostępnione dane można czytać na innych komputerach w sieci za pośrednictwem programów Aspad, dla których te same zasoby zostały wyspecyfikowane w parametrach archiwum sieciowego. Dalej będą one nazywane klientami sieciowymi tych zasobów.

Dla klienta parametr Powtarzanie szukania serwerów określa, jak często ponawiać próbę szukania serwera, jeżeli zasób nie jest aktualnie dostępny w sieci:

Architekt > Obszary i komputery > moduł Dane archiwalne > zakładka Standardowe

Parametr Wyszukiwanie serwerów mówi jak długo, w trakcie wyszukiwania zasobów w sieci, należy czekać na zgłoszenia serwerów:

Architekt > Obszary i komputery > moduł Dane archiwalne > zakładka Wyszukiwanie serwerów

Rysunek: Parametryzacja czasu wyszukiwania serwerów w sieci.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.6. Parametry archiwizacji zmiennych

7.6.6. Parametry archiwizacji zmiennych

Parametry archiwizacji są pobierane z bazy definicji zmiennych.

Parametry archiwizacji w bazie definicji zmiennych zawarte są w polach o następujących nazwach:

Parametr Pole

Nazwa zmiennej Nazwa

Nazwa zasobu Archiwum

Parametry archiwizacji ParametryArchiwizacji

Opisane parametry charakteryzują sposób archiwizacji zmiennej i stanowią uzupełnienie pozostałych parametrów zadanych w bazie zmiennych.

Należy tutaj zwrócić szczególną uwagę na typ zmiennej, określony przez funkcję przeliczającą modułu Asmen. Sposób pakowania zmiennej w archiwum jest zależny od jej typu. Dlatego Aspad nie może archiwizować pod tą samą nazwą zmiennej danych innego typu niż już zgromadzone w archiwum. Załóżmy, że dla zmiennej była zadeklarowana funkcja przeliczająca NIC (typu WORD). Powstało archiwum zmiennej typu WORD. Następnie funkcję przeliczającą zmieniono na NIC_INT (typu INTEGER). Aspad nie może już poprawnie archiwizować tej zmiennej, a przy starcie ostrzega o różnicach typu danych zadeklarowanych w module Asmen i typu danych zarchiwizowanych.

Deklaracja parametrów archiwizacji zmiennych ma następującą postać:

NZm, RArc, Okres, Hor, Dt, Dx, Atr, War, PrzedWar, PoWar

gdzie:

NZm - nazwa zmiennej zgodna z deklaracją w konfiguracji modułu Asmen;

RArc - jednoliterowe oznaczenie rodzaju archiwizacji;

Okres - okres próbkowania wartości zmiennej; powinien on odpowiadać rzeczywistym potrzebom, gdyż zbyt krótki okres spowoduje zwiększenie zajętości dysku oraz większe obciążenie czasowe systemu, a przy zbyt długim okresie nie zostanie oddany w pełni charakter przebiegu wartości;

Hor - minimalny horyzont czasowy przechowywania danych dla zmiennej typu H i B; wartość 0 oznacza nieskończoność, co jest wartością domyślną; zaleca się jednak określanie skończonego horyzontu, bo pozostawienie wartości 0 może doprowadzić do przekroczenia limitu 2GB dla plików archiwum H i B;

Dt - dokładność rejestracji czasu, np. 30s oznacza, że dane pobrane zarówno o 14:27:45 jak i o 14:28:14 zostaną zarejestrowane z czasem 14:28:00; podanie możliwie dużej wartości dt pozwoli na lepsze upakowanie danych w plikach archiwalnych; minimalne dt wynosi 1;

Dx - dokładność rejestracji danych, która określa, przy jakich zmianach wartości zmiennej należy zapamiętać nową wartość; przy mniejszych zmianach kolejne wartości nie będą rejestrowane jako nieistotne, a przy odczycie będzie w tym miejscu obowiązywała poprzednia wartość zapisana w archiwum, np. 5 oznacza, że należy rejestrować nowe wartości tylko wtedy, gdy zmiana w stosunku do poprzednio zarejestrowanej jest większa lub równa 5. 0 będzie oznaczało rejestrację przy każdej zmianie, z pominięciem rejestracji wartości stałej; podanie możliwie dużej wartości dx pozwoli na lepsze upakowanie danych w plikach archiwalnych;

Atr - [image] patrz: Atrybuty archiwizacji; można podać kilka atrybutów oddzielonych pionową kreską | ;

War - nazwa opcjonalnego warunku archiwizacji ( [image] patrz: Archiwizacja warunkowa);Archiwizacja_warunkowa;.

definicje warunków archiwizacji znajdują się w plikach lub mogą być deklarowane bezpośrednio w parametrze War;

PrzedWar - okres przed wystąpieniem warunku War, z którego dane mają być zapisane w archiwum; ten parametr nie powinien być zbyt duży, gdyż wymaga to tworzenia odpowiednich buforów w pamięci operacyjnej, obejmujących liczbę próbek danych przypadających na zadany okres;

PoWar - okres po zaniku warunku War, z którego dane mają być zapisane w archiwum.

Poszczególne pola deklaracji oddzielone są przecinkami. Dwa przecinki nie rozdzielone wartością parametru oznaczają przyjęcie wartości domyślnej. Pominięcie kilku ostatnich parametrów przypisze im wartości domyślne.

UWAGA: Poza archiwizacją podstawową istnieje również możliwość zadeklarowania dla danej zmiennej dodatkowej archiwizacji (w ramach tego samego archiwum) - [image] patrz Archiwizacja podstawowa i dodatkowa. Deklaracja parametrów dodatkowej archiwizacji umieszczana jest w bazie definicji zmiennych w polu ParametryArchiwizacji zaraz za deklaracją podstawowej archiwizacji (deklaracje obu archiwizacji należy oddzielić średnikiem). Składnia archiwizacji dodatkowej jest taka sama jak dla archiwizacji podstawowej.

PRZYKŁAD

Deklaracja parametrów archiwizacji zmiennych.

Rysunek: Przykładowa deklaracja zmiennych w bazie danych.

# Zmienną KW_A000 zapisuj w archiwum typu D,

# archiwum typu D (pliki dobowe),

# dane pobieraj co 1 sekundę,

# czas rejestruj z dokładnością do 1 sekundy,

# rejestruj każdą zmianę wartości zmiennej,

# nie inicjuj wartości zmiennej Asmena.

KW_A000, D, 1s, , 1s, 0, nie_odtwarzaj

# Zmienną KW_A004 zapisuj w archiwum typu D,

# dane pobieraj co 1 sekundę,

# czas rejestruj z dokładnością do 1 sekundy,

# rejestruj tylko gdy wartość zmieni się o więcej niż 5.

KW_A004, D, 1s, , 1s, 5

# Zmienną KW_A008 zapisuj w archiwum typu M,

# dane pobieraj co 1 sekundę,

# przechowuj przez 1 godzinę,

# czas rejestruj z dokładnością do 1 sekundy,

# rejestruj każdą zmianę wartości zmiennej.

KW_A008, M, 1s, , 1s, 0

# Zmienną KW_A008 zapisuj w archiwum typu H,

# archiwum typu H,

# dane pobieraj co 1 sekundę,

# przechowuj przez 1 godzinę,

# czas rejestruj z dokładnością do 1 sekundy,

# rejestruj każdą zmianę wartości zmiennej,

# nie inicjuj wartości zmiennej Asmena.

KW_A032, H, 1s, 1g, 1s, 0, nie_odtwarzaj


Archiwizacja podstawowa i dodatkowa

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.7. Archiwizacja podstawowa i dodatkowa

7.6.7 Archiwizacja podstawowa i dodatkowa

W ramach danego archiwum (pole Archiwum w bazie definicji zmiennych) zmienna może podlegać dodatkowej archiwizacji w sytuacji, gdy oprócz archiwów przechowywanych w plikach np. dobowych, wymagana jest archiwizacja danych w bazie SQL. W innym przypadku może zachodzić potrzeba przeanalizowania dla danego wycinka czasu danych archiwizowanych z większą częstotliwością niż przewiduje to zasadnicza archiwizacja - wówczas również należy skorzystać z archiwizacji dodatkowej.

Sposób deklarowania archiwizacji dodatkowej dla danej zmiennej wymaga następujących czynności:

1. Dla danego zasobu (archiwum), w którym ma być prowadzona dodatkowa archiwizacja - zadeklarowania stosownego rodzaju archiwum (STANDARD, MS SQL), adekwatnego do planowanego typu dodatkowej archiwizacji (D, M, Y, H, B lub P):

program Architekt > Dane archiwalne > <nazwa archiwum> > zakładka Standardowe

W sytuacji, gdy oprócz archiwów przechowywanych w plikach np. dobowych (w ramach podstawowej archiwizacji), wymagana jest archiwizacja danych w bazie SQL (jako archiwizacja dodatkowa) - należy zaznaczyć 2 rodzaje archiwum: STANDARD i MS SQL.

2. W definicji archiwizowanej zmiennej (w bazie definicji zmiennych) należy w polu Parametry archiwizacji zadeklarować parametry archiwizacji dodatkowej. Deklaracja parametrów dodatkowej archiwizacji umieszczana jest za deklaracją podstawowej archiwizacji (deklaracje obu archiwizacji należy oddzielić średnikiem).

Składnia archiwizacji dodatkowej jest taka sama jak dla archiwizacji podstawowej ( [image] patrz: Parametry archiwizacji zmiennych).

W przypadku deklarowania parametrów archiwizacji dodatkowej przy użyciu edytora parametrów archiwizacji, w oknie głównym edytora należy wybrać jako rodzaj archiwizacji opcję: 'Archiwizacja podstawowa i dodatkowa' i zdefiniować parametry archiwizacji dodatkowej na osobnej zakładce edytora ( [image] patrz: Parametry archiwizacji zmiennych; Edytor parametrów archiwizacji zmiennych).


7.6.7. Atrybuty archiwizacji

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.8. Atrybuty archiwizacji

7.6.8. Atrybuty archiwizacji

ODTWARZAJ

Na starcie Aspad będzie wpisywał do bazy danych modułu Asmen ostatnią wartość zarejestrowaną w archiwum. Pozwoli to na przechowywanie i odtwarzanie wartości zadawanych przez operatora systemu Asix także w okresie wyłączenia komputera. Atrybut przeznaczony generalnie dla zmiennych należących do kanału transmisji Asmena typu NONE (brak odświeżania zmiennej poprzez odczyt ze sterownika). Od momentu startu modułu Aspad wartości zadane przed wyłączeniem będą dostępne dla wszystkich użytkowników modułu Asmen w danym systemie.

NIE_ODTWARZAJ odwołuje deklarację ODTWARZAJ.

NIE_PAKUJ

Atrybut NIE_PAKUJ zmienia dwie cechy archiwizacji.

  • W archiwum w każdym cyklu archiwizacji nastąpi zapis wartości, pod warunkiem, że uda się pozyskać poprawną wartość. Nie będą więc pomijane w kolejnych cyklach zapisy wartości stałej.

  • Przy odczycie Aspad będzie zorientowany na odczyt punktów, a nie odcinków. W zwykłym trybie Aspad udostępnia odcinki, co oznacza, że jeżeli wartość została zapisana z czasem 1:00 i jest ważna przez godzinę (cykl próbkowania wynosi 1 godz.), to przy odczycie o godzinie 2:00 pojawi się nowa wartość, a jeżeli jej nie ma (dziura w archiwum), to zostanie tam powtórzona wartość z 1:00. Pozwala to na narysowanie odcinka od godziny 1:00 do 2:00 i pokazanie dziury w archiwum dopiero od 2:00. Atrybut NIE_PAKUJ spowoduje odczyt tylko wartości z 1:00.

PAKUJ odwołuje deklarację NIE_PAKUJ.

KAŻDY

Atrybut KAŻDY może być stosowany tylko z archiwum typu B. Zmienna musi być przy tym pozyskiwana z kanału, którego drajwer udostępnia dodatkowe usługi pozwalające na pobieranie każdej przychodzącej wartości. Aktualnie takie możliwości ma drajwer SINAUT.

Atrybut KAŻDY spowoduje zapis do archiwum B wszystkich wartości pobranych przez drajwer, niezależnie od cyklu próbkowania i kolejności ich udostępniania. Cykl próbkowania oznacza wtedy jedynie czas ważności pobranych danych.

NIE_KAŻDY odwołuje deklarację KAŻDY.


Edytor parametrów archiwizacji zmiennych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.6. Konfigurowanie i uruchomienie modułu Aspad > 7.6.9. Edytor parametrów archiwizacji zmiennych

7.6.9. Edytor parametrów archiwizacji zmiennych

W przypadku tworzenia / definiowania bazy definicji zmiennych przy użyciu programu Architekt definiowanie parametrów archiwizacji umożliwia 'Edytor parametrów archiwizacji zmiennych', dostępny w:

program Architekt > Bazy danych > Edytor definicji zmiennych (przy załączonym trybie Edytor tworzenia bazy i otwartej bazie definicji zmiennych) > pole Parametry archiwizacji > edytor parametrów archiwizacji

Rys. Edytor parametrów archiwizacji.

Wybór rodzaju archiwizacji odbywa się za pośrednictwem pola Rodzaj - dostępne opcje to:

- Bez archiwizacji;

- Archiwizacja podstawowa;

- Archiwizacja podstawowa i dodatkowa

Podstawowe parametry:

Pole Rodzaj archiwum określa typ archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

uwaga Archiwa typu D, M, Y, H wymagają archiwum STANDARD. Stąd zmienna, która w parametrach archiwizacji ma zadeklarowany jeden z wymienionych typów, musi mieć w parametrach archiwum zadeklarowany jako rodzaj archiwum: STANDARD (Architekt > Dane archiwalne > <nazwa archiwum> > zakładka Standardowe).

Pozostałe typy archiwum B i P deklarowane są dla archiwum MS SQL.

Pozostałe pola edytora umożliwiają zadeklarowanie następujących parametrów archiwizacji:

- Okres próbkowania;

- Dokładność rejestracji czasu;

Parametry opcjonalne:

- Dokładność rejestracji wartości;

- Okres przechowywania danych (H i B);

- Odtwarzaj ostatnią wartość zarejestrowaną w archiwum;

- Nie kompresuj danych;

Opcjonalne - archiwizacja warunkowa:

- Nazwa warunku archiwizacji;

- Okres archiwizacji przed wystąpieniem warunku;

- Okres archiwizacji po zaniku warunku;


7.7. Archiwizacja warunkowa

Archiwizacja warunkowa pozwala na archiwizację tylko wtedy, gdy spełnione są określone warunki. Można zadawać, z jakiego okresu przed wystąpieniem warunku i po jego zaniku dane mają zostać zapamiętane w archiwum.

Warunki mogą być definiowane bezpośrednio w definicji zmiennej w bazie definicji zmiennej w polu Warunki archiwizacji lub znajdować się w osobnym pliku warunków.


Nowa strona 1

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.7. Archiwizacja warunkowa > 7.7.1. Deklaracje warunków archiwizacji

7.7.1. Deklaracje warunków archiwizacji

Deklaracja w plikach

Warunki archiwizacji są definiowane przy pomocy wyrażeń umieszczanych w pliku. Każde wyrażenie musi być zdefiniowane w odrębnej linii. Nazwa warunku podana w pliku jest następnie umieszczana w definicji zmiennej w polu Parametry archiwizacji. Nazwę pliku z warunkami archiwizacji należy zadeklarować w: programie Architekt > Obszary i komputery > Dane archiwalne > zakładka Standardowe > opcja Warunki

Wartości i argumenty wyrażeń są stałymi lub zmiennymi wartościami zmiennoprzecinkowymi, maskami 32-bitowymi, lub wartościami logicznymi. Argumentami wyrażeń mogą być inne wyrażenia, czyli można definiować wyrażenia złożone. Nazwy wyrażeń nie mogą się powtarzać.

Jeżeli wartość wyrażenia nie jest wartością logiczną, a zostanie użyta bezpośrednio jako warunek, to jest dokonywana konwersja:

  • maski 32-bitowe, w których wszystkie bity są zerowe są konwertowane na fałsz, inne na prawdę,

  • liczby z zakresu (-0.5;0.5) są konwertowane na fałsz, inne na prawdę.

Linia wyrażenia ma następującą strukturę:

Nazwa_wyrażenia, Operator, Arg1, Arg2, ...

gdzie:

Nazwa_wyrazenia - identyfikator wyrażenia zawierający do 15 znaków; nazwa wyrażenia może się powtarzać; nazwy wyrażeń stanowią odrębną grupę, dzięki czemu nie dochodzi do konfliktu np. z identyczną nazwą zmiennej;

Operator - nazwa jednego z dopuszczalnych operatorów;

Arg1, Arg2, ... - argumenty wyrażenia.

Argumenty mają postać:

[u][$]źródło

gdzie:

u i $ - są opcjonalne i oznaczają:

u - jest jednym z operatorów jednoargumentowych:

- - oznacza zmianę znaku z wcześniejszą konwersją do postaci liczby zmiennoprzecinkowej,

~ - oznacza negację bitów maski z wcześniejszą konwersją do postaci maski 32-bitowej,

! - oznacza negację z wcześniejszą konwersją do postaci wartości logicznej.

$ - oznacza pobranie wartości wyliczonej przy poprzednim wartościowaniu warunku dla danej zmiennej i zachowanie aktualnej wartości do przyszłych wyliczeń.

Źródło danych źródło ma jedną z następujących postaci:

liczba_dziesiętna - wartość liczbowa zmiennoprzecinkowa (np. 9999);

0x liczba_szesnastkowa - maska 32-bitowa zakodowana szesnastkowo (np. 0xFFFF);

>> - plus nieskończoność;

<< - minus nieskończoność;

@nazwa_zmiennej - wartość zmiennej procesowej;

@ - wartość zmiennej procesowej, dla której aktualnie wyznaczany jest warunek; taki warunek ma różne wartości w zależności od tego, dla której zmiennej jest wyznaczany;

?nazwa_wyrażenia - wartość innego, wcześniej zdefiniowanego wyrażenia. Można w ten sposób definiować wyrażenia złożone.

Deklaracja in-line warunku archiwizacji

W skład definicji zmiennej może wchodzić warunek archiwizacji tej zmiennej. Warunek umieszczany jest w polu Archiwizacja zmiennej, w parametrze War.

Ponieważ większość warunków ma prostą jednowierszową postać, to w wielu aplikacjach pozwoli to uniknąć tworzenia pliku warunków.

Takie warunki można wprowadzać w edytorze bazy definicji zmiennych Architekta. Nie można ich stosować z wcześniejszymi wersjami Architekta, gdyż nieprawidłowo interpretuje on dodatkowe przecinki w definicji zmiennej.

Deklarację in-line można zdefiniować na 2 niżej opisane sposoby.

Warunek jako wyrażenie w deklaracji zmiennej

Zamiast nazwy warunku można wpisać bezpośrednio wyrażenie, zgodne ze składnią definicji warunku w pliku warunków, ujęte w nawiasy (). W takim wyrażeniu pomija się pierwszy parametr określający nazwę warunku.

Przykłady

Archiwizuj, gdy bit 4 zmiennej AAA jest równy 1:

(BAND, @AAA, 0x10)

Archiwizuj, gdy bity 4 lub 8 zmiennej AAA zmieniły stan:

(BNE, @AAA, $@AAA, 0x110)

Archiwizuj, gdy bit 0 zmiennej archiwizowanej zmienia stan z 0 na 1:

(BGT, @, $@, 0x1)

Archiwizuj, gdy wartość zmiennej archiwizowanej jest poza przedziałem (20,80):

(IN, @, <<, 20, 80, >>)

Warunek jako argument w deklaracji zmiennej

Zamiast nazwy warunku można wpisać bezpośrednio wyrażenie, zgodne ze składnią argumentu warunku w pliku warunków. Takie wyrażenie musi się zaczynać od !, -, ~, $, @ lub ?.

Przykłady

Archiwizuj, gdy zmienna AAA jest poza przedziałem (-0.5; 0.5):

@AAA

Archiwizuj, gdy zmienna AAA jest w przedziale (-0.5; 0.5):

!@AAA

Archiwizuj, gdy poprzednia wartość zmiennej AAA była poza przedziałem (-0.5; 0.5):

$@AAA

Archiwizuj, gdy warunek QQQ nie jest spełniony:

!?QQQ


7.7.2. Operatory warunków archiwizacji

Operatory logiczne

Operatory relacyjne

Operatory logiczne bitowe

Operatory relacyjne bitowe

Operatory arytmetyczne

Operator testu na wartość mieszczącą się w zadanych przedziałach

Operatory warunków mogą mieć różny typ wyniku oraz różną liczbę i typ argumentów, w zależności od rodzaju operatora. W razie niezgodności typu argumentu z typem akceptowanym przez operator, dokonywana jest automatycznie konwersja. Niżej opisano zdefiniowane do tej pory operatory.

Operatory logiczne

OR suma logiczna

AND iloczyn logiczny

XOR logiczny iloczyn wykluczający

Typ argumentów: wartość logiczna

Typ wyniku: wartość logiczna

Liczba argumentów: dowolna

Operatory relacyjne

LT mniejszy

LE mniejszy lub równy

EQ równy

NE różny

GE większy lub równy

GT większy

Typ argumentów: wartość liczbowa

Typ wyniku: wartość logiczna

Liczba argumentów: 2

Operatory logiczne bitowe

BAND iloczyn logiczny wszystkich bitów argumentów

BOR suma logiczna wszystkich bitów argumentów

BXOR iloczyn wykluczający wszystkich bitów argumentów

Typ argumentów: maska 32-bitowa

Typ wyniku: maska 32-bitowa

Liczba argumentów: dowolna

Operatory relacyjne bitowe

BLT ustawia bity zadane w Arg3, które w Arg1 są < od bitów w Arg2

BLE ustawia bity zadane w Arg3, które w Arg1 są < lub = bitom w Arg2

BEQ ustawia bity zadane w Arg3, które w Arg1 są = bitom w Arg2

BNE ustawia bity zadane w Arg3, które w Arg1 nie są = bitom w Arg2

BGE ustawia bity zadane w Arg3, które w Arg1 są > lub = bitom w Arg2

BGT ustawia bity zadane w Arg3, które w Arg1 są > lub = bitom w Arg2

Typ argumentów: maska 32-bitowa

Typ wyniku: maska 32-bitowa

Liczba argumentów: 2 lub 3. Jeżeli podano tylko 2 argumenty, to zakłada się, że Arg3=0xFFFFFFFF.

Operatory arytmetyczne

ADD suma arytmetyczna

MUL iloczyn arytmetyczny

DIV iloraz arytmetyczny Arg1 / Arg2.

Typ argumentów: wartość liczbowa

Typ wyniku: wartość liczbowa

Liczba argumentów: ADD i MUL - dowolna, DIV - 2.

Operator testu na wartość mieszczącą się w zadanych przedziałach

IN spełniony, gdy wartość Arg1 mieści się w przedziale

[Arg2, Arg3], lub w przedziale [Arg4, Arg5] itd.

Typ argumentów: wartość liczbowa

Typ wyniku: wartość logiczna

Liczba argumentów: nieparzysta nie mniejsza niż 3.


7.7.3. Przykłady warunków

Archiwizuj, gdy bity 4. lub 8. zmiennej AAA zmieniły stan:

WARUNEK, BNE, @AAA, $@AAA, 0x110

Archiwizuj, gdy bit 0. zmiennej archiwizowanej zmienia stan z 0 na 1:

WARUNEK, BGT, @, $@, 0x1

Archiwizuj, gdy wartość zmiennej archiwizowanej jest poza przedziałem (20,80) i ustawiony jest jeden z bitów 0-3 zmiennej WWW:

W1, IN, @, <<, 20, 80, >>

W2, BAND, @WWW, 0xF

WARUNEK, AND, ?W1, ?W2

Archiwizuj w chwili, gdy wartość zmiennej archiwizowanej przekracza granicę 100:

W3, GT, @, 100

WARUNEK, AND, ?W3, !$?W3


7.7.4. Deklaracja in-line warunku archiwizacji

W skład deklaracji zmiennej może wchodzić warunek archiwizacji tej zmiennej. Do tej pory wpisywało się tam nazwę warunku, którego definicja znajdowała się w osobnym pliku warunków. Aspad 7.12 dostępny od wersji Asix 6.0.2 umożliwia zdefiniowanie warunku bezpośrednio w deklaracji zmiennej (deklaracja in-line).

Ponieważ większość warunków ma prostą jednowierszową postać, to w wielu aplikacjach pozwoli to uniknąć tworzenia pliku warunków.

Takie warunki można wprowadzać w edytorze bazy definicji zmiennych Architekta. Nie można ich stosować z wcześniejszymi wersjami Architekta, gdyż nieprawidłowo interpretuje on dodatkowe przecinki w definicji zmiennej.

Deklarację in-line można zdefiniować na 2 niżej opisane sposoby.

Warunek jako wyrażenie w deklaracji zmiennej

Zamiast nazwy warunku można wpisać bezpośrednio wyrażenie, zgodne ze składnią definicji warunku w pliku warunków, ujęte w nawiasy (). W takim wyrażeniu pomija się pierwszy parametr określający nazwę warunku.

Przykłady

Archiwizuj, gdy bit 4 zmiennej AAA jest równy 1:

(BAND, @AAA, 0x10)

Archiwizuj, gdy bity 4 lub 8 zmiennej AAA zmieniły stan:

(BNE, @AAA, $@AAA, 0x110)

Archiwizuj, gdy bit 0 zmiennej archiwizowanej zmienia stan z 0 na 1:

(BGT, @, $@, 0x1)

Archiwizuj, gdy wartość zmiennej archiwizowanej jest poza przedziałem (20,80):

(IN, @, <<, 20, 80, >>)

Warunek jako argument w deklaracji zmiennej

Zamiast nazwy warunku można wpisać bezpośrednio wyrażenie, zgodne ze składnią argumentu warunku w pliku warunków. Takie wyrażenie musi się zaczynać od !, -, ~, $, @ lub ?.

Przykłady

Archiwizuj, gdy zmienna AAA jest poza przedziałem (-0.5; 0.5):

@AAA

Archiwizuj, gdy zmienna AAA jest w przedziale (-0.5; 0.5):

!@AAA

Archiwizuj, gdy poprzednia wartość zmiennej AAA była poza przedziałem (-0.5; 0.5):

$@AAA

Archiwizuj, gdy warunek QQQ nie jest spełniony:

!?QQQ


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.8. Archiwizacja typu B

7.8. Archiwizacja typu B


7.8.1. Specyficzne cechy archiwizacji typu B

Archiwum typu B pozwala na wykorzystanie typowych baz danych do przechowywania archiwum Aspada. Z jednej strony pozwala to na bardziej elastyczne wykorzystanie takiego archiwum i stwarza możliwość korzystania z niego także w programach nie należących do pakietu A six. Jest także jedynym rodzajem archiwizacji, w którym możliwe jest wypełnienie dziur powstałych w archiwum. Z drugiej strony nie jest w nim stosowana żadna forma kompresji danych lub pomijania nieistotnych zmian wartości, a każdy rekord zajmuje ponad 50 bajtów (uwzględniając pliki indeksowe).

Asix umożliwia przechowywanie archiwów w bazach danych typu SQL.

Ponieważ zapis i odczyt archiwum B jest wolniejszy, a wielkość plików większa niż archiwum D czy M, rozsądnym rozwiązaniem jest stosowanie np. archiwum D do rejestracji przebiegów dla wykresów, a archiwum B do przechowywania danych zagregowanych (np. średnie godzinne do raportów).

Archiwum B umożliwia ponadto:

  • archiwizację dodatkowych informacji o archiwizowanych punktach,

  • archiwizację poszczególnych grup zmiennych w wielu bazach danych,

  • archiwizację niesekwencyjną (wartości mogą przychodzić w dowolnej kolejności),

  • automatyczne tworzenie kartoteki archiwum i nazwy bazy danych w środowisku SQL,

  • przeglądanie zawartości baz danych archiwum B za pomocą standardowych narzędzi przeznaczonych do przeglądania baz danych typu SQL.


7.8.2. Dodatkowe wymagania archiwum typu B

Realizacja archiwizacji danych z wykorzystaniem bazy typu SQL

Oprogramowanie systemowe:

  • Realizacja połączeń z bazami SQL wymaga:

  • MDAC w wersji 2.7 lub nowszego po stronie klienta bazy danych (stacja z systemem Asix) oraz

  • Microsoft SQL Server 2000 po stronie serwera bazy danych,

  • użytkownik bazy danych musi mieć konto na stacji serwera SQL, zapewniające mu dostęp do zapisu do bazy danych,

  • dysk z bazą danych nie może mieć włączonej kompresji.

Oprogramowanie Asix:

Dostęp do bazy SQL realizują ASPAD.DLL (od wersji 6.25) wraz z ASSQL.DLL (od wersji 6.00).

Aby możliwa była archiwizacja typu B, należy załadować dodatkową bibliotekę ASSQL.DLL poprzez zadeklarowanie archiwum rodzaju MS SQL przy użyciu programu Architekt.

Architekt > Obszary i komputery > moduł Dane archiwalne > dodana definicja archiwum z następującymi parametrami:

- Nazwa zasobu,

- Rodzaj archiwum: MS SQL,

- dodatkowe parametry.

Uprawnienia użytkownika:

Uprawnienia użytkownika są weryfikowane na poziomie Windows. Dlatego bieżący użytkownik musi mieć na komputerze serwera SQL nadane uprawnienia dostępu do bazy danych.

Przy pierwszym uruchomieniu baza danych jest tworzona - a użytkownik w tym momencie musi mieć także uprawnienia do tworzenia baz danych.

Uwagi te odnoszą się do wszystkich baz danych deklarowanych w pliku konfiguracyjnym aplikacji, także do wykorzystywanych tylko w deklaracji synchronizacji ( [image] Patrz: Architekt, rozdz. Deklaracja synchronizacji zawartości archiwum typu B z danymi w bazie MS SQL).

Deklaracja udziału na serwerze:

Zapisy do archiwum oraz synchronizacja wymagają utworzenia na komputerze serwera, do którego zapis jest wykonywany, katalogu tymczasowego, udostępnianego jako udział o nazwie ASSQL. Musi on być udostępniony do zapisu dla wszystkich użytkowników, na konto których zapisy będą dokonywane. Katalog ten jest wykorzystywany w celu wymiany plików, pozwalających na wielokrotne zwiększenie szybkości zapisu do bazy.

Udział ASSQL musi zostać utworzony także wtedy, gdy baza danych znajduje się na tym samym komputerze, z którego dokonuje się zapisu.


7.8.3. Uzupełnianie danych w archiwum B

Archiwum B pozwala na uzupełnianie danych w dziurach powstałych na skutek braku łączności ze źródłem danych lub wyłączenia komputera. Aby takie uzupełnienie mogło nastąpić konieczne jest, aby urządzenie będące źródłem danych, udostępniało oprócz danych bieżących także dane historyczne. Także Asmen z drajwerem tego urządzenia muszą udostępniać możliwość sięgnięcia do tych danych.

Parametry Czas pierwszego pobierania i Okres pobierania pozwalają określić, kiedy należy dokonać takiego uzupełnienia:

Architekt > Obszary i komputery > moduł Dane archiwalne > zakładka Pobieranie danych historycznych


7.8.4. Synchronizacja archiwum z bliźniaczą bazą danych

Funkcja synchronizacji archiwum z bliźniaczą bazą danych pozwala na realizację uzupełniania danych w trakcie działania systemu, uwzględniającą uzupełnianie danych historycznych i ręczną edycję danych.

Synchronizacja powoduje kopiowanie przyrostowe. Kopiowane są tylko dane, które zostały dopisane lub zmienione w archiwum źródłowym od ostatniego kopiowania. W przypadku konfliktu z już istniejącymi danymi w archiwum docelowym znajdą się dane o lepszej jakości. W przypadku danych o tej samej jakości preferowane są dane wprowadzane ręcznie.

Można skonfigurować wiele deklaracji synchronizacji, także dla jednego zasobu, co pozwala np. na uzupełnianie danych z kilku bliźniaczych serwerów.

Szczegóły dotyczące deklaracji synchronizacji znajdują się w:

Patrz: Architekt, rozdz. Deklaracja synchronizacji zawartości archiwum typu B z danymi w bazie MS SQL

Porady dotyczące wykorzystania deklaracji synchronizacji

Deklaracja synchronizacji może znaleźć kilka zastosowań. Niżej zostaną pokazane przykłady zastosowania w celu:

  • wzajemnego uzupełniania danych stacji operatorskich,

  • budowy archiwum nadążnego na serwerze pośredniczącym,

  • wykonania kopii archiwum.

Wzajemne uzupełnianie danych stacji operatorskich

Deklaracja synchronizacji pozwala na wzajemne uzupełnianie danych między stacjami operatorskimi, które ma kilka zalet w stosunku do typowego uzupełniania danych w module Aspad:

  • pozwala na uzupełnianie danych w trakcie pracy systemu, a nie tylko na starcie,

  • uzupełnia wszystkie zmiany w archiwum, włączając w to wprowadzone w trakcie pracy systemu dane historyczne i wpisywane ręcznie.

Budowa archiwum nadążnego na serwerze pośredniczącym

Na serwerze pośredniczącym można zadeklarować zasób tylko do odczytu, a następnie jego synchronizację ze stacji operatorskich. Taki serwer nie będzie pobierał danych bieżących z modułu ASMEN. Dane będą cyklicznie pozyskiwane ze stacji operatorskich przy użyciu synchronizacji baz danych. Synchronizacja obejmie wszystkie dopisane dane, także historyczne.

Wykonanie kopii archiwum

Deklarację synchronizacji można stosować do wykonania kopii zapasowej. Kopia powinna być umieszczona na innej stacji niż oryginał. Kopia będzie w pełni funkcjonalną bazą danych.

Na serwerze SQL, na którym tworzona jest kopia, nie musi w tym wypadku działać żaden Asix, a jedynym celem operacji synchronizacji jest uzyskanie zapasowej bazy danych.

Takiego rodzaju kopii można używać tylko w ograniczonym zakresie, gdyż w stosunku do systemowej kopii zapasowej SQL ma ona kilka wad:

  • ma duże rozmiary, gdyż zawiera pliki logu transakcji, pliki indeksowe i wolne obszary, wynikające ze sposobu rozmieszczania informacji w serwerze SQL,

  • nie można jej tworzyć na dysku z kompresją.


7.8.5. Deklaracja bazy danych

Przy archiwizacji w bazie danych typu SQL koniczne jest zadeklarowanie odpowiedniego zasobu archiwalnego, bazy danych i nazwy serwera.

Aby baza danych mogła być używana w systemie Asix, bieżący użytkownik musi mieć uprawnienia dostępu do bazy (musi być użytkownikiem o odpowiednich uprawnieniach na serwerze).

Przy pierwszym uruchomieniu baza jest automatycznie tworzona, a użytkownik w tym momencie musi mieć uprawnienia do tworzenia baz danych na serwerze.

Szczegóły dotyczące deklaracji bazy danych zostały omówione w:

Architekt, rozdz. Konfiguracja danych archiwalnych > Parametryzacja archiwum


Deklaracja zamiennych do archiwizacji w bazie danych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.8. Archiwizacja typu B > 7.8.6 Deklaracja zamiennych do archiwizacji w bazie danych

7.8.6 Deklaracja zamiennych do archiwizacji w bazie danych

Deklaracja zmiennych do archiwizacji w bazie danych dokonywana jest przy użyciu odpowiednich parametrów archiwizacji zmiennych ( [image] Patrz: Parametry archiwizacji zmiennych).


7.8.7. Dodatkowe informacje o archiwizowanych punktach

Typowo archiwizowane są wartość i czas punktu, przy czym można tak sparametryzować archiwum, aby rozszerzyć rekord o dodatkowe pola. Archiwum B pozwala na zapamiętanie następującego zestawu pól.

Archiwizacja w bazie danych SQL

Baza danych archiwum B w SQL może zawierać następujące pola:

  1. Pola obowiązkowe:

  • czas podstawowy (T),

  • jakość danej,

  • wartość (X).

2. Pola opcjonalne:

  • czas dokładny danej (XT),

  • czas zapisu rekordu (WT),

  • okres ważności próbki (VT).

wartość (X)

Liczba określająca wartość zmiennej.

czas podstawowy (T)

Przy archiwizacji z zadanym cyklem próbkowania jest to czas początku kolejnego cyklu. Jest on wyznaczany w następujący sposób:

czas danej zaokrąglany jest do najbliższej wielokrotności zadanej dokładności rejestracji, np. przy dokładności rejestracji równej 5 minut 1:17:30 zostanie zaokrąglony do 1:20:00, 1:22:00 do 1:20:00, a 1:22:30 do 1:25:00;

tak zaokrąglony czas jest ponownie zaokrąglany w dół do wielokrotności cyklu próbkowania, np. przy cyklu 15-minutowym czas 1:20:00 i 1:25:00 będą zaokrąglone do 1:15:00.

Przy archiwizacji bez zadanego cyklu (atrybut KAŻDY) jest to czas danej zaokrąglany tylko do zadanej dokładności rejestracji.

czas danej (XT) - pole opcjonalne

Dokładny czas przypisany do zmiennej, zaokrąglony z dokładnością zadaną przy parametryzacji. Jeżeli archiwum nadano atrybut KAŻDY, to jest on równy czasowi podstawowemu.

czas zapisu (WT) - pole opcjonalne

Czas zapisu danej w bazie. Pole jest istotne w systemach z opóźnionym pozyskiwaniem danych.

okres ważności próbki (VT) - pole opcjonalne. Określa, czy w bazie danych będzie archiwizowany czas ważności próbki (+VT), czy też na być pomijany, a domyślnym czasem ważności ma być okres archiwizacji (-VT); w efekcie, dla -VT, gdy zostanie w przyszłości skrócony okres archiwizacji, to dane historyczne będą oddzielone dziurami; domyślnie czas ważności jest archiwizowany.

Włączenie opcji powoduje dodanie 4-bajtowego pola do każdego rekordu danych;

4-bajtowe identyfikatory zmiennych (SV) - pole opcjonalne. Po zaznaczeniu identyfikatory zmiennych będą 4-bajtowe, zamiast 2-bajtowych. Opcja ma znaczenie tylko w aplikacjach, w których przewidujemy deklaracje ponad 32 767 zmiennych w pojedynczej bazie danych, wliczając w to zmienne, które zostały dodane i później usunięte. Koszt, to ponad 4 bajty na próbkę (2 bajty w tablicy i ponad 2 bajty w indeksie).

8-bajtowe identyfikatory rekordów archiwizowanych danych (SD) - pole opcjonalne. Po zaznaczeniu identyfikatory rekordów archiwizowanych danych będą 8-bajtowe, zamiast 4-bajtowych. Opcja ma znaczenie tylko w aplikacjach, w których przewidujemy możliwość zapisu ponad 2 147 483 647 próbek w pojedynczej bazie danych, wliczając w to próbki, które zostały zapisane i później usunięte oraz próbki, które zostały poprawione, np. w wyniku synchronizacji z innym archiwum (próbka o lepszej jakości zastępuje próbkę o gorszej, a licznik próbek zwiększa się o 1). Koszt, to ponad 8 bajtów na próbkę (4 bajty w tablicy i ponad 4 bajty w indeksie).

Szczegóły dotyczące parametryzacji dodatkowych informacji archiwizowanych punktów znajdują się w:

Architekt, rozdz. Parametryzacja archiwum


7.8.8. Archiwizacja w wielu bazach danych

Możliwe jest deklarowanie dla jednej aplikacji wielu archiwów/baz danych, w których prowadzona będzie archiwizacja zmiennych procesowych. Oznacza to utworzenie wielu archiwów, z których każdy przypisany jest do innej bazy MS SQL.


7.8.9. Archiwizacja niesekwencyjna

Po zadaniu atrybutu KAŻDY do archiwum B będą zapisywane wszystkie pobrane przez drajwer Asmena dane, niezależnie od kolejności ich pobierania.

Patrz: Atrybuty archiwizacji


7.8.11. Przeglądanie zawartości bazy danych archiwum B za

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.8. Archiwizacja typu B > 7.8.10. Przeglądanie zawartości bazy danych archiwum B za

7.8.10. Przeglądanie zawartości bazy danych archiwum B

W przypadku baz danych typu SQL - istnieje możliwość przeglądania ich zawartości przy użyciu standardowych narzędzi przeznaczonych do tego celu.


7.9. Przebiegi wzorcowe

Przebiegi wzorcowe są specyficznym rodzajem archiwum, w którym dane są gromadzone tylko w chwili parametryzacji aplikacji. Zapisuje się w nich przebieg wartości, który następnie może być odtworzony z dowolnym przesunięciem czasowym. Są one traktowane jako dodatkowy typ archiwum tylko do odczytu oznaczany literą P.

Dane wzorców są przechowywane w bazie danych analogicznej do archiwum B. Wzorce najlepiej umieścić w osobnej bazie danych, traktowanej jako odrębny zasób programu Aspad. Jest możliwe umieszczenie archiwum B i P w tej samej bazie danych, ale nie jest to zalecane.

Rozszerzone możliwości w zakresie przebiegów wzorcowych omawia rozdział [image] Przebiegi wzorcowe.


7.9.1. Deklaracja przebiegu wzorcowego

Przebieg wzorcowy jest oznaczany jako typ P. Deklaracja takiego przebiegu nie może być umieszczona w archiwum do zapisu - musi to być deklaracja archiwum do odczytu lub sieciowego.

Dla archiwum do odczytu, zawierającego przebiegi typu P, konieczna jest deklaracja bazy danych (Archiwum do odczytu zadeklarowane jako MSSQL), identycznie jak dla przebiegów typu B.

Deklaracja przebiegu wzorcowego wymaga:

1. utworzenia archiwum;

2. zadeklarowania w definicji zmiennej, która ma być archiwizowana, nazwy przebiegu w polu Nazwa, typu archiwum P w parametrach archiwizacji (pole Parametry archiwizacji) oraz nazwy utworzonego archiwum (pole Archiwum).

Nazwa przebiegu nie powinna być nazwą żadnej zmiennej Asixa.

Czas ważności danej jest dla przebiegu P zawsze ustawiany na 1 dobę, a pozostałe parametry są nieistotne.


7.9.2. Generacja przebiegów wzorcowych

Do generacji przebiegów wzorcowych służy program PEdit.

Szczegółowy opis użycia programu PEdit można znaleźć w dokumentacji Przebiegi Wzorcowe, znajdującym się w kartotece instalacyjnej dokumentacji pakietu Asix (domyślnie C:\Program Files\Askom\Asix\Dokumentacja).


7.10. Agregacja danych archiwalnych

Od wersji 5 system Asix posiada funkcję agregacji danych archiwalnych. Funkcję tę realizują moduły wchodzące w skład programu Aspad, 'scalone' wspólną nazwą Agregator. Obliczone agregaty udostępniane są programom pobierającym dane za pośrednictwem serwerów AsixConnect (programy: AsTrend, AsAlarm i moduł skryptów).

Agregator odczytuje dane surowe i na ich podstawie wylicza zadane agregaty oraz zapisuje je w archiwum danych zagregowanych.

Agregator pozwala również na wykonanie agregacji przy odczycie danych. Na podstawie danych surowych oraz zapisanych danych zagracowanych Agregator wylicza agregaty także w okresach innych niż zarchiwizowane.

Archiwum wartości zagregowanych przechowywane jest w plikach binarnych o wewnętrznym formacie.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 7. Program Archiwizacji Danych Aspad > 7.10. Agregacja danych archiwalnych > 7.10.1. Warunki agregacji

7.10.1. Warunki agregacji

Agregator korzysta z podstawowego rodzaju archiwum danych, co wymaga określenia podstawowego typu archiwizacji dla każdej zmiennej.


7.10.2 Parametryzacja

Parametry agregacji i archiwizacji agregatów przechowywane są w pliku konfiguracyjnym XML aplikacji systemu Asix.

Parametryzacji należy dokonać przy użyciu programu Architekt:

Architekt > Obszary i komputery > Dane archiwalne > <nazwa zadeklarowanego archiwum> > zakładka Agregaty:

Parametry:

Lista okresów - jest listą okresów agregacji w konwencji modułu danych archiwalnych oddzielonych pionowymi liniami, np. 5m | 1h - oznacza wyliczanie agregatów 5-minutowych i 1-godzinnych.

Lista agregatów - jest listą nazw agregatów, oddzielonych pionowymi liniami, np.: Jakość_Dobra | Jakość_Zła | Średnia

Horyzont agregacji - to ograniczenie na najstarsze dane do agregacji, podane w konwencji modułu danych archiwalnych, np.: 366d - oznacza, że nie będą archiwizowane agregaty starsze niż rok. Horyzont agregacji nie jest wymagany - brak wartości oznacza agregację wszystkich danych.


7.10.3 Zestaw agregatów

Lista dostępnych agregatów:

- Początek - wartość na początku interwału

- Koniec - wartość na końcu interwału

- Przyrost - różnica wartości na końcu i na początku interwału

- Min - minimalna wartość w interwale

- Max - maksymalna wartość w interwale

- Zakres - różnica między maksymalna a minimalna wartością w interwale

- Suma - suma wartości ważonych czasowo w interwale (całka po czasie)

- Suma0 - suma wartości ważonych czasowo (całka po czasie); w okresach, w których próbka ma jakość zła, do obliczeń używana jest wartość 0

- Średnia - średnia wartości ważonych czasowo w interwale

- Średnia0 - średnia wartości ważonych czasowo w interwale; w okresach, w których wartość jest niedostępna do obliczeń, używana jest wartość 0.

- Jakość_Dobra - procent próbek o jakości dobrej w interwale

- Jakość_Niepewna - procent próbek o jakości niepewnej w interwale

- Jakość_Zła - procent próbek o jakości złej w interwale

- Jakość_Dobra_Czas - czas trwania (w sekundach) czasu w przedziale, w którym dane mają jakość dobrą

- Jakość_Niepwewna_Czas - czas trwania (w sekundach) czasu w przedziale, w którym dane mają jakość niepewną

- Jakość_Zła_Czas - czas trwania (w sekundach) czasu w przedziale, w którym dane mają jakość złą

- Suma_Wzrostów - suma wartości dodatnich zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem przedziału próbkowania.

Dla typów FLOAT, DOUBLE i INT64 wynik przechowywany jest jako FLOAT, a dla pozostałych jako LONG.

Jednym ze sposobów wykorzystania agregatu jest obliczanie liczby załączeń. Wystarczy w tym celu zagregować zmienną, która przyjmuje wartość 0 przy wyłączonym urządzeniu, a wartość 1 przy włączonym.

- Suma_Spadków - suma wartości bezwzględnych ujemnych zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem przedziału próbkowania.

Dla typów FLOAT, DOUBLE i INT64 wynik przechowywany jest jako FLOAT, a dla pozostałych jako LONG.

Jednym ze sposobów wykorzystania agregatu jest obliczanie liczby wyłączeń. Wystarczy w tym celu zagregować zmienną, która przyjmuje wartość 0 przy wyłączonym urządzeniu, a wartość 1 przy włączonym.

- Poprzedni_Znany - ostatnio znana (dobra lub niepewna) wartość przed rozpoczęciem przedziału próbkowania. Podaje ostatnią wartość, nawet jeżeli wystąpiła ona bardzo dawno.

Dla typów FLOAT, DOUBLE i INT64 wynik przechowywany jest jako FLOAT, a dla pozostałych jako LONG.

- Ostatni - ostatnio znana (dobra lub niepewna) wartość w przedziale próbkowania wyłączając koniec przedziału - dla odróżnienia od agregatu End, który zawiera koniec przedziału.

Dla typów FLOAT, DOUBLE i INT64 wynik przechowywany jest jako FLOAT, a dla pozostałych jako LONG.

- Odchylenie_Standardowe - ważone czasowo odchylenie standardowe w przedziale próbkowania. Wynik jest zawsze typu FLOAT.

Odchylenie standardowe jest liczone jako

- Średnia_Kwadratowa - ważona czasowo średnia kwadratowa w przedziale próbkowania. Wynik jest zawsze typu FLOAT.

Średnia kwadratowa jest liczona jako

- Średnia_Ostatnia_Znana - średnia ważona czasowo w przedziale próbkowania; w miejsce złych wartości wstawia ostatnią znaną wartość. Wynik jest zawsze typu FLOAT.

Średnia_Ostatnia_Znana jest lepsza od Średnia dla zmiennych, które z natury mają w dłuższych okresach wartość stałą, np. sygnał pracy urządzenia.

- Suma_Ostatnia_Znana - całka w przedziale próbkowania; w miejsce złych lub brakujących wartości wstawia ostatnią znaną wartość. Wynik jest zawsze typu FLOAT.

Jednym ze sposobów wykorzystania agregatu jest obliczanie czasu pracy urządzeń. Wystarczy w tym celu zagregować zmienną, która przyjmuje wartość 0 przy wyłączonym urządzeniu, a wartość 1 przy włączonym. Wynik będzie czasem pracy w sekundach.


8. Aslink - moduł sieciowy

Aslink jest modułem, który umożliwia innym komponentom systemu Asix wzajemną komunikację poprzez lokalną sieć komputerową. Aslink definiuje zestaw usług sieciowych, z których korzystają wszystkie inne programy systemu Asix, sparametryzowane do pracy w sieci.

W swoim działaniu Aslink wykorzystuje usługi dostarczane przez emulator NETBIOS, tzn. program implementujący jeden z najpowszechniej stosowanych interfejsów sieciowych w warstwie transportu. Specyfikacja NETBIOS została opracowana przez IBM; Aslink opiera się na specyfikacji NETBIOS wersja 3.0 zawartej w IBM Local Area Network Technical Reference (IBM Part Number SC30-3587-00). Podstawą działania Aslinka są NETBIOS'owe usługi połączeniowego (inaczej: sesyjnego) przesyłu danych.

Wersja Aslinka dla systemów WINDOWS NT, WINDOWS 2000, WINDOWS XP wykorzystuje standardowy interfejs NETBIOS udostępniany przez wymienione systemy operacyjne.

Zwracamy uwagę, że instalowanie usług sieciowych jest zbędne w tych konfiguracjach Asixa, gdzie nie jest wymagany dostęp do sieci komputerowej.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 8. Aslink - moduł sieciowy > 8.1. Ogólna charakterystyka modułu Aslink

8.1. Ogólna charakterystyka modułu Aslink


8.1.1. Usługi wiarygodnego przesyłu danych

Podstawowa usługa świadczona między innymi na rzecz takich komponentów pakietu A six, jak Asmen, Aspad czy podsystem obsługi alarmów - to wiarygodny przesył danych pomiędzy każdą parą procesów użytkowych, działających na dowolnych stanowiskach przyłączonych do sieci komputerowej i realizujących wspólny protokół użytkowy. W tym zakresie usługi modułu Aslink ukierunkowane są na wsparcie komunikacji opartej na istnieniu procesu "serwera" i korzystającego z jego usług procesu "klienta". W szczególności Aslink zapewnia:

  • wyszukanie w sieci procesów pełniących rolę serwerów w odniesieniu do zasobów potrzebnych procesom klientów,

  • nawiązanie połączenia (tzw. kanału) pomiędzy klientem i wskazanym przez niego serwerem zasobu,

  • dwukierunkowy, wiarygodny przesył danych w każdym z kanałów,

  • powiadomienie procesów, że kanał został zamknięty wskutek awarii sieci lub na jawne polecenie któregoś z partnerów.


8.1.2. Usługa synchronizacji czasu

W przypadku instalacji sieciowych Asixa bardzo istotne jest zapewnienie zgodności czasu na poszczególnych stanowiskach. W tym celu przynajmniej jedno stanowisko powinno dysponować dobrym źródłem aktualnego czasu i spełniać funkcje serwera czasu, czyli systemu udostępniającego czas innym stanowiskom sieciowym. Funkcja synchronizacji czasu została zaimplementowana w module sieciowym Aslink. W zależności od parametryzacji Aslink może pełnić funkcję serwera czasu lub jedynie synchronizować swój czas z aktywnym serwerem czasu. Każdy serwer posiada swój priorytet. W danej chwili aktywny jest tylko serwer o najwyższym priorytecie. Pojawienie się w sieci nowego serwera o wyższym priorytecie powoduje przejście aktualnego serwera w stan zwykłej synchronizacji tj. odbierania czasu od nowego serwera. Wyłączenie (lub awaria) aktualnego serwera powoduje aktywizację jednego z pozostałych serwerów. Innym parametrem charakteryzującym pracę serwera czasu jest częstotliwość, z jaką serwer rozgłasza w sieci swój aktualny czas. Wszystkie stacje, odbierające aktualny czas rozgłaszany przez aktywny serwer, dokonują synchronizacji swojego czasu, gdy różnica pomiędzy czasem własnym i serwera przekroczy pewną dopuszczalną, określoną parametrem wartość.


8.1.3. Usługi zdalnego zapisu plików

Moduł Aslink świadczy na rzecz modułów wbudowanych w pakiet Asix także usługi związane z transferem plików pomiędzy stanowiskami sieciowymi. Na tej bazie możliwe jest w sieci stanowisk Asix zdalne przeglądanie katalogów, skopiowanie pliku na dysk lokalny, zapis pliku na dysk zdalny, czy skasowanie pliku. Opcje związane z zapisem/usuwaniem plików można udostępniać wybiórczo na poszczególnych stanowiskach, odpowiednio w tym celu parametryzując moduł Aslink.


8.1.4. Konfiguracje wielokartowe

ASLINK może współpracować z kilkoma kartami sieciowymi jednocześnie. Nie powoduje to jednak bezpośredniego połączenia komputerów dwóch różnych sieci. Przepływ danych pomiędzy sieciami wymaga jeszcze działania na komputerach pomostu odpowiednio sparametryzowanych modułów Asmena i Aspada.


8.2.1. Typy obsługiwanych lokalnych sieci komputerowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 8. Aslink - moduł sieciowy > 8.2. Typy obsługiwanych rodzajów komunikacji

8.2. Typy obsługiwanych rodzajów komunikacji

Aslink może pracować w każdej sieci akceptowanej przez systemy operacyjne, na których pracuje system Asix.

Istnieją 2 typy pracy:

1. oparty na NETBIOS - w konfiguracji karty sieciowej wymaga włączenia obsługi protokołu NetBT;

działa we wszystkich wersjach systemu Asix;

działa w dwóch wariantach:

- tylko w jednej sieci lokalnej - tryb zwykły; aktywne poszukiwanie serwerów;

- w przypadku użycia w kilku segmentach - połączenia sesyjne (należy użyć opcji Połączenia sesyjne); wymaga zdefiniowania wszystkich serwerów, z którymi będą nawiązywane połączenia;

2. wykorzystanie własnego protokołu bazującego na TCPIP;

działa w sieci rozległej i wielu segmentach sieci lokalnej;

wymaga zdefiniowania wszystkich serwerów, z którymi będą nawiązywane połączenia;

działa w systemie Asix od wersji 6.0

Zaleca się wykorzystanie własnego protokołu bazujacego na TCPIP.

Komunikacja pomiędzy modułami systemu Asix na jednym komputerze odbywa się po protokole wewnętrznym.

Jeśli program Architekt został uruchomiony bez uruchamiania aplikacji systemu Asix, a serwer Asix6 używa tylko protokołu TCP/IP lub znajduje się w innej podsieci, to należy skonfigurować połączenie TCP/IP z tym serwerem używając polecenia: Architekt > menu Narzędzia > Moduł sieci - opcje dla serwerów.


8.3. Parametryzacja modułu ASLINK

Parametryzacja modułu Aslinkj w całości odbywa się przy użyciu programu Architekt.

Patrz: Architekt, cały rozdział Konfiguracja modułu sieci


8.3.1. Identyfikacja stacji

Stacje identyfikowane są za pomocą nazw. Każda stacja powinna mieć unikalną w sieci nazwę. Oprócz nazwy indywidualnej, każda stacja należy do grupy stacji posiadających wspólną nazwę grupową. Wymiana danych pomiędzy stacjami należącymi do różnych grup nie jest możliwa. Dotyczy to również synchronizacji czasu - czas stacji jest synchronizowany tylko wewnątrz jednej grupy. Wyjątkiem od powyższej zasady są stacje pracujące pod kontrolą modułu sieciowego w wersji niższej niż 5.00.000. Moduł sieciowy w wersji 5.00.000 lub wyższej, sparametryzowany do współpracy ze stacjami o niższych wersjach będzie mógł się z nimi łączyć oraz synchronizować czas. Stacje pracujące pod kontrolą starszych wersji modułu sieciowego należą do wszystkich grup.

Parametr nazwy służy do nadawania stacji unikalnej nazwy sieciowej:

program Architekt > Obszary i komputery > Moduł sieci > zakładka Nazwa komputera > opcja Automatyczne nadawanie sieciowych nazw komputerom / Sieciowa nazwa komputera

Parametr grupy przyporządkowuje stacji nazwę grupową (dla komunikacji poprzez NetBIOS):

program Architekt > Obszary i komputery > Moduł sieci > zakładka Komunikacja poprzez NetBIOS > Zaawansowane > Nazwa grupy


8.3.2. Dostęp do sieci

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 8. Aslink - moduł sieciowy > 8.3. Parametryzacja modułu ASLINK > 8.3.2. Dostęp do sieci przy komunikacji poprzez NetBIOS

8.3.2. Dostęp do sieci przy komunikacji poprzez NetBIOS

Moduł sieciowy Aslink realizuje dostęp do sieci za pomocą adapterów logicznych. Adapter logiczny to fizyczny adapter sieciowy oraz zestaw związanych z nim protokołów sieciowych. Adaptery logiczne identyfikowane są za pomocą numerów. W systemie Windows powiązania numerów logicznych z protokołami i rzeczywistymi adapterami sieciowymi można ustalić za pomocą ustawień sieciowych systemu operacyjnego. Do odczytu tych powiązań można również wykorzystać program AslView.

Zestaw adapterów logicznych podaje się za pomocą parametru Używane karty sieciowe i protokoły (Architekt > Obszary i komputery > Moduł sieci > zakładka Komunikacja poprzez NetBIOS > Protokoły sieciowe). Wartością tego parametru są nazwy protokołów lub numery adapterów logicznych oddzielone przecinkiem. Jeśli jako wartość podano znak "*", to zostaną wykorzystane wszystkie dostępne w systemie operacyjnym adaptery logiczne.

W niektórych zastosowaniach konieczne jest ograniczenie zbioru stacji, z którymi można nawiązywać połączenie. Do tego celu służy parametr Karty sieciowe i protokoły używane przez moduł sieciowy do szukania serwerów (Architekt > Obszary i komputery > Moduł sieci > zakładka Komunikacja poprzez NetBIOS > Protokoły sieciowe). Jako wartość podaje się numery adapterów, na których będą szukane serwery. Parametr ma wpływ jedynie na działanie klientów na stacji lokalnej. Nie ogranicza on połączeń dokonywanych z inicjatywy zdalnych klientów. Brak tego parametru lub podanie znaku '*’ jako jego wartości spowoduje, że do szukania będą wykorzystane wszystkie adaptery.

Innym sposobem ograniczenia zbioru stacji, z którymi mogą być nawiązywane połączenia jest użycie parametru Filtrowanie sieciowych nazw komputerów (Architekt > Obszary i komputery > Moduł sieci > zakładka Zaawansowane). Wartością tego parametru są oddzielone przecinkiem nazwy stacji, z którymi mogą być nawiązywane połączenia. Parametr dotyczy tylko nawiązywania połączeń ze zdalnymi serwerami. Klienty na zdalnych stacjach mogą łączyć się z serwerami na lokalnej stacji bez ograniczeń. Jeśli nazwa filtru zawiera znaki "?", to porównywanie nazwy zdalnej stacji z filtrem nie będzie przeprowadzone w miejscu tych znaków. Przykładowo, jeśli w sieci znajdują się stacje o nazwach A1X, A2X, i B1X, a filtr ma postać A?X, to będą możliwe połączenia z serwerami na stacjach A1X i A2X, ale nie będą możliwe ze stacją B1X. Nazwa filtru może zawierać znak "*". W takim przypadku nazwy filtru i stacji są porównywane tylko w części poprzedzającej znak "*".

PRZYKŁADY

W systemie zdefiniowane są adaptery ujęte w tabeli poniżej.

Tabela: Adaptery logiczne modułu sieciowego ASLINK.

Wybrane protokoły: NBF

wszystkie adaptery logiczne z protokołem Nbf, ale bez łączy typu WAN

Wybrane protokoły: Realtek&#2

wszystkie adaptery logiczne związane z kartą " Karta Realtek RTL8029(AS) PCI Ethernet Adapter #2"

Wybrane protokoły: Nbf+Realtek, IPX

wszystkie adaptery logiczne związane z protokołem Nbf i kartami Realtek oraz z protokołem IPX (NwlnkNb)

Wybrane protokoły: tcpip

wszystkie adaptery logiczne związane z protokołem TCP/IP, ale bez łączy typu WAN

Wybrane protokoły: tcpip&3Com

adapter logiczny 2 (protokół TCP/IP na karcie 3Com)

Wybrane protokoły: NETBEUI&In

adapter logiczny 8 (połączenie WAN przychodzące)

Wybrane protokoły: - TCPIP&3Com

wszystkie adaptery z wyjątkiem adaptera logicznego 2 (protokół TCP/IP i karta 3Com) oraz połączeń typu WAN

Wybrane protokoły: - IPX

wszystkie adaptery logiczne za wyjątkiem adapterów związanych z protokołem IPX i łączami typu WAN

Wybrane protokoły: - /2

wszystkie adaptery logiczne za wyjątkiem adapterów związanych z kartą o numerze 2 (numer slotu) oraz łączami typu WAN

Wybrane protokoły: 1,3,5

adaptery logiczne 1, 3 i 5

Wybrane protokoły: *, wan

wszystkie adaptery logiczne

Domyślna wartość specyfikacji adapterów ma postać:

Wybrane protokoły: *

tzn. wszystkie adaptery z wyjątkiem tych związanych z łączami typu WAN


8.3.3. Synchronizacja czasu

Moduł sieciowy Aslink może synchronizować swój czas z innymi stacjami (Architekt > Obszary i komputery > Moduł sieci > zakładka Synchronizacja czasu).

Synchronizację czasu z innymi stacjami można wyłączyć opcją Synchronizacja czasu. Jeśli różnica czasu pomiędzy stacją a zdalnym serwerem czasu przekroczy wartość określoną parametrem Maksymalna różnica czasu, w co najmniej tylu kolejno otrzymanych pakietach, ile zdefiniowano parametrem Liczba pakietów czasu, to nastąpi ustawienie czasu lokalnej stacji. Maksymalną różnicę czasu podaje się w sekundach. Do ograniczenia zbioru serwerów czasu, z którymi czas może być synchronizowany, służy parametr Ograniczenia synchronizacji czasu. Jego wartością jest lista serwerów czasu. Podobnie jak w przypadku filtrów, nazwy serwerów mogą zawierać znaki "?" i "*". Aby stacja zmieniła swój czas, musi otrzymać od jednego serwera czasu przynajmniej taką ilość kolejnych pakietów czasu, która jest określona parametrem Liczba pakietów czasu.

Aby stacja pełniła w sieci funkcję serwera czasu, należy podać parametry Priorytet serwera czasu oraz Interwał serwera czasu. Jeśli jedna z tych wartości jest mniejsza niż zero, to stacja nie będzie pełnić funkcji serwera czasu. Jeśli wartość parametru jest równa 0, to jako wartość przyjmuje się 5 dla priorytetu i 10 dla interwału. Priorytet serwera to liczba określająca ważność serwera czasu. W danej chwili jest aktywny tylko jeden serwer o najwyższym priorytecie. Aktywny serwer czasu rozsyła pakiety sieciowe zawierające bieżący czas serwera czasu z interwałem określonym parametrem Interwał serwera czasu. Interwał podaje się w sekundach.

Jeżeli serwer przestaje być aktywny, to jego funkcje może przejąć inny serwer, który był nieaktywny z powodu niskiego priorytetu. Serwer może podjąć funkcje serwera czasu, jeżeli dotychczasowy serwer nie nada żadnego pakietu przez okres czasu równy iloczynowi wartości parametru Warunek aktywacji serwera czasu (zdefiniowany na lokalnej stacji) i interwału dotychczasowego serwera czasu (zdefiniowanej na zdalnej stacji serwera czasu). Aby uniknąć sytuacji, w której błędna parametryzacja zdalnego serwera czasu (np. interwał równy 1 godzina), powoduje, że sieć nie jest w długim okresie czasu synchronizowana, wprowadzono parametr Interwał serwera czasu. Jeżeli interwał serwera czasu, z którego nowy serwer nie otrzymuje pakietów czasu, jest większy niż wartość określona tym parametrem, to do obliczenia czasu, po jakim nowy serwer podejmie działanie, przyjmowana jest wartość określona parametrem.

Jeśli różnica czasu pomiędzy czasem serwera a czasem lokalnym jest większa niż wartość określona parametrem Duża różnica czasu, to zmiana czasu stacji nastąpi dopiero po otrzymaniu przynajmniej tylu pakietów, ile jest określone parametrem Duża różnica czasu - licznik. Parametry te dają czas na wprowadzenie korekty błędnego ustawienia czasu przez operatora zdalnej stacji.

Serwer nadaje pakiety czasu do wszystkich wykorzystywanych adapterów logicznych. Jeśli klient serwera czasu obsługuje kilka adapterów logicznych, to otrzymane z jednego adaptera pakiety czasu może przesyłać do pozostałych adapterów. Funkcja ta może być wykorzystywana do synchronizacji czasu w podsieciach innych niż podsieć, w której pracuje serwer czasu. Aby uruchomić rozsyłanie czasu do innych sieci, należy parametrowi Replikacja pakietów czasu nadać wartość Tak na stacji podłączonej do wielu podsieci. Pakiety czasu mogą podlegać dalszej replikacji na kolejnych stacjach aż do chwili, gdy ilość replikacji przekroczy wartość parametru Replikacja pakietów czasu (parametr ustawiany dla Serwera). Parametr definiuje się na serwerze czasu. Aby zmienić maksymalną ilość replikacji na stacjach, które dokonują replikacji, należy podać parametr Replikacja pakietów czasu (parametr ustawiany dla Klienta).


8.3.4. Zabezpieczenie hasłem

Z pomocą programu AslView jest możliwe wykonanie funkcji, które mogą mieć istotny wpływ na działanie modułu sieciowego. Aby uniknąć przypadkowego lub nieuprawnionego dostępu do tych funkcji, wprowadzono możliwość zabezpieczenia modułu sieciowego hasłem. Hasło można podać za pomocą parametru Blokada zmian (Architekt > Obszary i komputery > Moduł sieci > zakładka Diagnostyka - AslView). Wartością tego parametru mogą być słowa Tak, Nie lub tekst hasła. Jeśli podano Tak, to wykonanie funkcji chronionych hasłem będzie niemożliwe. Jeśli wartością parametru jest słowo Nie, to dostęp do modułu sieciowego jest nieograniczony. Inne wartości są interpretowane jako hasło, które musi zostać podane przez użytkownika przed wykonaniem funkcji chronionej hasłem. Raz wprowadzone hasło jest ważne przez 10 minut. Każde kolejne wykonanie funkcji chronionej hasłem powoduje rozpoczęcie odliczania czasu od początku.


8.3.5. Połączenia ze starszymi wersjami modułu sieciowego

Stacja pracująca pod kontrolą modułu sieciowego w wersji 5.00.000 lub późniejszej może łączyć się ze starszymi wersjami modułu sieciowego tylko wtedy, gdy włączony jest parametr Aslink 4 (Architekt > Obszary i komputery > Moduł sieci > zakładka Zaawansowane). Możliwość ta wiąże się ze zwiększonym obciążeniem sieci w fazie nawiązywania połączenia. Domyślnie parametr Aslink4 jest wyłączony.

Uruchomienie modułu sieciowego w wersji mniejszej niż 5.00.000 na stacji, na której uprzednio pracował moduł nowszej wersji, musi wiązać się z ponownym uruchomieniem wszystkich zdalnych stacji na których pracują nowsze wersje modułu sieciowego (należy ponownie uruchomić aplikacje korzystające z modułu sieciowego Aslink). Konieczność ponownego uruchomienia nie dotyczy stacji pracujących z modułem w starszej wersji.


8.3.6. Diagnostyka

Parametry sterują informacjami diagnostycznymi wyprowadzanymi przez moduł sieciowy Aslink. Niniejszy dokument nie zawiera danych pozwalających na pełną interpretację informacji diagnostycznych. Celem diagnostyki jest pomoc w ustaleniu przyczyn nieprawidłowości funkcjonowania połączeń sieciowych systemu A six i powinna być ona uruchamiana przez pracowników firmy ASKOM lub przy ich wsparciu.

Informacje diagnostyczne wygenerowane przez moduł sieciowy mogą być zapisywane w pliku log i/lub przekazywane do programów AslView przyłączonych do modułu sieciowego.

Parametr Plik logu (Architekt > Obszary i komputery > Moduł sieci > zakładka Diagnostyka) definiuje nazwę oraz położenie pliku, do którego będą wyprowadzane informacje diagnostyczne. Obok nazwy, po przecinku, można podać maksymalną wielkość pliku log wyrażoną w megabajtach.


9. Konstruktor - projektowanie aplikacji

Zasadniczą częścią każdej aplikacji jest zestaw diagramów (masek) wizualizacyjnych. Pozwalają one na prezentację aktualnego stanu kontrolowanego procesu przemysłowego. Każda maska składa się ze zbioru obiektów, których zadaniem jest przedstawienie w formie graficznej wartości zmiennych procesowych (pobieranych za pośrednictwem menedżera Asmen) oraz archiwalnych (gromadzonych przez moduł Aspad). Program AS pozwala na edycję masek niezależnie od trybu, w jakim jest wykonywany. Również w trybie realizacji aplikacji możliwe jest przejście do trybu konstrukcyjnego, co pozwala na zmianę masek na działającym systemie aplikacyjnym.


9.1. Okno Konstruktora

Centralnym elementem programu AS w trakcie pracy w trybie konstrukcyjnym jest Okno Konstruktora. Okno to jest automatycznie otwierane w momencie startu programu AS w trybie konstrukcyjnym, lub w momencie przejścia do konstruktora w systemie aplikacyjnym (komendą MASKI.KONSTRUKTOR z okna Panelu Kontrolnego).

Okno Konstruktora spełnia poniższe funkcje:

  • udostępnia zestaw komend służących do projektowania aplikacji,

  • pokazuje pola kontrolne używane w czasie tworzenia masek,

  • pokazuje i przechowuje komunikaty dotyczące wewnętrznej pracy systemu.

Okno Konstruktora pozostaje otwarte przez cały czas pracy w trybie konstrukcyjnym. Zamknięcie okna jest równoznaczne z końcem działania programu. W przypadku, gdy konstruktor był uruchomiony w ramach systemu aplikacyjnego, istnieje możliwość zablokowania operacji zamknięcia okna lub jej ochrony hasłem.


9.1.1. Elementy składowe Okna Konstruktora

Okno Konstruktora zostało pokazane poniżej:

Rysunek: Okno Konstruktora.

Okno Konstruktora składa się z czterech zasadniczych elementów:

linia tytułu - podawana jest tutaj nazwa pliku inicjującego opisującego aktualną aplikację;

pasek menu rozwijanego - menu udostępniające komendy służące do projektowania aplikacji; niektóre z tych komend są dublowane poprzez kombinację klawiszy, których przyciśnięcie jest równoznaczne wykonaniu komendy;

obszaru pól statusowych - w obszarze tym znajdują się pola pomocne w fazie projektowania masek:

Obiekt - pole podające nazwę aktualnie wybranego obiektu lub liczbę wybranych obiektów;

Maska - pole podające nazwę bieżącej maski; jeżeli maska jest w stanie odświeżania, to pokazywany jest odpowiedni komentarz; jeżeli maska była zmieniona, to przed nazwą maski pojawia się znak *;

Typ Nowego - rozwijane pole pokazujące nazwę klasy obiektu, który zostanie wstawiony na edytowaną maską; pole służy też do wyboru klasy, poprzez wskazanie na rozwiniętej liście wszystkich dostępnych klas;

lista komunikatów - lista, w której wyświetlane są komunikaty związane z pracą programów systemu Asix.


9.1.2. Opis menu Okna Konstruktora

Menu:

PLIKI

EDYCJA

MASKI

NARZĘDZIA

OPCJE

OKNA

POMOC

Poniżej opisane zostały komendy znajdujące się w menu Okna Konstruktora. Bardziej szczegółowych informacji dotyczących niektórych z tych komend należy szukać w odpowiednich rozdziałach tematycznych. Zestaw dostępnych komend jest różny w zależności od trybu wystartowania programu. Na przykład, jeżeli start nastąpił w trybie aplikacyjnym, to blokowane są komendy pozwalające na zmianę aplikacji.

PLIKI.NOWY

Utworzenie nowego pliku inicjującego, to znaczy - opisu nowej aplikacji. Niektóre ustawienia są dziedziczone z ostatnio edytowanej aplikacji.

PLIKI.OTWÓRZ

Otwarcie istniejącego pliku inicjującego. Oznacza to przejście do edycji aplikacji, która była już wcześniej utworzona. Należy pamiętać o tym, że maski wizualizacyjne nie są w bezpośredni sposób związane z żadnym plikiem inicjującym. Te same maski mogą być używane w różnych aplikacjach, pod warunkiem odpowiedniego ustawienia ścieżki dostępu do masek oraz identycznej definicji czcionek i map bitowych.

PLIKI.ZACHOWAJ

Zapisanie aktualnego stanu pliku inicjującego na dysku.

PLIKI.ZACHOWAJ_JAKO

Zapisanie aktualnego stanu pliku inicjującego na dysku w pliku o innej nazwie. Odpowiada to utworzeniu nowej aplikacji o ustawieniach identycznych z aplikacją wzorcową.

PLIKI.PANEL_KONTROLNY

Przejście do trybu wykonania aplikacji. Komenda dostępna tylko wtedy, gdy start programu AS nastąpił w trybie aplikacyjnym.

PLIKI.UKRYJ_OKNA

Umożliwia zwinięcie wszystkich otwartych okien aplikacji do ikony. W wyniku tego następuje automatyczna redukcja obciążenia procesora. Przywrócenie poprzedniego stanu okien aplikacji następuje po dwukrotnym kliknięciu na ikonę Asixa umieszczoną na pasku zadań. Funkcja ukrycia wszystkich okien działa także w systemach bez paska zadań. W tym przypadku ukrywane są wszystkie okna z wyjątkiem okna panelu lub okna konstruktora, które jest tylko minimalizowane.

PLIKI.KONIEC

Zamknięcie Okna Konstruktora, co jest równoznaczne z końcem pracy programu. Jeżeli konstruktor był uruchomiony w ramach systemu aplikacyjnego, to komenda ta może być zablokowana lub chroniona hasłem poprzez odpowiednie zdefiniowanie pozycji BLOKADA_KONCA w pliku inicjującym.

EDYCJA

Menu rozwijane zawierające komendy dotyczące edycji obiektów na maskach wizualizacyjnych. Menu to zostanie opisane w rozdziale dotyczącym edycji obiektów (patrz: 9.2.5. Edycja Obiektów).

MASKI

Menu rozwijane zawierające komendy dotyczące operacji na maskach wizualizacyjnych. Menu to zostanie opisane w rozdziałach: 9.2.1. Okno parametrów podstawowych maski, 9.2.2. Okno selekcji maski, 9.2.3. Opis komend w menu MASKI.

NARZĘDZIA.ZESTAWY_KLAWISZY

Otwarcie okna służącego do zarządzania plikami zawierającymi opisy zestawów klawiszy. Zestawy klawiszy pozwalają na definiowanie sposobu użycia klawiatury w czasie wykonania aplikacji.

NARZĘDZIA.PRZEGLĄD_ZMIENNYCH

Otwarcie okna umożliwiającego przeglądanie listy zmiennych procesowych (bieżących i archiwalnych) zdefiniowanych w systemie.

NARZĘDZIA.OPIS_TEKSTOWY

Komenda przeznaczona dla celów dokumentacyjnych aplikacji. Pozwala na utworzenie plików zawierających tekstowy opis niektórych parametrów masek wchodzących w skład aplikacji. Szczególnie istotną cechą opisu tekstowego jest możliwość uzyskania zbiorczego opisu wszystkich zmiennych procesowych używanych na maskach.

Wykonanie komendy powoduje otwarcie poniższego okna dialogowego.

Rysunek: Okno 'Generacja Tekstowych Masek'.

Wygenerowanie opisu tekstowego polega na wybraniu nazwy maski i przyciśnięciu przycisku Wykonaj. Możliwe jest wykonanie opisu wielu masek jednocześnie przy użyciu jednej operacji. W tym celu należy podać w polu Nazwa maski nazwę grupy masek używając znaków * i ? (w konwencji zgodnej z nazewnictwem plików). W szczególności, podanie w omawianym polu tylko znaku *, spowoduje utworzenie opisów dla wszystkich masek aplikacji (masek zlokalizowanych w ścieżce dostępu).

Opisy tekstowe są zapisywane w plikach o nazwach identycznych z nazwą maski, której opis dotyczy, oraz rozszerzeniu TXT.

NARZĘDZIA.WYDRUK_GRAFICZNY

Komenda przeznaczona dla celów dokumentacyjnych aplikacji. Pozwala na utworzenie wydruków graficznych masek wchodzących w skład aplikacji. Obsługa otwieranego okna jest taka sama, jak okna z komendy NARZĘDZIA.OPIS_TEKSTOWY. Dodatkowym elementem jest określenie formatu, w jakim wydruk ma zostać utworzony. Możliwe jest utworzenie obrazu maski w formacie pliku mapy bitowej lub wydruk bezpośrednio na wybranej drukarce. Rezultat operacji jest zapisywany w plikach o nazwach identycznych z nazwą maski i rozszerzeniem BMP. Poniżej przedstawiono okno wydruku graficznego.

Rysunek: Okno 'Wydruk Graficzny Masek'.

NARZĘDZIA.EDYTOR_MAP_BITOWYCH

Otwarcie okna edytora map bitowych. Edytor pozwala na tworzenie i modyfikację ikon i obrazków znajdujących się w pliku biblioteki obrazków używanych w tworzonej aplikacji.

NARZĘDZIA.EDYTOR_TEKSTÓW

Otwarcie okna edytora tekstów. Jest to prosty edytor pozwalający na modyfikację dowolnych plików tekstowych w formacie ASCII. Nie powinien być jednak używany do tekstowej edycji bieżącego pliku inicjującego (program AS przechowuje swoją kopię zawartości tego pliku, na podstawie której utworzony zostanie plik inicjujący w formie tekstowej, niszcząc zmiany wprowadzone w czasie edycji).

NARZĘDZIA.OKNO_RAPORTÓW

Otwarcie okna systemu raportów, które pozwala na liczenie wybranych raportów oraz inne operacje związane z raportami.

NARZĘDZIA.OKNO_DIALOGÓW

Otwarcie okna ’r;PANEL DIALOGOWY’ pozwalającego na interaktywne obliczenie wyrażeń arytmetycznych korzystających z wartości zmiennych procesowych.

NARZĘDZIA.TERMINARZ_AKCJI. CZASOWY

NARZĘDZIA.TERMINARZ_AKCJI. ZDARZENIOWY

Otwarcie okna służącego do deklarowania akcji wykonywanych okresowo lub w reakcji na spełnienie określonego warunku.

NARZĘDZIA.OBSŁUGA_DRUKARKI

Otwarcie okna obsługi drukarki. Okno to pozwala na podgląd aktualnie wykonywanych wydruków, zarządzanie kolejką wydruków oczekujących oraz zlecanie wydruku plików.

NARZĘDZIA.OBSŁUGA_HASEŁ

Otwarcie okna obsługi haseł. Okno to pozwala na ustawianie stanu ważności haseł oraz na zmianę treści haseł.

NARZĘDZIA.OBSŁUGA_UŻYTKOWNIKÓW

Otwarcie okna umożliwiającego założenie nowego użytkownika w przypadku stosowania systemu logowania.

NARZĘDZIA.TABELA_ZMIENNYCH

Otwarcie okienka zarządzania tabelami zmiennych. Umożliwia ono tworzenie nowych tabel i edycję istniejących.

OPCJE.ZMIANA_CZASU

Otwarcie okna pozwalającego na zmianę czasu.

OPCJE.PODGLĄD_POZYCJI

Włączenie opcji podglądu pozycji myszki w czasie edycji obiektów na maskach.

OPCJE.SKOK_KURSORA

Ustawienie sposobu przemieszczania się kursora w czasie edycji obiektów na maskach.

OPCJE.EDYCJA_OBIEKTÓW

Zmiana trybu edycji obiektów. Komenda pozwala na wybór rodzaju okna dialogowego służącego do zmiany definicji obiektu.

OPCJE.SEKWENCJA_DEMO

Wykonanie operacji nagrania lub odtworzenia sekwencji demonstracyjnej.

OKNA

Lista otwartych okien.

POMOC.INDEKS

Wyświetlenie okna indeksu pomocy kontekstowej.

POMOC.WIZYTÓWKA

Wyświetlenie okna z wizytówką systemu Asix.


9.2. Tworzenie masek schematowych

Zasadniczą część każdej aplikacji systemu Asix stanowi zestaw masek służących do wizualizacji stanu procesu przemysłowego. W systemie rozróżniane są maski służące do obsługi alarmów oraz maski schematowe, które służą do przedstawienia w sposób graficzny wartości odczytywanych zmiennych procesowych. Maski schematowe mogą także służyć do wykonywania operacji sterujących.


9.2.1. Okno parametrów podstawowych maski

Podstawowe komendy służące do zarządzania maskami wchodzącymi w skład aplikacji udostępnione są w menu MASKI Okna Konstruktora. Nowa maska schematowa tworzona jest komendą MASKI.NOWA_MASKA.SCHEMATOWA. Powoduje to otwarcie poniższego okna dialogowego służącego do zdefiniowania podstawowych parametrów maski.

Rysunek: Okno 'Definicja Maski'.

W polu Nazwa maski należy podać maksymalnie 8-znakową nazwę symboliczną maski. Nazwa ta będzie służyła w systemie do identyfikacji maski. Zestaw znaków, które można użyć w nazwie maski jest taki, jak dla nazw plików systemu DOS. Wynika to z tego, że nazwa symboliczna maski jest jednocześnie nazwą pliku dyskowego, w którym jest przechowywany opis maski (z dodawanym automatycznie rozszerzeniem MSK).

Pole Opis maski służy do podania tekstu, który ma zostać wyświetlony w linii nagłówka maski. Jeżeli maska nie będzie posiadała nagłówka, to pole Opis maski można traktować jako pole czysto dokumentacyjne służące do opisu przeznaczenia maski.

Grupa pól edycyjnych Pozycja pozwala na określenie położenia i rozmiaru maski. Koordynaty maski mogą być również zmienione później (gdy maska zostanie wyświetlona) przy pomocy myszki. Można przesuwać maskę "chwytając" ją za linię nagłówka lub rozciągać ramkę ograniczającą maskę.

W polu Zestaw Klawiszy należy podać (nieobowiązkowo) nazwę zestawu klawiszy związanego z maską. Można też wybrać nazwę zestawu w oknie selekcji, które otwierane jest klawiszem Szary-+ lub kliknięciem prawym klawiszem myszki w obrębie pola. Szczegółowe zasady użycia zestawów klawiszy są podane w osobnym rozdziale (Patrz: 9.3.2. Definiowanie zestawów klawiszy).

Klawisz Tło-Kolor pozwala na określenie koloru tła maski schematowej. Kliknięcie klawisza myszki powoduje otwarcie okna kolorów, w którym można wskazać żądany kolor.

Klawisz Tło-Obraz pozwala na określenie mapy bitowej, która będzie wyświetlana jako tło maski schematowej. Kliknięcie prawym klawiszem myszki powoduje otwarcie okna wyboru, w którym można wskazać żądaną bitmapę w pliku bitmap danej aplikacji. Można także podać nazwę bitmapy wraz z jej rozszerzeniem. Plik tej bitmapy powinien znajdować się w kartotece masek.

W polu Ikona należy podać nazwę ikony, która będzie wyświetlana po wykonaniu operacji zwinięcia maski do ikony. Można też wybrać nazwę ikony w oknie selekcji, które otwierane jest klawiszem Szary-+ lub kliknięciem prawym klawiszem myszki w obrębie pola. Podanie nazwy ikony jest konieczne tylko wtedy, gdy maska będzie miała zezwolenie na wykonanie operacji zwinięcia do ikony.

W znajdującej się po lewej stronie okna liście znajdą się później nazwy obiektów wizualizacyjnych wchodzących w skład maski. Oczywiście bezpośrednio po utworzeniu maski lista ta jest pusta. Lista obiektów pozwala na wykonanie niektórych operacji związanych z zarządzaniem obiektami. Zostaną one opisane w dalszej części rozdziału.

Lista po prawej stronie okna pozwala na zdefiniowanie różnorodnych atrybutów tworzonej maski. Projektant powinien ustawić pola wyboru wchodzące w skład listy zgodnie z wymaganymi parametrami maski.

Znaczenie poszczególnych pól w ramach listy atrybutów jest następujące:

Tryb Otwarcia - określenie domyślnego tryb otwierania maski; maski schematowe są typowo otwierane przy pomocy akcji operatorskiej OTWÓRZ_MASKĘ; w treści tej akcji może być podany tryb otwarcia; jeżeli nie zostanie on podany, to maska jest otwierana zgodnie z trybem podanym w definicji okna;

Nowa - otwarcie maski nie będzie miało wpływu na maskę bieżącą w chwili wykonania operacji;

Zamiana - otwarcie maski spowoduje zamknięcie maski bieżącej w chwili wykonania operacji;

Dialog - otwarcie maski nie będzie miało wpływu na maskę bieżącą w chwili wykonania operacji; po otwarciu nie będzie możliwości przejścia do innej maski, aż do momentu zamknięcia maski otwartej w trybie Dialog;

Chwilowa - otwarcie maski nie ma wpływu na maskę bieżącą w chwili wykonania operacji; po otwarciu każda selekcja innej maski lub okna powoduje automatyczne zamknięcie maski chwilowej;

Wymiana Zestawu - otwarcie maski spowoduje zamknięcie wszystkich masek nie zablokowanych (posiadających zezwolenie na zamknięcie);

Części Składowe - określenie części składowych maski;

Linia Nagłówka - maska będzie posiadała linię nagłówka;

Ramka - maska będzie posiadała standardową ramkę;

Klawisz Systemowy - maska będzie posiadała klawisz menu systemowego; Menu to pozwala na wykonanie operacji takich jak: przesuwanie maski, zamykanie maski itp.;

Operacje - określenie zestawu dozwolonych operacji wykonywanych na masce;

Bez Przesuwania - maska nie będzie mogła być przesunięta (w trybie aplikacyjnym);

Bez Zmiany Rozmiaru - nie będzie można zmienić rozmiaru maski (w trybie aplikacyjnym);

Pełny Ekran - będzie możliwe rozwinięcie maski na pełny ekran; wybranie tego pola powoduje dodanie do maski klawisza powiększania okna;

Do Ikony - będzie możliwe zwinięcie maski do ikony; wybranie tego pola powoduje dodanie do maski klawisza zwijania do ikony;

Bez Zamykania - maska nie będzie mogła być zamknięta;

Na Wierzchu - maska zawsze widoczna (stan masek Na Wierzchu jest usuwany dynamicznie w momencie przejścia do innej aplikacji; pozwala to na normalną obsługę innych programów nawet wtedy, gdy aplikacja Asixa posiada otwarte maski w trybie Na Wierzchu).

Skalowana - atrybut ustawiony w trakcie parametryzacji maski uaktywnia mechanizm przeskalowania wielkości i położenia obiektów przy zmianie wielkości maski w trybie pracy aplikacji. W trybie edycyjnym (konstruktora) można przeskalować maskę niezależnie od stanu atrybutu skalowana poprzez przyciśnięcie klawisza Alt w trakcie zmiany rozmiaru maski.

Dopasowanie w Prawo - atrybut ustawiony w trakcie parametryzacji maski uaktywnia mechanizm przeskalowania wielkości maski, tzn. maska zostanie poszerzona bez zmiany wysokości, chyba że zostanie zaznaczona również opcja Dopasowanie w Dół (w tym przypadku rozmiar i rozmieszczenie obiektów na masce pozostaje nie zmienione). Opcja ma zastosowanie do dużych masek z suwakami, które są wyświetlane na monitorach o różnej wielkości - wówczas rozmiar maski dopasowuje się do rozmiaru monitora.

Dopasowanie w Dół - atrybut ustawiony w trakcie parametryzacji maski uaktywnia mechanizm przeskalowania wielkości maski, tzn. maska zostanie wydłużona bez zmiany szerokości, chyba że zostanie zaznaczona również opcja Dopasowanie w Prawo (w tym przypadku rozmiar i rozmieszczenie obiektów na masce pozostaje nie zmienione). Opcja ma zastosowanie do dużych masek z suwakami, które są wyświetlane na monitorach o różnej wielkości - wówczas rozmiar maski dopasowuje się do rozmiaru monitora.

Po zakończeniu wprowadzania parametrów maski i przyciśnięciu przycisku OK na ekranie pojawia się nowa maska. Od tego momentu można rozpocząć dodawanie do maski obiektów wizualizacyjnych. Do okna parametrów podstawowych można wrócić w każdej chwili. W tym celu należy podwójnie kliknąć lewym klawiszem myszki w obrębie okna (poza granicami obiektów) lub wykonać komendę MASKI.POPRAW (jeżeli żaden obiekt nie jest wyselekcjonowany).


9.2.2. Okno selekcji maski

Jeżeli wymagana jest zmiana definicji maski utworzonej wcześniej (zmiana parametrów podstawowych lub definicji obiektów), to należy wykonać komendę MASKI.OTWÓRZ. Spowoduje to otwarcie poniższego okna dialogowego pokazującego listę wszystkich masek dostępnych w aplikacji.

Rysunek: Okno 'Wybór Maski'.

Maska wizualizacyjna jest dostępna w aplikacji wtedy, gdy jej plik opisujący znajduje się w jednej z kartotek podanych w polu Ścieżka Poszukiwań. Ścieżka dostępu jest definiowana jako lista nazw kartotek oddzielonych znakiem średnika. Ścieżka dostępu jest tworzona w momencie zakładania pliku inicjującego. W oknie selekcji masek można dowolnie zmieniać ścieżkę, co pozwala na rozmieszczenie masek aplikacji w różnych katalogach. Należy pamiętać o tym, ścieżka poszukiwań jest wspólna dla wszystkich elementów aplikacji: masek wizualizacyjnych, zestawów klawiszy i akcji złożonych. Zmiana ścieżki w oknie selekcji masek wpływa na dostęp do zestawów klawiszy i akcji.

Otwarcie maski polega na wyborze nazwy maski na liście i przyciśnięciu przycisku OK. Alternatywnie można nazwę wybranej maski wprowadzić ręcznie w polu Nazwa Maski. Pole to może służyć też do ograniczenia ilości masek na liście. Poprzez właściwe użycie znaków * i ? można ograniczyć ilość pokazywanych masek do wybranego podzbioru. Pole Kartoteka Wybranej Maski jest polem pomocniczym, które pokazuje w jakiej kartotece znajduje się plik opisujący wskazaną na liście maskę.

Okno selekcji masek może także służyć do kasowania z dysków masek już niepotrzebnych. Służy do tego klawisz Usuń.

Operacja kopiowania maski może być wykonana na dwa sposoby. Pierwszy polega na zwykłym skopiowaniu pliku opisującego maskę (na przykład zleceniem copy). Przy kopiowaniu pliku maski należy pamiętać o tym, że nazwa pliku jest identyczna z nazwą symboliczną maski oraz, że nie można zmieniać rozszerzenia MSK. Druga metoda kopiowania masek (bez wychodzenia z programu AS) polega na otwarciu wybranej maski komendą MASKI.OTWÓRZ, wejściu do jej okna parametrów podstawowych (podwójne kliknięcie lub komenda MASKI.POPRAW), a następnie zmianie nazwy symbolicznej. W momencie zamknięcia okna program AS spyta się, czy zmienić nazwę istniejącej maski, czy też utworzyć nową maskę o podanej nazwie i definicji identycznej z maską oryginalną.


9.2.3. Opis komend w menu MASKI

Pozostałe komendy menu MASKI są opisane poniżej. Operują one z reguły na masce, która jest aktualnie wyselekcjonowana. Nazwa tej maski jest podana w polu Maska w Oknie Konstruktora. Komendy te dotyczą również masek alarmowych.

MASKI.ZAPISZ

Zapisanie aktualnej definicji maski w pliku dyskowym. W celu uchronienia się przed stratą efektów swojej pracy (na przykład wskutek braku zasilania) należy wykonywać tę komendę okresowo. Komenda jest dublowana kombinacją klawiszy Alt-F2.

MASKI.SKOŃCZ

Skończenie edycji maski. Zostanie ona usunięta z ekranu. Jeżeli maska była zmodyfikowana, to program zapyta się projektanta czy należy zapamiętać zmiany w pliku.

MASKI.POPRAW

Otwarcie okna parametrów podstawowych maski lub okna definiującego obiektu wizualizacyjnego, jeżeli obiekt był wyselekcjonowany (stan selekcji obiektów jest podany w polu Obiekt w Oknie Konstruktora).

MASKI.WŁĄCZ_ODŚWIEŻANIE

Komenda powoduje przełączenie maski w tryb odświeżania. Jeżeli program AS był wystartowany w trybie aplikacyjnym, odpowiada to postawieniu maski w stan normalnej obsługi procesu. W przypadku pracy wyłącznie w trybie konstrukcyjnym, odświeżanie maski pozwala na ogólny test zachowania się maski na danych testowych (chociaż można uzyskać dostęp do danych rzeczywistych, jeżeli został odpowiednio sparametryzowany menedżer komunikacyjny ASMEN).

W momencie zatrzymania odświeżania masek w trybie konstruktora wstrzymywana jest także archiwizacja danych.

MASKI.PRZEJDŹ_DO_EDYCJI

Komenda powoduje wyjście maski z trybu odświeżania i przejście do trybu edycji.

MASKI.WSZYSTKIE_DO_EDYCJI

Komenda pozwala na jednorazowe wyłączenie odświeżania wszystkich aktualnie otwartych masek wizualizacyjnych.


9.2.4. Menu kontekstowe edycji maski

Możliwość skorzystania z podręcznego menu stanowi znaczne ułatwienie pracy w trakcie edytowania masek.

Menu kontekstowe składa się z komend menu Edycja, części komend menu Maski oraz komend selekcji obiektu/wzorca.

Postać menu zmienia się w zależności od ilości wybranych obiektów, zdefiniowanych wzorców, itp. Pokazywane są komendy, które można wykonać w aktualnym stanie.

Menu kontekstowe włączane jest poprzez kliknięcie prawym klawiszem myszki na obszarze edytowanej maski.

Po wyselekcjonowaniu obiektu/obiektów typu OBRAZEK, w menu kontekstowym maski dostępna jest między innymi funkcja Edytuj obrazek, wyświetlająca listę nazw wszystkich map bitowych, użytych w wyselekcjonowanych obiektach. Kliknięcie na nazwie obrazka powoduje jego otwarcie w edytorze obrazków.


9.2.5. Edycja Obiektów

Po ustaleniu parametrów podstawowych maski można przejść do edycji obiektów wizualizacyjnych. Obiekty stanowią zasadniczą część każdej maski. Służą one do graficznej prezentacji stanu kontrolowanego procesu. Ze względu na swoje cechy obiekty można podzielić na następujące kategorie:

statyczne - obiekty statyczne są to obiekty, które wyświetlane są zawsze w ten sam sposób; nie korzystają one z żadnych danych procesowych; są przeznaczone tylko do nadania masce odpowiedniej formy graficznej;

dynamiczne - obiekty dynamicznie zmienne, których wygląd zależy od danych przez nie pobieranych (z reguły dane procesowe Asmena lub zmienne archiwalne Aspada);

sterujące - obiekty, które posiadają możliwość wykonywania operacji sterujących procesem przemysłowym; proces sterowania oparty jest na dialogu z operatorem procesu, który za pośrednictwem obiektu może wysyłać wybrane wartości do sterownika; obiekty sterujące zazwyczaj należą również do kategorii obiektów dynamicznych;

wybieralne - obiekty, które posiadają możliwość reakcji na polecenia operatora wydawane przy pomocy myszki lub klawiatury; w wyniku tej reakcji obiekt może (ale nie musi) wykonać operacje sterujące;

specjalne - obiekty nie przeznaczone bezpośrednio do wizualizacji procesu, których zadaniem jest wykonywanie funkcji diagnostycznych lub usługowych (na przykład przeliczanie zmiennych w obiekcie klasy PRZELICZNIK).

Podane kategorie obiektów nie muszą być rozłączne. Przykładowo obiekt statyczny nie może być jednocześnie dynamicznym, ale na przykład obiekt dynamiczny może być jednocześnie obiektem sterującym i (lub) wybieralnym.

Oprócz umownego podziału na kategorie istnieje podział obiektów na klasy. Obiekt należący do danej klasy posiada ściśle określone zasady zachowania (wyświetlanie, dostęp do danych, sposób prowadzenia dialogu). Budowa maski schematowej polega na wstawieniu na maskę odpowiedniego zestawu obiektów. Należy użyć obiektów takich klas, które spełniają wymagania narzucone masce w fazie projektowania. Każdy z obiektów posiada także indywidualnie deklarowane parametry, które określają jego specyficzne cechy (ogólna zasada zachowania się obiektu zawsze zależy od jego klasy).


Wstawianie nowego obiektu

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.1. Wstawianie nowego obiektu

9.2.5.1. Wstawienie nowego obiektu

Wstawienie na maskę schematową nowego obiektu składa się z dwóch kroków. W pierwszym należy określić klasę tworzonego obiektu. Do wyboru klasy służy rozwijana lista Typ Nowego znajdująca się w Oknie Konstruktora. Po rozwinięciu listy należy wskazać nazwę klasy obiektów. Nastąpi wtedy przejście do trybu wstawiania obiektu sygnalizowane wyświetleniem w polu Typ Nowego nazwy wybranej klasy. Kolejnym krokiem jest określenie położenia i rozmiaru obiektu. Sposób wykonania tej operacji zależy od klasy obiektu. Używane metody określenia koordynat wstawianych obiektów są następujące:

pojedynczy punkt - kliknięcie lewym klawiszem w odpowiednim miejscu; rozmiar obiektu jest ustawiany automatycznie;

prostokąt - miejsce przyciśnięcia lewego klawisza oznacza położenie pierwszego narożnika obszaru obiektu; następnie należy przesunąć myszkę w miejsce drugiego narożnika i puścić klawisz myszki;

linia - miejsce przyciśnięcie lewego klawisza oznacza położenie punktu początkowego odcinka linii; następnie należy przesunąć myszkę w miejsce drugiego końca i puścić klawisz myszki;

wielolinia - należy kolejno definiować kolejne odcinki w sposób analogiczny jak powyżej; początek następnego odcinka znajduje się zawsze w punkcie końca odcinka poprzedniego; koniec definiowania jest sygnalizowany kliknięciem prawym klawiszem myszki.

tekst - kliknięcie lewym klawiszem powoduje ustawienie kursora; następnie należy wprowadzić tekst, który będzie wyświetlany przez obiekt; wprowadzanie tekstu kończone jest klawiszem Enter.

Po określeniu miejsca i rozmiaru ekranu tworzony jest nowy obiekt. Jego szczegółowe parametry ustalane są w sposób domyślny. Z reguły obiekt jest upodabniany do poprzednio edytowanego (wstawianego) obiektu tej samej klasy. Wszystkie parametry obiektu, jego rozmiar i położenie mogą być później zmienione.

Po utworzeniu obiektu z pola Typ Nowego usuwana jest nazwa klasy. Oznacza to, że program powrócił do trybu edycji obiektów istniejących. Wstawienie kolejnego obiektu wymaga ponownego wyboru klasy. Jeżeli obiekt ma być tej samej klasy co poprzedni, to wystarczające jest kliknięcie w obszarze maski prawym klawiszem myszki. Spowoduje to wejście w tryb wstawiania. Kliknięcie prawym klawiszem myszki może służyć także do wyjścia z trybu wstawiania bez utworzenia nowego obiektu.


Selekcja obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.2. Selekcja obiektów

9.2.5.2. Selekcja obiektów

Każda operacja, która ma być wykonana na obiekcie wymaga jego wcześniejszej selekcji. Obiekt w stanie selekcji jest otoczony ramką. Jednocześnie jego nazwa pojawia się w polu Obiekt w Oknie Konstruktora. Niektóre operacje edycyjne operują na całej grupie obiektów. Należy wtedy wykonać jednoczesną selekcję wszystkich obiektów, na których operacja ma być zrealizowana. Wszystkie obiekty wyselekcjonowane zostaną otoczone ramką, a w polu Obiekt pojawi się informacja podająca ilość wybranych obiektów.

W najprostszym przypadku, selekcja pojedynczego obiektu wykonywana jest poprzez kliknięcie lewym klawiszem myszki w obszarze obiektu. Operacja taka automatycznie zdejmuje selekcję z poprzednio wybranego obiektu. Jeżeli jednak w czasie wybrania obiektu będzie przyciśnięty klawisz Alt, to poprzednia selekcja zostaje utrzymana. Pozwala to na wykonanie selekcji wielokrotnej. Jeżeli chcemy zdjąć selekcję z jednego obiektu przy zachowaniu stanu pozostałych obiektów, to należy postąpić podobnie: trzymając klawisz Alt kliknąć na właściwym obiekcie. Samo kliknięcie na wybranym obiekcie nie zmienia stanów selekcji innych wybranych obiektów. Generalnie trzymanie klawisza Alt oznacza, że nie należy zmieniać stanu selekcji żadnych innych obiektów. Selekcja pojedynczych obiektów jest możliwa także przy pomocy klawiatury. Przyciskanie klawiszy Tab i Shift-Tab powoduje przejście stanu selekcji po kolejnych obiektach (w sekwencji ich uporządkowania na masce). Kombinacja klawiszy Alt-(szara)* powoduje selekcję wszystkich obiektów na masce.

W przypadku selekcji wielokrotnej prościej jest posłużyć się selekcją obszaru. Polega to na tym, że na obszarze maski zaznacza się prostokąt selekcji. Wszystkie obiekty, których obszar przynajmniej częściowo pokrywa się z obszarem selekcji zostaną wybrane. Prostokąt selekcji zaznacza się poprzez przyciśnięcie lewego klawisza myszki w pierwszym narożniku prostokąta, przesunięcie myszki w miejsce drugiego narożnika i puszczenie klawisza.

Dodatkowo dostępna jest funkcja selekcji wszystkich obiektów tego samego typu w trybie edycji maski poprzez kliknięcie na obiekcie z przytrzymanym klawiszem Ctrl. Przed tą operacją zalecane jest tymczasowe rozgrupowanie wszystkich grup obiektów, żeby nie wyselekcjonować niepożądanych obiektów.


Zmiana parametrów obiektu

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.3. Zmiana parametrów obiektu

9.2.5.3. Zmiana parametrów obiektu

Parametry specyficzne dla danego obiektu zmieniane są przy pomocy specjalnych okien dialogowych. Wejście do okna dialogowego obiektu wykonywane jest jedną z poniższych operacji:

  • podwójne kliknięcie lewym klawiszem myszki na obszarze obiektu,

  • wykonanie komendy MASKI.POPRAW z uprzednią selekcją obiektu,

  • przyciśnięcie klawisza Enter po uprzedniej selekcji obiektu,

  • w liście obiektów okna parametrów podstawowych maski wybrać właściwy obiekt, a następnie przycisnąć klawisz Enter lub podwójnie kliknąć lewym klawiszem myszki.

Istnieją trzy typy okien definiujących. To, które z nich jest otwierane wynika z ostatnio wykonanej komendy OPCJE.EDYCJA_OBIEKTÓW. Typy okien definiujących są następujące:

Pełna definicja - okno zawierające wszystkie parametry obiektu (za wyjątkiem pozycji i rozmiaru); postać tego okna jest zależna od klasy edytowanego obiektu;

Zmienne procesowe - okno służące do podglądu i zmiany nazw zmiennych procesowych Asmena, z których korzysta edytowany obiekt; ten typ okna jest dostępny tylko dla obiektów korzystających ze zmiennych Asmena; postać tego okna jest taka sama dla wszystkich klas obiektów.

Rysunek: Okno 'Liczba' umożliwiające edycję zmiennych procesowych.

W oknie podane są nazwy wszystkich zmiennych procesowych używanych w obiekcie. Opisy pól zależą od klasy obiektu i opisują przeznaczenie zmiennych. Pole WIZ informuje, czy dana procesowa jest pobierana z procesu. Pole STER informuje, czy dana służy do sterowania procesem. Przycisk PRZEWIŃ jest stosowany wtedy, gdy obiekt używany jest więcej niż 8 zmiennych. Pozwala on przeglądać kolejne partie zmiennych.

Koordynaty - okno pozwalające na zmianę położenia i rozmiaru obiektu. Postać jego jest taka sama dla wszystkich klas obiektów. Niektóre klasy obiektów nie pozwalają na zmianę rozmiaru.

Rysunek: Okno 'Liczba' umożliwiające edycję koordynat.

Okno koordynat jest mechanizmem pomocniczym. Z reguły używane są operacje przy pomocy myszki, bezpośrednio na obszarze tworzonej maski.

Wybór postaci okna definiującego odbywa się w nieco inny sposób w przypadku, gdy wykonano podwójne kliknięcie myszką na obiekcie z jednoczesnym trzymaniem klawisza CTRL. Otwierane jest wtedy okno koordynat (lub gdy edycja była przełączona trwale na koordynaty - okno pełnej definicji).


Zmiana położenia i rozmiaru obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.4. Zmiana położenia i rozmiaru obiektów

9.2.5.4. Zmiana położenia i rozmiaru obiektów

Podstawową metodą zmiany koordynat obiektów jest przesuwanie ich przy pomocy myszki. Przesunięcie obiektu polega na przyciśnięciu lewego klawisza myszki w centralnej części obiektu, "przeciągnięciu" obiektu w nowe miejsce i puszczeniu klawisza. Zmiana rozmiaru wykonywana jest w sposób podobny. Jedyną różnicą jest miejsce przyciśnięcia klawisza. Należy to wykonać w pobliżu tej krawędzi (narożnika) obszaru obiektu, która ma zostać przesunięta. Niektóre klasy obiektów nie pozwalają na zmianę rozmiaru lub pozwalają na przesunięcie tylko niektórych krawędzi.

Możliwe jest także grupowe przesuwanie obiektów. Pozwala to na jednoczesne przesunięcie kilku obiektów z zachowaniem ich względnego położenia. Grupowe przesunięcie musi być poprzedzone selekcją wszystkich obiektów biorących udział w operacji. Następnie należy rozpocząć przesunięcie dowolnego wybranego obiektu trzymając przyciśnięty klawisz Alt. Po rozpoczęciu przesunięcia klawisz Alt może być puszczony. Koniec operacji jest wykonywany w zwykły sposób. W jej efekcie wszystkie wybrane obiekty zostaną przesunięte tak, żeby zachować względne położenie w stosunku do przemieszczonego obiektu. W trakcie przesuwania wielu obiektów pokazywane są przesunięte ramki wszystkich wybranych obiektów.

We wszystkich operacjach selekcji, zmiany rozmiaru i położenia możliwe jest wspomaganie się użyciem klawiatury (szczególnie w przypadku konieczności bardzo szczegółowego pozycjonowania). Operacja jest zaczynana przy pomocy myszki, a następnie używane są klawisze strzałek (należy pamiętać o trzymaniu wciśniętego klawisza myszki). Każde przyciśnięcie klawisza strzałki powoduje przesunięcie kursora o jeden skok w odpowiednim kierunku (w normalnym przypadku jeden skok jest równy jednemu pikselowi). Operację kończy puszczenie klawisza myszki lub przyciśnięcie klawisza Enter. Operacja może być także zaniechana w dowolnym momencie klawiszem Esc.

W czasie wykonywania operacji przesuwania i zmiany rozmiaru pomocny jest podgląd położenia kursora myszki. Przy pomocy komendy OPCJE.PODGLĄD_POZYCJI można otworzyć małe okienko, w którym wyświetlane są koordynaty aktualnego położenia myszki. Pozycja myszki jest uaktualniana tylko wtedy, gdy kursor znajduje się w obszarze maski. Koordynaty są podawane względem lewego górnego narożnika obszaru obiektów maski. W czasie operacji przesuwania obiektów, w oknie podglądu podawana jest pozycja górnego narożnika obszaru obiektu. W czasie operacji zmiany rozmiaru, w oknie podglądu pokazywany jest rozmiar obiektu.

W normalnym trybie pracy kursor myszki przemieszcza się po obszarze maski z dokładnością do jednego piksela. Istnieje możliwość zdefiniowania większego skoku kursora. Zwiększony skok ułatwia równomiernie rozmieszczać obiekty, na przykład w kolumnach. Ustawienie skoku kursora wykonuje się komendą OPCJE.SKOK_KURSORA, w wyniku której wyświetlane jest poniższe okno dialogowe.

Rysunek: Okno umożliwiające określenie skoku kursora.

Możliwe jest niezależne zdefiniowanie skoku kursora w obu osiach. Wartość skoku wyrażona jest w pikselach. Definicja punktu odniesienia pozwala na przesunięcie punktów, w których będzie pozycjonowany kursor myszki. Na przykład, jeżeli skok jest równy (10,20), a punkt odniesienia znajduje się w położeniu (5,8), to kursor będzie pozycjonowany w kolumnach 5,15,25... i liniach 8,28,48.

Edytor masek wyposażony został ponadto w polecenie EDYCJA.COFNIJ_PRZESUNIĘCIE, dostępne również poprzez skrót klawiszowy Ctrl-Z. Operacja ta pozwala na cofnięcie sekwencji operacji, które zmieniały wyłącznie położenie i rozmiar obiektów. Lista operacji cofnięcia przechowywana jest (i możliwa do odtworzenia) do momentu wykonania dowolnej operacji, która zmienia stan maski/obiektu w sposób inny niż podany wcześniej (np. edycja obiektu, usunięcie obiektu, itp.). Lista operacji przechowywana jest oddzielnie dla każdej edytowanej maski.


Kasowanie obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.5. Kasowanie obiektów

9.2.5.5. Kasowanie obiektów

Obiekt znajdujący się na masce może zostać z niej usunięty. Wykonywane jest to komendą EDYCJA.USUŃ_OBIEKT po uprzednim wyselekcjonowaniu obiektu. Możliwe jest jednorazowe skasowanie wielu obiektów. Komenda kasowania może być również wykonana poprzez przyciśnięcie klawiszy Ctrl-U, Ctrl-Q lub Del.

Jeżeli obiekt(y) został omyłkowo usunięty, to możliwe jest jego odzyskanie. Pozwala na to komenda EDYCJA.ODTWÓRZ_SKASOWANY. Odzyskać można tylko te obiekty, które zostały usunięte w ostatniej operacji kasowania.

Obiekt można usunąć również w oknie parametrów podstawowych maski. W liście obiektów należy wskazać odpowiedni obiekt, a następnie przycisnąć klawisz Ctrl-Del.


Kopiowanie obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.6. Kopiowanie obiektów

9.2.5.6. Kopiowanie obiektów

Bardzo często sytuacją w czasie projektowania maski jest potrzeba utworzenia wielu prawie identycznych obiektów. Najłatwiej wykonać to przy pomocy komendy EDYCJA.POWTÓRZ_OBIEKT (dublowanej klawiszem Ctrl-P i Ctrl-R). Komenda to tworzy dokładną kopię obiektu(ów) wyselekcjonowanego. Tworzone obiekty są lekko przesunięte względem pierwowzoru. Wystarczy je następnie przesunąć we właściwe miejsce i wykonać niezbędnych modyfikacji definicji (na przykład nazw zmiennych).

Utworzone kopie obiektów pozostają w stanie selekcji. Pozwala to na utworzenie wielu kopii poprzez wielokrotne przyciśnięcia klawisza Ctrl-P. lub Ctrl-R. W przypadku kopiowania wielu obiektów, możliwe jest natychmiastowe zbiorowe przesunięcie.

Możliwe jest także kopiowanie obiektów pomiędzy maskami. W tym celu należy otworzyć do edycji dwie maski schematowe Na jednej z nich wybrać obiekty, które mają być skopiowane, a następnie wykonać komendę EDYCJA.WYTNIJ (Ctrl-T, Ctrl-X, Shift-Del) lub EDYCJA.KOPIUJ (Ctrl-K, Ctrl-C, Ctrl-Ins). Obie powyższe komendy kopiują wskazane obiekty do bufora. Komenda WYTNIJ dodatkowo usuwa obiekty z maski źródłowej. Następnie należy wykonać komendę EDYCJA.WKLEJ (dublowana klawiszami Ctrl-W, Ctrl-V, Shift-Ins). W jej efekcie w polu Typ Nowego pojawi się tekst "Wklejenie" sygnalizujące tryb wstawiania obiektów z bufora. Należy teraz wskazać pozycję na masce docelowej, na której ma nastąpić wstawienie kopiowanych obiektów. Operacja wklejania może być wielokrotnie powtarzana (wielokrotnie kopiując te same obiekty).


Ustalenie kolejności obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.7. Ustalenie kolejności obiektów

9.2.5.7. Ustalenie kolejności obiektów

Obiekty wchodzące w skład maski są początkowo uporządkowane w takiej kolejności, w jakiej były tworzone. Zmiana tej kolejności może okazać się konieczna z poniższych powodów.

  • W fazie wykonania aplikacji, operator może sterować procesem przy pomocy obiektów sterujących. Jeżeli sterowanie odbywa się przy pomocy klawiatury, to przejście pomiędzy obiektami następuje przy pomocy klawiszy Tab i Shift-Tab. Kolejność przejścia wynika z sekwencji obiektów. Projektant maski powinien zapewnić, że obiekty są uporządkowane w sposób pozwalający na uporządkowane przechodzenie między obiektami.

  • W przypadku obiektów częściowo się przesłaniających istotna jest kolejność ich wyświetlania. Jeżeli obiekt o dużym obszarze całkowicie pokrywa obszary innych obiektów, to utrudniona staje się selekcja tych obiektów przy pomocy myszki. Pomocne może być (nawet chwilowe) przesunięcie dużego obiektu na koniec listy.

Program AS udostępnia dwie metody zmiany kolejności obiektów. Pierwsza metoda polega na posłużeniu się listą obiektów znajdującą się oknie parametrów podstawowych maski. Lista ta pozwala na pełną kontrolę uporządkowania obiektów. Przemieszczenie obiektu polega na jego wskazaniu, a następnie przesunięciu w żądane miejsce przy pomocy klawiszy Ctrl-Home, Ctrl-End, Ctrl-Strzałka_w_górę, Ctrl-Strzałka_w_dół.

Druga metoda zmiany kolejności polega na posłużeniu się komendami EDYCJA.NA_PIERWSZY_PLAN (Ctrl-Home) i EDYCJA.NA_DRUGI_PLAN (Ctrl-End). Komendy te nadają się głównie do zmian kolejności spowodowanych przesłanianiem się obiektów. Komenda EDYCJA.NA_PIERWSZY_PLAN powoduje wstawienie przed pierwszy obiekt, którego obszar nakłada się z obszarem obiektu wyselekcjonowanego. Komenda EDYCJA.NA_DRUGI_PLAN powoduje wstawienie za ostatni obiekt, którego obszar nakłada się z obszarem obiektu wyselekcjonowanego.

Operacje EDYCJA.NA_PIERWSZY_PLAN i EDYCJA.NA_DRUGI_PLAN można wykonywać jednocześnie na wielu obiektach.


grupowanie obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.8. Grupowanie obiektów

9.2.5.8. Grupowanie obiektów

Obiekty na masce mogą być zgrupowane w sposób trwały. Do zarządzania grupowaniem służą następujące komendy podmenu EDYCJA.GRUPOWANIE:

Zgrupuj - trwałe zgrupowanie wybranych obiektów;

Rozgrupuj - trwałe rozgrupowanie;

Rozgrupuj tymczasowo - tymczasowe rozgrupowanie, pozwalające na edycję indywidualnych obiektów i zmianę ich położenia. Po zamknięciu i ponownym otwarciu maski obiekty będą automatycznie zgrupowane ponownie;

Zgrupuj ponownie - ponowne zgrupowanie tymczasowo rozgrupowanych obiektów z grupy wybranego obiektu.

Kliknięcie na dowolnym obiekcie grupy powoduje selekcję wszystkich obiektów grupy a podwójne kliknięcie powoduje otwarcie okna zamiany zmiennych. W oknie tym podane są wszystkie zmienne używane w wybranych obiektach. Po podaniu nowych nazw zostaną one wprowadzone we właściwe miejsca wybranych obiektów, powodując tym przypisanie nowych zmiennych do danych obiektów. Podmianie podlegają zmienne deklarowane w sposób jawny w oknie partametryzacji obiektu, zmienne użyte w treści wyrażeń oraz zmienne zadeklarowane w treści akcji operatorskich obiektów.

Rysunek: Okno zamiany zmiennych.

Okno zamiany zmiennych bezpośrednio po wyświetleniu ma wpisane w polach edycyjnych nazw zmiennych nazwy identyczne z nazwami zmiennych źródłowych - pozwala to na modyfikację nazw oryginalnych.

Okno zamiany zmiennych ma również sekcję pól pozwalających na wykonanie tekstowej zamiany fragmentu tekstu we wszystkich polach edycyjnych nazw zmiennych.

Edycja parametrów szczegółowych dowolnego z wybranych obiektów możliwa jest poprzez podwójne kliknięcie połączone z klawiszem Ctrl.


Tworzenie wzorców obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.9. Tworzenie wzorców obiektów

9.2.5.9. Tworzenie wzorców obiektów

Każdy zestaw obiektów może być zapisany jako wzorzec. Służy do tego komenda EDYCJA.GRUPOWANIE.zapisz_jako_wzorzec. Wykonanie tej funkcji powoduje otwarcie rozszerzonego okna zamiany nazw zmiennych, które pozwala zamienić nazwy zmiennych z oryginalnych na opisowe (w tym przypadku okno zamiany nazw zmiennych nie powoduje zamiany zmiennych a wyłącznie zmianę ich nazw), nadać nazwę i opis wzorca i zapisać w pliku. Wzorce zapisywane są w plikach o rozszerzeniu MST i mogą być swobodnie kopiowane pomiędzy aplikacjami. Wzorzec może być poddany edycji - okno otwarcia maski posiada możliwość wyboru pomiędzy standardowymi maskami a wzorcami. Wstawienie wzorca na maskę odbywa się podobnie jak w przypadku zwykłych obiektów. W nowym polu okna konstruktora Typ wzorca wybierany jest wzorzec do wstawienia i po wskazaniu miejsca na masce otwierane jest okno zamiany zmiennych wzorca (umożliwiające przypisanie do obiektów nowych zmiennych), a następnie wszystkie obiekty wzorca są wstawiane na maskę z jednoczesnym połączeniem ich w stałą grupę.

W przypadku użycia okna zamiany zmiennych wzorca, umożliwiającego przypisanie do obiektów nowych zmiennych, podmianie podlegają zmienne deklarowane w sposób jawny w oknie partametryzacji obiektu, zmienne użyte w treści wyrażeń oraz zmienne zadeklarowane w treści akcji operatorskich obiektów.

Wzorce mogą być tworzone również dla pojedynczych obiektów.

Rysunek: Okno definiujące wzorzec obiektów połączonych w jedną grupę.

Okno zamiany zmiennych wzorca oraz okno zamiany nazw zmiennych bezpośrednio po wyświetleniu ma wpisane w polach edycyjnych nazw zmiennych nazwy identyczne z nazwami zmiennych źródłowych - pozwala to na modyfikację nazw oryginalnych.

Powyższe okna mają również sekcję pól pozwalających na wykonanie tekstowej zamiany fragmentu tekstu we wszystkich polach edycyjnych nazw zmiennych.


9.2.5.10. Ukrywanie obiektów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.10. Ukrywanie obiektów

9.2.5.10. Ukrywanie obiektów

System Asix pozwala na kontrolę widzialności obiektów masek technologicznych. Mechanizm 'widzialności’ dotyczy obiektów wszystkich klas. Obiekt ukryty (niewidzialny) nie jest wyświetlany i nie wykonuje żadnych swoich funkcji. W szczególności można w ten sposób ukryć obiekt typu PRZYCISK, lub wyłączyć obiekt PRZELICZNIK.

Sterowanie stanem widzialności obiektu nie jest deklarowane w samym obiekcie, ale odbywa się za pośrednictwem obiektu klasy KONTROLER OBIEKTÓW, który może sterować widzialnością innych obiektów na podstawie stanu zmiennej procesowej lub aktualnie ustawionego poziomu hasła (patrz: 19.4.7 . Obiekt KONTROLER OBIEKTÓW.).


Operacje pomocnicze

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.5. Edycja Obiektów > 9.2.5.11. Operacje pomocnicze

9.2.5.11. Operacje pomocnicze

W menu EDYCJA Okna Konstruktora znajduje się jeszcze szereg operacji pomocniczych służących do edycji obiektów. Z reguły służą one do operacji na grupach obiektów. Znacznie tych komend jest następujące:

EDYCJA.WYRÓWNAJ

Komenda pozwala na wyrównywanie obiektów w jednej linii. Należy wybrać grupę obiektów i określić sposób wyrównania. Wyrównanie następuje zawsze do skrajnego obiektu w wybranym kierunku.

EDYCJA.ROZSUŃ

Rozsunięcie obiektów pozwala na równomierne rozmieszczenie obiektów. Po wybraniu obiektu oraz wybraniu osi, następuje takie rozmieszczenie obiektów, że odległości pomiędzy początkami (lewy górny narożnik) obiektów są takie same. Jako granice rozsunięcia przyjmuje się położenie dwóch skrajnych obiektów w wybranej osi.

EDYCJA.NAŁÓŻ

Komenda służy do centralnego umieszczenia obiektów jeden na drugim. Z reguły używana w sytuacji gdy obiekt dynamiczny chcemy umieścić centralnie na tle obiektu statycznego. Nałożenie następuje w miejscu obiektu o największym obszarze.

EDYCJA.OBRÓT_SYMETRYCZNY

Komenda pozwala na tworzenia lustrzanych odbić obiektów. Ma sens tylko dla niektórych obiektów (na przykład obiekty klasy WIELOKĄT).

EDYCJA.PRZYSUŃ

Komenda powoduje takie przemieszczenie obiektów, że ich krawędzie stykają się ze sobą.

EDYCJA.ZABLOKUJ

W przypadku kiedy niektóre obiekty zostały już poprawnie zdefiniowane, a maska cały czas podlega edycji, celowe może okazać się zablokowanie zmian obiektów już utworzonych. Zabezpieczy to przed przypadkową ich zmianą (i koniecznością ich kolejnego poprawiania). Do tego celu służy komenda EDYCJA.ZABLOKUJ, która może zablokować możliwość przesuwania obiektu lub zmiany jego rozmiaru. Kopiowanie obiektów zablokowanych powoduje, że nowe obiekty mają automatycznie usuniętą blokadę przesuwania.

EDYCJA.USUŃ_BLOKADY

Komenda usuwa blokady założone komendą EDYCJA.ZABLOKUJ.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.6. Zmiana zmiennych procesowych w trakcie otwierania maski

9.2.6. Zmiana zmiennych procesowych w trakcie otwierania maski

Zmiana zmiennych procesowych używanych na masce może być wykonana w trakcie otwierania maski. Pozwala to na stosowanie pojedynczego pliku maski do otwierania wielu wariantów różniących się używanymi zmiennymi.

AKCJA OTWÓRZ_MASKĘ

Przedmiot zamiany jest podawany w treści akcji OTWÓRZ_MASKĘ, gdzie parametr nazwa_maski musi być podany w sposób zgodny z jednym z poniższych wariantów:

nazwa_maski#plik zamian

W pliku o rozszerzeniu VRT należy podać sposób zamiany nazw zmiennych. Format pliku przyjmuje następującą postać:

linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;

linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej

W oknie definicji maski znajduje się klawisz, który pozwala na wygenerowanie wzorcowego pliku VRT zamiany nazw dla edytownaej maski.

nazwa_maski#zmienna_źródłowej_1;zmienna_wstawiana_1[...#zmienna_źródłowej_n;zmienna_wstawiana_n]

W tym wariancie wszystkie pary zamienników są podawane wprost w treści akcji.

AKCJA SKRYPT

Operacją zamiany nazw objęta jest również akcja operatorska SKRYTP w części przekazującej parametry uruchamianego skryptu. Ze względu na to, iż struktura parametrów akcji SKRYTP jest nieznana, projektant musi oznaczyć miejsca występowania nazw zmiennych poprzez umieszczenie ich w wewnątrz znaków dolara $, np. SKRYPT x.vbs,$nazwa_zmiennej$.

W trakcie wykonania skrypt musi usunąć znaki $ z treści parametrów. Tak wygląda skrypt wyświetlający w panelu parametry wywołania bez znaków $ -

napisany w VBS:

Asix.Panel.Message(Replace(Asix.Script.Arguments(1),"$",""))

napisany w JS:

var args = new String(Asix.Script.Arguments(1))

var re = /\$/g

Asix.Panel.Message(args.replace(re,""))

Chociaż nominalnie program AS traktuje fragmenty $...$ jako nazwy zmiennych, to rzeczywista interpretacja parametrów zależy wyłącznie od autora skryptu. Np. poniższy skrypt pozwala wykonać właściwie dowolną modyfikowaną akcję operatorską:

Asix.ExecuteAction(Replace(Asix.Script.Arguments(1),"$",""))


Mechanizm skalowania masek

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.7. Mechanizm skalowania masek

9.2.7. Mechanizm skalowania masek

Sposób obsługi zależy od sposobu zdefiniowania maski w oknie definicyjnym: czy maska ma suwaki, czy ustawiona jest opcja skalowania, czy zdefiniowana jest nazwa tzw. maski szczegółów.

Szczegółowe działanie jest następujące:

a) okno maski bez linii tytułu można przesunąć przez kliknięcie lewym klawiszem myszki z przyciśniętym klawiszem ctrl w dowolnym miejscu maski i przesunięcie kursora. Przyciśnięcie klawisza ctrl nie jest konieczne, jeżeli maska nie ma suwaków.

b) jeżeli maska posiada suwaki, to kliknięcie lewym klawiszem myszki i przesunięcie kursora powoduje przesuwanie widzialnego obszaru maski (analogiczne do użycia suwaków)

c) jeżeli maska jest skalowana, ma suwaki, nie ma zadeklarowanej maski szczegółów i nie ma na masce obiektów o nazwie __REDIR__, to można zaznaczyć przy pomocy myszki z przyciśniętym prawym klawiszem myszki fragment maski, który powinien być powiększony - zaznaczony prostokąt jest tak powiększany, żeby wypełnił cały obszar okna. Zaznaczenie prostokąta od prawej strony do lewej powoduje powrót do wyświetlania maski w sposób początkowy.

d) jeżeli maska ma zadeklarowaną maskę szczegółów lub posiada obiekty o nazwie __REDIR__, to prostokąt zaznaczony przy pomocy prawego klawisza służy do określenia wyświetlanego fragmentu na nowootwieranej masce. Nazwa nowej maski to nazwa maski szczegółów lub nazwa pobrana z obiektu __REDIR__ leżącego w obszarze prostokąta (obiekt __REDIR ma pierwszeństwo). Pokazywany fragment dla masek z obiektem __REDIR__ pobierany jest również z obiektu __REDIR__. W przypadku masek szczegółów koordynaty są przeliczane proporcjonalnie z uwzględnieniem rozmiaru maski pierwotnej,

rozmiaru i położenia prostokąta oraz rozmiaru maski szczegółów (ten rozmiar można zmienić przy pomocy obiektu o nazwie __THEEND__).

Obiektem __REDIR__ może być obiekt klasy TEKST lub TEKSTY (w nazwie musi być zadeklarowany tekst __REDIR__. W tekście obiektu (pierwszym dla TEKSTY) podaje się nazwę otwieranej maski oraz oddzielone znakami spacji koordynaty x i y górnego narożnika pokazywanego fragmentu.

Obiektem __THEEND__ może być obiekt dowolnego typu, ale musi być on pierwszym obiektem na masce i musi mieć w nazwie zadeklarowany tekst __THEEND__. Położenie tego obiektu jest brane do przeliczeń pokazywanego fragmentu (zamiast rzeczywistego rozmiaru nowej maski).

Rysunek: Schemat powiększania obszaru maski przy zastosowaniu maski szczegółów.

Założenie: maska szczegółów jest powiększoną kopią maski podstawowej.

Obszar na masce szczegółów jest proporcjonalny do obszaru zaznaczonego na masce podstawowej.

Rysunek: Schemat powiększania obszaru maski przy zastosowaniu obiektów __REDIR__.

Założenie: maska docelowa nie musi być powiększoną kopią maski podstawowej, równie dobrze może to być dowolna inna maską, która zawiera powiększony element z maski podstawowej. W obiekcie TEKST lub TEKSTY w polu tekst podawana jest nazwa maski docelowej oraz współrzędne lewego górnego narożnika obszaru powiększonego.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.2. Tworzenie masek schematowych > 9.2.8. Funkcja dopasowania masek do rozmiaru ekranu

9.2.8. Funkcja dopasowania masek do rozmiaru ekranu

W oknach parametryzacji masek znajdują się opcje umożliwiające dopasowanie wielkości maski do rozmiaru ekranu. W tym przypadku rozmiar i rozmieszczenie obiektów na masce pozostaje nie zmienione. Funkcja ma zastosowanie do dużych masek z suwakami, które są wyświetlane na monitorach o różnej wielkości - wówczas rozmiar maski dopasowuje się do rozmiaru monitora.

Dopasowanie w Prawo - atrybut ustawiony w trakcie parametryzacji maski uaktywnia mechanizm przeskalowania wielkości maski, tzn. maska zostanie poszerzona bez zmiany wysokości, chyba że zostanie zaznaczona również opcja Dopasowanie w Dół.

Dopasowanie w Dół - atrybut ustawiony w trakcie parametryzacji maski uaktywnia mechanizm przeskalowania wielkości maski, tzn. maska zostanie wydłużona bez zmiany szerokości, chyba że zostanie zaznaczona również opcja Dopasowanie w Prawo.


9.3. Komponowanie systemu masek

W fazie wykonania aplikacji operator ma do swojej dyspozycji zestaw standardowych operacji, wykonywanych przy pomocy myszki lub klawiatury, które pozwalają mu na sterowanie pracą aplikacji. Chodzi tu przede wszystkim o możliwości otwierania i zamykania masek wizualizacyjnych. Mechanizmy standardowe należy traktować jednak jako pomocnicze. Stworzenie pełnego logicznego modelu aplikacji wymaga użycia odpowiednich, swobodnie parametryzowanych, mechanizmów systemu Asix.

Projektant może wpływać na sposób obsługi aplikacji poprzez udostępnianie operatorowi tak zwanych akcji operatorskich. Zestaw wszystkich możliwych akcji jest opisany w osobnym rozdziale. W skrócie, akcje można zdefiniować jako komendy, które po ich uaktywnieniu powodują wykonanie określonej operacji przez program AS. Akcje definiowane są poprzez wprowadzenie odpowiednich tekstów w przeznaczonych do tego polach edycyjnych.

Na etapie realizacji, wykonanie akcji może być inicjowane poprzez kliknięcie myszką w odpowiednim miejscu maski lub przyciśnięcie odpowiedniej kombinacji klawiszy na klawiaturze. Dalsza część rozdziału dotyczy użycia klawiatury.


9.3.1. Zasady identyfikacji klawiszy

Wykonanie akcji może być przywiązane do przyciśnięcia odpowiedniej kombinacji klawiszy na dwa sposoby. W pierwszym, akcja opisywana jest w obiekcie PRZYCISK. Dodatkowo, definiuje się kombinację klawiszy (w oknie definiującym obiektu), której przyciśnięcie spowoduje wykonanie akcji. Drugim sposobem użycia klawiatury jest zdefiniowanie tak zwanych zestawów klawiszy. Pozwalają one na zdefiniowanie dowolnie długiej listy różnych kombinacji klawiszy wraz z odpowiadającymi im akcjami operatorskimi. Tak przygotowane zestawy są dołączane do masek wizualizacyjnych. W oknie parametrów podstawowych maski znajduje się pole, w którym należy podać nazwę zestawu (możliwy jest także wybór z listy zestawów poprzez przyciśnięcie klawisz Szary-+ lub kliknięcie prawym klawiszem myszki).

Charakterystyczną cechą użycia klawiszy (w obu wariantach) jest to, że wybrane kombinacje są aktywne przez cały czas obecności masek (do których są dołączone) na ekranie. Nie ma znaczenia, która maska jest aktywna.

Schemat wyboru akcji związanej z przyciśniętą kombinacją klawiszy jest następujący:

  • jeżeli system nie jest w trybie wykonawczym, to rozpoznanie akcji nie jest wykonywane;

  • jeżeli aktywne jest okno, które nie jest maską wizualizacyjną, to rozpoznanie akcji nie jest wykonywane;

  • dla bieżącej (aktywnej) maski wizualizacyjnej wykonywane jest sprawdzenie, czy klawisz został użyty w obiekcie należącym do maski; jeżeli tak, to wykonywana jest akcja zdefiniowana w obiekcie, a dalsze sprawdzanie jest przerywane;

  • dla bieżącej (aktywnej) maski wizualizacyjnej wykonywane jest sprawdzenie czy klawisz należy do zestawu klawiszy dołączonego do maski; jeżeli tak, to wykonywana jest akcja zdefiniowana w zestawie klawiszy, a dalsze sprawdzanie jest przerywane;

  • poprzednie dwa punkty są powtarzane dla wszystkich otwartych masek wizualizacyjnych, aż do znalezienia akcji związanej z kombinacją klawiszy; kolejność przeglądania masek jest nieokreślona (silnie zależy od historii przełączania masek); jeżeli aktywną maską jest maska typu dialogowego, to weryfikacja klawisza nie przechodzi do pozostałych otwartych masek;

Na podstawie powyższego schematu można wyciągnąć następujące wnioski:

  • przeszukiwanie wykonywane jest do pierwszego znalezionego powiązania klawisz-akcja; nie można spowodować tego, żeby dla jednego przyciśnięcia wykonywane były dwie różne akcje; jeżeli zachodzi taka potrzeba, to należy użyć akcji złożonych, gdzie jedna wykonywana akcja składa się z wielu akcji składowych;

  • zdefiniowanie akcji, która ma być zawsze dostępna, jest realizowane poprzez zdefiniowanie wymaganego powiązania klawisz-akcja na masce, która jest otwarta przez cały czas działania aplikacji;

  • można spowodować, że ta sama kombinacja klawiszy oznacza różne akcje, w zależności od tego, która maska jest aktywna.


9.3.2. Definiowanie zestawów klawiszy

Zestawy klawiszy pamiętane są w plikach binarnych. Nazwa zestawu jest identyczna z nazwą pliku. Rozszerzenie nazwy pliku klawiszy jest zawsze równe MNU. Wszystkie operacje edycyjne na zestawach klawiszy muszą być wykonywane w trybie konstrukcyjnym programu AS. Podstawowym oknem służącym do zarządzania zestawami klawiszy jest poniższe okno selekcji. Jest ono otwierane komendą NARZĘDZIA.ZESTAWY_KLAWISZY z menu Okna Konstruktora. Podobne okno otwierane jest również bezpośrednio z pola Zestaw klawiszy w oknie definiującym maski wizualizacyjnej (otwieranie klawiszem Szary-+, lub kliknięciem prawym klawiszem myszy).

Rysunek: Okno 'Obsługa Zestawów Klawiszy'.

Zasadniczą część okna stanowi lista, która zawiera nazwy wszystkich zdefiniowanych zestawów klawiszy dostępnych w aplikacji. Zestaw jest dostępny wtedy, gdy jego plik znajduje się w jednej z kartotek podanych w polu Ścieżka Poszukiwań. Ścieżka dostępu jest definiowana jako lista nazw kartotek oddzielonych znakiem średnika. Należy pamiętać o tym, że ścieżka poszukiwań jest wspólna dla wszystkich elementów aplikacji: masek wizualizacyjnych, zestawów klawiszy i akcji złożonych. Zmiana ścieżki w oknie selekcji zestawów wpływa na dostęp do masek i akcji. Wykonywanie operacji na zestawach polega na wyborze jednego zestawu na podanej liście i przyciśnięciu odpowiedniego klawisza umieszczonego w dolnej części okna. Alternatywnie można nazwę wybranego zestawu wprowadzić ręcznie w polu Nazwa Zestawu. Pole to może służyć też do ograniczenia ilości zestawów na liście. Poprzez właściwe użycie znaków * i ? można ograniczyć pokazywane zestawu do wybranego podzbioru. Pole Kartoteka Wybranego Zestawu jest polem pomocniczym, które pokazuje w jakiej kartotece znajduje się plik opisujący wskazany na liście zestaw.

Znaczenie klawiszy znajdujących się w oknie selekcji jest następujące:

Usuń - operacja powoduje skasowanie wskazanego zestawu; z dysku zostanie usunięty plik opisujący zestaw;

Zmień - wejście w okno, które pozwala na zmiany w definicji zestawu klawiszy;

Utwórz - utworzenie nowego zestawu klawiszy, połączone z wejściem w okno pozwalające na zdefiniowanie zestawu; okno jest takie samo jak w przypadku operacji Zmień; plik opisujący zestaw jest tworzone w kartotece znajdującej się na pierwszej pozycji w ścieżce dostępu.

Okno służące do definiowania zestawów klawiszy prezentuje poniższy rysunek.

Rysunek: Okno służące do definiowania zestawów klawiszy.

W polu Nazwa Zestawu znajduje się nazwa definiowanego zestawu klawiszy, która służy do identyfikacji zestawu w ramach aplikacji, oraz do utworzenia nazwy pliku opisującego zestaw. Dla nowo definiowanego zestawu jest ona początkowo pusta. Poprzez zmianę nazwy można spowodować utworzenie kopii wcześniej zdefiniowanego zestawu. Program AS pyta się w takiej sytuacji, czy ma zmienić nazwę istniejącego zestawu, czy utworzyć nowy zestaw o podanej nazwie i definicji identycznej z zestawem oryginalnym. Dalsze operacje edycyjne dotyczą zestawu o nowej nazwie.

Alternatywną metodą kopiowania zestawów klawiszy jest zwykłe skopiowanie pliku opisującego zestaw (np. zleceniem copy systemu DOS) z zachowaniem rozszerzenia MNU.

Zasadniczą część okna stanowi lista pokazująca wszystkie zdefiniowane powiązania klawisz-akcja w danym zestawie. Każda pozycja w liście podaje nazwę tekstową kombinacji klawiszy oraz tekst powiązanej akcji. Uporządkowanie akcji w liście jest alfabetyczne.

Klawisze znajdujące się z prawej strony okna mają następujące znaczenie:

Zmień - wejście w okno pozwalające na zmianę definicji powiązania klawisz-akcja dla pozycji wskazanej na liście;

Dodaj - utworzenie nowej pozycji w liście powiązań połączone z wejściem w okno definicji powiązania;

Usuń - skasowanie powiązania wskazanego na liście;

Anuluj - zamknięcie okna definiującego zestaw z zaniechaniem wszystkich wprowadzonych zmian;

Zapisz - zamknięcie okna definiującego zestaw połączone z zapisaniem aktualnego opisu zestawu w pliku opisującym zestaw.

Poniżej pokazane zostało okno służące do definiowania pojedynczego powiązania klawisz-akcja. Okno to otwierane jest klawiszami Zmień i Dodaj.

Rysunek: Okno służące do definiowania pojedynczego powiązania klawisz-akcja.

Zdefiniowanie kombinacji klawiszy, która ma zostać powiązana z akcją najprościej wykonać poprzez naciśnięcie klawisza Podaj Klawisz. Spowoduje to otwarcie okno komunikatu żądającego przyciśnięcia wybranej kombinacji klawiszy. Po jej przyciśnięciu okno komunikatu jest zamykane, a opis kombinacji pojawia się w polach: Nazwa w wersji tekstowej i Kod w postaci liczby szesnastkowej. Nie wszystkie kombinacje klawiszy są dozwolone np. nie można używać kombinacji Alt-Fxx.

W polu Akcja należy wprowadzić opis tekstowy powiązanej akcji. Tak jak w każdym przypadku pola służącego do wprowadzania akcji, można posługiwać się skrótami nazw i symboli. Jeżeli opis akcji jest poprawny, to w momencie wyjścia z pola Akcja nastąpi sformatowanie tekstu z uwzględnieniem pełnych nazw.

Dodatkowego komentarza wymaga użycie kombinacji klawiszy będących przyciśnięciem pojedynczego klawisza litery. Program AS traktuje małe i duże litery jednakowo. Zdefiniowanie powiązania dla litery "t" powoduje, że akcja będzie wykonywana dla liter "t" i "T". Nie ma możliwości zdefiniowania osobnych powiązań dla dużych i małych liter.


9.4. Operacje sterujące

Jedną z funkcji aplikacji systemu Asix jest sterowanie pracą kontrolowanego procesu. Odbywa się to poprzez wysyłanie odpowiednich wartości do sterownika przemysłowego. Są dostępne dwie metody wykonywania sterowań:

  • wysyłanie wartości zdefiniowanych przez projektanta systemu,

  • wysyłanie wartości uzyskanych w wyniku dialogu z operatorem.

Pierwsza metoda polega na zdefiniowaniu akcji operatorskich i udostępnieniu ich w zestawach klawiszy lub obiektach klasy PRZYCISK. Do dyspozycji są trzy typy akcji. We wszystkich przypadkach projektant określa adres przeznaczenia oraz wysyłaną wartość. Wykonanie akcji powoduje natychmiastowe wysłanie podanej wartość. Akcja USTAW_WARTOŚĆ służy do wysyłania wartości analogowych. Akcje STERUJ_BITY i ZMIEŃ_BITY są zorientowane na sterowanie bitowe (Patrz: 9.4.1. Akcje operatorskie). Pozwalają one na zmianę pojedynczych bitów zmiennych procesowych (z zachowaniem stanu bitów pozostałych).

Druga metoda sterowania polega na umieszczeniu na masce obiektów wizualizacyjnych, które posiadają funkcje wykonywania sterowań. W czasie wykonania aplikacji operator ma możliwość wyboru obiektu i poprzez dialog ustawienia wartości sterującej. Sposób prowadzenia dialogu zależy od klasy używanego obiektu i może być bardzo różnorodny, na przykład wybór z zestawu możliwych wartości, wprowadzenie wartości numerycznej. Wybór obiektu przez operatora odbywa się poprzez wskazanie myszką lub przy pomocy klawiszy Tab i Shift-Tab (powodują one sekwencyjne przejście po wszystkich obiektach sterujących). Różny może być też moment wykonania sterowania.

Niektóre klasy obiektów wysyłają wartości natychmiast. Inne jedynie zapamiętują wybraną wartość i wymagają przesłania dodatkowego sygnału wysłania. Mechanizm ten pozwala na przygotowanie przez operatora wielu sterowań, a następnie w jednym momencie wysłanie ich wszystkich do sterownika. Sygnał wysłania jest wykonywany akcją operatorską WYŚLIJ_STEROWANIA. Niektóre klasy obiektów akceptują dodatkowo indywidualny sygnał wysłania - przyciśnięcie klawisza Szary-+ (w czasie selekcji obiektu).

Istnieje możliwość zablokowania wszystkich operacji sterujących aplikacji poprzez użycie parametru Blokada sterowania w pliku konfiguracyjnym aplikacji:

Architekt > Obszary i komputery > moduł Zabezpieczenia > zakładka Blokady

Istnieje możliwość ustawienia akcji WYŚLIJ_STEROWANIA w ten sposób, że wysyłane są sterowania tylko z masek całkowicie widocznych. Z maski, która jest choć w części przykryta inną maską lub jakimkolwiek innym oknem, sterowania nie zostaną wysłane, mimo, że zostały one na niej ustawione.

Drugą opcją jest wysłanie wszystkich ustawionych sterowań ze wszystkich otwartych w tym momencie masek.

Wyboru sposobu wysyłania sterowań dokonuje się przy pomocy parametru Bez niewidocznych sterowań:

Architekt > Obszary i komputery > moduł Maski > zakładka Pozostałe

Wysyłanie sterowań posiada też mechanizm pozwalający na ustawienie czasu ważności sterowań. Czas ten jest liczony od momentu dokonania ostatniego wyboru sterowania przez operatora. Jeśli operator nie potwierdzi wysłania wybranych sterowań, po upływie tego czasu następuje skasowanie aktywnych sterowań. Parametryzacji tej opcji dokonuje się za pomocą parametru Czas ważności sterowań. Brak tej pozycji lub ustawienie jej z parametrem 0 powoduje, że ustawienia sterowań zostają zachowane przez dowolnie długi czas.

Architekt > Obszary i komputery > moduł Maski > zakładka Pozostałe

Wszystkie typy operacji sterujących mają możliwość ochrony przy pomocy haseł.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.4. Operacje sterujące > 9.4.1. Akcje operatorskie

9.4.1. Akcje operatorskie

STERUJ_BITY

USTAW_WARTOŚĆ

WYŚLIJ_STEROWANIA

ZMIEŃ_BITY


9.5. Hasła

System Asix posiada wbudowany moduł zarządzania hasłami służącymi do ochrony różnych części systemu przed niepowołanym użyciem. Można wyróżnić dwa typy operacji chronionych hasłami:

  • operacje sterujące kontrolowanym procesem,

  • akcje operatorskie (kontrola wykonania aplikacji).

W każdym przypadku, w momencie próby wykonania operacji chronionej hasłem pojawia się poniższe okno dialogowe.

Rysunek: Okno umożliwiające podanie hasła dostępu do systemu Asix.

Operator powinien wprowadzić hasło, a następnie przycisnąć klawisz Enter. Jeżeli hasło zostanie wprowadzone błędnie (zła treść lub podane hasło o innym przeznaczeniu), to operacja, która była chroniona nie zostanie wykonana.

W trakcie wprowadzania treści hasła przez operatora, znaki przez niego podawane nie są wyświetlane w oknie zapytania (położenie zmienia tylko kursor). Ma to na celu zabezpieczenie przed możliwością podejrzenia treści hasła przez osoby postronne.

Hasła nie są sprawdzane podczas pracy w trybie konstruktora.

Hasła poziomowe przechowywane są w zewnętrznym pliku Passwords.ini w postaci zakodowanej.

We wszystkich pozycjach pliku ini i akcjach operatorskich, gdzie podawane jest indywidualne hasło dostępowe można wprowadzić liczbę od 1 do 4 (w miejsce hasła), co oznacza żądanie podania odpowiedniego hasła poziomowego.


9.5.1. Zabezpieczenie operacji sterujących

Ochrona wykonania operacji sterujących opiera się na układzie 4 (maksymalnie) haseł hierarchicznych. Projektant systemu deklaruje dla każdego obiektu wizualizacyjnego, który może wykonywać operacje sterujące, poziom jego zabezpieczenia. Poziomy ochrony są identyfikowane liczbą, od 1 do 4. Poziom numer 4 jest poziomem o najwyższym stopniu zabezpieczenia. Możliwe jest także pozostawienie obiektu bez kontroli operacji sterujących. Hasła dla poszczególnych poziomów deklarowane są w:

Architekt > Obszary i komputery > moduł Zabezpieczenia > zakładka Tryb haseł poziomowych

W czasie realizacji aplikacji, przed wykonaniem żądanego przez operatora sterowania, wykonywane jest odpytanie o hasło przy pomocy pokazanego wcześniej okna zapytania. Operator musi odpowiedzieć hasłem właściwym dla wykonywanego sterowania. Użyte hasło musi być hasłem poziomu zadeklarowanego dla obiektu, który realizuje sterowanie lub dowolnym z haseł poziomów wyższych. Jeżeli wykonywane jest kilka sterowań jednocześnie (o różnych poziomach zabezpieczeń), to możliwe jest pojawienie się kilku zapytań.

Jeżeli hasło zostanie poprawnie podane, to operacja sterująca będzie wykonana. Ponadto, każda następna operacja sterująca (na tym samym lub niższym poziomie ochrony) będzie wykonywana bez pytania się o hasło. Stan ten będzie utrzymywał się aż do wycofania hasła przez operatora lub upłynięcia limitu czasowego, po którym znów nastąpi zapytanie o hasło. Czas ważności hasła deklarowany jest w pliku inicjującym (standardowo 15 minut).

Operator posiada do swej dyspozycji okno zarządzania hasłami, przy pomocy którego można wykonywać zmianę haseł oraz wycofywać stan ważności. Okno obsługi haseł otwierane jest komendą NARZĘDZIA.OBSŁUGA_HASEŁ lub akcją operatorską OBSŁUGA_HASEŁ. Postać okna zarządzania hasłami jest następująca:

Rysunek: Okno obsługi haseł.

Po lewej stronie okna znajduje się kolumna pól wyboru pokazujących aktualny stan ważności haseł dla poszczególnych poziomów. Poprzez zmianę tych pól można usuwać lub ustawiać stan ważności haseł. Próba ustawienia pola ważności powoduje automatyczne odpytanie o hasło, przy czym w tym wypadku należy podać hasło dokładnie tego poziomu, którego zapytanie dotyczy. Przyciski Zmiana służą do zmiany treści haseł. Po przyciśnięciu klawisza wykonywane jest zawsze zapytanie o bieżące hasło (niezależnie od aktualnego stanu ważności). Po poprawnej odpowiedzi (hasłem dla zmienianego poziomu) otwierane jest okno zmiany treści hasła.

Rysunek: Okno zmiany treści hasła.

W polach Nowe Hasło i Weryfikacja należy podać nową treść hasła. Podawanie hasła w dwóch polach ma na celu uniknięcie przypadkowych pomyłek przy zmianie hasła.

Należy pamiętać o tym, że jeżeli hasło nie jest ustawione (jest puste), to system ochrony na poziomie tego hasła jest nieaktywny. Projektant systemu powinien w czasie rozruchu zdefiniować hasła początkowe.


9.5.2. Zabezpieczenie wykonania akcji

Osobna grupa zabezpieczeń dotyczy operacji sterujących pracą aplikacji. Chodzi tu o blokady wykonania akcji oraz niektórych komend dostępnych w menu. Parametryzacja tych zabezpieczeń polega na zdefiniowaniu odpowiednich pozycji w pliku inicjującym aplikacji oraz odpowiednim doborze używanych akcji.

Najbardziej ogólnym mechanizmem w tej grupie zabezpieczeń jest akcja HASŁO. Akcja ta przeznaczona jest do użycia w akcjach złożonych. Poprzez użycie akcji HASŁO jako pierwszego składnika akcji złożonej, można zablokować wykonanie wszystkich następnych składników, jeżeli operator nie potrafi podać właściwego hasła. Treść wymaganego hasła jest jednym z elementów definicji akcji HASŁO (Patrz: 9.5.3. Akcje operatorskie).

Metoda akcji HASŁO nie pozwala jednak na blokadę komend znajdujących się w menu Panela Kontrolnego oraz Okna Konstruktora. Niektóre kluczowe komendy, a mianowicie: przejście do Konstruktora i koniec programu, mogą być kontrolowane poprzez zdefiniowanie odpowiednich parametrów w pliku konmfiguracyjnym aplikacji (Blokada Konstruktora i Blokada zamykania apliakcji w: Architekt > Obszary i komputery > moduł Zabezpieczenia > zakładka Blokady). Wspomniane komendy mogą być zablokowane całkowicie lub chronione hasłem podanym w treści pozycji. Zakończenie pracy programu może być również wykonane przy pomocy akcji KONIEC. W akcji tej można zdefiniować niezależne hasło, lub posłużyć się hasłem z pliku inicjującego.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 9. Konstruktor - projektowanie aplikacji > 9.5. Hasła > 9.5.3. Akcje operatorskie

9.5.3. Akcje operatorskie

HASŁO

OBSŁUGA_HASEŁ

KONIEC


9.6. System logowania

Użytkownik domyślny

Dostęp do aktualnie zalogowanego użytkownika

Dostęp do aktualnie obowiązującego poziomu uprawnień

Pakiet Asix pozwala na tworzenie aplikacji wyposażonych w system logowania użytkowników.

Aktywowanie takiego systemu logowania odbywa się poprzez zadeklarowanie stosownego trybu pracy systemu zabezpieczeń w programie Architekt:

Architekt > Obszary i komputery > moduł Zabezpieczenia > zakładka Zabezpieczenia > Opcja Tryb użytkowników

Nazwy użytkowników i hasła przechowywane są w zewnętrznym pliku Users.ini.

Do zarządzania bazą użytkowników służy okno administracyjne otwierane komendą NARZĘDZIA.OBSŁUGA_UŻYTKOWNIKÓW w oknie Konstruktora. Okno to jest dostępne wyłącznie po zalogowaniu się w systemie Asix jako administrator. Wymaga to w pierwszej kolejności (kiedy już zostanie zadeklarowany tryb użytkowników) utworzenia użytkownika o uprawnieniach administratora, któremu przyporządkowuje się 5 poziom zaufania (dostępu). W tym celu należy uruchomić program Asix w trybie kontrukcyjnym (uruchomienie as32.EXE bez uruchamiania aplikacji) - umożliwi to założenie użytkownika z uprawnieniami administratora.

Rysunek: Okno obsługi użytkowników systemu asix.

Okno administracyjne pozwala na założenie nowego użytkownika, usunięcie użytkownika i zmianę parametrów użytkownika.

Rysunek: Okno definiowania użytkowników systemu asix.

Użytkownik opisany jest przez 6 znakowy identyfikator, 30 znakowy opis tekstowy, hasło i poziom zaufania (dostępu). Istnieje 5 poziomów zaufania, z czego 4 pierwsze odpowiadają poziomom stosowanym w systemie haseł (w przypadku braku logowania użytkowników), 5 poziom - jest poziomem administratora systemu Asix.

Okno logowania użytkowników aplikacji systemu Asix otwierane jest komendą NARZĘDZIA.LOGOWANIE w Panelu Kontrolnym. Okno pozwala także na wylogowanie użytkownika i zmianę hasła aktualnie zalogowanego.

Rysunek: Okno logowania użytkowników systemu asix.

Okno logowania użytkowników można również uruchomić przy wykorzystaniu akcji operatorskiej LOGUJ.

Operacje logowania, wylogowania i 3-krotnego błędnego wprowadzenia hasła są zapisywane jako zdarzenia systemowe w logu alarmów. Treść komunikatów zawiera identyfikator użytkownika.

System logowania użytkowników jest zintegrowany z systemem haseł (haseł poziomowych i indywidualnych).

  • Zalogowanie się użytkownika poziomu 1-4 odpowiada wprowadzeniu na stałe hasła na odpowiadającym mu poziomie. W efekcie operacje chronione poziomami haseł będą wykonywane bez żadnego dodatkowego zapytania - po wprowadzeniu właściwego hasła. W przeciwnym razie - będą odrzucane z komunikatem o niewystarczających uprawnieniach. Operacje chronione hasłami indywidualnymi są dla użytkowników o poziomie zaufania 1-4 dostępne pod warunkiem znajomości hasła.

  • Użytkownik o uprawnieniach administratora systemu może wykonywać dowolne operacje bez konieczności wprowadzania haseł.

  • Praca bez zalogowania powoduje, że wszystkie operacje chronione poziomowymi hasłami są zablokowane. Można wykonać operacje chronione hasłem indywidualnym pod warunkiem znajomości hasła.

  • Jeżeli używany jest system logowania, to przejście z trybu aplikacyjnego do trybu konstruktora wymaga wcześniejszego zalogowania się jako administrator systemu Asix.

We wszystkich akcjach operatorskich, gdzie podawane jest indywidualne hasło dostępowe można wprowadzić liczbę od 1 do 5 (w miejsce hasła), co oznacza żądanie podania odpowiedniego hasła poziomowego.

Użytkownik domyślny

W sytuacji, gdy aktywny jest system logowania użytkowników, można zadeklarować użytkownika domyślnego, który jest automatycznie logowany (bez pytania o hasło) na starcie programu.

Użytkownik domyślny może zostać zadeklarowany poprzez podanie identyfikatora użytkownika do parametru Identyfikator domyślnego użytkownika:

Architekt > Obszary i komputery > moduł Zabezpieczenia > zakładka Tryb użytkowników

Dostęp do aktualnie zalogowanego użytkownika

System logowania zapewnia dostęp do: opisu aktualnie zalogowanego użytkownika i jego identyfikatora. W tym celu należy zdefiniować zmienne procesowe o nazwie:

__USERID__ - 7 znakowy łańcuch przetwarzany funkcją NIC_TEXT,

__USERNAME__ - 31 znakowy łańcuch przetwarzany funkcją NIC_TEXT,

do których wpisywane są odpowiednio: identyfikator użytkownika i jego opis.

Dostęp do aktualnie obowiązującego poziomu uprawnień

System logowania zapewnia dostęp do aktualnie obowiązującego poziomu uprawnień (od 0 do 5). W tym celu należy zdefiniować zmienną procesową o następującej nazwie:

__USERLEVEL__ - wartość typu INT


9.7. Mechanizm zabezpieczeń systemowych

Zabezpieczenia dynamiczne

Zabezpieczenia statyczne

Mechanizmy zabezpieczeń systemowych pozwalają na łatwe zabezpieczanie dostępu do potencjalnie niebezpiecznych funkcji systemu operacyjnego, których nieumiejętne lub nieodpowiedzialne użycie przez operatora mogłoby doprowadzić do uszkodzenie systemu. Jednocześnie, użycie mechanizmów zabezpieczeń, pozwala na pracę na konto użytkowników systemu Windows o dużych uprawnieniach, co ułatwia konserwację i zarządzanie pracą systemu operacyjnego.

Mechanizmy zabezpieczeń dzielą się na dwie grupy:

dynamiczne - zintegrowane z Asixem i dynamicznie włączające się lub wyłączające w zależności od stanu programu;

statyczne - ustawiane jednorazowo i pozostające w stanie aktywnym przez cały czas pracy systemu.

Zabezpieczenia dynamiczne

Mechanizm dynamicznych zabezpieczeń systemowych uaktywniany jest poprzez zastosowanie parametru Zabezpieczenia systemowe:

Architekt > Obszary i komputery > moduł Zabezpieczenia

Zabezpieczenia dynamiczne są włączane i wyłączane w trakcie pracy programu.

Zestaw zabezpieczeń przełączanych dynamicznie jest następujący:

  • blokada dostępu do menedżera zadań (klawisze Ctrl+Alt+Del);

  • ukrywanie i blokada paska zadań;

  • blokada klawiszy otwierających menu startowe (klawisze Ctrl+Esc i Windows);

  • blokada wyświetlania plików pomocy HLP.

Sposób przełączania zabezpieczeń zależy od sposobu konfiguracji systemu kontroli dostępu w aplikacji. Możliwe są dwa warianty:

  • aktywny jest system użytkowników aplikacji (logowania); wówczas zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora;

  • aktywny jest tylko system haseł poziomowych; zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy aktywne jest hasło poziomu 4.

System zabezpieczeń dynamicznych włącza się dopiero po pełnym uruchomieniu aplikacji, dlatego też został wprowadzony mechanizm ochrony fazy uruchomienia programu. W komendzie startowej programu as32.exe należy dodać przełącznik /PROTECT, co spowoduje natychmiastowe domyślne włączenie zabezpieczeń, które mogą zostać odblokowane dopiero po zalogowaniu operatora typu administrator lub podaniu hasła poziomu 4.

Przełącznik /PROTECT można stosować również wtedy, gdy system zabezpieczeń dynamicznych nie jest włączony. W tym przypadku system operacyjny jest trwale zabezpieczony w trakcie pracy aplikacji.

Zabezpieczenia statyczne

Uzupełnieniem mechanizmu zabezpieczeń dynamicznych sa zabezpieczenia statyczne ustawiane przy pomocy programu Menedżer uprawnień globalnych (plik StaticPolicies.exe).

Rysunek: Okno menedżera uprawnień globalnych.

Po zaznaczeniu zabezpieczeń, które mają być zastosowane, należy użyć przycisku Zastosuj, a następnie restartować system operacyjny. Rekomendowane działanie to zaznaczenie wszystkich opcji.

Opcje w grupach Ukrywanie ikon na pulpicie i Inne ustawienia dotyczą tylko użytkownika systemu Windows, na konto którego wykonywany jest program Menedżera. Zestaw ikon standardowo widocznych na pulpicie zależy od wersji systemu operacyjnego i jego ustawień.


9.8. Użycie map bitowych

Mapy bitowe są to obrazki o niewielkich rozmiarach, służące do prezentacji symboli graficznych, tworzone poprzez odpowiednie zdefiniowanie prostokątnej matrycy bitów. Program AS używa map bitowych do dwóch celów:

ikony - symbole, które wyświetlane są zamiast okna (maski wizualizacyjnej) po wykonaniu operacji przejścia do ikony,

obrazki - symbole wyświetlane przez obiekty na maskach wizualizacyjnych.

Mapy bitowe potrzebne podczas działania aplikacji, znajdują się w pliku biblioteki obrazków lub są zapisane w plikach dyskowych w formacie BMP, GIF, PNG, JPG (i inne). Standardowo plik biblioteki nazywa się asbitmap.dat, istnieje jednak możliwość zadeklarowania użycia innego pliku poprzez parametr Plik symboli graficznych w pliku konfiguracyjnym aplikacji:

Architekt > Obszary i komputery > moduł Maski > zakładka Pliki i Foldery

W pakiecie systemu A six dostarczana jest bogata biblioteka map bitowych.

W aktualnej wersji obsługiwane są pliki graficzne z atrybutem przeźroczystości oraz pliki animowane. Pliki animowane można w szczególności użyć w obiekcie OBRAZKI do animacji wybranych stanów.

Zewnętrzne pliki graficzne należy zawsze umieszczać w katalogach zadeklarowanych w pozycji Ścieżka masek w pliku konfiguracyjnym aplikacji (w obiektach w polu nazwy obrazka nie można podawać ścieżek dostępu - zewnętrzne pliki obrazków są zawsze poszukiwane w ścieżce masek).

Program AS posiada wbudowany edytor map bitowych, który może zostać uruchomiony komendą NARZĘDZIA.EDYTOR_MAP_BITOWYCH. Szczegółowy opis użycia edytora obrazków znajduje się w osobnym rozdziale (Patrz: 9.8.1. Edytor map bitowych).

Dopuszczalne jest stosowanie map bitowych o dowolnym rozmiarze i dowolnej ilości kolorów. Wbudowany edytor pozwala jednak zmieniać tylko mapy 16 kolorowe o rozmiarze poniżej 65000 punktów.

Parametryzacja użycia map bitowych polega na wpisaniu nazwy obrazka lub pliku mapy bitowej w odpowiednich polach edycyjnych. Na przykład, w oknach definiujących masek znajduje się pole o nazwie Ikona, przeznaczone do podania nazwy ikony, która ma zostać użyta w przypadku wykonania operacji zwinięcia maski do ikony. Podobnie, w oknach definiujących obiektów wizualizacyjnych wyświetlających informacje w postaci obrazków, znajduje się pole o nazwie Mapa Bitowa lub Obrazek (lub podobnej), służące do określenia mapy bitowej używanej w obiekcie.

Maksymalna dozwolona długość nazwy obrazka wynosi 64 znaki.

Poniżej pokazany jest typowy przykład okna definiującego obiekty klasy OBRAZEK.

PRZYKŁAD

Rysunek: Okno definiujące obiekty klasy OBRAZEK.

W polu edycyjnym Nazwa Mapy należy wprowadzić nazwę mapy bitowej używanej przez obiekt. W przypadku użycia bitmap zapisanych w oddzielnych plikach w formacie BMP należy podać nazwę pliku dyskowego wraz z rozszerzeniem. Pliki pojedynczych bitmap muszą znajdować się w jednej z kartotek zadeklarowanych w parametrze Ścieżka masek w pliku konfiguracyjnym aplikacji. Możliwy jest również wybór z listy map bitowych dostępnych w aplikacji. Wykonuje się to poprzez przyciśnięcie klawisza Szary-+ lub kliknięcie prawym klawiszem myszki, po uprzednim wyselekcjonowaniu pola mapy bitowej. Powoduje to otwarcie okna pokazującego listę wszystkich map bitowych znajdujących się w pliku map bitowych aplikacji. Z listy tej można dokonać wyboru poprzez wskazanie właściwej mapy.

Okno selekcji map bitowych prezentuje Rysunek: Okno selekcji map bitowych.

Rysunek: Okno selekcji map bitowych.

Grupa pól wyboru Rodzaj obrazka służy do wyboru typu mapy bitowej (ikona, obrazek lub zewnętrzny plik graficzny). Jeżeli z kontekstu użycia okna selekcji wynika jakiego typu mapa ma być wybrana, to wybór typu mapy jest zablokowany. Pole Nazwa automatycznie wyświetla nazwę mapy, która została wskazana oraz umożliwia wprowadzenie nazwy mapy bitowej dostępnej na liście. Podczas selekcji map bitowych, w polu znajdującym się w górnym prawym rogu okna wyświetlana jest zawartość mapy, która jest aktualnie wybrana.

Zestaw klawiszy oraz operacja wykonywana na wybranej mapie jest uzależniona od kontekstu w jakim okno selekcji zostało użyte. Przycisk OK powoduje wykonanie operacji typu wybór lub import mapy (import w przypadku wywołania okna selekcji map bitowych za pomocą opcji MAPA.IMPORT... w edytorze map bitowych - patrz: 9.8.1. Edytor map bitowych). Podwójne kliknięcie myszką (na pozycji wybranej nazwy) jest równoznaczne przyciśnięciu przycisku OK. Przyciski Anuluj i Koniec powoduje zamknięcie okna bez wykonywania żadnej operacji. W przypadku importowania map pomiędzy plikami bibliotek (patrz: 9.8.1. Edytor map bitowych), na liście selekcji można jednorazowo wybrać dowolną ilość map (klawisz spacji służy do zaznaczenia wyboru mapy przy pomocy klawiatury).


9.8.1. Edytor map bitowych

Program AS posiada wbudowany edytor map bitowych. Mapy używane są jako ikony, do których można zwijać maski lub jako obrazki wyświetlane przez obiekty wizualizacyjne. Edytor uruchamiany jest komendą NARZĘDZIA.EDYTOR_MAP_BITOWYCH z menu Okna Konstruktora. Wszystkie operacje edycyjne dotyczą map znajdujących się w bibliotece map bitowych, która jest używana w projektowanej aplikacji (plik biblioteki jest deklarowany za pomocą parametru Plik symboli graficznych: Architekt > Obszary i komputery > moduł Maski > zakładka Pliki i Foldery).

Okno edytora map bitowych prezentuje poniższy rysunek.

Rysunek: Okno edytora map bitowych.

W skład okna edytora wchodzą następujące elementy:

linia tytułu linia tytułu, w której podawana jest nazwa aktualnie edytowanej mapy (maksymalnie 64 znaki);

pasek menu rozwijanego - menu udostępniające komendy służące do edycji map bitowych;

pasek narzędzi - pasek zmiany narzędzi służących do rysowania (trybów rysowania); komendy zmiany narzędzi są również dostępne w menu; pasek pozwala na szybką zmianę narzędzia przy pomocy myszki;

obszar edycji - obszar służący do bezpośredniej edycji mapy bitowej; jego struktura zostanie podana w dalszej części rozdziału.

Znaczenie komend znajdujących się w rozwijanym menu okna edytora jest następujące:

MAPA.NOWA

Utworzenie nowej mapy. Wykonanie komendy powoduje otwarcie poniższego okna dialogowego.

Rysunek: Okno umożliwiające utworzenie nowej mapy bitowej/ikony.

W momencie zakładania nowej mapy należy określić jej typ oraz początkowy rozmiar. Jeżeli wybrany zostanie typ Ikona, to rozmiar ustalany jest na 32x32 piksele. Nie może on ulec zmianie. Typ Mapa Bitowa pozwala na swobodne deklarowanie rozmiaru, który może być zmieniony także później (komendą EDYCJA.ZMIANA_ROZMIARU).

MAPA.OTWÓRZ

Rozpoczęcie edycji utworzonej wcześniej mapy bitowej. Po wykonaniu komendy otwierane jest standardowe okno selekcji map bitowych. Należy w nim wybrać mapę, która będzie następnie edytowana. W oknie selekcji można przełączać się między listami ikon i obrazków.

MAPA.ZACHOWAJ

Zapamiętanie zmian w mapie bitowej w pliku biblioteki map.

MAPA.ZACHOWAJ_JAKO

Zapamiętanie edytowanej mapy bitowej w pliku biblioteki map pod zmienioną nazwą. Poprzednia wersja mapy bitowej z oryginalną nazwą pozostaje w bibliotece.

MAPA.IMPORT

Komenda pozwala na dołączenie do pliku biblioteki zewnętrznej mapy bitowej. Selekcja dołączanego pliku wykonywana jest w otwieranym oknie wyboru pliku. Import może być wykonany z plików typu BMP lub ICO, lub z innej biblioteki map (plik typu DAT). Okno wywołane komendą MAPA.IMPORT pozwala na selekcję wszystkich obrazków nieistniejących w aktualnej bibliotece (należy przy tym wybrać opcję Żaden na pytanie o nadpisywanie istniejących obrazków).

MAPA.USUŃ

Skasowanie wybranej mapy bitowej z pliku biblioteki. Wybór mapy wykonywany jest w otwieranym oknie selekcji.

MAPA.KONIEC

Zakończenie pracy edytora map bitowych.

EDYCJA.COFNIJ

Wycofanie ostatniej operacji edycyjnej wykonanej na mapie bitowej.

EDYCJA.WYCZYŚĆ

Wyczyszczenie mapy bitowej do stanu jak po utworzenie mapy (prostokąt w białym kolorze).

EDYCJA.OŁÓWEK

Wybór narzędzia (trybu rysowania) typu Ołówek.

EDYCJA.WAŁEK

Wybór narzędzia typu Wałek. Rozmiar Wałka można ustalić komendą OPCJE.ROZMIAR_WAŁKA.

EDYCJA.LINIA

Wybór narzędzia typu Linia.

EDYCJA.PROSTOKĄT

Wybór narzędzia typu Prostokąt.

EDYCJA.PROSTOKĄT-PEŁNY

Wybór narzędzia typu Wypełniony Prostokąt.

EDYCJA.ELIPSA

Wybór narzędzia typu Elipsa.

EDYCJA.ELIPSA-PEŁNA

Wybór narzędzia typu Wypełniona Elipsa.

EDYCJA.WYPEŁNIENIE

Wybór narzędzia typu Wypełnienie.

EDYCJA.ZMIANA_ROZMIARU

Wykonanie komendy powoduje otwarcie okna dialogowego, w którym można podać nowy rozmiar aktualnie edytowanej mapy bitowej. Poprzednia zawartość mapy nie ulega zniszczeniu, następuje tylko dodanie (usunięcie) odpowiedniej liczby kolumn lub wierszy. Nie można zmienić rozmiaru ikon.

EDYCJA.USTAWIENIE_PALETY

Wykonanie komendy powoduje otwarcie poniższego okna dialogowego w którym można wybrać kolory edytowanej mapy bitowej. Edytowana mapa może posiadać 16 różnych kolorów. Nie ma jednak ograniczenia na ich zestaw.

Rysunek: Okno definiujące kolor edytowanej bitmapy.

OPCJE.RASTER

Komenda powoduje włączenie lub wyłączenie wyświetlania rastra pikselowego w polu edycji mapy bitowej.

OPCJE.ROZMIAR_WAŁKA

Ustalenie wielkości narzędzia typu Wałek

Edytor map bitowych wyposażony jest w podręczne menu kontekstowe pozwalające na szybki dostęp do funkcji edycyjnych - użyteczne w przypadku operacji dodaj/usuń wiersz, dodaj/usuń kolumnę. Menu kontekstowe otwierane jest prawym przyciskiem myszy lub prawym przyciskiem myszy w połączeniu z klawiszem Ctrl (drugi wariant należy użyć wtedy, gdy kursor znajduje się nad którymś z aktywnych elementów okna edycji).

Podstawową część okna edytora stanowi obszar edycji. W jego skład wchodzą poniższe elementy:

prostokąt wyboru koloru - pole położone w lewym górnym narożniku obszaru edycji; złożone jest z różnokolorowych pól służących do wyboru koloru rysowania; wybór odbywa się poprzez wskazanie myszą odpowiedniego prostokąta i kliknięcie prawym lub lewym klawiszem myszki; oba klawisze mają niezależnie przydzielane kolory;

pole wyboru tła "ekran" - kliknięcie jednym z klawiszy myszki w obszarze pola powoduje, że temu klawiszowi nadawany jest atrybut przeźroczysty; pole wyświetlane jest w aktualnie wybranym kolorze tła;

status wyboru koloru "lewy/prawy"- pole statusowe pokazujące aktualnie przydzielone kolory dla obu klawiszy myszki;

pole edycji mapy - główne pole edytora służące do edycji mapy bitowej; pokazuje ono w powiększeniu aktualny stan mapy; stopień powiększenia zależy od rozmiaru mapy bitowej i rozmiaru okna edytora;

pole podglądu mapy - pole położone w górnym prawym narożniku obszaru edycji; pokazuje aktualny wygląd edytowanej mapy w jej rzeczywistych rozmiarach; mapa otoczona jest obszarem tła; pole podglądu służy również do wyboru koloru tła.

Edycja mapy bitowej sprowadza się do wykonywania operacji myszką na obszarze pola edycyjnego. Istotne znaczenie ma aktualnie wybrane narzędzie (tryb rysowania). Wpływa ono na sposób operowania myszką. Wszystkie operacje edycyjne mogą być wykonywane przy pomocy lewego lub prawego klawisza myszki. Każdemu klawiszowi przyporządkowany jest określony atrybut (ustalany w polach wyboru koloru i tła). Wybór klawisza decyduje o atrybucie, z którym operacja zostanie wykonana. Poniżej podane zostaną znaczenia wszystkich typów narzędzi oraz specyficzny dla nich sposób operowania myszką:

Ołówek - kliknięcie klawiszem myszki powoduje ustawienie koloru pojedynczego piksela wskazanego pozycją myszy;

Wałek - kliknięcie klawiszem myszki powoduje ustawienie koloru pikseli znajdujących się w bezpośrednim otoczeniu pozycji myszki; rozmiar wałka jest definiowany przy pomocy komendy OPCJE.ROZMIAR_WAŁKA;

Linia - narzędzie pozwalające na zmianę koloru wszystkich pikseli należących do odcinka linii; punkt początkowy znajduje się w miejscu przyciśnięcia klawisza myszki, punkt końcowy w miejscu puszczenia klawisza;

Prostokąt - narzędzie pozwalające na narysowanie prostokąta o wybranym kolorze; dwa przeciwległe narożniki prostokąta określane są poprzez miejsca przyciśnięcia i puszczenia klawiszy myszki;

Wypełniony Prostokąt - narzędzie obsługiwane tak samo jak poprzednie; różnicą jest to, że wnętrze prostokąta jest również wypełniane kolorem klawisza;

Elipsa - narzędzie pozwalające na narysowanie elipsy o wybranym kolorze; dwa przeciwległe narożniki prostokąta opisującego elipsę określane są poprzez miejsca przyciśnięcia i puszczenia klawiszy myszki;

Wypełniona Elipsa - narzędzie obsługiwane tak samo jak poprzednie; różnicą jest to, że wnętrze elipsy jest również wypełniane kolorem klawisza;

Wypełnienie - narzędzie pozwalające na zmianę koloru wybranego obszaru mapy bitowej; obszar wskazywany jest poprzez kliknięcie klawiszem myszki w wybranym miejscu mapy; kolor jest zmieniany dla wszystkich punktów, których aktualny kolor jest identyczny z kolorem punktu wskazanego, a dodatkowo punkt ten nie jest odcięty od punktu wskazanego punktami w innym kolorze.

Dodatkowego wyjaśnienia wymaga jeszcze atrybut przeźroczystości. Jego użycie w dowolnym punkcie mapy bitowej powoduje, że w momencie jej wyświetlenia w przeźroczystych punktach pokazywana będzie aktualna zawartość tła. W polu podglądu punkty te wyświetlane są w kolorze użytym w polu wyboru tła. W razie konieczności, kolor tła można zmienić w oknie ustawienia palety.

Skróty klawiszowe

Edytor map bitowych posiada funkcje przekształceń edytowanych map. Funkcje te dostępne są poprzez poniższe skróty klawiszowe:

Alt_R - obrót mapy bitowej o 90 stopni;

Alt_Z - odbicie lustrzane względem osi poziomej;

Alt_X - odbicie lustrzane względem osi pionowej;

Alt_W - wstawienie wiersza; jeżeli kursor myszki znajduje się poza obszarem edytowanej mapy, to wstawiany jest wiersz na górze mapy; jeżeli kursor myszki znajduje się w obszarze mapy bitowej, to wstawiany jest wiersz poniżej kursora myszki;

Alt_S - usunięcie wiersza; jeżeli kursor myszki znajduje się poza obszarem edytowanej mapy, to usuwany jest wiersz na górze mapy; jeżeli kursor myszki znajduje się w obszarze mapy bitowej, to usuwany jest wiersz poniżej kursora myszki;

Alt_C - wstawienie kolumny; jeżeli kursor myszki znajduje się poza obszarem edytowanej mapy, to wstawiana jest kolumna po lewej stronie mapy; jeżeli kursor myszki znajduje się w obszarze mapy bitowej, to wstawiana jest kolumna na prawo od kursora myszki;

Alt_V - usunięcie kolumny; jeżeli kursor myszki znajduje się poza obszarem edytowanej mapy, to usuwana jest kolumna po lewej stronie mapy; jeżeli kursor myszki znajduje się w obszarze mapy bitowej, to usuwana jest kolumna na prawo od kursora myszki.


9.9. Użycie wyrażeń

Naciskając prawy klawisz myszy w polu edycyjnym, do którego wprowadza się ciąg wyrażeń języka ASTEL użytkownik wywołuje okno umożliwiające generację tych wyrażeń. Dotyczy to odpowiednich pól obiektów typu WYRAŻENIE, PRZELICZNIK i RAPORT oraz edytora tekstowego, pracującego w szczególności jako edytor raportów.

Korzystając z wyświetlanego po wybraniu komendy okna użytkownik może:

  • tworzyć i obliczać wyrażenia języka ASTEL,

  • sprawdzać przyczyny powstałych podczas wartościowania błędów,

  • poprawiać poprzednio wprowadzone wyrażenia,

  • pobrać utworzone wyrażenie do pola edycyjnego.

Okno dialogowe podzielone jest na kilka obszarów. W górnej części okna zgrupowane są pola umożliwiające generację wyrażeń. Generacja ta polega na dopisywaniu w polu wyrażenia kolejno wybieranych jego elementów. Osoba znająca język ASTEL może takie wyrażenie wpisać w tym polu bezpośrednio.

Rysunek: Panel dialogowy umożliwiający konstruowanie wyrażeń.

Górna część okna zawiera kolejno omówione pola (od lewej).

  • Pole Zmienne umożliwia dopisanie zmiennych zadeklarowanych w nim do tworzonego w linii wyrażenia. Zmienne mogą być wprowadzone do pola ręcznie lub zaimportowane z bazy zmiennych (przycisk Dopisz powoduje dopisanie zmiennej). W przypadku pobierania zmiennej z bazy należy kliknąć prawym klawiszem myszy w polu nazwy zmiennej i w wyświetlonym oknie 'Lista zmiennych’ dokonać selekcji zmiennej.

  • Pole umożliwiające dopisywanie liczb składające się z klawiszy dopisujących cyfry od "0" do "9" oraz znak kropki "." wykorzystywanej dla liczb dziesiętnych.

  • Pole Funktor umożliwia dopisanie nazwy funktora np. "SIN". Aby nazwę funktora dopisać należy wybrać ją na liście po czym nacisnąć umieszczony pod nią przycisk Dopisz.

  • Pole umożliwiające dopisywanie w wyrażeniu operatorów. Klawisz oznaczony czerwoną strzałką "-" jest równoważny naciśnięciu klawisza BACKSPACE w polu wyrażenia i powoduje skasowanie ostatniego znaku.

  • Pole Ewaluator umożliwia dopisanie nazwy ewaluatora np. "MAX". Aby nazwę ewaluatora dopisać należy wybrać ją na liście po czym nacisnąć umieszczony pod nią przycisk Dopisz.

  • Pole umożliwiające dopisywanie w wyrażeniu różnych innych znaków, które mogą w nim wystąpić np. nawiasów czy też elementów tzw. momentów. Dopisanie następuje po naciśnięciu odpowiedniego klawisza.

  • Wartościowania wyrażenia dokonuje się naciskając klawisz ENTER w polu wyrażenia, lub naciskając klawisz ENTER umieszczony z prawej strony pola wyrażenia. Po dokonaniu obliczeń pole wyrażeń pozostaje puste. Położony obok klawisz edycyjny, oznaczony strzałką niebieską z rotacją powoduje wpisanie w polu wyrażeń ostatnio wartościowanego wyrażenia. Może ono posłużyć jako źródło tekstu do edycji.

  • Powyżej pola wyrażenia umieszczone jest pole tekstowe zapamiętujące przebieg kolejnych wartościowań. W kolejnych wierszach (od góry) dopisywane są wartościowane wyrażenia oraz wyniki wartościowania. Jeśli podczas wartościowania wystąpił błąd wówczas zamiast wyniku wpisuje się ciąg "???".

Zawartość tego okna jest następująca:

  • "ostatnio wartościowane wyrażenie"

  • "wynik ostatnio wartościowanego wyrażenia"

  • "przedostatnio wartościowane wyrażenie"

  • "wynik przedostatnio wartościowanego wyrażenia"

  • "..."

  • Poniżej pola wyrażenia umieszczone jest pole tekstowe wyświetlające listę błędów i ostrzeżeń jakie wystąpiły podczas ostatniego wartościowania albo komunikat "brak błędów".

Pozostałe pola zapewniają:

  • możliwość wyświetlania nazw funktorów i ewaluatorów w języku polskim "j.polski";

  • wyświetlanie statusu pracy okna typu "gotowość", "liczenie" i "blokada";

  • wprowadzenie zakresu czasu;

  • możliwość wyświetlania podpowiedzi oraz zakończenia pracy.


9.10. Użycie zmiennych

Zmienne systemu Asix zdefiniowane są w bazie definicji zmiennych. W każdym miejscu, gdzie niezbędne jest podanie nazwy zmiennej (przy parametryzacji obiektów dynamicznych) możliwe jest użycie okna 'Przeglądanie zmiennych’, które pozwala przeglądać, wyszukiwać i wybierać zmienną o żądanej nazwie.

Okno można wywołać przy pomocy menu NARZĘDZIA\Przegląd zmiennych lub też w wyniku kliknięcia prawym klawiszem myszy w polu służącym do deklarowania zmiennej.

Rysunek: Okno 'Przeglądanie zmiennych’.

Główną część okna 'Przeglądanie zmiennych’ stanowi lista zmiennych zadeklarowanych w bazie. Zmienne te mogą być posortowane wg dowolnego pola - wystarczy kliknąć na obszar nazwy pola, wg którego chcemy dokonać operacji sortowania. Kluczem sortowania może być np. nazwa zmiennej lub też jej opis. O kierunku sortowania decyduje ustawienie znacznika ˆ (rosnąco) lub ˇ (malejąco).

Aby w posortowanej liście zmiennych znaleźć pierwszą, której cecha we wskazanej kolumnie zaczyna się od określonego ciągu znaków, należy ten ciąg znaków wpisać do dowolnego pola danej kolumny.

Listę wyświetlanych zmiennych można poddać filtracji. Służy do tego 'Kreator filtrów’ uruchamiany przyciskiem Filtrowanie i grupowanie w oknie 'Przeglądania zmiennych’. W kreatorze istnieje możliwość zdefiniowania warunku filtrowania.

Wyświetlaną listę zmiennych można również ograniczyć dokonując selekcji w lewej części okna, gdzie wyświetlana jest struktura zmiennych. Kliknięcie na dowolnej grupie spowoduje wyświetlenie listy danej grupy zmiennych.

Przyciski OK i Anuluj służą odpowiednio do wyboru wskazanej zmiennej i wstawienia jej do okienka parametryzacji obiektu dynamicznego oraz zamknięcia okienka bez wykonania wyboru zmiennej.


9.11. Użycie czcionek

Zmiana definicji czcionki

Zmiana nazwy czcionki

Dodawanie czcionki do listy

Usuwanie czcionki z listy

W systemie Asix istnieje możliwość wyświetlania informacji tekstowych przy użyciu różnych krojów czcionek.

W oknach definiujących większość obiektów wizualizacyjnych, wyświetlających informacje w postaci alfanumerycznej, znajduje się pole o nazwie Czcionka (lub podobnej), służące do określenia typu czcionki używanej w obiekcie. Poniżej pokazany jest typowy przykład okna definiującego obiekty klasy TEKST.

Rysunek: Okno definiujące obiekty klasy TEKST.

W polu edycyjnym Czcionka należy wprowadzić nazwę czcionki używanej przez obiekt. Nazwa czcionki może być:

  • nazwą predefiniowanej czcionki o zmiennej szerokości znaku: SYSTEM, DIALOG lub SMALL,

  • nazwą predefiniowanej czcionki o stałej szerokości znaku: ROM8x8, ROM8x14 lub ROM8x16,

  • nazwą predefiniowanej czcionki o stałej szerokości i stronie kodowej 852: RAPORT_8x8, RAPORT_8x14 lub RAPORT_8x16, przeznaczone dla raportów i zawierające znaki ramek,

  • nazwą symboliczną czcionki systemu Windows; w pakiecie Asixa dostarczony jest zestaw dodatkowych czcionek typu rastrowego; można jednak używać dowolnej innej czcionki.

Możliwy jest również wybór z zestawu zainstalowanych czcionek. Wykonuje się to poprzez przyciśnięcie klawisza Szary-+ lub kliknięcie prawym klawiszem myszki czcionki polu czcionki. Powoduje to otwarcie okna pokazującego listę zainstalowanych czcionek, z której można dokonać wyboru. Okno to pozwala również na wykonanie innych operacji dotyczących użycia czcionek.

Rysunek: Okno obsługi czcionek.

Po pojawieniu się okna 'Wybierz czcionkę’ należy dokonać selekcji jednej z nazw czcionek z listy, a następnie użyć przycisku Wybierz.

Wybranie przycisku Zakończ lub naciśnięcie klawisza Esc spowoduje wyjście z okna bez wyboru nowej czcionki.

W oknie Przykład można oglądać wyselekcjonowaną czcionkę. Znaki wyświetlane w oknie Przykład można zmienić w polu edycyjnym Przykład.

Zmiana definicji czcionki

Po pojawieniu się okna 'Wybierz czcionkę’ należy dokonać selekcji jednej z nazw czcionek z listy, a następnie wybrać klawisz Zmień definicję. Pojawi się systemowe okno wyboru czcionki. Po dokonaniu wyboru; nowa definicja zostanie przypisana do wybranej wcześniej nazwy.

Zmiana nazwy czcionki

Po pojawieniu się okna 'Wybierz czcionkę’ należy dokonać selekcji jednej z nazw czcionek z listy. Jej nazwa pojawi się w polu edycyjnym Nowa nazwa. Można dokonać jej edycji, a następnie przycisnąć przycisk Zmień nazwę oraz potwierdzić zmianę nazwy w oknie Zmiana nazwy logicznej, które pojawi się na środku ekranu. Zmieni się wtedy nazwa czcionki na liście, przy czym jej definicja pozostanie bez zmian.

Dodawanie czcionki do listy

Po pojawieniu się okna 'Wybierz czcionkę’ należy dokonać selekcji jednej z nazw czcionek z listy, a następnie wybrać przycisk Dodaj. Pojawi się okno takie jak przy zmianie definicji czcionki, przy czym wstępny wybór będzie odpowiadał parametrom wcześniej wyselekcjonowanej czcionki. Po dokonaniu nowego wyboru i jego zatwierdzeniu, nowa czcionka pojawi się na liście z nazwą nadaną przez system Asix. Nazwę tą można zmienić w wyżej opisany sposób.

Usuwanie czcionki z listy

Po pojawieniu się okna 'Wybierz czcionkę’ należy dokonać selekcji jednej z nazw czcionek z listy, a następnie wybrać przycisk Usuń oraz potwierdzić chęć usunięcia nazwy z listy w oknie 'Usuwanie czcionki z listy’, które pojawi się na środku ekranu.

Nazwa symboliczna czcionki jest to dowolna nazwa, której w pliku inicjującym został przyporządkowany opis czcionki. W czasie konstrukcji aplikacji można posługiwać się tak zdefiniowanymi nazwami przy wyborze czcionek. Zalety użycia tej metody wyboru to:

  • posługiwanie się nazwami, które w sposób logiczny oznaczają przeznaczenie i kształt czcionki, na przykład: TYTUL, OZDOBNA, MALA, POMIAR; bezpośrednie opisy czcionek są trudne do zapamiętania oraz nie mają żadnego związku ze sposobem ich użycia;

  • zmiana czcionki używanej do pewnego konkretnego celu polega na zmianie definicji nazwy symbolicznej w pliku inicjującym; wszystkie obiekty używające tej nazwy automatycznie zaczną wyświetlać się przy użyciu nowej czcionki.


9.11.1. Wskazówki dotyczące użycia polskich liter

W systemie Windows XP/2000/NT4.0 do wyświetlania polskich liter używa się czcionek w stronie kodowej 1250. Program Asix używa strony kodowej 852, lecz wszędzie tam, gdzie jest to konieczne i możliwe następuje automatyczna konwersja tekstów na stronę 1250 przed wyświetleniem.

System raportów ze względu na kompatybilność z wersją DOS używa przez cały czas czcionek w standardzie LATIN II (strona kodowa 852). Raporty nie są konwertowane przed wyświetleniem na stronę kodową 1250.

W związku z tym wersja dla Windows XP/2000/NT4.0 posiada dodatkowo wbudowane czcionki o stałej szerokości znaku, wyposażone w ramki, wykorzystujące stronę kodową 852 o nazwach RAPORT_8x8, RAPORT_8x14 oraz RAPORT_8x16. Czcionek tych nie powinno się używać w obiektach, jeśli chce się mieć poprawnie wyświetlone polskie znaki. Edytor tekstów wbudowany w systemie Asix w zależności od tego, czy został wywołany z menu NARZĘDZIA czy też z okna raportowego wyświetla prawidłowo i prawidłowo wstawia polskie znaki albo w stronie kodowej 1250 albo 852. Okno wyświetlające zawartość pliku tekstowego używane w akcji ZOBACZ wyświetla polskie znaki w stronie kodowej 1250. To samo okno używane do wyświetlania raportów używa zawsze strony kodowej 852.

W przypadku wydruków w trybie tekstowym, np.: wydruk alarmów, wydruk raportów - wymagane jest aby drukarka posiadałam wbudowane czcionki zgodne ze standardem LATIN II.


9.12. Lista operacji klawiszowych

Operacje dotyczące pól edycyjnych

Operacje dotyczące kopiowania tekstów w polach edycyjnych

Operacje dotyczące list z możliwością przestawiania i usuwania elementów

Operacje dotyczące edycji obiektów w trybie konstruktora

Globalne operacje systemowe

Operacje dotyczące makr klawiszowych

Większość operacji wykonywanych przez operatora w Systemie Asix może być realizowana dwoma sposobami: przy pomocy myszki lub klawiatury. W rozdziale tym podane zostanie znaczenie pewnych specyficznych kombinacji klawiszy, które mają w systemie z góry zdefiniowane znaczenie. Należy pamiętać o tym, że oprócz tych kombinacji, projektant systemu aplikacyjnego może zdefiniować swoje własne dodatkowe klawisze, które będą inicjowały wykonanie wybranych przez niego akcji.

Interpretacja klawiszy jest w systemie Asix wykonywana w sposób kontekstowy. Oznacza to, że ta sama kombinacja może oznaczać różną operację w zależności od aktualnego stanu systemu. Podobnie, w pewnych sytuacjach, niektóre klawisze mogą tracić swoje znaczenie.

Poniżej podana jest lista klawiszy specjalnych systemu Asix.

Enter - sygnał potwierdzenia, wykonania operacji (zależnie od kontekstu użycia).

Esc - sygnał rezygnacji z wykonania operacji.

spacja - sygnał selekcji elementu w listach lub wykonania operacji w klawiszach.

Szary- + - sygnał selekcji, otwarcie listy wyboru, potwierdzenie wysłania wartości dla obiektów wizualizacyjnych.

strzałki - zmiana pozycji lub selekcji we wskazanym kierunku.

Tab - przejście do następnego obiektu/pola.

Shift-Tab - przejście do poprzedniego obiektu/pola.

Home - przejście na początek listy lub początek linii w polach edytowanych.

End - przejście na koniec listy lub koniec linii w polach edytowanych.

Ctrl-Home - przejście na początek tekstu lub linii, lub przejście na początek listy.

Ctrl-End - przejście na koniec tekstu lub linii, lub przejście na koniec listy.

PgUp - zmiana selekcji lub położenia kursora o stronę w górę.

PgDn - zmiana selekcji lub położenia kursora o stronę w dół.

Alt-litera - natychmiastowa selekcja pola w oknach lub wykonanie komendy z menu. litera użyta w kombinacji jest wyróżnioną literą nazwy pola lub komendy menu.

Operacje dotyczące pól edycyjnych:

Del - skasowanie znaku na pozycji kursora

Backspace - skasowanie znaku przed kursorem

Ctrl-Del - kasowanie tekstu do końca linii

Ctrl- [image] - przejście do słowa na lewo od kursora

Ctrl- [image] - przejście do słowa na prawo od kursora

Ins - zmiana trybu wstawianie/nadpisywanie

Ctrl-PgUp - przejście na początek tekstu

Ctrl-PgDn - przejście na koniec tekstu

Operacje dotyczące kopiowania tekstów w polach edycyjnych:

Shift-Strzałka - zmiana położenia kursora połączona z zaznaczeniem tekstu

Ctrl-x - usunięcie z zapamiętaniem zaznaczonego tekstu

Ctrl-c - zapamiętanie zaznaczonego tekstu

Ctrl-v - wstawienie zapamiętanego tekstu

Operacje dotyczące list z możliwością przestawiania i usuwania elementów:

Ctrl-Home - przestawienie elementu na początek listy

Ctrl-End - przestawienie elementu na koniec listy

Ctrl- [image] - przesunięcie elementu listy w górę

Ctrl- [image] - przesunięcie elementu listy w dół

Alt-a - przesunięcie elementu listy w górę

Alt-z - przesunięcie elementu listy w dół

Ctrl-Del - usunięcie elementu listy

Alt-d - usunięcie elementu listy

Operacje dotyczące edycji obiektów w trybie konstruktora:

Ctrl-p - utworzenie kopii obiektu

Ctrl-r - utworzenie kopii obiektu

Ctrl-t - usunięcie z zapamiętaniem obiektu

Ctrl-x - usunięcie z zapamiętaniem obiektu

Shift-Del - usunięcie z zapamiętaniem obiektu

Ctrl_k - zapamiętanie obiektu

Ctrl_c - zapamiętanie obiektu

Shift-Ins - zapamiętanie obiektu

Ctrl_w - wstawienie zapamiętanego obiektu

Ctrl_v - wstawienie zapamiętanego obiektu

Ctrl-Ins - wstawienie zapamiętanego obiektu

Ctrl_u - usunięcie obiektu

Ctrl_q - usunięcie obiektu

Del - usunięcie obiektu

Ctrl-Home - przesunięcie obiektu na pierwszy plan

Ctrl_End - przesunięcie obiektu na drugi plan

Globalne operacje systemowe:

Alt-F1 - otwarcie okna pomocy

Alt-F2 - zapisanie bieżącej maski w pliku (w trybie konstruktora)

Alt-F3 - odrysowanie ekranu

Alt-F4 - zamknięcie okna

Alt-F5 - odtworzenie rozmiaru okna (dla Windows 2000 / NT 4.0 / 98 wydruk ekranu)

Alt-F6 - przejście do następnego okna

Operacje dotyczące makr klawiszowych:

Alt-F12 - otwarcie okna zarządzania makrami lub koniec sekwencji nagrywania

Alt-0 ... Alt-9 - odegranie makra

Oprócz opisanych powyżej klawiszy, w systemie mogą jeszcze być używane inne bardzo specyficzne sekwencje, które mają znaczenie tylko w bardzo wąskim zakresie. Dotyczy to głównie operacji wykonywanych przez obiekty wizualizacyjne (w szczególności obiekt klasy WYKRES). Klawisze te zostaną opisane w rozdziałach dotyczących tych części Systemu Asix, w których są używane.


9.12.1. Makra

Program AS posiada wbudowany mechanizm makrooperacji, który pozwala znacznie przyspieszyć pracę projektanta w przypadku konieczności wielokrotnego powtarzania tej samej sekwencji operacji. System makr charakteryzuje się następującymi cechami:

  • podczas definiowania makra zapamiętywane są operacje wykonywane przy pomocy klawiatury i myszki,

  • odtwarzanie makra odbywa się z maksymalną osiągalną szybkością (bez zachowania oryginalnych zależności czasowych),

  • można zapamiętać maksymalnie 10 makrooperacji,

  • makra są dostępne tylko w trybie konstruktora.

Proces nagrania makra inicjuje się przyciśnięciem klawisza Alt-F12. Powoduje to wyświetlenie poniższego okna:

Rysunek: Okno 'Zarządzanie Makrami'.

Okno podzielone jest na dziesięć sekcji odpowiadających za poszczególne makra. Pola wchodzące w skład każdej sekcji mają następujące znaczenie:

pole nazwy - nazwa makra, używane tylko jako pomocnicze pole, w którym projektant może zanotować jaką operację makro wykonuje,

pole wyboru Nagrane - wskaźnik czy makro jest już nagrane,

klawisz Nagraj - klawisz inicjujący nagrywanie,

klawisz Skasuj - klawisz usuwa zapamiętaną poprzednio makrooperację.

Po wybraniu numeru makra, projektant powinien przycisnąć odpowiedni klawisz Nagraj. Okno obsługi makr jest zamykane, po czym projektant wykonuje operacje, które mają być zapamiętane. W trakcie nagrywania program AS sygnalizuje dźwiękiem zapamiętanie każdej operacji wykonanej myszą lub klawiaturą. Jeżeli projektant zakończy wykonanie sekwencji operacji, która miała być zapamiętana, to powinien ponownie przycisnąć klawisz Alt-F12. Zostanie to zasygnalizowane specjalnym sygnałem dźwiękowym, po czym proces nagrywania zostanie zakończony. Od tego momentu projektant ma możliwość odtworzenia nagranego makra. Odtworzenie makrooperacji jest inicjowane przyciśnięciem jednej z kombinacji klawiszy: od Alt-0 do Alt-9. Klawisz cyfry w użytej kombinacji decyduje o numerze makra, które ma być odegrane.

Makra są zapamiętywane w plikach dyskowych.

W procesie odegrania makra usuwane są wszystkie przerwy czasowe pomiędzy kolejnymi operacjami. W efekcie odgrywanie zabiera minimalną ilość czasu. Stwarza to czasem problemy, jeżeli w trakcie makra otwierane są niektóre okna systemowe (np. okno wyboru koloru). Nie są one w stanie tak szybko obsługiwać zdarzeń. W tego typu sytuacjach można używać makr o numerach 0 i 9. W czasie odgrywania wprowadzają one drobne opóźnienia pomiędzy kolejnymi operacjami.


10. Egzekutor - realizacja aplikacji

Program AS32 uruchamiany jest automatycznie w trybie wykonania aplikacji, jeżeli zostanie uruchomiony z podaniem nazwy pliku inicjującego, który definiuje parametry aplikacji.

Podstawowe cechy trybu realizacji są następujące:

  • otwierane są automatycznie wszystkie maski podane w parametrze Otwórz pliku konfiguracyjnego (Architetk > Obszary i komputery > moduł Parametry startowe > zakładka Maski),

  • maski otwierane są w trybie odświeżania,

  • akcje operatorskie są wykonywane,

  • system alarmów jest aktywny,

  • uruchamiane są moduły komunikacyjne i archiwizacji (Aslink, Asmen, Aspad).


10.1. Panel Kontrolny

W momencie startu programu AS32 w trybie wykonania aplikacji automatycznie tworzone jest okno Panelu Kontrolnego. Jest to centralne okno aplikacji, które spełnia dwie funkcje:

  • udostępnia zestaw komend służących do kontroli pracy aplikacji; komendy te są uzupełnieniem zestawu operacji udostępnionych przez projektanta systemu w postaci akcji operatorskich;

  • pokazuje i przechowuje komunikaty dotyczące wewnętrznej pracy systemu.

Panel Kontrolny pozostaje otwarty przez cały czas działania aplikacji (może zostać chwilowo zamknięty po przejściu do trybu konstruktora, ale wtedy zostanie ponownie otwarty po powrocie do trybu aplikacji). Zamknięcie Panelu Kontrolnego jest równoznaczne z końcem działania aplikacji.

Selekcja Panelu Kontrolnego przez operatora odbywa się przy pomocy standardowych mechanizmów środowiska programu AS32 (na przykład, wskazanie myszki, przyciskanie klawisza Alt+F6), lub poprzez wykonanie udostępnionej przez projektanta akcji operatorskiej PANEL.

Miejsce i rozmiar okna Panelu Kontrolnego w momencie startu aplikacji może być zadeklarowane w pliku konfiguracyjnym poprzez odpowiednie użycie parametru Położenie okna panelu kontrolnego. Istnieje również możliwość automatycznego zwijania Panelu do ikony.

Próba ponownego uruchomienia programu AS32, gdy poprzednia instancja jest w stanie ukryj, powoduje wyjście ze stanu ukryj. Jest to przydatne w sytuacji, gdy ze względu na zabezpieczenia systemu pasek zadań jest nieaktywny.


10.2. Elementy składowe Panelu Kontrolnego

Okno Panelu Kontrolnego prezentuje poniższy rysunek.

Rysunek: Okno Panelu Kontrolnego.

Zasadniczą część Panelu Kontrolnego stanowi lista komunikatów systemowych, które dotyczą zdarzeń związanych z działaniem oprogramowania oraz stanem otoczenia systemu, zachodzących w czasie działania aplikacji. Typowe przykłady komunikatów to: komunikaty instalacyjne określające aktywne komponenty systemu, informacje o błędach w czasie transmisji danych procesowych, komunikaty dotyczące autodiagnostyki systemu. Każdy komunikat składa się z czasu wystąpienia, identyfikatora części składowej oprogramowania, której dotyczy zdarzenie oraz z treści komunikatu.

Komunikaty podzielone są na typy, które odpowiadają ich stopniom ważności. Komunikat wyświetlany jest w różnych kolorach w zależności od typu:

kolor zielony - komunikat;

kolor niebieski - błąd;

kolor czerwony - ważny błąd.

Pojawienie się zdarzeń o stopniu ważności powyżej komunikatu sygnalizowane jest dodatkowo sygnałem dźwiękowym.

Rozmiar pliku komunikatów panelu kontrolnego może być ograniczana w pliku konfiguracyjnym aplikacji poprzez parametr Maksymalny rozmiar:

Architekt > Obszary i komputery > moduł Parametry startowe > zakładka Panel kontrolny


10.2.1. Opis menu Panelu Kontrolnego

Poniżej opisane zostały wszystkie komendy znajdujące się w menu Panelu Kontrolnego. Bardziej szczegółowych informacji dotyczących niektórych z tych komend należy szukać w odpowiednich rozdziałach tematycznych.

MASKI.OTWÓRZ

Otwarcie dowolnie wybranej maski. W efekcie wykonania tej komendy otwierane jest okno pokazujące wszystkie zdefiniowane maski, z których operator może dokonać wyboru. Okno selekcji jest opisane w rozdziale dotyczącym Okna Konstruktora. Preferowaną metodą otwierania masek w aplikacji są jednak akcje operatorskie.

MASKI.KONSTRUKTOR

Przejście do trybu Konstruktora. Pozwala to na edycję masek równolegle z normalną pracą systemu. Komenda ta może być zablokowana lub chroniona hasłem poprzez odpowiednie zdefiniowanie pozycji Blokada konstruktora w pliku konfiguracyjnym aplikacji.

MASKI.KONIEC

Zamknięcie okna Panelu Kontrolnego, co jest równoznaczne z końcem pracy aplikacji. Komenda ta może być zablokowana lub chroniona hasłem poprzez odpowiednie zdefiniowanie pozycji Blokada zamykania aplikacji w pliku konfiguracyjnym aplikacji. Akcja operatorska KONIEC jest dokładnym odpowiednikiem omawianej komendy.

NARZĘDZIA.OKNO_AKTYWNYCH_ALARMÓW

Otwarcie maski alarmów aktywnych w jej standardowej pełnej formie. Jest to alternatywna metoda obsługi alarmów aktywnych, obok głównej metody masek swobodnie definiowanych.

NARZĘDZIA.OKNO_HISTORYCZNYCH_ALARMÓW

Otwarcie maski alarmów historycznych w jej standardowej pełnej formie. Jest to alternatywna metoda obsługi alarmów historycznych, obok głównej metody masek swobodnie definiowanych.

NARZĘDZIA.OKNO_RAPORTÓW

Otwarcie okna systemu raportów, które pozwala na liczenie wybranych raportów, oraz inne operacje związane z raportami. Komenda może być blokowana przy pomocy pozycji Blokada edycji (Architekt > Obszary i komputery > moduł Raporty > zakładka Raporty).

NARZĘDZIA.OKNO_DIALOGÓW

Otwarcie okna Dialogów pozwalającego na interaktywne obliczenie wyrażeń arytmetycznych korzystających z wartości zmiennych procesowych.

NARZĘDZIA.PRZEGLĄD_ZMIENNYCH

Otwarcie okna umożliwiającego przeglądanie listy zmiennych procesowych (bieżących i archiwalnych) zdefiniowanych w systemie.

NARZĘDZIA.OBSŁUGA_DRUKARKI

Otwarcie okna obsługi drukarki. Okno to pozwala na podgląd aktualnie wykonywanych wydruków, zarządzanie kolejką wydruków oczekujących oraz zlecanie wydruku plików.

NARZĘDZIA.OBSŁUGA_HASEŁ

Otwarcie okna obsługi haseł. Okno to pozwala na ustawianie stanu ważności haseł oraz na zmianę treści haseł.

NARZEDZIA.LOGOWANIE

W przypadku stosowania systemu logowania, pozwala uruchomić okno 'Logowanie użytkownika’.

NARZEDZIA.STAN_SYSTEMU.ALARMY

Otwarcie okna, w którym pokazany jest aktualny stan oraz konfiguracja systemu alarmów.

OPCJE.ZMIANA_CZASU

Otwarcie okna pozwalającego na zmianę czasu.

OPCJE.SEKWENCJA_DEMO

Wykonanie operacji nagrania lub odtworzenia sekwencji demonstracyjnej.


10.2.2. Przełączanie masek wizualizacyjnychh

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 10. Egzekutor - realizacja aplikacji > 10.2. Elementy składowe Panelu Kontrolnego > 10.2.2. Przełączanie masek wizualizacyjnychh

10.2.2. Przełączanie masek wizualizacyjnych

Zasadniczą część każdej aplikacji stanowi zestaw masek wizualizacyjnych. W fazie wykonania operator wybiera maski, które mają być wyświetlane. W oknie Panelu Kontrolnego udostępniona jest komenda MASKI.OTWÓRZ, która pozwala na wybór dowolnej maski wchodzącej w skład aplikacji (plik opisujący maskę znajduje się w jednym z katalogów ścieżki dostępu). Jest to jednak komenda pomocnicza. Podstawowym mechanizmem przełączania masek są akcje operatorskie OTWÓRZ_MASKĘ i ZAMKNIJ_MASKĘ. Projektant systemu musi udostępnić te akcje poprzez odpowiednio sparametryzowane zestawy klawiszy oraz obiekty klasy PRZYCISK. Projektant musi także określić, które maski mają być otwarte automatycznie w momencie startu systemu:

Architekt > Obszary i komputery > moduł Parametry startowe > zakładka Maski > opcja Otwórz

W normalnym przypadku, ładowanie masek odbywa się z plików dyskowych. W przypadku masek, które zawierają dużą ilość obiektów może to być operacja czasochłonna. Program AS32 pozwala na buforowanie masek w pamięci operacyjnej komputera. Polega to na zapamiętaniu w pamięci masek, które nie są aktualnie wyświetlane, a w chwili gdy maska ma zostać otwarta, skorzystaniu z przechowanego opisu bez konieczności czytania definicji z pliku dyskowego.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 10. Egzekutor - realizacja aplikacji > 10.2. Elementy składowe Panelu Kontrolnego > 10.2.3. Akcje operatorskie

10.2.3. Akcje operatorskie

PANEL

KONIEC


10.3. Użycie drukarki

Program AS32 posiada wbudowany moduł obsługi drukarki. Pozwala on na wykonywanie wydruków równolegle z normalną pracą systemu. Drukowanie w żaden sposób nie wpływa na odświeżanie masek wizualizacyjnych i wykonywanie innych operacji związanych z obsługą aplikacji.

Wydruki mogą być wykonywane dowolnej, zainstalowanej w systemie drukarce. Nie jest wymagany żaden konkretny typ drukarki. Wydruki tekstowe mogą jednak wymagać drukarek ze sprzętowo wbudowanymi czcionkami, pozwalającymi na wydruk znaków narodowych i znaków ramek dla raportów. W przypadku wersji polskiej jest to strona kodowa LATIN II.

W systemie Asix mogą być drukowane informacje różnego typu. Ze względu na ich charakter mogą być podzielone na wydruki tekstowe i graficzne.

Istotną cechą modułu obsługi drukarki jest możliwość kolejkowania wydruków. Pozwala to operatorowi na zlecanie wielu wydruków bez oczekiwania na ich rzeczywisty wydruk. Moduł obsługi zapewnia, że będą one wszystkie kolejno zrealizowane. Program AS32 pozwala także na natychmiastowy wydruk zdarzeń związanych z alarmami procesowymi (wydruk alarmów na bieżąco jest deklarowany poprzez parametr Wydruk alarmów pliku konfiguracyjnego aplikacji: Architekt > Obszary i komputery > moduł Wydruk > zakładka Wydruk alarmów). Jeżeli drukarka nie jest zajęta, to moduł obsługi drukuje alarmy. Jeżeli jednak pojawi się jakieś inne zlecenie, to wydruk alarmów zostaje przerywany. Kolejne nadchodzące alarmy zostaną zapamiętane w buforze, a po zwolnieniu drukarki zostaną natychmiast wydrukowane. Pomiędzy poszczególnymi typami (zleceniami) wydruków automatycznie generowany jest wysuw strony.

Operator systemu posiada możliwość wpływania na pracę systemu wydruków poprzez specjalne okno obsługi, które uruchamiane jest komendą

NARZĘDZIA.OBSŁUGA_DRUKARKI z menu Okna Konstruktora lub Panelu Kontrolnego.

Okno obsługi drukarki przedstawia poniższy rysunek.

Rysunek: Okno obsługi drukarki.

Poszczególne pola kontrolne podają następujące informacje:

Aktualny Wydruk - w polu podany jest opis aktualnie wykonywanego wydruku;

Stan Kolejki Alarmów - pole używane w przypadku, gdy w systemie aplikacyjnym wykonywane jest drukowanie alarmów na bieżąco; pole to podaje stan bufora przechowującego opisy zdarzeń alarmowych; możliwe są następujące wartości:

• pusta - żaden alarm nie oczekuje na wydrukowanie; system nadąża na bieżąco z drukowaniem;

• używana- bufor jest częściowo zapełniony; sytuacja normalna jeżeli drukarka była zajęta innymi wydrukami lub nastąpił chwilowy napływ dużej ilości alarmów; system wdrukuje alarmy przy pierwszej nadarzającej się sposobności;

• pełna - bufor jest całkowicie zapełniony; przychodzące zdarzenie alarmowe powodują utratę informacji na wydruku; typowo taka sytuacja występuje wtedy, gdy drukarka była przez dłuższy czas wyłączona; drugą przyczyną może być wykonywanie innych długotrwałych wydruków; jeżeli zapełnianie bufora alarmów się powtarza, to celowe może okazać się zwiększenie rozmiaru bufora w pozycji Wydruk alarmów pliku konfiguracyjnego apliakcji;

Lista Oczekujących Wydruków - na tej liście pokazane są opisy wszystkich zleconych wydruków, w kolejności w jakiej będą drukowane.

Poniżej zostały podane typy wydruków wykonywanych w systemie Asix, wraz i ich opisami pojawiającymi się na liście wydruków:

alarmy bieżące - drukowanie alarmów w trybie natychmiastowym,

wydruk alarmów historycznych - drukowanie alarmów, które zostało zlecone przez operatora systemu na masce alarmów historycznych,

drukowanie raportu - wydruk utworzonego raportu,

wydruk graficzny okna - graficzny wydruk maski wizualizacyjnej zlecony komendą NARZĘDZIA.WYDRUK_GRAFICZNY z menu Okna Konstruktora,

wydruk graficzny ekranu - zrzut graficzny aktualnej zawartości ekranu wywołany przyciśnięciem kombinacji klawiszy Alt-F,

nazwa_pliku - wydruk dowolnego pliku, który został zainicjowany z okna obsługi drukarki.

Oprócz funkcji kontrolnych, okno obsługi drukarki posiada jeszcze możliwości sterowania prowadzeniem wydruków. Do tego celu służą klawisze umieszczone z prawej strony okna. Ich znaczenie jest następujące:

Usuń Alarmy - komenda powoduje wyczyszczenie bufora alarmów używanego podczas wydruku alarmów bieżących;

Usuń - komenda pozwalająca selektywnie skasować jeden z oczekujących wydruków; przed przyciśnięciem klawisza należy wybrać wydruk na liście zadań oczekujących;

Wszystkie - komenda pozwalająca na usunięcie wszystkich oczekujących wydruków oraz przerwanie zadania bieżącego;

Drukuj Plik - przyciśnięcie tego klawisza powoduje otwarcie okna, w którym operator może wybrać dowolny plik znajdujący się na dysku; plik zostanie wydrukowany na drukarce wybranej z listy zainstalowanych drukarek;

Koniec - zamknięcie okna obsługi.

Lista wydruków oczekujących dotyczy wszystkich wydruków wykonywanych przez program AS32 niezależnie od drukarki, dla której są przeznaczone. Pozycje są usuwane z listy w momencie przekazania ich do realizacji przez system Windows (mogą być one dodatkowo kolejkowane przed ich rzeczywistym wydrukowaniem).


10.3.1. Zrzut zawartości ekranu

Operator inicjuje zrzut poprzez przyciśnięcie klawisza ALT-F7. Powoduje to wyświetlenie poniższego okna dialogowego:

Rysunek: Okno wydruku ekranu.

W oknie tym operator powinien ustawić parametry, według których zrzut ma zostać wykonany:

  • obszar, którego operacja dotyczy; możliwy jest zrzut całego ekranu lub zrzut obszaru okna (maski), które było aktywne w momencie przyciśnięcia klawisza ALT-F7;

  • format zrzutu. Możliwe są poniższe typy formatu:

Mapa bitowa - format graficzny pliku typu BMP; zrzut w tym formacie może być wykonywany jedynie do pliku dyskowego;

Drukarka - zrzut przeznaczony do wydruku na drukarce;

  • port drukarki; możliwy jest wydruk na dowolnej drukarce zainstalowanej w systemie Windows XP / 2000 / NT 4.0 ; przy pierwszym użyciu proponowana jest domyślna drukarka systemowa.

W pliku konfiguracyjnym w parametrze Parametry zrzutu można zdefiniować parametry domyślne zrzutu. Powyższe okno będzie pojawiać się z ustawionymi wstępnie parametrami domyślnymi. Przed wykonaniem zrzutu operator może jednak zmienić parametry. W pozycji Automatyczny zrzut można zażądać, żeby zrzut był wykonywany natychmiast po przyciśnięciu klawisza ALT-F7. Zrzut zostanie zrealizowany zgodnie z ustawieniami domyślnymi, a w miejsce okna parametrów zostanie wyświetlone okno komunikatu informujące jedynie o tym, że zrzut jest wykonywany. Komunikat ten zostanie automatycznie usunięty po upływie około 1 sekundy. Poniżej pokazane jest przykładowe okno komunikatu. Możliwy jest też zrzut ekranu bez żadnej sygnalizacji.

Rysunek: Komunikat informujący o zrzucie ekranu.

W chwili, gdy parametry zostaną określone, następuje początek zrzutu. Na czas jego wykonywania zostaje wstrzymane odświeżanie masek wizualizacyjnych. Zakończenie zrzutu jest sygnalizowane sygnałem dźwiękowym, po którym system wraca do normalnego stanu.

Pliki zrzutu są umieszczane w kartotece roboczej programu, deklarowanej w parametrze Kartoteka robocza. Nazwy plików nadawane są według wzorca: ekran???.bmp dla zrzutów całego ekranu, okno???.bmp dla zrzutów aktywnego okna. W miejscu znaków ??? w nazwie pliku wstawiane są kolejne numery zrzutu.


10.4. Obsługa czasu

W Systemie Asix zmiana czasu systemowego odbywa się poprzez specjalne okno zmiany czasu. Okno to może być otworzone przy pomocy komendy OPCJE.ZMIANA_CZASU w Oknie Konstruktora i Panelu Kontrolnego, lub poprzez wykonanie akcji operatorskiej ZMIANA_CZASU.

Okno zmiany czasu prezentuje poniższy rysunek.

Rysunek: Okno zmiany czasu.

W polu Aktualny Czas pokazywany jest stale aktualizowany bieżący czas systemowy. W celu zmiany czasu, operator powinien w polu Nowy Czas wprowadzić nową wartość czasu i przycisnąć przycisk Ustaw.

Program AS32 pozwala na ograniczenie okresu czasu, o jaki może nastąpić jego jednorazowa modyfikacja. Okres ten definiowany jest w pliku inicjującym w parametrze Limit zmiany czasu (Architekt > Obszary i komputery > moduł Pozostałe > zakładka Pozostałe). Ograniczenie zmiany służy temu, aby nie nastąpiły przypadkowe duże zmiany czasu, które prowadzą do archiwizacji danych i alarmów z niepoprawnym czasem. Typowym ograniczeniem jest okres jednej godziny, który pozwala na bieżące korekty czasu oraz przejścia między czasem zimowym i letnim. Możliwa jest tez całkowita blokada zmiany czasu.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 10. Egzekutor - realizacja aplikacji > 10.4. Obsługa czasu > 10.4.1. Akcje operatorskie

10.4.1. Akcje operatorskie

ZMIANA_CZASU


10.5. Sekwencje demonstracyjne

Program AS32 udostępnia jeszcze jeden mechanizm służący do automatycznego odtwarzania zapamiętanych wcześniej operacji. Są to tak zwane sekwencje demonstracyjne, które przeznaczone są do użycia w wersjach pokazowych aplikacji. Pozwalają one na uruchomienie aplikacji, której działanie jest sterowane poprzez nagrane wcześniej przez projektanta systemu sekwencje ruchów myszki oraz przyciśnięć klawiszy klawiatury.

Ogólne zasady użycia sekwencji demonstracyjnych są zbliżone do zasad użycia makrooperacji. Poniżej opisane są cechy specyficzne sekwencji demonstracyjnych:

  • istnieje możliwość zdefiniowania tylko jednej sekwencji; jest ona zapamiętywana w pliku replayw.dem w kartotece programu AS;

  • sekwencje demonstracyjne mogą działać w trybie konstruktora i w trybie aplikacyjnym;

  • w procesie nagrywania i odtwarzania zachowane są zależności czasowe;

  • nagrywanie jest rozpoczynane komendą OPCJE.SEKWENCJA_DEMO.NAGRAJ z Okna Konstruktora lub Panelu Kontrolnego;

  • nagrywanie jest kończone klawiszem Alt-F12;

  • proces odtwarzania jest rozpoczynany komendą OPCJE.SEKWENCJA_DEMO.ODTWÓRZ z Okna Konstruktora lub Panelu Kontrolnego; istnieje możliwość automatycznej inicjacji odtwarzania w momencie startu aplikacji, poprzez odpowiednie zdefiniowanie opcji SEKWENCJA_DEMO w pliku asix.ini;

  • w normalnym trybie pracy użycie sekwencji demonstracyjnych jest zablokowane; mechanizm musi być specjalnie odblokowany w opcji SEKWENCJA_DEMO w pliku asix.ini;

Wykonanie sekwencji demonstracyjnej może być przerwane poprzez przyciśnięcie klawiszy Ctrl-Esc. Jeżeli sekwencja nie zostanie przerwana, to po jej zakończeniu zostanie automatycznie wznowione jej odgrywanie od początku. Z tego względu projektant musi kończyć nagrywanie sekwencji w sposób umożliwiający poprawne jej wznowienie (stan programu w momencie początku i końca nagrywania makra musi być w wystarczający sposób zgodny).


10.6. Mechanizm klawiatur ekranowych

Mechanizm klawiatur ekranowych (aktywny w trybie wykonawczym aplikacji) zapewnia operatorowi możliwość wprowadzania tekstów do pól edycyjnych okien dialogowych i pól edycyjnych obiektów LICZBA i NAPIS poprzez klawiaturę ekranową. Mechanizm stanowi wsparcie dla aplikacji pracujących na panelach z ekranem dotykowym.

Klawiatura jest uaktywniana po kliknięciu w obszarze pola lub obiektu.

Mechanizm klawiatur ekranowych uaktywniany jest przy pomocy parametru Klawiatura ekranowa określanego w:

Architekt > Obszary i komputery > moduł Maski > zakładka Klawiatura ekranowa

Istnieją dwa rodzaje klawiatur: klawiatura do edycji tekstu oraz klawiatura numeryczna wywoływana w momencie edytowania wartości obiektu LICZBA.

Rysunek:. Klawiatura ekranowa.

Rysunek: Klawiatura numeryczna.


10.7 Funkcja zapisu do schowka nazw zmiennych użytych w obiekcie

Funkcja zapisu do schowka nazw zmiennych umożliwia kopiowanie nazw zmiennych użytych w obiekcie na masce aplikacji. Zapamiętane zmienne mogą być następnie wklejone w oknie wykresu programu AsTrend.

UWAGA: Funkcja działa tylko w trybie wykonawczym maski.

Aby skopiować zmienną do schowka, należy na masce wskazać kursorem myszy właściwy obiekt i przycisnąć kombinację klawiszy Ctrl+C.


11. Tabele zmiennych

Tabele zmiennych pozwalają na łatwe tworzenie okien służących do przeglądania aktualnych wartości zmiennych Asmena. Tabele dostępne są z menu okna konstruktora lub w trybie aplikacyjnym przez użycie akcji operatorskiej TABELA. Zdefiniowanie tabeli odbywa się interaktywnie przez wybór opcji i parametrów.

Użycie tabel zmiennych możliwe jest pod warunkiem wcześniejszego zdefiniowania Bazy Definicji Zmiennych.

Tabele zmiennych umożliwiają wyświetlenie wartości analogowych zmiennych - takich jak teksty przypisane sygnałom dwustanowym.

WAŻNE: Szczegółowy opis sposobu projektowania tabel przy użyciu edytora tabel dostępnego z poziomu programu Architekt znajduje się w części „Architekt -Parametryzacja aplikacji”, w rozdziale 4.24 Edytor tabeli zmiennych .


11.1. Otwarcie tabeli

W trybie aplikacyjnym utworzone wcześniej tabele zmiennych mogą być otwierane przy użyciu akcji operatorskiej TABELA.

TABela nazwa[, tryb[, x[, y], s]]]]

gdzie:

nazwa - nazwa tabeli;

tryb - tryb otwarcia:

Otwórz - otwarcie tabeli;

Wymiana - otwarcie tabeli połączone z zamknięciem wcześniej otwartych tabel na tym samym monitorze;

Zamknij - zamknięcie tabeli (jeżeli nazwą jest *, to zamyka wszystkie tabele;

x - współrzędna x okna tabeli (domyślnie -1 - położenie z definicji tabeli);

y - współrzędna y okna tabeli (domyślnie -1 - położenie z definicji tabeli);

s - numer monitora (domyślnie -1 - monitor wynika ze współrzędnych xy).

W menu okna konstruktora dostępna jest komenda TABELA. Służy ona do otwarcia pustej tabeli zmiennych.


11.2. Opis zawartości pliku definicji tabeli

Dane opisujące tabelę pamiętane są w plikach tekstowych o rozszerzeniu *.TBL, posiadających strukturę plików .INI systemu Windows.

Sekcja [TABELA]:

TYTUŁ

POZYCJA

SZEROKOŚĆ

WYSOKOŚĆ

LICZBAKOLUMN

NRKOLUMNYWARTOŚCI

LICZBAWIERSZY

CZCIONKA

PRZESUNIĘCIE

FORMAT

BELKA

SIATKA

PASKI

BŁĄDFORMAT

Sekcja [KOLORY]:

TŁO

CZCIONKA

MIGOTANIE

PASEKTŁO

PASEKCZCIONKA

PASEKMIGOTANIE

LIMITHHTŁO

LIMITHHCZCIONKA

LIMITHHMIGOTANIE

BŁĄDTŁO

BŁĄDCZCIONKA

BŁĄDMIGOTANIE

Sekcja [KOLUMNY]:

<nr_kolumny>

Sekcja [WIERSZE]:

<nr_wiersza>

PRZYKŁAD

Treść przykładowego pliku definicji tabeli *.TBL

[Tabela]

Tytuł=Przepływ pary i przepływ spalin - Kocioł nr 15

Pozycja=60,25

LiczbaKolumn=4

LiczbaWierszy=31

NrKolumnyWartości=3

Czcionka=MS Sans Serif,13,[],EastEurope

Format=%7.2f

Belka=1

Siatka=0

Paski=1

BłądFormat=

Szerokość=-1

Wysokość=-1

Przesunięcie=30

[Kolory]

Tło=192,192,192

Czcionka=0,0,0

PasekTło=175,175,175

LimitHHTło=255,0,0

LimitHHCzcionka=255,255,255

LimitHHMigotanie=1

LimitHTło=255,0,0

LimitHCzcionka=255,255,0

LimitLTło=0,0,160

LimitLCzcionka=255,255,0

LimitLLTło=0,0,160

LimitLLCzcionka=255,255,255

LimitLLMigotanie=1

BłądTło=255,255,191

BłądCzcionka=255,0,0

Migotanie=0

PasekCzcionka=0,0,0

PasekMigotanie=0

LimitHHTłoDomyślne=0

LimitHTłoDomyślne=0

LimitHMigotanie=0

LimitLTłoDomyślne=0

LimitLMigotanie=0

LimitLLTłoDomyślne=0

BłądTłoDomyślne=0

BłądMigotanie=0

[Kolumny]

1=Nazwa,15

2=Opis,30

3=Wartość,7

4=Jednostka,7

[Wiersze]

1=K15_SPV_Para

2=K15_CRR_Para

3=K15_PVL_Para

4=K15_STA_Para

5=K15_Para

6=K15_LV_Para

7=K15_TRN_Para

8=

9=K15_CLSS_Para

10=K15_IPVL_Para

11=K15_INTG_Para

12=K15_ILV_Para

13=K15_DAVG_Para

14=K15_DTRN_Para

15=K15_MAVG_Para

16=

17=K15_SPV_Vss

18=K15_CRR_Vss

19=K15_PVL_Vss

20=K15_STA_Vss

21=K15_Vss

22=K15_LV_Vss

23=K15_TRN_Vss

24=

25=K15_CLSS_Vss

26=K15_IPVL_Vss

27=K15_INTG_Vss

28=K15_ILV_Vss

29=K15_DAVG_Vss

30=K15_DTRN_Vss

31=K15_MAVG_Vss

Sekcja [TABELA] w pliku *.tbl , określa parametry globalne dla okna tabeli zmiennych Asmena.

TYTUŁ= <tekst>

Znaczenie - określenie tytułu wyświetlanej tabeli.

Zdefiniowanie - ręczne.

POZYCJA= x, y

Znaczenie - pozycja okna tabeli na ekranie podana jako współrzędne lewego górnego narożnika.

Zdefiniowanie - automatyczne.

SZEROKOŚĆ = -1|<liczba>

Znaczenie - szerokość okna tabeli podana w pikselach. W przypadku użycia wartości -1 następuje automatyczne dobranie szerokości w oparciu o parametry czcionki, szerokości kolumn oraz parametry okna.

Zdefiniowanie - automatyczne.

WYSOKOŚĆ = -1|<liczba>

Znaczenie - wysokość okna tabeli podana w pikselach. W przypadku użycia wartości -1 następuje automatyczne dobranie wysokości w oparciu o parametry czcionki, liczbę wierszy oraz parametry okna.

Zdefiniowanie - automatyczne.

LICZBAKOLUMN = <liczba>

Znaczenie - deklaracja ilości wyświetlanych kolumn tabeli. W obecnej wersji liczba kolumn jest stała i wynosi 4.

Zdefiniowanie - automatyczne.

NRKOLUMNYWARTOŚCI = <liczba>

Znaczenie - podaje numer kolumny, w której wyświetlana ma być wartość zmiennej. W obecnej wersji dozwolona jest jedynie wartość 3.

Zdefiniowanie - automatyczne.

LICZBAWIERSZY = <liczba>

Znaczenie - ilość wierszy wyświetlanej tabeli

Zdefiniowanie - automatyczne.

CZCIONKA = <nazwa>, <rozmiar>, [<atrybuty czcionki>], <strona kodowa>

Znaczenie - zdefiniowanie nazwy i parametrów czcionki do wypełnienia tabeli.

Zdefiniowanie - automatyczne.

PRZESUNIĘCIE = <liczba>

Znaczenie - deklaracja przesunięcia w % tekstu względem gabarytów pozycji tabeli.

Wartość domyślna - 30 %.

Zdefiniowanie - automatyczne.

FORMAT = <format>

Znaczenie - deklaracja formatu wyświetlania wartości zmiennej, zgodny z formatem wyświetlania wartości liczbowych używanym w obiektach systemu Asix. Używany jest w przypadku braku formatu prezentacji wartości pomiaru w Bazie Zmiennych.

Zdefiniowanie - automatyczne.

BELKA = 0|1

Znaczenie - pozycja określająca czy belka opisu okna tabeli ma być widoczna.

Zdefiniowanie - automatyczne.

SIATKA = 0|1

Znaczenie - pozycja określająca czy wewnątrz okna tabeli ma być wyświetlana siatka oddzielająca pozycje tabeli.

Zdefiniowanie - automatyczne.

PASKI = 0|1

Znaczenie - pozycja określająca czy kolejne wiersze tabeli mają być wyświetlane naprzemiennie w kolorach tła i paska. Użycie tej opcji znacznie poprawia czytelność zawartości tabeli.

Zdefiniowanie - automatyczne.

BŁĄDFORMAT = <format>

Znaczenie - format wyświetlania wartości zmiennej stosowany w przypadku otrzymania wartości opatrzonej statusem błędu.

Zdefiniowanie - automatyczne.

PRZYKŁAD

[Tabela]

Tytuł=Przepływ pary i przepływ spalin - Kocioł nr 15

Pozycja=60,25

LiczbaKolumn=4

LiczbaWierszy=31

NrKolumnyWartości=3

Czcionka=MS Sans Serif,13,[],EastEurope

Format=%7.2f

Belka=1

Siatka=0

Paski=1

BłądFormat=

Szerokość=-1

Wysokość=-1

Przesunięcie=30

Sekcja [KOLORY] w pliku *.tbl, określa kolorystykę wyświetlania wszystkich elementów tabeli zmiennych Asmena. Każdy kolor jest określony poprzez podanie jego trzech składowych RGB. Konwencja definicji koloru jest zgodna z konwencją zastosowaną w plikach inicjujących programu AS.

TŁO = R, G, B

Znaczenie - deklaracja koloru tła tabeli.

Zdefiniowanie - automatyczne.

CZCIONKA = R, G, B

Znaczenie - deklaracja koloru czcionki tabeli.

Zdefiniowanie - automatyczne.

MIGOTANIE = 0|1

Znaczenie - deklaracja użycia atrybutu migotania czcionki tabeli.

Zdefiniowanie - automatyczne.

PASEKTŁO = R, G, B

Znaczenie - deklaracja alternatywnego koloru tła tabeli.

Zdefiniowanie - automatyczne.

PASEKCZCIONKA = R, G, B

Znaczenie - deklaracja koloru czcionki w pasku alternatywnego koloru tła tabeli.

Zdefiniowanie - automatyczne.

PASEKMIGOTANIE = 0|1

Znaczenie - deklaracja atrybutu migotania alternatywnego koloru czcionki tabeli.

Zdefiniowanie - automatyczne.

LIMITHHTŁO = R, G, B

LIMITHTŁO = R, G, B

LIMITLTŁO = R, G, B

LIMITLLTŁO = R, G, B

Znaczenie - deklaracja koloru tła tabeli dla przekroczeń limitów.

Zdefiniowanie - automatyczne.

LIMITHHCZCIONKA = R, G, B

LIMITHCZCIONKA = R, G, B

LIMITLCZCIONKA = R, G, B

LIMITLLCZCIONKA = R, G, B

Znaczenie - deklaracja koloru czcionki tabeli dla przekroczeń limitów.

Zdefiniowanie - automatyczne.

LIMITHHMIGOTANIE = 0|1

LIMITHMIGOTANIE = 0|1

LIMITLMIGOTANIE = 0|1

LIMITLLMIGOTANIE = 0|1

Znaczenie - deklaracja atrybutu migotania koloru czcionki tabeli dla przekroczeń limitów.

Zdefiniowanie - automatyczne.

BŁĄDTŁO = R, G, B

Znaczenie - deklaracja koloru tła tabeli dla pomiarów ze statusem błędu.

Zdefiniowanie - automatyczne.

BŁĄDCZCIONKA = R, G, B

Znaczenie - deklaracja koloru czcionki tabeli dla pomiarów z błędem.

Zdefiniowanie - automatyczne.

BŁĄDMIGOTANIE = 0|1

Znaczenie - deklaracja atrybutu migotania koloru tła tabeli dla pomiarów z błędem.

Zdefiniowanie - automatyczne.

PRZYKŁAD

[Kolory]

Tło=192,192,192

Czcionka=0,0,0

PasekTło=175,175,175

LimitHHTło=255,0,0

LimitHHCzcionka=255,255,255

LimitHHMigotanie=1

LimitHTło=255,0,0

LimitHCzcionka=255,255,0

LimitLTło=0,0,160

LimitLCzcionka=255,255,0

LimitLLTło=0,0,160

LimitLLCzcionka=255,255,255

LimitLLMigotanie=1

BłądTło=255,255,191

BłądCzcionka=255,0,0

Migotanie=0

PasekCzcionka=0,0,0

PasekMigotanie=0

LimitHHTłoDomyślne=0

LimitHTłoDomyślne=0

LimitHMigotanie=0

LimitLTłoDomyślne=0

LimitLMigotanie=0

LimitLLTłoDomyślne=0

BłądTłoDomyślne=0

BłądMigotanie=0

Sekcja [KOLUMNY] określa nazwę i szerokość (w znakach) kolumn tabeli zmiennych Asmena.

<nr_kolumny> = <nazwa>, <szerokość>

Znaczenie - określenie nagłówka kolumny i jej szerokości.

Zdefiniowanie - ręczne.

PRZYKŁAD

[Kolumny]

1=Nazwa,15

2=Opis,30

3=Wartość,7

4=Jednostka,7

Sekcja [WIERSZE] w pliku *.tbl, określa zawartości wierszy tabeli zmiennych Asmena (patrz: Tabele zmiennych). Podanie nazwy zmiennej umożliwia pobranie z Bazy Definicji Zmiennych informacji o danej zmiennej, takich jak: opis, jednostka, format wyświetlania, parametry limitów. W oparciu o nazwę zmiennej za pomocą programu Asmen pobierane są również aktualne wartości pomiarowe. Można zaniechać podania nazwy zmiennej, co powoduje umieszczenie pustego wiersza w tabeli.

<nr_wiersza> = [<nazwa zmiennej>]

Znaczenie - wskazanie zmiennej w Bazie Definicji Zmiennych. Informacje o wskazanej zmiennej będą wyświetlone w wierszu o wyspecyfikowanym numerze.

Zdefiniowanie - ręczne.

PRZYKŁAD

[Wiersze]

1=K15_SPV_Para

2=K15_CRR_Para

3=K15_PVL_Para

4=K15_STA_Para

5=K15_Para

6=K15_LV_Para

7=K15_TRN_Para

8=

9=K15_CLSS_Para

10=K15_IPVL_Para

11=K15_INTG_Para

12=K15_ILV_Para

13=K15_DAVG_Para

14=K15_DTRN_Para

15=K15_MAVG_Para

16=

17=K15_SPV_Vss

18=K15_CRR_Vss

19=K15_PVL_Vss

20=K15_STA_Vss

21=K15_Vss

22=K15_LV_Vss

23=K15_TRN_Vss

24=

25=K15_CLSS_Vss

26=K15_IPVL_Vss

27=K15_INTG_Vss

28=K15_ILV_Vss

29=K15_DAVG_Vss

30=K15_DTRN_Vss

31=K15_MAVG_Vss


11.3. Interfejs użytkownika

Tabela zmiennych ma postać okna prezentowanego na poniższym rysunku.

Rysunek: Tabela zmiennych.

Okno składa się z czterech kolumn zawierających: nazwę zmiennej, opis zmiennej, wartość pomiarową oraz jednostkę. Nazwa specyfikowana jest przez projektanta, opis i jednostka pobierane są z bazy zmiennych, a wartości na bieżąco pozyskiwane są z modułu Asmen. W nagłówku okna tabeli znajduje się jej tytuł.

W celu wybrania zmiennej do prezentacji należy w wierszu tabeli dwukrotnie kliknąć przyciskiem myszy, co spowoduje otwarcie okna wyboru zmiennych. Okno listy zmiennych można również otworzyć z menu kontekstowego tabeli.

Rysunek: Okno wyboru zmiennych.

Menu kontekstowe tabeli, uaktywniane prawym klawiszem myszy, może mieć dwie postaci, zależne od trybu pracy programu AS: tryb wykonywania aplikacji oraz tryb konstruktora.

Rysunek: Menu kontekstowe tabeli.

W trybie wykonywania aplikacji menu kontekstowe umożliwia wymianę zmiennej w wierszu tabeli (za pomocą okna listy zmiennych), usunięcie zmiennej z wiersza tabeli, zapisanie dokonanych modyfikacji oraz zakończenie działania tabeli.

W trybie konstruktora menu kontekstowe umożliwia dodatkowo parametryzację okna tabeli, wyświetlenie informacji szczegółowej o używanej czcionce, otwarcie innego okna tabeli oraz zapisanie aktualnego okna pod inną nazwą.

Parametryzacja okna tabeli realizowana jest za pomocą poniższego okna.

Rysunek: Okno parametryzacji tabeli.

Pozwala ono na modyfikację kolejno wymienionych parametrów:

  • Tytuł tabeli;

  • Pozycja na ekranie;

  • Szerokość okna; wartość -1 oznacza, że szerokość okna zostanie określona automatycznie;

  • Wysokość okna; wartość -1 oznacza, że wysokość okna zostanie określona automatycznie;

  • Liczba kolumn tabeli; w obecnej wersji wartość stała 4;

  • Liczba wierszy tabeli;

  • Przesunięcie znaku;

  • Domyślny format wyświetlania wartości;

  • Format wyświetlania wartości błędnych;

  • Opcje wyświetlania nagłówka okna, pasków i siatki;

  • Czcionka;

  • Kolorystyka wyświetlania.

W ramce Czcionka wyświetlany jest aktualną czcionką przykładowy tekst. Za pomocą menu kontekstowego można zmienić czcionkę lub jej atrybuty. Możliwe jest wyświetlenie okna wyboru czcionki dla wszystkich zarejestrowanych w systemie czcionek lub tylko dla czcionek o stałej szerokości.

Po naciśnięciu przycisku Kolorystyka Tabeli pojawia się okno pozwalające na ustawienie kolorów wszystkich elementów okna tabeli. Kolejne ramki zawierają tekst testowy wyświetlony zgodnie z ustawieniami odpowiednio dla:

  • Limitów górnych krytycznych (HH);

  • Limitów górnych (H);

  • Podstawowego tekstu;

  • Paska tabeli;

  • Limitów dolnych (L);

  • Limitów dolnych krytycznych (LL);

  • Błędnych wartości pomiarowych.

Rysunek: Okno kolorystyki tabeli.

Za pomocą menu kontekstowych poszczególnych ramek istnieje możliwość zamiany następujących atrybutów:

  • kolor tła; dla limitów i błędów można użyć tła domyślnego, tzn. koloru tła tekstu podstawowego lub koloru paska;

  • kolor czcionki;

  • zadeklarowanie dla wartości atrybutu migotania.

W menu kontekstowym tabeli (tryb konstruktora) możliwe jest wyświetlenia okna zawierającego szczegółowe informacje o wybranej czcionce. Okno to jest aktywne aż do momentu zamknięcia przez operatora.

Rysunek: Okno informacji o czcionce.


11.4. Sygnały dwustanowe

Aby Tabele zmiennych pokazywały teksty odpowiednie do wartości zmiennych, należy dla sygnałów, które mają mieć wyświetlany tekst w zależności od wartości, w polu format umieścić odpowiedni łańcuch formatujący zaczynający się od znaków %@

Przykładowy łańcuch formatujący:

%@ 0="WYŁ" ; 1="ZAŁ"

- dla wartości zmiennej = 0, pojawi się tekst WYŁ

- dla wartości zmiennej = 1, pojawi się tekst ZAŁ

Funkcja przeliczająca tych zmiennych musi zwracać w wyniku liczbę całkowitą, np. NIC, NIC_BYTE, NIC_INT.

W pliku schemat.txt opisującym Bazę Zmiennych można zmienić rozmiar pola Format, stosownie do potrzeb biorąc pod uwagą wielkość najdłuższego łańcucha formatującego.


12. System alarmów

System Asix posiada wbudowany elastyczny, konfigurowalny system obsługi alarmów, który pozwala na pełne zaspokojenie potrzeb związanych z kompleksową obsługą sytuacji awaryjnych i zdarzeń w procesie technologicznym. Podstawowe cechy tego systemu to:

  • długoterminowy log historii alarmów ograniczony tylko pojemnością dysku,

  • osobny log alarmów aktywnych,

  • automatyczne odtworzenie stanu alarmów po restarcie systemu,

  • możliwość zdefiniowania 65535 różnych alarmów,

  • podział alarmów na 5 typów:

  • systemowe,

  • komunikaty,

  • ostrzeżenia,

  • alarmy,

  • alarmy ważne;

  • podział zdefiniowanych alarmów na dowolną ilość grup,

  • sygnalizacja dźwiękowa pojawienia się alarmu,

  • milisekundowa rozdzielczość alarmów,

  • możliwość drukowania alarmów na bieżąco lub za zadany okres czasu,

  • dwa typy masek służących do prezentacji stanu alarmów:

  • maska alarmów aktywnych,

  • maska alarmów historycznych;

  • możliwość selekcji pokazywanych alarmów według następujących kryteriów:

  • czas,

  • tekst,

  • typ,

  • status,

  • grupa,

  • numery;

  • zapis stanu selekcji alarmów do pliku oraz odczyt z pliku i ustawianie selekcji alarmów zgodnie z jego zawartością,

  • możliwość wykluczania wybranych alarmów z obsługi,

  • zapis stanu wykluczeń do pliku oraz odczyt z pliku i ustawianie stanu wykluczeń alarmów zgodnie z jego zawartością,

  • możliwość czasowego filtrowania wybranych alarmów,

  • mechanizm potwierdzania alarmów,

  • możliwość wstawiania w teksty opisujące alarm wartości zmiennych procesowych,

  • możliwość powiązania alarmów z maskami schematowymi,

  • strategie rozpoznania alarmów:

  • mapa bitów alarmowych,

  • test przekroczenia limitów;

  • praca kilku stanowisk operatorskich w sposób zsynchronizowany:

  • uzgadnianie stanu alarmów w momencie restartu stanowiska,

  • potwierdzenie alarmu przesyłanego do wszystkich stanowisk,

  • synchronizacja wykluczeń i filtrów;

  • przeglądanie alarmów historycznych pochodzących z innych, połączonych sieciowo stanowisk,

  • możliwość tworzenia kopii bezpieczeństwa plików logu historycznego,

  • współpraca z PLC w zakresie wykluczania i sterowania sygnalizacją dźwiękową.

Ogólnie system alarmów można podzielić na dwie części: jądro systemu, które odpowiedzialne jest za wykrywanie, zapamiętywanie i definicje alarmów, oraz cześć wizualizacyjną, którą stanowią dwa typy masek alarmowych (alarmów aktywnych i historycznych).


12.1. Konfiguracja jądra systemu alarmów

Konfiguracja jądra systemu opiera się na odpowiednim zdefiniowaniu pozycji w pliku inicjującym aplikacji oraz na utworzeniu plików tekstowych zawierających dodatkowe informacje. Większość parametrów dotyczących alarmów definiowanych jest przy użyciu programu Architekt (moduł System alarmów). Dodatkowe pliki tekstowe to: pliki definicji alarmów, pliki definicji grup, pliki definicji limitów.

Bieżący stan oraz historia alarmów przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowane iine rozwiązanie). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można też ograniczyć ilość pamiętanych dni poprzez odpowiednie ustawienie parametru Okres przechowywania plików alarmów.


12.1.1. Plik definicji alarmów

Każdy alarm, który ma być używany w systemie Asix, musi być uprzednio zdefiniowany. Definicje alarmów standardowo znajdują się w pliku tekstowym o rozszerzeniu .adf (lub pliku tekstowym alarm.def). Możliwe jest użycie pliku o innej nazwie poprzez zdefiniowanie parametru Nazwy plików, w których zdefiniowane są alarmy (Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów przy założeniu, że tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów). Opisy alarmów mogą się też znajdować w kilku plikach definicji. Wewnętrznie alarmy identyfikowane są przez numer. Można zdefiniować 65535 różnych alarmów. Nie istnieje konieczność sekwencyjnego numerowania alarmów. Na przykład, numeracja jednej grupy alarmów rozpoczyna się od numeru 1000, a drugiej (o innym pochodzeniu) od numeru 30000. Należy pamiętać o tym, że zmiana numeracji alarmów w już działającym systemie powoduje konieczność skasowania plików archiwalnych.

Każdemu alarmowi nadawany jest jeden z pięciu dostępnych typów (w zasadzie czterech, ponieważ typ alarmów systemowych dotyczy wewnętrznego stanu oprogramowania systemu Asix i nie może być stosowany dla alarmów związanych ze stanem kontrolowanego procesu). Typy alarmów powodują, że alarmy wyświetlane są na maskach alarmowych w różnych kolorach. Generowane są też różne sygnały dźwiękowe w momencie pojawiania się alarmów. Typy alarmów używane są też jako jedno z kryteriów selekcji.

Z każdym alarmem związany jest tekst, który wyświetlany jest na maskach alarmów oraz drukowany na drukarce. Możliwe jest powiązanie z alarmem dwóch różnych tekstów, jeden używany w momencie pojawienia się alarmu, drugi w momencie wykrycia zaniku alarmu. W tekście alarmu można umieszczać znaki formatujące w konwencji funkcji sprintf języka C. Pozwala to na umieszczanie w opisie alarmów wartości parametrów związanych z wykrytym alarmem. Wymaga to jednak, aby strategia rozpoznająca alarm przekazywała wraz z numerem alarmu te dodatkowe informacje. Aktualnie tylko strategia limitów potrafi przekazać wartość zmiennej i ograniczenia w momentach pojawienia się i zaniku alarmu. W tekście alarmu mogą pojawić się znaki formatujące (typu %d, %f, %4.1f), których użycie spowoduje wstawienie w treść alarmu wartości sterowanej zmiennej.

Od wersji 4.04.001 systemu Asix rozszerzono formatowanie tekstów alarmów - dodana została możliwość podania dwóch formatów %s. Dotychczas można było podawać tylko jeden znacznik %s i nie można było wtedy używać innych znaczników. Działanie polegało na wstawieniu maksymalnie 7-znakowego tekstu w miejscu znacznika. Od wersji 4.04.001 znacznik %s może być łączony z innym znacznikiem (%s lub każdym innym np. %f) w dowolnej kolejności. Wstawiany tekst(y) jest wtedy maksymalnie 3-znakowy. Pojedynczy znacznik %s działa jak dotychczas. Ażeby opisany mechanizm działał właściwie, potrzebna jest oczywiście strategia alarmowa, która przekazuje do logu alarmów odpowiednie informacje - w praktyce: alarm zgłaszany bezpośrednio przez drajwer komunikacyjny lub skrypt użytkownika.

System alarmów pozwala na podzielenie wszystkich zdefiniowanych alarmów na dowolną ilość grup. Podział na grupy używany jest przez jedno z kryteriów selekcji alarmów. W definicji alarmów należy posługiwać się 4-znakowym identyfikatorem grupy. Dodatkowo, w pliku definicji grup, należy zdefiniować pełne nazwy grup, które będą wyświetlane w oknie selekcji alarmów. Operator systemu nie musi znać sztucznych identyfikatorów grup, dokonuje on wyboru z listy tekstów opisujących zdefiniowane grupy.

Wyjątek stanowi tworzona automatycznie grupa alarmów, do której należą wszystkie wewnętrzne zdarzenia programu AS - alarmy numer 0. Pozwala to na wybór tych alarmów do wyświetlania poprzez kryterium grupy. W opisywanym dalej oknie kryterium selekcji alarmów, w sekcji grupy należy zaznaczyć grupę o nazwie Zdarzenia systemu asix.

Istnieje również możliwość powiązania alarmów z maskami procesowymi. w definicji alarmów podaje się nazwę maski stowarzyszonej. Dla tak zdefiniowanego alarmu operator systemu może poprzez wskazanie alarmu na masce alarmów spowodować natychmiastowe przejście do maski stowarzyszonej, pokazującej fragment instalacji, którego alarm dotyczy.

Plik definicji alarmów jest plikiem tekstowym. Zawartość pliku składa się z linii, z których każda opisuje jeden alarm. Linie puste są ignorowane. Pojedynczy opis składa się z pól oddzielonych znakiem przecinka. Spacje początkowe i końcowe w ramach każdego pola są ignorowane. Wszystkie pola mają wartości domyślne. Jeżeli pole nie jest ustawiane, to należy wstawić tylko znak przecinka. Jeżeli nie są ustawiane wszystkie pola aż do końca linii, to znaki przecinka można też pominąć. Maksymalna długość linii wynosi 200 znaków.

Struktura linii opisującej alarm jest następująca:

[numer_alarmu],[typ_alarmu],[tekst_początku_alarmu],[tekst_końca_alarmu],

[identyfikator_grupy], [nazwa_maski],[DRUKUJ|NIE_DRUKUJ]

gdzie:

numer alarmu - pominięcie oznacza definicję alarmu o następnym numerze w stosunku do alarmu poprzedniego (pierwszy alarm w pliku otrzymuje domyślnie numer 1);

typ alarmu - określenie typu alarmów; teksty używane do określenia typu to: SYSTEMOWY, KOMUNIKAT, OSTRZEŻENIE, ALARM, WAŻNY, IGNOROWANY; wystarczające jest podanie 2 pierwszych liter; domyślnie przyjmowany jest typ ALARM;

Typ IGNOROWANY pozwala na wyłączenie z obsługi, na etapie projektowania, niektórych alarmów. (na przykład, ignorowanie niektórych pozycji w mapie alarmów strategii bitowej);

tekst początku - tekst wyświetlany w momencie wykrycia alarmu;

tekst końca - tekst wyświetlany dla alarmów, które zostały zakończone; brak podania tego tekstu oznacza, że ma być używany tekst jak dla początku alarmu;

identyfikator grupy - 4-znakowy identyfikator grupy, do której alarm należy;

nazwa maski - nazwa maski sugerowanej;

[DRUKUJ|NIE_DRUKUJ] - zezwolenie|blokada wydruku liniowego alarmów (na bieżąco).


12.1.2. Plik definicji grup

Plik definicji grup alarmów jest plikiem tekstowym. Stosują się do niego te same zasady co dla pliku definicji alarmów. Definicje grup alarmów standardowo znajdują się w pliku o rozszerzeniu .gdf (lub w pliku tekstowym group.def). Możliwe jest użycie pliku (plików) o innej nazwie poprzez zdefiniowanie parametru Nazwy plików, w których zdefiniowane są grupy alarmów (Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów - grupy przy założeniu, ze tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów). Struktura linii opisującej grupę alarmów jest następująca:

identyfikator_grupy,[opis_grupy], [DRUKUJ|NIE_DRUKUJ]

gdzie:

identyfikator grupy - maksymalnie 4-znakowy identyfikator grupy, służący do identyfikacji grup w pliku definiującym alarmy;

opis grupy - dowolny tekst opisujący grupę; tekst ten będzie wyświetlany w liście grup okna selekcji alarmów; brak tekstu spowoduje użycie w liście wyboru identyfikatora grupy;

[DRUKUJ|NIE_DRUKUJ] - zezwolenie|blokada wydruku liniowego alarmów (na bieżąco) dla danej grupy.


12.1.3. Kontrola zbiorczego stanu grup alarmów

Mechanizm kontroli zbiorczego stanu grup alarmów pozwala na wyświetlenie stanu aktywności alarmów należących do wspólnej grupy. Włączenie mechanizmu dla wybranej grupy polega na zdefiniowaniu w kanale typu NONE zmiennej o nazwie tworzonej według zasady:

__AGR_identyfikatorgrupy__

Identyfikator grupy powinien być zgodny z zadeklarowanym w pliku definicji grup.

Jeżeli zmienna kontrolna grupy zostanie utworzona, to system alarmów automatycznie odświeża jej wartość według zasady:

- wartość 0 oznacza brak aktywnych alarmów w grupie,

- wartość 1 oznacza, że w grupie są aktywne alarmy, ale wszystkie są potwierdzone,

- wartość 2 oznacza, że w grupie jest co najmniej jeden niepotwierdzony aktywny alarm.

Zmienną kontrolną grupy można użyć w innych obiektach do określania atrybutów wyświetlania.


12.1.4. Wybór alarmów drukowanych w trybie natychmiastowym

Deklaracji, czy alarm ma być drukowany, dokonuje się na dwa sposoby:

  • w definicji grupy alarmów można dodać parametr DRUKUJ, który oznacza, że wszystkie alarmy z tej grupy mają być drukowane; brak parametru (lub NIE_DRUKUJ) oznacza, że grupa nie jest drukowana;

  • na końcu indywidualnej definicji alarmu można dodać parametr DRUKUJ lub NIE_DRUKUJ; indywidualna specyfikacja ma pierwszeństwo przed specyfikacją w grupie; brak parametru oznacza akceptację ustawienia grupy lub brak wydruku dla alarmów bezgrupowych.

Jeżeli nigdzie nie zostaną użyte jawne specyfikacje wydruku, to zakłada się, że wszystkie alarmy mają zezwolenie na wydruk.

Parametr Drukuj zdarzenia systemowe definiowany w:

Architekt > Obszary i komputery > moduł Wydruk > zakładka Wydruk alarmów

specyfikuje, czy należy drukować zdarzenia systemowe.


12.1.5. Strategie rozpoznawania alarmów

Strategia bitowa rozpoznawania alarmów

Strategia limitów rozpoznawania alarmów

Przykład

Strategia aktywna rozpoznawania alarmów

Strategia buforowa rozpoznawania alarmów

Przykład

Strategia alarmów OPC

Przykład

Format pliku tłumaczenia warunków OPC na alarmy w systemie Asix

Przykłady

Oprócz zdefiniowania alarmów konieczne jest jeszcze określenie sposobu wykrywania alarmów. W systemie Asix dostępnych jest pięć strategii rozpoznawania alarmów.

Strategia bitowa polega na sprawdzaniu stanu bitów w mapie bitowej alarmów, tworzonej przez oprogramowanie sterownika kontrolującego proces.

Strategia limitów polega na okresowym sprawdzaniu zgodności wartości wybranych zmiennych procesowych z podanymi limitami.

Strategia aktywna opiera się na wymianie ze sterownikiem listy alarmów ułożonych przezeń chronologicznie i z rozdzielczością czasową lepszą niż 1 s.

Strategia buforowa alarmów pozwala na wykrywanie alarmów z rozdzielczością milisekundową i nadawanie im stempla czasu przez sterownik dokładnie w momencie pojawienia się zdarzenia.

Strategia alarmów OPC umożliwia przesyłanie danych o alarmach z serwera alarmów OPC (ang. OPC Alarm and Event Server) do systemu Asix z wykorzystaniem drajwera alarmów OPC (który służy jako klient dla dowolnego serwera alarmów OPC).

Strategia bitowa rozpoznawania alarmów

Strategia bitowa parametryzowana jest poprzez odpowiednio zdefiniowane pozycje w module System alarmów programu Architekt. Możliwa jest jednoczesna obsługa kilku map bitowych alarmów, z których każda definiowana jest w osobnej pozycji. Dwa podstawowe parametry mapy bitowej to nazwa zmiennej Asmena służącej do odczytu mapy ze sterownika oraz numer pierwszego alarmu w mapie. Należy zapewnić zgodność tego numeru z uporządkowaniem alarmów w pliku definicji. Każdemu następnemu bitowi w mapie odpowiada numer alarmu powiększony o jeden. Jeżeli bit w mapie alarmów jest równy 1, to oznacza to, że odpowiadający mu alarm jest aktywny. Jeżeli jest równy 0, to uznaje się, że alarm jest nieaktywny. Ilość alarmów znajdujących się na pojedynczej mapie wynika z rozmiaru zmiennej procesowej Asmena służącej do odczytu mapy.

Patrz: część „Architekt - Parametryzacja aplikacji”, rozdz. 4.9 Konfiguracja systemu alarmów .

Strategia limitów rozpoznawania alarmów

Strategia limitów parametryzowana jest poprzez odpowiednie zdefiniowanie pozycji w module System alarmów programu Architekt oraz stworzenie pliku (plików) tekstowego zawierającego opisy używanych limitów. Strategia limitów opiera się na ciągłym monitorowaniu wartości zmiennych procesowych i porównywaniu ich z zadanymi ograniczeniami. Nie jest wymagana żadna specjalna pomoc ze strony oprogramowania sterownika. Istnieje możliwość użycia jednego z sześciu typów porównań. Porównywać można wartość zmiennej procesowej do z góry ustalonej wartości liczbowej limitu lub też wartości dwóch różnych zmiennych procesowych. Zasadniczo, strategia limitów posługuje się zmiennymi analogowymi. Można jednak, przy pomocy warunków typu "=" i "<>" (równe, różne), weryfikować stan zmiennych binarnych.

Plik opisu limitów alarmowych jest plikiem tekstowym. Stosują się do niego te same zasady co dla pliku definicji alarmów. Standardową nazwą jest limits.def. Struktura linii opisującej limit alarmowy jest następująca:

[numer_alarmu],nazwa_zmiennej,warunek,ograniczenie

gdzie:

numer alarmu - pominięcie oznacza nadanie następnego numeru w stosunku do alarmu poprzedniego (alarm pierwszego limitu w pliku domyślnie otrzymuje numer 1);

nazwa zmiennej - nazwa zmiennej procesowej Asmena, której wartość będzie monitorowana;

warunek - rodzaj wykonywanej operacji porównania; możliwe są następujące warunki: < , <= , = , <> , >= , > ;

ograniczenie - wartość liczbowa lub nazwa zmiennej procesowej, do której będzie porównywana dana monitorowana. Wartość liczbowa może być zmiennoprzecinkowa lub całkowita, w zależności od typu danej monitorowanej; w przypadku porównywania zmiennych należy zapewnić zgodność ich typów.

Strategia limitów w momencie wykrycia pojawienia lub zakończenia się alarmu, przekazuje do logu alarmów zarówno aktualną wartość zmiennej monitorowanej jak i wartość ograniczenia. Mogą one zostać wyświetlone w tekście alarmu na maskach alarmowych, poprzez użycie właściwych znaków formatujących w tekstach początku i końca podanych w definicji alarmu.

Przykład

Limit: 10,A1,>,A2

Założenie: zmienne A1 i A2 są liczbami 16-bitowymi

Tekst alarmu: Temperatura korpusu %u większa od maksimum krytycznego %u

Limit: 0,F1,>,3.4

Założenie: zmienna F1 jest liczbą zmiennoprzecinkową

Tekst alarmu: Temperatura korpusu %f większa od maksimum krytycznego %f

Pierwsza sekwencja formatująca w tekście alarmu dotyczy zawsze wartości zmiennej, druga wartości ograniczenia.

Strategia aktywna rozpoznawania alarmów

Zasada jej działania polega na tym, że sterownik aktywnie wysyła do komputera informacje o zdarzeniach alarmowych. Użycie tej strategii wymaga stosowania protokołu transmisji pozwalającego na inicjację przesyłów ze strony sterownika oraz specjalnego programu w sterowniku, który wysyła dane zgodnie z protokołem przyjętym w strategii aktywnej.

Definiowanie poprzez jedną lub więcej pozycji w module System alarmów programu Architekt:

bufor,synchro,numer_alarmu,id

Znaczenie parametrów:

bufor - nazwa zmiennej służącej do wymiany danych,

synchron - nazwa zmiennej synchronizującej,

numer_alarmu - numer pierwszego alarmu obsługiwanego przez ten element strategii,

id - identyfikator (sieci SINECL2, aktualnie 1(SSNR =0) lub 2 (SSNR =8)).

Strategia buforowa rozpoznawania alarmów

Strategia ta charakteryzuje się dużą rozdzielczością wykrywania alarmów - milisekundy, także przypisaniem każdemu alarmowi dokładnego czasu jego wystąpienia.

Strategia ta jest równoważna strategii aktywnej. Nie wymaga jednak aktywnego przesyłu danych ze sterownika. Sterownik zapełnia swój bufor alarmami. W momencie pojawienia się jakichkolwiek alarmów w buforze, sterownik ustawia zmienną synchronizującą. Jest to sygnałem dla stacji Asixa, że dane o nowych alarmach są gotowe do odczytu. Po zakończeniu operacji czytania stacja Asixa zeruje zmienną synchronizującą. Oznacza to dla sterownika, że może on zapełniać bufor nowymi alarmami.

Strategia ta może być stosowana z dowolnym protokołem komunikacyjnym, zdolnym do przesyłu danych w postaci tablic słów 16-bitowych.

Do poprawnej pracy wymagana jest współpraca odpowiedniego programu po stronie sterownika. Szczegóły dotyczące tego programu powinny zostać omówione z firmą ASKOM.

Parametryzacja Strategii Buforowej odbywa się poprzez umieszczenie jednej lub kilku pozycji w module System alarmów programu Architekt:

<zmienna_buforowa>,<zmienna_synchronizująca>,

<zmienna_alarmów>,<numer_alarmu>

<zmienna_buforowa> - nazwa zmiennej Asmena służącej do wymiany informacji o alarmach; jej rozmiar musi być równy rozmiarowi bufora w sterowniku;

<zmienna_synchronizująca> - nazwa zmiennej Asmena służącej do synchronizacji dostępu do bufora;

<zmienna_alarmów> - nazwa zmiennej Asmena służącej do wystawiania przez PC żądania odczytu mapy alarmów - stosowana w trakcie inicjacji systemu;

<numer_alarmu> - określa numer alarmu w ramach systemu Asix, nadawany pierwszemu alarmowi wykrywanemu przez deklarowaną strategię.

PRZYKŁAD

Deklaracja strategii buforowej w programie Architekt > module System alarmów > na zakładce Strategie / Aktywna:

41_ALBUFOR,41_ALSYNC,41_ALMAPA,21

Więcej informacji na temat strategii buforowej rozpoznawania alarmów znajduje się w pliku pomocy StBuforowa.pdf.

Strategia alarmów OPC

W strategii alarmów OPC dane o alarmach przesyłane są z serwera alarmów OPC (ang. OPC Alarm and Event Server) do systemu Asix z wykorzystaniem drajwera alarmów OPC (który służy jako klient dla dowolnego serwera alarmów OPC).

Ta strategia pozwala na przesyłanie tylko alarmów aktywnych. Dane o czasie rozpoczęcia i zakończenia alarmu przesyłane są z dokładnością do jednej milisekundy.

W systemie Asix operujemy pojęciem alarmu, który sygnalizuję jakąś sytuację (zwykle awaryjną) i ma czas rozpoczęcia oraz zakończenia.

Specyfikacja OPC, a co za tym idzie serwery alarmów OPC operują pojęciem warunku (ang. condition) i pod-warunku (ang. sub-condition). Warunek jest stanem serwera OPC lub jednego z jego obiektów. Na przykład warunek "Alarm Poziomu" może zawierać pod-warunki "Poziom Niski", "Poziom Wysoki", "Poziom Bardzo Wysoki" itp. Jeśli wartość zmiennej wzrosła powyżej lub poniżej zdefiniowanego poziomu, to zmienna przechodzi z warunku 'normalnego’ do wcześniej zdefiniowanego warunku związanego z wartością zmiennej.

Nazwy warunków i pod-warunków są zależne od serwera. Jeśli jakiś obiekt na serwerze (np. zmienna) zmienia swój warunek lub pod-warunek, to serwer generuje zdarzenie, które jest następnie odbierane przez klienta alarmów i tłumaczone na alarmy w systemie Asix.

W tym celu drajwer alarmów OPC wymaga pliku tłumaczeń warunków OPC na alarmy w systemie Asix. Struktura tego pliku jest podana w dalszej części tego punktu.

Obiekty (zmienne) na serwerze OPC są podzielone na kategorie. Nazwy kategorii są zależne od serwera. W momencie generowania zdarzenia związanego ze zmianą warunku lub pod-warunku, obiekt, który zmienia swój stan, jest nazywany źródłem.

Sposób użycia drajwera alarmów OPC

w programie Architekt > module System alarmów > na zakładce Strategie / Serwera alarmów OPC należy dodać wiersz o poniższej składni:

ALOPC.dll, , <serwer>, <plik_al_opc>

gdzie:

<serwer> - oznacza nazwę serwera alarmów OPC;

<plik_al_opc> - oznacza nazwę pliku tłumaczeń warunków OPC na alarmy w systemie Asix.

PRZYKŁAD

ALOPC.dll, , TriangleMicroWorks.OPCAE, c:\asix\app\app.alarmyOPC

Jeśli alarmy mają być wyświetlane w systemie Asix z dokładnością do 10 milisekund - dla pliku konfiguracyjnym aplikacji, należy skonfigurować opcję Dokładność zapisu czasu / Rozdzielczość milisekund:

Architekt > Obszary i komputery > moduł System alarmów > zakładka Archiwum2

Format pliku tłumaczenia warunków OPC na alarmy w systemie Asix

Struktura pliku:

- wiersze komentarza rozpoczynają się znakiem średnika ( ; );

- jeden wiersz odpowiada jednemu warunkowi (ang. condition) lub pod-warunkowi (ang. sub-condition) serwera alarmów OPC;

- każda linia w pliku tłumaczeń ma formę: <typ>, <źródło>, <kategoria>, <warunek>, ...pozostałe parametry zależą od typu.

Wyróżniamy 6 typów alarmów (sposobów tłumaczenia zdarzeń OPC na alarmy w systemie Asix):

1. alarm - alarm w systemie Asix zostanie rozpoczęty po tym jak pod-warunek z nim związany stanie sie aktywny lub gdy pod-warunek o wyższym priorytecie stanie się aktywny (np.: włączenie alarmu HI_HI włączy automatycznie alarm HI);

2. alarm/switch - alarm w systemie Asix zostanie rozpoczęty po tym jak pod-warunek z nim związany stanie sie aktywny;

3. alarm/attribute/bool - alarm w systemie Asix zostanie rozpoczęty po tym jak pod-warunek z nim związany stanie sie aktywny lub zaistnieje zdarzenie dla aktywnego pod-warunku, a wartość przekazana w atrybucie o podanym ID jest różna od 0;

4. alarm/attribute/trip/start

5. alarm/attribute/trip/impulse

6. alarm/attribute/trip/durable - alarm w systemie Asix zostanie rozpoczęty po tym jak pod-warunek z nim związany stanie sie aktywny lub zaistnieje zdarzenie dla aktywnego pod-warunku.

Typy 4, 5 oraz 6 różnią się między sobą sposobem postępowania w momencie odebrania od serwera OPC nowego zdarzenia:

  • dla alarmów typu start nie jest generowany koniec bieżącego alarmu, a tylko początek nowego;

  • dla alarmów typu impulse jest generowany początek nowego alarmu i natychmiast jego koniec;

  • dla alarmów typu durable jest generowany koniec bieżącego alarmu, a następnie początek nowego.

W praktyce oznacza to, że:

  • dla alarmów typu start:

- w okienku aktywnych alarmów zmieni się wartość i data alarmu, ale alarm pozostanie ciągle widoczny;

- w okienku alarmów historycznych pojawi się tylko początek alarmu;

  • dla alarmów typu impulse:

- w okienku aktywnych alarmów nie pojawi się nic;

- w okienku alarmów historycznych pojawi się początek i koniec alarmu;

  • dla alarmów typu durable:

- w okienku aktywnych alarmów zmieni się wartość i data alarmu, ale alarm pozostanie ciągle widoczny;

- w okienku alarmów historycznych pojawi się koniec poprzedniego alarmu i początek nowego;

Format wiersza pliku tłumaczeń warunków OPC na alarmy w systemie Asix dla warunków typu alarm:

W przypadku warunków typu alarm wiersz pliku tłumaczeń ma następującą postać:

alarm , <źródło> , <kategoria> , <warunek> [ , <pod-warunek> <alarm Asixa> ], * [, <pod-warunek> <alarm Asixa> ]

ang.:

alarm, <source>, <category>, <condition> [, <sub-condition> <Asix alarm> ], * [, <sub-condition> <Asix alarm> ]

gdzie:

<Źródło> - nazwa zmiennej (obiektu) na serwerze OPC;

<kategoria> - nazwa kategorii warunków - wartość specyficzna dla danego serwera OPC;

<warunek> - nazwa warunku - wartość specyficzna dla danego serwera OPC;

<pod-warunek> - nazwa pod-warunku - wartość specyficzna dla danego serwera OPC;

<alarm asixa> - numer alarmu w systemie Asix.

Para <Pod-warunek> <Alarm asixa> może się powtarzać wielokrotnie (zwykle dwa razy).

Nazwy pod-warunków i numery alarmów podajemy od alarmu odpowiadającego najwyższej wartości zmiennej do najniższej.

Przed symbolem gwiazdki (*) wpisujemy nazwy pod-warunków typu HI (odpowiadających wartości zmiennej większej niż normalna) oraz numery alarmów (w systemie Asix) odpowiadających tym pod-warunkom. Natomiast po symbolu gwiazdki (*) wpisujemy nazwy pod-warunków typu LO (odpowiadających sytuacji, gdy wartość zmiennej jest niższa niż normalnie) wraz z numerami alarmów (w systemie Asix) odpowiadających tym pod-warunkom.

PRZYKŁAD

Mamy zmienną x przyjmującą wartości od 0 do 100, skonfigurowaną w następujący sposób na serwerze OPC:

Tabela: Strategie rozpoznawanie alarmów - tabela do przykładu.

* - nazwy warunków i pod-warunków zależą od serwera OPC

** - stan normalny

Chcemy, aby tym pod-warunkom odpowiadały alarmy w systemie Asix o następujących numerach:

Lo_Lo - 10

Lo - 11

Hi - 20

Hi_Hi - 21

(stanowi normalnemu nie odpowiada żaden alarm w systemie Asix).

Jeśli zmienna nosi nazwę: "Device1.Variable1", kategoria nosi nazwę: "Level Category", a warunek i pod-warunki noszą nazwy jakie podano w powyższej tabeli, to należy w pliku tłumaczeń warunków OPC na alarmy w systemie Asix dopisać następujący wiersz:

alarm, Device1.Variable1, Level Category, Level, Hi_Hi 21, Hi 20, *, Lo 11, Lo_Lo 10

PRZYKŁAD

alarm, Numeric.AlSource, Limit, LIMIT_EXCEEDED, HI_HI 4, HI 3, *, LO 2, LO_LO 1

Format wiersza pliku tłumaczeń warunków OPC na alarmy w systemie Asix dla warunków typu alarm/switch

W przypadku warunków typu alarm/switch wiersz pliku tłumaczeń ma następującą postać:

alarm/switch, <źródło>, <kategoria>, <warunek> [ , <pod-warunek> <alarm Asixa> ]

ang.:

alarm/switch, <source>, <category>, <condition> [ , <sub-condition > <Asix alarm > ]

można też pisać oddzielną linię dla każdego podwarunku

alarm , <źródło> , <kategoria> , <warunek>, <Pod-warunek 1> <Alarm Asixa 1>

alarm , <źródło> , <kategoria> , <warunek>, <Pod-warunek 2> <Alarm Asixa 2>

alarm , <źródło> , <kategoria> , <warunek>, <Pod-warunek 3> <Alarm Asixa 3>

gdzie:

<źródło> - nazwa zmiennej (obiektu) określona na serwerze OPC;

<kategoria> - nazwa kategorii warunków - wartość specyficzna dla danego serwera OPC;

<warunek> - nazwa warunku - wartość specyficzna dla danego serwera OPC;

<pod-warunek> - nazwa pod-warunku - wartość specyficzna dla danego serwera OPC;

<alarm asixa> - numer alarmu w systemie Asix;

PRZYKŁAD

alarm/switch, My.Source.Name, Category, CONDITION, CASE_1 301, CASE_2 302, CASE_3 303

lub:

alarm/switch, My.Source.Name, Category, CONDITION, CASE_1 301

alarm/switch, My.Source.Name, Category, CONDITION, CASE_2 302

alarm/switch, My.Source.Name, Category, CONDITION, CASE_3 303

Format wiersza pliku tłumaczeń warunków OPC na alarmy w systemie Asix dla warunków typu alarm/attribute/bool

W przypadku warunków typu alarm/attribute/bool wiersz pliku tłumaczeń ma następującą postać:

alarm/attribute/bool , <źródło> , <kategoria> , <warunek> , <pod-warunek> <ID atrybutu> <Alarm asixa>

ang.:

alarm/attribute/bool, <source>, <category>, <condition> , <sub-condition > <attribute ID> <asix alarm >

gdzie:

<źródło> - nazwa zmiennej (obiektu) określona na serwerze OPC;

<kategoria> - nazwa kategorii warunków - wartość specyficzna dla danego serwera OPC;

<warunek> - nazwa warunku - wartość specyficzna dla danego serwera OPC;

<pod-warunek> - nazwa pod-warunku - wartość specyficzna dla danego serwera OPC;

<alarm asixa> - numer alarmu w systemie Asix;

<ID atrybutu> - parametr określający ID atrybutu, którego wartość będzie użyta jako stan alarmu. Dla wartości różnej od zera alarm zostanie włączony, a dla wartości równej zeru alarm zostanie wyłączony.

PRZYKŁAD

alarm/attribute/trip/start , Numeric.AlSource, Limit, LIMIT_EXCEEDED, Default 255 401

gdzie:

255 jest numerem (ID) atrybutu, w którym przesyłana jest wartość zmiennej

Format wiersza pliku tłumaczeń warunków OPC na alarmy w systemie Asix dla warunków typu alarm/attribute/trip/start, alarm/attribute/trip/impulse, alarm/attribute/trip/durable

W przypadku warunków typu alarm/attribute/trip/start, alarm/attribute/trip/impulse, lub alarm/attribute/trip/durable wiersz pliku tłumaczeń ma następującą postać:

alarm/attribute/trip/start , <źródło> , <kategoria> , <warunek> , <Pod-warunek> [<ID Atrybutu>] <Alarm Asixa>

alarm/attribute/trip/impulse , <źródło> , <kategoria> , <warunek> , <Pod-warunek> [<ID Atrybutu>] <Alarm Asixa>

alarm/attribute/trip/durable , <źródło> , <kategoria> , <warunek> , <Pod-warunek> [<ID Atrybutu>] <Alarm Asixa>

ang.:

alarm/attribute/trip/start , <source >, <category>, <condition> , <sub-condition > [<attribute ID>] <Asix alarm>

alarm/attribute/trip/impulse , <source >, <category>, <condition> , <sub-condition > [<attribute ID>] <Asix alarm>

alarm/attribute/trip/durable , <source >, <category>, <condition> , <sub-condition > [<attribute ID>] <Asix alarm>

gdzie:

<źródło> - nazwa zmiennej (obiektu) określona na serwerze OPC;

<kategoria> - nazwa kategorii warunków - wartość specyficzna dla danego serwera OPC;

<warunek> - nazwa warunku - wartość specyficzna dla danego serwera OPC;

<pod-warunek> - nazwa pod-warunku - wartość specyficzna dla danego serwera OPC;

<alarm asixa> - numer alarmu w systemie Asix;

<ID atrybutu> - opcjonalny parametr określający ID atrybutu, którego wartość będzie pdczytana i przekazana do systemu Asix. Wartość ta następnie może zostać wyświetlona w tekście alarmu.

PRZYKŁAD

alarm/attribute/trip/start, My.Source, Trip, COS, Default 55

alarm/attribute/trip/impulse, My.Source, Trip, COS, Default 56

alarm/attribute/trip/durable, My.Source, Trip, COS, Default 57

Aby wyświetlić wartość zmiennej w tekście alarmu należy użyć symbolu %f w definicji alarmu,

W miejscu, gdzie ma sie pojawić wartość.

PRZYKŁAD

17, AL, Temperatura kotła. Wartość atrybutu cv jest równa %f

101, AL, Prędkość przesuwu taśmy wynosi %f metrów na sekundę


12.1.6. Konfiguracja pracy sieciowej

System alarmów programu AS posiada wbudowane mechanizmy pracy sieciowej. Uaktywniają się one, jeżeli w czasie startu aplikacji zostanie uruchomiony moduł Aslink. System alarmów może pracować w jednym z czterech trybów. Tryb ten jest ustawiany za pomocą parametru Sposób pracy systemu alarmów:

Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy:

Operatorski - tryb aktywny, charakteryzuje się pełnymi możliwościami obsługi alarmów aktywnych. Stanowisko aktywne może wykrywać alarmy. Operator ma możliwość potwierdzania alarmów, zmiany wykluczeń i filtrów. W systemach sieciowych stanowiska operatorskie mogą być łączone w grupy, które obsługują taki sam zestaw alarmów. Obsługa ta jest synchronizowana. Potwierdzenie alarmu, zmiana wykluczenia lub filtru na jednym stanowisku jest transmitowana natychmiast do wszystkich stanowisk grupy. W czasie restartu komputera następuje uzupełnianie plików logu historycznego z innego pracującego stanowiska grupy. Stanowiska aktywne mogą również udostępniać swoje archiwa alarmów dla stanowisk kontrolnych.

Kontrolny - tryb pasywny, pozbawiony jest możliwości obsługi alarmów aktywnych. Strategie wykrywania alarmów nie są uruchamiane. Stanowiska kontrolne służą do przeglądania logów historycznych, które są transferowane ze stanowisk operatorskich.

Lokalny - tryb ten pod względem pracy lokalnej daje takie same możliwości jak tryb Operatorski. Jedynym ograniczeniem jest brak możliwości łączenia się z innymi stanowiskami w celu wymiany danych o alarmach.

Serwer alarmów

historycznych - z punktu widzenia operatora praca w trybie serwera alarmów historycznych jest taka sama jak w trybie kontrolnym. Istota trybu serwera polega na jego usługach dla innych stanowisk sieciowych. Serwer alarmów historycznych przez cały czas swojego działania otrzymuje kopie logów alarmów ze wszystkich stanowisk operatorskich, które uda mu się wykryć.

Zgromadzone archiwa mogą być następnie udostępnione stanowiskom kontrolnym. Serwer alarmów może być stosowany w dwóch przypadkach:

  • w dużych instalacjach (z dużą ilością stanowisk kontrolnych) pozwala odciążyć stanowiska operatorskie;

  • w instalacjach złożonych z dwóch osobnych sieci; komputer tzw. pomost pracując w trybie serwera może udostępnić alarmy ze stanowisk operatorskich pierwszej sieci stanowiskom kontrolnym w sieci drugiej.

Kluczowym pojęciem, którego zrozumienie jest niezbędne w celu poprawnej konfiguracji sieciowej instalacji alarmów jest tak zwany zestaw alarmów. W skład definicji zestawu alarmów wchodzą następujące elementy:

  • pliki definicji alarmów,

  • pliki definicji grup,

  • instalowane strategie rozpoznania alarmów.

Zestaw alarmów jest identyfikowany przez 8-znakową nazwę, która jest deklarowana w pliku konfiguracyjnym w parametrze Nazwa komputera:

Architekt > Obszary i omputery > moduł Moduł sieci > zakładka Standardowe

Stacje operatorskie współpracują ze sobą tylko wtedy, gdy mają nadaną taką samą nazwę zestawu alarmu. Istotne jest, aby projektant systemu zapewnił zgodność wszystkich elementów wchodzących w skład zestawu. W przypadku plików definicji alarmów i grup wystarczająca jest zgodność nazw plików (program automatycznie transferuje zawartość plików w przypadku stwierdzenia niezgodności, sprawdzany jest czas zapisu pliku). Natomiast bezwarunkowo muszą zgadzać się parametry strategii rozpoznania alarmów. Wynika to z faktu, że w ramach działającej grupy stanowisk operatorskich tylko jeden komputer aktywnie rozpoznaje alarmy i transferuje je do innych komputerów. Ponieważ nie jest określone, które stanowisko jest aktywne, wobec tego każde z nich musi być w stanie podjąć wykrywanie wszystkich alarmów.

Stanowiska kontrolne nie są uzależnione od nazw sieciowych. Mogą one ściągnąć archiwa historyczne z dowolnego działającego stanowiska operatorskiego. Razem z treścią archiwum transferowane są również pliki definicji alarmów i grup. Przesyłane archiwa są zapisywane w podkartotekach katalogu alarmów, które tworzone są indywidualnie dla każdego stanowiska, z którego przesyłane są archiwa. Nazwa kartoteki tworzona jest na podstawie nazwy zasobu sieciowego przyłączonego komputera. W kartotece oprócz archiwów i plików definicyjnych generowany jest plik alarm.ini, w którym zapisane są informacje na temat komputera, z którego archiwa zostały przesłane. Po początkowym pełnym transferze plików z aktywnego stanowiska, kontynuowana jest automatyczna, okresowa próba uaktualniania zmian zachodzących w stanie archiwum. Stanowisko kontrolne może pracować w całkowitym oderwaniu od stanowisk operatorskich, służąc do przeglądania alarmów, które znajdują się w utworzonych wcześniej kartotekach archiwalnych.


12.1.7. Wykluczenia i filtry

WYKLUCZENIA

FILTRY

System alarmów programu AS ma wbudowane mechanizmy służące wykluczaniu i czasowemu filtrowaniu alarmów.

Mechanizmy wykluczania i filtrów są sterowane interaktywnie z masek alarmów. Każde ustawienie lub zdjęcie wykluczenia/filtru jest odnotowywane odpowiednim alarmem systemowym. W systemach sieciowych zmiany stanu wykluczeń są propagowane na wszystkie połączone stanowiska operatorskie.

Wykluczenia

Wykluczanie pozwala na wyeliminowanie alarmów, które ze względu na uszkodzenie urządzeń lub łączy pozostają aktywne pomimo tego, że wiadomo o nich, iż w danym momencie nie są aktywne.

W normalnym trybie wykluczenia i filtry są realizowane po stronie komputera. Istnieje jednak możliwość współpracy z mechanizmem wykluczeń sterownika. Program AS ogranicza się wtedy jedynie do interfejsu operatorskiego pozwalającego na ustawianie w pamięci sterownika bitowej mapy alarmów wykluczanych. Włączenie tego trybu pracy następuje wtedy, gdy zostanie zadeklarowana Mapa wykluczeń:

Architekt > Obszary i komputery > moduł System alarmów > zakładka Mapy

Jednocześnie wyłączana jest wewnętrzna kontrola wykluczeń i filtrów.

Możliwa jest praca systemu alarmów w trybie, w którym wykluczanie alarmów polega jedynie na blokadzie wyświetlania alarmów na maskach. Wszystkie zdarzenia są zapisywane w plikach logu. Po wycofaniu wykluczenia można przejrzeć wszystkie zarejestrowane zdarzenia.

Tryb włączany jest parametrem Wyłączenie wyświetlania alarmów wykluczonych:

Architekt > Obszary i komputery > moduł System alarmów > zakładka Zaawansowane

W niektórych zastosowaniach zachodzi konieczność jednoczesnego wykluczenia dużej liczby alarmów. Związane to jest ze specjalnymi trybami pracy instalacji - faza rozruchu, prace serwisowe, wyłączenie części instalacji. Można wtedy zastosować mechanizm wykluczeń za pomocą plików. Jego działanie opiera się na tworzeniu plików zawierających numery alarmów. Tak przygotowane zestawy alarmów mogą być następnie wykluczane przy pomocy pojedynczej operacji. Istnieje możliwość zapisu stanu wykluczeń alarmów do pliku, a także ustawienie wykluczeń zgodnie z zawartością pliku.

Wszystkie pliki wykluczeń są przechowywane w katalogu roboczym systemu alarmów (standardowo ALARMS) i posiadają rozszerzenie EXL. Są to pliki w formacie tekstowym - zawierają numery alarmów zapisane w osobnych liniach. Możliwe jest tworzenie plików wykluczeń przy pomocy standardowego edytora tekstowego pracującego w trybie ASCII (np. program Notatnik systemu Windows).Obsługa plików wykluczeń odbywa się w oknie wykluczeń alarmów. Możliwe jest też sterowanie wykluczeniami przy pomocy akcji operatorskiej WYKLUCZENIE.

Okno obsługi plików wykluczeń otwierane jest poprzez pasek narzędziowy masek alarmowych.

Rysunek : Okno wykluczenia alarmów.

Z użyciem plików wykluczeń związane są przyciski: Zapisz, Ustaw z pliku, Dodaj z pliku i Usuń z pliku.

  • Przycisk Zapisz powoduje zapisanie w pliku numerów wszystkich alarmów znajdujących się na liście Alarmy Wykluczone, w momencie przyciśnięcia przycisku.

  • Przycisk Ustaw z pliku powoduje odczyt wybranego pliku i przepisanie do listy Alarmy Wykluczone alarmów o numerach zapisanych w wybranym pliku. Jednocześnie z listy Alarmy Wykluczone usuwane są wszystkie alarmy o numerach nie znajdujących się w pliku. Nowy stan wykluczeń będzie identyczny ze stanem zapisanym w pliku.

  • Przycisk Dodaj z pliku powoduje odczyt wybranego pliku i dodanie do listy Alarmy Wykluczone alarmów o numerach zapisanych w wybranym pliku.

  • Przycisk Usuń z pliku powoduje odczyt wybranego pliku i usunięcie z listy Alarmy Wykluczone alarmów o numerach zapisanych w wybranym pliku.

Operacje Ustaw z pliku, Dodaj z pliku i Usuń z pliku nie wykonują jeszcze żadnych zmian w stanie wykluczeń. Dopiero przyciśnięcie przycisku OK powoduje realizację nowych ustawień. Powoduje to jednocześnie zapis w logu alarmów informacji o wszystkich zmianach w wykluczeniach alarmów.

Wszystkie powyższe operacje powodują wyświetlenie okna pokazanego poniżej.

Rysunek: Okno plików wykluczeń.

Na liście wyświetlane są nazwy plików wszystkich wcześniej zapamiętanych zestawów wykluczeń. Jak widać z przykładu, wskazane jest nadawaniem plikom nazw opisowych, co pozwala na łatwą identyfikację przeznaczenia poszczególnych zestawów.

Operator może wybrać nazwę zestawu z listy lub ręcznie wprowadzić ją w polu edycyjnym.

Wszystkie pliki wykluczeń są przechowywane w katalogu roboczym systemu alarmów (standardowo ALARMS) i posiadają rozszerzenie EXL. Są to pliki w formacie tekstowym - zawierają numery alarmów zapisane w osobnych liniach. Możliwe jest tworzenie plików wykluczeń przy pomocy standardowego edytora tekstowego pracującego w trybie ASCII (np. program Notatnik systemu Windows).

W systemach sieciowych pliki wykluczeń nie są automatycznie uzgadniane pomiędzy połączonymi stanowiskami.

PORADA - jak szybko usunąć wszystkie wykluczenia

Usunięcie wszystkich wykluczeń można najłatwiej wykonać poprzez użycie pustego zestawu wykluczeń. W tym celu należy w pierwszym kroku zapisać plik wykluczeń w momencie, gdy lista Alarmy Wykluczone jest pusta i nazwać go np. "sunięcie wykluczeń". Operator będzie od tego momentu dysponował zestawem, którego użycie w operacji Ustaw z pliku powoduje usunięcie całej zawartości listy Alarmy Wykluczone.

Filtry

Filtrowanie czasowe eliminuje alarmy, które pojawiają się tylko na chwilę (migotają) zapełniając archiwa alarmowe dużą ilością zdarzeń. Po ustawieniu filtra, alarm jest zgłaszany tylko wtedy, gdy trwa dostatecznie długo.

System Asix posiada dwa algorytmy filtrowania alarmów. Wyboru algorytmu dokonuje się poprzez odpowiednią deklarację algorytmu filtrowania:

Architekt > Obszary i komputery > moduł System alarmów > zakładka Zaawansowane:

- Filtrowanie krótkich alarmów, pojawiających się na czas krótszy niż zadeklarowany;

- Filtrowanie szybkich sekwencji: pojawienie się alarmu - zanik alarmu - pojawienie się alarmu.

Algorytm nr 1

Czas filtrowania tf - jest załączany na zboczu narastającym i opadającym sygnału,

- jest ustawiany indywidualnie dla każdego sygnału.

Rysunek: Algorytm filtrowania alarmów.

Algorytm nr 2

Czas filtrowania tf - jest załączany tyko na zboczu narastającym sygnału,

- jest ustawiany indywidualnie dla każdego sygnału.

Rysunek: Algorytm filtrowania alarmów.


12.1.8. Sygnalizacja dźwiękowa

Program AS posiada mechanizmy pozwalające na sygnalizację dźwiękową pojawiania się alarmów. Domyślnie w przypadku pojawienia się zdarzeń typu: ostrzeżenie, alarm, alarm ważny generowane są proste sygnały dźwiękowe, które nie wymagają instalacji żadnego specjalnego sprzętu. Jeżeli jednak komputer wyposażony jest w kartę dźwiękową, to można zadeklarować dla podanych wyżej zdarzeń pliki typu WAV, które zostaną odtworzone w momencie zajścia zdarzenia.

Sygnały alarmowe deklarowane są w programie Architekt > module System alarmów > na zakładce Sygnalizacja: Sygnał ostrzeżeń, Sygnał alarmów, Sygnał ważnych. Normalnie pojawienie się alarmu powoduje jednokrotne odegranie sygnału dźwiękowego. Poprzez użycie pozycji Alarm ciągły można spowodować, że sygnał będzie powtarzany aż do wyłączenia go poprzez akcję UCISZ_SYGNAL.

Jeżeli sygnalizacja dźwiękowa jest realizowana przez sterownik, to możliwe jest indywidualne ustawianie sygnału dla każdego alarmu osobno. Współpraca ze sterownikiem opiera się na istnieniu bitowych map sygnałów (umownie - dzwonków i buczków), które są czytane i zapisywane przez program AS. Istnienie map sygnałów należy zadeklarować w programie Architekt > module System alarmów > na zakładce Mapy:

opcja: Mapa buczków

Użycie tych opcji powoduje, że na maskach alarmowych pojawia się komenda otwierająca okno obsługi sygnałów.

Przy aktywnej opcji Alarm ciągły działa priorytetowa sygnalizacja dźwiękowa alarmów. Polega ona na tym, że sygnał dźwiękowy danego alarmu nie jest przerywany przez sygnał alarmu o niższym priorytecie. Np. sygnał alarmu ważnego nie jest przerywany przez sygnał ostrzeżenia.


12.1.9. Dziennik sterowań

Mechanizm dziennika sterowań pozwala na notowanie w logu alarmów faktu wykonania przez operatora wybranych operacji sterujących. Zasada działania dziennika opiera się na powiązaniu nazw zmiennych z numerami alarmów. Wykonanie zakończonego sukcesem sterowania zmiennej, która posiada przyporządkowany alarm powoduje zgłoszenie alarmu. W tekście alarmu może wystąpić wartość, która została wysłana.

Parametryzacja dziennika sterowań składa się z trzech części. Należy przygotować jeden lub kilka plików zawierających powiązania nazw zmiennych do numerów alarmów. Są to pliki tekstowe, w których każda linia podaje jedno powiązanie postaci:

<nazwa zmiennej> , <numer alarmu>

Kolejną czynnością jest przygotowanie tekstów alarmów, które mają się pojawić w momencie wykonania sterowania. W tekście alarmu mogą pojawić się znaki formatujące (typu %d, %f, %4.1f), których użycie spowoduje wstawienie w treść alarmu wartości sterowanej zmiennej.

W przypadku, gdy używany jest sieciowy tryb pracy systemu alarmów, wszystkie alarmy dziennika sterowań powinny być zdefiniowane jako systemowe. Pozwoli to na prawidłowe rozgłaszanie alarmów w sieci stanowisk.

Niezbędnym jest również zadeklarowanie opcji DZIENNIK_STEROWAN.

Przy użyciu programu Architekt opcja deklarowana jest w:

Architekt > Obszary i komputery > moduł Pozostałe > zakładka Opcje wprowadzane bezpośrednio

Nazwa sekcji: SYSTEM_ALARMOW

Nazwa opcji: DZIENNIK_STEROWAN

Wartość opcji: plik_powiązań_1[, plik_powiązań_2,.. ]

Znaczenie - pozycja deklarująca nazwy plików, w których zdefiniowane są powiązania pomiędzy nazwami zmiennych i numerami alarmów. Użycie pozycji powoduje automatyczne włączenie procedur dziennika sterowań.

Wartość domyślna - dziennik sterowań nie jest używany.

Zdefiniowanie - ręczne.

Pozycja może być użyta wielokrotnie.

Aktualnie mechanizm rejestrowania wykonanych sterowań zapewnia moduł AsAudit, znacznie przewyższający pod względem funkcjonalności mechanizm dziennika sterowań.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 12. System alarmów > 12.1. Konfiguracja jądra systemu alarmów > 12.1.10. Akcje operatorskie

12.1.10. Akcje operatorskie

UCISZ_SYGNAL

POŁĄCZ__ALARMY

POTWIERDŹ_ALARMY


12.2. Maski alarmowe

W systemie Asix można wyróżnić dwa rodzaje masek alarmowych:

maski alarmów aktywnych - maski pokazujące listę alarmów aktywnych - to znaczy alarmów, które zostały wykryte, a jeszcze się nie zakończyły;

maski alarmów historycznych - maski pokazujące pełną historię zmian stanu alarmów.

Notowane są zarówno pojawienia jak i zaniki alarmów. Pamiętana historia może sięgać wielu dni.

W przypadku systemów pracujących w trybie kontrolnym archiwa alarmów mogą pochodzić z innych stanowisk.

Oprócz możliwości przeglądania, maski alarmowe stwarzają możliwość wykonywania szeregu operacji zarządzających, takich jak:

  • potwierdzanie alarmów (tylko na maskach alarmów aktywnych),

  • selekcja zestawu alarmów pokazywanych,

  • wyłączanie wybranych alarmów z monitoringu,

  • zakładanie filtrów czasowych na momenty pojawiania się i zaniku alarmów,

  • wydruk alarmów za zadany okres czasu,

  • przechodzenie na maskę schematową stowarzyszoną ze wskazanym alarmem,

  • przyłączanie się do archiwów historycznych innych stanowisk (tylko dla stanowisk pracujących w trybie kontrolnym),

  • sterowanie sygnalizacją dźwiękową.

Poza pewnymi specyficznymi cechami wynikającymi z przeznaczenia opisywanych masek, maski alarmowe posiadają wszystkie cechy masek schematowych, tzn. mogą być przesuwane, zwijane do ikony, powiększane itd. Obsługa tych typowych operacji jest tak sama jak masek schematowych. Dalsza część rozdziału dotyczy właściwie tylko elementów specyficznych dla masek alarmowych.


12.2.1. Obsługa Masek Alarmowych

Potwierdzenie

Kryteria

Wykluczenia

Filtry

Sygnały

Wydruk

Maska

Definicja

Połącz

Maski alarmowe są otwierane w taki sam sposób jak maski schematowe - przez przyciśnięcie odpowiedniej kombinacji klawiszy lub kliknięcie myszką w odpowiednim miejscu maski schematowej. Ponadto istnieje możliwość otwarcia masek alarmowych (w ich standardowej postaci) poprzez wykonanie komend:

NARZĘDZIA.OKNO_AKTYWNYCH_ALARMÓW lub NARZĘDZIA.OKNO_HISTORYCZNYCH_ALARMÓW w oknie panelu kontrolnego.

Maski alarmów aktywnych i historycznych mogą przybierać różnorodną postać w zależności od sposobu ich sparametryzowania przez projektanta aplikacji. Mogą to być duże okna posiadające wszystkie elementy kontrolne, mogą też w skrajnej postaci składać się z jednej linii alarmu bez żadnych elementów kontrolnych.

Poniżej pokazana jest pełna postać maski alarmów aktywnych po jej otwarciu komendą z Panelu Kontrolnego.

Rysunek: Okno alarmów aktywnych.

Pełna wersja maski alarmów aktywnych składa się z następujących elementów:

  • ramki,

  • linii nagłówka z przyciskami menu systemowego, przejścia do ikony i pełnego ekranu,

  • paska przycisków służących do wykonywania operacji zarządzających,

  • listy alarmów, której każda linia składa się z tekstu alarmu oraz czasu jego pojawienia,

  • linii statusu złożonej ze strzałek służących do przemieszczania się po liście alarmów oraz pola pokazującego ilość aktywnych alarmów.

Kompletną wersję maski alarmów historycznych (w postaci dla stanowiska operatorskiego) przedstawia poniższy rysunek.

Rysunek: Okno alarmów historycznych.

W wersji tej maska alarmów historycznych składa się z następujących elementów:

  • ramki,

  • linii nagłówka z przyciskami menu systemowego, przejścia do ikony i pełnego ekranu,

  • paska przycisków służących do wykonywania operacji zarządzających,

  • listy alarmów, której każda linia składa się z tekstu alarmu, identyfikatora zmiany stanu oraz czasu zajścia zdarzenia,

  • linii statusu złożonej ze strzałek służących do przemieszczania się po liście alarmów, pola pokazującego zakres ograniczenia czasowego wyświetlanych alarmów oraz pola, które podaje zestaw używanych kryteriów selekcji,

  • daty na pasku.

Teksty alarmów wyświetlane są w kolorach uzależnionych od typu alarmu, który opisują. Istnieje następujące przyporządkowanie kolorów tekstów do typu alarmów rozróżnianych w systemie Asix:

kolor żółty - alarm systemowy, nie związany z kontrolowanym procesem, lecz dotyczący zdarzeń związanych z wewnętrznym działaniem systemu;

kolor zielony - komunikat;

kolor niebieski - ostrzeżenie;

kolor fioletowy - alarm normalny;

kolor czerwony - alarm ważny.

Dodatkowo, alarm w stanie selekcji wyświetlany jest na błękitnym tle.

W przypadku maski alarmów aktywnych możliwa jest taka parametryzacja, że wszystkie alarmy, niezależnie od ich typów, wyświetlane są w białym kolorze na czerwonym tle ("Tryb czerwony"). Pozwala to na tworzenie tzw. masek ostatniego alarmu (pokazujących tylko ostatni aktywny alarm), na których pojawienie się alarmu powoduje wyświetlenie go w czerwonym kontrastowym kolorze. Pojawienie się alarmów typu ostrzeżenie, alarm normalny i alarm ważny jest dodatkowo sygnalizowane sygnałem dźwiękowym (uzależnionym od typu alarmu).

Kolorystyka wyświetlanych czasów zdarzeń jest następująca:

kolor jasnoczerwony - alarm rozpoczęty, niepotwierdzony;

kolor czerwony - alarm rozpoczęty, potwierdzony;

kolor zielony - alarm zakończony, potwierdzony;

kolor żółty - alarm zakończony, niepotwierdzony.

Wyświetlane na masce alarmów historycznych identyfikatory zmiany stanu określają rodzaj zdarzenia, które zaszło dla pokazywanego alarmu. Używane są poniższe wartości identyfikatorów:

P - początek alarmu,

K - koniec alarmu,

W - wymuszone zakończenie alarmu spowodowane wykluczeniem alarmu z monitoringu przez operatora.

Kolory używane na maskach alarmowych mogą być zmieniane przy pomocy zakładki Wygląd w programie Architekt > Obszary i omputery > moduł System alarmów.

Maski alarmów pokazują jednorazowo ograniczoną liczbę zdarzeń alarmowych (zazwyczaj ostatnich). Operator ma możliwość zmiany zakresu pokazywanych alarmów posługując się klawiszami PgUp, PgDn, Home, End oraz klawiszami strzałek. Jeżeli maska alarmowa posiada linię statusu, to możliwe jest jeszcze przemieszczanie się w alarmach przy pomocy myszki. Kliknięcie lewym klawiszem myszki na obrazkach strzałek w linii statusu powoduje zmianę wybranych alarmów o jedną pozycję, kliknięcie prawym klawiszem powoduje zmianę o całą stronę. Powyższe operacje pozwalają także na zmianę alarmu wyselekcjonowanego.

Obecność paska przycisków na masce alarmowej pozwala na wykonywanie operacji zarządzających systemem alarmów. Wykonanie operacji inicjowane jest kliknięciem myszką na wybranym przycisku lub przyciśnięciem na klawiaturze kombinacji Alt-litera, gdzie użyta litera odpowiada literze wyróżnionej na opisie klawisza. Znaczenie poszczególnych operacji jest opisane poniżej:

Potwierdzenie - wykonanie operacji potwierdzenia alarmów. Potwierdzane są wszystkie alarmy wyświetlane aktualnie na masce. Spełnione muszą być jednak dwa dodatkowe warunki: alarm nie może być zakończony i musi być dodatkowo wyselekcjonowany, jeżeli jest typu "alarm ważny". Można selektywnie potwierdzać alarmy poprzez podwójne kliknięcie klawiszem myszki na linii alarmu.

Kryteria - określenie warunków, które muszą być spełnione, aby alarm został wyświetlony na masce. Istnieje możliwość użycia sześciu kryteriów selekcji:

  • czasu wystąpienia zdarzenia (tylko dla alarmów historycznych,

  • tekstu opisującego alarm,

  • typu alarmu,

  • stanu alarmu,

  • przynależności alarmu do grupy,

  • numeru alarmu.

Możliwe jest wybranie dowolnego zestawu kryteriów, które mają być użyte jako warunki selekcji. Szczególną uwagę należy zwrócić na kryterium czasu. Jest ono pomocne przede wszystkim przy przeglądaniu alarmów, które wydarzyły się w dalszej przeszłości. Pozwala ono szybko zlokalizować interesujący fragment historii alarmów. Drugą korzyścią z użycia tego kryterium jest ograniczenie czasu przeszukiwania alarmów w przypadku użycia kryteriów, które są spełnione przez niewielką liczbę alarmów, a zgromadzone archiwum sięga okresu wielu dni. Zawężenie okresu czasu pozwala na radykalne skrócenie czasu oczekiwania na reakcję systemu.

Z okna selekcji alarmów masek alarmów historycznych można zapamiętać kryteria selekcji w pliku i ustawić kryteria według zawartości pliku. Pliki kryteriów przechowywane są w katalogu archiwum alarmów i posiadają rozszerzenie SEL.

Rysunek: Okno kryteriów selekcji alarmów - wywoływane z maski alarmów historycznych.

Okno selekcji składa się z sześciu grup odpowiedzialnych za poszczególne kryteria. Aby odpowiednie kryterium było brane pod uwagę, wymagane jest ustawienie pola wyboru znajdującego się na początku każdej grupy.

W przypadku użycia kryterium czasu, pozostawienie pustego pola Czas Początku oznacza sięganie do najstarszych zapamiętanych alarmów, a puste pole Czas Końca oznacza wyświetlanie alarmów nowoprzychodzących. Zdefiniowanie kryterium tekstu polega na podaniu w polu Wzorzec fragmentu tekstu, który musi pojawić się w opisie alarmu, aby został on wyselekcjonowany. We wzorcu mogą pojawiać się specjalne znaki * i ?. Znak * oznacza, że w jego miejscu w opisie alarmów może pojawić się dowolna liczba nieokreślonych znaków. Znak ? pozwala na wystąpienie w jego miejscu dowolnego jednego znaku. Najbardziej typowe określenia wzorca przyjmują postać:

tekst - odpowiada alarmom, których opis zaczyna się od "tekst",

*tekst - odpowiada alarmom, w opisie których "tekst" pojawia się w dowolnym miejscu.

Kryterium grupy określa się poprzez wyselekcjonowanie na liście nazw, grup do których wyświetlane alarmy muszą należeć. Istnieje możliwość jednoczesnej selekcji do dziesięciu nazw grup.

Kryterium numerów pozwala ograniczyć listę wyświetlanych alarmów do ściśle określonej numerami. Można zadeklarować listę numerów oddzielonych przecinkiem (np. 2,34,789), zakres numerów alarmów (np. 3-128,300-572) lub połączyć oba sposoby specyfikacji alarmów do wyświetlenia (np. 2,4,5-89). Pole selekcji Pokaż inne służy do wskazania, że wymienione z numerów alarmy mają być wykluczone z wyświetlanej listy (selekcja negatywna).

Przyciski Zapisz i Czytaj służą odpowiednio do zapamiętywania na dysku ustawienia kryteriów selekcji oraz do odczytu plików zapisanych wcześniej. Pliki te znajdują się w kartotece archiwum alarmów i posiadają rozszerzenie SEL. Naciśnięcie jednego z tych przycisków powoduje otwarcie poniższego okna:

Rysunek: Okno plików selekcji alarmów.

W górnej części okna pojawia się lista plików z zapisanymi kryteriami selekcji, które znajdują się w katalogu archiwum alarmów. W dolnym pasku można wpisać nazwę pliku do zapisu.

Poniżej pokazane zostało okno służące do wykluczania alarmów.

Rysunek: Okno wykluczenia alarmów.

Wykluczenia - okno wykluczeń składa się z dwóch list: w jednej pokazane są wszystkie alarmy zdefiniowane w systemie, w drugiej alarmy, które są aktualnie wyłączone. Wykluczenie alarmu polega na wybraniu go na liście alarmów zdefiniowanych i przyciśnięciu przycisku Dodaj. Wznowienie kontroli stanu alarmu polega na wybraniu alarmu na liście alarmów wykluczonych i przyciśnięciu przycisku Usuń. Ze względu na to, że liczba alarmów zdefiniowanych może być bardzo długa, wprowadzone zostały specjalne udogodnienia służące do selekcji alarmów na tej liście. W momencie pojawienia się okna wykluczeń następuje automatyczna selekcja alarmu, który był wybrany na masce alarmów w momencie wykonania komendy. Ponadto istnieje możliwość selekcji poprzez pisanie tekstu alarmu, który ma być wykluczony. Tekst wprowadzany nie pojawia się na ekranie, lecz wykonywana jest natychmiastowa selekcja alarmów, których początek opisu jest identyczny z podanym tekstem. Przyciskanie klawisza Enter po wprowadzeniu tekstu powoduje kolejne przechodzenie po alarmach rozpoczynających się właściwym tekstem.

Każde wykluczenie i wznowienie kontroli alarmu jest notowane poprzez wygenerowanie alarmu systemowego opisującego akcję wykonaną przez operatora.

Możliwe jest zapisanie stanu wykluczeń alarmów do pliku, a także ustawienie wykluczeń zgodnie z zawartością pliku. Pliki wykluczeń przechowywane są w katalogu archiwum alarmów i posiadają rozszerzenie EXL. Przy zapisie do pliku wystarczy podać nazwę pliku, a rozszerzenie i lokalizacja są przyjęte domyślnie. Do operacji na plikach wykluczeń alarmów służą przyciski: Zapisz, Ustaw z pliku, Dodaj z pliku i Usuń z pliku. Ich naciśnięcie powoduje otwarcie okna , pozwalającego na wybór pliku do odczytu lub zapisu:

Rysunek: Okno plików wykluczeń.

W górnej części okna pojawia się lista plików z wykluczeniami, które znajdują się w katalogu archiwum alarmów. W dolnym pasku można wpisać nazwę pliku do zapisu.

Filtry - komenda ta pozwala na wprowadzenie filtru czasowego na wykrywanie zmian stanu niektórych alarmów (patrz: 12.1.7. Wykluczenia i filtry). Stosuje się ją dla tych alarmów, które mają tendencję do tzw. migotania, przez co niepotrzebnie zapełniają maski alarmów wciąż powtarzającymi się zdarzeniami. Możliwe jest zadeklarowanie w pliku inicjalizującym aplikacji jednej z dwóch metod filtracji alarmów. Filtrowanie metodą pierwszą powoduje, że notowane są tylko zmiany stanu, które trwają dłużej niż podane minimum, druga metoda eliminuje szybkie sekwencje pojawienia/zaniku/pojawienia alarmu. Poniżej pokazane jest okno służące do włączania filtrowania alarmów:

Rysunek: Okno filtrowania alarmów.

Okno filtrowania składa się z dwóch list: w jednej pokazane są wszystkie alarmy zdefiniowane w systemie, w drugiej alarmy, które są aktualnie filtrowane. Włączenie filtrowania alarmu polega na wybraniu go na liście alarmów zdefiniowanych i przyciśnięciu przycisku Dodaj. Wznowienie normalnej obsługi alarmu polega na wybraniu alarmu na liście alarmów filtrowanych i przyciśnięciu przycisku Usuń. Każdy z alarmów posiada indywidualnie definiowany czas filtracji. Pokazuje się on w polu edycyjnym poniżej listy alarmów filtrowanych w momencie selekcji alarmu. Pole to służy także do zmian czasu filtracji. Czas filtracji wyrażony jest w sekundach.

Ze względu na to, że liczba alarmów zdefiniowanych może być bardzo długa, wprowadzone zostały specjalne udogodnienia służące selekcji alarmów na tej liście. W momencie pojawienia się okna filtrowań następuje automatyczna selekcja alarmu, który był wybrany na masce alarmów w momencie wykonania komendy. Ponadto istnieje możliwość selekcji poprzez pisanie tekstu alarmu, który ma być filtrowany. Tekst wprowadzany nie pojawia się na ekranie, lecz wykonywana jest natychmiastowa selekcja alarmów, których początek opisu jest identyczny z podanym tekstem. Przyciskanie klawisza Enter po wprowadzeniu tekstu powoduje kolejne przechodzenie po alarmach rozpoczynających się właściwym tekstem.

Każde włączenie filtrowania i wznowienie normalnej obsługi alarmu jest notowane poprzez wygenerowanie alarmu systemowego opisującego akcję wykonaną przez operatora.

Sygnały - komenda, która otwiera okno dialogowe służące do parametryzacji sygnalizacji dźwiękowej alarmów, wykonywanej przez sterownik (przycisk dostępny w momencie zadeklarowania odpowiednich pozycji dotyczących sygnalizacji dźwiękowej - Patrz: 12.1.8. Sygnalizacja dźwiękowa).

Rysunek: Okno sygnalizacji alarmów.

Po lewej stronie okna znajduje się lista wszystkich zdefiniowanych alarmów. Po prawej stronie znajdują się dwie listy, w których pokazywane są alarmy, którym zostały przyporządkowane sygnały dźwiękowe dzwonków i buczków. Włączenie sygnału dla alarmu polega na jego wybraniu z listy alarmów zdefiniowanych i przyciśnięciu odpowiedniego przycisku Dodaj. Żeby usunąć sygnalizację dźwiękową, należy wskazać alarm na liście dzwonków i buczków, a następnie przycisnąć odpowiedni przycisk Usuń. Przyciśnięcie przycisku OK powoduje utworzenie map bitowych sygnałów i odesłanie ich do sterownika.

Wydruk - komenda ta pozwala na wydrukowanie alarmów, które zmieniły stan w wybranym zakresie czasu. Drukowane są tylko te alarmy, które spełniają aktualnie ustawione kryteria selekcji (za wyjątkiem kryterium czasu, ponieważ zakres czasu jest tutaj definiowany osobno). Okno wydruku alarmów jest pokazane poniżej:

Rysunek: Okno wydruku alarmów historycznych.

Pozostawienie pustego pola Czas Początku oznacza wydruk najstarszych zapamiętanych alarmów, a puste pole Czas Końca oznacza drukowanie aż do alarmu najnowszego. Informacja, która ma być wydrukowana może zostać zastępczo zapamiętana w pliku (poprzez wybranie opcji Plik i ustawienie pola Nazwa Pliku), skąd może być wydrukowana w terminie późniejszym, bądź posłużyć jako podstawa bardziej szczegółowych analiz. Pole selekcji Tylko z okna pozwala na wydrukowanie aktualnie widocznych na masce alarmów historycznych alarmów wybranych wcześniej według określonego zestawu kryteriów, a pole selekcji Opis umożliwia opatrzenie wydruku dodatkowymi informacjami na tema źródła alarmów, okresu, za który są drukowane oraz zastosowanych kryteriów.

Maska - wykonanie tej komendy powoduje przejście do maski stowarzyszonej z alarmem, który jest aktualnie wyselekcjonowany na masce alarmów. Powiązanie alarmów z właściwymi maskami schematowymi wykonywane jest przez projektanta systemu.

Definicja - komenda ta ma znaczenie jedynie pomocnicze. Pozwala ona na sprawdzenie pełnej definicji alarmu wyselekcjonowanego na masce. Wykonanie tej komendy powoduje otwarcie poniższego okna:

Rysunek: Okno definicji alarmu.

Podanie w polu Numer innego numeru alarmu niż właśnie wyselekcjonowany spowoduje wyświetlenie jego definicji (nawet, jeśli dany alarm nie występuje na liście wyświetlonej na masce alarmów).

Połącz - komenda dostępna tylko na maskach alarmów historycznych systemów kontrolnych. Pozwala ona na wybór źródła pochodzenia alarmów. Wykonanie komendy powoduje wyświetlenie poniższego okna.

Rysunek: Okno przyłączenia do alarmów historycznych.

Przedstawia ono listę dostępnych zasobów - kolor czarny oraz listę zasobów, które znajdują się na dysku lokalnym stacji i zostały ściągnięte w wyniku poprzednich połączeń z serwerami alarmów - kolor szary. Wybór zasobu do przyłączenia dokonywany jest za pomocą przycisku Wybierz.

Przycisk Zaawansowane otwiera następujące okno:

Rysunek: Okno przyłączenia do alarmów historycznych - opcja 'Zaawansowane'.

Zasadniczą część okna stanowi lista stanowisk, do których można wykonać przyłączenie. Opis stanowiska składa się z nazwy sieciowej zasobu oraz nazwy komputera. Może się również pojawić trzecia nazwa. Jest to nazwa serwera alarmów historycznych, za pośrednictwem którego alarmy są przesyłane. Pozycje są wyświetlane w dwóch kolorach. Kolor czerwony oznacza połączenie z aktualnie działającym stanowiskiem. W przypadku wyboru takiego połączenia nastąpi uaktualnienie archiwum i plików definicyjnych z działającego stanowiska operatorskiego. Również w czasie wyświetlania maski będzie podejmowana próba (w takcie minutowym) przesyłania zmian w plikach archiwalnych. Pozycja w kolorze czarnym oznacza przyłączenie do kartoteki, w której wcześniej zostały zapisane archiwa (połączeniem czerwonym lub ręcznie przy pomocy dyskietek). W tym przypadku nie zostanie wykonana próba uaktualnienia archiwum, obecność stanowiska operatorskiego nie jest wymagana.

Pola wyboru Pokaż stanowiska aktywne i Pokaż lokalne kopie archiwalne pozwalają na zawężenie zestawu pozycji w liście połączeń. Każda maska alarmów może być przyłączona do innego źródła alarmów.

Niektóre operacje zarządzające mogą być wykonywane niezależnie od obecności paska przycisków. Pozwala to na wykonanie podstawowych operacji na uproszczonych maskach alarmów (na przykład maska pokazująca tylko ostatni alarm aktywny). Klawisze klawiatury, które mają specjalne znaczenie na maskach alarmowych to:

Enter - potwierdzenie alarmu;

Podwójne kliknięcie myszką na linii alarmu - potwierdzenie alarmu;

Szary- + - przejście do maski stowarzyszonej.

Maski alarmów posiadają menu kontekstowe otwierane prawym przyciskiem myszki. W menu tym pokazywany jest numer wskazanego alarmu oraz poniższe komendy:

przejście do maski stowarzyszonej z alarmem (o ile taka maska jest zdefiniowana);

określenie dolnego limitu wydruku alarmów (na podstawie czasu wskazanego alarmu);

określenie górnego limitu wydruku alarmów (na podstawie czasu wskazanego alarmu).


12.2.2. Definiowanie masek alarmowych

Sposób definiowania masek alarmowych jest zbliżony do tego, w jaki tworzone są zwykłe maski schematowe. Utworzenie nowej maski alarmów aktywnych lub alarmów historycznych wymaga wykonania jednej z komend:

MASKI.NOWA_MASKA_ALARMÓW_AKTYWNYCH

lub

MASKI.NOWA_MASKA_ALARMÓW_HISTORYCZNYCH.

Powoduje to otwarcie okna definiującego maski. Poniżej pokazane jest okno definiujące maski alarmów historycznych.

Rysunek: Okno definicji maski alarmów historycznych.

Jak widać, okna definiujące masek alarmowych zawierają w większości te same pola, co okna definiujące masek schematowych. Obsługa i znaczenie tych pól jest także takie samo. Występujące różnice to:

Pasek Klawiszy - pole w liście atrybutów maski; zaznaczenie tego pola jest konieczne, żeby do maski alarmowej został dołączony pasek przycisków służących do wykonywania operacji zarządzających alarmami;

Linia Statusu - pole w liście atrybutów maski; zaznaczenie tego pola jest konieczne, żeby do maski alarmowej została dołączona linia statusu;

Bez Kolumny Zdarzeń - zaznaczenie tego pola powoduje, że na liście alarmów historycznych nie jest odnotowywany charakter zdarzenia (początek/koniec alarmu); jedyna metodą rozróżnienia początków i końców alarmów jest zdefiniowanie odpowiednich tekstów alarmów dla początku i zakończenia aktywności alarmu;

Bez Daty - na liście alarmów historycznych nie jest wyświetlana data zdarzenia; ustawienie ma sens, gdy lista alarmów jest ograniczona do jednego dnia;

Czerwony Tryb - ustawienie pola powoduje, że wszystkie alarmy wyświetlane są w białym kolorze na czerwonym tle; pole jest używane tylko dla masek alarmów aktywnych;

Selekcja Ramką - zmienia sposób zaznaczania aktualnej pozycji na masce; zamiast zmiany koloru tła, alarm jest zaznaczany przez rysowanie ramki koła tekstu alarmu;

Data na Pasku - powoduje ono wyświetlenie na pasku przycisków maski pola pokazującego datę alarmu, znajdującego się na ostatniej dolnej pozycji listy alarmów – dotyczy tylko maski alarmów historycznych;

Tylko Kryteria - zmienia ono sposób wyświetlenia paska przycisków - zawiera tylko jeden przycisk, który otwiera uproszczone okno selekcji alarmów; okno to pozwala jedynie na ustawianie kryterium selekcji według czasu - dotyczy tylko maski alarmów historycznych;

Linie Zmiany Daty - powoduje on wstawianie na maskach linii informującej o zmianie daty pomiędzy każdą parą wyświetlanych zdarzeń różniących się datą; wyświetlanie linii zmiany daty jest niezależne od kryteriów selekcji - dotyczy tylko maski alarmów historycznych;

--- Używane klawisze--- - za pomocą sekcji Używane klawisze można wybrać, które przyciski paska narzędziowego mają pojawić się na masce alarmowej;

Kolejne pola odpowiadają kolejnym przyciskom na pasku przycisków maski alarmów aktywnych lub historycznych;

Czcionka - pole służące do podania nazwy czcionki, w której mają być wyświetlane opisy alarmów.

Zdarzenie specjalne - pole wyboru charakterystyczne dla masek alarmów historycznych; zaznaczenie pola powoduje, że alarmy rozpoznawane jako "specjalne" wyświetlane są z wyróżniającym je znakiem *.

---Operacje---

Tylko Ostatnie Alarmy - tryb pracy masek alarmów historycznych, w którym pokazywane są tylko ostatnie alarmy (tyle ile mieści sie na ekranie) bez możliwości przeglądania historii

Istnieje możliwość zadeklarowania alarmów rozpoznawanych jako "specjalne" w przypadku stosowania zewnętrznej strategii rozpoznawania alarmów, utworzonej indywidualnie przez użytkownika systemu A six (szczegóły - kontakt z działem pomocy technicznej firmy ASKOM).

Otwierane okno selekcji kryteriów różni się od okna selekcji używanego w czasie działania aplikacji tym, że nie ma możliwości ustawienia kryterium czasu i numeru.

Rysunek: Okno kryteriów selekcji alarmów.

Maska alarmowa, która miała w czasie projektowania ustawione kryteria selekcji, w czasie działanie aplikacji będzie otwierana z jednoczesną aktywizacją ustawionych kryteriów. Grupa pól wyboru Blokady służy do wybrania zestawu kryteriów, które w czasie wykonywania aplikacji nie będą mogły być zmieniane przez operatora, na stan pozostałych kryteriów operator ma wpływ przez zwykłe okienko wyboru kryteriów.

Rozmiar i położenie maski alarmów może być podane bezpośrednio w oknie definiującym, lub też można je ustawić przy pomocy myszki. Na maskach alarmowych nie można umieszczać obiektów wizualizacyjnych.

Definicje masek alarmowych są przechowywane w plikach o rozszerzeniu MSK (tak samo jak maski schematowe).

Sposób użycia masek alarmowych w aplikacji jest taki sam jak masek schematowych. Operacje zamykania i otwierania wykonywane są przy użyciu tych samych akcji.

W oknie definicyjnym maski alarmów historycznych można wyłączyć wyświetlanie na masce alarmów historycznych kolumny typu zdarzenia alarmowego (początek/koniec).


13. System generacji raportów

W systemie Asix dostępne są trzy technologie tworzenia raportów:

- tworzenie raportów z wykorzystaniem języków ASTEL i ASTER;

- pisanie raportów w językach skryptowych VBScript i Jscript;

- projektowanie raportów w środowisku Reporting Services firmy Microsoft (patrz więcej: podręcznik AsRaport.CHM).


raporty_ASTEL_ASTER

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER

13.1. Raporty tworzone przy użyciu ASTEL/ASTER

Raportowanie stanowi integralną cechę systemu Asix. Definicje raportów tworzone są przy wykorzystaniu wbudowanego języka do tworzenia raportów - języka ASTER. Język ten zostanie szczegółowo opisany w osobnym podrozdziale.

Raporty podzielić można na dwie grupy:

  • raporty wyświetlane na maskach schematowych realizowane przez obiekty typu RAPORT, które w dalszej części nazywane będą raportami obiektowymi;

  • raporty zapisywane na dysku i ewentualnie wyświetlane w oknach, realizowane przez wbudowany moduł narzędziowy (uruchamiany za pośrednictwem menu lub odpowiednich akcji); raporty te w dalszej części nazywane będą raportami dyskowymi.


13.1. Obsługa raportów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.1. Obsługa raportów

13.1.1. Obsługa raportów

Grupa RAPORT

Grupa WZORZEC

Grupa FUNKCJA

W przypadku raportów obiektowych definicja raportu traktowana jest jako fragment definicji obiektu i przechowywana jest w pliku opisującym maski (*.msk). Raport po wyliczeniu wyświetlany jest jedynie na masce schematowej. Raport obiektowy może być obliczany cyklicznie, na żądanie operatora lub też w ustalonych terminach w ciągu dnia. Tryb obliczania specyfikuje się podczas parametryzacji obiektu. Raporty obiektowe powinny być, projektowane w taki sposób, aby nie zawierały zbyt wielu informacji. Ograniczenie to spowodowane jest niewielką ilością miejsca na tego typu raporty (brak możliwości przewijania okien masek schematowych oraz konieczność współdzielenia miejsca na ekranie razem z innymi obiektami). Horyzont czasowy takich raportów obejmuje zwykle okres nie przekraczający jednej doby. Bliższe informacje na temat wyświetlania raportów zawiera rozdział poświęcony obiektom typu RAPORT.

Definicje raportów dyskowych przechowywane są jako osobne pliki (*.r). Raporty te mogą być liczone na żądanie lub w sposób automatyczny. Raporty wynikowe zapisywane są w postaci plików tekstowych na dysku. Aby policzyć raport na żądanie operatora, należy wykonać komendę NARZĘDZIA.OKNO_RAPORTÓW w menu Panelu Kontrolnego albo Okna Konstruktora. Na ekranie wyświetlone zostanie wówczas okno raportowe przedstawione na poniższym rysunku. Wyświetlenie okna raportowego można spowodować również wykonując akcję RAPORTUJ (np. naciskając klawisz odpowiednio zdefiniowany jako obiekt typu PRZYCISK).

Rysunek: Okno 'Raporter'.

Aby obliczyć raport, korzystając z okna raportowego, należy:

  • wskazać na liście raportów nazwę raportu, który ma być policzony,

  • wybrać datę odpowiadającą początkowi raportu (domyślnie ustawiona jest data bieżąca),

  • opcjonalnie wybrać nazwisko operatora (o ile występuje w treści raportu),

  • opcjonalnie ustawić czas odpowiadający początkowi raportu (domyślnie 00:00:00),

  • opcjonalnie wprowadzić notatkę (o ile występuje w treści raportu),

  • wybrać opcję WYŚWIETL z menu RAPORT.

Wykonanie funkcji WYŚWIETL powoduje sprawdzenie, czy wybrany raport nie został policzony już wcześniej i zapisany na dysku. Jeżeli tak było, zostaje on wyświetlony w specjalnie utworzonym oknie na ekranie.

W przeciwnym przypadku raport przed wyświetleniem zostanie policzony i zapisany na dysku. Raporty nie mieszczące się na ekranie mogą być przewijane wewnątrz okna. Liczba jednocześnie otwartych okien została ograniczona do ośmiu. Przykład raportu wyświetlonego w postaci odrębnego okna został zamieszczony na poniższym rysunku.

Rysunek: Okno z przykładowym raportem.

Efekt obliczenia określonego raportu bez potrzeby korzystania z okna raportowego i bez jego wyświetlania można uzyskać wykonując akcję LICZ_RAPORT z parametrami określającymi:

  • nazwę pliku z definicją raportu,

  • moment odpowiadający początkowi raportu,

  • nazwisko operatora (opcjonalnie),

  • treść notatki (opcjonalnie).

Efekt obliczenia raportu, z jednoczesnym jego wyświetleniem, uzyskać można przy pomocy akcji POKAZ_RAPORT. Akcja ta oferuje ponadto możliwość ewentualnego skasowania raportu na dysku po jego wyświetleniu.

Dla użytkowników, którzy chcą wydrukować raport bez jego wcześniejszego oglądania przeznaczona jest akcja PISZ_RAPORT.

Wszystkie wymienione akcje mogą być wykonywane po wciśnięciu klawisza zdefiniowanego jako obiekt PRZYCISK. Prócz tego mogą być wykorzystywane w terminarzu.

Korzystanie z okna raportowego daje większe możliwości, aniżeli jedynie liczenie i wyświetlanie raportów. Funkcje modułu raportowego dostępne są za pośrednictwem menu i podzielone zostały na cztery grupy: RAPORT, WZORZEC, FUNKCJA i POMOC. Funkcje należące do grupy RAPORT umożliwiają gospodarkę raportami - ich liczenie, kasowanie itp. Funkcje należące do grupy WZORZEC umożliwiają gospodarkę definicjami raportów - ich poprawianie i sprawdzanie. Grupa FUNKCJA umożliwia wprowadzenie notatki, która może być wstawiona do raportu, o ile jest on odpowiednio zdefiniowany (posiada znacznik %remark% w treści instrukcji format, - patrz: 13.1.4. Język definiowania raportów ASTER) oraz ustawienie daty niedostępnej (spoza zakresu) na liście dat obliczania raportu.

W polu Stan wyświetlają się informacje o etapie liczenia raportu. Raport może: być w trakcie liczenia, czekać w kolejce na policzenie oraz być już policzony. Niemożliwe jest zamknięcie okna raportów, o ile nie zostało zakończone liczenie raportu.

Grupa RAPORT menu okna raportującego obejmuje opisane poniżej funkcje:

WYŚWIETL - umożliwia wyświetlenie raportu w oknie z ewentualnym wcześniejszym jego policzeniem, jeżeli danego raportu nie było na dysku;

UAKTUALNIJ - działa podobnie jak WYŚWIETL z tą różnicą, że raporty, które już zostały policzone, ale nie obejmują pełnego okresu, dla którego zostały napisane, policzą się powtórnie; przykładowo, jeśli dany raport dotyczący całego dnia bieżącego, zostanie policzony na przykład o godzinie 10-tej i zapisany na dysku, to wykonanie funkcji WYŚWIETL o godzinie 12-tej spowoduje wyświetlenie raportu zawierającego tylko dane do godziny 10-tej; w tej sytuacji należy wykonać funkcję UAKTUALNIJ, która spowoduje ponowne obliczenie tak, że będzie on zawierał dane do godziny 12-tej; w przypadku raportów dotyczących całkowicie zakończonych dni, nie ma różnicy między funkcją WYŚWIETL i UAKTUALNIJ;

PRZELICZ - usuwa raport z dysku (o ile był wcześniej policzony), po czym raport jest liczony i wyświetlany;

DRUKUJ - powoduje policzenie raportu, po czym następuje jego wyprowadzenie na aktualnie przyłączoną drukarkę; wydruk jest wykonywany z wykorzystaniem instrukcji sterujących formatowaniem zawartych w treści raportu;

USUŃ - umożliwia usunięcie raportu; wymagane jest potwierdzenie tej operacji (przykład poniżej);

Rysunek: Okno z informacją o usuwanym raporcie.

KOPIUJ - umożliwia kopiowanie pliku zawierającego raport; zwykle używana jest do kopiowania raportów na dyskietki; należy wyspecyfikować napęd dyskowy i katalog, do którego raport zostanie skopiowany;

KATALOG - umożliwia zmianę katalogu, z którego czytane są definicje raportów; na podstawie ich zawartości tworzona jest lista nazw raportów w oknie raportowym; po zmianie katalogu lista ta zostanie utworzona na nowo; stosowanie katalogów umożliwia podział raportów na grupy; okno do wyboru katalogu zostało przedstawione poniżej;

Rysunek: Okno wyboru katalogu docelowego raportów.

ZAMKNIJ - umożliwia zamknięcie okna raportowego.

Funkcje WYŚWIETL, UAKTUALNIJ, PRZELICZ, DRUKUJ, USUŃ i KOPIUJ wymagają uprzedniego wskazania (np. kursorem myszy) nazwy raportu na liście nazw raportów, oraz ustawienia daty raportu. W celu ustawienia daty raportu należy wskazać datę z listy dat.

Dodatkowo w podobny sposób można wybrać nazwisko operatora, jeżeli będzie ono umieszczone w treści raportu.

Grupa WZORZEC okna raportowego obejmuje następujące funkcje:

SPRAWDŹ - umożliwia sprawdzenie poprawności definicji raportu; funkcję tę należy wywołać każdorazowo po wykonaniu jakiejkolwiek modyfikacji definicji raportu; wywoływana jest wtedy funkcja translacji źródłowego raportu do postaci wewnętrznej; po jej zakończeniu zostanie wywołane okno z informacją o braku błędów lub ewentualnie o wykrytych błędach i miejscach, w których wystąpiły; bliższe informacje dotyczące wykrywanych błędów zamieszczone zostały w opisie języka definiowania raportów ASTER.

Rysunek: Okno statusu poprawności definicji raportu.

POPRAW - wywołuje edytor tekstowy umożliwiający dokonanie modyfikacji definicji raportu; wskazany przed wywołaniem tej funkcji raport jest automatycznie otwierany w oknie edytora; menu edytora oferuje typowe funkcje umożliwiające założenie nowego pliku, otwarcie do edycji pliku istniejącego, zapisanie poprawionej zawartości pliku na dysk, usunięcie pliku oraz zakończenie edycji. Edytor wywoływany przy pomocy funkcji POPRAW może być również wywołany z menu NARZĘDZIA konstruktora i użyty na przykład do modyfikacji plików z opisem aplikacji (*.ini); w tym przypadku jednak nie jest automatycznie dokonywane otwarcie pliku, tak jak to jest przy poprawianiu definicji raportu. Jednocześnie może być poprawiany jedynie jeden raport; w przypadku konieczności wyświetlenia większej liczby raportów należy użyć funkcji ZOBACZ.

W systemie Windows 2000 / NT 4.0 moduł raportów, ze względu na kompatybilność z wersją DOS (polskie znaki, ramki..), używa czcionek w stronie kodowej 852. W związku z tym edytor raportów, wywołany funkcją POPRAW okna raportowego, wstawia polskie znaki w standardzie Latin-2. Należy o tym pamiętać i nie używać go do poprawiania innych plików tekstowych, co jest teoretycznie możliwe, dzięki funkcji edytora PLIK.OTWÓRZ. Jeżeli chcemy użyć edytora do poprawiania normalnych (windowsowych) plików tekstowych, należy edytor tekstowy wywołać przy pomocy komendy NARZĘDZIA.EDYTOR_TEKSTÓW... . Wówczas polskie znaki wstawiane będą w stronie kodowej 1250, właściwej dla systemu Windows. Rozwiązanie takie zapewnia przenoszalność definicji raportów pomiędzy wersjami A sixa dla systemów DOS, Windows 2000 / NT 4.0.

Okno edytora z definicją raportu zostało przedstawione poniżej.

Rysunek: Okno edytora definicji raportu.

ZOBACZ - umożliwia wyświetlenie definicji raportu bez możliwości poprawienia go. Służy do porównywania definicji raportów.

Grupa FUNKCJA zawiera dwie pozycje:

NOTATKA - pozwala na wprowadzenie tekstu notatki i wklejenie go do treści raportu w miejscu, gdzie umieszczono znacznik %remark% w instrukcji format.

Rysunek: Okno umożliwiające wprowadzenie do raportu treści notatki.

USTAW DATĘ - daje możliwość policzenia raportu za dzień, który nie figuruje na standardowej liście dat obliczania raportu.

Rysunek: Okno umożliwiające ustawienie daty wyliczania raportu.


13.1.1. Drukowanie raportów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.1. Obsługa raportów > 13.1.1.1. Drukowanie raportów

13.1.1.1. Drukowanie raportów

Raporty mogą być drukowane przy pomocy:

  • funkcji DRUKUJ okna raportów,

  • funkcji DRUKUJ dodanej do menu umieszczonego pod przyciskiem systemowym okna służącego do wyświetlania raportów (RAPORTER/Raport/Wyświetl). Funkcja ta posiada dwa warianty:

  • drukowanie kopii ekranu lub okna (funkcja KOPIUJ EKRAN),

  • drukowanie raportu w postaci tekstowej (funkcja DRUKUJ TEKST).

Rysunek: Menu okna wyświetlania raportów.

Funkcja DRUKUJ TEKST drukuje raport w takiej postaci, w jakiej jest on przechowywany na dysku oraz wyświetlany w oknie prezentacji raportu. Zawiera on jedynie treść raportu. Nie są używane instrukcje formatujące.

Drukowanie raportów przy pomocy funkcji DRUKUJ w menu RAPORT okna raportowego wykorzystuje instrukcje sterujące formatem wydruku. W tym trybie raporty nie są wyświetlane na ekranie. Podstawowym trybem wydruku raportów w aktualnej wersji oprogramowania jest tryb graficzny z wykorzystaniem wszystkich mechanizmów udostępnianych przez system Windows. Sposób formatowania wydruku jest niezależny od użytej drukarki. Treść raportu jest automatycznie skalowana, aby dopasować go do szerokości kartki. Można dodatkowo formatować wydruk przy pomocy znaczników PRINT-XXXX języka Aster.

Starsze wersje systemu drukowały raporty w trybie tekstowym. Formatowanie odbywało się poprzez wysyłanie do drukarki właściwych dla niej kodów sterujących, o ile zostały one zdefiniowane w pliku inicjującym oraz użyte w definicji raportu przy pomocy instrukcji ctrl. Różne typy drukarek mogą wymagać stosowania różnych kodów sterujących dla tej samej funkcji. Z tego powodu przy przenoszeniu aplikacji na system komputerowy wyposażony w drukarkę innego typu należało zadbać o wpisanie w pliku inicjującym odpowiednich kodów sterujących dla odpowiednich funkcji. W przypadku konieczności zachowania zgodności z aplikacją wykonaną dla wcześniejszych wersji systemu Asix, należy włączyć tryb wydruku tekstowego poprzez parametr Raporty w trybie tekstowym:

Architekt > Obszary i komputery > moduł Wydruk > zakładka Wydruk raportów


13.1.2. Obsługa dialogów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.1. Obsługa raportów > 13.1.1.2. Obsługa dialogów

13.1.1.2. Obsługa dialogów

Korzystając z komendy DIALOGI w menu NARZĘDZIA Panelu Kontrolnego lub Okna Konstruktora. Użytkownik ma możliwość obliczania pewnych nietypowych parametrów i wskaźników, wykorzystywanych sporadycznie. Korzystając z okna wyświetlanego po wybraniu komendy, użytkownik może:

  • tworzyć i obliczać wyrażenia języka ASTEL,

  • wyświetlać i modyfikować momenty początkowe i końcowe,

  • sprawdzać przyczyny powstałych podczas wartościowania błędów,

  • poprawiać poprzednio wprowadzone wyrażenia.

Szczegóły omawiające możliwości funkcjonalne okna 'Panel dialogowy’ znajdują się w rozdziale 9.9. Użycie wyrażeń.


13.1.3. Akcje operatorskie

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.1. Obsługa raportów > 13.1.1.3. Akcje operatorskie

13.1.1.3. Akcje operatorskie

LICZ_RAPORT

POKAŻ_RAPORT

PISZ_RAPORT

RAPORTUJ


13.2. Projektowanie raportów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów

13.1.2. Projektowanie raportów

W systemie Asix zaprojektowanie raportu sprowadza się do zapisania definicji raportu w języku definiowania raportów ASTER. Zapisana w tym języku definicja jest interpretowana przez program. Wynikiem interpretacji jest zapisanie raportu w odpowiednio sformatowanym pliku na dysku. Obliczenie raportu dokonuje się na skutek interpretacji szeregu definiujących raport formuł, zapisanych w instrukcji record. Formuły te zapisane są w języku ASTEL, który pozwala na definiowanie wyrażeń arytmetycznych wykorzystujących wartości zmiennych procesowych.

W dalszej części rozdziału opisany zostanie sposób tworzenia raportów. W celu uproszczenia opisu nie będzie jednak podawana szczegółowa składnia użytych konstrukcji języków ASTER i ASTEL. W razie pojawienia się niejasności w trakcie analizy przykładowych raportów, można poszukać bardziej szczegółowych informacji w odpowiednich podrozdziałach tematycznych umieszczonych bezpośrednio po rozdziale bieżącym.

Pewna grupa instrukcji musi wystąpić w każdej definicji raportu. Inne instrukcje są opcjonalne. Do grupy pierwszej należy instrukcja name określająca nazwę raportu wyświetlaną przy pomocy menu okna raportów, definiująca formuły instrukcja record lub symbol oraz określająca wygląd raportu instrukcja format.

W związku z powyższym definicja raportu powinna mieć następującą postać (w komentarzu podano opcjonalne instrukcje lub grupy instrukcji).

name <nazwa>

record <argumenty> / lub symbol <argumenty>

{inne instrukcje}

format <argumenty>

Kolejność występowania poszczególnych instrukcji jest dowolna. Od reguły tej istnieje jeden wyjątek w postaci instrukcji format, która powinna wystąpić po instrukcji record, a także po instrukcjach header, symbol, delimiter i marker, o ile takie w definicji występują. W związku z tym zwykle występuje jako ostatnia.


13.2.1. Najprostszy raport

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów > 13.1.2.1. Najprostszy raport

13.1.2.1. Najprostszy raport

Poznawszy poprzednio podane informacje można przystąpić do definiowania pierwszych, najprostszych raportów. Raport powinien zawierać minimum trzy instrukcje - name, record oraz format. Pierwsza z nich służy do nazwania raportu nazwą, która umożliwi potem jego identyfikację. Z kolei instrukcja record specyfikuje listę formuł definiujących wyrażenia do policzenia wraz z informacjami o formacie wyprowadzanych liczb (szerokości pól, liczbie miejsc po przecinku, stylu). W najprostszym przypadku lista taka jest jednoelementowa, zaś wyrażenie może być bardzo proste (np. stała). Instrukcja format określa postać raportu (nagłówki, ramki etc.).

Przykład

Definicja najprostszego raportu może w związku z tym być następująca:

name "prosty" {wpisanie "prosty" do menu}
record '1':1; {obliczenie formuły '1'}
format "%r0%"; {wpisanie 1 do raportu}

W wyniku wykonania takiej definicji obliczona zostanie formuła '1'. Jej rezultat (liczba 1) zostanie następnie wpisany do pliku raportowego. Otrzymamy raport składa się jedynie z jednej cyfry i nie zależy w ogóle od stanu zmiennych procesowych.


13.2.2. Pliki

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów > 13.1.2.2. Pliki

13.1.2.2. Pliki

Zarówno definicje raportów jak i raporty zapisywane są w plikach dyskowych. Pliki z definicjami powinny posiadać rozszerzenie *.r. Pliki z raportami posiadają nazwę identyczną z nazwą pliku definiującego różnią się jedynie rozszerzeniami. Każdej definicji może odpowiadać wiele plików z raportami, jako że definicja określa raport z dokładnością do dnia jego rozpoczęcia. W związku z tym pliki z raportami posiadają różne rozszerzenia, umożliwiające określenie dnia, do którego odnosi się raport. Przykładowo, jeśli prezentowane poprzednio definicja prostego raportu umieszczona będzie w pliku o nazwie prosty.r , wtedy odpowiednie raporty znajdą się w plikach prosty.nnn, gdzie nnn będzie określało datę raportu ustaloną przed jego wykonaniem (nawet jeśli zawartość raportu nie zależy od tego). Pliki zawierające raporty i ich definicje przechowywane są w tej samej kartotece.

Datę raportu można ustalić na podstawie rozszerzenia pliku. Kolejne znaki rozszerzenia pliku oznaczają odpowiednio rok - 1990, miesiąc oraz dzień. Dla oznaczenia liczb większych od 9 zastosowano kolejne litery począwszy od litery 'a'.

Przykład

raport.111 - 1 (1) stycznia (1) 1991 (1) roku

raport.54b - 11 (b) kwietnia (4) 1995 (5) roku

raport.bbb - 11 (b) listopada (b) 2001 (b) roku


13.2.3. Opisy pól

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów > 13.1.2.3. Opisy pól

13.1.2.3. Opisy pól

We wszystkich raportach, po formułach występujących w instrukcji record i symbol lub łańcuchach występujących w instrukcji header, input i symbol, wystąpić mogą opisy pól. Zostaną one omówione w tym miejscu. Każdy opis pola może składać się z sekwencji maksymalnie dwóch liczb poprzedzonych dwukropkami, po których opcjonalnie może wystąpić jedna z liter L, R, C lub Z poprzedzona znakiem minus (tzw. styl). Oznaczają one:

  • styl precyzuje umieszczenie znaków w polu (L-uzupełnienie spacjami z lewej strony, R-z prawej strony, C-z obu stron, Z-uzupełnianie zerami z lewej strony);

  • pierwsza liczba określa szerokość pola przeznaczonego na łańcuch lub liczbę; jeżeli długości łańcucha lub liczby są mniejsze od podanej szerokości pola, wówczas są uzupełniane spacjami do wymaganej szerokości pola; uzupełnianie następuje w zależności od wybranego stylu z lewej strony (L), z prawej strony (R) lub po obu stronach (C); w przypadku liczb możliwe jest dopisywanie nieznaczących zer z lewej strony (Z); jeżeli długość łańcucha przekracza maksymalną szerokość pola, wówczas jest on obcinany; jeżeli liczba nie mieści się w wyspecyfikowanym polu, wówczas zastępowana jest ciągiem znaków "?FRM" oznaczającym błąd formatu; komunikat o błędzie również może być obcięty do wymaganej szerokości pola;

  • brak szerokości pola w przypadku łańcucha powoduje wyprowadzenie go w podanej postaci, bez uzupełniania lub obcinania; brak podania szerokości w przypadku formuł powoduje brak wyprowadzenia liczby, ale formuła jest wartościowana; może to być praktycznie wykorzystane w przypadku podstawienia wartości formuły do zmiennej pomocniczej, która nie musi być wyprowadzana, ale zostanie wykorzystywana do obliczenia innych formuł;

  • druga liczba oznacza liczbę znaków po przecinku, jaka ma być wyprowadzona; pominięcie drugiej liczby oznacza wyprowadzanie części całkowitej; jeśli suma liczby miejsc po przecinku oraz liczby miejsc przed przecinkiem plus jeden (pozycja kropki) jest większa od szerokości pola, to powoduje błąd; w przypadku łańcuchów druga liczba określa ile znaków na być wyprowadzanych; jej pominięcie powoduje wyprowadzenie całego łańcucha, o ile mieści się w podanym polu.

Istnieje możliwość modyfikowania standardowych formatów oznaczanych literami L, R, C oraz Z przez dodanie deklaracji dodatkowych zawartych w grupie znaków sterujących wydrukiem ostrzeżeń. Można po znaku oznaczającym styl tj. L, R, C, Z, umieścić znaki sterujące wydrukiem w przypadku wystąpienia błędu lub ostrzeżenia określonego typu. Dopuszczalne są znaki:

- F - odwołanie w przyszłość,

- H - wystąpiła dziura,

- B - wystąpiło cofnięcie czasu,

- N - brak danych (ale zmienna jest zadeklarowana),

- R - nastąpił brak odpowiedzi archiwum.

Umieszczenie wymienionych znaków powoduje, że znak "?" informujący o błędzie nie zostanie wyświetlony razem z wartością. Modyfikatory znaków oznaczających styl można łączyć. Dla zwiększenia czytelności zaleca się pisanie modyfikatorów małą literą dla oddzielenia ich wizualnie od znacznika stylu. Ilustruje to poniższy przykład.

Przykład

Jeśli zostanie zadeklarowany format:

:8:3-Lfh,

to, w przypadku wystąpienia dziury w danych archiwalnych lub odwołania w przyszłość, nie będzie wyprowadzany znak ? wraz z liczbą, a jeśli dodatkowo miał być wyprowadzany ciąg 0? - to zamiast niego zostanie wyprowadzone puste miejsce.


13.2.4. Definicje raportów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów > 13.1.2.4. Definicje raportów

13.1.2.4. Definicje raportów

Formatowanie raportów | Raporty alarmowe
Raport z ramką | Raport "post mortem"
Raport z ramką i nagłówkiem | Raporty z polami wprowadzanymi
Okres raportu | Raporty eksportowane
Raport jednej zmiennej | Raport eksportowany w formacie "delimited with"
Stosowanie zmiennych | Raporty o nieznanej liczbie wierszy
Raport ze zmiennymi | Raport o przekroczeniach
Formuły globalne |
Raport z formułami globalnymi |

Na podstawie jednego z poprzednich rozdziałów wiadomo już - jak można zdefiniować najprostszy raport. Przedstawiony tam raport obejmował pojedynczą liczbę zapisaną do pliku. Zwykle jednak raporty są znacznie bardziej skomplikowane. Najczęściej mają postać tabeli złożonej z pewnej liczby wierszy i określonej liczby kolumn. Kolejne wiersze odpowiadają kolejnym okresom czasu, zaś kolejne kolumny wybranym wskaźnikom technologicznym. Tabela zwykle opatrzona jest tytułem, legendą, nazwiskiem operatora itp. Język definiowania raportów ASTER umożliwia tworzenie takich raportów. Możliwości te zostaną teraz kolejno omówione.

Formatowanie raportów

Dzięki zastosowaniu instrukcji format możliwe jest tworzenie ramek, opisów, legendy itp. Wyprowadzanie kolejnych wierszy raportów sterowane jest zawartością kolejnych linii tej instrukcji. Linie poddawane są interpretacji. Każda linia instrukcji format składać się może ze zwykłych znaków lub znaczników. Znaki wpisywane są do raportu. Po napotkaniu znacznika wykonywana jest pewna akcja. Może to być na przykład wartościowanie formuły z instrukcji record i wpisanie wyniku do raportu. Aby było to możliwe, każdej kolejnej formule z instrukcji record przypisywany zostaje podczas interpretacji znacznik %rN% (gdzie N jest numerem formuły licząc od zera). W podobny sposób mogą być wykorzystane łańcuchy zadeklarowane w instrukcji header. Odwołać się do nich można poprzez znaczniki %hN%. W instrukcji format tylko jedna linia może zawierać znaczniki %rN% i jest ona interpretowana wielokrotnie (count razy). Przykłady ilustrują jak dodać ramkę do raportu z wykorzystaniem lub bez wykorzystania instrukcji header.

Przykład

Raport z ramką

Zdefiniowane są trzy zmienne procesowe A, B oraz C, dla których należy wyprowadzić w raporcie ich wartości średnie za trzy kolejne godzinowe okresy od ustalonego momentu. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Dodatkowo należy opisać zmienne A, B i C oznaczające odpowiednio ciśnienie, temperaturę oraz objętość i odpowiadający każdemu z wierszy czas. Raport otoczyć ramką.

name "ramka" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

record

{%r0%}'hour btime':8-c, / znacznik %r0% godzina rozpoczęcia

{%r1%}'avg a':8:3-c, / znacznik %r1% obliczenie średniej A

{%r2%}'avg b':8:3-c, / znacznik %r2% obliczenie średniej B

{%r3%}'avg c':8:3-c; / znacznik %r3% obliczenie średniej C

Format

"+-----------------------------------+",

"¦ godz. ¦ ciśn. ¦ temp. ¦ obj. ¦",

"+--------+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦%r3%¦", / interpretowane count razy

"+-----------------------------------+";

W przykładzie nie wykorzystano instrukcji header. Po obliczeniu raportu o podanej definicji powstać może raport o postaci:

+-----------------------------------+
¦ godz. ¦ ciśn. ¦ temp. ¦ obj. ¦
+--------+--------+--------+--------¦
¦ 12 ¦ 15.300 ¦ 88.000 ¦ 33.333 ¦
¦ 13 ¦ 16.850 ¦ 91.500 ¦ 29.200 ¦
¦ 14 ¦ 13.333 ¦ 92.245 ¦ 21.880 ¦
+-----------------------------------+

Przykład

Raport z ramką i nagłówkiem

Zdefiniowane są trzy zmienne procesowe A, B oraz C, dla których należy wyprowadzić w raporcie ich wartości średnie za trzy kolejne godzinowe okresy od ustalonego momentu. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Dodatkowo należy opisać zmienne A, B i C oznaczające odpowiednio: ciśnienie, temperaturę i objętość oraz odpowiadający każdemu z wierszy czas. Raport otoczyć ramką. Wykorzystać definicję nagłówka. Odpowiednia definicja raportu może być następująca:

{Definicja raportu z ramką i nagłówkiem}

name "ramka2" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

header

{%h0%}"godz.":8-c, / znacznik %h0% opis czasu

{%h1%}"ciśn.":8-c, / znacznik %h1% opis zmiennej A

{%h2%}"temp.":8-c, / znacznik %h2% opis zmiennej B

{%h3%}"obj." :8-c; / znacznik %h3% opis zmiennej C

record

{%r0%}'hour btime':8-c, / znacznik %r0% godzina rozpoczęcia

{%r1%}'avg a':8:3-c, / znacznik %r1% obliczenie średniej A

{%r2%}'avg b':8:3-c, / znacznik %r2% obliczenie średniej B

{%r3%}'avg c':8:3-c; / znacznik %r3% obliczenie średniej C

format

"+-----------------------------------+",

"¦%h0%¦%h1%¦%h2%¦%h3%¦",

"+--------+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦%r3%¦", / interpretowane count razy

"+-----------------------------------+";

W przykładzie wykorzystana została instrukcja header. Po obliczeniu raportu powstanie raport identyczny jak w przykładzie poprzednim.

Okres raportu

Okres, do którego odnosi się raport, wyznaczany jest przy pomocy instrukcji begin step i count. Instrukcja step określa przedział czasu odpowiadający jednemu wierszowi raportu. Jej argument może precyzować okresy od sekundowych do wielodniowych (uwaga: wydłuża się wtedy czas obliczeń). Okres raportu wyznacza się jako iloczyn liczby wierszy (określonej instrukcją count) oraz kwantu czasu przyporządkowanego wierszowi.

Moment początkowy dla pierwszego wiersza raportu ustala się dodając do jego momentu rozpoczęcia, który ustawiany jest w oknie dialogowym raportów, czas określony instrukcją begin. Moment końcowy dla pierwszego wiersza określany jest przez dodanie do momentu początkowego okresu zdefiniowanego w instrukcji step. Dla każdego następnego wiersza momentem początkowym staje się moment końcowy z poprzedniego wiersza, zaś nowy moment końcowy wyznaczany jest analogicznie jak w przypadku wiersza pierwszego. Tak ustalone momenty noszą nazwę momentów domyślnych i są wykorzystywane do określenia okresów wykorzystywanych przy wartościowaniu.

Opisana sytuacja ma miejsce, jeżeli w formułach nie podano nigdzie w sposób jawny momentów początkowych oraz końcowych dla występujących w nich ewaluatorów. Nie jest to jednak konieczne - użytkownik może wpisywać dowolne momenty absolutne i relatywne uzyskując w ten sposób możliwość tworzenia raportów, dla których w jednym wierszu mogą występować różne okresy czasu, związane lub nie z okresem domyślnym. Wyjaśnione to zostanie na przykładach.

Przykład

Raport jednej zmiennej

Zdefiniowana jest zmienna procesowa A (temperatura), dla której należy wyprowadzić w raporcie jej wartości średnie. Powinny one obejmować okresy 15-minutowe (kwadrans). W każdym wierszu należy wyprowadzić średnie za cztery kolejne kwadranse. Kolejne wiersze powinny obejmować trzy kolejne godzinowe okresy od ustalonego momentu. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Właściwa definicja raportu może być następująca

{Definicja raportu 1-zmiennej}

name "1-zmienna" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

record

{%r0%}'hour btime':8-c, / godzina rozpoczęcia

{%r1%}'avg(a,@,<0\45)':8:3-c, / obliczenie za pierwszy kwadrans

{%r2%}'avg(a,>0\15,<0\30)':8:3-c, / obliczenie za drugi kwadrans

{%r3%}'avg(a,>0\30,<0\15)':8:3-c, / obliczenie za trzeci kwadrans

{%r4%}'avg(a,>0\45)':8:3-c; / obliczenie za czwarty kwadrans

Format

"+--------------------------------------------+",

"¦ godz. ¦ 1-kw. ¦ 2-kw. ¦ 3-kw. ¦ 4-kw. ¦",

"+--------+--------+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦%r3%¦%r4%¦", / interpretowane count razy

"+--------------------------------------------+";

W przykładzie tym podział domyślnego 1-godzinnego okresu na 4 kwadranse uzyskany został poprzez zastosowanie momentów względnych, przesuwających moment początkowy i końcowy dla każdego ewaluatora średniej. Po obliczeniu raportu o podanej definicji powstać może raport o postaci:

+--------------------------------------------+
¦ godz. ¦ 1-kw. ¦ 2-kw. ¦ 3-kw. ¦ 4-kw. ¦
+--------+--------+--------+--------+--------¦
¦ 12 ¦ 15.300 ¦ 15.900 ¦ 15.500 ¦ 15.200 ¦
¦ 13 ¦ 15.100 ¦ 15.000 ¦ 15.200 ¦ 15.000 ¦
¦ 14 ¦ 15.300 ¦ 15.500 ¦ 15.800 ¦ 15.400 ¦
+--------------------------------------------+

Możliwe jest także wprowadzanie okresów typu "od początku dnia do momentu domyślnego", "od momentu domyślnego do określonego momentu", "od określonego momentu przez ustalony okres", itp.

Stosowanie zmiennych

Cenne możliwości w przypadku tworzenia raportów, których niektóre kolumny są zależne od pozostałych, daje możliwość stosowania zmiennych. Przy ich pomocy można zapamiętywać pewne wielkości potrzebne do obliczeń w różnych kolumnach. Zostanie to zilustrowane przykładem.

Przykład

Raport ze zmiennymi

Zdefiniowane są dwie zmienne procesowe P oraz Q, oznaczające odpowiednio moc czynną i bierną. W raporcie należy wyprowadzić ich wartości średnie za trzy kolejne okresy godzinowe od ustalonego momentu. Dodatkowo w następnej kolumnie należy wyznaczyć średnią wartość mocy pozornej S. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Należy opisać zmienne oraz czas. Definicja odpowiedniego raportu może być następująca:

{Definicja raportu ze zmiennymi}

name "ze zmienną" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

record

{%r0%} 'hour btime':8-c, / znacznik %r0% godzina rozpoczęcia

{%r1%} 'p=avg p':8:3-c, / znacznik %r1% obliczenie średniej P

{%r2%} 'q=avg q':8:3-c, / znacznik %r2% obliczenie średniej Q

{%r3%} 's=sqrt(p^2+q^2)':8:3-c; / znacznik %r3% obliczenie zmiennej S

Format

"+-----------------------------------+",

"¦ godz. ¦ P[W] ¦ Q[VAr] ¦ S[VA] ¦",

"+--------+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦%r3%¦", / interpretowane count razy

"+-----------------------------------+";

Po obliczeniu raportu o podanej definicji powstać może raport o postaci:

+-----------------------------------+
¦ godz. ¦ P[W] ¦ Q[VAr] ¦ S[VA] ¦
+--------+--------+--------+--------¦
¦ 12 ¦ 10.000 ¦ 2.000 ¦ 10.198 ¦
¦ 13 ¦ 12.000 ¦ 2.500 ¦ 12.258 ¦
¦ 14 ¦ 13.000 ¦ 2.500 ¦ 13.238 ¦
+-----------------------------------+

Obliczanie mocy pozornej można było w powyższym przykładzie zrealizować bez korzystania ze zmiennych. Wystarczyłoby wpisać:

sqrt((avg p)^2+(avg q)^2)

Powodowałoby to jednak konieczność dwukrotnego obliczenia średniej zmiennych P oraz Q co w efekcie prowadzi do mniej więcej dwukrotnego zwiększenia czasu obliczania raportu.

Dla przedstawionego układu kolejność wartościowania jest taka jak kolejność formuł w instrukcji record to znaczy najpierw oblicza się wartość P, potem Q a następnie S dla okresu od 12-tej do 13-tej (a następnie dla okresów kolejnych).

Formuły globalne

W raportach istnieje możliwość wprowadzania wierszy zawierających wyniki formuł nie występujących w instrukcji record. Wiersze takie nie są interpretowane count razy. Do ich definiowania wykorzystywana jest instrukcja symbol, umożliwiająca deklarowanie globalnych formuł i łańcuchów. Domyślne momenty początkowe i końcowe dla formuł zadeklarowanych w instrukcji symbol, to momenty rozpoczęcia i zakończenia raportu. Wykorzystanie instrukcji symbol do deklarowania łańcuchów daje możliwość deklarowania dla nich stylu i szerokości pola. Elementom deklarowanym przy pomocy instrukcji symbol przyporządkowywane są znaczniki %sN%. Użycie formuł globalnych wyjaśnia przykład.

Przykład

Raport z formułami globalnymi

Zdefiniowane są trzy zmienne procesowe A, B oraz C, dla których należy wyprowadzić w raporcie ich wartości średnie za trzy kolejne godzinowe okresy od ustalonego momentu. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Dodatkowo należy opisać zmienne A, B i C oznaczające odpowiednio ciśnienie, temperaturę i objętość oraz odpowiadający każdemu z wierszy czas. W ostatnim wierszu raportu wyprowadzić wartości wariancji zmiennych A, B i C dla całego (trzygodzinnego) okresu. Definicja raportu może być następująca:

{Definicja raportu z formułami globalnymi}

name "formuła" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

symbol

{%s0%}"war.":8-c, / znacznik %s0% opis

{%s1%}'var a':8:3-c, / znacznik %s1% obliczenie wariancji A

{%s2%}'var b':8:3-c, / znacznik %s2% obliczenie wariancji B

{%s3%}'var c':8:3-c; / znacznik %s3% obliczenie wariancji C

record

{%r0%}'hour btime':8-c, / znacznik %r0% godzina rozpoczęcia

{%r1%}'avg a':8:3-c, / znacznik %r1% obliczenie średniej A

{%r2%}'avg b':8:3-c, / znacznik %r2% obliczenie średniej B

{%r3%}'avg c':8:3-c; / znacznik %r3% obliczenie średniej C

Format

"+-----------------------------------+",

"¦ godz. ¦ ciśn. ¦ temp. ¦ obj. ¦",

"+--------+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦%r3%¦", / interpretowane count razy

"+--------+--------+--------+--------¦",

"¦%s0%¦%s1%¦%s2%¦%s3%¦", / interpretowane jeden raz

"+-----------------------------------+";

Po obliczeniu raportu o podanej definicji powstać może raport o postaci:

+-----------------------------------+
¦ godz. ¦ ciśn. ¦ temp. ¦ obj. ¦
+--------+--------+--------+--------¦
¦ 12 ¦ 15.300 ¦ 88.000 ¦ 33.333 ¦
¦ 13 ¦ 16.850 ¦ 91.500 ¦ 29.200 ¦
¦ 14 ¦ 13.333 ¦ 92.245 ¦ 21.880 ¦
+--------+--------+--------+--------¦
¦ war. ¦ 0.333 ¦ 2.240 ¦ 8.800 ¦
+--------+--------+--------+--------+

Raporty alarmowe

Pewne typy raportów obliczane są okresowo. Inne raporty mogą być obliczane w sytuacjach wyjątkowych (awarie, rozruchy). Od raportu wymaga się wówczas, aby obejmował określony okres przed wystąpieniem zdarzenia (np. awarii). Raporty tego typu określane są czasem nazwą "post mortem". Bywają one implementowane jako szczególny rodzaj raportów, które możliwe są do uzyskania jednorazowo po wystąpieniu awarii. W systemie Asix mogą one być liczone wielokrotnie, a nawet definiowane już po wystąpieniu awarii. Okres raportowania może być ustawiany indywidualnie dla każdej liczonej w raporcie formuły. Ilustruje to przykład.

Przykład

Raport "post mortem"

Zdefiniowane są trzy zmienne procesowe A, B oraz C, dla których należy wyprowadzić w raporcie ich wartości maksymalne w okresach poprzedzających awarię (policzenie raportu). Okresy te dla zmiennych A, B i C wynoszą odpowiednio 30, 60 i 90 minut. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Dodatkowo należy opisać zmienne A, B i C oznaczające odpowiednio ciśnienie, temperaturę i objętość. Definicja raportu może być następująca:

{Definicja raportu alarmowego}

name "post mortem" / nazwa

record

{%r0%}'max(a,&,&0\30)':8:3-c, / znacznik %r0% obliczenie maksimum A

{%r1%}'max(b,&,&1)':8:3-c, / znacznik %r1% obliczenie maksimum B

{%r2%}'max(c,&,&1\30)':8:3-c; / znacznik %r2% obliczenie maksimum C

Format

"+--------------------------+",

"¦ awaria ¦ %date% %time% ¦",

"+--------+-----------------¦",

"¦ ciśn. ¦ temp. ¦ obj. ¦",

"+--------+--------+--------¦",

"¦%r0%¦%r1%¦%r2%¦",

"+--------------------------+";

Po obliczeniu raportu o podanej definicji, jeśli na przykład awaria miała miejsce 15 lipca 1993 roku o godzinie 15:20, powstać może raport o postaci:

+--------------------------+
¦ awaria ¦ 15-07-93 15:20 ¦
+--------+-----------------¦
¦ ciśn. ¦ temp. ¦ obj. ¦
+--------+--------+--------¦
¦ 25.300 ¦ 98.000 ¦ 23.700 ¦
+--------------------------+

W raporcie użyto znaczników %date% i %time%.

W typowych sytuacjach raport alarmowy liczony może być ręcznie przez operatora, po naciśnięciu odpowiedniego klawisza (obiekt PRZYCISK) lub automatycznie dzięki wykorzystaniu terminarza zdarzeniowego.

Raporty z polami wprowadzanymi

Często zachodzi potrzeba umieszczenia w treści raportu pewnych dodatkowych informacji, które nie są pamiętane w systemie (numery zamówień, symbole wyrobów, identyfikatory klientów). Dane te mogą być wpisywane do raportu podczas jego tworzenia przez operatora. Wykorzystuje się do tego celu instrukcję input. Elementom deklarowanym przy pomocy instrukcji symbol przyporządkowuje się znaczniki %iN%. Każdy element deklarowany przez instrukcję input zawiera pytanie wyprowadzane podczas interpretacji znacznika (może być puste) oraz specyfikację pola mieszczącego odpowiedź. Użycie pól wprowadzanych wyjaśnia przykład.

Przykład

Raport z polami wprowadzanymi

Zdefiniowane są dwie zmienne procesowe A i B dla których należy wyprowadzić w raporcie ich wartości średnie za trzy kolejne godzinowe okresy (od ustalonego momentu). Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Dodatkowo należy opisać zmienne A i B oznaczające odpowiednio prędkość i temperaturę oraz odpowiadający każdemu z wierszy czas. Dodatkowo każdy wiersz powinien zawierać wprowadzony przez operatora materiał zaś cały raport numer serii produkcyjnej. Definicja raportu może być następująca:

{Definicja raportu z polami wprowadzanymi}

name "wprowadzany" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

input

{%i0%}"podaj numer serii ?":8, / znacznik %i0% wprowadzenie numeru

{%i1%}"podaj materiał ?":8-c; / znacznik %i1% wprowadzenie materiału

record

{%r0%}'hour btime':8-c, / znacznik %r0% godzina rozpoczęcia

{%r1%}'avg a':8:3-c, / znacznik %r1% obliczenie średniej A

{%r2%}'avg b':8:3-c; / znacznik %r2% obliczenie średniej B

Format

"+-----------------------------------+",

"¦ Numer serii %i0% ¦",

"+-----------------------------------+",

"+-----------------------------------+",

"¦ godz. ¦ mat. ¦ prąd. ¦ temp. ¦",

"+--------+--------+--------+--------¦",

"¦%r0%¦%i1%¦%r2%¦%r3%¦",

"+-----------------------------------+";

Po obliczeniu raportu o podanej definicji (jeśli przykładowo kolejne odpowiedzi operatora będą następujące: "Z2511", "stal", "stal", "cynk") powstać może raport o postaci:

+-----------------------------------+
¦ Numer serii Z2511 ¦
+-----------------------------------+
+-----------------------------------+
¦ godz. ¦ mat. ¦ prąd. ¦ temp. ¦
+--------+--------+--------+--------¦
¦ 12 ¦ stal ¦ 38.000 ¦ 33.333 ¦
¦ 13 ¦ stal ¦ 41.500 ¦ 29.200 ¦
¦ 14 ¦ cynk ¦ 12.245 ¦ 91.880 ¦
+-----------------------------------+

Raporty eksportowane

Często zachodzi potrzeba udostępnienia danych umieszczonych w raporcie innym programom (bazy danych, arkusze kalkulacyjne). Dane eksportowane są w postaci tekstowej i mogą być wczytywane do baz danych lub arkuszy kalkulacyjnych jako liczby bądź teksty. W przypadku eksportowania raportów z konwersją tekstów na liczby, zaleca się użycie instrukcji export. Powoduje ona wpisywanie w pola raportu tylko liczb w zapisie akceptowanym podczas konwersji. W związku z tym informacje o błędach (typu "?ARC") nie będą w ogóle wyprowadzane (odpowiadające im pola zostaną wypełnione spacjami). Zaniechana zostanie również zamiana kropki dziesiętnej na przecinek w sytuacji wystąpienia błędów niekrytycznych (w niektórych przypadkach uniemożliwia to konwersję). Możliwy jest również eksport raportów w postaci tekstowej. Wtedy jednak ewentualna późniejsza obróbka danych jest bardziej złożona (należy interpretować komunikaty o błędach oraz osobno konwertować liczby z przecinkiem).

W przypadku eksportowania danych do relacyjnych baz danych (dBase, FoxBase, Clipper, CodeBase) należy w zasadzie ograniczyć się do macierzy liczb. Do arkuszy kalkulacyjnych (Quattro) można eksportować również nagłówki oraz opisy, jednak ramki należy wykonać przy pomocy mechanizmów wbudowanych.

Poniżej zostanie podany przykład eksportowania raportów do baz danych typu dBase, FoxBase oraz Clipper. W tym przypadku raport powinien być wyprodukowany w formacie SDF (rekordy tekstowe o stałej długości zakończone znakami CR-LF) lub jako rekordy z poszczególnymi polami rozdzielanymi przy pomocy zadeklarowanych ograniczników (DELIMITED WITH).

W drugim przypadku opis pól raportu nie musi być zgodny z opisem pól rekordu w bazie danych. Wymagane jest jedynie, aby pola rekordu bazy danych miały wystarczającą szerokość do pomieszczenia odpowiedniej wartości raportu. Ilustruje to przykład.

Przykład

Raport eksportowany w formacie "delimited with"

Zdefiniowane są trzy zmienne procesowe A, B oraz C, dla których należy wyprowadzić w raporcie ich wartości średnie za trzy kolejne godzinowe okresy od ustalonego momentu. Dla wszystkich liczb przyjmuje się 6 pozycji i 3 cyfry po przecinku. Dodatkowo należy dopisać odpowiadający każdemu z wierszy czas. Raport powinien być eksportowany do bazy danych (dBase). Poszczególne pola powinny być rozdzielone znakiem przecinka. Odpowiednia definicja raportu przedstawiona została na następnej stronie.

{Definicja raportu eksportowanego w formacie "delimited with"}

name "eksport delimited" / nazwa

begin 12 / początek raportu o 12-tej

step 1 / okres 1-godzinny (wartość domyślna)

count 3 / trzy wiersze

export / konwersja na liczby

record

{%r0%}'hour btime':3-r, / godzina rozpoczęcia

{%r1%}'avg a':7:3-r, / obliczenie średniej A

{%r2%}'avg b':7:3-r, / obliczenie średniej B

{%r3%}'avg c':7:3-r; / obliczenie średniej C

format

"%R0%,%R1%,%R2%,%R3%"; / ogranicznik - przecinek

Po obliczeniu raportu o podanej definicji powstać może raport o postaci:

12, 15.300, 88.000, 33.333
13, 16.850, 91.500, 29.200
14, 13.333, 92.245, 21.880

Powstały w ten sposób raport można wprowadzić do baz danych typu dBase przy pomocy instrukcji:

APPEND FROM <nazwa_raportu> DELIMITED WITH ,

Raporty o nieznanej liczbie wierszy

Dotychczas prezentowane przykłady raportów miały jedną wspólną cechę - stałą, deklarowaną z góry liczbę wierszy. Każdemu z wierszy odpowiadał stały przedział czasu. Nie zawsze jednak musi tak być. W niektórych przypadkach liczba wierszy oraz okres czasu przypadający na jeden wiersz mogą być zależne od przebiegu wykorzystywanych w raporcie zmiennych archiwalnych. Dzieje się tak w przypadku raportów, wykorzystujących formuły, które operują na przedziałach czasu wyznaczanych przez momenty przekroczeń limitów technologicznych. W sytuacji takiej do wyznaczenia momentów przekroczeń używane są ewaluatory over i under. Zwykle używane są one w formułach, które są wykonywane, aby przestawić odpowiednie momenty, ale ich wartości nie są wyprowadzane. Dodatkowo wiersz zawierający znaczniki typu %rN% powinien zawierać (zwykle na końcu) znacznik %next% powodujący ustawienie nowego momentu początkowego wyznaczoną wartością momentu końcowego oraz odtworzenie domyślnego momentu końcowego. Ilustruje to przykład.

Przykład

Raport o przekroczeniach

Zdefiniowana jest zmienna procesowa A (temperatura), dla której należy odnaleźć przedziały, w których przekraczała ona limit technologiczny 155 stopni. Poszukiwania przeprowadzać w zadanym godzinnym okresie rozpoczynającym się o godzinie 7-ej. Dla każdego odnalezionego w ten sposób przedziału należy wyprowadzić moment początkowy, moment końcowy, czas trwania oraz wartość maksymalną. Dodatkowo należy wprowadzić kolumnę zawierającą wartość maksymalną, wyprowadzaną w przypadku, jeśli znaleziony przedział mieści się całkowicie w zadanym okresie, lub zero w przypadku przeciwnym. Raport należy otoczyć ramką. Dla wszystkich liczb przyjmuje się pole o 8 pozycjach oraz 3 cyfry po przecinku. Czasy i okresy wyprowadzić jako godzina, minuta i sekunda. Odpowiednia definicja raportu może być następująca:

{Definicja raportu o przekroczeniach}

name "przekroczenia" / nazwa

begin 7 / początek o godzinie 7-ej

step 1 / okres 1 godziny

repeat / nieokreślona liczba wierszy

record

{%r0%}'p=155':8:2-c, / znacznik %r0% ustawienie limitu

{%r1%}'o=over>(a,p)', / znacznik %r1% moment początkowy

{%r2%}'u=under<(a,p)', / znacznik %r2% moment końcowy

{Powyższe 2 formuły nie wyprowadzają wyniku - są jedynie wartościowane}

{%r3%}'mx=max a':10:3-c, / znacznik %r3% szukanie maksimum

{%r4%}'o*u*mx':10:3-c; / znacznik %r4% maksimum x przedział

format

"+---------------------------------------------------------------+",

"¦ limit ¦ początek ¦ koniec ¦ maks. ¦ różn. ¦ maks-prz ¦",

"+--------+----------+----------+----------+----------+----------¦",

"¦%R0%¦%R1%%R2% %btime% ¦ %etime% ¦%R3%¦ %dtime% ¦%R4%¦%NEXT%",

"+---------------------------------------------------------------+";

W wyniku realizacji definicji takiego raportu może powstać raport przedstawiony w dalszej części. Należy zwrócić uwagę na postać ostatniego wiersza. Nie zawiera on danych o wykrytym przekroczeniu (maksimum jest niższe od limitu, a czas trwania przekroczenia zerowy).

W przykładzie formuły %r1% i %r2% są wartościowane bez wyprowadzania wyników.

Kolejność ich wartościowania określa postać odpowiedniej linii w instrukcji format. Znaczniki te muszą wystąpić w podanej kolejności przed znacznikiem %btime%.

+---------------------------------------------------------------+
¦ limit ¦ początek ¦ koniec ¦ maks. ¦ różn. ¦ maks-prz ¦
+--------+----------+----------+----------+----------+----------¦
¦ 155.00 ¦ 07:16:00 ¦ 07:18:00 ¦ 160,130 ¦ 00:02:00 ¦ 160.130 ¦
¦ 155.00 ¦ 07:22:00 ¦ 07:24:00 ¦ 155,004 ¦ 00:02:00 ¦ 155.004 ¦
¦ 155.00 ¦ 07:28:00 ¦ 07:34:00 ¦ 170,626 ¦ 00:06:00 ¦ 170.626 ¦
¦ 155.00 ¦ 07:42:00 ¦ 07:46:00 ¦ 162,571 ¦ 00:04:00 ¦ 162.571 ¦
¦ 155.00 ¦ 07:52:00 ¦ 07:56:00 ¦ 162,815 ¦ 00:04:00 ¦ 162.815 ¦
¦ 155.00 ¦ 07:56:00 ¦ 07:56:00 ¦ 146,704 ¦ 00:00:00 ¦ 0.000 ¦
+---------------------------------------------------------------+

Raporty o przekroczeniach w przypadku, kiedy w zadanym przedziale brak przekroczenia limitu, jak również w sytuacji kiedy wszystkie wartości w przedziale są powyżej limitu, produkują jeden wiersz raportu, na podstawie którego określić można badaną sytuację. Dla raportu prezentowanego poprzednio byłyby to za każdym razem wiersze o zerowej szerokości przedziału, z momentem początkowym równym końcowemu. W pierwszym przypadku (brak przekroczeń) obydwa momenty ustawione są na początku okresu, w przypadku drugim (cały przedział jest przekroczeniem) na końcu.


13.2.5. Raport przykładowy

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.2. Projektowanie raportów > 13.1.2.5. Raport przykładowy

13.1.2.5. Raport przykładowy

Poniżej zaprezentowany zostanie typowy (stosowany w praktyce) raport. Raport dotyczy pracy hutniczego pieca przepychowego do nagrzewania kęsisk, które następnie są walcowane. Piec taki podzielony jest na trzy strefy opalane gazem. Dla każdej strefy istotnymi parametrami są średnie zużycia gazu, średnie temperatury oraz stosunki objętości powietrza do gazu. Dodatkowo raport powinien zawierać średnią temperaturę kęsisk wychodzących z pieca oraz liczbę wygrzanych kęsisk. Raport powinien obejmować jedną dobę. W związku ze specyfiką pracy w hucie, każda doba (dzieląca się na trzy zmiany) rozpoczyna się i kończy o godzinie 22-ej (zmiany zaczynają się odpowiednio o 22-ej, 6-ej i 14-ej). Okres doby powinien zostać podzielony na 24 okresy jednogodzinne. Maksymalne zużycie gazu przez piec jest rzędu 6000 [m3/h]. Stosunek powietrze/gaz zależy od rodzaju gazu i waha się w granicach od 5 do 8 (powinien być wyprowadzany z dwoma miejscami po przecinku). Temperatury w poszczególnych strefach pieca w czasie pracy są rzędu od 1200 do 1300 [oC]. Temperatura kęsisk wychodzących z pieca jest zwykle o kilkadziesiąt stopni niższa niż temperatura w strefach. Podczas pracy z maksymalną wydajnością liczba kęsisk opuszczających piec nie przekracza 200 na godzinę (średnio jest o połowę mniejsza). Raport powinien zawierać datę rozpoczęcia raportu i nazwisko operatora.

name "dobowy" / nazwa raportu
begin 22 step 1 count 24
{raport 24 godzinny początek o 22-ej jeden wiersz odpowiada godzinie}
record
{%R0%} 'hour btime':2, / godzina początku przedziału
{%R1%} 'hour etime':2, / godzina końca przedziału
{%R2%} 'avg M67I2':4, / średnia zużycia gazu w strefie 1
{%R3%} 'avg M67I4':4, / średnia zużycia gazu w strefie 2
{%R4%} 'avg M67I6':4, / średnia zużycia gazu w strefie 3
{%R5%} 'avg PowGaz1':4:2, / średni stosunek powietrze/gaz w strefie 1
{%R6%} 'avg PowGaz2':4:2, / średni stosunek powietrze/gaz w strefie 2
{%R7%} 'avg PowGaz3':4:2, / średni stosunek powietrze/gaz w strefie 3
{%R8%} 'avg M75I4':4, / średnia temperatura w strefie 1
{%R9%} 'avg M75I5':4, / średnia temperatura w strefie 2
{%R10%} 'avg M75I6':4, / średnia temperatura w strefie 3
{%R11%} 'avg (M75I2,v)':4, / średnia temperatura wychodzących kęsisk
{%R12%} 'diff (cntLSW,v)':3; / liczba kęsisk
format
" HUTA ŁABĘDY Piec Przepychowy",
" Operator: %operator% Data: %bdate% ",
"+----------------------------------------------------------------------------+",
"¦ od-do ¦g1[m3]g2[m3]g3[m3]¦ p/g1 p/g2 p/g3 ¦t1[°C]t2[°C]t3[°C]¦tk[°C] lk ¦",
"+-------+------------------+------------------+------------------+-----------¦",
/"¦ xx-xx ¦ xxxx xxxx xxxx ¦ x.xx x.xx x.xx ¦ xxxx xxxx xxxx ¦ xxxx xxx ¦",
"¦ %R0%-%R1% ¦ %R2% %R3% %R4% ¦ %R5% %R6% %R7% ¦ %R8% %R9% %R10% ¦ %R11% %R12% ¦",
"+----------------------------------------------------------------------------+";

Raport zostanie zaprojektowany jako wyposażony w ramkę. Dla średniego zużycia gazu w strefie przyjęte zostało pole o szerokości czterech znaków (maksymalne średnie zużycie gazu na strefę wynosi około 2000 [m3/h]). Podobna szerokość pola została przyjęta dla temperatur. Liczba kęsisk będzie wyprowadzana w polu o szerokości trzech znaków. Dla stosunku powietrze/gaz przyjęte zostało czteroznakowe pole z dwoma znakami po przecinku. Okres wyprowadzany będzie jako godzina początku i końca rozdzielone kreską.

W przypadku wszystkich zmiennych, za wyjątkiem liczby kęsisk, obliczane są średnie godzinowe (zużycie gazu pamiętane jest w [m3/h]). Licznik kęsisk jest archiwizowany. Na podstawie jego zawartości, przy pomocy ewaluatora diff, liczona jest różnica stanu między końcem i początkiem przedziału. Definicja tego raportu przedstawiona jest na listingu.

Przykładowy raport zamieszczony został poniżej.

HUTA ŁABĘDY Piec Przepychowy
Operator: Marek Jabłoński Data: 20-06-992
+---------------------------------------------------------------------------+
¦ od-do ¦g1[m3]g2[m3]g3[m3]¦ p/g1 p/g2 p/g3 ¦t1[°C]t2[°C]t3[°C]¦tk[°C] lk ¦
+-------+------------------+------------------+------------------+-----------¦
¦ 22-23 ¦ 379 1079 536 ¦ 6,23 7,48 5,60 ¦ 1269 1274 1281 ¦ 1206 34 ¦
¦ 23- 0 ¦ 947 1429 371 ¦ 5,59 7,46 5,58 ¦ 1266 1261 1269 ¦ 1218 84 ¦
¦ 0- 1 ¦ 478 952 561 ¦ 6,24 7,52 5,57 ¦ 1268 1258 1259 ¦ 1179 4 ¦
¦ 1- 2 ¦ 158 546 701 ¦ 8,34 7,50 5,57 ¦ 1268 1252 1257 ¦ 1157 0 ¦
¦ 2- 3 ¦ 141 716 692 ¦ 8,36 7,46 5,59 ¦ 1278 1260 1272 ¦ 1178 30 ¦
¦ 3- 4 ¦ 915 1564 373 ¦ 5,55 7,22 5,60 ¦ 1265 1274 1277 ¦ 1220 48 ¦
¦ 4- 5 ¦ 1187 1618 338 ¦ 5,57 7,25 5,58 ¦ 1270 1274 1275 ¦ 1220 67 ¦
¦ 5- 6 ¦ 1113 1597 455 ¦ 5,62 7,16 5,56 ¦ 1259 1275 1271 ¦ 1206 46 ¦
¦ 6- 7 ¦ 498 1244 486 ¦ 5,55 7,48 5,59 ¦ 1273 1274 1276 ¦ 1203 0 ¦
¦ 7- 8 ¦ 929 1419 389 ¦ 5,60 7,36 5,57 ¦ 1276 1270 1274 ¦ 1212 5 ¦
¦ 8- 9 ¦ 593 1018 444 ¦ 5,60 7,48 5,59 ¦ 1274 1259 1276 ¦ 1201 0 ¦
¦ 9-10 ¦ 712 1228 415 ¦ 5,57 7,49 5,58 ¦ 1259 1255 1267 ¦ 1198 0 ¦
¦ 10-11 ¦ 729 1229 415 ¦ 5,59 7,49 5,61 ¦ 1259 1255 1265 ¦ 1195 15 ¦
¦ 11-12 ¦ 694 1301 397 ¦ 5,58 7,49 5,60 ¦ 1262 1260 1266 ¦ 1197 0 ¦
¦ 12-13 ¦ 991 1533 326 ¦ 5,56 7,20 5,60 ¦ 1258 1269 1266 ¦ 1210 7 ¦
¦ 13-14 ¦ 673 1228 631 ¦ 5,77 7,38 5,56 ¦ 1244 1257 1266 ¦ 1181 0 ¦
¦ 14-15 ¦ 213 727 691 ¦ 7,10 7,49 5,61 ¦ 1278 1259 1272 ¦ 1179 7 ¦
¦ 15-16 ¦ 983 1541 352 ¦ 5,58 7,27 5,57 ¦ 1272 1258 1271 ¦ 1216 26 ¦
¦ 16-17 ¦ 884 1346 452 ¦ 5,61 7,49 5,59 ¦ 1276 1260 1270 ¦ 1185 21 ¦
¦ 17-18 ¦ 412 1024 512 ¦ 5,58 7,48 5,61 ¦ 1274 1268 1272 ¦ 1191 28 ¦
¦ 18-19 ¦ 1014 1409 389 ¦ 5,61 7,47 5,58 ¦ 1276 1262 1269 ¦ 1204 6 ¦
¦ 19-20 ¦ 754 1256 431 ¦ 5,57 7,45 5,59 ¦ 1270 1257 1267 ¦ 1195 8 ¦
¦ 20-21 ¦ 773 1187 417 ¦ 5,58 7,49 5,58 ¦ 1274 1254 1266 ¦ 1195 5 ¦
¦ 21-22 ¦ 947 1369 414 ¦ 5,60 7,51 5,58 ¦ 1277 1256 1265 ¦ 1197 12 ¦
+----------------------------------------------------------------------------+


13.3. Język przetwarzania danych procesowych ASTEL

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.3. Język przetwarzania danych procesowych ASTEL

13.1.3. Język przetwarzania danych procesowych ASTEL

Do przetwarzania danych procesowych, zarówno archiwalnych (głównie), jak i bieżących, opracowany został specjalny język ASTEL. Umożliwia on obliczanie wyrażeń arytmetycznych zawierających dane procesowe. Obliczanie może być przeprowadzane interakcyjnie. Wyrażenia napisane w języku ASTEL mogą być również wykorzystywane do definiowania raportów przy pomocy omówionego w dalszej części języka ASTER.


13.3.1. Elementy języka

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.3. Język przetwarzania danych procesowych ASTEL > 13.1.3.1. Elementy języka

13.1.3.1. Elementy języka

Liczby | Ewaluatory
Zmienne | Ewaluatory operujące na danych archiwalnych
Momenty | Ewaluatory operujące na danych archiwalnych z określonym krokiem
Operatory | Ewaluatory czasu
Funktory | Ewaluatory przesuwające momenty początkowe i końcowe
Nawiasy | Ewaluatory operujące na danych bieżących
Przecinki | Ewaluator opowiednika
 | Czas jako argument ewaluatorów

Znak spacji (odstępu) służy jako separator elementów wyrażeń. Elementy wyrażeń muszą być rozdzielane spacjami tylko tam, gdzie ich brak powoduje niejednoznaczności składniowe. Długość pojedynczego wyrażenia ograniczona jest do 256 znaków. Duże i małe litery traktowane są jako tożsame (wyjątki zostaną osobno omówione). Elementami wyrażeń w języku ASTEL mogą być:

  • liczby,

  • zmienne,

  • momenty,

  • operatory,

  • funktory,

  • ewaluatory,

  • nawiasy,

  • przecinki.

Liczby

Liczbami są dowolne ciągi złożone z cyfr oraz kropki dziesiętnej. Dopuszczalne są zarówno liczby całkowite jak i zmiennoprzecinkowe (oprócz zapisu wykładniczego). W przypadku liczb zmiennoprzecinkowych puste części całkowite oraz ułamkowe są dopuszczalne.

Przykłady

1

1.2345

33.

.123

.

Zmienne

Zmiennymi nazywane są dowolne ciągi złożone z liter, cyfr oraz znaku podkreślenia zaczynające się od litery. Liczba znaków tworzących poszczególne zmienne nie jest ograniczona, jednak tworząc zbyt długie nazwy zmiennych można doprowadzić do sytuacji, w której zabraknie pamięci i nie będzie można dokonać translacji. Nazwy zmiennych nie mogą być identyczne jak nazwy funktorów i ewaluatorów. Zmiennej może zostać nadana jakaś wartość liczbowa, do której następnie można się odwołać podając jej nazwę. Zmienne występujące w wyrażeniach powinny mieć nadane wartości (wyjątkiem są zmienne będące argumentami ewaluatorów oraz zmienne pojawiające się po lewej stronie instrukcji podstawienia).

Przykład

x

s2

Moc_Bierna

W języku ASTEL wprowadzono trzy zdefiniowane wstępnie zmienne btime, etime oraz dtime, wykorzystywane jako identyfikatory momentu początkowego, końcowego momentu oraz ich różnicy. Wymienione zmienne mogą wystąpić jedynie jako argumenty ewaluatorów time, year, month, day, hour, minute oraz second.

Nazwy zmiennych będących zmiennymi systemu Asix mogą nie spełniać ograniczeń języka ASTEL (zawierać na przykład znaki typu +-/= itp). Takie zmienne pojawić się mogą jedynie jako argumenty ewaluatorów. Aby jednak można było przeprowadzić analizę leksykalną, należy nazwy te ograniczyć nawiasami klamrowymi {}.

Przykład

{s=x+y/5}

{/////////}

Momenty

Momentami nazywane są specjalnie utworzone ciągi znaków, których interpretacja umożliwia określenie daty oraz czasu. Wartościowanie pewnej klasy wyrażeń w języku ASTEL wymaga określenia (czasem niejawnego) początkowego oraz końcowego momentu. Wyróżnia się momenty absolutne i względne. Momenty absolutne składają się z liczb określających rok, miesiąc, dzień, godzinę, minutę oraz sekundę rozdzielonych znakami ukośnika \ . Liczba określająca rok podana może być w postaci skróconej do dwóch ostatnich cyfr. Pominięcie godziny, minuty i sekundy powoduje przyjęcie zerowych wartości. Pominięcie dnia powoduje przyjęcie pierwszego dnia miesiąca. Pominięcie miesiąca oznacza przyjęcie stycznia.Momentami nie są, ciągi zawierające nieprawidłowe wartości liczbowe (np. 13 na pozycji miesiąca).

Przykład

Momentami absolutnymi są następujące ciągi znaków:

1991\6\3\12\20\10 | 3 | czerwiec | 1991 | 12:20:10
93\1\1 | 1 | styczeń | 1993 | 00:00:00
1992\12\3\18 | 3 | grudzień | 1992 | 18:00:00

Niektóre momenty absolutne określać można wykorzystując predefiniowane ciągi znaków oznaczające początek lub koniec pewnych charakterystycznych okresów (roku, miesiąca, dnia oraz tygodnia). Momenty te określane są w stosunku do daty wykonania raportu. Poniżej wymienione zostały momenty absolutne (z komentarzem zakładającym, że raport sporządzany jest we wtorek 9 marca 1993 o godzinie 15-tej 30).

year> | 1 | styczeń | 1993 | 00:00:00
month> | 1 | marzec | 1993 | 00:00:00
day> | 9 | marzec | 1993 | 00:00:00
hour> | 9 | marzec | 1993 | 15:00:00
week> | 8 | marzec | 1993 | 00:00:00
year< | 1 | styczeń | 1994 | 00:00:00
month< | 1 | kwiecień | 1993 | 00:00:00
day< | 10 | marzec | 1993 | 00:00:00
hour< | 15 | marzec | 1993 | 16:00:00
week< | 15 | marzec | 1993 | 00:00:00
year| | 1 | styczeń | 1992 | 00:00:00
month| | 1 | luty | 1993 | 00:00:00
day| | 8 | marzec | 1993 | 00:00:00
week| | 1 | marzec | 1993 | 00:00:00

Do oznaczenia predefiniowanych momentów absolutnych można zamiast angielskich określeń typu year, day, etc. używać nazw polskich rok, miesiąc, dzień, godzina i tydzień.

Tak określone momenty absolutne mogą być dodatkowo przesunięte. Jeżeli bezpośrednio po momencie absolutnym oznaczającym początek okresu (np. dzień>) wystąpią liczby określające godzinę, minutę i sekundę rozdzielone znakami ukośnika \, wówczas zapis ten oznacza odpowiednio moment przesunięty w przód od momentu aktualnego o wyspecyfikowany okres czasu. Jeżeli ciąg taki wystąpi po momencie absolutnym oznaczającym koniec okresu (np. dzień<), wówczas zapis taki oznacza odpowiednio moment cofnięty od momentu aktualnego o wyspecyfikowany okres czasu.

Jeżeli raport sporządzany jest we wtorek 9 marca 1993 o godzinie 15-tej 30 to:

day>5 | 9 | marzec | 1993 | 05:00:00
day<1\30 | 9 | marzec | 1993 | 22:30:00

Możliwe jest określenie w sposób uproszczony momentu aktualnego. Używany jest do tego celu znak &. Jeżeli bezpośrednio po znaku tym wystąpią liczby określające godzinę, minutę i sekundę rozdzielone znakami ukośnika \, wówczas zapis ten oznacza odpowiednio moment cofnięty od momentu aktualnego o wyspecyfikowany okres czasu. Przesuwanie momentu od momentu aktualnego o określony okres w przód nie zostało zrealizowane (oznacza przesunięcie w przyszłość). Możliwość specyfikowania momentów względem aktualnego czasu może być szczególnie przydatna w niektórych typach raportów.

Jeśli raport sporządzany jest na przykład 9 marca 1993 (wtorek) o godzinie 11:20 to

& | 9 | marzec | 1993 | 11:20:00
&2\10 | 9 | marzec | 1993 | 9:10:00

Obok momentów absolutnych tak jak je opisano powyżej język ASTEL pozwala zdefiniować momenty przez wskazanie nazwy miesięcy. Określają one początki tych miesięcy lub początki miesięcy te miesiące poprzedzających. Skróty są 3-literowe i kończą się znakiem ">" lub "|". W pierwszym przypadku skrót taki oznacza początek danego miesiąca, a w drugim początek jego poprzednika. Przy ich użyciu należy pamiętać, że rok danego momentu wynika z daty wskazanej do liczenia raportu bądź z przesunięcia momentu domyślnego.

Nazwy momentów określających miesiące można podać po angielsku lub po polsku. Nazwy te są następujące:

wersja polska

STY> , LUT> , MAR> , KWI> , MAJ> , CZE> , LIP> , SIE> , WRZ> , PAZ> , LIS> , GRU>

wersja angielska

JAN| , FEB| , MAR| , APR| , MAY| , JUN| , JUL| , AUG| , SEP| , OCT| , NOV| , DEC|

Przykłady

Avg(moc,STY>,LUT>) // średnia moc za styczeń

Avg(moc,GRU>,ROK<) // średnia moc za grudzień

Mechanizm ten przeznaczony jest do użycia w raportach opartych o instrukcję "symbol".

Momenty początku i końca okresu pozwalają wyznaczyć początek i koniec okresu czasu dla ewaluatorów języka ASTEL. Moment początkowy ma symbol "|", zaś końcowy "_". Jedynym miejscem zastosowania tych momentów są raporty miesięczne, gdzie nie wiadomo o jaki okres przesunąć się względem momentu domyślnego, np. początku, aby być w określonej odległości od końca (ponieważ miesiące mają różną długość). Składnia taka sama jak dla momentu teraz "&".

Przykłady (okres jest miesiącem)

Avg(moc,|,|240) // średnia moc za 1-szą dekadę

Avg(moc,|480,_) // średnia moc za ostatnią dekadę

Oprócz momentów absolutnych można używać momentów względnych. Wyznaczane są one w stosunku do momentów poprzednio zdefiniowanych (również niejawnie). Ciągi znaków określające moment względny składają się z liczb określających godzinę, minutę i sekundę rozdzielonych znakami ukośnika \ . Ciąg taki powinien być poprzedzony znakiem większości > lub mniejszości < określającym kierunek przesunięcia czasu (w przód lub w tył). Wartości minut oraz sekund większe od 59 traktowane są jako błędne. W przypadku momentów względnych dopuszcza się liczbę godzin przekraczającą 24 co umożliwia przesunięcia wielodniowe. Pominięcie minut i sekund powoduje przyjęcie wartości zerowych. Poniżej zamieszczone zostały przykłady. Jeśli zdefiniowany jest moment absolutny 7 kwiecień 1993 12:00:00 to:

>48 | 9 | kwiecień | 1993 | 12:00:00
>1\30 | 7 | kwiecień | 1993 | 13:30:00
<0\0\30 | 7 | kwiecień | 1993 | 11:59:30

Operatory

Operatorami są pojedyncze znaki symbolizujące poszczególne operacje arytmetyczne. Dopuszcza się dwuargumentowe operatory dodawania, odejmowania, mnożenia, dzielenia, potęgowania i podstawienia oraz jednoargumentowy operator zmiany znaku. Argumentami operatorów są wyrażenia. Każdy operator posiada przyporządkowany priorytet określający kolejność wartościowania wyrażeń. Operatory zestawiono poniżej.

+ | (plus) | dodawanie
- | (minus) | odejmowanie
* | (gwiazdka) | mnożenie
/ | (kreska) | dzielenie
^ | (strzałka) | potęgowanie
++ | (2 x plus) | maksimum
-- | (2 x minus) | minimum
|| | (2 x kreska) | logiczna suma (or)
&& | (2 x ampersand) | logiczny iloczyn (and)
^^ | (2 x strzałka) | logiczne albo (xor)
! | (wykrzyknik) | logiczne nie (not)
== | (2 x równość) | równość
<> | (mniejszość-większość) | różność
>> | (2 x większość) | większość
<< | (2 x mniejszość) | mniejszość
>= | (większość- równość) | większość lub równość
<= | (mniejszość - równość) | mniejszość lub równość
== | (2 x równość) | równość
? | (pytajnik) | zaokrąglanie
= | (równość) | podstawienie
- | (minus) | zmiana znaku (również tylda ~)

Przykład

Wyrażenia zawierające operatory:

(x+y)*z+1.3/(x-2)

p=-3.33*5

2++99--(-11)--0

z=x=3

Nowe operatory relacyjne to:

== dwuargumentowy operator równości

<> dwuargumentowy operator różności

>> dwuargumentowy operator większości

<< dwuargumentowy operator mniejszości

>= dwuargumentowy operator większości lub równości

<= dwuargumentowy operator mniejszości lub równości

Operatory tej grupy przyjmują wartość 1 jeśli spełniony jest warunek lub 0 jeśli warunek jest niespełniony np. "a==5" ma wartość 1 jeśli wartość zmiennej "a" w chwili wykonywania porównania wynosi 5. Możliwe jest wielokrotne stosowanie tych operatorów w jednym wyrażeniu, ale uwaga, o ile wyrażenie:

5>>4 ma wartość 1, to

5>>4>>3 ma wartość 0, bo operacje są wykonywane od lewej więc (5>>4)>>3 daje 1>>3 daje 0

Nowe operatory logiczne to:

! jednoargumentowy operator negacji (NOT)

|| dwuargumentowy operator sumy (OR)

&& dwuargumentowy operator iloczynu (AND)

^^ dwuargumentowy operator różnicy symetrycznej (XOR)

Operatory tej grupy przyjmują wartość 1 lub 0. Uwaga są to operatory logiczne, a nie bitowe tzn. działają na całych słowach. Przyjmuje się, że jeśli wartość operandu jest różna od zera to oznacza to "prawdę", zaś jeśli wartość operandu jest równa zero to oznacza to "fałsz".

Nowe operatory ekstremum to:

++ dwuargumentowy operator maximum

-- dwuargumentowy operator minimum

Operatory tej grupy przyjmują wartość większego (++) lub mniejszego(--) z dwóch argumentów. W związku z tym np. wartością wyrażenia:

2++8 jest 8, zaś

2++99--(-11)--0 jest -11

Wprowadzenie nowych operatorów daje spore możliwości, ale należy uważać na istniejące obecnie zagrożenie tworzeniem dość kryptograficznie wyglądających wyrażeń np. wyrażenie:

a>>3||x+3++6 jest poprawne

Nowe operatory w połączeniu z rozszerzeniami wprowadzonymi dla ewaluatorów READ i GET dają możliwość liczenia warunkowego.

Funktory

Funktory reprezentowane są przez ciągi znaków symbolizujących jednoargumentową funkcję matematyczną. Z punktu widzenia wartościowania wyrażenia podobne są do jednoargumentowych operatorów. Argumentem każdego funktora jest wyrażenie. Jeśli argumentem funktora jest liczba lub zmienna można pominąć nawiasy okrągłe, w których zapisuje się wyrażenie. Funktory podobnie jak operatory posiadają przyporządkowany priorytet. Można podawać polskie odpowiedniki nazw funktorów.

ang. | pol. |
sin | sin | sinus
cos | cos | cosinus
tg | tg | tangens
arcsin | arcsin | arcus sinus
arccos | arccos | arcus cosinus
arctg | arctg | arcus tangens
sinh | sinh | sinus hiperboliczny
cosh | cosh | cosinus hiperboliczny
tgh | tgh | tangens hiperboliczny
abs | bezw | moduł (również nawiasy kwadratowe [ ])
exp | exp | exponent
ln | ln | logarytm naturalny
sqr | kwad | kwadrat
sqrt | pierw | pierwiastek kwadratowy (również znak  )
rnd | pseud | liczba pseudolosowa
ent | całk | część całkowita liczby
frac | ułam | część ułamkowa liczby

Przykład

Wyrażenia zawierające funktory:

sin x

sin(x)+cos(y^2)

sin ln [x*2.15]

sin (z=x=3)

Poniższe wyrażenia są parami równoważne

sin x sin(x)

[x+2] abs(x+2)

sqrt 3 sqrt(3)

Ewaluatory

Ewaluatory reprezentowane są przez ciągi znaków symbolizujących wykonanie pewnej funkcji z kilkoma argumentami (lub funkcji wielu zmiennych). Liczba argumentów oraz ich rodzaj uzależnione są od typu ewaluatora. Argumentami niekoniecznie muszą być wielkości numeryczne (liczby) mogą to być również zmienne i momenty. Poszczególne argumenty umieszczane są w nawiasach za nazwą ewaluatora oraz rozdzielone znakami spacji lub przecinka. Dopuszcza się pominięcie końcowych argumentów z listy i wtedy w ich miejsce przyjmowane są wartości domyślne. Nie można pominąć pierwszego z argumentów, natomiast jeśli występuje tylko jeden argument, można pominąć otaczające go nawiasy. Jeżeli część argumentów stanowić mają argumenty domyślne, poprzedzające na liście argumenty podawane w postaci jawnej, to wówczas dla oznaczenia argumentów domyślnych należy użyć znaku @. Ewaluatory podzielone zostały na grupy ze względu na liczbę i rodzaj argumentów. Można podawać polskie odpowiedniki nazw ewaluatorów.

  • Ewaluatory operujące na danych archiwalnych

ang. pol.

val

wart

- wartość zmiennej w danym momencie;

int

sum

- suma wartości w przedziale;

diff

różn

- różnica wartości na krańcach przedziału;

max

maks

- wartość maksymalna;

min

min

- wartość minimalna;

grad

skok

- największa różnica wartości;

avg

śred

- średnia wartość (przerwy w archiwizacji traktowane są jak zera);

acc

akum

- średnia wartość zakumulowana (przerwy w archiwizacji są pomijane); ewaluatory średniej avg oraz acc inaczej traktują obszary, w których brakowało danych ze względu na brak archiwizacji lub wyłączenia; i tak, jeśli w badanym okresie zmienna była stała i wynosiła 100 przez 50% czasu, a w pozostałym okresie brakowało danych, to wartością ewaluatora avg będzie 50 zaś wartością acc będzie 100;

inc

przyr

- suma dodatnich przyrostów;

spos

sdod

podobnie jak inc, lecz po wystąpieniu spadku wartości dodawana jest wartość pierwszego pomiaru po spadku;

sposh

sdodhd

- podobnie jak spos, lecz dodaje się także przyrosty dwóch wartości, mimo, że pomiędzy nimi wystąpiła dziura;

Przykład:

Zawartość archiwum: 2,3,4,3,(dziura),5

Wynik: (3-2)+(4-3)+3+(5-3) = 7

dec

spad

- suma ujemnych przyrostów;

sneg

sujem

- podobnie jak dec, lecz po wystąpieniu wzrostu wartości dodawana jest wartość pierwszego pomiaru po wzroście;

snegh

sujemd

- podobnie jak sneg , lecz dodaje się także przyrosty ujemne, mimo, że pomiędzy nimi wystąpiła dziura;

Przykład:

zawartość archiwum: 7,4,3,5,4,(dziura),2

wynik: (4-7)+(3-4)+5+(4-5)+(2-4) = -2

var

war

- wariancja;

count

licz

- liczba wartości w przedziale;

inf

ważn

- stosunek czasu, w którym dostępne były ważne pomiary do czasu odpowiadającego badanemu przedziałowi;

wartością ewaluatora inf jest liczba z przedziału od 0 do 1; wartość równa 1 oznacza, że system pracował bez błędów, przerw w archiwizacji i wyłączeń; wartość 0 oznacza brak ważnych pomiarów w przedziale;

Ewaluatory operujące na danych archiwalnych wywoływane są przy pomocy sekwencji:

evaluator_name (name, begin, end, min, max, type)

gdzie:

name - nazwa zmiennej procesowej systemu Asix;

begin - moment początkowy;

end - moment końcowy;

min - dopuszczalna wartość minimalna zmiennej (domyślnie najmniejsza liczba float);

max - dopuszczalna wartość maksymalna zmiennej (domyślnie największa liczba float);

type - typ archiwum(domyślnie m).

Name i type tworzą opis zmiennej procesowej utworzony dla potrzeb programu archiwizacyjnego Aspad. Podanie nazwy jest obligatoryjne, pozostałe argumenty mogą być pominięte, co powoduje przyjęcie wartości domyślnych. Parametry begin i end określają okres, dla którego wykonuje się obliczenia. Parametry min oraz max umożliwiają ograniczenie zakresu zmiennych procesowych do zakresu wartości sensownych. Brak podania tych parametrów powoduje przyjęcie zakresu dopuszczalnego dla liczb zmiennoprzecinkowych. W przypadku ewaluatora val moment końcowy jest nieistotny. Jako wartości dla parametru type można użyć liter B, M, H, D, Y. Oznaczają one odpowiednio:

B szukanie danych archiwalnych w plikach typu B (relacyjna baza danych Paradox),

M szukanie danych archiwalnych w plikach typu M,

H szukanie danych archiwalnych w plikach typu H,

D szukanie danych archiwalnych w plikach typu D,

Y szukanie danych archiwalnych w plikach typu Y.

Podanie w tym miejscu małej litery b, m, h, d lub y powoduje najpierw próbę otwarcia archiwum wskazanego typu, a jeśli takie nie istnieje wykonuje się próbę otwarcia archiwum dla danej zmiennej kolejno typu B, M, H, D lub Y.

Przykłady

avg (moc,93\1\3,93\4\8) oznacza obliczenie średniej wartości zmiennej procesowej MOC o typie archiwizacji m w okresie od 3 stycznia do 8 kwietnia 1993 roku.

avg (moc,@,@,0,50) oznacza obliczenie średniej wartości zmiennej procesowej MOC o typie archiwizacji m w okresie domyślnym z jednoczesnym ograniczeniem zakresu wartości do przedziału 0-50.

  • Ewaluatory operujące na danych archiwalnych z określonym krokiem

ang. pol.

sval | kwart | - wartość zmiennej w danym momencie;
sint | ksum | - suma wartości w przedziale;
smax | kmaks | - wartość maksymalna;
smin | kmin | - wartość minimalna;
savg | kśred | - średnia wartość;
scount | klicz | - liczba wartości w przedziale.

Ewaluatory operujące na danych archiwalnych z określonym krokiem, wywoływane są przy pomocy sekwencji:

evaluator_name (name, step ,begin, end, min, max, type)

gdzie

name - nazwa zmiennej procesowej systemu Asix;

step - krok, z jakim próbkowany jest przebieg w sekundach (domyślnie 60);

begin - moment początkowy;

end - moment końcowy;

min - dopuszczalna wartość minimalna zmiennej (domyślnie najmniejsza liczba float);

max - dopuszczalna wartość maksymalna zmiennej (domyślnie największa liczba float);

type - typ zmiennej procesowej (domyślnie m).

Z ewaluatorami operującymi na archiwach z określonym krokiem związana jest funkcja stype (ang.) ktyp (pol). Określa ona sposób interpolacji. Funkcja STYPE posiada jeden argument, który jest liczbą całkowitą 0,1,2,3. Oznaczają one odpowiednio:

0 - wybranie najbliższego pomiaru;

1 - wybranie interpolacji liniowej (domyślnie);

2 - wybranie poprzedniego pomiaru;

3 - wybranie następnego pomiaru.

Wymienione w tej grupie ewaluatory są bardzo podobne do ewaluatorów opisanych w poprzedniej grupie. Jedyna różnica polega na tym, że o ile w poprzedniej grupie do obliczeń brane były wszystkie zarejestrowane w archiwum pomiary odnoszące się do danego przedziału, to opisane w tej grupie ewaluatory jedynie próbkują zarejestrowany przebieg z określonym krokiem, i tylko takie pomiary są dalej przetwarzane.

Różnica ta jest dość istotna bo np. jeśli wyszukujemy w danym przedziale o długości 1 godziny wartości maksymalnej i stosujemy np. krok wynoszący 5 minut, to może się okazać, że zamiast odnaleźć rzeczywistą maksymalną wartość, która wystąpiła o godzinie 1:38 odnajdziemy nieco niższą wartość z godziny 1:40.

Znaczenie poszczególnych parametrów jest identyczne jak dla ewaluatorów pierwszej grupy. Parametr step oznacza krok przeszukiwania archiwum. Należy unikać stosowania bardzo małych kroków dla dużych przedziałów, gdyż prowadzi to do znacznego wydłużenia czasu obliczeń. W przypadku ewaluatora sval moment końcowy jest nieistotny.

Przykład

savg (moc,3600,93\1\3,93\4\8) oznacza obliczenie średniej wartości zmiennej procesowej MOC o typie archiwizacji m w okresie od 3 stycznia do 8 kwietnia 1993 roku, w ten sposób, że wartości do obliczenia średniej próbkowane są z krokiem wynoszącym 1 godzinę.

  • Ewaluatory czasu

ang. pol.

time | czas | - czas (liczba sekund jaka upłynęła od 1 stycznia 1980);
year | rok | - rok;
month | miesiąc | - miesiąc;
day | dzień | - dzień;
hour | godzina | - godzina;
minute | minuta | - minuta;
second | sekunda | - sekunda;
tmax | tmaks | - określa czas, dla którego wystapiło maksimum;
tmin | tmin | - określa moment czasu, dla którego wystąpiło minimum.

Ewaluatory czasowe wywoływane są przy pomocy sekwencji:

evaluator_name (time)

gdzie:

time - nazwa momentu początkowego BTIME, końcowego ETIME lub ich różnicy DTIME albo moment absolutny albo moment względny

Przykłady

hour (etime) godzina odpowiadająca (domyślnemu) momentowi końcowemu

hour (&) godzina odpowiadająca momentowi aktualnemu

month (month>) miesiąc odpowiadający miesiącowi bieżącemu

  • Ewaluatory przesuwające momenty początkowe i końcowe

ang. pol.

over> | przek> | - początek przekroczenia;
over< | obniż< | - koniec obniżenia;
under> | obniż> | - początek obniżenia;
under< | przek< | - koniec przekroczenia;
limit | limit | - stosunek okresu, dla którego wartość zmiennej była większa od ustalonego limitu do okresu odpowiadającego badanemu przedziałowi (nie przesuwa momentów - przybiera wartości z przedziału od 0 do 1);
nlimit | nlimit | - stosunek okresu, dla którego wartość zmiennej była mniejsza od ustalonego limitu do okresu odpowiadającego badanemu przedziałowi (nie przesuwa momentów - przybiera wartości z przedziału od 0 do 1);
tmax> | tmaks> | - przestawia moment początkowy na czas wystapienia maksimum;
tmin> | tmin> | - przestawia moment początkowy na czas wystąpienia minimum.

Ewaluatory przesuwające momenty wywoływane są przy pomocy sekwencji:

evaluator_name (name, limit, begin, end, type)

gdzie:

name - nazwa zmiennej procesowej;

limit - zmienna lub stała określająca limit (domyślnie 0);

begin - moment początkowy;

end - moment końcowy;

type - typ zmiennej procesowej (domyślnie m).

Podanie nazwy jest obligatoryjne, pozostałe argumenty mogą być pominięte co powoduje przyjęcie wartości domyślnych. Wartością ewaluatorów tej grupy jest zawsze 0 lub 1. Wartość 1 oznacza, że w badanym przedziale znaleziono punkt, w którym testowana zmienna przekracza wartość limitu (lub obniża się poniżej limitu). Efektem ubocznym jest przesunięcie do znalezionego punktu momentu początkowego lub końcowego. Wyjątkiem jest ewaluator limit. Przyjmuje on wartości z przedziału 0-1 i nie powoduje przesunięcia momentów. Parametr type może przyjmować wartości takie jak dla ewaluatorów grupy pierwszej. Graficzna interpretacja początku i końca przekroczenia (oraz obniżenia) przedstawiona została na rysunku.

Rysunek: Graficzna prezentacja początku i końca przekroczenia (oraz obniżenia) wartości zmiennej.

Przykłady

over> (moc,100) oznacza wyszukanie w badanym przedziale zmienności zmiennej procesowej MOC o typie archiwizacji m momentu, w którym przekracza ona wartość 100. Jeżeli moment taki zostanie znaleziony wtedy, wartością ewaluatora będzie 1, zaś moment początkowy zostanie przyporządkowany wyszukanemu.

limit (moc,100) oznacza określenie jaki jest udział w badanym przedziale zmienności zmiennej procesowej MOC o typie archiwizacji m pomiarów których wartość przekracza 100.

m = max(z) zmienna m zawiera maksimum zmiennej z

t = tmax(z) zmienna t zawiera czas w którym było maksimum

v = val(x,t) zmienna v zawiera wartość zmiennej x dla czasu t

Możliwe są dalsze konstrukcje typu:

t = t+3600 zwiększenie czasu t o 1 godzinę

v = val(x,t) v zawiera wartość zmiennej x dla nowego czasu t

Jeśli korzysta się z operatorów grupy tmax> i tmin> to pierwszy przykład podany powyżej z użyciem tych ewaluatorów można zapisać następująco:

m = max(z) zmienna m zawiera maksimum zmiennej z

t = tmax>(z) zmienna t zawiera w którym było maksimum

v = val(x) zmienna v zawiera wartość zmiennej x dla czasu t

ale trzeba pamiętać, że domyślny początek jest przesunięty

dla każdej następnej linii (co zresztą może być celowe)

  • Ewaluatory operujące na danych bieżących

ang. pol.

read | czyt | - bieżąca wartość zmiennej procesowej przeczytana ze sterownika;
get | pob | - bieżąca wartość zmiennej procesowej pobrana z tablic systemu.

Ewaluator ten wywoływany jest przy pomocy sekwencji:

evaluator_name (name, min, max, mask)

gdzie:

name - nazwa zmiennej procesowej systemu Asix;

min - dopuszczalna wartość minimalna zmiennej (domyślnie najmniejsza liczba float);

max - dopuszczalna wartość maksymalna zmiennej (domyślnie największa liczba float);

mask - opcjonalne maskowanie wybranych bitów słowa (domyślnie brak maskowania).

Zaleca się używanie ewaluatora get zamiast ewaluatora read wszędzie tam gdzie nie jest konieczne bezpośrednie czytanie zmiennej ze sterownika. Takie postępowanie znacznie przyśpiesza działanie systemu.

Przykład

read(x,@,@,0x00FF) oznacza pobranie wartości zmiennej X i przed jej konwersją na wartość typu float wykonanie operacji iloczynu bitowego z maską szesnastkową 0x00FF.

Ponieważ zmienna procesowa może być liczbą stałoprzecinkową 16 i 32 bitową oraz także liczbą zmiennoprzecinkową, należy odpowiednio stosować maskę 16 lub 32 bitową. Stosowanie 32 bitowej maski w przypadku liczb zmiennoprzecinkowych wymaga poznania formatu liczby typu float. Zastosowanie maski 32 bitowej dla 16 bitowej zmiennej powoduje usunięcie starszego słowa maski. Zastosowanie maski 16 bitowej do 32 bitowej zmiennej powoduje jej uzupełnienie zerowym starszym słowem.

Wprowadzenie maskowania daje zupełnie nowe możliwości wprowadzania nowych wirtualnych zmiennych, "wycinanych" z fragmentów różnych innych zmiennych.

Przykłady

read(x,@,@,0xFF) wycięcie młodszego bajtu

read(x,@,@,0xFF)/256 wycięcie starszego bajtu

read(x,@,@,0x80)/2+read(y,@,@,0x3) utworzenie nowej zmiennej przez wycięcie dwóch najmłodszych bitów słowa Y raz dodanie do nich starszego bajtu bitu o wadze 2^7 słowa X przesuniętego o jedną pozycje w lewo.

Zastosowanie wyrażeń logicznych daje możliwość wprowadzenia mechanizmu zastępującego instrukcję "if". Np. fragment programu zawierający instrukcję "if" o treści

if ((a>30)||(b&0x10)) // gdzie a i b to zmienne procesowe

w=50

else

w=0

należy zapisać w języku ASTEL jako

a=read(a)

b=read(b,@,@,0x10)

w=((a>>30)||b)*50

  • Ewaluator odpowiednika

ang. pol.

alias

odpow

- wartość odpowiednika zadeklarowanego w pliku inicjującym.

Ewaluator ten wywoływany jest przy pomocy sekwencji:

evaluator_name (name)

gdzie:

name nazwa odpowiednika. Ewaluator alias używany jest wtedy, jeśli wartości pewnych parametrów użytych w wyrażeniu mają zostać odczytane z pliku inicjującego. Postępowanie takie celowe jest przy tworzeniu wielu powtarzalnych aplikacji, różniących się drobnymi szczegółami (np. wartością parametrów w pewnych podobnych wyrażeniach).

Przykład

Wyrażenia zawierające ewaluatory:

max d2

max d2 - min d2

int(moc)/count(moc)*0.8

max(para,91\6\6,91\6\7)

var(z,week>,week<)

1.2*read(x)+200

  • Czas jako argument ewaluatorów

Istnieje możliwość operowania czasem jako argumentem ewaluatorów grupy day, hour, second itd.... . Możliwe są np. konstrukcje:

t = time(&) zmienna t zawiera aktualny czas

h = hour(&) zmienna h zawiera aktualną godzinę np. 15

t = t+3600 zwiększenie czasu t o 1 godzinę

s = time(t) zmienna s zawiera aktualny czas zwiększony o 1 h

g = hour(t) zmienna g zawiera aktualną godzinę + 1 np. 16

Nawiasy

Dopuszcza się dwa rodzaje nawiasów - nawiasy okrągłe ( ) używane dla określenie kolejności wykonywania poszczególnych operacji tworzących wyrażenie oraz nawiasy kwadratowe używane [ ] dla oznaczenia wartości bezwzględnej.

Nawiasy klamrowe { } mogą być używane jako ograniczniki dla zmiennych systemu Asix, używanych jako pierwszy parametr niektórych ewaluatorów.

Przecinki

Znaki przecinka, używane są jako separatory (zamiennie ze znakami odstępu) w celu rozdzielenia poszczególnych argumentów ewaluatora. Przykłady poniższe zawierają wyrażenia równoważne.

PRZYKŁADY

count(X,93\3\1,93\3\3)

count(X 93\3\1 93\3\3)


13.3.2. Gramatyka języka ASTEL

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.3. Język przetwarzania danych procesowych ASTEL > 13.1.3.2. Gramatyka języka ASTEL

13.1.3.2. Gramatyka języka ASTEL

<cyfra> ::= 0|1|2|3|4|5|6|7|8|9

<litera> ::= A|B|C|D|E|F|G|H|I|J|K|L|M|N|O|P|Q|R|S|T|U|V|W|X|Y|Z

<cliczba> ::= <cyfra>|<cliczba><cyfra>

<liczba> ::= <cliczba>.<cliczba>|<cliczba>.|.<cliczba>|.

<zmienna> ::= <litera>|<zmienna><litera>|<zmienna><cyfra>|<zmienna>_

<znak> ::= dowolny znak wprowadzony z klawiatury oprócz { }

<nazwa> ::= {<znak>}|{<nazwa><znak>}

<sekunda> ::= <cliczba>[0-59]

<minuta> ::= <cliczba>[0-59]

<godzina> ::= <cliczba>[0-24]

<dzień> ::= <cliczba>[1-31]

<miesiąc> ::= <cliczba>[1-12]

<rok> ::= <cliczba>[1980-2047]

<przes> ::= >|<

<wartprzes> ::= <cliczba>|<cliczba>\<minuta>|

<cliczba>\<minuta>\<sekunda>

<okres> ::= year>|month>|day>|hour>|week>|

jan>|feb>|mar>|apr>|may>|jun>|jul>|

aug>|sep>|oct>|nov>|dec>| jan||feb||mar||apr||may||jun||jul||aug||

sep||oct||nov||dec||year||month||day||hour||week||

year<|month<|day<|hour<|week<

<moment> ::= <rok>\<miesiąc>\<dzień>|

<rok>\<miesiąc>\<dzień>\<godzina>|

<rok>\<miesiąc>\<dzień>\<godzina>\<minuta>|

<rok>\<miesiąc>\<dzień>\<godzina>\<minuta>\<sekunda>| <okres>|<okres><wartprzes>|<przes><wartprzes>|&|&<wartprzes>

<operator1> ::= -|~|!

<operator2> ::= +|-|*|/|^|=|++|--||||&&|^^|==|<>|>>|<<|>=|<=|?

<funktor> ::= sin|cos|tg|arcsin|arccos|arctg|sinh|cosh|tgh|

abs|exp|ln|sqr|sqrt||rnd|ent|frac

<ewaluator> ::= val|int|diff|max|min|grad|avg|acc|var|count|inf|inc|dec|spos|sneg|

sposh|snegh|sval|sint|smax|smin|savg|scount|tmax|tmin|

tmax>|tmin>|time|year|month|day|hour|minute|second|

limit|over>|over<|under>|under<|read|get|alias

<separator> ::= ,|<odstęp>

<składnik> ::= <liczba>|<zmienna>|<moment>|<nazwa>

<lista> ::= <składnik><separator><składnik>|

<lista><separator><składnik>

<argument> ::= <liczba>|<zmienna>|

(<wyrażenie>)|[<wyrażenie>]|

<funktor><wyrażenie>|

<ewaluator><składnik>|<ewaluator>(<lista>)

<wyrażenie> ::= <argument>|

<operator1><wyrażenie>|

<wyrażenie><operator2><argument>

Gramatyka języka ASTEL zapisana została przy użyciu notacji BNF. Produkcję <znak> należy interpretować jako dowolne znaki, które mogą być wprowadzone z klawiatury za wyjątkiem nawiasów klamrowych. Użyto rozszerzenia polegającego na dopisaniu w niektórych produkcjach dopuszczalnego zakresu liczby w nawiasach kwadratowych. Pominięto możliwość stosowania polskich odpowiedników nazw funktorów i ewaluatorów.


13.3.3. Wartościowanie wyrażeń

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.3. Język przetwarzania danych procesowych ASTEL > 13.1.3.3. Wartościowanie wyrażeń

13.1.3.3. Wartościowanie wyrażeń

Sposób wartościowania wyrażeń wyznaczają poniższe reguły:

  • kolejność wykonywania poszczególnych operacji tworzących wyrażenie wyznaczają priorytety.

  • kolejność wykonywania operacji wynikającą z priorytetów można zmienić przy pomocy nawiasów.

  • W przypadku jednakowych priorytetów operacje wykonywane są od lewej do prawej.

  • funkcje wykonywane są od prawej do lewej.

  • operacje podstawienia wykonywane są od prawej do lewej.

Prezentowana tabela zawiera wykaz operatorów (i funktorów) wraz z przyporządkowanymi im priorytetami (od najwyższego).

Tabela: Wykaz operatorów i funktorów dla języka ASTEL.

Przykłady wyrażeń

Tabela: Przykłady wyrażeń dla języka ASTEL.


13.3.4. Diagnostyka

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.3. Język przetwarzania danych procesowych ASTEL > 13.1.3.4. Diagnostyka

13.1.3.4. Diagnostyka

Błędy w pracy dialogowej | Typy błędów
BŁĄD SKŁADNIOWY | BŁĘDY OBLICZENIOWE
WYRAŻENIE ZBYT ZŁOŻONE | BŁĘDY DZIEDZINY
NIEZDEFINIOWANA ZMIENNA | BŁĘDY ARCHIWIZACJI
BŁĄD WYKONANIA | BŁĘDY KOMUNIKACJI
BŁĄD WARTOŚCIOWANIA | BŁĘDY FORMATU
 | BŁĘDY SKŁADNIOWE
 | INNE BŁĘDY WYKONANIA
 | Błędy przy obliczaniu raportów

Podczas translacji oraz wartościowania wyrażeń w języku ASTEL może wystąpić szereg błędów. Mogą to być błędy składniowe (syntaktyczne), semantyczne oraz błędy wartościowania (wykonania). Jeśli błędy wystąpią na etapie translacji wyrażenia, to wyrażenie nie jest wartościowane. Błędy występujące podczas wartościowania podzielone zostały na:

  • błędy krytyczne, powodujące przerwanie wartościowania np. odwołanie do niezdefiniowanej zmiennej;

  • błędy krytyczne warunkowo, po których proces wartościowania może być kontynuowany;

  • błędy niekrytyczne, nie powodujące przerwania wartościowania np. zaokrąglenie wyniku.

W zależności od trybu korzystania z języka ASTEL, błędy te są w różny sposób sygnalizowane. Pełniejsza diagnostyka jest do dyspozycji w przypadku interakcyjnego wykorzystania języka ASTEL (poprzez tzw. DIALOG). W tym trybie wyrażenia analizowane i wartościowane są na bieżąco, po czym wyświetlana jest obliczona wartość lub też informacja o błędzie (ewentualnie ostrzeżenia). Każdorazowo po analizie oraz ewentualnym wartościowaniu wyrażenia można uzyskać pełną informację diagnostyczną po wydaniu komendy ?. W przypadku obliczania raportów sytuacje błędne sygnalizowane są w sposób uproszczony.

Błędy w pracy dialogowej

  • BŁĄD SKŁADNIOWY

Błąd składniowy występuje, jeśli składnia wprowadzonego wyrażenia nie jest zgodna z gramatyką języka ASTEL. W takim przypadku zostaje wyprowadzony komunikat błąd składniowy poprzedzający wyrażenie, w którym błąd wystąpił. W wyrażeniu tym poszczególne symbole (leksykalne) będą rozdzielone spacjami oraz dodatkowo przed pierwszym nieprawidłowym lub nierozpoznawalnym symbolem umieszczony zostanie znak ?. W przypadku błędu składniowego, polegającego na niezgodności nawiasów zamiast wyrażenia zostanie wyprowadzony komunikat niezgodność nawiasów (ponieważ nie wiadomo, czy nawiasów brakuje, czy jest ich za dużo). Po błędzie składniowym nie następuje wartościowanie.

Przykłady

2+++3

błąd składniowy 2 ++ ? + 3

-S błąd składniowy lub nadmierna złożoność

ln+2

błąd składniowy ln ? + 2

-S błąd składniowy lub nadmierna złożoność

(2+3

błąd składniowy - niezgodność nawiasów

-S błąd składniowy lub nadmierna złożoność

  • WYRAŻENIE ZBYT ZŁOŻONE

Błąd ten występuje, jeśli wprowadzone wyrażenie składa się z większej liczby elementów (leksykalnych) niż 255. Należy wyrażenie uprościć lub zastąpić większą liczbą wyrażeń prostszych. Błąd ten nie występuje w trybie dialogowym, ponieważ niemożliwe jest wprowadzenie linii dłuższej. W trybie obliczania raportów powoduje wyprowadzenie komunikatu diagnostycznego oraz niemożliwość wyprowadzenia raportu.

  • NIEZDEFINIOWANA ZMIENNA

Błąd ten występuje w przypadku użycia zmiennej, która nie została wcześniej zdefiniowana (nie wystąpiła po lewej stronie operacji podstawienia). Nie jest to błąd składniowy tylko semantyczny, którego wystąpienie testowane jest w trakcie wartościowania. Jeśli wystąpi, należy zdefiniować brakującą zmienną, po czym powtórzyć wartościowanie (lub poprawnie wpisać nazwę zmiennej już zdefiniowanej).

Przykład

z+3

niezdefiniowana zmienna

-S błąd składniowy lub nadmierna złożoność

z=2

brak błędów

2

z+3

brak błędów

5

  • BŁĄD WYKONANIA

Błąd wykonania występuje, jeżeli z jakichś przyczyn nie można było zakończyć procesu wartościowania lub też po jego zakończeniu wystąpiła niezgodność wskaźnika stosu obliczeniowego. Zamiast wyniku wartościowania zostaje wyprowadzony komunikat błąd wykonania.

  • BŁĄD WARTOŚCIOWANIA

Błąd wartościowania występuje, jeżeli proces wartościowania został zakończony, ale w czasie jego trwania wystąpiły błędy krytyczne lub też błędy warunkowo krytyczne, w wyniku których wynik wartościowania jest nie-liczbą (not-a-number). Przykładową nie-liczbą jest wynik operacji dzielenia przez zero (nieskończoność). Nie-liczba może być warunkowo wykorzystywana przy kontynuacji obliczeń, których wynikiem będzie poprawna wartość. W przypadku błędu wartościowania zostaje wyprowadzony komunikat błąd wartościowania.

Przykłady

ln 0

błąd wartościowania

-D niedodatni argument logarytmu

1/0

błąd wykonania

-O dzielenie przez zero

-O nadmiar

arctg(1/0)

-O dzielenie przez zero

-O utrata precyzji

Jeśli podczas procesu wartościowania wystąpią niekrytyczne błędy lub też błędy warunkowo krytyczne, nie powodujące błędu wartościowania, wtedy wynik obliczeń jest wyprowadzany, ale obliczony jest warunkowo. Sytuacja taka jest dość częsta. Może na przykład wystąpić przy obliczaniu wartości średniej, jeżeli wystąpią przerwy w zbieraniu danych (spowodowane na przykład wyłączeniem komputera). Wówczas zamiast błędu wartościowania i braku wyniku zostanie wyprowadzona średnia policzona z pominięciem przerw. O tym, że wynik jest obliczony warunkowo można się przekonać przy pomocy komendy w odpowiednim polu okna dialogów.

Typy błędów

Wykonanie tej komendy powoduje wyprowadzenie informacji objaśniającej przyczyny błędu. Ponieważ przyczyn mogło być wiele, informacja ta może być zawarta w kilku kolejnych wierszach. Każdy z nich rozpoczyna się od znacznika wskazującego na przynależność błędu do określonej grupy błędów. Ich znaczenie jest następujące:

-O błędy obliczeniowe

-D błędy dziedziny

-A błędy archiwizacji

-K błędy komunikacji

-W błędy wykonania

-I błędy inne

-F błędy formatu

-S błędy składniowe

  • BŁĘDY OBLICZENIOWE

-O niedozwolona operacja błąd krytyczny

Wystąpiła niedozwolona operacja np. 0/0, użyto nie-liczby jako operandu lub też wystąpił błąd wskaźnika stosu koprocesora. Przerywa obliczenia.

-O denormalizacja mantysy błąd niekrytyczny

Wystąpiła denormalizacja mantysy (przy minimalnej wartości cechy mantysa nie jest znormalizowana tzn. z przedziału od 1/2 do 1). Tracone są najmniej znaczące cyfry operandu (operand jest bliski zera). Wystąpi dodatkowo utrata precyzji. Obliczenia są kontynuowane.

-O dzielenie przez zero błąd krytyczny warunkowo

Wystąpiło dzielenie przez zero. Jako wynik przyjmuje się nie-liczbę symbolizującą + lub -. Obliczenia są warunkowo kontynuowane.

-O nadmiar błąd krytyczny warunkowo

Wynik operacji przekracza zakres liczbowy (otrzymano za dużą co do modułu liczbę). Jako wynik przyjmuje się nie-liczbę symbolizującą + lub -. Obliczenia są warunkowo kontynuowane.

-O podmiar błąd niekrytyczny

Wynik operacji jest zbyt bliski zera (otrzymano zbyt małą co do modułu liczbę). Jako wynik przyjmuje się zero i obliczenia są kontynuowane. Prowadzi do utraty precyzji.

-O utrata precyzji błąd niekrytyczny

W czasie wykonywania operacji wystąpiło zaokrąglenie. Wynik nie jest dokładny. Obliczenia są kontynuowane.

  • BŁĘDY DZIEDZINY

-D ujemny argument pierwiastka błąd krytyczny warunkowo

Argument funkcji pierwiastek jest liczbą ujemną. Przyjmowana jest wartość 0 i obliczenia są warunkowo kontynuowane.

-D niedodatni argument logarytmu błąd krytyczny warunkowo

Argument funkcji logarytm jest liczbą niedodatnią. Przyjmowana jest nie-liczba i obliczenia są warunkowo kontynuowane.

-D błędny argument funkcji arcus błąd krytyczny warunkowo

Argument funkcji arcsin lub arccos nie należy do przedziału od - do +. Przyjmowana jest nie liczba i obliczenia są warunkowo kontynuowane.

-D za mało liczna populacja błąd niekrytyczny

Liczba pomiarów w zadanym przedziale jest zbyt mała, aby można było dokonać obliczeń. Sytuacja taka występuje na przykład w przypadku obliczania średniej dla przedziału pustego lub obliczania różnicy wartości na krańcach przedziału jeśli wewnątrz przedziału są mniej niż dwa pomiary. Powoduje przyjęcie wartości zero i kontynuowanie obliczeń.

-D błędna konwersja liczb błąd krytyczny

Nastąpił błąd podczas konwersji liczby zmiennoprzecinkowej na całkowitą (przekroczenie zakresu liczb całkowitych).

  • BŁĘDY ARCHIWIZACJI

-A błąd otwarcia kanału błąd krytyczny

Brak możliwości otwarcia kanału przez program Aspad. Przyczyną może być błędnie wyspecyfikowana zmienna archiwalna lub zbyt wiele jednocześnie otwartych kanałów.

-A błąd szukania - brak danych błąd krytyczny

Błąd podczas operacji pozycjonowania (szukania początku obszaru przeszukiwania danych). Powodem jest sięganie do zbyt odległej przeszłości, dla której nie ma danych.

-A odwołanie w przyszłość błąd niekrytyczny

Odwołanie do danych z przyszłości. Przyjmowana jest wartość 0. Obliczenia są kontynuowane.

-A brak danych błąd niekrytyczny

Wystąpił brak danych archiwalnych w badanym okresie. Przyjmowana jest wartość 0. Obliczenia są kontynuowane.

-A przeszły okres błąd niekrytyczny

Wystąpił brak danych archiwalnych w badanym okresie (są poza nim). Przyjmowana jest wartość 0. Obliczenia są kontynuowane.

-A przerwy w archiwizacji błąd niekrytyczny

Wystąpiły przerwy w danych archiwalnych wewnątrz badanego okresu. Dla przerw przyjmowana jest wartość 0. Obliczenia są kontynuowane.

-A brak pomiaru błąd krytyczny

Dla podanego czasu (i w najbliższym jego sąsiedztwie określonym momentami granicznymi) brak pomiaru. Błąd ten może wystąpić jedynie w przypadku ewaluatora val.

-A brak danych z serwera błąd krytyczny

Błąd ten może wystąpić jedynie w konfiguracji sieciowej programu jeśli nie można przetransmitować danych za pośrednictwem sieci. Przyczyną może być rozłączenie połączenia sieciowego, uszkodzenie toru przesyłowego lub jego błędna parametryzacja.

-A ujemny przyrost czasu błąd krytyczny

  • BŁĘDY KOMUNIKACJI

-K nieodświeżona zmienna błąd niekrytyczny

Dane nie zostały odświeżone w zadanym czasie. Przyjmowana jest wartość odebrana ostatnio. Obliczenia są kontynuowane.

-K niezdefiniowana zmienna błąd krytyczny

Zmienna o takiej nazwie nie została zdefiniowana. Należy sprawdzić poprawność wpisania nazwy.

-K niepewna wartość zmiennej błąd niekrytyczny

Wartość zmiennej jest niepewna (np. dawno nie odświeżona). Obliczenia są kontynuowane.

-K błąd transmisji błąd krytyczny

Błędy transmisji na łączach komunikacyjnych. Nie można pobrać zmiennej procesowej.

  • BŁĘDY FORMATU

-F nieprawidłowy format

Proces wartościowania zakończył się prawidłowo, ale wynik nie może zostać poprawnie wyprowadzony w założonym formacie (przewidziana zbyt mała liczba pól). Błąd ten nie może wystąpić w pracy dialogowej (gdzie format wyniku nie jest specyfikowany), a jedynie w czasie obliczania raportów. Sygnalizowany jest wtedy w sposób uproszczony.

  • BŁĘDY SKŁADNIOWE

-S błąd składniowy lub nadmierna złożoność

Wystąpił błąd składniowy, lub wyrażenie było zbytnio skomplikowane. Objaśnienie rodzaju błędu zostało wyprowadzone wcześniej.

  • INNE BŁĘDY WYKONANIA

-W nie zadeklarowana zmienna błąd krytyczny

W czasie wartościowania wystąpiło odwołanie do niezdefiniowanej zmiennej.

-W niewłaściwy argument błąd krytyczny

Wystąpił nieprawidłowy argument ewaluatora. Nieprawidłowości mogą dotyczyć typu, zakresu lub liczby argumentów. Zgodność argumentów jest sprawdzana w czasie wartościowania.

-I błąd konwersji odpowiednika tekstowego błąd krytyczny

W czasie wartościowania ewaluatora alias wystąpił błąd konwersji na wartość liczbową odpowiednika tekstowego.

-I brak odpowiednika tekstowego błąd krytyczny

W pliku inicjującym brak odpowiednika tekstowego, do którego odwołuje się funkcja alias.

-W dane symulowane błąd niekrytyczny

Program obliczający raport wykorzystuje dane symulowane. Otrzymane wyniki nie mają znaczenia praktycznego.

Błędy przy obliczaniu raportów

Podczas obliczania raportów wartościowanych jest bardzo wiele wyrażeń języka ASTEL. Wynikiem wartościowania każdego wyrażenia jest liczba, która powinna zostać wpisana w odpowiednio wyspecyfikowanym polu. Rodzaje błędów są zasadniczo te same, co przy pracy dialogowej. Jedynie informacja o wystąpieniu błędu musi się mieścić w polu o określonych rozmiarach. Wszystkie błędy składniowe wykrywane są już na etapie analizy definicji raportu, dlatego podczas jego obliczania nie mogą wystąpić. Jedynym wyjątkiem jest błąd polegający na użyciu niezdefiniowanej zmiennej. Wystąpienie błędu powoduje wpisanie zamiast wyniku tekstu sygnalizującego błąd.

Tekst opisu błędu umieszczany jest w polu wyniku. Jeśli szerokość pola wyniku jest większa niż długość tekstu, wtedy opis jest wpisywany w środku pola. Jeżeli szerokość pola jest mniejsza niż długość opisu (cztery znaki), wtedy obcinane są końcowe znaki opisu.

Błędy formatu, które nie występowały w pracy dialogowej spowodowane są wyspecyfikowaniem zbyt małej szerokości pola dla zaprezentowania wyniku (ponieważ nie można zapisać liczby 1000 na 3 pozycjach zostanie wyprowadzony łańcuch "?FR").

Tabela: Zestawienie rodzajów błędów występujących przy obliczaniu raportów.

Wyniki obliczone warunkowo, tzn. takie podczas wartościowania których wystąpiły błędy niekrytyczne, wyprowadzane są z dopisanym na końcu znakiem '?'.


13.4. Język definiowania raportów ASTER

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.4. Język definiowania raportów ASTER

13.1.4. Język definiowania raportów ASTER

Język ASTER został specjalnie opracowany do definiowania zawartości oraz postaci raportów tworzonych w systemie Asix.


13.4.1. Elementy języka

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.4. Język definiowania raportów ASTER > 13.1.4.1. Elementy języka

13.1.4.1. Elementy języka

Komentarze

Słowa kluczowe

Formuły

Łańcuchy

Liczby

Style

Znaczniki

Linie

Znaki specjalne

Definicje raportów napisanych w języku ASTER składają się z ciągu deklaracji oraz instrukcji. Ich elementami mogą być:

  • komentarze,

  • słowa kluczowe,

  • formuły,

  • łańcuchy,

  • liczby,

  • style,

  • znaczniki,

  • linie,

  • znaki specjalne.

Format definicji raportu nie został określony w sposób sztywny. Poszczególne elementy definicji mogą być rozdzielone dowolną liczbą znaków spacji (odstępu), tabulacji oraz nowych linii. Nie jest ważna też kolejność występowania deklaracji i instrukcji poza instrukcją format odwołującą się do symboli, które powinny być zdefiniowane wcześniej. Małe i duże litery poza łańcuchami traktowane są jako tożsame.

Komentarze

Komentarzem jest nazywany tekst objaśniający definicję raportu, który nie jest analizowany przez translator języka. Komentarzem może być dowolny ciąg znaków ograniczony parą nawiasów klamrowych { } lub też dowolny ciąg znaków od znaku ukośnej kreski / aż do końca linii.

Przykład

{Komentarz}

{Komentarz

może zawierać

wiele linii}

/Komentarz

Słowa kluczowe

Słowami kluczowymi nazywa się zastrzeżone ciągi znaków używane w instrukcjach i deklaracjach. Przewidziano 13 niżej wymienionych słów kluczowych. Można używać polskich odpowiedników nazw słów kluczowych. Ich znaczenie zostanie omówione w dalszej części opracowania.

Wersja w jęz. angielskim:

name | delimiter | marker | begin
step | repeat | count | symbol
format | header | record | input
alias | ctrl | export | text
nowarning | noerror |  |

Wersja w jęz. polskim:

nazwa | ogranicznik | znacznik | początek
krok | powtarzaj | licznik | symbol
format | nagłówek | wiersz | wprowadź
odpow | ster | eksport | tekst
bez_ost. | bez_bł. |  |

Formuły

Formułami są dowolne wyrażenia języka przetwarzania danych procesowych ASTEL, ujęte znakami apostrofu '. Ich składnia i znaczenie omówione zostały w rozdziale poświęconym językowi ASTEL. Formuły mogą być wartościowane (obliczane). Efektem wartościowania formuły jest przekazanie wyniku liczbowego lub informacji o błędzie.

Przykład

'1'

'arctg(1/0)*(3+2)'

'z=avg(moc,day>)*0.8'

Łańcuchy

Łańcuchami są dowolne ciągi znaków ograniczone znakami cudzysłowu ". Łańcuch nie może zawierać znaku cudzysłowu. Łańcuchy służą do przechowywania danych o charakterze tekstowym.

Przykład

"raport"

"12.5"

""

Liczby

Liczbami są dowolne ciągi złożone z cyfr. W języku ASTER do definicji raportów wykorzystuje się jedynie liczby naturalne (elementami formuł mogą być również liczby rzeczywiste). Wykorzystywane są przy określaniu dat, czasu oraz sposobu prezentacji wyników.

Przykład

0

123

Style

Stylami nazywane są ciągi znaków określające sposób umieszczania wyników w polu przeznaczonym na prezentację. Zdefiniowane są cztery style -L, -R, -C oraz -Z oznaczające odpowiednio uzupełnianie spacjami z lewej i z prawej strony, centrowanie wyniku w polu prezentacji oraz uzupełnianie zerami z lewej strony.

Przykład

'1':5:0-C / oznacza, że łańcuch "1" zostanie wyprowadzony w środku pola o szerokości 5 znaków

Istnieje możliwość modyfikowania standardowych formatów oznaczanych literami L, R, C oraz Z przez dodanie deklaracji dodatkowych zawartych w grupie znaków sterujących wydrukiem ostrzeżeń. Można po znaku oznaczającym styl tj. L, R, C, Z, umieścić znaki sterujące wydrukiem w przypadku wystąpienia błędu lub ostrzeżenia określonego typu. Dopuszczalne są znaki:

- F - odwołanie w przyszłość

- H - wystąpiła dziura

- B - wystąpiło cofnięcie czasu

- N - brak danych (ale zmienna jest zadeklarowana)

- R - nastąpił brak odpowiedzi archiwum

Umieszczenie wymienionych znaków powoduje, że znak ”r;r;?" informujący o błędzie nie zostanie wyświetlony razem z wartością. Dla zwiększenia czytelności zaleca się pisanie modyfikatorów małą literą dla oddzielenia ich wizualnie od znacznika stylu. Ilustruje to

Przykład

Jeśli zadeklaruje się format jak niżej:

:8:3-Lfh,

to, jeśli wystąpi dziura w danych archiwalnych lub odwołanie w przyszłość, nie będzie wyprowadzany znak ? wraz z liczbą, a jeśli dodatkowo miał być wyprowadzany ciąg 0? to będzie wyprowadzone puste miejsce.

Po znaku stylu (L,R,C,Z) można wstawić dodatkową flagę O. Powoduje ona, że wynik wyrażenia jest traktowany jako numer operatora w liście pozycji NAZWISKO sekcji [OPERATOR] (liczone od 1 ). Zamiast liczby do raportu wynikowego jest wstawiane nazwisko operatora.

PRZYKŁAD

Poniższy symbol wstawia nazwisko pierwszego operatora.

{S1} '1’:10-LO;

Znaczniki

Znacznikami nazywane są predefiniowane ciągi znaków ograniczone znakami procentu %. Znaczniki mogą występować jedynie wewnątrz specjalnego rodzaju łańcuchów zwanych liniami. Znaczniki mogą być ograniczane znakami innymi niż procent w przypadku zadeklarowania ich przy pomocy deklaracji marker. Jest to niezbędne w przypadku, gdy linia zawierająca znaczniki posiada znaki procentu. Znaczniki zostały wymienione poniżej. Mogą występować w wersji angielskiej i polskiej.

Wersja w języku angielskim:

%date% | %time% | %day% | %dtime%
%bdate% | %edate% | %btime% | %etime%
%rN% | %hN% | %sN% | %iN%
%page% | %remark% | %operator% | %next%
%print-xxx% |  |  |

Wersja w języku polskim:

%data% | %czas% | %dzień% | %okres%
%pdata% | %kdata% | %pczas% | %kczas%
%rN% | %hN% | %sN% | %iN%
%strona% | %notatka% | %operator% | %następny%
%druk-xxx% |  |  |

gdzie:

N - jest liczbą należącą do przedziału od 0 do n;

xxx - jest komendą sterującą sposobem wydruku (w trybie graficznym).

Znaczniki mogą pojawiać się wewnątrz linii i są interpretowane przez instrukcję format. Wystąpienie znacznika wewnątrz linii powoduje jego zastąpienie w raporcie wynikowym określonym ciągiem znaków. Znaczenie poszczególnych znaczników jest następujące:

%date% - dzień, w którym obliczono raport (w formacie "dd-mm-rrrr").

%time% - godzina i minuta, o których obliczono raport (w formacie "gg:mm").

%day% - dzień, dla którego obliczony został raport (w przypadku raportów wielodniowych jest to pierwszy dzień okresu, dla którego liczony jest raport).

%bdate% - data, odpowiadająca momentowi początkowemu (w formacie "dd-mm-rrrr").

%edate% - data, odpowiadająca momentowi końcowemu (w formacie "dd-mm-rrrr").

%btime% - czas, odpowiadający momentowi początkowemu (w formacie "gg:mm:ss").

%etime% - czas, odpowiadający momentowi końcowemu (w formacie "gg:mm:ss").

%dtime% - różnica czasu między aktualnym momentem końcowym i początkowym (w formacie "gg:mm:ss"). Jeśli różnica czasu przekracza dobę (24 godziny) wówczas wyprowadzany jest łańcuch " > doba ".

%rN% - wynik wartościowania N-tej formuły z instrukcji record (w formacie określonym przez pole i styl).

%hN% - N-ty łańcuch z instrukcji header (w formacie określonym przez pole i styl).

%sN% - wynik wartościowania N-tej formuły lub N-ty łańcuch z instrukcji symbol (w formacie określonym przez pole i styl).

%iN% - wyprowadzane jest N-te pytanie (łańcuch) z instrukcji input po czym do raportu w miejsce znacznika wprowadzana jest odpowiedź (również łańcuch) w formacie określonym przez pole i styl.

%remark% - notatka operatora, wprowadzona przy pomocy okna dialogowego. Do 60 znaków.

%page% - wyprowadzenie nowej strony na drukarce. Zachowane ze względu na zgodność ze starszymi wersjami. Obecnie należy wykorzystywać raczej instrukcję ctrl.

%operator% - nazwisko operatora, wybrane w oknie dialogowym. Do 30 znaków.

%next% - wynikiem interpretacji %next% jest zawsze pusty łańcuch. Efektem ubocznym interpretacji jest ustalenie następnego momentu początkowego oraz końcowego. Znacznik %next% powinien być używany jedynie w definicjach raportów zawierających instrukcję repeat. Powoduje, że nowo wyliczony moment końcowy staje się momentem początkowym, zaś poprzedni moment końcowy zostaje odtworzony.

%print-xxx% - służy do sterowania sposobem wydruku raportu w formie graficznej. Możliwe są następujące komendy sterujące (xxx):

PAGE - wysuw strony,

PORTRAIT- ustawienie orientacji strony na pionową,

LANDSCAPE - ustawienie orientacji strony na poziomą,

FONT(opis_czcionki) - zmiana czcionki. Opis formatu czcionki jest następujący:

nazwa_kroju,wysokość,szerokość,atrybuty

Wysokość i szerokość podawane są w dziesiątych częściach milimetra, dostępne atrybuty, to: bold, italic, underline, strikeout. Żaden z elementów opisu czcionki nie jest obowiązujący, w szczególności zapis FONT() oznacza użycie czcionki wg ostatnio zdefiniowanego kroju i ostatnich rozmiarach z usuniętymi wszystkimi atrybutami.

Przykład

Użycie znaczników %print-xxx% do formatowania wydruku treści raportu. Sekwencja:

"%print-landscape%%print-font(50)%tekst zwykły %print-font(bold)% tłusty %print-font()% zwykły"

ma następujące znaczenie:

  • włączenie orientacji poziomej (jeżeli nie na początku raportu, to połączone ze zmianą strony);

  • ustawienie czcionki o domyślnym kroju (Courier New lub wg pozycji CZCIONKI lub ostatnio podanym w komendach FONT) o wysokości 5 mm i szerokości dobranej automatycznie (na podstawie domyślnych proporcji czcionki arial);

  • ustawienie czcionki wytłuszczonej - pozostałe parametry czcionki jak w punkcie 2;

  • powrót do czcionki ustawionej w punkcie 1.

Linie

Liniami nazywane będą specjalnego rodzaju łańcuchy, których zawartość interpretowana jest w języku ASTER. Wykorzystywane są one w instrukcji format. Tak jak normalne łańcuchy mogą być ograniczone znakami cudzysłowu ". Mogą być również alternatywnie ograniczane innymi znakami zadeklarowanymi przy pomocy deklaracji delimiter. Ten drugi przypadek ma zastosowanie, jeśli linia musi zawierać znak cudzysłowu. Linie mogą zawierać interpretowane znaczniki.

Przykład

"Zwykła linia"

"Linia ze znacznikiem %day%"

*Linia ograniczona znakami gwiazdki może zawierać znak " (cudzysłów)*

"Linia ze znakiem % (procent) zawiera znacznik @day@"

Znaki specjalne

Znaki specjalne dopuszczone w języku ASTER to dwukropek : przecinek , oraz średnik ;. Wykorzystywane są one w różnych przypadkach jako separatory (znaki rozdzielające) dla innych elementów.

Przykład

{instrukcja} symbol {zawiera}

{formułę} '1+2' : {dwukropek} 3 {szerokość pola} , {przecinek}

{formułę} '2+3' : {dwukropek} 3 {szerokość pola} ; {średnik}


13.4.2. Instrukcje

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.4. Język definiowania raportów ASTER > 13.1.4.2. Instrukcje

13.1.4.2. Instrukcje

Instrukcja name | Instrukcja header
Instrukcja export | Instrukcja record
Instrukcja nowarning | Instrukcja symbol
Instrukcja noerror | Instrukcja input
Instrukcja delimiter | Instrukcja format
Instrukcja marker | Instrukcja alias
Instrukcja begin | Instrukcja ctrl
Instrukcja step | Instrukcja text
Instrukcja repeat | Instrukcja header
Instrukcja count | Instrukcja input
 | Instrukcja symbol
 | Instrukcja record

Poniżej zostaną opisane kolejne instrukcje języka ASTER. Część ta nie stanowi podręcznika tworzenia raportów, a jedynie wykaz instrukcji wraz z ich opisem.

  • Instrukcja name

Składnia

name <łańcuch>

Instrukcja name używana jest do określenia nazwy raportu. Nazwa ta pojawia się na liście raportów. Nazwę stanowi dowolny łańcuch, zaleca się jednak, aby nie był on dłuższy niż 30 znaków, ponieważ do takiej liczby zostanie obcięty. Instrukcja ta musi wystąpić w definicji raportu. Powinno się stosować unikalne nazwy dla poszczególnych raportów.

Przykład

name "zużycie wody"

  • Instrukcja export

Składnia

export

Instrukcja export umożliwia wyprowadzanie liczb bez znaku przecinka, zastępującego kropkę w sytuacji, kiedy wystąpiły niekrytyczne błędy wartościowania. Komunikaty o błędach normalnie wpisywane w polu przeznaczonym na liczbę nie będą wpisywane. Ułatwia to ewentualną konwersję na inne formaty zapisu danych, na przykład DBF.

  • Instrukcja nowarning

Składnia

nowarning

Użycie instrukcji nowarning powoduje, że nie będą wyprowadzane ostrzeżenia podczas pracy raportera.

  • Instrukcja noerror

Składnia

noerror

Użycie instrukcji noerror powoduje, że nie będą wyprowadzane komunikaty o błędach podczas pracy raportera.

  • Instrukcja delimiter

Składnia

delimiter <znak>

Instrukcja delimiter umożliwia zdefiniowanie alternatywnego ogranicznika dla linii pojawiających się w instrukcji format (standardowo ogranicznikiem jest cudzysłów). Zdefiniowanie alternatywnego ogranicznika jest konieczne, jeżeli wewnątrz linii wystąpi znak cudzysłowu. Instrukcja delimiter (o ile występuje) powinna być umieszczona przed instrukcją format. Nowo zdefiniowany ogranicznik linii może być używany zamiennie ze znakiem cudzysłowu (ale nie w tej samej linii).

Przykład

{"linia ze znakiem""} /nie jest poprawną linią

delimiter @ /znak '@' będzie ogranicznikiem

{@linia ze znakiem "@} /jest teraz poprawną linią

  • Instrukcja marker

Składnia

marker <znak>

Instrukcja marker umożliwia przedefiniowanie ogranicznika znaczników pojawiających się w instrukcji format (standardowo ogranicznikiem znaczników jest procent). Zdefiniowanie nowego ogranicznika jest konieczne, jeżeli wewnątrz linii wystąpi znak procentu. Instrukcja marker (o ile występuje) powinna być umieszczona przed instrukcją format.

Przykład

{"linia ze znakiem % oraz %remark%"} /nie jest poprawną linią

marker @ /znak '@' będzie ogranicznikiem

{"linia ze znakiem % oraz @remark@"} /jest teraz poprawną linią

  • Instrukcja begin

Składnia

begin <godzina>[:<minuta>[:<sekunda>]]

Instrukcja begin wykorzystywana jest do ustawienia przesunięcia czasu rozpoczęcia raportu. Data rozpoczęcia raportu ustawiana jest wstępnie przy pomocy menu. Czas podany w instrukcji begin sumowany jest z początkiem raportu w celu określenia momentu początkowego. Przykładowo instrukcja begin 2:30 oznacza, że początek raportu zostanie przesunięty o 2 godziny i 30 minut względem początku raportu. Instrukcja begin jest opcjonalna. Jej brak traktowany jest jako przesunięcie zerowe.

Przykład

begin 0:10 / przesunięcie o 10 minut

  • Instrukcja step

Składnia

step <liczba>[:<minuta>[:<sekunda>]]

Instrukcja step powoduje zdefiniowanie okresu czasu, którego raport dotyczy. Podany w instrukcji step okres czasu zasadniczo odpowiada jednemu wierszowi raportu i może być wykorzystany wielokrotnie w przypadku raportów wielowierszowych (liczbę wierszy określa w tym przypadku instrukcja count). Moment końcowy raportu wyznaczany jest jako suma momentu początkowego oraz okresu czasu zdefiniowanego przy pomocy instrukcji step. Ponieważ liczba godzin nie jest limitowana możliwe jest ustalanie okresów wielodniowych. Instrukcja step nie jest obligatoryjna - jeśli nie wystąpi przyjmowany jest okres 1-godzinny.

Przykłady

step 0:30 / okres półgodzinny

step 72 / okres trzydniowy

  • Instrukcja repeat

Składnia

repeat

Instrukcja repeat występuje w przypadku raportów o nieznanej z góry liczbie wierszy. Najprostszym przykładem takiego raportu może być raport zawierający w kolejnych wierszach informację o przekroczeniach limitów technologicznych. A priori nie wiadomo ile takich przekroczeń było w badanym okresie - ich poszukiwania należy kontynuować, aż do osiągnięcia momentu końcowego raportu. Na taki tryb pracy wskazuje wystąpienie instrukcji repeat. Instrukcja repeat nie może wystąpić razem z instrukcją count.

  • Instrukcja count

Składnia

count <liczba>

lub

count <zmienna>

Instrukcja count określa liczbę wierszy raportu. Jest ona opcjonalna - domyślnie liczba wierszy ustawiona jest na 1. Każdy wiersz odpowiada okresowi czasu zdefiniowanego instrukcją step.

Zamiast liczby całkowitej można podać identyfikator jednej z predefiniowanych zmiennych określających liczbę dni dla odpowiedniego miesiąca lub roku. Zmienna taka przyjmuje wartość odpowiadającą liczbie dni w miesiącu (lub roku), w którym rozpoczyna się dany raport. W języku ASTER predefiniowano cztery takie zmienne:

days_of_month, days_of_last_month

days_of_year, days_of_last_year

Można stosować polskie odpowiedniki nazw angielskich:

dni_miesiąca, dni_ostatniego_miesiąca

dni_roku, dni_ostatniego_roku

Zmienna określająca liczbę dni miesiąca może przyjmować wartości 28,29,30 i 31. Zmienna określająca liczbę dni w roku może przyjmować wartości 365 i 366.

Opisane zmienne stosuje się w celu tworzenia raportów długookresowych (miesięcznych i rocznych), których liczba wierszy odpowiada zmiennej liczbie dni w danym okresie. Aby raport taki policzyć, należy ustawić moment początkowy raportu (np. przy pomocy listy dat w oknie raportowym lub odpowiedniego parametru akcji LICZ_RAPORT) na pierwszy dzień obejmowanego okresu.

Przykład

count 8 /raport 8-wierszowy

count days_of_month /raport miesięczny o liczbie wierszy równej dniom miesiąca

  • Instrukcja header

Składnia

header <definicja> [ , <definicja> [...]] ;

Instrukcja header umożliwia zadeklarowanie szeregu łańcuchów. Zadeklarowane w instrukcji header łańcuchy mogą być za pośrednictwem automatycznie nadawanych im znaczników wykorzystywane w instrukcji format. Kolejno definiowanym łańcuchom z listy instrukcji header przyporządkowywane są znaczniki %hN%. Instrukcja header jest opcjonalna. Wykorzystywana zwykle, aby zmienić linię nagłówkową raportu bez potrzeby modyfikacji instrukcji format.

Przykład

header

"godzina" :11-c, / szerokość pola 11 pozycji z centrowaniem

"moc [W]" :11-c, / szerokość pola 11 pozycji z centrowaniem

"temp [oC]" :11-c; / szerokość pola 11 pozycji z centrowaniem

  • Instrukcja record

Składnia

record <definicja> [ , <definicja> [...]] ;

Instrukcja record umożliwia zadeklarowanie szeregu formuł, które następnie wykorzystywane są do tworzenia raportów. Zadeklarowane w instrukcji record formuły powinny być poprawnymi wyrażeniami języka ASTEL. Formuły za pośrednictwem automatycznie nadawanych im znaczników są wykorzystywane w instrukcji format. Kolejno definiowanym formułom z listy instrukcji record przyporządkowywane są znaczniki %rN%. Instrukcja record musi wystąpić.

Przykład

record

'hour(btime)' :11-c, / szerokość pola 11 pozycji z centrowaniem

'avg(moc)' :11:3-c, / 11 pozycji 3 miejsca po przecinku

'avg(temp)' :11:3-c; / 11 pozycji 3 miejsca po przecinku

Raporty nie wykorzystujące instrukcji record mogą być kompilowane bez przeszkód. Użytkownik jednak zostanie ostrzeżony odpowiednim komunikatem o braku instrukcji record.

Syntaktyka wzorca raportu (plik *.r) daje możliwość łatwego definiowania raportów nie opartych na cyklicznych obliczeniach z zadanym krokiem czasu bez uciekania się do "sztuczek" w rodzaju "pustych instrukcji rekord", co mogło prowadzić w przypadku raportów miesięcznych do niechcianych efektów ubocznych. (wyprowadzania 30 pustych wierszy - czyli zwykle w efekcie pustej kartki na końcu wydruku).

  • Instrukcja symbol

Składnia

symbol <definicja> [ , <definicja> [...]] ;

Instrukcja symbol umożliwia zadeklarowanie szeregu formuł lub łańcuchów, które mogą być następnie wykorzystywane w instrukcji format. Kolejnym deklaracjom pojawiającym się na liście instrukcji symbol przypisywane są znaczniki %sN%. Wystąpienie danego znacznika, w którejś z linii instrukcji format powoduje obliczenie odpowiedniej formuły i wpisanie wyniku lub też umieszczenie w tekście raportu zadeklarowanego tekstu. Dla wszystkich formuł z instrukcji symbol domyślnym momentem początkowym jest czas rozpoczęcia raportu, zaś momentem końcowym czas zakończenia raportu. Instrukcja symbol jest opcjonalna, jednak musi wystąpić, jeżeli w jakiejś linii instrukcji format wystąpią znaczniki %sN%.

Przykład

symbol 'avg(x)+avg(y)':10:3; /'avg(x)+avg(y)' przypisane jest znacznikowi %s0% wystąpienie znacznika %s0% spowoduje obliczenie sumy średniej zmiennej x i średniej zmiennej y oraz wpisanie wyniku w polu o szerokości dziesięciu znaków z trzema miejscami po przecinku

  • Instrukcja input

Składnia

input <definicja> [ , <definicja> [...]] ;

Instrukcja input umożliwia wprowadzanie przez operatora do treści raportu stałych tekstowych i liczbowych, które nie są możliwe do uzyskania z archiwum lub ze sterowników, a mogą być istotne z punktu widzenia wewnątrzzakładowego obiegu dokumentów. Przykładem tego typu informacji mogą być ciągi znaków identyfikujące numery zamówień, symbole materiałowe, identyfikatory narzędzi itp. Wprowadzanie następuje podczas interpretacji znaczników %iN% przypisywanych kolejnym definicjom występujących w instrukcji input. Przed wprowadzeniem następuje wyprowadzenie pytania określającego wprowadzaną daną. Wprowadzony łańcuch znaków jest formatowany według pola i stylu.

Przykład

input

"podaj zlecenie ?":10, /odpowiedź będzie przypisana znacznikowi %i0%

"podaj materiał ?":10-c; /odpowiedź będzie przypisana znacznikowi %i1%

/ wystąpienie znacznika %i0% spowoduje wyprowadzenie pytania

/ "podaj zlecenie ?" odpowiedź na to pytanie zostanie wpisana

/ do raportu w miejsce znacznika w polu o szerokości 10 znaków

/ (z lewej strony) wystąpienie znacznika %i1% spowoduje wyprowadzenie

/ pytania "podaj materiał ?" odpowiedź na to pytanie zostanie

/ wpisana do raportu w miejsce znacznika w polu o szerokości

/ 10 znaków (w środku)

  • Instrukcja format

Składnia

format <linia> [ , <linia> [...]] ;

Instrukcja format używana jest do tworzenia raportów. Można przy jej pomocy tworzyć dowolne raporty. Algorytm działania instrukcji format jest następujący:

dopóki są linie powtarzaj

początek

czytaj linię

dopóki linia niepusta powtarzaj

początek

wydziel element linii

jeśli element jest znacznikiem to interpretuj znacznik

inaczej {element był znakiem} wpisz do raportu

koniec

koniec

Interpretacja znacznika polega na wpisaniu w linię, w miejsce, w którym się znajdował, odpowiedniego ciągu znaków. Linia, w której wyspecyfikowano znaczniki %rN% interpretowana jest tyle razy, ile wynosi liczba wierszy raportu wyspecyfikowana instrukcją count. W przypadku raportów, w których wykorzystano instrukcję repeat linia ta interpretowana jest dopóki nie osiągnie się momentu końcowego raportu.

Istnieje możliwość stosowania bardziej zwartego zapisu znaczników generowanych przez header, input, symbol i record:

Zamiast: %r0%%r1%%r2%%r3% można zapisać: %r1..3%.

Przykład

{prosty raport bez ramki}

symbol {%s0} "Tytuł";

header

{%h0} "godzina" :11-c,

{%h1} "moc [W]" :11-c,

{%h2} "temp [C]" :11-c;

record

{%r0) "hour(btime)" :11-c,

{%r1} "avg(moc)" :11:3-c,

{%r2} "avg(temp)" :11:3-c;

format

"%s0%", /tytuł

"%h0%%h1%%h2%", /nagłówek

"%r0%%r1%%r2%"; /formuły

  • Instrukcja alias

Składnia

alias <łańcuch>

albo

@ <łańcuch>

Instrukcja alias używana jest do wstawiania do raportu łańcuchów, które zdefiniowane są w pliku inicjującym. Umożliwia to zastosowanie identycznych definicji raportów do wytwarzania raportów różniących się pewnymi tekstami np. tytułem. Argumentem instrukcji jest nazwa odpowiednika tekstu, który powinien być zdefiniowany w:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe

Instrukcja alias może wystąpić zamiast łańcucha w instrukcji symbol. Zamiast słowa kluczowego alias można użyć znaku @.

Przykład

Jeżeli zostanie zdefiniowany parametr tekstowy:

Nazwa logiczna parametru tekstowego: NAZWA

Tekst: NAPĘD WENTYLATORA SPALIN NR 3

to w definicji raportu można użyć instrukcji

symbol {%s0} alias "NAZWA";

  • Instrukcja ctrl

Składnia

ctrl <łańcuch>

albo

^ <łańcuch>

Instrukcja ctrl używana jest do wstawiania do raportu kodów sterujących drukarką, które zdefiniowane zostały w pliku inicjującym. Umożliwia to wykorzystanie pełnych możliwości drukarki. Wymiana drukarki względnie powielenie aplikacji na innym systemie komputerowym wyposażonym w drukarkę innego typu wymaga jedynie edycji zawartości pliku inicjującego. Można stosować atrybuty czcionek jak pochylenie (italic), wytłuszczenie (bold), kolor etc. Działanie instrukcji ctrl jest podobne do instrukcji alias. Występują jednak dwie różnice. Po pierwsze, odpowiedniki tekstowe (czyli kody sterujące drukarką) zdefiniowane są w pliku inicjującym jako szesnastkowe kody znaków rozdzielone spacjami. Wykonanie instrukcji ctrl powoduje interpretację takiego łańcucha, polegającą na zastępowaniu szesnastkowych kodów odpowiednimi znakami. Taki ciąg kodów sterujących wstawiany jest do raportu, przed wydrukowaniem na drukarce, przy pomocy funkcji DRUKUJ z menu RAPORT okna raportowego. Kody sterujące nie są natomiast wyświetlane na ekranie, jak również nie będą na ekranie wyświetlane efekty działania tych kodów. Instrukcja ctrl wystąpić może zamiast łańcucha w instrukcji symbol. Zamiast słowa kluczowego ctrl można użyć znaku ^. Instrukcja ctrl ma znaczenie jedynie w połączeniu z deklaracją tekstowego wydruku alarmów.

Przykład

jeśli w pliku inicjującym znajdzie się sekcja (przykładowe kody dla drukarek HP)

[PARAMETRY_TEKSTOWE]

BOLD= 1B 28 73 33 42

NORMAL= 1B 28 73 30 42

to w definicji raportu można użyć instrukcji

symbol

{%s0} ctrl "BOLD",

{%s1} ctrl "NORMAL";

format

/tytuł raportu będzie wytłuszczony

"%s0% Tytuł raportu %s1%",

...

Interpretacja znacznika %s0% spowoduje, że na drukarkę wysłany zostanie kod sterujący powodujący włączenie wytłuszczenia. Kod ten wpisany jest w pliku inicjującym jako odpowiednik tekstowy zwany BOLD. Zakończenie wytłuszczania nastąpi w wyniku interpretacji kodu %s1% (pismo normalne).

Jeżeli podłączana drukarka nie posiada np. możliwości wytłuszczania znaków, to nie jest konieczne usuwanie z definicji raportu instrukcji typu ctrl "BOLD" oraz odpowiedniego znacznika w instrukcji format. Wystarczy usunąć z pliku inicjującego linię opisującą odpowiednik tekstowy BOLD, ewentualnie nie przypisywać mu żadnych kodów sterujących.

  • Instrukcja text

Składnia

text <łańcuch>

albo

# <łańcuch>

Instrukcja text używana jest do wstawiania do raportu łańcuchów, które przechowywane są w zmiennych Asmena. Umożliwia to zastosowanie identycznych definicji raportów do wytwarzania raportów różniących się pewnymi tekstami. Mogą to być np. przechowywane w bazie danych pola alfanumeryczne. Argumentem instrukcji jest nazwa zmiennej. Instrukcja text wystąpić może zamiast łańcucha w instrukcji symbol. Zamiast słowa kluczowego text można użyć znaku #.

Instrukcje header, input, symbol, record

Instrukcje, które nie wyprowadzają żadnej zmiennej nie wyprowadzają także pustej linii.


13.4.3. Gramatyka języka ASTER

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.4. Język definiowania raportów ASTER > 13.1.4.3. Gramatyka języka ASTER

13.1.4.3. Gramatyka języka ASTER

<znak> ::=

<znaki> ::= |<znak>|<znaki><znak>

<łańcuch> ::= "<znaki>"

<formuła> ::= '<wyrażenie>'

<styl> ::= |-L|-R|-C|-Z

<znacznik> ::= %date%|%time%|%day%|

%dtime%|%bdate%|%edate%|%btime%|%etime%|

%r<cliczba>%|%h<cliczba>%|%s<cliczba>%|%i<cliczba>%|

%page%|%remark%|%operator%|%next%|%print-xxx%

<element> ::= <znak>|<znacznik>

<elementy> ::= |<element>|<elementy><element>

<linia> ::= "<elementy>"

<komentarz> ::= {<znaki}|/<znaki><nowa_linia>

<instrukcja> ::= <name>|<delimiter>|<marker>|

<begin>|<step>|repeat|<count>

<symbol>|<format>|<header>|<record>|

<input>| export|<alias>|<text>|<ctrl>|nowarning|noerror

<name> ::= name <łańcuch>

<delimiter> ::= delimiter <znak>

<marker> ::= marker <znak>

<count> ::= count <cliczba>|count<days_of_month>|

count<days_of_last_month>|count<days_of_year>|

count<days_of_last_year>

<begin> ::= begin <godzina>|

begin <godzina>:<minuta>|

begin <godzina>:<minuta>:<sekunda>

<step> ::= step <cliczba>|

step <cliczba>:<minuta>|

step <cliczba>:<minuta>:<sekunda>

<pole> ::= |:<cliczba>|:<cliczba>:<cliczba>

<hdlista> ::= <łańcuch><pole><styl>|<hdlista>,<łańcuch><pole><styl>

<header> ::= header <hdlista>;

<rdlista> ::= <formuła><pole><styl>|<rdlista>,<formuła><pole><styl>

<record> ::= record <rdlista>;

<alias> ::= alias<łańcuch>|@<łańcuch>

<text> ::= text<łańcuch>|#<łańcuch>

<ctrl> ::= ctrl<łańcuch>|^<łańcuch>

<sblista> ::= <łańcuch><pole><styl>|<formuła><pole><styl>| <sblista>,<łańcuch><pole><styl>|<sblista>,<formuła><pole><styl>| <sblista>,<alais><pole><styl>|<sblista>,<ctrl><pole><styl>

<symbol> ::= symbol <sblista>;

<input> ::= input <hdlista>;

<frlista> ::= <linia>|<frlista>,<linia>

<format> ::= format <frlista>;

<raport> ::= <instrukcja>|<raport><instrukcja>

Gramatyka języka ASTER zapisana została przy użyciu notacji BNF. Nie jest ona do końca ścisła, dlatego że gramatyki języka ASTER nie da się zapisać w sposób formalny przy użyciu tego typu notacji, ponieważ nie jest ona gramatyką bezkontekstową (należałoby użyć notacji dla gramatyki dwupoziomowej). Nieścisłości (oznaczone gwiazdkami) występują przy definicji łańcucha oraz linii. Spowodowane są one możliwością przedefiniowywania ograniczników zarówno łańcucha jak i linii. Produkcja <znak> oznacza wszystkie znaki jakie mogą być wprowadzone z klawiatury. Znaki tworzące łańcuch nie mogą zawierać znaku " chyba, że przedefiniuje się ogranicznik łańcucha.


13.4.4. Diagnostyka

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.1. Raporty tworzone przy użyciu ASTEL/ASTER > 13.1.4. Język definiowania raportów ASTER > 13.1.4.4. Diagnostyka

13.1.4.4. Diagnostyka

Błędy składniowe

Błędy znaczeniowe

Inne błędy

Ostrzeżenia

Definicja raportu jest analizowana zanim raport zostanie wygenerowany. Podczas tej analizy mogą zostać wykryte pewne błędy, które uniemożliwiają generację. Jeżeli wykryty zostanie błąd składniowy wówczas analiza jest przerywana i wyprowadzany jest komunikat o błędzie. Po zakończeniu analizy składniowej (a częściowo w jej trakcie) realizowana jest analiza znaczeniowa definicji raportu. W jej wyniku mogą zostać wykryte błędy semantyczne powodujące niemożliwość wygenerowania raportu. Mogą również zostać wykryte sytuacje, które potencjalnie mogą powodować tworzenie nieprawidłowych raportów. Powodują one jedynie wyprowadzanie ostrzeżeń przed wygenerowaniem raportu.

Jeżeli wykryte zostaną błędy składniowe, wówczas wyprowadzana jest informacja o rodzaju błędu oraz jego lokalizacji (LINIA). Informacja ta będzie wpisana w specjalnym oknie. Postać informacji diagnostycznej wyprowadzanej przez interpretator języka ASTER jest następująca:

Błąd w <numer linii> linii <numer słowa> słowo

LINIA: <błędna linia z zaznaczonym znakiem "?" błędnym elementem języka ASTER>

BŁĄD: <opis błędu>

Jeżeli wykryto błąd składniowy wewnątrz formuły, to linia (LINIA) wyprowadzana jest dwukrotnie. Po raz pierwszy analizator składniowy języka ASTER wyprowadza błędną linię z zaznaczoną znakiem ? błędną formułą. Po raz drugi analizator składniowy języka ASTEL wyprowadza błędne wyrażenie z poprzedzonym znakiem ? błędnym elementem. Postać informacji jest wówczas następująca:

Błąd w <numer linii> linii <numer słowa> słowo

LINIA: <błędna linia z zaznaczoną znakiem "?" błędną formułą języka ASTER>

BŁĄD: <opis błędu>

LINIA: <wyrażenie języka ASTEL z poprzedzonym znakiem "?" błędnym elementem>

Jeżeli nie wykryto błędów składniowych, a jedynie błędy znaczeniowe, wówczas zostanie wyprowadzona informacja:

Błąd w <numer ostatniej linii> linii <numer ostatniego słowa> słowo

BŁĄD: <opis błędu>

Jeżeli nie wykryto błędów, a jedynie ostrzeżenia wówczas zostanie wyprowadzona informacja:

Liczba linii <numer ostatniej linii>

UWAGA: <opis ostrzeżenia>

Jeżeli nie wykryto błędów ani ostrzeżeń, wówczas zostanie wyprowadzona informacja:

Liczba linii <numer ostatniej linii>

brak błędów

Błędy składniowe

Błędy składniowe (syntaktyczne) sygnalizowane są poprzez jeden z niżej wymienionych komunikatów. Dodatkowo wyprowadzana jest błędna linia z zaznaczonym nieprawidłowym elementem (w każdej linii może występować wiele tego samego typu elementów np. formuł, dlatego sam komunikat nie wskazuje jednoznacznie na przyczynę błędu). Istnieją dwie grupy błędów. Pierwsza polega na tym, że w danym miejscu analizator spodziewa się elementu innego typu (komunikat typu oczekiwany...) lub też element mimo właściwego typu jest niepoprawny (komunikaty pozostałe).

Wszystkie komunikaty dotyczące błędów składniowych wymienione zostały poniżej.

oczekiwane słowo kluczowe

nieznane słowo kluczowe

oczekiwane wyrażenie

błędne lub zbyt długie wyrażenie

oczekiwany łańcuch

zbyt długi łańcuch

oczekiwane wyrażenie lub łańcuch

oczekiwana liczba

błędna liczba

oczekiwany średnik lub przecinek

oczekiwany średnik, przecinek lub minus

oczekiwany średnik, przecinek, dwukropek lub minus

oczekiwany styl

oczekiwany znak

Błędy znaczeniowe

Błędy znaczeniowe (semantyczne) wykrywane są głównie po zakończeniu analizy składniowej. Oznaczają, że definicja raportu jest niekompletna, sprzeczna lub nadmiarowa (pewne instrukcje zostały przedefiniowane). Poniżej wymienione zostały (z komentarzem) możliwe sytuacje błędne.

brak nazwy raportu Brak nazwy raportu w definicji.

powtórna definicja Wystąpiło powtórne użycie instrukcji (np. count 5 count 10).

błędny zakres liczby Liczba jest poprawna, lecz jej zakres błędny (np. godzina równa 30).

błędna (zerowa) wartość COUNT Wystąpiła instrukcja count z argumentem 0 (oznacza to 0 wierszy, czyli pusty raport).

niezdefiniowany RECORD Brak w definicji instrukcji record.

niezdefiniowany FORMAT Brak w definicji instrukcji format.

zdefiniowany COUNT i REPEAT Instrukcje count i repeat wykluczają się wzajemnie.

błędny znacznik w instrukcji FORMAT Wykryty został nieznany lub niezdefiniowany znacznik w instrukcji format.

mieszane pola RH w linii FORMAT W tej samej linii instrukcji format wystąpiły znaczniki z instrukcji record i header.

więcej niż jedna linia z polami RH Znaczniki z instrukcji record lub header wystąpiły w więcej niż jednej linii.

Inne błędy

brak pamięci Definicja raportu jest zbyt obszerna, brakuje pamięci aby mogła być zinterpretowana. Jeśli jest to możliwe, należy podzielić definicję na dwie prostsze.

Ostrzeżenia

Ostrzeżenia nie powodują utraty możliwości utworzenia raportu. Wskazują jednak, że jego postać może odbiegać od wyobrażeń użytkownika. Poniżej zostały wymienione komunikaty ostrzegawcze z komentarzem.

Niezgodne FORMAT lub HEADER i RECORD

Występuje, jeśli lista łańcuchów zadeklarowanych w instrukcji header nie jest równoliczna z listą formuł zadeklarowaną w instrukcji record. Wystąpić może również, jeśli lista znaczników związanych z instrukcją record i występujących w instrukcji format nie odpowiada znacznikom związanym z instrukcją header.

Przesunięcie czasu większe niż 1 dzień

Występuje, jeśli argument instrukcji begin jest większy lub równy od 1 dnia (24 godzin). Powoduje to jako skutek uboczny fakt, że np. w raporcie z 1 stycznia będą się znajdować dane z 2 stycznia.


13.5. Raporty skryptowe (VBScript, JavaScript)

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript)

13.2. Raporty skryptowe (VBScript, JavaScript)

Standardowym językiem do tworzenia raportów w systemie Asix jest język ASTER, którego interpreter jest wbudowany w program AS. Możliwe jest również pisanie raportów w językach skryptowych VBScript i Jscript. Pozwala to na tworzenie raportów, których sposób liczenia i forma są niemożliwe do uzyskania w języku ASTER, np. można korzystać z różnych zewnętrznych źródeł danych.

Program AS pozwala na zintegrowaną obsługę raportów obu typów.

UWAGA: Obsługa raportów skryptowych jest tak jak w przypadku raportów pisanych w języku ASTEL/ASTER (patrz: 13.1.1. Obsługa raportów).


13.5.1. Deklarowanie raportów skryptowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.1. Deklarowanie raportów skryptowych

13.2.1. Deklarowanie raportów skryptowych

W przeciwieństwie do raportów w języku ASTER, wszystkie używane raporty skryptowe muszą być jawnie zadeklarowane w pliku konfiguracyjnym aplikacji.

Do deklaracji raportu skryptowego służy zakładka Raporty skryptowe w module Raporty programu Architekt.

Patrz: Architekt, rozdz. 4.13.1. Deklaracja plików raportów skryptowych


13.5.2. Okno raportera

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.2. Okno raportera

13.2.2. Okno raportera

Obsługa raportów napisanych przy pomocy skryptów nie różni się zasadniczo od obsługi raportów utworzonych w języku ASTER. Na liście raportów pojawiają się nazwy raportów obu typów. Nie są one w żaden sposób rozróżniane. Jedyne różnice w obsłudze to:

  • Dla raportów skryptowych nie jest wykonywana komenda Sprawdź z menu okna Raportera.

  • Komenda Katalog ma znaczenie tylko dla raportów w języku ASTER. Niezależnie od wybranego katalogu, zestaw pokazywanych raportów skryptowych jest zawsze taki sam i wynika wyłącznie z deklaracji zapisanych w pliku ini.


13.5.3. Akcje operatorskie

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.3. Akcje operatorskie

13.2.3. Akcje operatorskie

W zestawie akcji operatorskich znajdują się trzy akcje służące do obsługi raportów. Są to akcje LICZ_RAPORT, PISZ_RAPORT i POKAŻ_RAPORT.

Jeżeli akcja ma dotyczyć raportu w języku ASTER, to w pierwszym parametrze należy podać nazwę pliku (łącznie z rozszerzeniem .r) z definicją raportu.

Jeżeli akcja operatorska ma dotyczyć raportu skryptowego, to w pierwszym parametrze należy podać nazwę raportu skryptowego, taką jak została zadeklarowana w pliku ini. Raporty skryptowe używane w akcjach operatorskich muszą być także deklarowane w pliku ini. Jeżeli nazwa raportu zawiera spacje, to w treści akcji operatorskiej należy nazwę ująć w znaki cudzysłowu ".


13.5.4. Zasady tworzenia raportów skryptowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.4. Zasady tworzenia raportów skryptowych

13.2.4. Zasady tworzenia raportów skryptowych

Skrypty służące do tworzenia raportów posiadają kilka charakterystycznych cech różniących je od innych skryptów używanych w systemie Asix. Skrypty raportowe tworzą treść raportu w postaci plików tekstowych. W momencie wywołania do skryptu przekazywany jest zestaw parametrów określających sposób generacji raportu. Pierwszym parametrem jest zawsze nazwa pliku tekstowego, w którym należy zapisać wygenerowany raport. Poniżej pokazany został skrypt, który w pliku raportu zapisuje wartości wszystkich przekazanych parametrów:

dim fso, file

set fso = CreateObject("Scripting.FileSystemObject")

set file = fso.CreateTextFile(asix.script.arguments(1), True)

for each p in asix.script.arguments

file.WriteLine p.name & " = " & p.value

next

file.Close


13.5.5. Znaczenie parametrów skryptu

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.5. Znaczenie parametrów skryptu

13.2.5. Znaczenie parametrów skryptu

Do skryptów generujących raporty przekazywane są poniższe parametry.

Tabela: Zestawienie parametrów przekazywanych do skryptów generujących raporty.


13.5.6. Sterowanie wydrukiem

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.6. Sterowanie wydrukiem

13.2.6. Sterowanie wydrukiem

Jeżeli raport jest generowany w celu wydruku, to do treści utworzonego raportu można wstawić instrukcje formatujące sposób wydruku. Są one zgodne z formatowaniem za pomocą znaczników PRINT-xxx raportów w języku ASTER.

PRZYKŁAD

Poniższy przykład pozwala na wydruk fragmentu raportu wytłuszczoną czcionką:

if asix.script.arguments(3) then

file.Writeline CHR(27) & "FONT(bold)" & "Temperatury" & CHR(27) & FONT()"

else

file.Writeline "Temperatury"

end if

Instrukcje sterujące wydrukiem powinny być używane tylko wtedy, gdy parametr ForPrint jest równy 1. Instrukcja zawsze zaczyna się znakiem Escape, po którym wpisywana jest treść instrukcji.

Możliwe są poniższe warianty:

  • PAGE

Wysuw strony.

  • PORTRAIT

Ustawienie orientacji strony na pionową.

  • LANDSCAPE

Ustawienie orientacji strony na poziomą.

  • FONT(opis_czcionki)

Zmiana czcionki. Opis formatu czcionki jest następujący:

nazwa_kroju,wysokość,szerokość,atrybuty

Wysokość i szerokość podawane są w dziesiątych częściach milimetra, dostępne atrybuty, to: bold, italic, underline, strikeout. Żaden z elementów opisu czcionki nie jest obowiązujący, w szczególności zapis FONT() oznacza użycie czcionki wg ostatnio zdefiniowanego kroju i ostatnich rozmiarach z usuniętymi wszystkimi atrybutami.


13.5.7. Strona kodowa plików wynikowych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.2. Raporty skryptowe (VBScript, JavaScript) > 13.2.7. Strona kodowa plików wynikowych

13.2.7. Strona kodowa plików wynikowych

System Asix używa do wyświetlania i drukowania raportów czcionek z wybraną stroną kodową typu OEM. Czcionka ta jest zależna od systemu operacyjnego. Dla systemu skonfigurowanego do pracy w języku polskim jest to strona kodowa numer 852. Strona OEM używana jest przez system operacyjny w oknach konsoli znakowej. Przy generacji tekstów zawierających znaki narodowe, należy pamiętać o wprowadzeniu ich w standardzie używanej strony OEM.

Cechą charakterystyczną czcionek OEM jest obecność znaków używanych do tworzenia ramek.


Raporty w środowisku Reporting Services fimry Microsoft

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 13. System generacji raportów > 13.3. Raporty w środowisku Reporting Services fimry Microsoft

13.3. Raporty w środowisku Reporting Services firmy Microsoft

Od wersji 6.0 pakietu Asix dostępny jest system raportowania oparty na usługach Reporting Services firmy Microsoft.

Microsoft® SQL Server™ 2008 Reporting Services jest kompletną platformą serwerową zaprojektowaną do spełniania szerokiego zakresu oczekiwań w dziedzinie raportowania na poziomie całego przedsiębiorstwa. Usługi Reporting Services, będące komponentem bazy danych SQL Server 2008, umożliwiają: tworzenie raportów na podstawie różnorodnych źródeł danych; zarządzanie środowiskiem raportowania polegające na planowaniu generowania raportów, zarządzaniu prenumeratami raportów i kontrolowaniu praw dostępu; a także dostarczanie użytkownikom raportów w stosownym formacie i w dogodny dla nich sposób (przewidziana między innymi możliwość automatycznego dostarczania raportów drogą elektroniczną poprzez subskrypcję, bądź też możliwość osadzania raportów w aplikacjach biznesowych i portalach).

Możliwa jest współpraca systemu Asix zarówno z usługami Reporting Services wchodzącymi w skład darmowego Microsoft SQL Server 2008 Express, jak i usługami udostępnianymi w płatnych wersjach serwera SQL Server 2008. Rozszerzenie systemu Asix w zakresie współpracy ze środowiskiem raportowym Reporting Services obejmuje programy: Askom.Data.Host, AsRaport, bazę danych AsixConnect na serwerze Microsoft SQL oraz niezależny archiwizator alarmów w bazie Microsoft SQL. Dodatkowo, w ramach integracji z Reporting Services Asix udostępnia moduł AsRapView umożliwiający przeglądanie z poziomu aplikacji Asix raportów utworzonych w środowisku Reporting Services.

Szczegółowy opis dotyczacy projektowania raportów w środowisku projektowania raportów - AsRaport można znaleźć w pomocy AsRaport.chm lub AsRaport.pdf.


14. Systemy wielomonitorowe

Konfiguracja sprzętowa

Akcje otwarcia

Interpretacja zestawów klawiszy

Praca ze standardową licencją

System Asix posiada wbudowane funkcje ułatwiające projektowanie aplikacji przeznaczonych do uruchomienia na komputerach wyposażonych w kilka monitorów.

Wykorzystanie tych funkcji wymaga zakupu rozszerzenia licencji Asixa o pracę wielomonitorową.

Konfiguracja sprzętowa

Pierwszym krokiem w przypadku uruchamiania systemów wielomonitorowych jest poprawne skonfigurowanie sprzętu. W przypadku systemów Windows ME i Windows 2000 praca wielomonitorowa jest wbudowana w system operacyjny. Wymagane jest tylko użycie krat graficznych kompatybilnych z użytym systemem. W przypadku Windows NT praca wielomonitorowa nie jest wspierana przez system. Wymagana jest zastosowanie kart graficznych, których producent dostarcza sterowniki pozwalające na pracę wielomonitorową pod systemem Windows NT.

Pod systemami Windows ME i Windows 2000, Asix pozwala na pracę w dowolnej konfiguracji monitorów. W przypadku Windows NT obsługiwana jest tylko konfiguracja 2-4 monitorów w ułożeniu poziomym.

Akcje otwarcia

W trybie pracy wielomonitorowej możliwe jest otwieranie masek, tabel oraz trendów na wskazanych monitorowych. Służą do tego parametry x, y i monitor w akcjach operatorskich OTWÓRZ_MASKĘ, TABELA i ASTREND.

Parametry x i y pozwalają na bezpośrednie wskazanie ekranu, na którym ma się okno otworzyć. Zalecane jest jednak określanie tymi parametrami jedynie pozycji w ramach monitora podstawowego, a do wyboru ekranu używać parametru monitor. Parametr monitor może przybierać jedną z poniższych wartości:

  • numer monitora - współrzędne otwarcia są przeliczane w sposób powodujący wyświetlenie okna na wskazanym monitorze; uwzględniane jest przesunięcie względem lewego górnego narożnika monitora podstawowego;

  • 0 - współrzędne otwarcia są przeliczane w sposób powodujący wyświetlenie okna na monitorze wskazywanym przez kursor myszki; uwzględniane jest przesunięcie względem lewego górnego narożnika monitora podstawowego; tryb ten pozwala na dynamiczne dostosowanie się aplikacji do pracy operatora;

  • -1 - przeliczanie współrzędnych monitora nie jest wykonywane, okno otwiera się w pozycji podanej w parametrach akcji lub w definicji maski.

Dodatkowym mechanizmem w pracy wielomonitorowej jest zmiana sposobu działania trybów otwarcia związanych z wymianą okien. Zamykane są tylko okna, które znajdują się (choćby fragmentarycznie) na ekranie, na którym wyświetlane jest nowe okno.

We wszystkich przypadkach Asix zabezpiecza przed próbą otwarcia okna w obszarze niewyświetlanym przez żaden monitor. W takim przypadku koordynaty okna są modyfikowane w taki sposób, aby otworzyło się ono na monitorze podstawowym - aplikacja projektowana do pracy wielomonitorowej, na systemie jednomonitorowym będzie wyświetlała wszystkie okna na monitorze podstawowym.

Interpretacja zestawów klawiszy

W czasie pracy aplikacji przyciśnięcie klawisza na klawiaturze powoduje włączenie mechanizmu interpretacji klawisza. Przeszukiwane są otwarte maski, aż do momentu znalezienia powiązania klawisza z akcją operatorską (w definicjach obiektów lub w zestawach klawiszy przyłączonych do maski). W zwykłym trybie przeszukiwane są wszystkie otwarte maski. Poprzez użycie parametru Klawisze dla ekranu:

Architekt > Obszary i komputery > moduł Pozostałe > zakładka Pozostałe

można spowodować, że przeszukiwane są tylko maski, które wyświetlane są (choćby fragmentarycznie) na ekranie wskazywanym przez kursor myszki. Mechanizm ten pozwala na różną interpretację znaczenia klawisza w zależności od ekranu, którego w danej chwili używa operator.

Praca ze standardową licencją

W przypadku posiadania jedynie standardowej licencji Asixa, wykorzystanie wielu monitorów wymaga jawnego podawania, w parametrach masek lub w akcji otwarcia, współrzędnych wskazujących na właściwy monitor. Działa tylko zabezpieczenie przed próbą otwarcia maski w obszarze, który nie jest wyświetlany przez żaden monitor.


15. System kontroli uprawnień

Pakiet programowy Asix posiada mechanizmy pozwalające na wyposażenie realizowanych w nim aplikacji w system kontroli uprawnień użytkowników.

Ochronie podlegają operacje sterujące kontrolowanym procesem oraz akcje operatorskie, sterujące pracą aplikacji.

Dzięki systemowi haseł hierarchicznych, istnieje możliwość zadeklarowania dla każdego obiektu wizualizacyjnego, który może wykonywać operacje sterujące, poziomu jego zabezpieczenia. Każdy z poziomów, identyfikowany liczbą od 1 do 4 (w przypadku integracji sytemu haseł z systemem logowania istnieje dodatkowy 5 najwyższy poziom administratora) posiada swoje hasło dostępu.

Akcje operatorskie sterujące pracą aplikacji (tj. akcje i niektóre komendy dostępne w menu) zabezpieczane są indywidualnymi hasłami. Parametryzacja tego typu zabezpieczeń polega na zdefiniowaniu odpowiednich pozycji w pliku inicjującym aplikacji oraz odpowiednim doborze używanych akcji.

Szczegóły dotyczące parametryzacji systemu haseł omówione zostały w rozdziale 9.5. Hasła.

Bardziej zaawansowaną metodą kontroli uprawnień użytkowników aplikacji programu Asix jest system logowania. Dzięki takiemu rozwiązaniu możliwe jest przyporządkowanie konkretnym użytkownikom haseł uprawniających ich do realizacji założonych czynności. Dane dotyczące użytkowników oraz ich uprawnień gromadzone są w bazie mieszczącej się w osobnym pliku z rozszerzeniem .ini. Zalogowanie się użytkownika określonego poziomu zabezpieczeń (1-5) odpowiada wprowadzeniu na stałe hasła z odpowiedniego poziomu. Dodatkowym atutem stosowania systemu logowania jest mechanizm pozwalający na śledzenie operacji logowania, wylogowania oraz 3-krotnego błędnego wprowadzenia hasła. Zdarzenia te są zapisywane w logu alarmów. Ponadto system logowania zapewnia wgląd do danych aktualnie zalogowanego użytkownika.

Oprogramowanie Asix zapewnia pełną kompatybilność systemów: haseł oraz logowania. W przypadku stosowania systemu logowania użytkowników - jest on w pełni zintegrowany z systemem blokad haseł poziomowych oraz indywidualnych.

Szczegóły dotyczące parametryzacji systemu logowania omówione zostały w rozdziale 9.6. System logowania.


16. Akcje operatorskie

Akcje operatorskie są podstawowym środkiem sterowania pracą aplikacji przez operatora. Akcje mogą być udostępniane operatorowi, przez projektanta systemu, za pomocą obiektów klasy PRZYCISK, Zestawów Klawiszy lub definiowanych menu.

Akcje opisywane są poprzez łańcuchy tekstowe. Opisy akcji wprowadzane są w odpowiednich polach edycyjnych. Pola te dokonują automatycznego formatowania tekstu, jeżeli wprowadzony zostanie poprawny tekst. Opis akcji składa się z nazwy akcji oraz jej parametrów. Poszczególne elementy opisu oddzielane są spacjami lub przecinkami. Ilość i typ parametrów zależy od typu akcji. W niektórych przypadkach możliwe jest pominięcie pewnych parametrów, co oznacza przyjęcie wartości domyślnych. Istnieje 5 typów parametrów: tekst, symbol (tekst wybrany z dozwolonego zestawu), liczba całkowita, liczba zmiennoprzecinkowa i iczba szesnastkowa.

Dla nazw akcji oraz symboli nie ma znaczenia rodzaj użytych liter (formatowanie zmienia litery na duże). Typ liter może mieć znaczenie tylko dla niektórych parametrów tekstowych. W przypadku nazw akcji i parametrów symbolicznych wystarczające jest wprowadzenie liter początkowych jednoznacznie identyfikujących akcję lub symbol.

Czasami opisy akcji są deklarowane w plikach tekstowych bez pośrednictwa pól formatujących (dotyczy to przypadku akcji złożonych). Zasady opisywania akcji nie ulegają jednak zmianie. Nie trzeba używać pełnych sformatowanych opisów. Każda forma opisu, która byłaby przyjęta przez pole formatujące jest dozwolona i zostanie poprawnie wykonana.

Parametry typu tekstowego mogą być ujęte znakami "", co pozwala na przekazanie spacji wewnątrz parametru.

Dla wygody projektanta istnieje możliwość użycia edytora budowy akcji operatorskich, wywoływanego kliknięciem prawym przyciskiem myszy w polu edycyjnym, w którym wprowadzana jest akcja operatorska. W kolejnym podpunkcie zamieszczono opisy akcji operatorskich ze wskazaniem sposobu ich parametryzacji przy użyciu Edytora akcji.

Rysunek: Okno edytora akcji operatorskich.


16.2. Opisy akcji operatorskich

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 16. Akcje operatorskie > 16.1. Opisy akcji operatorskich

16.1. Opisy akcji operatorskich

Lista dostępnych akcji operatorskich obejmuje:

AKCJA ZŁOŻONA - sekwencja dowolnego zestawu akcji operatorskich

ASAUDIT - sterowanie wyświetlaniem okien programów modułu AsAudit

ASBASE - pozwala na zdalne sterowanie pracą programu AsBase

ASRAPORT - powoduje uruchomienie programu do wyświetlania nowych raportów

ASTREND - sterowanie pracą programu ASTREND, w tym możliwość wyświetlenia lub wydrukowania trendu

DRUKUJ - wydrukowanie pliku

FILTR_SERWERÓW - blokowanie dostępu do stanowisk sieciowych

GRAJ - odtworzenie pliku typu WAV

HASŁO - odpytanie operatora o hasło

KONIEC - zakończenie pracy programu AS

KURSOR - ustawienie pozycji kursora

LANGUAGE - przełączenie języka aplikacji

LICZ_RAPORT - obliczenie raportu

LOGUJ - logowanie użytkowników

MAKRO - odtworzenie makra

MENU - otwarcie zdefiniowanego menu

NIC - akcja pusta

OBLICZ - otwarcie okna dialogów

OBSŁUGA_HASEŁ - otwarcie okna zarządzania hasłami

ODCZYT_HISTORII - uzupełnienie danych historycznych z drajwerów

OPIS_ZMIENNEJ - wyświetlenie informacji na temat wskazanej zmiennej

OTWÓRZ_MASKĘ - otwarcie maski

PANEL - selekcja Panelu Kontrolnego

PASEK_WYKRESOW - otwarcie paska narzędziowego obiektu WYKRES

PAUZA - wstrzymanie działania programu

PISZ_RAPORT - obliczenie i wydrukowanie raportu

POKAŻ_RAPORT - obliczenie i wyświetlenie raportu

POŁĄCZ_ALARMY - przyłączenie do określonego źródła alarmów historycznych

POTWIERDŹ_ALARMY - potwierdzenie alarmów na maskach alarmów aktywnych

PRZEŁĄCZ_ZASÓB_ALARMÓW - dynamiczne przełączanie zasobów alarmów

PRZEPISZ - przesłanie wartości pomiędzy zmiennymi procesowymi

PYTAJ - otwarcie okna z pytaniem do operatora

RAPORTUJ - otwarcie okna systemu raportów

SKRYPT - zlecenie wykonania skryptu

STERUJ_BITY - wysłanie wartości bitowej do sterownika

SYGNAŁY - wybór alarmów, których pojawienie się powoduje sygnalizację dźwiękową

SYNCHRONIZUJ_ARCHIWUM -akcja operatorska wymusza wykonanie przez moduł Aspad synchronizacji

TABELA - otwarcie okna tabeli zmiennych

UCISZ_SYGNAL - wyłączenie sygnału dźwiękowego alarmu

UKRYJ_WSZYSTKO - zwinięcie całej aplikacji do ikony

URUCHOM - uruchomienie programu

USTAW_WARTOŚĆ - wysłanie wartości liczbowej do sterownika

USTAW WYKRES - ustawianie czasu obiektu WYKRES

WYDRUK_EKRANU - powoduje wydruk całego ekranu lub aktywnego okna

WYKLUCZENIE - zmiana stanu wykluczenia alarmu

WYLOGUJ - natychmiastowe wylogowanie aktywnego użytkownika

WYŚLIJ_STEROWANIA - zlecenie wysłania sterowań przez obiekty na maskach

ZAMKNIJ_MASKĘ - zamknięcie maski

ZMIANA_CZASU - otwarcie okna służącego do zmiany czasu

ZMIEN_BITY - zmiana wartości wybranych bitów zmiennej procesowej

ZOBACZ - wyświetlenie pliku

AKCJA ZŁOŻONA

Akcja złożona stanowi sekwencję dowolnego zestawu akcji operatorskich, przypisanych do jednej akcji operatora.

Składnia akcji złożonych wpisywanych przez projektanta bezpośrednio w polach edycyjnych obiektów klasy PRZYCISK, Zestawów Klawiszy lub definiowanych menu) wygląda następująco:

AKCJA_ZŁOŻONA nazwa_akcji_złożonej[, tekst]

gdzie:

AKCJA_ZŁOŻONA - stały element deklaracji; można go zastąpić skrótem AK;

nazwa_akcji_złożonej - nazwa akcji złożonej służąca do lokalizacji akcji składowych;

tekst - dowolny tekst, który jest wstawiany do treści akcji składowych, w miejscu użycia znaczników ”%s". Pozwala on na tworzenie akcji, których treść jest zmienna.

***

Akcje złożone mogą być definiowane:

1. przy użyciu edytora akcji złożonych dostępnego w module Architekt:

Architekt > Obszary i komputery > moduł Skrypty i akcje > zakładka Akcje złożone:

Akcja wymaga zadeklarowania w tym miejscu nazwy jednoznacznie identyfikującej zestaw akcji operatorskich (nazwa akcji złożonej) oraz zdefiniowania akcji składowych (najlepiej za pomocą edytora akcji).

Dodatkowo generator bazy akcji złożonych umożliwia generowanie definicji akcji na podstawie danych zawartych w plikach *. act (przycisk Importuj akcje złożone (act)) i *.xls (przycisk Importuj akcje złożone (xls)) oraz eksportowanie definicji akcji do zewnętrznego pliku *.xls (przycisk Eksportuj akcje złożone (xls)).

2. jako kolejne parametry tekstowe pliku konfiguracyjnego aplikacji (Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe) zgodnie z następującą zasadą:

nazwa_akcji_złożonej=<składnia akcji składowej>

nazwa_akcji_złożonej=<składnia akcji składowej>

nazwa_akcji_złożonej=<składnia akcji składowej>

...

3. przy pomocy pliku tekstowego z rozszerzeniem *.ACT

Plik akcji jest zwykłym plikiem tekstowym, w którym każda linia opisuje jedną akcję. Pliki te należy umieszczać w kartotekach masek wizualizacyjnych.

Rysunek: Przykład pliku *.ACT opisującego składowe akcji złożonej.

do góry

ASAUDIT

ASAUDIT - umożliwia sterowanie wyświetlaniem okien programów modułu AsAudit zgodnie z parametrami:

Parametry akcji definiowane przy użyciu edytora akcji:

Okno - pozwala na wybór okna, które ma być uaktywnione. Może przybierać poniższe wartości:

Konsola - okno Konsoli AsAudit

Parametr: Notatka

Identyfikator segmentu - identyfikator zdefiniowany w Konfiguratorze programu AsAudit; służy do identyfikowania notatek skojarzonych z danym segmentem

Parametr: Login - aktywizuje okno Konsoli z otwartą sekcją logowania użytkowników

Konfigurator - okno Konfiguratora AsAudit

Przeglądarka - okno Przeglądarki AsAudit

Parametr: Notatka

Identyfikator segmentu - identyfikator zdefiniowany w Konfiguratorze programu AsAudit; służy do identyfikowania notatek skojarzonych z danym segmentem

Składnia akcji definiowana ręcznie:

ASAUDIT rodzaj_okna,parametry_okna

gdzie:

ASAUDIT - stały element deklaracji; można go zastąpić skrótem ASW;

Parametr rodzaj_okna

Znaczenie - pozwala na wybór okna, które ma być uaktywnione. Może przybierać poniższe wartości:

KONSOLA, CONSOLE - okno Konsoli AsAudit

KONFIGURATOR, CONFIG - okno Konfiguratora AsAudit

PRZEGLĄDARKA, BROWSER - okno Przeglądarki AsAudit

Typ - tekst.

Parametr parametry_okna

Notatka [,id_segmentu] - parametr dodany do okna Konsola powoduje otwarcie konsoli z przełączeniem na zakładkę notatek i preselekcją segmentu.

- parametr dodany do okna Przeglądarka powoduje otwarcie przeglądarki z przełączeniem na zakładkę notatek i ustawionym filtrem segmentu i flagi aktywności.

LOGIN - parametr dodany do okna Konsola aktywizuje okno Konsoli z otwartą sekcją logowania użytkowników

Dodatkowe wsparcie to ustawianie flag obecności aktywnych notatek w segmencie w zmiennych procesowych __id_segmentu__.

Mechanizm tez jest włączany, jeżeli użytkownik zdefiniuje odpowiednie zmienne.

W przypadku aktywizacji okien Konfiguratora i Przeglądarki, jeżeli te programy nie były wcześniej uruchomione, to zostaną one wystartowane przez akcję AsAudit.

Użycie Konsoli AsAudit zmienia także działanie innych akcji operatorskich związanych z obsługą haseł i użytkowników - akcje są blokowane lub powodują otwarcie okna Konsoli.

do góry

ASBASE

ASBASE - pozwala na zdalne sterowanie pracą programu AsBase.

Parametry akcji definiowane przy użyciu edytora akcji:

Typ operacji:

start - operacja powoduje uruchomienie modułu AsBase z przekazaniem mu parametrów; Jeżeli AsBase był już wcześniej uruchomiony, to operacja start jest równoważna operacji pokaż bez parametrów. Dodatkowym efektem użycia operacji start jest to, że w momencie końca pracy głównego modułu programu Asix zostanie również zakończona praca modułu Asbase. Struktura parametrów jest następująca:

nazwa_pliku_xml [/single][/minimize] /user:<id_uzytkownika>/password:<hasło>

gdzie:

nazwa_pliku_xml - plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

/single - powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

/minimize - powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna;

/user:<id_uzytkownika>/password:<hasło> - powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

pokaż - operacja powoduje uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch). Dodatkowe parametry pozwalają określić informację, która ma zostać pokazana w oknie:

Typ obszaru: RCP - wartości receptury, RLD - historia ładowań receptur, ARC - archiwum;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

Pokaż obszar - wyświetla zdefiniowany obszar;

Pokaż zestaw - wyświetla zdefiniowany obszar dla zestawu zmiennych, identyfikowanych identyfikatorem wpisywanym do pola Identyfikator zestawu;

Widok - wyświetla zdefiniowany obszar zgodnie z parametrami definiującymi sposób wyświetlania zawartości danej tabeli; widok identyfikowany jest za pomocą identyfikatora wpisywanego do pola Identyfikator widoku;

załaduj - operacja pozwala na załadowanie receptury zgodnie z parametrami:

ID grupy - określa grupę receptur, której operacja dotyczy;

ID zestawu - określa zestaw zmiennych, gdzie receptura ma być załadowana;

Nazwa receptury - jeżeli parametr ten zostanie podany, to wyświetlone zostanie okno z listą wszystkich receptur zdefiniowanych w grupie, z której operator będzie mógł wybrać recepturę, która ma być załadowana

nawiguj - operacja pozwala na przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu A six; parametry wymagane:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

Komenda - nazwa komendy, jaka ma zostać wykonana; można podać następujące komendy:

FIRST - pierwszy zapis tabeli,

NEXT - kolejny zapis tabeli,

PREVIOUS - poprzedni zapis tabeli,

LAST - ostatni zapis tabeli,

FILTER - nowy filtr: zdefiniowanie nowego filtru oraz wyświetlenie ostatniego zapisu z tabeli zgodnego z nowym filtrem,

COUNT - liczba wierszy: powoduje przypisanie do określonej zmiennej zestawu zmiennych liczby, która jest ilością zapisów w tabeli zgodnych z aktualnym filtrem;

LOAD - receptura: komenda powoduje załadowanie wskazanej receptury do zestawu zmiennych; działanie tego wariantu akcji zbliżone jest do wariantu ASBASE;

drukuj - operacja pozwala na wydrukowanie zawartości tabel bazy danych modułu AsBase; parametryzacja operacji obejmuje:

Typ obiektu: RCP - wartości receptur, RLD - historia ładowań receptur, ARC - archiwum zestawu rejestracji;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

ID widoku - jest identyfikatorem jednego z widoków skojarzonych z daną tabelą;

dodaj - operacja pozwala na dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

usuń - operacja pozwala na usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

zmień - operacja pozwala na zmianę bieżącego rekordu w tabeli bazy danych modułu AsBase;parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

Składnia akcji definiowana ręcznie:

ASBASE typ_operacji [parametry_operacji]

gdzie:

ASBASE - stały element deklaracji; można go zastąpić skrótem ASB;

typ_operacji:

STart - operacja powoduje uruchomienie modułu AsBase z przekazaniem mu parametrów podanych w parametry_operacji (z reguły nazwa pliku xml aplikacji). Jeżeli AsBase był już wcześniej uruchomiony, to operacja Start jest równoważna operacji Pokaż bez parametrów. Dodatkowym efektem użycia operacji Start jest to, że w momencie końca pracy programu AS zostanie również zakończona praca modułu Asbase. Struktura parametrów jest następująca:

nazwa_pliku_xml [/single][/minimize] /user:<id_uzytkownika>/password:<hasło>

gdzie:

nazwa_pliku_xml - plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

/single - powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

/minimize - powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna;

/user:<id_uzytkownika>/password:<hasło> - powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

POkaż - operacja powoduje uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch). W parametry_aplikacji można opcjonalnie dodać opis informacji, która ma zostać pokazana w oknie. Struktura parametrów jest następująca:

typ_obiektu\identyfikator_obiektu[\identyfikator_zestawu]

gdzie:

typ_obiektu może być równy:

RCP - żadanie wyświetlenia tabeli wartości receptur lub podglądu zestawu zmiennych związanych z grupą receptur;

RLD - żądanie wyświetlenia tabeli historii ładowań receptur;

ARC - żądanie wyświetlenia tabeli archiwum zestawu rejestracji lub podglądu zestawu zmiennych związanych z zestawem rejestracji;

identyfikator_obiektu - jest identyfikatorem zestawu rejestracji lub grupy receptur;

identyfikator_zestawu - jest opcjonalny, jest on identyfikatorem zestawu zmiennych.

Komenda Pokaż pozwala również na wybór widoku. Struktura parametrów jest następująca:

typ_obiektu\identyfikator_obiektu\\identyfikator_widoku

identyfikator_widoku - jest identyfikatorem widoku - czyli zestawu parametrów określających, w jaki sposób wyświetlana jest zawartość danej tabeli.

ZAładuj (LOad)

Znaczenie - operacja pozwala na załadownie receptury. Struktura parametry_operacji jest następująca:

identyfikator_grupy\identyfikator_zestawu[\nazwa_receptury]

gdzie:

identyfikator_grupy i identyfikator_zestawu określają odpowiednio grupę receptur, której operacja dotyczy oraz zestaw zmiennych, gdzie receptura ma być załadowana. Jeżeli nazwa_receptury zostanie podana, to akcja załaduje wskazaną recepturę do zestawu zmiennych. Jeżeli nazwa_receptury nie zostanie podana, to wyświetlone zostanie okno z listą wszystkich receptur zdefiniowanych w grupie, z której operator będzie mógł wybrać recepturę, która ma być załadowana.

Nawiguj (NAvigate)

Znaczenie - operacja pozwala na przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu Asix. Struktura parametry_operacji jest następująca:

identyfikator_połączenia\komenda[\definicja_filtru]

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

komenda - nazwa komendy, jaka ma zostać wykonana; można podać następujące komendy:

FIRST - powoduje wyświetlenie pierwszego zapisu tabeli,

NEXT - powoduje wyświetlenie kolejnego zapisu tabeli,

PREVIOUS - powoduje wyświetlenie poprzedniego zapisu tabeli,

LAST - powoduje wyświetlenie ostatniego zapisu tabeli,

FILTER - powoduje zdefiniowanie nowego filtru oraz wyświetlenie ostatniego zapisu z tabeli zgodnego z nowym filtrem,

COUNT - powoduje przypisanie do określonej zmiennej zestawu zmiennych liczby, która jest ilością zapisów w tabeli zgodnych z aktualnym filtrem;

definicja_filtru - definicja nowego filtru; ten parametr podaje się tylko dla komendy FILTER; zasady konstruowania definicji filtru zostały opisane w części 19.4.1. Obiekt ASBASE.

Drukuj (PRint)

Znaczenie - operacja pozwala na wydrukowanie zawartości tabel bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

typ_obiektu\identyfikator_obiektu[\identyfikator_widoku]

gdzie:

typ_obiektu - może przyjąć postać:

RCP - tabela wartości receptur;

RLD - tabela historii ładowań receptur;

ARC - tabela archiwum zestawu rejestracji;

identyfikator_obiektu - jest identyfikatorem zestawu rejestracji lub grupy receptur;

identyfikator_widoku - parametr opcjonalny; jest identyfikatorem jednego z widoków skojarzonych z daną tabelą.

DOdaj - operacja pozwala na dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: 19.4.1. Obiekt ASBASE);

USuń - operacja pozwala na usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: 19.4.1. Obiekt ASBASE);

ZMień - operacja pozwala na zmianę bieżącego rekordu w tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: 19.4.1. Obiekt ASBASE);

do góry

ASRAPORT

ASRAPORT - powoduje uruchomienie programu służącego do wyświetlania raportów utworzonych przy użyciu usług Microsoft SQL Server Reporting Services.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa raportu - nazwa raportu utworzonego przy użyciu usług Reporting Services (definicja raportu przechowywana w pliku *.RDL musi być opublikowana na serwerze raportów usług Reporting Services).

Opcjonalny plik konfiguracyjny – pole umożliwia zadeklarowanie pliku konfiguracyjnego wskazującego na inny serwer raportów bądź katalog raportów niż te zadeklarowane w pliku konfiguracyjnym bieżącej aplikacji.

Plik konfiguracyjny aplikacji Asixa umożliwia zadeklarowanie 1 serwera raportów i 1 katalogu na tym serwerze (serwer i katalog deklarowane są przy pomocy konfiguratora systemu raportowania AsRaport dostępnego w Architekcie).

Aby wyświetlić raport z innego źródła (serwera, katalogu), należy utworzyć nowy plik konfiguracyjny aplikacji Asixa z deklaracją innego serwera i katalogu. Wymagane jest aby w tym pliku skonfigurować parametry ustawiane przy pomocy konfiguratora systemu AsRaport oraz 3 inne parametry:

- położenie bazy definicji zmiennych (Architekt > Bazy danych > Baza definicji zmiennych > Format)

- nazwa sieciowa zestawu alarmów (Architekt > Obszary i komputery > System alarmów > Alarmy > Nazw sieciowa)

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów (Architekt > Obszary i komputery > System alarmów > Archiwum > Serwer Microsoft SQL)

Pozostałe parametry konfiguracyjne są w tym przypadku nieistotne. Następnie należy zadeklarować ten plik konfiguracyjny w polu Opcjonalny plik konfiguracyjny akcji AsRaport.

Domyślnie informacje na temat serwera raportów i katalogu raportów pobierane są z pliku konfiguracyjnego bieżącej aplikacji Asixa.

Nazwa parametru raportu - opcja umożliwia wprowadzanie opcjonalnych parametrów raportu.

Składnia akcji definiowana ręcznie:

ASRAPORT <nazwa_raportu>[<opcjonalny_plik_konfiguracyjny><parametry_raportu>]

gdzie:

nazwa_raportu - nazwa raportu utworzonego przy użyciu usług Reporting Services (definicja raportu przechowywana w pliku *.RDL musi być opublikowana na serwerze raportów usług Reporting Services);

opcjonalny_plik_konfiguracyjny - pole umożliwia zadeklarowanie pliku konfiguracyjnego wskazującego na inny serwer raportów bądź katalog raportów niż te zadeklarowane w pliku konfiguracyjnym bieżącej aplikacji.

Plik konfiguracyjny aplikacji Asixa umożliwia zadeklarowanie 1 serwera raportów i 1 katalogu na tym serwerze (serwer i katalog deklarowane są przy pomocy konfiguratora systemu raportowania AsRaport dostępnego w Architekcie).

Aby wyświetlić raport z innego źródła (serwera, katalogu), należy utworzyć nowy plik konfiguracyjny aplikacji Asixa z deklaracją innego serwera i katalogu. Wymagane jest aby w tym pliku skonfigurować parametry ustawiane przy pomocy konfiguratora systemu AsRaport oraz 3 inne parametry:

- położenie bazy definicji zmiennych (Architekt > Bazy danych > Baza definicji zmiennych > Format)

- nazwa sieciowa zestawu alarmów (Architekt > Obszary i komputery > System alarmów > Alarmy > Nazw sieciowa)

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów (Architekt > Obszary i komputery > System alarmów > Archiwum > Serwer Microsoft SQL)

Pozostałe parametry konfiguracyjne są w tym przypadku nieistotne. Następnie należy zadeklarować ten plik konfiguracyjny w polu Opcjonalny plik konfiguracyjny akcji AsRaport.

Domyślnie informacje na temat serwera raportów i katalogu raportów pobierane są z pliku konfiguracyjnego bieżącej aplikacji Asixa.

parametry_raportu - dodatkowe parametry raportu

do góry

ASTREND

ASTREND - umożliwia otwarcie okienka programu AsTrend z jednoczesnym wyświetleniem trendu wg definicji zapisanej w pliku *.trnx lub wydruk wskazanego trendu.

Parametry akcji definiowane przy użyciu edytora akcji:

Tryb:

Wyświetl wykres trendu w sposób określony przez następujące parametry:

Trend - nazwa pliku z domyślnym rozszerzeniem trn, który zawiera uprzednio przygotowaną definicję trendu wyświetlanego przez program AsTrend; wpisanie znaku ”?" powoduje otwarcie okna, w którym Użytkownik może wybrać trend do wyświetlenia;

Położenie okna - współrzędne x i y lewego górnego narożnika okienka programu ASTREND; ma zastosowanie w systemach wielomonitorowych;

Monitor - wskazanie monitora, na którym powinno otworzyć się okienko programu ASTREND (dotyczy systemów wielomonitorowych):

-1 - monitor wynikający z definicji maski,

0 - monitor, gdzie znajduje się kursor,

1 - monitor podstawowy,

2 - drugi monitor,

3 - trzeci monitor,

4 - czwarty monitor,

…

8 - ósmy monitor;

Katalog roboczy - kartoteka, z której ma zostać odczytana definicja trendu;

Początek okresu - czas, dla którego trend ma być wyświetlony; parametr może być czasem w formacie OPC (absolutnym lub względnym) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w formacie OPC (absolutnym lub względnym).

Koniec okresu - koniec okresu, dla którego trend ma być wyświetlony; parametr może być czasem w formacie OPC (absolutnym lub względnym) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w formacie OPC (absolutnym lub względnym).

Rysunek: Edytor czasu w formacie OPC.

Drukuj wykres trendu w sposób określony przez następujące parametry:

Trend - nazwa pliku z domyślnym rozszerzeniem trn, który zawiera uprzednio przygotowaną definicję trendu wyświetlanego przez program AsTrend; wpisanie znaku ”?" powoduje otwarcie okna, w którym Użytkownik może wybrać trend do wyświetlenia;

Tytuł - tytuł trendu na wydruku;

Nagłówek - nagłówek trendu na wydruku;

Stopka - stopka trendu na wydruku;

Początek okresu - czas, dla którego trend ma być wyświetlony; parametr może być czasem w formacie OPC (absolutnym lub względnym) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w formacie OPC (absolutnym lub względnym).

Oba powyższe tryby mają możliwość zadeklarowania zmiennych ze wskazanej bazy definicji zmiennych, które po załadowaniu pliku zostaną wymienione lub dodane do zmiennych zadeklarowanych w pliku definicji trendu. Zmienne należy wskazać na zakładce Dodaj/wymień zmienne, a bazę definicji zmiennych na zakładce VarDef.

Składnia akcji definiowana ręcznie:

ASTREND trend[, x, y, monitor, kartoteka, baza_zmiennych, czas_trendu] tryb_pracy tekst_tytułu tekst_nagłówka tekst_stopki

gdzie:

ASTREND - stały element deklaracji; można go zastąpić skrótem AST;

trend - nazwa pliku z domyślnym rozszerzeniem trn, który zawiera uprzednio przygotowaną definicję trendu wyświetlanego przez program AsTrend. Wpisanie znaku ”?" powoduje otwarcie okna, w którym Użytkownik może wybrać trend do wyświetlenia.

Po nazwie pliku .trn można podać nazwy zmiennych, które zostaną dodane do wykresu zmiennych zadeklarowanych w definicji trendu (pliku .trn). Nazwy zmiennych należy oddzielić znakiem #.

Typ - tekst.

Parametry x,y

Znaczenie - współrzędne x i y lewego górnego narożnika okienka programu AsTrend. Wartość -1 oznacza pobranie odpowiedniej współrzędnej z definicji trendu. Pozycja ma zastosowanie w systemach wielomonitorowych.

Typ - liczba dziesiętna.

Wartość domyślna - -1

Parametr monitor

Znaczenie - wskazanie monitora, na którym powinno otworzyć się okienko programu AsTrend (dotyczy systemów wielomonitorowych). Wartość 0 oznacza monitor, na którym aktualnie znajduje się kursor myszki, -1 oznacza monitor wynikający z przyjętych parametrów x, y. Pozycja ma zastosowanie w systemach wielomonitorowych.

Typ - liczba dziesiętna.

Wartość domyślna - -1

Parametr kartoteka

Znaczenie - podanie kartoteki, z której ma zostać odczytana definicja trendu (plik*.trn).

Typ - tekst.

Parametr baza_zmiennych

Znaczenie - nazwa bazy zmiennych (zestawu zmiennych, plik *.zez), którą należy załadować.

Typ - tekst.

Parametr czas_trendu

Znaczenie - określenie czasu, dla którego trend ma być wyświetlony; parametr może być czasem bezwzględnym w postaci yyyymmddhhnnss, czasem w formacie OPC (szczegóły na temat formatu czasu OPC omawia plik pomocy do AsixConnecta5: w rozdziale 7.4. Format czasu OPC) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w postaci yyyymmddhhnnss lub w formacie OPC; dodana została również obsługa końca okresu trendu - dzięki czemu parametr czas_trendu może być połączeniem czasów (rozdzielonych średnikiem) początku i końca okresu.

Typ - tekst/liczba.

Parametr tryb_pracy

Znaczenie - określa tryb otwarcia pliku trendu; dostępne opcje:

DRUKUJ_WYKRES - powoduje wydrukowanie wskazanego trendu,

POKAŻ_ WYKRES - powoduje wyświetlenie wykresu trendu.

Typ - tekst.

Parametr tekst_tytułu

Znaczenie - określa nowy tytuł wydruku, zastępujący tytuł zdefiniowany w pliku trendu; parametr dla trybu POKAŻ_ WYKRES;

Typ - tekst.

Parametr tekst_nagłówka

Znaczenie - określa nowy nagłówek wydruku, zastępujący nagłówek zdefiniowany w pliku trendu; parametr dla trybu POKAŻ_ WYKRES;

Typ - tekst.

Parametr tekst_stopki

Znaczenie - określa nowy tekst stopki wydruku, zastępujący stopkę zdefiniowaną w pliku trendu; parametr dla trybu POKAŻ_ WYKRES;

Typ - tekst.

do góry

DRUKUJ

DRUKUJ - zlecenie wydrukowania pliku.

Parametry akcji definiowane przy użyciu edytora akcji:

nazwa_pliku - nazwa pliku, który ma zostać wydrukowany.

Składnia akcji definiowana ręcznie:

DRUKUJ nazwa_pliku

gdzie:

DRUKUJ - stały element deklaracji; można go zastąpić skrótem DR;

Parametr nazwa_pliku

Znaczenie - nazwa pliku, który ma zostać wydrukowany.

Typ - tekst.

do góry

FILTR_SERWERÓW

FILTR_SERWERÓW - ustawienie informacji dla modułu Aslink, z jakimi stanowiskami może się łączyć. Akcja tylko dla specjalnych zastosowań, gdy chce się sterować źródłem pochodzenia danych.

Parametry akcji definiowane przy użyciu edytora akcji:

nazwa_serwera - nazwa sieciowa komputera, do którego można się przyłączyć. Można używać znaków * i ? dla określenia grupy komputerów.

Składnia akcji definiowana ręcznie:

FILTR_SERWERÓW nazwa_serwera

gdzie:

FILTR_SERWERÓW - stały element deklaracji; można go zastąpić skrótem FIL;

Parametr nazwa_serwera

Znaczenie - nazwa sieciowa komputera do którego można się przyłączyć. Można używać znaków * i ? dla określenia grupy komputerów.

Typ - tekst.

Akcja tylko dla specjalnych zastosowań, gdy chce się sterować źródłem pochodzenia danych.

do góry

GRAJ

GRAJ - odtwarzanie pliku typu WAV.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa pliku - nazwa pliku typu WAV, którego zawartość ma być odegrana; przycisk z prawej strony pola umożliwia odsłuchanie pliku.

Składnia akcji definiowana ręcznie:

GRAJ [nazwa_pliku]

gdzie:

GRAJ - stały element deklaracji; można go zastąpić skrótem GRA;

Parametr nazwa_pliku

Znaczenie - nazwa pliku typu WAV, którego zawartość ma być odegrana.

Typ - tekst.

Wartość domyślna - brak parametru powoduje przerwanie wcześniej rozpoczętego odtwarzania.

Wymagana jest instalacja karty dźwiękowej w komputerze.

do góry

HASŁO

HASŁO - akcja jest przeznaczona do użycia jako element składowy akcji złożonych. Jeżeli operator nie poda prawidłowego hasła, to wykonanie akcji złożonej zostaje natychmiast przerwane.

Parametry akcji definiowane przy użyciu edytora akcji:

Hasło lub poziom uprawnień - rozwijane pole umożliwia zadeklarowanie odpowiedniego poziomu uprawnień (dla którego zostało przypisane hasło), bądź podanie hasła. W obu przypadkach do wykonania akcji będzie wymagane podanie hasła przez operatora.

Składnia akcji definiowana ręcznie:

HASŁO hasło

gdzie:

HASŁO - stały element deklaracji; można go zastąpić skrótem HAS;

Parametr hasło

Znaczenie - treść hasła.

Typ - tekst.

do góry

KONIEC

KONIEC - zakończenie pracy głównego modułu systemu Asix; akcja równoznaczna z komendą MASKI.KONIEC w oknie Panelu Kontrolnego (zamknięciem Panelu Kontrolnego). Akcja pozwala na zakończenie pracy programu nawet wtedy, gdy w Zabezpieczeniach aplikacji został włączony parametr Blokada zamykania aplikacji.

Parametry akcji definiowane przy użyciu edytora akcji:

Hasło lub poziom uprawnień - rozwijane pole umożliwia zadeklarowanie odpowiedniego poziomu uprawnień (dla którego zostało przypisane hasło), bądź podanie hasła - skutkiem czego w obu przypadkach do zamknięcia aplikacji będzie wymagane podanie hasła.

Składnia akcji definiowana ręcznie:

KONIEC [hasło]

gdzie:

KONIEC - stały element deklaracji; można go zastąpić skrótem KON;

Parametr hasło

Znaczenie - treść hasła, które należy znać aby zakończyć aplikację.

Typ - tekst.

Wartość domyślna - brak podania hasła oznacza zastosowanie hasła podanego w pozycji BLOKADA_KONCA pliku inicjującego lub jeżeli pozycja ta nie jest użyta, wyjście bez kontroli hasła.

Akcja pozwala na zakończenie pracy programu nawet wtedy, gdy w pliku konfiguracyjnym aplikacji został włączony parametr Blokada zamykania aplikacji. Treść hasła może być inna niż zadeklarowane hasła dla poziomu 1-4 i nie może być zmieniana z poziomu aplikacji.

do góry

KURSOR

KURSOR - ustawienie kursora myszki w zadanej pozycji; akcja przeznaczona dla tworzenia prezentacji.

Parametry akcji definiowane przy użyciu edytora akcji:

x, y - określają nową pozycję myszki.

Składnia akcji definiowana ręcznie:

KURSOR x, y

gdzie:

KURSOR - stały element deklaracji; można go zastąpić skrótem KUR;

Parametry x, y

Znaczenie - określenie nowej pozycji myszki.

Typ - liczba całkowita.

Akcja przeznaczona dla tworzenia prezentacji.

do góry

LANGUAGE

LANGUAGE - wykonanie akcji z podanym kodem powoduje przełączenie języka aplikacji. Brak parametru powoduje otwarcie okna wyboru języka.

Parametry akcji definiowane przy użyciu edytora akcji:

Język - umożliwia wybór jednego z zadeklarowanych kodów języków projektowanej aplikacji.

Składnia akcji definiowana ręcznie:

LANGUAGE [kod_języka]

gdzie:

LANGUAGE - stały element deklaracji; można go zastąpić skrótem LAN;

Parametr kod_języka

Znaczenie - dwuliterowy kod języka; zaleca się zachowanie zgodności z normą ISO639; kod języka używany jest do selekcji aktywnego języka i wyboru właściwych wersji tekstów używanych w aplikacji; w miejsce parametru może zostać wpisany kod języka, który uprzednio został zadeklarowany na zakładce Języki modułu Parametry startowe programu Architekt;

np.: pl - polski, en-angielski

Typ - tekst.

Wartość domyślna - brak.

do góry

LICZ_RAPORT

LICZ_RAPORT - obliczenie wyspecyfikowanego raportu. Policzony raport zapisany zostanie na dysku.

Parametry akcji definiowane przy użyciu edytora akcji:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem, znajdującym się z prawej strony pola - ’Edytor momentów języka ASTEL’:

Rysunek: Edytor momentów języka ASTEL.

Nazwisko operatora - nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - treść notatki (o ile pojawia się w definicji raportu).

Składnia akcji definiowana ręcznie:

LICZ_RAPORT plik moment [operator] [notatka]

gdzie:

Skrót - stały element deklaracji; można go zastąpić skrótem LI;

Parametr plik

Znaczenie - nazwa pliku z definicją raportu (pełna ścieżka).

Typ - tekst.

Parametr moment

Znaczenie - moment rozpoczęcia raportu w konwencji języka ASTEL.

Typ - tekst.

Parametr operator

Znaczenie - nazwisko operatora (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak nazwiska.

Parametr notatka

Znaczenie - treść notatki (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak notatki.

do góry

LOGUJ

LOGUJ - akcja otwierająca okno służące do logowania użytkowników aplikacji pakietu Asix w przypadku stosowania systemu logowania.

Składnia akcji definiowana ręcznie:

LOGUJ

gdzie:

LOGUJ - stały element deklaracji; można go zastąpić skrótem LOG.

do góry

MAKRO

MAKRO - odegranie makra (sekwencji demonstracyjnej) zapisanej w pliku. W czasie odegrania zachowane są wszystkie uzależnienia czasowe. Akcja przeznaczona do tworzenia prezentacji.

Parametry akcji definiowane przy użyciu edytora akcji:

nazwa_pliku - nazwa pliku zawierającego makro. Plik ten musi być utworzony poprzez nagranie sekwencji demonstracyjnej (komenda OPCJE.SEKWENCJA.DEMO w oknie Konstruktora), a następnie przemianowanie pliku replayw.dem.

Składnia akcji definiowana ręcznie:

MAKRO nazwa_pliku

gdzie:

MAKRO - stały element deklaracji; można go zastąpić skrótem MAK;

Parametr nazwa_pliku

Znaczenie - nazwa pliku zawierającego makro. Plik ten musi być utworzony poprzez nagranie sekwencji demonstracyjnej (komenda OPCJE.SEKWENCJA.DEMO), a następnie przemianowanie pliku replayw.dem

Typ - tekst.

Akcja przeznaczona dla tworzenia prezentacji.

do góry

MENU

MENU - akcja wyświetla menu typu pop-up, którego postać definiowana jest przy użyciu programu Architekt (można również wyświetlić menu, którego definicja utworzona została w pliku *.pum).

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa menu - nazwa menu opisującego strukturę tworzonego menu; pole umożliwia wywołanie okna z wyborem definicji menu, które zostały zdefiniowane w programie Architekt (pierwszy przycisk w polu Nazwa menu) lub wywołanie okna, umożliwiającego wskazanie pliku *.pum z definicją menu (drugi przycisk w polu Nazwa menu).

Położenie - wskazuje miejsce, w którym ma się docelowo otwierać menu na masce aplikacji. Wartość parametru zależy od kontekstu użycia akcji - jeżeli akcja wywoływana będzie z obiektu PRZYCISK, to jako wartość parametru Położenie przyjmuje się położenie obiektu. W innych wypadkach przyjmuje się współrzędne (100,100).

Aktywowanie mechanizmu zamiany zmiennych procesowych:

Zakładka Zamiana zmiennych:

Aby użyć mechanizmu zamiany zmiennych procesowych, należy zdefiniować nazwę pliku VRT (pole Nazwa pliku VRT) lub ręcznie wpisać listę zamienianych zmiennych (opcja Lista zmian). W przeciwnym przypadku mechanizm podmiany zmiennych nie będzie użyty.

Format pliku VRT przyjmuje następującą postać:
linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;
linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej.

Składnia akcji definiowana ręcznie:

MENU nazwa_menu [x][y][parametry_zamian]

gdzie:

MENU - stały element deklaracji; można go zastąpić skrótem ME;

Parametr nazwa_menu

Znaczenie - nazwa menu opisującego strukturę tworzonego menu.

Typ - tekst.

Parametry x y

Znaczenie - miejsce, w którym należy utworzyć menu.

Typ - liczba całkowita.

Wartość domyślna - zależy od kontekstu użycia akcji. Jeżeli wywołana z obiektu PRZYCISK, to przyjmuje się położenie obiektu. W innych wypadkach przyjmuje się współrzędne (100,100).

Parametr parametry_zamian

Znaczenie - w przypadku stosowania mechanizmu zamiany zmiennych procesowych należy zastosować jeden z poniższych wariantów:

1. plik zamian - w pliku o rozszerzeniu VRT należy podać sposób zamiany nazw zmiennych. Format pliku przyjmuje następującą postać:
linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;
linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej

2. zmienna_źródłowej_1;zmienna_wstawiana_1[...#zmienna_źródłowej_n;zmienna_wstawiana_n]

W tym wariancie wszystkie pary zamienników są podawane wprost w treści akcji.

Typ - tekst.

Patrz: część „Architekt - Parametryzacja aplikacji” , rozdz. 4.5.6 Definicje menu umieszczanego na masce aplikacji.

do góry

NIC

NIC - akcja pusta. Akcja przeznaczona jest dla blokady wykonania akcji klawiszowych, zdefiniowanych na innych maskach. Przyłączenie do maski zestawu klawiszy z akcjami NIC powoduje, że w czasie gdy maska jest aktywna, akcje klawiszowe (dla wybranych klawiszy) z innych masek nie są wykonywane.

Składnia akcji definiowana ręcznie:

NIC

gdzie:

NIC - stały element deklaracji.

Akcja przeznaczona jest dla blokady wykonania akcji klawiszowych zdefiniowanych na innych maskach. Przyłączenie do maski zestawu klawiszy z akcjami NIC powoduje, że w czasie gdy maska jest aktywna, akcje klawiszowe (dla wybranych klawiszy) z innych masek nie są wykonywane.

do góry

OBLICZ

OBLICZ - otwarcie okna Dialogów. Akcja równoznaczna z wykonaniem komendy NARZĘDZIA.OKNO_DIALOGÓW z poziomu Panelu Kontrolnego.

Parametry akcji definiowane przy użyciu edytora akcji:

x, y - określenie pozycji, na której okno Panelu Dialogowego ma być otwarte.

Składnia akcji definiowana ręcznie:

OBLICZ [x] [y]

gdzie:

OBLICZ - stały element deklaracji; można go zastąpić skrótem OBL;

Parametry x y

Znaczenie - określenie pozycji, na której okno Dialog ma być otwarte.

Typ - liczba całkowita.

Wartość domyślna - okno otwierane na pozycji ostatnio zapamiętanej.

do góry

OBSŁUGA_HASEŁ

OBSŁUGA_HASEŁ - otwarcie okna zarządzania hasłami.

Składnia akcji definiowana ręcznie:

OBSŁUGA_HASEŁ

gdzie:

OBSŁUGA_HASEŁ - stały element deklaracji; można go zastąpić skrótem OBL.

do góry

ODCZYT_HISTORII

ODCZYT_HISTORII - akcja wymusza wykonanie przez moduł Aspad uzupełniania danych historycznych z drajwerów poza cyklem wynikającym z deklaracji na zakładce Pobieranie danych historycznych w module Dane archiwalne programu Architekt.

Składnia akcji definiowana ręcznie:

ODCZYT_HISTORII

gdzie:

ODCZYT_HISTORII - stały element deklaracji; można go zastąpić skrótem ODC;

Parametry x y

Znaczenie - określenie pozycji, na której okno Dialog ma być otwarte.

do góry

OPIS_ZMIENNEJ

OPIS_ZMIENNEJ - wyświetlenie informacji na temat wskazanej zmiennej, znajdującej się w bazie definicji zmiennych.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna - określenie zmiennej Asmena, której opis, zawarty w bazie danych, ma być wyświetlony.

Atrybuty zmiennej:

- Wszystkie;

- Zestaw - pole wyboru umożliwia wybór jednego z zestawów, zadeklarowanego dla danej aplikacji;

- Podane - lista atrybutów oddzielonych przecinkiem; nie może zawierać znaków spacji i średnika.

Składnia akcji definiowana ręcznie:

OPIS_ZMIENNEJ nazwa_zmiennej[;atrybuty zmiennej]

gdzie:

OPIS_ZMIENNEJ - stały element deklaracji; można go zastąpić skrótem OPI;

Parametr nazwa_zmiennej

Znaczenie - określenie zmiennej Asmena, której opis, zawarty w bazie danych, ma być wyświetlony.

Typ - tekst.

Parametr parametry_zmiennej

Znaczenie - określenie atrybutów, które mają być wyświetlane.

Typ - tekst.

do góry

OTWÓRZ_MASKĘ

OTWÓRZ_MASKĘ - akcja pozwalająca na otwarcie dowolnej maski wizualizacyjnej (schematowej lub alarmów); dodatkowo istnieje możliwość sparametryzowania akcji w taki sposób, aby w momencie otwierania maski nastąpiła zamiana zmiennych procesowych na inne wskazane przez projektanta.

Próba otwarcia maski już otwartej powoduje wybranie jej jako nowej maski bieżącej. Zasady zamykania innych masek pozostają wtedy niezmienione.

Aktywowanie mechanizmu zamiany zmiennych procesowych na maskach:

Zakładka Zamiana zmiennych:

Aby użyć mechanizmu zamiany zmiennych procesowych, należy zdefiniować nazwę pliku VRT (pole Nazwa pliku VRT) lub ręcznie wpisać listę zamienianych zmiennych (opcja Lista zmian). W przeciwnym przypadku mechanizm podmiany zmiennych nie będzie użyty.

Format pliku VRT przyjmuje następującą postać:
linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;
linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej.

***

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa maski - nazwa maski, którą należy otworzyć. Rodzaj użytych liter nie ma znaczenia.

Tryb otwarcia:

zamiana - maska bieżąca zostanie zamknięta, po czym otwarta będzie nowa maska,

zastąpienie - podobnie jak ’zamiana’, lecz nowa maska zostanie otwarta fizycznie w miejscu, gdzie znajdowała się maska zamykana (identyczne będą współrzędne x,y lewego, górnego narożnika maski),

wymiana - zostaną zamknięte wszystkie maski nie zablokowane (posiadające zezwolenie na zamknięcie), po czym otwarta będzie nowa maska,

ograniczona wymiana - tak samo jak dla trybu ’wymiana’, lecz maska bieżąca nie zostanie zamknięta nawet wtedy, gdy nie jest zablokowana,

nowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą,

dialog - otwarcie nowej maski nie ma wpływu na maskę bieżącą; po otwarciu nie będzie możliwości przejścia do innej maski, aż do momentu zamknięcia maski utworzonej w wyniku tej akcji,

chwilowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą. Późniejsze przejście na inną maskę spowoduje automatyczne zamknięcie maski chwilowej.

Położenie - miejsce na ekranie, gdzie maska ma być otwarta określone jako współrzędne jej lewego górnego narożnika. Brak parametrów lub wartości -1 oznaczają, że maska ma zostać otwarta zgodnie z jej pierwotna definicją. Pozycja ma zastosowanie w systemach wielomonitorowych.

Monitor - określenie monitora, na którym maska ma zostać otwarta (w systemie wielomonitorowym):

-1 - monitor wynikający z definicji maski,

0 - monitor, gdzie znajduje się kursor,

1 - monitor podstawowy,

2 - drugi monitor,

3 - trzeci monitor,

4 - czwarty monitor,

…

8 - ósmy monitor;

Składnia akcji definiowana ręcznie:

OTWÓRZ_MASKĘ nazwa_zmiennej[;atrybuty zmiennej]

gdzie:

OTWÓRZ_MASKĘ - stały element deklaracji; można go zastąpić skrótem OTW;

Parametr nazwa_maski

Znaczenie - nazwa maski, którą należy otworzyć. Rodzaj użytych liter nie ma znaczenia.

Typ - tekst.

Parametr tryb otwarcia

Znaczenie - określenie trybu otwarcia maski.

Typ - symbol:

zamiana - maska bieżąca zostanie zamknięta, po czym otwarta będzie nowa maska;

zastąpienie - podobnie jak zamiana, lecz nowa maska zostanie otwarta fizycznie w miejscu, gdzie znajdowała się maska zamykana (identyczne będą współrzędne x,y lewego, górnego narożnika maski);

wymiana - zostaną zamknięte wszystkie maski nie zablokowane (posiadające zezwolenie na zamknięcie), po czym otwarta będzie nowa maska;

ograniczona_wymiana - tak samo jak dla trybu "wymiana", lecz maska bieżąca nie zostanie zamknięta nawet wtedy, gdy nie jest zablokowana;

nowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą;

dialog - otwarcie nowej maski nie ma wpływu na maskę bieżącą; po otwarciu nie będzie możliwości przejścia do innej maski, aż do momentu zamknięcia maski utworzonej w wyniku tej akcji;

chwilowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą. Późniejsze przejście na inną maskę spowoduje automatyczne zamknięcie maski chwilowej.

Wartość domyślna - tryb otwarcia zgodny z trybem podanym w definicji maski.

Parametr x,y

Znaczenie - miejsce na ekranie, gdzie maska ma być otwarta określone jako współrzędne jej lewego górnego narożnika. Brak parametrów lub wartości -1 oznaczają, że maska ma zostać otwarta zgodnie z jej pierwotna definicją. Pozycja ma zastosowanie w systemach wielomonitorowych.

Typ - liczba.

Parametr monitor

Znaczenie - określenie monitora, na którym maska ma zostać otwarta (w systemie wielomonitorowym). Wartość 1 oznacza monitor podstawowy, wartość 0 oznacza, że maska ma zostać otwarta na monitorze, na którym znajduje się myszka, wartość -1 oznacza użycie monitora wynikającego z definicji maski i współrzędnych x,y. Pozycja ma zastosowanie w systemach wielomonitorowych.

Próba otwarcia maski już otwartej powoduje wybranie jej jako nowej maski bieżącej. Zasady zamykania innych masek pozostają niezmienione.

W przypadku stosowania mechanizmu zamiany zmiennych procesowych w trakcie otwierania maski, parametr nazwa_maski musi być podany w sposób zgodny z jednym z poniższych wariantów:

1. nazwa_maski#plik zamian

W pliku o rozszerzeniu VRT należy podać sposób zamiany nazw zmiennych. Format pliku przyjmuje następującą postać:
linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;
linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej

2. nazwa_maski#zmienna_źródłowej_1;zmienna_wstawiana_1[...#zmienna_źródłowej_n;zmienna_wstawiana_n]

W tym wariancie wszystkie pary zamienników są podawane wprost w treści akcji.

do góry

PANEL

PANEL - wyselekcjonowanie okna Panelu Kontrolnego. Jeżeli okno Panelu jest zminimalizowane, to zostanie automatycznie rozwinięte.

Składnia akcji definiowana ręcznie:

PANEL

gdzie:

PANEL - stały element deklaracji; można go zastąpić skrótem PAN;

Parametry x y

Znaczenie - określenie pozycji, na której okno Dialog ma być otwarte.

Jeżeli okno Panelu jest zminimalizowane, to zostanie automatycznie rozwinięte.

do góry

PASEK_WYKRESOW

PASEK_WYKRESOW - otwarcie paska narzędziowego obiektu WYKRES. Akcja zasadniczo przeznaczona jest dla systemów z ekranem dotykowym.

Składnia akcji definiowana ręcznie:

PASEK_WYKRESOW

gdzie:

PASEK_WYKRESOW - stały element deklaracji; można go zastąpić skrótem PASEK;

do góry

PAUZA

PAUZA - wstrzymuje wykonywanie akcji na podany okres czasu lub do przyciśnięcia klawisza przez operatora. Akcja przeznaczona do tworzenia prezentacji. Używana w akcjach złożonych.

Parametry akcji definiowane przy użyciu edytora akcji:

opóźnienie - czas opóźnienia w sekundach.

wartość domyślna: oczekiwanie tylko na przyciśnięcie klawisza.

Składnia akcji definiowana ręcznie:

PAUZA [opóźnienie]

gdzie:

PAUZA - stały element deklaracji; można go zastąpić skrótem PAU;

Parametry opóźnienie

Znaczenie - czas opóźnienia w sekundach.

Typ - liczba całkowita.

Wartość domyślna - oczekiwanie tylko na przyciśnięcie klawisza.

Akcja przeznaczona do tworzenia prezentacji. Używana w akcjach złożonych.

do góry

PISZ_RAPORT

PISZ_RAPORT - obliczenie wyspecyfikowanego raportu oraz wydrukowanie go na drukarce. Policzony raport zapisany zostanie na dysku lub usunięty.

Parametry akcji definiowane przy użyciu edytora akcji:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem, znajdującym się przy polu - ’Edytor momentów języka ASTEL’;

Usuń raport po wydrukowaniu - spowoduje usunięcie raportu po jego wydrukowaniu;

Nazwisko operatora - do raportu zostanie dopisane nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - do raportu zostanie dołączona treść notatki (o ile pojawia się w definicji raportu).

Składnia akcji definiowana ręcznie:

PISZ_RAPORT plik moment operacja [operator] [notatka]

gdzie:

PISZ_RAPORT - stały element deklaracji; można go zastąpić skrótem PIS;

Parametr plik

Znaczenie - nazwa pliku z definicją raportu (pełna ścieżka).

Typ - tekst.

Parametr moment

Znaczenie - moment rozpoczęcia raportu w konwencji języka ASTEL.

Typ - tekst.

Parametr operacja

Typ - symbol (KASUJ lub ZOSTAW).

Znaczenie - czy raport ma zostać lub usunięty.

Wartość domyślna - raport zostanie pozostawiony.

Parametr operator

Znaczenie - nazwisko operatora (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak nazwiska.

Parametr notatka

Znaczenie - treść notatki (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak notatki.

do góry

POKAŻ_RAPORT

POKAŻ_RAPORT - obliczenie wyspecyfikowanego raportu oraz wyświetlenie go na ekranie. Policzony raport zapisany zostanie na dysku lub usunięty.

Parametry akcji definiowane przy użyciu edytora akcji:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem, znajdującym się przy polu - ’Edytor momentów języka ASTEL’;

Usuń raport po wydrukowaniu - spowoduje usunięcie raportu po jego wyświetleniu;

Nazwisko operatora - do raportu zostanie dopisane nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - do raportu zostanie dołączona treść notatki (o ile pojawia się w definicji raportu).

Składnia akcji definiowana ręcznie:

POKAŻ_RAPORT plik moment operacja [operator] [notatka]

gdzie:

POKAŻ_RAPORT - stały element deklaracji; można go zastąpić skrótem POK;

Parametr plik

Znaczenie - nazwa pliku z definicją raportu (pełna ścieżka).

Typ - tekst.

Parametr moment

Znaczenie - moment rozpoczęcia raportu w konwencji języka ASTEL.

Typ - tekst.

Parametr operacja

Typ - symbol (KASUJ lub ZOSTAW).

Znaczenie - czy raport ma zostać lub usunięty.

Wartość domyślna - raport zostanie pozostawiony.

Parametr operator

Znaczenie - nazwisko operatora (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak nazwiska.

Parametr notatka

Znaczenie - treść notatki (o ile pojawia się w definicji raportu).

Typ - tekst.

Wartość domyślna - brak notatki.

do góry

POŁĄCZ_ALARMY

POŁĄCZ_ALARMY - akcja pozwala na przyłączenie do maski alarmów historycznych (o podanej nazwie) źródła alarmów, określonego nazwą zasobu i nazwą komputera.

Parametry akcji definiowane przy użyciu edytora akcji:

Maska - maska, do której ma nastąpić przyłączenie wskazanego źródła alarmów historycznych; jako nazwę maski można podać znak ’*’ - oznacza to operację na pierwszej znalezionej masce alarmów historycznych (operacja zawsze dotyczy tylko jednej maski);

Nazwa zasobu - nazwa zasobu do przyłączenia; jest to nazwa sieciowa zestawu alarmów zadeklarowana na stanowisku pracującym w operatorskim trybie pracy systemu alarmów;

Komputer - nazwa serwera operatorskiego, z którego alarmy mają pochodzić; jeżeli źródło alarmów nie ma znaczenia, jako nazwę komputera można podać znak ’*’ - a wówczas poszukiwanie źródła alarmów odbywa się w kolejności: bezpośrednie połączenie do stanowiska alarmowego, połączenie przez pośredniczący serwer alarmów historycznych, połączenie do istniejącego archiwum plikowego;

Rodzaj połączenia - określa sposób wykonania połączenia; może przyjmować poniższe wartości:

- nazwa serwera pośredniczącego - wykonywana jest próba połączenia wyłącznie za pośrednictwem wskazanego serwera pośredniczącego; jeżeli się to nie uda, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- brak lub * - procedura domyślna, w pierwszym kroku szukane jest bezpośrednie połączenie do serwera operatorskiego; jeżeli się to nie uda, to poszukiwane jest dojście poprzez serwer pośredniczący. Jeżeli w dalszym ciągu nie uzyskano dostępu do logu, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- BEZ_SERWERA - poszukiwane jest tylko bezpośrednie dojście do serwera operatorskiego; po niepowodzeniu, pokazywane jest stare archiwum lokalne (o ile istnieje);

- LOKALNIE - przyłączenie następuje do lokalnego archiwum, nie są wykonywane żadne próby szukania źródła alarmów w sieci.

Ilość dni - określa ilość ostatnich dni, z których należy przetransferować pliki logu alarmów. Brak parametru oznacza transfer całego logu.

Składnia akcji definiowana ręcznie:

POŁĄCZ_ALARMY nazwa_maski,nazwa_zasobu,[komputer],[rodzaj_połączenia],[ilość_dni]

gdzie:

POŁĄCZ_ALARMY - stały element deklaracji; można go zastąpić skrótem PO;

Parametr nazwa_maski

Znaczenie - maska, do której ma nastąpić przyłączenie wskazanego źródła alarmów historycznych.

Typ - tekst.

Parametrz nazwa_zasobu

Znaczenie - nazwa zasobu do przyłączenia.

Typ - tekst.

Parametr komputer

Znaczenie - nazwa serwera operatorskiego, z którego alarmy mają pochodzić; jeżeli źródło alarmów nie ma znaczenia, należy zadeklarować znak '*’.

Typ - tekst.

Parametr rodzaj_połączenia

Znaczenie - określa sposób wykonania połączenia. Może przyjmować poniższe wartości:

- brak lub * - procedura domyślna, w pierwszym kroku szukane jest bezpośrednie połączenie do serwera operatorskiego; jeżeli się to nie uda, to poszukiwane jest dojście poprzez serwer pośredniczący. Jeżeli w dalszym ciągu nie uzyskano dostępu do logu, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- nazwa serwera pośredniczącego - wykonywana jest próba połączenia wyłącznie za pośrednictwem wskazanego serwera pośredniczącego; jeżeli się to nie uda, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- BEZ_SERWERA - poszukiwane jest tylko bezpośrednie dojście do serwera operatorskiego; po niepowodzeniu, pokazywane jest stare archiwum lokalne (o ile istnieje);

- LOKALNIE - przyłączenie następuje do lokalnego archiwum, nie są wykonywane żadne próby szukania źródła alarmów w sieci.

Typ - tekst.

Parametr ilość_dni

Znaczenie - określa ilość ostatnich dni, z których należy przetransferować pliki logu alarmów. Brak parametru oznacza transfer całego logu.

Typ - tekst.

Akcja działa tylko wtedy, gdy system alarmów pracuje w trybie kontrolnym.

do góry

POTWIERDŹ_ALARMY

POTWIERDŹ_ALARMY - potwierdzenie alarmów pokazywanych na wszystkich otwartych maskach alarmów.

Parametry akcji definiowane przy użyciu edytora akcji:

Numer alarmu - wskazuje na konkretny numer alarmu, który zostanie potwierdzony (tylko alarmy aktywne);

Składnia akcji definiowana ręcznie:

POTWIERDŹ_ALARMY [numer_alarmu]

gdzie:

POTWIERDŹ_ALARMY - stały element deklaracji; można go zastąpić skrótem POT;

Parametr numer_alarmu

Znaczenie - numer alarmu, który zostanie potwierdzony.

Typ - liczba.

do góry

PRZEŁĄCZ_ZASÓB_ALARMÓW

PRZEŁĄCZ_ZASÓB_ALARMÓW - akcja umożliwia dynamiczne przełączanie zasobów alarmów.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa zasobu alarmów - nazwa zasobu alarmów (maksymalnie 8 znaków).

Składnia akcji definiowana ręcznie:

PRZEŁĄCZ_ZASÓB_ALARMÓW nazwa_zasobu_alarmów

gdzie:

PRZEŁĄCZ_ZASÓB_ALARMÓW - stały element deklaracji; można go zastąpić skrótem PRZEŁ;

Parametr nazwa_zasobu_alarmów

Znaczenie - nazwa zasobu alarmów.

Typ - tekst (maksymalnie 8 znaków).

do góry

PRZEPISZ

PRZEPISZ - wykonanie operacji transferu wartości zmiennej procesowej Asmena, do innej zmiennej. Jeżeli zmienne znajdują się w rzeczywistych kanałach transmisyjnych, to operacja jest połączona z przesyłem danych do lub ze sterownika. Akcja nie sprawdza zgodności typów zmiennych. Zakłada się, że projektant systemu jest odpowiedzialny za konstrukcję aplikacji. Jedyną weryfikowaną cecha jest zgodność rozmiarów transferowanych zmiennych.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna źródłowa - nazwa zmiennej Asmena, której wartość jest transferowana;

Zmienna docelowa - nazwa zmiennej Asmena, do której transferowana jest wartość innej zmiennej;

Wyświetl komunikat informujący o błędzie - parametr jest liczbą, która określa, czy należy wyświetlać komunikat o ewentualnym błędzie operacji. Wartość parametru równa 0 oznacza, że komunikat nie jest wyświetlany. Opcja ta może być przydatna np. w sytuacji grupy operacji PRZEPISZ wywoływanych z terminarza, gdy nie można zapewnić potwierdzenia komunikatów przez operatora - w takiej sytuacji najwygodniej jest pozostawić opcję wyłączoną (parametr będzie miał przypisaną wartość 0), dzięki czemu komunikaty o błędzie nie będą wyświetlane.

Składnia akcji definiowana ręcznie:

PRZEPISZ nazwa_danej_źródłowej nazwa_danej_docelowej flaga_komunikatu

gdzie:

PRZEPISZ - stały element deklaracji; można go zastąpić skrótem PRZ;

Parametr nazwa_danej_źródłowej

Znaczenie - nazwa zmiennej Asmena, której wartość jest transferowana.

Typ - tekst.

Parametr nazwa_danej_docelowej

Znaczenie - nazwa zmiennej Asmena, do której transferowana jest wartość innej zmiennej.

Typ - tekst.

Parametr flaga_komunikatu

Znaczenie - parametr flaga_komunikatu jest liczbą, która określa czy należy wyświetlać komunikat o ewentualnym błędzie operacji. Wartość parametru równa 0 oznacza, że komunikat nie jest wyświetlany. Opcja ta może być przydatna np. w sytuacji grupy operacji PRZEPISZ wywoływanych z terminarza, gdy nie można zapewnić potwierdzenia komunikatów przez operatora.

Typ - liczba.

Akcja nie sprawdza zgodności typów zmiennych. Zakłada się, że projektant systemu jest odpowiedzialny za konstrukcję aplikacji. Jedyną weryfikowaną cecha jest zgodność rozmiarów transferowanych zmiennych.

do góry

PYTAJ

PYTAJ - przeznaczenie - do użytku w akcjach złożonych; akcja powoduje wyświetlenie okna dialogowego z podanym tekstem i przyciskami TAK i NIE. Przyciśniecie przez operatora przycisku NIE powoduje przerwanie akcji złożonej.

Parametry akcji definiowane przy użyciu edytora akcji:

tekst - tekst wyświetlany w oknie. W przypadku długich tekstów można wprowadzić podział na linie poprzez wstawienie znaku \. Długość definicji akcji nie może przekroczyć 200 znaków.

Składnia akcji definiowana ręcznie:

PYTAJ tekst

gdzie:

PYTAJ - stały element deklaracji; można go zastąpić skrótem PYT;

Parametry tekst

Znaczenie - tekst wyświetlany w oknie. W przypadku długich tekstów można wprowadzić podział na linie poprzez wstawienie znaku \. Długość definicji akcji nie może przekroczyć 200 znaków.

Typ - tekst.

Przeznaczona do użycia w akcjach złożonych.

do góry

RAPORTUJ

RAPORTUJ - otwarcie okna systemu raportów. Akcja równoważna komendzie Narzędzia > Okno raportów w Panelu Kontrolnym.

Parametry akcji definiowane przy użyciu edytora akcji:

Położenie - określenie pozycji, w której okno ma być otwarte;

Katalog - nazwa katalogu roboczego modułu raportów. Pozwala na rozdzielenie definicji raportów na kilka katalogów, a następnie startowanie systemu z selektywnie wybranym zestawem raportów.

Wartość domyślna: katalog roboczy ustalany na podstawie pliku konfiguracyjnego aplikacji.

Składnia akcji definiowana ręcznie:

RAPORTUJ [x] [y] [katalog]

gdzie:

RAPORTUJ - stały element deklaracji; można go zastąpić skrótem RAP;

Parametry x y

Znaczenie - określenie pozycji, w której okno ma być otwarte.

Typ - liczba całkowita.

Wartość domyślna - okno otwierane w pozycji ostatnio zapamiętanej.

Parametr katalog

Znaczenie - nazwa katalogu roboczego modułu raportów. Pozwala na rozdzielenie definicji raportów na kilka katalogów, a następnie startowanie systemu z selektywnie wybranym zestawem raportów.

Wartość domyślna - katalog roboczy ustalany na podstawie pliku inicjującego.

do góry

SKRYPT

SKRYPT - zlecenie wykonania skryptu znajdującego się w pliku tekstowym.

Parametry akcji definiowane przy użyciu edytora akcji:

Skrypt - nazwa pliku zawierającego skrypt. Jeżeli ścieżka dostępu nie zostanie podana, przeszukiwane są katalogi ścieżki masek. Jeśli nie jest podane rozszerzenie pliku, to domyślnie dodawane jest vbs;

Parametry skryptu i wykonawcze - parametry przekazywane do wykonywanego skryptu: parametry skryptu oraz parametry wykonawcze, których deklarację umożliwia edytor parametrów wykonawczych skryptu, uruchamiany przyciskiem, znajdującym się przy polu.

Składnia akcji definiowana ręcznie:

SKRYPT nazwa_pliku,parametry_skryptu parametry_wykonawcze

gdzie:

SKRYPT - stały element deklaracji; można go zastąpić skrótem SKR;

Parametr nazwa_pliku:

Znaczenie - nazwa pliku zawierającego skrypt. Jeżeli ścieżka dostępu nie zostanie podana, przeszukiwane są katalogi ścieżki masek. Jeśli nie jest podane rozszerzenie pliku, to domyślnie dodawane jest vbs.

Typ - tekst.

Parametr parametry_skryptu:

Znaczenie - parametry przekazywane do wykonywanego skryptu.

Parametr parametry_ wykonawcze:

Znaczenie - parametry przekazywane do modułu skryptów (a nie do skryptu) i określające parametry wykonywania skryptu różne od domyślnych

Parametry wykonawcze podaje się w konwencji programu cscript, tj. są one poprzedzone podwójnym ukośnikiem.

Parametry wykonawcze:

//S - w danej chwili może być uruchomiony tylko jeden skrypt z parametrem //S, zawarty w podanym pliku; parametr ma znaczenie tylko w przypadku uruchamiania skryptu jako akcji operatorskiej systemu Asix; moduł skryptów odrzuci próbę ponownego uruchomienia skryptu w sytuacji, gdy poprzednie uruchomienie skryptu z parametrem //S, zawartego w tym samym pliku, jeszcze się nie zakończyło; brak tego parametru powoduje, że można równocześnie uruchamiać wiele skryptów w oparciu o program zawarty w tym samym pliku.;

//X - po uruchomieniu skryptu jest również uruchamiany debugger (zainstalowany w systemie jako domyślny); debugger zatrzymuje wykonanie skryptu na pierwszej instrukcji skryptu;

//D - wystąpienie błędu w skrypcie powoduje uruchomienie debuggera;

//IT:nnn - ograniczenie czasu wykonania części inicjalizacyjnej wyrażone w milisekundach;

//T:nnn - ograniczenie czasu wykonania części zdarzeniowej wyrażone w milisekundach;

//E:nazwa - podaje nazwę języka skryptu (np. //E:JScript);

//Watek:nazwa[,pri] - podaje nazwę wątku, w którym wykonuje się skrypt oraz określa priorytet pri wątku; nazwa wątku może być dowolna i służy grupowaniu skryptów wykonywanych w jednym wątku;

priorytety wątku skryptu:

0 IDLE – bezczynny,

1 LOWEST – najniższy,

2 BELOW_NORMAL - poniżej normalnego,

3 NORMAL - normalny (domyślny),

4 ABOVE_NORMAL - powyżej normalnego,

5 HIGHEST – najwyższy,

6 TIME_CRITICAL - krytyczny czasowo;

domyślnym priorytetem wątku jest priorytet 3 (normalny).

//U - podanie tego parametru spowoduje, że nie będą generowane zdarzenia „OnRead" oraz funkcje zdarzeń czasowych zdefiniowane metodami SetInterval i ExecuteAt, jeśli okna aplikacji Asix są ukryte (np. za pomocą akcji operatorskiej UKRYJ).

do góry

STERUJ_BITY

STERUJ_BITY - ustawienie wartości zmiennej procesowej Asmena, co powoduje jednoczesną transmisję wartości danej do sterownika (o ile zmienna procesowa znajduje się w kanale transmisyjnym). Akcja jest zorientowana na sterowania bitowe; Akcja STERUJ_BITY obsługuje zmienne 32-bitowe.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Wartość - wysyłana wartość, która może zostać jeszcze zmodyfikowana przez parametr maska; jest to liczba szesnastkowa;

Maska - maska określająca, które bity zmiennej są ustawiane (zerowane). Użycie maski powoduje, że w pierwszym kroku odczytywana jest aktualna wartość danej. Następnie modyfikowane są (zgodnie z parametrem wartość) tylko te bity, które są ustawione w masce. Na końcu tak spreparowana wartość jest odsyłana do Asmena. Wzór modyfikacji można przedstawić następująco:

nowa = (stara&(~maska))|(wartość&maska)

Mechanizm maskowania pozwala na zmianę w zmiennej tylko niektórych bitów. Pozostałe bity zachowują swą pierwotną wartość. Brak parametru oznacza, że aktualna wartość zmiennej nie jest czytana. Dana jest ustawiana bezpośrednio, zgodnie z parametrem wartość.

Składnia akcji definiowana ręcznie:

STERUJ_BITY nazwa_danej wartość [maska]

gdzie:

STERUJ_BITY - stały element deklaracji; można go zastąpić skrótem STE;

Parametr nazwa_danej

Znaczenie - nazwa zmiennej Asmena, która zostanie ustawiona.

Typ - tekst.

Parametr wartość

Znaczenie - wysyłana wartość, która może zostać jeszcze zmodyfikowana przez parametr maska.

Typ - liczba szesnastkowa.

Parametr maska

Typ - liczba szesnastkowa.

Znaczenie - maska określająca, które bity zmiennej są ustawiane (zerowane). Użycie maski powoduje, że w pierwszym kroku odczytywana jest aktualna wartość danej. Następnie modyfikowane są (zgodnie z parametrem wartość) tylko te bity, które są ustawione w masce. Na końcu tak spreparowana wartość jest odsyłana do Asmena. Wzór modyfikacji można przedstawić następująco:

nowa = (stara&(~maska))|(wartość&maska)

Mechanizm maskowania pozwala na zmianę w zmiennej tylko niektórych bitów. Pozostałe bity zachowują swą pierwotną wartość. Brak parametru oznacza, że aktualna wartość zmiennej nie jest czytana. Dana jest ustawiana bezpośrednio, zgodnie z parametrem wartość.

Akcja STERUJ_BITY obsługuje zmienne 32-bitowe.

do góry

SYGNAŁY

SYGNAŁY - akcja umożliwia sygnalizowanie dźwiękiem tylko tych alarmów, które należą do określonych grup alarmów.

Parametry akcji definiowane przy użyciu edytora akcji:

lista grup

- jeżeli parametr nie jest podany, to alarmy pochodzące ze wszystkich grup są sygnalizowane dźwiękiem (domyślny stan po starcie programu);

- jeżeli parametr jest podany, to od momentu wykonania akcji sygnalizowane są tylko alarmy należące do dowolnej z grup, których identyfikatory zostały podane.

Składnia akcji definiowana ręcznie:

SYGNAŁY[lista_identyfikatorów_grup]

gdzie:

SYGNAŁY - stały element deklaracji; można go zastąpić skrótem SYG;

l ista_identyfikatorów_grup

- jeżeli lista_identyfikatorów_grup nie jest podana, to alarmy pochodzące ze wszystkich grup są sygnalizowane dźwiękiem (domyślny stan po starcie programu);

- jeżeli lista_identyfiaktorów_grup jest podana, to od momentu wykonania akcji sygnalizowane są tylko alarmy należące do dowolnej z grup, których identyfikatory zostały podane.

do góry

SYNCHRONIZUJ_ARCHIWUM

SYNCHRONIZUJ_ARCHIWUM - akcja operatorska wymusza wykonanie przez moduł ASPAD synchronizacji archiwów typu SQL, podanych w treści akcji.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa zasobu docelowego - nazwa zasobu docelowego typu SQL;

Nazwa zasobu źródłowego - nazwa zasobu źródłowego typu SQL;

Składnia akcji definiowana ręcznie:

SYNCHRONIZUJ_ARCHIWUM zasób_źródłowy, zasób_docelowy

gdzie:

SYNCHRONIZUJ_ARCHIWUM - stały element deklaracji; można go zastąpić skrótem SYN;

zasób_źródłowy - nazwa zasobu źródłowego typu SQL;

zasób_docelowy - nazwa zasobu docelowego typu SQL;

do góry

TABELA

TABELA - otwiera okna tabeli zmiennych.

Parametry akcji definiowane przy użyciu edytora akcji:

Tabela - określenie nazwy pliku zawierającego definicję tabeli;

Atrybut - nazwa atrybutu bazy definicji zmiennych grupującego zmienne do wyświetlania;

Wartość - wartość atrybutu bazy definicji zmiennych stanowiąca filtr zmiennych. Może zawierać znaki specjalne:

* - zastępuje dowolna liczbę znaków;

# - zastępuje jedna cyfrę;

? - zastępuje jedna literę;

Tryb - oznacza rodzaj operacji jaka ma być wykonana:

otwórz - otwarcie tabeli;

wymiana - otwarcie tabeli połączone z zamknięciem wcześniej otwartych tabel na tym samym monitorze;

zamknij - zamknięcie tabeli. Jeżeli parametr nazwa jest równy *, to zamykane są wszystkie otwarte tabele;

Położenie - wskazanie położenia lewego górnego narożnika okienka tabeli. Brak parametrów lub wartości -1 oznaczają, że należy wziąć współrzędne zapisane w definicji tabeli. Pozycja ma zastosowanie w systemach wielomonitorowych;

Monitor - określa numer monitora, na którym tabela ma być wyświetlona (wartość 1 odpowiada monitorowi podstawowemu). Specjalne znaczenie ma wartość 0. Oznacza ona wyświetlenie tabeli na monitorze, na którym znajduje się aktualnie kursor myszki, pominięcie parametru lub jego wartość równa -1, oznacza użycie monitora wynikającego z definicji tabeli i parametrów x,y. Pozycja ma zastosowanie w systemach wielomonitorowych:

-1 - monitor wynikający z definicji maski,

0 - monitor, gdzie znajduje się kursor,

1 - monitor podstawowy,

2 - drugi monitor,

3 - trzeci monitor,

4 - czwarty monitor,

..

8 - ósmy monitor;

Składnia akcji definiowana ręcznie:

TABELA nazwa[#atrybut=wartość_atrybutu, tryb, x, y, monitor]

gdzie:

TABELA - stały element deklaracji; można go zastąpić skrótem TAB;

Parametr nazwa

Znaczenie - określenie nazwy pliku zawierającego definicję tabeli.

Typ - tekst.

Parametr atrybut

Znaczenie - nazwa atrybutu bazy definicji zmiennych grupującego zmienne do wyświetlania.

Typ - tekst.

Parametr wartość_atrybutu

Znaczenie - wartość atrybutu bazy definicji zmiennych stanowiąca filtr zmiennych. Może zawierać znaki specjalne:

* - zastępuje dowolna liczbę znaków;

# - zastępuje jedna cyfrę;

? - zastępuje jedna literę.

Typ - tekst.

Parametr tryb

Znaczenie - oznacza rodzaj operacji jaka ma być wykonana:

o twórz - otwarcie tabeli;

w ymiana - otwarcie tabeli połączone z zamknięciem wcześniej otwartych tabel na tym samym monitorze;

z amknij - zamknięcie tabeli. Jeżeli parametr nazwa jest równy *, to zamykane są wszystkie otwarte tabele.

Typ - tekst.

Parametry x, y

Znaczenie - wskazanie położenia lewego górnego narożnika okienka tabeli. Brak parametrów lub wartości -1 oznaczają, że należy wziąć współrzędne zapisane w definicji tabeli. Pozycja ma zastosowanie w systemach wielomonitorowych.

Typ - liczba dziesiętna.

Wartość domyślna - -1

Parametr monitor

Znaczenie - określa numer monitora, na którym tabela ma być wyświetlona (wartość 1 odpowiada monitorowi podstawowemu). Specjalne znaczenie ma wartość 0. Oznacza ona wyświetlenie tabeli na monitorze, na którym znajduje się aktualnie kursor myszki, pominięcie parametru lub jego wartość równa -1, oznacza użycie monitora wynikającego z definicji tabeli i parametrów x,y. Pozycja ma zastosowanie w systemach wielomonitorowych.

Typ - liczba dziesiętna.

Wartość domyślna - -1

do góry

UCISZ_SYGNAL

UCISZ_SYGNAL - wyłączenie sygnału dźwiękowego informującego o przyjściu alarmu. W przypadku stanowisk sieciowych wyciszenie sygnału jest wykonywane na wszystkich połączonych stanowiskach.

Składnia akcji definiowana ręcznie:

UCISZ_SYGNAL

gdzie:

UCISZ_SYGNAL - stały element deklaracji; można go zastąpić skrótem UCI;

do góry

UKRYJ_WSZYSTKO

UKRYJ_WSZYSTKO - zwinięcie wszystkich otwartych okien aplikacji do ikony na pasku zadań w prawej jego części. W wyniku tego następuje automatyczna redukcja obciążenia procesora. Przywrócenie aplikacji do poprzedniego stanu wykonuje się przez dwukrotne kliknięcie na ikonie Asixa na pasku zadań. Funkcja ukrycia wszystkich okien działa także w systemach bez paska zadań. W tym przypadku ukrywane są wszystkie okna z wyjątkiem okna panelu lub okna konstruktora, które jest tylko minimalizowane.

Składnia akcji definiowana ręcznie:

UKRYJ_WSZYSTKO

gdzie:

UKRYJ_WSZYSTKO - stały element deklaracji; można go zastąpić skrótem UKR;

do góry

URUCHOM

URUCHOM - wykonanie dowolnego programu.

Parametry akcji definiowane przy użyciu edytora akcji:

Komenda - nazwa programu wraz z parametrami, który ma zostać uruchomiony.

Składnia akcji definiowana ręcznie:

URUCHOM komenda

gdzie:

URUCHOM - stały element deklaracji; można go zastąpić skrótem URU;

Parametry komenda

Znaczenie - nazwa programu wraz z parametrami, który ma zostać uruchomiony.

Typ - tekst.

do góry

USTAW_WARTOŚĆ

USTAW_WARTOŚĆ - ustawienie wartości zmiennej procesowej Asmena, co powoduje jednoczesną transmisję wartości danej do sterownika (o ile zmienna procesowa znajduje się w kanale transmisyjnym). Akcja jest zorientowana na sterowanie wartością analogową.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Wartość - wysyłana wartość.

Składnia akcji definiowana ręcznie:

USTAW_WARTOŚĆ nazwa_danej wartość

gdzie:

USTAW_WARTOŚĆ - stały element deklaracji; można go zastąpić skrótem UST;

Parametr nazwa_danej

Znaczenie - nazwa zmiennej Asmena, która zostanie ustawiona.

Typ - tekst.

Parametr wartość

Znaczenie - wysyłana wartość

Typ - liczba całkowita lub zmiennoprzecinkowa.

do góry

USTAW_WYKRES

USTAW_WYKRES - ustawienie czasu obiektu Wykres; skutkiem akcji jest zsynchronizowanie wszystkich wykresów na bieżącej masce z czasem przekazanym w zmiennej procesowej.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna - nazwa zmiennej przekazującej czas; zmienna musi być typu 32-bitowego i musi się w niej znajdować czas w formie zgodnej z formatem D obiektu liczba (liczba sekund od 1.1.1970). Jest to forma kompatybilna ze sposobem przekazywania pól typu Data przez AsBase’a. Akcja przeznaczona jest głównie do sterowania obiektami WYKRES, generowanymi na podstawie danych zebranych w bazie AsBase’a.

Składnia akcji definiowana ręcznie:

USTAW_WYKRES nazwa_zmiennej

gdzie:

USTAW_WYKRES - stały element deklaracji; można go zastąpić skrótem USTAW_WY;

Parametr nazwa_zmiennej

Znaczenie - nazwa zmiennej przekazującej czas; zmienna musi być typu 32-bitowego i musi się w niej znajdować czas w formie zgodnej z formatem D obiektu liczba (liczba sekund od 1.1.1970). Jest to forma kompatybilna ze sposobem przekazywania pól typu Data przez AsBase’a. Akcja przeznaczona jest głównie do sterowania obiektami WYKRES, generowanymi na podstawie danych zebranych w bazie AsBase’a

Typ - tekst.

do góry

WYDRUK_EKRANU

WYDRUK_EKRANU - akcja powoduje wydruk całego ekranu lub aktywnego okna. Jest ona równorzędna wydrukowi wykonywanemu poprzez zastosowanie klawiszy Alt+F5.

Parametry akcji definiowane przy użyciu edytora akcji:

Zawartość wydruku:

- Aktywne okno,

- Cały ekran;

Drukarka:

- Drukuj na drukarce domyślnej,

- Drukuj na wybranej drukarce - możliwość wskazania wymaganej drukarki, zainstalowanej w systemie operacyjnym komputera;

Składnia akcji definiowana ręcznie:

WYDRUK_EKRANU tryb[,nazwa_drukarki]

gdzie:

WYDRUK_EKRANU - stały element deklaracji; można go zastąpić skrótem WYD;

Parametr tryb

Znaczenie - parametr określa przedmiot wydruku.

Typ - symbol:

Okno - akcja operatorska spowoduje wydrukowanie aktywnego okna;

Ekran - akcja operatorska spowoduje wydrukowanie całego ekranu.

Parametr nawa_drukarki

Znaczenie - w przypadku podania parametru, nazwa drukarki musi być zgodna z nazwami drukarek wyświetlanymi przez program As (np. w oknie parametrów wydruku ekranu). Pominięcie nazwy drukarki oznacza wydruk na systemowej drukarce domyślnej.

do góry

WYKLUCZENIE

WYKLUCZENIE - akcja pozwala na zmianę stanu wykluczenia alarmu o podanym numerze.

Parametry akcji definiowane przy użyciu edytora akcji:

Operacja:

- Dodaj,

- Usuń;

Alarm - może być numerem pojedynczego alarmu lub nazwą pliku zestawu alarmów; należy podawać nazwę pliku bez rozszerzenia i ścieżki dostępu - automatycznie dodawane jest rozszerzenie EXL, a pliki są poszukiwane w katalogu roboczym systemu alarmów:

Numer alarmu,

Plik z zestawem alarmów.

Składnia akcji definiowana ręcznie:

WYKLUCZENIE rodzaj_operacji specyfikacja_alarmu

gdzie:

WYKLUCZENIE - stały element deklaracji; można go zastąpić skrótem WYK;

Parametr rodzaj_operacji - może przyjmować dwie wartości:

dodaj - włączenie wykluczenia alarmu;

usuń - usunięcie wykluczenia.

Parametr specyfikacja_alarmu

Znaczenie - może być numerem pojedynczego alarmu lub nazwą pliku zestawu alarmów. Należy podawać nazwę pliku bez rozszerzenia i ścieżki dostępu - automatycznie dodawane jest rozszerzenie EXL, a pliki są poszukiwane w katalogu roboczym systemu alarmów.

Akcja ”WYKLUCZENIE dodaj nazwa_pliku" jest równoważna operacji Dodaj z pliku wykonanej w oknie obsługi wykluczeń.

Akcja ”WYKLUCZENIE usuń nazwa_pliku" jest równoważna operacji Usuń z pliku.

do góry

WYLOGUJ

WYLOGUJ - akcja pozwala na natychmiastowe (bez żadnych pytań) wylogowanie aktywnego użytkownika i przejście do anonimowego trybu pracy, lub przełączenie na użytkownika domyślnego (jeżeli taki został zdefiniowany).

Składnia akcji definiowana ręcznie:

WYLOGUJ

gdzie:

WYLOGUJ - stały element deklaracji; można go zastąpić skrótem WYL;

do góry

WYŚLIJ_STEROWANIA

WYŚLIJ_STEROWANIA - wysłanie sygnału wykonania operacji sterującej. Akcja używana przy współpracy z obiektami wizualizacyjnymi. W normalnym trybie pracy, obiekty po wyborze wartości sterującej nie wykonują natychmiastowego jej wysłania. Oczekują na sygnał, który wykonywany jest akcją WYŚLIJ_STEROWANIA.

Parametry akcji definiowane przy użyciu edytora akcji:

Zakres operacji - określenie, czy operacja dotyczy maski bieżącej, czy wszystkich otwartych masek:

Maska bieżąca - sygnał do obiektów na masce bieżącej,

Wszystkie maski - sygnał do obiektów na wszystkich otwartych maskach.

Składnia akcji definiowana ręcznie:

WYŚLIJ_STEROWANIA [zakres_operacji]

gdzie:

WYŚLIJ_STEROWANIA - stały element deklaracji; można go zastąpić skrótem WY;

Parametr zakres_operacji

Znaczenie - określenie czy operacja dotyczy maski bieżącej, czy wszystkich otwartych masek.

Typ - symbol:

bieżące - sygnał do obiektów na masce bieżącej;

wszystkie - sygnał do obiektów na wszystkich otwartych maskach.

Wartość domyślna - sygnał wysyłany tylko do obiektów na masce bieżącej.

do góry

ZAMKNIJ_MASKĘ

ZAMKNIJ_MASKĘ- zamknięcie maski bieżącej lub zadeklarowanej. Jeśli nie została podana jawnie nazwa maski, to nie zostaną zamknięte maski z ustawioną opcją Bez zamykania. Jeśli parametrem jest jawnie podana nazwa maski, to zamknie się ona nawet, gdy opcja Bez zamykania została ustawiona w jej parametrach.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa maski - określenie nazwy masek (maski), które mają zostać zamknięte; można używać znaków * i ? do deklaracji jednoczesnego zamknięcia całych grup masek;

Monitor - określa numer monitora, którego akcja dotyczy.

Składnia akcji definiowana ręcznie:

ZAMKNIJ_MASKĘ [nazwa_maski][nr_monitora]

gdzie:

ZAMKNIJ_MASKĘ - stały element deklaracji; można go zastąpić skrótem ZAM;

Parametr nazwa_maski

Znaczenie - określenie nazwy masek (maski), które mają zostać zamknięte. Można używać znaków * i ? do deklaracji jednoczesnego zamknięcia całych grup masek.

Typ - tekst.

Wartość domyślna- zamknięcie tylko maski bieżącej.

Parametr nr_monitora

Znaczenie - określa numer monitora, którego akcja dotyczy.

Jeśli nie została podana jawnie nazwa maski, to nie zostaną zamknięte maski z ustawioną opcją Bez zamykania. Jeśli parametrem jest jawnie podana nazwa maski, to zamknie się ona nawet, gdy opcja Bez zamykania została ustawiona w jej parametrach.

do góry

ZMIANA_CZASU

ZMIANA_CZASU - otwarcie okna dialogowego pozwalającego na zmianę czasu systemowego. Akcja równoznaczna z komendą Opcje > Zmiana czasu w Panelu Kontrolnym i Oknie Konstruktora.

Składnia akcji definiowana ręcznie:

ZMIANA_CZASU

gdzie:

ZMIANA_CZASU - stały element deklaracji; można go zastąpić skrótem ZMIA;

do góry

ZMIEN_BITY

ZMIEN_BITY - zmiana wartości wybranych bitów zmiennej procesowej Asmena. Procedura wykonania akcji polega na odczycie bieżącej wartości zmiennej ze sterownika, zmianie stanu wskazanych bitów na przeciwny i odesłaniu tak przygotowanej wartości do sterownika. Akcja ZMIEN_BITY obsługuje zmienne 32-bitowe.

Parametry akcji definiowane przy użyciu edytora akcji:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Maska - maska określająca, które bity zmiennej są zmieniane (negowane). Wzór modyfikacji można przedstawić następująco:

nowa = (stara^maska)

Składnia akcji definiowana ręcznie:

ZMIEN_BITY nazwa_danej maska

gdzie:

ZMIEN_BITY - stały element deklaracji; można go zastąpić skrótem ZMIE;

Parametr nazwa_danej

Znaczenie - nazwa zmiennej Asmena, która zostanie ustawiona.

Typ - tekst.

Parametr maska

Typ - liczba szesnastkowa.

Znaczenie - maska określająca, które bity zmiennej są zmieniane (negowane). Wzór modyfikacji można przedstawić następująco:

nowa = (stara^maska)

Akcja ZMIEN_BITY obsługuje zmienne 32-bitowe.

do góry

ZOBACZ

ZOBACZ - zlecenie wyświetlenia pliku.

Parametry akcji definiowane przy użyciu edytora akcji:

nazwa_pliku - nazwa pliku, który ma zostać wyświetlony.

Składnia akcji definiowana ręcznie:

ZOBACZ nazwa_pliku

gdzie:

ZOBACZ - stały element deklaracji; można go zastąpić skrótem ZOB;

Parametr nazwa_pliku

Znaczenie - nazwa pliku, który ma zostać wyświetlony.

Typ - tekst.

do góry


17. Terminarz akcji

Terminarz akcji jest modułem programu AS, który pozwala na automatyczne wykonywanie wybranych akcji. Moment wykonania akcji może być określany według dwóch kryteriów:

czasu systemowego - akcje wykonywane o konkretnej godzinie; można ograniczyć wykonanie akcji do wybranego dnia miesiąca; czas uruchomienia akcji podawany jest z dokładnością do jednej minuty;

zmian wartości zmiennych - akcje wykonywane w momencie zajścia podanej relacji dla wartości wybranej zmiennej procesowej.

Typowym zastosowaniem terminarza jest automatyczne okresowe obliczanie raportów lub wykonywanie akcji związanych z obsługą bazy danych po otrzymaniu sygnału ze sterownika.

Nie ma żadnych ograniczeń dotyczących zestawu akcji, które mogą być wykonywane przez moduł terminarza akcji. Należy pamiętać jednak o tym, że w momencie stwierdzenia konieczności wykonania akcji, nie są znane czynności, które aktualnie wykonuje operator systemu. Z tego względu, użycie akcji, które powodują zmianę aktualnego okna (np. OTWÓRZ_MASKĘ) może stanowić pewne zaskoczenie dla operatora.

Niezależnie od wybranej metody aktywizacji akcji możliwe jest zadeklarowanie konieczności użycia mechanizmu okna zezwalającego. Powoduje on, że przed wykonaniem akcji na ekranie pojawia się okno dialogowe opisujące wykonywaną akcję. Operator ma wtedy możliwość zablokowania wykonania akcji.


17.1. Definiowanie terminów akcji

Deklaracja akcji wykonywanych przez Terminarz osługiwana jest przez program Architekt:

Architekt > Obszary i komputery > moduł Akcje i terminarze > zakładka Terminarz czasowy/zdarzeniowy

Istnieją dwa warianty, służące do deklaracji zdarzeń według dwóch dostępnych kryteriów. Wszystkie deklaracje wprowadzone przez twórcę aplikacji są zapamiętywane w pliku konfiguracyjnym aplikacji.

Akcje uzależnione czasowo zapisywane są w kolejnych wierszach pola Termin (zakładka Terminarz czasowy), natomiast akcje uzależnione od wartości zmiennych w wierszach pola Zdarzenie (zakładka Terminarz zdarzeniowy).

Okres próbkowania wartości zmiennych zapamiętany jest w parametrze Okres sprawdzania wartości monitorowanych zmiennych (zakładka Terminarz zdarzeniowy).


17.1.1. Definiowanie akcji czasowych

Komenda NARZĘDZIA.TERMINARZ_AKCJI.CZASOWY powoduje otwarcie poniższego okna dialogowego, które pozwala na zdefiniowanie akcji terminarza uruchamianych na podstawie warunków czasowych.

Rysunek: Okno 'Terminarz Akcji'.

Okno definicji terminów czasowych złożone jest z 3 części. W górnej części okna znajduje się lista pokazująca wszystkie aktualnie zdefiniowane terminy. W środkowej części okna znajdują się pola służące do zdefiniowania nowej lub zmiany istniejącej akcji terminowej.

Znaczenie poszczególnych pól jest następujące:

pole edycyjne Akcja - treść akcji, która ma zostać wykonana; w przypadku wprowadzenia poprawnej treści akcji, pole to automatycznie formatuje podany tekst;

pole edycyjne Czas - pole służące do podania czasu (z dokładnością do minuty), w którym akcja ma zostać wykonana;

pole wyboru Potwierdzenie - wybranie tego pola powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania,

pole wyboru Codziennie - wybranie tego pola powoduje, że akcja będzie wykonywana codziennie,

pole edycyjne Dzień - pole służące do podania numeru dnia w miesiącu, w którym akcja ma zostać wykonana; zawartość pola ma znaczenie tylko wtedy, gdy pole Codziennie nie jest zaznaczone.

W dolnej części okna znajduje się zestaw klawiszy, których przyciśnięcie powoduje wykonanie poniższych operacji:

klawisz Anuluj - zamknięcie okna ze zignorowaniem wszystkich wprowadzonych zmian,

klawisz Zmień - zmiana definicji wyselekcjonowanej pozycji na liście terminów na podstawie aktualnej zawartości pól edycyjnych,

klawisz Dodaj - dodanie nowej pozycji na liście terminów na podstawie aktualnej zawartości pól edycyjnych,

klawisz Usuń - usunięcie wyselekcjonowanej pozycji z listy terminów,

klawisz Koniec - zamknięcie okna z zapamiętaniem definicji wszystkich aktualnie zdefiniowanych terminów w pliku konfiguracyjnym aplikacji.

Alternatywnym sposobem definiowania akcji czasowych jest wykorzystanie do tego celu programu Architekt:

Architekt > Obszary i komputery > moduł Skrypty i akcje > zakładka Terminarz czasowy

Rysunek: Architekt - zakładka 'Terminarz czasowy'.

Znaczenie poszczególnych pól definiujących akcje terminowe jest analogiczne do pól w oknie ’Terminarz Akcji’ Konstruktora.


17.1.2. Definiowanie akcji zdarzeniowych

Komenda NARZĘDZIA.TERMINARZ_AKCJI.ZDARZENIOWY powoduje otwarcie poniższego okna dialogowego, które pozwala na zdefiniowanie akcji terminarza uruchamianych na podstawie monitorowania wartości zmiennych procesowych.

Rysunek: Okno definicji terminów zdarzeniowych.

Okno definicji terminów zdarzeniowych złożone jest z 3 części. W górnej części okna znajduje się lista pokazująca wszystkie aktualnie zdefiniowane terminy. W środkowej części okna znajdują się pola służące do zdefiniowania nowej lub zmiany istniejącej akcji zdarzeniowej.

Znaczenie poszczególnych pól jest następujące:

pole edycyjne Akcja - treść akcji, która ma zostać wykonana; w przypadku wprowadzenia poprawnej treści akcji, pole to automatycznie formatuje podany tekst;

pole edycyjne Zmienna - nazwa zmiennej procesowej, od której wartości jest uzależnione wykonanie akcji;

pole warunku - rozwijana lista służąca do określenia rodzaju sprawdzanego warunku; dostępne są 4 typy warunków:

= - zmienna równa podanej wartości,

> - zmienna większa od ograniczenia,

< - zmienna mniejsza od ograniczenia,

& - iloczyn logiczny zmiennej i podanej wartości;

pole edycyjne Wartość - liczba względem której porównywana jest wartość monitorowanej zmiennej procesowej; jest to dziesiętna liczba całkowita lub liczba zmiennoprzecinkowa; program automatycznie uzgadnia typy danych zmiennej i wartości; nie można stosować warunku typu "&" dla danych zmiennoprzecinkowych;

pole wyboru Potwierdzenie - wybranie tego pola powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania;

pole edycyjne Wspólny okres odświeżania

- pole dotyczące wszystkich pozycji jednocześnie; określa ono okres czasu pomiędzy kolejnymi sprawdzaniami wartości monitorowanych zmiennych.

W dolnej części okna znajduje się zestaw klawiszy. Ich znaczenie jest takie samo jak w oknie definicji terminów czasowych.

Istotne znaczenie ma dobranie odpowiedniego okresu odświeżania. Po spełnieniu warunku wykonania akcji, kolejne wykonanie akcji będzie możliwe dopiero po tym jak zostanie wykryty stan niespełnienia warunku (najszybciej w następnym cyklu sprawdzeń). W efekcie najszybszy czas powtórzenia akcji jest dwukrotnie dłuższy niż okres sprawdzania warunków.

Okres odświeżania nie powinien być również dłuższy od okresów odświeżania zmiennych zdefiniowanych w menedżerze Asmen (brak odpowiednio częstego odczytu może wstrzymać pobieranie zmiennych).

Alternatywnym sposobem definiowania akcji zdarzeniowych jest wykorzystanie do tego celu programu Architekt:

Architekt > Obszary i kompunetry > moduł Skrypty i akcje > zakładka Terminarz zdarzeniowy

Rysunek: Architekt - zakładka 'Terminarz zdarzeniowy'.

Znaczenie poszczególnych pól definiujących akcje zdarzeniowe jest analogiczne do pól w oknie ’Terminarz Akcji’ Konstruktora.


17.1.3. Zapamiętanie parametryzacji

W momencie użycia przycisku KONIEC w oknie definiującym wszystkie aktualnie zdefiniowane akcje są zapisywane w pliku konfiguracyjnym aplikacji. Nie jest to jeszcze równoważne z definitywnym zapamiętaniem nowych terminów. Program AS będzie używał nowych terminów, lecz w celu ich zapamiętania na dysku konieczne jest jeszcze wykonanie operacji zapisania pliku konfiguracyjnego aplikacji (komenda PLIKI.ZACHOWAJ w Konstruktorze lub wyjście z programu AS z zachowaniem pliku konfiguracyjnego). W przypadku definiowania akcji terminowych i zdarzeniownych przy użyciu Architekta - deklaracje zapamiętywanę są w pliku XML za pomocą komendy Zapisz [image] .


17.1.4. Wykonanie akcji terminowych

W momencie uruchomienia programu AS w trybie wykonania aplikacji następuje rozpoczęcie monitorowania czasu i wartości zmiennych w celu wykrycia momentów uruchomienia akcji terminowych. Jeżeli zostaną stwierdzone warunki, które wymuszają wykonanie akcji, to sprawdzany jest atrybut potwierdzenia akcji. Jeżeli akcja została zdefiniowana bez ustawienia tego atrybutu, to akcja jest natychmiast wykonywana. Jeżeli potwierdzenie jest wymagane, to wyświetlane jest okno zapytania o prawo wykonania akcji.

Rysunek: Okno 'Terminowe Wykonanie Akcji'.

Operator może zezwolić lub nie na wykonanie akcji. Brak reakcji operatora powoduje zamkniecie okna po około 5 sekundach i wykonanie akcji.

Zablokowanie wykonania akcji przez operatora nie powoduje prób późniejszego ponownego jej wykonania.


18. Opcje definiowane w pliku asix.ini

Poniżej opisane opcje definiowane są tylko w pliku asix.ini w sekcji o nazwie [STAN]. Opcje te dotyczą sposobu pracy programu AS. Służą również do zapamiętania ostatnich ustawień programu, co poprawia wygodę projektowania aplikacji.

Plik asix.ini mieści się w katalogu głównym zainstalowanego pakietu (domyślnie C:\Asix\).

Rysunek: Przykładowa deklaracja opcji w pliku asix.ini.

  • CZCIONKI_PRZYKLAD = tekst

Znaczenie - definicja tekstu stosowanego w oknie selekcji czcionek do wyświetlenia przykładu użycia wybranej czcionki.

Zdefiniowanie - poprzez okno selekcji czcionek.

  • LICZBA_KOPII = ilość_kopii_zapasowych

Znaczenia - pozycja określająca liczbę tworzonych kopii zapasowych. Dotyczy ona plików inicjujących aplikacji i plików opisujących maski.

Wartość domyślna - tworzona jest jedna kopia zapasowa.

Zdefiniowanie - ręczne.

  • OKNO_EDYTORA = lewy,prawy,góra,dół

Znaczenie - pozycja zapamiętująca ostatnie położenia okna Edytora. Koordynaty wyrażone w pikselach, punkt 0,0 leży w lewym górnym narożniku ekranu.

Wartość domyślna - pozycja standardowa.

Zdefiniowanie - automatyczne.

  • OKNO_KONSTRUKTORA = lewy,prawy,góra,dół

Znaczenie - pozycja zapamiętująca ostatnie położenia okna Konstruktora. Koordynaty wyrażone w pikselach, punkt 0,0 leży w lewym górnym narożniku ekranu.

Wartość domyślna - pozycja standardowa.

Zdefiniowanie - automatyczne.

  • OKNO_PODGLADU = lewy,prawy,góra,dół

Znaczenie - pozycja zapamiętująca ostatnie położenia okna, w którym wyświetlane są raporty. Koordynaty wyrażone w pikselach, punkt 0,0 leży w lewym górnym narożniku ekranu.

Wartość domyślna - pozycja standardowa.

Zdefiniowanie - automatyczne.

  • OKNO_RAPORTOWE = lewy,prawy,góra,dół

Znaczenie - pozycja zapamiętująca ostatnie położenia okna systemu raportów. Koordynaty wyrażone w pikselach, punkt 0,0 leży w lewym górnym narożniku ekranu.

Wartość domyślna - pozycja standardowa.

Zdefiniowanie - automatyczne.

  • OSTATNI_PLIK = nazwa_pliku

Znaczenie - pozycja służąca zapamiętaniu ostatnio używanego pliki inicjującego aplikacji. W momencie startu programu AS w trybie konstruktora, nastąpi automatyczne załadowanie pliku inicjującego o podanej nazwie.

Wartość domyślna - ładowany plik beznazwy.ini.

Zdefiniowanie - automatyczne przez program AS.

  • PODGLAD_POZYCJI = lewy,góra,prawy,dół

Znaczenie - pozycja służąca do zapamiętania ostatniego położenia okna podglądu pozycji myszki. Koordynaty wyrażone są w pikselach, punkt 0,0 leży w lewym górnym narożniku ekranu.

Wartość domyślna - okno podglądu nie jest używane.

Zdefiniowanie - automatyczne, w momencie otwarcia okna podglądu lub zmiany jego pozycji.

  • SEKWENCJA_DEMO = [TAK|NIE|AUTO]

Znaczenie - pozycja pozwala na odblokowanie mechanizmu sekwencji demonstracyjnych. Użycie symbolu AUTO powoduje, że dodatkowo następuje automatyczne rozpoczęcie odtwarzania sekwencji w momencie startu aplikacji.

Wartość domyślna - sekwencje demonstracyjne nie są używane.

Zdefiniowanie - ręczne.

  • SKOK_KURSORA = skokX,skokY,punktX,punktY

Znaczenie - pozycja służąca do zapamiętania ostatnich używanych parametrów skoku kursora.

Wartość domyślna - skok równy 1 w obu kierunkach.

Zdefiniowanie - automatyczne, w momencie zmiany skoku.


19. Obiekty

System Asix wyposażony jest w zbiór obiektów umożliwiających projektowanie masek do wizualizacji procesów technologicznych. Tworzenie masek odbywa się podczas pracy programu AS w trybie konstrukcyjnym. Umożliwia on wstawianie, definiowanie oraz modyfikację obiektów na maskach.

Obiekt stanowi pewną strukturę, której przypisać można zestaw parametrów określających jego atrybuty (wymiary, kolory, czcionki), powiązania ze zmiennymi systemu Asix, sposób reakcji na zmiany zmiennych systemowych, akcje wykonywane przez operatora, itp. Parametry obiektu wprowadza się przy pomocy okna definiującego obiektu. Obiekt potrafi się zaprezentować, czyli wyświetlić na masce. Wyświetlony obraz obiektu uzależniony jest od jego stanu. Obiekty pobudzane są do wyświetlenia wewnętrznym sygnałem odświeżania. Zmianę stanu obiektu spowodować mogą również działania operatora.


19.1. Zestaw obiektów systemu Asix

Standardowy zestaw obiektów systemu Asix obejmuje:

  • ASBASE

zapewnia łączność z bazą danych modułu AsBase

  • DATA + CZAS

wyświetla datę lub/i czas

  • ELIPSA

rysuje elipsę - obiekt statyczny

  • ELIPSY

elipsa reagująca na stan zmiennej

  • KOMUNIKATY

wyświetla jeden z wielu wyspecyfikowanych tekstów

  • KONTROLER OBIEKTÓW

obiekt ten pozwala kontrolować widzialność innych obiektów

  • KONTROLER RUCHU

obiekt ten pozwala na animację ruchu obiektów masek technologicznych

  • LICZBA

wyświetla liczbę odpowiadającą wartości zmiennej

  • LINIA

rysuje dowolną linię - obiekt statyczny

  • LINIA PP

linia prostopadła do krawędzi maski - obiekt statyczny

  • LINIE

wyświetla linie zależne od stanu zmiennej monitorowanej

  • LINIE PP

wyświetla linie prostopadłe zależne od stanu zmiennej

  • NAPĘD

wyświetla tabelarycznie stan napędu z możliwością sterowania

  • NAPIS

wyświetla ciąg znaków ze zmiennej jako tekst

  • OBRAZEK

wyświetla bitmapę - obiekt statyczny

  • OBRAZKI

wyświetla bitmapy zależnie od stanu zmiennej

  • PREZENTER

sygnalizuje otwarcie wybranej maski

  • PROSTOKĄT

rysuje prostokąt - obiekt statyczny

  • PROSTOKĄTY

wyświetla prostokąty zależnie od stanu zmiennej

  • PRZELICZNIK

wykonuje przeliczenia między zmiennymi

  • PRZEŁĄCZNIK

zestaw przycisków sterujących

  • PRZYCISK

klawisz z możliwością wykonania akcji lub sterowania

  • PUNKT PRACY

wyświetla kursor w zależności od stanu zmiennych X i Y

  • RAPORT

oblicza i wyświetla uprzednie zdefiniowany raport

  • RUROCIĄG

rysuje fragmenty rurociągów - obiekt statyczny

  • SELEKTOR

pozwala sterować zmienną operując objaśniającymi tekstami

  • SŁUPEK

wyświetla wartość analogową w postaci słupka

  • SUWAK

wskaźnik słupkowy z zadawaniem wartości

  • SYNCHRONIZATOR

sygnalizuje wykonanie akcji "wyślij sterowania"

  • TEKST

pisze tekst dowolną czcionką - obiekt statyczny

  • TEKSTY

wyświetla jeden z wielu tekstów w zależności od stanu zmiennej

  • TEST ODŚWIEŻANIA

testuje szybkość odświeżania masek

  • WIELOKĄT

rysuje dowolny wielokąt - obiekt statyczny

  • WIELOKĄT PP

rysuje wielokąt o bokach prostopadłych - obiekt statyczny

  • WIELOKĄTY

wyświetla wielokąt jeden z, zależnie od stanu zmiennej

  • WIELOKĄTY PP

wyświetla wielokąt prostokątny jeden z, zależnie od zmiennej

  • WIELOLINIA

rysuje linę łamaną - obiekt statyczny

  • WIELOLINIA PP

rysuje linę łamaną prostokątną - obiekt statyczny

  • WIELOLINIE

wyświetla linę łamaną w zależności od stanu zmiennej

  • WIELOLINIE PP

wyświetla linę łamaną prostokątną w zal. od stanu zmiennej

  • WSKAŹNIK

wyświetla wartość analogową jako wskaźnik kołowy

  • WYKRES

wyświetla dane archiwalne w formie wykresu

  • WYRAŻENIE

wyświetla wynik obliczeń dokonanych na zmiennych

  • WYŁĄCZNIK

wysyła dwa różne sterowania w zależności od stanu zmiennej

Zostaną one opisane w dalszej części rozdziału. Opis obiektów w każdym przypadku zawierać będzie przykładowe okno definiujące dany obiekt oraz wykaz parametrów obiektu. Dodatkowo, w większości przypadków opis będzie zawierał okno z przykładowym obiektem lub zestawem obiektów danej klasy.

W przypadku większości obiektów ich wymiary można określić dowolnie przy pomocy myszy (w sposób analogiczny do skalowania okien - "ciągnąć" kursorem myszy róg obiektu). Wymiary niektórych obiektów (wszystkie mapy bitowe) określone są na sztywno i nie mogą być zmienione. Czasami obiekt może nie dopuszczać do skalowania powodującego utratę zawartych w nim informacji lub też przyjmować wymiary uzależnione od sposobu parametryzacji. Dokładniejsze informacje na ten temat zapisane zostały w opisie obiektów.

Definicje obiektów tworzących maski schematowe zapisywane są na dysku w postaci binarnej (pliki *.msk). Obiekty nowszych wersji automatycznie dokonują konwersji czytanych z dysku definicji obiektów starszych wersji. Każdorazowy zapis definicji maski na dysku powoduje zapisanie przekonwertowanych definicji.


19.2. Słowniczek pojęć

Błąd komunikacyjny

Błąd komunikacyjny może wystąpić w czasie przesyłania danych pomiędzy sterownikiem a komputerem, na którym zainstalowany został system Asix. Każdy obiekt dynamiczny może reagować na błąd komunikacyjny zmianą swojego obrazu.

Błąd pomiarowy

Błąd pomiarowy może wystąpić między przetwornikiem pomiarowym i obiektem, ewentualnie w samym przetworniku. W pewnych przypadkach sterownik może wykryć błąd pomiarowy (wymaga to odpowiedniego oprogramowania w sterowniku) i przekazać informację o tym do obiektu za pomocą danej kontrolnej. Niektóre obiekty dynamiczne mogą reagować na błąd pomiarowy zmianą swojego obrazu.

Dana kontrolna

Dana kontrolna jest odmianą danej monitorowanej. Pełni ona pomocniczą rolę w każdym obiekcie wykorzystującym dane pomiarowe. Przyjęta została konwencja, że jeśli iloczyn logiczny danej kontrolnej oraz stowarzyszonego z nią statusu jest różny od zera, wówczas obiekt sygnalizuje błąd pomiarowy. Do wypracowania danej kontrolnej niezbędne jest odpowiednie oprogramowanie w sterowniku.

Dana monitorowana

Dana monitorowana to zmienna systemowa, która jest czytana przez obiekt dynamiczny w trakcie odświeżania. Dane monitorowane przesyłane są ze sterownika. Zmiana wartości danej monitorowanej może wywołać zmianę obrazu obiektu.

Dana pomiarowa

Dana pomiarowa to zmienna systemowa, która odpowiada analogowej wielkości pomiarowej. Dana ta przesyłana jest ze sterownika i czytana przez obiekt dynamiczny w trakcie odświeżania. Dana pomiarowa to podklasa danej monitorowanej.

Dana sterowana

Dana sterowana to zmienna systemowa, której wartość może zostać ustawiona przez operatora i wysłana do sterownika. Dana ta jest zapisywana przez obiekt. W niektórych przypadkach zmienna taka może być przed zapisem odczytana ze sterownika po to, żeby zapisać do sterownika sumę logiczną wielkości odczytanej z wyzerowanym polem zapisu i wielkości zapisywanej. Ten typ zapisu można wykonać ustawiając dla danej sterowanej parametr najpierw czytaj. Dana monitorowana może być jednocześnie daną sterowaną.

Obiekt dynamiczny

Obiektem dynamicznym nazywany będzie obiekt, który zmienia swój stan (i obraz) podczas odświeżania maski. Zmiana stanu może nastąpić pod wpływem zmiany wartości zmiennych systemowych, upływu czasu lub akcji operatora. Parametry obiektów dynamicznych zwykle zawierają zmienne systemowe.

Obiekt statyczny

Obiektem statycznym nazywany będzie obiekt, który nie zmienia swojego stanu podczas odświeżania maski. Obiekty statyczne nie są powiązane ze zmiennymi systemowymi. Zestaw parametrów takiego obiektu ogranicza się do atrybutów obrazu obiektu.

Obiekt wybieralny

Obiektem wybieralnym nazywany będzie obiekt, który zmienia swój stan (i obraz) podczas odświeżania maski. Zmiana stanu następuje pod wpływem akcji wykonanej przez operatora. Obiekty te służą zazwyczaj do wysyłania sterowań (zapisują one wartości do zmiennych systemowych). Obiekt taki powinien reagować na selekcję (wybór) dokonany przez operatora. W odpowiedzi na selekcję obiekt powinien:

  • zmienić swój stan odrysowując się lub

  • umożliwić operatorowi wprowadzenie wartości (lub przejrzenie możliwych stanów obiektu, którym wcześniej przypisane zostały jakieś wartości) oraz

  • dokonać zapisu nowej wartości do zmiennej systemowej i ewentualnie zainicjować proces jej wysłania.

Obiekt wybieralny może być jednocześnie obiektem dynamicznym.

Zmienna systemowa

Zmienna systemowa to zmienna zadeklarowana w systemie Asix. Posiada ona nazwę symboliczną, typ oraz status. Może przechowywać wartości odczytane ze sterownika, wartości które mają być w sterowniku zapisane lub inne wartości przechowywane, na przykład na potrzeby obiektów.


19.3. Atrybut migotania

Następujące obiekty systemu Asix posiadają możliwość zadeklarowania atrybutu migotania:

ELIPSY

KOMUNIKATY

LICZBA

LINIE, LINIE PP

OBRAZKI

PROSTOKĄTY

SŁUPEK

TEKSTY

WIELOKĄTY, WIELOKĄTY PP

WIELOLINIE, WIELOLINIE PP

WSKAŹNIK

WYRAŻENIE

Dla wszystkich wymienionych powyżej obiektów (poza obiektem OBRAZKI) atrybut migotania oznacza wyświetlanie obiektu w zadeklarowanych kolorach. W przypadku obiektu OBRAZKI atrybut ten umożliwia zadeklarowanie dwóch map bitowych dla każdego stanu obiektu.

Możliwe jest deklarowanie kolorów wyświetlania obiektów na dwa sposoby: przez wskaźnik ustawionego koloru podstawowego w kształcie prostokąta lub przez indykator ustawienia atrybutu migotania (w kształcie okrągłej kontrolki)

.

Jeśli kolor wskaźnika ustawienia atrybutu migotania jest popielaty, to nie ustawiono tego atrybutu i obiekt wyświetlany będzie kolorem stałym, jeśli wskaźnik wyświetlany jest w kolorze żółtym lub czerwonym naprzemiennie z popielatym, to zadeklarowano migotanie obiektu. Migotanie kolorem żółtym indykatora oznacza wybranie jednego z trybów xor, kolorem czerwonym pozostałe ustawienia migotania.

W przypadku deklarowania bitmap dla obiektu OBRAZKI należy posłużyć się polami edycyjnymi położonymi poniżej listy obrazków.


19.3.1. Deklarowanie migotania

Aby parametryzowany obiekt wyświetlany był z atrybutem migotania, należy kliknąć myszką na wskaźniku atrybutu migotania, co prowadzi do otwarcia okienka, w którym należy zadeklarować tryb i kolory migotania. Możliwe są następujące opcje:

  • brak - kolory stałe,

  • xor znak tło - pulsują kolory tła i znaku zmieniając się na kolory przeciwne,

  • xor znak - zmienia się tylko kolor znaku na przeciwny,

  • xor tło - zmienia się kolor tła na przeciwny,

  • kolor znak tło - zmieniają sie kolory tła i znaku na zadeklarowane kolory alternatywne,

  • kolor znak - zmienia się kolor znaku na zadeklarowany kolor alternatywny,

  • kolor tło - zmienia się kolor tła na zadeklarowany kolor alternatywny.

Pole Przykład pokazuje, jak będzie wyglądać układ kolorów w trakcie działania aplikacji.

Rysunek: Okno parametryzacji atrybutu migotania.

Pola zaznaczone kolorem zielonym i pomarańczowym służą do określania koloru podstawowego.

W polach [image] oraz [image] określane są kolory przeciwne (xor koloru podstawowego).

W polach [image] oraz [image] określane są kolory alternatywne.


19.3.2. Ustawienie częstotliwości migotania

Aby zmieniać domyślny okres pulsacji obiektów z zadeklarowanym atrybutem migotania (333 ms) należy w pliku konfiguracyjnym aplikacji (plik XML aplikacji) dokonać ustawienia parametru Okres migotania:

Architekt > Obszary i komputery > moduł Maski > zakładka Pozostałe

Rysunek: Architekt - definiowanie okresu migotania obiektów.


19.4.1. Obiekt ASBASE

Parametry obiektu

Filtrowanie danych

Przykłady

Definiowanie zestawu zmiennych

Przykład

Obiekt ASBASE zapewnia łączność z bazą danych modułu AsBase, umożliwiając przeglądanie jej tabel. Jest to obiekt "przezroczysty", wstawiany na tle maski. Jeżeli potrzebny jest globalny dostęp do bazy danych, wówczas obiekt można umieścić na masce wyświetlanej przez cały czas działania aplikacji (np. menu). Działanie obiektu w momencie uruchamiania maski polega na utworzeniu połączenia z odpowiednim źródłem danych, natomiast w momencie zamknięcia maski na jego zamknięciu (przez cały czas wyświetlania maski musi być uruchomiony moduł AsBase).

Przegląd pojedynczej tabeli odbywa się w ramach połączenia, które posiada swój unikalny identyfikator, zdefiniowany w czasie parametryzacji obiektu ASBASE. Identyfikator ten jest potem wykorzystywany jako parametr akcji operatorskiej ASBASE,Nawiguj do określenia połączenia, którego dotyczy ta akcja. Oprócz określenia identyfikatora połączenia, obiekt ASBASE pozwala zdefiniować typ przeglądanej tabeli, jej identyfikator, zestaw zmiennych procesowych, do których będą przekazywane wartości z wierszy tabeli oraz filtr pozwalający określić, które zapisy znajdujące się w tabeli mają zostać wyświetlone na maskach procesowych.

Obiekt ASBASE pozwala przeglądać tabele typu: zestaw rejestracji, grupa receptur oraz historia ładowań. Sposób definiowania filtru znajduje się poniżej.

W chwili otwarcia maski, na której znajduje się obiekt ASBASE, następuje otwarcie połączenia o podanym identyfikatorze, otwarcie określonej tabeli oraz przekazanie wartości poszczególnych pól ostatniego zapisu w tabeli, który jest zgodny z definicją filtru, do zmiennych procesowych zestawu zmiennych o podanym identyfikatorze.

Do prezentacji wartości pól rekordu bazy danych najlepiej nadają się obiekty LICZBA oraz NAPIS.

Nawigacja po rekordach źródła danych realizowana jest za pomocą obiektów PRZYCISK, do których należy przypisać odpowiednio sparametryzowaną akcję ASBASE, Nawiguj (patrz: akcja ASBASE, 16. Akcje operatorskie).

Parametry obiektu

Rysunek: Okno parametryzacji obiektu ASBASE.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Identyfikator połączenia - pole tekstowe przeznaczone do wpisania identyfikatora jednoznacznie identyfikującego połączenie z określonym źródłem danych i zestawem zmiennych; identyfikator wykorzystywany jest później w akcji ASBASE NAWIGUJ, umożliwiającej poruszanie się po rekordach zmiennych pochodzących z danego źródła (patrz: akcja ASBASE, 16. Akcje operatorskie).

Typ źródła danych - pole cechy definiujące typ źródła danych, dostępny w module AsBase. Dostępne są następujące typy:

- zestaw rejestracji,

- grupa receptur,

- historia ładowań receptur.

Identyfikator źródła danych - pole wyboru umożliwiające, kolejno dla poszczególnych typów źródła danych, wybór nastepujących identyfikatorów: identyfikator zestawu rejestracji, grupy receptur i dla historii ładowań receptur - grupy receptur.

Identyfikator zestawu zmiennych - pole wyboru umożliwiające wybór zestawu zmiennych, za pomocą których przekazywane będą do aplikacji systemu Asix (i wyświetlane na projektowanej masce) wartości żądanych pól bazy danych modułu AsBase.

Filtr - parametr umożliwiający selekcję wyświetlanych wartości zmiennych.

Filtrowanie danych

Przeglądanie tabel można ograniczyć do zapisów spełniających określone kryteria za pomocą filtru danych. Filtr można zdefiniować w czasie parametryzacji obiektu ASBASE oraz za pomocą akcji operatorskiej ASBASE,Nawiguj (patrz: akcja ASBASE, 16. Akcje operatorskie).

Składnia filtru jest zgodna z klauzulą WHERE języka SQL z rozszerzeniami pozwalającymi na wstawianie do tej klauzuli wartości zmiennych procesowych oraz predefiniowanych filtrów. Słowa WHERE nie podaje się w definicji filtru. Wstawkę do filtru ujmuje się w nawiasy klamrowe.

Istnieje też możliwość dodania do składni filtru klauzuli ORDER BY.

Wstawka rozszerzająca pozwalająca zastosować wartość zmiennej procesowej ma postać:

{V:nazwa_zmiennej}

Wartość zmiennej wstawiana jest w miejsce wstawki. Jeśli zmienna ma wartość liczbową, to jest ona zamieniana na tekst.

Wstawka definiujące elementy filtru czasowego ma postać:

{T:kod[:identyfikator_pola]}

gdzie:

kod to:

t - dzisiaj

y - wczoraj

sy - od wczoraj

tw - ten tydzień

lw - poprzedni tydzień

slw - od poprzedniego tygodnia

tm - ten miesiąc

lm - poprzedni miesiąc

slm - od poprzedniego miesiąca

ty - ten rok

ly - poprzedni rok

sly - od poprzedniego roku

identyfikator_pola - opcjonalny identyfikator pola tabeli, do którego ma być zastosowany filtr czasowy. Jeśli ten element jest pominięty, to przyjmuje się, że filtr dotyczy czasu zapisu rekordu w tabeli. Jeśli identyfikator pola jest podany, to pole powinno być typu Data. Użycie tej wstawki powoduje, że cały tekst wstawki zostanie zastąpiony wyrażeniem (zgodnym ze składnią języka SQL) ograniczającym zbiór zapisów tabeli do takich, których wartość (czas) jest zawarty w przedziale czasowym określonym przez parametr kod. W ten sposób można np. wyświetlać zapisy tabeli dotyczące tylko poprzedniego dnia (kod y). Filtr nie jest modyfikowany w czasie trwania połączenia nawet jeśli upłynął podany odcinek czasu, tj. jeśli podano dzisiaj i połączenie jest otwarte drugą dobę, to pokazywane będą rekordy z poprzedniego dnia. Dopiero ponowne otwarcie połączenia lub ponowne zastosowanie tego samego filtru w akcji operatorskiej spowoduje aktualizację danych. Identyfikator pola tworzy się poprzez poprzedzenie nazwy pola przedrostkiem "V_".

PRZYKŁADY

Filtr {T:t} spowoduje wyświetlenie tylko tych zapisów, które zostały zapisane w dniu zdefiniowania filtru.

Filtr {T:y:V_pole1} spowoduje wyświetlenie tylko tych zapisów, które których pole o nazwie pole1 jest czasem i wartość tego pola należy do przedziału czasowego wczoraj.

Wstawki nie mogą występować wewnątrz elementów filtra zawartych w nawiasach prostokątnych [ i ] oraz ujętych w cudzysłowy ' i ". Aby treść wstawki mogła być zawarta pomiędzy tymi ogranicznikami, to te ograniczniki muszą być zawarte w nawiasach klamrowych. PRZYKŁAD: {'}{V:nazwa_zmiennej}{'} Powyższy fragment filtru zostanie zastąpiony wartością zmiennej ujętą w cudzysłowy pojedyncze.

Oprócz identyfikatorów pól tabeli, można również używać identyfikatorów dotyczących stałych pól tabeli, tj. takich pól, które zawsze są obecne w tabeli niezależnie od pól zestawu rejestracji czy receptury. Są to takie pola jak Czas, Czas UTC, Źródło, itd. Są to nazwy kolumn, które pojawiają się w module AsBase w czasie przeglądania archiwum zestawu rejestracji, receptury lub historii ładowań receptury. Pola te również mogą być elementami filtru. Identyfikatory tych pól są nazwami kolumn tabeli - tak jak występują one w bazie danych (nie dodaje się przedrostka "V_").

Tabela: Identyfikatory stałych pól tabeli bazy modułu AsBase.

Jak wyżej wspomniano, aby wartość pola zestawu rejestracji, receptury lub historii ładowań mogła być użyta jako element filtru, to nazwę tego pola należy poprzedzić przedrostkiem "V_" (poza stałymi polami tabel). W przypadku archiwum zestawu rejestracji, z każdą wartością pola jest związany status wartości oraz stempel czasowy tej wartości. Aby skorzystać z tych elementów, należy nazwę pola zestawu rejestracji poprzedzić przedrostkiem "S_" lub "T_" odpowiednio.

PRZYKŁAD ZASTOSOWANIA FILTRU W AKCJI OPERATORSKIEJ ASBASE

ASBASE,NAWIGUJ,conMie\Filter\v_id_miesz like {'}{V:1PD_id_m1}{'} OR v_id_miesz like {'}{V:1PD_id_m2}{'} AND {'}{V:1PD_id_m2}{'}<>"

Akcja ustawia filtr w łączu conMie w następujący sposób:

wartość pola v_id_miesz jest równa jednemu z identyfikatorów mieszanki: id mieszanki 1 (zmienna 1PD_id_m1), id mieszanki 2 (zmienna 1PD_id_m2). Wykluczono z zapytania rekordy o pustym id mieszanki 2.

Definiowanie zestawu zmiennych

Aby wartości poszczególnych pól tabeli można było wyświetlać na maskach procesowych, polom tym muszą być przypisane nazwy zmiennych procesowych, znajdujących się w kanele typu NONE. Przypisanie to wykonuje się w module AsBase poprzez utworzenie odpowiedniego zestawu zmiennych. Identyfikator tego zestawu podaje się następnie jako parametr obiektu ASBASE. Domyślnie, pola stałe tabeli nie są w takim zestawie pokazane. Aby przypisać zmienne polom stałym tabeli, należy z menu Widok lub z menu kontekstowego zestawu zmiennych wybrać pozycję Pokaż wszystkie pola.

PRZYKŁAD

Poniżej pokazano definicję przykładowego zestawu zmiennych. Pole stałe o nazwie Ilość rekordów pozwala na przypisanie do zmiennej ilości zapisów spełniających kryterium filtru. Zliczanie rekordów następuje w czasie otwarcia połączenia, zdefiniowania nowego filtru oraz w wyniku akcji operatorskiej ASBASE,Nawiguj z komendą COUNT. Wartością pola stałego ID jest numer kolejny rekordu w bazie danych.

Rysunek: Przykład definicji zestawu zmiennych w oknie modułu AsBase.


19.4.2. Obiekt DATA + CZAS

Wymiary

Parametry obiektu

Nazwa Obiektu

Atrybuty

Rodzaj

Parametry

Wyrównanie

Format daty

Łącznik daty

Obiekt DATA+CZAS umożliwia wyświetlenie na masce daty lub czasu względnie daty oraz czasu łącznie. Jest obiektem dynamicznym, choć jego postać nie jest uzależniona od zmiennych systemowych, a jedynie od czasu. Możliwe jest dla niego określenie sposobu prezentacji poprzez podanie czcionki oraz kolorów.

Rysunek: Przykład obiektu DATA+CZAS.

Wymiary

Wysokość przyjmuje się automatycznie na podstawie wybranej czcionki bez możliwości modyfikacji.

Szerokość przyjmuje się automatycznie na podstawie najdłuższego możliwego łańcucha (dla daty jest to miesiąc październik) z możliwością modyfikacji przy pomocy myszki.

Parametry obiektu

Rysunek: Okno parametryzacji obiektu DATA+CZAS.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Atrybuty-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlona data i czas. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Atrybuty-Linia - pole koloru umożliwiające ustawienie koloru czcionki po wywołaniu okna wyboru koloru.

Atrybuty-Tło - pole koloru umożliwiające ustawienie koloru tła po wywołaniu okna wyboru koloru.

Atrybuty- Tło przezroczyste - pole cechy umożliwiające ustawienie tła przezroczystego pod tekstem obiektu.

Atrybuty-Tło w Kolorze Okna - pole cechy umożliwiające wymuszenie rysowania tła obiektu w kolorze tła ustawionym dla maski.

Rodzaj-Data+Czas - pole wyboru wymuszające wyświetlenie daty oraz czasu.

Rodzaj-Data - pole wyboru wymuszające wyświetlenie tylko daty.

Rodzaj-Czas - pole wyboru wymuszające wyświetlenie tylko czasu.

Parametry-Miesiąc słownie - pole cechy wymuszające wyświetlenie miesiąca słownie np. "25 Listopad 98".

Parametry-Duże litery - pole cechy wymuszające wyświetlenie miesiąca dużymi literami np. "3 MAJ 1956".

Parametry-Skrócony rok - pole cechy wymuszające wyświetlenie skróconego roku np. "7 10 63".

Parametry-Skrócony miesiąc - pole cechy wymuszające wyświetlenie skróconego do trzech liter miesiąca np. "7 Paź. 63".

Parametry-Nieznaczące zera - pole cechy wymuszające wyświetlenie nieznaczących zer w oznaczeniu dni oraz ewentualnie miesięcy i lat np. "07/01/63".

Parametry-Czas bez sekund - pole cechy wymuszające wyświetlenie czasu bez sekund np. "12:45".

Wyrównanie-Do Lewej - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do lewej.

Wyrównanie-Środkowanie - pole wyboru wymuszające środkowanie tekstu w obszarze obiektu.

Wyrównanie-Do Prawej - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do prawej.

Format Daty-Domyślny - pole cechy wymuszające wyświetlenie daty według ustawień systemu.

Format Daty-Amerykański - pole cechy wymuszające amerykański sposób wyświetlenia daty np. "Marzec 28, 1990".

Format Daty-Azjatycki - pole cechy wymuszające azjatycki sposób wyświetlenia daty np. "1990 Marzec 28".

Format Daty-Europejski - pole cechy wymuszające europejski sposób wyświetlenia daty np. "28 Marzec 1990".

Format Daty-Systemowy - pole cechy wymuszające użycie systemowej daty np. "3/28/90" .

Format Daty-Wojskowy - pole cechy wymuszające wojskowy sposób wyświetlenia daty np. "28 Mar 90".

Łącznik Daty-Brak - pole cechy wymuszające wyświetlenie daty bez łącznika np. "3 28 90".

Łącznik Daty-Kreska - pole cechy wymuszające poziomą kreskę w charakterze łącznika daty np. "3-28-90".

Łącznik Daty- / Ukośnik - pole cechy wymuszające ukośnik w charakterze łącznika daty np. "3/28/90".

Domyślnie ustawione są opcje Rodzaj-Data+Czas, Parametry-Miesiąc słownie, Wyrównanie-Do Lewej, Format Daty-Europejski oraz Łącznik Daty-Brak.

Zaleca się stosowanie zamiast obiektu DATA i CZAS dwóch oddzielnych obiektów (wówczas data nie będzie odświeżana co sekundę tylko co dobę). Ponadto wskazane jest stosowanie czcionki o stałej szerokości znaku (unika się wtedy efektu dynamicznej zmiany szerokości obiektu).


Obiekt_dymek

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.3. Obiekt DYMEK

19.4.3. Obiekt DYMEK

Nowa klasa obiektów DYMEK. Użycie obiektu na masce powoduje, że dla wszystkich dynamicznych posiadających podaną nazwę zmiennej) obiektów wyświetlany jest tzw. dymek. Zestaw informacji określony jest w definicji obiektu DYMEK. Są te generalnie atrybuty zmiennej, deklarowane w identyczny sposób jak w polu formatu legendy w obiekcie WYKRES.

Umieszczenie na masce obiektu DYMEK powoduje, że inne obiekty dynamiczne znajdujące się na ten masce mają wyświetlany tzw. dymek, po najechaniu na nie kursorem.

Rysunek: Okno parametryzacji obiektu DYMEK.


19.4.3. Obiekt ELIPSA

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.4. Obiekt ELIPSA

19.4.4. Obiekt ELIPSA

Wymiary

Parametry obiektu

Nazwa obiektu

Kolor linii

Kolor wypełnienia

Kąty

Szerokość linii

Wypełnienie

Rysowanie okręgu

Obiekt ELIPSA umożliwia wyświetlenie na masce elipsy lub też jej wycinka. Jest to obiekt statyczny. Możliwe jest określenie dla niego wymiarów i kolorów, a także początkowego i końcowego kąta. Można narysować okrąg jako szczególny przypadek elipsy.

Rysunek: Przykład obiektu ELIPSA.

Wymiary

Wysokość i szerokość podaje się przy pomocy myszki.

Parametry obiektu

Rysunek: Okno parametryzacji obiektu ELIPSA.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolor Linii - pole koloru umożliwiające ustawienie koloru linii otaczającej elipsę po wywołaniu okna wyboru koloru.

Kolor Wypełnienia - pole koloru umożliwiające ustawienie koloru wnętrza elipsy po wywołaniu okna wyboru koloru.

Kąt Początkowy - pole liczbowe umożliwiające ustawienie kąta początkowego łuku elipsy (domyślnie 0).

Kąt końcowy - pole liczbowe umożliwiające ustawienie kąta końcowego łuku elipsy (domyślnie 360).

Szerokość Linii - pole liczbowe umożliwiające ustawienie grubości linii otaczającej elipsę (domyślnie 1).

Wypełnić Wnętrze - pole cechy umożliwiające wypełnienie wnętrza elipsy.

Wypełnienie w Kolorze Okna - pole cechy umożliwiające wymuszenie rysowania wnętrza elipsy w kolorze tła ustawionym dla maski.

Rysować okrąg - pole cechy umożliwiające wymuszenie rysowania okręgu.

Elipsa (lub jej wycinek) kreślone są linią o zadanej grubości. Kąt początkowy powinien być mniejszy od końcowego, zaś ich różnica mniejsza lub równa 360 stopni. Tylko w przypadku linii o pojedynczej grubości wnętrze może pozostać niewypełnione.


19.4.4. Obiekt ELIPSY

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.5. Obiekt ELIPSY

19.4.5. Obiekt ELIPSY

Wymiary | Sposoby kodowania
Parametry obiektu | Przykład kodowania
Nazwa |
Parametry |
Wysyłanie |
Stan |
Maska bitowa |
Linia |
Tło |
Migot. |
Kodowanie |
Dana monitorowana |
Kąty |

Obiekt ELIPSY stanowi odmianę obiektu ELIPSA umożliwiającą zmianę kolorów i ustawienie atrybutu migotania narysowanej elipsy w zależności od stanu danej monitorowanej. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Opcjonalnie obiekt ELIPSY może być także obiektem wybieralnym i może służyć do wysyłania określonej zawartości do zmiennej sterowanej.

Wysyłanie wartości może być chronione hasłem.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są zmianą koloru.

Rysunek: Przykład obiektu ELIPSY.

Wymiary

Wymiary elipsy podaje się przy pomocy myszki.

Parametry

Rysunek: Okno parametryzacji obiektu ELIPSY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-Wypełnić Wnętrze - pole cechy umożliwiające wypełnienie wnętrza elipsy w zadeklarowanym kolorze.

Parametry-w Kolorze Okna - pole cechy umożliwiające wypełnienie wnętrza elipsy w kolorze ustawionym dla okna bez względu na zadeklarowany kolor wnętrza.

Parametry-Rysować okrąg - pole cechy umożliwiające wymuszenie rysowania okręgu

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającej jej elipsy przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany, w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej elipsie.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającej jej elipsy przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej elipsie.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jedna z wielu zadeklarowanych elips. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi elipsami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji jednej z dwu list kolorów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku.

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Linia - lista kolorów odpowiadających otoczkom poszczególnych elips. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Przerwa - deklaruje kolor przerwy na otoczce poszczególnych elips.

Tło - lista kolorów odpowiadających wnętrzom poszczególnych elips. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Tło2 - deklaracje koloru dla pola Tło2 spowoduje, że obszar elips będzie naprzemiennnie wypełniony dwoma kolorami.

Migot. - otwarcie okienka do parametryzacji atrybutu migotania.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Kolor linii - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji. Wybranie tego pola powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany kolorem linii obwiedni oraz wnętrza). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Kąty-Początkowy - pole liczbowe umożliwiające ustawienie kąta początkowego łuku elipsy w stopniach (domyślnie 0).

Kąty-Końcowy - pole liczbowe umożliwiające ustawienie kąta końcowego łuku elipsy w stopniach (domyślnie 360).

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych kolorów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji "ze sterowaniem"). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Kodowanie

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa "liczbie stanów", zaś numer najmłodszego bitu określa "przesunięcie". Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z "liczby stanów" zaś, numer najmłodszego bitu określa "przesunięcie". Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr "przesunięcie". Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

PrzYkład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu, co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery elipsy np. żółtą, zieloną, niebieską i czerwoną (w tej kolejności) to stanowi "00" będzie odpowiadać elipsa żółta, stanowi "01" elipsa zielona itd. W przypadku zapisu, jeśli wybrana zostanie elipsa czerwona to odpowiadający jej stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający kolorowi wybranej elipsy.

1000000000100000 / zmienna przeczytana
1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"
----------11---- / bity ustawiane przez obiekt
1000000000110000 / zmienna wysyłana


19.4.5. Obiekt KOMUNIKATY

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.6. Obiekt KOMUNIKATY

19.4.6. Obiekt KOMUNIKATY

Wymiary | Przykłady pliku *.msg
Parametry obiektu |
Nazwa Obiektu |
Nazwa Pliku |
Ogranicznik tekstów |
Przezroczyste tło |
Lista komunikatów |
Edycja komunikatu |
Dana monitorowana |

Obiekt KOMUNIKATY umożliwia wyświetlenie na masce jednego z wielu wyspecyfikowanych tekstów. Obiekt może obsługiwać maksymalnie 65535 stanów. Przystosowany jest do wyświetlania dużej liczby komunikatów (nawet kilkaset). W związku z tym może być parametryzowany z pliku tekstowego, w którym przechowywane są teksty oraz ewentualnie ich atrybuty, o ile nie są one domyślne.

Jest to obiekt dynamiczny. Wybrany do wyświetlenia tekst oraz jego atrybuty (kolor, czcionka, migotanie) zależą od wartości zmiennej monitorowanej.

Rysunek: Przykład obiektu KOMUNIKATY.

Wymiary

Wymiary obiektu KOMUNIKATY są określane za pomocą myszki. Obszar ten nie skaluje się automatycznie na podstawie zawartości tekstu oraz zastosowanej czcionki (tak jak np. obiekt TEKSTY). W związku z tym na projektancie ciąży obowiązek dobrania właściwego obszaru, tak aby mieściły się na nim wszystkie możliwe wyświetlane teksty. Sam obiekt nie może tego zrobić, ponieważ teksty nie są przechowywane w obiekcie, ale w pliku tekstowym i mogą zostać zmienione już po parametryzacji. Jeżeli jednak podczas wyświetlania tekst zostanie obcięty, wówczas obiekt wskazuje ten fakt umieszczeniem na końcu tekstu sekwencji trzech kropek "...".

Parametry

Rysunek: Okno parametryzacji obiektu KOMUNIKATY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Nazwa Pliku - pole tekstowe służące do wpisania nazwy pliku, w którym mieści się definicja obiektu. Domyślne rozszerzenie tego pliku to msg. Plik ten może być utworzony ręcznie lub automatycznie. Składnia tego pliku podana została w dalszej części opisu. Plik ten można wybrać po naciśnięciu przycisku Czytaj.

Ogranicznik tekstów - pola tekstowe (1-znakowe) umożliwiające ustawienie ogranicznika tekstów (domyślnie znak " - cudzysłów) używanego w pliku msg.

Przezroczyste tło - pole cechy umożliwiające zastosowanie przezroczystego tła tekstu.

Lista komunikatów - lista tekstów odpowiadających poszczególnym stanom obiektu wraz z numerami stanów. Zmian elementów tej listy można dokonać przy pomocy grupy pól Edycja komunikatu oraz umieszczonych pod nim klawiszy.

Edycja komunikatu - grupa pól wyświetlających treść komunikatu wybranego oraz jego atrybuty. Pola te mogą być edytowane i służyć do modyfikacji istniejących komunikatów oraz wstawiania komunikatów nowych. W polach tej grupy wyświetla się tekst oraz atrybuty komunikatu wskazanego na Liście komunikatów.

Numer - pole tekstowe umożliwiające wyświetlenie i wprowadzenie numeru wyświetlanego komunikatu. W polu tym oprócz liczby może się również pojawić zakres (np. 5..10) lub znak "*" (gwiazdka) symbolizujący numer komunikatu domyślnego.

Tekst - pole tekstowe umożliwiające wyświetlenie i wprowadzenie tekstu komunikatu bieżącego (odpowiadający danemu stanowi).

Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony tekst bieżący (odpowiadający danemu stanowi). Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Kolory - pola koloru umożliwiające wyświetlenie oraz ustawienie koloru znaków i tła którymi ma zostać wyświetlony tekst odpowiadający danemu stanowi. Po wyselekcjonowaniu tego pola wyświetlone zostaje okno wyboru koloru.

Migot. - pole sygnalizujące tryb migotania tekstu bieżącego (poprzez zmianę koloru). Kliknięcie na tym polu powoduje wejście do okna umożliwiającego zdefiniowanie trybu migotania.

Przycisk Czytaj - przycisk umożliwiający wybranie i wczytanie definicji obiektu z pliku tekstowego za pomocą standardowego okna umożliwiającego otwarcie pliku. Nazwa pliku jest pobierana z pola Nazwa pliku.

Przycisk Zmień - przycisk umożliwiający zmianę wskazanego komunikatu. Zmienione mogą być wszystkie jego parametry (treść, numer, atrybuty). W szczególności można zmienić również definicję komunikatu domyślnego, ale wówczas w polu numeru musi pozostać znak "*". Modyfikując pole numeru należy uważać, aby nie spowodować konfliktu numerów. Klawisz Zmień musi być użyty tylko wtedy, gdy zmieniony został numer komunikatu. Zmiany pozostałych parametrów, są akceptowane automatycznie.

Przycisk Dodaj - przycisk umożliwiający dodanie nowego komunikatu o własnościach określonych zawartością pól Komunikatu bieżącego. Dodając nowy komunikat należy uważać, aby nie spowodować konfliktu numerów. Nie jest możliwe dodanie komunikatu domyślnego, za wyjątkiem sytuacji kiedy lista komunikatów jest pusta.

Przycisk Usuń - przycisk umożliwiający usunięcie wskazanego komunikatu. Komunikat domyślny nie może zostać usunięty.

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Sposób działania / składnia pliku definiującego obiekt typu KOMUNIKATY

Po wstawieniu nowego obiektu ma masce pole Lista komunikatów oraz Nazwa pliku są puste. Należy wtedy wpisać odpowiednie komunikaty. Są dwie możliwości wypełnienia tej listy. Można wszystkie komunikaty wpisać w pliku tekstowym o zadanej składni lub też wpisać je wprost z okna parametryzacji. Ta pierwsza metoda jest lepsza w przypadku pierwszej parametryzacji, z kolei druga metoda jest wydajniejsza dla wprowadzania drobnych poprawek.

Poniżej przedstawiona jest składnia pliku definiującego obiekt typu KOMUNIKATY. Pliki te posiadają rozszerzenie *.msg.

Składnia pojedynczej linii jest następująca:

Numer,Tekst[,Czcionka[,Kolor[,Tło[,Migotanie[,Kolor1[,Kolor2[,]]]]]]]

gdzie:

Numer - jest numerem tekstu, który ma zostać wyświetlony, jeśli zmienna monitorowana będzie miała odpowiednią wartość; dopuszcza się zapis dziesiętny i szesnastkowy w postaci np. 0x10; możliwe jest specyfikowanie przedziału wartości np. 10..20. Znak * w tym polu oznacza tekst domyślny; numery muszą być z przedziału od 0..n;

Tekst - jest dowolnym tekstem ograniczonym znakami "" (domyślnie cudzysłów z możliwością zmiany);

Czcionka - jest opcjonalną nazwą czcionki dla danego tekstu;

Kolor - jest opcjonalnym kolorem znaków;

Tło - jest opcjonalnym kolorem tła;

Migotanie - jest opcjonalną nazwą trybu migotania; przyjęto następujące skróty oznaczające poszczególne tryby: "NO", "X", "FX", "BX", "F", "B", "FB";

Kolor1 - jest kolorem wymaganym dla migotania znakami;

Kolor2 - jest kolorem wymaganym dla migotania tłem;

Pierwsza linia powinna zawierać komunikat domyślny. Znak # na początku linii oznacza komentarz. Dopuszczalne są linie puste.

Do kodowania koloru użyto notacji stosowanej w A sixie do zapisu kolorów w pliku definicyjnym trendów. Kolor jest zapisywany jako łańcuch:

RGB-rrr-ggg-bbb

gdzie:

rrr nasycenie koloru czerwonego (0..255),

ggg nasycenie koloru zielonego (0..255),

bbb nasycenie koloru niebieskiego (0..255) .

Pola Kolor 1 i Kolor2 muszą wystąpić, o ile aktywny jest odpowiedni tryb migotania ("F", "B" lub "FB"). Poszczególne pola opcjonalne mogą być puste. Wtedy przyjmuje się, że wartość pola jest domyślna.

W większości przypadków pola opcjonalne nie będą używane i generalnie nie będzie się ich wypełniało przy pomocy edytora. Pola te będą zasadniczo generowane automatycznie przy wyjściu z edycji obiektu, po tym jak użytkownik określi, że np. tekst numer 100 ma być czerwony i w dodatku migający.

Każdy plik z definicją komunikatów przed wczytaniem musi zostać sprawdzony i wykrywa się następujące błędy:

niewłaściwa zawartość pola np. oczekiwany tekst, a jest kolor,

wielokrotna definicja danego komunikatu np. dwie linie typu

1,"tekst....

1,"tekst....

zachodzące na siebie obszary np. linie typu

1..30, "tekst....

20..50, "tekst....

puste obszary np.

20..10, "tekst.....

Poniżej zamieszczony jest przykład pliku *.msg.

PRZYKŁAD pliku definiującego obiekt typu KOMUNIKATY

*,"Tekst domyślny ...",Dialog,RGB-0-0-0,RGB-0-255-128,

1,"Tekst wyświetlany dla stanu 1",Dialog,RGB-0-0-0,RGB-255-255-128,

3..10,"Tekst wyświetlany dla stanów od 3 do 10",Dialog,RGB-0-0-0,RGB-255-0-0,FB,RGB-0-0-0,RGB-255-128-64,

Po wstawieniu nowego obiektu KOMUNIKATY na masce należy nacisnąć przycisk Czytaj, aby wczytać wstępnie przygotowany plik tekstowy z definicją. Plik ten może mieć wypełnione jedynie pozycje określające numer oraz tekst. Jeśli w pliku tym nie będzie błędów wówczas wypełniona zostanie Lista komunikatów.

Mając gotową listę komunikatów można komunikaty edytować, dodawać i usuwać. Służą do tego klawisze Zmień, Dodaj i Usuń oraz pola Edycja komunikatu. Aby dokonać edycji określonego komunikatu należy najpierw go wskazać na liście. Wówczas jego numer (numery), treść, oraz atrybuty pojawią się w odpowiednich polach grupy Edycja komunikatu. Wtedy można dokonać ich edycji po czym należy nacisnąć przycisk Zmień. Podobnie wygląda dodawanie i usuwanie komunikatów.

Należy pamiętać, że komunikat domyślny jest obsługiwany w sposób specjalny. Nie można go usunąć, nie można dodać drugiego - można go jedynie edytować nie zmieniając pola numer.

PRZYKŁAD pliku definiującego obiekt typu KOMUNIKATY

*,"Wieża węgla - rząd VII",syst95,RGB-255-255-255,RGB-148-148-148,

81,"Wieża węgla - rząd VIII",syst95,RGB-0-0-0,RGB-255-255-255,

82,"Wieża węgla - rząd VII",syst95,RGB-0-0-0,RGB-255-255-255,

83,"Wieża węgla - rząd IV",syst95,RGB-0-0-0,RGB-255-255-255,

84,"Wieża węgla - rząd III",syst95,RGB-0-0-0,RGB-255-255-255,

85,"Wieża węgla - rząd II",syst95,RGB-0-0-0,RGB-255-255-255,

1101,"Komora nr 1101",syst95,RGB-0-0-0,RGB-255-255-255,

1102,"Komora nr 1102",syst95,RGB-0-0-0,RGB-255-255-255,

1190,"Pozycja MAX w przodzie",syst95,RGB-0-0-0,RGB-255-255-255,

1192,"Czyszczenie rury kom. nr 1101",syst95,RGB-0-0-0,RGB-255-255-255,

1193,"Czyszczenie rury kom. nr 1102",syst95,RGB-0-0-0,RGB-255-255-255,

1194,"Czyszczenie rury kom. nr 1139",syst95,RGB-0-0-0,RGB-255-255-255,

1195,"Czyszczenie rury kom. nr 1140",syst95,RGB-0-0-0,RGB-255-255-255,

1292,"Czyszczenie rury kom.1201",syst95,RGB-0-0-0,RGB-255-255-255,

1293,"Czyszczenie rury kom.1202",syst95,RGB-0-0-0,RGB-255-255-255,

1294,"Czyszczenie rury kom.1239",syst95,RGB-0-0-0,RGB-255-255-255,

1295,"Czyszczenie rury kom.1240",syst95,RGB-0-0-0,RGB-255-255-255,


19.4.6. Obiekt KONTROLER OBIEKTÓW

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.7. Obiekt KONTROLER OBIEKTÓW

19.4.7. Obiekt KONTROLER OBIEKTÓW

Obiekt KONTROLER OBIEKTÓW pozwala na kotrolę widzialności obiektów masek technologicznych. Mechanizm 'widzialności’ dotyczy obiektów wszystkich klas. Obiekt ukryty (niewidzialny) nie jest wyświetlany i nie wykonuje żadnych swoich funkcji. W szczególności można w ten sposób ukryć obiekt typu PRZYCISK, lub wyłączyć obiekt PRZELICZNIK.

Sterowanie stanem widzialności obiektu nie jest deklarowane w samym obiekcie, ale odbywa się za pośrednictwem obiektu klasy KONTROLER OBIEKTÓW, który może sterować widzialnością innych obiektów na podstawie stanu zmiennej procesowej lub aktualnie ustawionego poziomu hasła (co również działa z systemem logowania użytkowników - wewnętrznym i modułu AsAudit).

W przypadku stosowania kontroli poziomem hasła, kontrolowane obiekty widoczne są wyłącznie dla tych operatorów, których poziom hasła jest równy bądź większy od poziomu zadeklarowanego w obiekcie KONTROLER OBIEKTÓW - sterującym widocznością wspomnianych obiektów.

Kontrola wartością zmiennej polega na zadeklarowaniu maski bitowej zmiennej, od której zależeć będzie widoczność obiektów, zadeklarowanych w obiekcie KONTROLER OBIEKTÓW jako Obiekty kontrolowane. Gdy warunek zostanie spełniony, obiekty te staną się niewidoczne.

Zastosowanie obu typów kontroli jednocześnie spowoduje następujące zachowanie kontrolowanych obiektów: obiekty będą widoczne pod warunkiem posiadania przez operatora poziomu hasła równego bądź większego od zadeklarowanego w obiekcie KONTROLER OBIEKTÓW; dodatkowo, kontrolowane obiekty (dostępne dla operatora o wymaganym poziomie hasła) będą ukrywane w momencie spełnienia warunku kontroli wartością zmiennej.

Kontrola położeniem myszki powoduje pojawienie się na masce aplikacji obiektów kontrolowanych w momencie najechania kursorem myszki na obiekt KONTROLER OBIEKTÓW.

Kontroler może jednocześnie sterować stanem wielu obiektów umieszczonych na tej samej masce, ale na podstawie tego samego warunku. Na tej samej masce może zatem znajdować się wiele obiektów klasy KONTROLER OBIEKTÓW.

Wiązanie obiektów z Kontrolerem odbywa się poprzez nazwy obiektów, czyli - każdy obiekt, którego widzialność ma być kontrolowana musi mieć nadaną nazwę, którą należy wskazać w definicji obiektu Kontrolera.

Rysunek: Okno parametryzacji obiektu KONTROLER OBIEKTÓW.


19.4.7. Obiekt KONTROLER RUCHU

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.8. Obiekt KONTROLER RUCHU

19.4.8. Obiekt KONTROLER RUCHU

Obiekt KONTROLER RUCHU pozwala na animację ruchu obiektów masek technologicznych. Ruch ten wykonywany jest w osi X i Y i może dotyczyć jednego lub wielu obiektów jednocześnie.

Deklaracja obiektów poruszanych odbywa się poprzez podanie nazwy obiektu w definicji KONTROLERA RUCHU (pole Obiekty kontrolowane w oknie definicji KONTROLERA RUCHU).

Zakres ruchu określony jest rozmiarem obiektu KONTROLER RUCHU (pola Pozycja i Zakres).

Parametry

Rysunek: Okno parametryzacji obiektu.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Poziomo - Nazwa zmiennej - pole tekstowe umożliwiające zadeklarowanie zmiennej, od zmiany której zależeć będzie ruch kontrolowanych obiektów po osi Y.

Poziomo - Pozycja - pole umożliwiające zadeklarowanie skrajnych punktów (w pikselach) poziomego zakresu, w którym obiekt kontrolowany będzie się mógł poruszać.

Poziomo - Zakres - pole umożliwiające zadeklarowanie zakresu zmiennej.

Pionowo - Nazwa zmiennej - pole tekstowe umożliwiające zadeklarowanie zmiennej, od zmiany której zależeć będzie ruch kontrolowanych obiektów po osi X.

Pionowo - Pozycja - pole umożliwiające zadeklarowanie skrajnych punktów (w pikselach) pionowego zakresu, w którym obiekt kontrolowany będzie się mógł poruszać.

Pionowo - Zakres - pole umożliwiające zadeklarowanie zakresu zmiennej.

Wszystkie obiekty - lista wszystkich nazw obiektów, znajdujących się na masce.

Obiekty kontrolowane - lista obiektów, których ruch kontrolowany jest przez KONTROLERA RUCHU.


19.4.8. Obiekt LICZBA

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.9. Obiekt LICZBA

19.4.9. Obiekt LICZBA

Wymiary | Opis działania
Parametry obiektu | Opis formatów
Nazwa obiektu | Parametryzacja z Bazy
Kolory i Czcionki |
Format |
Zakresy |
Limity |
Parametry |
Dana pomiarowa |
Wyrówn. |
W pionie |

Obiekt LICZBA umożliwia wyświetlenie na masce liczby odpowiadającej wartości zmiennej systemowej. Jest obiektem dynamicznym. Może opcjonalnie być obiektem wybieralnym. W tym przypadku umożliwia wpisanie do obiektu wartości, która zostanie następnie zapisana do zmiennej systemowej. Wysyłanie wartości może być chronione hasłem. Obiekt LICZBA może zmieniać swój kolor i migotać w zależności od wystąpienia przekroczeń wartości krytycznych lub wystąpienia pewnych warunków logicznych.

Rysunek: Przykład obiektu LICZBA.

Wymiary

Wysokość i szerokość przyjmuje się automatycznie według wyspecyfikowanego formatu dla najdłuższego możliwego łańcucha wynikającego z podanego zakresu. Wymiary obiektu można zwiększyć przy pomocy myszki. Przy podaniu cechy "obszar wg. formatu" będą one automatycznie zmieniane na obszar wynikający z formatu.

Parametry

Kolejno zaprezentowane zostało okno umożliwiające parametryzację obiektu LICZBA.

Rysunek: Okno parametryzacji obiektu LICZBA.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolory i Czcionki->> - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy alarmowej.

Kolory i Czcionki -> - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy ostrzegawczej.

Kolory i Czcionki -= - pola koloru umożliwiające ustawienie podstawowego koloru cyfr (pole lewe) oraz tła (pole prawe) wyświetlanej liczby.

Kolory i Czcionki -? - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe i środkowe) oraz tła (pole prawe) wyświetlanej liczby w przypadku błędu komunikacji (pole lewe) i błędu pomiarowego (pole środkowe).

Kolory i Czcionki -< - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy ostrzegawczej.

Kolory i Czcionki -<< - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy alarmowej.

Kolory i Czcionki -^ - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) wyświetlanej liczby podczas jej edycji poprzedzającej wysłanie wartości.

Kolory i Czcionki --> - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) wyświetlanej liczby po jej edycji, a przed wysłaniem w trybie z potwierdzeniem.

Kolory i Czcionki -Tło koloru Okna - pole cechy umożliwiające wymuszenie ustawienie koloru tła zgodnego z kolorem okna.

Kolory i Czcionki -Tło przezroczyste - pole cechy umożliwiające zastosowanie przezroczystego tła tekstu.

Kolory i Czcionki - na prawo od pól wyboru koloru dla poszczególnych limitów znajdują się indykatory atrybutu migotania. Dalej na prawo znajduje się kolumna pól wyboru czcionek. Czcionki mogą być wybrane indywidualnie dla każdego z limitów, przez co można np. zadeklarować większą czcionkę dla sytuacji alarmowych, by ułatwić Operatorowi spostrzeżenie przekroczenie limitów technologicznych.

Format - pole tekstowe umożliwiające zadeklarowanie formatu wyprowadzanej liczby. Dopuszczalne formaty pochodzą ze standardu języka C i zostały omówione w dalszej części. Domyślny jest format %d (liczba całkowita).

Format-Dokł. - pole liczbowe umożliwiające ustawienie dokładności. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie wartość tego pola jest zerowa, co oznacza brak zaokrąglania.

Format-Obszar wg Formatu - pole cechy umożliwiające wymuszenie obszaru zajmowanego przez obiekt zgodnego z formatem i czcionką np. dla formatu %5u oznacza to, że obszar zajmowany przez obiekt odpowiadał będzie pięciu cyfrom o wymiarach określonych przez wybraną czcionkę.

Zakresy-X>> - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 90. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-X> - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 75. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego zakresu. Domyślnie 0. Liczby mniejsze będą wyświetlone. Wartość wykorzystywana jedynie do określenia obszaru zajmowanego przez obiekt.

Zakresy-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości górnego zakresu. Domyślnie 100. Liczby większe będą wyświetlone. Wartość wykorzystywana jedynie do określenia obszaru zajmowanego przez obiekt.

Zakresy-X< - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 25. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-X<< - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 10. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Limity-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego limitu wprowadzanych liczb (dotyczy opcji Ze sterowaniem). Domyślnie 0. Liczby mniejsze nie będą przyjmowane i wysyłane.

Limity-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości górnego limitu wprowadzanych liczb (dotyczy opcji Ze sterowaniem). Domyślnie 100. Liczby większe nie będą przyjmowane i wysyłane.

Wyrówn.-w lewo - pole wyboru wymuszające wyrównanie liczby w obszarze obiektu do lewej.

Wyrówn.-środek - pole wyboru wymuszające środkowanie liczby w obszarze obiektu.

Wyrówn.-w prawo - pole wyboru wymuszające wyrównanie liczby w obszarze obiektu do prawej.

W pionie-w górę - pole wyboru wymuszające pionową justację liczby do górnej krawędzi pola zajmowanego przez obiekt.

W pionie-środek - pole wyboru wymuszające środkowanie w pionie liczby wewnątrz pola zajmowanego przez obiekt.

W pionie-w dół - pole wyboru wymuszające pionową justację liczby do dolnej krawędzi pola zajmowanego przez obiekt.

Dana pomiarowa - pole tekstowe umożliwiające podanie nazwy danej pomiarowej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku do liczby zostanie dopisany znak umieszczony w polu z prawej strony, domyślnie "?". Umieszczenie w tym polu np. dwóch znaków "?" spowoduje, że w przypadku wystąpienia tego błędu całe pole liczby zostanie wypełnione pytajnikami. Opcja domyślna.

Błędy pomiarowe - pole cechy umożliwiające sygnalizację błędów pomiarowych. W takim przypadku do liczby zostanie dopisany znak umieszczony w polu z prawej strony, domyślnie "!". Umieszczenie w tym polu np. dwóch znaków "!" spowoduje, że w przypadku wystąpienia tego błędu całe pole liczby zostanie wypełnione wykrzyknikami. Wymaga wyspecyfikowania Danej kontrolnej.

Dana kontrolna - pole tekstowe umożliwiające podanie nazwy danej kontrolnej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Błędy pomiarowe. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej kontrolnej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Status - pole tekstowe umożliwiające wprowadzenie szesnastkowej maski. Jeśli iloczyn tej maski i danej kontrolnej jest różny od zera, wówczas mamy do czynienia z wystąpieniem błędu pomiarowego.

Parametry-Autom. Edycja - pole cechy umożliwiające edycję liczby bezpośrednio po wyselekcjonowaniu (kliknięciu). W przeciwnym razie, aby rozpocząć edycję należy wyselekcjonować obiekt po czym przycisnąć klawisz Enter.

Parametry-Inicjacja poprzednią - pole cechy umożliwiające inicjację pola liczby przed edycją poprzednio wprowadzoną wartością.

Parametry-Inicjacja bieżącą - pole cechy umożliwiające inicjację pola liczby przed edycją bieżącą wartością.

Parametry-Autom. wysłanie - pole cechy umożliwiające natychmiastowe wysłanie wartości liczbowej po zakończeniu edycji poprzez naciśnięcie klawisza Enter .W przeciwnym przypadku liczba jest wysyłana po naciśnięciu klawisza Szary_+ ewentualnie wykonaniu odpowiedniej akcji.

Teksty puste i złożone z samych spacji są dopuszczalne w polach ograniczeń i są traktowane jako rezygnacja ze sprawdzania.

Opis działania

Dopuszczalne formaty obiektu LICZBA opisane zostały w punkcie Opis formatów, znajdującym się w dalszej części niniejszego rozdziału.

Wystąpienie błędu powoduje dopisanie znaku kontrolnego (domyślnie ? lub !) do liczby lub zastąpienie całej liczby znakami kontrolnymi. Miejsce na znak kontrolny należy uwzględnić przy specyfikowaniu formatu.

Wyspecyfikowany format obowiązuje zarówno dla operacji wejścia (monitorowania) jak i operacji wyjścia (sterowania). W przypadku sterowania wybór automatycznej edycji powoduje, że po wskazaniu obiektu kursorem automatycznie inicjuje się tryb edycyjny. W przeciwnym razie wskazanie kursorem powoduje jedynie zamianę kursora na kursor edycyjny, zaś rozpoczęcie edycji następuje po naciśnięciu klawisza Enter. W polu edycji może się pojawić liczba ostatnio wysłana lub liczba ostatnio wyświetlona (do wyboru). Liczba wprowadzanych znaków jest ograniczona do szerokości pola, jeśli zostało to podane w specyfikacji formatu względnie do 20 znaków w przeciwnym przypadku. Zakończenie edycji klawiszem Enter może powodować natychmiastowe wysłanie liczby, lub wysłanie jej po naciśnięciu klawisza Szary_+ ewentualnie wykonaniu odpowiedniej akcji. W takim przypadku liczba wyświetlana jest w kolorze wskazującym, że wprowadzono ważną wartość oczekującą na wysłanie. Podczas edycji oraz oczekiwania na wysłanie wartość zmiennej pomiarowej nie jest wyświetlana. Klawisz Esc lub prawy klawisz myszy powoduje zaniechanie edycji.

Wyświetlana liczba może zmieniać kolor w sytuacji wystąpienia przekroczeń. Przekroczenia mogą być specyfikowane jako liczby (stałe) lub nazwy zmiennych systemowych. Próba wprowadzenia i wysłania niepoprawnej liczby lub wartości spoza limitów sterowania powoduje wyprowadzenie komunikatu o błędzie. W przypadku, jeśli typ zmiennej systemowej jest niezgodny z typem wyspecyfikowanym przy pomocy formatu dokonywana jest automatyczna konwersja (konwersja taka może powodować błędy - obcięcie części ułamkowej liczby lub nadmiar). Dlatego w zasadzie typ liczby powinien być zgodny z typem zmiennej.

Jeżeli przekroczenia są specyfikowane jako nazwy zmiennych, wówczas można specyfikować warunki logiczne nakładane na zmienne, których spełnienie powoduje zmianę koloru wyświetlania liczby. Warunek logiczny jest ciągiem składającym się z liczby szesnastkowej (warunku) wraz z poprzedzającym go znakiem "&" lub "|". W pierwszym (&) przypadku spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest równy warunkowi, zaś w drugim przypadku (|) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest różny od zera. Innymi słowy w pierwszym przypadku dla zmiany atrybutu liczby wymagane jest, aby wszystkie bity warunku były w danej zmiennej ustawione, zaś w drugim przypadku wystarczające jest, jeżeli co najmniej jeden bit warunku jest jedynką. Znak "|" można pominąć przy specyfikowaniu warunku.

Przykład

Obiekt LICZBA powinien zmienić kolor w przypadku, gdy zawartość zmiennej X będzie miała ustawione bity 20 i 22. W takim przypadku w polu Zakresy-X>> wpisujemy kolejno "X" z dodanym na końcu ciągiem znaków "&5".

Opis formatów

Parametr format musi być zgodny z poniższą składnią:

[%][[0]szerokość][.precyzja][format_daty][format_czasu][l|h]typ

gdzie:

% - opcjonalny początek formatu

typ - sposób formatowania:

d,i - liczba dzisiętna całkowita ze znakiem,

u - liczba dzisiętna całkowita bez znaku,

o - liczba ósemkowa,

x - liczba szesnastkowa używająca małych liter abcdef,

X - liczba szesnastkowa używająca dużych liter ABCDEF,

B - liczba w kodzie BCD,

f,e,g,E,G - liczba zmiennoprzecinkowa,

D - data, dana wejściowa jest traktowana jako ilość sekund od 1970-01-01-00:00, 32 bity;

T - czas, dana wejściowa jest traktowana jako ilość milisekund, 32 bity;

[0]szerokość - minimalna szerokość pola; rozpoczęcie szerokości cyfrą 0 oznacza, że pole ma być w razie konieczności uzupełnione zerami z lewej strony; element używany tylko dla formatów d,i,u,o,x,X,B,f,e,g,E,G;

precyzja - określa ilość cyfr ułamkowych dla formatów f,e,g,E,G;

l|h - dodatkowe określenie typu danej wejściowej: l - 32 bity, h - 16 bitów; element używany tylko dla formatów d,i,u,o,x,X,B;

format daty - używany tylko dla kodu D szczegółowy opis formatowania daty; treścią formatu jest ciąg znaków określających separatory i elementy składowe daty w dowolnej kolejności; elementy składowe to: y -rok, m - miesiąc, d -dzień, h - godzina, n - minuta, s - sekunda; brak określenia formatu daty oznacza formatowanie według wzorca y/m/d h:n:s;

format_czasu - używany tylko dla kodu T szczegółowy opis formatowania czasu; treścią formatu jest ciąg znaków określających separatory i elementy składowe czasu w dowolnej kolejności; Elementy składowe to: d - ilość dni, h - ilość godzin, n - ilość minut, s - ilość sekund, z - ilość milisekund; brak określenia formatu czasu oznacza formatowanie według wzorca h:n:s.

Jeżeli pole d jest użyte, to pole h nigdy nie jest większe niż 23, np. jeśli format "h:n:sT" wyświetla "46:10:00", to format "d h:n:sT" wyświetla "1 22:10:00".

Przed literą T można wstawić literę "l" - oznacza to, że dana wejściowa jest ilością sekund (a nie ilością milisekund).

Zastosowana koncepcja formatów liczb pochodzi z języka programowania C.

Przykład

    • %i - liczba stałoprzecinkowa wyprowadzane wszystkie cyfry znaczące.

    • %7lu - iczba stałoprzecinkowa długa bez znaku wyprowadzana na siedmiu pozycjach.

    • %6.2f - liczba zmiennoprzecinkowa dziesiętna wyprowadzana na sześciu pozycjach z dwoma miejscami po kropce.

    • h:n:s:zT - format zapisu czasu z milisekundami.

    • T - nie ma konieczności wstawiania przed T znaku %.

    • y/m/dD - format daty bez podawania czasu.

    • y-m-dD - format daty w postaci: 2005-11-30.

Parametryzacja z bazy

Obiekt LICZBA posiada cechy umożliwiające ustawienie z bazy zmiennych następujących parametrów:

  • format według typu liczby wyświetlanej np. %f, %i itp.

  • zakres zmienności np. 0, 100 według nazwy zmiennej wyświetlanej,

  • limity, przy których wystąpi zmiana koloru np. nazwy zmiennych Limit, Limit&10 (nazwa zmiennej wraz z maską bitową) według nazwy zmiennej wyświetlanej,

  • zakresy wysyłanych wartości np. 0, 100 według nazwy zmiennej sterowanej,

  • nazwę i maskę danej kontrolnej,

  • dokładność.

W tym celu obiekt liczba został dodatkowo wyposażony w przycisk Łącze, którego naciśnięcie powoduje wpis zawartości danego pola w bazie, poprzedzonego znakiem @ na wszystkich pozycjach, które mogą być potencjalnie ustawione z bazy zmiennych.

W poniższym przykładzie naciśnięcie przycisku Łącze spowodowało wpisanie zawartości pól z bazy dla:

  • limitu maksimum krytyczne - wartość 100

  • limitu maksimum - zmienna o nazwie A02_H

  • limitu minimum - zmienna o nazwie A02_L

  • limitu minimum krytycznego - wartość bitu zmiennej A02_LL, określonego przez maskę (w tym przypadku heksadecymalnie 4).

  • dana kontrolna - zmienna A02?

  • maska danej kontrolnej - 4

  • format liczby.

Rysunek: Okno parametryzacji obiektu LICZBA - parametryzacja z bazy.

Aby pole zostało zapełnione z bazy, musi być ono puste w momencie naciśnięcia przycisku Łącze. Dla zmiennych sterowanej i kontrolnej musi być zaznaczone odpowiednie pole wyboru.


19.4.9. Obiekt LINIA i LINIA PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.10. Obiekt LINIA i LINIA PP

19.4.10. Obiekt LINIA i LINIA PP

Wymiary

Parametry obiektu

Nazwa Obiektu

Szerokość Linii

Typ

Kolor linii

Kolor Przerwy

Przerwa

Rodzaj wzorca

Definicja własnego

Zaokrąglenia końców linii

Obiekt LINIA oraz LINIA PP umożliwiają wyświetlenie na masce odcinka.

Obiekt LINIA PP został wprowadzony dla wygody projektanta i różni się od obiektu LINIA tym, że może przyjmować jedynie postać linii pionowej lub poziomej.

Możliwe jest określenie koloru i grubości kreski.

Wymiary

Współrzędne początku i końca odcinka podaje się przy pomocy myszki

Parametry

Rysunek: Okno parametryzacji obiektu LINIA.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Szerokość Linii - pole liczbowe umożliwiające podanie szerokości linii w pikselach. Dla linii przerywanych dopuszczalne są jedynie szerokości nieparzyste.

Typ-normalna - pole wyboru umożliwiające wybór normalnej (ciągłej) linii.

Typ-przerywana - pole wyboru umożliwiające wybór przerywanej linii.

Typ-normalna w trybie XOR - pole wyboru umożliwiające wybór normalnej (ciągłej) linii rysowanej w trybie XOR (tzn. takiej, której kolor wyznaczany jest jako wynik operacji XOR i tła, na którym jest ona rysowana.

Kolor Linii - pole koloru umożliwiające wybór koloru linii. Po jego wybraniu pojawia się okno wyboru kolorów.

Kolor Przerwy - pole koloru umożliwiające wybór koloru przerwy linii (o ile jest ona przerywana). W przeciwnym razie pole to jest nieaktywne. Po wybraniu tego pola pojawia się okno wyboru kolorów.

Przerwa-w kolorze podanym - pole wyboru umożliwiające wybór trybu rysowania linii przerywanej, w którym przerwa rysowana będzie w kolorze zadeklarowanym.

Przerwa- w kolorze okna - pole wyboru umożliwiające wybór trybu rysowania linii przerywanej, w którym przerwa rysowana będzie w kolorze ustawionym dla okna.

Przerwa-przezroczysta - pole wyboru umożliwiające wybór trybu rysowania linii przerywanej, w którym przerwa będzie przezroczysta.

Rodzaj wzorca - pole wyboru umożliwiające wybór wzorca dla linii przerywanej (do wyboru jest kilka wzorców oraz wzorzec własny deklarowany w polu następnym). Domyślnym wzorcem jest linia ciągła.

Definicja własnego - pole tekstowe umożliwiające wybór własnego wzorca lub też wyświetlenie wzorca standardowego. Wzorzec wyświetlany jest jako liczba szesnastkowa, której kolejne bity odpowiadają kolejnym punktom linii. (Dla linii ciągłej np. wyświetlany jest wzorzec "ffff"). W przypadku wybrania własnego wzorca (wykorzystując opcję Rodzaj wzorca)pole to można edytować.

Zaokrąglenia końców linii - pole cechy umożliwiające zaokrąglanie końców linii. Możliwe tylko w przypadku linii przerywanych.

Kolor linii rysowanej w trybie XOR ustalany jest jako różnica symetryczna zadeklarowanego koloru linii oraz koloru tła. Powoduje to, że linia zawsze będzie widoczna, zaś przechodząc przez różnego koloru tła automatycznie zmieni kolor.


19.4.10. Obiekt LINIE i LINIE PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.11. Obiekt LINIE i LINIE PP

19.4.11. Obiekt LINIE i LINIE PP

Wymiary | Kodowanie
Parametry obiektu | Przykład kodowania
Nazwa Obiektu |
Parametry |
Wysyłanie |
Stan |
Maska bitowa |
Linia |
Migot. |
Kodowanie |
Dana monitorowana |

Obiekty LINIE oraz LINIE PP umożliwiają wyświetlenie na masce linii.

Obiekt LINIE PP został wprowadzony dla wygody projektanta i różni się od obiektu LINIE tym, że może przyjmować jedynie postać linii pionowej lub poziomej.

Wyświetlana linia może zmieniać swój kolor i migotać w zależności od stanu danej monitorowanej. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Opcjonalnie obiekt LINIE może być także obiektem wybieralnym i może służyć do wysyłania określonej zawartości do zmiennej sterowanej. Wysyłanie wartości może być chronione hasłem. Możliwe jest zablokowanie wyświetlania tzw. "ramki selekcji" standardowo pojawiającej się po wybraniu obiektu.

Wymiary

Współrzędne początku i końca odcinka podawane są przy użyciu myszki.

Parametry

Rysunek: Okno parametryzacji obiektu LINIE.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-szerokość linii - pole liczbowe umożliwiające zadeklarowanie szerokości linii.

Parametry-linia w trybie XOR - pole cechy umożliwiające wymuszenie kreślenia linii w trybie XOR. Kolor linii "rysowanej w trybie XOR" ustalany jest jako różnica symetryczna zadeklarowanego koloru linii oraz koloru tła. Powoduje to, że linia zawsze będzie widoczna, zaś przechodząc przez różnego koloru tła automatycznie zmieni kolor.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającej jej linii przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany, w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej linii.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającej jej linii przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej linii.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jedna z wielu zadeklarowanych linii. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi liniami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji liście kolorów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Linia - lista kolorów odpowiadających poszczególnym liniom. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Przerwa - zadeklarowanie koloru dla przerwy pozwoli uzyskać efekt przerywanej linii.

Migot. - otwarcie okienka do parametryzacji atrybutu migotania.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. . Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Kolor linii - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji. Wybranie tego pola powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są zmianą koloru.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany kolorem linii). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych kolorów linii oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji "ze sterowaniem"). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Kodowanie

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa "liczbie stanów", zaś numer najmłodszego bitu określa "przesunięcie". Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z "liczby stanów", zaś numer najmłodszego bitu określa "przesunięcie". Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr "przesunięcie". Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych "ze sterowaniem" możliwe jest użycie opcji "najpierw czytaj". W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery linie np. żółtą, zieloną, niebieską i czerwoną (w tej kolejności) to stanowi "00" będzie odpowiadać linia żółta, stanowi "01" linia zielona itd. W przypadku zapisu, jeśli wybrana zostanie linia czerwona to odpowiadający jej stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający kolorowi wybranej linii.

1000000000100000 / zmienna przeczytana
1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"
----------11---- / bity ustawiane przez obiekt
1000000000110000 / zmienna wysyłana


19.4.11. Obiekt NAPĘD

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.12. Obiekt NAPĘD

19.4.12. Obiekt NAPĘD

Wymiary | Format danej monitorowanej
Parametry obiektu | Format danej sterowanej
Nazwa Obiektu |
Blokada |
Sterowanie |
Czcionka |
Dana monitorowana |
Pole sterowania |

Obiekt NAPĘD umożliwia wyświetlenie stanu napędu na masce oraz sterowanie nim. Zwykle obiekty te grupuje się w tak zwane tabele napędów.

Obiekt NAPĘD jest obiektem historycznym - aktualnie stan napędów ilustrowany jest za pomocą kombinacji takich elementów jak maska i umieszczane na niej obiekty typu: SELEKTOR, OBRAZKI, TEKSTY, PRZYCISK.

Obiekt przystosowany do współpracy ze słowem wejściowym i wyjściowym o odpowiednim formacie (narzuconym przez oprogramowanie sterownika - patrz: opis pod koniec rozdziału).

Jest to obiekt dynamiczny i wybieralny. Stan napędu wyświetlany jest przy pomocy trzech okienek współpracujących z przyciskami oraz czwartego okienka służącego do sygnalizacji awarii elektrycznej oraz wyłączenia technologicznego. Pozostałe trzy okienka służą do wyboru miejsca, trybu oraz rodzaju sterowania. Wysyłanie sterowania może być chronione hasłem.

Rysunek: Przykład obiektu NAPĘD.

Wymiary

Wymiary obiektu NAPĘD są określone na sztywno i nie mogą być zmienione.

Parametry

Rysunek: Okno parametryzacji obiektu NAPĘD.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Blokada-lokalne/zdalne - pole cechy umożliwiające zablokowanie możliwości przełączania trybu lokalnego na zdalny i odwrotnie przy pomocy przedstawionej stacyjki napędowej.

Blokada-AUT - pole cechy umożliwiające zablokowanie możliwości przełączania w tryb sterowania automatycznego AUT przy pomocy przedstawionej stacyjki napędowej.

Blokada-MAN - pole cechy umożliwiające zablokowanie możliwości przełączania w tryb sterowania ręcznego MAN przy pomocy przedstawionej stacyjki napędowej.

Blokada-REM - pole cechy umożliwiające zablokowanie możliwości przełączania w tryb remontowy REM przy pomocy przedstawionej stacyjki napędowej.

Blokada-WYŁ/ZAŁ - pole cechy umożliwiające zablokowanie możliwości wyłączania i załączania napędu przy pomocy przedstawionej stacyjki napędowej.

Sterowanie-lokalne - pole tekstowe umożliwiające zadeklarowanie skrótu opisującego sterowanie w trybie lokalnym. Domyślnie "L".

Sterowanie-zdalne - pole tekstowe umożliwiające zadeklarowanie skrótu opisującego sterowanie w trybie zdalnym. Domyślnie "Z".

Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą mają zostać wyświetlona napisy w obiekcie NAPĘD.

Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki. Ze względu na sztywne wymiary obiektu przy wyborze należy ograniczyć się jedynie do małych czcionek (Dialog, Small itd.).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. . Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Błędy - pole cechy umożliwiające sygnalizację błędów komunikacyjnych oraz współpracujące z nim pole koloru (obiekt zmienia kolor ramki). Opcja domyślna.

Pole sterowania-WYŁ/ZAŁ - pole wyboru umożliwiające wyświetlanie w odpowiednim polu obiektu tylko napisów "WYŁ" lub "ZAŁ" (np. dla silników).

Pole sterowania -WYŁ/OTW/ZAM - pole wyboru umożliwiające wyświetlanie w odpowiednim polu obiektu tylko napisów "WYŁ", "OTW" lub "ZAM" (np. dla zasuw).

Pole sterowania -WYŁ/ZAŁ+/ZAŁ - pole wyboru umożliwiające wyświetlanie w odpowiednim polu obiektu tylko napisów "WYŁ", "ZAŁ+" lub "ZAŁ-" (np. dla napędów dwukierunkowych).

Wszystkie kolory występujące w obiekcie są predefiniowane. Stany pracy napędu są wyświetlane w polach koloru ciemnoszarego (wyjątkiem jest stan remontowy wyświetlany w polu czerwonym). Stany wyselekcjonowane wyświetlane są na tle niebieskim. Stany zablokowane wyświetlane są na tle fioletowym. Obiekt posiada czarną ramkę, która w przypadku błędu może zmienić kolor. Ramka zmienia też kolor sygnalizując selekcję. Należy jako kolor sygnalizacji błędu wybierać inny kolor aniżeli kolor ramki i kolor selekcji.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy wybierając kursorem myszy odpowiednie przyciski wybrać żądany stan napędu. Jego wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy. Wyboru stanu można też dokonać naciskając (wielokrotnie) klawisz Enter.

Format danej monitorowanej

  • bit 0 - stan wyłączony/zamknięty

  • bit 1 - stan załączony/załączony+/otwarty

  • bit 2 - stan załączony-

  • bit 3 - wyłączenie technologiczne

  • bit 4 - awaria elektryczna

  • bit 5 - tryb remontowy REM

  • bit 6 - tryb ręczny MAN

  • bit 7 - tryb automatyczny AUT

  • bit 13 - 0 sterowanie zdalne 1 sterowanie lokalne

Format danej sterowanej

  • bit 0 - impuls wyłączenia/zamknięcia

  • bit 1 - impuls załączenia/załączenia+/otwarcia

  • bit 2 - impuls załączenia-

  • bit 3 - wybór sterowania zdalnego

  • bit 4 - wybór sterowania lokalnego

  • bit 5 - włączenie trybu remontowego REM

  • bit 6 - włączenie trybu ręcznego MAN

  • bit 7 - włączenie trybu automatycznego AUT

Najmłodszy bit jest bitem o numerze 0.


19.4.12. Obiekt_NAPIS

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.13. Obiekt_NAPIS

19.4.13. Obiekt NAPIS

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Parametry |
Edycja |
Wyrównanie |
Dana monitorowana |

Obiekt NAPIS umożliwia wyświetlenie na masce ciągu (tablicy) znaków czyli tekstu. Tekst powinien być wpisany do zmiennej Asmena (może pochodzić ze sterownika). Obiekt NAPIS sparametryzowany ze sterowaniem może zostać użyty do wysyłania ciągu znaków do zmiennej Asmena (i dalej do sterownika). Obiekt ten współpracuje ze specjalnie przygotowaną funkcją przeliczającą NIC_TEXT. Zwykle obiekt ten współpracuje ze zmiennymi, którym nie przypisano fizycznych kanałów transmisji, a jedynie kanał wirtualny (protokół NONE). Używany jest wtedy do wyświetlania i ustawiania pól bazy danych o charakterze tekstowym. Wysyłanie sterowania może być chronione hasłem.

Na masce obiekt niczym nie różni się od innych obiektów typu TEKST lub TEKSTY.

Rysunek: Przykład obiektu NAPIS.

Wymiary

Wymiary obiektu NAPIS są określone na podstawie podanej maksymalnej długości łańcucha oraz zastosowanej czcionki. Tak określony obszar jest obszarem minimalnym i może zostać powiększony przy pomocy myszy. Próba zmniejszenia obiektu poniżej wymiarów minimalnych jest nieskuteczna.

Maksymalna długość tekstu zadeklarowana w obiekcie NAPIS powinna być zgodna z odpowiednim parametrem funkcji przeliczającej NIC_TEXT.

W przypadku sterowania wybór automatycznej edycji powoduje, że po wskazaniu obiektu kursorem automatycznie inicjuje się tryb edycyjny. W przeciwnym razie wskazanie kursorem powoduje jedynie zamianę kursora na kursor edycyjny, zaś rozpoczęcie edycji następuje po naciśnięciu klawisza Enter. W polu edycji może się pojawić tekst ostatnio wysłany lub tekst ostatnio wyświetlony (do wyboru). Zakończenie edycji klawiszem Enter może powodować natychmiastowe wysłanie tekstu, lub wysłanie go po naciśnięciu klawisza Szary_+ ewentualnie wykonaniu odpowiedniej akcji. W takim przypadku tekst wyświetlany jest w kolorze wskazującym, że wprowadzono ważną wartość oczekującą na wysłanie. Podczas edycji oraz oczekiwania na wysłanie wartość tekstowa zmiennej monitorowanej nie jest wyświetlana. Próba wprowadzenia i wysłania niepoprawnego (zbyt długiego) tekstu skutkuje niemożnością wprowadzenia (jeżeli chcemy wprowadzić dłuższy tekst, niż na to pozwala parametr "długość") lub jego obcięciem (jeżeli długość wysłanego tekstu jest większa, niż to dopuszcza odpowiedni parametr funkcji przeliczającej).

Parametry

Rysunek: Okno parametryzacji obiektu NAPIS.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-Czcionka m - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony napis. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Parametry-Czcionka s - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony napis podczas edycji i wysyłania wartości. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Parametry = - pola koloru umożliwiające ustawienie koloru napisu (pole lewe) oraz tła (pole prawe) wyświetlanego tekstu.

Parametry-? - pola koloru umożliwiające ustawienie koloru napisu (pole lewe) oraz tła (pole prawe) wyświetlanego tekstu w przypadku wystąpienia błędu komunikacji.

Parametry-^ - pola koloru umożliwiające ustawienie koloru napisu (pole lewe) oraz tła (pole prawe) wyświetlanego tekstu podczas jego edycji.

Parametry--> - pola koloru umożliwiające ustawienie koloru napisu (pole lewe) oraz tła (pole prawe) wyświetlanego tekstu po jego edycji a przed wysłaniem w trybie z potwierdzeniem.

Parametry-Tło koloru okna - pole cechy umożliwiające ustawienie koloru tła zgodnego z kolorem okna.

Parametry-Tło przezroczyste - pole cechy umożliwiające ustawienie tła przezroczystego.

Edycja-Autom. Edycja - pole cechy umożliwiające edycję napisu bezpośrednio po wyselekcjonowaniu (kliknięciu). W przeciwnym razie, aby rozpocząć edycję należy wyselekcjonować obiekt po czym przycisnąć klawisz Enter.

Edycja -Inicjacja poprzednią - pole cechy umożliwiające inicjację pola napisu przed edycją poprzednio wprowadzonym tekstem.

Edycja -Inicjacja bieżącą - pole cechy umożliwiające inicjację pola napisu przed edycją bieżąco wyświetlanym tekstem.

Edycja -Autom. wysłanie - pole cechy umożliwiające natychmiastowe wysłanie tekstu (tablicy znaków) po zakończeniu edycji poprzez naciśnięcie klawisza Enter .W przeciwnym przypadku tekst jest wysyłany po naciśnięciu klawisza Szary_+ ewentualnie wykonaniu odpowiedniej akcji.

Wyrównanie-Do Lewej - pole wyboru wymuszające wyrównanie napisu w obszarze obiektu do lewej.

Wyrównanie-Środkowanie - pole wyboru wymuszające środkowanie napisu w obszarze obiektu.

Wyrównanie-Do Prawej - pole wyboru wymuszające wyrównanie napisu w obszarze obiektu do prawej.

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku do tekstu zostanie dopisany znak umieszczony w polu Znak kontrolny (domyślnie "?").Opcja domyślna.

Znak kontrolny - pole tekstowe umożliwiające zadeklarowanie znaku. Wystąpienie błędu komunikacyjnego powoduje dopisanie tego znaku do tekstu.

Długość - pole liczbowe określające maksymalną długość tekstu stanowiącego napis. Domyślnie pole to jest ustawione na 20. Należy pamiętać o skorelowaniu tej wielkości z odpowiednim parametrem funkcji przeliczającej NIC_TEXT.

Parametryzacja z bazy

Obiekt NAPIS posiada cechy umożliwiające ustawienie z bazy zmiennych długości zmiennej tekstowej. Obiekt ten posiada przycisk Łącze, którego naciśnięcie powoduje wpis znaków "@ liczba" do pola Długość, gdzie liczba jest zawartością pola bazy LiczbaElementów. Przycisk Łącze działa pod warunkiem, że pole Długość jest puste.


19.4.13. Obiekt OBRAZEK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.14. Obiekt OBRAZEK

19.4.14. Obiekt OBRAZEK

Wymiary

Parametry

Obiekt OBRAZEK umożliwia wyświetlenie na masce mapy bitowej. Jest to obiekt statyczny.

Rysunek: Przykład zastosowania obiektów typu OBRAZEK.

Wymiary

Wymiary obiektu OBRAZEK są określone na sztywno (na podstawie wymiarów mapy bitowej/grafiki z pliku graficznego) i nie mogą być zmienione.

Parametry

Rysunek: Okno parametryzacji obiektu OBRAZEK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Nazwa Obrazka - pole tekstowe służące do wpisania nazwy pliku graficznego lub mapy bitowej. Nazwę można wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór plików umieszczonych w katalogu zadeklarowanym dla projektowanej aplikacji lub map bitowych należących do puli map systemu Asix.

Dopasuj rozmiar do obrazka - opcja służąca do załączania lub wyłączania mechanizmu skalowania obiektu. Załączenie skalowania wymaga wyłączenia domyślnie ustawionej opcji - od tego momentu można dowolnie zmieniać rozmiar obiektu. W przypadku masek skalowalnych po wyłączeniu opcji Dopasuj rozmiar do obrazka obiekt będzie automatycznie zmieniał rozmiar w zależności od rozmiaru maski.

Zewnętrzne pliki graficzne należy umieszczać w zadeklarowanych katalogach masek (patrz: 9.8. Użycie map bitowych).

Mapy bitowe mogą być tworzone oraz importowane przy pomocy wbudowanego w system Asix edytora map bitowych. Jest on dostępny za pośrednictwem menu NARZĘDZIA w oknie konstruktora.

Rysunek: Okno wyboru mapy bitowej.


19.4.14. Obiekt OBRAZKI

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.15. Obiekt OBRAZKI

19.4.15. Obiekt OBRAZKI

Wymiary | Strategie kodowania
Parametry obiektu | Przykład kodowania
Nazwa Obiektu |
Lista obrazków |
Kodowanie |
Wysyłanie |
Maska bitowa |
Stan |
Dana monitorowana |

Obiekt OBRAZKI umożliwia wyświetlenie na masce jednej z wielu (do 17) wyspecyfikowanych map bitowych. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Wybrany do wyświetlenia obrazek zależy od wartości zmiennej monitorowanej. Opcjonalnie obiekt OBRAZKI może być także obiektem wybieralnym i może służyć do wysyłania określonej zawartości do zmiennej sterującej. Wysyłanie wartości może być chronione hasłem.

Poniższe rysunki prezentują przykładowe obiekty typu OBRAZKI.

Rysunek: Przykłady obiektu OBRAZKI.

Wymiary

Wymiary obiektu OBRAZKI są automatycznie dopasowywane do rozmiarów map bitowych.

Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając w polu nazwy mapy bitowej prawy klawisz myszy. Pojawia się wtedy okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix. Nazwę mapy bitowej wpisuje się do listy pokazując odpowiednie miejsce kursorem myszy. Wskazanie nazwy mapy bitowej na liście powoduje jej wyświetlenie w specjalnym polu okna dialogowego (poniżej pola Nazwa Obiektu) (patrz: poniżej).

Parametry

Rysunek: Okno parametryzacji obiektu OBRAZKI.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Lista obrazków - lista nazw obrazków (bitmap) odpowiadających poszczególnym stanom obiektu. Zmiany nazwy obrazka można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie wpisaniu w polu poniżej listy nowej nazwy i naciśnięciu klawisza Enter. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix. Próba zadeklarowania nazwy obrazka dla nieistniejącego stanu jest nieskuteczna.

Obiekt OBRAZKI pozwala na podanie nazw dwóch map bitowych dla każdego stanu. Jeżeli projektant poda dla wybranego stanu dwie nazwy, to obiekt w tym stanie będzie naprzemiennie wyświetlał obie zadeklarowane mapy bitowe. Nazwy map bitowych wprowadza się w dwóch polach edycyjnych położonych poniżej listy obrazków. Podanie nazwy mapy w lewym polu powoduje włączenie migotania. W liście obrazków, nazwy map bitowych dla sanów z migotaniem są oddzielone znakiem '/’.

Istnieje też możliwość zadeklarowania dla danego stanu jednej mapy bitowej dla uzyskania efektu migotania pojedynczą bitmapą. W takim przypadku jako nazwę mapy alternatywnej należy podać nazwę składającą się z samych znaków '-'.

Częstotliwość migotania jest stała i określana parametrem Okres migotania, ustawianym za pomocą programu Architekt (Architekt > Obszary i komputery > moduł Maski > zakładka Pozostałe).

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiedniej bitmapy przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany, w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej bitmapie (obrazkowi).

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiedniej bitmapy przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej bitmapie (obrazkowi).

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych obrazków. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi obrazkami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji Liście obrazków.

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony lub zamiast niego wyświetlona zostanie inna bitmapa). Opcja domyślna.

Linia - pole koloru linii przekreślającej obiekt, w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru. Zobacz też opis pola Obrazek.

Obrazek - pole tekstowe umożliwiające podanie nazwy bitmapy (obrazka), która ma się wyświetlić w przypadku wystąpienia błędu komunikacji. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix. Jeśli pole to pozostaje puste, wówczas w momencie wystąpienia błędu komunikacji nastąpi jedynie przekreślenie obiektu przy pomocy linii, której atrybuty zostają określone przy pomocy pola Linia. Jeśli pole to jest niepuste, wówczas zamiast linii wyświetlony zostanie wyspecyfikowany obrazek.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Dopasuj rozmiar do obrazków - opcja służąca do załączania lub wyłączania mechanizmu skalowania obiektu. Załączenie skalowania wymaga wyłączenia domyślnie ustawionej opcji - od tego momentu można dowolnie zmieniać rozmiar obiektu. W przypadku masek skalowalnych po wyłączeniu opcji Dopasuj rozmiar do obrazka obiekt będzie automatycznie zmieniał rozmiar w zależności od rozmiaru maski.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany zmianą obrazka). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych obrazków oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji ze sterowaniem). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Kodowanie

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie naturalne. Na zakodowanie czterech naturalnych stanów (000,001,010,100) potrzebna jest trzy-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 0 wtedy stan jedynie trzech pierwszych bitów wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

-------------xxx

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery obrazki np. "1","2", "3" i "4" (w tej kolejności) to stanowi "000" będzie odpowiadać obrazek "1", stanowi "001" obrazek "2" itd. W przypadku zapisu, jeśli wybrana zostanie obrazek "4" to odpowiadający mu stan czyli "100" na najmłodszych bitach czyli dziesiętnie liczba 4 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowana będzie grupa trzech najmłodszych bitów po czym na bity te zostanie wpisany stan odpowiadający numerowi wybranego obrazka.

1000000000100001 / zmienna przeczytana

1000000000100--- / zmienna przeczytana z wyzerowanymi bitami "-"

-------------100 / bity ustawiane przez obiekt

1000000000100100 / zmienna wysyłana


19.4.15. Obiekt PREZENTER

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.16. Obiekt PREZENTER

19.4.16. Obiekt PREZENTER

Wymiary

Parametry obiektu

Nazwa Obiektu

Mapa bitowa

Tryb otwarcia

Odświeżanie obiektów

Nazwa Maski

Obiekt PREZENTER służy do wskazania określonego obiektu (zwanego dalej obiektem wskazywanym) w sytuacji spełnienia pewnego warunku. Warunkiem tym dla obiektu PREZENTER jest fakt wyświetlenia wyspecyfikowanej maski. W praktyce konieczność użycia tego obiektu występuje w warunkach sterowania dużą ilością urządzeń (np. napędów lub zaworów), umieszczonych na jednej masce schematowej. Zazwyczaj problem wysyłania sterowań rozwiązuje się nakładając na obiekt wyświetlający stan danego urządzenia obiekt typu przycisk przezroczysty wykonujący akcję polegającą na wyświetleniu pewnej specjalizowanej maski zwanej stacyjką, z której możliwe jest wysyłanie sterowań tego urządzenia. Jeżeli takich urządzeń na masce jest bardzo wiele, wówczas nie wiadomo na pierwszy rzut oka, z którym urządzeniem współpracuje dana stacyjka. Trudność potęguje fakt, że na ogół stacyjki są bardzo podobne i mogą różnić się jedynie nazwą sterowanego urządzenia. W takim przypadku przydatny jest obiekt PREZENTER, który potrafi wyświetlić się w pobliżu określonego obiektu.

W prezentowanym przykładzie rolę obiektu wskazywanego pełni obiekt typu OBRAZKI, wyświetlający stany zaworu. Na tym obiekcie nałożony jest przezroczysty obiekt typu przycisk wykonujący akcję typu OTWÓRZ_MASKĘ. Jeżeli operator wykona "kliknięcie" myszką w rejonie zaworu, wówczas określona maska ze stacyjką zostanie wyświetlona. To z kolei powoduje wyświetlenie przez obiekt typu PREZENTER wykrzyknika wskazującej zawór. Zamknięcie maski ze stacyjką usuwa obiekt PREZENTER.

Rysunek: Przykład obiektu PREZENTER.

Wymiary

Wymiary obiektu PREZENTER są określone na sztywno (na podstawie wymiarów mapy bitowej) i nie mogą być zmienione.

Obiekt PREZENTER wyświetla się po wyświetleniu określonej maski. Nazwę tej maski należy podać w oknie do parametryzacji obiektu. PREZENTER może się wyświetlić, jeśli maska jest jedynie otwarta, lub też pod warunkiem, że maska jest otwarta i jednocześnie bieżąca.

Maska otwarta może zostać przesłonięta przez inną maskę i być niewidoczna. Maska bieżąca jest maską otwartą, która została ostatnio wyselekcjonowana. Maska bieżąca jest zawsze widoczna. Jeśli maska bieżąca pełni rolę stacyjki, wówczas dopóki jest maską bieżącą, dopóty można wysyłać z niej sterowania.

Usuwanie obiektu PREZENTER polega na wyświetleniu w miejscu starego obiektu mapy bitowej w kolorze tła. Jeżeli obiekt PREZENTER przesłaniał całkowicie lub częściowo inny obiekt, wówczas usuwając się powinien spowodować odrysowanie obiektu, który zasłaniał. Czynność ta jest uwarunkowana zawartością pola odświeżanie obiektów.

Parametry

Rysunek: Okno parametryzacji obiektu PREZENTER.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Nazwa Maski - pole tekstowe służące do wpisania nazwy maski, której otwarcie (i ewentualne wyselekcjonowanie) powinno spowodować zadziałanie obiektu PREZENTER. Nazwa maski może zawierać znaki "?" i "*" zastępujące odpowiednio pojedynczy znak lub ich ciąg.

Mapa bitowa-bieżąca - pole tekstowe umożliwiające podanie nazwy bitmapy (obrazka), która ma się wyświetlić w przypadku otwarcia maski o podanej nazwie oraz wyselekcjonowania jej, tak aby stała się maską bieżącą. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Mapa bitowa-otwarta - pole tekstowe umożliwiające podanie nazwy bitmapy (obrazka), która ma się wyświetlić w przypadku otwarcia maski o podanej nazwie. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Mapa bitowa-tło - pole tekstowe umożliwiające podanie nazwy bitmapy (obrazka), która ma się wyświetlić jako tło usuwające poprzednio wrysowaną bitmapę. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Tryb otwarcia-maska bieżąca - pole wyboru umożliwiające wyświetlenie mapy bitowej, której nazwa podana została w polu Mapa bitowa-bieżąca, jeśli zostanie otwarta i wyselekcjonowana maska, której nazwa podana została w polu Nazwa Maski.

Tryb otwarcia-maska otwarta - pole wyboru umożliwiające wyświetlenie mapy bitowej, której nazwa podana została w polu Mapa bitowa-otwarta, jeśli zostanie otwarta maska, której nazwa podana została w polu Nazwa Maski.

Odświeżanie obiektów - pole cechy umożliwiające wymuszenie odrysowania obiektów, które obiekt PREZENTER przesłaniał. Odrysowanie następuje przed wyświetleniem bitmapy o nazwie Mapa bitowa-tło.


19.4.16. Obiekt PROSTOKĄT

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.17. Obiekt PROSTOKĄT

19.4.17. Obiekt PROSTOKĄT

Wymiary

Parametry obiektu

Obiekt PROSTOKĄT umożliwia wyświetlenie na masce prostokąta. Jest to obiekt statyczny. Możliwe jest określenie dla niego wymiarów i kolorów. Można narysować kwadrat jako szczególny przypadek prostokąta.

Rysunek: Przykład obiektu PROSTOKĄT.

Wymiary

Wysokość i szerokość podaje się przy pomocy myszki.

Prostokąt może być kreślony z zastosowaniem efektu cieniowania. Decyduje o tym efekcie wartość parametru głębokość. Możliwe jest indywidualne ustalenie koloru podświetlenia (lewa strona i góra prostokąta) oraz koloru cienia (prawa strona i dół). Jeżeli jako podświetlenie zostaną wybrane jasne kolory, zaś jako cień kolory ciemne, wówczas otrzymamy efekt wypukłości. Jeżeli jako podświetlenie wybrane zostaną kolory ciemne, zaś jako cień kolory jasne, wtedy uzyskany zostanie efekt wklęsłości. Dodatkowo można opcjonalnie wrysować ramkę (z zaokrąglonymi rogami) oraz narysować naroża w odpowiednim kolorze. Daje to możliwość rysowania "trójwymiarowych" prostokątów stanowiących tło dla innych obiektów. Prostokąt bez cieniowania można uzyskać, jeżeli wartość głębokości wynosi zero.

Parametry

Rysunek: Okno parametryzacji obiektu PROSTOKĄT.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolor linii - pole koloru umożliwiające ustawienie koloru linii otaczającej prostokąt po wywołaniu okna wyboru koloru.

Kolor Wypełnienia - pole koloru umożliwiające ustawienie koloru wnętrza prostokąta po wywołaniu okna wyboru koloru.

Cień - pola kolorów umożliwiające ustawienie kolorów cienia otaczającego prostokąt (jeśli parametr głębokość jest niezerowy). Ustawia się odpowiednio kolor cienia strona lewa-góra oraz kolor cienia dół-strona prawa. Dobierając odpowiednio kolory można wtedy uzyskać efekt wklęsłości lub wypukłości. Kolory są wybierane po wywołaniu okna wyboru koloru.

Szerokość linii - pole liczbowe umożliwiające ustawienie grubości linii otaczającej prostokąt (domyślnie 1).

Głębokość - pole liczbowe umożliwiające określenie czy ma być rysowany prostokąt z efektem głębokości (jeśli wartość jest niezerowa) czy nie (domyślnie 0). Wartość tego pola decyduje o szerokości pola cienia.

Naroża-góra - zestaw składający się z dwóch pól cechy oraz dwóch pól koloru określający parametry górnego lewego i górnego prawego naroża. Pole cechy określa, czy dane naroże rysować, natomiast pole koloru określa w jakim kolorze powinno być ono wykreślone.

Naroża-dół - zestaw składający się z dwóch pól cechy oraz dwóch pól koloru określający parametry dolnego lewego i dolnego prawego naroża. Pole cechy określa, czy dane naroże rysować, natomiast pole koloru określa w jakim kolorze powinno być ono wykreślone.

Wypełnić wnętrze - pole cechy umożliwiające wypełnienie wnętrza prostokąta.

Wypełnienie w kolorze okna - pole cechy umożliwiające wymuszenie rysowania wnętrza prostokąta w kolorze tła ustawionym dla maski.

Rysować kwadrat - pole cechy umożliwiające wymuszenie rysowania kwadratu.

Rysować ramkę - pole cechy umożliwiające wymuszenie rysowania ramki (dla prostokątów z cieniowaniem).

Kolor ramki - pole koloru umożliwiające zadeklarowanie koloru ramki po wywołaniu okna wyboru koloru.


19.4.17. Obiekt PROSTOKĄTY

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.18. Obiekt PROSTOKĄTY

19.4.18. Obiekt PROSTOKĄTY

Wymiary | Sposoby kodowania
Parametry obiektu | Przykład kodowania
Nazwa Obiektu |
Parametry |
Wysyłanie |
Stan |
Linia |
Tło |
Migot |
Kodowanie |
Dana monitorowana |
Maska bitowa |

Obiekt PROSTOKĄTY stanowi odmianę obiektu PROSTOKĄT umożliwiającą zmianę kolorów i migotanie narysowanego prostokąta w zależności od stanu danej monitorowanej. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Opcjonalnie obiekt PROSTOKĄTY może być także obiektem wybieralnym i może służyć do wysyłania określonej zawartości do zmiennej sterowanej. Wysyłanie wartości może być chronione hasłem.

Wymiary

Wymiary prostokąta podaje się przy pomocy myszki.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są zmianą koloru.

Parametry

Rysunek: Okno parametryzacji obiektu PROSTOKĄTY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-Wypełnić Wnętrze - pole cechy umożliwiające wypełnienie wnętrza prostokąta w zadeklarowanym kolorze.

Parametry-w Kolorze Okna - pole cechy umożliwiające wypełnienie wnętrza prostokąta w kolorze ustawionym dla okna bez względu na zadeklarowany kolor wnętrza.

Parametry-Rysować kwadrat - pole cechy umożliwiające wymuszenie rysowania kwadratu.

Przezroczystość - zadeklarowanie koloru przezroczystości pozwala uzyskać efekt przezroczystości.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającego jej prostokąta przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany, w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu prostokątowi.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającego jej prostokąta przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu prostokątowi.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych prostokątów. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi prostokątami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji jednej z dwu list kolorów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Linia - lista kolorów odpowiadających otoczkom poszczególnych prostokątów. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Tło - lista kolorów odpowiadających wnętrzom poszczególnych prostokątów. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Migot. - otwarcie okienka do parametryzacji atrybutu migotania.

Szerokość linii - pole liczbowe umożliwiające określenie szerokości linii (obwódki) otaczającej prostokąt (domyślnie 1).

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką, dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Kolor linii - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji. Wybranie tego pola powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany kolorem linii obwiedni oraz wnętrza). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych kolorów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji ze sterowaniem). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Sposoby kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery prostokąty np. żółty, zielony, niebieski i czerwony (w tej kolejności) to stanowi "00" będzie odpowiadać prostokąt żółty, stanowi "01" prostokąt zielony itd. W przypadku zapisu, jeśli wybrana zostanie prostokąt czerwony to odpowiadający mu stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej – najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający kolorowi wybranego prostokąta.

1000000000100000 / zmienna przeczytana

1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"

----------11---- / bity ustawiane przez obiekt

1000000000110000 / zmienna wysyłana


19.4.18. Obiekt PRZELICZNIK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.19. Obiekt PRZELICZNIK

19.4.19. Obiekt PRZELICZNIK

Wymiary | Format danej statusowej
Parametry obiektu |
Nazwa Obiektu |
Czasy |
Limity |
Dana wynikowa |
Obliczenie |

Obiekt PRZELICZNIK umożliwia wartościowanie ciągu wyrażeń języka ASTEL. Obiekt ten w czasie odświeżania maski pozostaje niewidoczny. Obiekt dokonuje wartościowania ciągu wyrażeń języka ASTEL i zapisuje wynik w wyspecyfikowanej zmiennej systemowej. Obiekt ten zasadniczo powinien dokonywać przeliczeń dla innych obiektów umieszczonych na tej samej masce. W opisanym przypadku wartościowanie odbywa się cyklicznie. Obiekt ten może także dokonywać obliczeń na żądanie operatora (naciśnięcie przycisku z nałożonym obiektem typu PRZELICZNIK sparametryzowanym "na żądanie").

Wymiary

Wymiary obiektu PRZELICZNIK są nieistotne (obiekt niewidzialny). W trybie edycyjnym pojawia się on na ekranie jako ramka (podobnie jak obiekty typu PRZYCISK przezroczysty).

Parametry

Rysunek: Okno parametryzacji obiektu PRZELICZNIK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Pola nieopisane - pole tekstowe umożliwiające wpisanie programu w języku ASTEL (główne pole pod nazwą obiektu) oraz wyświetlenie wyników wartościowania (pole z prawej), a także wyświetlenie komunikatów diagnostycznych (pole poniżej). W głównym polu można wpisać wiele kolejnych linii zawierających wyrażenia. Kliknięcie prawym klawiszem w tym polu powoduje otwarcie okna generacji wyrażeń, które pozwala na generację wyrażeń użytkownikowi nie znającemu składni języka.

Rysunek: Okno generatora wyrażeń.

Czasy-cykl - pole liczbowe oraz pole wyboru umożliwiające określenie cyklu odświeżania obiektu przez podanie liczby kwantów oraz jednostki. Ważne dla cyklicznego trybu pracy.

Czasy-okres - pole liczbowe oraz pole wyboru umożliwiające określenie domyślnego okresu czasu, (w archiwum) do którego odnoszą się wyrażenia wartościowane przez obiekt. Jeżeli w wyrażeniach nie występują odwołania do danych archiwalnych lub też nie korzystają z domyślnego okresu, wówczas zawartość tych pól jest bez znaczenia.

Limity-od - pole liczbowe umożliwiające podanie dolnego limitu wartości dla zmiennej wynikowej (domyślnie 0). Jeśli w wyniku wartościowania powstanie wartość mniejsza, wówczas zostanie zastąpiona dolnym limitem.

Limity-do - pole liczbowe umożliwiające podanie górnego limitu wartości dla zmiennej wynikowej (domyślnie 100). Jeśli w wyniku wartościowania powstanie wartość większa, wówczas zostanie zastąpiona górnym limitem.

Dana wynikowa - pole tekstowe umożliwiające podanie nazwy danej wynikowej (do której wpisany zostanie wynik wartościowania). Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Wyślij po zmianie - pole cechy umożliwiające wykonanie zapisu wyniku do zmiennej wynikowej tylko wtedy, jeśli uległ on zmianie (od ostatniego wartościowania).

Wyślij jeśli poprawny - uzależnia wysłanie wyniku zadeklarowanych obliczeń do Danej wynikowej od statusu tychże. Status jest porównywany z zadanym. Jeśli status obliczeń jest zgodny z zadanym, to wynik jest przepisywany do Danej wynikowej.

Maska popr. - deklaracja maski poprawności porównywanej ze statusem obliczeń. Równość statusu obliczeń i Maski poprawności jest warunkiem przepisania wyniku do Danej wynikowej.

Dana statusowa - pole tekstowe umożliwiające podanie nazwy danej statusowej (do której wpisany zostanie status wartościowania). Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez statusu. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej statusowej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez statusu - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby nie zapisywać zmiennej statusowej.

Dana synchronizująca - pole tekstowe umożliwiające podanie nazwy danej synchronizującej (niezbędnej dla trybu pracy z synchronizacją). Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej statusowej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Maska synch. - pole liczbowe umożliwiające wpisanie szesnastkowej maski, której niezerowy iloczyn z daną synchronizującą powoduje rozpoczęcie wartościowania wyrażenia.

Obliczenie-Cyklicznie - pole wyboru umożliwiające wymuszenie cyklicznego wartościowania wyrażenia przez obiekt.

Obliczenie-Na Żądanie - pole wyboru umożliwiające wymuszenie wartościowania na żądanie operatora (kliknięcie w polu obiektu).

Obliczenie-Z synchronizacją - pole wyboru umożliwiające wymuszenie wartościowania w przypadku, gdy określone polem Maska bity Danej synchronizującej są ustawione.

W przypadku obliczania z synchronizacją wartościowanie powinno zostać wymuszone przez ustawienie odpowiednie danej synchronizującej. W przypadku wartościowania cyklicznego można określić czas trwania cyklu. Użyteczną cechą obiektu jest możliwość wpisywania nowej wartości do zmiennej (oraz opcjonalnego wysyłania do sterownika) tylko wtedy, jeśli uległa ona zmianie (pole "wyślij po zmianie). Wyliczane wartości mogą być ograniczone do przedziału wyznaczonego wartościami dolnego oraz górnego limitu. Dodatkowo należy wyspecyfikować okres czasu, dla którego wartościowane będą ewaluatory języka ASTEL (np. podanie okresu 10 minutowego oznacza, że ewaluator średniej będzie obliczał średnią wartość danej zmiennej dla okresu ostatnich 10 minut przed rozpoczęciem wartościowania). Jeśli ciąg wyrażeń nie zawiera ewaluatorów, lub zawierają one podany jako parametr okres, wówczas podany podczas parametryzacji okres jest nieistotny.

Wyrażenie języka ASTEL powinno zostać wpisane w polu wyrażeń umieszczonym pod nazwą obiektu. Po wpisaniu każdego wyrażenia można sprawdzić jego poprawność wykonując "kliknięcie" w polu diagnostycznym umieszczonym poniżej pola wyrażeń. Jeżeli wyrażenie jest niepoprawne, wówczas w polu diagnostycznym pojawi się informacja o błędzie wraz z linią zawierającą błąd. W linii tej element leksykalny powodujący błąd zostanie poprzedzony znakiem zapytania (?). "Kliknięcie" w polu wynikowym umieszczonym na prawo od pola wyrażeń powoduje wartościowanie kolejnych wyrażeń i wpisanie w polu wynikowym rezultatów. Wystąpienie błędu powoduje komunikat w polu diagnostycznym.

Wartościowane wyrażenie powinno być tak dobrane, aby czas jego wartościowania wynosił maksymalnie kilka-kilkanaście sekund. W przeciwnym razie wydajność sytemu obciążonego dużą liczbą czasochłonnych obliczeniowo obiektów PRZELICZNIK spada. Można to zjawisko (powodujące w konsekwencji tzw. przeciążenie - czyli sytuację, w której PRZELICZNIK mimo, iż nie zakończył ostatniego wartościowania zostaje pobudzony ponownie) minimalizować dobierając odpowiednio długie cykle wartościowania dla obiektów, które wymagają długich czasów wartościowania. Przeciążenia powodują wyprowadzanie komunikatów do panelu. Komunikaty te mogą zostać zablokowane przez wyłączenie w pliku konfiguracyjnym aplikacji parametru Przeciążenia:

Architekt > Obszary i komputery > moduł Pozostałe > zakładka Przelicznik

Status wyniku wartościowania może być zapisany w danej statusowej i pobrany przez sterownik. Dana statusowa jest liczbą stałoprzecinkową długą. Jej format przedstawiono poniżej (Najmłodszy bit ma numer 0).

Format danej statusowej

bit 0 - niedozwolona operacja zmiennoprzecinkowa

bit 1 - denormalizacja mantysy

bit 2 - dzielenie przez zero

bit 3 - nadmiar

bit 4 - podmiar

bit 5 - utrata precyzji

bit 6 - cofnięcie czasu (błąd zgłaszany przez Aspada)

bit 7 - błędny argument operacji zaokrąglania

bit 8 - pierwiastek z liczby ujemnej

bit 9 - logarytm z liczby niedodatniej

bit 10 - błąd dziedziny funkcji arcus sin cos

bit 11 - za mało liczna populacja

bit 12 - błąd konwersji liczb (float->int)

bit 13 - błąd otwarcia kanału (błąd zgłaszany przez Aspada)

bit 14 - błąd funkcji pozycjonowania pliku (seek) (błąd zgłaszany przez Aspada)

bit 15 - odwołanie do przyszłości (błąd zgłaszany przez Aspada)

bit 16 - brak danych (błąd zgłaszany przez Aspada)

bit 17 - są dane późniejsze (błąd zgłaszany przez Aspada)

bit 18 - przerwa w archiwizacji (błąd zgłaszany przez Aspada)

bit 19 - brak punktu w podanym przedziale (błąd zgłaszany przez Aspada)

bit 20 - dana nie odświeżona na czas (błąd zgłaszany przez Asmena)

bit 21 - dana niepewna (błąd zgłaszany przez Asmena)

bit 22 - dana niezdefiniowana (błąd zgłaszany przez Asmena)

bit 23 - błąd transmisji -zła dana (błąd zgłaszany przez Asmena)

bit 24 - brak danych z serwera (błąd zgłaszany przez Aspada)

bit 25 - błąd konwersji odpowiednika tekstowego

bit 26 - brak odpowiednika tekstowego

bit 27 - błędny format (tylko w pracy z językiem ASTER)

bit 28 - niezdefiniowana zmienna języka ASTEL

bit 29 - błąd syntaktyczny wyrażenia

bit 30 - dane symulowane (tylko w pracy z samym konstruktorem)

bit 31 - błędny argument ewaluatora języka ASTEL


19.4.19. Obiekt PRZEŁĄCZNIK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.20. Obiekt PRZEŁĄCZNIK

19.4.20. Obiekt PRZEŁĄCZNIK

Wymiary

Parametry obiektu

Nazwa Obiektu

Przycisk

Maska bitowa

Lista tekstów

Kodowanie

Układ

Dana monitorowana

Stan

Wysyłanie

Obiekt PRZEŁĄCZNIK jest zestawem przycisków obsługiwanych wspólnie. Przyciski te mogą być zależne (tzn. wciśnięcie jednego powoduje wyciśnięcie pozostałych) lub niezależne. Obiekt ten jest wybieralny. Naciśnięcie jakiegoś przycisku może powodować wysłanie sterowania. Może to nastąpić w momencie naciskania przycisku lub po potwierdzeniu. Wysyłanie sterowania może być chronione hasłem. Obiekt może także być dynamiczny. W takim przypadku stan klawiszy przełącznika może być opcjonalnie ustawiany ze sterownika. PRZEŁĄCZNIK może być obiektem przezroczystym. Wówczas poszczególne klawisze należy utworzyć np. przy pomocy obiektów typu PRZYCISK nie wykonujących żadnej akcji lub obiektów typu OBRAZKI, TEKSTY nie wysyłających sterowań. Możliwe jest zablokowanie wyświetlania tzw. "ramki selekcji" standardowo pojawiającej się po wybraniu obiektu.

Rysunek: Przykład obiektu PRZEŁĄCZNIK.

Wymiary

Wymiary obiektu PRZEŁĄCZNIK są określane przy pomocy myszy. Po każdorazowej zmianie parametryzacji obiektu należy ewentualnie zmodyfikować jego wymiary ponieważ nie przeskalowuje się on automatycznie, jeśli zmienione zostaną teksty opisujące klawisze.

Tekst opisu klawiszy wpisuje się do listy pokazując odpowiednie miejsce kursorem myszy. Domyślnie obiekt ma jedynie dwa stany (klawisze). Układ klawiszy może być poziomy lub pionowy. Klawisze mogą być zależne lub nie. Normalne przyporządkowanie bitów klawiszom polega na przypisaniu najmłodszego bitu w słowie lewemu klawiszowi dla układu poziomego (odpowiednio najmłodszy bit odpowiada górnemu klawiszowi dla układu pionowego). Przyporządkowanie to można zmienić stosując "układ odwrotny". Błędy komunikacji sygnalizowane są ukośnym przekreśleniem przełącznika linią o podanym kolorze i grubości.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub naciskając wielokrotnie klawisz Enter wybrać żądany stan przełącznika. Wysłanie sterowania następuje automatycznie po wybraniu stanu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy co powoduje wyciśnięcie wszystkich klawiszy przełącznika.

Dla każdego klawisza możliwy jest indywidualny dobór kolorów (tło, cień, podświetlenie etc.).

Parametry

Rysunek: Okno parametryzacji obiektu PRZEŁĄCZNIK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Przycisk-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą mają zostać opisane klawisze. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Przycisk-Tło - pola koloru umożliwiające ustawienie koloru tekstu opisującego klawisze (pole lewe) tekstu opisującego klawisz po jego wciśnięciu (pole środkowe) oraz tła (pole prawe). Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień + - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wyciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy klawisze powinny posiadać ramkę oraz zadeklarowanie jej koloru.

Przycisk-trójwymiarowy - pole cechy umożliwiające rysowanie tzw. trójwymiarowych klawiszy.

Przycisk-przezroczysty - pole cechy umożliwiające rysowanie przezroczystych klawiszy. W tym przypadku właściwe klawisze powinny być utworzone przy pomocy innych obiektów.

Przycisk-Otoczka - pole liczbowe umożliwiające zadeklarowanie otoczki klawiszy określonej w pikselach (domyślnie 0). Otoczka pozwala na powiększenie obszaru reagującego na selekcję (istotne dla niewielkich klawiszy).

Przycisk-Rozsunięcie - pole liczbowe umożliwiające zadeklarowanie rozsunięcia klawiszy (odstępu pomiędzy nimi) w pikselach (domyślnie 0).

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (o ile nie użyto opcji Bez monitorowania) oraz zmiennej, która może zostać wysłana z obiektu odpowiadającej danemu stanowi.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Lista tekstów - lista tekstów wpisywanych na klawiszach odpowiadających poszczególnym stanom obiektu. Zmiany tekstu można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie wpisaniu w polu poniżej listy nowego tekstu i naciśnięciu klawisza Enter. Próba zadeklarowania tekstu dla nieistniejącego stanu jest nieskuteczna.

Kodowanie-zależne - pole wyboru umożliwiające wybranie zależnego sposobu kodowania oraz obsługi obiektu. Ten sposób kodowania zakłada możliwość naciśnięcia jednocześnie tylko jednego z klawiszy (tak jak w przełączniku zakresów w radioodbiorniku) oraz wysłanie tylko jednej jedynki.

Kodowanie-niezależne - pole wyboru umożliwiające wybranie niezależnego sposobu kodowania oraz obsługi obiektu. Ten sposób kodowania zakłada możliwość wysłania grupy jedynek (jednoczesne naciśnięcie kilku klawiszy).

Układ-poziomy - pole wyboru powodujące, że zestaw klawiszy będzie rysowany poziomo.

Układ-pionowy - pole wyboru powodujące, że zestaw klawiszy będzie rysowany pionowo.

Układ-odwrotny - pole cechy umożliwiające odwrócenie przyporządkowania bitów w słowie poszczególnym klawiszom (normalne przyporządkowanie bitów klawiszom polega na przypisaniu najmłodszego bitu w słowie lewemu klawiszowi dla układu poziomego oraz odpowiednio najmłodszego bitu górnemu klawiszowi dla układu pionowego).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej statusowej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 16 stanów (16 przycisków). Maksymalna liczba stanów wynosi 32. Poszczególnym stanom (przyciskom) odpowiadają kolejne bity słowa.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako stan kolejnych klawiszy klawiatury. Zawartość tego pola umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi stanami. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa liczba stanów.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji Liście tekstów.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiedniego klawisza przez kliknięcie myszką w obszarze wybranego klawisza w trybie odświeżania maski. Ten typ wysyłania jest sensowny w przypadku wyboru trybu Kodowanie-zależne, w przeciwnym razie naciskanie kolejnych klawiszy (tak, aby ustawić żądany stan klawiatury) spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest stan klawiatury.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiednich klawiszy przez (wielokrotne) kliknięcie myszką w obszarze wybranych klawiszy w trybie odświeżania maski a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt został sparametryzowany w trybie Kodowanie-niezależne, choć może być użyty również w przypadku pozostałym. Wysyłaną przez obiekt wartością jest stan klawiatury.


19.4.20. Obiekt PRZYCISK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.21. Obiekt PRZYCISK

19.4.21. Obiekt PRZYCISK

Wymiary

Parametry obiektu

Nazwa Obiektu

Akcja

Tekst

Obrazek

Wyrównanie

Wykonanie

Opis

Kod

Podaj klawisz

Przycisk

Obiekt PRZYCISK umożliwia wykonanie przez operatora określonej akcji po naciśnięciu klawisza. Obiekt ten jest wybieralny. Selekcja przycisku przy pomocy myszy lub naciśnięcie przycisku Enter po wybraniu klawisza powoduje wykonanie akcji. Akcję można wykonać także naciskając na klawiaturze klawisz o podanym w czasie parametryzacji kodzie. Wykonanie akcji może być chronione hasłem. Obiekt nie jest uzależniony od stanu zmiennych, ale zmienia swój wygląd w zależności od tego czy przycisk jest naciśnięty. Może być przezroczysty i wielokrotnie nakładany.

Rysunek: Przykład obiektu PRZYCISK.

Wymiary

Minimalne wymiary obiektu PRZYCISK są określane na podstawie tekstu opisującego klawisz, zastosowanej czcionki oraz wymiarów ewentualnych map bitowych wpisywanych w klawisz. PRZYCISK może zostać powiększony przy pomocy myszy. Próba zmniejszenia obiektu poniżej wymiarów minimalnych jest nieskuteczna.

Kod klawisza (na klawiaturze) można wpisać w polu kod albo prościej nacisnąć odpowiednie klawisze po wybraniu funkcji Podaj klawisz. Wewnątrz klawisza może wystąpić jednocześnie opis tekstowy oraz obrazek (mapa bitowa). Można zastosować różne mapy bitowe w zależności od stanu klawisza (wyciśnięty-wciśnięty). Przycisk przezroczysty może być nałożony na inne obiekty (w szczególności tego samego typu). Obiekty, na które nakładany jest PRZYCISK przezroczysty mogą być statyczne, dynamiczne i wybieralne. Szczególnie ciekawe zastosowania daje wzajemne nakładanie na siebie obiektów przezroczystych.

Przycisk może pracować w trybie natychmiastowym lub w trybie z potwierdzeniem W pierwszym z trybów rozpoczęcie realizacji akcji następuje w momencie puszczenia klawisza myszy. W trybie z potwierdzeniem klawisz pozostaje wciśnięty do czasu potwierdzenia wykonania danej akcji przy pomocy klawisza Szary_+ lub wykonania odpowiedniej akcji.

Parametry

Rysunek: Okno parametryzacji obiektu PRZYCISK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Akcja - pole tekstowe zawierające tekst akcji operatorskiej wykonywanej po naciśnięciu klawisza (zobacz opisy akcji operatorskich). Może być puste.

Tekst-linia1 - pole tekstowe zawierające tekst opisujący klawisz.

Tekst-linia2 - pole tekstowe zawierające drugą linię tekstu opisującego klawisz. Jeśli pole to jest puste to klawisz będzie opisany tylko jedną linią umieszczoną w środku.

Obrazek-wyciśnięty - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze wyciśniętego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Obrazek-płaski - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze płaskiego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Obrazek-naciśnięty - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze wciśniętego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Wyrównanie-Do lewej - wyrównanie tekstu wewnątrz obiektu PRZYCISK do lewej krawędzi.

Wyrównanie-Środkowanie - wyśrodkowanie tekstu wewnątrz obiektu PRZYCISK.

Wyrównanie-Do prawej - wyrównanie tekstu wewnątrz obiektu PRZYCISK do prawej krawędzi.

Tekst na obrazku - wyświetlenie zadeklarowanego tekstu na tle obrazka wyświetlanego w obszarze obrazka.

Opis - pole tekstowe służące do wyświetlania kodu klawisza (np. Ctrl‑y), którego naciśnięcie spowoduje w trakcie odświeżania maski wykonanie akcji (tak jak w wyniku normalnego naciśnięcia klawisza).

Kod - pole tekstowe służące do wyświetlania i wprowadzania szesnastkowego kodu klawisza (np. 0x1519), którego naciśnięcie spowoduje w trakcie odświeżania maski wykonanie akcji (tak jak w wyniku normalnego naciśnięcia klawisza).

Podaj klawisz - klawisz, po którego naciśnięciu należy podać kod klawisza (naciskając odpowiednią kombinację klawiszy na klawiaturze komputera), który ma spowodować wykonanie akcji obiektu PRZYCISK podczas odświeżania maski. Jest to metoda alternatywna do podawania kodu szesnastkowego (w polu Kod) i znacznie prostsza w użyciu.

Wykonanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wykonania akcji po wyselekcjonowaniu obiektu przez kliknięcie myszką w obszarze klawisza w trybie odświeżania maski

Wykonanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wykonania akcji dopiero po wysłaniu potwierdzenia. Potwierdzenia wykonania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję (wcześniej klawisz powinien być wyselekcjonowany).

Wykonanie akcji przy wciśnięciu klawisza - umożliwia zadeklarowanie wykonania akcji w momencie wciśnięcia klawisza.

Przycisk-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą mają zostać opisane klawisze. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Przycisk-wyciśnięty - pola koloru umożliwiające ustawienie koloru tekstu opisującego klawisz wraz z tłem w przypadku wyciśniętego klawisza. Pole lewe określa kolor tekstu, środkowe pole - kolor cienia tekstu (o ile wybrana zostanie opcja Przycisk-cieniowanie), natomiast pole prawe umożliwia ustawienie koloru tła tekstu. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-płaski - pola koloru umożliwiające ustawienie koloru tekstu opisującego klawisz wraz z tłem w przypadku gdy klawisz znajduje się w pozycji płaskiej. Pole lewe określa kolor tekstu, środkowe pole - kolor cienia tekstu (o ile wybrana zostanie opcja Przycisk-cieniowanie), natomiast pole prawe umożliwia ustawienie koloru tła tekstu. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-naciśnięty - pola koloru umożliwiające ustawienie koloru tekstu opisującego klawisz wraz z tłem w przypadku wciśniętego klawisza. Pole lewe określa kolor tekstu, środkowe pole - kolor cienia tekstu (o ile wybrana zostanie opcja Przycisk-cieniowanie), natomiast pole prawe umożliwia ustawienie koloru tła tekstu. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień + - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wyciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy klawisz powinien posiadać ramkę oraz zadeklarowanie jej koloru.

Przycisk-Ochrona wyboru - pole cechy umożliwiające tzw. ochronę wyboru danego przycisku co sprowadza się do konieczności naciśnięcia dodatkowo klawisza Ctrl (oprócz kliknięcia myszką lub naciśnięcia klawisza Enter), aby wykonać akcję.

Przycisk-trójwymiarowy - pole cechy umożliwiające rysowanie tzw. trójwymiarowego klawisza.

Przycisk-przezroczysty - pole cechy umożliwiające rysowanie przezroczystego klawisza. W tym przypadku właściwy klawisz (lub inny obrazek) powinien być utworzony przy pomocy innych obiektów.

Przycisk-trójstanowy - pole cechy pozwalające na trzeci - płaski stan obiektu.

Przycisk-cieniowanie - pole cechy umożliwiające cieniowanie tekstów umieszczonych na klawiszu.

Przycisk-zaokrąglanie - pole cechy umożliwiające zaokrąglenie rogów klawisza.

Przycisk-Otoczka - pole liczbowe umożliwiające zadeklarowanie otoczki klawiszy określonej w pikselach (domyślnie 0). Otoczka pozwala na powiększenie obszaru reagującego na selekcję (istotne dla niewielkich klawiszy).

Przycisk-Hasło- - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

.


19.4.21. Obiekt PUNKT PRACY

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.22. Obiekt PUNKT PRACY

19.4.22. Obiekt PUNKT PRACY

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Zakres zmiennej X |
Zakres zmiennej Y |
Tło |
Ślad |
Dane pomiarowe |

Obiekt PUNKT PRACY umożliwia wyświetlenie kursora poruszającego się po uprzednio przygotowanym (pod postacią tabel mapy bitowej) tle. Bitmapa, która stanowić ma tło wyświetlania stanu zmiennych X i Y nie ma ograniczeń co do wielkości. Może ona być umieszczona w oddzielnym pliku w formacie BMP zlokalizowanym na dysku w kartotece zadeklarowanej jako katalog masek. W okienku parametryzacyjnym obiektu podaje się wtedy jedynie nazwę pliku wraz z rozszerzeniem BMP.

W istnieje również możliwość zadeklarowania obiektu bez tła w postaci bitmapy. Aktualny stan zmiennych X i Y wyświetlany jest wtedy bezpośrednio na masce - można wcześniej przygotować statyczny podkład PUNKTU PRACY przy użyciu obiektów LINIA PP, PROSTOKĄT, OBRAZEK lub podobnych.

Kursor może ciągnąć za sobą ślad. Istnieje możliwość użycia kursora standardowego lub deklarowania dowolnego kursora wskazującego aktualne wartości zmiennych. Może być to dowolna bitmapa znajdująca się w katalogu bitmap Asixa.

Możliwa jest sygnalizacja błędów komunikacyjnych oraz pomiarowych.

Wymiary

Wymiary obiektu PUNKT PRACY są określone na sztywno, jeśli użyto mapy bitowe jako podkładu graficznego. W przeciwnym przypadku mogą być ustalone dowolnie przez użycie myszki lub podanie wprost w rubryce Tło okienka dialogowego parametryzacji obiektu.

Parametry

Rysunek: Okno parametryzacji obiektu PUNKT PRACY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Zakres zmiennej X-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości odpowiadającej dolnemu zakresowi zmiennej X. Domyślnie 0.

Zakres zmiennej X-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości odpowiadającej górnemu zakresowi zmiennej X. Domyślnie 100.

Zakres zmiennej Y-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości odpowiadającej dolnemu zakresowi zmiennej Y. Domyślnie 0.

Zakres zmiennej Y-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości odpowiadającej górnemu zakresowi zmiennej Y. Domyślnie 100.

Tło-nazwa - pole tekstowe służące do wpisania nazwy bitmapy (stanowiącej tło kursora). Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Tło-Rodzaj-mapa bitowa - pole wyboru mapy bitowej do wyświetlania tła obiektu.

Tło-Rodzaj-brak (własne) - pole wyboru służące do zadeklarowania tła bez mapy bitowej - obiekt jest wtedy przezroczysty i widoczne są wszystkie obiekty nałożone wcześniej na maskę w miejscu zlokalizowania obiektu Punkt pracy.

Tło-szerokość - pole edycyjne do wprowadzenia szerokości obiektu w przypadku zaznaczenia pola wyboru Tło-Rodzaj-brak (własne). Wartość zmienia się automatycznie po przeskalowaniu obiektu przy użyciu myszki.

Tło-wysokość - pole edycyjne do wprowadzenia wysokości obiektu w przypadku zaznaczenia pola wyboru Tło-Rodzaj-brak (własne). Wartość zmienia się automatycznie po przeskalowaniu obiektu przy użyciu myszki.

Ślad-Kursor-standardowy - pole wyboru służące do zadeklarowania użycia standardowego kursora.

Ślad-Kursor-definiowany - pole wyboru służące do zadeklarowania użycia niestandardowego kursora. Kształt kursora jest definiowany przez mapę bitową zadeklarowaną w Ślad-kursor def.

Ślad-kolor std. - pole koloru umożliwiające ustawienie koloru kursora.

Ślad-kursor def. - pole wyboru kształtu kursora definiowanego wyświetlanego podczas pracy obiektu i braku błędów pomiarowych.

Ślad-błąd pom. - pole wyboru kształtu kursora wyświetlanego przy błędach pomiarowych występujących w zmiennych pomiarowych.

Ślad-punkty - pole liczbowe umożliwiające ustawienie liczba punktów śladu, rysowanego za kursorem (domyślnie 0 - brak śladu).

Ślad-kasowanie śladu - pole cechy umożliwiające kasowanie śladu (przez kliknięcie w polu obiektu).

Dane pomiarowe-Zmienna X - pole tekstowe umożliwiające podanie nazwy danej pomiarowej X (odpowiada osi poziomej). Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dane pomiarowe-Zmienna Y - pole tekstowe umożliwiające podanie nazwy danej pomiarowej Y (odpowiada osi pionowej). Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku zmieniony zostaje kolor kursora. Opcja domyślna.

Błędy pomiarowe - pole cechy umożliwiające sygnalizację błędów pomiarowych. W takim przypadku kursor zostaje obwiedziony linią. Wymaga wyspecyfikowania Danej kontrolnej.

Dana kontrolna - pole tekstowe umożliwiające podanie nazwy danej kontrolnej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Błędy pomiarowe. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Status - pole tekstowe umożliwiające wprowadzenie szesnastkowej maski. Jeśli iloczyn tej maski i danej kontrolnej jest różny od zera, wówczas mamy do czynienia z wystąpieniem błędu pomiarowego.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędów oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Parametryzacja z bazy

Obiekt PUNKT PRACY jest wyposażony w cechy umożliwiające ustawienie z bazy zmiennych następujących parametrów:

  • zakres zmienności obydwu zmiennych wejściowych np. 0-200, 100-300,

  • nazwę i maskę danej kontrolnej, umieszczonych w bazie dla zmiennej X.

Obiekt ten posiada przycisk Łącze, którego naciśnięcie powoduje wpis znaku @, a następnie zawartości odpowiedniego pola w bazie danych. Przycisk Łącze działa pod warunkiem, że dane pola w oknie definicji obiektu są puste.

Rysunek: Okno parametryzacji obiektu PUNKT PRACY - parametryzacja z bazy.


19.4.22. Obiekt RAPORT

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.23. Obiekt RAPORT

19.4.23. Obiekt RAPORT

Wymiary

Parametry obiektu

Nazwa Obiektu

Definicja raportu w języku ASTER

Nazwa Raportu

Obliczenie

Terminy

Cykl

Wygląd

Czytaj

Zapisz

Obiekt RAPORT umożliwia sprawdzenie i obliczenie raportu (którego definicja zapisana została w języku ASTER) oraz wyświetlenie raportu wynikowego na masce technologicznej. Raporty są tablicami liczb zwykle wyświetlanymi pod postacią tabel. Obliczanie raportów może odbywać się cyklicznie. Obiekt ten może także dokonać obliczenia na żądanie operatora (po jego wyselekcjonowaniu). Możliwe jest również automatyczne obliczanie raportów o określonych porach (do 8 terminów na dzień).

Poniższy rysunek prezentuje fragment raportu demonstracyjnej aplikacji systemu Asix dla Wytwórni Kwasu.

Rysunek: Fragment raportu demonstracyjnej aplikacji systemu Asix.

Wymiary

Wysokość i szerokość przyjmuje się automatycznie według definicji raportu (na podstawie zawartości instrukcji format oraz wybranej czcionki); wartości liczbowe wpisywane do raportów podczas pracy z konstruktorem są symulowane; w przypadku obliczenia na żądanie operator może wymusić wartościowanie dokonując selekcji obiektu; w przypadku wartościowania cyklicznego należy określić czas trwania cyklu; ze względu na liczenie raportu w cyklu odświeżania obiekty-raporty powinny się liczyć nie dłużej niż kilka-kilkanaście sekund (należy to sprawdzić indywidualnie); czas obliczeń jest wprost proporcjonalny do:

  • liczby wartościowanych wyrażeń (iloczynu wierszy i kolumn raportu) oraz

  • liczby pomiarów archiwizowanych w okresie, którego raport dotyczy (iloczynu okresu raportu i częstotliwości próbkowania zmiennych).

Raporty wymagające dłuższych obliczeń powinny być projektowane jako raporty dyskowe.

Definicja raportu w języku ASTER powinna zostać wpisana w polu umieszczonym pod nazwą obiektu. Najlepszym rozwiązaniem jest jednak wczytanie z dysku gotowej definicji (po wybraniu nazwy raportu) przy pomocy funkcji CZYTAJ oraz ewentualna jej modyfikacja we wspomnianym polu edycyjnym. Definicja raportu jest zapamiętywana wewnątrz obiektu. Definicję raportu można sprawdzić wykonując "kliknięcie" w polu diagnostycznym umieszczonym poniżej pola definicji. Jeżeli raport jest niepoprawny, wówczas w polu diagnostycznym pojawi się informacja o błędzie wraz z linią zawierającą błąd. W linii tej element leksykalny powodujący błąd zostanie poprzedzony znakiem zapytania (?). Wykonanie funkcji CZYTAJ w przypadku wybrania pustej nazwy raportu powoduje wpisanie w pole edycyjne pustego raportu.

Zmodyfikowany raport może zostać zapisany przy pomocy funkcji ZAPISZ. Zapis następuje do raportu, którego nazwa (nazwa raportu nie jest nazwą pliku) wskazana jest w polu nazwy raportu. Jeśli wykonana zostanie funkcja ZAPISZ w przypadku wybrania pustej nazwy raportu, nazwa pliku zostaje wygenerowana automatycznie.

Możliwy jest wybór czcionki raportu obiektowego. W odróżnieniu od pozostałych tekstów do wyboru są jedynie trzy rodzaje czcionek o nazwach ROM_8x8, ROM_8x14 i ROM_8x16. Wymienione czcionki posiadają stałą szerokość znaku oraz zdefiniowane jako znaki elementy ramek a dodatkowo zapewniają kompatybilność raportów ze starszymi wersjami Asixa (DOS).

Parametry

Rysunek: Okno parametryzacji obiektu RAPORT.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Pola nieopisane - pole tekstowe umożliwiające wpisanie definicji raportu w języku ASTER (główne pole pod nazwą obiektu) oraz wyświetlenie komunikatów diagnostycznych (pole poniżej). Kliknięcie prawym klawiszem w tym polu powoduje otwarcie okna generacji wyrażeń, które pozwala na generację wyrażeń języka ASTEL użytkownikowi nie znającemu jego składni.

Nazwa Raportu - pole wyboru umożliwiające wybór raportu, który ma zostać odczytany lub zapisany. Raporty te (a ściślej ich definicje umieszczone w plikach *.r) powinny być umieszczone w katalogu wyspecyfikowanym w sekcji raport pliku *.ini. Pole to może być puste - co oznacza brak definicji raportów.

Obliczenie-Cyklicznie - pole wyboru umożliwiające wymuszenie cyklicznego wartościowania wyrażenia przez obiekt.

Obliczenie-Na Żądanie - pole wyboru umożliwiające wymuszenie wartościowania na żądanie operatora (kliknięcie w polu obiektu).

Obliczenie-Terminowo - pole wyboru umożliwiające wymuszenie wartościowania według listy wprowadzonych terminów.

Terminy-Czas - pole tekstowe umożliwiające wpisanie terminu (czasu) policzenia raportu. Poniżej tego pola znajduje się lista wyświetlająca do ośmiu wprowadzonych terminów (na dobę). Termin zostaje wpisany na listę przez naciśnięcie klawisza Enter.

Cykl - pole liczbowe oraz pole wyboru umożliwiające określenie cyklu odświeżania obiektu przez podanie liczby kwantów oraz jednostki. Ważne dla cyklicznego trybu pracy.

Wygląd-= - pola koloru umożliwiające ustawienie koloru znaków (pole lewe) oraz tła (pole prawe) wyświetlanej liczby.

Wygląd-Tło koloru okna - pole cechy umożliwiające wymuszenie ustawienia koloru tła zgodnego z kolorem okna.

Wygląd-Krój - pole wyboru umożliwiające wybór jednej z trzech dopuszczalnych dla raportów czcionek.

Czytaj - klawisz, którego naciśnięcie powoduje odczyt raportu ustawionego w polu Nazwa Raportu do pola edycyjnego.

Zapisz - klawisz, którego naciśnięcie powoduje zapis raportu umieszczonego w polu edycyjnym do pliku zawierającego raport, którego nazwa ustawiona jest w polu Nazwa Raportu.


19.4.23. Obiekt RUROCIĄG

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.24. Obiekt RUROCIĄG

19.4.24. Obiekt RUROCIĄG

Wymiary

Parametry obiektu

Zestaw parametrów ustalanych dla wszystkich stanów jednocześnie

Nazwa obiektu

Szerokość rury

Wzorzec

Linia

Początek

Koniec

Zestaw parametrów ustalanych indywidualnie dla poszczególnych stanów

Dana monitorowana

Stan

Maska bitowa

Linia

Prędkość

Kodowanie

Sposoby kodowania

Obiekt RUROCIĄG umożliwia wyświetlenie na masce odcinka rurociągu. Jest to obiekt dynamiczny. Możliwy jest wybór grubości rurociągu oraz indywidualne zdefiniowanie każdej linii tworzącej go. Dzięki temu łatwo można uzyskać np. efekt trójwymiarowości. Końcówki rurociągu mogą być osobno deklarowane co ułatwia rysowanie kolanek, trójników itp. Odcinki rurociągu mogą być pionowe, poziome lub nachylone pod kątem 45 stopni. Ponadto dzięki odpowiedniemu zdefiniowaniu parametrów linii dla poszczególnych stanów danej monitorowanej istnieje możliwość uzyskania efektu animacji ruchu.

Rysunek: Przykłady obiektu RUROCIĄG.

Wymiary

Jeden z wymiarów obiektu RUROCIĄG jest określony na sztywno (na podstawie grubości rurociągu), zaś drugi podaje się przy pomocy myszki (przy pomocy myszki można też zmieniać kierunek istniejącego obiektu RUROCIĄG).

Rurociąg tworzony jest z linii w ten sposób, że w jego środku rysowana jest linia oznaczona numerem 1, stanowiąc zarazem oś symetrii, wokół której rysowane są kolejne linie oznaczone jako linia 2, 3... itd. aż do osiągnięcia zadeklarowanej grubości rury.

Pole =Wzorzec określa sposób wyrównania wzorca linii względem początku rurociągu. Wzorzec może być rysowany w ten sposób, aby końcówki rurociągu były płasko ścięte, ewentualnie może "dopasować się" do kształtu początku rury (lewy lub górny koniec w zależności od orientacji).

Parametry

Rysunek: Okno parametryzacji obiektu RUROCIĄG.

Zestaw parametrów ustalanych dla wszystkich stanów jednocześnie

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Szerokość rury - pole wyboru umożliwiające określenie szerokości rurociągu w pikselach (do wyboru jedynie nieparzyste szerokości).

=Wzorzec - pole cechy umożliwiające włączenie tzw. wyrównywania wzorca (zobacz opis obiektu).

i-Linia - zestaw pól składających się z pola wyboru oraz pola tekstowego. Pola te umożliwiają zdefiniowanie poszczególnych linii tworzących rurociąg. Dla każdej linii można określić wzorzec linii (do wyboru: linia ciągła, różne rodzaje linii przerywanych oraz własny wzorzec) oraz szesnastkowo wartość odpowiadającą własnemu wzorcowi.

Początek - pole wyboru umożliwiające zadeklarowanie odpowiedniego początkowej (lewa lub górna) końcówki rury (do wyboru płasko ścięta, w lewo ścięta, w prawo ścięta, zaostrzona).

Koniec - pole wyboru umożliwiające zadeklarowanie odpowiedniego końcowej (prawa lub dolna) końcówki rury (do wyboru płasko ścięta, w lewo ścięta, w prawo ścięta, zaostrzona).

Zestaw parametrów ustalanych indywidualnie dla poszczególnych stanów

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy jest konieczne w przypadku, gdy liczba stanów jest większa od 1. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Odwrotny ruch - zadeklarowanie tego atrybutu powoduje, że ruch linii odbywa się w kierunku przeciwnym (z prawej do lewej).

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych stanów selektora. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi stanami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się za pomocą przycisków [image] [image].

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej, odpowiadającej danemu stanowi.

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- – wartość bitu nie ma znaczenia

1 – bit musi być ustawiony

0 – bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

i-Linia - zestaw pól składających się z dwóch pól koloru. Pola te umożliwiają zdefiniowanie poszczególnych linii tworzących rurociąg. Dla każdej linii można określić kolor, drugi kolor (ważny jeśli linia jest przerywana).

Prędkość - pole pozwala określić prędkość, z jaką porusza się linia; możliwe warianty to: postój, szybko do tyłu, do tyłu, wolno do tyłu, wolno do przodu, do przodu, szybko do przodu.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych tekstów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość. Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Sposoby kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).


19.4.24. Obiekt SELEKTOR

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.25. Obiekt SELEKTOR

19.4.25. Obiekt SELEKTOR

Wymiary | Sposoby kodowania
Parametry obiektu | Przykład kodowania
Nazwa Obiektu |
Przycisk |
Wysyłanie |
Lista tekstów |
Stan |
Maska bitowa |
Kodowanie |
Dana monitorowana |
Parametry |
Wyrównanie |

Obiekt SELEKTOR stanowi połączenie przycisku z okienkiem wyświetlającym objaśniający tekst. Można opcjonalnie użyć identyfikatora tekstu, który deklarowany jest dla pliku konfiguracyjnego projektowanej aplikacji poprzez program Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe,

gdzie tekst definiowany jest poprzez podanie nazwy logicznej tekstu oraz tekstu właściwego, który wyświetlany będzie przez obiekt SELEKTOR.

Takie postępowanie umożliwia wykorzystanie identycznej maski dla różnych aplikacji (różniących się opisem).

Rysunek: Przykład obiektu SELEKTOR.

Obiekt ten jest wybieralny. Selekcja przycisku powoduje wyświetlenie opisu odpowiadającego wysyłanemu sterowaniu. Wysłanie sterowania może nastąpić w momencie naciskania przycisku lub po potwierdzeniu. Wysłanie sterowania może być chronione hasłem. Obiekt jest również obiektem dynamicznym wyświetlającym w okienku tekstowym stan odpowiadający określonej zmiennej monitorowanej w sterowniku. Pewne (zadeklarowane jako "ochrona wyboru") sterowania z obiektu SELEKTOR można wysłać naciskając oprócz przycisku myszy lub klawisza Enter dodatkowo klawisz Ctrl. Ma to na celu ochronę przed przypadkowym wysłaniem określonych sterowań. Inne stany (np. niewykorzystane) mogą posiadać cechę "blokada wyboru", co powoduje niemożliwość jego wyświetlenia podczas przeglądania listy stanów. Klawisze obiektu SELEKTOR mogą być przezroczyste (ale okienko tekstowe pozostaje). W miejsce klawisza należy wtedy wstawić inny obiekt (np. PRZYCISK).

Wymiary

Wymiary obiektu SELEKTOR są określane na podstawie zawartości tekstu opisującego stan selektora, tekstu opisującego klawisz, zastosowanych czcionek oraz wymiarów ewentualnych map bitowych tworzących klawisz. W celu określenia wymiaru przeglądane są wszystkie mogące zostać wyświetlone w okienku teksty. Tak określony wymiar obiektu jest wymiarem minimalnym i może zostać powiększony wraz ze znajdującym się pod nim klawiszem przy pomocy myszy. Próba zmniejszenia obiektu poniżej wymiarów minimalnych jest nieskuteczna.

Tekst wpisuje się do listy pokazując odpowiednie miejsce kursorem myszy. Wskazanie tekstu na liście powoduje wyświetlenie jego atrybutów w odpowiednich polach dialogowych. Atrybuty wyświetlania tekstu (czcionka, środkowanie, kolory, ochrona i blokada dostępu) można modyfikować. Zostaną one przypisane do konkretnego tekstu wskazanego na liście.

Domyślnie obiekt ma jedynie jeden stan. Błędy komunikacji sygnalizowane są ukośnymi przekreśleniami linią o podanym kolorze i grubości.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wyświetlić w okienku żądany stan. Stany chronione wyświetlić można naciskając jednocześnie dodatkowo przycisk Ctrl. Wysłanie sterowania następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Parametry

Rysunek: Okno parametryzacji obiektu SELEKTOR.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Przycisk- Ob.wyciś. - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze wyciśniętego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Przycisk- Ob. płaski - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze płaskiego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix. Stan płaski klawisza pojawia się tylko w przypadku wyboru okna trójstanowy, opisanego poniżej.

Przycisk-Ob.naciś. - pole tekstowe służące do wpisania nazwy bitmapy wyświetlanej w obszarze wciśniętego klawisza. Nazwę mapy bitowej można w polu dialogowym wpisać lub też dokonać jej wyboru naciskając prawy klawisz myszy. Pojawia się wówczas okno umożliwiające przeglądanie i wybór map bitowych należących do puli map systemu Asix.

Przycisk-Tekst - pole tekstowe umożliwiające wpisanie tekstu opisującego klawisz selektora. Do wykorzystania alternatywnie zamiast bitmap deklarowanych w polu Przycisk-Obrazek.

Przycisk-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać opisany klawisz. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Przycisk-Tło - pola koloru umożliwiające ustawienie koloru tekstu opisującego klawisz (pole lewe) tekstu opisującego klawisz po jego wciśnięciu (pole środkowe) oraz tła (pole prawe). Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień + - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wyciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień - - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wciśniętego klawisza (pole prawe). Podświetlenie obejmuje obramowanie klawisza z góry i lewej strony, natomiast cień to obramowanie klawisza z dołu i strony prawej. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy klawisze powinny posiadać ramkę oraz zadeklarowanie jej koloru.

Przycisk-trójwymiarowy - pole cechy umożliwiające rysowanie tzw. trójwymiarowych klawiszy.

Przycisk-przezroczysty - pole cechy umożliwiające rysowanie przezroczystych klawiszy. W tym przypadku właściwe klawisze powinny być utworzone przy pomocy innych obiektów.

Przycisk-trójstanowy - pole cechy pozwalające na trzeci - płaski stan obiektu.

Przycisk-Ramka tekstu - pole cechy umożliwiające określenie czy ma być rysowana ramka okienka tekstowego (umieszczonego nad klawiszem).

Przycisk-Otoczka - pole liczbowe umożliwiające zadeklarowanie otoczki klawisza określonej w pikselach (domyślnie 0). Otoczka pozwala na powiększenie obszaru reagującego na selekcję (istotne dla niewielkich klawiszy).

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu klawisza przez kliknięcie myszką w polu obiektu w trybie odświeżania maski. Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany - w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu w okienku tekstowym opisowi.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiedniego opisu tekstowego przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu w okienku tekstowym opisowi.

Lista tekstów - lista tekstów wpisywanych na klawiszach odpowiadających poszczególnym stanom obiektu. Zmiany tekstu można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie wpisaniu w polu poniżej listy nowego tekstu i naciśnięciu klawisza Enter. Próba zadeklarowania tekstu dla nieistniejącego stanu jest nieskuteczna.

Odpowiednik tekstu - pole cechy informujące, że na liście tekstów znajdują się jedynie nazwy odpowiedników tekstów, zaś właściwe teksty deklarowane są przy użyciu programu Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi 17. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych stanów selektora. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi stanami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji na Liście tekstów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (o ile nie użyto opcji Bez monitorowania) oraz zmiennej, która może zostać wysłana z obiektu, odpowiadającej danemu stanowi.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej statusowej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Parametry-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony tekst odpowiadający danemu stanowi selektora. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Parametry-Kolor/Tło - pola koloru umożliwiające ustawienie koloru tekstu (pole lewe) oraz koloru tła tekstu (pole prawe) opisującego stan selektora. Po wyselekcjonowaniu tego pola wyświetlone zostaje okno wyboru koloru. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Parametry-Tło koloru okna - pole cechy umożliwiające wymuszenie ustawienia koloru tła tekstu opisującego stan selektora zgodnego z kolorem okna. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Parametry-Ochrona wyboru - pole cechy umożliwiające tzw. ochronę wyboru danego przycisku, co sprowadza się do konieczności naciśnięcia dodatkowo klawisza Ctrl (oprócz kliknięcia myszką lub naciśnięcia klawisza Enter), aby wykonać akcję. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Parametry-Blokada wyboru - pole cechy umożliwiające tzw. blokadę wyboru danego przycisku, co sprowadza się do uniemożliwienia wyboru pewnych stanów - tak aby niemożliwe było wysłanie odpowiadającego im sterowania. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Wyrównanie-Do Lewej - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do lewej. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Wyrównanie-Środkowanie - pole wyboru wymuszające środkowanie tekstu w obszarze obiektu. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Wyrównanie-Do Prawej - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do prawej. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych tekstów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość. Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Sposoby kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery teksty opisujące stan selektora np. "???", "MAN", "AUT" i "REM" (w tej kolejności) to stanowi "00" będzie odpowiadać tekst "???", stanowi "01" tekst "MAN" itd. W przypadku zapisu, jeśli wybrany zostanie tekst "REM" to odpowiadający mu stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający numerowi wybranego tekstu.

1000000000100000 / zmienna przeczytana
1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"
----------11---- / bity ustawiane przez obiekt
1000000000110000 / zmienna wysyłana

W przypadkach praktycznych można dodatkowo stanowi "00" ("???") przypisać cechę Blokada wyboru, natomiast stanowi "11" ("REM") cechę Ochrona wyboru. Spowoduje to niemożliwość wybrania stanu "???" oraz utrudnione (przez konieczność dodatkowego naciśnięcia klawisza Ctrl) wybieranie stanu "REM".


19.4.25. Obiekt SŁUPEK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.26. Obiekt SŁUPEK

19.4.26. Obiekt SŁUPEK

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Kolory |
Zakresy |
Ramka |
Kierunek |
Dana pomiarowa |
Kontur |

Obiekt SŁUPEK umożliwia wyświetlenie na masce wskaźnika słupkowego odpowiadającego zmiennej systemowej. Jest obiektem dynamicznym. SŁUPEK może zmieniać kolory oraz posiadać naniesione znaczniki odpowiadające określonym wartościom stałym lub zmiennym; możliwe jest zadeklarowanie atrybutu migotania dla stanów przekroczenia zadanych limitów. Sygnalizuje błędy pomiarowe i komunikacyjne. Przy zastosowaniu konturu w formacie czarno-białej bitmapy (z zestawu bitmap Asixa lub w oddzielnym pliku) możliwe jest dowolne ukształtowanie wskaźnika słupkowego.

Rysunek: Przykłady obiektu SŁUPEK.

Wymiary

Wymiary obiektu SŁUPEK są określane przy pomocy myszy lub są ustalone wymiarami bitmapy w przypadku użycia konturu do kształtowania wskaźnika słupkowego.

Parametry

Rysunek: Okno parametryzacji obiektu SŁUPEK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolory->> - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy alarmowej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-> - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy ostrzegawczej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-= - pola koloru umożliwiające ustawienie podstawowego koloru słupka (pole lewe) oraz tła (pole prawe) wyświetlanej liczby. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-? - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku błędu. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-< - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy ostrzegawczej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-<< - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy alarmowej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-Znacznik - pole koloru umożliwiające ustawienie koloru znaczników.

Kolory-Tło koloru Okna - pole cechy umożliwiające wymuszenie ustawienia koloru tła słupka zgodnego z kolorem okna.

Kolory-Tło przezroczyste - pole cechy umożliwiające wymuszenie ustawienia przezroczystego tła SŁUPKA.

Zakresy-X>> - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 90. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-X> - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 75. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-od - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości lub nazwy zmiennej odpowiadającej dolnemu zakresowi słupka. Domyślnie 0.

Zakresy-do - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości lub nazwy zmiennej odpowiadającej górnemu zakresowi słupka. Domyślnie 100.

Zakresy-X< - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 25. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-X<< - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 10. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-baza - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości lub nazwy zmiennej odpowiadającej bazie słupka. Domyślnie 0.Prawe okienko tego pola pozwala deklarować grubość linii (w pikselach) oznaczającej bazę.

Ramka-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy słupek powinien posiadać ramkę oraz zadeklarowanie jej koloru.

Ramka-Grubość - pole liczbowe umożliwiające określenie grubości ramki (domyślnie 1).

Kierunek - pole wyboru określające kierunek wzrostu słupka. Do wyboru N (w górę), E (w prawo), S (w dół) oraz W (w lewo). Domyślnie E.

Dana pomiarowa - pole tekstowe umożliwiające podanie nazwy danej pomiarowej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku słupek zostaje przekreślony wzdłuż linią o wyspecyfikowanych parametrach. Opcja domyślna.

Błędy pomiarowe - pole cechy umożliwiające sygnalizację błędów pomiarowych. W takim przypadku słupek zostaje pokreskowany w poprzek liniami o wyspecyfikowanych parametrach. Wymaga wyspecyfikowania Danej kontrolnej.

Dana kontrolna - pole tekstowe umożliwiające podanie nazwy danej kontrolnej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Błędy pomiarowe. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej kontrolnej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Status - pole tekstowe umożliwiające wprowadzenie szesnastkowej maski. Jeśli iloczyn tej maski i danej kontrolnej jest różny od zera, wówczas mamy do czynienia z wystąpieniem błędu pomiarowego.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędów oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Kontur - wprowadzenie konturu maskującego w obiekcie SŁUPEK umożliwia wizualizowanie zmian poziomu w zbiornikach o dowolnym kształcie (stożkowym, kulistym lub tp.)

Kontur maskujący należy sporządzić dowolnym edytorem graficznym obsługującym format BMP. Obraz konturu musi być monochromatyczny (biało-czarny), przy czym kolor biały jest "przezroczysty" dla słupka, kolor czarny dla tła obiektu.

Teksty puste i złożone z samych spacji są dopuszczalne w polach ograniczeń i są traktowane jako rezygnacja ze sprawdzania.

Wyświetlany słupek może zmieniać kolor w sytuacji wystąpienia przekroczeń lub spełnienia określonych warunków logicznych. Przekroczenia mogą być specyfikowane jako liczby (stałe) lub nazwy zmiennych systemowych. Jeśli przekroczenia zostały wyspecyfikowane jako nazwy zmiennych systemowych, wówczas w polu deklarującym zmienną można wpisać warunek logiczny jako przyrostek nazwy zmiennej - utworzony zgodnie z poniższymi wytycznymi.

Warunek logiczny jest ciągiem składającym się z liczby szesnastkowej (warunku) wraz z poprzedzającym go znakiem "&" lub "|". W pierwszym przypadku (&) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest równy warunkowi, zaś w drugim przypadku (|) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest różny od zera. Innymi słowy w pierwszym przypadku dla zmiany atrybutu liczby wymagane jest, aby wszystkie bity warunku były w danej zmiennej ustawione, zaś w drugim przypadku wystarczające jest, jeżeli co najmniej jeden bit warunku jest jedynką. Znak "|" można pominąć przy specyfikowaniu warunku.

Dodatkowo mogą być rysowane znaczniki (kreseczki) w miejscach odpowiadających limitom przekroczeń. Znaczniki rysowane są po ustawieniu na "tak" pola logicznego sąsiadującego z polem służącym do wpisywania limitów przekroczeń. Domyślnie poziom odniesienia jest jednocześnie poziomem minimalnym (poziom "od" równy jest poziomowi "bazy"). Poziom odniesienia tzw. "baza" różna od wartości minimalnej powoduje, że słupek nie rozpoczyna się od podstawy obiektu. Ten tryb pracy używany jest do wizualizacji przyrostów (gradientów). Poziom minimalny powinien być różny od maksymalnego (uwaga: nie musi być większy). Poziom odniesienia powinien zawierać się w przedziale pomiędzy minimum i maksimum. W czasie odświeżania (o ile nie jest wymagana zmiana koloru) rysowany jest jedynie przyrost słupka odpowiadający zmianie zmiennej pomiarowej obiektu. W przypadku wystąpienia błędu komunikacyjnego obiekt przekreślony zostaje linią o podanym kolorze i grubości wzdłuż kierunku ruchu słupka. Pojawienie się błędu pomiarowego powoduje pokreskowanie słupka w poprzek liniami o parametrach jak wyżej. Dodatkowo słupek może w przypadku wystąpienia jednego z błędów (lub obu naraz) zmienić swoje kolory. Słupek może być otoczony ramką.

Parametryzacja z bazy

Obiekt SŁUPEK wyposażony został dodatkowo w cechy umożliwiające ustawienie z bazy zmiennych następujących parametrów:

  • zakres zmienności np. 0, 100 według nazwy zmiennej wyświetlanej,

  • limity, przy których wystąpi zmiana koloru np. nazwy zmiennych Limit, Limit&10 (nazwa zmiennej wraz z maską bitową) według nazwy zmiennej wyświetlanej,

  • nazwę i maskę danej kontrolnej.

W tym celu obiekt liczba został dodatkowo wyposażony w przycisk Łącze, którego naciśnięcie powoduje wpis zawartości danego pola w bazie, poprzedzonego znakiem @ na wszystkich pozycjach, które mogą być potencjalnie ustawione z bazy zmiennych.

W poniższym przykładzie naciśnięcie przycisku Łącze spowodowało wpisanie zawartości pól z bazy dla:

  • limitu maksimum krytyczne - wartość 100

  • limitu maksimum - zmienna o nazwie A_H

  • limitu minimum - bit określony przez maskę (heksadecymalnie 4) zmiennej o nazwie A_L

  • limitu minimum krytycznego - zmienna A_LL

  • dana kontrolna - zmienna A?

  • maska danej kontrolnej - 4


19.4.26. Obiekt SUWAK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.27. Obiekt SUWAK

19.4.27. Obiekt SUWAK

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Limity |
Uchwyt |
Kolory |
Ramka |
Wysyłanie |
Kierunek |
Dana pomiarowa |

Obiekt SUWAK umożliwia wyświetlenie na masce wskaźnika słupkowego odpowiadającego zmiennej pomiarowej wraz z umieszczonym na nim przesuwalnym uchwytem. Położenie uchwytu suwaka sterowane jest wartością zmiennej sterowanej, ale może być zmieniane przez operatora. Jest obiektem dynamicznym. Jest również obiektem wybieralnym. Po wyselekcjonowaniu obiektu typu SUWAK możliwe jest przesunięcie uchwytu suwaka. Momentowi puszczenia uchwytu towarzyszy zapis do zmiennej sterowanej i wysłanie do sterownika wartości odpowiadającej jego położeniu. Wysłanie wartości może być chronione hasłem.

Poniższy rysunek prezentuje przykładowe obiekty typu SUWAK.

Rysunek: Przykład obiektu SUWAK.

Wymiary

Wymiary obiektu SUWAK są określane przy użyciu myszy.

Parametry

Rysunek: Okno parametryzacji obiektu SUWAK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Limity słupka-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego limitu wyświetlanego słupka. Domyślnie 0.

Limity słupka -do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości górnego limitu wyświetlanego słupka. Domyślnie 100.

Limity uchwytu -od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego limitu wyświetlanego uchwytu słupka. Domyślnie 0.

Limity uchwytu -do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości górnego limitu wyświetlanego uchwytu słupka. Domyślnie 100.

Uchwyt-pełny obszar - pole cechy umożliwiające zadeklarowanie obszaru czułego na selekcję. Ustawienie tego pola powoduje, że kliknięcie myszką w dowolnym punkcie na obszarze obiektu powoduje przestawienie do tego punktu uchwytu. W przeciwnym razie należy kliknąć dokładnie w obszarze uchwytu, a następnie przeciągnąć go w żądane położenie.

Uchwyt-przezroczysty - pole cechy umożliwiające zadeklarowanie przezroczystego uchwytu suwaka (spod uchwytu widoczne jest położenie słupka). W przeciwnym razie uchwyt ma kształt trójwymiarowego klawisza z kreseczką.

Uchwyt-Otoczka - pole liczbowe umożliwiające zadeklarowanie otoczki uchwytu suwaka określonej w pikselach (domyślnie 0). Otoczka pozwala na powiększenie obszaru reagującego na selekcję (istotne dla niewielkich klawiszy).

Kolory-= - pola koloru umożliwiające ustawienie podstawowego koloru słupka (pole lewe) oraz tła (pole prawe) wyświetlanej liczby.

Kolory-? - pola koloru umożliwiające ustawienie koloru słupka (pole lewe) oraz tła (pole prawe) w przypadku błędu.

Kolory-^ - pola koloru umożliwiające ustawienie koloru uchwytu słupka (pole lewe) oraz koloru uchwytu słupka po jego wyselekcjonowaniu (pole prawe).

Kolory-[] - pola koloru umożliwiające ustawienie koloru podświetlenia uchwytu słupka (pole lewe) oraz koloru cienia uchwytu słupka (pole prawe).

Kolory-Tło koloru Okna - pole cechy umożliwiające wymuszenie ustawienie koloru tła słupka zgodnego z kolorem okna.

Ramka-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy słupek powinien posiadać ramkę oraz zadeklarowanie jej koloru.

Ramka-Grubość - pole liczbowe umożliwiające określenie grubości ramki (domyślnie 1).

Wysyłanie-natychamistowe - pole cechy umożliwiające zadeklarowanie natychmiastowego wysłania wartości suwaka (po puszczeniu suwaka).

Wysyłanie-z potwierdzeniem - pole cechy umożliwiające zadeklarowanie wysłania wartości suwaka z dodatkowym potwierdzeniem.

Kierunek - pole wyboru określające kierunek wzrostu słupka. Do wyboru N (w górę), E (w prawo), S (w dół) oraz W (w lewo). Domyślnie E.

Dana pomiarowa - pole tekstowe umożliwiające podanie nazwy danej pomiarowej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku słupek zostaje przekreślony wzdłuż linią o wyspecyfikowanych parametrach. Opcja domyślna.

Błędy pomiarowe - pole cechy umożliwiające sygnalizację błędów pomiarowych. W takim przypadku słupek zostaje pokreskowany w poprzek liniami o wyspecyfikowanych parametrach. Wymaga wyspecyfikowania Danej kontrolnej.

Dana kontrolna - pole tekstowe umożliwiające podanie nazwy danej kontrolnej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Błędy pomiarowe. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Status - pole tekstowe umożliwiające wprowadzenie szesnastkowej maski. Jeśli iloczyn tej maski i danej kontrolnej jest różny od zera wówczas mamy do czynienia z wystąpieniem błędu pomiarowego.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędów oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Dana podglądowa - jeżeli w polu edycyjnym zostanie wprowadzona nazwa zmiennej, to włączony zostanie mechanizm automatycznego ustawiania wartości zmiennej podglądowej w trakcie przesuwania suwaka przez operatora. Wartość ustawiana jest równa wartości , która byłaby wysłana, gdyby operator puścił suwak w danym momencie. Jeżeli suwak nie jest sterowany przez operatora, to wartość zmiennej podglądowej jest mniejsza od dolnego limitu uchwytu. W polu Dana podglądowa można stosować notację #sufiks generacji nazwy zmiennych. Można również pobierać nazwę zmiennej podglądowej z bazy zmiennych z atrybutu PołożenieSuwaka.

Zmienna podglądowa powinna być zadeklarowana w kanale NONE. Jej wartość można wyświetlać obiektem LICZBA, a poprzez właściwe ustawienie atrybutów wyświetlania można spowodować, że podgląd będzie widoczny tylko w momencie przesuwania suwaka.

Uchwyt suwaka może być przezroczysty. W takim przypadku wyświetlane są jedynie obrzeża uchwytu wraz z kreseczką oznaczającą dokładne położenie. Widoczna pozostaje część słupka znajdująca się pod suwakiem. Możliwe jest również użycie uchwytu nieprzezroczystego, podobnego do klawisza trójwymiarowego z kreseczką oznaczającą położenie. Obiekt może być czuły na selekcję w "pełnym obszarze", lub też przesunięcie uchwytu może wymagać wcześniejszej selekcji obszaru uchwytu (z ewentualną możliwą do zadeklarowania otoczką). Suwak może być otoczony ramką.

Wymiary uchwytu dobierane są automatycznie z zależności od wymiarów suwaka. Wyselekcjonowany uchwyt może zmienić kolor na wcześniej zadeklarowany. W przypadku wystąpienia błędu komunikacyjnego obiekt przekreślony zostaje linią o podanym kolorze i grubości wzdłuż kierunku ruchu słupka. Pojawienie się błędu pomiarowego powoduje pokreskowanie słupka w poprzek liniami o parametrach jak wyżej. Dodatkowo słupek może w przypadku wystąpienia jednego z błędów (lub obu naraz) zmienić swoje kolory.

Parametryzacja z bazy

Obiekt SUWAK wyposażony został dodatkowo w cechy umożliwiające ustawienie z bazy zmiennych następujących parametrów:

  • zakres zmienności np. 0, 100 według nazwy zmiennej wyświetlanej,

  • zakres wysyłanych wartości np. 0, 100 według nazwy zmiennej sterowanej,

  • nazwę i maskę danej kontrolnej.

Do tego celu służy przycisk Łącze, którego naciśnięcie powoduje wpis zawartości danego pola w bazie, poprzedzonego znakiem @ na wszystkich pozycjach, które mogą być potencjalnie ustawione z bazy zmiennych.

W poniższym przykładzie naciśnięcie przycisku Łącze spowodowało wpisanie zawartości pól z bazy dla:

  • limitów zmiennej wyświetlanej - wartości 0 - 100

  • limitów wartości zmiennej wysyłanej - wartości 0 - 100

  • danej kontrolnej - zmienna A002?

  • maska danej kontrolnej - 4


19.4.27. Obiekt SYNCHRONIZATOR

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.28. Obiekt SYNCHRONIZATOR

19.4.28. Obiekt SYNCHRONIZATOR

Wymiary

Parametry obiektu

Obiekt SYNCHRONIZATOR jest obiektem niewidocznym. Umożliwia zapisanie do danej sterowanej określonej wartości. Zapis synchronizowany jest akcją WYŚLIJ_STEROWANIA.

Wymiary

Wymiary obiektu SYNCHRONIZATOR są nieistotne (obiekt niewidzialny).

Wykorzystanie obiektu SYNCHRONIZATOR umożliwia optymalizację programu sterownika. Ustawienie określonej zmiennej stanowi dla sterownika informację, że operator współpracuje z określoną maską. W związku z tym jedynie ograniczony podzbiór sterowań może zostać wysłany. Dzięki tej informacji zbędne staje się sprawdzanie w sterowniku wszystkich zmiennych sterowanych.

Parametry

Rysunek: Okno parametryzacji obiektu SYNCHRONIZATOR.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Wartość - pole tekstowe umożliwiające wprowadzenie szesnastkowej wartości (domyślnie 0).


19.4.28. Obiekt TEKST

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.29. Obiekt TEKST

19.4.29. Obiekt TEKST

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Tekst |
Źródło tekstu |
Baza |
Atrybuty |
Wyrównanie |
Widok |
Zakotwiczenie |
Parametry |

Obiekt TEKST umożliwia wyświetlenie na masce tekstu. Jest to obiekt statyczny. Możliwe jest określenie dla niego czcionki i kolorów. Tekst może być wpisany na innym obiekcie (np. OBRAZEK) z zadeklarowanym tłem przezroczystym. Można opcjonalnie użyć identyfikatora tekstu, który deklarowany jest dla pliku konfiguracyjnego projektowanej aplikacji poprzez program Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe,

gdzie tekst definiowany jest poprzez podanie nazwy logicznej tekstu oraz tekstu właściwego, który wyświetlany będzie przez obiekt TEKST.

Takie postępowanie umożliwia wykorzystanie identycznej maski dla różnych (różniących się opisem) aplikacji. Możliwe jest pisanie pionowe (od góry do dołu bez obracania znaków). Nietypowym użyciem obiektu TEKST jest zastosowanie go do wyświetlenia nazwy maski (a dokładniej pliku, w którym maska została umieszczona) po ustawieniu pola "wstawić nazwę maski". Skopiowanie tak sparametryzowanego obiektu na inną maskę powoduje, że zacznie on wyświetlać nazwę nowej maski. Obiekt TEKST wyświetlający nazwę maski ignoruje zawartość pola "tekst".

Wymiary

Wysokość i szerokość uzależniona jest od tekstu oraz wybranej czcionki.

W przypadku pobrania pustego tekstu wysokość obiektu nie ulega zmianie.

Tekst może zostać wpisany (oraz edytowany) bezpośrednio na masce bez otwierania okna dialogowego.

Parametry

Rysunek: Okno parametryzacji obiektu TEKST.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Tekst - jedno lub wielowierszowe pole tekstowe zawierające tekst wpisywany w polu obiektu. Tekst ten może zostać wpisany bezpośrednio na masce. Dopuszczalna liczba znaków wynosi 1000. Przejście do nowej linii następuje po naciśnięciu Shift + ENTER. Klawisz Backspace jest obsługiwany tylko w ramach ostatniej linii wprowadzanego tekstu.

Pole Źródło tekstu

- Wpisany - pole umożliwiające deklarację, że tekst jest wpisywany przez operatora.

- nazwa Maski - pole zadeklarowania, że zamiast tekstu zostanie wstawiona nazwa maski, na której mieści się dany obiekt. Ułatwia to późniejszą edycją i wyszukiwanie masek. Jest ono aktywne tylko dla tekstu jednoliniowego.

- z Bazy zmiennych - pole umożliwiające wyprowadzenie wartości dowolnego atrybutu umieszczonego w bazie zmiennych.

Baza - umożliwia wprowadzenie nazwy zmiennej oraz nazwy wyświetlanego atrybutu zmiennej (istnieje możliwość interaktywnego wyboru nazwy atrybutu z bazy zmiennych).

Pole Atrybuty

- Odpowiednik tekstu - pole deklaracji, czy wyświetlany tekst ma być odpowiednikiem tekstu i w polu Tekst znajduje się jedynie nazwa odpowiednika tekstu, zaś właściwy tekst zdefiniowany jest w pliku konfiguracyjnym aplikacji przy użyciu programu Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe

- Pisać Pionowo - pole to pozwala także zadeklarować pisanie tekstu pionowo (od góry do dołu bez obracania znaków). Jest ono aktywne tylko dla tekstu jednoliniowego.

Wyrównanie - pole wyboru wymuszające wyrównanie napisu w obszarze obiektu do lewej, jego środkowanie lub wyrównanie do prawej.

Widok - wyświetla zadeklarowany tekst, również cieniowany.

Zakotwiczenie - pole cechy deklarujące punkt zaczepienia tekstu na masce. W wypadku zmiany rozmiaru w bazie wyświetlanego tekstu zostanie on poszerzony w prawo, o ile jest zakotwiczony z lewej. Zakotwiczenie z prawej powoduje, że rozszerzy się on w lewo.

Pole Parametry

- Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony tekst. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

- Kolor Linii - pole koloru umożliwiające ustawienie koloru czcionek po wywołaniu okna wyboru koloru.

- Kolor Cienia - pole koloru umożliwiające ustawienie koloru cieniowania czcionek o ile taka opcja została zaznaczona ) po wywołaniu okna wyboru koloru

- Kolor Tła - pole koloru umożliwiające ustawienie koloru tła tekstu po wywołaniu okna wyboru koloru.

- Tło przezroczyste - pole cechy umożliwiające wymuszenie przezroczystego tła tekstu (w przeciwnym razie tekst będzie pisany po istniejącym tle, co również może być użyteczne).

- Tło w koloru Okna - pole cechy umożliwiające wymuszenie wyświetlania tła tekstu w kolorze tła ustawionym dla maski.

- Cieniowanie - pole cechy umożliwiające wymuszenie wyświetlania cieniowanego tekstu.

Odstęp - pole deklaracji odstępu między liniami tekstu (istotny jest tylko dla tekstu wielowierszowego). Domyślnie wynosi 0, co należy interpretować jako odstęp standardowy dla wybranej czcionki. Wpisanie w tym polu wartości dodatniej powoduje zwiększenie odstępu o podaną liczbę pikseli, natomiast podanie wartości ujemnej zmniejszenie odstępu.

Parametryzacja z bazy

Istnieje także możliwość wyprowadzania wartości dowolnego atrybutu umieszczonego w bazie zmiennych.

Pole Baza, umożliwia wpisanie nazwy zmiennej oraz nazwy atrybutu. Naciskając prawy klawisz myszy w polu nazwa można przejść do okna wyboru zmiennej. W polu atrybut należy wpisać nazwę atrybutu. Może to być dowolny istniejący atrybut. W typowych zastosowaniach przewiduje się użycie atrybutów tekstowych typu Nazwa, Opis czy Jednostka. Mogą to być jednak również atrybuty liczbowe jak np. ZakresFunkcjiAsmenLo i wtedy zawartość będzie automatycznie skonwertowana do postaci tekstowej.

Aby obiekt wyświetlał wartość atrybutu z bazy należy w polu wyboru Źródło tekstu zaznaczyć pozycję z Bazy zmiennych. Tekst z bazy zmiennych może być również pisany pionowo. Obiekt TEKST wyświetlający zawartość pola bazy ignoruje zawartość pola tekst.


19.4.29. Obiekt TEKSTY

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.30. Obiekt TEKSTY

19.4.30. Obiekt TEKSTY

Wymiary | Sposoby kodowania
Parametry obiektu | Przykład kodowania
Nazwa Obiektu | Parametryzacja z bazy
Tekst |
Stan |
Lista tekstów |
Kodowanie |
Wyrówn. |
W pionie |
Wysyłanie |
Maska bitowa |
Dana monitorowana |
Parametry |

Obiekt TEKSTY umożliwia wyświetlenie na masce jednego z wielu (do 17) wyspecyfikowanych tekstów. Teksty mogą być wyświetlane pionowo. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Wybrany do wyświetlenia tekst oraz jego atrybuty (kolor, czcionka, sposób wyjustowania, migotanie) zależą od wartości zmiennej monitorowanej.

Opcjonalnie obiekt TEKSTY może być także obiektem wybieralnym i może służyć do wysyłania określonej wartości do zmiennej sterującej. Wysłanie wartości może być chronione hasłem.

Zamiast tekstów można użyć identyfikatorów tekstów zadeklarowanych za pomocą Architekta w pliku konfiguracyjnym aplikacji:

Moduł Maski > zakładka Parametry tekstowe

Jeśli zamiast tekstów użyte zostaną identyfikatory tekstów, należy pamiętać o włączeniu opcji Odpowiednik tekstów w oknie parametryzacji obiektu TEKSTY.

Rysunek : Przykład obiektu TEKSTY.

Takie postępowanie umożliwia wykorzystanie identycznej maski dla różnych (różniących się opisem) aplikacji.

Wymiary

Wymiary obiektu TEKSTY są określane na podstawie zawartości tekstu oraz zastosowanej czcionki. W celu określenia wymiaru przeglądane są wszystkie mogące zostać wyświetlone teksty. Tak określony wymiar obiektu jest wymiarem minimalnym i może zostać powiększony przy pomocy myszy. Próba zmniejszenia obiektu poniżej wymiarów minimalnych jest nieskuteczna.

Parametry

Rysunek: Okno parametryzacji obiektu TEKSTY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Tekst - pole tekstowe zawierające tekst wyselekcjonowanego stanu.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych tekstów. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi tekstami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji Listy tekstów.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Wyrówn.-w lewo - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do lewej. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Wyrówn.-środek - pole wyboru wymuszające środkowanie tekstu w obszarze obiektu. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Wyrówn.-w prawo - pole wyboru wymuszające wyrównanie tekstu w obszarze obiektu do prawej. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

W pionie-w górę - pole wyboru justacji pionowej do górnej krawędzi pola zajmowanego przez obiekt. Justacja indywidualna dla każdego ze stanów (tekstów), nie zalezy od kierunku pisania.

W pionie-środek - pole wyboru justacji pionowej z wyśrodkowaniem w pionie w polu zajmowanym przez obiekt. Justacja indywidualna dla każdego ze stanów (tekstów), nie zalezy od kierunku pisania.

W pionie-w dół - pole wyboru justacji pionowej do dolnej krawędzi pola zajmowanego przez obiekt. Justacja indywidualna dla każdego ze stanów (tekstów), nie zależy od kierunku pisania.

Lista tekstów - lista tekstów odpowiadających poszczególnym stanom obiektu. Zmiany tekstu można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie wpisaniu w polu Tekst nowego tekstu i naciśnięciu klawisza Enter. Próba zadeklarowania tekstu dla nieistniejącego stanu jest nieskuteczna. Mając zdefiniowane stany, można zmienić ich kolejność przy jednoczesnym użyciu klawisza Ctrl i strzałki  lub .

Atrybuty

Odpowiednik tekstu - pole cechy informujące, że na liście tekstów znajdują się jedynie nazwy odpowiedników tekstów, zaś właściwe teksty umieszczone są w pliku konfiguracyjnym aplikacji za pomocą Architekta: Obszary i komputery > Maski > Parametry Tekstowe - gdzie określane są parametry tekstowe definiowane za pomocą nazw logicznych i odpowiadających im tekstów właściwych.

Pisać Pionowo - pole cechy informujące, że tekst powinien być pisany pionowo (od góry do dołu bez obracania znaków).

Wspólny tekst - załączona opcja oznacza, że dla wszystkich stanów ma być wyświetlany ten sam tekst (pobierany z definicji stanu pierwszego). Dodatkowo, dla obiektów spełniających warunek: obiekt dwustanowy, ustawiona opcja Wspólny tekst, kodowanie naturalne - tekst pierwszego stanu pobierany jest z bazy definicji zmiennych (jako wartość stanu stosowana jest wartość parametru Pierwszy bit).

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającego jej tekstu przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany - w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu tekstowi.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającego jej tekstu przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu tekstowi.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-”.

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką - dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Parametry-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlony tekst odpowiadający danemu stanowi. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Parametry-Kolor/Cień/Tło - pola koloru umożliwiające ustawienie koloru tekstu (pole lewe), cieniowania (o ile zostało zadeklarowane) oraz koloru tła tekstu (pole prawe) odpowiadającego danemu stanowi. Po wyselekcjonowaniu tego pola wyświetlone zostaje okno wyboru koloru. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Parametry-Tło koloru okna - pole cechy umożliwiające wymuszenie ustawienia koloru tła tekstu zgodnego z kolorem okna. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Parametry-Tło przezroczyste - pole cechy umożliwiające wymuszenie ustawienia przezroczystego tła. Możliwe jest indywidualne ustawienie tego pola dla każdego tekstu.

Cieniowanie - pole cechy deklarujące cieniowanie tekstu zgodnie ze zdefiniowanym kolorem w pozycji Parametry-Kolor/Cień /Tło.

Odstęp - deklaracja odstępu pomiędzy wierszami tekstu wieloliniowego.

Tekst wpisuje się do listy pokazując odpowiednie miejsce kursorem myszy. Wskazanie tekstu na liście powoduje jego wyświetlenie w specjalnym polu okna dialogowego. Ustawione atrybuty wyświetlania tekstu (czcionka, środkowania i kolory) przypisane będą do konkretnego tekstu wskazanego na liście.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są poziomym przekreśleniem tekstu linią o podanym kolorze i grubości.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu. Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych tekstów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji ze sterowaniem). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Sposoby kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-” oznacza bit nieistotny, zaś "x” oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery teksty np. "1”, "2”, "3” i "4” (w tej kolejności) to stanowi "00” będzie odpowiadać tekst "1”, stanowi "01” tekst "2” itd. W przypadku zapisu, jeśli wybrana zostanie tekst "4” to odpowiadający mu stan czyli "11” na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający numerowi wybranego obrazka.

1000000000100000 / zmienna przeczytana

1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-”

----------11---- / bity ustawiane przez obiekt

1000000000110000 / zmienna wysyłana

Parametryzacja z bazy

Obiekt TEKSTY wyposażony został w cechy umożliwiające ustawienie z bazy definicji zmiennych listy tekstów oraz wartości masek bitowych dla poszczególnych stanów.

W przypadku parametryzowania obiektu TEKSTY z bazy należy w pierwszej kolejności odpowiednio przygotować bazę definicji zmiennych - tak aby znalazły się w niej atrybuty obsługujące definicje stanów. Są to następujące atrybuty:

Nazwy stanów - nazwa zbioru stanów lub bezpośrednio zbiór opisów stanów zmiennej;

Zestaw stanów - nazwa zbioru stanów, do którego należy bieżący wiersz; atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów;

Wartość stanu - wartość maski bitowej wyrażona w systemie dziesiętnym dla stanu, którego opis zawiera bieżący wiersz (dla kodowania binarnego wartość stanu odpowiada numerowi stanu w oknie parametryzacji obiektu TEKSTY); atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów.

Należy zdefiniować tyle zmiennych, ile jest stanów danej zmiennej monitorowanej. Każda taka zmienna musi mieć zadeklarowany tekst, który będzie wyświetlany dla danego stanu, wartość stanu oraz nazwę zestawu stanów. Zmienne te powinny mieć włączony atrybut Zmienna nieaktywna.

Wszystkie zmienne z tekstami stanów należy powiązać ze zmienną monitorowaną za pomocą wspólnej nazwy zestawu stanów - którą dla zmiennej monitorowanej należy zadeklarować jako wartość atrybutu Nazwy stanów, a dla zmiennych z tekstami stanów jako wartość atrybutu Zestaw stanów. Teksty, które mają być wyświetlane na maskach technologicznych aplikacji należy zapisać jako wartości atrybutu Opis dla poszczególnych zmiennych odpowiadających wartościom stanów zmiennej monitorowanej. Patrz: rysunek poniżej.

Rysunek: Przykładowa deklaracja zmiennych z definicją stanów dla obiektu TEKSTY.

I przypadek: Parametryzacja obiektu pustego, dla którego zaciągane są z bazy teksty i wartości wszystkich stanów zmiennej monitorowanej

W tym przypadku obiekt TEKSTY dla danej zmiennej monitorowanej pobiera z bazy definicji zmiennych wartości masek bitowych i teksty wszystkich stanów. Wystarczy w oknie parametryzacji obiektu TEKSTY podać nazwę zmiennej monitorowanej i nacisnąć przycisk Łącze, a zostaną pobrane z bazy wartości poszczególnych stanów i zadeklarowana dla nich lista tekstów. Wtedy można przystąpić do definiowania pozostałych parametrów obiektu.

II przypadek: Pobieranie z bazy jedynie brakujących tekstów dla uprzednio zadeklarowanych stanów zmiennej monitorowanej

W takiej sytuacji obiekt TEKSTY w pierwszej kolejności jest parametryzowany ręcznie - definiowana jest: liczba stanów, maski bitowe dla wszystkich zadeklarowanych stanów oraz wybrane teksty. Do tak sparametryzowanego obiektu istnieje możliwość pobrania brakujących tekstów z bazy definicji zmiennych - wystarczy w oknie parametryzacji obiektu TEKSTY użyć przycisku Łącze. Teksty pobierane są z rekordów zmiennych zawierających teksty stanów dla określonej zmiennej monitorowanej na podstawie wartości pola Wartość stanu.


19.4.30. Obiekt TEST ODŚWIEŻANIA

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.31. Obiekt TEST ODŚWIEŻANIA

19.4.31. Obiekt TEST ODŚWIEŻANIA

Wymiary

Parametry obiektu

Obiekt TEST ODŚWIEŻANIA jest obiektem służącym do testów. Umożliwia zorientowanie się jaka jest częstotliwość odświeżania danej maski (albo inaczej jak często obiekty na masce mogą zostać odrysowane). Wynik jest wyświetlany. Wynik testu świadczyć może o powolnym komputerze lub też o zbyt wielkiej liczbie obiektów umieszczonych na masce.

Wymiary

Wymiary obiektu TEST ODŚWIEŻANIA wynikają z liczby znaków oraz domyślnej czcionki (dialog).

Obiekt służy do kontroli masek w czasie testowania. Na masce wyświetlane są dwie liczby w formacie nn (nn). Liczby te należy interpretować jako ilość odświeżeń maski w okresie 15 sekund. Pierwsza liczba (cały czas inkrementująca się) to wynik bieżącego testu. Liczba w nawiasach to wynik testu poprzedniego. Wynik gorszy niż 15 (czyli mniej niż jedno odświeżenie na sekundę) należy uważać za wynik kiepski. Obiekt TEST ODŚWIEŻANIA w aplikacjach powinien zostać usunięty.

Parametry

Rysunek: Okno parametryzacji obiektu TEST ODŚWIEŻANIA.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.


19.4.31. Obiekt WIELOKĄT i WIELOKĄT PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.32. Obiekt WIELOKĄT i WIELOKĄT PP

19.4.32. Obiekt WIELOKĄT i WIELOKĄT PP

Wymiary

Parametry obiektu

Obiekty WIELOKĄT oraz WIELOKĄT PP umożliwiają wyświetlenie na masce statycznych wielokątów. W przypadku obiektu WIELOKĄT PP łamana ograniczająca wielokąt może składać się jedynie z linii wzajemnie równoległych lub prostopadłych.

Rysunek: Przykład obiektu WIELOKĄT.

Wymiary

Współrzędne wierzchołków odcinków podaje się przy pomocy myszy. Koniec linii tworzącej wielokąt zaznacza się prawym klawiszem myszy.

Obiekty typu WIELOKĄT mogą być obracane w pionie i w poziomie przy pomocy odpowiednich komend edycyjnych.

Parametry

Rysunek: Okno parametryzacji obiektu WIELOKĄT.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolor Linii - pole koloru umożliwiające ustawienie koloru linii otaczającej wielokąt po wywołaniu okna wyboru koloru.

Kolor Wypełnienia - pole koloru umożliwiające ustawienie koloru wnętrza wielokąta po wywołaniu okna wyboru koloru.

Wypełnić Wnętrze - pole cechy umożliwiające wypełnienie wnętrza wielokąta.

Wypełnienie w Kolorze Okna - pole cechy umożliwiające wymuszenie rysowania wnętrza wielokąta w kolorze tła ustawionym dla maski.


19.4.32. Obiekt WIELOKĄTY i WIELOKĄTY PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.33. Obiekt WIELOKĄTY i WIELOKĄTY PP

19.4.33. Obiekt WIELOKĄTY i WIELOKĄTY PP

Wymiary | Systemy kodowania
Parametry obiektu | Przykład kodowania
Nazwa Obiektu |
Parametry |
Wysyłanie |
Stan |
Linia |
Tło |
Migot. |
Kodowanie |
Dana monitorowana |
Maska bitowa |

Obiekty WIELOKĄTY oraz WIELOKĄTY PP umożliwiają wyświetlenie na masce wielokątów. W przypadku obiektu WIELOKĄTY PP łamana ograniczająca wielokąt może składać się jedynie z linii wzajemnie równoległych lub prostopadłych. Wyświetlany wielokąt może zmieniać swój kolor w zależności od stanu zmiennej monitorowanej. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Opcjonalnie obiekt WIELOKĄTY może być także obiektem wybieralnym i może służyć do wysyłania określonej zawartości do zmiennej sterowanej. Wysłanie wartości może być chronione hasłem.

Wymiary

Współrzędne początku i końca odcinków składowych podaje się przy pomocy myszki, zaś zakończenie wielolinii następuje po naciśnięciu prawego przycisku myszy.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są ukośnym przekreśleniem linią w wyspecyfikowanym kolorze.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (kolor). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Obiekty typu WIELOKĄT mogą być obracane w pionie i w poziomie przy pomocy odpowiednich komend edycyjnych.

Parametry

Rysunek: Okno parametryzacji obiektu WIELOKĄTY.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-Wypełnić Wnętrze - pole cechy umożliwiające zadeklarowanie wypełniania wnętrza wielokąta.

Parametry-w Kolorze Okna - pole cechy umożliwiające wymuszenie ustawienia koloru wnętrza wielokąta zgodnego z kolorem tła maski.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającego jej wielokąta przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany - w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu wielokątowi.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającego jej wielokąta przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem), a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonemu wielokątowi.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jeden z wielu zadeklarowanych wielokątów. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi wielokątami w słowie. Pierwszy bit określa najmłodszy bit w grupie, zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji jednej z dwu list kolorów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Linia - lista kolorów odpowiadających poszczególnym liniom stanowiącym obrzeże wielokątów. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Tło - lista kolorów odpowiadających wnętrzom poszczególnych wielokątów. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Migot. - lista indykatorów migotania otwierających okienko do ustawiania atrybutu migotania dla każdego ze stanów.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką - dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Kolor linii - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji. Wybranie tego pola powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są zmianą koloru.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany kolorem linii obwiedni oraz wnętrza). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych wielokątów oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji ze sterowaniem). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Systemy kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery wielokąty np. gwiazdkę żółtą, zieloną, niebieską i czerwoną (w tej kolejności) to stanowi "00" będzie odpowiadać gwiazdka żółta, stanowi "01" gwiazdka zielona itd. W przypadku zapisu, jeśli wybrana zostanie gwiazdka czerwona to odpowiadający jej stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający kolorowi wybranej linii.

1000000000100000 / zmienna przeczytana

1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"

----------11---- / bity ustawiane przez obiekt

1000000000110000 / zmienna wysyłana


19.4.33. Obiekt WIELOLINIA i WIELOLINIA PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.34. Obiekt WIELOLINIA i WIELOLINIA PP

19.4.34. Obiekt WIELOLINIA i WIELOLINIA PP

Wymiary

Parametry obiektu

Nazwa obiektu

Szerokość linii

Typ

Kolor linii

Kolor przerwy

Przerwa

Rodzaj wzorca

Definicja własnego

Zaokrąglenia końców linii

Obiekt WIELOLINIA oraz WIELOLINIA PP umożliwiają wyświetlenie na masce ciągu odcinków. Odcinki te mogą być pionowe lub poziome w przypadku WIELOLINII PP. Jest to obiekt statyczny. Możliwe jest określenie koloru i grubości kreski.

Wymiary

Współrzędne początku i końca odcinka podaje się przy pomocy myszki. Koniec linii tworzącej wielokąt zaznacza się prawym klawiszem myszy.

Parametry

Okno parametryzacji obiektu WIELOLINIA jest takie samo jak w przypadku obiektu LINIA.

Rysunek: Okno parametryzacji obiektu LINIA.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Szerokość Linii - pole liczbowe umożliwiające podanie szerokości linii w pikselach. Dla linii przerywanych dopuszczalne są jedynie szerokości nieparzyste.

Typ-normalna - pole wyboru umożliwiające wybór normalnej (ciągłej) linii.

Typ-przerywana - pole wyboru umożliwiające wybór przerywanej linii.

Typ-normalna w trybie XOR - pole wyboru umożliwiające wybór normalnej (ciągłej) linii rysowanej w trybie XOR (tzn. takiej, której kolor wyznaczany jest jako wynik operacji XOR i tła, na którym jest ona rysowana.

Kolor Linii - pole koloru umożliwiające wybór koloru linii. Po jego wybraniu pojawia się okno wyboru kolorów.

Kolor Przerwy iwiające wy linii przerywanej, w którym przerwa będzie przezroczysta.

Rodzaj wzorca - pole wyboru umożliwiające wybór wzorca dla linii przerywanej (do wyboru jest kilka wzorców oraz wzorzec własny deklarowany w polu następnym). Domyślnym wzorcem jest linia ciągła.

Definicja własnego - pole tekstowe umożliwiające wybór własnego wzorca lub też wyświetlenie wzorca standardowego. Wzorzec wyświetlany jest jako liczba szesnastkowa, której kolejne bity odpowiadają kolejnym punktom linii. (dla linii ciągłej np. wyświetlany jest wzorzec "ffff"). W przypadku wybrania własnego wzorca (wykorzystując opcję Rodzaj wzorca) pole to można edytować.

Zaokrąglenia końców linii - pole cechy umożliwiające zaokrąglanie końców linii. Możliwe tylko w przypadku linii przerywanych.

Obiekty typu WIELOLINIA mogą być obracane w pionie i w poziomie przy pomocy odpowiednich komend edycyjnych. Kolor linii "rysowanej w trybie XOR" ustalany jest jako różnica symetryczna zadeklarowanego koloru linii oraz koloru tła. Powoduje to, że linia zawsze będzie widoczna, zaś przechodząc przez różnego koloru tła automatycznie zmieni kolor.


19.4.34. Obiekt WIELOLINIE i WIELOLINIE PP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.35. Obiekt WIELOLINIE i WIELOLINIE PP

19.4.35. Obiekt WIELOLINIE i WIELOLINIE PP

Wymiary | Przykład kodowania
Parametry obiektu |
Nazwa Obiektu |
Parametry |
Wysyłanie |
Stan |
Linia |
Migot. |
Kodowanie |
Dana monitorowana |
Maska bitowa |

Obiekty WIELOLINIE oraz WIELOLINIE PP umożliwiają wyświetlenie na masce linii łamanych. W przypadku obiektu WIELOLINIE PP łamana może składać się jedynie z linii wzajemnie równoległych lub prostopadłych. Wyświetlana linia łamana może zmieniać swój kolor i migotać w zależności od stanu danej monitorowanej. Jest to obiekt dynamiczny (o ile posiada więcej niż jeden stan). Opcjonalnie obiekty WIELOLINIE i WIELOLINIE PP mogą być także obiektami wybieralnymi i mogą służyć do wysyłania określonej wartości do zmiennej sterowanej. Wysłanie wartości może być chronione hasłem.

Wymiary

Współrzędne początku i końca odcinków składowych podaje się przy pomocy myszki, zaś zakończenie wielolinii następuje po naciśnięciu prawego przycisku myszy.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są ukośnym przekreśleniem linią w wyspecyfikowanym kolorze.

Obiekty typu WIELOLINIE mogą być obracane w pionie i w poziomie przy pomocy odpowiednich komend edycyjnych.

Parametry

Rysunek: Okno parametryzacji obiektu LINIE.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Parametry-szerokość linii - pole liczbowe umożliwiające zadeklarowanie szerokości linii.

Parametry-linia w trybie XOR - pole cechy umożliwiające wymuszenie kreślenia linii w trybie XOR. Kolor linii "rysowanej w trybie XOR" ustalany jest jako różnica symetryczna zadeklarowanego koloru linii oraz koloru tła. Powoduje to, że linia zawsze będzie widoczna, zaś przechodząc przez różnego koloru tła automatycznie zmieni kolor.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu odpowiadającej wielolinii przez kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem). Ten typ wysyłania jest sensowny, jeśli obiekt ma dwa stany - w przeciwnym razie przeglądanie stanu obiektu następujące w wyniku wybierania kolejnych stanów spowoduje wysłanie serii wartości. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej elipsie.

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu odpowiadającej wielolinii przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski (możliwe tylko, jeśli obiekt został sparametryzowany ze sterowaniem) a następnie potwierdzenie. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Ten typ wysyłania jest sensowny, jeśli obiekt ma większą liczbę stanów. Wysyłaną przez obiekt wartością jest numer stanu odpowiadający wyświetlonej wielolinii.

Stan-Liczba stanów - pole liczbowe umożliwiające zadeklarowanie liczby stanów obiektu. Domyślnie obiekt ma 1 stan i jest wtedy obiektem statycznym. Maksymalna liczba stanów wynosi: 33 dla kodowania naturalnego, 64 dla kodowania binarnego i dowolnego. Poszczególnym stanom odpowiadają wartości wynikające z wybranego sposobu kodowania.

Stan-Pierwszy bit - pole liczbowe umożliwiające zadeklarowanie pierwszego (najmłodszego) bitu danej monitorowanej, której wartość jest wyświetlana jako jedna z wielu zadeklarowanych wielolinii. Zawartość tego pola (istotna tylko dla naturalnego oraz binarnego sposobu kodowania) umożliwia jednoznaczne określenie położenia grupy bitów sterującej wyświetlanymi wieloliniami w słowie. Pierwszy bit określa najmłodszy bit w grupie zaś wielkość grupy określa sposób kodowania.

Stan-Numer stanu - pole liczbowe umożliwiające jedynie wyświetlenie wybranego numeru stanu. Wyboru stanu dokonuje się poprzez kliknięcie na odpowiedniej pozycji jednej na liście kolorów.

Maska bitowa - pole liczbowe umożliwiające wyświetlenie zmiennej monitorowanej (a jednocześnie zmiennej, która może zostać wysłana z obiektu, o ile został on sparametryzowany Ze sterowaniem) odpowiadającej danemu stanowi. W trybie kodowania dowolnego maskę można ustawić wpisując kod szesnastkowy lub binarny odpowiadający danemu stanowi z ewentualnym zaznaczeniem bitów o wartości dowolnej symbolem "-".

Dla ułatwienia w przypadku stosowania kodowania dowolnego do zdefiniowania stanu służy okno 'Koder’, prezentowane na poniższym rysunku:

Rysunek: Okno 'Koder'.

W polu Liczba stanów podaje się liczbę stanów rozpoznawanych przez obiekt. Wartość ta może być ustawiona również w głównym oknie definiującym obiektu. W polu Numer stanu wybiera się stan, którego kodowanie należy zdefiniować. W momencie wybrania numeru w ramce Bitowo pokazywane jest bieżące kodowanie stanu. Aby go zmienić należy kliknąć myszką na wartościach bitów. Kolejne kliknięcia powodują zmianę wartości w sekwencji:

- - wartość bitu nie ma znaczenia

1 - bit musi być ustawiony

0 - bit musi być wyzerowany

Kodowanie stanu zostanie automatycznie zapamiętane w momencie wyboru innego stanu.

Pola Dziesiętnie i Szesnastkowo pokazują dziesiętną i szesnastkową wartość definiowanego stanu. Mogą też służyć do ustawiania wartości stanów.

Linia - lista kolorów odpowiadających poszczególnym liniom. Zmiany koloru można dokonać po wybraniu odpowiedniej pozycji na liście, a następnie naciśnięciu klawisza Enter. Pojawi się wówczas okno wyboru kolorów. Próba zadeklarowania koloru dla nieistniejącego stanu jest nieskuteczna. Numery stanów (od 0 do n) wyświetlane są na liście kolorów w kolorze czarnym.

Migot. - lista indykatorów migotania otwierających okienko do ustawiania atrybutu migotania dla każdego ze stanów.

Kodowanie-Kod naturalny - pole wyboru umożliwiające wybranie naturalnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod binarny - pole wyboru umożliwiające wybranie binarnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Kodowanie-Kod dowolny - pole wyboru umożliwiające wybranie dowolnego sposobu kodowania (sposoby kodowania zostały omówione po liście parametrów).

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy nie jest konieczne, jeżeli została wybrana opcja Bez monitorowania. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Ze sterowaniem. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Bez monitorowania - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby stan wyświetlany nie był zależny od jakiejkolwiek zmiennej systemowej i służył jedynie do indykacji wartości, która ma zostać wysłana.

Ze sterowaniem - pole cechy umożliwiające sparametryzowanie obiektu w taki sposób, aby wartość odpowiadająca jego stanowi mogła być wysłana do zmiennej systemowej. Wysłanie wartości następuje po wybraniu obiektu np. przez kliknięcie myszką - dalszy jego przebieg zależny jest od trybu wysyłania.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Kolor linii - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji. Wybranie tego pola powoduje wyświetlenie okna wyboru koloru.

Ramka selekcji - pole cechy umożliwiające dodatkowe wyświetlenie tzw. ramki selekcji (obwódki obiektu) po jego wyselekcjonowaniu w trakcie odświeżania maski. Ramka ta pozwala łatwo zorientować się, który obiekt został ostatnio wyselekcjonowany.

Domyślnie obiekt ma jedynie jeden stan i jest wtedy obiektem statycznym. Błędy komunikacji sygnalizowane są zmianą koloru.

Obiekt w trakcie odświeżania można wyselekcjonować kursorem myszy lub przyciskiem Tab (Shift+Tab). Po selekcji należy kursorem myszy lub klawiszem Enter wybrać żądany stan obiektu (sygnalizowany kolorem linii obwiedni oraz wnętrza). Wysłanie stanu następuje automatycznie po wyselekcjonowaniu lub po potwierdzeniu. Potwierdzenia wysłania można dokonać naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Można zaniechać selekcji naciskając klawisz Esc lub prawy klawisz myszy.

Możliwe jest użycie funkcji przeliczającej, której wartości są indeksami kolejnych kolorów wielolinii oraz drugiej funkcji przeliczającej zamieniającej numer stanu obiektu na wysyłaną wartość (dotyczy to opcji ze sterowaniem). Możliwe jest również dekodowanie wartości monitorowanej zmiennej stałoprzecinkowej (oraz kodowanie ewentualnie wysyłanych wartości) przy użyciu jednej z trzech wbudowanych wewnątrz obiektu strategii.

Sposoby kodowania

Kodowanie naturalne

Sprawdzana jest grupa bitów. Liczba bitów jest równa liczbie stanów, zaś numer najmłodszego bitu określa przesunięcie. Grupa bitów może zawierać co najwyżej jedną jedynkę. Numer stanu wyznaczany jest jako pozycja jedynki wewnątrz grupy bitów (najmłodsza pozycja ma numer 1). Stan zerowy odpowiada grupie samych zer.

Kodowanie binarne

Sprawdzana jest grupa bitów. Liczba bitów jest równa logarytmowi dwójkowemu z liczby stanów, zaś numer najmłodszego bitu określa przesunięcie. Numer stanu wyznaczany jest jako zawartość testowanej grupy bitów.

Kodowanie dowolne

Sprawdzane jest całe słowo. Nieistotny jest parametr przesunięcie. Każdemu stanowi użytkownik przyporządkowuje ciąg zer i jedynek (z możliwością zamaskowania bitu znakiem '-'). Numer stanu wyznaczany jest jako pierwszy ze stanów, któremu użytkownik na odpowiednich pozycjach przyporządkował identyczne bity (z pominięciem bitów zamaskowanych).

Dla obiektów sparametryzowanych ze sterowaniem możliwe jest użycie opcji najpierw czytaj. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej odczytanej ze sterownika z wyzerowanymi bitami ustawianymi przez obiekt.

Przykład kodowania

Obiekt posiada cztery stany i wybrane zostało kodowanie binarne. Na zakodowanie czterech binarnych stanów (00,01,10,11) potrzebna jest dwu-bitowa grupa w słowie. Pierwszy (najmłodszy) bit grupy określa zawartość pola Stan-Pierwszy bit. Jeśli jest on równy np. 4 wtedy jedynie stan piątego i szóstego bitu wpływa na stan obiektu. Pozostałe bity nie mają wpływu na wyświetlanie obiektu co zilustrowane zostało poniżej.

----------xx----

("-" oznacza bit nieistotny, zaś "x" oznacza bit wpływający na stan obiektu)

Jeżeli zdefiniujemy odpowiadające tym czterem stanom, cztery wielolinie np. żółtą, zieloną, niebieską i czerwoną (w tej kolejności) to stanowi "00" będzie odpowiadać wielolinia żółta, stanowi "01" wielolinia zielona itd. W przypadku zapisu, jeśli wybrana zostanie wielolinia czerwona to odpowiadający jej stan czyli "11" na piątym i szóstym bicie czyli dziesiętnie liczba 48 zostanie wysłana do zmiennej. W przypadku ustawienia pola najpierw czytaj mechanizm ten działa nieco inaczej - najpierw czytana jest dana zmienna, następnie zerowany będzie jej piąty i szósty bit po czym na bity te zostanie wpisany stan odpowiadający kolorowi wybranej wielolinii.

1000000000100000 / zmienna przeczytana

1000000000--0000 / zmienna przeczytana z wyzerowanymi bitami "-"

----------11---- / bity ustawiane przez obiekt

1000000000110000 / zmienna wysyłana


19.4.35. Obiekt WSKAŹNIK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.36. Obiekt WSKAŹNIK

19.4.36. Obiekt WSKAŹNIK

Wymiary | Parametryzacja z bazy
Parametry obiektu |
Nazwa Obiektu |
Kolory |
Skala |
Zakresy |
Kąty |
Ramka |
Kierunek |
Dana pomiarowa |
Wygląd |

Obiekt WSKAŹNIK umożliwia wyświetlenie na masce wskaźnika analogowego (kołowego) wyświetlającego zmienną systemową. Jest obiektem dynamicznym zmieniającym się w takt zmian odpowiadającej mu zmiennej pomiarowej. WSKAŹNIK może zmieniać kolory oraz posiadać naniesione znaczniki odpowiadające określonym wartościom stałym lub zmiennym. Elementem wskazującym może być klasyczna wskazówka (wskazówki), łuk lub wycinek okręgu. Obiekt staje się wybieralny, jeśli posiada dwie wskazówki nie zapisuje jednak żadnych zmiennych.

Rysunek: Przykład obiektu WSKAŹNIK.

Wymiary

Wymiary obiektu WSKAŹNIK są określane przy pomocy myszy. Obiekt tego typu nie może być elipsą.

Parametry

Rysunek: Okno parametryzacji obiektu WSKAŹNIK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Kolory->> - pola koloru umożliwiające ustawienie koloru wskaźnika (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy alarmowej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-> - pola koloru umożliwiające ustawienie koloru wskaźnika (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy ostrzegawczej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-= - pola koloru umożliwiające ustawienie podstawowego koloru wskaźnika (pole lewe) oraz tła (pole prawe) wyświetlanej liczby. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-? - pola koloru umożliwiające ustawienie koloru wskaźnika (pole lewe) oraz tła (pole prawe) w przypadku błędu. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-< - pola koloru umożliwiające ustawienie koloru wskaźnika (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy ostrzegawczej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-<< - pola koloru umożliwiające ustawienie koloru wskaźnika (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy alarmowej. Indykator na prawo od pól koloru umożliwia ustawienie atrybutu migotania.

Kolory-^| - pola koloru umożliwiające ustawienie koloru skali (pole prawe) oraz znaczników (pole lewe).

Kolory-Tło koloru Okna - pole cechy umożliwiające wymuszenie ustawienie koloru tła wskaźnika zgodnego z kolorem okna.

Skala-punkty skali - pole liczbowe umożliwiające zadeklarowanie skali składającej się z podanej liczby znaczników (domyślnie 0 co oznacza brak skali).

Skala-szerokość wsk. - pole liczbowe umożliwiające zadeklarowanie szerokości wskazówki ewentualnie łuku (domyślnie 1).

Skala- szerokość pkt. - pole liczbowe umożliwiające zadeklarowanie szerokości znacznika skali (domyślnie 1).

Zakresy-X>> - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 90. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-X> - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 75. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości lub nazwy zmiennej odpowiadającej dolnemu zakresowi wskaźnika. Domyślnie 0.

Zakresy-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości lub nazwy zmiennej odpowiadającej górnemu zakresowi wskaźnika. Domyślnie 100.

Zakresy-X< - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 25. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Zakresy-X<< - pole cechy oraz pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 10. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części. Pole cechy wymusza rysowanie znacznika.

Kąty-Początek - pole liczbowe umożliwiające ustawienie kąta początkowego zakresu wskaźnika w stopniach (domyślnie 0).

Kąty-Koniec - pole liczbowe umożliwiające ustawienie kąta końcowego zakresu wskaźnika w stopniach (domyślnie 360).

Ramka-Ramka - pole cechy oraz pole koloru umożliwiające określenie czy wskaźnik powinien posiadać ramkę oraz zadeklarowanie jej koloru.

Ramka-Grubość - pole liczbowe umożliwiające określenie grubości (domyślnie 1).

Kierunek - pole wyboru określające kierunek obrotu wskaźnika. Do wyboru R (w prawo), L (w lewo). Domyślnie R.

Dana pomiarowa - pole tekstowe umożliwiające podanie nazwy danej pomiarowej. Podanie tej nazwy jest konieczne. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych. W takim przypadku wskaźnik zostaje przekreślony na krzyż dwiema liniami o wyspecyfikowanych parametrach. Opcja domyślna.

Błędy pomiarowe - pole cechy umożliwiające sygnalizację błędów pomiarowych. W takim przypadku wskaźnik zostaje zakreślony przez wrysowanie w jego wnętrzu okręgu o wyspecyfikowanych parametrach. Wymaga wyspecyfikowania Danej kontrolnej.

Dana kontrolna - pole tekstowe umożliwiające podanie nazwy danej kontrolnej. Podanie tej nazwy jest konieczne, jeżeli została wybrana opcja Błędy pomiarowe. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej kontrolnej przy wykorzystaniu notacji ze znakiem #. Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Status - pole tekstowe umożliwiające wprowadzenie szesnastkowej maski. Jeśli iloczyn tej maski i danej kontrolnej jest różny od zera, wówczas mamy do czynienia z wystąpieniem błędu pomiarowego.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Wygląd-Wskazówka - pole wyboru umożliwiające wybór trybu pracy z jedną wskazówką.

Wygląd-Wskazówki - pole wyboru umożliwiające wybór trybu pracy z dwoma wskazówkami (druga ze wskazówek pełni wtedy rolę wskazówki zapamiętującej maksymalne wartości i jej położenie może być przez operatora kasowane).

Wygląd-Wycinek - pole wyboru umożliwiające wybór trybu pracy z wycinkiem okręgu pełniącym rolę indykatora.

Wygląd-Łuk - pole wyboru umożliwiające wybór trybu pracy z łukiem wydłużającym się w takt zmian wyświetlanej wielkości.

Teksty puste i złożone z samych spacji są dopuszczalne w polach ograniczeń i są traktowane jako rezygnacja ze sprawdzania.

Wyświetlany wskaźnik może zmieniać kolor (wraz z kolorem tła) lub migotać w sytuacji wystąpienia przekroczeń. Atrybut migotania może być ustawiony oddzielnie dla wskazówki i tarczy. Przekroczenia mogą być specyfikowane jako liczby (stałe) lub nazwy zmiennych systemowych. Jeśli przekroczenia zostały wyspecyfikowane jako nazwy zmiennych systemowych, wówczas w polu deklarującym zmienną można wpisać warunek logiczny jako przyrostek nazwy zmiennej - utworzony zgodnie z poniższymi wytycznymi.

Warunek logiczny jest ciągiem składającym się z liczby szesnastkowej (warunku) wraz z poprzedzającym go znakiem "&" lub "|". W pierwszym przypadku (&) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest równy warunkowi, zaś w drugim przypadku (|) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest różny od zera. Innymi słowy w pierwszym przypadku dla zmiany atrybutu liczby wymagane jest, aby wszystkie bity warunku były w danej zmiennej ustawione, zaś w drugim przypadku wystarczające jest, jeżeli co najmniej jeden bit warunku jest jedynką. Znak "|" można pominąć przy specyfikowaniu warunku.

Dodatkowo mogą być rysowane znaczniki (kreseczki) w miejscach odpowiadających limitom przekroczeń. Znaczniki rysowane są po ustawieniu na "tak" pola logicznego sąsiadującego z polem służącym do wpisywania limitów przekroczeń. Na tarczy wskaźnika może być narysowana skala. W przypadku wskaźnika z dwoma wskazówkami druga wskazówka "zapamiętuje" maksymalną wskazywaną wartość. Dokonując selekcji wskaźnika (na przykład przy pomocy myszy) powoduje się nałożenie wskazówek.

Parametryzacja z bazy

Obiekt WSKAŹNIK wyposażony został dodatkowo w cechy umożliwiające ustawienie z bazy zmiennych następujących parametrów:

  • zakres zmienności np. 0, 100 według nazwy zmiennej wyświetlanej,

  • limity, przy których wystąpi zmiana koloru np. nazwy zmiennych Limit, Limit&10 według nazwy zmiennej wyświetlanej,

  • nazwę i maskę danej kontrolnej.

Do tego celu służy przycisk Łącze, którego naciśnięcie powoduje wpis zawartości danego pola w bazie, poprzedzonego znakiem @ na wszystkich pozycjach, które mogą być potencjalnie ustawione z bazy zmiennych.

W poniższym przykładzie naciśnięcie przycisku Łącze spowodowało wpisanie zawartości pól z bazy dla:

  • limitu maksimum krytyczne - wartość 100

  • limitu maksimum - zmienna o nazwie A_H

  • limitu minimum - bit określony przez maskę (heksadecymalnie 4) zmiennej o nazwie A_L

  • limitu minimum krytycznego - zmienna A_LL

  • zakresu zmienności

  • nazwy i maski danej kontrolnej - zmienna A? Z maską heksadecymalnie 4.

Patrz: Rysunek: Okno parametryzacji obiektu WSKAŹNIK.


19.4.36. Obiekt WYŁĄCZNIK

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.37. Obiekt WYŁĄCZNIK

19.4.37. Obiekt WYŁĄCZNIK

Wymiary

Parametry obiektu

Nazwa Obiektu

Stany

Wysyłanie

Wyrównanie

Strefy

Dana monitorowana

Przycisk

Obiekt WYŁĄCZNIK jest odmianą przycisku umożliwiającą wysyłanie sterowań. W zależności od wersji może składać się z jednego lub dwóch przycisków. Wersja dwuprzyciskowa posiada osobne przyciski do załączania oraz wyłączania.

Wysłanie sterowania może być chronione hasłem.

Poniższy rysunek prezentuje przykładowe obiekty typu WYŁĄCZNIK.

Rysunek: Przykład obiektu WYŁĄCZNIK.

W wersji jednoprzyciskowej znaczenie przycisku przedefiniowuje się w zależności od stanu zmiennej monitorowanej. Jeżeli stan tej zmiennej jest zgodny ze stanem wpisanym w pozycji Z naciśnięty, naciśnięcie przycisku wyśle wartość lub wykona akcję zdefiniowaną pod przyciskiem na pozycji Z wyciśnięty. Jeżeli warunek nie jest spełniony, obiekt bada, czy stan zmiennej monitorowanej jest zgodny z drugą wartością. Jeśli tak, wysyłana jest wartość lub wykonywana akcja z warunku zdefiniowanego pod przyciskiem na pozycji W wyciśnięty. O ile żaden z warunków nie jest spełniony, wykonywana jest operacja spod przycisku Z wyciśnięty. Okno definicji operacji dla danego przycisku otwiera się po kliknięciu na nim.

Rysunek: Okno 'Sterowanie' umożliwiające definiowanie operacji dla przycisku.

Pod przyciskiem może być zdefiniowana akcja operatorska lub wysłanie wartości, którą wpisuje się w okienku Słowo.

Obiekt WYŁĄCZNIK jest wybieralny (to znaczy wysyła sterowania) oraz dynamiczny ponieważ zmienia stan w zależności od stanu zmiennej monitorowanej oraz w zależności od tego, czy przycisk jest wybrany, naciśnięty czy nie. Jeśli wyłącznik jest zdefiniowany jako trójstanowy, przycisk jest płaski dopóki nie zostanie wybrany, po wybraniu obiektu przez najechanie na niego kursorem lub za pomocą klawisza TAB, przycisk staje się wypukły, wciśnięty - po kliknięciu myszą na jego obszarze. Po wyłączeniu opcji trójstanowej obiekt przyjmuje tylko dwa stany - naciśnięty i wciśnięty.

W obiekcie WYŁĄCZNIK przyciski mogą być do wyboru tekstowe albo utworzone przez mapy bitowe (niedopuszczalne jest występowanie jednocześnie tekstu i mapy bitowej). Przycisk obiektu WYŁĄCZNIK może być przezroczysty. W jego miejsce należy wtedy wstawić inny obiekt (np. PRZYCISK lub OBRAZKI).

Wymiary

Wymiary obiektu WYŁĄCZNIK są określane na podstawie zawartości tekstu opisującego przyciski lub wymiarów ewentualnych map bitowych tworzących przyciski. W celu określenia wymiaru przeglądane są wszystkie zadeklarowane do wyświetlenia teksty lub mapy bitowe. Tak określony wymiar obiektu jest wymiarem minimalnym i może zostać powiększony przy pomocy myszy. Próba zmniejszenia obiektu poniżej wymiarów minimalnych jest nieskuteczna.

Przyciski obiektu WYŁĄCZNIK mogą być selekcjonowane przy pomocy myszy lub klawisza Tab (Shift+Tab). Wysłanie sterowania następuje:

  • w przypadku trybu natychmiastowego w momencie puszczenia lewego klawisza myszy lub po naciśnięciu klawisza Enter;

  • w przypadku trybu z potwierdzeniem po naciśnięciu klawisza Szary_+ lub wykonaniu odpowiedniej akcji (klawiszem Enter można zmieniać stan klawisza obiektu WYŁĄCZNIK);

  • w przypadku trybu z powtarzaniem sterowanie wysyłane jest cyklicznie co jedną sekundę tak długo, jak długo naciśnięty jest lewy klawisz myszy. W momencie puszczenia klawisza myszy następuje wysłanie dodatkowo specjalnego słowa sterującego ("koniec powtarzania"). Używając klawisza Enter należy go nacisnąć dwukrotnie. Pierwsze naciśnięcie powoduje "zapadnięcie się" przycisku oraz cykliczne wysyłanie sterowań. Drugie naciśnięcie kończy cykliczne wysyłanie oraz powoduje wysłanie specjalnego słowa do zmiennej sterowanej ("koniec powtarzania").

W przypadku użycia trybu z potwierdzeniem oraz z powtarzaniem - aby wstrzymać wysyłanie sterowań przez wciśnięty przycisk obiektu WYŁĄCZNIK należy użyć prawego klawisza myszy lub klawisza Esc.

Parametry

Rysunek: Okno parametryzacji obiektu WYŁĄCZNIK.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Stany-tekst - pole cechy pozwala określić, czy przyciski mają być opisane przy pomocy tekstu, czy też we wnętrzu przycisków powinny pojawiać się bitmapy. Teksty opisujące przyciski oraz nazwy bitmap umieszczane są w polach poniżej pola Stany-tekst.

uaktywnienie pola 'Stany-tekst’ powoduje, że wpisane uprzednio nazwy bitmap zostaną automatycznie skasowane.

Stany-Z naciśnięty - trzy pola tekstowe umożliwiające parametryzację naciśniętego przycisku typu Z. Pierwsze pole zawiera tekst opisujący (np. "ZAŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Trzecie pole zawiera liczbę w kodzie szesnastkowym, wskazującą które bity mają być kontrolowane w zmiennej monitorowanej.

Aktualnie istnieją trzy sposoby określania stanu w obiekcie WYŁĄCZNIK:

  1. wprowadzenie liczby w kodzie szesnastkowym, wskazującą, które bity mają być kontrolowane w zmiennej monitorowanej;

  2. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem =; wówczas wymagana jest dokładna zgodność wartości zmiennej i maski (bitów zerowych i jedynkowych);

  3. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem &; wymagana jest zgodność wszystkich bitów jedynkowych.

Np. jeżeli w polu wpisana jest liczba 2 i jeśli drugi bit od prawej zmiennej monitorowanej ma wartość 1 - to na przycisku wyświetli się opis lub bitmapa zdefiniowane dla tego stanu (lub przycisk Z będzie aktywny dla wersji dwuprzyciskowej). Wówczas kliknięcie na przycisku spowoduje wykonanie operacji zdefiniowanej pod nim.

Stany-Z płaski - dwa pola tekstowe umożliwiające parametryzację nieaktywnego przycisku typu Z. Pierwsze pole zawiera tekst opisujący (np. "ZAŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Przycisk nieaktywny będzie płaski - jeśli zostanie zaznaczona opcja trójstanowy.

Stany-Z wyciśnięty - dwa pola tekstowe umożliwiające parametryzację wyciśniętego przycisku typu Z. Pierwsze pole zawiera tekst opisujący (np. "ZAŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Trzecie pole zawiera przycisk, pod którym zdefiniowana jest operacja wykonywana w wyniku naciśnięcia przycisku - pod warunkiem, że zmienna monitorowana ma ustawione bity wskazane w linii Z naciśnięty. Np. jeżeli w tym polu wpisana jest liczba 3, to wykonana zostanie operacja spod omawianego przycisku w przypadku, gdy zmienna monitorowana ma ustawione dwa najmłodsze bity.

Stany-Z zablokowany - trzy pola tekstowe umożliwiające parametryzację zablokowanego przycisku typu Z. Pierwsze pole zawiera tekst opisujący (np. "ZAB") wyświetlany we wnętrzu przycisku, o ile nie jest ustawione pole blokada przezroczysta. Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst lub blokada przezroczysta. Trzecie pole zawiera liczbę w kodzie szesnastkowym, wskazującą które bity mają być kontrolowane w zmiennej dana blokady.

Aktualnie istnieją trzy sposoby określania stanu w obiekcie WYŁĄCZNIK:

  1. wprowadzenie liczby w kodzie szesnastkowym, wskazującą, które bity mają być kontrolowane w zmiennej dana blokady;

  2. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem =; wówczas wymagana jest dokładna zgodność wartości zmiennej i maski (bitów zerowych i jedynkowych);

  3. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem &; wymagana jest zgodność wszystkich bitów jedynkowych.

Np. jeżeli w polu wpisana jest liczba 2 i jeśli drugi bit od prawej zmiennej dana blokady ma wartość 1- to na przycisku wyświetli się opis lub bitmapa zdefiniowane dla tego stanu i przycisk zostanie zablokowany (lub dla wersji dwuprzyciskowej zostaną zablokowane oba przyciski Z i W).

Stany-W naciśnięty - trzy pola tekstowe umożliwiające parametryzację naciśniętego przycisku typu W. Pierwsze pole zawiera tekst opisujący (np. "WYŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Trzecie pole zawiera liczbę w kodzie szesnastkowym, wskazującą które bity mają być kontrolowane w zmiennej monitorowanej.

Aktualnie istnieją trzy sposoby określania stanu w obiekcie WYŁĄCZNIK:

  1. wprowadzenie liczby w kodzie szesnastkowym, wskazującą, które bity mają być kontrolowane w zmiennej monitorowanej;

  2. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem =; wówczas wymagana jest dokładna zgodność wartości zmiennej i maski (bitów zerowych i jedynkowych);

  3. wprowadzenie liczby w kodzie szesnastkowym z poprzedzającym go znakiem &; wymagana jest zgodność wszystkich bitów jedynkowych.

Np. jeżeli w polu wpisana jest liczba 2 i jeśli drugi bit od prawej zmiennej monitorowanej ma wartość 1- to na przycisku wyświetli się opis lub bitmapa zdefiniowane dla tego stanu (lub przycisk W będzie aktywny dla wersji dwuprzyciskowej). Wówczas kliknięcie na przycisku spowoduje wykonanie operacji zdefiniowanej pod nim.

Stany-W płaski - dwa pola tekstowe umożliwiające parametryzację nieaktywnego przycisku typu W. Pierwsze pole zawiera tekst opisujący (np. "WYŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Przycisk nieaktywny będzie płaski - jeśli zostanie zaznaczona opcja trójstanowy.

Stany-W wyciśnięty - dwa pola tekstowe umożliwiające parametryzację wyciśniętego przycisku typu W. Pierwsze pole zawiera tekst opisujący (np. "WYŁ"). Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst. Trzecie pole zawiera przycisk, pod którym zdefiniowana jest operacja wykonywana w wyniku naciśnięcia przycisku - pod warunkiem, że zmienna monitorowana ma ustawione bity wskazane w linii W naciśnięty. Np. jeżeli w tym polu wpisana jest liczba 3, to wykonana zostanie operacja spod omawianego przycisku w przypadku, gdy zmienna monitorowana ma ustawione dwa najmłodsze bity.

Stany-W zablokowany - dwa pola tekstowe umożliwiające parametryzację zablokowanego przycisku typu W. Pierwsze pole zawiera tekst opisujący (np. "ZAB") wyświetlany we wnętrzu przycisku, o ile nie jest ustawione pole blokada przezroczysta. Drugie pole może zawierać nazwę bitmapy wyświetlanej we wnętrzu przycisku, o ile nie jest ustawione pole Stany-tekst lub blokada przezroczysta.

Wysyłanie-natychmiastowe - pole wyboru umożliwiające zadeklarowanie natychmiastowego wysyłania wartości po wybraniu przycisku poprzez kliknięcie myszką w polu obiektu w trybie odświeżania maski. Wysyłaną przez obiekt wartością jest wartość odpowiadająca przyciskowi (WYŁ lub ZAŁ).

Wysyłanie-z potwierdzeniem - pole wyboru umożliwiające zadeklarowanie wysyłania wartości po wybraniu przycisku przez (wielokrotne) kliknięcie myszką w polu obiektu w trybie odświeżania maski, a następnie potwierdzenie. Wysłanie sterowania można potwierdzić naciskając klawisz Szary_+ lub wykonując odpowiednią akcję. Wysyłaną przez obiekt wartością jest wartość odpowiadająca przyciskowi (WYŁ lub ZAŁ).

Wysyłanie-z powtarzaniem - pole wyboru umożliwiające zadeklarowanie cyklicznego wysyłania wartości (okres 1 sekunda) po jej wybraniu poprzez naciśnięcie lewego klawisza myszki w polu obiektu w trybie odświeżania maski. Cykliczne wysyłanie wartości trwa, dopóki lewy klawisz myszy pozostaje naciśnięty. Wysyłana wartość odpowiada przyciskowi ZAŁ. W momencie puszczenia lewego klawisza jednokrotnie wysyłana jest wartość zadeklarowana w polu Koniec powtarzania.

Wyrównanie-Do Lewej - pole wyboru wymuszające wyrównanie tekstu w obszarze przycisku do lewej.

Wyrównanie-Środkowanie - pole wyboru wymuszające środkowanie tekstu w obszarze przycisku.

Wyrównanie-Do Prawej - pole wyboru wymuszające wyrównanie tekstu w obszarze przycisku do prawej.

Strefy-pojedyncza - pole wyboru umożliwiające wybór trybu pracy z pojedynczym przyciskiem, który zmienia swój opis (np. ZAŁ albo WYŁ) w zależności od tego, która czynność jest możliwa do wykonania (np. jeśli napęd aktualnie jest załączony to można go wyłączyć, więc na klawiszu pojawi się napis typu WYŁ).

Strefy-poziome WZ - pole wyboru umożliwiające wybór trybu pracy z dwoma przyciskami, (np. ZAŁ oraz WYŁ) w ustawieniu poziomym (WYŁ z lewej, ZAŁ z prawej). Jeśli napęd aktualnie jest np. załączony, to można go jedynie wyłączyć - a więc przycisk ZAŁ jest nieaktywny.

Strefy-poziome ZW - pole wyboru umożliwiające wybór trybu pracy z dwoma przyciskami, (np. ZAŁ oraz WYŁ) w ustawieniu poziomym (ZAŁ z lewej, WYŁ z prawej). Jeśli napęd aktualnie jest np. załączony, to można go jedynie wyłączyć - a zatem przycisk ZAŁ jest nieaktywny.

Strefy-pionowe WZ - pole wyboru umożliwiające wybór trybu pracy z dwoma przyciskami, (np. ZAŁ oraz WYŁ) w ustawieniu pionowym (WYŁ z góry ZAŁ z dołu). Jeśli napęd aktualnie jest np. załączony, to można go jedynie wyłączyć, a więc przycisk ZAŁ jest nieaktywny.

Strefy-pionowe ZW - pole wyboru umożliwiające wybór trybu pracy z dwoma przyciskami, (np. ZAŁ oraz WYŁ) w ustawieniu pionowym (ZAŁ z góry, WYŁ z dołu). Jeśli napęd aktualnie jest np. załączony, to można go jedynie wyłączyć - a zatem przycisk ZAŁ jest nieaktywny.

Dana monitorowana - pole tekstowe umożliwiające podanie nazwy danej monitorowanej. Podanie tej nazwy jest konieczne. Od stanu tej zmiennej zależy, jaki opis wyświetli się na przycisku (typu ZAŁ lub WYŁ) w wersji jednoprzyciskowej, lub który przycisk będzie aktywny (typu ZAŁ lub WYŁ) w wersji dwuprzyciskowej. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w ten sposób dokonać wyboru zmiennej.

Dana sterowana - pole tekstowe umożliwiające podanie nazwy danej sterowanej. Podanie tej nazwy jest konieczne. Do tej zmiennej wysyłane są sterowania zadeklarowane przy pomocy odpowiednich pól przycisków. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej sterowanej (przy wykorzystaniu notacji ze znakiem #). Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Dana blokady - pole tekstowe umożliwiające podanie nazwy danej blokady. Podanie tej nazwy nie jest konieczne. Stan zmiennej decyduje o blokowaniu przycisku WYŁĄCZNIK. Naciskając prawy klawisz myszy w tym polu można otworzyć okno z listą dostępnych zmiennych i w nim dokonać wyboru. Możliwe jest określenie nazwy danej blokady (przy wykorzystaniu notacji ze znakiem #). Jeśli w polu nazwy zmiennej wpiszemy znaki #_ z sufiksem, wówczas w czasie działania aplikacji traktowane to będzie jako zmienna o nazwie, w której zamiast znaku # zostanie podstawiona nazwa zmiennej monitorowanej.

Hasło - pole wyboru hasła chroniącego wysyłanie sterowania (do wyboru cztery poziomy hasła, lub domyślnie jego brak).

Najpierw czytaj - pole cechy umożliwiające wymuszenie przeczytania wartości przed wysłaniem sterowania. W takim przypadku do zmiennej sterowanej zapisywana jest suma logiczna wartości wysyłanej i wartości danej zmiennej, odczytanej ze sterownika, z wyzerowaną grupą bitów ustawianych przez obiekt.

Błędy komunikacji - pole cechy umożliwiające sygnalizację błędów komunikacyjnych (obiekt zostaje przekreślony). Opcja domyślna.

Linia - pole koloru linii przekreślającej obiekt w przypadku wystąpienia błędu komunikacji oraz pole liczbowe umożliwiające określenie szerokości linii. Wybranie pola koloru powoduje wyświetlenie okna wyboru koloru.

Koniec powtarzania - pole przycisku (przycisk ze zmiennym opisem) umożliwiające podanie wartości liczbowej (szesnastkowo), która zostanie wysłana do zmiennej sterowanej (na zakończenie wysyłania) "z powtarzaniem" lub akcji, która zostanie wykonana we wspomnianej sytuacji. Po naciśnięciu tego przycisku na ekranie pojawia się omówione już okno 'Sterowanie’, umożliwiające podanie wartości lub wpisanie akcji.

Przycisk-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać opisany przycisk (przyciski). Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Przycisk-Z - pola koloru umożliwiające ustawienie koloru tekstu opisującego przycisk ZAŁ (pole lewe), tekstu opisującego przycisk po jego wciśnięciu (pole środkowe) oraz tła (pole prawe). Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-W - pola koloru umożliwiające ustawienie koloru tekstu opisującego przycisk WYŁ (pole lewe), tekstu opisującego przycisk po jego wciśnięciu (pole środkowe) oraz tła (pole prawe). Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień + - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wyciśniętego przycisku (pole prawe). Podświetlenie obejmuje obramowanie przycisku z góry i lewej strony, natomiast cień - to obramowanie przycisku z dołu i prawej strony. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Cień - pola koloru umożliwiające ustawienie koloru podświetlenia (pole lewe) oraz koloru cienia wciśniętego przycisku (pole prawe). Podświetlenie obejmuje obramowanie przycisku z góry i lewej strony, natomiast cień to obramowanie przycisku z dołu i prawej strony. Po wyselekcjonowaniu tych pól wyświetlone zostaje okno wyboru koloru.

Przycisk-Ramka - pole cechy oraz pole koloru umożliwiające określenie, czy przyciski powinny posiadać ramkę oraz jeśli tak - zadeklarowanie jej koloru.

Przycisk-trójwymiarowy - pole cechy umożliwiające rysowanie tzw. trójwymiarowych przycisków.

Przycisk-przezroczysty - pole cechy umożliwiające rysowanie przezroczystych przycisków. W tym przypadku właściwe przyciski powinny być utworzone przy pomocy innych obiektów.

Przycisk-blokada przezroczysta - pole cechy sprawiające, że obiekt PRZYCISK staje się niewidoczny w momencie, gdy jest zablokowany.

Przycisk-Otoczka - pole liczbowe umożliwiające zadeklarowanie otoczki przycisku, określonej w pikselach (domyślnie 0). Otoczka pozwala na powiększenie obszaru reagującego na selekcję (istotne dla niewielkich przycisków).

Przycisk-Rozsunięcie - pole liczbowe umożliwiające zadeklarowanie rozsunięcia przycisków (odstępu pomiędzy nimi) w pikselach (domyślnie 0). Istotne dla wersji dwuprzyciskowej.


19.4.37. Obiekt WYRAŻENIE

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.38. Obiekt WYRAŻENIE

19.4.38. Obiekt WYRAŻENIE

Wymiary | Opis działania
Parametry obiektu | Opis formatów
Nazwa Obiektu | Przykłady zdefiniowania różnych formatów
Wprowadzanie kodu języka ASTEL |
Kolory i Czcionki |
Zakresy |
Obliczenie |
Prezentacja |
Wyrówn. |
W pionie |
Czasy |

Obiekt WYRAŻENIE umożliwia wartościowanie ciągu wyrażeń języka ASTEL oraz wyświetla wynik wartościowania ostatniego z nich w postaci liczbowej. Stanowi on więc w zasadzie połączenie obiektów typu PRZELICZNIK oraz LICZBA. Wartościowanie może odbywać się cyklicznie. Obiekt ten może także dokonywać obliczeń na żądanie operatora (po jego wyselekcjonowaniu).

Wymiary

Wysokość i szerokość przyjmuje się automatycznie według wyspecyfikowanego formatu dla najdłuższego możliwego łańcucha wynikającego z podanego zakresu. Wymiary obiektu można zwiększyć przy pomocy myszki. Przy podaniu cechy obszar wg formatu wymiary będą automatycznie zmieniane na obszar wynikający z formatu.

Parametry

Rysunek: Okno parametryzacji obiektu WYRAŻENIE.

Nazwa Obiektu - pole tekstowe służące do wpisania opcjonalnej nazwy obiektu. Nazwa ta pojawia się na liście obiektów. Jeżeli nie podamy nazwy obiektu, wówczas na liście obiektów pojawi się jego typ wraz ze współrzędnymi.

Pola nieopisane - pole tekstowe umożliwiające wpisanie programu w języku ASTEL (główne pole pod nazwą obiektu) oraz wyświetlenie wyników wartościowania (pole z prawej) a także wyświetlenie komunikatów diagnostycznych (pole poniżej). W głównym polu można wpisać wiele linii zawierających kolejne wyrażenia. Kliknięcie prawym klawiszem w tym polu powoduje otwarcie okna generacji wyrażeń (zobacz opis obiektu PRZELICZNIK), które pozwala na generację wyrażeń użytkownikowi nie znającemu składni języka.

Kolory i Czcionki ->> - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy alarmowej.

Kolory i Czcionki -> - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia górnej granicy ostrzegawczej.

Kolory i Czcionki -= - pola koloru umożliwiające ustawienie podstawowego koloru cyfr (pole lewe) oraz tła (pole prawe) wyświetlanej liczby.

Kolory i Czcionki -? - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe i środkowe) oraz tła (pole prawe) wyświetlanej liczby w przypadku błędu komunikacji (pole lewe) i błędu pomiarowego (pole środkowe).

Kolory i Czcionki -< - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy ostrzegawczej.

Kolory i Czcionki -<< - pola koloru umożliwiające ustawienie koloru cyfr (pole lewe) oraz tła (pole prawe) w przypadku przekroczenia dolnej granicy alarmowej.

Kolory i Czcionki -Tło koloru Okna - pole cechy umożliwiające wymuszenie ustawienie koloru tła zgodnego z kolorem okna.

Kolory i Czcionki -Tło przezroczyste - pole cechy umożliwiające wymuszenie ustawienie tła przezroczystego.

Kolory i Czcionki - na prawo od pól wyboru koloru dla poszczególnych limitów znajdują się indykatory atrybutu migotania. Dalej na prawo znajduje się kolumna pól wyboru czcionek. Czcionki mogą być wybrane indywidualnie dla każdego z limitów, przez co można np. zadeklarować większa czcionkę dla sytuacji alarmowych, by ułatwić Operatorowi spostrzeżenie przekroczenie limitów technologicznych.

Zakresy-X>> - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 90. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-X> - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości górnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 75. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-od - pole liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego zakresu. Domyślnie 0. Liczby mniejsze będą wyświetlone. Wartość wykorzystywana jedynie do określenia obszaru zajmowanego przez obiekt.

Zakresy-do - pole liczbowe umożliwiające wprowadzenie liczbowej wartości górnego zakresu. Domyślnie 100. Liczby większe będą wyświetlone. Wartość wykorzystywana jedynie do określenia obszaru zajmowanego przez obiekt.

Zakresy-X< - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia ostrzegawczego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 25. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Zakresy-X<< - pole tekstowo-liczbowe umożliwiające wprowadzenie liczbowej wartości dolnego ograniczenia alarmowego ewentualnie nazwę zmiennej zawierającej to ograniczenie. Domyślnie 10. W przypadku podania nazwy zmiennej dodatkowo można wpisać warunek logiczny. Zostały one opisane w dalszej części.

Obliczenie-Cyklicznie - pole wyboru umożliwiające wymuszenie cyklicznego wartościowania wyrażenia przez obiekt.

Obliczenie-Na Żądanie - pole wyboru umożliwiające wymuszenie wartościowania na żądanie operatora (kliknięcie w polu obiektu).

Prezentacja-Czcionka - pole tekstowe umożliwiające wprowadzenie nazwy czcionki, którą ma zostać wyświetlona liczba. Brak podania czcionki powoduje przyjęcie domyślnej czcionki (Dialog). Naciśnięcie prawego klawisza myszy w tym polu powoduje wejście w okno wyboru czcionki.

Prezentacja-Format - pole tekstowe umożliwiające zadeklarowanie formatu wyprowadzanej liczby. Dopuszczalne formaty pochodzą ze standardu języka C i zostały omówione w dalszej części. Domyślny jest format %d (liczba całkowita).

Prezentacja-Obszar wg Formatu - pole cechy umożliwiające wymuszenie obszaru zajmowanego przez obiekt zgodnego z formatem i czcionką np. dla formatu %5u oznacza to, że obszar zajmowany przez obiekt odpowiadał będzie pięciu cyfrom o wymiarach określonych przez wybraną czcionkę.

Znak kontrolny - pole tekstowe umożliwiające zadeklarowanie znaku kontrolnego (domyślnie ?), który jest wykorzystywany do sygnalizacji błędów.

Wyrówn.-w lewo - pole wyboru wymuszające wyrównanie liczby w obszarze obiektu do lewej.

Wyrówn.-środek - pole wyboru wymuszające środkowanie liczby w obszarze obiektu.

Wyrówn.-w prawo - pole wyboru wymuszające wyrównanie liczby w obszarze obiektu do prawej.

W pionie-w górę - pole wyboru wymuszające pionową justację liczby do górnej krawędzi pola zajmowanego przez obiekt.

W pionie-środek - pole wyboru wymuszające środkowanie w pionie liczby wewnątrz pola zajmowanego przez obiekt.

W pionie-w dół - pole wyboru wymuszające pionową justację liczby do dolnej krawędzi pola zajmowanego przez obiekt.

Czasy-cykl - pole liczbowe oraz pole wyboru umożliwiające określenie cyklu odświeżania obiektu przez podanie liczby kwantów oraz jednostki. Ważne dla cyklicznego trybu pracy.

Czasy-okres - pole liczbowe oraz pole wyboru umożliwiające określenie domyślnego okresu czasu (w archiwum), do którego odnoszą się wyrażenia wartościowane przez obiekt. Jeżeli w wyrażeniach nie występują odwołania do danych archiwalnych lub też nie korzystają z domyślnego okresu, wówczas zawartość tych pól jest bez znaczenia.

Teksty puste i złożone z samych spacji są dopuszczalne w polach ograniczeń i są traktowane jako rezygnacja ze sprawdzania.

Opis działania

W przypadku wystąpienia błędu obliczeniowego (np. próba policzenia logarytmu z wartości ujemnej) liczba zostaje zastąpiona ciągiem znaków kontrolnych.

Wyświetlana liczba może zmieniać kolor w sytuacji wystąpienia przekroczeń. Przekroczenia mogą być specyfikowane jako liczby (stałe) lub nazwy zmiennych systemowych. Jeśli przekroczenia zostały wyspecyfikowane jako nazwy zmiennych systemowych, wówczas w polu deklarującym zmienną można wpisać warunek logiczny jako przyrostek nazwy zmiennej - utworzony zgodnie z poniższymi wytycznymi.

Warunek logiczny jest ciągiem składającym się z liczby szesnastkowej (warunku) wraz z poprzedzającym go znakiem "&" lub "|". W pierwszym przypadku (&) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest równy warunkowi, zaś w drugim przypadku (|) spełnienie warunku następuje, jeśli iloczyn logiczny zmiennej i warunku jest różny od zera. Innymi słowy w pierwszym przypadku dla zmiany atrybutu liczby wymagane jest, aby wszystkie bity warunku były w danej zmiennej ustawione, zaś w drugim przypadku wystarczające jest, jeżeli co najmniej jeden bit warunku jest jedynką. Znak "|" można pominąć przy specyfikowaniu warunku.

W przypadku obliczenia na żądanie operator może wymusić wartościowanie dokonując selekcji obiektu. W przypadku wartościowania cyklicznego należy określić czas trwania cyklu. Dodatkowo w obydwu przypadkach powinno się wyspecyfikować okres czasu, dla którego wartościowane będą ewaluatory języka ASTEL (np. podanie okresu 10 minutowego oznacza, że ewaluator średniej będzie obliczał średnią wartość danej zmiennej dla okresu ostatnich 10 minut przed rozpoczęciem wartościowania). Jeśli ciąg wyrażeń nie zawiera ewaluatorów, lub zawierają one podany okres jako parametr, wówczas podany podczas parametryzacji okres jest nieistotny.

Wyrażenie języka ASTEL powinno zostać wpisane w polu wyrażeń umieszczonym pod nazwą obiektu. Po wpisaniu każdego wyrażenia można sprawdzić jego poprawność wykonując "kliknięcie" w polu diagnostycznym umieszczonym poniżej pola wyrażeń. Jeżeli wyrażenie jest niepoprawne wówczas w polu diagnostycznym pojawi się informacja o błędzie wraz z linią zawierającą błąd. W linii tej element leksykalny powodujący błąd zostanie poprzedzony znakiem zapytania (?). "Kliknięcie" w polu wynikowym umieszczonym na prawo od pola wyrażeń powoduje wartościowanie kolejnych wyrażeń i wpisanie w polu wynikowym rezultatów. Wystąpienie błędu powoduje komunikat w polu diagnostycznym.

Wartościowane wyrażenie powinno być tak dobrane, aby czas jego wartościowania wynosił maksymalnie kilka-kilkanaście sekund. W przeciwnym razie wydajność sytemu obciążonego dużą liczbą czasochłonnych obliczeniowo obiektów WYRAŻENIE spada. Można to zjawisko minimalizować dobierając odpowiednio długie cykle wartościowania dla obiektów, które wymagają długich czasów wartościowania.

Opis formatów

Parametr format musi być zgodny z poniższą składnią:

[%][[0]szerokość][.precyzja][format_daty][format_czasu][l|h]typ

gdzie:

% - opcjonalny początek formatu

typ - sposób formatowania:

d,i - liczba dzisiętna całkowita ze znakiem,

u - liczba dzisiętna całkowita bez znaku,

o - liczba ósemkowa,

x - liczba szesnastkowa używająca małych liter abcdef,

X - liczba szesnastkowa używająca dużych liter ABCDEF,

B - liczba w kodzie BCD,

f,e,g,E,G - liczba zmiennoprzecinkowa,

D - data, dana wejściowa jest traktowana jako ilość sekund od 1970-01-01-00:00, 32 bity;

T - czas, dana wejściowa jest traktowana jako ilość milisekund, 32 bity;

[0]szerokość - minimalna szerokość pola; rozpoczęcie szerokości cyfrą 0 oznacza, że pole ma być w razie konieczności uzupełnione zerami z lewej strony; element używany tylko dla formatów d,i,u,o,x,X,B,f,e,g,E,G;

precyzja - określa ilość cyfr ułamkowych dla formatów f,e,g,E,G;

l|h - dodatkowe określenie typu danej wejściowej: l - 32 bity, h - 16 bitów; element używany tylko dla formatów d,i,u,o,x,X,B;

format daty - używany tylko dla kodu D szczegółowy opis formatowania daty; treścią formatu jest ciąg znaków określających separatory i elementy składowe daty w dowolnej kolejności; elementy składowe to: y -rok, m - miesiąc, d -dzień, h - godzina, n - minuta, s - sekunda; brak określenia formatu daty oznacza formatowanie według wzorca y/m/d h:n:s;

format_czasu - używany tylko dla kodu T szczegółowy opis formatowania czasu; treścią formatu jest ciąg znaków określających separatory i elementy składowe czasu w dowolnej kolejności; Elementy składowe to: d - ilość dni, h - ilość godzin, n - ilość minut, s - ilość sekund, z - ilość milisekund; brak określenia formatu czasu oznacza formatowanie według wzorca h:n:s.

Jeżeli pole d jest użyte, to pole h nigdy nie jest większe niż 23, np. jeśli format "h:n:sT" wyświetla "46:10:00", to format "d h:n:sT" wyświetla "1 22:10:00".

Przed literą T można wstawić literę "l" - oznacza to, że dana wejściowa jest ilością sekund (a nie ilością milisekund).

Zastosowana koncepcja formatów liczb pochodzi z języka programowania C.

Przykłady zastosowania różnych formatów

%i - liczba stałoprzecinkowa wyprowadzane wszystkie cyfry znaczące.

%7lu - liczba stałoprzecinkowa długa bez znaku wyprowadzana na siedmiu pozycjach.

%6.2f - liczba zmiennoprzecinkowa dziesiętna wyprowadzana na sześciu pozycjach z dwoma miejscami po kropce.

h:n:s:zT - format zapisu czasu z milisekundami.

T - nie ma konieczności wstawiania przed T znaku %.

y/m/dD - format daty bez podawania czasu.

y-m-dD - format daty w postaci: 2005-11-30.


19.4.38. Obiekt WYKRES

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES

19.4.39. Obiekt WYKRES

OBSZAR OPISÓW

OBSZAR PRZEBIEGÓW

OBSZAR LEGENDY

Obiekt WYKRES umożliwia graficzną prezentację danych archiwalnych zgromadzonych za pomocą modułu Aspad oraz przebiegów wzorcowych wygenerowanych przy pomocy programu Pedit. Dane mogą być przedstawione w postaci wykresów liniowych i słupkowych, zorientowanych poziomo lub pionowo. Każdy WYKRES automatycznie skalowany jest do obszaru zadeklarowanego przez projektanta. Zawierać może wiele krzywych, których ilość ograniczona jest jedynie zestawem dostępnych kolorów, grubości i wzorców linii kreślenia. Krzywe mogą prezentować wartości bieżące, archiwalne zmiennych pomiarowych oraz wzorce przebiegów. Krzywe archiwalne oraz wzorcowe mogą być przesuwane względem krzywych bieżących. Dodatkowo krzywa wzorcowa posiada możliwość zaczepienia jej w dowolnym położeniu względem osi OX. Jeżeli maska, na której będzie znajdował się wykres ze zmienną wzorcową, będzie buforowana, punkt zaczepienia będzie pamiętany. Dla wykresów słupkowych możliwa jest zmiana atrybutów (szerokość, wysokość i kolor) w zależności od wartości związanej z nim zmiennej pomiarowej.

Rysunek: Przykład obiektu WYKRES.

Każdy WYKRES zajmuje prostokątny obszar na ekranie, składający się z:

OBSZAR OPISÓW - zawierającego elementy pozwalające na odczyt i interpretację danych zawartych w obszarze przebiegów,

OBSZARU PRZEBIEGÓW - zawierającego krzywe będące graficzną prezentacją zmiennych pomiarowych,

OBSZARU LEGENDY - zawierającego informację o krzywych oraz zmiennych pomiarowych.

Obszar opisów zawiera następujące elementy:

znacznik selekcji - służy do wskazywania aktywnego wykresu,

data kursora - pokazuje datę odpowiadającą położeniu kursora (jeśli jest włączony) w osi czasu, w formacie DD-MM-RR; kolor znaków jest zgodny z kolorem wyselekcjonowanej krzywej na wykresie,

czas kursora - pokazuje czas odpowiadający położeniu kursora (jeśli jest włączony) w osi czasu, w formacie GG:MM:SS; kolor znaków jest zgodny z kolorem wyselekcjonowanej krzywej na wykresie,

wartość kursora - pokazuje wartość odpowiadającą położeniu kursora (jeśli jest włączony) w osi wartości; kolor znaków jest zgodny z kolorem wyselekcjonowanej krzywej na wykresie,

tytuł wykresu - opisuje zawartość obszaru przebiegów; przeważnie zawiera nazwę zmiennej procesowej, jej opis oraz jednostkę miary,

opis osi czasu - pokazuje wartości liczbowe skalujące oś czasu i określające zakres, w którym wyświetlane są krzywe na wykresie. Opis osi podzielony jest na podprzedziały opisane znacznikami, ułatwiające interpretację wyświetlanych krzywych. Format opisu znaczników osi czasu może mieć jedną z trzech postaci: GG:MM:SS, GG:MM lub GG(format dostosowywany jest automatycznie w zależności od ustalonego horyzontu i kroku),

opis osi wartości - pokazuje wartości liczbowe skalujące oś wartości i określające zakres, w którym wyświetlane są krzywe na wykresie. Opis osi podzielony jest na podprzedziały opisane znacznikami, ułatwiające interpretację wyświetlanych krzywych. Format opisu osi wartości ma postać liczby dziesiętnej z częścią ułamkową lub liczby w zapisie wykładniczym, gdzie wykładnik potęgi znajduje się ponad opisem osi wartości,

wykładnik potęgi - pole zawierające potęgę (mantysę) opisów osi wartości przedstawionych w zapisie wykładniczym. Zapis wykładniczy ma postać c*10m, gdzie c jest liczbą dziesiętną nazywaną cechą a m jest liczbą całkowitą nazywaną mantysą. Przykładowo liczba 2300 w zapisie wykładniczym może mieć postać 2.3*10 3,

znacznik osi - znak graficzny (kreska pionowa lub pozioma o różnej długości) dzielący osie czasu i wartości na równe podprzedziały ułatwiające interpretacje i odczyt danych prezentowanych w postaci krzywych na wykresie. Znaczniki mogą być dwojakiego rodzaju: opisane (dłuższe) i nieopisane (krótsze),

znacznik historii - znak graficzny (prostokąt) pojawiający się w momencie, gdy krzywa bieżąca w obszarze przebiegów nie zawiera punktu odpowiadającego aktualnej chwili czasu,

ramka graniczna - ramka oddzielająca obszar opisów od obszaru przebiegów.

Obszar przebiegów zawiera następujące elementy:

krzywe bieżące - krzywe zbudowane z punktów pomiarowych połączonych liniami prostymi, odzwierciedlające bieżące zmiany wartości zmiennych technologicznych. Rozróżniane są pomiędzy sobą za pomocą koloru, grubości i wzorca linii kreślącej. Ponieważ argumentem zmiennych jest czas oraz krzywe te mają pokazywać zmiany na bieżąco, to wyjście takiej krzywej poza obszar przebiegów powoduje przesunięcie zawartości obszaru przebiegów wraz z opisem osi czasu. Jeśli krzywe te nie zawierają w sobie punktu odpowiadającego aktualnej chwili czasu, powyższe przesunięcie nie następuje (widoczny jest znacznik historii).

krzywe archiwalne - krzywe zbudowane z punktów pomiarowych połączonych liniami prostymi, odzwierciedlające archiwalne zmiany wartości zmiennych technologicznych. Rozróżniane są pomiędzy sobą za pomocą koloru linii, grubości i wzorca kreślącej. Wraz z upływem czasu nie powodują przesuwania zawartości obszaru przebiegów. Mogą być przesuwane względem krzywych bieżących za pomocą specjalnych funkcji obsługi przebiegów.

krzywe wzorcowe - krzywe zdefiniowane za pomocą programu PEdit, (dokładny opis w pliku PrzebiegiWzorcowe.pdf) Wraz z upływem czasu nie powodują przesuwania zawartości obszaru przebiegów. Mogą być przesuwane względem krzywych bieżących za pomocą specjalnych funkcji obsługi przebiegów, tych samych, co dla przebiegów archiwalnych.

kursor - znak graficzny (skrzyżowane linie) pozwalający na wskazanie dowolnego miejsca w obszarze przebiegów. Jego kolor zależny jest od koloru wyselekcjonowanej krzywej na wykresie. Wykorzystywany jest do:

  • informowania, która z krzywych jest aktualnie wyselekcjonowana,

  • odczytu współrzędnych punktów w obszarze przebiegów,

  • określania punktu, względem którego dokonywana będzie zmiana zakresu w osi czasu i wartości.

siatka odczytu - linie poziome lub pionowe wychodzące ze znaczników opisu osi czasu lub osi wartości przechodzące przez cały obszar przebiegów. Ułatwiają interpretację i odczyt położenia punktów na krzywych.

Obszar LEGENDY zawiera następujące elementy:

wzorzec linii - graficzna prezentacja linii użytych do kreślenia krzywych wykresu.

nazwa zmiennej - nazwa zmiennej pomiarowej w oparciu o którą tworzone są krzywe wykresu.

opis zmiennej - opis zmiennej pomiarowej wyświetlany w oparciu o dane zapisane w plikach konfiguracyjnych systemu Asix.

Wszystkie powyższe elementy wyświetlane są w kolorach odpowiednich krzywych, zdefiniowanych w obiekcie WYKRES.


19.4.38.1 Funkcje obsługi przebiegów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.1 Funkcje obsługi przebiegów

19.4.39.1 Funkcje obsługi przebiegów

Przedstawione poniżej operacje wykonywane za pomocą myszy, charakteryzują sposób selekcji obiektów WYKRES.

  • Po naciśnięciu lewego klawisza myszy w obszarze obiektu WYKRES następuje:

  • zdjęcie selekcji z innych obiektów WYKRES,

  • zaznaczenie selekcji wskazanego obiektu,

  • uczynienie obiektu bieżącym.

  • Po naciśnięciu lewego klawisza myszy w obszarze innego obiektu niż WYKRES następuje:

  • uczynienie wskazanego obiektu bieżącym,

  • zachowanie selekcji obiektów WYKRES.

  • Po naciśnięciu lewego klawisza myszy wraz z klawiszem Ctrl w obszarze obiektu WYKRES następuje:

  • zaznaczenie selekcji wskazanego obiektu WYKRES,

  • zachowanie selekcji innych obiektów WYKRES w ramach maski.

  • Po naciśnięciu prawego klawisza myszy w obszarze obiektu WYKRES następuje wyświetlenie menu kontekstowego, pozwalającego wykonywać operacje na wyselekcjonowanych obiektach WYKRES.

Opisana zmiana w selekcji obiektów klasy WYKRES pozwala na wykonywanie funkcji na grupie wyselekcjonowanych obiektów WYKRES. Z punktu widzenia użytkowego pozwala to na uzyskanie następujących cech:

  • funkcje uaktywniane z klawiatury dla bieżącego obiektu WYKRES będą powielane dla wyselekcjonowanych obiektów WYKRES;

  • pasek narzędziowy obiektu WYKRES, uaktywniany na żądanie użytkownika, steruje grupą wyselekcjonowanych obiektów WYKRES;

  • menu kontekstowe inicjuje wykonanie niektórych funkcji na grupie obiektów WYKRES.


19.4.38.2 Menu kontekstowe

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.2 Menu kontekstowe

19.4.39.2 Menu kontekstowe

Menu kontekstowe obiektu WYKRES jest uaktywniane poprzez naciśnięcie prawego klawisza myszy w obszarze obiektu (w trybie realizacji aplikacji). Ma ono następującą postać:

Rysunek: Menu kontekstowe obiektu WYKRES.

Poszczególne pozycje menu mają następujące znaczenie:

Selekcja - pozwala na włączenie lub wyłączenie selekcji danego obiektu WYKRES;

Usuń selekcję (wszystkich) - pozwala na usunięcie selekcji wszystkich wyselekcjonowanych obiektów WYKRES;

Selekcja wszystkie - pozwala wyselekcjonować wszystkie obiekty WYKRES w ramach maski;

Pasek narzędzi - pozwala na pokazanie lub schowanie paska narzędzi sterującego funkcjami wyselekcjonowanych obiektów WYKRES; operacja ta może być również wykonana za pomocą podwójnego kliknięcia w obszarze obiektu WYKRES;

Funkcje - pokazuje podmenu zawierające funkcje obiektu WYKRES możliwe do wykonania z tego miejsca; podmenu zawiera te funkcje, które w wyniku swego działania uaktywniają okna dialogowe; należą do nich:

  • Pomoc,

  • Legenda,

  • Zmiana horyzontu,

  • Obsługa archiwum,

  • Redefinicja krzywych.


19.4.38.3 Pasek narzędzi (Toolbar)

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.3 Pasek narzędzi (Toolbar)

19.4.39.3 Pasek narzędzi (Toolbar)

W celu ułatwienia obsługi obiekt WYKRES został wyposażony w specjalizowany pasek narzędzi, pozwalający na obsługę za pomocą myszy. Dodatkowo wykorzystując sposób selekcji obiektów WYKRES, uzyskuje się możliwość wykonywania operacji na grupie wykresów.

Uaktywnienie paska narzędzi realizowane jest poprzez podwójne kliknięcie myszą w obszarze dowolnego obiektu WYKRES lub za pomocą menu kontekstowego. Zamknięcie paska narzędzi dokonuje się poprzez naciśnięcie klawisza systemowego okna lub za pomocą menu kontekstowego obiektu.

Postać paska narzędzi jest następująca:

Rysunek: Pasek narzędzi obiektu WYKRES.

Pojawia się w postaci niezależnego okna, które posiada cechę "zawsze na wierzchu" z możliwością zmiany jego rozmiaru i położenia. Okno to zawiera kilka pasków grupujących funkcje obiektu według ich przeznaczenia. Są nimi:

  • funkcje związane z obsługą kursora,

  • funkcje związane z ogólną obsługą wykresu,

  • funkcje związane ze zmianą zakresu na osiach,

  • funkcje związane z obsługą archiwum.

Postać paska narzędzi obiektu WYKRES po rozwinięciu wszystkich funkcji jest następująca:

Rysunek: Pasek narzędzi obiektu WYKRES.

Podział funkcji na grupy jest zgodny z podziałem zaproponowanym w oknie pomocy obiektu wywoływanym kombinacją klawiszy Ctrl-F1.

Poniższe tabele zawierają zestawy funkcji z odpowiadającymi im kodami klawiszowymi i ikonami graficznymi.

Tabela: Zestaw funkcji z odpowiadającymi im kodami klawiszowymi i ikonami graficznymi dla obiektu WYKRES.

Tabela: Zestaw funkcji z odpowiadającymi im kodami klawiszowymi i ikonami graficznymi dla obiektu WYKRES (c.d.).

Tabela: Zestaw funkcji z odpowiadającymi im kodami klawiszowymi i ikonami graficznymi dla obiektu WYKRES (c.d.).

Tabela: Zestaw funkcji z odpowiadającymi im kodami klawiszowymi i ikonami graficznymi dla obiektu WYKRES (c.d.).

Paski narzędzi można dowolnie ustawiać w ramach okna. Każdy z pasków zawiera odpowiedni zestaw przycisków. Każdy przycisk reprezentuje jedną funkcję obiektu WYKRES oraz opatrzony jest obrazkiem reprezentującym tą funkcję. Po najechaniu kursorem myszy na przycisk pojawia się "dymek" podpowiedzi, który podaje nazwę funkcji. Naciśnięcie przycisku powoduje wykonanie funkcji na wyselekcjonowanym obiekcie lub grupie obiektów WYKRES.


19.4.38.4 Klawisze uaktywniające funkcje obsługi przebiegów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.4 Klawisze uaktywniające funkcje obsługi przebiegów

19.4.39.4 Klawisze uaktywniające funkcje obsługi przebiegów

Sterowanie kursorem

Obsługa wykresu

Zmiana zakresu prezentacji

Przebiegi archiwalne i wzorcowe

Operacje dostępne z paska narzędziowego mogą być też wykonane z użyciem klawiatury. Służy do tego zdefiniowany zestaw klawiszy o funkcjonalności opisanej poniżej. Opis skrótów klawiszowych prezentuje okno 'Funkcje klawiszowe obiektu WYKRES’, wywoływane z menu kontekstowego aplikacji po wybraniu opcji Funkcja/Pomoc (menu kontekstowe dostępne jest w trybie realizacji aplikacji, po najechaniu kursorem na obiekt WYKRES. Dodatkowo, aby uruchomić okno 'Funkcje klawiszowe obiektu WYKRES’, należy w pierwszej kolejności w wyżej wspomnianym menu kontekstowym załączyć opcję Selekcja).

Rysunek: Menu kontekstowe obiektu WYKRES.

Sterowanie kursorem

Ins - włączenie/wyłączenie kursora w polu przebiegów; w wyniku tej operacji pojawia się kursor w postaci krzyżyka o kolorze wyselekcjonowanego przebiegu. Na opisie osi czasu i osi wartości pojawiają się znaczniki ułatwiające odczyt położenia kursora.

- przesunięcie kursora o piksel (punkt) w górę.

- przesunięcie kursora o piksel (punkt) w dół.

- przesunięcie kursora o piksel (punkt) w lewo.

- przesunięcie kursora o piksel (punkt) w prawo.

Home - przesunięcie kursora na początek pola przebiegów w osi czasu.

End - przesunięcie kursora na koniec pola przebiegów w osi czasu.

PgUp - przesunięcie pola przebiegów o "stronę" w przód w osi czasu; poprzez "stronę" rozumiemy fragment przebiegu o długości osi czasu pola przebiegów (horyzont czasowy).

PgDn - przesunięcie pola przebiegów o "stronę" w tył w osi czasu; poprzez "stronę" rozumiemy fragment przebiegu o długości osi czasu pola przebiegów (horyzont czasowy).

Ctrl-Home - powrót do bieżącej chwili czasu; funkcja wykorzystywana dla szybkiego powrotu do wyświetlania przebiegu pokazującego aktualną chwilę czasową. Szczególnie przydatna po stosowaniu funkcji PgUp lub PgDn.

Ctrl-P - przesunięcie lewej krawędzi pola przebiegów do znacznika osi czasu znajdującego się z lewej strony kursora (szybkie ustalanie początku pola wykresów za pomocą kursora).

Ctrl-K - przesunięcie prawej krawędzi pola przebiegów do znacznika osi czasu znajdującego się z prawej strony kursora (szybkie ustalanie końca pola wykresów za pomocą kursora).

Rysunek: Okno 'Funkcje klawiszowe obiektu WYKRES' - zakładka 'Kursor’.

Obsługa wykresu

Rysunek: Okno 'Funkcje klawiszowe obiektu WYKRES' - zakładka 'Obsługa wykresu'.

Tab - selekcja pola przebiegów.

Center - (klawisz 5 na klawiaturze numerycznej) selekcja krzywej w ramach pola przebiegów.

Ctrl-Enter - przerysowanie zawartości pola przebiegów.

Ctrl-F1 - uaktywnienie okna dialogowego informującego o funkcjach klawiszowych obiektu WYKRES.

Ctrl-L- - uaktywnienie okna dialogowego informującego o krzywych zdefiniowanych dla wyselekcjonowanego obiektu WYKRES.

Rysunek: Okno 'Legenda wykresu'.

Ctrl-D - uaktywnienie okna dialogowego pozwalającego na redefinicję krzywych obiektu WYKRES. Okno to jest dostępne tylko dla obiektów posiadających cechę parametryzacji dynamicznej.

Rysunek: Okno 'Zmiana przypisania krzywych'.

Zmiana zakresu prezentacji

Rysunek: Okno 'Funkcje klawiszowe obiektu WYKRES' - zakładka 'Zmiana zakresu'.

Ctrl- [image] - zwiększenie dokładności wyświetlania przebiegów w osi czasu; polega na zmniejszeniu długości horyzontu czasowego o połowę. Zmiana odbywa się względem środka aktualnego zakresu osi czasu, jeżeli kursor nie jest włączony. W przypadku, gdy kursor jest aktywny zmiana długości horyzontu odbywa się względem niego; po dokonaniu tej operacji kursor znajduje się w środku zakresu osi czasu.

Ctrl- [image] - zmniejszenie dokładności wyświetlania przebiegów w osi czasu; polega na zwiększeniu długości horyzontu czasowego dwukrotnie. Zmiana odbywa się względem środka aktualnego zakresu osi czasu, jeżeli kursor nie jest włączony. W przypadku gdy kursor jest aktywny zmiana długości horyzontu odbywa się względem niego; po dokonaniu tej operacji kursor znajduje się w środku zakresu osi czasu.

Ctrl-H - zmiana horyzontu wyświetlania przebiegów w osi czasu; polega na zmianie długości horyzontu czasowego poprzez określenie jego rozpiętości w oparciu o okno dialogowe:

Rysunek: Okno 'Horyzonty czasowe'.

Pola grupy Czas początku pozwalają na określenie momentu czasu, od którego rozpoczęte będzie wyświetlanie przebiegów w zadanym horyzoncie.

Ctrl- [image] - zwiększenie dokładności wyświetlania przebiegów w osi wartości; polega na zmniejszeniu długości zakresu osi wartości o połowę. Zmiana odbywa się względem środka aktualnego zakresu w osi czasu, jeżeli kursor nie jest włączony. W przypadku, gdy kursor jest aktywny, zmiana długości zakresu osi wartości odbywa się względem niego; po dokonaniu tej operacji kursor znajduje się w środku zakresu osi wartości.

Ctrl- [image] - zmniejszenie dokładności wyświetlania przebiegów w osi wartości; polega na zwiększeniu długości zakresu osi wartości dwukrotnie. Zmiana odbywa się względem środka aktualnego zakresu w osi czasu, jeżeli kursor nie jest włączony. W przypadku, gdy kursor jest aktywny, zmiana długości zakresu osi wartości odbywa się względem niego; po dokonaniu tej operacji kursor znajduje się w środku zakresu osi wartości.

Ctrl-Center - (Ctrl-Numer5) powrót do parametrów początkowych, określających długości horyzontu czasowego oraz zakresu osi wartości. Parametry początkowe są to parametry określone przez projektanta obiektu.

Przebiegi archiwalne i wzorcowe

Rysunek: Okno 'Funkcje klawiszowe obiektu WYKRES' - zakładka 'Archiwum'.

Ctrl-Ins - włączenie/wyłączenie wyświetlania przebiegów archiwalnych;

Ctrl-A - uaktywnienie okna dialogowego pozwalającego określić parametry przebiegów archiwalnych; do parametrów tych należą: data i czas początku archiwum;

Rysunek: Okno 'Początek archiwum'.

Enter - ustawienie kroku przesunięcia wykresów archiwalnych o piksel lub znacznik na osi czasu;

Ctrl-+ - przesunięcie przebiegów archiwalnych względem przebiegów bieżących w przód w osi czasu, o piksel lub znacznik;

Ctrl-- - przesunięcie przebiegów archiwalnych względem przebiegów bieżących w tył w osi czasu, o piksel lub znacznik;

Ctrl-PgUp - przesunięcie przebiegów archiwalnych względem przebiegów bieżących w przód w osi czasu, o "stronę";

Ctrl-PgDn - przesunięcie przebiegów archiwalnych względem przebiegów bieżących w tył w osi czasu, o "stronę".


19.4.38.5 Funkcje obsługi przebiegów uaktywniane przez mysz

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.5 Funkcje obsługi przebiegów uaktywniane przez mysz

19.4.39.5 Funkcje obsługi przebiegów uaktywniane przez mysz

selekcja - selekcja wykresu, realizowana poprzez ustawienie kursora myszy w obszarze przebiegów wykresu oraz naciśnięcie lewego przycisku myszy;

przesuń kursor - przesunięcie kursora w obszarze przebiegów, realizowane na wyselekcjonowanym wykresie z włączonym kursorem poprzez ustawienie kursora myszy w interesującym miejscu oraz naciśnięcie lewego przycisku myszy;

odczyt wartości - realizowany na bieżąco podczas przesuwania kursora myszy po polu przebiegów wyselekcjonowanego wykresu;

menu kontekstowe - otwierane po kliknięciu prawym klawiszem myszy na polu wykresowym;

pasek narzędziowy - otwiera się przez dwukrotne, szybkie kliknięcie myszą na polu wykresowym.


19.4.38.6 Parametryzacja

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.6 Parametryzacja

19.4.39.6 Parametryzacja

Parametry ogólne

OŚ OX

OŚ_OY

Parametry opisu osi

Parametry siatki

Parametry - Kolorystyka wykresu

Parametry - kursora

Parametry - Zarządzanie krzywymi

Parametry krzywej

Okno dialogowe Parametry obiektu WYKRES pozwala na określenie globalnych parametrów obiektu.

Parametry ogólne

Rysunek: Okno parametryzacji obiektu WYKRES.

Nazwa - pozwala określić nazwę obiektu.

Kolory - przycisk uaktywniający okno dialogowe doboru kolorystyki wykresu.

Kursor - przycisk uaktywniający okno dialogowe określające postać i reakcję kursora wykresu.

Krzywe - przycisk uaktywniający okno dialogowe zarządzające krzywymi w ramach wykresu.

Tytuł - pozwala na wprowadzenie tytułu wykresu, opisującego jego zawartość.

Kierunki osi - pozwala na określenie kierunków osi wykresu. Można wybrać jedną z możliwości: EN, ES, WS, WN, NE, SE, SW, NW. Pierwsza litera określa kierunek osi czasu, a druga kierunek osi wartości. Litery są początkami angielskich nazw stron świata (North, East, South, West);
wartość domyślna EN.

Opis wykresu - pozwala na określenie sposobu opisu wykresu; zarządza elementami wykresu data kursora, czas kursora i wartość kursora. Możliwe są do wyboru następujące kombinacje: Data-Czas-Wartość, Data-Czas lub Brak opisu;
wartość domyślna Data-Czas-Wartość.

Max liczba krzywych - maksymalna liczba krzywych prezentowana w ramach wykresu; wartość domyślna 0;

Numer grupy - daje możliwość grupowania obiektów WYKRES; w definicji każdego obiektu WYKRES, który chcemy zgrupować, należy wpisać identyczny numer grupy, do której WYKRES będzie należał; wszystkie obiekty należące do jednej grupy są obsługiwane (na etapie wykonywania aplikacji) w sposób synchroniczny - operacje zmiany zakresu przewijania wykresu, itp. są wykonywane jednocześnie na wszystkich obiektach grupy;

Parametryzacja dynamiczna - opcja umożliwiająca dynamiczną parametryzację wykresu w trakcie działania aplikacji; wartość domyślna Nie;

Legenda - opcja umożliwiająca wyświetlenia legendy w ramach obiektu Wykres; wartość domyślna Nie;

Czcionka - nazwa fontu użytego do tworzenia legendy;
wartość domyślna Dialog.

Format legendy - pole edycyjne, do którego należy wprowadzić tekst definiujący legendę. Parametry pobierane z bazy zmiennych są określane poprzez wpisanie nazwy parametru w nawiasach klamrowych, np.:

{Nazwa} -- {Jednostka}

Jeżeli pole formatu legendy pozostanie puste lub baza zmiennych nie będzie używana, to zostanie zastosowany format standardowy: Nazwa Zakres Opis.

W polu można wstawić również znacznik {-}, który spowoduje wyświetlenie kreski w kolorze krzywej.

Oś 0X

Początek - określa wartość początkową argumentu wykresu. Jeżeli argument jest czasem to pole to jest ignorowane.

Horyzont - określa horyzont prezentacji wartości argumentu. Jeżeli argument jest czasem to wprowadzane wartości posiadają następujący format: liczba [jednostka czasu]
gdzie: jednostka czasu jest jednym ze znaków s-sekundy, m.-minuty, h-godziny; wartość domyślna 1h.

Krok - określa krok skalowania osi argumentu. Format jak dla pola Horyzont; wartość domyślna 10m.

Oś 0Y

Początek - określa wartość początkową opisu osi;

Koniec - określa wartość końcową opisu osi;

Krok - określa krok skalowania osi wartości;

Parametry opisu osi

Czcionka - czcionka opisu osi; wartość domyślna Dialog;

Szerokość opisu znacznika - 0X: liczba znaków opisu znacznika osi 0X;
wartość domyślna 5;

- 0Y: liczba znaków opisu znacznika osi 0Y;
wartość domyślna 3.

Liczba podprzedziałów - 0X: liczba podprzedziałów pomiędzy znacznikami osi 0X;
wartość domyślna 1;

- 0Y: liczba podprzedziałów pomiędzy znacznikami osi 0Y;
wartość domyślna 1.

Szerokość opisu potęgi - liczba znaków potęgi dla wartości w zapisie wykładniczym; wartość domyślna 0.

Parametry siatki

Siatkę - 0X: opcja rysowania siatki dla osi 0X;
wartość domyślna Tak;

- 0Y: opcja rysowania siatki dla osi 0Y;
wartość domyślna Tak.

Opis osi - 0X: opcja rysowania opisu osi 0X; wartość domyślna Tak;

- 0Y: opcja rysowania opisu osi 0Y; wartość domyślna Tak.

Okno dialogowe parametrów zawiera przyciski Kolory, Kursor i Krzywe, których naciśnięcie uaktywnia kolejne - omawiane poniżej okna dialogowe.

Parametry - kolorystyka wykresu

Rysunek: Okno 'Kolorystyka wykresu'.

Tytuł wykresu - kolor znaków tytułu wykresu; wartość domyślna Żółty;

Kolor tła tytułu wykresu; wartość domyślna Fiolet.

Opis osi - kolor znaków opisu osi; wartość domyślna Błękit;

Kolor tła opisu osi; wartość domyślna Niebieski.

Tło wykresu - kolor tła obszaru przebiegów; wartość domyślna Szary.

Siatka - kolor siatki odczytu; wartość domyślna Morski.

Osie 0XY - kolor linii osi układu współrzędnych;
wartość domyślna Biały.

Parametry kursora

Rysunek: Okno 'Parametry Kursora'.

Tryb pracy - grupa pól pozwalająca na wybór trybu pracy kursora w ramach obszaru przebiegów (Brak, Na żądanie, Zawsze);
wartość domyślna Na żądanie;

Typ - grupa pól pozwalająca na określenie postaci graficznej kursora widocznego w ramach obszaru przebiegów;
wartość domyślna + .

Parametry - zarządzanie krzywymi

Rysunek: Okno 'Zarządzanie krzywymi'.

Definicje krzywych - lista zdefiniowanych krzywych w ramach obiektu; opis podaje nazwę zmiennej oraz jej typ.

Dodaj - przycisk tworzy nową krzywą w ramach obiektu (liczba krzywych zawiera się w ramach wartości określonej przez max liczba krzywych) oraz uaktywnia okno dialogowe 'Parametry krzywej’.

Zmień - przycisk uaktywnia okno dialogowe 'Parametry krzywej’, w celu modyfikacji parametrów wyselekcjonowanej krzywej.

Usuń - usuwa wyselekcjonowaną krzywą.

Parametry krzywej

Rysunek: Okno 'Parametry krzywej'.

Aktywna - opcja określająca, czy w momencie startu obiektu krzywa jest aktywna.

Rodzaj wykresu - grupa pól pozwalająca na wybór rodzaju wykresu:

liniowy: pozwala przedstawić zmianę wartości w czasie za pomocą linii łamanej, której węzłami są punkty pomiarowe połączone linią prostą.

dwustanowy: pozwala przedstawić przebiegi sygnałów mających charakter dwustanowy np. włączenia/wyłączenia urządzeń wykonawczych.

zdarzeniowy: pozwala pokazać momenty pewnych zdarzeń, określonych jako wartości z zakresu 0 do 10, poprzez wyświetlenie znaczników graficznych w osi argumentu (nie zaimplementowany).

słupkowy: pozwala przedstawić zmienność wartości jako ciąg słupków, których wysokość określa wartość. Współpracują z nim dwa dodatkowe typy wykresów:

  • górne ograniczenie: określa sposób prezentacji przekroczenia górnego limitu.

  • dolne ograniczenie: określa sposób prezentacji przekroczenia dolnego limitu.

Nazwa zmiennej - pozwala na określenie nazwy zmiennej, której reprezentacją graficzną będzie parametryzowana krzywa.

Typ krzywej - grupa pól pozwalająca na określenie typu krzywej.

Krzywa bieżąca powoduje przesuwanie zawartości obszaru przebiegów wraz z upływem czasu; wartość domyślna - bieżący.

- grupa pól pozwalająca na określenie rodzaju archiwum, z którego czerpane są wartości zmiennej. Do wyboru mamy archiwa typu H, M, D, Y, B (Patrz: 7.1.2. Podstawowe rodzaje i typy archiwum Aspada) oraz @ - oznacza, że parametr jest zaciągany z bazy danych (Patrz: 19.4.38.7. Parametryzacja z bazy zmiennych); wartość domyślna - H.

- grupa pól pozwalająca na określenie funkcji logicznej stosowanej podczas kreślenia krzywej na ekranie. Służy do uzyskania efektów specjalnych na wykresach;
wartość domyślna - MOV.

Zaczep wzorca - pole pozwalające na wskazanie punktu początkowego krzywej wzorcowej na osi OX. Dotyczy tylko krzywych wzorcowych.

Jeżeli pole jest puste, to przesuwanie krzywej wzorcowej wykonywane jest za pomocą okna do obsługi krzywych archiwalnych.

Pole może zawierać nazwę zmiennej, w której jest przechowywany moment czasu określający punkt zaczepienia krzywej wzorcowej. Zmienna ta musi być typu DW. Operacje na krzywej wzorcowej wykonywane funkcjami obsługi krzywych archiwalnych powodują automatyczne wpisanie punktu zaczepienia krzywej wzorcowej do omawianej zmiennej. Po nowym otwarciu maski z wykresem lub restarcie aplikacji pamiętany jest w zmiennej ostatni punkt zaczepienia krzywej wzorcowej.

Wstępne przeliczanie - grupa pól pozwalająca określić rodzaj funkcji wstępnego przeliczania wartości zmiennej przed jej wykreśleniem. Dostępne są następujące sposoby przeliczania:

brak bez przeliczania wstępnego,

INT część całkowita,

LOG10 logarytm dziesiętny,

SQRT pierwiastek kwadratowy,

AVG średnia "krocząca" z wartości w zadanym horyzoncie czasu; brak pomiaru traktowany jest jako wartość zerowa,

ACC średnia "krocząca" z wartości w zadanym horyzoncie czasu; brak pomiaru nie jest uwzględniany w średniej,

Trend gradient liczony w zadanym horyzoncie czasowym,

100% wartość procentowa w zakresie zmienności zmiennej,

BIT pozwala na rysowanie wykresu dwustanowego z dowolnego bitu zmiennej procesowej; parametrem funkcji jest numer bitu, którego sprawdzanie decyduje o wartości funkcji; funkcja BIT zwraca 0, gdy bit nie jest ustawiony, a 1 w przeciwnym przypadku;

BITV pozwala na rysowanie wykresu dwustanowego z dowolnego bitu zmiennej procesowej; parametrem funkcji jest numer bitu, którego sprawdzanie decyduje o wartości funkcji; funkcja BITV zwraca 0, gdy bit nie jest ustawiony, a wartość równą numerowi bitu w przeciwnym przypadku - pozwala to wyświetlić kilka krzywych dwustanowych na jednym wykresie (nawet dla tej samej zmiennej).

Wartość domyślna: brak.

Kolor - kolor linii; wartość domyślna zielony

Typ linii; wartość domyślna ciągła

Grubość linii; wartość domyślna 1x1

Znacznik - rodzaj znacznika rysowany w miejscu punktu pomiarowego.


19.4.38.7 Parametryzacja z bazy zmiennych

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 19. Obiekty > 19.4. Obiekty - opisy > 19.4.39. Obiekt WYKRES > 19.4.39.7 Parametryzacja z bazy zmiennych

19.4.39.7 Parametryzacja z bazy zmiennych

Pobieranie wartości parametrów z bazy

Określanie rodzaju archiwum

Definiowanie postaci legendy

Przeliczanie wartości zmiennych w trybie 100%

Obiekt WYKRES począwszy od wersji 3.05.006 programu AS może być częściowo parametryzowany na podstawie zawartości bazy zmiennych.

Informacje przechowywane w bazie zmiennych wykorzystywane są do:

  • tworzenia tytułu wykresu;

  • skalowania osi Y;

  • tworzenia legendy;

  • określania rodzaju archiwum, z którego będą pobierane wartości zmiennej;

  • przeliczania wartości zmiennych w trybie wyświetlania 100%.

Pobieranie wartości parametrów z bazy

Rysunek: Okno parametryzacji obiektu WYKRES.

Parametryzacji z bazy zmiennych podlegają pola w grupie Oś 0Y , pola Szerokość opisu znacznika 0Y i Liczba podprzedziałów 0Y oraz pole Tytuł.

Przycisk Łącze wstawia do wymienionych pól znacznik @ (wraz z aktualnymi parametrami), o ile dane pole nie zostanie określone jawnie.

Zasady określania wartości parametrów są następujące:

Początek - pobierany z pola ZakresWyswietlaniaLo - minimum z wartości dla wszystkich krzywych.

Koniec - pobierany z pola ZakresWyswietlaniaHi - maksimum z wartości dla wszystkich krzywych.

Krok - pobierany z pola ZakresWyswietlaniaKrok - maksimum z wartości dla wszystkich krzywych. Jeżeli parametr nie zostanie znaleziony w bazie to jest wyliczany zgodnie z następującym algorytmem. Różnica wartości Początek i Koniec jest dzielona kolejno przez 3, 4 i 5. Dla pierwszego dzielnika, który daje resztę 0 , zakres zmienności jest dzielony przez ten dzielnik i w ten sposób określany jest krok. Jeżeli żaden dzielnik nie spełnia warunku, to przyjmuje się dzielnik równy 2.

Szerokość opisu znacznika 0Y - pobierana z pola ZakresWyswietlaniaSzer - maksimum z wartości dla wszystkich krzywych. Jeżeli parametr nie zostanie znaleziony w bazie to jest wyliczany zgodnie z następującym algorytmem: Szerokość jest równa liczbie znaków w polu Początek lub Koniec (wybierana większa wartość) + 1.

Liczba podprzedziałów 0Y - pobierana z pola ZakresWyswietlaniaPodzial - maksimum z wartości dla wszystkich krzywych. Jeżeli parametr nie zostanie znaleziony w bazie to jest wyliczany zgodnie z następującym algorytmem. Krok jest dzielona kolejno przez 3 i 4. Pierwszy dzielnik, który daje resztę 0 określa liczbę podprzedziałów. Jeżeli żaden dzielnik nie spełnia warunku, to liczba podprzedziałów jest równa 2.

Tytuł - pobierane z pola WykresTytul zmiennej wyświetlanej na pierwszej krzywej. Wymagane jest jawne wprowadzenie znaku @ do pola edycyjnego tytułu.

Określanie rodzaju archiwum

Rysunek: Okno parametrów krzywej.

W parametrach krzywej typ archiwizacji @ oznacza, że rzeczywisty typ archiwum użyty przy otwarciu dostępu do zmiennej, będzie taki jak podany w bazie zmiennych w atrybucie ParametryArchiwizacji. Pozwala to uzyskać niezależność definicji krzywej od typu archiwum zmiennej.

Definiowanie postaci legendy

Format legendy wyświetlanej poniżej pola wykresu jest swobodnie definiowany. W polu edycyjnym Format legendy okna parametrów obiektu WYKRES należy wprowadzić tekst definiujący legendę. Parametry pobierane z bazy zmiennych są określane poprzez wpisanie nazwy parametru w nawiasach klamrowych, np.:

{Nazwa} -- {Jednostka}

Jeżeli pole formatu legendy pozostanie puste lub baza zmiennych nie będzie używana, to zostanie zastosowany format standardowy: Nazwa Zakres Opis.

Przeliczanie wartości zmiennych w trybie 100%

Dla krzywych z ustawionym wstępnym przeliczaniem typu 100% zakres zmienności jest pobierany z pól ZakresPomiarowyLo i ZakresPomiarowyHi bazy zmiennych. Jeżeli baza zmiennych nie jest dostępna, to zakres zmiennej jest określany na podstawie parametrów funkcji przeliczającej Asmena.


20. Architekt – interaktywna konfiguracja aplikacji systemu asix

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 20. Architekt – interaktywna konfiguracja aplikacji systemu Asix

20. Architekt - interaktywna konfiguracja aplikacji systemu Asix

Prawdziwym krokiem milowym w rozwoju pakietu Asix jest moduł Architekt, umożliwiający w pełni wizualne zaprojektowanie, skonfigurowanie i bieżącą edycję aplikacji systemu Asix za pomocą okien dialogowych z systemem zakładek, które w uporządkowany i czytelny sposób grupują wszystkie opcje odpowiedzialne za poszczególne obszary funkcjonalne aplikacji i bezbłędnie prowadzą projektanta przez proces prawidłowego skompletowania wymaganych parametrów (jedynie parametryzacja obiektów umieszczanych na maskach technologicznych odbywa się za pomocą Konstruktora).

Baza definicji zmiennych

W systemie Asix miejscem przechowywania wszelkich informacji o zmiennych procesowych jest baza definicji zmiennych. Stanowi ona podstawowe repozytorium całości informacji o wszystkich zmiennych projektowanego systemu wizualizacji. Moduł Architekt skojarzony z modułem VarDef, odpowiedzialnym za przechowywanie bazy definicji zmiennych, umożliwia w pełni interaktywną i wizualną obsługę bazy definicji, obejmującą: tworzenie struktury bazy i jej edycję oraz edycję zawartości bazy.

Funkcjonalność modułu Architekt zapewnia obsługę baz Microsoft SQL Server 2000/2005, baz formatu MDB (Jet / Microsoft Access), a także zestawów definicji bezpośrednio pobieranych ze skoroszytów programu Excel. Dla zapewnienia kompatybilności z wcześniejszymi wersjami pakietu Asix, definicje zmiennych mogą być również przechowywane w bazie formatu Paradox.

Szczegółowe omówienie zagadnień dotyczących stosowania modułu Architekt do konfigurowania aplikacji systemu Asix znajduje się w drugiej części niniejszego podręcznika "Architekt - Parametryzacja aplikacji".


21. AsAlert - system powiadamiania o zdarzeniach alarmowych

Zadaniem systemu alertowania jest zdalne powiadamianie wybranych osób o ważnych zdarzeniach. Komunikaty mogą docierać do adresatów jako poczta elektroniczna (email) lub jako komunikat SMS sieci GSM. Oba rodzaje przesyłek mogą być przekazywane z wykorzystaniem różnych metod przesyłu - zarówno poprzez Internet, jak i sieć komórkową GSM.

Do wysyłki alertów z zastosowaniem różnych mediów i metod transmisji służą moduły komunikacyjne AsAlerta. Ich zakres funkcjonalny obejmuje między innymi:

  • wysyłkę alertów w postaci poczty elektronicznej poprzez Internet i protokół SMTP,

  • wysyłkę alertów w postaci poczty elektronicznej poprzez sieć komórkową GSM z wykorzystaniem usług poczty elektronicznej operatorów sieci komórkowych,

  • wysyłkę alertów w postaci komunikatów SMS do urządzeń odbiorczych sieci komórkowej (np. telefony komórkowe) poprzez sieć GSM,

  • wysyłkę alertów w postaci komunikatów SMS do urządzeń odbiorczych sieci komórkowej poprzez sieć Internet.

Aplikacje klienckie żądające wysyłki alertów mogą pracować na stacjach sieciowych. Połączenie z AsAlertem uzyskują po pomyślnym zweryfikowaniu przez AsAlerta ich praw dostępu - w tym celu AsAlert utrzymuje listę nazw użytkowników wraz z ich hasłami.

Szczegółowe omówienie zagadnień dotyczących wykorzystania modułu AsAlert do wspomagania mechanizmów powiadamiania o zdarzeniach alarmowych, generowanych przez aplikacje systemu Asix, znajduje się w pomocy dla modułu AsAlert.


22. Aplikacje wielojęzyczne

System aplikacji wielojęzycznych pozwala przełączać na żądanie operatora język pracy aplikacji. Przełączeniu podlegają wszystkie teksty wprowadzone przez projektanta na etapie tworzenia aplikacji. Zestaw używanych języków aplikacji jest deklarowany w parametrach aplikacji. Wszystkie używane języki muszą być oparte na 256 znakowym zestawie znaków.

W typowym zastosowaniu aplikacja jest tworzona w języku podstawowym. Na dalszym etapie prac dostarczane są tłumaczenia tekstów użytych w aplikacji.

Nie należy mylić języków pracy aplikacji z językiem pracy programu. Język pracy programu jest używany w oknach dialogowych i komunikatach. Językiem pracy programu może być język polski lub angielski. Język pracy programu jest określany na podstawie ustawień systemowych lub wybierany przy pomocy programu SelectLanguage. Język pracy programu jest niezmienny przez cały czas działania.


22.1. Deklaracja języków aplikacji

System przełączania języków uaktywnia się, jeżeli w pliku konfiguracyjnym aplikacji zostaną zdefiniowane co najmniej dwa języki pracy. Języki definiowane są przy użyciu programu Architekt:

Architekt > Obszary i komputery > moduł Maski > zakładka Języki

Dla danej aplikacji można zadeklarować pięć języków, co oznacza, że aplikacja zbudowana przy wykorzystaniu pakietu Asix może pracować w pięciu językach. Specjalne znaczenie ma język zadeklarowany jako pierwszy w tabeli języków. Określa on tzw. język podstawowy. Jest to język, w którym aplikacja została zbudowana.


22.2. Wybór języka aplikacji

Język aplikacji może zostać zmieniony poprzez wykonanie funkcji JĘZYK z menu OPCJE okna Panelu Kontrolnego. Funkcja ta otwiera okienko wyświetlające listę zdefiniowanych języków pracy aplikacji. Zawartość listy jest tworzona na podstawie języków zadeklarowanych w tabeli języków (patrz: 22.1. Deklaracja języków aplikacji ).

Alternatywnym mechanizmem wyboru języka jest akcja operatorska LANGUAGE (JĘZYK) o poniższej składni:

LANGUAGE [kod_języka]

Wykonanie akcji z podanym kodem powoduje odpowiednie przełączenie języka pracy. Brak parametru powoduje otwarcie okienka wyboru języka.


Mechanizmy translacji

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.3. Mechanizmy translacji

22.3. Mechanizmy translacji

Do tłumaczenia tekstów stosowane są następujące mechanizmy:

  • Teksty wielojęzyczne;

  • Tablica tekstów;

  • Tablica translacji.


22.3.1. Teksty wielojęzyczne

Ogólny mechanizm umożliwiający zdefiniowanie różnych wersji językowych aplikacji opiera się na odpowiednio sformatowanym tekście.

Format takiego wielojęzycznego tekstu jest następujący:

[kod_1]tekst_1[kod_2]tekst_2[kod_n]tekst_n

Kody języków umieszczone w nawiasach [] muszą być zgodne z kodami języków zdefiniowanych w sekcji LANGUAGES. W czasie działania programu z tekstu wielojęzycznego wybierany jest wariant właściwy dla aktualnego języka aplikacji. Jeżeli brakuje wariantu dla aktualnego języka aplikacji, wykorzystywany jest wariant tekstu, zadeklarowany jako pierwszy.

Teksty wielojęzyczne mogą być użyte jako samodzielny mechanizm tłumaczący lub jako element innego mechanizmu.

Jeżeli w tekście wystąpi konieczność użycia znaku [, to należy wprowadzić go w postaci sekwencji \[.


22.3.2. Tablica Tekstów

Mechanizm Tablicy Tekstów służy do tłumaczenia tekstów, które są wyświetlane w ramach elementów aplikacji i nie są podawane jawnie przez projektanta (są wbudowane w kod programu). Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TextTable.Lng.

Plik Tablicy Tekstów jest plikiem tekstowym, w którym poszczególne linie są tekstami wielojęzycznymi określającym tłumaczenia tekstów. W pliku dopuszczalne są linie komentarzy, które są oznaczane przez znak średnika na początku linii.

W ramach pakietu Asix jest dostarczany plik TextTable.Tlt zawierający kompletną tablicę tekstów dla języków polskiego i angielskiego. Projektant powinien skopiować ten plik do katalogu aplikacji pod nazwą TextTable.Lng, a następnie uzupełnić teksty wielojęzyczne o definicje wariantów dla pozostałych używanych języków aplikacji.

Zasada działania Tablicy Tekstów polega na wyszukiwaniu wśród zdefiniowanych wielojęzycznych tekstów tłumaczenia dla tekstu wbudowanego w program.


22.3.3. Tablica Translacji

Mechanizm Tablicy Translacji służy do tłumaczenia tekstów wprowadzonych przez operatora w trakcie definiowania aplikacji. Dotyczy to głównie tekstów z obiektów umieszczonych na maskach wizualizacyjnych.

Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TranslateTable.Lng. Jest to plik tekstowy, w którym poszczególne linie są tekstami wielojęzycznymi. Teksty podzielone są na grupy, które dzielą teksty według ich miejsca zastosowania. Początek grupy oznaczany jest przez linię postaci:

#nazwa_grupy

Akceptowane są poniższe nazwy grup:

OBJECT - teksty z obiektów wizualizacyjnych,

MASK - teksty użyte w definicjach masek wizualizacyjnej,

TIMER - teksty z definicji czasomierzy,

TREND - teksty z definicji trendów wbudowanych w program AS,

TABLE - teksty z definicji tabel.

W pliku translacji dopuszczalne są także linie komentarzy, które są oznaczane przez znak średnika na początku linii.

Zasada działania Tablicy Translacji polega na wyszukiwaniu wśród zdefiniowanych wielojęzycznych tekstów tłumaczenia dla tekstu użytego w definicji aplikacji. Wyszukiwany jest tekst w wariancie dla języka podstawowego aplikacji i wybierany wariant dla aktualnego języka aplikacji.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.3. Mechanizmy translacji > 22.3.3. Tablica Translacji > 22.3.3.1 Generacja pliku Tablicy Translacji

22.3.3.1 Generacja pliku Tablicy Translacji

Bazowy plik Tablicy Translacji można wygenerować automatycznie przy pomocy funkcji PLIK_TŁUMACZEŃ z menu NARZĘDZIA okna Konstruktora. Wykonanie tej funkcji powoduje wyświetlenie poniższego okna dialogowego:

Rysunek: Okno generacji pliku tłumaczeń.

Po wybraniu kategorii generowanych informacji i użyciu przycisku Generuj wszystkie znalezione teksty zostaną zapisane w pliku TranslateTable.Tlt. Jeżeli istniał wcześniej plik TranslateTable.Lng, to wszystkie zawarte w nim tłumaczenia będą przeniesione do pliku generowanego.

Projektant powinien uzupełnić brakujące tłumaczenia bezpośrednio w pliku TranslateTable.Lng lub uzupełnić plik TranslateTable.Tlt i przemianować go na TranslateTable.Lng.


22.3.4. Atrybuty zastępcze bazy definicji zmiennych

Mechanizm atrybutów zastępczych bazy zmiennych używany jest wszędzie tam, gdzie wyświetlane teksty pobierane są z atrybutów zmiennych procesowych. Ponadto mechanizm używany jest w oknach dialogowych służących do wyboru zmiennej oraz do wyboru atrybutu. Mechanizm zapewnia automatyczne pobranie wersji językowej atrybutu właściwej dla aktualnego języka aplikacji.

Atrybut zastępczy jest to atrybut zastępujący inny atrybut przy zmianie języka aplikacji. Atrybut pełniący rolę atrybutu zastępczego należy zdefiniować w schemacie bazy definicji zmiennych projektowanej aplikacji - na zakładce Atrybuty zastępcze. Tam również następuje powiązanie atrybutów podstawowych z atrybutami zastępczymi:

Architekt > Bazy danych > Baza definicji zmiennych > moduł Edytor schematu (musi być otwarta baza definicji zmiennych, aby możliwe było otwarcie Edytora schematu) > zakładka Atrybuty zastępcze

( [image] patrz: Architekt > 2.2.2.5. Atrybuty zastępcze).

W przypadku deklarowania atrybutu zastępczego, zarówno dla atrybutu podstawowego jak i zastępczego należy zdefiniować język w tabeli języków - zakładka Języki atrybutów w Edytorze schematu. Patrz: Architekt > Deklarowanie języków atrybutów.

Ograniczenia przy definiowaniu atrybutów zastępczych:

  1. Nie wolno definiować atrybutów zastępczych dla atrybutów podstawowych takich jak Nazwa, Kanal, Adres, LiczbaElementow, OkresProbkowania, FunkcjaPrzeliczajaca, Archiwum, ParametryArchiwizacji, Grupa oraz dla atrybutów PlikAsmena, PlikAspada, ZrodloDanych, TabelaDanych.

  2. Parametrami funkcji przeliczającej nie mogą być atrybuty zastępcze.

  3. Atrybut zastępczy musi mieć taki sam typ jak atrybut zastępowany.


22.3.5. Zmiana stron kodowych czcionek

Jeżeli w deklaracji języków aplikacji zostały określone nazwy stron kodowych, to będzie wykonywana automatyczna zmiana strony kodowej dla niektórych czcionek. Zmianie podlegają wyłącznie czcionki zdefiniowane w pliku inicjującym, w których opisie została podana strona kodowa zgodna ze stroną kodową języka podstawowego.

Akceptowane są następujące nazwy stron kodowych: ANSI(zachodnioeuropejska), BALTIC, EASTEUROPE, GREEK, RUSSIAN, TURKISH, CHARSET_numer.


22.4. Obsługa elementów aplikacji

W rozdziale tym opisane zostały szczegółowe informacje dotyczące obsługi wielojęzyczności dla poszczególnych elementów definicji aplikacji.


22.4.1. Parametry aplikacji definionwane przy użyciu tekstów

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.4. Obsługa elementów aplikacji > 22.4.1. Parametry aplikacji definionwane przy użyciu tekstów

22.4.1. Parametry aplikacji definiowane przy użyciu tekstów wielojęzycznych

Wybrane opcje parametryzujące pracę aplikacji można definiować używając tekstów wielojęzycznych.

Są to poniższe opcje związane z wykonywaniem wydruków:

Nazwa aplikacji

Nagłówek

Nagłówek raportu

Stopka

Stopka raportu

Nagłówek alarmów historycznych

Nagłówek alarmów aktywnych

Stopka alarmów historycznych

Stopka alarmów aktywnych

Architekt > Obszary i komputery > moduł Wydruk

Można także używać wielojęzycznych tekstów deklarowanych przy pomocy Parametrów tekstowych:

Architekt > Obszary i komputery > moduł Maski > zakładka Parametry tekstowe


22.4.2. Akcje operatorskie

Akcja PYTAJ

Parametr akcji PYTAJ może być tekstem wielojęzycznym.

Akcja MENU

Teksty wyświetlane w menu, zdefiniowane w pliku pum, mogą być podawane w formacie tekstu wielojęzycznego.


22.4.3. Skrypty

Utworzenie skryptu, który uwzględnia aktualny język aplikacji należy wyłącznie do autora skryptu. Kod aktualnego języka można pobrać z właściwości LanguageApplication obiektu Application.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.4. Obsługa elementów aplikacji > 22.4.4. Raporty

22.4.4. Raporty

W razie konieczności należy przygotować różne wersje językowe i wybierać właściwy raport w oknie Raportera.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.4. Obsługa elementów aplikacji > 22.4.5. Trendy wbudowane

22.4.5. Trendy wbudowane

Parametry Opis i Tytuł definicji trendu tłumaczone są poprzez Tablicę Translacji. Teksty stałe okna trendu tłumaczone poprzez Tablicę Tekstów.


Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 22. Aplikacje wielojęzyczne > 22.4. Obsługa elementów aplikacji > 22.4.6. Maski wizualizacyjne

22.4.6. Maski wizualizacyjne

Parametr Opis maski tłumaczony jest poprzez Tablicę Translacji.


22.4.7. Obiekty wizualizacyjne

W przypadku obiektów, które pobierają parametry tekstowe z bazy zmiennych można korzystać z mechanizmu atrybutów zastępczych. Pozostałe zasady translacji są następujące:

  • DATA+CZAS

Nazwy miesięcy pobierane z Tablicy Tekstów

  • KOMUNIKATY

Teksty komunikatów są zdefiniowane w pliku tekstowym, w którym można używać formatu tekstów wielojęzycznych. Jeżeli komunikat nie jest tekstem wielojęzycznym, to podlega tłumaczeniu przez Tablicę Translacji.

  • NAPĘD

Stałe opisy klawiszy pobierane są z Tablicy Tekstów. Opisy podawane przez projektanta tłumaczone przez Tablicę Translacji.

  • PRZEŁĄCZNIK

Teksty z Listy Tekstów tłumaczone są poprzez Tablicę Translacji.

  • PRZYCISK

Parametry Linia 1 i Linia 2 tłumaczone są poprzez Tablicę Translacji.

  • SELEKTOR

Parametr Tekst tłumaczony jest poprzez Tablicę Translacji.

Teksty z Listy Tekstów, o ile nie są stosowane odpowiedniki tekstów, tłumaczone są poprzez Tablicę Translacji. W przypadku odpowiedników tekstów można stosować teksty wielojęzyczne w pliku inicjującym.

  • TEKST

Parametr Tekst, o ile nie jest odpowiednikiem tekstu, jest tłumaczony poprzez Tablicę Translacji. Każda linia tekstu jest tłumaczona oddzielnie. W przypadku odpowiedników tekstów można stosować teksty wielojęzyczne w pliku inicjującym.

  • TEKSTY

Teksty z Listy Tekstów, o ile nie są stosowane odpowiedniki tekstów, tłumaczone są poprzez Tablicę Translacji. Każda linia w tekście wieloliniowym jest tłumaczona oddzielnie. W przypadku odpowiedników tekstów można stosować teksty wielojęzyczne w pliku inicjującym.

  • WYKRES

Parametr Tytuł tłumaczony jest poprzez Tablicę Translacji.

  • WYŁĄCZNIK

Opisy stanów tłumaczone są poprzez Tablicę Translacji.


22.4.8. Tabele

Parametr Tytuł definicji tabeli tłumaczony jest poprzez Tablicę Translacji. Można korzystać z atrybutów zastępczych dla parametrów pobieranych z bazy definicji zmiennych.


22.4.9. System alarmów

Teksty alarmów i nazwy grup w tekstowych plikach definicyjnych można podawać w formacie tekstów wielojęzycznych.

Teksty wbudowane, używane podczas wydruków alarmów, są tłumaczone poprzez Tablicę Tekstów.


23. AsBase

Moduł AsBase jest częścią systemu Asix przeznaczoną do tworzenia aplikacji, których celem jest:

  1. archiwizacja wybranych danych procesowych w bazie danych wraz z ich późniejszą analizą,

  2. realizacja systemu zarządzania recepturami.

Charakterystyczną cechą AsBasa jest jego w pełni interaktywna parametryzacja i obsługa. Ponadto, od twórcy aplikacji nie jest wymagana żadna wiedza dotycząca tworzenia baz danych. Cały proces budowy aplikacji odbywa się poprzez wprowadzanie danych w oknach dialogowych modułu.

W części archiwizacyjnej AsBase jest przystosowany do zapisywania danych w postaci struktur złożonych z wartości wielu zmiennych procesowych. Operacja zapisu jest inicjowana zajściem warunku logicznego zależnego od wartości zmiennych synchronizujących lub/i aktualnego czasu. W przypadku konieczności zapisu z dużą częstotliwością wartości pojedynczych zmiennych, należy stosować metody archiwizacji udostępniane przez moduł Aspad.

AsBase przechowuje dane w bazie danych serwera Microsoft SQL Server 2000. Można wykorzystywać wersję MSDE tego serwera, która jest dostarczana bez dodatkowych kosztów w ramach systemu Asix. Można też stosować tzw. wersje pełne serwera, lecz w tym przypadku użytkownik ponosi koszty zakupu odpowiednich licencji.

Zastosowanie standardowej bazy danych stwarza użytkownikom możliwość łatwego dostępu do danych aplikacji z innych programów, pisanych własnoręcznie lub standardowych (np. Microsoft Excel).

Zakres funkcji realizowanych przez moduł AsBase jest następujący:

  1. wbudowany system budowy aplikacji,

  2. zintegrowany z aplikacją system uprawnień dostępu,

  3. automatyczna archiwizacja danych procesowych uruchamiana zgodnie z harmonogramem czasowym lub na podstawie wartości zmiennych procesowych,

  4. możliwość ręcznej edycji (uzupełniania) archiwum,

  5. edycja receptur,

  6. ładowania wartości receptury do zmiennych procesowych,

  7. rejestracja operacji ładowania receptur,

  8. podgląd bieżących wartości zmiennych procesowych z możliwością ręcznego uaktywnienia operacji zapisu do bazy danych aplikacji,

  9. system analizy i wydruku archiwizowanych danych i receptur,

  10. eksport danych do plików tekstowych, xls, xml i html,

  11. wbudowany system zarządzania bazą danych.

Szczegółowy opis użycia modułu AsBase można znaleźć w pomocy dla modułu AsBase.


24. Menedżer połączeń AsComm

Menedżer połączeń AsComm - program AsComm służy do zarządzania i monitorowania połączeń dokonywanych przez moduły systemu Asix. Połączenia nawiązywane są za pomocą portów szeregowych lub modemów (np. linie komutowane). Podstawowymi elementami zarządzanymi przez program AsComm są "Klient" i "Zasób". Klientem jest moduł systemu Asix wykorzystujący funkcje programu AsComm. Klient identyfikowany jest poprzez jego nazwę. Zasobem jest łącze komunikacyjne, takie jak port szeregowy lub modem. Za pośrednictwem programu AsComm "klienci" mogą korzystać z "zasobów" do nawiązywania połączeń. Z pojedynczego zasobu może korzystać wielu klientów. Jednym z zadań programu AsComm jest umożliwienie współdzielenia pojedynczego łącza pomiędzy wielu klientów. Sposób przydziału zasobów oraz realizacji pozostałych funkcji jest określony poprzez odpowiednią parametryzację pliku inicjalizacyjnego.

Szczegółowe omówienie zagadnień dotyczących wykorzystania powyższego modułu znajduje się w pomocy dla modułu AsComm.


25. Asix4Internet - wizualizacja i nadzór poprzez Internet

W wersji 8 pakietu Asix4Internet to narzędzie zawierające dwa moduły do użytku z klasyczną wersją Asixa:

· AsPortal - Webowy Portal Informacji Procesowych - gotowy do natychmiastowego użycia, pozwala przeglądać w Internecie dane procesowe z dowolnej aplikacji systemu Asix. Portal umożliwia przeglądanie bazy zmiennych, odczyt wartości bieżących, wgląd w listę alarmów aktywnych i alarmów historycznych, prezentację historycznych wartości zmiennych procesowych w układzie tabelarycznym lub w postaci wykresów; AsPortal – witryna w technologii HTML – jest dostępna pod dowolną przeglądarką internetową na dowolnym systemie operacyjnym.

· AsTrend - wersja przeglądarkowa programu graficznej analizy danych historycznych, o funkcjonalności zgodnej z wersją okienkową, szczególnie wysoko ocenianą przez użytkowników,

Funkcja konwersji klasycznej aplikacji systemu Asix na aplikację internetową została w wersji 8 pakietu usunięta. Aby utworzyć wersję internetową aplikacji, należy przekonwertować aplikację klasyczną na wersję Evo i dopiero wtedy opublikować ją jako aplikację WWW.

Istnieje również wersja internetowa narzędzia przeznaczonego do: interaktywnej analizy historycznych zdarzeń alarmowych aplikacji - program AsAlarm.

Do uruchomienia modułów i korzystania z nich lokalnie wymagane jest posiadanie klucza HASP od wersji Asix 7. Do korzystania z modułów zdalnie wymagany jest klucz HASP Asix rozszerzony o licencję klientów internetowych. Szczegóły w informacjach handlowych na witrynie www.asix.com.pl.

Szczegółowe omówienie zagadnień dotyczących wykorzystania powyższych modułów znajduje się w pomocy dla modułów AsPortal, AsAlarm i AsTrend.


26. AsixConnect

Pakiet AsixConnect jest pakietem serwerów rozszerzającym możliwości zastosowań pakietu Asix w dziedzinie wizualizacji i nadzoru procesów przemysłowych.

Komputer posiadający fizyczne połączenie ze sterownikiem (za pośrednictwem łącza szeregowego, magistrali przemysłowej lub sieci lokalnej) stanowi źródło informacji o zmiennych procesowych dla innych komputerów w sieci lokalnej; komputer taki jest serwerem danych bieżących i archiwalnych. W dostępie do tych danych pośredniczy pakiet AsixConnect.

Pakiet AsixConnect zawiera serwery OPC, Automation, .NET i DDE udostępniające wartości bieżące zmiennych procesowych z aplikacji pakietu Asix, serwery Automation, .NET i OLE DB udostępniające wartości archiwalne zmiennych procesowych oraz serwer .NET udostępniający dane o alarmach. Ponadto pakiet zawiera serwer Web Service udostępniający wszystkie rodzaje danych aplikacji systemu Asix w standardzie XML Web Services.

Każdy program środowiska Windows wyposażony w obsługę mechanizmu Automation, OPC, .NET lub DDE może współdziałać z aplikacją programu Asix za pośrednictwem serwerów pakietu AsixConnect. Taki program może być zarówno konsumentem danych z procesu przemysłowego jak i źródłem danych dla celów sterowania nadrzędnego lub parametryzacji. Innymi słowy tą drogą w środowisku Windows dostępne są on-line wartości bieżące zmiennych procesowych jak i ich wartości archiwalne, czyli zarejestrowane przebiegi czasowe. Przykładami produktów wyposażonych w mechanizmy wymiany danych Automation i DDE są składowe pakietu Microsoft Office - Excel, Access, Word i PowerPoint. Aplikacje stworzony przy użyciu tych produktów i pakietu AsixConnect mogą efektywnie wzbogacać komputerowe systemy nadzoru. Aplikacje te mogą służyć do analizy i prezentacji danych, badań modelowych, specjalistycznego raportowania czy tworzenie baz danych procesowych.

AsixConnect jest integralnym elementem pakietu Asix, ale jest także dostępny jako samodzielny produkt. Produkt ten może być stosowany na stacjach PC dołączonych do lokalnych sieci komputerowych i mających dostęp do serwerów danych wyposażonych w pakiety Asix. W tym przypadku AsixConnect udostępnia w środowisku Windows dane importowane z oddalonych stanowisk komputerowych wyposażonych w łącza ze sterownikami procesów.

Szczegółowe omówienie zagadnień dotyczących wykorzystania możliwości pakietu AsixConnect znajduje się w odrębnym pliku pomocy dla modułu AsixConnect.


27. Program AsTrend

Program AsTrend - przeznaczony jest do graficznej prezentacji danych archiwalnych gromadzonych przez program archiwizacji danych Aspad. Możliwe są dwa sposoby pracy tego programu: statyczne odrysowanie danych zgromadzonych w plikach archiwalnych lub dynamiczne wyświetlanie danych napływających z obiektu (symulacja rejestratora). W tym drugim trybie pracy AsTrend działa jak obiekt WYKRES, lecz łatwo w nim można zmieniać listę wyświetlanych krzywych, parametry osi wartości i czasu, drukować trend na papierze i wykonywać na wykresach wiele innych czynności, których nie da się wykonać na obiekcie WYKRES. W porównaniu z narzędziem Trend dostępnym z menu konstruktora, AsTrend jest łatwiejszy w użyciu, parametryzacji i przewyższa go możliwościami prezentacji danych. W nowych aplikacjach zaleca się więc używanie programu AsTrend.

Szczegółowy opis użycia programu AsTrend można znaleźć w pomocy dla modułu AsTrend.


28. Program AslView

Program AslView - służy do wizualizacji i diagnostyki połączeń sieciowych systemu Asix. Program AslView pozwala połączyć się z modułem sieciowym Aslink systemu Asix pracującym na lokalnej lub zdalnej stacji oraz obserwację stanu połączeń nawiązywanych przez inne komponenty systemu Asix - jak Asmen i Aspad, a także obserwację stanu synchronizacji czasu z innymi stacjami. Za pośrednictwem programu AslView można sparametryzować działanie modułu sieciowego Aslink.

Szczegółowy opis użycia programu AslView można znaleźć w pomocy dla modułu AslView.


29. Program AspadTools

Program AspadTools - jest przeznaczony do przetwarzania i konserwacji plików archiwum typu Y, M, D i H.

Pozwala on na:

· zmianę konwencji nazw plików ze starej (Aspad 5) na nową (Aspad 6) i odwrotnie,

· konwersję archiwum na inny typ (np. M na D),

· eksport do pliku tekstowego,

· sprawdzenie i naprawę archiwum,

· zbieranie statystyk dotyczących wielkości danych dla poszczególnych zarchiwizowanych przebiegów zmiennych,

· zmianę nazwy lub usuwanie zmiennej z pliku archiwalnego.

Szczegółowy opis użycia programu AspadTools można znaleźć w pomocy dla modułu Aspad_tools, znajdującym się w kartotece instalacyjnej \ASIX\Dokumentacja.


30. Menedżer kanałów logicznych dla drajwera OPC

Menedżer kanałów logicznych umożliwia łatwe edytowanie definicji kanałów transmisji korzystających z serwera OPC przez proste wybieranie opcji w oknie dialogowym, specjalnie przygotowanym dla drajwera OPC. Możliwa jest również tekstowa edycja kanałów transmisji korzystających z innych drajwerów niż drajwer OPC.

Menedżer kanałów znajduje się w pliku ChannelsManager.exe w katalogu systemu Asix (domyślnie c:\asix). Po uruchomieniu programu pojawia się okno główne:

Rysunek: Okno menedżera kanałów systemu Asix

W menu Plik programu znajdują się następujące polecenia:

Nowy - utworzenie nowego pliku ini aplikacji systemu Asix,

Otwórz - załadowanie do menedżera istniejącego pliku ini aplikacji,

Zapisz - zapisanie w pliku ini dokonanych modyfikacji,

Zapisz jako - zapisanie pliku ini pod nową nazwą,

Koniec - zakończenie pracy programu.

W menu Kanały znajdują się następujące polecenia:

Nowy - utworzenie nowego logicznego kanału transmisji,

Zmień nazwę - zmiana nazwy kanału transmisji,

Edytuj - edycja definicji kanału transmisji,

Edytuj jako tekst - edycja definicji kanału transmisji w postaci tekstowej, w tym również kanału odwołującego się do serwera OPC,

Usuń - usunięcie definicji kanału transmisji.

Po otwarci pliku ini aplikacji okno główne wygląda następująco:

Rysunek: Okno menedżera kanałów logicznych dla drajwera OPC.

Kanały WinTech i MATRIKON korzystają z drajwera OPC. Okno edycji kanału WinTech prezentuje poniższy rysunek.

Rysunek: Okno ustawień opcji kanału menedżera kanałów logicznych dla drajwera OPC.

Identyfikator serwera OPC można wpisać ręcznie lub wybrać z menu rozwijanego. Przed pierwszym wyświetleniem okna przeglądany jest rejestr systemu Windows w poszukiwaniu zarejestrowanych serwerów OPC. Jeżeli takie serwery zostaną znalezione, to ich identyfikatory są umieszczane w menu rozwijanym pola Identyfikator serwera OPC.

Pozostałe opcje dostępne w oknie dialogowym są opisane w rozdziale Asmen - menedżer komunikacyjny/Drajwer OPC/Definicja kanału logicznego.

W przykładowej aplikacji zdefiniowano są też dwa kanały transmisji korzystające z drajwerów NETWORK i NONE. Kanały te mogą być edytowane tylko tekstowo. Okno edytujące kanał OPC wygląda następująco:

Rysunek: Okno edycyjne kanału OPW.


32. As_Power_Close

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 31. As_Power_Close

31. as_power_close

Program as_power_close przeznaczony jest do współpracy z oprogramowaniem kontrolującym pracę zasilaczy UPS. Uruchomienie w dowolny sposób programu as_power_close powoduje natychmiastowe i bezwarunkowe zakończenie programu AS. W logu komunikatów programu AS wpisywana jest informacja o przyczynie końca pracy.

Plik a s_power_close.exe znajduje się w kartotece instalacyjnej \ASIX.


33. Program ZMIANADP

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 32. Program ZMIANADP

32. Program ZMIANADP

Program zmiany lub listowania nazw zmiennych procesowych ZMIANADP pozwala na globalną wymianę lub wylistowanie do pliku tekstowego nazw zmiennych procesowych, użytych jako parametry w obiektach masek wizualizacyjnych.

Program ZMIANADP bierze pod uwagę wszystkie zmienne użyte na masce (w tym w treści akcji operatorskich oraz w obiektach WYRAŻENIE, PRZELICZNIK, RAPORT).

W przypadku użycia programu do zmiany nazw, możliwe są dwie sytuacje:

- kompletna zmiana nazewnictwa, np. w przypadku tworzenia bliźniaczej aplikacji;

- zmiany nazw na pojedynczej masce, np. tworzenie nowej maski na podstawie podobnej maski, działającej na innych zmiennych.

Program ZMIANADP wykonywany jest w trybie wsadowym. Nie wymaga obecności żadnego innego programu systemu Asix.

Należy zwrócić uwagę na numer wersji programu ZMIANADP. Jest on identyczny z numerem wersji programu AS, którego format jest formatem roboczym programu ZMIANADP. Program ZMIANADP potrafi czytać pliki z wcześniejszych wersji, modyfikacje są jednak zapisywane w formacie roboczym. Oznacza to, ze nie należy modyfikować masek z wcześniejszych wersji programu AS, jeżeli maski mają być dalej używane przez tę wcześniejszą wersję.
Uruchomienie programu ZMIANADP w trybie listowania wymaga użycia przełączników /l lub /v. Brak tych przełączników oznacza pracę w trybie zamiany nazw zmiennych.

Tryb zamiany nazw

W przypadku zamiany nazw zmiennych - program ZMIANADP uruchamiany jest komendą:

zmianadp <plik nazw> <plik maski>

gdzie:

<plik nazw> - określa nazwę pliku tekstowego, w którym umieszczona została informacja o sposobie zmiany nazw; plik definicji zamian jest plikiem złożonym z linii, w których zapisane są pary nazw zmiennych procesowych oddzielone znakami spacji; pierwsza nazwa określa nazwę zmiennej, do której odwołania są poszukiwane; druga nazwa w linii pliku zamian określa nazwę zmiennej, na którą należy dokonać zamiany;

<plik maski> - określa nazwę pliku definicji maski, którego zawartość ma zostać zmodyfikowana; podanie rozszerzenia MSK nie jest konieczne; możliwe jest użycie w nazwie pliku znaków ? i * - stwarza to możliwość przetworzenia za jednym wykonaniem programu całej grupy masek.

PRZYKŁAD

zawartość pliku zmiany.txt:

TEMPA11 TEMPX30

TEMPA12 TEMPY0

komenda:

zmianadp zmiany.txt *

efekt:

We wszystkich maskach bieżącego katalogu odwołania do zmiennej TEMPA11 zostaną zamienione na TEMPX30, a odwołania do TEMPA12 na TEMPY0.

Tryb listowania

W przypadku listowania nazw zmiennych - program ZMIANADP uruchamiany jest komendą:

ZmianaDp [/l] [/v] [/b] [/c] [/s] <plik_nazw> <wzorzec_nazwy_maski>[;<>wzorzec nazwy_maski> ... ]

Uruchomienie programu ZMIANADP w trybie listowania wymaga użycia przełączników /l lub /v, gdzie:

przełącznik /l - tryb listowania zmiennych z podaniem trybów archiwizacji użytych w obiektach WYKRES

przełącznik /v - tryb listowania nazw zmiennych bez dodawania tryby archiwizacji

Przełączniki /b , /c , /s muszą być stosowane łącznie z przełącznikami /l lub /v:

przełącznik /b - tryb listowania, w którym dla każdego pliku pokazywana jest lista wszystkich użytych zmiennych

przełącznik /c - tryb listowania, w którym dla każdej zmiennej pokazywana jest lista wszystkich plików, na których zmienna została użyta

przełącznik /s - w poszukiwaniu plików masek przeglądane są również wszystkie podkatalogi

Brak przełączników /l i /v oznacza pracę w trybie zamiany nazw zmiennych.

<plik nazw> - plik nazw zmiennych, dla /l i /v jest on tworzony w wyniku działania programu, w innym przypadku zawiera pary zamienianych nazw

<wzorzec_nazwy maski> - jeden lub więcej wzorców określających lokalizację oraz nazwy przetwarzanych plików.

PRZYKŁAD

zmianadp /v /s zmienne.txt c:\huta\*.msk - zapisuje w pliku zmienne.txt wszystkie zmienne użyte we wszystkich plikach masek w katalogu c:\huta łącznie z podkatalogami.


34. Przebiegi wzorcowe

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 33. Przebiegi wzorcowe

33. Przebiegi wzorcowe

Aktualnie system Asix oferuje znacznie rozszerzone możliwości w zakresie przebiegów wzorcowych:

  • program dialogowej edycji przebiegów wzorcowych PEdit,

  • możliwość automatycznej zmiany punktu zaczepienia początku wzorca na wykresie,

  • możliwość przechowywania punktu zaczepienia wzorca, także po restarcie Asixa.

Ponadto ASKOM oferuje rozwiązania oparte na skryptach, uzupełnionych dodatkowym programem PSelect. Pozwalają one na:

  • ręczny wybór krzywej wzorcowej,

  • automatyczny wybór krzywej wzorcowej,

  • transfer wybranej krzywej wzorcowej do sterownika, gdzie może być wykorzystana do sterowania.

Przebiegi wzorcowe traktowane jako dodatkowy typ archiwum tylko do odczytu, oznaczany literą P.

Dane wzorców przechowywane są w bazie danych w sposób analogiczny do archiwum B. Wzorce najlepiej przechowywać w osobnej bazie danych, traktowanej jako odrębny zasób programu Aspad. Jest możliwe umieszczenie archiwum B i P w tej samej bazie danych, niemniej rozwiązanie to nie jest zalecane.

Szczegółowy opis wykorzystania programu PEdit, PSelect oraz skryptów do obsługi przebiegów wzorcowych można znaleźć w pomocy do Przebiegów wzorcowych.


35. Moduł SKRYPTÓW

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 34. Moduł SKRYPTÓW

34. Moduł SKRYPTÓW

Celem modułu skryptów jest rozszerzenie funkcji systemu Asix o:

  • wykonywanie nietypowych obliczeń na wartościach zmiennych procesowych;

  • zaprogramowanie nietypowych reakcji na zdarzenia wewnątrz modułu Asix;

  • przekazywanie na zewnątrz systemu Asix wartości zmiennych i innych informacji o działaniu systemu;

  • pozyskiwanie danych z nietypowych źródeł danych.

W celu realizacji powyższych zadań moduł skryptów umożliwia:

  • automatyczne uruchamianie wielu współbieżnych skryptów stworzonych w różnych językach z możliwością określenia priorytetu/ważności skryptu;

  • wymianę danych pomiędzy skryptami;

  • wywoływanie przez jeden skrypt funkcji znajdujących się w innych skryptach stworzonych w różnych językach (skrypty biblioteczne);

  • przekazywanie sterowania do systemu Asix w wyniku zdarzeń powstałych w czasie wykonywania skryptu (akcje operatorskie);

  • kontrolę czasu wykonywania skryptów;

  • śledzenia zmian w pliku zawierającym program skryptu i automatyczne ponowne uruchomienie skryptu po wykryciu takich zmian;

Szczegółowy opis użycia modułu SKRYPTÓW można znaleźć w pomocy do modułu skryptów.


Środowisko projektowania raportów na bazie Report Services MS Microsoft

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 35. AsRaport - środowisko projektowania raportów na bazie Report Services MS Microsoft

35. AsRaport - środowisko projektowania raportów na bazie Report Services MS Microsoft

Microsoft® SQL Server™ 2008 Reporting Services jest kompletną platformą serwerową zaprojektowaną do spełniania szerokiego zakresu oczekiwań w dziedzinie raportowania na poziomie całego przedsiębiorstwa. Usługi Reporting Services, będące komponentem bazy danych SQL Server 2008, umożliwiają: tworzenie raportów na podstawie różnorodnych źródeł danych ( w tym raportowanie ad hoc oparte na przyjaznym dla użytkownika semantycznym modelu raportu, umożliwiającym tworzenie raportów bez konieczności posiadania szczegółowej wiedzy technicznej na temat wykorzystywanych źródeł danych); zarządzanie środowiskiem raportowania polegające na planowaniu generowania raportów, zarządzaniu prenumeratami raportów i kontrolowaniu praw dostępu; a także dostarczanie użytkownikom raportów w stosownym formacie i w dogodny dla nich sposób (przewidziana między innymi możliwość automatycznego dostarczania raportów drogą elektroniczną poprzez subskrypcję, bądź też możliwość osadzania raportów w aplikacjach biznesowych i portalach).

Rozszerzenie systemu Asix w zakresie współpracy ze środowiskiem raportowym Reporting Services obejmuje programy: Askom.Data.Host, AsRaport, archiwizator alarmów w bazie Microsoft SQL oraz bazę danych AsixConnect na serwerze Microsoft SQL. Kluczowy element stanowi baza AsixConnect, której procedury składowane za pośrednictwem programu Asix.Data.Host udostępniają do środowiska raportowego dane procesowe z aplikacji Asix.

Szczegółowy opis dotyczacy projektowania raportów w środowisku projektowania raportów - AsRaport można znaleźć w pomocy AsRaport.chm lub AsRaport.pdf.


36. Symulator przebiegów

37. Symulator przebiegów

Moduł symulatora przebiegów zmiennych procesowych pozwala na tworzenie realistycznych symulacji procesów przemysłowych. Używany jest w systemach demonstracyjnych, uruchamianych bez dostępu do sterowników. Podstawową różnicą w stosunku do wewnętrznej symulacji Asmena jest fakt tworzenia elementów logicznych, które składają się z kilku nawzajem sprzężonych zmiennych. Moduł Symulatora uaktywniany jest automatycznie w przypadku stwierdzenia w pliku konfiguracyjnym aplikacji sekcji [SYMULACJA].

Sekcja [SYMULACJA] deklarowana jest przy użyciu programu Architekt w następujący sposób:

W programie Architekt > Obszary i komputery > module Pozostałe > mieści się zakładka Opcje wprowadzane bezpośrednio (aby zakładka była widoczna, musi być włączona opcja Pokazuj opcje zaawansowane (w kategorii Obszary i komputery górnego menu okna Architekta)

Zakładka Opcje wprowadzane bezpośrednio wymaga podania nazwy sekcji, nazwy opcji oraz wartości opcji.

Zestawienie dostępnych opcji dla sekcji [SYMULACJA] zawiera rozdział

W celu poprawnej pracy modułu wymagane są jeszcze następujące zmiany w definicji zmiennych procesowych menedżera Asmen:

- przedefiniowanie kanałów transmisji używanych w symulacji na typ NONE,

- zmiana funkcji przeliczających dla zmiennych symulowanych na odpowiednie wersje funkcji NIC_xx.

Opis symulacji jest umieszczany w sekcji [SYMULACJA] pliku konfiguracyjnego aplikacji. Można tam jednak wpisać pozycję:

PLIK_SYMULACJI=nazwa_pliku

ażeby skierować czytanie opisu symulacji z sekcji [SYMULACJA] do innego pliku (w którym także należy użyć sekcji [SYMULACJA]).

Opis symulacji składa się z zestawu opisów elementów (w kolejnych pozycjach sekcji), które definiują sposób zmian zmiennych oraz ich wzajemnych powiązań.

PRZYKŁAD

[symulacja]

inicjuj=D1,10.18

inicjuj=D6,567

inicjuj=R2,1000

naped=D2,D3,D4,D5,2048

pseudo=D9,-10,10,2

pseudo=D10,-15,20,1

regulator=R1,R2,U1,21

regulator=R1F,R2F,U2,11

relacja=R3,-100,100,D5,2048

relacja=R3F,0,4000,D5,2048


36.1. Opcje wykorzystywane do parametryzacji symulatora

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 37. Symulator przebiegów > 37.1. Opcje wykorzystywane do parametryzacji symulatora

37.1. Opcje wykorzystywane do parametryzacji symulatora przebiegów zmiennych procesowych

Poniższe opcje deklarowane są przy użyciu programu Architekt w następujący sposób:

w programie Architekt > Obszary i komputery > module Pozostałe > mieści się zakładka Opcje wprowadzane bezpośrednio (aby zakładka była widoczna, musi być włączona opcja Pokazuj opcje zaawansowane (w kategorii Obszary i komputery górnego menu okna Architekta)

Zakładka Opcje wprowadzane bezpośrednio wymaga podania nazwy sekcji, nazwy opcji oraz wartości opcji.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: INICJUJ

Wartość opcji: <zmienna>,<wartość>

Znaczenie - inicjowanie zmiennej na wybraną wartość.

Parametry:

<zmienna> - nazwa zmiennej procesowej.

<wartość> - wartość, która ma zostać wpisana do zmiennej.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: NAPED

Wartość opcji: <sterowanie>,<status>,<zadawanie>,<wartość>,<zakres>

Znaczenie - symulacja napędu w sposób zgodny z działaniem sprzężonych obiektów klas NAPED i SUWAK.

Parametry:

<sterowanie> - nazwa zmiennej sterującej obiektu NAPED;

<status> - nazwa zmiennej monitorowanej obiektu NAPED;

<zadawanie> - nazwa zmiennej sterującej obiektu SUWAK;

<wartość> - nazwa zmiennej monitorowanej obiektu SUWAK;

<zakres> - limit górny zmiennej monitorowanej obiektu SUWAK.

Obiekt wylicza wartość zmiennej monitorowanej obiektu NAPED w zależności od zmian jego zmiennej sterującej. Jednocześnie powoduje odpowiednią zmianę wartości monitorowanej obiektu SUWAK. Osiągnięcie przez nią wartości granicznej wpływa zwrotnie na stan zmiennej monitorowanej obiektu NAPED. Możliwa jest też zmiana wartości obiektu SUWAK poprzez zmienną <zadawanie> (przesunięcie suwaka na masce).

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: PSEUDO

Wartość opcji: <zmienna>,<limit dolny>,<limit górny>,<częstość zmiany>

Znaczenie - pseudolosowa zmiana wartości w zadanym zakresie.

Parametry:

<zmienna> - nazwa symulowanej zmiennej,

<limit dolny> - dolne ograniczenie zakresu zmian,

<limit górny> - górne ograniczenie zakresu zmian,

<częstość zmian> - odstęp w sekundach pomiędzy zmianami.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: REGULATOR

Wartość opcji: <wart. bieżąca>,<wart. zadana>,<zmienna uchybu>,<czas dojścia>

Znaczenie - symulacja regulatora.

Parametry:

<wart. bieżąca> - nazwa zmiennej regulowanej

<wart. zadana> - nazwa zmiennej określająca wart. zadaną

<zmienna uchybu> - nazwa zmiennej dla wartości uchybu

<czas dojścia> - czas w sekundach, po których wartość bieżąca osiąga wartość zadaną

Zmiana przez operatora wartości zadanej powoduje odpowiednią modyfikację zmiennej wartości bieżącej z jednoczesnym liczeniem uchybu.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: RELACJA

Wartość opcji: <zmienna>,<limit dolny>,<limit górny>,<zmienna ster.>,<zakres>

Znaczenie - przeliczenie proporcjonalne.

Parametry:

<zmienna> - nazwa zmiennej liczonej,

<limit dolny> - dolne ograniczenie zakresu zmian zmiennej liczonej,

<limit górny> - górne ograniczenie zakresu zmian zmiennej liczonej,

<zmienna ster.> - nazwa zmiennej sterującej,

<zakres> - maks. dopuszczalne wartość zmiennej sterującej.

Zmiana wartości zmiennej sterującej powoduje modyfikację zmiennej liczonej. Zmiana zmiennej liczonej jest liniowo proporcjonalna do wartości zmiennej sterującej, biorąc pod uwagę, że zmienna sterująca zmienia się w zakresie od 0 do <zakres>, a zmienna przeliczana w zakresie od <limit dolny> do <limit górny>.

<zmienna> = <limit dolny> + ( <limit górny> - <limit dolny> ) * ( <zmienna ster.> / <zakres> )

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: SUMALOG

Wartość opcji: Y,YB,X1,XB1,X2,XB2,X3,XB3\

Znaczenie - wykonuje sumę logiczną wybranych bitów dwóch lub trzech zmiennych.

Parametry:

Y - zmienna wynikowa, typu słowo 16-bitowe;

YB - maska bitowa określająca bity ustawiane/zerowane w zmiennej wynikowej, podawana jako liczba dziesiętna;

X1,X2,X3 - zmienne, których wartości są sumowane logicznie, typu słowo 16 bitowe;

B1,XB2,XB3 - maski bitowe, które określają bity brane pod uwagę, podawane jako liczby dziesiętne. Parametry X3 i XB3 można pominąć.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: ILOCZYNLOG

Wartość opcji: Y,YB,X1,XB1,X2,XB2,X3,XB3

Znaczenie - wykonuje iloczyn logiczny wybranych bitów dwóch lub trzech zmiennych.

Parametry:

Y - zmienna wynikowa, typu słowo 16-bitowe;

YB - maska bitowa określająca bity ustawiane/zerowane w zmiennej wynikowej, podawana jako liczba dziesiętna;

X1,X2,X3 - zmienne, na których wykonywany jest iloczyn logiczny, typu słowo 16-bitowe;

XB1,XB2,XB3 - maski bitowe, które określają bity brane pod uwagę, podawane jako liczby dziesiętne. Parametry X3 i XB3 można pominąć.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: POROWNANIE

Wartość opcji: Y,X,L

Znaczenie - porównuje wartość zmiennej względem deklarowanej stałej.

Y - zmienna wynikowa typu słowo 16-bitowe przyjmuje wartość:

0 - jeżeli X=L

1 - jeżeli X<L

2 - jeżeli X>L

X - zmienna wejściowa dowolnego typu, której wartość jest porównywana;

L - wartość względem której wykonywane jest porównanie, liczba dziesiętna lub zmiennoprzecinkowa.

Nazwa sekcji: [SYMULACJA]

Nazwa opcji: NEGACJA

Wartość opcji: X,Y

Znaczenie - wykonuje logiczną negację zmiennej.

X - zmienne wynikowa typu słowo 16-bitowe

Y - zmienne wejściowa, której wartość jest negowana, typu słowo 16 bitowe.


1.1 Wstep

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.1 Wstęp

1.1 Wstęp

Podręcznik Architekt przeznaczony jest dla wszystkich użytkowników oprogramowania Asix. Opisuje on strukturę i funkcje modułu Architekt, pozwalając tym samym nabyć wiedzę z zakresu konfigurowania aplikacji systemu Asix.

Architekt umożliwia w pełni wizualne zaprojektowanie, skonfigurowanie i bieżącą edycję aplikacji. W szczególności dotyczy to edycji definicji kanałów i definicji adresów zmiennych.

Parametryzując aplikację przy wykorzystaniu programu Architekt, użytkownik wykorzystuje do tego celu okna wyposażone w system wygodnych w obsłudze zakładek, które w uporządkowany sposób grupują opcje odpowiedzialne za poszczególne obszary funkcjonalne projektowanej aplikacji. Moduł Architekt stanowi potężne narzędzie integrujące konfigurację wszystkich kluczowych modułów odpowiedzialnych za sposób działania systemu Asix [1] . Przy jego użyciu użytkownik może dokonać ustawień i modyfikować wszystkie opcje i parametry niezbędne do prawidłowego działania aplikacji systemu Asix. Takie rozwiązanie pozwala znacznie skrócić czas tworzenia zaawansowanych aplikacji oraz ułatwia zarządzanie pracą całego systemu sterowania i nadzoru procesów przemysłowych.

Program Architekt zawiera w sobie moduł VarDef, odpowiedzialny za zarządzanie bazą definicji zmiennych. Umożliwia w pełni interaktywną i wizualną obsługę bazy definicji, tworzenie struktury bazy i jej edycję oraz edycję zawartości bazy. Architekt zapewnia obsługę baz Microsoft SQL Server 2000/2005/2008, baz formatu MDB (Jet / Microsoft Access), a także baz definicji zmiennych bezpośrednio pobieranych ze skoroszytów programu Excel. Dla zapewnienia kompatybilności z wcześniejszymi wersjami pakietu Asix, definicje zmiennych mogą być również pobierane z bazy formatu Paradox i plików tekstowych.

Materiał zamieszczony w niniejszym podręczniku prezentuje krok po kroku pełny proces konfigurowania aplikacji systemu A six w wersji klasycznej.

_______________________________________

[1] Z zakresu konfiguracji aplikacji systemu Asix przy użyciu modułu Architekt wyłączona jest edycja: masek, skryptów, raportów, map bitowych, trendów, pliku wykluczeń do alarmów, pliku archiwizacji warunkowej. Sposób działania kluczowych modułów oraz kluczowych funkcji systemu Asix omawia dział ’Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji’. Opisy funkcjonalności pozostałych modułów pakietu Asix znajdują się w odrębnych podręcznikach.


1.2 Komponenty systemu Asix

System Asix jest systemem otwartym zbudowanym w oparciu o technologie OPC (OLE for Process Control), DDE, Automation, OLE DB, .NET, z możliwością pracy w Internecie i sieciach rozległych (TAPI). Jego modularna budowa stwarza możliwości optymalnego dopasowania funkcjonalności do wymaganych potrzeb.

Dla zaprezentowania możliwości funkcjonalnych jakie oferuje system Asix, poniżej zamieszczony został krótki przegląd jego poszczególnych komponentów. Powiązanie modułu Architekt z pozostałymi komponentami systemu Asix prezentuje Rysunek: Główne komponenty systemu asix - wersji klasycznej oraz Rysunek: Główne komponenty systemu Asix.Evo.

Rysunek: Główne komponenty systemu Asix - wersji klasycznej.

Baza definicji zmiennych - VarDef

W systemie Asix baza definicji zmiennych jest miejscem przechowywania wszelkich informacji o zmiennych procesowych. Każdej zmiennej identyfikowanej poprzez unikalną Nazwę odpowiada jeden rekord w bazie definicji zmiennych; pola tego rekordu zawierają wartości tzw. atrybutów zmiennej. Lista atrybutów zawiera pozycje obligatoryjne, opcjonalne oraz definiowane przez użytkownika. Atrybutami obligatoryjnymi są np.: opis zmiennej, jednostka, nazwa kanału komunikacji z obiektem, deklaracja sposobu przetwarzania przy pobieraniu ze sterownika, parametry archiwizacji. Atrybuty opcjonalne to np.: limity, format, zakresy. Poza powyższymi, użytkownik może również utworzyć swoje atrybuty tekstowe, indywidualnie dla każdego projektu, np.: KKS, czy dane montażowe.

System VarDef obsługuje bazy danych serwera Microsoft SQL Server 2000/2005/2008 oraz bazy danych w formacie MDB (Jet / Microsoft Access). Dla przeniesienia aplikacji z wcześniejszych wersji systemu Asix dane definicji zmiennych mogą być przekonwertowane z bazy Paradox lub plików tekstowych do formatu bazy MSQL lub Jet.

Moduł Architekt zapewnia pełną obsługę bazy VarDef w formacie Jet lub MS SQL. W tym zakresie łączy on w sobie funkcjonalność dwóch odrębnych programów stosowanych wcześniej do tworzenia i edycji baz definicji zmiennych: Menedżera Bazy Zmiennych i Edytora Bazy Zmiennych (używane w starszych wersjach pakietu Asix). Programy te nadal dołączane są do pakietu Asix, aby można było korzystać ze starej wersji bazy.

AS

Podstawę systemu Asix stanowi moduł AS. W trakcie pracy systemu Asix w trybie konstrukcyjnym program AS przybiera postać okna Konstruktora i udostępnia zestaw komend i obiektów służących do projektowania aplikacji. Konstruktor pozwala zaprojektować, sparametryzować okna aplikacji i uruchomić aplikację. Aplikacja składa się z systemu okien - tzw. masek procesowych (inaczej ekranów synoptycznych aplikacji), które odpowiednio sparametryzowane obrazują stan monitorowanego i sterowanego procesu przemysłowego. Bogata biblioteka obiektów statycznych oraz dynamicznych, których atrybuty są kontrolowane przez wartości zmiennych procesowych, daje duże możliwości w budowie systemu wizualizacji.

W momencie startu programu AS w trybie wykonania aplikacji automatycznie aktywowane jest okno Panelu Kontrolnego. Jest to centralne okno aplikacji, które udostępnia zestaw komend służących do kontroli pracy aplikacji oraz pokazuje i przechowuje komunikaty dotyczące wewnętrznej pracy systemu Asix.

Zarówno tryb konstruowania jak i wykonywania aplikacji realizowany jest przez program AS w oparciu o plik konfiguracyjny w formacie xml. Plik ten jest tworzony przez program Architekt i przechowuje ustawienia wszystkich parametrów aplikacji systemu Asix.

Operacje wspomagające działanie modułu AS realizowane są przez moduły: Asmen, Aslink i Aspad.

Asmen

Moduł Asmen to menedżer komunikacyjny, który odpowiada za przesył danych między komputerem, na którym została uruchomiona aplikacja systemu Asix, a sterownikami obsługującymi kontrolowany proces. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery komunikacyjne pracujące pod kontrolą Asmena. Zestaw drajwerów wykorzystywanych w systemie wizualizacji zależy każdorazowo od sposobu połączenia danego systemu ze sterownikami przemysłowymi.

Szczególnym trybem pracy modułu Asmen jest działanie w trybie symulacji. Polega ono na tym, że wartości zmiennych procesowych nie są określane w oparciu o dane pochodzące z fizycznego kanału transmisji, lecz są generowane przy użyciu odpowiednich funkcji przeliczających, zaprojektowanych pod kątem symulowania pracy ze środowiskiem docelowym. Tryb symulacji jest szczególnie przydatny na etapie projektowania aplikacji, gdy połączenie ze sterownikami jest najczęściej niemożliwe.

Aslink

Moduł Aslink jest modułem sieciowym używanym w instalacjach sieciowych. Umożliwia on innym komponentom systemu Asix wzajemną komunikację poprzez lokalną sieć komputerową. ASLINK definiuje zestaw usług sieciowych, z których korzystają wszystkie inne programy systemu Asix.

Aspad

Moduł Aspad jest modułem archiwizacji danych, przeznaczonym do rejestracji i późniejszego odtwarzania przebiegów czasowych zmiennych. W systemie Asix przebiegi te są wykorzystywane przy tworzeniu wykresów i raportów. Mogą też być użyte przez przeliczniki do obliczania syntetycznych zmiennych. Przetwarzanie i konserwację plików archiwum wspomaga dodatkowe narzędzie AspadTools.

AsixConnect

Komputer posiadający fizyczne połączenie ze sterownikiem (za pośrednictwem łącza szeregowego, magistrali przemysłowej lub sieci lokalnej) stanowi źródło informacji o zmiennych procesowych dla innych komputerów w sieci lokalnej; komputer taki jest serwerem danych bieżących i archiwalnych oraz alarmów. W dostępie do tych danych pośredniczy pakiet AsixConnect.

Za pośrednictwem programu AsixConnect przebiegi czasowe zmiennych systemu Asix mogą być eksportowane do innych programów, np. do arkuszy EXCEL, za pomocą mechanizmu DDE, Automation lub .NET.

AsTrend

Program AsTrend przeznaczony jest do graficznej prezentacji danych archiwalnych gromadzonych przez program archiwizacji danych Aspad. Pozwala on na wyświetlanie, przeglądanie i drukowanie przebiegów czasowych wybranych zestawów zmiennych i służy do przygotowania swego rodzaju ”raportów graficznych” pracy obiektu. Możliwe są dwa sposoby pracy tego programu: statyczne odrysowanie danych zgromadzonych w plikach archiwalnych lub dynamiczne wyświetlanie w trybie rejestratora danych napływających ze sterowników.

AsScripter

Moduł skryptowania jest rozszerzeniem systemu Asix pozwalającym na wykonywanie skryptów w technologii ActiveX Scripting, napisanych w językach VBScript lub JScript. Skrypty pozwalają realizować nietypowe obliczenia, programować specjalne reakcje systemu na zdarzenia, obsługiwać dedykowane bazy danych i wyliczać raporty.

AsAlert

Moduł AsAlert służy do zdalnego powiadamiania wybranych osób o ważnych zdarzeniach pocztą elektroniczną lub komunikatami SMS. AsAlert może pracować jako program powiadamiający ogólnego przeznaczenia. Jego siła objawia się w pełni podczas pracy w ramach systemu Asix. Sprzężenie AsAlert z mechanizmem wykrywania i obsługi alarmów Asixa pozwala na automatyczne wysyłanie alertów w reakcji na wykrycie zmiany stanu wybranych alarmów.

AsBase

Moduł AsBase dedykowany jest do tworzenia aplikacji, których celem jest zdarzeniowa archiwizacja wybranych danych procesowych w relacyjnej bazie danych Microsoft SQL oraz ich późniejsza analiza. Drugim zastosowaniem modułu jest realizacja systemu zarządzania recepturami.

Asix4Internet

W wersji 8 pakietu Asix4Internet to narzędzie zawierające dwa moduły do użytku z klasyczną wersją Asixa:

· AsPortal - Webowy Portal Informacji Procesowych - gotowy do natychmiastowego użycia, pozwala przeglądać w Internecie dane procesowe z dowolnej aplikacji systemu Asix. Portal umożliwia przeglądanie bazy zmiennych, odczyt wartości bieżących, wgląd w listę alarmów aktywnych i alarmów historycznych, prezentację historycznych wartości zmiennych procesowych w układzie tabelarycznym lub w postaci wykresów; AsPortal – witryna w technologii HTML – jest dostępna pod dowolną przeglądarką internetową na dowolnym systemie operacyjnym.

· AsTrend - wersja przeglądarkowa programu graficznej analizy danych historycznych, o funkcjonalności zgodnej z wersją okienkową, szczególnie wysoko ocenianą przez użytkowników,

Funkcja konwersji klasycznej aplikacji systemu Asix na aplikację internetową została w wersji 8 pakietu usunięta. Aby utworzyć wersję internetową aplikacji, należy przekonwertować aplikację klasyczną na wersję Evo i dopiero wtedy opublikować ją jako aplikację WWW.

AsAudit

AsAudit to zaawansowane narzędzie pakietu Asix, którego podstawowym zadaniem jest dostosowanie Asixa do wymagań stawianych przez procedury walidacji systemów zgodnych z wymaganiami GAMP4, FDA 21 CFR Part 11, stosowanych w farmacji i w przemyśle spożywczym. Moduł rozszerza zaimplementowany w Asix centralny system logowania użytkowników i kontroli uprawnień o rejestrację wykonanych sterowań, rejestrację działań operatora oraz kontrolę integralności aplikacji.

PEdit

Istnieją też dodatkowe narzędzia rozszerzające funkcjonalność systemu Asix w zakresie obsługi przebiegów wzorcowych. Jednym z nich jest PEdit - edytor przebiegów wzorcowych. Drugi - to PSelect – narzędzie do ręcznego lub automatycznego wyboru krzywej wzorcowej lub transferu wybranej krzywej wzorcowej do sterownika, gdzie może być wykorzystana do sterowania.

AsComm

Program AsComm służy do zarządzania i monitorowania połączeń, nawiązywanych za pomocą portów szeregowych lub modemów, dokonywanych przez moduły systemu Asix.

AslView

Program AslView służy do wizualizacji i diagnostyki połączeń sieciowych systemu Asix. Program pozwala połączyć się z modułem sieciowym Aslink systemu Asix, pracującym na lokalnej lub zdalnej stacji oraz obserwać stan połączeń nawiązywanych przez inne komponenty systemu Asix - jak Asmen i Aspad, a także obserwać stan synchronizacji czasu z innymi stacjami. Za pośrednictwem programu AslView możliwe jest parametryzowanie działania modułu sieciowego Aslink.

AsAlarm

AsAlarm to program dostarczający narzędzi do szczegółowej analizy informacji o alarmach generowanych przez monitorowany obiekt oraz danych na temat pracy systemu alarmów. Program jest zgodny z wytycznymi organizacji EEMUA (The Engineering Equipment and Materials Users Association) nr 191. Pozwala on prowadzić analizę systemu alarmów w dwóch płaszczyznach:

- oceny poprawności projektu struktury systemu alarmów w konkretnej aplikacji;

- dogłębnej analizy statycznej i dynamicznej alarmów zarejestrowanych na obiekcie.

AsRaport

AsRaport to narzędzia do projektowania i generowania raportów w oparciu o Microsoft® SQL Server™ Reporting Services. Z punktu widzenia użytkownika oznacza to możliwość swobodnego konstruowania raportów, ich modyfikowania, przeglądania i wykonywania w środowisku Asix.


1.3.1 Uruchomienie modulu Architekt

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.1 Uruchomienie modułu Architekt

1.3.1 Uruchomienie modułu Architekt

Moduł Architekt można uruchomić wybierając kolejno z menu Start systemu operacyjnego:

Programy > A six > Architekt


1.3.2 Zamykanie modulu Architekt

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.2 Zamykanie modułu Architekt

1.3.2 Zamykanie modułu Architekt

Zamknięcie modułu Architekt następuje w wyniku wybrania polecenia Zakończ zakończ z menu Plik okna programu Architekt.


1.3.3 Okno glowne modulu Architekt

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.3 Okno główne modułu Architekt

1.3.3 Okno główne modułu Architekt

Program Architekt posiada przyjazny interfejs wizualny. Środowisko pracy projektanta stanowi okno programu podzielone na dwa główne bloki:

- lewy blok kategorii parametrów dla baz danych i danych aplikacji;

- prawy blok parametrów konfiguracyjnych.

uwaga Parametry konfigurujące pracę aplikacji oraz deklarujące bazę danych, w oparciu o którą aplikacja pracuje zapisywane są do jednego wspólnego pliku XML (ang. Extensible Markup Language), umieszczanego w kartotece głównej projektowanej aplikacji.

Zawartość lewego bloku okna Architekta przełączana jest przyciskami Bazy danych i Obszary i komputery(znajdującymi się w dolnej części bloku).

Podłużny przycisk Bazy danych wyświetla drzewo parametrów do konfiguracji bazy definicji zmiennych i bazy alarmów danej aplikacji.

Rysunek: Okno Architekta - widok grup parametrów do konfiguracji baz danych definicji zmiennych i alarmów.

Podłużny przycisk Obszary i komputery aktywuje blok zawierający listę komputerów, dla których konfigurowana jest aplikacja systemu Asix oraz drzewo grup parametrów konfigurujących pracę tej aplikacji.

Rysunek: Okno Architekta - widok listy komputerów oraz drzewa grup parametrów do konfiguracji aplikacji.

Parametry konfiguracyjne dostępne w prawym bloku okna Architekta - umieszczone zostały na tematycznych zakładkach.

W bloku tym projektant nadaje pożądane wartości poszczególnym parametrom aplikacji oraz bazy danych, w oparciu o którą aplikacja pracuje.

Rysunek: Okno Architekta - przykładowa zakładka do parametryzacji danych archiwalnych.

uwaga Użytkownik używając środowiska konfiguracyjnego Architekt nie zakłóca pracy aplikacji, która działa w tle. Niektóre zmiany w ustawieniach parametrów aktualizowane są automatycznie w chwili zapisu, choć dla większości parametrów wymagany jest restart aplikacji.


1.3.3.1 Drzewo modulow

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.3 Okno główne modułu Architekt > 1.3.3.1 Drzewo modułów

1.3.3.1 Drzewo modułów

Głównym narzędziem nawigacyjnym służącym do lokalizacji poszczególnych obszarów funkcjonalnych programu Architekt jest drzewo modułów aktywowane podłużnym przyciskiem Obszary i komputery.

Rysunek: Okno Architekta - widok drzewa modułów aplikacji.

Ponieważ rzeczywista aplikacja działająca na obiekcie często pracuje w różny sposób na różnych stanowiskach komputerowych, wymaga to zdefiniowania w jednym pliku XML kilku różnych zestawów parametrów dla poszczególnych stanowisk. Zestaw parametrów dla wybranego stanowiska komputerowego dostępny jest w bloku parametrów konfiguracyjnych po kliknięciu na wybranym Komputerze z listy zadeklarowanych komputerów w polu Obszary i komputery.

Obszar działania aplikacji, który jest wspólny dla kilku lub wszystkich komputerów symbolizowany jest tutaj poprzez element Obszar - gdy użytkownik kliknie na ten element, może przystąpić do ustawienia wartości parametrów aplikacji, które są takie same dla wszystkich stanowisk.

uwaga Konfiguracja na poziomie Obszaru powoduje globalne ustawienia dla wszystkich komputerów należących do tego obszaru, natomiast konfiguracja na poziomie Komputera pozwala zindywidualizować ustawienia w zależności od typu komputera (inne dla stacji operatorskiej a inne dla dedykowanego serwera danych w sieci zakładowej). Ustawienia na poziomie Komputera są ważniejsze od ustawień na poziomie Obszaru.

Parametry konfigurujące pracę aplikacji podzielone zostały na następujące moduły parametrów:

- Parametry startowe,

- Maski,

- Dane bieżące,

- Dane bieżące - serwer sieci,

- Dane archiwalne,

- System alarmów,

- Moduł sieci,

- Zabezpieczenia,

- Wydruk,

- Raporty,

- Akcje i terminarze,

- Pozostałe.

Widok drzewa modułów dla baz danych (podłużny przycisk Bazy danych), w zależności od ustawionego typu bazy definicji zmiennych, obejmuje pozycje omówione poniżej.

Rysunek: Okno Architekta - widok drzewa modułów dla baz danych.

- Baza definicji zmiennych - parametry określające Typ bazy, Format bazy, Źródła danych oraz Opcje;

- Edytor definicji zmiennych (dostępny dla typu bazy definicji zmiennych - Standardowa baza definicji zmiennych, po otwarciu bazy);

- Edytor schematu (dostępny dla typu bazy definicji zmiennych - Standardowa baza definicji zmiennych, po otwarciu bazy);

- Baza definicji alarmów SQL - parametry określające Źródła danych definicji alarmów;

- Baza definicji alarmów - parametry określające Typ, Źródła danych oraz Szablon pliku źródłowego definicji alarmów; (zakładki Baza definicji alarmów > Źródła danych oraz Baza definicji alarmów > Szablon dostępne są dla następującego ustawienia Typu bazy definicji alarmów - Baza definicji alarmów jest generowana z arkusza kalkulacyjnego);

- Baza akcji złożonych - pozwala określić tryb pracy bazy akcji złożonych; definicje mogą być wprowadzane przez projektanta w module Akcje i terminarze, na zakładce Akcje złożone lub definicje akcji mogą być generowane na podstawie danych z arkuszy kalkulacyjnych.

- Opcje programu - pozwalające ustawić indywidualnie dla każdej aplikacji:

- widok okna głównego na starcie Architekta (zakładka Opcje > Start),

- silnik odczytu plików XLSXLSX i wybór edytora plików XLS/XLSX (zakładka Opcje > Źródła danych - silnik odczytu),

- parametry dla okna przeglądania bazy definicji zmiennych (zakładka Opcje > Baza definicji zmiennych).

(szczegóły patrz: 1.3.4 . Indywidualne opcje pracy programu Architekt).


1.3.3.2 Blok parametrow konfiguracyjnych

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.3 Okno główne modułu Architekt > 1.3.3.2 Blok parametrów konfiguracyjnych

1.3.3.2 Blok parametrów konfiguracyjnych

Blok parametrów konfiguracyjnych umożliwia dokonywanie ustawień parametrów konfigurujących pracę aplikacji systemu Asix oraz parametrów bazy definicji zmiennych.

Rysunek: Okno Architekta – przykładowy widok bloku parametrów konfiguracyjnych.

Blok ten zamienia się w okno edytora atrybutów zmiennych, gdy otwarta jest baza definicji zmiennych w formacie SQL lub Jet (w grupie parametrów Bazy danych > Baza definicji zmiennych > Typ bazy zaznaczona jest opcja Standardowa baza definicji zmiennych)

Rysunek: Okno edycji bazy definicji zmiennych.


1.3.4 Indywidualne opcje pracy programu Architekt

Istnieje możliwość określenia przez użytkownika pewnych domyślnych opcji pracy programu Architekt, obowiązujących podczas pracy nad danym plikiem aplikacji.

W widoku drzewa modułów dla baz danych (podłużny przycisk Bazy danych) znajduje się moduł Opcje, który daje możliwość dokonania poniższych ustawień.

Zakładka Start:

  • Aktywny edytor po uruchomieniu programu - pozwala zadeklarować, który edytor uruchamiany będzie na starcie programu:

  • Edytor aplikacji (ze wskazaniem aktywnego obszaru/komputera),

  • Edytor bazy danych;

  • Aktywny moduł po zmianie obszaru/komputera - aktywuje mechanizm, który zapamiętuje moduł i zakładkę ostatnio otwieraną dla danego obszaru lub komputera podczas bieżącej sesji:

  • Ten sam dla wszystkich komputerów/obszarów - ostatnio otwierany moduł i zakładka będą domyślnie aktywowane po przejściu do dowolnego obszaru/komputera;

  • Osobny dla każdego komputera/obszaru - zostanie zapamiętany ostatnio otwierany moduł i zakładka indywidualnie dla każdego komputera/obszaru.

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Start’.

Zakładka Źródła danych - silnik odczytu pozwala zadeklarować silnik odczytu plików XLS oraz edytor plików XLS.

Edytor plików XLS/XLSX:

  • Domyślny edytor zainstalowany w systemie,

  • Edytor wbudowany w Architekt,

  • Zewnętrzny edytor.

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Źródła danych - silnik odczytu’.

Zakładka Baza definicji zmiennych - pozwala określić parametry pomocne w sprawdzaniu działania okna wyboru zmiennej; efekty wyboru języka widoczne są w oknie ’Przeglądanie zmiennych’ aktywowanym przyciskiem pokaż:

  • Okno przeglądania bazy definicji zmiennych:

  • Widoczne zmienne - pozwala zawęzić zestaw wyświetlanych definicji zmiennych do zmiennych aktywnych lub archiwizowanych;

  • Język aplikacji - umożliwia wybór języka, w jakim wyświetlane są nagłówki i wartości atrybutów zmiennych (nagłówki atrybutów dla wymaganych języków deklarowane są w schemacie bazy definicji zmiennych, a tłumaczenia wartości atrybutów (np. atrybutu Opis) w bazie definicji zmiennych).

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Baza definicji zmiennych’.


1.3.5 Menu glowne, dostepne polecenia

Home > Architekt - Parametryzacja aplikacji > 1. Praca z programem Architekt > 1.3 Środowisko pracy modułu Architekt > 1.3.5 Menu główne, dostępne polecenia

1.3.5 Menu główne, dostępne polecenia

Komendy wykonywane przez moduł Architekt zostały zgrupowane w 9 kategoriach [2]:

  1. Plik,

  2. Aplikacja,

  3. Obszary i komputery,

  4. Widok,

  5. Narzędzia,

  6. Pomoc,

  7. Edytor,

  8. Baza definicji zmiennych,

  9. Baza definicji alarmów.

Użytkownik ma możliwość samodzielnego określenia, które polecenia chce mieć wyświetlone w oknie Architekta. Służy to tego polecenie Dostosuj..., uruchamiane po kliknięciu prawym klawiszem myszy na dowolnym pasku narzędzi bądź menu głównym. Wywołuje ono okno ’Dostosuj’, które umożliwia konfigurację zawartości menu głównego oraz pasków narzędzi i dostępnych poleceń w zależności od preferencji użytkownika.

Rysunek: Okno umożliwiające konfigurację zawartości pasków narzędzi.

W oknie modułu Architekt dostępne są następujące kategorie poleceń:

Plik

- Nowa aplikacja (Ctrl + N);

nowa aplikacja - kreator - Nowa aplikacja - kreator;

Nowa aplikacja - kreator OPC... - uruchamia kreator aplikacji w trybie importu bazy z serwera OPC;

Nowa aplikacja - kreator OPC UA... - uruchamia kreator aplikacji w trybie importu bazy z serwera OPC UA;

- Nowa aplikacja - importer;

otwórz - Otwórz (Ctrl + O); otwiera plik XML;

zapisz - Zapisz (Ctrl + S);

- Zapisz jako;

zakończ - Zakończ; zakończenie pracy modułu Architekt;

Wyświetlana jest też lista ostatnio otwieranych plików konfiguracyjnych XML aplikacji

Aplikacja

uruchom - Uruchom system Asix (F5); uruchomienie aplikacji systemu Asix dla wybranego komputera;

uruhcom konstruktor - Uruchom system Asix (F6) - konstruktor; uruchomienie aplikacji systemu Asix w trybie Konstruktora dla wyselekcjonowanej stacji;

stop - Zatrzymaj system Asix (Ctrl + F5); zamknięcie aplikacji systemu Asix;

- Konfiguruj system raportów AsRaport ...

- Konfiguruj aplikacje internetowe...;

- Konfiguruj wygląd aplikacji AsPortal;

Paleta kolorów aplikacji...

Generuj listę używanych zmiennych...

Paleta kolorów aplikacji - polecenie uruchamia paletę kolorów; użytkownik może sam komponować swoją własną paletę przeciągając kolory metodą 'przeciągnij i upuść' z wzornika kolorów do sekcji Kolory użytkownika.

Generuj listę używanych zmiennych... - polecenie tworzy listę nazw używanych w aplikacji na maskach i zapisuje je w pliku xls. Lista nazw zmiennych tworzona jest programem ZMIANADP, który zapisuje listę zmiennych do pliku tekstowego (który następnie przetwarzany jest na plik xls). Pełny zakres funkcjonalności programu ZMIANADP opisany został w I części podręcznika "Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji".

Baza Definicji Zmiennych - zestaw poleceń dostępny w zależności od typu bazy definicji zmiennych !!!

- Pokaż (F7) - otwiera okno przeglądania bazy definicji zmiennych;

- Generuj (Ctrl + G) - generuje bazę definicji zmiennych;

- Otwórz (Ctrl + B) - otwiera bazę definicji zmiennych do edycji;

- Zapisz - zapisuje zmiany w bazie definicji zmiennych;

- Zamknij - zamyka bazę definicji zmiennych (kończy edycję);

- Przeładuj - zamyka i ponownie otwiera bazę definicji zmiennych;

- Aktualizuj on-line - w przypadku, gdy niemożliwe jest zatrzymanie aplikacji i jej restart w celu zmodyfikowania bazy definicji zmiennych, możliwe jest przeprowadzenie aktualizacji bazy w trybie on-line;

- Poka ż modyfikacje - pozwala prześledzić zmiany w definicjach zmiennych (w tym dodawanie i usuwanie zmiennych);

importuj modyfikacje - Importuj modyfikacje - pozwala zaimportować do istniejącej bazy definicji zmiennych MS SQL lub Jet zmiany w definicji zmiennych wykorzystując arkusz Excel jako źródło;

- Exportuj... - pozwala wyeksportować definicje zmiennych do arkusza kalkulacyjnego;

Importuj z serwera OPC... - otwiera okno importu bazy definicji zmiennych z serwera OPC do pliku xls;

Importuj z serwera OPC UA... - otwiera okno importu bazy definicji zmiennych z serwera OPC UA do pliku xls;

- Utwórz nową;

- Usuń;

- Utwórz kopię zapasową;

- Przywróć z kopii;

dodaj atrybut - Dodaj atrybut - dodawanie nowego atrybutu do definicji zmiennej;

usuń atrybut - Usuń atrybut - usuwanie nowego atrybutu do definicji zmiennej;

- Zmień rozmiar atrybutu;

Edytor - polecenia edytora bazy definicji zmiennych:

- Wstaw definicję zmiennej - dodanie rekordu definicji nowej zmiennej;

- Wstaw kopię definicji zmiennej - dodanie rekordu skopiowanej definicji nowej zmiennej;

- Wstaw definicję zmiennej systemowej - dodanie rekordu definicji zmiennej systemowej - uruchamiany jest edytor z listą obsługiwanych zmiennych systemowych;

- Wstaw definicję zmiennej z kanału OPC

- Zmień wartości - po zaznaczeniu wybranych wartości danego atrybutu w tabeli z definicjami zmiennych umożliwia zmianę tych wartości;

- Zamień zaznaczone - po zaznaczeniu wybranych wartości danego atrybutu w tabeli z definicjami zmiennych umożliwia zamianę pewnej określonej wartości atrybutu w obszarze zaznaczonych pól na nową wartość;

- Zamień w kolumnie - po kliknięciu prawym klawiszem myszy w dowolnym polu danego atrybutu w tabeli z definicjami zmiennych pozwala użytkownikowi zmienić określoną wartość atrybutu w obszarze całej kolumny;

- Wyczyść zaznaczone;

Natychmiastowa edycja - załączenie opcji umożliwia natychmiastową edycję bieżącej komórki po wpisaniu dowolnego znaku;

Filtrowanie

- Kopiuj wiersz do schowka;

- Dodaj nazwy zmiennych do schowka;

Mirror:

Konfigurowanie - polecenie uruchamia okno z instrukcją uruchomienia mirroringu;

Konfigurowanie użytkownika_asix_internal - kopiowanie użytkownika _asix_internal z serwera głównego na mirror;

- Pokaż atrybuty - wszystkie (Shift + Ctrl + 0);

- Pokaż atrybuty – bieżące (Shift + Ctrl + 9);

Pokaż atrybuty – systemowe;

Baza definicji alarmów

- Pokaż (F8)- uruchamia okno wyboru alarmów

- Generuj (Ctrl + H) – generuje bazę definicji alarmów;

- Pokaż SQL... - uruchamia okno wyboru alarmów SQL;

- Generuj SQL (Ctrl + J) – generuje bazę definicji alarmów SQL;

Obszary i komputery

dodaj obszar - Dodaj obszar;

usuń obszar - Usuń obszar;

zmień nazwę obszaru - Zmień nazwę obszaru;

Utwórz kopię obszaru...

Konwertuj obszar na komputer;

dodaj komputer - Dodaj komputer w bieżącym obszarze;

dodaj komputer - Dodaj komputer

usuń komputer - Usuń komputer;

zmień nzawę komputera - Zmień nazwę komputera;

Utwórz kopię komputera... - tworzy kopię komputera zaznaczonego w chwili wykonywania polecenia w bloku Obszary i komputery.

Utwórz kopię komputera - terminal... - tworzy kopię terminala zaznaczonego w chwili wykonywania polecenia w bloku Obszary i komputery.

- Konwertuj komputer na obszar;

Importuj komputer/obszar z pliku... - powoduje import komputera lub obszaru z pliku XML (do którego uprzednio wyeksportowano wskazany komputer/obszar np. z pliku XML parametryzującego inną aplikację systemu A six;

Eksportuj komputer/obszar z pliku... - powoduje wyeksportowanie definicji komputera/obszaru do pliku XML;

dodaj kanał - Dodaj kanał;

Utwórz kopię kanału...

reedytuj kanał - Zmień definicję kanału – umożliwia zmianę nazwy kanału i typu drajwera;

usuń kanał - Usuń kanał;

Zarządzaj kanałami... - pozwala wykonać nast. operacje na kanałach dla danego komputera/obszaru:

Usuń;

Zmień typ na: fizyczny, NONE lub sieciowy;

Kopiuj do komputera/obszaru.

Rysunek: Okno ’Zarządzanie kanałami’.

dodaj archiwum - Dodaj archiwum;

Utwórz kopię archiwum...

- Zmień nazwę archiwum;

usuń archiwum - Usuń archiwum;

Zarządzaj archiwami...- pozwala wykonać nast. operacje na archiwach dla danego komputera/obszaru:

Usuń;

Zmień typ archiwum: do zapisu, do odczytu, pomocnicze lub sieciowe

Kopiuj do komputera/obszaru.

Zarządzaj opcjami - uruchamia menadżera opcji, który pozwala przeglądać wszystkie parametry ustawione dla poszczególnych obszarów funkcjonalnych aplikacji;

Importuj opcje - uruchamia menadżera opcji, który pozwala zaimportować wybrane wartości opcji z zewnętrznych plików *.xml;

informacje - Informacje; wyświetla zależności pomiędzy komputerami i obszarami;

Widok

paski narz - obejmuje listę dostępnych pasków narzędzi i opcję Dostosuj...;

Obszary/komputery, Moduły opcji aplikacji, Moduły opcji baz danych, Opcje programu - przyciski pozwalają przełączać się do bloku obszarów i komputerów oraz do bloków opcji;

pokaz opcje zaawansowane - Pokazuj opcje zaawansowane; aktywuje ukryte zakładki zaawansowanych parametrów w modułach opcji aplikacji;

- Pokaż tylko opcje Asix.Evo - opcja redukuje zestaw parametrów dostępnych dla klasycznej wersji Asixa do tych parametrów, które są wymagane dla aplikacji projektowanej przy użyciu Asixa.Evo;

Narzędzia

utwórz skrót - Kreator skrótów; umożliwia tworzenie skrótu do uruchamiania różnych aplikacji systemu Asix;

powiększ >>

Rysunek: Okno do tworzenia skrótu uruchamiającego aplikację systemu Asix.

arkusz kalkulacyjny - Arkusz kalkulacyjny; uruchamia okno wbudowanego arkusza kalkulacyjnego;

Edytor tabeli - uruchamia edytor obiektu Tabela do przeglądania wartości zmiennych

- Wybór języka; uruchamia program wyboru języka interfejsu użytkownika systemu Asix;

- Zabezpieczenia statyczne; uruchamia program menedżera uprawnień globalnych (plik StaticPolicies.exe) umożliwiającego ustawienie mechanizmów zabezpieczających dostęp do potencjalnie niebezpiecznych funkcji systemu operacyjnego;

Rysunek: Okno menedżera uprawnień globalnych.

- AsTrend; uruchamia program do graficznej prezentacji danych archiwalnych gromadzonych przez program archiwizacji danych ASPAD;

Konwerter trendów 1 - uruchamia konwerter trendów służący do przekonwertowania pliku dat zawierającego definicje trendów (trendy definiowane w plikach dat dostępne były w systemie Asix do wersji 3) do postaci definicji trendów obsługiwanych przez program AsTrend.

- AsBase; uruchamia program AsBase;

- AsRaport - uruchamia program AsRaport do edycji zapytać SQL dla raportów tworzonych w środowisku Reporting Services firmy Microsoft;

- Askom.Data.Host - uruchamia program do konfiguracji środowiska umożliwiającego udostępnianie do środowiska raportowego MS Reporting Services danych procesowych pochodzących z aplikacji systemu Asix;

- AsAlarm - uruchamia program AsAlarm z załadowana baza VarDef aktualnej aplikacji;

- Konfiguracja AsixConnect; uruchamia konfiguratora pakietów serwerów AsixConnect;

- Moduł sieci – opcje – opcja uruchamia edytor ustawień sieciowych, które zapisywane są w pliku aslink.ini (stosowane gdy na komputerzen nie ma aplikacji A sixa, za to są inne programy, które korzystają z danych aplikacji Asixa (np. AsTrend, AsixConnect);

- Konfiguracja Alertów; uruchamia program konfiguratora alertów;

alerty - Konfiguracja AsAudit; uruchamia program konfiguratora AsAudit;

alerty - Katalogi logów i ustawień - uruchamia program konfiguratora umożliwiającego deklarowanie katalogów dla plików logów tworzonych przez program AsTrend, serwery pakietu AsixConnect, program Architekt i moduł wykonawczy systemu Asix oraz deklarowanie katalogów plików konfiguracyjnych aplikacji systemu Asix.

Rysunek: Konfigurator katalogów logów.

alerty - Menadżer pakietów Asix - uruchamia program konfiguratora umożliwiającego przygotowanie środowiska MS Windows do uruchomienia dowolnej zainstalowanej na komputerze wersji pakietu Asix (na komputerze może być zainstalowanych kilka wersji pakietu, zaczynając od wersji 2).

- Wersja pakietu systemu Asix - wyświetla okno z metryką pakietu.

Pomoc

pomoc - poszczególne ikony pomocy uruchamiają kolejno (w domyślnym porządku):

1. plik pomocy dla modułu Architekt;

2. plik pomocy dla modułu Asix;

3. plik pomocy dla modułu Drajwery komunikacyjne;

4. plik pomocy dla modułu Asix4Internet;

5. plik pomocy dla modułu AsixConnect;

6. plik pomocy dla modułu Skrypty;

zgłoszenie usterki - Zgłoszenie usterki lub Zgłoszenie propozycji modyfikacji;

o programie - O programie; wyświetla podstawowe informacje o programie.

_______________________________________

[2] Widok okna Architekta w niniejszym opracowaniu pochodzi z systemu Windows XP Professional.


2.1 Wstep

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.1 Wstęp

2.1 Wstęp

Baza definicji zmiennych VarDef stanowi podstawowe repozytorium całości informacji o wszystkich zmiennych projektowanego systemu wizualizacji. Jest fundamentem, na którym opiera się konstruowanie aplikacji asixowej, w tym konfigurowanie jej przy użyciu modułu Architekt.

Każdej zmiennej identyfikowanej poprzez unikalną Nazwę odpowiada jeden rekord w bazie definicji zmiennych. Pola tego rekordu zawierają wartości tzw. atrybutów zmiennej. Lista atrybutów zawiera pozycje obligatoryjne, opcjonalne oraz definiowane przez użytkownika. Atrybutami obligatoryjnymi są: opis zmiennej, jednostka, nazwa kanału komunikacji z obiektem, deklaracja sposobu przetwarzania przy pobieraniu ze sterownika, parametry archiwizacji. Atrybuty opcjonalne to np.: limity, format, zakresy. Poza powyższymi, użytkownik może również utworzyć swoje atrybuty tekstowe, indywidualnie dla każdego projektu, np.: KKS’y, czy dane montażowe.

W bazie definicji zmiennych VarDef poza definicjami zmiennych przechowywane są również informacje na temat: atrybutów grupujących, zestawów atrybutów, funkcji przeliczających, nagłówków atrybutów, wykorzystywanych w zaprojektowanej aplikacji języków narodowych atrybutów zmiennych, informacje na temat atrybutów zastępczych (dla aplikacji wielojęzycznych). Te dodatkowe dane dostępne są z poziomu modułu Baza definicji zmiennych > Edytor schematu.

uwaga Możliwe jest użycie skoroszytu programu Excel bezpośrednio jako bazy definicji zmiennych z pominięciem kroku generowania bazy definicji zmiennych. Po załadowaniu bazy skoroszyt nie jest już używany.

Dane konfiguracyjne dotyczące bazy definicji zmiennych konfigurowane są w Architekcie przy użyciu modułu Baza definicji zmiennych (otwieranego podłużnym przyciskiem Bazy danych, znajdującym się w lewym bloku okna Architekt) i zapisywane w pliku konfiguracyjnym XML tworzonej aplikacji.

uwaga Sposób działania całej aplikacji opisuje jeden plik XML - wspólny dla danych dotyczących bazy definicji zmiennych i dla wartości parametrów określających pracę aplikacji.

Rysunek: Okno modułu konfigurowania bazy definicji zmiennych.

Szczególny rodzaj zmiennych stanowią zmienne systemowe:

__USERID__ - zapewnia dostęp do identyfikatora aktualnie zalogowanego użytkownika (patrz: część „Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji” , rozdział o systemie logowania);

__USERNAME__ - zapewnia dostęp do nazwy aktualnie zalogowanego użytkownika (patrz: część „Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdział o systemie logowania);

__USERLEVEL__ - zapewnia dostęp do aktualnie obowiązującego poziomu uprawnień (patrz: część „Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdział o systemie logowania);

__AGR_IdGrupy__ - pozwala na wyświetlenie stanu aktywności alarmów należących do wspólnej grupy (patrz: część „Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdział o systemie alarmów).


2.1.1 Tryb tworzenia bazy danych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.1 Wstęp > 2.1.1 Tryb tworzenia bazy danych

2.1.1. Tryb tworzenia bazy danych

Program Architekt zapewnia tworzenie nowych baz definicji zmiennych systemu Asix od wersji 5 w następujących trybach:

1. baza jest tworzona i edytowana ręcznie - Tryb Edytor;

2. baza danych jest generowana na podstawie danych dostarczonych w źródłach zewnętrznych (np. arkuszach kalkulacyjnych Excel) - Tryb Generator;

3. definicje zmiennych pobierane są bezpośrednio z arkusza Excel z pominięciem kroku generowania bazy zmiennych - Tryb Źródło danych.


2.1.2 Format bazy danych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.1 Wstęp > 2.1.2 Format bazy danych

2.1.2 Typ i format bazy danych

W systemie wizualizacji od wersji Asix 7 dane bazy definicji zmiennych mogą być przechowywane:

- w bazie MSQL,

- w bazie Jet,

- bezpośrednio w plikach Excel,

- w formacie plików tekstowych wykorzystywanym w starszych wersjach Asixa [3] (Tekstowa baza definicji zmiennych dla Asix 1-4)

lub

- w bazie zewnętrznej (MSQL lub Jet) utworzonej programem Architekt, ale parametryzowanej innym plikiem XML niż projektowana aplikacja. Istnieje możliwość jednoczesnego odczytu definicji zmiennych z kilku zewnętrznych baz definicji zmiennych (patrz: 2.1.2.1. Łączone bazy definicji zmiennych).

Baza Jet

Zalecanym formatem bazy definicji zmiennych jest baza Microsoft Jet. Nie wymaga ona instalowania serwera bazy danych, a sama baza zawiera się w jednym pliku .mdb, który z łatwością można przenosić pomiędzy komputerami.

Definicje zmiennych przechowywane w źródłach zewnętrznych - plikach XLS

Przechowywanie definicji zmiennych w arkuszu kalkulacyjnym jest wygodne na etapie projektowania aplikacji z uwagi na czytelność przechowywanych informacji oraz łatwość, z jaką użytkownik może wprowadzać zmiany do struktury i wartości danych.

Baza MS SQL

Baza MS SQL zalecana jest dla dużych aplikacji pracujących na ok. 20 000 i więcej zmiennych.

Bazę MS SQL należy również zastosować w sytuacji, kiedy projektowana aplikacja ma być wielojęzyczna.

***

Typ i format bazy definicji zmiennych wybierany jest na zakładkach Typ i Format modułu Bazy danych > Baza definicji zmiennych.

Zakładka Typ pozwala zdecydować, czy baza ma być tworzona w standardowym formacie: MBD lub MS SQL (ze wskazaniem trybu tworzenia: Edytor, Generator lub Źródło danych), czy tez w starym formacie (pliki tekstowe).

W przypadku wyboru typu bazy w standardowym formacie zostanie wyświetlona zakładka Format z wyborem formatu bazy danych: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access).

***

W przypadku wyboru bazy w formacie serwera MS SQL Server należy przestrzegać następujących zasad:

Serwer SQL musi mieć włączone oba rodzaje autentyfikacji: SQL Server i Windows.

W przypadku użycia lokalnego serwera SQL - konto, pod jakim pracuje serwer, musi mieć dostęp do katalogu TEMP. Najłatwiej to osiągnąć konfigurując proces serwera SQL do pracy pod kontem o nazwie LocalSystem.

W przypadku użycia zdalnego serwera SQL z włączoną zaporą, na komputerze serwera:

- dla głównej instancji musi być otwarty port tcp/1433;

- dla instancji nazwanej musi być otwarty port używany przez tę instancję;

- dla wszystkich w sieci nazw serwerów SQL musi być otwarty port udp/1434.

_____________________________________________

[3] W systemie Asix definicje zmiennych mogą być pobierane z plików tekstowych ze względu na kompatybilność z wcześniejszymi wersjami systemu. Stosowanie wspomnianych formatów przechowywania definicji zmiennych nie jest jednak aktualnie zalecane. Bazy w formacie Paradox - pliki MDB należy przekonwertować do aktualnego formatu baz danych systemu Asix.


2.1.2.1. Łączone bazy definicji zmiennych

Dopuszczalnym typem bazy definicji zmiennych są łączone bazy definicji zmiennych, parametryzowane odrębnymi plikami XML.

Wymaga to:

1. zadeklarowania w Architekcie odpowiedniego typu bazy definicji zmiennych:

Architekt > Bazy danych > zakładka Typ > opcja Zewnętrzna baza/bazy definicji zmiennych

2. oraz wskazania zewnętrznych baz definicji zmiennych:

Architekt > Obszary i komputery > moduł Parametry startowe > zakładka Baza definicji zmiennych

Deklaracja bazy obejmuje podanie w przypadku bazy MDB: nazwy i ścieżki do pliku MDB, a w przypadku bazy MS SQL: nazwy serwera Microsoft SQL i nazwy bazy.

Rys. Deklaracja łączonych baz definicji zmiennych.


2.1.3 Atrybuty zmiennych

Atrybuty zmiennych dzielone są na 3 rodzaje:

1. atrybuty obligatoryjne,

2. atrybuty opcjonalne,

3. atrybuty użytkownika.

Atrybuty obligatoryjne są to wszystkie atrybuty używane przez system Asix do uruchomienia aplikacji, np.: Nazwa, Adres, Funkcja przeliczająca.

Pełne zestawienie obligatoryjnych i opcjonalnych atrybutów zmiennych znajduje się w Załącznik 1. Dodatkowo Załącznik 2 zawiera zestawienie atrybutów i wykorzystujących je obiektów/modułów systemu Asix.

uwaga Nazwy i typy atrybutów obligatoryjnych i opcjonalnych są ustalone i niezmienne.

Wartość atrybutu Nazwa musi być unikalna w całej bazie definicji zmiennych.

Wśród atrybutów opcjonalnych jest ZmiennaNieaktywana. Jeżeli wartość atrybutu ZmiennaNieaktywana wynosi 1, to zmienna nie jest widoczna w systemie A six dla modułów Asmen i Aspad.

Atrybuty użytkownika są to wszystkie pozostałe atrybuty. Użytkownik sam ustala ich nazwy (atrybuty mogą być wyłącznie typu tekstowego).

Ponadto w bazie zmiennych istnieją atrybuty wewnętrzne tworzone na potrzeby systemu bazy definicji zmiennych i nie ujawniane użytkownikowi. Atrybuty te to: DataUtworzenia, DataUsunięcia.


2.1.4 Nazewnictwo atrybutow i tabel

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.1 Wstęp > 2.1.4 Nazewnictwo atrybutów i tabel

2.1.4 Nazewnictwo atrybutów i tabel

Nazwa atrybutu może zawierać wszelkie znaki z alfabetu łacińskiego, cyfry, spacje, itd. (Można używać znaków alfabetu lokalnego - ale tylko dla aplikacji jednojęzycznych). Nazwa ta jest używana i w bazie i w interfejsie użytkownika.

Wszystkie nazwy atrybutów systemowych oraz nazwy tabel bazy definicji zmiennych wewnętrznie są w języku angielskim. Nazwy te w interfejsie użytkownika pojawiają się w oknie edycji definicji zmiennych / oknie przeglądania zmiennych / oknie opisu zmiennych w zależności od wersji językowej Architekta - w języku polskim lub angielskim.

uwaga Przy imporcie danych nazwy mogą być podawane zarówno w języku polskim jak i angielskim.

Wyświetlanie lokalnych nazw nagłówków w dowolnym zadeklarowanym przez projektanta języku wymaga samodzielnego zdefiniowania tych nazw - patrz: 2.2.2.4 . Tłumaczenia nazw atrybutów.

Rysunek: Okno podglądu definicji zmiennych.

Rysunek:. Okno opisu wybranej zmiennej - widok atrybutów z zadeklarowanego zestawu atrybutów.


2.2. Tworzenie bazy w trybie Edytora

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora

2.2 Tworzenie bazy w trybie Edytora

Tworzenie bazy definicji zmiennych w trybie Edytora realizowane jest w następujących krokach:

  1. Określ typ bazy definicji zmiennych:

    Baza definicji zmiennych > zakładka Typ > tryb tworzenia bazy ustawiony na Tryb Edytor

    Rysunek: Baza definicji zmiennych/zakładka Typ - Tryb Edytor.

  2. Wybierz format bazy definicji zmiennych:

    Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access)

    Rysunek: Baza definicji zmiennych - zakładka ’Format’.

  3. Podaj nazwę tworzonej bazy.

    W przypadku baz danych MS SQL wymagane jest określenie parametrów:

    - Nazwa serwera;

    - Nazwa bazy;

    - Katalog bazy;

    - Tyb uwierzytelniania:

    - Windows,

    - Serwer MSQL - wymaga określenia nazwy użytkownika oraz Hasła.

- Nazwa serwera mirror - w przypadku obsługi mirroringu pole wymaga zadeklarowania nazwy serwera mirror (wskazówki dotyczace obsługi mirroringu podaje okno pomocy wywoływane przyciskiem [image], umieszczonym obok pola Nazwa serwera mirror).

  4. Wybierz polecenie Utwórz nową utwórz;

  5. Otwórz bazę i wprowadź dane atrybutów zmiennych przy użyciu Edytora definicji zmiennych

(patrz: 2.2.1.3. Dodawanie i usuwanie atrybutów zmiennych);

  6. Zdefiniuj schemat bazy definicji zmiennych za pomocą Edytora schematu

(patrz: 2.2.2 . Tworzenie schematu bazy definicji zmiennych - Edytor schematu).


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.1 Dodawanie, usuwanie i modyfikowanie zmiennych

2.2.1.1 Dodawanie, usuwanie i modyfikowanie zmiennych

Polecenia:

- dodania rekordu nowej zmiennej powyżej wskazanego rekordu (przycisk [image]);

- dopisania nowego rekordu zmiennej jako ostatniego w kolejności (przycisk [image]),

- usunięcia zaznaczonego rekordu (przycisk USUNIĘCIE REKORDU);

- edycji zaznaczonego pola (przycisk EDYCJA REKORDU lub naciśnięcie klawisza F2 powoduje przejście do trybu edycji danego pola);

dostępne są z poziomu paska poleceń okna Definicje zmiennych w Edytorze definicji zmiennych.

Rysunek : Pasek poleceń do edycji rekordu bazy definicji zmiennych.

uwaga Usunięcie zmiennej nie spowoduje fizycznego usunięcia zmiennej z bazy, ale zaznaczenie zmiennej jako usuniętej – dzięki temu w tworzonym raporcie zmian będzie można ująć również informacje na temat zmiennych usuniętych (patrz: 2.11 Export bazy do arkusza Excel).


2.2.1.2 Dodawanie, usuwanie i natychmiastowa edycja zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.2 Dodawanie, usuwanie i natychmiastowa edycja zmiennych

2.2.1.2 Dodawanie, usuwanie i natychmiastowa edycja zmiennych przy użyciu poleceń menu lokalnego / dodawanie zmiennych systemowych / wstawianie definicji zmiennej z kanału OPC

Klikając w edytorze definicji zmiennych prawym przyciskiem myszy na rekordzie (na dowolnym atrybucie) wybranej zmiennej uruchamiane jest menu lokalne umożliwiające:

  • dodanie nowej zmiennej w wyniku skopiowania rekordu wybranej zmiennej - polecenie Wstaw kopię definicji zmiennej (Shift + Ctr + Ins) - rekord nowej zmiennej dodawany jest powyżej zmiennej wybranej; wartości atrybutów nowej zmiennej są identyczne z wartościami atrybutów zmiennej wskazanej, za wyjątkiem atrybutu Nazwa, któremu należy nadać indywidualną nazwę;

  • usuwanie zmiennej - polecenie Wyczyść zaznaczone (Del) - usuwany jest rekord wskazanej zmiennej;

  • natychmiastową edycję bieżącej komórki po wpisaniu dowolnego znaku - opcja Natychmiastowa edycja (Shift + Ctrl +E);

Rysunek : Menu lokalne rekordu zmiennej.

Menu lokalne umożliwia również dodawanie zmiennych systemowych - polecenie Wstaw definicję zmiennej systemowej - uruchamiane jest okno, za pomocą którego można dodać do bazy definicji zmiennych następujące zmienne systemowe:

__USERID__ - zapewnia dostęp do identyfikatora aktualnie zalogowanego użytkownika;

__USERNAME__ - zapewnia dostęp do nazwy aktualnie zalogowanego użytkownika;

__USERLEVEL__ - zapewnia dostęp do aktualnie obowiązującego poziomu uprawnień;

__AGR_IdGrupy__ - pozwala na wyświetlenie stanu aktywności alarmów należących do wspólnej grupy.

Rysunek : Menu lokalne rekordu zmiennej - dodawanie zmiennej systemowej.


2.2.1.3 Dodawanie i usuwanie atrybutow zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.3 Dodawanie i usuwanie atrybutów zmiennych

2.2.1.3 Dodawanie i usuwanie atrybutów zmiennych

uwaga Nie można usunąć atrybutów obligatoryjnych.

Przyciski Dodaj atrybut dodaj atrybut, Usuń atrybut usuń atrybut znajdują się w menu Baza Definicji Zmiennych.

Rysunek : Okno dodawania nowego atrybutu.


2.2.1.4 Edycja wartosci atrybutu dla kilku zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.4 Edycja wartości atrybutu dla kilku zmiennych

2.2.1.4 Edycja wartości atrybutu dla kilku zmiennych jednocześnie

Polecenie Zmień wartości dostępne w menu lokalnym wywoływanym po zaznaczeniu wybranych wartości danego atrybutu umożliwia zmianę tych wartości – patrz: rys. poniżej.

Rysunek: Zamiana wszystkich zaznaczonych wartości danego atrybutu.

Polecenie Zamień zaznaczone dostępne w menu lokalnym wywoływanym po zaznaczeniu wybranych wartości danego atrybutu umożliwia zamianę pewnej określonej wartości atrybutu w obszarze zaznaczonych pól na nową wartość - patrz: rys. poniżej.

Rysunek: Zamiana określonej wartości atrybutu w obszarze zaznaczonych pól.

Polecenie Zamień w kolumnie dostępne w menu lokalnym wywoływanym po kliknięciu prawym klawiszem myszy w dowolnym polu danego atrybutu pozwala użytkownikowi zmienić określoną wartość atrybutu w obszarze całej kolumny, w której chociaż jedno pole jest zaznaczone - patrz: rys. poniżej.

Rysunek: Zamiana określonej wartości atrybutu w obszarze zaznaczonej kolumny.


2.2.1.5 Wybor widocznych atrybutow zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.5 Wybór widocznych atrybutów zmiennych

2.2.1.5 Wybór widocznych atrybutów zmiennych

Lista atrybutów wszystkich zmiennych wyświetlana w oknie edytora atrybutów zmiennych oraz oknie podglądu zmiennych może być określana przez użytkownika przy użyciu przycisku lista atrybutów (pierwsza pozycja wiersza nagłówków listy zmiennych). Naciśnięcie go otwiera listę wszystkich atrybutów danej bazy definicji zmiennych.

Rysunek: Przycisk wyboru widocznych atrybutów zmiennych.

Można również podejrzeć wartości (wszystkich / bieżących lub zadeklarowanych w zestawie) atrybutów wybranej zmiennej, klikając w edytorze definicji zmiennych lub oknie przeglądania zmiennych prawym przyciskiem myszy na rekordzie wybranej zmiennej (patrz: rysunek poniżej).

Rysunek: Menu lokalne dostępne dla rekordów zmiennej.

Po kliknięciu prawym przyciskiem myszy na dowolne pole wiersza nagłówków pojawia się menu lokalne nagłówków umożliwiające:

  • sortowanie wg wartości rosnącej wskazanego atrybutu - polecenie rosnąco,

  • sortowanie wg wartości malejącej wskazanego atrybutu - polecenie malejąco,

  • usunięcie efektu sortowania,

  • usunięcie kolumny,

  • usunięcie wszystkich kolumn (poza kolumną Nazwa),

  • wybór kolumny - uruchamia okno wyboru nagłówków kolumn wszystkich zadeklarowanych w bazie definicji zmiennych atrybutów, które metodą drag-and-drop można przeciągnąć do pola grupowania lub do wiersza wyświetlanych atrybutów zmiennych - polecenie wybór kolumn;

  • wybór zestawu kolumn - uruchamia okno z zestawami atrybutów, jakie wykorzystywane są do parametryzacji określonych modułów systemu Asix oraz poszczególnych obiektów, umieszczanych na maskach wizualizacyjnych aplikacji; wskazanie danego zestawu atrybutów powoduje, że w edytorze bazy wyświetlone zostaną kolumny parametrów parametryzujących pracę określonego modułu/obiektu;

  • dopasowanie szerokości kolumny do wartości atrybutów - polecenie dostosowanie (dotyczy wybranej kolumny) lub polecenie dopasowanie (wszystkie kolumny), które dotyczy wszystkich kolumn jednocześnie;

  • wyświetlenie okna z opisem atrybutu aktualnie zaznaczonej kolumny.

Rysunek: Menu lokalne dla wiersza nagłówków atrybutów.


2.2.1.6 Edytory atrybutow zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji > 2.2.1.6 Edytory atrybutów zmiennych

2.2.1.6 Edytory atrybutów zmiennych

Edycję wybranych atrybutów zmiennych ułatwiają edytory uruchamiane przyciskiem wielokropek, znajdującym się w polu atrybutu. Aktualnie dostępne są następujące edytory:

1. Adresów zmiennych

2. Parametrów archiwizacji

3. Maski zmiennej

4. Achiwum

5. Formatu zmiennej

6. Funkcji przeliczającej

7. Zmiennej kontrolnej

8. Edytor wyboru kanału

9. Edytor limitów

***

Edytor adresu zmiennej (uruchamiany z pola Adres) uruchamia okno zawierające zestaw pól umożliwiających zdefiniowanie adresu zmiennej. Zestaw pól zależy od drajwera zadeklarowanego dla kanału, do którego została przyporządkowana dana zmienna.

Edytor adresu zmiennej dostępny jest dla wybranych drajwerów. W pozostałych przypadkach należy adres zmiennej wprowadzić ręcznie na podstawie sposobu adresowania zmiennych dla danego drajwera.

Rysunek: Przykładowe okno edytora adresu zmiennej dla kanału z drajwerem Sapis7.

***

Edytor parametrów archiwizacji zmiennych (uruchamiany z pola Parametry archiwizacji) umożliwia zadeklarowanie parametrów archiwizacji podstawowej i archiwizacji dodatkowej.

W ramach danego archiwum (pole Archiwum w bazie definicji zmiennych) zmienna może podlegać dodatkowej archiwizacji w sytuacji, gdy oprócz archiwów przechowywanych w plikach np. dobowych, wymagana jest archiwizacja danych w bazie SQL. W innym przypadku może zachodzić potrzeba przeanalizowania dla danego wycinka czasu danych archiwizowanych z większą częstotliwością niż przewiduje to zasadnicza archiwizacja - wówczas również należy skorzystać z archiwizacji dodatkowej.

Wybór rodzaju archiwizacji odbywa się za pośrednictwem pola Rodzaj - dostępne opcje to:

- Bez archiwizacji;

- Archiwizacja podstawowa;

- Archiwizacja podstawowa i dodatkowa.

Pole Rodzaj archiwum określa typ archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

uwaga Archiwa typu D, M, Y, H wymagają archiwum STANDARD. Stąd zmienna, która w parametrach archiwizacji ma zadeklarowany jeden z wymienionych typów, musi mieć w parametrach archiwum zadeklarowany jako rodzaj archiwum: STANDARD (Architekt > Dane archiwalne > <nazwa archiwum> > zakładka Standardowe).

Pozostałe typy archiwum B i P deklarowane są dla archiwum MS SQL.

Pozostałe pola edytora umożliwiają zadeklarowanie pozostałych parametrów archiwizacji:

- Okres próbkowania;

- Dokładność rejestracji czasu;

- Dokładność rejestracji wartości;

- atrybuty rejestracji: Odtwarzaj ostatnią wartość zarejestrowaną w archiwum, Nie kompresuj danych;

- Okres przechowywania danych (tylko dla archiwów H i B).

Rysunek: Okno edytora parametrów archiwizacji (archiwizacja podstawowa).

***

Edytor maski zmiennej (uruchamiany z pola Maska zmiennej):

Rysunek: Okno edytora maski bitowej zmiennej.

***

Edytor wyboru archiwum (uruchamiany z pola Archiwum):

Rysunek: Okno wyboru archiwum.

***

Edytor formatu (uruchamiany z pola Format) ułatwia definiowanie formatu zmiennej. Dostępne formaty:

  • Liczba całkowita określana przez:

Typ;

Szerokość;

Typ danej wejściowej;

  • Liczba zmiennoprzecinkowa określana przez:

Typ;

Szerokość;

Precyzja

  • Data - dane wejściowa jest traktowana jako ilość sekund od 1970-01-01 00:00, 32 bity określany przez:

Format daty - treścią formatu jest ciąg znaków określających separatory i elementy składowe daty w dowolnej kolejności. Elementy składowe to:

y - rok

m - miesiąc

d - dzień

h - godzina

n - minuta

s - sekunda

Brak określenia formatu daty oznacza formatowanie według domyślnego wzorca: y/m/d h:n:s

  • Czas określany przez opcje:

Dana wejściowa jest traktowana jako ilość milisekund, 32 bity,

Dana wejściowa jest traktowana jao ilość sekund, 32 bity,

Format czasu - treścią formatu jest ciąg znaków określających separatory i elementy składowe czasu w dowolnej kolejności. Elementy składowe to:

d - ilość dni

h - ilość godzin

n - ilość minut

s - ilość sekund

z - ilość milisekund

Brak określenia formatu czasu oznacza formatowanie według domyślnego wzorca: h:n:s

Rysunek: Edytor atrybutu Format.

***

Edytor funkcji przeliczających (uruchamiany z pola Funkcja przeliczająca), który podpowiada projektantowi składnię dla każdej z wbudowanych w system Asix funkcji przeliczających.

Pełny zestaw funkcji przeliczających - patrz: część Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji, 6.6. Funkcje przeliczające.

Funkcje przeliczające używane są przez moduł ASMEN przy przekształcaniu wartości zmiennych procesowych z postaci surowej na postać rzeczywistą. Każda zmienna posiada indywidualnie deklarowaną funkcję przeliczającą.

Rysunek. Okno edytora funkcji przeliczających.

***

Edytor zmiennej kontrolnej (uruchamiany z pola Zmienna kontrolna) uruchamia okno wyboru zmiennej kontrolnej:

Rysunek: Okno wyboru zmiennej.

***

Edytor wyboru kanału (uruchamiany z pola Kanał):

Rysunek: Edytor wyboru kanału.

***

Edytor limitów (uruchamiany z pola: Maksimum, Maksimum krytyczne, Minimum, Minimum krytyczne). Umożliwia zadeklarowanie limitu w jednej z trzech następujących postaci:

  • Limit jako wartość stała

  • Limit jako wartość zmiennej

  • Przekroczenie limitu sygnalizowane kombinacja bitów zmiennej (Nazwa zmiennej, Operator bitowy, Maska bitowa (szesnastkowo))

Rysunek: Okno edytora limitów.


2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor

2.2.2 Tworzenie schematu bazy definicji zmiennych - Edytor schematu

Schemat bazy definicji zmiennych obejmuje informacje dotyczące atrybutów grupujących, definicji zestawów atrybutów, parametrów funkcji przeliczających, nagłówków atrybutów, języków narodowych atrybutów zmiennych, deklaracji atrybutów zastępczych (dla aplikacji wielojęzycznych).

Edycja tych informacji możliwa jest za pomocą Edytora schematu, dostępnego w module Baza definicji zmiennych po otwarciu bazy.

Rysunek: Widok edytora schematu.


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.1 Grupowanie zmiennych

2.2.2.1 Grupowanie zmiennych

Grupowanie zmiennych opiera się na przypisaniu zmiennych do dowolnej liczby grup identyfikowanych przez atrybut grupujący, dodany do Edytora schematu, na zakładce Atrybuty grupujące.

Rysunek: Okno definiowania atrybutów grupujących.

Aby można było zadeklarować atrybut grupujący w zakładce Atrybuty grupujące - najpierw atrybut ten musi zostać dodany do bazy definicji zmiennych w Edytorze definicji zmiennych.

Domyślnie w bazie definicji zmiennych tworzony jest jeden atrybut grupujący o nazwie Grupa1. Projektant może dodać więcej atrybutów grupujących - ich liczba nie jest ograniczona.

Także nazwy atrybutów grupujących mogą być dowolne.

uwaga Zaleca się, aby baza miała zadeklarowany przynajmniej jeden atrybut grupujący.

Zmienna, dla której pominięto wartość pola atrybutu grupującego, będzie widoczna w systemie w grupie o nazwie (Pusta nazwa) widocznej pośród grup użytkownika.

Rysunek: Drzewo grup zmiennych.

Przykładowo, zmienna może mieć atrybuty grupujące: Wydział (wartości np.: Bloki, Pomocniczy), Jednostka (Blok1, Blok2, Demineralizacja, Odpopielanie, itd.), Urządzenie (Camac, S7_1, GeFanuc11, itp.) i Dziedzina Wartości (Analog, Dwustan, Średnia_5m, itd.).

Po otwarciu okna edytora definicji zmiennych / okna przeglądania zmiennych drzewo obrazujące strukturę bazy jest generowane automatycznie na podstawie atrybutów grupujących.

Drzewo ma tyle poziomów, ile jest atrybutów grupujących. Na pierwszym poziomie wyświetlane są wszystkie unikalne wartości atrybutu, który został zadeklarowany jako pierwszy w Edytorze schematu, zakładce Atrybuty grupujące. Następnie dla każdej wartości atrybutu pierwszego tworzonych jest tyle węzłów, ile jest różnych wartości atrybutu zadeklarowanego jako drugi. Tak samo dzieje się dla pozostałych poziomów.

Aby zmienić kolejność wartości atrybutów - wystarczy metodą drag-and-drop uchwycić nagłówek atrybutu grupującego i przenieść go na inną pozycję w bloku Grupy okna edytora definicji zmiennych lub okna podglądu zmiennych.

Rysunek: Zmiana kolejności grupowania zmiennych wg atrybutów.

Kolejność wyświetlanych wartości dla poszczególnych atrybutów grupujących może być ustalana poprzez kliknięcie na nagłówku nazwy danej grupy w bloku Grupy okna edytora zmiennych / okna przeglądania zmiennych (symbol wg malejących wartości oznacza posortowanie wg malejących wartości, wg rosnących wartości - wg rosnących wartości).


2.2.2.2 Zestawy atrybutow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.2 Zestawy atrybutów

2.2.2.2 Zestawy atrybutów

Zestawy atrybutów definiowane są na potrzeby aplikacji systemu Asix. Używane są w akcji OPIS_ZMIENNEJ oraz w oknie wyboru zmiennej (oknie edytora definicji zmiennych / oknie przeglądania zmiennych) dla zawężenia ilości wyświetlanych atrybutów zgodnie z potrzebami projektanta.

Miejscem, gdzie użytkownik może utworzyć swoje zestawy atrybutów jest zakładka Zestawy atrybutów w edytorze schematu (patrz: Rysunek: Okno definiowania zestawu atrybutów.).

uwaga Obecnie zestaw składa się tylko z listy nazw atrybutów. Szerokość okna atrybutów musi być zawsze podawana przy wywołaniu akcji OPIS_ZMIENNEJ.

Rysunek: Okno definiowania zestawu atrybutów.


2.2.2.3 Parametry funkcji przeliczajacych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.3 Parametry funkcji przeliczających

2.2.2.3 Parametry funkcji przeliczających

Parametry funkcji przeliczających definiowane są na potrzeby aplikacji systemu Asix.

W bazie definicji zmiennych atrybut FunkcjaPrzeliczajaca domyślnie zawiera nazwę funkcji przeliczającej zmiennej i wszystkie parametry funkcji. Istnieje jednakże mechanizm, który umożliwia umieszczanie w atrybucie FunkcjaPrzeliczajaca tylko nazwy funkcji przeliczającej, a każdego jej parametru w osobnym atrybucie. Tabela FunkcjePrzeliczające definiuje niezależnie dla każdej funkcji nazwy atrybutów zawierających parametry tej funkcji.

Rysunek: Okno definiowania parametrów funkcji przeliczających.


2.2.2.4 Tlumaczenia nazw atrybutow zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.4 Tłumaczenia nazw atrybutów zmiennych

2.2.2.4 Tłumaczenia nazw atrybutów zmiennych

Baza posiada możliwość definiowania lokalnych, przetłumaczonych na dowolny zadeklarowany przez użytkownika język, nazw atrybutów systemowych i atrybutów użytkownika.

Lokalne nazwy atrybutów pojawiają się jako tytuły kolumn w oknie opisu zmiennej (dostępnym w Edytorze definicji zmiennych lub w oknie podglądu zmiennych).

Rysunek: Okno opisu zmiennej - angielskie nazwy atrybutów.

Każdy język (poza PL i EN) wymaga zadeklarowania przez użytkownika nazw atrybutów zmiennych w Edytorze schematu bazy definicji zmiennych:

Bazy danych > Baza definicji zmiennych > Edytor schematu > Nagłówki atrybutów

Rysunek: Okno deklarowania lokalnych nazw atrybutów zmiennych.


2.2.2.5 Atrybuty zastepcze

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.5 Atrybuty zastępcze

2.2.2.5 Atrybuty zastępcze

Atrybuty zastępcze stosowane są w aplikacjach wielojęzycznych. Dla każdego atrybutu użytkownika oraz dla atrybutu Opis można zdefiniować atrybut zastępczy - tzw. alias.

Dany atrybut (atrybut podstawowy) może posiadać jeden alias dla każdego języka obsługiwanego przez aplikację. Zdefiniowanie aliasu atrybutu sprawia, że dla wybranego języka w miejsce atrybutu podstawowego używany jest alias.

Rysunek: Okno definiowania atrybutów zastępczych.

uwaga W przypadku deklarowania atrybutu zastępczego, zarówno dla atrybutu podstawowego jak i zastępczego należy zdefiniować język w tabeli języków – zakładka Języki atrybutów w Edytorze schematu. Patrz: 2.2.2.6. Deklarowanie języków atrybutów.


2.2.2.6 Deklarowanie jezykow atrybutow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor > 2.2.2.6 Deklarowanie jezyków atrybutów

2.2.2.6 Deklarowanie języków atrybutów

Tabela języków atrybutów znajduje się w:

Bazy danych > Baza definicji zmiennych > Edytor schematu > zakładka Języki atrybutów

Rysunek: Okno definiowania języków atrybutów.

Tabela języków pozwala określić, w jakim języku zdefiniowano wartości danego atrybutu. Informacja ta potrzebna jest zwykle wyłączne w aplikacjach wielojęzycznych do zadeklarowania języka dla atrybutów tekstowych. Język deklarowany jest zarówno dla atrybutu podstawowego jak i zastępczego.


2.2.3 Import modyfikacji z arkusza Excel

Zmiany w definicji zmiennych polegające na dodaniu, usunięciu lub modyfikacji rekordu/rekordów mogą być w wygodny sposób importowane do bazy definicji zmiennych z arkusza Excel. Dla wygody użytkownika w module Baza definicji zmiennych > zakładce Szablon importu modyfikacji znajduje się funkcja umożliwiająca utworzenie skoroszytu (o domyślnej nazwie SzablonImportuModyfikacjiVarDef.xls) zawierającego wszystkie niezbędne kolumny oraz przykładowe dane potrzebne do importu modyfikacji.

uwaga Zakładka Szablon importu modyfikacji dostępna jest dla Typu bazy definicji zmiennych: Standardowa baza definicji zmiennych / Tryb Edytor. Lista kolumn w utworzonym szablonie importu odpowiada bieżącej (zadeklarowanej w zakładce Format) bazie definicji zmiennych.

Rysunek: Szablon importu modyfikacji VarDef.

Jak zaimportować do istniejącej bazy definicji zmiennych MS SQL lub Jet zmiany w definicji zmiennych wykorzystując arkusz Excel jako źródło?:

1. W pierwszym kroku wygeneruj szablon importu modyfikacji:

(wcześniej upewnij się, czy aktualnie włączonym trybem tworzenia bazy jest Tryb Edytor, a w zakładce Baza definicji zmiennych > Format zadeklarowana została właściwa baza)

Funkcja generujące szablon importu modyfikacji znajduje się w:

Baza definicji zmiennych > zakładka Szablon importu modyfikacji > przycisk Utwórz

2. W wygenerowanym skoroszycie, w zakładce Modyfikacje zmiennych wprowadź stosowne rekordy, pamiętając że:

- w przypadku dodania rekordu nowej zmiennej, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak plus (+);

- w przypadku usunięcia rekordu zmiennej istniejącej w bazie, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak minus (-);

- w przypadku modyfikacji rekordu zmiennej istniejącej w bazie, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak gwiazdka (*);

3. Otwórz istniejącą bazę definicji zmiennych (przycisk Otwórz otwórz).

4. Wybierz komendę Importuj modyfikacje importuj modyfikacje i wskaż stosowny plik *. XLS ze zmodyfikowanymi rekordami zmiennych.

5. W oknie ’Wybierz arkusz’ zaznacz opcję Modyfikacje zmiennych i zatwierdź wybór przyciskiem OK.


2.3 Tworzenie bazy w trybie Generatora

W przypadku tworzenia bazy definicji zmiennych w trybie Generatora, definicje zmiennych dostarczane są w zewnętrznych źródłach (np. w arkuszach Excel). Baza generowana jest przy użyciu programu Architekt. Po każdej modyfikacji źródeł danych należy bazę ręcznie wygenerować (lub uaktualnić) i uruchomić ponownie aplikację systemu Asix.

Szczególnym przypadkiem jest tworzenie zbiorczej bazy generowanej z kilku istniejących baz definicji zmiennych - patrz: 2.3.7. Zbiorcza baza definicji zmiennych.

Tworzenie bazy definicji zmiennych w trybie Generatora realizowane jest w następujących krokach:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

Rysunek: Baza definicji zmiennych > zakładka Typ - Tryb Generator.

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia Nazwy użytkownika oraz Hasła.

3. Określ źródła danych:

Baza definicji zmiennych > zakładka Źródła danych > pliki źródła danych (pliki Excel, obiekt OLE DB, pliki ZEZ/DB starszych wersji Asixa, pliki tekstowe starszych wersji Asixa lub pliki konfiguracyjne aplikacji formatu *.XML)

Rysunek: Baza definicji zmiennych - zakładka 'Źródło danych'.

4. Wybierz polecenie Generuj generuj.

5. Ewentualnie otwórz bazę, aby zweryfikować przy użyciu Edytora definicji zmiennych poprawność generacji;


2.3.1 Opcje generowania bazy definicji zmiennych z wielu zrodel

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.1 Opcje generowania bazy definicji zmiennych z wielu źródeł

2.3.1 Opcje generowania bazy definicji zmiennych z wielu źródeł danych

Blok Bazy danych > Baza definicji zmiennych wyposażony został w zakładki Opcje/Opcje2, umożliwiające ustawienie parametrów dotyczących generowania bazy definicji zmiennych pochodzących z wielu źródeł - włączając w to przypadki, kiedy różne źródła zawierają definicje powtarzających się zmiennych.

Zakładka Opcje obejmuje następujące parametry:

  • Generowanie informacji o położeniu definicji zmiennych

  • Dodaj atrybut ’Źródło danych’ - powoduje dodanie do bazy definicji zmiennych atrybutu przechowującego nazwę skoroszytu zawierającego definicję zmiennej;

  • Dodaj atrybut ’Tabela danych’ - powoduje dodanie do bazy definicji zmiennych atrybutu przechowującego nazwę arkusza zawierającego definicję zmiennej;

  • Sprawdzanie różnic podczas generowania bazy definicji zmiennych

  • Włącz sprawdzanie różnic podczas generowania bazy definicji zmiennych - opcja umożliwia porównanie generowanej bazy z istniejącą bazą w trakcie generowania bazy definicji zmiennych; w przypadku wykrycia zmian pojawia się pytanie o kontynuowanie; porównywane są definicje zmiennych i tabele schematu.

  • Włącz zapis tylko różnic do bazy definicji zmiennych - opcja umożliwia zapisywanie tylko zmian wykrytych w trakcie generacji bazy definicji zmiennych zamiast czyszczenia bazy i zapisywania wszystkich danych; zapis samych zmian jest możliwy gdy nie występują zmiany schematu bazy.

  • Tworzenie kopii zapasowej podczas generowania bazy definicji zmiennych

  • Włącz tworzenie kopii zapasowej podczas generowania bazy definicji zmiennych – przy załączonej opcji generator bazy definicji zmiennych tworzy kopię dotychczasowej bazy w podkatalogu ‘backup’ zadeklarowanego katalogu bazy (lub w przypadku braku zadeklarowanego katalogu bazy danych serwera MS SQL podkatalog z kopią tworzony jest w domyślnym katalogu bazy serwera MS SQL).

Zakładka Opcje 2 obejmuje następujące parametry:

  • Dzielenie definicji zmiennej pomiędzy źródłami

  • Pozwalaj na dzielenie definicji zmiennej pomiędzy źródłami - opcja przydatna w przypadku scalania definicji tych samych zmiennych pochodzących z wielu różnych źródeł;

  • Wielokrotne definicje zmiennych - preferowanie zmiennych aktywnych

  • W przypadku powtórzenia definicji zmiennej użyj pierwszej definicji zmiennej aktywnej – w przypadku użycia opcji generator przyjmuje jako obowiązującą definicję pochodzącą z pierwszego dokumentu zawierającego tę definicję wg kolejności zadeklarowanych źródeł danych na zakładce Źródła danych.

  • Wielokrotne definicje zmiennych - preferowanie kanałów fizycznych

Opcja ma zastosowanie dla źródeł danych w postaci plików *.ini i *.xml, ponieważ tylko dla tych źródeł możliwe jest określenie typu kanału w definicji zmiennej:

Definicje zmiennych nie mogą się powtarzać;

Definicje zmiennych mogą się powtarzać: zezwalaj na jedną definicję w kanale fizycznym, ignoruj powtórzone definicje w kanałach typu NETWORK - w praktyce oznacza to, że w trakcie generowania bazy zaakceptowana zostanie pierwsza napotkana definicja, a dla wszystkich definicji z pozostałych kanałów fizycznych wypisane zostanie ostrzeżenie w panelu logu ’Generacja bazy definicji zmiennych’;

Definicje zmiennych mogę się powtarzać: akceptuj pierwszą definicję w kanale fizycznym, ignoruj pozostałe powtórzone definicje - oznacza, że w trakcie generowania bazy zaakceptowana zostanie pierwsza definicja z kanału fizycznego, dla drugiej definicji z kanały fizycznego pojawi się ostrzeżenie w panelu logu ’Generacja bazy definicji zmiennych’, a pozostałe powtarzające się definicje zostaną zignorowane.


Generowanie bazy z plików ZEZ/mdb

2.3.2. Generowanie bazy z plików ZEZ/DB

W przypadku baz definicji zmiennych w formacie Paradox wykorzystywanych w starszych wersjach Asixa (wersja 4 i wcześniejsze) należy przekonwertować je do formatu standardowych baz systemu Asix. Patrz rozdział: 2.9 Konwertowanie bazy definicji zmiennych z formatu Paradox na format Jet lub MS SQL.


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.3 Generowanie bazy definicji zmiennych z arkusza Excel > 2.3.3.1. Generowanie bazy na podstawie listy używanych zmiennych

2.3.3.1. Generowanie bazy na podstawie listy używanych zmiennych

Generowanie bazy definicji zmiennych na podstawie listy używanych zmiennych umożliwia wygenerowanie bazy, w której znajdą się wyłącznie definicje zmiennych wykorzystywanych jako parametry w obiektach masek wizualizacyjnych w aplikacji (włącznie ze zmiennymi zależnymi - czyli użytymi w atrybutach wyżej wymienionych zmiennych lub w funkcji przeliczającej).

Aby wygenerować listę używanych zmiennych na podstawie definicji aplikacji należy:

1. Przy załadowanym pliku konfiguracyjnym aplikacji wybrać polecenie Generuj listę używanych zmiennych (opcja dostępna po przejściu na widok Obszary i computery) - dostępne w menu Aplikacja.

2. Zapisać wygenerowany plik o domyślnej nazwie 'Nazwy zmiennych używanych.xls'.

UWAGA: Istotny jest arkusz z listą zmiennych znajdujący się wewnątrz wygenerowanego pliku xls. Arkusz ten można przenieść do pliku, w którym umieszczone są arkusze z definicjami zmiennych. Ważne, aby zachować nazwę arkusza: 'ZmienneUżywane'.

Aby wygenerować bazę definicji zmiennych na podstawie listy używanych zmiennych należy:

1. Ustawić w bloku Bazy danych > Baza definicji zmiennych > zakładka Typ: typ bazy definicji zmiennych na Standardowa baza definicji zmiennych w trybie Generator.

2. Przejść do bloku Bazy danych > Baza definicji zmiennych > zakładka Źródła danych

2. Zadeklarować arkusze z definicjami zmiennych (w oparciu o które będzie generowana baza) wraz z arkuszem zawierającym listę zmiennych używanych.

3. Nacisnąć polecenie generowania bazy definicji zmiennych - Generuj.


2.3.3 Generowanie bazy definicji zmiennych na podstawie bazy

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.4 Generowanie bazy definicji zmiennych na podstawie bazy

2.3.4 Generowanie bazy definicji zmiennych na podstawie bazy OLE DB

Istnieje możliwość wygenerowania bazy definicji zmiennych z bazy OLE DB po odpowiednim skonfigurowaniu właściwości łącza danych (dostawca, właściwości połączenia oraz opcje zaawansowane).

Struktura źródłowej bazy OLE DB powinna być przygotowana w sposób analogiczny do arkuszy Excel, wykorzystywanych jako źródło generowania bazy definicji zmiennych. Wymagane jest zatem zdefiniowanie następujących rodzajów danych:

- atrybuty zmiennych,

- grupowanie,

- zestawy atrybutów,

- funkcje przeliczające,

- nagłówki,

- języki atrybutów,

- nazwy zstępcze.

Powyższe dane należy przygotować według wskazówek omówionych w rozdziale 2.6. Przygotowanie zewnętrznego źródła danych - arkusz Excel.


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.5. Generowanie bazy definicji zmiennych na podstawie plików xml

2.3.5. Generowanie bazy definicji zmiennych na podstawie plików XML

W przypadku generowania zbiorczej bazy definicji zmiennych z baz kilku aplikacji konfigurowanych w plikach xml - zaleca się wskazanie źródeł danych przy użyciu przycisku Asix - plik xml....

Rysunek: Okno deklarowania źródeł danych do wygenerowania bazy definicji zmiennych.


2.3.6. Import definicji zmeinnych z serwera OPC

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.6. Import definicji zmiennych z serwera OPC / OPC UA

2.3.6. Import definicji zmiennych z serwera OPC / OPC UA

Definicje zmiennych z serwera OPC / OPC UA importowane są do arkusza programu Excel poleceniem Importuj z serwera OPC… z menu Baza definicji zmiennych. Polecenie to uruchamia kreator, który pozwala zdefiniować połączenie z serwerem OPC i sposób importu definicji zmiennych. Kreator automatycznie doda utworzony arkusz do listy źródeł danych projektowanej aplikacji (Architekt > Bazy danych > Baza definicji zmiennych > Źródła danych), gdy aktywnym typem tworzenia aplikacji jest Tryb Generator.

Jeśli baza jest generowana po raz pierwszy - należy w module Bazy danych > Baza definicji zmiennych na zakładce Typ zadeklarować jako typ tworzenia bazy - Tryb Generator.

Jeżeli definicje zmiennych z serwera OPC zostały juz zaimportowane do arkusza Ecxel a następnie baza definicji zmiennych wygenerowana - istnieje możliwość wprowadzania zmian do arkusza zawierającego definicje zmiennych pochodzących z OPC i importowania tych zmian do bazy przy użyciu komendy Importuj modyfikacje... z menu Baza definicji zmiennych. Opcja ta jest dostępna po ustawieniu w module Bazy danych > Baza definicji zmiennych na zakładce Typ typu tworzenia bazy Tryb Edytor i otwarciu bazy.

Rysunek: Kreator importu definicji zmiennych z serwera OPC.


2.3.7. Zbiorcza baza definicji zmiennych

Zbiorcza baza definicji zmiennych jest to baza definicji zmiennych generowanych z kilku istniejących baz definicji zmiennych. Przy generowaniu takiej bazy można napotkać dwa rodzaje problemów.

Informacje tego samego typu mogą znajdować się w wejściowych bazach w atrybutach o innych nazwach. W tym przypadku należy użyć transformacji nazw atrybutów, aby ujednolicić nazwy atrybutów.

Drugi problem to różne nazwy i liczby atrybutów grupujących. W takim przypadku również należy użyć transformacji nazw atrybutów, aby ujednolić nazwy atrybutów lub dodać brakujące atrybuty grupujące. Należy również użyć transformacji wartości atrybutów, aby podać wartości dodawanych atrybutów grupujących i, ewentualnie, dopasować wartości atrybutów grupujących do nazewnictwa stosowanego w zbiorczej bazie definicji zmiennych.

Uwaga: istnieje też możliwość czytania definicji zmiennych z łączonych baz definicji zmiennych, parametryzowanych przez zewnętrzne pliki XML. Patrz: 2.1.2.1. Łączone bazy definicji zmiennych.


2.3.8. Uaktualnianie źródeł danych

Jeśli baza definicji zmiennych została wygenerowana, dalsze uaktualnianie definicji zmiennych można przeprowadzać przy użyciu komendy Uaktualnij (moduł Bazy danych > Baza definicji zmiennych (dla typu: Standardowa baza definicji zmiennych; tryb Generator) > zakładka Źródła danych.

Funkcja uaktualniania źródeł danych zostaje zablokowana, gdy źródła zawierają tabele transformacji lub tabele zmiennych używanych.


2.3.9. Transformacja nazw i wartości atrybutów

W przypadku generowania baz definicji zmiennych na podstawie definicji zmiennych znajdujących się w arkuszu kalkulacyjnym *.xls dostępny jest mechanizm transformacji nazw atrybutów i wartości atrybutów. Transformacji takiej można dokonać definiując w arkuszu Excela nazwę atrybutu wejściowego i wyjściowego (dla transformacji nazw atrybutów) lub wejściowe i wyjściowe wartości atrybutów (dla transformacji wartości atrybutów). Zarówno nazwa jak i struktura takiego arkusza (tabeli) musi być ściśle określona:

- dla transformacji nazw atrybutów:

- nazwa arkusza: PrzekształceniaNazwAtr

- kolumny arkusza: NazwaŹródłaDanych, AtrybutWejściowy, AtrybutWyjściowy

(szczegółowy opis - patrz: 2.6.8 Parametry transformacji nazw atrybutów i wartości)

Podanie jako AtrybutWejściowy nazwy pustej powoduje dodanie do źródła danych nowej kolumny.

Podanie jako AtrybutWyjściowy nazwy pustej powoduje usunięcie z źródła danych wskazanej kolumny.

- dla transformacji wartości atrybutów:

- nazwa arkusza: PrzekształceniaWartościAtr

- kolumny arkusza: NazwaŹródłaDanych, Atrybut, WejściowaWartośćAtrybutu i WyjściowaWartośćAtrybutu

(szczegółowy opis - patrz: 2.6.8 Parametry transformacji nazw atrybutów i wartości)

Podanie jako WejściowaWartośćAtrybutu nazwy pustej powoduje dodanie do źródła danych nowej wartości atrybutu.

Podanie jako WyjściowaWartośćAtrybutu nazwy pustej powoduje usunięcie z źródła danych wskazanej wartości atrybutu.


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.10. Nadpisywanie atrybutów przez wybraną tabelę źródła danych

2.3.10. Nadpisywanie atrybutów przez wybraną tabelę źródła danych

Nadpisywanie wartości atrybutów przez wybraną tabelę źródła danych wymaga wstawienia dodatkowej kolumny o nazwie ForceUpdateAttributes do tabeli (arkusza) z docelowymi wartościami atrybutów, które chcemy nadpisać.

Nadpisywanie wartości atrybutów wykonywane jest dla konkretnych zmiennych - tabela z docelowymi wartościami atrybutów powinna zatem zawierać kolumnę z nazwami zmiennych, kolumny atrybutów z wartościami docelowymi oraz kolumnę ForceUpdateAttributes (kolumna ta może być pusta, wartości w niej nie są brane pod uwagę).

Rysunek: Nadpisywanie atrybutów - tabela docelowych wartości atrybutów.


2.4 Przegladanie_zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.4 Przeglądanie zmiennych

2.4 Przeglądanie zmiennych

Poza dostępem do definicji zmiennych, jaki zapewnia edytor bazy definicji zmiennych, definicje zmiennych mogą być przeglądanie za pomocą okna 'Przeglądanie zmiennych', uruchamianego przyciskiem [image] Pokaż.

Rysunek. Okno 'Przeglądanie zmiennych'.

Dodatkowo okno daje możliwość przeglądania wartości bieżących zmiennych oraz modyfikowania tych wartości.

Do wyświetlenia wartości bieżących zmiennych służy przycisk Pokaż wartości bieżące, po naciśnięciu którego zostają wyświetlone kolumny Wartość zmiennej i Jakość zmiennej.

Funkcja jest dostępna tylko w oknie wyboru zmiennych wywoływanym bezpośrednio z programu Architekt. W trybie pokazywanie wartości bieżących ukrywany jest wiersz filtrów, ponieważ odświeżanie wartości bieżących i tak praktycznie uniemożliwia korzystanie z niego.

Aby dokonać zmiany wartości zmiennej, należy w wierszu wybranej zmiennej wybrać z rozwijanego menu Pokaż wartości bieżące polecenie [image] Modyfikuj wartość bieżącą.

Rysunek: Okno 'Przeglądanie zmiennych' - modyfikacja wartości bieżącej zmiennej.

Okno 'Przeglądanie zmiennych' umożliwia również wyszukiwanie zmiennych po nazwie.

Rysunek: Okno 'Przeglądanie zmiennych' - wyszukiwanie zmiennych.


2.4.1 Wyszukiwanie wartosci atrybutu i filtrowania rekordow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.4 Przeglądanie zmiennych > 2.4.1 Wyszukiwanie wartości atrybutu i filtrowanie rekordów

2.4.1 Wyszukiwanie wartości atrybutu i filtrowanie rekordów po wartości atrybutu

Wyszukiwanie i filtrowanie rekordów wg wymaganej wartości atrybutu umożliwia Kreator filtrów wywoływany poleceniem Filtrowanie i grupowanie z paska poleceń okna 'Przeglądanie zmiennych':

Rysunek: Okno kreatora filtrów dla rekordów bazy definicji zmiennych.

W edytorze definicji zmiennych istnieje mechanizm wyszukiwania inkrementalnego wartości dowolnego atrybutu. Po wpisaniu początkowych liter szukanej wartości w dowolną komórkę kolumny tego atrybutu mechanizm powoduje automatyczne przeniesienie do pierwszego rekordu z daną początkową wartością atrybutu. Mechanizm działa dla kolumn wszystkich atrybutów.


2.5 Praca ze skoroszytem Excel jako zrodlem danych o atrybutach

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.5 Praca ze skoroszytem Excel jako źrółem danych o atrybutach

2.5 Praca ze skoroszytem Excel jako źródłem danych o atrybutach zmiennych bez generowania bazy definicji zmiennych

Użytkownik pracujący z najnowszą wersją pakietu Asix ma do dyspozycji możliwość takiego skonfigurowania pracy aplikacji, aby korzystała ona z definicji zmiennych pobieranych bezpośrednio z arkuszy kalkulacyjnych Excel [4]. Arkusze te należy przygotować w sposób szczegółowo opisany w rozdziale 2.6 . Przygotowanie zewnętrznego źródła danych - arkusz Excel.

Jak zadeklarować arkusz kalkulacyjny jako źródło definicji zmiennych?:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Źródło danych

3. Załaduj źródła danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż plik *.XLS naciskając przycisk Excel....

W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

Krok powtórz tyle razy, aż zostaną zadeklarowane wszystkie pliki źródłowe.

4. Dane mogą być przeglądane w oknie ’Przeglądanie zmiennych’ po wybraniu komendy Pokaż pokaż.

uwaga Ten typ bazy definicji zmiennych można stosować tylko wtedy, gdy na komputerze pracuje system Asix i ZAWSZE jest on uruchamiany jako pierwszy. Wyklucza to sytuację, w której na komputerze pracuje serwer internetowy AsPortal lub AsWWW lub generowane są raporty przy pomocy programu AsixConnect.

__________________________________________________

[4] Baza jest generowana ’w locie’ – w sposób niewidoczny dla użytkownika i tylko na czas działania aplikacji.


2.6 Przygotowanie zewnetrznego zrodla danych – arkusz Excel

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel

2.6 Przygotowanie zewnętrznego źródła danych - arkusz Excel

W przypadku, gdy źródłem danych niezbędnych do wygenerowania bazy definicji zmiennych (jak i w trybie tworzenia bazy Tryb Źródło danych, kiedy definicje zmiennych pobierane są bezpośrednio z arkusza Excel) jest arkusz Excel, dane muszą znajdować się w arkuszach w formacie XLS lub XLSX. Arkusze mogą być tworzone programem Microsoft Excel (w wersji 97, 2000, XP, 2003 i 2007) lub programem Open Office (w wersji 1.1.2 lub późniejszej).

uwaga Architekt wyposażony został w prosty, ale w pełni funkcjonalny arkusz kalkulacyjny, który umożliwia edycję arkusza w formacie XLS - pomocny w sytuacji, gdy na komputerze nie jest zainstalowany pakiet Microsoft Excel.

Wyróżnionych zostało kilka rodzajów danych, które są umieszczone w odrębnych arkuszach w formie tabel [5] - rodzaje te zostaną omówione w kolejnych podrozdziałach:

  • atrybuty zmiennych,

  • grupowanie,

  • zestawy atrybutów,

  • funkcje przeliczające,

  • nagłówki,

  • języki atrybutów,

  • nazwy zastępcze,

  • parametry transformacji nazw atrybutów i wartości atrybutów.

uwaga Zakładki, których nazwy rozpoczynają się od znaku '#', są to zakładki informacyjne, nie wchodzące w skład schematu bazy. Takie zakładki nie są widziane przez Architekta podczas wyboru źródeł danych.

______________________________________________

[5] Nazwa arkusza w skoroszycie Excel odpowiada nazwie tabeli w docelowej bazie, generowanej na podstawie arkusza


2.6.1 Atrybuty zmiennych

Definicje zmiennych mogą znajdować się w jednym lub kilku arkuszach o dowolnej nazwie, w jednym lub kilku skoroszytach. Wszystkie atrybuty jednej zmiennej muszą znajdować się w jednym arkuszu.

W danym arkuszu nie muszą znajdować się wszystkie zdefiniowane w bazie atrybuty. Wszystkie atrybuty liczbowe, które nie są dla zmiennej zdefiniowane mają wartość NULL. Puste atrybuty tekstowe mają jako wartość tekst o długości 0.

Rysunek: Definicje zmiennych w arkuszu Excel w rozbiciu na kilka zakładek.

uwaga Wszystkie nazwy atrybutów systemowych wewnętrznie są zadeklarowane w języku angielskim.

Przy imporcie danych nazwy atrybutów systemowych mogą być podawane zarówno w języku polskim jak i angielskim - zgodnie z ustalonym szablonem nazw atrybutów - patrz: Załącznik 1.


2.6.2 Grupowanie

Atrybuty grupujące muszą znaleźć się w tabeli o ustalonej nazwie (w języku polskim: AtrybutyGrupujące, angielskim: GroupingAttributes).

Tabela składa się z jednej kolumny (pol.: Nazwa, ang.: Name). Każdy wiersz zawiera nazwę jednego atrybutu grupującego. Przykład - patrz: rysunek poniżej.

Nazwy atrybutów grupujących mogą być dowolne.

Rysunek: Arkusz Excel - atrybuty grupujące.


2.6.3 Zestawy atrybutow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.3 Zestawy atrybutów

2.6.3 Zestawy atrybutów

Tabela zestawów atrybutów (o ustalonej nazwie - pol.: ZestawyAtrybutów, ang.: AttributeSets) składa się z dwóch kolumn. W pierwszej kolumnie (o nazwie - pol: Nazwa, ang.: Name) znajduje się nazwa zestawu, a w drugiej kolumnie (pol.: Atrybut, ang.: Attribute) - nazwa atrybutu.

Dla atrybutów systemowych należy użyć nazw atrybutów ustalonych dla języka polskiego lub angielskiego (nazw wewnętrznych lub nazw zadeklarowanych jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 . Nagłówki).

Rysunek: Arkusz Excel - zestawy atrybutów.


2.6.4 Parametry funkcji przeliczajacych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.4 Parametry funkcji przeliczających

2.6.4 Parametry funkcji przeliczających

Tabela parametrów funkcji (o ustalonej nazwie - pol.: FunkcjePrzeliczające, ang.: ConversionFunctions) składa się z dwóch kolumn. W pierwszej kolumnie (pol.: Nazwa, ang.: Name) umieszczana jest nazwa funkcji, a w drugiej kolumnie (pol.: Atrybut, ang.: Attribute) - nazwa atrybutu.

Dla atrybutów systemowych należy użyć nazw atrybutów ustalonych dla języka polskiego lub angielskiego (nazw wewnętrznych lub nazw zadeklarowanych jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 . Nagłówki).

Rysunek: Arkusz Excel - parametry funkcji przeliczających.


2.6.5 Naglowki

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.5 Nagłówki

2.6.5 Nagłówki

Tabela nagłówków (polska nazwa ustalona tabeli: NagłówkiAtrybutów, angielska: AttributeCaptions) pozwala zdefiniować nagłówki kolumn w oknach wyboru/edycji atrybutów zmiennych. Wszystkie teksty będące nagłówkami zmiennych muszą być unikalne. Nazwa jakiegokolwiek atrybutu nie może być nazwą nagłówka innego atrybutu.

W pierwszej kolumnie tabeli nagłówków (pol.: Nazwa, ang.: Name) należy umieścić nazwy atrybutów - dla atrybutów systemowych należy użyć nazw systemowych atrybutów w języku polskim lub angielskim; dla atrybutów użytkownika należy je podać w takiej formie, w jakiej zostały zdefiniowane w arkuszach zawierających definicje zmiennych.

W drugiej kolumnie (pol.: Język, ang.: Language) umieszczane są kody języków - zgodne z oznaczeniami ISO obsługiwanych języków. Zestawienie wszystkich kodów języków obsługiwanych przez Architekta zawiera Załącznik 3.

Kolumna trzecia (pol.: Nagłówek, ang.: Caption) przeznaczona jest do określania wyświetlanych nazw nagłówków.

Rysunek: Arkusz Excel - nagłówki.


2.6.6 Jezyki atrybutow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.6 Języki atrybutów

2.6.6 Języki atrybutów

Tabela o ustalonej nazwie (pol.: JęzykiAtrybutów, ang.: AttributeLanguages) pozwala określić, w jakim języku zdefiniowano wartości danego atrybutu. Informacja ta potrzebna jest zwykle wyłącznie w aplikacjach wielojęzycznych do podania języka atrybutu-aliasu oraz atrybutów tekstowych do prawidłowego działania edycji i wyświetlania.

W pierwszej kolumnie (pol.: Nazwa, ang.: Name) należy podać nazwy atrybutów (nazwy oryginalne lub nazwy zadeklarowane jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 Nagłówki .).

W drugiej kolumnie (pol.: Język, ang.: Language) umieszczane są kody języków - zgodne z oznaczeniami ISO obsługiwanych języków.

Na poniższym ekranie zadeklarowano język angielski dla atrybutu Opis_EN, który zawiera angielskie opisy zmiennych. Po zadeklarowaniu atrybutu Opis_EN jako nazwy zastępczej dla atrybutu Opis zmiennej (patrz: 2.6.7 . Atrybuty zastępcze) opisy zmiennych będą pojawiać się, stosowanie do załączonego języka aplikacji, albo w języku polskim albo w języku angielskim.

Rysunek: Arkusz Excel - języki atrybutów.


2.6.7 Atrybuty zastepcze

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.7 Atrybuty zastępcze

2.6.7 Atrybuty zastępcze

Definiowanie aliasów stosowane jest dla aplikacji wielojęzycznych, gdzie często zachodzi potrzeba, aby w jednym z języków zamiast pewnego atrybutu, zwanego dalej podstawowym, wyświetlić atrybut zastępczy (alias). Aby osiągnąć ten efekt, należy zdefiniować w bazie oba atrybuty i w tabeli aliasów zadeklarować, który jest atrybutem podstawowym a który zastępczym.

Dla atrybutu podstawowego i zastępczego należy zdefiniować język w tabeli języków - patrz: 2.6.6 . Języki atrybutów.

Aliasy atrybutów muszą zostać określone w tabeli o ustalonej nazwie - pol.: AtrybutyZastępcze, ang.: SubstituteAttributes.

W pierwszej kolumnie (pol.: Nazwa, ang.: Name) powinny znaleźć się atrybuty podstawowe, a w drugiej kolumnie (pol.: NazwaZastępcza, ang.: SubstituteName) odpowiadające im aliasy.

Rysunek: Arkusz Excel - atrybuty zastępcze.


2.6.8 Parametry transformacji nazw atrybutow i wartosci

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.8 Parametry transformacji nazw atrybutów i wartości

2.6.8 Parametry transformacji nazw atrybutów i wartości atrybutów

W przypadku generowania baz definicji zmiennych na podstawie definicji zmiennych znajdujących się w arkuszu kalkulacyjnym *.xls dostępny jest mechanizm transformacji nazw atrybutów i wartości atrybutów.

Parametry transformacji, tzn.:

- NazwaŹródłaDanych, AtrybutWejściowy, AtrybutWyjściowy dla transformacji nazw atrybutów

oraz

- NazwaŹródłaDanych, Atrybut, WejściowaWartośćAtrybutu i WyjściowaWartośćAtrybutu dla transformacji wartości atrybutów

należy zadeklarować odpowiednio na zakładkach: PrzekształceniaNazwAtr lub PrzekształceniaWartościAtr źródłowego pliku *.XLS.

Jako NazwaŹródłaDanych należy podać nazwę źródła danych taką jaka pojawia się w Architekcie w tabeli Bazy danych > Baza definicji zmiennych > Źródła danych, kolumnie Nazwa źródła danych. Nazwą tą może być np. nazwa arkusza Excel. Jako AtrybutWejściowy należy podać nazwę istniejącej kolumny. Jako AtrybutWyjściowy należy podać nową nazwę kolumny - nie może już istnieć kolumna o takiej nazwie.

Podanie jako AtrybutWejściowy nazwy pustej powoduje dodanie do źródła danych nowej kolumny.

Podanie jako AtrybutWyjściowy nazwy pustej powoduje usunięcie z źródła danych wskazanej kolumny.

Jako NazwaŹródłaDanych należy wartość jak wyżej. Jako Atrybut należy podać nazwę atrybutu którego wartości mają być przekształcane. Jako WejściowaWartośćAtrybutu należy podać wartość atrybut która ma zostać zmodyfikowana. Jako WyjściowaWartośćAtrybutu należy podać nową wartość atrybutu.

Podanie jako WejściowaWartośćAtrybutu nazwy pustej powoduje dodanie do źródła danych nowej wartości atrybutu.

Podanie jako WyjściowaWartośćAtrybutu nazwy pustej powoduje usunięcie z źródła danych wskazanej wartości atrybutu.

Rysunek: Arkusz Excel - PrzekształceniaNazwAtr.

Rysunek: Arkusz Excel - PrzekształceniaWartościAtr.


2.6.9. Zmeinne używane

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.9. Zmienne używane

2.6.9. Zmienne używane

Arkusz z zestawem zmiennych używanych pozwala zawęzić liczbę zmiennych, których definicje mają być pobrane ze źródeł w trakcie generowania bazy definicji zmiennych.

Ten mechanizm ma zastosowanie głównie podczas generowania zbiorczych baz definicji zmiennych.

Zmienne używane muszą znaleźć się w tabeli (arkuszu) o ustalonej nazwie ZmienneUżywane. Tabela zawierać powinna jedną kolumnę Nazwa.

Zadeklarowanie arkusza (tabeli) ZmienneUżywane jako źródła danych, z którego wygenerowana zostanie baza definicji zmiennych (obok źródeł, z których pobrane zostaną definicje zmiennych) - pozwala kontrolować ilość zmiennych, które mają znaleźć się w bazie.

***

Można również wygenerować z istniejącej bazy definicji zmiennych listę zmiennych używanych przez maski aplikacji. Służy do tego polecenie Generuj listę używanych zmiennych z menu Aplikacja, dostępne w bloku Obszary i komputery.


Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.10. Szablon bazy definicji zmiennych

2.6.10. Szablon bazy definicji zmiennych

Architekt ułatwia przygotowanie pliku Excel z definicjami zmiennych, dając możliwość wygenerowania szablonowego skoroszytu zawierającego wybrane arkusze używane do wygenerowania bazy definicji zmiennych.

Wygenerowanie szablonu definicji zmiennych w pliku Excel:

1. Przejdź do:

Baza definicji zmiennych > zakładka Szablon (przy załączonym typie standardowej bazy definicji zmiennych systemu Asix tworzonej w trybie Generatora lub trybie Źródło danych)

2. Zaznacz arkusze, które mają się pojawić w szablonie

3. Kliknij przycisk Utwórz...


2.6.11. Szablony wartosci atrybutow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.11. Szablony wartości atrybutów

2.6.11. Szablony wartości atrybutów

Przy generowaniu bazy dla pojedynczej bazy definicji zmiennych można wykorzystać transformację wartości atrybutów do zebrania w jednym miejscu często powtarzających się wartości atrybutów. Na przykład można podać dla każdej zmiennej jako parametry archiwizacji identyfikatory 'ArchiwizacjaPLC' lub 'ArchiwizacjaScript'. Następnie w tabeli transformacji wartości atrybutów podać, że 'ArchiwizacjaPLC' ma być zamieniana np. na D, 1s,,1s a 'ArchiwizacjaScript' na D, 10s,,10s.


2.6.12. Edycja atrybutów bazy definicji zmiennych przy użyciu dodatku Asix Architekt Plugin

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.6 Przygotowanie zewnętrznego źródła danych – arkusz Excel > 2.6.12. Asix Architekt Plugin - edycja atrybutów bazy definicji zmiennych

2.6.12. Asix Architekt Plugin - edycja atrybutów bazy definicji zmiennych

Dodatek Asix Architekt Plugin dedykowany arkuszowi kalkulacyjnemu od wersji MS Excel 2010 daje możliwość edytowania atrybutów definicji zmiennych przy użyciu tych samych edytorów, które dostępne są w przypadku edycji definicji zmiennych w bazie tworzonej w trybie Edytora - czyli bezpośrednio w programie Architekt (Typ bazy definicji zmiennych > Standardowa baza definicji zmiennych > Tryb Edytor).

Lista atrybutów, które mogą być definiowane w arkuszu kalkulacyjnym MS Excel przy pomocy wspomnianych edytorów, obejmuje: Adres, Kanał, Funkcja przeliczająca, Format, Archiwum, Parametry archiwizacji oraz limity.

Opcja Napraw arkusz usuwa z arkusza formatowanie komórek znajdujących się poza obszarem danych.

Dodatek Asix Architekt Plugin dostępny jest od wersji 7.0.0. pakietu Asix. Jego instalacja odbywa się w trakcie instalacji pakietu Asix (jeśli na komputerze zainstalowany jest 32-bitowy MS Office 2010 lub nowszy). Po zainstalowaniu pakietu Asix instalację Asix Architekt Plugin można przeprowadzić (np. po aktualizacji Office'a do wymaganej wersji) przy użyciu Menedżera pakietów Asix (Architekt > menu Narzędzia).

UWAGA:

Dodatek Asix Architekt Plugin podpisany jest cyfrowo certyfikatem firmy Askom. Przy niektórych konfiguracjach komputerów, które nie posiadają dostępu do Internetu a tym samym do serwera weryfikacji certyfikatów, system Windows długo próbuje zweryfikować certyfikat programu - przez co znacznie wydłuża start programu MS Excel. W takim przypadku rozwiązaniem problemu jest utworzenie dla programu MS Excel pliku konfiguracyjnego o nazwie "Excel.exe.config" i umieszczenie go w katalogu instalacyjnym pakietu Microsoft Office, w którym znajduje się plik wykonywalny Excel.exe.

Gotowy plik Excel.exe.config można pobrać z witryny internetowej firmy Askom:

http://www.asix.com.pl/pl/do_pobrania/software/

W przypadku systemu operacyjnego Windows Vista lub nowszego, aby wgrać plik do katalogu zawierającego program Excel.exe, konieczne jest posiadanie praw administratora.

Rys. Arkusz kalkulacyjny MS Excel - widok zakładki zainstalowanego dodatku Asix Architekt Plugin - edytor kanału.

Rys. Arkusz kalkulacyjny MS Excel - widok zakładki zainstalowanego dodatku Asix Architekt Plugin - edytor adresu.


2.7 Przechowywanie opisow stanow zmiennych w bazie definicji

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.7 Przechowywanie opisów stanów zmiennych w bazie definicji

2.7 Przechowywanie opisów stanów zmiennych w bazie definicji zmiennych

W programie AsTrend5 istnieje możliwość wyświetlania opisów stanów jako etykiet osi wartości dla wykresów fizycznych.

Mechanizm wyświetlania wartości stanów wymaga zadeklarowania zmiennych, które będą odpowiadać stanom zmiennych monitorowanych. W tym celu należy w pierwszej kolejności odpowiednio przygotować bazę definicji zmiennych - tak aby znalazły się w niej atrybuty obsługujące definicje stanów. Są to następujące atrybuty:

Nazwy stanów - nazwa zbioru stanów lub bezpośrednio zbiór opisów stanów zmiennej wg formatu:

<wartość_stanu_0>=<opis_stanu_0>;<wartość_stanu_1>=<opis_stanu_1>;..itd.

Zestaw stanów - nazwa zbioru stanów, do którego należy bieżący wiersz; atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów;

Wartość stanu - wartość wyrażona w systemie dziesiętnym dla stanu, którego opis zawiera bieżący wiersz; atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów zmiennej.

Należy zdefiniować tyle zmiennych, ile jest stanów danej zmiennej monitorowanej. Każda taka zmienna musi mieć zadeklarowany tekst, który będzie wyświetlany dla danego stanu, wartość stanu oraz nazwę zestawu stanów. Zmienne te powinny mieć włączony atrybut Zmienna nieaktywna.

Wszystkie zmienne z tekstami stanów należy powiązać ze zmienną monitorowaną za pomocą wspólnej nazwy zestawu stanów - którą dla zmiennej monitorowanej należy zadeklarować jako wartość atrybutu Nazwy stanów, a dla zmiennych z tekstami stanów jako wartość atrybutu Zestaw stanów. Teksty, które mają być wyświetlane na osi wartości wykresu należy zapisać jako wartości atrybutu Opis dla poszczególnych zmiennych odpowiadających wartościom stanów zmiennej monitorowanej.

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów.

Dodatkowo opis stanów dla zmiennych monitorowanych wyświetlany jest na etykietach i w polu pojawiającym się po kliknięciu wybranego punktu linii wykresu.

uwaga Przy dodawaniu zmiennych z bazy definicji zmiennych aplikacji Asixa oraz przy dodawaniu zmiennych zewnętrznych sprawdzane jest, czy zmienna ma zdefiniowane opisy stanów - jeśli tak, załączana jest aproksymacja schodkowa dla danej zmiennej.


2.8. Przechowywanie opisów stanów bitów oraz opisów bitów w bazie definicji zmiennych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.8. Przechowywanie opisów stanów bitów oraz opisów bitów w bazie definicji zmiennych

2.8 Przechowywanie opisów stanów bitów w bazie definicji zmiennych

I PRZYPADEK - OPISY STANÓW BITÓW POCHODZĄ Z JEDNEJ ZMIENNEJ

Mechanizm wyświetlania wartości stanów bitów wymaga zadeklarowania zmiennych, które będą odpowiadać poszczególnym bitom zmiennej monitorowanej. W tym celu należy w pierwszej kolejności odpowiednio przygotować bazę definicji zmiennych - tak aby znalazły się w niej atrybuty obsługujące definicje stanów bitów. Są to następujące atrybuty:

Nazwy stanów - nazwa zbioru stanów (dla wiersza definicji zmiennej, której bity będą wyświetlane) lub opisy stanów bitów zmiennej (dla wierszy poszczególnych bitów);

Zestaw stanów - nazwa zbioru bitów, do którego należy bieżący wiersz; atrybut używany tylko dla wierszy poszczególnych bitów;

Wartość stanu - numer bitu, którego opis zawiera bieżący wiersz; atrybut używany tylko dla wierszy poszczególnych bitów.

Należy zdefiniować tyle zmiennych, ile jest bitów danej zmiennej monitorowanej. Każda taka zmienna musi mieć zadeklarowany tekst, który będzie wyświetlany dla danego stanu, wartość stanu oraz nazwę zestawu stanów. Zmienne te powinny mieć włączony atrybut Zmienna nieaktywna.

Wszystkie bity z tekstami stanów należy powiązać ze zmienną monitorowaną za pomocą wspólnej nazwy zestawu stanów - którą to nazwę dla zmiennej monitorowanej należy zadeklarować jako wartość atrybutu Nazwy stanów, a dla zmiennych z tekstami stanów bitów jako wartość atrybutu Zestaw stanów. Teksty, które mają być wyświetlane na osi wartości wykresu należy zapisać jako wartości atrybutu Nazwy stanów dla zmiennych odpowiadających poszczególnym bitom zmiennej monitorowanej, wg. formatu:

0=<opis stanu>;1=<opis stanu>

Natomiast atrybut Wartość stanu określa numer bitu zmiennej monitorowanej.

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów bitów.

II PRZYPADEK - OPISY STANÓW BITÓW POCHODZĄ Z RÓŻNYCH ZMIENNYCH DWUSTANOWYCH

Mechanizm wyświetlania wartości stanów bitów zmiennych dwustanowych nie wymaga deklarowania dodatkowych zmiennych. Atrybutem obsługującym definicje stanów bitów jest w tym przypadku atrybut:

Nazwy stanów - zawierający opisy stanów zmiennej wg. formatu:

0=<opis stanu>;1=<opis stanu>

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów bitów zmiennych dwustanowych.


2.9. Konwertowanie bazy definicji zmiennych z formatu Paradox na

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.9. Konwertowanie bazy definicji zmiennych z formatu Paradox na

2.9 Konwertowanie bazy definicji zmiennych z formatu Paradox na format Jet lub MS SQL

Architekt stwarza możliwość przekonwertowania wszystkich danych z bazy definicji zmiennych BDE utworzonej w starszej wersji pakietu Asix (baza w formacie Paradox) do bazy Jet lub SQL.

Dla starszych wersji systemu Asix baza definicji zmiennych w formacie Paradox składa się z:

- bazy atrybutów zmiennych - fizycznie pliki bazy Paradox;

- schematu bazy definicji zmiennych - plik *.TXT opisujący wszystkie atrybuty jakie może posiadać zmienna;

- zestawu zmiennych - plik tekstowy *.ZEZ zawierający definicję ułożenia grup zmiennych (jedna baza definicji zmiennych może zawierać dowolną ilość zestawów zmiennych).

Zasadniczo wskazane było przy tego typu bazach przygotowywanie definicji zmiennych w arkuszu kalkulacyjnym Excel, w oparciu o który następnie generowana była baza definicji zmiennych przy użyciu programu Menedżer Bazy Zmiennych. W przypadku mniejszych aplikacji - bazy definicji zmiennych bezpośrednio tworzone były i edytowane za pomocą programu Edytor Bazy Zmiennych.

Jak przekonwertować bazę definicji zmiennych formatu Paradox utworzoną w starszych wersjach asixa na bazę Jet lub MS SQL?:

I przypadek, kiedy baza definicji zmiennych tworzona była bezpośrednio za pomocą Edytora Bazy Zmiennych (z pominięciem pliku *.XLS)

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia Nazwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki ZEZ/DB (przycisk zez)

4. W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

Rysunek: Okno wyboru tabel do konwersji bazy na format Jet lub MS SQL.

5. Wybierz polecenie Generuj generuj.

6. Otwórz bazę i w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; zmodyfikuj w miarę potrzeby schemat bazy definicji zmiennych za pomocą Edytora schematu (dostępny po otwarciu bazy).

uwaga Edycja zawartości bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor.

II przypadek, kiedy baza definicji zmiennych generowana była za pomocą Menedżera Bazy Zmiennych w oparciu o definicje zmiennych przygotowane w arkuszu kalkulacyjnym Excel

Założenie: po konwersji bazy definicje zmiennych i schemat bazy będą mogły być aktualizowane z arkuszy Excel zgodnych z obowiązującym dla Asix 5-6 szablonem.

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki ZEZ/DB (przycisk zez)

4. W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

5. Wybierz polecenie Generuj generuj, a następnie otwórz bazę i sprawdź, czy baza została prawidłowo wygenerowana; w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; wprowadź również zmiany (jeśli istnieje taka potrzeba) do schematu bazy definicji zmiennych za pomocą Edytora schematu (dostępny po otwarciu bazy).

uwaga Edycja bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor (baza musi być zamknięta w trakcie zmiany trybów)

7. Zamknij bazę i przejdź na tryb edytora:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor

8. Ponownie otwórz wygenerowaną bazę definicji zmiennych i wyeksportuj ją do arkusza Excel za pomocą komendy Eksportuj eksportuj. W oknie ’Eksport bazy do Arkusza Excel’ wybierz wszystkie dostępne rodzaje danych do eksportu i zmień nazwę pliku wyjściowego na Schemat.xls (nazwa dowolna); zatwierdź zmiany przyciskiem OK.

Rysunek: Okno ’Eksport bazy do arkusza Excel’.

9. Zamknij bazę.

10. Otwórz skoroszyt Schemat.xls;

W arkuszu AtrybutyGrupujące znajdują się atrybuty grupujące, które należy ’ręcznie’ dodać do definicji zmiennych przechowywanych w skoroszycie Excel służącym do tej pory jako źródło generowania i aktualizowania bazy definicji zmiennych formatu Paradox.

W starszych wersjach Asixa w bazie definicji zmiennych istniała możliwość zadeklarowania dla każdej zmiennej wyłącznie jednego atrybutu grupującego o ustalonej nazwie Grupa. Możliwe było jednak ułożenie grup zadeklarowanych w atrybucie Grupa w strukturę hierarchiczną typu drzewo wyświetlaną w oknie wyboru zmiennych - co pozwalało ’widzieć’ daną zmienną jako element przynależny do określonej grupy lub podgrupy. Patrz: Rysunek: Okno listy zmiennych w pakiecie Asix4.

Rysunek: Okno listy zmiennych w pakiecie Asix4.

Definicję ułożenia grup zmiennych zawierał plik *.ZEZ.

Aktualnie w trakcie konwersji bazy definicji zmiennych Paradox na format Jet lub MS SQL generowanych jest tyle atrybutów grupujących, ile wynika to ze struktury hierarchicznej zdefiniowanej w pliku *.ZEZ. Patrz: Rysunek: Edytor definicji zmiennych - okno grupowania zmiennych.

Rysunek: Edytor definicji zmiennych - okno grupowania zmiennych.

11. Otwórz skoroszyt, który do tej pory stanowił plik źródłowy do generowania/aktualizowania bazy definicji zmiennych Paradox i do wszystkich arkuszy z definicjami zmiennych dodaj kolumny atrybutów grupujących wygenerowanych w skoroszycie Schemat.xls

Dla każdej definicji zmiennych dodaj wartości atrybutów grupujących kopiując je z arkusza Zmienne pliku Schemat.xls, pamiętając o usunięciu starego atrybutu Grupa.

Tak zmodyfikowane arkusze z definicjami zmiennych mogą służyć jako źródło generowania/aktualizowania bazy definicji zmiennych Jet lub MS SQL.

13. Usuń ze skoroszytu Schemat.xls arkusz Zmienne.

Pozostałe zakładki zawierają przetłumaczone na język narodowy nazwy atrybutów zmiennych, deklaracje atrybutów zastępczych (dla aplikacji wielojęzycznych), definicje zestawów atrybutów, atrybutów grupujących - czyli wszystkie te informacje, które do tej pory w większości przechowywane były w pliku tekstowym Schemat.txt.

Plik Schemat.xls może odtąd stanowić źródło aktualizacji danych dostępnych w Architekcie z poziomu Edytora schematu modułu Baza definicji zmiennych.

14. Przejdź na tryb generatora:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Generator

15. Na zakładce Źródła danych zaznacz i usuń wszystkie źródła danych.

16. Naciśnij przycisk Excel i wskaż plik *.xls zawierający definicje zmiennych.

17. W oknie ’Wybierz tabele’ zaznacz wszystkie arkusze z definicjami zmiennych i zatwierdź wybór przyciskiem OK.

18. Na zakładce Źródła danych ponownie naciśnij przycisk Excel i wskaż plik *.xls z danymi schematu bazy definicji zmiennych, czyli plik Schemat.xls.

19. W oknie ’Wybierz tabele’ zaznacz wszystkie arkusze i zatwierdź wybór przyciskiem OK.

20. Wybierz polecenie Generuj generuj, a następnie otwórz bazę i sprawdź, czy baza została prawidłowo wygenerowana; wszelkie dane do aktualizacji bazy mogą być wprowadzane do plików *.xls, które przygotowane zostały w poprzednich krokach - każdorazowa zmiana w tych plikach wymaga ponownego wygenerowania bazy.


2.10. Konwertowanie bazy definicji zmiennych z plikow tekstowych

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.10. Konwertowanie bazy definicji zmiennych z plików tekstowych

2.10 Konwertowanie bazy definicji zmiennych z plików tekstowych na format Jet lub SQL

Dla zachowania kompatybilności ze starszymi wersjami systemu Asix, Architekt pozwala również zaimportować dane definicji zmiennych znajdujące się w plikach tekstowych.

Jak przekonwertować bazę definicji zmiennych z plików tekstowych na bazę Jet lub MS SQL?:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator.

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki tekstowe definicji zmiennych (przycisk Asix - plik ini...)

4. W oknie 'Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

5. Wybierz polecenie Generuj generuj.

6. Otwórz bazę i w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; zmodyfikuj w miarę potrzeby schemat bazy definicji zmiennych za pomocą Edytora schematu.

uwaga Edycja bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor.


2.10.1. Import definicji zmiennych z plikow tekstowych - atrybuty grupujace

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.10. Konwertowanie bazy definicji zmiennych z plików tekstowych > 2.10.1. Import definicji zmiennych z plików tekstowych - atrybuty grupujące

2.10.1. Import definicji zmiennych z plików tekstowych - atrybuty grupujące

Wartość pierwszego atrybutu grupującego zmiennej, jest domyślnie taka sama jak nazwa pliku zmiennych bieżących, w którym zdefiniowana jest zmienna (nazwa pliku bez rozszerzenia i bez ścieżki). Aby jawnie określić wartości atrybutów grupujących zmiennej, należy umieścić w pliku definicji zmiennych bieżących, w postaci komentarza, linie deklarujące wartości atrybutów grupujących. Linia deklarująca wartości atrybutów grupujących jest linią o następującym formacie:

#Atrybuty : Atrybut1 = Wartość1 [,Atrybut2 = Wartość2...]

lub

#Attributes : Atrybut1 = Wartość1 [,Atrybut2 = Wartość2...]

Deklaracja rozpoczyna się od miejsca deklaracji i rozciąga się do następnej deklaracji lub do końca pliku.


2.11 Export bazy do arkusza Excel

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.11 Export bazy do arkusza Excel

2.11 Eksport bazy do arkusza Excel

Program Architekt umożliwia zapisanie wszystkich danych lub wybranych danych z bazy definicji zmiennych w arkuszu Excel. Dane są zapisane w jednym lub kilku arkuszach. Można ograniczać maksymalną liczbę wierszy w jednym arkuszu tak, aby istniała możliwość eksportowania również dużych baz definicji zmiennych. Dodatkowo w skoroszycie umieszczany jest arkusz z listą modyfikacji definicji zmiennych od chwili utworzenia bazy. Lista ta zawiera zmienne utworzone, usunięte i zmodyfikowane. Maksymalna liczba eksportowanych wierszy to 32000.

Jak wyeksportować definicje zmiennych do arkusza Excel:

1. Otwórz bazę definicji zmiennych MSQL (lub Jet), podając jej lokalizację w:

Baza definicji zmiennych > zakładka Format

oraz klikając na komendę Otwórz otwórz z kategorii poleceń Baza definicji zmiennych.

2. Wybierz komendę Eksportuj eksportuj.

3. W oknie ’Eksport bazy do arkusza Excel’ zaznacz dane, które mają być wyeksportowane oraz ścieżkę i nazwę docelowego pliku XLS (Patrz: Rysunek: Okno 'Eksport bazy do arkusza Excel'.).

Rysunek: Okno 'Eksport bazy do arkusza Excel'.


2.12 Dostep z poziomu innych programow

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.12 Dostęp z poziomu innych programów

2.12 Dostęp z poziomu innych programów

Baza definicji zmiennych jest bazą zarządzaną przez Microsoft SQL Server lub bazą Jet i dostęp do niej jest możliwy z każdego programu, który obsługuje ten system.

W dostępie do danych przechowywanych w bazie definicji zmiennych VarDef pośredniczy moduł AsixConnect za pomocą mechanizmu DDE, Automation lub .NET.


2.13. Uaktualnianie bazy zmiennych on-line

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.13. Uaktualnianie bazy zmiennych on-line

2.13 Uaktualnianie bazy definicji zmiennych on-line

W przypadku, gdy niemożliwe jest zatrzymanie aplikacji i jej restart w celu zmodyfikowania bazy definicji zmiennych, możliwe jest przeprowadzenie aktualizacji bazy w trybie on-line. Operacja taka jest możliwa jedynie, gdy zadeklarowany typ bazy definicji zmiennych to Standardowa baza definicji zmiennych, tryb “Edytor”.

Zakładając, że używając edytora bazy zmiennych dokonano jej modyfikacji (zmieniono definicje zmiennych, dodano nowe zmienne itp.), należy użyć przycisku z niebieskim trójkątem - [image] Aktualizuj on-line.

Rysunek: Okno dialogowe akceptacji operacji pobrania przez Asix ostatnich modyfikacji z bazy definicji zmiennych.

Po potwierdzeniu chęci aktualizacji bazy on-line system Asix przeprowadzi ją, a w Panelu Kontrolnym pojawi się odpowiedni komunikat, podający liczbę zmodyfikowanych rekordów bazy oraz nazwy zmiennych:

Rysunek: Panel Kontrolny z informacja o odczycie przez asixa aktualizacji z bazy definicji zmiennych.

UWAGA: W sytuacji, gdy definicje zmiennych przechowywane są w arkuszach kalkulacyjnych (w nich wprowadzane były aktualizacje tych definicji), na podstawie których generowana jest baza definicji zmiennych – przejście na tryb aktualizacji bazy za pomocą edytora bazy definicji zmiennych spowoduje, że źródłowe arkusze kalkulacyjne nie będą uwzględniały zmian wprowadzonych za pomocą edytora.


3. Baza definicji alarmów - konfiguracja

Home > Architekt - Parametryzacja aplikacji > 3. Baza definicji alarmów - konfiguracja

3. Baza definicji alarmów

Definicje alarmów standardowo znajdują się w pliku tekstowym alarm.def (lub <nazwa_pliku_XML_aplikacji>.adf). Możliwe jest użycie pliku o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów przy założeniu, że tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów). Opisy alarmów mogą się też znajdować w kilku plikach definicji. Wewnętrznie alarmy identyfikowane są przez numer. Można zdefiniować 65535 różnych alarmów. Nie istnieje konieczność sekwencyjnego numerowania alarmów. Na przykład, numeracja jednej grupy alarmów rozpoczyna się od numeru 1000, a drugiej (o innym pochodzeniu) od numeru 30000. Należy pamiętać o tym, że zmiana numeracji alarmów w już działającym systemie powoduje konieczność skasowania plików archiwalnych.

Definicje grup alarmów standardowo znajdują się w pliku tekstowym group.def (lub <nazwa_pliku_XML_aplikacji>.gdf). Możliwe jest użycie pliku (plików) o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów - grupy przy założeniu, ze tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów).

Patrz więcej:

część Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji, rozdz. 12. System alarmów;

część Architekt - Parametryzacja aplikacji, rozdz. 4.9. Konfiguracja systemu alarmów.


Zbiorcza baza definicji alarmów generowana z wielu aplikacji

Home > Architekt - Parametryzacja aplikacji > 3. Baza definicji alarmów - konfiguracja > 3.1 Zbiorcza baza definicji alarmów generowana z wielu aplikacji

3.1 Zbiorcza baza definicji alarmów generowana z wielu aplikacji

Generator zbiorczej bazy definicji alarmów i grup alarmów utworzy zbiorcza bazę definicji alarmów na podstawie źródeł zdefiniowanych we wskazanych aplikacjach. Wygenerowana baza zostanie dołączona do bazy definicji zmiennych aktualnie parametryzowanej aplikacji.

Aby wygenerować zbiorczą bazę definicji alarmów z wielu aplikacji:

1. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Zbiorcza baza definicji alarmów jest generowana z baz definicji alarmów innych aplikacji

2. Dodaj źródła danych:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: pliki INI lub XML

3. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów z wielu aplikacji do istniejącej bazy definicji zmiennych parametryzowanej aplikacji):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rys. Rysunek: Architekt - generator zbiorczej bazy definicji alarmów i grup alarmów.


Baza definicji alarmów generowana z arkuszy kalkulacyjnych

Home > Architekt - Parametryzacja aplikacji > 3. Baza definicji alarmów - konfiguracja > 3.2 Baza definicji alarmów generowana z arkuszy kalkulacyjnych

3.2. Baza definicji alarmów generowana z arkuszy kalkulacyjnych

Aby dołączyć definicje alarmów i definicje grup alarmów z arkusza kalkulacyjnego do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w arkuszu Excel

UWAGA: Przyłączenie definicji alarmów do bazy definicji zmiennych wymaga utworzenia arkusza programu Excel z definicjami alarmów oraz drugiego arkusza z definicjami grup alarmów wg określonego szablonu. Szablon taki można wygenerować z Architekta: Bazy danych > Baza definicji alarmów > zakładka Szablon - dostępna przy zaznaczonym typie pracy bazy definicji alarmów, który zakłada generowanie bazy definicji alarmów z arkuszy kalkulacyjnych.

W przypadku posiadania definicji alarmów w plikach tekstowych - można albo wygenerować bazę definicji alarmów bezpośrednio na podstawie tekstowych plików definicji alarmów i grup alarmów (patrz: rozdział 3.3. Baza definicji alarmów generowana z plików tekstowych albo dokonać ich konwersji do arkusza Excel wg poniższych kroków:

- uruchomić program Microsoft Excel,

- wybrać menu Dane->Z tekstu,

- zmienić ‘pliki typu’ na ‘wszystkie pliki’, następnie otworzyć plik definicji (.adf lub .gdf),

- wybrać typ pliku ‘rozdzielny’, pochodzenie pliku: 1250 Europa środkowa (Windows), przejść dalej,

- z listy ograniczników wybrać przecinek i wybrać polecenie Zakończ.

2. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Baza definicji alarmów jest generowana z arkuszy kalkulacyjnych zawierających definicje alarmów

Rysunek: Architekt - deklaracja trybu pracy generatora bazy definicji alarmów.

3. Dodaj arkusze Excel z definicjami alarmów i definicjami grup alarmów do źródeł danych bazy definicji alarmów:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: Excel

4. Zadeklaruj, że baza definicji alarmów ma zostać dołączona do istniejącej bazy definicji zmiennych

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja: Dodaj bazę definicji alarmów do bazy definicji zmiennych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.

UWAGA: Każda aktualizacja bazy definicji zmiennych (jej ponowna generacja) wymaga ponownego dogenerowania definicji alarmów i grup alarmów do bazy definicji zmiennych przy użyciu polecenia:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj


Baza definicji alarmów generowana z plików tekstowych (dla aplikacji Asixa klasycznego)

Home > Architekt - Parametryzacja aplikacji > 3. Baza definicji alarmów - konfiguracja > 3.3 Baza definicji alarmów generowana z plików tekstowych

3.3. Baza definicji alarmów generowana z plików tekstowych

Dla aplikacji Asixa klasycznego definicje alarmów standardowo przechowywane są w plikach tekstowych .adf (lub alarm.def), a definicje grup alarmów w plikach tekstowych .gdf (lub group.def).

Aby dołączyć definicje alarmów i definicje grup alarmów z plików tekstowych do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w plikach tekstowych.

Informacje na temat tego, jak należy utworzyć takie pliki można znaleźć w części Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji, 12. System alarmów.

2. Zadeklaruj nazwy plików, o których mowa w punkcie 1 w module:

Architekt > Obszary i komputery > System alarmów > Alarmy > zakładki Baza definicji alarmów oraz Baza definicji alarmów - grupy

3. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów

Rysunek: Architekt - deklaracja trybu pracy bazy definicji alarmów.

3. Wybierz obszar/komputer, dla którego zostały zadeklarowane pliki tekstowe, o czym mowa w punkcie 2. Spowoduje to automatyczne załadowanie plików definicji alarmów i grup alarmów do okna generatora:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Obszar/komputer

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.


Baza definicji alarmów generowana na podstawie alarmów SQL

Home > Architekt - Parametryzacja aplikacji > 3. Baza definicji alarmów - konfiguracja > 3.4 Baza definicji alarmów generowana na podstawie alarmów SQL

3.4. Baza definicji alarmów generowana na podstawie alarmów SQL

Generowanie bazy definicji alarmów na podstawie alarmów SQL dotyczy przypadku, kiedy informacje o wszystkich zdarzeniach alarmowych przechowywane są nie tylko w logach alarmów historycznych, ale również jako uzupełnienie w archiwum alarmów typu SQL. Generator bazy definicji alarmów SQL w programie Architekt na podstawie archiwum zdarzeń przechowywanych w bazie SQL generuje bazę definicji alarmów dołączaną do bazy definicji zmiennych załadowanej w Architekcie aplikacji.

Sposób konfigurowania rejestracji zdarzeń alarmowych w bazie SQL dla aplikacji klasycznej omawia rozdział 4.9.11. Baza zdarzeń alarmów.

Aby dołączyć definicje alarmów SQL do bazy definicji zmiennych:

1. Określ źródło definicji alarmów: (może to być plik xml aplikacji Asixa, pliki ini aplikacji starszych wersji Asixa lub bieżąca aplikacja):

Architekt > Bazy danych > Baza definicji alarmów SQL > zakładka Źródła danych > opcja: Dodaj źródło danych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rys. Architekt - Generator bazy definicji alarmów SQL.


4.1 Wstep

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.1 Wstęp

4.1 Wstęp

Gotowa aplikacja systemu Asix składa się z zestawu powiązanych ze sobą masek technologicznych, zawierających obiekty statyczne i dynamiczne. Tworzą one spójną całość za pośrednictwem akcji sterujących ich wyświetlaniem. Podstawą działania całego sytemu masek jest plik konfiguracyjny XML, tworzony za pomocą programu Architekt. System masek projektowany jest za pomocą programu AS w trybie Konstruktora. Z kolei gotowa aplikacja realizowana jest przez główny moduł systemu Asix - program AS, pracujący w trybie wykonywania aplikacji.

Rysunek: Widok masek technologicznych aplikacji demonstracyjnego systemu Asix – Fabryka.

Konfiguracja aplikacji systemu Asix przy użyciu programu Architekt obejmuje:

- konfigurację bazy definicji zmiennych (szczegółowo omówiono to zagadnienie w rozdziale 2. Obsługa baz definicji zmiennych aplikacji systemu Asix);

- konfigurację pracy aplikacji.

Uproszczony proces projektowania i realizacji aplikacji w systemie Asix prezentuje poniższy schemat [6].

Rysunek: Schemat procesu projektowania i realizacji aplikacji w systemie Asix.

W trakcie parametryzacji aplikacji Architekt prowadzi na bieżąco kontrolę wzajemnej niesprzeczności zadeklarowanych opcji, co przekłada się na duży wzrost wydajności pracy.

Konfiguracja pracy aplikacji przeprowadzana jest przy użyciu modułów parametrów wyświetlanych podłużnym przyciskiem Obszary i komputery (przycisk znajduje się w lewym bloku okna Architekt).

Rysunek: Okno modułu konfigurowania parametrów aplikacji.

Moduł Architekt pozwala w sposób całkowicie wizualny i interaktywny skonfigurować pracę całej aplikacji systemu Asix. Sprowadza się to do zdefiniowania parametrów potrzebnych do pracy różnych podsystemów programu AS odpowiadających za realizację projektowanej aplikacji.

Wspomniane parametry podzielone zostały w Architekcie na następujące grupy (drzewo parametrów wywoływane jest przyciskiem Aplikacja, znajdującym się w lewym bloku okna Architekt):

- Parametry startowe,

- Maski,

- Dane bieżące,

- Dane bieżące – serwer sieci,

- Dane archiwalne,

- System alarmów,

- Moduł sieci,

- Zabezpieczenia,

- Wydruk,

- Raporty,

- Akcje i terminarze,

- Pozostałe.

Ustawienia parametrów pracy aplikacji zapisywane są w pliku konfiguracyjnym XML, w którym umieszczane są również dane dotyczące bazy definicji zmiennych i bazy definicji alarmów aplikacji.

Szczegóły dotyczące funkcjonalności pakietu Asix (w tym opis poszczególnych etapów projektowania aplikacji z wykorzystaniem pakietu Asix) zawarte są w części Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji.

Proces projektowania aplikacji, która dołączona została do pakietu Asix jako aplikacja demo - Fabryka, szczegółowo omawia odrębny podręcznik ”Pierwsza aplikacja - krok po kroku”.

Niektóre praktyczne przykłady omawiane w podręczniku Architekt odwołują się do wspomnianej powyżej demonstracyjnej aplikacji.

[6] W trakcie realizacji rzeczywistego projektu zwykle nie udaje się ściśle zachować przedstawionej sekwencji operacji. W miarę rozbudowywania aplikacji wielokrotnie trzeba bowiem wracać do wcześniejszych punktów. Schemat daje jednak pewien pogląd na całokształt procesu tworzenia aplikacji.


4.1.1 Wskazowki dotyczace obslugi opcji domyslnych w modulach

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.1 Wstęp > 4.1.1 Wskazówki dotyczące obsługi opcji domyślnych w modułach

4.1.1 Wskazówki dotyczące obsługi opcji domyślnych w modułach konfiguracyjnych

Każda opcja parametryzująca pracę aplikacji posiada zewnętrzny checkbox, znajdujący się z lewej strony opcji, który w odróżnieniu od pól deklarujących wartości parametrów, służy wyłącznie do załączania lub wyłączania ustalonych wartości parametrów.

Parametry posiadające zadeklarowaną wartość domyślną, np. czas, nazwę pliku lub w przypadku parametrów o wartości logicznych zaznaczone pole checkbox, należy uaktywnić załączając je zewnętrznym checkboxem.

Rysunek: Widok załączonej opcji domyślnej.

W trakcie parametryzowania aplikacji należy pamiętać o poniższych zasadach:

- opcje wyłączone są nieedytowalne; dopiero zaznaczenie zewnętrznego pola checkbox pozwala na zmianę wartości parametru;

- w momencie wyłączenia opcji dla Obszaru automatycznie przywracana jest domyślna wartość parametru;

- w momencie kiedy opcja dla Komputera zostanie wyłączona, parametr automatycznie przyjmuje wartość zadeklarowaną dla Obszaru lub (w przypadku braku takiej deklaracji w Obszarze) przywracana jest domyślna wartość parametru.


4.1.2 Zarzadzanie opcjami za pomoca okna z zestawieniem

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.1 Wstęp > 4.1.2 Zarządzanie opcjami za pomocą okna z zestawieniem wszystkich zadeklarowanych opcji

4.1.2 Zarządzanie opcjami za pomocą okna z zestawieniem wszystkich zadeklarowanych opcji

Wykorzystując okno ’Zarządzanie opcjami’ projektant może w prosty sposób uzyskać dostęp do wszystkich parametrów, jakie zostały ustawione w pliku konfiguracyjnym aplikacji w ramach konfigurowania poszczególnych ’obszarów’ i ’komputerów’.

Wspomniane okno daje wgląd do wartości zdefiniowanych opcji z jednoczesną możliwością wykonania prostych operacji edycyjnych na wybranych opcjach - dostępne są operacje usuwania i kopiowania opcji z/do wybranych obszarów/komputerów (w tym również techniką drag-and-drop).

Dalsza edycja zaznaczonej opcji możliwa jest po naciśnięciu przycisku Przejdź do edytora opcji. Okno zarządzania opcjami zostaje wtedy zamknięte, a Architekt otwiera tę zakładkę modułu konfigurowania parametrów, która umożliwia zmianę wybranej opcji.

Wszystkie opcje wykorzystane do parametryzowania aplikacji wyświetlane są w oknie ’Zarządzanie opcjami’ w postaci zestawienia tabelarycznego w jednym z trzech możliwych do wyboru widoków: Tabela, Drzewo i Drzewo opcji. Okno uruchamiane jest za pomocą komendy Zarządzaj opcjami… z menu Obszary i komputery.

Rysunek: Okno 'Zarządzanie opcjami'.


4.1.3 Importowanie wybranych opcji z zewnetrznego pliku *.xml

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.1 Wstęp > 4.1.3 Importowanie wybranych opcji z zewnętrznego pliku *.xml

4.1.3 Importowanie wybranych opcji z zewnętrznego pliku *.xml

Przygotowując aplikację, projektant ma możliwość importowania ustawień wybranych parametrów z plików *.xml innych aplikacji. Komenda Importuj opcje… z menu Obszary i komputery uruchamia okno wyboru pliku XML innej aplikacji, a następnie okno ’Importowanie opcji’, które wyglądem przypomina narzędzie zarządzania opcjami pliku konfiguracyjnego projektowanej aplikacji, z tą różnicą, że oglądane parametry pochodzą z pliku *.xml innej aplikacji. Aby zaimportować do swojej aplikacji wartość dowolnego parametru, należy ten parametr zaznaczyć, przycisnąć przycisk Importuj, a następnie wskazać docelowy obszar/komputer.

Rysunek: Okno 'Importowanie opcji'.


4.2 Utworzenie pliku konfiguracyjnego nowej aplikacji

Utworzenie pliku konfiguracyjnego XML aplikacji stanowi pierwszy krok poprzedzający etap konfigurowania bazy definicji zmiennych oraz konfigurowania aplikacji.

uwaga Parametry konfigurujące pracę aplikacji oraz deklarujące bazę danych, w oparciu o którą aplikacja pracuje zapisywane są do jednego wspólnego pliku XML (ang. Extensible Markup Language), umieszczanego w kartotece głównej projektowanej aplikacji.

Tworzenie pliku konfiguracyjnego:

Wariant 1 - bez kreatora

  1. Z menu głównego z pozycji Plik wybierz komendę Nowa aplikacja [image].

  2. W lewym bloku okna Architekta kliknij na przycisk Obszary i komputery.

  3. Na liście komputerów wprowadź następujące zmiany:

    - dodaj tyle pozycji komputerów i obszarów, ile wynika z projektu aplikacji - pamiętając, że obszar wspólny zawiera parametry, które w wielostanowiskowej konfiguracji systemu Asix są wspólne dla wszystkich stanowisk, na których uruchamiana jest aplikacja; natomiast konfiguracja na poziomie Komputera pozwala zindywidualizować ustawienia w zależności od typu komputera (inne dla stacji operatorskiej, a inne dla dedykowanego serwera danych w sieci zakładowej). Ustawienia na poziomie Komputera są ważniejsze od ustawień na poziomie Obszaru.

    - zmień nazwy komputerów i obszarów na takie, które odpowiadają specyfice środowiska, w którym aplikacja będzie pracowała

  4. Zapisz plik w katalogu projektowanej aplikacji.

Wariant 2 - użycie kreatora

1. Z menu głównego z pozycji Plik wybierz komendę Nowa aplikacja - kreator nowa aplikacja - kreator.

2. W oknie kreatora nowej aplikacji - zakładce Aplikacja określ następujące dane:

- Nazwa pliku aplikacji,

- Katalog aplikacji;

oraz katalogi, których ścieżki są ścieżkami względnymi w odniesieniu do katalogu aplikacji:

- Katalog masek (z możliwością dodania do aplikacji podstawowych masek),

- Katalog archiwum danych,

- Katalog archiwum alarmów,

- Katalog raportów,

- Katalog trendów,

- Katalog roboczy;

Ponadto dostępne są dwa szablony aplikacji zawierające elementy graficzne pozwalające na zaprojektowanie estetycznych masek wizualizacyjnych oraz opcja dodania do aplikacji zestawu klasycznych czcionek (Arial, Sans Serif, Times New Roman).

- wersja STANDARD aplikacji:

Rys. Szablon aplikacji w wersji STANDARD.

- wersja MODERN aplikacji:

Rys. Szablon aplikacji w wersji MODERN.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Aplikacja'.

3. W oknie kreatora nowej aplikacji - zakładce Komputery i obszary określ następujące dane:

- w bloku Parametryzacja wielu stanowisk należy podać rodzaje komputerów, dla których zostaną utworzone zestawy parametrów:

- Stacja operatorska,

- Stacja KE,

- Terminal,

- Serwer sieciowy.

uwaga Nazwy komputerów tworzonych przez kreator dostosowano do konwencji nazw sieciowych – nie zawierają spacji i mają maksymalnie 15 znaków.

uwaga Określenie w tym miejscu wszystkich rodzajów komputerów, dla których kreator automatycznie utworzy zestawy parametrów aplikacji nie jest wymagane - projektant w każdej chwili może zmodyfikować ilość pozycji komputerów/obszarów wyświetlanych w bloku Obszary i komputery.

Poza tym wybór określonego rodzaju komputera nie ma wpływu na ilość i rodzaj parametrów, które znajdą się w zestawie. Dla każdego Obszaru i Komputera udostępniane są wszystkie możliwe do zadeklarowania parametry.

a także:

- Nazwa pliku komunikatów - plik ten zostanie utworzony w katalogu roboczym.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Komputery i obszary'.

4. W oknie kreatora nowej aplikacji - zakładce Zasoby określ następujące dane:

- w bloku Zasoby podstawowe należy zadeklarować następujące elementy:

- Nazwa kanału zmiennych systemowych,

- Nazwa archiwum danych w sieci,

- Nazwa serwera alarmów w sieci;

- w bloku Kanały fizyczne należy zadeklarować kanały fizyczne, które zostaną utworzone w zadeklarowanych stacjach operatorskich.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Komputery i obszary'.

5. W oknie kreatora nowej aplikacji - zakładce VarDef - typ określ typ bazy definicji zmiennych.

W przypadku zadeklarowania opcji Tryb Generator dopiero po utworzeniu pliku konfiguracyjnego aplikacji będzie można zadeklarować pliki źródłowe z definicjami zmiennych i wygenerować na ich podstawie bazę.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'VarDef - typ'.

uwaga W przypadku wybrania opcji Tryb Generator i formatu bazy - Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 -

przed przystąpieniem do generowania pliku aplikacji za pomocą kreatora, łącznie z generowaniem bazy definicji zmiennych w formacie SQL, na komputerze powinien zostać zainstalowany serwer SQL. Pakiet systemu Asix zawiera MSDE 2000 (Microsoft SQL Server 2000 Desktop Engine), ktory stanowi uproszczoną wersję SQL Server 2000. Dostarczana przez firmę Askom wersja MSDE jest przeznaczona tylko do stosowania z produktami firmy Askom. Sposób instalacji MSDE 2000 został omówiony w opracowaniu: ”MSDE 2000 - instrukcja instalacji. Pomoc techniczna”, do pobrania z witryny ASKOM (www.asix.com.pl) z działu 'wsparcie techniczne' > 'porady/instrukcje'.

6. W oknie kreatora nowej aplikacji - zakładce VarDef - format i położenie określ format oraz nazwę bazy definicji zmiennych.

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'VarDef - format i położenie'.

uwaga Kreator aplikacji tworzy domyślnych użytkowników: Administratora oraz Operatora z uprawnieniami 1 poziomu. Automatycznie tworzony jest również kanał NONE oraz 2 zmienne w bazie definicji zmiennych: __USERNAME__ i __USERLEVEL__. Kreator aplikacji zakłada również katalog plików trendów i ustawia ten katalog jako roboczy dla programu AsTrend.


4.2.1. Kreator nowej aplikacji w trybie importu bazy z serwera OPC

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.2 Utworzenie pliku konfiguracyjnego nowej aplikacji > 4.2.1. Kreator nowej aplikacji w trybie importu bazy z serwera OPC

4.2.1. Kreator nowej aplikacji w trybie importu bazy z serwera OPC / OPC UA

Utworzenie pliku konfiguracyjnego XML aplikacji w trybie importu bazy z serwera OPC zakłada zaimportowanie definicji zmiennych z bazy serwera OPC do formatu bazy systemu Asix. W tym celu należy użyć kreatora aplikacji wywoływanego poleceniem Nowa aplikacja - kreator OPC / Nowa aplikacja - kreator OPC UA z menu Plik.

Okno kreatora obejmuje ustawienia podstawowych parametrów aplikacji takich jak: lokalizacja aplikacji, struktura katalogów, plik logu, struktura komputerów/obszarów, format i położenie bazy definicji zmiennych. Dodatkowe informacje dotyczą źródła danych OPC oraz ustawień związanych z importem zmiennych z serwera OPC.

Zakładki Aplikacja, Komputery i obszary, VarDef - format i położenie zawierają parametry identyczne jak w przypadku standardowego kreatora aplikacji - patrz: 4.2 Utworzenie pliku konfiguracyjnego nowej aplikacji.

Zakładka Źródło danych OPC wymaga podania następujących parametrów:

- Identyfikator serwera OPC w systemie Windows;

- Nazwa zdalnego serwera w systemie Windows;

- Nazwa kanału OPC.

Rysunek: Kreator aplikacji - Źródło danych OPC.

Zakładka Źródło danych OPC UA wymaga podania następujących parametrów:

- Adres serwera OPC UA;

- Nazwa kanału OPC UA.

Rysunek: Kreator aplikacji - Źródło danych OPC UA.

Zakładki VarDef - OPC/VarDef - OPC 2 obejmuje deklarację następujących parametrów:

- Określenie nazw zmiennych importowanych z serwera OPC – nazwy pobierane z Sewera OPC; w przypadku niezgodności ze standardem Asixa nazwy generowane są na podstawie zadeklarowanego prefiksu i kolejnych liczb dodawanych na końcu.

- Liczba Elementów – wartość atrybutu dla zmiennych skalarnych ustawiana na 1. Dla zmiennych tekstowych / tablicowych należy wprowadzić ręcznie długość tekstu/rozmiar tablicy, ponieważ serwer OPC nie udostępnia tych informacji.

- Plik wyjściowy – zostanie wygenerowany skoroszyt o zadeklarowanej nazwie z arkuszem definicji zmiennych pobranych z serwera OPC; plik zostanie automatycznie zadeklarowany w źródle danych zawierającym definicje zmiennych dla aplikacji (Architekt > Bazy danych > Baza definicji zmiennych > Źródła danych).

- Wartości zmiennoprzecinkowe – wartości zmiennoprzecinkowe podwójnej precyzji mogą być archiwizowane z pełną dokładnością tylko w archiwum typu B. Pozostałe archiwa zapisują liczby zmiennoprzecinkowe zawsze z pojedynczą precyzją.

- Parametry archiwizacji – domyślne wartości parametrów archiwizacji zmiennych procesowych.

Rysunek: Kreator aplikacji - VarDef - OPC (zakładka 1).

Rysunek: Kreator aplikacji - VarDef - OPC (zakładka 2).


4.3 Import plikow konfiguracyjnych *.INI

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.3 Import plików konfiguracyjnych *.INI

4.3 Import plików konfiguracyjnych *.INI

Dla aplikacji tworzonych w starszych wersjach pakietu Asix istnieje możliwość przekonwertowania plików aplikacji *.INI na format pliku konfiguracyjnego *.XML.

Służy do tego polecenie:

Plik > Nowa aplikacja - importer importuj, które powoduje uruchomienie okna z parametrami importu:

Rysunek: Okno importu aplikacji opartej na plikach *.INI.

Okno ’Import aplikacji’ pozwala określić:

  • Katalog źródłowy - parametr wskazuje katalog aplikacji systemu Asix sparametryzowanej za pomocą plików *.ini;

  • Pliki aplikacji - pole to wskazuje pliki *.ini importowanej aplikacji;

  • Opcje:

  • Importuj pliki menu (*.pum) - zaznaczenie opcji spowoduje zaimportowanie definicji menu aplikacji do pliku konfiguracyjnego *.XML; dzięki temu możliwa będzie edycja menu z poziomu programu Architekt:

Moduł Maski > zakładka Menu;

  • Importuj pliki akcji złożonych (*.act) - zaznaczenie opcji spowoduje zaimportowanie definicji akcji złożonych do pliku konfiguracyjnego *.XML; składnia akcji złożonych będzie mogła być edytowana w programie Architekt:

Moduł Akcje i terminarze > zakładka Akcje złożone;

  • Importu opcje zakomentowane - zaznaczenie tej opcji spowoduje, że opcje zakomentowane w plikach *.ini zostaną zaimportowane do pliku *. XML; opcje te pozostaną nieaktywne;

uwaga Jeśli plik *.ini zawiera zakomentowane fragmenty dokumentacji nie zaleca się zaznaczenia tej opcji.


4.4 Konfiguracja parametrow startowych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.4 Konfiguracja parametrów startowych

4.4 Konfiguracja parametrów startowych

par startowe Parametry startowe zawierają podstawowe informacje o stanie systemu Asix na etapie uruchamiania aplikacji.


4.4.1 Dane standardowe

Zakładka Standardowe określa:

Rysunek: Okno parametrów startowych - zakładka 'Standardowe'.

  • Identyfikator aplikacji / Nazwa - pozwala nadać aplikacji nazwę identyfikującą daną aplikację w sieci stanowisk. Nadanie nazwy powoduje, że w momencie kończenia pracy sprawdzane jest, czy w sieci znajdują się komputery wykonujące tę samą aplikację. Jeżeli taki komputer nie zostanie znaleziony, to wyświetlane jest okno informujące o tym. Wymagane jest wtedy potwierdzenie komendy zakończenia wykonywania programu.

Wartość domyślna: brak nazwy

  • Obraz początkowy - pole wskazuje na bitmapę, która będzie wyświetlana na ekranie w fazie uruchomienia aplikacji.

Wartość domyślna: brak

  • Akcja - pole wskazuje na akcję operatorską, która ma być wykonana na starcie aplikacji - po otwarciu wszystkich masek zadeklarowanych w parametrze:

moduł Parametry startowe > zakładka Maski > parametr Otwórz

Wartość domyślna - brak akcji startowej

uwaga Wykonanie kilku operacji wymaga użycia akcji złożonej.


4.4.2 Deklaracja programow startowanych jednoczesnie z aplikacja

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.4 Konfiguracja parametrów startowych > 4.4.2 Deklaracja programów startowanych jednocześnie z aplikacją

4.4.2 Deklaracja programów startowanych jednocześnie z aplikacją

Zakładka Programy:

AsTrend:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsTrend'.

  • Startuj AsTrend - pozwala zadeklarować startowanie programu AsTrend równocześnie ze startem aplikacji programu Asix; program AsTrend uruchamia się w postaci zminimalizowanej i oczekuje na zlecenia z programu AS. Istnieje również możliwość podania katalogu roboczego trendów.

Wartość domyślna: brak deklaracji

  • Blokada edycji - pozwala zablokować możliwość zapisywania zmian we wszystkich plikach AsTrend.

Wartość domyślna: brak deklaracji

  • Zawsze pracuj jako Administrator - pozwala nadać operatorowi prawa Administratora programu AsTrend.

Wartość domyślna: brak deklaracji

AsTrend2:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsTrend2'.

  • Alternatywna baza definicji zmiennych dla programu AsTrend - pozwala zadeklarować dla programu AsTrend inną bazę definicji zmiennych niż tą zadeklarowana dla aplikacji.

Wartość domyślna: brak deklaracji

  • Katalog przekonwertowanych trendów v1 - pozycja przeznaczona jest do użytku w sytuacji, gdy w zaimportowanym do formatu xml pliku konfiguracyjnym aplikacji wykorzystywane są definicje trendów zapisane w plikach dat, wywoływane akcją RYSUJ_TREND (tego rodzaju trendy stosowane były w aplikacjach projektowanych w starszych wersjach systemu Asix - do wersji 3).

Aby móc przeglądać trendy, których definicje przechowywane są w plikach dat za pomocą programu AsTrend (bez konieczności ręcznej zamiany na wszystkich maskach aplikacji akcji RYSUJ_TREND na akcje ASTREND), należy w pierwszej kolejności przekonwertować pliki dat z definicjami trendów do formatu plików trnx (-> przycisk Uruchom konwerter) i zadeklarować katalog przekonwertowanych trendów w polu opcji Katalog przekonwertowanych trendów v1. Po konwersji trendów należy też pamiętać o usunięciu pozycji BEZ_TRENDOW, znajdującej się w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio (pozostałość po konwersji pliku konfiguracyjnego aplikacji z formatu ini na xml).

Dzięki powyższym działaniom wywołania trendów za pomocą akcji RYSUJ_TREND przekonwertowane zostaną na wywołania programu AsTrend - czyli akcje ASTREND.

Wartość domyślna: brak deklaracji

  • Ignoruj parametry akcji Trendów v1 - opcja może być użyta w przypadku konwertowania plików trendów pochodzących z Trendów v1 (program stosowany do definiowania trendów w starszych wersjach Asixa). Przy konwersji plików Trendów v1 na trendy aktualnej wersji AsTrend załączenie opcji skutkuje pominięciem parametrów akcji RYSUJ_TREND w trakcie jej konwertowania na akcję ASTREND (chodzi o parametry: początek i koniec trendu oraz drukuj). Początek i koniec konwertowanych trendów można określić podając w oknie konwertera trendów v1 plik trendu wzorcowego ze zdefiniowanym momentem początkowym i końcowym.

AsBase:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsBase'.

  • Startuj AsBase - pozwala zadeklarować startowanie programu AsBase równocześnie ze startem aplikacji programu Asix z dodatkowymi opcjami:

  • Nazwa pliku konfiguracyjnego XML - parametr obligatoryjny; plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

  • Użytkownik, Hasło - parametry opcjonalne; powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

  • Zezwalaj na uruchomienie tylko jednej instancji programu - parametr opcjonalny; w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

  • Uruchom program zminimalizowany - parametr opcjonalny;

  • Wymagaj uprawnień administratora do zakończenia pracy programu AsBase.

Pozycja powoduje identyczne działanie co akcja operatorska ASBASE, umieszczona w parametrze AKCJA (moduł Parametry startowe > zakładka Standardowe > parametr Akcja); istotną różnicą jest natomiast moment wykonania - parametr Startuj AsBase jest wykonywany przed otwarciem masek wskazanych w parametrze: moduł Parametry startowe > zakładka Maski > parametr Otwórz; natomiast akcja AUTOSTART - nawet wykonana poprzez parametr Akcja (moduł Parametry startowe > zakładka Standardowe) jest uruchamiana po otwarciu masek startowych. Może to powodować istotny problem: maski autostartu nie mogą używać obiektów ASBASE.

Wartość domyślna - brak akcji startowej

Askom.Data.Host:

Rysunek: Okno parametrów startowych - zakładka 'Askom.Data.Host'.

  • Startuj Askom.Data.Host - pozwala zadeklarować startowanie programu Askom.Data.Host równocześnie ze startem aplikacji programu Asix.

Skrypty:

Rysunek: Okno parametrów startowych - zakładka 'Programy/Skrypty'.

Zakładka Skrypty umożliwia zadeklarowanie skryptów rozszerzających możliwości funkcjonalne systemu Asix. Skrypty należy zadeklarować w kolejnych pozycjach, podając nazwę skryptu oraz deklarując plik i dodatkowe opcje skryptu zgodnie z opisaną poniżej składnią.

Nazwa skryptu musi być różna od nazw innych parametrów deklarujących użycie skryptu. Nazwa skryptu nie może być nazwą parametru modułu skryptów oraz nie może być słowem ”skrypt" i ”script".

Obecnie moduł skryptów rozpoznaje rozszerzenia języka VBScript (.vbs) oraz języka JScript (.js).

Deklaracja pliku skryptu wraz z dodatkowymi opcjami wymaga zapisu zgodnie z następującą składnią:

plik_skryptu parametry_skryptu parametry_wykonawcze

gdzie:

plik_skryptu - ścieżka oraz nazwa pliku zawierającego program skryptu; rozszerzenie nazwy pliku określa domyślny język skryptu;

parametry_skryptu - parametry przekazywane do skryptu; parametry skryptu są dostępne w skrypcie za pomocą obiektu Asix.Script.Parameters (lub Asix.Script.Arguments);

parametry_wykonawcze - parametry przekazywane do modułu skryptów (a nie do skryptu) i określające parametry wykonywania skryptu różne od domyślnych;

Do parametrów wykonawczych należą: ograniczenia czasu wykonania, aktywacja debuggera, deklaracja wątku, w którym zostanie wykonany skrypt i jego priorytet, typ skryptu, język itp. Niektóre parametry (np. ograniczenia) odpowiadają parametrom modułu skryptów. Umieszcza się je jako parametry wykonawcze tylko wtedy, gdy określony skrypt ma specjalne wymagania, różne od tych określonych za pomocą parametrów definiujących sposób wykonywania skryptów - patrz: zakładka Parametry skryptów w module Pozostałe.

Parametry wykonawcze podaje się w konwencji programu cscript, tj. są one poprzedzone podwójnym ukośnikiem.

Parametry wykonawcze:

//S - w danej chwili może być uruchomiony tylko jeden skrypt z parametrem //S, zawarty w podanym pliku; parametr ma znaczenie tylko w przypadku uruchamiania skryptu jako akcji operatorskiej systemu Asix; moduł skryptów odrzuci próbę ponownego uruchomienia skryptu w sytuacji, gdy poprzednie uruchomienie skryptu z parametrem //S, zawartego w tym samym pliku, jeszcze się nie zakończyło; brak tego parametru powoduje, że można równocześnie uruchamiać wiele skryptów w oparciu o program zawarty w tym samym pliku.;

//X - po uruchomieniu skryptu jest również uruchamiany debugger (zainstalowany w systemie jako domyślny); debugger zatrzymuje wykonanie skryptu na pierwszej instrukcji skryptu;

//D - wystąpienie błędu w skrypcie powoduje uruchomienie debuggera;

//IT:nnn - ograniczenie czasu wykonania części inicjalizacyjnej wyrażone w milisekundach;

//T:nnn - ograniczenie czasu wykonania części zdarzeniowej wyrażone w milisekundach;

//E:nazwa - podaje nazwę języka skryptu (np. //E:JScript);

//Watek:nazwa[,pri] - podaje nazwę wątku, w którym wykonuje się skrypt oraz określa priorytet pri wątku; nazwa wątku może być dowolna i służy grupowaniu skryptów wykonywanych w jednym wątku;

priorytety wątku skryptu:

0 IDLE - bezczynny,

1 LOWEST - najniższy,

2 BELOW_NORMAL - poniżej normalnego,

3 NORMAL - normalny (domyślny),

4 ABOVE_NORMAL - powyżej normalnego,

5 HIGHEST - najwyższy,

6 TIME_CRITICAL - krytyczny czasowo;

domyślnym priorytetem wątku jest priorytet 3 (normalny).

//U - podanie tego parametru spowoduje, że nie będą generowane zdarzenia ”OnRead" oraz funkcje zdarzeń czasowych zdefiniowane metodami SetInterval i ExecuteAt, jeśli okna aplikacji Asix są ukryte (np. za pomocą akcji operatorskiej UKRYJ).

Szczegółowy opis modułu skryptów znajduje się w odrębnym podręczniku ”Skrypty - podręcznik użytkownika”.


4.4.3 Podstawowe parametry Panelu Kontrolnego i Konstruktora

Zakładka Panel kontrolny pozwala zdefiniować podstawowe parametry Panelu Kontrolnego i Konstruktora:

Okno:

Rysunek: Okno parametrów startowych - zakładka 'Panel Kontrolny/Okno'.

  • Położenie okna Panelu Kontrolnego - to pozycja podająca początkowe położenie okna Panelu Kontrolnego. Koordynaty wyrażone są w pikselach.

Wartość domyślna - użycie pozycji standardowej.

Definiując położenie okna, projektant ma do dyspozycji narzędzie ułatwiające tę czynność. Przycisk Wybierz… uruchamia okno ’Pozycja okna’, które jest wyposażone w przycisk Podgląd. Pozwala on określić współrzędne położenia poprzez ręczne przesuwanie szarego okna, odpowiadającego wymiarom Panelu Kontrolnego.

Rysunek: Okno definiujące położenie okna Panelu Kontrolnego.

  • Zwiń przy starcie okno Panelu Kontrolnego do ikony - pozwala na automatyczne zwinięcie Panelu do ikony w czasie wykonywania startu aplikacji. Parametry położenia zostaną wtedy użyte przy operacji rozwinięcia okna.

  • Wyświetlaj okno panelu zawsze na wierzchu - pozycja pozwala na nadanie oknu Panelu Kontrolnego atrybutu powodującego jego wyświetlanie ponad wszystkimi innymi oknami systemu. Wykorzystanie tego parametru jest przydatne w sytuacji używania masek z atrybutem ”na wierzchu", które mogą zasłonić Panel.

  • Liczba pamiętanych błędów - określa liczbę błędów zapamiętywanych w oknach Panelu Kontrolnego i Konstruktora.

  • Ukryj - pozwala na zablokowanie ukrycia okien aplikacji z poziomu menu Konstruktora (blokowane jest polecenie Pliki > Ukryj okna) oraz akcją UKRYJ_WSZYSTKO. Ma zastosowanie w przypadku, gdy istnieje potrzeba zróżnicowania sposobu pracy tej samej aplikacji na różnych stanowiskach (np. stanowisko operatorskie i kontrolne).

Polecenie Pliki > Ukryj okna oraz akcja UKRYJ_WSZYSTKO powodują zwinięcie wszystkich otwartych okien aplikacji do ikony na pasku zadań w prawej jego części. W wyniku tego następuje automatyczna redukcja obciążenia procesora. Przywrócenie aplikacji do poprzedniego stanu wykonuje się przez dwukrotne kliknięcie na ikonie Asixa, znajdującej się w prawej części paska zadań.

  • Cicho - wyłącza sygnalizację dźwiękową alarmów i komunikatów Panelu Kontrolnego.

Plik:

Rysunek: Okno parametrów startowych - zakładka 'Panel Kontrolny/Plik'.

  • Plik komunikatów - wskazuje miejsce, gdzie mają być zapisywane komunikaty Panelu Kontrolnego i Konstruktora oraz maksymalny rozmiar pliku komunikatów.

Wartość domyślna - komunikaty systemowe nie są zapisywane do pliku.

Rysunek: Przeglądarka logów Asixa.

Przycisk uruchom okno komunikatów uruchamia okno przeglądarki logów Asixa.

Przycisk usunięcie pliku logów powoduje skasowanie pliku logów.


4.4.4 Parametryzacja mechanizmu aktualizacji oprogramowania

Zakładka Aktualizacja Plików obejmuje parametry dotyczące oprogramowania narzędziowego Asixa, elementów składowych aplikacji oraz częstotliwości sprawdzania jednolitości oprogramowania. Deklarowane tu operacje pozwalają ujednolicić oprogramowanie narzędziowe i aplikacyjne w sposób automatyczny:

Aktualizacja Plików / Pliki:

Rysunek: Okno parametrów pozostałych - zakładka 'Aktualizacja plików'.

  • Plik - użycie parametru powoduje wykonywanie aktualizacji dowolnych plików; dla pozycji Plik należy zadeklarować nazwę pliku (wraz z jego katalogiem), którego zawartość ma być aktualizowana oraz nazwę katalogu wzorca, w którym umieszczone są pliki wzorcowe;

uwaga Aktualizacja jest wykonywana wtedy, gdy pliki wzorcowe mają późniejszy czas modyfikacji niż pliki oryginalne lub pliki oryginalne nie zostały znalezione

Aktualizacja Plików / Opcje:

  • Okres - służy do podania okresu czasu wyrażonego w minutach, co jaki należy wykonywać synchronizację plików; brak pozycji lub wartość 0 oznacza, że synchronizacja jest wykonywana tylko na starcie programu;

Wartość domyślna: 0

  • Raport - parametr włączony powoduje wysyłanie komunikatów do panelu kontrolnego w przypadku wykonania operacji synchronizacji pliku;

Wartość domyślna: domyślnie parametr jest wyłączony

Aktualizacja Plików / VarDef - pliki txt:

  • Katalog wzorców plików modułu modułu danych bieżących - zastosowanie parametru powoduje wykonywanie aktualizacji plików definicji zmiennych Asmena

uwaga Parametr stosowany w sytuacji, gdy definicje zmiennych przechowywane w plikach tekstowych (w starszych wersjach systemu Asix). Parametr jest dostępny na zakładce Aktualizacja Plików / VarDef - pliki txt, gdy jako typ bazy definicji zmiennych został zadeklarowany typ: Tekstowa baza definicji zmiennych (Asix 1-4).

  • Katalog wzorców plików modułu modułu danych archiwalnych – zastosowanie parametru powoduje wykonywanie aktualizacji plików definicji zmiennych Aspada

uwaga Parametr stosowany w sytuacji, gdy definicje zmiennych przechowywane w plikach tekstowych (w starszych wersjach systemu Asix). Parametr jest dostępny na zakładce Aktualizacja Plików / VarDef - pliki txt, gdy jako typ bazy definicji zmiennych został zadeklarowany typ: Tekstowa baza definicji zmiennych (Asix 1-4).


4.4.5 Definiowanie zaleznosci pomiedzy komputerami i obszarami

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.4 Konfiguracja parametrów startowych > 4.4.5 Definiowanie zależności pomiędzy komputerami i obszarami

4.4.5 Definiowanie zależności pomiędzy komputerami i obszarami

Widok zakładki Komputery zależny jest od tego, który element zaznaczony jest w drzewie komputerów i obszarów. Jeśli jest to Obszar, okno wyświetla listę komputerów podpiętych do danego obszaru (patrz: Rysunek: Widok komputerów podłączonych do wskazanego obszaru.). Jeśli jest to Komputer, pojawia się zakładka z zestawieniem obszarów dostępnych oraz obszarów, do których dołączony jest dany komputer (patrz: Rysunek: Widok obszarów, do których podpięty jest wskazany komputer.).

Rysunek: Widok komputerów podłączonych do wskazanego obszaru.

Rysunek: Widok obszarów, do których podpięty jest wskazany komputer.


4.4.6. Deklaracja aktywnych zmiennych

Zakładka VarDef - aktywne zmienne pozwala załączyć selekcję zmiennych wg atrybutu bazy definicji zmiennych, który pozwala określić zmienne aktywne dla danego komputera - jest to dowolny atrybut utworzony przez projektanta. Załączenie tej opcji i zadeklarowanie nazwy tego atrybutu spowoduje, ze podczas startu aplikacji ładowane będą tylko te zmienne, dla których wartość wskazanego atrybutu wynosi 1.

Rysunek: Okno parametrów startowych - zakładka 'VarDef - aktywne zmienne'.


4.4.7. Deklaracja zwenetrznej bazy definicji zmiennych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.4 Konfiguracja parametrów startowych > 4.4.7. Deklaracja zewnętrznej bazy definicji zmiennych

4.4.7 Deklaracja zewnętrznej bazy definicji zmiennych

uwaga Zakładka Baza definicji zmiennych pojawia się w sytuacji, gdy:

1. dla aplikacji zadeklarowana jest Zewnętrzna baza/bazy definicji zmiennych:

Bazy danych > Baza definicji zmiennych > zakładka Typ

Zakładka Baza definicji zmiennych pozwala określić następujące opcje:

Rysunek: Okno parametrów startowych - zakładka 'Baza definicji zmiennych'.

  • Bazy definicji zmiennych - pole to wskazuje lokalizację pliku zewnętrznej bazy definicji zmiennych - utworzonej za pomocą Architekta, parametryzowanej plikiem XML innym niż ten, który parametryzuje projektowaną aplikację.


4.5 Konfiguracja parametrow masek

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek

4.5 Konfiguracja parametrów masek

Moduł maski ikonka Maski obejmuje parametry, których konfiguracja jest niezbędna do prawidłowej pracy masek, m.in. lokalizuje symbole graficzne wykorzystywane do projektu masek, wskazuje katalogi, z których pobierane są maski w trakcie działania aplikacji oraz definiuje wybrane parametry pracy obiektów na maskach.


4.5.1 Deklaracja lokalizacji plikow graficznych i masek

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.1 Deklaracja lokalizacji plików graficznych i masek

4.5.1 Deklaracja lokalizacji plików graficznych i masek technologicznych

Zakładka Pliki i Foldery pozwala określić następujące opcje:

Rysunek: Okno parametrów masek - zakładka 'Pliki i Foldery'.

  • Plik symboli graficznych - podaje nazwę pliku, w którym znajdują się mapy bitowe i ikony używane w aplikacji. Użytkownik może sam tworzyć pliki symboli graficznych, potrzebnych do projektowanych aplikacji.

Wartość domyślna: mapy bitowe standardowo dołączane do pakietu znajdują się w pliku asbitmap.dat w katalogu programu AS.

Opis użycia map bitowych w aplikacji systemu A six znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Konstruktor - projektowanie aplikacji.

  • Ścieżka masek - pozycja podająca listę nazw katalogów, w których znajdują się pliki zawierające maski wizualizacyjne;

Wartość domyślna: brak pozycji oznacza, że pliki masek będą czytane z katalogu głównego aplikacji.


4.5.2. Deklaracja masek otwieranych automatycznie po

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.2. Deklaracja masek otwieranych automatycznie po

4.5.2 Deklaracja masek otwieranych automatycznie po uruchomieniu aplikacji

Zakładka Maski otwierane określa:

Rysunek: Okno parametrów startowych - zakładka 'Maski otwierane'.

  • Maski otwierane - nazwy masek, które mają być automatycznie otwarte po uruchomieniu aplikacji;

  • Maski otwierane zminimalizowane - nazwy masek, które mają być automatycznie otwarte po uruchomieniu aplikacji i natychmiast zwinięte do ikony.


4.5.3 Deklaracja czcionek wykorzystywanych w projektowanej

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.3 Deklaracja czcionek wykorzystywanych w projektowanej

4.5.3 Deklaracja czcionek wykorzystywanych w projektowanej aplikacji

Zakładka Czcionki pozwala zdefiniować czcionki, używane w aplikacji systemu Asix. Poniżej listy zadeklarowanych czcionek znajduje się okno podglądu czcionek, w którym wyświetlany jest krój zaznaczonej czcionki.

Rysunek: Okno parametrów masek - zakładka 'Czcionki'.


4.5.4 Deklaracja jezykow aplikacji

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.4 Deklaracja języków aplikacji

4.5.4 Deklaracja języków aplikacji

Zakładka Języki przeznaczona jest do definiowania języków pracy aplikacji:

Rysunek: Okno parametrów startowych - zakładka 'Języki'.

  • Języki deklarowane są poprzez:

  • Kod języka - zaleca się zachowanie zgodności z normą ISO639; kod języka używany jest do selekcji aktywnego języka i wyboru właściwych wersji tekstów używanych w aplikacji;

Zestawienie wszystkich kodów języków obsługiwanych przez Architekta zawiera Załącznik 3.

  • Opis - opis języka;

  • Strona kodowa - parametr, który określa właściwą stronę kodową dla danego języka; parametr stosowany jest w funkcji

uwaga Dla danej aplikacji można zadeklarować pięć pozycji języków,automatycznego przełączania stron kodowych czcionek; co oznacza, że aplikacja zbudowana przy wykorzystaniu pakietu może pracować w pięciu językach.

uwaga Specjalne znaczenie ma pierwszy zadeklarowany język. Określa ona tzw. język podstawowy. Jest to język, w którym aplikacja została zbudowana.

uwaga System przełączania języków uaktywnia się, jeżeli w pliku konfiguracyjnym zostaną zdefiniowane co najmniej dwa języki pracy aplikacji.

  • Tablica Tekstów - służy do tłumaczenia tekstów, które są wyświetlane w ramach elementów aplikacji i są wbudowane w kod programu.

Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TextTable.Lng.

Plik Tablicy Tekstów jest plikiem tekstowym, w którym poszczególne linie są tekstami wielojęzycznymi określającym tłumaczenia tekstów. W pliku dopuszczalne są linie komentarzy, które są oznaczane przez znak średnika na początku linii.

uwaga W ramach pakietu Asix jest dostarczany plik TextTable.Tlt zawierający kompletną tablicę tekstów dla języków polskiego i angielskiego.

Projektant powinien skopiować ten plik do katalogu aplikacji pod nazwą TextTable.Lng, a następnie uzupełnić teksty wielojęzyczne o definicje wariantów dla pozostałych używanych języków aplikacji.

  • Tablica Translacji - służy do tłumaczenia tekstów wprowadzonych przez projektanta w trakcie definiowania aplikacji. Dotyczy to głównie tekstów z obiektów umieszczonych na maskach wizualizacyjnych.

uwaga Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TranslateTable.Lng. Bazowy plik Tablicy Translacji można wygenerować automatycznie przy pomocy funkcji PLIK_TŁUMACZEŃ z menu NARZĘDZIA okna Konstruktora.

Zobacz też zagadnienie 4.17. Konfiguracja aplikacji wielojęzycznej .


Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.5. Dostęp do edytora Tabeli zmiennych

4.5.5. Dostęp do edytora Tabeli zmiennych

Zakładka Tabela umożliwia uruchomienie edytora Tabeli zmiennych.

Rysunek: Okno parametrów masek - zakładka 'Tabela'.


4.5.6 Definicje menu umieszczanego na masce aplikacji

Zakładka Menu przeznaczona jest do tworzenia definicji menu umieszczanych na maskach pełniących funkcje pasków menu z rozwijanymi pozycjami do wyboru.

Rysunek: Okno parametrów masek - zakładka 'Menu'.

Definicja pojedynczego menu dołączana jest do jednego przycisku na pasku menu.

Rysunek: Widok menu rozwijanego.

Tworzenie definicji menu umożliwia edytor menu wywoływany poleceniem rozwiń po zadeklarowaniu nazwy menu w oknie Menu.

Rysunek: Okno edytora menu.

W Edytorze menu należy określić następujące elementy określające wygląd oraz sposób działania pojedynczego menu:

  • Nazwa - w tym polu należy wpisać bezpośrednio lub za pomocą Edytora tekstów wielojęzycznych (uruchamianego przyciskiem [image]) teksty, które pojawią się w gotowej aplikacji jako pozycje rozwijanej listy. Patrz: Rysunek: Edytor tekstów wielojęzycznych.

Rysunek: Edytor tekstów wielojęzycznych.

  • Akcja - pole pozwala dla każdej pozycji rozwijanej listy definiowanego menu zadeklarować akcję, która zostanie wykonana po wybraniu danej pozycji; akcję można zdefiniować przy użyciu Edytora akcji uruchamianego przyciskiem 3 kropki. Patrz: poniżej.

Rysunek: Edytor akcji.

  • Początek grupy - zaznaczenie pola przy określonej pozycji spowoduje, że w gotowej wyświetlanej liście pozycji menu pojawi się nad tą pozycją pionowa kreska oddzielająca daną pozycję od pozycji wcześniejszych. Patrz: poniżej.

Rysunek: Początek grupy na liście rozwijanych pozycji menu.

Dodawanie i usuwanie pozycji rozwijanej listy menu umożliwia pasek narzędziowy Edytora menu:

pasek narzędziowy edytora menu, gdzie:

dodaj pozycje menu - Dodaj element (Shift + Ctrl + Ins);

dodaj podelement - Dodaj podelement (Ctrl + Ins);

ususń element - Usuń element (Ctrl + Del);

przenieś wyżej - Przenieś wyżej (Ctrl + Up);

przenieś niżej - Przenieś niżej (Ctrl + Down);

przenieś w lewo - Przenieś w lewo (Ctrl + Left);

przenieś w prawo - Przenieś w prawo (Ctrl + Right);

podgląd - Podgląd (Ctrl + P).

Utworzoną definicję pojedynczego menu należy podpiąć do przycisku umieszczonego na masce paska menu:

Rysunek: Schemat powiązania definicji pojedynczego menu z maską menu aplikacji.


4.5.7 Definicje parametrow tekstowych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.7 Definicje parametrów tekstowych

4.5.7 Definicje parametrów tekstowych

Zakładka Parametry tekstowe pozwala zdefiniować stałe tekstowe, które służą następującym celom:

  • definicje tekstów wyświetlanych przez obiekty wizualizacyjne klasy TEKST,

  • definicje tekstów używanych przez język ASTER do tworzenia raportów (instrukcja alias),

  • definicje wartości liczbowych (wpisywanych jako teksty) używanych przez język ASTEL do przetwarzania danych procesowych (funktor alias),

  • definicje kodów sterujących używanych do formatowania raportów na drukarce (instrukcja ctrl),

  • definicje części składowych złożonej akcji operatorskiej,

Definicja parametru tekstowego składa się z pól:

  • Nazwa logiczna parametru;

  • Tekst - parametr może być definiowany przy użyciu Edytora tekstów wielojęzycznych, uruchamianego przyciskiem [image];

Rysunek: Okno parametrów masek - zakładka Parametry Tekstowe.


4.5.8 Deklaracja klawiatur ekranowych

Mechanizm klawiatur ekranowych (aktywny w trybie wykonawczym aplikacji) zapewnia operatorowi możliwość wprowadzania tekstów do pól edycyjnych okien dialogowych i pól edycyjnych obiektów LICZBA i NAPIS poprzez stosowną klawiaturę ekranową (patrz: Rysunek: Okna klawiatur ekranowych dostępnych w systemie Asix.). Mechanizm stanowi wsparcie dla aplikacji pracujących na panelach z ekranem dotykowym.

Klawiatura jest uaktywniana po kliknięciu w obszarze pola lub obiektu.

Rysunek: Okna klawiatur ekranowych dostępnych w systemie Asix.

Zakładka Klawiatura ekranowa obejmuje następujące parametry:

Rysunek: Okno parametrów masek - zakładka 'Klawiatura ekranowa'.

  • Włącz klawiaturę ekranową - uruchamia mechanizm klawiatur ekranowych, które umożliwiają (w trybie wykonawczym aplikacji) wprowadzanie tekstów do pól edycyjnych okien dialogowych i pól edycyjnych obiektów LICZBA i NAPIS;

Wartość domyślna: mechanizm klawiatur ekranowych nie jest włączony.

  • Rozmiar klawiatury ekranowej - parametr pozwala określić rozmiar klawiatury ekranowej w pikselach;

Wartość domyślna: okno klawiatury ma szerokość 500 pikseli;

  • Rozmiar klawiatury numerycznej - parametr pozwala określić rozmiar klawiatury numerycznej w pikselach;

Wartość domyślna: okno klawiatury ma szerokość 300 pikseli.


4.5.9 Parametry dotyczace okresu migotania obiektow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.5 Konfiguracja parametrów masek > 4.5.9 Parametry dotyczące okresu migotania obiektów

4.5.9 Parametry dotyczące okresu migotania obiektów wizualizacyjnych oraz parametry wysyłanych sterowań

Zakładka Pozostałe obejmuje następujące parametry:

Rysunek: Okno parametrów masek - zakładka 'Pozostałe'.

  • Okres migotania - deklaracja okresu migotania w milisekundach; parametr ten jest ustawiany jednorazowo i ma skutek w działaniu wszystkich obiektów używających atrybutu migotania;

Wartość domyślna: 333 ms

  • Bez niewidocznych sterowań - parametr pozwala zablokować wysyłanie sterowań z masek nawet częściowo przesłoniętych innym oknem;

Wartość domyślna: domyślnie wysyłane są ustawione sterowania z wszystkich otwartych w danym momencie masek.

  • Czas ważności sterowań - parametr pozwalający określić czas, liczony w sekundach od momentu ustawienia ostatniego wyboru sterowania przez operatora do skasowania wszystkich aktywnych wyborów przez system. ”r;0" oznacza, że opcja liczenia czasu ważności sterowań nie jest włączona; domyślnie opcja nie jest włączona.

Wartość domyślna: 0 - raz ustawiony wybór sterowania jest aktywny do zamknięcia maski, o ile wcześniej nie został skasowany przez operatora.


4.6 Konfiguracja parametrow danych biezacych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.6 Konfiguracja parametrów danych bieżących

4.6 Konfiguracja parametrów danych bieżących

Grupa parametrów dane bieżące ikonka Dane bieżące obejmuje ustawienia pracy modułu Asmen, w tym szczegółową parametryzację kanałów transmisyjnych - fizycznie realizowanych połączeń pomiędzy komputerem systemu Asix i sterownikami na obiekcie oraz parametryzację drajwerów komunikacyjnych.

W systemie Asix wszystkie operacje związane z dostępem do zmiennych procesowych są realizowane przez moduł Asmen. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych procesowych w bazie danych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery pracujące pod kontrolą Asmena.

W oparciu o dokonaną parametryzację tworzone jest repozytorium bieżących wartości zmiennych procesowych (przechowywane przez moduł Asmen w pamięci operacyjnej komputera), do którego mają dostęp wszystkie komponenty systemu Asix. Wartości przechowywanych zmiennych procesowych są na bieżąco aktualizowane poprzez cykliczny odczyt z obiektu.

Szczegółowy opis funkcjonalności modułu Asmen znajduje się w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdziale Asmen - M enedżer komunikacyjny.


4.6.1 Parametry standardowe

Parametry dotyczące danych bieżących znajdujące się na zakładce Standardowe obejmują:

Rysunek: Okno parametrów danych bieżących - zakładka 'Standardowe'.

  • Symulacja - Asmen działa w trybie symulacji danych po zaznaczeniu opcji Zaznaczenie tej opcji spowoduje pominięcie ładowania modułu danych bieżących Asmen.

Wartość domyślna: domyślnie opcja jest wyłączona.

  • Przeciążenia - wykorzystanie parametru pozwala na rejestrację stanu przeciążenia przy odświeżaniu zmiennych procesowych w panelu operatorskim;

Wartość domyślna: domyślnie opcja jest włączona;

Przeciążenia te dotyczą zmiennych - w sytuacji gdy zadeklarowany czas odświeżania zmiennych przekracza możliwości kanału transmisyjnego. (Częstość odświeżania deklarowana jest w definicji zmiennej).

  • Sprawdzanie zakresów - włącza sprawdzanie zakresów dla zmiennych z ustawionym atrybutem Sprawdzanie zakresu pomiarowego;

Wartość domyślna: domyślnie opcja jest wyłączona;

  • Dane / Nazwy plików z deklaracjami zmiennych procesowych

uwaga Pole dostępne jest wyłącznie wówczas, gdy definicje zmiennych procesowych pobierane są z plików tekstowych, co zostało uprzednio zadeklarowane w:

Moduł Bazy danych > zakładka Typ > Typ bazy definicji zmiennych: Tekstowa baza definicji zmiennych (Asix 1-4).


4.6.2 Parametry zaawansowane

uwaga Zakładki Zaawansowane i Zaawansowane2 pojawiają się po wybraniu polecenia:

Obszary i komputery > Pokaż opcje zaawansowane

Zakładki Zaawansowane i Zaawansowane 2 pozwala na parametryzację następujących pozycji:

Rysunek: Okno parametrów danych bieżących - zakładka 'Zaawansowane'.

  • Status OPC - deklaracja używania statusów w trybie zgodnym z OPC; włączenie tej opcji jest wymagane dla poprawnego działania modułu skryptów.

Wartość domyślna: opcja włączona

  • Priorytet - deklaracja priorytetów wątków Asmena:

  • 0 - THREAD_PRIORITY_NORMAL,

  • 1 - THREAD_PRIORITY_ABOVE_NORMAL,

  • 2 - THREAD_PRIORITY_HIGHEST.

Wartość domyślna: 0

  • Liczba prób dostępu do zmiennej - deklaracja liczby prób zdalnego dostępu do zmiennej na serwerze, po której przyjmuje się, że zmienna na przedmiotowym serwerze nie została zadeklarowana;

Wartość domyślna: 1

  • Liczba użytkowników - pozwala zdefiniować maksymalną liczbę użytkowników korzystających z API Asmena. Pozycja ma zastosowanie w wieloportowych aplikacjach z drajwerem MUZ;

Wartość domyślna: 128

  • Wstępne odświeżanie - jeśli opcja zostanie zadeklarowana, na etapie instalacji Asmena następuje odczyt aktualnych wartości wszystkich zmiennych procesowych;

Wartość domyślna: opcja załączona

Rysunek: Okno parametrów danych bieżących - zakładka 'Zaawansowane2'.

  • Zwłoka danych z serwera - pozycja stosowana na terminalu; określa czas, po którym następuje ustawienie statusu błędu zmiennej w następstwie braku napływu odświeżonych danych z serwera; czas jest wyliczany jako iloczyn czasu odświeżania zmiennej (podanego w definicji zmiennej) oraz wartości pozycji; pozycja ma zastosowanie do wszystkich zmiennych jednocześnie; jednostka: sekunda.

Wartość domyślna: 1 sekunda

  • Cykl odświeżania - deklaracja wartości domyślnego cyklu odświeżania zmiennych procesowych (w sekundach), dla których nie podano wartości cyklu odświeżania w deklaracji zmiennej;

Wartość domyślna: 1 sekunda

  • Ścieżka funkcji przeliczającej TABELA- deklaracja nazwy kartoteki, w której znajdują się tabele używane przez funkcje przeliczające TABELA;

Wartość domyślna: brak zadeklarowanej ścieżki

  • Opis zmiennej - określa użycie pola Opis w deklaracji zmiennych procesowych Asmena;

uwaga Użycie opcji jest zasadne wyłącznie wtedy - gdy deklaracje zmiennych procesowych pobierane są z plików - tekstowych.

Wartość domyślna: opcja jest włączona

  • Sterowanie asynchroniczne - deklaracja użycia trybu asynchronicznego przy realizacji sterowań w szybkich kanałach transmisji;

Wartość domyślna: tryb asynchroniczny nie jest używany


4.6.3 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia:

Widok > Pokaż opcje zaawansowane

Zakładka Diagnostyka obejmuje:

Rysunek: Okno parametrów danych bieżących - zakładka 'Diagnostyka'.

  • Plik logu - domyślnie opcja załączana dla nowych aplikacji

  • Statystyka kanałów - zestawienie liczby odświeżanych oraz przeciążonych zmiennych w poszczególnych kanałach fizycznych; zestawienie wyprowadzane do Panelu Kontrolnego co sekundę;

Wartość domyślna: opcja jest wyłączona

  • Statystyka przeciążeń - zestawienie liczby przeciążonych zmiennych w kanałach fizycznych; zestawienie jest wyprowadzane do Panelu Kontrolnego wtedy, gdy wystąpi przeciążenie;

Wartość domyślna: opcja jest wyłączona

Zakładka Diagnostyka - śledzenie obejmuje:

Rysunek: Okno parametrów danych bieżących - zakładka 'Diagnostyka - śledzenie'.

  • Śledzenie zmiennych - opcja ta powoduje dla wybranych zmiennych wpisywanie do pliku logu komunikatów o wartościach, które moduł danych bieżących otrzymał ze sterowników i innych źródeł.

Zakładka Diagnostyka - śledzenie sterowań obejmuje:

Rysunek: Okno parametrów danych bieżących - zakładka 'Diagnostyka - śledzenie sterowań'.

  • Śledzenie sterowań- opcja ta powoduje dla wybranych zmiennych wpisywanie do pliku logu komunikatów o ich sterowaniu.


4.6.4 Definicja kanalow komunikacyjnych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.6 Konfiguracja parametrów danych bieżących > 4.6.4 Definicja kanałów komunikacyjnych

4.6.4 Definicja kanałów komunikacyjnych

Definicje kanałów komunikacyjnych dodawane są za pomocą polecenia Dodaj kanał po kliknięciu prawym klawiszem myszki na pozycji Dane bieżące. Pojawia się wówczas okno ’Dodaj kanał’, gdzie należy określić nazwę kanału i nazwę drajwera komunikacyjnego.

Rysunek: Okno deklarowania definicji kanałów.

Wyboru nazwy drajwera należy dokonać z listy drajwerów dostępnych w pakiecie Asix, która uruchamiana jest przyciskiem Wybierz w oknie ’Dodaj kanał’.

Rysunek: Okno wyboru drajwerów komunikacyjnych.

Po wybraniu konkretnego drajwera w grupie parametrów Dane bieżące pojawia się pozycja z nazwą wyselekcjonowanego drajwera. Kliknięcie na tę pozycję otwiera w oknie parametrów zakładki, które służą do parametryzacji tego drajwera - zakładki te zostały opisane poniżej. Ponadto, kliknięcie prawym klawiszem myszki na wybranym kanale uruchamia podręczne menu z komendami umożliwiającymi zmianę definicji kanału oraz usunięcie zaznaczonego kanału.

Zakładka Standardowe obejmuje standardowe parametry deklaracji każdego kanału:

Rysunek: Widok okna parametryzującego pracę drajwera komunikacyjnego - zakładka 'Standardowe'.

  • Kanał/Nazwa - określa nazwę kanału;

  • Kanał/Drajwer - określa nazwę drajwera;

  • Drajwer użyty w kanale:

  • Używaj drajwer jaki podano w definicji kanału;

  • Tymczasowo używaj drajwer NONE - opcja stosowana w przypadku braku fizycznego podłączenia do sterownika; drajwer NONE może być stosowany w celu testowania aplikacji;

  • Tymczasowo używaj drajwer NETWORK - drajwer NETWORK jest specyficznym rodzajem drajwera; nie realizuje on fizycznego połączenia ze sterownikiem, a jedynie połączenie z innym komputerem, który takie połączenie ma; drajwer kanału sieciowego po nawiązaniu połączenia wysyła zapytanie do wszystkich serwerów podając nazwę logiczną kanału; odpowiadają na to pytanie jedynie serwery, które posiadają zadeklarowany taki kanał; jeżeli odpowie więcej niż jeden serwer, to wtedy do nawiązania połączenia wybiera się serwer najmniej obciążony; jeżeli w czasie pracy nastąpi wyłączenie serwera, wówczas drajwer kanału sieciowego przełączy się na inny serwer;

  • Alarm w kanale (parametr dostępny dla wybranych drajwerów) - deklaracja zgłoszenia alarmu w przypadku braku transmisji w kanale logicznym; opcjonalnie możliwe jest zgłoszenie nr alarmu w przypadku przełączenia transmisji na kanał redundantny (o ile kanał redundantny został zadeklarowany dla kanału logicznego);

Wartość domyślna: brak deklaracji kanału podstawowego i redundantnego

  • Synchronizacja czasu (parametr dostępny dla wybranych drajwerów) - synchronizacja czasu odbywa się w kierunku od systemu Asix do sterownika. Więcej informacji znajduje się w podręczniku ‘Drajwery komunikacyjne’ (plik pomocy Drajwery komunikacyjne.pdf / Drajwery komunikacyjne.chm);

Wartość domyślna: brak deklaracji

Pozostałe parametry dostępne na zakładce Standardowe zależą od konkretnego zadeklarowanego drajwera.

Zakładka z nazwą zadeklarowanego drajwera obejmuje parametry właściwe do skonfigurowania kanału komunikacyjnego dla danego drajwera.

Opisy parametryzacji poszczególnych drajwerów znajdują się w odrębnym podręczniku Drajwery komunikacyjne (plik DrajweryKomunikacyjne.pdf/chm).

uwaga Zakładka Zaawansowane i Zaawansowane 2 pojawia się po wybraniu polecenia Obszary i komputera > Pokaż opcje zaawansowane z menu Widok modułu Architekt.

Zakładka Zaawansowane pozwala na parametryzację następujących pozycji:

Rysunek: Widok okna parametryzujących pracę drajwera komunikacyjnego - zakładka 'Zaawansowane'.

  • Redundancja - (parametr dostępny dla wybranych drajwerów) deklaracja kanału redundantnego dla kanału logicznego. Opcjonalnie można ograniczyć zakres poszukiwań poprzez zadeklarowanie listy komputerów. W polu należy wpisać nazwę kanału redundantnego, a po przecinku można podać nazwy komputerów, do których ma być ograniczone szukanie.

Wartość domyślna: domyślnie kanał redundantny jest szukany na wszystkich komputerach sieci

  • Zezwolenie zapisu - deklaracja nazw sieciowych komputerów, które mają uprawnienia do sterowania w danym kanale. Nazwy oddzielić należy przecinkiem.

Wartość domyślna: domyślnie żaden z komputerów nie ma uprawnień do zapisu.

  • Ograniczenie odczytu - deklaracja nazw sieciowych komputerów, które mają uprawnienia do czytania wartości zmiennych z danego kanału.

Wartość domyślna: domyślnie wszystkie komputery mogą czytać zmienne z tego kanału.

Zakładka Zaawansowane 2 pozwala na parametryzację następujących pozycji:

Rysunek: Widok okna parametryzującego pracę drajwera komunikacyjnego - zakładka 'Zaawansowane 2'.

  • Blokada zapisu lokalnego - blokada lokalnych sterowań w kanale logicznym;

Wartość domyślna: nie ma blokady lokalnych sterowań

  • Czas ważności danych - okres czasu (w sekundach), przez który wartości zmiennych procesowych w kanale logicznym zachowują ważność bez względu na zadeklarowaną częstość odświeżania; ważność wartości zmiennych procesowych określa się na podstawie cyklu odświeżania;

Wartość domyślna: 0


4.6.5. Zarzadzanie_kanalami

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.6 Konfiguracja parametrów danych bieżących > 4.6.5. Zarządzanie kanałami

4.6.5. Zarządzanie kanałami

W menu uruchamianym po kliknięciu prawym klawiszem myszki na pozycji Dane bieżące dostępne jest również polecenie Zarządzaj kanałami, umożliwiające masowe kopiowanie i usuwanie kanałów, zmianę typu drajwera użytego w kanale oraz sortowanie kolejności wyświetlania kanałów w drzewie modułu Dane bieżące.

Rysunek: Okno 'Zarządzaj kanałami'.


4.7 Konfiguracja parametrow danych biezacych dotyczacych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.7 Konfiguracja parametrów danych bieżących dotyczących serwera sieci

4.7 Konfiguracja parametrów danych bieżących dotyczących serwera sieci

Konfiguracja parametrów z grupy serwer sieci Dane bieżące - serwer sieci wiąże się z ustawieniem wartości parametrów konfigurujących sposób wymiany danych poprzez lokalną sieć komputerową.

Lokalna sieć komputerowa może być wykorzystana do stworzenia takiej konfiguracji systemu Asix, w której tylko część komputerów (serwery danych) ma bezpośrednie połączenie ze sterownikami, natomiast pozostałe komputery (stacje robocze) korzystają z informacji udostępnianych przez serwery danych za pośrednictwem lokalnej sieci komputerowej.

Kanały transmisji systemu Asix służące do pozyskiwania danych poprzez lokalną sieć komputerową noszą nazwę kanału sieciowego.

Wymiana danych w lokalnej sieci komputerowej pomiędzy stacjami systemu Asix jest realizowana przez moduł NETSRV. Moduł ten jest ładowany automatycznie przy uruchomieniu Asixa.


4.7.1 Dane standardowe

Zakładka Standardowe obejmuje konfigurację następujących opcji:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Standardowe'.

  • Kanały redundantne - określa typ kanału serwera, który będzie akceptowany przez dany komputer zdalny jako kanał redundantny; dopuszczalne typy to:

  • FIZYCZNE - tylko kanał fizyczny,

  • SIECIOWE - tylko kanał sieciowy,

  • WSZYSTKIE - dowolny typ kanału;

Wartość domyślna: FIZYCZNE

  • Tryb pomost - deklaruje pracę stacji roboczej w trybie POMOST.

W konfiguracjach, w których stacja robocza systemu Asix jest pomostem pomiędzy dwiema lokalnymi sieciami komputerowymi, kanały sieciowe stacji roboczej traktowane są na równi z kanałami fizycznymi w zakresie udostępniania danych w lokalnej sieci komputerowej. Terminale w sieci zakładowej mogą dołączyć się do kanałów sieciowych pomostu.

Wartość domyślna: tryb POMOST nie jest zadeklarowany

  • Wyszukiwanie serwerów - okres - pozwala określać odstęp czasu (w sekundach) pomiędzy operacjami poszukiwania serwerów;

Wartość domyślna: 1 sekunda

  • Wyszukiwanie serwerów - czas oczekiwania na odpowiedź - deklaracja maksymalnego okresu oczekiwania na odpowiedź podczas wyszukiwania serwerów; okres podany jest jako liczba taktów o czasie trwania 55 ms każdy.

Wartość domyślna: 18 (odpowiada jednej sekundzie)

  • Transmisja danych - czas oczekiwania na odpowiedź - deklaruje maksymalny czas oczekiwania na odpowiedź serwera podczas transmisji danych (w sekundach);

Wartość domyślna: 10 sekund


4.7.2 Dane zaawansowane

uwaga Zakładka Zaawansowane i Zaawansowane2 pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładki Zaawansowane i Zaawansowane2:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Zaawansowane'.

  • Czas UTC - żądanie przekazywania wartości zmiennych opatrzonych czasem UTC.

Wartość domyślna: opcja wyłączona

  • Zamykanie połączeń z klientami - deklaruje, czy stacja serwera będzie automatycznie zrywała połączenia ze stacjami zdalnymi w przypadku błędów komunikacji stwierdzonych w fizycznych kanałach komunikacyjnych stacji serwera; opcji nie należy używać, gdy w sieci jest tylko jeden serwer danych mający połączenie ze sterownikiem; opcja ta ma znaczenie tylko dla kanałów, które obsługują opcję Alarm w kanale.

Wartość domyślna: opcja włączona

  • Kanały poza pomostem - lista zawiera spis kanałów sieciowych, rozdzielonych przecinkami, do których klienci NIE BĘDĄ mogli się dołączyć; dotyczy to również klientów lokalnych;

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Zaawansowane2'.

  • Limit odświeżania - określa odstęp czasu (w sekundach), z jakim stacja robocza chce otrzymywać z serwera danych wartości zmiennych procesowych należących do kanału o nazwie zdefiniowanej w polu Kanał. Zaleca się używać tę opcję przy komunikacji po wolnych łączach.

Wartość domyślna: wartości zmiennych procesowych są rozsyłane z okresem zgodnym z deklaracją zmiennej procesowej na serwerze danych

  • Priorytet - deklaracja priorytetów wątków NETSRVa:

  • 0 - THREAD_PRIORITY_NORMAL,

  • 1 - THREAD_PRIORITY_ABOVE_NORMAL,

  • 2 - THREAD_PRIORITY_HIGHEST.

Wartość domyślna: 0

  • Wątek połączeń - deklaracja użycia odrębnego wątku dla realizacji połączeń sieciowych;

Wartość domyślna: opcja włączona


4.7.3 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Diagnostyka:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka Diagnostyka.

  • Plik logu - deklaracja nazwy pliku logu z komunikatami diagnostycznymi NETSRV;

- Nazwa - Wartość domyślna: plik logu nie jest tworzony

- Maksymalny rozmiar - wartość domyślna: 1 MB; po przekroczeniu rozmiaru zadeklarowanego w opcji dotychczasowa zawartość pliku jest kasowana

Szczegóły na temat wymiana danych poprzez lokalną sieć komputerową można znaleźć w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Menedżer komunikacyjny ASMEN, Wymiana danych poprzez lokalną sieć komputerową.

  • Log telegramów z Aslinka - deklaracja zapisu komunikatów odbieranych z Aslinka do pliku logu, zadeklarowanego w powyższej pozycji Plik logu;

Wartość domyślna: opcja jest wyłączona


4.8 Konfiguracja danych archiwalnych

Grupa parametrów dane archiwalne ikonka Dane archiwalne obejmuje ustawienia pracy modułu Aspad, w tym parametry rejestracji i późniejszego odtwarzania przebiegów czasowych zmiennych.

Moduł Aspad pozwala na archiwizację zmiennych każdego typu dozwolonego w module Asmen, pod warunkiem, że są to zmienne skalarne. Mogą to być zarówno zmienne procesowe, jak i uzyskiwane w wyniku przeliczeń lub symulacji. W obecnej wersji nie można archiwizować tablic. Oprócz wartości i czasu przechowywany jest także status wartości zgodny ze standardem OPC. Dane gromadzone są zarówno w plikach o specjalnie zaprojektowanej strukturze (archiwum D, M, Y - podział na pliki odpowiednio dobowe, miesięczne lub roczne), jak i w bazach danych (archiwum B).

Szczegółowy opis możliwości funkcjonalnych modułu Aspad znajduje się w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdziale Program Archiwizacji Danych ASPAD.


4.8.1 Dane standardowe

Zakładka Standardowe pozwala określić następujące podstawowe parametry archiwizacji:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Standardowe'.

  • Symulacja - zaznaczenie tej opcji spowoduje pominięcie ładowania Aspada;

Wartość domyślna: Aspad jest ładowany

  • Powtarzanie szukania serwerów - określa po jakim czasie należy ponowić próbę szukania serwera dla zasobów Aspada, jeżeli dotychczasowe próby nie powiodły się;

Wartość domyślna: 60 sekund.

uwaga Dobór zbyt krótkiego czasu spowoduje zwielokrotnienie obciążenia sieci operacjami wyszukiwania nieistniejącego serwera. Duża wartość parametru spowoduje, że po włączeniu serwera do sieci nie zostanie on jeszcze przez długi czas zauważony.

  • Warunki - pozwala zdefiniować pliki zawierające warunki w sytuacji stosowania archiwizacji warunkowej.

Szczegółowy opis archiwizacji warunkowej znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Deklaracje warunków archiwizacji.

Przykłady warunków archiwizacji:

Archiwizuj, gdy bity 4. lub 8. zmiennej AAA zmieniły stan:

WARUNEK, BNE, @AAA, $@AAA, 0x110

Archiwizuj, gdy bit 0. zmiennej archiwizowanej zmienia stan z 0 na 1:

WARUNEK, BGT, @, $@, 0x1

Archiwizuj, gdy wartość zmiennej archiwizowanej jest poza przedziałem (20,80) i ustawiony jest jeden z bitów 0-3 zmiennej WWW:

W1, IN, @, <<, 20, 80, >>

W2, BAND, @WWW, 0xF

WARUNEK, AND, ?W1, ?W2

Archiwizuj w chwili, gdy wartość zmiennej archiwizowanej przekracza granicę 100:

W3, GT, @, 100

WARUNEK, AND, ?W3, !$?W3


4.8.2 Deklaracja czasu oczekiwania na zgloszenie serwerow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.2 Deklaracja czasu oczekiwania na zgłoszenie serwerów

4.8.2 Deklaracja czasu oczekiwania na zgłoszenie serwerów

uwaga Zakładka Serwer profile pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Wyszukiwanie serwerów obejmuje następujące parametry:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Wyszukiwanie serwerów'.

  • Wyszukiwanie serwerów - określa jak długo należy czekać na zgłoszenia serwerów po zainicjowaniu poszukiwania:

  • Minimalny czas - określa jak długo czekać na odpowiedzi serwerów, niezależnie od tego, ile serwerów już się zgłosiło.

  • Maksymalny czas - podaje czas, po którym, w przypadku braku odpowiedzi jakiegokolwiek serwera, należy uznać, że w sieci nie został zainstalowany serwer dla danego zasobu.

  • Cykl powtarzania - opcjonalny parametr, który oznacza cykl, w którym należy ponawiać poszukiwanie serwera, jeżeli nie nadchodzi odpowiedź z żadnego serwera na poprzednie zapytania.

Wartość domyślna: odpowiednio 2 s, 10 s, 1 s

uwaga Zbyt mały parametr Minimalny czas może spowodować przyłączenie do pierwszego zgłaszającego się serwera, co uniemożliwi zastosowanie kryterium równomiernego obciążania serwerów.

Zbyt duży parametr Minimalny czas wydłuży oczekiwanie na nawiązanie połączenia z serwerem.

Zbyt mały parametr Maksymalny czas może uniemożliwić przyłączenie do istniejących serwerów.

Zbyt duży parametr Maksymalny czas wydłuży oczekiwanie na rozstrzygnięcie o braku serwera w sieci.


Deklaracja wersji plików archiwum standardowego

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.4 Deklaracja wersji plików archiwum standardowego

4.8.4. Deklaracja wersji plików archiwum standardowego

Zakładka Zaawansowane obejmuje następujące parametry:

Rysunek: Widok okna deklarującego wersje plików archiwum standardowego.

  • Domyślna wersja plików archiwum standardowego - opcja definiuje domyślną wersję plików archiwum standardowego dla archiwów, w których nie zadeklarowano jej indywidualnie:

Wersja 1 - zgodna z wersjami Asix od 5.0 do 7.0 (Aspad 6 i 7).

Wersja 2 - dostępna od wersji Asix 7.1 (Aspad 8).

W wersji 2 archiwum obsługiwane są długie nazwy zmiennych, nazwy zmiennych zawierające znaki UNICODE oraz archiwizacja z pełną precyzją liczb typu Double i Int64.

OSTRZEŻENIE: Uruchomienie aplikacji przy użyciu Asixa w wersji 7.0 lub wcześniejszej z plikami archiwum w wersji 2 spowoduje uszkodzenie tych plików.

INFORMACJE DODATKOWE:

Nie wolno kopiować plików archiwum w wersji 2 do pakietów Asix wcześniejszych ni 7.1.

Odczyt sieciowy archiwum w wersji 2 przez wcześniejsze wersje pakietu Asix podlega pewnym ograniczeniom:

1. Nie są dostępne zmienne o długich nazwach.

2. Funkcje uzupełniania danych, replikacji archiwum, obiekt WYKRES oraz skrypty VBSScript i JScript w Asixie klasycznym:

- nie działają w pakiecie Asix 5.2 lub wcześniejszych,

- działają w pakietach Asix 6 i Asix 7.0 tylko pod warunkiem aktualizacji modułu Aspad, przy czym wydajność odczytu jest wtedy zmniejszona w stosunku do archiwum w wersji 1.

  • Liczba wątków używanych do agregacji - opcja definiuje maksymalna liczbę wątków procesowa do liczenia agregatów zmiennych (0-wszystkie).

  • Agregacja w wątku głównym - opcja deklaruje obliczanie agregatów zmiennych w głównym wątku procesora.


4.8.4 Parametry diagnostyczne

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.5 Parametry diagnostyczne

4.8.5 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Diagnostyka określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka'.

  • Nazwa pliku logu - określenie pliku, do którego ASPAD będzie wpisywał informacje diagnostyczne;

Wartość domyślna: domyślnie tworzony jest plik logu aspad.log

  • Ustawienia diagnostyki - pozwala określić, jakiego rodzaju informacje diagnostyczne będą zapisywane w pliku logu:

  • Diagnostyka operacji sieciowych,

  • Diagnostyka stref czasowych,

  • Diagnostyka zapytań modułu danych archiwalnych,

  • Diagnostyka agregacji - pozwala załączyć diagnostykę agregacji;

  • Diagnostyka modyfikacji online otrzymanych z bazy definicji zmiennych;

  • Diagnostyka uzupełniania archiwów;

  • Diagnostyka uzupełniania danych historycznych;

  • Diagnostyka odczytu agregatów na interfejsie sieciowym - określenie pliku, do którego ASPAD będzie wpisywał informacje diagnostyczne;

  • Diagnostyka modyfikacji on-line otrzymanych z bazy definicji zmiennych;

Wartość domyślna: opcja wyłączona


4.8.5. Sledzenie probkowanych wartosci

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.6 Śledzenie próbkowanych wartości

4.8.6. Śledzenie próbkowanych wartości

Zakładka Diagnostyka - śledzenie określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka - śledzenie'.

  • Śledzenie próbkowanych wartości - opcja powoduje, że dla zadanej zmiennej wyprowadzane są do pliku logu (zadanego w deklaracji Nazwa pliku logu) komunikaty o wartościach, które moduł danych archiwalnych ASPAD otrzymał ze źródła danych;

- Podanie samej nazwy zmiennej powoduje śledzenie wszystkich zdarzeń dla danej zmiennej i jej agregatów;

- Podanie nazwy i typu archiwum oddzielonych przecinkiem (np. "A000,D") powoduje śledzenie tylko podanego typu archiwum zmiennej, bez śledzenia innych archiwów i agregatów;

- Podanie nazwy z pełną specyfikacją agregatu (tak jak pojawia się w logach, np. " A000,M-1m-Avg) powoduje śledzenie tylko tego agregatu.

Wartość domyślna: brak zadeklarowanych pozycji

uwaga W obecnej wersji można w ten sposób śledzić tylko zmienne typu zmiennoprzecinkowego.


4.8.6. Debugowanie zapytań

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.7 Debugowanie zapytań

4.8.7. Debugowanie zapytań

Zakładka Diagnostyka - debug określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka - debug'.

  • Debugowanie zapytań - opcja załącza wpisywanie do logu informacji o zapytaniach modułu sieciowego dla zmiennych debugowanych;

Wartość domyślna: opcja wyłączona

  • Zmienne debugowane - opcja umożliwia deklarowanie zmiennych debugowanych;

- Podanie samej nazwy zmiennej powoduje śledzenie wszystkich zdarzeń dla danej zmiennej i jej agregatów;

- Podanie nazwy i typu archiwum oddzielonych przecinkiem (np. "A000,D") powoduje śledzenie tylko podanego typu archiwum zmiennej, bez śledzenia innych archiwów i agregatów;

- Podanie nazwy z pełną specyfikacją agregatu (tak jak pojawia się w logach, np. " A000,M-1m-Avg) powoduje śledzenie tylko tego agregatu.

Wartość domyślna: brak zadeklarowanych zmiennych


4.8.7 Parametryzacja cyklicznego pobierania danych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.8 Parametryzacja cyklicznego pobierania danych historycznych

4.8.8 Parametryzacja cyklicznego pobierania danych historycznych dla wybranych drajwerów komunikacyjnych

Niektóre drajwery systemu Asix umożliwiają pobieranie przez aplikację brakujących danych historycznych z urządzeń (które same w sobie archiwizują wartości pomiarów) lub z zewnętrznej bazy danych. Dane historyczne udostępniane są przez następujące drajwery: Baza, DMS285, DMS500, Talas, Macmat, DataPAF, Mevas.

Parametryzacja sposobu pobierania danych historycznych odbywa się przy użyciu opcji znajdujących się na zakładce Pobieranie danych historycznych:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Pobieranie danych historycznych'.

  • Czas pierwszego pobierania - opcja ta określa, po jakim czasie od rozpoczęcia bieżącej archiwizacji należy wystartować pierwsze wypełnianie dziur;

Wartość domyślna: 10 sekund

uwaga W procesie uzupełniania danych potrzebna jest informacja o tym, jaka jest długość dziury w archiwum wynikłej z ostatniego wyłączenia archiwizacji; dla uzyskania tej informacji niezbędne jest pozyskanie pierwszego punktu po tej dziurze; czas zadany w tym miejscu ma pozwalać na pozyskanie pierwszej danej dla każdej zmiennej.

  • Okres pobierania - pozwala określić, jak często należy włączać uzupełnianie dziur w archiwum:

  • Długość cyklu i Faza cyklu - są to parametry, które określają częstotliwość prób uzupełniania dziur w archiwum – np.: 5m, 30s oznacza, że 30 sekund po każdych pełnych pięciu minutach nastąpi próba wypełniania dziur w archiwum;

Wartość domyślna: dla długości cyklu równej 1 godzina i fazy cyklu 5 minut uzupełnianie archiwum będzie miało miejsce 5 minut po każdej pełnej godzinie; długość cyklu liczona jest według czasu UTC.

  • Horyzont wypełniania dziur - to dodatkowy, opcjonalny parametr, który określa jak daleko wstecz należy próbować uzupełnić dane historyczne; horyzont ten nie jest uzależniony od tego, czy próba uzupełniania była już wcześniej przeprowadzona; jest to potrzebne w przypadku źródeł danych, w których dane historyczne mogą pojawić się z opóźnieniem; w przypadku braku tego parametru - brak danych historycznych w źródle danych powoduje, że zostają zaniechane próby ich ponownego odzyskania;

Wartość domyślna: brak


4.8.9 Parametryzacja archiwum

W przypadku stosowania archiwizacji wartości zmiennych niezbędne jest zadeklarowanie archiwum.

Archiwum deklarowane jest za pomocą polecenia Dodaj archiwum... po kliknięciu prawym klawiszem myszki na pozycji Dane archiwalne. Pojawia się wówczas okno ’Dodawanie nowego archiwum’, gdzie należy określić nazwę archiwum.

powiększ >>

Rysunek: Wywołanie okna 'Dodawanie nowego archiwum'.

Aspad gromadzi dane w plikach zawierających przebiegi z jednego okresu dobowego, miesięcznego lub rocznego odpowiednio do typu archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

Patrz: część "Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji", rozdział 7.1.3. Podstawowe rodzaje i typy archiwum Aspada, 7.8. Archiwizacja typu B.

Podstawowym rodzajem archiwum jest STANDARD. Archiwum to jest zapisywane w binarnych plikach na dysku.

Drugim rodzajem archiwum jest MS SQL. Jest to archiwum zapisywane w bazie danych SQL.

Można jeszcze wyróżnić podział archiwum ze względu na sposób udostępniania danych:

Archiwum do zapisu - podstawowe archiwum pozwalające na zapis i odczyt danych z plików archiwalnych;

Archiwum do odczytu - to archiwum pozwalające tylko na odczyt danych z plików archiwalnych;

Archiwum sieciowe - to archiwum pozwalające na odczyt danych przez sieć z innego komputera;

Archiwum pomocnicze - to archiwum pozwalające na zapis i odczyt danych, służące jako redundancja archiwum podstawowego na innym komputerze;

Archiwum replikowane - to archiwum pozwalające na zapis i odczyt danych z archiwum; dane do archiwum pobierane są z archiwum innego komputera.

Aby skonfigurować archiwum przy użyciu modułu Architekt, należy zaznaczyć w drzewie parametrów aplikacji pozycję Dane archiwalne i kliknąć prawym klawiszem myszki - a następnie wybrać polecenie Dodaj archiwum.

Po kliknięciu na utworzonym archiwum w oknie konfiguracji parametrów pojawią się zakładki, umożliwiające skonfigurowanie danego archiwum.

Archiwum pomocnicze jest to archiwum do zapisu umieszczane na serwerze pomocniczym danego zasobu. Archiwum pomocnicze powinno stanowić redundancję archiwum podstawowego na serwerze podstawowym. Różnica między archiwum pomocniczym a archiwum podstawowym polega na preferencjach dla archiwum podstawowego podczas przyłączania klientów sieciowych. Klient przyłączy się do archiwum pomocniczego tylko wtedy, gdy w sieci nie znajdzie archiwum podstawowego.

Archiwum pomocnicze jest stosowane w celu zapewnienia tymczasowej redundancji na czas konserwacji lub awarii serwera podstawowego. Można np. zadeklarować archiwum podstawowe ze 100-dniowym horyzontem i archiwum pomocnicze z horyzontem 10-dniowym. Pozwoli to na uzupełnienie archiwum podstawowego za okres przerwy nie przekraczającej 10 dni, przy czym w obecności serwera podstawowego klienty przyłączą się do niego, zapewniając obserwację danych z horyzontem 100-dniowym.

Archiwum replikowane ma zastosowanie na serwerach, na których Asmen nie posiada kanałów fizycznych dla danych archiwizowanych w danym zasobie, a równocześnie w sieci dostępne jest inne archiwum, z którego można pozyskać dane historyczne. Dla archiwum replikowanego Aspad nie pobiera danych bieżących z Asmena. W zamian stale pozyskuje dane historyczne z innego serwera, na którym archiwizowane są dane z kanałów fizycznych, zapisując je we własnym archiwum. Typowym zastosowaniem będą serwery pośredniczące.

Sposób działania nieco się różni dla archiwum standardowego i SQL.

Archiwum standardowe

Dla archiwum standardowego Aspad po uzupełnieniu danych przy starcie systemu, kontynuuje to uzupełnianie, cyklicznie sprawdzając nowe dane pojawiające się na drugim serwerze. Nawet dłuższe przerwy w komunikacji są na bieżąco nadrabiane po uzyskaniu łączności, aż do ograniczenia podanego w deklaracji Minimalny okres uzupełniania na zakładce Uzupełnianie w parametrach danego archiwum.

Także na wspomnianej zakładce Uzupełnianie można określić nazwy serwerów, z których mają być pobierane dane do replikacji.

Deklaracja Bez uzupełniania na zakładce Uzupełnianie dla takiego archiwum nie ma sensu i jest ignorowana.

Archiwum SQL

Jeżeli dla danego zasobu nie podano deklaracji synchronizacji archiwum SQL, to archiwum replikowane działa tak samo, jak standardowe.

Jeżeli podano deklarację SYNCHRO, to dane są tylko synchronizowane na poziomie baz danych SQL, a wyłączone jest zarówno pobieranie danych bieżących z Asmena, jak i uzupełnianie przez Aslinka, tak jakby zadeklarowano opcję Bez uzupełniania na zakładce Uzupełnianie w parametrach danego archiwum.

Synchronizacja ma tę przewagę nad zwykłym uzupełnianiem, że uwzględnia wszystkie zmiany w archiwum, także dane historyczne dopisywane lub zmieniane z opóźnieniem.


4.8.8.1 Parametry standardowe

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.1 Parametry standardowe

4.8.9.1 Parametry standardowe

Zakładka Standardowe obejmuje następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Standardowe'.

  • Archiwum:

  • Nazwa - nazwa logiczna archiwum (zasobu);

Wartość domyślna: Archiwum1

  • Typ archiwum ze względu na sposób udostępniania danych:

(archiwum lokalne):

’Archiwum do zapisu’

’Archiwum do odczytu’

’Archiwum pomocnicze’

’Archiwum replikowane’

lub

’Archiwum sieciowe’

Wartość domyślna: ’Archiwum do zapisu’

  • Rodzaj archiwum:

’STANDARD’

’MS SQL’

Wartość domyślna: ’STANDARD’

Archiwa STANDARD

Archiwa STANDARD wymagają podania dodatkowych parametrów, których prawidłowe określenie ułatwia okno uruchamiane przyciskiem rozwin 2:

Rysunek: Okno parametryzacji archiwów STANDARD.

  • Kartoteka archiwum - względna lub bezwzględna ścieżka do kartoteki, w której będą gromadzone pliki archiwalne;

Wartość domyślna: brak

  • Okres przechowywania plików archiwalnych - okres przechowywania plików archiwalnych odpowiednio typu D, M, Y, przy czym:

min określa liczbę dni, po zakończeniu okresu danego pliku, przez które nie wolno automatycznie kasować pliku, nawet gdy brak miejsca na dysku (domyślnie 1),

max określa liczbę dni, po których plik należy usunąć (domyślnie 0, co jest interpretowane jako nieskończoność).

  • Okres przechowywania danych archiwalnych [dni] - okres przechowywania danych archiwalnych archiwum typu H, przy czym:

min określa minimalną liczbę dni przechowywania danych,

max określa liczbę dni przechowywania danych (0 interpretowane jest jako nieskończoność).

uwaga UWAGA: Deklaracja ma pierwszeństwo przed deklaracjami poszczególnych zmiennych w bazie definicji zmiennych. Jeśli wartość minimalna jest większa lub maksymalna mniejsza niż wartość podana w bazie, to użyta będzie wartość podana w edytorze.

Archiwa MS SQL

Archiwa MS SQL wymagają podania dodatkowych parametrów, których prawidłowe określenie ułatwia okno uruchamiane przyciskiem rozwin 2:

Rysunek: Okno parametryzacji archiwów MS SQL.

  • Nazwa_serwera - względna lub bezwzględna ścieżka do kartoteki, w której będą gromadzone pliki archiwalne;

nazwa instancji serwera SQL, na którym znajduje się lub zostanie utworzona baza danych; jeżeli ten parametr jest pusty, to zostanie wykorzystany lokalny serwer (istnieje też możliwość deklaracji serwera LOCAL, co jest równoważne pustej nazwie serwera w deklaracji archiwum);

nazwa instancji ma postać:

nazwa_systemowa_komputera - dla podstawowej instancji serwera lub

nazwa_systemowa_komputera\nazwa_instancji - dla nazwanej instancji;

Wartość domyślna: brak

  • Baza danych - nazwa bazy danych po stronie serwera; jeżeli ten parametr jest pusty, to nazwa bazy danych = ASSQL_nazwa_zasobu;

ta nazwa nie może się powtarzać dla różnych archiwów na tym samym serwerze SQL, ale może się powtarzać w różnych deklaracjach, jeżeli dotyczą one wielu serwerów

Wartość domyślna: brak

  • Parametry opcjonalne:

-XT, +XT - archiwizacja czasu danej - określa, czy w bazie danych będzie archiwizowany czas dokładny danej (+XT), czy też jedynie czas zaokrąglony do pełnego cyklu próbkowania (-XT) (wyjątkiem są dane, dla których zadeklarowano atrybut KAŻDY - dla takich danych czas nie jest zaokrąglany do cyklu próbkowania);

włączenie opcji powoduje dodanie 8-bajtowego pola do każdego rekordu danych;

Wartość domyślna: +XT - czas jest archiwizowany;

-WT, +WT - archiwizacja czasu dokonania zapisu - określa, czy w bazie danych będzie archiwizowany czas dokonania zapisu;

włączenie opcji powoduje dodanie 8-bajtowego pola do każdego rekordu danych;

Wartość domyślna: -WT - czas zapisu jest pomijany;

-VT, +VT - archiwizacja czasu ważności próbki - określa, czy w bazie danych będzie archiwizowany czas ważności próbki (+VT), czy też na być pomijany, a domyślnym czasem ważności ma być okres archiwizacji (-VT); w efekcie, dla -VT, gdy zostanie w przyszłości skrócony okres archiwizacji, to dane historyczne będą oddzielone dziurami; domyślnie czas ważności jest archiwizowany;

włączenie opcji powoduje dodanie 4-bajtowego pola do każdego rekordu danych;

Wartość domyślna: +VT - czas ważności jest archiwizowany;

-SV, +SV - liczba bajtów identyfikatora przebiegu - określa, czy identyfikator przebiegu zmiennej ma mieć 2 (+SV), czy 4 (-SV) bajty; dla +SV baza danych nie może zawierać więcej niż 32767 zmiennych na zasób (wlicza się w to zmienne kiedyś zadeklarowane, później usunięte);

wyłączenie opcji powoduje, dla każdego rekordu danych, zwiększenie pola identyfikatora przebiegu o 2 bajty w danych i o 2 bajty w indeksie bazy;

Wartość domyślna: +SV - używane są małe identyfikatory;

-SD, +SD - liczba bajtów identyfikatora rekordów - określa, czy identyfikator rekordu danych ma mieć 4 (+SD), czy 8 (-SD) bajtów; dla +SD do bazy nie można zapisać więcej niż 2 miliardów (231) rekordów danych na zasób (wlicza się w to każdy zapis i zmianę rekordu nawet, gdy zostanie on usunięty);

wyłączenie opcji powoduje, dla każdego rekordu danych, zwiększenie pola identyfikatora rekordu o 4 bajty w danych i o 4 bajty w indeksie bazy;

Wartość domyślna: +SD - używane są małe identyfikatory.

uwaga Dla baz danych zadeklarowanych jako MSSQL rekord zawiera dla każdej próbki domyślnie wartość, jakość, czas cyklu, czas dokładny, czas zapisu rekordu i okres ważności próbki. Tylko czas cyklu należy do klucza bazy danych. Trzy pierwsze pola są obowiązkowe.

uwaga Dla raz utworzonej bazy danych nie wolno zmieniać pól opcjonalnych w deklaracji, gdyż nie będą one wtedy odpowiadały strukturze tablic bazy danych.

  • Okres przechowywania danych archiwalnych [dni] - okres przechowywania danych archiwalnych archiwum typu H, przy czym:

min określa minimalną liczbę dni przechowywania danych,

max określa liczbę dni przechowywania danych (0 interpretowane jest jako nieskończoność).

uwaga UWAGA: Deklaracja ma pierwszeństwo przed deklaracjami poszczególnych zmiennych w bazie definicji zmiennych. Jeśli wartość minimalna jest większa lub maksymalna mniejsza niż wartość podana w bazie, to użyta będzie wartość podana w edytorze.

Archiwa sieciowe

Archiwa sieciowe wymagają podania stacji, do których wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego lub odczycie archiwum zdalnego. Deklaracja stacji odbywa się za pomocą okno uruchamianego przyciskiem rozwin 2:

Rysunek: Okno deklaracji stacji przy odczycie archiwum zdalnego.

  • Komputery:

’Wszystkie’

’Tylko z listy’

’Wszystkie za wyjątkiem listy’

  • Lista nazw sieciowych serwerów danych - pozwala zadeklarować stacje, z których nie można sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego lub odczycie archiwum zdalnego.

Wartość domyślna: ’Wszystkie’

  • Czas UTC - deklaracja determinuje archiwizowanie zasobu zgodnie z czasem UTC;

uwaga Jeżeli deklarujemy takie zasoby, to ustawienia systemowe strefy czasowej MUSZĄ zawierać poprawną strefę z zaznaczoną automatyczną zmianą czasu letniego/zimowego. W przeciwnym razie czas będzie zapisywany niepoprawnie.

Jeżeli w już archiwizowanym zasobie deklarujemy Czas UTC, to trzeba skonwertować dotychczasowe archiwum. Dla archiwum standardowego można to wykonać przy pomocy specjalnej funkcji AspadTools. Trzeba pamiętać o sekwencyjnym przetwarzaniu plików archiwalnych - najlepiej konwertując wszystkie jednym poleceniem.

Gdy nie zostanie zadeklarowany czas UTC, to komunikacja pomiędzy ASPADami odbywa się w czasie lokalnym i nie jest wrażliwa na niewłaściwe ustawienia stref czasowych.

Jeżeli na serwerze zadeklarowano czas UTC, to na kliencie też musi zostać zadeklarowany czas UTC.

  • Archiwum nieaktywne - zmienne należące do archiwum nieaktywnego: nie są archiwizowane, nie są liczone do limitu licencji, jeśli jednocześnie nie należą do kanałów fizycznych.

Przykłady deklaracji archiwum MS SQL:

Deklaracja archiwum do zapisu dla zasobu MojeArchiwum, na lokalnym serwerze, w bazie danych ASSQL_MojeArchiwum, bez archiwizacji czasu zapisu rekordu:

Archiwum do zapisu

Nazwa: ’MojeArchiwum’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: -

Baza danych: -

Deklaracja archiwum do zapisu dla zasobu MojeArchiwum, na lokalnym serwerze, w bazie danych MojeArchiwum, bez archiwizacji czasu zapisu rekordu:

Archiwum do zapisu

Nazwa: ’MojeArchiwum’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: -

Baza danych: ’MojeArchiwum’

Deklaracja archiwum do odczytu dla zasobu ’ArcSrv1’, na serwerze ’Srv1’, w bazie ’ASSQL_Arc’ z pełnym rekordem:

Archiwum do odczytu

Nazwa: ’ArcSrv1’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: ’Srv1’

Baza danych: ’ASSQL_Arc’

Archiwizacja czasu dokonania zapisu: R


4.8.8.2 Parametry archiwizacji agregatow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.2 Parametry archiwizacji agregatów

4.8.9.2 Parametry archiwizacji agregatów

Zakładka Agregaty umożliwia parametryzację Agregatora - modułu systemu Asix przeznaczonego do wyliczania i archiwizacji danych statystycznych. Domyślnie funkcja jest załączona z rekomendowanymi ustawieniami.

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Agregaty'.

  • Lista okresów - pole umożliwia zadeklarowanie listy okresów agregacji, będących podstawą wyliczania wartości zagregowanych; wartości okresów należy deklarować w konwencji modułu Aspad, oddzielając je pionowymi liniami, np.: 5m|1h stanowi podstawę wyliczania agregatów 5-minutowych i 1-godzinnych;

  • Lista agregatów - pole, w którym należy określić agregaty, które będą wyliczane i archiwizowane; po rozwinięciu pola pojawia się okno umożliwiające selekcję agregatów z listy agregatów dostępnych w systemie Asix;

  • Horyzont agregacji - oznacza okres, z którego dane będą agregowane; wartość horyzontu należy deklarować w konwencji modułu Aspad, np.: 366d - oznacza, że nie będą archiwizowane dane starsze niż rok.

Przycisk Ustaw wartości rekomendowane pozwala ustawić okresy danych 1m,1h oraz wszystkie agregaty. Wymienione opcje ustawiane są domyślnie przy tworzeniu nowego archiwum.


4.8.8.3 Zarzadzanie uzupelnianiem danych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.3 Zarządzanie uzupełnianiem danych

4.8.9.3 Zarządzanie uzupełnianiem danych

Zakładka Uzupełnianie pozwala określić następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Uzupełnianie'.

  • Bez uzupełniania - włączenie opcji spowoduje zakaz uzupełniania danych dla danego archiwum (zasobu);

Wartość domyślna: opcja wyłączona

  • Ograniczenia uzupełniania - pozwala zawęzić listę stacji, z których Aspad będzie uzupełniał dane; pod warunkiem, ze opcja Bez uzupełniani jest wyłączona:

  • Uzupełniaj dane tylko z serwerów wymienionych na liście - lista nazw stacji, do których wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego; pominięcie tej deklaracji oznacza akceptację dowolnego serwera dysponującego określonym zasobem.

  • Uzupełniaj dane ze wszystkich stacji za wyjątkiem wymienionych na liście - lista nazw stacji, do których nie wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego.

Wartość domyślna: dane uzupełniane są z dowolnego serwera dysponującego danym zasobem

  • Minimalny okres uzupełniania - używając opcji można wydłużyć okres czasu, z którego archiwa mają być uzupełniane.

Wartość domyślna: uzupełniany jest bieżący i poprzedni plik archiwum.


4.8.8.4. Zarzadzanie odczytem danych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.4. Zarządzanie odczytem danych

4.8.9.4. Zarządzanie odczytem danych

Zakładka Zarządzanie pozwala określić następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Zarządzanie'.

  • Ograniczenie odczytu - opcja pozwala ustalić tryb pracy, w którym określone stacje mogą korzystać z danego archiwum:

Tryb pracy:

  • Tylko stacje wymienione na liście mogą korzystać z tego archiwum;

  • Wszystkie stacje oprócz wymienionych na liście mogą korzystać z danego archiwum;

Nazwy sieciowe stacji należy wpisać, oddzielając je przecinkami.

Wartość domyślna: nie ma ograniczeń dotyczących odczytu.


4.8.8.5 Parametry okreslajace sposob tworzenia kopii zapasowej

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.5 Parametry określające sposób tworzenia kopii zapasowej

4.8.9.5 Parametry określające sposób tworzenia kopii zapasowej archiwum

Zakładka Kopia dotyczy opcji:

Rysunek: Okno parametrów archiwum - zakładka 'Kopia'.

  • Kopia - parametryzuje sposób tworzenia kopii zapasowych:

Wartość domyślna: kopia zapasowa nie jest tworzona

  • Ścieżka do katalogu archiwum lub nazwa archiwum - pozwala zadeklarować bezpośrednio katalog docelowy, w którym będzie tworzona kopia archiwum, bądź też dla zachowania kompatybilności ze starszą formą deklarowania kopii zapasowych - nazwę archiwum, w którym tworzona będzie kopia zapasowa (wcześniejsza forma deklarowania kopii zapasowej zakładała bowiem utworzenie dodatkowego archiwum pomocniczego, które następnie deklarowane było jako miejsce docelowe tworzenia kopii zapasowej innego archiwum); aktualnie w przypadku wyboru archiwum po nazwie możliwy jest wybór wszystkich archiwów standardowych, a nie tylko pomocniczych.

Wartość domyślna: brak

  • Długość cyklu - zadaje jak często inicjować tworzenie kopii zapasowych;

Wartość domyślna: 1 dzień

Rysunek: Pole deklaracji długości cyklu inicjowania tworzenia kopii zapasowych.

  • Faza cyklu - określa, z jakim opóźnieniem w stosunku do pełnego cyklu inicjować tworzenie kopii;

Wartość domyślna: 1 godzina i 30 minut

  • Typ i liczba kopiowanych plików - pozwala określić, jakiego typu pliki należy kopiować i ile ostatnich plików danego typu kopiować:

  • Pliki archiwum dobowego (D),

  • Pliki archiwum miesięcznego (M),

  • Pliki archiwum rocznego (Y),

  • Pliki archiwum z horyzontem.

Wartość domyślna: brak deklaracji typu

  • Wykonaj jako podany użytkownik

uwaga Dla jednego zasobu można zadeklarować kilka archiwów, do których tworzone będą kopie - co pozwala np. na kopiowanie plików dobowych w inne miejsce niż miesięcznych.


4.8.8.6 Deklaracja synchronizacji zawartosci archiwum typu B z

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.6 Deklaracja synchronizacji zawartości archiwum typu B z danymi w bazie MS SQL

4.8.9.6 Deklaracja synchronizacji zawartości archiwum typu B z danymi w bazie MS SQL

uwaga Synchronizacja powoduje kopiowanie przyrostowe. Kopiowane są tylko dane, które zostały dopisane lub zmienione w archiwum źródłowym od ostatniego kopiowania. W przypadku konfliktu z już istniejącymi danymi w archiwum docelowym znajdą się dane o lepszej jakości. W przypadku danych o tej samej jakości preferowane są dane wprowadzane ręcznie.

Można podać wiele deklaracji synchronizacji, także dla jednego zasobu, co pozwala np. na uzupełnianie danych z kilku bliźniaczych serwerów.

Deklaracja synchronizacji archiwum MS SQL z danymi innego archiwum wymaga podania w parametrach synchronizacji (w parametrach archiwum, którego zawartość będzie synchronizowana) nazwy serwera SQL, z którego będą pobierane dane do synchronizacji. Wymagane jest przy tym, aby nazwy obu baz danych były identyczne.

Deklaracji takiej dokonuje się na zakładce Synchronizacja:

Rys. Okno parametrów archiwum - zakładka 'Synchronizacja'.

  • Nazwa archiwum lub serwera SQL - nazwa serwera SQL, z którego będą pobierane dane do synchronizacji lub nazwa archiwum, z którego pobierane będą dane do synchronizacji w przypadku deklaracji dodatkowego 'wirtualnego' archiwum, gdy nazwy baz danych (archiwum synchronizowanego i archiwum, z którym realizowana jest synchronizacja) różnią się - poniżej patrz przypadek z nazwą archiwum;

Wartość domyślna: brak deklaracji synchronizacji.

  • Synchronizacja przy starcie systemu - włączenie tej opcji powoduje jednorazową synchronizację przy starcie systemu.

  • Synchronizacja cykliczna - włączenie tej opcji powoduje synchronizację cykliczną.

  • długość cyklu - określa, jak często inicjować dopisywanie danych; w przypadku, gdy jako parametr cykl zostanie podana wartość 0, synchronizacja nie będzie wykonywana cyklicznie, a wówczas przedmiotowa deklaracja będzie wykorzystywana tylko jako deklaracja dla akcji operatorskiej SYNCHRONIZUJ_ARCHIWUM; wartość domyślna parametru cykl: 24 godz.;

  • faza cyklu - określa, z jakim opóźnieniem w stosunku do pełnego cyklu inicjować kopiowanie danych; wartość domyślna: 0.

  • Archiwum master - opcja powoduje, że przy zapisie do takiego archiwum na komputerze, na którym podano tę opcję, dane opatrywane są dodatkowym statusem AS_STAT_MASTER. Dla każdego archiwum na co najwyżej jednym z komputerów w sieci można podać taka opcję. Przy synchronizacji dane opatrzone statusem AS_STAT_MASTER są traktowane jako ważniejsze niż dane o tej samej jakości, ale bez tego statusu. Dzięki temu synchronizacja nie tylko wypełnia dziury w archiwum oraz zastępuje dane o gorszym statusie tymi o lepszym, ale także uzgadnia rekordy o różnych wartościach, a tej samej jakości, preferując dane z archiwum MASTER.

Rysunek: Przykład deklaracji synchronizacji archiwum X z archiwum Y przy założeniu identycznych nazw baz danych obu archiwów.

W sytuacji gdy nazwy baz danych obu archiwów różnią się, dla stacji operatorskiej, której archiwum będzie synchronizowane należy skonfigurować dodatkowe 'wirtualne' archiwum do odczytu, ze wskazaniem nazwy serwera i nazwy bazy danych MS SQL archiwum, z którym dane mają być synchronizowane (pozostałe parametry w konfiguracji 'wirtualnego' archiwum nie mają znaczenia).

Rysunek: Przykład deklaracji synchronizacji archiwum X z archiwum Y przy założeniu rożnych nazw baz danych obu archiwów.


4.8.8.7. Deklaracja wartosci o okreslonym_statusie

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.9 Parametryzacja archiwum > 4.8.9.7. Deklaracja wartości o określonym statusie

4.8.9.7. Deklaracja wartości o określonym statusie

Zakładka Zaawansowane pozwala skonfigurować archiwizację wartości w zależności od statusu:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Zaawansowane'.

  • Zapis wartości o określonym statusie - określa status wartości, które będą archiwizowane

Wartość domyślna: domyślnie archiwizowane są tylko wartości o statusie dobrym.

  • Domyślna wersja plików archiwum standardowego - opcja definiuje wersję plików archiwum standardowego dla bieżącego archiwum:

Wersja 1 - zgodna z wersjami Asix od 5.0 do 7.0 (Aspad 6 i 7).

Wersja 2 - dostępna od wersji Asix 7.1 (Aspad 8).

W wersji 2 archiwum obsługiwane są długie nazwy zmiennych, nazwy zmiennych zawierające znaki UNICODE oraz archiwizacja z pełną precyzją liczb typu Double i Int64.

OSTRZEŻENIE: Uruchomienie aplikacji przy użyciu Asixa w wersji 7.0 lub wcześniejszej z plikami archiwum w wersji 2 spowoduje uszkodzenie tych plików.

INFORMACJE DODATKOWE:

Sprawny odczyt sieciowy archiwum w wersji 2 w obiektach Wykres, Skryptach oraz uzupełnianiu danych lub replikacji jest możliwy tylko przy użyciu Aspada 8 (Asix 7.1) lub nowszego.

W Asixie 5.2 lub starszym odczyt sieciowy archiwum w wersji 2 nie jest możliwy.

W pozostałych wersjach Asixa konieczna jest aktualizacja Aspada dedykowana dla danego pakietu, a wydajność odczytu będzie zmniejszona.

Obniżenie wydajności przy łączeniu się starszych Aspadów z nowym np. przy replikacji lub uzupełnianiu, wynika z tego, że nie mogą wtedy przesyłać danych w postaci skompresowanej, a tylko po dekompresji, co powoduje zmniejszoną wydajność operacji sieciowych. Jeszcze starsze Aspady (z Asixa 5.2) nie potrafią w tej sytuacji przesyłać ani danych skompresowanych, ani zdekompresowanych.

W przypadku programów: AsixConnectowi i Trendom jest wszystko jedno, czy łączą się z Aspadem 7 czy 8 i czy archiwum jest w wersji 1 czy 2.


4.8.9. Zarzadzanie archiwami

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.10. Zarządzanie archiwami

4.8.10. Zarządzanie archiwami

W menu uruchamianym po kliknięciu prawym klawiszem myszki na pozycji Dane archiwalne dostępne jest również polecenie Zarządzaj archiwami, umożliwiające masowe kopiowanie, usuwanie archiwów pomiędzy komputerami/obszarami oraz zmiana typu archiwum (do zapisu, do odczytu, pomocnicze, sieciowe).

powiększ >>

Rysunek: Okno 'Zarządzanie archiwami'.


4.9 Konfiguracja systemu alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów

4.9 Konfiguracja systemu alarmów

System A six posiada wbudowany, elastyczny system obsługi alarmów, który pozwala na pełne zaspokojenie potrzeb związanych z kompleksową obsługą sytuacji awaryjnych i zdarzeń w procesie technologicznym.

Opis systemu alarmów znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale System alarmów.

Ogólnie system alarmów można podzielić na dwie części:

  • jądro systemu, które odpowiedzialne jest za wykrywanie, zapamiętywanie i definicje alarmów;

  • cześć wizualizacyjną, którą stanowią dwa typy masek alarmowych (alarmów aktywnych i historycznych).

Konfiguracja jądra systemu opiera się na odpowiednim zdefiniowaniu parametrów w pliku konfiguracyjnym XML aplikacji oraz na utworzeniu plików tekstowych zawierających dodatkowe informacje.

Dodatkowe parametry określane są w plikach tekstowym. Są to:

  • pliki definicji alarmów,

  • pliki definicji grup,

  • pliki definicji limitów.

Zamiast wspomnianych wyżej plików tekstowych, definicje alarmów i definicje grup można przygotować w arkuszu kalkulacyjnym Excel i na jego podstawie wygenerować bazę definicji alarmów (patrz: 4.9.1.1 . Przygotowanie definicji alarmów i grup alarmów w arkuszu kalkulacyjnym Excel).

Bieżący stan oraz historia alarmów przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowane inne rozwiązanie). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można ograniczyć okres przechowywania plików alarmów.

Większość parametrów dotyczących alarmów konfigurowana jest przez moduł Architekt w grupie parametrów aplikacji: system alarmów System alarmów.


4.9.1 Okreslenie trybu tworzenia bazy definicji alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.1 Określenie trybu tworzenia bazy definicji alarmów

4.9.1 Określenie trybu tworzenia bazy definicji alarmów

Tryb pracy bazy definicji alarmów określany jest w:

moduł Bazy danych > Baza definicji alarmów > zakładka Typ

Definicje alarmów w systemie Asix tworzone są w plikach tekstowych (przygotowanych przez projektanta lub wygenerowanych z arkusza kalkulacyjnego). Istnieje też możliwość wygenerowania bazy definicji alarmów - w formacie bazy SQL lub MDB (Jet/MS Access) jako elementu bazy definicji zmiennych (Uwaga: Jeśli baza definicji zmiennych nie istnieje - tworzony jest szablon pustej bazy definicji zmiennych).

Wymaga to załączenia opcji Baza definicji alarmów jest generowana z arkusza kalkulacyjnego na zakładce Typ wraz z opcją Dodaj bazę definicji alarmów do bazy definicji zmiennych na zakładce Źródła danych, a następnie wskazania na zakładce Źródła danych arkusza kalkulacyjnego z definicjami alarmów i definicjami grup alarmów oraz obszaru/komputera identyfikującego nazwę sieciową zestawu alarmów.

Definicje alarmów przechowywane w bazie definicji zmiennych wykorzystywane są przez programy: AsAlarm, AsTrend oraz AsRaport - środowisko tworzenia raportów w technologii MS Reporting Services.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Typ'.

  • Jeśli tekstowe pliki definicji alarmów są edytowane przez projektanta - nazwy tych plików należy zadeklarować w oknie definiowania parametrów obszarów i komputerów, w module System alarmów na zakładce Alarmy / Baza definicji alarmów. Dodatkowo, można wygenerować na ich podstawie bazę definicji alarmów, która domyślnie zostanie dołączona do bazy definicji zmiennych - należy w tym celu w oknie definiowania baz danych, w kategorii Baza definicji alarmów, na zakładce Źródła danych wskazać pliki tekstowe z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący nazwę sieciową zestawu alarmów i wykonać operację generowania bazy z pomocą przycisku Generuj.

Rys. Generowanie bazy definicji alarmów z plików tekstowych.

  • Jeśli baza generowana jest z arkuszy kalkulacyjnych - definicje alarmów i grup alarmów umieszczane są w plikach tekstowych o rozszerzeniach - odpowiednio: .gdf i .adf. Pliki te automatycznie ładowane są na starcie aplikacji systemu Asix. Możliwe jest tez dołączenie wygenerowanych definicji alarmów i grup alarmów do bazy definicji zmiennych. Na zakładce Źródła danych należy wskazać pliki tekstowe z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący nazwę sieciową zestawu alarmów i wykonać operację generowania bazy z pomocą przycisku Generuj (pamiętając o załączeniu opcji Dodaj bazę definicji alarmów do bazy definicji zmiennych w razie potrzeby).

Rys. Generowanie bazy definicji alarmów z arkuszy kalkulacyjnych.

  • W przypadku generowania zbiorczej bazy definicji alarmów na podstawie baz z aplikacji konfigurowanych plikiem XML lub INI (w starszych wersjach systemu Asix) - zbiorcza baza definicji alarmów zostanie domyślnie dołączona do bazy definicji zmiennych.

Rys. Generowanie bazy definicji alarmów z kilku baz.


4.9.1.1 Przygotowanie definicji alarmow i grup alarmow w

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.1 Określenie trybu tworzenia bazy definicji alarmów > 4.9.1.1 Przygotowanie definicji alarmów i grup alarmów w arkuszu Excel

4.9.1.1 Przygotowanie definicji alarmów i grup alarmów w arkuszu kalkulacyjnym Excel

W przypadku, gdy źródłem danych niezbędnych do wygenerowania bazy definicji alarmów jest arkusz Excel, dane muszą znajdować się w arkuszach w formacie XLS lub XLSX. Arkusze mogą być tworzone programem Microsoft Excel (od wersji 97) lub programem Open Office (w wersji 1.1.2 lub późniejszej).

Arkusz z definicją alarmów musi mieć nazwę Alarmy i zawierać następujące kolumny:

  • Numer - unikalny numer alarmu;

  • Typ - typ alarmu (SYSTEMOWY, KOMUNIKAT, OSTRZEŻENIE, ALARM, WAŻNY, IGNOROWANY);

  • TekstPoczątku - tekst wyświetlany w momencie wykrycia alarmu;

  • TekstKońca - tekst wyświetlany dla alarmów, które zostały zakończone. Brak podania tego tekstu oznacza, że ma być używany tekst jak dla początku alarmu;

  • IdGrupy - maksymalnie 4-znakowy identyfikator grupy, do której należy alarm;

  • NazwaMaski - nazwa sugerowanej maski;

  • Wydruk - zezwolenie lub blokada (DRUKUJ, NIE_DRUKUJ) liniowego wydruku alarmów.

Rysunek: Arkusz definicji alarmów.

Kolumna Wydruk pozwala określić alarmy, które będą drukowane w przypadku zadeklarowania bieżącego wydruku alarmów.

Bieżący wydruk alarmów aktywowany jest parametrem Wydruk alarmów:

Moduł Obszary i komputery > Wydruk > zakładka Wydruk alarmów: zakładka Nagłówki i stopki, Czcionki, Opcje

Jeśli zostanie zadeklarowany parametr Wydruk alarmów bez podawania nazwy drukarki w polu Drukarka, wykorzystywana będzie domyślna drukarka systemowa. Parametr Drukarka pozwala na indywidualny wybór drukarki dedykowanej do wydruku alarmów.

Arkusz z definicją grup alarmów musi mieć nazwę Grupy i zawierać następujące kolumny:

  • IdGrupy - maksymalnie 4-znakowy identyfikator grupy, służący do identyfikacji grup w definicjach alarmów,

  • OpisGrupy - dowolny tekst opisujący grup; tekst ten będzie wyświetlany w liście grup okna selekcji alarmów; brak tekstu spowoduje użycie w liście wyboru identyfikatora grupy;

  • Wydruk.- zezwolenie lub blokada (DRUKUJ, NIE_DRUKUJ) liniowego wydruku alarmów należących do danej grupy.

Rysunek: Arkusz definicji grup alarmów.

Aby przyśpieszyć etap przygotowania arkuszy z definicjami alarmów i grup alarmów, Architekt udostępnia funkcję generowania szablonu skoroszytu zawierającego wszystkie potrzebne arkusze, kolumny w arkuszach i przykładowe definicje alarmów:

Moduł Bazy danych > Baza definicji alarmów > zakładka Szablon > wygenerowany plik nosi domyślną nazwę ’SzablonBazyDefinicjiAlarmów.xls’

(zakładka Szablon dostępna jest przy załączonym trybie pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z arkuszy kalkulacyjnych zawierających definicje alarmów)


4.9.1.2 Generowanie bazy definicji alarmow z arkusza

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.1 Określenie trybu tworzenia bazy definicji alarmów > 4.9.1.2 Generowanie bazy definicji alarmów z arkusza

4.9.1.2 Generowanie bazy definicji alarmów z arkusza kalkulacyjnego

Generowanie bazy definicji alarmów z arkusza kalkulacyjnego realizowane jest w następujących krokach:

1. Zdefiniuj tryb pracy bazy definicji alarmów jako Baza definicji alarmów generowana jest z arkusza kalkulacyjnego

Rysunek: Baza definicji alarmów > zakładka 'Typ'.

2. Określ źródła danych:

Baza definicji alarmów > zakładka Źródła danych > wskazane pliki Excel

Rysunek: Baza definicji alarmów > zakładka 'Źródło danych'.

3. Wybierz polecenie Generuj generuj def alarmow.

Wygenerowana w ten sposób baza ma format plików tekstowych.

Istnieje możliwość wygenerowania bazy definicji alarmów w formacie bazy SQL lub MDB jako elementu bazy definicji zmiennych. W tym celu należy na zakładce Źródła danych zaznaczyć opcję Dodaj bazę definicji alarmów do bazy definicji zmiennych i wskazać źródłowe pliki z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący sieciową nazwę zestawu alarmów.


4.9.2 Aktywowanie sposobu pracy systemu alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.2 Aktywowanie sposobu pracy systemu alarmów

4.9.2 Aktywowanie sposobu pracy systemu alarmów

Zakładka Alarmy / Typ systemu obejmuje konfigurację następujących parametrów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Typ systemu'.

  • Blokowanie uruchamiania systemu alarmów - pozycja pozwalająca na zablokowanie inicjacji systemu alarmów;

Wartość domyślna: system alarmów aktywny

  • Sposób pracy systemu alarmów - określa sposób pracy systemu alarmów:

  • Tryb Operatorski - jest podstawowym trybem pracy systemu alarmów, w którym udostępniane są wszystkie mechanizmy aktywnej obsługi alarmów (wykrywanie, potwierdzanie, itd.) oraz możliwa jest praca stanowisk połączonych sieciowo.

Stacje operatorskie współpracują ze sobą tylko wtedy, gdy mają nadaną taką samą nazwę zestawu alarmów. Zestaw alarmów jest identyfikowany przez 8-znakową nazwę.

Istotne jest, aby projektant systemu zapewnił zgodność wszystkich elementów wchodzących w skład zestawu. W przypadku plików definicji alarmów i grup wystarczająca jest zgodność nazw plików (program automatycznie transferuje zawartość plików w przypadku stwierdzenia niezgodności, sprawdzany jest czas zapisu pliku). Natomiast bezwarunkowo muszą zgadzać się parametry strategii rozpoznania alarmów. Wynika to z faktu, że w ramach działającej grupy stanowisk operatorskich tylko jeden komputer aktywnie rozpoznaje alarmy i transferuje je do innych komputerów. Ponieważ nie jest określone, które stanowisko jest aktywne, wobec tego każde z nich musi być w stanie podjąć wykrywanie wszystkich alarmów.

  • Tryb Kontrolny - pozwala jedynie na pasywne przeglądanie alarmów ściąganych ze stanowisk operatorskich.

  • Tryb Lokalny - jest funkcjonalnie identyczny z trybem operatorskim, za wyjątkiem braku możliwości pracy w sieci.

  • Tryb Serwer alarmów historycznych - z punktu widzenia operatora systemu oznacza pracę taką, jak w trybie kontrolnym. Dodatkowo wykonywane jest automatyczne uaktualnianie archiwum alarmów ze wszystkich wykrytych stanowisk operatorskich. Zgromadzone archiwa mogą być udostępniane innym komputerom, pracującym w trybie kontrolnym.

Wartość domyślna: ’Operatorski’, jeżeli została zadeklarowana Nazwa sieciowa zestawu alarmów; w przeciwnym razie wartością domyślną jest praca w trybie ’Lokalnym’.

uwaga Poza powyższymi trybami pracy systemu alarmów istnieje również tryb pozwalający na dynamiczne przyłączanie się do różnych zasobów alarmowych:

Tryb ten pozwala na kontrolowanie w sposób operatorski alarmów aktywnych i historycznych z wielu źródeł.

Podstawowe ograniczenia tego trybu:

- w danej chwili podłączone jest tylko jedno źródło alarmów (nie można otworzyć kilku masek alarmowych, które pokazują różne źródła alarmów);

- stanowisko jest zawsze stroną pasywną (tak jakby wyłączona była opcja Stanowisko aktywne w Architekt > Obszary i komputery > System alarmów > Zaawansowane).

Parametryzacja trybu dynamicznego przyłączania do zasobów alarmów:

  1. Sposób pracy systemu alarmów ustawiony na ’Operatorski’.

  2. Załączona opcja Zmienna nazwa zasobu (System alarmów > Alarmy > Nazwa sieciowa)

  3. Przyłączanie do źródeł alarmów następuje przy użyciu akcji operatorskiej PRZEŁĄCZ_ZASÓB_ALARMÓW

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Nazwa sieciowa'.

Zakładka Alarmy / Nazwa sieciowa obejmuje konfigurację następujących parametrów:

  • Nazwa sieciowa zestawu alarmów - określenie nazwy sieciowej zestawu alarmów obsługiwanego przez program AS. Nazwa może posiadać maksymalnie 8 znaków. Zestaw dostępnych znaków taki sam jak dla nazw plików. Nazwa sieciowa ma znaczenie dla stanowisk pracujących w trybie operatorskim. Stanowiska o tej samej nazwie prowadzą wspólną, zintegrowaną obsługę alarmów. Nazwa sieciowa jest używana ponadto na stanowiskach pasywnych do identyfikacji źródła pochodzenia alarmów.

Wartość domyślna: brak nazwy sieciowej. Program może pracować tylko w trybie kontrolnym (pasywnym) lub w trybie lokalnym.

  • Zmienna nazwa zasobu - opcja załączona zezwala na dynamiczne przyłączanie się do różnych dostępnych zasobów (zestawów alarmów) w przypadku odpowiednio skonfigurowanego trybu pracy systemu alarmów pozwalającego na przełączanie się do różnych zasobów alarmowych.


4.9.3 Deklaracja plikow definicji alarmow i definicji grup

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.3 Deklaracja plików definicji alarmów i definicji grup alarmów

4.9.3 Deklaracja plików definicji alarmów i definicji grup alarmów

uwaga Możliwość deklarowania plików, z których pobierane są definicje alarmów i definicje grup alarmów istnieje wówczas, gdy w module Bazy danych zostanie zdefiniowany tryb pracy bazy definicji alarmów z plikami:

Moduł Bazy danych > Baza definicji alarmów > Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów'.

  • Nazwy plików, w których zdefiniowane są alarmy - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały alarmy; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: definicje alarmów będą czytane z pliku ’alarm.def’ z kartoteki bieżącej aplikacji

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów - grupy'.

  • Nazwy plików, w których zdefiniowane są grupy alarmów - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały grupy alarmów; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: brak


4.9.4 Parametryzacja archiwum alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.4 Parametryzacja archiwum alarmów

4.9.4 Parametryzacja archiwum alarmów

Zakładka Archiwum / Dysk dotyczy wartości następujących parametrów:

  • Zapisuj pliki alarmowe na dysku - pozycja pozwalająca na zablokowanie zapisu alarmów do plików dyskowych;

Wartość domyślna: domyślnie alarmy są zapisywane w plikach dyskowych;

uwaga Brak zapisu alarmów do pliku powoduje, że dostępne są tylko alarmy pamiętane w pamięci operacyjnej komputera (standardowo 1000 pozycji). Ponadto, historia alarmów jest tracona w momencie restartu komputera.

  • Katalog archiwum alarmów - pozycja służąca do określenia katalogu, w którym mają być zapisywane pliki logu alarmów;

Wartość domyślna: domyślnie pliki tworzone są w podkatalogu ’Alarms’ kartoteki startowej aplikacji;

  • Ograniczenie okresu przechowywania plików alarmów - pozycja określa przez ile dni mają być przechowywane pliki alarmów;

Wartość domyślna: domyślnie pliki przechowywane są bezterminowo;

uwaga Bezterminowe przechowywanie plików będzie powodowało zapełnianie się dysku, a więc konieczność okresowego kasowania starych plików. Dodatkowo, duża ilość plików alarmów może spowodować zwolnienie funkcji przeglądania alarmów (szczególnie przy użyciu kryteriów selekcji).

  • Katalog tworzenia kopii bezpieczeństwa archiwum alarmów - pozycja, której użycie włącza mechanizm tworzenia kopii bezpieczeństwa historycznego logu alarmów; program AS utrzymuje w podanej kartotece kopie plików logu; operacja uaktualniania wykonywana jest co jedną godzinę; katalog zapasowy powinien (optymalnie) znajdować się na innym dysku fizycznym niż katalog logu roboczego; można również używać napędów dysków wymiennych;

Wartość domyślna: domyślnie kopia bezpieczeństwa nie jest wykonywana.

uwaga Pliki logu historycznego składowane w kartotece zapasowej nie podlegają ograniczeniu wprowadzanemu przez pozycję Ograniczenie okresu przechowywania plików alarmów.

Pliki są przechowywane bezterminowo.

  • Dokładność zapisu czasu w archiwach alarmów - ustawienie dokładności zapisu czasu w archiwach alarmów; czasy alarmów mogą być pamiętane z rozdzielczością milisekund lub z rozdzielczością zegara systemowego (ok. 55 ms); użycie rozdzielczości milisekundowej powoduje dodatkowo zmianę formatu wyświetlania czasu na maskach alarmów; użycie pozycji jest istotne w sytuacji stosowania niestandardowych strategii rozpoznania alarmów, które nadają alarmom czas z dokładnością do milisekund;

Wartość domyślna: strategie standardowe pracują z dokładnością 55 ms.

uwaga Zmiana użycia parametru Dokładność zapisu czasu w archiwach alarmów wymaga skasowania starego archiwum (na wszystkich połączonych stanowiskach jednocześnie).

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Dysk'.

Zakładka Archiwum / Serwer Microsoft SQL pozwala określić nazwę serwera oraz nazwę bazy MS SQL, w której archiwizowane będą alarmy. Alarmy mogą być archiwizowane w dowolnej liczbie baz na serwerach MS SQL. Archiwizacja na serwerze SQL wykonywana jest niezależnie od archiwizacji zdefiniowanej na zakładce Dysk. Dane w archiwach SQL mogą być analizowane przy pomocy programu AsAlarm i udostępniane przy pomocy systemu raportów opartego o MS Reporting Services. Pierwsza baza na liście używana jest przez środowisko raportów AsRaport. Domyślnie żadna baza nie jest zadeklarowana.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Serwer Microsoft SQL'.

Zakładka Archiwum / Pamięć operacyjna pozwala określić ilość zdarzeń alarmowych logu historycznego przechowywanych w pamięci. Użycie tej pozycji może ewentualnie poprawić czasy dostępu do alarmów historycznych; w przypadku pracy bez logu plikowego, pozycja określa jednocześnie całkowitą liczbę pamiętanych alarmów; Wartość domyślna: domyślnie ilość alarmów przechowywanych w pamięci wynosi 1000.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Pamięć operacyjna'.


4.9.5 Definicje strategii alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.5 Definicje strategii alarmów

4.9.5 Definicje strategii alarmów

Oprócz zdefiniowania alarmów konieczne jest jeszcze określenie sposobu wykrywania alarmów.

Zakładka Strategie pozwala zadeklarować jedną z pięciu dostępnych w systemie Asix strategii rozpoznawania alarmów:

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Bitowa'.

  • Strategia bitowa - polega na sprawdzaniu stanu bitów w mapie bitowej alarmów, tworzonej przez oprogramowanie sterownika kontrolującego proces; wymaga to zadeklarowania danych Asmena służących do odczytu zawartości mapy alarmów; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli używanych jest mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru Liczba alarmów; okres sprawdzania stanu mapy bitowej wynika z czasu odświeżania podanego w definicji danej Asmena;

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Limitów'.

  • Strategia limitów - pozycja powoduje, że instalowana jest strategia rozpoznania alarmów oparta na sprawdzaniu przekroczenia wartości ograniczeń; okres sprawdzania określa cykl sprawdzania limitów w sekundach (domyślnie 1 sekunda); lista plików podaje nazwy plików (oddzielone znakiem przecinka), w których umieszczone zostały opisy limitów; brak listy oznacza, że użyty zostanie plik limits.def z kartoteki bieżącej aplikacji;

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Buforowa'.

  • Strategia buforowa - umożliwia parametryzację strategii buforowej w programie AS poprzez zadeklarowanie jednej lub kilku pozycji o następującej składni:

<zmienna_buforowa>,<zmienna_synchronizująca>,<zmienna_alarmów>,<numer_alarmu>,

gdzie:

<zmienna_buforowa> - nazwa zmiennej Asmena służącej do wymiany informacji o alarmach; jej rozmiar musi być równy rozmiarowi bufora w sterowniku;

<zmienna_synchronizująca> - nazwa zmiennej Asmena służącej do synchronizacji dostępu do bufora;

<zmienna_alarmów> - nazwa zmiennej Asmena służącej do wystawiania przez PC żądania odczytu mapy alarmów;

<numer_alarmu> - określa numer alarmu w ramach systemu Asix, nadawany pierwszemu alarmowi wykrywanemu przez deklarowaną strategię.

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Aktywna'.

  • Strategia aktywna (SINEC L2) - użycie tej strategii wymaga stosowania protokołu transmisji pozwalającego na inicjację przesyłów ze strony sterownika oraz specjalnego programu w sterowniku, który wysyła dane zgodnie z protokołem przyjętym w strategii aktywnej; strategia wymaga zadeklarowania jednej lub więcej pozycji o następującej składni:

bufor,synchro,numer_alarmu,id

gdzie:

bufor - nazwa zmiennej służącej do wymiany danych,

synchro - nazwa zmiennej synchronizującej,

numer_alarmu - numer pierwszego alarmu obsługiwanego przez ten element strategii,

id - identyfikator (sieci SINECL2, aktualnie 1(SSNR =0) lub 2 (SSNR =8)).

Wartość domyślna: domyślnie strategia nie jest używana

uwaga Użycie tej strategii wymaga stosowania protokołu transmisji pozwalającego na inicjację przesyłów ze strony sterownika oraz specjalnego programu w sterowniku, który wysyła dane zgodnie z protokołem przyjętym w strategii aktywnej.

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Serwera alarmów OPC'.

  • Strategia alarmów OPC - pozwala na deklarację użycia strategii rozpoznawania alarmów, której drajwer znajduje się w zewnętrznym pliku dll; zadeklarowanie drajwera alarmów OPC wymaga podania wiersza o następującej składni:

ALOPC.dll, , <serwer>, <plik_al_opc>

gdzie:

<serwer> - oznacza nazwę serwera alarmów OPC;

<plik_al_opc> - oznacza nazwę pliku tłumaczeń warunków OPC na alarmy w systemie Asix.


4.9.6 Definicja formatu alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.6 Definicja formatu alarmów

4.9.6 Definicja formatu alarmów

Grupa zakładek Wygląd służy do definiowania sposobu wyświetlania alarmów:

  • Kolor tła - określa:

  • Tło tabeli alarmów,

  • Alternatywne tło tabeli alarmów,

  • Linie rozdzielające;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd / Kolor tła'.

  • Kolor tekstu alarmu - w zależności od rodzaju alarmu oraz od stanu alarmu (początek lub koniec) pozwala określić kolor tekstu i kolor tła dla:

  • Komunikat systemowy,

  • Komunikat,

  • Ostrzeżenie,

  • Alarm,

  • Ważny alarm.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor tekstu alarmu'.

  • Kolor daty alarmu - w zależności od stanu alarmu pozwala określić kolor tekstu daty oraz kolor tła daty dla:

  • Alarm rozpoczęty,

  • Alarm rozpoczęty i potwierdzony,

  • Alarm zakończony,

  • Alarm zakończony i potwierdzony.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor daty alarmu'.

  • Alarmy wyselekcjonowane - umożliwia zadeklarowanie koloru tła alarmów wyselekcjonowanych;

Rysunek:. Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Alarmy wyselekcjonowane'.

  • Maski typu Czerwony Tryb - definiuje kolor tekstu kolor tła masek ’Czerwony Tryb’;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Maska typu Czerwony Tryb'.

  • Opcje - pozwala dodatkowo określić:

  • Użycie na maskach i wydrukach alarmów długiego 4-cyfrowego formatu numeru roku;

  • Sortowanie alarmów na liście alarmów aktywnych i historycznych;

  • Czas po lewej stronie - wyświetlanie czasu na maskach alarmowych po lewej stronie;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Opcje'.

uwaga Użycie trybu sortowania według czasu zdarzeń ma sens tylko wtedy, gdy używana strategia wykrywania alarmów zgłasza alarmy łącznie z czasem.


4.9.7 Parametryzacja sygnalizacji alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.7 Parametryzacja sygnalizacji alarmów

4.9.7 Parametryzacja sygnalizacji alarmów

Sygnalizacja umożliwia przeprowadzenie parametryzacji dotyczącej sposobu sygnalizacji alarmów, w tym:

- sposobu sygnalizacji dźwiękowej wystąpienia alarmu, ostrzeżenia oraz alarmu ważnego;

- akcji, która ma być wykonana w momencie wystąpienia alarmu;

- sprzęgu pomiędzy systemem Asix a modułem AsAlert, umożliwiającym zdalne powiadamianie wybranych osób o ważnych zdarzeniach.


4.9.7.1 Definiowanie dzwiekow sygnalizacji

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.7 Parametryzacja sygnalizacji alarmów > 4.9.7.1 Definiowanie dzwięków sygnalizacji

4.9.7.1 Definiowanie dźwięków sygnalizacji

Zakładka Sygnalizacja / Dźwięki służy do parametryzacji sygnalizacji dźwiękowej alarmów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Dźwięki'.

  • Sygnalizacja dźwiękowa wystąpienia alarmu - określa sposób sygnalizacji dźwiękowej wystąpienia alarmu:

  • ’TAK’ - oznacza, że alarmy są zawsze sygnalizowane;

  • ’NIE’ - oznacza wyłączenie sygnalizacji alarmów;

  • ’MASTER’ - dotyczy instalacji sieciowej; na danej stacji są generowane sygnały dźwiękowe tylko w przypadku, gdy jest ona stroną aktywną w sieci;

Wartość domyślna: ’TAK’

uwaga Wymagana jest instalacja karty dźwiękowej.

  • Sygnał alarmów - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Sygnał ostrzeżeń - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Sygnał ważnych - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Alarm ciągły - włączenie ciągłego odgrywania sygnału po wykryciu alarmu. Sygnał będzie wyłączony dopiero po wykonani akcji UCISZ_SYGNAL;

Wartość domyślna: opcja wyłączona


4.9.7.2 Definiowanie akcji

Zakładka Sygnalizacja / Akcja służy do deklaracji akcji, wykonywanej w momencie wykrycia alarmu:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Akcja'.

  • Akcja, która ma zostać wykonana w momencie wykrycia alarmu

Wartość domyślna: brak

uwaga Nie ma możliwości rozróżnienia rodzaju akcji dla różnych numerów alarmów.


4.9.7.3 Definiowanie sprzegu systemu Asix z modulem AsAlert

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.7 Parametryzacja sygnalizacji alarmów > 4.9.7.3 Definiowanie sprzęgu systemu Asix z modułem AsAlert

4.9.7.3 Definiowanie sprzęgu systemu Asix z modułem AsAlert

Włączenie modułu sprzęgu pomiędzy systemem Asix a systemem zdalnego powiadamiania wybranych osób o ważnych zdarzeniach - AsAlert wymaga załączenia opcji AsAlert, zlokalizowanej na zakładce Sygnalizacja / Alerty, oraz podania nazwy pliku konfiguracyjnego sprzęgu (plik XML).

Dodatkowa opcja Alerty, gdy stacja aktywna umożliwia wymuszenie wysyłania alertów wyłącznie przez aktywne stacje. Opcja znajduje zastosowanie w redundantnych stacjach operatorskich, gdzie tylko jedno stanowisko jest aktywne - załączenie opcji eliminuje nadmiarowe wysyłanie alertów, ponieważ są one wysyłane tylko przez stację aktywną.

Szczegóły na temat tworzenia pliku konfiguracyjnego sprzęgu omawia AsAlert - podręcznik użytkownika.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Alerty'.


4.9.8 Deklaracja uprawnien dotyczacych obslugi alarmow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

4.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

Zakładka Bezpieczeństwo daje możliwość:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Bezpieczeństwo'.

  • zadeklarowania poziomu hasła, którego znajomość będzie wymagana do wykonania określonych operacji:

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów filtrowanych,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów sygnalizowanych dźwiękiem,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów wykluczeń.

Wartość domyślna: brak kontroli

Sposób deklarowania trybu logowania omawia rozdział 4.11 . Konfiguracja zabezpieczenia aplikacji .

  • Dodatkowo użycie opcji Zablokowanie obsługi alarmów przez operatora powoduje, że blokowane są operacje zmiany filtrów, wykluczeń i potwierdzania alarmów. Możliwe jest jedynie przeglądanie alarmów;

Wartość domyślna: obsługa nie jest blokowana


4.9.9 Deklaracja mapy buczkow i mapy wykluczen

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.9 Deklaracja mapy buczków i mapy wykluczeń

4.9.9 Deklaracja mapy buczków i mapy wykluczeń

Zakładka Mapy pozwala zadeklarować:

Rysunek 156. Okno parametrów systemu alarmów - zakładka 'Mapy' / 'Buczków'.

  • mapę buczków; jest to deklaracja obszarów map bitowych, używanych do parametryzacji sygnalizacji dźwiękowej, realizowanej przez sterownik, zgodnie z następującym zapisem:

nazwa_danej, numer_pierwszego_alarmu[,liczba_alarmów]

gdzie:

nazwa_danej - podaje symboliczną nazwę zmiennej procesowej Asmena, w której sterownik przechowuje bitową informację o sygnałach alarmów (wartość 1 oznacza dla danego alarmu, że generuje on buczek lub dzwonek, w zależności od typu mapy);

numer_pierwszego_alarmu - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie mapy sygnałów nie są obsługiwane;

  • mapę dzwonków; jest to deklaracja obszarów map bitowych, używanych do parametryzacji sygnalizacji dźwiękowej, realizowanej przez sterownik, zgodnie z następującym zapisem:

nazwa_danej, numer_pierwszego_alarmu[,;iczba_alarmów]

gdzie:

nazwa_danej - podaje symboliczną nazwę zmiennej procesowej Asmena, w której sterownik przechowuje bitową informację o sygnałach alarmów (wartość 1 oznacza dla danego alarmu, że generuje on buczek lub dzwonek, w zależności od typu mapy);

numer_pierwszego_alarmu - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie mapy sygnałów nie są obsługiwane;

  • mapę wykluczeń; jest to deklaracja mapy bitowej, która steruje wykluczaniem alarmów realizowanych przez sterownik, zgodnie z zapisem:

nazwa_danej, numer_pierwszego_alarmu[,liczba_alarmów]

gdzie:

nazwa_danej - podaje nazwę symboliczną zmiennej Asmena, w której sterownik przechowuje informację o wykluczonych alarmach (wartość 1 oznacza dla danego alarmu, że jest wykluczony);

numer_pierwszego_alarmu - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena;jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie wykluczenia realizowane są wewnętrznie w komputerze.

uwaga Użycie pozycji powoduje wyłączenie wewnętrznego mechanizmu kontroli wykluczeń i filtrów.


4.9.10 Parametry zaawansowane

 uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Zaawansowane obejmuje konfigurację następujących parametrów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Zaawansowane'.

  • Wyłączenie wyświetlania alarmów wykluczonych - zastosowanie trybu pracy polegającego na wyłączeniu wyświetlania alarmów wykluczonych; alarmy takie są jednak rejestrowane i zapisywane do logu - gdzie po wycofaniu wykluczenia można przejrzeć wszystkie zarejestrowane zdarzenia;

Wartość domyślna: alarmy wykluczone są wyświetlane

  • Algorytm filtrowania - wybór sposobu filtracji alarmów; możliwe jest filtrowanie krótkich alarmów, pojawiających się na czas krótszy niż zadeklarowany (algorytm nr 1) lub szybkich sekwencji pojawienie się alarmu-zanik alarmu - pojawienie się alarmu (algorytm nr 2);

Wartość domyślna: 1

  • Stanowisko aktywne - uzupełnienie parametryzacji dla stanowisk pracujących w trybie operatorskim w sieci; w grupie połączonych stanowisk operatorskich w danej chwili jest tylko jeden komputer, który wykrywa alarmy - jest to samoistnie ustalane przez Asix a; wyłączenie opcji oznacza, że dany komputer nigdy nie zostanie komputerem aktywnym; opcja ma zastosowanie tam, gdzie nie ma bezpośredniego łącza do sterowników lub na stanowiskach typu nadzorczego z wymaganym dostępem do alarmów aktywnych;

Wartość domyślna: stanowisko może być aktywne

Zadeklarowanie zmiennej __ALSYS_STATE__ w kanale NONE pozwala na diagnostykę, czy dane stanowisko jest stanowiskiem aktywnym, tzn. w tym przypadku - czy wykrywa alarmy. Zmienna automatycznie ustawiana jest na następujące wartości:

0 - gdy system alarmów jest w stanie przejściowym,

1 - gdy system alarmów pracuje w trybie aktywnym,

2 - gdy system alarmów pracuje w trybie pasywnym.

  • Stacje operatorskie będące serwerami alarmów - jawne deklarowanie stacji operatorskich będącymi serwerami alarmów;

Wartość domyślna: brak zadeklarowanych stacji

uwaga Parametr dotyczy pliku konfiguracyjnego aplikacji dla komputerów pracujących z systemem alarmów kontrolnych; kosztem wydłużenia czasu wyszukiwania, zwiększa się prawdopodobieństwo znalezienia żądanych serwerów.

  • Stacje operatorskie będące serwerami alarmów w trybie POMOST - jawne deklarowanie serwerów alarmów historycznych; służy do deklaracji komputerów pracujących w trybie serwerów alarmów historycznych jako stacja typu pomost;

Wartość domyślna: brak zadeklarowanych stacji

uwaga Pozycja dotyczy pliku konfiguracyjnego aplikacji dla komputerów pracujących z systemem alarmów kontrolnych. Kosztem wydłużenia czasu wyszukiwania, zwiększa się prawdopodobieństwo znalezienia żądanych serwerów.


4.9.11. Baza zdarzeń alarmów

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.11. Baza zdarzeń alarmów

4.9.11. Baza zdarzeń alarmów - konfiguracja

Bieżący stan oraz historia alarmów systemu Asix przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowana inna lokalizacja). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można też ograniczyć ilość pamiętanych dni.

Istnieje możliwość przekonwertowania plików binarnych z logami zdarzeń alarmowych systemu Asix (pliki al??????.log) do formatu bazy SQL. Służy do tego programu AlarmLogConverter.exe dołączany do pakietu Asix.

Możliwa jest też bieżąca rejestracja zdarzeń alarmowych w bazie SQL. Wymaga to odpowiedniego skonfigurowania pliku XML aplikacji systemu Asix przy jednoczesnym odblokowaniu zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line.

(patrz: - 4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych - gdy istnieje potrzeba zachowania ciągłości w rejestracji zdarzeń alarmowych pomiędzy archiwum a bieżącą rejestracją

- 4.9.11.2 Uruchamianie rejestracji zdarzeń alarmowych on-line - gdy nie ma archiwum alarmów a rejestracja zaczyna się od bieżącego momentu)

UWAGA:

Na potrzeby programu AsAlarm oraz środowiska AsRaport tworzenia raportów z wykorzystaniem usług Reporting Revices - wymagane jest archiwizowanie zdarzeń alarmowych w bazie danych typu SQL.


4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.11. Baza zdarzeń alarmów > 4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL

4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL

Konwersja plików binarnych archiwum alarmów systemu Asix do formatu bazy SQL realizowana jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix (katalog główny pakietu Asix).

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL:

Aby dokonać konwersji plików al??????.log do formatu bazy SQL i uruchomić bieżącą rejestrację zdarzeń alarmowych bez utraty danych dotyczących wystąpień alarmów w momencie wykonywania czynności związanych z konwersją - należy postępować ściśle wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Przekonwertowanie plików al??????.log do formatu bazy danych SQL:

a. przejdź do programu AlarmLogKonwerter i w kategorii Operacje kliknij na przycisk Rozpocznij.

5. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. po zakończeniu konwersji przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL - zapisowi podlegają tylko te zdarzenia, których nie objęła operacja konwersja plików zdarzeń al??????.log.


4.9.11.2. Uruchamianie rejestracji zdarezń alarmowych on-line

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.9 Konfiguracja systemu alarmów > 4.9.11. Baza zdarzeń alarmów > 4.9.11.2. Uruchamianie rejestracji on-line zdarzeń alarmowych

4.9.11.2. Uruchamianie rejestracji on-line zdarzeń alarmowych

Uruchomienie rejestracji alarmów systemu Asix do bazy SQL realizowane jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix.

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych do formatu bazy SQL (bez konwersji plików binarnych):

Aby uruchomić bieżącą rejestrację zdarzeń alarmowych - należy postępować wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL.


4.10 Konfiguracja modulu sieci

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.10 Konfiguracja modułu sieci

4.10 Konfiguracja modułu sieci

Grupa parametrów konfiguracja modułu sieci Moduł sieci obejmuje ustawienia pracy modułu Aslink.

ASLINK jest modułem, który umożliwia innym komponentom systemu Asix wzajemną komunikację poprzez lokalną sieć komputerową. Aslink definiuje zestaw usług sieciowych, z których korzystają wszystkie inne programy systemu Asix, sparametryzowane do pracy w sieci.

Podstawowa usługa świadczona między innymi na rzecz takich komponentów pakietu Asix, jak Asmen, Aspad czy podsystem obsługi alarmów - to wiarygodny przesył danych pomiędzy każdą parą procesów użytkowych, działających na dowolnych stanowiskach przyłączonych do sieci komputerowej i realizujących wspólny protokół użytkowy. W tym zakresie usługi modułu Aslink ukierunkowane są na wsparcie komunikacji opartej na istnieniu procesu ”serwera" i korzystającego z jego usług procesu ”klienta".

W szczególności Aslink zapewnia:

  • wyszukanie w sieci procesów pełniących rolę serwerów w odniesieniu do zasobów potrzebnych procesom klientów,

  • nawiązanie połączenia (tzw. kanału transmisji) pomiędzy klientem i wskazanym przez niego serwerem zasobu,

  • dwukierunkowy, wiarygodny przesył danych w każdym z kanałów,

  • powiadomienie procesów, że kanał został zamknięty wskutek awarii sieci lub na jawne polecenie któregoś z partnerów.

Szczegółowy opis funkcjonalności modułu Aslink znajduje się w podręczniku ”Asix - funkcjonalność i zasady działania”, rozdziale ASLINK - moduł sieciowy.

uwaga Ustawienia modułu sieciowego przechowywane są w pliku XML aplikacji Asixa. Gdy na danym komputerze nie ma takiej aplikacji (tym samym pliku xml), za to znajdują się: AsixConnect, AsTrend lub inna aplikacja korzystająca z danych aplikacji Asixa - w takiej sytuacji ustawienia sieciowe dla danego komputera przechowywane są w pliku aslink.ini. Edytor pliku aslink.ini dostępny jest z poziomu Architekta z menu Narzędzia i obejmuje konfigurację dokładnie tych samych opcji co Moduł sieci.


4.10.1 Nazwa komputera

Zakładka Nazwa komputera obejmuje parametryzację następujących elementów:

Rysunek: Okno parametrów modułu sieci - zakładka 'Nazwa komputera'.

  • Automatyczne nadawanie sieciowych nazw komputerom - zaznaczenie opcji spowoduje, że nazwa komputera widniejąca w panelu 'Obszary i komputery' zostanie sieciową nazwą komputera;

Wartość domyślna: automatycznie przydzielana jest nazwa komputera w systemie Windows, zdefiniowana w czasie parametryzacji sieci z dodaną na końcu kropką.

  • Sieciowa nazwa komputera - nazwa sieciowa komputera; jeśli nie podano w tym polu nazwy, to zostanie wygenerowana nazwa na podstawie nazwy komputera w systemie Windows, zdefiniowanej w czasie parametryzacji sieci z dodaną na końcu kropką;

Wartość domyślna: nazwa przydzielona automatycznie

uwaga Dopuszczalne wartości: tekst o maks. 15 znakach. Wielkość znaków ma znaczenie. Nazwa nie może zwierać znaku ”*”. Nie powinna również zawierać znaku ”,”


4.10.2. Komunikacja poprzez TCP/IP

Zakładka Komunikacja poprzez TCP/IP obejmuje parametryzację następujących elementów:

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja poprzez TCP/IP'.

  • Połączenia po protokole TCP/IP - opcja wymaga podania nazwy w systemie Windows lub adresu IP wszystkich komputerów, do których ma się dołączać moduł sieciowy; nazwy należy rozdzielić przecinkami.

Domyślnym portem komputera, do którego ma się dołączać moduł sieciowy, jest port numer 6000. Jeśli zdalny komputer używa innego portu, należy go podać po dwukropku, np.: serwer2:6001, 10.10.10.13:6003.

Na odległych serwerach zaleca się zwiększenie wartości opcji Dane bieżące > Zaawansowane 2 > Zwłoka danych z serwera

Wartość domyślna: brak połączenia

  • Nr portu TCP/IP - numer portu, na którym moduł sieciowy oczekuje na połączenie.

Wartość domyślna: 6000

  • Nie używaj TCP/IP - załączenie opcji oraz jednocześnie opcji Nie używaj NetBIOS z zakładki Komunikacja przez NetBIOS/Protokoły sieciowe powoduje, że możliwa jest jedynie komunikacja modułów systemu Asix na jednym komputerze z użyciem wewnętrznego protokołu.

Wartość domyślna: opcja wyłączona


4.10.3 Deklaracje synchronizacji czasu po stronie Klienta

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.10 Konfiguracja modułu sieci > 4.10.3 Komunikacja poprzez NetBIOS

4.10.3 Komunikacja poprzez NetBIOS

Zakładka Komunikacja poprzez NetBIOS/Protokoły sieciowe obejmuje deklarację kart i protokołów sieciowych.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Protokoły sieciowe'.

  • Używane karty sieciowe i protokoły - opcja określa wykorzystywane do komunikacji protokoły sieciowe:

  • Wszystkie karty sieciowe i protokół TCP/IP

  • Wybrane karty sieciowe i protokoły - pozwala zadeklarować nazwy kart sieciowych, protokołów lub numery adapterów oddzielone przecinkami; poprzedzenie nazwy znakiem ’-’ oznacza, że dany adapter nie może być używany; znak '*' oznacza wszystkie dostępne protokoły i karty sieciowe. Aby wyświetlić listę dostępnych adapterów, należy uruchomić program AslView i z menu Widok wybrać polecenie Adaptery.

Wartość domyślna: ’TCPIP’

  • Karty sieciowe i protokoły używane przez moduł sieciowy do szukania serwerów - określa adaptery logiczne wykorzystywane przez moduł sieciowy do szukania serwerów;

  • Wszystkie karty sieciowe i protokół TCP/IP

  • Wybrane karty sieciowe i protokoły

Wartość domyślna: wszystkie adaptery wykorzystywane przez moduł sieciowy.

uwaga Pozycje używane na komputerach typu ’POMOST’.

Dopuszczalne wartości: numery adapterów oddzielone przecinkami; jeżeli numer adaptera poprzedzony jest znakiem '-', to adapter nie zostanie użyty; jeśli podano ’*’, to zostaną wykorzystane wszystkie dostępne adaptery.

  • Nie używaj NetBIOS - załączenie opcji oraz jednocześnie opcji Nie używaj TCP/IP z zakładki Komunikacja poprzez TCP/IP powoduje, że możliwa jest jedynie komunikacja modułów systemu Asix na jednym komputerze z użyciem wewnętrznego protokołu.

Wartość domyślna: opcja wyłączona

uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Zaawansowane obejmuje parametryzację następujących opcji:

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Zaawansowane'.

  • Nazwa grupy - nazwa grupy, do której należy komputer;

Wartość domyślna: ASIX

  • Połączenia sesyjne - jeśli pole to jest wypełnione, to połączenia będą nawiązywane tylko do zdefiniowanych komputerów;

Wartość domyślna: brak połączenia

Uwaga:

Użycie tej opcji blokuje synchronizację czasu.

Na odległych terminalach zaleca się zwiększenie wartości opcji Dane bieżące > Zaawansowane 2 > Zwłoka danych z serwera

Do działania połączeń sesyjnych wymagane jest wykonanie odpowiednich wpisów w systemowych plikach LMHOSTS.

  • Aslink 4 - opcja załącza komunikację ze starszymi wersjami modułu sieciowego (Asix 1-3);

Wartość domyślna: komunikacja ze starszymi wersjami modułu sieciowego załączona

Uwaga:

Zaznaczenie tej opcji spowoduje zwiększenie obciążenia sieci.

  • Domena Aslinka - włącza realizację połączeń pomiędzy komputerami położonymi w różnych sieciach połączonych przez router;

Wartość domyślna: opcja wyłączona

Uwaga:

Do działania tej opcji wymagane jest wykonanie odpowiednich wpisów w systemowych plikach LMHOSTS.

Zamiast tej opcji zaleca się użycie opcji Połączenia sesyjne.

 uwaga Zakładka Synchronizacja czasu pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Klient 1 umożliwia parametryzację synchronizacji czasu od strony klienta.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Klient 1'.

  • Synchronizacja czasu - opcja pozwala załączyć synchronizację czasu;

Wartość domyślna: czas synchronizowany jest z wszystkimi dostępnymi serwerami czasu

  • Ograniczenia synchronizacji czasu - jeśli pole jest wypełnione, to synchronizacja czasu zostanie ograniczona do serwerów o podanych nazwach; sieciowe nazwy komputerów należy podać, oddzielając je przecinkami;

Wartość domyślna: czas synchronizowany jest z wszystkimi dostępnymi serwerami czasu

  • Maksymalna różnica czasu - różnica pomiędzy czasem serwera a czasem stacji lokalnej, której przekroczenie spowoduje synchronizację czasu lokalnego (CMOSu); wartość w sekundach;

Wartość domyślna: 4 sekundy

  • Liczba pakietów czasu - liczba pakietów czasu, jaką stacja musi otrzymać od jednego serwera, aby zsynchronizować swój zegar;

Wartość domyślna: 3 pakiety

  • Ignorowane pakiety czasu - liczba pakietów czasu, które są pomijane po uruchomieniu modułu sieciowego na każdym adapterze;

Wartość domyślna: 2

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Klient 2 umożliwia parametryzację synchronizacji czasu od strony klienta.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Klient 2'.

  • Duża różnica czasu określa:

  • różnicę (czas w milisekundach) pomiędzy czasem serwera czasu a czasem stacji lokalnej, której przekroczenie powoduje specjalne traktowanie odbieranych pakietów czasu, polegające na opóźnionej synchronizacji czasu stacji lokalnej;

Wartość domyślna: 3600 milisekund

  • liczbę pakietów, po której otrzymaniu nastąpi synchronizacja czasu;

Wartość domyślna: 2

  • Replikacja pakietów czasu - włączenie opcji spowoduje, że wszystkie odbierane z danego adaptera pakiety czasu będą rozsyłane do pozostałych adapterów; dodatkowo można określić liczbę dopuszczalnych replikacji pakietu czasu.

Wartość domyślna: replikacja czasu wyłączona

  • Limit zmiany czasu - pozycja pozwala zdefiniować jaka jest maksymalna dozwolona jednorazowa zmiana czasu;

Wartość domyślna: domyślnie zmiany czasu nie są ograniczone

uwaga Podanie ujemnego limitu zmiany całkowicie blokuje możliwość modyfikacji czasu.

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Serwer umożliwia parametryzację synchronizacji czasu od strony serwera.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Serwer'.

  • Serwer czasu - określa, czy stacja będzie pracować jako serwer czasu (tj. rozgłaszać w sieci informacje o bieżącym czasie):

  • Komputer nigdy nie jest serwerem czasu,

  • Komputer jest zawsze serwerem czasu - nawet jeśli w sieci pracuje serwer czasu o wyższym priorytecie,

  • Komputer jest serwerem czasu tylko jeśli ma najwyższy priorytet;

Wartość domyślna: komputer nigdy nie jest serwerem czasu

  • Priorytet serwera czasu - określa priorytet stacji jako serwera czasu; im większa wartość tym większy priorytet (0 - 32768). Wartość priorytetu przesyłana jest razem z aktualnym czasem w pakietach synchronizacyjnych (BROADCAST). Jeżeli aktywny w danej chwili serwer czasu odbierze pakiet zawierający wyższy priorytet, to przestaje być aktywnym serwerem czasu.

Wartość domyślna: 0

  • Interwał serwera czasu - określa interwał czasu (w sekundach), z jakim wysyłane są do sieci pakiety zawierające bieżący czas stacji.

Wartość domyślna: 0

  • Maksymalny interwał serwera czasu - określa maksymalny interwał wysyłania pakietów zawierających bieżący czas

Wartość domyślna: 60 sekund

  • Warunek aktywacji serwera czasu - stacja stanie się serwerem czasu, gdy od dotychczasowego serwera czasu nie dostanie określonej przez użytkownika liczby kolejnych pakietów synchronizacyjnych;

Wartość domyślna: 5

  • Replikacja pakietów czasu - określa liczbę dopuszczalnych replikacji pakietu czasu; maksymalna ilość kolejnych stacji, z jakich może się składać trasa pakietu czasu. Parametr ma znaczenie tylko na stacji będącej serwerem czasu.

Wartość domyślna: 2

uwaga Zakładka Diagnostyka - AslView pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Diagnostyka - AslView dotyczy konfiguracji informacji diagnostycznych przekazywanych do programów AslView przyłączonych do modułu sieciowego.

Rysunek: Okno parametrów modułu sieci - zakładka 'Diagnostyka' / 'AslView'.

  • Historia - określa:

  • Maksymalna ilość zapisów w historii połączeń modułu sieciowego;

Wartość domyślna: 0;

  • Maksymalna ilość zapisów w historii zmian czasu;

Wartość domyślna: 50;

  • Maksymalna ilość zapisów w historii połączeń klienta/serwera;

Wartość domyślna: 300;

  • Blokada zmian - parametr określa uprawnienia dotyczące zmiany parametrów z poziomu programu AslView:

  • Zezwalaj na zmiany parametrów z poziomu programu AslView;

  • Nie zezwalaj na zmiany parametrów z poziomu programu AslView;

  • Blokuj hasłem zmianę parametrów z poziomu programu AslView;

Hasło - parametr określa hasło, które musi wprowadzić użytkownik programu AslView przed dokonaniem czynności powodujących istotne zmiany w funkcjonowaniu modułu sieciowego.

Wartość domyślna: nie ma zezwolenia na zmiany parametrów z poziomu programu AslView.

Obowiązuje parametr Czas ważności logowania zdefiniowany w module Zabezpieczenia.


4.10.4 Parametry zaawansowane

uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Zaawansowane pozwala określić następujące opcje.

Rysunek: Okno parametrów modułu sieci - zakładka 'Zaawansowane'.

  • Filtrowanie sieciowych nazw komputerów - określenie tekstowego filtru, jakiemu podlegać będą nazwy stacji zdalnych; stacje o nazwach niezgodnych z filtrem nie będą widoczne; nazwa może zawierać znaki ? i * (tylko na końcu); nazwy kilku stacji podaje się oddzielając je przecinkami;

Wartość domyślna: brak (wszystkie stacje są widoczne)

  • Maksymalny czas operacji nadawania - maksymalny czas trwania operacji nadawania; jednostką jest okres czasu równy 500ms;

Wartość domyślna: 30 (15 sekund)

  • Maksymalny czas operacji odbioru - maksymalny czas trwania operacji odbioru; jednostką jest okres czasu równy 500ms;

Wartość domyślna: 30 (15 sekund)

  • Sprawdzanie łączności - czas, po którym zostanie wysłany pakiet sprawdzający stan połączenia w sieci lokalnej;

Wartość domyślna: 5 sekund

  • Sprawdzanie łączności WAN - czas, po którym zostanie wysłany pakiet sprawdzający stan połączenia w sieci rozległej;

Wartość domyślna: 60 sekund

  • Lokalne połączenia - możliwe połączenia pomiędzy klientami i serwerami znajdującymi się na tej samej stacji bez udziału oprogramowania sieciowego.

Wartość domyślna: opcja jest włączona

uwaga Włączenie opcji jest koniczne w przypadku korzystania z programu AsixConnect pobierającego dane z lokalnego Asmena i Aspada.


4.10.5 Parametry diagnostyczne

 uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Diagnostyka obejmuje parametry sterujące informacjami diagnostycznymi wyprowadzanymi przez moduł Aslink:

Rysunek: Okno parametrów modułu sieci - zakładka 'Diagnostyka'.

  • Plik logu - definiuje nazwę pliku, w którym będą zapisywane informacje diagnostyczne oraz maksymalny rozmiar pliku (w MB)

Wartość domyślna: plik o nazwie ’aslink.log’ o maksymalnym rozmiarze: 500 000 KB

  • Zapisz informacje o ... - pozwala określić rodzaj informacji, która zostanie zapisana do pliku logu; istnieje możliwość zadeklarowania zapisu informacji o:

  • Pakietach odebranych,

  • Pakietach wysłanych,

  • Wywołania CALLBACK,

  • Wywołania API,

  • Danych zawartych w pakietach organizacyjnych,

  • Pakietach danych,

  • Danych \zawartych w pakietach danych,

  • Rozgłaszanych pakietach czasu,

  • Operacjach NetBios NBC

Wartość domyślna: żaden rodzaj informacji nie jest zadeklarowany

  • Rozmiar danych - określa maksymalną długość części danych pakietów sieciowych, która będzie zapisywana w pliku log;

Wartość domyślna: 10 B.


4.11 Konfiguracja zabezpieczenia aplikacji

Grupa parametrów zabezpieczenia ikonka Zabezpieczenia obejmuje aktywację mechanizmu dynamicznych zabezpieczeń systemowych, definiowanie haseł poziomowych, a w przypadku stosowania systemu logowania - definiowanie użytkowników oraz blokadę komend mogących powodować zmianę stanu aplikacji.

Mechanizmy zabezpieczeń systemowych pozwalają na łatwe zabezpieczanie dostępu do potencjalnie niebezpiecznych funkcji systemu operacyjnego, których nieumiejętne lub nieodpowiedzialne użycie przez operatora mogłoby doprowadzić do uszkodzenie systemu. Jednocześnie, użycie mechanizmów zabezpieczeń, pozwala na pracę systemu Asix na konto użytkowników systemu Windows o dużych uprawnieniach, co ułatwia konserwację i zarządzanie pracą systemu operacyjnego. Mechanizm zabezpieczeń dynamicznych zintegrowany jest z systemem Asix i powoduje włączanie i wyłączanie zabezpieczeń, w zależności od sposobu konfiguracji systemu kontroli dostępu w aplikacji.

Zestaw zabezpieczeń przełączanych dynamicznie obejmuje następujące mechanizmy:

- blokada dostępu do menedżera zadań (klawisze Ctrl+Alt+Del);

- ukrywanie i blokada paska zadań;

- blokada klawiszy otwierających menu startowe (klawisze Ctrl+Esc i Windows);

- blokada wyświetlania plików pomocy HLP.

Sposób przełączania zabezpieczeń zależy od sposobu konfiguracji systemu kontroli dostępu w aplikacji. Możliwe są dwa warianty:

- aktywny jest system użytkowników aplikacji (logowania); wówczas zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora;

- aktywny jest tylko system haseł poziomowych; zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy aktywne jest hasło poziomu 4.

W przypadku stosowania systemu haseł poziomowych dostępne są cztery poziomy uprawnień wymaganych do realizacji akcji operatorskich oraz operacji sterujących kontrolowanym procesem.

System logowania pozwala zdefiniować dowolną liczbę użytkowników, z których każdy posiada hasło jednego z pięciu poziomów uprawnień.

Szczegółowy opis mechanizmów zabezpieczeń stosowanych w systemie Asix (w tym stosowanie trybu haseł poziomowych oraz trybu logowania użytkowników) znajduje się w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdziale Konstruktor - projektowanie aplikacji.


4.11.1 Aktywacja mechanizmu dynamicznych zabezpieczen

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.11 Konfiguracja zabezpieczenia aplikacji > 4.11.1 Aktywacja mechanizmu dynamicznych zabezpieczeń

4.11.1 Aktywacja mechanizmu dynamicznych zabezpieczeń. Określenie trybu haseł poziomowych

Zakładka Zabezpieczenia umożliwia zdefiniowanie następujących parametrów:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Zabezpieczenia'.

  • Zabezpieczenia systemowe - pozwala aktywować mechanizm dynamicznych zabezpieczeń systemowych; w przypadku gdy aktywny jest system użytkowników aplikacji - wówczas zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora; gdy aktywny jest system haseł poziomowych - zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy aktywne jest hasło poziomu 4;

Wartość domyślna: zabezpieczenia systemowe są wyłączone

  • Tryb pracy systemu haseł:

  • Tryb użytkowników.

  • Tryb haseł poziomowych;

Wartość domyślna: ’Tryb użytkowników’


4.11.2 Parametryzacja systemu logowania

Zakładka Tryb użytkowników - aktywna w przypadku włączenia trybu pracy systemu zabezpieczeń użytkowników (zakładka Zabezpieczenia) jako Tryb użytkowników, pozwala określić:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Tryb użytkownika'.

  • Identyfikator domyślnego użytkownika - użytkownik taki jest automatycznie logowany (bez pytania o hasło) na starcie aplikacji systemu Asix;

Wartość domyślna: brak zadeklarowanego użytkownika domyślnego

  • Czas ważności hasła - określa czas ważności operacji zalogowania; po upływie zdefiniowanego czasu, użytkownik zostaje wylogowany lub następuje przełączenie na użytkownika domyślnego;

Wartość domyślna: 0, czyli czas ważności operacji logowania jest nieograniczony - aż do momentu wyłączenia aplikacji

  • Lista zdefiniowanych użytkowników - pozwala utworzyć pozycje użytkowników aplikacji obejmujące: identyfikator, nazwę, hasło i poziom uprawnień;

Wartość domyślna: brak listy zdefiniowanych użytkowników, co oznacza brak możliwości logowania do systemu Asix i tym samym brak możliwości wykonania operacji chronionych określonym poziomem zabezpieczeń

uwaga Deklaracje użytkowników przechowywane są w zewnętrznym pliku ’Users.ini’, znajdującym się w katalogu głównym aplikacji.


4.11.3 Parametryzacja systemu hasel poziomowych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.11 Konfiguracja zabezpieczenia aplikacji > 4.11.3 Parametryzacja systemu haseł poziomowych

4.11.3 Parametryzacja systemu haseł poziomowych

Zakładka Tryb haseł poziomowych - aktywna w przypadku włączenia trybu pracy systemu zabezpieczeń użytkowników (zakładka Zabezpieczenia) jako Tryb haseł poziomowych, pozwala określić:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Tryb haseł poziomowych'.

  • Czas ważności hasła - okresu czasu w minutach, w którym ustawione hasło pozostaje w stanie ważności;

Wartość domyślna: 15 minut

  • Lista zdefiniowanych haseł poziomowych - zawiera pozycje, w których zapisane są treści haseł dla poszczególnych poziomów.

Wartość domyślna: hasło nie jest zdefiniowane, co pociąga za sobą brak kontroli na danym poziomie (jeżeli zadeklarowany został tryb haseł poziomowych

uwaga Hasła poziomowe przechowywane są w zewnętrznym pliku ’Passwords.ini’, znajdującym się w katalogu głównym aplikacji.


4.11.4 Parametryzacja blokad

Zakładka Blokady pozwala zablokować wybrane elementy związane z obsługą aplikacji:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Blokady'.

  • Blokada zmian - umożliwia zablokowanie wykonania wszystkich komend, które mogą powodować zmianę stanu aplikacji w sposób niezamierzony przez projektanta: zablokowanie Konstruktora, zablokowanie edycji raportów, zablokowanie edycji trendów oraz zablokowanie możliwości otwierania masek z poziomu Panelu Kontrolnego za pomocą komendy MASKI.OTWÓRZ;

Wartość domyślna: domyślnie blokada jest wyłączona

  • Blokada zamykania aplikacji obejmuje warianty:

  • Zezwalaj na zamykanie aplikacji;

  • Nie zezwalaj na zamykanie aplikacji;

  • Zabezpiecz zamykanie aplikacji - hasłem lub też poziomem uprawnień:

  • Hasło lub poziom uprawnień - jeśli stosowany jest Tryb użytkowników a dostęp do aplikacji zablokowany został hasłem, wówczas znaczenia nabiera parametr Czas ważności logowania, zdefiniowany na zakładce Tryb użytkowników;

Wartość domyślna: domyślnie komenda końca jest dostępna bez ograniczeń

uwaga Blokada dotyczy tylko wyjścia poprzez zamknięcie Okna Konstruktora lub Panelu Kontrolnego. Dostępna jest jeszcze alternatywna metoda wyjścia poprzez akcję operatorską KONIEC.

  • Blokada konstruktora zawiera warianty:

  • Zezwalaj na przejście do konstruktora;

  • Nie zezwalaj na przejście do konstruktora;

  • Zabezpiecz przejście do konstruktora - hasłem lub poziomem uprawnień:

  • Hasło lub poziom uprawnień - jeśli stosowany jest Tryb użytkowników a dostęp do Konstruktora zablokowany został hasłem, wówczas znaczenia nabiera parametr Czas ważności logowania, zdefiniowany na zakładce Tryb użytkowników;

Wartość domyślna: domyślnie Konstruktor jest dostępny bez ograniczeń

  • Blokada Sterowania - pozwala zablokować wykonywanie w aplikacji operacji sterujących; stosowana na stanowiskach zdalnych;

Wartość domyślna: domyślnie sterowanie nie jest blokowane

uwaga Użycie blokady sterowania nie powoduje zakłóceń w pracy obiektów klasy PRZELICZNIK mimo, że wykonują one sterowanie.


4.12 Konfiguracja parametrow wydrukow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.12 Konfiguracja parametrów wydruków

4.12 Konfiguracja parametrów wydruków

Grupa wydruk ikonka Wydruk - to miejsce gdzie użytkownik ma możliwość zadeklarowania wyglądu wydruków - w tym wydruków alarmów.


4.12.1 Deklaracja zezwolenia na wydruki Deklaracja zmian

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.12 Konfiguracja parametrów wydruków > 4.12.1 Deklaracja zezwolenia na wydruki Deklaracja zmian kolorów

4.12.1 Deklaracja zezwolenia na wydruki. Deklaracja zmian kolorów wykonywanych podczas wydruków zrzutów masek

Zakładka Drukowanie pozwala zadeklarować użycie drukarki oraz zdefiniować zamianę kolorów wykonywanych podczas wydruków zrzutów masek lub ekranu:

Rysunek: Okno parametrów wydruków - zakładka 'Drukowanie'.

  • Zezwolenie drukowania - pozycja decydująca o tym, czy program będzie wykonywał wydruki; obsługiwane są wszystkie drukarki dostępne w systemie; jeżeli jakaś operacja nie pozwala na indywidualny wybór drukarki, to używana jest systemowa drukarka domyślna;

Wartość domyślna: domyślnie wydruki są wykonywane;

  • Zmiana koloru - pozycja pozwala na zdefiniowanie zamian kolorów wykonywanych podczas wydruków zrzutów masek lub ekranu;

sposób zapisu zamiany koloru:

r, g, b, zr, zg, zb, np.: 0,0,0,255,255,255 zamienia kolor czarny na biały,

parametry r, g, b (liczby dziesiętne określające składowe RGB) definiują kolor, który ma zostać na wydruku zamieniony na kolor zr, zg, zb.

Wartość domyślna: brak deklaracji


4.12.2 Deklaracja wydruku ekranu

Zakładka Wydruk ekranu pozwala określić następujące parametry:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk ekranu'.

  • Automatyczny zrzut:

  • Pytaj przed wykonaniem zrzutu ekranu;

  • Nie pytaj przed wykonaniem zrzutu ekranu;

  • Nie pytaj przed wykonaniem zrzutu ekranu i nie wyświetlaj informacji po jego wykonaniu;

Wartość domyślna: domyślnie przed każdym zrzutem ekranu otwierane jest okno dialogowe w celu określenia parametrów zrzutu

  • Parametry zrzutu - pozycja określająca parametry zrzutu ekranu:

  • Blokada zrzutu - blokada zrzutu ekranu;

  • Okno - zaznaczenie opcji umożliwi zrzut aktywnego okna;

  • Ekran - zaznaczenie opcji umożliwi zrzut całego ekranu;

  • Plik BMP - zaznaczenie opcji umożliwi zrzut do pliku w formacie BMP;

  • Drukarka - zaznaczenie opcji umożliwi wydruk w formacie wybranej drukarki;

Wartość domyślna: domyślne ustawienia: wykonywany jest zrzut całego ekranu do pliku w formacie BMP;

uwaga Podane parametry mogą być zmodyfikowane przez operatora, jeżeli nie zostanie użyta opcja Automatyczny zrzut.

  • Kartoteka zrzutów ekranu - parametr pozwala określić kartotekę roboczą aplikacji; kartoteka robocza służy jako miejsce przechowania plików zrzutów ekranu;

Wartość domyślna: jeśli pozycja nie zostanie wykorzystana, jako kartoteka robocza zostanie użyta kartoteka aktywna w momencie startu aplikacji.


4.12.3 Deklaracja parametrow czcionek oraz naglowkow i stopek

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.12 Konfiguracja parametrów wydruków > 4.12.3 Deklaracja parametrów czcionek oraz nagłówków i stopek

4.12.3 Deklaracja parametrów czcionek oraz nagłówków i stopek

Zakładka Wydruk określa parametry dotyczące formatu nagłówków i stopek oraz rodzaju czcionek wykorzystywanych w tworzonych wydrukach (zrzutach masek):

  • Zakładka Nagłówki i stopki:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk' / 'Nagłówki i stopki'.

  • Nazwa aplikacji - tekst wyświetlany w linii nagłówków i stopek tworzonych wydruków;

  • Nagłówek - określa tekst nagłówka na wszystkich rodzajach wydruków (oprócz alarmów on-line - dla których tekst nagłówka definiowany jest na zakładce Wydruk alarmów);

Wartość domyślna: w przypadku, gdy użytkownik nie zadeklaruje własnego tekstu nagłówka, domyślnie wstawiony zostanie tekst określany znakiem sterującym: &w | | ASIX.

  • Stopka - definiuje tekst stopki na wszystkich rodzajach wydruków (oprócz alarmów on-line - dla których tekst stopki definiowany jest w pozycji Stopka listingu alarmów na zakładce Wydruk alarmów);

Wartość domyślna: określana jest znakami sterującymi &D &T|&p|&c; dopuszczalne są znaki sterujące opisane w pozycji Nagłówek.

  • Marginesy - pozwala ustawić marginesy dla wydruków; pozycja dotyczy wszystkich drukarek i większości wydruków (oprócz wydruku trendów i wydruków wykonywanych w trybie tekstowym); jednostką marginesów jest 1/10 mm;

Wartość domyślna: wszystkie marginesy są równe 0;

  • Zakładka Czcionki:

Rysunek: Okno parametrów wydruków - zakładka' Wydruk' / 'Czcionki'.

  • Czcionka - określenie czcionki dla wydruku informacji tekstowej; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Courier New,0;

  • Czcionka nagłówka - określa czcionkę używaną do drukowania nagłówków; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Times New Roman,30;

  • Czcionka stopki - określa czcionki używane do drukowania stopek; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Times New Roman,30.

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.


4.12.4 Deklaracja wydruku raportow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.12 Konfiguracja parametrów wydruków > 4.12.4 Deklaracja wydruku raportów

4.12.4 Deklaracja wydruku raportów

Zakładka Wydruk raportów pozwala zadeklarować:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk raportów'.

  • Nagłówek raportu - definiuje tekst nagłówka jaki jest dodawany do wydruku raportu;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek na zakładce Wydruk.

  • Stopka raportu - definiuje tekst stopki jaki jest dodawany do wydruku raportu;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka na zakładce Wydruk.

  • Ustawienia / Raporty w trybie tekstowym - standardowo raporty są wykonywane w trybie graficznym. Skutkiem użycia tej opcji jest to, że stosowane we wcześniejszych raportach sekwencje sterujące czcionką wstawiane w treść raportu przestają działać. Włączenie trybu tekstowego powoduje wydruk raportów w sposób kompatybilny z wersjami programu AS wcześniejszymi od 2.59;

Wartość domyślna: wydruk w trybie graficznym

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.


4.12.5 Deklaracja wydruku alarmów

Zakładka Wydruk alarmów obejmuje parametry definiujące format wydruku alarmów historycznych oraz aktywnych:

  • Zakładka Nagłówki i stopki:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Nagłówki i stopki'.

  • Nagłówek alarmów historycznych - definiuje tekst nagłówka na wydrukach alarmów historycznych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek (zakładka Wydruk);

  • Nagłówek alarmów aktywnych - definiuje tekst nagłówka na wydrukach alarmów aktywnych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek (zakładka Wydruk);

  • Stopka alarmów historycznych - definiuje tekst stopki na wydrukach alarmów historycznych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka (zakładka Wydruk);

  • Stopka alarmów aktywnych - definiuje tekst stopki na wydrukach alarmów aktywnych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka (zakładka Wydruk);

  • Nagłówek listingu alarmów - definiuje tekst nagłówka używanego podczas wydruku alarmów bieżących w trybie graficznym;

Wartość domyślna: domyślnie drukowany jest tekst: listing zdarzeń alarmowych| |

  • Stopka listingu alarmów - definiuje tekst stopki używanej podczas wydruku alarmów bieżących w trybie graficznym;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany znakami sterującymi:

&D &T|&p|&c

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.

  • Zakładka Czcionki zawiera definicje czcionek wykorzystywanych w wydrukach alarmów:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Czcionki'.

  • Czcionka alarmów - określa czcionki dla wydruku alarmów w trybie graficznym; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Courier New,0;

  • Czcionka nagłówka alarmów - określa czcionki używane w nagłówkach wydruków alarmów; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: jeśli parametr nie jest określony, obowiązuje ustawienie z pozycji Czcionka nagłówka (zakładka Czcionki);

  • Czcionka stopki alarmów - określa czcionki używane w stopkach wydruków alarmów; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: jeśli parametr nie zostanie określony, obowiązuje ustawienie z pozycji Czcionka stopki (zakładka Czcionki).

  • Zakładka Opcje pozwala zdefiniować:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Opcje'.

  • Długość tekstu alarmu - określa ilość znaków używanych do wydruku tekstu alarmu; standardowo długość ta jest wyliczana na około 90 znaków, tak aby cała linia wydruku nie przekraczała 120 znaków;

  • Formaty wydruku alarmów:

  • Format linii alarmów - określa ilość i kolejność drukowania informacji; jest to łańcuch znakowy złożony z liter definiujących typy pól - znaki definiujące format linii alarmów znajdują się w Załącznik 5;

  • Format linii alarmów systemowych - pozycja pozwala określić format używany do wydruku alarmów systemowych; znaki używane do definicji formatu są opisane przy pozycji Format linii alarmów;

Wartość domyślna: formatem domyślnym jest format podany w pozycji Format linii alarmów;

  • Ustawienia:

  • Drukuj zdarzenia systemowe - specyfikuje, czy należy drukować zdarzenia systemowe;

Wartość domyślna: domyślnie zdarzenia systemowe są drukowane

  • Liniowy wydruk alarmów - pozycja określa tryb wydruku alarmów bieżących; tryb liniowy jest wydrukiem tekstowym, identycznym z trybem używanym w wersjach programu AS poniżej 2.59; linie alarmów są drukowane po jednej w momencie zajścia zdarzenia (drukarka może jednak zbuforować tekst wewnętrznie i wydrukować dopiero pełną stronę); w trybie graficznym wydruku najpierw gromadzona jest pełna strona alarmów i dopiero wtedy jest wykonywany wydruk; dodawane są również nagłówek i stopka wydruku;

Wartość domyślna: wydruki alarmów bieżących domyślnie wykonywane są w trybie graficznym;

  • Separator daty w wydrukach alarmów historycznych - określa, czy w wydruku alarmów historycznych mają być wstawiane linie sygnalizujące zmianę daty alarmów;

Wartość domyślna: domyślnie parametr nie jest używany;

  • Wydruk alarmów - pozycja powodująca włączenie natychmiastowego wydruku alarm;

  • Drukuj na domyślnej drukarce - użycie pierwszej formy pozycji oznacza wydruk na domyślnej drukarce systemowej;

  • Nie drukuj alarmów;

  • Drukuj na wybranej drukarce - pozwala określić dowolną zainstalowaną na komputerze drukarkę.

Wartość domyślna: wydruk na domyślnej drukarce


4.12.6 Znaki specjalne sterujące formatem wydruków

Zestawienie znaków sterujących wyglądem nagłówków i stopek znajduje się w Załącznik 4.

Zestawienie znaków sterujących formatem linii alarmów znajduje się w Załącznik 5.


4.13 Deklaracja obslugi definicji raportow

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.13 Deklaracja obsługi definicji raportów

4.13 Deklaracja obsługi definicji raportów

Moduł [image] Raporty obejmuje parametry konfiguracyjne modułu raportowego.

Zakładka Raporty obejmuje następujące parametry konfiguracyjne:

Rysunek: Okno parametrów raportów - zakładka 'Raporty'.

  • Blokada edycji - pozycja umożliwiająca zablokowanie możliwości poprawiania definicji raportów w trybie wykonania aplikacji; odblokowanie edycji może być celowe w czasie rozruchu (nie jest wymagane wówczas przechodzenie do Konstruktora);

Wartość domyślna: domyślnie parametr jest wyłączony, co oznacza, że można zmieniać raporty w trybie wykonania aplikacji

  • Blokada skalowania - użycie parametru pozwala na blokadę rozmiaru okna raportów;

Wartość domyślna: domyślnie operator może dowolnie zmieniać rozmiar okna raportów;

  • Kartoteka, w której znajdują się pliki z definicjami raportów;

Wartość domyślna: domyślnie pliki z definicjami raportów znajdują się w bieżącej kartotece aplikacji

  • Liczba dni o jaką maksymalnie można się cofnąć przy obliczaniu raportów - podaje okres czasu liczony wstecz od momentu bieżącego (w dniach), o jaki maksymalnie można się cofnąć przy obliczaniu raportów; podanie okresu niedodatniego lub większego od 366 dni powoduje przyjęcie okresu domyślnego: 366 dni;

Wartość domyślna: 0 dni

uwaga Pozycja ta pozwala na pewne zaoszczędzenie pamięci operacyjnej wymaganej do uruchomienia modułu raportowego. Ograniczenie dopuszczalnego okresu może pozwolić na obliczanie raportów w sytuacji, w której normalnie moduł raportowy nie mógł wcześniej wystartować ze względu na brak pamięci.


4.13.1 Deklaracja plikow raportow skryptowych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.13 Deklaracja obsługi definicji raportów > 4.13.1 Deklaracja plików raportów skryptowych

4.13.1 Deklaracja plików raportów skryptowych

Zakładka Parametry skryptowe obejmuje:

Rysunek: Okno parametrów raportów - zakładka 'Raporty skryptowe'.

  • Pliki raportów skryptowych - pozwala zadeklarować użycie raportu skryptowego wg nastęopującego

format zapisu:

nazwa_raportu, nazwa_pliku_kodu_raportu [, nazwa_pliku _wynikowego, parametry_raportu]

gdzie:

nazwa_raportu - parametr jest dowolnym tekstem opisującym raport; nazwa ta będzie wyświetlana na liście raportów okna Raportera oraz będzie służyła do uruchamiania raportu przy pomocy akcji operatorskich;

nazwa_pliku_kodu_raportu - parametr służy do podania nazwy pliku z kodem raportu; można podać pełną ścieżkę do pliku lub tylko nazwę pliku wraz z rozszerzeniem; w drugim przypadku plik raportu będzie poszukiwany w katalogu podanym w pozycji Kartoteka, w której znajdują się pliki z definicjami raportów i w katalogach ścieżki masek;

nazwa_pliku_wynikowego - parametr służy do podania nazwy bazowej plików, w których będą przechowywane wygenerowane raporty; nazwy plików wynikowych tworzone są poprzez dodanie do nazwy bazowej rozszerzenia zależnego od daty tworzenia raportu; parametr nazwa_pliku_wynikowego powinien być użyty tylko wtedy, gdy na podstawie tego samego pliku kodu tworzone są różne rodzaje raportów (patrz opis parametru parametry_raportu); pominięcie parametru lub wstawienie znaku * oznacza, że nazwy plików wynikowych raportu są tworzone na podstawie nazwy pliku kodu raportu;

parametry_raportu - parametr pozwala na tworzenie parametryzowanych plików kodu raportu; zawartość parametru jest w całości przekazywana do skryptu w momencie jego uruchomienia i może służyć do sterowania pracą skryptu; należy pamiętać o tym, aby w przypadku używania tego samego pliku kodu raportów w wielu pozycjach SKRYPT, podawać w każdej z nich unikalną nazwę pliku wynikowego.

W treści parametrów raportu można podawać parametry wykonawcze skryptera (więcej na temat deklaracji skryptu można znaleźć w podręczniku ”Skrypty - podręcznik użytkownika” - plik Skrypty.hlp lub Skrypty.pdf):

//S - w danej chwili może być uruchomiony tylko jeden skrypt z parametrem //S, zawarty w podanym pliku; parametr ma znaczenie tylko w przypadku uruchamiania skryptu jako akcji operatorskiej systemu Asix; moduł skryptów odrzuci próbę ponownego uruchomienia skryptu w sytuacji, gdy poprzednie uruchomienie skryptu z parametrem //S, zawartego w tym samym pliku, jeszcze się nie zakończyło; brak tego parametru powoduje, że można równocześnie uruchamiać wiele skryptów w oparciu o program zawarty w tym samym pliku;

//X - po uruchomieniu skryptu jest również uruchamiany debugger (zainstalowany w systemie jako domyślny); debugger zatrzymuje wykonanie skryptu na pierwszej instrukcji skryptu;

//D - wystąpienie błędu w skrypcie powoduje uruchomienie debuggera;

//IT:nnn - ograniczenie czasu wykonania części inicjalizacyjnej wyrażone w milisekundach;

//T:nnn - ograniczenie czasu wykonania części zdarzeniowej wyrażone w milisekundach;

//E:nazwa - podaje nazwę języka skryptu (np. //E:JScript);

//Watek:nazwa[,pri] - podaje nazwę wątku, w którym wykonuje się skrypt oraz określa priorytet pri wątku; nazwa wątku może być dowolna i służy grupowaniu skryptów wykonywanych w jednym wątku; priorytety wątku skryptu:

0 IDLE - bezczynny,

1 LOWEST - najniższy,

2 BELOW_NORMAL - poniżej normalnego,

3 NORMAL - normalny (domyślny),

4 ABOVE_NORMAL - powyżej normalnego,

5 HIGHEST - najwyższy,

6 TIME_CRITICAL - krytyczny czasowo;

domyślnym priorytetem wątku jest priorytet 3 (normalny);

//U - podanie tego parametru spowoduje, że nie będą generowane zdarzenia ”OnRead" oraz funkcje zdarzeń czasowych zdefiniowane metodami SetInterval i ExecuteAt, jeśli okna aplikacji Asix są ukryte (np. za pomocą akcji operatorskiej UKRYJ).

uwaga Parametry wykonawcze podaje się w konwencji programu cscript, tj. są one poprzedzone podwójnym ukośnikiem.


4.13.2 Deklaracja listy operatorow do okna raportowego

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.13 Deklaracja obsługi definicji raportów > 4.13.2 Deklaracja listy operatorów do okna raportowego

4.13.2 Deklaracja listy operatorów do okna raportowego

Zakładka Lista operatorów obejmuje parametr:

Rysunek: Okno parametrów raportów - zakładka 'Raporty' / 'Lista operatorów'.

  • Lista operatorów - pozwala zadeklarować nazwiska operatorów, które będą wyświetlane w oknie raportowym.


4.14 Konfiguracja parametrow skryptow i akcji

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.14 Konfiguracja parametrów akcji i terminarzy akcji

4.14 Konfiguracja parametrów akcji i terminarzy akcji

Grupa skrypty i akcje Akcje i terminarze obejmuje parametry związane z:

  • deklaracją akcji złożonych;

  • konfiguracją terminarza.

- Lista akcji operatorskich wraz z parametryzacją przy użyciu edytora akcji omówiona została w punkcie 4.16. Lista akcji operatorskich.

- Ponadto szczegółowy opis składni akcji operatorskich znajduje się również w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdział 16.1 Opisy akcji operatorskich.


4.14.1 Deklaracja akcji zlozonych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.14 Konfiguracja parametrów akcji i terminarzy akcji > 4.14.1 Deklaracja akcji złożonych

4.14.1 Deklaracja akcji złożonych

Zakładka Akcje złożone pozwala zdefiniować dla danej aplikacji akcje złożone, będące sekwencją dowolnego zestawu akcji operatorskich, przypisanych do jednej akcji operatora.

Lista akcji operatorskich wraz z parametrami omówiona została w punkcie 4.16 Lista akcji operatorskich.

Zaimplementowany generator bazy akcji złożonych umożliwia generowanie definicji akcji na podstawie danych zawartych w plikach *. act (przycisk Importuj akcje złożone (act)) oraz eksportowanie definicji akcji do zewnętrznego pliku *.xls (przycisk Eksportuj akcje złożone (xls)).

Dla ułatwienia użytkownik ma możliwość załączania/wyłączania wszystkich akcji należących do jednej akcji złożonej za pomocą skrótu klawiszowego Ctrl + '+' / Ctr + '-'. Wystarczy kliknąć na nagłówek Akcje składowe lub na definicje jednej z akcji i użyć skrótu.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Akcje złożone'.


4.14.2 Deklaracja terminarza akcji

Zakładka Terminarz pozwala sparametryzować moduł programu AS, który pozwala na automatyczne wykonywanie wybranych akcji w konkretnym terminie lub w odpowiedzi na zmianę wartości wybranej zmiennej procesowej.

Szczegółowy opis modułu Terminarz znajduje się w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdział 17 Terminarz akcji.

Typowym zastosowaniem terminarza jest automatyczne okresowe obliczanie raportów lub wykonywanie akcji związanych z obsługą bazy danych po otrzymaniu sygnału ze sterownika.

Zakładka Terminarz czasowy - umożliwia zdefiniowanie akcji terminarza, uruchamianych na podstawie warunków czasowych.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Terminarz czasowy'.

W polu Termin znaczenie poszczególnych pól jest następujące:

  • Czas wykonania - pole służące do podania czasu (z dokładnością do minuty), w którym akcja ma zostać wykonana;

  • Potwierdzenie - zaznaczenie pola wyboru powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania,

  • Dzień wykonania - pole służące do podania numeru dnia w miesiącu, w którym akcja ma zostać wykonana; wartość Codziennie umożliwia wykonywanie akcji codziennie.

  • Akcja - treść akcji, która ma zostać wykonana;

Zakładka Terminarz zdarzeniowy - umożliwia zdefiniowanie akcji terminarza, uruchamianych w odpowiedzi na zmianę wartości wybranej zmiennej procesowej.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Terminarz zdarzeniowy'.

Pole Okres - oznacza okres sprawdzania monitorowanych zmiennych.

Wartość domyślna: 10 s.

W polu Zdarzenie znaczenie poszczególnych pól jest następujące:

  • Nazwa zmiennej - nazwa zmiennej procesowej, od której wartości jest uzależnione wykonanie akcji;

  • Warunek - rozwijana lista służąca do określenia rodzaju sprawdzanego warunku; dostępne są 4 typy warunków:

= - zmienna równa podanej wartości,

> - zmienna większa od ograniczenia,

< - zmienna mniejsza od ograniczenia,

& - iloczyn logiczny zmiennej i podanej wartości,

  • Wartość - liczba względem której porównywana jest wartość monitorowanej zmiennej procesowej; jest to dziesiętna liczba całkowita lub liczba zmiennoprzecinkowa; program automatycznie uzgadnia typy danych zmiennej i wartości; nie można stosować warunku typu "&" dla danych zmiennoprzecinkowych.

  • Potwierdzenie - wybranie tego pola powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania

  • Akcja - treść akcji, która ma zostać wykonana;


4.14.3 Określenie trybu pracy bazy akcji złożonych

Architekt daje możliwość definiowania akcji złożonych w dwojaki sposób, określany Trybem pracy bazy akcji złożonych:

- definicje akcji złożonych są wprowadzane przez projektanta w module Akcje i terminarze > na zakładce Akcje złożone;

- definicje akcji złożonych są generowane na podstawie danych w arkuszach kalkulacyjnych.

Drugi z wymienionych trybów wskazany jest w pracy z dużą ilością akcji złożonych. Umożliwia zdefiniowanie akcji w kilku arkuszach, a następnie zaimportowanie ich definicji do podanego obszaru/komputera. Aby zmienić definicję akcji, należy zmodyfikować pliki źródłowe i wygenerować od nowa bazę akcji złożonych. W przypadku stosowania tego trybu pracy edytor akcji umożliwia jedynie przeglądanie akcji.

Deklaracja trybu pracy bazy akcji złożonych odbywa się za pomocą parametru umieszczonego w module Bazy danych > Baza akcji złożonych > zakładka Tryb pracy.

Rysunek: Okno Bazy akcji złożonych - zakładka 'Tryb pracy'.


4.15 Grupa Pozostale

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.15 Grupa Pozostałe

4.15 Grupa Pozostałe

Grupa rózne Pozostałe zawiera parametry nie zaklasyfikowane do pozostałych grup. Są to następujące kategorie parametrów:

- Aplikacja,

- Parametry skryptów,

- Parametry skryptu - dane archiwalne,

- Przelicznik,

- Opcje wprowadzane bezpośrednio.


4.15.1 Deklaracja rozmiaru aplikacji oraz kartoteki roboczej

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.15 Grupa Pozostałe > 4.15.1 Deklaracja rozmiaru aplikacji oraz kartoteki roboczej dla plików zrzutów ekranów

4.15.1 Deklaracja rozmiaru aplikacji oraz kartoteki roboczej dla plików zrzutów ekranów

Zakładka Aplikacja pozwala określić parametry:

Rysunek: Okno parametrów pozostałych - zakładka 'Aplikacja'.

  • Rozmiar aplikacji - rozdzielczość ekranu w pikselach, w której tworzona jest aplikacja; użycie pozycji oznacza, że w przypadku pracy w rozdzielczości ekranu większej od podanej w pozycji, punkt otwarcia masek i innych elementów będzie tak przesuwany, ażeby aplikacja działała na środku ekranu;

Wartość domyślna: w przypadku nie zadeklarowania wartości, okno aplikacji pojawi się w lewym górnym rogu ekranu o rozdzielczości większej od tej, w której wykonywana była aplikacja

  • Klawisze dla ekranu - włączenie pozycji powoduje, że interpretacja znaczenia przyciśniętych klawiszy zależy od aktualnego położenia kursora myszki; brane są pod uwagę tylko maski znajdujące się na tym samym ekranie co myszka; pozycja ma zastosowanie w systemach wielomonitorowych; mechanizm ten pozwala na różną interpretację znaczenia klawisza w zależności od ekranu, którego w danej chwili używa operator;

Wartość domyślna: opcja wyłączona


4.15.2 Parametryzacja obsługi skryptów

Zakładka Parametry skryptów pozwala określić:

Rysunek: Okno parametrów pozostałych - zakładka 'Parametry skryptów'.

  • Plik logu - parametr określa nazwę pliku, w którym będą zapisywane informacje diagnostyczne;

Wartość domyślna: jeśli parametr nie jest podany, to plik logu nie zostanie utworzony

  • Ustawienia debuggera - parametr określa zakres współpracy modułu skryptów z debuggerem skryptów

  • Uruchamiaj skrypty bez debuggera - wybranie tej opcji oznacza, że debugger nie zostanie nigdy uruchomiony; w przypadku timeoutu lub błędu skryptu do panelu programu AS zostanie wyprowadzona informacja o błędzie z podaniem numeru linii i znak; parametry wykonawcze //X i //D podawane w deklaracji skryptu nie mają znaczenia, jeśli zadeklarowana zostanie opcja Uruchamiaj skrypty bez debuggera;

  • Uruchamiaj skrypty pod kontrolą debuggera - opcja umożliwia uruchamianie skryptów pod kontrolą debuggera;

  • Uruchamiaj skrypty i włączaj debugger w chwili inicjalizacji modułu skryptów;

Wartość domyślna: Uruchamiaj skrypty bez debuggera

uwaga Parametr Ustawienia debuggera ma znaczenie tylko wtedy, gdy w systemie operacyjnym Windows został zainstalowany odpowiedni debugger skryptów.

  • Maksymalny czas obsługi zdarzenia przez skrypt - parametr określa maksymalny czas obsługi zdarzenia przez skrypt. Jeśli wartością tego parametru jest 0, to czas obsługi zdarzenia nie jest ograniczony. Jednostką jest czas wyrażony w milisekundach.

Wartość domyślna: 5000 milisekumd

  • Maksymalny czas wykonania części inicjalizacyjnej skryptu - parametr określa maksymalny czas wykonywania części inicjalizacyjnej skryptu. Jeśli wartością tego parametru jest 0, to czas wykonywania części inicjalizacyjnej skryptu nie jest ograniczony. Jednostką jest czas wyrażony w milisekundach.

Wartość domyślna: 15000 milisekumd

  • Automatyczne przeładowywanie w przypadku błędów - jeśli opcja jest włączona, to błędy czasu wykonania wykryte w fazie inicjalizacji skryptu oraz w czasie pierwszego wywołania dowolnej funkcji obsługującej zdarzenia, powodują zakończenie skryptu. Błąd, który wystąpi później, spowoduje zakończenie bieżącego wykonania skryptu, a następnie skrypt jest ponownie uruchamiany od początku.

Wartość domyślna: opcja załączona

Zakładka Parametry skryptu - dane archiwalne pozwala określić:

Rysunek: Okno parametrów pozostałych - zakładka 'Parametry skryptów - dane archiwalne'.

  • Tryb agregacji - opcja ustawia wartość parametru AggregateMode. Służy do określenia trybu agregacji dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości 0 (ASKOM), 1 (OPC) lub 2 (RAPORT).

Wartość domyślna: 0 - tryb ASKOM.

  • Próg jakości dobrej - opcja ustawia wartość parametru QualityGoodThreshold. Służy do określenia progu jakości dla próbek dobrych dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości od 0 do 100 (próg jakości wymnożony przez 100 i wyrażony w procentach).

Wartość domyślna 80 - 80% próbek daje jakość dobrą.

  • Próg jakości złej - opcja ustawia wartość parametru QualityBadThreshold. Służy do określenia progu jakości dla próbek złych dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości od 0 do 100 (próg jakości wymnożony przez 100 i wyrażony w procentach).

Wartość domyślna 0 - każdy agregat, który nie jest dobry, jest zły i nie ma niepewnych.

uwaga Więcej informacji nt parametrów z zakładki 'Parametry skryptów - dane archiwalne' - patrz: odrębny podręcznik do modułu AsSkrypter - plik Skrypty.chm/pdf, rozdz. 6.12. Obiekt Variable.


4.15.3 Parametryzacja obiektów PRZELICZNIK i WYRAŻENIE

Zakładka Przelicznik zawiera parametry:

Rysunek: Okno parametrów pozostałych - zakładka 'Przelicznik'.

  • Maksymalny czas - maksymalny czas (w sekundach) liczenia się obiektu PRZELICZNIK lub WYRAŻENIE;

Wartość domyślna: 30 sekund

  • Przeciążenia - pozycja pozwala zablokować komunikaty diagnostyczne informujące o przeciążeniach w obiektach PRZELICZNIK i WYRAZENIE;

Wartość domyślna: domyślnie komunikaty są generowane;


4.15.4 Deklaracja parametrów wprowadzanych bezpośrednio

uwaga Zakładka Opcje wprowadzane bezpośrednio pojawia się po wybraniu polecenia: Widok > Pokaż opcje zaawansowane

Rysunek: Okno parametrów pozostałych - zakładka 'Opcje wprowadzane bezpośrednio'.

Zakładka Opcje wprowadzane bezpośrednio pozwala zadeklarować dla danej aplikacji pozycje, których edycja nie jest wspierana przez moduł Architekt - tzn. są to pozycje używane w starszych wersjach pakietu Asix lub zupełnie nowe pozycje.


4.17. Konfiguracja aplikacji wielojezycznej

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.16. Konfiguracja aplikacji wielojęzycznej

4.16 Konfiguracja aplikacji wielojęzycznej

System aplikacji wielojęzycznych pozwala przełączać na żądanie operatora język pracy aplikacji. Przełączeniu podlegają wszystkie teksty wprowadzone przez projektanta na etapie tworzenia aplikacji.

Sparametryzowanie aplikacji do pracy w kilku językach wymaga wykonania następujących kroków:

  1. Pierwszą rzeczą, którą należy wykonać jest ustawienie parametrów deklarowanych języków:

    Maski > zakładka Języki:

    pl, Polski, EastEurope

    en, Angielski, EastEurope

    Ważna jest przy tym kolejność wpisywanych języków – pierwszy język jest głównym (domyślnym) językiem.

    Szczegółowy opis dotyczący deklarowania kilku języków pracy dla aplikacji znajduje się w części ”Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji”, rozdziale Aplikacje wielojęzyczne.

  2. Następnie należy utworzyć listę używanych w aplikacji tekstów. Z pomocą przychodzi tu mechanizm Tablicy Translacji, który służy do tłumaczenia tekstów wprowadzonych przez operatora w trakcie definiowania aplikacji. Dotyczy to głównie tekstów z obiektów umieszczonych na maskach wizualizacyjnych.

Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TranslateTable.Lng. Jest to plik tekstowy, w którym poszczególne linie są tekstami wielojęzycznymi.

Bazowy plik Tablicy Translacji można wygenerować automatycznie przy pomocy funkcji PLIK_TŁUMACZEŃ z menu NARZĘDZIA okna Konstruktora.

Po wybraniu kategorii generowanych informacji i użyciu przycisku Generuj wszystkie znalezione teksty zostaną zapisane w pliku TranslateTable.Tlt. Jeżeli istniał wcześniej plik TranslateTable.Lng, to wszystkie zawarte w nim tłumaczenia będą przeniesione do pliku generowanego.

Projektant powinien uzupełnić brakujące tłumaczenia bezpośrednio w pliku TranslateTable.Lng lub uzupełnić plik TranslateTable.Tlt i przemianować go na TranslateTable.Lng.

Po wygenerowaniu tablicy translacji należy uzupełnić wpisy wg poniższego przykładu:

[pl]tekst polski[en]english text

Edycji tekstów można dokonać przy pomocy edytora modułu Architekt:

Maski > zakładka Języki > Tablica translacji, przycisk Edytuj

  3. Jeżeli aplikacja zaciąga opisy z bazy definicji zmiennych, należy również tam wprowadzić pewne modyfikacje. W pliku XLS obok kolumny Opis w każdym arkuszu należy utworzyć kolumny o nazwach w stosownych językach (w których ma pracować aplikacja), w których należy umieścić odpowiedniki opisów znajdujących się w kolumnie Opis.

W przypadku arkusza źródłowego do generowania bazy definicji alarmów Alarmy opis znajduje się w jednej kolumnie zgodnie z zapisem: [pl]tekst polski[en]english text.

  4. Do tłumaczenia tekstów aplikacji wielojęzycznych stosowany jest również mechanizm Tablicy Tekstów, który służy do tłumaczenia tekstów, które są wyświetlane w ramach elementów aplikacji i nie są podawane jawnie przez projektanta (są wbudowane w kod programu). Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TextTable.Lng.

Plik Tablicy Tekstów jest plikiem tekstowym, w którym poszczególne linie są tekstami wielojęzycznymi określającym tłumaczenia tekstów.

W ramach pakietu Asix jest dostarczany plik TextTable.Tlt zawierający kompletną tablicę tekstów dla języków polskiego i angielskiego. Projektant powinien skopiować ten plik do katalogu aplikacji pod nazwą TextTable.Lng, a następnie uzupełnić teksty wielojęzyczne o definicje wariantów dla pozostałych używanych języków aplikacji.

Zasada działania Tablicy Tekstów polega na wyszukiwaniu wśród zdefiniowanych wielojęzycznych tekstów tłumaczenia dla tekstu wbudowanego w program.

Edycji tekstów można dokonać przy pomocy edytora modułu Architekt:

Maski > zakładka Języki > Tablica tekstów, przycisk Edytuj


4.18. Uruchomienie aplikacji

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.17 Uruchomienie aplikacji

4.17 Uruchomienie aplikacji

Jak utworzyć ikonę skrótu uruchamiającą aplikację systemu Asix:

  1. W oknie modułu Architekt otwórz plik XML aplikacji i wybierz z paska menu polecenie Narzędzia > Kreator skrótów...

  2. Określ rodzaj skrótu (Skrót do Asix), nazwę stacji - której aplikację chcesz uruchomić, nazwę skrótu, lokalizację skrótu (Pulpit lub Wybrany katalog) i naciśnij przycisk Utwórz.

  3. Teraz aplikacja może być uruchamiana za pomocą skrótu np. z Pulpitu.

Aplikacja może być również uruchamiana w czasie pracy modułu Architekt za pomocą polecenia Uruchom system Asix z menu Aplikacja. Uruchomieniu podlega plik konfiguracyjny XML z podaniem parametrów zadeklarowanych dla określonego stanowiska.

Kreator skrótów… daje również możliwość tworzenia skrótów do programu Architekt i AsTrend. W szczególności, tworząc skrót do programu Architekt, możliwe jest zadeklarowanie wsadowego generowania baz - pod warunkiem, że dla danego pliku konfiguracyjnego aplikacji zostały zadeklarowane wcześniej bazy: definicji alarmów, definicji zmiennych i definicji akcji złożonych.

Rysunek: Okno Kreatora skrótów.


4.19. Konfigurator aplikacji AsPortal

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.18 Konfigurator aplikacji AsPortal

4.18 Konfigurator aplikacji AsPortal

Wbudowany w program Architekt - konfigurator aplikacji AsPortal pozwala łatwo uruchomić portal informacji procesowych zaprojektowanej aplikacji.

Szczegółowy opis dotyczący funkcjonalności oraz sposobu konfigurowania aplikacji AsPortal znajduje się w odrębnym podręczniku ”AsPortal - Wizualizacja i nadzór nad realizacją procesów przemysłowych z wykorzystaniem przeglądarki internetowej” (plik AsPortal.CHM/PDF).

Konfigurator aplikacji AsPortal uruchamiany jest komendą z menu głównego (Architekt uruchomiony w trybie administratora):

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsPortal

Obsługa Konfiguratora sprowadza się do użycia przycisków: Konfiguruj, Ustaw oraz Uruchom AsPortal.

1. Przycisk Konfiguruj na zakładce Konfiguracja serwera - tworzy kanał AsixConnect, parametryzuje plik Web.Config, nadaje prawa dostępu do katalogu bazy definicji zmiennych. Aby komenda zadziała, należy w pierwszej kolejności zainstalować moduł Asix4Internt z instalatora pakietu Asix.

Operację należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

2. Kilka przycisków Ustaw umożliwiających konfigurację dostępu do aplikacji znajduje się na zakładkach Ustawienia dostępu:

Aplikację można skonfigurować w taki sposób, aby dostęp do niej był anonimowy lub oparty o uwierzytelnianie systemu Windows.

Dla aplikacji AsPortal oznacza to możliwość ustawienia:

a) dostępu do przeglądania wartości zmiennych

lub

b) dostępu do modyfikowania wartości zmiennych.

ad a)

Aby ustanowić dostęp do przeglądania wartości zmiennych, należy ustawić dla aplikacji AsPortal uwierzytelnianie systemu Windows (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu > opcja Uwierzytelnianie Windows), a w bazie definicji zmiennych dodać atrybut Grupa uprawnień odczytu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienOdczytu). Następnie dla każdej zmiennej należy podać w bazie definicji zmiennych, jako wartość atrybutu Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do przeglądania wartości zmiennej.

UWAGA:

Pozostawienie pustego pola dla atrybutu Grupa uprawnień odczytu dla danej zmiennej będzie oznaczać, że zmienna ta będzie niewidoczna dla wszystkich użytkowników.

UWAGA: Załączenie mechanizmu uwierzytelniania dla AsPortala wymaga uprzedniego załączenia funkcji systemu Windows: 'Uwierzytelnianie Windows'.

Rys. Załączenie funkcji uwierzytelniania Windows.

Rys. Funkcja uwierzytelniania systemu Windows dla aplikacji AsPortal.

PRZYKŁAD

Rys. Ustawienie funkcji uwierzytelniania systemu Windows dla aplikacji AsPortal.

Rys. Grupa użytkowników Windows.

Rys. Nadanie grupie użytkowników 'TEST' uprawnienia odczytu zmiennej 'A046'.

Rys. AsPortal - dostęp do zmiennej 'A046' przez użytkownika z grupy 'TEST'.

ad b)

Aby ustanowić dostęp do modyfikowania wartości zmiennych, należy:

- ustawić uwierzytelnianie systemu Windows dla aplikacji AsPortal (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu > opcja Uwierzytelnianie Windows),

- załączyć funkcję modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Funkcja modyfikowania wartości zmiennych jest dostępna),

- zadeklarować nazwę grupy użytkowników systemu Windows, którzy będą mieć uprawnienie do modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Nazwa grupy uprawnionych użytkowników).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, ale NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości zmiennych - to wszyscy będą mieć prawo do modyfikacji zmiennych.

Dostęp do modyfikowania wartości zmiennych można dodatkowo zawęzić umieszczając w bazie definicji zmiennych atrybut Grupa uprawnień zapisu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienZapisu), a następnie wpisując grupę użytkowników podaną w polu Nazwa grupy uprawionych użytkowników bezpośrednio do pola atrybutu Grupa uprawnień zapisu tylko dla tych zmiennych, które mają być dostępne do modyfikacji dla danej grupy użytkowników (pozostałych zmiennych nie będzie można modyfikować).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, a w bazie definicji zmiennych zostanie dodany atrybut Grupa uprawnień zapisu, ale dla poszczególnych zmiennych w polu atrybutu Grupa uprawnień zapisu NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości tych zmiennych - to nikt nie będzie mieć prawa do modyfikowania zmiennych.

UWAGA:

Jeśli oprócz pola Nazwa grupy uprawionych użytkowników i/lub atrybutu Grupa uprawnień zapisu w bazie definicji zmiennych zostanie zadeklarowany atrybut Grupa uprawnień odczytu - użytkownik będzie miał możliwość modyfikowania wartości zmiennej pod warunkiem, że będzie należał do grupy użytkowników uprawnionych do zapisu wartości zmiennej oraz do grupy użytkowników uprawnionych do odczytu wartości danej zmiennej.

Rys. Deklaracja dostępu do odczytu i zapisu zmiennych w bazie definicji zmiennych.

Rys. Dostęp do zapisu zmiennej w AsPortal.

3. Przycisk Uruchom AsPortal na zakładce Klient - pozwala uruchomić AsPortal z dostępem do danych procesowych pracującej aplikacji

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsPortal

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsPortal

***

Zakres wyświetlanych informacji na temat zmiennych procesowych można określić wykorzystując Edytor wyglądu aplikacji AsPortal uruchamiany poleceniem:

menu Aplikacja > Konfiguruj wygląd aplikacji AsPortal

Edytor pozwala określić listę atrybutów wyświetlanych:

- w oknie podglądu bazy i wyboru zmiennych z podaniem liczby wierszy wyświetlanych na jednej stronie (zakładka Baza definicji zmiennych);

- w tabeli danych bieżących (zakładka Dane bieżące);

- w tabeli zmiennych, w nagłówkach tabeli wynikowej, w legendzie na stronie wydruku - dla danych prezentowanych w formie tabelarycznej (zakładka Dane archiwalne - tabela);

- w tabeli zmiennych, w legendzie na stronie wydruku - dla danych prezentowanych w postaci wykresów (zakładka Dane archiwalne - wykres).

Ponadto, na zakładce Aplikacje znajdują się edytory umożliwiające zadeklarowanie adresów, pod którymi dostępne będą internetowe aplikacje pakietu Asix (z poziomu AsPortala):

- aplikacja demo;

- AsTrend;

- AsAlarmNet;

- ReportServer (serwer raportów przygotowanych z wykorzystaniem środowiska AsRaport na bazie usług MS Reporting Services);


4.20. Konfigurator internetowej aplikacji AsTrend

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.19. Konfigurator internetowej aplikacji AsTrend

4.19 Konfigurator internetowej wersji programu AsTrend

Wbudowany w program Architekt - konfigurator internetowej wersji programu AsTrend pozwala łatwo skonfigurować program na podstawie ustawień bieżącej aplikacji systemu Asix.

Szczegółowy opis dotyczący funkcjonalności programu AsTrend znajduje się w podręczniku ”AsTrend - prezentacja danych archiwalnych”.

Konfigurator AsTrend uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsTrend

Obsługa Konfiguratora sprowadza się do użycia dwóch przycisków:

Konfiguruj na zakładce Konfiguracja - polecenie aktualizuje plik konfiguracyjny internetowej wersji programu AsTrend - plik default.htm w zakresie ustawień parametrów połączenia sieciowego oraz nazwy bazy definicji zmiennych na podstawie ustawień bieżącej aplikacji systemu Asix. W sytuacji, gdy definicje zmiennych przechowywane są w bazie *.mdb, w momencie konfigurowania baza definicji zmiennych kopiowana jest do katalogu w/w programu. W przypadku stosowania bazy definicji zmiennych w formacie MS SQL, należy zapewnić stacjom klienckim dostęp do serwera SQL, na którym umieszczona jest baza - jeśli nie jest to możliwie, rozwiązaniem jest zastosowanie bazy definicji zmiennych w formacie pliku *.mdb.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

Dodatkowo, konfigurator daje możliwość edycji adresów IP serwerów danych.

Rys. Konfigurator internetowej wersji programu AsTrend.

Ustaw na zakładce Ustawienia dostępu - polecenie pozwala skonfigurować kontrolę dostępu do programu.

Dostęp do odczytu wartości zmiennych jest chroniony jeśli włączone jest uwierzytelnianie systemu Windows dostępu do aplikacji i baza definicji zmiennych zawiera atrybut 'Grupa uprawnień odczytu'. Wtedy dla każdej zmiennej należy podać, jako wartość atrybutu 'Grupa uprawnień odczytu', nazwę grupy użytkowników uprawnionych do odczytu wartości zmiennej.

Rys. Konfigurator internetowej wersji programu AsTrend - ustawienie dostępu.

Rys. Konfigurator internetowej wersji programu AsTrend - deklaracja katalogów plików trendów.

Opcja Katalogi aplikacji pozwala określić listę katalogów sieciowych, z których użytkownicy mogą pobierać pliki trendów oraz nawzajem je sobie udostępniać. Zdefiniowane katalogi aplikacji dostępne są w programie AsTrend w przeglądarce, w oknie otwierania pliku trendu.

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsTrend

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsTrend


4.21. Konfigurator internetowej wersji AsAlarm

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.20 Konfigurator internetowej wersji AsAlarm

4.20 Konfigurator internetowej wersji AsAlarm

Wbudowany w program Architekt - konfigurator internetowej wersji programu AsAlarm pozwala łatwo skonfigurować program na podstawie ustawień bieżącej aplikacji systemu Asix.

Szczegółowy opis dotyczący funkcjonalności programu AsAlarm znajduje się w podręczniku ”AsAlarm - interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu Asix”.

Konfigurator AsAlarm uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsAlarm

Obsługa Konfiguratora sprowadza się do użycia dwóch przycisków:

Konfiguruj na zakładce Konfiguracja - polecenie aktualizuje plik konfiguracyjny internetowej wersji programu AsAlarm - plik index.htm w zakresie ustawień dotyczacych nazwy bazy definicji zmiennych oraz bazy alarmów na serwerze MS SQL na podstawie ustawień bieżącej aplikacji systemu Asix. W sytuacji, gdy definicje zmiennych przechowywane są w bazie *.mdb, w momencie konfigurowania baza definicji zmiennych kopiowana jest do katalogu w/w programu. W przypadku stosowania bazy definicji zmiennych w formacie MS SQL, należy zapewnić stacjom klienckim dostęp do serwera SQL, na którym umieszczona jest baza (podobnie jak do serwera MS SQL z bazą alarmów.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

Rys. Konfigurator internetowej wersji programu AsAlarm.

Ustaw na zakładce Ustawienia dostępu - pozwala skonfigurować kontrolę dostępu do programu.

Rys. Konfigurator internetowej wersji programu AsAlarm - deklaracja dostępu.

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsAlarm

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsAlarm


4.22. Konfigurator systemu raportowania AsRaport

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.21 Konfigurator systemu raportowania AsRaport

4.21 Konfigurator systemu raportowania AsRaport

Konfigurator systemu raportowania AsRaport umożliwia przygotowanie środowiska systemu Asix do tworzenia i obsługi raportów projektowanych w oparciu o Microsoft Reporting Services.

Konfigurator systemu AsRaport uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj system raportów AsRaport...

Utworzenie bazy danych AsixConnect

Procedury składowane bazy danych AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają do środowiska raportowego dane procesowe z aplikacji Asix.

Baza danych AsixConnect tworzona jest za pośrednictwem programu Architekt – jest to pierwszy krok, jaki należy wykonać, przygotowując w systemie Asix środowisko do tworzenia raportów z użyciem Reporting Services.

UWAGA: Baza danych AsixConnect jest niezbędna do pracy systemu raportowania w oparciu o dane procesowe Asixa.

Aby utworzyć bazę danych AsixConnect z dostępem do danych aplikacji systemu Asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Baza danych AsixConnect

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect/Lokalizacja.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect/Logowanie.

3. Na zakładkach Lokalizacja i Logowanie wybierz nazwę serwera MS SQL dla bazy danych AsixConnect, określ sposób weryfikacji użytkowników i kliknij przycisk Utwórz bazę.

Dostępne są trzy sposoby weryfikacji użytkowników dla bazy danych AsixConnect:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika ‘_asix_internal’ zdefiniowanego w serwerze MS SQL – domyślnie utworzonego w momencie instalowania pakietu Asix (warunkiem utworzenia takiego użytkownika jest zainstalowanie serwera MS SQL przed rozpoczęciem instalacji pakietu Asix)

3. Weryfikacja wg użytkownika serwera MS SQL, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport przed utworzeniem bazy danych AsixConnect.

4. Na zakładce Opcje bazy danych AsixConnect istnieje możliwość:

- określenia innego położenia serwera danych Askom.Data.Host (domyślnie serwer danych Askom.Data.Host i baza AsixConnect znajdują się na tym samym komputerze);

- zadeklarowania traktowania punktów o jakości niepewnej jako punkty o jakości dobrej lub jako punkty o jakości złej;

- konfiguracji systemu zmianowego:

Początek pierwszej zmiany - oznacza godzinę rozpoczęcia pierwszej zmiany;

Długość zmiany - okres czasu deklarowany w godzinach.

5. Ustawienia na zakładce Opcje bazy danych AsixConnect zostaną zapisane do bazy danych AsixConnect przy użyciu przycisku Wpisz opcje do bazy.

6. Jeśli domyślny port IP 6001 został zmieniony, należy go zarezerwować klikając przycisk Zarezerwuj port IP. Należy to zrobić na komputerze, na którym pracuje program Askom.Data.Host. Do czynności tej wymagane są uprawnienia administratora.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect/Opcje bazy danych AsixConnect.

***

Parametryzacja dostępu do bazy definicji zmiennych i systemu alarmów

Dla klasycznej wersji aplikacji pakietu Asix na podstawie nazwy komputera serwera aplikacji systemu Asix pobierane są do systemu raportowania AsRaport następujące parametry aplikacji:

- położenie bazy definicji zmiennych deklarowane przy użyciu:

Architekt > Bazy danych > Baza definicji zmiennych > zakładka Format

- nazwa sieciowa zestawu alarmów deklarowana przy użyciu:

Architekt > Obszary i komputery > System alarmów > zakładka Alarmy / Nazwa sieciowa

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów pobierana jest z bazy definicji zmiennych; należy jednak wcześniej wygenerować bazę definicji zmiennych alarmów SQL (czyli alarmów, których archiwum zdarzeń przechowywane jest w bazie SQL deklarowanej w: Architekt > Obszary i komputery > System alarmów > zakładka Archiwum > Serwer Microsoft SQL), która zostanie dołączona do bazy definicji zmiennych:

Architekt > Bazy danych > Baza definicji alarmów SQL > Źródła danych > Generator bazy definicji alarmów SQL

Aby zadeklarować nazwę komputera serwera aplikacji systemu Asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Opcje

3. Wybierz z rozwijanego pola nazwę komputera i kliknij przycisk OK.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – 'Opcje'.

***

Deklaracja serwera raportów

Deklaracja serwera raportów MS Reporting Services wykorzystywana jest do otwierania raportów utworzonych w środowisku MS Reporting Services, bezpośrednio z poziomu aplikacji systemu Asix. Wspomniane raporty mogą być wówczas przeglądane za pomocą stosownych przeglądarek systemu Asix.

Aby zadeklarować serwer raportów:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Serwer raportów

3. Zadeklaruj adres serwera raportów, nazwę kartoteki w serwerze raportów i określ sposób weryfikacji użytkowników.

Dostępne są trzy sposoby weryfikacji użytkowników dla serwera raportów:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika o nazwie ‘AskomInternal’ zdefiniowanego w systemie Windows – domyślnie utworzonego w momencie instalowania pakietu Asix

3. Weryfikacja wg użytkownika Windows, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport

4. Kliknij przycisk OK.

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – 'Serwer raportów'.

***

Określenie progów jakości danych archiwalnych

Aby określić progi jakości danych archiwalnych:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Opcje

3. Zadeklaruj próg jakości dobrej i jakości złej.

Próg jakości dobrej [%] - agregat ma jakość dobrą, jeżeli w interwale liczba próbek dobrych jest równa lub przekracza zadany próg jakości dobrej.

Próg jakości złej [%] - agregat ma jakość złą, jeżeli w interwale liczba próbek złych jest równa lub przekracza zadany próg jakości złej.

4. Kliknij przycisk OK.

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – zakładka 'Opcje'.

***

Uruchomienie programu Askom.Data.Host

Aby możliwe było pobieranie danych procesowych z aplikacji Asixa, musi być przez cały czas uruchomiony program Askom.Data.Host.

Askom.Data.Host.exe domyślnie umieszczany jest przez instalator pakietu Asix w katalogu głównym pakietu C:\Program Files\Askom\Asix.


4.23. Generator aplikacji WWW

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.22 Generator aplikacji WWW

4.22 Generator aplikacji WWW

Generator aplikacji WWW pozwala wygenerować aplikację internetową, która może być oglądana przez użytkownika w przeglądarce Internet Explorer od wersji 6. Wystarczy jedno przyciśnięcie przycisku, aby wszystkie komponenty standardowej aplikacji zostały przekonwertowane do formatu wymaganego przez aplikację WWW.

Funkcja konwersji klasycznej aplikacji systemu Asix na aplikację internetową została w wersji 8 pakietu usunięta. Aby utworzyć wersję internetową aplikacji, należy przekonwertować aplikację klasyczną na wersję Evo i dopiero wtedy opublikować ją jako aplikację WWW.

Rysunek: Widok aplikacji WWW w przeglądarce IE 7.


4.24. Konwerter trendow 1

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.23 Konwerter trendów 1

4.23 Konwerter trendów 1

Konwerter trendów służy do przekonwertowania pliku dat zawierającego definicje trendów (trendy definiowane w plikach dat dostępne były w systemie Asix do wersji 3) do postaci definicji trendów obsługiwanych przez program AsTrend (pliki trnx).

W deklarowanej bazie definicji zmiennych aplikacji muszą znajdować się definicje zmiennych, na których opierają sie definicje trendów z plików dat. W tym celu przed przystąpieniem do konwertowania plików dat z definicja trendów należy w pierwszej kolejności zaimportować wspomniane definicje zmiennych do aktualnej bazy definicji zmiennych projektowanej aplikacji.

Architekt > menu Narzędzia > Konwerter trendów 1

Rysunek: Konwerter trendów.

Dodatkowe parametry dotyczące konwersji trendów v1 ustawiane są w module Parametry startowe > Programy > AsTrend2. Są to: możliwość zadeklarowania katalogu przekonwertowanych trendów oraz opcja, której załączenie skutkuje pominięciem parametrów akcji RYSUJ_TREND w trakcie jej konwertowania na akcję ASTREND (chodzi o parametry: początek i koniec trendu oraz drukuj - początek i koniec konwertowanych trendów można określić podając w oknie konwertera trendów v1 plik trendu wzorcowego ze zdefiniowanym momentem początkowym i końcowym). (Patrz: 4.4.2 Deklaracja programów startowanych jednocześnie z aplikacją).


4.25. Edytor tabeli zmiennych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych

4.24 Edytor Tabeli Zmiennych

Tabele zmiennych pozwalają na łatwe tworzenie okien służących do przeglądania aktualnych wartości zmiennych Asmena. Tabele dostępne są w trybie edycyjnym z poziomu Architekta lub w trybie aplikacyjnym przez użycie akcji operatorskiej TABELA.

Pełne wsparcie w zakresie projektowania tabel dostarcza edytor tabel dostępny w module Architekt (edytor dostępny od wersji Asix 6):

Architekt > Obszary i komputery > Maski > Tabela > Otwórz edytor tabeli

Przełomem w funkcjonalności obiektu Tabela jest możliwość dostępu do opisów bitów zmiennych statusowych oraz opisów wartości bitów zmiennych statusowych. W tym zakresie edytor tabel w pełni wspomaga projektanta zarówno w tworzeniu tabel wartości dwustanowych - w których wartości bitów danej zmiennej mogą być wyświetlane w kolejnych kolumnach w ramach jednego wiersza zmiennej, bądź też tabel diagnostycznych słowa statusowego napędu – gdzie wartości bitów jednej zmiennej prezentowane są w kolejnych wierszach tabeli. Ciekawostką jest również możliwość realizacji akcji operatorskich wywoływanych z poziomu tabeli – z osobnych pól tabeli na podstawie definicji przechowywanych w bazie definicji zmiennych.

Interfejs edytora zaprojektowany został w taki posób, aby logicznie zgrupować poszczególne parametry definiujące tabelę na oddzielnych zakładkach - w ten sposób użytkownik ma do dyspozycji 4 zakładki:

Tabela – obejmującą podstawowe parametry tabeli takie jak położenie i rozmiar okna;

Kolumny – do parametryzacji nagłówków i formatu wyświetlanych danych;

Wiersze – określającą zmienne, których wartości będą prezentowane w tabeli (wartość zmiennej lub wartość pojedynczego bitu)

oraz

Kolory – do formatowania kolorystyki tabeli i wyświetlanych wartości.

Wszystkie zmiany wprowadzane do definicji tabeli można na bieżąco ‘monitorować’ na podglądzie, wywoływanym przyciskiem umieszczonym na panelu głównym edytora. Dodatkowo, na panelu głównym umieszczone zostały opcje symulujące ustawienia parametrów akcji operatorskiej (ma to znaczenie w przypadku projektowania wzorca tabeli, który zostanie wykorzystany do wywoływania różnych zestawów zmiennych).

Rysunek: Okno edytora tabeli.

Podstawowe założenia funkcjonalne obiektu Tabela:

- Tabela w swojej istocie nie jest obiektem w rozumieniu Asixa (moduł zewnętrzny dostarczany w postaci biblioteki DLL), a w związku z tym nie można jej osadzić na masce aplikacji;

- jeden wiersz Tabeli opisuje wartość i atrybuty związane z pojedynczą zmienną procesową;.

- zmienne procesowe zajmują kolejne wiersze a atrybuty pokazywane są w kolumnach;

- Tabela umożliwia otwieranie starych plików konfiguracyjnych Tabel (utworzonych w starszych wersjach Asixa);

- obiekt Tabela ma możliwość automatycznej parametryzacji w zakresie zestawu zmiennych do wyświetlenia na podstawie bazy definicji zmiennych (możliwość dynamicznej wymiany wyświetlanego zestawu zmiennych w oparciu o zawartość bazy definicji zmiennych);

- rozmiar Tabeli automatycznie dostosowywany jest do ilości zmiennych oraz atrybutów do wyświetlania, z uwzględnieniem parametrów wyświetlania np. rodzaj i rozmiar fontu (dynamiczna liczba zmiennych procesowych do wyświetlania dla danego typu tabeli);

- dla dowolnej kolumny/atrybutu istnieje możliwość zadeklarowania łącznika (linku) uruchamiającego akcję operatorską systemu Asix (składnia akcji operatorskiej przechowywana w bazie definicji zmiennych);

- dla zmiennych procesowych przekazujących informacje statusowe wprowadzona została możliwość deklarowania wielu kolumn zawierających złożenie wartości zmiennej i maski bitowej.


4.25.1. Plik definicji Tabeli

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.1 Plik definicji Tabeli

4.24.1 Plik definicji Tabeli

Dane opisujące tabelę pamiętane są w plikach tekstowych o rozszerzeniu *.TBL.

Poniżej przykład okna Tabeli wraz z zawartością pliku definicji prezentowanej Tabeli.

Rysunek: Okno przykładowej Tabeli.

Zawartość pliku definicji powyższej tabeli wygląda następująco:

[Tabela]

Tytuł=Pomiary K-2

Pozycja=17,93

LiczbaKolumn=4

LiczbaWierszy=21

NrKolumnyWartości=3

Czcionka=Tahoma,-13,[],EastEurope

Format=%d

Belka=1

Siatka=0

Paski=1

BłądFormat=

Szerokość=-1

Wysokość=-1

Przesunięcie=30

[Kolory]

Tło=192,192,192

Czcionka=0,0,0

PasekTło=175,175,175

LimitHHTło=255,0,0

LimitHHCzcionka=255,255,255

LimitHHMigotanie=1

LimitHTło=255,0,0

LimitHCzcionka=255,255,0

LimitLTło=0,0,160

LimitLCzcionka=255,255,0

LimitLLTło=0,0,160

LimitLLCzcionka=255,255,255

LimitLLMigotanie=1

BłądTło=255,255,191

BłądCzcionka=255,0,0

Migotanie=0

PasekCzcionka=0,0,0

PasekMigotanie=0

LimitHHTłoDomyślne=0

LimitHTłoDomyślne=0

LimitHMigotanie=0

LimitLTłoDomyślne=0

LimitLMigotanie=0

LimitLLTłoDomyślne=0

BłądTłoDomyślne=0

BłądMigotanie=0

[Kolumny]

1=Nazwa,10

2=Opis,35

3=Wartość,7

4=Jednostka,7

[Wiersze]

1=FQUIT2130

2=FQUIT2230

3=FQUIT2330

4=FQUIT2430

5=K2_Fgaz

6=TIT2506

7=PICAL2111

8=PICAL2311

9=K2_Pgaz

10=

11=FITR2004

12=TIR2807

13=

14=FITR2005

15=TICR2813

16=TICR2823

17=K2_Tpara

18=

19=K2_MocQ

20=K2_Vspr

21=

Zawiera on dwie kategorie informacji:

- Pozycje deklarujące wygląd oraz zestaw kolumn tabeli;

sekcje [Tabela], [Kolory], [Kolumny]

- Pozycje deklarujące zestaw zmiennych procesowych oraz kolejność ich wyświetlania;

sekcja [Wiersze]

Szczegółowy opis poszczególnych parametrów znajduje się w częsci "Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji", rozdział 11.2. Opis zawartości pliku definicji tabeli.


4.25.2. Konfigurowanie podstawowych parametrów Tabeli

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.2 Konfigurowanie podstawowych parametrów Tabeli

4.24.2 Konfigurowanie podstawowych parametrów Tabeli

Podstawowe parametry tabeli takie jak położenie i rozmiar okna konfigurowane są na zakładce Tabela.

Rysunek: Okno edytora Tabeli - zakładka 'Tabela'.

Położenie i rozmiar okna tabeli – umożliwia skonfigurowanie współrzędnych lewego górnego narożnika oraz wielkości okna w pikselach. Pozycję i rozmiar okna można w prosty sposób określić za pomocą testowego okna, uruchamianego przyciskiem Wybierz pozycję. Okno to można umieścić w dowolnym miejscu ekranu, a rozmiar określić przeciągając krawędzie okna za pomocą myszy - wartości tych ustawień automatycznie pojawiają się w stosownych polach definiujących położenie i rozmiar okna Tabeli.

Wygląd tabeli - obejmuje grupę opcji definiujących podstawowe cechy wyglądu Tabeli: rozmiar i treść belki tytułowej, wyświetlanie nagłówków kolumn, wyświetlanie wierszy różnymi kolorami, wyświetlanie linii siatki pomiędzy komórkami Tabeli.

W celu umożliwienia personalizacji opisu Tabeli wprowadzono tzw. modyfikatory tytułu Tabeli pozwalające na wprowadzenie do tytułu: nazwy Tabeli, nazwy atrybutu oraz wartości atrybutu. Modyfikatory posiadają następującą postać:

{TN} nazwa Tabeli

{AN} nazwa atrybutu selekcji

{AV} wartość atrybutu selekcji

Modyfikatory można wykorzystać w treści pola Tytuł.

Wygląd komórki – obejmuje parametry umożliwiające definiowanie: formatu czcionki dla tekstów w komórkach Tabeli, procentowego przesunięcia tekstu względem dolnej krawędzi komórki, formatów wyświetlania wartości zmiennych.

Automatyczna parametryzacja - parametr określający nazwę atrybutu, wg którego zostaną posortowane wiersze zmiennych wywoływane akcją operatorską przy zastosowaniu mechanizmu automatycznej parametryzacji Tabeli. Należy zwrócić uwagę na fakt, że kolejność zmiennych nie musi określać atrybut, który jest wyświetlany w tabeli. W przypadku gdy nie zostanie jawnie wskazany atrybut określający porządek wyświetlania, zmienne procesowe będą prezentowane w Tabeli w kolejności otrzymania z bazy definicji zmiennych.

Ochrona przed modyfikacją operatora - opcja wymusza ochronę modyfikacji definicji Tabeli z poziomu interfejsu użytkownika. Modyfikacje można zapisywać jedynie z poziomu administracyjnego.


4.25.3. Parametryzacja nagłówków i formatu wyświetlanych danych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.3. Parametryzacja nagłówków i formatu wyświetlanych danych

4.24.3 Parametryzacja nagłówków i formatu wyświetlanych danych

Do parametryzacji nagłówków i formatu wyświetlanych danych służy zakładka Kolumny.

Rysunek: Okno edytora Tabeli - zakładka 'Kolumny'.

Nazwa atrybutu

Nazwa atrybutu (pobrana z bazy definicji zmiennych) lub dowolny tekst (ograniczony cudzysłowami), który będzie wyświetlany jako zawartość kolumny.

Szerokość

Szerokość kolumny podana w znakach.

Wyrównanie

Sposób wyrównania tekstu w kolumnie: do lewej, do prawej, wyśrodkowany.

Nagłówek

Własny opis kolumny zastępujący nazwę atrybutu.

Wyświetlana wartość

Dla atrybutu _Wartość_zmiennej możliwe jest określenie: czy wyświetlać wartość zmiennej czy wartość bitu zmiennej.

Opisy stanów

Dla atrybutu _Wartość_zmiennej opisy tekstowe przypisane poszczególnym wartościom zmiennej. Możliwe jest użycie opisów stanów zmiennej zdefiniowanych w edytorze lub bazie definicji zmiennych lub użycie wartości zmiennej w postaci liczbowej.

Sposób definiowania opisów stanów w bazie definicji zmiennych omawia rozdział 2.7 Przechowywanie opisów stanów zmiennych w bazie definicji zmiennych.

Rysunek: Edytor Tabeli - okno deklaracji opisów stanów dla atrybutu '_Wartość_zmiennej'.

Kolory stanów

Dla atrybutu _Wartość_zmiennej wartości atrybutów przypisane poszczególnym wartościom zmiennej.

Rysunek: Edytor Tabeli - okno deklaracji kolorów stanów dla atrybutu '_Wartość_zmiennej'.

Nazwa atrybutu akcji

Atrybut bazy definicji zmiennych przechowujący treść akcji operatorskiej do wykonania.


4.25.4. Deklarowanie zmiennych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.4 Deklarowanie zmiennych

4.24.4 Deklarowanie zmiennych

Do deklaracji zmiennych służy zakładka Wiersze.

Rysunek: Okno edytora Tabeli - zakładka 'Wiersze'.

Liczba wyświetlanych wierszy uzależniona jest od sposobu sparametryzowania Tabeli:

– jeżeli ma to być tabela parametryzowana automatycznie, liczba wierszy jest dynamicznie kształtowana w zależności od ilości zmiennych w wywoływanym zestawie zmiennych;

- w przypadku tabeli nie podlegającej automatycznej parametryzacji liczba wierszy widocznych w oknie Tabeli może być ustalona na sztywno (wówczas pozostałe wiersze nie są wyświetlane) lub dynamicznie (szerokość Tabeli dopasowuje się do liczby zdefiniowanych wierszy).

Numer wiersza - pozwala określić kolejność wierszy zmiennych w oknie Tabeli.

Nazwa zmiennej - określa nazwę zmiennej zadeklarowanej w bazie definicji zmiennych. Opcjonalnie można zamiast nazwy zmiennej zadeklarować numer zmiennej ujęty w klamry {}. Wpisanie liczby ujętej w klamry {} z przedziału 1 do liczby wierszy spowoduje wyświetlenie zmiennej o tym numerze spośród zmiennych uzyskanych z bazy definicji zmiennych.

Rysunek: Okno dodawania zmiennej do definicji Tabeli.

Przykładem zastosowania liczb w klamrach w polu Nazwa zmiennej jest Tabela słowa statusowego napędu, parametryzowana automatycznie względem wybranego atrybutu. Przewidując liczbę wierszy zmiennych spełniających kryterium wartości wybranego atrybutu można podać w kolejnych wierszach Tabeli numer, który określi na liście zmiennych uzyskanych z bazy definicji zmiennych –tę zmienną, której wartości bitów zostaną ostatecznie wyświetlone w oknie Tabeli, np. {1} spowoduje wyświetlenie w Tabeli wartości bitów zmiennej, która jako pierwsza została pobrana z bazy definicji zmiennych.

Rysunek: Przykład deklaracji zmiennej jako liczby w klamrach {}.

Wyświetlana wartość – pole definiuje rodzaj wyświetlanej wartości zmiennej, tj. czy wyświetlana będzie wartość zmiennej, czy też wartość określonego bitu zmiennej.


4.25.5. Atrybutyt wyświetlania zmiennych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.5 Atrybut wyświetlania zmiennych

4.24.5 Atrybuty wyświetlania zmiennych

Atrybutami wyświetlania są: kolor tła, kolor czcionki oraz migotanie wartości, deklarowane dla poszczególnych wierszy, wartości przekraczających limit, wartości błędnych. Parametry deklarujące powyższe atrybuty globalnie dla wszystkich komórek Tabeli ustawiane są na zakładce Kolory.

Dodatkowo atrybuty wyświetlania (w szczególności: kolor tła, czcionki i migotanie) mogą być deklarowane indywidualnie dla wartości bitów w polu Opisy stanów na zakładce Kolumny.

Rysunek: Okno edytora Tabeli - zakładka 'Kolory'.

Rysunek: Okno edytora Tabeli - zakładka 'Kolumny' > pole 'Kolory stanów'.


4.25.6. Automatyczna parametryzacja

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.6 Automatyczna parametryzacja

4.24.6 Automatyczna parametryzacja

Automatyczna parametryzacja daje możliwość dynamicznej wymiany wyświetlanego zestawu zmiennych w oparciu o zawartość bazy definicji zmiennych.

Automatyczna parametryzacja wymaga przy każdorazowym uruchomieniu obiektu TABELA pobrania (wyfiltrowania) z bazy definicji zmiennych zestawu zmiennych procesowych do wyświetlenia. Filtrowanie zmiennych realizowane jest na podstawie wartości atrybutu zadanej w treści akcji operatorskiej uruchamiającej Tabelę.

Przykład automatycznej parametryzacji Tabeli:

Przykładowo, zawartość bazy definicji zmiennych ma następującą postać:

Rysunek: Przykładowa definicja zmiennych.

Do dynamicznej parametryzacji zostanie użyty atrybut TABELA_DIAG. Tabela zawierać będzie zmienne, dla których atrybut TABELA_DIAG przyjmuje wartość DIAG_5. Postać wywołania akcji operatorskiej ma następującą postać:

TABELA <katalog_z_tabelami>\<nazwa_tabeli>#TABELA_DIAG=DIAG_5

Zmienne można uporządkować, posługując się parametrem Nazwa atrybutu sortującego na zakładce Tabela edytora Tabeli - np. wg. atrybutu Nazwa:

Rysunek: Przykład Tabeli wyświetlonej na podstawie dynamicznie wyselekcjonowanego zestawu zmiennych posortowanych wg atrybutu 'Nazwa'.

Zmianę kolejności wyświetlania zmiennych oraz wprowadzenie wierszy separujących, zrealizować można za pomocą następującej parametryzacji na zakładce Wiersze:

Rysunek: Przykład ustalania kolejności zmiennych wraz z deklaracją wierszy separujących dla Tabeli dynamicznie parametryzowanej.

Rysunek: Przykład Tabeli wyświetlonej na podstawie dynamicznie wyselekcjonowanego zestawu zmiennych posortowanych na podstawie deklaracji zmiennych jako kolejnych numerów w klamrach {}.


4.25.7. Zamieszczanie akcji oepratorskich w Tabeli

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.7 Zamieszczanie akcji operatorskich w Tabeli

4.24.7 Zamieszczanie akcji operatorskich w Tabeli

Jedną z podstawowych cech wyróżniających obiekt TABELA jest możliwość tworzenia hierarchicznych struktur wizualizacji informacji diagnostycznych odnośnie systemów PLC. Funkcjonalność ta pozwala otwierać następną Tabelę za pomocą linku (łącznika) umieszczonego w komórce Tabeli, który uruchamia akcję operatorską według zadanych parametrów, określonych w bazie definicji zmiennych.

Łącznik deklarowany jest za pomocą atrybutu bazy definicji zmiennych przechowującego wywołanie akcji operatorskiej. Nazwa atrybutu pełniącego rolę łącznika deklarowana jest w definicji kolumny Tabeli: na zakładce Kolumny > w polu Nazwa atrybutu akcji.

Zawartość kolumny zawierającej łącznik wyświetlana jest w oknie gotowej Tabeli z podkreśleniem w kolorze niebieskim i może to być albo wartość jakiegoś atrybutu pobierana z bazy definicji zmiennych albo tekst wpisany ręcznie - określa to zawartość pola Nazwa atrybutu, np. można podpiąć akcję pod atrybut Nazwa albo zadeklarować osobną kolumnę Tabeli z pustym atrybutem - tzn. w definicji dodatkowej kolumny Tabeli na zakładce Kolumny w polu Nazwa atrybutu wpisać jakiś tekst, który będzie linkiem do akcji (np. >>).

Poprzez kliknięcie myszą w gotowej Tabeli na wartość kolumny z podpiętą akcją operatorską następuje uruchomienie zadeklarowanej akcji operatorskiej, w szczególności zainicjowanie otwarcia nowej Tabeli ze wskazanym zestawem zmiennych.


4.25.8. Tabela_analogów

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.8 Tabela analogów

4.24.8 Tabela analogów

Poniżej parametryzacja Tabeli analogów – Tabeli pomiarów parametrów mediów przed piecem.

Pomiary wyświetlane są w kolejnych wierszach Tabeli, oddzielonych wierszami separującymi.

Rysunek: Przykład Tabeli analogów.

Rysunek: Parametryzacja Tabeli analogów - parametry podstawowe.

Tabela zawiera 4 kolumny deklarowane na zakładce Kolumny: Nazwa, Opis, _Wartość_zmiennej, Jednostka.

Dla atrybutu _Wartość_zmiennej wartością wyświetlaną jest wartość zmiennej.

Rysunek: Parametryzacja Tabeli analogów - deklaracja nagłówków i formatu wyświetlanych danych.

Deklaracja zmiennych obejmuje wartości analogowe zmiennych umieszczonych w kolejnych wierszach.

Zamieszczenie wierszy separujących wymaga zadeklarowania pustych wierszy bez podawania nazw zmiennych.

Rysunek: Parametryzacja Tabeli analogów - deklaracja zmiennych.

Kolorystyka Tabeli została sparametryzowana w następujący sposób:

Rysunek: Parametryzacja Tabeli analogów - deklaracja kolorystyki.


Tabela dwustanów

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.9 Tabela dwustanów - wyświetlanie bitów (opisów stanów bitów) zmiennej w kolejnych

4.24.9 Tabela dwustanów - wyświetlanie bitów (opisów stanów bitów) zmiennej w kolejnych kolumnach

Aktualna wersja obiektu TABELA umożliwia wyświetlanie w jednym wierszu wartości poszczególnych bitów słowa statusowego. Funkcjonalność ta realizowana jest za pomocą numeru bitu wartości zmiennej statusowej, co w konsekwencji wydziela odpowiedni sygnał dwustanowy. Jeżeli numer bitu zostanie pominięty, to brana jest pod uwagę wartość całego słowa statusowego (nr bitu = -1).

Funkcja przeliczająca zmiennej statusowej musi zwracać w wyniku liczbę całkowitą, np. NIC, NIC_BYTE, NIC_INT.

Numeracja bitów w słowie statusowym zaczyna się od najmłodszego bitu o numerze 0.

Rysunek: Przykład Tabeli dwustanów - wyświetlanie wartości bitów zmiennej w kolejnych kolumnach wiersza zmiennej.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - parametry podstawowe.

Wartość sygnału dwustanowego, wydzielonego ze zmiennej statusowej za pomocą numeru bitu, domyślnie wyświetlana jest zgodnie z formatem określonym w bazie definicji zmiennych, formatem zadeklarowanym w sekcji [Tabela] lub przyjmuje wartość 0/1.

Reguła ta dotyczy wszystkich kolumn zawierających wartości statusowe (dwustanowe).

Wartości poszczególnych bitów wyświetlane w oknie gotowej Tabeli w kolejnych kolumnach wiersza zmiennej statusowej deklarowane są na zakładce Kolumny:

- ilość atrybutów _Wartość_zmiennej odpowiada ilości bitów, które mają być wyświetlone w Tabeli - dla każdego takiego atrybutu jako wartość wyświetlaną należy zadeklarować numer kolejnego bitu zmiennej statusowej;

- w celu zróżnicowania prezentacji wartości statusowych proponuje się wprowadzenie indywidualnego formatu oraz atrybutów wyświetlania sygnału dwustanowego dla pojedynczej kolumny Tabeli. Opisy oraz kolorystyka stanów określane są indywidualnie dla każdego bitu w polach Opisy stanów i Kolory stanów.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - deklaracja bitów zmiennej statusowej.

Zmienną statusową, której bity zostały rozpisane na poszczególne kolumny, należy zadeklarować na zakładce Wiersze.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - deklaracja zmiennej statusowej.


4.25.10. Tabela dwustanów - wyświetlanie opisów bitów zmiennych w kolejnych wierszach

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.24 Edytor tabeli zmiennych > 4.24.10 Tabela dwustanów - wyświetlanie opisów bitów zmiennych w kolejnych wierszach

4.24.10 Tabela dwustanów - wyświetlanie opisów bitów oraz opisów stanów bitów w kolejnych wierszach

Baza definicji zmiennych daje możliwość dostępu do opisów bitów zmiennych statusowych oraz opisów wartości bitów zmiennych statusowych (patrz: rozdział 2.8. Przechowywanie opisów stanów bitów oraz opisów bitów w bazie definicji zmiennych).

Zastosowanie tego mechanizmu w sposób drastyczny zmniejsza liczbę zmiennych podlegających licencjonowaniu, potrzebnych do opisu bitów wartości statusowych. Dodatkowo mechanizm ten przyspiesza działanie bazy definicji zmiennych.

Reguły przygotowania odpowiedniej bazy definicji zmiennych zawarte są w dokumentacji pakietu Asix.

Wykorzystanie powyższego mechanizmu pozwala na “pionową” organizację prezentacji danych w Tabeli, tzn. że kolejne wiersze Tabeli pokazują wartości pojedynczych bitów zmiennej statusowej.

Wymaga to odpowiedniej deklaracji wiersza Tabeli.

Rysunek: Przykład Tabeli dwustanów - wyświetlanie wartości i opisów bitów zmiennej w kolejnych wierszach Tabeli.

W obecnej chwili interfejs programowy pozwala na uzyskanie dla pojedynczego bitu informacji o jego opisie oraz nazwie stanu. W związku z tym kolumny opisu i wartości pokazują dane z dokładnością do pojedynczego bitu. Pozostałe atrybuty wyświetlane są z dokładnością do zmiennej. (Konsekwencją praktyczną jest konieczność umieszczania w opisie bitu wszystkich informacji potrzebnych do prezentacji bitów zmiennych statusowych).

Umieszczenie bitów zmiennej statusowej w kolejnych wierszach Tabeli wymaga zadeklarowania każdego bitu (w osobnym wierszu zakładki Wiersze) jako wartość wyświetlaną zmiennej statusowej. Na zakładce Kolumny należy umieścić atrybut _Wartość_zmiennej z polem Wyświetlana wartość ustawionym na: Wartość zmiennej. Pozostałe parametry dotyczące kolorystyki i atrybutów wyświetlania danych znajdują się na zakładkach Tabela i Kolory.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - deklaracja bitów.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - format nagłówków i wyświetlanych danych.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - parametry podstawowe.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - ustawienia dotyczące kolorystyki.

Definicje bitów umieszczone są w bazie definicji zmiennych jako odrębne zmienne nieaktywne.

Rysunek: Baza definicji zmiennych - definicje bitów zmiennej statusowej.

Opisy stanów poszczególnych bitów pobierane są do Tabeli z bazy definicji zmiennych z pola Nazwy stanów.

Opisy bitów pobierane są do Tabeli z bazy definicji zmiennych z pola Opis.


Zalacznik 1

Home > Architekt - Parametryzacja aplikacji > Załącznik 1

Załącznik 1

Tabela 1. Lista atrybutów systemowych Bazy Definicji Zmiennych definiujących zmienne procesowe.

Nazwa wewnętrzna atrybutu zmiennej (PL)

Rodzaj atrybutu

Nawa domyślnie wyświetlana w nagłówku (PL)

Nazwa wewnętrzna atrybutu zmiennej (EN)

Nawa domyślnie wyświetlana w nagłówku (EN)

Typ

Opis

Nazwa

obligatoryjny

Nazwa

Name

Name

T

Unikalna nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca tę zmienną dla wszystkich komponentów systemu A six

Opis

obligatoryjny

Opis

Description

Description

T

Dowolny tekst np. zawierający technologiczny opis zmiennej procesowej

Kanał

obligatoryjny

Kanał

Channel

Channel

T

Nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji)

Adres

obligatoryjny

Adres

Address

Address

T

Adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu A six

LiczbaElementow

obligatoryjny

Liczba elementów

ElementsCount

Elements count

L

Liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą)

OkresProbkowania

obligatoryjny

Okres próbkowania

SampleRate

Sample rate

L

okres aktualizacji wartości zmiennej procesowej (w sekundach)

FunkcjaPrzeliczajaca

obligatoryjny

Funkcja przeliczająca

ConversionFunction

Conversion function

T

Nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu A six

Archiwum

obligatoryjny

Archiwum

Archive

Archive

T

Nazwa zasobu ASPAD (logiczna nazwa zasobu archiwum)

ParametryArchiwizacji

obligatoryjny

Parametry archiwizacji

ArchivingParameters

Archiving parameters

T

Parametry archiwizacji danej zmiennej

Grupa1

opcjonalny

Grupa1

Group1

Group1

T

Domyślnie generowany atrybut grupujący

Format

opcjonalny

Format

Format

Format

T

Format liczby w jakim będzie ona wyświetlana w systemie asix; format podany jest w konwencji języka C (np.: %4.2f oznacza 4 znaki, w tym 2 miejsca po przecinku)

FormatEvo

opcjonalny

FormatEvo

FormatEvo

FormatEvo

T

Format liczby w jakim będzie ona wyświetlana w aplikacji Asix.Evo

Jednostka

opcjonalny

Jednostka

Unit

Unit

T

Fizyczna jednostka zmiennej

ZakresPomiarowyOd

opcjonalny

Zakres pomiarowy od

MeasurementRangeFrom

Measurement range from

L

Maksymalny zakres możliwy do uzyskania - minimum

ZakresPomiarowyHi

opcjonalny

Zakres pomiarowy do

MeasurementRangeTo

Measurement range to

L

Maksymalny zakres możliwy do uzyskania - maksimum

ZakresSurowyOd

opcjonalny

Zakres surowy od

RawRangeFrom

Raw range from

L

Parametr funkcji przeliczającej – zakres wejściowy od …

ZakresSurowyDo

opcjonalny

Zakres surowy do

RawRangeTo

Raw range to

L

Parametr funkcji przeliczającej – zakres wejściowy do …

ZakresPrzetwornikaOd

opcjonalny

Zakres przetwornika od

TransducerRangeFrom

Transducer range from

L

Zakres przetwornika - minimum

ZakresPrzetwornikaDo

opcjonalny

Zakres przetwornika do

TransducerRangeTo

Transducer range to

L

Zakres przetwornika - maksimum

ZakresWyswietlaniaOd

opcjonalny

Zakres wyświetlania od

DisplayRangeFrom

Display range from

L

Dolny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresWyswietlaniaDo

opcjonalny

Zakres wyświetlania do

DisplayRangeTo

Display range to

L

Górny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresSterowaniaOd

opcjonalny

Zakres sterowania od

SteeringRangeFrom

Steering range from

L

Dolny zakres wartości danej zmiennej ustawiany z asixa

ZakresSterowaniaDo

opcjonalny

Zakres sterowania do

SteeringRangeTo

Steering range to

L

Górny zakres wartości danej zmiennej ustawiany z asixa

BazaSlupka

opcjonalny

Baza słupka

BarBase

Bar base

T

Wielkość wczytywana z bazy przez obiekt SŁUPEK

NazwyStanow

opcjonalny

Nazwy stanów

StateNames

State names

T

Nazwa zbioru tekstów lub bezpośrednio zbiór opisów stanów (poszczególnych wartości całkowitych) zmiennej

ZestawStanow

opcjonalny

Zestaw stanów

StateSet

State set

T

Nazwa zbioru opisów stanów do którego należy bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

WartoscStanu

opcjonalny

Wartość stanu

StateValue

State value

T

Numer stanu, którego opis zawiera bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

MaskaZmiennejKontrolnej

opcjonalny

Maska zmiennej kontrolnej

ControlVariableMask

Control Variable mask

T

Wskazuje na bit statusu sygnalizowanego przez zmienną kontrolną

ZmiennaKontrolna

opcjonalny

Zmienna kontrolna

ControlVariable

Control variable

T

Nazwa zmiennej reprezentującej status zmiennej pomiarowej

LimitLoLo

opcjonalny

Minimum krytyczne

LimitLoLo

Limit LoLo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum krytycznego dla zmiennej pomiarowej

LimitLo

opcjonalny

Minimum

LimitLo

Limit Lo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum dla zmiennej pomiarowej

LimitHi

opcjonalny

Maksimum

LimitHi

Limit Hi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum dla zmiennej pomiarowej

LimitHiHi

opcjonalny

Maksimum krytyczne

LimitHiHi

Limit HiHi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum krytycznego dla zmiennej pomiarowej

ZakresWyswietlaniaKrok

opcjonalny

Zakres wyświetlania krok

DisplayRangeStep

Display range step

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość podziałki głównej na osi OY (co ile jednostek będzie wyświetlana etykieta wartości na osi OY)

ZakresWyswietlaniaSzer

opcjonalny

Zakres wyświetlania szerokość

DisplayRangeWidth

Display range width

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość etykiety wartości wyświetlanych na osi OY

ZakresWyswietlaniaPodzial

opcjonalny

Zakres wyświetlania podział

DisplayRangeDivision

Display range division

L

Atrybut wykorzystywany przez obiekt WYKRES. Wyznacza podział na mniejsze jednostki podziałki głównej (wyznaczonej przez atrybut Zakres wyświetlania krok) na osi OY

Dokładnosc

opcjonalny

Dokładność

Precision

Precision

T

Dokładność zaokrąglania w obiekcie LICZBA. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie nie ma zaokrąglania.

PolozenieSuwaka

opcjonalny

Położenie suwaka

SliderPosition

Slider position

T

Nazwa zmiennej, do której wpisywana będzie wartości reprezentująca położenie uchwytu obiektu SUWAK w trakcie przesuwania tegoż uchwytu

RejestracjaSterowania

opcjonalny

Rejestracja sterowania

ControlLogging

Control logging

Wartość logiczna

Wartość 1 oznacza, że sterowania zmiennej podlegają rejestracji w module AsAudit

ZmiennaNieaktywna

opcjonalny

Zmienna nieaktywna

ItemNotActive

Item not active

Wartość logiczna

Jeżeli wartość atrybutu wynosi 1, to zmienna nie jest widoczna w systemie A six dla modułów Asmen i Aspad

WykresTytul

opcjonalny

Tytuł wykresu

ChartTitle

Chart title

T

Atrybut wykorzystywany przez obiekt WYKRES. Tytuł wykresu pobierany jest z atrybutu Tytuł wykresu pierwszej zmiennej zadeklarowanej na wykresie

ZakresSlupkaOd

opcjonalny

Zakres słupka od

BarRangeFrom

Bar range from

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera dolny zakres wyświetlania danej zmiennej.

ZakresSlupkaDo

opcjonalny

Zakres słupka do

BarRangeTo

Bar range to

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera górny zakres wyświetlania danej zmiennej.

SzybkieOdswiezanie

opcjonalny

Szybkie odświeżanie

FastRefresh

Fast refresh

Wartość logiczna

Atrybut wykorzystywany przez drajwer CtTwinCATTcpip od wersji 1.3.5. Zmienne z zadeklarowanym atrybutem Fast Refresh mają udostępnioną funkcję szybkiego odświeżania, która umożliwia odświeżanie zmiennych z maksymalną osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę)

SprawdzanieZakresuPomiarowego

opcjonalny

Sprawdzanie zakresu pomiarowego

MeasurementRangeCheck

Measurement range check

Wartość logiczna

Wartość 1 oznacza, że dla podanej zmiennej monitorowane będą przekroczenia zakresu pomiarowego i sygnalizowane odpowiednim statusem OPC.

Status zmiennej jest określany po porównaniu wartości pomiarowej z wartościami zakresów pomiarowych:

a/ przy przekroczeniu zakresu o wartość <= od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_EGU_EXCEEDED

b/ przy przekroczeniu zakresu o wartość > od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_SENSOR_FAILURE

GrupaUprawnienOdczytu

opcjonalny

Grupa uprawnień odczytu

ReadAuthorizationGroup

Read authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzystają aplikacje: AsPortal i AsTrend, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do przeglądania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do

przeglądania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

GrupaUprawnienZapisu

opcjonalny

Grupa uprawnień zapisu

WriteAuthorizationGroup

Write authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzysta aplikacja AsPortal, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do modyfikowania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień zapisu, nazwę grupy użytkowników systemu Windows uprawnionych do

modyfikowania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

T - tekst, L - liczba zmiennoprzecinkowa 64 bitowa


Zalacznik 2

Home > Architekt - Parametryzacja aplikacji > Załącznik 2

Załącznik 2

Tabela 2. Zestawienie atrybutów i wykorzystujących (wyświetlających) je obiektów.

Obiekty Atrybuty | Obiekt LICZBA | Obiekt KONTROLER RUCHU | Obiekt NAPIS | Obiekt PUNKT PRACY | Obiekt SŁUPEK | Obiekt SUWAK | Obiekt TEKST | Obiekt TEKSTY | Obiekt WSKAŹNIK | Obiekt WYKRES | Moduł AsAudit | Moduł AsTrend*
Nazwa |  |  |  |  |  |  | P |  |  |  |  |
Opis |  |  |  |  |  |  | P | P |  |  |  | P
Kanał |  |  |  |  |  |  | P |  |  |  |  |
Adres |  |  |  |  |  |  | P |  |  |  |  |
Liczba elementów |  |  | P |  |  |  | P |  |  |  |  |
Okres próbkowania |  |  |  |  |  |  | P |  |  |  |  |
Funkcja przeliczająca |  |  |  |  |  |  | P |  |  |  |  |
Archiwum |  |  |  |  |  |  | P |  |  |  |  |
Parametry archiwizacji |  |  |  |  |  |  | P |  |  |  |  |
Grupa1 |  |  |  |  |  |  | P |  |  |  |  |
Format | P |  |  |  |  |  | P |  |  |  |  |
Jednostka |  |  |  |  |  |  | P |  |  |  |  |
Zakres pomiarowy od |  | P |  |  |  |  | P |  |  |  |  |
Zakres pomiarowy do |  | P |  |  |  |  | P |  |  |  |  |
Zakres surowy od |  |  |  |  |  |  | P |  |  |  |  |
Zakres surowy do |  |  |  |  |  |  | P |  |  |  |  |
Zakres przetwornika od |  |  |  |  |  |  | P |  |  |  |  |
Zakres przetwornika do |  |  |  |  |  |  | P |  |  |  |  |
Zakres wyświetlania od | P |  |  | P | P | P | P |  | P | P |  |
Zakres wyświetlania do | P |  |  | P | P | P | P |  | P | P |  |
Zakres sterowania od | P |  |  |  |  | P | P |  |  |  |  |
Zakres sterowania do | P |  |  |  |  | P | P |  |  |  |  |
Baza słupka |  |  |  |  | P |  | P |  |  |  |  |
Nazwy stanów |  |  |  |  |  |  | P | P |  |  |  | P
Zestaw stanów |  |  |  |  |  |  | P | P |  |  |  | P
Wartość stanu |  |  |  |  |  |  | P | P |  |  |  | P
Maska zmiennej kontrolnej | P |  |  | P | P | P | P |  | P |  |  |
Zmienna kontrolna | P |  |  | P | P | P | P |  | P |  |  |
Minimum krytyczne | P |  |  |  | P |  | P |  | P |  |  |
Minimum | P |  |  |  | P |  | P |  | P |  |  |
Maksimum | P |  |  |  | P |  | P |  | P |  |  |
Maksimum krytyczne | P |  |  |  | P |  | P |  | P |  |  |
Zakres wyświetlania krok |  |  |  |  |  |  | P |  |  | P |  |
Zakres wyświetlania szerokość |  |  |  |  |  |  | P |  |  | P |  |
Zakres wyświetlania podział |  |  |  |  |  |  | P |  |  | P |  |
Dokładność | P |  |  |  |  |  | P |  |  |  |  |
Położenie suwaka |  |  |  |  |  |  | P |  |  |  |  |
Rejestracja sterowania |  |  |  |  |  |  | P |  |  |  | P |
Zmienna nieaktywna |  |  |  |  |  |  | P | P |  |  |  | P
Tytuł wykresu |  |  |  |  |  |  | P |  |  | P |  |
Zakres słupka od |  |  |  |  | P |  |  |  |  |  |  |
Zakres słupka do |  |  |  |  | P |  |  |  |  |  |  |

* - moduł AsTrend może wyświetlić w Legendzie wartości wszystkich atrybutów zmiennej zadeklarowanej na wykresie


Zalacznik 3

Home > Architekt - Parametryzacja aplikacji > Załącznik 3

Załącznik 3

 | Kod języka | Nazwa języka
za | af | afrykanerski
al | sq | albański
gb | en | angielski
az | az | azerski
by | be | białoruski
bg | bg | bułgarski
hr | hr | chorwacki
cz | cs | czeski
dk | da | duński
ee | et | estoński
fi | fi | fiński
fr | fr | francuski
gr | el | grecki
ge | ka | gruziński
es | es | hiszpański
lu | nl | holenderski
ax | is | islandzki
kz | kk | kazachski
kr | ko | koreański
lt | lt | litewski
lv | lv | łotewski
mk | mk | macedoński
de | de | niemiecki
no | no | norweski
am | hy | ormiański
pl | pl | polski
pt | pt | portugalski
ru | ru | rosyjski
ro | ro | rumuński
sr-serbski | sr | serbski
sk | sk | słowacki
si | sl | słoweński
se | sv | szwedzki
tr | tr | turecki
ua | uk | ukraiński
uz | uz | uzbecki
hu | hu | węgierski
ie | it | włoski


Zalacznik 4

Home > Architekt - Parametryzacja aplikacji > Załącznik 4

Załącznik 4

Znaki sterujące wykorzystywane do definicji stałych elementów wydruków

uwaga Definicje nagłówków i stopek składają się z trzech części oddzielonych znakiem |. Zostaną one wydrukowane odpowiednio po lewej stronie, na środku i po prawej stronie kartki.

&p - numer strony

&c - nazwa komputera

&a - nazwa aplikacji

&o - operator (w wersji 2.66 pusty tekst)

&w - tekst definiujący rodzaj wydruku (tekst z góry ustalony, np. dla wydruku maski schematowej: ”Zrzut graficzny ekranu")

&r - nazwa raportu

&m - miesiąc - liczba

&M - miesiąc - nazwa

&y - rok

&h - godzina

&n - minuta

&s - sekunda

&D - pełna data w postaci zdefiniowanej w systemie operacyjnym

&T - pełny czas w postaci zdefiniowanej w systemie operacyjnym

&& - &

&es - nazwa zasobu drukowanych alarmów

&ef - czas początku okresu drukowanych alarmów

&et - czas końca okresu drukowanych alarmów

&ec - opis użytych kryteriów - nazwa pliku jeżeli kryteria wzięte z pliku selekcji

Nagłówek i stopka mogą być wieloliniowe. W tym celu należy do tekstu wstawić znacznik ^.


Zalacznik 5

Home > Architekt - Parametryzacja aplikacji > Załącznik 5

Załącznik 5

Znaki definiujące format linii alarmów

A - tekst alarmu;

D - data alarmu - 4 cyfrowy rok;

d - data alarmu - 2 cyfrowy rok;

T - czas alarmu z milisekundami;

t - czas alarmu bez milisekundami;

S - status: początek/koniec (podczas wydruku alarmów aktywnych znacznik S jest ignorowany);

N - numer kolejny;

I - numer/identyfikator alarmu;

X - w miejscu umieszczenia kodu drukowany jest znak * dla alarmów specjalnych, a spacja dla alarmów zwykłych;

Spacja - wstawia spację do tekstu;

Wartość domyślna: formatem domyślnym jest ADTS;

uwaga Po znaczniku A można podać długość pola i numer znaku początkowego w formacie: dlugosc[/pierwszy_znak] - pierwszy_znak może być liczbą ujemną i oznacza to liczenie od końca tekstu alarmu.


1.3 Srodowisko pracy modułu Architekt

Home > 1.3 Srodowisko pracy modułu Architekt

1.3 Środowisko pracy modułu Architekt


Home > 1 Praca z programem Architekt

1 Praca z programem Architekt


2.2.1 Edycja bazy definicji zmiennych – Edytor definicji

Home > 2.2.1 Edycja bazy definicji zmiennych – Edytor definicji

2.2.1 Edycja bazy definicji zmiennych – Edytor definicji zmiennych


2.3.2 Generowanie bazy definicji zmiennych z arkusza Excel

Home > 2.3.2 Generowanie bazy definicji zmiennych z arkusza Excel

2.3.3 Generowanie bazy definicji zmiennych z arkusza Excel

W przypadku generowania bazy definicji zmiennych na podstawie arkuszy Excel, należy te arkusze przygotować w sposób szczegółowo opisany w rozdziale 2.6 . Przygotowanie zewnętrznego źródła danych - arkusz Excel .

Architekt pozwala przygotować szablonowy plik Excel definicji zmiennych (Szablon bazy definicji zmiennych w Excel).


2 Obsluga baz definicji zmiennych aplikacji systemu asix

Home > 2 Obsluga baz definicji zmiennych aplikacji systemu asix

2 Obsługa baz definicji zmiennych aplikacji systemu Asix


3.10.3 Deklaracje synchronizacji czasu po stronie Serwera

Home > 3.10.3 Deklaracje synchronizacji czasu po stronie Serwera

3.10.4 Deklaracje synchronizacji czasu po stronie Serwera


3.10.6 Parametry diagnostyczne przekazywane do AslView

Home > 3.10.6 Parametry diagnostyczne przekazywane do AslView

3.10.7 Parametry diagnostyczne przekazywane do AslView


3.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

Home > 3.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

3.10.8 Deklaracja uprawnień dotyczących obsługi alarmów

Rysunek 155. Okno parametrów systemu alarmów – zakładka Bezpieczeństwo.

Zakładka Bezpieczeństwo daje możliwość:

  • zadeklarowania poziomu hasła, którego znajomość będzie wymagana do wykonania określonych operacji:

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów filtrowanych,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów sygnalizowanych dźwiękiem,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów wykluczeń.

Wartość domyślna: brak kontroli

Sposób deklarowania trybu logowania omawia rozdział 3.11 . Konfiguracja zabezpieczenia aplikacji .

  • Dodatkowo użycie opcji Zablokowanie obsługi alarmów przez operatora powoduje, że blokowane są operacje zmiany filtrów, wykluczeń i potwierdzania alarmów. Możliwe jest jedynie przeglądanie alarmów;

Wartość domyślna: obsługa nie jest blokowana


4.8.3. Uzupełnianie danych

Home > Architekt - Parametryzacja aplikacji > 4 Konfigurowanie aplikacji systemu Asix > 4.8 Konfiguracja danych archiwalnych > 4.8.3. Parametryzacja okresu uzupełniania danych

4.8.3. Parametryzacja okresu uzupełniania danych

Zakładka Uzupełnianie obejmuje następujące parametry:

powiększ >>

Rysunek: Widok okna parametryzującego okresu uzupełniania danych.

  • Domyślny minimalny okres uzupełniania - używając tej opcji można wydłużyć domyślny okres czasu (w dniach), z którego archiwa mogą być uzupełniane. Opcja ma znaczenie tylko dla tych archiwów, dla których nie zdefiniowano opcji Minimalny okres uzupełniania.


4.9.3 Deklaracja plikow definicji alarmow i definicji grup

Home > 4.9.3 Deklaracja plikow definicji alarmow i definicji grup

3.9.3 Deklaracja plików definicji alarmów i definicji grup alarmów

uwaga Możliwość deklarowania plików, z których pobierane są definicje alarmów i definicje grup alarmów istnieje wówczas, gdy w module Bazy danych zostanie zdefiniowany tryb pracy bazy definicji alarmów z plikami:

Moduł Bazy danych > Baza definicji alarmów > Tryb pracy bazy definicji alarmów: Tekstowe pliki definicji alarmów są edytowane przez projektanta

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów'.

  • Nazwy plików, w których zdefiniowane są alarmy - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały alarmy; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: definicje alarmów będą czytane z pliku ’alarm.def’ z kartoteki bieżącej aplikacji

  • Nazwy plików, w których zdefiniowane są grupy alarmów - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały grupy alarmów; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: brak


4.9.6 Definicja formatu alarmow

Home > 4.9.6 Definicja formatu alarmow

3.9.6 Definicja formatu alarmów

Grupa zakładek Wygląd służy do definiowania sposobu wyświetlania alarmów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd'.

  • Kolor tła - określa:

  • Tło tabeli alarmów,

  • Alternatywne tło tabeli alarmów,

  • Linie rozdzielające;

  • Kolor tekstu alarmu - w zależności od rodzaju alarmu oraz od stanu alarmu (początek lub koniec) pozwala określić kolor tekstu i kolor tła dla:

  • Komunikat systemowy,

  • Komunikat,

  • Ostrzeżenie,

  • Alarm,

  • Ważny alarm.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor tekstu alarmu'.

  • Kolor daty alarmu - w zależności od stanu alarmu pozwala określić kolor tekstu daty oraz kolor tła daty dla:

  • Alarm rozpoczęty,

  • Alarm rozpoczęty i potwierdzony,

  • Alarm zakończony,

  • Alarm zakończony i potwierdzony.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor daty alarmu'.

  • Alarmy wyselekcjonowane - umożliwia zadeklarowanie koloru tła alarmów wyselekcjonowanych;

Rysunek:. Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Alarmy wyselekcjonowane'.

  • Maski typu Czerwony Tryb - definiuje kolor tekstu kolor tła masek ’Czerwony Tryb’;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Maska typu Czerwony Tryb'.

  • Opcje - pozwala dodatkowo określić:

  • Użycie na maskach i wydrukach alarmów długiego 4-cyfrowego formatu numeru roku;

  • Sortowanie alarmów na liście alarmów aktywnych i historycznych;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Opcje'.

uwaga Użycie trybu sortowania według czasu zdarzeń ma sens tylko wtedy, gdy używana strategia wykrywania alarmów zgłasza alarmy łącznie z czasem.


Home > 4 Konfigurowanie aplikacji systemu Asix

4 Konfigurowanie aplikacji systemu Asix


Deklarowanie długości nazwy zmiennej

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.2. Tworzenie bazy w trybie Edytora > 2.2.4. Deklarowanie długości nazwy zmiennej

2.2.4 Deklarowanie długości nazwy zmiennej

Sprawdzanie maksymalnego rozmiaru zmiennej w edytorze bazy definicji zmiennych jest wykonywane w odniesieniu do aktualnego rozmiaru kolumny Nazwa. Chcąc zmienić ograniczenie dotyczące długości zmiennej, należy użyć opcji Zmień rozmiar atrybutu [image] dla pola Nazwa. Opcja dostępna w menu edytora bazy definicji zmiennych.

Rys. Okno 'Modyfikacja szerokości atrybutu'.


Deklarowanie maksymalnej długości nazwy zmiennej

Home > Architekt - Parametryzacja aplikacji > 2. Obsługa baz definicji zmiennych aplikacji systemu Asix > 2.3 Tworzenie bazy w trybie Generatora > 2.3.11 Deklarowanie maksymalnej długości nazwy zmiennej

2.3.11. Deklarowanie maksymalnej długości nazwy zmiennej

Dla baz definicji zmiennych tworzonych w trybie generatora istnieje możliwość użycia opcji definiującej maksymalną długość nazw zmiennych: 50 znaków dla aplikacji klasycznych i 255 dla aplikacji w wersji Evo. Opcja Maksymalny rozmiar nazwy zmiennej dostępna jest przy trybie tworzenia bazy definicji zmiennych przy użyciu generatora, na zakładce Opcje:

Architekt > Bazy danych > Baza definicji zmiennych > Opcje

Rys. Baza definicji zmiennych > Opcje > Maksymalny rozmiar nazwy zmiennej.


Tabela atrybutow zmiennych

Home > Tabela atrybutow zmiennych

azwa

Opis

Typ wartości

Określa typ wartości zmiennej w konwencji .Net. W przypadku użycia bazy MDB nie posiadającej tego atrybutu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej funkcji przeliczającej i formatu.

Format

Sposób formatowania tekstowego wartości w konwencji .Net. Skrócony opis formatów .Net można znaleźć w podręczniku AsixEvo_Techniki_budowy_diagramów.pdf/chm.

W przypadku baz MDB atrybut tworzony jest wirtualnie według poniższych zasad:

  1. Jeżeli w bazie jest atrybut FormatEvo, to jest on traktowany wprost jako definicja atrybutu Format Asix.Evo.

  2. Jeżeli w bazie nie ma atrybutu FormatEvo, to atrybut Format bazy MDB (podawany w konwencji formatów aplikacji klasycznych) jest w trakcie ładowania tłumaczony na odpowiadający mu format .Net.

Funkcja przeliczająca odczytu

Atrybut ma postać wyrażenia, które wstępnie przelicza pobraną z drajwera wartość surową zmiennej. W treści wyrażenia odwołanie do wartości surowej wykonywane jest przy pomocy funkcji RawValue.

W przypadku korzystania z serwera danych (kanał Asix6), niezależnie od definicji atrybutu funkcji przeliczającej odczytu, wartość zmiennej podlega standardowemu przeliczeniu przez Asmen’a na podstawie atrybutu Funkcja przeliczająca.

W przypadku użycia bazy MDB nie posiadającej atrybutu Funkcja przeliczająca odczytu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej formatu.

Funkcja przeliczająca zapisu

Atrybut ma postać wyrażenia, które przelicza wartość sterującą przed wysłaniem jej do drajwera.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Wartość początkowa

Określa wartość początkową zmiennej, nadawaną zmiennej w momencie uruchomienia aplikacji.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.


1. Nowości w wersji Asix

Home > 1. Nowości w wersji Asix

1. Nowości w systemie Asix.Evo 7

• Całkowicie przeprojektowany, nowy system wizualizacji cechujący się w pełni skalowalną grafiką wektorową

• Konstruktor aplikacji wbudowany w każdym pakiecie run-time

• Elastyczne obiekty wizualizacyjne, których wszystkie cechy można uzależniać od dynamicznych parametrów środowiska pracy (wartości zmiennych, stanu alarmów, itp.)

• Możliwość tworzenia automatycznie aktualizowanych parametryzowanych wzorców obiektów

• Możliwość tworzenia własnych typów obiektów

• Zwiększona produktywność konstruowania aplikacji dzięki parametryzacji obiektów z Bazy Zmiennych oraz interaktywnego parametryzowania w trybie on-line

• Możliwość dynamicznej wymiany zawartości części okna wizualizacyjnego

• Wydłużenie nazw zmiennych procesowych

• Możliwość jednoczesnego korzystania z wielu baz zmiennych

• Obsługa zmiennych o różnorodnych typach w tym 64-bitowych oraz tablicowych

• Pełne wsparcie dla pracy w konfiguracjach wielomonitorowych

• Bogata biblioteka symboli technologicznych

• Możliwość automatycznej konwersji starszych aplikacji Asix do nowej wersji

• Możliwość uruchomienia aplikacji w pełnej funkcjonalności w środowisku WWW dla przeglądarek IE

• Prekonfigurowany uniwersalny portal informacji procesowych

• Superwydajny archiwizator danych procesowych

• Rejestracja przebiegów zmiennych w archiwach dobowych, miesięcznych lub rocznych

• Automatyczna kompresja archiwum danych

• Automatyczne wyliczanie i archiwizacja różnorodnych danych agregowanych

• Automatyczna archiwizacja danych na rezerwowych dyskach stałych lub wymiennych (tworzenie kopii bezpieczeństwa)

• Bogata lista drajwerów komunikacyjnych zapewniających łączność z większością dostępnych sterowników przemysłowych

• Nowy system alarmów z rejestracją pełnych informacji o zdarzeniach oraz przebiegu ich obsługi

• Długookresowy dziennik alarmów i zdarzeń ograniczony jedynie pojemnością dysku z możliwością bieżącego zapisu zdarzeń do baz SQL

• W pełni synchronizowana obsługa alarmów aktywnych w środowiskach wielostanowiskowych

• Brak ograniczenia na liczbę zdefiniowanych alarmów

• System otwarty: dostęp do danych bieżących i archiwalnych w oparciu o protokoły OPC, OLE DB, OLE Automation, serwery .NET, Web services

• Wbudowany tryb pracy w „gorącej rezerwie” podnoszący niezawodność stacji operatorskich

• Możliwość tworzenia systemów w oparciu o sieci LAN, WAN, Internet, łącza modemowe i systemy łączności bezprzewodowej (radiolinie, GPRS)

• Współpraca z istniejącymi starszymi aplikacjami Asix

• System skryptów oparty o języki C# oraz Visual Basic platformy .NET, z wbudowanym edytorem z kontrolą i kolorowaniem składni. Możliwość wykorzystania wszystkich usług platformy .Net łącznie z tworzeniem własnych interfejsów użytkownika

• Narzędzie do analizy danych archiwalnych w postaci wykresów AsTrend. Możliwość analizy danych odczytywanych bezpośrednio z serwerów OPC HDA

• Narzędzie do analizy statystycznej zarejestrowanych zdarzeń alarmowych AsAlarm

• Moduł receptur i rejestracji zdarzeniowej danych w bazie SQL AsBase

• Moduł tworzenia raportów oparty o Microsoft Reporting Services

• Zintegrowany system kontroli uprawnień oparty na rolach użytkowników

• Rejestracji wykonanych operacji sterujących w bazie danych typu SQL

• Możliwość tworzenia aplikacji wielojęzycznych z przełączaniem języka operatora w trakcie pracy. Pełna obsługa standardu Unicode


Home > 3. Instalacja i konfiguracja systemu Asix

3. Instalacja i konfiguracja systemu Asix


Home > 7.1. Ogólna charakterystyka programu Aspad

7.1. Ogólna charakterystyka programu Aspad


8.2.2. Wymagania programowe

W systemach NT/2000/XP należy zainstalować oprogramowanie sieciowe oraz interfejs NETBIOS. Są one częścią składową tych systemów. Można również zainstalować oprogramowanie sieciowe innych firm.

Warunkiem poprawnej współpracy jest udostępnianie przez to oprogramowanie interfejsu NETBIOS.

W każdym przypadku należy pamiętać, żeby spełnione były poniższe warunki.

  • W sieciach opartych o systemy WINDOWS NT/2000/XP konieczne jest skonfigurowanie tych systemów oraz Aslinka w taki sposób, aby na każdym stanowisku Asix interfejs NETBIOS, wykorzystywany przez Aslink, powiązany był z tym samym protokołem. Takim protokołem może być np. odpowiednio: “NetBEUI protocol" lub “NWLink IPX/SPX Compatible Transport" dla systemu WINDOWS NT.

  • W systemach WINDOWS NT/2000 nie jest wymagana parametryzacja interfeju NETBIOS. Należy zwrócić jedynie uwagę na powiązanie Aslink z właściwym interfejsem NETBIOS, tj. należy odpowiednio dobrać parametr Adapter w pliku konfiguracyjnym aplikacji. Parametr ten definiuje logiczny numer interfejsu sieciowego. W systemie WINDOWS NT i WINDOWS 2000 zawierającym jedną (lub więcej) kart sieciowych może być kilka logicznych interfejsów sieciowych (logicznych adapterów). Wybór odpowiedniego interfejsu logicznego decyduje o protokole, na jakim będzie oparta komunikacja z wykorzystaniem interfejsu NETBIOS. System WINDOWS NT pozwala na swobodne przyporządkowywanie interfejsów NETBIOS protokołom. W systemie WINDOWS 2000 ustawienie danego protokołu jako domyślny powoduje, że związany z nim interfejs NETBIOS ma numer logiczny 0.


8.2.3. Aktywowanie usługi zdalnego dostępu (RAS) w systemach

Home > 8.2.3. Aktywowanie usługi zdalnego dostępu (RAS) w systemach

8.2.3. Aktywowanie usługi zdalnego dostępu (RAS) w systemach Windows XP/2003

Alokacja_zasobów_

Program EnableRASLana jest programem umożliwiającym modułowi sieciowemu Aslink wykorzystanie usługi zdalnego dostępu (RAS), protokołu TCPIP i interfejsu NETBIOS do nawiązywania połączeń w systemach Windows XP oraz Windows 2003. Usługa RAS pozwala na łączenie się ze zdalną stacją za pomocą np. modemu, łącza szeregowego itp. W wyżej wymienionych systemach Windows niektóre funkcje tego typu połączeń są domyślnie zablokowane, co uniemożliwia ich wykorzystanie przez moduł Aslink. Aby takie połączenia były możliwe, należy jednorazowo uruchomić program EnableRASLana. Ponowne uruchomienie tego programu może okazać się konieczne po zmianie konfiguracji sieci.

Uruchomienie programu EnableRASLana wymaga uprawnień administracyjnych.


Home > 8.2. Wymagania sprzętowe i programowe

8.2. Wymagania sprzętowe i programowe


Home > 19.4. Obiekty - opisy

19.4. Obiekty - opisy


31. Notatnik dyspozytorski

Z ukierunkowaniem na systemu dyspozytorskie powstał moduł notatnika operatora. Notatnik Dyspozytorski jest programem ułatwiającym dyspozytorom prowadzenie rejestru notatek. Posiada on między innymi możliwość:

- edytowania oraz automatycznego numerowanie notatek,

- opatrywania notatek datą, czasem utworzenia oraz nazwą autora,

- tworzenia z bazy notatek raportów,

- szybkiego wyszukiwania notatek spełniających zadane kryteria.

Szczegółowy opis wykorzystania modułu notatnika znajduje się w pomocy do modułu Notatnik.


AsAlarm - interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu asix.

Home > Asix - Funkcjonalność i zasady działania / Projektowanie aplikacji > 36. AsAlarm - interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu asix.

36. AsAlarm - interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu Asix

AsAlarm to program dostarczający narzędzi do szczegółowej analizy informacji o alarmach generowanych przez monitorowany obiekt oraz danych na temat pracy systemu alarmów. Zarządzanie informacjami alarmowymi realizowane jest przy użyciu:

  • tabeli zdarzeń historycznych,

  • wykresów przebiegów wybranych zdarzeń alarmowych,

  • części analitycznej służącej wyliczaniu różnego rodzaju statystyk.

Szczegółowy opis użycia modułu AsAlarm można znaleźć w pomocy AsAlarm.chm lub AsAlarm.pdf.


First Topic

This is the first topic in your project. Delete this text and replace it with your own. To add a new topic, click the New Topic button on the tool bar.

To learn more about the WYSIWYG Editor, pressF1 (with your cursor in this pane) to display Help.