Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 7

www.asix.com.pl

AsAlarm

Interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu Asix

Dok. Nr PLH7101

Wersja: 2013-07-15


3. Specyfikacja funkcjonalna programu AsAlarm

1. Specyfikacja funkcjonalna programu AsAlarm

AsAlarm to program dostarczający narzędzi do szczegółowej analizy informacji o alarmach generowanych przez monitorowany obiekt oraz danych na temat pracy systemu alarmów. Program jest zgodny z wytycznymi organizacji EEMUA (The Engineering Equipment and Materials Users Association) nr 191. Dokument określa zasady prawidłowego projektowania i eksploatacji systemu alarmów. Głównym wnioskiem tej publikacji jest konieczność regularnej analizy systemu alarmów w celu uzyskania jego wysokiej wydajności i niezawodności.

AsAlarm pozwala prowadzić analizę systemu alarmów w dwóch płaszczyznach:

- oceny poprawności projektu struktury systemu alarmów w konkretnej aplikacji;

- analizy alarmów zarejestrowanych na obiekcie.

Zarządzanie informacjami alarmowymi realizowane jest przy użyciu:

  • tabeli zdarzeń historycznych,

  • wykresów przebiegów wybranych zdarzeń alarmowych,

  • analizy dynamicznej służącej wyliczaniu różnego rodzaju statystyk dotyczących archiwum zdarzeń,

  • analizy statycznej obrazującej strukturę bazy definicji alarmów.

W programie AsAlarm zastosowano interfejs użytkownika wzorowany na modelu MDI (ang. Multi Document Interface), który umożliwia tworzenie wielu zakładek w obrębie głównego okna programu. Każda zakładka przechowuje własny zestaw filtrów, oraz własny obszar prezentacji danych (tabela, wykres, analiza).

Ustawienia programu AsAlarm, w szczególności parametry dostępu do baz danych, wartości filtrów wraz z innymi opcjami zapamiętywane są w pliku projektu w formacie XML. Zestaw alarmów poddawanych analizie podlega wstępnie określanym kryteriom selekcji, definiowanym przez wspólny filtr zdarzeń. W ramach jednego projektu programu AsAlarm możliwe jest utworzenie w oknie głównym programu wielu zakładek przechowujących własny zestaw opcji filtrowania. Taki mechanizm umożliwia stworzenie jednego projektu pozwalającego na analizę alarmów za różne okresy czasu zdefiniowane na osobnych zakładkach, a zatem bez konieczności ciągłego przedefiniowywania warunków filtrowania w celu uzyskania wyników za dany okres.

Program AsAlarm dostępny jest w dwóch wersjach: standardowej okienkowej oraz uruchamianej w oknie przeglądarki. Funkcjonalność obu wersji jest identyczna - jedyną różnicą jest możliwość swobodnego deklarowania baz zdarzeń i definicji alarmów w wersji okienkowej - w wersji przeglądarkowej parametry dostępu do wspomnianych baz są 'zaszyte' w kodzie stron programu AsAlarm (konfiguracji takiej dokonuje administrator na etapie przygotowania programu do pracy w przeglądarce; konfiguracji można dokonać za pomocą programu Architekt).

Rysunek: AsAlarm - wersja okienkowa - okno główne.


Wymagania programu AsAlarm

2. Wymagania programu AsAlarm

Definicje alarmów / Archiwum zdarzeń alarmowych

Definicje alarmów poddawane analizie przez program AsAlarm muszą być przechowywane w bazie definicji zmiennych aplikacji systemu Asix w formacie SQL lub MDB, natomiast archiwum zdarzeń alarmowych musi znajdować się na serwerze SQL. W tym zakresie istnieje możliwość przekonwertowania logów zdarzeń alarmowych systemu Asix w formacie binarnym (pliki al??????.log) do formatu SQL przy wykorzystaniu programu AlarmLogConverter.exe, dostępnego w pakiecie Asix. Możliwa jest też bieżąca rejestracja zdarzeń alarmowych w bazie SQL pod kątem późniejszej analizy przez program AsAlarm - rejestracja taka odbywa się równolegle z zapisywaniem zdarzeń alarmowych do archiwum w plikach al??????.log.

AsAlarm wymaga baz danych serwera MS SQL Server od wersji 2008.

AsAlarm w przeglądarce internetowej

Dla wersji przeglądarkowej programu AsAlarm wymagana jest przeglądarka: Internet Explorer lub Firefox z doinstalowanym dodatkiem IE Tab.


Baza definicji alarmów - konfiguracja

3. Baza definicji alarmów - konfiguracja

Na potrzeby programu AsAlarm, AsTrend oraz środowiska projektowania raportów opartym na usługach Reporting Services firmy Microsoft (w systemie Asix nazywany systemem raportowania AsRaport) wymagane jest pobieranie definicji alarmów z bazy definicji zmiennych w formacie MS SQL lub MDB. W praktyce wymaga to odpowiedniego skonfigurowania bazy definicji alarmów i dołączenia definicji alarmów do istniejącej bazy definicji zmiennych. Dotyczy to zarówno aplikacji systemu Asix wersji klasycznej jak i wersji Evo.

W kolejnych rozdziałach omówione zostaną sposoby przygotowania bazy definicji alarmów do współpracy z programem AsAlarm / AsTrend / środowiskiem AsRaport: dla wersji klasycznej oraz dla wersji Evo systemu Asix.

Asix - wersja klasyczna

Definicje alarmów standardowo znajdują się w pliku tekstowym alarm.def (lub <nazwa_pliku_XML_aplikacji>.adf). Możliwe jest użycie pliku o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów przy założeniu, że tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów). Opisy alarmów mogą się też znajdować w kilku plikach definicji. Wewnętrznie alarmy identyfikowane są przez numer. Można zdefiniować 65535 różnych alarmów. Nie istnieje konieczność sekwencyjnego numerowania alarmów. Na przykład, numeracja jednej grupy alarmów rozpoczyna się od numeru 1000, a drugiej (o innym pochodzeniu) od numeru 30000. Należy pamiętać o tym, że zmiana numeracji alarmów w już działającym systemie powoduje konieczność skasowania plików archiwalnych.

Definicje grup alarmów standardowo znajdują się w pliku tekstowym group.def (lub <nazwa_pliku_XML_aplikacji>.gdf). Możliwe jest użycie pliku (plików) o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów - grupy przy założeniu, ze tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów).

Patrz więcej:

'Asix - funkcjonalność i zasady działania', rozdz. '12. System alarmów';

'Moduł Architekt - Interaktywne środowisko konfigurowania aplikacji systemu Asix. Obsługa baz definicji zmiennych VarDef', rozdz. '4.9. Konfiguracja systemu alarmów'.

Asix - wersja Evo

Informacje na temat definicji alarmów przechowywane są standardowo w pliku XML aplikacji.

Patrz więcej:

'Asix.Evo - System alarmów' (PDF/CHM).


Generowanie bazy definicji zmiennych z arkusza kalkulacyjnego (Asix klasyczny)

3.1. Generowanie bazy definicji alarmów z arkusza kalkulacyjnego (Asix klasyczny)

Aby dołączyć definicje alarmów i definicje grup alarmów do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w arkuszu Excel

UWAGA: Przyłączenie definicji alarmów do bazy definicji zmiennych wymaga utworzenia arkusza programu Excel z definicjami alarmów oraz drugiego arkusza z definicjami grup alarmów.

2. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Baza definicji alarmów jest generowana z arkuszy kalkulacyjnych...

3. Dodaj arkusze Excel z definicjami alarmów i definicjami grup alarmów do źródeł danych bazy definicji alarmów:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: Excel

4. Określ, czy baza definicji alarmów ma zostać dołączona do istniejącej bazy definicji zmiennych

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja: Dodaj bazę definicji alarmów do bazy definicji zmiennych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rysunek: Architekt - deklaracja dodania bazy definicji alarmów i grup alarmów do bazy definicji zmiennych.

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.

UWAGA: Każda aktualizacja bazy definicji zmiennych (jej ponowna generacja) wymaga ponownego dogenerowania definicji alarmów i grup alarmów do bazy definicji zmiennych przy użyciu polecenia:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj


Zbiorcza baza definicji alarmów generowana z wielu aplikacji

3.2. Zbiorcza baza definicji alarmów generowana z wielu aplikacji (Asix klasyczny)

Generator zbiorczej bazy definicji alarmów i grup alarmów utworzy zbiorcza bazę definicji alarmów na podstawie źródeł zdefiniowanych we wskazanych aplikacjach. Wygenerowana baza zostanie dołączona do bazy definicji zmiennych aktualnie parametryzowanej aplikacji.

Aby wygenerować zbiorczą bazę definicji alarmów z wielu aplikacji:

1. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Zbiorcza baza definicji alarmów generowana z wielu wybranych aplikacji

2. Dodaj źródła danych:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: pliki INI lub XML

3. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów z wielu aplikacji do istniejącej bazy definicji zmiennych parametryzowanej aplikacji):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

Rys. Rysunek: Architekt - generator zbiorczej bazy definicji alarmów i grup alarmów.


Baza definicji alarmów generowana z plików tekstowych

3.3. Baza definicji alarmów generowana z plików tekstowych (Asix klasyczny)

Dla aplikacji Asixa klasycznego definicje alarmów standardowo przechowywane są w plikach tekstowych .adf (lub alarm.def), a definicje grup alarmów w plikach tekstowych .gdf (lub group.def).

Aby dołączyć definicje alarmów i definicje grup alarmów z plików tekstowych do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w plikach tekstowych.

Informacje na temat tego, jak należy utworzyć takie pliki można znaleźć w podręczniku: Asix.PDF/CHM, 12. System alarmów.

2. Zadeklaruj nazwy plików, o których mowa w punkcie 1 w module:

Architekt > Obszary i komputery > System alarmów > Alarmy > zakładki Baza definicji alarmów / Baza definicji alarmów - grupy

3. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tekstowe pliki definicji alarmów ...

powiększ >>

Rysunek: Architekt - deklaracja trybu pracy bazy definicji alarmów.

3. Wybierz obszar/komputer, dla którego zostały zadeklarowane pliki tekstowe, o czym mowa w punkcie 2. Spowoduje to automatyczne załadowanie plików definicji alarmów i grup alarmów do okna generatora:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Obszar/komputer

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.


Baza definicji generowana z arkuszy kalkulacyjnych w formacie Asix.Evo

3.4. Baza definicji alarmów generowana na podstawie alarmów SQL (Asix klasyczny i Evo)

Generowanie bazy definicji alarmów na podstawie alarmów SQL aplikacji Asixa wersji Evo dotyczy przypadku, kiedy informacje o wszystkich zdarzeniach alarmowych przechowywane są nie tylko w logach alarmów historycznych, ale również jako uzupełnienie w archiwum alarmów typu SQL. Identycznie jest w przypadku aplikacji klasycznych - gdzie oprócz archiwów przechowywanych w plikach dyskowych może być prowadzona również archiwizacja w bazie MS SQL. Generator bazy definicji alarmów SQL w programie Architekt na podstawie archiwum zdarzeń przechowywanych w bazie SQL generuje bazę definicji alarmów dołączaną do bazy definicji zmiennych załadowanej w Architekcie aplikacji.

Sposób konfigurowania rejestracji zdarzeń alarmowych w bazie SQL dla aplikacji klasycznej i Evo omawiają kolejne rozdziały.

Aby dołączyć definicje alarmów SQL do bazy definicji zmiennych:

1. Określ źródło definicji alarmów: (może to być katalog aplikacji Asixa w wersji Evo, pliki xml aplikacji Asixa klasycznego, pliki ini aplikacji starszych wersji Asixa klasycznego lub bieżąca aplikacja):

Architekt > Bazy danych > Baza definicji alarmów SQL > zakładka Źródła danych > opcja: Dodaj źródło danych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rys. Architekt - Generator bazy definicji alarmów SQL na przykładzie alarmów z aplikacji Asix.Evo.


Baza zdarzeń alarmów

4. Baza zdarzeń alarmów

UWAGA:

Na potrzeby programu AsAlarm oraz środowiska AsRaport tworzenia raportów z wykorzystaniem usług Reporting Revices - wymagane jest archiwizowanie zdarzeń alarmowych w bazie danych typu SQL. Dotycz to aplikacji systemu Asix zarówno klasycznych jak i w wersji Evo.

Asix klasyczny

Bieżący stan oraz historia alarmów systemu Asix przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowana inna lokalizacja). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można też ograniczyć ilość pamiętanych dni.

Istnieje możliwość przekonwertowania plików binarnych z logami zdarzeń alarmowych systemu Asix (pliki al??????.log) do formatu bazy SQL. Służy do tego programu AlarmLogConverter.exe dołączany do pakietu Asix.

Możliwa jest też bieżąca rejestracja zdarzeń alarmowych w bazie SQL. Wymaga to odpowiedniego skonfigurowania pliku XML aplikacji systemu Asix przy jednoczesnym odblokowaniu zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line.

(patrz: - 4.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych - gdy istnieje potrzeba zachowania ciągłości w rejestracji zdarzeń alarmowych pomiędzy archiwum a bieżącą rejestracją

- 4.2. Uruchamianie rejestracji zdarzeń alarmowych on-line - gdy nie ma archiwum alarmów a rejestracja zaczyna się od bieżącego momentu)

Asix Evo

Sposób konfigurowania rejestracji zdarzeń alarmowych w bazie SQL dla aplikacji Evo omawia rozdział 4.3. Archiwum alarmów SQL.


4.2. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do

4.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL (Asix klasyczny)

Konwersja plików binarnych archiwum alarmów systemu Asix do formatu bazy SQL realizowana jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix.

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL:

Aby dokonać konwersji plików al??????.log do formatu bazy SQL i uruchomić bieżącą rejestrację zdarzeń alarmowych bez utraty danych dotyczących wystąpień alarmów w momencie wykonywania czynności związanych z konwersją - należy postępować ściśle wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Przekonwertowanie plików al??????.log do formatu bazy danych SQL:

a. przejdź do programu AlarmLogKonwerter i w kategorii Operacje kliknij na przycisk Rozpocznij.

5. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. po zakończeniu konwersji przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL - zapisowi podlegają tylko te zdarzenia, których nie objęła operacja konwersja plików zdarzeń al??????.log.


Uruchamianie rejestracji zdarezń alarmowych on-line

4.2. Uruchamianie rejestracji on-line zdarzeń alarmowych (Asix klasyczny)

Uruchomienie rejestracji alarmów systemu Asix do bazy SQL realizowane jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix.

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych do formatu bazy SQL (bez konwersji plików binarnych):

Aby uruchomić bieżącą rejestrację zdarzeń alarmowych - należy postępować wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL.


Uruchamianie programu AsAlarm

5. Uruchamianie programu AsAlarm

Wersja okienkowa programu AsAlarm

AsAlarm w wersji okienkowej można uruchomić z poziomu menu Start > Programy > Asix lub bezpośrednio uruchamiając plik AsAlarm.exe znajdujący się domyślnie w głównej kartotece pakietu Asix.

powiększ >>

Rysunek: AsAlarm - wersja okienkowa.

Wersja uruchamiana w oknie przeglądarki internetowej

Program AsAlarm można uruchomić w przeglądarce Internet Explorer wpisując adres:

http://(nazwa_komputera)/AsAlarmNet/index.htm

W miejsce nazwy komputera należy podać nazwę lub adres serwera internetowego. AsAlarmNet to nazwa katalogu na serwerze, udostępnionego w sieci Web. Katalog z wersją internetową programu AsAlarm domyślnie umieszczany jest w trakcie instalacji pakietu Asix w katalogu głównym pakietu.

Widok aplikacji jest bezstanowy. Oznacza to, że można uruchomić wiele okien przeglądarki z programem i pracować na nich niezależnie.

Dla prawidłowej pracy programu AsAalrm wymagane jest odpowiednie skonfigurowanie zabezpieczeń przeglądarki i systemu operacyjnego. W tym celu należy uruchomić program BrowserConfigurator.exe deklarując adres, pod którym AsAlarm będzie uruchamiany, jako adres zaufany. BrowserConfigurator.exe do pobrania z aplikacji internetowej AsPortal.

powiększ >>

Rysunek: AsAlarm - wersja uruchamiana w oknie przeglądarki internetowej.


Otwieranie baz danych - zdarzeń i definicji alarmów

5.1. Deklarowanie baz danych dla wersji lokalnej AsAlarm

Baza definicji alarmów deklarowana jest za pomocą okna ‘Wybór bazy’ uruchamianego przyciskiem Otwórz z menu głównego programu AsAlarm.

Rysunek: Okno deklaracji bazy definicji alarmów.

Baza archiwum zdarzeń alarmowych pobierana jest automatycznie przez program na podstawie danych z bazy definicji zalarmów - wymaga to właściwego skonfigurowania bazy definicji alarmów w postaci pliku .mdb lub bazy w formacie SQL, o czym mowa w rozdziale 3. Baza definicji alarmów - konfiguracja.


Konfiguracja dostępu do baz dla internetowej wersji programu AsAlarm

5.2. Konfiguracja dostępu do baz dla internetowej wersji programu AsAlarm

Program AsAlarm umożliwia analizę danych zawartych w bazie definicji zmiennych i bazie alarmów historycznych. Internetowa wersja programu AsAlarm odczytuje parametry dostępu do tych baz ze strony internetowej (np. index.htm) umieszczonej na serwerze.

Informacje o lokalizacji bazy archiwum znajduje się w następujących elementach strony:

<head>

<meta name="AlarmsArchiveServerName" id="AlarmsArchiveServerName" content="(local)"> - nazwa instancji serwera Microsoft Sql Server 2008 w formacie: "nazwa_serwera\nazwa_instacji"

<meta name="AlarmsArchiveDatabaseName" id="AlarmsArchiveDatabaseName" content="AsAlarm"> - nazwa bazy zawierającej archiwum alarmów

</head>

Parametry dostępu do bazy definicji alarmów zdefiniowane są w elemencie strony:

<head>

<meta name="AlarmsDef" id="AlarmsDef" content="Baza_zmiennych.mdb"> - nazwa pliku bazy programu Microsoft Acces (plik mdb) lub parametry dostępu do bazy na serwerze Microsoft Sql Server w formacie: "nazwa_serwera\nazwa_instacji/nazwa_bazy"

</head>

Aby zmienić parametry dostępu do baz należy zmodyfikować zawartość atrybutów 'content' opisanych wyżej elementów.

UWAGA: Możliwa jest konfiguracja dostępu do bazy definicji zmiennych i bazy alarmów historycznych za pośrednictwem konfiguratora dostępnego w programie Architekt. Umożliwia on aktualizację pliku konfiguracyjnego 'index.htm' na podstawie konfiguracji aplikacji systemu Asix. Konfigurator kopiuje plik bazy definicji zmiennych .mdb (w której mieszczą się definicje alarmów) do katalogu programu AsAlarm.

Aby skonfigurować dostęp do baz danych dla internetowej wersji programu AsAlarm przy użyciu programu Architekt

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji systemu Asix

2. Uruchom konfigurator aplikacji internetowych:

Architekt > menu Aplikacja > Konfiguruj aplikacje internetowe ... > zakładka AsAlarm/Konfiguracja

3. Kliknij na przycisk Konfiguruj


Okno główne

6.1. Okno główne

Główne okno programu AsAlarm składa się z następujących części: paska narzędzi, listy zakładek, opcji filtrowania, obszaru prezentacji tabeli, wykresów i analizy. Nagłówek okna zawiera nazwę bieżącego pliku projektu.

powiększ >>

Rysunek: Okno główne programu AsAlarm.


Menu główne

6.2. Menu główne

Menu główne programu ma nowoczesny wygląd wstęgi, charakterystyczny dla produktów firmy Microsoft. Wszystkie polecenia zorganizowane zostały w dwie główne kategorie: narzędzia, widok i pomoc. W ramach każdej kategorii przyciski pogrupowane są w logiczne grupy:

Narzędzia

Plik - grupa poleceń umożliwiających tworzenie, otwieranie i zapisywanie pliku projektu w formacie xml oraz tworzenie wydruków. Okna otwarcia i zapisu pliku posiadają ustawione filtry, dzięki czemu wyświetlają tylko pliki z rozszerzeniem *.xml.

Filtry - polecenia umożliwiające zarządzanie zakładkami z ustawionymi filtrami

Dane - kategoria zawiera polecenia służące do odświeżania danych (np. po zmianie warunków filtrowania)

Wykres - polecenia związane z zakładką wykresu

Baza definicji alarmów - kategoria aktywna dla lokalnej (okienkowej) wersji AsAlarm; umożliwia deklarowanie bazy definicji alarmów

Rysunek: Polecenia z kategorii 'Narzędzia'.

Widok

Zakładka widok umożliwia zmianę wyglądu programu. Znajduje się na niej lista dostępnych stylów wizualnych aplikacji. Po dokonaniu wyboru, zmienia się układ kolorystyczny programu.

Rysunek: Polecenia z kategorii 'Widok'.

Pomoc

Zakładka zawiera przycisk do uruchamiania okna pomocy i okna z informacją na temat wersji programu.

Rysunek: Polecenia z kategorii 'Pomoc'.


Zarządzanie zakładkami

6.3. Zarządzanie zakładkami z filtrami

W aplikacji zastosowano interfejs użytkownika wzorowany na modelu MDI (ang. Multi Document Interface), który umożliwia tworzenie wielu zakładek w obrębie głównego okna programu.

Każda zakładka przechowuje własny zestaw filtrów oraz własny obszar prezentacji danych (tabela, wykres, analiza).

Wybranie polecenia Filtry > Nowy filtr spowoduje dodanie nowej zakładki, z wygenerowaną domyślnie nazwą. Domyślna nazwa ma stały przedrostek „Filtr”, do którego doklejana jest pierwsza wolna cyfra zaczynając od „1”.

Do zmiany nazwy aktywnej zakładki służy polecenie Filtry > Zmień nazwę, które otwiera okno do wprowadzenia tekstu.

Możliwe jest również dowolne przestawianie zakładek metodą „drag and drop”. Do usuwania zakładki służy czerwony przycisk widoczny przy nazwie aktywnej zakładki.

powiększ >>

Rysunek: Okno AsAlarm z utworzonymi zakładkami filtrów.


Tabela

6.5. Tabela

Tabela zdarzeń historycznych umożliwia wyświetlanie wszystkich informacji zawartych w bazie zdarzeń alarmowych. Kolumny w tabeli odpowiadają kolumnom istniejącym w tej bazie.

Tabela prezentuje wszystkie zdarzenia, spełniające określone warunki filtru zdarzeń. Układ, kolejność i widoczność kolumn są w pełni konfigurowalne. Dodatkowo użytkownik ma do dyspozycji mechanizmy wbudowane w użyty komponent tabeli, czyli: grupowanie, dodatkowe filtrowanie i sortowanie. Rysunek poniżej przedstawia tabelę z użytymi mechanizmami grupowania (1) i sortowania, z otwartym oknem wyboru widocznych kolumn (2).W dolnej części tabeli znajduje się pasek statusu pokazujący następujące informacje: liczba wszystkich zdarzeń, liczba wybranych zdarzeń, czas trwania wybranych zdarzeń.

Dodatkowo wszystkie kolumny typu data/czas mają dwie wersje: prezentujące czas lokalny i UTC.

Rysunek 9. Tabela zdarzeń alarmowych

Tabela posiada własne menu kontekstowe, działające na wybranych wierszach (zdarzeniach alarmowych), umożliwiające:

  • wyświetlenie podglądu tabeli zawierającej tylko wystąpienia wybranych zdarzeń,

  • dodanie zdarzeń do istniejącego wykresu, lub stworzenie nowego wykresu z wybranymi zdarzeniami.

UWAGA: Tabela posiada ograniczenie na maksymalną liczbę wyświetlanych wierszy (100000). W przypadku próby wyświetlenia większej liczby danych pojawia się odpowiedni komunikat (pojawia się tylko raz na uruchomienie programu) i zostaje pobranych 100000 najnowszych zdarzeń alarmowych. W takiej sytuacji dodatkowo na pasku statusu widoczny jest żółty trójkąt ostrzegawczy.


Wykres

6.6. Wykres

Wykres umożliwia prezentację przebiegu zdarzeń alarmowych w postaci schodkowej. Składa się on z trzech części, panelu zakresu danych (1), obszaru prezentacji danych (2) i panelu legendy (3). Oba panele mogą zostać zwinięte, aby powiększyć obszar prezentacji danych. W ramach poszczególnych zakładek możliwe jest tworzenie wielu wykresów, wyświetlających różne zestawy danych. Kolejność i nazwy wykresów można dowolnie modyfikować - identycznie, jak ma to miejsce w przypadku głównych zakładek programu.

Zdarzenia alarmowe można dodawać do wykresu na dwa sposobu. Legenda zawiera przyciski otwierający okno wyboru alarmu z bazy definicji alarmów. Można też dodawać zdarzenia z poziomu tabeli, zaznaczając kilka wierszy i wywołując menu podręczne. Również z poziomu legendy można usuwać serie z wykresu.

Okres wykresu ustalany jest na podstawie pierwszego i ostatniego punktu, pobranego dla wybranych zdarzeń z uwzględnieniem warunków filtrowania. W obszarze okresu można się poruszać za pomocą panelu zakresu danych. Możliwe jest przybliżanie/oddalanie wykresu, przewijanie w przód/tył, przechodzenie po punktach wybranej serii. Można również sprecyzować własny zakres.

Panel legendy prezentuje podstawowe informacje dotyczące zdarzeń. Kolory wierszy w legendzie odpowiadają kolorom serii na wykresie. Jeżeli legenda zostanie ukryta, to identyfikatory zdarzeń zostaną wyświetlone na wykresie.

Po najechaniu kursorem na punkt wykresu wyświetlana jest etykieta z dokładnym stemplem czasu tego punktu. Tą funkcjonalność i obraz całego wykresu przestawia poniższy rysunek.

Możliwe jest „poruszanie się” w obrębie wykresu tzn.:

- przybliżanie/oddalanie (za pomocą przycisków [image] [image] lub przy pomocy lupy uruchamianej po najechaniu kursorem myszy w obszar wykresu przy wciśniętym klawiszu Shift / Ctrl),

- przesuwanie w lewo/prawo (za pomocą przycisków [image] [image]; [image] [image]),

- pozycjonowanie początku wykresu do kolejnych wystąpień danego zdarzenia wybranego w legendzie (za pomocą przycisków [image]),

Rysunek: Wykres zdarzeń alarmowych.

UWAGA: Podobanie jak tabela, wykres posiada ograniczenie na wyświetlaną liczbę danych – 5000 punktów. W przypadku gdy sumaryczna liczba punktów wszystkich serii przekracza ten limit, żądana seria nie zostanie narysowana - pojawi się odpowiedni komunikat (komunikat pojawia się tylko raz na uruchomienie programu), a na pasku statusu zostanie wyświetlony żółty trójkąt ostrzegawczy.


Analiza

6.7. Analiza dynamiczna

Część analityczna podzielona jest na dwie zakładki, analizę statyczną i dynamiczną.

Analiza dynamiczna prezentowana jest w postaci tabeli przestawnej. Oznacza to, że użytkownik sam może tworzyć potrzebny zestaw danych. Możliwe jest wybieranie kolumn, wierszy oraz zawartości obszaru danych.

Analiza dynamiczna umożliwia przeglądanie następujących informacji statystycznych, wyliczanych na podstawie analizy archiwum zdarzeń alarmowych:

  • rozkład wystąpień zdarzeń (liczbowy, procentowy),

  • czas trwania zdarzeń,

  • średni czas potwierdzenia,

  • liczba alarmów zakończonych,

  • liczba alarmów potwierdzonych,

  • wykrycie zdarzenia występującego najczęściej,

  • wykrycie zdarzeń trwających najdłużej.

Wymienione statystyki mogą być wyliczane z podziałem na typy, grupy i identyfikatory alarmów. Możliwe jest dowolne organizowanie widoku tabeli, tj.: wybór widocznych pól i kolumn, zmiana organizacji całej tabeli.

Połączenie tych możliwości z prostym mechanizmem sortowania pozwala na dogłębną analizę danych.

Rysunek: Analiza dynamiczna.


Analiza statyczna

6.8. Analiza statyczna

Na zakładce analizy statycznej prezentowana jest analiza bazy definicji alarmów. Użytkownik otrzymuje informację o liczbie alarmów, procentowemu i liczbowemu rozkładowi definicji alarmów z podziałem na grupy i typy. Wyniki przedstawione są w postaci tabeli i wykresu.

UWAGA: Istnieje możliwość sortowania wierszy wg kolumn, co przekłada się również na kolejność słupków na wykresie - słupki szeregowane są rosnąco lub malejąco względem rosnących lub malejących wartości kolumny, wg której zostały posortowane wiersze w tabeli.

Rysunek: Analiza statyczna.


Wydruki

6.9. Wydruki

Aplikacja umożliwia wydruk danych z tabeli, wykresu oraz analizy. Wybranie polecenia Drukuj spowoduje otwarcie okna podglądu wydruku. Sporządzony w ten sposób raport, przedstawiony na poniższym rysunku, jest wstępnie sformatowany, tzn. zawiera nagłówek(1), datę sporządzenia wydruku(2), numerację stron(3), oraz stopkę firmową(4). Nagłówek zawiera nazwę zakładki oraz tytuł wykresu. Wszystkie opisane parametry mogą być zmodyfikowane przez użytkownika w oknie podglądu wydruku.

Raport zawiera również tekstowy opis aktywnych warunków filtrowania(5). W przypadku drukowania wykresu, domyślnie ustawiana jest orientacja pozioma strony.

Rysunek. Wydruk wykresu.


Filtr zdarzeń

6.3. Filtr zdarzeń

Filtr zdarzeń umieszony jest na rozwijanym panelu. Możliwe jest jego ukrycie, w celu powiększenia obszaru prezentacji danych. Wszystkie opcje filtrowania podzielone są na logiczne grupy. Wartość wynikowa całego filtru tworzona jest jako iloczyn logiczny poszczególnych warunków. Na rysunku poniżej znajduje się zrzut ekranu prezentujący panel filtrowania, z jedną rozwiniętą grupą.

Rysunek: Panel filtru zdarzeń.


Filtr zdarzeń

6.4. Filtr alarmów

Filtr alarmów jest stosowany do tabeli, wykresów oraz analizy dynamicznej. Posiada bardzo rozbudowane możliwości selekcji alarmów ze względu na:

- domenę alarmów (z domen zdefiniowanych w bazie definicji alarmów),

- identyfikatory (lista identyfikatorów lub wzorce identyfikatorów),

- tekst,

- grupy,

- typy,

- statusy (predefiniowane lub własne kombinacje),

- czasy rozpoczęcia i zakończenia,

- opcje potwierdzenia (czas, operator, stacja).

Opcje filtrowania pozwalają na wprowadzanie bezwzględnego czasu dzięki zaimplementowanej obsłudze symbolicznych czasów w notacji OPC.

Rysunek: Widok filtrów alarmów z rozwiniętą grupą 'Status'.


Konfigurowanie rejestracji zdarzeń alarmowych w bazie SQL (Asix.Evo)

4.3. Konfigurowanie rejestracji zdarzeń alarmowych w bazie SQL (Asix.Evo)

Uzupełnieniem standardowego logu alarmów historycznych aplikacji Asix.Evo jest archiwum alarmów typu SQL. Archiwum to jest przeznaczone do analizy alarmów przy pomocy programu AsAlarm, a także w systemach raportowania AsRaport. W celu podniesienia niezawodności, można równolegle tworzyć archiwum na kilku serwerach. Jednak nawet w przypadku użycia pojedynczego serwera, Asix.Evo dysponuje mechanizmami buforowania danych pozwalającymi na pracę z chwilową utratą połączenia z serwerem SQL. Archiwum SQL należy identycznie parametryzować na wszystkich stanowiskach typu kontroler. Wynika to z faktu, że zapis do bazy SQL w danej chwili wykonuje tylko stanowisko kontrolera aktywnego.

powiększ>>

Rys. AsixEvo.exe / Konfiguracja systemu alarmów / Ustawienia / Bazy danych alarmów historycznych.

Przed rozpoczęciem archiwizacji alarmowa baza danych SQL musi być utworzona. Służy do tego powyższe okno otwierane przyciskiem Zarządzanie bazami danych. Okno pozwala również na wykonywanie innych zadań administracyjnych. Poświadczenia z grupy Autoryzacja serwera bazy danych muszą zapewnić uzyskanie w serwerze SQL uprawnień wystarczających do wykonywania operacji tworzenia i usuwania baz danych.


Tworzenie bazy

.1. Tworzenie bazy