Witamy

>> Pomoc dla użytkowników systemu asix - wersji 5 i 6

www.asix.com.pl

Moduł AsBase -

System recepturowania i rejestracji zdarzeniowej

Dok. Nr PLH6004

Wersja: 11-07-2011


2.1. Zestaw archiwizacji

Zestaw rejestracji (archiwizacji) opisuje strukturę danych, która będzie archiwizowana. Parametryzowanie zestawu archiwizacji polega na definiowaniu pól wchodzących w skład zestawu (w terminologii aplikacji bazodanowych odpowiada to definiowaniu pól tabeli danych). Pola te nie są bezpośrednio związane ze zmiennymi procesowymi. Jednak wykorzystanie zestawu wymaga określenia tych powiązań poprzez zdefiniowanie zestawów zmiennych przyłączonych do zestawu archiwizacji.

W fazie wykonania aplikacji zestaw archiwizacji przechowuje zarejestrowane wartości (rekordy) zmiennych.

PRZYKŁAD

Aplikacja monitorująca (archiwizująca) stan pieca. W zestawie archiwizacji „Temperatury pieca" zdefiniowane zostały pola:

Temperatura dół, typ zmiennoprzecinkowy

Temperatura środek, typ zmiennoprzecinkowy

Temperatura góra, typ zmiennoprzecinkowy

Włączenie palnika, typ całkowity


2.2. Grupa receptur

Pojęcie podobne do zestawu zmiennych, jednak w tym przypadku chodzi o definiowanie struktury receptury.

Parametryzowanie grupy receptur polega na definiowaniu pól wchodzących w skład receptur - utworzeniu wykazu składników receptur (różne wartości tych składników tworzą receptury). Pola te nie są bezpośrednio związane ze zmiennymi procesowymi. Jednak wykonywanie operacji załadowania receptury wymaga określenia tych powiązań poprzez zdefiniowanie zestawów zmiennych przyłączonych do grupy receptur, do których to zmiennych ładowane są wartości receptur.

W fazie wykonania aplikacji grupa receptur przechowuje wartości receptur. W inny sposób, grupę receptur można opisać jako kontener przechowujący wartości receptur tego samego typu.

PRZYKŁAD

Aplikacja służąca do mieszania farb. W grupie receptur „Kolory" zdefiniowane zostały pola:

Kolor czerwony, typ zmiennoprzecinkowy

Kolor zielony, typ zmiennoprzecinkowy

Kolor niebieski, typ zmiennoprzecinkowy


2.3. Receptura

Receptura to pojedynczy element (rekord) grupy receptur przechowujący wartości nastaw. Każda receptura jest identyfikowana przez unikalną nazwę.

PRZYKŁAD

W grupie receptur „Kolory" wprowadzona została receptura „Żółty" o poniższych wartościach pól:

Kolor czerwony, 255

Kolor zielony, 255

Kolor niebieski, 0


2.4. Zestaw zmiennych

Zestawy zmiennych służą do określenia powiązania pól zestawów archiwizacji i grup receptur ze zmiennymi procesowymi asixa. Zestawy zmiennych to po prostu zbiory nazw zmiennych procesowych. Każda nazwa zmiennej jest związana z odpowiadającym mu polem zestawu archiwizacji lub grupy receptur. Zestawy zmiennych służą jako źródło danych dla zestawów archiwizacji, lub jako miejsce wysłania danych dla grup receptur. Z każdym zestawem archiwizacji i grupą receptur można powiązać więcej niż jeden zestaw zmiennych. Pozwala to na obsługę kilku instalacji poprzez jeden zestaw archiwizacji lub grupę receptur.

PRZYKŁAD

W aplikacji mieszania farb dla grupy receptur „Kolory" można zdefiniować dwa zestawy zmiennych, „Mieszalnik 1" i „Mieszalnik 2", co pozwoli sterować ich pracą ze wspólnej bazy puli receptur:

Zestaw zmiennych „Mieszalnik 1"

Kolor czerwony, zmienna M1_R

Kolor zielony, zmienna M1_G

Kolor niebieski, zmienna M1_B

Zestaw zmiennych „Mieszalnik 2"

Kolor czerwony, zmienna M2_R

Kolor zielony, zmienna M2_G

Kolor niebieski, zmienna M2_B


2.6. Warunek archiwizacji

Warunki archiwizacji są mechanizmem służącym do automatycznego określania momentów zapisu danych do zestawów archiwizacji. W definicji warunku określa się miejsce zapisu danych (zestaw archiwizacji), źródło danych procesowych (zestaw zmiennych) oraz warunek zapisu. Warunki mogą być uzależnione czasowo lub/i polegać na sprawdzaniu wartości synchronizujących zmiennych procesowych.

PRZYKŁAD

W aplikacji monitorującej stan pieca można zdefiniować warunek powodujący zapis rekordu bieżących wartości zmiennych procesowych w zestawie archiwizacji „Temperatury pieca" w chwili, gdy np. wartość temperatury przekroczy jej wartość krytyczną.


2.7. Automatyczna receptura

Automatyczna receptura to mechanizm, który pozwala na załadowanie wartości receptury do zmiennych procesowych w reakcji na zmianę zmiennej synchronizującej. Wybór wysyłanej receptury bazuje na wartości zmiennej synchronizującej – możliwe jest synchronizowanie przez nazwę receptury lub wartość dowolnego z pól grupy receptur.

PRZYKŁAD

AsBase monitoruje zmiany zmiennej tekstowej „Kolor". Po wykryciu zmiany wartości tej zmiennej, wyszukiwana jest receptura w grupie „Kolory" o nazwie identycznej z wartością zmiennej „Kolor", a następnie rekord receptury ładowany jest do właściwego zestawu zmiennych.


2.8. Receptury przeliczalne (procentowe)

W aplikacji AsBase'a istnieje możliwość definiowania receptur z funkcją przeliczania wartości pól w momencie ich wysyłania. Obliczanie wartości pól wykonywane jest na podstawie wartości parametru wsad, podanej przez operatora.

Rys. Przykład definicji receptury przeliczalnej.

Szczegóły dotyczące obsługi receptur przeliczalnych - patrz: 4.7. Obsługa receptur przeliczalnych.


3.2. Tryb anonimowy

AsBase pracuje w trybie anonimowym, gdy nie jest otwarta żadna aplikacja i gdy aplikacja nie ma zdefiniowanego żadnego użytkownika. Tryb pracy zależy od sposobu instalacji programu.

Administrator anonimowy ma poniższe uprawnienia:

  • Administracja

  • Edycja aplikacji

  • Edycja receptur

  • Ładowanie receptur

  • Pełna edycja archiwum

  • Zapis archiwum

  • Utworzenie nowej aplikacji

Utworzyć nową aplikację AsBase’a można tylko na stanowisku zainstalowanym jako stanowisko administracyjne.

Użytkownik anonimowy ma poniższe uprawnienia:

  • Edycja receptur

  • Ładowanie receptur

  • Zapis archiwum

UWAGA Działanie wszystkich okien dialogowych aplikacji pozwalających na wybór pliku lub folderu jest ograniczone do bieżącego folderu aplikacji i jego podfolderów, o ile użytkownik nie posiada uprawnień do tworzenia lub modyfikacji aplikacji.


4.1. Struktura plików

Każda aplikacja AsBase’a składa się z dwóch elementów:

  • Pliku konfiguracyjnego xml

Plik xml przechowuje jedynie podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji. W pliku xml zapisywane są także definicje warunków archiwizacji i automatycznych receptur.

  • Bazy danych

Baza danych aplikacji przechowuje zarówno dane konfiguracyjne aplikacji (opis zestawów archiwizacji, grup receptur, zestawów zmiennych i słowników), jak i dane wykonawcze (archiwa zestawów archiwizacji, wartości receptur). Charakterystyczną cechą AsBase’a jest to, że w trakcie konfigurowania aplikacji, żadne dane nie są zapisywane w bazie danych, aż do momentu wykonania przez użytkownika komendy zapisu. Dane wykonawcze są zawsze zapisywane na bieżąco, bez ingerencji użytkownika.

  • Dodatkowy plik AsbaseParameters.xml

AsBase używa ponadto pliku AsbaseParameters.xml. Plik ten jest niezależny od aplikacji. Przechowywane są w nim parametry globalne, takie jak sposób wyświetlania tabel.


4.2. Uruchomienie programu

Program AsBase uruchamiany jest poniższą komendą:

AsBase [/single][/minimize] nazwa_pliku_xml

Opcjonalny parametr /single powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona. Na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a.

Opcjonalny parametr /minimize powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna.


4.3.1. Menu Plik

Menu Plik zawiera poniższe komendy:

Nowy

Tworzy nową, pustą aplikację.

Odczytaj ponownie

Komenda ponownie odczytuje wcześniej otwartą aplikację. Przydatne jest to, jeżeli po niepożądanej modyfikacji aplikacji projektant chce usunąć zmiany i powrócić do oryginalnej konfiguracji.

Otwórz

Otwiera nową aplikację. Użytkownik wskazuje nazwę pliku konfiguracyjnego xml. Na podstawie jego zawartości otwierana jest właściwa baza danych.

Zapisz

Zapisuje konfigurację na dysku. Dotyczy to zarówno parametrów trzymanych w pliku xml, jak i zawartości tabel konfiguracyjnych bazy danych. Operacja nie dotyczy danych wykonawczych (archiwa zestawów archiwizacji i wartości receptur), które są zapisywane na bieżąco.

Zapisz jako

Zapisuje konfigurację aplikacji w innym pliku niż oryginalny. Dotyczy to tylko zawartości pliku xml, dane bazy danych pozostają w tej samej bazie.

Ostatnie pliki

Grupa komend w menu pozwalających na szybkie otwarcie wcześniej uruchamianych aplikacji.

Style wydruków

Grupa komend w menu pozwalających na wybór aktywnego stylu wydruków. Style wydruków określają formatowanie w zakresie rozmiaru i układu strony, wielkości marginesów, postaci stopek i nagłówków, itp. Przycisk dostępny jest w menu Plik, jeśli zostały zdefiniowane style wydruków za pomocą okna 'Definiowanie stylów wydruków', dostępnego z poziomu panelu głównego AsBase'a (przycisk [image] przy polu Style wydruku:)

Rysunek: Okno definiowania stylów wydruku.

Drukuj

Komenda powoduje bezpośredni wydruk informacji pokazywanych w panelu roboczym.

Podgląd wydruku

Otwiera okno podglądowe wydruku informacji pokazywanych w panelu roboczym. Użytkownik może w tym oknie dowolnie konfigurować wydruk.

Eksportuj

Pozwala zapisać informacje pokazywane w panelu roboczym w pliku o formacie tekstowym, xls, xml lub html.

Zakończ

Kończy pracę AsBase’a.


4.3.2. Menu Widok

Menu Widok zawiera poniższe komendy:

Dziennik zdarzeń

Otwiera okno służące do przeglądania komunikatów programu AsBase’a dotyczących wykonania aplikacji.

Styl

Grupa komend pozwalających na wybór stylu wyświetlania okien AsBase’a.

Paski narzędzi

Grupa komend zarządzających wyświetlaniem pasków narzędzi.

Tabele

Podmenu grupujące komendy działające na tabelach pokazywanych w panelu roboczym okna AsBase’a. Dostępne są poniższe komendy:

Tryb natychmiastowej edycji

Komenda zmienia tryb obsługi tabel. W trybie natychmiastowej edycji po wejściu w pole tabeli następuje przejście do edycji zawartości pola. Tryb jest wygodny w sytuacji, gdy wykonywane jest dużo prac edycyjnych na danych w tabelach. Jeżeli tryb natychmiastowej edycji jest wyłączony, to uaktywnienie edycji wymaga dodatkowego kliknięcia w polu tabeli lub rozpoczęcia wpisywania nowej zawartości. Tryb ten należy używać, gdy działanie użytkownika polega głównie na przeglądaniu danych.

Automatyczne odświeżanie

Powoduje odświeżenie wartości zmiennych w tabelach. W przypadku mniejszej ilości rekordów ustawienie opcji nie ma większego znaczenia, natomiast przy znacznej ilości rekordów zlecane jest wyłączenie opcji, aby nie obciążać pracy modułu.

Pokaż pole grupowania

Komenda włącza pokazywanie w aktualnej tabeli pola grupowania. Pole to pozwala na pogrupowania danych według zawartości wybranych pól.

Pokaż stopkę

Komenda włącza pokazywania w aktualnej tabeli paska stopki. Na stopce można wyświetlić informacje zbiorcze dotyczące poszczególnych kolumn, na przykład wartość średnią.

Dopasuj kolumny

Komenda automatycznie dopasowuje szerokości kolumn aktualnej tabeli. Dopasowanie wykonywane jest na podstawie szerokości okna oraz szerokości kolumn (z uwzględnieniem szerokości pokazywanych danych).

Pokaż szczegóły

Opcja aktywna dla tabel relacyjnych, pozwala na przeglądanie danych w układzie hierarchicznym - wierszy tabeli nadrzędnej (master) oraz powiązanych z nimi wierszy tabeli podrzędnej (detail).

Przełącz widok

Komenda pozwala na zmianę sposobu prezentacji danych w tabeli. Tabela może być przedstawiana jako zestaw wierszy lub jako zestaw kart. Zmianę sposobu prezentacji można również uzyskać za pomocą kombinacji klawiszy CTRL+Tab.

Wybierz widok

Pozwala rozwinąć listę zdefiniowanych widoków celem wybrania jednego z nich.

Zapisz widok

Komenda powoduje zapisanie zmian w aktualnym widoku tabeli.

Zapisz widok jako...

Komenda umożliwia zapisanie ustawień bieżącego widoku tabeli pod określoną nazwą.

Usuń widok

Komenda powoduje usunięcie wskazanego widoku tabeli z listy zadeklarowanych widoków.


4.3.4. Menu Pomoc

Menu Pomoc zawiera poniższe komendy:

AsBase – Pomoc

Komenda otwiera plik pomocy AsBase’a.

AsBase – Informacje

Otwiera okienko informacyjne dotyczące wersji programu AsBase.


4.4. Pasek statusu

Pasek statusu podzielony jest na strefy o następującym znaczeniu:

Strefa logowania

W strefie logowania wyświetlana jest nazwa aktualnie zalogowanego użytkownika. Podwójne kliknięcie wewnątrz strefy powoduje otwarcie okna logowania.

Sygnalizator komunikatów

Ikona sygnalizująca pojawienie się nowego komunikatu w dzienniku zdarzeń. Kolor ikony określa ważność komunikatu (czerwony - błędy; żółty - ostrzeżenia, zielony - komunikaty). Pojedyncze kliknięcie na ikonię powoduje zgaszenie sygnału. Podwójne kliknięcie otwiera okno dziennika zdarzeń.

Strefa wymiany danych

W strefie wyświetlany jest aktualny status automatycznej wymiany danych. Podwójne kliknięcie wewnątrz strefy pozwala włączyć lub wyłączyć wymianę danych.


4.5. Drzewo nawigacyjne

Drzewo nawigacyjne służy do wyboru informacji pokazywanych w panelu roboczym okna AsBase’a.

Postać drzewa zależy od uprawnień użytkownika i konstrukcji aplikacji.

Struktura drzewa w pełnej wersji i znaczenie poszczególnych węzłów jest następujące:

Konfiguracja

Węzeł służący do edycji parametrów podstawowych aplikacji, takich jak nazwa i lokalizacja bazy danych.

Użytkownicy

Węzeł służący do definiowania użytkowników wraz z ich uprawnieniami.

Grupy receptur

Węzeł służący do zbiorczego definiowania grup receptur. Możliwe jest definiowanie pól grup.

Grupa receptur (nazwa)

Węzeł pozwalający na definiowanie pojedynczej grupy receptur. Możliwe jest definiowanie pól grupy oraz związanych z nią zestawów zmiennych.

Zestaw zmiennych (nazwa)

Węzeł służący do definiowania zmiennych wchodzących w skład zestawu zmiennych.

Zestawy rejestracji

Węzeł służący do zbiorczego definiowania zestawów rejestracji. Możliwe jest definiowanie pól zestawów.

Zestaw rejestracji (nazwa)

Węzeł pozwalający na definiowanie pojedynczego zestawu rejestracji. Możliwe jest definiowanie pól zestawu oraz związanych z nim zestawów zmiennych.

Zestaw zmiennych (nazwa)

Węzeł służący do definiowania zmiennych wchodzących w skład zestawu zmiennych.

Warunki rejestracji

Węzeł służący do definiowania warunków rejestracji.

Automatyczne receptury

Węzeł służący do definiowania automatycznych receptur.

Słowniki

Węzeł pozwalający na edycję słowników określających translację wartości pól na teksty.

Receptury

Węzeł, którego podwęzły pozwalają na dostęp do wartości receptur.

Grupa receptur (nazwa)

Węzeł służący do przeglądania i edytowania wartości receptur grupy. Możliwe jest także wykonanie operacji załadowania receptury.

Zestaw zmiennych (nazwa)

Węzeł pozwalający na podgląd bieżących wartości zmiennych wchodzących w skład zestawu zmiennych. Pozwala także na wykonanie ręcznego zapisu danych do grupy receptur jako nowej receptury oraz wykonanie operacji załadowania receptury.

Historia ładowań

Węzeł, w którym można przeglądać rejestr wszystkich operacji załadowania receptury.

Rejestr

Węzeł, którego podwęzły pozwalają na dostęp do archiwów zestawów rejestracji

Zestaw rejestracji (nazwa)

Węzeł służący do przeglądania i analizy zgromadzonych w bazie danych zapisów dla zestawu rejestracji. Użytkownik posiadający uprawnienia może także edytować zawartość archiwum.

Zestaw zmiennych (nazwa)

Węzeł pozwalający na podgląd bieżących wartości zmiennych wchodzących w skład zestawu zmiennych. Pozwala także na wykonanie ręcznego zapisu danych do archiwum zestawu rejestracji.


4.6. Panel roboczy

Zawartość panelu roboczego jest przełączana poprzez wybór nazwy węzła drzewa nawigacyjnego. W większości przypadków w panelu wyświetlana jest tabela, przy pomocy której wprowadza się lub analizuje dane. Ogólne zasady postępowania w trakcie pracy w panelu roboczym dotyczą zagadnień:

Nazewnictwo elementów

Obsługa tabel

Selekcja danych

Widoki tabel


nazewnictwo definiowanych elementow aplikacji

4.6.1. Nazewnictwo definiowanych elementów aplikacji

W trakcie definiowania elementów aplikacji (np. grup receptur, pól poszczególnych grup receptur, zestawów zmiennych dla konkretnej grupy receptur) wymagana jest z reguły podanie trzech parametrów:

Identyfikator – krótka nazwa symboliczna używana do tworzenia nazw pól w tabelach bazy danych aplikacji i interfejsach programowych.

Nazwa – nazwa opisowa elementu używana wszędzie tam, gdzie element jest pokazywany, np. nazwy węzłów drzewa nawigacyjnego, nagłówki kolumn tabel.

Opis – opcjonalny opis elementu, ma znaczenie dokumentacyjne, używany w podpowiedziach węzłów drzewa nawigacyjnego.

Rysunek: Podstawowe parametry elementów definiowanych w ramach aplikacji AsBase.


Selekcja danych

4.6.3. Selekcja danych

Selekcja danych pokazywanych w tabeli może być wykonana poprzez automatyczne (predefiniowane) poprzez kliknięcie na nagłówku kolumny tabeli. Można tez używać zaawansowanego okna tworzenia wyrażeń filtrujących otwieranego przyciskiem [image] paska narzędzi tabeli.

Predefiniowane filtry dostępne są z poziomu nagłówków następujących tabel: tabela zdefiniowanych receptur, tabela historii ładowań receptur, tabela zarejestrowanych wartości zestawu rejestracyjnego. Wartości filtru automatycznego zależą od pola tabeli - przykładowo pole Czas posiada wartości filtrujące rekordy tabeli z dokładnością do dnia, tygodnia, miesiąca lub roku.

Rysunek: Filtr predefiniowany rozwijany z nagłówka kolumn tabel.

Rysunek: Okno kreatora filtrów zaawansowanych.


Widoki paneli

4.6.4. Widoki paneli

Widok to zestaw parametrów określających, w jaki sposób dany panel / dana tabela jest pokazywana.

Możliwości dostępne w porgramie AsBase w zakresie definiowania widoku paneli obejmują:

- zapamiętywanie bieżącego układu pasków narzędzi w oknie programu AsBase; zapamiętywany jest zawsze ostatni układ; układ pasków narzędzi obowiązuje globalnie na wszystkich panelach AsBase'a; układ zapamiętywany jest w rejestrze windowsowym

- zapamiętywanie bieżącego widoku tabel obowiązującego wszystkie panele (ustawienia dotyczące stylów tabel głównych, tabel szczegółów oraz tabeli logu zdarzeń związanych z pracą modułu AsBase), ustawianego przy użyciu komendy Narzędzia > Konfiguruj…); zapamiętywany jest zawsze ostatni układ; (Patrz: Style tabel); nie ma możliwości zapamiętywania stylów tabel dla konkretnych aplikacji AsBase; styl tabel obowiązuje globalnie na wszystkich panelach; styl zapamiętywany jest w rejestrze windowsowym;

- możliwość zdefiniowania kilku indywidualnych widoków tabel dla: tabeli gotowych wartości receptur, tabeli historii ładowań receptur oraz tabeli archiwum wartości zestawu rejestracyjnego; widok zapisywany jest pod indywidualną nazwą dla danej aplikacji AsBase (w bazie SQLowej aplikacji); można zdefiniować wiele widoków dla tej samej tabeli. (Patrz: Widoki tabeli).


Widoki tabeli

4.6.4.1. Widoki tabeli

W skład parametrów definiujących indywidualny widok tabeli wchodzą:

- sposób prezentacji (wiersze/karty),

- zestaw, szerokość i kolejność kolumn,

- wartość filtrów zastosowanych do wyświetlenia wartości wierszy,

- sortowanie.

Załączanie pola grupującego rekordy lub stopki z polami obliczeniowymi ma znaczenie przy przygotowywaniu raportu do wydruku i nie jest zapamiętywane w ramach widoku tabeli.

(Patrz: znaczenie pola grupującego i stopki w rozdziale 5.7. Tworzenie raportów / definiowanie stylu wydruku)

Widok zapisywany jest pod indywidualną nazwą dla danej aplikacji AsBase (w bazie SQLowej aplikacji); można zdefiniować wiele widoków dla tej samej tabeli

Komendy związane z obsługą widoków tabeli dostępne są z poziomu:

1. menu podręcznego tabel wywoływanego kliknięciem prawym klawiszem myszki w obszarze nagłówków tabeli;

2. menu głównego Widok > Tabele.

Dostępne są tam komendy: Wybierz widok, Zapisz widok, Zapisz widok jako..., Usuń widok oraz Widoki...

Rysunek: Menu podręczne tabeli archiwum zestawu rejestracyjnego.

Zarządzanie widokami odbywa się za pomocą okienka dialogowego widoków:

Rysunek: Okno "Widoki tabeli’.

Okno widoków otwierane jest poprzez wybranie pozycji Widoki z menu Widok > Tabele lub z menu kontekstowego tabeli (komenda Widoki...).

Z każdym widokiem związany jest unikalny identyfikator widoku oraz opis widoku. Identyfikator widoku może być użyty w przypadku drukowania tabeli przez aplikację zewnętrzną. Nastąpi wtedy wydruk tabeli po zastosowaniu parametrów widoku określonego identyfikatorem. Dodawanie nowych widoków odbywa się za pomocą przycisku Dodaj bieżący. Powoduje on dodanie nowej pozycji zwierającej parametry aktualnego wyglądu tabeli. Przycisk Zastosuj powoduje zastosowanie wybranego widoku do aktualnej tabeli. Przycisk Usuń kasuje wybrany widok. Przycisk OK powoduje akceptację wszystkich zmian w zestawie widoków i zamknięcie okna.

Zestaw, szerokość i kolejność kolumn

Selekcji wyświetlanych kolumn tabeli można dokonać za pomocą listy dostępnych kolumn, rozwijanej przy użyciu przycisku umieszczonego w lewym górnym rogu tabeli.

Rysunek: Lista do selekcji kolumn wyświetlanych w tabeli.

Filtry

Zastosowanie wybranego widoku do tabeli może wiązać się z modyfikacją filtru (patrz: 4.6.3. Selekcja danych), jeśli taki filtr jest zawarty w widoku i dotyczy on kolumny zawierającej czas. Celem tej modyfikacji jest to, aby filtry typu „wczoraj", „ostatni miesiąc" itp. zachowywały swoje znaczenie w chwili zastosowania widoku. Modyfikowane są filtry, które zawierają dokładnie dwa warunki połączone spójnikiem „i" i każdy warunek jest jedną z relacji: <, <=, >, >= lub dokładnie jeden warunek typu „pomiędzy" i „nie pomiędzy".

Sortowanie

Funkcja sortowania rekordów tabeli dostępna jest z poziomu:

1. nagłówka kolumny - wystarczy kliknąć na nagłówku lewym klawiszem myszy i pojawi się w obszarze nagłówka trójkąt wskazujący kierunek sortowania (kliknięcie na trójkąt zmienia kierunek sortowania);

2. menu podręcznego rozwijanego kliknięciem prawym klawiszem myszy w obszarze nagłówka kolumny.


Style tabel

4.6.4.2. Style tabel

Styl tabeli wyznaczany jest przez: kolorystykę tabeli, szerokość wierszy i wielkość czcionki. AsBase zawiera zestaw predefiniowanych stylów tabeli, dostępnych w oknie wywoływanym komendą Konfiguruj… w menu Narzędzia.

Na zakładce Style tabel użytkownik ma możliwość wyboru stylu dla tabeli głównej, tabeli szczegółów oraz tabeli zdarzeń.

Rysunek: Okno wyboru stylu tabel.


Panel konfiguracji

4.6.5. Panel konfiguracji

Panel konfiguracji służy do podania globalnych ustawień aplikacji AsBase. Są to:

Rysunek: Panel konfiguracji aplikacji AsBase.

Opis aplikacji

Opisowa nazwa aplikacji

Nazwa serwera

Nazwa serwera, na którym umieszczona jest baza danych aplikacji. Brak nazwy oznacza użycie serwera na komputerze, na którym AsBase jest uruchomiony.

Nazwa bazy danych

Nazwa bazy danych aplikacji. Zmiana ustawień dotyczących bazy danych odbywa się w specjalizowanym oknie otwieranym przyciskiem Ustawienia bazy danych.

Baza zmiennych

Nazwa bazy definicji zmiennych używanej do komunikacji z resztą systemu asix. Do wyboru następujące opcje identyfikujące bazę definicji zmiennych:

- plik XML aplikacji systemu asix;

- nazwa serwera i nazwa bazy danych na serwerze MS SQL;

- plik MDB (format MS Access).

Rysunek: Okno wyboru bazy definicji zmiennych.

Serwer danych procesowych

Nazwa sieciowa komputera (zdefiniowana w parametrach sieciowych aplikacji asix), z którego będą pozyskiwane dane procesowe oraz do którego będą wysyłane wartości receptur. W przypadku komputera lokalnego, należy wpisać LOCAL.

Komputer komunikacyjny

Nazwa systemowa komputera, który będzie archiwizował zestawy rejestracji oraz ładował automatyczne receptury. Wprowadzenie tego parametru zablokuje funkcję wymiany danych na wszystkich innych komputerach aplikacji.

Automatyczna wymiana danych

Zaznaczenie tego pola wyboru powoduje automatyczne uruchomienie wymiany danych (obsługa warunków archiwizacji i automatycznych receptur) w momencie załadowania aplikacji przez program AsBase.

Style wydruków

W polu podaje się nazwę domyślnego stylu wydruków. Użycie przycisku [image] otwiera okno dialogowe służące do tworzenia, modyfikowania i wyboru stylów wydruków.

Zaloguj

Przycisk otwierający okno logowania, wyświetlany tylko wtedy, gdy brak zalogowanego użytkownika.

Ustawienia bazy danych

Zmiana ustawień dotyczących bazy danych odbywa się w specjalizowanym oknie otwieranym przyciskiem Ustawienia bazy danych.

Rysunek: Okno ustawienia bazy danych.

Znaczenie pól jest następujące:

Nazwa serwera

Nazwa serwera, na którym umieszczona jest baza danych aplikacji. Brak nazwy oznacza użycie serwera na komputerze, na którym AsBase jest uruchomiony.

Nazwa bazy danych

Nazwa bazy danych aplikacji

Tryb autoryzacji

Określa sposób autoryzacji AsBase’a w serwerze bazy danych. W przypadku autoryzacji typu „Serwer SQL" AsBase używa konta automatycznie tworzonego użytkownika dedykowanego dla dostępu do baz AsBase’a.

Parametry dostępu administracyjnego

Operacje wykonywane w oknie Ustawienia bazy danych wymagają posiadania uprawnień administratora używanego serwera bazy danych. W ramce Parametry dostępu administracyjnego należy ustawić właściwe parametry, które zależą od sposobu skonfigurowania serwera.

Kopia bazy danych

Ta grupa pól określa parametry wykonywania kopii zapasowej bazy danych.

Pole Folder określa katalog, w którym ma być zapisywana kopia bazy danych.

Pole Twórz kopię co pozwala zdefiniować częstość, z jaką będzie tworzona automatycznie kopia bazy danych. Jeśli pole to ma wartość zerową, to funkcja automatycznego tworzenia kopii zapasowej będzie wyłączona. Kopię zapasową można wykonać „ręcznie" wybierając pozycję Zapisz kopię bazy danych użytkowników menu Narzędzia. Także w tym przypadku kopia jest zapisywana w miejscu określonym przez pole Folder. Jeśli pole Folder jest puste, to kopia jest zapisywana w domyślnym folderze kopii serwera SQL. Jeśli serwer SQL znajduje się na tym samym komputerze co aplikacja AsBase, to możliwy jest wybór foldera kopii poprzez użycie przycisku pola Folder. Jeśli serwer SQL znajduje się na zdalnym stanowisku, to nazwę folderu kopii należy wpisać do pola Folder.

Automatyczne usuwanie danych

Ta grupa pól pozwala określić sposób, w jaki zapisy z tabel będą automatycznie usuwane. Automatyczne usuwanie rekordów dotyczy tabel archiwum oraz historii ładowań receptur.

Pole Usuwaj dane starsze niż pozwala określić maksymalny czas po jakim rekordy zostaną usunięte z tablicy.

Pole Maksymalna ilość zapisów w tabeli pozwala ograniczyć maksymalną wielkość tabel. Jeśli podana ilość rekordów zostanie przekroczona, to najstarsze rekordy zostaną usunięte.

Okno ustawień bazy danych może zostać wykorzystane do przenoszenia bazy danych pomiędzy serwerami. Jeśli pole Nazwa bazy danych zawiera nieistniejącą jeszcze bazę, to AsBase zapyta użytkownika, czy taką bazę należy utworzyć, czy też odczytać z pliku. W tym ostatnim przypadku można wskazać uprzednio zapisany plik kopii bazy danych.


Panel definiowana grup receptur

4.6.7. Panel definiowana grup receptur

Panel definiowana grup receptur służy do tworzenia i edycji grup receptur.

Rysunek: Panel definiowania grup receptur.

Tabela główna pozwala na edycję identyfikatorów, nazw i opisów grup receptur.

Tabele szczegółów służą do definiowania pól grupy receptur. Znacznie parametrów dostępnych w tabeli pól jest opisane w 4.6.9 Panel definiowania pól grupy receptur.


Panel_definiowania_zestawow_rejestracji

4.6.8. Panel definiowania zestawów rejestracji

Tabela główna pozwala na edycję identyfikatorów, nazw i opisów zestawów rejestracji.

Tabele szczegółów służą do definiowania pól zestawu rejestracji. Znacznie parametrów dostępnych w tabeli pól jest opisane w 4.6.10. Panel definiowania pol zestawu rejestracji.

Rysunek: Panel definiowania zestawów rejestracji.


Panel definiowania pol grupy receptur

4.6.9. Panel definiowania pól grupy receptur

Panel definiowana grupy receptur służy do kompleksowej parametryzacji pojedynczej grupy receptur.

Dostępne są dwa widoki parametryzacji. Pierwszy służy do edycji pól. Drugi służy do edycji zestawów zmiennych danej grupy receptur.

Widok 1 &endash; edycja pól

Rysunek: Okno parametryzacji pojedynczej grupy receptur.

Znaczenie kolumn tabeli pól jest następujące:

Kolejność

W kolumnie podaje się numer kolejny pola w grupie. Pozwala to na uporządkowanie pól w wymaganym porządku. Zmiana kolejności polega na podaniu nowego numeru pola. AsBase automatycznie skoryguje wartości kolumny Kolejność dla pozostałych pól.

Identyfikator

Identyfikator pola.

Nazwa

Nazwa opisowa pola.

Opis

Opis pola.

Parametry

Pole służące do określenia typu pola oraz dodatkowych informacji związanych z konkretnym typem. Wejście w pole Parametry powoduje otwarcie poniższego okna:

Rysunek: Okno parametryzacji pola 'Parametry' w definicji grupy receptur.

Dostępne są następujące typy pól:

Całkowity &endash; Liczba całkowita

Dla pól typu całkowitego można zadeklarować nazwę słownika służącego do tłumaczenia wartości numerycznych pola na teksty.

Zmiennoprzecinkowy &endash; Liczba zmiennoprzecinkowa

Dla pól zmiennoprzecinkowych można określić ilość miejsc dziesiętnych o raz format. Parametry te są wykorzystywane w czasie wyświetlania tabel.

Tekst &endash; Pole tekstowe

Dla pól tekstowych należy określić dodatkowo długość pola.

Data &endash; Pole w formacie daty i czasu

Pole daty wymaga określenia sposobu interpretacji danych procesowych. Podstawowym trybem jest wymiana przez zmienne tekstowe. W tym przypadku, w oknie parametrów podaje się sposób formatowania daty i czasu dla wymiany danych. Możliwa jest też wymiana poprzez zmienne liczbowe jako ilość sekund od 01-01-1970 (wg standardu IEC61131 &endash; DATE_AND_TIME).

Czas trwania &endash; Pole w formacie liczby całkowitej określającej czas w milisekundach.

Jeśli wymiana danych odbywa się poprzez zmienne tekstowe, to pole czasu trwania wymaga określenia sposób formatowania czasu trwania dla wymiany danych. Możliwa jest też wymiana poprzez zmienne liczbowe, gdzie czas trwania jest wyrażony jako ilość milisekund (wg standardu IEC61131 &endash; TIME_OF_DAY).

%wsadu &endash; Liczba zmiennoprzecinkowa.

Pole to wykorzystywane jest do wyliczania wartości pól w recepturach przeliczanych. Zdefiniowana w recepturze wartość określa jaki procent wartości pola WSAD zostanie wyliczony podczas ładowania receptury. W ramach definicji receptury suma pól o typie zadeklarowanym jako % wsadu nie może przekraczać wartości 100%.

Widok 2 &endash; zestawy zmiennych

Drugi widok panelu pozwala na definiowanie zestawów zmiennych związanych z grupą receptur.

Rysunek: Okno definicji zestawów zmiennych związanych z grupą receptur.

Tabela główna pozwala na edycję identyfikatorów, nazw i opisów zestawów zmiennych.

Tabele szczegółów służą do definiowania pól nazw zmiennych wchodzących w skład zestawu.

Kolumny Kolejność i Nazwa nie podlegają edycji. Ich wartości wynikają z definicji pól grupy receptur.


Panel definiowania pol zestawu rejestracji

4.6.10. Panel definiowania pól zestawu rejestracji

Panel definiowana zestawu rejestracji służy do kompleksowej parametryzacji pojedynczego zestawu rejestracji. Dostępne są dwa widoki parametryzacji. Pierwszy służy do edycji pól. Drugi służy do edycji zestawów zmiennych danego zestawu rejestracji.

Widok 1 – edycja pól

Rysunek: Okno parametryzacji pojedynczego zestawu rejestracji.

Znaczenie kolumn tabeli pól jest następujące:

Kolejność

W kolumnie podaje się numer kolejny pola w zestawie. Pozwala to na uporządkowanie pól w wymaganym porządku. Zmiana kolejności polega na podaniu nowego numeru pola. AsBase automatycznie skoryguje wartości kolumny Kolejność dla pozostałych pól.

Identyfikator

Identyfikator pola.

Nazwa

Nazwa opisowa pola.

Opis

Opis pola.

Parametry

Pole służące do określenia typu pola oraz dodatkowych informacji związanych z konkretnym typem. Wejście w pole Parametry powoduje otwarcie poniższego okna:

Rysunek: Okno parametryzacji pola 'Parametry' w definicji grupy receptur.

Dostępne są następujące typy pól:

Całkowity – Liczba całkowita

Dla pól typu całkowitego można zadeklarować nazwę słownika służącego do tłumaczenia wartości numerycznych pola na teksty.

Zmiennoprzecinkowy – Liczba zmiennoprzecinkowa

Dla pól zmiennoprzecinkowych można określić ilość miejsc dziesiętnych o raz format. Parametry te są wykorzystywane w czasie wyświetlania tabel.

Tekst – Pole tekstowe

Dla pól tekstowych należy określić dodatkowo długość pola.

Data – Pole w formacie daty i czasu

Pole daty wymaga określenia sposobu interpretacji danych procesowych. Podstawowym trybem jest wymiana przez zmienne tekstowe. W tym przypadku, w oknie parametrów podaje się sposób formatowania daty i czasu dla wymiany danych. Możliwa jest też wymiana poprzez zmienne liczbowe jako ilość sekund od 01-01-1970 (wg standardu IEC61131 – DATE_AND_TIME).

Czas trwania – Pole w formacie liczby całkowitej określającej czas w milisekundach.

Jeśli wymiana danych odbywa się poprzez zmienne tekstowe, to pole czasu trwania wymaga określenia sposób formatowania czasu trwania dla wymiany danych. Możliwa jest też wymiana poprzez zmienne liczbowe, gdzie czas trwania jest wyrażony jako ilość milisekund (wg standardu IEC61131 – TIME_OF_DAY).

Edycja - Parametr decyduje o tym, czy pole archiwum zestawu rejestracji będzie mogło być edytowane przez użytkownika z uprawnieniem Ograniczona edycja archiwum. Parametr ustawiony na TAK zezwala na edycję pola przez użytkowników z uprawnieniami zarówno do pełnej jak i ograniczonej edycji archiwum. Ustawienie parametru na NIE zezwala na edytowanie pola wyłącznie przez użytkowników z uprawnieniem Pełna edycja archiwum. Patrz: 3.1. Pełna kontrola uprawnień.

Ze statusem - Parametr określa, czy pole wartości zmiennej w zestawie archiwizacji jest rejestrowane łącznie ze statusem. Domyślnie parametr przyjmuje wartość NIE dla nowych aplikacji, a TAK dla aplikacji konwertowanych ze starszej wersji.

Z czasem - Parametr określa, czy pole wartości zmiennej w zestawie archiwizacji jest rejestrowane łącznie z czasem. Domyślnie parametr przyjmuje wartość NIE dla nowych aplikacji, a TAK dla aplikacji konwertowanych ze starszej wersji.

Widok 2 – zestawy zmiennych

Drugi widok panelu pozwala na definiowanie zestawów zmiennych związanych z zestawem rejestracji.

Rysunek: Okno definicji zestawów zmiennych związanych z zestawem rejestracji.

Tabela główna pozwala na edycję identyfikatorów, nazw i opisów zestawów zmiennych.

Tabele szczegółów służą do definiowania pól nazw zmiennych wchodzących w skład zestawu.

Kolumny Kolejność i Nazwa nie podlegają edycji. Ich wartości wynikają z definicji pól zestawu rejestracji.


Panel definiowania zestawu

4.6.11. Panel edycji zestawu zmiennych

Panel definiowania zestawu zmiennych służy do edycji zestawu zmiennych związanego z zestawem rejestracji lub grupą receptur nadrzędnego węzła.

Rysunek: Panel edycji zestawu zmiennych.

Tabela zestawu zmiennych pozwala na edycję wyłącznie nazwy zmiennych wchodzących w skład zestawu. Kolumny Kolejność i Nazwa nie podlegają edycji. Ich wartości wynikają z definicji pól zestawu rejestracji lub grupy receptur, z którą zestaw zmiennych jest związany.


Panel warunków rejestracji

4.6.12. Panel warunków rejestracji

Panel warunków rejestracji służy do definiowania warunków rejestracji używanych do automatycznej archiwizacji zestawów rejestracji. W czasie pracy z włączoną wymianą danych, AsBase sprawdza wszystkie zdefiniowane warunki i w przypadku ich spełnienia zapisuje aktualne wartości zmiennych procesowych w archiwum.

Rysunek: Panel warunków rejestracji.

Panel warunków składa się z dwóch części. W górnej, znajduje się tabela nawigacyjna pokazująca nazwy wszystkich zdefiniowanych warunków wraz z identyfikatorami zestawu rejestracji i zestawu zmiennych, których warunek dotyczy. W dolnej części znajduje się grupa pól edycyjnych służących do określenia wszystkich parametrów warunku rejestracji wybranego w tabeli nawigacyjnej.

Znaczenie pól edycyjnych jest następujące:

Opis

Opisowa nazwa warunku rejestracji

Zestaw archiwizacji

Identyfikator zestawu rejestracji, do którego będą wykonywane zapisu w przypadku spełnienia warunku.

Zestaw zmiennych

Identyfikator zestawu zmiennych, z którego będą pochodziły zapisywane wartości.

Synchronizacja czasowa

Pole wyboru włączające sprawdzanie warunku uzależnionego czasowo.

Okres

Okres zapisu rekordów do zestawów rejestracji. Jeżeli okres jest równy 0:00, to rekord zapisywany jest raz na dobę o godzinie podanej w polu „Start".

Start

Początkowa godzina zapisu. Na przykład: jeżeli pole „Start" jest równe 0:15, a okres zapisu jest równy 1 godzina, to zapis jest wykonywany o godzinach 0:15, 1:15, 2:15 itd.

Dzień

Wybór dnia, w którym ma być wykonywany zapis. Ustawienie trybu „Codziennie" wyłącza sprawdzanie dnia.

Synchronizacja wartością

Pole wyboru włączające sprawdzanie warunku uzależnionego od wartości zmiennej.

Testuj wartość

Pole wyboru włączające sprawdzanie warunku polegające na testowaniu wartości zmiennej kontrolnej.

Nazwa zmiennej

Nazwa zmiennej kontrolnej.

Rodzaj porównania

Wybór rodzaju porównania. Dostępne są tryby porównania wielkości wartości:

  • Mniejsza;

  • Mniejsza lub równa;

  • Większa;

  • Większa lub równa;

  • Równa.

i tryby porównania bitowego:

  • Równa - układ bitów w zmiennej kontrolnej musi dawać dokładnie wskazaną wartość porównania (pozostałe bity ustawione na zero);

  • Dowolny bit - pośród bitów wskazanych (wymaskowanych) przez wartość porównania dowolny z nich (przynajmniej jeden bit) musi przyjmować wartość 1;

  • Wszystkie bity - wszystkie bity wskazane (wymaskowane) przez wartość porównania muszą przyjmować wartość 1.

Wartość porównania

Wartość, do której będzie porównywana wartość zmiennej kontrolnej. Wartość porównania może być:

  • wartością liczbową;

  • nazwą zmiennej porównania (zawartość pola rozpoczęta znakiem @); w tym przypadku porównywane są wartości zmiennej kontrolnej i zmiennej porównania;

  • wartością atrybutu zmiennej kontrolnej (zawartość pola rozpoczęta znakiem #).

Wartość porównania w dwóch ostatnich z wymienionych przypadków pobierana jest z bazy definicji zmiennych.

Wartość zerująca

W polu opcjonalnie podaje się wartość, która ma być wysłana pod adres zmiennej kontrolnej, gdy zostanie wykonany zapis rekordu. Służy to zapewnieniu synchronizacji ze sterownikiem procesu przemysłowego, z którym AsBase komunikuje się w kwestii rejestracji zestawu rejestracyjnego.

Typ synchronizacji

Pole to określa moment, w którym następuje zapis archiwizowanych wartości, po tym jak został wykryty warunek archiwizacji. Pole może mieć jedną z następujących wartości:

  • „archiwizuj aktualnie dostępne wartości" – wartości zmiennych zestawu rejestracji są archiwizowane natychmiast po wykryciu warunku archiwizacji; jest to domyślny typ synchronizacji; wybór tego typu może spowodować, że w archiwum zostaną zapisane wartości odczytane z urządzeń przed wystąpieniem warunku archiwizacji;

  • „oczekuj na dane bieżące" – po wykryciu warunku archiwizacji AsBase będzie oczekiwał na otrzymanie wartości pomiarowych, których czasy odczytu są równe lub późniejsze w stosunku do czasu odczytu wartości zmiennej kontrolnej. Wybór tego typu synchronizacji może spowodować znaczne opóźnienie zapisu do archiwum, jeżeli zestaw zmiennych zawiera zmienne o długim okresie odświeżania;

  • „wymuś odczyt danych bieżących" – po wykryciu warunku archiwizacji AsBase wymusza fizyczny odczyt danych z urządzeń pomiarowych. Należy zwrócić uwagę na to, że fizyczny odczyt może być długotrwały i może spowodować opóźnienia w pracy AsBase - w tym opóźnienie archiwizacji innych warunków rejestracji.

Jeżeli stosowany jest tryb czasowy i porównania wartości, to sposób postępowania jest następujący: sprawdzany jest warunek czasowy i jeżeli jest on spełniony, to wykonywany jest test wartości.


Panel automatycznych

4.6.13. Panel automatycznych receptur

Panel automatycznych receptur służy do definiowania parametrów powodujących podczas pracy z włączoną wymianą danych, automatyczne ładowanie receptur w reakcji na zmiany wartości zmiennych synchronizujących.

Rysunek: Panel automatycznych receptur.

Panel składa się z dwóch części. W górnej, znajduje się tabela nawigacyjna pokazująca nazwy wszystkich zdefiniowanych automatycznych receptur wraz z identyfikatorami grupy receptur i zestawu zmiennych, które są używane w operacji ładowania. W dolnej części znajduje się grupa pól edycyjnych służących do określenia wszystkich parametrów automatycznej receptury wybranej w tabeli nawigacyjnej.

Znaczenie pól edycyjnych jest następujące:

Opis

Opisowa nazwa automatycznej receptury.

Grupa receptur

Identyfikator grupy receptur, dla której będą wykonywane operacje ładowania.

Zestaw zmiennych

Identyfikator zestawu zmiennych, do którego będą ładowane wartości receptury.

Nazwa zmiennej

Nazwa zmiennej kontrolnej. Zmiany wartości tej zmiennej powodują wyszukiwanie zgodnej receptury i w przypadku znalezienia takiej receptury, załadowanie jej do zestawu zmiennych.

Pole synchronizacji

Nazwa pola grupy receptur, którego zawartość jest porównywana z wartością zmiennej synchronizującej w procesie uzgadniania receptury, która ma zostać załadowana.

Synchronizuj nazwą receptury

Pole wyboru, którego zaznaczenie powoduje, że wybór receptury do załadowania odbywa się na podstawie nazw receptur.


Panel archiwum zestawu rejestracji

4.6.17. Panel archiwum zestawu rejestracji

Panel archiwum zestawu rejestracji służy do przeglądania i analizy zebranych danych dla pojedynczego zestawu rejestracji. Użytkownik o odpowiednich uprawnieniach może uzupełniać i modyfikować zebrane dane.

Rysunek: Panel archiwum zestawu rejestracji.

W tabeli archiwum znajduje się kolumna czasu zarejestrowania wartości, kolumna zbiorczej jakości danych, kolumny dotyczące wielkości wsadu oraz kolumny wartości dla wszystkich zdefiniowanych pól zestawu rejestracji. Opcjonalnie można włączyć (przy pomocy komendy Wybór pól menu kontekstowego tabeli) kolumnę czasu zapisu przeliczonego na czas UTC, kolumnę zestawu zmiennych (z którego pochodzą dane) oraz kolumny indywidualnego czasu i jakości dla wszystkich pól zestawu.

Interpretacja wartości kolumn jakości jest wykonywana zgodnie z konwencją statusów OPC. AsBase wykonuje translacje wartości numerycznych na odpowiadające im teksty. Zbiorczy status jakości jest równy OK (192) tylko wtedy, gdy indywidualna jakość wszystkich pól zestawu jest również OK.


4.7. Obsługa receptur przeliczalnych

Podczas definiowania grupy receptur przeliczalnych dostępny jest parametr Rejestruj %. Zaznaczenie tego parametru umożliwi zapis nieprzeliczonych wartości procentowych pól receptury do tabeli historii ładowań danej receptury - w przeciwnym razie będą pamiętany wyłączne przeliczone wartości pól receptury.

Rys. Definicja grupy receptur przeliczalnych.

Pola receptury, których wartość ma być automatycznie wyliczana w momencie ładowania receptury, należy zdefiniować jako % wsadu.

Podczas definiowania wartości pól procentowych receptury prowadzona jest kontrola - czy nie została przekroczona wartość 100% dla wszystkich pól przeliczalnych w ramach danej receptury. Wartość mniejsza jest dozwolona.

Rys. Definicja pól receptury przeliczalnej.

Dopuszczalne jest definiowanie receptury mieszanej, w której wartości niektórych pól wyliczane są procentowo na podstawie wsadu, natomiast pozostałe pola posiadają z góry zadeklarowaną wartość.

Obliczanie wartości pól (składowych receptury) następuje w momencie jej ładowania w panelu zarządzania recepturami na podstawie wielkości wsadu (pole Wsad). Wypełnienie pola Wsad dla receptur przeliczalnych jest obligatoryjne, dla pozostałych receptur pole to jest dostępne, ale nie ma żadnego znaczenia. Przeliczenie wartości pól w aplikacji AsBase'a dla receptur przeliczalnych następuje po naciśnięciu przycisku Załaduj recepturę oraz potwierdzeniu wysłania receptury do zestawu zmiennych.

Rys. Ładowanie receptury przeliczalnej.

Podczas ładowania receptury przeliczalnej za pomocą akcji operatorskiej systemu asix:

ASBASE, NAWIGUJ,[identyfikator_połaczenia]\download\[zestaw_zmiennych]

należy zapewnić, aby w ramach danego zestawu zmiennych ustawiana była wartość wsadu, na podstawie której zostaną wyliczone wartości pozostałych zmiennych. W praktyce: rozwiązaniem jest umieszczenie na masce synoptycznej aplikacji asixa obiektu LICZBA (podpiętego do zmiennej pola WSAD ładowanej receptury) z możliwością wpisu do niego wartości wsadu.

Rys. Dostęp do definicji pola WSAD receptury.


4.8. Obsługa relacji między danymi

4.8. Obsługa relacji pomiędzy danymi

Od wersji 6.1 pakietu asix istnieje możliwość deklarowania powiązań (relacji) pomiędzy danymi rejestrowanymi w bazie danych AsBase - dotyczy to zestawów rejestracji jak i receptur.

Dostępne mechanizmy pozwalają na tworzenie następujących rodzajów relacji:

1. Rekord nadrzędny (master) pochodzi z tablicy ładowań receptur a rekordy podrzędne (details) pochodzą z archiwum zestawu rejestracji. Polem nadrzędnym relacji jest identyfikator załadowania receptury, natomiast polem podrzędnym (details) może być dowolnie wybrane pole zestawu rejestracji. Użytkownik może zobaczyć relację rozwijając wybrany rekord w historii ładowań receptur.

2. Rekord nadrzędny (master) oraz rekordy podrzędne (details) pochodzą z zestawu rejestracji. Polem nadrzędnym (master) relacji oraz polem podrzędnym (details) może być dowolnie wybrane pole w każdym zestawie rejestracji. (Użytkownik może zobaczyć relację rozwijając wybrany rekord w archiwum zestawu rejestracji).

3. Rekord nadrzędny (master) pochodzi z archiwum zestawu rejestracji a rekord podrzędny (jeden) z historii ładowań receptury. (Użytkownik może zobaczyć relację rozwijając wybrany rekord w archiwum zestawu rejestracji).

Powiązania (relacje) pomiędzy danymi tworzone są w zależności od potrzeby w następujący sposób:

1. Ad. relacji pomiędzy tablicą historii ładowań receptur a archiwum zestawu rejestracji

W przypadku relacji pomiędzy tablicą historii ładowań receptur a archiwum zestawu rejestracji do łączenia zawsze wykorzystywany jest unikalny identyfikator załadowania receptury oraz dowolne pole podrzędne (detail) z zestawu rejestracji. Połączenie definiujemy na etapie definiowania grup receptur na zakładce Relacje:

AsBase => Konfiguracja => Grupy receptur => <nazwa zdefiniowanej grupy receptur> => zakładka Relacje

W polu Archiwum należy określić zestaw rejestracji.

W polu Pole należy określić pole, które posłuży do połączenia.

Unikalny identyfikator ładowania receptury można odczytać przez zmienną Asmena przypisaną do ukrytego pola w rekordzie receptury. Tą samą zmienną należy podpiąć do pola podrzędnego (detail) z zestawu rejestracji.

Poniżej przykład powiązania pomiędzy recepturą mycia linii produkcyjnej a zestawem parametrów rejestrowanych na poszczególnych fazach mycia linii. Przeglądanie relacji - patrz: Wizualizacja relacji.

Rys. Definiowanie relacji pomiędzy tablicą historii ładowań receptur a archiwum zestawu rejestracji.

Rys. Deklaracja zmiennej dla ID ładowania receptury.

Rys. Deklaracja zmiennej dla pola podrzędnego (Detail) z zestawu rejestracji.

2. Ad. relacji pomiędzy zestawami rejestracji

W przypadku zestawów rejestracji - każde pole zestawu może być polem nadrzędnym (master), dlatego istnieje możliwość definiowania relacji dla każdego pola osobno. W tym celu wiersz definicji pola zawiera kolumny: Unikalne i Relacje.

Kolumna Unikalny zawiera checkbox określający unikalność pola.

Kolumna Relacje daje możliwość utworzenia połączenia z polem podrzędnym (detail) z innego zestawu rejestracji. Połączenie to definiowane jest jako tekst: nazwa_archiwum(nazwa_pola_podrzędnego). Dla ułatwienia, kliknięcie w komórce kolumny Relacje uruchamia edytor z dostępem do zdefiniowanych zestawów rejestracji oraz ich pól (pola edytora: Archiwum oraz Pole).

W celu zapewnienia odpowiedniego typu relacji pomiędzy tabelami zestawów rejestracji należy odpowiednio oznaczyć pola łączące tabele jako unikalne:

- dla relacji 1:n - jeden wiersz z tabeli nadrzędnej (master) powiązany jest z n wierszami z tabeli podrzędnej (details); w takiej sytuacji pole wykorzystywane do połączenia tabel po stronie tabeli nadrzędnej musi być oznaczone jako unikalne.

- dla relacji 1:1 - jeden wiersz z tabeli nadrzędnej (master) powiązany jest z jednym wierszem z tabeli podrzędnej (detail); w takiej sytuacji zarówno w tabeli nadrzędnej jak i podrzędnej pola służące do określenia powiązania (relacji) muszą posiadać wartości unikalne.

Rys. Przykład deklaracji relacji 1:n pomiędzy zestawami rejestracji.

Wizualizacja relacji

Przeglądanie danych relacyjnych w układzie hierarchicznym polega na wyświetleniu w jednej tabeli wierszy tabeli nadrzędnej (master) razem z powiązanymi z nimi wierszami tabeli podrzędnej (details).

Aby uzyskać taki widok - należy przejść do tabeli nadrzędnej (historia ładowań receptur lub archiwum zestawu rejestracji) i wybrać komendę Pokaż szczegóły z menu Widok > Tabele.

Rys. Wizualizacja relacji w układzie hierarchicznym - master: historia ładowania receptur; details: archiwum zestawu rejestracji.

Rys. Wizualizacja relacji w układzie hierarchicznym - master: archiwum zestawu rejestracji; detail: archiwum zestawu rejestracji.

W celu poprawnego zdefiniowania odwołania do tabel relacyjnych należy odpowiednio skonfigurować obiekt AsBase. Po nadaniu nazwy i identyfikatora obiektu należy zdefiniować typ danych źródłowych tabeli nadrzędnej (historia ładowań receptur lub zestaw rejestracji). Następnie jako źródło danych nadrzędnych należy wskazać grupę receptur lub zestaw rejestracji i powiązany z nimi zestaw zmiennych. Podobnie należy wskazać źródło danych podrzędnych (zestaw rejestracji) i powiązany z nim zestaw zmiennych.

Rysunek: Parametryzacja obiektu AsBase.

Przeglądanie danych relacyjnych powoduje jednoczesny odczyt danych zarówno z tabeli nadrzędnej jak i podrzędnej. Przeglądanie danych relacyjnych prezentuje poniższy rysunek.

Rysunek: Nawigacja po rekordach danych relacyjnych.

W celu poprawnego zdefiniowania filtrowania lub sortowania danych w czasie odwołań do tabel relacyjnych należy odpowiednio oznaczyć kolumny, których dotyczą poszczególne warunki sortowania lub filtrowania.

Dla pól (kolumn) pochodzących z tabeli nadrzędnej (master) stosujemy przedrostek "m”.

Dla pól (kolumn) pochodzących z tabeli podrzędnej (detail) stosujemy przedrostek "d”.

Rys. Przykład filtru.

- m.ID>1 - filtruje dane dla tabeli nadrzędnej (master); dotyczy wierszy o wartości pola 'ID' większej od 1

- order by d.ID, m.V_privNAZWA - sortuje dane według pola 'ID' z tabeli podrzędnej (detail), a następnie według wartości pola 'privNazwa' z tabeli nadrzędnej (master)


4.9. Eksport rekordu do pliku XML

W aplikacji AsBase za pośrednictwem menu Narzędzia > Eksportuj rekord do pliku XML możliwe jest zapisanie wybranego rekordu z rejestru receptur do pliku tekstowego w formacie XML.

Dla danych powiązanych relacją:

W ramach eksportu rekordu tabeli nadrzędnej eksportowane są automatycznie wszystkie powiązane rekordy z tabeli podrzędnej.


WAŻNE - przed przystąpieniem do ćwiczeń

5.1. WAŻNE - przed przystąpieniem do części praktycznej

Praktyczne zadania związane z wykorzystaniem modułu AsBase do obsługi receptur i zestawów rejestracji - zaprezentowane w części "5. Obsługa programu w praktyce - podstawowy poziom obsługi AsBase" - wymagają testowej aplikacji AsBase'owej 'AsBase - DEMO działania programu AsBase' działającej we współpracy z rozszerzoną wersją aplikacji asixa o nazwie 'Fabryka'. Prezentację przygotowano na bazie systemu asix wersji 5.

Rozszerzona wersja aplikacji 'Fabryka' ze wszystkimi plikami gotowej aplikacji modułu AsBase dostępna jest w postaci zzipowanego katalogu 'Fabryka_z_AsBase' pod poniższym adresem:

http://downloads.askom.com.pl/download/pl/Fabryka_z_AsBase.zip (47,8 MB)

W prezentacji katalog 'Fabryka_z_AsBase' został umieszczony na dysku D:\ - stąd wszystkie ścieżki odwołań do plików aplikacji zaczynają się od 'D:\Fabryka_z_AsBase\...'. Z tego powodu przed przystąpieniem do samodzielnej realizacji praktycznych zadań demonstrowanych w prezentacji zaleca się dla zachowania spójności umieszczenie katalogu 'Fabryka_z_AsBase' na dysku D:\.

Uruchomienie tej wersji aplikacji 'Fabryka' spowoduje jednoczesne uruchomienie sprzężonego modułu AsBase - jednakże dopiero po odtworzeniu bazy danych aplikacji AsBase (co zostało omówione w rozdziale 5.2.3.1. Odtwarzanie / przenoszenie gotowej bazy danych) możliwa będzie prawidłowa praca tej aplikacji.


instalowanie_silnika_bazy_sql

5.2.1. Instalowanie silnika bazy SQLExpress 2005

Instalator SQLExpress 2005 dołączany jest do płyty instalacyjnej pakietu asix. Zawiera on Microsoft SQL Server Management Studio Express - bezpłatny dodatek do serwera, który stanowi graficzną nakładkę dla wbudowanych narzędzi konfiguracyjnych (umożliwia wygodne zarządzanie bazami danych, a w szczególności ich tworzenie, modyfikację przechowywanych obiektów, wykonywanie zapytań oraz kopii zapasowych).

Poniżej znajduje się opis kroków, jakie należy wykonać w celu zainstalowania serwera MS SQLExpress 2005.

1. Uruchom instalatora SQLExpress 2005 z płyty instalacyjnej pakietu asix.

2. Określ język okien dialogowych instalatora. Zatwierdź wybór przyciskiem OK.

3. Wskaż lokalizację docelową plików SQLExpress2005 i kliknij przycisk Dalej.

4. Wybierz instalowane komponenty. Kliknij przycisk Dalej.

5. Podaj parametry instalacji serwera SQL (nazwa instancji, hasło administratora). Kliknij przycisk Dalej.

6. Po wykonaniu powyższych czynności i ponownym kliknięciu przycisku Dalej zostaną uruchomione instalatory wybranych komponentów.

7. Jeśli wybrany został program MS SQL Server Management Studio Express, zostanie dodatkowo uruchomiony instalator tego komponentu wyświetlający dodatkowe okna dialogowe wymagające zatwierdzenia przez użytkownika, m.in. instalator będzie wymagał podania nazwy i nazwy firmy użytkownika. Po zakończeniu instalacji MS SQL Server Management Studio Express zostanie wyświetlone okno z informacją o konieczności zrestartowania komputera. Wówczas wybierz opcję późniejszego ręcznego restartu systemu - spowoduje to powrót do głównego instalatora SQLExpress 2005.

8. Na zakończenie powinno wyświetlić się okno z informacją o pomyślnie przeprowadzonej instalacji. Po wciśnięciu przycisku Zakończ pojawi się jeszcze jedno okno sugerujące zrestartowanie systemu w celu dokończenia instalacji – należy wówczas przycisnąć przycisk OK.

Instalowanie silnika bazy SQLExpress 2005 - instrukcja demo >>

rozdzielczość: 1113x885 px

czas prezentacji: 2 min 43 sek


Pierwsze uruchomienie modułu AsBase - wybór trybu pracy

5.2.2. Pierwsze uruchomienie modułu AsBase - wybór trybu pracy

Przy pierwszym uruchomieniu programu AsBase zostaniesz zobligowany do dokonania wyboru trybu pracy modułu AsBase. Z uwagi na możliwość tworzenia lub przeparametryzowania aplikacji AsBase, wybierz tryb administracyjny.

Rysunek: Okno wyboru trybu pracy (administracyjny/ograniczony) modułu AsBase.

Na tym etapie uruchamiania programu istnieje możliwość wyboru jednego z dwóch wariantów anonimowego trybu pracy:

Administracyjny – użytkownik ma dostęp do wszystkich funkcji programu;

Ograniczony – użytkownik może obsługiwać aplikacje AsBase utworzone na innym stanowisku, nie może tworzyć nowych aplikacji.

Wybranie trybu pracy ograniczonego jest nieodwracalne – zmiana tego trybu pracy możliwa jest po przeprowadzeniu reinstalacji programu.

Administrator anonimowy posiada pełne uprawnienia administracyjne obejmujące m.in. tworzenie nowej aplikacji, edycję i ładowanie receptur, edycję i zapis archiwum, a także możliwość załączania i zatrzymywania wymiany zmiennych (komenda służąca do włączania i wyłączania automatycznej archiwizacji i automatycznych receptur). Patrz: 3.2. Tryb anonimowy.

Pełna kontrola uprawnień do obsługi modułu AsBase ujawnia się w momencie załadowania konkretnej aplikacji AsBase, która ma skonfgurowanych użytkowników ze wskazaniem ich uprawnień do wykonywania poszczególnych operacji. Patrz: 3.1. Pełna kontrola uprawnień.

Pierwsze uruchomienie modułu AsBase - wybór trybu pracy - instrukcja demo >>

rozdzielczość: 1113x885 px

czas prezentacji: 56 sek


Odtwarzanie / przenoszenie gotowej bazy danych

5.2.3.1. Odtwarzanie / przenoszenie gotowej bazy danych

Odtwarzanie bazy danych z pliku kopii

Deklaracja źródła pozyskiwania danych procesowych

Parametry tworzenia kopii bazy

a. Odtwarzanie bazy danych z pliku kopii

Odtworzenie bazy danych gotowej aplikacji AsBase oznacza odtworzenie na wskazanym serwerze SQL bazy z pliku kopii, z zachowaniem wszystkich parametrów konfigurujących tę aplikację.

Odtwórz bazę danych gotowej aplikacji modułu AsBase 'AsBase - DEMO działania programu AsBase' działającej we współpracy z aplikacją asixa o nazwie 'Fabryka'.

Aplikacja 'Fabryka' ze wszystkimi plikami gotowej aplikacji modułu AsBase dostępna jest w postaci zzipowanego katalogu 'Fabryka_z_AsBase' pod poniższym adresem:

http://downloads.askom.com.pl/download/pl/Fabryka_z_AsBase.zip (47,8 MB)

W prezentacji katalog 'Fabryka_z_AsBase' został umieszczony na dysku D:\ - stąd wszystkie ścieżki odwołań do plików aplikacji zaczynają się od 'D:\Fabryka_z_AsBase\...'.

Z tego powodu przed przystąpieniem do samodzielnej realizacji praktycznych zadań demonstrowanych w prezentacji zaleca się dla zachowania spójności umieszczenie katalogu 'Fabryka_z_AsBase' na dysku D:\.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

Zostanie wyświetlony komunikat z informacją o błędzie w odczycie bazy danych (w deklaracji bazy znajdują się ustawienia dotyczące dostępu do bazy obowiązujące na komputerze, na którym dotychczas aplikacja pracowała). Należy komunikat zignorować klikając przycisk OK.

3. Wybierając przycisk Ustawienia bazy danych skonfiguruj poprawne ustawienia bazy SQL:

Nazwa serwera: <podaj swoją nazwę serwera SQL>

Nazwa bazy danych: Fabryka

Tryb autoryzacji: Windows NT

Rysunek: Okno ustawień bazy danych SQL.

4. Po zatwierdzeniu przyciskiem OK wprowadzonych zmian zostanie wyświetlone okno parametrów utworzenia bazy danych SQL, wymagające określenia pliku kopii bazy danych oraz katalogu, w którym zostanie utworzona baza danych AsBase.

Wskaż lokalizację do pliku kopii bazy ‘_asbase_Fabryka 2009-05-28 150615.bk’ i katalogu ‘ASBASE’, zatwierdzając wybór przyciskiem OK:

Plik kopii bazy danych: D:\Fabryka_z_AsBase\ASBASE\BACKUP\_asbase_Fabryka 2009-05-28 150615.bk

Katalog bazy danych: D:\Fabryka_z_AsBase\ASBASE

Rysunek: Okno parametrów utworzenia bazy danych.

5. Jeśli baza utworzona została starszą wersją programu – zostanie wyświetlone okno z propozycją przekonwertowania bazy do aktualnej wersji modułu AsBase.

Rysunek: Okno komunikatu nt kopiowania bazy utworzonej w starszej wersji programu AsBase.

6. W przypadku kiedy aplikacja AsBase posiada zadeklarowanych użytkowników - w trakcie operacji odtwarzania bazy zostaniesz poproszony o zalogowanie się. Wpisz dane użytkownika posiadającego uprawnienia administracyjne:

Identyfikator użytkownika: mst

Hasło: <brak hasła>

Zalogowanie użytkownika umożliwi odtworzenie gotowej aplikacji AsBase (bazy i pliku konfiguracyjnego aplikacji) ze wskazanych plików kopii.

Rysunek: Okno logowania użytkownika aplikacji AsBase w trakcie odtwarzania bazy.

Rysunek: Widok panelu głównego odtworzonej aplikacji AsBase.

7. Po odtworzeniu bazy zapisz aktualne ustawienia.

Razem z bazą AsBase zostaną odtworzone wszystkie parametry aplikacji AsBase – w tym: globalne ustawienia aplikacji, dane użytkowników, receptur i zestawów rejestracji (także historia ładowań receptur, archiwum rejestracji zdarzeniowej oraz definicje warunków rejestracji i automatyczne receptury).

Dla prawidłowej pracy aplikacji AsBase konieczne jest jeszcze poprawne skonfigurowanie źródła pozyskiwania danych (zostanie to omówione w kolejnym rozdziale Deklaracja_zrodla_danych).

b. Deklaracja źródła pozyskiwania danych procesowych

Dla aplikacji AsBase odtworzonej w poprzednim punkcie Odtwarzanie bazy danych z pliku kopii określ źródło pozyskiwania danych procesowych. Wymaga to podania:

- bazy definicji zmiennych aplikacji asixa, z której pochodzą definicje zmiennych procesowych przetwarzanych przez moduł AsBase;

- serwera danych procesowych, z którego dane procesowe będą pozyskiwane oraz do którego będą wysyłane wartości receptur;

- komputera komunikacyjnego, który będzie archiwizował zestawy rejestracji oraz ładował automatyczne receptury.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik aplikacji ‘AaBase_Fabryka.XML’.

3. W panelu globalnych ustawień aplikacji AsBase określ wartości następujących pól:

- Baza zmiennych: D:\Fabryka_z_AsBase\BAZA\Baza_zmiennych.mdb

- Serwer danych procesowych: podaj nazwę sieciową komputera (zdefiniowaną w parametrach aplikacji asix), z którego pozyskiwane będą dane procesowe, oraz do którego będą wysyłane wartości receptur; w niniejszym przykładzie z założenia jest to komputer lokalny, na którym odtworzona została baza aplikacji AsBase – dlatego należy wpisać nazwę LOCAL.

- Komputer komunikacyjny: podaj nazwę systemową komputera, który będzie archiwizował zestawy rejestracji oraz ładował automatyczne receptury; w niniejszym przykładzie z założenia jest to komputer lokalny, na którym odtworzona została baza aplikacji AsBase.

Rysunek: Panel główny – parametry globalne aplikacji AsBase.

c. Parametry tworzenia kopii bazy

Kontynuując czynności wykonane w poprzednim punkcie, zadeklaruj folder, w którym przechowywane będą kopie bazy danych, tworzone co 1 godzinę, bez opcji automatycznego usuwania danych i ograniczeń w ilości zapisów w tabeli. Parametry tworzenia kopii zapasowej bazy danych modułu AsBase deklarowane są w Ustawieniach bazy danych, dostępnych w panelu globalnych ustawień aplikacji.

Aby ułatwić dostęp do kopii bazy danych tworzonej przez aplikację AsBase, należy w oknie ustawień bazy podać ścieżkę do dowolnego utworzonego przez siebie katalogu (jeśli pole Kopia bazy danych / Folder jest puste, to kopia jest zapisywana w domyślnym folderze kopii serwera SQL, który może być trudny do zlokalizowania).

Jeśli pole Kopia bazy danych / Twórz kopię co ma wartość zerową, to funkcja automatycznego tworzenia kopii zapasowej będzie wyłączona.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik aplikacji ‘AaBase_Fabryka.XML’.

2. Wybierając przycisk Ustawienia bazy danych skonfiguruj ustawienia bazy SQL:

Folder: D:\Fabryka_z_AsBase\ASBASE\BACKUP

Twórz kopię co: 1 godz

Usuwaj dane starsze niż: 0 dni

Maksymalna ilość zapisów w tabeli: 0

Rysunek: Parametry tworzenia kopii zapasowej.

Odtwarzanie / przenoszenie gotowej bazy danych - instrukcja demo >>

rozdzielczość: 1113x885

czas prezentacji: 3 min 45 sek


Tworzenie nowej pustej bazy danych

5.2.3.2. Tworzenie nowej pustej bazy danych

W przypadku tworzenia nowej bazy danych wymagane jest zadeklarowanie nazwy serwera i bazy danych oraz trybu autoryzacji, co sprowadza się do wykonania poniższych kroków:

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Wybierając przycisk Ustawienia bazy danych skonfiguruj ustawienia bazy SQL:

Nazwa serwera: <podaj swoją nazwę serwera SQL>

Nazwa bazy danych: <podaj swoją nazwę bazy>

Tryb autoryzacji: Windows NT

3. Zatwierdź ustawienia przyciskiem OK.

4. Zostanie wyświetlone okno parametrów utworzenia bazy danych SQL - pozostaw następujące domyślne parametry bez zmian:

Plik kopii bazy danych: "Nowa pusta baza danych"

Katalog bazy danych: "Domyślny katalog plików serwera SQL"

5. Zatwierdź ustawienia przyciskiem OK.

Zostanie utworzona nowa pusta baza danych - pozostałe elementy aplikacji AsBase (parametry aplikacji, parametry kopii bazy, receptury, zestawy rejestracji, itd.) wymagają zadeklarowania od podstaw.

Dalsza część praktycznych ćwiczeń będzie się opierać na bazie, która została odtworzona w poprzednim punkcie.

6. W panelu głównym AsBase wypełnij pole Opis aplikacji: 'Aplikacja_testowa'

7. Zapisz plik nowoutworzonej aplikacji AsBase pod nazwą: 'Aplikacja_testowa.XML'

Tworzenie nowej pustej bazy danych - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 1 min 43 sek


Deklarowanie użytkowników

5.2.4. Deklarowanie użytkowników

Zadeklaruj użytkownika modułu AsBase z uprawnieniami administratora.

1. Mając uruchomioną aplikację:

AsBase D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

login: mst

hasło: <brak hasła>

(Login i hasło użytkownika, z którym dostarczana jest testowa aplikacja AsBase )

w drzewie nawigacyjnym AsBase wybierz pozycję Konfiguracja > Użytkownicy

2. Przejdź do widoku ‘Karty’.

3. Kliknij przycisk Dodaj [image] i w kolejnych polach karty określ następujące dane:

Identyfikator: admin

Nazwa: administrator

Hasło: admin

Uprawnienia:

Administracja: tak

Edycja aplikacji: tak

Edycja receptur: tak

Ładowanie receptur: tak

Pełna edycja archiwum: tak

Ograniczona edycja archiwum: nie

Zapis archiwum: tak

Zmiana wyglądu: tak

4. Zatwierdź wprowadzone dane przyciskiem [image].

5. Zapisz zmiany w pliku xml aplikacji: polecenie Plik > Zapisz

Rysunek: Panel użytkowników – widok ‘Karty’.

Deklarowanie użytkowników - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 1 min 30 sek


Tworzenie grupy receptur

5.3.1. Tworzenie grupy receptur - definiowanie struktury receptur

W testowej aplikacji asixa ‘Fabryka’ funkcjonują 3 mieszalniki, w których kwas siarkowy zostaje zmieszany z wodą w proporcjach ustalonych w zadanej recepturze. Obsługa receptur realizowana jest dla powyższych mieszalników z użyciem modułu AsBase. Każdy z mieszalników posiada swój odrębny zestaw zmiennych, do których ładowane są wartości receptur. Struktura receptur jest identyczna dla wszystkich trzech mieszalników - tzn. na rekord każdej receptury składają się zawsze trzy pola: opis receptury, ilość wody, ilość kwasu siarkowego (plus dodatkowe pole Nazwa i pola systemowe: ID, Użytkownik, Czas).

W związku z powyższym należy zdefiniować jedną grupę receptur (inaczej strukturę receptur), którą w przykładzie nazwiemy 'Stężenia2', składającą się z następujących pól:

-‘Opis receptury’

-‘Kwas siarkowy’

-‘Woda’.

Ponieważ każdy mieszalnik obsługują inne zmienne - należy w ramach jednej wspólnej grupy receptur utworzyć 3 zestawy zmiennych, do których będą ładowane wartości receptur za pośrednictwem pól zdefiniowanych na poziomie grupy receptur.

Zmienne ładujące receptury do poszczególnych mieszalników są pogrupowane w następujących zestawach:

zestaw 'Mieszalnik 1':

Opis receptury – zmienna M1_R1

Kwas siarkowy – zmienna M1_1

Woda – zmeinna M1_2

zestaw 'Mieszalnik 2':

Opis receptury – zmienna M2_R2

Kwas siarkowy – zmienna M2_1

Woda – zmienna M2_2

zestaw 'Mieszalnik 3':

Opis receptury – zmienna M3_R3

Kwas siarkowy – zmienna M3_1

Woda – zmienna M3_2

Rysunek: Schemat powiązań pomiędzy elementami zdefiniowanymi w module AsBase w zakresie obsługi receptur.

Utwórz grupę receptur ‘Stężenia2’, w ramach której zdefiniuj pola, które posłużą do utworzenia receptur.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Grupy receptur.

5. Dodaj nowy rekord tabeli za pomocą przycisku [image], opisując go w następujący sposób:

Identyfikator: st2

Nazwa: Stężenia2

Opis: Stężenia kwasu siarkowego

Rysunek: Panel definiowania grup receptur.

6. Zapisz rekord przyciskiem [image].

Dla grupy receptur ‘Stężenia2’ zdefiniuj pola: ‘Opis receptury’, ‘Kwas siarkowy’ i ‘Woda’.

1. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Grupy receptur > Stężenia2 > zakładka Grupa receptur Stężenia2 - Pola

2. Za pomocą przycisku [image] dodaj nowy rekord tabeli definiujący pole ‘Opis receptury’. Opisz pole w nastepujący sposób:

Kolejność: 1

Identyfikator: opis_rec

Nazwa: Opis receptury

Opis: wartość procentowa roztworu kwasu siarkowego

Parametry: Tekst(30)

3. Zatwierdź wprowadzone dane przyciskiem [image].

4. W analogiczny sposób dodaj pola ‘Kwas siarkowy’ i ‘Woda’, opisując je w następujący sposób:

Kolejność: 2

Identyfikator: skl1

Nazwa: Kwas siarkowy

Opis: ilość kwasu siarkowego w %

Parametry: Całkowity

Kolejność: 3

Identyfikator: skl2

Nazwa: Woda

Opis: ilość wody w %

Parametry: Całkowity

5. Zapisz plik xml aplikacji AsBase: polecenie Plik > Zapisz

Rysunek: Panel definiowania pól dla grupy receptur.

Tworzenie grupy receptur / definiowanie struktury receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 3 min 4 sek


Definiowanie zestawów zmiennych dla grupy receptur

5.3.2. Definiowanie zestawów zmiennych powiązanych z polami grupy receptur

Każdy z trzech mieszalników aplikacji 'Fabryka' posiada odrębny zestaw zmiennych procesowych, do którego ładowane są receptury. Każdy taki zestaw wiąże pola definiujące recepturę z nazwami zmiennych procesowych, do których ładowane będą wartości nastaw receptur.

Zdefiniuj 3 zestawy zmiennych przypisanych do poszczególnych mieszalników: ‘Mieszalnik1’, ‘Mieszalnik2’ i ‘Mieszalnik3’.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Grupy receptur > Stężenia2 > zakładka Zestawy zmiennych.

5. Za pomocą przycisku [image] dodaj nowy rekord tabeli definiujący zestaw ‘Mieszalnik1’. Opisz zestaw w następujący sposób:

Identyfikator: z1

Nazwa: Mieszalnik1

Opis: zestaw zmiennych dla mieszalnika 1

6. Zatwierdź wprowadzone dane przyciskiem [image].

7. W analogiczny sposób dodaj zestawy ‘Mieszalnik2’ i ‘Mieszalnik3’, opisując je w następujący sposób:

Identyfikator: z2

Nazwa: Mieszalnik2

Opis: zestaw zmiennych dla mieszalnika 2

Identyfikator: z3

Nazwa: Mieszalnik3

Opis: zestaw zmiennych dla mieszalnika 3

8. Dla zestawu ‘Mieszalnik1’ zdefiniuj powiązania pomiędzy polami grupy receptur 'Stezenia2' i następującymi zmiennymi procesowymi:

Kolejność | Nazwa | Nazwa zmiennej
1 | Opis receptury | M1_R1
2 | Kwas siarkowy | M1_1
3 | Woda | M1_2

W tym celu przejdź do Konfiguracja > Grupy receptur > Stężenia2 > Mieszalnik1

Po dodaniu zmiennych zatwierdź wprowadzone dane przyciskiem [image].

9. W analogiczny sposób zdefiniuj powiązania pomiędzy polami grupy receptur ‘Stężenia2’ i zmiennymi procesowymi dla mieszalników 2 i 3.

‘Mieszalnik2’:

Kolejność | Nazwa | Nazwa zmiennej
1 | Opis receptury | M2_R2
2 | Kwas siarkowy | M2_1
3 | Woda | M2_2

‘Mieszalnik3’:

Kolejność | Nazwa | Nazwa zmiennej
1 | Opis receptury | M3_R3
2 | Kwas siarkowy | M3_1
3 | Woda | M3_2

10. Zapisz plik xml aplikacji AsBase: polecenie Plik > Zapisz

Rysunek: Panel definiowania zestawów zmiennych.

Definiowanie zestawów zmiennych powiązanych z polami grupy receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 3 min 58 sek


Tworzenie receptur

5.3.3. Tworzenie receptur

Dla grupy receptur ‘Stężenia2’ utwórz w kolejnych rekordach receptury przechowujące wartości nastaw.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Receptury > Stężenia2

5. Za pomocą przycisku [image] dodaj rekord receptury:

Nazwa: rec100

Opis receptury: roztwór o stężeniu 100%

Kwas siarkowy: 100

Woda: 0

6. Zatwierdź wprowadzone dane przyciskiem [image].

7. W analogiczny sposób dodaj rekordy następujących receptur:

Nazwa | Opis receptury | Kwas siarkowy | Woda
rec25 | roztwór o stężeniu 25% | 25 | 75
rec50 | roztwór o stężeniu 50% | 50 | 50
rec75 | roztwór o stężeniu 75% | 75 | 25
rec80 | roztwór o stężeniu 80% | 80 | 20

Rysunek: Panel definiowania receptur.

Tworzenie receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 2 min 14 sek


Ładowanie receptur

5.3.4. Ładowanie receptur

I sposób – selekcja zestawu zmiennych dla danej receptury

II sposób – selekcja receptury dla danego zestawu zmiennych

Do mieszalnika 1 załaduj recepturę, w wyniku której zostanie uzyskany roztwór kwasu siarkowego o stężeniu 75%.

I sposób – selekcja zestawu zmiennych dla danej receptury

1. Uruchom aplikację ’Fabryka’ dla komputera ‘StacjaSO1’.

(D:\Fabryka_z_AsBase\Fabryka_Prezentacja.xml)

Razem z aplikacją asixa zostanie również uruchomiony moduł AsBase z załadowanym plikiem konfiguracyjnym aplikacji AsBase

(D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML )

2. W drzewie nawigacyjnym okna AsBase wybierz pozycję Receptury > Stężenia2

3. Wybierz rekord z wartością nastaw dla receptury ‘rec75’.

4. W polu Zestaw zmiennych wybierz zestaw zmiennych dla mieszalnika 1: ‘Mieszalnik1’.

5. Kliknij przycisk Załaduj recepturę.

6. Potwierdź chęć wysłania receptury do mieszalnika 1.

Rysunek: Ładowanie receptury z poziomu okna AsBase’a – selekcja zestawu zmiennych.

II sposób – selekcja receptury dla danego zestawu zmiennych

1. Uruchom aplikację ’Fabryka’ dla komputera ‘StacjaSO1’.

(D:\Fabryka_z_AsBase\Fabryka_Prezentacja.xml)

Razem z aplikacją asixa zostanie również uruchomiony moduł AsBase z załadowanym plikiem konfiguracyjnym aplikacji AsBase

(D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML )

2. W drzewie nawigacyjnym okna AsBase wybierz pozycję Receptury > Stężenia2 > Mieszalnik1

3. W polu Nazwa receptury wybierz recepturę ‘rec75’.

4. Kliknij przycisk Załaduj recepturę.

5. Potwierdź chęć wysłania receptury do mieszalnika 1.

Rysunek: Ładowanie receptury z poziomu okna AsBase’a – selekcja nazwy receptury.

Ładowanie receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 1 min 58 sek


Przeglądanie historii ładowań receptur

5.3.6. Przeglądanie historii ładowań receptur

Historia ładowań receptur

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych

Historia ładowań receptur

Wyświetl archiwum wartości nastaw dostępne w tabeli historii ładowań.

1. W drzewie nawigacyjnym okna AsBase z załadowaną aplikacją (D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML - login: admin, hasło: admin) wybierz pozycję Receptury > Stężenia2 > Historia ładowań

Rysunek: Log historii ładowań.

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych użytkownik otrzymuje za pośrednictwem paneli (które m.in. umożliwiają ładowanie do zmiennych wartości wymaganych receptur). Z poziomu tych paneli można dokonać operacji ładowania receptur (o czym była mowa wcześniej) oraz rejestracji bieżących wartości zmiennych, wpływając tym samym na zmianę definicji receptur (w sytuacji, gdy wyświetlane wartości zmiennych odbiegają od wartości zarejestrowanych receptur).

1. W drzewie nawigacyjnym okna AsBase z załadowaną aplikacją (D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML) wybierz pozycję Receptury > Stężenia2 > Mieszalnik1

2. Z pola Nazwa receptury, znajdującego się poniżej zestawu zmiennych, wybierz pozycję ‘rec50’ – zostaną uaktywnione przyciski Załaduj recepturę oraz Zarejestruj wartości.

Rysunek: Podgląd aktualnych wartości zmiennych wybranego zestawu przynależnego do analizowanej grupy receptur.

Dostęp do historii ładowania receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 1 min 4 sek


Tworzenie automatycznych receptur

5.3.6. Tworzenie automatycznych receptur

Zadanie:

Dla grupy receptur ‘Stężenia’ zdefiniuj mechanizm automatycznej receptury, który będzie ładował do mieszalnika 1 odpowiednią recepturę w zależności od zmiany wartości zmiennej określającej jakie ma być stężenie wody w mieszance. Przetestuj działanie mechanizmu automatycznej receptury.

Zmienną kontrolną będzie w tym przypadku zmienna M1_2, a zmiana wartości tej zmiennej będzie następować w wyniku zadeklarowania stosownej wartości wody przez operatora na masce asixa.

1. Uruchom aplikację ’Fabryka’ dla komputera ‘StacjaSO1’.

(D:\Fabryka_z_AsBase\Fabryka_Prezentacja.xml)

Razem z aplikacją asixa zostanie również uruchomiony moduł AsBase z załadowanym plikiem konfiguracyjnym aplikacji AsBase

(D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML )

2. Przejdź do trybu konstruktora masek aplikacji.

3. Otwórz maskę ‘T_MIXER’.

4. Kliknij na obiekt LICZBA, znajdujący się przy napisie ‘Woda:’ na formularzu wyświetlającym skład receptury dla mieszalnika 1. W oknie parametrów obiektu LICZBA zaznacz opcję ‘ze sterowaniem’ i zadeklaruj jako daną sterowaną zmienną 'M1_2'. Zatwierdź zmiany przyciskiem OK.

Rysunek: Deklaracja możliwości sterowania wartością zmiennej M1_2 za pośrednictwem obiektu LICZBA.

5. Zapisz i zamknij maskę za pomocą komendy Maski > Zapisz oraz Maski > Skończ w oknie Konstruktora

6. Przejdź do trybu wykonawczego aplikacji.

7. W drzewie nawigacyjnym modułu AsBase wybierz pozycję Konfiguracja > Automatyczne receptur.

8. Za pomocą przycisku [image] zdefiniuj następujący warunek automatycznego ładowania receptury:

Opis: Ładowanie receptury w zależności od stężenia wody

Grupa receptur: st (Stężenia)

Zestaw zmiennych: z1 (Mieszalnik1)

Nazwa zmiennej: M1_2

Pole synchronizacji: skl2 (Woda)

9. Zatwierdź wprowadzone dane przyciskiem [image].

10. Zapisz zmiany poleceniem Plik > Zapisz

Rysunek: Deklaracja mechanizmu ładowania receptury w odpowiedzi na zmianę wartości zmiennej kontrolnej.

11. Przeładuj aplikację 'Fabryka'.

12. W menu aplikacji ‘Fabryka’ wybierz pozycję F2 > Mieszalniki – Receptury.

13. W formularzu wyświetlającym skład receptury dla mieszalnika 1 kliknij na polu wyświetlającym wartość stężenia wody i wprowadź nową wartość np. 50. Zatwierdź wartość klawiszem Enter i klawiszem F12. Spowoduje to załadowanie stosownej receptury.

Aktualną wartość zestawu zmiennych, do którego załadowana została odpowiednia receptura można również podejrzeć w oknie AsBase:

AsBase > Receptury > Stężenia2 > Mieszalnik1

W opisywanym przypadku - gdzie zmienna, do której wysyłana jest wartość jednego ze składników ładowanej receptury jest jednocześnie zmienną kontrolną ustawianą ręcznie – należy pamiętać o tym, ażeby podawana wartość była wartością rzeczywiście zdefiniowaną w jednej z receptur, w przeciwnym razie zamiast załadowania całej receptury zostanie jedynie zmieniona wartość jednego składnika.

Ładowanie automatycznych receptur nie podlega rejestracji w historii ładowań.

Tworzenie automatycznych receptur - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 4 min 24 sek


Tworzenie zestawów rejestracji

5.4.1. Tworzenie zestawów rejestracji

W testowej aplikacji ‘Fabryka’ rejestracji podlegają:

- zdarzenie awarii wentylatora (patrz więcej: 5.4.3. Rejestrowanie wartości zestawów rejestracji) - zestaw rejestracji obejmuje w tym przypadku pola:

- tekst alarmu,

- czas początku,

- czas końca,

- czas trwania awarii wentylatora;

Awaria symulowana jest na masce aplikacji asixa poprzez wyłączenie i załączenie wentylatora przy użyciu stacyjki; wyłączenie i załączenie wentylatora możliwe jest po przejściu na manualny tryb obsługi wentylatora; ponadto należy pamiętać, że każda czynność sterująca wymaga potwierdzenia przyciskiem F12, a ponowne uruchomienie wentylatora wymaga dwukrotnego wyłączenia i załączenia przyciskami Wyłącz / Załącz.

Rysunek: Maska ‘PIEC I APARAT KONTAKTOWY’ – stacyjka obsługi wentylatora.

- zestaw temperatur pieca rejestrowany przy przekroczeniu przez temperaturę wymurówki pieca wartości maksimum (patrz więcej: 5.4.3. Rejestrowanie wartości zestawów rejestracji) - zestaw rejestracji obejmuje w tym przypadku pola:

- temperatura wymurówki pieca,

- temperatura gazów kwaśnych,

- temperatura spalin między III i IV p.,

- temperatura spalin przed odemglaczem,

- temperatura spalin w chłodnicy.

Rysunek: Maska ‘PIEC I APARAT KONTAKTOWY’ – przekroczenie przez temperaturę wymurówki pieca wartości maksymalnej.

Utwórz 2 zestawy rejestracji ‘Awarie W1’ i ‘Temperatury2’, w ramach których zdefiniuj pola, których wartości będą rejestrowane.

Dla zestawu rejestracji ‘Awarie W1’ zdefiniuj pola zawierające następujące informacje:

- opis alarmu - ‘Tekst alarmu’,

- czas początku awarii wiatraka - ‘Początek’,

- czas końca awarii wiatraka - ‘Koniec’,

- czas trwania awarii wiatraka - ‘Czas trwania’.

Dla zestawu rejestracji ‘Temperatury2’ zdefiniuj pola zawierające następujące informacje:

- temperatura wymurówki pieca - ‘Temp_wym’,

- temperatura gazów kwaśnych - ‘Temp_gkw’,

- temperatura spalin między III i IV p. - ‘Temp_s34’,

- temperatura spalin przed odemglaczem - ‘Temp_spo’,

- temperatura spalin w chłodnicy - 'Temp_swc'.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Zestawy rejestracji.

5. Dodaj nowy rekord tabeli za pomocą przycisku [image], opisując go w następujący sposób:

Identyfikator: aw1

Nazwa: Awarie W1

Opis: Awarie wentylatora powietrza W1

6. Zatwierdź wprowadzone dane przyciskiem [image].

Rysunek: Panel definiowania zestawów rejestracji.

7. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Zestawy rejestracji > Awarie W1 > zakładka Zestaw rejestracji Awarie W1 - Pola

8. Za pomocą przycisku [image] dodaj nowy rekord tabeli definiujący pole ‘Tekst alarmu’. Opisz pole w nastepujący sposób:

Kolejność: 1

Identyfikator: tekst_al

Nazwa: Tekst alarmu

Opis: opis alarmu

Parametry: Tekst(25)

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

9. Zatwierdź wprowadzone dane przyciskiem [image].

10. W analogiczny sposób dodaj pola ‘Początek’, ‘Koniec’ i ‘Czas trwania’, opisując je w następujący sposób:

Kolejność: 2

Identyfikator: aw_p

Nazwa: Początek

Opis: czas początku awarii wiatraka

Parametry: Data(yyyymmdd hh:nn:ss)

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 3

Identyfikator: aw_k

Nazwa: Koniec

Opis: czas końca awarii wiatraka

Parametry: Data(yyyymmdd hh:nn:ss)

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 4

Identyfikator: aw_c

Nazwa: Czas trwania

Opis: czas trwania awarii wiatraka

Parametry: Data(yyyymmdd hh:nn:ss)

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Rysunek: Panel definiowania pól dla zestawów rejestracji.

11. Utwórz zestaw rejestracji ‘Temperatury2’ powtarzając kroki 1-6 dla następujących danych:

Definicja zestawu rejestracji ‘Temperatury2’:

Identyfikator: T2

Nazwa: Temperatury2

Opis: Temperatury pieca

Definicje pól zestawu rejestracji ‘Temperatury2’:

Kolejność: 1

Identyfikator: T2_1

Nazwa: Temp_wym

Opis: temperatura wymurówki pieca

Parametry: zmiennoprzecinkowy

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 2

Identyfikator: T2_2

Nazwa: Temp_gkw

Opis: temperatura gazów kwaśnych

Parametry: zmiennoprzecinkowy

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 3

Identyfikator: T2_3

Nazwa: Temp_s34

Opis: temperatura spalin między III i IV p.

Parametry: zmiennoprzecinkowy

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 4

Identyfikator: T2_4

Nazwa: Temp_spo

Opis: temperatura spalin przed odemglaczem

Parametry: zmiennoprzecinkowy

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

Kolejność: 5

Identyfikator: T2_5

Nazwa: Temp_swc

Opis: temperatura spalin w chłodnicy

Parametry: zmiennoprzecinkowy

Edycja: nie (pozostaw puste pole)

Ze statusem: tak (zaznacz pole)

Z czasem: tak (zaznacz pole)

12. Zapisz plik xml aplikacji AsBase: Plik > Zapisz

Rysunek: Definicja pól dla zestawów rejestracji ‘Temperatury2’.

Tworzenie zestawu rejestracji - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 6 min 34 sek


Definiowanie zestawów zmiennych powiązanych z polami zestawów rejestracji

5.4.2. Definiowanie zestawów zmiennych powiązanych z polami zestawów rejestracji

Zdefiniuj zestawy zmiennych dla zestawów rejestracji 'Awarie W1' i 'Temperatury2'.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Zestawy rejestracji > Awarie W1 > zakładka Zestawy zmiennych

5. Za pomocą przycisku [image] dodaj nowy rekord tabeli definiujący zestaw ‘Zestaw 1 dla W1’. Opisz zestaw w następujący sposób:

Identyfikator: aw1_z1

Nazwa: Zestaw 1 dla W1

Opis: Zestaw 1 - Awarie wentylatora powietrza W1

6. Zatwierdź wprowadzone dane przyciskiem [image].

7. Dla zestawu ‘Zestaw 1 dla W1’ z automatycznie dodanymi polami zestawu rejestracji ‘Awarie W1’ zadeklaruj następujące zmienne procesowe:

Kolejność | Nazwa | Nazwa zmiennej
1 | Tekst alarmu | AL30_T
2 | Początek | AL30_B
3 | Koniec | AL30_E
4 | Czas trwania | AL30_D

W tym celu wybierz pozycję Konfiguracja > Zestawy rejestracji > Awarie W1 > Zestaw 1 dla W1

Rysunek: Definicja zestawu zmiennych dla zestawu rejestracji ‘Awarie W1’.

8. W analogiczny sposób dodaj zestaw zmiennych ‘Z1 dla Temperatury2' do zestawu rejestracji ‘Temperatury2’ i zdefiniuj powiązania pomiędzy polami zestawu rejestracji ‘Temperatury2’ i odpowiadającymi im zmiennymi procesowymi.

Zestaw zmiennych dla zestawu rejestracji ‘Temperatury2’:

Identyfikator: temp2_z1

Nazwa: Z1 dla Temperatury2

Opis: Zestaw 1 – Przekroczenia temperatur pieca

Zestaw zmiennych ‘Z1 dla Temperatury2’:

Kolejność | Nazwa | Nazwa zmiennej
1 | Temp_wym | A078
2 | Temp_gkw | A046
3 | Temp_s34 | A052
4 | Temp_spo | A000
5 | Temp_swc | A076

9. Zapisz plik xml aplikacji AsBase: Plik > Zapisz

Rysunek: Definicja zestawu zmiennych dla zestawu rejestracji ‘Temperatury2’.

Definiowanie zestawów zmiennych powiązanych z polami zestawów rejestracji - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 4 min


Rejestrowanie wartości zestawów rejestracji

5.4.3. Rejestrowanie wartości zestawów rejestracji / Definiowanie warunków rejestracji

Rejestracja zdarzenia awarii wentylatora

Momentem inicjującym zapis danych do zestawu archiwizacji jest skasowanie awarii za pomocą przycisku umieszczonego na stacyjce do obsługi pracy wentylatora. Akcja ta powoduje ustawienie bitu nr 15 na zmiennej N13_S, co w naturalnych warunkach pracy aplikacji spowodowałoby przygotowanie przez sterownik zmiennych potrzebnych do zarejestrowania awarii (początek, koniec, czas trwania awarii) i ustawienie przez sterownik odpowiedniego bitu na zmiennej synchronizującej rejestrację AL30_S. W warunkach symulacji pracy aplikacji ‘Fabryka’ działania sterownika zastępuje skrypt ‘KW_AL30_obs.vbs’ (katalog Fabryka_z_AsBase\SKRYPTY), który wylicza czas trwania awarii, wystawia wartości wymaganych zmiennych oraz ustawia wartość 1 na zmiennej AL30_S, co bezpośrednio uruchamia rejestrację wartości charakteryzujących awarię wentylatora. Po zaistnieniu warunku (i rejestracji awarii) AsBase wysyła do zmiennej kontrolnej wartość zerującą.

Awaria symulowana jest poprzez wyłączenie i załączenie wentylatora przy użyciu wspomnianej stacyjki; wyłączenie i załączenie wentylatora możliwe jest po przejściu na manualny tryb obsługi wentylatora; ponadto należy pamiętać, że każda czynność sterująca wymaga potwierdzenia przyciskiem F12, a co drugie wyłączenie i ponowne załączenie wentylatora ponownie uruchamia pracę wentylatora.

Rejestracja zestawu temperatur pieca

Rejestracja następuje, gdy określona zmienna (w przypadku aplikacji ‘Fabryka’ jest to zmienna B172_36) ma ustawiona wartość 1 na drugim bicie (przy dowolnym ustawieniu pozostałych bitów). W normalnych warunkach pracy aplikacji przy przekroczeniu przez temperaturę wymurówki pieca wartości maksymalnej (max) sterownik ustawia odpowiedni bit określonej zmiennej (w przypadku pomiarów analogowych zazwyczaj jest to zmienna statusowa)- i jest to sygnałem dla modułu AsBase do wykonania rejestracji wartości temperatur pieca. W warunkach symulacji pracy aplikacji ‘Fabryka’ w przypadku przekroczenia przez temperaturę wymurówki wartości maksimum ustawiany jest odpowiedni bit w zmiennej B172_36 za pomocą skryptu ‘An2.vbs’ (w katalogu Fabryka_z_AsBase\demo) – a wówczas następuje rejestracja.

Tryb rejestracji – typ synchronizacji

AsBase zakłada możliwość zapisu rejestrowanych wartości z dokładnością do znacznika czasu wynikającego z przyjętego typu synchronizacji. W przypadku aplikacji ‘Fabryka’ przyjęto, że wartości temperatur będą archiwizowane w trybie oczekiwania na dane bieżące – co oznacza, że po wykryciu warunku rejestracji AsBase będzie oczekiwał na otrzymanie wartości pomiarowych z najbliższego cyklu odświeżania zmiennych.

Zdefiniuj warunki rejestracji dla zestawów: 'Awarie W1' i 'Temperatury2' zgodnie z powyższymi założeniami.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Warunki rejestracji

5. Za pomocą przycisku [image] dodaj nowy rekord tabeli definiujący warunek rejestracji awarii wentylatora powietrza W1 – zapis inicjowany jest wartością zmiennej AL30_S (rejestracja następuje, gdy wartość AL30_S wynosi 1):

Opis: warunki rejestracji dla ‘Awarie W1’

Zestaw archiwizacji: aw1

Zestaw zmiennych: aw1_z1

Synchronizacja czasowa:

Synchronizuj czasem: nie

Okres:

Start:

Dzień:

Synchronizuj wartością:

Testuj wartość: tak

Nazwa zmiennej: AL30_S

Rodzaj porównania: Równa

Wartość porównania: 1

Wartość zerująca: 0

Typ synchronizacji: archiwizuj aktualnie dostępne dane

Rysunek: Warunek rejestracji zestawu ‘Awarie W1’.

6. Zatwierdź wprowadzone dane przyciskiem [image].

7. Dodaj rekord definiujący warunek rejestracji temperatur pieca – zapis inicjowany jest wartością bitów zmiennej B172_36:

Opis: warunki rejestracji dla ‘Temperatury2’

Zestaw archiwizacji: T2

Zestaw zmiennych: temp2_z1

Synchronizacja czasowa:

Synchronizuj czasem: tak

Okres: 00:00:10

Start: 00:00

Dzień: Codziennie

Synchronizuj wartością:

Testuj wartość: tak

Nazwa zmiennej: B172_36

Rodzaj porównania: Dowolny bit

Wartość porównania: 2

Wartość zerująca:

Typ synchronizacji: archiwizuj aktualnie dostępne dane

Rysunek: Warunek rejestracji zestawu ‘Temperatury2’.

8. Zatwierdź wprowadzone dane przyciskiem [image].

9. Zapisz zmiany poleceniem Plik > Zapisz.

Definiowanie warunków rejestracji - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 2 min 45 sek


Przeglądanie archiwum zestawu rejestracji

5.4.4. Przeglądanie archiwum zestawu rejestracji

Archiwum wartości zestawów rejestracji

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych

Archiwum wartości zestawów rejestracji

Przejrzyj zarejestrowane wartości zestawu rejestracyjnego 'Temperatury2' dostępne w tabeli archiwum danego zestawu.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Rejestr > Temperatury2

Rysunek: Archiwum wartości zestawu rejestracyjnego.

Rejestr zostanie zapełniony po uruchomieniu aplikacji asixa 'Fabryka' dla komputera ‘StacjaSO1’:

(D:\Fabryka_z_AsBase\Fabryka_Prezentacja.xml)

Razem z aplikacją asixa uruchomiony jest moduł AsBase z załadowanym plikiem konfiguracyjnym aplikacji AsBase - ponieważ jednak AsBase z właściwą aplikacją został juz uruchomiony, zostanie jedynie przywołane okno pracującego AsBase'a.

Podczas pracy aplikacji ważne jest, aby cały czas aktywna była wymiana danych.

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych

Podgląd bieżących wartości zmiennych poszczególnych zestawów zmiennych użytkownik otrzymuje za pośrednictwem paneli podpiętych do archiwum danego zestawu rejestracyjnego. Z poziomu takiego panelu istnieje możliwość ręcznego rejestrowania wartości aktualnie wyświetlanych przy użyciu przycisku ‘Zarejestruj wartości’.

5. W drzewie nawigacyjnym okna AsBase wybierz pozycję Rejestr > Temperatury2 > Z1 dla Temperatury2

Rysunek: Podgląd aktualnych wartości zmiennych wybranego zestawu zmiennych przynależnego do analizowanego zestawu rejestracji.

Przeglądanie archiwum zestawu rejestracji - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 4 min 27 sek


Definiowanie_slownikow_zastosowanie_na_przykladzie receptur

5.5. Definiowanie słownika - zastosowanie na przykładzie receptur

Dla grupy receptur ‘Stężenia2’ zadeklaruj słownik ‘Wartości stężenia kwasu siarkowego’, który zamiast liczbowej wartości będzie wyświetlał tektst informujący o zawartości kwasu w mieszance.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Słowniki

5. Za pomocą przycisku [image] dodaj nowy słownik:

Nazwa: Stężenia kwasu

Opis: zawartość kwasu siarkowego w mieszance

6. Zatwierdź wprowadzone dane przyciskiem [image].

7. W nowoutworzonym słowniku dodaj rekordy deklarujące sposób tłumaczenia liczbowych wartości pola ‘Kwas siarkowy’ z grupy receptur 'Stężenia2':

Tekst | Wartość
Zawartość kwasu siarkowego w mieszance wynosi 50% | 50
Zawartość kwasu siarkowego w mieszance wynosi 100% | 100
Zawartość kwasu siarkowego w mieszance wynosi 25% | 25
Zawartość kwasu siarkowego w mieszance wynosi 75% | 75
Zawartość kwasu siarkowego w mieszance wynosi 80% | 80

Rysunek: Panel definiowania słowników.

8. Przejdź do rekordu definicji pola ‘Kwas siarkowy’ (Konfiguracja > grupa receptur ‘Stężenia2’) i w parametrach pola oprócz typu danych zadeklaruj słownik ‘Stężenia kwasu’.

9. Zatwierdź wprowadzone dane przyciskiem [image].

10. Zapisz zmiany poleceniem Plik > Zapisz.

Rysunek: Deklarowanie słownika w parametrach pola receptury.

Definiowanie słownika - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 3 min


Dostosowanie widoków paneli AsBase'a

5.6. Dostosowanie widoków paneli/tabel AsBase’a do indywidualnych preferencji użytkowników

Możliwości dostępne w programie AsBase w zakresie definiowania widoku paneli obejmują:

- zapamiętywanie bieżącego układu pasków narzędzi w oknie programu AsBase; zawsze obowiązuje ostatni zastosowany układ - nie ma możliwości zapamiętywania układów pasków dla konkretnych aplikacji AsBase - układ zapamiętywany jest w rejestrze windowsowym; układ pasków narzędzi obowiązuje globalnie na wszystkich panelach AsBase'a;

- zapamiętywanie bieżącego widoku tabel obowiązującego wszystkie panele (ustawienia dotyczące stylów tabel głównych, tabel szczegółów oraz tabeli logu zdarzeń związanych z pracą modułu AsBase), ustawianego przy użyciu komendy Narzędzia > Konfiguruj…); zawsze obowiązuje ostatni zastosowany styl - nie ma możliwości zapamiętywania stylów tabel dla konkretnych aplikacji AsBase - styl zapamiętywany jest w rejestrze windowsowym; styl tabel obowiązuje globalnie na wszystkich panelach;

- możliwość zdefiniowania kilku indywidualnych widoków definiujących takie elementy jak: sposób prezentacji (wiersze/karty), liczba, szerokość i kolejność kolumn, wartość filtrów zastosowanych do wyświetlenia wartości wierszy. Takie indywidualne widoki można zdefiniować dla konkretnych: tabeli gotowych wartości receptur, tabeli historii ładowań receptur oraz tabeli archiwum wartości zestawu rejestracyjnego - widoki są zapamiętywane pod indywidualną nazwą dla danej aplikacji AsBase (w bazie SQLowej aplikacji); można zdefiniować wiele widoków dla tej samej tabeli.

Zadanie:

Zmodyfikuj widok paneli zmieniając kolorystykę tabel - styl 'storm VGA' dla tabel głównych, styl 'wheat' dla tabel szczegółów oraz styl 'Red, White and Blue (VGA)' dla tabeli logu zdarzeń.

Dodatkowo dla grupy receptur ‘Stężenia2’ utwórz indywidualny widok o nazwie ‘widok_grey’, uwzględniający zmianę ilości wyświetlanych kolumn (dodaj kolumnę ‘Użytkownik’ oraz ‘Czas’) oraz filtr wyświetlający tylko te receptury, w których zawartość wody nie przekracza 50%.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja > Grupy receptur

5. W menu Narzędzia wybierz komendę Konfiguruj…:

6. W oknie ‘Parametry konfiguracyjne’ na zakładce Styl tabel określ styl tabel głównych, tabel szczegółów oraz styl tabeli logu zdarzeń:

Style tabel: Storm (VGA)

Style tabel szczegółów: Wheat

Style tabeli logu zdarzeń: Red, White and Blue (VGA)

7. Zatwierdź zmiany przyciskiem OK.

Rysunek: Okno definiowania stylów tabel.

8. W drzewie nawigacyjnym okna AsBase wybierz pozycję Receptury > Stężenia2

9. W tabeli receptur dodaj do widoku kolumny ‘Użytkownik’ i ‘Czas’, klikając na przycisk w lewym górnym rogu tabeli i zaznaczając pola wyboru przy odpowiedniej nazwie kolumny.

10. W tabeli receptur dodaj fitlr wyświetlający jedynie te rekordy receptur, w których zawartość wody nie przekracza 50%. W tym celu:

- kliknij na przycisk … w dolnym pasku narzędziowym tabeli;

- w oknie kreatora filtrów utwórz następujący filtr:

Wartość pola ‘Woda’ <= 50

- zatwierdź zmiany przyciskiem OK.

Rysunek: Okno kreatora filtrów.

11. W menu Widok > Tabele wybierz komendę Zapisz widok jako… i zachowaj aktualny widok pod nazwą ‘widok_grey’.

Zestawienie widoków zdefiniowanych dla tabeli receptur ‘Stężenia2’ można wyświetlić za pomocą komendy Widok > Tabele > Widoki…

12. Zapisz zmiany poleceniem Plik > Zapisz.

Rysunek: Lista widoków zdefiniowanych dla konkretnej grupy receptur.

Dostosowanie widoków paneli/tabel do indywidualnych preferencji użytkownika - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 2 min 51 sek


Tworzenie raportów

5.7. Tworzenie raportów / definiowanie stylu wydruku

Dane zarejestrowane przy użyciu modułu AsBase mogą być prezentowane w formie raportów przeznaczonych do wydruku. Przygotowanie takiego raportu z widoku tabel historii ładowań receptur bądź archiwum wartości zestawu rejestracji umożliwia zintegrowane z AsBase’em narzędzie do edycji podglądu wydruku raportu.

Raporty tworzone są na podstawie bieżącego widoku tabeli (patrz: 4.6.4.1. Widoki tabeli) w panelu AsBase’a, obejmującego ustawienia następujących elementów:

- szerokość kolumn;

- ilość widocznych kolumn;

- kolorystyka tabel;

- ograniczenia pozwalające przefiltrować dane źródłowe raportu;

- pole grupowania wg kolumny;

- stopka, która umożliwia utworzenie pól podsumowujących wartości z kolumn (po jednym polu dla każdej kolumny): Suma, Minimum, Maksimum, Ilość, Średnia.

Widok zapisywany jest pod indywidualną nazwą dla danej aplikacji AsBase (w bazie SQLowej aplikacji).

Podgląd wydruku (wywoływany z AsBase'a komendą Plik > Podgląd wydruku) pozwala dodefiniować następujące elementy raportu:

- tytuł raportu;

- marginesy;

- nagłówek i stopka;

- kolor tła raportu;

- definiowany przy użyciu edytora format raportu określający głównie kolorystykę oraz poziom szczegółowości prezentowanych danych;

Elementy te zapamiętywane są w rejestrze windowsowym.

Zadanie:

Utwórz raport wartości nastaw dokonanych przez użytkownika ‘administrator’ dla receptur z grupy ‘Stężenia2’ za ostatni miesiąc. Wartości powinny być pogrupowane wg miejsca nastaw (mieszalnik 1,2,3) z polami podsumowującymi wyświetlajacymi: ilość wierszy, maksymalną wartość stężenia kwasu i maksymalną wartość stężenia wody. Styl tabeli: ‘Wheat’.

Raport powinien być opatrzony tytułem oraz stopką z podaną datą utworzenia wydruku, liczbą stron w formacie ‘n z n’ oraz czasem wydruku.

Przed przystąpieniem do wykonania zadania potrzebne będzie zarejestrowanie danych, które zostaną przetworzone w raporcie. W tym celu wykonaj kilka operacji ładowania receptur (patrz: 5.3.4. Ładowanie receptur).

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Receptury > Historia ładowań (widok tabela)

5. Ustaw styl tabeli na ‘Wheat’.

W tym celu w menu Narzędzia wybierz komendę Konfiguruj… i z zakładki Styl tabel w polu Style tabel określ stosowny styl. Zatwierdź wybór przyciskiem OK.

6. Ustaw jako widoczne następujące kolumny: Nazwa, Użytkownik, Czas, Satus, Kwas siarkowy, Woda i Miejsce.

W tym celu używając przycisku w lewym górnym rogu tabeli rozwiń listę wszystkich dostępnych kolumn i zaznacz te kolumny, które mają być widoczne na raporcie.

Rysunek: Lista wyboru wyświetlanych kolumn w tabeli historii ładowań receptur.

7. Załącz wyświetlanie stopki i pola grupującego.

W tym celu wybierz z menu Widok > Tabele polecenie ‘Pokaż pole grupowania’ oraz ‘Pokaż stopkę’.

8. Pogrupuj rekordy tabeli wg miejsca nastaw, przeciągając nagłówek kolumny Miejsce w obszar pola grupującego. Rekordy zostaną zgrupowane w 3 grupach odpowiadających zestawom zmiennych przypisanych do mieszalników 1,2 i 3.

9. Dodaj do stopki pola podsumowujące: Ilość dla kolumny Czas, Maksimum dla kolumn Kwas siarkowy i Woda. W tym celu kliknij prawym przyciskiem myszy w obszarze stopki pod odpowiednim nagłówkiem kolumny i z rozwijanej listy wybierz odpowiednio Ilość lub Maksimum.

10. Załącz filtr, który wyświetli rekordy dla operatora ‘administrator’. Korzystając z przycisku [image] znajdującym się na pasku poniżej tabeli uruchom kreator filtrów i zdefiniuj następujący filtr: ‘Użytkownik’ ‘jest zgodne z’ ‘administrator’.

11. Przefiltruj rekordy tak, aby w raporcie znalazły się wyłącznie dane z jednego (aktualnego) miesiąca (w przypadku tego przykładu jest to miesiąc czerwiec).

W tym celu skorzystaj z predefiniowanych filtrów czasowych. Kliknij na strzałkę w nagłówku kolumny Czas i wybierz filtr ‘Ten miesiąc’.

Rysunek: Raport nastaw receptur – widok w oknie AsBase.

12. Przejdź do widoku podglądu wydruku raportu – polecenie Plik > Podgląd wydruku… i zdefiniuj styl wydruku:

a. Dodaj tytuł raportu za pomocą okna wywoływanego poleceniem Format > Tytuł…:

- na zakładce Tekst zdefiniuj tekst tytułu, który będzie się pojawiał na każdej stronie:

‘Raport wartości nastaw za miesiąc czerwiec’;

- na zakładce Właściwości określ czcionkę tytułu: 14 pt. Calibri [Pogrubiona]

b. W stopce raportu umieść liczbę stron w formacie ‘n z n’, a w nagłówku raportu: datę utworzenia wydruku oraz czas wydruku.

Skorzystaj w tym celu z okna ‘Ustawienia strony’ wywoływanego przyciskiem [image] z paska narzędziowego. Na zakładce Nagłówek/Stopka, korzystając z predefiniowanych funkcji znajdujących się u dołu okna, wstaw następujące elementy:

- w sekcji Nagłówek: Data wydruku: [Ddata wydruku] i Godzina: [Czas wydruku];

- w sekcji Stopka: [Strona #] z [Suma stron].

Rysunek: Podgląd wydruku – okno ‘Ustawienia strony’ – definicja nagłówka i stopki raportu.

c. Zapis raport pod nazwą ‘Raport wartości nastaw za miesiąc czerwiec.rps’ w katalogu:

‘Fabryka_z_AsBase/ASBASE/RAPORTY’

Rysunek: Raport wartości nastaw - podgląd wydruku.

13. Zapisz zmiany poleceniem Plik > Zapisz.

Tworzenie raportu / definiowanie stylu wydruku - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 5 min 52 sek


Definiowanie stylu wydruku przypisanego do danej aplikacji

5.7.1. Definiowanie stylu wydruku przypisanego do danej aplikacji

Do każdej aplikacji istnieje możliwość przypisania kilku stylów wydruku. Style te definiowane są przy użyciu okna ‘Definiowanie stylów wydruków’. Pierwszy styl tworzony jest przy użyciu komendy Nowy…, każdy następny należy utworzyć jako kopię już istniejącego stylu - którą następnie można zmodyfikować za pomocą komendy Edytuj…. Zarówno polecenie Nowy… jak i Edytuj… uruchamia okno umożliwiające dokonanie ustawień dotyczących: rozmiaru strony, ustawień marginesów, zawartości nagłówka i stopki oraz opcji skalowania.

Style wydruków zdefiniowane w powyższy sposób zapisywane są w bazie SQLowej danej aplikacji.

Rysunek: Okno ‘Ustawienia strony’ – strona.

Rysunek: Okno ‘Ustawienia strony’ – marginesy.

Rysunek: Okno ‘Ustawienia strony’ – nagłówek i stopka.

Rysunek: Okno ‘Ustawienia strony’ – skalowanie.

Zadanie:

Zdefiniuj styl 'Raporty miesięczne' o następujących parametrach:

- typ papieru: A4;

- marginesy - kolejno: 33,10; 12,70; 12,70; 12,70; 6,35; 6,35;

- stopka: [Strona #] [Data wydruku];

- skalowanie: 100% normalnego rozmiaru.

1. Uruchom moduł AsBase: menu Start > Programy > Asix > AsBase

2. Otwórz plik konfiguracyjny aplikacji AsBase:

D:\Fabryka_z_AsBase\ASBASE\AsBase_Fabryka.XML

3. Zaloguj się jako administrator - patrz: definicja użytkownika 5.2.4. Deklarowanie użytkowników (login: admin, hasło: admin)

4. W drzewie nawigacyjnym okna AsBase wybierz pozycję Konfiguracja

5. Na panelu głównym wybierz przycisk '...' z prawej strony pola Style wydruku

6. W oknie ‘Definiowanie stylów wydruków’ uruchom komendę Nowy...

Zostanie uruchomione okno z parametrami wydruku

7. Na zakładce Strona wybierz typ papieru A4

8. Na zakładce Marginesy określ zgodnie z powyższymi ustaleniami rozmiary marginesów oraz wymiary nagłówka i stopki

9. Przejdź do zakładki Nagłówek/Stopka i w sekcji Stopka zadeklaruj w części środkowej numer strony, a w części prawej datę wydruku.

Posłuż się predefiniowanymi funkcjami znajdującymi się poniżej obszaru definicji stopki - przyciski: i [image].

10. Na zakładce Skalowanie pozostaw domyślne ustawienie skalowania do 100% normalnego rozmiaru.

11. Zapisz zdefiniowany styl pod nazwą 'Raporty miesięczne' - pole Nazwa stylu w górnej części okna ustawień wydruku.

12. Zapisz zmiany poleceniem Plik > Zapisz.

Definiowanie stylu wydruku - instrukcja demo >>

rozdzielczość: 1024x768 px

czas prezentacji: 1 min 47 sek


6. Współpraca obiektów asixa z tablicami modułu AsBase

6. Współpraca obiektów asixa z tablicami modułu AsBase - opis mechanizmu połączenia

Łączność z bazą danych modułu AsBase zapewnia obiekt ASBASE, umożliwiając przeglądanie jej tabel. Jest to obiekt "przezroczysty", wstawiany na tle maski. Jeżeli potrzebny jest globalny dostęp do bazy danych, wówczas obiekt można umieścić na masce wyświetlanej przez cały czas działania aplikacji (np. menu). Działanie obiektu w momencie uruchamiania maski polega na utworzeniu połączenia z odpowiednim źródłem danych, natomiast w momencie zamknięcia maski na jego zamknięciu (przez cały czas wyświetlania maski musi być uruchomiony moduł AsBase).

Przegląd pojedynczej tabeli odbywa się w ramach połączenia, które posiada swój unikalny identyfikator, zdefiniowany w czasie parametryzacji obiektu ASBASE. Identyfikator ten jest potem wykorzystywany jako parametr akcji operatorskiej ASBASE,Nawiguj do określenia połączenia, którego dotyczy ta akcja. Oprócz określenia identyfikatora połączenia, obiekt ASBASE pozwala zdefiniować typ przeglądanej tabeli, jej identyfikator, zestaw zmiennych procesowych, do których będą przekazywane wartości z wierszy tabeli oraz filtr pozwalający określić, które zapisy znajdujące się w tabeli mają zostać wyświetlone na maskach procesowych.

Obiekt ASBASE pozwala przeglądać tabele typu:

- zestaw rejestracji,

- grupa receptur

- historia ładowań.

W chwili otwarcia maski, na której znajduje się obiekt ASBASE, następuje otwarcie połączenia o podanym identyfikatorze, otwarcie określonej tabeli oraz przekazanie wartości poszczególnych pól ostatniego zapisu w tabeli, który jest zgodny z definicją filtru, do zmiennych procesowych zestawu zmiennych o podanym identyfikatorze.

Do prezentacji wartości pól rekordu bazy danych najlepiej nadają się obiekty LICZBA oraz NAPIS.

Nawigacja po rekordach źródła danych realizowana jest za pomocą obiektów PRZYCISK, do których należy przypisać odpowiednio sparametryzowaną akcję 'ASBASE' w wariancie 'Nawiguj' (patrz: 6.1. Akcja operatorska ASBASE).

Akcja operatorska ASBASE pozwala na zdalne sterowanie praca programu AsBase w następującym zakresie:

- uruchomienie modułu AsBase z przekazaniem mu określonych parametrów;

- uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch);

- załadowanie receptury;

- przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu asix;

- wydrukowanie zawartości tabel bazy danych modułu AsBase;

- dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase;

- usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase;

- zmiana bieżącego rekordu w tabeli bazy danych modułu AsBase.

Szczegółowy opis różnych wariantów akcji ASBASE znajduje się w rozdziale 6.1. Akcja operatorska ASBASE.


Akcja operatorska ASBASE

6.1. Akcja operatorska ASBASE

ASBASE - pozwala na zdalne sterowanie pracą programu AsBase.

Parametry akcji definiowane przy użyciu edytora akcji:

Typ operacji:

start - operacja powoduje uruchomienie modułu AsBase z przekazaniem mu parametrów; Jeżeli AsBase był już wcześniej uruchomiony, to operacja start jest równoważna operacji pokaż bez parametrów. Dodatkowym efektem użycia operacji start jest to, że w momencie końca pracy głównego modułu programu asix zostanie również zakończona praca modułu Asbase. Struktura parametrów jest następująca:

nazwa_pliku_xml [/single][/minimize] /user:<id_uzytkownika>/password:<hasło>

gdzie:

nazwa_pliku_xml - plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

/single - powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

/minimize - powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna;

/user:<id_uzytkownika>/password:<hasło> - powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

pokaż - operacja powoduje uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch). Dodatkowe parametry pozwalają określić informację, która ma zostać pokazana w oknie:

Typ obszaru: RCP - wartości receptury, RLD - historia ładowań receptur, ARC - archiwum;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

Pokaż obszar - wyświetla zdefiniowany obszar;

Pokaż zestaw - wyświetla zdefiniowany obszar dla zestawu zmiennych, identyfikowanych identyfikatorem wpisywanym do pola Identyfikator zestawu;

Widok - wyświetla zdefiniowany obszar zgodnie z parametrami definiującymi sposób wyświetlania zawartości danej tabeli; widok identyfikowany jest za pomocą identyfikatora wpisywanego do pola Identyfikator widoku;

załaduj - operacja pozwala na załadowanie przeliczonych wartości receptury zgodnie z parametrami:

ID grupy - określa grupę receptur, której operacja dotyczy;

ID zestawu - określa zestaw zmiennych, gdzie receptura ma być załadowana;

Nazwa receptury - jeżeli parametr ten nie zostanie podany, to wyświetlone zostanie okno z listą wszystkich receptur zdefiniowanych w grupie, z której operator będzie mógł wybrać recepturę, która ma być załadowana

nawiguj - operacja pozwala na przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu asix. Parametry wymagane:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

Komenda - nazwa komendy, jaka ma zostać wykonana; można podać następujące komendy:

FIRST - pierwszy zapis tabeli,

NEXT - kolejny zapis tabeli,

PREVIOUS - poprzedni zapis tabeli,

LAST - ostatni zapis tabeli,

FILTER - nowy filtr: zdefiniowanie nowego filtru oraz wyświetlenie ostatniego zapisu z tabeli zgodnego z nowym filtrem,

COUNT - liczba wierszy: powoduje przypisanie do określonej zmiennej zestawu zmiennych liczby, która jest ilością zapisów w tabeli zgodnych z aktualnym filtrem;

LOAD - receptura: komenda powoduje załadowanie wskazanej receptury (definicji receptury) do zestawu zmiennych; działanie tego wariantu akcji zbliżone jest do wariantu ASBASE, załaduj; zwyczajowo wartości receptury ładowane są do zmiennych wirtualnych, wykorzystywanych do przeglądania zmiennych. (uwaga: komenda ta nie uwzględnia pola wsad niezbędnego dla receptur przeliczalnych).

DOWNLOAD - receptura: komenda powoduje załadowanie bieżącej receptury do wskazanego identyfikatorem zestawu zmiennych (z kanału fizycznego). Każda operacja załadowania receptury posiada automatycznie nadany unikalny numer, który może być wysłany razem z recepturą. Komenda ta pozwala wyliczyć wartości pól dla receptur przeliczalnych - wówczas przed wykonaniem komendy należy ustawić wartość pola określającego wielkość wsadu dla danej receptury (na masce aplikacji asixa powinno znajdować się pole umożliwiające wprowadzenie wielkości wsadu do zmiennej podpiętej do pola WSAD wysyłanej receptury).

drukuj - operacja pozwala na wydrukowanie zawartości tabel bazy danych modułu AsBase; parametryzacja operacji obejmuje:

Typ obiektu: RCP - wartości receptur, RLD - historia ładowań receptur, ARC - archiwum zestawu rejestracji;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

ID widoku - jest identyfikatorem jednego z widoków skojarzonych z daną tabelą;

dodaj - operacja pozwala na dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

usuń - operacja pozwala na usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

zmień - operacja pozwala na zmianę bieżącego rekordu w tabeli bazy danych modułu AsBase;parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

Składnia akcji definiowana ręcznie:

ASBASE typ_operacji [parametry_operacji]

gdzie:

ASBASE - stały element deklaracji; można go zastąpić skrótem ASB;

typ_operacji:

STart

Znaczenie - operacja powoduje uruchomienie modułu AsBase z przekazaniem mu parametrów podanych w parametry_operacji (z reguły nazwa pliku xml aplikacji). Jeżeli AsBase był już wcześniej uruchomiony, to operacja Start jest równoważna operacji Pokaż bez parametrów. Dodatkowym efektem użycia operacji Start jest to, że w momencie końca pracy programu AS zostanie również zakończona praca modułu Asbase. Struktura parametrów jest następująca:

nazwa_pliku_xml [/single][/minimize] /user:<id_uzytkownika>/password:<hasło>

gdzie:

nazwa_pliku_xml - plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

/single - powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

/minimize - powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna;

/user:<id_uzytkownika>/password:<hasło> - powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

POkaż

Znaczenie - operacja powoduje uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch). W parametry_aplikacji można opcjonalnie dodać opis informacji, która ma zostać pokazana w oknie. Struktura parametrów jest następująca:

typ_obiektu\identyfikator_obiektu[\identyfikator_zestawu]

gdzie:

typ_obiektu może być równy:

RCP - żadanie wyświetlenia tabeli wartości receptur lub podglądu zestawu zmiennych związanych z grupą receptur;

RLD - żądanie wyświetlenia tabeli historii ładowań receptur;

ARC - żądanie wyświetlenia tabeli archiwum zestawu rejestracji lub podglądu zestawu zmiennych związanych z zestawem rejestracji;

identyfikator_obiektu - jest identyfikatorem zestawu rejestracji lub grupy receptur;

identyfikator_zestawu - jest opcjonalny, jest on identyfikatorem zestawu zmiennych.

Komenda Pokaż pozwala również na wybór widoku. Struktura parametrów jest następująca:

typ_obiektu\identyfikator_obiektu\\identyfikator_widoku

identyfikator_widoku - jest identyfikatorem widoku - czyli zestawu parametrów określających, w jaki sposób wyświetlana jest zawartość danej tabeli.

ZAładuj (LOad)

Znaczenie - operacja pozwala na załadownie receptury. Struktura parametry_operacji jest następująca:

identyfikator_grupy\identyfikator_zestawu[\nazwa_receptury]

gdzie:

identyfikator_grupy i identyfikator_zestawu określają odpowiednio grupę receptur, której operacja dotyczy oraz zestaw zmiennych, gdzie receptura ma być załadowana. Jeżeli nazwa_receptury zostanie podana, to akcja załaduje wskazaną recepturę do zestawu zmiennych. Jeżeli nazwa_receptury nie zostanie podana, to wyświetlone zostanie okno z listą wszystkich receptur zdefiniowanych w grupie, z której operator będzie mógł wybrać recepturę, która ma być załadowana.

Nawiguj (NAvigate)

Znaczenie - operacja pozwala na przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu asix. Struktura parametry_operacji jest następująca:

identyfikator_połączenia\komenda[\definicja_filtru]

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

komenda - nazwa komendy, jaka ma zostać wykonana; można podać następujące komendy:

FIRST - powoduje wyświetlenie pierwszego zapisu tabeli,

NEXT - powoduje wyświetlenie kolejnego zapisu tabeli,

PREVIOUS - powoduje wyświetlenie poprzedniego zapisu tabeli,

LAST - powoduje wyświetlenie ostatniego zapisu tabeli,

FILTER - powoduje zdefiniowanie nowego filtru oraz wyświetlenie ostatniego zapisu z tabeli zgodnego z nowym filtrem,

COUNT - powoduje przypisanie do określonej zmiennej zestawu zmiennych liczby, która jest ilością zapisów w tabeli zgodnych z aktualnym filtrem;

LOAD - receptura: komenda powoduje załadowanie wskazanej receptury (definicji receptury) do zestawu zmiennych; działanie tego wariantu akcji zbliżone jest do wariantu ASBASE, załaduj; zwyczajowo wartości receptury ładowane są do zmiennych wirtualnych, wykorzystywanych do przeglądania zmiennych. (uwaga: komenda ta nie uwzględnia pola wsad niezbędnego dla receptur przeliczalnych).

DOWNLOAD - receptura: komenda powoduje załadowanie bieżącej receptury do wskazanego identyfikatorem zestawu zmiennych (z kanału fizycznego). Każda operacja załadowania receptury posiada automatycznie nadany unikalny numer, który może być wysłany razem z recepturą. Komenda ta pozwala wyliczyć wartości pól dla receptur przeliczalnych - wówczas przed wykonaniem komendy należy ustawić wartość pola określającego wielkość wsadu dla danej receptury (na masce aplikacji asixa powinno znajdować się pole umożliwiające wprowadzenie wielkości wsadu do zmiennej podpiętej do pola WSAD wysyłanej receptury).

definicja_filtru - definicja nowego filtru; ten parametr podaje się tylko dla komendy FILTER; zasady konstruowania definicji filtru zostały opisane w części asix.chm, 19.4.1. Obiekt ASBASE.

Drukuj (PRint)

Znaczenie - operacja pozwala na wydrukowanie zawartości tabel bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

typ_obiektu\identyfikator_obiektu[\identyfikator_widoku]

gdzie:

typ_obiektu - może przyjąć postać:

RCP - tabela wartości receptur;

RLD - tabela historii ładowań receptur;

ARC - tabela archiwum zestawu rejestracji;

identyfikator_obiektu - jest identyfikatorem zestawu rejestracji lub grupy receptur;

identyfikator_widoku - parametr opcjonalny; jest identyfikatorem jednego z widoków skojarzonych z daną tabelą.

DOdaj

Znaczenie - operacja pozwala na dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: asix.chm, 19.4.1. Obiekt ASBASE);

USuń

Znaczenie - operacja pozwala na usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: asix.chm, 19.4.1. Obiekt ASBASE);

ZMień

Znaczenie - operacja pozwala na zmianę bieżącego rekordu w tabeli bazy danych modułu AsBase. Struktura parametry_operacji jest następująca:

identyfikator_połączenia

gdzie:

identyfikator_połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE (patrz: asix.chm, 19.4.1. Obiekt ASBASE);


7. Struktura bazy danych

Baza danych aplikacji AsBase jest tworzona na serwerze Microsoft SQL Server. Poniższe informacje pozwalają na dostęp do archiwów i receptur aplikacji z zewnętrznego oprogramowania niezależnego od AsBase’a (np. Microsoft Excel, aplikacje bazodanowe).


6.1. Nazwa bazy danych

7.1. Nazwa bazy danych

Nazwa bazy danych serwera SQL tworzona jest według wzorca:

_asbase_<nazwa_bazy>

gdzie:

<nazwa bazy> - jest wewnętrzną nazwą bazy AsBase’a wyświetlaną między innymi w panelu konfiguracyjnym.


6.2. Tabele archiwum zestawów rejestracji

7.2. Tabele archiwum zestawów rejestracji

Nazwa tabeli archiwum zestawu rejestracji tworzona jest według wzorca:

ARCHSET_<identyfikator zestawu>

W skład tabeli archiwum wchodzą następujące pola:

  • ID

Typ - int

Unikalny identyfikator rekordu.

  • SOURCE

Typ – varchar(20)

Nazwa źródła pochodzenia rekordu: identyfikator użytkownika lub nazwa komputera.

  • LOCALTIME

Typ - datetime

Czas lokalny zapisu rekordu.

  • UTCTIME

Typ – datetime

Czas UTC zapisu rekordu.

  • STATUS

Typ – int

Zbiorczy status w konwencji OPC opisujący jakość danych zapisanych w rekordzie.

  • V_<identyfikator pola>

Typ – zależny od wybranego typu pola

Wartość pola archiwizacji.

  • T_<identyfikator pola>

Typ – datetime

Indywidualny czas lokalny odczytu wartości pola.

  • S_<identyfikator pola>

Typ – int

Indywidualny status w konwencji OPC opisujący jakość wartość pola .

Pola typu V_, T_ i S_ powtarzają się dla każdego pola archiwizacji zestawu.


6.3. Tabele wartości receptur

7.3. Tabele wartości receptur

Nazwa tabeli wartości grupy receptur tworzona jest według wzorca:

RECIPESET_<identyfikator grupy>

W skład tabeli wartości receptur wchodzą następujące pola:

  • ID

Typ - int

Unikalny identyfikator rekordu.

  • NAME

Typ – varchar(50)

Nazwa receptury.

  • CREATEDBY

Typ – varchar(20)

Autor receptury: identyfikator użytkownika lub nazwa komputera.

  • LOCALTIME

Typ - datetime

Czas lokalny ostatniej modyfikacji rekordu receptury.

  • V_<identyfikator pola>

Typ – zależny od wybranego typu pola

Wartość pola receptury.

Pole typu V_ powtarza się dla każdego pola grupy receptur.


1. Przeznaczenie modułu AsBase

Moduł AsBase jest częścią systemu asix przeznaczoną do tworzenia aplikacji, których celem jest:

  • archiwizacja wybranych danych procesowych w bazie danych wraz z ich późniejszą analizą,

  • realizacja systemu zarządzania recepturami.

Charakterystyczną cechą AsBase’a jest jego w pełni interaktywna parametryzacja i obsługa. Ponadto, od twórcy aplikacji nie jest wymagana żadna wiedza dotycząca tworzenia baz danych. Cały proces budowy aplikacji odbywa się poprzez wprowadzanie danych w oknach dialogowych modułu.

W części archiwizacyjnej AsBase jest przystosowany do zapisywania danych w postaci struktur złożonych z wartości wielu zmiennych procesowych. Operacja zapisu jest inicjowana zajściem warunku logicznego zależnego od wartości zmiennych synchronizujących lub/i aktualnego czasu. W przypadku konieczności zapisu z dużą częstotliwością wartości pojedynczych zmiennych należy stosować metody archiwizacji udostępniane przez moduł ASPAD.

AsBase przechowuje dane w bazie danych serwera Microsoft SQL Server - wersjach od 2000 wzwyż. Można wykorzystywać wersję MSDE tego serwera, która jest dostarczana bez dodatkowych kosztów w ramach systemu asix. Istnieje również możliwość stosowania tzw. wersji pełnych serwera, niemniej w takim przypadku użytkownik ponosi koszty zakupu odpowiednich licencji.

Zastosowanie standardowej bazy danych stwarza użytkownikom możliwość łatwego dostępu do danych aplikacji z innych programów, pisanych własnoręcznie lub standardowych (np. Microsoft Excel).

Zakres funkcji realizowanych przez moduł AsBase jest następujący:

  • wbudowany system budowy aplikacji,

  • zintegrowany z aplikacją system uprawnień dostępu,

  • automatyczna archiwizacja danych procesowych uruchamiana zgodnie z harmonogramem czasowym lub na podstawie wartości zmiennych procesowych,

  • możliwość ręcznej edycji (uzupełniania) archiwum,

  • edycja receptur,

  • ładowania wartości receptury do zmiennych procesowych,

  • rejestracja operacji ładowania receptur,

  • automatyczne ładowanie receptur w reakcji na zmiany wartości zmiennej procesowej,

  • podgląd bieżących wartości zmiennych procesowych z możliwością ręcznego uaktywnienia operacji zapisu do bazy danych aplikacji,

  • system analizy i wydruku archiwizowanych danych i receptur,

  • eksport danych do plików tekstowych, xls, xml i html,

  • wbudowany system zarządzania bazą danych,

  • możliwość sterowania pracą AsBase’a przy pomocy akcji operatorskich programu AS.


2.5. Słownik

W przypadku pól zestawów archiwizacji i grup receptur można zadeklarować sposób tłumaczenia wartości liczbowych na teksty. Słowniki używane są w części prezentacyjnej AsBase’a i ułatwiają interpretację przez użytkowników zarchiwizowanych danych lub wartości nastaw.

PRZYKŁAD

Aplikacja monitorująca. Pole „Włączenie palnika" można połączyć ze słownikiem „Stany załączeń" o poniżej definicji:

Wartość 0 – Wyłączony

Wartość 1 – Włączony


2. Podstawowe pojęcia

Do posługiwania się modułem AsBase konieczne jest zrozumienie pewnych pojęć, które zostały wyjaśnione w kolejnych podrozdziałach.


3.1. Pełna kontrola uprawnień

Każdy użytkownik zdefiniowany w aplikacji ma określone prawo do wykonywania poniższych operacji:

Administracja

Uprawnia do definiowania użytkowników, prawo do wykonywania kopii bazy danych,

włączanie/wyłączanie automatycznej archiwizacji.

Edycja aplikacji

Uprawnia do zmian definicji aplikacji za wyjątkiem zmieniania praw użytkowników, włączanie/wyłączanie automatycznej archiwizacji

Edycja receptur

Uprawnia do edycji i dodawania nowych receptur bez prawa do zmiany struktury grupy receptur.

Ładowanie receptur

Uprawnia do wykonania operacji ładowania receptury.

Pełna edycja archiwum

Uprawnia do ręcznej edycji i uzupełniania danych zestawu archiwizacji bez prawa do zmiany struktury.

Ograniczona edycja archiwum

Ograniczona edycja pozwala na zmianę w archiwum zestawu rejestracji tylko tych kolumn, które mają zezwolenie na edycję (w definicji pola zestawu rejestracji własność ‘Edycja’ została ustawiona przy pomocy obiektu checkbox na TAK).

UWAGA Edycja tych pól zestawu, które nie są związane z żadną zmienną w zestawach zmiennych, jest zablokowana dla wszystkich użytkowników.

Zapis archiwum

Uprawnia do ręcznego zapisu rekordu do zestawu archiwizacji. Zapisywane wartości muszą pochodzić z zestawu zmiennych związanego z zestawem archiwizacji. Zezwala także na edycję pól zestawu, które nie są połączone poprzez zestaw zmiennych z żadną zmienną procesową.

Zmiana wyglądu

Uprawnia do zmiany wyglądu wierszy/kart archiwów rejestracji i receptur, a w szczególności:

- tworzenie widoków:

- przesuwanie kolumn/wierszy;

- zmiana szerokości kolumny;

- zmiana rozmiaru karty;

- wybór kolumn.

Użytkownik bez uprawnień do zmiany wyglądu może przełączać zdefiniowane widoki, filtrować i sortować dane.

UWAGA Użytkownik z uprawnieniem Edycja aplikacji automatycznie ma uprawnienie do zmiany wyglądu wierszy/kart archiwów rejestracji i receptur.


3. System uprawnień

AsBase posiada własny system autoryzacji użytkowników i kontroli ich uprawnień. Możliwe są dwa tryby pracy:

Pełna kontrola uprawnień

Każdy użytkownik przed wykonaniem jakiejkolwiek operacji musi się zalogować w aplikacji. W bazie danych aplikacji zapisana jest informacja o wszystkich dopuszczonych użytkownikach, łącznie z ich uprawnieniami do wykonywania poszczególnych operacji.

Tryb anonimowy

W tym trybie nie ma operacji logowania użytkowników. AsBase pracuje w trybie administratora anonimowego lub użytkownika anonimowego. Wybór trybu pracy wykonywany jest w trakcie instalacji programu i nie można go później zmienić.


4.3.3. Menu Narzędzia

Menu Narzędzia zawiera poniższe komendy:

Logowanie

Komenda służy do zalogowania się użytkowników aplikacji. Komenda jest zablokowana w sytuacji, gdy aplikacja nie posiada zdefiniowanych użytkowników.

Wyłącz wymianę danych

Komenda służy do włączania i wyłączania automatycznej archiwizacji zestawów archiwizacji (działania warunków archiwizacji).

Zapisz kopie bazy danych

Komenda tworzy kopię zapasową bazy danych. Lokalizacja pliku kopii zapasowej wynika z parametryzacji serwera bazy danych.

Odtwórz bazę danych

Odtworzenie zawartości bazy danych AsBase’a na podstawie ostatnio utworzonej kopii zapasowej.

Importuj z bazy danych

Komenda pozwala na import danych konfiguracyjnych z utworzonej wcześniej bazy danych innej aplikacji AsBase’a.

Usuń bazę danych

Komenda pozwala na usunięcie zbędnych baz danych z serwera. Możliwe jest usunięcie tylko baz danych utworzonych przez AsBase’a.

Usuń dane

Komenda służąca do usuwania danych z tabel zestawów archiwizacji i grup receptur.

Eksportuj rekord do pliku XML

Komenda umożliwia zapisanie wybranego rekordu do pliku tekstowego w formacie XML. Dla tabel relacyjnych pozwala na zapisanie rekordu (wiersza) tabeli nadrzędnej razem z wszystkimi powiązanymi wierszami tabeli podrzędnej.

Konfiguruj

Otwarcie okna służącego do definiowania parametrów globalnych programu AsBase’a.

Wyłącz tryb administracyjny

Uruchamia operację wyłączenia trybu administratora anonimowego; operacja wymaga zatwierdzenia i jest nieodwracalna. Operacja znajduje zastosowanie w sytuacji, gdy istnieje potrzeba uniemożliwienia operatorowi dokonania ewentualnych zmian w aplikacji uruchomionej na komputerze przez niego obsługiwanym. Pozostawienie trybu administratora anonimowego daje sposobność dokonywania zmian w aplikacji pracującej w trybie anonimowym (bez zalogowanych użytkowników).


4.3. Menu i paski narzędzi

Menu AsBase’a i jego paski narzędzi są w pełni konfigurowalne. Użytkownik może dowolnie modyfikować zawartość menu i predefiniowanych pasków. Można też tworzyć własne paski narzędzi.

Funkcje konfiguracyjne menu i pasków są dostępne poprzez:

1. komendę Paski narzędzi dostępną na pasku narzędziowym Plik;

2. menu kontekstowe pasków;

3. lub przycisk o kształcie małego trójkąta obecny w menu i na każdym pasku narzędziowym.

Poniższe podrozdziały opisują komendy AsBase’a zgodnie z ich domyślnym uporządkowaniem.


4. Obsługa programu

Poniższa ilustracja pokazuje główne okno robocze AsBase’a.

Rysunek: Główne okno robocze programu AsBase.

Obszar okna dzieli się na następujące części:

  • Menu i paski narzędzi

Menu i opcjonalne paski narzędzi są w pełni konfigurowalne.

  • Drzewo nawigacyjne

Struktura drzewa nawigacyjnego zależy od uprawnień użytkownika i konstrukcji aplikacji. Kliknięcie na wybranym węźle przełącza zawartość panelu roboczego.

  • Panel roboczy

Główny element roboczy okna AsBase’a. Jego zawartość zależy od wybranego węzła drzewa nawigacyjnego.

  • Pasek statusu

Pasek zawierający pola informacyjne dotyczące aktualnego stanu aplikacji. Pola są aktywne, kliknięcie na polu powoduje wykonanie operacji z nim związanych.


6.4. Tabele historii ładowań receptur

7.4. Tabele historii ładowań receptur

Nazwa tabeli historii ładowań receptur dla grupy receptur tworzona jest według wzorca:

RECIPELOAD_<identyfikator grupy>

W skład tabeli historii ładowań wchodzą następujące pola:

  • ID

Typ - int

Unikalny identyfikator rekordu.

  • NAME

Typ &endash; varchar(50)

Nazwa załadowanej receptury.

  • LOADBY

Typ &endash; varchar(20)

Określa kto załadował recepturę: identyfikator użytkownika lub nazwa komputera.

  • LOCALTIME

Typ - datetime

Czas lokalny załadowania receptury.

  • UTCTIME

Typ - datetime

Czas UTC załadowania receptury.

  • STATUS

Typ - int

Status w konwencji OPC wykonania operacji załadowania.

  • V_<identyfikator pola>

Typ &endash; zależny od wybranego typu pola

Załadowana wartość pola receptury. Jest to wartość pola, która obowiązywała w chwili wykonywania operacji ładowania.

Pole typu V_ powtarza się dla każdego pola grupy receptur.

  • BATCH

Typ - float

Pole zawierające wartość wsadu, wykorzystywane do wyliczania wartości zmiennych receptur przeliczalnych.

  • VP_<identyfikator_pola>

Typ - float

Pola dodawane tylko do receptur przeliczalnych, w których definicji oznaczono pole Rejestruj %. Pola te zawierają nieprzeliczone wartości procentowe.


AsBase

Spis treści

1. Przeznaczenie modułu AsBase

2. Podstawowe pojęcia

2.1. Zestaw archiwizacji

2.2. Grupa receptur

2.3. Receptura

2.4. Zestaw zmiennych

2.5. Słownik

2.6. Warunek archiwizacji

2.7. Automatyczna receptura

3. System uprawnień.

3.1. Pełna kontrola uprawnień

3.2. Tryb anonimowy

4. Obsługa programu.

4.1. Struktura plików

4.2. Uruchomienie programu

4.3. Menu i paski narzędzi

4.3.1. Menu Plik

4.3.2. Menu Widok

4.3.3. Menu Narzędzia

4.3.4. Menu Pomoc

4.4. Pasek statusu

4.5. Drzewo nawigacyjne

4.6. Panel roboczy

4.6.1. Panel konfiguracji

4.6.2. Panel użytkowników

4.6.3. Panele definiowana zestawów rejestracji i grup receptur

4.6.4. Panele definiowania zestawu rejestracji i grupy receptur

4.6.5. Panel definiowania zestawu zmiennych

4.6.6. Panel warunków rejestracji

4.6.7. Panel automatycznych receptur

4.6.8. Panel słowników

4.6.9. Panel zarządzania recepturami

4.6.10. Panel historii ładowań receptur

4.6.11. Panel archiwum zestawu rejestracji

4.6.12. Panel podglądu zestawu zmiennych

5. Akcje operatorskie

6. Struktura bazy danych

6.1. Nazwa bazy danych

6.2. Tabele archiwum zestawów rejestracji

6.3. Tabele wartości receptur

6.4. Tabele historii ładowań receptur

7. Indeks

8. Spis rysunków


Deklaracja źródła pozyskiwania danych

5.1.4. Deklaracja źródła pozyskiwania danych procesowych


Obsługa tabel

4.6.2. Obsługa tabel

Tabele występują w dwóch formach: prostej lub dwupoziomowej. W drugim przypadku na pierwszym poziomie wyświetlana jest główna zawartość panelu (np. nazwy wszystkich grup receptur), natomiast z każdym wierszem pierwszego poziomu związana jest tzw. tabela szczegółów, która pokazuje informacje dotyczące tylko tego wiersza (np. tabela pól grupy receptur).

Rysunek: Przykład tabeli dwupoziomowej: tabela główna - zestawienie wszystkich grup receptur; tabela szczegółów - zestawienie wszystkich pól dla jednej konkretnej grupy receptur.

Każda tabela posiada własny pasek narzędziowy wyświetlany na dolnej ramce tabeli, służący do obsługi tabeli. Oprócz tego można użyć menu kontekstowego tabeli, które udostępnia dodatkowy zestaw operacji. Menu kontekstowe wyświetlane jest poprzez kliknięcie lewym klawiszem myszki w obszarze nagłówka wierszy lub w obszarze nagłówków karty (jeśli dostępny jest typ prezentacji tabeli w formie karty).

Dodanie wiersza do tabeli odbywa się poprzez kliknięcie w obszarze nowego wiersza (o ile taki jest pokazywany), przyciśnięcie klawisza insert lub przy pomocy przycisku [image] paska narzędzi tabeli.

Jeżeli informacje w danym wierszu tabeli zostaną zmienione, to muszą być zatwierdzone przez użytkownika. Zatwierdzenie jest automatyczne po przejściu do innego wiersza tabeli lub wykonywane przy pomocy przycisku [image] paska narzędzi tabeli.


Panel historii ładowań receptur

4.6.16. Panel historii ładowań receptur

Panel historii ładowań receptur służy do przeglądania zarejestrowanych operacji załadowania receptury dla pojedynczej grupy receptur.

Rysunek: Panel historii ładowań receptur.

W tabeli receptur, znajduje się kolumna nazw receptur, kolumna czasu wykonania załadowania, kolumna statusu operacji oraz kolumny wartości dla wszystkich zdefiniowanych pól grupy receptur. Opcjonalnie można włączyć (przy pomocy komendy Wybór pól lub Wszystkie kolumny menu kontekstowego tabeli) kolumnę czasu ładowania przeliczonego na czas UTC, kolumnę identyfikatora użytkownika (który załadował recepturę) i kolumnę zestawu zmiennych, do którego receptura była ładowana.

Kolumny wartości pól receptury pokazują wartości, które obowiązywały dla danej receptury w chwili wykonania operacji załadowania. Mogą się różnić od bieżących, jeżeli receptura została później zmodyfikowana.


Panel podglądu zestawu zmiennych

4.6.18. Panel podglądu zestawu zmiennych

Panel podglądu zestawu zmiennych pozwala na kontrolę bieżących wartości zmiennych procesowych wchodzących w skład zestawu. Panel pozwala też na wykonanie operacji załadowania receptury i ręcznej zarejestrowanie wartości.

Rysunek: Panel podglądu zestawu zmiennych dla receptur.

Rysunek: Panel podglądu zestawu zmiennych dla zestawu rejestracji.

Kolumny pokazywane w tabeli to:

Nazwa

Nazwa pola grupy receptur lub zestawu archiwizacji, z którym zmienna jest związana.

Nazwa zmiennej

Nazwa monitorowanej zmiennej procesowej.

Wartość

Aktualna wartość zmiennej.

Jakość

Jakość pokazywanej wartości. Oryginalny status w formacie OPC jest tłumaczony na jego odpowiednik tekstowy.

Czas

Czas odczytu zmiennej.

Operacja załadowania receptury polega na wybraniu w polu „Nazwa receptury" receptury, która ma zostać załadowana i użyciu przycisku Załaduj recepturę.

Żeby utworzyć nową recepturę na podstawie aktualnych wartości zmiennych należy w polu Nazwa receptury podać nazwę nowej receptury i przycisnąć Zarejestruj wartości.

Zapis rekordu dla zestawu rejestracji polega tylko na przyciśnięciu klawisza Zarejestruj wartości.


Panel słowników

4.6.14. Panel słowników

Panel słowników służy do definiowania słowników pozwalających na translację wartości numerycznych pól zestawów rejestracji i grup receptur na ich odpowiedniki tekstowe.

Rysunek: Panel słowników.

Tabela główna pozwala na edycję nazw i opisów słowników. W tabelach szczegółów definiowane są teksty słownika wraz z odpowiadającymi im wartościami liczbowymi.


Panel użytkowników

4.6.6. Panel użytkowników

Panel użytkowników służy do zarządzania bazą użytkowników aplikacji AsBase’a. Dostępny jest w dwóch formach: tabeli lub kart użytkowników.

Rysunek: Panel użytkowników - karty użytkowników.

Znaczenie pól jest następujące:

Identyfikator

Identyfikator logowania.

Nazwa

Opisowa nazwa użytkownika.

Hasło

Hasło logowania użytkownika.

Uprawnienia

Grupa pól wyboru poszczególnych uprawnień. Opis ich szczegółowego znaczenia znajduje się w rozdziale Pełna kontrola uprawnień.


Panel zarządzania recepturami

4.6.15. Panel zarządzania recepturami

Panel zarządzania recepturami służy do kompleksowej obsługi receptur należących do pojedynczej grupy receptur.

Możliwe jest dodawanie nowych receptur, edycja i kasowanie istniejących.

Panel dysponuje też mechanizmami do przeglądania i analizy puli receptur (patrz: Widoki tabeli).

Możliwe jest także wykonanie operacji załadowania wskazanej receptury.

Rysunek: Panel zarządzania recepturami &endash; grupa receptur.

W tabeli receptur, znajduje się kolumna nazw receptur, kolumny wartości dla wszystkich zdefiniowanych pól grupy receptur oraz dostępne są pola systemowe ID, Użytkownik i Czas.

Pole Wsad wykorzystywane jest w recepturach przeliczalnych do obliczenia wartości poszczególnych pól przeliczalnych zdefiniowanych jako % wsadu. Pole to występuje również dla receptur bez pól przeliczalnych - należy go wówczas pozostawić puste.

Żeby załadować recepturę, należy w tabeli wyselekcjonować właściwy wiersz, a w polu Zestaw zmiennych wybrać nazwę zestawu zmiennych, który ma służyć jako miejsce przesłania wartości receptur. Operację inicjuje się przyciskiem Załaduj recepturę. Wszystkie operacje załadowania receptury są rejestrowane.