Witamy

www.asix.com.pl

AsService – moduł systemu Asix

dla gospodarki remontowej urządzeń, umożliwiający rejestrację i raportowanie czasów pracy, eksploatacji oraz ilości załączeń i awarii

Dok. Nr PLH7200

Wersja: 2013-05-23


Wprowadzenie

1 Wprowadzenie

AsService to moduł systemu Asix umożliwiający rejestrację czasów pracy oraz liczby załączeń urządzeń (również dwukierunkowych) na podstawie danych pobieranych z aplikacji Asixa. Dzięki temu możliwe jest monitorowanie konieczności wykonania czynności konserwacyjno-remontowych, alarmowanie i raportowanie przekroczeń z tym związanych oraz gromadzeniem danych technicznych i ewidencyjnych każdego nadzorowanego urządzenia.

Funkcjonalność modułu AsService realizowana jest w oparciu o zliczanie ilości wystąpień wartości bitowych odpowiadających stanom załączenia/wyłączenia oraz czasów trwania stanu załączenia dla poszczególnych liczników przypisanych do urządzeń. W oparciu o te dane prowadzona jest detekcja momentów, w których należy wykonać dla poszczególnych urządzeń czynności konserwacyjne, remontowe lub wymianę na nowe.

Ilości załączeń oraz czasów pracy urządzeń wyliczane są w postaci agregatów przez moduł archiwizacji danych systemu Asix. Stan każdego urządzenia opisuje pojedynczy bit słowa statusowego, którego wartość (1-pracuje; 0-postój) przechowywana jest w pojedynczej zmiennej podlegającej agregacji. Każdy z liczników modułu AsService charakteryzujący pracę danego urządzenia odwołuje się do jednej takiej zmiennej zdefiniowanej w bazie definicji zmiennych aplikacji Asixa oraz określonego agregatu: zliczającego ilości załączeń (zmiana wartości bitu z 0 na 1) lub zliczającego czas pracy urządzenia (odcinek czasu, w którym bit przyjmował wartość 1).

Wartości wspomnianych zmiennych (i ich agregatów) przypisanych do poszczególnych liczników archiwizowane są w systemie Asix przez moduł Aspad, a sposób tej archiwizacji parametryzowany jest w ramach aplikacji Asixa przy użyciu programu Architekt. Współpracę pomiędzy aplikacją Asixa i środowiskiem modułu AsService zapewnia baza danych AsixConnect, której procedury składowane za pośrednictwem programu Askom.Data.Host udostępniają dane procesowe z aplikacji Asixa do modułu AsService. Na tej podstawie AsService na bieżąco uzupełnia i aktualizuje wartości liczników i dokonuje zapisów tych wartości do swojej bazy MS SQL z częstotliwością odświeżania danych ustalaną przez użytkownika. Oprócz zapisów bieżących wartości liczników, AsService archiwizuje również rekordy danych charakteryzujące stany liczników w momencie ich resetu (1 rekord odpowiada jednemu licznikowi, a zapis kolejnego rekordu danych wybranego licznika inicjowany jest momentem resetu tego licznika).

Rys. AsService - architektura systemu.

UWAGA:

Aktualny interfejs modułu AsService daje możliwość przeglądania bieżących wartości liczników oraz rekordów danych historycznych opisujących stany liczników (m.in. czas startu , czas resetu, wartość początkowa, wartość bieżąca, itd.) na moment ich resetu (patrz: 13. Przeglądanie archiwum czynności eksploatacyjnych). Nie ma natomiast możliwości przeglądania wszystkich archiwalnych wartości liczników, które wpisywane są do bazy AsService zgodnie z częstotliwością odświeżania wartości zmiennych licznikowych pobieranych z archiwum Asixa.

zoom in

Rys. Okno modułu AsService - zestaw liczników.


Dokumenty

1.2 Dokumenty

Dla każdego urządzenia istnieje możliwość określenia zestawu dokumentów elektronicznych związanych z jego eksploatacją - takich jak: dokumentacja techniczno-ruchowa, instrukcje obsługi, protokoły badań, schematy technologiczne i inne.

Użytkownik ma możliwość w każdym momencie dołączenia do urządzenia dokumentu poprzez podanie jego lokalizacji na dysku lokalnym lub sieciowym.

zoom in

Rys. Okno modułu AsService - definicja urządzenia/załącznik w postaci dokumentu.


Liczniki czasu pracy

1.3.1 Liczniki czasu pracy

Liczniki czasu pracy urządzenia podają aktualny czas pracy urządzenia (w zadanym formacie czasu: sekunda, minuta, godzina, dzień, miesiąc = 30 dni) liczony od ostatniego resetu licznika. Wartość licznika zmienia się przyrostowo po każdorazowym odświeżeniu danych z aplikacji Asixa.

Resety liczników czasu pracy wykonywane przez obsługę typowo związane są z następującymi zdarzeniami (projektant może zdefiniować inne przyczyny resetów):

  • Wymiana (dedykowany licznik główny)

  • Remont

  • Konserwacja

  • Przegląd

Resety liczników czasu pracy wykonywane automatycznie związane są z następującymi zdarzeniami (w tym przypadku przyczyny resetów zostały zaprogramowane i nie podlegają modyfikacji przez użytkownika):

  • Koniec zmiany produkcyjnej

  • Koniec doby

  • Koniec miesiąca


Liczniki okresowe

1.3.3 Liczniki okresowe

Liczniki okresowe urządzenia podają liczbę dni jaka upłynęła od zadanego momentu czasu. Wartość licznika zmienia się automatycznie po rozpoczęciu nowego dnia.

Resety liczników okresowych wykonywane przez obsługę związane są typowo z następującymi zdarzeniami (projektant może zdefiniować inne przyczyny resetów):

  • Wymiana (dedykowany licznik główny – określający okres czasu przez jaki urządzenie jest eksploatowane na obiekcie)

  • Koniec okresu (badanie elektryczne, badanie UDT, koniec atestu, koniec dopuszczenia, koniec gwarancji, ...)


Licznik czasu braku danych

1.3.4 Licznik czasu braku danych

Dla każdego licznika moduł AsService prowadzi automatycznie licznik czasu braku danych. Wartość ta rejestrowana jest w momencie resetu licznika w rekordzie danego zdarzenia resetu (patrz: 13 . Przeglądanie archiwum czynności eksploatacyjnych).


Wymagania programowe

2 Wymagania systemowe

Wymagania zgodne z systemem Asix (wersji pełnej bez modułów przeglądarkowych):

  • system operacyjny Windows

  • Windows Installer 4.5

  • Windows Power Shell 1.0

  • Microsoft .NET Framework 4.0

  • instalacja serwerowa MS SQL Server, wersja z usługą SQL Server Agent

Do współpracy systemu Asix z modułem AsService wymagana jest instalacja serwera MS SQL Server w wersji pozwalającej na konfigurację ustawień Agenta SQL Server. Dla zalecanej wersji serwera: MS SQL 2008 R2 - wymagana jest wersja wyższa niż SQL Express.

UWAGA:

Darmowa wersja serwera MS SQL Express nie posiada programowalnej usługi SQL Server Agent.


Instalacja pakietu

3. Instalacja modułu AsService

Instalacja modułu AsService przebiega w następujących krokach:

1. Uruchomienie programu instalacyjnego przy użyciu ikony [image].

2. Kontrola konta użytkownika (wymagane uprawnienia administratora).

Rys. Okno 'Kontrola konta użytkownika'.

3. Przygotowanie programu instalacyjnego do uruchomienia.

Rys. Okno kreatora instalacji pakietu instalacyjnego.

4. Wybór typu instalacji.

Rys. Okno wyboru typu instalacji.

5. Wskazanie miejsca na dysku oraz folderu modułu AsService.

Rys. Okno wyboru ścieżki instalacyjnej modułu.

Rys. Okno wyboru folderu modułu.

6. Zakończenie instalacji.

Rys. Okno zakończenia instalacji modułu.


Aktywacja licencji

4.1. Aktywacja licencji

Przygotowanie kodów potrzebnych do aktywacji klucza modułu AsService (według zakupionej licencji warunkującej ilość liczników możliwych do zdefiniowania) wymaga wykonania następujących kroków w dwóch etapach:

Przygotowanie kodów potrzebnych do aktywacji klucza

1. Uruchomienie programu AsServiceLicense.exe.

2. Skopiowanie kodów (miejsca i MID) do schowka - przy użyciu polecenia Kopiuj kody.

3. Przesłanie emailem kodów do firmy ASKOM.

Rys. Okno programu do aktywacji licencji.

Wprowadzenie kodu aktywacji

1. Uruchomienie programu AsServiceLicense.exe.

2. Skopiowanie otrzymanego mailem z Askom kodu aktywacyjnego do programu do pola Kod aktywacji.

3. Aktywacja klucza programowego przy użyciu polecenia Aktywuj.

Rys. Aktywacja klucza programowego.

Rys. Status licencji AsService po aktywacji klucza programowego.


Zmiana licencji

4.2. Zmiana licencji

Zmiana licencji wymaga wykonania następujących kroków:

Przygotowanie kodów potrzebnych do aktywacji klucza

1. Uruchomienie programu AsServiceLicense.exe.

2. Wywołanie okna zmiany licencji przy użyciu polecenia Zmień licencję.

3. Skopiowanie kodów (miejsca i MID) do schowka - przy użyciu polecenia Kopiuj kody.

4. Przesłanie emailem kodów do firmy ASKOM.

Rys. Okno zmiany licencji.

Wprowadzenie kodu aktywacji

1. Uruchomienie programu AsServiceLicense.exe.

2. Wywołanie okna zmiany licencji przy użyciu polecenia Zmień licencję.

3. Skopiowanie otrzymanego mailem z Askom kodu aktywacyjnego do okna do pola Kod aktywacji.

4. Aktywacja klucza programowego przy użyciu polecenia Aktywuj.


Usunięcie licencji

4.3. Usunięcie licencji

Usunięcie licencji (w celu np. przeniesienia instalacji na inny komputer) wymaga wygenerowania kodu usunięcia, który stanowić będzie podstawę do udostępnienia przez firmę Askom kodu aktywacyjnego dla serwera AsService, gdy zostanie on zainstalowany na innym komputerze. Wymaga to wykonania następujących kroków:

Wygenerowanie kodu usunięcia

1. Uruchomienie programu AsServiceLicense.exe.

2. Wywołanie okna z kodem usunięcia przy użyciu polecenia Usuń licencję.

UWAGA:

Należy zapamiętać kod usunięcia, ponieważ będzie on niezbędny, aby otrzymać nowy kod aktywacyjny.

Rys. Kod usunięcia licencji AsService.

Po zainstalowaniu serwera AsService w nowej lokalizacji, aby aktywować licencję, należy postępować zgodnie z krokami opisanymi w rozdziale 4.1. Aktywacja licencji, z ta różnicą, ze wysyłając do Askomu kody (miejsca i MID), należy dodatkowo przesłać kod usunięcia poprzedniej instalacji.


Konfiguracja dostępu do danych aplikacji Asix

5 Konfiguracja dostępu do danych aplikacji Asix

Przystępując do pracy z modułem AsService należy w pierwszej kolejności zainstalować serwer MS SQL Server 2008 R2.

Kolejny etap przygotowania dostępu do danych procesowych aplikacji, które staną się źródłem danych dla liczników - to konfiguracja środowiska systemu raportowania AsRaport, która obejmuje następujące kroki omówione w kolejnych rozdziałach dokumentacji:

1. Utworzenie bazy danych AsixConnect

2. Parametryzacja dostępu do bazy definicji zmiennych

3. Uruchomienie programu Askom.Data.Host.exe

UWAGA:

Wymagane jest, aby instalacja serwerowa modułu AsService i instalacja serwera SQL z bazą AsixConnect znajdowały się na tym samym komputerze. Należy również bazę SQL modułu AsService umieścić na tym samym serwerze SQL co bazę AsixConnect.


Utworzenie bazy danych AsixConnect

5.1 Utworzenie bazy danych AsixConnect

Procedury składowane bazy danych AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają do modułu AsService dane procesowe z aplikacji Asixa.

Baza danych AsixConnect tworzona jest za pośrednictwem programu Architekt – jest to pierwszy krok, jaki należy wykonać, przygotowując w systemie Asix środowisko do przekazywania danych do liczników modułu AsService.

UWAGA: Baza danych AsixConnect jest niezbędna do pracy AsService w oparciu o dane procesowe Asixa.

UWAGA: Utworzenie bazy danych AsixConnect jest jednym z elementów konfigurowania środowiska systemu raportowania AsRaport.

Aby utworzyć bazę danych AsixConnect z dostępem do danych aplikacji systemu Asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa, w której zdefiniowane zostały zmienne licznikowe. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk programu AsixEvo.exe.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport > zakładka Baza danych AsixConnect/Lokalizacja i logowanie

3. Wybierz nazwę serwera MS SQL dla bazy danych AsixConnect, określ sposób weryfikacji użytkowników i kliknij przycisk Utwórz bazę.

zoom in

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect.

Dostępne są trzy sposoby weryfikacji użytkowników dla bazy danych AsixConnect:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika ‘_asix_internal’ zdefiniowanego w serwerze MS SQL – domyślnie utworzonego w momencie instalowania pakietu Asix (warunkiem utworzenia takiego użytkownika jest zainstalowanie serwera MS SQL przed rozpoczęciem instalacji pakietu Asix)

3. Weryfikacja wg użytkownika serwera MS SQL, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport przed utworzeniem bazy danych AsixConnect.


Uruchomienie programu Askom.Data.Host.exe

3.3 Uruchomienie programu Askom.Data.Host.exe

Aby możliwe było pobieranie danych procesowych z aplikacji Asixa, w której zdefiniowane zostały zmienne licznikowe, musi być przez cały czas uruchomiony program Askom.Data.Host.

Askom.Data.Host.exe domyślnie umieszczany jest przez instalator pakietu Asix w katalogu głównym pakietu C:\Program Files\Askom\Asix.

W przypadku aplikacji Asixa ze skonfigurowanym środowiskiem AsRaport program Askom.Data.Host uruchamiany jest automatycznie na starcie w/w aplikacji, gdy zadeklarowana zostanie opcja Startuj Askom.Data.Host w programie Architekt:

Architekt > Obszary i komputery > Parametry startowe > Programy > Askom.Data.Host

Domyślnie program Askom.Data.Host i baza AsixConnect znajdują się na tym samym komputerze fizycznym. Konfigurator systemu raportowania AsRaport (omawiany w poprzednich rozdziałach) na zakładce Baza danych Asix.Connect/Serwer danych Askom.Data.Host daje możliwość określenia innego położenia programu Askom.Data.Host.


Pobieranie danych z Asixa

6 Pobieranie danych z Asixa

Wartości liczników definiowanych w module AsService pobierane są z agregatów zmiennych zdefiniowanych w ramach aplikacji systemu Asix. Zmienna utworzona dla danego urządzenia odwołuje się do pojedynczego bitu słowa statusowego opisującego pracę w/w urządzenia (1-pracuje, 0-postój). Mechanizmem, który przygotowuje dane do określenia: czasów pracy, liczby załączeń oraz czasu braku danych dla urządzeń – jest agregator modułu Aspad, który wylicza dla zmiennych licznikowych potrzebne agregaty. Procedury składowane bazy AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają wyliczone wartości agregatów z aplikacji Asixa do modułu AsService.

Liczniki czasu pracy oraz załączeń wyświetlane w module AsService zmieniają swoje wartości przyrostowo po każdorazowym odświeżeniu danych z aplikacji systemu Asix. AsService uzupełnia i aktualizuje wartości liczników i dokonuje zapisów tych wartości do swojej bazy MS SQL z częstotliwością odświeżania danych ustalaną przez użytkownika. Każda aktualizacja danych wiąże się ze sprawdzeniem progów eksploatacyjnych. Oprócz zapisów bieżących wartości liczników AsService archiwizuje również rekordy danych charakteryzujące stany liczników w momencie ich resetu (jeden rekord odpowiada jednemu licznikowi, a zapis kolejnego rekordu danych wybranego licznika inicjowany jest momentem resetu tego licznika).

Każdy z liczników modułu AsService zwiera zatem w swojej definicji nazwę zmiennej, agregat systemu Asix oraz częstotliwość odświeżania danych. Wyjątkiem są liczniki okresowe, które są wewnętrznymi licznikami modułu AsService niezależnymi od wartości zmiennych systemu Asix - zmianę wartości dla tego licznika wymusza rozpoczęcie nowej doby.

UWAGA:

Aktualny interfejs modułu AsService daje możliwość przeglądania bieżących wartości liczników oraz rekordów danych historycznych opisujących stany liczników (m.in. czas startu, czas resetu, wartość początkowa, wartość bieżąca, itd.) na moment ich resetu (patrz: 13 . Przeglądanie archiwum czynności eksploatacyjnych ). Nie ma natomiast możliwości przeglądania wszystkich archiwalnych wartości liczników, które wpisywane są do bazy AsService zgodnie z częstotliwością odświeżania wartości zmiennych licznikowych pobieranych z archiwum Asixa.


Deklaracja zmiennych licznikowych

6.1 Deklaracja zmiennych licznikowych

Przykład uproszczonej deklaracji zmiennych, z których wyliczane są agregaty dla liczników modułu AsService w przypadku urządzeń jednokierunkowych:

zoom in

Rys. Deklaracja zmiennych dla liczników urządzeń jednokierunkowych.

Deklaracja funkcji przeliczającej dla zmiennej charakteryzującej pracę urządzenia jednokierunkowego:

Funkcja CYRK1 dokonuje przekształcenia wartości zmiennej procesowej odczytanej ze sterownika na jedną z liczb 16-bitowych bez znaku znajdujących się w tablicy przypisanej danej zmiennej procesowej. Zawartość oraz rozmiar tablicy określany jest na podstawie deklaracji zmiennej procesowej. Przekształcenie polega na odnalezieniu pozycji pierwszego niezerowego bitu w 16 bitowej liczbie odczytanej ze sterownika i użycia tej pozycji jako indeksu przy odczycie z tablicy. Poszukiwanie niezerowego bitu rozpoczyna się od bitu podanego w deklaracji zmiennej i kontynuuje w stronę malejących rangą bitów. Liczba testowanych bitów podana jest w deklaracji zmiennej. W przypadku, gdy odczytane słowo jest równe 0, to jako wartość zwracany jest ostatni parametr, podany przy deklaracji zmiennej procesowej.

Przykład uproszczonej deklaracji zmiennych, z których wyliczane są agregaty dla liczników modułu AsService w przypadku urządzenia dwukierunkowego:

1 wariant

Deklarowane są dwie zmienne odwołujące się do osobnych bitów słowa statusowego urządzenia/napędu. W AsRemoncie należy wówczas zduplikować liczniki – tworząc zestaw liczników odwołujących się do zmiennej charakteryzującej pracę urządzenia w lewo i identyczny zestaw dla drugiej zmiennej charakteryzującej pracę urządzenia w prawo. Wariant ten pozwala uzyskać 2 rodzaje wartości: ilość załączeń/czas pracy urządzenia w prawo i ilość załączeń/czas pracy urządzenia w lewo. Aby uzyskać wartości sumaryczne ilości załączeń/czasu pracy urządzenia, należy zastosować wariant 2.

zoom in

Rys. Deklaracja zmiennych dla liczników urządzenia dwukierunkowego.

Deklaracja funkcji przeliczającej dla zmiennej charakteryzującej pracę urządzenia/napędu w lewo:

Deklaracja funkcji przeliczającej dla zmiennej charakteryzującej pracę urządzenia/napędu w prawo:

2 wariant

Deklarowana jest jedna zmienna odwołująca się do dwóch bitów słowa statusowego urządzenia/napędu. W AsRemoncie tworzony jest jeden zestaw liczników odwołujący się do zmiennej charakteryzującej pracę urządzenia w lewo i w prawo jednocześnie. Dzięki odpowiedniemu sparametryzowaniu funkcji CYRK1, zmienna przyjmuje wartość 1 w przypadku pracy urządzenia/napędu w prawo lub w lewo.

zoom in

Rys. Deklaracja zmiennej dla liczników urządzenia dwukierunkowego.

Deklaracja funkcji przeliczającej dla zmiennej charakteryzującej pracę urządzenia dwukierunkowego (w lewo i w prawo):


Parametryzacja archiwizacji zmiennych licznikowych /

6.2 Parametryzacja archiwizacji zmiennych licznikowych / deklaracja agregatów

Dla zmiennych charakteryzujących pracę urządzeń należy zadeklarować wyliczanie następujących agregatów:

- Całka_Ostatnia_Znana (ang. Total_Last_Known ) - dla licznika czasu pracy;

- Suma_Wzrostów (ang. Sum_Up) - dla licznika załączeń;

- Jakość_Niepewna_Czas i Jakość_Zła_Czas (ang. Quality_Uncertain_Duration i Quality_Bad_Duration) - ich suma to wartość dla licznika czasu braku danych.

(Liczniki okresowe są czasomierzami wewnętrznymi modułu AsService, niezależnymi od wartości zmiennych systemu Asix).

Deklaracji i parametryzacji archiwum zmiennych licznikowych należy dokonać przy użyciu modułu Architekt:

Architekt > Obszary i komputery > Dane archiwalne > <pozycja dodanego archiwum> zakładka Standardowe oraz Agregaty

zoom in

Rys. Deklaracja archiwum zmiennych licznikowych.

zoom in

Rys. Deklaracja agregatów dla zmiennych licznikowych.

Zalecane jest ustawienie progu jakości dobrej dla danych archiwalnych na poziomie 80%. Oznacza to, że agregat ma jakość dobrą, jeżeli w interwale liczba próbek dobrych jest równa lub przekracza zadany próg jakości dobrej.

Deklaracji progu jakości należy dokonać przy użyciu modułu Architekt:

Architekt > Aplikacja > Dane archiwalne > Konfiguruj system raportów AsRaport... > zakładka Opcje

Rys. Deklaracja progów jakości dla danych archiwalnych.


Wprowadzanie danych ewidencyjnych urządzeń do rejestru /

9 Wprowadzanie danych ewidencyjnych urządzeń do rejestru / usuwanie, edycja i przeglądanie danych

Rejestr urządzeń uruchamiany jest poleceniem Urządzenia znajdującym się na liście kategorii danych ewidencyjnych (rozwijanej poleceniem Konfiguracja dostępnym zarówno w menu głównym programu lub też bezpośrednio z poziomu okna głównego).

zoom in

Rys. Okno AsService – karta ewidencji urządzenia / tabela urządzeń.

Panel danych ewidencyjnych urządzeń składa się z dwóch części:

- tabeli Urządzenia, która wyświetla rekordy wszystkich zdefiniowanych w rejestrze urządzeń.

- karty Szczegóły urządzenia zawierającej dane ewidencyjne pojedynczego urządzenia; wskazanie rekordu wybranego urządzenia w tabeli Urządzenia powoduje wyświetlenie danych tego urządzenia na karcie Szczegóły urządzenia.

***

Każdy rekord w tabeli Urządzenia odpowiadający jednemu urządzeniu ma opcję podglądu wszystkich liczników i dokumentów związanych z danym urządzeniem. Wystarczy wybrać przycisk [image] znajdujący się w polu Urządzenie i zostanie wyświetlona tabela z dwiema zakładkami: Liczniki urządzenia – z zestawem liczników oraz Dokumenty - z zestawem dokumentów eksploatacyjnych, zadeklarowanych dla urządzenia. Kliknięcie na zakładkę Dokumenty i wskazanie dowolnego dokumentu poprzez dwukrotne kliknięcie spowoduje uruchomienie okna Szczegóły dokumentu (patrz: 9.1 .Dołączanie dokumentów elektronicznych do deklaracji urządzeń / przeglądanie zawartości dokumentów).

zoom in

Rys. Okno modułu AsService - widok zestawu liczników i dokumentów powiązanych z rekordem danych ewidencyjnych urządzenia.

***

Aby utworzyć rekord nowego urządzenia:

1. Należy w pasku narzędziowym umieszczonym w dolnej części karty Szczegóły urządzenia wybrać przycisk [image] .

2. Po wypełnieniu niżej opisanych pól należy rekord zapisać, wybierając przycisk [image] .

Chcąc dokonać edycji wartości istniejącego rekordu urządzenia:
Należy wybrać przycisk [image], który aktywuje edycję wybranego rekordu (pola nie podlegające edycji są wyszarzone). Zmiany edycyjne należy zatwierdzić przyciskiem [image]. Z kolei przycisk [image] anuluje wprowadzone zmiany edycyjne.

Aby usunąć rekord wybranego urządzenia:

1. Należy w pasku narzędziowym umieszczonym w dolnej części karty Szczegóły urządzenia wybrać przycisk [image] .

***

Pozostałe przyciski paska narzędziowego umożliwiają wykonanie następujących czynności na rekordach urządzeń:

- przejście do pierwszego rekordu;

- przejście o 10 rekordów wstecz;

- przejście o 1 rekord wstecz;

- przejście o 1 rekord do przodu;

- przejście o 10 rekordów do przodu;

- przejście do przodu do ostatniego rekordu;

- dołączenie do rekordu danych urządzenia dokumentu elektronicznego związanego z eksploatacją urządzenia;

***

Poniższe zestawienie określa pola, które opisują urządzenie w ewidencji:

Urządzenie - nazwa urządzenia (fabryczna, zwyczajowa, …);

Identyfikator - identyfikator urządzenia; unikalny widoczny dla obsługi symbol alfanumeryczny urządzenia, jednoznacznie identyfikujący je; nadawany przez projektanta (np. zmienna statusowa napędu);

Symbol - symbol alfanumeryczny urządzenia jednoznacznie identyfikujący je w module AsService, nadany przez użytkownika lub projektanta (np. KKS);

Grupa - przypisuje urządzenie do zbioru urządzeń posiadającego wspólne cechy (napędy, zawory, styczniki, ...), wybieranego ze słownika tworzonego na bieżąco przez użytkownika;

Producent - nazwa producenta urządzenia, wybierana za słownika tworzonego na bieżąco przez użytkownika;

Status - status urządzenia, wybierana za słownika tworzonego na bieżąco przez użytkownika;

Wydział - pierwszy poziom lokalizacji urządzenia, wybierany ze słownika tworzonego na bieżąco przez użytkownika;

Linia - drugi poziom lokalizacji urządzenia, wybierany ze słownika tworzonego na bieżąco przez użytkownika;

Maszyna - trzeci poziom lokalizacji urządzenia, wybierany ze słownika tworzonego na bieżąco przez użytkownika;

Nr ewidencyjny - numer ewidencyjny urządzenia w ramach przedsiębiorstwa;

Stan techniczny - określenie stanu technicznego urządzenia (np. bardzo dobry, dobry, zły), wybierany ze słownika tworzonego na bieżąco przez użytkownika;

Nr fabryczny - numer fabryczny urządzenia;

Rok produkcji - rok produkcji urządzenia;

Data zakupu - data zakupu urządzenia;

Dostawca - nazwa dostawcy urządzenia, wybierana za słownika tworzonego na bieżąco przez użytkownika;

Rodzaj zasilania - rodzaj zasilania urządzenia, wybierany za słownika tworzonego na bieżąco przez użytkownika;

Moc zasilania - moc zasilania urządzenia;

Wymiary - wymiary urządzenia;

Masa - masa całkowita urządzenia;

Urządzenie wirtualne - flaga informująca, czy mamy do czynienia z urządzeniem fizycznym lub wirtualnym. Urządzenie wirtualne może być wykorzystane do np. określania czasu pracy układu w trybie „manual”, czasu pracy elektrowni w trybie „wyspowym”, liczby logowań poszczególnych operatorów, itd.

Opis – szczegółowy opis urządzenia;


Dołączanie dokumentów elektronicznych do deklaracji

9.1 Dołączanie dokumentów elektronicznych do deklaracji urządzeń / przeglądanie zawartości dokumentów

Dla każdego urządzenia można dołączyć zestaw dokumentów elektronicznych związanych z jego eksploatacją, takich jak: dokumentacja techniczno-ruchowa, instrukcje obsługi, protokoły badań, schematy technologiczne i inne.

Użytkownik może w każdym momencie dołączyć do urządzenia nowy dokument poprzez podanie jego lokalizacji na dysku.

Aby dodać do danych ewidencyjnych urządzenia plik dokumentu:

1. Należy wybrać z paska narzędziowego umieszczonego w dolnej części karty Szczegóły urządzenia polecenie [image] .

2. Spowoduje to wyświetlenie okna dialogowego Szczegóły dokumentu, wymagającego podania ścieżki dostępu do pliku oraz opisu dokumentu, co ułatwi jego późniejszą identyfikację. Wspomniane okno dialogowe zawiera ponadto: polecenie Otwórz, które w zależności od formatu pliku dokumentu uruchamia program dedykowany do przeglądania plików o danym formacie oraz polecenie Usuń, za pomocą którego można usunąć dokument z rejestru urządzenia.

Rys. Okno wyboru pliku dokument związanego z eksploatacją urządzenia.

Przegląd dokumentów możliwy jest z poziomu tabeli urządzeń. Każdy rekord w tabeli Urządzenia odpowiadający jednemu urządzeniu ma opcję podglądu wszystkich liczników i dokumentów związanych z danym urządzeniem. Wystarczy wybrać przycisk [image] znajdujący się w polu Urządzenie i zostanie wyświetlona tabela z dwiema zakładkami:

- Liczniki urządzenia - zestawem liczników

oraz

- Dokumenty - z zestawem dokumentów eksploatacyjnych zadeklarowanych dla urządzenia. Kliknięcie na zakładkę Dokumenty i wskazanie dowolnego dokumentu poprzez dwukrotne kliknięcie spowoduje uruchomienie okna Szczegóły dokumentu - omówionego powyżej.


Deklaracja liczników urządzenia / usuwanie, edycja i

10 Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych

Zestawienie liczników uruchamiane jest poleceniem Definicje liczników znajdującym się na liście kategorii danych ewidencyjnych (rozwijanej poleceniem Konfiguracja dostępnym zarówno w menu głównym programu lub też bezpośrednio z poziomu okna głównego).

zoom in

Rys. Okno AsService – tabela liczników / karta definicji wybranego licznika.

Okno danych liczników składa się z dwóch części:

- tabeli Definicje liczników, która wyświetla rekordy wszystkich zdefiniowanych w rejestrze liczników.

- karty Szczegóły licznika zawierającej dane pojedynczego licznika; wskazanie rekordu wybranego licznika w tabeli Definicje liczników powoduje wyświetlenie danych tego licznika na karcie Szczegóły licznika.

***

Deklaracja liczników skojarzonych z danym urządzeniem odbywa się z wykorzystaniem karty Szczegóły licznika.

Aby utworzyć rekord nowego licznika:

1. Należy w pasku narzędziowym umieszczonym w dolnej części karty wybrać przycisk [image]. 2. Po wypełnieniu niżej opisanych pól należy rekord zapisać, wybierając przycisk [image] .

Chcąc dokonać edycji wartości istniejącego rekordu licznika:
Należy wybrać przycisk [image], który aktywuje edycję wybranego rekordu (pola nie podlegające edycji są wyszarzone). Zmiany edycyjne należy zatwierdzić przyciskiem [image]. Z kolei przycisk [image] anuluje wprowadzone zmiany edycyjne.

Aby usunąć rekord wybranego licznika:

1. Należy w pasku narzędziowym umieszczonym w dolnej części karty Szczegóły licznika wybrać przycisk [image] .

***

Pozostałe przyciski paska narzędziowego umożliwiają wykonanie następujących czynności na rekordach liczników:

- przejście do pierwszego rekordu;

- przejście o 10 rekordów wstecz;

- przejście o 1 rekord wstecz;

- przejście o 1 rekord do przodu;

- przejście o 10 rekordów do przodu;

- przejście do przodu do ostatniego rekordu;

***

Poniższe zestawienie określa pola, które opisują licznik:

Nazwa licznika - dowolna nazwa licznika;

Licznik główny - flaga informująca, czy licznik posiada status głównego licznika;

Urządzenie - nazwa urządzenia zdefiniowanego w rejestrze modułu AsService, dla którego definiowany jest licznik; wartość wybierana z rejestru urządzeń;

Rodzaj - jeden z trzech typowych predefiniowanych w słowniku modułu AsService rodzajów licznika: licznik czasu pracy, licznik załączeń i licznik okresowy; (użytkownik może również sam utworzyć swój własny licznik).

Identyfikator - unikalny widoczny dla obsługi symbol alfanumeryczny licznika, jednoznacznie identyfikujący go; nadawany przez projektanta.

Auto reset - mechanizm automatycznego resetu licznika (i tym samym zapisu stanu licznika do bazy modułu AsService) co pewien zadany okres czasu: koniec zmiany, koniec doby lub koniec miesiąca. Wartość wybierana ze słownika – liczba i sposób działania dostępnych wariantów został zaprogramowany w ustalony sposób i nie podlega modyfikacji przez użytkownika.

Format – pole określające jednostkę, w jakiej wyświetlana/podawana będzie wartość w polu Wartość bieżąca / Wartość początkowa: sekunda, minuta, godzina, dzień, miesiąc (jako 30 dni). Pole dostępne dla liczników czasu pracy i liczników okresowych.

Próg ostrzegawczy 1 - informuje użytkownika o zbliżaniu się do momentu, w którym należy wykonać przewidziane czynności eksploatacyjne; pole oznacza ilość czasu wg zadanego formatu (dla licznika czasu pracy / licznika okresowego) lub liczbę załączeń (dla licznika załączeń), po przekroczeniu którego licznik zostanie dodany do zestawienia planowanych czynności eksploatacyjnych, a pole z bieżącą wartością licznika zaświeci się w tabeli: Aktualne stany liczników oraz Czynności planowane na żółto.

Próg ostrzegawczy 2 - informuje użytkownika o zbliżaniu się do momentu, w którym należy wykonać przewidziane czynności eksploatacyjne; pole oznacza ilość czasu wg zadanego formatu (dla licznika czasu pracy / licznika okresowego) lub liczbę dni (dla licznika okresowego), po przekroczeniu którego licznik zostanie dodany do zestawienia planowanych czynności eksploatacyjnych, a pole z bieżącą wartością licznika zaświeci się w tabeli: Aktualne stany liczników oraz Czynności planowane na pomarańczowo.

Próg eksploatacyjny - wyznacza specyficzny moment w pracy urządzenia (wg zadanego formatu czasu), po przekroczeniu którego należy wykonać czynności eksploatacyjne utrzymujące urządzenie w gotowości produkcyjnej. Przekroczenie wartości zadeklarowanej jako próg eksploatacyjny spowoduje, że licznik zostanie dodany do zestawienia przeterminowanych czynności eksploatacyjnych, a pola wartości bieżących takich liczników zostaną podświetlone w tabeli: Aktualne stany liczników oraz Czynności przeterminowane na kolor czerwony.

Jednorazowy – flaga informująca o cykliczności progu eksploatacyjnego; wszystkie liczniki z zadeklarowanym progiem eksploatacyjnym obsługiwane są jako cykliczne - tzn. po resecie próg eksploatacyjny pozostaje bez zmian (zostaje automatycznie odnowiony), a obsługa licznika przebiega tak jak przed resetem (wartość licznika jest aktualizowana). W przypadku zadeklarowania progu jako próg jednorazowy - wartość progu eksploatacyjnego obowiązywać będzie do pierwszego następnego resetu licznika – tzn. po resecie licznika próg eksploatacyjny zostanie wyzerowany, a licznik nie będzie pojawiał się w listach zaplanowanych i przeterminowanych czynności.

Czynność eksploatacyjna - czynność określana na podstawie dokumentacji techniczno-ruchowej lub doświadczenia ruchowego; wartość wybierana ze słownika tworzonego na bieżąco przez użytkownika.

Częstotliwość odświeżania - częstotliwość (w minutach) z jaką AsService na bieżąco uzupełnia i aktualizuje wartości liczników i dokonuje zapisów tych wartości do swojej bazy MS SQL. (Pole nie dotyczy licznika okresowego, który działa w oparciu o czasomierz modułu AsService całkowicie niezależny od wartości zmiennych asixowych - zmianę wartości dla tego licznika wymusza rozpoczęcie nowej doby). Dostępne wartości częstości odświeżania są zaprogramowane w ustalony sposób i nie podlegają modyfikacji przez użytkownika (30, 60, 90 i 120 minut).

Nazwa zmiennej w ASIX - nazwa zmiennej zadeklarowanej w bazie definicji zmiennych aplikacji Asixa; dla danej zmiennej wyliczane są w systemie Asix agregaty, na podstawie których określane są ilości załączeń oraz czasów pracy urządzeń (licznik okresowy działa w oparciu o czasomierz modułu AsService całkowicie niezależny od wartości zmiennych asixowych - zatem dla niego wartość tego pola nie ma znaczenia).

Nazwa agregatu ASIX - nazwa agregatu, na podstawie którego określane są z wartości odpowiednich zmiennych licznikowych (zadeklarowanych w bazie definicji zmiennych aplikacji Asixa) ilości załączeń oraz czasów pracy urządzeń (licznik okresowy działa w oparciu o czasomierz modułu AsService całkowicie niezależny od wartości zmiennych asixowych - zatem dla niego wartość tego pola nie ma znaczenia).

Wartość bieżąca - wartości liczników: czasu pracy i załączeń pobierane są z agregatów zmiennych licznikowych wyliczanych w aplikacji systemu Asix. AsService uzupełnia i aktualizuje wartości liczników i dokonuje zapisów tych wartości do swojej bazy MS SQL z częstotliwością odświeżania danych wybraną przez użytkownika.

Wartość licznika okresowego wyliczana jest w oparciu o czasomierz modułu AsService całkowicie niezależnie od wartości zmiennych asixowych. Zmianę wartości wymusza rozpoczęcie nowej doby.

Jednostka, w jakiej wyświetlane są dane w polu Wartość bieżąca określa ustawienie pola Format.

Wartość początkowa - początkowa wartość liczników, ustawiana ręcznie przez użytkownika. Jednostka, w jakiej wyświetlane są dane w polu Wartość początkowa określa ustawienie pola Format.

Czas braku danych - wartość określana przez licznik czasu braku danych na podstawie odpowiednich agregatów zmiennych licznikowych wyliczanych w aplikacji systemu Asix.

Czas ostatniego odczytu - data i czas ostatniej operacji odświeżenia danych z aplikacji Asixa.

Czas następnego odczytu - data i czas kolejnej operacji odświeżenia danych z aplikacji Asixa. Czas następnego odczytu wyznaczany jest przez wartość pola Częstotliwość odświeżania.

Czas startu - data i czas ostatniego resetu licznika.

Reset - polecenie inicjujące operację ręcznego resetu licznika. Uruchamia okno resetu licznika, w którym należy określić parametry resetu, w tym zestaw liczników, które zostaną zresetowane razem z bieżącym licznikiem (patrz: 11 . Resetowanie licznika).


Resetowanie licznika

11 Resetowanie licznika

Ręczny reset licznika umożliwia polecenie Reset, dostępne na karcie Szczegóły licznika:

Konfiguracja > Dane liczników > karta Szczegóły licznika

Polecenie to aktywuje okno ‘Reset licznika’, na którym znajdują się podstawowe dane urządzenia, do którego podpięty jest dany licznik, zestaw pozostałych liczników związanych z danym urządzeniem oraz pola, których wypełnienie wymagane jest do przeprowadzenia ręcznego resetu.

zoom in

Rys. AsService – okno ręcznego resetu licznika.

Pola oznaczone kolorem żółtym należy obowiązkowo wypełnić – pola te zostaną zarchiwizowane w bazie AsService w rekordzie charakteryzującym stan licznika w momencie jego resetu (jeden rekord odpowiada jednemu licznikowi, a zapis kolejnego rekordu danych wybranego licznika inicjowany jest momentem resetu tego licznika). Archiwum kolejnych resetów licznika można przeglądać w Archiwum czynności eksploatacyjnych (patrz: 13 . Przeglądanie archiwum czynności eksploatacyjnych).

Pola wymagane do ręcznego resetu licznika:

Przyczyny resetu licznika - wartość wybierana ze słownika tworzonego na bieżąco przez użytkownika;

Osoba wykonująca;

Nr protokołu;

Nowa wartość początkowa.

W oknie ‘Reset licznika’ dostępny jest również zestaw pozostałych liczników powiązanych z danym urządzeniem – zaznaczenie pola reset w rekordach tych liczników również spowoduje ich reset. Mechanizm ten jest przydatny w momencie, gdy reset licznika głównego wymaga resetu liczników pomocniczych danego typu – w takiej sytuacji można jedną operacją zresetować cały zestaw liczników.

Polecenie Wykonaj uruchamia operację resetu.


Przeglądanie archiwum czynności eksploatacyjnych

13 Przeglądanie archiwum czynności eksploatacyjnych

Zestawienie danych liczników charakteryzujących ich stan w momencie resetu prezentuje tabela wyświetlana poleceniem Archiwum czynności eksploatacyjnych, znajdującym się na liście rozwijanej Zestawienia (z menu głównego lub z okna głównego). Jeden rekord odpowiada jednemu licznikowi, a zapis kolejnego rekordu danych wybranego licznika inicjowany jest momentem resetu tego licznika, zazwyczaj wynikającym z potrzeby wykonania określonej czynności eksploatacyjnej.

Powyżej tabeli znajduje się opcja Zakres danych pozwalająca na przefiltrowanie rekordów tabeli wg kryterium czasowego:

- ostatni dzień - okres 24 godzin liczony od bieżącego czasu;

- ostatni tydzień - okres 24 godzin liczony od bieżącego czasu pomnożony przez 7;

- ostatni miesiąc - okres 24 godzin liczony od bieżącego czasu pomnożony przez 30;

- określony zakres czasu - zaznaczenie tego wariantu uaktywnia pola od / do wymagające określenia indywidualnego zakresu czasowego.

Poniżej tabeli znajduje się karta prezentująca szczegółowe dane wybranego licznika.

zoom in

Rys. AsService – tabela archiwum czynności eksploatacyjnych.

Pola tabeli zawierają następujące dane:

- nazwa licznika;

- czas startu;

- czas resetu;

- wartość początkowa;

- wartość - wartość licznika zapamiętana w momencie resetu;

- czas braku danych;

- nr protokołu;

- wykonawca;

- przyczyna resetu;

- symbol;

- format czasu;

(Znaczenie pól – patrz: 10 . Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych)

***

Tabela Archiwum czynności eksploatacyjnych posiada standardowe mechanizmy filtrowania i sortowania informacji o licznikach:

Aby przefiltrować dane wg określonej wartości wybranego pola:

1. Kliknij najpierw na nagłówek pola, a następnie na ikonę [image]. Zostanie rozwinięta lista, z której należy wybrać wartość, zgodnie z którą zostanie przefiltrowana zawartość tabeli.

Aby posortować rosnąco/malejąco rekordy tabeli wg wybranego pola:

1. Kliknij na nagłówek pola. Pojawi się znacznik [image], a rekordy zostaną posortowane wg schematu Z-A, ponowne kliknięcie spowoduje pojawienie się znacznika [image] i posortowanie wg schematu A-Z.

***

Nawigację po rekordach tabeli ułatwia pasek narzędziowy znajdujący się poniżej karty Szczegóły archiwalnej wartości licznika, który zawiera przyciski:

- wstecz do początku (do najstarszego rekordu);

- wstecz o 10 rekordów;

- wstecz o 1 rekord;

- do przodu o 1 rekord;

- do przodu o 10 rekordów;

- do przodu do ostatniego (najnowszego) rekordu;


Przeglądanie informacji na temat planowanych czynności

13 Przeglądanie informacji na temat planowanych czynności eksploatacyjnych

Tabela Czynności planowane prezentuje zestawienie danych liczników tych urządzeń, które zbliżają się do progu eksploatacyjnego – czyli momentu (czasu lub liczby załączeń), po przekroczeniu którego należy wykonać przewidziane czynności eksploatacyjne utrzymujące urządzenie w gotowości produkcyjnej.

Do zestawienia automatycznie zostają dodane te liczniki, których wartość (czas pracy / liczba załączeń – w zależności od typu licznika) przekroczyła wartość zadeklarowaną w definicji liczników jako Próg ostrzegawczy 1 lub Próg ostrzegawczy 2.

Pole z bieżącą wartością licznika, który przekroczył Próg ostrzegawczy 1 zaświeci się w tabeli: Czynności planowane na żółto.

Pole z bieżącą wartością licznika, który przekroczył Próg ostrzegawczy 2 zaświeci się w tabeli Czynności planowane na pomarańczowo.

zoom in

Rys. AsService – tabela czynności planowanych.

Pola tabeli zawierają następujące dane:

- urządzenie;

- nazwa licznika;

- wartość;

- licznika główny;

- czas ostatniego odczytu;

- próg eksploatacyjny;

- typ licznika;

- czynność eksploatacyjna;

- format czasu.

(Znaczenie pól – patrz: 8 . Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych)

***

Tabela Czynności planowane posiada standardowe mechanizmy filtrowania i sortowania informacji o licznikach:

Aby przefiltrować dane wg określonej wartości wybranego pola:

1. Kliknij najpierw na nagłówek pola, a następnie na ikonę [image]. Zostanie rozwinięta lista, z której należy wybrać wartość, zgodnie z którą zostanie przefiltrowana zawartość tabeli.

Aby posortować rosnąco/malejąco rekordy tabeli wg wybranego pola:

1. Kliknij na nagłówek pola. Pojawi się znacznik [image], a rekordy zostaną posortowane wg schematu Z-A, ponowne kliknięcie spowoduje pojawienie się znacznika [image] i posortowanie wg schematu A-Z.

***

Nawigację po rekordach tabeli ułatwia pasek narzędziowy znajdujący się pod tabelą, który zawiera przyciski:

- wstecz do początku (do najstarszego rekordu);

- wstecz o 10 rekordów;

- wstecz o 1 rekord;

- do przodu o 1 rekord;

- do przodu o 10 rekordów;

- do przodu do ostatniego (najnowszego) rekordu;


Przeglądanie informacji na temat czynności przeterminowanych

15 Przeglądanie informacji na temat czynności przeterminowanych

Tabela Czynności przeterminowane prezentuje zestawienie danych liczników tych urządzeń, które przekroczyły próg eksploatacyjny – czyli moment oznaczający moment czasu (dla licznika czasu pracy / licznika okresowego) lub liczbę załączeń (dla licznika załączeń), po przekroczeniu którego należy wykonać przewidziane czynności eksploatacyjne utrzymujące urządzenie w gotowości produkcyjnej.

Do zestawienia automatycznie zostają dodane te liczniki, których wartość (czas pracy / liczba załączeń – w zależności od typu licznika) przekroczyła wartość zadeklarowaną w definicji liczników jako Próg eksploatacyjny.

Pole z bieżącą wartością licznika, który przekroczył Próg eksploatacyjny zaświeci się w tabeli Czynności przeterminowane na czerwono.

zoom in

Rys. AsService – tabela czynności przeterminowanych.

Pola tabeli zawierają następujące dane:

- urządzenie;

- nazwa licznika;

- wartość;

- licznik główny;

- czas ostatniego odczytu;

- próg eksploatacyjny;

- typ licznika;

- czynność eksploatacyjna;

- format czasu.

(Znaczenie pól – patrz: 10 . Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych)

***

Tabela Czynności przeterminowane posiada standardowe mechanizmy filtrowania i sortowania informacji o licznikach:

Aby przefiltrować dane wg określonej wartości wybranego pola:

1. Kliknij najpierw na nagłówek pola, a następnie na ikonę [image]. Zostanie rozwinięta lista, z której należy wybrać wartość, zgodnie z którą zostanie przefiltrowana zawartość tabeli.

Aby posortować rosnąco/malejąco rekordy tabeli wg wybranego pola:

1. Kliknij na nagłówek pola. Pojawi się znacznik [image], a rekordy zostaną posortowane wg schematu Z-A, ponowne kliknięcie spowoduje pojawienie się znacznika [image] i posortowanie wg schematu A-Z.

***

Nawigację po rekordach tabeli ułatwia pasek narzędziowy znajdujący się pod tabelą, który zawiera przyciski:

- wstecz do początku (do najstarszego rekordu);

- wstecz o 10 rekordów;

- wstecz o 1 rekord;

- do przodu o 1 rekord;

- do przodu o 10 rekordów;

- do przodu do ostatniego (najnowszego) rekordu;


Definiowanie danych słownikowych modułu AsRemont

8 Definiowanie danych słownikowych modułu AsService

Podstawą działania modułu AsService jest rejestr urządzeń (i maszyn). Wszystkie dane ewidencyjne opisujące poszczególne pozycje urządzeń zostały odpowiednio pogrupowane w kategorie danych, które należy uzupełnić przed przystąpieniem do wypełniania rejestru. Dane te stanowią możliwe warianty pól opisujących urządzenia oraz liczniki i definiowane są w ramach tzw. słownika modułu AsService. Dostęp do poszczególnych kategorii słownikowych zapewnia lista kategorii rozwijana poleceniem Konfiguracja, dostępnym zarówno w menu głównym programu lub też bezpośrednio z poziomu okna głównego.

Rys. Okno główne modułu AsService – dostęp do słownika danych ewidencyjnych.

Słownik modułu AsService obejmuje następujące kategorie danych ewidencyjnych:

- Producenci;

- Dostawcy;

-Linie;

-Rodzaje zasilania;

- Maszyny;

- Statusy;

- Grupy;

- Wydziały;

-Stany techniczne;

- Przyczyny resetów;

- Rodzaje liczników;

- Czynności eksploatacyjne;

Powyższe dane mogą być swobodnie definiowane za wyjątkiem kategorii: rodzaje liczników (istnieją ustalone predefiniowane typy liczników obsługiwane przez AsService; użytkownik ma jednak możliwość dodefiniowania swoich typów liczników) oraz przyczyny resetów (można dowolnie definiować przyczyny resetów wykonywanych ręcznie, ale resety automatyczne zostały zaprogramowane w ustalony sposób i nie mogą być modyfikowane przez użytkownika).

Znaczenie poszczególnych kategorii danych zostało omówione w rozdziałach: 7 . Wprowadzanie danych ewidencyjnych urządzeń do rejestru / usuwanie, edycja i przeglądanie danych i 8 . Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych.


Deklaracja użytkowników modułu AsRemont

7.4 Deklaracja użytkowników modułu AsService

Istnieje możliwość deklarowania użytkowników modułu AsService, posiadających jedno z trzech uprawnień:

1. konfigurowanie całego modułu (Administrator);

2. edycja (dodawanie/usuwanie) urządzeń i liczników (Specjalista);

3. przeglądanie (Użytkownik).

Aby zdefiniować użytkownika modułu AsService:

1. Z menu Konfiguracja wybierz polecenie Użytkownicy.

2. Zostanie uruchomiony panel Użytkownicy. W dolnym pasku narzędziowym kliknij przycisk '+'.

3. Zostanie dodany nowy rekord definicji użytkownika, w którym należy podać identyfikator, nazwę i hasło dla użytkownika.

Kluczowe znaczenie ma zaznaczenie checkbox'ów w polach: konfiguracja i modyfikacja:

- jeśli żadne z powyższych pól nie zostanie zaznaczone, użytkownik będzie miał jedynie uprawnienia do przeglądania danych ze słownika modułu AsService oraz danych zestawień (aktualne stany liczników, archiwum, czynności planowane, czynności przeterminowane);

- jeżeli zaznaczony zostanie checkbox w polu modyfikacja - użytkownik będzie miał możliwość (poza przeglądaniem danych) definiowania danych słownikowych modułu AsService, dodawania/usuwania urządzeń oraz liczników i możliwość resetowania liczników; nie będzie miał natomiast uprawnień do definiowania użytkowników i parametrów konfiguracyjnych z panelu Ustawienia;

- jeżeli zaznaczony zostanie checkbox w polu konfiguracja - użytkownik będzie miał pełne prawa do konfigurowania modułu AsService jako administrator.

UWAGA:

- Jeśli nie zostanie zdefiniowany żaden użytkownik, plik konfiguracyjny modułu AsService będzie uruchamiany z możliwością jego pełnej konfiguracji.

- Decydując się na zdefiniowanie użytkowników modułu AsService, należy w pierwszej kolejności zdefiniować przynajmniej jednego użytkownika z prawami administratora.


Deklaracja ścieżki dostępu do listy zmiennych licznikowych

7.2 Deklaracja ścieżki dostępu do listy zmiennych licznikowych

Aby zadeklarować ścieżkę dostępu do pełnej listy zmiennych licznikowych:

1. Z menu Konfiguracja uruchom okno 'Ustawienia'.

zoom in

Rys. AsService - okno 'Ustawienia' - ścieżka dostępu do listy zmiennych licznikowych.

2. W polu Baza zmiennych wskaż ścieżkę dostępu do bazy definicji zmiennych, w której zadeklarowane zostały zmienne licznikowe.

UWAGA:

Deklaracja polu Baza zmiennych ścieżki dostępu do bazy, w której zdefiniowane zostały zmienne wykorzystywane w licznikach, oznacza jedynie, że w oknach definicji liczników w polu Nazwa zmiennej w ASIX przy użyciu przycisku [image] będzie można wywoływać okno z zestawem wszystkich zmiennych zadeklarowanych we wspomnianej bazie.

Powiązanie modułu AsService ze zmiennymi pobieranymi z bazy definicji zmiennych aplikacji Asix następuje na etapie konfiguracji dostępu do danych aplikacji Asix, co szczegółowo zostało omówione w rozdziale 3 . Konfiguracja dostępu do danych aplikacji Asix .


Ewidencja urządzeń

1.1 Ewidencja urządzeń

Podstawą funkcjonowania modułu AsService jest rejestr urządzeń i maszyn, który pozwala na zebranie i odpowiednie pogrupowanie danych nt wszystkich urządzeń. Wszystkie informacje generowane i przetwarzane w module AsService (stany liczników, czynności eksploatacyjne, historia operacji, …) powinny odnosić się do urządzeń wprowadzonych do w/w rejestru.

Źródłem danych ewidencji mogą być ustalenia projektowe, dane techniczne, informacje z systemu środków trwałych lub inne pomocnicze źródła.

zoom in

Rys. Okno modułu AsService - zestaw urządzeń.


Import/eksport definicji urządzeń lub liczników z/do pliku

9.2 Import/eksport definicji urządzeń lub liczników z/do pliku *.XLS

AsService umożliwia import/eksport danych ewidencyjnych urządzeń lub liczników z/do plików *.xls. Służy do tego celu polecenie Import dostępne w menu Plik, które uruchamia okno z parametrami importu definicji urządzeń.

zoom in

Rys. AsService - okno parametrów importu definicji urządzeń.

Aby zaimportować do bazy AsService definicje urządzeń (analogicznie liczników), należy wykonać następujące kroki:

  1. W polu Plik wskaż ścieżkę dostępu do pliku *.xls, w którym znajdują się dane ewidencyjne urządzeń.

  2. W polu Rodzaj danych podaj Urządzenia.

  3. W polu Arkusz podaj dokładną nazwę arkusza, na którym znajdują się dane do importu.

  4. Uruchom polecenie Otwórz – spowoduje to załadowanie podglądu arkusza do pola Zawartość pliku.

  5. W polu Powiązanie kolumn ręcznie zamapuj dla poszczególnych pól opisu urządzenia modułu AsService odpowiadające im pola z pliku importu. (Dla ułatwienia posłuż się podglądem arkusza, z którego dane będą importowane - dostępnym w polu Zawartość pliku.)

Wstawienie kursora w dowolnym polu kolumny Pole w arkuszu aktywuje listę z wszystkimi polami zadeklarowanymi w arkuszu importu – wówczas należy wskazać to pole, z którego dane mają być zaimportowane.

zoom in

Rys. AsService – lista pól arkusza importu.

UWAGA:

Aby przy kolejnym imporcie definicji urządzeń z tego samego pliku uniknąć ponownego ręcznego mapowania pól – można skorzystać z polecenia Zapisz konfigurację, który zapamięta schemat mapowania w pliku *.xml. Przy kolejnej operacji importu wystarczy przywołać wspomniany plik *.xml poleceniem Otwórz konfigurację i pola w Powiązanie kolumn zostanie automatycznie wypełnione danymi zdefiniowanymi podczas pierwszego importu.


Licencjonowanie

4. Licencjonowanie

Licencja modułu AsService obejmuje serwer AsService oraz nielimitowaną liczbę klientów AsService.

Rodzaj licencji determinuje liczbę wszystkich liczników zdefiniowanych na komputerze serwera AsService.

Wersja DEMO

  • Po zainstalowaniu aplikacji AsService

  • Pozwala na pracę przez 30 dni

  • Bez ograniczeń na ilość liczników

Aktywacja oprogramowania AsService odbywa się za pośrednictwem aplikacji AsServiceLicense, uruchamianej ikoną [image].

UWAGA:

Wykorzystanie większej liczby liczników niż pozwala na to licencja, zatrzyma naliczanie wszystkich zdefiniowanych liczników.


Liczniki urządzeń / progi eksploatacyjne / reset licznika

1.3 Liczniki urządzeń / progi eksploatacyjne / reset licznika

  • Rodzaje liczników

Z każdym urządzeniem mogą być skojarzone następujące predefiniowane rodzaje liczników:

Liczniki czasu pracy - przechowują czas pracy urządzenia (lub innego wybranego stanu urządzenia) w zadanym okresie.
Zmianę wymusza nowa wartość agregatu Całka_Ostatnia_Znana (ang. Total_Last_Known ), zadeklarowanego przez projektanta w parametrach archiwum zmiennej monitorowanej w systemie Asix.

Liczniki załączeń - przechowują liczbę załączeń (lub innych wybranych zdarzeń) urządzenia w zadanym okresie.
Zmianę wymusza nowa wartość agregatu Suma_Wzrostów (ang. Sum_Up), zadeklarowanego przez projektanta w parametrach archiwum zmiennej monitorowanej w systemie Asix.

Liczniki okresowe - przechowują liczbę dni, która upłynęła od początku zadanego okresu czasu. Zmianę wartości wymusza rozpoczęcie nowej doby. Jest to czasomierz modułu AsService niezależny od wartości zmiennych systemu Asix.

Jest możliwość utworzenia przez użytkownika własnego rodzaju licznika w oparciu o zmienną z zadeklarowanym agregatem wybranym z listy dostępnych agregatów dla zmiennych systemu Asix (pełna lista agregatów dostępna w podręczniku Asix.CHM/PDF, 7.10.3 Zestaw agregatów).

Każdy z rodzajów liczników może posiadać jeden licznik główny oraz wiele liczników pomocniczych.

UWAGA:

Dla urządzeń/napędów dwukierunkowych można zadeklarować dwa liczniki danego urządzenia odwołujące się do dwóch zmiennych przechowujących wartości dwóch rożnych bitów słowa statusowego, lub dla jednej zmiennej zadeklarować funkcję przeliczającą CYRK1 sparametryzowaną w taki sposób, aby sczytywała wartości dwóch sąsiednich bitów słowa statusowego (patrz: 6.1 . Deklaracja zmiennych licznikowych ).

  • Progi eksploatacyjne / ostrzegawcze

Każdy z liczników może mieć przypisany próg eksploatacyjny wyznaczający specyficzny moment w pracy urządzenia. Progi określane są na podstawie dokumentacji techniczno-ruchowej lub doświadczenia ruchowego. Mają one na celu przypomnienie obsłudze o konieczności wykonania czynności eksploatacyjnych utrzymujących urządzenia w gotowości produkcyjnej. Przekroczenie wartości zadeklarowanej jako próg eksploatacyjny spowoduje, że licznik zostanie dodany do zestawienia przeterminowanych czynności eksploatacyjnych, a pola wartości bieżących takich liczników w w/w zestawieniu zostaną podświetlone na kolor czerwony (patrz: 15 . Przeglądanie informacji na temat czynności przeterminowanych).

Ponieważ zwykle takie czynności eksploatacyjne mają charakter cykliczny co pewien stały okres czasu - wszystkie liczniki z zadeklarowanym progiem eksploatacyjnym obsługiwane są jako cykliczne - tzn. po resecie próg eksploatacyjny pozostaje bez zmian (zostaje automatycznie odnowiony), a obsługa licznika przebiega tak jak przed resetem (wartość licznika jest aktualizowana). W przypadku braku deklaracji cykliczności (próg jednorazowy) - wartość progu eksploatacyjnego obowiązywać będzie do pierwszego następnego resetu licznika – tzn. po resecie licznika próg eksploatacyjny zostanie wyzerowany, a licznik nie będzie pojawiał się w listach zaplanowanych i przeterminowanych czynności.

Dla każdego progu eksploatacyjnego można określić próg ostrzegawczy informujący użytkownika, że zbliża się do momentu konieczności wykonania czynności eksploatacyjnej. Próg ostrzegawczy określany jest jako ilość czasu (w zależności od rodzaju licznika) pozostała do osiągnięcia progu eksploatacyjnego, po przekroczeniu którego liczniki będą wyświetlane w zestawieniu planowanych czynności eksploatacyjnych, a pola wartości bieżących liczników w zestawieniach czynności planowanych zostaną podświetlone na: żółto (gdy osiągnięta zostanie wartość zadeklarowana jako 1 próg ostrzegawczy) lub na pomarańczowo (gdy osiągnięta zostanie wartość zadeklarowana jako 2 próg ostrzegawczy) (patrz: 13 . Przeglądanie informacji na temat planowanych czynności eksploatacyjnych).

UWAGA: wartości progów ostrzegawczych i progu eksploatacyjnego mogą być deklarowane w następujących jednostkach: sekunda, minuta, godzina, dzień, miesiąc (30-dniowy).

  • Reset licznika

Reset licznika ustawia jego wartość na zero lub umożliwia zadanie wartości początkowej określonej przez użytkownika. Operacja ta inicjuje zapis do bazy modułu AsService rekordu zawierającego wartości licznika zapamiętane w momencie jego resetu. Rekordy danych odpowiadające kolejnym resetom liczników mogą być przeglądane w module AsService w historii czynności eksploatacyjnych. Reset licznika wykonany manualnie zapamiętuje m.in.: wartość licznika w momencie resetu, nr protokołu, osobę, która wykonała reset, symbol urządzenia, przyczynę resetu. (patrz: 13 . Przeglądanie archiwum czynności eksploatacyjnych).

Reset licznika głównego powinien nastąpić po wymianie lub remoncie generalnym urządzenia. Reset taki powinien wiązać się z resetem liczników pomocniczych dla danego rodzaju licznika, dlatego też AsService umożliwia wykonanie operacji resetu jednocześnie dla kilku wskazanych przez użytkownika liczników (również liczników innego rodzaju).

Reset licznika pomocniczego powinien nastąpić po wykonaniu przynależnej czynności eksploatacyjnej urządzenia. Podobnie jak w przypadku resetu licznika głównego istnieje możliwość jednoczesnego zresetowania kilku wskazanych przez użytkownika liczników (również liczników innego rodzaju).

UWAGA: Zdarzenia, dla których wykonywane są ręczne resety, mogą być dowolnie definiowane przez projektanta. Inaczej jest w przypadku resetów automatycznych, dla których zadeklarowano na sztywno zdarzenie wywołujące reset.

Auto reset licznika – dane do raportu o czasie pracy urządzenia

Auto reset to mechanizm automatycznego resetu licznika (i tym samym zapisu stanów licznika do bazy modułu AsService) co pewien zadany okres czasu: koniec zmiany, koniec doby lub koniec miesiąca. Zastosowanie takiego resetu dla liczników czasu pracy umożliwi sporządzenie okresowych (np. miesięcznych) zestawień rzeczywistego czasu pracy urządzeń z podziałem na mniejsze odcinki czasu (zmianowe i dobowe).

UWAGA:

Okresy czasu jakie można zadeklarować dla auto resetu zostały zaprogramowane i nie podlegają modyfikacji przez użytkownika.

Wariant Koniec zmiany odnosi się do systemu 3-zmianowego: 6:00-14:00, 14:00-22:00, 22:00-6:00.


Liczniki załączeń

1.3.2 Liczniki załączeń

Liczniki ilości załączeń podają aktualną liczbę załączeń liczoną od ostatniego resetu licznika. Wartość licznika zmienia się przyrostowo po każdorazowym odświeżeniu danych z aplikacji Asixa.

Resety liczników załączeń wykonywane przez obsługę typowo związane są z następującymi zdarzeniami (projektant może zdefiniować inne przyczyny resetów):

  • Wymiana (dedykowany licznik główny)

  • Remont

Resety liczników załączeń wykonywane automatycznie związane są z następującymi zdarzeniami (w tym przypadku przyczyny resetów zostały zaprogramowane i nie podlegają modyfikacji przez użytkownika):

  • Koniec zmiany produkcyjnej

  • Koniec doby

  • Koniec miesiąca


Obsługa pliku konfiguracyjnego modułu AsRemont

7.3 Obsługa pliku konfiguracyjnego modułu AsService

Aby zapisać ustawienia modułu AsService w pliku konfiguracyjnym:

1. Z menu Plik wybierz polecenie Zapisz jako... lub Zapisz.

Aby otworzyć plik konfiguracyjny modułu AsService:

1. Z menu Plik wybierz polecenie Otwórz... i wskaż ścieżkę dostępu do pliku XML.

Aby utworzyć nowy plik konfiguracyjny modułu AsService:

1. Z menu Plik wybierz polecenie Nowy....


Parametryzacja dostępu do bazy definicji zmiennych

5.2. Parametryzacja dostępu do bazy definicji zmiennych procesowych aplikacji systemu Asix

Na podstawie nazwy komputera w konfiguracji aplikacji systemu Asix, w której zdefiniowane zostały zmienne licznikowe pobierane są do systemu raportowania AsRaport między innymi parametry określające położenie bazy definicji zmiennych.

Aby zadeklarować nazwę komputera w konfiguracji aplikacji systemu Asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa, w której zdefiniowane zostały zmienne licznikowe. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk programu AsixEvo.exe.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Opcje

3. Wybierz z rozwijanego pola nazwę komputera i kliknij przycisk OK.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Nazwa komputera w konfiguracji aplikacji systemu Asix.

UWAGA:

Położenie bazy definicji zmiennych deklarowane jest przy użyciu:

Architekt > Bazy danych > Baza definicji zmiennych > zakładka Format


Przeglądanie aktualnych stanów liczników

12 Przeglądanie aktualnych stanów liczników

Zestawienie wszystkich liczników zdefiniowanych w module AsService wraz z ich wartościami bieżącymi prezentuje tabela wyświetlana poleceniem Aktualne stany liczników, znajdującym się na liście rozwijanej Zestawienia (z menu głównego lub z okna głównego).

zoom in

Rys. AsService – tabela ‘Aktualne stany liczników’.

Wartości liczników z pola Wartość podświetlane są na kolor: żółty – w przypadku przekroczenia 1 progu ostrzegawczego, pomarańczowy – w przypadku przekroczenia 2 progu ostrzegawczego oraz czerwony – w przypadku przekroczenia progu eksploatacyjnego.

Pozostałe pola tabeli zawierają następujące dane:

- nazwa licznika;

- nazwa urządzenia;

- czas ostatniego odczytu;

- flagę informującą o tym czy licznik jest licznikiem głównym;

- wartość progu eksploatacyjnego;

- typ licznika;

- czynność eksploatacyjną;

- format czasu.

(Znaczenie pól – patrz: 10 . Deklaracja liczników urządzenia / usuwanie, edycja i przeglądanie danych)

***

Tabela Aktualne stany liczników posiada standardowe mechanizmy filtrowania i sortowania informacji o licznikach:

Aby przefiltrować dane wg określonej wartości wybranego pola:

1. Kliknij najpierw na nagłówek pola, a następnie na ikonę [image]. Zostanie rozwinięta lista, z której należy wybrać wartość, zgodnie z którą zostanie przefiltrowana zawartość tabeli:

Rys. AsService – filtrowanie tabeli.

Aby posortować rosnąco/malejąco rekordy tabeli wg wybranego pola:

1. Kliknij na nagłówek pola. Pojawi się znacznik [image], a rekordy zostaną posortowane wg schematu Z-A, ponowne kliknięcie spowoduje pojawienie się znacznika [image] i posortowanie wg schematu A-Z.

***

Nawigację po rekordach tabeli ułatwia pasek narzędziowy znajdujący się u dołu tabeli, który zawiera przyciski:

- wstecz do początku;

- wstecz o 10 rekordów;

- wstecz o 1 rekord;

- do przodu o 1 rekord;

- do przodu o 10 rekordów;

- do przodu do ostatniego (najnowszego) rekordu;


Przygotowanie modułu AsRemont do pracy z

7 Przygotowanie modułu AsService do pracy z aplikacją systemu Asix

Po zainstalowaniu serwera MS SQL Server i przygotowaniu dostępu do danych procesowych aplikacji Asixa należy skonfigurować moduł AsService.


Tworzenie/Konfiguracja bazy danych modułu AsRemont

7.1 Tworzenie/Konfiguracja bazy danych modułu AsService

Przystępując do konfigurowania modułu AsService należy w pierwszej kolejności dokonać edycji podstawowych ustawień - w tym ustawień dotyczących bazy danych, w której przechowywane będą wszystkie dane dot. urządzeń i liczników i również historia czynności eksploatacyjnych.

Okno wspomnianych ustawień uruchamiane jest automatycznie po uruchomieniu AsService. Ponadto w dowolnym momencie można je wywołać z menu głównego AsService: Konfiguracja > Ustawienia.

Aby skonfigurować dostęp do bazy SQL modułu AsService (bądź utworzyć tę bazę):

1. Z menu Konfiguracja uruchom okno 'Ustawienia'.

zoom in

Rys. AsService - okno 'Ustawienia' .

2. W polu Opis aplikacji wpisz informacje nt pliku konfiguracyjnego XML tworzonego przez AsService, pozwalającego na zapisywanie i odczytywanie ustawień modułu z dowolnego miejsca.

3. Uruchom okno 'Ustawienia bazy danych'.

zoom in

Rys. Okno 'Ustawienia bazy danych'.

4. Podaj nazwę serwera bazy modułu AsService, nazwę tej bazy oraz tryb autoryzacji.

Jeśli wybierzesz tryb autoryzacji: Serwer SQL - zdefiniowany zostanie domyślny użytkownik (bez możliwości zadeklarowania dla niego nazwy i hasła), wykorzystywany później do autoryzacji dostępu do bazy AsService.

5. W przypadku tworzenia nowej bazy w Parametrach dostępu administracyjnego podaj właściwy tryb autoryzacji oraz nazwę i hasło użytkownika uprawnionego do tworzenia baz na wskazanym serwerze SQL.

6. Kliknij przycisk OK. Zostanie utworzona baza modułu AsService.