Witamy

>> Pomoc dla użytkowników systemu asix - wersji 6

www.asix.com.pl

Raportowanie w systemie asix

na bazie usług Reporting Services firmy Microsoft

Dok. Nr PLH6100

Wersja: 16-09-2010


1 Wprowadzenie

Wersja 6 pakietu asix dysponuje systemem raportowania opartym na usługach Reporting Services firmy Microsoft.

Microsoft® SQL Server™ 2008 Reporting Services jest kompletną platformą serwerową zaprojektowaną do spełniania szerokiego zakresu oczekiwań w dziedzinie raportowania na poziomie całego przedsiębiorstwa. Usługi Reporting Services, będące komponentem bazy danych SQL Server 2008, umożliwiają: tworzenie raportów na podstawie różnorodnych źródeł danych; zarządzanie środowiskiem raportowania polegające na planowaniu generowania raportów, zarządzaniu prenumeratami raportów i kontrolowaniu praw dostępu, a także dostarczanie użytkownikom raportów w stosownym formacie i w dogodny dla nich sposób. Przewidziana jest między innymi możliwość automatycznego dostarczania raportów drogą elektroniczną poprzez subskrypcję, bądź też możliwość osadzania raportów w aplikacjach biznesowych i portalach.

Rozszerzenie systemu asix w zakresie współpracy ze środowiskiem raportowym Reporting Services obejmuje programy: Askom.Data.Host, AsRaport, bazę danych AsixConnect na serwerze Microsoft SQL oraz niezależny archiwizator alarmów w bazie Microsoft SQL. Kluczowy element stanowi baza AsixConnect, której procedury składowane, za pośrednictwem programu Askom.Data.Host, udostępniają do środowiska raportowego dane procesowe z aplikacji asix. Program AsRaport odgrywa ważną rolę w fazie projektowania raportów jako narzędzie służące do przygotowania zapytań w języku SQL.Za pośrednictwem tych zapytań pobierane są dane z aplikacji systemu asix przez Report Builder lub Report Designer (aplikacje klienckie wchodzące w skład środowiska Reporting Services) w trakcie projektowania i generowania gotowych raportów. Istotne jest to, że zapytania SQL przygotowywane w programie AsRaport mogą być konstruowane w sposób wizualny za pomocą edytorów, a zatem bez konieczności znajomości ich składni.

Report Builder to narzędzie, które pozwala pracownikom nie posiadającym szczegółowej wiedzy programistycznej tworzyć definicje raportów umożliwiające samodzielne generowanie raportów ad hoc (na żądanie) przez użytkowników końcowych. Intuicyjne, przypominające pakiet Office środowisko tworzenia raportów, pozwala wykorzystać doświadczenie zdobyte w obsłudze produktów takich jak Excel czy Access.

Report Designer stanowi bardzo elastyczne i produktywne środowisko tworzenia raportów dla programistów oraz zaawansowanych projektantów raportów. Report Designer to składnik SQL Server Business Intelligence Development Studio, środowiska programistycznego Business Intelligence, bazującego na znanym interfejsie programistycznym Microsoft Visual Studio. Programiści mogą szybko i łatwo tworzyć raporty, korzystając z kreatora Report Wizard lub budować bardziej złożone raporty, korzystając z wizualnego środowiska projektowego narzędzia Report Designer.

Rysunek: Architektura powiązania systemu asix ze środowiskiem raportowym Reporting Services.

Prace nad projektem raportu pobierającego dane z aplikacji systemu asix użytkownik realizuje przy jednoczesnym wykorzystaniu paneli programów AsRaport i Report Builder (lub Report Designer). Przygotowanie systemu asix do pracy ze środowiskiem Reporting Services wymaga skonfigurowania programów Askom.Data.Host.exe i AsRaport oraz utworzenia bazy danych AsixConnect. Projektowanie raportu rozpoczyna się od określenia przy pomocy AsRaport składni zapytań SQL do procedur składowanych, co pozwala określić dane źródłowe, w oparciu o które będą projektowane raporty. Następnie przygotowywany jest w Report Builder (lub Report Designer) układ raportu – wymaga to wybrania szablonu układu raportu z predefiniowanymi sekcjami danych (tabele, macierze, wykresy), a następnie umieszczeniu w widoku projektu wybranych elementów danych i zdefiniowaniu ograniczeń pozwalających przefiltrować dane źródłowe raportu. Report Builder i Report Designer pozwalają też tworzyć nowe pola obliczeniowe raportu, niemal w dowolny sposób formatować wygląd raportu, a ponadto umożliwiają podgląd, drukowanie i publikowanie raportów. Przygotowany w ten sposób raport (model raportu) umieszczany jest na centralnym serwerze środowiska Reporting Services, skąd udostępniany jest m.in. za pośrednictwem przeglądarki internetowej w całym przedsiębiorstwie.

Oryginalne informacje nt tworzenia raportów w środowisku SQL Server 2008 Reporting Services na stronach firmy Microsoft:

http://www.microsoft.com/poland/technet/bazawiedzy/centrumrozwiazan/cr276_01.mspx


1.1 Wymagania programowe

Do współpracy systemu asix 6 ze środowiskiem raportowym Reporting Services firmy Microsoft wymagana jest instalacja serwera SQL Server 2008 Service Pack 1.


2.1 Utworzenie bazy AsixConnect

2.1 Utworzenie bazy danych AsixConnect

Procedury składowane bazy danych AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają do środowiska raportowego dane procesowe z aplikacji asix.

Baza danych AsixConnect tworzona jest za pośrednictwem programu Architekt – jest to pierwszy krok, jaki należy wykonać przygotowując w systemie asix środowisko do tworzenia raportów z użyciem Reporting Services.

UWAGA: Baza danych AsixConnect jest niezbędna do pracy systemu raportowania w oparciu o dane procesowe asixa.

Procedury składowane bazy danych AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają do środowiska raportowego dane procesowe z aplikacji asix.

Baza danych AsixConnect tworzona jest za pośrednictwem programu Architekt – jest to pierwszy krok, jaki należy wykonać przygotowując w systemie asix środowisko do tworzenia raportów z użyciem Reporting Services.

UWAGA: Baza danych AsixConnect jest niezbędna do pracy systemu raportowania w oparciu o dane procesowe asixa.

Aby utworzyć bazę danych AsixConnect z dostępem do danych aplikacji systemu asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport > zakładka Baza danych AsixConnect

3. Wybierz nazwę serwera MS SQL dla bazy danych AsixConnect, określ sposób weryfikacji użytkowników i kliknij przycisk Utwórz bazę.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect.

Dostępne są trzy sposoby weryfikacji użytkowników dla bazy danych AsixConnect:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika ‘_asix_internal’ zdefiniowanego w serwerze MS SQL – domyślnie utworzonego w momencie instalowania pakietu asix (warunkiem utworzenia takiego użytkownika jest zainstalowanie serwera MS SQL przed rozpoczęciem instalacji pakietu asix)

3. Weryfikacja wg użytkownika serwera MS SQL, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport przed utworzeniem bazy danych AsixConnect.


2.2 Parametryzacja środowiska AsRaport

Parametryzacja środowiska AsRaport obejmuje następujące elementy:

- deklarację nazwy komputera serwera aplikacji systemu asix;

- deklarację serwera raportów.

Na podstawie nazwy komputera serwera aplikacji systemu asix pobierane są do systemu raportowania AsRaport następujące parametry aplikacji:

- położenie bazy definicji zmiennych

- nazwa sieciowa zestawu alarmów

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów

Aby zadeklarować nazwę komputera serwera aplikacji systemu asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Nazwa komputera serwera

3. Wybierz z rozwijanego pola nazwę komputera i kliknij przycisk OK.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Nazwa komputera serwera.

Położenie bazy definicji zmiennych deklarowane jest przy użyciu:

Architekt > Bazy danych > Baza definicji zmiennych > zakładka Format

Nazwa sieciowa zestawu alarmów deklarowana jest przy użyciu:

Architekt > Obszary i komputery > System alarmów > zakładka Alarmy / Nazwa sieciowa

Nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów deklarowana jest przy użyciu:

Architekt > Obszary i komputery > System alarmów > zakładka Archiwum > Serwer Microsoft SQL

Deklaracja serwera raportów MS Reporting Services wykorzystywana jest do otwierania raportów utworzonych w środowisku MS Reporting Services, bezpośrednio z poziomu aplikacji systemu asix. Wspomniane raporty mogą być wówczas przeglądane za pomocą programu AsRapView - będącego modułem systemu asix.

Aby zadeklarować serwer raportów:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji asixa.

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Serwer raportów

3. Zadeklaruj adres serwera raportów, nazwę kartoteki w serwerze raportów i określ sposób weryfikacji użytkowników.

4. Kliknij przycisk OK.

Dostępne są trzy sposoby weryfikacji użytkowników dla serwera raportów:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika o nazwie ‘AskomInternal’ zdefiniowanego w systemie Windows – domyślnie utworzonego w momencie instalowania pakietu asix

3. Weryfikacja wg użytkownika Windows, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Serwer raportów.


2.3 Uruchomienie programu Askom.Data.Host.exe

Aby możliwe było pobieranie danych procesowych z aplikacji asixa, musi być przez cały czas uruchomiony program Askom.Data.Host.

Askom.Data.Host.exe domyślnie umieszczany jest przez instalator pakietu asix w katalogu głównym pakietu C:\Program Files\Askom\Asix.


3.1.2. Odczyt danych archiwalnych

ReadProcessed

periodStart, periodEnd, resampleInterval, column1, column2, column3, …

Specyfikacja okresu czasu:

periodStart, periodEnd: data np. '2009-1-1 0:0:0‘

resampleInterval: liczba sekund

Procedura ReadProcessed – kolumny wartości zmiennych

  • Nazwa zmiennej: ‘A000’

  • Jw. + alias: ‘A000 as [Temp. spalin]’

  • Agregat i nazwa zmiennej: ‘avg(A000)’

  • Jw. + alias: ‘avg(A000) as [ Śr. temp. spalin]’

Procedura ReadProcessed – kolumny czasu

  • Stempel czasu początku interwału – ‘starttime’

  • Stempel czasu końca interwału – ‘endtime’

  • Data początku zmiany – ‘shiftdate’

  • Numer zmiany – ‘shiftnumber’


Odczyt danych z bazy definicji zmiennych

3.1.3. Odczyt danych z bazy definicji zmiennych

Odczyt danych z bazy definicji zmiennych

  • ReadAttributes variableNames, column1, column2, column3, …

  • variableNames: lista nazw zmiennych, np.
    ‘A000, A004, A008’

Odczyt i transpozycja danych z bazy definicji zmiennych

  • ReadAttributesTranspose attributeNames, column1, column2, column3, …

  • attributeNames: lista nazw atrybutów, np.
    ‘Nazwa, Opis, Jednostka’


3.1.4. Odczyt alarmów historycznych – archiwum SQL

Odczyt alarmów historycznych – archiwum SQL

  • ReadProcessedHistoricalAlarms resourceName, periodStart, periodEnd, alarmIdPattern, alarmTextPattern, alarmTextLang

  • Zwracane są alarmy, które rozpoczęły się w podanym okresie czasu

  • Zwracane są daty początku, końca i potwierdzenia alarmu, identyfikator, tekst,
    długość okresu trwania

  • periodStart, periodEnd – okres czasu w formacie lokalnym lub OPC

  • alarmIdPattern – pusty, numer alarmu, wzorzec numeru lub lista numerów, np.

1,2,3,

1-3

  • alarmTextPattern – tekst alarmu lub wzorzec testu alarmu, np.

*<tekst>*

  • alarmTextLang – identyfikator języka tekstu alarmu (język polski – ‘pl’)

Odczyt alarmów historycznych – okresy aktywności

  • ReadProcessedHistoricalAlarms_ActivePeriods resourceName, periodStart, periodEnd, alarmIdPattern, alarmTextPattern, alarmTextLang

  • Zwracane są alarmy, które były aktywne w podanym okresie czasu

  • Każda data początku i końca alarmu, która wykracza poza podany okres jest zawężana do podanego okresu czasu

Odczyt alarmów historycznych – suma długości okresów aktywności

  • ReadProcessedHistoricalAlarms_ActivePeriodTotal resourceName, periodStart, periodEnd, alarmId, alarmTextPattern,
    alarmTextLang

  • Zwracana jest długość okresu, w którym alarm był aktywny w podanym okresie czasu


3.1.5. Odczyt alarmów historycznych – archiwum plikowe

  • ReadHistoricalAlarmsOpc
    periodStart, periodLen,
    alarmIdRange, alarmTextMask,
    alarmType, alarmStatus,
    maxNumberOfAlarms

  • Początki i końce alarmu są zwracana jako osobne wiersze


4 Projektowanie raportów w Report Builder

Poniżej opisane zostały podstawowe kroki, jakie należy wykonać w celu zaprojektowania raportu na bazie wartości zmiennych procesowych i ich definicji pobieranych z aplikacji systemu asix. Za przykład aplikacji posłużyła aplikacja demo ‘Fabryka’, dołączana do pakietu asix. Wersja testowanego środowiska Reporting Services pochodzi z instalacji serwera SQL Server 2008 Service Pack 1 w wersji Express.

Szczegółowe informacje na temat projektowania raportów w Report Builder można znaleźć w dokumentacji samego produktu (dostępna polska wersja językowa).

Widok okna głównego programu Report Builder w wersji 2.0 przedstawia poniższy rysunek.

Rysunek: Okno główne programu Report Bulder.

Domyślnie definicja nowego raportu zawiera treść raportu, stopkę strony oraz następujące elementy:

  • Pole tekstowe z komunikatem „Kliknij tutaj, aby dodać tytuł”.

  • Symbol zastępczy z łączem do kreatora tabeli lub macierzy oraz kreatora wykresu.

  • Pole tekstowe w stopce strony zawierające wbudowane pole [&ExecutionTime]. Powoduje dodawanie daty i godziny wykonania raportu u dołu każdej strony raportu.


4.1 Utworzenie nowego raportu

4.1 Otwarcie nowego raportu

W celu utworzenia nowego raportu kliknij przycisk Start, wskaż polecenie Programy, wskaż polecenie Microsoft SQL Server 2008 Report Builder, a następnie kliknij polecenie Report Builder 2.0.

Zostanie otwarte okno programu Report Builder z nowym raportem w widoku projektu.


4.4 Dodawanie i edycja zestawu danych

Edycja zestawu danych dostępna jest z poziomu okna ‘Danych raportu’ w katalogu źródła danych. UWAGA: musi być określone źródło danych.

Aby utworzyć zestaw danych

1. W okienku ‘Dane raportu’ kliknij prawym przyciskiem myszy nazwę źródła danych, a następnie kliknij polecenie Dodaj zestaw danych. Zostanie otwarte okno dialogowe ‘Właściwości zestawu danych’ z widokiem na właściwości kwerendy.

2. W polu Nazwa wpisz nazwę zestawu danych lub zaakceptuj nazwę domyślną.

3. W polu Źródło danych wybierz nazwę istniejącego udostępnionego źródła danych lub kliknij przycisk Nowy, aby utworzyć nowe osadzone źródło danych.

4. Wybierz opcję Typ kwerendy. Opcje będą się różnić w zależności od typu źródła danych.

  • Wybranie opcji Tekst umożliwia napisanie kwerendy w języku kwerend źródła danych.

  • Wybranie opcji Tabela umożliwia zwrócenie wszystkich pól w tabeli relacyjnej bazy danych.

  • Wybranie opcji Procedura przechowywana umożliwia uruchomienie procedury przechowywanej o wybranej nazwie.

5. W polu Kwerenda wpisz nazwę kwerendy, procedury przechowywanej lub tabeli. Możesz również kliknąć przycisk Projektant kwerend, aby otworzyć graficzne lub tekstowe narzędzie projektanta kwerend, lub przycisk Importuj, aby zaimportować kwerendę z istniejącego raportu.

6. W polu Limit czasu wpisz liczbę sekund oczekiwania serwera raportów na odpowiedź z bazy danych. Wartość domyślna to 0 sekund. Wartość 0 sekund oznacza brak limitu czasu kwerendy.

7. Kliknij przycisk OK.

8. Zestaw danych i jego kolekcja pól są wyświetlane w okienku ‘Dane raportu’ w węźle źródła danych okna głównego Report Buildera.

Aby edytować zestaw danych

W okienku ‘Dane raportu’ kliknij prawym przyciskiem myszy nazwę źródła danych, a następnie zestawu danych i kliknij polecenie Właściwości zestawu danych. Zostanie otwarte okno dialogowe ‘Właściwości zestawu danych’ z widokiem na właściwości kwerendy.

Rysunek: Okno właściwości zestawu danych.

Aby przejść do pozostałych właściwości zestawu danych, wystarczy wybrać daną kategorię właściwości w lewej części okna ‘Właściwości zestawu danych’.


4.6 Zapisywanie raportów

Aby zapisać raport

  1. Kliknij na ikonę w lewym górnym rogu okna Report Builder i wybierz polecenie Zapisz jako.

  2. Wskaż adres URL do serwera raportów lub katalog docelowy lokalnie na swoim komputerze – format pliku raportu to plik *.RDL.

  3. Kliknij przycisk Zapisz.

Rysunek: Okno ‘Zapisz jako raport’.


5 Projektowanie raportów w Report Designer

Niniejszy rozdział prezentuje jedynie podstawowe kroki utworzenie prostego raportu z wykorzystaniem źródeł danych procesowych z aplikacji systemu asix. Za przykład aplikacji posłużyła aplikacja demo ‘Fabryka’, dołączana do pakietu asix. Wersja testowanego środowiska Reporting Services pochodzi z instalacji serwera SQL Server 2008 Service Pack 1 w wersji Express.

Szczegółowe informacje na temat projektowania raportów w Report Designer można znaleźć w dokumentacji samego produktu.

Rysunek: Okno Microsoft Visual Studio.

  1. Uruchom menu Start > Programy > Microsoft SQL Server 2008 > SQL Server Business Intelligence Development Studio

  2. W okienku Recent Projects wybierz opcję Create: Project …

  3. Określ podstawowe parametry raportu: nazwę i lokalizację raportu.

    4. Rysunek: Okno parametrów zapisu nowego projektu raportu.

  4. Zostanie uruchomione okno kreatora raportów. Kliknij przycisk Next.

    5. Rysunek: Okno powitalne kreatora raportów.

  5. W oknie źródła danych kreatora raportu wskaż źródło danych: nazwę serwera SQL, na którym znajduje się baza AsixConnect oraz bazę AsixConnect. Kliknij Next.

    6. Rysunek: Kreator raportów - okno deklarujące źródło danych.

  6. Zostanie uruchomione okno projektowania kwerendy. Aby wkleić kwerendę przygotowaną w programie AsRaport, należy przygotować taką kwerendę, skopiować ją przy użyciu polecenia Kopiuj z zakładki narzędziowej programu AsRaport, następnie przejść do okna projektowania kwerendy w kreatorze raportu i wkleić skopiowaną definicję kwerendy do pola Query string.

    7. Rysunek: Kreator raportów – okno projektowania kwerendy.

  7. Wybierz typ raportu: tabelaryczny lub matrix. Kliknij Next.

    8. Rysunek: Kreator raportów – okno definiowania typu raportu.

  8. Zaprojektuj układ danych na raporcie (w omawianym przykładzie wybrano tabelę). Kliknij Next.

    9. designer_ukladdanych na rap.jpg

    Rysunek: Kreator raportu – okno projektowania układu danych na raporcie.

  9. Określ styl tabeli. Kliknij Next.

    10. Rysunek: Kreator raportu – okno definiowania stylu tabeli.

  10. Wskaż serwer raportów i katalog na tym serwerze, do którego będą transferowane raporty. Kliknij przycisk Next.

    11. Rysunek: Kreator raportu – okno definiowania danych dostępu do serwera raportów.

  11. Określ nazwę raportu. Kliknij przycisk Finish. Zostanie wyświetlony raport w widoku projektu.

    12. Rysunek: Kreator raportu – okno definiowania nazwy raportu.

    Rysunek: Gotowy raport w widoku projektu.

  12. Aby uruchomić podgląd raportu, kliknij na przycisk Preview.

    13. Rysunek: Gotowy raport w widoku podgląd.

  13. Aby umieścić raport na serwerze raportów, wybierz polecenie Deploy <nazwa raportu> z menu Build.


2.4 Uruchomienie programu Askom.Data.Host.exe

Aby możliwe było pobieranie danych procesowych z aplikacji asixa musi być przez cały czas uruchomiony program Askom.Data.Host.

Askom.Data.Host.exe domyślnie umieszczany jest przez instalator pakietu asix w katalogu głównym pakietu C:\Asix.


2.5 Przykład

Przygotowanie dostępu do danych procesowych aplikacji ‘Fabryka’ (aplikacja demo, dołączana do pakietu asix).

  1. Otwórz program Architekt.

  2. Uruchom aplikację ‘Fabryka’ dla stacji nr 1. W tym celu załaduj do Architekta plik konfiguracyjny aplikacji:

    3. domyślnie umieszczany przez instalator pakietu asix w katalogu

    C:\Asix\Aplikacje\Fabryka\ Fabryka.xml

    Następnie w polu Obszary i komputery kliknij na pozycję ‘Stacja_SO1’ i uruchom aplikację wybierając z menu Aplikacja polecenie Uruchom system Asix.

  3. Utwórz bazę AsixConnect i jednocześnie skonfiguruj program Askom.Data.Host przy użyciu okna ‘Tworzenie serwera danych dla systemu raportów’, wywoływanego z menu Aplikacja programu Architekt. W polu Nazwa serwera podaj nazwę serwera MS SQL, na którym baza zostanie utworzona.

  4. Skonfiguruj program AsRaport deklarując parametry dostępu do bazy AsixConnect i bazy definicji zmiennych – w przykładzie baza AsixConnect utworzona na serwerze lokalnym:

    5. <applicationSettings>

    <AsRaport.Properties.Settings>

    <setting name="AsixConnectConnectionString" serializeAs="String">

    <value>Data Source=(local)\sqlexpress;Database=AsixConnect;Integrated Security=SSPI;</value>

    </setting>

    <setting name="ItemsDatabase" serializeAs="String">

    <value>C:\Asix\Aplikacje\Fabryka\BAZA\Baza_zmiennych.mdb</value>

    </setting>

    </AsRaport.Properties.Settings>

    </applicationSettings>

  5. Uruchom plik Askom.Data.Host.exe


2 Konfiguracja dostępu do danych aplikacji asix

Przystępując do projektowania raportów z wykorzystaniem usług Reporting Services należy w pierwszej kolejności zainstalować na komputerze, na którym raporty będą projektowane, środowisko raportowe serwera MS SQL Server 2008. Kolejny etap - przygotowania dostępu do danych procesowych aplikacji, które staną się źródłem raportów, obejmuje następujące kroki, omówione w kolejnych rozdziałach dokumentacji:

1. Utworzenie bazy danych AsixConnect

2. Parametryzacja środowiska AsRaport

3. Uruchomienie programu Askom.Data.Host.exe


3.1.1. Format czasu i format długości okresu czasu OPC

Format czasu OPC

Składnia:
keyword +/- liczba offset +/- liczba offset …

‘keyword’: NOW, MINUTE, HOUR, DAY, WEEK, MONTH, YEAR

‘offset’: S, M, H, D, W, MO, Y

Przykłady: DAY-1D, YEAR+1MO

Format długości okresu czasu OPC

Składnia:

+/- liczba offset +/- liczb offset …

Nie zawiera części ‘keyword’

‘offset’: S, M, H, D, W, MO, Y

Przykłady: 5M, 1H, 12H, 1MO, 1D+12h


3.1 Odczyt danych / procedury składowane bazy AsixConnect

Program AsRaport pozwala konstruować zapytania SQL w sposób wizualny za pomocą edytorów, a zatem bez konieczności znajomości ich składni. Użytkownik może jednak sam budować zapytania - w tym również do danych z archiwum alarmów. Zapytania mogą wykorzystywać parametry podawane w czasie lokalnym lub w formacie czasu OPC (dotyczy parametrów: periodStart, periodEnd, resampleInterval, periodLen) - patrz: 3.1.1. Format czasu i format długości okresu czasu OPC. W poniższych rozdziałach znajdują się informacje na temat budowy zapytań do danych archiwalnych, danych z bazy definicji zmiennych, danych archiwum SQL alarmów historycznych i danych archiwum plikowego alarmów historycznych.


3 Projektowanie zapytań SQL do procedur składowanych bazy

3 Projektowanie zapytań SQL do procedur składowanych bazy danych AsixConnect przy pomocy programu AsRaport

Program AsRaport uruchamiany jest przez plik AsRaport.exe domyślnie umieszczany przez instalator pakietu asix w katalogu C:\Program Files\Askom\Asix.

Okno główne programu składa się z zakładek pasków narzędziowych Narzędzia i Widok oraz zakładki/zakładek umożliwiających definiowanie zapytań do bazy archiwum wartości procesowych oraz bazy definicji zmiennych.

Rysunek: AsRaport – okno główne – zakładka definiowania zapytań do danych archiwum wartości procesowych.

Zakładka Narzędzia obejmuje następujące polecenia:

Otwórz plik aplikacji – polecenie otwiera plik konfiguracyjny XML aplikacji systemu asix.

Nowe zapytanie – dane archiwalne – powoduje dodanie nowej zakładki umożliwiającej budowanie zapytań SQL do bazy archiwum wartości procesowych.

Nowe zapytanie – baza definicji zmiennych – powoduje dodanie nowej zakładki umożliwiającej budowanie zapytań do bazy definicji zmiennych.

Uruchom – polecenie wyświetla wynik zapytania na podstawie zdefiniowanych pól kwerendy.

Kopiuj– polecenie kopiuje do schowka zapytanie SQL zbudowane przez użytkownika w oknie AsRaporta – celem wklejenia w oknie definiowania kwerend programów Report Builder lub Report Designer (na etapie projektowania raportów).

Wklej – polecenie wkleja kwerendę do programu AsRaport.

Wybierz – polecenie umożliwia wybór zmiennej procesowej.

Wstaw – polecenie wstawia wiersz do listy kolumn (w przypadku zapytań do archiwum wartości procesowych) lub wiersz do listy atrybutów/zmiennych (w przypadku zapytań do bazy definicji zmiennych).

Usuń – polecenie usuwa wiersz z listy kolumn (w przypadku zapytań do archiwum wartości procesowych) lub z listy atrybutów/zmiennych (w przypadku zapytań do bazy definicji zmiennych).

Zakładka Widok umożliwia wybór stylu i kolorystyki programu AsRaport.

Zakładka Zapytanie utworzona poleceniem Nowe zapytanie – dane archiwalne obejmuje następujące parametry:

Parametry okresu czasu:

Początek – początek okresu, z którego będą pobierane wartości zmiennych procesowych.

Koniec – koniec okresu, z którego będą pobierane wartości zmiennych procesowych.

Długość interwału – określa odstęp czasu pomiędzy kolejnymi wartościami zmiennych procesowych (okres czasu, z którego pobierane są dane dzielony jest na interwały o stałej długości czasu).

Lista kolumn – określa zestaw danych (pól kwerendy), które będą prezentowane w raporcie. Zestaw predefiniowanych pól deklarowanych z listy rozwijanej przyciskiem [image] po kliknięciu w nowym wierszu w Nazwie danego pola obejmuje:

- start time – czas początku interwału

- endtime – czas końca interwału

- shiftnumber – numer zmiany w pracy operatora (domyślnie ustalono 3 zmiany: 1- od godz. 6:00 – do godz. 14:00; 2 – od godz. 14:00 – do godz. 22:00 i 3 – od godz. 22:00 – do godz. 6:00).

- shiftdate – data określająca dzień, w którym rozpoczęła się dana zmiana.

Dla każdego pola kwerendy można zadeklarować Agregat (average0, average, delta, end, max, min, range, start, Total, quality_bad, quality_good, qyality_uncertain) oraz Alias.

Agregat obliczany jest dla każdego interwału przy wykorzystaniu danych zarchiwizowanych w czasie trwania tego interwału.

Rysunek: Deklaracja pola kwerendy dla zapytań do archiwum wartości zmiennych procesowych.

Wynik zapytania – pole wyświetla wynik zapytania SQL do bazy definicji zmiennych

Rysunek: Zakładka z parametrami zapytania do archiwum wartości procesowych.

Zakładka Zapytanie utworzona poleceniem Nowe zapytanie – baza definicji zmiennych obejmuje następujące parametry:

Lista atrybutów – określa zestaw danych (pól kwerendy) – w tym przypadku atrybutów zmiennych, które będą prezentowane w raporcie.

Lista zmiennych – określa zestaw danych (pól kwerendy) – w tym przypadku nazw zmiennych, które będą prezentowane w raporcie.

Wynik zapytania – pole wyświetla składnię zapytania SQL do bazy definicji zmiennych

Rysunek: Zakładka z parametrami zapytania do bazy definicji zmiennych.


4.2 Deklaracja źródła danych, układu i stylu prezentowanych

4.2 Deklaracja źródła danych, układu i stylu prezentowanych danych przy użyciu kreatora

Przystępując do projektowania raportu należy określić format, w jakim będą prezentowane dane oraz źródło danych, z którego będą te dane pobierane. Poniżej został opisany tabelaryczny format wyświetlania danych w raporcie.

Po utworzeniu raportu można użyć kreatora tabeli, aby dodać do raportu tabelę i dane. Kreator pomaga zdefiniować połączenie ze źródłem danych, utworzyć kwerendę w celu określenia, które dane będą używane, zorganizować dane w grupy i dodać wiersze w celu wyświetlenia podsumowanych wartości dla zgrupowanych danych.

Kliknij przycisk Projekt, aby przełączyć się do widoku projektu.

Na powierzchni projektowej w obszarze Kliknij, aby dodać dane kliknij pozycję Tabela lub macierz.

Rysunek: Obszar ‘Kliknij, aby dodać dane’.

Zostanie otwarte okno Wybierz połączenie ze źródłem danych.

Rysunek: Okno ‘Wybierz połączenie ze źródłem danych’.

Jeśli na serwerze raportów znajduje się wyznaczony folder udostępnionych źródeł danych, zostanie wyświetlona lista źródeł danych. Jeśli nie - należy takie źródło zdefiniować.

Aby dodać źródło danych z poziomu raportu:

1. Kliknij przycisk Nowy….

2. Dla typu połączenia‘Microsoft SQL Server’zdefiniuj właściwości połączenia klikając na polecenie Trwa kompilowanie.

Rysunek: Okno definiowania właściwości połączeń z źródłem danych.

3. Podaj lokalizację bazy danych AsixConnect.

4. Kliknij dwukrotnie OK, a następnie Dalej.

UWAGA: W ten sposób definiowane jest źródło danych z poziomu raportu, aby jednak móc swobodnie modyfikować raporty zapisane na serwerze raportów – źródło danych powinno być utworzone na serwerze raportów (źródło danych zadeklarowane na serwerze raportów jest automatycznie wyświetlane w oknie ‘Wybierz połączenie ze źródłem danych’) . Można tego dokonać między innymi poprzez narzędzie Report Manager – dostępne wg poniższej ścieżki dostępu:

Menu Start > Microsoft SQL Server 2008 > Configuration Tools > Reporting Services Configuration Manager > Report Manager URL > link w polu URLs

Rysunek: Okno definiowania źródła danych na serwerze raportów przy użyciu Report Manager.

Po zadeklarowaniu źródła danych w następnych krokach należy utworzyć kwerendę określającą dane, które będą używane. Poniżej kontynuacja deklaracji danych przy użyciu kreatora tabeli.

Po zadeklarowaniu lokalizacji bazy AsixConnect w oknie kreatora tabeli pojawi się okno ‘Zaprojektuj kwerendę’.

Aby wkleić kwerendę przygotowaną w programie AsRaport, należy przygotować taką kwerendę, skopiować ją przy użyciu polecenia Kopiuj z zakładki narzędziowej programu AsRaport, następnie przejść do okna projektowania kwerendy w Report Builderze, wybrać opcję Edytuj jako tekst i wkleić skopiowaną definicję kwerendy (wynik działania kwerendy widoczny jest po naciśnięciu przycisku [image]).

Rysunek: Report Bulider – kreator tabeli – okno projektowania kwerendy.

Kliknij przycisk Dalej.

Uporządkuj pola, grupując dane w wiersze, kolumny lub wiersze i kolumny. Kliknij przycisk Dalej.

Rysunek: Report Bulider – kreator tabeli – okno grupowania pól.

Wybierz układ tabeli. Kliknij przycisk Dalej.

Rysunek: Report Bulider – kreator tabeli – okno układu tabeli.

Wybierz styl tabeli. Kliknij przycisk Zakończ.

Rysunek: Report Bulider – kreator tabeli – okno stylu tabeli.

Rysunek: Gotowy raport w widoku’ Projekt’.


4.3 Podgląd raportu

Podgląd raportu uruchamiany jest komendą Uruchom z zakładki Narzędzia główne Report Buildera.

Rysunek: Podgląd gotowego raportu.


4.5 Osadzone a udostępnione źródło danych

W programie Report Builder 2.0 można utworzyć nowe źródło danych odwołujące się do udostępnionego źródła danych umieszczonego na serwerze raportów lub osadzonego źródła danych, którego używa tylko dany raport.

Aby można było utworzyć odwołanie do udostępnionego źródła danych, trzeba mieć dostęp do serwera raportów oraz znać lokalizację źródła. W celu utworzenia osadzonego źródła danych należy podać dane połączenia oraz wiedzieć, które uprawnienia określić, tak aby ze źródła mogły być pobierane dane raportu.

Po przejściu do serwera raportów i wybraniu na nim udostępnionego źródła danych serwer staje się bieżącym serwerem raportów.

Aby utworzyć odwołanie do udostępnionego źródła danych

1. W okienku Dane raportu na pasku narzędzi okna głównego Report Buildera kliknij przycisk Nowy, a następnie kliknij pozycję Źródło danych. Zostanie otwarte okno dialogowe ‘Właściwości źródła danych’.

2. W polu tekstowym Nazwa wpisz nazwę dla tworzonego źródła danych lub zaakceptuj nazwę domyślną.

3. Zaznacz opcję Użyj połączenia udostępnionego lub modelu raportu. Pojawi się lista udostępnionych źródeł danych i modeli raportu używanych w raporcie. Jeśli lista jest pusta, kliknij przycisk Przeglądaj i przejdź do folderu na serwerze raportów, w którym znajdują się udostępnione źródła danych.

4. Zaznacz żądane udostępnione źródło danych. Kliknij przycisk OK.

5. Źródło danych zostanie wyświetlone w okienku Dane raportu.

Aby utworzyć osadzone źródło danych

1. Na pasku narzędzi okna głównego Report Buildera, w okienku Dane raportu kliknij przycisk Nowy, a następnie kliknij pozycję Źródło danych. Zostanie otwarte okno dialogowe ‘Właściwości źródła danych’.

2. W polu tekstowym Nazwa wpisz nazwę dla tworzonego źródła danych lub zaakceptuj nazwę domyślną.

3. Sprawdź, czy jest wybrana opcja Użyj połączenia osadzonego w tym raporcie.

4. Na liście rozwijanej Wybierz typ połączenia zaznacz typ źródła danych, np. Microsoft SQL Server czy OLE DB.

5. Używając jednego z poniższych sposobów, określ ciąg połączenia:

- Wpisz ciąg połączenia bezpośrednio w polu tekstowym Ciąg połączenia.

- Kliknij przycisk wyrażenia (fx). W oknie dialogowym Wyrażenie w okienku ‘Wyrażenie‘ wpisz treść wyrażenia. Kliknij przycisk OK.

6. Kliknij przycisk Utwórz. Zostanie otwarte okno dialogowe Właściwości połączenia dla połączenia z typem źródła danych wybranym we wcześniejszym kroku.

Wypełnij pola w oknie dialogowym Właściwości połączenia odpowiednio dla wybranego typu źródła. Właściwości połączenia obejmują m.in. typ i nazwę źródła danych oraz poświadczenia służące do nawiązywania łączności. Po wprowadzeniu wartości w tym oknie dialogowym kliknij przycisk Testuj połączenie i upewnij się, że źródło danych jest dostępne, a wprowadzone poświadczenia poprawne.

7. Kliknij pozycję Poświadczenia.

8. Określ poświadczenia, które będą używane w celu nawiązywania połączeń z tym źródłem danych. Za wybór akceptowanych poświadczeń odpowiada właściciel źródła danych. Czasami właściciel decyduje o udostępnieniu źródła na serwerze raportów i konfiguruje w jego ustawieniach poświadczenia, z których mogą korzystać inni użytkownicy. Poproś właściciela o te dane.

9. Kliknij przycisk OK.

10. Źródło danych zostanie wyświetlone w okienku Dane raportu.


6 Dostęp do raportów umieszczonych na serwerze raportów

Raporty udostępniane na serwerze raportów mogą być oglądane w przeglądarce internetowej po podaniu adresu do serwera raportów.

Serwer raportów dostępny jest w środowisku MS SQL Server 2008 Reporting Services w przeglądarce internetowej pod adresem:

http://<nazwa_komputera>/ReportServer_<nazwa_instancji_serwera_SQL>

Rysunek: Dostęp do serwera raportów przez przeglądarkę internetową.

Rysunek: Widok raportu oglądanego poprzez przeglądarkę internetową.

Taka forma dostępu do raportu umożliwia drukowanie raportów lub eksportowanie do plików w formacie: PDF, Excel lub Word.


AsRaport

Pomoc dla użytkowników systemu asix 6

www.asix.com.pl

Raportowanie w systemie asix

na bazie usług Reporting Services firmy Microsoft

Dok. Nr PLP6100

Wersja: 29-01-2010

ASKOM® i asix™ to zastrzeżone znaki firmy ASKOM Sp. z o. o., Gliwice. Inne występujące w tekście znaki firmowe bądź towarowe są zastrzeżonymi znakami ich właścicieli.

Wszelkie prawa zastrzeżone. Nieautoryzowane rozpowszechnianie całości lub fragmentu niniejszej publikacji w jakiejkolwiek postaci jest zabronione. Wykonywanie kopii metodą kserograficzną, fotograficzną lub inną powoduje naruszenie praw autorskich niniejszej publikacji.

ASKOM Sp. z o. o. nie bierze żadnej odpowiedzialności za jakiekolwiek szkody wynikłe z wykorzystywania zawartych w publikacji treści.

Copyright © 2010, ASKOM Sp. z o. o., Gliwice

ASKOM Sp. z o. o., ul. Józefa Sowińskiego 13, 44-121 Gliwice,

tel. +48 (0) 32 3018100, fax +48 (0) 32 3018101,

http://www.askom.com.pl , e-mail: office@askom.com.pl

Spis treści

1 Wprowadzenie

1.1 Wymagania programowe

2 Konfiguracja dostępu do danych aplikacji asix

2.1 Utworzenie bazy AsixConnect

2.2 Konfiguracja programu Askom Data Host

2.3 Konfiguracja programu AsRaport

2.4 Uruchomienie programu Askom.Data.Host.exe

2.5 Przykład

3 Projektowanie zapytań SQL do procedur składowanych bazy AsixConnect przy pomocy programu AsRaport

3.1 Odczyt danych / procedury składowane bazy AsixConnect

4 Projektowanie raportów w Report Builder

4.1 Utworzenie nowego raportu

4.2 Deklaracja źródła danych, układu i stylu prezentowanych danych przy użyciu kreatora

4.3 Podgląd raportu

4.4 Dodawanie i edycja zestawu danych

4.5 Osadzone a udostępnione źródło danych

4.6 Zapisywanie raportów

5 Projektowanie raportów w Report Designer

6 Dostęp do raportów umieszczonych na serwerze raportów


Przeglądanie raportów w aplikacji systemu asix

7. Przeglądanie raportów w aplikacji systemu asix

Przeglądane raportów utworzonych w środowisku MS SQL Reporting Services bezpośrednio w aplikacji systemu asix umożliwia przeglądarka raportów AsRapView uruchamiana akcją operatorską ASRAPORT.

Parametry akcji definiowane przy użyciu edytora akcji:

Nazwa raportu - nazwa raportu utworzonego przy użyciu usług Reporting Services (definicja raportu przechowywana w pliku *.RDL musi być opublikowana na serwerze raportów usług Reporting Services).

Opcjonalny plik konfiguracyjny – pole umożliwia zadeklarowanie pliku konfiguracyjnego wskazującego na inny serwer raportów bądź katalog raportów niż te zadeklarowane w pliku konfiguracyjnym bieżącej aplikacji.

Plik konfiguracyjny aplikacji asixa umożliwia zadeklarowanie 1 serwera raportów i 1 katalogu na tym serwerze (serwer i katalog deklarowane są przy pomocy konfiguratora systemu raportowania AsRaport dostępnego w Architekcie).

Aby wyświetlić raport z innego źródła (serwera, katalogu), należy utworzyć nowy plik konfiguracyjny aplikacji asixa z deklaracją innego serwera i katalogu. Wymagane jest aby w tym pliku skonfigurować parametry ustawiane przy pomocy konfiguratora systemu AsRaport oraz 3 inne parametry:

- położenie bazy definicji zmiennych (Architekt > Bazy danych > Baza definicji zmiennych > Format)

- nazwa sieciowa zestawu alarmów (Architekt > Obszary i komputery > System alarmów > Alarmy > Nazw sieciowa)

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów (Architekt > Obszary i komputery > System alarmów > Archiwum > Serwer Microsoft SQL)

Pozostałe parametry konfiguracyjne są w tym przypadku nieistotne. Następnie należy zadeklarować ten plik konfiguracyjny w polu Opcjonalny plik konfiguracyjny akcji AsRaport.

Domyślnie informacje na temat serwera raportów i katalogu raportów pobierane są z pliku konfiguracyjnego bieżącej aplikacji asixa.

Nazwa parametru raportu - opcja umożliwia wprowadzanie opcjonalnych parametrów raportu.

Składnia akcji definiowana ręcznie:

ASRAPORT <nazwa_raportu>[<opcjonalny_plik_konfiguracyjny><parametry_raportu>]

gdzie:

nazwa_raportu - nazwa raportu utworzonego przy użyciu usług Reporting Services (definicja raportu przechowywana w pliku *.RDL musi być opublikowana na serwerze raportów usług Reporting Services);

opcjonalny_plik_konfiguracyjny - pole umożliwia zadeklarowanie pliku konfiguracyjnego wskazującego na inny serwer raportów bądź katalog raportów niż te zadeklarowane w pliku konfiguracyjnym bieżącej aplikacji.

Plik konfiguracyjny aplikacji asixa umożliwia zadeklarowanie 1 serwera raportów i 1 katalogu na tym serwerze (serwer i katalog deklarowane są przy pomocy konfiguratora systemu raportowania AsRaport dostępnego w Architekcie).

Aby wyświetlić raport z innego źródła (serwera, katalogu), należy utworzyć nowy plik konfiguracyjny aplikacji asixa z deklaracją innego serwera i katalogu. Wymagane jest aby w tym pliku skonfigurować parametry ustawiane przy pomocy konfiguratora systemu AsRaport oraz 3 inne parametry:

- położenie bazy definicji zmiennych (Architekt > Bazy danych > Baza definicji zmiennych > Format)

- nazwa sieciowa zestawu alarmów (Architekt > Obszary i komputery > System alarmów > Alarmy > Nazw sieciowa)

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów (Architekt > Obszary i komputery > System alarmów > Archiwum > Serwer Microsoft SQL)

Pozostałe parametry konfiguracyjne są w tym przypadku nieistotne. Następnie należy zadeklarować ten plik konfiguracyjny w polu Opcjonalny plik konfiguracyjny akcji AsRaport.

Domyślnie informacje na temat serwera raportów i katalogu raportów pobierane są z pliku konfiguracyjnego bieżącej aplikacji asixa.

parametry_raportu - dodatkowe parametry raportu

Lokalizacja raportów wyświetlanych w przeglądarce AsRapView deklarowana jest w pliku konfiguracyjnym AsRapViewReportServerConfig.xml. Lokalizacja dotyczy miejsca na serwerze raportów MS SQL Reporting Services.

Konfiguracji dostępu do serwera raportów dla danej aplikacji systemu asix należy dokonać przy użyciu konfiguratora dostępnego w programie Architekt:

Architekt > Aplikacja > Konfiguruj system raportów AsRaport...