Witamy

>> Pomoc dla użytkowników systemu asix - wersji 6

www.asix.com.pl

AspadTools

Dok. Nr PLH6006

Wersja: 29-01-2010


1.1. Przeznaczenie programu AspadTools

Program AspadTools jest przeznaczony do przetwarzania i konserwacji plików archiwum typu Y, M, D i H.

Pozwala on na:

  • zmianę konwencji nazw plików ze starej (ASPAD 5) na nową (ASPAD 7) i odwrotnie,

  • konwersję archiwum na inny typ (np. M na D),

  • eksport do pliku tekstowego,

  • sprawdzenie i naprawę archiwum,

  • zbieranie statystyk dotyczących wielkości danych dla poszczególnych zarchiwizowanych przebiegów zmiennych,

  • zmianę nazwy lub usuwanie zmiennej z pliku archiwalnego,

  • konwersję czasu w archiwum z lokalnego na UTC i z UTC na lokalny.


1.2. AspadTools a wersje plików archiwalnych

Program AspadTools jest w zasadzie przeznaczony do współpracy z bieżącą wersją programu ASPAD. Oznacza to, że pliki tworzone przez AspadTools będą zgodne z aktualną wersją ASPAD’a, a mogą być niezrozumiałe dla jego starszych wersji.

Dotyczy to w szczególności ASPAD’a w wersji 5, który posługiwał się inną konwencją nazw plików i inaczej pakował w nich dane. Przed wykonaniem jakiejkolwiek innej operacji na plikach ASPAD’a 5, należy zmienić konwencję nazw plików na nową. Zaleca się też wykonanie kopii zapasowej oryginalnego pliku, gdyż niektóre operacje na plikach są nieodwracalne, a wynik nieczytelny dla ASPAD’a 5.

W niektórych przypadkach można użyć programu AspadTools do wykonania pewnych operacji na plikach ASPAD’a 5. Należy w tym celu:

  • wykonać kopie zapasowe oryginalnych plików,

  • zmienić konwencję nazw plików na nową, podając „ASPAD" jako nazwę zasobu,

  • wykonać określoną operację na plikach,

  • przywrócić stare nazwy plików.

Tylko część operacji pozwala na dalsze użytkowanie plików z ASPAD’em 5. Są to:

  • eksport do pliku tekstowego,

  • sprawdzenie i naprawa archiwum,

  • zbieranie statystyk dotyczących wielkości danych dla poszczególnych zarchiwizowanych przebiegów zmiennych,

  • zmiana nazwy lub usuwanie zmiennej z pliku archiwalnego.

Dla pozostałych operacji wynik nie będzie czytelny. W szczególności dla ASPAD’a 5 nie wolno wykonywać:

  • konwersji archiwum na inny typ (np. M na D),

  • przepakowania danych do nowego pliku.


1.3. Uruchamianie programu z parametrami

Program AspadTools.exe może być uruchamiany w linii polecenia z następującymi parametrami:

- jednym z parametrów musi być nazwa pliku archiwum;

- parametr –U oznacza, że program nie powinien wyprowadzać komunikatów wymagających odpowiedzi operatora;

- parametr –R oznacza weryfikację i rekonstrukcję pliku;

- podanie tylko nazwy pliku archiwum oznacza, że dany plik ma być pokazany w przeglądarce.

UWAGA Należy podać ścieżkę dostępu do pliku archiwum.


2.1. Zmiana konwencji nazw plikówIDH_Rename

2.1. Zmiana konwencji nazw plików

ASPAD od wersji 6 stosuje nową konwencję nazw plików.

W poprzednich wersjach plik archiwum z grudnia 2000 nazywałby się ASPAD.AC@, gdzie ASPAD jest stałą nazwą, a czas jest zakodowany w 3-literowym rozszerzeniu nazwy.

Obecnie taki plik mógłby się nazywać M200012xx-BL06.ahf, gdzie pierwsze 10 znaków koduje typ archiwum i okres danego pliku, .ahf jest stałym rozszerzeniem nazwy plików archiwalnych, a BL06 jest nazwą zasobu archiwalnego. Dokładniejszy opis konwencji nazw plików można znaleźć w dokumentacji systemu asix.

Aby zmienić konwencję na nową, zrozumiałą dla ASPAD’a 6, należy wybrać jeden lub kilka plików o starej konwencji nazw i dla wskazanych plików wykonać akcję Konwersja-Konwertuj nazwy plików. Program zapyta o nazwę zasobu. Należy podać taką nazwę, jaka będzie przypisana w przyszłości do zasobu archiwizowanego w tych plikach.

Jeżeli planujemy pracę tylko z jednym zasobem archiwalnym, a typ archiwum nie ma ulec zmianie (archiwum M pozostanie M, H pozostanie H), to wykonanie zmiany nazw plików jest wystarczające, aby ASPAD 6 mógł z takimi plikami pracować.

Jeżeli będzie tam archiwizowanych kilka zasobów, ale nie zmieni się typ archiwum, to można wybrać jeden z następujących sposobów postępowania:

  • wykonać kilka kopii każdego pliku, odpowiednio zmieniając część nazwy odpowiadającą nazwie zasobu,

  • jako nazwę zasobu należy wpisać dowolną nazwę np. „ASPAD", a pliki poddać dalszej obróbce,

Zmiana typu archiwum wymusza wykonanie zaawansowanych operacji konwersji archiwum.

Program AspadTools pozwala także odwrócić operację zmiany konwencji nazw plików. W tym celu należy wybrać z listy odpowiednie pliki i wywołać z menu akcję Konwersja-Przywróć stare nazwy plików. Plikom zostaną nadane rozszerzenia nazwy odpowiadające ich czasom, a sama nazwa będzie nazwą zasobu. Jeżeli nazwa zasobu była inna niż „ASPAD", to w plikach wynikowych należy ich nazwy zmienić ręcznie na „ASPAD". Operacja przywracania starych nazw plików może być wykonana tylko dla archiwum typu H i M.


2.2. Konwersja archiwumIDH_Convert

2.2. Konwersja archiwum

Dzięki konwersji plików archiwalnych możemy:

  • zmienić typ archiwum np. z M na D,

  • rozdzielić zmienne dla poszczególnych zasobów do oddzielnych plików,

  • przepakować dane z wykorzystaniem ulepszonych metod kompresji ASPAD’a 6, przez dokonanie konwersji na ten sam typ archiwum,

  • wyeksportować dane do pliku tekstowego.

Konwersja musi być przeprowadzana z zachowaniem dużej ostrożności. Poprawne rezultaty uzyskamy tylko pod warunkiem przestrzegania poniższych reguł:

  • poprawnie można przetwarzać tylko pliki w nowej konwencji nazw ASPAD’a 6, a nazwy plików w starej konwencji należy wcześniej zamienić na nową,

  • nie wolno dopuścić do zapisu wyników do tego samego pliku, najlepiej zapisując wynikowe pliki do nowej kartoteki,

  • dane są dopisywane na końcu pliku wynikowego, więc nie wolno dopisywać dwa razy tych samych danych (z tego samego okresu) do tego samego pliku,

  • pliki muszą być przetwarzane w kolejności chronologicznej (np. nie wolno konwertować pliku z sierpnia po pliku z września); w przypadku zaznaczenia kilku plików do przetwarzania, AspadTools sam porządkuje je w kolejności chronologicznej.

Konwersję plików archiwalnych inicjuje się akcją Konwersja-Konwertuj pliki. Po jej wybraniu pojawia się okno konwersji, z którego można zdefiniować listę operacji do wykonania i wystartować konwersję.


2.3. Okno konwersji

Po wybraniu operacji konwersji pojawia się pokazane niżej okno, z którego można zdefiniować listę operacji do wykonania i wystartować konwersję.

Rysunek 2. Okno konwersji archiwum.

W dolnej części okna przedstawiona jest lista operacji do wykonania na każdym pliku. Lista ta odpowiada zawartości pliku AspadToolsConvert.ini, który jest tworzony automatycznie przez AspadTools przy definiowaniu konwersji. Przy pierwszym uruchomieniu lista operacji jest pusta.

Naciśnięcie przycisku akceptacji spowoduje rozpoczęcie wykonywania operacji z listy dla każdego pliku wybranego do przetwarzania.

Listę można modyfikować dodając do niej nowe linie lub usuwając stare.

W celu usunięcia linii z listy należy ją wskazać, a następnie nacisnąć przycisk Usuń.

Przed dodaniem nowego elementu listy należy zdefiniować odpowiednie parametry w polach w górnej części okna, a następnie nacisnąć przycisk Dodaj.

Znaczenie większości pól jest oczywiste. Wyjaśnienia wymaga możliwość wyboru tekstu, jako typu archiwum. Taki wybór spowoduje utworzenie pliku lub plików tekstowych o takiej samej nazwie jak plik archiwalny, ale z rozszerzeniem .txt. Zostanie w nim umieszczona zawartość archiwum w postaci tekstowej, przy czym dane będą poddane dekompresji, a dziury w archiwum zostaną pominięte.

Porady na temat konwersji można znaleźć w rozdziale Jak skonwertować archiwum?.


2.4. Plik definicji operacji konwersjiIDH_ConvIni

2.4. Plik definicji operacji konwersji

Lista definicji operacji, które należy wykonać w trakcie konwersji przechowywana jest w pliku AspadToolsConvert.ini w kartotece archiwum źródłowego.

Każda operacja jest definiowana za pomocą następującej linii tekstowej:

typ_archiwum_wynikowego, nazwa_zasobu_wynikowego, kartoteka_docelowa, [plik_konfiguracyjny]

gdzie:

typ_archiwum_wynikowego - Y, M, D lub H albo T(eksport do pliku tekstowego),

nazwa_zasobu_wynikowego - nazwa zasobu, którego dane mają być umieszczone w pliku,

kartoteka_docelowa - pełna ścieżka do kartoteki, w której mają być umieszczone pliki wynikowe,

plik_konfiguracyjny - opcjonalna definicja pliku zawierającego deklaracje archiwizacji zmiennych ASPAD’a (plik umieszczany w deklaracjach ZMIENNE=..); tylko zmienne zdefiniowane w tym pliku i o typie archiwum podanym w parametrze typ_archiwum_wynikowego zostaną umieszczone w pliku wynikowym; pominięcie tego parametru spowoduje przetworzenie wszystkich zmiennych pliku źródłowego.

Na przykład linia:

D, Aspad, D:\Test\ArcH\D, D:\Test\ArcH\Kociol_01.aspad

oznacza, że każdy plik archiwalny zostanie przetworzony na archiwum D o nazwie zasobu Aspad i umieszczony w kartotece D:\Test\ArcH\D, przy czym w plikach wynikowych znajdą się tylko zmienne, których archiwum zostało zadeklarowane w pliku D:\Test\ArcH\Kociol_01.aspad jako D.


2.4.2. Konwersja do jednego zasobu bez zmiany typu archiwum

Jeżeli wszystkie dane chcemy umieścić pod jedną nazwą zasobu i nie chcemy zmieniać typu archiwizacji, to wystarczy doprowadzić do zgodności nazewnictwa plików do aktualnej konwencji. W tym celu należy wyselekcjonować odpowiednie pliki i zmienić stare nazwy plików na nowe.


2.4.4. Konwersja do wielu zasobów

Jeżeli będzie konieczne rozdzielenie zasobów archiwum lub konwersja na różne typy archiwizacji, to należy:

  • doprowadzić do zgodności nazw plików z aktualną konwencją - wyselekcjonować pliki o starej konwencji nazw i zmienić stare nazwy plików na nowe,

  • przygotować docelowe pliki konfiguracyjne ASPAD’a,

  • wyselekcjonować pliki do konwersji i wywołać okno konwersji plików,

  • na liście operacji do wykonania umieścić po jednej linii dla każdego typu archiwum i pliku konfiguracyjnego ze zmiennymi ASPAD’a, podając dla każdej linii wszystkie parametry, włącznie z nazwą pliku z parametrami zmiennych,

  • wykonać zadaną listę operację konwersji.

Jeżeli tworzymy kilka zasobów, ale nie zmieniamy typu archiwum, to wystarczy zmienić stare nazwy plików na nowe, a następnie wykonać po jednej kopii każdego pliku dla każdego zasobu, odpowiednio zmieniając część nazwy pliku zawierającą nazwę zasobu. Jest to metoda szybka, ale powoduje zwielokrotnienie zajętego miejsca na dysku.

UWAGA Koniecznie należy pamiętać o chronologicznym przetwarzaniu plików dla każdego zasobu.


3.1. Statystyki zmiennychIDH_Statistics

3.1. Statystyki zmiennych

Akcja Statystyka-Oblicz statystyki zmiennych powoduje obliczenie liczby 512-bajtowych bloków danych dla wszystkich zmiennych archiwizowanych w poszczególnych plikach. Statystyki są tworzone dla każdego pliku archiwalnego osobno i dopisywane na końcu do pliku AspadTools.log.

Informacje o liczbie bloków są przydatne przy optymalizacji aplikacji. Pozwalają określić, które zmienne zajmują najwięcej miejsca w archiwum i warto przyjrzeć się ich parametrom archiwizacji, głównie częstotliwości próbkowania, dokładności rejestracji wartości i czasu i ewentualnie warunkom archiwizacji.


4.1. Poprawianie uszkodzonych plików

4.1. Poprawianie uszkodzonych plików archiwalnych

Czasami dochodzi do uszkodzenia plików archiwalnych. Dochodzi do nich zwykle w przypadku niespodziewanego zakończenia pracy systemu operacyjnego (zanik napięcia, niebieski ekran). Program AspadTools umożliwia sprawdzanie poprawności struktury pliku archiwalnego, a także umożliwia poprawianie struktury pliku lub przepisanie jego zawartości do nowego pliku o poprawnej strukturze.


4.2. Weryfikacja struktury pliku archiwumIDH_Verify

4.2. Weryfikacja struktury pliku archiwum

Aby sprawdzić, czy archiwum jest poprawne, należy wskazać jeden lub wiele plików do weryfikacji i wykonać akcję Naprawa-Sprawdź.

Program sprawdzi poprawność struktury pliku i poinformuje o wyniku weryfikacji odpowiednim komunikatem. Bliższe informacje będą zawarte w pliku AspadTools.log.

Program zapamiętuje w pliku wynik jego sprawdzenia i przy ponownym wykonaniu tej akcji, jeżeli plik nie był modyfikowany, to nie sprawdza go powtórnie, a tylko odtwarza zapamiętany poprzednio wynik.

Program sprawdza tylko poprawność struktury pliku, a nie dane w nim zgromadzone. Stwierdzenie poprawności struktury pliku nie gwarantuje poprawności zawartych w nim danych, a jedynie zapewnia, że jest możliwy prawidłowy do nich dostęp.

W przypadku stwierdzenia nieprawidłowej struktury pliku należy taki plik naprawić.


4.3. Naprawa struktury pliku archiwum

Jeżeli zostało stwierdzone uszkodzenie struktury pliku archiwum lub zachodzi podejrzenie jej uszkodzenia, to można spróbować dokonać jej naprawy. Należy w tym celu wskazać jeden lub kilka plików archiwum i wykonać akcję Naprawa-Sprawdź i napraw.

Struktura plików jest najpierw sprawdzana (tylko, gdy plik nie był wcześniej sprawdzony) i w przypadku błędów jego zawartość jest porządkowana i zapisywana do innego pliku do tymczasowej podkartoteki „__TMP__". Jeżeli operacja zakończy się powodzeniem, to rozszerzenie nazwy oryginalnego pliku jest zmieniane na „.bak", a tymczasowy plik jest przepisywany w miejsce oryginalnego. Zawartość podkartoteki „__TMP__" jest usuwana.

Nowy plik zawiera te same dane, co plik oryginalny, a naprawieniu podlega tylko jego struktura tak, aby możliwy był poprawny dostęp do zgromadzonych danych. Jeżeli zachodzi podejrzenie, że same dane mogą być przyczyną problemów, np. zawierają wartości nieskończone lub nie będące liczbami, to szansę na ich usunięcie daje przepisanie wszystkich danych do nowego pliku.


4.4. Przepakowanie danych do nowego plikuIDH_CopyData

4.4. Przepakowanie danych do nowego pliku

Jeżeli zachodzi podejrzenie, że same dane mogą być przyczyną problemów, np. zawierają wartości nieskończone lub nie będące liczbami, to szansę na ich usunięcie daje przepisanie wszystkich danych do nowego pliku. Aby tego dokonać należy wskazać jeden lub kilka plików i wykonać akcję Naprawa-Przepisz dane do nowego pliku.

Program rozpakuje wszystkie dane z pliku źródłowego i ponownie zapakuje je do pliku wynikowego, umieszczonego w tymczasowej podkartotece „__TMP__". Jeżeli operacja zakończy się powodzeniem, to rozszerzenie nazwy oryginalnego pliku jest zmieniane na „.bak", a tymczasowy plik jest przepisywany w miejsce oryginalnego. Zawartość podkartoteki „__TMP__" jest usuwana.

Podczas tej operacji usuwane są dane o wartościach nieskończonych lub nie będące liczbami. W pliku wynikowym dane będą spakowane zgodnie z aktualnymi metodami kompresji.

UWAGA Ta metoda spowoduje przepisanie danych tylko dla tych zmiennych, dla których poprawnie zachowała się informacja o typie zmiennej (jest ona potrzebna do rozpakowania danych). Jeżeli ta informacja uległa zniszczeniu, to dane dla zmiennej zostaną utracone. Dlatego należy unikać stosowania tej metody w przypadku, gdy wystarczająca jest naprawa struktury archiwum oraz pamiętać o zachowaniu kopii zapasowej archiwum.


5.1. Zmiana nazwy i usuwanie zmiennejIDH_RenameVar

5.1. Zmiana nazwy i usuwanie zmiennej

Czasami zachodzi potrzeba usunięcia dotychczasowego przebiegu zmiennej lub zmiany nazwy zmiennej w pliku archiwalnym. Przykładem jest zmiana typu zmiennej, uniemożliwiająca poprawny odczyt dotychczasowego jej przebiegu lub zmiana nazw technologicznych archiwizowanych zmiennych.

W celu zmiany nazwy zmiennej należy wybrać z listy pliki archiwalne, w których należy dokonać zmian, a następnie wykonać akcję Zmienne-Zmień nazwę zmiennej (polecenie dostępne z menu Zmienne lub pod przyciskiem [image] na pasku narzędzi). Program zapyta o starą i nową nazwę zmiennej, a po naciśnięciu przycisku OK wykona operację zmiany nazw zmiennych na wszystkich zaznaczonych plikach.

Rysunek 3. Uruchamianie polecenia zmiany nazwy zmiennej.

Usuwanie zmiennej polega na zmianie jej nazwy na taką, która nie koliduje z już istniejącymi nazwami. Zaleca się wybór takiej nazwy, która pozwoliłaby na łatwe jej odnalezienie, w przypadku, gdyby należało przywrócić stare archiwum.

W razie problemów ze znalezieniem odpowiedniej nazwy zmiennej można skorzystać z funkcji tworzenia statystyk zmiennych, która wygeneruje plik z listą zmiennych.


5.2. Zmiana nazw wielu zmiennychZmiana_nazw_wielu_zmiennych

5.2. Zmiana nazw wielu zmiennych

W celu umożliwienia łatwiejszej zmiany nazw zmiennych w plikach archiwalnych przygotowana została funkcja ‘Zmień nazwy wielu zmiennych’.

Funkcję można wywołać z menu kontekstowego, menu głównego lub za pomocą przycisku [image].

Aby dokonać zmiany nazw, należy najpierw przygotować listę tłumaczeń nazw zmiennych w pliku tekstowym w formacie zgodnym z programem ZmianaDP. W kolejnych liniach należy umieścić po 2 nazwy: stara nazwa, spacja, nowa nazwa. Jeżeli linia zawiera tylko jedną nazwę lub jest pusta, to zostanie pominięta.

Następnie na liście plików programu AspadTools należy wybrać pliki, w których będzie dokonana zmiana nazw.

Rysunek 4. Uruchamianie akcji zmiany nazw wielu zmiennych.

Po wywołaniu funkcji pojawia się ostrzeżenie z zaleceniem wykonania kopii zapasowej archiwum, a następnie dialog z pytaniem o plik z listą tłumaczeń nazw zmiennych.

Po zatwierdzeniu nazwy pliku, sprawdzana jest jego zawartość oraz zawartość plików archiwalnych. Jeżeli wystąpią błędy, np. w archiwum już była zmienna o nazwie, którą podano jako docelową, to konwersja nie zostanie przeprowadzona, a użytkownik zostanie poinformowany o błędzie. Szczegółowe informacje o błędach zostaną zapisane do pliku AspadTools.log w katalogu archiwum.

Jeżeli błędów tego typu nie pojawią się, to w wybranych plikach nazwy zmiennych zostaną zmienione.


5.3. Zapisywanie listy zmiennychZapisywanie_listy_zmiennych

5.3. Zapisywanie listy zmiennych

Funkcję ‘Zapisz listę zmiennych’ utworzono w celu ułatwienia tworzenia listy dla funkcji ‘Zmień nazwy wielu zmiennych’.

Funkcję można wywołać z menu kontekstowego, menu głównego lub za pomocą przycisku [image] .

Aby wygenerować plik z nazwami, na liście plików programu AspadTools należy wybrać pliki, z których będzie generowana lista nazw.

Rysunek 5. Selekcja plików do utworzenia listy zmiennych.

Po wywołaniu funkcji pojawia się dialog z pytaniem o docelowy plik z listą nazw zmiennych. Po zatwierdzeniu nazwy pliku generowana jest alfabetycznie uporządkowana lista wszystkich nazw zmiennych znalezionych w wybranych plikach archiwum.

Rysunek 6. Plik z listą zmiennych.


1.4. Główne okno programuIDH_MainWindow

1.4. Główne okno programu

Główne okno programu AspadTools przedstawia poniższy rysunek.

Rysunek 1. Główne okno programu AspadTools.

Za pomocą tego okna można wykonać wybrane akcje na wskazanych plikach.

Po lewej stronie znajduje się pole wyboru kartoteki zawierającej archiwum. Pliki archiwalne znajdujące się w tej kartotece pojawiają się po prawej stronie.

Listę plików można wyświetlać w sposób selektywny poprzez wybór odpowiednich filtrów w polach wyboru znajdujących się nad listą. Można wybrać tylko pliki związane z określonym zasobem, przy czym <wszystkie> oznacza wybór wszystkich zasobów. Można też zmieniać zaznaczenia określonych typów plików (Y, M, D, H). Tylko pliki wybranych typów pojawią się na liście.

Na liście plików można wskazać jeden lub kilka plików, na których zostaną wykonane określone akcje takie, jak zmiana konwencji nazw plików, konwersji archiwum na inny typ, czy zbieranie statystyk.

Odpowiednią akcję można zainicjować za pośrednictwem głównego menu, menu kontekstowego (po naciśnięciu prawego klawisza myszy) lub przez naciśnięcie odpowiedniego klawisza na pasku narzędzi.

Przebieg wykonania akcji jest rejestrowany w pliku AspadTools.log w kartotece, w której znajdują się pliki archiwum.


1. Wstęp


2.4.1. Jak skonwertować archiwum?IDH_ConvGuide

2.4.1. Jak skonwertować archiwum?

Przystępując do konwersji należy rozróżnić kilka przypadków

  • nie chcemy zmieniać typu archiwum, a wszystkie dane będą związane z jednym zasobem,

  • chcemy zmienić typ archiwum, ale wszystkie zmienne mogą być umieszczone w jednym zasobie,

  • dane chcemy rozdzielić do różnych zasobów.

Szczególnym przypadkiem konwersji jest eksport do pliku tekstowego.


2.4.3. Konwersja do jednego zasobu ze zmianą typu archiwum

Jeżeli nie będzie konieczne rozdzielenie zasobów archiwum lub rozdzielenie zmiennych na różne typy archiwizacji, to należy:

  • doprowadzić do zgodności nazw plików z aktualną konwencją - wyselekcjonować pliki o starej konwencji nazw i zmienić stare nazwy plików na nowe,

  • wyselekcjonować pliki do konwersji i wywołać okno konwersji plików,

  • na liście operacji do wykonania umieścić jedną linię z podaniem docelowego typu, nazwy zasobu i kartoteki, bez określania pliku z parametrami zmiennych,

  • wykonać zadaną operację konwersji.

UWAGA Koniecznie należy pamiętać o chronologicznym przetwarzaniu plików.


2.4.5. Jak wyeksportować dane do pliku tekstowego?

Eksport do pliku tekstowego nie różni się zasadniczo od konwersji. Jedyną różnicą jest wybór tekstu w miejsce typu archiwum.

W pliku tekstowym każdy zarchiwizowany punkt jest reprezentowany w jednym wierszu i zawiera nazwę zmiennej, czas, szesnastkowo kodowany status OPC i wartość zmiennej.

Jeżeli w wierszu brak wartości zmiennej, a status jest równy 0, to czas oznacza początek dziury w archiwum.

Jeżeli przy zadawaniu parametrów konwersji podano plik z parametrami zmiennych, to dane poddawane są dekompresji z okresem odpowiadającym okresowi próbkowania zmiennej.


2. Konwersja i eksport danych


3. Statystyki danych


4. Naprawa archiwum


5. Operacje na zmiennych