Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 7

www.asix.com.pl

Moduł Architekt -

Interaktywne środowisko konfigurowania aplikacji systemu Asix

Obsługa baz definicji zmiennych VarDef

Dok. Nr PLH7019

Wersja: 2013-07-22

UWAGA:

Niniejszy podręcznik dedykowany jest zasadniczo klasycznym aplikacjom systemu Asix. Dla aplikacji zaprojektowanym w wersji Evo systemu Asix istotne są rozdziały dotyczące:

- obsługi bazy definicji zmiennych,

- konfigurowania bazy definicji alarmów,

- konfiguracji parametrów startowych (startowanie Askom.Data.Host),

- konfiguracji danych bieżących,

- konfiguracji danych achiwalnych,

- konfiguracji modułu sieci,

- oraz konfiguratorów: aplikacji AsPortal, AsTrend, AsAlarm i AsRaport.


1.1 Wstep

1.1 Wstęp

Podręcznik Architekt przeznaczony jest dla wszystkich użytkowników oprogramowania A six. Opisuje on strukturę i funkcje modułu Architekt, pozwalając tym samym nabyć wiedzę z zakresu konfigurowania aplikacji systemu A six.

Architekt umożliwia w pełni wizualne zaprojektowanie, skonfigurowanie i bieżącą edycję aplikacji. W szczególności dotyczy to edycji definicji kanałów i definicji adresów zmiennych.

Parametryzując aplikację przy wykorzystaniu programu Architekt, użytkownik wykorzystuje do tego celu okna wyposażone w system wygodnych w obsłudze zakładek, które w uporządkowany sposób grupują opcje odpowiedzialne za poszczególne obszary funkcjonalne projektowanej aplikacji. Moduł Architekt stanowi potężne narzędzie integrujące konfigurację wszystkich kluczowych modułów odpowiedzialnych za sposób działania systemu A six [1] . Przy jego użyciu użytkownik może dokonać ustawień i modyfikować wszystkie opcje i parametry niezbędne do prawidłowego działania aplikacji systemu A six. Takie rozwiązanie pozwala znacznie skrócić czas tworzenia zaawansowanych aplikacji oraz ułatwia zarządzanie pracą całego systemu sterowania i nadzoru procesów przemysłowych.

Program Architekt zawiera w sobie moduł VarDef, odpowiedzialny za zarządzanie bazą definicji zmiennych. Umożliwia w pełni interaktywną i wizualną obsługę bazy definicji, tworzenie struktury bazy i jej edycję oraz edycję zawartości bazy. Architekt zapewnia obsługę baz Microsoft SQL Server 2000/2005/2008, baz formatu MDB (Jet / Microsoft Access), a także baz definicji zmiennych bezpośrednio pobieranych ze skoroszytów programu Excel. Dla zapewnienia kompatybilności z wcześniejszymi wersjami pakietu A six, definicje zmiennych mogą być również pobierane z bazy formatu Paradox i plików tekstowych.

Materiał zamieszczony w niniejszym podręczniku prezentuje krok po kroku pełny proces konfigurowania aplikacji systemu A six w wersji klasycznej.

UWAGA: Konfiguracja aplikacji systemu Asix w wersji Evo (Asix.Evo) przy użyciu Architekta obejmuje zawężony zestaw parametrów, które należy zdefiniować na etapie tworzenia nowej aplikacji przy użyciu kreatora aplikacji Asix.Evo uruchamianego z programu AsixEvo.exe - wspomniany kreator wskazuje krok po kroku parametry, które należy skonfigurować.

_______________________________________

[1] Z zakresu konfiguracji aplikacji systemu Asix przy użyciu modułu Architekt wyłączona jest edycja: masek, skryptów, raportów, map bitowych, timerów, trendów, pliku wykluczeń do alarmów, pliku archiwizacji warunkowej. Sposób działania kluczowych modułów oraz kluczowych funkcji systemu Asix omawia podręcznik ’Asix – funkcjonalność i zasady działania’. Opisy funkcjonalności pozostałych modułów pakietu Asix znajdują się w odrębnych podręcznikach, które mieszczą się w katalogu ’Dokumentacja’ (pliki PDF) oraz ’HelpPL’ (pliki CHM, HLP).


1.2 Komponenty systemu Asix

System A six jest systemem otwartym zbudowanym w oparciu o technologie OPC (OLE for Process Control), DDE, Automation, OLE DB, .NET, z możliwością pracy w Internecie i sieciach rozległych (TAPI). Jego modularna budowa stwarza możliwości optymalnego dopasowania funkcjonalności do wymaganych potrzeb.

Dla zaprezentowania możliwości funkcjonalnych jakie oferuje system A six, poniżej zamieszczony został krótki przegląd jego poszczególnych komponentów. Powiązanie modułu Architekt z pozostałymi komponentami systemu A six prezentuje Rysunek: Główne komponenty systemu asix - wersji klasycznej oraz Rysunek: Główne komponenty systemu Asix.Evo.

Rysunek: Główne komponenty systemu Asix - wersji klasycznej.

Rysunek: Główne komponenty systemu Asix.Evo.

uwaga W przypadku parametryzowania aplikacji projektowanej przy użyciu Asixa w wersji Evo, zestaw dostępnych parametrów redukowany jest w Architekcie do zestawu parametryzujacego tzw. serwer danych, czyli zestaw modułów niezbędnych do tego, aby pozyskiwać dane procesowe i je archiwizować. W systemie Asix wersji Evo moduł AsixEvo.exe przejmuje funkcje innych modułów wersji klasycznej Asixa odpowiedzialnych za obsługę skryptów, generowanie aplikacji WWW, zarządzanie uprawnieniami użytkowników, obsługę przebiegów wzorcowych, czy projektowanie części wizualizacyjnej aplikacji.

Baza definicji zmiennych - VarDef

W systemie A six baza definicji zmiennych jest miejscem przechowywania wszelkich informacji o zmiennych procesowych. Każdej zmiennej identyfikowanej poprzez unikalną Nazwę odpowiada jeden rekord w bazie definicji zmiennych; pola tego rekordu zawierają wartości tzw. atrybutów zmiennej. Lista atrybutów zawiera pozycje obligatoryjne, opcjonalne oraz definiowane przez użytkownika. Atrybutami obligatoryjnymi są np.: opis zmiennej, jednostka, nazwa kanału komunikacji z obiektem, deklaracja sposobu przetwarzania przy pobieraniu ze sterownika, parametry archiwizacji. Atrybuty opcjonalne to np.: limity, format, zakresy. Poza powyższymi, użytkownik może również utworzyć swoje atrybuty tekstowe, indywidualnie dla każdego projektu, np.: KKS, czy dane montażowe.

System VarDef obsługuje bazy danych serwera Microsoft SQL Server 2000/2005/2008 oraz bazy danych w formacie MDB (Jet / Microsoft Access). Dla przeniesienia aplikacji z wcześniejszych wersji systemu A six dane definicji zmiennych mogą być przekonwertowane z bazy Paradox lub plików tekstowych do formatu bazy MSQL lub Jet.

Moduł Architekt zapewnia pełną obsługę bazy VarDef w formacie Jet lub MS SQL. W tym zakresie łączy on w sobie funkcjonalność dwóch odrębnych programów stosowanych wcześniej do tworzenia i edycji baz definicji zmiennych: Menedżera Bazy Zmiennych i Edytora Bazy Zmiennych (używane w starszych wersjach pakietu A six). Programy te nadal dołączane są do pakietu asix, aby można było korzystać ze starej wersji bazy.

AS

Podstawę systemu A six stanowi moduł AS. W trakcie pracy systemu A six w trybie konstrukcyjnym program AS przybiera postać okna Konstruktora i udostępnia zestaw komend i obiektów służących do projektowania aplikacji. Konstruktor pozwala zaprojektować, sparametryzować okna aplikacji i uruchomić aplikację. Aplikacja składa się z systemu okien - tzw. masek procesowych (inaczej ekranów synoptycznych aplikacji), które odpowiednio sparametryzowane obrazują stan monitorowanego i sterowanego procesu przemysłowego. Bogata biblioteka obiektów statycznych oraz dynamicznych, których atrybuty są kontrolowane przez wartości zmiennych procesowych, daje duże możliwości w budowie systemu wizualizacji.

W momencie startu programu AS w trybie wykonania aplikacji automatycznie aktywowane jest okno Panelu Kontrolnego. Jest to centralne okno aplikacji, które udostępnia zestaw komend służących do kontroli pracy aplikacji oraz pokazuje i przechowuje komunikaty dotyczące wewnętrznej pracy systemu A six.

Zarówno tryb konstruowania jak i wykonywania aplikacji realizowany jest przez program AS w oparciu o plik konfiguracyjny w formacie xml. Plik ten jest tworzony przez program Architekt i przechowuje ustawienia wszystkich parametrów aplikacji systemu A six.

Operacje wspomagające działanie modułu AS realizowane są przez moduły: Asmen, Aslink i Aspad.

Asmen

Moduł Asmen to menedżer komunikacyjny, który odpowiada za przesył danych między komputerem, na którym została uruchomiona aplikacja systemu A six, a sterownikami obsługującymi kontrolowany proces. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery komunikacyjne pracujące pod kontrolą Asmena. Zestaw drajwerów wykorzystywanych w systemie wizualizacji zależy każdorazowo od sposobu połączenia danego systemu ze sterownikami przemysłowymi.

Szczególnym trybem pracy modułu Asmen jest działanie w trybie symulacji. Polega ono na tym, że wartości zmiennych procesowych nie są określane w oparciu o dane pochodzące z fizycznego kanału transmisji, lecz są generowane przy użyciu odpowiednich funkcji przeliczających, zaprojektowanych pod kątem symulowania pracy ze środowiskiem docelowym. Tryb symulacji jest szczególnie przydatny na etapie projektowania aplikacji, gdy połączenie ze sterownikami jest najczęściej niemożliwe.

Aslink

Moduł Aslink jest modułem sieciowym używanym w instalacjach sieciowych. Umożliwia on innym komponentom systemu A six wzajemną komunikację poprzez lokalną sieć komputerową. ASLINK definiuje zestaw usług sieciowych, z których korzystają wszystkie inne programy systemu A six.

Aspad

Moduł Aspad jest modułem archiwizacji danych, przeznaczonym do rejestracji i późniejszego odtwarzania przebiegów czasowych zmiennych. W systemie A six przebiegi te są wykorzystywane przy tworzeniu wykresów i raportów. Mogą też być użyte przez przeliczniki do obliczania syntetycznych zmiennych. Przetwarzanie i konserwację plików archiwum wspomaga dodatkowe narzędzie AspadTools.

AsixConnect

Komputer posiadający fizyczne połączenie ze sterownikiem (za pośrednictwem łącza szeregowego, magistrali przemysłowej lub sieci lokalnej) stanowi źródło informacji o zmiennych procesowych dla innych komputerów w sieci lokalnej; komputer taki jest serwerem danych bieżących i archiwalnych oraz alarmów. W dostępie do tych danych pośredniczy pakiet AsixConnect.

Za pośrednictwem programu AsixConnect przebiegi czasowe zmiennych systemu A six mogą być eksportowane do innych programów, np. do arkuszy EXCEL, za pomocą mechanizmu DDE, Automation lub .NET.

AsTrend

Program AsTrend przeznaczony jest do graficznej prezentacji danych archiwalnych gromadzonych przez program archiwizacji danych Aspad. Pozwala on na wyświetlanie, przeglądanie i drukowanie przebiegów czasowych wybranych zestawów zmiennych i służy do przygotowania swego rodzaju ”raportów graficznych” pracy obiektu. Możliwe są dwa sposoby pracy tego programu: statyczne odrysowanie danych zgromadzonych w plikach archiwalnych lub dynamiczne wyświetlanie w trybie rejestratora danych napływających ze sterowników.

AsScripter

Moduł skryptowania jest rozszerzeniem systemu A six pozwalającym na wykonywanie skryptów w technologii ActiveX Scripting, napisanych w językach VBScript lub JScript. Skrypty pozwalają realizować nietypowe obliczenia, programować specjalne reakcje systemu na zdarzenia, obsługiwać dedykowane bazy danych i wyliczać raporty.

AsAlert

Moduł AsAlert służy do zdalnego powiadamiania wybranych osób o ważnych zdarzeniach pocztą elektroniczną lub komunikatami SMS. AsAlert może pracować jako program powiadamiający ogólnego przeznaczenia. Jego siła objawia się w pełni podczas pracy w ramach systemu A six. Sprzężenie AsAlert z mechanizmem wykrywania i obsługi alarmów A sixa pozwala na automatyczne wysyłanie alertów w reakcji na wykrycie zmiany stanu wybranych alarmów.

AsBase

Moduł AsBase dedykowany jest do tworzenia aplikacji, których celem jest zdarzeniowa archiwizacja wybranych danych procesowych w relacyjnej bazie danych Microsoft SQL oraz ich późniejsza analiza. Drugim zastosowaniem modułu jest realizacja systemu zarządzania recepturami.

Asix4Internet

Asix4Internet to narzędzie zawierające trzy moduły: AsPortal, As2HTML i wbudowany w program Architekt moduł do konwersji aplikacji systemu asix na aplikację internetową. Innowacyjność Asix4Internet umożliwia wizualizację i nadzór nad realizacją procesów przemysłowych przy wykorzystaniu przeglądarki internetowej.

Portal danych procesowych AsPortal umożliwia przeglądanie wszystkich danych procesowych tj. bazy zmiennych aplikacji, wartości bieżących i archiwalnych pomiarów, archiwum alarmów historycznych oraz listę alarmów aktywnych - w postaci tabelarycznej, wykresów lub raportów. Pakiet As2HTML umożliwia zaprojektowanie i utworzenie dynamicznych stron HTML zawierających dane procesowe z aplikacji systemu A six. Natomiast moduł konwersji pozwala automatycznie wygenerować aplikację WWW ze standardowej aplikacji systemu A six.

AsAudit

AsAudit to zaawansowane narzędzie pakietu A six, którego podstawowym zadaniem jest dostosowanie asixa do wymagań stawianych przez procedury walidacji systemów zgodnych z wymaganiami GAMP4, FDA 21 CFR Part 11, stosowanych w farmacji i w przemyśle spożywczym. Moduł rozszerza zaimplementowany w asix centralny system logowania użytkowników i kontroli uprawnień o rejestrację wykonanych sterowań, rejestrację działań operatora oraz kontrolę integralności aplikacji.

PEdit

Istnieją też dodatkowe narzędzia rozszerzające funkcjonalność systemu A six w zakresie obsługi przebiegów wzorcowych. Jednym z nich jest PEdit - edytor przebiegów wzorcowych. Drugi - to PSelect – narzędzie do ręcznego lub automatycznego wyboru krzywej wzorcowej lub transferu wybranej krzywej wzorcowej do sterownika, gdzie może być wykorzystana do sterowania.

AsComm

Program AsComm służy do zarządzania i monitorowania połączeń, nawiązywanych za pomocą portów szeregowych lub modemów, dokonywanych przez moduły systemu A six.

AslView

Program AslView służy do wizualizacji i diagnostyki połączeń sieciowych systemu A six. Program pozwala połączyć się z modułem sieciowym Aslink systemu A six, pracującym na lokalnej lub zdalnej stacji oraz obserwać stan połączeń nawiązywanych przez inne komponenty systemu A six - jak Asmen i Aspad, a także obserwać stan synchronizacji czasu z innymi stacjami. Za pośrednictwem programu AslView możliwe jest parametryzowanie działania modułu sieciowego Aslink.

AsAlarm

AsAlarm to program dostarczający narzędzi do szczegółowej analizy informacji o alarmach generowanych przez monitorowany obiekt oraz danych na temat pracy systemu alarmów. Program jest zgodny z wytycznymi organizacji EEMUA (The Engineering Equipment and Materials Users Association) nr 191. Pozwala on prowadzić analizę systemu alarmów w dwóch płaszczyznach:

- oceny poprawności projektu struktury systemu alarmów w konkretnej aplikacji;

- dogłębnej analizy statycznej i dynamicznej alarmów zarejestrowanych na obiekcie.


1.3.1 Uruchomienie modulu Architekt

1.3.1 Uruchomienie modułu Architekt

Moduł Architekt można uruchomić wybierając kolejno z menu Start systemu operacyjnego:

Programy > A six > Architekt


1.3.2 Zamykanie modulu Architekt

1.3.2 Zamykanie modułu Architekt

Zamknięcie modułu Architekt następuje w wyniku wybrania polecenia Zakończ zakończ z menu Plik okna programu Architekt.


1.3.3 Okno glowne modulu Architekt

1.3.3 Okno główne modułu Architekt

Program Architekt posiada przyjazny interfejs wizualny. Środowisko pracy projektanta stanowi okno programu podzielone na dwa główne bloki:

- lewy blok kategorii parametrów dla baz danych i danych aplikacji;

- prawy blok parametrów konfiguracyjnych.

uwaga Parametry konfigurujące pracę aplikacji oraz deklarujące bazę danych, w oparciu o którą aplikacja pracuje zapisywane są do jednego wspólnego pliku XML (ang. Extensible Markup Language), umieszczanego w kartotece głównej projektowanej aplikacji.

Zawartość lewego bloku okna Architekta przełączana jest przyciskami Bazy danych i Obszary i komputery (znajdującymi się w dolnej części bloku).

Podłużny przycisk Bazy danych wyświetla drzewo parametrów do konfiguracji bazy definicji zmiennych i bazy alarmów danej aplikacji.

Rysunek: Okno Architekta - widok grup parametrów do konfiguracji baz danych definicji zmiennych i alarmów.

Podłużny przycisk Obszary i komputery aktywuje blok zawierający listę komputerów, dla których konfigurowana jest aplikacja systemu A six oraz drzewo grup parametrów konfigurujących pracę tej aplikacji.

Rysunek: Okno Architekta - widok listy komputerów oraz drzewa grup parametrów do konfiguracji aplikacji.

Parametry konfiguracyjne dostępne w prawym bloku okna Architekta - umieszczone zostały na tematycznych zakładkach.

W bloku tym projektant nadaje pożądane wartości poszczególnym parametrom aplikacji oraz bazy danych, w oparciu o którą aplikacja pracuje.

Rysunek: Okno Architekta - przykładowa zakładka do parametryzacji danych archiwalnych.

uwaga Użytkownik używając środowiska konfiguracyjnego Architekt nie zakłóca pracy aplikacji, która działa w tle. Niektóre zmiany w ustawieniach parametrów aktualizowane są automatycznie w chwili zapisu, choć dla większości parametrów wymagany jest restart aplikacji.


1.3.3.1 Drzewo modulow

1.3.3.1 Drzewo modułów

Głównym narzędziem nawigacyjnym służącym do lokalizacji poszczególnych obszarów funkcjonalnych programu Architekt jest drzewo modułów aktywowane podłużnym przyciskiem Obszary i komputery.

Rysunek: Okno Architekta - widok drzewa modułów aplikacji.

Ponieważ rzeczywista aplikacja działająca na obiekcie często pracuje w różny sposób na różnych stanowiskach komputerowych, wymaga to zdefiniowania w jednym pliku XML kilku różnych zestawów parametrów dla poszczególnych stanowisk. Zestaw parametrów dla wybranego stanowiska komputerowego dostępny jest w bloku parametrów konfiguracyjnych po kliknięciu na wybranym Komputerze z listy zadeklarowanych komputerów w polu Obszary i komputery.

Obszar działania aplikacji, który jest wspólny dla kilku lub wszystkich komputerów symbolizowany jest tutaj poprzez element Obszar - gdy użytkownik kliknie na ten element, może przystąpić do ustawienia wartości parametrów aplikacji, które są takie same dla wszystkich stanowisk.

uwaga Konfiguracja na poziomie Obszaru powoduje globalne ustawienia dla wszystkich komputerów należących do tego obszaru, natomiast konfiguracja na poziomie Komputera pozwala zindywidualizować ustawienia w zależności od typu komputera (inne dla stacji operatorskiej a inne dla dedykowanego serwera danych w sieci zakładowej). Ustawienia na poziomie Komputera są ważniejsze od ustawień na poziomie Obszaru.

Parametry konfigurujące pracę aplikacji podzielone zostały na następujące moduły parametrów:

- Parametry startowe,

- Maski,

- Dane bieżące,

- Dane bieżące - serwer sieci,

- Dane archiwalne,

- System alarmów,

- Moduł sieci,

- Zabezpieczenia,

- Wydruk,

- Raporty,

- Akcje i terminarze,

- Pozostałe.

Widok drzewa modułów dla baz danych (podłużny przycisk Bazy danych), w zależności od ustawionego typu bazy definicji zmiennych, obejmuje pozycje omówione poniżej.

Rysunek: Okno Architekta - widok drzewa modułów dla baz danych.

- Baza definicji zmiennych - parametry określające Typ bazy, Format bazy, Źródła danych oraz Opcje;

- Edytor atrybutów (dostępny dla typu bazy definicji zmiennych - Standardowa baza definicji zmiennych, po otwarciu bazy);

- Edytor schematu (dostępny dla typu bazy definicji zmiennych - Standardowa baza definicji zmiennych, po otwarciu bazy);

- Baza definicji alarmów - parametry określające Typ, Źródła danych oraz Szablon pliku źródłowego definicji alarmów; (zakładki Baza definicji alarmów > Źródła danych oraz Baza definicji alarmów > Szablon dostępne są dla następującego ustawienia Typu bazy definicji alarmów - Baza definicji alarmów jest generowana z arkusza kalkulacyjnego);

- Baza akcji złożonych - pozwala określić tryb pracy bazy akcji złożonych; definicje mogą być wprowadzane przez projektanta w module Akcje i terminarze, na zakładce Akcje złożone lub definicje akcji mogą być generowane na podstawie danych z arkuszy kalkulacyjnych.

- Opcje - pozwalające ustawić indywidualnie dla każdej aplikacji:

- widok okna głównego na starcie Architekta (zakładka Opcje > Start),

- silnik odczytu plików XLS (zakładka Opcje > Źródła danych - silnik odczytu),

- wybór edytora plików XLS (zakładka Opcje > Źródła danych – edycja),

- parametry dla okna przeglądania bazy definicji zmiennych (zakładka Opcje > Baza definicji zmiennych).

(szczegóły patrz: 1.3.4 . Indywidualne opcje pracy programu Architekt).


1.3.3.2 Blok parametrow konfiguracyjnych

1.3.3.2 Blok parametrów konfiguracyjnych

Blok parametrów konfiguracyjnych umożliwia dokonywanie ustawień parametrów konfigurujących pracę aplikacji systemu A six oraz parametrów bazy definicji zmiennych.

Rysunek: Okno Architekta – przykładowy widok bloku parametrów konfiguracyjnych.

Blok ten zamienia się w okno edytora atrybutów zmiennych, gdy otwarta jest baza definicji zmiennych w formacie SQL lub Jet (w grupie parametrów Bazy danych > Baza definicji zmiennych > Typ bazy zaznaczona jest opcja Standardowa baza definicji zmiennych)

Rysunek: Okno edycji bazy definicji zmiennych.


1.3.4 Indywidualne opcje pracy programu Architekt

Istnieje możliwość określenia przez użytkownika pewnych domyślnych opcji pracy programu Architekt, obowiązujących podczas pracy nad danym plikiem aplikacji.

W widoku drzewa modułów dla baz danych (podłużny przycisk Bazy danych) znajduje się moduł Opcje, który daje możliwość dokonania poniższych ustawień.

Zakładka Start:

  • Aktywny edytor po uruchomieniu programu - pozwala zadeklarować, który edytor uruchamiany będzie na starcie programu:

  • Edytor aplikacji (ze wskazaniem aktywnego obszaru/komputera),

  • Edytor bazy danych;

  • Aktywny moduł po zmianie obszaru/komputera - aktywuje mechanizm, który zapamiętuje moduł i zakładkę ostatnio otwieraną dla danego obszaru lub komputera podczas bieżącej sesji:

  • Ten sam dla wszystkich komputerów/obszarów - ostatnio otwierany moduł i zakładka będą domyślnie aktywowane po przejściu do dowolnego obszaru/komputera;

  • Osobny dla każdego komputera/obszaru - zostanie zapamiętany ostatnio otwierany moduł i zakładka indywidualnie dla każdego komputera/obszaru.

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Start’.

Zakładka Źródła danych - silnik odczytu pozwala zadeklarować silnik odczytu plików XLS oraz edytor plików XLS.

Edytor plików XLS/XLSX:

  • Domyślny edytor zainstalowany w systemie,

  • Edytor wbudowany w Architekt,

  • Zewnętrzny edytor.

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Źródła danych - silnik odczytu’.

Zakładka Baza definicji zmiennych - pozwala określić parametry pomocne w sprawdzaniu działania okna wyboru zmiennej; efekty wyboru języka widoczne są w oknie ’Przeglądanie zmiennych’ aktywowanym przyciskiem pokaż:

  • Okno przeglądania bazy definicji zmiennych:

  • Widoczne zmienne - pozwala zawęzić zestaw wyświetlanych definicji zmiennych do zmiennych aktywnych lub archiwizowanych;

  • Język aplikacji - umożliwia wybór języka, w jakim wyświetlane są nagłówki i wartości atrybutów zmiennych (nagłówki atrybutów dla wymaganych języków deklarowane są w schemacie bazy definicji zmiennych, a tłumaczenia wartości atrybutów (np. atrybutu Opis) w bazie definicji zmiennych).

Rysunek: Moduł opcji pracy programu Architekt - zakładka ’Baza definicji zmiennych’.


1.3.5 Menu glowne, dostepne polecenia

1.3.5 Menu główne, dostępne polecenia

Komendy wykonywane przez moduł Architekt zostały zgrupowane w 9 kategoriach [2]:

  1. Plik,

  2. Aplikacja,

  3. Obszary i komputery,

  4. Widok,

  5. Narzędzia,

  6. Pomoc,

  7. Edytor,

  8. Baza definicji zmiennych,

  9. Baza definicji alarmów.

Użytkownik ma możliwość samodzielnego określenia, które polecenia chce mieć wyświetlone w oknie Architekta. Służy to tego polecenie Dostosuj..., uruchamiane po kliknięciu prawym klawiszem myszy na dowolnym pasku narzędzi bądź menu głównym. Wywołuje ono okno ’Dostosuj’, które umożliwia konfigurację zawartości menu głównego oraz pasków narzędzi i dostępnych poleceń w zależności od preferencji użytkownika.

Rysunek: Okno umożliwiające konfigurację zawartości pasków narzędzi.

W oknie modułu Architekt dostępne są następujące kategorie poleceń:

Plik

- Nowa aplikacja (Ctrl + N);

nowa aplikacja - kreator - Nowa aplikacja - kreator;

Nowa aplikacja - kreator OPC... - uruchamia kreator aplikacji w trybie importu bazy z serwera OPC;

- Nowa aplikacja - importer;

otwórz - Otwórz (Ctrl + O); otwiera plik XML;

zapisz - Zapisz (Ctrl + S);

- Zapisz jako;

zakończ - Zakończ; zakończenie pracy modułu Architekt;

Wyświetlana jest też lista ostatnio otwieranych plików konfiguracyjnych XML aplikacji

Aplikacja

uruchom - Uruchom system Asix (F5); uruchomienie aplikacji systemu Asix dla wybranego komputera;

uruhcom konstruktor - Uruchom system Asix (F6) - konstruktor; uruchomienie aplikacji systemu A six w trybie Konstruktora dla wyselekcjonowanej stacji;

stop - Zatrzymaj system Asix (Ctrl + F5); zamknięcie aplikacji systemu A six;

- Konfiguruj system raportów AsRaport ...

- Konfiguruj aplikacje internetowe...;

- Konfiguruj wygląd aplikacji AsPortal;

- Generuj aplikację WWW;

Paleta kolorów aplikacji...

Generuj listę używanych zmiennych...

Paleta kolorów aplikacji - polecenie uruchamia paletę kolorów; użytkownik może sam komponować swoją własną paletę przeciągając kolory metodą 'przeciągnij i upuść' z wzornika kolorów do sekcji Kolory użytkownika.

Generuj listę używanych zmiennych... - polecenie tworzy listę nazw używanych w aplikacji na maskach i zapisuje je w pliku xls. Lista nazw zmiennych tworzona jest programem ZMIANADP, który zapisuje listę zmiennych do pliku tekstowego (który następnie przetwarzany jest na plik xls). Pełny zakres funkcjonalności programu ZMIANADP opisany został w podręczniku "Asix - funkcjonalność i zasady działania" (Asix.chm / Asix.pdf).

Baza Definicji Zmiennych - zestaw poleceń dostępny w zależności od typu bazy definicji zmiennych !!!

- Pokaż (F7) - otwiera okno przeglądania bazy definicji zmiennych;

- Otwórz (Ctrl + B) - otwiera bazę definicji zmiennych do edycji;

- Zapisz - zapisuje zmiany w bazie definicji zmiennych;

- Zamknij - zamyka bazę definicji zmiennych (kończy edycję);

- Przeładuj - zamyka i ponownie otwiera bazę definicji zmiennych;

- Aktualizuj on-line - w przypadku, gdy niemożliwe jest zatrzymanie aplikacji i jej restart w celu zmodyfikowania bazy definicji zmiennych, możliwe jest przeprowadzenie aktualizacji bazy w trybie on-line;

- Poka ż modyfikacje - pozwala prześledzić zmiany w definicjach zmiennych (w tym dodawanie i usuwanie zmiennych);

importuj modyfikacje - Importuj modyfikacje - pozwala zaimportować do istniejącej bazy definicji zmiennych MS SQL lub Jet zmiany w definicji zmiennych wykorzystując arkusz Excel jako źródło;

- Exportuj... - pozwala wyeksportować definicje zmiennych do arkusza kalkulacyjnego;

Importuj z serwera OPC... - otwiera okno importu bazy definicji zmiennych z serwera OPC do pliku xls;

- Utwórz nową;

- Usuń;

- Utwórz kopię zapasową;

- Przywróć z kopii;

dodaj atrybut - Dodaj atrybut - dodawanie nowego atrybutu do definicji zmiennej;

usuń atrybut - Usuń atrybut - usuwanie nowego atrybutu do definicji zmiennej;

- Zmień rozmiar atrybutu;

Edytor - polecenia edytora bazy definicji zmiennych:

- Wstaw definicję zmiennej - dodanie rekordu definicji nowej zmiennej;

- Wstaw kopię definicji zmiennych - dodanie rekordu skopiowanej definicji nowej zmiennej;

- Wstaw definicję zmiennej systemowej - dodanie rekordu definicji zmiennej systemowej - uruchamiany jest edytor z listą obsługiwanych zmiennych systemowych;

- Wstaw definicję zmiennej z kanału OPC

- Zmień wartości - po zaznaczeniu wybranych wartości danego atrybutu w tabeli z definicjami zmiennych umożliwia zmianę tych wartości;

- Zamień zaznaczone - po zaznaczeniu wybranych wartości danego atrybutu w tabeli z definicjami zmiennych umożliwia zamianę pewnej określonej wartości atrybutu w obszarze zaznaczonych pól na nową wartość;

- Zamień w kolumnie - po kliknięciu prawym klawiszem myszy w dowolnym polu danego atrybutu w tabeli z definicjami zmiennych pozwala użytkownikowi zmienić określoną wartość atrybutu w obszarze całej kolumny;

- Wyczyść zaznaczone;

Natychmiastowa edycja - załączenie opcji umożliwia natychmiastową edycję bieżącej komórki po wpisaniu dowolnego znaku;

- Kopiuj komórkę do schowka;

- Dodaj nazwy zmiennych do schowka;

- Pokaż atrybuty - wszystkie (Shift + Ctrl + 0);

- Pokaż atrybuty – bieżące (Shift + Ctrl + 9);

Pokaż atrybuty – systemowe;

Baza definicji alarmów

- Pokaż (F8)- uruchamia okno wyboru alarmów

- Generuj (Ctrl + H) – generuje bazę definicji alarmów;

Obszary i komputery

dodaj obszar - Dodaj obszar;

usuń obszar - Usuń obszar;

zmień nazwę obszaru - Zmień nazwę obszaru;

Utwórz kopię obszaru...

Konwertuj obszar na komputer;

dodaj komputer - Dodaj komputer w bieżącym obszarze;

dodaj komputer - Dodaj komputer

usuń komputer - Usuń komputer;

zmień nzawę komputera - Zmień nazwę komputera;

Utwórz kopię komputera... - tworzy kopię komputera zaznaczonego w chwili wykonywania polecenia w bloku Obszary i komputery.

Utwórz kopię komputera - terminal... - tworzy kopię terminala zaznaczonego w chwili wykonywania polecenia w bloku Obszary i komputery.

- Konwertuj komputer na obszar;

Importuj komputer/obszar z pliku... - powoduje import komputera lub obszaru z pliku XML (do którego uprzednio wyeksportowano wskazany komputer/obszar np. z pliku XML parametryzującego inną aplikację systemu A six;

Importuj komputer/obszar z pliku... - powoduje wyeksportowanie definicji komputera/obszaru do pliku XML;

dodaj kanał - Dodaj kanał;

Utwórz kopię kanału...

reedytuj kanał - Zmień definicję kanału – umożliwia zmianę nazwy kanału i typu drajwera;

usuń kanał - Usuń kanał;

Zarządzaj kanałami... - pozwala wykonać nast. operacje na kanałach dla danego komputera/obszaru:

Usuń;

Zmień typ na: fizyczny, NONE lub sieciowy;

Kopiuj do komputera/obszaru.

Rysunek: Okno ’Zarządzanie kanałami’.

dodaj archiwum - Dodaj archiwum;

Utwórz kopię archiwum...

- Zmień nazwę archiwum;

usuń archiwum - Usuń archiwum;

Zarządzaj archiwami...- pozwala wykonać nast. operacje na archiwach dla danego komputera/obszaru:

Usuń;

Zmień typ archiwum: do zapisu, do odczytu, pomocnicze lub sieciowe

Kopiuj do komputera/obszaru.

Zarządzaj opcjami - uruchamia menadżera opcji, który pozwala przeglądać wszystkie parametry ustawione dla poszczególnych obszarów funkcjonalnych aplikacji;

Importuj opcje - uruchamia menadżera opcji, który pozwala zaimportować wybrane wartości opcji z zewnętrznych plików *.xml;

informacje - Informacje; wyświetla zależności pomiędzy komputerami i obszarami;

Widok

style - pozwala ustawić wygląd okna programu Architekt; obejmuje następujące style:

standardowy - Standardowy;

płaski - Płaski;

ultra płaski - Ultrapłaski;

office11 - Office 2003;

natywny - Systemowy;

paski narz - obejmuje listę dostępnych pasków narzędzi i opcję Dostosuj...;

Obszary/komputery, Moduły opcji aplikacji, Moduły opcji baz danych, Opcje programu - przyciski pozwalają przełączać się do bloku obszarów i komputerów oraz do bloków opcji;

pokaz opcje zaawansowane - Pokazuj opcje zaawansowane; aktywuje ukryte zakładki zaawansowanych parametrów w modułach opcji aplikacji;

- Pokaż tylko opcje Asix.Evo - opcja redukuje zestaw parametrów dostępnych dla klasycznej wersji Asixa do tych parametrów, które są wymagane dla aplikacji projektowanej przy użyciu Asixa.Evo;

Narzędzia

utwórz skrót - Kreator skrótów; umożliwia tworzenie skrótu do uruchamiania różnych aplikacji systemu A six;

powiększ >>

Rysunek: Okno do tworzenia skrótu uruchamiającego aplikację systemu Asix.

arkusz kalkulacyjny - Arkusz kalkulacyjny; uruchamia okno wbudowanego arkusza kalkulacyjnego;

Edytor tabeli - uruchamia edytor obiektu Tabela do przeglądania wartości zmiennych

- Wybór języka; uruchamia program wyboru języka interfejsu użytkownika systemu A six;

- Zabezpieczenia statyczne; uruchamia program menedżera uprawnień globalnych (plik StaticPolicies.exe) umożliwiającego ustawienie mechanizmów zabezpieczających dostęp do potencjalnie niebezpiecznych funkcji systemu operacyjnego;

Rysunek: Okno menedżera uprawnień globalnych.

- AsTrend; uruchamia program do graficznej prezentacji danych archiwalnych gromadzonych przez program archiwizacji danych ASPAD;

Konwerter trendów 1 - uruchamia konwerter trendów służący do przekonwertowania pliku dat zawierającego definicje trendów (trendy definiowane w plikach dat dostępne były w systemie A six do wersji 3) do postaci definicji trendów obsługiwanych przez program AsTrend.

- AsBase; uruchamia program AsBase;

- AsRaport - uruchamia program AsRaport do edycji zapytać SQL dla raportów tworzonych w środowisku Reporting Services firmy Microsoft;

- Askom.Data.Host - uruchamia program do konfiguracji środowiska umożliwiającego udostępnianie do środowiska raportowego MS Reporting Services danych procesowych pochodzących z aplikacji systemu A six;

- AsAlarm - uruchamia program AsAlarm z załadowana baza VarDef aktualnej aplikacji;

- Konfiguracja AsixConnect; uruchamia konfiguratora pakietów serwerów AsixConnect;

- Moduł sieci – opcje – opcja uruchamia edytor ustawień sieciowych, które zapisywane są w pliku aslink.ini (stosowane gdy na komputerzen nie ma aplikacji A sixa, za to są inne programy, które korzystają z danych aplikacji A sixa (np. AsTrend, AsixConnect);

- Konfiguracja Alertów; uruchamia program konfiguratora alertów;

alerty - Konfiguracja AsAudit; uruchamia program konfiguratora AsAudit;

alerty - Katalogi logów i ustawień - uruchamia program konfiguratora umożliwiającego deklarowanie katalogów dla plików logów tworzonych przez program AsTrend, serwery pakietu AsixConnect, program Architekt i moduł wykonawczy systemu A six oraz deklarowanie katalogów plików konfiguracyjnych aplikacji systemu A six.

Rysunek: Konfigurator katalogów logów.

alerty - Menadżer pakietów Asix - uruchamia program konfiguratora umożliwiającego przygotowanie środowiska MS Windows do uruchomienia dowolnej zainstalowanej na komputerze wersji pakietu A six (na komputerze może być zainstalowanych kilka wersji pakietu, zaczynając od wersji 2).

- Wersja pakietu systemu Asix - wyświetla okno z metryką pakietu.

Pomoc

pomoc - poszczególne ikony pomocy uruchamiają kolejno (w domyślnym porządku):

1. plik pomocy dla modułu Architekt;

2. plik pomocy dla modułu Asix;

3. plik pomocy dla modułu Drajwery komunikacyjne;

4. plik pomocy dla modułu Asix4Internet;

5. plik pomocy dla modułu AsixConnect;

6. plik pomocy dla modułu Skrypty;

zgłoszenie usterki - Zgłoszenie usterki lub Zgłoszenie propozycji modyfikacji;

o programie - O programie; wyświetla podstawowe informacje o programie.

_______________________________________

[2] Widok okna Architekta w niniejszym opracowaniu pochodzi z systemu Windows XP Professional z ustawionym widokiem: Standardowym; widok Architekta został ustawiony na styl standardowy lub Office 2003.


2.1 Wstep

2.1 Wstęp

Baza definicji zmiennych VarDef stanowi podstawowe repozytorium całości informacji o wszystkich zmiennych projektowanego systemu wizualizacji. Jest fundamentem, na którym opiera się konstruowanie aplikacji asixowej, w tym konfigurowanie jej przy użyciu modułu Architekt.

Każdej zmiennej identyfikowanej poprzez unikalną Nazwę odpowiada jeden rekord w bazie definicji zmiennych. Pola tego rekordu zawierają wartości tzw. atrybutów zmiennej. Lista atrybutów zawiera pozycje obligatoryjne, opcjonalne oraz definiowane przez użytkownika. Atrybutami obligatoryjnymi są: opis zmiennej, jednostka, nazwa kanału komunikacji z obiektem, deklaracja sposobu przetwarzania przy pobieraniu ze sterownika, parametry archiwizacji. Atrybuty opcjonalne to np.: limity, format, zakresy. Poza powyższymi, użytkownik może również utworzyć swoje atrybuty tekstowe, indywidualnie dla każdego projektu, np.: KKS’y, czy dane montażowe.

W bazie definicji zmiennych VarDef poza definicjami zmiennych przechowywane są również informacje na temat: atrybutów grupujących, zestawów atrybutów, funkcji przeliczających, nagłówków atrybutów, wykorzystywanych w zaprojektowanej aplikacji języków narodowych atrybutów zmiennych, informacje na temat atrybutów zastępczych (dla aplikacji wielojęzycznych). Te dodatkowe dane dostępne są z poziomu modułu Baza definicji zmiennych > Edytor schematu.

uwaga Możliwe jest użycie skoroszytu programu Excel bezpośrednio jako bazy definicji zmiennych z pominięciem kroku generowania bazy definicji zmiennych. Po załadowaniu bazy skoroszyt nie jest już używany.

Dane konfiguracyjne dotyczące bazy definicji zmiennych konfigurowane są w Architekcie przy użyciu modułu Baza definicji zmiennych (otwieranego podłużnym przyciskiem Bazy danych, znajdującym się w lewym bloku okna Architekt) i zapisywane w pliku konfiguracyjnym XML tworzonej aplikacji.

uwaga Sposób działania całej aplikacji opisuje jeden plik XML - wspólny dla danych dotyczących bazy definicji zmiennych i dla wartości parametrów określających pracę aplikacji.

Rysunek: Okno modułu konfigurowania bazy definicji zmiennych.

Szczególny rodzaj zmiennych stanowią zmienne systemowe:

__USERID__ - zapewnia dostęp do identyfikatora aktualnie zalogowanego użytkownika (patrz: Asix - podręcznik użytkownika, rozdział o systemie logowania);

__USERNAME__ - zapewnia dostęp do nazwy aktualnie zalogowanego użytkownika (patrz: Asix - podręcznik użytkownika, rozdział o systemie logowania);

__USERLEVEL__ - zapewnia dostęp do aktualnie obowiązującego poziomu uprawnień (patrz: Asix - podręcznik użytkownika, rozdział o systemie logowania);

__AGR_IdGrupy__ - pozwala na wyświetlenie stanu aktywności alarmów należących do wspólnej grupy (patrz: Asix - podręcznik użytkownika, rozdział o systemie alarmów).


2.1.1. Tryb tworzenia bazy danych

Program Architekt zapewnia tworzenie nowych baz definicji zmiennych systemu A six od wersji 5 w następujących trybach:

1. baza jest tworzona i edytowana ręcznie - Tryb Edytor;

2. baza danych jest generowana na podstawie danych dostarczonych w źródłach zewnętrznych (np. arkuszach kalkulacyjnych Excel) - Tryb Generator;

3. definicje zmiennych pobierane są bezpośrednio z arkusza Excel z pominięciem kroku generowania bazy zmiennych - Tryb Źródło danych.


2.1.2 Format bazy danych

2.1.2 Typ i format bazy danych

W systemie wizualizacji A six 7 dane bazy definicji zmiennych mogą być przechowywane:

- w bazie MSQL 2000/2005/2008,

- w bazie Jet,

- bezpośrednio w plikach Excel,

- w formacie plików tekstowych wykorzystywanym w starszych wersjach A sixa [3] (Tekstowa baza definicji zmiennych (Asix 1-4)

lub

- w bazie zewnętrznej (MSQL 2000/2005/2008 lub Jet) utworzonej programem Architekt, ale parametryzowanej innym plikiem XML niż projektowana aplikacja. Istnieje możliwość jednoczesnego odczytu definicji zmiennych z kilku zewnętrznych baz definicji zmiennych (patrz: 2.1.2.1. Łączone bazy definicji zmiennych).

Baza Jet

Zalecanym formatem bazy definicji zmiennych jest baza Microsoft Jet. Nie wymaga ona instalowania serwera bazy danych, a sama baza zawiera się w jednym pliku .mdb, który z łatwością można przenosić pomiędzy komputerami.

Definicje zmiennych przechowywane w źródłach zewnętrznych - plikach XLS

Przechowywanie definicji zmiennych w arkuszu kalkulacyjnym jest wygodne na etapie projektowania aplikacji z uwagi na czytelność przechowywanych informacji oraz łatwość, z jaką użytkownik może wprowadzać zmiany do struktury i wartości danych.

Baza MS SQL

Baza MS SQL zalecana jest dla dużych aplikacji pracujących na ok. 20 000 i więcej zmiennych.

Bazę MS SQL należy również zastosować w sytuacji, kiedy projektowana aplikacja ma być wielojęzyczna.

***

Typ i format bazy definicji zmiennych wybierany jest na zakładkach Typ i Format modułu Bazy danych > Baza definicji zmiennych.

Zakładka Typ pozwala zdecydować, czy baza ma być tworzona w standardowym formacie: MBD lub MS SQL (ze wskazaniem trybu tworzenia: Edytor, Generator lub Źródło danych), czy tez w starym formacie (pliki tekstowe).

W przypadku wyboru typu bazy w standardowym formacie zostanie wyświetlona zakładka Format z wyborem formatu bazy danych: Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 lub Plik w formacie Mdb (Jet/Microsoft Access).

***

W przypadku wyboru bazy w formacie serwera MS SQL Server 2000/2005/2008 należy przestrzegać następujących zasad:

Serwer SQL musi mieć włączone oba rodzaje autentyfikacji: SQL Server i Windows.

W przypadku użycia lokalnego serwera SQL - konto, pod jakim pracuje serwer, musi mieć dostęp do katalogu TEMP. Najłatwiej to osiągnąć konfigurując proces serwera SQL do pracy pod kontem o nazwie LocalSystem.

W przypadku użycia zdalnego serwera SQL z włączoną zaporą, na komputerze serwera:

- dla głównej instancji musi być otwarty port tcp/1433;

- dla instancji nazwanej musi być otwarty port używany przez tę instancję;

- dla wszystkich w sieci nazw serwerów SQL musi być otwarty port udp/1434.

_____________________________________________

[3] W systemie Asix definicje zmiennych mogą być pobierane z plików tekstowych ze względu na kompatybilność z wcześniejszymi wersjami systemu. Stosowanie wspomnianych formatów przechowywania definicji zmiennych nie jest jednak aktualnie zalecane. Bazy w formacie Paradox - pliki MDB należy przekonwertować do aktualnego formatu baz danych systemu Asix 7.


2.1.2.1. Łączone bazy definicji zmiennych

Dopuszczalnym typem bazy definicji zmiennych są łączone bazy definicji zmiennych, parametryzowane odrębnymi plikami XML.

Wymaga to:

1. zadeklarowania w Architekcie odpowiedniego typu bazy definicji zmiennych:

Architekt > Bazy danych > zakładka Typ > opcja Zewnętrzna baza/bazy definicji zmiennych

2. oraz wskazania zewnętrznych baz definicji zmiennych:

Architekt > Obszary i komputery > moduł Parametry startowe > zakładka Baza definicji zmiennych

Deklaracja bazy obejmuje podanie w przypadku bazy MDB: nazwy i ścieżki do pliku MDB, a w przypadku bazy MS SQL: nazwy serwera Microsoft SQL i nazwy bazy.

Rys. Deklaracja łączonych baz definicji zmiennych.


2.1.3 Atrybuty zmiennych

Atrybuty zmiennych dzielone są na 3 rodzaje:

1. atrybuty obligatoryjne,

2. atrybuty opcjonalne,

3. atrybuty użytkownika.

Atrybuty obligatoryjne są to wszystkie atrybuty używane przez system A six do uruchomienia aplikacji, np.: Nazwa, Adres, Funkcja przeliczająca.

Pełne zestawienie obligatoryjnych i opcjonalnych atrybutów zmiennych znajduje się w Załącznik 1. Dodatkowo Załącznik 2 zawiera zestawienie atrybutów i wykorzystujących je obiektów/modułów systemu A six.

uwaga Nazwy i typy atrybutów obligatoryjnych i opcjonalnych są ustalone i niezmienne.

Wartość atrybutu Nazwa musi być unikalna w całej bazie definicji zmiennych.

Wśród atrybutów opcjonalnych jest ZmiennaNieaktywana. Jeżeli wartość atrybutu ZmiennaNieaktywana wynosi 1, to zmienna nie jest widoczna w systemie A six dla modułów Asmen i Aspad.

Atrybuty użytkownika są to wszystkie pozostałe atrybuty. Użytkownik sam ustala ich nazwy (atrybuty mogą być wyłącznie typu tekstowego).

Ponadto w bazie zmiennych istnieją atrybuty wewnętrzne tworzone na potrzeby systemu bazy definicji zmiennych i nie ujawniane użytkownikowi. Atrybuty te to: DataUtworzenia, DataUsunięcia.


2.1.4 Nazewnictwo atrybutow i tabel

2.1.4 Nazewnictwo atrybutów i tabel

Nazwa atrybutu może zawierać wszelkie znaki z alfabetu łacińskiego, cyfry, spacje, itd. (Można używać znaków alfabetu lokalnego - ale tylko dla aplikacji jednojęzycznych). Nazwa ta jest używana i w bazie i w interfejsie użytkownika.

Wszystkie nazwy atrybutów systemowych oraz nazwy tabel bazy definicji zmiennych wewnętrznie są w języku angielskim. Nazwy te w interfejsie użytkownika pojawiają się w oknie edycji definicji zmiennych / oknie przeglądania zmiennych / oknie opisu zmiennych w zależności od wersji językowej Architekta - w języku polskim lub angielskim.

uwaga Przy imporcie danych nazwy mogą być podawane zarówno w języku polskim jak i angielskim.

Wyświetlanie lokalnych nazw nagłówków w dowolnym zadeklarowanym przez projektanta języku wymaga samodzielnego zdefiniowania tych nazw - patrz: 2.2.2.4 . Tłumaczenia nazw atrybutów.

Rysunek: Okno podglądu definicji zmiennych.

Rysunek:. Okno opisu wybranej zmiennej - widok atrybutów z zadeklarowanego zestawu atrybutów.


2.2. Tworzenie bazy w trybie Edytora

Tworzenie bazy definicji zmiennych w trybie Edytora realizowane jest w następujących krokach:

  1. Określ typ bazy definicji zmiennych:

    2. Baza definicji zmiennych > zakładka Typ > tryb tworzenia bazy ustawiony na Tryb Edytor

    Rysunek: Baza definicji zmiennych/zakładka Typ - Tryb Edytor.

  2. Wybierz format bazy definicji zmiennych:

    3. Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer 2000/2005 lub Plik w formacie Mdb (Jet/Microsoft Access)

    Rysunek: Baza definicji zmiennych - zakładka ’Format’.

  3. Podaj nazwę tworzonej bazy.

    4. W przypadku baz danych MS SQL wymagane jest określenie parametrów:

    - Nazwa serwera;

    - Nazwa bazy;

    - Katalog bazy;

    - Tyb uwierzytelniania:

    - Windows,

    - Serwer MSQL - wymaga określenia nazwy użytkownika oraz Hasła.

- Nazwa serwera mirror - w przypadku obsługi mirroringu pole wymaga zadeklarowania nazwy serwera mirror (wskazówki dotyczace obsługi mirroringu podaje okno pomocy wywoływane przyciskiem [image], umieszczonym obok pola Nazwa serwera mirror).

  3. Wybierz polecenie Utwórz nową utwórz;

  4. Otwórz bazę i wprowadź dane atrybutów zmiennych przy użyciu Edytora definicji zmiennych

(patrz: 2.2.1.3. Dodawanie i usuwanie atrybutów zmiennych);

  6. Zdefiniuj schemat bazy definicji zmiennych za pomocą Edytora schematu

(patrz: 2.2.2 . Tworzenie schematu bazy definicji zmiennych - Edytor schematu).


2.2.1.1 Dodawanie, usuwanie i modyfikowanie zmiennych

Polecenia:

- dodania rekordu nowej zmiennej powyżej wskazanego rekordu (przycisk WSTAW REKORD);

- dopisania nowego rekordu zmiennej jako ostatniego w kolejności (przycisk DOPISZ REKORD),

- usunięcia zaznaczonego rekordu (przycisk USUNIĘCIE REKORDU);

- edycji zaznaczonego pola (przycisk EDYCJA REKORDU lub naciśnięcie klawisza F2 powoduje przejście do trybu edycji danego pola);

dostępne są z poziomu paska poleceń okna Definicje zmiennych w Edytorze definicji zmiennych.

Rysunek : Pasek poleceń do edycji rekordu bazy definicji zmiennych.

uwaga Usunięcie zmiennej nie spowoduje fizycznego usunięcia zmiennej z bazy, ale zaznaczenie zmiennej jako usuniętej – dzięki temu w tworzonym raporcie zmian będzie można ująć również informacje na temat zmiennych usuniętych (patrz: 2.11 Export bazy do arkusza Excel).


2.2.1.2 Dodawanie, usuwanie i natychmiastowa edycja zmiennych

2.2.1.2 Dodawanie, usuwanie i natychmiastowa edycja zmiennych przy użyciu poleceń menu lokalnego / dodawanie zmiennych systemowych / wstawianie definicji zmiennej z kanału OPC

Klikając w edytorze definicji zmiennych prawym przyciskiem myszy na rekordzie (na dowolnym atrybucie) wybranej zmiennej uruchamiane jest menu lokalne umożliwiające:

  • dodanie nowej zmiennej w wyniku skopiowania rekordu wybranej zmiennej - polecenie Wstaw kopię definicji zmiennej (Shift + Ctr + Ins) - rekord nowej zmiennej dodawany jest powyżej zmiennej wybranej; wartości atrybutów nowej zmiennej są identyczne z wartościami atrybutów zmiennej wskazanej, za wyjątkiem atrybutu Nazwa, któremu należy nadać indywidualną nazwę;

  • usuwanie zmiennej - polecenie Wyczyść zaznaczone (Del) - usuwany jest rekord wskazanej zmiennej;

  • natychmiastową edycję bieżącej komórki po wpisaniu dowolnego znaku - opcja Natychmiastowa edycja (Shift + Ctrl +E);

Rysunek : Menu lokalne rekordu zmiennej.

Menu lokalne umożliwia również dodawanie zmiennych systemowych - polecenie Wstaw definicję zmiennej systemowej - uruchamiane jest okno, za pomocą którego można dodać do bazy definicji zmiennych następujące zmienne systemowe:

__USERID__ - zapewnia dostęp do identyfikatora aktualnie zalogowanego użytkownika;

__USERNAME__ - zapewnia dostęp do nazwy aktualnie zalogowanego użytkownika;

__USERLEVEL__ - zapewnia dostęp do aktualnie obowiązującego poziomu uprawnień;

__AGR_IdGrupy__ - pozwala na wyświetlenie stanu aktywności alarmów należących do wspólnej grupy.

Rysunek : Menu lokalne rekordu zmiennej - dodawanie zmiennej systemowej.


2.2.1.3 Dodawanie i usuwanie atrybutow zmiennych

2.2.1.3 Dodawanie i usuwanie atrybutów zmiennych

uwaga Nie można usunąć atrybutów obligatoryjnych.

Przyciski Dodaj atrybut dodaj atrybut, Usuń atrybut usuń atrybut znajdują się w menu Baza Definicji Zmiennych.

Rysunek : Okno dodawania nowego atrybutu.


2.2.1.4 Edycja wartosci atrybutu dla kilku zmiennych

2.2.1.4 Edycja wartości atrybutu dla kilku zmiennych jednocześnie

Polecenie Zmień wartości dostępne w menu lokalnym wywoływanym po zaznaczeniu wybranych wartości danego atrybutu umożliwia zmianę tych wartości – patrz: rys. poniżej.

Rysunek: Zamiana wszystkich zaznaczonych wartości danego atrybutu.

Polecenie Zamień zaznaczone dostępne w menu lokalnym wywoływanym po zaznaczeniu wybranych wartości danego atrybutu umożliwia zamianę pewnej określonej wartości atrybutu w obszarze zaznaczonych pól na nową wartość - patrz: rys. poniżej.

Rysunek: Zamiana określonej wartości atrybutu w obszarze zaznaczonych pól.

Polecenie Zamień w kolumnie dostępne w menu lokalnym wywoływanym po kliknięciu prawym klawiszem myszy w dowolnym polu danego atrybutu pozwala użytkownikowi zmienić określoną wartość atrybutu w obszarze całej kolumny, w której chociaż jedno pole jest zaznaczone - patrz: rys. poniżej.

Rysunek: Zamiana określonej wartości atrybutu w obszarze zaznaczonej kolumny.


2.2.1.5 Wybor widocznych atrybutow zmiennych

2.2.1.5 Wybór widocznych atrybutów zmiennych

Lista atrybutów wszystkich zmiennych wyświetlana w oknie edytora atrybutów zmiennych oraz oknie podglądu zmiennych może być określana przez użytkownika przy użyciu przycisku lista atrybutów (pierwsza pozycja wiersza nagłówków listy zmiennych). Naciśnięcie go otwiera listę wszystkich atrybutów danej bazy definicji zmiennych.

Rysunek: Przycisk wyboru widocznych atrybutów zmiennych.

Można również podejrzeć wartości (wszystkich / bieżących lub zadeklarowanych w zestawie) atrybutów wybranej zmiennej, klikając w edytorze definicji zmiennych lub oknie przeglądania zmiennych prawym przyciskiem myszy na rekordzie wybranej zmiennej (patrz: rysunek poniżej).

Rysunek: Menu lokalne dostępne dla rekordów zmiennej.

Po kliknięciu prawym przyciskiem myszy na dowolne pole wiersza nagłówków pojawia się menu lokalne nagłówków umożliwiające:

  • sortowanie wg wartości rosnącej wskazanego atrybutu - polecenie rosnąco,

  • sortowanie wg wartości malejącej wskazanego atrybutu - polecenie malejąco,

  • usunięcie efektu sortowania,

  • grupowanie wg wartości danego pola - polecenie grupowanie,

  • włączenie/wyłącznie pola grupowania, do którego można przeciągnąć kursorem myszy nazwę dowolnego nagłówka w celu pogrupowania rekordów wg wartości danego atrybutu - polecenie pole grupowania,

  • usunięcie kolumny,

  • usunięcie wszystkich kolumn (poza kolumną Nazwa),

  • wybór kolumny - uruchamia okno wyboru nagłówków kolumn wszystkich zadeklarowanych w bazie definicji zmiennych atrybutów, które metodą drag-and-drop można przeciągnąć do pola grupowania lub do wiersza wyświetlanych atrybutów zmiennych - polecenie wybór kolumn;

  • wybór zestawu kolumn - uruchamia okno z zestawami atrybutów, jakie wykorzystywane są do parametryzacji określonych modułów systemu Asix oraz poszczególnych obiektów, umieszczanych na maskach wizualizacyjnych aplikacji; wskazanie danego zestawu atrybutów powoduje, że w edytorze bazy wyświetlone zostaną kolumny parametrów parametryzujących pracę określonego modułu/obiektu;

  • dopasowanie szerokości kolumny do wartości atrybutów - polecenie dostosowanie (dotyczy wybranej kolumny) lub polecenie dopasowanie (wszystkie kolumny), które dotyczy wszystkich kolumn jednocześnie;

  • wyświetlenie okna z opisem atrybutu aktualnie zaznaczonej kolumny.

Rysunek: Menu lokalne dla wiersza nagłówków atrybutów.


2.2.1.6 Edytory atrybutow zmiennych

2.2.1.6 Edytory atrybutów zmiennych

Edycję wybranych atrybutów zmiennych ułatwiają edytory uruchamiane przyciskiem wielokropek, znajdującym się w polu atrybutu. Aktualnie dostępne są następujące edytory:

1. Adresów zmiennych

2. Parametrów archiwizacji

3. Maski zmiennej

4. Achiwum

5. Formatu zmiennej

6. Funkcji przeliczającej

7. Zmiennej kontrolnej

8. Edytor wyboru kanału

9. Edytor limitów

***

Edytor adresu zmiennej (uruchamiany z pola Adres) uruchamia okno zawierające zestaw pól umożliwiających zdefiniowanie adresu zmiennej. Zestaw pól zależy od drajwera zadeklarowanego dla kanału, do którego została przyporządkowana dana zmienna.

Edytor adresu zmiennej dostępny jest dla wybranych drajwerów. W pozostałych przypadkach należy adres zmiennej wprowadzić ręcznie na podstawie sposobu adresowania zmiennych dla danego drajwera.

Rysunek: Przykładowe okno edytora adresu zmiennej dla kanału z drajwerem Sapis7.

***

Edytor parametrów archiwizacji zmiennych (uruchamiany z pola Parametry archiwizacji) umożliwia zadeklarowanie parametrów archiwizacji podstawowej i archiwizacji dodatkowej.

W ramach danego archiwum (pole Archiwum w bazie definicji zmiennych) zmienna może podlegać dodatkowej archiwizacji w sytuacji, gdy oprócz archiwów przechowywanych w plikach np. dobowych, wymagana jest archiwizacja danych w bazie SQL. W innym przypadku może zachodzić potrzeba przeanalizowania dla danego wycinka czasu danych archiwizowanych z większą częstotliwością niż przewiduje to zasadnicza archiwizacja - wówczas również należy skorzystać z archiwizacji dodatkowej.

Wybór rodzaju archiwizacji odbywa się za pośrednictwem pola Rodzaj - dostępne opcje to:

- Bez archiwizacji;

- Archiwizacja podstawowa;

- Archiwizacja podstawowa i dodatkowa.

Pole Rodzaj archiwum określa typ archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

uwaga Archiwa typu D, M, Y, H wymagają archiwum STANDARD. Stąd zmienna, która w parametrach archiwizacji ma zadeklarowany jeden z wymienionych typów, musi mieć w parametrach archiwum zadeklarowany jako rodzaj archiwum: STANDARD (Architekt > Dane archiwalne > <nazwa archiwum> > zakładka Standardowe).

Pozostałe typy archiwum B i P deklarowane są dla archiwum MS SQL lub AS BDE.

Pozostałe pola edytora umożliwiają zadeklarowanie pozostałych parametrów archiwizacji:

- okres próbkowania;

- dokładność rejestracji czasu;

- dokładność rejestracji danych;

- atrybuty rejestracji: ODTWARZAJ, NIE PAKUJ, KAŻDY;

- minimalny horyzont czasu przechowywania (tylko dla archiwów H i B).

Rysunek: Okno edytora parametrów archiwizacji (archiwizacja podstawowa).

***

Edytor maski zmiennej (uruchamiany z pola Maska zmiennej):

Rysunek: Okno edytora maski bitowej zmiennej.

***

Edytor wyboru archiwum (uruchamiany z pola Archiwum):

Rysunek: Okno wyboru archiwum.

***

Edytor formatu (uruchamiany z pola Format) ułatwia definiowanie formatu zmiennej. Dostępne formaty:

  • Liczba całkowita określana przez:

Typ;

Szerokość;

Typ danej wejściowej;

  • Liczba zmiennoprzecinkowa określana przez:

Typ;

Szerokość;

Precyzję;

  • Data - dane wejściowa jest traktowana jako ilość sekund od 1970-01-01 00:00, 32 bity określany przez:

Format daty - treścią formatu jest ciąg znaków określających separatory i elementy składowe daty w dowolnej kolejności. Elementy składowe to:

y - rok

m - miesiąc

d - dzień

h - godzina

n - minuta

s - sekunda

Brak określenia formatu daty oznacza formatowanie według domyślnego wzorca: y/m/d h:n:s

  • Czas określany przez opcje:

Dana wejściowa jest traktowana jako ilość milisekund, 32 bity,

Dana wejściowa jest traktowana jao ilość sekund, 32 bity,

Format czasu - treścią formatu jest ciąg znaków określających separatory i elementy składowe czasu w dowolnej kolejności. Elementy składowe to:

d - ilość dni

h - ilość godzin

n - ilość minut

s - ilość sekund

z - ilość milisekund

Brak określenia formatu czasu oznacza formatowanie według domyślnego wzorca: h:n:s

Rysunek: Edytor atrybutu Format.

***

Edytor funkcji przeliczających (uruchamiany z pola Funkcja przeliczająca), który podpowiada projektantowi składnię dla każdej z wbudowanych w system Asix funkcji przeliczających.

Pełny zestaw funkcji przeliczających - patrz podręcznik: Asix.chm / Asix.pdf

Funkcje przeliczające używane przez są przez moduł ASMEN przy przekształcaniu wartości zmiennych procesowych z postaci surowej na postać rzeczywistą. Każda zmienna posiada indywidualnie deklarowaną funkcję przeliczającą.

Rysunek . Okno edytora funkcji przeliczających.

***

Edytor zmiennej kontrolnej (uruchamiany z pola Zmienna kontrolna) uruchamia okno wyboru zmiennej kontrolnej:

Rysunek: Okno wyboru zmiennej.

***

Edytor wyboru kanału (uruchamiany z pola Kanał):

Rysunek: Edytor wyboru kanału.

***

Edytor limitów (uruchamiany z pola: Maksimum, Maksimum krytyczne, Minimum, Minimum krytyczne). Umożliwia zadeklarowanie limitu w jednej z trzech następujących postaci:

  • Limit jako wartość stała

  • Limit jako wartość zmiennej

  • Przekroczenie limitu sygnalizowane kombinacja bitów zmiennej (Nazwa zmiennej, Operator bitowy, Maska bitowa (szesnastkowo))

Rysunek: Okno edytora limitów.


2.2.2 Tworzenie schematu bazy definicji zmiennych – Edytor

2.2.2 Tworzenie schematu bazy definicji zmiennych - Edytor schematu

Schemat bazy definicji zmiennych obejmuje informacje dotyczące atrybutów grupujących, definicji zestawów atrybutów, parametrów funkcji przeliczających, nagłówków atrybutów, języków narodowych atrybutów zmiennych, deklaracji atrybutów zastępczych (dla aplikacji wielojęzycznych).

Edycja tych informacji możliwa jest za pomocą Edytora schematu, dostępnego w module Baza definicji zmiennych po otwarciu bazy.

Rysunek: Widok edytora schematu.


2.2.2.1 Grupowanie zmiennych

Grupowanie zmiennych opiera się na przypisaniu zmiennych do dowolnej liczby grup identyfikowanych przez atrybut grupujący, dodany do Edytora schematu, na zakładce Atrybuty grupujące.

Rysunek: Okno definiowania atrybutów grupujących.

Aby można było zadeklarować atrybut grupujący w zakładce Atrybuty grupujące - najpierw atrybut ten musi zostać dodany do bazy definicji zmiennych w Edytorze definicji zmiennych.

Domyślnie w bazie definicji zmiennych tworzony jest jeden atrybut grupujący o nazwie Grupa1. Projektant może dodać więcej atrybutów grupujących - ich liczba nie jest ograniczona.

Także nazwy atrybutów grupujących mogą być dowolne.

uwaga Zaleca się, aby baza miała zadeklarowany przynajmniej jeden atrybut grupujący.

Zmienna, dla której pominięto wartość pola atrybutu grupującego, będzie widoczna w systemie w grupie o nazwie (Pusta nazwa) widocznej pośród grup użytkownika.

Rysunek: Drzewo grup zmiennych.

Przykładowo, zmienna może mieć atrybuty grupujące: Wydział (wartości np.: Bloki, Pomocniczy), Jednostka (Blok1, Blok2, Demineralizacja, Odpopielanie, itd.), Urządzenie (Camac, S7_1, GeFanuc11, itp.) i Dziedzina Wartości (Analog, Dwustan, Średnia_5m, itd.).

Po otwarciu okna edytora definicji zmiennych / okna przeglądania zmiennych drzewo obrazujące strukturę bazy jest generowane automatycznie na podstawie atrybutów grupujących.

Drzewo ma tyle poziomów, ile jest atrybutów grupujących. Na pierwszym poziomie wyświetlane są wszystkie unikalne wartości atrybutu, który został zadeklarowany jako pierwszy w Edytorze schematu, zakładce Atrybuty grupujące. Następnie dla każdej wartości atrybutu pierwszego tworzonych jest tyle węzłów, ile jest różnych wartości atrybutu zadeklarowanego jako drugi. Tak samo dzieje się dla pozostałych poziomów.

Aby zmienić kolejność wartości atrybutów - wystarczy metodą drag-and-drop uchwycić nagłówek atrybutu grupującego i przenieść go na inną pozycję w bloku Grupy okna edytora definicji zmiennych lub okna podglądu zmiennych.

Rysunek: Zmiana kolejności grupowania zmiennych wg atrybutów.

Kolejność wyświetlanych wartości dla poszczególnych atrybutów grupujących może być ustalana poprzez kliknięcie na nagłówku nazwy danej grupy w bloku Grupy okna edytora zmiennych / okna przeglądania zmiennych (symbol wg malejących wartości oznacza posortowanie wg malejących wartości, wg rosnących wartości - wg rosnących wartości).


2.2.2.2 Zestawy atrybutow

2.2.2.2 Zestawy atrybutów

Zestawy atrybutów definiowane są na potrzeby aplikacji systemu Asix. Używane są w akcji OPIS_ZMIENNEJ oraz w oknie wyboru zmiennej (oknie edytora definicji zmiennych / oknie przeglądania zmiennych) dla zawężenia ilości wyświetlanych atrybutów zgodnie z potrzebami projektanta.

Miejscem, gdzie użytkownik może utworzyć swoje zestawy atrybutów jest zakładka Zestawy atrybutów w edytorze schematu (patrz: Rysunek: Okno definiowania zestawu atrybutów.).

uwaga Obecnie zestaw składa się tylko z listy nazw atrybutów. Szerokość okna atrybutów musi być zawsze podawana przy wywołaniu akcji OPIS_ZMIENNEJ.

Rysunek: Okno definiowania zestawu atrybutów.


2.2.2.3 Parametry funkcji przeliczajacych

2.2.2.3 Parametry funkcji przeliczających

Parametry funkcji przeliczających definiowane są na potrzeby aplikacji systemu Asix.

W bazie definicji zmiennych atrybut FunkcjaPrzeliczajaca domyślnie zawiera nazwę funkcji przeliczającej zmiennej i wszystkie parametry funkcji. Istnieje jednakże mechanizm, który umożliwia umieszczanie w atrybucie FunkcjaPrzeliczajaca tylko nazwy funkcji przeliczającej, a każdego jej parametru w osobnym atrybucie. Tabela FunkcjePrzeliczające definiuje niezależnie dla każdej funkcji nazwy atrybutów zawierających parametry tej funkcji.

Rysunek: Okno definiowania parametrów funkcji przeliczających.


2.2.2.4 Tlumaczenia nazw atrybutow zmiennych

2.2.2.4 Tłumaczenia nazw atrybutów zmiennych

Baza posiada możliwość definiowania lokalnych, przetłumaczonych na dowolny zadeklarowany przez użytkownika język, nazw atrybutów systemowych i atrybutów użytkownika.

Lokalne nazwy atrybutów pojawiają się jako tytuły kolumn w oknie opisu zmiennej (dostępnym w Edytorze definicji zmiennych lub w oknie podglądu zmiennych).

Rysunek: Okno opisu zmiennej - angielskie nazwy atrybutów.

Każdy język (poza PL i EN) wymaga zadeklarowania przez użytkownika nazw atrybutów zmiennych w Edytorze schematu bazy definicji zmiennych:

Bazy danych > Baza definicji zmiennych > Edytor schematu > Nagłówki atrybutów

Rysunek: Okno deklarowania lokalnych nazw atrybutów zmiennych.


2.2.2.5 Atrybuty zastepcze

2.2.2.5 Atrybuty zastępcze

Atrybuty zastępcze stosowane są w aplikacjach wielojęzycznych. Dla każdego atrybutu użytkownika oraz dla atrybutu Opis można zdefiniować atrybut zastępczy - tzw. alias.

Dany atrybut (atrybut podstawowy) może posiadać jeden alias dla każdego języka obsługiwanego przez aplikację. Zdefiniowanie aliasu atrybutu sprawia, że dla wybranego języka w miejsce atrybutu podstawowego używany jest alias.

Rysunek: Okno definiowania atrybutów zastępczych.

uwaga W przypadku deklarowania atrybutu zastępczego, zarówno dla atrybutu podstawowego jak i zastępczego należy zdefiniować język w tabeli języków – zakładka Języki atrybutów w Edytorze schematu. Patrz: 2.2.2.6. Deklarowanie języków atrybutów .


2.2.2.6 Deklarowanie jezykow atrybutow

2.2.2.6 Deklarowanie języków atrybutów

Tabela języków atrybutów znajduje się w:

Bazy danych > Baza definicji zmiennych > Edytor schematu > zakładka Języki atrybutów

Rysunek: Okno definiowania języków atrybutów.

Tabela języków pozwala określić, w jakim języku zdefiniowano wartości danego atrybutu. Informacja ta potrzebna jest zwykle wyłączne w aplikacjach wielojęzycznych do zadeklarowania języka dla atrybutów tekstowych. Język deklarowany jest zarówno dla atrybutu podstawowego jak i zastępczego.


2.2.3 Import modyfikacji z arkusza Excel

Zmiany w definicji zmiennych polegające na dodaniu, usunięciu lub modyfikacji rekordu/rekordów mogą być w wygodny sposób importowane do bazy definicji zmiennych z arkusza Excel. Dla wygody użytkownika w module Baza definicji zmiennych > zakładce Szablon importu modyfikacji znajduje się funkcja umożliwiająca utworzenie skoroszytu (o domyślnej nazwie SzablonImportuModyfikacjiVarDef.xls) zawierającego wszystkie niezbędne kolumny oraz przykładowe dane potrzebne do importu modyfikacji.

uwaga Zakładka Szablon importu modyfikacji dostępna jest dla Typu bazy definicji zmiennych: Standardowa baza definicji zmiennych / Tryb Edytor. Lista kolumn w utworzonym szablonie importu odpowiada bieżącej (zadeklarowanej w zakładce Format) bazie definicji zmiennych.

Rysunek: Szablon importu modyfikacji VarDef.

Jak zaimportować do istniejącej bazy definicji zmiennych MS SQL lub Jet zmiany w definicji zmiennych wykorzystując arkusz Excel jako źródło?:

1. W pierwszym kroku wygeneruj szablon importu modyfikacji:

(wcześniej upewnij się, czy aktualnie włączonym trybem tworzenia bazy jest Tryb Edytor, a w zakładce Baza definicji zmiennych > Format zadeklarowana została właściwa baza)

Funkcja generujące szablon importu modyfikacji znajduje się w:

Baza definicji zmiennych > zakładka Szablon importu modyfikacji > przycisk Utwórz

2. W wygenerowanym skoroszycie, w zakładce Modyfikacje zmiennych wprowadź stosowne rekordy, pamiętając że:

- w przypadku dodania rekordu nowej zmiennej, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak plus (+);

- w przypadku usunięcia rekordu zmiennej istniejącej w bazie, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak minus (-);

- w przypadku modyfikacji rekordu zmiennej istniejącej w bazie, należy w kolumnie Rodzaj operacji (ang. OperationKind) wstawić znak gwiazdka (*);

3. Otwórz istniejącą bazę definicji zmiennych (przycisk Otwórz otwórz).

4. Wybierz komendę Importuj modyfikacje importuj modyfikacje i wskaż stosowny plik *. XLS ze zmodyfikowanymi rekordami zmiennych.

5. W oknie ’Wybierz arkusz’ zaznacz opcję Modyfikacje zmiennych i zatwierdź wybór przyciskiem OK.


2.3 Tworzenie bazy w trybie Generatora

W przypadku tworzenia bazy definicji zmiennych w trybie Generatora, definicje zmiennych dostarczane są w zewnętrznych źródłach (np. w arkuszach Excel). Baza generowana jest przy użyciu programu Architekt. Po każdej modyfikacji źródeł danych należy bazę ręcznie wygenerować (lub uaktualnić) i uruchomić ponownie aplikację systemu Asix.

Szczególnym przypadkiem jest tworzenie zbiorczej bazy generowanej z kilku istniejących baz definicji zmiennych - patrz: 2.3.7. Zbiorcza baza definicji zmiennych.

Tworzenie bazy definicji zmiennych w trybie Generatora realizowane jest w następujących krokach:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

Rysunek: Baza definicji zmiennych > zakładka Typ - Tryb Generator.

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia Nazwy użytkownika oraz Hasła.

3. Określ źródła danych:

Baza definicji zmiennych > zakładka Źródła danych > pliki źródła danych (pliki Excel, obiekt OLE DB, pliki ZEZ/DB starszych wersji A sixa, pliki tekstowe starszych wersji A sixa lub pliki konfiguracyjne aplikacji formatu *.XML)

Rysunek: Baza definicji zmiennych - zakładka 'Źródło danych'.

4. Wybierz polecenie Generuj generuj.

5. Ewentualnie otwórz bazę, aby zweryfikować przy użyciu Edytora definicji zmiennych poprawność generacji;


2.3.1 Opcje generowania bazy definicji zmiennych z wielu zrodel

2.3.1 Opcje generowania bazy definicji zmiennych z wielu źródeł danych

Blok Bazy danych > Baza definicji zmiennych wyposażony został w zakładki Opcje/Opcje2, umożliwiające ustawienie parametrów dotyczących generowania bazy definicji zmiennych pochodzących z wielu źródeł - włączając w to przypadki, kiedy różne źródła zawierają definicje powtarzających się zmiennych.

Zakładka Opcje obejmuje następujące parametry:

  • Generowanie informacji o położeniu definicji zmiennych

  • Dodaj atrybut ’Źródło danych’ - powoduje dodanie do bazy definicji zmiennych atrybutu przechowującego nazwę skoroszytu zawierającego definicję zmiennej;

  • Dodaj atrybut ’Tabela danych’ - powoduje dodanie do bazy definicji zmiennych atrybutu przechowującego nazwę arkusza zawierającego definicję zmiennej;

  • Sprawdzanie różnic podczas generowania bazy definicji zmiennych

  • Włącz sprawdzanie różnic podczas generowania bazy definicji zmiennych - opcja umożliwia porównanie generowanej bazy z istniejącą bazą w trakcie generowania bazy definicji zmiennych; w przypadku wykrycia zmian pojawia się pytanie o kontynuowanie; porównywane są definicje zmiennych i tabele schematu.

  • Włącz zapis tylko różnic do bazy definicji zmiennych - opcja umożliwia zapisywanie tylko zmian wykrytych w trakcie generacji bazy definicji zmiennych zamiast czyszczenia bazy i zapisywania wszystkich danych; zapis samych zmian jest możliwy gdy nie występują zmiany schematu bazy.

  • Dzielenie definicji zmiennej pomiędzy źródłami

  • Pozwalaj na dzielenie definicji zmiennej pomiędzy źródłami - opcja przydatna w przypadku scalania definicji tych samych zmiennych pochodzących z wielu różnych źródeł;

  • Tworzenie kopii zapasowej podczas generowania bazy definicji zmiennych

  • Włącz tworzenie kopii zapasowej podczas generowania bazy definicji zmiennych – przy załączonej opcji generator bazy definicji zmiennych tworzy kopię dotychczasowej bazy w podkatalogu ‘backup’ zadeklarowanego katalogu bazy (lub w przypadku braku zadeklarowanego katalogu bazy danych serwera MS SQL podkatalog z kopią tworzony jest w domyślnym katalogu bazy serwera MS SQL).

Zakładka Opcje 2 obejmuje następujące parametry:

  • Wielokrotne definicje zmiennych - preferowanie zmiennych aktywnych

  • W przypadku powtórzenia definicji zmiennej użyj pierwszej definicji zmiennej aktywnej – w przypadku użycia opcji generator przyjmuje jako obowiązującą definicję pochodzącą z pierwszego dokumentu zawierającego tę definicję wg kolejności zadeklarowanych źródeł danych na zakładce Źródła danych.

  • Wielokrotne definicje zmiennych - preferowanie kanałów fizycznych

Opcja ma zastosowanie dla źródeł danych w postaci plików *.ini i *.xml, ponieważ tylko dla tych źródeł możliwe jest określenie typu kanału w definicji zmiennej:

Definicje zmiennych nie mogą się powtarzać;

Definicje zmiennych mogą się powtarzać: zezwalaj na jedną definicję w kanale fizycznym, ignoruj powtórzone definicje w kanałach typu NETWORK - w praktyce oznacza to, że w trakcie generowania bazy zaakceptowana zostanie pierwsza napotkana definicja, a dla wszystkich definicji z pozostałych kanałów fizycznych wypisane zostanie ostrzeżenie w panelu logu ’Generacja bazy definicji zmiennych’;

Definicje zmiennych mogę się powtarzać: akceptuj pierwszą definicję w kanale fizycznym, ignoruj pozostałe powtórzone definicje - oznacza, że w trakcie generowania bazy zaakceptowana zostanie pierwsza definicja z kanału fizycznego, dla drugiej definicji z kanały fizycznego pojawi się ostrzeżenie w panelu logu ’Generacja bazy definicji zmiennych’, a pozostałe powtarzające się definicje zostaną zignorowane.


Generowanie bazy z plików ZEZ/mdb

2.3.2. Generowanie bazy z plików ZEZ/DB

W przypadku baz definicji zmiennych w formacie Paradox wykorzystywanych w starszych wersjach Asixa (wersja 4 i wcześniejsze) należy przekonwertować je do formatu standardowych baz systemu Asix. Patrz rozdział: 2.8 Konwertowanie bazy definicji zmiennych z formatu Paradox na format Jet lub MS SQL.


2.3.2 Generowanie bazy definicji zmiennych z arkusza Excel

2.3.3 Generowanie bazy definicji zmiennych z arkusza Excel

W przypadku generowania bazy definicji zmiennych na podstawie arkuszy Excel, należy te arkusze przygotować w sposób szczegółowo opisany w rozdziale 2.6 . Przygotowanie zewnętrznego źródła danych - arkusz Excel .

Architekt pozwala przygotować szablonowy plik Excel definicji zmiennych (Szablon bazy definicji zmiennych w Excel).


2.3.3.1. Generowanie bazy na podstawie listy używanych zmiennych

Generowanie bazy definicji zmiennych na podstawie listy używanych zmiennych umożliwia wygenerowanie bazy, w której znajdą się wyłącznie definicje zmiennych wykorzystywanych jako parametry w obiektach masek wizualizacyjnychw aplikacji (włącznie ze zmiennymi zależnymi - czyli użytymi w atrybutach wyżej wymienionych zmiennych lub w funkcji przeliczającej).

Aby wygenerować listę używanych zmiennych na podstawie definicji aplikacji należy:

1. Przy załadowanym pliku konfiguracyjnym aplikacji wybrać polecenie Generuj listę używanych zmiennych - dostępne w menu Aplikacja.

2. Zapisać wygenerowany plik o domyślnej nazwie 'Nazwy zmiennych używanych.xls'.

UWAGA: Istotny jest arkusz z listą zmiennych znajdujący się wewnątrz wygenerowanego pliku xls. Arkusz ten można przenieść do pliku, w którym umieszczone są arkusze z definicjami zmiennych. Ważne, aby zachować nazwę arkusza: 'ZmienneUżywane'.

Aby wygenerować bazę definicji zmiennych na podstawie listy używanych zmiennych należy:

1. Ustawić w bloku Bazy danych > Baza definicji zmiennych > zakładka Typ: typ bazy definicji zmiennych na Standardowa baza definicji zmiennych w trybie Generator.

2. Przejść do bloku Bazy danych > Baza definicji zmiennych > zakładka Źródła danych

2. Zadeklarować arkusze z definicjami zmiennych (w oparciu o które będzie generowana baza) wraz z arkuszem zawierającym listę zmiennych używanych.

3. Nacisnąć polecenie generowania bazy definicji zmiennych - Generuj.


2.3.3 Generowanie bazy definicji zmiennych na podstawie bazy

2.3.4 Generowanie bazy definicji zmiennych na podstawie bazy OLE DB

Istnieje możliwość wygenerowania bazy definicji zmiennych z bazy OLE DB po odpowiednim skonfigurowaniu właściwości łącza danych (dostawca, właściwości połączenia oraz opcje zaawansowane).

Struktura źródłowej bazy OLE DB powinna być przygotowana w sposób analogiczny do arkuszy Excel, wykorzystywanych jako źródło generowania bazy definicji zmiennych. Wymagane jest zatem zdefiniowanie następujących rodzajów danych:

- atrybuty zmiennych,

- grupowanie,

- zestawy atrybutów,

- funkcje przeliczające,

- nagłówki,

- języki atrybutów,

- nazwy zstępcze.

Powyższe dane należy przygotować według wskazówek omówionych w rozdziale 2.6. Przygotowanie zewnętrznego źródła danych - arkusz Excel.


2.3.5. Generowanie bazy definicji zmiennych na podstawie plików XML

W przypadku generowania zbiorczej bazy definicji zmiennych z baz kilku aplikacji konfigurowanych w plikach xml - zaleca się wskazanie źródeł danych przy użyciu przycisku Asix - pliki xml....

Rysunek: Okno deklarowania źródeł danych do wygenerowania bazy definicji zmiennych.


2.3.6. Import definicji zmeinnych z serwera OPC

2.3.6. Import definicji zmiennych z serwera OPC

Definicje zmiennych z serwera OPC importowane są poleceniem Importuj z serwera OPC… z menu Baza definicji zmiennych. Polecenie to uruchamia kreator, który pozwala zdefiniować połączenie z serwerem OPC i sposób importu definicji zmiennych. Kreator automatycznie doda utworzony arkusz do listy źródeł danych projektowanej aplikacji (Architekt > Bazy danych > Baza definicji zmiennych > Źródła danych), gdy aktywnym typem tworzenia aplikacji jest Tryb Generator.

Jeśli baza jest generowana po raz pierwszy - należy w module Bazy danych > Baza definicji zmiennych na zakładce Typ zadeklarować jako typ tworzenia bazy - Tryb Generator.

Jeżeli definicje zmiennych z serwera OPC zostały juz zaimportowane do arkusza Ecxel a następnie baza definicji zmiennych wygenerowana - istnieje możliwość wprowadzania zmian do arkusza zawierającego definicje zmiennych pochodzących z OPC i importowania tych zmian do bazy przy użyciu komendy Importuj modyfikacje... z menu Baza definicji zmiennych. Opcja ta jest dostępna po ustawieniu w module Bazy danych > Baza definicji zmiennych na zakładce Typ typu tworzenia bazy Tryb Edytor i otwarciu bazy.

Rysunek: Kreator importu definicji zmiennych z serwera OPC.


2.3.7. Zbiorcza baza definicji zmiennych

Zbiorcza baza definicji zmiennych jest to baza definicji zmiennych generowanych z kilku istniejących baz definicji zmiennych. Przy generowaniu takiej bazy można napotkać dwa rodzaje problemów.

Informacje tego samego typu mogą znajdować się w wejściowych bazach w atrybutach o innych nazwach. W tym przypadku należy użyć transformacji nazw atrybutów, aby ujednolicić nazwy atrybutów.

Drugi problem to różne nazwy i liczby atrybutów grupujących. W takim przypadku również należy użyć transformacji nazw atrybutów, aby ujednolić nazwy atrybutów lub dodać brakujące atrybuty grupujące. Należy również użyć transformacji wartości atrybutów, aby podać wartości dodawanych atrybutów grupujących i, ewentualnie, dopasować wartości atrybutów grupujących do nazewnictwa stosowanego w zbiorczej bazie definicji zmiennych.

Uwaga: istnieje też możliwość czytania definicji zmiennych z łączonych baz definicji zmiennych, parametryzowanych przez zewnętrzne pliki XML. Patrz: 2.1.2.1. Łączone bazy definicji zmiennych.


2.3.9. Transformacja nazw i wartości atrybutów

W przypadku generowania baz definicji zmiennych na podstawie definicji zmiennych znajdujących się w arkuszu kalkulacyjnym *.xls dostępny jest mechanizm transformacji nazw atrybutów i wartości atrybutów. Transformacji takiej można dokonać definiując w arkuszu Excela nazwę atrybutu wejściowego i wyjściowego (dla transformacji nazw atrybutów) lub wejściowe i wyjściowe wartości atrybutów (dla transformacji wartości atrybutów). Zarówno nazwa jak i struktura takiego arkusza (tabeli) musi być ściśle określona:

- dla transformacji nazw atrybutów:

- nazwa arkusza: PrzekształceniaNazwAtr

- kolumny arkusza: NazwaŹródłaDanych, AtrybutWejściowy, AtrybutWyjściowy

(szczegółowy opis - patrz: 2.6.8 Parametry transformacji nazw atrybutów i wartości)

Podanie jako AtrybutWejściowy nazwy pustej powoduje dodanie do źródła danych nowej kolumny.

Podanie jako AtrybutWyjściowy nazwy pustej powoduje usunięcie z źródła danych wskazanej kolumny.

- dla transformacji wartości atrybutów:

- nazwa arkusza: PrzekształceniaWartościAtr

- kolumny arkusza: NazwaŹródłaDanych, Atrybut, WejściowaWartośćAtrybutu i WyjściowaWartośćAtrybutu

(szczegółowy opis - patrz: 2.6.8 Parametry transformacji nazw atrybutów i wartości)

Podanie jako WejściowaWartośćAtrybutu nazwy pustej powoduje dodanie do źródła danych nowej wartości atrybutu.

Podanie jako WyjściowaWartośćAtrybutu nazwy pustej powoduje usunięcie z źródła danych wskazanej wartości atrybutu.


2.3.10. Nadpisywanie atrybutów przez wybraną tabelę źródła danych

Nadpisywanie wartości atrybutów przez wybraną tabelę źródła danych wymaga wstawienia dodatkowej kolumny o nazwie ForceUpdateAttributes do tabeli (arkusza) z docelowymi wartościami atrybutów, które chcemy nadpisać.

Nadpisywanie wartości atrybutów wykonywane jest dla konkretnych zmiennych - tabela z docelowymi wartościami atrybutów powinna zatem zawierać kolumnę z nazwami zmiennych, kolumny atrybutów z wartościami docelowymi oraz kolumnę ForceUpdateAttributes (kolumna ta może być pusta, wartości w niej nie są brane pod uwagę).

Rysunek: Nadpisywanie atrybutów - tabela docelowych wartości atrybutów.


2.4 Przegladanie_zmiennych

2.4 Przeglądanie zmiennych

Poza dostępem do definicji zmiennych, jaki zapewnia edytor bazy definicji zmiennych, definicje zmiennych mogą być przeglądanie za pomocą okna 'Przeglądanie zmiennych', uruchamianego przyciskiem [image] Pokaż.

Rysunek. Okno 'Przeglądanie zmiennych'.

Dodatkowo okno daje możliwość przeglądania wartości bieżących zmiennych oraz modyfikowania tych wartości.

Do wyświetlenia wartości bieżących zmiennych służy przycisk Pokaż wartości bieżące, po naciśnięciu którego zostają wyświetlone kolumny Wartość zmiennej i Jakość zmiennej.

Funkcja jest dostępna tylko w oknie wyboru zmiennych wywoływanym bezpośrednio z programu Architekt. W trybie pokazywanie wartości bieżących ukrywany jest wiersz filtrów, ponieważ odświeżanie wartości bieżących i tak praktycznie uniemożliwia korzystanie z niego.

Aby dokonać zmiany wartości zmiennej, należy w wierszu wybranej zmiennej kliknąć prawym klawiszem myszy w kolumnie Wartość zmiennej i wybrać z menu podręcznego polecenie [image] Modyfikuj wartość bieżącą.

Rysunek: Okno 'Przeglądanie zmiennych' - modyfikacja wartości bieżącej zmiennej.

Okno 'Przeglądanie zmiennych' umożliwia również wyszukiwanie zmiennych po nazwie.

Rysunek: Okno 'Przeglądanie zmiennych' - wyszukiwanie zmiennych.


2.4.1 Wyszukiwanie wartosci atrybutu i filtrowania rekordow

2.4.1 Wyszukiwanie wartości atrybutu i filtrowania rekordów po wartości atrybutu

Wyszukiwanie i filtrowanie rekordów wg wymaganej wartości atrybutu umożliwia Kreator filtrów wywoływany poleceniem FILTRUJ DANE z paska poleceń okna 'Przeglądanie zmiennych':

Rysunek: Okno kreatora filtrów dla rekordów bazy definicji zmiennych.

W edytorze definicji zmiennych istnieje mechanizm wyszukiwania inkrementalnego wartości dowolnego atrybutu. Po wpisaniu początkowych liter szukanej wartości w dowolną komórkę kolumny tego atrybutu mechanizm powoduje automatyczne przeniesienie do pierwszego rekordu z daną początkową wartością atrybutu. Mechanizm działa dla kolumn wszystkich atrybutów.


2.5 Praca ze skoroszytem Excel jako zrodlem danych o atrybutach

2.5 Praca ze skoroszytem Excel jako źródłem danych o atrybutach zmiennych bez generowania bazy definicji zmiennych

Użytkownik pracujący z najnowszą wersją pakietu Asix ma do dyspozycji możliwość takiego skonfigurowania pracy aplikacji, aby korzystała ona z definicji zmiennych pobieranych bezpośrednio z arkuszy kalkulacyjnych Excel [4]. Arkusze te należy przygotować w sposób szczegółowo opisany w rozdziale 2.6 . Przygotowanie zewnętrznego źródła danych - arkusz Excel.

Jak zadeklarować arkusz kalkulacyjny jako źródło definicji zmiennych?:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Źródło danych

3. Załaduj źródła danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż plik *.XLS naciskając przycisk Excel.

W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

Krok powtórz tyle razy, aż zostaną zadeklarowane wszystkie pliki źródłowe.

4. Dane mogą być przeglądane w oknie ’Przeglądanie zmiennych’ po wybraniu komendy Pokaż pokaż.

uwaga Ten typ bazy definicji zmiennych można stosować tylko wtedy, gdy na komputerze pracuje system Asix i ZAWSZE jest on uruchamiany jako pierwszy. Wyklucza to sytuację, w której na komputerze pracuje serwer internetowy AsPortal lub AsWWW lub generowane są raporty przy pomocy programu AsixConnect.

__________________________________________________

[4] Baza jest generowana ’w locie’ – w sposób niewidoczny dla użytkownika i tylko na czas działania aplikacji.


2.6 Przygotowanie zewnetrznego zrodla danych – arkusz Excel

2.6 Przygotowanie zewnętrznego źródła danych - arkusz Excel

W przypadku, gdy źródłem danych niezbędnych do wygenerowania bazy definicji zmiennych (jak i w trybie tworzenia bazy Tryb Źródło danych, kiedy definicje zmiennych pobierane są bezpośrednio z arkusza Excel) jest arkusz Excel, dane muszą znajdować się w arkuszach w formacie XLS lub XLSX. Arkusze mogą być tworzone programem Microsoft Excel (w wersji 97, 2000, XP, 2003 i 2007) lub programem Open Office (w wersji 1.1.2 lub późniejszej).

uwaga Architekt wyposażony został w prosty, ale w pełni funkcjonalny arkusz kalkulacyjny, który umożliwia edycję arkusza w formacie XLS - pomocny w sytuacji, gdy na komputerze nie jest zainstalowany pakiet Microsoft Excel.

Wyróżnionych zostało kilka rodzajów danych, które są umieszczone w odrębnych arkuszach w formie tabel [5] - rodzaje te zostaną omówione w kolejnych podrozdziałach:

  • atrybuty zmiennych,

  • grupowanie,

  • zestawy atrybutów,

  • funkcje przeliczające,

  • nagłówki,

  • języki atrybutów,

  • nazwy zastępcze,

  • parametry transformacji nazw atrybutów i wartości atrybutów.

uwaga Zakładki, których nazwy rozpoczynają się od znaku '#', są to zakładki informacyjne, nie wchodzące w skład schematu bazy. Takie zakładki nie są widziane przez Architekta podczas wyboru źródeł danych.

______________________________________________

[5] Nazwa arkusza w skoroszycie Excel odpowiada nazwie tabeli w docelowej bazie, generowanej na podstawie arkusza


2.6.1 Atrybuty zmiennych

Definicje zmiennych mogą znajdować się w jednym lub kilku arkuszach o dowolnej nazwie, w jednym lub kilku skoroszytach. Wszystkie atrybuty jednej zmiennej muszą znajdować się w jednym arkuszu.

W danym arkuszu nie muszą znajdować się wszystkie zdefiniowane w bazie atrybuty. Wszystkie atrybuty liczbowe, które nie są dla zmiennej zdefiniowane mają wartość NULL. Puste atrybuty tekstowe mają jako wartość tekst o długości 0.

Rysunek: Definicje zmiennych w arkuszu Excel w rozbiciu na kilka zakładek.

uwaga Wszystkie nazwy atrybutów systemowych wewnętrznie są zadeklarowane w języku angielskim.

Przy imporcie danych nazwy atrybutów systemowych mogą być podawane zarówno w języku polskim jak i angielskim - zgodnie z ustalonym szablonem nazw atrybutów - patrz: Załącznik 1.


2.6.2 Grupowanie

Atrybuty grupujące muszą znaleźć się w tabeli o ustalonej nazwie (w języku polskim: AtrybutyGrupujące, angielskim: GroupingAttributes).

Tabela składa się z jednej kolumny (pol.: Nazwa, ang.: Name). Każdy wiersz zawiera nazwę jednego atrybutu grupującego. Przykład - patrz: rysunek poniżej.

Nazwy atrybutów grupujących mogą być dowolne.

Rysunek: Arkusz Excel - atrybuty grupujące.


2.6.3 Zestawy atrybutow

2.6.3 Zestawy atrybutów

Tabela zestawów atrybutów (o ustalonej nazwie - pol.: ZestawyAtrybutów, ang.: AttributeSets) składa się z dwóch kolumn. W pierwszej kolumnie (o nazwie - pol: Nazwa, ang.: Name) znajduje się nazwa zestawu, a w drugiej kolumnie (pol.: Atrybut, ang.: Attribute) - nazwa atrybutu.

Dla atrybutów systemowych należy użyć nazw atrybutów ustalonych dla języka polskiego lub angielskiego (nazw wewnętrznych lub nazw zadeklarowanych jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 . Nagłówki).

Rysunek: Arkusz Excel - zestawy atrybutów.


2.6.4 Parametry funkcji przeliczajacych

2.6.4 Parametry funkcji przeliczających

Tabela parametrów funkcji (o ustalonej nazwie - pol.: FunkcjePrzeliczające, ang.: ConversionFunctions) składa się z dwóch kolumn. W pierwszej kolumnie (pol.: Nazwa, ang.: Name) umieszczana jest nazwa funkcji, a w drugiej kolumnie (pol.: Atrybut, ang.: Attribute) - nazwa atrybutu.

Dla atrybutów systemowych należy użyć nazw atrybutów ustalonych dla języka polskiego lub angielskiego (nazw wewnętrznych lub nazw zadeklarowanych jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 .. Nagłówki).

Rysunek: Arkusz Excel - parametry funkcji przeliczających.


2.6.5 Naglowki

2.6.5 Nagłówki

Tabela nagłówków (polska nazwa ustalona tabeli: NagłówkiAtrybutów, angielska: AttributeCaptions) pozwala zdefiniować nagłówki kolumn w oknach wyboru/edycji atrybutów zmiennych. Wszystkie teksty będące nagłówkami zmiennych muszą być unikalne. Nazwa jakiegokolwiek atrybutu nie może być nazwą nagłówka innego atrybutu.

W pierwszej kolumnie tabeli nagłówków (pol.: Nazwa, ang.: Name) należy umieścić nazwy atrybutów - dla atrybutów systemowych należy użyć nazw systemowych atrybutów w języku polskim lub angielskim; dla atrybutów użytkownika należy je podać w takiej formie, w jakiej zostały zdefiniowane w arkuszach zawierających definicje zmiennych.

W drugiej kolumnie (pol.: Język, ang.: Language) umieszczane są kody języków - zgodne z oznaczeniami ISO obsługiwanych języków. Zestawienie wszystkich kodów języków obsługiwanych przez Architekta zawiera Załącznik 3.

Kolumna trzecia (pol.: Nagłówek, ang.: Caption) przeznaczona jest do określania wyświetlanych nazw nagłówków.

Rysunek: Arkusz Excel - nagłówki.


2.6.6 Jezyki atrybutow

2.6.6 Języki atrybutów

Tabela o ustalonej nazwie (pol.: JęzykiAtrybutów, ang.: AttributeLanguages) pozwala określić, w jakim języku zdefiniowano wartości danego atrybutu. Informacja ta potrzebna jest zwykle wyłącznie w aplikacjach wielojęzycznych do podania języka atrybutu-aliasu oraz atrybutów tekstowych do prawidłowego działania edycji i wyświetlania.

W pierwszej kolumnie (pol.: Nazwa, ang.: Name) należy podać nazwy atrybutów (nazwy oryginalne lub nazwy zadeklarowane jako te, które mają się pojawiać w nagłówkach kolumn okna edytora definicji zmiennych, oknie podglądu definicji zmiennych lub oknie wyboru atrybutów - patrz: 2.6.5 Nagłówki .).

W drugiej kolumnie (pol.: Język, ang.: Language) umieszczane są kody języków - zgodne z oznaczeniami ISO obsługiwanych języków.

Na poniższym ekranie zadeklarowano język angielski dla atrybutu Opis_EN, który zawiera angielskie opisy zmiennych. Po zadeklarowaniu atrybutu Opis_EN jako nazwy zastępczej dla atrybutu Opis zmiennej (patrz: 2.6.7 . Atrybuty zastępcze) opisy zmiennych będą pojawiać się, stosowanie do załączonego języka aplikacji, albo w języku polskim albo w języku angielskim.

Rysunek: Arkusz Excel - języki atrybutów.


2.6.7 Atrybuty zastepcze

2.6.7 Atrybuty zastępcze

Definiowanie aliasów stosowane jest dla aplikacji wielojęzycznych, gdzie często zachodzi potrzeba, aby w jednym z języków zamiast pewnego atrybutu, zwanego dalej podstawowym, wyświetlić atrybut zastępczy (alias). Aby osiągnąć ten efekt, należy zdefiniować w bazie oba atrybuty i w tabeli aliasów zadeklarować, który jest atrybutem podstawowym a który zastępczym.

Dla atrybutu podstawowego i zastępczego należy zdefiniować język w tabeli języków - patrz: 2.6.6 . Języki atrybutów.

Aliasy atrybutów muszą zostać określone w tabeli o ustalonej nazwie - pol.: AtrybutyZastępcze, ang.: SubstituteAttributes.

W pierwszej kolumnie (pol.: Nazwa, ang.: Name) powinny znaleźć się atrybuty podstawowe, a w drugiej kolumnie (pol.: NazwaZastępcza, ang.: SubstituteName) odpowiadające im aliasy.

Rysunek: Arkusz Excel - atrybuty zastępcze.


2.6.8 Parametry transformacji nazw atrybutow i wartosci

2.6.8 Parametry transformacji nazw atrybutów i wartości atrybutów

W przypadku generowania baz definicji zmiennych na podstawie definicji zmiennych znajdujących się w arkuszu kalkulacyjnym *.xls dostępny jest mechanizm transformacji nazw atrybutów i wartości atrybutów.

Parametry transformacji, tzn.:

- NazwaŹródłaDanych, AtrybutWejściowy, AtrybutWyjściowy dla transformacji nazw atrybutów

oraz

- NazwaŹródłaDanych, Atrybut, WejściowaWartośćAtrybutu i WyjściowaWartośćAtrybutu dla transformacji wartości atrybutów

należy zadeklarować odpowiednio na zakładkach: PrzekształceniaNazwAtr lub PrzekształceniaWartościAtr źródłowego pliku *.XLS.

Jako NazwaŹródłaDanych należy podać nazwę źródła danych taką jaka pojawia się w Architekcie w tabeli Bazy danych > Baza definicji zmiennych > Źródła danych, kolumnie Nazwa źródła danych. Nazwą tą może być np. nazwa arkusza Excel. Jako AtrybutWejściowy należy podać nazwę istniejącej kolumny. Jako AtrybutWyjściowy należy podać nową nazwę kolumny - nie może już istnieć kolumna o takiej nazwie.

Podanie jako AtrybutWejściowy nazwy pustej powoduje dodanie do źródła danych nowej kolumny.

Podanie jako AtrybutWyjściowy nazwy pustej powoduje usunięcie z źródła danych wskazanej kolumny.

Jako NazwaŹródłaDanych należy wartość jak wyżej. Jako Atrybut należy podać nazwę atrybutu którego wartości mają być przekształcane. Jako WejściowaWartośćAtrybutu należy podać wartość atrybut która ma zostać zmodyfikowana. Jako WyjściowaWartośćAtrybutu należy podać nową wartość atrybutu.

Podanie jako WejściowaWartośćAtrybutu nazwy pustej powoduje dodanie do źródła danych nowej wartości atrybutu.

Podanie jako WyjściowaWartośćAtrybutu nazwy pustej powoduje usunięcie z źródła danych wskazanej wartości atrybutu.

Rysunek: Arkusz Excel - PrzekształceniaNazwAtr.

Rysunek: Arkusz Excel - PrzekształceniaWartościAtr.


2.6.9. Zmeinne używane

2.6.9. Zmienne używane

Arkusz z zestawem zmiennych używanych pozwala zawęzić liczbę zmiennych, których definicje mają być pobrane ze źródeł w trakcie generowania bazy definicji zmiennych.

Ten mechanizm ma zastosowanie głównie podczas generowania zbiorczych baz definicji zmiennych.

Zmienne używane muszą znaleźć się w tabeli (arkuszu) o ustalonej nazwie ZmienneUżywane. Tabela zawierać powinna jedną kolumnę Nazwa.

Zadeklarowanie arkusza (tabeli) ZmienneUżywane jako źródła danych, z którego wygenerowana zostanie baza definicji zmiennych (obok źródeł, z których pobrane zostaną definicje zmiennych) - pozwala kontrolować ilość zmiennych, które mają znaleźć się w bazie.

***

Można również wygenerować z istniejącej bazy definicji zmiennych listę zmiennych używanych przez maski aplikacji. Służy do tego polecenie Generuj listę używanych zmiennych z menu Aplikacja, dostępne w bloku Obszary i komputery.


2.6.10. Szablon bazy definicji zmiennych

Architekt ułatwia przygotowanie pliku Excel z definicjami zmiennych, dając możliwość wygenerowania szablonowego skoroszytu zawierającego wybrane arkusze używane do wygenerowania bazy definicji zmiennych.

Wygenerowanie szablonu definicji zmiennych w pliku Excel:

1. Przejdź do:

Baza definicji zmiennych > zakładka Szablon (przy załączonym typie standardowej bazy definicji zmiennych systemu Asix tworzonej w trybie Generatora)

2. Zaznacz arkusze, które mają się pojawić w szablonie

3. Kliknij przycisk Utwórz...


2.6.11. Szablony wartosci atrybutow

2.6.11. Szablony wartości atrybutów

Przy generowaniu bazy dla pojedynczej bazy definicji zmiennych można wykorzystać transformację wartości atrybutów do zebrania w jednym miejscu często powtarzających się wartości atrybutów. Na przykład można podać dla każdej zmiennej jako parametry archiwizacji identyfikatory 'ArchiwizacjaPLC' lub 'ArchiwizacjaScript'. Następnie w tabeli transformacji wartości atrybutów podać, że 'ArchiwizacjaPLC' ma być zamieniana np. na D, 1s,,1s a 'ArchiwizacjaScript' na D, 10s,,10s.


2.6.12. Edycja atrybutów bazy definicji zmiennych przy użyciu dodatku Asix Architekt Plugin

2.6.12. Edycja atrybutów bazy definicji zmiennych z wykorzystaniem dodatku Asix Architekt Plugin

Dodatek Asix Architekt Plugin dedykowany arkuszowi kalkulacyjnemu MS Excel 2010 daje możliwość edytowania atrybutów definicji zmiennych przy użyciu tych samych edytorów, które dostępne są w przypadku edycji definicji zmiennych w bazie tworzonej w trybie Edytora - czyli bezpośrednio w programie Architekt (Typ bazy definicji zmiennych > Standardowa baza definicji zmiennych > Tryb Edytor).

Lista atrybutów, które mogą być definiowane w arkuszu kalkulacyjnym MS Excel przy pomocy wspomnianych edytorów, obejmuje: Adres, Kanał, Funkcja przeliczająca, Archiwum, Parametry archiwizacji oraz limity.

Opcja Napraw arkusz usuwa z arkusza formatowanie komórek znajdujących się poza obszarem danych.

Dodatek Asix Architekt Plugin dostępny jest od wersji 7.0.0. pakietu Asix. Jego instalacja odbywa się w trakcie instalacji pakietu Asix (jeśli na komputerze zainstalowany jest 32-bitowy MS Office 2010). Po zainstalowaniu pakietu Asix instalację Asix Architekt Plugin można przeprowadzić (np. po aktualizacji Office'a do wymaganej wersji) przy użyciu Menedżera pakietów Asix (Architekt > menu Narzędzia).

UWAGA:

Dodatek Asix Architekt Plugin podpisany jest cyfrowo certyfikatem firmy Askom. Przy niektórych konfiguracjach komputerów, które nie posiadają dostępu do Internetu a tym samym do serwera weryfikacji certyfikatów, system Windows długo próbuje zweryfikować certyfikat programu - przez co znacznie wydłuża start programu MS Excel. W takim przypadku rozwiązaniem problemu jest utworzenie dla programu MS Excel pliku konfiguracyjnego o nazwie "Excel.exe.config" i umieszczenie go w katalogu instalacyjnym pakietu Microsoft Office, w którym znajduje się plik wykonywalny Excel.exe.

Gotowy plik Excel.exe.config można pobrać z witryny internetowej firmy Askom:

http://www.asix.com.pl/pl/do_pobrania/software/

W przypadku systemu operacyjnego Windows Vista lub nowszego, aby wgrać plik do katalogu zawierającego program Excel.exe, konieczne jest posiadanie praw administratora.

Rys. Arkusz kalkulacyjny MS Excel - widok zakładki zainstalowanego dodatku Asix Architekt Plugin.


2.7 Przechowywanie opisow stanow zmiennych w bazie definicji

2.7 Przechowywanie opisów stanów zmiennych w bazie definicji zmiennych

W programie AsTrend5 istnieje możliwość wyświetlania opisów stanów jako etykiet osi wartości dla wykresów fizycznych.

Mechanizm wyświetlania wartości stanów wymaga zadeklarowania zmiennych, które będą odpowiadać stanom zmiennych monitorowanych. W tym celu należy w pierwszej kolejności odpowiednio przygotować bazę definicji zmiennych - tak aby znalazły się w niej atrybuty obsługujące definicje stanów. Są to następujące atrybuty:

Nazwy stanów - nazwa zbioru stanów lub bezpośrednio zbiór opisów stanów zmiennej wg formatu:

<wartość_stanu_0>=<opis_stanu_0>;<wartość_stanu_1>=<opis_stanu_1>;..itd.

Zestaw stanów - nazwa zbioru stanów, do którego należy bieżący wiersz; atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów;

Wartość stanu - wartość wyrażona w systemie dziesiętnym dla stanu, którego opis zawiera bieżący wiersz; atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów zmiennej.

Należy zdefiniować tyle zmiennych, ile jest stanów danej zmiennej monitorowanej. Każda taka zmienna musi mieć zadeklarowany tekst, który będzie wyświetlany dla danego stanu, wartość stanu oraz nazwę zestawu stanów. Zmienne te powinny mieć włączony atrybut Zmienna nieaktywna.

Wszystkie zmienne z tekstami stanów należy powiązać ze zmienną monitorowaną za pomocą wspólnej nazwy zestawu stanów - którą dla zmiennej monitorowanej należy zadeklarować jako wartość atrybutu Nazwy stanów, a dla zmiennych z tekstami stanów jako wartość atrybutu Zestaw stanów. Teksty, które mają być wyświetlane na osi wartości wykresu należy zapisać jako wartości atrybutu Opis dla poszczególnych zmiennych odpowiadających wartościom stanów zmiennej monitorowanej.

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów.

Dodatkowo opis stanów dla zmiennych monitorowanych wyświetlany jest na etykietach i w polu pojawiającym się po kliknięciu wybranego punktu linii wykresu.

uwaga Przy dodawaniu zmiennych z bazy definicji zmiennych aplikacji Asixa oraz przy dodawaniu zmiennych zewnętrznych sprawdzane jest, czy zmienna ma zdefiniowane opisy stanów - jeśli tak, załączana jest aproksymacja schodkowa dla danej zmiennej.


2.8. Przechowywanie opisów stanów bitów oraz opisów bitów w bazie definicji zmiennych

2.8 Przechowywanie opisów stanów bitów w bazie definicji zmiennych

I PRZYPADEK - OPISY STANÓW BITÓW POCHODZĄ Z JEDNEJ ZMIENNEJ

Mechanizm wyświetlania wartości stanów bitów wymaga zadeklarowania zmiennych, które będą odpowiadać poszczególnym bitom zmiennej monitorowanej. W tym celu należy w pierwszej kolejności odpowiednio przygotować bazę definicji zmiennych - tak aby znalazły się w niej atrybuty obsługujące definicje stanów bitów. Są to następujące atrybuty:

Nazwy stanów - nazwa zbioru stanów (dla wiersza definicji zmiennej, której bity będą wyświetlane) lub opisy stanów bitów zmiennej (dla wierszy poszczególnych bitów);

Zestaw stanów - nazwa zbioru bitów, do którego należy bieżący wiersz; atrybut używany tylko dla wierszy poszczególnych bitów;

Wartość stanu - numer bitu, którego opis zawiera bieżący wiersz; atrybut używany tylko dla wierszy poszczególnych bitów.

Należy zdefiniować tyle zmiennych, ile jest bitów danej zmiennej monitorowanej. Każda taka zmienna musi mieć zadeklarowany tekst, który będzie wyświetlany dla danego stanu, wartość stanu oraz nazwę zestawu stanów. Zmienne te powinny mieć włączony atrybut Zmienna nieaktywna.

Wszystkie bity z tekstami stanów należy powiązać ze zmienną monitorowaną za pomocą wspólnej nazwy zestawu stanów - którą to nazwę dla zmiennej monitorowanej należy zadeklarować jako wartość atrybutu Nazwy stanów, a dla zmiennych z tekstami stanów bitów jako wartość atrybutu Zestaw stanów. Teksty, które mają być wyświetlane na osi wartości wykresu należy zapisać jako wartości atrybutu Nazwy stanów dla zmiennych odpowiadających poszczególnym bitom zmiennej monitorowanej, wg. formatu:

0=<opis stanu>;1=<opis stanu>

Natomiast atrybut Wartość stanu określa numer bitu zmiennej monitorowanej.

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów bitów.

II PRZYPADEK - OPISY STANÓW BITÓW POCHODZĄ Z RÓŻNYCH ZMIENNYCH DWUSTANOWYCH

Mechanizm wyświetlania wartości stanów bitów zmiennych dwustanowych nie wymaga deklarowania dodatkowych zmiennych. Atrybutem obsługującym definicje stanów bitów jest w tym przypadku atrybut:

Nazwy stanów - zawierający opisy stanów zmiennej wg. formatu:

0=<opis stanu>;1=<opis stanu>

Rysunek: Definicje atrybutów wykorzystywanych do wyświetlania opisów stanów bitów zmiennych dwustanowych.


2.9. Konwertowanie bazy definicji zmiennych z formatu Paradox na

2.9 Konwertowanie bazy definicji zmiennych z formatu Paradox na format Jet lub MS SQL

Architekt stwarza możliwość przekonwertowania wszystkich danych z bazy definicji zmiennych BDE utworzonej w starszej wersji pakietu Asix (baza w formacie Paradox) do bazy Jet lub SQL.

Dla starszych wersji systemu Asix baza definicji zmiennych w formacie Paradox składa się z:

- bazy atrybutów zmiennych - fizycznie pliki bazy Paradox;

- schematu bazy definicji zmiennych - plik *.TXT opisujący wszystkie atrybuty jakie może posiadać zmienna;

- zestawu zmiennych - plik tekstowy *.ZEZ zawierający definicję ułożenia grup zmiennych (jedna baza definicji zmiennych może zawierać dowolną ilość zestawów zmiennych).

Zasadniczo wskazane było przy tego typu bazach przygotowywanie definicji zmiennych w arkuszu kalkulacyjnym Excel, w oparciu o który następnie generowana była baza definicji zmiennych przy użyciu programu Menedżer Bazy Zmiennych. W przypadku mniejszych aplikacji - bazy definicji zmiennych bezpośrednio tworzone były i edytowane za pomocą programu Edytor Bazy Zmiennych.

Jak przekonwertować bazę definicji zmiennych formatu Paradox utworzoną w starszych wersjach asixa na bazę Jet lub MS SQL?:

I przypadek, kiedy baza definicji zmiennych tworzona była bezpośrednio za pomocą Edytora Bazy Zmiennych (z pominięciem pliku *.XLS)

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia Nazwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki ZEZ/DB (przycisk zez)

4. W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

Rysunek: Okno wyboru tabel do konwersji bazy na format Jet lub MS SQL.

5. Wybierz polecenie Generuj generuj.

6. Otwórz bazę i w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; zmodyfikuj w miarę potrzeby schemat bazy definicji zmiennych za pomocą Edytora schematu.

uwaga Edycja zawartości bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor.

II przypadek, kiedy baza definicji zmiennych generowana była za pomocą Menedżera Bazy Zmiennych w oparciu o definicje zmiennych przygotowane w arkuszu kalkulacyjnym Excel

Założenie: po konwersji bazy definicje zmiennych i schemat bazy będą mogły być aktualizowane z arkuszy Excel zgodnych z obowiązującym dla Asix 5-6 szablonem.

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki ZEZ/DB (przycisk zez)

4. W oknie ’Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

5. Wybierz polecenie Generuj generuj, a następnie otwórz bazę i sprawdź, czy baza została prawidłowo wygenerowana; w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; wprowadź również zmiany (jeśli istnieje taka potrzeba) do schematu bazy definicji zmiennych za pomocą Edytora schematu

uwaga Edycja bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor (baza musi być zamknięta w trakcie zmiany trybów)

7. Zamknij bazę i przejdź na tryb edytora:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor

8. Ponownie otwórz wygenerowaną bazę definicji zmiennych i wyeksportuj ją do arkusza Excel za pomocą komendy Eksportuj eksportuj. W oknie ’Eksport bazy do Arkusza Excel’ wybierz wszystkie dostępne rodzaje danych do eksportu i zmień nazwę pliku wyjściowego na Schemat.xls (nazwa dowolna); zatwierdź zmiany przyciskiem OK.

Rysunek: Okno ’Eksport bazy do arkusza Excel’.

9. Zamknij bazę.

10. Otwórz skoroszyt Schemat.xls;

W arkuszu AtrybutyGrupujące znajdują się atrybuty grupujące, które należy ’ręcznie’ dodać do definicji zmiennych przechowywanych w skoroszycie Excel służącym do tej pory jako źródło generowania i aktualizowania bazy definicji zmiennych formatu Paradox.

W starszych wersjach asixa w bazie definicji zmiennych istniała możliwość zadeklarowania dla każdej zmiennej wyłącznie jednego atrybutu grupującego o ustalonej nazwie Grupa. Możliwe było jednak ułożenie grup zadeklarowanych w atrybucie Grupa w strukturę hierarchiczną typu drzewo wyświetlaną w oknie wyboru zmiennych - co pozwalało ’widzieć’ daną zmienną jako element przynależny do określonej grupy lub podgrupy. Patrz: Rysunek: Okno listy zmiennych w pakiecie asix4.

Rysunek: Okno listy zmiennych w pakiecie asix4.

Definicję ułożenia grup zmiennych zawierał plik *.ZEZ.

Aktualnie w trakcie konwersji bazy definicji zmiennych Paradox na format Jet lub MS SQL generowanych jest tyle atrybutów grupujących, ile wynika to ze struktury hierarchicznej zdefiniowanej w pliku *.ZEZ. Patrz: Rysunek: Edytor definicji zmiennych - okno grupowania zmiennych.

Rysunek: Edytor definicji zmiennych - okno grupowania zmiennych.

11. Otwórz skoroszyt, który do tej pory stanowił plik źródłowy do generowania/aktualizowania bazy definicji zmiennych Paradox i do wszystkich arkuszy z definicjami zmiennych dodaj kolumny atrybutów grupujących wygenerowanych w skoroszycie Schemat.xls

Dla każdej definicji zmiennych dodaj wartości atrybutów grupujących kopiując je z arkusza Zmienne pliku Schemat.xls, pamiętając o usunięciu starego atrybutu Grupa.

Tak zmodyfikowane arkusze z definicjami zmiennych mogą służyć jako źródło generowania/aktualizowania bazy definicji zmiennych Jet lub MS SQL.

13. Usuń ze skoroszytu Schemat.xls arkusz Zmienne.

Pozostałe zakładki zawierają przetłumaczone na język narodowy nazwy atrybutów zmiennych, deklaracje atrybutów zastępczych (dla aplikacji wielojęzycznych), definicje zestawów atrybutów, atrybutów grupujących - czyli wszystkie te informacje, które do tej pory w większości przechowywane były w pliku tekstowym Schemat.txt.

Plik Schemat.xls może odtąd stanowić źródło aktualizacji danych dostępnych w Architekcie z poziomu Edytora schematu modułu Baza definicji zmiennych.

14. Przejdź na tryb generatora:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Generator

15. Na zakładce Źródła danych zaznacz i usuń wszystkie źródła danych.

16. Naciśnij przycisk Excel i wskaż plik *.xls zawierający definicje zmiennych.

17. W oknie ’Wybierz tabele’ zaznacz wszystkie arkusze z definicjami zmiennych i zatwierdź wybór przyciskiem OK.

18. Na zakładce Źródła danych ponownie naciśnij przycisk Excel i wskaż plik *.xls z danymi schematu bazy definicji zmiennych, czyli plik Schemat.xls.

19. W oknie ’Wybierz tabele’ zaznacz wszystkie arkusze i zatwierdź wybór przyciskiem OK.

20. Wybierz polecenie Generuj generuj, a następnie otwórz bazę i sprawdź, czy baza została prawidłowo wygenerowana; wszelkie dane do aktualizacji bazy mogą być wprowadzane do plików *.xls, które przygotowane zostały w poprzednich krokach - każdorazowa zmiana w tych plikach wymaga ponownego wygenerowania bazy.


2.10. Konwertowanie bazy definicji zmiennych z plikow tekstowych

2.10 Konwertowanie bazy definicji zmiennych z plików tekstowych na format Jet lub SQL

Dla zachowania kompatybilności ze starszymi wersjami systemu A six, Architekt pozwala również zaimportować dane definicji zmiennych znajdujące się w plikach tekstowych.

Jak przekonwertować bazę definicji zmiennych z plików tekstowych na bazę Jet lub MS SQL?:

1. Zdefiniuj typ bazy definicji zmiennych jako Tryb Generator

2. Określ format oraz nazwę bazy definicji zmiennych, która ma zostać wygenerowana:

Baza definicji zmiennych > zakładka Format > format bazy danych ustawiony na: Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 lub Plik w formacie Mdb (Jet/Microsoft Access)

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

3. Określ źródło danych:

Baza definicji zmiennych > zakładka Źródła danych > wskaż pliki tekstowe definicji zmiennych (przycisk przycisk - asix pliki etkstowe)

4. W oknie 'Wybierz tabele’ wskaż wszystkie pozycje i zatwierdź przyciskiem OK.

5. Wybierz polecenie Generuj generuj.

6. Otwórz bazę i w razie potrzeby wprowadź zmiany do atrybutów zmiennych przy użyciu Edytora definicji zmiennych; zmodyfikuj w miarę potrzeby schemat bazy definicji zmiennych za pomocą Edytora schematu.

uwaga Edycja bazy możliwa jest po przejściu na tryb Edytor:

Baza definicji zmiennych > zakładka Typ > opcja Tryb Edytor.


2.10.1. Import definicji zmiennych z plikow tekstowych - atrybuty grupujace

2.10.1. Import definicji zmiennych z plików tekstowych - atrybuty grupujące

Wartość pierwszego atrybutu grupującego zmiennej, jest domyślnie taka sama jak nazwa pliku zmiennych bieżących, w którym zdefiniowana jest zmienna (nazwa pliku bez rozszerzenia i bez ścieżki). Aby jawnie określić wartości atrybutów grupujących zmiennej, należy umieścić w pliku definicji zmiennych bieżących, w postaci komentarza, linie deklarujące wartości atrybutów grupujących. Linia deklarująca wartości atrybutów grupujących jest linią o następującym formacie:

#Atrybuty : Atrybut1 = Wartość1 [,Atrybut2 = Wartość2...]

lub

#Attributes : Atrybut1 = Wartość1 [,Atrybut2 = Wartość2...]

Deklaracja rozpoczyna się od miejsca deklaracji i rozciąga się do następnej deklaracji lub do końca pliku.


2.11 Export bazy do arkusza Excel

2.11 Eksport bazy do arkusza Excel

Program Architekt umożliwia zapisanie wszystkich danych lub wybranych danych z bazy definicji zmiennych w arkuszu Excel. Dane są zapisane w jednym lub kilku arkuszach. Można ograniczać maksymalną liczbę wierszy w jednym arkuszu tak, aby istniała możliwość eksportowania również dużych baz definicji zmiennych. Dodatkowo w skoroszycie umieszczany jest arkusz z listą modyfikacji definicji zmiennych od chwili utworzenia bazy. Lista ta zawiera zmienne utworzone, usunięte i zmodyfikowane. Maksymalna liczba eksportowanych wierszy to 32000.

Jak wyeksportować definicje zmiennych do arkusza Excel?:

1. Otwórz bazę definicji zmiennych MSQL (lub Jet), podając jej lokalizację w:

Baza definicji zmiennych > zakładka Format

oraz klikając na komendę Otwórz otwórz z kategorii poleceń Baza definicji zmiennych.

2. Wybierz komendę Eksportuj eksportuj.

3. W oknie ’Eksport bazy do arkusza Excel’ zaznacz dane, które mają być wyeksportowane oraz ścieżkę i nazwę docelowego pliku XLS (Patrz: Rysunek: Okno 'Eksport bazy do arkusza Excel'.).

Rysunek: Okno 'Eksport bazy do arkusza Excel'.


2.12 Dostep z poziomu innych programow

2.12 Dostęp z poziomu innych programów

Baza definicji zmiennych jest bazą zarządzaną przez Microsoft SQL Server lub bazą Jet i dostęp do niej jest możliwy z każdego programu, który obsługuje ten system.

W dostępie do danych przechowywanych w bazie definicji zmiennych VarDef pośredniczy moduł AsixConnect za pomocą mechanizmu DDE, Automation lub .NET.


2.13. Uaktualnianie bazy zmiennych on-line

2.13 Uaktualnianie bazy definicji zmiennych on-line

W przypadku, gdy niemożliwe jest zatrzymanie aplikacji i jej restart w celu zmodyfikowania bazy definicji zmiennych, możliwe jest przeprowadzenie aktualizacji bazy w trybie on-line. Operacja taka jest możliwa jedynie, gdy zadeklarowany typ bazy definicji zmiennych to Standardowa baza definicji zmiennych, tryb “Edytor”.

Zakładając, że używając edytora bazy zmiennych dokonano jej modyfikacji (zmieniono definicje zmiennych, dodano nowe zmienne itp.), należy użyć przycisku z niebieskim trójkątem - [image] Aktualizuj on-line.

Rysunek: Okno dialogowe akceptacji operacji pobrania przez Asix ostatnich modyfikacji z bazy definicji zmiennych.

Po potwierdzeniu chęci aktualizacji bazy on-line system Asix przeprowadzi ją, a w Panelu Kontrolnym pojawi się odpowiedni komunikat, podający liczbę zmodyfikowanych rekordów bazy oraz nazwy zmiennych:

Rysunek: Panel Kontrolny z informacja o odczycie przez asixa aktualizacji z bazy definicji zmiennych.

UWAGA: W sytuacji, gdy definicje zmiennych przechowywane są w arkuszach kalkulacyjnych (w nich wprowadzane były aktualizacje tych definicji), na podstawie których generowana jest baza definicji zmiennych – przejście na tryb aktualizacji bazy za pomocą edytora bazy definicji zmiennych spowoduje, że źródłowe arkusze kalkulacyjne nie będą uwzględniały zmian wprowadzonych za pomocą edytora.


3. Baza definicji alarmów - konfiguracja

3. Baza definicji alarmów

Dla systemu Asix w wersji klasycznej

Definicje alarmów standardowo znajdują się w pliku tekstowym alarm.def (lub <nazwa_pliku_XML_aplikacji>.adf). Możliwe jest użycie pliku o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów przy założeniu, że tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów). Opisy alarmów mogą się też znajdować w kilku plikach definicji. Wewnętrznie alarmy identyfikowane są przez numer. Można zdefiniować 65535 różnych alarmów. Nie istnieje konieczność sekwencyjnego numerowania alarmów. Na przykład, numeracja jednej grupy alarmów rozpoczyna się od numeru 1000, a drugiej (o innym pochodzeniu) od numeru 30000. Należy pamiętać o tym, że zmiana numeracji alarmów w już działającym systemie powoduje konieczność skasowania plików archiwalnych.

Definicje grup alarmów standardowo znajdują się w pliku tekstowym group.def (lub <nazwa_pliku_XML_aplikacji>.gdf). Możliwe jest użycie pliku (plików) o innej nazwie poprzez zdefiniowanie parametru Nazwy plików (konfiguracja pliku xml aplikacji przy użyciu programu Architekt: Architekt > Obszary i komputery > moduł System alarmów > zakładka Alarmy / Baza definicji alarmów - grupy przy założeniu, ze tryb pracy bazy definicji alarmów oparty jest na tekstowych plikach definicji alarmów: Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tryb pracy bazy definicji alarmów: Baza definicji alarmów jest generowana z tekstowych plików definicji alarmów).

Patrz więcej:

'Asix - funkcjonalność i zasady działania', rozdz. '12. System alarmów';

'Moduł Architekt - Interaktywne środowisko konfigurowania aplikacji systemu Asix. Obsługa baz definicji zmiennych VarDef', rozdz. '4.9. Konfiguracja systemu alarmów'.

Dla systemu Asix w wersji Evo

Informacje na temat definicji alarmów i przechowywane są standardowo w pliku XML aplikacji.

Patrz więcej:

'Asix.Evo - System alarmów' (PDF/CHM).

***

Na potrzeby programu AsAlarm, AsTrend oraz środowiska projektowania raportów opartym na usługach Reporting Services firmy Microsoft (w systemie Asix nazywany systemem raportowania AsRaport) wymagane jest pobieranie definicji alarmów z bazy definicji zmiennych w formacie MS SQL lub MDB. W praktyce wymaga to odpowiedniego skonfigurowania bazy definicji alarmów i dołączenia definicji alarmów do istniejącej bazy definicji zmiennych, co zostało omówione w kolejnych rozdziałach. Dotyczy to zarówno aplikacji systemu Asix wersji klasycznej jak i wersji Evo.


Zbiorcza baza definicji alarmów generowana z wielu aplikacji

3.1. Zbiorcza baza definicji alarmów generowana z wielu aplikacji (Asix klasyczny)

Generator zbiorczej bazy definicji alarmów i grup alarmów utworzy zbiorcza bazę definicji alarmów na podstawie źródeł zdefiniowanych we wskazanych aplikacjach. Wygenerowana baza zostanie dołączona do bazy definicji zmiennych aktualnie parametryzowanej aplikacji.

Aby wygenerować zbiorczą bazę definicji alarmów z wielu aplikacji:

1. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Zbiorcza baza definicji alarmów generowana z wielu wybranych aplikacji

2. Dodaj źródła danych:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: pliki INI lub XML

3. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów z wielu aplikacji do istniejącej bazy definicji zmiennych parametryzowanej aplikacji):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rys. Rysunek: Architekt - generator zbiorczej bazy definicji alarmów i grup alarmów.


Baza definicji alarmów generowana z arkuszy kalkulacyjnych

3.2. Baza definicji alarmów generowana z arkuszy kalkulacyjnych (dla aplikacji Asixa klasycznego)

Aby dołączyć definicje alarmów i definicje grup alarmów z arkusza kalkulacyjnego do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w arkuszu Excel

UWAGA: Przyłączenie definicji alarmów do bazy definicji zmiennych wymaga utworzenia arkusza programu Excel z definicjami alarmów oraz drugiego arkusza z definicjami grup alarmów wg określonego szablonu. Szablon taki można wygenerować z Architekta: Bazy danych > Baza definicji alarmów > zakładka Szablon - dostępna przy zaznaczonym typie pracy bazy definicji alarmów, który zakłada generowanie bazy definicji alarmów z arkuszy kalkulacyjnych.

W przypadku posiadania definicji alarmów w plikach tekstowych - można albo wygenerować bazę definicji alarmów bezpośrednio na podstawie tekstowych plików definicji alarmów i grup alarmów (patrz: rozdział 3.3. Baza definicji alarmów generowana z plików tekstowych (dla aplikacji Asixa klasycznego) albo dokonać ich konwersji do arkusza Excel wg poniższych kroków:

- uruchomić program Microsoft Excel,

- wybrać menu Dane->Z tekstu,

- zmienić ‘pliki typu’ na ‘wszystkie pliki’, następnie otworzyć plik definicji (.adf lub .gdf),

- wybrać typ pliku ‘rozdzielny’, pochodzenie pliku: 1250 Europa środkowa (Windows), przejść dalej,

- z listy ograniczników wybrać przecinek i wybrać polecenie Zakończ.

2. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Baza definicji alarmów jest generowana z arkuszy kalkulacyjnych zawierających definicje alarmów

powiększ >>

Rysunek: Architekt - deklaracja dodania bazy definicji alarmów i grup alarmów do bazy definicji zmiennych.

3. Dodaj arkusze Excel z definicjami alarmów i definicjami grup alarmów do źródeł danych bazy definicji alarmów:

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcje: Dodaj źródło danych: Excel

4. Zadeklaruj, że baza definicji alarmów ma zostać dołączona do istniejącej bazy definicji zmiennych

Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja: Dodaj bazę definicji alarmów do bazy definicji zmiennych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.

UWAGA: Każda aktualizacja bazy definicji zmiennych (jej ponowna generacja) wymaga ponownego dogenerowania definicji alarmów i grup alarmów do bazy definicji zmiennych przy użyciu polecenia:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj


Baza definicji alarmów generowana z plików tekstowych (dla aplikacji Asixa klasycznego)

3.3. Baza definicji alarmów generowana z plików tekstowych (Asix klasyczny)

Dla aplikacji Asixa klasycznego definicje alarmów standardowo przechowywane są w plikach tekstowych .adf (lub alarm.def), a definicje grup alarmów w plikach tekstowych .gdf (lub group.def).

Aby dołączyć definicje alarmów i definicje grup alarmów z plików tekstowych do bazy definicji zmiennych:

1. Przygotuj definicje alarmów w plikach tekstowych.

Informacje na temat tego, jak należy utworzyć takie pliki można znaleźć w podręczniku: Asix.PDF/CHM, 12. System alarmów.

2. Zadeklaruj nazwy plików, o których mowa w punkcie 1 w module:

Architekt > Obszary i komputery > System alarmów > Alarmy > zakładki Baza definicji alarmów / Baza definicji alarmów - grupy

3. Ustaw odpowiedni tryb pracy bazy definicji alarmów:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Typ > opcja Tekstowe pliki definicji alarmów ...

powiększ >>

Rysunek: Architekt - deklaracja trybu pracy bazy definicji alarmów.

3. Wybierz obszar/komputer, dla którego zostały zadeklarowane pliki tekstowe, o czym mowa w punkcie 2. Spowoduje to automatyczne załadowanie plików definicji alarmów i grup alarmów do okna generatora:

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Obszar/komputer

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rysunek: Architekt - generator bazy definicji alarmów i grup alarmów.


Baza definicji generowana z arkuszy kalkulacyjnych w formacie Asix.Evo

3.4. Baza definicji alarmów generowana na podstawie alarmów SQL (Asix klasyczny i Evo)

Generowanie bazy definicji alarmów na podstawie alarmów SQL aplikacji Asixa wersji Evo dotyczy przypadku, kiedy informacje o wszystkich zdarzeniach alarmowych przechowywane są nie tylko w logach alarmów historycznych, ale również jako uzupełnienie w archiwum alarmów typu SQL. Identycznie jest w przypadku aplikacji klasycznych - gdzie oprócz archiwów przechowywanych w plikach dyskowych może być prowadzona również archiwizacja w bazie MS SQL. Generator bazy definicji alarmów SQL w programie Architekt na podstawie archiwum zdarzeń przechowywanych w bazie SQL generuje bazę definicji alarmów dołączaną do bazy definicji zmiennych załadowanej w Architekcie aplikacji.

Sposób konfigurowania rejestracji zdarzeń alarmowych w bazie SQL dla aplikacji klasycznej omawia rozdział 4.9.11. Baza zdarzeń alarmów.

Sposób konfigurowania rejestracji zdarzeń alarmowych w bazie SQL dla aplikacji Evo omawia podręcznik 'Asix.Evo - System alarmów', rozdział 8.1. Archiwum alarmów SQL.

Aby dołączyć definicje alarmów SQL do bazy definicji zmiennych:

1. Określ źródło definicji alarmów: (może to być katalog aplikacji Asixa w wersji Evo, pliki xml aplikacji Asixa klasycznego, pliki ini aplikacji starszych wersji Asixa klasycznego lub bieżąca aplikacja):

Architekt > Bazy danych > Baza definicji alarmów SQL > zakładka Źródła danych > opcja: Dodaj źródło danych

5. Wygeneruj bazę definicji alarmów (operacja ta dołącza definicje alarmów i grup alarmów do istniejącej bazy definicji zmiennych):

Program Architekt > Bazy danych > Baza definicji alarmów > zakładka Źródła danych > opcja Operacje: Generuj.

powiększ >>

Rys. Architekt - Generator bazy definicji alarmów SQL.


4.1 Wstep

4.1 Wstęp

Gotowa aplikacja systemu Asix składa się z zestawu powiązanych ze sobą masek technologicznych, zawierających obiekty statyczne i dynamiczne. Tworzą one spójną całość za pośrednictwem akcji sterujących ich wyświetlaniem. Podstawą działania całego sytemu masek jest plik konfiguracyjny XML, tworzony za pomocą programu Architekt. System masek projektowany jest za pomocą programu AS w trybie Konstruktora. Z kolei gotowa aplikacja realizowana jest przez główny moduł systemu Asix - program AS, pracujący w trybie wykonywania aplikacji.

Rysunek: Widok masek technologicznych aplikacji demonstracyjnego systemu Asix – Fabryka.

Konfiguracja aplikacji systemu Asix przy użyciu programu Architekt obejmuje:

- konfigurację bazy definicji zmiennych (szczegółowo omówiono to zagadnienie w rozdziale 2. Obsługa baz definicji zmiennych aplikacji systemu Asix);

- konfigurację pracy aplikacji.

Uproszczony proces projektowania i realizacji aplikacji w systemie Asix prezentuje poniższy schemat [6].

Rysunek: Schemat procesu projektowania i realizacji aplikacji w systemie Asix.

W trakcie parametryzacji aplikacji Architekt prowadzi na bieżąco kontrolę wzajemnej niesprzeczności zadeklarowanych opcji, co przekłada się na duży wzrost wydajności pracy.

Konfiguracja pracy aplikacji przeprowadzana jest przy użyciu modułów parametrów wyświetlanych podłużnym przyciskiem Obszary i komputery (przycisk znajduje się w lewym bloku okna Architekt).

Rysunek: Okno modułu konfigurowania parametrów aplikacji.

Moduł Architekt pozwala w sposób całkowicie wizualny i interaktywny skonfigurować pracę całej aplikacji systemu Asix. Sprowadza się to do zdefiniowania parametrów potrzebnych do pracy różnych podsystemów programu AS odpowiadających za realizację projektowanej aplikacji.

Wspomniane parametry podzielone zostały w Architekcie na następujące grupy (drzewo parametrów wywoływane jest przyciskiem Aplikacja, znajdującym się w lewym bloku okna Architekt):

- Parametry startowe,

- Maski,

- Dane bieżące,

- Dane bieżące – serwer sieci,

- Dane archiwalne,

- System alarmów,

- Moduł sieci,

- Zabezpieczenia,

- Wydruk,

- Raporty,

- Akcje i terminarze,

- Pozostałe.

Ustawienia parametrów pracy aplikacji zapisywane są w pliku konfiguracyjnym XML, w którym umieszczane są również dane dotyczące bazy definicji zmiennych i bazy definicji alarmów aplikacji.

Szczegóły dotyczące funkcjonalności pakietu Asix (w tym opis poszczególnych etapów projektowania aplikacji z wykorzystaniem pakietu Asix) zawarte są w opracowaniu ”Asix - podręcznik użytkownika”.

Proces projektowania aplikacji, która dołączona została do pakietu Asix jako aplikacja demo - Fabryka, szczegółowo omawia podręcznik ”Pierwsza aplikacja - krok po kroku”.

Niektóre praktyczne przykłady omawiane w podręczniku Architekt odwołują się do wspomnianej powyżej demonstracyjnej aplikacji.

[6] W trakcie realizacji rzeczywistego projektu zwykle nie udaje się ściśle zachować przedstawionej sekwencji operacji. W miarę rozbudowywania aplikacji wielokrotnie trzeba bowiem wracać do wcześniejszych punktów. Schemat daje jednak pewien pogląd na całokształt procesu tworzenia aplikacji.


4.1.1 Wskazowki dotyczace obslugi opcji domyslnych w modulach

4.1.1 Wskazówki dotyczące obsługi opcji domyślnych w modułach konfiguracyjnych

Każda opcja parametryzująca pracę aplikacji posiada zewnętrzny checkbox, znajdujący się z lewej strony opcji, który w odróżnieniu od pól deklarujących wartości parametrów, służy wyłącznie do załączania lub wyłączania ustalonych wartości parametrów.

Parametry posiadające zadeklarowaną wartość domyślną, np. czas, nazwę pliku lub w przypadku parametrów o wartości logicznych zaznaczone pole checkbox, należy uaktywnić załączając je zewnętrznym checkboxem.

Rysunek: Widok załączonej opcji domyślnej.

W trakcie parametryzowania aplikacji należy pamiętać o poniższych zasadach:

- opcje wyłączone są nieedytowalne; dopiero zaznaczenie zewnętrznego pola checkbox pozwala na zmianę wartości parametru;

- w momencie wyłączenia opcji dla Obszaru automatycznie przywracana jest domyślna wartość parametru;

- w momencie kiedy opcja dla Komputera zostanie wyłączona, parametr automatycznie przyjmuje wartość zadeklarowaną dla Obszaru lub (w przypadku braku takiej deklaracji w Obszarze) przywracana jest domyślna wartość parametru.


4.1.2 Zarzadzanie opcjami za pomoca okna z zestawieniem

4.1.2 Zarządzanie opcjami za pomocą okna z zestawieniem wszystkich zadeklarowanych opcji

Wykorzystując okno ’Zarządzanie opcjami’ projektant może w prosty sposób uzyskać dostęp do wszystkich parametrów, jakie zostały ustawione w pliku konfiguracyjnym aplikacji w ramach konfigurowania poszczególnych ’obszarów’ i ’komputerów’.

Wspomniane okno daje wgląd do wartości zdefiniowanych opcji z jednoczesną możliwością wykonania prostych operacji edycyjnych na wybranych opcjach - dostępne są operacje usuwania i kopiowania opcji z/do wybranych obszarów/komputerów (w tym również techniką drag-and-drop).

Dalsza edycja zaznaczonej opcji możliwa jest po naciśnięciu przycisku Przejdź do edytora opcji. Okno zarządzania opcjami zostaje wtedy zamknięte, a Architekt otwiera tę zakładkę modułu konfigurowania parametrów, która umożliwia zmianę wybranej opcji.

Wszystkie opcje wykorzystane do parametryzowania aplikacji wyświetlane są w oknie ’Zarządzanie opcjami’ w postaci zestawienia tabelarycznego w jednym z trzech możliwych do wyboru widoków: Tabela, Drzewo i Drzewo opcji. Okno uruchamiane jest za pomocą komendy Zarządzaj opcjami… z menu Obszary i komputery.

Rysunek: Okno 'Zarządzanie opcjami'.


4.1.3 Importowanie wybranych opcji z zewnetrznego pliku *.xml

4.1.3 Importowanie wybranych opcji z zewnętrznego pliku *.xml

Przygotowując aplikację, projektant ma możliwość importowania ustawień wybranych parametrów z plików *.xml innych aplikacji. Komenda Importuj opcje… z menu Obszary i komputery uruchamia okno ’Importowanie opcji’, które wyglądem przypomina narzędzie zarządzania opcjami pliku konfiguracyjnego projektowanej aplikacji, z tą różnicą, że oglądane parametry pochodzą z pliku *.xml innej aplikacji. Aby zaimportować do swojej aplikacji wartość dowolnego parametru, należy ten parametr zaznaczyć, przycisnąć przycisk Importuj, a następnie wskazać docelowy obszar/komputer.

Rysunek: Okno 'Importowanie opcji'.


4.2 Utworzenie pliku konfiguracyjnego nowej aplikacji

Utworzenie pliku konfiguracyjnego XML aplikacji stanowi pierwszy krok poprzedzający etap konfigurowania bazy definicji zmiennych oraz konfigurowania aplikacji.

uwaga Parametry konfigurujące pracę aplikacji oraz deklarujące bazę danych, w oparciu o którą aplikacja pracuje zapisywane są do jednego wspólnego pliku XML (ang. Extensible Markup Language), umieszczanego w kartotece głównej projektowanej aplikacji.

Tworzenie pliku konfiguracyjnego:

Wariant 1 - bez kreatora

  1. Z menu głównego z pozycji Plik wybierz komendę Nowa aplikacja [image].

  2. W lewym bloku okna Architekta kliknij na przycisk Obszary i komputery.

  3. Na liście komputerów wprowadź następujące zmiany:

    4. - dodaj tyle pozycji komputerów i obszarów, ile wynika z projektu aplikacji - pamiętając, że obszar wspólny zawiera parametry, które w wielostanowiskowej konfiguracji systemu A six są wspólne dla wszystkich stanowisk, na których uruchamiana jest aplikacja; natomiast konfiguracja na poziomie Komputera pozwala zindywidualizować ustawienia w zależności od typu komputera (inne dla stacji operatorskiej, a inne dla dedykowanego serwera danych w sieci zakładowej). Ustawienia na poziomie Komputera są ważniejsze od ustawień na poziomie Obszaru.

    - zmień nazwy komputerów i obszarów na takie, które odpowiadają specyfice środowiska, w którym aplikacja będzie pracowała

  4. Zapisz plik w katalogu projektowanej aplikacji.

Wariant 2 - użycie kreatora

1. Z menu głównego z pozycji Plik wybierz komendę Nowa aplikacja - kreator nowa aplikacja - kreator.

2. W oknie kreatora nowej aplikacji - zakładce Aplikacja określ następujące dane:

- Nazwa pliku aplikacji,

- Katalog aplikacji;

oraz katalogi, których ścieżki są ścieżkami względnymi w odniesieniu do katalogu aplikacji:

- Katalog masek (z możliwością dodania do aplikacji podstawowych masek),

- Katalog archiwum danych,

- Katalog archiwum alarmów,

- Katalog raportów,

- Katalog trendów,

- Katalog roboczy;

Ponadto dostępne są dwa szablony aplikacji zawierające elementy graficzne pozwalające na zaprojektowanie estetycznych masek wizualizacyjnych oraz opcja dodania do aplikacji zestawu klasycznych czcionek (Arial, Sans Serif, Times New Roman).

- wersja STANDARD aplikacji:

Rys. Szablon aplikacji w wersji STANDARD.

- wersja MODERN aplikacji:

Rys. Szablon aplikacji w wersji MODERN.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Aplikacja'.

3. W oknie kreatora nowej aplikacji - zakładce Komputery i obszary określ następujące dane:

- w bloku Parametryzacja wielu stanowisk należy podać rodzaje komputerów, dla których zostaną utworzone zestawy parametrów:

- Stacja operatorska,

- Stacja KE,

- Terminal,

- Serwer sieciowy.

uwaga Nazwy komputerów tworzonych przez kreator dostosowano do konwencji nazw sieciowych – nie zawierają spacji i mają maksymalnie 15 znaków.

uwaga Określenie w tym miejscu wszystkich rodzajów komputerów, dla których kreator automatycznie utworzy zestawy parametrów aplikacji nie jest wymagane - projektant w każdej chwili może zmodyfikować ilość pozycji komputerów/obszarów wyświetlanych w bloku Obszary i komputery.

Poza tym wybór określonego rodzaju komputera nie ma wpływu na ilość i rodzaj parametrów, które znajdą się w zestawie. Dla każdego Obszaru i Komputera udostępniane są wszystkie możliwe do zadeklarowania parametry.

a także:

- Nazwa pliku komunikatów - plik ten zostanie utworzony w katalogu roboczym.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Komputery i obszary'.

4. W oknie kreatora nowej aplikacji - zakładce Zasoby określ następujące dane:

- w bloku Zasoby podstawowe należy zadeklarować następujące elementy:

- Nazwa kanału zmiennych systemowych,

- Nazwa archiwum danych w sieci,

- Nazwa serwera alarmów w sieci;

- w bloku Kanały fizyczne należy zadeklarować kanały fizyczne, które zostaną utworzone w zadeklarowanych stacjach operatorskich.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'Komputery i obszary'.

5. W oknie kreatora nowej aplikacji - zakładce VarDef - typ określ typ bazy definicji zmiennych.

W przypadku zadeklarowania opcji Tryb Generator dopiero po utworzeniu pliku konfiguracyjnego aplikacji będzie można zadeklarować pliki źródłowe z definicjami zmiennych i wygenerować na ich podstawie bazę.

Wprowadzone zmiany zatwierdź przyciskiem OK.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'VarDef - typ'.

uwaga W przypadku wybrania opcji Tryb Generator i formatu bazy - Baza danych serwera Microsoft SQL Serwer 2000/2005/2008 -

przed przystąpieniem do generowania pliku aplikacji za pomocą kreatora, łącznie z generowaniem bazy definicji zmiennych w formacie SQL, na komputerze powinien zostać zainstalowany serwer SQL. Pakiet systemu asix zawiera MSDE 2000 (Microsoft SQL Server 2000 Desktop Engine), ktory stanowi uproszczoną wersję SQL Server 2000. Dostarczana przez firmę Askom wersja MSDE jest przeznaczona tylko do stosowania z produktami firmy Askom. Sposób instalacji MSDE 2000 został omówiony w opracowaniu: ”MSDE 2000 - instrukcja instalacji. Pomoc techniczna”, do pobrania z witryny ASKOM (www.asix.com.pl) z działu 'wsparcie techniczne' > 'porady/instrukcje'.

6. W oknie kreatora nowej aplikacji - zakładce VarDef - format i położenie określ format oraz nazwę bazy definicji zmiennych.

W przypadku baz danych MS SQL wymagane jest określenie parametrów:

- Nazwa serwera;

- Nazwa bazy;

- Katalog bazy;

- Tryb uwierzytelniania:

- Windows,

- Serwer MSQL - wymaga określenia N azwy użytkownika oraz Hasła.

Rysunek: Kreator pliku konfiguracyjnego oraz struktury katalogów nowej aplikacji - zakładka 'VarDef - format i położenie'.

uwaga Kreator aplikacji tworzy domyślnych użytkowników: Administratora oraz Operatora z uprawnieniami 1 poziomu. Automatycznie tworzony jest również kanał NONE oraz 2 zmienne w bazie definicji zmiennych: __USERNAME__ i __USERLEVEL__. Kreator aplikacji zakłada również katalog plików trendów i ustawia ten katalog jako roboczy dla programu AsTrend.


4.2.1. Kreator nowej aplikacji w trybie importu bazy z serwera OPC

Utworzenie pliku konfiguracyjnego XML aplikacji w trybie importu bazy z serwera OPC zakłada zaimportowanie definicji zmiennych z bazy serwera OPC do formatu bazy systemu A six. W tym celu należy użyć kreatora aplikacji wywoływanego poleceniem Nowa aplikacja - kreator OPC z menu Plik.

Okno kreatora obejmuje ustawienia podstawowych parametrów aplikacji takich jak: lokalizacja aplikacji, struktura katalogów, plik logu, struktura komputerów/obszarów, format i położenie bazy definicji zmiennych. Dodatkowe informacje dotyczą źródła danych OPC oraz ustawień związanych z importem zmiennych z serwera OPC.

Zakładki Aplikacja, Komputery i obszary, VarDef - format i położenie zawierają parametry identyczne jak w przypadku standardowego kreatora aplikacji - patrz: 3.2 Utworzenie pliku konfiguracyjnego nowej aplikacji.

Zakładka Źródło danych OPC wymaga podania następujących parametrów:

- Identyfikator serwera OPC w systemie Windows;

- Nazwa zdalnego serwera;

- Nazwa kanału OPC.

Rysunek: Kreator aplikacji - Źródło danych OPC.

Zakładka VarDef - OPC obejmuje deklarację następujących parametrów:

- Określenie nazw zmiennych importowanych z serwera OPC – nazwy pobierane z Sewera OPC; w przypadku niezgodności ze standardem Asixa nazwy generowane są na podstawie zadeklarowanego prefiksu i kolejnych liczb dodawanych na końcu.

- Liczba Elementów – wartość atrybutu dla zmiennych skalarnych ustawiana na 1. Dla zmiennych tekstowych / tablicowych należy wprowadzić ręcznie długość tekstu/rozmiar tablicy, ponieważ serwer OPC nie udostępnia tych informacji.

- Plik wyjściowy – zostanie wygenerowany skoroszyt o zadeklarowanej nazwie z arkuszem definicji zmiennych pobranych z serwera OPC; plik zostanie automatycznie zadeklarowany w źródle danych zawierającym definicje zmiennych dla aplikacji (Architekt > Bazy danych > Baza definicji zmiennych > Źródła danych).

- Wartości zmiennoprzecinkowe – wartości zmiennoprzecinkowe podwójnej precyzji mogą być archiwizowane z pełną dokładnością tylko w archiwum typu B. Pozostałe archiwa zapisują liczby zmiennoprzecinkowe zawsze z pojedynczą precyzją.

Rysunek: Kreator aplikacji - VarDef - OPC.


4.3 Import plikow konfiguracyjnych *.INI

4.3 Import plików konfiguracyjnych *.INI

Dla aplikacji tworzonych w starszych wersjach pakietu A six istnieje możliwość przekonwertowania plików aplikacji *.INI na format pliku konfiguracyjnego *.XML.

Służy do tego polecenie:

Plik > Nowa aplikacja - importer importuj, które powoduje uruchomienie okna z parametrami importu:

Rysunek: Okno importu aplikacji opartej na plikach *.INI.

Okno ’Import aplikacji’ pozwala określić:

  • Katalog źródłowy - parametr wskazuje katalog aplikacji systemu A six sparametryzowanej za pomocą plików *.ini;

  • Pliki aplikacji - pole to wskazuje pliki *.ini importowanej aplikacji;

  • Opcje:

  • Importuj pliki menu (*.pum) - zaznaczenie opcji spowoduje zaimportowanie definicji menu aplikacji do pliku konfiguracyjnego *.XML; dzięki temu możliwa będzie edycja menu z poziomu programu Architekt:

Moduł Maski > zakładka Menu;

  • Importuj pliki akcji złożonych (*.act) - zaznaczenie opcji spowoduje zaimportowanie definicji akcji złożonych do pliku konfiguracyjnego *.XML; składnia akcji złożonych będzie mogła być edytowana w programie Architekt:

Moduł Akcje i terminarze > zakładka Akcje złożone;

  • Importu opcje zakomentowane - zaznaczenie tej opcji spowoduje, że opcje zakomentowane w plikach *.ini zostaną zaimportowane do pliku *. XML; opcje te pozostaną nieaktywne;

uwaga Jeśli plik *.ini zawiera zakomentowane fragmenty dokumentacji nie zaleca się zaznaczenia tej opcji.


4.4 Konfiguracja parametrow startowych

4.4 Konfiguracja parametrów startowych

par startowe Parametry startowe zawierają podstawowe informacje o stanie systemu A six na etapie uruchamiania aplikacji.


4.4.1 Dane standardowe

Zakładka Standardowe określa:

Rysunek: Okno parametrów startowych - zakładka 'Standardowe'.

  • Identyfikator aplikacji / Nazwa - pozwala nadać aplikacji nazwę identyfikującą daną aplikację w sieci stanowisk. Nadanie nazwy powoduje, że w momencie kończenia pracy sprawdzane jest, czy w sieci znajdują się komputery wykonujące tę samą aplikację. Jeżeli taki komputer nie zostanie znaleziony, to wyświetlane jest okno informujące o tym. Wymagane jest wtedy potwierdzenie komendy zakończenia wykonywania programu.

Wartość domyślna: brak nazwy

  • Obraz początkowy - pole wskazuje na bitmapę, która będzie wyświetlana na ekranie w fazie uruchomienia aplikacji.

Wartość domyślna: brak

  • Akcja - pole wskazuje na akcję operatorską, która ma być wykonana na starcie aplikacji - po otwarciu wszystkich masek zadeklarowanych w parametrze:

moduł Parametry startowe > zakładka Maski > parametr Otwórz

Wartość domyślna - brak akcji startowej

uwaga Wykonanie kilku operacji wymaga użycia akcji złożonej.


4.4.2 Deklaracja programow startowanych jednoczesnie z aplikacja

4.4.2 Deklaracja programów startowanych jednocześnie z aplikacją

Zakładka Programy:

AsTrend:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsTrend'.

  • Startuj AsTrend - pozwala zadeklarować startowanie programu AsTrend równocześnie ze startem aplikacji programu A six; program AsTrend uruchamia się w postaci zminimalizowanej i oczekuje na zlecenia z programu AS. Istnieje również możliwość podania katalogu roboczego trendów.

Wartość domyślna: brak deklaracji

  • Blokada edycji - pozwala zablokować możliwość zapisywania zmian we wszystkich plikach AsTrend.

Wartość domyślna: brak deklaracji

  • Zawsze pracuj jako Administrator - pozwala nadać operatorowi prawa Administratora programu AsTrend.

Wartość domyślna: brak deklaracji

AsTrend2:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsTrend2'.

  • Alternatywna baza definicji zmiennych dla programu AsTrend - pozwala zadeklarować dla programu AsTrend inną bazę definicji zmiennych niż tą zadeklarowana dla aplikacji.

Wartość domyślna: brak deklaracji

  • Katalog przekonwertowanych trendów v1 - pozycja przeznaczona jest do użytku w sytuacji, gdy w zaimportowanym do formatu xml pliku konfiguracyjnym aplikacji wykorzystywane są definicje trendów zapisane w plikach dat, wywoływane akcją RYSUJ_TREND (tego rodzaju trendy stosowane były w aplikacjach projektowanych w starszych wersjach systemu Asix - do wersji 3).

Aby móc przeglądać trendy, których definicje przechowywane są w plikach dat za pomocą programu AsTrend (bez konieczności ręcznej zamiany na wszystkich maskach aplikacji akcji RYSUJ_TREND na akcje ASTREND), należy w pierwszej kolejności przekonwertować pliki dat z definicjami trendów do formatu plików trnx (-> przycisk Uruchom konwerter) i zadeklarować katalog przekonwertowanych trendów w polu opcji Katalog przekonwertowanych trendów v1. Po konwersji trendów należy też pamiętać o usunięciu pozycji BEZ_TRENDOW, znajdującej się w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio (pozostałość po konwersji pliku konfiguracyjnego aplikacji z formatu ini na xml).

Dzięki powyższym działaniom wywołania trendów za pomocą akcji RYSUJ_TREND przekonwertowane zostaną na wywołania programu AsTrend - czyli akcje ASTREND.

Wartość domyślna: brak deklaracji

  • Ignoruj parametry akcji Trendów v1 - opcja może być użyta w przypadku konwertowania plików trendów pochodzących z Trendów v1 (program stosowany do definiowania trendów w starszych wersjach Asixa). Przy konwersji plików Trendów v1 na trendy aktualnej wersji AsTrend załączenie opcji skutkuje pominięciem parametrów akcji RYSUJ_TREND w trakcie jej konwertowania na akcję ASTREND (chodzi o parametry: początek i koniec trendu oraz drukuj). Początek i koniec konwertowanych trendów można określić podając w oknie konwertera trendów v1 plik trendu wzorcowego ze zdefiniowanym momentem początkowym i końcowym.

AsBase:

Rysunek: Okno parametrów startowych - zakładka 'Programy/AsBase'.

  • Startuj AsBase - pozwala zadeklarować startowanie programu AsBase równocześnie ze startem aplikacji programu A six z dodatkowymi opcjami:

  • Nazwa pliku konfiguracyjnego XML - parametr obligatoryjny; plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

  • Użytkownik, Hasło - parametry opcjonalne; powoduje automatyczne logowanie wskazanego uzytkownika na starcie programu;

  • Zezwalaj na uruchomienie tylko jednej instancji programu - parametr opcjonalny; w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

  • Uruchom program zminimalizowany - parametr opcjonalny;

  • Wymagaj uprawnień administratora do zakończenia pracy programu AsBase.

Pozycja powoduje identyczne działanie co akcja operatorska ASBASE, umieszczona w parametrze AKCJA (moduł Parametry startowe > zakładka Standardowe > parametr Akcja); istotną różnicą jest natomiast moment wykonania - parametr Startuj AsBase jest wykonywany przed otwarciem masek wskazanych w parametrze: moduł Parametry startowe > zakładka Maski > parametr Otwórz; natomiast akcja AUTOSTART - nawet wykonana poprzez parametr Akcja (moduł Parametry startowe > zakładka Standardowe) jest uruchamiana po otwarciu masek startowych. Może to powodować istotny problem: maski autostartu nie mogą używać obiektów ASBASE.

Wartość domyślna - brak akcji startowej

Askom.Data.Host:

Rysunek: Okno parametrów startowych - zakładka 'Askom.Data.Host'.

  • Startuj Askom.Data.Host - pozwala zadeklarować startowanie programu Askom.Data.Host równocześnie ze startem aplikacji programu A six.

Skrypty:

Rysunek: Okno parametrów startowych - zakładka 'Programy/Skrypty'.

Zakładka Skrypty umożliwia zadeklarowanie skryptów rozszerzających możliwości funkcjonalne systemu Asix. Skrypty należy zadeklarować w kolejnych pozycjach, podając nazwę skryptu oraz deklarując plik i dodatkowe opcje skryptu zgodnie z opisaną poniżej składnią.

Nazwa skryptu musi być różna od nazw innych parametrów deklarujących użycie skryptu. Nazwa skryptu nie może być nazwą parametru modułu skryptów oraz nie może być słowem ”skrypt" i ”script".

Obecnie moduł skryptów rozpoznaje rozszerzenia języka VBScript (.vbs) oraz języka JScript (.js).

Deklaracja pliku skryptu wraz z dodatkowymi opcjami wymaga zapisu zgodnie z następującą składnią:

plik_skryptu parametry_skryptu parametry_wykonawcze

gdzie:

plik_skryptu - ścieżka oraz nazwa pliku zawierającego program skryptu; rozszerzenie nazwy pliku określa domyślny język skryptu;

parametry_skryptu - parametry przekazywane do skryptu; parametry skryptu są dostępne w skrypcie za pomocą obiektu Asix.Script.Parameters (lub Asix.Script.Arguments);

parametry_wykonawcze - parametry przekazywane do modułu skryptów (a nie do skryptu) i określające parametry wykonywania skryptu różne od domyślnych;

Do parametrów wykonawczych należą: ograniczenia czasu wykonania, aktywacja debuggera, deklaracja wątku, w którym zostanie wykonany skrypt i jego priorytet, typ skryptu, język itp. Niektóre parametry (np. ograniczenia) odpowiadają parametrom modułu skryptów. Umieszcza się je jako parametry wykonawcze tylko wtedy, gdy określony skrypt ma specjalne wymagania, różne od tych określonych za pomocą parametrów definiujących sposób wykonywania skryptów - patrz: zakładka Parametry skryptów w module Pozostałe.

Parametry wykonawcze podaje się w konwencji programu cscript, tj. są one poprzedzone podwójnym ukośnikiem.

Parametry wykonawcze:

//S - w danej chwili może być uruchomiony tylko jeden skrypt z parametrem //S, zawarty w podanym pliku; parametr ma znaczenie tylko w przypadku uruchamiania skryptu jako akcji operatorskiej systemu Asix; moduł skryptów odrzuci próbę ponownego uruchomienia skryptu w sytuacji, gdy poprzednie uruchomienie skryptu z parametrem //S, zawartego w tym samym pliku, jeszcze się nie zakończyło; brak tego parametru powoduje, że można równocześnie uruchamiać wiele skryptów w oparciu o program zawarty w tym samym pliku.;

//X - po uruchomieniu skryptu jest również uruchamiany debugger (zainstalowany w systemie jako domyślny); debugger zatrzymuje wykonanie skryptu na pierwszej instrukcji skryptu;

//D - wystąpienie błędu w skrypcie powoduje uruchomienie debuggera;

//IT:nnn - ograniczenie czasu wykonania części inicjalizacyjnej wyrażone w milisekundach;

//T:nnn - ograniczenie czasu wykonania części zdarzeniowej wyrażone w milisekundach;

//E:nazwa - podaje nazwę języka skryptu (np. //E:JScript);

//Watek:nazwa[,pri] - podaje nazwę wątku, w którym wykonuje się skrypt oraz określa priorytet pri wątku; nazwa wątku może być dowolna i służy grupowaniu skryptów wykonywanych w jednym wątku;

priorytety wątku skryptu:

0 IDLE - bezczynny,

1 LOWEST - najniższy,

2 BELOW_NORMAL - poniżej normalnego,

3 NORMAL - normalny (domyślny),

4 ABOVE_NORMAL - powyżej normalnego,

5 HIGHEST - najwyższy,

6 TIME_CRITICAL - krytyczny czasowo;

domyślnym priorytetem wątku jest priorytet 3 (normalny).

//U - podanie tego parametru spowoduje, że nie będą generowane zdarzenia ”OnRead" oraz funkcje zdarzeń czasowych zdefiniowane metodami SetInterval i ExecuteAt, jeśli okna aplikacji Asix są ukryte (np. za pomocą akcji operatorskiej UKRYJ).

Szczegółowy opis modułu skryptów znajduje się w podręczniku ”Skrypty - podręcznik użytkownika”.


4.4.3 Podstawowe parametry Panelu Kontrolnego i Konstruktora

Zakładka Panel kontrolny pozwala zdefiniować podstawowe parametry Panelu Kontrolnego i Konstruktora:

Okno:

Rysunek: Okno parametrów startowych - zakładka 'Panel Kontrolny/Okno'.

  • Położenie okna Panelu Kontrolnego - to pozycja podająca początkowe położenie okna Panelu Kontrolnego. Koordynaty wyrażone są w pikselach.

Wartość domyślna - użycie pozycji standardowej.

Definiując położenie okna, projektant ma do dyspozycji narzędzie ułatwiające tę czynność. Przycisk Wybierz… uruchamia okno ’Pozycja okna’, które jest wyposażone w przycisk Podgląd. Pozwala on określić współrzędne położenia poprzez ręczne przesuwanie szarego okna, odpowiadającego wymiarom Panelu Kontrolnego.

Rysunek: Okno definiujące położenie okna Panelu Kontrolnego.

  • Zwiń przy starcie okno Panelu Kontrolnego do ikony - pozwala na automatyczne zwinięcie Panelu do ikony w czasie wykonywania startu aplikacji. Parametry położenia zostaną wtedy użyte przy operacji rozwinięcia okna.

  • Wyświetlaj okno panelu zawsze na wierzchu - pozycja pozwala na nadanie oknu Panelu Kontrolnego atrybutu powodującego jego wyświetlanie ponad wszystkimi innymi oknami systemu. Wykorzystanie tego parametru jest przydatne w sytuacji używania masek z atrybutem ”na wierzchu", które mogą zasłonić Panel.

  • Liczba pamiętanych błędów - określa liczbę błędów zapamiętywanych w oknach Panelu Kontrolnego i Konstruktora.

  • Ukryj - pozwala na zablokowanie ukrycia okien aplikacji z poziomu menu Konstruktora (blokowane jest polecenie Pliki > Ukryj okna) oraz akcją UKRYJ_WSZYSTKO. Ma zastosowanie w przypadku, gdy istnieje potrzeba zróżnicowania sposobu pracy tej samej aplikacji na różnych stanowiskach (np. stanowisko operatorskie i kontrolne).

Polecenie Pliki > Ukryj okna oraz akcja UKRYJ_WSZYSTKO powodują zwinięcie wszystkich otwartych okien aplikacji do ikony na pasku zadań w prawej jego części. W wyniku tego następuje automatyczna redukcja obciążenia procesora. Przywrócenie aplikacji do poprzedniego stanu wykonuje się przez dwukrotne kliknięcie na ikonie A sixa, znajdującej się w prawej części paska zadań.

  • Cicho - wyłącza sygnalizację dźwiękową alarmów i komunikatów Panelu Kontrolnego.

Plik:

Rysunek: Okno parametrów startowych - zakładka 'Panel Kontrolny/Plik'.

  • Plik komunikatów - wskazuje miejsce, gdzie mają być zapisywane komunikaty Panelu Kontrolnego i Konstruktora oraz maksymalny rozmiar pliku komunikatów.

Wartość domyślna - komunikaty systemowe nie są zapisywane do pliku.

Rysunek: Przeglądarka logów asixa.

Przycisk uruchom okno komunikatów uruchamia okno przeglądarki logów A sixa.

Przycisk usunięcie pliku logów powoduje skasowanie pliku logów.


4.4.4 Parametryzacja mechanizmu aktualizacji oprogramowania

Zakładka Aktualizacja Plików obejmuje parametry dotyczące oprogramowania narzędziowego A sixa, elementów składowych aplikacji oraz częstotliwości sprawdzania jednolitości oprogramowania. Deklarowane tu operacje pozwalają ujednolicić oprogramowanie narzędziowe i aplikacyjne w sposób automatyczny:

Aktualizacja Plików / Pliki:

Rysunek: Okno parametrów pozostałych - zakładka 'Aktualizacja plików'.

  • Plik - użycie parametru powoduje wykonywanie aktualizacji dowolnych plików; dla pozycji Plik należy zadeklarować nazwę pliku (wraz z jego katalogiem), którego zawartość ma być aktualizowana oraz nazwę katalogu wzorca, w którym umieszczone są pliki wzorcowe;

uwaga Aktualizacja jest wykonywana wtedy, gdy pliki wzorcowe mają późniejszy czas modyfikacji niż pliki oryginalne lub pliki oryginalne nie zostały znalezione

Aktualizacja Plików / Opcje:

  • Okres - służy do podania okresu czasu wyrażonego w minutach, co jaki należy wykonywać synchronizację plików; brak pozycji lub wartość 0 oznacza, że synchronizacja jest wykonywana tylko na starcie programu;

Wartość domyślna: 0

  • Raport - parametr włączony powoduje wysyłanie komunikatów do panelu kontrolnego w przypadku wykonania operacji synchronizacji pliku;

Wartość domyślna: domyślnie parametr jest wyłączony

Aktualizacja Plików / VarDef - pliki txt:

  • Katalog wzorców plików modułu modułu danych bieżących - zastosowanie parametru powoduje wykonywanie aktualizacji plików definicji zmiennych Asmena

uwaga Parametr stosowany w sytuacji, gdy definicje zmiennych przechowywane w plikach tekstowych (w starszych wersjach systemu A six). Parametr jest dostępny na zakładce Aktualizacja Plików / VarDef - pliki txt, gdy jako typ bazy definicji zmiennych został zadeklarowany typ: Baza definicji zmiennych w starym formacie - pliki tekstowe (Asix 1-4).

  • Katalog wzorców plików modułu modułu danych archiwalnych – zastosowanie parametru powoduje wykonywanie aktualizacji plików definicji zmiennych Aspada

uwaga Parametr stosowany w sytuacji, gdy definicje zmiennych przechowywane w plikach tekstowych (w starszych wersjach systemu A six). Parametr jest dostępny na zakładce Aktualizacja Plików / VarDef - pliki txt, gdy jako typ bazy definicji zmiennych został zadeklarowany typ: Baza definicji zmiennych w starym formacie - pliki tekstowe (Asix 1-4).


4.4.5 Definiowanie zaleznosci pomiedzy komputerami i obszarami

4.4.5 Definiowanie zależności pomiędzy komputerami i obszarami

Widok zakładki Komputery zależny jest od tego, który element zaznaczony jest w drzewie komputerów i obszarów. Jeśli jest to Obszar, okno wyświetla listę komputerów podpiętych do danego obszaru (patrz: Rysunek: Widok komputerów podłączonych do wskazanego obszaru.). Jeśli jest to Komputer, pojawia się zakładka z zestawieniem obszarów dostępnych oraz obszarów, do których dołączony jest dany komputer (patrz: Rysunek: Widok obszarów, do których podpięty jest wskazany komputer.).

Rysunek: Widok komputerów podłączonych do wskazanego obszaru.

Rysunek: Widok obszarów, do których podpięty jest wskazany komputer.


4.4.6. Deklaracja aktywnych zmiennych

Zakładka VarDef - aktywne zmienne pozwala załączyć selekcję zmiennych wg atrybutu bazy definicji zmiennych, który pozwala określić zmienne aktywne dla danego komputera - jest to dowolny atrybut utworzony przez projektanta. Załączenie tej opcji i zadeklarowanie nazwy tego atrybutu spowoduje, ze podczas startu aplikacji ładowane będą tylko te zmienne, dla których wartość wskazanego atrybutu wynosi 1.

Rysunek: Okno parametrów startowych - zakładka 'VarDef - aktywne zmienne'.


4.4.7. Deklaracja zwenetrznej bazy definicji zmiennych

4.4.7 Deklaracja zewnętrznej bazy definicji zmiennych

uwaga Zakładka Baza definicji zmiennych pojawia się w sytuacji, gdy:

1. dla aplikacji zadeklarowana jest Zewnętrzna baza/bazy definicji zmiennych:

Bazy danych > Baza definicji zmiennych > zakładka Typ

Zakładka Baza definicji zmiennych pozwala określić następujące opcje:

Rysunek: Okno parametrów startowych - zakładka 'Baza definicji zmiennych'.

  • Bazy definicji zmiennych - pole to wskazuje lokalizację pliku zewnętrznej bazy definicji zmiennych - utworzonej za pomocą Architekta, parametryzowanej plikiem XML innym niż ten, który parametryzuje projektowaną aplikację.


4.5 Konfiguracja parametrow masek

4.5 Konfiguracja parametrów masek

Moduł maski ikonka Maski obejmuje parametry, których konfiguracja jest niezbędna do prawidłowej pracy masek, m.in. lokalizuje symbole graficzne wykorzystywane do projektu masek, wskazuje katalogi, z których pobierane są maski w trakcie działania aplikacji oraz definiuje wybrane parametry pracy obiektów na maskach.


4.5.1 Deklaracja lokalizacji plikow graficznych i masek

4.5.1 Deklaracja lokalizacji plików graficznych i masek technologicznych

Zakładka Pliki i Foldery pozwala określić następujące opcje:

Rysunek: Okno parametrów masek - zakładka 'Pliki i Foldery'.

  • Plik symboli graficznych - podaje nazwę pliku, w którym znajdują się mapy bitowe i ikony używane w aplikacji. Użytkownik może sam tworzyć pliki symboli graficznych, potrzebnych do projektowanych aplikacji.

Wartość domyślna: mapy bitowe standardowo dołączane do pakietu znajdują się w pliku asbitmap.dat w katalogu programu AS.

Opis użycia map bitowych w aplikacji systemu A six znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Konstruktor - projektowanie aplikacji.

  • Ścieżka masek - pozycja podająca listę nazw katalogów, w których znajdują się pliki zawierające maski wizualizacyjne;

Wartość domyślna: brak pozycji oznacza, że pliki masek będą czytane z katalogu głównego aplikacji.


4.5.2. Deklaracja masek otwieranych automatycznie po

4.5.2 Deklaracja masek otwieranych automatycznie po uruchomieniu aplikacji

Zakładka Maski otwierane określa:

Rysunek: Okno parametrów startowych - zakładka 'Maski otwierane'.

  • Maski otwierane - nazwy masek, które mają być automatycznie otwarte po uruchomieniu aplikacji;

  • Maski otwierane zminimalizowane - nazwy masek, które mają być automatycznie otwarte po uruchomieniu aplikacji i natychmiast zwinięte do ikony.


4.5.3 Deklaracja czcionek wykorzystywanych w projektowanej

4.5.3 Deklaracja czcionek wykorzystywanych w projektowanej aplikacji

Zakładka Czcionki pozwala zdefiniować czcionki, używane w aplikacji systemu A six. Poniżej listy zadeklarowanych czcionek znajduje się okno podglądu czcionek, w którym wyświetlany jest krój zaznaczonej czcionki.

Rysunek: Okno parametrów masek - zakładka 'Czcionki'.


4.5.4 Deklaracja jezykow aplikacji

4.5.4 Deklaracja języków aplikacji

Zakładka Języki przeznaczona jest do definiowania języków pracy aplikacji:

Rysunek: Okno parametrów startowych - zakładka 'Języki'.

  • Języki deklarowane są poprzez:

  • Kod języka - zaleca się zachowanie zgodności z normą ISO639; kod języka używany jest do selekcji aktywnego języka i wyboru właściwych wersji tekstów używanych w aplikacji;

Zestawienie wszystkich kodów języków obsługiwanych przez Architekta zawiera Załącznik 3.

  • Opis - opis języka;

  • Strona kodowa - parametr, który określa właściwą stronę kodową dla danego języka; parametr stosowany jest w funkcji

uwaga Dla danej aplikacji można zadeklarować pięć pozycji języków,automatycznego przełączania stron kodowych czcionek; co oznacza, że aplikacja zbudowana przy wykorzystaniu pakietu może pracować w pięciu językach.

uwaga Specjalne znaczenie ma pierwszy zadeklarowany język. Określa ona tzw. język podstawowy. Jest to język, w którym aplikacja została zbudowana.

uwaga System przełączania języków uaktywnia się, jeżeli w pliku konfiguracyjnym zostaną zdefiniowane co najmniej dwa języki pracy aplikacji.

  • Tablica Tekstów - służy do tłumaczenia tekstów, które są wyświetlane w ramach elementów aplikacji i są wbudowane w kod programu.

Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TextTable.Lng.

Plik Tablicy Tekstów jest plikiem tekstowym, w którym poszczególne linie są tekstami wielojęzycznymi określającym tłumaczenia tekstów. W pliku dopuszczalne są linie komentarzy, które są oznaczane przez znak średnika na początku linii.

uwaga W ramach pakietu A six jest dostarczany plik TextTable.Tlt zawierający kompletną tablicę tekstów dla języków polskiego i angielskiego.

Projektant powinien skopiować ten plik do katalogu aplikacji pod nazwą TextTable.Lng, a następnie uzupełnić teksty wielojęzyczne o definicje wariantów dla pozostałych używanych języków aplikacji.

  • Tablica Translacji - służy do tłumaczenia tekstów wprowadzonych przez projektanta w trakcie definiowania aplikacji. Dotyczy to głównie tekstów z obiektów umieszczonych na maskach wizualizacyjnych.

uwaga Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TranslateTable.Lng. Bazowy plik Tablicy Translacji można wygenerować automatycznie przy pomocy funkcji PLIK_TŁUMACZEŃ z menu NARZĘDZIA okna Konstruktora.

Zobacz też zagadnienie 4.17. Konfiguracja aplikacji wielojęzycznej .


4.5.5. Dostęp do edytora Tabeli zmiennych

Zakładka Tabela umożliwia uruchomienie edytora Tabeli zmiennych.

Rysunek: Okno parametrów masek - zakładka 'Tabela'.


4.5.6 Definicje menu umieszczanego na masce aplikacji

Zakładka Menu przeznaczona jest do tworzenia definicji menu umieszczanych na maskach pełniących funkcje pasków menu z rozwijanymi pozycjami do wyboru.

Rysunek: Okno parametrów masek - zakładka 'Menu'.

Definicja pojedynczego menu dołączana jest do jednego przycisku na pasku menu.

Rysunek: Widok menu rozwijanego.

Tworzenie definicji menu umożliwia edytor menu wywoływany poleceniem rozwiń po zadeklarowaniu nazwy menu w oknie Menu.

Rysunek: Okno edytora menu.

W Edytorze menu należy określić następujące elementy określające wygląd oraz sposób działania pojedynczego menu:

  • Nazwa - w tym polu należy wpisać bezpośrednio lub za pomocą Edytora tekstów wielojęzycznych (uruchamianego przyciskiem [image]) teksty, które pojawią się w gotowej aplikacji jako pozycje rozwijanej listy. Patrz: Rysunek: Edytor tekstów wielojęzycznych.

Rysunek: Edytor tekstów wielojęzycznych.

  • Akcja - pole pozwala dla każdej pozycji rozwijanej listy definiowanego menu zadeklarować akcję, która zostanie wykonana po wybraniu danej pozycji; akcję można zdefiniować przy użyciu Edytora akcji uruchamianego przyciskiem 3 kropki. Patrz: poniżej.

Rysunek: Edytor akcji.

  • Początek grupy - zaznaczenie pola przy określonej pozycji spowoduje, że w gotowej wyświetlanej liście pozycji menu pojawi się nad tą pozycją pionowa kreska oddzielająca daną pozycję od pozycji wcześniejszych. Patrz: poniżej.

Rysunek: Początek grupy na liście rozwijanych pozycji menu.

Dodawanie i usuwanie pozycji rozwijanej listy menu umożliwia pasek narzędziowy Edytora menu:

pasek narzędziowy edytora menu, gdzie:

dodaj pozycje menu - Dodaj element (Shift + Ctrl + Ins);

dodaj podelement - Dodaj podelement (Ctrl + Ins);

ususń element - Usuń element (Ctrl + Del);

przenieś wyżej - Przenieś wyżej (Ctrl + Up);

przenieś niżej - Przenieś niżej (Ctrl + Down);

przenieś w lewo - Przenieś w lewo (Ctrl + Left);

przenieś w prawo - Przenieś w prawo (Ctrl + Right);

podgląd - Podgląd (Ctrl + P).

Utworzoną definicję pojedynczego menu należy podpiąć do przycisku umieszczonego na masce paska menu:

Rysunek: Schemat powiązania definicji pojedynczego menu z maską menu aplikacji.


4.5.7 Definicje parametrow tekstowych

4.5.7 Definicje parametrów tekstowych

Zakładka Parametry tekstowe pozwala zdefiniować stałe tekstowe, które służą następującym celom:

  • definicje tekstów wyświetlanych przez obiekty wizualizacyjne klasy TEKST,

  • definicje tekstów używanych przez język ASTER do tworzenia raportów (instrukcja alias),

  • definicje wartości liczbowych (wpisywanych jako teksty) używanych przez język ASTEL do przetwarzania danych procesowych (funktor alias),

  • definicje kodów sterujących używanych do formatowania raportów na drukarce (instrukcja ctrl),

  • definicje części składowych złożonej akcji operatorskiej,

Definicja parametru tekstowego składa się z pól:

  • Nazwa logiczna parametru;

  • Tekst - parametr może być definiowany przy użyciu Edytora tekstów wielojęzycznych, uruchamianego przyciskiem [image];

Rysunek: Okno parametrów masek - zakładka Parametry Tekstowe.


4.5.8 Deklaracja klawiatur ekranowych

Mechanizm klawiatur ekranowych (aktywny w trybie wykonawczym aplikacji) zapewnia operatorowi możliwość wprowadzania tekstów do pól edycyjnych okien dialogowych i pól edycyjnych obiektów LICZBA i NAPIS poprzez stosowną klawiaturę ekranową (patrz: Rysunek: Okna klawiatur ekranowych dostępnych w systemie Asix.). Mechanizm stanowi wsparcie dla aplikacji pracujących na panelach z ekranem dotykowym.

Klawiatura jest uaktywniana po kliknięciu w obszarze pola lub obiektu.

Rysunek: Okna klawiatur ekranowych dostępnych w systemie Asix.

Zakładka Klawiatura ekranowa obejmuje następujące parametry:

Rysunek: Okno parametrów masek - zakładka 'Klawiatura ekranowa'.

  • Włącz klawiaturę ekranową - uruchamia mechanizm klawiatur ekranowych, które umożliwiają (w trybie wykonawczym aplikacji) wprowadzanie tekstów do pól edycyjnych okien dialogowych i pól edycyjnych obiektów LICZBA i NAPIS;

Wartość domyślna: mechanizm klawiatur ekranowych nie jest włączony.

  • Rozmiar klawiatury ekranowej - parametr pozwala określić rozmiar klawiatury ekranowej w pikselach;

Wartość domyślna: okno klawiatury ma szerokość 500 pikseli;

  • Rozmiar klawiatury numerycznej - parametr pozwala określić rozmiar klawiatury numerycznej w pikselach;

Wartość domyślna: okno klawiatury ma szerokość 300 pikseli.


4.5.9 Parametry dotyczace okresu migotania obiektow

4.5.9 Parametry dotyczące okresu migotania obiektów wizualizacyjnych oraz parametry wysyłanych sterowań

Zakładka Pozostałe obejmuje następujące parametry:

Rysunek: Okno parametrów masek - zakładka 'Pozostałe'.

  • Okres migotania - deklaracja okresu migotania w milisekundach; parametr ten jest ustawiany jednorazowo i ma skutek w działaniu wszystkich obiektów używających atrybutu migotania;

Wartość domyślna: 333 ms

  • Bez niewidocznych sterowań - parametr pozwala zablokować wysyłanie sterowań z masek nawet częściowo przesłoniętych innym oknem;

Wartość domyślna: domyślnie wysyłane są ustawione sterowania z wszystkich otwartych w danym momencie masek.

  • Czas ważności sterowań - parametr pozwalający określić czas, liczony w sekundach od momentu ustawienia ostatniego wyboru sterowania przez operatora do skasowania wszystkich aktywnych wyborów przez system. ”r;0" oznacza, że opcja liczenia czasu ważności sterowań nie jest włączona; domyślnie opcja nie jest włączona.

Wartość domyślna: 0 - raz ustawiony wybór sterowania jest aktywny do zamknięcia maski, o ile wcześniej nie został skasowany przez operatora.


4.6 Konfiguracja parametrow danych biezacych

4.6 Konfiguracja parametrów danych bieżących

Grupa parametrów dane bieżące ikonka Dane bieżące obejmuje ustawienia pracy modułu Asmen, w tym szczegółową parametryzację kanałów transmisyjnych - fizycznie realizowanych połączeń pomiędzy komputerem systemu A six i sterownikami na obiekcie oraz parametryzację drajwerów komunikacyjnych.

W systemie A six wszystkie operacje związane z dostępem do zmiennych procesowych są realizowane przez moduł Asmen. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych procesowych w bazie danych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery pracujące pod kontrolą Asmena.

W oparciu o dokonaną parametryzację tworzone jest repozytorium bieżących wartości zmiennych procesowych (przechowywane przez moduł Asmen w pamięci operacyjnej komputera), do którego mają dostęp wszystkie komponenty systemu A six. Wartości przechowywanych zmiennych procesowych są na bieżąco aktualizowane poprzez cykliczny odczyt z obiektu.

Szczegółowy opis funkcjonalności modułu Asmen znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Menedżer komunikacyjny ASMEN.


4.6.1 Parametry standardowe

Parametry dotyczące danych bieżących znajdujące się na zakładce Standardowe obejmują:

Rysunek: Okno parametrów danych bieżących - zakładka 'Standardowe'.

  • Symulacja - Asmen działa w trybie symulacji danych po zaznaczeniu opcji Zaznaczenie tej opcji spowoduje pominięcie ładowania modułu danych bieżących Asmen.

Wartość domyślna: domyślnie opcja jest wyłączona.

  • Przeciążenia - wykorzystanie parametru pozwala na rejestrację stanu przeciążenia przy odświeżaniu zmiennych procesowych w panelu operatorskim;

Wartość domyślna: domyślnie opcja jest włączona;

Przeciążenia te dotyczą zmiennych - w sytuacji gdy zadeklarowany czas odświeżania zmiennych przekracza możliwości kanału transmisyjnego. (Częstość odświeżania deklarowana jest w definicji zmiennej).

  • Sprawdzanie zakresów - włącza sprawdzanie zakresów dla zmiennych z ustawionym atrybutem Sprawdzanie zakresu pomiarowego;

Wartość domyślna: domyślnie opcja jest wyłączona;

  • Dane / Nazwy plików z deklaracjami zmiennych procesowych

uwaga Pole dostępne jest wyłącznie wówczas, gdy definicje zmiennych procesowych pobierane są z plików tekstowych, co zostało uprzednio zadeklarowane w:

Moduł Bazy danych > zakładka Typ > Typ bazy definicji zmiennych: Tekstowa baza definicji zmiennych (Asix 1-4).


4.6.2 Parametry zaawansowane

uwaga Zakładki Zaawansowane i Zaawansowane2 pojawiają się po wybraniu polecenia:

Obszary i komputery > Pokaż opcje zaawansowane

Zakładki Zaawansowane i Zaawansowane 2 pozwala na parametryzację następujących pozycji:

Rysunek: Okno parametrów danych bieżących - zakładka 'Zaawansowane'.

  • Status OPC - deklaracja używania statusów w trybie zgodnym z OPC; włączenie tej opcji jest wymagane dla poprawnego działania modułu skryptów.

Wartość domyślna: opcja włączona

  • Priorytet - deklaracja priorytetów wątków Asmena:

  • 0 - THREAD_PRIORITY_NORMAL,

  • 1 - THREAD_PRIORITY_ABOVE_NORMAL,

  • 2 - THREAD_PRIORITY_HIGHEST.

Wartość domyślna: 0

  • Liczba prób dostępu do zmiennej - deklaracja liczby prób zdalnego dostępu do zmiennej na serwerze, po której przyjmuje się, że zmienna na przedmiotowym serwerze nie została zadeklarowana;

Wartość domyślna: 1

  • Liczba użytkowników - pozwala zdefiniować maksymalną liczbę użytkowników korzystających z API Asmena. Pozycja ma zastosowanie w wieloportowych aplikacjach z drajwerem MUZ;

Wartość domyślna: 128

  • Wstępne odświeżanie - jeśli opcja zostanie zadeklarowana, na etapie instalacji Asmena następuje odczyt aktualnych wartości wszystkich zmiennych procesowych;

Wartość domyślna: opcja załączona

Rysunek: Okno parametrów danych bieżących - zakładka 'Zaawansowane2'.

  • Zwłoka danych z serwera - pozycja stosowana na terminalu; określa czas, po którym następuje ustawienie statusu błędu zmiennej w następstwie braku napływu odświeżonych danych z serwera; czas jest wyliczany jako iloczyn czasu odświeżania zmiennej (podanego w definicji zmiennej) oraz wartości pozycji; pozycja ma zastosowanie do wszystkich zmiennych jednocześnie; jednostka: sekunda.

Wartość domyślna: 1 sekunda

  • Cykl odświeżania - deklaracja wartości domyślnego cyklu odświeżania zmiennych procesowych (w sekundach), dla których nie podano wartości cyklu odświeżania w deklaracji zmiennej;

Wartość domyślna: 1 sekunda

  • Ścieżka tabel - deklaracja nazwy kartoteki, w której znajdują się tabele używane przez funkcje przeliczające TABELA;

Wartość domyślna: brak zadeklarowanej ścieżki

  • Opis zmiennej - określa użycie pola Opis w deklaracji zmiennych procesowych Asmena;

uwaga Użycie opcji jest zasadne wyłącznie wtedy - gdy deklaracje zmiennych procesowych pobierane są z plików - tekstowych.

Wartość domyślna: opcja jest włączona

  • Sterowanie asynchroniczne - deklaracja użycia trybu asynchronicznego przy realizacji sterowań w szybkich kanałach transmisji;

Wartość domyślna: tryb asynchroniczny nie jest używany


4.6.3 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia:

Widok > Pokaż opcje zaawansowane

Zakładka Diagnostyka obejmuje:

Rysunek: Okno parametrów danych bieżących - zakładka 'Diagnostyka'.

  • Plik logu - domyślnie opcja załączana dla nowych aplikacji

  • Statystyka kanałów - zestawienie liczby odświeżanych oraz przeciążonych zmiennych w poszczególnych kanałach fizycznych; zestawienie wyprowadzane do Panelu Kontrolnego co sekundę;

Wartość domyślna: opcja jest wyłączona

  • Statystyka przeciążeń - zestawienie liczby przeciążonych zmiennych w kanałach fizycznych; zestawienie jest wyprowadzane do Panelu Kontrolnego wtedy, gdy wystąpi przeciążenie;

Wartość domyślna: opcja jest wyłączona

Zakładka Diagnostyka - śledzenie obejmuje:

Rysunek: Okno parametrów danych bieżących - zakładka 'Diagnostyka - śledzenie'.

  • Śledzenie zmiennych - opcja ta powoduje dla wybranych zmiennych wpisywanie do pliku logu komunikatów o wartościach, które moduł danych bieżących otrzymał ze sterowników i innych źródeł.


4.6.4 Definicja kanalow komunikacyjnych

4.6.4 Definicja kanałów komunikacyjnych

Definicje kanałów komunikacyjnych dodawane są za pomocą polecenia Dodaj kanał po kliknięciu prawym klawiszem myszki na pozycji Dane bieżące. Pojawia się wówczas okno ’Dodaj kanał’, gdzie należy określić nazwę kanału i nazwę drajwera komunikacyjnego.

Rysunek: Okno deklarowania definicji kanałów.

Wyboru nazwy drajwera należy dokonać z listy drajwerów dostępnych w pakiecie A six, która uruchamiana jest przyciskiem Wybierz w oknie ’Dodaj kanał’.

Rysunek: Okno wyboru drajwerów komunikacyjnych.

Po wybraniu konkretnego drajwera w grupie parametrów Dane bieżące pojawia się pozycja z nazwą wyselekcjonowanego drajwera. Kliknięcie na tę pozycję otwiera w oknie parametrów zakładki, które służą do parametryzacji tego drajwera - zakładki te zostały opisane poniżej. Ponadto, kliknięcie prawym klawiszem myszki na wybranym kanale uruchamia podręczne menu z komendami umożliwiającymi zmianę definicji kanału oraz usunięcie zaznaczonego kanału.

Zakładka Standardowe obejmuje standardowe parametry deklaracji każdego kanału:

Rysunek: Widok okna parametryzującego pracę drajwera komunikacyjnego - zakładka 'Standardowe'.

  • Kanał/Nazwa - określa nazwę kanału;

  • Kanał/Drajwer - określa nazwę drajwera;

  • Drajwer użyty w kanale:

  • Używaj drajwer jaki podano w definicji kanału;

  • Tymczasowo używaj drajwer NONE - opcja stosowana w przypadku braku fizycznego podłączenia do sterownika; drajwer NONE może być stosowany w celu testowania aplikacji;

  • Tymczasowo używaj drajwer NETWORK - drajwer NETWORK jest specyficznym rodzajem drajwera; nie realizuje on fizycznego połączenia ze sterownikiem, a jedynie połączenie z innym komputerem, który takie połączenie ma; drajwer kanału sieciowego po nawiązaniu połączenia wysyła zapytanie do wszystkich serwerów podając nazwę logiczną kanału; odpowiadają na to pytanie jedynie serwery, które posiadają zadeklarowany taki kanał; jeżeli odpowie więcej niż jeden serwer, to wtedy do nawiązania połączenia wybiera się serwer najmniej obciążony; jeżeli w czasie pracy nastąpi wyłączenie serwera, wówczas drajwer kanału sieciowego przełączy się na inny serwer;

  • Alarm w kanale (parametr dostępny dla wybranych drajwerów) - deklaracja zgłoszenia alarmu w przypadku braku transmisji w kanale logicznym; opcjonalnie możliwe jest zgłoszenie nr alarmu w przypadku przełączenia transmisji na kanał redundantny (o ile kanał redundantny został zadeklarowany dla kanału logicznego);

Wartość domyślna: brak deklaracji kanału podstawowego i redundantnego

  • Synchronizacja czasu (parametr dostępny dla wybranych drajwerów) - synchronizacja czasu odbywa się w kierunku od systemu Asix do sterownika. Więcej informacji znajduje się w podręczniku ‘Drajwery komunikacyjne’ (plik pomocy Drajwery komunikacyjne.pdf / Drajwery komunikacyjne.chm);

Wartość domyślna: brak deklaracji

Pozostałe parametry dostępne na zakładce Standardowe zależą od konkretnego zadeklarowanego drajwera.

Zakładka z nazwą zadeklarowanego drajwera obejmuje parametry właściwe do skonfigurowania kanału komunikacyjnego dla danego drajwera.

Opisy parametryzacji poszczególnych drajwerów znajdują się w podręczniku Drajwery komunikacyjne (plik DrajweryKomunikacyjne.pdf/chm).

uwaga Zakładka Zaawansowane i Zaawansowane 2 pojawia się po wybraniu polecenia Obszary i komputera > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Zaawansowane pozwala na parametryzację następujących pozycji:

Rysunek: Widok okna parametryzujących pracę drajwera komunikacyjnego - zakładka 'Zaawansowane'.

  • Redundancja - (parametr dostępny dla wybranych drajwerów) deklaracja kanału redundantnego dla kanału logicznego. Opcjonalnie można ograniczyć zakres poszukiwań poprzez zadeklarowanie listy komputerów. W polu należy wpisać nazwę kanału redundantnego, a po przecinku można podać nazwy komputerów, do których ma być ograniczone szukanie.

Wartość domyślna: domyślnie kanał redundantny jest szukany na wszystkich komputerach sieci

  • Zezwolenie zapisu - deklaracja nazw sieciowych komputerów, które mają uprawnienia do sterowania w danym kanale. Nazwy oddzielić należy przecinkiem.

Wartość domyślna: domyślnie żaden z komputerów nie ma uprawnień do zapisu.

  • Ograniczenie odczytu - deklaracja nazw sieciowych komputerów, które mają uprawnienia do czytania wartości zmiennych z danego kanału.

Wartość domyślna: domyślnie wszystkie komputery mogą czytać zmienne z tego kanału.

Zakładka Zaawansowane 2 pozwala na parametryzację następujących pozycji:

Rysunek: Widok okna parametryzującego pracę drajwera komunikacyjnego - zakładka 'Zaawansowane 2'.

  • Blokada zapisu lokalnego - blokada lokalnych sterowań w kanale logicznym;

Wartość domyślna: nie ma blokady lokalnych sterowań

  • Czas ważności danych - okres czasu (w sekundach), przez który wartości zmiennych procesowych w kanale logicznym zachowują ważność bez względu na zadeklarowaną częstość odświeżania; ważność wartości zmiennych procesowych określa się na podstawie cyklu odświeżania;

Wartość domyślna: 0


4.6.5. Zarzadzanie_kanalami

4.6.5. Zarządzanie kanałami

W menu uruchamianym po kliknięciu prawym klawiszem myszki na pozycji Dane bieżące dostępne jest również polecenie Zarządzaj kanałami, umożliwiające masowe kopiowanie i usuwanie kanałów, zmianę typu drajwera użytego w kanale oraz sortowanie kolejności wyświetlania kanałów w drzewie modułu Dane bieżące.

Rysunek: Okno 'Zarządzaj kanałami'.


4.7 Konfiguracja parametrow danych biezacych dotyczacych

4.7 Konfiguracja parametrów danych bieżących dotyczących serwera sieci

Konfiguracja parametrów z grupy serwer sieci Dane bieżące - serwer sieci wiąże się z ustawieniem wartości parametrów konfigurujących sposób wymiany danych poprzez lokalną sieć komputerową.

Lokalna sieć komputerowa może być wykorzystana do stworzenia takiej konfiguracji systemu A six, w której tylko część komputerów (serwery danych) ma bezpośrednie połączenie ze sterownikami, natomiast pozostałe komputery (stacje robocze) korzystają z informacji udostępnianych przez serwery danych za pośrednictwem lokalnej sieci komputerowej.

Kanały transmisji systemu A six służące do pozyskiwania danych poprzez lokalną sieć komputerową noszą nazwę kanału sieciowego.

Wymiana danych w lokalnej sieci komputerowej pomiędzy stacjami systemu A six jest realizowana przez moduł NETSRV. Moduł ten jest ładowany automatycznie przy uruchomieniu A sixa.


4.7.1 Dane standardowe

Zakładka Standardowe obejmuje konfigurację następujących opcji:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Standardowe'.

  • Kanały redundantne - określa typ kanału serwera, który będzie akceptowany przez dany komputer zdalny jako kanał redundantny; dopuszczalne typy to:

  • FIZYCZNE - tylko kanał fizyczny,

  • SIECIOWE - tylko kanał sieciowy,

  • WSZYSTKIE - dowolny typ kanału;

Wartość domyślna: FIZYCZNE

  • Tryb pomost - deklaruje pracę stacji roboczej w trybie POMOST.

W konfiguracjach, w których stacja robocza systemu A six jest pomostem pomiędzy dwiema lokalnymi sieciami komputerowymi, kanały sieciowe stacji roboczej traktowane są na równi z kanałami fizycznymi w zakresie udostępniania danych w lokalnej sieci komputerowej. Terminale w sieci zakładowej mogą dołączyć się do kanałów sieciowych pomostu.

Wartość domyślna: tryb POMOST nie jest zadeklarowany

  • Wyszukiwanie serwerów - okres - pozwala określać odstęp czasu (w sekundach) pomiędzy operacjami poszukiwania serwerów;

Wartość domyślna: 1 sekunda

  • Wyszukiwanie serwerów - czas oczekiwania na odpowiedź - deklaracja maksymalnego okresu oczekiwania na odpowiedź podczas wyszukiwania serwerów; okres podany jest jako liczba taktów o czasie trwania 55 ms każdy.

Wartość domyślna: 18 (odpowiada jednej sekundzie)

  • Transmisja danych - czas oczekiwania na odpowiedź - deklaruje maksymalny czas oczekiwania na odpowiedź serwera podczas transmisji danych (w sekundach);

Wartość domyślna: 10 sekund


4.7.2 Dane zaawansowane

uwaga Zakładka Zaawansowane i Zaawansowane2 pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładki Zaawansowane i Zaawansowane2:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Zaawansowane'.

  • Czas UTC - żądanie przekazywania wartości zmiennych opatrzonych czasem UTC.

Wartość domyślna: opcja wyłączona

  • Zamykanie połączeń z klientami - deklaruje, czy stacja serwera będzie automatycznie zrywała połączenia ze stacjami zdalnymi w przypadku błędów komunikacji stwierdzonych w fizycznych kanałach komunikacyjnych stacji serwera; opcji nie należy używać, gdy w sieci jest tylko jeden serwer danych mający połączenie ze sterownikiem; opcja ta ma znaczenie tylko dla kanałów, które obsługują opcję Alarm w kanale.

Wartość domyślna: opcja włączona

  • Kanały poza pomostem - lista zawiera spis kanałów sieciowych, rozdzielonych przecinkami, do których klienci NIE BĘDĄ mogli się dołączyć; dotyczy to również klientów lokalnych;

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka 'Zaawansowane2'.

  • Limit odświeżania - określa odstęp czasu (w sekundach), z jakim stacja robocza chce otrzymywać z serwera danych wartości zmiennych procesowych należących do kanału o nazwie zdefiniowanej w polu Kanał. Zaleca się używać tę opcję przy komunikacji po wolnych łączach.

Wartość domyślna: wartości zmiennych procesowych są rozsyłane z okresem zgodnym z deklaracją zmiennej procesowej na serwerze danych

  • Priorytet - deklaracja priorytetów wątków NETSRVa:

  • 0 - THREAD_PRIORITY_NORMAL,

  • 1 - THREAD_PRIORITY_ABOVE_NORMAL,

  • 2 - THREAD_PRIORITY_HIGHEST.

Wartość domyślna: 0

  • Wątek połączeń - deklaracja użycia odrębnego wątku dla realizacji połączeń sieciowych;

Wartość domyślna: opcja włączona


4.7.3 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Diagnostyka:

Rysunek: Okno parametrów danych bieżących - serwera sieci - zakładka Diagnostyka.

  • Plik logu - deklaracja nazwy pliku logu z komunikatami diagnostycznymi NETSRV;

- Nazwa - Wartość domyślna: plik logu nie jest tworzony

- Maksymalny rozmiar - wartość domyślna: 1 MB; po przekroczeniu rozmiaru zadeklarowanego w opcji dotychczasowa zawartość pliku jest kasowana

Szczegóły na temat wymiana danych poprzez lokalną sieć komputerową można znaleźć w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Menedżer komunikacyjny ASMEN, Wymiana danych poprzez lokalną sieć komputerową.

  • Log telegramów z Aslinka - deklaracja zapisu komunikatów odbieranych z Aslinka do pliku logu, zadeklarowanego w powyższej pozycji Plik logu;

Wartość domyślna: opcja jest wyłączona


4.8 Konfiguracja danych archiwalnych

Grupa parametrów dane archiwalne ikonka Dane archiwalne obejmuje ustawienia pracy modułu Aspad, w tym parametry rejestracji i późniejszego odtwarzania przebiegów czasowych zmiennych.

Moduł Aspad pozwala na archiwizację zmiennych każdego typu dozwolonego w module Asmen, pod warunkiem, że są to zmienne skalarne. Mogą to być zarówno zmienne procesowe, jak i uzyskiwane w wyniku przeliczeń lub symulacji. W obecnej wersji nie można archiwizować tablic. Oprócz wartości i czasu przechowywany jest także status wartości zgodny ze standardem OPC. Dane gromadzone są zarówno w plikach o specjalnie zaprojektowanej strukturze (archiwum D, M, Y - podział na pliki odpowiednio dobowe, miesięczne lub roczne), jak i w bazach danych (archiwum B).

Szczegółowy opis możliwości funkcjonalnych modułu Aspad znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Program Archiwizacji Danych ASPAD.


4.8.1 Dane standardowe

Zakładka Standardowe pozwala określić następujące podstawowe parametry archiwizacji:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Standardowe'.

  • Symulacja - zaznaczenie tej opcji spowoduje pominięcie ładowania Aspada;

Wartość domyślna: Aspad jest ładowany

  • Powtarzanie szukania serwerów - określa po jakim czasie należy ponowić próbę szukania serwera dla zasobów Aspada, jeżeli dotychczasowe próby nie powiodły się;

Wartość domyślna: 60 sekund.

uwaga Dobór zbyt krótkiego czasu spowoduje zwielokrotnienie obciążenia sieci operacjami wyszukiwania nieistniejącego serwera. Duża wartość parametru spowoduje, że po włączeniu serwera do sieci nie zostanie on jeszcze przez długi czas zauważony.

  • Warunki - pozwala zdefiniować pliki zawierające warunki w sytuacji stosowania archiwizacji warunkowej.

Szczegółowy opis archiwizacji warunkowej znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Deklaracje warunków archiwizacji.

Przykłady warunków archiwizacji:

Archiwizuj, gdy bity 4. lub 8. zmiennej AAA zmieniły stan:

WARUNEK, BNE, @AAA, $@AAA, 0x110

Archiwizuj, gdy bit 0. zmiennej archiwizowanej zmienia stan z 0 na 1:

WARUNEK, BGT, @, $@, 0x1

Archiwizuj, gdy wartość zmiennej archiwizowanej jest poza przedziałem (20,80) i ustawiony jest jeden z bitów 0-3 zmiennej WWW:

W1, IN, @, <<, 20, 80, >>

W2, BAND, @WWW, 0xF

WARUNEK, AND, ?W1, ?W2

Archiwizuj w chwili, gdy wartość zmiennej archiwizowanej przekracza granicę 100:

W3, GT, @, 100

WARUNEK, AND, ?W3, !$?W3


4.8.2 Deklaracja czasu oczekiwania na zgloszenie serwerow

4.8.2 Deklaracja czasu oczekiwania na zgłoszenie serwerów

uwaga Zakładka Serwer profile pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Wyszukiwanie serwerów obejmuje następujące parametry:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Wyszukiwanie serwerów'.

  • Wyszukiwanie serwerów - określa jak długo należy czekać na zgłoszenia serwerów po zainicjowaniu poszukiwania:

  • Minimalny czas - określa jak długo czekać na odpowiedzi serwerów, niezależnie od tego, ile serwerów już się zgłosiło.

  • Maksymalny czas - podaje czas, po którym, w przypadku braku odpowiedzi jakiegokolwiek serwera, należy uznać, że w sieci nie został zainstalowany serwer dla danego zasobu.

  • Cykl powtarzania - opcjonalny parametr, który oznacza cykl, w którym należy ponawiać poszukiwanie serwera, jeżeli nie nadchodzi odpowiedź z żadnego serwera na poprzednie zapytania.

Wartość domyślna: odpowiednio 2 s, 10 s, 1 s

uwaga Zbyt mały parametr Minimalny czas może spowodować przyłączenie do pierwszego zgłaszającego się serwera, co uniemożliwi zastosowanie kryterium równomiernego obciążania serwerów.

Zbyt duży parametr Minimalny czas wydłuży oczekiwanie na nawiązanie połączenia z serwerem.

Zbyt mały parametr Maksymalny czas może uniemożliwić przyłączenie do istniejących serwerów.

Zbyt duży parametr Maksymalny czas wydłuży oczekiwanie na rozstrzygnięcie o braku serwera w sieci.


Deklaracja wersji plików archiwum standardowego

4.8.4. Deklaracja wersji plików archiwum standardowego

Zakładka Zaawansowane obejmuje następujące parametry:

powiększ >>

Rysunek: Widok okna deklarującego wersje plików archiwum standardowego.

  • Domyślna wersja plików archiwum standardowego - opcja definiuje domyślną wersję plików archiwum standardowego dla archiwów, w których nie zadeklarowano jej indywidualnie:

Wersja 1 - zgodna z wersjami Asix od 5.0 do 7.0 (Aspad 6 i 7).

Wersja 2 - dostępna od wersji Asix 7.1 (Aspad 8).

W wersji 2 archiwum obsługiwane są długie nazwy zmiennych, nazwy zmiennych zawierające znaki UNICODE oraz archiwizacja z pełną precyzją liczb typu Double i Int64.

OSTRZEŻENIE: Uruchomienie aplikacji przy użyciu Asixa w wersji 7.0 lub wcześniejszej z plikami archiwum w wersji 2 spowoduje uszkodzenie tych plików.

INFORMACJE DODATKOWE:

Nie wolno kopiować plików archiwum w wersji 2 do pakietów Asix wcześniejszych ni 7.1.

Odczyt sieciowy archiwum w wersji 2 przez wcześniejsze wersje pakietu Asix podlega pewnym ograniczeniom:

1. Nie są dostępne zmienne o długich nazwach.

2. Funkcje uzupełniania danych, replikacji archiwum, obiekt WYKRES oraz skrypty VBSScript i JScript w Asixie klasycznym:

- nie działają w pakiecie Asix 5.2 lub wcześniejszych,

- działają w pakietach Asix 6 i Asix 7.0 tylko pod warunkiem aktualizacji modułu Aspad, przy czym wydajność odczytu jest wtedy zmniejszona w stosunku do archiwum w wersji 1.


4.8.4 Parametry diagnostyczne

4.8.5 Parametry diagnostyczne

uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna modułu Architekt.

Zakładka Diagnostyka określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka'.

  • Nazwa pliku logu - określenie pliku, do którego ASPAD będzie wpisywał informacje diagnostyczne;

Wartość domyślna: domyślnie tworzony jest plik logu aspad.log

  • Ustawienia diagnostyki - pozwala określić, jakiego rodzaju informacje diagnostyczne będą zapisywane w pliku logu:

  • Diagnostyka operacji sieciowych,

  • Diagnostyka stref czasowych,

  • Diagnostyka zapytań modułu danych archiwalnych,

  • Diagnostyka agregacji - pozwala załączyć diagnostykę agregacji;

  • Diagnostyka modyfikacji online otrzymanych z bazy definicji zmiennych;

  • Diagnostyka uzupełniania archiwów;

  • Diagnostyka uzupełniania danych historycznych;

  • Diagnostyka odczytu agregatów na interfejsie sieciowym - określenie pliku, do którego ASPAD będzie wpisywał informacje diagnostyczne;

  • Diagnostyka modyfikacji on-line otrzymanych z bazy definicji zmiennych;

Wartość domyślna: opcja wyłączona


4.8.5. Sledzenie probkowanych wartosci

4.8.6. Śledzenie próbkowanych wartości

Zakładka Diagnostyka - śledzenie określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka - śledzenie'.

  • Śledzenie próbkowanych wartości - opcja powoduje, że dla zadanej zmiennej wyprowadzane są do pliku logu (zadanego w deklaracji Nazwa pliku logu) komunikaty o wartościach, które moduł danych archiwalnych ASPAD otrzymał ze źródła danych;

- Podanie samej nazwy zmiennej powoduje śledzenie wszystkich zdarzeń dla danej zmiennej i jej agregatów;

- Podanie nazwy i typu archiwum oddzielonych przecinkiem (np. "A000,D") powoduje śledzenie tylko podanego typu archiwum zmiennej, bez śledzenia innych archiwów i agregatów;

- Podanie nazwy z pełną specyfikacją agregatu (tak jak pojawia się w logach, np. " A000,M-1m-Avg) powoduje śledzenie tylko tego agregatu.

Wartość domyślna: brak zadeklarowanych pozycji

uwaga W obecnej wersji można w ten sposób śledzić tylko zmienne typu zmiennoprzecinkowego.


4.8.6. Debugowanie zapytań

4.8.7. Debugowanie zapytań

Zakładka Diagnostyka - debug określa:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Diagnostyka - debug'.

  • Debugowanie zapytań - opcja załącza wpisywanie do logu informacji o zapytaniach modułu sieciowego dla zmiennych debugowanych;

Wartość domyślna: opcja wyłączona

  • Zmienne debugowane - opcja umożliwia deklarowanie zmiennych debugowanych;

- Podanie samej nazwy zmiennej powoduje śledzenie wszystkich zdarzeń dla danej zmiennej i jej agregatów;

- Podanie nazwy i typu archiwum oddzielonych przecinkiem (np. "A000,D") powoduje śledzenie tylko podanego typu archiwum zmiennej, bez śledzenia innych archiwów i agregatów;

- Podanie nazwy z pełną specyfikacją agregatu (tak jak pojawia się w logach, np. " A000,M-1m-Avg) powoduje śledzenie tylko tego agregatu.

Wartość domyślna: brak zadeklarowanych zmiennych


4.8.7 Parametryzacja cyklicznego pobierania danych

4.8.8 Parametryzacja cyklicznego pobierania danych historycznych dla wybranych drajwerów komunikacyjnych

Niektóre drajwery systemu A six umożliwiają pobieranie przez aplikację brakujących danych historycznych z urządzeń (które same w sobie archiwizują wartości pomiarów) lub z zewnętrznej bazy danych. Dane historyczne udostępniane są przez następujące drajwery: Baza, DMS285, DMS500, Talas, Macmat, DataPAF, Mevas.

Parametryzacja sposobu pobierania danych historycznych odbywa się przy użyciu opcji znajdujących się na zakładce Pobieranie danych historycznych:

powiększ >>

Rysunek: Okno parametrów danych archiwalnych - zakładka 'Pobieranie danych historycznych'.

  • Czas pierwszego pobierania - opcja ta określa, po jakim czasie od rozpoczęcia bieżącej archiwizacji należy wystartować pierwsze wypełnianie dziur;

Wartość domyślna: 10 sekund

uwaga W procesie uzupełniania danych potrzebna jest informacja o tym, jaka jest długość dziury w archiwum wynikłej z ostatniego wyłączenia archiwizacji; dla uzyskania tej informacji niezbędne jest pozyskanie pierwszego punktu po tej dziurze; czas zadany w tym miejscu ma pozwalać na pozyskanie pierwszej danej dla każdej zmiennej.

  • Okres pobierania - pozwala określić, jak często należy włączać uzupełnianie dziur w archiwum:

  • Długość cyklu i Faza cyklu - są to parametry, które określają częstotliwość prób uzupełniania dziur w archiwum – np.: 5m, 30s oznacza, że 30 sekund po każdych pełnych pięciu minutach nastąpi próba wypełniania dziur w archiwum;

Wartość domyślna: dla długości cyklu równej 1 godzina i fazy cyklu 5 minut uzupełnianie archiwum będzie miało miejsce 5 minut po każdej pełnej godzinie; długość cyklu liczona jest według czasu UTC.

  • Horyzont wypełniania dziur - to dodatkowy, opcjonalny parametr, który określa jak daleko wstecz należy próbować uzupełnić dane historyczne; horyzont ten nie jest uzależniony od tego, czy próba uzupełniania była już wcześniej przeprowadzona; jest to potrzebne w przypadku źródeł danych, w których dane historyczne mogą pojawić się z opóźnieniem; w przypadku braku tego parametru - brak danych historycznych w źródle danych powoduje, że zostają zaniechane próby ich ponownego odzyskania;

Wartość domyślna: brak


4.8.9 Parametryzacja archiwum

W przypadku stosowania archiwizacji wartości zmiennych niezbędne jest zadeklarowanie archiwum.

Archiwum deklarowane jest za pomocą polecenia Dodaj archiwum... po kliknięciu prawym klawiszem myszki na pozycji Dane archiwalne. Pojawia się wówczas okno ’Dodawanie nowego archiwum’, gdzie należy określić nazwę archiwum.

powiększ >>

Rysunek: Wywołanie okna 'Dodawanie nowego archiwum'.

Aspad gromadzi dane w plikach zawierających przebiegi z jednego okresu dobowego, miesięcznego lub rocznego odpowiednio do typu archiwum:

Archiwum typu D (ang. day) - dane gromadzone w plikach dobowych;

Archiwum typu M (ang. month) - dane gromadzone w plikach miesięcznych;

Archiwum typu Y (ang. year) - dane gromadzone w plikach rocznych;

Archiwum typu H (ang. horizon) - dane gromadzone w jednym pliku;

Archiwum typu B (Baza Danych) - dane gromadzone w typowych bazach danych;

Archiwum typu P (ang. pattern) - dane wzorcowe;

Podstawowym rodzajem archiwum jest STANDARD. Archiwum to jest zapisywane w binarnych plikach na dysku.

Drugim rodzajem archiwum jest MS SQL. Jest to archiwum zapisywane w bazie danych SQL.

Można jeszcze wyróżnić podział archiwum ze względu na sposób udostępniania danych:

Archiwum do zapisu - podstawowe archiwum pozwalające na zapis i odczyt danych z plików archiwalnych;

Archiwum do odczytu - to archiwum pozwalające tylko na odczyt danych z plików archiwalnych;

Archiwum sieciowe - to archiwum pozwalające na odczyt danych przez sieć z innego komputera;

Archiwum pomocnicze - to archiwum pozwalające na zapis i odczyt danych, służące jako redundancja archiwum podstawowego na innym komputerze;

Archiwum replikowane - to archiwum pozwalające na zapis i odczyt danych z archiwum; dane do archiwum pobierane są z archiwum innego komputera.

Aby skonfigurować archiwum przy użyciu modułu Architekt, należy zaznaczyć w drzewie parametrów aplikacji pozycję Dane archiwalne i kliknąć prawym klawiszem myszki - a następnie wybrać polecenie Dodaj archiwum.

Po kliknięciu na utworzonym archiwum w oknie konfiguracji parametrów pojawią się zakładki, umożliwiające skonfigurowanie danego archiwum.

Archiwum pomocnicze jest to archiwum do zapisu umieszczane na serwerze pomocniczym danego zasobu. Archiwum pomocnicze powinno stanowić redundancję archiwum podstawowego na serwerze podstawowym. Różnica między archiwum pomocniczym a archiwum podstawowym polega na preferencjach dla archiwum podstawowego podczas przyłączania klientów sieciowych. Klient przyłączy się do archiwum pomocniczego tylko wtedy, gdy w sieci nie znajdzie archiwum podstawowego.

Archiwum pomocnicze jest stosowane w celu zapewnienia tymczasowej redundancji na czas konserwacji lub awarii serwera podstawowego. Można np. zadeklarować archiwum podstawowe ze 100-dniowym horyzontem i archiwum pomocnicze z horyzontem 10-dniowym. Pozwoli to na uzupełnienie archiwum podstawowego za okres przerwy nie przekraczającej 10 dni, przy czym w obecności serwera podstawowego klienty przyłączą się do niego, zapewniając obserwację danych z horyzontem 100-dniowym.

Archiwum replikowane ma zastosowanie na serwerach, na których Asmen nie posiada kanałów fizycznych dla danych archiwizowanych w danym zasobie, a równocześnie w sieci dostępne jest inne archiwum, z którego można pozyskać dane historyczne. Dla archiwum replikowanego Aspad nie pobiera danych bieżących z Asmena. W zamian stale pozyskuje dane historyczne z innego serwera, na którym archiwizowane są dane z kanałów fizycznych, zapisując je we własnym archiwum. Typowym zastosowaniem będą serwery pośredniczące.

Sposób działania nieco się różni dla archiwum standardowego i SQL.

Archiwum standardowe

Dla archiwum standardowego Aspad po uzupełnieniu danych przy starcie systemu, kontynuuje to uzupełnianie, cyklicznie sprawdzając nowe dane pojawiające się na drugim serwerze. Nawet dłuższe przerwy w komunikacji są na bieżąco nadrabiane po uzyskaniu łączności, aż do ograniczenia podanego w deklaracji Minimalny okres uzupełniania na zakładce Uzupełnianie w parametrach danego archiwum.

Także na wspomnianej zakładce Uzupełnianie można określić nazwy serwerów, z których mają być pobierane dane do replikacji.

Deklaracja Bez uzupełniania na zakładce Uzupełnianie dla takiego archiwum nie ma sensu i jest ignorowana.

Archiwum SQL

Jeżeli dla danego zasobu nie podano deklaracji synchronizacji archiwum SQL, to archiwum replikowane działa tak samo, jak standardowe.

Jeżeli podano deklarację SYNCHRO, to dane są tylko synchronizowane na poziomie baz danych SQL, a wyłączone jest zarówno pobieranie danych bieżących z Asmena, jak i uzupełnianie przez Aslinka, tak jakby zadeklarowano opcję Bez uzupełniania na zakładce Uzupełnianie w parametrach danego archiwum.

Synchronizacja ma tę przewagę nad zwykłym uzupełnianiem, że uwzględnia wszystkie zmiany w archiwum, także dane historyczne dopisywane lub zmieniane z opóźnieniem.


4.8.8.1 Parametry standardowe

4.8.9.1 Parametry standardowe

Zakładka Standardowe obejmuje następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Standardowe'.

  • Archiwum:

  • Nazwa - nazwa logiczna archiwum (zasobu);

Wartość domyślna: Archiwum1

  • Typ archiwum ze względu na sposób udostępniania danych:

(archiwum lokalne):

’Archiwum do zapisu’

’Archiwum do odczytu’

’Archiwum pomocnicze’

’Archiwum replikowane’

lub

’Archiwum sieciowe’

Wartość domyślna: ’Archiwum do zapisu’

  • Rodzaj archiwum:

’STANDARD’

’MS SQL’

Wartość domyślna: ’STANDARD’

Archiwa STANDARD

Archiwa STANDARD wymagają podania dodatkowych parametrów, których prawidłowe określenie ułatwia okno uruchamiane przyciskiem rozwin 2:

Rysunek: Okno parametryzacji archiwów STANDARD.

  • Kartoteka archiwum - względna lub bezwzględna ścieżka do kartoteki, w której będą gromadzone pliki archiwalne;

Wartość domyślna: brak

  • Okres przechowywania plików archiwalnych - okres przechowywania plików archiwalnych odpowiednio typu D, M, Y, przy czym:

min określa liczbę dni, po zakończeniu okresu danego pliku, przez które nie wolno automatycznie kasować pliku, nawet gdy brak miejsca na dysku (domyślnie 1),

max określa liczbę dni, po których plik należy usunąć (domyślnie 0, co jest interpretowane jako nieskończoność).

  • Okres przechowywania danych archiwalnych [dni] - okres przechowywania danych archiwalnych archiwum typu H, przy czym:

min określa minimalną liczbę dni przechowywania danych,

max określa liczbę dni przechowywania danych (0 interpretowane jest jako nieskończoność).

uwaga UWAGA: Deklaracja ma pierwszeństwo przed deklaracjami poszczególnych zmiennych w bazie definicji zmiennych. Jeśli wartość minimalna jest większa lub maksymalna mniejsza niż wartość podana w bazie, to użyta będzie wartość podana w edytorze.

Archiwa MS SQL

Archiwa MS SQL wymagają podania dodatkowych parametrów, których prawidłowe określenie ułatwia okno uruchamiane przyciskiem rozwin 2:

Rysunek: Okno parametryzacji archiwów MS SQL.

  • Nazwa_serwera - względna lub bezwzględna ścieżka do kartoteki, w której będą gromadzone pliki archiwalne;

nazwa instancji serwera SQL, na którym znajduje się lub zostanie utworzona baza danych; jeżeli ten parametr jest pusty, to zostanie wykorzystany lokalny serwer (istnieje też możliwość deklaracji serwera LOCAL, co jest równoważne pustej nazwie serwera w deklaracji archiwum);

nazwa instancji ma postać:

nazwa_systemowa_komputera - dla podstawowej instancji serwera lub

nazwa_systemowa_komputera\nazwa_instancji - dla nazwanej instancji;

Wartość domyślna: brak

  • Baza danych - nazwa bazy danych po stronie serwera; jeżeli ten parametr jest pusty, to nazwa bazy danych = ASSQL_nazwa_zasobu;

ta nazwa nie może się powtarzać dla różnych archiwów na tym samym serwerze SQL, ale może się powtarzać w różnych deklaracjach, jeżeli dotyczą one wielu serwerów

Wartość domyślna: brak

  • Parametry opcjonalne:

-XT, +XT - archiwizacja czasu danej - określa, czy w bazie danych będzie archiwizowany czas dokładny danej (+XT), czy też jedynie czas zaokrąglony do pełnego cyklu próbkowania (-XT) (wyjątkiem są dane, dla których zadeklarowano atrybut KAŻDY - dla takich danych czas nie jest zaokrąglany do cyklu próbkowania);

włączenie opcji powoduje dodanie 8-bajtowego pola do każdego rekordu danych;

Wartość domyślna: +XT - czas jest archiwizowany;

-WT, +WT - archiwizacja czasu dokonania zapisu - określa, czy w bazie danych będzie archiwizowany czas dokonania zapisu;

włączenie opcji powoduje dodanie 8-bajtowego pola do każdego rekordu danych;

Wartość domyślna: -WT - czas zapisu jest pomijany;

-VT, +VT - archiwizacja czasu ważności próbki - określa, czy w bazie danych będzie archiwizowany czas ważności próbki (+VT), czy też na być pomijany, a domyślnym czasem ważności ma być okres archiwizacji (-VT); w efekcie, dla -VT, gdy zostanie w przyszłości skrócony okres archiwizacji, to dane historyczne będą oddzielone dziurami; domyślnie czas ważności jest archiwizowany;

włączenie opcji powoduje dodanie 4-bajtowego pola do każdego rekordu danych;

Wartość domyślna: +VT - czas ważności jest archiwizowany;

-SV, +SV - liczba bajtów identyfikatora przebiegu - określa, czy identyfikator przebiegu zmiennej ma mieć 2 (+SV), czy 4 (-SV) bajty; dla +SV baza danych nie może zawierać więcej niż 32767 zmiennych na zasób (wlicza się w to zmienne kiedyś zadeklarowane, później usunięte);

wyłączenie opcji powoduje, dla każdego rekordu danych, zwiększenie pola identyfikatora przebiegu o 2 bajty w danych i o 2 bajty w indeksie bazy;

Wartość domyślna: +SV - używane są małe identyfikatory;

-SD, +SD - liczba bajtów identyfikatora rekordów - określa, czy identyfikator rekordu danych ma mieć 4 (+SD), czy 8 (-SD) bajtów; dla +SD do bazy nie można zapisać więcej niż 2 miliardów (231) rekordów danych na zasób (wlicza się w to każdy zapis i zmianę rekordu nawet, gdy zostanie on usunięty);

wyłączenie opcji powoduje, dla każdego rekordu danych, zwiększenie pola identyfikatora rekordu o 4 bajty w danych i o 4 bajty w indeksie bazy;

Wartość domyślna: +SD - używane są małe identyfikatory.

uwaga Dla baz danych zadeklarowanych jako MSSQL rekord zawiera dla każdej próbki domyślnie wartość, jakość, czas cyklu, czas dokładny, czas zapisu rekordu i okres ważności próbki. Tylko czas cyklu należy do klucza bazy danych. Trzy pierwsze pola są obowiązkowe.

uwaga Dla raz utworzonej bazy danych nie wolno zmieniać pól opcjonalnych w deklaracji, gdyż nie będą one wtedy odpowiadały strukturze tablic bazy danych.

  • Okres przechowywania danych archiwalnych [dni] - okres przechowywania danych archiwalnych archiwum typu H, przy czym:

min określa minimalną liczbę dni przechowywania danych,

max określa liczbę dni przechowywania danych (0 interpretowane jest jako nieskończoność).

uwaga UWAGA: Deklaracja ma pierwszeństwo przed deklaracjami poszczególnych zmiennych w bazie definicji zmiennych. Jeśli wartość minimalna jest większa lub maksymalna mniejsza niż wartość podana w bazie, to użyta będzie wartość podana w edytorze.

Archiwa sieciowe

Archiwa sieciowe wymagają podania stacji, do których wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego lub odczycie archiwum zdalnego. Deklaracja stacji odbywa się za pomocą okno uruchamianego przyciskiem rozwin 2:

Rysunek: Okno deklaracji stacji przy odczycie archiwum zdalnego.

  • Komputery:

’Wszystkie’

’Tylko z listy’

’Wszystkie za wyjątkiem listy’

  • Lista nazw sieciowych serwerów danych - pozwala zadeklarować stacje, z których nie można sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego lub odczycie archiwum zdalnego.

Wartość domyślna: ’Wszystkie’

  • Czas UTC - deklaracja determinuje archiwizowanie zasobu zgodnie z czasem UTC;

uwaga Jeżeli deklarujemy takie zasoby, to ustawienia systemowe strefy czasowej MUSZĄ zawierać poprawną strefę z zaznaczoną automatyczną zmianą czasu letniego/zimowego. W przeciwnym razie czas będzie zapisywany niepoprawnie.

Jeżeli w już archiwizowanym zasobie deklarujemy Czas UTC, to trzeba skonwertować dotychczasowe archiwum. Dla archiwum standardowego można to wykonać przy pomocy specjalnej funkcji AspadTools. Trzeba pamiętać o sekwencyjnym przetwarzaniu plików archiwalnych - najlepiej konwertując wszystkie jednym poleceniem.

Gdy nie zostanie zadeklarowany czas UTC, to komunikacja pomiędzy ASPADami odbywa się w czasie lokalnym i nie jest wrażliwa na niewłaściwe ustawienia stref czasowych.

Jeżeli na serwerze zadeklarowano czas UTC, to na kliencie też musi zostać zadeklarowany czas UTC.

Przykłady deklaracji archiwum MS SQL:

Deklaracja archiwum do zapisu dla zasobu MojeArchiwum, na lokalnym serwerze, w bazie danych ASSQL_MojeArchiwum, bez archiwizacji czasu zapisu rekordu:

Archiwum do zapisu

Nazwa: ’MojeArchiwum’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: -

Baza danych: -

Deklaracja archiwum do zapisu dla zasobu MojeArchiwum, na lokalnym serwerze, w bazie danych MojeArchiwum, bez archiwizacji czasu zapisu rekordu:

Archiwum do zapisu

Nazwa: ’MojeArchiwum’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: -

Baza danych: ’MojeArchiwum’

Deklaracja archiwum do odczytu dla zasobu ’ArcSrv1’, na serwerze ’Srv1’, w bazie ’ASSQL_Arc’ z pełnym rekordem:

Archiwum do odczytu

Nazwa: ’ArcSrv1’

Rodzaj archiwum: ’MS SQL’

Nazwa serwera: ’Srv1’

Baza danych: ’ASSQL_Arc’

Archiwizacja czasu dokonania zapisu: R


4.8.8.2 Parametry archiwizacji agregatow

4.8.9.2 Parametry archiwizacji agregatów

Zakładka Agregaty umożliwia parametryzację Agregatora - modułu systemu A six przeznaczonego do wyliczania i archiwizacji danych statystycznych. Domyślnie funkcja jest załączona z rekomendowanymi ustawieniami.

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Agregaty'.

  • Lista okresów - pole umożliwia zadeklarowanie listy okresów agregacji, będących podstawą wyliczania wartości zagregowanych; wartości okresów należy deklarować w konwencji modułu Aspad, oddzielając je pionowymi liniami, np.: 5m|1h stanowi podstawę wyliczania agregatów 5-minutowych i 1-godzinnych;

  • Lista agregatów - pole, w którym należy określić agregaty, które będą wyliczane i archiwizowane; po rozwinięciu pola pojawia się okno umożliwiające selekcję agregatów z listy agregatów dostępnych w systemie A six;

  • Horyzont agregacji - oznacza okres, z którego dane będą agregowane; wartość horyzontu należy deklarować w konwencji modułu Aspad, np.: 366d - oznacza, że nie będą archiwizowane dane starsze niż rok.

Przycisk Ustaw wartości rekomendowane pozwala ustawić okresy danych 1m,1h oraz wszystkie agregaty. Wymienione opcje ustawiane są domyślnie przy tworzeniu nowego archiwum.


4.8.8.3 Zarzadzanie uzupelnianiem danych

4.8.9.3 Zarządzanie uzupełnianiem danych

Zakładka Uzupełnianie pozwala określić następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Uzupełnianie'.

  • Bez uzupełniania - włączenie opcji spowoduje zakaz uzupełniania danych dla danego archiwum (zasobu);

Wartość domyślna: opcja wyłączona

  • Ograniczenia uzupełniania - pozwala zawęzić listę stacji, z których Aspad będzie uzupełniał dane; pod warunkiem, ze opcja Bez uzupełniani jest wyłączona:

  • Uzupełniaj dane tylko z serwerów wymienionych na liście - lista nazw stacji, do których wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego; pominięcie tej deklaracji oznacza akceptację dowolnego serwera dysponującego określonym zasobem.

  • Uzupełniaj dane ze wszystkich stacji za wyjątkiem wymienionych na liście - lista nazw stacji, do których nie wolno sięgać po dane dla zasobu przy uzupełnianiu archiwum lokalnego.

Wartość domyślna: dane uzupełniane są z dowolnego serwera dysponującego danym zasobem

  • Minimalny okres uzupełniania - używając opcji można wydłużyć okres czasu, z którego archiwa mają być uzupełniane.

Wartość domyślna: uzupełniany jest bieżący i poprzedni plik archiwum.


4.8.8.4. Zarzadzanie odczytem danych

4.8.9.4. Zarządzanie odczytem danych

Zakładka Zarządzanie pozwala określić następujące parametry:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Zarządzanie'.

  • Ograniczenie odczytu - opcja pozwala ustalić tryb pracy, w którym określone stacje mogą korzystać z danego archiwum:

Tryb pracy:

  • Tylko stacje wymienione na liście mogą korzystać z tego archiwum;

  • Wszystkie stacje oprócz wymienionych na liście mogą korzystać z danego archiwum;

Nazwy sieciowe stacji należy wpisać, oddzielając je przecinkami.

Wartość domyślna: nie ma ograniczeń dotyczących odczytu.


4.8.8.5 Parametry okreslajace sposob tworzenia kopii zapasowej

4.8.9.5 Parametry określające sposób tworzenia kopii zapasowej archiwum

Zakładka Kopia dotyczy opcji:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Kopia'.

  • Kopia - parametryzuje sposób tworzenia kopii zapasowych:

Wartość domyślna: kopia zapasowa nie jest tworzona

  • Ścieżka do katalogu archiwum lub nazwa archiwum - pozwala zadeklarować bezpośrednio katalog docelowy, w którym będzie tworzona kopia archiwum, bądź też dla zachowania kompatybilności ze starszą formą deklarowania kopii zapasowych - nazwę archiwum, w którym tworzona będzie kopia zapasowa (wcześniejsza forma deklarowania kopii zapasowej zakładała bowiem utworzenie dodatkowego archiwum pomocniczego, które następnie deklarowane było jako miejsce docelowe tworzenia kopii zapasowej innego archiwum); aktualnie w przypadku wyboru archiwum po nazwie możliwy jest wybór wszystkich archiwów standardowych, a nie tylko pomocniczych.

Wartość domyślna: brak

  • Długość cyklu - zadaje jak często inicjować tworzenie kopii zapasowych;

Wartość domyślna: 1 dzień

Rysunek: Pole deklaracji długości cyklu inicjowania tworzenia kopii zapasowych.

  • Faza cyklu - określa, z jakim opóźnieniem w stosunku do pełnego cyklu inicjować tworzenie kopii;

Wartość domyślna: 1 godzina i 30 minut

  • Typ i liczba kopiowanych plików - pozwala określić, jakiego typu pliki należy kopiować i ile ostatnich plików danego typu kopiować:

  • Pliki archiwum dobowego (D),

  • Pliki archiwum miesięcznego (M),

  • Pliki archiwum rocznego (Y),

  • Pliki archiwum z horyzontem.

Wartość domyślna: brak deklaracji typu

uwaga Dla jednego zasobu można zadeklarować kilka archiwów, do których tworzone będą kopie - co pozwala np. na kopiowanie plików dobowych w inne miejsce niż miesięcznych.


4.8.8.6 Deklaracja synchronizacji zawartosci archiwum typu B z

4.8.9.6 Deklaracja synchronizacji zawartości archiwum typu B z danymi w bazie MS SQL

uwaga Synchronizacja powoduje kopiowanie przyrostowe. Kopiowane są tylko dane, które zostały dopisane lub zmienione w archiwum źródłowym od ostatniego kopiowania. W przypadku konfliktu z już istniejącymi danymi w archiwum docelowym znajdą się dane o lepszej jakości. W przypadku danych o tej samej jakości preferowane są dane wprowadzane ręcznie.

Można podać wiele deklaracji synchronizacji, także dla jednego zasobu, co pozwala np. na uzupełnianie danych z kilku bliźniaczych serwerów.

Deklaracja synchronizacji archiwum MS SQL z danymi innego archiwum wymaga podania w parametrach synchronizacji (w parametrach archiwum, którego zawartość będzie synchronizowana) nazwy serwera SQL, z którego będą pobierane dane do synchronizacji. Wymagane jest przy tym, aby nazwy obu baz danych były identyczne.

Deklaracji takiej dokonuje się na zakładce Synchronizacja:

powiększ >>

Rys. Okno parametrów archiwum - zakładka 'Synchronizacja'.

  • Nazwa archiwum lub serwera SQL - nazwa serwera SQL, z którego będą pobierane dane do synchronizacji lub nazwa archiwum, z którego pobierane będą dane do synchronizacji w przypadku deklaracji dodatkowego 'wirtualnego' archiwum, gdy nazwy baz danych (archiwum synchronizowanego i archiwum, z którym realizowana jest synchronizacja) różnią się - poniżej patrz przypadek z nazwą archiwum;

Wartość domyślna: brak deklaracji synchronizacji.

  • Synchronizacja przy starcie systemu - włączenie tej opcji powoduje jednorazową synchronizację przy starcie systemu.

  • Synchronizacja cykliczna - włączenie tej opcji powoduje synchronizację cykliczną.

  • długość cyklu - określa, jak często inicjować dopisywanie danych; w przypadku, gdy jako parametr cykl zostanie podana wartość 0, synchronizacja nie będzie wykonywana cyklicznie, a wówczas przedmiotowa deklaracja będzie wykorzystywana tylko jako deklaracja dla akcji operatorskiej SYNCHRONIZUJ_ARCHIWUM; wartość domyślna parametru cykl: 24 godz.;

  • faza cyklu - określa, z jakim opóźnieniem w stosunku do pełnego cyklu inicjować kopiowanie danych; wartość domyślna: 0.

  • Archiwum master - opcja powoduje, że przy zapisie do takiego archiwum na komputerze, na którym podano tę opcję, dane opatrywane są dodatkowym statusem AS_STAT_MASTER. Dla każdego archiwum na co najwyżej jednym z komputerów w sieci można podać taka opcję. Przy synchronizacji dane opatrzone statusem AS_STAT_MASTER są traktowane jako ważniejsze niż dane o tej samej jakości, ale bez tego statusu. Dzięki temu synchronizacja nie tylko wypełnia dziury w archiwum oraz zastępuje dane o gorszym statusie tymi o lepszym, ale także uzgadnia rekordy o różnych wartościach, a tej samej jakości, preferując dane z archiwum MASTER.

Rysunek: Przykład deklaracji synchronizacji archiwum X z archiwum Y przy założeniu identycznych nazw baz danych obu archiwów.

W sytuacji gdy nazwy baz danych obu archiwów różnią się, dla stacji operatorskiej której archiwum będzie synchronizowane należy skonfigurować dodatkowe 'wirtualne' archiwum do odczytu, ze wskazaniem nazwy serwera i nazwy bazy danych MS SQL archiwum, z którym dane mają być synchronizowane (pozostałe parametry w konfiguracji 'wirtualnego' archiwum nie mają znaczenia).

Rysunek: Przykład deklaracji synchronizacji archiwum X z archiwum Y przy założeniu rożnych nazw baz danych obu archiwów.


4.8.8.7. Deklaracja wartosci o okreslonym_statusie

4.8.9.7. Deklaracja wartości o określonym statusie

Zakładka Zaawansowane pozwala skonfigurować archiwizację wartości w zależności od statusu:

powiększ >>

Rysunek: Okno parametrów archiwum - zakładka 'Zaawansowane'.

  • Zapis wartości o określonym statusie - określa status wartości, które będą archiwizowane

Wartość domyślna: domyślnie archiwizowane są tylko wartości o statusie dobrym.

  • Domyślna wersja plików archiwum standardowego - opcja definiuje wersję plików archiwum standardowego dla bieżącego archiwum:

Wersja 1 - zgodna z wersjami Asix od 5.0 do 7.0 (Aspad 6 i 7).

Wersja 2 - dostępna od wersji Asix 7.1 (Aspad 8).

W wersji 2 archiwum obsługiwane są długie nazwy zmiennych, nazwy zmiennych zawierające znaki UNICODE oraz archiwizacja z pełną precyzją liczb typu Double i Int64.

OSTRZEŻENIE: Uruchomienie aplikacji przy użyciu Asixa w wersji 7.0 lub wcześniejszej z plikami archiwum w wersji 2 spowoduje uszkodzenie tych plików.

INFORMACJE DODATKOWE:

Sprawny odczyt sieciowy archiwum w wersji 2 w obiektach Wykres, Skryptach oraz uzupełnianiu danych lub replikacji jest możliwy tylko przy użyciu Aspada 8 (Asix 7.1) lub nowszego.

W Asixie 5.2 lub starszym odczyt sieciowy archiwum w wersji 2 nie jest możliwy.

W pozostałych wersjach Asixa konieczna jest aktualizacja Aspada dedykowana dla danego pakietu, a wydajność odczytu będzie zmniejszona.

Obniżenie wydajności przy łączeniu się starszych Aspadów z nowym np. przy replikacji lub uzupełnianiu, wynika z tego, że nie mogą wtedy przesyłać danych w postaci skompresowanej, a tylko po dekompresji, co powoduje zmniejszoną wydajność operacji sieciowych. Jeszcze starsze Aspady (z Asixa 5.2) nie potrafią w tej sytuacji przesyłać ani danych skompresowanych, ani zdekompresowanych.

W przypadku programów: AsixConnectowi i Trendom jest wszystko jedno, czy łączą się z Aspadem 7 czy 8 i czy archiwum jest w wersji 1 czy 2.


4.8.9. Zarzadzanie_ archiwami

4.8.9. Zarządzanie archiwami

W menu uruchamianym po kliknięciu prawym klawiszem myszki na pozycji Dane archiwalne dostępne jest również polecenie Zarządzaj archiwami, umożliwiające masowe kopiowanie, usuwanie archiwów pomiędzy komputerami/obszarami oraz zmiana typu archiwum (do zapisu, do odczytu, pomocnicze, sieciowe).

powiększ >>

Rysunek: Okno 'Zarządzanie archiwami'.


4.9 Konfiguracja systemu alarmow

4.9 Konfiguracja systemu alarmów

System A six posiada wbudowany, elastyczny system obsługi alarmów, który pozwala na pełne zaspokojenie potrzeb związanych z kompleksową obsługą sytuacji awaryjnych i zdarzeń w procesie technologicznym.

Opis systemu alarmów znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale System alarmów.

Ogólnie system alarmów można podzielić na dwie części:

  • jądro systemu, które odpowiedzialne jest za wykrywanie, zapamiętywanie i definicje alarmów;

  • cześć wizualizacyjną, którą stanowią dwa typy masek alarmowych (alarmów aktywnych i historycznych).

Konfiguracja jądra systemu opiera się na odpowiednim zdefiniowaniu parametrów w pliku konfiguracyjnym XML aplikacji oraz na utworzeniu plików tekstowych zawierających dodatkowe informacje.

Dodatkowe parametry określane są w plikach tekstowym. Są to:

  • pliki definicji alarmów,

  • pliki definicji grup,

  • pliki definicji limitów.

Zamiast wspomnianych wyżej plików tekstowych, definicje alarmów i definicje grup można przygotować w arkuszu kalkulacyjnym Excel i na jego podstawie wygenerować bazę definicji alarmów (patrz: 4.9.1.1 . Przygotowanie definicji alarmów i grup alarmów w arkuszu kalkulacyjnym Excel).

Bieżący stan oraz historia alarmów przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowane inne rozwiązanie). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można ograniczyć okres przechowywania plików alarmów.

Większość parametrów dotyczących alarmów konfigurowana jest przez moduł Architekt w grupie parametrów aplikacji: system alarmów System alarmów.


4.9.1 Okreslenie trybu tworzenia bazy definicji alarmow

4.9.1 Określenie trybu tworzenia bazy definicji alarmów

Tryb pracy bazy definicji alarmów określany jest w:

moduł Bazy danych > Baza definicji alarmów > zakładka Typ

Definicje alarmów w systemie A six tworzone są w plikach tekstowych (przygotowanych przez projektanta lub wygenerowanych z arkusza kalkulacyjnego). Istnieje też możliwość wygenerowania bazy definicji alarmów - w formacie bazy SQL lub MDB (Jet/MS Access) jako elementu bazy definicji zmiennych.

Uwaga: Jeśli baza definicji zmiennych nie istnieje - tworzony jest szablon pustej bazy definicji zmiennych.

Wymaga to załączenia opcji Baza definicji alarmów jest generowana z arkusza kalkulacyjnego na zakładce Typ wraz z opcją Dodaj bazę definicji alarmów do bazy definicji zmiennych na zakładce Źródła danych, a następnie wskazania na zakładce Źródła danych arkusza kalkulacyjnego z definicjami alarmów i definicjami grup alarmów oraz obszaru/komputera identyfikującego nazwę sieciową zestawu alarmów.

Definicje alarmów przechowywane w bazie definicji zmiennych wykorzystywane są przez programy: AsAlarm, AsTrend oraz AsRaport - środowisko tworzenia raportów w technologii MS Reporting Services.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Typ'.

  • Jeśli tekstowe pliki definicji alarmów są edytowane przez projektanta - nazwy tych plików należy zadeklarować w oknie definiowania parametrów obszarów i komputerów, w module System alarmów na zakładce Alarmy / Baza definicji alarmów. Dodatkowo, można wygenerować na ich podstawie bazę definicji alarmów, która domyślnie zostanie dołączona do bazy definicji zmiennych - należy w tym celu w oknie definiowania baz danych, w kategorii Baza definicji alarmów, na zakładce Źródła danych wskazać pliki tekstowe z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący nazwę sieciową zestawu alarmów i wykonać operację generowania bazy z pomocą przycisku Generuj.

Rys. Generowanie bazy definicji alarmów z plików tekstowych.

  • Jeśli baza generowana jest z arkuszy kalkulacyjnych - definicje alarmów i grup alarmów umieszczane są w plikach tekstowych o rozszerzeniach - odpowiednio: .gdf i .adf. Pliki te automatycznie ładowane są na starcie aplikacji systemu asix. Możliwe jest tez dołączenie wygenerowanych definicji alarmów i grup alarmów do bazy definicji zmiennych. Na zakładce Źródła danych należy wskazać pliki tekstowe z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący nazwę sieciową zestawu alarmów i wykonać operację generowania bazy z pomocą przycisku Generuj (pamiętając o załączeniu opcji Dodaj bazę definicji alarmów do bazy definicji zmiennych w razie potrzeby).

Rys. Generowanie bazy definicji alarmów z arkuszy kalkulacyjnych.

  • W przypadku generowania zbiorczej bazy definicji alarmów na podstawie baz z aplikacji konfigurowanych plikiem XML lub INI (w starszych wersjach systemu Asix) - zbiorcza baza definicji alarmów zostanie domyślnie dołączona do bazy definicji zmiennych.

Rys. Generowanie bazy definicji alarmów z kilku baz.


4.9.1.1 Przygotowanie definicji alarmow i grup alarmow w

4.9.1.1 Przygotowanie definicji alarmów i grup alarmów w arkuszu kalkulacyjnym Excel

W przypadku, gdy źródłem danych niezbędnych do wygenerowania bazy definicji alarmów jest arkusz Excel, dane musza znajdować się w arkuszach w formacie XLS lub XLSX. Arkusze mogą być tworzone programem Microsoft Excel (w wersji 97, 2000, XP, 2003 i 2007) lub programem Open Office (w wersji 1.1.2 lub późniejszej).

Arkusz z definicją alarmów musi mieć nazwę Alarmy i zawierać następujące kolumny:

  • Numer - unikalny numer alarmu;

  • Typ - typ alarmu (SYSTEMOWY, KOMUNIKAT, OSTRZEŻENIE, ALARM, WAŻNY, IGNOROWANY);

  • TekstPoczątku - tekst wyświetlany w momencie wykrycia alarmu;

  • TekstKońca - tekst wyświetlany dla alarmów, które zostały zakończone. Brak podania tego tekstu oznacza, że ma być używany tekst jak dla początku alarmu;

  • IdGrupy - maksymalnie 4-znakowy identyfikator grupy, do której należy alarm;

  • NazwaMaski - nazwa sugerowanej maski;

  • Wydruk - zezwolenie lub blokada (DRUKUJ, NIE_DRUKUJ) liniowego wydruku alarmów.

Rysunek: Arkusz definicji alarmów.

Kolumna Wydruk pozwala określić alarmy, które będą drukowane w przypadku zadeklarowania bieżącego wydruku alarmów.

Bieżący wydruk alarmów aktywowany jest parametrem Wydruk alarmów:

Moduł Obszary i komputery > Wydruk > zakładka Wydruk alarmów: zakładka Nagłówki i stopki, Czcionki, Opcje

Jeśli zostanie zadeklarowany parametr Wydruk alarmów bez podawania nazwy drukarki w polu Drukarka, wykorzystywana będzie domyślna drukarka systemowa. Parametr Drukarka pozwala na indywidualny wybór drukarki dedykowanej do wydruku alarmów.

Arkusz z definicją grup alarmów musi mieć nazwę Grupy i zawierać następujące kolumny:

  • IdGrupy - maksymalnie 4-znakowy identyfikator grupy, służący do identyfikacji grup w definicjach alarmów,

  • OpisGrupy - dowolny tekst opisujący grup; tekst ten będzie wyświetlany w liście grup okna selekcji alarmów; brak tekstu spowoduje użycie w liście wyboru identyfikatora grupy;

  • Wydruk.- zezwolenie lub blokada (DRUKUJ, NIE_DRUKUJ) liniowego wydruku alarmów należących do danej grupy.

Rysunek: Arkusz definicji grup alarmów.

Aby przyśpieszyć etap przygotowania arkuszy z definicjami alarmów i grup alarmów, Architekt udostępnia funkcję generowania szablonu skoroszytu zawierającego wszystkie potrzebne arkusze, kolumny w arkuszach i przykładowe definicje alarmów:

Moduł Bazy danych > Baza definicji alarmów > zakładka Szablon > wygenerowany plik nosi domyślną nazwę ’SzablonBazyDefinicjiAlarmów.xls’

(zakładka Szablon dostępna jest przy załączonym trybie pracy bazy definicji alarmów: Baza definicji alarmów generowana jest z arkusza kalkulacyjnego)


4.9.1.2 Generowanie bazy definicji alarmow z arkusza

4.9.1.2 Generowanie bazy definicji alarmów z arkusza kalkulacyjnego

Generowanie bazy definicji alarmów z arkusza kalkulacyjnego realizowane jest w następujących krokach:

1. Zdefiniuj tryb pracy bazy definicji alarmów jako Baza definicji alarmów generowana jest z arkusza kalkulacyjnego

Rysunek: Baza definicji alarmów > zakładka 'Typ'.

2. Określ źródła danych:

Baza definicji alarmów > zakładka Źródła danych > wskazane pliki Excel

Rysunek: Baza definicji alarmów > zakładka 'Źródło danych'.

3. Wybierz polecenie Generuj generuj def alarmow.

Wygenerowana w ten sposób baza ma format plików tekstowych.

Istnieje możliwość wygenerowania bazy definicji alarmów w formacie bazy SQL lub MDB jako elementu bazy definicji zmiennych. W tym celu należy na zakładce Typ zaznaczyć opcję Dodaj bazę definicji alarmów do bazy definicji zmiennych / Dodaj bazę definicji alarmów do bazy definicji zmiennych, a na zakładce Źródła danych wskazać źródłowe pliki z definicjami alarmów i grup alarmów oraz obszar/komputer identyfikujący sieciową nazwę zestawu alarmów.


4.9.2 Aktywowanie sposobu pracy systemu alarmow

4.9.2 Aktywowanie sposobu pracy systemu alarmów

Zakładka Alarmy / Typ systemu obejmuje konfigurację następujących parametrów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Typ systemu'.

  • Blokowanie uruchamiania systemu alarmów - pozycja pozwalająca na zablokowanie inicjacji systemu alarmów;

Wartość domyślna: system alarmów aktywny

  • Sposób pracy systemu alarmów - określa sposób pracy systemu alarmów:

  • Tryb Operatorski - jest podstawowym trybem pracy systemu alarmów, w którym udostępniane są wszystkie mechanizmy aktywnej obsługi alarmów (wykrywanie, potwierdzanie, itd.) oraz możliwa jest praca stanowisk połączonych sieciowo.

Stacje operatorskie współpracują ze sobą tylko wtedy, gdy mają nadaną taką samą nazwę zestawu alarmów. Zestaw alarmów jest identyfikowany przez 8-znakową nazwę.

Istotne jest, aby projektant systemu zapewnił zgodność wszystkich elementów wchodzących w skład zestawu. W przypadku plików definicji alarmów i grup wystarczająca jest zgodność nazw plików (program automatycznie transferuje zawartość plików w przypadku stwierdzenia niezgodności, sprawdzany jest czas zapisu pliku). Natomiast bezwarunkowo muszą zgadzać się parametry strategii rozpoznania alarmów. Wynika to z faktu, że w ramach działającej grupy stanowisk operatorskich tylko jeden komputer aktywnie rozpoznaje alarmy i transferuje je do innych komputerów. Ponieważ nie jest określone, które stanowisko jest aktywne, wobec tego każde z nich musi być w stanie podjąć wykrywanie wszystkich alarmów.

  • Tryb Kontrolny - pozwala jedynie na pasywne przeglądanie alarmów ściąganych ze stanowisk operatorskich.

  • Tryb Lokalny - jest funkcjonalnie identyczny z trybem operatorskim, za wyjątkiem braku możliwości pracy w sieci.

  • Tryb Serwer alarmów historycznych - z punktu widzenia operatora systemu oznacza pracę taką, jak w trybie kontrolnym. Dodatkowo wykonywane jest automatyczne uaktualnianie archiwum alarmów ze wszystkich wykrytych stanowisk operatorskich. Zgromadzone archiwa mogą być udostępniane innym komputerom, pracującym w trybie kontrolnym.

Wartość domyślna: ’Operatorski’, jeżeli została zadeklarowana Nazwa sieciowa zestawu alarmów; w przeciwnym razie wartością domyślną jest praca w trybie ’Lokalnym’.

uwaga Poza powyższymi trybami pracy systemu alarmów istnieje również tryb pozwalający na dynamiczne przyłączanie się do różnych zasobów alarmowych:

Tryb ten pozwala na kontrolowanie w sposób operatorski alarmów aktywnych i historycznych z wielu źródeł.

Podstawowe ograniczenia tego trybu:

- w danej chwili podłączone jest tylko jedno źródło alarmów (nie można otworzyć kilku masek alarmowych, które pokazują różne źródła alarmów);

- stanowisko jest zawsze stroną pasywną (tak jakby wyłączona była opcja Stanowisko aktywne w Architekt > Obszary i komputery > System alarmów > Zaawansowane).

Parametryzacja trybu dynamicznego przyłączania do zasobów alarmów:

  1. Sposób pracy systemu alarmów ustawiony na ’Operatorski’.

  2. Załączona opcja Zmienna nazwa zasobu (System alarmów > Alarmy > Nazwa sieciowa)

  3. Przyłączanie do źródeł alarmów następuje przy użyciu akcji operatorskiej PRZEŁĄCZ_ZASÓB_ALARMÓW

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Nazwa sieciowa'.

Zakładka Alarmy / Nazwa sieciowa obejmuje konfigurację następujących parametrów:

  • Nazwa sieciowa zestawu alarmów - określenie nazwy sieciowej zestawu alarmów obsługiwanego przez program AS. Nazwa może posiadać maksymalnie 8 znaków. Zestaw dostępnych znaków taki sam jak dla nazw plików. Nazwa sieciowa ma znaczenie dla stanowisk pracujących w trybie operatorskim. Stanowiska o tej samej nazwie prowadzą wspólną, zintegrowaną obsługę alarmów. Nazwa sieciowa jest używana ponadto na stanowiskach pasywnych do identyfikacji źródła pochodzenia alarmów.

Wartość domyślna: brak nazwy sieciowej. Program może pracować tylko w trybie kontrolnym (pasywnym) lub w trybie lokalnym.

  • Zmienna nazwa zasobu - opcja załączona zezwala na dynamiczne przyłączanie się do różnych dostępnych zasobów (zestawów alarmów) w przypadku odpowiednio skonfigurowanego trybu pracy systemu alarmów pozwalającego na przełączanie się do różnych zasobów alarmowych.


3.9.3 Deklaracja plikow definicji alarmow i definicji grup

4.9.3 Deklaracja plików definicji alarmów i definicji grup alarmów

uwaga Możliwość deklarowania plików, z których pobierane są definicje alarmów i definicje grup alarmów istnieje wówczas, gdy w module Bazy danych zostanie zdefiniowany tryb pracy bazy definicji alarmów z plikami:

Moduł Bazy danych > Baza definicji alarmów > Tryb pracy bazy definicji alarmów: Tekstowe pliki definicji alarmów są edytowane przez projektanta

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów'.

  • Nazwy plików, w których zdefiniowane są alarmy - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały alarmy; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: definicje alarmów będą czytane z pliku ’alarm.def’ z kartoteki bieżącej aplikacji

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów - grupy'.

  • Nazwy plików, w których zdefiniowane są grupy alarmów - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały grupy alarmów; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: brak


4.9.4 Parametryzacja archiwum alarmow

4.9.4 Parametryzacja archiwum alarmów

Zakładka Archiwum / Dysk dotyczy wartości następujących parametrów:

  • Zapisuj pliki alarmowe na dysku - pozycja pozwalająca na zablokowanie zapisu alarmów do plików dyskowych;

Wartość domyślna: domyślnie alarmy są zapisywane w plikach dyskowych;

uwaga Brak zapisu alarmów do pliku powoduje, że dostępne są tylko alarmy pamiętane w pamięci operacyjnej komputera (standardowo 1000 pozycji). Ponadto, historia alarmów jest tracona w momencie restartu komputera.

  • Katalog archiwum alarmów - pozycja służąca do określenia katalogu, w którym mają być zapisywane pliki logu alarmów;

Wartość domyślna: domyślnie pliki tworzone są w podkatalogu ’Alarms’ kartoteki startowej aplikacji;

  • Ograniczenie okresu przechowywania plików alarmów - pozycja określa przez ile dni mają być przechowywane pliki alarmów;

Wartość domyślna: domyślnie pliki przechowywane są bezterminowo;

uwaga Bezterminowe przechowywanie plików będzie powodowało zapełnianie się dysku, a więc konieczność okresowego kasowania starych plików. Dodatkowo, duża ilość plików alarmów może spowodować zwolnienie funkcji przeglądania alarmów (szczególnie przy użyciu kryteriów selekcji).

  • Katalog tworzenia kopii bezpieczeństwa archiwum alarmów - pozycja, której użycie włącza mechanizm tworzenia kopii bezpieczeństwa historycznego logu alarmów; program AS utrzymuje w podanej kartotece kopie plików logu; operacja uaktualniania wykonywana jest co jedną godzinę; katalog zapasowy powinien (optymalnie) znajdować się na innym dysku fizycznym niż katalog logu roboczego; można również używać napędów dysków wymiennych;

Wartość domyślna: domyślnie kopia bezpieczeństwa nie jest wykonywana.

uwaga Pliki logu historycznego składowane w kartotece zapasowej nie podlegają ograniczeniu wprowadzanemu przez pozycję Ograniczenie okresu przechowywania plików alarmów.

Pliki są przechowywane bezterminowo.

  • Dokładność zapisu czasu w archiwach alarmów - ustawienie dokładności zapisu czasu w archiwach alarmów; czasy alarmów mogą być pamiętane z rozdzielczością milisekund lub z rozdzielczością zegara systemowego (ok. 55 ms); użycie rozdzielczości milisekundowej powoduje dodatkowo zmianę formatu wyświetlania czasu na maskach alarmów; użycie pozycji jest istotne w sytuacji stosowania niestandardowych strategii rozpoznania alarmów, które nadają alarmom czas z dokładnością do milisekund;

Wartość domyślna: strategie standardowe pracują z dokładnością 55 ms.

uwaga Zmiana użycia parametru Dokładność zapisu czasu w archiwach alarmów wymaga skasowania starego archiwum (na wszystkich połączonych stanowiskach jednocześnie).

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Dysk'.

Zakładka Archiwum / Serwer Microsoft SQL pozwala określić nazwę serwera oraz nazwę bazy MS SQL, w której archiwizowane będą alarmy. Alarmy mogą być archiwizowane w dowolnej liczbie baz na serwerach MS SQL. Archiwizacja na serwerze SQL wykonywana jest niezależnie od archiwizacji zdefiniowanej na zakładce Dysk. Dane w archiwach SQL mogą być analizowane przy pomocy programu AsAlarm i udostępniane przy pomocy systemu raportów opartego o MS Reporting Services. Pierwsza baza na liście używana jest przez środowisko raportów AsRaport. Domyślnie żadna baza nie jest zadeklarowana.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Serwer Microsoft SQL'.

Zakładka Archiwum / Pamięć operacyjna pozwala określić ilość zdarzeń alarmowych logu historycznego przechowywanych w pamięci. Użycie tej pozycji może ewentualnie poprawić czasy dostępu do alarmów historycznych; w przypadku pracy bez logu plikowego, pozycja określa jednocześnie całkowitą liczbę pamiętanych alarmów; Wartość domyślna: domyślnie ilość alarmów przechowywanych w pamięci wynosi 1000.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Archiwum' / 'Pamięć operacyjna'.


4.9.5 Definicje strategii alarmow

4.9.5 Definicje strategii alarmów

Oprócz zdefiniowania alarmów konieczne jest jeszcze określenie sposobu wykrywania alarmów.

Zakładka Strategie pozwala zadeklarować jedną z pięciu dostępnych w systemie A six strategii rozpoznawania alarmów:

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Bitowa'.

  • Strategia bitowa - polega na sprawdzaniu stanu bitów w mapie bitowej alarmów, tworzonej przez oprogramowanie sterownika kontrolującego proces; wymaga to zadeklarowania danych Asmena służących do odczytu zawartości mapy alarmów; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli używanych jest mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru Liczba alarmów; okres sprawdzania stanu mapy bitowej wynika z czasu odświeżania podanego w definicji danej Asmena;

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Limitów'.

  • Strategia limitów - pozycja powoduje, że instalowana jest strategia rozpoznania alarmów oparta na sprawdzaniu przekroczenia wartości ograniczeń; okres sprawdzania określa cykl sprawdzania limitów w sekundach (domyślnie 1 sekunda); lista plików podaje nazwy plików (oddzielone znakiem przecinka), w których umieszczone zostały opisy limitów; brak listy oznacza, że użyty zostanie plik limits.def z kartoteki bieżącej aplikacji;

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Buforowa'.

  • Strategia buforowa - umożliwia parametryzację strategii buforowej w programie AS poprzez zadeklarowanie jednej lub kilku pozycji o następującej składni:

<zmienna_buforowa>,<zmienna_synchronizująca>,<zmienna_alarmów>,<numer_alarmu>,

gdzie:

<zmienna_buforowa> - nazwa zmiennej Asmena służącej do wymiany informacji o alarmach; jej rozmiar musi być równy rozmiarowi bufora w sterowniku;

<zmienna_synchronizująca> - nazwa zmiennej Asmena służącej do synchronizacji dostępu do bufora;

<zmienna_alarmów> - nazwa zmiennej Asmena służącej do wystawiania przez PC żądania odczytu mapy alarmów;

<numer_alarmu> - określa numer alarmu w ramach systemu A six, nadawany pierwszemu alarmowi wykrywanemu przez deklarowaną strategię.

Wartość domyślna: domyślnie strategia nie jest używana

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Aktywna'.

  • Strategia aktywna (SINEC L2) - użycie tej strategii wymaga stosowania protokołu transmisji pozwalającego na inicjację przesyłów ze strony sterownika oraz specjalnego programu w sterowniku, który wysyła dane zgodnie z protokołem przyjętym w strategii aktywnej; strategia wymaga zadeklarowania jednej lub więcej pozycji o następującej składni:

bufor,synchro,numer_alarmu,id

gdzie:

bufor - nazwa zmiennej służącej do wymiany danych,

synchro - nazwa zmiennej synchronizującej,

numer_alarmu - numer pierwszego alarmu obsługiwanego przez ten element strategii,

id - identyfikator (sieci SINECL2, aktualnie 1(SSNR =0) lub 2 (SSNR =8)).

Wartość domyślna: domyślnie strategia nie jest używana

uwaga Użycie tej strategii wymaga stosowania protokołu transmisji pozwalającego na inicjację przesyłów ze strony sterownika oraz specjalnego programu w sterowniku, który wysyła dane zgodnie z protokołem przyjętym w strategii aktywnej.

Rysunek: Okno parametrów systemu alarmów – zakładka 'Strategie / Serwera alarmów OPC'.

  • Strategia alarmów OPC - pozwala na deklarację użycia strategii rozpoznawania alarmów, której drajwer znajduje się w zewnętrznym pliku dll; zadeklarowanie drajwera alarmów OPC wymaga podania wiersza o następującej składni:

ALOPC.dll, , <serwer>, <plik_al_opc>

gdzie:

<serwer> - oznacza nazwę serwera alarmów OPC;

<plik_al_opc> - oznacza nazwę pliku tłumaczeń warunków OPC na alarmy w systemie A six.


3.9.6 Definicja formatu alarmow

4.9.6 Definicja formatu alarmów

Grupa zakładek Wygląd służy do definiowania sposobu wyświetlania alarmów:

  • Kolor tła - określa:

  • Tło tabeli alarmów,

  • Alternatywne tło tabeli alarmów,

  • Linie rozdzielające;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd / Kolor tła'.

  • Kolor tekstu alarmu - w zależności od rodzaju alarmu oraz od stanu alarmu (początek lub koniec) pozwala określić kolor tekstu i kolor tła dla:

  • Komunikat systemowy,

  • Komunikat,

  • Ostrzeżenie,

  • Alarm,

  • Ważny alarm.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor tekstu alarmu'.

  • Kolor daty alarmu - w zależności od stanu alarmu pozwala określić kolor tekstu daty oraz kolor tła daty dla:

  • Alarm rozpoczęty,

  • Alarm rozpoczęty i potwierdzony,

  • Alarm zakończony,

  • Alarm zakończony i potwierdzony.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor daty alarmu'.

  • Alarmy wyselekcjonowane - umożliwia zadeklarowanie koloru tła alarmów wyselekcjonowanych;

Rysunek:. Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Alarmy wyselekcjonowane'.

  • Maski typu Czerwony Tryb - definiuje kolor tekstu kolor tła masek ’Czerwony Tryb’;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Maska typu Czerwony Tryb'.

  • Opcje - pozwala dodatkowo określić:

  • Użycie na maskach i wydrukach alarmów długiego 4-cyfrowego formatu numeru roku;

  • Sortowanie alarmów na liście alarmów aktywnych i historycznych;

  • Czas po lewej stronie - wyświetlanie czasu na maskach alarmowych po lewej stronie;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Opcje'.

uwaga Użycie trybu sortowania według czasu zdarzeń ma sens tylko wtedy, gdy używana strategia wykrywania alarmów zgłasza alarmy łącznie z czasem.


4.9.7 Parametryzacja sygnalizacji alarmow

4.9.7 Parametryzacja sygnalizacji alarmów

Sygnalizacja umożliwia przeprowadzenie parametryzacji dotyczącej sposobu sygnalizacji alarmów, w tym:

- sposobu sygnalizacji dźwiękowej wystąpienia alarmu, ostrzeżenia oraz alarmu ważnego;

- akcji, która ma być wykonana w momencie wystąpienia alarmu;

- sprzęgu pomiędzy systemem Asix a modułem AsAlert, umożliwiającym zdalne powiadamianie wybranych osób o ważnych zdarzeniach.


4.9.7.1 Definiowanie dzwiekow sygnalizacji

4.9.7.1 Definiowanie dźwięków sygnalizacji

Zakładka Sygnalizacja / Dźwięki służy do parametryzacji sygnalizacji dźwiękowej alarmów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Dźwięki'.

  • Sygnalizacja dźwiękowa wystąpienia alarmu - określa sposób sygnalizacji dźwiękowej wystąpienia alarmu:

  • ’TAK’ - oznacza, że alarmy są zawsze sygnalizowane;

  • ’NIE’ - oznacza wyłączenie sygnalizacji alarmów;

  • ’MASTER’ - dotyczy instalacji sieciowej; na danej stacji są generowane sygnały dźwiękowe tylko w przypadku, gdy jest ona stroną aktywną w sieci;

Wartość domyślna: ’TAK’

uwaga Wymagana jest instalacja karty dźwiękowej.

  • Sygnał alarmów - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Sygnał ostrzeżeń - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Sygnał ważnych - nazwa pliku typu WAV - deklaracja plików typu WAV, które mają być odtworzone po wykryciu zdarzenia alarmowego podanego typu;

Wartość domyślna: domyślnie generowane są proste sygnały standardowe;

  • Alarm ciągły - włączenie ciągłego odgrywania sygnału po wykryciu alarmu. Sygnał będzie wyłączony dopiero po wykonani akcji UCISZ_SYGNAL;

Wartość domyślna: opcja wyłączona


4.9.7.2 Definiowanie akcji

Zakładka Sygnalizacja / Akcja służy do deklaracji akcji, wykonywanej w momencie wykrycia alarmu:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Akcja'.

  • Akcja, która ma zostać wykonana w momencie wykrycia alarmu

Wartość domyślna: brak

uwaga Nie ma możliwości rozróżnienia rodzaju akcji dla różnych numerów alarmów.


4.9.7.3 Definiowanie sprzegu systemu asix z modulem AsAlert

4.9.7.3 Definiowanie sprzęgu systemu Asix z modułem AsAlert

Włączenie modułu sprzęgu pomiędzy systemem A six a systemem zdalnego powiadamiania wybranych osób o ważnych zdarzeniach - AsAlert wymaga załączenia opcji AsAlert, zlokalizowanej na zakładce Sygnalizacja / Alerty, oraz podania nazwy pliku konfiguracyjnego sprzęgu (plik XML).

Dodatkowa opcja Alerty, gdy stacja aktywna umożliwia wymuszenie wysyłania alertów wyłącznie przez aktywne stacje. Opcja znajduje zastosowanie w redundantnych stacjach operatorskich, gdzie tylko jedno stanowisko jest aktywne - załączenie opcji eliminuje nadmiarowe wysyłanie alertów, ponieważ są one wysyłane tylko przez stację aktywną.

Szczegóły na temat tworzenia pliku konfiguracyjnego sprzęgu omawia AsAlert - podręcznik użytkownika.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Sygnalizacja' / 'Alerty'.


4.9.8 Deklaracja uprawnien dotyczacych obslugi alarmow

4.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

Zakładka Bezpieczeństwo daje możliwość:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Bezpieczeństwo'.

  • zadeklarowania poziomu hasła, którego znajomość będzie wymagana do wykonania określonych operacji:

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów filtrowanych,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów sygnalizowanych dźwiękiem,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów wykluczeń.

Wartość domyślna: brak kontroli

Sposób deklarowania trybu logowania omawia rozdział 3.11 . Konfiguracja zabezpieczenia aplikacji .

  • Dodatkowo użycie opcji Zablokowanie obsługi alarmów przez operatora powoduje, że blokowane są operacje zmiany filtrów, wykluczeń i potwierdzania alarmów. Możliwe jest jedynie przeglądanie alarmów;

Wartość domyślna: obsługa nie jest blokowana


4.9.9 Deklaracja mapy buczkow i mapy wykluczen

4.9.9 Deklaracja mapy buczków i mapy wykluczeń

Zakładka Mapy pozwala zadeklarować:

Rysunek 156. Okno parametrów systemu alarmów - zakładka 'Mapy' / 'Buczków'.

  • mapę buczków; jest to deklaracja obszarów map bitowych, używanych do parametryzacji sygnalizacji dźwiękowej, realizowanej przez sterownik, zgodnie z następującym zapisem:

nazwa_danej, numer_pierwszego[,ilość alarmów]

gdzie:

nazwa_danej - podaje symboliczną nazwę zmiennej procesowej Asmena, w której sterownik przechowuje bitową informację o sygnałach alarmów (wartość 1 oznacza dla danego alarmu, że generuje on buczek lub dzwonek, w zależności od typu mapy);

numer_pierwszego - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie mapy sygnałów nie są obsługiwane;

  • mapę dzwonków; jest to deklaracja obszarów map bitowych, używanych do parametryzacji sygnalizacji dźwiękowej, realizowanej przez sterownik, zgodnie z następującym zapisem:

nazwa_danej, numer_pierwszego[,ilość alarmów]

gdzie:

nazwa_danej - podaje symboliczną nazwę zmiennej procesowej Asmena, w której sterownik przechowuje bitową informację o sygnałach alarmów (wartość 1 oznacza dla danego alarmu, że generuje on buczek lub dzwonek, w zależności od typu mapy);

numer_pierwszego - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena; jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie mapy sygnałów nie są obsługiwane;

  • mapę wykluczeń; jest to deklaracja mapy bitowej, która steruje wykluczaniem alarmów realizowanych przez sterownik, zgodnie z zapisem:

nazwa_danej, numer_pierwszego[,ilość alarmów]

gdzie:

nazwa_danej - podaje nazwę symboliczną zmiennej Asmena, w której sterownik przechowuje informację o wykluczonych alarmach (wartość 1 oznacza dla danego alarmu, że jest wykluczony);

numer_pierwszego - określa numer nadany pierwszemu alarmowi w mapie; ilość alarmów w mapie wynika z rozmiaru danej Asmena;jeżeli jest używanych mniej bitów, to można ograniczyć ich ilość przy pomocy trzeciego parametru;

Wartość domyślna: domyślnie wykluczenia realizowane są wewnętrznie w komputerze.

uwaga Użycie pozycji powoduje wyłączenie wewnętrznego mechanizmu kontroli wykluczeń i filtrów.


4.9.10 Parametry zaawansowane

 uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Zaawansowane obejmuje konfigurację następujących parametrów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Zaawansowane'.

  • Wyłączenie wyświetlania alarmów wykluczonych - zastosowanie trybu pracy polegającego na wyłączeniu wyświetlania alarmów wykluczonych; alarmy takie są jednak rejestrowane i zapisywane do logu - gdzie po wycofaniu wykluczenia można przejrzeć wszystkie zarejestrowane zdarzenia;

Wartość domyślna: alarmy wykluczone są wyświetlane

  • Algorytm filtrowania - wybór sposobu filtracji alarmów; możliwe jest filtrowanie krótkich alarmów, pojawiających się na czas krótszy niż zadeklarowany (algorytm nr 1) lub szybkich sekwencji pojawienie się alarmu-zanik alarmu - pojawienie się alarmu (algorytm nr 2);

Wartość domyślna: 1

  • Stanowisko aktywne - uzupełnienie parametryzacji dla stanowisk pracujących w trybie operatorskim w sieci; w grupie połączonych stanowisk operatorskich w danej chwili jest tylko jeden komputer, który wykrywa alarmy - jest to samoistnie ustalane przez Asix a; wyłączenie opcji oznacza, że dany komputer nigdy nie zostanie komputerem aktywnym; opcja ma zastosowanie tam, gdzie nie ma bezpośredniego łącza do sterowników lub na stanowiskach typu nadzorczego z wymaganym dostępem do alarmów aktywnych;

Wartość domyślna: stanowisko może być aktywne

Zadeklarowanie zmiennej __ALSYS_STATE__ w kanale NONE pozwala na diagnostykę, czy dane stanowisko jest stanowiskiem aktywnym, tzn. w tym przypadku - czy wykrywa alarmy. Zmienna automatycznie ustawiana jest na następujące wartości:

0 - gdy system alarmów jest w stanie przejściowym,

1 - gdy system alarmów pracuje w trybie aktywnym,

2 - gdy system alarmów pracuje w trybie pasywnym.

  • Stacje operatorskie będące serwerami alarmów - jawne deklarowanie stacji operatorskich będącymi serwerami alarmów;

Wartość domyślna: brak zadeklarowanych stacji

uwaga Parametr dotyczy pliku konfiguracyjnego aplikacji dla komputerów pracujących z systemem alarmów kontrolnych; kosztem wydłużenia czasu wyszukiwania, zwiększa się prawdopodobieństwo znalezienia żądanych serwerów.

  • Stacje operatorskie będące serwerami alarmów w trybie POMOST - jawne deklarowanie serwerów alarmów historycznych; służy do deklaracji komputerów pracujących w trybie serwerów alarmów historycznych jako stacja typu pomost;

Wartość domyślna: brak zadeklarowanych stacji

uwaga Pozycja dotyczy pliku konfiguracyjnego aplikacji dla komputerów pracujących z systemem alarmów kontrolnych. Kosztem wydłużenia czasu wyszukiwania, zwiększa się prawdopodobieństwo znalezienia żądanych serwerów.


4.9.11. Baza zdarzeń alarmów

4.9.11. Baza zdarzeń alarmów - konfiguracja

Asix klasyczny

Bieżący stan oraz historia alarmów systemu Asix przechowywane są w plikach dyskowych. Pliki alarmowe przechowywane są w podkatalogu alarms katalogu startowego (jeśli nie zostanie zadeklarowana inna lokalizacja). W pliku o nazwie alarms.act przechowywane są wszystkie alarmy aktywne. Historia alarmów przechowywana jest w zestawie plików o nazwach wywodzących się ze wzorca al??????.log. W każdym takim pliku przechowywane są alarmy dotyczące jednego dnia. Data tego dnia kodowana jest w miejscu znaków ??????, podając kolejno dzień, miesiąc i rok. Pliki historii alarmów mogą być przechowywane bezterminowo. Można też ograniczyć ilość pamiętanych dni.

Istnieje możliwość przekonwertowania plików binarnych z logami zdarzeń alarmowych systemu Asix (pliki al??????.log) do formatu bazy SQL. Służy do tego programu AlarmLogConverter.exe dołączany do pakietu Asix.

Możliwa jest też bieżąca rejestracja zdarzeń alarmowych w bazie SQL. Wymaga to odpowiedniego skonfigurowania pliku XML aplikacji systemu Asix przy jednoczesnym odblokowaniu zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line.

(patrz: - 4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych - gdy istnieje potrzeba zachowania ciągłości w rejestracji zdarzeń alarmowych pomiędzy archiwum a bieżącą rejestracją

- 4.9.11.2 Uruchamianie rejestracji zdarzeń alarmowych on-line - gdy nie ma archiwum alarmów a rejestracja zaczyna się od bieżącego momentu)

Asix Evo

Sposób konfigurowania rejestracji zdarzeń alarmowych dla aplikacji Evo omawia podręcznik 'Asix.Evo - System alarmów', rozdział 8. Log alarmów historycznych i 8.1. Archiwum alarmów SQL.

UWAGA:

Na potrzeby programu AsAlarm oraz środowiska AsRaport tworzenia raportów z wykorzystaniem usług Reporting Revices - wymagane jest archiwizowanie zdarzeń alarmowych w bazie danych typu SQL. Dotycz to aplikacji systemu Asix zarówno klasycznych jak i w wersji Evo.


4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do

4.9.11.1. Uruchomienie rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL (Asix klasyczny)

Konwersja plików binarnych archiwum alarmów systemu Asix do formatu bazy SQL realizowana jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix.

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych z konwersją plików binarnych do formatu bazy SQL:

Aby dokonać konwersji plików al??????.log do formatu bazy SQL i uruchomić bieżącą rejestrację zdarzeń alarmowych bez utraty danych dotyczących wystąpień alarmów w momencie wykonywania czynności związanych z konwersją - należy postępować ściśle wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Przekonwertowanie plików al??????.log do formatu bazy danych SQL:

a. przejdź do programu AlarmLogKonwerter i w kategorii Operacje kliknij na przycisk Rozpocznij.

5. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. po zakończeniu konwersji przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL - zapisowi podlegają tylko te zdarzenia, których nie objęła operacja konwersja plików zdarzeń al??????.log.


4.9.11.2. Uruchamianie rejestracji zdarezń alarmowych on-line

4.9.11.2. Uruchamianie rejestracji on-line zdarzeń alarmowych (Asix klasyczny)

Uruchomienie rejestracji alarmów systemu Asix do bazy SQL realizowane jest za pośrednictwem programu AlarmLogConverter.exe, który jest standardowo dołączany do pakietu Asix.

Rysunek: Okno główne programu AlarmLogKonwerter.

Poniżej zestawienie opcji wymaganych do uruchomienia rejestracji zdarzeń alarmowych i przeprowadzenia konwersji:

Aplikacja Asix – dotyczy źródła alarmów

Plik konfiguracyjny – wymaga podania pliku konfiguracyjnego aplikacji Asixa – plik XML dla wersji Asix 5 – 6 oraz klasycznej wersji 7 Asixa lub pliku INI dla starszych wersji Asixa

Wariant – wariant aplikacji dedykowany konkretnemu komputerowi lub obszarowi obiektu (kilku komputerom pracującym pod daną aplikacją na obiekcie)

Ustawienia bazy danych – parametry dotyczące lokalizacji i nazwy docelowej bazy alarmów

Nazwa serwera – nazwa serwera MS SQL Server 2008

Nazwa bazy danych - nazwa bazy MS SQL zdarzeń alarmów

Udostępnij anonimowy dostęp do bazy alarmów / Tylko autentyfikacja Windows – określenie sposobu dostępu do bazy alarmów

Administracja bazami danych – obejmuje opcje i komendy związane z administrowaniem baz danych

Tryb autoryzacji - określenie sposobu autoryzacji administratora bazy danych SQL Server poprzez Windows lub Windows i SQL Server (czyli wprost przez login i hasło)

Sprawdź bazę – służy do sprawdzenia czy baza istnieje i weryfikacji jej poprawności.

Utwórz bazę - służy do utworzenia nowej bazy alarmów

Usuń bazę – służy do usunięcia bazy alarmów

Wyczyść bazę – służy do wyczyszczenia bazy w celu ponownej konwersji

Operacje – polecenia odnoszące się bezpośrednio do procedury konwersji

Odblokowanie – odblokowanie zapisu do bazy SQL danych na temat zdarzeń alarmowych generowanych na bieżąco on-line od momentu załączenia opcji EXPORT_CHANNEL, która uruchamia tworzenie przez Asixa plików buforujących zawierających dane na temat tych zdarzeń; odblokowanie powoduje zapis do bazy SQL danych nagromadzonych w plikach buforujących.

Rozpocznij – rozpoczyna konwersję plików al??????.log alarmów do formatu bazy danych MS SQL Server 2008

Przerwij – powoduje przerwanie konwersji (konwersja w ogóle nie zostaje wykonana)

Procedura uruchomienia rejestracji zdarzeń alarmowych do formatu bazy SQL (bez konwersji plików binarnych):

Aby uruchomić bieżącą rejestrację zdarzeń alarmowych - należy postępować wg poniższych kroków:

1. Tworzenie pustej bazy SQL przy użyciu konwertera AlarmLogKonwerter – w tym celu:

a. otwórz program AlarmLogKonwerter

b. zadeklaruj plik XML aplikacji ze wskazaniem stacji komputerowej, z której będą pochodzić pliki archiwum alarmów

c. podaj nazwę serwera SQL i docelową nazwę bazy alarmów

d. określ tryb autoryzacji do funkcji użytkowych i administracyjnych

e. kliknij przycisk Utwórz bazę

2. Deklaracja bieżącej rejestracji zdarzeń alarmowych (do momentu odblokowania zapisu do bazy MS SQL zdarzenia te zapisywane będą w plikach buforowych):

a. otwórz plik konfiguracyjny pracującej aplikacji Asixa przy użyciu programu Architekt

b. w kategorii System alarmów > zakładka Archiwum > zakładka Serwer Microsoft SQL zadeklaruj opcje:

Nazwa serwera Microsoft SQL - nazwa serwera MS SQL Server 2008 bazy zdarzeń alarmów,

Nazwa bazy - nazwa bazy MS SQL zdarzeń alarmów.

c. Zapisz zmiany w pliku konfiguracyjnym aplikacji

3. Wykonaj restart aplikacji. Od tego momentu zdarzenia zapisywane są w plikach buforowych.

4. Odblokowanie zapisu do bazy SQL zdarzeń alarmowych generowanych on-line:

a. przejdź w programie AlarmLogKonwerter do kategorii Operacje i kliknij na przycisk Odblokuj. Operacja ta spowoduje przepisanie zdarzeń alarmowych z plików buforowych do bazy SQL.


4.10 Konfiguracja modulu sieci

4.10 Konfiguracja modułu sieci

Grupa parametrów konfiguracja modułu sieci Moduł sieci obejmuje ustawienia pracy modułu Aslink.

ASLINK jest modułem, który umożliwia innym komponentom systemu Asix wzajemną komunikację poprzez lokalną sieć komputerową. Aslink definiuje zestaw usług sieciowych, z których korzystają wszystkie inne programy systemu Asix, sparametryzowane do pracy w sieci.

Podstawowa usługa świadczona między innymi na rzecz takich komponentów pakietu Asix, jak Asmen, Aspad czy podsystem obsługi alarmów - to wiarygodny przesył danych pomiędzy każdą parą procesów użytkowych, działających na dowolnych stanowiskach przyłączonych do sieci komputerowej i realizujących wspólny protokół użytkowy. W tym zakresie usługi modułu Aslink ukierunkowane są na wsparcie komunikacji opartej na istnieniu procesu ”serwera" i korzystającego z jego usług procesu ”klienta".

W szczególności Aslink zapewnia:

  • wyszukanie w sieci procesów pełniących rolę serwerów w odniesieniu do zasobów potrzebnych procesom klientów,

  • nawiązanie połączenia (tzw. kanału transmisji) pomiędzy klientem i wskazanym przez niego serwerem zasobu,

  • dwukierunkowy, wiarygodny przesył danych w każdym z kanałów,

  • powiadomienie procesów, że kanał został zamknięty wskutek awarii sieci lub na jawne polecenie któregoś z partnerów.

Szczegółowy opis funkcjonalności modułu Aslink znajduje się w podręczniku ”Asix - funkcjonalność i zasady działania”, rozdziale ASLINK - moduł sieciowy.

uwaga Ustawienia modułu sieciowego przechowywane są w pliku XML aplikacji Asixa. Gdy na danym komputerze nie ma takiej aplikacji (tym samym pliku xml), za to znajdują się: AsixConnect, AsTrend lub inna aplikacja korzystająca z danych aplikacji Asixa - w takiej sytuacji ustawienia sieciowe dla danego komputera przechowywane są w pliku aslink.ini. Edytor pliku aslink.ini dostępny jest z poziomu Architekta z menu Narzędzia i obejmuje konfigurację dokładnie tych samych opcji co Moduł sieci.


4.10.1 Nazwa komputera

Zakładka Nazwa komputera obejmuje parametryzację następujących elementów:

Rysunek: Okno parametrów modułu sieci - zakładka 'Nazwa komputera'.

  • Automatyczne nadawanie sieciowych nazw komputerom - zaznaczenie opcji spowoduje, że nazwa komputera widniejąca w panelu 'Obszary i komputery' zostanie sieciową nazwą komputera;

Wartość domyślna: automatycznie przydzielana jest nazwa komputera w systemie Windows, zdefiniowana w czasie parametryzacji sieci z dodaną na końcu kropką.

  • Sieciowa nazwa komputera - nazwa sieciowa komputera; jeśli nie podano w tym polu nazwy, to zostanie wygenerowana nazwa na podstawie nazwy komputera w systemie Windows, zdefiniowanej w czasie parametryzacji sieci z dodaną na końcu kropką;

Wartość domyślna: nazwa przydzielona automatycznie

uwaga Dopuszczalne wartości: tekst o maks. 15 znakach. Wielkość znaków ma znaczenie. Nazwa nie może zwierać znaku ”*”. Nie powinna również zawierać znaku ”,”


4.10.2. Komunikacja poprzez TCP/IP

Zakładka Komunikacja poprzez TCP/IP obejmuje parametryzację następujących elementów:

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja poprzez TCP/IP'.

  • Połączenia po protokole TCP/IP - opcja wymaga podania nazwy w systemie Windows lub adresu IP wszystkich komputerów, do których ma się dołączać moduł sieciowy; nazwy należy rozdzielić przecinkami.

Domyślnym portem komputera, do którego ma się dołączać moduł sieciowy, jest port numer 6000. Jeśli zdalny komputer używa innego portu, należy go podać po dwukropku, np.: serwer2:6001, 10.10.10.13:6003.

Na odległych serwerach zaleca się zwiększenie wartości opcji Dane bieżące > Zaawansowane 2 > Zwłoka danych z serwera

Wartość domyślna: brak połączenia

  • Nr portu TCP/IP - numer portu, na którym moduł sieciowy oczekuje na połączenie.

Wartość domyślna: 6000

  • Nie używaj TCP/IP - załączenie opcji oraz jednocześnie opcji Nie używaj NetBIOS z zakładki Komunikacja przez NetBIOS/Protokoły sieciowe powoduje, że możliwa jest jedynie komunikacja modułów systemu Asix na jednym komputerze z użyciem wewnętrznego protokołu.

Wartość domyślna: opcja wyłączona


4.10.3 Deklaracje synchronizacji czasu po stronie Klienta

4.10.3 Komunikacja poprzez NetBIOS

Zakładka Komunikacja poprzez NetBIOS/Protokoły sieciowe obejmuje deklarację kart i protokołów sieciowych.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Protokoły sieciowe'.

  • Używane karty sieciowe i protokoły - opcja określa wykorzystywane do komunikacji protokoły sieciowe:

  • Wszystkie karty sieciowe i protokół TCP/IP

  • Wybrane karty sieciowe i protokoły - pozwala zadeklarować nazwy kart sieciowych, protokołów lub numery adapterów oddzielone przecinkami; poprzedzenie nazwy znakiem ’-’ oznacza, że dany adapter nie może być używany; znak '*' oznacza wszystkie dostępne protokoły i karty sieciowe. Aby wyświetlić listę dostępnych adapterów, należy uruchomić program AslView i z menu Widok wybrać polecenie Adaptery.

Wartość domyślna: ’TCPIP’

  • Karty sieciowe i protokoły używane przez moduł sieciowy do szukania serwerów - określa adaptery logiczne wykorzystywane przez moduł sieciowy do szukania serwerów;

  • Wszystkie karty sieciowe i protokół TCP/IP

  • Wybrane karty sieciowe i protokoły

Wartość domyślna: wszystkie adaptery wykorzystywane przez moduł sieciowy.

uwaga Pozycje używane na komputerach typu ’POMOST’.

Dopuszczalne wartości: numery adapterów oddzielone przecinkami; jeżeli numer adaptera poprzedzony jest znakiem '-', to adapter nie zostanie użyty; jeśli podano ’*’, to zostaną wykorzystane wszystkie dostępne adaptery.

  • Nie używaj NetBIOS - załączenie opcji oraz jednocześnie opcji Nie używaj TCP/IP z zakładki Komunikacja poprzez TCP/IP powoduje, że możliwa jest jedynie komunikacja modułów systemu Asix na jednym komputerze z użyciem wewnętrznego protokołu.

Wartość domyślna: opcja wyłączona

uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Zaawansowane obejmuje parametryzację następujących opcji:

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Zaawansowane'.

  • Nazwa grupy - nazwa grupy, do której należy komputer;

Wartość domyślna: ASIX

  • Połączenia sesyjne - jeśli pole to jest wypełnione, to połączenia będą nawiązywane tylko do zdefiniowanych komputerów;

Wartość domyślna: brak połączenia

Uwaga:

Użycie tej opcji blokuje synchronizację czasu.

Na odległych terminalach zaleca się zwiększenie wartości opcji Dane bieżące > Zaawansowane 2 > Zwłoka danych z serwera

Do działania połączeń sesyjnych wymagane jest wykonanie odpowiednich wpisów w systemowych plikach LMHOSTS.

  • Aslink 4 - opcja załącza komunikację ze starszymi wersjami modułu sieciowego (Asix 1-3);

Wartość domyślna: komunikacja ze starszymi wersjami modułu sieciowego załączona

Uwaga:

Zaznaczenie tej opcji spowoduje zwiększenie obciążenia sieci.

  • Domena Aslinka - włącza realizację połączeń pomiędzy komputerami położonymi w różnych sieciach połączonych przez router;

Wartość domyślna: opcja wyłączona

Uwaga:

Do działania tej opcji wymagane jest wykonanie odpowiednich wpisów w systemowych plikach LMHOSTS.

Zamiast tej opcji zaleca się użycie opcji Połączenia sesyjne.

 uwaga Zakładka Synchronizacja czasu pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Klient 1 umożliwia parametryzację synchronizacji czasu od strony klienta.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Klient 1'.

  • Synchronizacja czasu - opcja pozwala załączyć synchronizację czasu;

Wartość domyślna: czas synchronizowany jest z wszystkimi dostępnymi serwerami czasu

  • Ograniczenia synchronizacji czasu - jeśli pole jest wypełnione, to synchronizacja czasu zostanie ograniczona do serwerów o podanych nazwach; sieciowe nazwy komputerów należy podać, oddzielając je przecinkami;

Wartość domyślna: czas synchronizowany jest z wszystkimi dostępnymi serwerami czasu

  • Maksymalna różnica czasu - różnica pomiędzy czasem serwera a czasem stacji lokalnej, której przekroczenie spowoduje synchronizację czasu lokalnego (CMOSu); wartość w sekundach;

Wartość domyślna: 4 sekundy

  • Liczba pakietów czasu - liczba pakietów czasu, jaką stacja musi otrzymać od jednego serwera, aby zsynchronizować swój zegar;

Wartość domyślna: 3 pakiety

  • Ignorowane pakiety czasu - liczba pakietów czasu, które są pomijane po uruchomieniu modułu sieciowego na każdym adapterze;

Wartość domyślna: 2

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Klient 2 umożliwia parametryzację synchronizacji czasu od strony klienta.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Klient 2'.

  • Duża różnica czasu określa:

  • różnicę (czas w milisekundach) pomiędzy czasem serwera czasu a czasem stacji lokalnej, której przekroczenie powoduje specjalne traktowanie odbieranych pakietów czasu, polegające na opóźnionej synchronizacji czasu stacji lokalnej;

Wartość domyślna: 3600 milisekund

  • liczbę pakietów, po której otrzymaniu nastąpi synchronizacja czasu;

Wartość domyślna: 2

  • Replikacja pakietów czasu - włączenie opcji spowoduje, że wszystkie odbierane z danego adaptera pakiety czasu będą rozsyłane do pozostałych adapterów; dodatkowo można określić liczbę dopuszczalnych replikacji pakietu czasu.

Wartość domyślna: replikacja czasu wyłączona

  • Limit zmiany czasu - pozycja pozwala zdefiniować jaka jest maksymalna dozwolona jednorazowa zmiana czasu;

Wartość domyślna: domyślnie zmiany czasu nie są ograniczone

uwaga Podanie ujemnego limitu zmiany całkowicie blokuje możliwość modyfikacji czasu.

Zakładka Komunikacja poprzez NetBIOS/Synchronizacja czasu/Serwer umożliwia parametryzację synchronizacji czasu od strony serwera.

Rysunek: Okno parametrów modułu sieci - zakładka 'Komunikacja przez NetBIOS/Synchronizacja Czasu/Serwer'.

  • Serwer czasu - określa, czy stacja będzie pracować jako serwer czasu (tj. rozgłaszać w sieci informacje o bieżącym czasie):

  • Komputer nigdy nie jest serwerem czasu,

  • Komputer jest zawsze serwerem czasu - nawet jeśli w sieci pracuje serwer czasu o wyższym priorytecie,

  • Komputer jest serwerem czasu tylko jeśli ma najwyższy priorytet;

Wartość domyślna: komputer nigdy nie jest serwerem czasu

  • Priorytet serwera czasu - określa priorytet stacji jako serwera czasu; im większa wartość tym większy priorytet (0 - 32768). Wartość priorytetu przesyłana jest razem z aktualnym czasem w pakietach synchronizacyjnych (BROADCAST). Jeżeli aktywny w danej chwili serwer czasu odbierze pakiet zawierający wyższy priorytet, to przestaje być aktywnym serwerem czasu.

Wartość domyślna: 0

  • Interwał serwera czasu - określa interwał czasu (w sekundach), z jakim wysyłane są do sieci pakiety zawierające bieżący czas stacji.

Wartość domyślna: 0

  • Maksymalny interwał serwera czasu - określa maksymalny interwał wysyłania pakietów zawierających bieżący czas

Wartość domyślna: 60 sekund

  • Warunek aktywacji serwera czasu - stacja stanie się serwerem czasu, gdy od dotychczasowego serwera czasu nie dostanie określonej przez użytkownika liczby kolejnych pakietów synchronizacyjnych;

Wartość domyślna: 5

  • Replikacja pakietów czasu - określa liczbę dopuszczalnych replikacji pakietu czasu; maksymalna ilość kolejnych stacji, z jakich może się składać trasa pakietu czasu. Parametr ma znaczenie tylko na stacji będącej serwerem czasu.

Wartość domyślna: 2

uwaga Zakładka Diagnostyka - AslView pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Komunikacja poprzez NetBIOS/Diagnostyka - AslView dotyczy konfiguracji informacji diagnostycznych przekazywanych do programów AslView przyłączonych do modułu sieciowego.

Rysunek: Okno parametrów modułu sieci - zakładka 'Diagnostyka' / 'AslView'.

  • Historia - określa:

  • Maksymalna ilość zapisów w historii połączeń modułu sieciowego;

Wartość domyślna: 0;

  • Maksymalna ilość zapisów w historii zmian czasu;

Wartość domyślna: 50;

  • Maksymalna ilość zapisów w historii połączeń klienta/serwera;

Wartość domyślna: 300;

  • Blokada zmian - parametr określa uprawnienia dotyczące zmiany parametrów z poziomu programu AslView:

  • Zezwalaj na zmiany parametrów z poziomu programu AslView;

  • Nie zezwalaj na zmiany parametrów z poziomu programu AslView;

  • Blokuj hasłem zmianę parametrów z poziomu programu AslView;

Hasło - parametr określa hasło, które musi wprowadzić użytkownik programu AslView przed dokonaniem czynności powodujących istotne zmiany w funkcjonowaniu modułu sieciowego.

Wartość domyślna: nie ma zezwolenia na zmiany parametrów z poziomu programu AslView.

Obowiązuje parametr Czas ważności logowania zdefiniowany w module Zabezpieczenia.


4.10.4 Parametry zaawansowane

uwaga Zakładka Zaawansowane pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Zaawansowane pozwala określić następujące opcje.

Rysunek: Okno parametrów modułu sieci - zakładka 'Zaawansowane'.

  • Filtrowanie sieciowych nazw komputerów - określenie tekstowego filtru, jakiemu podlegać będą nazwy stacji zdalnych; stacje o nazwach niezgodnych z filtrem nie będą widoczne; nazwa może zawierać znaki ? i * (tylko na końcu); nazwy kilku stacji podaje się oddzielając je przecinkami;

Wartość domyślna: brak (wszystkie stacje są widoczne)

  • Maksymalny czas operacji nadawania - maksymalny czas trwania operacji nadawania; jednostką jest okres czasu równy 500ms;

Wartość domyślna: 30 (15 sekund)

  • Maksymalny czas operacji odbioru - maksymalny czas trwania operacji odbioru; jednostką jest okres czasu równy 500ms;

Wartość domyślna: 30 (15 sekund)

  • Sprawdzanie łączności - czas, po którym zostanie wysłany pakiet sprawdzający stan połączenia w sieci lokalnej;

Wartość domyślna: 5 sekund

  • Sprawdzanie łączności WAN - czas, po którym zostanie wysłany pakiet sprawdzający stan połączenia w sieci rozległej;

Wartość domyślna: 60 sekund

  • Lokalne połączenia - możliwe połączenia pomiędzy klientami i serwerami znajdującymi się na tej samej stacji bez udziału oprogramowania sieciowego.

Wartość domyślna: opcja jest włączona

uwaga Włączenie opcji jest koniczne w przypadku korzystania z programu AsixConnect pobierającego dane z lokalnego Asmena i Aspada.


4.10.5 Parametry diagnostyczne

 uwaga Zakładka Diagnostyka pojawia się po wybraniu polecenia Widok > Pokaż opcje zaawansowane z menu okna programu Architekt.

Zakładka Diagnostyka obejmuje parametry sterujące informacjami diagnostycznymi wyprowadzanymi przez moduł Aslink:

Rysunek: Okno parametrów modułu sieci - zakładka 'Diagnostyka'.

  • Plik logu - definiuje nazwę pliku, w którym będą zapisywane informacje diagnostyczne oraz maksymalny rozmiar pliku (w MB)

Wartość domyślna: plik o nazwie ’aslink.log’ o maksymalnym rozmiarze: 500 000 KB

  • Zapisz informacje o ... - pozwala określić rodzaj informacji, która zostanie zapisana do pliku logu; istnieje możliwość zadeklarowania zapisu informacji o:

  • Pakietach odebranych,

  • Pakietach wysłanych,

  • Wywołania CALLBACK,

  • Wywołania API,

  • Danych zawartych w pakietach organizacyjnych,

  • Pakietach danych,

  • Danych \zawartych w pakietach danych,

  • Rozgłaszanych pakietach czasu,

  • Operacjach NetBios NBC

Wartość domyślna: żaden rodzaj informacji nie jest zadeklarowany

  • Rozmiar danych - określa maksymalną długość części danych pakietów sieciowych, która będzie zapisywana w pliku log;

Wartość domyślna: 10 B.


4.11 Konfiguracja zabezpieczenia aplikacji

Grupa parametrów zabezpieczenia ikonka Zabezpieczenia obejmuje aktywację mechanizmu dynamicznych zabezpieczeń systemowych, definiowanie haseł poziomowych, a w przypadku stosowania systemu logowania - definiowanie użytkowników oraz blokadę komend mogących powodować zmianę stanu aplikacji.

Mechanizmy zabezpieczeń systemowych pozwalają na łatwe zabezpieczanie dostępu do potencjalnie niebezpiecznych funkcji systemu operacyjnego, których nieumiejętne lub nieodpowiedzialne użycie przez operatora mogłoby doprowadzić do uszkodzenie systemu. Jednocześnie, użycie mechanizmów zabezpieczeń, pozwala na pracę systemu Asix na konto użytkowników systemu Windows o dużych uprawnieniach, co ułatwia konserwację i zarządzanie pracą systemu operacyjnego. Mechanizm zabezpieczeń dynamicznych zintegrowany jest z systemem Asix i powoduje włączanie i wyłączanie zabezpieczeń, w zależności od sposobu konfiguracji systemu kontroli dostępu w aplikacji.

Zestaw zabezpieczeń przełączanych dynamicznie obejmuje następujące mechanizmy:

- blokada dostępu do menedżera zadań (klawisze Ctrl+Alt+Del);

- ukrywanie i blokada paska zadań;

- blokada klawiszy otwierających menu startowe (klawisze Ctrl+Esc i Windows);

- blokada wyświetlania plików pomocy HLP.

Sposób przełączania zabezpieczeń zależy od sposobu konfiguracji systemu kontroli dostępu w aplikacji. Możliwe są dwa warianty:

- aktywny jest system użytkowników aplikacji (logowania); wówczas zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora;

- aktywny jest tylko system haseł poziomowych; zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy aktywne jest hasło poziomu 4.

W przypadku stosowania systemu haseł poziomowych dostępne są cztery poziomy uprawnień wymaganych do realizacji akcji operatorskich oraz operacji sterujących kontrolowanym procesem.

System logowania pozwala zdefiniować dowolną liczbę użytkowników, z których każdy posiada hasło jednego z pięciu poziomów uprawnień.

Szczegółowy opis mechanizmów zabezpieczeń stosowanych w systemie Asix (w tym stosowanie trybu haseł poziomowych oraz trybu logowania użytkowników) znajduje się w podręczniku ”Asix - funkcjonalność i zasady działania”, rozdziale Konstruktor - projektowanie aplikacji.


4.11.1 Aktywacja mechanizmu dynamicznych zabezpieczen

4.11.1 Aktywacja mechanizmu dynamicznych zabezpieczeń. Określenie trybu haseł poziomowych

Zakładka Zabezpieczenia umożliwia zdefiniowanie następujących parametrów:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Zabezpieczenia'.

  • Zabezpieczenia systemowe - pozwala aktywować mechanizm dynamicznych zabezpieczeń systemowych; w przypadku gdy aktywny jest system użytkowników aplikacji - wówczas zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora; gdy aktywny jest system haseł poziomowych - zabezpieczenia dynamiczne są wyłączane tylko wtedy, gdy aktywne jest hasło poziomu 4;

Wartość domyślna: zabezpieczenia systemowe są wyłączone

  • Tryb pracy systemu haseł:

  • Tryb użytkowników.

  • Tryb haseł poziomowych;

Wartość domyślna: ’Tryb użytkowników’


4.11.2 Parametryzacja systemu logowania

Zakładka Tryb użytkowników - aktywna w przypadku włączenia trybu pracy systemu zabezpieczeń użytkowników jako Tryb użytkowników, pozwala określić:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Tryb użytkownika'.

  • Identyfikator domyślnego użytkownika - użytkownik taki jest automatycznie logowany (bez pytania o hasło) na starcie aplikacji systemu Asix;

Wartość domyślna: brak zadeklarowanego użytkownika domyślnego

  • Czas ważności hasła - określa czas ważności operacji zalogowania; po upływie zdefiniowanego czasu, użytkownik zostaje wylogowany lub następuje przełączenie na użytkownika domyślnego;

Wartość domyślna: 0, czyli czas ważności operacji logowania jest nieograniczony - aż do momentu wyłączenia aplikacji

  • Lista zdefiniowanych użytkowników - pozwala utworzyć pozycje użytkowników aplikacji obejmujące: identyfikator, nazwę, hasło i poziom uprawnień;

Wartość domyślna: brak listy zdefiniowanych użytkowników, co oznacza brak możliwości logowania do systemu Asix i tym samym brak możliwości wykonania operacji chronionych określonym poziomem zabezpieczeń

uwaga Deklaracje użytkowników przechowywane są w zewnętrznym pliku ’Users.ini’, znajdującym się w katalogu głównym aplikacji.


4.11.3 Parametryzacja systemu hasel poziomowych

4.11.3 Parametryzacja systemu haseł poziomowych

Zakładka Tryb haseł poziomowych - aktywna w przypadku włączenia trybu pracy systemu zabezpieczeń użytkowników jako Tryb haseł poziomowych, pozwala określić:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Tryb haseł poziomowych'.

  • Czas ważności hasła - okresu czasu w minutach, w którym ustawione hasło pozostaje w stanie ważności;

Wartość domyślna: 15 minut

  • Lista zdefiniowanych haseł poziomowych - zawiera pozycje, w których zapisane są treści haseł dla poszczególnych poziomów.

Wartość domyślna: hasło nie jest zdefiniowane, co pociąga za sobą brak kontroli na danym poziomie (jeżeli zadeklarowany został tryb haseł poziomowych

uwaga Hasła poziomowe przechowywane są w zewnętrznym pliku ’Passwords.ini’, znajdującym się w katalogu głównym aplikacji.


4.11.4 Parametryzacja blokad

Zakładka Blokady pozwala zablokować wybrane elementy związane z obsługą aplikacji:

Rysunek: Okno parametrów zabezpieczeń - zakładka 'Blokady'.

  • Blokada zmian - umożliwia zablokowanie wykonania wszystkich komend, które mogą powodować zmianę stanu aplikacji w sposób niezamierzony przez projektanta: zablokowanie Konstruktora, zablokowanie edycji raportów, zablokowanie edycji trendów oraz zablokowanie możliwości otwierania masek z poziomu Panelu Kontrolnego za pomocą komendy MASKI.OTWÓRZ;

Wartość domyślna: domyślnie blokada jest wyłączona

  • Blokada zamykania aplikacji obejmuje warianty:

  • Zezwalaj na zamykanie aplikacji;

  • Nie zezwalaj na zamykanie aplikacji;

  • Zabezpiecz zamykanie aplikacji - hasłem lub też poziomem uprawnień:

  • Hasło lub poziom uprawnień - jeśli stosowany jest Tryb użytkowników a dostęp do aplikacji zablokowany został hasłem, wówczas znaczenia nabiera parametr Czas ważności logowania, zdefiniowany na zakładce Tryb użytkowników;

Wartość domyślna: domyślnie komenda końca jest dostępna bez ograniczeń

uwaga Blokada dotyczy tylko wyjścia poprzez zamknięcie Okna Konstruktora lub Panelu Kontrolnego. Dostępna jest jeszcze alternatywna metoda wyjścia poprzez akcję operatorską KONIEC.

  • Blokada konstruktora zawiera warianty:

  • Zezwalaj na przejście do konstruktora;

  • Nie zezwalaj na przejście do konstruktora;

  • Zabezpiecz przejście do konstruktora - hasłem lub poziomem uprawnień:

  • Hasło lub poziom uprawnień - jeśli stosowany jest Tryb użytkowników a dostęp do Konstruktora zablokowany został hasłem, wówczas znaczenia nabiera parametr Czas ważności logowania, zdefiniowany na zakładce Tryb użytkowników;

Wartość domyślna: domyślnie Konstruktor jest dostępny bez ograniczeń

  • Blokada Sterowania - pozwala zablokować wykonywanie w aplikacji operacji sterujących; stosowana na stanowiskach zdalnych;

Wartość domyślna: domyślnie sterowanie nie jest blokowane

uwaga Użycie blokady sterowania nie powoduje zakłóceń w pracy obiektów klasy PRZELICZNIK mimo, że wykonują one sterowanie.


4.12 Konfiguracja parametrow wydrukow

4.12 Konfiguracja parametrów wydruków

Grupa wydruk ikonka Wydruk - to miejsce gdzie użytkownik ma możliwość zadeklarowania wyglądu wydruków - w tym wydruków alarmów.


4.12.1 Deklaracja zezwolenia na wydruki Deklaracja zmian

4.12.1 Deklaracja zezwolenia na wydruki. Deklaracja zmian kolorów wykonywanych podczas wydruków zrzutów masek

Zakładka Drukowanie pozwala zadeklarować użycie drukarki oraz zdefiniować zamianę kolorów wykonywanych podczas wydruków zrzutów masek lub ekranu:

Rysunek: Okno parametrów wydruków - zakładka 'Drukowanie'.

  • Zezwolenie drukowania - pozycja decydująca o tym, czy program będzie wykonywał wydruki; obsługiwane są wszystkie drukarki dostępne w systemie; jeżeli jakaś operacja nie pozwala na indywidualny wybór drukarki, to używana jest systemowa drukarka domyślna;

Wartość domyślna: domyślnie wydruki są wykonywane;

  • Zmiana koloru - pozycja pozwala na zdefiniowanie zamian kolorów wykonywanych podczas wydruków zrzutów masek lub ekranu;

sposób zapisu zamiany koloru:

r, g, b, zr, zg, zb, np.: 0,0,0,255,255,255 zamienia kolor czarny na biały,

parametry r, g, b (liczby dziesiętne określające składowe RGB) definiują kolor, który ma zostać na wydruku zamieniony na kolor zr, zg, zb.

Wartość domyślna: brak deklaracji


4.12.2 Deklaracja wydruku ekranu

Zakładka Wydruk ekranu pozwala określić następujące parametry:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk ekranu'.

  • Automatyczny zrzut:

  • Pytaj przed wykonaniem zrzutu ekranu;

  • Nie pytaj przed wykonaniem zrzutu ekranu;

  • Nie pytaj przed wykonaniem zrzutu ekranu i nie wyświetlaj informacji po jego wykonaniu;

Wartość domyślna: domyślnie przed każdym zrzutem ekranu otwierane jest okno dialogowe w celu określenia parametrów zrzutu

  • Parametry zrzutu - pozycja określająca parametry zrzutu ekranu:

  • Blokada zrzutu - blokada zrzutu ekranu;

  • Okno - zaznaczenie opcji umożliwi zrzut aktywnego okna;

  • Ekran - zaznaczenie opcji umożliwi zrzut całego ekranu;

  • Plik BMP - zaznaczenie opcji umożliwi zrzut do pliku w formacie BMP;

  • Drukarka - zaznaczenie opcji umożliwi wydruk w formacie wybranej drukarki;

Wartość domyślna: domyślne ustawienia: wykonywany jest zrzut całego ekranu do pliku w formacie BMP;

uwaga Podane parametry mogą być zmodyfikowane przez operatora, jeżeli nie zostanie użyta opcja Automatyczny zrzut.

  • Kartoteka zrzutów ekranu - parametr pozwala określić kartotekę roboczą aplikacji; kartoteka robocza służy jako miejsce przechowania plików zrzutów ekranu;

Wartość domyślna: jeśli pozycja nie zostanie wykorzystana, jako kartoteka robocza zostanie użyta kartoteka aktywna w momencie startu aplikacji.


4.12.3 Deklaracja parametrow czcionek oraz naglowkow i stopek

4.12.3 Deklaracja parametrów czcionek oraz nagłówków i stopek

Zakładka Wydruk określa parametry dotyczące formatu nagłówków i stopek oraz rodzaju czcionek wykorzystywanych w tworzonych wydrukach (zrzutach masek):

  • Zakładka Nagłówki i stopki:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk' / 'Nagłówki i stopki'.

  • Nazwa aplikacji - tekst wyświetlany w linii nagłówków i stopek tworzonych wydruków;

  • Nagłówek - określa tekst nagłówka na wszystkich rodzajach wydruków (oprócz alarmów on-line - dla których tekst nagłówka definiowany jest na zakładce Wydruk alarmów);

Wartość domyślna: w przypadku, gdy użytkownik nie zadeklaruje własnego tekstu nagłówka, domyślnie wstawiony zostanie tekst określany znakiem sterującym: &w | | ASIX.

  • Stopka - definiuje tekst stopki na wszystkich rodzajach wydruków (oprócz alarmów on-line - dla których tekst stopki definiowany jest w pozycji Stopka listingu alarmów na zakładce Wydruk alarmów);

Wartość domyślna: określana jest znakami sterującymi &D &T|&p|&c; dopuszczalne są znaki sterujące opisane w pozycji Nagłówek.

  • Marginesy - pozwala ustawić marginesy dla wydruków; pozycja dotyczy wszystkich drukarek i większości wydruków (oprócz wydruku trendów i wydruków wykonywanych w trybie tekstowym); jednostką marginesów jest 1/10 mm;

Wartość domyślna: wszystkie marginesy są równe 0;

  • Zakładka Czcionki:

Rysunek: Okno parametrów wydruków - zakładka' Wydruk' / 'Czcionki'.

  • Czcionka - określenie czcionki dla wydruku informacji tekstowej; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Courier New,0;

  • Czcionka nagłówka - określa czcionkę używaną do drukowania nagłówków; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Times New Roman,30;

  • Czcionka stopki - określa czcionki używane do drukowania stopek; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Times New Roman,30.

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.


4.12.4 Deklaracja wydruku raportow

4.12.4 Deklaracja wydruku raportów

Zakładka Wydruk raportów pozwala zadeklarować:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk raportów'.

  • Nagłówek raportu - definiuje tekst nagłówka jaki jest dodawany do wydruku raportu;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek na zakładce Wydruk.

  • Stopka raportu - definiuje tekst stopki jaki jest dodawany do wydruku raportu;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka na zakładce Wydruk.

  • Ustawienia / Raporty w trybie tekstowym - standardowo raporty są wykonywane w trybie graficznym. Skutkiem użycia tej opcji jest to, że stosowane we wcześniejszych raportach sekwencje sterujące czcionką wstawiane w treść raportu przestają działać. Włączenie trybu tekstowego powoduje wydruk raportów w sposób kompatybilny z wersjami programu AS wcześniejszymi od 2.59;

Wartość domyślna: wydruk w trybie graficznym

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.


4.12.5 Deklaracja wydruku alarmów

Zakładka Wydruk alarmów obejmuje parametry definiujące format wydruku alarmów historycznych oraz aktywnych:

  • Zakładka Nagłówki i stopki:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Nagłówki i stopki'.

  • Nagłówek alarmów historycznych - definiuje tekst nagłówka na wydrukach alarmów historycznych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek (zakładka Wydruk);

  • Nagłówek alarmów aktywnych - definiuje tekst nagłówka na wydrukach alarmów aktywnych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Nagłówek (zakładka Wydruk);

  • Stopka alarmów historycznych - definiuje tekst stopki na wydrukach alarmów historycznych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka (zakładka Wydruk);

  • Stopka alarmów aktywnych - definiuje tekst stopki na wydrukach alarmów aktywnych;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany w pozycji Stopka (zakładka Wydruk);

  • Nagłówek listingu alarmów - definiuje tekst nagłówka używanego podczas wydruku alarmów bieżących w trybie graficznym;

Wartość domyślna: domyślnie drukowany jest tekst: listing zdarzeń alarmowych| |

  • Stopka listingu alarmów - definiuje tekst stopki używanej podczas wydruku alarmów bieżących w trybie graficznym;

Wartość domyślna: domyślnie drukowany jest tekst zdefiniowany znakami sterującymi:

&D &T|&p|&c

Zestaw dostępnych znaków sterujących wykorzystywanych w deklaracji nagłówków i stopek znajduje się w Załącznik 4.

  • Zakładka Czcionki zawiera definicje czcionek wykorzystywanych w wydrukach alarmów:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Czcionki'.

  • Czcionka alarmów - określa czcionki dla wydruku alarmów w trybie graficznym; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: Courier New,0;

  • Czcionka nagłówka alarmów - określa czcionki używane w nagłówkach wydruków alarmów; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: jeśli parametr nie jest określony, obowiązuje ustawienie z pozycji Czcionka nagłówka (zakładka Czcionki);

  • Czcionka stopki alarmów - określa czcionki używane w stopkach wydruków alarmów; wysokość podawana w dziesiątych częściach milimetra; wartość 0 oznacza automatyczne skalowanie do szerokości kartki;

Wartość domyślna: jeśli parametr nie zostanie określony, obowiązuje ustawienie z pozycji Czcionka stopki (zakładka Czcionki).

  • Zakładka Opcje pozwala zdefiniować:

Rysunek: Okno parametrów wydruków - zakładka 'Wydruk alarmów' / 'Opcje'.

  • Długość tekstu alarmu - określa ilość znaków używanych do wydruku tekstu alarmu; standardowo długość ta jest wyliczana na około 90 znaków, tak aby cała linia wydruku nie przekraczała 120 znaków;

  • Formaty wydruku alarmów:

  • Format linii alarmów - określa ilość i kolejność drukowania informacji; jest to łańcuch znakowy złożony z liter definiujących typy pól - znaki definiujące format linii alarmów znajdują się w Załącznik 5;

  • Format linii alarmów systemowych - pozycja pozwala określić format używany do wydruku alarmów systemowych; znaki używane do definicji formatu są opisane przy pozycji Format linii alarmów;

Wartość domyślna: formatem domyślnym jest format podany w pozycji Format linii alarmów;

  • Ustawienia:

  • Drukuj zdarzenia systemowe - specyfikuje, czy należy drukować zdarzenia systemowe;

Wartość domyślna: domyślnie zdarzenia systemowe są drukowane

  • Liniowy wydruk alarmów - pozycja określa tryb wydruku alarmów bieżących; tryb liniowy jest wydrukiem tekstowym, identycznym z trybem używanym w wersjach programu AS poniżej 2.59; linie alarmów są drukowane po jednej w momencie zajścia zdarzenia (drukarka może jednak zbuforować tekst wewnętrznie i wydrukować dopiero pełną stronę); w trybie graficznym wydruku najpierw gromadzona jest pełna strona alarmów i dopiero wtedy jest wykonywany wydruk; dodawane są również nagłówek i stopka wydruku;

Wartość domyślna: wydruki alarmów bieżących domyślnie wykonywane są w trybie graficznym;

  • Separator daty w wydrukach alarmów historycznych - określa, czy w wydruku alarmów historycznych mają być wstawiane linie sygnalizujące zmianę daty alarmów;

Wartość domyślna: domyślnie parametr nie jest używany;

  • Wydruk alarmów - pozycja powodująca włączenie natychmiastowego wydruku alarm;

  • Drukuj na domyślnej drukarce - użycie pierwszej formy pozycji oznacza wydruk na domyślnej drukarce systemowej;

  • Nie drukuj alarmów;

  • Drukuj na wybranej drukarce - pozwala określić dowolną zainstalowaną na komputerze drukarkę.

Wartość domyślna: wydruk na domyślnej drukarce


4.12.6 Znaki specjalne sterujące formatem wydruków

Zestawienie znaków sterujących wyglądem nagłówków i stopek znajduje się w Załącznik 4.

Zestawienie znaków sterujących formatem linii alarmów znajduje się w Załącznik 5.


4.13 Deklaracja obslugi definicji raportow

4.13 Deklaracja obsługi definicji raportów

Moduł [image] Raporty obejmuje parametry konfiguracyjne modułu raportowego.

Zakładka Raporty obejmuje następujące parametry konfiguracyjne:

Rysunek: Okno parametrów raportów - zakładka 'Raporty'.

  • Blokada edycji - pozycja umożliwiająca zablokowanie możliwości poprawiania definicji raportów w trybie wykonania aplikacji; odblokowanie edycji może być celowe w czasie rozruchu (nie jest wymagane wówczas przechodzenie do Konstruktora);

Wartość domyślna: domyślnie parametr jest wyłączony, co oznacza, że można zmieniać raporty w trybie wykonania aplikacji

  • Blokada skalowania - użycie parametru pozwala na blokadę rozmiaru okna raportów;

Wartość domyślna: domyślnie operator może dowolnie zmieniać rozmiar okna raportów;

  • Kartoteka, w której znajdują się pliki z definicjami raportów;

Wartość domyślna: domyślnie pliki z definicjami raportów znajdują się w bieżącej kartotece aplikacji

  • Liczba dni o jaką maksymalnie można się cofnąć przy obliczaniu raportów - podaje okres czasu liczony wstecz od momentu bieżącego (w dniach), o jaki maksymalnie można się cofnąć przy obliczaniu raportów; podanie okresu niedodatniego lub większego od 366 dni powoduje przyjęcie okresu domyślnego: 366 dni;

Wartość domyślna: 0 dni

uwaga Pozycja ta pozwala na pewne zaoszczędzenie pamięci operacyjnej wymaganej do uruchomienia modułu raportowego. Ograniczenie dopuszczalnego okresu może pozwolić na obliczanie raportów w sytuacji, w której normalnie moduł raportowy nie mógł wcześniej wystartować ze względu na brak pamięci.


4.13.1 Deklaracja plikow raportow skryptowych

4.13.1 Deklaracja plików raportów skryptowych

Zakładka Parametry skryptowe obejmuje:

Rysunek: Okno parametrów raportów - zakładka 'Raporty skryptowe'.

  • Pliki raportów skryptowych - pozwala zadeklarować użycie raportu skryptowego wg nastęopującego

format zapisu:

nazwa_raportu, nazwa_pliku_kodu_raportu [, nazwa_pliku _wynikowego, parametry_raportu]

gdzie:

nazwa_raportu - parametr jest dowolnym tekstem opisującym raport; nazwa ta będzie wyświetlana na liście raportów okna Raportera oraz będzie służyła do uruchamiania raportu przy pomocy akcji operatorskich;

nazwa_pliku_kodu_raportu - parametr służy do podania nazwy pliku z kodem raportu; można podać pełną ścieżkę do pliku lub tylko nazwę pliku wraz z rozszerzeniem; w drugim przypadku plik raportu będzie poszukiwany w katalogu podanym w pozycji Kartoteka, w której znajdują się pliki z definicjami raportów i w katalogach ścieżki masek;

nazwa_pliku_wynikowego - parametr służy do podania nazwy bazowej plików, w których będą przechowywane wygenerowane raporty; nazwy plików wynikowych tworzone są poprzez dodanie do nazwy bazowej rozszerzenia zależnego od daty tworzenia raportu; parametr nazwa_pliku_wynikowego powinien być użyty tylko wtedy, gdy na podstawie tego samego pliku kodu tworzone są różne rodzaje raportów (patrz opis parametru parametry_raportu); pominięcie parametru lub wstawienie znaku * oznacza, że nazwy plików wynikowych raportu są tworzone na podstawie nazwy pliku kodu raportu;

parametry_raportu - parametr pozwala na tworzenie parametryzowanych plików kodu raportu; zawartość parametru jest w całości przekazywana do skryptu w momencie jego uruchomienia i może służyć do sterowania pracą skryptu; należy pamiętać o tym, aby w przypadku używania tego samego pliku kodu raportów w wielu pozycjach SKRYPT, podawać w każdej z nich unikalną nazwę pliku wynikowego.

W treści parametrów raportu można podawać parametry wykonawcze skryptera (więcej na temat deklaracji skryptu można znaleźć w podręczniku ”Skrypty - podręcznik użytkownika” - plik Skrypty.hlp lub Skrypty.pdf):

//S - w danej chwili może być uruchomiony tylko jeden skrypt z parametrem //S, zawarty w podanym pliku; parametr ma znaczenie tylko w przypadku uruchamiania skryptu jako akcji operatorskiej systemu Asix; moduł skryptów odrzuci próbę ponownego uruchomienia skryptu w sytuacji, gdy poprzednie uruchomienie skryptu z parametrem //S, zawartego w tym samym pliku, jeszcze się nie zakończyło; brak tego parametru powoduje, że można równocześnie uruchamiać wiele skryptów w oparciu o program zawarty w tym samym pliku;

//X - po uruchomieniu skryptu jest również uruchamiany debugger (zainstalowany w systemie jako domyślny); debugger zatrzymuje wykonanie skryptu na pierwszej instrukcji skryptu;

//D - wystąpienie błędu w skrypcie powoduje uruchomienie debuggera;

//IT:nnn - ograniczenie czasu wykonania części inicjalizacyjnej wyrażone w milisekundach;

//T:nnn - ograniczenie czasu wykonania części zdarzeniowej wyrażone w milisekundach;

//E:nazwa - podaje nazwę języka skryptu (np. //E:JScript);

//Watek:nazwa[,pri] - podaje nazwę wątku, w którym wykonuje się skrypt oraz określa priorytet pri wątku; nazwa wątku może być dowolna i służy grupowaniu skryptów wykonywanych w jednym wątku; priorytety wątku skryptu:

0 IDLE - bezczynny,

1 LOWEST - najniższy,

2 BELOW_NORMAL - poniżej normalnego,

3 NORMAL - normalny (domyślny),

4 ABOVE_NORMAL - powyżej normalnego,

5 HIGHEST - najwyższy,

6 TIME_CRITICAL - krytyczny czasowo;

domyślnym priorytetem wątku jest priorytet 3 (normalny);

//U - podanie tego parametru spowoduje, że nie będą generowane zdarzenia ”OnRead" oraz funkcje zdarzeń czasowych zdefiniowane metodami SetInterval i ExecuteAt, jeśli okna aplikacji Asix są ukryte (np. za pomocą akcji operatorskiej UKRYJ).

uwaga Parametry wykonawcze podaje się w konwencji programu cscript, tj. są one poprzedzone podwójnym ukośnikiem.


4.13.2 Deklaracja listy operatorow do okna raportowego

4.13.2 Deklaracja listy operatorów do okna raportowego

Zakładka Lista operatorów obejmuje parametr:

Rysunek: Okno parametrów raportów - zakładka 'Raporty' / 'Lista operatorów'.

  • Lista operatorów - pozwala zadeklarować nazwiska operatorów, które będą wyświetlane w oknie raportowym.


4.14 Konfiguracja parametrow skryptow i akcji

3.14 Konfiguracja parametrów akcji i terminarzy akcji

Grupa skrypty i akcje Akcje i terminarze obejmuje parametry związane z:

  • deklaracją akcji złożonych;

  • konfiguracją terminarza.

- Lista akcji operatorskich wraz z parametryzacją przy użyciu edytora akcji omówiona została w punkcie 4.16. Lista akcji operatorskich.

- Ponadto szczegółowy opis składni akcji operatorskich znajduje się również w podręczniku ”Asix - funkcjonalność i zasady działania”.


4.14.1 Deklaracja akcji zlozonych

4.14.1 Deklaracja akcji złożonych

Zakładka Akcje złożone pozwala zdefiniować dla danej aplikacji akcje złożone, będące sekwencją dowolnego zestawu akcji operatorskich, przypisanych do jednej akcji operatora.

Lista akcji operatorskich wraz z parametrami omówiona została w punkcie 4.16. Lista akcji operatorskich.

Zaimplementowany generator bazy akcji złożonych umożliwia generowanie definicji akcji na podstawie danych zawartych w plikach *. act (przycisk Importuj akcje złożone (act)) oraz eksportowanie definicji akcji do zewnętrznego pliku *.xls (przycisk Eksportuj akcje złożone (xls)).

Dla ułatwienia użytkownik ma możliwość załączania/wyłączania wszystkich akcji należących do jednej akcji złożonej za pomocą skrótu klawiszowego Ctrl + '+' / Ctr + '-'. Wystarczy kliknąć na nagłówek Akcje składowe lub na definicje jednej z akcji i użyć skrótu.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Akcje złożone'.


4.14.2 Deklaracja terminarza akcji

Zakładka Terminarz pozwala sparametryzować moduł programu AS, który pozwala na automatyczne wykonywanie wybranych akcji w konkretnym terminie lub w odpowiedzi na zmianę wartości wybranej zmiennej procesowej.

Szczegółowy opis modułu Terminarz znajduje się w podręczniku ”Asix - podręcznik użytkownika”.

Typowym zastosowaniem terminarza jest automatyczne okresowe obliczanie raportów lub wykonywanie akcji związanych z obsługą bazy danych po otrzymaniu sygnału ze sterownika.

Zakładka Terminarz czasowy - umożliwia zdefiniowanie akcji terminarza, uruchamianych na podstawie warunków czasowych.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Terminarz czasowy'.

W polu Termin znaczenie poszczególnych pól jest następujące:

  • Czas wykonania - pole służące do podania czasu (z dokładnością do minuty), w którym akcja ma zostać wykonana;

  • Potwierdzenie - zaznaczenie pola wyboru powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania,

  • Dzień wykonania - pole służące do podania numeru dnia w miesiącu, w którym akcja ma zostać wykonana; wartość Codziennie umożliwia wykonywanie akcji codziennie.

  • Akcja - treść akcji, która ma zostać wykonana;

Zakładka Terminarz zdarzeniowy - umożliwia zdefiniowanie akcji terminarza, uruchamianych w odpowiedzi na zmianę wartości wybranej zmiennej procesowej.

Rysunek: Okno parametrów skryptów i akcji - zakładka 'Terminarz zdarzeniowy'.

Pole Okres - oznacza okres sprawdzania monitorowanych zmiennych.

Wartość domyślna: 10 s.

W polu Zdarzenie znaczenie poszczególnych pól jest następujące:

  • Nazwa zmiennej - nazwa zmiennej procesowej, od której wartości jest uzależnione wykonanie akcji;

  • Warunek - rozwijana lista służąca do określenia rodzaju sprawdzanego warunku; dostępne są 4 typy warunków:

= - zmienna równa podanej wartości,

> - zmienna większa od ograniczenia,

< - zmienna mniejsza od ograniczenia,

& - iloczyn logiczny zmiennej i podanej wartości,

  • Wartość - liczba względem której porównywana jest wartość monitorowanej zmiennej procesowej; jest to dziesiętna liczba całkowita lub liczba zmiennoprzecinkowa; program automatycznie uzgadnia typy danych zmiennej i wartości; nie można stosować warunku typu "&" dla danych zmiennoprzecinkowych.

  • Potwierdzenie - wybranie tego pola powoduje, że przed wykonaniem akcji nastąpi odpytanie operatora o zezwolenie jej wykonania

  • Akcja - treść akcji, która ma zostać wykonana;


4.14.3 Określenie trybu pracy bazy akcji złożonych

Architekt daje możliwość definiowania akcji złożonych w dwojaki sposób, określany Trybem pracy bazy akcji złożonych:

- definicje akcji złożonych są wprowadzane przez projektanta w module Skrypty i akcje > na zakładce Akcje złożone;

- definicje akcji złożonych są generowane na podstawie danych w arkuszach kalkulacyjnych.

Drugi z wymienionych trybów wskazany jest w pracy z dużą ilością akcji złożonych. Umożliwia zdefiniowanie akcji w kilku arkuszach, a następnie zaimportowanie ich definicji do podanego obszaru/komputera. Aby zmienić definicję akcji, należy zmodyfikować pliki źródłowe i wygenerować od nowa bazę akcji złożonych. W przypadku stosowania tego trybu pracy edytor akcji umożliwia jedynie przeglądanie akcji.

Deklaracja trybu pracy bazy akcji złożonych odbywa się za pomocą parametru umieszczonego w module Bazy danych > Baza akcji złożonych > zakładka Tryb pracy.

Rysunek: Okno Bazy akcji złożonych - zakładka 'Tryb pracy'.


4.15 Grupa Pozostale

4.15 Grupa Pozostałe

Grupa rózne Pozostałe zawiera parametry nie zaklasyfikowane do pozostałych grup. Są to następujące kategorie parametrów:

- Aplikacja,

- Parametry skryptów,

- Parametry skryptu - dane archiwalne,

- Przelicznik,

- Opcje wprowadzane bezpośrednio.


4.15.1 Deklaracja rozmiaru aplikacji oraz kartoteki roboczej

4.15.1 Deklaracja rozmiaru aplikacji oraz kartoteki roboczej dla plików zrzutów ekranów

Zakładka Aplikacja pozwala określić parametry:

Rysunek: Okno parametrów pozostałych - zakładka 'Aplikacja'.

  • Rozmiar aplikacji - rozdzielczość ekranu w pikselach, w której tworzona jest aplikacja; użycie pozycji oznacza, że w przypadku pracy w rozdzielczości ekranu większej od podanej w pozycji, punkt otwarcia masek i innych elementów będzie tak przesuwany, ażeby aplikacja działała na środku ekranu;

Wartość domyślna: w przypadku nie zadeklarowania wartości, okno aplikacji pojawi się w lewym górnym rogu ekranu o rozdzielczości większej od tej, w której wykonywana była aplikacja

  • Klawisze dla ekranu - włączenie pozycji powoduje, że interpretacja znaczenia przyciśniętych klawiszy zależy od aktualnego położenia kursora myszki; brane są pod uwagę tylko maski znajdujące się na tym samym ekranie co myszka; pozycja ma zastosowanie w systemach wielomonitorowych; mechanizm ten pozwala na różną interpretację znaczenia klawisza w zależności od ekranu, którego w danej chwili używa operator;

Wartość domyślna: opcja wyłączona


4.15.2 Parametryzacja obsługi skryptów

Zakładka Parametry skryptów pozwala określić:

Rysunek: Okno parametrów pozostałych - zakładka 'Parametry skryptów'.

  • Plik logu - parametr określa nazwę pliku, w którym będą zapisywane informacje diagnostyczne;

Wartość domyślna: jeśli parametr nie jest podany, to plik logu nie zostanie utworzony

  • Ustawienia debuggera - parametr określa zakres współpracy modułu skryptów z debuggerem skryptów

  • Uruchamiaj skrypty bez debuggera - wybranie tej opcji oznacza, że debugger nie zostanie nigdy uruchomiony; w przypadku timeoutu lub błędu skryptu do panelu programu AS zostanie wyprowadzona informacja o błędzie z podaniem numeru linii i znak; parametry wykonawcze //X i //D podawane w deklaracji skryptu nie mają znaczenia, jeśli zadeklarowana zostanie opcja Uruchamiaj skrypty bez debuggera;

  • Uruchamiaj skrypty pod kontrolą debuggera - opcja umożliwia uruchamianie skryptów pod kontrolą debuggera;

  • Uruchamiaj skrypty i włączaj debugger w chwili inicjalizacji modułu skryptów;

Wartość domyślna: Uruchamiaj skrypty bez debuggera

uwaga Parametr Ustawienia debuggera ma znaczenie tylko wtedy, gdy w systemie operacyjnym Windows został zainstalowany odpowiedni debugger skryptów.

  • Maksymalny czas obsługi zdarzenia przez skrypt - parametr określa maksymalny czas obsługi zdarzenia przez skrypt. Jeśli wartością tego parametru jest 0, to czas obsługi zdarzenia nie jest ograniczony. Jednostką jest czas wyrażony w milisekundach.

Wartość domyślna: 5000 milisekumd

  • Maksymalny czas wykonania części inicjalizacyjnej skryptu - parametr określa maksymalny czas wykonywania części inicjalizacyjnej skryptu. Jeśli wartością tego parametru jest 0, to czas wykonywania części inicjalizacyjnej skryptu nie jest ograniczony. Jednostką jest czas wyrażony w milisekundach.

Wartość domyślna: 15000 milisekumd

  • Automatyczne przeładowywanie w przypadku błędów - jeśli opcja jest włączona, to błędy czasu wykonania wykryte w fazie inicjalizacji skryptu oraz w czasie pierwszego wywołania dowolnej funkcji obsługującej zdarzenia, powodują zakończenie skryptu. Błąd, który wystąpi później, spowoduje zakończenie bieżącego wykonania skryptu, a następnie skrypt jest ponownie uruchamiany od początku.

Wartość domyślna: opcja załączona

Zakładka Parametry skryptu - dane archiwalne pozwala określić:

Rysunek: Okno parametrów pozostałych - zakładka 'Parametry skryptów - dane archiwalne'.

  • Tryb agregacji - opcja ustawia wartość parametru AggregateMode. Służy do określenia trybu agregacji dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości 0 (ASKOM), 1 (OPC) lub 2 (RAPORT).

Wartość domyślna: 0 - tryb ASKOM.

  • Próg jakości dobrej - opcja ustawia wartość parametru QualityGoodThreshold. Służy do określenia progu jakości dla próbek dobrych dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości od 0 do 100 (próg jakości wymnożony przez 100 i wyrażony w procentach).

Wartość domyślna 80 - 80% próbek daje jakość dobrą.

  • Próg jakości złej - opcja ustawia wartość parametru QualityBadThreshold. Służy do określenia progu jakości dla próbek złych dla funkcji ReadProcessed obiektu Variable. Przyjmuje wartości od 0 do 100 (próg jakości wymnożony przez 100 i wyrażony w procentach).

Wartość domyślna 0 - każdy agregat, który nie jest dobry, jest zły i nie ma niepewnych.

uwaga Więcej informacji nt parametrów z zakładki 'Parametry skryptów - dane archiwalne' - patrz: podręcznik do modułu AsSkrypter - plik Skrypty.chm/pdf, rozdz. 6.12. Obiekt Variable.


4.15.3 Parametryzacja obiektów PRZELICZNIK i WYRAŻENIE

Zakładka Przelicznik zawiera parametry:

Rysunek: Okno parametrów pozostałych - zakładka 'Przelicznik'.

  • Maksymalny czas - maksymalny czas (w sekundach) liczenia się obiektu PRZELICZNIK lub WYRAŻENIE;

Wartość domyślna: 30 sekund

  • Przeciążenia - pozycja pozwala zablokować komunikaty diagnostyczne informujące o przeciążeniach w obiektach PRZELICZNIK i WYRAZENIE;

Wartość domyślna: domyślnie komunikaty są generowane;


4.15.4 Deklaracja parametrów wprowadzanych bezpośrednio

uwaga Zakładka Opcje wprowadzane bezpośrednio pojawia się po wybraniu polecenia: Widok > Pokaż opcje zaawansowane

Rysunek: Okno parametrów pozostałych - zakładka 'Opcje wprowadzane bezpośrednio'.

Zakładka Opcje wprowadzane bezpośrednio pozwala zadeklarować dla danej aplikacji pozycje, których edycja nie jest wspierana przez moduł Architekt - tzn. są to pozycje używane w starszych wersjach pakietu Asix lub zupełnie nowe pozycje.


4.16 Lista akcji operatorskich

Akcje operatorskie są podstawowym środkiem sterowania pracą aplikacji przez operatora. Akcje mogą być udostępniane operatorowi, przez projektanta systemu, za pomocą obiektów klasy PRZYCISK, Zestawów Klawiszy lub definiowanych menu.

Akcje opisywane są poprzez łańcuchy tekstowe. Opisy akcji wprowadzane są w odpowiednich polach edycyjnych. Pola te dokonują automatycznego formatowania tekstu, jeżeli wprowadzony zostanie poprawny tekst. Opis akcji składa się z nazwy akcji oraz jej parametrów.

Dla wygody projektanta istnieje możliwość użycia edytora budowy akcji operatorskich, wywoływanego kliknięciem prawym przyciskiem myszy w polu edycyjnym, w którym wprowadzana jest akcja operatorska. W kolejnym podpunkcie zamieszczono opisy akcji operatorskich ze wskazaniem sposobu ich parametryzacji przy użyciu Edytora akcji.

Rysunek: Okno edytora akcji operatorskich.

Lista dostępnych akcji operatorskich obejmuje:

ASAUDIT - sterowanie wyświetlaniem okien programów modułu AsAudit

ASBASE - pozwala na zdalne sterowanie pracą programu AsBase

ASTREND - sterowanie pracą programu ASTREND, w tym możliwość wyświetlenia lub wydrukowania trendu

DRUKUJ - wydrukowanie pliku

FILTR_SERWERÓW - blokowanie dostępu do stanowisk sieciowych

GRAJ - odtworzenie pliku typu WAV

HASŁO - odpytanie operatora o hasło

KONIEC - zakończenie pracy programu AS

KURSOR - ustawienie pozycji kursora

LANGUAGE - przełączenie języka aplikacji

LICZ_RAPORT - obliczenie raportu

LOGUJ - logowanie użytkowników

MAKRO - odtworzenie makra

MENU - otwarcie zdefiniowanego menu

NIC - akcja pusta

OBLICZ - otwarcie okna dialogów

OBSŁUGA_HASEŁ - otwarcie okna zarządzania hasłami

ODCZYT_HISTORII - uzupełnienie danych historycznych z drajwerów

OPIS_ZMIENNEJ - wyświetlenie informacji na temat wskazanej zmiennej

OTWÓRZ_MASKĘ - otwarcie maski

PANEL - selekcja Panelu Kontrolnego

PAUZA - wstrzymanie działania programu

PISZ_RAPORT - obliczenie i wydrukowanie raportu

POKAŻ_RAPORT - obliczenie i wyświetlenie raportu

POŁĄCZ_ALARMY - przyłączenie do określonego źródła alarmów historycznych

POTWIERDŹ_ALARMY - potwierdzenie alarmów na maskach alarmów aktywnych

PRZEŁĄCZ_ZASÓB_ALARMÓW - dynamiczne przełączanie zasobów alarmów

PRZEPISZ - przesłanie wartości pomiędzy zmiennymi procesowymi

PYTAJ - otwarcie okna z pytaniem do operatora

RAPORTUJ - otwarcie okna systemu raportów

SKRYPT - zlecenie wykonania skryptu

STERUJ_BITY - wysłanie wartości bitowej do sterownika

SYGNAŁY - wybór alarmów, których pojawienie się powoduje sygnalizację dźwiękową

SYNCHRONIZUJ_ARCHIWUM - akcja operatorska wymusza wykonanie przez moduł ASPAD synchronizacji archiwów typu SQL, podanych w treści akcji

TABELA - otwarcie okna tabeli zmiennych

UCISZ_SYGNAL - wyłączenie sygnału dźwiękowego alarmu

UKRYJ_WSZYSTKO - zwinięcie całej aplikacji do ikony

URUCHOM - uruchomienie programu

USTAW_WARTOŚĆ - wysłanie wartości liczbowej do sterownika

USTAW WYKRES - ustawianie czasu obiektu Wykres

WYDRUK_EKRANU - powoduje wydruk całego ekranu lub aktywnego okna

WYKLUCZENIE - zmiana stanu wykluczenia alarmu

WYLOGUJ - natychmiastowe wylogowanie aktywnego użytkownika

WYŚLIJ_STEROWANIA - zlecenie wysłania sterowań przez obiekty na maskach

ZAMKNIJ_MASKĘ - zamknięcie maski

ZMIANA_CZASU - otwarcie okna służącego do zmiany czasu

ZMIEN_BITY - zmiana wartości wybranych bitów zmiennej procesowej

ZOBACZ - wyświetlenie pliku


4.17. Konfiguracja aplikacji wielojezycznej

4.17 Konfiguracja aplikacji wielojęzycznej

System aplikacji wielojęzycznych pozwala przełączać na żądanie operatora język pracy aplikacji. Przełączeniu podlegają wszystkie teksty wprowadzone przez projektanta na etapie tworzenia aplikacji.

Sparametryzowanie aplikacji do pracy w kilku językach wymaga wykonania następujących kroków:

  1. Pierwszą rzeczą, którą należy wykonać jest ustawienie parametrów deklarowanych języków:

    2. Maski > zakładka Języki:

    pl, Polski, EastEurope

    en, Angielski, EastEurope

    Ważna jest przy tym kolejność wpisywanych języków – pierwszy język jest głównym (domyślnym) językiem.

    Szczegółowy opis dotyczący deklarowania kilku języków pracy dla aplikacji znajduje się w podręczniku ”Asix - podręcznik użytkownika”, rozdziale Aplikacje wielojęzyczne.

  2. Następnie należy utworzyć listę używanych w aplikacji tekstów. Z pomocą przychodzi tu mechanizm Tablicy Translacji, który służy do tłumaczenia tekstów wprowadzonych przez operatora w trakcie definiowania aplikacji. Dotyczy to głównie tekstów z obiektów umieszczonych na maskach wizualizacyjnych.

Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TranslateTable.Lng. Jest to plik tekstowy, w którym poszczególne linie są tekstami wielojęzycznymi.

Bazowy plik Tablicy Translacji można wygenerować automatycznie przy pomocy funkcji PLIK_TŁUMACZEŃ z menu NARZĘDZIA okna Konstruktora.

Po wybraniu kategorii generowanych informacji i użyciu przycisku Generuj wszystkie znalezione teksty zostaną zapisane w pliku TranslateTable.Tlt. Jeżeli istniał wcześniej plik TranslateTable.Lng, to wszystkie zawarte w nim tłumaczenia będą przeniesione do pliku generowanego.

Projektant powinien uzupełnić brakujące tłumaczenia bezpośrednio w pliku TranslateTable.Lng lub uzupełnić plik TranslateTable.Tlt i przemianować go na TranslateTable.Lng.

Po wygenerowaniu tablicy translacji należy uzupełnić wpisy wg poniższego przykładu:

[pl]tekst polski[en]english text

Edycji tekstów można dokonać przy pomocy edytora modułu Architekt:

Maski > zakładka Języki > Tablica translacji, przycisk Edytuj

  3. Jeżeli aplikacja zaciąga opisy z bazy definicji zmiennych, należy również tam wprowadzić pewne modyfikacje. W pliku XLS obok kolumny Opis w każdym arkuszu należy utworzyć kolumny o nazwach w stosownych językach (w których ma pracować aplikacja), w których należy umieścić odpowiedniki opisów znajdujących się w kolumnie Opis.

W przypadku arkusza źródłowego do generowania bazy definicji alarmów Alarmy opis znajduje się w jednej kolumnie zgodnie z zapisem: [pl]tekst polski[en]english text.

  4. Do tłumaczenia tekstów aplikacji wielojęzycznych stosowany jest również mechanizm Tablicy Tekstów, który służy do tłumaczenia tekstów, które są wyświetlane w ramach elementów aplikacji i nie są podawane jawnie przez projektanta (są wbudowane w kod programu). Mechanizm jest uruchamiany, jeżeli w katalogu startowym aplikacji zostanie umieszczony plik o nazwie TextTable.Lng.

Plik Tablicy Tekstów jest plikiem tekstowym, w którym poszczególne linie są tekstami wielojęzycznymi określającym tłumaczenia tekstów.

W ramach pakietu A six jest dostarczany plik TextTable.Tlt zawierający kompletną tablicę tekstów dla języków polskiego i angielskiego. Projektant powinien skopiować ten plik do katalogu aplikacji pod nazwą TextTable.Lng, a następnie uzupełnić teksty wielojęzyczne o definicje wariantów dla pozostałych używanych języków aplikacji.

Zasada działania Tablicy Tekstów polega na wyszukiwaniu wśród zdefiniowanych wielojęzycznych tekstów tłumaczenia dla tekstu wbudowanego w program.

Edycji tekstów można dokonać przy pomocy edytora modułu Architekt:

Maski > zakładka Języki > Tablica tekstów, przycisk Edytuj


4.18. Uruchomienie aplikacji

Jak utworzyć ikonę skrótu uruchamiającą aplikację systemu Asix?:

  1. W oknie modułu Architekt otwórz plik XML aplikacji i wybierz z paska menu polecenie Narzędzia > Kreator skrótów...

  2. Określ rodzaj skrótu (Skrót do Asix), nazwę stacji - której aplikację chcesz uruchomić, nazwę skrótu, lokalizację skrótu (Pulpit lub Wybrany katalog) i naciśnij przycisk Utwórz.

  3. Teraz aplikacja może być uruchamiana za pomocą skrótu np. z Pulpitu.

Aplikacja może być również uruchamiana w czasie pracy modułu Architekt za pomocą polecenia Uruchom system Asix z menu Aplikacja. Uruchomieniu podlega plik konfiguracyjny XML z podaniem parametrów zadeklarowanych dla określonego stanowiska.

Kreator skrótów… daje również możliwość tworzenia skrótów do programu Architekt i AsTrend. W szczególności, tworząc skrót do programu Architekt, możliwe jest zadeklarowanie wsadowego generowania baz - pod warunkiem, że dla danego pliku konfiguracyjnego aplikacji zostały zadeklarowane wcześniej bazy: definicji alarmów, definicji zmiennych i definicji akcji złożonych.

Rysunek: Okno Kreatora skrótów.


4.19. Konfigurator aplikacji AsPortal

Wbudowany w program Architekt - konfigurator aplikacji AsPortal pozwala łatwo uruchomić portal informacji procesowych zaprojektowanej aplikacji.

Szczegółowy opis dotyczący funkcjonalności oraz sposobu konfigurowania aplikacji AsPortal znajduje się w podręczniku ”Asix4Internet - podręcznik użytkownika”.

Konfigurator aplikacji AsPortal uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsPortal

Obsługa Konfiguratora sprowadza się do użycia przycisków: Konfiguruj, Ustaw oraz Uruchom AsPortal.

1. Przycisk Konfiguruj na zakładce Konfiguracja serwera- tworzy kanał AsixConnect, parametryzuje plik Web.Config, nadaje prawa dostępu do katalogu bazy definicji zmiennych. Aby komenda zadziała, należy w pierwszej kolejności zainstalować moduł Asix4Internt z instalatora pakietu A six.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

2. Kilka przycisków Ustaw umożliwiających konfigurację dostępu do aplikacji znajduje się na zakładkach Ustawienia dostępu:

Aplikację można skonfigurować w taki sposób, aby dostęp do niej był anonimowy lub oparty o uwierzytelnianie systemu Windows.

Dla aplikacji AsPortal oznacza to możliwość ustawienia:

a) dostępu do przeglądania wartości zmiennych

lub

b) dostępu do modyfikowania wartości zmiennych.

ad a)

Aby ustanowić dostęp do przeglądania wartości zmiennych, należy ustawić dla aplikacji AsPortal uwierzytelnianie systemu Windows (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu > opcja Uwierzytelnianie Windows), a w bazie definicji zmiennych dodać atrybut Grupa uprawnień odczytu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienOdczytu). Następnie dla każdej zmiennej należy podać w bazie definicji zmiennych, jako wartość atrybutu Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do przeglądania wartości zmiennej.

UWAGA:

Pozostawienie pustego pola dla atrybutu Grupa uprawnień odczytu dla danej zmiennej będzie oznaczać, że zmienna ta będzie niewidoczna dla wszystkich użytkowników.

UWAGA: Załączenie mechanizmu uwierzytelniania dla AsPortala wymaga uprzedniego załączenia funkcji systemu Windows: 'Uwierzytelnianie Windows'.

Rys. Załączenie funkcji uwierzytelniania Windows.

Rys. Funkcja uwierzytelniania systemu Windows dla aplikacji AsPortal.

PRZYKŁAD

Rys. Ustawienie funkcji uwierzytelniania systemu Windows dla aplikacji AsPortal.

Rys. Nadanie grupie użytkowników 'TEST' uprawnienia odczytu zmiennej 'A046'.

Rys. AsPortal - dostęp do zmiennej 'A046' przez użytkownika z grupy 'TEST'.

ad b)

Aby ustanowić dostęp do modyfikowania wartości zmiennych, należy:

- ustawić uwierzytelnianie systemu Windows dla aplikacji AsPortal (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu > opcja Uwierzytelnianie Windows),

- załączyć funkcję modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Funkcja modyfikowania wartości zmiennych jest dostępna),

- zadeklarować nazwę grupy użytkowników systemu Windows, którzy będą mieć uprawnienie do modyfikowania wartości zmiennych (Konfigurator aplikacji internetowych > zakładka AsPortal > zakładka Ustawienia dostępu 2 > opcja Nazwa grupy uprawnionych użytkowników).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, ale NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości zmiennych - to wszyscy będą mieć prawo do modyfikacji zmiennych.

Dostęp do modyfikowania wartości zmiennych można dodatkowo zawęzić umieszczając w bazie definicji zmiennych atrybut Grupa uprawnień zapisu (w podpowiedzi okna 'Dodaj nowy atrybut' jest to atrybut GrupaUprawnienZapisu), a następnie wpisując grupę użytkowników podaną w polu Nazwa grupy uprawionych użytkowników bezpośrednio do pola atrybutu Grupa uprawnień zapisu tylko dla tych zmiennych, które mają być dostępne do modyfikacji dla danej grupy użytkowników (pozostałych zmiennych nie będzie można modyfikować).

UWAGA:

Jeśli zostanie ustawione uwierzytelnianie systemu Windows i załączona funkcja modyfikowania wartości zmiennych, a w bazie definicji zmiennych zostanie dodany atrybut Grupa uprawnień zapisu, ale dla poszczególnych zmiennych w polu atrybutu Grupa uprawnień zapisu NIE zostanie zadeklarowana żadna grupa użytkowników uprawnionych do modyfikowania wartości tych zmiennych - to nikt nie będzie mieć prawa do modyfikowania zmiennych.

UWAGA:

Jeśli oprócz pola Nazwa grupy uprawionych użytkowników i/lub atrybutu Grupa uprawnień zapisu w bazie definicji zmiennych zostanie zadeklarowany atrybut Grupa uprawnień odczytu - użytkownik będzie miał możliwość modyfikowania wartości zmiennej pod warunkiem, że będzie należał do grupy użytkowników uprawnionych do zapisu wartości zmiennej oraz do grupy użytkowników uprawnionych do odczytu wartości danej zmiennej.

Rys. Deklaracja dostępu do odczytu i zapisu zmiennych w bazie definicji zmiennych.

Rys. Dostęp do zapisu zmiennej w AsPortal.

3. Przycisk Uruchom AsPortal na zakładce Klient - pozwala uruchomić AsPortal z dostępem do danych procesowych pracującej aplikacji

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsPortal

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsPortal

***

Zakres wyświetlanych informacji na temat zmiennych procesowych można określić wykorzystując Edytor wyglądu aplikacji AsPortal uruchamiany poleceniem:

menu Aplikacja > Konfiguruj wygląd aplikacji AsPortal

Edytor pozwala określić listę atrybutów wyświetlanych:

- w oknie podglądu bazy i wyboru zmiennych z podaniem liczby wierszy wyświetlanych na jednej stronie (zakładka Baza definicji zmiennych);

- w tabeli danych bieżących (zakładka Dane bieżące);

- w tabeli zmiennych, w nagłówkach tabeli wynikowej, w legendzie na stronie wydruku - dla danych prezentowanych w formie tabelarycznej (zakładka Dane archiwalne - tabela);

- w tabeli zmiennych, w legendzie na stronie wydruku - dla danych prezentowanych w postaci wykresów (zakładka Dane archiwalne - wykres).

Ponadto, na zakładce Aplikacje znajdują się edytory umożliwiające zadeklarowanie adresów, pod którymi dostępne będą internetowe aplikacje pakietu Asix (z poziomu AsPortala):

- aplikacja demo;

- AsTrend;

- AsAlarmNet;

- ReportServer (serwer raportów przygotowanych z wykorzystaniem środowiska AsRaport na bazie usług MS Reporting Services);


4.20. Konfigurator internetowej aplikacji AsTrend

4.20. Konfigurator internetowej wersji programu AsTrend

Wbudowany w program Architekt - konfigurator internetowej wersji programu AsTrend pozwala łatwo skonfigurować program na podstawie ustawień bieżącej aplikacji systemu Asix.

Szczegółowy opis dotyczący funkcjonalności programu AsTrend znajduje się w podręczniku ”AsTrend - prezentacja danych archiwalnych”.

Konfigurator AsTrend uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsTrend

Obsługa Konfiguratora sprowadza się do użycia dwóch przycisków:

Konfiguruj na zakładce Konfiguracja - polecenie aktualizuje plik konfiguracyjny internetowej wersji programu AsTrend - plik default.htm w zakresie ustawień parametrów połączenia sieciowego oraz nazwy bazy definicji zmiennych na podstawie ustawień bieżącej aplikacji systemu Asix. W sytuacji, gdy definicje zmiennych przechowywane są w bazie *.mdb, w momencie konfigurowania baza definicji zmiennych kopiowana jest do katalogu w/w programu. W przypadku stosowania bazy definicji zmiennych w formacie MS SQL, należy zapewnić stacjom klienckim dostęp do serwera SQL, na którym umieszczona jest baza - jeśli nie jest to możliwie, rozwiązaniem jest zastosowanie bazy definicji zmiennych w formacie pliku *.mdb.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

Dodatkowo, konfigurator daje możliwość edycji adresów IP serwerów danych.

Rys. Konfigurator internetowej wersji programu AsTrend.

Ustaw na zakładce Ustawienia dostępu - polecenie pozwala skonfigurować kontrolę dostępu do programu.

Dostęp do odczytu wartości zmiennych jest chroniony jeśli włączone jest uwierzytelnianie systemu Windows dostępu do aplikacji i baza definicji zmiennych zawiera atrybut 'Grupa uprawnień odczytu'. Wtedy dla każdej zmiennej należy podać, jako wartość atrybutu 'Grupa uprawnień odczytu', nazwę grupy użytkowników uprawnionych do odczytu wartości zmiennej.

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsTrend

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsTrend


4.21. Konfigurator internetowej wersji AsAlarm

Wbudowany w program Architekt - konfigurator internetowej wersji programu AsAlarm pozwala łatwo skonfigurować program na podstawie ustawień bieżącej aplikacji systemu Asix.

Szczegółowy opis dotyczący funkcjonalności programu AsAlarm znajduje się w podręczniku ”AsAlarm - interaktywna analiza historycznych zdarzeń alarmowych aplikacji systemu Asix”.

Konfigurator AsAlarm uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj aplikacje internetowe > zakładka AsAlarm

Obsługa Konfiguratora sprowadza się do użycia dwóch przycisków:

Konfiguruj na zakładce Konfiguracja - polecenie aktualizuje plik konfiguracyjny internetowej wersji programu AsAlarm - plik index.htm w zakresie ustawień dotyczacych nazwy bazy definicji zmiennych oraz bazy alarmów na serwerze MS SQL na podstawie ustawień bieżącej aplikacji systemu Asix. W sytuacji, gdy definicje zmiennych przechowywane są w bazie *.mdb, w momencie konfigurowania baza definicji zmiennych kopiowana jest do katalogu w/w programu. W przypadku stosowania bazy definicji zmiennych w formacie MS SQL, należy zapewnić stacjom klienckim dostęp do serwera SQL, na którym umieszczona jest baza (podobnie jak do serwera MS SQL z bazą alarmów.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

Ustaw na zakładce Ustawienia dostępu - pozwala skonfigurować kontrolę dostępu do programu.

Aplikacja jest dostępna lokalnie pod adresem:

http://localhost/AsAlarm

Aplikacja jest dostępna w sieci lokalnej pod adresem:

http://<nazwa komputera w systemie Windows>/AsAlarm


4.22. Konfigurator systemu raportowania AsRaport

Konfigurator systemu raportowania AsRaport umożliwia przygotowanie środowiska systemu Asix do tworzenia i obsługi raportów projektowanych w oparciu o Microsoft Reporting Services.

Konfigurator systemu AsRaport uruchamiany jest komendą z menu głównego:

Aplikacja > Konfiguruj system raportów AsRaport...

Utworzenie bazy danych AsixConnect

Procedury składowane bazy danych AsixConnect za pośrednictwem programu Askom.Data.Host udostępniają do środowiska raportowego dane procesowe z aplikacji Asix.

Baza danych AsixConnect tworzona jest za pośrednictwem programu Architekt – jest to pierwszy krok, jaki należy wykonać, przygotowując w systemie Asix środowisko do tworzenia raportów z użyciem Reporting Services.

UWAGA: Baza danych AsixConnect jest niezbędna do pracy systemu raportowania w oparciu o dane procesowe Asixa.

Aby utworzyć bazę danych AsixConnect z dostępem do danych aplikacji systemu Asix:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Baza danych AsixConnect

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect/Lokalizacja i logowanie.

3. Na zakładce Lokalizacja i logowanie wybierz nazwę serwera MS SQL dla bazy danych AsixConnect, określ sposób weryfikacji użytkowników i kliknij przycisk Utwórz bazę.

Dostępne są trzy sposoby weryfikacji użytkowników dla bazy danych AsixConnect:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika ‘_asix_internal’ zdefiniowanego w serwerze MS SQL – domyślnie utworzonego w momencie instalowania pakietu Asix (warunkiem utworzenia takiego użytkownika jest zainstalowanie serwera MS SQL przed rozpoczęciem instalacji pakietu Asix)

3. Weryfikacja wg użytkownika serwera MS SQL, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport przed utworzeniem bazy danych AsixConnect.

4. Na zakładce Opcje bazy danych AsixConnect istnieje możliwość:

- określenia innego położenia serwera danych Askom.Data.Host (domyślnie serwer danych Askom.Data.Host i baza AsixConnect znajdują się na tym samym komputerze);

- zadeklarowania traktowania punktów o jakości niepewnej jako punkty o jakości dobrej lub jako punkty o jakości złej;

- konfiguracji systemu zmianowego:

Początek pierwszej zmiany - oznacza godzinę rozpoczęcia pierwszej zmiany;

Długość zmiany - okres czasu deklarowany w godzinach.

5. Ustawienia na zakładce Opcje bazy danych AsixConnect zostaną zapisane do bazy danych AsixConnect przy użyciu przycisku Wpisz opcje do bazy.

6. Jeśli domyślny port IP 6001 został zmieniony, należy go zarezerwować klikając przycisk Zarezerwuj port IP. Należy to zrobić na komputerze, na którym pracuje program Askom.Data.Host. Do czynności tej wymagane są uprawnienia administratora.

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – Baza danych AsixConnect/Opcje bazy danych AsixConnect.

***

Parametryzacja dostępu do bazy definicji zmiennych i systemu alarmów

Dla klasycznej wersji aplikacji pakietu Asix

Dla klasycznej wersji aplikacji pakietu Asix na podstawie nazwy komputera serwera aplikacji systemu Asix pobierane są do systemu raportowania AsRaport następujące parametry aplikacji:

- położenie bazy definicji zmiennych deklarowane przy użyciu:

Architekt > Bazy danych > Baza definicji zmiennych > zakładka Format

- nazwa sieciowa zestawu alarmów deklarowana przy użyciu:

Architekt > Obszary i komputery > System alarmów > zakładka Alarmy / Nazwa sieciowa

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów pobierana jest z bazy definicji zmiennych; należy jednak wcześniej wygenerować bazę definicji zmiennych alarmów SQL (czyli alarmów, których archiwum zdarzeń przechowywane jest w bazie SQL deklarowanej w: Architekt > Obszary i komputery > System alarmów > zakładka Archiwum > Serwer Microsoft SQL), która zostanie dołączona do bazy definicji zmiennych:

Architekt > Bazy danych > Baza definicji alarmów SQL > Źródła danych > Generator bazy definicji alarmów SQL

Dla aplikacji wersji Evo pakietu Asix

Dla aplikacji wersji Evo pakietu Asix na podstawie nazwy komputera serwera aplikacji systemu Asix pobierane są do systemu raportowania AsRaport następujące parametry aplikacji:

- położenie bazy definicji zmiennych deklarowane przy użyciu:

Architekt > Bazy danych > Baza definicji zmiennych > zakładka Format

- nazwa serwera MS SQL i nazwa bazy danych archiwum alarmów pobierana jest z bazy definicji zmiennych; należy jednak wcześniej wygenerować bazę definicji zmiennych alarmów SQL (czyli alarmów, których archiwum zdarzeń przechowywane jest w bazie SQL deklarowanej w: AsixEvo.exe > Eksplorator aplikacji > System alarmów > Konfiguracja systemu alarmów > Ustawienia > Baza danych alarmów historycznych), która zostanie dołączona do bazy definicji zmiennych:

Architekt > Bazy danych > Baza definicji alarmów SQL > Źródła danych > Generator bazy definicji alarmów SQL

Aby zadeklarować nazwę komputera serwera aplikacji systemu Asix (zarówno dla wersji klasycznej jak i Evo):

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Opcje

3. Wybierz z rozwijanego pola nazwę komputera i kliknij przycisk OK.

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – 'Opcje'.

***

Deklaracja serwera raportów

Deklaracja serwera raportów MS Reporting Services wykorzystywana jest do otwierania raportów utworzonych w środowisku MS Reporting Services, bezpośrednio z poziomu aplikacji systemu Asix. Wspomniane raporty mogą być wówczas przeglądane za pomocą stosownych przeglądarek systemu Asix (zarówno w wersji klasycznej jak i wersji Evo).

Aby zadeklarować serwer raportów:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Serwer raportów

3. Zadeklaruj adres serwera raportów, nazwę kartoteki w serwerze raportów i określ sposób weryfikacji użytkowników.

Dostępne są trzy sposoby weryfikacji użytkowników dla serwera raportów:

1. Weryfikacja wg bieżącego użytkownika Windows – logowanie bieżącego użytkownika systemu operacyjnego Windows

2. Weryfikacja wg użytkownika o nazwie ‘AskomInternal’ zdefiniowanego w systemie Windows – domyślnie utworzonego w momencie instalowania pakietu Asix

3. Weryfikacja wg użytkownika Windows, zdefiniowanego przy użyciu Architekta w konfiguratorze systemu raportowania AsRaport

4. Kliknij przycisk OK.

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – 'Serwer raportów'.

***

Określenie progów jakości danych archiwalnych

Aby określić progi jakości danych archiwalnych:

1. Uruchom program Architekt i otwórz w nim plik konfiguracyjny aplikacji Asixa. (W aplikacji robionej technologią Asix.Evo stosowny plik konfiguracyjny zostanie uruchomiony w programie Architekt, jeśli użyjesz przycisku [image] z zakładki Źródła danych panelu roboczego Ustawienia stanowisk.)

2. Uruchom konfigurator systemu raportowania AsRaport:

Architekt > menu Aplikacja > Konfiguruj system raportów AsRaport... > zakładka Opcje

3. Zadeklaruj próg jakości dobrej i jakości złej.

Próg jakości dobrej [%] - agregat ma jakość dobrą, jeżeli w interwale liczba próbek dobrych jest równa lub przekracza zadany próg jakości dobrej.

Próg jakości złej [%] - agregat ma jakość złą, jeżeli w interwale liczba próbek złych jest równa lub przekracza zadany próg jakości złej.

4. Kliknij przycisk OK.

powiększ >>

Rys.: Okno ‘Konfigurator systemu raportowania AsRaport’ – zakładka 'Opcje'.

***

Uruchomienie programu Askom.Data.Host

Aby możliwe było pobieranie danych procesowych z aplikacji Asixa, musi być przez cały czas uruchomiony program Askom.Data.Host.

Askom.Data.Host.exe domyślnie umieszczany jest przez instalator pakietu Asix w katalogu głównym pakietu C:\Program Files\Askom\Asix.


4.23. Generator aplikacji WWW

Generator aplikacji WWW pozwala wygenerować aplikację internetową, która może być oglądana przez użytkownika w przeglądarce Internet Explorer 6/7. Wystarczy jedno przyciśnięcie przycisku, aby wszystkie komponenty standardowej aplikacji zostały przekonwertowane do formatu wymaganego przez aplikację WWW.

Szczegółowy opis dotyczący konwertowania aplikacji Asixowej na aplikację WWW znajduje się w podręczniku ”Asix4Internet – podręcznik użytkownika”.

Generator aplikacji WWW uruchamiany jest z programu Architekt poleceniem Generuj aplikację WWW... z menu Aplikacja.

Podgląd aplikacji uruchamiany przyciskiem Pokaż podgląd wykorzystuje przeglądarkę Internet Explorer.

Rysunek: Okno generatora aplikacji WWW.

Rysunek: Okno generatora aplikacji WWW – raport z generowania aplikacji.

Aplikacja jest dostępna lokalnie po wpisaniu w przeglądarce IE6 adresu:

http://localhost/<nazwa katalogu wirtualnego aplikacji>

Aplikacja jest dostępna w sieci lokalnej pod adresem

http://<nazwa komputera w systemie Windows>/<nazwa katalogu wirtualnego aplikacji>

Rysunek: Widok aplikacji WWW w przeglądarce IE 7.


4.24. Konwerter trendow 1

4.24. Konwerter trendów 1

Konwerter trendów służy do przekonwertowania pliku dat zawierającego definicje trendów (trendy definiowane w plikach dat dostępne były w systemie Asix do wersji 3) do postaci definicji trendów obsługiwanych przez program AsTrend (pliki trnx).

W deklarowanej bazie definicji zmiennych aplikacji muszą znajdować się definicje zmiennych, na których opierają sie definicje trendów z plików dat. W tym celu przed przystąpieniem do konwertowania plików dat z definicja trendów należy w pierwszej kolejności zaimportować wspomniane definicje zmiennych do aktualnej bazy definicji zmiennych projektowanej aplikacji.

Rysunek: Konwerter trendów.

Dodatkowe parametry dotyczące konwersji trendów v1 ustawiane są w module Parametry startowe > Programy > AsTrend2. Są to: możliwość zadeklarowania katalogu przekonwertowanych trendów oraz opcja, której załączenie skutkuje pominięciem parametrów akcji RYSUJ_TREND w trakcie jej konwertowania na akcję ASTREND (chodzi o parametry: początek i koniec trendu oraz drukuj - początek i koniec konwertowanych trendów można określić podając w oknie konwertera trendów v1 plik trendu wzorcowego ze zdefiniowanym momentem początkowym i końcowym). (Patrz: 3.4.2 Deklaracja programów startowanych jednocześnie z aplikacją).


4.25. Edytor Tabeli Zmiennych

Tabele zmiennych pozwalają na łatwe tworzenie okien służących do przeglądania aktualnych wartości zmiennych Asmena. Tabele dostępne są w trybie edycyjnym z poziomu Architekta lub w trybie aplikacyjnym przez użycie akcji operatorskiej TABELA.

Pełne wsparcie w zakresie projektowania tabel dostarcza edytor tabel dostępny w module Architekt (edytor dostępny od wersji Asix 6):

Architekt > Obszary i komputery > Maski > Tabela > Otwórz edytor tabeli

Przełomem w funkcjonalności obiektu Tabela jest możliwość dostępu do opisów bitów zmiennych statusowych oraz opisów wartości bitów zmiennych statusowych. W tym zakresie edytor tabel w pełni wspomaga projektanta zarówno w tworzeniu tabel wartości dwustanowych - w których wartości bitów danej zmiennej mogą być wyświetlane w kolejnych kolumnach w ramach jednego wiersza zmiennej, bądź też tabel diagnostycznych słowa statusowego napędu – gdzie wartości bitów jednej zmiennej prezentowane są w kolejnych wierszach tabeli. Ciekawostką jest również możliwość realizacji akcji operatorskich wywoływanych z poziomu tabeli – z osobnych pól tabeli na podstawie definicji przechowywanych w bazie definicji zmiennych.

Interfejs edytora zaprojektowany został w taki posób, aby logicznie zgrupować poszczególne parametry definiujące tabelę na oddzielnych zakładkach - w ten sposób użytkownik ma do dyspozycji 4 zakładki:

Tabela – obejmującą podstawowe parametry tabeli takie jak położenie i rozmiar okna;

Kolumny – do parametryzacji nagłówków i formatu wyświetlanych danych;

Wiersze – określającą zmienne, których wartości będą prezentowane w tabeli (wartość zmiennej lub wartość pojedynczego bitu)

oraz

Kolory – do formatowania kolorystyki tabeli i wyświetlanych wartości.

Wszystkie zmiany wprowadzane do definicji tabeli można na bieżąco ‘monitorować’ na podglądzie, wywoływanym przyciskiem umieszczonym na panelu głównym edytora. Dodatkowo, na panelu głównym umieszczone zostały opcje symulujące ustawienia parametrów akcji operatorskiej (ma to znaczenie w przypadku projektowania wzorca tabeli, który zostanie wykorzystany do wywoływania różnych zestawów zmiennych).

Rysunek: Okno edytora tabeli.

Podstawowe założenia funkcjonalne obiektu Tabela:

- Tabela w swojej istocie nie jest obiektem w rozumieniu Asixa (moduł zewnętrzny dostarczany w postaci biblioteki DLL), a w związku z tym nie można jej osadzić na masce aplikacji;

- jeden wiersz Tabeli opisuje wartość i atrybuty związane z pojedynczą zmienną procesową;.

- zmienne procesowe zajmują kolejne wiersze a atrybuty pokazywane są w kolumnach;

- Tabela umożliwia otwieranie starych plików konfiguracyjnych Tabel (utworzonych w starszych wersjach Asixa);

- obiekt Tabela ma możliwość automatycznej parametryzacji w zakresie zestawu zmiennych do wyświetlenia na podstawie bazy definicji zmiennych (możliwość dynamicznej wymiany wyświetlanego zestawu zmiennych w oparciu o zawartość bazy definicji zmiennych);

- rozmiar Tabeli automatycznie dostosowywany jest do ilości zmiennych oraz atrybutów do wyświetlania, z uwzględnieniem parametrów wyświetlania np. rodzaj i rozmiar fontu (dynamiczna liczba zmiennych procesowych do wyświetlania dla danego typu tabeli);

- dla dowolnej kolumny/atrybutu istnieje możliwość zadeklarowania łącznika (linku) uruchamiającego akcję operatorską systemu Asix (składnia akcji operatorskiej przechowywana w bazie definicji zmiennych);

- dla zmiennych procesowych przekazujących informacje statusowe wprowadzona została możliwość deklarowania wielu kolumn zawierających złożenie wartości zmiennej i maski bitowej.


4.25.1. Plik definicji Tabeli

Dane opisujące tabelę pamiętane są w plikach tekstowych o rozszerzeniu *.TBL.

Poniżej przykład okna Tabeli wraz z zawartością pliku definicji prezentowanej Tabeli.

Rysunek: Okno przykładowej Tabeli.

Zawartość pliku definicji powyższej tabeli wygląda następująco:

[Tabela]

Tytuł=Pomiary K-2

Pozycja=17,93

LiczbaKolumn=4

LiczbaWierszy=21

NrKolumnyWartości=3

Czcionka=Tahoma,-13,[],EastEurope

Format=%d

Belka=1

Siatka=0

Paski=1

BłądFormat=

Szerokość=-1

Wysokość=-1

Przesunięcie=30

[Kolory]

Tło=192,192,192

Czcionka=0,0,0

PasekTło=175,175,175

LimitHHTło=255,0,0

LimitHHCzcionka=255,255,255

LimitHHMigotanie=1

LimitHTło=255,0,0

LimitHCzcionka=255,255,0

LimitLTło=0,0,160

LimitLCzcionka=255,255,0

LimitLLTło=0,0,160

LimitLLCzcionka=255,255,255

LimitLLMigotanie=1

BłądTło=255,255,191

BłądCzcionka=255,0,0

Migotanie=0

PasekCzcionka=0,0,0

PasekMigotanie=0

LimitHHTłoDomyślne=0

LimitHTłoDomyślne=0

LimitHMigotanie=0

LimitLTłoDomyślne=0

LimitLMigotanie=0

LimitLLTłoDomyślne=0

BłądTłoDomyślne=0

BłądMigotanie=0

[Kolumny]

1=Nazwa,10

2=Opis,35

3=Wartość,7

4=Jednostka,7

[Wiersze]

1=FQUIT2130

2=FQUIT2230

3=FQUIT2330

4=FQUIT2430

5=K2_Fgaz

6=TIT2506

7=PICAL2111

8=PICAL2311

9=K2_Pgaz

10=

11=FITR2004

12=TIR2807

13=

14=FITR2005

15=TICR2813

16=TICR2823

17=K2_Tpara

18=

19=K2_MocQ

20=K2_Vspr

21=

Zawiera on dwie kategorie informacji:

- Pozycje deklarujące wygląd oraz zestaw kolumn tabeli;

sekcje [Tabela], [Kolory], [Kolumny]

- Pozycje deklarujące zestaw zmiennych procesowych oraz kolejność ich wyświetlania;

sekcja [Wiersze]

Szczegółowy opis poszczególnych parametrów znajduje się w dokumentacji 'Asix - funkcjonalność i zasady działania' (plik asix.chm).


4.25.2. Konfigurowanie podstawowych parametrów Tabeli

Podstawowe parametry tabeli takie jak położenie i rozmiar okna konfigurowane są na zakładce Tabela.

Rysunek: Okno edytora Tabeli - zakładka 'Tabela'.

Położenie i rozmiar okna tabeli – umożliwia skonfigurowanie współrzędnych lewego górnego narożnika oraz wielkości okna w pikselach. Pozycję i rozmiar okna można w prosty sposób określić za pomocą testowego okna, uruchamianego przyciskiem Wybierz pozycję. Okno to można umieścić w dowolnym miejscu ekranu, a rozmiar określić przeciągając krawędzie okna za pomocą myszy - wartości tych ustawień automatycznie pojawiają się w stosownych polach definiujących położenie i rozmiar okna Tabeli.

Wygląd tabeli - obejmuje grupę opcji definiujących podstawowe cechy wyglądu Tabeli: rozmiar i treść belki tytułowej, wyświetlanie nagłówków kolumn, wyświetlanie wierszy różnymi kolorami, wyświetlanie linii siatki pomiędzy komórkami Tabeli.

W celu umożliwienia personalizacji opisu Tabeli wprowadzono tzw. modyfikatory tytułu Tabeli pozwalające na wprowadzenie do tytułu: nazwy Tabeli, nazwy atrybutu oraz wartości atrybutu. Modyfikatory posiadają następującą postać:

{TN} nazwa Tabeli

{AN} nazwa atrybutu selekcji

{AV} wartość atrybutu selekcji

Modyfikatory można wykorzystać w treści pola Tytuł.

Wygląd komórki – obejmuje parametry umożliwiające definiowanie: formatu czcionki dla tekstów w komórkach Tabeli, procentowego przesunięcia tekstu względem dolnej krawędzi komórki, formatów wyświetlania wartości zmiennych.

Automatyczna parametryzacja - parametr określający nazwę atrybutu, wg którego zostaną posortowane wiersze zmiennych wywoływane akcją operatorską przy zastosowaniu mechanizmu automatycznej parametryzacji Tabeli. Należy zwrócić uwagę na fakt, że kolejność zmiennych nie musi określać atrybut, który jest wyświetlany w tabeli. W przypadku gdy nie zostanie jawnie wskazany atrybut określający porządek wyświetlania, zmienne procesowe będą prezentowane w Tabeli w kolejności otrzymania z bazy definicji zmiennych.

Ochrona przed modyfikacją operatora - opcja wymusza ochronę modyfikacji definicji Tabeli z poziomu interfejsu użytkownika. Modyfikacje można zapisywać jedynie z poziomu administracyjnego.


4.25.3. Parametryzacja nagłówków i formatu wyświetlanych danych

Do parametryzacji nagłówków i formatu wyświetlanych danych służy zakładka Kolumny.

Rysunek: Okno edytora Tabeli - zakładka 'Kolumny'.

Nazwa atrybutu

Nazwa atrybutu (pobrana z bazy definicji zmiennych) lub dowolny tekst (ograniczony cudzysłowami), który będzie wyświetlany jako zawartość kolumny.

Szerokość

Szerokość kolumny podana w znakach.

Wyrównanie

Sposób wyrównania tekstu w kolumnie: do lewej, do prawej, wyśrodkowany.

Nagłówek

Własny opis kolumny zastępujący nazwę atrybutu.

Wyświetlana wartość

Dla atrybutu _Wartość_zmiennej możliwe jest określenie: czy wyświetlać wartość zmiennej czy wartość bitu zmiennej.

Opisy stanów

Dla atrybutu _Wartość_zmiennej opisy tekstowe przypisane poszczególnym wartościom zmiennej. Możliwe jest użycie opisów stanów zmiennej zdefiniowanych w edytorze lub bazie definicji zmiennych lub użycie wartości zmiennej w postaci liczbowej.

Sposób definiowania opisów stanów w bazie definicji zmiennych omawia rozdział Przechowywanie opisów stanów zmiennych w bazie definicji zmiennych podręcznika 'Asix - funkcjonalność i zasady działania' (Asix.chm).

Rysunek: Edytor Tabeli - okno deklaracji opisów stanów dla atrybutu '_Wartość_zmiennej'.

Kolory stanów

Dla atrybutu _Wartość_zmiennej wartości atrybutów przypisane poszczególnym wartościom zmiennej.

Rysunek: Edytor Tabeli - okno deklaracji kolorów stanów dla atrybutu '_Wartość_zmiennej'.

Nazwa atrybutu akcji

Atrybut bazy definicji zmiennych przechowujący treść akcji operatorskiej do wykonania.


4.25.4. Deklarowanie zmiennych

Do deklaracji zmiennych służy zakładka Wiersze.

Rysunek: Okno edytora Tabeli - zakładka 'Wiersze'.

Liczba wyświetlanych wierszy uzależniona jest od sposobu sparametryzowania Tabeli:

– jeżeli ma to być tabela parametryzowana automatycznie, liczba wierszy jest dynamicznie kształtowana w zależności od ilości zmiennych w wywoływanym zestawie zmiennych;

- w przypadku tabeli nie podlegającej automatycznej parametryzacji liczba wierszy widocznych w oknie Tabeli może być ustalona na sztywno (wówczas pozostałe wiersze nie są wyświetlane) lub dynamicznie (szerokość Tabeli dopasowuje się do liczby zdefiniowanych wierszy).

Numer wiersza - pozwala określić kolejność wierszy zmiennych w oknie Tabeli.

Nazwa zmiennej - określa nazwę zmiennej zadeklarowanej w bazie definicji zmiennych. Opcjonalnie można zamiast nazwy zmiennej zadeklarować numer zmiennej ujęty w klamry {}. Wpisanie liczby ujętej w klamry {} z przedziału 1 do liczby wierszy spowoduje wyświetlenie zmiennej o tym numerze spośród zmiennych uzyskanych z bazy definicji zmiennych.

Rysunek: Okno dodawania zmiennej do definicji Tabeli.

Przykładem zastosowania liczb w klamrach w polu Nazwa zmiennej jest Tabela słowa statusowego napędu, parametryzowana automatycznie względem wybranego atrybutu. Przewidując liczbę wierszy zmiennych spełniających kryterium wartości wybranego atrybutu można podać w kolejnych wierszach Tabeli numer, który określi na liście zmiennych uzyskanych z bazy definicji zmiennych –tę zmienną, której wartości bitów zostaną ostatecznie wyświetlone w oknie Tabeli, np. {1} spowoduje wyświetlenie w Tabeli wartości bitów zmiennej, która jako pierwsza została pobrana z bazy definicji zmiennych.

Rysunek: Przykład deklaracji zmiennej jako liczby w klamrach {}.

Wyświetlana wartość – pole definiuje rodzaj wyświetlanej wartości zmiennej, tj. czy wyświetlana będzie wartość zmiennej, czy też wartość określonego bitu zmiennej.


4.25.5. Atrybutyt wyświetlania zmiennych

4.25.5. Atrybuty wyświetlania zmiennych

Atrybutami wyświetlania są: kolor tła, kolor czcionki oraz migotanie wartości, deklarowane dla poszczególnych wierszy, wartości przekraczających limit, wartości błędnych. Parametry deklarujące powyższe atrybuty globalnie dla wszystkich komórek Tabeli ustawiane są na zakładce Kolory.

Dodatkowo atrybuty wyświetlania (w szczególności: kolor tła, czcionki i migotanie) mogą być deklarowane indywidualnie dla wartości bitów w polu Opisy stanów na zakładce Kolumny.

Rysunek: Okno edytora Tabeli - zakładka 'Kolory'.

Rysunek: Okno edytora Tabeli - zakładka 'Kolumny' > pole 'Kolory stanów'.


4.25.6. Automatyczna parametryzacja

Automatyczna parametryzacja daje możliwość dynamicznej wymiany wyświetlanego zestawu zmiennych w oparciu o zawartość bazy definicji zmiennych.

Automatyczna parametryzacja wymaga przy każdorazowym uruchomieniu obiektu TABELA pobrania (wyfiltrowania) z bazy definicji zmiennych zestawu zmiennych procesowych do wyświetlenia. Filtrowanie zmiennych realizowane jest na podstawie wartości atrybutu zadanej w treści akcji operatorskiej uruchamiającej Tabelę.

Przykład automatycznej parametryzacji Tabeli:

Przykładowo, zawartość bazy definicji zmiennych ma następującą postać:

Rysunek: Przykładowa definicja zmiennych.

Do dynamicznej parametryzacji zostanie użyty atrybut TABELA_DIAG. Tabela zawierać będzie zmienne, dla których atrybut TABELA_DIAG przyjmuje wartość DIAG_5. Postać wywołania akcji operatorskiej ma następującą postać:

TABELA <katalog_z_tabelami>\<nazwa_tabeli>#TABELA_DIAG=DIAG_5

Zmienne można uporządkować posługując się parametrem Nazwa atrybutu sortującego na zakładce Tabela edytora Tabeli - np. wg. atrybutu Nazwa:

Rysunek: Przykład Tabeli wyświetlonej na podstawie dynamicznie wyselekcjonowanego zestawu zmiennych posortowanych wg atrybutu 'Nazwa'.

Zmianę kolejności wyświetlania zmiennych oraz wprowadzenie wierszy separujących, zrealizować można za pomocą następującej parametryzacji na zakładce Wiersze:

Rysunek: Przykład ustalania kolejności zmiennych wraz z deklaracją wierszy separujących dla Tabeli dynamicznie parametryzowanej.

Rysunek: Przykład Tabeli wyświetlonej na podstawie dynamicznie wyselekcjonowanego zestawu zmiennych posortowanych na podstawie deklaracji zmiennych jako kolejnych numerów w klamrach {}.


4.25.7. Zamieszczanie akcji oepratorskich w Tabeli

4.25.7. Zamieszczanie akcji operatorskich w Tabeli

Jedną z podstawowych cech wyróżniających nową wersję obiektu TABELA jest możliwość tworzenia hierarchicznych struktur wizualizacji informacji diagnostycznych odnośnie systemów PLC. Funkcjonalność ta pozwala otwierać następną Tabelę za pomocą linku (łącznika) umieszczonego w komórce Tabeli, który uruchamia akcję operatorską według zadanych parametrów, określonych w bazie definicji zmiennych.

Łącznik deklarowany jest za pomocą atrybutu bazy definicji zmiennych przechowującego wywołanie akcji operatorskiej. Nazwa atrybutu pełniącego rolę łącznika deklarowana jest w definicji kolumny Tabeli: na zakładce Kolumny > w polu Nazwa atrybutu akcji.

Zawartość kolumny zawierającej łącznik wyświetlana jest w oknie gotowej Tabeli z podkreśleniem w kolorze niebieskim i może to być albo wartość jakiegoś atrybutu pobierana z bazy definicji zmiennych albo tekst wpisany ręcznie - określa to zawartość pola Nazwa atrybutu, np. można podpiąć akcję pod atrybut Nazwa albo zadeklarować osobną kolumnę Tabeli z pustym atrybutem - tzn. w definicji dodatkowej kolumny Tabeli na zakładce Kolumny w polu Nazwa atrybutu wpisać jakiś tekst, który będzie linkiem do akcji (np. >>).

Poprzez kliknięcie myszą w gotowej Tabeli na wartość kolumny z podpiętą akcją operatorską następuje uruchomienie zadeklarowanej akcji operatorskiej, w szczególności zainicjowanie otwarcia nowej Tabeli ze wskazanym zestawem zmiennych.


4.25.8. Tabela_analogów

Poniżej parametryzacja Tabeli analogów – Tabeli pomiarów parametrów mediów przed piecem.

Pomiary wyświetlane są w kolejnych wierszach Tabeli, oddzielonych wierszami separującymi.

Rysunek: Przykład Tabeli analogów.

Rysunek: Parametryzacja Tabeli analogów - parametry podstawowe.

Tabela zawiera 4 kolumny deklarowane na zakładce Kolumny: Nazwa, Opis, _Wartość_zmiennej, Jednostka.

Dla atrybutu _Wartość_zmiennej wartością wyświetlaną jest wartość zmiennej.

Rysunek: Parametryzacja Tabeli analogów - deklaracja nagłówków i formatu wyświetlanych danych.

Deklaracja zmiennych obejmuje wartości analogowe zmiennych umieszczonych w kolejnych wierszach.

Zamieszczenie wierszy separujących wymaga zadeklarowania pustych wierszy bez podawania nazw zmiennych.

Rysunek: Parametryzacja Tabeli analogów - deklaracja zmiennych.

Kolorystyka Tabeli została sparametryzowana w następujący sposób:

Rysunek: Parametryzacja Tabeli analogów - deklaracja kolorystyki.


Tabela dwustanów

4.25.9. Tabela dwustanów - wyświetlanie bitów (opisów stanów bitów) zmiennej w kolejnych kolumnach

Aktualna wersja obiektu TABELA umożliwia wyświetlanie w jednym wierszu wartości poszczególnych bitów słowa statusowego. Funkcjonalność ta realizowana jest za pomocą numeru bitu wartości zmiennej statusowej, co w konsekwencji wydziela odpowiedni sygnał dwustanowy. Jeżeli numer bitu zostanie pominięty, to brana jest pod uwagę wartość całego słowa statusowego (nr bitu = -1).

Funkcja przeliczająca zmiennej statusowej musi zwracać w wyniku liczbę całkowitą, np. NIC, NIC_BYTE, NIC_INT.

Numeracja bitów w słowie statusowym zaczyna się od najmłodszego bitu o numerze 0.

Rysunek: Przykład Tabeli dwustanów - wyświetlanie wartości bitów zmiennej w kolejnych kolumnach wiersza zmiennej.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - parametry podstawowe.

Wartość sygnału dwustanowego, wydzielonego ze zmiennej statusowej za pomocą numeru bitu, domyślnie wyświetlana jest zgodnie z formatem określonym w bazie definicji zmiennych, formatem zadeklarowanym w sekcji [Tabela] lub przyjmuje wartość 0/1.

Reguła ta dotyczy wszystkich kolumn zawierających wartości statusowe (dwustanowe).

Wartości poszczególnych bitów wyświetlane w oknie gotowej Tabeli w kolejnych kolumnach wiersza zmiennej statusowej deklarowane są na zakładce Kolumny:

- ilość atrybutów _Wartość_zmiennej odpowiada ilości bitów, które mają być wyświetlone w Tabeli - dla każdego takiego atrybutu jako wartość wyświetlaną należy zadeklarować numer kolejnego bitu zmiennej statusowej;

- w celu zróżnicowania prezentacji wartości statusowych proponuje się wprowadzenie indywidualnego formatu oraz atrybutów wyświetlania sygnału dwustanowego dla pojedynczej kolumny Tabeli. Opisy oraz kolorystyka stanów określane są indywidualnie dla każdego bitu w polach Opisy stanów i Kolory stanów.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - deklaracja bitów zmiennej statusowej.

Zmienną statusową, której bity zostały rozpisane na poszczególne kolumny, należy zadeklarować na zakładce Wiersze.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych kolumnach wiersza zmiennej) - deklaracja zmiennej statusowej.


4.25.10. Tabela dwustanów - wyświetlanie opisów bitów zmiennych w kolejnych wierszach

4.25.10. Tabela dwustanów - wyświetlanie opisów bitów oraz opisów stanów bitów w kolejnych wierszach

Baza definicji zmiennych daje możliwość dostępu do opisów bitów zmiennych statusowych oraz opisów wartości bitów zmiennych statusowych.

Zastosowanie tego mechanizmu w sposób drastyczny zmniejsza liczbę zmiennych podlegających licencjonowaniu, potrzebnych do opisu bitów wartości statusowych. Dodatkowo mechanizm ten przyspiesza działanie bazy definicji zmiennych.

Reguły przygotowania odpowiedniej bazy definicji zmiennych zawarte są w dokumentacji pakietu Asix.

Wykorzystanie powyższego mechanizmu pozwala na “pionową” organizację prezentacji danych w Tabeli, tzn. że kolejne wiersze Tabeli pokazują wartości pojedynczych bitów zmiennej statusowej.

Wymaga to odpowiedniej deklaracji wiersza Tabeli.

Rysunek: Przykład Tabeli dwustanów - wyświetlanie wartości i opisów bitów zmiennej w kolejnych wierszach Tabeli.

W obecnej chwili interfejs programowy pozwala na uzyskanie dla pojedynczego bitu informacji o jego opisie oraz nazwie stanu. W związku z tym kolumny opisu i wartości pokazują dane z dokładnością do pojedynczego bitu. Pozostałe atrybuty wyświetlane są z dokładnością do zmiennej. (Konsekwencją praktyczną jest konieczność umieszczania w opisie bitu wszystkich informacji potrzebnych do prezentacji bitów zmiennych statusowych).

Umieszczenie bitów zmiennej statusowej w kolejnych wierszach Tabeli wymaga zadeklarowania każdego bitu (w osobnym wierszu zakładki Wiersze) jako wartość wyświetlaną zmiennej statusowej. Na zakładce Kolumny należy umieścić atrybut _Wartość_zmiennej z polem Wyświetlana wartość ustawionym na: Wartość zmiennej. Pozostałe parametry dotyczące kolorystyki i atrybutów wyświetlania danych znajdują się na zakładkach Tabela i Kolory.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - deklaracja bitów.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - format nagłówków i wyświetlanych danych.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - parametry podstawowe.

Rysunek: Parametryzacja Tabeli dwustanów (bity wyświetlane w kolejnych wierszach tabeli) - ustawienia dotyczące kolorystyki.

Definicje bitów umieszczone są w bazie definicji zmiennych jako odrębne zmienne nieaktywne.

Rysunek: Baza definicji zmiennych - definicje bitów zmiennej statusowej.

Opisy stanów poszczególnych bitów pobierane są do Tabeli z bazy definicji zmiennych z pola Nazwy stanów.

Opisy bitów pobierane są do Tabeli z bazy definicji zmiennych z pola Opis.


Zalacznik 1

Załącznik 1

Tabela 1. Lista atrybutów systemowych Bazy Definicji Zmiennych dla aplikacji Asix w wersji Evo i klasycznej.

UWAGA: Różnice w interpretacji atrybutów dla aplikacji wersji Evo znajdują się w tabeli 1a (za tabelą 1).

Nazwa wewnętrzna atrybutu zmiennej (PL)

Rodzaj atrybutu

Nawa domyślnie wyświetlana w nagłówku (PL)

Nazwa wewnętrzna atrybutu zmiennej (EN)

Nawa domyślnie wyświetlana w nagłówku (EN)

Typ

Opis

Nazwa

obligatoryjny

Nazwa

Name

Name

T

Unikalna nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca tę zmienną dla wszystkich komponentów systemu A six

Opis

obligatoryjny

Opis

Description

Description

T

Dowolny tekst np. zawierający technologiczny opis zmiennej procesowej

Kanał

obligatoryjny

Kanał

Channel

Channel

T

Nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji)

Adres

obligatoryjny

Adres

Address

Address

T

Adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu A six

LiczbaElementow

obligatoryjny

Liczba elementów

ElementsCount

Elements count

L

Liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą)

OkresProbkowania

obligatoryjny

Okres próbkowania

SampleRate

Sample rate

L

okres aktualizacji wartości zmiennej procesowej (w sekundach)

FunkcjaPrzeliczajaca

obligatoryjny

Funkcja przeliczająca

ConversionFunction

Conversion function

T

Nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu A six

Archiwum

obligatoryjny

Archiwum

Archive

Archive

T

Nazwa zasobu ASPAD (logiczna nazwa zasobu archiwum)

ParametryArchiwizacji

obligatoryjny

Parametry archiwizacji

ArchivingParameters

Archiving parameters

T

Parametry archiwizacji danej zmiennej

Grupa1

opcjonalny

Grupa1

Group1

Group1

T

Domyślnie generowany atrybut grupujący

Format

opcjonalny

Format

Format

Format

T

Format liczby w jakim będzie ona wyświetlana w systemie asix; format podany jest w konwencji języka C (np.: %4.2f oznacza 4 znaki, w tym 2 miejsca po przecinku)

FormatEvo

opcjonalny

FormatEvo

FormatEvo

FormatEvo

T

Format liczby w jakim będzie ona wyświetlana w aplikacji Asix.Evo

Jednostka

opcjonalny

Jednostka

Unit

Unit

T

Fizyczna jednostka zmiennej

ZakresPomiarowyOd

opcjonalny

Zakres pomiarowy od

MeasurementRangeFrom

Measurement range from

L

Maksymalny zakres możliwy do uzyskania - minimum

ZakresPomiarowyHi

opcjonalny

Zakres pomiarowy do

MeasurementRangeTo

Measurement range to

L

Maksymalny zakres możliwy do uzyskania - maksimum

ZakresSurowyOd

opcjonalny

Zakres surowy od

RawRangeFrom

Raw range from

L

Parametr funkcji przeliczającej – zakres wejściowy od …

ZakresSurowyDo

opcjonalny

Zakres surowy do

RawRangeTo

Raw range to

L

Parametr funkcji przeliczającej – zakres wejściowy do …

ZakresPrzetwornikaOd

opcjonalny

Zakres przetwornika od

TransducerRangeFrom

Transducer range from

L

Zakres przetwornika - minimum

ZakresPrzetwornikaDo

opcjonalny

Zakres przetwornika do

TransducerRangeTo

Transducer range to

L

Zakres przetwornika - maksimum

ZakresWyswietlaniaOd

opcjonalny

Zakres wyświetlania od

DisplayRangeFrom

Display range from

L

Dolny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresWyswietlaniaDo

opcjonalny

Zakres wyświetlania do

DisplayRangeTo

Display range to

L

Górny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresSterowaniaOd

opcjonalny

Zakres sterowania od

SteeringRangeFrom

Steering range from

L

Dolny zakres wartości danej zmiennej ustawiany z asixa

ZakresSterowaniaDo

opcjonalny

Zakres sterowania do

SteeringRangeTo

Steering range to

L

Górny zakres wartości danej zmiennej ustawiany z asixa

BazaSlupka

opcjonalny

Baza słupka

BarBase

Bar base

T

Wielkość wczytywana z bazy przez obiekt SŁUPEK

NazwyStanow

opcjonalny

Nazwy stanów

StateNames

State names

T

Nazwa zbioru tekstów lub bezpośrednio zbiór opisów stanów (poszczególnych wartości całkowitych) zmiennej

ZestawStanow

opcjonalny

Zestaw stanów

StateSet

State set

T

Nazwa zbioru opisów stanów do którego należy bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

WartoscStanu

opcjonalny

Wartość stanu

StateValue

State value

T

Numer stanu, którego opis zawiera bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

MaskaZmiennejKontrolnej

opcjonalny

Maska zmiennej kontrolnej

ControlVariableMask

Control Variable mask

T

Wskazuje na bit statusu sygnalizowanego przez zmienną kontrolną

ZmiennaKontrolna

opcjonalny

Zmienna kontrolna

ControlVariable

Control variable

T

Nazwa zmiennej reprezentującej status zmiennej pomiarowej

LimitLoLo

opcjonalny

Minimum krytyczne

LimitLoLo

Limit LoLo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum krytycznego dla zmiennej pomiarowej

LimitLo

opcjonalny

Minimum

LimitLo

Limit Lo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum dla zmiennej pomiarowej

LimitHi

opcjonalny

Maksimum

LimitHi

Limit Hi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum dla zmiennej pomiarowej

LimitHiHi

opcjonalny

Maksimum krytyczne

LimitHiHi

Limit HiHi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum krytycznego dla zmiennej pomiarowej

ZakresWyswietlaniaKrok

opcjonalny

Zakres wyświetlania krok

DisplayRangeStep

Display range step

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość podziałki głównej na osi OY (co ile jednostek będzie wyświetlana etykieta wartości na osi OY)

ZakresWyswietlaniaSzer

opcjonalny

Zakres wyświetlania szerokość

DisplayRangeWidth

Display range width

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość etykiety wartości wyświetlanych na osi OY

ZakresWyswietlaniaPodzial

opcjonalny

Zakres wyświetlania podział

DisplayRangeDivision

Display range division

L

Atrybut wykorzystywany przez obiekt WYKRES. Wyznacza podział na mniejsze jednostki podziałki głównej (wyznaczonej przez atrybut Zakres wyświetlania krok) na osi OY

Dokładnosc

opcjonalny

Dokładność

Precision

Precision

T

Dokładność zaokrąglania w obiekcie LICZBA. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie nie ma zaokrąglania.

PolozenieSuwaka

opcjonalny

Położenie suwaka

SliderPosition

Slider position

T

Nazwa zmiennej, do której wpisywana będzie wartości reprezentująca położenie uchwytu obiektu SUWAK w trakcie przesuwania tegoż uchwytu

RejestracjaSterowania

opcjonalny

Rejestracja sterowania

ControlLogging

Control logging

Wartość logiczna

Wartość 1 oznacza, że sterowania zmiennej podlegają rejestracji w module AsAudit

ZmiennaNieaktywna

opcjonalny

Zmienna nieaktywna

ItemNotActive

Item not active

Wartość logiczna

Jeżeli wartość atrybutu wynosi 1, to zmienna nie jest widoczna w systemie A six dla modułów Asmen i Aspad

WykresTytul

opcjonalny

Tytuł wykresu

ChartTitle

Chart title

T

Atrybut wykorzystywany przez obiekt WYKRES. Tytuł wykresu pobierany jest z atrybutu Tytuł wykresu pierwszej zmiennej zadeklarowanej na wykresie

ZakresSlupkaOd

opcjonalny

Zakres słupka od

BarRangeFrom

Bar range from

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera dolny zakres wyświetlania danej zmiennej.

ZakresSlupkaDo

opcjonalny

Zakres słupka do

BarRangeTo

Bar range to

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera górny zakres wyświetlania danej zmiennej.

SzybkieOdswiezanie

opcjonalny

Szybkie odświeżanie

FastRefresh

Fast refresh

Wartość logiczna

Atrybut wykorzystywany przez drajwer CtTwinCATTcpip od wersji 1.3.5. Zmienne z zadeklarowanym atrybutem Fast Refresh mają udostępnioną funkcję szybkiego odświeżania, która umożliwia odświeżanie zmiennych z maksymalną osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę)

SprawdzanieZakresuPomiarowego

opcjonalny

Sprawdzanie zakresu pomiarowego

MeasurementRangeCheck

Measurement range check

Wartość logiczna

Wartość 1 oznacza, że dla podanej zmiennej monitorowane będą przekroczenia zakresu pomiarowego i sygnalizowane odpowiednim statusem OPC.

Status zmiennej jest określany po porównaniu wartości pomiarowej z wartościami zakresów pomiarowych:

a/ przy przekroczeniu zakresu o wartość <= od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_EGU_EXCEEDED

b/ przy przekroczeniu zakresu o wartość > od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_SENSOR_FAILURE

GrupaUprawnienOdczytu

opcjonalny

Grupa uprawnień odczytu

ReadAuthorizationGroup

Read authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzystają aplikacje: AsPortal i AsTrend, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do przeglądania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do

przeglądania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

GrupaUprawnienZapisu

opcjonalny

Grupa uprawnień zapisu

WriteAuthorizationGroup

Write authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzysta aplikacja AsPortal, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do modyfikowania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień zapisu, nazwę grupy użytkowników systemu Windows uprawnionych do

modyfikowania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

T - tekst, L - liczba zmiennoprzecinkowa 64 bitowa

Tabela 1a. Lista atrybutów systemowych Bazy Definicji Zmiennych dla aplikacji Asix w wersji Evo.

Nazwa

Opis

Typ wartości

Określa typ wartości zmiennej w konwencji .Net. W przypadku użycia bazy MDB nie posiadającej tego atrybutu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej funkcji przeliczającej i formatu.

Format

Sposób formatowania tekstowego wartości w konwencji .Net. Skrócony opis formatów .Net można znaleźć w podręczniku AsixEvo_Techniki_budowy_diagramów.pdf/chm.

W przypadku baz MDB atrybut tworzony jest wirtualnie według poniższych zasad:

  1. Jeżeli w bazie jest atrybut FormatEvo, to jest on traktowany wprost jako definicja atrybutu Format Asix.Evo.

  2. Jeżeli w bazie nie ma atrybutu FormatEvo, to atrybut Format bazy MDB (podawany w konwencji formatów aplikacji klasycznych) jest w trakcie ładowania tłumaczony na odpowiadający mu format .Net.

Funkcja przeliczająca odczytu

Atrybut ma postać wyrażenia, które wstępnie przelicza pobraną z drajwera wartość surową zmiennej. W treści wyrażenia odwołanie do wartości surowej wykonywane jest przy pomocy funkcji RawValue.

W przypadku korzystania z serwera danych (kanał Asix6), niezależnie od definicji atrybutu funkcji przeliczającej odczytu, wartość zmiennej podlega standardowemu przeliczeniu przez Asmen’a na podstawie atrybutu Funkcja przeliczająca.

W przypadku użycia bazy MDB nie posiadającej atrybutu Funkcja przeliczająca odczytu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej formatu.

Funkcja przeliczająca zapisu

Atrybut ma postać wyrażenia, które przelicza wartość sterującą przed wysłaniem jej do drajwera.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Wartość początkowa

Określa wartość początkową zmiennej, nadawaną zmiennej w momencie uruchomienia aplikacji.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.


Zalacznik 2

Załącznik 2

Tabela 2. Zestawienie atrybutów i wykorzystujących (wyświetlających) je obiektów.

Obiekty Atrybuty | Obiekt LICZBA | Obiekt KONTROLER RUCHU | Obiekt NAPIS | Obiekt PUNKT PRACY | Obiekt SŁUPEK | Obiekt SUWAK | Obiekt TEKST | Obiekt TEKSTY | Obiekt WSKAŹNIK | Obiekt WYKRES | Moduł AsAudit | Moduł AsTrend*
Nazwa |  |  |  |  |  |  | P |  |  |  |  |
Opis |  |  |  |  |  |  | P | P |  |  |  | P
Kanał |  |  |  |  |  |  | P |  |  |  |  |
Adres |  |  |  |  |  |  | P |  |  |  |  |
Liczba elementów |  |  | P |  |  |  | P |  |  |  |  |
Okres próbkowania |  |  |  |  |  |  | P |  |  |  |  |
Funkcja przeliczająca |  |  |  |  |  |  | P |  |  |  |  |
Archiwum |  |  |  |  |  |  | P |  |  |  |  |
Parametry archiwizacji |  |  |  |  |  |  | P |  |  |  |  |
Grupa1 |  |  |  |  |  |  | P |  |  |  |  |
Format | P |  |  |  |  |  | P |  |  |  |  |
Jednostka |  |  |  |  |  |  | P |  |  |  |  |
Zakres pomiarowy od |  | P |  |  |  |  | P |  |  |  |  |
Zakres pomiarowy do |  | P |  |  |  |  | P |  |  |  |  |
Zakres surowy od |  |  |  |  |  |  | P |  |  |  |  |
Zakres surowy do |  |  |  |  |  |  | P |  |  |  |  |
Zakres przetwornika od |  |  |  |  |  |  | P |  |  |  |  |
Zakres przetwornika do |  |  |  |  |  |  | P |  |  |  |  |
Zakres wyświetlania od | P |  |  | P | P | P | P |  | P | P |  |
Zakres wyświetlania do | P |  |  | P | P | P | P |  | P | P |  |
Zakres sterowania od | P |  |  |  |  | P | P |  |  |  |  |
Zakres sterowania do | P |  |  |  |  | P | P |  |  |  |  |
Baza słupka |  |  |  |  | P |  | P |  |  |  |  |
Nazwy stanów |  |  |  |  |  |  | P | P |  |  |  | P
Zestaw stanów |  |  |  |  |  |  | P | P |  |  |  | P
Wartość stanu |  |  |  |  |  |  | P | P |  |  |  | P
Maska zmiennej kontrolnej | P |  |  | P | P | P | P |  | P |  |  |
Zmienna kontrolna | P |  |  | P | P | P | P |  | P |  |  |
Minimum krytyczne | P |  |  |  | P |  | P |  | P |  |  |
Minimum | P |  |  |  | P |  | P |  | P |  |  |
Maksimum | P |  |  |  | P |  | P |  | P |  |  |
Maksimum krytyczne | P |  |  |  | P |  | P |  | P |  |  |
Zakres wyświetlania krok |  |  |  |  |  |  | P |  |  | P |  |
Zakres wyświetlania szerokość |  |  |  |  |  |  | P |  |  | P |  |
Zakres wyświetlania podział |  |  |  |  |  |  | P |  |  | P |  |
Dokładność | P |  |  |  |  |  | P |  |  |  |  |
Położenie suwaka |  |  |  |  |  |  | P |  |  |  |  |
Rejestracja sterowania |  |  |  |  |  |  | P |  |  |  | P |
Zmienna nieaktywna |  |  |  |  |  |  | P | P |  |  |  | P
Tytuł wykresu |  |  |  |  |  |  | P |  |  | P |  |
Zakres słupka od |  |  |  |  | P |  |  |  |  |  |  |
Zakres słupka do |  |  |  |  | P |  |  |  |  |  |  |

* - moduł AsTrend może wyświetlić w Legendzie wartości wszystkich atrybutów zmiennej zadeklarowanej na wykresie


Zalacznik 3

Załącznik 3

 | Kod języka | Nazwa języka
za | af | afrykanerski
al | sq | albański
gb | en | angielski
az | az | azerski
by | be | białoruski
bg | bg | bułgarski
hr | hr | chorwacki
cz | cs | czeski
dk | da | duński
ee | et | estoński
fi | fi | fiński
fr | fr | francuski
gr | el | grecki
ge | ka | gruziński
es | es | hiszpański
lu | nl | holenderski
ax | is | islandzki
kz | kk | kazachski
kr | ko | koreański
lt | lt | litewski
lv | lv | łotewski
mk | mk | macedoński
de | de | niemiecki
no | no | norweski
am | hy | ormiański
pl | pl | polski
pt | pt | portugalski
ru | ru | rosyjski
ro | ro | rumuński
sr-serbski | sr | serbski
sk | sk | słowacki
si | sl | słoweński
se | sv | szwedzki
tr | tr | turecki
ua | uk | ukraiński
uz | uz | uzbecki
hu | hu | węgierski
ie | it | włoski


Zalacznik 4

Załącznik 4

Znaki sterujące wykorzystywane do definicji stałych elementów wydruków

uwaga Definicje nagłówków i stopek składają się z trzech części oddzielonych znakiem |. Zostaną one wydrukowane odpowiednio po lewej stronie, na środku i po prawej stronie kartki.

&p - numer strony

&c - nazwa komputera

&a - nazwa aplikacji

&o - operator (w wersji 2.66 pusty tekst)

&w - tekst definiujący rodzaj wydruku (tekst z góry ustalony, np. dla wydruku maski schematowej: ”Zrzut graficzny ekranu")

&r - nazwa raportu

&m - miesiąc - liczba

&M - miesiąc - nazwa

&y - rok

&h - godzina

&n - minuta

&s - sekunda

&D - pełna data w postaci zdefiniowanej w systemie operacyjnym

&T - pełny czas w postaci zdefiniowanej w systemie operacyjnym

&& - &

&es - nazwa zasobu drukowanych alarmów

&ef - czas początku okresu drukowanych alarmów

&et - czas końca okresu drukowanych alarmów

&ec - opis użytych kryteriów - nazwa pliku jeżeli kryteria wzięte z pliku selekcji

Nagłówek i stopka mogą być wieloliniowe. W tym celu należy do tekstu wstawić znacznik ^.


Zalacznik 5

Załącznik 5

Znaki definiujące format linii alarmów

A - tekst alarmu;

D - data alarmu - 4 cyfrowy rok;

d - data alarmu - 2 cyfrowy rok;

T - czas alarmu z milisekundami;

t - czas alarmu bez milisekundami;

S - status: początek/koniec (podczas wydruku alarmów aktywnych znacznik S jest ignorowany);

N - numer kolejny;

I - numer/identyfikator alarmu;

X - w miejscu umieszczenia kodu drukowany jest znak * dla alarmów specjalnych, a spacja dla alarmów zwykłych;

Spacja - wstawia spację do tekstu;

Wartość domyślna: formatem domyślnym jest ADTS;

uwaga Po znaczniku A można podać długość pola i numer znaku początkowego w formacie: dlugosc[/pierwszy_znak] - pierwszy_znak może być liczbą ujemną i oznacza to liczenie od końca tekstu alarmu.


2.2.1 Edycja bazy definicji zmiennych – Edytor definicji

2.2.1 Edycja bazy definicji zmiennych &endash; Edytor definicji zmiennych


2.3.8. Uaktualnianie źródeł danych

Jeśli baza definicji zmiennych została wygenerowana, dalsze uaktualnianie definicji zmiennych można przeprowadzać przy użyciu komendy Uaktualnij (moduł Bazy danych > Baza definicji zmiennych (dla typu: Standardowa baza definicji zmiennych; tryb Generator) > zakładka Źródła danych.

Funkcja uaktualniania źródeł danych zostaje zablokowana, gdy źródła zawierają tabele transformacji lub tabele zmiennych używanych.


2 Obsluga baz definicji zmiennych aplikacji systemu asix

2 Obsługa baz definicji zmiennych aplikacji systemu Asix


3.10.3 Deklaracje synchronizacji czasu po stronie Serwera

3.10.4 Deklaracje synchronizacji czasu po stronie Serwera


3.10.6 Parametry diagnostyczne przekazywane do AslView

3.10.7 Parametry diagnostyczne przekazywane do AslView


3.9.8 Deklaracja uprawnień dotyczących obsługi alarmów

3.10.8 Deklaracja uprawnień dotyczących obsługi alarmów

Rysunek 155. Okno parametrów systemu alarmów – zakładka Bezpieczeństwo.

Zakładka Bezpieczeństwo daje możliwość:

  • zadeklarowania poziomu hasła, którego znajomość będzie wymagana do wykonania określonych operacji:

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów filtrowanych,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów sygnalizowanych dźwiękiem,

  • poziom uprawnień wymagany do wykonania operacji zmiany alarmów wykluczeń.

Wartość domyślna: brak kontroli

Sposób deklarowania trybu logowania omawia rozdział 3.11 . Konfiguracja zabezpieczenia aplikacji .

  • Dodatkowo użycie opcji Zablokowanie obsługi alarmów przez operatora powoduje, że blokowane są operacje zmiany filtrów, wykluczeń i potwierdzania alarmów. Możliwe jest jedynie przeglądanie alarmów;

Wartość domyślna: obsługa nie jest blokowana


4.6 Konfiguracja parametrow danych biezacych

4.6 Konfiguracja parametrów danych bieżących

Grupa parametrów dane bieżące ikonka Dane bieżące obejmuje ustawienia pracy modułu Asmen, w tym szczegółową parametryzację kanałów transmisyjnych - fizycznie realizowanych połączeń pomiędzy komputerem systemu asix i sterownikami na obiekcie oraz parametryzację drajwerów komunikacyjnych.

W systemie asix wszystkie operacje związane z dostępem do zmiennych procesowych są realizowane przez moduł Asmen. Moduł Asmen nadzoruje proces cyklicznej aktualizacji wartości zmiennych procesowych w bazie danych oraz pośredniczy we wszystkich operacjach związanych z przesyłem sterowań do obiektu. Bezpośrednia wymiana danych pomiędzy komputerem i sterownikiem obiektu jest wykonywana poprzez drajwery pracujące pod kontrolą Asmena.

W oparciu o dokonaną parametryzację tworzone jest repozytorium bieżących wartości zmiennych procesowych (przechowywane przez moduł Asmen w pamięci operacyjnej komputera), do którego mają dostęp wszystkie komponenty systemu asix. Wartości przechowywanych zmiennych procesowych są na bieżąco aktualizowane poprzez cykliczny odczyt z obiektu.

Szczegółowy opis funkcjonalności modułu Asmen znajduje się w podręczniku ”Asix - funkcjonalnośc i zasady dzialania”, rozdziale Menedżer komunikacyjny ASMEN (pliki asix.CHM lub asix.PDF).


4.8.3. Uzupełnianie danych

4.8.3. Parametryzacja okresu uzupełniania danych

Zakładka Uzupełnianie obejmuje następujące parametry:

powiększ >>

Rysunek: Widok okna parametryzującego okresu uzupełniania danych.

  • Domyślny minimalny okres uzupełniania - używając tej opcji można wydłużyć domyślny okres czasu (w dniach), z którego archiwa mogą być uzupełniane. Opcja ma znaczenie tylko dla tych archiwów, dla których nie zdefiniowano opcji Minimalny okres uzupełniania.


4.9.3 Deklaracja plikow definicji alarmow i definicji grup

3.9.3 Deklaracja plików definicji alarmów i definicji grup alarmów

uwaga Możliwość deklarowania plików, z których pobierane są definicje alarmów i definicje grup alarmów istnieje wówczas, gdy w module Bazy danych zostanie zdefiniowany tryb pracy bazy definicji alarmów z plikami:

Moduł Bazy danych > Baza definicji alarmów > Tryb pracy bazy definicji alarmów: Tekstowe pliki definicji alarmów są edytowane przez projektanta

Rysunek: Okno parametrów systemu alarmów - zakładka 'Alarmy' / 'Baza definicji alarmów'.

  • Nazwy plików, w których zdefiniowane są alarmy - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały alarmy; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: definicje alarmów będą czytane z pliku ’alarm.def’ z kartoteki bieżącej aplikacji

  • Nazwy plików, w których zdefiniowane są grupy alarmów - parametr pozwala zadeklarować nazwy plików, w których zdefiniowane zostały grupy alarmów; nazwy powinny być oddzielone przecinkami;

Wartość domyślna: brak


4.9.6 Definicja formatu alarmow

3.9.6 Definicja formatu alarmów

Grupa zakładek Wygląd służy do definiowania sposobu wyświetlania alarmów:

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd'.

  • Kolor tła - określa:

  • Tło tabeli alarmów,

  • Alternatywne tło tabeli alarmów,

  • Linie rozdzielające;

  • Kolor tekstu alarmu - w zależności od rodzaju alarmu oraz od stanu alarmu (początek lub koniec) pozwala określić kolor tekstu i kolor tła dla:

  • Komunikat systemowy,

  • Komunikat,

  • Ostrzeżenie,

  • Alarm,

  • Ważny alarm.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor tekstu alarmu'.

  • Kolor daty alarmu - w zależności od stanu alarmu pozwala określić kolor tekstu daty oraz kolor tła daty dla:

  • Alarm rozpoczęty,

  • Alarm rozpoczęty i potwierdzony,

  • Alarm zakończony,

  • Alarm zakończony i potwierdzony.

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Kolor daty alarmu'.

  • Alarmy wyselekcjonowane - umożliwia zadeklarowanie koloru tła alarmów wyselekcjonowanych;

Rysunek:. Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Alarmy wyselekcjonowane'.

  • Maski typu Czerwony Tryb - definiuje kolor tekstu kolor tła masek ’Czerwony Tryb’;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Maska typu Czerwony Tryb'.

  • Opcje - pozwala dodatkowo określić:

  • Użycie na maskach i wydrukach alarmów długiego 4-cyfrowego formatu numeru roku;

  • Sortowanie alarmów na liście alarmów aktywnych i historycznych;

Rysunek: Okno parametrów systemu alarmów - zakładka 'Wygląd' / 'Opcje'.

uwaga Użycie trybu sortowania według czasu zdarzeń ma sens tylko wtedy, gdy używana strategia wykrywania alarmów zgłasza alarmy łącznie z czasem.


4.16.1 Opisy parametryzacji akcji za pomoca edytora

4.16.1 Opisy parametryzacji akcji za pomocą edytora akcji

Opisy akcji - parametryzacja przy użyciu edytora akcji.

akcja ASBASE - pozwala na zdalne sterowanie pracą programu AsBase

Parametry:

Typ operacji:

start - operacja powoduje uruchomienie modułu AsBase z przekazaniem mu parametrów; Jeżeli AsBase był już wcześniej uruchomiony, to operacja start jest równoważna operacji pokaż bez parametrów. Dodatkowym efektem użycia operacji start jest to, że w momencie końca pracy głównego modułu programu asix zostanie również zakończona praca modułu Asbase. Struktura parametrów jest następująca:

nazwa_pliku_xml [/single][/minimize] /user:<id_uzytkownika>/password:<hasło>

gdzie:

nazwa_pliku_xml - plik XML przechowuje podstawowe informacje konfiguracyjne, takie jak lokalizacja i sposób dostępu do bazy danych aplikacji AsBase’a; w pliku XML zapisywane są także definicje warunków archiwizacji i automatycznych receptur;

/single - powoduje, że w przypadku próby uruchomienia AsBase’a w sytuacji, gdy jest on już uruchomiony, nowa instancja programu nie zostanie utworzona; na pierwszy plan zostanie wyciągnięte okno wcześniej uruchomionego AsBase’a;

/minimize - powoduje uruchomienie AsBase’a z automatyczną minimalizacją okna;

/user:<id_uzytkownika>/password:<hasło> - powoduje automatyczne logowanie wskazanego użytkownika na starcie programu;

pokaż - operacja powoduje uaktywnienie okna modułu AsBase (wyciągnięcie go na wierzch). Dodatkowe parametry pozwalają określić informację, która ma zostać pokazana w oknie:

Typ obszaru: RCP - wartości receptury, RLD - historia ładowań receptur, ARC - archiwum;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

Pokaż obszar - wyświetla zdefiniowany obszar;

Pokaż zestaw - wyświetla zdefiniowany obszar dla zestawu zmiennych, identyfikowanych identyfikatorem wpisywanym do pola Identyfikator zestawu;

Widok - wyświetla zdefiniowany obszar zgodnie z parametrami definiującymi sposób wyświetlania zawartości danej tabeli; widok identyfikowany jest za pomocą identyfikatora wpisywanego do pola Identyfikator widoku;

załaduj - operacja pozwala na załadowanie receptury zgodnie z parametrami:

ID grupy - określa grupę receptur, której operacja dotyczy;

ID zestawu - określa zestaw zmiennych, gdzie receptura ma być załadowana;

Nazwa receptury - jeżeli parametr ten zostanie podany, to wyświetlone zostanie okno z listą wszystkich receptur zdefiniowanych w grupie, z której operator będzie mógł wybrać recepturę, która ma być załadowana

nawiguj - operacja pozwala na przeglądanie zawartości tabel bazy danych modułu AsBase na maskach aplikacji systemu asix; parametry wymagane:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

Komenda - nazwa komendy, jaka ma zostać wykonana; można podać następujące komendy:

FIRST - pierwszy zapis tabeli,

NEXT - kolejny zapis tabeli,

PREVIOUS - poprzedni zapis tabeli,

LAST - ostatni zapis tabeli,

FILTER - nowy filtr: zdefiniowanie nowego filtru oraz wyświetlenie ostatniego zapisu z tabeli zgodnego z nowym filtrem,

COUNT - liczba wierszy: powoduje przypisanie do określonej zmiennej zestawu zmiennych liczby, która jest ilością zapisów w tabeli zgodnych z aktualnym filtrem;

LOAD - receptura: komenda powoduje załadowanie wskazanej receptury do zestawu zmiennych; działanie tego wariantu akcji zbliżone jest do wariantu ASBASE;

drukuj - operacja pozwala na wydrukowanie zawartości tabel bazy danych modułu AsBase; parametryzacja operacji obejmuje:

Typ obiektu: RCP - wartości receptur, RLD - historia ładowań receptur, ARC - archiwum zestawu rejestracji;

ID obiektu - identyfikator zestawu rejestracji lub grupy receptur;

ID widoku - jest identyfikatorem jednego z widoków skojarzonych z daną tabelą;

dodaj - operacja pozwala na dodanie nowego rekordu do zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

usuń - operacja pozwala na usunięcie rekordu z zawartości tabeli bazy danych modułu AsBase; parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

zmień - operacja pozwala na zmianę bieżącego rekordu w tabeli bazy danych modułu AsBase;parametr operacji:

ID połączenia - identyfikator połączenia zdefiniowany w czasie parametryzacji obiektu ASBASE;

akcja ASTREND - umożliwia otwarcie okna programu AsTrend z jednoczesnym wyświetleniem trendu wg definicji zapisanej w pliku *.trnx lub wydruk wskazanego trendu. Ponowne użycie akcji AsTrend przy uruchomionej aplikacji Asix powoduje wywołanie okna AsTrend z nowym lub aktualnie wczytanym plikiem definicji trendu (w zależności od parametryzacji akcji).

Parametry:

Tryb:

Wyświetl wykres trendu w sposób określony przez następujące parametry:

Trend - nazwa pliku z domyślnym rozszerzeniem trnx lub trn, który zawiera uprzednio przygotowaną definicję trendu wyświetlanego przez program AsTrend;

wpisanie znaku ”?" powoduje otwarcie okna, w którym Użytkownik może wybrać plik trendu do wyświetlenia;

w przypadku nie podania nazwy trendu wszystkie operacje są wykonywane na bieżącym trendzie (załadowanym przy pierwszym uruchomieniu programu AsTrend w trakcie uruchomienia aplikacji Asix) - w takim przypadku zmienne mogą być dodawane i nie mogą być wymieniane.

Położenie okna - współrzędne x i y lewego górnego narożnika okienka programu ASTREND; ma zastosowanie w systemach wielomonitorowych;

Monitor - wskazanie monitora, na którym powinno otworzyć się okienko programu ASTREND (dotyczy systemów wielomonitorowych):

-1 - monitor wynikający z definicji maski,

0 - monitor, gdzie znajduje się monitor,

1 - monitor podstawowy,

2 - drugi monitor,

3 - trzeci monitor,

4 - czwarty monitor,

…

8 - ósmy monitor;

Katalog roboczy - kartoteka, z której ma zostać odczytana definicja trendu;

Początek okresu - czas, dla którego trend ma być wyświetlony; parametr może być czasem w formacie OPC (absolutnym lub względnym) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w formacie OPC (absolutnym lub względnym).

Koniec okresu - koniec okresu czasu wyświetlania danych - data lub nazwa zmiennej.

Jeśli podano nazwę zmiennej tekstowej, to musi ona zawierać czas w formacie OPC. Jeśli podano nazwę zmiennej liczbowej, to musi ona zawierać czas w postaci liczby sekund, jakie upłynęły od północy 1.01.1970.

edytor czasu opc

Rysunek: Edytor czasu w formacie OPC.

Dodaj/wymień zmienne - umożliwia zadeklarowanie listy zmiennych, które po załadowaniu zostaną wymienione lub dodane do zmiennych zadeklarowanych w pliku definicji trendu.

Drukuj wykres trendu w sposób określony przez następujące parametry:

Trend - nazwa pliku z domyślnym rozszerzeniem trnx lub trn, który zawiera uprzednio przygotowaną definicję trendu wyświetlanego przez program AsTrend;

wpisanie znaku ”?" powoduje otwarcie okna, w którym Użytkownik może wybrać plik trendu do wyświetlenia;

w przypadku nie podania nazwy trendu wszystkie operacje są wykonywane na bieżącym trendzie (załadowanym przy pierwszym uruchomieniu programu AsTrend w trakcie uruchomienia aplikacji Asix) - w takim przypadku zmienne mogą być dodawane i nie mogą być wymieniane.

Tytuł - tytuł trendu na wydruku;

Nagłówek - nagłówek trendu na wydruku;

Stopka - stopka trendu na wydruku;

Początek okresu - czas, dla którego trend ma być wyświetlony; parametr może być czasem w formacie OPC (absolutnym lub względnym) lub nazwą zmiennej; w sytuacji, gdy parametrem jest nazwa zmiennej, to jej wartość interpretowana jest jako: ilość sekund od 1.1.1970 dla zmiennych jednoelementowych, a dla zmiennych tablicowych jako tablica wartości tekstowych zapisanych w formacie OPC (absolutnym lub względnym).

Koniec okresu - koniec okresu czasu wyświetlania danych - data lub nazwa zmiennej.

Jeśli podano nazwę zmiennej tekstowej, to musi ona zawierać czas w formacie OPC. Jeśli podano nazwę zmiennej liczbowej, to musi ona zawierać czas w postaci liczby sekund, jakie upłynęły od północy 1.01.1970.

Dodaj/wymień zmienne - umożliwia zadeklarowanie listy zmiennych, które po załadowaniu zostaną wymienione lub dodane do zmiennych zadeklarowanych w pliku definicji trendu.

akcja ASAUDIT - umożliwia sterowanie wyświetlaniem okien programów modułu AsAudit zgodnie z parametrami:

Okno - pozwala na wybór okna, które ma być uaktywnione. Może przybierać poniższe wartości:

Konsola - okno Konsoli AsAudit

Konfigurator - okno Konfiguratora AsAudit

Przeglądarka - okno Przeglądarki AsAudit

akcja DRUKUJ - zlecenie wydrukowania pliku.

Parametry:

nazwa_pliku - nazwa pliku, który ma zostać wydrukowany.

akcja FILTR_SERWERÓW - ustawienie informacji dla modułu Aslink, z jakimi stanowiskami może się łączyć. Akcja tylko dla specjalnych zastosowań, gdy chce się sterować źródłem pochodzenia danych.

Parametry:

nazwa_serwera - nazwa sieciowa komputera, do którego można się przyłączyć. Można używać znaków * i ? dla określenia grupy komputerów.

akcja GRAJ - odtwarzanie pliku typu WAV.

Parametry:

Nazwa pliku - nazwa pliku typu WAV, którego zawartość ma być odegrana; przycisk odegraj z prawej strony pola umożliwia odsłuchanie pliku.

akcja HASŁO - akcja jest przeznaczona do użycia jako element składowy akcji złożonych. Jeżeli operator nie poda prawidłowego hasła, to wykonanie akcji złożonej zostaje natychmiast przerwane.

Parametry:

Hasło lub poziom uprawnień - rozwijane pole umożliwia zadeklarowanie odpowiedniego poziomu uprawnień (dla którego zostało przypisane hasło), bądź podanie hasła. W obu przypadkach do wykonania akcji będzie wymagane podanie hasła przez operatora.

akcja KONIEC - zakończenie pracy głównego modułu systemu A six; akcja równoznaczna z komendą MASKI.KONIEC w oknie Panelu Kontrolnego (zamknięciem Panelu Kontrolnego). Akcja pozwala na zakończenie pracy programu nawet wtedy, gdy w Zabezpieczeniach aplikacji został włączony parametr Blokada zamykania aplikacji.

Parametry:

Hasło lub poziom uprawnień - rozwijane pole umożliwia zadeklarowanie odpowiedniego poziomu uprawnień (dla którego zostało przypisane hasło), bądź podanie hasła - skutkiem czego w obu przypadkach do zamknięcia aplikacji będzie wymagane podanie hasła.

akcja KURSOR - ustawienie kursora myszki w zadanej pozycji; akcja przeznaczona dla tworzenia prezentacji.

Parametry:

x, y - określają nową pozycję myszki.

akcja LANGUAGE - wykonanie akcji z podanym kodem powoduje przełączenie języka aplikacji. Brak parametru powoduje otwarcie okna wyboru języka.

Parametry:

Język - umożliwia wybór jednego z zadeklarowanych kodów języków projektowanej aplikacji.

akcja LICZ_RAPORT - obliczenie wyspecyfikowanego raportu. Policzony raport zapisany zostanie na dysku.

Parametry:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem wielokropek ’Edytor momentów języka ASTEL’:

Rysunek: Edytor momentów języka ASTEL.

Nazwisko operatora - nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - treść notatki (o ile pojawia się w definicji raportu).

akcja LOGUJ - akcja otwierająca okno służące do logowania użytkowników aplikacji pakietu asix w przypadku stosowania systemu logowania.

akcja MAKRO - odegranie makra (sekwencji demonstracyjnej) zapisanej w pliku. W czasie odegrania zachowane są wszystkie uzależnienia czasowe. Akcja przeznaczona do tworzenia prezentacji.

Parametry:

nazwa_pliku - nazwa pliku zawierającego makro. Plik ten musi być utworzony poprzez nagranie sekwencji demonstracyjnej (komenda OPCJE.SEKWENCJA.DEMO w oknie Konstruktora), a następnie przemianowanie pliku replayw.dem.

akcja MENU - akcja wyświetla menu typu pop-up, którego postać definiowana jest przy użyciu programu Architekt (można również wyświetlić menu, którego definicja utworzona została w pliku *.pum).

Parametry:

Nazwa menu - nazwa menu opisującego strukturę tworzonego menu; pole umożliwia wywołanie okna z wyborem definicji menu, które zostały zdefiniowane w programie Architekt (pierwszy przycisk wielokropek w polu Nazwa menu) lub wywołanie okna, umożliwiającego wskazanie pliku *.pum z definicją menu (drugi przycisk wielokropek w polu Nazwa menu).

Położenie - wskazuje miejsce, w którym ma się docelowo otwierać menu na masce aplikacji. Wartość parametru zależy od kontekstu użycia akcji - jeżeli akcja wywoływana będzie z obiektu PRZYCISK, to jako wartość parametru Położenie przyjmuje się położenie obiektu. W innych wypadkach przyjmuje się współrzędne (100,100).

akcja NIC - akcja pusta. Akcja przeznaczona jest dla blokady wykonania akcji klawiszowych, zdefiniowanych na innych maskach. Przyłączenie do maski zestawu klawiszy z akcjami NIC powoduje, że w czasie gdy maska jest aktywna, akcje klawiszowe (dla wybranych klawiszy) z innych masek nie są wykonywane.

akcja OBLICZ - otwarcie okna Dialogów. Akcja równoznaczna z wykonaniem komendy NARZĘDZIA.OKNO_DIALOGÓW z poziomu Panelu Kontrolnego.

Parametry:

x, y - określenie pozycji, na której okno Panelu Dialogowego ma być otwarte.

akcja OBSŁUGA_HASEŁ - otwarcie okna zarządzania hasłami.

akcja ODCZYT_HISTORII - akcja wymusza wykonanie przez moduł Aspad uzupełniania danych historycznych z drajwerów poza cyklem wynikającym z deklaracji na zakładce Pobieranie danych historycznych w module Dane archiwalne programu Architekt.

akcja OPIS_ZMIENNEJ - wyświetlenie informacji na temat wskazanej zmiennej, znajdującej się w bazie definicji zmiennych.

Parametry:

Zmienna - określenie zmiennej Asmena, której opis, zawarty w bazie danych, ma być wyświetlony.

Atrybuty zmiennej:

- Wszystkie;

- Zestaw - pole wyboru umożliwia wybór jednego z zestawów, zadeklarowanego dla danej aplikacji;

- Podane - lista atrybutów oddzielonych przecinkiem; nie może zawierać znaków spacji i średnika.

akcja OTWÓRZ_MASKĘ - akcja pozwalająca na otwarcie dowolnej maski wizualizacyjnej (schematowej lub alarmów); dodatkowo istnieje możliwość sparametryzowania akcji w taki sposób, aby w momencie otwierania maski nastąpiła zamiana zmiennych procesowych na inne wskazane przez projektanta.

Próba otwarcia maski już otwartej powoduje wybranie jej jako nowej maski bieżącej. Zasady zamykania innych masek pozostają wtedy niezmienione.

Parametry:

Nazwa maski - nazwa maski, którą należy otworzyć. Rodzaj użytych liter nie ma znaczenia.

Tryb otwarcia:

- zamiana - maska bieżąca zostanie zamknięta, po czym otwarta będzie nowa maska,

- zastąpienie - podobnie jak ’r;zamiana’, lecz nowa maska zostanie otwarta fizycznie w miejscu, gdzie znajdowała się maska zamykana (identyczne będą współrzędne x,y lewego, górnego narożnika maski),

- wymiana - zostaną zamknięte wszystkie maski nie zablokowane (posiadające zezwolenie na zamknięcie), po czym otwarta będzie nowa maska,

- ograniczona wymiana - tak samo jak dla trybu ’r;wymiana’, lecz maska bieżąca nie zostanie zamknięta nawet wtedy, gdy nie jest zablokowana,

- nowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą,

- dialog - otwarcie nowej maski nie ma wpływu na maskę bieżącą; po otwarciu nie będzie możliwości przejścia do innej maski, aż do momentu zamknięcia maski utworzonej w wyniku tej akcji,

- chwilowa - otwarcie nowej maski nie ma wpływu na maskę bieżącą. Późniejsze przejście na inną maskę spowoduje automatyczne zamknięcie maski chwilowej.

Położenie - miejsce na ekranie, gdzie maska ma być otwarta określone jako współrzędne jej lewego górnego narożnika. Brak parametrów lub wartości -1 oznaczają, że maska ma zostać otwarta zgodnie z jej pierwotna definicją. Pozycja ma zastosowanie w systemach wielomonitorowych.

Monitor - określenie monitora, na którym maska ma zostać otwarta (w systemie wielomonitorowym):

-1 – monitor wynikający z definicji maski,

0 – monitor, gdzie znajduje się monitor,

1 – monitor podstawowy,

2 – drugi monitor,

3 – trzeci monitor,

4 – czwarty monitor,

…

8 – ósmy monitor;

Aktywowanie mechanizmu zamiany zmiennych procesowych na maskach:

Zakładka Zamiana zmiennych:

Aby użyć mechanizmu zamiany zmiennych procesowych, należy zdefiniować nazwę pliku VRT (pole Nazwa pliku VRT) lub ręcznie wpisać listę zamienianych zmiennych (opcja Lista zmian). W przeciwnym przypadku mechanizm podmiany zmiennych nie będzie użyty.

Format pliku VRT przyjmuje następującą postać:
linia 1: opis tekstowy - jeżeli maska posiada linię tytułu, to opis jest do niej wstawiany;
linie 2 do n: nazwa_zmiennej_źródłowej;nazwa_zmiennej_wstawianej.

akcja PANEL - wyselekcjonowanie okna Panelu Kontrolnego. Jeżeli okno Panelu jest zminimalizowane, to zostanie automatycznie rozwinięte.

akcja PASEK_WYKRESOW - otwarcie paska narzędziowego obiektu WYKRES. Akcja zasadniczo przeznaczona jest dla systemów z ekranem dotykowym.

akcja PAUZA - wstrzymuje wykonywanie akcji na podany okres czasu lub do przyciśnięcia klawisza przez operatora. Akcja przeznaczona do tworzenia prezentacji. Używana w akcjach złożonych.

Parametry:

opóźnienie - czas opóźnienia w sekundach.

wartość domyślna: oczekiwanie tylko na przyciśnięcie klawisza.

akcja PISZ_RAPORT - obliczenie wyspecyfikowanego raportu oraz wydrukowanie go na drukarce. Policzony raport zapisany zostanie na dysku lub usunięty.

Parametry:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem wielokropek ’r;Edytor momentów języka ASTEL’;

Usuń raport po wydrukowaniu – spowoduje usunięcie raportu po jego wydrukowaniu;

Nazwisko operatora - do raportu zostanie dopisane nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - do raportu zostanie dołączona treść notatki (o ile pojawia się w definicji raportu).

akcja POKAŻ_RAPORT - obliczenie wyspecyfikowanego raportu oraz wyświetlenie go na ekranie. Policzony raport zapisany zostanie na dysku lub usunięty.

Parametry:

Raport - nazwa pliku z definicją raportu (pełna ścieżka); dla raportów skryptowych jest to zdefiniowana nazwa skryptu;

Moment - moment rozpoczęcia raportu w konwencji języka ASTEL; zdefiniowanie tego parametru ułatwia uruchamiany przyciskiem wielokropek ’Edytor momentów języka ASTEL’;

Usuń raport po wydrukowaniu - spowoduje usunięcie raportu po jego wyświetleniu;

Nazwisko operatora - do raportu zostanie dopisane nazwisko operatora (o ile pojawia się w definicji raportu);

Treść notatki - do raportu zostanie dołączona treść notatki (o ile pojawia się w definicji raportu).

akcja POŁĄCZ_ALARMY - akcja pozwala na przyłączenie do maski alarmów historycznych (o podanej nazwie) źródła alarmów, określonego nazwą zasobu i nazwą komputera.

Parametry:

Maska - maska, do której ma nastąpić przyłączenie wskazanego źródła alarmów historycznych; jako nazwę maski można podać znak ’*’ - oznacza to operację na pierwszej znalezionej masce alarmów historycznych (operacja zawsze dotyczy tylko jednej maski);

Nazwa zasobu - nazwa zasobu do przyłączenia; jest to nazwa sieciowa zestawu alarmów zadeklarowana na stanowisku pracującym w operatorskim trybie pracy systemu alarmów;

Komputer - nazwa serwera operatorskiego, z którego alarmy mają pochodzić; jeżeli źródło alarmów nie ma znaczenia, jako nazwę komputera można podać znak ’*’ - a wówczas poszukiwanie źródła alarmów odbywa się w kolejności: bezpośrednie połączenie do stanowiska alarmowego, połączenie przez pośredniczący serwer alarmów historycznych, połączenie do istniejącego archiwum plikowego;

Rodzaj połączenia - określa sposób wykonania połączenia; może przyjmować poniższe wartości:

- nazwa serwera pośredniczącego - wykonywana jest próba połączenia wyłącznie za pośrednictwem wskazanego serwera pośredniczącego; jeżeli się to nie uda, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- brak lub * - procedura domyślna, w pierwszym kroku szukane jest bezpośrednie połączenie do serwera operatorskiego; jeżeli się to nie uda, to poszukiwane jest dojście poprzez serwer pośredniczący. Jeżeli w dalszym ciągu nie uzyskano dostępu do logu, to sprawdzane jest czy na dysku lokalnym znajduje się ściągnięte wcześniej stare archiwum;

- BEZ_SERWERA - poszukiwane jest tylko bezpośrednie dojście do serwera operatorskiego; po niepowodzeniu, pokazywane jest stare archiwum lokalne (o ile istnieje);

- LOKALNIE - przyłączenie następuje do lokalnego archiwum, nie są wykonywane żadne próby szukania źródła alarmów w sieci.

Ilość dni - określa ilość ostatnich dni, z których należy przetransferować pliki logu alarmów. Brak parametru oznacza transfer całego logu.

akcja POTWIERDŹ_ALARMY - potwierdzenie alarmów pokazywanych na wszystkich otwartych maskach alarmów.

Parametry:

Numer alarmu - wskazuje na konkretny numer alarmu, który zostanie potwierdzony (tylko alarmy aktywne);

akcja PRZEŁĄCZ_ZASÓB_ALARMÓW - akcja umożliwia dynamiczne przełączanie zasobów alarmów.

Parametry:

Nazwa zasobu alarmów - nazwa zasobu alarmów (maksymalnie 8 znaków).

akcja PRZEPISZ - wykonanie operacji transferu wartości zmiennej procesowej Asmena, do innej zmiennej. Jeżeli zmienne znajdują się w rzeczywistych kanałach transmisyjnych, to operacja jest połączona z przesyłem danych do lub ze sterownika. Akcja nie sprawdza zgodności typów zmiennych. Zakłada się, że projektant systemu jest odpowiedzialny za konstrukcję aplikacji. Jedyną weryfikowaną cecha jest zgodność rozmiarów transferowanych zmiennych.

Parametry:

Zmienna źródłowa - nazwa zmiennej Asmena, której wartość jest transferowana;

Zmienna docelowa - nazwa zmiennej Asmena, do której transferowana jest wartość innej zmiennej;

Wyświetl komunikat informujący o błędzie - parametr jest liczbą, która określa, czy należy wyświetlać komunikat o ewentualnym błędzie operacji. Wartość parametru równa 0 oznacza, że komunikat nie jest wyświetlany. Opcja ta może być przydatna np. w sytuacji grupy operacji PRZEPISZ wywoływanych z terminarza, gdy nie można zapewnić potwierdzenia komunikatów przez operatora – w takiej sytuacji najwygodniej jest pozostawić opcję wyłączoną (parametr będzie miał przypisaną wartość 0), dzięki czemu komunikaty o błędzie nie będą wyświetlane.

akcja PYTAJ - przeznaczenie - do użytku w akcjach złożonych; akcja powoduje wyświetlenie okna dialogowego z podanym tekstem i przyciskami TAK i NIE. Przyciśniecie przez operatora przycisku NIE powoduje przerwanie akcji złożonej.

Parametry:

tekst - tekst wyświetlany w oknie. W przypadku długich tekstów można wprowadzić podział na linie poprzez wstawienie znaku \. Długość definicji akcji nie może przekroczyć 200 znaków.

akcja RAPORTUJ - otwarcie okna systemu raportów. Akcja równoważna komendzie Narzędzia > Okno raportów w Panelu Kontrolnym.

Parametry:

Położenie - określenie pozycji, w której okno ma być otwarte;

Katalog - nazwa katalogu roboczego modułu raportów. Pozwala na rozdzielenie definicji raportów na kilka katalogów, a następnie startowanie systemu z selektywnie wybranym zestawem raportów.

Wartość domyślna: katalog roboczy ustalany na podstawie pliku konfiguracyjnego aplikacji.

akcja SKRYPT - zlecenie wykonania skryptu znajdującego się w pliku tekstowym.

Parametry:

Skrypt - nazwa pliku zawierającego skrypt. Jeżeli ścieżka dostępu nie zostanie podana, przeszukiwane są katalogi ścieżki masek. Jeśli nie jest podane rozszerzenie pliku, to domyślnie dodawane jest vbs;

Parametry skryptu i wykonawcze - parametry przekazywane do wykonywanego skryptu: parametry skryptu oraz parametry wykonawcze, których deklarację umożliwia Edytor parametrów wykonawczych skryptu, uruchamiany przyciskiem wielokropek:

edytor parametrow wyk skryptow

Rysunek: Edytor parametrów wykonawczych skryptów.

akcja STERUJ_BITY - ustawienie wartości zmiennej procesowej Asmena, co powoduje jednoczesną transmisję wartości danej do sterownika (o ile zmienna procesowa znajduje się w kanale transmisyjnym). Akcja jest zorientowana na sterowania bitowe; Akcja STERUJ_BITY obsługuje zmienne 32-bitowe.

Parametry:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Wartość - wysyłana wartość, która może zostać jeszcze zmodyfikowana przez parametr maska; jest to liczba szesnastkowa;

Maska - maska określająca, które bity zmiennej są ustawiane (zerowane). Użycie maski powoduje, że w pierwszym kroku odczytywana jest aktualna wartość danej. Następnie modyfikowane są (zgodnie z parametrem wartość) tylko te bity, które są ustawione w masce. Na końcu tak spreparowana wartość jest odsyłana do Asmena. Wzór modyfikacji można przedstawić następująco:

nowa = (stara&(~maska))|(wartość&maska)

Mechanizm maskowania pozwala na zmianę w zmiennej tylko niektórych bitów. Pozostałe bity zachowują swą pierwotną wartość. Brak parametru oznacza, że aktualna wartość zmiennej nie jest czytana. Dana jest ustawiana bezpośrednio, zgodnie z parametrem wartość.

akcja SYGNAŁY - akcja umożliwia sygnalizowanie dźwiękiem tylko tych alarmów, które należą do określonych grup alarmów.

Parametry:

lista_identyfikatorów_grup

- jeżeli parametr nie jest podany, to alarmy pochodzące ze wszystkich grup są sygnalizowane dźwiękiem (domyślny stan po starcie programu);

- jeżeli parametr jest podany, to od momentu wykonania akcji sygnalizowane są tylko alarmy należące do dowolnej z grup, których identyfikatory zostały podane.

akcja TABELA - otwiera okna tabeli zmiennych.

Parametry:

Tabela - określenie nazwy pliku zawierającego definicję tabeli;

Tryb - oznacza rodzaj operacji, jaka ma być wykonana:

otwórz - otwarcie tabeli;

wymiana - otwarcie tabeli połączone z zamknięciem wcześniej otwartych tabel na tym samym monitorze;

zamknij - zamknięcie tabeli. Jeżeli parametr nazwa jest równy *, to zamykane są wszystkie otwarte tabele;

Położenie - wskazanie położenia lewego górnego narożnika okienka tabeli. Brak parametrów lub wartości -1 oznaczają, że należy wziąć współrzędne zapisane w definicji tabeli. Pozycja ma zastosowanie w systemach wielomonitorowych;

Monitor - określa numer monitora, na którym tabela ma być wyświetlona (wartość 1 odpowiada monitorowi podstawowemu). Specjalne znaczenie ma wartość 0. Oznacza ona wyświetlenie tabeli na monitorze, na którym znajduje się aktualnie kursor myszki, pominięcie parametru lub jego wartość równa -1, oznacza użycie monitora wynikającego z definicji tabeli i parametrów x,y. Pozycja ma zastosowanie w systemach wielomonitorowych:

-1 - monitor wynikający z definicji maski,

0 - monitor, gdzie znajduje się monitor,

1 - monitor podstawowy,

2 - drugi monitor,

3 - trzeci monitor,

4 - czwarty monitor,

…

8 - ósmy monitor;

akcja UCISZ_SYGNAL - wyłączenie sygnału dźwiękowego informującego o przyjściu alarmu. W przypadku stanowisk sieciowych wyciszenie sygnału jest wykonywane na wszystkich połączonych stanowiskach.

akcja UKRYJ_WSZYSTKO - zwinięcie wszystkich otwartych okien aplikacji do ikony na pasku zadań w prawej jego części. W wyniku tego następuje automatyczna redukcja obciążenia procesora. Przywrócenie aplikacji do poprzedniego stanu wykonuje się przez dwukrotne kliknięcie na ikonie A sixa na pasku zadań. Funkcja ukrycia wszystkich okien działa także w systemach bez paska zadań. W tym przypadku ukrywane są wszystkie okna z wyjątkiem okna panelu lub okna konstruktora, które jest tylko minimalizowane.

akcja URUCHOM - wykonanie dowolnego programu.

Parametry:

Komenda - nazwa programu wraz z parametrami, który ma zostać uruchomiony.

akcja USTAW_WARTOŚĆ - ustawienie wartości zmiennej procesowej Asmena, co powoduje jednoczesną transmisję wartości danej do sterownika (o ile zmienna procesowa znajduje się w kanale transmisyjnym). Akcja jest zorientowana na sterowanie wartością analogową.

Parametry:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Wartość - wysyłana wartość.

akcja USTAW_WYKRES - ustawienie czasu obiektu Wykres; skutkiem akcji jest zsynchronizowanie wszystkich wykresów na bieżącej masce z czasem przekazanym w zmiennej procesowej.

Parametry:

Zmienna - nazwa zmiennej przekazującej czas; zmienna musi być typu 32-bitowego i musi się w niej znajdować czas w formie zgodnej z formatem D obiektu liczba (liczba sekund od 1.1.1970). Jest to forma kompatybilna ze sposobem przekazywania pól typu Data przez AsBase’a. Akcja przeznaczona jest głównie do sterowania obiektami WYKRES, generowanymi na podstawie danych zebranych w bazie AsBase’a.

akcja WYDRUK_EKRANU - akcja powoduje wydruk całego ekranu lub aktywnego okna. Jest ona równorzędna wydrukowi wykonywanemu poprzez zastosowanie klawiszy Alt+F5.

Parametry:

Zawartość wydruku:

- Aktywne okno,

- Cały ekran;

Drukarka:

- Drukuj na drukarce domyślnej,

- Drukuj na wybranej drukarce - możliwość wskazania wymaganej drukarki, zainstalowanej w systemie operacyjnym komputera;

akcja WYKLUCZENIE - akcja pozwala na zmianę stanu wykluczenia alarmu o podanym numerze.

Parametry:

Operacja:

- Dodaj,

- Usuń;

Alarm - może być numerem pojedynczego alarmu lub nazwą pliku zestawu alarmów; należy podawać nazwę pliku bez rozszerzenia i ścieżki dostępu - automatycznie dodawane jest rozszerzenie EXL, a pliki są poszukiwane w katalogu roboczym systemu alarmów:

- Numer alarmu,

- Plik z zestawem alarmów.

akcja WYLOGUJ - akcja pozwala na natychmiastowe (bez żadnych pytań) wylogowanie aktywnego użytkownika i przejście do anonimowego trybu pracy, lub przełączenie na użytkownika domyślnego (jeżeli taki został zdefiniowany).

akcja WYŚLIJ_STEROWANIA - wysłanie sygnału wykonania operacji sterującej. Akcja używana przy współpracy z obiektami wizualizacyjnymi. W normalnym trybie pracy, obiekty po wyborze wartości sterującej nie wykonują natychmiastowego jej wysłania. Oczekują na sygnał, który wykonywany jest akcją WYŚLIJ_STEROWANIA.

Parametry:

Zakres operacji - określenie, czy operacja dotyczy maski bieżącej, czy wszystkich otwartych masek:

- Maska bieżąca - sygnał do obiektów na masce bieżącej,

- Wszystkie maski - sygnał do obiektów na wszystkich otwartych maskach.

akcja ZAMKNIJ_MASKĘ- zamknięcie maski bieżącej lub zadeklarowanej. Jeśli nie została podana jawnie nazwa maski, to nie zostaną zamknięte maski z ustawioną opcją Bez zamykania. Jeśli parametrem jest jawnie podana nazwa maski, to zamknie się ona nawet, gdy opcja Bez zamykania została ustawiona w jej parametrach.

Parametry:

Nazwa maski - określenie nazwy masek (maski), które mają zostać zamknięte; można używać znaków * i ? do deklaracji jednoczesnego zamknięcia całych grup masek;

Monitor - określa numer monitora, którego akcja dotyczy.

akcja ZMIANA_CZASU - otwarcie okna dialogowego pozwalającego na zmianę czasu systemowego. Akcja równoznaczna z komendą Opcje > Zmiana czasu w Panelu Kontrolnym i Oknie Konstruktora.

akcja ZMIEN_BITY - zmiana wartości wybranych bitów zmiennej procesowej Asmena. Procedura wykonania akcji polega na odczycie bieżącej wartości zmiennej ze sterownika, zmianie stanu wskazanych bitów na przeciwny i odesłaniu tak przygotowanej wartości do sterownika. Akcja ZMIEN_BITY obsługuje zmienne 32-bitowe.

Parametry:

Zmienna docelowa - nazwa zmiennej Asmena, która zostanie ustawiona;

Maska - maska określająca, które bity zmiennej są zmieniane (negowane). Wzór modyfikacji można przedstawić następująco:

nowa = (stara^maska)

akcja ZOBACZ - zlecenie wyświetlenia pliku.

Parametry:

nazwa_pliku - nazwa pliku, który ma zostać wyświetlony.


Deklarowanie długości nazwy zmiennej

2.2.4 Deklarowanie długości nazwy zmiennej

Sprawdzanie maksymalnego rozmiaru zmiennej w edytorze bazy definicji zmiennych jest wykonywane w odniesieniu do aktualnego rozmiaru kolumny Nazwa. Chcąc zmienić ograniczenie dotyczące długości zmiennej, należy użyć opcji Zmień rozmiar atrybutu [image] dla pola Nazwa. Opcja dostępna w menu edytora bazy definicji zmiennych.

Rys. Okno 'Modyfikacja szerokości atrybutu'.


Deklarowanie maksymalnej długości nazwy zmiennej

2.3.11. Deklarowanie maksymalnej długości nazwy zmiennej

Dla baz definicji zmiennych tworzonych w trybie generatora istnieje możliwość użycia opcji definiującej maksymalną długość nazw zmiennych: 50 znaków dla aplikacji klasycznych i 255 dla aplikacji w wersji Evo. Opcja Maksymalny rozmiar nazwy zmiennej dostępna jest przy trybie tworzenia bazy definicji zmiennych przy użyciu generatora, na zakładce Opcje:

Architekt > Bazy danych > Baza definicji zmiennych > Opcje

powiększ >>

Rys. Baza definicji zmiennych > Opcje > Maksymalny rozmiar nazwy zmiennej.


tabela_atrybutow_zmiennych

Nazwa

Opis

Typ wartości

Określa typ wartości zmiennej w konwencji .Net. W przypadku użycia bazy MDB nie posiadającej tego atrybutu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej funkcji przeliczającej i formatu.

Format

Sposób formatowania tekstowego wartości w konwencji .Net. Skrócony opis formatów .Net można znaleźć w podręczniku AsixEvo_Techniki_budowy_diagramów.pdf/chm.

W przypadku baz MDB atrybut tworzony jest wirtualnie według poniższych zasad:

  1. Jeżeli w bazie jest atrybut FormatEvo, to jest on traktowany wprost jako definicja atrybutu Format Asix.Evo.

  2. Jeżeli w bazie nie ma atrybutu FormatEvo, to atrybut Format bazy MDB (podawany w konwencji formatów aplikacji klasycznych) jest w trakcie ładowania tłumaczony na odpowiadający mu format .Net.

Funkcja przeliczająca odczytu

Atrybut ma postać wyrażenia, które wstępnie przelicza pobraną z drajwera wartość surową zmiennej. W treści wyrażenia odwołanie do wartości surowej wykonywane jest przy pomocy funkcji RawValue.

W przypadku korzystania z serwera danych (kanał Asix6), niezależnie od definicji atrybutu funkcji przeliczającej odczytu, wartość zmiennej podlega standardowemu przeliczeniu przez Asmen’a na podstawie atrybutu Funkcja przeliczająca.

W przypadku użycia bazy MDB nie posiadającej atrybutu Funkcja przeliczająca odczytu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej formatu.

Funkcja przeliczająca zapisu

Atrybut ma postać wyrażenia, które przelicza wartość sterującą przed wysłaniem jej do drajwera.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Wartość początkowa

Określa wartość początkową zmiennej, nadawaną zmiennej w momencie uruchomienia aplikacji.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.


Zalacznik 1

Załącznik 1

Tabela 1. Lista atrybutów systemowych Bazy Definicji Zmiennych.

Nazwa wewnętrzna atrybutu zmiennej (PL) | Rodzaj atrybutu | Nawa domyślnie wyświetlana w nagłówku (PL) | Nazwa wewnętrzna atrybutu zmiennej (EN) | Nawa domyślnie wyświetlana w nagłówku (EN) | Typ | Opis
Nazwa | obligatoryjny | Nazwa | Name | Name | T | Unikalna nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca tę zmienną dla wszystkich komponentów systemu asix
Opis | obligatoryjny | Opis | Description | Description | T | Dowolny tekst np. zawierający technologiczny opis zmiennej procesowej
Kanał | obligatoryjny | Kanał | Channel | Channel | T | Nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji)
Adres | obligatoryjny | Adres | Address | Address | T | Adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu asix
LiczbaElementow | obligatoryjny | Liczba elementów | ElementsCount | Elements count | L | Liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą)
OkresProbkowania | obligatoryjny | Okres próbkowania | SampleRate | Sample rate | L | okres aktualizacji wartości zmiennej procesowej (w sekundach)
FunkcjaPrzeliczajaca | obligatoryjny | Funkcja przeliczająca | ConversionFunction | Conversion function | T | Nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu asix
Archiwum | obligatoryjny | Archiwum | Archive | Archive | T | Nazwa zasobu ASPAD (logiczna nazwa zasobu archiwum)
ParametryArchiwizacji | obligatoryjny | Parametry archiwizacji | ArchivingParameters | Archiving parameters | T | Parametry archiwizacji danej zmiennej
Grupa1 | opcjonalny | Grupa1 | Group1 | Group1 | T | Domyślnie generowany atrybut grupujący
Format | opcjonalny | Format | Format | Format | T | Format liczby w jakim będzie ona wyświetlana w systemie asix; format podany jest w konwencji języka C (np.: %4.2f oznacza 4 znaki, w tym 2 miejsca po przecinku
Jednostka | opcjonalny | Jednostka | Unit | Unit | T | Fizyczna jednostka zmiennej
ZakresPomiarowyOd | opcjonalny | Zakres pomiarowy od | MeasurementRangeFrom | Measurement range from | L | Maksymalny zakres możliwy do uzyskania - minimum
ZakresPomiarowyHi | opcjonalny | Zakres pomiarowy do | MeasurementRangeTo | Measurement range to | L | Maksymalny zakres możliwy do uzyskania - maksimum
ZakresFunkcjiPrzeliczajacejOd | opcjonalny | Zakres funkcji przeliczającej od | ConversionFunctionRangeFrom | Conversion function range from | L | Parametr funkcji przeliczającej &endash; zakres wejściowy od &ldots;
ZakresFunkcjiPrzeliczajacejDo | opcjonalny | Zakres funkcji przeliczającej do | ConversionFunctionRangeTo | Conversion function range to | L | Parametr funkcji przeliczającej &endash; zakres wejściowy do &ldots;
ZakresPrzetwornikaOd | opcjonalny | Zakres przetwornika od | TransducerRangeFrom | Transducer range from | L | Zakres przetwornika - minimum
ZakresPrzetwornikaDo | opcjonalny | Zakres przetwornika do | TransducerRangeTo | Transducer range to | L | Zakres przetwornika - maksimum
ZakresWyswietlaniaOd | opcjonalny | Zakres wyświetlania od | DisplayRangeFrom | Display range from | L | Dolny zakres wyświetlania danej zmiennej &endash; dla obiektów asixa
ZakresWyswietlaniaDo | opcjonalny | Zakres wyświetlania do | DisplayRangeTo | Display range to | L | Górny zakres wyświetlania danej zmiennej &endash; dla obiektów asixa
ZakresSterowaniaOd | opcjonalny | Zakres sterowania od | SteeringRangeFrom | Steering range from | L | Dolny zakres wartości danej zmiennej ustawiany z asixa
ZakresSterowaniaDo | opcjonalny | Zakres sterowania do | SteeringRangeTo | Steering range to | L | Górny zakres wartości danej zmiennej ustawiany z asixa
BazaSlupka | opcjonalny | Baza słupka | BarBase | Bar base | T | Wielkość wczytywana z bazy przez obiekt SŁUPEK
NazwyStanow | opcjonalny | Nazwy stanów | StateNames | State names | T | Nazwa zbioru tekstów lub bezpośrednio zbiór opisów stanów (poszczególnych wartości całkowitych) zmiennej
ZestawStanow | opcjonalny | Zestaw stanów | StateSet | State set | T | Nazwa zbioru opisów stanów do którego należy bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów
WartoscStanu | opcjonalny | Wartość stanu | StateValue | State value | T | Numer stanu, którego opis zawiera bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów
MaskaZmiennejKontrolnej | opcjonalny | Maska zmiennej kontrolnej | ControlVariableMask | Control Variable mask | T | Wskazuje na bit statusu sygnalizowanego przez zmienną kontrolną
ZmiennaKontrolna | opcjonalny | Zmienna kontrolna | ControlVariable | Control variable | T | Nazwa zmiennej reprezentującej status zmiennej pomiarowej
LimitLoLo | opcjonalny | Minimum krytyczne | LimitLoLo | Limit LoLo | T | Nazwa zmiennej systemu asix, która zawiera wartość minimum krytycznego dla zmiennej pomiarowej
LimitLo | opcjonalny | Minimum | LimitLo | Limit Lo | T | Nazwa zmiennej systemu asix, która zawiera wartość minimum dla zmiennej pomiarowej
LimitHi | opcjonalny | Maksimum | LimitHi | Limit Hi | T | Nazwa zmiennej systemu asix, która zawiera wartość maksimum dla zmiennej pomiarowej
LimitHiHi | opcjonalny | Maksimum krytyczne | LimitHiHi | Limit HiHi | T | Nazwa zmiennej systemu asix, która zawiera wartość maksimum krytycznego dla zmiennej pomiarowej
ZakresWyswietlaniaKrok | opcjonalny | Zakres wyświetlania krok | DisplayRangeStep | Display range step | L | Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość podziałki głównej na osi OY (co ile jednostek będzie wyświetlana etykieta wartości na osi OY)
ZakresWyswietlaniaSzer | opcjonalny | Zakres wyświetlania szerokość | DisplayRangeWidth | Display range width | L | Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość etykiety wartości wyświetlanych na osi OY
ZakresWyswietlaniaPodzial | opcjonalny | Zakres wyświetlania podział | DisplayRangeDivision | Display range division | L | Atrybut wykorzystywany przez obiekt WYKRES. Wyznacza podział na mniejsze jednostki podziałki głównej (wyznaczonej przez atrybut Zakres wyświetlania krok) na osi OY
Dokładnosc | opcjonalny | Dokładność | Precision | Precision | T | Dokładność zaokrąglania w obiekcie LICZBA. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie nie ma zaokrąglania.
PolozenieSuwaka | opcjonalny | Położenie suwaka | SliderPosition | Slider position | T | Nazwa zmiennej, do której wpisywana będzie wartości reprezentująca położenie uchwytu obiektu SUWAK w trakcie przesuwania tegoż uchwytu
RejestracjaSterowania | opcjonalny | Rejestracja sterowania | ControlLogging | Control logging | Wartość logiczna | Wartość 1 oznacza, że sterowania zmiennej podlegają rejestracji w module AsAudit
ZmiennaNieaktywna | opcjonalny | Zmienna nieaktywna | ItemNotActive | Item not active | Wartość logiczna | Jeżeli wartość atrybutu wynosi 1, to zmienna nie jest widoczna w systemie asix dla modułów Asmen i Aspad
WykresTytul | opcjonalny | Tytuł wykresu | ChartTitle | Chart title | T | Atrybut wykorzystywany przez obiekt WYKRES. Tytuł wykresu pobierany jest z atrybutu Tytuł wykresu pierwszej zmiennej zadeklarowanej na wykresie
ZakresSlupkaOd | opcjonalny | Zakres słupka od | BarRangeFrom | Bar range from | T | Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera dolny zakres wyświetlania danej zmiennej.
ZakresSlupkaDo | opcjonalny | Zakres słupka do | BarRangeTo | Bar range to | T | Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera górny zakres wyświetlania danej zmiennej.

T &endash;tekst, L &endash; liczba zmiennoprzecinkowa 64 bitowa