Witamy

>> Pomoc dla użytkowników systemu asix - wersji 6

www.asix.com.pl

AsAudit

Dok. Nr PLH6013

Wersja: 22-09-2010


1.1. Serwer bazy danych

Działanie AsAudit oparte jest na zastosowaniu bazy danych SQL do przechowywania danych konfiguracyjnych i rejestracji danych zbieranych w trakcie pracy aplikacji.

Użycie AsAudit wymaga wcześniejszej instalacji serwera Microsoft SQL Server 2005. Można stosować bezpłatną wersję Express Edition, którą można pobrać ze strony www.microsoft.com/downloads.

W trakcie instalacji zalecane jest wybranie mieszanego trybu autoryzacji użytkowników (SQL Server/Windows NT).


1.3. Struktura danych konfiguracyjnych

Dane konfiguracyjne aplikacji AsAudit przechowywane są w dwóch miejscach:

  • Plik XML

W pliku XML przechowywana jest niewielka część danych konfiguracyjnych. Są to parametry dostępu do bazy danych oraz parametry uruchomienia aplikacji Asix.

Nazwa pliku XML jest podawana w liniach komend uruchamiających programy AsAudit’a. Ze względu na ochronę integralności plików, plik XML nie może być utworzony ręcznie – musi być zapisany przy pomocy programu konfiguracyjnego AsAudit’a.

  • Baza danych aplikacji

Przechowuje wszystkie pozostałe dane konfiguracyjne. Podobnie jak plik XML, ze względu na ochronę integralności, zawartość danych konfiguracyjnych bazy AsAudit nie może być modyfikowana przy pomocy innych narzędzi niż Konfigurator AsAudit.


1.4. Konfiguracja wielostanowiskowa

W przypadku konfiguracji sieciowych (wielostanowiskowych) stosowana jest pojedyncza baza danych ulokowana na wybranym stanowisku. Pliki XML mogą być różne, pod warunkiem identycznego określenia parametrów dostępu do bazy danych.

Konsola AsAudit ma wbudowane zabezpieczenia przed utratą połączenia z serwerem bazy danych. W fazie uruchomienia Konsola, w razie konieczności, używa lokalnej kopii danych konfiguracyjnych. Dane rejestrowane także mogą być buforowane lokalnie, do momentu odzyskania połączenia z serwerem bazy danych.


2.1.1. Lista chronionych funkcji systemu

W poniższej tabeli znajduje się opis funkcji systemowych kontrolowanych przez AsAudit’a.

Opis | Grupa
Uprawnienie parametryzacji aplikacji AsAudit. Zezwala na pracę z programem AsAudit Konfigurator. | AsAudit
Prawo zakończenia pracy Konsoli AsAudit, co jest równoznaczne z zakończeniem pracy całej aplikacji. | AsAudit
Użytkownik może zmienić hasło. Uprawnienie daje możliwość zmiany hasła w AsAudit Konsoli. | AsAudit
Brak blokowania funkcji systemu operacyjnego. Uprawnienie wyłącza zabezpieczenia dynamiczne systemu operacyjnego Windows (patrz: 2.6. Mechanizm zabezpieczeń systemowych). | System
Uprawnienie administratora programu As. Funkcjonalnie równoznaczne poziomowi administratora w systemie logowania programu As. | As
Uprawnienia hasła poziomu 1 programu As. Funkcjonalnie równoznaczne uprawnieniom hasła poziomu 1 w systemie logowania lub systemie haseł programu As. | As
Uprawnienia hasła poziomu 2 programu As. Funkcjonalnie równoznaczne uprawnieniom hasła poziomu 2 w systemie logowania lub systemie haseł programu As. | As
Uprawnienia hasła poziomu 3 programu As. Funkcjonalnie równoznaczne uprawnieniom hasła poziomu 3 w systemie logowania lub systemie haseł programu As. | As
Uprawnienia hasła poziomu 4 programu As. Funkcjonalnie równoznaczne uprawnieniom hasła poziomu 4 w systemie logowania lub systemie haseł programu As. | As
Uprawnienie do przejścia w tryb konstruktora programu AS. Odpowiada opcji Blokada konstruktora pliku inicjującego programu AS. | As
Uprawnienie zmiany czasu programu AS. Odpowiada opcji Limit zmiany czasu=0 pliku inicjującego programu AS. | As
Prawo edycji raportów programu AS. Odpowiada opcji Blokada edycji pliku inicjującego programu AS. | As
Prawo interaktywnego wyboru dowolnej maski. W programie AS funkcja jest objęta ochroną w ramach opcji Blokada zmian pliku inicjującego. | As
Prawo użycia menedżer plików programu AS. Odpowiada opcji BLOKADA_MENEDZERA_PLIKOW pliku inicjującego programu AS. | As
Prawo zakończenia pracy aplikacji As. Odpowiada opcji Blokada zamykania aplikacji pliku inicjującego programu AS. | As
Prawo zmiany ustawień filtrowania alarmów. Odpowiada opcji ustalania poziomu uprawnień do wykonania operacji zmiany alarmów filtrowanych - opcja pliku inicjującego programu AS. | As
Prawo zmiany ustawień sygnałów dźwiękowych alarmów. Odpowiada opcji ustalania poziomu uprawnień do wykonania operacji zmiany alarmów sygnalizowanych dźwiękowo – opcja pliku inicjującego programu AS. | As
Prawo zmiany ustawień wykluczania alarmów. Odpowiada opcji ustalania poziomu uprawnień do wykonania operacji zmiany alarmów wykluczeń - opcja pliku inicjującego programu AS. | As
Uprawnienie edycji tabel programu As. | As
Prawo do przeglądania archiwum działań operatora w programie AsAudit Przeglądarka. | AsAudit
Prawo do przeglądania archiwum wykonanych sterowań w programie AsAudit Przeglądarka. | AsAudit
Prawo do przeglądania archiwum notatek i zdarzeń w programie AsAudit Przeglądarka. | AsAudit
Uprawnienie administratora programu AsTrend. | AsTrend
Prawo zapisu plików konfiguracyjnych trendów. | AsTrend
Prawo zapisu chronionych plików konfiguracyjnych trendów. | AsTrend
Prawo tworzenia nowych plików konfiguracyjnych trendów. | AsTrend
Prawo posiadania własnego układu menu i pasków narzędzi. | AsTrend
Prawo modyfikacji wspólnego układu menu i pasków narzędzi. | AsTrend
Prawo administrowania mechanizmem automatyki | AsTrend
Uprawnienie administratora programu AsBase | AsBase
Prawo do edycji aplikacji | AsBase
Prawo ładowania receptur | AsBase
Prawo edytowania receptur | AsBase
Prawo do pełnego edytowania archiwów | AsBase
Prawo do zmiany w archiwum pól posiadających zezwolenie na edycję | AsBase
Prawo do ręcznego inicjowania zapisu rekordu do archiwum | AsBase
Prawo do zmiany wyglądu tabel | AsBase


2.2. Notatnik operatora

Notatnik operatora to funkcjonalność, która umożliwia operatorom sporządzanie elektronicznych ‘odręcznych’ notatek tekstowych, które mogą być przypisywane do dowolnego miejsca na masce synoptycznej aplikacji systemu asix.

Z obsługą notatek związane jest pojęcie segmentu, który w tym przypadku jest elementem jednoznacznie identyfikującym notatkę lub grupę notatek. Dzięki segmentowi istnieje możliwość powiązania notatki z konkretnym miejscem na masce synoptycznej aplikacji asixa.

Segmenty definiowane są w Konfiguratorze AsAudit.

Notatki tworzone są w Konsoli AsAudit.

Przeglądanie notatek z podziałem na segmenty umożliwia Przeglądarka AsAudit.

Wywołanie notatek utworzonych dla danego segmentu z poziomu maski synoptycznej aplikacji asixa następuje za pomocą akcji operatorskiej o następującej składni:

AsAudit Przeglądarka,Notatki[,id_segmentu]


2.2.3. Tworzenie notatek

Aby utworzyć notatkę – należy wywołać okno konsoli AsAudit, umożliwiające operatorowi utworzenie nowej notatki.

Rys. Konsola AsAudit – okno do tworzenia notatek operatorskich.


2.2.4. Tworzenie segmentu

Segmenty definiowane są w oknie Konfiguratora AsAudit w widoku ‘Segmenty’, który dostępny jest po wybraniu pozycji Notatki w drzewie nawigacyjnym.

Rys. Konfigurator AsAudit – okno do tworzenia segmentów notatek.


2.2.5. Monitorowanie aktywnych notatek w segmencie

Dodatkowe wsparcie dla obsługi notatek to ustawianie flag obecności aktywnych notatek w segmencie w zmiennych procesowych __id_segmentu__. Mechanizm tez jest włączany, jeżeli użytkownik zdefiniuje odpowiednie zmienne systemowe __id_segmentu__.

__id_segmentu__ monitoruje stan obecności aktywnych notatek w segmencie; przyjmuje wartości:

1 - aktywne notatki dla danego segmentu

0 – brak aktywnych notatek dla danego segmentu


2.5. Kontrola integralności aplikacji

Kontrola integralności aplikacji polega na weryfikacji zawartości bazy zmiennych oraz wybranych plików używanych w aplikacji. Program konfiguracyjny wylicza sumy kontrolne wskazanych plików oraz bazy zmiennych. Sumy kontrolne weryfikowane są w trakcie pracy systemu. W fazie startowej Konsoli sprawdzane są wszystkie kontrolowane pliki. W przypadku wykrycia niezgodności użytkownik może podjąć decyzję, czy start aplikacji ma być kontynuowany. Dodatkowe testy wykonywane są przy każdej próbie dostępu do kontrolowanego pliku – w przypadku błędu operacja jest blokowana. Każdy błąd integralności jest rejestrowany w bazie danych.


Mechanizm zabezpieczeń systemowych

2.6. Mechanizm zabezpieczeń systemowych

Mechanizmy zabezpieczeń systemowych pozwalają na łatwe zabezpieczanie dostępu do potencjalnie niebezpiecznych funkcji systemu operacyjnego, których nieumiejętne lub nieodpowiedzialne użycie przez operatora mogłoby doprowadzić do uszkodzenie systemu. Jednocześnie, użycie mechanizmów zabezpieczeń, pozwala na pracę na konto użytkowników systemu Windows o dużych uprawnieniach, co ułatwia konserwację i zarządzanie pracą systemu operacyjnego.

Mechanizmy zabezpieczeń dzielą się na dwie grupy:

dynamiczne - zintegrowane z asixem i dynamicznie włączające się lub wyłączające w zależności od stanu programu;

statyczne - ustawiane jednorazowo i pozostające w stanie aktywnym przez cały czas pracy systemu operacyjnego (więcej w podręczniku "asix - funkcjonalność i zasady działania" (plik asix.chm lub asix.pdf).

Zestaw zabezpieczeń przełączanych dynamicznie jest następujący:

  • blokada dostępu do menedżera zadań (klawisze Ctrl+Alt+Del);

  • ukrywanie i blokada paska zadań;

  • blokada klawiszy otwierających menu startowe (klawisze Ctrl+Esc i Windows);

  • blokada wyświetlania plików pomocy HLP.

System zabezpieczeń dynamicznych w przypadku stosowania systemu kontroli uprawnień przy użyciu modułu AsAudit włączany jest przełacznikiem /PROTECT dodawanym do komendy startowej programu AsAudit (Konsoli). Dzięki temu zabezpieczenia włączane są natychmiast jeszcze przed pełnym uruchomieniem aplikacji asixa. Pozwala to uniknąć nieautoryzowanych zmian w aplikacji, wprowadzonych przez operatora na etapie uruchamiania aplikacji. Zabezpieczenia dynamiczne wyłączane są tylko wtedy, gdy zalogowany jest operator o uprawnieniach administratora.


3.1. Konsola

Konsola AsAudit uruchamiana jest przy pomocy komendy:

AsAuditConsole plik_konfiguracyjny [/protect] [/user:<id> /password:<haslo>][/forcelogin][/nologinrules]

Obowiązkowy parametr plik_konfiguracyjny określa nazwę pliku konfiguracyjnego xml aplikacji AsAudit.

Opcjonalny przełącznik /protect włącza obsługę ochrony pulpitu (blokada paska zadań, klawiszy funkcyjnych Windows, itp.). Domyślnie ochrona jest wyłączona. Użycie Konsoli bez przełącznika /protect powoduje, że program As32 pakietu asixa automatycznie wyłącza własną kontrolę pulpitu.

Parametry [/user:<id> /password:<haslo>] powodują automatyczne logowanie wskazanego użytkownika. Parametry te maja pierwszeństwo przed ustawieniami domyślnego uzytkownika w bazie danych aplikacji AsAudit.

Parametr [/forcelogin] zmienia sposób obsługi parametrów wylogowania. W momencie upłynięcia czasu ważności logowania, użytkownik pozostaje zalogowany, ale aktywizywane jest okno konsoli w trybie logowania. Okna nie można ukryć ani zamknąć aż do momentu zalogowania się uzytkownika.

Parametr [/nologinrules] powoduje, że parametry logowania zapisane w bazie danych (domyślny użytkownik, parametr wylogowania) są ignorowane.

Bardzo istotnym elementem uruchomienia Konsoli jest katalog startowy aplikacji, który musi być zgodny z katalogiem bazowym plików wchodzących w skład aplikacji. Wynika to z faktu, że wszystkie nazwy plików użyte w konfiguracji aplikacji AsAudit (zabezpieczenia dostępu do plików i kontrola integralności) są zapisywane w bazie danych ze ścieżkami względnymi (względem katalogu bazowego).

Uruchomienie Konsoli może być połączone z uruchomieniem programu As32 (o ile w pliku konfiguracyjnym umieszczone są parametry startowe As32). Pozwala to uruchomić całą aplikację Asix’a z pojedynczego skrótu na pulpicie startującego Konsolę AsAudit.

Konsola monitoruje zmiany danych konfiguracyjnych. W przypadku wykrycia zmiany, Konsola automatycznie odczytuje nowe dane konfiguracyjne z bazy danych.

Okno Konsoli składa się z dwóch przełączanych paneli. Górny służy do logowania użytkowników. W dolnym panelu znajdują się dwie zakładki:

  • Podgląd zdarzeń

Służy do przeglądania komunikatów związanych z bieżącą pracą aplikacji AsAudit. Nie są to komunikaty rejestrowane w bazie danych. Część z komunikatów jest kopią zdarzeń zapisanych w bazie danych, inne są związane z pracą oprogramowania Modułu AsAudit. Komunikaty z zakładki „Podgląd zdarzeń” są zapisywane na dysku w pliku aswork_console.log.

  • Nowa Notatka

Zakładka pozwala na wpisanie przez operatora notatki tekstowej.


3.3. Konfigurator

Konfigurator AsAudit uruchamiana jest przy pomocy komendy:

AsAuditConfig [plik_konfiguracyjny]

Parametr plik_konfiguracyjny określa nazwę pliku konfiguracyjnego xml aplikacji AsAudit. Jeżeli nazwa pliku nie zostanie podana, to można później wybrać plik konfiguracyjne poprzez funkcje dostępne w menu Konfiguratora.

Jeżeli Konfigurator jest uruchamiany przy działającej Konsoli, to parametr plik_konfiguracyjny jest ignorowany – używany jest ten sam plik konfiguracyjny, który został podany przy starcie Konsoli.

Okno Konfigurator składa się z dwóch części. Z lewej strony okna znajduje się drzewko nawigacyjne, którego postać zależy od aktualnego kontekstu Konfiguratora i listy zdefiniowanych użytkowników i grup. Poprzez kliknięcie na właściwym elemencie drzewka przełączana jest zawartość panelu w prawej części okna, służąca do parametryzowania aplikacji.


3.3.1. Tworzenie nowej aplikacji

Pierwszym krokiem w procesie tworzenia nowej aplikacji jest wykonanie komendy Nowy z menu Plik. Identyczny skutek powoduje uruchomienie Konfiguratora bez podania parametrów startowych. Okno Konstruktora wyświetlane jest w poniższej formie:

Przy pomocy przycisku Ustawienia bazy danych należy rozpocząć procedurę tworzenia bazy danych AsAudit’a. Wyświetlone zostanie poniższe okno dialogowe:

Należy określić lokalizacje serwera i nazwę bazy danych. Niewypełnienie pola Nazwa serwera oznacza użycie serwera bazy uruchomionego na lokalnym komputerze.

Tryb autoryzacji z reguły należy pozostawić w ustawieniu Serwer SQL.

Parametry dostępu administracyjnego do serwera są używane jednorazowo, tylko w momencie zakładania bazy danych. Jeżeli konto Windows, pod którym odbywa się praca jest kontem administracyjnym, to można stosować tryb Windows NT. Jeżeli nie, to z reguły należy użyć autoryzacji Serwer SQL z jawnym podaniem konta i hasła użytkownika administracyjnego serwera.

Zasady autoryzacji mogą być jednak inne, w zależności od przyjętych w firmie zasad bezpieczeństwa.

Po przyciśnięciu klawisza OK, jeżeli baza o podanej nazwie jeszcze nie istnieje wyświetlane jest poniższe okno.

Pole Plik kopii bazy danych używane jest tylko wtedy, gdy nowa baza danych ma być utworzona na podstawie posiadanej kopii bezpieczeństwa innej bazy danych AsAudit’a (np. podczas przenoszenia bazy danych z innego serwera).

W polu Katalog bazy danych można określić lokalizację plików, w których serwera SQL zapisuje bazę danych (tylko wtedy, gdy pliki mają być umieszczone w innej niż standardowa lokalizacja).

Po utworzeniu bazy danych kolejnym krokiem jest zdefiniowanie użytkownika z uprawnieniami do edycji aplikacji AsAudit. W tym celu należy:

  • Wybrać węzeł Użytkownicy w drzewku nawigacyjnym

  • Wprowadzić nowego użytkownika w panelu roboczym

  • Wybrać węzeł Uprawnienia w drzewku nawigacyjnym

  • W górnej części panelu roboczego wybrać uprawnienie Uprawnienie parametryzacji aplikacji AsAudit, a następnie w dolnej części panelu zaznaczyć pole wyboru w linii utworzonego wcześniej użytkownika.

Ostatnią operację w procesie tworzenia nowej aplikacji jest użycie funkcji Zapisz z menu Plik, w celu zapisania danych konfiguracyjnych w pliku xml i bazie danych. Utworzony w ten sposób plik xml jest używany później jako parametr startowy Konsoli i innych programów AsAudit’a.


3.3.3. Panel parametrów podstawowych

Panel Parametry podstawowe służy do tworzenia baz danych AsAudit’a oraz ustawienia parametrów o znaczeniu globalnym.

Pole Nazwa aplikacji pozwala nadać aplikacji nazwę. Nazwa wyświetlana jest na belkach tytułowych programów AsAudit’a.

Zawartości pola Katalog aplikacji nie można zmienić. Jest w nim wyświetlany katalog bazowy aplikacji, który wynika wyłącznie z lokalizacji pliku xml aplikacji. Względem katalogu bazowego są tworzone relatywne ścieżki do wszystkich plików aplikacji.

Pola w grupie Baza danych pokazują aktualne parametry bazy danych aplikacji AsAudit. Przycisk Ustawienia bazy danych pozwala na zmianę tych parametrów.

Pole Style wydruków wraz ze zintegrowanym przyciskiem służy do tworzenia styli drukowania stosowanych w aplikacji AsAudit.

Pole Parametry startowe AS, należy ustawiać tylko wtedy, gdy start Konsoli AsAudit ma być połączony ze startem aplikacji wizualizacyjnej Asix’a. Parametry te zapisywane są w pliku aplikacyjnym XML.

Pole Baza zmiennych wraz ze zintegrowanym przyciskiem służy do wprowadzenia parametrów bazy definicji zmiennych. Zawartość bazy zmiennych jest pokazywana w panelu roboczym w trakcie definiowania zasad ochrony zapisu do zmiennych. W przypadku zaznaczenia pola wyboru Integralność bazy zmiennych zawartość bazy definicji zmiennych podlega także sprawdzaniu pod kątem integralności aplikacji. Przycisk Sprawdź integralność pozwala sprawdzić czy baza definicji zmiennych uległa zmianie od ostatniego wyliczenia sumy kontrolnej zawartości bazy.


3.3.5. Znaczenie wyświetlanych ikon

Ikony wyświetlane w tabelach panelu roboczego mają poniższe znaczenie:

Kolumna U/G

oznaczenie użytkownik zwykłego

oznaczenie grupy użytkowników

Kolumna Status w zakładce Uprawnienia w panelu użytkownika/grupy

Brak | żaden użytkownik nie posiada tego uprawnienia
 | użytkownik posiada to uprawnienie
 | użytkownik nie posiada tego uprawnienia, ale ma je inny użytkownik

Kolumna Status w zakładce Zmienne w panelu użytkownika/grupy

Brak | zapis do zmiennej nie jest kontrolowany, wszyscy użytkownicy mogą wykonywać operacje sterujące do zmiennej
 | użytkownik może wykonywać zapisy zmiennej
 | użytkownik nie może wykonywać zapisów zmiennej

Kolumna Status w zakładce Pliki w panelu użytkownika/grupy

Brak | dostęp do pliku nie jest kontrolowany, wszyscy użytkownicy mogą go używać
 | plik może być używany przez użytkownika
 | użytkownik nie może używać pliku

Kolumna Użyte panelu Uprawnienia

Brak | żaden użytkownik nie posiada tego uprawnienia
 | uprawnienie zostało nadane co najmniej jednemu użytkownikowi

Kolumna Chroniona panelu Ochrona zmiennych

Brak | operacje sterujące dla zmiennej nie są chronione
 | operacje sterującej są chronione

Kolumna Chroniony panelu Ochrona plików

Brak | dostęp do pliku nie jest ograniczany
 | dostęp do pliku jest chroniony

Kolumna Status panelu Integralność

Brak | plik nie jest kontrolowany
 | plik nowo dodany, nie był wcześniej rejestrowany
 | plik jest zgodny z wcześniej zarejestrowaną wersją
 | plik podlegający kontroli nie istnieje
 | plik podlegający ochronie ma zmieniona zawartość
 | plik podlegający ochronie ma zmieniony czas, zawartość jest zgodna
 | błąd sprawdzania wersji pliku


3.3.6. Aktualizacja danych integralności aplikacji

W przypadku, gdy konieczna jest tylko aktualizacja danych integralności aplikacji (sum kontrolnych plików) należy otworzyć aplikację przy pomocy komendy Otwórz z menu Plik, a następnie wykonać komendę Zapisz. Konfigurator zapyta wtedy, czy należy zaktualizować dane dotyczące integralności. Po potwierdzeniu Konfigurator przeliczy ponownie sumy kontrolne wszystkich plików podlegających kontroli.

Pytanie o aktualizację danych integralności pojawia się przed każdym zapisem danych konfiguracyjnych. Poprzez negatywną odpowiedź można spowodować zmianę danych konfiguracyjnych z zachowaniem niezmienionych danych integralności.


4. Modyfikacja struktury bazy zmiennych dla parametryzacji

4. Modyfikacja struktury bazy zmiennych dla parametryzacji rejestracji sterowań

Wybór zmiennych, które podlegają rejestracji sterowań odbywa się w bazie definicji zmiennych poprzez ustawienie na niezerową wartość atrybutu RejestracjaSterowania.

Dotyczy modyfikacji bazy utworzonej w wersji pakietu asix4

Atrybut ten nie był do tej pory umieszczany w bazie zmiennych. W związku z tym wymagane jest utworzenie nowej bazy zmiennych rozszerzonej o atrybut RejestracjaSterowania. W tym celu należy do pliku schematu bazy zmiennych, na podstawie którego tworzona jest baza, dodać:

  • W sekcji [Attributes] linię „RejestracjaSterowania = N,”

  • W sekcji [LocalAttributesNames] linię „RejestracjaSterowania = 1045: Rejestracja sterowania, 1033: Control logging”

Po zmodyfikowaniu pliku schematu należy na jego podstawie utworzyć nową bazę zmiennych przy pomocy Edytor Bazy Zmiennych lub Menedżera Bazy Zmiennych.


1.2. Części składowe

W skład Modułu AsAudit wchodzą poniższe programy:

  • Konsola AsAudit

Podstawowy program, który musi być uruchomiony przez cały czas pracy aplikacji. Jest odpowiedzialny za logowanie użytkowników, sprawdzanie uprawnień i gromadzenie informacji dotyczących pracy aplikacji.

Uruchomienie aplikacji wykorzystującej funkcje AsAudit’a wymaga uruchomienia Konsoli jako pierwszy program aplikacji Asix’a.

  • Przeglądarka AsAudit

Program do przeglądania i analizy danych zbieranych w trakcie pracy aplikacji.

  • Konfigurator AsAudit

Interaktywny program konfiguracyjny parametrów aplikacji.


1. Wstęp

Moduł AsAudit jest częścią systemu Asix, której podstawowym zadaniem jest dostosowanie Asix’a do wymagań stawianych w trakcie walidacji systemów przeznaczonych do pracy w przemyśle spożywczym i farmacji. Zadaniem AsAudit jest także zastąpienie niezależnych systemów kontroli uprawnień, stosowanych przez poszczególne moduły systemu Asix, jednym centralnym systemem logowania użytkowników.

Moduł AsAudit obsługuje poniższe funkcje:

  • System logowania użytkowników i kontroli uprawnień

  • Notatnik operatora

  • Rejestracja wykonanych sterowań dla wybranych zmiennych

  • Rejestracja działań operatora

  • Kontrola integralności aplikacji


2.1. System logowania użytkowników i kontroli uprawnień

Moduł AsAudit pozwala na kontrolę dostępu do następujących elementów aplikacji asix’a:

  • Funkcje systemu

Niektóre funkcje systemu (np. operacja zakończenia aplikacji, wykluczenia alarmów) mogą być blokowane dla nieuprawnionych użytkowników. Parametryzacja praw dostępu do chronionych akcji odbywa się poprzez podanie użytkowników, którzy MOGĄ wykonać akcję. Domyślnie akcja jest zablokowana dla wszystkich użytkowników.

  • Pliki

Wybrane pliki mogą być chronione przed użyciem przez nieuprawnionego użytkownika. W przypadku takiego zdarzenia operacja jest blokowana.

Domyślnie pliki są niechronione.

Niekiedy prawa dostępu mogą być zignorowane przez oprogramowanie aplikacji. Dotyczy to plików, które ładowane są przez Asix’a w kontekście wszystkich użytkowników, np. pliki konfiguracyjne systemu alarmów.

  • Operacje sterujące zmiennych procesowych

AsAudit może kontrolować próby wysłania sterowania do wybranych zmiennych. Obiekty wizualizacyjne masek Asix’a, automatycznie blokują funkcje wyboru nowych wartości, jeżeli użytkownik nie ma wystarczających uprawnień.

Domyślnie, operacje sterowania dla zmiennej nie są chronione. Przy czym niezależnie od działania AsAudit’a, Asmen stosuje własne standardowe mechanizmy ochrony na poziomie kanałów komunikacyjnych.

AsAudit pozwala na tworzenie grup użytkowników. Grup można używać przy nadawaniu uprawnień do chronionych elementów aplikacji, w taki sam sposób jak zwykłych użytkowników.

Ponadto, istnieje możliwość zdefiniowania użytkownika domyślnego, który będzie automatycznie logowany na starcie systemu oraz po każdej operacji wylogowania innego użytkownika. Mechanizm ten pozwala zdefiniować minimalny poziom uprawnień dostępny dla wszystkich użytkowników aplikacji.

W bazie danych rejestrowane są wszystkie operacja logowania użytkowników, a także wszystkie zdarzenia prób nieuprawnionego dostępu do elementów aplikacji.


2.2.1. Przeglądanie notatek

Okno przeglądarki AsAudit służące do podglądu notatek operatorskich składa się z:

- menu głównego przeglądarki AsAudit,

- paska narzędziowego przeglądarki,

- linii wyświetlającej nazwę aktualnie zalogowanego użytkownika,

- tabeli komunikatów lub tabeli (dziennika) notatek (w zależności od tego, która zakładka jest wybrana),

- paska filtru tabeli,

- paska narzędziowego tabeli.

Rysunek: Okno Przeglądarki – Dziennik notatek.

Tabela notatek składa się z następujących pól:

- Data i czas utworzenia notatki;

- Treść notatki;

- Użytkownik, czyli autor notatki;

- Komputer, na którym utworzono notatkę;

- Segment – czyli identyfikator notatki na masce aplikacji;

- Aktywna – parametr informujący o statusie notatki (aktywna, nieaktywna).

Operator ma do dyspozycji zestaw predefiniowanych filtrów, które dają możliwość filtrowania notatek wg następujących kategorii informacji:

- daty i czasu utworzenia notatki;

- autora notatki;

- komputera operatora;

- segmentu;

- statusu notatki (aktywna, nieaktywna).

Predefiniowane filtry dla daty i czasu utworzenia notatek:

- Dzisiaj

- Wczoraj

- Od wczoraj

- Ten tydzień

- Poprzedni tydzień

- Od poprzedniego tygodnia

- Ten miesiąc

- Poprzedni miesiąc

- Od poprzedniego miesiąca

- Ten rok

- Poprzedni rok

- Od poprzedniego roku


2.2.2. Tworzenie indywidualnych widoków przeglądarki notatek

Widok tabeli notatek pozwala zapamiętać wszystkie filtry ustawione indywidualnie przez operatora.

Zestaw poleceń do tworzenia, usuwania i wybierania widoków tabel notatek dostępny jest w pasku narzędziowym Tabela.

Aby wyświetlić ten pasek, należy kliknąć w menu głównym przeglądarki na polecenie Widok > Paski narzędzi i zaznaczyć pozycję Tabele.

Aby utworzyć nowy widok – należy wybrać polecenie Zapisz jako i w oknie, które zostanie wyświetlone, wpisać nazwę widoku, a następnie zatwierdzić zmiany przyciskiem OK. Lsta wszystkich zdefiniowanych widoków dostępna jest pod poleceniem Wybierz widok.

Aby usunąć widok – należy wybrać polecenie Usuń widok i z rozwijanej listy wybrać widok przeznaczony do skasowania – zostanie uruchomione okno z prośbą o potwierdzenie czynności usuwania.

Aby wybrać widok – należy kliknąć na poleceniu Wybierz widok i z rozwijanej listy wybrać stosowną pozycję.

Rys. Okno przeglądarki AsAudit – zapis konfiguracji widoku tabeli.


2.3. Rejestracja wykonanych sterowań

AsAudit może rejestrować operacje sterujące wykonywane na wybranych zmiennych procesowych. Rejestrowane jest:

  • Moment wykonania sterowania

  • Identyfikator zalogowanego użytkownika

  • Nazwa komputera wykonującego sterowanie

  • Wartość zmiennej procesowej przed wykonaniem sterowania

  • Wartość sterująca

  • Status operacji wysłania wartości

Parametryzacja (wybór zmiennych) rejestracji sterowań odbywa się w bazie zmiennych poprzez ustawienie na niezerową wartość atrybutu RejestracjaSterowania.


2.4. Rejestracja działań operatora

AsAudit może rejestrować niektóre działania operatorów systemu Asix. Możliwa jest rejestracja operacji:

  • Otwarcia maski

  • Zamknięcia maski

  • Otwarcia tabeli

  • Zamknięcia tabeli

  • Otwarcia trendu

  • Zamknięcia trendu

  • Zmiany stanu programu AS (początek koniec, wejście do Konstruktora)

Rejestrowany jest rodzaj i obiekt operacji (np. nazwa maski) wraz z czasem zdarzenia i identyfikatorem aktualnego użytkownika.

Parametryzacja rejestracji działań operatora odbywa się w programie konfiguracyjnym i polega na określeniu rodzajów rejestrowanych operacji oraz nazw komputerów, dla których rejestracja ma być wykonywana.


2. Funkcje modułu AsAudit


3.2. Przeglądarka

Przeglądarka AsAudit uruchamiana jest przy pomocy komendy:

AsAuditBrowser [plik_konfiguracyjny]

Parametr plik_konfiguracyjny określa nazwę pliku konfiguracyjnego xml aplikacji AsAudit.

Jeżeli nazwa pliku nie zostanie podana, to można później wybrać plik konfiguracyjne poprzez funkcje dostępne w menu Przeglądarki.

Jeżeli Przeglądarka jest uruchamiana przy działającej Konsoli, to parametr plik_konfiguracyjny jest ignorowany – używany jest ten sam plik konfiguracyjny, który został podany przy starcie Konsoli.

Okno składa się z dwóch paneli. Górny panel służy do logowania użytkowników. Jest on aktywny tylko wtedy, gdy nie jest uruchomiona Konsola.

W dolnym panelu znajdują się trzy zakładki, służące do analizy danych zarejestrowanych w bazie danych aplikacji AsAudit:

  • Dziennik akcji

Przeglądanie zarejestrowanych działań operatora typu otwarcie maski, itp.

  • Dziennik sterowań

Przeglądanie zarejestrowanych operacji sterujących zmiennych procesowych

  • Dziennik notatek

Zbiorczy rejestr zdarzeń. Używane kategorie to: zdarzenia logowania, naruszenia praw dostępu, naruszenia integralności, notatki operatora, zmiany konfiguracji.


3.3.2. Logowanie użytkownika

Wszelkie zmiany parametrów aplikacji AsAudit wymagają posiadania uprawnienia o nazwie Uprawnienie parametryzacji aplikacji AsAudit. Pierwszą czynnością po uruchomieniu Konfiguratora i załadowaniu pliku xml musi być zalogowanie się użytkownika. Wykonywane jest to w panelu Logowanie.

Konfigurator nie przejmuje aktualnego użytkownika z pracującej Konsoli. Zawsze musi być wykonane bezpośrednie logowanie w programie Konfiguratora.


3.3.4. Użytkownik domyślny

Węzeł Zabezpieczenia pozwala na zdefiniowanie tzw. użytkownika domyślnego oraz czasu początkowego i okresu zalogowania.

Programy AsAudit’a w momencie startu automatycznie logują użytkownika domyślnego. Podobnie, w momencie gdy któryś z użytkowników się wylogowuje, to następuje zalogowanie użytkownika domyślnego.

Mechanizm użytkownika domyślnego pozwala ustanowić pewien minimalny zakres uprawnień, który jest dostępny wszystkim użytkownikom aplikacji.

Określenie czasu początkowego oraz okresu zalogowania parametryzuje mechanizm automatycznego wylogowania użytkowników.


3. Programy modułu AsAudit


5. Sterowanie programami modułu AsAudit z aplikacji Asix'a

Istnieje możliwość sterowania wyświetlaniem okien programów Modułu AsAudit z aplikacji wizualizacyjnej asixa. Do tego celu służy akcja ASAUDIT o poniższej składni:

Parametry akcji definiowane przy użyciu edytora akcji:

Okno - pozwala na wybór okna, które ma być uaktywnione. Może przybierać poniższe wartości:

Konsola - okno Konsoli AsAudit

Parametr: Notatka

Identyfikator segmentu - identyfikator zdefiniowany w Konfiguratorze programu AsAudit; służy do identyfikowania notatek skojarzonych z danym segmentem

Parametr: Login - aktywizuje okno Konsoli z otwartą sekcją logowania użytkowników

Konfigurator - okno Konfiguratora AsAudit

Przeglądarka - okno Przeglądarki AsAudit

Parametr: Notatka

Identyfikator segmentu - identyfikator zdefiniowany w Konfiguratorze programu AsAudit; służy do identyfikowania notatek skojarzonych z danym segmentem

Składnia akcji definiowana ręcznie:

ASAUDIT rodzaj_okna,parametry_okna

gdzie:

ASAUDIT - stały element deklaracji; można go zastąpić skrótem ASW;

Parametr rodzaj_okna

Znaczenie - pozwala na wybór okna, które ma być uaktywnione. Może przybierać poniższe wartości:

KONSOLA, CONSOLE - okno Konsoli AsAudit

KONFIGURATOR, CONFIG - okno Konfiguratora AsAudit

PRZEGLĄDARKA, BROWSER - okno Przeglądarki AsAudit

Typ - tekst.

Parametr parametry_okna

Notatka [,id_segmentu] - parametr dodany do okna Konsola powoduje otwarcie konsoli z przełączeniem na zakładkę notatek i preselekcją segmentu.

- parametr dodany do okna Przeglądarka powoduje otwarcie przeglądarki z przełączeniem na zakładkę notatek i ustawionym filtrem segmentu i flagi aktywności.

LOGIN - parametr dodany do okna Konsola aktywizuje okno Konsoli z otwartą sekcją logowania użytkowników

Dodatkowe wsparcie to ustawianie flag obecności aktywnych notatek w segmencie w zmiennych procesowych __id_segmentu__.

Mechanizm tez jest włączany, jeżeli użytkownik zdefiniuje odpowiednie zmienne (patrz: 2.2.5. Monitorowanie aktywnych notatek w segmencie).

W przypadku aktywizacji okien Konfiguratora i Przeglądarki, jeżeli te programy nie były wcześniej uruchomione, to zostaną one wystartowane przez akcję ASAUDIT.

Użycie Konsoli AsAudit zmienia także działanie innych akcji operatorskich związanych z obsługą haseł i użytkowników – akcje są blokowane lub powodują otwarcie okna Konsoli.