1 AsComm

Program AsComm służy do zarządzania i monitorowania połączeń dokonywanych przez moduły systemu asix. Połączenia nawiązywane są za pomocą portów szeregowych lub modemów (np. linie komutowane). Podstawowymi elementami zarządzanymi przez program AsComm są „Klient" i „Zasób". Klientem jest moduł systemu asix wykorzystujący funkcje programu AsComm. Klient identyfikowany jest poprzez jego nazwę. Zasobem jest łącze komunikacyjne takie jak port szeregowy lub modem. Za pośrednictwem programu AsComm „klienci" mogą korzystać z „zasobów" do nawiązywania połączeń. Z pojedynczego zasobu może korzystać wielu klientów. Jednym z zadań programu AsComm jest umożliwienie współdzielenia pojedynczego łącza pomiędzy wielu klientów. Sposób przydziału zasobów oraz realizacji pozostałych funkcji jest określony poprzez odpowiednią parametryzację pliku inicjalizacyjnego.

Niniejszy opis programu AsComm nie obejmuje konfiguracji modemu.


2.2 Okno informacji o kliencie

Poniżej pokazano okno informacji o kliencie.

Rysunek: Okno informacji o kliencie.

Okno informacji o kliencie zawiera następujące informacje:

  • czas instalacji i usunięcia klienta

  • zasób z którego korzysta klient

  • priorytet klienta

  • aktualny stan połączenia

  • ilość dotychczas nawiązanych połączeń

  • ilość nieudanych prób nawiązania połączenia

  • średni czas trwania połączenia

  • całkowity czas trwania wszystkich połączeń

  • parametry określające sposób nawiązywania połączeń

Okno informacji o kliencie posiada przycisk Zmień, który powoduje otwarcie okna zmian parametrów nawiązywania połączeń:

Rysunek: Okno zmian parametrów nawiązywania polaczeń.

Oprócz parametrów nawiązywania połączeń, okno to zwiera pole wyboru Rozłącz w razie potrzeby, które spowoduje rozłączenie połączenia, jeśli z nowo wprowadzonych parametrów wynika, że nie powinno być ono w danej chwili nawiązane. Jeśli pole nie jest zaznaczone, to zmiana parametrów nie powoduje rozłączenia aktualnego połączenia. Nowe parametry obowiązują do czasu zakończenia programu lub do czasu następnej zmiany. Po ponownym uruchomieniu programu AsComm nastąpi przywrócenie parametrów zawartych w pliku inicjalizacyjnym.


2.3 Okno informacji o zasobie

Okno informacji o zasobie zawiera podstawowe informacje o zasobie:

Rysunek: Okno informacji o zasobie.

Okno zawiera między innymi:

  • czas zainstalowania zasobu i czas jego usunięcia

  • nazwa klienta posiadającego nawiązane połączenie za pośrednictwem tego zasobu

  • ilość dotychczas pomyślnie nawiązanych połączeń

  • średni czas trwania połączenia

  • całkowity czas trwania wszystkich połączeń

  • parametry określające sposób nawiązywania połączeń

Okno informacji o kliencie posiada przycisk Zmień, który powoduje otwarcie okna zmian parametrów nawiązywania połączeń:

Rysunek: Okno informacji o kliencie.


2.4 Okno historii

Okno zawiera listę istotnych zdarzeń w pracy programu AsComm. Podana jest nazwa obiektu (klient, zasób) którego dotyczy zdarzenie, jego opis i czas wystąpienia.

Rysunek: Okno istotnych zdarzeń w pracy programu AsComm.


3 Parametryzacja programu AsComm

W systemie asix5 parametry programu AsComm deklarowane w pliku konfiguracyjnym aplikacji przy użyciu modułu Architekt.

Opcje (inaczej pozycje) umieszczane są z poziomu zakładki Opcje wprowadzane bezpośrednio:

Architekt > Obszary i komputery > moduł Pozostałe

Parametry ogólne umieszcza się w sekcji [ASCOMM]. Parametry dotyczące zasobu umieszcza się w sekcji o nazwie takiej samej jak nazwa zasobu. Parametry dotyczące sposobu nawiązywania połączenia na rzecz klienta i inne parametry związane z klientem umieszcza się w sekcji o nazwie takiej samej jak nazwa klienta.

Parametry których wartością jest czas mogą być liczbą bez jednostki lub ciągiem wartości numerycznych zakończonych jednoliterowym kodem jednostki:

d – dzień

h – godzina

g – godzina

m – minuta

s – sekunda

ms – milisekunda

Jeśli nie podano jednostki to przyjmowana jest sekunda. Np. 1g 20m 30s 4ms.

Tabela: Parametry ogólne.

Nazwa

Opis

Wartość domyślna

Blokada_Końca

Zabrania zamykać program AsComm przez operatora. Jeśli parametr nie jest obecny w sekcji [AsComm], to jest brany pod uwagę parametr o takiej samej nazwie z sekcji [START].

Dopuszczalne wartości: Tak, Nie lub hasło wymagane do zamknięcia programu (obowiązują parametry Kodowanie_Hasel i Czas_Waznosci sekcji [HASLA])

Nie

Blokada_Zmian

Zabrania dokonywania zmian parametrów w trakcie działania programu

Dopuszczalne wartości: Tak, Nie lub hasło wymagane do modyfikacji parametrów (obowiązują parametry Kodowanie_Hasel i Czas_Waznosci sekcji [HASLA])

Nie

Maksymalne_okno_historii

Określa maksymalną ilość elementów okna historii zdarzeń

5000

Maks_historia

Określa maksymalną ilość elementów historii zdarzeń

5000

Minimalizuj

Określa czy główne okno programu ma zostać otwarte w postaci zminimalizowanej

Dopuszczalne wartości: Tak, Nie

Tak

Nie_zamykaj

Jeśli podano Tak, to program AsComm nie zakończy się nawet jeśli zakończyła prace aplikacja, która z niego korzysta (asix).

Program AsComm nie zostanie zamknięty również wtedy, gdy w czasie pracy był wykorzystywany w postaci nie zminimalizowanej.

Dopuszczalne wartości: Tak, Nie

Nie

Log

Określa nazwę pliku w którym zapisywane są informacje diagnostyczne

brak

Parametry określające sposób udostępniania zasobu są umieszczane w sekcji o nazwie takiej samej jak nazwa klienta.

Tabela: Parametry określające sposób udostępniania zasobu.

Nazwa | Opis | Wartość domyślna
Baud | Szybkość transmisji | 9600
bity_stopu | Ilość bitów stop | 1
Com | Numer portu szeregowego | Brak
Czas_Rozłączenia | Czas rozwiązywania połączenia | 500 ms
Długość_słowa | Długość słowa | 8
Dokładność | Dokładność wyznaczania początku połączenia | 5000ms
Interval | Czasokres nawiązywania połączeń dla połączeń cyklicznych Nowe połączenie jest nawiązywane wtedy, gdy czas jaki upłynął od zakończenia poprzedniego połączenia jest większy od czasu określonego parametrem Interval. | Brak
Linia_Komutowana | Określa czy wykorzystywane jest połączenie modemowe. Dopuszczalne wartości: Tak, Nie | Nie
Maks_Czas_Połączenia | Określam maksymalny czas trwania połączenia. Jeśli parametr Maks_Czas_Połączenia jest również podany dla zasobu to brana jest pod uwagę mniejsza z podanych wartości. | Brak
Min_Czas_Między_Połącz | Minimalny odstęp czasu pomiędzy połączeniami. Jeśli parametr Czas_Między_Połączeniami jest również podany dla zasobu to brana jest pod uwagę większa z podanych wartości. | 0
Min_Czas_Połączenia | Minimalny czas trwania połączenia. Parametr pozwala określić minimalny czas trwania połączenia wymagany przez klienta. Jeśli z nawiązanego połączenia korzysta wielu klientów, określony jest parametr Maks_Czas_Połączenia i do rozwiązania połączenia pozostało mniej czasu niż jest to określone parametrem Min_Czas_Połączenia, to klient nie otrzyma przydziału. | Brak
Modem | Nazwa modemu jeśli do połączeń jest wykorzystywane łącze modemowe. Można podać tylko początkowy fragment nazwy modemu. | Brak
Numer | Numer telefoniczny. Parametr ma znaczenie tylko wtedy, gdy parametr Linia_Komutowana ma wartość „Tak". | Brak
Parzystość | Rodzaj kontroli parzystości | N
Port | Numer portu szeregowego. Numer portu można poprzedzić łańcuchem COM tj, Port = 2 i Port = Com2 są poprawne i oznaczają ten sam port. | Brak
Powtórzenia | Ilość powtórzeń nieudanych transmisji | 3
Priorytet | Priorytet klienta | 0
Timeout | Timeout oczekiwania na odpowiedź | Brak
Wyrównanie | Określa wyrównanie czasu dla połączeń nawiązywanych cyklicznie. Dopuszczalne wartości: Tak, Nie lub wartość określająca przesunięcie czasowe w stosunku do czasu, który jest wielokrotnością interwału. Np. jeśli interwał wynosi 1g, a parametr Wyrównanie ma wartość 15m to połączenia będą nawiązywane o godz.: 12:15:00, 01:15:00 itd. | Brak

Należy zauważyć, że klient korzystający z połączenia może sam określić parametry transmisji takie jak szybkość, bity danych, parzystość, timeout itp. Ustawienia dotyczące transmisji określone bezpośrednio przez klienta mają priorytet w stosunku do ustawień określonych powyższymi zapisami.

Parametry zasobu umieszcza się w sekcji o nazwie takiej samej jak nazwa zasobu.

Tabela: Parametry zasobu.

Nazwa | Opis | Wartość domyślna
Maks_Czas_Połączenia | Jeśli parametr Maks_Czas_Połączenia jest również podany dla klienta to brana jest pod uwagę mniejsza z podanych wartości. | Brak
Min_Czas_Między_Połącz | Minimalny odstęp czasu pomiędzy połączeniami. Jeśli parametr Czas_Między_Połączeniami jest również podany dla klienta to brana jest pod uwagę większa z podanych wartości. Parametr może być użyteczny w przypadku współdzielenia linii komutowanej przez modem i inne urządzenia (np. telefon), umożliwiając tym urządzeniom skorzystanie z linii komutowanej. | 0


4 Instalacja i deinstalacja programu AsComm

Aby zainstalować program AsComm należy przekopiować go do wybranego katalogu oraz uruchomić podając opcję /Regserver:

AsComm /regserver

Programy użytkowe korzystające z programu AsComm, muszą mieć dostęp do biblioteki AsCommcl.dll

W celu deinstalacji należy wykonać komendę:

AsComm /unregserver


1.1 Przydział zasobów

Dany zasób może być przydzielony klientowi wtedy, gdy klient żąda takiego przydziału oraz spełnione są inne warunki określone parametrami przydziału zawartymi w pliku inicjalizacyjnym. Parametry te mogą określać czas w jakim zasób jest przydzielany klientowi, czasokres trwania takiego przydziału i in. Z przydziałem danego zasobu mogą wiązać się dodatkowe czynności jak np. nawiązanie połączenia za pomocą linii komutowanej.


1.2 Współdzielenie zasobów

Zasoby są przydzielane klientom na ich żądanie. Do rozwiązywania konfliktów dostępu do zasobu jest wykorzystywana zasada priorytetów. Każdy klient może mieć przyporządkowaną liczbę, która określa jego priorytet. Jeśli w chwili otrzymania żądania zasób jest już zajęty przez innego klienta o niższym priorytecie, to program AsComm przekazuje dany zasób klientowi o wyższym priorytecie. Z przekazaniem zasobu może wiązać się rozwiązanie istniejącego połączenia. W zależności od parametryzacji, rozwiązanie połączenie może być poprzedzone zwłoką czasową. Zwłoka może również poprzedzać nawiązanie nowego połączenia.


2.1 Okno główne

Poniżej pokazano główne okno programu.

Rysunek: Okno główne programu AsComm.

Okno główne składa się z trzech podokien:

  • okno klienta

  • okno zasobu

  • okno komunikatów

Okno klienta pokazuje listę klientów, oraz powiązanych z nimi zasobów. Nazwa klienta poprzedzona jest znacznikiem określającym stan połączenia:

- klient nie jest połączony

- trwa rozłączanie

- klient żąda nawiązania połączenia

- trwa nawiązywanie połączenia

- klient jest połączony

Okno zasobów jest listą zwierającą wszystkie zasoby zarządzane przez program AsComm.

Do okna komunikatów wyprowadzane są komunikaty informujące o zdarzeniach w programie AsComm.

Wybranie pozycji w oknie klientów i podwójne kliknięcie myszki lub wybranie pozycji Szczegóły w głównym menu programu powoduje otwarcie okna informacyjnego klienta.

Wybranie pozycji w oknie zasobów i podwójne kliknięcie myszki lub wybranie pozycji Szczegóły w głównym menu programu powoduje otwarcie okna informacyjnego zasobu.

Wybranie pozycji Historia powoduje otwarcie okna historii zdarzeń.


2 Interfejs użytkownika


5 Współdziałanie drajwera MODBUS z programem AsComm

Drajwer MODBUS w wersji 1.9.1 lub wyższej przygotowany jest do współpracy z programem AsComm.

Parametryzacja drajwera MODBUS opisana jest w podręczniku Drajwery Komunikacyjne.

Kanał drajwera MODBUS jest klientem serwera AsComm o nazwie MODBUS:n, gdzie n jest numerem portu szeregowego pobranym z definicji kanału ASMENa.

Jeśli deklaracja kanału wg drajwera MODBUS wygląda następująco:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MODBUS

Identyfikator urządzenia (slave id): 4

Port: COM3

to nazwą klienta będzie MODBUS:3.

Aby protokół MODBUS nawiązywał połączenia na łączach komutowanych za pośrednictwem programu AsComm, należy w parametrach kanału wykorzystującego drajwer Modbus (kanału zadeklarowanego w module Dane bieżące programu Architekt) - na zakładce Klient serwera AsComm włączyć parametr Linia komutowana.

Jeśli modem jest przyłączony do innego portu niż COMn, to należy podać numer tego portu za pomocą parametru Port lub określić nazwę modemu za pomocą parametru Nazwa. Należy również podać numer telefoniczny oraz określić inne wymagane parametry. Jeśli drajwer MODBUS ma komunikować się z wieloma sterownikami za pomocą tego samego modemu, to należy zdefiniować odpowiednią ilość kanałów traktując parametr port jako nazwę wirtualną kanału transmisji, oraz dla każdego kanału określić odpowiedni numer telefoniczny.

PRZYKŁAD

Deklaracje kanałów:

Nazwa: Kanal1

Drajwer: MODBUS

Identyfikator urządzenia: 1

Port: COM11

Prędkość transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: none

Liczba bitów stopu: 1

Maksymalna liczba we/wy: 16

Maksymalna liczba rejestrów: 16

Deklaracja Kanału 'Kanal1' jako klienta serwera AsComm:

Linia komutowana / Używaj modemu do nawiązania połączenia – załączona

Nazwa modemu: US Robotics

Numer telefonu: 11111111

Nazwa: Kanal2

Drajwer: MODBUS

Identyfikator urządzenia: 1

Port: COM12

Prędkośc transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: none

Liczba bitów stopu: 1

Maksymalna liczba we/wy: 16

Maksymalna liczba rejestrów: 16

Deklaracja Kanału 'Kanal2' jako klienta serwera AsComm:

Linia komutowana / Używaj modemu do nawiązania połączenia – załączona

Nazwa modemu: US Robotics

Numer telefonu: 22222222

W powyższym przykładzie 'Kanal1' będzie komunikował się ze sterownikiem znajdującym się pod numerem telefonicznym 11111111, a 'Kanal2' ze sterownikiem znajdującym się pod numerem telefonicznym 22222222. Zostanie wykorzystany modem US Robotics. Parametr Modem można zastąpić parametrem Port określającym numer portu szeregowego, do którego przyłączony jest modem.

Należy zwrócić uwagę, że powyższy opis wykorzystania drajwera MODBUS na łączach komutowanych nie obejmuje parametryzacji modemu. Parametryzacja modemu zależy od typów wykorzystywanych modemów.

W czasie testów został wykorzystany modem „Zyxel OMNI 288S” (po stronie sterownika) oraz modem „Pentagram Shadow 56K” po stronie systemu asix. Została przeprowadzona następująca parametryzacja modemów:

  • Modem po stronie sterownika został ustawiony w tryb „Auto answer” i odpowiadał na zdalne wywołanie po usłyszeniu jednego dzwonka

  • Modem po stronie sterownika został ustawiony w ten sposób, że transmisja pomiędzy modemem a sterownikiem odbywała się zawsze przy szybkości 9600 bps

  • Modem po stronie sterownika został ustawiony w ten sposób, że wykorzystywana była zawsze modulacja V32 9600

  • Maksymalna szybkość transmisji pomiędzy systemem asix a modemem została ograniczona do 9600 bps (ustawienia modemu w systemie Windows)

  • Po stronie systemu asix została wyłączona sprzętowa kompresja (ustawienia modemu w systemie Windows)

  • Parametry transmisji drajwera MODBUS zostały ustawione na 9600,8,none,1 (w sekcji [ASMEN] pliku inicjalizacyjnego aplikacji systemu asix)


Wstęp

>> Pomoc dla użytkowników systemu asix - wersji 6

www.asix.com.pl

AsComm -

Zarządzania i monitorowania połączeń dokonywanych przez moduły systemu asix za pomocą portów szeregowych lub modemów

Dok. Nr PLH6016

Wersja: 23-01-2010