Rodzaje agregatów danych archiwalnych

W każdym przypadku, w którym w aplikacji wymagany jest dostęp do zagregowanych danych historycznych konieczne jest podanie nazwy agregatu. Dotyczy to obiektu Wykres, funkcji HorizonAggregate i RangeAggregate, interfejsów modelu skryptowego.

Nazwa | Znaczenie
none | brak agregacji
start | Wartość na początku interwału.
end | Wartość na końcu interwału.
delta | Różnica wartości na końcu i na początku interwału.
min | Minimalna wartość w interwale.
max | Maksymalna wartość w interwale.
range | Różnica między maksymalna a minimalna wartością w interwale.
total | Suma wartości ważonych czasowo w interwale (całka po czasie).
average | Średnia wartości ważonych czasowo w interwale.
average0 | Średnia wartości ważonych czasowo w interwale. W okresach, w których wartość jest niedostępna do obliczeń, używana jest wartość 0.
sumup | Suma wartości dodatnich zmian, od ostatniej znanej wartości przed rozpoczęciem, do ostatniej wartości przed końcem przedziału próbkowania.
sumdown | Suma wartości bezwzględnych ujemnych zmian, od ostatniej znanej wartości przed rozpoczęciem, do ostatniej wartości przed końcem przedziału próbkowania.
prevknown | Ostatnio znana (dobra lub niepewna) wartość przed rozpoczęciem przedziału próbkowania. Podaje ostatnią wartość, nawet jeżeli wystąpiła ona bardzo dawno.
last | Ostatnio znana (dobra lub niepewna) wartość w przedziale próbkowania wyłączając koniec przedziału - dla odróżnienia od agregatu end, który zawiera koniec przedziału.
stdev | Ważone czasowo odchylenie standardowe w przedziale próbkowania.
rms | Ważona czasowo średnia kwadratowa w przedziale próbkowania.
avglk | Średnia ważona czasowo w przedziale próbkowania. W miejsce złych lub brakujących wartości wstawia ostatnią znaną wartość.
totallk | Całka w przedziale próbkowania, przy czasie liczonym w sekundach. W miejsce złych lub brakujących wartości wstawia ostatnią znaną wartość.

Szczegółowy opis agregatów oraz ich parametryzacji znajduje się w dokumentacji modułu archiwizacji Aspad (podręcznik Asix.PDF/CHM).