Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 7

www.asix.com.pl

Asix.Evo - System alarmów

Dok. Nr PLH7E008

Wersja: 2013-12-13


1 Podstawowe pojęcia

System Asix.Evo posiada wbudowany elastyczny, konfigurowalny system obsługi alarmów, który pozwala na pełne zaspokojenie potrzeb związanych z kompleksową obsługą sytuacji awaryjnych i zdarzeń w procesie technologicznym.

System alarmów Asix.Evo jest zorganizowany w tzw. domeny. Domena identyfikowana jest przez nazwę i w praktyce stanowi w pełni funkcjonalny i niezależny od innych domen samodzielny system. Domeny pozwalają na logiczny i funkcjonalny podział alarmów na pewne niezależne obszary. W typowym zastosowaniu, w aplikacji stosowana jest pojedyncza domena , służąca do obsługi wszystkich alarmów aplikacji. W bardziej złożonych przypadkach, w których aplikacja obsługuje wiele niezależnych instalacji, może być przydatne rozdzielenie alarmów na kilka domen.

Uwaga:

W aplikacjach Asix, domenie odpowiadała bezpośrednio tzw. nazwa sieciowa zasobu alarmowego. Podstawowa różnica, to możliwość użycia wielu, jednocześnie aktywnych domen Asix.Evo.

Stany alarmowe rozpoznawane są przy pomocy strategii wykrywania alarmów. Istnieją różne typy strategii, które wykrywają alarmy różnymi metodami.

Wykryte alarmy gromadzone są w dwóch logach:

  • Log alarmów aktywnych

Przechowuje informacje o wszystkich aktualnie aktywnych alarmach. Przy odpowiedniej parametryzacje może też posiadać informacje dotyczące alarmów niedawno zakończonych.

  • Log alarmów historycznych

Przechowuje długoterminowo informacje o wszystkich wykrytych alarmach.

Zarejestrowane alarmy mogą być przeglądane przy pomocy tabel alarmów aktywnych i historycznych. Stan alarmów aktywnych może być także prezentowany bezpośrednio na diagramach synoptycznych.

W przypadku aplikacji wykorzystujących wiele stanowisk Asix.Evo, stan systemu alarmów jest synchronizowany pomiędzy tymi stanowiskami. Stanowiska rozpoczynające pracę uzgadniają stan alarmów aktywnych oraz uzupełniają archiwum alarmów historycznych. Obsługa alarmów przez operatora jest także synchronizowana, np. potwierdzenie alarmu na jednym stanowisku jest natychmiast widoczne na stanowiskach pozostałych.

Alarmy w aplikacji Asix.Evo identyfikowane są przez nazwę. Wszystkie parametry alarmu (opis, kategoria, metoda wykrywania, itp.) są przechowywane w bazie definicji alarmów. Możliwe jest importowanie definicji z arkuszy programu Excel.


2 Parametryzacja systemu alarmów

Parametryzacja systemu alarmów wykonywana jest w panelu Konfiguracja systemu alarmów otwieranym poprzez wybór węzła System alarmów w panelu Eksplorator aplikacji.

Panel konfiguracyjny składa się dwóch części. Lewa służy do tworzenia i wyboru domen. W prawej części, w przełączanych zakładkach wykonywana jest parametryzacja domeny. Poszczególne zakładki pozwalają na:

  • Stanowiska

Określenie roli pełnionej w systemie alarmów przez poszczególne stanowiska zdefiniowane w aplikacji.

  • Strategie

Definiowanie strategii wykrywania alarmów.

  • Alarmy

Definiowanie alarmów domeny.

  • Ustawienia

Parametryzowanie różnych elementów domeny, np. sposobu pracy logów alarmów.

  • Źródła

Określenie źródeł definicji alarmów (arkuszy programu Excel) oraz wykonywanie importu definicji z tych źródeł.


3 Role stanowisk

Każde ze stanowisk uczestniczących w pracy domeny pełni w nim określoną rolę. Stanowiska mogą pełnić jedną z następujących ról:

  • Kontroler

Stanowisko uczestniczy aktywnie w obsłudze alarmów. Kontrolery odpowiedzialne są za wykrywanie alarmów oraz przesyłanie informacji o stanie alarmów pomiędzy stanowiskami. W każdej domenie musi być przynajmniej jedno stanowisko kontrolera. W celu zapewnienia redundancji można stosować większą liczbę kontrolerów. W tym przypadku, w trakcie pracy następuje automatyczne wybranie tzw. kontrolera aktywnego. Pozostałe stanowiska kontrolerów przechodzą chwilowo w tryb pracy zbliżony do stanowisk terminalowych. Pozostają jednak w gotowości do przejęcia funkcji kontrolera aktywnego. Mogą też mieć uruchomione strategie wykrywania alarmów.

Każdy kontroler posiada priorytet. W sytuacji, gdy dochodzi do uzgodnienia kontrolera aktywnego, jeżeli jest to możliwe, wybierany jest kontroler o najwyższym priorytecie.

  • Terminal

Stanowiska terminali służą jedynie do pokazywania stanu alarmów i obsługi operatorskiej. Terminal nie może działać samodzielnie, musi być podłączony do kontrolera. Połączenie może być bezpośrednie lub za pomocą pomostu. W tym drugim przypadku, w parametryzacji stanowiska, w kolumnie Pomosty, należy podać nazwy stanowisk pomostowych. Jeżeli dla danego terminala nie wskazano pomostów, to będzie on się łączyć tylko z aktywnym kontrolerem domeny.

  • Pomost

Funkcjonalność dotycząca obsługi alarmów jest identyczna jak w przypadku terminali. Pomost dodatkowo może służyć jako pośrednik w wymianie danych pomiędzy stanowiskami terminali, a kontrolerem. Pomosty stosuje się wtedy, gdy terminale znajdują się w innej sieci niż stanowiska kontrolerów. Innym zastosowaniem jest użycie pomostu w celu redukcji obciążenia kontrolerów (w szczególności, gdy liczba terminali jest duża).

  • Brak

Jeżeli żadna rola nie została wybrana, to stanowisko nie uczestniczy w pracy domeny i nie ma dostępu do alarmów domeny.

W najprostszym przypadku aplikacja może składać się z pojedynczego stanowiska pełniącego rolę kontrolera domeny. Poniższy schemat pokazuje konfigurację z dwoma redundantnymi kontrolerami. Jeden terminal pobiera dane o alarmach bezpośrednio z kontrolerów. Dwa inne terminale znajdujące się w sieci, która nie ma bezpośredniego kontaktu z kontrolerami, wykorzystują stanowisko pełniące rolę pomostu.

Pewne ograniczenia na możliwe role w systemie alarmów narzuca rola stanowiska w systemie komunikacyjnym. Kontrolerem lub pomostem może być jedynie stanowisko, które jest serwerem komunikacyjnym.


4 Baza definicji alarmów

Wszystkie alarmy używane w aplikacji Asix.Evo muszą zostać wcześniej zdefiniowane. Służy do tego tabela alarmów w zakładce Alarmy.


4.1 Atrybuty

Definicja alarmu składa się z zestawu atrybutu. Znaczenie poszczególnych atrybutów wyjaśnia poniższa tabelka.

Nazwa

Znaczenie

Identyfikator

Tekstowy identyfikator alarmu

Typ

Priorytet alarmy określający ważność alarmu. Możliwe są poniższe priorytety (w kolejności malejącej ważności):

  • Krytyczny

  • Pilny

  • Alarm

  • Ostrzeżenie

  • Komunikat

Alarmy o różnych priorytetach wyświetlane są na tabelach alarmów różnymi kolorami. Alarmy krytyczne i pilne są wymagają selektywnego potwierdzania.

Kategoria

Określa kategorię alarmu. Dostępne są dwie kategorie: alarmy zwykły i powiadomienie. Powiadomienie różni się od alarmu zwykłego tym, że wykrywane jest dla niego tylko zdarzenie początku. Powiadomienia nie maja końców.

Strategia

Określa nazwę strategii używanej do wykrywania alarmu. Sposób parametryzacji strategii wykrywania znajduje się osobnym rozdziale.

Parametry wykrywania

Określa parametry służące do wykrywania alarmu. Postać atrybutu zależy od typu użytej strategii. Sposób parametryzacji strategii wykrywania znajduje się osobnym rozdziale.

Tekst początku

Określa tekst opisujący zdarzenie początku alarmu. Sposób tworzenia tekstu i jego użycia opisuje osobny rozdział.

Tekst końca

Określa opcjonalny tekst opisujący zdarzenie zakończenia alarmu. Jeżeli tekst nie jest zdefiniowany, to koniec alarmu jest opisywany w identyczny sposób jak początek. Sposób tworzenia tekstu i jego użycia opisuje osobny rozdział.

Formatowanie parametrów

W momencie wykrycia alarmu strategia alarmowa może przekazać razem ze zgłoszeniem alarmu pewną ilość dodatkowych parametrów wykrycia. Zestaw i znaczenie parametrów jest specyficzne dla konkretnego typu strategii. W momencie zgłoszenia wartości parametrów są konwertowane na postać tekstową. Atrybut Formatowanie parametrów pozwala kontrolować tą konwersję. Atrybut jest kolekcją tekstów formatujących, kolejne elementy służą do formatowania kolejnych parametrów wykrycia. Postać tekstu formatującego jest następująca:

[-]Szerokość:Format

Szerokość określa minimalną szerokość wygenerowanego tekstu. W razie konieczności tekst uzupełniany jest spacjami. Opcjonalny znak minusa oznacza wyrównanie pola do lewej strony. Format określa sposób konwersji w sposób zgodny z przyjętym w platformie .NET.

Przykład:

0:f3

Konwersja na format zmiennoprzecinkowy z trzema cyframi ułamkowymi. Długość tekstu wynika z wartości konwertowanego parametru.

6:d

Konwersja na liczbę całkowitą. Pole będzie miało minimalnie 6 znaków, a liczna będzie wyrównana do prawej strony.

Wyrażenie

Określa wyrażenie, którego wartość w momencie początku i końca alarmu jest rejestrowana w logu. Wartość wyrażenia może być wyświetlona w treści tekstu początku lub końca alarmu. Jest również pokazywana w okienku informacyjnym alarmu dostępnym poprzez przyciski tabel alarmów.

Akcja

Określa akcję skojarzoną z alarmem. Operator może uruchomić tą akcję przyciskiem dostępnym w tabeli alarmów aktywnych.

Bit wykluczenia

Służy do deklaracji bitu zmiennej procesowej, którego stan 0/1 będzie odzwierciedlał aktualny stan wykluczenia alarmu. Mechanizm pozwala na przekazanie do sterownika PLC informacji o wykluczeniu – w efekcie tego sterownik może np. nie generować ostrzegawczych sygnałów dźwiękowych dla alarm wykluczonego.

Atrybut ma postać nazwa_zmiennej.numer_bitu. Najmłodszy bit zmiennej ma numer 0.

Dźwięk

Określa nazwę dźwięku, które należy odtworzyć w momencie wystąpienia alarmu.

Powtarzanie dźwięku

Określa czy dźwięk sygnalizujący wystąpienie alarmu ma być powtarzany aż do momentu wykonania przez operatora funkcji wyciszenia dźwięku. Wyciszyć sygnał można przyciskiem w tabeli alarmów aktywnych lub przy pomocy akcji operatorskiej StopSound.

Tryb alertów

Określa czy alarm ma być sygnalizowany przy pomocy sms’ów lub email’i za pośrednictwem programu Alerter. Sposób użycia Alertera opisuje osobny rozdział.

Adresaci alertów

Określa adresatów, do których należy wysłać powiadomienie za pośrednictwem programu Alerter. Sposób użycia Alertera opisuje osobny rozdział.

Atrybuty grupowania

Nazwy i ilość atrybut grupujących jest określana przez projektanta aplikacji. Zasady grupowania opisuje osobny rozdział.


4.2 Teksty opisu alarmów

Definicja alarmu zawiera dwa teksty opisujące alarm – tekst dla zdarzenia początku oraz tekst dla zdarzenia końca. Tekst końca jest opcjonalny. Teksty alarmów używane są w obiektach tabel alarmów. Projektant aplikacji wybiera, które teksty należy wyświetlić w linii alarmów. Do wyboru jest także opcja, w której wyświetlana jest tylko jedna kolumna tekstu, ale jej zawartość jest określana w sposób kontekstowy. Jeżeli zdarzenie dotyczy początku alarmu, to wyświetlany jest tekst początku. Jeżeli zdarzenie dotyczy końca alarmu, to wyświetlany jest tekst końca (o ile został zdefiniowany).

W tekście alarmu można umieścić dodatkowe informacje. Może to być wartość wyrażenia określona w atrybucie Wyrażenie, lub wartości parametrów wykrycia alarmu (zgłaszane przez strategię alarmową, skrypty lub akcje operatorskie). Aby wstawić te dodatkowe informacje do tekstu alarmu należy wstawić do tekstu znaczniki postaci {numer}. Numer 0 oznacza wstawienie wartości wyrażenia podanego w atrybucie Wyrażenie. Numery od 1 w górę, oznaczają kolejne parametry wykrycia alarmu.

Przykład:

Przekroczony limit {2}, wartość {1}, stan maszyny {0}

Stan maszyny pobierany jest z atrybutu Wyrażenie, a limit oraz wartość pochodzą ze zgłoszenia alarmu (np. w skrypcie użytkownika).

W tekście alarmów nie można używać dodatkowego formatowania wstawianych elementów. Wynika to z faktu, że zarówno wyrażenie, jak i parametry wykrycia są konwertowane na tekst już w momencie zgłoszenia alarmu, a tekst alarmu używany jest tylko w momencie jego wyświetlenia. Jeżeli konieczna jest konwersja inna niż domyślna, to w przypadku parametrów wykrycia należy odpowiednio zdefiniować atrybut Formatowanie parametrów, a w przypadku wyrażenia zapewnić właściwą konwersję już w samym wyrażeniu (np. przy pomocy funkcji Format).


4.3 Grupy alarmów

System alarmów Asix.Evo posiada elastyczny mechanizm selekcji alarmów wykorzystujący tzw. atrybuty grupujące. Pierwszym krokiem w parametryzacji grupowania alarmów jest utworzenie zestawu atrybutów grupujących. Poniższy obrazek pokazuje fragment zakładki Ustawienia, w którym można dodać dowolną ilość atrybutów służących do grupowania. Każdy atrybut zdefiniowany jest przez identyfikatorem grupy oraz tekst opisowy. Identyfikator ma znaczenie tylko organizacyjne, tekst opisowy jest używany we wszystkich interfejsach użytkownika.

Po zdefiniowaniu atrybutów grupujących, definicje alarmów w zakładce Alarmy zostaną rozszerzone o dodatkowe kolumny.

Dla każdego alarmu należy podać wartości atrybutów grupujących. Alarmy o tej samej wartości atrybutu należą do tej samej grupy.

W trybie wykonania aplikacji użytkownik będzie mógł wybierać alarmy pokazywane w tabeli alarmów historycznych wykorzystując zdefiniowane wcześniej grupy. Po użyciu przycisku Kryteria selekcji otwarte zostanie okienko, w którym użytkownik może wybrać pokazywane grupy.

Powyższy przykład należy interpretować następująco: pokazane zostaną alarmy, których atrybut Strefa jest równy A lub B, a atrybut Rodzaj jest równy Elektryczna.


4.4 Import z arkuszy Excel

W przypadku aplikacji z większa ilością alarmów korzystne może okazać się definiowanie alarmów w arkuszach programu MS Excel i generowanie bazy definicji alarmów na ich podstawie.

Obsługę funkcji importu z arkuszu Ms Excel zapewnia zakładka Źródła.

Rys. Dostęp do funkcji import z arkusza MS Excel.

Można zdefiniować dowolną ilość arkuszy źródłowych. Po naciśnięciu przycisku Importuj alarmy i grupy ze źródeł baza definicji alarmów zostanie utworzona od nowa na podstawie aktualnej zawartości arkuszy.

Poniższy obrazek pokazuje przykładowy arkusz definicji alarmów.

Rys. Arkusz definicji alarmów.

Najprostszą metodą utworzenia poprawnego wzorca arkusza definicji alarmów jest użycie przycisku Utwórz pusty plik źródła Excela. Utworzony wzorzec będzie uwzględniał zdefiniowane języki aplikacji oraz dodane atrybuty grupujące.

Można też utworzyć plik Excela łącznie z wszystkimi aktualnie zdefiniowanymi alarmami, korzystając z przycisku Eksportuj alarmy i grupy do pliku Excela.

W przypadku, gdy aplikacja współpracuje z programem AsService, można użyć przycisk Generuj arkusz alarmów strategii AsService w celu utworzenia wzorcowego arkusza alarmów, zawierającego wstępne definicje alarmów dla strategii AsService. Arkusz będzie zawierał definicje alarmów dla wszystkich liczników zdefiniowanych w bazie danych programu AsService, które mają niezerowe wartości limitów eksploatacyjnych lub ostrzegawczych. Po uzupełnieniu o dodatkowe dane arkusz może służyć jako arkusz źródłowy funkcji importowania alarmów.


5 Strategie wykrywania alarmów

W każdej domenie alarmów można stosować dowolną ilość strategii wykrywania alarmów. Do parametryzowania strategii służy zakładka Strategie panelu parametryzacji systemu alarmów.

Strategię wykrywania alarmów, można przez analogię, traktować jak kanał komunikacyjny, którego efektem działania jest zgłaszanie alarmów. Każda strategia może pracować tylko na jednym kontrolerze (aktywnym lub pasywnym) w ramach domeny. O tym na którym kontrolerze ma zostać uruchomiona dana strategia decyduje zawsze aktywny kontroler. Każda strategia określona jest przez:

  • Nazwa strategii

Nazwa identyfikuje strategię. Alarmy, które w swojej definicji, w atrybucie Strategia mają podaną zgodną nazwę, są wykrywane przez tą strategię.

  • Typ strategii

Określa typ strategii, a co za tym idzie sposób wykrywania alarmów. Dostępne typy strategii zostały opisane w dalszej części dokumentacji.

  • Lista kontrolerów

Określa listę nazw stanowisk kontrolerów, na których można strategię uruchomić. Kontroler aktywny, jeżeli będzie miał zezwolenie, to uruchomi strategię na własnym stanowisku. Jeżeli nie, to wybierze jeden z wymienionych kontrolerów.

  • Flaga aktywności

Określa czy strategia ma być używana.

  • Inne parametry

W zależności od wybranego typu strategii może być wymagane ustawienie dodatkowych parametrów.


5.1 Strategia bitowa

Strategia bitowa przeznaczona jest do wykrywania alarmów na podstawie pojedynczego bitu określonej zmiennej procesowej.

Dla alarmów kontrolowanych przez strategię bitową, atrybut Parametry wykrywania w definicji alarmu musi mieć poniższą postać:

nazwa_zmiennej.nr_bitu[r]

, nazwa_zmiennej określa nazwę monitorowanej zmiennej procesowej, nr_bitu określa numer kontrolowanego bitu (najmłodszy bit ma numer 0), a opcjonalna litera r oznacza użycie odwrotnej logiki wykrywania (zmiana wartości bitu z 1 na 0 oznacza początek alarmu).

W ramach pojedynczej strategii można kontrolować stan wielu zmiennych procesowych. Nie ma ograniczenia na rozmiar kontrolowanych zmiennych.

Przykład:

al100.1r

Początek alarmu będzie wykrywany w momencie zmiany bitu numer 1 (maska bitowa 0x0002) zmiennej al100 z wartości 1 na 0.


5.2 Strategia warunkowa

Strategia warunkowa przeznaczona jest do wykrywania alarmów na podstawie monitorowania wartości dowolnego wyrażenia podanego jako parametr wykrywania alarmu.

Dla alarmów kontrolowanych przez strategię warunkową, atrybut Parametry wykrywania w definicji alarmu musi mieć postać wyrażenia arytmetycznego. Monitorowane wyrażenie powinno mieć wynik typu logicznego. Zmiana wartości wyrażenia z false na true oznacza rozpoczęcie alarmu, a zmiana odwrotna koniec alarmu.

W zestawie funkcji udostępnianych przez Asix.Evo znajdują się funkcje dedykowane specjalnie do użycia w strategii warunkowej:

  • DeadBand – kontrola przekraczania limitów z histerezą

  • DelayedState – wykrywanie braku przewidywanych zmian stanu procesu

  • RateOfChange – monitorowanie prędkości zmian wartości wyrażenia

Przykład:

Variable(Speed1)>1000 && (Variable(SMode)&1)

Alarm będzie aktywny, gdy zmienna Speed1 będzie miała wartość większą od 0 i najmłodszy bit zmiennej SMode będzie ustawiony.

DelayedState(Variable(MState)&0x100,15,Variable(MState)&0x200)

Alarm zostanie włączony wtedy, gdy po ustawieniu bitu numer 8 zmiennej MState, w ciągu 15 sekund nie dojdzie do ustawienie bitu numer 9.


Strategia OPC

5.3 Strategia OPC

W strategii alarmów OPC dane o alarmach odbierane są z niezależnego serwera alarmów OPC (ang. OPC Alarm and Event Server). Strategia pozwala zaimplementować w aplikacji systemu Asix sygnalizację alarmów pochodzących z innych systemów.

Parametr Adres serwera OPC służy do podania nazwy serwera OPC, z którego będą pobierane alarmy.

Dla poprawnego działania strategii istotne jest właściwe przemapowanie warunków i podwarunków alarmowych serwera OPC na identyfikatory alarmów systemu Asix. Sposób mapowania określony jest w atrybucie Parametry wykrywania definicji poszczególnych alarmów.


5.3 Strategia buforowa

5.4 Strategia buforowa

Strategia buforowa jest specjalną strategią, która pozwala na precyzyjne wykrywanie alarmów z rozdzielczością milisekundową i gwarancją zachowania sekwencji zdarzeń. Strategia wymaga jednak współpracy z oprogramowaniem sterownika. Sterownik odpowiedzialny jest za wykrywanie alarmów oraz nadawanie im czasów. Dokładny opis protokołu wymiany danych opisany jest w pliku pomocy systemu Asix 6.

Strategia buforowa wymaga podania dodatkowych parametrów, które związane z protokołem wymiany danych pomiędzy sterownikiem, a aplikacją Asix.Evo:

  • Zmienna buforowa – zmienna poprzez, którą są przekazywane informacje o stanie alarmów. Wartość zmiennej musi być tablicą 8- lub 16-bitowych liczb całkowitych bez znaku.

  • Zmienna synchronizująca – zmienna służącą do synchronizacji dostępu do bufora alarmów. Wartość zmiennej musi być 16-bitową liczbą całkowitą bez znaku.

  • Zmienna żądania mapy alarmów – zmienna poprzez, która Asix.Evo może zażądać przesłanie aktualnego stanu wszystkich alarmów. Wartość zmiennej musi być 16-bitową liczbą całkowitą bez znaku.

  • Format czasu – deklaracja w jaki sposób przekazywane są czasy alarmów: w czasie lokalnym czy w czasie UTC.

Dla alarmów kontrolowanych przez strategię buforową, atrybut Parametry wykrywania w definicji alarmu musi być numerem kolejnym alarmu w puli alarmów obsługiwanych przez strategię. Pierwszy alarm strategii ma numer 0.


5.4 Strategia Asix

5.5 Strategia Asix

Strategia Asix jest specjalna strategią, która pozwala przejąć alarmy z aplikacji Asix. Stosuje się ją w konfiguracjach, w których aplikacja Asix.Evo służy jako wersja przeglądarkowa aplikacji Asix.

Pierwszym krokiem w parametryzacji strategii jest skonfigurowanie aplikacji Asix w taki sposób, aby tworzyła ona plik eksportu alarmów. Wykonać to można przy pomocy programu Architekt z pakietu Asix, w zakładce konfiguracji archiwum alarmów typu SQL. Pokazuje to poniższy obrazek:

Istotne jest aby w kolumnie Nazwa serwera Microsoft SQL podać nazwę FILE.

Strategia Asix posiada jeden dodatkowy parametr Pliki źródeł alarmów. Należy w nim podać ścieżkę wskazującą na plik, do którego aplikacja Asix zapisuje zdarzenia alarmów. W przypadku podłączenia do aplikacji z redundantnymi serwerami alarmów, należy podać ścieżki do plików eksportowych wszystkich serwerów. Plik eksportowy tworzony jest katalogu logu alarmów aplikacji Asix. W przypadku pokazanym na obrazku prawidłowa nazwa to:

C:\AsixApp\Fabryka\Alarms\FILE_Fabryka.xml

Dodatkowym wymaganiem jest zgodność pomiędzy numerem alarmu w systemie Asix, a identyfikatorem alarmu w Asix.Evo, np. zgłoszenie alarmu numer 100 w Asix, powoduje w Asix.Evo zgłoszenie alarmu o identyfikatorze 100.


Strategia_AsRemont

5.6 Strategia AsService

Strategia AsService przeznaczona jest do wykrywania alarmów na podstawie aktualnego stanu liczników programu AsService. Strategia pozwala wykrywać przekroczenia limitów eksploatacyjnych lub ostrzegawczych wartości liczników.

Dla alarmów kontrolowanych przez strategię AsService, atrybut Parametry wykrywania w definicji alarmu musi mieć poniższą postać:

identyfikator_licznika.typ_limitu

- identyfikator_licznika określa identyfikator licznika zdefiniowanego w bazie danych programu AsService, a typ_limitu określa, przekroczenie którego limitu powoduje zgłoszenie alarmu. Możliwe są następujące wartość: E dla limitu eksploatacyjnego, W dla limitu ostrzegawczego lub W2 dla drugiego limitu ostrzegawczego.


Strategia Wago

5.7 Strategia Wago

Strategia Wago przeznaczona jest do obsługi alarmów zgłaszanych przez oprogramowanie sterowników WAGO. Stosowana jest w aplikacjach, które tworzone są przez kreatora aplikacji typu WAGO. W trakcie pracy kreator parametryzuje domenę alarmową, zakłada strategię oraz definiuje alarmy należące do strategii.

Atrybut Parametry wykrywania w definicji alarmów jest nazwą instancji struktury Wago. W praktyce jest to prefiks nazwy zmiennych stosowanych do rozpoznawania alarmów (prefiks_wError_Status i prefiks_xError).


5.5 Strategia zewnętrzna

5.8 Strategia zewnętrzna

Strategia zewnętrzna przeznaczona jest do obsługi alarmów, których zmiany stanu są zgłaszane przy pomocy akcji operatorskich StartAlarm i EndAlarm, lub poprzez skrypty przy pomocy funkcji Raise i Cancel interfejsu IAlarm. Strategia sama w sobie nie posiada żadnych metod wykrywania alarmów. Służy jako kontener dla alarmów zgłaszanych metodami zewnętrznymi. Pomimo tego, że strategia sama nie zgłasza alarmów, podlega normalnemu zarządzaniu przez kontroler aktywny. W danym momencie strategia jest aktywna tylko na jednym stanowisku – oznacza to, że jeżeli skrypt działający na różnych stanowiskach zgłosi wielokrotnie ten sam alarm, to zostanie on zaakceptowany tylko na jednym stanowisku (na którym strategia jest uruchomiona).


5.6 Globalna strategia zewnętrzna

5.9 Globalna strategia zewnętrzna

Globalna strategia zewnętrzna działa w sposób zbliżony do zwykłej strategii zewnętrznej. Strategia globalna nie jest nigdzie definiowana. Jest tworzona zawsze. Alarmy, które w swojej definicji nie mają podanej nazwy strategii są automatycznie przydzielane do domyślnej strategii zewnętrznej.

Jedyną różnicą w działaniu w stosunku do zwykłej strategii zewnętrznej jest brak kontroli aktywności. Strategia globalna jest zawsze aktywna – zgłoszenie alarmu należącego do niej jest zawsze akceptowane. Projektant aplikacji musi sam zapewnić, że zgłoszenia alarmu nie są duplikowane na różnych stanowiskach.


Obsługa alarmów zgłaszanych przez drajwery Asix6

6 Obsługa alarmów zgłaszanych przez drajwery komunikacyjne typu Asix6

Drajwery typu Asix6 w wyniku swojego działania mogą bezpośrednio zgłaszać alarmy. Typowym przykładem mogą być alarmy od braku komunikacji, ale pełny zestaw możliwości zależy od użytego drajwera Asmena.

W celu przejęcia alarmów tego typu należy:

a) Sparametryzować drajwery Asmena przy pomocy programu Architekt w sposób identyczny jak dla aplikacji typu klasycznego. W typowym przypadku parametryzacja polega na podaniu identyfikatora alarmu związanego z konkretnym zdarzeniem.

b) Zdefiniować alarmy o identyfikatorach użytych w trakcie parametryzacji drajwerów. Alarmy mogą być zdefiniowane w dowolnej domenie, ale należy zapewnić unikalność identyfikatorów alarmów w ramach wszystkich domen aplikacji. W momencie zgłoszenia alarmu, na podstawie identyfikatora zostanie określone, którą domenę alarmów należy użyć. Alarmy należy skojarzyć ze strategią typu zewnętrznego lub pozostawić atrybut strategii pusty, co oznacza użycie globalnej strategii zewnętrznej.

Strategię nazwaną należy używać wtedy, gdy w konfiguracji sieciowej te same alarmy mogą być zgłaszane przez różne stanowiska – alarmy będą przyjmowane wtedy tylko na jednym stanowisku.


6 Log alarmów aktywnych

7 Log alarmów aktywnych

Log alarmów aktywnych przechowuje informacje o wszystkich aktualnie rozpoczętych alarmach. W zależności od konfiguracji może też przechowywać informacje o alarmach niedawno zakończonych. Alarmy znajdujące się logu pokazywane są w tabelach alarmów aktywnych.

Tryb pracy logu alarmów aktywnych jest parametryzowany w pokazanym niżej fragmencie zakładki Ustawienia.

Możliwe tryby pracy opisuje poniższa tabela.

Tryb | Sposób pracy
Natychmiast | Alarm jest usuwany z logu natychmiast po zakończeniu, niezależnie od jakichkolwiek innych warunków. Należy zwrócić uwagę, że w tym trybie alarmy kategorii Powiadomienie nigdy nie znajdą się logu alarmów aktywnych, ponieważ taktowane są jako od razu zakończone.
Po potwierdzeniu | Zakończony alarm jest usuwany dopiero wtedy, gdy został potwierdzony przez operatora.
Po potwierdzeniu lub czasie | Zakończony alarm jest usuwany dopiero wtedy, gdy został potwierdzony przez operatora lub od momentu zakończenia upłynął okres czasu podany w parametrze Zwłoka czasowa.

Uwaga:

Niezależnie od użytego trybu usuwania zakończonych alarmów, obiekty tabel alarmów aktywnych mogą wprowadzać własne buforowanie (właściwość Usuwaj zakończone alarmy), które może spowodować pokazywanie alarmu usuniętego już z logu alarmów aktywnych. Musi być jednak spełniony warunek, że tabela była otwarta w czasie przebywania alarmu w logu alarmów aktywnych


7 Log alarmów historycznych

8 Log alarmów historycznych

Log alarmów historycznych przechowuje informacje o wszystkich zdarzeniach alarmowych, zarówno początkach jak i końcach alarmów. Log może przechowywać historię zdarzeń z wielu dni.

Globalny tryb pracy logu alarmów historycznych domeny jest parametryzowany w pokazanym niżej fragmencie zakładki Ustawienia. Niektóre ustawienia mogą być deklarowane indywidualnie dla poszczególnych stanowisk – w tym przypadku należy użyć zakładki Stanowiska.

Podstawowy log alarmów, wykorzystywany do bieżącej obsługi alarmów, tworzony jest na każdym stanowisku domeny. Zawartość logów historycznych poszczególnych stanowisk jest wzajemnie synchronizowana. Standardowo log przechowywany jest w lokalnym pliku, w parametrze Usuwaj alarmy historyczne starsze niż można określić okres przechowywania informacji o zdarzeniach alarmowych. Jeżeli opcja Zapisuj plik logów alarmów historycznych nie zostanie zaznaczona, to log historyczny jest przechowywany tylko w pamięci w trakcie pracy aplikacji. Po restarcie aplikacji log będzie tworzony od nowa.


7.1 Archiwum alarmów SQL

8.1 Archiwum alarmów SQL

Uzupełnieniem standardowego logu alarmów historycznych jest archiwum alarmów typu SQL. Archiwum to jest przeznaczone do analizy alarmów przy pomocy programu AsAlarm, a także w systemach raportowania. W celu podniesienia niezawodności, można równolegle tworzyć archiwum na kilku serwerach. Jednak nawet w przypadku użycia pojedynczego serwera, Asix.Evo dysponuje mechanizmami buforowania danych pozwalającymi na pracę z chwilową utratą połączenia z serwerem SQL. Archiwum SQL należy identycznie parametryzować na wszystkich stanowiskach typu kontroler. Wynika to z faktu, że zapis do bazy SQL w danej chwili wykonuje tylko stanowisko kontrolera aktywnego.

Przed rozpoczęciem archiwizacji alarmowa baza danych SQL musi być utworzona. Służy do tego powyższe okno otwierane przyciskiem Zarządzanie bazami danych. Okno pozwala również na wykonywanie innych zadań administracyjnych. Poświadczenia z grupy Autoryzacja serwera bazy danych muszą zapewnić uzyskanie w serwerze SQL uprawnień wystarczających do wykonywania operacji tworzenia i usuwania baz danych.


9 Wizualizacja stanu alarmów

8 Wizualizacja stanu alarmów

Podstawowym elementem służącym do wizualizacji stanu alarmów są obiekty tabel alarmów. Dostępne są dwa typy tabel, przeznaczone do obsługi alarmów aktywnych i historycznych. Jako uzupełnienie można stosować prezentację stanu alarmów przy pomocy innych obiektów ogólnego przeznaczenia.


8.1 Tabele alarmów aktywnych

9.1 Tabele alarmów aktywnych

Obiekt Tabela alarmów aktywnych służy do wyświetlania informacji o alarmach znajdujących się logu alarmów aktywnych.

Obiekt pozwala także na obsługę operatorską. Wykorzystywane są do tego celu przyciski ze zintegrowanego paska narzędziowego.


8.2 Tabele alarmów historycznych

9.2 Tabele alarmów historycznych

Obiekt Tabela alarmów historycznych służy do przeglądania informacji o zdarzeniach alarmach zarejestrowanych w logu alarmów historycznych.

Obiekt posiada wbudowane mechanizmy swobodnego określania zestawu alarmów pokazywanych w tabeli.


8.3 Inne obiekty

9.3 Inne obiekty

Stan alarmów może być pokazywany na zwykłych obiektach. W tym celu należy użyć funkcji IsAlarm, IsAlarmUnaccepted lub IsAlarmExcluded. Wszystkie te funkcje zwracają informacje na temat stanu wskazanego alarmu.

Poniższy przykład pokazuje parametryzację obiektu Tekst wyświetlającego wartość zmiennej VA001. Jeżeli alarm o identyfikatorze A_VA001 jest aktywny, to wartość zmiennej wyświetlana jest w kolorze czerwonym.

Właściwości podstawowe
 | Główna zmienna | VA001
Właściwości stanowe, stan podstawowy
 | Tekst | #
 | Kolor | Black
Właściwości stanowe, stan numer 1
 | Warunek stanu | =IsAlarm(A_VA001)
 | Kolor | Red


9 Obsługa alarmów

10 Obsługa alarmów

Większość funkcji związanych z operatorską obsługą alarmów dostępna jest poprzez interfejs obiektu Tabela alarmów aktywnych. Niektóre funkcje mogą być wykonane przy pomocy akcji operatorskich. Pozwala to projektantowi aplikacji na zintegrowanie funkcji obsługowych bezpośrednio z obiektami diagramów synoptycznych.


9.1 Potwierdzanie alarmów

10.1 Potwierdzanie alarmów

Podstawowym mechanizmem potwierdzenia alarmu jest przycisk w pasku narzędziowym obiektu Tabela alarmów aktywnych. Przyciśnięcie przycisku potwierdza wszystkie widoczne alarmy. Jedynie w przypadku alarmów o priorytetach pilny i krytyczne wymagana jest wcześniejsza selekcja wiersza alarmu. Alternatywna metoda potwierdzenia to wykonanie akcji AcceptAlarm użytej w obsłudze zdarzenia obiektu diagramu.

Funkcja potwierdzania alarmów jest kontrolowana przez system uprawnień. Pierwszym warunkiem jest zezwolenie na potwierdzanie alarmów na stanowisku. Jest ono deklarowane w ustawienia stanowiska w panelu parametryzacji systemu alarmów. Drugi warunek to indywidualne uprawnienia aktualnie zalogowanego użytkownika. Musi on pełnić rolę, która posiada uprawnienie Prawo potwierdzania alarmów.


9.2 Wykluczenia alarmów

10.2 Wykluczenia alarmów

Mechanizm wykluczania alarmów pozwala wyłączyć z obsługi dowolny alarm. Wszystkie zdarzenia dotyczące alarmu wykluczonego są ignorowane. Wykluczenia są przydatne w celu eliminacji alarmów, które ze względu na jakąś awarię są nieprawidłowo wykrywane.

Do obsługi wykluczeń służy poniższe okno otwierane przyciskiem paska narzędziowego obiektu Tabela alarmów aktywnych.

W liście po prawej stronie pokazane są wszystkie alarmy, które są aktualnie wykluczone.

Funkcja wykluczania alarmów jest kontrolowana przez system uprawnień. Aktualnie zalogowany użytkownik musi pełnić rolę, która posiada uprawnienie Prawo edycji wykluczeń alarmów.


9.3 Wykluczenia jednorazowe

10.3 Wykluczenia jednorazowe

Mechanizm wykluczeń jednorazowych pozwala operatorowi na usunięcie z tabeli dowolnego aktywnego alarmu. W przeciwieństwie jednak do standardowych wykluczeń, ponowne wykrycie alarmu zostanie zgłoszone w normalny sposób.

Jednokrotne wykluczenie wykonywane jest poprzez wskazanie alarmu w tabeli alarmów aktywnych i przyciśnięcie odpowiedniego przycisku paska narzędziowego.

Funkcja jednorazowego wykluczania alarmów jest kontrolowana przez system uprawnień. Aktualnie zalogowany użytkownik musi pełnić rolę, która posiada uprawnienie Prawo jednokrotnego wykluczania alarmów.


9.4 Filtrowanie alarmów

10.4 Filtrowanie alarmów

Mechanizm filtrowania alarmów pozwala ograniczyć liczbę zgłaszanych alarmów. Mechanizm eliminuje krótkotrwałe zdarzenia alarmowe, które mogą powstawać w wyniku złego działania czujników.

Możliwe są dwa tryby filtrowania:

  • Filtrowanie krótkich alarmów

Ignorowane są krótkotrwałe zmiany stanu alarmu. Stan musi utrzymać się przez określony czas, aby zmiana została zaakceptowane.

  • Filtrowanie szybkich sekwencji

Ignorowane są sekwencje szybko następujących po sobie zmian stanu alarmu (tzw. „drgające styki”). Pierwsza, nawet krótka, zmiana jest natychmiast akceptowana, ale następne zostaną przyjęte dopiero po upływie czasu karencji.

Do obsługi filtrów służy poniższe okno otwierane przyciskiem paska narzędziowego obiektu Tabela alarmów aktywnych.

Żeby włączyć filtr, należy kolejno: wybrać alarm na lewej liście, wybrać tryb filtracji i ustawić czas filtra, przyciskiem > przesunąć alarm na listę alarmów filtrowanych.

Funkcja filtrowania alarmów jest kontrolowana przez system uprawnień. Aktualnie zalogowany użytkownik musi pełnić rolę, która posiada uprawnienie Prawo edycji filtrów alarmów.


9.5 Sygnalizacja dźwiękowa

10.5 Sygnalizacja dźwiękowa

Moment wykrycia alarmu może być sygnalizowany sygnałem dźwiękowym. Nastąpi to, gdy w definicji alarmu, w atrybucie Dźwięk została podana nazwa pliku dźwiękowego.

Operator ma możliwość wyciszenia dźwięku. Pierwszą metodą jest użycia przycisku wyciszenia na pasku narzędziowym obiektu Tabela alarmów aktywnych. Druga metoda to użycie akcji operatorskiej StopSound.

W przypadku aplikacji złożonych z kilku stanowisk, sygnał dźwiękowy może być odtwarzany na kilku stanowiskach. Pasek narzędziowy tabeli alarmów ma dwa różne przyciski wyciszenia. Pierwszy wycisza dźwięk tylko na lokalnym stanowisku, drugi wykonuje to na wszystkich stanowiskach domeny.

To czy wybrane stanowisko odtwarza dźwięki alarmowe zależy od ustawień w zakładce Stanowiska panelu parametryzacji systemu alarmów. Możliwe są trzy tryby pracy:

a) Odtwarzaj – stanowisko zawsze odtwarza dźwięki alarmowe

b) Nie odtwarzaj – stanowisko nigdy nie odtwarza dźwięków alarmowych

c) Gdy aktywny kontroler – stanowisko odtwarza dźwięki tylko wtedy, gdy jest kontrolerem aktywnym. Pozwala to zapewnić, że w przypadku stosowania kilku redundantnych stanowisk operatorskich dźwięki są odtwarzane tylko przez jedno stanowisko.


9.6 Drukowanie

10.6 Drukowanie

Funkcja wydruku alarmów dostępna jest w obiektach Tabela alarmów aktywnych i Tabela alarmów historycznych. Przyciśnięcie przycisku wydruku powoduje otwarcie poniższego okna, w którym operator może ustawić opcje wydruku.

W oknie wydruku można określić wygląd wydruku, zestaw drukowanych danych oraz kryteria wyboru alarmów. Oprócz wydruku na drukarce, można zapisać dane o alarmach w pliku tekstowym.


10 Współpraca z AsAlert

11 Współpraca z AsAlert

Program AsAlert w aplikacjach systemu Asix służy do wysyłania powiadomień o alarmach. W zależności od konfiguracji programu, powiadomienia mogą być wysyłane przy pomocy komunikatów SMS lub poczty elektronicznej.

System alarmów Asix.Evo może współpracować z programem AsAlert. Parametryzacja sprzęgu wykonywana jest dwustopniowo. W pierwszym kroku deklarowane są podstawowe parametry komunikacyjne. Służy do tego pokazany poniżej fragment zakładki Ustawienia.

Znaczenie parametrów jest następujące:

  • Stanowisko

Określenie stanowiska aplikacji Asix.Evo, które będzie inicjowało wysłanie powiadomienia. Może to być nazwa dowolnego stanowiska uczestniczącego w pracy domeny. Można też wybrać opcję, w której powiadomienia wysyła zawsze aktywny kontroler. Właściwy wybór zależy od konfiguracji systemu. W każdym przypadku stanowisko powinno być włączone przez cały czas. Dlatego zazwyczaj alerty wysyłane są ze stanowisk kontrolerów. Jeżeli AsAlert jest zainstalowany na komputerze jednego z kontrolerów, to z reguły powiadomienia powinno wysyłać to stanowisko. W przeciwnym wypadku z reguły lepsza jest opcja aktywnego kontrolera.

  • Lokalizacja

Systemowa nazwa komputera, na którym zainstalowany jest program AsAlert. W przypadku korzystania z lokalnej instalacji należy parametr pozostawić pusty.

  • Użytkownik

Nazwa użytkownika programu AsAlert na konto, którego będą wysyłane powiadomienia.

  • Hasło

Hasło użytkownika programu AsAlert na konto, którego będą wysyłane powiadomienia.

  • Nazwa źródła

Dowolny tekst, który w wysłanym alercie zostanie użyty jako nadawca wiadomości.

  • Nagłówek

Dowolny tekst, który w wysłanym alercie zostanie użyty jako tytuł wiadomości.

Drugim krokiem w parametryzacji sprzęgu jest odpowiednie zdefiniowanie atrybutów TrybAlertów i Adresaci Alertów w definicji każdego alarmu, dla którego mają być wysyłane alerty. Tryb alertów pozwala wybrać kiedy alerty są wysyłane: możliwe jest wysyłanie w momentach początku i/lub końcu alarmu. W atrybucie AdresaciAlertów należy podać nazwy adresatów zdefiniowanych w programie AsAlert, do których powiadomienie ma być wysłane.