Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 8

www.asix.com.pl

AsTrend -

Prezentacja danych archiwalnych

Podręcznik dla projektantów / administratorów

Dok. Nr PLH8022

Wersja: 2015-03-06

UWAGA:

Niniejszy podręcznik dedykowany jest zarówno aplikacjom wykonanym w wersji klasycznej jak i wersji Evo systemu Asix.


Program AsTrend

1. AsTrend - funkcjonalność

Program AsTrend przeznaczony jest do graficznej analizy i prezentacji w postaci graficznej lub tabelarycznej danych archiwalnych gromadzonych przez aplikacje SCADA. Możliwe są dwa sposoby pracy programu:

- statyczne odrysowanie danych zgromadzonych w plikach archiwalnych;

- dynamiczne wyświetlanie danych napływających z obiektu (symulacja rejestratora).

Aby móc analizować dane z aplikacji systemu Asix, należy posiadać bazę definicji zmiennych aplikacji. Baza definicji zmiennych tworzona jest przez administratora aplikacji.

Wartości zmiennych mogą być również pobierane z serwera danych historycznych z aplikacji innych systemów SCADA. Konieczne jest posiadanie serwera zgodnego ze standardem OPC HDA.

Możliwe jest również pokazywanie wykresów wartości zmiennych pobranych ze źródeł zewnętrznych takich jak: pliki txt, csv, xls oraz z baz danych dostępnych przez OLE DB np. Microsoft SQL Serwer i Microsoft Access. Warunkiem odczytu jest struktura bazy pozwalająca na odczyt danych w sposób uporządkowany.


Nowości 5.2

1.1.1 Nowości 5.2

Nawigacja po 'historii okresów’

Dodane do menu Okres polecenia [image] [image] Ustaw poprzedni / następny pozwalają na poruszanie się po historii kolejno wyświetlonych przez użytkownika okresów (działanie identyczne jak przyciski Wstecz / Dalej w przeglądarce internetowej); zapamiętywanych jest 20 kolejno wyświetlonych okresów.

Modernizacja schowka okresów

Zmiany w zakresie funkcjonalności i wyglądu schowka okresów obejmują:

- zapisywane okresy przechowywane są w pliku konfiguracyjnym trendów (a nie w rejestrze jak dotychczas);

- okres zapamiętywany jest jako Opis, Początek, Koniec wraz z dodatkowymi informacjami dotyczącymi ustawień głównej i dodatkowej linii odczytu (pola Główna linia odczytu i Dodatkowa linia odczytu umieszczone na zakładce Historia okresów okna schowka).

Lista ostatnio otwieranych trendów / baz definicji zmiennych

W menu Plik pojawiły się nowe polecenia umożliwiające otwieranie trendów / baz definicji zmiennych z listy ostatnio otwieranych plików. Polecenia te dostępne są w pełnym trybie pracy programu AsTrend.

Zmiany w funkcjonalności legendy

- Użytkownik ma możliwość zmiany wysokości legendy za pomocą Paska podziału [image], nowego polecenia dostępnego w menu Widok. Wysokość legendy jest zaokrąglana do pełnych wierszy.

- Pola wyświetlane w tabeli legendy mogą być teraz usuwane metodą drag-and-drop.

- Legenda na wydruku może być umieszczana na osobnej stronie (Opcje trendu > Wydruk > parametr Układ legendy - Legenda na osobnej stronie).

Deklaracja parametrów sieciowych

Wersja AsTrend 5.2 daje możliwość wyboru serwerów danych, z których pobierane są wartości wyświetlanych na wykresie zmiennych. W tym celu pośród opcji programu określanych przy użyciu okna wywoływanego komendą Plik > Opcje programu&ldots; zamieszczona została zakładka Sieć z możliwością zadeklarowania nazwy serwerów danych, z których pobierane będą dane do wyświetlania wykresów trendów oraz Maksymalnego czasu oczekiwania na zgłoszenie się serwera i Maksymalnego czasu odpowiedzi serwera danych.

Pozostałe zmiany

Polecenie Blokada zmiany rozmiarów zastąpione zostało przez dwie odrębne komendy: Blokada rozmiarów okna i [image] Stały układ wykresu. Polecenia znajdują się w menu Widok. Stały układ wykresu oznacza, że osie i legenda zawsze są widoczne, szerokość etykiet lewej i prawej osi jest stała (z wyjątkiem wykresu wieloosiowego), a na wydruku zawsze jest zarezerwowane miejsce na tytuł trendu - taki układ wykresu ułatwia porównywanie wydruków trendów.

Aktualnie maksymalna ilość serii danych, które mogą być wyświetlona na jednym wykresie została zwiększona z 16 do 32 serii.

Użytkownik może dokonywać zmiany koloru lewej i dolnej ściany wykresu 3D (do tej pory kolory tych elementów były nieedytowalne).

Dodany został parametr, który pozwala określić rodzaj okna, jakie będzie używane do otwierania plików trendu (z lub bez opcji podglądu zawartości trendu) - opcja działa tylko wtedy, gdy program AsTrend uruchamiany jest samodzielnie: Opcje programu > zakładka Okno otwarcia trendu > opcja Okno otwarcia pliku trendu.

Zarówno administrator jak i operator mogą mieć zablokowaną możliwość kasowania plików w sytuacji, kiedy na pliki AsTrend nałożona została blokada zapisu (opcja ustawiana w Architekcie: Obszary i komputery > Parametry startowe > Programy > opcja Blokada zapisu w programie AsTrend.

W momencie, gdy program AsTrend jest uruchamiany na danym komputerze razem z Asixem, powinien być wywoływany przez Operatora z menu aplikacji Asixa a nie z belki systemu Windows. AsTrend uruchomiony z belki ma ograniczenia dotyczące operacji na plikach - Operator nie może zapisywać plików, ponieważ nie ma zadeklarowanego katalogu, w którym plik mógłby być zapisany.

Nowa opcja uruchamiania AsTrend w aplikacji Asix: dzięki wprowadzonym modyfikacjom dostępnej w systemie Asix akcji operatorskiej ASTREND (poza możliwością otwarcia okna programu AsTrend z jednoczesnym wyświetleniem trendu wg definicji zapisanej w pliku *.trnx) istnieje również możliwość automatycznego wydruku trendu, wskazanego w definicji akcji. Dzieje się tak dzięki dodanemu parametrowi Tryb, określającemu sposób działania akcji: DRUKUJ_WYKRES - drukuj wykres trendu lub POKAŻ_WYKRES - wyświetl wykres trendu.


Nowości 6.0

1.1.2 Nowości 6.0

  • Praca w trybie tabeli danych historycznych

Program AsTrend wyposażony został w nowy tryb pracy umożliwiający oglądanie danych historycznych w formie tabeli.

  • Zapisywanie parametrów domyślnych trendu

Do edytora opcji trendu dodano pole wyboru Zapisz jako domyślne. Zamknięcie okna gdy pole jest włączone powoduje zapisanie aktualnych opcji trendu w pliku domyślnych wartości trendu. Opcje te będą zawsze używane przy tworzeniu nowego trendu.

  • Nowa opcja formatu wartości agregatu 'całka'

W parametrach serii dotyczących formatu wartości dodano opcję Pokazuj całkę jako czas, której zastosowanie umożliwia wyświetlanie wartości agregatu 'całka' w formacie czasu: d h:mm:ss.

  • Przeliczanie agregatów 'całka' i 'gradient'

Do parametrów serii dodano nową opcję Okres pomiaru, która używana jest do przeliczania wartości agregatów 'całka' i 'gradient'. Opcja przy dodawaniu zmiennej inicjowana jest na podstawie wartości atrybutu Jednostka.

  • Zmiany w wykresach XY

Dodano możliwość rysowania wykresu XY z wieloma osiami OY

  • Agregacja danych systemu Asix

Dodano możliwość wyliczania agregatów dla wszystkich typów danych zmiennych Asixa - poprzednio agregaty wyliczane były tylko dla danych równomiernych.

  • Wyświetlanie przebiegów wzorcowych

Zakładka Przebiegi wzorcowe w opcjach serii pozwala na dodanie do okna trendu przebiegu wzorcowego (jednego lub dwóch). Dodanie dwóch przebiegów wzorcowych pozwala uzyskać wykres wstęgowy - przydatny przy ocenie kształtowania się wartości analizowanej zmiennej pod kątem przekroczeń wartości maksymalnych i minimalnych.

  • Wyświetlanie danych równomiernych

Do paska narzędzi do polecenia Dane równomierne dodano przycisk wyświetlający okienko edycji interwału odczytu tych danych.

  • Dodawanie zmiennych agregowanych

Do menu Seria dołożona została opcja dodawania zmiennej agregowanej. Polecenie to umożliwia dodanie zmiennej z Asixa oraz zdefiniowanie agregatu tej zmiennej.

  • Osadzanie tabeli w obszarze wykresu trendu

Aktualnie tabela może być 'zadokowana' w oknie trendu, co oznacza wpasowanie tabeli w obszar wykresu w taki sposób, że zamiast wykresu widoczna jest tabela z wartościami zmiennych. Obszar wykresu zostaje wówczas przykryty przez tabelę - istnieje jednakze mozliwość przełączania się pomiędzy widokami wykres - tabela za pomocą zakładek Wykres / Tabela, pojawiających się nad legendą w momencie osadzenia tabeli.

  • Wersja internetowa programu AsTrend

W systemie Asix od wersji 6 dostępna jest internetowa wersja programu AsTrend - co oznacza możliwość dostępu do programu poprzez przeglądarkę internetową.


Nowości 6.1

1.1.3 Nowości 6.1

  • Od wersji 6.1 pakietu Asix tradycyjne menu wraz z paskami narzędzi zastąpione zostało w AsTrendzie Wstążką (ang. ribbon) - co znacznie upraszcza strukturę poleceń i ułatwia dostęp do funkcji programu.

  • Zrezygnowano ze starej metody definiowania automatyki wyświetlania trendów, wymagającej definiowania dodatkowych zmiennych przechowujących wartości uśrednione zmiennych surowych. Od wersji 5.1 alternatywą dla w/w automatyki stały się agregaty danych surowych. Czas odrysowania wykresu został znacząco przyspieszony poprzez zastosowanie w systemie Asix archiwizacji agregatów danych surowych, bez konieczności dokonywania przez operatora programu AsTrend jakichkolwiek ustawień w programie. Wykresy odrysowywane są w pierwszej kolejności z wartości zagregowanych pobieranych z archiwum serwera Asix, a w przypadku braku takiego archiwum - z agregatów wyliczanych na bieżąco. Stosowanie agregatów jest obecnie od wersji 6.1 jedyną zalecaną metodą na zwiększenie szybkości i elastyczności wyświetlania trendów.

  • Baza typów danych, które mogą być przeglądane w programie AsTrend - została wzbogacona o dwa nowe typy: dane pochodzące z systemu Wonderware (zarówno dane historyczne pobierane z Historiana jak i alarmy) oraz dane historyczne pochodzące z serwera OPC HDA.

  • Dodano możliwość zmiany on-line bezpośrednio w programie AsTrend treści nagłówków kolumn legendy (dotychczas zmiany nazw nagłówków można było dokonać w bazie definicji zmiennych, skąd pobierane są wartości atrybutów zmiennych).

  • Wybór kolumn legendy ułatwia aktualnie okno wyboru, które w uporządkowany sposób grupuje dostępne kolumny według następujących kategorii: Agregaty, Trend, Linia odczytu, standardowe atrybuty bazy definicji zmiennych oraz niestandardowe atrybuty bazy definicji zmiennych utworzone przez projektanta bazy.

  • Dla internetowej wersji programu AsTrend wprowadzona została możliwość kontrolowania dostępu do odczytu wartości zmiennych pochodzących z aplikacji systemu Asix. Ochrona dostępu jest aktywowana pod warunkiem uwierzytelniania dostępu do programu AsTrend przez system Windows oraz umieszczenia w bazie definicji zmiennych atrybutu 'Grupa uprawnień odczytu', w którym dla każdej zmiennej należy podać nazwę grupy użytkowników uprawnionych do odczytu wartości danej zmiennej.


Nowości 7.0

1.1.4 Nowości 7.0

Lista zmian obejmuje m.in.:

1. Dodano obsługę łączonych baz definicji zmiennych.

2. Zmiany układu wstążki zapisywane są od razu po każdej zmianie.

3. Dodano menu kontekstowe w oknach tabeli danych bieżących, historycznych oraz schowka.

4. Dodano wybór formatu jakości przy eksporcie danych.

5. Dodano opcję Progi jakości dla atrybutów wyliczanych w edytorze opcji danych wejściowych.

6. Dodano opcję umożliwiającą zmianę szerokości linii wskazanego przebiegu.

7. Dodano opcje umożliwiające wybór formatu papieru wydruku i eksportu do pliku PDF (opcje programu).

8. Dodano możliwość zastosowania gradientu dla wypełnienia obszaru serii w wykresach: słupkowych i obszarowych.


nowości 7.1

1.1.5 Nowości wersji 7.1

Lista zmian obejmuje m.in.:

1. Dodano nowy rodzaj przebiegu - Archiwum Asix [image] . Przebieg umożliwia wczytanie danych wyeksportowanych w programie AspadTools.

2. Dodano nowy rodzaj przebiegu - Alarm SQL [image] . Dodanie alarmu SQL stosuje się wyłącznie dla alarmów, których archiwa zdarzeń przechowywane są w bazie SQL. Może to dotyczyć zarówno aplikacji wersji Evo jak i klasycznej wersji Asixa. Należy zadbać o to, aby dla aplikacji Evo informacje o wszystkich zdarzeniach alarmowych przechowywane były nie tylko w logach alarmów historycznych, ale również jako uzupełnienie w archiwum alarmów typu SQL. Podobnie w aplikacjach klasycznych - oprócz archiwizacji zdarzeń alarmów w plikach dyskowych należy równolegle zadeklarować przechowywanie zdarzeń alarmowych w bazie MS SQL.

3. Do opcji programu dodano opcję wyboru rodzaju wydruku: wydruk wysokiej jakości, wydruk standardowy. Wydruk wysokiej jakości umożliwia drukowanie przeźroczystości.

4. Do opcji programu dodano funkcje umożliwiające ustawianie za pomocą dwóch przycisków bieżących opcji trendu lub wbudowanych opcji trendu jako domyślnych dla nowo tworzonych plików trendu. Funkcje zastąpiły opcje Zapisz jako domyślne w oknach edycji opcji trendu.

5. Dodano otwieranie na starcie programu ostatnio używanej bazy definicji zmiennych.

6. Dodano możliwość wyboru predefiniowanych palet kolorów przebiegów. Można również utworzyć swoją własną paletę.

7. Dodano obsługę wykresów 3D z możliwością przestrzennej manipulacji obszarem wykresu w trzech płaszczyznach.

8. Dodano możliwość stosowania gradientu dla wszystkich ścian wykresu.

9. Dodano możliwość definiowania kolorów osi wykresu (razem z kolorem etykietek opisujących osie) oraz kolorów i formatu siatki na obszarze wykresu.

10. Reorganizacja poleceń na zakładkach wstążki oraz poleceń okien opcji programu, trendu i przebiegu.


Nowości 8.0

1.1.6 Nowości 8.0

  • Obsługa wielu wykresów

Oprócz wykresu głównego, który jest zawsze widoczny, istnieje możliwość wyświetlenia maksymalnie 3 dodatkowych wykresów - każdy w indywidualnym oknie - z pełna obsługa dokowania. Każdy wykres może mieć zdefiniowane indywidualne opcje. Istnieje tez pełna swoboda w przenoszeniu i kopiowaniu przebiegów między wykresami.

  • Dokowanie okien

Pełna obsługa dokowania okien wykresów dodatkowych, legendy, tabeli i schowka okresów: okno pływające, okno jedno na drugim (zakładki), okno sąsiadujące, kombinacje powyższych. Układ okien zapamiętywany jest w programie AsTrend automatycznie przy wyjściu z programu - ale istnieje również możliwość zapisu stanu okien dla pliku trendu.

  • Integracja z programem do rejestracji szybkozmiennych serii pomiarowych - AsLogger oraz z programem do obsługi receptur i archiwizacji zdarzeniowej - AsBase

Zdefiniowane zostały nowe rodzaje przebiegów pobierające dane z baz danych programów AsBase i AsLogger. Dodano obsługę przebiegów modułu AsLogger o okresie próbkowania poniżej 1 ms.

  • Operacje na wielu przebiegach

Dodano możliwość zaznaczania wielu przebiegów i wykonywania operacji jednocześnie dla nich wszystkich:

- włączenie punktów, etykiet;

- zmiana kształtu: liniowy / słupkowy / obszarowy;

- usuwanie;

- przenoszenie między wykresami;

- przesuwanie w legendzie w górę / w dół.

  • Nowe atrybuty przebiegów wyświetlane w legendzie

Dodano 2 istotne atrybuty (kolumny legendy) z grupy atrybutów o nazwie Trend:

- Nazwa przebiegu - symboliczna nazwa przebiegu, której domyślna wartość dla zmiennych pobieranych z aplikacji systemu Asix przyjmuje wartość atrybutu Nazwa z bazy definicji zmiennych; może być zmieniana poleceniem Wybierz atrybut nazw przebiegów (menu Dane > Asix - zmienne i alarmy); nazwa przebiegu może być edytowana przez użytkownika.

- Adres przebiegu - symboliczny adres przebiegu; domyślnie niewidoczny; pozwala umieścić w legendzie informacje o źródłach, z których czytane są dane przebiegów (np. A090/ARCHIWUM, Alarmy_F/414).

  • Etykiety wartości definiowane w pliku trendu

Dodano edytor pozwalający na definiowanie tekstowych etykiet wartości, używanych zamiast wartości liczbowych:

- na wykresie: dymki i etykiety punktów;

- w legendzie: kolumna Wartość próbki linii odczytu 1/2;

- na osi pionowej: w przypadku wielu osi OY lub wykresu procentowego; w przypadku osi fizycznej etykiety zostaną wyświetlone tylko gdy będą identyczne dla wszystkich przebiegów;

- w tabeli: kolumny wartości;

- przy eksporcie danych: kolumny wartości.

  • Dodawanie przebiegów przy otwarciu pliku trendu

Dzięki tej nowości Użytkownik ma możliwość sam zadecydować, które przebiegi będzie oglądać. Dotyczy to zmiennej Asix, bitu zmiennej Asix, agregatu zmiennej Asix, pola zestawu rejestracji modułu AsBase oraz punktu z planu rejestracji modułu AsLogger. Funkcjonalność tę umożliwiają: zmodyfikowana składnia komendy otwierającej program AsTrend oraz akcja operatorska AsTrend.

  • Wykres typu X

Wykres X daje możliwość zaprezentowania różnych wartości zmiennej (niezależnie od czasu czy innej zmiennej) w kolejności ich zarejestrowania. Pozioma oś zawiera indeksy próbek zamiast stempli czasu - próbki indeksowane są od 1.

  • Bardziej elastyczny wykres typu 'stos'

- Domyślnie każdy przebieg w osobnym wierszu.

- Możliwość zgrupowania dowolnej liczby przebiegów w każdym wierszu.

- Wybór osi pionowej po lewej lub prawej stronie.

  • Wsparcie dla urządzeń mobilnych i ekranów dotykowych

- Pełne wsparcie dla skalowania UI w Windows 8.

- Zmniejszone okienka dialogowe mieszczą się na ekranie 1024x720 px

(np. Tablet 10” FullHD + Skalowanie 150%).

- Wykrywanie w systemie obsługi dotyku i włączenie większych elementów UI, większej tolerancji ”r;r;kliknięcia” itp.

- Wsparcie dla gestów: przesuwanie okresu, zmiana okresu (zoom).

- Klawiatura ekranowa.

  • Wydruk i eksport

- Eksport do BMP analogicznie do eksportu do PDF.

- Nowa opcja określająca, czy podczas wydruku lub eksportu ma być zachowane kolorowe tło czy zamienione na białe.

- Wydruk wielu wykresów.

- Usunięcie ramek i poprawki wizualne przy wydruku lub eksporcie do PDF/BMP.

- Wydruk z domyślnego podajnika.

  • Usprawnienia wizualne

Wykres

- Poprawiono płynność animacji po zmianie okresu.

- Nowe opcje dla wykresów 3D i słupkowych.

- Obsługa dodatkowej osi czasu myszką (zmiana okresu lub przesunięcia).

- Wykres słupkowy zamieniany na liniowy gdy liczba próbek > 60.

Tabela

- Kolorowanie kolumn kolorem przebiegu.

- Wyrównanie wartości do prawej.

Czcionka

- Możliwość zdefiniowania czcionki (krój, wygląd, rozmiar) dla całego trendu.

  • Inne usprawnienia

- Przyspieszono odczyt danych z agregatora.

- Dodano okno postępu odczytu wartości przebiegów (z możliwością przerwania odczytu).

- Automatyczna obsługa krótkich okresów czasu (edytor milisekund widoczny gdy okres < 60s).


Nowości 8.0.2

1.1.7 Nowości 8.0.2

Lista nowości obejmuje udostępnienie w module AsTrend funkcji generowania ad-hoc prostych raportów tabelarycznych dla różnych okresów czasu i wybranych agregatów zmiennych. Stanowi to alternatywę dla raportów tworzonych w środowisku MS Reporting Services, pod warunkiem że nie są to raporty skomplikowane.

AsTrend został też rozszerzony o następujące elementy:

  • dla wykresu obszarowego dodano możliwość ustawienia linii bazowej;

  • dodano zapamiętywanie osobnych układów okien w trybie trendu i w trybie raportu;

  • rozbudowano obsługę przebiegów wyliczanych - 3 rodzaje przebiegów wyliczanych: agregacja danych wyliczonych z danych surowych, wyliczanie wartości próbek z danych zagregowanych i agregacja danych wyliczonych z danych zagregowanych;

  • dodano wewnętrzny agregat AsTrend: suma wartości próbek - dostępny w podsumowaniu raportu;

  • w wersji przeglądarkowej programu AsTrend dodano możliwość otwierania plików z katalogów sieciowych zadeklarowanych przez projektanta.


nowosci_w_8.0.3

1.1.8 Nowości w 8.0.3

- W trybie raportu dodano obsługę zmiennych zewnętrznych.

- Dodano obsługę agregatów dla przebiegów z danych zewnętrznych.

- Dodano możliwość powiększania wykresów z wieloma osiami Y.

- Dodano możliwość włączenia trybu powiększenia dla wykresu XY.

- Włączenie powiększenia jest możliwe tylko gdy chociaż jeden z wykresów umożliwia powiększenie i jest widoczny.

- Zablokowano kółko myszy dla wykresu XY. Kółko powodowało błędną zmianę okresu czasu oraz przesuwanie osi.


Wymagania sprzętowe programu AsTrend

1.2 Wymagania sprzętowe programu AsTrend

Program AsTrend może działać na każdym komputerze, na którym zainstalowany jest system operacyjny Windows XP lub wersja późniejsza. Jedynym ograniczeniem sprzętowym dla poprawnego działania AsTrend jest rozdzielczość ekranu - musi ona wynosić przynajmniej 1024x768; optymalna rozdzielczość: 1280x800.


Tryby pracy programu AsTrend

1.3 Tryby pracy programu AsTrend

Program AsTrend może pracować w dwóch trybach: z aplikacją systemu Asix i samodzielnie.

W każdym z tych trybów serwerem danych może być ten sam komputer, na którym został uruchomiony AsTrend lub dowolny inny komputer pracujący w sieci.

Szczegóły na temat sposobów uruchamiania programu AsTrend podano w rozdziale 2.1 Uruchamianie i praca programu AsTrend.


Praca programu z aplikacja systemu Asix

1.4 System uprawnień AsTrend uruchamianego z aplikacją systemu Asix

Przypadek aplikacji systemu Asix.Evo

Podczas pracy z aplikacją systemu Asix.Evo użytkownicy definiowani są w aplikacji Asixa.Evo. Uprawnienia dotyczące obsługi programu AsTrend dla kadego użytkownika określane są w AsixEvo.exe, w panelu Zabezpieczenia, na zakładce Role > Uprawnienia. Tylko użytkownik posiadający rolę administratora aplikacji Asix.Evo ma automatycznie przypisane pełne uprawnienia w zakresie obsługi programu AsTrend.

Przypadek aplikacji systemu Asix w wersji klasycznej

Podczas pracy z aplikacją systemu Asix AsTrend posiada dwa tryby systemu uprawnień:

  • tryb użytkowników, których uprawnienia definiowane są w programie AsAudit

  • tryb operator / administrator

Tryb pracy programu AsTrend uruchamianego z aplikacją systemu Asix uzależniony jest od używanego mechanizmu zarządzania i kontroli uprawnień.

Tryb użytkowników, których uprawnienia definiowane są w programie AsAudit

W przypadku, kiedy do obsługi uprawnień użytkowników aplikacji systemu Asix stosowany jest moduł AsAudit, uprawnienia w zakresie obsługi programu AsTrend definiowane są module AsAudit. Pełna lista funkcji zależnych od uprawnień zalogowanego użytkownika obejmuje:

  • administrowanie programem AsTrend,

  • tworzenie nowych plików,

  • modyfikację plików,

  • modyfikację plików tylko do odczytu,

  • posiadanie własnego układu menu i pasków narzędzi,

  • modyfikację wspólnego układu menu i pasków narzędzi.

Tryb operator/administrator

Operator

W sytuacji, kiedy w systemie Asix nie ma uaktywnionego modułu AsAudit, dostępne są uproszczone mechanizmy zarządzania uprawnieniami użytkowników i AsTrend posiada wówczas dwa tryby pracy: tryb operatora, tryb administratora.

Każdorazowe uruchomienie programu przez system Asix ustawia tryb pracy jako operator.

Operator:

- nie może tworzyć i modyfikować plików .TRNX opatrzonych atrybutem ”Tylko do odczytu" (Patrz: Zapis definicji trendu);

- ma prawo odczytywać wzorce definicji trendów, zmieniać je i zapisywać pod nowymi nazwami lub tworzyć zupełnie nowe definicje trendów (tylko w katalogu roboczym).

Administrator

Praca administratora pozwala na dodatkowe operacje:

- nie ma ograniczeń co do poruszania się po kartotekach na dyskach komputera,

- istnieje możliwość zapisania pliku trendu z atrybutem "tylko do odczytu" - wówczas operator nie ma możliwości jego modyfikowania,

- działa funkcja blokowania i odblokowywania rozmiarów okna - opcja: Blokada rozmiarów okna [image] (zakładka Widok okna głównego AsTrend > grupa Okno),

- administrator ma możliwość modyfikowania układu menu/pasków narzędzi,

- administrator ma możliwość eksportowania wykresu do pliku .PDF lub .BMP, a legendy do pliku tekstowego, HTML i XLS.

Patrz: 2.2 Definiowanie hasła i sposób logowania administratora.

uwaga W trybie operator /administrator istnieje możliwość nadania operatorowi praw administratora programu AsTrend. Należy tego dokonać w programie Architekt > module Parametry startowe > na zakładce Programy / AsTrend > opcja Zawsze pracuj jako Administrator/ Nadaj operatorowi prawa Administratora programu AsTrend.

uwaga Po 15 minutach od zalogowania się jako administrator nastąpi automatyczne wylogowanie do trybu operatora.

uwaga Zapisanie definicji trendu z odblokowaną zmianą rozmiarów okna w trybie administratora powoduje, że po otwarciu go jako wzorzec stan tej blokady jest taki sam.

Patrz również: 2.1 Uruchamianie i praca programu AsTrend .


Informacje o przechowywaniu opcji programu

1.5 Informacje o przechowywaniu opcji programu

W trybie pracy z aplikacją systemu Asix w wersji klasycznej program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla Administratora i Operatora. Definicje te przechowywane są w pliku programu AsTrend, umieszczanym w katalogu aplikacji.

Jedynie Administrator ma możliwość definiowania układu menu / pasków narzędzi - dla siebie jak również dla Operatora.

***

W trybie pracy z aplikacją systemu Asix w wersji klasycznej z użytkownikami, których uprawnienia definiowane są w programie AsAudit, program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w programie AsAudit. Definicje te przechowywane są w pliku programu AsTrend, umieszczanym w katalogu aplikacji.

***

Podczas pracy z aplikacją systemu Asix w wersji Evo program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w konfiguracji systemu zabezpieczeń. Definicje te przechowywane są w pliku programu AsTrend, umieszczanym w katalogu aplikacji.

***

W przypadku niezależnej pracy programu AsTrend niezależny układ menu / pasków narzędzi definiowany jest dla poszczególnych użytkowników systemu operacyjnego. Plik konfiguracyjny przechowywany jest wówczas w katalogu systemu Windows Documents and Settings.

***

Pozostałe ustawienia opcji związanych z wyświetlaniem trendów również są przechowywane w pliku w katalogu aplikacji lub w katalogu Documents and Settings.


Wersja internetowa programu AsTrend

1.6 Wersja internetowa programu AsTrend

W systemie Asix od wersji 6 dostępna jest internetowa wersja programu AsTrend z zachowaniem pełnej funkcjonalności wersji standardowej okienkowej.

Konfiguracja programu AsTrend do pracy w przeglądarce internetowej realizowana jest przez administratora programu.


Okno Trendow

1.7 Okno programu AsTrend

Po wystartowaniu programu AsTrend na ekranie komputera pojawia się okno przedstawione poniżej. Jest to podstawowe okno programu. W oknie tym można wyróżnić następujące obszary:

Wstążka - wywołanie funkcji dotyczących trendów; funkcje podzielone są na zakładki;

Obszar wykresów - miejsce wyświetlania układu współrzędnych i wykresów; ograniczeniem obszaru wykresu są osie OX i OY;

Legenda - opis wyświetlanych zmiennych;

Pasek statusu - status wyświetlanych trendów.

powiększ >>

Rysunek: Obszary okna programu AsTrend.

Obszar wykresów i legenda będą puste, jeżeli program zostanie uruchomiony bez argumentu. Po starcie większość funkcji jest nieaktywna. W początkowym etapie zaleca się skorzystanie z kreatora trendów, który pozwoli w prosty sposób przejść cały proces definiowania trendu.


Wstążka

1.7.1 Wstążka

Dostęp do poszczególnych funkcji programu AsTrend realizowany jest za pośrednictwem wstążki umieszczonej w górnej części okna głównego AsTrend. Polecenia rozdzielone zostały na zakładki: Plik, Narzędzia główne, Dane, Trend i legenda, Wykres, Przebieg, Tabela, Widok oraz Pomoc. Istnieje również możliwość zdefiniowania paska szybkiego dostępu z zestawem preferowanych przez użytkownika przycisków.


Pasek szybkiego dostępu

1.7.1.1. Pasek szybkiego dostępu

Pasek szybkiego dostępu to miejsce przygotowane na dodawanie dowolnych przycisków dla poleceń, które będą często potrzebne operatorowi lub administratorowi. Aby umieścić nowe przyciski na tym pasku, możemy kliknąć w niego prawym przyciskiem myszy i z menu kontekstowego wybrać polecenie Dostosuj pasek szybkiego dostępu.... Otwiera się wówczas okno dialogowe 'Dostosowanie paska szybkiego dostepu', gdzie po lewej stronie mamy listę dostępnych poleceń (wyświetlanych jednocześnie z wszystkich zakładek lub według zakładek wstążki), a po prawej listę poleceń dodanych do paska szybkiego dostępu.

Drugim sposobem dodania do paska szybkiego dostępu nowego polecenia jest kliknięcie prawym przyciskiem myszy na wybranym poleceniu znajdującym się na wstążce i wybranie z menu kontekstowego polecenia Dodaj do paska szybkiego dostępu.

Aby usunąć polecenie z paska szybkiego dostępu, należy kliknąć w to polecenie prawym przyciskiem myszy i z menu kontekstowego wybrać polecenie Usuń z paska szybkiego dostępu.

Rys. Pasek szybkiego dostępu.


Menu Główne AsTrend

1.7.1.2 Zakładka 'Plik'

Zakładka pozwala na wykonanie następujących operacji:

Nowy trend - otwarcie okna nowego trendu;

Nowy trend - kreator... - otwarcie okna kreatora tworzenia nowego trendu;

Nowy trend - samouczek... - otwarcie okna kreatora tworzenia nowego trendu; kreator uruchamiany jest w wersji rozszerzonej o szczegółowe opisy poszczególnych etapów definiowania nowego trendu;

Nowy raport - otwarcie okna nowego raportu;

Nowy raport - z bieżącego trendu - otwarcie okna nowego raportu w oparciu o dane z bieżącego trendu;

Nowa tabela danych historycznych - otwarcie okna nowej tabeli danych bieżących;

Przywróć oryginał - przywrócenie trendu (bez zapisywania bieżących zmian);

Otwórz... - otwarcie pliku trendu z ostatnio używanych plików/katalogów lub otwarcie pliku ze wskazanej lokalizacji:

Drukuj:

- Drukuj [image] ,

- Podgląd wydruku [image] .

Zapisz - zapisanie trendu;

Zapisz jako ... - zapisanie trendu pod inną nazwą;

Utwórz skrót... - utworzenie skrótu uruchamiającego program AsTrend; polecenie dostępne dla AsTrend uruchamianego poza aplikacją Asixa;

Eksportuj do PDF - eksportuje trend do pliku PDF;

Eksportuj do BMP - eksportuje cały trend do pliku BMP;

Opcje programu - otwarcie okna opcji programu;

Ukryj okno główne - 'zwinięcie' programu do systemowego traya;

Zakończ - zakończenie pracy programu AsTrend; polecenie dostępne dla AsTrend uruchamianego poza aplikacją Asixa;

Ostatnio używane pliki - lista ostatnio otwieranych plików trendów; polecenie dostępne dla AsTrend uruchamianego poza aplikacją Asixa;

Powiększ >>

Rys. Lista poleceń menu 'Plik'.


Zakładka 'Narzędzia główne'

1.7.1.3 Zakładka 'Narzędzia główne'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Nowy przebieg:

Asix:

Dane surowe - dodaje przebieg surowych wartości zmiennych z aplikacji systemu Asix,

Dane agregowane - dodaje do okna trendu przebieg zagregowanych wartości zmiennych z aplikacji systemu Asix,

Bity danych - dodaje do okna trendu przebieg wartości bitu zmiennej z aplikacji systemu Asix,

Zmienna ze schowka - dodaje do okna trendu zmienną pochodzącą ze schowka,

Alarm SQL - dodaje przebieg stanu wybranego alarmu, którego archiwum zdarzeń przechowywane jest w bazie SQL; dedykowane głównie dla alarmów aplikacji wersji Evo,

Alarm - dodaje przebieg stanu wybranego alarmu z aplikacji systemu Asix,

Wyliczany - powoduje otwarcie okna 'Dodaj przebieg wyliczany’, które umożliwia dodanie do wykresu przebiegu, który jest wyliczany z innych przebiegów za pomocą podanego wyrażenia;

AsBase - powoduje otwarcie okna, które umożliwia dodanie do wykresu przebiegu z pola zestawu rejestracji z bazy danych modułu AsBase;

AsLogger - powoduje otwarcie okna, które umożliwia dodanie do wykresu przebiegu z planu rejestracji z bazy danych modułu AsLogger;

Pozostałe przebiegi:

Dane zewnętrzne - powoduje pobranie wartości zmiennych z plików zewnętrznych;

Serwer OPC - HDA - powoduje pobranie wartości zmiennych z serwera OPC-HDA; opcja dostępna przy rozszerzonej licencji klucza HASP pakietu Asix;

Plik archiwum Asix - powoduje dodanie do okna trendu zmiennych wyeksportowany

Przebieg stały - powoduje otwarcie okna 'Dodaj stały przebieg’, które umożliwia wstawienie do wykresu wartości stałej;

Przebieg pusty - dodaje do legendy / tabeli danych historycznych pusty wiersz;

Usuń zaznaczony - usuwa aktualnie wybraną zmienną.

***

Grupa Okres:

- kliknięcie na pole uruchamia okno 'Okres' umożliwiające ustawienie okresu wyświetlania danych;

- przycisk pozwala na cofanie się po historii kolejno wyświetlanych przez użytkownika okresów (działanie identyczne jak przycisk Wstecz w przeglądarce internetowej); zapamiętywanych jest 20 kolejno wyświetlonych okresów;

- przycisk pozwala na poruszanie się po historii kolejno wyświetlanych przez użytkownika okresów (działanie identyczne jak przycisk Dalej w przeglądarce internetowej); zapamiętywanych jest 20 kolejno wyświetlonych okresów;

Kopiuj do schowka - kopiuje bieżący okres do schowka okresów;

Wstaw ze schowka - wstawia okres ze schowka okresów;

Schowek okresów - pokazuje/ukrywa okno schowka okresów;

Wybierz datę początku lub początku i końca okresu z archiwum AsLogger - pozwala ustawić parametry okresu archiwum pochodzącego z programu AsLogger;

- przycisk uruchamia okno 'Opcje okresu trendu'.

***

Grupa Przesuwanie okresu:

Tryb żywy - uruchamia tryb rejestracji;

Ostatnie dane - pokazuje ostatnie (najświeższe dane) z wybranego okresu czasu;

Zmniejsz okres - powoduje zmniejszenie okresu następujące wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

Zwiększ okres - powoduje zwiększenie okresu następujące wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

Do początku danych - powoduje przesunięcie do początku przebiegu; polecenie dostępne dla wybranych rodzajów przebiegów (m.in. danych zewnętrznych, pliku archiwum Asix, przebiegów z AsBase);

Do tyłu o okres - powoduje przesunięcie o bieżący okres do tyłu;

Do tyłu - powoduje przesunięcie o ¼ okresu do tyłu;

Do przodu - powoduje przesunięcie o ¼ okresu do przodu;

Do przodu o okres - powoduje przesunięcie o bieżący okres do przodu;

Do końca danych - powoduje przesunięcie do końca przebiegu.


Zakładka Raport

1.7.1.4 Zakładka 'Raport'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Nowy przebieg:

Dane surowe - powoduje otwarcie okna dodawania zmiennej agregowanej,

Wyliczany - powoduje otwarcie okna 'Dodaj przebieg wyliczany’, które umożliwia dodanie do raportu zmiennej, która jest wyliczana z innych zmiennych za pomocą podanego wyrażenia;

Pozostałe przebiegi:

Dane zewnętrzne - powoduje pobranie wartości zmiennych z plików zewnętrznych;

Serwer OPC - HDA - powoduje pobranie wartości zmiennych z serwera OPC-HDA; opcja dostępna przy rozszerzonej licencji klucza HASP pakietu Asix;

Usuń zaznaczony - usuwa aktualnie wybraną zmienną.

***

Grupa Typ i okres danych raportu:

- umożliwia wybranie typu raportu; dostępne typy:

- raport roczny wg miesięcy,

- raport roczny wg tygodni,

- raport roczny wg dni,

- raport kwartalny wg miesięcy,

- raport kwartalny wg dni,

- raport miesięczny wg dni,

- raport miesięczny wg godzin,

- raport tygodniowy wg dni,

- raport tygodniowy wg godzin,

- raport dobowy wg godzin,

- raport zmianowy wg godzin,

- raport dowolny - wybranie tego typu wyświetla w grupie poleceń dodatkowe pola: Długość i Interwał, za pomocą których użytkownik może sam określić typ raportu;

W zależności od ustawienia typu raportu w grupie poleceń wyświetlane są dodatkowe pola, umożliwiające doprecyzowanie wybranego typu:

, [image], [image], [image], [image];

Do tyłu o okres - powoduje przesunięcie o bieżący okres do tyłu;

Do przodu o okres - powoduje przesunięcie o bieżący okres do przodu;

Do końca danych - powoduje przesunięcie do końca przebiegu.

***

Grupa Operacje raportu:

Opcje - powoduje uruchomienie okna 'Opcje raportu' umożliwiającego zdefiniowanie wyglądu raportu, układu i wyglądu strony raportu;

Pokaż brzeg strony - pokazuje linię prawego brzegu strony raportu;

Podgląd wydruku - załącza okno podglądu wydruku;

Eksport - umożliwia wyeksportowanie raportu do pliku jednego z trzech formatów:

- plik tekstowy,

- HTML,

- XLSX.


Zakładka 'Dane'

1.7.1.5 Zakładka 'Dane'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Połączenie z archiwum:

Asix - zmienne i alarmy - otwiera bazę definicji zmiennych i alarmów oraz umożliwia zadeklarowanie atrybutu, który automatycznie będzie określał nazwę przebiegu dla nowo dodawanych przebiegów; polecenie wyświetla również listę ostatnio otwieranych baz definicji zmiennych;

Asix AsBase - połączenie z bazą aplikacji AsBase;

Asix AsLogger - połączenie z bazą programu AsLogger;

OPC HDA - zmienne - otwiera okno z parametrami połączenia z serwerem OPC HDA;

***

Grupa Dane wejściowe:

Oryginalne - powoduje pobieranie dokładnie takich danych, jakie zostały określone w opcjach przebiegu (zakładka Przebieg okna głównego AsTrend > grupa Przebieg > okno 'Opcje przebiegu' uruchamiane przyciskiem [image] > zakładka Dane);

Równomierne - powoduje pobieranie danych zagregowanych, gdzie okres próbkowania jest stały; umożliwia też zmianę okresu próbkowania poleceniem Ustaw okres próbkowania;

Uśrednione - powoduje pobieranie danych uśrednionych; dla krótkich okresów czasu pobierane są dane oryginalne, dla długich okresów czasu pobierane są agregaty - wartości uśrednione; moment przejścia z danych oryginalnych na agregaty oraz okres agregacji są dobierane automatycznie;

Przybliżone - powoduje pobieranie danych przybliżonych; dla krótkich okresów czasu pobierane są dane oryginalne, dla długich okresów pobierane są dwa agregaty: wartości minimalne i wartości maksymalne; moment przejścia z danych oryginalnych na agregaty oraz okres agregacji dobierane są automatycznie.

Odśwież dane - ponownie pobiera dane i odrysowuje wykres;

Serwer danych - wyświetla informacje na temat aktualnego serwera danych wybranego przebiegu;

- przycisk uruchamia okno 'Opcje danych wejściowych trendu' z możliwością definiowania wybranych opcji.

***

Grupa Eksport danych:

Kopiuj do schowka - kopiuje dane i umieszcza je w schowku systemu Windows; takie dane można bezpośrednio wkleić np. w programie Excel.

Eksportuj do CSV - eksportuje dane do pliku w postaci tabelarycznej;

- przycisk otwiera okno 'Opcje eksportu danych', które umożliwia ustawienie parametrów eksportu danych do schowka lub pliku tekstowego.


Zakładka Trend i tabela

1.7.1.6 Zakładka Trend i legenda

Zakładka pozwala na wykonanie następujących operacji:

Grupa Trend:

Paleta kolorów - umożliwia wybór palety kolorów dla dodawanych przebiegów; dostępna jest lista predefiniowanych palet, paleta własna użytkownika oraz domyślna paleta programu;

Czcionka trendu - umożliwia wybór czcionki (kroju, rozmiaru i atrybutu: pogrubienie, kursywa lub podkreślenie) dla czcionki używanej w legendzie, w opisie osi wykresu, tytule i legendzie w obszarze wykresu oraz etykietach przebiegów;

- przycisk uruchamia okno 'Opcje trendu' z możliwością definiowania wyglądu, palety kolorów przebiegów, parametrów legendy i opcji wydruku dla trendu.

Grupa Legenda:

Kolumny legendy - umożliwia wybór kolumn legendy;

Kolor - umożliwia określenie koloru tła wierszy legendy;

Wysokość - umożliwia określenie wysokości legendy liczonej w ilości wyświetlonych wierszy;

- przycisk uruchamia okno 'Opcje trendu' z możliwością definiowania wyglądu, palety kolorów przebiegów, parametrów legendy i opcji wydruku dla trendu.

Grupa Operacje legendy:

Eksportuj legendę - eksportuje legendę do pliku; dostępne formaty pliku: XLS, HTML, tekstowy lub umożliwia wstawienie do schowka w formacie tekstowym.

Przywróć nagłówki - po zmianie opisów nagłówków przez użytkownika, polecenie pozwala przywrócić domyślne opisy dla wszystkich wyświetlonych nagłówków.

Aktualizuj atrybuty - umożliwia aktualizację wartości atrybutów przebiegów z bazy definicji zmiennych.


Zakładka 'Wykres'

1.7.1.7 Zakładka 'Wykres'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Typ wykresu:

Wykres XT - umożliwia wyświetlenie wykresów, których wartości pomiarowe przebiegu rysowane są w funkcji czasu;

Wykres XY - umożliwia wyświetlenie wykresów będących funkcją dwóch zmiennych;

Wykres X - umożliwia wyświetlenie wykresów, których wartości pomiarowe przebiegu rysowane są w kolejności zarejestrowania, bez względu na czas lub wartość innej zmiennej;

- przycisk uruchamia okno 'Opcje wykresu'.

***

Grupa Osie:

Jedna oś OY - wyświetlenie jednej osi fizycznej OY;

Wiele osi OY - wyświetlenie osobnych osi pionowych dla każdej zmiennej;

Wiele osi OY - stos - wyświetlenie osobnych osi pionowych dla każdej zmiennej; osie znajdują się jedna nad drugą;

Oś procentowa - wyświetlenie osi procentowej;

Osie i siatka - wyświetlenie listy z parametrami umożliwiającymi:

- włączenie/wyłączenie widoczności osi;

- określenie koloru osi i tym samym tekstu etykiet osi;

- włączenie stałego układu wykresu;

- włączenie/wyłączenie widoczności siatki;

- określenie formatu wyświetlania linii siatki: punkty lub linia ciągła;

- określenie koloru linii/punktów siatki;

- przycisk uruchamia okno 'Opcje wykresu'.

***

Grupa Powiększanie:

Powiększanie - pozwala załączyć tryb pracy z programem AsTrend umożliwiający powiększanie i zmianę widocznego obszaru wykresu przy pomocy myszy i poleceń wstążki; fragment wykresu można powiększyć kółkiem myszy (po powiększeniu wykresu można go uchwycić myszką i przesunąć);

Powiększ - powiększenie wykresu;

Pomniejsz - pomniejszenie wykresu;

Przywróć oryginał - przywrócenie oryginalnego rozmiaru wykresu;

***

Grupa Wygląd:

Tło panelu wykresu - pozwala określić kolor i gradient tła trendu; jest to obszar pod obszarem wykresu i wokół obszaru wykresu. Tło trendu widoczne jest w całości, gdy wyłączone zostanie kolorowanie tła obszaru wykresu.

Tło wykresu - pozwala określić kolor i gradient tła obszaru wykresu; możliwy wariant, w którym tło obszaru wykresu jest elementem niewidocznym;

Tytuł wykresu - tytuł w obszarze wykresu;

Legenda na wykresie - pozwala załączyć wyświetlanie uproszczonej wersji legendy w obszarze wykresu; legenda ta zawiera nazwy przebiegów;

3D - włącza postać 3D wykresu;

- przycisk uruchamia okno 'Opcje wykresu'.

***

Grupa 3D (dostępna po włączeniu opcji 3D):

Parametry 3D - umożliwia wybór pomiędzy rzutem prostokątnym a widokiem 3D;

- widok 3D podlega manipulacji w przestrzeni z użyciem parametrów: obrót, pochylenie, perspektywa, powiększenie, głębia oraz widok: z przodu, z prawej i z lewej;

- rzut prostokątny podlega parametryzacji z użyciem parametrów: kąt, głębia oraz widok: rzut prostokątny z prawej (domyślny), rzut prostokątny z lewej;

Lewa ściana - pozwala określić kolorystykę, gradient i ramkę dla lewej ściany w wersji wykresu: 3D lub Rzut prostokątny; możliwy wariant, w którym lewa ściana wykresu jest elementem niewidocznym;

Prawa ściana - pozwala określić kolorystykę, gradient i ramkę dla prawej ściany w wersji wykresu: 3D lub Rzut prostokątny; możliwy wariant, w którym prawa ściana wykresu jest elementem niewidocznym;

Dolna ściana - pozwala określić kolorystykę, gradient i ramkę dla dolnej ściany w wersji wykresu: 3D lub Rzut prostokątny; możliwy wariant, w którym dolna ściana wykresu jest elementem niewidocznym;

***

Grupa Linie odczytu:

Główna - wyświetlenie jednej linii odczytu;

Dodatkowa - wyświetlenie dodatkowej linii odczytu;

- uruchamia okno opcji linii odczytu; umożliwia ustawienie położenia obu linii odczytu wraz z opcją zachowywania się linii odczytu w trybie rejestracji; dodatkowo, okno umożliwia wybór atrybutów legendy pokazywanych razem z główną linią odczytu.

***

Grupa Eksport wykresu:

Kopiuj do schowka - tworzy kopię przebiegu i wstawia do schowka w postaci bitmapy;

Zapisz do pliku BMP - eksportuje wykres do pliku BMP; polecenie zablokowane w trybie operatora;


Zakładka Przebieg

1.7.1.8 Zakładka 'Przebieg'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Przebieg:

Liniowy - ustawia liniowy rodzaj wykresu;

Słupkowy - ustawia słupkowy rodzaj wykresu;

Obszarowy - ustawia słupkowy rodzaj wykresu;

Punkty - wyświetla punkty pomiarowe dla wybranych krzywych; opcja nie obsługiwana dla wykresu słupkowego;

Etykiety - wyświetla etykiety dla wybranych krzywych;

Interpolacja schodkowa - załącza interpolację schodkową wybranych krzywych; opcja nie obsługiwana dla wykresu słupkowego;

Grubość linii - ustawia grubość linii wskazanego przebiegu;

Przezroczystość - ustawia przeźroczystość wykresu przebiegu;

Własny kolor - włącza własny kolor serii z możliwością wyboru koloru;

Skala gradientu - dotyczy wykresów słupkowego i obszarowego; zakres od -100 do 100; wartości większe od 0 rozjaśniają wykres a wartości mniejsze od 0 przyciemniają wykres; wartość 0 oznacza brak gradientu;

Balans gradientu - dotyczy wykresów słupkowego i obszarowego; zakres od 0 do 100; przesuwa gradient wykresu w górę lub w dół; wartość domyślna 50 oznacza gradient równomierny;

Linia bazowa - dotyczy wykresu obszarowego; pozwala ustawić linię bazową dla wykresu na poziomie zadanej wartości zmiennej;

Odwrócenie gradientu - dotyczy wykresów: słupkowego i obszarowego; zamienia miejscami początkowy i końcowy kolor gradientu;

Głębokość przebiegu - dotyczy wykresu w trybie 3D; zmienia głębokość przebiegu w zakresie od 5% do 100%;

Szerokość słupka - dotyczy wykresu słupkowego; zmienia szerokość słupka wykresu w zakresie od 5% do 100%;

Przesunięcie słupka - dotyczy wykresu słupkowego; przesuwa słupek w poziomie w zakresie od -100% do 100%;

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala wybrać kształt znacznika graficznego;

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala określić wielkość znaczników graficznych;

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala załączyć ramkę znacznikom graficznym;

Dane z głównego okresu czasu - powoduje, że przebieg zawiera dane pobrane z okresu określonego przez główną oś czasu;

Dane z dodatkowego okresu czasu - powoduje, że przebieg zawiera dane pobrane z okresu określonego przez dodatkową oś czasu;

Liniowa podziałka osi - oznacza zastosowanie liniowej podziałki dla osi pionowej;

Logarytmiczna podziałka osi - oznacza zastosowanie logarytmicznej podziałki dla osi pionowej; oś może mieć podziałkę logarytmiczną tylko wtedy, gdy zakres minimalny i maksymalny jest większy od zera;

Oś po lewej stronie wykresu - dla wykresów z wieloma osiami OY; oś może być usytuowana z lewej strony wykresu;

Oś po prawej stronie wykresu - dla wykresów z wieloma osiami OY; oś może być usytuowana z prawej strony wykresu;

Oś pionowa w tym samym wierszu co oś poprzedniego przebiegu - tylko dla wykresów Wiele osi OY - stos; polecenie umożliwia rysowanie przebiegu na jednym wykresie w parze z sąsiadującym przebiegiem;

Oś pionowa w nowym wierszu - tylko dla wykresów Wiele osi OY - stos; polecenie umożliwia rozdzielenie przebiegów rysowanych na wspólnym wykresie;

Opcje przebiegu - uruchamia okno umożliwiające definiowanie opcji przebiegu;

Atrybuty przebiegu - wyświetla aktualne wartości atrybutów z bazy definicji zmiennych;

- przycisk uruchamia okno 'Opcje przebiegu'.

***

Grupa Położenie przebiegu:

Ukryty - ukrywa przebieg wybranej zmiennej;

- powoduje wyświetlenie przebiegu na wykresie głównym;

- powoduje wyświetlenie przebiegu na wykresie drugim;

- powoduje wyświetlenie przebiegu na wykresie trzecim;

- powoduje wyświetlenie przebiegu na wykresie czwartym;

***

Grupa Operacje przebiegu:

Opcje źródła danych przebiegu - otwiera okno umożliwiające definiowanie opcji źródła danych przebiegu;

Kopiuj - tworzy kopię przebiegu;

Zamień na pusty - zamienia wybrany w legendzie przebieg na pusty wiersz;

Przesuń w górę - powoduje w legendzie wykresu przesunięcie wiersza wskazanego przebiegu o jeden w górę;

Przesuń w dół - powoduje w legendzie wykresu przesunięcie wiersza wskazanego przebiegu o jeden w dół;

Zaznacz wszystkie - zaznacza wszystkie przebiegi;


Zakładka 'Tabela'

1.7.1.9 Zakładka 'Tabela'

Zakładka użyteczna po przełączeniu się (przyciskiem Tabela danych [image] z zakładki Widok) na tryb wyświetlania danych bieżących w postaci tabeli. Pozwala na wykonanie następujących operacji:

Grupa Kolumny:

Pojedyncza kolumna czasu - włącza tryb widoku tabeli zawierający jedyną wspólną kolumnę czasu i wiele kolumn wartości.

Kolumny jakości - włącza tryb widoku tabeli zawierający kolumny jakości;

***

Grupa Zaczepienie kursora:

Bez zaczepienia - zmiana aktywnego wiersza w tabeli nie będzie powodowała zmiany pozycji linii odczytu;

Do głównej linii odczytu - zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji głównej linii odczytu. Opcja ma znaczenie tylko jeśli główna linia odczytu jest włączona;

Do dodatkowej linii odczytu - zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji dodatkowej linii odczytu. Opcja ma znaczenie tylko jeśli dodatkowa linia odczytu jest włączona.

***

Grupa Rekordy:

Próbki wg osi czasu - załącza wariant, w którym próbki wszystkich przebiegów są ułożone wg osi czasu;

Próbki jedna za drugą - załącza wariant, w którym próbki wszystkich przebiegów są ułożone jedna za drugą;

***

Grupa Informacje:

Dane - wyświetla informacje o rodzaju danych w tabeli i jak one są wyświetlane;

***

Grupa Wygląd:

Kolor tła wspólnych kolumn tabeli - ustawia kolor tła kolumn Lp. i pojedynczej kolumny Czasu;

Kolor tła panelu tabeli - ustawia kolor tła panelu tabeli;

- uruchamia okno 'Opcje trendu' ze wskazaniem zakładki Tabela, umożliwiającej definiowanie powyższych dwóch parametrów grupy Wygląd.


Zakładka 'Widok'

1.7.1.10 Zakładka 'Widok'

Menu pozwala na wykonanie następujących operacji:

Grupa Okno:

Blokada rozmiarów okna - blokuje możliwość zmiany rozmiaru okna trendów,

- przycisk uruchamia okno 'Opcje okna trendu'.

***

Grupa Panele:

Wykres 2 - włącza/wyłącza wyświetlenie w oknie trendów obszaru dodatkowego wykresu 2,

Wykres 3 - włącza/wyłącza wyświetlenie w oknie trendów obszaru dodatkowego wykresu 3,

Wykres 4 - włącza/wyłącza wyświetlenie w oknie trendów obszaru dodatkowego wykresu 4,

Legenda - włącza/wyłącza wyświetlenie w oknie trendów legendy,

Tabela danych - wywołuje/ukrywa tabelę danych,

Schowek okresów - wyświetla okno schowka okresów,

Resetuj układ paneli - przywraca układ paneli sprzed operacji dokowania przeprowadzonych od momentu otwarcia okna programu AsTrend lub otwarcia pliku trendu posiadającego swój własny zapisany układ okien.

***

Grupa Styl:

Wstążka - uruchamia listę dostępnych opcji kolorystycznych wstążki oraz opcję resetowania układu przycisków;

Akcent kolorystyczny wstążki - zmienia kolor zakładki Plik;

Resetuj układ przycisków - przywraca układ przycisków z momentu otwarcia okna programu AsTrend; polecenie dostępne dla administratora programu AsTrend;

Układ przycisków Operatora - opcja dostępna, gdy AsTrend uruchamiany jest razem z aplikacją Asixa i zalogowany jest użytkownik z uprawnieniami administratora programu AsTrend; komenda ładuje układ wstążki użytkownika 'Operator'. Aby administrator mógł powrócić do swojego układu wstążki, musi wyłączyć przycisk Układ przycisków Operatora. Polecenie dostępne dla administratora programu AsTrend.

***

Grupa Bezpieczeństwo - grupa dostępna, gdy AsTrend uruchamiany jest razem z aplikacją systemu Asix:

Tryb administratora - przełącza program na tryb administratora,

Zmiana hasła administratora - uruchamia okno zmiany hasła administratora.


Zakładka 'Pomoc'

1.7.1.11 Zakładka 'Pomoc'

Zakładka pozwala na wykonanie następujących operacji:

Tematy pomocy - otwiera plik pomocy,

Tematy pomocy on-line - otwiera pomoc WebHelp,

O programie... - wyświetla informację o programie.


zakładka Schowek okresów

1.7.1.12 Zakładka 'Schowek okresów'

Zakładka pozwala na wykonanie następujących operacji:

Grupa Schowek okresów:

Kopiuj do schowka - kopiuje bieżący okres do schowka okresów;

Wstaw ze schowka - wstawia okres ze schowka okresów;

Skasuj zawartość całego schowka - usuwa zapamiętane przebiegi zmiennych;


Zarzadzanie ukladem przyciskow i paskow narzedzi

1.7.1.13 Niezależne układy Wstążki

W trybie pracy z aplikacją systemu Asix w wersji klasycznej program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla Administratora i Operatora. Osobno pamiętany jest układ Wstążki dla operatora i administratora.

Jedynie Administrator ma możliwość definiowania układu menu / pasków narzędzi - dla siebie jak również dla Operatora.

***

W trybie pracy z aplikacją systemu Asix w wersji klasycznej z użytkownikami, których uprawnienia definiowane są w programie AsAudit, program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w programie AsAudit.

***

Podczas pracy z aplikacją systemu Asix w wersji Evo program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w konfiguracji systemu zabezpieczeń.

***

W przypadku niezależnej pracy programu AsTrend niezależny układ menu / pasków narzędzi definiowany jest dla poszczególnych użytkowników systemu operacyjnego.


Obszar wykresow

1.7.2 Obszar wykresów

Obszar wykresu mieści się poniżej paska narzędzi.

Rysunek: Obszar wykresów.

Bezpośrednio w polu wykresów można wykonywać operacje:

  • zmiana okresu wyświetlenie danych,

  • odczyt wartości i czasu,

  • przesuwanie w obszarze wykresów linii odczytu wartości w wybranych punktach przebiegów,

  • powiększanie zaznaczonego obszaru,

  • selekcja jednej zmiennej,

  • zmiana parametrów wyświetlania osi OY,

  • wywoływanie funkcji umieszczonych w kontekstowym menu.


Legenda2

1.7.3 Legenda

Obszar legendy umieszczony jest poniżej obszaru wykresów.

W przypadku, gdy nie ma zadeklarowanej żadnej serii, legenda wyświetlana jest jako nagłówek z miejscem na jeden wiersz danych, gdzie pojawia się napis: ’brak danych do wyświetlenia’.

Wysokość legendy jest zaokrąglana do pełnych wierszy. Użytkownik ma możliwość zmiany wysokości legendy.

Dodatkowo, wprowadzone zostało zabezpieczenie uniemożliwiające przekroczenie przez obszar legendy powierzchni ¾ okna głównego AsTrend. W sytuacji, gdy obszar legendy jest większy od ¾ okna głównego trendów - pojawia się pasek przewijania.

Legenda może zawierać następujące rodzaje pól:

1. Agregaty

2. Trend

3. Linia odczytu

4. Baza definicji zmiennych - standardowe

5. Baza definicji zmiennych - niestandardowe (zadeklarowane przez użytkownika)

Domyślnie nazwy i parametry zmiennych wyświetlane w poszczególnych wierszach legendy mają kolory odpowiadające kolorom na wykresie. Istnieje też możliwość zmiany koloru wierszy na czarny - niezależnie od kolorów przebiegów na wykresie (więcej w: 2.10 Operacje dostępne w obszarze legendy).

UWAGA: Prawidłowe wyświetlanie legendy po otwarciu pliku trendu możliwe jest również w sytuacji, kiedy nie ma dostępu do bazy definicji zmiennych. Przy dodawaniu nowej zmiennej do trendu czytane są z bazy definicji zmiennych wszystkie atrybuty zmiennej i są przechowywane w pliku.

Rys. Legenda.


Pasek statusu

1.7.4 Pasek statusu

Pasek statusu umieszczony jest poniżej obszaru legendy. Jest on zawsze widoczny. Przykładowy pasek statusu umieszczony został poniżej.

Rys. Pasek statusu.


Wiele wykresów

1.7.5 Wiele okien wykresów w jednej instancji programu AsTrend

AsTrend daje możliwość wyświetlenia jednocześnie do 4 wykresów, z czego pierwszy wykres jest wykresem głównym i zawsze widocznym. Przebiegi mogą być zatem rysowane na dowolnym z 4 wykresów. Istnieje tez pełna swoboda w przenoszeniu i kopiowaniu przebiegów między wykresami.

Wykresy wyświetlane są w indywidualnych oknach z pełną obsługą dokowania.

Dla każdego z wykresów istnieje możliwość zdefiniowania indywidualnych opcji.

Wykresy zawsze drukowane są w liczbie 1, 2 lub 4 na 1 stronie wydruku. (W przypadku 3 wyświetlonych wykresów, liczba wykresów na wydruku wynosi 4.)

powiększ >>

Rys. AsTrend z 4 wykresami.

powiększ >>

Rys. Podgląd wydruku 4 wykresów w 1 trendzie (jeden z wykresów nie ma dodanego przebiegu).


Typy danych

1.8 Rodzaje danych przebiegów

Przebiegi prezentowane na wykresie trendu mogą pochodzić z następujących źródeł:

- aplikacja systemu Asix:

- surowa zmienna procesowa;

- zmienna zagregowana;

- bit zmiennej;

- alarm - alarm (z aplikacji systemu Asix wersji klasycznej), którego archiwum zdarzeń przechowywane jest w plikach binarnych, a definicja w plikach tekstowych lub w bazie definicji zmiennych (mdb lub MS SQL);

- alarm SQL - alarm (z aplikacji systemu Asix wersji klasycznej lub wersji Evo), którego archiwum zdarzeń przechowywane jest w bazie MS SQL, a definicja w bazie definicji zmiennych (mdb lub MS SQL);

- archiwum Asix - czyli zmienna/zmienne, której dane wyeksportowane zostały programem AspadTools;

- zmienna wyliczana z innych rzeczywistych zmiennych za pomocą podanego wyrażenia;

- zewnętrzne źródło danych;

- serwer OPC-HDA;

- moduł AsBase - przebieg z pola zestawu rejestracji z bazy danych modułu AsBase;

- moduł AsLogger - przebieg z planu rejestracji z bazy danych modułu AsLogger;

- stała;

- pusty przebieg - używany jako separator w legendzie i w trybie tabeli danych historycznych.

Każda zmienna może być traktowana jako zmienna analogowa lub binarna.

Każdy alarm traktowany jest na wykresie jako zmienna binarna. Posiada on osobną pozycję w legendzie i osobną oś OY ponad wykresem analogów.

Przykład wykresu alarmów:

powiększ >>

Rysunek: Wykres alarmów (kolor czerwony - alarm, którego zdarzenia umieszczone są w plikach binarnych; kolor zielony - alarm, którego zdarzenia pochodzą z bazy MS SQL).

Przykłady wykresów przebiegów z bazy AsBase:

powiększ >>

Rys. Wykres (1) przebiegu z bazy AsBase.

powiększ >>

Rys. Wykres (2) przebiegu z bazy AsBase.

Przykład wykresu przebiegu z bazy AsLogger:

powiększ >>

Rys. Wykres przebiegu z bazy AsLogger.


Typ wykresu ze względu na typ osi

1.9 Typ wykresu zależny od typu osi

AsTrend rozróżnia następujące typy osi:

- oś fizyczna,

- oś procentowa,

- wiele osi OY,

- wiele osi OY - stos,

- wykres XY,

- wykres X.

Zastosowanie poszczególnych typów osi ilustrują kolejne rozdziały.


Wykres z osią fizyczną

1.9.1 Wykres z osią fizyczną

Wykres z osią fizyczną jest domyślnym wykresem. Oś wartości OY wyświetla rzeczywiste wartości przebiegu w zakresie, który może być ustalany przez operatora.

Przy użyciu zakresu wyświetlania wartości przebiegu istnieje możliwość przeskalowania osi fizycznej. W szczególności oznacza to, że minimum i maksimum zakresu wyświetlania na osi fizycznej OY przyjmują wartości wynikające z zakresu wyświetlania przebiegu (wartości te pobierane są z bazy definicji zmiennych, ale mogą być tez indywidualnie ustalane w programie AsTrend). W przypadku wyświetlenia kilku przebiegów, przy skalowaniu osi fizycznej brane są pod uwagę zakresy wyświetlania wszystkich przebiegów. W przypadku zdefiniowania zakresów wyświetlania przebiegów na poziomie 0-0 zakres wyświetlania na osi OY wyliczany jest na podstawie bieżących wartości próbek przebiegu. Istnieje tez możliwość określenia na sztywno stałej wartości minimum oraz maksimum osi fizycznej.

Również przy użyciu zakresu pomiarowego wartości przebiegu istnieje możliwość przeskalowania osi fizycznej. W szczególności oznacza to, że minimum i maksimum zakresu wyświetlania na osi fizycznej OY przyjmują wartości wynikające z zakresu pomiarowego przebiegu (wartości te pobierane są z bazy definicji zmiennych, ale mogą być tez indywidualnie ustalane w programie AsTrend).

Dla wykresów z osia fizyczna program AsTrend daje również możliwość wyświetlania opisów stanów jako etykiet osi wartości dla wykresów fizycznych.

powiększ >>

Rysunek: Wykres z osią fizyczną.

powiększ >>

Rys. Opisy stanów jako wartości osi OY.


Wykres z osią procentową

1.9.2 Wykres z osią procentową

W wykresach z osią procentową oś wartości OY przeniesiona zostaje na prawą stronę obszaru wykresu, natomiast po lewej stronie obszaru wykresu wyświetlona zostaje oś procentowa w skali 0-100%.

Wykres procentowy wyświetla prawą oś dla pierwszego wybranego przebiegu analogowego.

powiększ >>

Rysunek: Wykres z osią procentową.


Wykres z wieloma osiami OY

1.9.3 Wykres z wieloma osiami OY

Wykres z wieloma osiami wartości OY pozwala wyświetlić indywidualną oś wartości dla każdego przebiegu. Oś przyjmuje kolor danego przebiegu i może być wyświetlona po lewej lub prawej stronie obszaru wykresu.

powiększ >>

Rysunek: Wykres z wieloma osiami OY.


Wykres z wieloma osiami OY - stos

1.9.4 Wykres z wieloma osiami OY - stos

Wykres z wieloma osiami wartości OY pozwala wyświetlić indywidualną oś wartości dla każdego przebiegu. Oś przyjmuje kolor danego przebiegu i wyświetlana jest po lewej lub prawej stronie obszaru wykresu.

Dodatkowo, dla wykresu Wiele osi OY - stos dodana została opcja umożliwiająca wyświetlanie przebiegów sąsiednich zmiennych na wspólnym wykresie. Taki wykres opisany jest przy pomocy wielu osi OY (w zależności od tego, ile sąsiednich przebiegów połączymy na wspólnym wykresie) umieszczonych po lewej lub prawej stronie wykresu.

powiększ >>

Rysunek: Wykres z wieloma osiami OY - stos.

powiększ >>

Rys. Wykres z wieloma osiami OY - stos z dwoma przebiegami na wspólnym wykresie.


Wykres X-Y

1.9.5 Wykres X-Y

Istnieje możliwość tworzenia wykresów będących funkcją dwóch zmiennych systemu Asix, np. wykresy typu ”punkt pracy”. Dla każdego punktu na wykresie może być wyświetlana etykieta. Etykieta ta może zawierać:

- stempel czasu punktu,

- numer punktu serii,

- wartości próbek.

powiększ >>

Rysunek: Wykres X-Y.

powiększ >>

Rysunek: Okno 'Opcje wykresu'> zakładka 'Typ' - definicja zawartości etykiet wykresu XY.


Wykres X

1.9.6 Wykres X

Wykres X daje możliwość zaprezentowania różnych wartości zmiennej (niezależnie od czasu czy innej zmiennej) w kolejności ich zarejestrowania. Pozioma oś zawiera indeksy próbek zamiast stempli czasu - próbki indeksowane są od 1.

Rys. Wykres X.


Typ wykresu ze względu na typ przebiegu

1.10 Typ wykresu zależny od typu/wyglądu przebiegu

W programie AsTrend dostępne są następujące typy wykresów ze względu na wygląd przebiegu:

  • liniowy,

  • słupkowy,

  • obszarowy,

  • zmiennych dwustanowych.

Jeden z typów wykresów (domyślnie liniowy) jest stale wybrany ii służy jako typ podczas dodawania kolejnych zmiennych do trendu. Wybór ten można w każdej chwili zmienić.

Możliwa jest również zmiana typu wykresu już istniejącego. W tym celu należy najpierw wyselekcjonować zmienną, której typ wykresu chcemy zmienić, a następnie nacisnąć jeden z przycisków zmieniających typ.

Każdy z wymienionych typów wykresów może być wyświetlany również w trybie 3D.


Agregacja danych systemu Asix

1.11 Agregacja danych systemu Asix

Czas odrysowania wykresu może być przyspieszony poprzez zastosowanie w systemie Asix archiwizacji agregatów danych archiwalnych, bez konieczności dokonywania przez operatora programu AsTrend jakichkolwiek ustawień w programie. Wykresy odrysowywane są w pierwszej kolejności z wartości zagregowanych pobieranych z archiwum serwera Asix, a w przypadku braku takiego archiwum - z agregatów wyliczanych na bieżąco.

AsTrend automatycznie sam dobiera okres agregatu i początek wyświetlania danych do horyzontu wyświetlanego wykresu. Przykładowo, jeśli zarchiwizowane agregaty liczone były od godziny 13:00 z okresem wynoszącym 1 godzina, a użytkownik zadeklaruje horyzont wyświetlania danych zaczynający się od godziny 13:05 - AsTrend dobierze do wykresu agregaty najbliżej odpowiadające horyzontowi czasu zadanemu przez użytkownika, czyli w tym przypadku wyliczane od godziny 13:00.

Parametryzacja wyliczania i archiwizacji agregatów wykonywana jest przez administratora lub projektanta aplikacji systemu Asix w oknie konfiguratora systemu Asix - programie Architekt.


Agregaty - nowe źródło analiz danych statystycznych

1.11.1 Agregaty - źródło analiz danych statystycznych

Dla potrzeb efektywnych analiz użytkownik programu AsTrend ma dostęp do obszernego zestawu wartości agregowanych na żądanie dla wszystkich danych z dowolnego horyzontu czasu. Zestaw agregatów obejmuje następujące pozycje:

- Wartość minimalna - minimalna wartość w interwale

- Wartość maksymalna - maksymalna wartość w interwale

- Całka - suma wartości ważonych czasowo w interwale (całka po czasie)

- Całka (ostatnia znana) - suma wartości ważonych czasowo w interwale (całka po czasie); w miejsce złych wartości wstawia ostatnią znaną wartość

- Całka 0 - suma wartości ważonych czasowo (całka po czasie); w okresach, w których próbka ma jakość złą do obliczeń używana jest wartość 0

- Czas_Max - stempel czasu maksymalnej wartości w interwale

- Czas Min - stempel czasu minimalnej wartości w interwale

- Jakość dobra - procent próbek o jakości dobrej w interwale

- Jakość dobra czas - czas trwania (w sekundach) czasu w interwale, w którym dane mają jakość dobrą

- Jakość niepewna - procent próbek o jakości niepewnej w interwale

- Jakość niepewna czas - czas trwania (w sekundach) czasu w interwale, w którym dane mają jakość niepewną

- Jakość zła - procent próbek o jakości złej w interwale

- Jakość zła czas - czas trwania (w sekundach) czasu w interwale, w którym dane mają jakość złą

- Odchylenie standardowe - ważone czasowo odchylenie standardowe w interwale próbkowania

- Ostatni - ostatnio znana wartość w interwale próbkowania wyłączając koniec interwału

- Poprzedni znany - ostatnio znana wartość przed rozpoczęciem interwału próbkowania

- Przyrost wartości - różnica wartości na końcu i na początku interwału

- Rozpiętość wartości - różnica między maksymalna a minimalna wartością w interwale

- Suma spadków - suma wartości ujemnych zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem interwału próbkowania

- Suma wzrostów - suma wartości dodatnich zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem interwału próbkowania

- Średnia kwadratowa - ważona czasowo średnia kwadratowa w interwale próbkowania

- Wartość końcowa- wartość na końcu interwału

- Wartość początkowa - wartość na początku interwału

- Wartość średnia - średnia wartości ważonych czasowo w interwale

- Wartość średnia (ostatnia znana) - średnia ważona czasowo w interwale próbkowania; w miejsce złych wartości wstawia ostatnią znaną wartość

- Wartość średnia 0 - średnia wartości ważonych czasowo w interwale; w okresach, w których wartość jest niedostępna, do obliczeń używana jest wartość 0.

Agregaty mogą być wykorzystywane do wyliczenia i wyświetlenia przebiegów wartości zagregowanych w zadanym horyzoncie czasu lub też wyliczenia wartości zagregowanych na podstawie danych z aktualnie wyświetlonego okresu i wyświetlenia tych wartości w polach legendy.

  • W pierwszym przypadku użytkownik sam określa rodzaj interesującego go agregatu używanego do czytania danych (niezależnie od typu danych prezentowanych na wykresie: dane oryginalne, równomierne, przybliżone i uśrednione) oraz okres agregatu, który jest podstawą wyliczania kolejnych wartości zagregowanych. Dzięki Agregatorowi (modułowi systemu Asix do wyliczania i archiwizacji danych statystycznych), dane wyliczane są przez serwer Asix, skąd pobiera je program AsTrend - dzięki temu ’gotowe’ dane statystyczne interesujące użytkownika dostarczane są w sposób szybki i efektywny.

  • W drugim przypadku wartości agregatów wyliczane są lokalnie przez program AsTrend dla wartości wyświetlonych na wykresie w ramach zadanego odcinka czasu (niezależnie od typu danych prezentowanych na wykresie: dane oryginalne, równomierne, przybliżone i uśrednione). Wgląd do tak wyliczonych agregatów umożliwiają kolumny wyświetlane w legendzie.


Tabela danych historycznych

1.12 Tryb tabeli danych historycznych

Program AsTrend umożliwia oglądanie danych historycznych w formie tabeli. Tryb pracy programu AsTrend w formie tabeli danych historycznych uruchamiany jest jednym przyciskiem, który umożliwia przełączenie programu na interfejs przeznaczony do obsługi tabeli.

Tryb tabeli danych historycznych zapisywany jest w pliku *.trnx trendu przez osobę zalogowaną jako administrator programu AsTrend. Otwarcie tego pliku przez osobę z uprawnieniami operatora powoduje przełączenie programu AsTrend w tryb tabeli danych historycznych i wyświetlenie w niej zdefiniowanych przez administratora zmiennych i kolumn.

Każdy rekord tabeli prezentuje wartości wybranych atrybutów zmiennej wraz z jej wartością na zadany punkt czasu. Poruszanie się po wartościach zmiennych z różnych punktów czasu umożliwiają przyciski nawigacyjne.

powiększ >>

Rysunek: AsTrend - tryb tabeli danych historycznych.


Raporty

1.13 Raporty

Program AsTrend posiada funkcję tworzenia ad-hoc raportów tabelarycznych dla różnych okresów czasu (zmiana, doba, miesiąc, kwartał, rok, dowolny okres) i odpowiadających im domyślnym przedziałom czasowym (godzina, dzień, miesiąc). Łatwość tworzenia raportów w AsTrend przekona każdego użytkownika. Po wyborze zmiennych z okna podpowiedzi wystarczy wybrać raportowane wartości w postaci jednego z proponowanych agregatów. Dostępne są m.in. agregaty typu wartość minimalna/maksymalna, wartość początkowa/końcowa, przyrost w przedziale, średnia, całka. Możliwe jest też utworzenie raportu dla zmiennych wyliczanych w oparciu o archiwizowane przebiegi. Dla każdego raportu można swobodnie określić nagłówek i podsumowanie raportu (do pięciu wierszy), a gotowe raporty można drukować i eksportować do plików PDF.

powiększ >>

Rysunek: AsTrend - tryb raportu.


Obsluga programu

2. AsTrend - obsługa

Obsługa programu AsTrend jest bardzo prosta. Typowe czynności to:

  • wyświetlanie definicji trendów,

  • operacje wykonywane na zdefiniowanych trendach,

  • drukowanie trendów,

  • definiowanie nowych trendów.

Definiowanie nowych trendów ułatwia wbudowany kreator trendów.


Startowanie i praca programu

2.1 Uruchamianie i praca programu

Uruchamianie programu AsTrend z aplikacją systemu Asix

Tryb pierwszy zakłada, że program AsTrend startowany jest przez system Asix. W trybie tym projektant aplikacji projektuje zestaw dostępnych trendów (a także tworzy bazę definicji zmiennych), a rola użytkownika zasadniczo ogranicza się do przeglądania zdefiniowanych trendów oraz wykonywania na nich operacji. W tym trybie użytkownik może zdefiniować własne trendy w określonym przez projektanta katalogu.

Program uruchomiany jest w trakcie ładowania aplikacji systemu Asix, dzięki specjalnemu parametrowi, który projektant aplikacji umieszcza w pliku konfiguracyjnym aplikacji:

- Szczegóły na temat konfiguracji parametrów startowych aplikacji klasycznej wersji systemu Asix można znaleźć w podręczniku dla modułu Architekt, rozdział 4.4.2. Deklaracja programów startowanych jednocześnie z aplikacją.

- Szczegóły na temat konfiguracji parametrów startowych aplikacji w wersji Evo systemu Asix w odniesieniu do programu AsTrend można znaleźć w podręczniku Asix.Evo - Parametryzacja aplikacji (PDF/CHM), rozdział 8. Współpraca z programem AsTrend.

Sposobem otwierania pliku trendu programu AsTrend z poziomu pracującej aplikacji jest wykonanie akcji operatorskiej:

- ASTREND, parametryzowanej przez projektanta aplikacji (w wersji klasycznej systemu Asix); Szczegóły: Asix - podręcznik użytkownika, rozdział 16.1. Opisy akcji operatorskich.

- AstrendDisplay, parametryzowanej przez projektanta aplikacji (w wersji Asix.Evo). Szczegóły: podręcznik Asix.Evo - Akcje operatorskie.

Uruchamianie programu AsTrend bez aplikacji systemu Asix

W drugim trybie zakłada się, że AsTrend wykorzystywany jest samodzielnie i startowany w dowolnym momencie przez użytkownika.

uwaga Możliwe jest uruchomienie wielu instancji programu AsTrend.

W tym trybie użytkownik sam decyduje, jakie trendy chce oglądać i zazwyczaj sam je definiuje.

Jako samodzielny program, AsTrend jest uruchamiany przy pomocy komendy:

Astrend.exe [definicja_trendu] [-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.


Dodawanie przebiegów przy otwieraniu pliku trendu

2.1.1 Dodawanie przebiegów przy otwieraniu pliku trendu

Użytkownik ma możliwość sam zadecydować, które trendy i jakie przebiegi będzie oglądać.

Aby dodać przebieg zmiennej z aplikacji systemu Asix, należy w komendzie uruchomiającej AsTrend podać nazwę zmiennej:

I wariant

Astrend.exe [definicja_trendu[#nazwa_zmiennej]] [-inazwa_pliku_bazy_mdb |

-inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL] [-dkartoteka] [-b]

II wariant - zakłada możliwość nadawania nowych wartości atrybutom dodawanych zmiennych w trakcie otwierania trendu

Astrend.exe [definicja_trendu[#/Aspad/nazwa_zmiennej;atrybut1=wartość1;atrybut2=wartość2;...]] [-inazwa_pliku_bazy_mdb | -inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL] [-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

Aspad -wskazuje na zmienną z aplikacji systemu Asix;

nazwa_zmiennej - nazwa zmiennej z aplikacji systemu Asix;

atrybut - nazwa atrybutu z bazy definicji zmiennych aplikacji systemu Asix;

wartość - nowa wartość atrybutu, jaką chce nadać użytkownik;

-inazwa_pliku_bazy_mdb - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie Jet;

-inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie MSSQL;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.

Aby dodać przebieg bitu zmiennej z aplikacji systemu Asix, należy w komendzie uruchomiającej AsTrend, po definicji trendu zastosować następującą składnię:

Astrend.exe [definicja_trendu[#/Aspad/nazwa_zmiennej/numer_bitu;atrybut1=wartość1;

atrybut2=wartość2;...]] [-inazwa_pliku_bazy_mdb | -inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL]

[-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

Aspad -wskazuje na zmienną z aplikacji systemu Asix;

nazwa_zmiennej - nazwa zmiennej z aplikacji systemu Asix;

numer_bitu - numer bitu, którego przebieg ma zostać wyświetlony;

atrybut - nazwa atrybutu z bazy definicji zmiennych aplikacji systemu Asix;

wartość - nowa wartość atrybutu, jaką chce nadać użytkownik;

-inazwa_pliku_bazy_mdb - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie Jet;

-inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie MSSQL;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.

Aby dodać przebieg agregatu zmiennej z aplikacji systemu Asix, należy w komendzie uruchomiającej AsTrend, po definicji trendu zastosować następującą składnię:

Astrend.exe [definicja_trendu[#/AspadAgg/nazwa_zmiennej/nazwa_agregatu/okres_agregacji;atrybut1=wartość1;

atrybut2=wartość2;...]] [-inazwa_pliku_bazy_mdb | -inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL]

[-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

Aspad -wskazuje na zmienną z aplikacji systemu Asix;

nazwa_zmiennej - nazwa zmiennej z aplikacji systemu Asix;

nazwa_agregatu - numer bitu, którego przebieg ma zostać wyświetlony;

okres_agregacji - interwał wyliczania agregatu, deklarowany w formacie OPC, np: 1MO+1M (1 miesiąc i jedna minuta);

atrybut - nazwa atrybutu z bazy definicji zmiennych aplikacji systemu Asix;

wartość - nowa wartość atrybutu, jaką chce nadać użytkownik;

-inazwa_pliku_bazy_mdb - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie Jet;

-inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL - jest opcjonalną nazwą pliku bazy definicji zmiennych w formacie MSSQL;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.

Aby dodać przebieg pola zestawu rejestracji AsBase, należy w komendzie uruchomiającej AsTrend, po definicji trendu zastosować następującą składnię:

Astrend.exe [definicja_trendu[#/AsBase/id_zestawu_rejestracji/id_pola_rejestracji;atrybut1=wartość1;

atrybut2=wartość2;...]] [-inazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL]

[-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

AsBase -wskazuje na dane z modułu AsBase;

id_zestawu_rejestracji - identyfikator zestawu rejestracji modułu AsBase;

id_pola_rejestracji - identyfikator pola z zestawu rejestracji, którego wartości mają być wyświetlone na wykresie AsTrend;

atrybut - nazwa atrybutu, którego wartość użytkownik chce zmienić, np. opis;

wartość - nowa wartość atrybutu, jaką chce nadać użytkownik;

-jnazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL - jest opcjonalną nazwą bazy modułu AsBase, z której mają pochodzić przebiegi;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.

Aby dodać przebieg punktu z planu rejestracji AsLogger, należy w komendzie uruchomiającej AsTrend, po definicji trendu zastosować następującą składnię:

Astrend.exe [definicja_trendu[#/AsLogger/nazwa_planu/nazwa_punktu;atrybut1=wartość1;

atrybut2=wartość2;...]] [-gnazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL]

[-dkartoteka] [-b]

gdzie:

definicja_trendu - jest opcjonalną nazwą pliku (z rozszerzeniem *.TRN lub *.TRNX wraz ze ścieżką względem aktualnego katalogu), zawierającego definicję trendu, który ma być wyświetlony po starcie programu;

AsLogger -wskazuje na dane z modułu AsLogger;

nazwa_planu - nazwa identyfikująca plan rejestracji przez moduł AsLogger serii pomiarowych;

nazwa_punktu - nazwa identyfikująca punkt pomiarowy definiowany w module AsLogger do zarejestrowania pomiarów z jednego wejścia urządzenia archiwizującego;

atrybut - nazwa atrybutu, którego wartość użytkownik chce zmienić, np. opis;

wartość - nowa wartość atrybutu, jaką chce nadać użytkownik;

-gnazwa_serwera_bazy_MSSQL/nazwa_bazy_MSSQL - jest opcjonalną nazwą bazy modułu AsLogger, z której mają pochodzić przebiegi;

-dkartoteka - jest opcjonalną nazwą kartoteki, z której czytane będą pliki typu *.trn przy pomocy okna 'Czytaj trend’- o ile podany został konkretny plik *.trn przy wywołaniu trendu. W przeciwnym wypadku po uruchomieniu programu automatycznie otworzy się okno 'Czytaj trend’ ze wskazaną w tym parametrze kartoteką;

-b - opcjonalny parametr pozwalający na zablokowanie zapisu definicji trendów.


Definiowanie hasła logowania administratora i sposób logowania

2.2 Definiowanie hasła i sposób logowania administratora

Logowanie Administratora

Przejście / logowanie w tryb administratora odbywa się za pomocą komendy [image] z zakładki Widok okna głównego AsTrend > grupy Bezpieczeństwo i wymaga wprowadzenia hasła.

Rysunek: Okno 'Podaj hasło’.

uwaga W momencie, gdy program AsTrend jest uruchamiany na danym komputerze po raz pierwszy, aby zalogować się w trybie administratora - wystarczy nacisnąć klawisz ENTER (po wywołaniu okna 'Podaj hasło’), a następnie ustanowić hasło logowania (zakładka Widok > grupa Bezpieczeństwo > polecenie Zmiana hasła administratora.

Zmiana hasła

Zmiany hasła można dokonać z poziomu zakładki Widok > grupa Bezpieczeństwo > polecenie [image] Zmiana hasła Administratora tylko w trybie administratora.

Rysunek: Okno 'Zmień hasło’.

Hasło przechowywane jest w rejestrze komputera.


Tworzenie skrótu uruchamiającego AsTrend

2.3 Tworzenie skrótu uruchamiającego AsTrend

Tworzenie skrótu przy użyciu programu Architekt:

W menu Plik dostępna jest komenda Utwórz skrót..., umożliwiająca tworzenie skrótów uruchamiających program AsTrend dla aktualnie otwartego w programie AsTrend pliku trendu. Polecenie dostępne dla AsTrend uruchamianego poza aplikacją Asixa.

Okno kreatora skrótów wymaga podania następujących parametrów:

- Utwórz w... - lokalizacja skrótu;

- Nazwa - nazwa skrótu;

Rysunek: Kreator skrótów AsTrend.


Konfiguracja wersji internetowej programu AsTrend

2.4 Konfiguracja wersji internetowej programu AsTrend

Plik z ustawieniami programu znajduje się domyślnie w katalogu:

C:\AsixApp\AsTrend\default.htm

Program Architekt umożliwia automatyczną konfigurację pliku ’default.htm’ na podstawie ustawień załadowanego pliku konfiguracyjnego aplikacji systemu Asix przy użyciu konfiguratora programu Architekt:

Architekt > menu Aplikacja > Konfiguruj aplikacje internetowe &ldots; > zakładka AsTrend

Automatyczny konfigurator zaktualizuje wpisy dotyczące nazwy bazy definicji zmiennych i adresu ip serwera danych. Plik bazy definicji zmiennych zostanie skopiowany do katalogu aplikacji.

Obsługa Konfiguratora sprowadza się do użycia dwóch przycisków:

Konfiguruj na zakładce Konfiguracja - polecenie aktualizuje plik konfiguracyjny internetowej wersji programu AsTrend - plik default.htm w zakresie ustawień parametrów połączenia sieciowego oraz nazwy bazy definicji zmiennych na podstawie ustawień bieżącej aplikacji systemu Asix. W sytuacji, gdy definicje zmiennych przechowywane są w bazie *.mdb, w momencie konfigurowania baza definicji zmiennych kopiowana jest do katalogu w/w programu. W przypadku stosowania bazy definicji zmiennych w formacie MS SQL, należy zapewnić stacjom klienckim dostęp do serwera SQL, na którym umieszczona jest baza - jeśli nie jest to możliwie, rozwiązaniem jest zastosowanie bazy definicji zmiennych w formacie pliku *.mdb.

Istnieje możliwość zadeklarowania listy nazw/adresów IP serwerów pakietu Asix6/7, z których mają być pobierane dane.

Operacje należy wykonać po każdej zmianie nazwy pliku lub katalogu bazy definicji zmiennych.

Ustaw na zakładce Ustawienia dostępu - polecenie pozwala skonfigurować kontrolę dostępu do programu, aby dostęp do niego był anonimowy lub oparty o uwierzytelnianie systemu Windows.

***

Istnieje też możliwość ustawienia dostępu do indywidualnych zmiennych. Aby ustawić selektywny dostęp do przeglądania zawartości zmiennych, należy ustawić dla aplikacji uwierzytelnianie systemu Windows (patrz wyżej), a w bazie definicji zmiennych dodać atrybut Grupa uprawnień odczytu. Następnie dla każdej zmiennej należy podać w bazie definicji zmiennych, jako wartość atrybutu Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do przeglądania wartości zmiennej.

UWAGA: Pozostawienie pustego pola dla atrybutu Grupa uprawnień odczytu dla danej zmiennej będzie oznaczać, że zmienna ta będzie niewidoczna dla wszystkich użytkowników.

***

Aplikacja będzie dostępna w sieci lokalnej pod adresem

http://<nazwa komputera w systemie Windows>/AsTrend

Aplikacja będzie dostępna lokalnie po wpisaniu w przeglądarce IE6 adresu:

http://localhost/AsTrend


System pomocy

2.5 System pomocy

System pomocy dostępny jest na zakładce Pomoc okna głównego AsTrend > grupie Tematy Pomocy.


Modyfikacja zawartosci menu i paskow narzedzi

2.6 Modyfikacja zawartości Wstążki

W programie możliwe jest modyfikowanie Wstążki. Jej zawartość zapamiętywana jest osobno dla Operatora i Administratora. Wszelkie zmiany w obydwu zestawach mogą być dokonywane tylko przez Administratora. Domyślnie Operator nie posiada takich uprawnień, niemniej istnieje możliwość nadania mu uprawnień do posiadania i modyfikowania własnego układu menu i pasków narzędzi (za wyjątkiem używania prostego mechanizmu zarządzania uprawnieniami użytkowników AsTrend - tryb Operator/Administrator, gdzie uprawnienia do modyfikacji zawartości wstążki posiada wyłącznie Administrator - patrz: 1.4 System uprawnień AsTrend uruchamianego z aplikacją systemu Asix).

Przy pierwszym uruchomieniu programu załadowany zostanie domyślny układ wstążki:

powiększ >>

Rysunek: Domyślny układ wstążki.

Aby dodać lub usunąć przycisk z paska narzędzi, należy:

1. kliknąć prawym klawiszem myszy w obszarze zakładki, a następnie wybrać opcję Dostosuj wstążkę...;

2. pojawi się wtedy okno 'Dostosowanie wstążki', które umożliwia dobór potrzebnych poleceń:

Rysunek: Okno 'Dostosowanie wstążki'.

3. Możliwe jest przywrócenie domyślnego układu przycisków za pomocą polecenia Resetuj układ przycisków.

Rys. Polecenia do zarządzania układem przycisków.


Zarządzanie niezaleznymi układami Wstążki

2.7 Zarządzanie niezależnymi układami Wstążki

Układ Wstążki zapisywany jest przy zamykaniu programu w katalogu danych aplikacji programu AsTrend.

W trybie pracy z aplikacją systemu Asix w wersji klasycznej program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla Administratora i Operatora. Osobno pamiętany jest układ Wstążki dla operatora i administratora. Definicje te przechowywane są w wewnętrznym pliku programu AsTrend, umieszczanym w katalogu aplikacji.

Jedynie Administrator ma możliwość definiowania układu menu / pasków narzędzi - dla siebie jak również dla Operatora.

Aby zmienić układ Wstążki dla operatora należy (będąc zalogowanym jako Administrator) wybrać opcję Widok > Układ przycisków Operatora. Od tej pory wszystkie zmiany w układzie przycisków będą zapisane w schemacie operatora. Odznaczenie opcji spowoduje zapisanie bieżącego układu i powrót do widoku administratora.

Oprócz tego zakładka Widok zawiera polecenia do zarządzania układem przycisków:

grupa Styl > polecenie Resetuj układ przycisków [image] - przywrócenie domyślnego układu przycisków. Polecenie dostępne dla administratora programu AsTrend.

***

W trybie pracy z aplikacją systemu Asix w wersji klasycznej z użytkownikami, których uprawnienia definiowane są w programie AsAudit, program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w programie AsAudit. Definicje te przechowywane są w pliku programu AsTrend, umieszczanym w katalogu aplikacji.

powiększ >>

Rys. Konfiguracja uprawnień zabezpieczeń w programie AsAudit.

***

Podczas pracy z aplikacją systemu Asix w wersji Evo program AsTrend daje możliwość definiowania niezależnych układów menu/pasków narzędzi dla użytkowników, którym nadano takie uprawnienie w konfiguracji systemu zabezpieczeń. Definicje te przechowywane są w pliku programu AsTrend, umieszczanym w katalogu aplikacji.

powiększ >>

Rys. Konfiguracja uprawnień zabezpieczeń w programie AsixEvo.exe.

***

W przypadku niezależnej pracy programu AsTrend niezależny układ menu / pasków narzędzi definiowany jest dla poszczególnych użytkowników systemu operacyjnego. Plik konfiguracyjny przechowywany jest wówczas w katalogu systemu Windows Documents and Settings.


Kreator trendow

2.8 Kreator trendów

Kreator trendów występuje w dwóch wersjach:

- kreatora prostego

oraz

- kreatora wyposażonego w samouczek.

Pierwszy z wymienionych wariantów kreatora uruchamiany jest poleceniem [image] Nowy trend - kreator... z menu Plik. Składa się z kolejno po sobie wywoływanych okien z zestawem parametrów wymaganych do utworzenia trendu.

Z kolei kreator trendów w postaci samouczka jest funkcją skierowaną do osób, które chciałyby zdefiniować trend, a nigdy wcześniej tego nie robiły. Aby wywołać kreator w tej postaci, należy nacisnąć przycisk Nowy trend - samouczek ... na liście poleceń menu Plik. Jeżeli jakaś czynność jest obligatoryjna, to jej wykonanie warunkuje możliwość przejścia do kolejnego kroku.


Operacje w obszarze wykresów

2.9 Operacje dostępne w obszarze wykresów

Bezpośrednio w obszarze wykresów można wykonywać następujące operacje:

  • zmiana okresu wyświetlania danych przez złapanie myszką za oś czasu i przesunięcie jej;

  • odczyt wartości i czasu - na pasku statusu wyświetlane są wartość i czas dla punktu krzywej, który został kliknięty;

  • przesuwanie w obszarze wykresów linii odczytu, za pomocą myszki (przycisk [image] wyświetla jedną linię odczytu; przycisk [image] pozwala wyświetlić dwie linie odczytu);

  • powiększanie zaznaczonego obszaru przez rozciąganie go lewym klawiszem myszki;

  • powiększanie obszaru wykresu za pomocą kółka myszki przy załączonej opcji [image] Powiększanie (zakładka Wykres > grupa Powiększanie);

  • selekcję jednej zmiennej przez pojedyncze kliknięcie na linii jej wykresu;

  • zmiana parametrów wyświetlania osi OY przez kliknięcie na niej;

  • wywoływanie funkcji umieszczonych w kontekstowym menu (przez kliknięcie prawym klawiszem myszki).

Kontekstowe menu zawiera operacje dodawania nowego przebiegu, uruchamiania okien do parametryzacji opcji przebiegu/źródła danych przebiegu/wykresu/trendu, wyświetlania atrybutów przebiegu, określania lokalizacji przebiegu (na którym wykresie ma się znajdować przebieg), zaznaczania przebiegów oraz usuwania przebiegów.

Rysunek: Menu kontekstowe w obszarze wykresów.


Operacje dostepne w polu legendy

2.10 Operacje dostępne w obszarze legendy

W obszarze legendy możliwie są następujące operacje:

  • Wyłączenie/włączenie legendy przy pomocy przycisku Legenda na wykresie na zakładce Wykres okna głównego AsTrend > grupie Wygląd

;

  • Zmiana wysokości legendy poprzez chwycenie kursorem za krawędź oddzielającą legendę od obszaru wykresu. Wysokość legendy jest zaokrąglana do pełnych wierszy.

  • Możliwość wyświetlenia pełnej wartości pola - przez najechanie myszką w obszarze pola; napis pozostanie wyświetlony tak długo, jak długo będzie przytrzymywany kursor w polu:

Rysunek: Wyświetlenie pełnej wartości pola.

  • Otwarcie okna zmiany zakresu zmiennej przez podwójne kliknięcie w polu zakres:

powiększ >>

Rysunek: Opcje przebiegu - definiowanie zakresów.

  • Wywoływanie funkcji umieszczonych w kontekstowym menu (przez kliknięcie prawym klawiszem w obszarze legendy):

Rysunek: Menu kontekstowe w obszarze legendy.

Nowy przebieg - Asix - dane surowe - dodaje przebieg surowych wartości zmiennych z aplikacji systemu Asix;

Kopiuj - tworzy kopię przebiegu;

Usuń przebieg - usunięcie aktualnie wybranej zmiennej;

Zamień na pusty - zamienia wybrany w legendzie przebieg na pusty wiersz;

Ukryj - ukrycie przebiegu wybranej zmiennej;

Położenie przebiegu - pozwala umieścić przebieg na jednym z wybranych wykresów: wykres 1, wykres 2, wykres 3, wykres 4 (ma to związek z możliwością wyświetlania jednocześnie max 4 wykresów w odrębnych oknach);

Zaznacz wszystkie - zaznacza wszystkie przebiegi;

Przesuń w górę - powoduje w legendzie wykresu przesunięcie wiersza wskazanego przebiegu o jeden w górę;

Przesuń w dół - powoduje w legendzie wykresu przesunięcie wiersza wskazanego przebiegu o jeden w dół;

Opcje przebiegu - wyświetla okno z opcjami przebiegu;

Opcje źródła danych przebiegu - wyświetla okno z opcjami źródła danego przebiegu;

Atrybuty przebiegu - wyświetla wartości atrybutów wybranej zmiennej;

Punkty - wyświetla punkty pomiarowe dla wybranych krzywych;

Etykiety - wyświetla etykiety dla wybranych krzywych;

Kolumny legendy - uruchamia okno 'Wybór kolumn legendy';

Opcje legendy - uruchamia okno 'Opcje trendu' z możliwością zdefiniowania wyglądu legendy.

  • Wywołanie funkcji zmiany treści nagłówka (przez kliknięcie prawym klawiszem w nagłówku wybranej kolumny legendy):

Rys. Zmiana nagłówka kolumny legendy.

  • Zmiana koloru nazwy i atrybutów zmiennych wyświetlanych w poszczególnych wierszach legendy - standardowo dane wyświetlane w wierszach mają kolory odpowiadające kolorom na wykresie, chyba że w legendzie zostanie wyświetlone pole Kolor przebiegu. Wówczas opisy zmiennych przyjmują kolor czarny, a o kolorze serii na wykresie informuje pole Kolor przebiegu.

  • Użytkownik może dokonać wyboru pól wyświetlanych w legendzie przy pomocy pola listy aktywowanego przyciskiem [image] w lewym górnym rogu legendy. Po naciśnięciu przycisku [image] uruchamiane jest okno 'Wybór kolumn legendy' z możliwością wyboru poniższych pól legendy. Możliwe jest też usuwanie pól przy użyciu metody Drag&Drop.

Pola legendy:

  • Agregaty

- Wartość minimalna - minimalna wartość w interwale

- Wartość maksymalna - maksymalna wartość w interwale

- Całka - suma wartości ważonych czasowo w interwale (całka po czasie)

- Całka (ostatnia znana) - suma wartości ważonych czasowo w interwale (całka po czasie); w miejsce złych wartości wstawia ostatnią znaną wartość

- Całka 0 - suma wartości ważonych czasowo (całka po czasie); w okresach, w których próbka ma jakość złą do obliczeń używana jest wartość 0

- Gradient - agregat Rozpiętość wartości podzielony przez długość okresu wyrażoną w sekundach)

- Jakość dobra - procent próbek o jakości dobrej w interwale

- Jakość dobra czas - czas trwania (w sekundach) czasu w interwale, w którym dane mają jakość dobrą

- Jakość niepewna - procent próbek o jakości niepewnej w interwale

- Jakość niepewna czas - długość (w sekundach) czasu w interwale, w którym dane mają jakość niepewną

- Jakość zła - procent próbek o jakości złej w interwale

- Jakość zła czas - czas trwania (w sekundach) czasu w interwale, w którym dane mają jakość złą

- Odchylenie standardowe - ważone czasowo odchylenie standardowe w interwale próbkowania

- Ostatni - ostatnio znana wartość w interwale próbkowania wyłączając koniec interwału

- Poprzedni znany - ostatnio znana wartość przed rozpoczęciem interwału próbkowania

- Przyrost wartości - różnica wartości na końcu i na początku interwału

- Rozpiętość wartości - różnica między maksymalna a minimalna wartością w interwale

- Suma spadków - suma wartości ujemnych zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem interwału próbkowania

- Suma wzrostów - suma wartości dodatnich zmian, od ostatniej znanej wartości przed rozpoczęciem się do ostatniej wartości przed końcem interwału próbkowania

- Średnia kwadratowa - ważona czasowo średnia kwadratowa w interwale próbkowania

- Wartość końcowa- wartość na końcu interwału

- Wartość początkowa - wartość na początku interwału

- Wartość średnia - średnia wartości ważonych czasowo w interwale

- Wartość średnia (ostatnia znana) - średnia ważona czasowo w interwale próbkowania; w miejsce złych wartości wstawia ostatnią znaną wartość

- Wartość średnia 0 - średnia wartości ważonych czasowo w interwale; w okresach, w których wartość jest niedostępna do obliczeń, używana jest wartość 0.

  • Trend

Nazwa przebiegu - symboliczna nazwa przebiegu, której domyślna wartość dla zmiennych pobieranych z aplikacji systemu Asix przyjmuje wartość atrybutu Nazwa z bazy definicji zmiennych; może być zmieniana poleceniem Wybierz atrybut nazw przebiegów (menu Dane > Asix - zmienne i alarmy); nazwa przebiegu może być edytowana przez użytkownika.

Zakres wyświetlania - zakres wyświetlania przebiegu.

Adres przebiegu - symboliczny adres przebiegu; domyślnie niewidoczny; pozwala umieścić w legendzie informacje o źródłach, z których czytane są dane przebiegów (np. A090/ARCHIWUM, Alarmy_F/414).

Dane wejściowe - Informacja o typie danych wejściowych przebiegu, jego archiwizacji i agregacji.

Dokładność - dokładność wyświetlania wartości przebiegu w legendzie.

Kolor przebiegu - kolor przebiegu na wykresie i w legendzie.

Liczba próbek - liczba odczytanych próbek.

  • Linia odczytu

Czas linii odczytu 1 - pozycja głównej linii odczytu na osi czasu.

Czas linii odczytu 2 - pozycja dodatkowej linii odczytu na osi czasu.

Czas próbki linii odczytu 1 - stempel czasu pierwszej próbki na lewo od głównej linii odczytu.

Czas próbki linii odczytu 2 - stempel czasu pierwszej próbki na lewo od dodatkowej linii odczytu.

Jakość próbki linii odczytu 1 - jakość pierwszej próbki na lewo od głównej linii odczytu.

Jakość próbki linii odczytu 2 - jakość pierwszej próbki na lewo od dodatkowej linii odczytu.

Odległość linii odczytu - odległość pomiędzy dwoma liniami odczytu.

Wartość próbki linii odczytu 1 - wartość pierwszej próbki na lewo od głównej linii odczytu.

Wartość próbki linii odczytu 2 - wartość pierwszej próbki na lewo od dodatkowej linii odczytu.

Wartość przybliżona linii odczytu 1 - przybliżona wartość przebiegu w punkcie głównej linii odczytu.

Wartość przybliżona linii odczytu 2 - przybliżona wartość przebiegu w punkcie dodatkowej linii odczytu.

  • Baza definicji zmiennych - niestandardowe pola (zadeklarowane przez użytkownika)

  • Baza definicji zmiennych - standardowe pola

Tabela 1. Lista atrybutów systemowych Bazy Definicji Zmiennych dla aplikacji Asix w wersji Evo i klasycznej.

UWAGA: Różnice w interpretacji atrybutów dla aplikacji wersji Evo znajdują się w tabeli 1a (za tabelą 1).

Nawa domyślnie wyświetlana w nagłówku (PL)

Opis

Nazwa

Unikalna nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca tę zmienną dla wszystkich komponentów systemu Asix

Opis

Dowolny tekst np. zawierający technologiczny opis zmiennej procesowej

Kanał

Nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji)

Adres

Adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu Asix

Liczba elementów

Liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą)

Okres próbkowania

okres aktualizacji wartości zmiennej procesowej (w sekundach)

Funkcja przeliczająca

Nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu Asix

Archiwum

Nazwa zasobu ASPAD (logiczna nazwa zasobu archiwum)

Parametry archiwizacji

Parametry archiwizacji danej zmiennej

Grupa1

Domyślnie generowany atrybut grupujący

Format

Format liczby w jakim będzie ona wyświetlana w systemie asix; format podany jest w konwencji języka C (np.: %4.2f oznacza 4 znaki, w tym 2 miejsca po przecinku)

FormatEvo

Format liczby w jakim będzie ona wyświetlana w aplikacji Asix.Evo

Jednostka

Fizyczna jednostka zmiennej

Zakres pomiarowy od

Maksymalny zakres możliwy do uzyskania - minimum

Zakres pomiarowy do

Maksymalny zakres możliwy do uzyskania - maksimum

Zakres surowy od

Parametr funkcji przeliczającej &endash; zakres wejściowy od &ldots;

Zakres surowy do

Parametr funkcji przeliczającej &endash; zakres wejściowy do &ldots;

Zakres przetwornika od

Zakres przetwornika - minimum

Zakres przetwornika do

Zakres przetwornika - maksimum

Zakres wyświetlania od

Dolny zakres wyświetlania danej zmiennej &endash; dla obiektów Asixa

Zakres wyświetlania do

Górny zakres wyświetlania danej zmiennej &endash; dla obiektów Asixa

Zakres sterowania od

Dolny zakres wartości danej zmiennej ustawiany z Asixa

Zakres sterowania do

Górny zakres wartości danej zmiennej ustawiany z Asixa

Baza słupka

Wielkość wczytywana z bazy przez obiekt SŁUPEK

Nazwy stanów

Nazwa zbioru tekstów lub bezpośrednio zbiór opisów stanów (poszczególnych wartości całkowitych) zmiennej

Zestaw stanów

Nazwa zbioru opisów stanów do którego należy bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

Wartość stanu

Numer stanu, którego opis zawiera bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

Maska zmiennej kontrolnej

Wskazuje na bit statusu sygnalizowanego przez zmienną kontrolną

Zmienna kontrolna

Nazwa zmiennej reprezentującej status zmiennej pomiarowej

Minimum krytyczne

Nazwa zmiennej systemu Asix, która zawiera wartość minimum krytycznego dla zmiennej pomiarowej

Minimum

Nazwa zmiennej systemu Asix, która zawiera wartość minimum dla zmiennej pomiarowej

Maksimum

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum dla zmiennej pomiarowej

Maksimum krytyczne

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum krytycznego dla zmiennej pomiarowej

Zakres wyświetlania krok

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość podziałki głównej na osi OY (co ile jednostek będzie wyświetlana etykieta wartości na osi OY)

Zakres wyświetlania szerokość

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość etykiety wartości wyświetlanych na osi OY

Zakres wyświetlania podział

Atrybut wykorzystywany przez obiekt WYKRES. Wyznacza podział na mniejsze jednostki podziałki głównej (wyznaczonej przez atrybut Zakres wyświetlania krok) na osi OY

Dokładność

Dokładność zaokrąglania w obiekcie LICZBA. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie nie ma zaokrąglania.

Położenie suwaka

Nazwa zmiennej, do której wpisywana będzie wartości reprezentująca położenie uchwytu obiektu SUWAK w trakcie przesuwania tegoż uchwytu

Rejestracja sterowania

Wartość 1 oznacza, że sterowania zmiennej podlegają rejestracji w module AsAudit

Zmienna nieaktywna

Jeżeli wartość atrybutu wynosi 1, to zmienna nie jest widoczna w systemie Asix dla modułów Asmen i Aspad

Tytuł wykresu

Atrybut wykorzystywany przez obiekt WYKRES. Tytuł wykresu pobierany jest z atrybutu Tytuł wykresu pierwszej zmiennej zadeklarowanej na wykresie

Zakres słupka od

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera dolny zakres wyświetlania danej zmiennej.

Zakres słupka do

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera górny zakres wyświetlania danej zmiennej.

Szybkie odświeżanie

Atrybut wykorzystywany przez drajwer CtTwinCATTcpip od wersji 1.3.5. Zmienne z zadeklarowanym atrybutem Szybkie odświeżanie mają udostępnioną funkcję szybkiego odświeżania, która umożliwia odświeżanie zmiennych z maksymalną osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę)

Sprawdzanie zakresu pomiarowego

Wartość 1 oznacza, że dla podanej zmiennej monitorowane będą przekroczenia zakresu pomiarowego i sygnalizowane odpowiednim statusem OPC.

Status zmiennej jest określany po porównaniu wartości pomiarowej z wartościami zakresów pomiarowych:

a/ przy przekroczeniu zakresu o wartość <= od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_EGU_EXCEEDED

b/ przy przekroczeniu zakresu o wartość > od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_SENSOR_FAILURE

Grupa uprawnień odczytu

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzystają aplikacje: AsPortal i AsTrend, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do przeglądania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do

przeglądania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

Grupa uprawnień zapisu

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzysta aplikacja AsPortal, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do modyfikowania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień zapisu, nazwę grupy użytkowników systemu Windows uprawnionych do

modyfikowania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

T - tekst, L - liczba zmiennoprzecinkowa 64 bitowa

Tabela 1a. Różnice w interpretacji atrybutów Bazy Definicji Zmiennych dla aplikacji wersji Evo (w porównaniu z wersją klasyczną).

Nazwa

Opis

Typ wartości

Określa typ wartości zmiennej w konwencji .Net. W przypadku użycia bazy MDB nie posiadającej tego atrybutu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej funkcji przeliczającej i formatu.

Format

Sposób formatowania tekstowego wartości w konwencji .Net. Skrócony opis formatów .Net można znaleźć w podręczniku AsixEvo_Techniki_budowy_diagramów.pdf/chm.

W przypadku baz MDB atrybut tworzony jest wirtualnie według poniższych zasad:

  1. Jeżeli w bazie jest atrybut FormatEvo, to jest on traktowany wprost jako definicja atrybutu Format Asix.Evo.

  2. Jeżeli w bazie nie ma atrybutu FormatEvo, to atrybut Format bazy MDB (podawany w konwencji formatów aplikacji klasycznych) jest w trakcie ładowania tłumaczony na odpowiadający mu format .Net.

Funkcja przeliczająca odczytu

Atrybut ma postać wyrażenia, które wstępnie przelicza pobraną z drajwera wartość surową zmiennej. W treści wyrażenia odwołanie do wartości surowej wykonywane jest przy pomocy funkcji RawValue.

W przypadku korzystania z serwera danych (kanał Asix6), niezależnie od definicji atrybutu funkcji przeliczającej odczytu, wartość zmiennej podlega standardowemu przeliczeniu przez Asmen’a na podstawie atrybutu Funkcja przeliczająca.

W przypadku użycia bazy MDB nie posiadającej atrybutu Funkcja przeliczająca odczytu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej formatu.

Funkcja przeliczająca zapisu

Atrybut ma postać wyrażenia, które przelicza wartość sterującą przed wysłaniem jej do drajwera.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Wartość początkowa

Określa wartość początkową zmiennej, nadawaną zmiennej w momencie uruchomienia aplikacji.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Dokowanie okna legendy w oknie trendu

Dodatkowo okno legendy może być 'zadokowana' w oknie trendu, co oznacza wpasowanie w okno trendu nad, pod lub w miejsce obszaru wykresu (zamiast wykresu widoczne jest okno legendy). W trzecim wariancie obszar wykresu zostaje przykryty przez okno legendy, niemniej można przełączać się pomiędzy widokami wykres - legenda za pomocą zakładek Wykres / Legenda.

- 'Dokowanie' okna legendy realizowane jest poprzez przeciągnięcie legendy w obszar wykresu i wpasowanie w wyświetlony graficzny schemat układu okien.

- Powrót do 'niezależnej' postaci legendy uzyskuje się poprzez przeciągnięcie zakładki Legenda poza obszar wykresu.

- Powrót do 'niezależnej' postaci legendy zawieszonej nad obszarem wykresu uzyskuje się poprzez przeciągnięcie zakładki Legenda nad obszar wykresu przy wciśniętym klawiszu Ctrl.

Układ okien zapamiętywany jest w programie AsTrend automatycznie przy wyjściu z programu - ale istnieje również możliwość zapisu stanu okien dla pliku trendu: zakładka Widok okna głównego AsTrend > grupa Okno > okno 'Opcje okna trendu' uruchamiane przyciskiem [image] > opcja Zapisywanie układu okien.

Polecenie resetowania układu dokowania paneli Resetuj układ paneli [image] znajduje się na zakładce

Widok okna głównego AsTrend > w grupie Panele.

powiększ>>

Rys. Efekt 'dokowania' okna legendy.


Operacje dostępne w obszarze paska statusu

2.11 Operacje dostępne w obszarze paska statusu

W poszczególnych polach statusu może pojawić się:

  • nazwa wyselekcjonowanej zmiennej - w polu Wybrany przebieg;

  • wartość okresu czasu wyświetlania wartości zmiennych - w polu Okres;

  • liczba punktów pomiarowych wyświetlanych aktualnie w obszarze wykresu - w polu Punkty.

W obszarze paska statusu możliwa jest następująca operacja:

- kliknięcie w obszarze okresu czasu wyświetlania powoduje otwarcie okna ustawiania okresu.


Wybor bazy definicji zmiennych

2.12 Wybór bazy definicji zmiennych systemu Asix / serwera OPC / AsBase / AsLogger

UWAGA: Na starcie programu AsTrend automatycznie otwierana jest ostatnio używana baza przebiegów.

Aby wybrać bazę definicji zmiennych systemu Asix, należy na zakładce Dane okna głównego programu AsTrend > w grupie Połączenie z archiwum nacisnąć przycisk Asix - zmienne i alarmy [image].

powiększ >>

Rysunek: Wybór bazy definicji zmiennych systemu Asix.

Aby wybrać bazę danych z serwera OPC, należy na zakładce Dane okna głównego programu AsTrend > w grupie Połączenie z archiwum wywołać polecenie OPC HDA - zmienne.

powiększ >>

Rys. Okno wyboru serwera OPC HDA.

Aby wybrać bazę danych modułu AsBase, należy na zakładce Dane okna głównego programu AsTrend > w grupie Połączenie z archiwum wywołać polecenie Asix - AsBase > Otwórz bazę danych modułu AsBase.

Rysunek: Okno 'Połącz z bazą danych modułu AsBase’.

Aby wybrać bazę danych modułu AsLogger, należy na zakładce Dane okna głównego programu AsTrend > w grupie Połączenie z archiwum wywołać polecenie Asix - AsLogger > Otwórz bazę danych modułu AsLogger.

Rysunek: Okno 'Połącz z bazą danych modułu AsLogger’.


Dodanie danych przebiegów

2.13 Dodanie danych przebiegów

uwaga Maksymalna ilość przebiegów dodanych do wykresu/wykresów wyświetlonych w ramach jednej uruchomionej instancji programu AsTrend wynosi 32.


Dodanie przebiegu zmiennej surowej

2.13.1.1 Dodanie przebiegu zmiennej surowej

Dodanie przebiegu zmiennej surowej do wykresu następuje w wyniku wyboru nazwy nowej zmiennej z okna wyboru zmiennych wywoływanego poprzez:

  • naciśnięcie przycisku [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg;

  • wybranie przycisku [image] w menu kontekstowym (prawy klawisz myszki) obszaru wykresów lub obszaru legendy.

Wymienione możliwości są dostępne pod warunkiem, że wcześniej otwarta została baza definicji zmiennych systemu Asix.

Możliwie jest wielokrotne dodawanie tej samej zmiennej do jednego trendu. Może to mieć sens, jeśli np. chcemy zobaczyć przebieg zmiennej i jej średniej, bądź przebieg zmiennej w dwóch okresach czasu jednocześnie.

Dla baz danych systemu Asix naciśnięcie przycisku [image] spowoduje uruchomienie poniższego 'Okna wyboru zmiennych’:

Rysunek: Okno wyboru zmiennych.

W oknie wyboru zmiennych należy dokonać wyboru zmiennych, których wykresy mają pojawić się w oknie trendu. Najpierw, rozwijając umieszczone w polu z lewej strony okna drzewo grup zmiennych, należy wybrać grupę zmiennych.

Następnie w polu zmiennych umieszczonym z prawej strony okna dokonujemy wyboru zmiennej. Można wybrać jedną lub kilka zmiennych. Wyboru jednej zmiennej dokonać można zaznaczając zmienną przy pomocy myszki, a następnie naciskając przycisk OK. Identyczny efekt daje dwukrotne kliknięcie myszką w polu danej zmiennej. Aby wybrać grupę zmiennych, należy przy wciśniętym klawiszu Ctrl zaznaczyć wybrane zmienne i zatwierdzić wybór przyciskiem OK.

W przypadku wyboru zmiennych z dużej grupy bardzo przydatne są funkcje wyszukiwania zmiennej oraz filtracji grup zmiennych, których atrybuty spełniają pewne kryteria.

Listę pól opisu zmiennych widocznych w polu zmiennych można swobodnie modyfikować. W tym celu należy kliknąć na przycisk [image] znajdujący się na lewo od nagłówków kolumn atrybutów. Na liście widocznych kolumn należy zaznaczyć lub odznaczyć wybrane kolumny i kliknąć poza tą listą.

***

Aby zlokalizować zmienną w oknie wyboru zmiennych, należy:

  • wskazać myszką grupę zmiennych;

  • kliknąć nagłówek wybranej kolumny, aby posortować wiersze według zawartości tej kolumny;

  • kliknąć dowolne pole znajdujące się w wybranej kolumnie;

  • rozpocząć pisanie szukanej wartości. Po każdym wpisanym znaku lista zmiennych zostanie przewinięta do odpowiedniego rekordu.

***

Aby przefiltrować i pogrupować dane w oknie wyboru zmiennych, należy wykonać następujące czynności:

Przy pomocy przycisku Filtrowanie i grupowanie można włączyć opcję filtrowania i grupowania - dzięki temu możliwe będzie wykonanie poniższych czynności.

Aby pogrupować zmienne według wartości danego atrybutu, należy przeciągnąć nagłówek kolumny tego atrybutu na pasek znajdujący się ponad nagłówkami atrybutów.

Rysunek: Filtrowanie wg kolumny.

Aby użyć prostego filtra wartości w danej kolumnie, należy nacisnąć przycisk [image] znajdujący się na nagłówku kolumny i wybrać wartość filtra z listy.

Rysunek: Filtrowanie wg wartości danej kolumny.

Aby użyć bardziej skomplikowanego filtra, należy kliknąć na przycisk [image] znajdujący się w lewej dolnej części tabeli zmiennych. Pojawi się narzędzie umożliwiające zdefiniowanie zaawansowanego filtru.

Rysunek: Kreator filtrów.


Dodanie przebiegu zagregowanego

2.13.1.2 Dodanie przebiegu zagregowanego

Zmienna zagregowana to zmienna surowa przeliczona funkcją agregującą. Dla zmiennej zagregowanej okres czasu pomiędzy próbkami jest stały i równy okresowi agregacji.

Jeśli trend używa danych równomiernych, okres pomiędzy próbkami będzie taki jak zdefiniowano w opcjach trendu.

Jeśli w aplikacji włączony jest agregator, to użycie interwału będącego wielokrotnością minuty może znacznie przyspieszyć pobieranie danych.

Dodanie zmiennej zagregowanej do okna trendu umożliwia okno wywoływane poleceniem Dane agregowane [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > przycisku Asix [image] .

Parametryzacja obejmuje opcje:

- Nazwa zmiennej;

- Nazwa agregatu;

- Interwał agregacji;

- Stempel czasu agregacji (początek interwału, koniec interwału).

powiększ >>

Rysunek: Okno 'Dodaj przebieg agregowany'.


Dodanie bitów zmiennej statusowej

2.13.1.3 Dodanie bitów zmiennej statusowej

Dodanie bitów zmiennej statusowej umożliwia polecenie z zakładki Narzędzia główne okna głównego programu AsTrend > grupa Nowy przebieg > Asix [image] > [image] Bity danych.

Powyższe polecenie uruchamia okno, w którym należy wskazać:

- zmienną, której bity zostaną dodane do trendu - pole Nazwa zmiennej,

- a także określić, które atrybuty bitów mają być wyświetlane w legendzie - blok Atrybuty pobierane z definicji bitu:

- Tylko opis - w legendzie, w kolumnie opisu zmiennej zostanie wyświetlony opis bitu zmiennej; w kolumnach pozostałych atrybutów zostaną wyświetlone wartości atrybutów zmiennej;

- Tylko opis połączony z opisem zmiennej - w legendzie, w kolumnie opisu zmiennej zostanie wyświetlony opis bitu zmiennej połączony z opisem zmiennej; w kolumnach pozostałych atrybutów zostaną wyświetlone wartości atrybutów zmiennej;

- Wszystkie - w legendzie, w kolumnach wszystkich atrybutów zostaną wyświetlone wartości atrybutów bitu zmiennej. Możliwość pobierania wszystkich atrybutów z definicji bitu blokowana jest w przypadku, gdy baza nie ma zdefiniowanego atrybutu Nazwy stanów.

Rys. Okno 'Dodaj bity zmiennej statusowej'.

Rysunek: Wykres bitów zmiennych statusowych.


Dodanie alarmu SQL

2.13.1.4 Dodanie alarmu SQL

UWAGA:

Dodanie alarmu SQL stosuje się wyłącznie dla alarmów, których archiwa zdarzeń przechowywane są w bazie SQL. Może to dotyczyć zarówno aplikacji wersji Evo jak i klasycznej wersji Asixa. Należy zadbać o to, aby dla aplikacji Evo informacje o wszystkich zdarzeniach alarmowych przechowywane były nie tylko w logach alarmów historycznych, ale również w archiwum alarmów typu SQL. Podobnie w aplikacjach klasycznych - oprócz archiwizacji zdarzeń alarmów w plikach dyskowych należy równolegle zadeklarować przechowywanie zdarzeń alarmowych w bazie MS SQL.

Alarmy SQL znajdujące się w bazie definicji zmiennych dodawane są do trendu przy użyciu okna 'Okno wyboru alarmów’, wywoływanego komendą [image] Asix > [image] Alarm SQL z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg.

Rys. Okno dodawania alarmu SQL.


Dodanie alarmu

2.13.1.5 Dodanie alarmu

Program AsTrend może pobierać definicje alarmów bezpośrednio z aplikacji Asix lub bazy definicji zmiennych (w formacie MS SQL lub MDB). Zaleca się przechowywanie definicji alarmów w bazie definicji zmiennych - znacznie ułatwia to identyfikację alarmu, którego przebieg ma być wyświetlony w programie AsTrend.

UWAGA: Opcja dodania alarmu [image] dotyczy wyłącznie alarmów aplikacji utworzonej w klasycznej wersji Asixa.

UWAGA: Dla alarmów aplikacji utworzonej w wersji Evo Asixa należy wykorzystać opcję dodawania alarmów, których archiwa zdarzeń przechowywane są w bazie SQL- patrz: rozdział 2.13.1.4 Dodanie alarmu SQL.

***

Jeśli baza definicji zmiennych nie zawiera definicji alarmów, alarmy dodawane są do trendu przy użyciu okna 'Dodaj przebieg - alarm’, wywoływanego komendą [image] Asix > [image] Alarm z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg.

powiększ >>

Rysunek: Okno 'Dodaj przebieg - alarm'.

***

Jeśli definicje alarmów znajdują się w bazie definicji zmiennych, to dodawane są do trendu przy użyciu okna 'Okno wyboru alarmów’, wywoływanego komendą [image] Asix > [image] Alarm z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg.

Rysunek: Okno wyboru alarmów.


Dodawanie zmiennej ze schowka

2.13.1.6 Dodawanie przebiegu ze schowka

Aby możliwe było wstawianie zmiennych ze schowka, musi on zawierać nazwy zmiennych w formacie tekstowym. Dopuszczalne separatory nazw zmiennych to: znak nowej linii, znak tabulacji, przecinek, średnik oraz systemowy separator listy. Wstawiane zmienne musza być zdefiniowane w aktualnie otwartej bazie definicji zmiennych.

Nazwy zmiennych można wstawić do schowka w następujący sposób:

- ustawiając kursor myszy nad dowolnym obiektem na masce synoptycznej aplikacji systemu Asix i następnie naciskając Ctrl+C (dotyczy aplikacji wersji klasycznej systemu Asix; w przypadku systemu w wersji Asix.Evo należy zdefiniować skrót klawiszowy, w szczególności Ctrl+C, wykonujący akcję operatorska GetVarNames),

- w oknie wyboru zmiennej programu Architekt, w menu lokalnym, wybierając polecenie Dodaj nazwy zmiennych do schowka,

- w jakimkolwiek dokumencie tekstowym, zaznaczając nazwę zmiennej i kopiując ją do schowka.

Nazwy zmiennych znajdujące się w bazie definicji zmiennych dodawane są ze schowka do trendu przy użyciu polecenia Zmienna ze schowka [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > grupy przycisków Asix [image] .


Dodanie archiwum Asix

2.13.1.7 Dodanie zmiennej z pliku archiwum Asix

Dodanie zmiennej z pliku archiwum Asix polega na wczytaniu do trendu danych wyeksportowanych w programie AspadTools.

Dane archiwum Asix wczytywane są do trendu przy użyciu okna 'Dodawanie zmiennych z archiwum Asix’, wywoływanego komendą [image] Plik archiwum Asix z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > grupy przycisków Pozostałe przebiegi [image] .

Opis użycia programu AspadTools dostępny jest po naciśnięciu przycisku Info w oknie 'Dodawanie zmiennych z archiwum Asix'.

powiększ >>

Rys. Okno 'Dodawanie zmiennych z archiwum Asix'.


Dodanie przebiegu wyliczanego

2.13.1.8 Dodanie przebiegu wyliczanego

Przebiegi wyliczane ze zmiennych za pomocą podanego wyrażenia dodawane są przy użyciu okna 'Dodaj przebieg wyliczany’, wywoływanego komendą [image] Wyliczany z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg.

Okno zawiera zakładki, dzięki którym użytkownik ma możliwość zadeklarowania atrybutów przebiegu wyliczanego oraz skonstruowania wyrażenia, wg którego przebieg zostanie wyliczony.

Zakładka Sposób wyliczania zawiera pola określające sposób wyliczania wartości próbek:

- Agregacja
 danych wyliczonych z danych surowych
 - wartości zmiennych wejściowych pobierane są jako dane surowe;
 następnie wartości próbek wyliczane są na podstawie podanego wyrażenia;
 ostatecznie wyliczone wartości są agregowane wybraną funkcją agregującą;

- Odczyt danych wyliczonych z danych zagregowanych - wartości zmiennych wejściowych pobierane są jako dane zagregowane; następnie wartości próbek wyliczane są na podstawie podanego wyrażenia;

- Agregacja danych wyliczonych z danych zagregowanych - wartości zmiennych wejściowych pobierane są jako dane zagregowane; następnie wartości próbek wyliczane są na podstawie podanego wyrażenia; ostatecznie wyliczone wartości są agregowane wybraną funkcją agregującą;

powiększ >>

Rysunek: Okno 'Dodaj przebieg wyliczany' - zakładka 'Wyliczane wyrażenie'.

Zakładka Przebieg wyliczany zawiera pola:

- Wyrażenie - pole, w którym należy wpisać wyrażenie do wyliczenia zmiennej; dla ułatwienia konstruowania wyrażeń poniżej pola Wyrażenie znajduje się przycisk Wstaw... uruchamiający okno z biblioteką funkcji, operatorów i stałych,

- Typ danych przebiegu:

- Traktuj wynik jako zmienną boolowską - pole pozawala zadeklarować wynik jako zmienną boolowską oraz umożliwia podanie interwału dla zmiennych wejściowych;

- Nazwa agregatu;

- Interwał wyliczania agregatu;

- Stempel czasu agregatu.

- Testowanie wyrażenia - po zadeklarowaniu wyrażenia istnieje możliwość sprawdzenia poprawności jego składni poprzez przyciśnięcie przycisku Sprawdź; jeśli wyrażenie zostało prawidłowo sformułowane, pojawi się okienko z komunikatem "Poprawne”:

- Zmienne wejściowe - obejmuje zmienne z bazy definicji zmiennych, które służą do wyliczenia wartości punktów przebiegu wyliczanego; przycisk 3kropki uruchamia 'Okno wyboru zmiennej’; przycisk i wyświetla metrykę wybranej zmiennej; limit na ilość zmiennych składowych w zmiennej wyliczanej wynosi 50.

- Interwał dla zmiennych wejściowych - interwał ten jest używany do próbkowania wartości zmiennych wejściowych wyliczanego wyrażenia; wyliczone wartości są następnie agregowane za pomocą funkcji i interwału podanych w grupie 'Typ danych przebiegu'.

powiększ >>

Rysunek: Okno 'Dodaj przebieg wyliczany' - zakładka 'Przebieg wyliczany'.

***

Zakładka Atrybuty przebiegu pozwala określić:

- Atrybuty przebiegu:

-Nazwę przebiegu, Opis, Jednostkę;

- Zakres wyświetlania - zakres wyświetlania służy do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres wyświetlania i Największy zakres wyświetlania). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu wyświetlania - wówczas zakres osi będzie wyliczany na podstawie bieżących wartości próbek.

Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy wyświetlania wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy wyświetlania, zakres ustalany jest automatycznie.

- Zakres pomiarowy - zakres pomiarowy służy do sprawdzania poprawności wartości próbek przebiegu. Wartości próbek, które przekraczają zakres przebiegu o liczbę równą szerokości zakresu przebiegu są obcinane. Wprowadzenie wartości zakresu 0-1 dla zmiennej systemu Asix typu całkowitego powoduje, że zmienna jest traktowana jako binarna.

Zakres pomiarowy może być także użyty do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego programu AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres pomiarowy i Największy zakres pomiarowy). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu pomiarowego. Jeśli zakres pomiarowy jest wybrany do skalowania osi, to zakresy osi będą wtedy wyliczane na podstawie bieżących wartości próbek. Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy pomiarowe wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy pomiarowe, zakres ustalany jest automatycznie.

powiększ >>

Rysunek: Okno 'Dodaj przebieg wyliczany' - zakładka 'Atrybuty'.


Dodanie stałej

2.13.2 Dodanie stałej

Istnieje możliwość wstawiania do wykresu wartości stałej (rysowanej jako pozioma linia lub obszar).

Aby dodać stałą, należy użyć polecenie [image] Stały z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > Pozostałe przebiegi [image] , wywołujące okno 'Dodaj stały przebieg'.

Poniżej definicje atrybutów konfigurowanych na zakładkach okna 'Dodaj stały przebieg'.

Zakładka Wartość, pozwalająca zadeklarować wartość stałej zawiera:

- pole Wyrażenie - do którego należy wpisać wartość lub wyrażenie służące do wyliczenia wartości stałej; dla ułatwienia poniżej pola Wyrażenie znajduje się przycisk Wstaw... uruchamiający okno z biblioteką funkcji, operatorów i stałych; po zadeklarowaniu wyrażenia istnieje możliwość sprawdzenia poprawności jego składni poprzez przyciśnięcie przycisku Sprawdź; jeśli wyrażenie zostało prawidłowo sformułowane, pojawi się okienko z komunikatem "Poprawne”:

Rys. Okno z komunikatem nt wyniku testu poprawności wyrażenia.

- Testowanie wyrażenia - mechanizm testowania wyrażenia polegający na wyliczeniu wartości zdefiniowanego wyrażenia.

powiększ >>

Rysunek: Okno 'Dodaj przebieg stały ' - zakładka 'Wartość'.

***

Zakładka Atrybuty pozwala określić podstawowe atrybuty stałej wraz z zakresem wyświetlania i zakresem pomiarowym:

- Nazwa - nazwa wartości stałej;

- Opis - opis stałej;

- Jednostka - jednostka wartości stałej.

- Zakres wyświetlania - zakres wyświetlania służy do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (uwaga: w ustawieniach Osi fizycznej OY jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres wyświetlania i Największy zakres wyświetlania - zakładka Wykres okna głównego AsTrend > grupa Osie > okno 'Opcje wykresu' > zakładka Oś fizyczna OY ). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu wyświetlania - wówczas zakres osi fizycznej będzie wyliczany na podstawie bieżących wartości próbek.

Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy wyświetlania wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy wyświetlania, zakres ustalany jest automatycznie.

- Zakres pomiarowy - zakres pomiarowy służy do sprawdzania poprawności wartości próbek przebiegu. Wartości próbek, które przekraczają zakres przebiegu o liczbę równą szerokości zakresu przebiegu są obcinane. Wprowadzenie wartości zakresu 0-1 dla zmiennej systemu Asix typu całkowitego powoduje, że zmienna jest traktowana jako binarna.

Zakres pomiarowy może być także użyty do skalowania osi fizycznej (uwaga: w ustawieniach Osi fizycznej OY jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres pomiarowy i Największy zakres pomiarowy - zakładka Wykres okna głównego AsTrend > grupa Osie > okno 'Opcje wykresu' > zakładka Oś fizyczna OY ). Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy pomiarowe wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy pomiarowe, zakres ustalany jest automatycznie.

Dla stałego przebiegu w przypadku braku zadeklarowanego zakresu zakres ustawiany jest na +/- 10% wokół wartości stałej serii.

powiększ >>

Rysunek: Okno 'Dodaj przebieg stały ' - zakładka 'Atrybuty'.


Dodanie zmiennej ze źródła zewnętrznego

2.13.3 Dodanie przebiegu zmiennej ze źródła zewnętrznego

W programie AsTrend istnieje możliwość wyświetlania wykresów wartości zmiennych pobranych z plików csv, xls oraz źródeł dostępnych poprzez OLE DB - takich jak bazy typu MSSQL i Access, pod warunkiem że struktura bazy pozwoli na odczyt danych w sposób uporządkowany czasowo.

Do dodawania zmiennych ze źródeł zewnętrznych służy polecenie Dane zewnętrzne [image] z zakładki Narzędzia główne okna głównego programu AsTrend > Nowy przebieg > Pozostałe przebiegi [image] , wywołujące okno 'Dodawanie zmiennych z zewnętrznego źródła danych’:

- Format - format zewnętrznego źródła danych:

- Plik tekstowy,

- plik programu Microsoft Excel,

- OLE DB.

powiększ >>

Rysunek: Okno 'Dodawanie zmiennych z zewnętrznego źródła danych’.

Opis formatu danych źródła zewnętrznego dostępny jest po naciśnięciu przycisku Pomoc w oknie 'Dodawanie zmiennych z zewnętrznego źródła danych'.


Dodanie danych z serwera OPC-HDA

2.13.4 Dodanie przebiegu danych z serwera OPC-HDA

Dodanie przebiegu danych z serwera OPC-HDA umożliwia polecenie Serwer OPC-HDA [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > Pozostałe przebiegi [image] .


Dodanie przebiegu z bazy modułu AsBase

2.13.5 Dodanie przebiegu z bazy modułu AsBase

W programie AsTrend istnieje możliwość wyświetlania wykresów wartości zmiennych pobranych z z pola zestawu rejestracji z bazy danych modułu AsBase.

Po wybraniu serwera i bazy danych modułu AsBase można przystąpić do wyboru przebiegu.

Do dodawania przebiegu z bazy danych AsBase służy polecenie AsBase z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg.

Okno wyboru przebiegu z bazy AsBase ma możliwość wyboru wirtualnej kolumny <Moment rejestracji>. Stemple czasu próbek tego przebiegu określają momenty zapisu nowych rekordów danych do bazy AsBase.

Rys. Okno wyboru przebiegu z bazy AsBase.


Dodanie przebiegu z modułu AsLogger

3.13.6 Dodanie przebiegu z bazy modułu AsLogger

W programie AsTrend istnieje możliwość wyświetlania wykresów wartości zmiennych pobranych z z planu rejestracji z bazy danych modułu AsLogger.

Po wybraniu serwera i bazy danych modułu AsLogger można przystąpić do wyboru przebiegu.

Do dodawania zmiennych z bazy danych AsLogger służy polecenie AsLogger z zakładki Narzędzia główne okna głównego programu AsTrend > Nowy przebieg, wywołującego okno 'Połącz z serwerem danych modułu AsLogger’.

Rys. Okno wyboru przebiegu z bazy AsLogger.


Dodanie pustej serii

2.13.7 Dodanie pustej serii

Dodanie pustego przebiegu umożliwia polecenie Pusty [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Nowy przebieg > Pozostałe przebiegi [image] .

Pusty przebieg używany jest jako separator w legendzie i w trybie tabeli danych historycznych.


Wybór typu danych

2.14 Wybór typu danych (dane oryginalne/zagregowane)

W programie AsTrend dostępne są następujące typy danych:

  • odstępy pomiędzy pomiarami są takie jak w archiwum (narzucone przez program archiwizujący) - dane oryginalne;

  • odstępy między pomiarami są równe (wymuszone przez program AsTrend) - dane równomierne;

  • odstępy pomiędzy pomiarami przyjmowane są automatycznie przez program AsTrend w zależności od długości okresu, dla którego wyliczane są średnie (dane uśrednione) lub wartości minimalne i maksymalne (dane przybliżone).

Domyślnie wybrany jest pierwszy wariant - dane oryginalne. Dane oryginalne załączane są przyciskiem [image] na zakładce Dane > grupie Dane wejściowe.

Zaletą tego wariantu jest to, że na wykresie po naniesieniu punktów widoczne będą momenty rzeczywistych pomiarów. Wadą są trudności występujące przy porównywaniu zmiennych o różnych przebiegach i różnych okresach próbkowania.

***

Wybór drugiego sposobu - dane równomierne (przycisk [image] na zakładce Dane okna głównego programu AsTrend > grupie Dane wejściowe) wymusza stały odstęp pomiędzy punktami na wykresie. Może to powodować dodanie lub usunięcie pewnych pomiarów. W rezultacie jednak otrzymujemy identyczne czasy próbkowania dla wszystkich zmiennych, co ułatwia ich porównywanie i jest szczególnie cenne przy wyświetlaniu trendu w postaci tabeli wartości (wszystkie przebiegi w tabeli poosiadają taką samą liczbę wierszy).

Aby ustalić własny okres próbkowania, należy w oknie 'Opcje danych wejściowych trendu’ uruchamianego przyciskiem [image] na zakładce Dane okna głównego programu AsTrend > grupie Dane wejściowe zdefiniować wartość parametru Dane równomierne - okres próbkowania.

powiększ >>

Rysunek: Okno 'Opcje danych wejściowych trendu' - zakładka 'Dane'.

***

Dane przybliżone lub dane uśrednione załączane są przyciskiem - odpowiednio: Dane uśrednione [image] lub Dane przybliżone [image] (na zakładce Dane okna głównego AsTrend > w grupie Dane wejściowe), lub też w oknie opcji danych wejściowych trendu (uruchamianego przyciskiem [image] na zakładce Dane okna głównego AsTrend > w grupie Dane wejściowe).

Dla danych uśrednionych:

Dla krótkich okresów czasu pobierane są dane oryginalne, dla długich okresów pobierane są agregaty - wartości średnie.

Moment przejścia z danych oryginalnych na agregaty oraz okres agregacji są dobierane automatycznie.

Tryb ten stosowany jest głównie do przeglądania danych z długiego okresu czasu. Archiwum powinno przechowywać wcześniej wyliczone wartości średnie pomiarów, aby ich pobieranie było szybkie.

Dla danych przybliżonych:

Dla krótkich okresów czasu pobierane są dane oryginalne, dla długich okresów pobierane są dwa agregaty: wartości minimalne i wartości maksymalne.

Moment przejścia z danych oryginalnych na agregaty oraz okres agregacji są dobierane automatycznie.

Tryb ten jest stosowany głównie do przeglądania danych z długiego okresu czasu. Archiwum powinno przechowywać wcześniej wyliczone wartości agregatów minimum i maksimum, aby ich pobieranie było szybkie.

Wartości przybliżone rysowane są w postaci wykresów wstęgowych; wykres jednej zmiennej składa się z dwu krzywych reprezentujących wartości minimalne i maksymalne - obszar pomiędzy nimi wypełniony jest kolorem serii.

***

Dane równomierne, uśrednione i przybliżone wyliczane są przez serwer systemu Asix przy użyciu modułu Agregatora. Dzięki temu AsTrend czyta gotowe dane zagregowane zamiast wyliczać je z wartości surowych.


Wybór rodzaju agregatu dla danych

2.14.1 Wybór funkcji agregującej dla czytanych danych

Istnieje możliwość wyboru rodzaju funkcji agregującej używanej do czytania danych.

Ustawienia funkcji agregującej do czytania danych można dokonać w oknie 'Źródło danych - przebieg zmiennej Asix' uruchamianym przyciskiem [image] z zakładki Przebieg okna głównego AsTrend > grupy Operacje przebiegu > poleceniem Opcje źródła danych przebiegu [image] .

Przy zastosowaniu Agregatora (modułu systemu Asix do wyliczania i archiwizacji danych statystycznych), dane wyliczane są przez serwer Asix, skąd pobiera je program AsTrend - dzięki temu 'gotowe’ dane zagregowane interesujące użytkownika dostarczane są w sposób szybki i efektywny. (Patrz: 1.11 Agregacja danych systemu Asix ).

powiększ >>

Rysunek: Okno 'Źródło danych - przebieg zmiennej Asix'.


Ustawienie okresu czasu za pomoca przyciskow przesuwania

2.15.1 Ustawienie okresu czasu za pomocą przycisków przesuwania trendu

Wykonanie funkcji przesuwania trendu (przyciski [image] [image] Do tyłu o okres / Do przodu o okres - przesunięcie o bieżący okres, [image] [image] Do tyłu / Do przodu - przesunięcie o ¼ okresu), włączanie trybu rejestracji (przycisk Tryb żywy [image]) oraz przesunięcie Do końca danych [image] (do chwili bieżącej lub do końca danych zewnętrznych) powoduje automatyczną zmianę okresu trendu.


Ustawianie okresu czasu przy pomocy edytora okresu

2.15.2 Ustawianie okresu czasu przy pomocy edytora okresu

W programie AsTrend powyżej okres czasu ustawiany jest przy użyciu edytora uruchamianego z paska Narzędzia główne > grupy Okres. Kliknięcie na pole wyświetlające początek i długość aktualnego okresu powoduje uruchomienie okna 'Okres', w którym można ustawić okres wyświetlania danych.

Ustalenie daty bazowej wymaga określenia wartości daty i długości okresu oraz określenia ”położenia” tej daty względem okresu (początek, środek i koniec okresu).

W zakresie długości okresu użytkownik ma możliwość:

- wybrania predefiniowanych okresów czasu,

- określenia własnej długości okresu.

Predefiniowane długości okresów (mniejsze wartości predefiniowanych długości okresów pojawiają się dopiero, gdy użytkownik wyświetlił bardzo krótki okres czasu za pomocą przycisku Zmniejsz okres [image], zdefiniuje krótki okres czasu w oknie 'Okres' (wywoływanym z zakładki Narzędzia główne > grupy Okres, po kliknięciu na pole z wartością aktualnie wyświetlanego okresu czasu) albo doda do trendu przebiegi obsługujące stemple czasu z dużą rozdzielczością):

- 5 milisekund,

- 10 milisekund,

- 20 milisekund,

- 50 milisekund,

- 100 milisekund,

- 200 milisekund,

- 500 milisekund,

- 1 sekunda,

- 2 sekundy,

- 5 sekund,

- 10 sekund,

- 15 sekund,

- 30 sekund,

- 1 minuta,

- 2 minuty

- 5 minut,

- 10 minut,

- 15 minut,

- 30 minut,

- 1 godzina,

- 2 godziny,

- 4 godziny,

- 8 godzin,

- 12 godzin,

- 1 dzień,

- 2 dni,

- 4 dni,

- 7 dni,

- 14 dni,

- 1 miesiąc,

- 2 miesiące,

- 3 miesiące,

- 6 miesięcy,

- 1 rok.

powiększ >>

Rysunek: Okno ustawiania okresu.


Ustawienie okresu czasu za pomoca schowka okresow

2.15.3 Ustawienie okresu czasu za pomocą schowka okresów

Ze schowka okresów można odczytać i zastosować zapamiętany w nim odcinek czasu dla aktualnie wyświetlanego trendu. Opis działania schowka okresów znajduje się w punkcie 2.29 Schowek okresów.


Ustawienie okresu czasu w wyniku wywolania definicji

2.15.4 Ustawienie okresu czasu w wyniku wywołania definicji trendu

Każdorazowe wczytanie trendu powoduje ustawienie okresu czasu na taki, jaki został zapamiętany zgodnie z ustawieniami w opcjach trendu:

(AsTrend > Narzędzia główne > Okres > okno 'Opcje okresu trendu' > zakładka Okres przy otwieraniu).

Możliwe do ustawienia opcje dotyczące okresu automatycznie ładowanego po otwarciu pliku trendu obejmują:

- Taki jak przy zapisie;

- Koniec okresu równy bieżącej chwili;

- Dzień bieżący, godzina bez zmian;

- Ostatnio używany;

- Wyrażony w formacie OPC (format OPC - patrz: podręcznik modułu AsixConnect, punkt 7.4. Format czasu OPC);

- Zapytaj.

powiększ >>

Rysunek: Opcje okresu trendu.


Ustawienie okresu czasu przy pomocy myszy

2.15.5 Ustawienie okresu czasu przy pomocy myszy

Możliwa jest również zmiana okresu czasu przy użyciu myszy:

- ruch samego kółka powoduje przesuwanie okresu w tył/przód;

- ruch kółka przy wciśniętym klawiszu Ctrl powoduje zmianę szerokości okresu;

- ruch kółka przy wciśniętym klawiszu Shift powoduje szybkie przesuwanie okresu.

Ponadto możliwa jest zmiana wyświetlanego okresu czasu poprzez chwycenie myszą osi czasu i przesunięcie jej.

Rysunek: Zmiana wyświetlanego okresu czasu poprzez przesunięcie osi czasu przy pomocy myszy.


Edytor czasu w formacie OPC

2.15.6 Edytor czasu w formacie OPC

Okres czasu ustawiany w trakcie wywoływania definicji trendu może być wyrażony w formacie OPC.

Okres ten definiowany jest w oknie opcji okresu trendu po zaznaczeniu opcji Wyrażony w formacie OPC. Kliknięcie na przycisku [image] w obszarze pola Początek lub Koniec powoduje uruchomienie edytora czasu w formacie OPC.

W definicji początku czasu względnego dostępne są następujące predefiniowane momenty:

- Chwila obecna;

- Początek bieżącej sekundy;

- Początek bieżącej minuty;

- Początek bieżącej godziny;

- Początek bieżącego dnia;

- Początek bieżącego tygodnia;

- Początek bieżącego miesiąca;

- Początek bieżącego roku;

- Początek bieżącej zmiany;

Początek bieżącej zmiany oznacza wybranie początku zmiany zaczynającej sie od godziny 6:00 lub 14:00 lub 22:00.

powiększ >>

Rysunek: Edytor czasu w formacie OPC.


Wyswietlanie agregatow

2.16 Wyświetlanie agregatów na podstawie danych z aktualnie wyświetlonego okresu

W programie AsTrend istnieje możliwość modyfikowania legendy w zakresie wyświetlania agregatów (czytaj: wartości zagregowanych). Do wyboru użytkownik ma możliwość wyświetlenia agregatów w polach legendy (których pełna lista omówiona została w rozdziale 2.6 Operacje dostępne w obszarze legendy). Wartości agregatów wyliczane są lokalnie przez program AsTrend dla wartości wyświetlonych na ekranie w ramach zadanego okresu czasu (niezależnie od typu danych prezentowanych na wykresie: dane oryginalne, równomierne, przybliżone i uśrednione).

Mechanizmu drugiej linii odczytu daje możliwość swobodnego wydzielenia na wykresie dowolnego odcinka czasu, dla którego wyliczone zostaną agregaty, wyświetlane w polach legendy (jeśli linie odczytu są wyłączone, wspomniane pola w legendzie wskazują agregaty wyliczane dla całego wyświetlonego okresu).


Wyświetlanie danych mających stemple czasu o rozdzielczości milisekund

2.16.1 Wyświetlanie danych mających stemple czasu o rozdzielczości milisekund

W przypadku danych mających stemple czasu o rozdzielczości milisekund (dane pobrane z systemu alarmów Asixa lub ze źródeł zewnętrznych) AsTrend automatycznie przełącza wykres na dane surowe - jeśli okres agregacji jest mniejszy niż 1 minuta. w oknie 'Okres', wywoływanym z zakładki Narzędzia główne > grupy Okres, po kliknięciu na pole z wartością aktualnie wyświetlanego okresu czasu pojawiają się wówczas okresy od 5 ms do 1 roku. Istnieje ponadto możliwość zdefiniowania własnego okresu wyświetlania danych.

powiększ >>

Rys. Predefiniowane okresy czasu dla danych o małym stemplu czasu.

powiększ >>

Rys. Okno definiowania własnego okresu czasu wyświetlania danych.


Ustawienie dodatkowego okresu czasu

2.17 Ustawienie dodatkowego okresu czasu

Program AsTrend daje możliwość wyświetlenia w ramach trendu dodatkowej osi czasu OX powiązanej z wybranymi zmiennymi / zmienną. Dodatkowa oś OX umiejscowiona jest ponad wykresem i pozwala wyświetlić dowolny okres czasu, co daje sposobność do porównania przebiegu zmiennych z dwóch różnych okresów.

Gdy choć jeden przebieg korzysta z dodatkowego okresu czasu:

- ponad wykresem pojawia się druga oś czasu,

- w edytorze okresu pojawia się możliwość edycji okresu dodatkowego.

Gdy tylko jeden przebieg korzysta z dodatkowego okresu czasu, druga oś czasu rysowana jest w kolorze tego przebiegu.

powiększ >>

Rys. Przykład wykresu z dodatkową osią czasu.

***

Dodatkowa oś czasu załączana jest dla danego przebiegu przyciskiem [image] z zakładki Przebieg okna głównego programu AsTrend > grupy Przebieg.

***

Format zapisu czasu z dodatkowej osi czasu definiowany jest w oknie 'Opcje okresu trendu' > zakładce Format zapisu czasu, uruchamianym za pomocą przycisku [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Osie.

Standardowo używany jest tryb automatyczny (format domyślny), przyjmujący opis typu ”yy-mm-dd" - jeśli wyświetlany okres jest większy niż dzień oraz opis typu ”hh:mm" - w pozostałych przypadkach. Takie rozwiązanie aczkolwiek wygodne, bo podczas powiększania lub pomniejszania automatycznie zmienia się sposób opisu osi, nie zawsze może użytkownikowi odpowiadać. Istnieje zatem możliwość wyboru innego sposobu opisu lub też zdefiniowania własnego formatu.

Do wyboru są następujące formaty:

  • yy-mm-dd hh:mm:ss

  • yy-mm-dd hh:mm

  • yy-mm-dd hh

  • yy-mm-dd

  • yy-mm

  • mm-dd hh:mm:ss

  • mm-dd hh:mm

  • mm-dd hh

  • mm-dd

  • dd hh:mm:ss

  • dd hh:mm

  • dd hh

  • hh:mm:ss

  • hh:mm

  • mm:ss

Wybór formatu własnego wymaga jego określenia w odpowiednim polu edycyjnym. Wpisanie np. łańcucha "yy*mm*dd" spowoduje wyprowadzanie daty w ten sposób, że jej pola zostaną rozdzielone gwiazdkami (zamiast standardowych kresek).

powiększ >>

Rysunek: Okno formatu zapisu czasu dla głównej i dodatkowej osi czasu.

***

Czas dla dodatkowej osi czasu określany jest przy użyciu przycisku [image], który uruchamia okno z opcjami ustawiania okresu czasu (zakładka Narzędzia główne okna głównego programu AsTrend > grupa Okres). Początek okresu dodatkowej osi czasu ustawiany jest opcją Przesunięcie względem głównej osi czasu (przesunięcie może być dodatnie lub ujemne) lub opcją Absolutna lub względna chwila czasowa.

powiększ >>

Rys. Okno ustawiania okresu czasu na głównej i dodatkowej osi czasu.


Wykres liniowy

2.19.1 Wykres liniowy

Wykres liniowy jest najczęściej stosowanym (i domyślnym) typem wykresu.

Wykres liniowy załączany jest przyciskiem [image] (zakładka Przebieg okna głównego programu AsTrend > grupa Przebieg). Przykładowy wykres liniowy przedstawiony został poniżej.

Wykres może być wyświetlany w trybie 3D.

***

powiększ >>

Rysunek: Wykres liniowy 3D.


Wykres słupkowy

2.19.2 Wykres słupkowy

Wykres słupkowy jest często stosowanym typem wykresu.

Wykres słupkowy załączany jest przyciskiem [image] (zakładka Przebieg okna głównego programu AsTrend > grupa Przebieg). Przykładowy wykres słupkowy przedstawiony został poniżej.

Wykres może być wyświetlany w trybie 3D.

***

powiększ >>

Rysunek: Wykres słupkowy 3D.


Wykres obszarowy

2.19.3 Wykres obszarowy

Wykres obszarowy załączany jest przyciskiem [image] (zakładka Przebieg okna głównego AsTrend > grupa Przebieg). Przykładowy wykres obszarowy przedstawiony został poniżej.

Wykres może być wyświetlany w trybie 3D.

powiększ >>

Rysunek: Wykres obszarowy 3D.


Wykresy zmiennych dwustanowych

2.19.4 Wykresy zmiennych dwustanowych

Wykresy zmiennych dwustanowych rysowane są na osobnych osiach dla wszystkich typów wykresów serii i wszystkich typów osi trendu.

Zmienna jest traktowana w programie AsTrend jako dwustanowa, jeśli ma zakres pomiarowy 0-1 i może przyjmować tylko wartości całkowite.

Wykresy zmiennych binarnych mają możliwość wyświetlania opisów stanów zmiennych (patrz: 2.16 Wyświetlanie opisów wartości zmiennych).

Rysunek: Wykres zmiennych dwustanowych.


Wyświetlanie opisów wartości zmiennych

2.20 Wyświetlanie opisów wartości zmiennych

W programie AsTrend istnieje możliwość wyświetlania opisów stanów jako etykiet osi wartości dla wykresów fizycznych.

W przypadku wyświetlania wykresów wielu zmiennych - warunkiem koniecznym jest, aby wszystkie zmienne miały identyczne opisy stanów.

Mechanizm wyświetlania wartości stanów wymaga zadeklarowania zmiennych, które będą odpowiadać stanom zmiennych monitorowanych. Definicje zmiennych obsługujących definicje stanów przygotowuje projektant aplikacji systemu Asix - szczegóły na temat przygotowania definicji zmiennych obsługujących definicje stanów omawia podręcznik do Architekta, rozdział 2.7. Przechowywanie opisów stanów zmiennych w bazie definicji zmiennych.

UWAGA:

Przy dodawaniu zmiennych systemu Asix i zmiennych zewnętrznych program AsTrend sprawdza, czy zmienna ma zdefiniowane opisy stanów - i jeśli tak, dla przebiegu zmiennej automatycznie załączana jest interpolacja schodkowa.

powiększ >>

Rys. Opisy stanów jako wartości osi OY.


Operacje na zmiennych

2.21 Operacje na zmiennych

Jeżeli w oknie trendu wyświetlona została grupa zmiennych, to można wykonywać na pojedynczych zmiennych, lub też całej ich grupie pewne operacje. Można je wykonywać za pośrednictwem poleceń umieszczonych na zakładkach Wstążki. Operacje wykonywane jedynie na konkretnych zmiennych wymagają wcześniejszego ich wyselekcjonowania. Brak selekcji oznacza w tym przypadku, że operacja zostanie wykonana na wszystkich zmiennych wchodzących w skład trendu.


Selekcja jednej lub wszystkich zmiennych

2.21.1 Selekcja jednej lub wszystkich zmiennych

W celu wykonania dowolnej operacji na jednej lub wszystkich krzywych należy dokonać selekcji zmiennych.

Selekcji pojedynczej zmiennej można dokonać:

  • kliknięciem lewym klawiszem myszy na linii wykresu;

  • kliknięciem lewym klawiszem myszy na legendzie w polu wiersza zmiennej.

Wybór wszystkich zmiennych następuje po dwukrotnym kliknięciu lewym klawiszem myszy na obszarze wykresu poza liniami krzywych.


Usuwanie zmiennych

2.21.2 Usuwanie zmiennych

Usunięcia zmiennej można dokonać przy pomocy:

  • przycisku [image] na zakładce Narzędzia główne okna głównego programu AsTrend > w grupie Nowy przebieg;

  • kontekstowego menu otwieranego w obszarze wykresów - polecenie Usuń zaznaczone przebiegi;

  • klawisza DEL.

Jeśli wybrane są wszystkie zmienne, to polecenie [image] usuwa wszystkie zmienne.

Usunięcie wyselekcjonowanej zmiennej powoduje, że następna w legendzie zmienna staje się zmienną wyselekcjonowaną.


Wyświetlanie metryki zmiennej

2.21.3 Wyświetlanie atrybutów zmiennej

Wyświetlenia definicji zmiennej (wartości atrybutów zmiennej z aplikacji Asix) można dokonać przy pomocy:

  • przycisku [image] na zakładce Przebieg okna głównego programu AsTrend > w grupie Przebieg;

  • polecenia Atrybuty przebiegu z menu kontekstowego wywołanego w obszarze wykresów.

Poniżej umieszczono przykładowe okno wyświetlające metrykę.

Rysunek: Metryka zmiennej.

Powyższe dane pobierane są z bazy definicji zmiennych aplikacji Asix.


Wyświetlenie etykiet

2.21.4 Wyświetlenie etykiet

Dla każdej zmiennej można wyświetlić tzw. etykiety. Są to umieszczone powyżej punktów pomiarowych prostokąty z wyświetloną wartością odpowiadającą danemu pomiarowi.

Wyświetlenia etykiet dokonać można przy pomocy przycisku [image] na zakładce Przebieg okna głównego programu AsTrend > w grupie Przebieg;

powiększ >>

Rysunek: Wykres zmiennych z załączonymi etykietami.

Podświetlony przycisk odpowiada sytuacji załączenia wyświetlania etykiet. Działanie tej funkcji uzależnione jest od kontekstu. Jeżeli w chwili naciskania przycisku [image] jest wyselekcjonowana jakaś zmienna, to etykiety zostaną wyświetlone lub usunięte jedynie na krzywej odpowiadającej wyselekcjonowanej zmiennej - w przeciwnym razie etykiety zostaną wyświetlone lub usunięte na wszystkich przebiegów.

W przypadku przebiegu, dla którego opisy stanów podane są w bazie definicji zmiennych, po włączeniu opcji wyświetlania etykiet zostaną wyświetlone w etykietach nazwy stanów danej zmiennej.


Wyswietlenie punktow

2.21.5 Wyświetlenie punktów

Dla każdej zmiennej można wyświetlić punkty. Są to umieszczone w miejscach odpowiadających punktom pomiarowym znaczki graficzne - kwadraciki. Funkcja ta działa dla wykresów liniowych i obszarowych.

Wyświetlenia punktów dokonać można przy pomocy przycisku [image] na zakładce Przebieg okna głównego programu AsTrend > w grupie Przebieg.

Załączenie wyświetlania punktów aktywuje pola umożliwiające deklarowanie: kształtu graficznego znacznika punktu, jego wielkości oraz ramki:

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala wybrać kształt znacznika graficznego;

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala określić wielkość znaczników graficznych;

- dotyczy wykresów z załączoną opcją graficznej prezentacji punktów pomiarowych za pomocą znaczników graficznych; pozwala załączyć ramkę znacznikom graficznym;

powiększ >>

Rysunek: Wykres zmiennych z załączonymi punktami.

Podświetlony przycisk odpowiada sytuacji załączenia wyświetlania punktów.
Działanie tej funkcji uzależnione jest od kontekstu. Jeżeli w chwili naciskania przycisku [image] jest wyselekcjonowany jakiś przebieg, to punkty zostaną wyświetlone lub usunięte jedynie na przebiegu odpowiadającemu wyselekcjonowanej zmiennej. W przeciwnym razie punkty zostaną wyświetlone lub usunięte na wszystkich przebiegach.


Zmiana zakresu zmiennej

2.21.6 Zmiana zakresu zmiennej

Działanie tej funkcji dotyczy wyselekcjonowanej zmiennej.

Zmianę zakresu (minimum i maksimum) przebiegu zmiennej dokonać można przy pomocy:

  • kliknięcia w obszarze Legendy w polu Zakres wyświetlania.

Spowoduje to wyświetlenie okienka 'Opcje przebiegu’ z możliwością dokonania zamiany wartości zakresu pomiarowego i zakresu wyświetlania na zakładce Atrybuty:

powiększ >>

Rysunek: Okno 'Opcje przebiegu' - zakładka 'Atrybuty'.

- Zakres wyświetlania - zakres wyświetlania służy do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres wyświetlania i Największy zakres wyświetlania). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu wyświetlania - wówczas zakres osi będzie wyliczany na podstawie bieżących wartości próbek.

Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy wyświetlania wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy wyświetlania, zakres ustalany jest automatycznie.

- Zakres pomiarowy - zakres pomiarowy służy do sprawdzania poprawności wartości próbek przebiegu. Wartości próbek, które przekraczają zakres przebiegu o liczbę równą szerokości zakresu przebiegu są obcinane. Wprowadzenie wartości zakresu 0-1 dla zmiennej systemu Asix typu całkowitego powoduje, że zmienna jest traktowana jako binarna.

Zakres pomiarowy może być także użyty do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego programu AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres pomiarowy i Największy zakres pomiarowy). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu pomiarowego. Jeśli zakres pomiarowy jest wybrany do skalowania osi, to zakresy osi będą wtedy wyliczane na podstawie bieżących wartości próbek. Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy pomiarowe wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy pomiarowe, zakres ustalany jest automatycznie.

Standardowo wykres posiada zakres wyznaczony na podstawie bazy definicji zmiennych (np. 0-10000).


Wybor interpolacji

2.21.7 Wybór interpolacji

Standardowo stosowana jest interpolacja liniowa. Można również zastosować interpolację schodkową, co wskazane jest w przypadku wykresów wielostanowych.

Działanie tej funkcji dotyczy wyselekcjonowanej zmiennej.

Zmienić rodzaj interpolacji przebiegu zmiennej można przy pomocy:

  • przycisku [image] na zakładce Przebieg okna głównego programu AsTrend > w grupie Przebieg;

Różnice pomiędzy sposobami interpolacji ilustruje poniższy rysunek.

UWAGA:

Przy dodawaniu zmiennych systemu Asix i zmiennych zewnętrznych program AsTrend sprawdza, czy zmienna ma zdefiniowane opisy stanów - i jeśli tak, dla przebiegu zmiennej automatycznie załączana jest interpolacja schodkowa.

powiększ >>

Rysunek: Przykład zastosowania interpolacji schodkowej i liniowej.


Ukrywanie przebiegu zmiennej

2.21.8 Ukrywanie przebiegu zmiennej

Standardowo przebieg zmiennej ustawiony jest jako widoczny.

Działanie tej funkcji dotyczy wyselekcjonowanej zmiennej.

Ukrycia lub pokazania przebiegu zmiennej dokonać można przy pomocy:

  • przycisku [image] na zakładce Przebieg okna głównego programu AsTrend > w grupie Operacje przebiegu;

  • polecenia [image] w menu kontekstowym legendy.

Podświetlony przycisk odpowiada ukryciu przebiegu zmiennej.


Zmiana koloru

2.21.9 Zmiana koloru

Każdej zmiennej można zmienić kolor. Normalnie koloru nie trzeba deklarować - program automatycznie przydziela kolejnym zmiennym kolejne kolory domyślne (czerwony, zielony, żółty...). Jeśli jednak z pewnych przyczyn nie podobają się nam te kolory lub też należy skorelować kolor z rodzajem pomiaru, wówczas można skorzystać z funkcji zmiany koloru.

Najpierw zmienną należy wyselekcjonować, a następnie dokonać zmiany koloru przy pomocy:

  • okna opcji przebiegu wywoływanego przyciskiem [image] z zakładki Przebieg okna głównego AsTrend > grupy Przebieg. W oknie 'Opcje przebiegu', na zakładce Wygląd znajduje się opcja Użyj własnego koloru; w ten sposób można zadeklarować swój własny kolor linii wykresu.

Można również:

  • wykorzystać predefiniowane palety kolorów zmiennych, dostępne na zakładce Trend i legenda > grupie Trend, pod przyciskiem Paleta kolorów [image];

  • zdefiniować własną paletę kolorów w oknie 'Opcje trendu' (wywoływanym przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > grupy Trend). W tym celu należy na zakładce Wygląd okna 'Opcje trendu' zaznaczyć opcję Użyj palety kolorów i na aktywowanej wówczas zakładce Paleta kolorów zaznaczyć wariant <Własna paleta trendu>. Pozwoli to zdefiniować własne kolory dla poszczególnych kwadratów odpowiadających kolejno dodawanym do wykresu zmiennym.

powiększ >>

Rys. Okno definiowania własnej palety kolorów przebiegów.


Operacje na wyświetlanych przebiegach

2.22 Operacje na wyświetlanych przebiegach

Po narysowaniu trendu w typowych przypadkach wykonuje się w oknie trendu operacje pozwalające na optymalne dostosowanie widoku wyświetlanych krzywych do aktualnych potrzeb.

Wykonanie pewnych operacji może skutkować niemożnością wykonania innych operacji. Przykładowo, jeśli rejestracja przebiegu jest włączona, to nie można się przesuwać wzdłuż wykresu itp.


Tryb żywy

2.22.1 Tryb żywy

Każdy trend może znajdować się w danym momencie w trybie rejestracji zmiennych.

Tryb żywy może być załączony/wyłączony przy pomocy:

  • przycisku [image] na zakładce Narzędzia główne okna głównego programu AsTrend > w grupie Przesuwanie okresu.

Tryb rejestracji przeznaczony jest zasadniczo do ciągłej obserwacji świeżo pojawiających się danych. Obszar wykresów jest wówczas odrysowywany co 2 sekundy.

W trybie zatrzymania rejestracji okres czasu trendu się nie zmienia - trend jest nieruchomy. W tym trybie można wykonywać wszelkie inne operacje.


Powiększenie

2.22.2 Powiększenie

Każdy fragment trendu wewnątrz pola wykresów może zostać powiększony.

Powiększenia można dokonać na poniżej opisane sposoby:

  • Zaznaczając prostokątny obszar, który chcemy powiększyć, przy pomocy myszki (rysunek poniżej). Obszar powinien być zaznaczany od lewej strony do prawej z naciśniętym lewym klawiszem myszki. Puszczenie klawisza powoduje wykonanie powiększenia w poziomie i pionie. Górny lewy róg obszaru nie może pokrywać się z krzywą, bo wtedy kliknięcie jest traktowane jako selekcja.

Operacja zaznaczenia fragmentu wykresu 'od prawej do lewej' działa odwrotnie do operacji powiększenia - umożliwia powrót do poprzedniego okresu w historii zmian (operację można powtarzać aż do momentu wyświetlenia pierwszego okresu zapamiętanego w historii zmian). Jest to operacja pomniejszania w poziomie.

Rysunek: Powiększenie wybranego obszaru wykresu.

  • Powiększenia można dokonać również zaliczając opcję [image] Powiększanie, a następnie używając polecenia [image] Powiększ (zakładka Wykres okna głównego AsTrend > grupa Powiększanie) lub używając rolki myszy. Ruch kółka myszki przy wciśniętym klawiszu Ctrl lub Shift powiększa wykres tylko względem jednej osi.

..

Pomniejszenia można dokonać przy pomocy przycisku [image] (zakładka Wykres okna głównego AsTrend > grupa Powiększanie) - po uprzednim załączeniu opcji [image] Powiększanie i wykonaniu operacji powiększenia.

Możliwa jest opcja zakazania powiększania obszaru wykresu:

  • Wyłączenie powiększania można uzyskać 'wyklikując' przycisk [image] (zakładka Wykres okna głównego AsTrend > grupa Powiększanie). Wyłączenie to nie ogranicza operacji powiększania fragmentu wykresu poprzez przeciąganie myszy 'od lewej do prawej'.


Przesunięcie

2.22.3 Przesunięcie

Wyświetlony obszar wykresu zgodnie z danymi początkowymi, może zostać przesunięty w przód lub w tył w zależności od potrzeby.

Przesunięcia można dokonać przy użyciu następujących przycisków (zakładka Narzędzia główne okna głównego AsTrend > grupa Przesuwanie okresu):

Zmniejsz okres - zmniejszenie okresu następuje wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

Zwiększ okres - zwiększenie okresu następuje wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

Do początku danych - powoduje przesunięcie do początku przebiegu; polecenie dostępne dla wybranych rodzajów przebiegów (m.in. danych zewnętrznych, pliku archiwum Asix, przebiegów z AsBase);

Do tyłu o okres - przesunięcie o bieżący okres do tyłu;

Do tyłu - przesunięcie o ¼ okresu do tyłu;

Do przodu - przesunięcie o ¼ okresu do przodu;

Do przodu o okres - przesunięcie o bieżący okres do przodu;

Do końca danych - przesunięcie do końca przebiegu.


Odczyt wartości

2.22.4 Odczyt wartości

Możliwy jest odczyt wartości wskazanej kursorem. W tym celu należy wskazać kursorem żądany punkt. W momencie, kiedy kursor pojawi się na tle krzywej, wówczas zmienia się jego kształt (ze strzałki na krzyżyk). Wtedy należy kliknąć myszką w danym punkcie i po chwili w okienku obok kursora pojawi się wskazana wartość wraz z odpowiadającym jej czasem (rysunek poniżej). Okienko pozostaje wyświetlone do momentu poruszenia kursora.

Rysunek: Odczyt wartości.

Ubocznym efektem odczytu wartości jest selekcja danej zmiennej.

Odczytu bloku wartości można dokonać z tabeli wartości.


Selekcja zmiennej

2.22.5 Selekcja zmiennej

W wielu przypadkach przed wykonaniem określonej operacji należy wykonać selekcję zmiennych tak, aby następna operacja dotyczyła właśnie tej zmiennej.

Istnieją następujące sposoby selekcji zmiennej:

  • klikając myszką na krzywej w obszarze wykresów (przed kliknięciem kursor powinien zmienić kształt ze strzałki na krzyżyk - tak jak przy odczycie wartości);

  • klikając w obszarze legendy w linii odpowiadającej określonej zmiennej.

Nazwa takiej wyselekcjonowanej zmiennej pojawi się w polu statusowym. Efektem ubocznym będzie uaktywnienie pewnych przycisków w pasku narzędzi oraz pewnych pozycji w menu, które są aktywne pod warunkiem dokonania selekcji.


Przywrócenie oryginału

2.22.6 Przywrócenie oryginału

Po wykonaniu dowolnych operacji zmiany wyglądu okna trendów zawsze można przywrócić stan początkowy.

Przywrócenie oryginału następuje z wykorzystaniem polecenia Przywróć oryginał [image], które dostępne jest w menu Plik okna głównego AsTrend. Powoduje ono, że na ekranie pojawia się ostatnio wczytany trend.


Blokowanie\odblokowanie rozmiarów i układu okna

2.22.7 Blokowanie\odblokowanie rozmiarów i układu okna

Blokady lub odblokowania rozmiarów i układu okna można dokonać tylko w trybie administratora.

Służą do tego opcje:

- parametr Blokada rozmiaru okna, dostępny w oknie 'Opcje okna trendu' (okno uruchamiane przyciskiem [image] na zakładce Widok okna głównego AsTrend > grupie Okno) lub pod przyciskiem Blokada rozmiarów okna [image] (zakładka Widok okna głównego AsTrend > grupa Okno).

Jeśli opcja jest włączona, to położenie i rozmiar okna są przechowywane w pliku trnx. Przy otwieraniu pliku trendu położenie i rozmiar są odtwarzane.

Jeśli plik trendu jest otwierany przy pomocy akcji operatorskiej, to jako parametr akcji można podać zadane położenie okna:

- dla wersji Evo Asixa stosowana jest akcja AstrendDisplay - patrz: Asix.Evo_Akcje_operatorskie.PDF.CHM,

- dla wersji klasycznej Asixa stosowana jest akcja ASTREND - patrz: Asix.PDF/CHM.

Podczas pracy poza systemem Asix można włączyć opcję programu pozwalającą na ignorowanie pozycji i blokady zmiany rozmiarów okna zapamiętanych w pliku trendu: menu Plik okna głównego AsTrend > Opcje programu > zakładka Okna > opcja Położenie głównego okna.

Praca w trybie blokady rozmiarów i układu okna jest przeznaczona dla operatora. W tym trybie nie można zmienić rozmiarów poszczególnych pól okna trendu. Równocześnie zablokowane jest dla operatora zakończenie programu AsTrend.

O ile administrator zapamiętując trend nie zablokuje rozmiarów okna, to trend otwarty w trybie operatora będzie traktowany jako wzorzec, ale nie będzie miał zablokowanych rozmiarów.


Obsługa wykresów 3D

2.23 Obsługa wykresów 3D

Program AsTrend daje możliwość prezentowania wykresów w widoku 3D. Istnieją dwa typy wykresów 3D:

1. wykres 3D z możliwością przestrzennej manipulacji obszarem wykresu w trzech płaszczyznach;

2. wykres w rzucie prostokątnym.

3D z pełną obsługą manipulacji obszarem wykresu w trzech płaszczyznach

3D jest zalecaną formą prezentacji wykresu 3D. Umożliwia manipulowanie obrotem, pochyleniem, perspektywą, wielkością i głębią obszaru wykresu.

Aby przełączyć wykres na wersję trójwymiarową, należy użyć przycisku [image] , znajdującego sie na zakładce Wykres okna głównego programu AsTrend > w grupie Wygląd.

Typ 3D załączany i parametryzowany jest za pomocą przycisku [image] , który uruchamia listę dostępnych parametrów widoku 3D: zakładka Wykres okna głównego AsTrend > grupa 3D > opcja 3D:

- Obrót pozwala obracać obszarem wykresu wokół osi pionowej;

- Pochylenie pozwala obracać obszarem wykresu wokół osi poziomej;

- Perspektywa pozwala załączyć perspektywę;

- Powiększenie pozwala określić wielkość obszaru wykresu;

- Głębia pozwala pogłębić perspektywę;

- Wybierz widok dostarcza przedefilowane ujęcia 3D:

- Widok 3D z przodu;

- Widok 3D z prawej;

- Widok 3D z lewej;

Rys. Wykres słupkowy w pełnym 3D.

Rzut prostokątny

Rzut prostokątny jest zdecydowanie prostszą formą prezentacji wykresu 3D. Umożliwia jedynie manipulowanie kątem i głębią obszaru wykresu.

Nie zaleca się stosowania tego typu dla wykresów liniowych. Dużo lepsze efekty wizualizacji wykresów liniowych w wersji trójwymiarowej uzyskuje się stosując wariant 3D z możliwością manipulacji obszarem wykresu w 3 płaszczyznach.

Aby przełączyć wykres na wersję trójwymiarową na typ Rzut prostokątny, należy użyć przycisku [image] , znajdującego sie na zakładce Wykres okna głównego AsTrend > w grupie Wygląd.

Typ Rzut prostokątny załączany i parametryzowany jest za pomocą przycisku [image] , który uruchamia listę dostępnych parametrów widoku 3D: zakładka Wykres okna głównego AsTrend > grupa 3D > opcja Rzut prostokątny:

- Kąt określa kąt pomiędzy krawędzią na styku ściany bocznej i dolnej wykresu a krawędzią poziomą dolnej ściany;

- Głębia określa długość krawędzi na styku ściany bocznej i dolnej wykresu; im krawędź jest dłuższa tym większe wrażenie głębi;

- Wybierz widok dostarcza predefiniowane ujęcia rzutu prostokątnego:

- Rzut prostokątny z prawej;

- Rzut prostokątny z lewej;

Rys. Fragment wykresu w rzucie prostokątnym - parametr: Kąt.

Rys. Wykres słupkowy w rzucie prostokątnym.


Opcje programu

2.24 Opcje programu

Okno z opcjami programu uruchamiane jest poleceniem Opcje programu z menu Plik. Opcje zawarte we wspomnianym oknie pozwalają dokonać ustawień dla programu AsTrend w następujących obszarach funkcjonalnych (większość z opcji została już omówiona we wcześniejszych rozdziałach, poświęconych poszczególnym aspektom obsługi programu AsTrend):

- położenie okna trendów;

- serwery danych;

- deklarowanie rodzaju okna używanego do otwierania pliku trendu (okno wbudowane z podglądem zawartości pliku lub onko systemowe);

- diagnostyka z informacjami na temat lokalizacji logów i programu AsTrend, ponadto na temat parametrów przekazywanych z aplikacji Asix (w przypadku uruchomienia AsTrend razem z aplikacją Asixa), łączności ze źródłem danych (gdy AsTrend uruchamiany jest w postaci przeglądarkowej);

- format wydruku trendów oraz domyślnego formatu papieru aplikacji;

- deklarowanie bieżących opcji trendu lub wbudowanych opcji trendu jako domyślnych dla nowo tworzonych plików trendów; zapamiętywanie bieżącego układu legendy jako wariantu domyślnego dla nowych plików trendów;

- paleta kolorów;

- wybór generowanych ostrzeżeń;

- parametry linii odczytu oraz osi pionowej przebiegu dwustanowego.

Poniżej opis parametrów deklarowanych na poszczególnych zakładkach okna 'Opcje programu':

***

Zakładka O kna pozwala określić, czy podczas pracy programu AsTrend poza aplikacją systemu Asix informacje o położeniu okna i opcja blokady zmiany rozmiarów okna trendów będą ignorowane.

Istnieje też możliwość zadeklarowania automatycznej aktywacji zakładek tabeli danych bieżących oraz schowka okresów po otwarciu okna tabeli danych lub schowka okresów. Dodatkowe zaznaczenie opcji Automatycznie aktywuj zakładkę po aktywacji okna (przy zaznaczonej opcji Automatycznie aktywuj zakładkę po otwarciu okna) powodować będzie przejście do zakładki tabeli danych bieżących lub schowka okresów w momencie, gdy oknem aktywnym będzie odpowiednio: tabela danych lub schowek okresów.

Wstążka - puste grupy poleceń i puste zakładki pozwala ukrywać puste grupy poleceń i puste zakładki.

Możliwość używania klawiatury ekranowej daje opcja Okna dialogowe - Pokaż przycisk klawiatury ekranowej, która załącza na każdym formularzu ikonkę pozwalającą na uruchomienie klawiatury ekranowej.

powiększ >>

Rysunek: Opcje programu - Okna.

***

Zakładka Sieć daje możliwość zadeklarowania nazw serwerów danych, z którego pobierane będą dane do wyświetlania wykresów trendów oraz maksymalnego czasu oczekiwania na zgłoszenie się serwera i maksymalnego czasu odpowiedzi serwera danych.

Jeśli program AsTrend został uruchomiony bez uruchamiania aplikacji systemu Asix, a serwer Asix używa tylko protokołu TCP/IP lub znajduje się w innej podsieci, to należy skonfigurować połączenie TCP/IP z tym serwerem, używając polecenie: 'Narzędzia/Moduł sieci - opcje' programu Architekt.

powiększ >>

Rysunek: Opcje programu - Sieć.

***

Zakładka Okno otwarcia pliku trendu, dostępna gdy AsTrend uruchamiany jest niezależnie od aplikacji systemu Asix, umożliwia zadeklarowanie rodzaju okna, które będzie służyć do otwierania plików trendu:

- Używaj wbudowanego okna, umożliwiającego podgląd zawartości pliku trendu;

- Używaj systemowego okna wyboru pliku do otwarcia pliku trendu.

powiększ >>

Rysunek: Opcje programu - Okno otwarcia pliku trendu.

***

Zakładka Diagnostyka dostarcza informacji na temat plików logu oraz parametrów przekazywanych z aplikacji Asix.

Gdy AsTrend uruchamiany jest razem z aplikacją systemu Asix, zakładka Diagnostyka zawiera dane na temat parametrów przekazywanych z aplikacji Asixa:

- Nie zezwalaj na zapisywanie plików trendów;

- Nadaj operatorowi prawa Administratora programu AsTrend;

- Katalog roboczy;

- Baza definicji zmiennych programu AsTrend;

Gdy AsTrend uruchamiany jest w postaci przeglądarkowej, zakładka Diagnostyka zawiera dodatkowo dane na temat:

- adresów serwerów danych;

- nazwy pliku bazy definicji zmiennych;

- informacje na temat inicjalizacji serwera licencji;

- informacje na temat statusu połączenia z serwerem licencji.

Dodatkowo, zakładka Diagnostyka zawiera opcje Aslink (jeśli są zdefiniowane).

powiększ >>

Rysunek: Opcje programu - podstawowy widok zakładki Diagnostyki.

powiększ >>

Rys. Opcje programu - Okno diagnostyki - parametry przekazane z aplikacji Asix.

powiększ >>

Rys. Opcje programu - Okno diagnostyki - parametry wersji przeglądarkowej AsTrend.

***

Zakładka Wydruk PDF pozwala określić format papieru przy eksporcie do pliku PDF oraz domyślny format papieru aplikacji.

Wydruk realizowany jest w trybie wysokiej jakości.

powiększ>>

Rysunek: Opcje programu - Okno wydruku do PDF.

***

Zakładka Nowe trendy umożliwia ustawienie bieżących opcji trendu jako domyślnych dla nowo tworzonych plików trendów. Mechanizm ten zadziała nie tylko w czasie nieprzerwanego działania programu AsTrend. Jeśli AsTrend uruchamiany jest razem z aplikacją - zatrzymanie aplikacji i ponowne jej uruchomienie (i tym samym ponowne uruchomienie programu AsTrend) spowoduje, że również przywołane zostaną domyślne opcje trendu.

W celu zapisania indywidualnych opcji trendu, należy zdefiniować te opcje, a następnie przycisnąć przycisk Używaj bieżących opcji trendu na zakładce Nowe trendy. Pojawi się komunikat, ze bieżące opcje trendu zostały zapamiętane.

W podobny sposób można zapamiętać bieżący układ legendy jako domyślny dla nowo tworzonych plików trendu.

Użycie opcji Używaj wbudowanych opcji trendu spowoduje, ze zostana użyte domyślne wbudowane w program opcje trendu.

powiększ >>

Rysunek: Opcje programu - Nowe trendy.

***

Zakładka Paleta kolorów pozwala przygotować domyślną paletę kolorów, zgodnie z którą dodawane będą do zestawu kolejne krzywe. Istnieje kilka predefiniowanych zestawów kolorystycznych, niemniej użytkownik może zdefiniować swój własny zestaw.

powiększ >>

Rysunek: Opcje programu - Paleta kolorów.

***

Zakładka Ostrzeżenia zawiera listę możliwych do wyświetlenia typów ostrzeżeń - zaznaczenie checkboxu przy wybranym typie oznacza, że ten rodzaj ostrzeżenia będzie wyświetlany w trakcie pracy programu AsTrend.

powiększ >>

Rysunek: Opcje programu - Ostrzeżenia.

***

Grubość linii odczytu (głównej i dodatkowej) określana jest przy pomocy okna Opcje programu > zakładka Wykres.

powiększ >>

Rysunek: Opcje programu - Linie odczytu.


Opcje typu i wyglądu wykresu

2.25.1 Opcje typu i wyglądu wykresu

Zakładki z okna 'Opcje wykresu' wywoływanego przyciskiem [image] z zakładki Wykres okna głównego programu AsTrend > z grup: Typ wykresu, Osie lub Wygląd) umożliwiają przeprowadzenie parametryzacji wykresu pod względem typu wykresu (XT, XY i X), wyglądu wykresu, osi oraz legendy wyświetlanej w obszarze wykresu.

Zakładka Typ zawiera następujące parametry:

- Typ wykresu:

- Rysuj wykres XT;

- Rysuj wykres XY - dla wykresu XY dane pobierane są z archiwum jako dane równomierne. Możliwe jest utworzenie wykresu XY dla dwóch typów osi OY: Jedna oś OY i Wiele osi OY. W przypadku wyboru typu Jedna oś OY, do tworzenia wykresu XY używane są dane z pierwszych dwu przebiegów. Przebiegi te nie mogą zawierać danych binarnych.

- Rysuj wykres X

- Etykiety na wykresie XY - umożliwia wybór treści etykiet:

- Numer punktu przebiegu;

- Numer punktu, stempel czasu;

- Numer punktu, stempel czasu, wartości próbek z dwu przebiegów,

- Numer punktu, stempel czasu, wartości próbek trzech przebiegów.

powiększ >>

Rys. Opcje wykresu - Typ.

***

Zakładka Wygląd zawiera następujące parametry:

- Kolory tła - opcja pozwala określić kolor i gradient tła trendu oraz tła obszaru wykresu.

- Tytuł wykresu - opcja pozwala określić widoczność, tekst oraz kolor tytułu wykresu.

- Wykres w trybie 3D - pozwala załączyć tryb 3D wyświetlania obszaru wykresu.

- Marginesy: określają odległość etykiety wartości maksymalnej od górnej krawędzi obszaru wykresu i odległość etykiety wartości minimalnej od dolnej krawędzi obszaru wykresu.

- Pokaż wykres również poza osiami - załączenie opcji umożliwia rysowanie przebiegów poza osiami wykresu; krzywe i etykiety nie są obcinane do rozmiarów wykresu (przydatne to jest w przypadku, gdy linia wykresu pokrywa się z osią poziomą lub znajduje się na górnej linii ograniczającej wykres; lepiej wygląda też wykres w wersji trójwymiarowej z załączoną opcją rysowania poza osiami wykresu) - przykład - patrz niżej:

powiększ >>

Rys. Opcje wykresu - Wygląd.

powiększ >> 1 2

Rys. Przykład przed i po załączeniu opcji rysowania poza osiami.


Opcje osi trendu

2.25.2 Opcje osi wykresu

Opcje osi wykresu mogą być zdefiniowane z poziomu okna 'Opcje wykresu’ otwieranego przyciskiem [image] z zakładki Wykres okna głównego programu AsTrend > z grupy Osie.

Powyższe parametry omówione zostały w kolejnych rozdziałach wg nazw zakładek okna 'Opcje wykresu', na których zostały umieszczone.


Opcje typu i wyglądu

2.25.2.1 Opcje typu i wyglądu osi wykresu

Okno 'Opcje wykresu' wywoływane przyciskiem [image] z zakładki Wykres okna głównego programu AsTrend > z grupy Osie umożliwia ustawienie następujących opcji:

- Typ osi pionowej - zdefiniowanie typu osi pionowej:

- Oś OY - fizyczna

- Oś OY - procentowa

- Wiele osi OY

- Wiele osi OY - stos

- Osie:

- Osie widoczne - załączenie osi OX i OY.

- Pole wyboru koloru - zadeklarowanie koloru osi; kolor osi jest jednocześnie kolorem tekstu etykiet obu osi.

- Siatka - załączenie siatki na wykresie, zadeklarowanie formatu linii siatki - do wyboru: linia punktowa lub ciągła oraz określenie koloru siatki.

powiększ >>

Rys. Opcje osi wykresu - opcje widoczności i typu.


Opcje fizycznej osi OY

2.25.2.2 Opcje fizycznej osi OY

Opcje ustawiane w odniesieniu do fizycznej osi pionowej dostępne są z poziomu przedstawionego poniżej okna:

zakładka Wykres okna głównego programu AsTrend > grupa Osie > okno 'Opcje wykresu' wywoływane przyciskiem [image] > zakładka 'Oś fizyczna OY'

Każdy otwierany trend posiada domyślnie oś ustawioną na zakres zgodny z zakresem wyświetlania. Minimum stanowi najmniejsza wartość spośród minimów odczytanych dla wszystkich zmiennych zdefiniowanych w trendzie. W analogiczny sposób wyliczane jest maksimum jako największa wartość ze wszystkich maksimów.

Istnieje możliwość określenia dla minimum i maksimum, czy mają one być:

  • wyznaczane na podstawie wartości zakresu wyświetlania,

  • wyznaczane na podstawie wartości zakresu pomiarowego,

  • wyznaczane na podstawie najmniejszej/największej wartości próbki,

  • podawane arbitralnie przez użytkownika.

Ustawiony ręcznie zakres obowiązywał będzie aż do następnej zmiany.

Obliczenie zakresu polega na wyznaczeniu najmniejszej wielkości minimum oraz największej wartości maksimum dla wszystkich krzywych trendu.

Dodatkowo okno umożliwia modyfikację sposobu wyświetlania etykiet opisujących oś pionową przy użyciu opcji Format etykiet. Edytując domyślny format można określić np. liczbę miejsc po przecinku, ilość wyprowadzanych pozycji, znak oddzielający część całkowitą od ułamkowej itp.

powiększ >>

Rysunek: Opcje fizycznej osi OY.


Opcje legendy w obszarze wykresu

2.25.3 Opcje legendy wyświetlanej przy/w obszarze wykresu

Opcje legendy wyświetlanej w obszarze wykresu dostępne są z poziomu przedstawionego poniżej okna:

zakładka Wykres okna głównego programu AsTrend > grupa Osie > okno 'Opcje wykresu' wywoływane przyciskiem [image] > zakładka 'Legenda na wykresie'.

- Legenda na wykresie - załączenie legendy w obszarze wykresu; parametryzacja podstawowych cech wyglądu legendy:

- Legenda widoczna - załączenie legendy.

- Położenie legendy - ustawia legendę we wskazanej lokalizacji na obszarze wykresu:

- lewo - legenda pionowa z lewej strony obszaru wykresu,

- prawo - legenda pionowa z prawej strony obszaru wykresu,

- góra - legenda pozioma powyżej obszaru wykresu,

- dół - legenda pozioma poniżej obszaru wykresu,

- pływająca pionowa - legenda pozioma w obszarze wykresu zgodnie z procentowym rozmieszczeniem w poziomie i w pionie,

- pływająca pozioma - legenda pionowa w obszarze wykresu zgodnie z procentowym rozmieszczeniem w poziomie i w pionie;

- Kolor tła - kolor tła legendy;

- Kolor ramki - kolor ramki legendy.

powiększ >>

Rys. Opcje wykresu - Legenda na wykresie.


3D

2.25.4 3D

Każdy wykres może być opcjonalnie wyświetlony jako trójwymiarowy.

Wyświetlenia trójwymiarowego wykresu dokonać można przy pomocy:

  • przycisku [image] na zakładce Wykres okna głównego programu AsTrend > w grupie Wygląd;

Przyciemniony przycisk odpowiada sytuacji załączenia trójwymiarowego wykresu.

Zakładka 3D (z okna 'Opcje wykresu' wywoływanego przyciskiem [image] z zakładki Wykres okna głównego programu AsTrend > z grup: Typ wykresu, Osie lub Wygląd) - widoczna pod warunkiem załączenia trójwymiarowego wykresu obejmuje następujące parametry:

- przełączenie na zwykły rzut prostokątny z możliwością określenia kąta i głębi obszaru wykresu;

- przełączenie na wersję 3D z możliwością manipulowania obszarem wykresu w przestrzeni 3D; parametry, które umożliwiają manipulację w przestrzeni:

- Kąt,

- Obrót,

- Pochylenie,

- Perspektywa,

- Powiększenie,

- Głębia.

- Wykres 3D - kolory ścian - pozwala określić kolorystykę, gradient i ramkę dla ścian: lewej, prawej i dolnej obszaru wykresu w wersji: 3D lub Rzut prostokątny. Aby zdefiniować wymienione cechy dla wybranej ściany, należy kliknąć w obszar prostokąta i dokonać ustawień w rozwiniętym oknie.

powiększ >>

Rys. Opcje trendu - 3D.


Opcje okresu trendu

2.26.1 Opcje okresu trendu

Opcje okresu trendu mogą być zdefiniowane z poziomu okna 'Opcje okresu trendu’ otwieranego przyciskiem [image] z zakładki Narzędzia główne okna głównego programu AsTrend > grupy Okres.

Okno pozwala dowolnie ustawić okres czasu, który zostanie załadowany w momencie otwarcia trendu oraz format zapisu czasu dla wykresów XT.

***

Zakładka Format zapisu czasu umożliwia określenie formatu zapisu czasu dla głównej osi czasu oraz dodatkowej osi czasu. Standardowo używany jest tryb automatyczny (format domyślny), przyjmujący opis typu ”yy-mm-dd" - jeśli wyświetlany okres jest większy niż dzień oraz opis typu ”hh:mm" - w pozostałych przypadkach. Takie rozwiązanie aczkolwiek wygodne, bo podczas powiększania lub pomniejszania automatycznie zmienia się sposób opisu osi, nie zawsze może użytkownikowi odpowiadać. Istnieje zatem możliwość wyboru innego sposobu opisu lub też zdefiniowania własnego formatu.

Do wyboru są następujące formaty:

  • yy-mm-dd hh:mm:ss

  • yy-mm-dd hh:mm

  • yy-mm-dd hh

  • yy-mm-dd

  • yy-mm

  • mm-dd hh:mm:ss

  • mm-dd hh:mm

  • mm-dd hh

  • mm-dd

  • dd hh:mm:ss

  • dd hh:mm

  • dd hh

  • hh:mm:ss

  • hh:mm

  • mm:ss

Wybór formatu własnego wymaga jego określenia w odpowiednim polu edycyjnym. Wpisanie np. łańcucha "yy*mm*dd" spowoduje wyprowadzanie daty w ten sposób, że jej pola zostaną rozdzielone gwiazdkami (zamiast standardowych kresek).

powiększ >>

Rys. Opcje okresu trendu - Format zapisu czasu.

***

Zakładka Okres przy otwieraniu umożliwia określenie okresu, jaki zostanie załadowany po otwarciu pliku trendu.

powiększ >>

Rysunek: Opcje okresu trendu - okres przy otwieraniu.

Dostępne są następujące warianty okresu ładowanego w trakcie otwierania trendu:

- Taki jak przy zapisie,

- Koniec okresu równy bieżącej chwili,

- Dzień bieżący, godzina bez zmian,

- Ostatnio używany,

- Wyrażony w formacie OPC - zastosowanie formatu OPC stwarza możliwość bardzo precyzyjnego określenia przedziału czasowego, dla którego mają być odrysowane przebiegi danych w momencie otwarcia trendu. Zarówno początek jak i koniec okresu definiowany jest przy użyciu edytora czasu uruchamianego przyciskiem 3kropki znajdującym się w polu Początek i Koniec. Czas może być czasem absolutnym lub czasem względnym, odnoszącym się do obecnej sekundy, minuty, godziny, itd.

- Najnowsza seria w bazie AsLogger,

- Zapytaj.


Opcje danych wejściowych trendu

2.26.2 Opcje danych wejściowych trendu

Opcje danych wejściowych trendu mogą być zdefiniowane z poziomu okna 'Opcje danych wejściowych trendu’ otwieranego przyciskiem [image] z zakładki AsTrend Dane okna głównego programu AsTrend > grupy Dane wejściowe.

***

Zakładka Dane okna 'Opcje danych wejściowych trendu’ umożliwia ustawienie typu danych, ustawienie okresu próbkowania dla danych równomiernych oraz załączenie zaokrąglania początku okresu dla danych agregowanych:

- Typ danych (patrz: 2.14 Wybór typu danych);

- Dane równomierne - okres próbkowania - opcja określa długość odstępów pomiędzy punktami na wykresie. Jeśli w aplikacji włączony jest agregator, to użycie opcji interwału będącego wielokrotnością minuty może znacznie przyspieszyć pobieranie danych. (patrz: więcej ...)

- Sposób zaokrąglania początku okresu czasu dla danych agregowanych - zaokrąglanie do wielokrotności interwału agregacji powoduje, że początek okresu czytania danych będzie w razie potrzeby cofany tak, by wypadał zawsze o tej samej porze. Np. dla interwału agregacji 15 minut i okresu od 0:22:00 do 1:22:00 początek okresu będzie cofnięty do godziny 0:15:00. Brak zaokrąglania powoduje, że agregaty będą wolniej wyświetlane - ponieważ zwykle będą wyliczane a nie pobierane z serwera, a przy przesuwaniu okresu czasu oraz w trybie żywym stemple czasu agregowanych próbek będą się zmieniać.

powiększ >>

Rysunek: Opcje danych wejściowych trendu.

***

Zakładka Agregaty okna 'Opcje danych wejściowych trendu’ umożliwia ustawienie progów jakości dla agregatów wyświetlanych przez program AsTrend:

- Progi jakości dla danych:

Próg jakości dobrej - agreagat ma jakość dobrą, jeżeli w interwale liczba próbek dobrych jest równa lub przekracza zadany próg jakości dobrej.

Próg jakości złej- agreagat ma jakość złą, jeżeli w interwale liczba próbek złych jest równa lub przekracza zadany próg jakości dobrej.

- Progi jakości dla atrybutów wyliczanych:

Próg jakości dobrej - jakość jest dobra, jeżeli w interwale liczba próbek dobrych jest równa lub przekracza zadany próg jakości dobrej.

Próg jakości złej - jakość jest zła, jeżeli w interwale liczba próbek złych jest równa lub przekracza zadany próg jakości dobrej.

powiększ >>

Rys. Opcje danych wejściowych trendu - progi jakości agregatów.

Zakładka System zmianowy okna 'Opcje danych wejściowych trendu’ umożliwia konfigurację systemu zmianowego. Konfiguracja ta ma wpływ na sposób interpretacji interwału OPC wyliczania agregatu Zmiana. Interwał Zmiana może być użyty dla okresu próbkowania danych równomiernych lub w interwale wyliczania agregatu przebiegu.

- Konfiguracja systemu zmianowego:

- Początek pierwszej zmiany,

- Długość zmiany.

powiększ >>

Rys. Opcje danych wejściowych trendu - system zmianowy.


Opcje wyglądu trendu

2.26.3 Opcje wyglądu trendu

Okno trendu posiada pewną grupę atrybutów, które mają wpływ na jego wygląd. Mogą one być włączane/wyłączane i parametryzowane przy pomocy odpowiednich przycisków na zakładkach Wstążki lub w oknie 'Opcje trendu', wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > grup: Trend lub Legenda.

Opcje wyglądu trendu omówione zostały w kolejnych rozdziałach wg nazw zakładek okna 'Opcje trendu', na których zostały umieszczone.


Wygląd

2.26.3.1 Wygląd

Zakładka Wygląd (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grup: Trend lub Legenda) obejmuje parametry:

- Paleta kolorów przebiegów - dotyczy kolorów zmiennych (przebiegów) dodawanych do trendu; opcja decyduje o użyciu:

- wbudowanej w program palety kolorów zmiennych lub

- palety kolorów z opcji trendu (jednej z kilku predefiniowanych palet) bądź też własnej - zdefiniowanej przez użytkownika palety kolorów.

- Własne kolory zmiennych - pozwala używać własnych kolorów dla dodawanych zmiennych. Jeśli opcja jest aktywna, nowo dodawane przebiegi będą pamiętały swój kolor. Zmiana kolejności przebiegów w legendzie nie spowoduje zmiany koloru tych przebiegów.

- Czcionka trendu - pozwala używać własnej czcionki używanej w: opisie etykiet osi, legendzie, etykietach punktów pomiarowych, legendzie wyświetlanej przy/w obszarze wykresu.

powiększ >>

Rys. Opcje trendu - Wygląd.


Legenda

2.26.3.2 Legenda

Zakładka Legenda (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grup: Trend lub Legenda) obejmuje parametry:

- Kolor tła legendy - pozwala wybrać kolor spośród kolorów standardowych bądź też skomponować swój własny niestandardowy kolor.

- Szerokość kolumn legendy - pozwala ustawić automatyczne ustalanie szerokości kolumn legendy.

- Nagłówki kolumn - pozwala załączyć opcję wyświetlania skróconych nazw atrybutów wyliczanych.

- Wysokość legendy na ekranie - pozwala załączyć opcję automatycznego wyliczania wysokości legendy w zależności od liczby przebiegów lub określania wysokości legendy indywidualnie przez użytkownika za pomocą paska podziału lub bezpośredniej deklaracji liczby widocznych przebiegów w legendzie.

powiększ >>

Rys. Opcje trendu - Legenda.


tabela

2.26.3.3 Tabela

Zakładka Tabela (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grup: Trend lub Legenda) obejmuje parametry mające wpływ na kolorystykę tabeli danych bieżących:

- Kolor tła wspólnych kolumn tabeli - pozwala wybrać kolor spośród kolorów standardowych bądź też skomponować swój własny niestandardowy kolor, który będzie wyświetlany w tle tych kolumn tabeli, które są wspólne dla prezentowanych danych przebiegów.

- Kolor tła panelu tabeli - pozwala wybrać kolor spośród kolorów standardowych bądź też skomponować swój własny niestandardowy kolor, który będzie wyświetlany w tle panelu tabeli.

powiększ >>

Rys. Opcje trendu - Tabela.


Wydruk

2.26.3.4 Wydruk

Zakładka Wydruk (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grup: Trend lub Legenda) obejmuje parametry wydruku:

Informacje

- Tytuł - pozwala określić treść tytułu na wydruku trendu.

- Nagłówek - pozwala określić treść nagłówka na wydruku trendu.

- Stopka - pozwala określić treść stopki na wydruku trendu.

- Drukuj nazwę pliku trendu - dołącza nazwę pliku trendu do wydruku trendu.

Układ legendy

- Drukuj legendę - załączenie opcji powoduje wydruk legendy.

- Stały układ wykresu - załączenie opcji ułatwia porównywanie wydruków przebiegów.

- Legenda na osobnej stronie - załączenie opcji powoduje wydruk legendy na osobnej stronie wydruku trendu.

- Legenda dwukolumnowa - załączenie opcji powoduje wydruk legendy w podziale na dwie kolumny na wydruku trendu.

Kolory teł wykresu i legendy

- Zamień kolory teł wykresu i legendy na białe - pozwala załączyć kolor biały dla tła wykresu i legendy. Opcja ma znaczenie w przypadku wydruków na kolorowej drukarce, ponieważ w przypadku czarno-białych wydruków tła te zawsze drukowane są w kolorze białym.

powiększ >>

Rys. Opcje trendu - Wydruk.


Paleta kolorów

2.26.3.5 Paleta kolorów

Zakładka Paleta kolorów (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grup: Trend lub Legenda) pozwala:

- wybrać paletę kolorów spośród predefiniowanych palet

albo

- utworzyć własną paletę, wybierając opcję <Własna paleta trendu> i definiując kolejne okna podglądu kolorów.

Uwaga: Zakładka Paleta kolorów jest dostępna pod warunkiem zaznaczenia opcji Użyj palety kolorów z opcji trendu na zakładce Wygląd okna 'Opcje trendu'.

powiększ >>

Rys. Opcje trendu - Paleta kolorów.


Opcje okna trendu

2.26.4 Opcje okna trendu

Opcje okna trendu mogą być zdefiniowane z poziomu okna 'Opcje okna trendu’ otwieranego przyciskiem [image] z zakładki Widok okna głównego programu AsTrend > z grupy Okno.

Opcje okna trendu pozwala określić położenie i rozmiar okna trendów z możliwością zablokowania rozmiaru okna oraz zapisania układu okien:

- Blokada rozmiaru okna - opcja stosowana głównie przy tworzeniu plików trendu dla aplikacji systemu Asix. Jeśli opcja jest włączona, to położenie i rozmiar okna są przechowywane w pliku trnx. Przy otwieraniu pliku trendu położenie i rozmiar okna są odtwarzane.

- Położenie i rozmiar okna - opcja ma znaczenie, gdy włączona jest blokada rozmiarów okna (zakładka Widok okna głównego programu AsTrend > grupa Okno > Blokada rozmiarów okna. Zmiana położenia będzie widoczna, jeśli w opcjach programu nie jest włączone ignorowanie pozycji okna.

- Zapisywanie układu okien - jeśli opcja jest włączona, to układ okien programu będzie zapamiętany w pliku trendu i odtwarzany przy jego otwarciu.

powiększ >>

Rysunek: Opcje okna trendu.


Opcje przebiegu

2.27 Opcje przebiegu

Opcje przebiegu ustalane są przy użyciu okna 'Opcje przebiegu’, wywoływanego przyciskiem [image] z zakładki Przebieg okna głównego programu AsTrend > grupy Przebieg.

UWAGA: Zakładki okna 'Opcje przebiegu' omówione poniżej mogą się nieznacznie różnić w zależności od rodzaju zmiennych (patrz: 1.8 Rodzaje danych przebiegów).

***

Zakładka Atrybuty pozwala określić:

- Atrybuty przebiegu - podstawowe atrybuty, takie jak: nazwa, opis i jednostka przebiegu,

- Zakres wyświetlania.

- Zakres pomiarowy,

Nazwa przebiegu - to symboliczna nazwa przebiegu, której wartość zależy od polecenia Wybierz atrybut nazw przebiegów (menu Dane > Asix - zmienne i alarmy); nazwa przebiegu może być edytowana przez użytkownika.

powiększ >>

Rysunek: Opcje przebiegu - Atrybuty.

- Zakres wyświetlania - zakres wyświetlania służy do skalowania osi fizycznej i osi przebiegu na wykresach wieloosiowych (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres wyświetlania i Największy zakres wyświetlania). Wprowadzenie wartości zakresu 0-0 oznacza brak zakresu wyświetlania - wówczas zakres osi będzie wyliczany na podstawie bieżących wartości próbek.

Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy wyświetlania wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy wyświetlania, zakres ustalany jest automatycznie.

- Zakres pomiarowy - zakres pomiarowy służy do sprawdzania poprawności wartości próbek przebiegu. Wartości próbek, które przekraczają zakres przebiegu o liczbę równą szerokości zakresu przebiegu są obcinane. Wprowadzenie wartości zakresu 0-1 dla zmiennej systemu Asix typu całkowitego powoduje, że zmienna jest traktowana jako binarna.

Zakres pomiarowy może być także użyty do skalowania osi fizycznej. (w ustawieniach Osi fizycznej OY - zakładka Wykres okna głównego programu AsTrend > grupa Osie > okno 'Opcje wykresu' uruchamiane przyciskiem [image] > zakładka Oś fizyczna OY - jako punkty minimum i maksimum muszą być zaznaczone opcje Najmniejszy zakres pomiarowy i Największy zakres pomiarowy). Należy przy tym pamiętać, że przy skalowaniu osi fizycznej trendu brane są pod uwagę zakresy pomiarowe wszystkich przebiegów, przykładowo: minimum może być ustalane na podstawie najmniejszego z minimów zdefiniowanych dla poszczególnych przebiegów, a maksimum na podstawie największego z maksimów. W przypadku, gdy nie wszystkie przebiegi mają zdefiniowane zakresy pomiarowe, zakres ustalany jest automatycznie.

***

Zakładka Dane daje możliwość wyświetlenia w ramach trendu dodatkowej osi czasu OX powiązanej z wybranymi zmiennymi / zmienną. Dodatkowa oś OX umiejscowiona jest ponad wykresem i pozwala wyświetlić dowolny okres czasu, co daje sposobność do porównania przebiegu zmiennych z dwóch różnych okresów.

Jest to również miejsce, gdzie można zadeklarować sposób traktowania punktów o jakości niepewnej (jako punkty o jakości dobrej / jako punkty o jakości złej) oraz dokonać wyboru typu danych przebiegu (z podaniem nazwy agregatu, interwału i stempla czasu agregatu dla danych zagregowanych).

powiększ >>

Rysunek: Opcje przebiegu - Dane.

Edycja dodatkowego okresu czasu możliwa jest w edytorze okresu, uruchamianym z zakładki Narzędzia główne okna głównego programu AsTrend po kliknięciu na przycisku z informacją o aktualnie ustawionym okresie wyświetlania danych.

Początek okresu dodatkowej osi czasu definiowany jest w formacie czasu OPC (patrz: 2.11.6 Edytor czasu w formacie OPC).

powiększ >>

Rysunek: Okno z parametrem do edycji dodatkowej osi czasu.

Aby porównać przebiegi tej samej zmiennej z dwóch różnych okresów czasu, należy daną zmienną dodać do wykresu dwa razy, przypisując jednemu z przebiegów tej zmiennej drugą oś OX z zadeklarowanym dodatkowym okresem.

Gdy tylko jeden przebieg korzysta z dodatkowego okresu czasu, druga oś czasu rysowana jest w kolorze tego przebiegu.

***

Zakładka Wykres obejmuje parametry umożliwiające:

- przełączenie typu wykresu na: liniowy, słupkowy bądź obszarowy,

- dla wykresów liniowych i obszarowych - załączenie interpolacji schodkowej (z możliwością odwrotnego rysowania wykresu schodkowego - opcja Interpolacja wartością przed punktem);

- dla wykresów słupkowych - ustawienie szerokości słupka i wartości przesunięcia słupka;

- dla wykresów obszarowych - włączenie linii bazowej oraz określenie jej położenia;

- włączenie opcji powodującej wyświetlenie na wykresie linii limitów przebiegu;

powiększ >>

Rysunek: Opcje przebiegu - Wykres.

Opcja Dla wszystkich przebiegów umożliwia zastosowanie ustawień dla wszystkich przebiegów zadeklarowanych na wykresie.

***

Sposób wyświetlania osi pionowej OY (dla osi procentowej i wykresów z wieloma osiami OY) determinują parametry zgromadzone za zakładce Oś pionowa - parametry ustawiane są dla danej wyselekcjonowanej zmiennej lub dla wszystkich zmiennych jednocześnie:

- Położenie osi - wykres z wieloma osiami OY:

- Po lewej stronie wykresu - oś może być usytuowana z lewej strony wykresu;

- Po prawej stronie wykresu - oś może być usytuowana z prawej strony wykresu;

- Położenie osi (wykres z wieloma osiami OY - stos):

- Oś zawsze po lewej stronie - osie mogą być rysowane zawsze po lewej stronie wykresu oddzielnie dla każdego przebiegu;

- Oś po lewej lub prawej stronie - osie mogą być rysowane po lewej lub prawej stronie, przebiegi mogą być rysowane na jednym wykresie w parze z sąsiadującym przebiegiem; przykładowo: jeśli 8 przebiegów będzie miało zaznaczoną tę opcję, wówczas będą rysowane parami na jednym wykresie - w sumie będzie tych wykresów 4 (jeden nad drugim).

- Typ podziałki osi:

- liniowa,

- logarytmiczna - oś może mieć podziałkę logarytmiczną tylko wtedy, gdy zakres minimalny i maksymalny jest większy od zera.

- Odwrócona oś 0Y - opcja ma znaczenie dla wykresu procentowego i wykresów wieloosiowych,

- Format etykiet osi (wykres procentowy i wykres z wieloma osiami OY).

powiększ >>

Rysunek: Opcje przebiegu - Oś pionowa.

***

Kolor, grubość, głębia 3D, gradient przebiegu, krój własnej czcionki w legendzie oraz widoczność przebiegu określane są na zakładce Wygląd:

powiększ >>

Rysunek: Opcje przebiegu - Wygląd.

- Wygląd - opcja umożliwia ustawienie atrybutów wyglądu przebiegu: załączenie punktów (łącznie z określeniem kształtu graficznych znaczników punktów, ich wielkości i możliwością załączenia obramówki dla punktów), etykiet; określenie grubości linii przebiegu; określenie przeźroczystości przebiegu (pozwala to oglądać w całości nakładające się przebiegi); ukrycie przebiegu, zdefiniowanie własnego koloru przebiegu oraz określenie grubości wybranego przebiegu. Jeśli użytkownik nie określi swojego indywidualnego koloru, kolorem przebiegu będzie pierwszy wolny kolor pobrany z palety zdefiniowanej w opcjach programu.

- Gradient - umożliwia zadeklarowanie skali, balansu i kierunku gradientu. Skala gradientu przyciemnia lub rozjaśnia gradient (powyżej 0 kolor rozjaśniany, poniżej 0 kolor przyciemniany). Balans gradientu przesuwa balans gradientu w górę lub w dół.

- Opcje czcionki - umożliwia zadeklarowanie czcionki w legendzie.

- Widoczność - opcja umożliwia ukrycie przebiegu na wszystkich wykresach lub wskazanie tylko wybranych wykresów, na których przebieg ma być widoczny.

***

Format wartości wyświetlanych w legendzie, tabeli i wyeksportowanych do pliku tekstowego ustawiane są na zakładce Format wartości:

- Format wartości - wyznaczany na podstawie zakresu zmiennej lub określany przez użytkownika.

- Pokazuj całkę jako czas - po załączeniu opcji wartość agregatu całka pokazywana będzie w formacie czasu: d h:mm:ss .

- Okres pomiaru przebiegu - okres pomiaru używany jest do przeliczania wartości agregatów Całka i Gradient wyświetlanych w legendzie. Wartość agregatu Całka jest dzielona przez wartość okresu pomiaru; wartość agregatu Gradient jest mnożona przez wartość okresu pomiaru.

powiększ >>

Rysunek: Opcje przebiegu - Format wartości.

***

Na zakładce Etykiety wartości umieszczony został edytor, który pozwala zdefiniować tekstowe etykiety wartości. Etykiety te są używane zamiast wartości liczbowych:

- na wykresie: dymki i etykiety punktów;

- w legendzie: kolumny Wartość próbki linii odczytu 1/2;

- na osi pionowej w przypadku wielu osi 0Y lub wykresu procentowego; w przypadku osi fizycznej etykiety będą wyświetlane tylko, jeśli są identyczne dla wszystkich przebiegów;

- w tabeli: kolumny wartości;

- przy eksporcie danych: kolumny wartości.

Dla wartości zmiennoprzecinkowych wyświetlane są etykiety odpowiadające ich zaokrąglonej wartości całkowitej.

powiększ >>

Rysunek: Opcje przebiegu - Etykiety wartości.

***

Zakładka Przebiegi wzorcowe pozwala na dodanie do okna trendu przebiegu wzorcowego (jednego lub dwóch). Dodanie dwóch przebiegów wzorcowych pozwala uzyskać wykres wstęgowy - przydatny przy ocenie kształtowania się wartości analizowanej zmiennej pod kątem przekroczeń wartości maksymalnych i minimalnych.

Przebiegi wzorcowe mogą być dodawane z archiwum aplikacji lub ze źródła zewnętrznego:

- w pierwszym przypadku przebiegi wzorcowe definiuje się za pomocą programu PEdit i przechowuje w archiwum SQL; dokładny opis - patrz: PrzebiegiWzorcowe.PDF;

- w drugim przypadku przebiegi wzorcowe definiuje się w pliku tekstowym, arkuszu kalkulacyjnym lub w bazie danych; format jest taki sam jak dla danych zewnętrznych; opis formatu znajduje się w kreatorze wyświetlanym po naciśnięciu przycisku Dodaj przebieg wzorcowy ze źródła zewnętrznego.

powiększ >>

Rysunek: Opcje przebiegu - Przebiegi wzorcowe.


Opcje eksportu danych

2.28 Opcje eksportu danych

Opcje eksportu danych ustawiane są w oknie 'Opcje eksportu danych', uruchamianym przyciskiem [image] z zakładki Dane okna AsTrend. Okno umożliwia ustawienie następujących parametrów eksportu danych do schowka lub pliku tekstowego:

- Nagłówek - możliwość zadeklarowania jedno- lub dwuwierszowego nagłówka oraz podania jednostki i agregatu przy nazwach zmiennych;

- Dane oryginalne - próbki ułożone według osi czasu lub jedna za drugą; możliwość zadeklarowania wspólnej kolumny czasu dla danych oryginalnych;

- Kolumna jakości - możliwość dodania kolumny jakości i określenia jej formatu;

- Dane równomierne - możliwość zadeklarowania wspólnej kolumny czasu dla danych równomiernych.

powiększ >>

Rys. Opcje eksportu danych.


Odczyt definicji trendu

2.29 Odczyt definicji trendu

Odczyt definicji trendu można zrealizować przy pomocy:

  • polecenia Otwórz z menu Plik.

Powoduje to usunięcie starego trendu i wczytanie definicji otwieranego trendu.

Na definicję trendu składają się:

  • nazwy zmiennych

  • okres czasu trendu

  • parametry krzywych (kolory, typy wykresów, etykiety...)

  • wygląd i atrybuty okna trendów

  • parametry trendu (tytuł, nagłówek i stopka).

Okres czasu trendu może być taki sam jak podczas definiowania trendu, ewentualnie może być zmodyfikowany zgodnie z możliwościami, które daje okno parametrów trendu. Jeśli wybrany został tryb pracy z odpytaniem użytkownika o okres, to po odczycie definicji trendu zostanie wyprowadzane okno, w którym można ustawić okres czasu.

Trendy zapisywane są w plikach XML. Definicja trendu może być odczytana automatycznie, jeśli wystąpi jako argument w linii komendy startującej program.

Istnieje parametr, który pozwala określić rodzaj okna, jakie zostanie uruchomione (po użyciu przycisku [image] z menu Plik > Otwórz) do otwierania plików trendu (z lub bez opcji podglądu zawartości trendu). uwaga Parametr ten jest możliwy do zdefiniowania tylko wtedy, gdy program AsTrend uruchamiany jest samodzielnie (niezależnie od aplikacji systemu Asix):

okno 'Opcje programu' > zakładka Okno otwarcia pliku trendu > opcja Okno otwarcia pliku trendu

Rys. Okno otwarcia pliku trendu z podglądem listy zmiennych trendu.

W przypadku pracy programu AsTrend z aplikacją klasycznej wersji systemu Asix, gdy praca odbywa się w trybie operator/administrator (aplikacja nie korzysta z modułu AsAudit do definiowania uprawnień użytkowników) rozróżniane są dwa okna do otwierania plików trendów: operatora i administratora. Okienko dla operatora nie ma możliwości przechodzenia do innego katalogu w polu Szukaj w oraz możliwości kasowania plików typu Tylko_do_odczytu. W sytuacji kiedy na pliki AsTrend nałożona została blokada zapisu (opcja ustawiana w Architekcie: Obszary i komputery > Parametry startowe > Programy > AsTrend > opcja Blokada zapisu w programie AsTrend) - zarówno administrator jak i operator nie mają możliwości kasowania plików.


Drukowanie trendow

2.30 Drukowanie trendów

Trend wyświetlony w oknie trendów może zostać wydrukowany. Z wydrukiem trendów związane są funkcje uruchamiane z listy poleceń karty Drukuj dostępnej po kliknięciu na menu Plik:

- Drukuj [image] ,

- Podgląd wydruku [image],

- Drukarka - wybór drukarki,

- Opcje wydruku trendu:

Na wydruku pojawiają się dodatkowe elementy, oprócz obszaru wykresów i legendy. Są to:

- tytuł,

- nagłówek,

- stopka.

Elementy te są widoczne w podglądzie wydruku i na karcie Drukuj, a można je edytować w oknie 'Opcje trendu', na zakładce Wydruk, gdzie ponadto można ustawić dodatkowe opcje wydruku, m.in opcję drukowania nazwy pliku trendu:

- Drukuj nazwę pliku trendu - oznacza wydrukowanie nazwy pliku trendu w stopce; opcja domyślnie załączona.

- Narzędzia:

Wyczyść kolejkę wydruków - wyczyszczenie kolejki wydruków;

powiększ >>

Rysunek: Karta 'Drukuj' z menu 'Plik'.


Podglad wydruku

2.30.1 Podgląd wydruku

Użytkownik może obejrzeć na ekranie komputera wydruk przed właściwym wydrukowaniem. Służy do tego funkcja podglądu wydruku, którą można wywołać przy pomocy:

  • przycisku Podgląd wydruku [image] z karty Drukuj z menu Plik okna głównego AsTrend.

W oknie podglądu wydruku w zależności od wybranej drukarki wydruk będzie czarno-biały lub kolorowy. Na drukarce czarno-białej wszystkie kolory będą się automatycznie zamieniać na odcienie szarości. W pasku narzędziowym tego okna znajdują się przyciski umożliwiające przeskalowanie podglądu do wymiarów okna, przeskalowanie do 100% (wielkość jak na drukarce), przeskalowanie do szerokości strony, ustawienie parametrów drukarki oraz sam wydruk.

Rysunek: Podgląd wydruku wykresu.


Wykonanie wydruku

2.30.2 Wykonanie wydruku

Wyprowadzenie wydruku następuje po:

  • wykonaniu polecenia Drukuj [image] z karty Drukuj z menu Plik programu AsTrend;

W trybie Operatora (patrz: 1.4 System uprawnień AsTrend uruchamianego z aplikacją systemu Asix)- dostępne jest okno wyboru drukarki, ale niedostępny jest przycisk otwierający okno właściwości drukarki.


Drukowanie trendow o ponad 8 krzywych

2.30.3 Drukowanie trendów o ponad 8 krzywych

Gdy definicja trendu zawiera ponad 8 krzywych, przed wydrukiem należy zmienić w oknie 'Opcje Trendu’ (zakładka Trend i legenda okna głównego programu AsTrend > grupa Legenda > okno 'Opcje trendu' > zakładka Wydruk) legendę na dwukolumnową - wówczas na wydruku mieści się do 16 opisów zmiennych w legendzie. Należy pamiętać, że wówczas wymiary legendy będą inne niż dla trendu z legendą jednokolumnową.

Rysunek: Podgląd wydruku.

Przy drukowaniu legendy jednokolumnowej, jeśli liczba krzywych przekroczy 8, na ekranie pojawia się następujący komunikat:

Rysunek: Ostrzeżenie przy drukowaniu wykresu z legendą przy liczbie krzywych przekraczających 8.

Pozostaje do decyzji operatora, jak ustawi poszczególne obszary ekranu. Należy pamiętać, że rozmiary wykresu na stronie zmienią się w stosunku do wydruku z zablokowanymi rozmiarami i autodopasowaniem.


Zamykanie trendu

2.31 Zamykanie trendu, tabeli danych historycznych, raportu / tworzenie nowego

Aby zamknąć aktualnie wyświetlany trend, tabelę lub raport bez zamykania programu AsTrend, należy:

  • wybrać z listy poleceń menu Plik okna głównego AsTrend jedno z poleceń Nowy...;

Spowoduje to usunięcie z ekranu starego trendu, tabeli danych historycznych lub raportu i wyświetlenie pustego obszaru gotowego do edytowania.


Zapis definicji trendu

2.32 Zapis definicji trendu

Zapis definicji trendu można zrealizować przy pomocy:

  • przycisków Zapisz [image] i Zapisz jako... na liście poleceń menu Plik okna głównego AsTrend.

Funkcje zapisu zależą również od trybu pracy trendów. W trybie Operatora, zapis definicji trendu jest ograniczony, natomiast w trybie Administratora i trybie Pełnym (gdy AsTrend uruchamiany jest poza aplikacją Asixa), użytkownik może w dowolny sposób zapisywać definicje trendów.

***

Domyślnym katalogiem zapisu plików TRNX przy pracy poza systemem Asix jest katalog dokumentów użytkownika.

W trybie Operatora (patrz: 1.4 System uprawnień AsTrend uruchamianego z aplikacją systemu Asix)

Operator nie może zapisać (modyfikować) istniejącego trendu, o ile ma on status Tylko_do_odczytu. Przy próbie takiego zapisu pojawia się komunikat:

Rysunek: Komunikat przy próbie zapisu trendu Tylko_do_odczytu przez Operatora.

uwaga W momencie, gdy program AsTrend jest uruchamiany na danym komputerze razem z Asixem, powinien być wywoływany przez Operatora z menu aplikacji Asixa a nie z belki systemu Windows. AsTrend uruchomiony z belki ma ograniczenia dotyczące operacji na plikach - Operator nie może zapisywać plików, ponieważ nie ma zadeklarowanego katalogu, w którym plik mógłby być zapisany.

Operator ma możliwość zapisu nowego trendu oraz zmodyfikowanego trendu pod nową nazwą, ale pod warunkiem, że AsTrend uruchomiony został z podaniem katalogu roboczego plików trendów:

- w akcji operatorskiej otwierającej AsTrend z diagramu aplikacji Asix,

- w opcji startowania AsTrend razem z aplikacją Asix z podaniem katalogu roboczego, definiowanej w programie Architekt: Parametry startowe > zakładka Program/ AsTrend > opcja Startuj AsTrend.

Rysunek: Okno 'Zapisz jako' dla Operatora.

Trendy zapisywane są w plikach TRNX.

W trybie Administratora (patrz: 1.4 System uprawnień AsTrend uruchamianego z aplikacją systemu Asix)

Administrator ma możliwość tworzenia nowych trendów ze statusem Tylko_do_odczytu.

W oknie pokazanym poniżej, nadaje nazwę nowego trendu i zaznacza status Tylko_do_odczytu.

Rysunek: Okno 'Zapisz jako' dla Administratora.

Administrator ma także możliwość modyfikowania istniejących definicji trendów, bez względu na ich status. Przy próbie modyfikacji istniejącego pliku trendu pojawia się okno informacyjne:

Rysunek: Komunikat przy próbie modyfikacji istniejącego pliku trendu przez Administratora.

Jeżeli modyfikowany plik jest plikiem ze statusem Tylko_do_odczytu, pojawia się następny komunikat:

Rysunek: Komunikat przy próbie modyfikacji istniejącego pliku trendu o statusie Tylko_do_odczytu przez Administratora.

Należy pamiętać, że trend zapisany przez Administratora w trybie Tylko_do_odczytu staje się automatycznie wzorcem, który nie może być już zmieniony przez Operatora.


Eksportowanie trendu / przebiegu / tabeli danych historycznych

2.33 Eksportowanie trendu / wykresu / legendy /przebiegu / tabeli danych historycznych / raportu

Program AsTrend umożliwia wyeksportowanie:

- całego trendu (wykres z legendą i informacjami określonymi w opcjach wydruku wykresu) do pliku PDF, BMP,

- wykresu z legendą do pliku BMP, schowka,

- samej legendy do schowka, pliku tekstowego, HTML lub XLS,

- danych wybranego przebiegu/przebiegów do pliku CSV, schowka.

***

Eksport całego trendu (wykres z legendą i informacjami określonymi w opcjach wydruku wykresu) do pliku PDF odbywa się przy użyciu polecenia Eksportuj do PDF [image] dostępnego z zakładki Plik. Dodatkowe informacje eksportu tj.: tytuł, nagłówek, stopkę, opcję drukowania nazwy pliku trendu oraz układ legendy można określić na zakładce Wydruk w oknie 'Opcje trendu' wywoływanym przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grupy Trend lub Legenda.

Efekt takiego eksportu prezentuje rysunek poniżej.

Eksport do pliku BMP odbywa sie w analogiczny sposób z użyciem polecenia Eksportuj do BMP [image] dostępnego z zakładki Plik.

powiększ >>

Rys. Opcje trendu - opcje wydruku.

Rys. Trend wyeksportowany do pliku PDF.

***

Eksport wykresu z legendą do schowka / do pliku BMP odbywa się przy użyciu poleceń: Kopiuj do schowka [image], Zapisz do pliku BMP [image] umieszczonych na zakładce Wykres okna głównego programu AsTrend > w grupie Eksport wykresów.

Efekt eksportu do pliku BMP prezentuje rysunek poniżej.

Rys. Wykres wyeksportowany do pliku BMP.

***

Eksport samej legendy do schowka /pliku tekstowego / HTML / XLS odbywa się przy użyciu poleceń: Kopiuj do schowka, Zapisz do pliku tekstowego, Zapisz do pliku HTML, Zapisz do pliku XLSX wywoływanych z zakładki Trend i legenda okna głównego programu AsTrend > z grupy Operacje legendy > z grupy poleceń Eksportuj legendę [image] . Rozwijana lista pozwala wybrać polecenie eksportujące zawartość legendy do wybranego formatu.

Efekt eksportu do pliku HTML prezentuje rysunek poniżej.

Rys. Wykres wyeksportowany do pliku HTML.

Efekt eksportu do pliku XLSX prezentuje rysunek poniżej.

Rys. Wykres wyeksportowany do pliku XLSX.

***

Eksport danych wybranego przebiegu/przebiegów do schowka / pliku CSV odbywa się przy użyciu poleceń: Kopiuj do schowka [image] , Eksportuj do CSV [image] wywoływanych z zakładki Dane okna głównego programu AsTrend > z grupy Eksport danych.

Parametry eksportu danych pozwala określić okno 'Opcje eksportu danych' wywoływane przyciskiem [image] z zakładki Dane okna głównego programu AsTrend > z grupy Eksport danych. Parametry dotyczą:

- nagłówka - możliwość zadeklarowania jedno- lub dwuwierszowego nagłówka oraz podania jednostki i agregatu przy nazwach zmiennych;

- danych oryginalnych - próbki ułożone według osi czasu lub jedna za druga; możliwość zadeklarowania wspólnej kolumny czasu dla danych oryginalnych;

- kolumny jakości - możliwość dodania kolumny jakości i określenia jej formatu;

- danych równomiernych - możliwość zadeklarowania wspólnej kolumny czasu dla danych równomiernych.

powiększ>>

Rys. Opcje eksportu danych.

Efekt eksportu do pliku CSV (z opcją Próbki według osi czasu) - po otwarciu w Excelu prezentuje rysunek poniżej.

powiększ>>

Rys. Dane przebiegów wyeksportowane do formatu CSV.

***

Wyeksportowanie tabeli danych historycznych do schowka / pliku tekstowego / HTML / XLS odbywa się przy użyciu poleceń: Kopiuj do schowka, Zapisz do pliku tekstowego, Zapisz do pliku HTML, Zapisz do pliku XLS wywoływanych z zakładki Narzędzia główne okna głównego programu AsTrend > z grupy Tabela danych historycznych > przyciskiem Eksport tabeli.

Efekt eksportu tabeli do pliku HTML prezentuje rysunek poniżej.

powiększ>>

Rys. Tabela danych historycznych wyeksportowana do pliku HTML.

Efekt eksportu tabeli danych historycznych do pliku XLS prezentuje rysunek poniżej.

powiększ>>

Rys. Tabela danych historycznych wyeksportowana do pliku XLS.

***

Aby wyeksportować raport utworzony w programie AsTrend, należy użyć polecenia [image] Eksport z grupy Operacje raportu na zakładce Raport. Polecenie to umożliwia wyeksportowanie raportu do pliku jednego z trzech formatów:

- plik tekstowy,

- HTML,

- XLSX.

***

Eksport do pliku tekstowego *.txt, *.csv (lub schowka) realizowany jest w formie wartości oddzielonych znakami separatora (w przypadku eksportu do schowka - znakami tabulacji). Dane uszeregowane są w kolumnach zawierających kolejno: czas, wartości zmiennej. Każda zmienna posiada swoja kolumnę czasu i wartości - wyjątkiem jest przypadek danych równomiernych (stały okres czasu pomiędzy kolejnymi próbkami), gdzie istnieje możliwość ustawienia wspólnej kolumny czasu. Czas eksportowany jest w formacie systemowym (’2008-02-20 16:48:22’). Dla serii alarmowych oraz danych zewnętrznych kolumna czasu dodatkowo zawiera milisekundy.


Kontekstowe menu

2.34 Kontekstowe menu

W obszarze wykresów, legendy oraz tabeli można wywołać menu kontekstowe, naciskając prawy klawisz myszy. Przy pomocy tego menu użytkownik jest w stanie wykonać opisane poniżej czynności.

W obszarze wykresów:

  • dodanie do wykresu nowej zmiennej surowej (Dane surowe),

  • wyświetlenie okna opcji przebiegu (Opcje przebiegu),

  • wyświetlenie okna opcji źródła danych przebiegu (Opcje źródła danych przebiegu),

  • wyświetlenie metryki zmiennej (Atrybuty przebiegu),

  • zmiana ulokowania przebiegu pomiędzy wykresami od 1 do 4 (Położenie przebiegu),

  • zaznaczenie wszystkich przebiegów (Zaznacz wszystkie przebiegi),

  • usunięcie z wykresu zaznaczonych przebiegów (Usuń zaznaczone przebiegi),

  • wyświetlenie okna opcji wykresu (Opcje wykresu),

  • wyświetlenie okna opcji trendu (Opcje trendu).

Rysunek: Menu kontekstowe obszaru wykresów.

W obszarze legendy:

  • dodanie do wykresu nowej zmiennej surowej (Dane surowe),

  • kopiowanie zaznaczonego rekordu zmiennej - polecenie kopiuje i wkleja kopię wskazanego rekordu (Kopiuj),

  • usunięcie z wykresu zaznaczonych przebiegów (Usuń zaznaczone),

  • usunięcie z wykresu zmiennej a w zamian wstawienie pustego rekordu (Zamień na pusty),

  • ukrycie przebiegu (Ukryty),

  • zmiana ulokowania przebiegu pomiędzy wykresami od 1 do 4 (Położenie przebiegu),

  • zaznaczenie wszystkich przebiegów (Zaznacz wszystkie),

  • przesunięcie wiersza zmiennej o jeden w górę (Przesuń w górę),

  • przesunięcie wiersza zmiennej o jeden w dół (Przesuń w dół),

  • wyświetlenie okna opcji przebiegu (Opcje przebiegu),

  • wyświetlenie okna opcji źródła danych przebiegu (Opcje źródła danych przebiegu),

  • wyświetlenie metryki zmiennej (Atrybuty przebiegu),

  • załączenie wyświetlania znaczników punktów pomiarowych na wykresie (Punkty),

  • załączenie wyświetlania etykiet punktów pomiarowych na wykresie (Etykiety),

  • wybranie kolumny legendy - polecenie otwiera okno z możliwością wyboru kolumn legendy (Kolumny legendy),

  • otwarcie okna opcji legendy (Opcje legendy)

Rysunek: Menu kontekstowe obszaru legendy.

W obszarze nagłówków kolumn legendy:

  • przeczytanie opisu atrybutu (Pokaż opis);

  • zmiana nagłówka (Zmień nagłówek);

  • wybranie kolumny legendy (Kolumny legendy);

  • uruchomienie okna do definiowania opcji legendy (Opcje legendy).

Rysunek: Menu kontekstowe nagłówków kolumn legendy.

W obszarze tabeli wartości bieżących:

  • wyświetlenie pojedynczej kolumny czasu (Pojedyncza kolumna czasu),

  • wyświetlenie kolumny jakości (Kolumny jakości),

  • załączenie opcji, dzięki której zmiana aktywnego wiersza w tabeli nie będzie powodowała zmiany pozycji linii odczytu (Kursor bez zaczepienia),

  • załączenie opcji, dzięki której zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji głównej linii odczytu. Opcja ma znaczenie tylko jeśli główna linia odczytu jest włączona (Zaczep kursor do głównej linii odczytu),

  • załączenie opcji, dzięki której zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji dodatkowej linii odczytu. Opcja ma znaczenie tylko jeśli dodatkowa linia odczytu jest włączona (Zaczep kursor do dodatkowej linii odczytu).

  • Próbki wg osi czasu.

  • Próbki jedna za drugą.

  • wyłączenie widoku tabeli wartości bieżących (Tabela danych).

Rysunek: Menu kontekstowe tabeli wartości bieżących.

W obszarze okna schowka:

  • kopiowanie aktualnego okresu do schowka (Kopiuj do schowka),

  • wstawianie okresu ze schowka (Wstaw ze schowka),

  • skasowanie zawartości całego schowka (Skasuj zawartości całego schowka),

  • zamykanie schowka okresu (Schowek okresów).

Rysunek: Menu kontekstowe okna schowka.


Schowek okresow

2.35 Schowek okresów

Bardzo przydatnym narzędziem podczas pracy przy analizowaniu rzeczywistych krzywych jest Schowek Okresów. Jest on przydatny, jeśli użytkownik oglądając jeden z trendów chciałby obejrzeć inny trend (być może pokrewny lub w jakiś sposób powiązany) w tym samym okresie czasu bez potrzeby zapamiętywania tego okresu.

Schowek jest swego rodzaju podręczną pamięcią umożliwiającą zapamiętywanie, w celu późniejszego wykorzystania, różnych interesujących okresów czasu. Okres zapamiętywany jest jako Opis, Początek, Koniec (zakładka Schowek okresów) wraz z dodatkowymi informacjami dotyczącymi ustawień głównej i dodatkowej linii odczytu. Zawartość tej pamięci wyświetlana jest w okienku 'Schowka Okresów’ przedstawionym poniżej - to jakie dokładnie informacje zostaną wyświetlone w tym oknie, zależy od wybranych kolumn. Kolumny te wybierane są z listy uruchamianej przyciskiem [image].

Po uruchomieniu okna schowka okresów poleceniem [image] Schowek okresów na zakładce Narzędzia główne okna głównego programu AsTrend > w grupie Okres następuje przełączenie na zakładkę Schowek okresów z elementarnymi poleceniami odnoszącymi się do danych przechowywanych w schowku okresów.

Rysunek: Schowek okresów.


Funkcje schowka okresow

2.35.1 Funkcje schowka okresów

Uruchomienie schowka

Schowek okresów wyświetlić można naciskając przycisk Schowek okresów [image] na zakładce Widok okna głównego programu AsTrend > w grupie Panele

lub

analogicznym poleceniem [image] z zakładki Narzędzia główne okna głównego programu AsTrend > z grupy Okres.

Okno to wyświetlane jest zawsze na wierzchu. Jego zamknięcie nie powoduje skasowania zawartości schowka. Pojemność schowka nie jest ograniczona, choć w momencie początkowym wyświetla się jedynie kilka pierwszych wierszy. W przypadku większego zapełnienia okno schowka można rozciągnąć lub też przesunąć się wzdłuż jego zawartości, korzystając z suwaka.

Zapamiętanie okresu

Interesujący okres zapamiętywany jest po kliknięciu na przycisk Kopiuj do schowka [image] (zakładka Narzędzia główne okna głównego programu AsTrend > grupa Okres).

Drugi sposób to użycie polecenia Kopiuj do schowka [image] z kontekstowej zakładki Schowek okresów wyświetlanej w oknie głównym programu AsTrend po otwarciu okna schowka okresów.

Wstawienie okresu

Wybrany okres wstawiany jest ze schowka przyciskiem Wstaw ze schowka [image] (zakładka Narzędzia główne okna głównego programu AsTrend > grupa Okres). Polecenie to wstawia ostatni zapamiętany okres lub przy jednocześnie otwartym oknie schowka (poleceniem Schowek okresów [image] z zakładki Narzędzia główne okna głównego programu AsTrend > z grupy Okres) i wyselekcjonowaniu wybranego okresu w schowku - ten właśnie wybrany okres.

Drugi sposób to kliknięcie myszą na wybrany okres w oknie 'Schowek okresów'.

Trzeci sposób to użycie polecenia Wstaw ze schowka [image] z kontekstowej zakładki Schowek okresów wyświetlanej w oknie głównym programu AsTrend po otwarciu okna schowka okresów.

Kasowanie okresu

Okres można usunąć z okna schowka okresów, selekcjonując okres na liście, a następnie naciskając przycisk [image] lub też naciskając klawisz DEL na klawiaturze.

Opróżnianie schowka okresów

Można opróżnić zawartość całego schowka naciskając przycisk Skasuj zawartość całego schowka [image] z kontekstowej zakładki Schowek okresów, wyświetlanej w oknie głównym programu AsTrend po otwarciu okna schowka okresów.

Edycja opisu okresu

Po wyselekcjonowaniu w oknie schowka okresów wybranego okresu można edytować pole opisu tego okresu. Kliknięcie w polu Opis daje możliwość edycji tego pola. Wpisany tekst opisu powinien identyfikować dla użytkownika dany okres. Po wprowadzeniu tekstu opisu należy nacisnąć klawisz ENTER. Pozostałe pola wpisywane są automatycznie po wywołaniu odpowiednich funkcji i nie mogą być edytowane.

Dokowanie okna schowka okresów w oknie trendu

Dodatkowo okno schowka okresów może być 'zadokowane' w oknie trendu, co oznacza wpasowanie w okno trendu nad, pod lub w miejsce obszaru wykresu (zamiast wykresu widoczne jest okno schowka okresów). W trzecim wariancie obszar wykresu zostaje przykryty przez schowek, niemniej można przełączać się pomiędzy widokami wykres - schowek za pomocą zakładek Wykres / Schowek okresów.

- 'Dokowanie' okna schowka realizowane jest poprzez przeciągnięcie schowka w obszar wykresu i wpasowanie w wyświetlony graficzny schemat układu okien.

- Powrót do 'niezależnej' postaci schowka okresów uzyskuje się poprzez przeciągnięcie zakładki Schowek okresów poza obszar wykresu.

- Powrót do 'niezależnej' postaci schowka okresów zawieszonego nad obszarem wykresu uzyskuje się poprzez przeciągnięcie zakładki Schowek okresów nad obszar wykresu przy wciśniętym klawiszu Ctrl.

Układ okien zapamiętywany jest w programie AsTrend automatycznie przy wyjściu z programu - ale istnieje również możliwość zapisu stanu okien dla pliku trendu: zakładka Widok okna głównego AsTrend > grupa Okno > okno 'Opcje okna trendu' uruchamiane przyciskiem [image] > opcja Zapisywanie układu okien.

Polecenie resetowania układu dokowania paneli Resetuj układ paneli [image] znajduje się na zakładce

Widok okna głównego AsTrend > w grupie Panele.

powiększ>>

Rys. Efekt 'dokowania' okna schowka.


Skalowanie 0-100%

2.36 Skalowanie 0-100%

Aby lepiej i łatwiej można było porównywać wykresy o różnych zakresach, na osi wartości można przeskalować wszystkie zmienne trendu na zakres od 0-100%. Przeliczanie w tym trybie realizowane jest w ten sposób, że wartości 0% odpowiada minimum zakresu wyświetlania zmiennej, zaś wartość 100% maksimum zakresu wyświetlania zmiennej. Dlatego należy ustawić odpowiedni zakres zmiennej lub zaakceptować zakres ustalony na podstawie bazy danych. Jeżeli włączone jest automatyczne skalowanie osi to oś procentowa będzie miała zakres 0-100%. W przeciwnym wypadku wyświetlany jest podzakres, w którym znajdują się wartości.

Funkcję przeskalowania można wywołać przy pomocy:

  • przycisku [image] na zakładce Wykres okna głównego programu AsTrend > w grupie Osie;

Podświetlony przycisk odpowiada sytuacji załączenia przeskalowania wykresu.

W trybie tym selekcja zmiennej powoduje wyrysowanie osi wartości właściwej dla danej zmiennej w kolorze danej zmiennej po prawej stronie obszaru wykresu.

Oś wartości wyskalowanej od 0 do 100% zostaje wyrysowana po lewej stronie obszaru wykresu.

W trybie tym odczyt wartości zarówno przy pomocy linii odczytu jak i myszki wskazuje wartości rzeczywiste, a nie procentowe.

W przypadku kiedy na wykresie procentowym znajduje się więcej niż jedna krzywa, wyświetlenie osi wyskalowanej w jednostkach fizycznych dla danej zmiennej następuje po kliknięciu na danej krzywej (oś procentowa jest cały czas widoczna z lewej strony okna trendu). Oś wyskalowana jest wówczas wyświetlona w kolorze wyselekcjonowanej krzywej. Podwójne kliknięcie poza krzywą powoduje usunięcie osi z prawej strony wykresu.

Pole wykresów z dwiema osiami przedstawia rysunek poniżej.

powiększ >>

Rysunek: Pole wykresów z dwiema osiami OX.


Tabela wartości bieżących

2.37 Obsługa tabeli wartości bieżących

Tabela wartości bieżących pozwala na wyświetlenie punktów, tworzących widoczne na ekranie krzywe, w postaci tabeli. Jest pokazywana po naciśnięciu przycisku Tabela danych [image] z zakładki Widok okna głównego programu AsTrend > z grupy Panele.

W tabeli znajdują się czasy i wartości kolejnych zmiennych z wykresu. W tabeli wyświetlane są wszystkie punkty pomiarowe odpowiadające kolejnym jej wierszom. Jeśli liczba wierszy przekracza liczbę możliwą do wyświetlenia w oknie, wtedy z prawej strony okna pojawia się suwak.

Jeśli wybrany został sposób próbkowania ze stałym okresem próbkowania, wówczas liczba pomiarów w tabeli dla każdej zmiennej jest jednakowa.

Zakładka Tabela zawiera polecenia dotyczące kolumn i zabezpieczenia kursora:

- Pojedyncza kolumna czasu [image] - załącza tryb widoku tabeli zawierający jedyna wspólna kolumnę czasu i wiele kolumn wartości.

- Kolumny jakości [image] - załącza tryb widoku tabeli zawierający kolumny jakości;

- Bez zaczepienia [image] - zmiana aktywnego wiersza w tabeli nie będzie powodowała zmiany pozycji linii odczytu;

- Do głównej linii odczytu [image] - zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji głównej linii odczytu. Opcja ma znaczenie tylko, jeśli główna linia odczytu jest włączona;

- Do dodatkowej linii odczytu [image] - zmiana aktywnego wiersza w tabeli będzie powodowała zmianę pozycji dodatkowej linii odczytu. Opcja ma znaczenie tylko, jeśli dodatkowa linia odczytu jest włączona;

- Dane [image] - wyświetla informacje o rodzaju danych w tabeli i jak one są wyświetlane;

- Kolor tła wspólnych kolumn tabeli [image] - ustawia kolor tła kolumn Lp. i pojedynczej kolumny Czasu;

- Kolor tła panelu tabeli [image] - ustawia kolor tła panelu tabeli;

powiększ>>

Rysunek: Tabela danych bieżących.

Jeśli w oknie trendów aktywna jest linia odczytu, wówczas przesuwanie jej powoduje przesuwanie odpowiadającej jej wyselekcjonowanej linii w tabeli (z ewentualnym dodatkowym przesunięciem suwaka, tak aby wyselekcjonowana linia była zawsze widoczna). Odpowiednio zmiana położenia wyselekcjonowanej linii (spowodowana przez kliknięcie myszką w określonym wierszu) powoduje odpowiadającą zmianę położenia jej linii odczytu w obszarze wykresów.

Tabelę wartości można zapisać do pliku przy pomocy komendy Eksport danych, dostępnej na zakładce Dane okna głównego programu AsTrend > w grupie Eksport danych. Dane zostaną zapisane do pliku CSV.

Dokowanie okna tabeli w oknie trendu

Dodatkowo tabela może być 'zadokowana' w oknie trendu, co oznacza wpasowanie w okno trendu nad, pod, z lewej, z prawej lub w miejsce obszaru wykresu (zamiast wykresu widoczne jest okno tabeli). W ostatnim wariancie obszar wykresu zostaje przykryty przez tabelę, niemniej można przełączać się pomiędzy widokami wykres - tabela za pomocą zakładek Wykres / Tabela.

- 'Dokowanie' okna tabeli realizowane jest poprzez przeciągnięcie tabeli w obszar wykresu i wpasowanie w wyświetlony graficzny schemat układu okien.

- Powrót do 'niezależnej' postaci tabeli uzyskuje się poprzez przeciągnięcie zakładki Tabela poza obszar wykresu.

- Powrót do 'niezależnej' postaci tabeli zawieszonej nad obszarem wykresu uzyskuje się poprzez przeciągnięcie zakładki Tabela nad obszar wykresu przy wciśniętym klawiszu Ctrl.

powiększ>>

Rys. Efekt 'dokowania' okna tabeli wartości bieżących.

Układ okien zapamiętywany jest w programie AsTrend automatycznie przy wyjściu z programu - ale istnieje również możliwość zapisu stanu okien dla pliku trendu: zakładka Widok okna głównego AsTrend > grupa Okno > okno 'Opcje okna trendu' uruchamiane przyciskiem [image] > opcja Zapisywanie układu okien.

Polecenie resetowania układu dokowania paneli Resetuj układ paneli [image] znajduje się na zakładce

Widok okna głównego AsTrend > w grupie Panele.


Obsługa tabeli danych historycznych

2.38 Obsługa trybu tabeli danych historycznych

Tryb pracy programu AsTrend w formie tabeli danych historycznych uruchamiany jest poleceniem [image] Nowa tabela danych historycznych z zakładki Plik okna głównego programu AsTrend.

Tryb pracy zapisywany jest przez administratora w pliku *.trnx trendu. Otwarcie tego pliku przez operatora spowoduje przełączenie programu AsTrend w tryb tabeli danych historycznych i wyświetlenie zdefiniowanych przez administratora zmiennych i kolumn.

Aby przygotować plik zawierający tabelę danych historycznych, użytkownik musi się zalogować jako administrator programu AsTrend, wybrać polecenie Nowa tabela danych historycznych (w menu Plik), otworzyć bazę definicji zmiennych i dodać wybrane zmienne. Dla lepszej przejrzystości danych wyświetlanych w tabeli można użyć pustych wierszy. Można zmieniać kolejność zmiennych przeciągając je myszką w wybrane miejsce. Administrator określa również kolumny wyświetlane w tabeli, zaznaczając nazwy nagłówków kolumn w oknie otwieranym przyciskiem [image].

Wyeksportowanie tabeli danych historycznych do schowka / pliku tekstowego / HTML / XLS odbywa się przy użyciu poleceń: Kopiuj do schowka, Zapisz do pliku tekstowego, Zapisz do pliku HTML, Zapisz do pliku XLS wywoływanych z zakładki Narzędzia główne okna głównego programu AsTrend > z grupy Tabela danych historycznych > przyciskiem Eksport tabeli.

powiększ >>

Rysunek: AsTrend - tryb tabeli danych historycznych - kontekstowa zakładka 'Narzędzia główne'.

***

Zmianę opcji dotyczących wyglądu tabeli umożliwia kontekstowa zakładka Widok - dostępna w oknie głównym programu AsTrend. Zakładka pozwala określić kolorystykę tabeli i format czcionki tabeli (opcje dotyczą wyłącznie pracy programu AsTrend w trybie tabeli danych historycznych):

powiększ >>

Rysunek: AsTrend - tryb tabeli danych historycznych - kontekstowa zakładka 'Widok'.


otwieranie okna raportu

2.39.1 Uruchamianie okna nowego raportu

Aby przełączyć AsTrend do pracy w trybie generowania raportu, należy z menu Plik wybrać jedno z dwóch poniższych poleceń:

Nowy raport - otwarcie okna nowego raportu;

Nowy raport - z bieżącego trendu - otwarcie okna nowego raportu w oparciu o dane z bieżącego skonfigurowanego pliku trendu;

Spowoduje to wyświetlenie okna w jednej z dwóch następujących postaci (w zależności od użytego polecenia), z dodaną zakładką Raport:

powiększ >>

Rysunek: AsTrend - okno raportu pustego.

powiększ >>

Rysunek: AsTrend - okno raportu utworzonego na podstawie bieżącego trendu.


Dodawanie zmiennych do raportu

2.39.2 Dodawanie/usuwanie zmiennych do/z raportu

Przed przystąpieniem do odczytu wartości zmiennych, w oparciu o które budowany będzie raport, należy wskazać bazę definicji zmiennych - patrz: 2.12 Wybór bazy definicji zmiennych systemu Asix / serwera OPC / AsBase / AsLogger .

Aby dodać do raportu dane przebiegu zmiennej, należy użyć poleceń z grupy Nowy przebieg na zakładce Raport:

Dane surowe - powoduje otwarcie okna dodawania zmiennej agregowanej, w którym należy wybrać zmienną oraz agregat, który będzie wyliczany w wierszu podsumowującym raportu.

Wyliczany - powoduje otwarcie okna 'Dodaj przebieg wyliczany’, które umożliwia dodanie do raportu zmiennej, która jest wyliczana z innych zmiennych za pomocą podanego wyrażenia;

Pozostałe przebiegi:

Dane zewnętrzne - powoduje pobranie wartości zmiennych z plików zewnętrznych;

Serwer OPC - HDA - powoduje pobranie wartości zmiennych z serwera OPC-HDA; opcja dostępna przy rozszerzonej licencji klucza HASP pakietu Asix;

***

Aby usunąć z raportu dane przebiegu zmiennej, należy użyć polecenia z grupy Nowy przebieg na zakładce Raport:

Usuń zaznaczony - usuwa aktualnie wybraną zmienną.

Poniższy rysunek przedstawia 'surowy' raport, który następnie należy sparametryzować według własnych potrzeb.

powiększ >>

Rys. AsTrend - prosty nie sparametryzowany raport.


Parametryzacja raportu

2.39.3 Parametryzacja raportu / opcje raportu

Parametryzacja raportu w programie AsTrend obejmuje określenie typu i okresu danych oraz szeregu parametrów wpływających na estetykę raportu.

Zasadniczą sprawą jest określenie, z jakiego typu raportem chcemy mieć do czynienia - czy będzie to przykładowo raport dobowy wg godzin, raport zmianowy wg godziny, czy może jakiś inny zdefiniowany według własnych potrzeb.

Aby określić typ i okres danych raportu, należy w grupie poleceń Typ i okres danych raportu skorzystać z następujących poleceń:

- umożliwia wybranie typu raportu; dostępne typy:

- raport roczny wg miesięcy,

- raport roczny wg tygodni,

- raport roczny wg dni,

- raport kwartalny wg miesięcy,

- raport kwartalny wg dni,

- raport miesięczny wg dni,

- raport miesięczny wg godzin,

- raport tygodniowy wg dni,

- raport tygodniowy wg godzin,

- raport dobowy wg godzin,

- raport zmianowy wg godzin,

- raport dowolny - wybranie tego typu wyświetla w grupie poleceń dodatkowe pola: Długość i Interwał, za pomocą których użytkownik może sam określić typ raportu;

W zależności od ustawienia typu raportu w grupie poleceń wyświetlane są dodatkowe pola, umożliwiające doprecyzowanie wybranego typu:

, [image], [image], [image], [image];

Do tyłu o okres - powoduje przesunięcie o bieżący okres do tyłu;

Do przodu o okres - powoduje przesunięcie o bieżący okres do przodu;

Do końca danych - powoduje przesunięcie do końca przebiegu.

***

Wygląd raportu definiowany jest przy użyciu opcji umieszczonych w oknie 'Opcje raportu', uruchamianym poleceniem Opcje z grupy poleceń Operacje raportu na zakładce Raport.

Okno 'Opcje raportu' obejmuje parametry pogrupowane na trzech poniższych zakładkach:

1. Zakładka Wygląd:

Nazwa czcionki - nazwa czcionki zastosowanej dla wszystkich tekstów raportu;

Rozmiar tekstu - rozmiar czcionki w wierszach danych;

Wiersze nieparzyste - kolor tekstu i tła dla nieparzystych wierszy danych;

Wiersze parzyste - kolor tekstu i tła dla parzystych wierszy danych

Etykiety wierszy podsumowań - teksty wierszy podsumowań;

Nagłówek:

Wysokość wiersza nagłówka - wysokość wiersza nagłówka liczona w liniach tekstu;

Rozmiar i kolor tekstu - rozmiar i kolor czcionki dla nagłówka;

Kolor tła - kolor tła nagłówka;

Podsumowanie:

Rozmiar i kolor tekstu - rozmiar i kolor tekstu wierszy podsumowań (agregatów);

Pogrubienie - pogrubienie tekstu wierszy podsumowań (agregatów);

Kolor tła - kolor tła wierszy podsumowań (agregatów);

Linia siatki:

Linie - wskazanie linii, do których będzie się odnosić wartość z pola Kolor (poniższego);

Kolor - kolor linii siatki tabeli wskazanych w powyższym parametrze Linie;

powiększ >>

Rys. Okno 'Opcje raportu' - zakładka 'Wygląd'.

2. Zakładka Układ strony:

Papier

Orientacja - orientacja strony na wydruku raportu;

Rozmiar - rozmiar strony wydruku raportu;

Centruj raport na stronie - opcja centrowania zawartości strony raportu;

Marginesy

Wysokość nagłówka [mm] - wysokość obszaru nagłówka raportu;

Marginesy [mm] - wysokość marginesów z czterech stron tabeli raportu;

Wysokość stopki [mm] - wysokość obszaru stopki raportu;

powiększ >>

Rys. Okno 'Opcje raportu' - zakładka 'Układ strony'.

3. Zakładka Wygląd strony:

Tytuł raportu

Tekst tytułu - tekst tytułu raportu;

Rozmiar i kolor tekstu - rozmiar i kolor tekstu tytułu raportu;

Wyrównanie na stronie - wycentrowanie, wyrównanie do prawej lub wyrównanie do lewej tekstu tytułu raportu;

Nagłówek strony

Logo - plik BMP, który można załadować do nagłówka raportu przyciskiem Wybierz, a usunąć przyciskiem Usuń;

Tekst nagłówka - pole do wpisania własnego tekstu nagłówka;

Rozmiar i kolor tekstu - rozmiar i kolor tekstu nagłówka raportu;

Pogrubienie - pogrubienie tekstu nagłówka raportu;

Stopka strony

Tekst stopki - tekst stopki raportu;

Rozmiar i kolor tekstu - rozmiar i kolor tekstu stopki raportu;

Pogrubienie - pogrubienie tekstu stopki raportu;

Drukuj numer strony - dodanie numeru strony do stopki raportu;

Drukuj nazwę pliku - dodanie nazwy pliku do stopki raportu;

powiększ >>

Rys. Okno 'Opcje raportu' - zakładka 'Układ strony'.

***

Aby podejrzeć wydruk raportu, należy skorzystać z polecenia [image] Podgląd wydruku z grupy Operacje raportu na zakładce Raport.

***

Aby podejrzeć prawą krawędź strony raportu, należy skorzystać z polecenia [image] Pokaż brzeg strony z grupy Operacje raportu na zakładce Raport.

powiększ >>

Rys. Podgląd raportu sparametryzowanego przez użytkownika.


eksportowanie raportu

2.39.5 Eksportowanie raportu

Aby wyeksportować raport utworzony w programie AsTrend, należy użyć polecenia [image] Eksport z grupy Operacje raportu na zakładce Raport. Polecenie to umożliwia wyeksportowanie raportu do pliku jednego z trzech formatów:

- plik tekstowy,

- HTML,

- XLSX.


Dodawanie do raportu nowych agregatów podsumowujących

2.39.6 Dodawanie do raportu nowych agregatów podsumowujących

Aby dodać do raportu nowe agregatu podsumowujące, należy poprzez dwukrotne kliknięcie w obszarze tabeli raportu wywołać okno 'Opcje przebiegu' i przejść na zakładkę Raport. W bloku Komórki podsumowania dla przebiegu znajdują się pola umożliwiające zadeklarowanie maksymalnie do 5 wartości agregatów podsumowujących wiersze tabeli danych w raporcie.

powiększ >>

Rys. Okno 'Opcje przebiegu' - zakładka Raport.


Zmiana palety kolorow

2.40 Zmiana palety kolorów

W programie AsTrend istnieje możliwość zdefiniowania domyślnej palety kolorów. Kolejne krzywe dodawane do zestawu będą przyjmować kolory zgodnie z tą paletą. Paleta może być zdefiniowana w opcjach programu lub opcjach trendu.

Własna paleta kolorów definiowana w opcjach trendu

Wywołanie okna definiującego tę paletę odbywa się przy pomocy zakładki Paleta kolorów z okna 'Opcje trendu', uruchamianego przyciskiem [image] z zakładki Trend i legenda okna głównego programu AsTrend > z grupy Trend. Zakładka jest dostępna pod warunkiem zaznaczenia opcji Użyj palety kolorów z opcji trendu (okno 'Opcje trendu' > zakładka Wygląd).

Zakładka Paleta kolorów pozwala:

- wybrać albo paletę kolorów spośród predefiniowanych palet

albo

- utworzyć własną paletę, wybierając opcję <Własna paleta trendu> i definiując kolejne okna podglądu kolorów.

powiększ >>

Rys. Opcje trendu - Paleta kolorów.

Własna paleta kolorów definiowana w opcjach programu

Wywołanie okna definiującego tę paletę odbywa się przy pomocy zakładki Paleta kolorów z okna 'Opcje programu', uruchamianego poleceniem Opcje programu z listy poleceń zakładki Plik okna głównego AsTrend.

Zakładka Paleta kolorów pozwala:

- wybrać albo paletę kolorów spośród predefiniowanych palet

albo

- utworzyć własną paletę, wybierając opcję <Własna paleta trendu> i definiując kolejne okna podglądu kolorów.

powiększ >>

Rys. Opcje trendu - Paleta kolorów.


Zmiana języka

2.42 Zmiana języka pracy programu

Zmiany języka pracy programu AsTrend można dokonać przy pomocy listy rozwijanej Język dostępnej na zakładce Widok okna głównego AsTrend > grupie Styl, pod warunkiem uruchomienia programu AsTrend niezależnie od aplikacji Asix.


Deklaracja parametrów sieciowych

2.43 Deklaracja parametrów sieciowych

Zakładka Sieć - dostępna w oknie 'Opcje programu' wywoływanym z menu Plik - daje możliwość zadeklarowania:

- Nazwy serwerów danych, z których pobierane będą dane do wyświetlania wykresów trendów,

- oraz Maksymalnego czasu oczekiwania na zgłoszenie się serwera i Maksymalnego czasu odpowiedzi serwera danych (wartość w milisekundach).

powiększ >>

Rysunek: Opcje programu - zakładka 'Sieć'.


Konfiguracja modułu sieciowego Aslink

2.44 Konfiguracja modułu sieciowego Aslink

Do poprawnej pracy programu AsTrend nie jest wymagana konfiguracja modułu Aslink odpowiedzialnego za dostarczanie danych archiwalnych - prawidłowe działanie systemu zapewniają domyślne ustawienia modułu sieciowego.

Jedynie parametr określający protokoły sieciowe oraz parametr deklarujący nazwę komputera mogą wymagać określenia dla stanowiska sieciowego:

- w przypadku pracy programu AsTrend w połączeniu z aplikacją systemu Asix ustawienie parametru Protokoły sieciowe i parametru Nazwa komputera pobierane są z pliku konfiguracyjnego aplikacji (plik XML);

Ustawienie parametru: Protokoły sieciowe:

Architekt > Obszary i komputery > moduł Moduł sieci > zakładki Komunikacja poprzez TCP/IP, Komunikacja poprzezNetBIOS

Ustawienie parametru: Nazwa komputera:

Architekt > Obszary i komputery > moduł Moduł sieci > zakładki Komunikacja poprzez TCP/IP, Komunikacja poprzezNetBIOS

- w przypadku niezależnej pracy programu AsTrend, należy umieścić w pliku ASLINK.INI (znajdującym się w katalogu, w którym zainstalowano system Asix) następujące zapisy:

[ASLINK]

NAZWA=ASIXTREND

ADAPTER=TCPIP

Wymieniony plik powinien się znaleźć w katalogu, z którego jest uruchamiany program AsTrend.


Agregaty - nowa źródło analiz danych statystycznych

4.13.1. Agregaty - nowe źródło analiz danych statystycznych

Dla potrzeb efektywnych analiz użytkownik programu AsTrend od wersji 5.1 ma dostęp do obszernego zestawu wartości agregowanych na żądanie dla wszystkich danych z dowolnego horyzontu czasu. Zestaw agregatów obejmuje następujące pozycje: wartość minimalna, wartość maksymalna, rozpiętość wartości, wartość początkowa, wartość końcowa, przyrost wartości, całka, wartość średnia, wartość średnia0 oraz gradient (czyli agregat rozpiętość wartości podzielony przez długość okresu w sekundach).

Agregaty mogą być wykorzystywane do wyliczenia i wyświetlenia przebiegów wartości zagregowanych w zadanym horyzoncie czasu, lub też wyliczenia wartości zagregowanych na podstawie danych z aktualnie wyświetlonego okresu i wyświetlenia tych wartości w polach legendy.

  • W pierwszym przypadku użytkownik sam określa rodzaj interesującego go agregatu używanego do czytania danych (niezależnie od typu danych prezentowanych na wykresie: dane oryginalne, równomierne, przybliżone i uśrednione) oraz okres agregatu, który jest podstawą wyliczania kolejnych wartości zagregowanych. Dzięki Agregatorowi (modułowi systemu asix do wyliczania i archiwizacji danych statystycznych), dane wyliczane są przez serwer asix, skąd pobiera je program AsTrend – dzięki temu ‘gotowe’ dane statystyczne interesujące użytkownika dostarczane są w sposób szybki i efektywny.

  • W drugim przypadku wartości agregatów wyliczane są lokalnie przez program AsTrend dla wartości wyświetlonych na wykresie w ramach zadanego odcinka czasu (niezależnie od typu danych prezentowanych na wykresie: dane oryginalne, równomierne, przybliżone i uśrednione). Wgląd do tak wyliczonych agregatów umożliwiają kolumny wyświetlane w legendzie.


Dodanie bitów zmiennej statusowej

4.3.9. Dodanie bitów zmiennej statusowej

Dodanie bitów zmiennej statusowej umożliwia polecenie z menu Seria > Dodaj bity zmiennej statusowej...

Powyższe polecenie uruchamia okno, w którym należy wskazać:

- zmienną, której bity zostaną dodane do trendu - pole Nazwa zmiennej,

- a także określić, które atrybuty bitów mają być wyświetlane w legendzie - blok Atrybuty pobierane z definicji bitu:

- Tylko opis - w legendzie, w kolumnie opisu zmiennej zostanie wyświetlony opis bitu zmiennej; w kolumnach pozostałych atrybutów zostaną wyświetlone wartości atrybutów zmiennej;

- Tylko opis połączony z opisem zmiennej - w legendzie, w kolumnie opisu zmiennej zostanie wyświetlony opis bitu zmiennej połączony z opisem zmiennej; w kolumnach pozostałych atrybutów zostaną wyświetlone wartości atrybutów zmiennej;

- Wszystkie - w legendzie, w kolumnach wszystkich atrybutów zostaną wyświetlone wartości atrybutów bitu zmiennej. Możliwość pobierania wszystkich atrybutów z definicji bitu blokowana jest w przypadku, gdy baza nie ma zdefiniowanego atrybutu Nazwy stanów.

Rysunek: Wykres bitów zmiennych statusowych.


długość okresu wyświetlania danych

2.15.7 Wyświetlanie długości okresu wyświetlania danych

Długość okresu wyświetlania danych można ustawić przy pomocy przycisków umieszczonych na zakładce Narzędzie główne okna głównego AsTrend > grupie Przesuwanie okresu:

Zmniejsz okres - powoduje zmniejszenie okresu następujące wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

Zwiększ okres - powoduje zwiększenie okresu następujące wg kolejnych predefiniowanych w programie AsTrend wielkości okresów;

***

Drugim sposobem jest zdefiniowanie własnego odcinka czasu w oknie 'Okres', wywoływanym z zakładki Narzędzia główne > grupy Okres, po kliknięciu na pole z wartością aktualnie wyświetlanego okresu czasu:

powiększ >>

Rys. Okno ustalania okresu czasu wyświetlania danych.

AsTrend obsługuje przebiegi o okresie próbkowania poniżej 1 ms. Dla bardzo krótkich okresów etykiety osi nie są oddalone o równe okresy czasu i jest to nieuniknione. Minimalna długość okresu wyświetlania przy operacji zoom wynosi 1 ms.


interwał wyliczania agregatu

Interwał wyliczania agregatu - długość okresu stanowi wielokrotność sekund, minut, godzin, zmian, dni, tygodni, miesięcy i lat.

Parametryzacja systemu zmianowego na potrzeby programu AsTrend realizowana jest w:

AsTrend > zakładka Dane > okno 'Opcje danych wejściowych trendu' > zakładka System zmianowy

Rys. Okno 'Interwał wyliczania agregatu'.

Rys. Opcje danych wejściowych trendu > Konfiguracja systemu zmianowego.


Nowości 5.1

1.1.6 Nowości 5.1

Program AsTrend w najnowszej wersji 5.1. został wyposażony w nową zaawansowaną funkcjonalność, która wyróżnia się intuicyjnością i łatwością obsługi. Nowa wersja oznacza przede wszystkim nowe możliwości w zakresie wyświetlania wielu rodzajów danych, możliwość rysowania wykresów o bardzo szerokim okresie za pomocą wartości uśrednionych, możliwość wyświetlania wykresów wartości zmiennych pobieranych z plików zewnętrznych oraz nowy przyjazny dla użytkownika interfejs graficzny, ułatwiający definiowanie i obsługę trendów w sposób bardziej efektywny i kreatywny.

Nowy Kreator Trendów

Wraz z wersją 5.1 programu AsTrend użytkownicy otrzymują udoskonalone narzędzie prowadzące użytkownika przez kolejne etapy definiowania trendu - czyli w przypadku programu AsTrend - definicji okna zawierającego zestaw wykresów zadeklarowanych zmiennych.

Nowy Kreator trendów dzięki systemowi podpowiedzi gwarantuje, że definicje trendów tworzone są w sposób szybki, łatwy i przyjemny. Na poszczególnych etapach tworzenia definicji użytkownik informowany jest m.in. o możliwych do zadeklarowania typach wykresu, typach osi, polach widocznych w legendzie i okresach próbkowania.

Kontrola uprawnień użytkowników AsTrend

Program AsTrend w wersji 5.1 wyposażony został w obsługę mechanizmu zarządzania i kontroli uprawnień opartego na systemie logowania indywidualnych użytkowników. Dzięki temu istnieje możliwość nadania użytkownikom indywidualnych haseł i uprawnień, które decydują o tym, które informacje są dla nich widoczne, lub które parametry mogą być przez nich modyfikowane.

W wersji AsTrend 5.1 obsługa uprawnień użytkowników może być realizowana na dwa sposoby:

  • z wykorzystaniem modułu AsAudit, który zapewnia bogate możliwości zarządzania użytkownikami oraz ich uprawnieniami (wymagane zainstalowanie silnika bazy MS SQL Express na jednym centralnym serwerze bazy uprawnień);

  • z wykorzystaniem uproszczonych mechanizmów zarządzania uprawnieniami dostępnych w starszych wersjach programu AsTrend.

Obsługa Agregatora - modułu systemu Asix do wyliczania i archiwizacji danych statystycznych

Zastosowanie modułu Agregator pozwoliło na zoptymalizowanie mechanizmu rysowania wykresów o szerokim okresie czasu. Wykresy rysowane są w pierwszej kolejności z wartości zagregowanych pobieranych z archiwum serwera Asix, co znacząco wpływa na szybkość i elastyczność ich wyświetlania. AsTrend automatycznie sam dobiera okres agregatu do horyzontu wyświetlanego wykresu.

Nowe agregaty - nowe źródło analiz danych statystycznych

Dla potrzeb efektywnych analiz użytkownik programu AsTrend wersji 5.1 ma dostęp do obszernego zestawu wartości agregowanych na żądanie dla wszystkich danych z dowolnego horyzontu czasu. Zestaw agregatów obejmuje następujące pozycje: wartość minimalna, wartość maksymalna, rozpiętość wartości, wartość początkowa, wartość końcowa, przyrost wartości, całka, wartość średnia, wartość średnia0 oraz gradient (czyli agregat rozpiętość wartości podzielony przez długość okresu w sekundach).

Agregaty mogą być wykorzystywane do wyliczenia i wyświetlenia przebiegów wartości zagregowanych w zadanym horyzoncie czasu, lub też wyliczone na podstawie danych z aktualnie wyświetlonego okresu i wyświetlone w polach legendy.

Dwie linie odczytu wartości na wykresie

AsTrend umożliwia bardzo dokładny odczyt wartości punktów pomiarowych przy pomocy linii odczytu ustawianej ręcznie lub przy użyciu okna dialogowego. Interesujące operatora wartości wskazanego punktu pomiarowego, m.in.: czas, wartość wskazana, wartość liczona, wyświetlane są w polach legendy.

Dzięki dodaniu w wersji 5.1 mechanizmu drugiej linii odczytu użytkownik otrzymuje możliwość swobodnego wydzielenia na wykresie dowolnego odcinka czasu, dla którego wyliczone zostaną agregaty, wyświetlane w polach legendy (jeśli linie odczytu są wyłączone, wspomniane pola w legendzie wskazują agregaty wyliczane dla całego wyświetlonego okresu). Druga linia odczytu posiada własne pola w legendzie wyświetlające: czas, wartość wskazaną, wartość liczoną oraz długość odcinka czasu pomiędzy obiema liniami.

Nowe opcje eksportu danych z wykresów

Korzystając z nowej komendy Eksportuj dane eksportujdane można w łatwy sposób wyeksportować dane prezentowane na ekranie monitora.

Udostępniony został zmodyfikowany format eksportu, w którym wartości punktów pomiarowych zmiennych wraz ze stemplem czasowym eksportowane są do pliku tekstowego *.txt, *.csv (lub schowka) w formie wartości oddzielonych znakami separatora (lub w przypadku eksportu do schowka - znakami tabulacji). Dane uszeregowane są w kolumnach zawierających kolejno: czas, wartości zmiennej. Każda zmienna posiada swoja kolumnę czasu i wartości - wyjątkiem jest przypadek danych równomiernych (stały okres czasu pomiędzy kolejnymi próbkami), gdzie istnieje możliwość ustawienia wspólnej kolumny czasu. Czas eksportowany jest w formacie systemowym ('2008-02-20 16:48:22’). Dla serii alarmowych oraz danych zewnętrznych kolumna czasu dodatkowo zawiera milisekundy. Dodano też możliwość ustawienia nagłówka dwuwierszowego oraz załączenia opcji wyświetlania przy nazwach zmiennych jednostki.

Odczyt danych z zewnętrznych źródeł

Poza odczytem danych dostarczanych przez system Asix, program AsTrend pozwala również na pobranie danych z zewnętrznego źródła. Odczytanie danych z plików *.csv, *.xls, oraz źródeł dostępnych poprzez OLE DB - takich jak bazy typu MSSQL i Access, ułatwia proste w użyciu i całkowicie intuicyjne okno dialogowe, zawierające podpowiedzi na temat wymaganej struktury danych w zewnętrznych źródłach, warunkującej odczyt danych w sposób uporządkowany czasowo.

Nowe typy prezentowanych danych

Nowa funkcjonalność programu AsTrend zwiększa możliwości w zakresie dostępnych typów danych, które mogą być prezentowane w przebiegach czasowych - poszerzając tym samym zakres informacji poddawanych analizie.

Poza wartościami zmiennych procesowych na wykresach istnieje możliwość wyświetlenia:

  • stałej, rysowanej jako pozioma linia;

  • zmiennej wyliczanej na podstawie wartości innych zmiennych;

  • informacji o momentach zmiany stanu alarmu;

  • oraz możliwość tworzenia wykresów z danych odczytanych z zewnętrznych źródeł (pliki *.csv, *.xls, bazy typu MS SQL i Access).

Wykresy dwuwymiarowe X-Y

Wykresy dwuwymiarowe dostępne od wersji AsTrend 5.1. umożliwiają prezentację i analizę zależności pomiędzy zmiennymi.

Wykres X-Y stanowi funkcję dwóch zmiennych Asixa przy założeniu, że okres czasu pomiędzy kolejnymi próbkami jest stały dla obu zmiennych (dane równomierne), a zmienne nie są binarne.

  • Zawartość etykiet załączanych dla punktów wykresu X-Y może być modyfikowana.

Możliwość użycia dodatkowej osi czasu

Możliwości oferowane przez wykresy powinny uwzględniać realizację porównań przebiegów tych samych bądź różnych zmiennych w różnych okresach czasu. Efekt taki można uzyskać w programie AsTrend stosując dodatkową oś czasu, załączaną dla jednej ze zmiennych, której przebieg jest porównywany z przebiegiem drugiej zmiennej (możliwe jest też porównywanie przebiegów tej samej zmiennej w 2 różnych okresach czasu).

Zmiany w zakresie sposobu próbkowania / obsługi różnych typów danych

W programie AsTrend 5.1. dostępne są następujące sposoby próbkowania powiązane z określonym typem danych:

  • odstępy pomiędzy pomiarami są takie jak w archiwum (narzucone przez program archiwizujący) - dane surowe;

  • odstępy między pomiarami są równe (wymuszone przez program AsTrend) - dane równomierne czytane przez agregat wskazany przez użytkownika;

  • odstępy pomiędzy pomiarami przyjmowane są automatycznie przez program AsTrend w zależności od długości okresu, dla którego wyliczane są wartości uśrednione (dane uśrednione) lub wartości minimalne i maksymalne (dane przybliżone).

Istotne zmiany wprowadzone do typów danych:

  • typy danych definiowane są teraz na poziomie całego trendu a nie na poziomie serii danych;

  • dane równomierne, uśrednione i przybliżone wyliczane są przez serwer Asix przy użyciu modułu Agregatora; dzięki temu AsTrend czyta gotowe dane zagregowane zamiast wyliczać je z wartości surowych;

  • wartości przybliżone są teraz rysowane w postaci wykresów HighLow; wykres jednej zmiennej składa się z dwu krzywych reprezentujących wartości minimalne i maksymalne - obszar pomiędzy nimi wypełniony jest kolorem serii.

Zmiana okresu wyświetlanych danych

Nowy interfejs AsTrend pozwala na płynne i precyzyjne ustawianie okresu wyświetlanych danych na kilka sposobów:

  • przy użyciu paska z przyciskami nawigacyjnymi;

  • poprzez nowe okno wyboru okresu, rozwijane z paska narzędzi;

  • przy użyciu okna predefiniowanych standardowych długości okresów (pula okresów została rozszerzona o nowe pozycje) - wybór preferowanego odcinka czasu przy użyciu tego okna powoduje wyświetlenie przebiegu zmiennych w zadanym okresie licząc od chwili bieżącej wstecz;

  • dodatkowo dodana została obsługa kółka myszy: ruch samego kółka powoduje przesuwanie okresu w tył/przód, ruch kółka przy wciśniętym klawiszu Ctrl powoduje zmianę szerokości okresu; ruch kółka przy wciśniętym klawiszu Shift powoduje szybkie przesuwanie okresu;

Ustawianie względnego okresu czasu danych wyświetlanych przy otwieraniu pliku trendu

Dzięki zastosowaniu formatu OPC opcje otwierania trendu pozwalają bardzo precyzyjnie określić czas, dla którego ma zostać wyświetlony przebieg wartości w momencie otwierania pliku trendu. Początek i koniec okresu czasu danych można wyrażać względnie wybierając konstrukcje typu: "Teraz”, "Początek dnia”, "Początek bieżącego miesiąca”, czy np. "Dziś godzina 6:00”.

W formułowaniu wyrażeń w formacie OPC użytkownik wyręczany jest przez 'Edytor czasu w formacie OPC’, który zawiera przyjazny interfejs z zestawem pól ułatwiających zdefiniowanie wymaganego okresu czasu.

Dostosowanie legendy do potrzeb użytkownika

Efektywność programu AsTrend w nowej wersji przejawia się również w funkcjonalności legendy trendu:

  • opcja zapamiętywania bieżących ustawień pozwala traktować daną legendę jako domyślną dla nowo tworzonych trendów;

  • mechanizm Drag&Drop umożliwia zmianę kolejności serii w legendzie;

  • do zestawu atrybutów wyświetlanych w polach legendy dodane zostały agregaty wyliczane dla wszystkich danych z aktualnie wyświetlonego okresu;

  • AsTrend wykorzystuje teraz informacje o typach atrybutów do automatycznego wyrównywania wartości w legendzie (informacja o typie atrybutu przechowywana jest w pliku trnx; tekst wyrównywany jest do lewej strony, liczba do prawej);

  • na liście standardowych kolumn legendy znalazła się kolumna Kolor serii, która wyświetla linię w kolorze serii danych; jeżeli kolumna jest wyświetlona w legendzie, to wszystkie teksty legendy wyświetlane są w kolorze czarnym; jeżeli kolumna Kolor serii jest ukryta, legenda wyświetla wiersze danych w kolorach odpowiadających kolorom serii na wykresie;

  • wszystkie atrybuty zmiennych zadeklarowanych w legendzie przechowywane są w pliku trendu, dlatego przy otwieraniu tego pliku nie jest wymagany dostęp do bazy definicji zmiennych, aby móc prawidłowo wyświetlić treść legendy;

  • format wyświetlania wartości w legendzie pobierany jest z bazy definicji zmiennych (w momencie zmiany zakresu wyświetlania wartości, format wyznaczany jest na podstawie zakresu, bądź może być ustawiony indywidualnie przez użytkownika);

Dodatkowe funkcje wykresów

  • Dodano wyświetlanie punktów brzegowych po prawej stronie wykresu.

  • Możliwe jest wyświetlanie na wykresie limitów ostrzegawczych i krytycznych dla poszczególnych serii. Funkcja jest dostępna, jeżeli w bazie definicji zmiennych limity określane zostały jako liczby.

  • Dodano również nową opcję serii: położenie osi pionowej dla wykresu wieloosiowego - stos. W zależności od ustawienia opcji Położenie osi w parametrach serii (oś może znajdować się po lewej lub prawej stronie wykresu) dwa sąsiednie wykresy przebiegów pojedynczych zmiennych mogą być połączone w jeden wykres dwóch przebiegów - taka możliwość ułatwia zagospodarowanie powierzchni wydruku (ekranu) i wpływa na zwiększoną czytelność wykresów oraz pozwala na szybkie zestawianie ze sobą dowolnych przebiegów.


Nowości w wersji 6

1.1. Nowości w wersji 6.0

strzalka Praca w trybie tabeli danych historycznych

Program AsTrend wyposażony został w nowy tryb pracy umożliwiający oglądanie danych historycznych w formie tabeli.

strzalka Zapisywanie parametrów domyślnych trendu

Do edytora opcji trendu dodano pole wyboru Zapisz jako domyślne. Zamknięcie okna gdy pole jest włączone powoduje zapisanie aktualnych opcji trendu w pliku domyślnych wartości trendu. Opcje te będą zawsze używane przy tworzeniu nowego trendu.

strzalka Nowa opcja formatu wartości agregatu 'całka'

W parametrach serii dotyczących formatu wartości dodano opcję Pokazuj całkę jako czas, której zastosowanie umożliwia wyświetlanie wartości agregatu 'całka' w formacie czasu: d h:mm:ss.

strzalka Przeliczanie agregatów 'całka' i 'gradient'

Do parametrów serii dodano nową opcję Okres pomiaru, która używana jest do przeliczania wartości agregatów 'całka' i 'gradient'. Opcja przy dodawaniu zmiennej inicjowana jest na podstawie wartości atrybutu Jednostka.

strzalka Zmiany w wykresach XY

Dodano możliwość rysowania wykresu XY z wieloma osiami OY

strzalka Agregacja danych systemu asix

Dodano możliwość wyliczania agregatów dla wszystkich typów danych zmiennych asixa - poprzednio agregaty wyliczane były tylko dla danych równomiernych.

strzalka Wyświetlanie przebiegów wzorcowych

Zakładka Przebiegi wzorcowe w opcjach serii pozwala na dodanie do okna trendu przebiegu wzorcowego (jednego lub dwóch). Dodanie dwóch przebiegów wzorcowych pozwala uzyskać wykres wstęgowy - przydatny przy ocenie kształtowania się wartości analizowanej zmiennej pod kątem przekroczeń wartości maksymalnych i minimalnych.

strzalka Wyświetlanie danych równomiernych

Do paska narzędzi do polecenia Dane równomierne dodano przycisk wyświetlający okienko edycji interwału odczytu tych danych.

strzalka Dodawanie zmiennych agregowanych

Do menu Seria dołożona została opcja dodawania zmiennej agregowanej. Polecenie to umożliwia dodanie zmiennej z asixa oraz zdefiniowanie agregatu tej zmiennej.

strzalka Osadzanie tabeli w obszarze wykresu trendu

Aktualnie tabela może być 'zadokowana' w oknie trendu, co oznacza wpasowanie tabeli w obszar wykresu w taki sposób, że zamiast wykresu widoczna jest tabela z wartościami zmiennych. Obszar wykresu zostaje wówczas przykryty przez tabelę - istnieje jednakze mozliwość przełączania się pomiędzy widokami wykres - tabela za pomocą zakładek Wykres / Tabela, pojawiających się nad legendą w momencie osadzenia tabeli.

strzalka Wersja internetowa programu AsTrend

W systemie asix w wersji 6 dostępna jest internetowa wersja programu AsTrend - co oznacza możliwość dostępu do programu poprzez przeglądarkę internetową.


Obsługa mechanizmu wielu wykresów

2.41 Obsługa mechanizmu wielu wykresów

Aby wyświetlić/ukryć dodatkowy wykres (maksymalnie 4 wykresy można wyświetlić), należy użyć poleceń [image], [image], [image] z zakładki Widok okna głównego AsTrend > grupy Panele.

Wykres 1 jest wykresem podstawowym i jest on zawsze widoczny.

***

Aby dodać przebieg do wybranego wykresu, należy zaznaczyć przebieg i użyć polecenia wyświetlającego przebieg na wybranym wykresie: , [image], [image] lub [image].

Drugim sposobem przydzielania przebiegów do wykresów jest metoda drag-and-drop. Przenoszenie tą metodą można wykonać z legendy do wykresu lub między wykresami.

***

Aby skopiować przebieg do innego wykresu, należy skorzystać z metody przenoszenia przebiegów drag-and-drop. Jeśli w trakcie przenoszenia naciśnięty jest przycisk Ctrl, to przebieg nie jest usuwany z wykresu, na którym aktualnie znajduje się, i tym sposobem zostaje skopiowany do innego wykresu.

***

Dodawanie nowego przebiegu do trendu powoduje dodanie tego przebiegu do aktywnego wykresu.

Rys. Wyświetlenie przebiegu na wykresie 3.

***

Dokowanie okna wykresu

Dodatkowo okno wykresu może być 'zadokowane' w oknie trendu, co oznacza wpasowanie w okno trendu nad, pod lub w miejsce innego wykresu. W ostatnim wariancie obszar innego wykresu zostaje przykryty przez dokowany wykres, niemniej można przełączać się pomiędzy widokami wykresów za pomocą zakładek Wykres / Wykres 2 / itd....

- 'Dokowanie' okna wykresu realizowane jest poprzez przeciągnięcie wykresu w obszar innego wyświetlonego wykresu i wpasowanie go w pojawiający się graficzny schemat układu okien.

- Powrót do 'niezależnej' postaci okna wykresu uzyskuje się poprzez przeciągnięcie zakładki wybranego wykresu poza obszar wykresu.

- Powrót do 'niezależnej' postaci okna wykresu zawieszonego nad obszarem innego wykresu uzyskuje się poprzez przeciągnięcie zakładki wybranego wykresu nad obszar innego wykresu przy wciśniętym klawiszu Ctrl.

Układ okien zapamiętywany jest w programie AsTrend automatycznie przy wyjściu z programu - ale istnieje również możliwość zapisu stanu okien dla pliku trendu: zakładka Widok okna głównego AsTrend > grupa Okno > okno 'Opcje okna trendu' uruchamiane przyciskiem [image] > opcja Zapisywanie układu okien.

Polecenie resetowania układu dokowania paneli Resetuj układ paneli [image] znajduje się na zakładce

Widok okna głównego AsTrend > w grupie Panele.

Rys. Efekt 'dokowania' okien wykresów.


okres próbkowania

Okres próbkowania danych równomiernych - długość okresu stanowi wielokrotność sekund, minut, godzin, zmian, dni, tygodni.

Parametryzacja systemu zmianowego na potrzeby programu AsTrend realizowana jest w:

AsTrend > zakładka okna głównego Dane > okno 'Opcje danych wejściowych trendu' > zakładka System zmianowy

powiększ >>

Rys. Okno 'Dane równomierne - okres próbkowania'.

Rys. Opcje danych wejściowych trendu > Konfiguracja systemu zmianowego.


Opcje źródła danych przebiegu

2.27.1 Opcje źródła danych przebiegu

Opcje umożliwiające dokonanie wyboru rodzaju agregatu używanego do przeliczania danych surowych, opcja wyboru archiwum aplikacji, z którego wyświetlane są dane znajdują się w oknie 'Źródło danych - przebieg zmiennej Asix', uruchamianym z zakładki Przebieg, grupy Operacje przebiegu, poleceniem Opcje źródła danych przebiegu [image] :

powiększ >>

Rys. Opcje źródła danych przebiegu.


Osie

2.21.3.2 Osie

Zakładka Osie (z okna 'Opcje trendu' wywoływanego przyciskiem [image] z zakładki Wykres okna głównego programu AsTrend > z grup: Typ wykresu lub Wygląd) obejmuje parametry:


stały układ wykresu

Stały układ wykresu - w momencie, gdy jest załączony, to:

- szerokość etykiet lewej i prawej osi jest stała (z wyjątkiem wykresu wieloosiowego);

- na wydruk zawsze jest rezerwowane miejsce na tytuł trendu.

Stały układ wykresu ułatwia porównywanie wydruków przebiegów.

Aby wykres miał stały układ, osie wykresu muszą być widoczne.


Ustawienie typu wykresu ze względu na typ osi

2.18 Ustawienie typu wykresu ze względu na typ osi

Wykres z osią fizyczną ustawiany jest przyciskiem Jedna oś OY [image] dostępnym na zakładce Wykres okna głównego programu AsTrend > grupie Osie.

Domyślnie trend ma załączoną oś fizyczną. Zakres ustalany jest w oknie 'Opcje osi trendu' ...

***

Wykres z osią procentową aktywowana jest z pomocą przycisku Oś procentowa [image] dostępnego na zakładce Wykres okna głównego programu AsTrend > grupie Osie.

***

Wykres Wiele osi OY uruchamiany jest przyciskiem Wiele osi OY [image] dostępnym na zakładce Wykres okna głównego programu AsTrend > grupie Osie.

Aby dla wybranego przebiegu wyświetlić oś pionową po prawej stronie wykresu, należy zaznaczyć dany przebieg i wybrać polecenie Oś po prawej stronie wykresu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

Aby dla wybranego przebiegu wyświetlić oś pionową po lewej stronie wykresu, należy zaznaczyć dany przebieg i wybrać polecenie Oś po lewej stronie wykresu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

***

Wykres Wiele osi OY - stos uruchamiany jest przyciskiem Wiele osi OY - stos [image] dostępnym na zakładce Wykres okna głównego programu AsTrend > grupie Osie.

Dodatkowo, dla wykresu Wiele osi OY - stos dodana została opcja umożliwiająca wyświetlanie przebiegów sąsiednich zmiennych na wspólnym wykresie. Taki wykres opisany jest przy pomocy wielu osi OY (w zależności od tego, ile sąsiednich przebiegów połączymy na wspólnym wykresie) umieszczonych po lewej lub prawej stronie wykresu. Opcja ta jest użyteczna, gdy chcemy pokazać przebieg zmiennych na większej powierzchni ekranu (wydruku), co znacznie poprawia czytelność wykresu, bądź też w sytuacji, gdy chcemy szybko zestawić ze sobą dwa przebiegi.

Aby połączyć wybrany przebieg z sąsiadującym przebiegiem, należy zaznaczyć dany przebieg i wybrać polecenie Oś pionowa w tym samym wierszu co oś poprzedniego przebiegu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

Aby na powrót rozdzielić połączone przebiegi, należy użyć polecenia Oś pionowa w nowym wierszu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

Aby dla wybranego przebiegu wyświetlić oś pionową po prawej stronie wykresu, należy zaznaczyć dany przebieg i wybrać polecenie Oś po prawej stronie wykresu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

Aby dla wybranego przebiegu wyświetlić oś pionową po lewej stronie wykresu, należy zaznaczyć dany przebieg i wybrać polecenie Oś po lewej stronie wykresu [image] z zakładki Przebieg okna głównego AsTrend > z grupy Przebieg.

***

Wykres X-Y załączany jest przyciskiem Wykres XY [image] , dostępnym na zakładce Wykres okna głównego programu AsTrend > grupie Wykres. Przełączenie na wykres, w którym wartości pomiarowe przebiegu rysowane są w funkcji czasu umożliwia przycisk Wykres XT [image] .

Zawartość etykiet na wykresie X-Y definiowana jest parametrem Etykiety na wykresie XY, dostępnym na zakładce Osie w oknie 'Opcje trendu', uruchamianym przyciskiem [image] na zakładce Wykres okna głównego programu AsTrend > w grupie Typ wykresu.

UWAGA: Parametr dotyczący zawartości wyświetlanych etykiet należy definiować dla zmiennej, która znajduje się jako pierwsza w legendzie.

***

Wykres X załączany jest przyciskiem Wykres X [image] , dostępnym na zakładce Wykres okna głównego programu AsTrend > grupie Typ wykresu.


Załącznik 1

Tabela 1. Lista atrybutów systemowych Bazy Definicji Zmiennych dla aplikacji Asix w wersji Evo i klasycznej.

UWAGA: Różnice w interpretacji atrybutów dla aplikacji wersji Evo znajdują się w tabeli 1a (za tabelą 1).

Nazwa wewnętrzna atrybutu zmiennej (PL)

Rodzaj atrybutu

Nawa domyślnie wyświetlana w nagłówku (PL)

Nazwa wewnętrzna atrybutu zmiennej (EN)

Nawa domyślnie wyświetlana w nagłówku (EN)

Typ

Opis

Nazwa

obligatoryjny

Nazwa

Name

Name

T

Unikalna nazwa symboliczna zmiennej procesowej jednoznacznie identyfikująca tę zmienną dla wszystkich komponentów systemu Asix

Opis

obligatoryjny

Opis

Description

Description

T

Dowolny tekst np. zawierający technologiczny opis zmiennej procesowej

Kanał

obligatoryjny

Kanał

Channel

Channel

T

Nazwa logiczna kanału transmisji (jedna z nazw podanych w deklaracji kanałów transmisji)

Adres

obligatoryjny

Adres

Address

Address

T

Adres symboliczny, którego forma jest specyficzna dla każdego z drajwerów systemu Asix

LiczbaElementow

obligatoryjny

Liczba elementów

ElementsCount

Elements count

L

Liczba elementów wchodzących w skład zmiennej procesowej (zmienna może być tablicą)

OkresProbkowania

obligatoryjny

Okres próbkowania

SampleRate

Sample rate

L

okres aktualizacji wartości zmiennej procesowej (w sekundach)

FunkcjaPrzeliczajaca

obligatoryjny

Funkcja przeliczająca

ConversionFunction

Conversion function

T

Nazwa funkcji przeliczającej służącej do przeliczenia wartości otrzymanej ze sterownika na wartość przekazywaną do komponentów systemu Asix

Archiwum

obligatoryjny

Archiwum

Archive

Archive

T

Nazwa zasobu ASPAD (logiczna nazwa zasobu archiwum)

ParametryArchiwizacji

obligatoryjny

Parametry archiwizacji

ArchivingParameters

Archiving parameters

T

Parametry archiwizacji danej zmiennej

Grupa1

opcjonalny

Grupa1

Group1

Group1

T

Domyślnie generowany atrybut grupujący

Format

opcjonalny

Format

Format

Format

T

Format liczby w jakim będzie ona wyświetlana w systemie asix; format podany jest w konwencji języka C (np.: %4.2f oznacza 4 znaki, w tym 2 miejsca po przecinku)

FormatEvo

opcjonalny

FormatEvo

FormatEvo

FormatEvo

T

Format liczby w jakim będzie ona wyświetlana w aplikacji Asix.Evo

Jednostka

opcjonalny

Jednostka

Unit

Unit

T

Fizyczna jednostka zmiennej

ZakresPomiarowyOd

opcjonalny

Zakres pomiarowy od

MeasurementRangeFrom

Measurement range from

L

Maksymalny zakres możliwy do uzyskania - minimum

ZakresPomiarowyHi

opcjonalny

Zakres pomiarowy do

MeasurementRangeTo

Measurement range to

L

Maksymalny zakres możliwy do uzyskania - maksimum

ZakresSurowyOd

opcjonalny

Zakres surowy od

RawRangeFrom

Raw range from

L

Parametr funkcji przeliczającej – zakres wejściowy od …

ZakresSurowyDo

opcjonalny

Zakres surowy do

RawRangeTo

Raw range to

L

Parametr funkcji przeliczającej – zakres wejściowy do …

ZakresPrzetwornikaOd

opcjonalny

Zakres przetwornika od

TransducerRangeFrom

Transducer range from

L

Zakres przetwornika - minimum

ZakresPrzetwornikaDo

opcjonalny

Zakres przetwornika do

TransducerRangeTo

Transducer range to

L

Zakres przetwornika - maksimum

ZakresWyswietlaniaOd

opcjonalny

Zakres wyświetlania od

DisplayRangeFrom

Display range from

L

Dolny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresWyswietlaniaDo

opcjonalny

Zakres wyświetlania do

DisplayRangeTo

Display range to

L

Górny zakres wyświetlania danej zmiennej – dla obiektów asixa

ZakresSterowaniaOd

opcjonalny

Zakres sterowania od

SteeringRangeFrom

Steering range from

L

Dolny zakres wartości danej zmiennej ustawiany z asixa

ZakresSterowaniaDo

opcjonalny

Zakres sterowania do

SteeringRangeTo

Steering range to

L

Górny zakres wartości danej zmiennej ustawiany z asixa

BazaSlupka

opcjonalny

Baza słupka

BarBase

Bar base

T

Wielkość wczytywana z bazy przez obiekt SŁUPEK

NazwyStanow

opcjonalny

Nazwy stanów

StateNames

State names

T

Nazwa zbioru tekstów lub bezpośrednio zbiór opisów stanów (poszczególnych wartości całkowitych) zmiennej

ZestawStanow

opcjonalny

Zestaw stanów

StateSet

State set

T

Nazwa zbioru opisów stanów do którego należy bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

WartoscStanu

opcjonalny

Wartość stanu

StateValue

State value

T

Numer stanu, którego opis zawiera bieżący wiersz. Atrybut używany tylko dla wierszy zawierających element zbioru opisów stanów

MaskaZmiennejKontrolnej

opcjonalny

Maska zmiennej kontrolnej

ControlVariableMask

Control Variable mask

T

Wskazuje na bit statusu sygnalizowanego przez zmienną kontrolną

ZmiennaKontrolna

opcjonalny

Zmienna kontrolna

ControlVariable

Control variable

T

Nazwa zmiennej reprezentującej status zmiennej pomiarowej

LimitLoLo

opcjonalny

Minimum krytyczne

LimitLoLo

Limit LoLo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum krytycznego dla zmiennej pomiarowej

LimitLo

opcjonalny

Minimum

LimitLo

Limit Lo

T

Nazwa zmiennej systemu Asix, która zawiera wartość minimum dla zmiennej pomiarowej

LimitHi

opcjonalny

Maksimum

LimitHi

Limit Hi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum dla zmiennej pomiarowej

LimitHiHi

opcjonalny

Maksimum krytyczne

LimitHiHi

Limit HiHi

T

Nazwa zmiennej systemu Asix, która zawiera wartość maksimum krytycznego dla zmiennej pomiarowej

ZakresWyswietlaniaKrok

opcjonalny

Zakres wyświetlania krok

DisplayRangeStep

Display range step

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość podziałki głównej na osi OY (co ile jednostek będzie wyświetlana etykieta wartości na osi OY)

ZakresWyswietlaniaSzer

opcjonalny

Zakres wyświetlania szerokość

DisplayRangeWidth

Display range width

L

Atrybut wykorzystywany przez obiekt WYKRES. Oznacza szerokość etykiety wartości wyświetlanych na osi OY

ZakresWyswietlaniaPodzial

opcjonalny

Zakres wyświetlania podział

DisplayRangeDivision

Display range division

L

Atrybut wykorzystywany przez obiekt WYKRES. Wyznacza podział na mniejsze jednostki podziałki głównej (wyznaczonej przez atrybut Zakres wyświetlania krok) na osi OY

Dokładnosc

opcjonalny

Dokładność

Precision

Precision

T

Dokładność zaokrąglania w obiekcie LICZBA. Przykładowo podanie w tym polu liczby 10 spowoduje, że liczba będzie zaokrąglana do dziesiątek. Domyślnie nie ma zaokrąglania.

PolozenieSuwaka

opcjonalny

Położenie suwaka

SliderPosition

Slider position

T

Nazwa zmiennej, do której wpisywana będzie wartości reprezentująca położenie uchwytu obiektu SUWAK w trakcie przesuwania tegoż uchwytu

RejestracjaSterowania

opcjonalny

Rejestracja sterowania

ControlLogging

Control logging

Wartość logiczna

Wartość 1 oznacza, że sterowania zmiennej podlegają rejestracji w module AsAudit

ZmiennaNieaktywna

opcjonalny

Zmienna nieaktywna

ItemNotActive

Item not active

Wartość logiczna

Jeżeli wartość atrybutu wynosi 1, to zmienna nie jest widoczna w systemie Asix dla modułów Asmen i Aspad

WykresTytul

opcjonalny

Tytuł wykresu

ChartTitle

Chart title

T

Atrybut wykorzystywany przez obiekt WYKRES. Tytuł wykresu pobierany jest z atrybutu Tytuł wykresu pierwszej zmiennej zadeklarowanej na wykresie

ZakresSlupkaOd

opcjonalny

Zakres słupka od

BarRangeFrom

Bar range from

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera dolny zakres wyświetlania danej zmiennej.

ZakresSlupkaDo

opcjonalny

Zakres słupka do

BarRangeTo

Bar range to

T

Atrybut wykorzystywany przez obiekt SŁUPEK. Zawiera górny zakres wyświetlania danej zmiennej.

SzybkieOdswiezanie

opcjonalny

Szybkie odświeżanie

FastRefresh

Fast refresh

Wartość logiczna

Atrybut wykorzystywany przez drajwer CtTwinCATTcpip od wersji 1.3.5. Zmienne z zadeklarowanym atrybutem Fast Refresh mają udostępnioną funkcję szybkiego odświeżania, która umożliwia odświeżanie zmiennych z maksymalną osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę)

SprawdzanieZakresuPomiarowego

opcjonalny

Sprawdzanie zakresu pomiarowego

MeasurementRangeCheck

Measurement range check

Wartość logiczna

Wartość 1 oznacza, że dla podanej zmiennej monitorowane będą przekroczenia zakresu pomiarowego i sygnalizowane odpowiednim statusem OPC.

Status zmiennej jest określany po porównaniu wartości pomiarowej z wartościami zakresów pomiarowych:

a/ przy przekroczeniu zakresu o wartość <= od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_EGU_EXCEEDED

b/ przy przekroczeniu zakresu o wartość > od pasma zmienności wartości zmiennej (zakresTo - zakresLo) ustawiany jest status OPC_QUALITY_SENSOR_FAILURE

GrupaUprawnienOdczytu

opcjonalny

Grupa uprawnień odczytu

ReadAuthorizationGroup

Read authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzystają aplikacje: AsPortal i AsTrend, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do przeglądania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień odczytu, nazwę grupy użytkowników systemu Windows uprawnionych do

przeglądania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

GrupaUprawnienZapisu

opcjonalny

Grupa uprawnień zapisu

WriteAuthorizationGroup

Write authorization group

T

Zadeklarowanie atrybutu dla bazy definicji zmiennych, z których korzysta aplikacja AsPortal, powoduje zablokowanie możliwości odczytu wartości do momentu sprawdzenia uprawnień użytkownika (aby umożliwić dostęp do modyfikowania wartości zmiennych, należy dla każdej zmiennej podać ,jako wartość atrybutu

Grupa uprawnień zapisu, nazwę grupy użytkowników systemu Windows uprawnionych do

modyfikowania wartości zmiennej - działa przy zastosowaniu uwierzytelniania użytkowników przez system Windows).

T - tekst, L - liczba zmiennoprzecinkowa 64 bitowa

Tabela 1a. Lista atrybutów systemowych Bazy Definicji Zmiennych dla aplikacji Asix w wersji Evo.

Nazwa

Opis

Typ wartości

Określa typ wartości zmiennej w konwencji .Net. W przypadku użycia bazy MDB nie posiadającej tego atrybutu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej funkcji przeliczającej i formatu.

Format

Sposób formatowania tekstowego wartości w konwencji .Net. Skrócony opis formatów .Net można znaleźć w podręczniku AsixEvo_Techniki_budowy_diagramów.pdf/chm.

W przypadku baz MDB atrybut tworzony jest wirtualnie według poniższych zasad:

  1. Jeżeli w bazie jest atrybut FormatEvo, to jest on traktowany wprost jako definicja atrybutu Format Asix.Evo.

  2. Jeżeli w bazie nie ma atrybutu FormatEvo, to atrybut Format bazy MDB (podawany w konwencji formatów aplikacji klasycznych) jest w trakcie ładowania tłumaczony na odpowiadający mu format .Net.

Funkcja przeliczająca odczytu

Atrybut ma postać wyrażenia, które wstępnie przelicza pobraną z drajwera wartość surową zmiennej. W treści wyrażenia odwołanie do wartości surowej wykonywane jest przy pomocy funkcji RawValue.

W przypadku korzystania z serwera danych (kanał Asix6), niezależnie od definicji atrybutu funkcji przeliczającej odczytu, wartość zmiennej podlega standardowemu przeliczeniu przez Asmen’a na podstawie atrybutu Funkcja przeliczająca.

W przypadku użycia bazy MDB nie posiadającej atrybutu Funkcja przeliczająca odczytu, jest on tworzony wirtualnie na podstawie użytej w definicji zmiennej formatu.

Funkcja przeliczająca zapisu

Atrybut ma postać wyrażenia, które przelicza wartość sterującą przed wysłaniem jej do drajwera.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.

Wartość początkowa

Określa wartość początkową zmiennej, nadawaną zmiennej w momencie uruchomienia aplikacji.

Pozostałe zasady użycia są identyczne jak dla atrybutu Funkcja przeliczająca odczytu.