Witamy

Home > Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 8

www.asix.com.pl

Drajwery komunikacyjne -

Konfiguracja przy użyciu modułu Architekt

Dok. Nr PLH8002

Wersja: 2016-07-19

UWAGA:

Niniejszy podręcznik do użytku zarówno z wersją klasyczną jak i wersją Evo systemu Asix.


1. Drajwery komunikacyjne

W skład systemu Asix wchodzą drajwery obsługujące następujące typy połączeń ze sterownikami obiektu przemysłowego:

Drajwer

Protokół

ADAM

-

protokół dla sterowników ADAM firmy ADVANTECH

AGGREGATE

-

drajwer Aggregate pozwala definiować zmienne, których wartości powstają w wyniku przeliczania wartości innych zmiennych systemu Asix

AirPointer

-

komunikacja odbywa się przy pomocy protokołu HTTP przy wykorzystaniu stron info.php i download.php serwera webowego stacji monitoringu

AK

-

protokół AK dla analizatorów MLT2 f-my Emerson

AM_SA85

-

protokół do łączności z siecią Modbus Plus firmy Schneider Automation

Areva

-

protokół do komunikacji z urządzeniami MiCOM

AS511

-

protokół wykorzystujący interfejs programatora sterowników serii SIMATIC firmy SIEMENS

AS512

-

protokół procesorów komunikacyjnych CP524/525 sterowników serii SIMATIC firmy SIEMENS

AS512S7

-

protokół procesora komunikacyjnego CP340 sterowników SIMATIC S7 firmy SIEMENS

BACnetIP

protokół BACnet/ IP

BASKI

-

drajwer jest przeznaczony do importu danych z systemu imisji BASKI zainstalowanego w El. Bełchatów do systemu Asix

BAZA

-

drajwer pozwala na import danych z baz danych do systemu Asix

BUFOR

-

uniwersalny protokół wymieniający informacje z programem użytkownika poprzez wspólną pamięć

CALEC

-

drajwer Calec służy do pobierania bieżących wartości zmiennych z urządzenia CALEC MCP firmy Aquametro zgodnie z protokołem opisanym w dokumencie ”MCP Datenauslesung mit dem lowlevel Protokoll"

CAN_AC_PCI

-

protokół wymiany danych pomiędzy sterownikami SELECONTROL MAS firmy Selectron Lyss AG oraz komputerem systemu Asix

CANOPEN

-

protokół sieci CANOPEN sterowników SELECTRON MAS firmy Selectron Lyss AG

CipAB

-

protokół sterownikówserii Logix5000 firmy Allen-Bradley

COMLI

-

protokół (COMunication Link) do komunikacji ze sterownikami typu SattCon, AC 800C, AC 800M, AC 250 firmy ABB. Wymiana danych poprzez łącze szeregowe RS-232 lub RS-485

CPIII

-

protokół do komunikacji z panelami kontrolnymi CP-III/E, wykorzystywanymi do sterowania sprężarkami firmy MYCOM (MAYEKAWA)

CZAZ

-

protokół do komunikacji z urządzeniami CZAZ-U oraz CZAZ-UM

DATAPAF

-

protokół do łączności z licznikiem energii DataPAF

DDE

-

drajwer DDE służy do definiowania kanału modułu Asmen, odwołującego się do zmiennych udostępnianych przez drajwer sterownika przemysłowego zaimplementowanego w postaci serwera DDE (zwanego dalej krótko serwerem DDE)

Diva

-

protokół kamer przemysłowych DIVA firmy VDG Security B.V.

Dlms

-

protokół liczników energii elektrycznej rodziny ZxD/ZxG/ZxQ firmy Landys&Gyr

DlmsTcpip

-

protokół DLMS; do komunikacji jest wykorzystywany Ethernet

DMS285

-

protokół komputerów emisji D-MS285

DMS500

-

protokół komputerów emisji D-MS500 (poprzednia nazwa - DURAG)

DNP3

-

protokół stosowany w elektroenergetycznych systemach sterowania i nadzoru

DP

-

protokół urządzeń zgodnych z PROFIBUS DP przy wykorzystaniu karty PROFIboard

DP5412

-

protokół urządzeń zgodnych z PROFIBUS DP przy wykorzystaniu kart firmy Siemens

DSC

-

protokół do wymiany danych pomiędzy komputerem systemu Asix i sterownikiem DSC 2000

DXF351

-

protokół do komunikacji z urządzeniami Compart DXF351 firmy Endress+Hauser

Ecl

-

protokół do komunikacji z regulatorami ECL Comfort 210/310 produkowanymi przez firmę Danfoss

E2tangoTcpip

-

protokół sterowników polowych e2TANGO produkowanych przez firmę Elektrometal Energetyka

EcoMUZ

-

protokół urządzeń zabezpieczających ecoMUZ firmy JM Tronik

EcoMUZ2

-

protokół urządzeń zabezpieczających ecoMUZ-2 firmy JM Tronik

EQABP

-

protokół liczników energii elektrycznej EQABP firmy POZYTON

EQM

-

protokół liczników energii elektrycznej typu EQM firmy POZYTON w Częstochowie

Esser

-

protokół centrali p-poż Esser 8008 firmy Honeywell

FESTO

-

protokół wykorzystujący interfejs diagnostyczny dla sterowników firmy FESTO

FILE2ASIX

-

drajwer FILE2ASIX jest przeznaczony do importu danych do systemu Asix z plików tekstowych mających określoną strukturę

FP1001

-

protokół monitorów przepływu wody i pary firmy METRONIC Kraków

GFCAN

-

protokół sieci CAN przy użyciu karty komunikacyjnej firmy Garz & Fricke Industrieautomation GmbH

Global

-

drajwer CtGlobal służy do wymiany danych pomiędzy aplikacją systemu Asix a tzw. plikiem wymiany, będącym kontenerem na aktualne parametry zmiennych drajwera (nazwa, status, wartość, znacznik czasu). W aplikacji składającej się z wielu komputerów zawartość pliku wymiany może być synchronizowana pomiędzy poszczególnymi komputerami. W ten sposób można propagować na wszystkie komputery zmiany wartości zmiennych dokonywane na jednym z nich

IEC61850

-

protokół IEC61850

K3N

-

protokół wymiany danych pomiędzy sterownikami serii K3N firmy OMRON oraz komputerem systemu Asix

K-BUS

-

protokół K-BUS jest wykorzystywany do wymiany danych pomiędzy regulatorami kotłów serii Dekamatic f-my VIESSMANN dołączonymi do koncentratora Dekatel-G (lub Vitocom 200) oraz komputerem systemu Asix

Lb480

-

protokół koncentratorów LB-480 firmy LAB_EL Elektronika Laboratoryjna

LG

-

protokół sterowników LG Master-K i Glofa GM

Logo

-

protokół do wymiany danych pomiędzy systemem Asix i sterownikiem Logo OBA5 firmy SIEMENS za pomocą łącza programatora przedmiotowego sterownika

LUMBUS

-

protokół wymiany danych pomiędzy regulatorami RG72 produkowanymi przez Lubuskie Zakłady Aparatów Elektrycznych "LUMEL" w Zielonej Górze oraz komputerem systemu Asix

LZQM

-

wymiana danych z licznikami energii elektrycznej typu LZQM, produkowanymi przez Zakład Elektronicznych Urządzeń Pomiarowych POZYTON sp. z o.o. w Częstochowie. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie CLO

M200

-

drajwer komputera przepływu Spirax Sarco M200

MACMAT

-

protokół GAZ-MODEM korektorów przepływu gazu MACMAT

Max1000

-

komunikacja w oparciu o tzw. 'protokół sieciowy' z systemem MAX 1000 firmy ULTRAK zarządzającym pracą kamer. Drajwer realizuje wyłącznie funkcje przełączania kamer oraz synchronizacji czasu (drajwer jest źródłem czasu)

M-BUS

-

podzbiór standardowego protokołu do odczytu danych z urządzeń pomiarowych, wykorzystywany między innymi przez mierniki ciepła MULTICAL firmy KAMSTRUP A/S

MEC

-

protokół wymiany danych pomiędzy systemem Asix i licznikami ciepła MEC07 i MEC08 wyprodukowanymi przez Instytut Techniki Cieplnej w Łodzi. Wymiana danych odbywa się przy pomocy łączy szeregowych w standardzie RS-232.

MegaMuz

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany interfejs RS-485 zabezpieczeń.

MegaMuz2

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU przy pomocy łącza szeregowego.

MegaMuz_TCPIP

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany Ethernet.

MegaMuz2_TCPIP

-

protokół do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz2, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany Ethernet.

MELSECA

-

protokół procesora komunikacyjnego A1SJ71C24-R2 sterowników serii MELSEC-A

MEVAS

-

protokół wymiany danych pomiędzy komputerem emisyjnym MEVAS produkowanymi przez Lubuskie Zakłady Aparatów Elektrycznych "LUMEL" w Zielonej Górze oraz komputerem systemu Asix

MicroSmart

-

protokół wykorzystywany do wymiany danych ze sterownikami MicroSmart firmy IDEC

MODBUS

-

podzbiór standardowego protokołu komunikacyjnego wykorzystywany między innymi przez sterowniki Modicon firmy AEG oraz sterowniki firmy GE Fanuc

MODBUS_TCPIP

-

protokół wymiany danych pomiędzy systemem Asix i innymi komputerami/urządzeniami za pomocą protokołu MODBUS, zrealizowanego w oparciu o sieć Ethernet z protokołem TCP/IP

MODBUSSLV

-

protokół MODBUS, w którym Asix działa jako SLAVE

MPI

-

protokół interfejsu MPI sterowników SIMATIC S7 firmy SIEMENS; łącze szeregowe

MPS

-

protokół łącza szeregowego mierników parametrów sieci energetycznej MPS firmy OBR Metrologii Elektrycznej w Zielonej Górze

MSP1X

-

protokół MSP1X jest wykorzystywany do wymiany danych pomiędzy sterownikami MSP1X f-my ELMONTEX oraz komputerem systemu Asix.

Muel

-

protokół do wymiany danych pomiędzy systemem Asix i komputerem technicznym systemu MUEL

MultiMuz

-

protokół służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz_tcpip

-

protokół do komunikacji z urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz3

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie

MultiMuz3_TCPIP

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie

MUPASZ

-

protokół kanału pustego (wirtualnego)

Mupasz710_RS

-

protokół do komunikacji z mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie

MupaszRtu

-

protokół do wymiany danych pomiędzy systemem Asix i urządzeniami Mupasz2001G, Mupasz07 oraz Mupasz Compact G01 - produkowanymi przez ITR Warszawa.

MupaszRtu_TCPIP

-

protokół do wymiany danych pomiędzy systemem ASIX i mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU na łączu Ethernet poprzez port 502.

Mus04

-

protokół do wymiany danych z mikroprocesorowymi urządzeniami sterującymi MUS-04 firmy ELEKTROMETAL S.A. w Cieszynie

MUZ

-

protokół do wymiany danych pomiędzy
Mikroprocesorowymi Urządzeniami Zabezpieczającymi MUZ typu MUZ-RO

NCP

-

protokół do wymiany danych pomiędzy systemem Asix i sterownikami serii MN firmy Invensys (dawniej Satchwell)

NetLink

-

protokół MPI/Profibus do komunikacji z urządzeniami SIMATIC S7 z wykorzystaniem modułu NetLink Lite SYSTEME HELMHOLZ

NetLinkPro

-

protokół do komunikacji ze sterownikami S7 przy pomocy gateway’a NetLinkPRO (gateway Ethernet <-> MPI/Profibus). Producentem NetLinkPro jest SYSTEME HELMHOLZ

NONE

-

protokół NONE; nie realizuje fizycznego połączenia ze sterownikiem. Może być zastosowany w celu:

  • testowania aplikacji w trybie symulacji,

  • umożliwienia wymiany informacji pomiędzy programami systemu Asix za pomocą zmiennych procesowych

NordicRF

-

wymiana danych z czytnikiem kodów kreskowych Nordic ID RF 601. Komunikacja odbywa się przy wykorzystaniu łącza szeregowego RS-232 stacji bazowej

OMRON

-

do wymiany danych ze sterownikami OMRON

OmronTcpip

-

protokół FINS

OPC

-

protokół do wymiany danych między systemem Asix a dowolnym sterownikiem przemysłowym lub programem klasy SCADA, dla którego dostępny jest serwer danych zgodny ze specyfikacją OPC 1.0 lub OPC 2.05

PA5

-

drajwer protokołu liczników przepływu PA5

PD21

-

protokół do komunikacji z koncentratorem PD21 produkowanym przez LUMEL S.A. Zielona Góra

Pmc4000

-

służy do wymiany danych pomiędzy systemem Asix i centralą ppoż POLON 4800 wg protokołu PMC-4000

PPI

-

protokół dla sterowników SIEMENS S7 serii 200

Protherm300

-

driver do wymiany danych pomiędzy systemem Asix i sterownikiem Protherm 300 DIFF firmy Process-Electronic GmbH

PROTRONICPS

-

PROTRONIC PS firmy Hartmann & Braun

S700

-

protokół S700 jest wykorzystywany do wymiany danych pomiędzy analizatorami gazu serii S700 firmy Maihak oraz komputerem systemu Asix.

S7_TCPIP

-

protokół wykorzystywany do wymiany danych ze sterownikami SIMATIC serii S7 poprzez łącze Ethernet przy wykorzystaniu standardowej karty sieciowej komputera

SAPIS7

-

protokół sterowników SIMATIC S7 poprzez łącze MPI lub poprzez procesor komunikacyjny magistrali PROFIBUS (implementacja funkcji S7)

S-BUS

-

protokół S-BUS jest wykorzystywany do wymiany danych pomiędzy sterownikami PCD firmy SAIA Burgess Electronics oraz komputerem systemu Asix

SbusTcpip

-

do wymiany danych pomiędzy systemem Asix i rodziną sterowników PCD SAIA-Burgess przy wykorzystaniu protokołu Ethernet S-Bus

SINECH1

-

protokół procesora komunikacyjnego CP1430 sterowników SIMATIC S5 (Ethernet)

SINECL2

-

protokół procesorów komunikacyjnych CP5430 sterowników serii SIMATIC firmy SIEMENS

Si400

-

protokół przeznaczony do wymiany danych pomiędzy systemem Asix i centralą alarmową Sintony SI 400 firmy SIEMENS

SNG

-

protokół do komunikacji z urządzeniami instalacji SNG firmy Synergia Tech z Warszawy

SNMP

-

drajwer umożliwia odczyt i zapis wartości obiektów protokołu SNMPv1 i SNMPv2c - zarządzania różnymi elementami sieci telekomunikacyjnych, takimi jak routery, przełączniki, komputery czy centrale telefoniczne. Drajwer realizuje swoje funkcje za pomocą SNMP Management API

SNPX

-

służy do wymiany danych pomiędzy systemem Asix i jednostkami centralnymi sterowników serii 90-30 oraz modułami CMM i PCM serii 90 firmy GE Fanuc

Sp100H

-

protokół sterowników SP-100H centrali deszczowej Aqua Center Industrial 100 H 14-60 firmy MARLEy Polska Sp. z o.o.

SPA

-

protokół wykorzystywany do komunikacji z urządzeniami podłączonymi do magistrali SPA firmy ABB

Srio

-

wymiana danych z koncentratorem SRIO 500M (prod. ABB) komunikującym system nadrzędny z urządzeniami podłączonymi do magistrali SPA, np. zabezpieczeniami przekaźnikowymi i urządzeniami sygnalizacyjnymi. Komunikacja z koncentratorem jest realizowana przy pomocy łączy szeregowych w standardzie RS232, warstwa transportu danych - w oparciu o protokół ANSI X3.28 w trybie full-duplex z sumą kontrolną BCC

SRTP

-

drajwer jest przeznaczony do wymiany danych pomiędzy systemem Asix i sterownikami firmy GE Fanuc Automation serii VersaMax Nano/Micro przy wykorzystaniu konwertera IC200SET001 oraz sterownikami serii WersaMax i Series 90, przy wykorzystaniu modułu komunikacyjnego IC693CMM321, po sieci Ethernet z protokołem TCP/IP.

TALAS

-

protokół komputerów emisji TALAS

TwinCAT

-

przeznaczony do wymiany danych pomiędzy systemem Asix i systemem TwinCAT firmy Beckhoff Industrie Elektronik

TwinCATTcpip

przeznaczony do wymiany danych pomiędzy systemem Asix i systemem TwinCAT firmy Beckhoff Industrie Elektronik (korzysta z interfejsu ADS/AMS over TCPIP (bez użycia bibliotek Beckhoff'a)

Wago

-

protokół do wymiany danych ze sterownikami Wago

Vantage

-

protokół stacji pogodowych rodziny Vantage Pro produkowanych przez Davis Instruments Corp. USA

ZDARZENIE ZMIENNA

-

drajwer do generowania zmiennych procesowych typu WORD (słowo 16 bitowe) na podstawie bieżących wartości zdarzeń alarmowych w systemie Asix

ZxD400

-

drajwer protokołu liczników energii serii ZxD400 f-my Landys & Gyr

Zestaw dostępnych protokołów będzie systematycznie powiększany. Firma ASKOM podejmuje się, na życzenie klienta, opracowania dowolnego protokołu transmisji na zasadach określonych w cenniku systemu Asix.


ADAM - drajwer protokołu ADAM

Home > 1.1 ADAM - drajwer protokołu ADAM

1.1. Drajwer protokołu ADAM

Przeznaczenie drajwera

Drajwer ADAM jest wykorzystywany do wymiany danych z modułami ADAM serii 4000 firmy ADVANTECH. Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera (z użyciem konwertera) bądź przy zastosowaniu dodatkowej karty interfejsu RS485.

Jedynym wymaganiem ze strony systemu Asix jest to, aby moduły ADAM były ustawione w następujący tryb wymiany danych:

  • liczba bitów znaku 10 (1 bit startu, 8 bitów znaku, 1 bit stopu),

  • bez kontroli parzystości,

  • z użyciem sumy kontrolnej.

Parametryzacja drajwera ADAM realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu ADAM wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa - nazwa logiczna kanału transmisji

Drajwer - Adam

Zakładka Adam / Parametry kanału:

Sieciowy numer modułu ADAM,

Identyfikator typu modułu ADAM - aktualnie zaimplementowane są następujące typy:

1 - ADAM-4011

2 - ADAM-4012

3 - ADAM-4013

4 - ADAM-4017

5 - ADAM-4018

6 - 8-kanałowy licznik impulsów Mcom-1 (odpowiednik ADAM-4080D)

7 - ADAM-4050

8 - ADAM-4052

9 - ADAM-4060

10 - ADAM-4053

11 - ADAM-4080

12 - ADAM-4021

Port - nazwa portu szeregowego,

Prędkość transmisji w bodach.

Parametr Prędkość transmisji w bodach jest parametrem opcjonalnym. Wartością domyślną tego parametru jest 9600 (Bd).

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu ADAM:

Nazwa: CHAN1

Drajwer: ADAM

Sieciowy numer modułu ADAM: 1

Identyfikator typu modułu ADAM: 5

Prędkość transmisji w bodach: 9600 Bd

Adresacja zmiennych procesowych

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych procesowych należących do kanału ADAM:

TYP_ZMIENNEJ indeks_zmiennej[.nr_podkanału]

gdzie:

TYP_ZMIENNEJ - łańcuch identyfikujący typ zmiennej w protokole ADAM,

indeks_zmiennej - indeks zmiennej w ramach danego typu,

nr_podkanału - numer podkanału dla modułów wielokanałowych lub numer bitu dla modułów wejść/wyjść cyfrowych.

Dozwolone są następujące oznaczenia typów zmiennych procesowych:

R - zmienna tylko do odczytu,

W - zmienna tylko do zapisu,

RW - zmienna do odczytu i zapisu.

Zależnie od typu modułu ADAM dozwolone są różne zakresy indeksu_zmiennej i nr_podkanału. Aktualnie zaimplementowane zmienne procesowe przedstawiają poniższe tabele.

Tabela: Typy zaimplementowanych zmiennych procesowych obsługiwanych przez moduł ADAM.

Tabela: Typy zaimplementowanych zmiennych procesowych obsługiwanych przez moduł ADAM (c.d.).

Tabela: Typy zaimplementowanych zmiennych procesowych obsługiwanych przez moduł ADAM (c.d.).

Drajwer ADAM instalowany jest automatycznie jako DLL.

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera Adam, na zakładce Adam / Parametry drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Domyślna długość odpowiedzi

Znaczenie: Używanie domyślnej długości odpowiedzi.

TAK - oczekiwanie na maksymalną możliwą długość odpowiedzi lub timeout znakowy;

NIE - jeśli długość odpowiedzi jest znana - to zostanie użyta, aby nie czekać na time-out przy odpowiedzi. W przeciwnym razie używa się domyślnej długości odpowiedzi i czeka na timeout znakowy.

Wartość opcji:

TAK / NIE

Wartość domyślnie: NIE

R Suma kontrolna

Znaczenie: Pozwala zadeklarować używanie sumy kontrolnej w przesyłkach PC <--> ADAM.

Wartość opcji:

TAK / NIE

Wartość domyślnie: TAK

R Timeout odczytu

Znaczenie: Timeout oczekiwania na odpowiedz w milisekundach.

Wartość parametru:

liczba - czas wyrażony w milisekundach

Wartość domyślna: 1500

R Timeout znakowy

Znaczenie: Timeout pomiędzy znakami w milisekundach.

Wartość opcji:

liczba - czas wyrażony w milisekundach

Wartość domyślna: 50

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.

R Czas ważności danych

Znaczenie - opcja określa czas, przez który wartości zmiennych w kanale zachowują ważność; opcję należy użyć tylko wtedy, gdy czasowy brak danych nie powinien być traktowany jako błąd.

Wartość opcji:

liczba - czas podany w sekundach; należy podać wartość (znacznie) większą niż najdłuższy okres odświeżania zmiennej w kanale.

Wartość domyślna - domyślnie nie ma ustalonego czasu ważności danych.


Drajwer Aggregate

Home > 1.2 Aggregate

1.2. Drajwer Aggregate

Przeznaczenie drajwera

Drajwer Aggregate pozwala definiować zmienne, których wartości powstają w wyniku przeliczania wartości innych zmiennych systemu Asix (zmienne źródłowe). Do obliczania agregatu drajwer wykorzystuje wartości archiwalne zmiennych źródłowych. Wykorzystanie wartości archiwalnych pozwala uniknąć nieciągłości w przypadku restartu systemu Asix.

Parametryzacja drajwera Aggregate realizowana jest przy użyciu programu Architekt.

Deklaracja kanału

Deklaracja kanału transmisyjnego wykorzystującego drajwer Aggregate wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Aggregate

Deklaracja zmiennej

Część adresowa deklaracji zmiennej ma postać:

nazwa_aggregatu parametry_agregatu

gdzie:

nazwa_agregatu - nazwa agregatu;

parametry_agregatu - parametry agregatu oddzielone spacjami.

Drajwer realizuje agregaty opisane w tabeli poniżej.

Tabela: Typy agregatów realizowanych przez drajwer Aggregate.

Parametry powyższych agregatów mają postać:

Nazwa_zmiennej:Typ_archiwum Okres Stopa [A] [L[limit_dolny]:[limit_górny]]

gdzie:

Nazwa_zmiennej - nazwa zmiennej źródłowej, której dotyczy agregat;

Typ_archiwum - jednoliterowy kod typu archiwum, w którym zapamiętane są wartości zmiennej źródłowej;

Okres - okres obliczeniowy agregatu;

Stopa - minimalna ilość poprawnych pomiarów w procentach, wymagana do obliczenia agregatu;

A - parametr określa, czy czas dokonywania obliczeń ma być wyrównany w odniesieniu do okresu obliczeniowego;

Limit_dolny - dolna wartość graniczna; jeśli wartość zmiennej źródłowej jest mniejsza od wartości limit_dolny, to przyjmowana jest wartość limit_dolny; parametr można podawać od wersji 1.01.000 drajwera;

Limit_górny - górna wartość graniczna; jeśli wartość zmiennej źródłowej jest większa od wartości limit_górny, to przyjmowana jest wartość limit_górny. Parametr można podawać od wersji 1.01.000 drajwera.

Parametr Okres określa okres obliczeniowy. Okres obliczeniowy podawany jest w taki sam sposób jak specyfikacja odcinków czasu dla modułu ASPAD, tj. w postaci liczb oraz jednostek:

<liczba><jednostka> [<liczba><jednostka> [...]]

gdzie:

<liczba> - jest liczbą podanych po niej jednostek czasu,

<jednostka> - określa jednostkę czasu, którą może być:

s - sekunda,

m - minuta,

g lub h - godzina,

d - doba.

W przypadku braku jednostki zakłada się, że okres obliczeniowy wyrażony jest w minutach. Wynik obliczenia agregatu uznawany jest za poprawny, jeśli stopa procentowa poprawnie odczytanych próbek wynosi Stopa. Wartością domyślną parametru Okres jest 5 minut, a parametru Stopa 80 procent. Do obliczania stopy poprawnych pomiarów brany jest pod uwagę czas ważności wartości zmiennej źródłowej zgodnie z parametryzacją archiwizacji tej zmiennej (okres próbkowania). Tzn. stopa jest obliczana jako stosunek sumy wszystkich czasów ważności pomiarów do długości okresu obliczeniowego. W przypadku średniej, wynik obliczeń jest średnią ważoną względem czasu ważności pomiaru. Do obliczania agregatu brane są pod uwagę wartości zmiennych, których stemple czasu są większe lub równe początkowi okresu obliczeniowego i mniejsze od końca okresu obliczeniowego. Obliczenie agregatu następuje po zakończeniu okresu obliczeniowego.

Ostatni, opcjonalny parametr A określa moment, w którym obliczany jest agregat. Jeśli parametr ten jest pominięty, to agregat obliczany jest po każdorazowym zakończeniu odczytu zmiennej źródłowej (krocząco). Jeśli ostatnim parametrem jest A, to moment obliczenia agregatu jest wyrównany do wielokrotności okresu obliczania agregatu. Typ wyniku obliczeń agregatu jest dostosowywany do typu funkcji przeliczającej podanej w deklaracji zmiennej.

PRZYKŁAD

Przykład deklaracji zmiennej:

Temp_sr, Temp-średnia, SREDNIA Temperatura:B 10 70 A, Srednie, 1, 1, NIC_FP

W powyższej linii zadeklarowano zmienną o nazwie Temperatura_sr, która jest uśrednioną wartością zmiennej Temperatura. Okres uśredniania wynosi 10 minut, a do otrzymania poprawnej wartości uśrednionej potrzebnych jest 70 procent poprawnych pomiarów. Do uśredniania zostaną wykorzystane wartości archiwalne zmiennej Temperatura, znajdujące się w archiwum typu B. Moment wyliczenia agregatu zostanie wyrównany do wielokrotności okresu jego obliczania, tj. obliczanie nastąpi o 00:00:00, 00:10:00, 00:20:00, ... itd.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtAirPointer - drajwer do komunikacji ze stacją monitoringu

Home > 1.3 AirPointer - drajwer do komunikacji ze stacją monitoringu

1.3. AirPointer - drajwer do komunikacji ze stacją monitoringu powietrza 'AirPointer' firmy Recordum Messtechnik GmbH z Austrii

Przeznaczenie drajwera

Drajwer AirPointer służy do wymiany danych pomiędzy systemem ASIX i stacją monitoringu powietrza AirPointer firmy Recordum Messtechnik GmbH, Austria. Komunikacja odbywa się przy pomocy protokołu HTTP przy wykorzystaniu stron info.php i download.php serwera webowego stacji monitoringu.

Drajwer pozwala na odczyt aktualnych oraz historycznych wartości średnich 1, 5 i 30 minutowych każdego z parametrów mierzonych przez stacją monitoringu. Aktualna wartość średniej jest przekazywana przez drajwer jako wartość bieżąca zmiennej procesowej.

Parametryzacja drajwera AirPointer realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AirPointer wymaga dodania do

modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AirPointer

Zakładka AirPointer:

Parametry kanału:

serwerIp=adres_IP; haslo=tekst; uzytkownik=tekst; nrAlarmu=liczba

gdzie:

serwerIP - adres IP stacji monitoringu,

haslo - hasło dostępu do stron info.php i download.php stacji

monitoringu,

użytkownik - nazwa użytkownika stacji monitoringu,

nrAlarmu - numer alarmu w przypadku braku komunikacji ze stacją

monitoringu.

Przykład:

serwerIp=192.168.200.160; haslo=password123; uzytkownik=user; nrAlarmu=100

Deklaracja zmiennych

Adres zmiennej ma następującą postać:

P<paramId>.<avgNr>

gdzie:

avgNr - liczba identyfikująca typ wartości średniej. Dopuszczalne wartości to:

1 - średnia 1-minutowa

2 - średnia 5-minutowa

3 - średnia 30-minutowa

paramId - liczba będąca identyfikatorem parametru rejestrowanego przez stację.

Zestawienie dopuszczalnych parametrów jest dostępne poprzez stronę

info.php

Wszystkie zmienne są typu FLOAT.

Przykładowe deklaracje zmiennych:

ZM_01_01, NO średnia 1 min, P1.1 PTY, 1, 1, NIC_FP

ZM_01_02, NO średnia 5 min, P1.2 PTY, 1, 1, NIC_FP

ZM_01_03, NO średnia 30 min, P1.3 PTY, 1, 1, NIC_FP

ZM_06_01, SO2 średnia 1 min, P6.1 PTY, 1, 1, NIC_FP

ZM_06_02, SO2 średnia 5 min, P6.2 PTY, 1, 1, NIC_FP

ZM_06_03, SO2 średnia 30 min, P6.3 PTY, 1, 1, NIC_FP

Parametryzacja drajwera

Parametry drajwera AirPointer deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany przy użyciu osobnej sekcji [CTAIRPOINTER]. W sekcji można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • tworzenie pliku logu danych historycznych,

  • rozmiar pliku logu,

  • log danych przesłanych ze stacji,

  • horyzont pozyskiwania danych historycznych,

  • timeout ponownego zapytania o dane historyczne,

  • log danych historycznych przekazywanych do Aspada.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: PLIK_LOGU_HISTORII

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu danych historycznych, do którego są wpisywane komunikaty dotyczące odczytu danych historycznych ze stacji monitoringu.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu danych historycznych nie jest tworzony.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU oraz PLIK_LOGU_HISTORII.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) danych przesyłanych ze stacji monitoringu. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: LOG_TELEGRAMOW_HISTORII

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU_HISTORII) danych przesyłanych ze stacji monitoringu. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: HORYZONT_HISTORII

R Wartość opcji: liczba

Znaczenie: Pozycja określa jak daleko wstecz w archiwach stacji monitoringu będzie sięgać drajwer przy odczycie danych historycznych.

Wartość opcji:

liczba - wartość czasu wyrażona w dniach.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 20 (dni).

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: TIMEOUT_PONOWNEGO_ZAPYTANIA_O_DANE_HISTORYCZNE

R Wartość opcji: liczba

Znaczenie: Pozycja określa, jaka wartość zostanie zwrócona do Aspada jako timeout ponownego zapytania o dane aktualnie niedostępne.

Wartość opcji:

liczba - wartość czasu wyrażona w minutach.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 5 (minut).

R Nazwa sekcji: CTAIRPOINTER

R Nazwa opcji: LOG_DANYCH_HISTORYCZNYCH_ASPADA

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU_HISTORII) danych historycznych przesyłanych do Aspada. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtAK - drajwer protokołu CtAK dla analizatorów MLT2 f-my

Home > 1.4 AK - drajwer protokołu CtAK dla analizatorów MLT2 f-my

1.4. AK - drajwer protokołu AK dla analizatorów MLT2 f-my Emerson

Przeznaczenie drajwera

Drajwer protokołu AK służy do wymiany danych pomiędzy systemem Asix i analizatorami MLT2 f-my Emerson. Komunikacja jest realizowana przy pomocy łączy szeregowych w standardzie RS-485.

Drajwer pozwala wyłącznie na odczyt danych dostępnych przez komendy typu READ z wyłączeniem komend przeznaczonych dla celów serwisowych oraz komend, których atrybut ma typ CODE.

Parametryzacja drajwera AK realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AK wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AK

Zakładka AK:

Parametry kanału:

Port=liczba [;Predkosc=liczba] [;TimeoutOdbioru] [;TimeoutZnaku]

gdzie:

Port - numer portu szeregowego COM;

Predkosc - prędkość transmisji między komputerem a urządzeniem; dopuszczalne są następujące prędkości: 300, 600,1200,2400, 4800, 9600, 19200 Bd; domyślna wartość wynosi 19200 Bd;

TimeoutOdbioru - timeout (w milisekundach) pomiędzy wysłaniem ostatniego znaku zapytania i odbiorem pierwszego znaku odpowiedzi; domyślna wartość wynosi 200 milisekund;

TimeoutZnaku - timeout (w milisekundach) pomiędzy kolejnymi znakami odpowiedzi; domyślna wartość wynosi 30 milisekund,

UWAGA Parametry podane w deklaracji kanału muszą być zgodne z parametrami ustawionymi dla portów komunikacyjnych sterowników obsługiwanych przez ten kanał.

PRZYKŁAD

Przykład deklaracji kanału o standardowych timeout’ach na porcie COM2:

Nazwa: KANAL

Drajwer: CtAK

Parametry kanału: Port=2

Adresacja zmiennych procesowych

Adres zmiennej ma składnię:

<Typ>.<nrAnal>.<nrKan>[.nrRange].<Index>

gdzie:

Typ - typ zmiennej - jako Typ używana jest nazwa komendy (CODE) użytej przez protokół do odczytu poszczególnych kategorii zmiennych z analizatora;

nrAnal - numer analizatora;

nrKan - numer kanału analizatora;

nrRange - numer Range danego kanału (o ile jest używany przy adresacji zmiennej - patrz: zestawienie komend, s.20);

Index - interpretacja jest specyficzna dla Typu i oznacza:

a/ numer elementu w ramach Range (o ile Range jest używany przy adresacji zmiennej - patrz: zestawienie komend, s.20),

b/ numer elementu w ramach tablicy danych zwracanej przez komendę (o ile komenda zwraca tablicę danych). W szczególnym przypadku rozmiar tablicy może wynosić 1.

/* koncentracja: analizator nr 1, kanał 2, index 1

JJ_01, koncentracja ,AIKO.1.2.1, KANAL, 1, 1, NIC_FP

/* ciśnienie: analizator nr 1, kanał 3, index 1

JJ_02, ciśnienie, ADRU.1.3.1, KANAL, 1, 1, NIC_FP

Stan wejść/wyjść oraz status kalibracji

Drajwer umożliwia odczyt stanu wejść/wyjść z kart DIO przy pomocy rozkazu serwisowego "ASVC Kn S615 b". Do odczytu stanu wejść/wyjść należy użyć następującego adresu symbolicznego zmiennej:

ASVC.<nrAnal>.<nrKan><nrDIO>.<Index>

gdzie:

nrAnal - numer analizatora,

nrKan - numer kanału analizatora,

nrDIO - numer karty DIO, poprzez którą jest przekazywany status kalibracji,

Index - offset w tablicy danych odczytanych z karty DIO. Dopuszczalne wartości to:

1 - stany 8-miu wejść I1 ... I8 (I1 - najmłodszy bit)

2 - stany 8-miu wyjść O1 ... O8 (O1 - najmłodszy bit)

3 - stany 8-miu wyjść O9 ... O16 (O9 - najmłodszy bit)

4 - stany 8-miu wyjść O17 ... O24 (O17 - najmłodszy bit)

Stan wyjścia O24 zawiera aktualny status kalibracji.

PRZYKŁAD

Przykłady deklaracji do odczytu stanu wejść/wyjść:

# analizator nr 1, kanał 2, DIO nr 3, stan wejść I1 ... I8

JJ_01, stan I1...8, ASVC.1.2.3.1, PT3, 1, 1, NIC

# analizator nr 3, kanał 1, DIO 4, stan wyjść O1 ... O24

JJ_02, stan O1...24, ASVC.3.1.4.2, PT3, 1, 1, NIC_DW

Stan transmisji z analizatorem

Drajwer przechowuje informacje o statusie wykonania ostatniej transmisji oraz o wartości pola 'Error Code', przekazanego z analizatora podczas ostatniej transmisji (o ile transmisja zakończyła się prawidłowo). Do odczytu tych informacji służą zastępujące adresy symboliczne:

IERR.<nrAnal>.<nrKan>

ICOM.<nrAnal>

gdzie:

nrAnal - numer analizatora,

nrKan - numer kanału analizatora

IERR zwraca wartość pola 'Error Code' ostatniego seansu transmisji w określonym kanale analizatora.

ICOM zwraca status ostatniego seansu transmisji z określonym analizatorem (0 - poprawny, 1 - błąd transmisji).

Parametry drajwera

Parametry drajwera AK deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany jest w osobnej sekcji CTAK.

R Nazwa sekcji: CtAK

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie - do celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

R Nazwa sekcji: CtAK

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU;

Wartość opcji: liczba - rozmiar pliku w MB

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtAK

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - NIE.

PRZYKŁAD

Przykładowe parametry drajwera:

Nazwa sekcji: CtAK

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\ctAk\ak.log

Nazwa sekcji: CtAK

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 3

Nazwa sekcji: CtAK

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Zestawienie komend

Poniżej podano zaimplementowane typy danych (komendy protokołu AK) oraz parametry użyte przy adresacji zmiennych należących do poszczególnych typów.

Tabela. Zestawienie zaimplementowanych komend protokołu AK dla drajwera AK.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


AM_SA85 – drajwer protokołu MODBUS PLUS dla karty

Home > 1.5 AM_SA85 – drajwer protokołu MODBUS PLUS dla karty AM-SA85-000

1.5. AM_SA85 - drajwer protokołu MODBUS PLUS dla karty AM-SA85-000

Przeznaczenie drajwera

Drajwer AM_SA85 jest wykorzystywany do wymiany danych pomiędzy siecią Modbus Plus firmy Schneider Automation oraz komputerem systemu Asix, wyposażonym w kartę AM-SA85-000 firmy Schneider Automation.

Parametryzacja drajwera AM_SA85 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AM_SA85 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AM_SA85

Zakładka AM_SA85 / Parametry kanału:

Adres w sieci Modbus Plus - adres w sieci Modbus Plus w postaci łańcucha ASCII o formacie R1.R2.R3.R4.R5, gdzie R1 ... R5 reprezentują kolejne poziomy rutowania do rzedmiotowego urządzenia w sieci;

Adapter - numer adaptera;

Maksymalna liczba wielkości dyskretnych odczytywanych w pojedynczym telegramie;

Maksymalna liczba rejestrów odczytywanych w pojedynczym telegramie.

Domyślnie przyjmuje się:

adapter - 0,

dyskretne - 120,

rejestry - 120.

Przykład

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu AM_SA85:

Nazwa: KANAL

Drajwer: AM_SA85

Adres w sieci Modbus Plus: 10.0.0.0.0

Drajwer AM_SA85 jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego jest zgodna z adresacją używaną w protokole MODBUS.

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera AM_SA85, na zakładce AM_SA85.

R Plik logu

Znaczenie: - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera AM_SA85 oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość opcji: nazwa pliku logu

Wartość domyślna: domyślnie nie tworzy się pliku logu.

PRZYKLAD

Plik logu: D:\ASIX\AM_SA85.LOG

R Rozmiar pliku logu

Znaczenie: pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku w MB

Wartość domyślna: domyślnie opcja przyjmuje wartość 1 MB.

R Log telegramów

Znaczenie: pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w trakcie wymiany danych pomiędzy systemem Asix i sterownikami sieci Modbus Plus. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość opcji: TAK / NIE

Wartość domyślna: domyślnie do pliku logu nie zapisuje się zawartości telegramów.

R Timeout wysłania

Znaczenie: pozwala określić czas oczekiwania na zakończenie operacji wysłania zapytania do sterownika.

Wartość opcji:

liczba - czas oczekiwania podawany jako wielokrotność 0.5 sekundy

Wartość domyślna: domyślnie opcja przyjmuje wartość 10 (5 sekund).

R Timeout odpowiedzi

Znaczenie: pozwala określić czas oczekiwania na odpowiedź ze sterownika.

Wartość opcji:

liczba - czas oczekiwania podawany jako wielokrotność 0.5 sekundy

Wartość domyślna: domyślnie opcja przyjmuje wartość 10 (5 sekund).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


AREVA - drajwer do komunikacji z urządzeniami MiCOM

Home > 1.6 AREVA - drajwer do komunikacji z urządzeniami MiCOM

1.6. AREVA - drajwer do komunikacji z urządzeniami MiCOM

Przeznaczenie drajwera

Drajwer AREVA jest rozszerzeniem drajwera MODBUS o generację alarmów w reakcji na zdarzenia zachodzące w urządzeniu. Niniejszy rozdział opisuje jedynie te rozszerzenia. Pozostałe informacje znajdują się w opisie drajwera MODBUS.

Parametryzacja drajwera AREVA realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AREVA wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AREVA

Zakładka Areva:

Parametry kanału:

adres,seria, port[,body,znak,parzystosc,stop, max_we/wy,max_rejestr]

gdzie:

adres - adres urządzenia w sieci MODBUS,

seria - numer serii urządzenia: 2 lub 4,

port - nazwa portu szeregowego (max ilość obsługiwanych portów: 32),

body - prędkość transmisji w bodach. Max prędkość transmisji wynosi 115 kBd,

znak - liczba bitów w transmitowanym znaku,

parzystość - typ kontroli parzystości (even, odd, none),

stop - liczba bitów stopu,

max_we/wy - maksymalna liczba wejść/wyjść, których stan może być przekazany przez urządzenie w ramach jednego cyklu (max 127*16 stanów we/wy),

max_rejestr - maksymalna liczba rejestrów, których stan może być przekazany przez urządzenie w ramach jednego cyklu (max 127 rejestrów)

Parametry body, znak, parzystość, stop, max_we/wy, max_rejestr są parametrami opcjonalnymi.

Deklaracja zmiennych procesowych

Deklaracja zmiennych jest taka sama jak w drajwerze MODBUS.

Parametry drajwera

Paramerty drajwera AREVA deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametry drajwera można umieszczać w sekcji o nazwie 'AREVA’ oraz w sekcjach o nazwach takich samych jak nazwa kanału. W sekcji 'AREVA’ umieszcza się parametry globalne, dotyczące wszystkich urządzeń. W pozostałych sekcjach umieszcza się parametry dotyczące poszczególnych urządzeń. Niektóre parametry mogą występować jedynie w sekcji 'AREVA’ inne mogą występować we wszystkich sekcjach.

PRZYKŁAD

AREVA1= AREVA, 10, 4,COM1,57600,8,none,1,32,64

AREVA2= AREVA, 10, 4, COM2,57600,8,none,1,32,64

AREVA3= AREVA, 10, 4, COM2,57600,8,none,1,32,64

R Nazwa sekcji: AREVA

R Nazwa opcji: Alarmy_globalne

R Wartość opcji: TAK

R Nazwa sekcji: AREVA

R Nazwa opcji: Timeout_odbioru

R Wartość opcji: 500

R Nazwa sekcji: AREVA1

R Nazwa opcji: Timeout_odbioru

R Wartość opcji: 1000

Parametr Alarmy_globalne dotyczy wszystkich urządzeń. Ponieważ nie przewidziano indywidualnej parametryzacji urządzeń w tym zakresie, to może on występować jedynie w sekcji 'AREVA’. Parametr Timeout_odbioru umieszczony w sekcji 'AREVA’ określa 500 milisekundowy timeout dla wszystkich urządzeń z wyjątkiem urządzenia kanału o nazwie 'AREVA1’, ponieważ w sekcji 'AREVA1’ określono, że w przypadku tego urządzenia timeout wynosi 1 sekunda.

Poniżej opisano parametry drajwera AREVA. Jeśli w opisie parametru znajduje się zapis "parametr globalny” to oznacza to, że ten parametr może wystąpić tylko w sekcji 'AREVA’.

R Nazwa sekcji: AREVA

R Nazwa opcji: Alarmy_globalne

R Wartość opcji: TAK/NIE

Znaczenie: pozycja steruje sposobem przekazywania alarmów odczytanych z urządzeń zdalnych do systemu alarmów systemu Asix; parametr globalny

Wartość domyślna: domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości pozycji Alarmy_globalne na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili()

R Nazwa sekcji: AREVA

R Nazwa opcji: Okres_sprawdzania_zdarzen

R Wartość opcji: liczba

Znaczenie: okres czasu w sekundach pomiędzy sprawdzeniem stanu zdarzeń i generacji alarmów w dwóch kolejnych urządzeniach przyłączonych do tego samego portu szeregowego; parametr globalny

Wartość domyślna: 10

R Nazwa sekcji: AREVA

R Nazwa opcji: Numer_pola

R Wartość opcji: numer_pola

Znaczenie: parametr określa numer pola dla danego urządzenia. Jest on przekazywany jako parametr alarmu;

Wartość domyślna: -1

R Nazwa sekcji: AREVA

R Nazwa opcji: Plik_logu

R Wartość opcji: nazwa_pliku

Znaczenie: pozycja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera AREVA oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer AREVA. Jeśli pozycja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix; parametr globalny

Wartość domyślna: domyślnie nie tworzy się pliku logu

R Nazwa sekcji: AREVA

R Nazwa opcji: Zwloka_transmisji

R Wartość opcji: liczba

Znaczenie: pozycja pozwala określić odstęp czasu (jako wielokrotność 10 msek) pomiędzy kolejnymi operacjami na magistrali komunikacyjnej; parametr globalny

Wartość domyślna: domyślnie pozycja przyjmuje wartość 1 (10 msek)

R Nazwa sekcji: AREVA

R Nazwa opcji: Liczba_powtorzen

R Wartość opcji: liczba

Znaczenie: pozycja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji; parametr globalny

Wartość domyślna: 3

R Nazwa sekcji: AREVA

R Nazwa opcji: Timeout_odbioru

R Wartość opcji: liczba

Znaczenie: określa maksymalny czas oczekiwania w milisekundach na odpowiedź urządzenia

Wartość domyślna: 1000

R Nazwa sekcji: AREVA

R Nazwa opcji: Alarmy_Areva2 / Alarmy_Areva4

R Wartość opcji: tak/nie

Znaczenie: jeśli parametr ma wartość tak to włączona jest obsługa alarmów danej serii urządzeń; parametr globalny

Wartość domyślna: tak

R Nazwa sekcji: AREVA

R Nazwa opcji: Pierwszy_alarm2 / Pierwszy_alarm4

R Wartość opcji: liczba

Znaczenie: określa liczbę jaka zostanie dodana do numeru alarmu w urządzeniu aby otrzymać numer alarmu w systemie Asix; parametr globalny

Wartość domyślna: 500 dla serii 2; 5000 dla serii 4

R Nazwa sekcji: AREVA

R Nazwa opcji: Pierwszy_alarm

R Wartość opcji: liczba

Znaczenie: parametr pozwala określić numerację alarmów indywidualnie dla każdego urządzenia

Wartość domyślna: 500 dla serii 2; 5000 dla serii 4

R Nazwa sekcji: AREVA

R Nazwa opcji: Numer_pola

R Wartość opcji: numer_pola

Znaczenie: parametr określa numer pola dla danego urządzenia. Jest on przekazywany jako parametr alarmu

Wartość domyślna: -1

Numeracja alarmów

Seria 2:

Przeliczanie numeru zdarzenia na numer alarmu:

Nr_alarmu_asixa = numer_zdarzenia*16 + numer_bitu + pierwszy_alarm

Bity liczone są poczynając od 0.

Numeracja zdarzeń i znaczenie poszczególnych bitów opisane jest w dokumentacji urządzenia

Seria 4:

Numeracja opiera się na dokumentacji P34x_EN_GC_H54.pdf "MiCOM P342, P343, P344. Generator Protection Relays. Software Version 0320. Hardware Suffix J” - tabela na stronie 117 "Event Record Specification for Courier and MODBUS Interfaces”.

Zakres Znaczenie

0 - 199 Zdarzenia ogólne (general events). Lista jest na końcu tabeli w dokumentacji.

200 - 231 Relay contact events, Jest to numer bitu liczony od 0.

300 - 331 Opto-isolated input events. Jest to numer bitu liczony od 0.

400 - 491 Latched alarms. Numer alarmu można odczytać z kolumny "Event index 3x10011”.

Znajduje się tam text:

"Bit 15=state, bits 0-14=nn

"nn” to numer alarmu.

500 - 595 Self reset alarms. Numeracja jak wyżej

1000 - 2599 Protection events. Jest to numer bitu liczony od 0.

Parametry alarmów

Parametry alarmów:

1. numer pola

2. słowo 16-bitowe związane ze zdarzeniem i przekazywane przez urządzenie

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


AS511 - drajwer protokołu AS511 dla SIMATIC

Home > 1.7 AS511 - drajwer protokołu AS511 dla SIMATIC

1.7. AS511 - drajwer protokołu AS511 dla SIMATIC

Przeznaczenie drajwera

Drajwer AS511 wykorzystywany jest do wymiany danych ze sterownikami SIMATIC poprzez interfejs programatora. Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix zaopatrzonych w konwerter RS232C - pętla prądowa 20 mA. Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu AS511 nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych z systemem Asix.

Drajwer AS511 systemu Asix może być użyty przy wymianie danych z następującymi typami sterowników: S5-90U, S5-95U, S5-100U, S5-115U, S5-135U.

Parametryzacja drajwera AS511 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AS511 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AS511

Zakładka AS511:

Parametry kanału:

port,[body,znak,parzystość,stop]

gdzie:

port - nazwa portu szeregowego,

body - prędkość transmisji w bodach; prędkość transmisji musi wynosić 9600 bodów,

znak - liczba bitów w transmitowanym znaku,

parzystość - typ kontroli parzystości (even,odd,none).

Parametry body, znak, parzystość, stop i bufor są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola parzystości,

  • liczba bitów stopu - 2.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu AS511:

Nazwa: CHAN1

Drajwert: AS511

Port: COM1

Adresacja zmiennych procesowych

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych należących do kanału AS511:

typ_zmiennej[numer_db.]indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w sterowniku;

numer_db - opcjonalny numer bloku danych; używany jedynie w przypadku zmiennych procesowych będących odwzorowaniem zawartości słów w blokach danych;

indeks_zmiennej - indeks zmiennej w ramach danego typu; w przypadku bloków danych jest to numer słowa w bloku danych.

Dozwolone są następujące oznaczenia typów zmiennych procesowych:

EA - stany wyjść przekazywane w bajtach,

EAW - stany wyjść przekazywane w słowach,

EE - stany wejść przekazywane w bajtach,

EEW - stany wejść przekazywane w słowach,

EM - stany znaczników (flag) przekazywane w bajtach,

EMW - stany znaczników (flag) przekazywane w słowach,

EZ - stany liczników przekazywane w słowach,

ET - stany zegarów przekazywane w słowach,

ED - wartości słów w blokach danych,

EL - wartości podwójnych słów w blokach danych,

EG - wartości podwójnych słów w blokach danych, traktowane jako liczba zmiennoprzecinkowa w formacie KG,

Przykłady

ED10.22 - słowo numer 22 w bloku danych o numerze 10.

EL20.32 - podwójne słowo umieszczone w słowach 32 i 33 w bloku danych o numerze 20.

EZ50 - licznik numer 100.

Parametry drajwera

Paramerty drajwera AS511 deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

UWAGA Drajwer AS511 wersji od 1.24 pozwala odczytywać słowa danych znajdujące się w blokach danych poprzez odczyt całego bloku zamiast określonego miejsca w pamięci, jak to miało miejsce w poprzedniej wersji. Pozwala to na odczyt ze sterownika 115F. Odczyt całego bloku uzyskuje się poprzez umieszczenie parametru ’blok’ w pliku konfiguracyjnym aplikacji w sekcji AS511.

R Nazwa sekcji: AS511

R Nazwa opcji: BLOK

R Wartość opcji: TAK/NIE

Znaczenie: powoduje odczyt całego bloku danych.

Wartość domyślna: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


AS512 - drajwer protokołu AS512 dla SIMATIC S5

Home > 1.8 AS512 - drajwer protokołu AS512 dla SIMATIC S5

1.8. AS512 - drajwer protokołu AS512 dla SIMATIC S5

Przeznaczenie drajwera

Protokół AS512 wykorzystywany jest do wymiany danych ze sterownikami SIMATIC wyposażonymi w procesor komunikacyjny CP524/CP525. Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych lub dodatkowych portów szeregowych komputera.

Oprogramowanie sterownika musi być odpowiednio przygotowane do współpracy z systemem Asix, to znaczy:

  • program w CPU sterownika musi zawierać wywołania bloków funkcyjnych realizujących odbiór i nadawanie telegramów poprzez procesor komunikacyjny CP524/CP525 (SEND_ALL, RECV_ALL). Liczba wywołań tych bloków w ramach cyklu pracy sterownika określa liczbę telegramów, jaka może być w trakcie trwania cyklu przesłana pomiędzy komputerem i sterownikiem !

  • Oprogramowanie procesora komunikacyjnego musi używać procedury 3964R, a prędkość transmisji musi być zgodna z prędkością deklarowaną w kanale transmisji programu ASMEN.

Parametryzacja drajwera AS512 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AS512 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AS512

Zakładka AS512:

Parametry kanału:

port, [,body,znak,parzystość,stop,cpu]

gdzie:

port - nazwa portu szeregowego;

body - prędkość transmisji w bodach; prędkość transmisji nie może przekroczyć 38400 bodów;

znak - liczba bitów w transmitowanym znaku;

parzystość - typ kontroli parzystości (even,odd,none);

stop - liczba bitów stopu;

cpu - numer CPU w sterowniku, którego dotyczy realizowana operacja.

Parametry body, znak, parzystość, stop, cpu i bufor są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola parzystości,

  • liczba bitów stopu - 1,

  • numer CPU - 0.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycie kanału transmisji pracującego według protokołu AS512:

Nazwa: CHAN1

Drajwer: AS512

Parametry kanału: COM1,4800,8,even,1,2

Adresacja zmiennych procesowych

Podczas definicji zmiennej procesowej podawany jest jej adres symboliczny. Służy on do jednoznacznego określenia zmiennej w sterowniku, której wartość zostanie przypisana zmiennej procesowej w systemie Asix. Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych należących do kanału AS512.

typ_zmiennej[numer_db.]indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w sterowniku;

numer_db - opcjonalny numer bloku danych; używany jedynie w przypadku zmiennych procesowych będących odwzorowaniem zawartości słów w blokach danych;

indeks_zmiennej - indeks zmiennej w ramach danego typu; w przypadku bloków danych jest to numer słowa w bloku danych.

Dozwolone są następujące oznaczenia typów zmiennych procesowych (wzorowane na nazewnictwie typów zmiennych używanych przez firmę SIEMENS):

EA - stany wyjść przekazywane w bajtach,

EE - stany wejść przekazywane w bajtach,

EM - stany znaczników (flag) przekazywane w bajtach,

EZ - stany liczników przekazywane w słowach,

ET - stany zegarów przekazywane w słowach,

ED - wartości słów w blokach danych,

EL - wartości podwójnych słów w blokach danych,

EG - wartości podwójnych słów w blokach danych, traktowane jako liczba w formacie zmiennoprzecinkowym KG.

Przykłady

ED10.22 - słowo numer 22 w bloku danych numer 10

EZ100 - licznik numer 100

Drajwer AS512 jest ładowany automatycznie jako DLL.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


AS512 - drajwer protokołu AS512 dla SIMATIC

Home > 1.9 AS512S7 - drajwer protokołu AS512 dla SIMATIC S7

1.9. AS512 - drajwer protokołu AS512 dla SIMATIC S7

Przeznaczenie drajwera

Protokół AS512S7 wykorzystywany jest do wymiany danych ze sterownikami SIMATIC S7 wyposażonymi w procesor komunikacyjny CP340. Transmisja jest realizowana łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera według protokołu AS512.

Firma ASKOM oferuje oprogramowanie dla sterownika SIMATIC S7 pozwalające na wymianę danych z systemem Asix według protokołu AS512.

Parametryzacja drajwera AS512S7 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer AS512S7 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: AS512S7

Zakładka AS512S7:

Parametry kanału:

port,[,body,znak,parzystość,stop,cpu]

gdzie:

port - nazwa portu szeregowego;

body - prędkość transmisji w bodach; prędkość transmisji nie może przekroczyć 9600 bodów;

znak - liczba bitów w transmitowanym znaku;

parzystość - typ kontroli parzystości (even,odd,none);

stop - liczba bitów stopu;

cpu - numer CPU w sterowniku, którego dotyczy realizowana operacja.

Parametry body, znak, parzystość, stop, cpu są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola parzystości,

  • liczba bitów stopu - 1,

  • numer CPU - 0.

PRZYKŁAD

Poniżej podana jest przykładowa opcja deklarująca użycie kanału transmisji pracującego według protokołu AS512S7:

Kanał: CHAN1

Drajwer: AS512S7

Parametry kanału: COM1,4800,8,even,1,2

Podczas definicji zmiennej procesowej podawany jest jej adres symboliczny. Służy on do jednoznacznego określenia zmiennej w sterowniku, której wartość zostanie przypisana zmiennej procesowej w systemie Asix.

Adresacja zmiennych

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych należących do kanału AS512S7

typ_zmiennej[numer_db.]indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w sterowniku;

numer_db - opcjonalny numer bloku danych; używany jedynie w przypadku zmiennych procesowych będących odwzorowaniem zawartości słów w blokach danych;

indeks_zmiennej - indeks zmiennej w ramach danego typu; w przypadku bloków danych jest to numer słowa w bloku danych.

W protokole AS512S7 zaimplementowano wyłącznie dostęp do słów w blokach danych. Z tego powodu dozwolony jest jeden typ zmiennych procesowych oznaczony:

ED - wartości słów w blokach danych.

Przykład

ED10.22 - słowo numer 22 w bloku danych numer 10

Drajwer AS512S7 jest ładowany automatycznie jako DLL.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


BACnetIP

Home > 1.10 BACnetIP - drajwer protokołu BACnet/ IP

1.10 BACnetIP - drajwer urządzeń realizujących protokół BACnet/IP

Przeznaczenie drajwera

Drajwer BACnetIP służy do wymiany danych pomiędzy systemem ASIX i urządzeniami realizującymi protokół BACnet/ IP.

Drajwer pozwala na odczyt (i ew. zapis) właściwości poniższych obiektów standardu BACnet:

AI - analog input object,

AO - analog output object,

AV - analog value object,

AVG - averaging object,

BI - binary input object,

BO - binary output object,

BV - binary value object,

CAL - calendar object,

DEV - device object,

LP - life-safety point object,

LZ - life-safety zone object,

MI - multi-state input object,

MO - multi-state output object,

MV - multi-state value object,

SCH - schedule object.

oraz na sygnalizację zdarzeń przekazywanych z urządzeń przy pomocy telegramów typu ConfirmedEventNotification oraz UnconfirmedEventNotification.

Drajwer został opracowany wg normy ISO 16484-5:2003.

Parametryzacja drajwera CtBACnetIP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer BACnetIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: BACnetIP

Zakładka CtBACnetIP/Parametry kanału:

Adres IP komputera - adres IP karty komputera z Asixem,

Adres IP urządzenia - adres IP urządzenia,

Identyfikator urządzenia - identyfikator urządzenia (’DeviceId’),

Plik definicji zdarzeń - nazwa pliku z definicjami zdarzeń,

Offset alarmów - offset dodawany do numeru każdego alarmu zdefiniowanego dla urządzenia w pliku definicji zdarzeń,

Priorytet zapisu - priorytet, z jakim są wykonywane sterowania obiektami typu 'commandable' (AO, BO, MO, AV, BV, MV). Dopuszczalny zakres parametru to 1 - 16. Domyślnie 16 (najniższy priorytet),

Port - port w PC, przez który jest realizowane połączenie ze sterownikiem. Domyślnie 0, tzn. port jest dostarczany przez system Windows,

Numer alarmu - numer alarmu zgłaszanego do systemu alarmów w przypadku braku komunikacji w kanale,

Plik logu - nazwa pliku logu; jeśli nie podano - komunikaty będą zapisywane do logu drajwera,

Rozmiar pliku logu - rozmiar pliku logu w MB,

Log telegramów - zapisywanie telegramów do pliku logu.

PRZYKLAD

Poniżej podano przykład deklaracji kanału KANAL, w którym jest obsługiwany sterownik, którego DeviceId jest ustawiony na 348380. Komunikacja odbywa się poprzez kartę sieciową o adresie 10.10.105.1, adres IP sterownika to 10.10.105.212, definicje zdarzeń generowanych przez sterownik są umieszczone w pliku Dev348380.def, do każdego alarmu zgłaszanego do systemu ASIX jest dodawany offset 100.

Nazwa: KANAL

Adres IP komputera: 10.10.105.1

Adres IP urządzenia: 10.10.105.212

Identyfikator urządzenia: 348380

Plik definicji zdarzeń: Dev348380.def

Offset alarmów: 100

Priorytet zapisu: 14

Deklaracja zmiennych procesowych

Drajwer obsługuje wyłącznie poniższe obiekty standardu BACnet:

AI - analog input object,

AO - analog output object,

AV - analog value object,

AVG - averaging object,

BI - binary input object,

BO - binary output object,

BV - binary value object,

CAL - calendar object,

DEV - device object,

LP - life-safety point object,

LZ - life-safety zone object,

MI - multi-state input object,

MO - multi-state output object,

MV - multi-state value object,

SCH - schedule object.

Adres zmiennej ma składnię:

objectType.instance[.property[.item]]

gdzie:

objectType - nazwa obiektu BACnet (z listy powyżej)

instance - numer instancji obiektu

property - identyfikator właściwości obiektu

item - element właściwości obiektu, jeśli właściwość obiektu jest tablicą (np. element właściwości

’date-;list’ kalendarza),

Dla obiektu SCHEDULE składnia jest następująca:

objectType.instance.property.dayNr.item.[VAL | TM]

gdzie:

dayNr - numer dnia tygodnia (poniedziałek 0, niedziela 7),

item - element tablicy danego dnia (indeksowany od 0),

VAL - wartość parametru ’value’ elementu ’item’,

TM - wartość parametru ’time’ elementu ’item.

PRZYKŁAD

Przykłady deklaracji zmiennych:

Nazwa: X01

Opis: device_max_apdu_length

Adres: DEV.62

Kanał: KAN

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: X02

Opis: analog-value_1_present_value

Adres: AV.1.85

Kanał: KAN

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: X03

Opis: analog-value_1_object_name

Adres: AV.1.77

Kanał: KAN

Liczba elementów: 50

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Nazwa: X04

Opis: binary-value_1_present_value

Adres: BV.1.85

Kanał: KAN

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: X05

Opis: device_local_time

Adres: DEV.57

Kanał: KAN

Liczba elementów: 20

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Nazwa: X06

Opis: device_local_date

Adres: DEV.56

Kanał: KAN

Liczba elementów: 20

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Nazwa: X07

Opis: item nr 6 of calendar_5

Adres: CAL.5.23.6

Kanał: KAN

Liczba elementów: 30

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Nazwa: Y20

Opis: ’value’ elem. 4 środa SCH nr 1

Adres: SCH.1.123.2.4.VAL

Kanał: KAN

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_BYTE

Nazwa: Y21

Opis: ’time’ elem. 3 wtorek SCH nr 2

Adres: SCH.2.123.1.3.TM

Kanał: KAN

Liczba elementów: 30

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Wartości zmiennych obiektu kalendarz (CALENDAR)

Wartości zmiennych obiektu kalendarz są zawsze wyrażone za pomocą łańcuchów ASCII i przyjmują jeden z poniższych formatów:

yyyy-mm-dd (data)

yyyy-mm-dd - yyyy-mm-dd (zakres dat)

D.W.M (dzień, tydzień, miesiąc)

gdzie:

yyyy - numer roku

mm - numer miesiąca

dd - numer dnia miesiąca

D - numer dnia tygodnia:

1 - poniedziałek

...

7 - niedziela

* - każdy dzień tygodnia

W - numer tygodnia w miesiącu:

1 - dni 1 do 7

2 - dni 8 do 14

3 - dni 15 do 21

4 - dni 22 do 28

5 - dni 29 do 31

6 - ostatnie 6 dni miesiąca

* - każdy tydzień miesiąca

M - numer miesiąca:

1 - styczeń

...

12 - grudzień

* - każdy miesiąc

Uwaga:

Przy zapisie dopuszcza się, aby wartość sterująca była pustym łańcuchem ASCII - taka wartość sterująca oznacza żądanie usunięcia danego elementu z kalendarza. Jeśli usuwany element kalendarza nie jest ostatnim elementem kalendarza, to następujące po nim elementy zostaną przesunięte o jedną pozycję do przodu (obiekt CALENDAR nie zezwala na zapis niezdefiniowanych elementów).

Wartości zmiennych obiektu harmonogram (SCHEDULE)

Wartości zmiennych obiektu harmonogram zależą do typu parametru harmonogramu.

Dla parametru 'time' są wyrażone za pomocą łańcucha ASCII o poniższym formacie:

hh:mm:ss.zz

gdzie:

hh - godzina

mm - minuta

ss - sekunda

zz - setne sekundy

Dla parametru 'value' są wyrażone liczbą jednego z poniższych typów:

bool

unsigned

signed

real

double

Jeśli parameter ’value’ ma w sterowniku wartość NULL, to zmienna przyjmuje wartość 0 oraz otrzymuje status OPC_QUALITY_OUT_OF_SERVICE.

Uwaga:

Przy zapisie dopuszcza się, aby wartość sterująca dla parametru 'time' była pustym łańcuchem ASCII - taka wartość sterująca oznacza żądanie usunięcia danego elementu z harmonogramu (zarówno parametru 'time', jak też 'value'). Jeśli usuwany element harmonogramu nie jest ostatnim elementem harmonogramu, to następujące po nim elementy zostaną przesunięte o jedną pozycję do przodu (obiekt SCHEDULE nie zezwala na zapis niezdefiniowanych elementów).

Sygnalizacja zdarzeń

Drajwer obsługuje telegramy ’ConfirmedEventNotification’ oraz ’UnconfirmedEventNotification’. Sposób interpretacji telegramu zależy od wartości pola ’Notify-Type’ odebranego telegramu:

a/ jeśli pole ’Notify-Type’ = ’alarm’ i pole ’To-State’ = ’normal’, to drajwer sygnalizuje koniec alarmu Asixa,

b/ jeśli pole ’Notify-Type’ = ’alarm’ i pole ’To-State’ != ’normal’, to drajwer sygnalizuje początek alarmu Asixa,

c/ Notify-Type = ’event’, to drajwer zgłasza początek i koniec alarmu Asixa (treść telegramu jest traktowana jako zdarzenie).

Treść telegramu o zdarzeniu jest zamieniana na alarmy w systemie Asix. w oparciu o definicje zdarzeń odczytane z pliku definicji zdarzeń. Nazwa pliku definicji zdarzeń jest umieszczana w deklaracji kanału transmisji (parametr DefZdarzen). Brak parametru DefZdarzen w deklaracji kanału transmisji powoduje, że telegramy o zdarzeniach w danym kanale są ignorowane przez drajwer.

Do każdego numeru alarmu Asixa odczytanego z definicji zdarzenia dodawana jest wartość parametru OffsetAlarmu umieszczonego w deklaracji kanału.

W przypadku Asixa Evo wszystkie parametry zdarzenia są przekazywane do systemu alarmów.

W przypadku klasycznego Asixa przekazywane są tylko te parametry zdarzenia, które zostały wyspecyfikowane w definicji danego zdarzenia w pliku definicji zdarzeń.

Składnia definicji zdarzenia jest następująca:

asixAlarmNr, BacnetObject, eventType [,par0[,par1[,par2[,par3]]]]

gdzie:

asixAlarmNr - numer alarmu w systemie Asix

BacnetObject - BACnet ObjectIdentifier oraz instanceNr obiektu BACnet, który

wygenerował alarm w sterowniku,

eventType - nazwa typu alarmu BACnet (wartości przyjmowane przez enumerator

BACnetEventType):

CHANGE_OF_BITSTRING

CHANGE_OF_STATE

CHANGE_OF_VALUE

FLOATING_LIMIT

OUT_OF_RANGE

parn - numer parametru alarmu BACnet, którego wartość zostanie

przekazana do systemu alarmów Asixa. Typ parametru to WORD lub

FLOAT zależnie od numeru parametru oraz typu alarmu BACnet.

Parametry są numerowane począwszy od 0.

Uwaga:

1. Zestawienie typów parametrów dla poszczególnych typów alarmów jest opisane w normie ISO 16484-5:2003 - typ BACnetNotificationParameters.

2. Łączna liczba bajtów zajmowana przez wartości parametrów przekazywanych z alarmem do systemu alarmów Asixa nie może przekroczyć 8 bajtów (ograniczenie systemu alarmów Asixa). Można zatem przekazać 2 parametry typu FLOAT, 2 parametry typu DWORD, 4 parametry typu WORD itd.

Przykłady definicji zdarzeń:

10, AV.2, OUT_OF_RANGE, 0, 3

Znaczenie powyższej definicji:

alarm typu OUT_OF_RANGE przychodzący z obiektu analog-value instance 2 generuje alarm Asixa o numerze 10. Razem z alarmem są przekazywane wartości parametrów:

parameter nr 0 - exceeding-value (FLOAT)

parameter nr 3 - exceeded limit (FLOAT)

20, AV.3, FLOATING_LIMIT, 0, 2

Znaczenie powyższej definicji:

alarm typu FLOATING_LIMIT przychodzący z obiektu analog-value instance 3 generuje alarm Asixa o numerze 20. Razem z alarmem są przekazywane wartości parametrów:

parametr nr 0 - reference-value (FLOAT)

parametr nr 2 - setpoint-value (FLOAT)

Sterowanie

Dla obiektów BACnet posiadających właściwość 'priority-array' (obiekty typu 'commandable') sterowania są wykonywane przy pomocy poleceń przekazujących wartość sterującą oraz priorytet. Domyślnie sterowania z priorytetem są wykonywane dla obiektów AO, BO, MO, AV, BV, MV.

Wartość priorytetu jest deklarowana dla każdego z kanałów z osobna przy pomocy parametru PriorytetZapisu. Jeśli parametr PriorytetZapisu nie zostanie użyty w deklaracji kanału, to jako domyślną wartość przyjmuje się 16 (najniższy priorytet).

Wartość priorytetu określona dla kanału obowiązuje dla wszystkich obiektów BACnet obsługiwanych w tym kanale. Wartość ta może być przeciążona dla dowolnego obiektu przez wpisanie żądanej wartości priorytetu (z zakresu od 1 do 16) do wirtualnej właściwości tego obiektu mającej identyfikator 512. Dla realizacji tej funkcjonalności należy utworzyć dodatkową zmienną, której adres symboliczny będzie odwoływać się do wirtualnej właściwości tego obiektu mającej identyfikator 512.

Usuwanie sterowań

Dla obiektów BACnet posiadających właściwość 'priority-array' (obiekty typu 'commandable') można usunąć aktywne sterowanie (znajdujące się w tablicy 'priority-array'). Usunięcie sterowania polega na zapisie wartości NULL do tablicy 'proprity-array' na pozycję odpowiadającą priorytetowi, z jakim są wykonywane sterowania danym obiektem.

Dla realizacji powyższej funkcjonalności należy utworzyć dodatkową zmienną, której adres symboliczny odwołuje się do wirtualnej właściwości tego obiektu mającej identyfikator 513. Operacja usunięcia sterowania polega na zapisie dowolnej wartości sterującej do takiej zmiennej.

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera BACnetIP, na zakładce BACnetIP / Parametry drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość parametru:

nazwa_pliku_logu - nazwa pliku

Wartość domyślnie: plik logu nie jest tworzony

R Plik logu zdarzeń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o zdarzeniach nadesłanych ze sterowników.

Wartość parametru:

nazwa_pliku_logu - nazwa pliku

Wartość domyślnie: plik logu nie jest tworzony

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu oraz Plik logu zdarzeń.

Wartość parametru:

liczba - rozmiar pliku logu w MB

Wartość domyślna: 10

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Wartość pozycji może zostać przeciążona przy pomocy opcji Log telegramów zadeklarowanej w parametrach kanału. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość opcji:

TAK / NIE

Wartość domyślna: NIE

R Ścieżka definicji zdarzeń

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików definicji zdarzeń podanych w deklaracji kanału.

Wartość opcji:

ścieżka - pełna ścieżka do katalogu plików z definicjami zdarzeń

Wartość domyślna: brak deklaracji

PRZYKŁAD

Przykładowa deklaracja parametrów drajwera:

R Plik logu

Wartość parametru: d:\tmp\CtBACnetIP\bacnet.log

R Plik logu zdarzeń

Wartość parametru: d:\tmp\CtBACnetIP\events.log

R Rozmiar pliku logu

Wartość parametru: 30

R Log telegramów

Wartość parametru: TAK

R Ścieżka definicji zdarzeń

Wartość parametru: d:\tmp\EventsDef


CtBASKI - drajwer systemu imisji BASKI

Home > 1.11 BASKI - drajwer systemu imisji BASKI

1.11. BASKI - drajwer systemu imisji BASKI

Przeznaczenie drajwera

Drajwer jest przeznaczony do importu danych z systemu imisji BASKI zainstalowanego w El. Bełchatów do systemu Asix. Import danych jest zrealizowany o oparciu o podgląd łącza szeregowego, którym transmitowane są dane pomiędzy komputerem BASKI i stacjami pomiarowymi systemu BASKI.

Parametryzacja drajwera BASKI realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer BASKI wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtBASKI

Zakładka BASKI:

Parametry kanału:

port=liczba [[;parametr=val]]

gdzie:

port - numer portu szeregowego, służącego do podglądu łącza komputera imisji systemu BASKI,

parametr - opcjonalne parametry, które mogą być przekazane do drajwera,

val - wartość opcjonalnego parametru.

Dopuszcza się następujące parametry opcjonalne:

TimeoutWartosci - max. okres czasu (w minutach) pomiędzy kolejnymi paczkami danych z wartościami pomiarów (domyślnie 60 minut),

TimeoutStatusow - max. okres czasu (w minutach) pomiędzy kolejnymi paczkami danych ze statusami pomiarów (domyślnie 15 minut),

BazowyAlarmSPX - bazowy numer alarmu przypisany stacji pomiarowej o numerze X.

PRZYKŁAD

Przykład deklaracji kanału, który:

- realizuje podsłuch linii na porcie COM2,

- przypisuje bazowy numer alarmu 1001 stacji pomiarowej nr 1,

- przypisuje bazowy numer alarmu 1401 stacji pomiarowej nr 2,

- używa domyślnych timeout’ów dla wartości pomiarów i wartości statusów.

Nazwa: KANAL

Drajwer: BASKI

Parametry kanału: Port=2;BazowyAlarmSP1=1001;BazowyAlarmSP2=1401

Deklaracja zmiennych procesowych

Drajwer udostępnia trzy typy zmiennych:

V - wartości pomiarów,

S - wartości słów statusowych,

SB - wartości bitów słów statusowych.

Stacje pomiarowe przekazują pojedyncze zmienne, dlatego liczba elementów w deklaracji zmiennej ASMENa musi być równa 1.

Wszystkie zmienne mogą być wyłącznie czytane.

Deklaracja wartości pomiarów

Deklaracja zmiennej procesowej służącej do przekazania wartości pomiaru ma następującą składnię:

V.<nrSP>.<nrPOM>

gdzie:

nrSP - numer stacji pomiarowej,

nrPOM - numer pomiaru.

Wszystkie wartości pomiarowe są przekazywane jako FLOAT.

Numerację pomiarów podaje poniższa tabela.

Tabela: Numeracja pomiarów dla drajwera Baski.

Deklaracja słów statusowych

Deklaracja zmiennej procesowej służącej do przekazania wartości słowa statusowego ma następującą składnię:

S.<nrSP>.<nrSS>

gdzie:

nrSP - numer stacji pomiarowej,

nrSS - numer słowa statusowego.

Wszystkie wartości słów statusowych są przekazywane jako WORD.

Numerację słow statusowych podaje poniższa tabela:

Tabela: Numeracja słów statusowych dla drajwera Baski.

Deklaracja bitów słów statusowych

Deklaracja zmiennej procesowej służącej do przekazania wartości wybranego bitu słowa statusowego ma następującą składnię:

SB.<nrSP>.<nrSS>.<nrBitu>

gdzie:

nrSP - numer stacji pomiarowej,

nrSS - numer słowa statusowego,

nrBitu - numer bitu słowa statusowego określonego przez <nrSS>.

Wszystkie wartości bitów słów statusowych są przekazywane jako WORD.

Numerację bitów słów statusowych (dla statusów pomiarów) podaje poniższa tabela:

Tabela: Numeracja bitów słów statusowych (dla statusów pomiarów) dla drajwera Baski.

Numerację bitów słów statusowych (dla statusu stacji pomiarowej) podaje poniższa tabela:

Tabela: Numeracja bitów słów statusowych (dla statusu stacji pomiarowej) dla drajwera Baski.

PRZYKŁAD

Przykład deklaracji zmiennych ASMENa:

JJ_1, Warosc pomiaru NO2 ze stacji nr 0,V.00.03, KANAL, 1, 1, NIC_FP

JJ_2, Wartosc pomiaru temperatury ze stacji nr 1,V.01.08, KANAL, 1, 1, NIC_FP

JJ_3, Słowo statusowe pomiaru NOx ze stacji nr 1,S.01.04, KANAL, 1, 1, NIC

JJ_4, Bit 3 słowa statusowego pomiaru NOx ze stacji nr 2,SB.02.04.03, KANAL, 1, 1, NIC

Generowanie alarmów

Drajwer domyślnie generuje alarmy na podstawie odczytanych słów statusowych pomiarów i stacji pomiarowych. Generalnie za początek alarmu uznaje się zmianę wartości bitu z 0 na 1, za koniec alarmu - zmianę wartości bitu z 1 na 0. Wyjątkiem od tej zasady jest bit Pomiar - w tym przypadku za początek alarmu uznaje się zmianę wartości bitu z 1 na 0, za koniec alarmu - zmianę wartości bitu z 0 na 1.

Domyślnie numery alarmów są budowane wg następującej reguły:

nrAl = baza + (nrSS-1)*11 + nrBitu

gdzie:

nrAl - numer alarmu,

baza - bazowy numer alarmu stacji pomiarowej, wyliczany wg wzoru:

baza = nrSP*300 +1

gdzie:

nrSP - numer stacji pomiarowej,

nrSS - numer słowa statusowego,

nrBitu - numer bitu słowa statusowego określonego przez <nrSS>.

W ten sposób najmniejszy numer alarmu jest równy 1 i jest generowany dla braku wiarygodności pomiaru SO2 na stacji pomiarowej nr 0 (nrSp = 0, nrSS = 1, nrBitu = 0). Można zmienić numer bazowy alarmów poszczególnych stacji pomiarowych poprzez wykorzystanie parametru BazowyAlarmSPx w deklaracji kanału dla wybranych stacji pomiarowych. Wtedy numery alarmów dla tych stacji będą wyliczane wg zasady:

nrAl = BazowyAlarmSPx + (nrSS-1)*11 + nrBitu

gdzie:

BazowyAlarmSPx - liczba dodawana do numerów alarmów generowanych dla stacji pomiarowej o numerze x.

PRZYKŁADY

Przykład zmiany alarmów stacji nr 1 na zakres numerów zaczynający się od 1001:

BazowyAlarmSP1=1001

Przykład definicji alarmów dla stacji nr 1 przy założeniu, że numer alarmu dla tej stacji wynosi 1001.

1001, KO, Brak wiarygodności pomiaru SO2 w stacji nr 1

1002, KO, Brak pomiaru SO2 na stacji nr 1

....

1012, KO, Brak wiarygodności pomiaru NO w stacji nr 1

1013, KO, Brak pomiaru NO na stacji nr 1

.....

1265, KO, Otwarte drzwi w stacji nr 1

1266, KO, Niska temperatura w stacji nr 1

1267, KO, Wysoka temperatura w stacji nr 1

1268, KO, Pożar stacji nr 1

1269, KO, Brak napięcia 220V w stacji nr 1

1270, KO, Brak napięcia 24V w stacji nr 1

Parametry drajwera

Parametry drajwera BASKI deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametry drajwera umieszczane są w sekcji CTBASKI.

R Nazwa sekcji: CtBASKI

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtBASKI

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku w MB.

Wartość domyślna: rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CtBASKI

R Nazwa opcji: BEZ_ALARMOW

R Wartość opcji: TAK/NIE

Znaczenie: pozwala zablokować generowanie alarmów.

Wartość domyślnie: opcja przyjmuje wartość NIE (domyślnie alarmy są generowane).

R Nazwa sekcji: CtBASKI

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie: pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych linią podglądaną przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie: domyślnie drajwer nie wpisuje do pliku logu treści telegramów.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


BAZA - drajwer dostępu do baz danych

Home > 1.12 BAZA - drajwer dostępu do baz danych

1.12. BAZA - drajwer dostępu do baz danych

Przeznaczenie drajwera

Drajwer pozwala na import danych z baz danych do systemu Asix. Dostęp do bazy danych został zrealizowany w oparciu o technologię ADO. Drajwer BAZA udostępnia systemowi Asix dane zawarte w zewnętrznych bazach danych. Pozyskiwane dane mogą być (ale nie muszą) opatrzone statusem oraz czasem. Drajwer pozwala również na odczyt z innych źródeł jak np. arkusz Excel. Jeśli dane są opatrzone czasem, to drajwer pozwala na uzupełnianie danych historycznych w archiwach ASPADa. W przypadku gdy dane zawarte w bazie nie są opatrzone czasem, nowo pozyskane przez drajwer dane są opatrywane czasem bieżącym. Jeśli dana nie jest opatrzona statusem, to zostanie jej przypisany status "dana poprawna".

Parametryzacja drajwera BAZA realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer BAZA wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: BAZA

Zakładka BAZA:

Parametry kanału:

baza_danych

gdzie:

baza_danych - pole określające bazę danych.

Pole to może być:

- nazwą pliku; nazwa pliku musi pozwalać na odróżnienie jej od nazwy bazy tj. musi zawierać znaki "." lub "\"; w przypadku podania pliku jako nazwy zakłada się, że jest to baza Microsoft Jet (Microsoft.Jet.OLEDB.4.0);

- nazwą bazy; w tym przypadku zakłada się, że baza obsługiwana jest przez serwer SQL na komputerze lokalnym (SQLOLEDB);

- ujętym w cudzysłowy łańcuchem dostępu do bazy (connection string); ta forma specyfikacji pozwala określić dowolną bazę danych, w tym pozwala określić takie parametry jak: lokalizacja serwera bazy (np. zdalny komputer), nazwę użytkownika, hasło, timeout nawiązywania połączenia itd.; forma ta pozwala również specyfikować bazy jako nazwy DSN;

- ujętą w nawiasy kwadratowe nazwą sekcji, w której umieszczone są elementy składające się na łańcuch dostępu do bazy; forma ta używana jest w przypadku długich łańcuchów dostępu.

PRZYKŁAD

Poniżej podane są przykładowe deklaracje użycia kanału transmisji pracującego według protokołu BAZA:

Baza Microsoft Jet:

Nazwa: Pomiary1

Drajwer: BAZA

Parametry kanału:

c:\Pomiary.mdb

Baza zdefiniowana za pomocą źródła danych DSN (komputerowego lub użytkownika):

Nazwa: Pomiary2

Drajwer:

Parametry kanału:

"DSN=Pomiary"

Baza zdefiniowana za pomocą plikowego źródła danych DSN

Nazwa: Pomiary3

Drajwer:

Parametry kanału:

"FILEDSN=C:\BAZA\Pomiary.dsn"

Baza zdefiniowana za pomocą pliku UDL (Microsoft Data Link)

Nazwa: Pomiary4

Drajwer: BAZA

Parametry kanału:

"File Name=C:\BAZA\Pomiary.UDL"

Baza SQL o nazwie "Pomiary" na komputerze lokalnym:

Nazwa: Pomiary5

Drajwer: BAZA

Parametry kanału:

Pomiary

Baza SQL o nazwie "Pomiary" na komputerze "Emisja"

Nazwa: Pomiary6

Drajwer: BAZA

Parametry kanału:

"Provider=SQLOLEDB.1;Data Source=Emisja;Initial Catalog = Poiary;Integrated Security=SSPI;"

Deklaracja zmiennych

Część adresowa deklaracji zmiennej ma postać:

deklaracja_tablicy[.pole_wartość[.[pole_czas][.pole_status]]]

gdzie:

deklaracja_tablicy - wyrażenie określające tablicę (zestaw rekordów) w bazie;

pole_wartość - nazwa pola (kolumny) zawierającej wartość danej;

pole_czas - nazwa pola (kolumny) zawierającej czas danej (typ Date/Time);

pole_status - nazwa pola (kolumny) zawierającej status danej (typ numeryczny - status OPC).

Pole pole_wartość można pominąć, jeśli deklaracja_tablicy określa tablicę zawierającą jedną kolumnę.

Jeśli pole_czas jest pominięte, to przyjmowany jest czas bieżący.

Jeśli pole_status zostanie pominięte, to wartość zmiennej otrzymuje status "dana poprawna".

Deklaracja_tablicy może być:

  • nazwą tablicy znajdującej się w bazie danych;

  • ujętym w apostrofy (') lub nawiasy okrągłe zapytaniem (query) wysyłanym przez drajwer do bazy w celu odczytu danych;

  • nazwą symboliczną zapytania w postaci $(nazwa). Nazwa określa zapytanie SQL, którego postać jest zdefiniowa w sekcji [BAZA] pliku konfiguracyjnego aplikacji.

W najprostszym i najbardziej typowym przypadku tablica jest określona poprzez jej nazwę. Przykładowo, jeśli baza danych zawiera tablicę o nazwie Pomiary, która zawiera kolumny Temperatura, Cisnienie, Czas oraz Status, to adresy zmiennych mogłyby mieć postać:

Pomiary.Temperatura.Czas.Status

Pomiary.Cisnienie.Czas.Status

PRZYKŁAD

W przypadku gdy należy użyć bardziej złożonej reguły wyznaczającej rekordy, można skorzystać z pozostałych form adresacji, tj. z wykorzystaniem tekstu zapytania. Na przykład:

(SELECT * FROM Pomiary WHERE ......).Temperatura.Czas.Status

Zapytania muszą być sformułowane w taki sposób, aby określały uporządkowany malejąco wg czasu zbiór rekordów. W przypadku odczytu danych bieżących drajwer modyfikuje zapytanie w taki sposób, aby odczytać najświeższy rekord (drajwer dodaje frazę "TOP 1"). W przypadku odczytu danych historycznych (tylko wtedy, gdy adres zawiera pole czas), drajwer dodaje lub modyfikuje frazę WHERE tak, aby otrzymać dane z określonego przedziału czasu.

Inną formą stosowania zapytań jest użycie nazwy zapytania. Zapytanie jest zdefiniowane w sekcji [BAZA] pliku inicjalizacyjnego. Stosowanie nazw pozwala na:

  • skrócenie adresu w przypadku użycia wielu zmiennych o tym samym zapytaniu, ale o różnych polach wartości;

  • uniknięcie błędów w przypadku konieczności użycia w zapytaniu znaków, które są przez moduł ASMEN interpretowane w inny sposób;

  • optymalizowanie ilości zapytań, tj. jeśli wynikiem zapytania jest tablica wielu zmiennych, to drajwer wystosuje tylko jedno zapytanie zamiast po jednym dla każdej zmiennej.

UWAGA W części adresowej zmiennej nie należy używać cudzysłowów (").

Parametry drajwera

Parametry drajwera BAZA deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametry drajwera można umieszczać w sekcji o nazwie BAZA oraz w sekcjach mających nazwy takie jak nazwy kanałów w deklaracji kanałów. Parametry umieszczone w sekcji BAZA dotyczą wszystkich kanałów drajwera BAZA. Parametry w pozostałych sekcjach dotyczą tylko określonego kanału. Jeśli parametr występuje w sekcji BAZA oraz w sekcji kanału, to wyższy priorytet ma parametr dotyczący określonego kanału.

R Nazwa sekcji: BAZA

R Nazwa opcji: Bez_TOP

R Wartość opcji: tak/nie

Znaczenie: jeśli parametr ma wartość Nie, to drajwer umieszcza w zapytaniu SQL frazę TOP ograniczającą ilość odczytywanych rekordów. Niektóre bazy danych nie dopuszczają użycia frazy TOP. W takich przypadkach należy nadać parametrowi wartość Tak.

Wartość domyślnie: Nie.

R Nazwa sekcji: BAZA

R Nazwa opcji: Log

R Wartość opcji: nazwa_pliku

Znaczenie: określa nazwę pliku, w którym zapisywaną są informacje diagnostyczne.

Wartość domyślnie: brak.

R Nazwa sekcji: BAZA

R Nazwa opcji: Maksymalna_historia

R Wartość opcji: liczba

Znaczenie: określa okres czasu liczony od bieżącej chwili wstecz, dla którego będą odczytywane dane historyczne znajdujące się w bazie danych.

Wartość opcji:

liczba - określa okres czasu liczony w dniach.

Wartość domyślnie: 30.

R Nazwa sekcji: BAZA

R Nazwa opcji: Optymalizacja_Rekordu

R Wartość opcji: TAK / NIE

Znaczenie: parametr dotyczy zmiennych określonych przez nazwę tablicy. Jeśli parametr ma wartość Tak, to dla wszystkich zmiennych zawartych w tej samej tablicy zostanie sformułowane tylko jedno, wspólne dla wszystkich zmiennych zapytanie SQL, powodujące odczyt rekordu zawierającego tylko pola występujące w adresach zmiennych. Jeśli parametr ma wartość Nie, to odczytane zostaną wszystkie pola zawarte w tablicy.

Wartość domyślnie: Tak.

R Nazwa sekcji: BAZA

R Nazwa opcji: Sortuj

R Wartość opcji: tak/nie

Znaczenie: jeśli parametr ma wartość Tak, to drajwer sformułuje zapytanie SQL w taki sposób, że odczytane rekordy będą odpowiednio posortowane wg pól czasu. Jeśli parametr ma wartość Nie, to rekordy nie będą sortowane.

Wartość domyślnie: Tak.

R Nazwa sekcji: BAZA

R Nazwa opcji: Rekordy_historii

R Wartość opcji: liczba

Znaczenie: parametr określa maksymalną ilość rekordów odczytywanych jednorazowo z bazy danych podczas odczytu historii. Parametr ma znaczenie tylko wtedy, gdy parametr Bez_TOP ma wartość Nie.

Wartość domyślnie: 1000.

R Nazwa sekcji: BAZA

R Nazwa opcji: UTC

R Wartość opcji: tak/nie

Znaczenie: parametr określa, czy czas zapisany w bazie danych jest czasem UTC (Universal Time Coordinate lub Greenwich Mean Time). Jeśli parametr ma wartość Tak, to czas jest czasem UTC. Jeśli parametr ma wartość Nie, to czas jest czasem lokalnym.

Wartość domyślnie: Nie.

Optymalizacja ilości pól w rekordzie

Dla wszystkich zmiennych zawartych w tej samej tablicy drajwer formułuje jedno wspólne dla wszystkich zmiennych zapytanie SQL powodujące odczyt rekordu zawierającego tylko pola występujące w adresach zmiennych. Jeśli adres chociaż jednej zmiennej zawiera nazwę pola, które nie znajduje się w tablicy, to odczyt wszystkich zmiennych tej tablicy zakończy się błędem. Aby określić, która zmienna ma niepoprawną nazwę pola, należy podać parametr Optymalizacja_Rekordu=Nie, który spowoduje, że błąd będzie dotyczył tylko niepoprawnie zadeklarowanych zmiennych. Jeśli błąd dotyczy nazwy pola czasu, to należy dotakowo podać Sortuj=Nie. Zaniechanie sortowania może jednak spowodować odczyt niepoprawnych danych.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


BUFOR - drajwer protokołu uniwersalnego

Home > 1.13 BUFOR - drajwer protokołu uniwersalnego

1.13. BUFOR - drajwer protokołu uniwersalnego

Przeznaczenie drajwera

Protokół uniwersalny BUFOR pozwala na wymianę danych pomiędzy systemem Asix i dowolnym programem transmisji danych procesowych opracowanym przez użytkownika.

Kanał transmisji oparty o protokół BUFOR jest realizowany przez dwa programy:

  • drajwer protokołu uniwersalnego BUFOR, wchodzący w skład pakietu Asix,

  • drajwer transmisji danych procesowych opracowany przez użytkownika.

Program użytkownika musi być zaimplementowany w postaci procesu działającego w środowisku Windows XP / 2000 / NT 4.0.

Wymiana danych pomiędzy drajwerem BUFOR i programem użytkownika jest realizowana poprzez plik wymiany (ang. Memory mapped file). Synchronizacja dostępu do pliku wymiany jest realizowana przy wykorzystaniu obiektu typu mutex.

Parametryzacja drajwera BUFOR realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer BUFOR wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: BUFOR

Zakładka BUFOR:

Parametry kanału:

PLIK_MMF,USER,PAR1,PAR2,PAR3

gdzie:

PLIK_MMF - nazwa pliku wymiany,

USER - nazwa procesu użytkownika,

PAR1..PAR3 - parametry przekazywane do procesu użytkownika.

Opis struktur danych oraz reguły współpracy procesu użytkownika z drajwerem BUFOR zawarte są w pliku DrBufor.hlp.

Adresacja zmiennych i instalacja drajwera

Składnia adresu symbolicznego używanego dla zmiennych procesowych należących do kanału BUFOR jest następująca:

Iindeks_zmiennej

gdzie:

I - stały element adresu symbolicznego kanału BUFOR;

indeks_zmiennej - indeks zmiennej w tablicy zmiennych drajwera użytkownika. Pierwsza zmienna posiada indeks 1.

Pozostałe parametry w deklaracji zmiennej procesowej maja typowe znaczenie.

Drajwer BUFOR jest ładowany automatycznie jako DLL.

Możliwość deklarowania nazwy mutexa, który pozwala na synchronizację drajwera BUFOR i programu użytkownika na etapie rozbiegu

Nazwę mutexa podaje się używając opcji MUTEX deklarowanego w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio:

Nazwa sekcji: identyczna z nazwą kanału logicznego używającego drajwera BUFOR

Nazwa opcji: MUTEX

Wartość pozycji: nazwa_mutexa

PRZYKŁAD

Deklartacja kanału logicznego KANAL:

Nazwa: KANAL

Drajwer: BUFOR

Parametry kanału: TEST_MMF, userebuf, par1 par2 par3

Deklaracja nazwy mutex’a:

Nazwa sekcji: KANAL

Nazwa opcji: MUTEX

Wartość pozycji: TEST_MUTEX

W przypadku deklaracji muetxa drajwer BUFOR działa wg następującego schematu:

  • kreuje proces użytkownika procedurą CreateProcess() i oczekuje, że kreowany proces utworzy mutex o nazwie podanej w opcji MUTEX (w przykładzie - TEST_MUTEX); proces kreując mutex musi go od razu zająć!

  • wywołuje OpenMutex(), podając nazwę mutexa zadeklarowaną w opcji MUTEX (w przykładzie - TEST_MUTEX); jeśli OpenMutex() zwróci błąd, to drajwer BUFOR kończy inicjalizację kanału z błędem;

  • oczekuje, aż program użytkownika zwolni mutex, dopiero potem przechodzi do etapu sprawdzania zawartości pliku wymiany.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CTCalec - drajwer protokołu urządzeń CALEC MCP

Home > 1.14 Calec - drajwer protokołu urządzeń CALEC MCP

1.14. Calec - drajwer protokołu urządzeń CALEC MCP

Przeznaczenie drajwera

Drajwer Calec służy do pobierania bieżących wartości zmiennych z urządzenia CALEC MCP firmy Aquametro.

Drajwer Calec jest biblioteką dynamiczną DLL o interfejsie spełniającym wymagania modułu UniDriver. Drajwer Calec wraz z modułem UniDriver stanowią drajwer spełniający wymagania modułu ASMEN.

Parametryzacja drajwera Calec realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Calec wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Calec

Zakładka Calec:

Parametr kanału:

parametry drajwera

gdzie:

parametry drajwera - parametry konfiguracyjne drajwera Calec opisane w dalszej części specyfikacji.

Podczas ładowania i inicjalizacji aplikacji systemu Asix drajwer Calec otrzymuje od modułu ASMEN kolejno i jednokrotnie adres każdej zmiennej procesowej, pobrany ze źródła definicji zmiennych. Zmienne dostarczane przez drajwer są zmiennymi tylko do odczytu.

Parametry konfiguracyjne

Drajwer obsługuje następujące parametry konfiguracyjne:

Tabela. Parametry konfiguracyjne dla Calec.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji wykorzystującego drajwer Calec:

Nazwa: CalecMCP

Drajwer: Calec

Parametry kanału:

Port=COM1:9600:8:even:1,OkresOdczytu=10, TimeoutOdczytu=1200

Parametry konfiguracyjne portu szeregowego

Pełna składnia deklaracji portu szeregowego jest następująca:

Port=<nazwa portu>:<szybkość>:<znak>:<parzystość>:<stop>

gdzie:

nazwa portu - nazwa portu szeregowego w systemie operacyjnym np. COM1 lub COM2;

szybkość - szybkość transmisji szeregowej;

znak - liczba bitów w transmitowanym znaku;

parzystość - typ kontrolo parzystości, można podać odd, eden lub none;

stop - liczba bitów stopu, można podać 1, 15 (1.5 bitu) lub 2.

Uproszczona składnia składa się tylko z nazwy portu:

Port = <nazwa portu>

Jako pozostałe parametry przyjmuje się wartości domyślne: 9600:8:even:1

Adres zmiennej

Adres zmiennej składa się z szesnastkowego adresu zmiennej w urządzeniu oraz z typu kodowania wartości zmiennej, oddzielonych od siebie dwukropkiem. Jako typ wartości zmiennej można podać FLOAT dla zmiennych zmiennoprzecinkowych oraz FIX dla zmiennych stałoprzecinkowych.

PRZYKŁAD

2000:FIX Zmienna stałoprzecinkowa pobierana z adresu 2000 szesnastkowo,

2080:FLOATZmienna zmiennoprzecinkowa pobierana z adresu 2080 szesnastkowo.

Dla zmiennych zmiennoprzecinkowych należy użyć funkcję przeliczającą NIC_FP, a dla stałoprzecinkowych funkcję przeliczającą NIC.

Okres odświeżania zmiennej

Czas odczytu jednej zmiennej z urządzenia wynosi typowo od 520 do 630 ms (średnio 570ms), lecz dla niektórych zmiennych (w testowanym urządzeniu był to pomiar o nazwie Temperaturdifferenz) może osiągnąć 1300 ms. Należy wziąć to pod uwagę przy ustalaniu okresu odczytu drajwera i okresu odświeżania zmiennych tak, aby fizycznie możliwe było odczytanie wymaganej liczby zmiennych z urządzenia w zadanym okresie odświeżania. Najczęściej okresy odczytu drajwera i okresy odświeżania zmiennych są równe.

Funkcje protokołu wyłączone z implementacji

W dokumentacji znajduje się jedna wzmianka, że w urządzeniu istnieje co najmniej jedna zmienna typu tekst. Ponieważ nie opisano sposobu transmisji danych tego typu, drajwer nie obsługuje ich.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CAN_AC_PCI - drajwer protokołu CANBUS dla karty

Home > 1.15 CAN_AC_PCI - drajwer protokołu CANBUS dla karty CAN_ACx_PCI

1.15 CAN_AC_PCI - drajwer protokołu CANBUS dla karty CAN_ACx_PCI

Przeznaczenie drajwera

Drajwer CAN_AC_PCI jest wykorzystywany do wymiany danych pomiędzy sterownikami SELECONTROL MAS firmy Selectron Lyss AG i komputerem systemu Asix przy zastosowaniu sieci CAN. Komputer systemu Asix musi być wyposażony w kartę procesora komunikacyjnego CAN_AC1 lub CAN_AC2 firmy Softing GmbH.

Parametryzacja drajwera CAN_AC_PCI realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer CAN_AC_PCI wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CAN_AC_PCI

Zakładka CAN_AC_PCI:

Parametry kanału:

nr_interfejsu

gdzie:

nr_interfejsu - numer interfejsu karty CAN_AC1/CAN_AC2, poprzez który realizowana jest transmisja z siecią CAN. W karcie CAN_AC1 można wykorzystywać wyłącznie interfejs numer 1.

Drajwer CAN_AC_PCI jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Wartości zmiennych procesowych przekazywane są w telegramach nadawanych przez sterowniki podłączone do sieci CAN. Każdy telegram składa się maksymalnie z 8-miu bajtów, które mogą być identyfikowane jako:

- bajty o indeksach 1 - 8 (typ BY),

- liczby 16-bitowe o indeksach 1 - 4 (typ WD),

- liczby 32-bitowe o indeksach 1 - 2 (typ (DW).

Drajwer CAN_AC_PCI rozróżnia następujące typy dostępu do zmiennych procesowych:

- tylko odczyt (typ R_),

- tylko zapis (typ W_),

- zapis i odczyt (typ RW_).

Adresacja zmiennych procesowych polega na wskazaniu:

- typu dostępu (R_, W_ lub RW_);

- typu zmiennej (BY, WD, DW);

- numeru telegramu (dla zmiennych o typie dostępu RW_ jest to numer telegramu służącego do odczytu zmiennej);

- indeksu w ramach telegramu (dla zmiennych o typie dostępu RW_ jest to indeks w telegramie służącym do odczytu zmiennej);

- dla zmiennych o typie dostępu RW_ należy zadeklarować dodatkowo:

a/ numer telegramu służącego do zapisu zmiennej,

b/ indeks w telegramie służącym do zapisu zmiennej.

Składnia adresu symbolicznego zmiennej jest następująca:

<typ_dostępu><typ_zmiennej><tel>.<indeks>[.<tel>.<indeks>]

gdzie:

typ_dostępu - typ dostępu do zmiennej procesowej:

R_ - tylko odczyt,

W_ - tylko zapis,

RW_ - odczyt i zapis,

typ_zmiennej - typ zmiennej procesowej:

BY - zmienna typu bajt,

WB - zmienna typu liczba 16-bitowa,

DW - zmienna typu liczba 32-bitowa,

tel - numer telegramu,

indeks - indeks w ramach telegramu.

Przykład

X1, bajt nr 2 telegramu 31, R_BY31.2, NONE, 1, 1, NIC_BYTE

X2, słowo nr 3 telegramu 31, R_WD31.3, NONE, 1, 1, NIC

X3, stan palników, RW_BY31.1.35.3, NONE, 1, 1, NIC_BYTE

X4, nastawa zaworu, RW_WD32.1.34.1, NONE, 1, 1, NIC

Wartość zmiennej X3 jest przekazywana do systemu Asix poprzez bajt nr 1 telegramu nr 31. Zmiana wartości zmiennej X3 polega na wysłaniu z systemu Asix telegramu nr 35, którego bajt nr 3 zawiera żądany stan zmiennej X3.

Parametry drajwera

Parametry drajwera CAN_AC_PCI deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu CAN_AC_PCI może być parametryzowany w sekcji CAN_AC_PCI.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: PREDKOSC_TRANSMISJI

R Wartość opcji: nr_interfejsu,baud_id

Znaczenie: służy do deklarowania prędkości transmisji w sieci CAN.

Wartość domyślna: domyślnie przyjmuje się prędkość transmisji 1 MB.

Parametry:

nr_interfejsu - numer interfejsu karty CAN_AC (dla karty CAN_AC1 zawsze 1),

baud_id - identyfikator prędkości transmisji sieci CAN:

1 - 1 MB

2 - 500 kB

3 - 250 kB

4 - 125 kB

5 - 100 kB

6 - 50 kB

7 - 20 kB

Przykład

Deklaracji prędkości transmisji 20 kB (sieć CAN o numerze 1):

Nazwa sekcji: CAN_AC_PCI

Nazwa opcji: PREDKOSC_TRANSMISJI

Wartość opcji: 1,7

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: CYKL_ODSWIEZANIA

R Wartość opcji: liczba

Znaczenie: służy do deklarowania odstępu czasu pomiędzy kolejnymi sygnałami zezwalającymi drajwerowi karty CAN_AC na odczyt danych z sieci CAN.

Wartość opcji:

liczba - ilość 0.5 sekundowych interwałów, które muszą upłynąć pomiędzy kolejnymi sygnałami, zezwalającymi drajwerowi karty CAN_AC na odczyt danych z sieci CAN.

Wartość domyślna: domyślnie drajwer CAN_AC_PCI odczytuje dane co 0.5 sekundy.

Przykład

Deklaracji odczytu danych co 1 sekundę:

Nazwa sekcji: CAN_AC_PCI

Nazwa opcji: CYKL_ODSWIEZANIA

Wartość opcji: 2

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: KONTROLA_SIECI

R Wartość opcji: liczba

Znaczenie: pozwala na testowanie odbioru telegramów z sieci CAN. Określa maksymalny czas (w sekundach) pomiędzy odbiorem kolejnych telegramów o tym samym numerze. W przypadku przekroczenia tego czasu zmienne procesowe związane z takim telegramem będą opatrzone statusem błędu. Jeśli dodatkowo w tym samym czasie nie odebrano żadnego telegramu z sieci CAN, to generowany jest komunikat w panelu operatorskim o braku telegramów w sieci.

Wartość opcji:

liczba - maksymalna liczba sekund, które mogą upłynąć pomiędzy kolejnymi telegramami o tym samym numerze.

Wartość domyślnie: domyślnie drajwer CAN_AC_PCI nie kontroluje napływu telegramów.

PRZYKŁAD

Przykład kontroli napływu telegramów co 5 sekund:

Nazwa sekcji: CAN_AC_PCI

Nazwa opcji: KONTROLA_SIECI

Wartość opcji: 5

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: PODGLAD_TELEGRAMU

R Wartość opcji: TAK|NIE

Znaczenie: steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach odebranych z sieci CAN. Komunikat zawiera numer sieci CAN, numer telegramu, liczbę bajtów oraz zawartość telegramu w postaci heksadecymalnej.

Wartość domyślnie: domyślnie nie wyświetla się zawartości telegramów.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: PODGLAD_STEROWANIA

R Wartość opcji: TAK|NIE

Znaczenie: steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach sterujących wysłanych z komputera systemu Asix do sterowników. Komunikat zawiera numer sieci CAN, numer telegramu, liczbę bajtów oraz zawartość telegramu w postaci heksadecymalnej.

Wartość domyślnie: domyślnie nie wyświetla się zawartości telegramów sterujących.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty opisujące telegramy odebrane z sieci CAN. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

Aktualizacja buforów drajwera danymi sterującymi

Drajwer posiada dwie pule telegramów: wysyłkowe i odbiorcze. Telegramy wysyłkowe są używane przez system Asix do wysyłania sterowań, natomiast telegramy odbiorcze zawierają aktualne kopie telegramów wysyłanych ze sterowników i są źródłem wartości zmiennych procesowych dla systemu Asix.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: UZYCIE_WARTOSCI_STERUJACYCH

R Wartość opcji: TAK|NIE

Znaczenie: pozwala na przepisanie wartości zmiennej sterującej (typu W_) z telegramu wysyłkowego bezpośrednio do bufora telegramu odbiorczego. Przepisanie dotyczy telegramu odbiorczego mającego ten sam numer, co telegram wysyłkowy przypisany zmiennej sterującej i jest realizowane jedynie po poprawnym wykonaniu operacji sterowania. W ten sposób wartości zmiennych sterujących zostają użyte przez drajwer jako aktualne wartości zmiennych procesowych. Stan ten trwa do momentu, gdy rzeczywiste wartości przedmiotowych zmiennych procesowych zostaną odczytane ze sterownika.

Wartość domyślna: domyślnie nie kopiuje się wartości sterujących do buforów telegramów odbiorczych drajwera.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: UZYCIE_DEKLARACJI_RW

R Wartość opcji: TAK|NIE

Znaczenie: pozwala na zmianę trybu przepisywania wartości sterujących.

Kontrola zmiennych sterujących

Domyślnie kontroluje się deklaracje zmiennych typu W_ (zmiennych sterujących), dopuszczając możliwość użycia wyłącznie jednej zmiennej takiego typu w jednym telegramie.

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: KONTROLA_ZMIENNYCH_STERUJACYCH

R Wartość opcji: TAK|NIE

Znaczenie: pozwala na zmianę ustawień domyślnych i umożliwia wykorzystanie dowolnego telegramu do realizacji sterowań przez więcej niż jedną zmienną typu W_. Poszczególne sterowania realizowane są sekwencyjnie, tzn. poprzez wysłanie odrębnego telegramu przekazującego wartość tylko jednej zmiennej sterującej; pozostałe elementy telegramu wypełniane są zerami.

Zmiana ustawień domyślnych trybu aktualizacji buforów odbiorczych danymi sterującymi

R Nazwa sekcji: CAN_AC_PCI

R Nazwa opcji: UZYCIE_DEKLARACJI_RW

R Wartość opcji: TAK|NIE

Znaczenie: pozwala na zmianę trybu przepisywania wartości sterujących do buforów telegramów odbiorczych drajwera. Opcja ma znaczenie tylko dla zmiennych typu RW_ oraz odnosi skutek, jeśli jednocześnie została użyta opcja UZYCIE_WARTOSCI_STERUJACYCH=TAK. Efektem użycia przedmiotowej opcji jest kopiowanie wartości sterującej do bufora telegramu odbiorczego o numerze wyspecyfikowanym w deklaracji zmiennej procesowej, na opcji telegramu służącego do odczytu wartości zmiennej.

Wartość domyślna: nie aktualizuje się buforów drajwera zgodnie z deklaracjami zmiennych typu RW_.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CANOPEN – drajwer protokołu CANBUS dla karty PCI_712 NT

Home > 1.16 CANOPEN - drajwer protokołu CANBUS dla karty PCI_712 NT

1.16 CANOPEN - drajwer protokołu CANBUS dla karty PCI_712 NT

Przeznaczenie drajwera

Drajwer CANOPEN jest wykorzystywany do wymiany danych pomiędzy sterownikami SELECONTROL MAS firmy Selectron Lyss AG i komputerem systemu Asix przy wykorzystaniu sieci CAN. Komputer systemu Asix musi być wyposażony w kartę procesora komunikacyjnego PCI_712 NT oraz oprogramowanie PCI712 CanLib32 firmy Selectron Lyss AG.

Parametryzacja drajwera CANOPEN realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer CANOPEN wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CANOPEN

Zakładka CANOPEN:

Parametr kanału:

nr_karty

gdzie:

nr_karty - numer karty PCI_712 NT, poprzez którą realizowana jest transmisja z siecią CAN. W obecnej wersji drajwer CANOPEN może współpracować z jedną kartą PCI_712 NT.

Drajwer CANOPEN jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Wartości zmiennych procesowych przekazywane są w telegramach nadawanych przez sterowniki podłączone do sieci CAN. Każdy telegram składa się maksymalnie z 8‑miu bajtów, które mogą być identyfikowane jako:

  • bajty o indeksach 1 - 8 (typ BY),

  • liczby 16-bitowe o indeksach 1- 4 (typ WD),

  • liczby 32-bitowe o indeksach 1- 2 (typ (DW).

Drajwer CANOPEN rozróżnia następujące typy dostępu do zmiennych procesowych:

  • tylko odczyt (typ R_),

  • tylko zapis (typ W_),

  • zapis i odczyt (typ RW_).

Adresacja zmiennych procesowych polega na wskazaniu:

  • typu dostępu (R_, W_ lub RW_),

  • typu zmiennej (BY, WD, DW),

  • numeru telegramu (dla zmiennych o typie dostępu RW_ jest to numer telegramu służącego do odczytu zmiennej),

  • indeksu w ramach telegramu (dla zmiennych o typie dostępu RW_ jest to indeks w telegramie służącym do odczytu zmiennej),

  • dla zmiennych o typie dostępu RW_ należy zadeklarować dodatkowo:

- numer telegramu służącego do zapisu zmiennej,

- indeks w telegramie służącym do zapisu zmiennej.

Składnia adresu symbolicznego zmiennej jest następująca:

<typ_dostępu><typ_zmiennej><tel>.<indeks>[.<tel>.<indeks>]

gdzie:

typ_dostępu - typ dostępu do zmiennej procesowej:

R_ - tylko odczyt,

W_ - tylko zapis,

RW_ - odczyt i zapis,

typ_zmiennej - typ zmiennej procesowej:

BY - zmienna typu bajt,

WB - zmienna typu liczba 16-bitowa,

DW - zmienna typu liczba 32-bitowa,

Tel - numer telegramu,

Indeks - indeks w ramach telegramu.

Przykład

X1, bajt nr 2 telegramu 31, R_BY31.2, NONE, 1, 1, NIC_BYTE

X2, słowo nr 3 telegramu 31, R_WD31.3, NONE, 1, 1, NIC

X3, stan palników, RW_BY31.1.35.3, NONE, 1, 1, NIC_BYTE

X4, nastawa zaworu, RW_WD32.1.34.1, NONE, 1, 1, NIC

Wartość zmiennej X3 jest przekazywana do systemu Asix poprzez bajt nr 3 telegramu nr 31. Zmiana wartości zmiennej X3 polega na wysłaniu z systemu Asix telegramu nr 34, którego bajt nr 3 zawiera żądany stan zmiennej X3.

Parametry drajwera CANOPEN

Parametry drajwera CANOPEN deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu CANOPEN może być parametryzowany w sekcji CANOPEN.

R Nazwa sekcji: CANOPEN

R Nazwa opcji: PREDKOSC_TRANSMISJI

R Wartość opcji: nr_sieci,baud_id

Znaczenie: służy do deklarowania prędkości transmisji w sieci CAN.

Wartość domyślna: domyślnie przyjmuje się prędkość transmisji 1 MB.

Parametry:

nr_sieci - numer sieci CAN (w obecnej wersji zawsze sieć nr 1),

baud_id - identyfikator prędkości transmisji w sieci CAN:

1 - 1 MB

2 - 500 kB

3 - 250 kB

4 - 125 kB

5 - 100 kB

6 - 50 kB

7 - 20 kB

Przykład

Przykład deklaracji prędkości transmisji 20 kB (sieć CAN o numerze 1):

Nazwa sekcji: CANOPEN

Nazwa opcji: PREDKOSC_TRANSMISJI

Wartość opcji: 1,7

Częstość odczytu danych z karty PCI_712 NT

R Nazwa sekcji: CANOPEN

R Nazwa opcji: CYKL_ODSWIEZANIA

R Wartość opcji: liczba

Znaczenie: służy do deklarowania odstępu czasu pomiędzy kolejnymi sygnałami zezwalającymi drajwerowi karty PCI_712 NT na generowanie powiadomień o odebranych komunikatach z sieci CAN.

Wartość opcji:

liczba - ilość 0.5 sekundowych interwałów, które muszą upłynąć pomiędzy kolejnymi sygnałami zezwalającymi drajwerowi karty PCI_712 NT na generowanie powiadomień o odebranych komunikatach z sieci CAN

Wartość domyślna: domyślnie drajwer CANOPEN wysyła sygnały co 0.5 sekundy.

Przykład

Deklaracja wysyłania sygnału zezwolenia co 1 sekundę:

Nazwa sekcji: CANOPEN

Nazwa opcji: CYKL_ODSWIEZANIA

Wartość opcji: 2

Kontrola odbioru telegramów z sieci CAN

R Nazwa sekcji: CANOPEN

R Nazwa opcji: KONTROLA_SIECI

R Wartość opcji: liczba

Znaczenie: pozwala na testowanie odbioru telegramów z sieci CAN. Określa maksymalny czas pomiędzy odbiorem kolejnych telegramów o tym samym numerze. W przypadku przekroczenia tego czasu zmienne procesowe związane z takim telegramem będą opatrzone statusem błędu. Jeśli dodatkowo w tym samym czasie nie odebrano żadnego telegramu z sieci CAN, to generowany jest komunikat w panelu operatorskim o braku telegramów w sieci.

Wartośc opcji:

liczba - czas wyrażony w sekundach.

Wartość domyślna: drajwer CANOPEN nie kontroluje napływu telegramów.

Przykład

Kontrola napływu telegramów co 5 sekund:

Nazwa sekcji: CANOPEN

Nazwa opcji: KONTROLA_SIECI

Wartość opcji: 5

R Nazwa sekcji: CANOPEN

R Nazwa opcji: PODGLAD_TELEGRAMU

R Wartość opcji: TAK/NIE

Znaczenie: steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach odebranych z sieci CAN. Komunikat zawiera numer sieci CAN, numer telegramu, liczbę bajtów oraz zawartość telegramu w postaci heksadecymalnej.

Wartość domyślna: domyślnie zawartość telegramów nie jest wyświetlana.

Przykład

Deklaracja podglądu odbieranych telegramów:

Nazwa sekcji: CANOPEN

Nazwa opcji: PODGLAD_TELEGRAMU

Wartość opcji: TAK

R Nazwa sekcji: CANOPEN

R Nazwa opcji: PODGLAD_STEROWANIA

R Wartość opcji: TAK/NIE

Znaczenie: steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach sterujących wysłanych z komputera systemu Asix do sterowników. Komunikat zawiera numer sieci CAN, numer telegramu, liczbę bajtów oraz zawartość telegramu w postaci heksadecymalnej.

Wartość domyślna: domyślnie zawartość telegramów sterujących nie jest wyświetlana.

Przykład

Deklaracja podglądu telegramów sterujących:

Nazwa sekcji: CANOPEN

Nazwa opcji: PODGLAD_STEROWANIA

Wartość opcji: TAK

R Nazwa sekcji: CANOPEN

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty opisujące telegramy odebrane z sieci CAN. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie pliku logu nie jest tworzony.

Przykład

Nazwa sekcji: CANOPEN

Nazwa opcji: PLIK_LOGU

Wartość opcji: D:\ASIX\CAN.LOG

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CipAB

Home > 1.17 CipAB - drajwer do komunikacji ze sterownikami serii Logix5000 firmy Allen-Bradley

1.17 CipAB - drajwer do komunikacji ze sterownikami serii Logix5000 firmy Allen-Bradley

Przeznaczenie drajwera

Drajwer CipAB służy do wymiany danych pomiędzy systemem Asix i sterownikami serii Logix5000 firmy Allen-Bradley przy pomocy protokołu EtherNet/IP w trybie Explicit Messaging.

Drajwer wymaga zainstalowania modułu Asmen.dll w wersji 5.9 lub nowszej.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera CipAB wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CipAB

Zakładka CipAB/Parametry kanału:

Adres IP urządzenia - adres IP urządzenia,

Numer alarmu - (opcjonalnie) numer alarmu w przypadku braku komunikacji ze sterownikiem.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału:

Nazwa: KANAL

Drajwer: CtCipAB

Parametry kanału:

Adres IP urządzenia: 10.10.105.21

N umer alarmu: 100

Deklaracja zmiennych procesowych

Adres symboliczny zmiennej jest budowany na bazie nazwy taga w programie sterownika. W przypadku adresów symbolicznych odwołujących się do tagów globalnych podaje się jedynie nazwę tego taga, w przypadku adresów symbolicznych odwołujących się do tagów lokalnych należy podać słowo kluczowe Program:, nazwę programu lokalnego oraz nazwę taga.

Drajwer umożliwia dostęp do tagów mających jeden z poniższych typów:

Boolean

8-Bit Int

16-Bit Int

32-Bit Int

32-Bit Unsigned

32-Bit Float

String

Przykłady:

Nazwa: G_01

Opis: tag globalny GBOOL1 typu Boolean

Adres: GBOOL1

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: G_02

Opis: tag globalny GDINT typu Dword

Adres: GDINT

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_DW

Nazwa: G_03

Opis: tag globalny GFLOAT typu Float

Adres: GFLOAT

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: G_04

Opis: tag globalny GSTRING10 typu String

Adres: GSTRING10

Kanał: KANAL1

Liczba elementów: 10

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Nazwa: L_01

Opis: tag lokalny Prg1.TINT typu Float

Adres: Program:Prg1.TINT

Kanał: KANAL1

Liczba elementów: 11

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: L_02

Opis: tag lokalny Prg2.TBOOL typu Boolean

Adres: Program:Prg2.TBOOL

Kanał: KANAL1

Liczba elementów: 11

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Możliwy jest także dostęp do elementów tablic:

Nazwa: G_05

Opis: tag globalny GTABINT[1] typu Int

Adres: GTABINT[1]

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

fragmentów lub całych tablic:

Nazwa: G_06

Opis: 10 pierwszych elementów tablicy GTABFP

Adres: GTABFP[0]

Kanał: KANAL1

Liczba elementów: 10

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

oraz dostęp do elementów struktur:

Nazwa: G_07

Opis: dostęp do pola ACC struktury TIMER

Adres: GTIMER.ACC

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_DW

Szybkie odświeżanie zmiennych

Zmienne, które mają ustawiony atrybut Szybkie Odswiezanie są przez drajwer odświeżane z okresem określonym przez opcję Okres szybkiego odświeżania. Odczytane w tym trybie wartości zmiennych są wpisywane bezpośrednio do cache’a Asmena, powalając tym samym na uzyskanie efektu szybkiego odświeżania elementów wizualizacyjnych aplikacji.

Szybkie odświeżanie jest wykorzystywane wyłącznie przez elementy wizualizacyjne aplikacji.

Testowanie komunikacji

Zakładka CipAB / Parametry drajwera - UniDriver pozwala określić parametry dotyczące szczegółowych informacji o błędach oraz informacji diagnostycznych. Informacje te zapisywane są w pliku o nazwie UniDriver.<bieżąca data>.log.

Parametry umieszczone na zakładkach Parametry drajwera - UniDriver obowiązują wszystkie kanały, które mają w deklaracji drajwera taką zakładkę. Parametry ustawione na zakładce Parametry drajwera - UniDriver w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera - UniDriver w definicji pozostałych kanałów.

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

Parametry drajwera

Drajwer jest parametryzowany przy użyciu opcji umieszczonych na zakładkach: CipAB / Parametry drajwera. Opcje te służą do deklaracji:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • adres IP karty komputera, poprzez którą są obsługiwane sterowniki,

  • okres szybkiego odświeżania.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych pomiędzy drajwerem i regulatorami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość opcji: TAK/NIE

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z regulatora.

Wartość opcji:

liczba - czas w milisekundach.

Wartość domyślna: Domyślnie wartość pozycji wynosi 500 milisekund.

R Adres IP komputera

Znaczenie: Opcja służy do określenia adresu karty sieciowej komputera, poprzez którą wszystkie kanały drajwera będą się komunikować z regulatorami.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4.

Wartość domyślna: Jeśli opcja nie jest zadeklarowana, to zostanie użyta karta sieciowa dostarczona przez system.

R Okres szybkiego odświeżania

Znaczenie: służy do określenia okresu odświeżania zmiennych, które mają ustawiony atrybut Szybkie Odświeżanie.

Wartość opcji:

liczba_ms - okres szybkiego odświeżania zmiennych (od 100 do 990).

Wartość domyślna: Domyślnie wartość pozycji wynosi 200 milisekund.

PRZYKŁAD

Przykładowa parametryzacja drajwera:

Drajwer: CipAB

Plik logu=d:\tmp\CtCipAB\ecl.log

Rozmiar pliku logu=20

Log telegramów=TAK

Adres IP komputera: 10.10.110.24

Okres szybkiego odświeżania: 250

Parametry kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach: CipAB / Parametry kanału 2. Opcje te służą do deklaracji:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • adres IP karty komputera, poprzez którą są obsługiwane sterowniki,

  • okres szybkiego odświeżania.

R Plik logu

Znaczenie: Dla celów diagnostycznych kanału służy tekstowy plik logu, do którego są wpisywane komunikaty zawierające treści telegramów wysyłanych i odbieranych w danym kanale.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych w danym kanale. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość opcji: TAK/NIE

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który w danym kanale oczekuje się na nadejście odpowiedzi z regulatora. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość opcji:

liczba - czas w milisekundach.

R Adres IP komputera

Znaczenie: Opcja służy do określenia adresu karty sieciowej komputera, poprzez którą kanał komunikuje się z regulatorem. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4.

R Okres szybkiego odświeżania

Znaczenie: Opcja służy do określenia okresu odświeżania zmiennych, które mają ustawiony atrybut Szybkie Odświeżanie. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość opcji:

liczba_ms - okres szybkiego odświeżania zmiennych (od 100 do 990).

Wartość domyślna: Domyślnie wartość pozycji wynosi 200 milisekund.

PRZYKŁAD

Przykładowa parametryzacja kanału:

Nazwa kanału: KANAL1

Plik logu=d:\logi\kanal1.log

Rozmiar pliku logu=20

Log telegramów=TAK

Adres IP komputera: 10.10.115.25

Timeout odpowiedzi: 750

Okres szybkiego odświeżania: 250


COMLI - drajwer protokołu COMLI

Home > 1.18 COMLI - drajwer protokołu COMLI

1.18 COMLI - drajwer protokołu COMLI

Przenaczenie drajwera

Drajwer COMLI jest przeznaczony do wymiany danych pomiędzy systemem Asix oraz sterownikami SattConXX i sterownikami ABB obsługującymi protokół COMLI (COMmunication LInk). Wymiana danych odbywa się poprzez łącze szeregowe w standardzie RS-232 lub RS-485.

W obecnej wersji drajwera zaimplementowane zostały następujące funkcje protokołu COMLI:

  • Transfer individual I/O bits,

  • Transfer I/O bits or a register,

  • Request individual I/O bits,

  • Request several I/O bits or registers,

  • Transfer date and time,

  • Acknowledge.

Parametryzacja drajwera COMLI realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer COMLI wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: COMLI

Zakładka COMLI:

Parametry kanału:

slave_nr, port [, baud] [,parity] [,typ_danych]

gdzie:

slave_nr - numer slave’a przypisany sterownikowi;

port - nazwa portu szeregowego, przez który będzie realizowane połączenie ze sterownikiem;

baud - opcja: prędkość transmisji; domyślnie 9600;

parity - opcja: kontrola parzystości; domyślnie ODD;

typ_danych - opcja: reprezentacja danych ASCII (ASCII) lub binarna (BINARY). Domyślnie przyjmuje się BINARY.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału transmisji KANAL, służącego do komunikacji ze sterownikiem o numerze 3 przez port COM2 w trybie domyślnym, tzn. 9600 Bd, 8 bitów znaku, kontrola parzystości nieparzysta (ODD), reprezentacja danych binarna:

Kanał: KANAL

Drajwer: COMLI

Parametry kanału: 3, COM2

Typy zmiennych procesowych

W drajwerze zdefiniowano następujące typy zmiennych procesowych:

IO - stany I/O,

RG - wartości rejestrów,

TM - zapis daty i czasu do sterownika.

Wartości zmiennych typu IO oraz RG mogą być czytane i zapisywane, natomiast wartości zmiennych typu TM mogą być wyłącznie zapisywane.

Adres zmiennej procesowej

Adres zmiennej procesowej ma składnię:

<Typ><Index>

gdzie:

Typ - nazwa typu zmiennej,

Index - adres zmiennej w ramach typu zmiennej Typ.

Zakresy indeksów są następujące:

typ IO: 0 - 16383,

typ REG: 0 - 3071,

typ TM: nie podaje się indeksu.

PRZYKŁADY

Przykłady deklaracji zmiennych procesowych:

JJ_1, stan I/O numer 1, IO1, KANAL,1,1,NIC

JJ_2, rejestr numer 10, RG10, KANAL,1,1,NIC

JJ_40, zapis daty i czasu co minutę, TM, KANAL,12,60,NIC_BYTE

Synchronizacja daty i czasu ze sterownikiem

W drajwerze został wbudowany mechanizm synchronizacji daty i czasu pomiędzy systemem Asix i sterownikami.

Synchronizacja jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji SYNCHRONIZACJA_CZASU - która deklarowana jest w Architekcie w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio:

Nazwa sekcji: ASMEN

Nazwa opcji: SYNCHRONIZACJA_CZASU

Wartość opcji: kanał, zmienna

gdzie:

kanał - nazwa kanału transmisji służącego do komunikacji z określonym sterownikiem,

zmienna - nazwa zmiennej Asmena należącej do kanału kanał, służącej do synchronizacji daty i czasu.

Synchronizacja daty i czasu polega na cyklicznym zapisie do sterownika ramki zawierającej aktualną datę i czas Asixa. Ramka jest zapisywana przy użyciu wbudowanej funkcji zapisu daty i czasu protokołu COMLI, zgodnie z częstością przypisaną zmiennej. Typem zmiennej musi być typ TM (obsługa daty i czasu); liczba elementów przypisana zmiennej musi mieć rozmiar 12 (rozmiar ramki daty i czasu). Jako funkcji przeliczającej należy użyć NIC_BYTE.

PRZYKŁAD

Poniżej podano przykład definicji synchronizacji czasu co 1 minutę dla kanału KANAL przy użyciu zmiennej SYNCHRO:

Deklaracja kanału:

Nazwa: KANAL

Drajwer: COMLI

Parametry kanału: 2, COM1

Deklaracja synchronizacji:

Nazwa sekcji: ASMEN

Nazwa opcji: DANE

Wartość opcji: COMLI.DAT

Nazwa sekcji: ASMEN

Nazwa opcji: SYNCHRONIZACJA_CZASU

Wartość opcji: KANAL, SYNCHRO

Deklaracja zmiennej SYNCHRO znajduje się w pliku COMLI.DAT i ma następującą postać:

SYNCHRO, synchronizacja daty i czasu, TM, KANAL, 12, 60, NIC_BYTE

Parametry drajwera

Parametry drajwera COMLI deklarowane sa w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

R Nazwa sekcji: COMLI

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: slave_nr, liczba

Znaczenie: dla każdego slave’a można określić maksymalny czas, jaki może upłynąć pomiędzy wysłaniem zapytania i otrzymaniem odpowiedzi (tzw. timeout odbioru).

Wartość domyślna: domyślnie opcja przyjmuje wartość 2000.

Parametry:

slave_nr - numer slave’a nadany sterownikowi,

liczba - wartość timeout’u wyrażona w milisekundach.

R Nazwa sekcji: COMLI

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera oraz informacje o zawartości telegramów wysłanych/odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: COMLI

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - wartość wyrażona w MB.

Wartość domyślna: opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Nazwa sekcji: COMLI

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych/odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: drajwer nie wpisuje do pliku logu treści telegramów.

R Nazwa sekcji: COMLI

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie: pozwala określić max. liczbę prób wykonania polecenia w przypadku błędów transmisji.

Wartość domyślna: domyślnie wykonywane są max. trzy powtórzenia.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CPIII – drajwer do komunikacji z panelami kontrolnymi

Home > 1.19 CPIII – drajwer do komunikacji z panelami kontrolnymi CP-III/E

1.19 CPIII - drajwer do komunikacji z panelami kontrolnymi CP-III/E, wykorzystywanymi do sterowania sprężarkami firmy MYCOM (MAYEKAWA)

Przeznaczenie drajwera

Drajwer CPIII służy do wymiany danych pomiędzy systemem Asix i panelami kontrolnymi CP-III/E, wykorzystywanymi do sterowania sprężarkami firmy MYCOM (MAYEKAWA). Komunikacja realizowana jest przy pomocy łączy szeregowych w standardzie RS-485.

Drajwer realizuje następujące funkcje:

  • odczyt bieżących wartości analogowych i dwustanowych,

  • odczyt i zapis wartości zadanych,

  • odczyt alarmów i zgłaszanie ich do systemu alarmów Asixa.

Parametryzacja drajwera CPIII realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera CPIII wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CPIII

Zakładka CPIII / Parametry kanału:

Identyfikacja:

Adres urządzenia w sieci;

Port:

Port;

Parametry transmisji:

Prędkość transmisji w bodach;

Liczba bitów w znaku;

Kontrola parzystości (n-brak, e-parzystość, o-nieparzystość, m-mark, s-space);

Liczba bitów stopu.

Jeśli parametry transmisji są pominięte, to przyjmuje się następujące wartości: 9600,7,e,1

Pierwszy alarm:

Numer pierwszego alarmu

Przykładowa deklaracja kanału:

Drajwer: CPIII

Parametry kanału:

Adres urządzenia w sieci: 10,

Port: COM1

Deklaracja zmiennych

Adresacja zmiennych drajwera CPIII powstała na podstawie opisu protokołu komunikacyjnego urządzenia CPIII, jednak wartości poszczególnych zmiennych różnią się w stosunku do tych w opisie protokołu. W szczególności nie należy stosować mnożników opisanych w protokole, ponieważ drajwer wykonuje już stosowne operacje mnożenia/dzielenia.

Tabela. Deklaracja adresu zmiennych drajwera CPIII.

Adres | Znaczenie | Funkcja przeliczająca typu NIC_xxx
D1 | Wejście analogowe 1 | NIC_FP
D2 | Wejście analogowe 2 | NIC_FP
D3 | Wejście analogowe 3 | NIC_FP
D4 | Wejście analogowe 4 | NIC_FP
D5 | Wejście analogowe 5 | NIC_FP
D6 | Wejście analogowe 6 | NIC_FP
D7 | Wejście analogowe 7 | NIC_FP
D8 | Wejście analogowe 8 | NIC_FP
D9 | Wejście analogowe 9 | NIC_FP
D10 | Wejście analogowe 10 | NIC_FP
D11 | Wejście analogowe 11 | NIC_FP
D12 | Wejście analogowe 12 | NIC_FP
D13 | Wejście analogowe 13 | NIC_FP
D14 | Wejście analogowe 14 | NIC_FP
D15 | Wejście analogowe 15 | NIC_FP
D16 | Wejście analogowe 16 | NIC_FP
D17 | Czas pracy w godzinach | NIC_DW
D18 | Tak jak D17 | NIC_DW
D19 | Capacity control manipulated value (MV), calculated by PID controller, wanted slide valve position. | NIC_FP
D20 | Superheat process value (PV); actual value of evaporator superheat in case of temperature control. example: chiller unit equipped with linear expansion valve. | NIC_FP
D21 | Superheat manipulated value (MV), calculated by PID controller. | NIC_FP
D22 | Liquid injection process value PV. | NIC_FP
D23 | Liquid injection manipulated value (MV), calculated by PID controller. | NIC_FP
D24 | fixed data: 000000 | NIC_FP
D25 | Setpoint unit start, cut-in value for controller. (Odpowiednik danej D1 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII). | NIC_FP
D26 | Setpoint unit stop, cut-out value for controller. (Odpowiednik danej D2 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII). | NIC_FP
D27 | Capacity control setpoint. (Odpowiednik danej D3 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII). | NIC_FP
D28 | Setpoint superheat control - only applicable in case of temperature control. (Odpowiednik danej D4 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII) | NIC_FP
D29 | Setpoint Liquid Injection, setpoint for liquid injection oil cooling. (Odpowiednik danej D5 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII). | NIC_FP
D30 | fixed data : 000000 | NIC_FP
D31 | Bieżący tryb pracy: 10 : manual mode 15 : manual mode + datacomms on 20 : auto 25 : auto mode + datacomms on 30 : remote mode 35 : remote mode + datacomms on 40 : remote - auto mode 45 : remote -auto mode + datacomms on | NIC_BYTE
D31.n | Bieżący tryb pracy w rozbiciu na poszczególne elementy: D31.0 - ma wartość 1 dla trybu automatycznego a 0 w przypadku ręcznego D31.1 - ma wartość 1 dla trybu "datacomms" a 0 w przeciwnym wypadku D31.2 - ma wartość 1 dla trybu zdalnego (”remote”) a 0 w przeciwnym wypadku | NIC_BYTE
D32 | Wejścia cyfrowe | NIC_DW
D32.n | Pojedynczy bit wejścia cyfrowego. "n" może przyjmować wartości od 0 do 31. Odpowiada to wejściom cyfrowym z zakresu od 1 do 32. Np. D32.0 odpowiada wejściu cyfrowemu 1. Zmienna przyjmuje wartość 1, jeśli dane wejście cyfrowe jest ustawione, a 0 w przeciwnym wypadku. | NIC_BYTE
D33 | Status wszystkich alarmów. | NIC_DW
D33.n | Status pojedynczego alarmu. Zmienna przyjmuje wartość 1, jeśli dany alarm jest aktywny, a 0 w przeciwnym wypadku. Liczba "n" identyfikuje pojedynczy alarm i jest numerem bitu w słowie statusowym alarmów w zakresie od 0 do 31. Przykłady: D33.0 - "start fail" (słowo statusu alarmów 00000001) D33.1 - "oil pressure low" (słowo statusu alarmów 00000002) D33.2 - "discharge pressure high" (słowo statusu alarmów 00000004) D33.3 - "discharge temperature high" (słowo statusu alarmów 00000008) itd. | NIC_BYTE
D100 | Sterowanie specjalne. Zmienna przyjmuje wartości: 0 - "remote start" OFF & "100% lock" OFF 1 - "remote start" OFF & "100% lock" ON 2 - "remote start" ON & '100% lock" OFF 3 - "remote start" ON & "100% lock" ON (Odpowiednik danej D6 w poleceniu zapisu nastaw protokołu komunikacyjnego urządzenia CPIII). | NIC_BYTE
D100.n | Sterowanie specjalne w rozbiciu na poszczególne elementy. D100.0 - "100% lock" D100.1 - "remote start" Starowaniu OFF odpowiada 0, a sterowaniu ON odpowiada wartość 1. | NIC_BYTE

Generacja alarmów

Drajwer urządzenia CPIII z interwałem nie dłuższym niż wartość określona parametrem Okres_sprawdzania_zdarzen sprawdza stan list zdarzeń urządzenia i generuje alarmy dla wszystkich nowo odkrytych zdarzeń. Sprawdzenie alarmów dokonuje się przy każdym odczycie danych z urządzenia, także wtedy, gdy z urządzenia czytane są dane w celu odświeżenia wartości zmiennych. A więc sprawdzenie stanu alarmów może być dokonywane częściej, niż określa to parametr Okres_sprawdzania_zdarzen, jeśli istnieją zmienne, których okres odświeżania jest krótszy niż wartość tego parametru. Numer alarmu systemu Asix tworzony jest jako suma numeru bitu w słowie statusowym alarmów urządzenia CPIII i wartości określonej parametrem Pierwszy_alarm. Jeśli nie podano parametru Pierwszy_alarm, to alarmy nie będą generowane.

Generując alarm, drajwer przekazuje adres urządzenia CPIII jako parametr tego alarmu. Adres ten można wykorzystać w tekście skojarzonym z danym alarmem.

Przykład:

Jeśli parametr Pierwszy_alarm ma wartość 5 i wystąpi alarm o nazwie ’start fail’, którego maska w słowie statusowym alarmów ma wartość 00000001 (bit nr 0), to zostanie wygenerowany alarm o numerze 5. Jednocześnie zmienna o adresie D33.0 przyjmie wartość 1.

Parametry kanału / drajwera CPIII

Parametry drajwera CPIII deklarowane są w programie Architekt, na zakładkach Parametry kanału oraz Parametry drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

Parametry ustawiane na zakładkach Parametry kanału dotyczą konkretnego urządzenia z danego kanału.

R Nazwa sekcji: CPIII

R Nazwa opcji: Pierwszy alarm

R Wartość opcji: liczba

Znaczenie - parametr pozwala określić numerację alarmów. Po dodaniu wartości tego parametru do numeru bitu w słowie statusowym alarmów otrzymuje się numer alarmu w systemie Asix. Bity numerowane są od 0.

Wartość domyślna - -1 (brak obsługi alarmów).

Parametr:

liczba - parametr musi być liczbą dodatnią.

R Nazwa sekcji: CPIII

R Nazwa opcji: Alarmy globalne

R Wartość opcji: TAK/NIE

Znaczenie - pozycja steruje sposobem przekazywania alarmów odczytanych z urządzeń zdalnych do systemu alarmów systemu Asix.

Wartość domyślna - domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości pozycji Alarmy_globalne na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili().

R Nazwa sekcji: CPIII

R Nazwa opcji: Okres sprawdzania zdarzeń

R Wartość opcji: liczba

Znaczenie - okres czasu w sekundach pomiędzy sprawdzeniem stanu zdarzeń i generacji alarmów.

Wartość domyślna - 30

R Nazwa sekcji: CPIII

R Nazwa opcji: Plik logu

R Wartość opcji: nazwa_pliku[,maksymalny_rozmiar]

Znaczenie - pozycja pozwala na zdefiniowanie pliku, do którego będą zapisywane komunikaty diagnostyczne dotyczące danego kanału CPIII oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer CPIII. Jeśli pozycja LOG nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu;

maksymalny_rozmiar - maksymalny rozmiar pliku log w megabajtach;

R Nazwa sekcji: CPIII

R Nazwa opcji: Ilość powtórzeń

R Wartość opcji: liczba

Znaczenie - pozycja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - 3

R Nazwa sekcji: CPIII

R Nazwa opcji: Timeout

R Wartość opcji: liczba

Znaczenie - określa maksymalny czas oczekiwania na odpowiedź urządzenia.

Wartość domyślna - 500

Parametr:

Liczba - czas wyrażony w milisekundach;

R Nazwa sekcji: CPIII

R Nazwa opcji: Sterowanie Specjalne

R Wartość opcji: liczba

Znaczenie - parametr określa domyślną wartość zmiennej D100 w sytuacji, gdy drajwer otrzymał pierwsze polecenie zapisu zmiennej z zakresu D25-D29. Wartości wszystkie zmiennych do zapisu, tj. D25-D29 oraz D100 zapisywane są jednocześnie w czasie jednej operacji transmisji. Przed wykonaniem takiej operacji drajwer odczytuje wartości zmiennych D25-D29 i przesyła je do urządzenia w niezmienionej postaci z wyjątkiem zmiennej, której wartość polecono zmienić. A zatem zmianie ulega jedynie wartość żądanej zmiennej. W przypadku zmiennej D100 nie jest możliwy odczyt jej poprzedniej wartości a jakąś wartość należy do urządzenia wysłać. Parametr określa wartość zmiennej D100 w powyższej sytuacji. Parametr nie ma znaczenia, jeśli pierwsza operacja zapisu dotyczy właśnie zmiennej D100, tzn. gdy użytkownik określił jej wartość przed zmianą wartości pozostałych zmiennych.

Wartość domyślna - 0

R Nazwa sekcji: CPIII

R Nazwa opcji: Sterowanie Ciśnieniem

R Wartość opcji: TAK/NIE

Znaczenie - parametr określa mnożnik stosowany przy odczycie/zapisie zmiennych. D25, D26 i D27. Jeśli podano ’Tak’, to mnożnik wynosi 100, a jeśli podano ’Nie’, to mnożnik ma wartość 10.

Wartość domyślna - ’Nie’

Przykład parametryzacji drajwera:

Deklaracja kanałów:

Nazwa: CPIII_1

Parametry kanału: 5, COM1,57600,8,none,1

Nazwa: CPIII_2

Parametry kanału: 5, COM2

Nazwa: CPIII_3

Parametry kanału: 6, COM2

Deklaracje parametrów:

R Nazwa sekcji: CPIII

R Nazwa opcji: Alarmy_globalne

R Wartość opcji: TAK

R Nazwa sekcji: CPIII

R Nazwa opcji: Okres_sprawdzania_zdarzen

R Wartość opcji: 60

R Nazwa sekcji: CPIII_2

R Nazwa opcji: Okres_sprawdzania_zdarzen

R Wartość opcji: 30

Parametr Alarmy_globalne dotyczy wszystkich urządzeń. Parametr Okres_sprawdzania_zdarzen umieszczony w sekcji CPIII określa 60 sekundowy interwał czasu, z jakim będzie dokonywana kontrola alarmów na wszystkich urządzeniach z wyjątkiem urządzenia kanału o nazwie CPIII_2, ponieważ w sekcji CPIII_2 określono, że w przypadku tego urządzenia interwał wynosi 30 sekund.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CZAZ – drajwer do komunikacji z urządzeniami CZAZ-U oraz

Home > 1.20 CZAZ – drajwer do komunikacji z urządzeniami CZAZ-U oraz CZAZ-UM

1.20 CZAZ - drajwer do komunikacji z urządzeniami CZAZ-U oraz CZAZ-UM

Przeznaczenie drajwera

Drajwer CZAZ przeznaczony jest do komunikacji z urządzeniami CZAZ-U oraz CZAZ-UM.

Parametryzacja drajwera CZAZ realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer CZAZ wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CZAZ

Zakładka CZAZ:

Parametry kanału:

adres, port,[body,znak,parzystosc,stop]

gdzie:

adres - adres urządzenia w sieci;

Port,[body.... - parametry drajwera CZAZ

Przykładowa deklaracje kanału:

Nazwa: ASMEN

Parametry kanału: 10, COM1,115200,8,none,1

Deklaracja zmiennych

Deklaracja adresu zmiennych drajwera CZAZ ma postać:

identyfikator_obiektu[.nr_elementu[nr_bitu]]

gdzie:

identyfikator_obiektu | - | szesnastkowy identyfikator obiektu wg dokumentacji urządzenia CZAZ. Zamiast numeru można również użyć nazwy obiektu.
nr_elementu | - | numer elementu wewnątrz obiektu. Pierwszy element ma numer 0. Jeśli identyfikator_obiektu jest pominięty to przyjmuje się 0.
nr_bitu | - | numer bitu wewnątrz elementu. Pierwszy bit ma numer 0.

Przykład

W dokumentacji urządzenia CZAZ występuje obiekt 0102 o nazwie Signal, który zawiera trzy elementy: Signal1, Signal2 i Signal3.

Adres | Znaczenie
102 | Pierwszy element obiektu - Signal1 (jako słowo 32-bitowe)
0102 | jw.
Signal | jw.
102.0 | jw.
Signal.0 | jw.
102.1 | Drugi element obiektu 102 - Signal2 (jako słowo 32-bitowe)
102.1.4 | Bit o nazwie SPZ5 w drugim elemencie obiektu 102

Zmienne odnoszące się do obiektów typu 0B są elementami 8-bitowymi (funkcja przeliczająca NIC_BYTE).

Zmienne odnoszące się do obiektów typu 2B są słowami 16-bitowymi (funkcja przeliczająca NIC).

Zmienne odnoszące się do obiektów typu 4B są słowami 32-bitowymi (funkcja przeliczająca NIC_DW).

Zmienne dotyczące pojedyńczych bitów w obiektach są elementami 8-bitowymi (funkcja przeliczająca NIC_BYTE).

Zmienne dotyczące elementów obiektów typu ULONG są słowami 32-bitowymi (funkcja przeliczająca NIC_DW).

Zmienne dotyczące elementów obiektów typu UWORD są słowami 16-bitowymi (funkcja przeliczająca NIC_DW).

Perwszy element obiektu 0110 (Liczniki) jest słowem 32-bitowym (funkcja przeliczająca NIC_DW) a pozostałe elementy są słowami 16-bitowymi (funkcja przeliczająca NIC).

Drajwer zezwala na dostęp do pierwszego elementu obiektu 0004 (Czas). Jest to liczba 32-bitowa (funkcja przeliczająca NIC_DW). Wyświetlając ten element na masce procesowej można użyć obiektu "Liczba” oraz formatu %D. Drajwer zezwala na zapis takiej zmiennej do urządzenia i ustawienie w ten sposób jego czasu. Ilość milisekund obiektu 0004 nie jest dostępna.

Drajwer zezwala na dostęp do następujących obiektów: 0001, 0002, 0004, 0011, 0012, 0013, 0014, 0100, 0101, 0102, 0105, 0110, 0111, 0112, 0114, 0115, 0119, 011B, 011D, 011E, 0120, 0121, 0125, 0126, 0200, 0201, 0202, 0203, 0204, 0208, 0209, 020A, 020B, 020D, 020E, 020F, 0210, 0211, 0212, 0213, 0221, 0222, 0223, 0224, 0225, 0227, 0228, 0229, 022A, 022C, 022D, 0230, 0231, 0232, 0233, 0234, 0235, 0236, 0300, 0311, 0312, 0313, 0314, 031A, 0320, 0321, 0330, 0400, 0401, 0402, 0500, 0501, 0502 oraz 0503.

Generacja alarmów

Drajwer urządzenia CZAZ z interwałem określonym parametrem "Okres_sprawdzania_zdarzen” sprawdza stan list zdarzeń urządzenia i generuje alarmy dla wszystkich nowo odkrytych zdarzeń. Numer alarmu systemu Asix tworzony jest jako suma numeru zdarzenia urządzenia CZAZ i wartości określonej parametrem "Pierwszy_alarm”. Bufor zdarzeń urządzenia CZAZ może zawierać do 500 nowych zdarzeń. Dla każdego z nich generowany jest alarm początku i końca zdarzenia. Zatem dla każdego łącza szeregowego do którego przyłączone są urządzenia CZAZ może zostać wygenerowanych 1000 alarmów jednocześnie podczas gdy, domyślny rozmiar bufora alarmów systemu Asix wynosi 200. Aby nie dochodziło do utraty alarmów, wielkość tego bufora należy ustawić za pomocą parametru "ROZMIAR_BUFORA_WEJSCIOWEGO” sekcji "SYSTEM_ALARMOW”.

Parametry drajwera

Parametry drajwera CZAZ deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametry drajwera można umieszczać w sekcji o nazwie 'CZAZ’ oraz w sekcjach o nazwach takich samych jak nazwa kanału. W sekcji 'CZAZ’ umieszcza się parametry globalne, dotyczące wszystkich urządzeń. W pozostałych sekcjach umieszcza się parametry dotyczące poszczególnych urządzeń. Niektóre parametry mogą występować jedynie w sekcji 'CZAZ’ inne mogą występować we wszystkich sekcjach.

Przykład

Deklaracja kanałów:

Nazwa: CZAZ1

Parametry kanału: 10, COM1,57600,8,none,1

Nazwa: CZAZ2

Parametry kanału: 10, COM2,57600,8,none,1

Nazwa: CZAZ3

Parametry kanału: 10, COM2,57600,8,none,1

Parametry drajwera:

R Nazwa sekcji: CZAZ

R Nazwa opcji: Alarmy_globalne

R Wartość opcji: tak

R Nazwa sekcji: CZAZ

R Nazwa opcji: Synchronizacja_Czasu

R Wartość opcji: 50

R Nazwa sekcji: CZAZ1

R Nazwa opcji: Synchronizacja_Czasu

R Wartość opcji: 120

Parametr "Alarmy_globalne” dotyczy wszystkich urządzeń. Ponieważ nie przewidziano indywidualnej parametryzacji urządzeń w tym zakresie, to może on występować jedynie w sekcji 'CZAZ’. Parametr "Synchronizacja_Czasu” umieszczony w sekcji 'CZAZ’ określa 50 sekundowy interwał czasu z jakim będzie dokonywana kontrola czasu wszystkich urządzeń z wyjątkiem urządzenia kanału o nazwie CZAZ1, ponieważ w sekcji 'CZAZ1’ określono, że w przypadku tego urządzenia interwał wynosi 120 sekund.

W poniższej tabeli zamieszczono parametry drajwera CZAZ. Jeśli w opisie parametru znajduje się zapis "parametr globalny” to oznacza to, że ten parametr moży wystąpić tylko w sekcji 'CZAZ’.

R Nazwa sekcji: CZAZ

R Nazwa opcji: Pierwszy_alarm

R Wartość opcji: liczba

Znaczenie: parametr pozwala określić numerację alarmów indywidualnie dla każdego urządzenia.

Wartość domyślna: -1 (brak obsługi alarmów).

R Nazwa sekcji: CZAZ

R Nazwa opcji: Alarmy_globalne

R Wartość opcji: TAK/NIE

Znaczenie: parametr steruje sposobem przekazywania alarmów odczytanych z urządzeń zdalnych do systemu alarmów systemu Asix; parametr globalny

Wartość domyślna: domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości pozycji Alarmy_globalne na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili().

R Nazwa sekcji: CZAZ

R Nazwa opcji: Okres_sprawdzania_zdarzen

R Wartość opcji: liczba

Znaczenie: okres czasu w sekundach pomiędzy sprawdzeniem stanu zdarzeń i generacji alarmów w dwóch kolejnych urządzeniach przyłączonych do tego samego portu szeregowego; parametr globalny

Wartość domyślna: 10

R Nazwa sekcji: CZAZ

R Nazwa opcji: Numer_pola

R Wartość opcji: numer_pola

Znaczenie: parametr określa numer pola dla danego urządzenia. Jest on przekazywany jako parametr alarmu

Wartość domyślna: -1

R Nazwa sekcji: CZAZ

R Nazwa opcji: Plik_logu

R Wartość opcji: nazwa_pliku

Znaczenie: parametr pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera CZAZ oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer CZAZ. Jeśli pozycja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix; parametr globalny

Wartość domyślna: domyślnie nie tworzy się pliku logu

R Nazwa sekcji: CZAZ

R Nazwa opcji: Zwloka_transmisji

R Wartość opcji: liczba

Znaczenie: parametr pozwala określić odstęp czasu (jako wielokrotność 10 msek) pomiędzy kolejnymi operacjami na magistrali CZAZ; parametr globalny

Wartość domyślna: domyślnie pozycja przyjmuje wartość 1 (10 msek)

R Nazwa sekcji: CZAZ

R Nazwa opcji: Liczba_powtorzen

R Wartość opcji: liczba

Znaczenie: parametr pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji; parametr globalny

Wartość domyślna: 3

R Nazwa sekcji: CZAZ

R Nazwa opcji: Timeout_odbioru

R Wartość opcji: liczba

Znaczenie: Określa maksymalny czas oczekiwania w milisekundach na odpowiedź urządzenia

Wartość domyślna: 1000

R Nazwa sekcji: CZAZ

R Nazwa opcji: Synchronizacja_Czasu

R Wartość opcji: liczba

Znaczenie: Parametr określa czas w sekundach pomiędzy kolejnymi odczytami czasu z urządzenia. Jeśli parametr ma wartość 0, to czas nie jest odczytywany a wszystkie zmienne otrzymują stempel czasu systemu Windows

Wartość domyślna: 600

R Nazwa sekcji: CZAZ

R Nazwa opcji: Roznica_Czasu

R Wartość opcji: liczba

Znaczenie: Parametr określa różnicę czasu w milisekundach pomiędzy czasem urządzenia a czasem systemu Windows po przekroczeniu której nastąpi ustawienie czasu w urządzeniu CZAZ i jego zrównanie z czasem systemu Windows. Parametr ma znaczenie tylko wtedy, gdy parametr "Synchronizacja_Czasu” jest różny od zera

Wartość domyślna: 0 (czas w urządzeniu Czaz nie jest zmieniany)

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DataPAF - drajwer protokołu miernika energii

Home > 1.21 DataPAF - drajwer protokołu miernika energii DataPAF

1.21 DataPAF - drajwer protokołu miernika energii DataPAF

Przeznaczenie drajwera

Drajwer DataPAF przeznaczony jest do komunikacji z licznikami energii DataPAF wyposażonymi w EPROM 2.1 13.Aug.96 (lub nowszy). Do komunikacji wykorzystywane jest łącze COM komputera.

Parametryzacja drajwera DataPAF realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DataPAF wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DataPAF

Zakładka DataPAf:

Parametry kanału:

COMn

gdzie:

COMn - numer portu szeregowego, do którego podłączony jest licznik energii DataPAF.

Każdy zdefiniowany kanał może mieć swoją sekcję, której nazwa jest nazwą logiczną kanału. Zawiera ona parametry danego kanału. Kilka kanałów może mieć wspólny port szeregowy.

Także dany port COMn może mieć swoją sekcję o nazwie [DataPAF:n]. Definiuje ona parametry portu szeregowego.

Definiowanie zmiennych

PRZYKŁAD

Przykład definicji zmiennych Asmena:

3010E15m1, DATAPAF Średnia 15min energii kan. 1, XEN1, KANAL1, 1, 60, NIC_FP

3010EBDSH, DATAPAF suma energii biernej kanałów w pop.okres, PEN11.8, KANAL1, 1, 3600, NIC_FP

Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DataPAF

c - oznacza numer kanału 1..30

s - strefa czasowa 0..8

Tabela. Lista wszystkich typów zmiennych obsługiwanych przez drajwer DataPAF.

Tabela. Lista wszystkich typów zmiennych obsługiwanych przez drajwer DataPAF.

Dane historyczne

Dane historyczne są dostępne dla następujących typów zmiennych: POF, IMP, BRK i XEN.

Parametry drajwera DataPAF

Parametry drajwera DataPAF deklarowane sa w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Wartości domyślne dla poszczególnych łącz szeregowych pobierane są z sekcji o nazwie DataPAF, o ile taka istnieje. Sekcja ta parametryzuje wszystkie kanały dla protokołu DataPAF, które są zadeklarowane dla danego systemu.

R Nazwa sekcji: DataPAF

R Nazwa opcji: NUMER

R Wartość opcji: liczba

Znaczenie: określa numer identyfikacyjny licznika DataPAF; podanie nieprawidłowego numeru uniemożliwia komunikację.

Wartość domyślna: 1234.

R Nazwa sekcji: DataPAF

R Nazwa opcji: SZYBKOSC

R Wartość opcji: liczba

Znaczenie: określa szybkość transmisji.

Wartość opcji: liczba - wartość wyrażona w Bd.

Wartość domyślna: 4800.

R Nazwa sekcji: DataPAF

R Nazwa opcji: PARZYSTOSC

R Wartość opcji: parametr_parzystości

Znaczenie: określa parzystość.

Wartość domyślna: N.

Parametry:

parametr_parzystości - określa parzystość; dopuszczalne wartości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

s - space.

R Nazwa sekcji: DataPAF

R Nazwa opcji: BITY_STOPU

R Wartość opcji: liczba

Znaczenie: określa ilość bitów stop.

Wartość opcji: liczba - dopuszczalne wartości to 1 i 2

Wartość domyślna: 1.

R Nazwa sekcji: DataPAF

R Nazwa opcji: SLOWO

R Wartość opcji: liczba

Znaczenie: określa długość słowa - ilość bitów.

Wartość opcji: liczba - dopuszczalne wartości mieszczą się w przedziale od 5 do 8.

Wartość domyślna: 8.

R Nazwa sekcji: DataPAF

R Nazwa opcji: TIMEOUT

R Wartość opcji: liczba

Znaczenie: pozwala określić czas oczekiwania na odpowiedź DataPAF’a.

Wartość opcji: liczba - czas wyrażony w milisekundach.

Wartość domyślna: 1000.

R Nazwa sekcji: DataPAF

R Nazwa opcji: ILOSC_POWTORZEN

R Wartość opcji: liczba

Znaczenie: pozwala określić ilość powtórzeń operacji komunikacyjnych zakończonych błędem.

Wartość domyślna: 3.

R Nazwa sekcji: DataPAF

R Nazwa opcji: MAKSYMALNA_ROZNICA_CZASU

R Wartość opcji: liczba

Znaczenie: pozwala określić maksymalną różnicę pomiędzy czasem systemu Asix a czasem licznika DataPAF, po przekroczeniu której będą wyprowadzane ostrzeżenia do panelu kontrolnego; czas stacji odczytywany jest z przerwą określoną przez parametr SPRAWDZANIE_CZASU.

Wartość opcji: liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: 60.

R Nazwa sekcji: DataPAF

R Nazwa opcji: SPARWADZANIE_CZASU

R Wartość opcji: liczba

Znaczenie: interwał z jakim odczytywany jest bieżący czas licznika.

Wartość opcji: liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: 180.

R Nazwa sekcji: DataPAF

R Nazwa opcji: SPARWADZANIE_OKRESU

R Wartość opcji: liczba

Znaczenie: interwał z jakim sprawdzana jest zmiana bieżącego okresu obliczeniowego licznika.

Wartość opcji: liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: 180.

R Nazwa sekcji: DataPAF

R Nazwa opcji: MAKSYMALNA_HISTORIA

R Wartość opcji: liczba

Znaczenie: pozwala zdefiniować okres czasu liczony od bieżącej chwili wstecz, dla którego będą odczytywane dane historyczne znajdujące się w pamięci stacji.

Wartość opcji: liczba - wartość czasu wyrażona w dniach.

Wartość domyślna: 35.

R Nazwa sekcji: DataPAF

R Nazwa opcji: USUWANIE_BUFOROW_HISTORYCZNYCH

R Wartość opcji: liczba

Znaczenie: opcja określa czas, po jakim usuwane są bufory zawierające dane historyczne odczytane na potrzeby modułu archiwizującego.

Wartość opcji: liczba - wartość czasu wyrażona w minutach.

Wartość domyślna: 120.

R Nazwa sekcji: DataPAF

R Nazwa opcji: CRC16

R Wartość opcji: TAK/NIE

Znaczenie: opcja pozwala określić, czy w komunikacji z licznikiem ma być wykorzystywana kontrola poprawności CRC16. Jeżeli zostanie określona wartość NIE, obliczana będzie suma kolejnych bajtów.

Wartość domyślna: TAK.

R Nazwa sekcji: DataPAF

R Nazwa opcji: LOG

R Wartość opcji: nazwa_pliku

Znaczenie: opcja pozwala określić nazwę pliku, do którego będą zapisywane dodatkowe informacje diagnostyczne.

Wartość domyślna: brak.

R Nazwa sekcji: DataPAF

R Nazwa opcji: KOD_ALARMU

R Wartość opcji: liczba

Znaczenie: opcja określa numer alarmu generowanego przez drajwer w przypadku utraty i odzyskania łączności ze stacją; w sytuacji utraty połączenia, razem z kodem alarmu przekazywana jest liczba charakteryzująca przyczynę utraty połączenia:

0 - zupełny brak jakiejkolwiek odpowiedzi ze strony stacji,

1 - timeout,

2 - błędy linii (błędy ramki, parzystości, overrun)

3 - błędy sumy kontrolnej,

4 - inne błędy;

Liczba ta określa status zakończenia ostatniej próby nawiązania łączności.

Wartość domyślna: brak.

R Nazwa sekcji: DataPAF

R Nazwa opcji: DIAGNOSTYKA

R Wartość opcji: liczba

Znaczenie: zadeklarowanie tej opcji spowoduje wyprowadzenie do pliku logu informacji diagnostycznych związanych z synchronizacją czasu.

Wartość opcji: liczba 4

Wartość domyślna: 0.

R Nazwa sekcji: DataPAF

R Nazwa opcji: SYSTEM_SYNC

R Wartość opcji: liczba

Znaczenie: umożliwia zadeklarowanie minimalnej różnicy czasu pomiędzy czasem systemu Asix a czasem sterownika DataPAF, dla którego następuje synchronizacja czasu systemu z czasem licznika.

Wartość opcji: liczba - wartość czasu w sekundach; jeżeli parametr ma wartość 0, czasy nie są synchronizowane.

Wartość domyślna: 0.

R Nazwa sekcji: DataPAF

R Nazwa opcji: NIEWAZNOSC_ENERGII

R Wartość opcji: liczba

Znaczenie: pozwala określić sytuacje, w których status wartości zmiennej XEN przyjmuje wartość błędu i jest sumą następujących wartości:

1 - błąd, gdy krótki zanik napięcia,

2 - błąd, gdy długi zanik napięcia,

4 - błąd, gdy przerwa w linii wejściowej licznika impulsów;

Wartość domyślna: 0.

R Nazwa sekcji: DataPAF

R Nazwa opcji: mult:

R Wartość opcji: liczba

Znaczenie: określa wartość wszystkich wejściowych współczynników. Współczynniki wejściowe używane są do przeliczania energii na podstawie liczby impulsów. Jeśli parametr mult jest podany, drajwer nie będzie odczytywał wartości współczyników z liczników energii. Jeśli poza parametrem mult używane są również parametry determinujące wartości współczynników dla indywidualnych kanałów (multn), wówczas parametr mult musi być umieszczony przed wszystkimi parametrami multn.

Wartośc opcji: liczba - współczynnik jest liczbą zmiennopozycyjną.

Wartość domyślna: brak.

Nazwa sekcji: DataPAF

Nazwa opcji: multn

Wartość opcji: liczba

Znaczenie: określa wartość wejściowego współczynnika dla kanału n (1-31). Współczynniki wejściowe używane są do przeliczania energii na podstawie liczby impulsów. Jeśli parametr jest podany, drajwer nie będzie odczytywał wartości współczynników z liczników energii. Jeśli parametr mult jest również podany, wówczas parametr mult musi być umieszczony przed wszystkimi parametrami multn.

Wartośc opcji: liczba - współczynnik jest liczbą zmiennopozycyjną.

Wartość domyślna: brak.

Przykłady

Przykładowe parametry drajwera:

Nazwa: KOMIN 2

Drajwer: DataPAF

Parametry kanału:

COM2

Parametry drajwera:

Nazwa sekcji: DataPAF:2

Nazwa opcji: baud

Wartość opcji: 19200

Nazwa sekcji: DataPAF:2

Nazwa opcji: Numer

Wartość opcji: 4800

W powyższym przykładzie zdefiniowano stację o nazwie KOMIN 2 podłączoną do portu COM2. Użyta zostanie prędkość transmisji 19200 bitów na sekundę.

W przypadku synchronizacji czasu stacji Asixa z czasem wybranego licznika - należy w sekcji pliku ini dla danego licznika umieścić definicję tego czasu. Służy do tego parametr system_sync, któremu nadaje się wartość dopuszczalnej różnicy czasów w sekundach.

Deklaracje kanałów:

Nazwa: KANAL1

Drajwer: DataPAF

Parametry kanału:

COM2

Nazwa: KANAL2

Drajwer: DataPAF

Parametry kanału:

COM4

Parametry drajwera:

Nazwa sekcji: KANAL1

Nazwa opcji: system_sync

Wartość opcji: 5

Nazwa sekcji: KANAL1

Nazwa opcji: log

Wartość opcji: DATAPAF.log

Nazwa sekcji: KANAL1

Nazwa opcji: diagnostyka

Wartość opcji: 14

W powyższym przykładzie czas systemu będzie synchronizowany do czasu licznika energii podłączonego portu COM2. Umieszczając w sekcji licznika wartości opcji: diagnostyka=14 oraz log=DATAPAF.log, można uzyskać w pliku DATAPAF.log zapis diagnostyki synchronizacji czasu. Czas synchronizowany jest z dokładnością do 1 sekundy.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


Drajwer DDE

Home > 1.22 DDE

1.22 Drajwer DDE

Przeznaczenie drajwera

Drajwer DDE służy do definiowania kanału modułu ASMEN odwołującego się do zmiennych udostępnianych przez drajwer sterownika przemysłowego zaimplementowanego w postaci serwera DDE (zwanego dalej krótko serwerem DDE).

W aktualnej wersji drajwera definiując kanał modułu ASMEN - oprócz nazwy drajwera DDE należy podać nazwę serwisu rejestrowanego przez serwer DDE i nazwę tematu połączenia DDE. Dzięki kojarzeniu połączenia DDE z kanałem zamiast z każdą zmienną osobno znacznie upraszcza się sposób definiowania zmiennych i definicje zmiennych są bardziej czytelne.

Obsługa grup zmiennych pozwoli drajwerowi DDE otrzymywać dane z serwera DDE w postaci grup zmiennych a nie tylko pojedynczych zmiennych, dzięki czemu może ogromnie wzrosnąć wydajność transmisji danych. Maksymalna wydajność transmisji przy użyciu protokołu DDE wynosi do 150 jednoelementowych grup zmiennych na sekundę (na komputerze Pentium 166 MHz) i spada wolno wraz ze wzrostem rozmiaru grupy. Jeśli grupa zawiera tylko jedną zmienną - to można przesłać 150 zmiennych na sekundę, natomiast jeśli rozmiar grupy wynosi np. 25 zmiennych - to możliwe jest przesyłanie 3000 zmiennych na sekundę.

Serwer DDE w ramach każdego połączenia może udostępniać specjalną zmienną, której wartość określa, czy zmienne pobierane w ramach tego połączenia mają poprawne wartości, czy połączenie ze sterownikiem przemysłowym funkcjonuje poprawnie. Drajwer DDE przyjmuje, że taka specjalna zmienna ma nazwę Status, lecz możliwe jest zdefiniowanie takiej zmiennej osobno dla każdego połączenia DDE.

Parametryzacja drajwera DDE realizowana jest przy użyciu programu Architekt.

Specyfikacja zewnętrzna

Deklaracja kanału transmisyjnego wykorzystującego drajwer DDE wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DDE

Zakładka DDE:

Parametry kanału:

service, topic

gdzie:

service - nazwa serwisu zarejestrowanego przez serwer DDE,

topic - nazwa tematu połączenia obsługiwanego przez serwer DDE.

Nazwy serwisu i tematu połączenia są specyficzne dla każdego drajwera sterownika przemysłowego, zaimplementowanego w postaci serwera DDE i ich opis znajduje się w dokumentacji danego drajwera.

PRZYKŁAD

Poniżej podane są przykładowe deklaracje użycia kanału transmisji pracującego według protokołu DDE:

Nazwa: KanAdam

Drajwer: DDE

Parametry kanału: Adam, E2018

Kanał modułu ASMEN o nazwie KanAdam jest skojarzony z drajwerem DDE i tematem połączenia o nazwie E2018 udostępnianego przez serwer DDE o nazwie Adam.

Nazwa: KanGE

Drajwer: DDE

Parametry kanału: GESNP, GE

Definicje zmiennej

Po uruchomieniu drajwera DDE moduł ASMEN przekazuje mu informacje o zmiennych procesowych pobrane z pliku definicji zmiennych. Definicja zmiennej obsługiwanej przez drajwer DDE ma następującą postać:

zmienna_asmena, opis, "item | numer_w_grupie | typ", nazwa_kanału, ilość, częstość_odświeżania, funkcja_przekształcająca

gdzie:

zmienna_asmena - nazwa zmiennej modułu ASMEN,

item - nazwa zmiennej lub grupy zmiennych udostępnianych przez serwer DDE, maksymalna długość tej nazwy wynosi 255 znaków (255 znaków to maksymalna długość tekstu obsługiwanego przez protokół DDE),

numer_w_grupie - numer zmiennej w grupie zmiennych, do której ma się odnosić zmienna ASMENa; numeracja zaczyna się od 1; jeśli jako item serwer DDE przysyła pojedyncze wartości, to parametr ten powinien mieć wartość 1,

typ - typ zmiennej ASMENa.

Jako parametr typ można podać jedną literę:

S - short,

W - word (słowo),

L - long,

D - double word (podwójne słowo),

F - float.

Określenie typu zmiennej jest konieczne, aby można było dokonać konwersji zmiennej do postaci binarnej używanej przez moduł ASMEN. Dane z serwera DDE przysyłane są w postaci tekstowej i nie jest możliwe jednoznaczne określenie ich typu, dlatego w definicji zmiennej jej typ określany jest jawnie.

Jeżeli zmienna ma być nie tylko czytana ale również zapisywana, to źródłem takiej zmiennej w serwerze DDE musi być pojedyncza zmienna. Jeśli zmiennej ASMENa, która jest częścią grupy zmiennych DDE, spróbuje się nadać nową wartość z poziomu aplikacji programu Asix, to wystąpi błąd. Gdyby było możliwe nadanie nowej wartości tylko jednej zmiennej w grupie, to drajwer DDE wysyłając tę grupę do serwera musiałby również przesłać nowe wartości pozostałych zmiennych w tej grupie. Użycie ostatnio przysłanych wartości pozostałych zmiennych w grupie jako ich nowych wartości mogłoby spowodować trudne do przewidzenia komplikacje.

PRZYKŁADY

Przykłady definicji zmiennych:

Z1, "O1| 1| W", KanAdam, 1, 1, NIC

Zmienna ASMENa Z1 jest skojarzona z pierwszą zmienną w grupie zmiennych o nazwie O1 pobieranych z serwera DDE wyspecyfikowanego w definicji kanału KanAdam.

Z2, "%I1| 5| s", KanalGE, 1, 1, NIC

Zmienna ASMENa Z2 jest skojarzona z piątą zmienną w grupie zmiennych o nazwie %I1 pobieranych z serwera DDE wyspecyfikowanego w definicji kanału KanGE.

Parametr drajwera

Parametry drajwera DataPAF deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

R Nazwa sekcji: DDE

R Nazwa opcji: ZmiennaStatusu

R Wartośc opcji: service, topic, item

Znaczenie - opcja pliku inicjacyjnego określająca nazwę zmiennej obsługiwanej przez serwer DDE, która pozwala monitorować status połączenia serwera DDE ze sterownikiem przemysłowym. Jeśli wartość tej zmiennej wynosi 1, to połączenie ze sterownikiem funkcjonuje prawidłowo; jeśli wartość zmiennej wynosi 0, to połączenie ze sterownikiem jest zerwane. Aby określić zmienną statusu, należy w pliku inicjacyjnym aplikacji zdefiniować pozycję o nazwie ZmiennaStatusu i nadać mu jej wartość w formacie service, topic, item.

Wartość domyślna - domyślnie przyjmuje się, że w ramach połączenia nie ma zmiennej statusu.

Parametr:

service i topic - określają połączenie,

item - nazwa zmiennej statusu w ramach połączenia.

Serwer DDE może obsługiwać jednocześnie wiele połączeń DDE i dla każdego z nich można osobno zdefiniować zmienną statusu.

PRZYKŁAD

Przykłady definicji zmiennej statusu:

Nazwa sekcji: DDE

Nazwa opcji: ZmiennaStatusu

Wartość opcji: TPERM, S1, Connected

W ramach połączenia TPERM, S1 nazwą zmiennej status jest Connected.

Priorytet wątku drajwera

PriData - wartość priorytetu wątku drajwera przesyłającego dane do modułu ASMEN; wartość domyślna wynosi 1.

Specyfikacja wewnętrzna

Drajwer przy pierwszym odwołaniu do serwera DDE opisanego parą service, topic nawiązuje z tym serwerem połączenie i utrzymuje je stale aż do zakończenia działania drajwera lub serwera DDE. Przy pierwszym czytaniu pierwszej zmiennej należącej do grupy zmiennych rozpoczynane jest odświeżanie tej grupy zmiennych. Nowe wartości są zapisywane w buforze wewnętrznym drajwera i przekazywane modułowi ASMEN w przypadku odczytu typu refresh. W przypadku odczytu zwykłego dane są czytane bezpośrednio z serwera DDE. Jeśli nie jest możliwe rozpoczęcie odświeżania, to wartość zmiennej czytana jest przy każdym odwołaniu się do niej modułu ASMEN. Operacje zapisu są zawsze wykonywane synchronicznie i uaktualniają one wewnętrzny bufor zmiennej.

W przypadku zerwania połączenia z serwerem DDE drajwer DDE próbuje odtworzyć to połączenie.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtDiva

Home > 1.23 Diva - drajwer kamer przemysłowych DIVA firmy VDG Security B.V.

1.23 Diva - drajwer kamer przemysłowych DIVA firmy VDG Security B.V.

Przeznaczenie drajwera

Drajwer Diva służy do sterowania systemem kamer przemysłowych DIVA produkowanym przez VDG Security B.V. Zakres komend wykonywanych przez drajwer jest ograniczony do wykonywania poleceń selectCamera() oraz selectLayout().

Wymiana danych pomiędzy drajwerem i systemem DIVA została zrealizowana w oparciu o dokumentację "Diva HTTP Interface Version 2.3.1" opracowaną przez VDG Software B.V. and affiliated Companies.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Diva wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Diva

Zakładka Diva:

Parametry kanału:

serwerIp=adresIP; haslo=tekst; użytkownik=tekst [;nrAlarmu=liczba][;timeout=liczba]

gdzie:

serwerIP - adres IP serwera systemu DIVA,

haslo - hasło dostępu do serwera systemu DIVA,

uzytkownik - nazwa użytkownika systemu DIVA,

nrAlarmu - nr alarmu systemu Asix, który jest generowany w przypadku braku komunikacji z serwerem systemu DIVA,

timeout - timeout operacji protokołu HTTP w sekundach (domyślnie 3 sekundy).

PRZYKŁAD

Przykład deklaracji kanału transmisji:

Nazwa: KANAL

Drajwer: CtDiva

Parametry kanału: serwerIP=10.10.104.73;
     haslo=abcd; użytkownik=admin;
     nrAlarmu=100

Deklaracja zmiennych

Drajwer udostępnia wyłącznie zmienne wirtualne, które służą do:

- prezentacji nazw nadanych przez drajwer stacjom systemu DIVA,

- przygotowania parametrów poleceń selectLayout() oraz selectCamera(),

- wykonania poleceń selectLayout() oraz selectCamera(),

- prezentacji stanu połączenia z serwerem systemu DIVA.

Dopuszczalne są następujące adresy symboliczne:

ALIAS - unikalna nazwa (alias) nadana serwerowi (stacji) systemu DIVA przez drajwer (tylko odczyt),

CAMERA - nazwa kamery (odczyt/zapis),

DIVA - unikalna nazwa (alias) urządzenia DIVA, na którym będzie wykonana operacja selectLayout() lub selectCamera()(odczyt/zapis),

LAYOUT - nazwa layout’u (odczyt/zapis),

MONITOR - numer monitora stacji systemu DIVA (odczyt/zapis),

PANEL - nazwa panelu na layout’ie określonym przez adres symboliczny

(odczyt/zapis),

SEL_CAMERA - wykonanie polecenia selectCamera() przy użyciu parametrów podanych w pozostałych adresach symbolicznych (tylko zapis),

SEL_LAYOUT - wykonanie polecenia selectLayout() przy użyciu parametrów podanych w pozostałych adresach symbolicznych (tylko zapis).

STATUS - status połączenia z serwerem systemu DIVA (0 - o.k., 1 - błąd)

(tylko odczyt).

Wartości zmiennych mających adresy symboliczne MONITOR, SEL_CAMERA, SEL_LAYOUT są liczbami, w związku z tym dla tych zmiennych należy zastosować funkcję przeliczającą NIC. Wartości zmiennych mających dowolny z pozostałych adresów symbolicznych są tekstami, w związku z tym dla takich zmiennych należy zastosować funkcję przeliczającą NIC_TEXT.

Dla celów identyfikacji serwerów i stacji systemu DIVA został wprowadzony adres symboliczny ALIAS. Adres ten pozwala na dostęp do unikalnej nazwy zbudowanej przez drajwer dla każdego z urządzeń systemu DIVA z osobna. Wprowadzenie adresów symbolicznych typu ALIAS została spowodowane tym, że nazwy nadawane serwerom (stacjom) w systemie DIVA mogą być jednakowe, a rozróżnianie urządzeń systemu DIVA poprzez wielocyfrowy unikalny identyfikator divaid jest niewygodne.

Adres symboliczny ALIAS wymaga podania parametru (oddzielonego od słowa kluczowego ALIAS kropką), którego wartość jest równa numerowi porządkowemu nadanemu urządzeniu systemu DIVA przez drajwer. Minimalna wartość parametru wynosi 1, maksymalna wartość parametru zależy od konfiguracji systemu DIVA.

Przyporządkowanie aliasów do serwerów (stacji) systemu DIVA jest wpisywane do logu drajwera podczas cyklicznego wykonywania polecenia getDivaList(). Przykładowa postać zestawienia jest podana poniżej:

alias : NVDR1master name :NVDR1master divaId : 8678015003039002295 type : 'Diva server'

alias : NVDR1master_1 name :NVDR1master divaId : 8678015003039002295 type : 'Diva client'

alias : NVDR2 name :NVDR2 divaId : 435039309 type : ''

alias : NVDR3 name :NVDR3 divaId : 586093958 type : ''

alias : Nvdr1master name :Nvdr1master divaId : 15551739365488560896 type : 'Diva client'

alias :Nvdr1master_1 name :Nvdr1master divaId : 16755657203230560766 type : 'Diva client'

alias : Nvdr1master_2 name :Nvdr1master divaId : 23456757203230500111 type : 'Diva client'

gdzie:

alias - unikalna nazwa nadana stacji przez drajwer,

name - nazwa nadana stacji przez system DIVA,

diavid - unikalny identyfikator nadany stacji przez system DIVA,

type - typ stacji w systemie DIVA.

PRZYKŁAD

Przykład deklaracji zmiennych:

J01, nazwa serwera DIVA, DIVA, KANAL, 20, 1, NIC_TEXT

J02, nazwa layout’u, LAYOUT, KANAL, 20, 1, NIC_TEXT

J03, numer monitora, MONITOR, KANAL, 1, 1, NIC

J04, selekcja kamery, SEL_CAMERA, KANAL, 1, 1, NIC

J04, selekcja layout’u, SEL_LAYOUT, KANAL, 1, 1, NIC

J05, alias urządzenia nr 1, ALIAS.1, KANAL, 1, 1, NIC_TEXT

J06, alias urządzenia nr 2, ALIAS.2, KANAL, 1, 1, NIC_TEXT

J07, alias urządzenia nr 3, ALIAS.3, KANAL, 1, 1, NIC_TEXT

Przełączanie kamery

Operacja przełączenia kamery składa się z dwóch faz:

• przygotowania parametrów dla polecenia selectCamera() poprzez:

- wpisanie nazwy kamery do zmiennej o adresie symbolicznym CAMERA,

- wpisanie nazwy layout’u do zmiennej o adresie symbolicznym LAYOUT,

- wpisanie nazwy panela do zmiennej o adresie symbolicznym PANEL,

- wpisanie nazwy serwera Diva do zmiennej o adresie symbolicznym DIVA, jeśli polecenie selectCamera() ma dotyczyć wyłącznie określonego serwera,

• wykonania operacji selectCamera() poprzez:

- wpisanie dowolnej wartości do zmiennej o adresie symbolicznym SEL_CAMERA.

Przełączanie layout'u

Operacja przełączenia layout’u składa się z dwóch faz:

• przygotowania parametrów dla polecenia selectLayout() poprzez:

- wpisanie nazwy serwera Diva do zmiennej o adresie symbolicznym DIVA,

- wpisanie nazwy layout’u do zmiennej o adresie symbolicznym LAYOUT,

- wpisanie numeru monitora do zmiennej o adresie symbolicznym MONITOR,

• wykonania operacji selectLayout() poprzez:

- wpisanie dowolnej wartości do zmiennej o adresie symbolicznym SEL_LAYOUT.

Parametryzacja drajwera

Parametry drajwera Diva deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

W sekcji CTDIVA można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log danych konfiguracyjnych odczytanych z webserwera Diva oraz poleceń wysyłanych do webserwera Diva.

R Nazwa sekcji: CTDIVA

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTDIVA

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTDIVA

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) danych konfiguracyjnych systemu Diva, odczytanych przy pomocy poleceń getDivaList(), getDeviceList(), getLayoutList() oraz treści komend wysyłanych do webserwera DIVA.

Wartość domyślna - Domyślnie wartość pozycji jest ustawiona na NIE.


CtDlms - licznikami energii elektrycznej rodziny

Home > 1.24 Dlms - licznikami energii elektrycznej rodziny ZxD/ZxG/ZxQ firmy Landys&Gyr

1.24 Dlms - drajwer liczników energii elektrycznej rodziny ZxD/ZxG/ZxQ firmy Landys&Gyr

Przeznaczenie drajwera

Drajwer protokołu Dlms służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej rodziny ZxD/ZxG/ZxQ firmy Landys & Gyr przy wykorzystaniu protokołu DLMS. Do komunikacji jest wykorzystywany interfejs RS-485/RS-232 przedmiotowych liczników. Drajwer nie może być stosowany do wymiany danych poprzez złącze optyczne.

Drajwer pozwala na:

  • odczyt rejestrów klasy 1, 3, 4, 5

  • odczyt profili mocy, okresów obrachunkowych i logu zdarzeń (rejestry klasy 7),

  • rejestrację w plikach tekstowych profili mocy, okresów obrachunkowych i logu zdarzeń.

Parametryzacja drajwera Dlms realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Dlms wymaga dodania do

modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Dlms

Zakładka Dlms/Parametry kanału:

gdzie:

Port szeregowy - numer portu szeregowego COM,

Prędkość transmisji - prędkość transmisji między komputerem a urządzeniem. Dopuszczalne są następujące prędkości: 2400, 4800, 9600, 19200, 38400 Bd. Domyślna wartość wynosi 9600 Bd,

Okres - okres czasu (w sekundach) pomiędzy kolejnymi odczytami rejestrów licznika. Domyślna wartość wynosi 10 sekund,

PRZYKŁAD

Przykład deklaracji kanału na porcie COM2:

Port szeregowy: 2;

Okres: 20;

Prędkość transmisji: 9600

Deklaracja zmiennych bieżących

Adres zmiennej bieżącej ma składnię:

[nazwa_licznika]/kod_OBIS_rejestru

gdzie:

nazwa_licznika - (opcja). Zawiera unikalną nazwę adresową licznika używaną w instalacjach multipoint do identyfikacji poszczególnych liczników.

nazwa_licznika odpowiada 'Device address' wg PN-EN 61107. Przy połączeniu point-point nazwa_licznika może być pominięta,

kod_OBIS_rejestru - kod OBIS rejestru licznika, zgodny z listą odczytową, która została wprowadzona do liczniku przez producenta na etapie parametryzacji. Jeśli ostatnim elementem kodu OBIS (grupa F) jest wartość255, to element ten może być w adresie pominięty.

UWAGA:

Wartości rejestrów przekazujących liczby drajwer konwertuje na liczby typu DOUBLE.

PRZYKŁAD

/* 1-0:0.0.1 - nr identyfikacyjny 1 licznika */

JJ_01, nr identyfikacyjny 1 licznika, "/1-0:0.0.1", KANAL, 1, 1, NIC_FP

/* 1-1:1.8.0 - rejestr pobranej energii czynnej */

JJ_02, rejestr pobranej energii czynnej, "/1-1:1.8.0”, KANAL, 1, 1, NIC_FP

Deklaracja zmiennych profili mocy

Dostęp do wartości profili mocy wymaga utworzenia pliku logu profili, do którego drajwer wpisuje dane profili mocy (odczytywane z licznika przy pomocy odpowiedniego rejestru klasy 7). Dane pochodzące z najmłodszego wpisu w pliku logu profili są udostępniane przez drajwer jako bieżące wartości profili mocy (ze znacznikiem czasu pobranym z logu profili). Starsze wpisy w pliku logu profili są udostępniane jako wartości historyczne profili mocy (poprzez interfejs dostępu do danych historycznych).

Adres zmiennej profilu mocy jest budowany na bazie adresu zmiennej bieżącej poprzez dodanie do niego przyrostka .P.

Składnia adresu zmiennej profilu mocy jest następująca:

[nazwa_licznika]/kod_OBIS_rejestru.P

gdzie:

nazwa_licznika - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

kod_OBIS_rejestru - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

.P - przyrostek używany dla odróżnienia adresu zmiennej profilu mocy od adresu odpowiadającej jej zmiennej bieżącej (o ile taka istnieje).

PRZYKŁAD

Profil_1.4.0, profil 1.4.0, "/1-1:1.4.0.P", KANAL, 1, 1, NIC_FP

Profil_2.4.0, profil 2.4.0, "/1-1:2.4.0.P", KANAL, 1, 1, NIC_FP

Uwaga:

Liczba oraz adresy zmiennych profilu mocy są specyficzne dla każdego licznika i zależą od sposobu sparametryzowania licznika.

Deklaracja zmiennych okresów obrachunkowych

Dostęp do wartości okresów obrachunkowych wymaga utworzenia pliku logu okresów obrachunkowych, do którego drajwer wpisuje dane okresów obrachunkowych (odczytywane z licznika przy pomocy odpowiedniego rejestru klasy 7). Dane pochodzące z najmłodszego wpisu w pliku logu okresów obrachunkowych są udostępniane przez drajwer jako bieżące wartości okresów obrachunkowych (ze znacznikiem czasu pobranym z logu profili). Starsze wpisy w pliku logu okresów obrachunkowych są udostępniane jako wartości historyczne okresów obrachunkowych (poprzez interfejs dostępu do danych historycznych).

Adres zmiennej okresów obrachunkowych jest budowany na bazie adresu zmiennej bieżącej poprzez dodanie do niego przyrostka .A.

Składnia adresu zmiennej okresu obrachunkowego jest następująca:

[nazwa_licznika]/kod_OBIS_rejestru.A

gdzie:

nazwa_licznika - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

kod_OBIS_rejestru - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

.A - przyrostek używany dla odróżnienia adresu zmiennej okresu obrachunkowego od adresu odpowiadającej jej zmiennej bieżącej (o ile taka istnieje).

PRZYKŁAD

Period_1.8.1, rejestr arch 1.8.1, "/1-1:1.8.1.A", KANAL, 1, 1, NIC_FP

Period_1.8.2, rejestr arch 1.8.2, "/1-1:1.8.2.A", KANAL, 1, 1, NIC_FP

Uwaga:

Liczba oraz adresy zmiennych okresów obrachunkowych są specyficzne dla każdego licznika i zależą od sposobu sparametryzowania licznika.

Parametryzacja drajwera

Parametry drajwera Dlms deklarowane są na zakładkach Dlms/Parametry drajwera....

Drajwer jest parametryzowany przy użyciu osobnej sekcji CtDLMS. W sekcji można umieścić opcje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • plik logu historii,

  • timeout odbioru,

  • timeout międzyznakowy.

Nazwy opcji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku w MB

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i licznikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie log nie jest tworzony.

R Plik logu historii

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o operacjach wykonywanych na interfejsie dostępu do historycznych wartości zmiennych profili mocy i okresów obrachunkowych. Plik logu historii jest wspólny dla wszystkich liczników.

Rozmiar pliku logu historii jest taki sam, jak rozmiar pliku logu drajwera.

Wartość domyślna - domyślnie nie tworzy się pliku logu historii.

Parametr:

nazwa pliku

R Timeout odbioru

Znaczenie - opcja określa czas oczekiwania na pierwszy znak odpowiedzi z licznika.

Wartość domyślna - domyślnie wartość opcji wynosi 1000.

Wartość opcji:

liczba - timeout odbioru w milisekundach.

R Timeout znaku

Znaczenie - opcja określa maksymalny czas pomiędzy kolejnymi znakami odpowiedzi z licznika.

Wartość domyślna - domyślnie wartość opcji wynosi 100.

Wartość opcji:

liczba - timeout znaku w milisekundach.

R Synchronizacja czasu

Znaczenie: Pozycja umożliwia załączenie synchronizacji czasu pomiędzy Asixem a sterownikiem, z określeniem odcinków czasu pomiędzy kolejnymi synchronizacjami.

Wartość domyślna: Domyślnie wartość pozycji wynosi 0 - brak synchronizacji czasu.

Parametr:

liczba - czas w minutach.

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Plik logu: d:\tmp\CtDlms\dlms.log

R Rozmiar pliku logu: 10

R Log telegramów: TAK

R Timeout odbioru: 1500

R Timeout znaku: 150

Opcje związane z możliwością zawieszania odczytu licznika w okresie, gdy licznik wylicza zamknięcia dobowe, dekadowe oraz miesięczne.

R Okres zawieszenia odczytu

Znaczenie: Pozycja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Zawieszenie odczytu - dobowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - dekadowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - miesięczne

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Parametryzacja poszczególnych liczników

Licznik jest parametryzowany przy użyciu opcji deklarujących:

  • adres klienta,

  • adres serwera,

  • nazwa pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • plik logu zdarzeń,

  • rozmiar pliku logu zdarzeń,

  • okres odczytu zdarzeń z licznika,

  • wyłączenie odczytu zdarzeń,

  • horyzont odczytu historii zdarzeń,

  • plik logu profili mocy,

  • rozmiar pliku logu profili mocy,

  • okres odczytu logu profili mocy,

  • wyłączenie odczytu profili mocy,

  • horyzont odczytu historii profili mocy,

  • plik logu okresów obrachunkowych,

  • rozmiar pliku logu okresów obrachunkowych,

  • okres odczytu logu okresów obrachunkowych,

  • wyłączenie odczytu okresów obrachunkowych,

  • horyzont odczytu historii okresów obrachunkowych,

  • okres uzupełniania danych historycznych.

1 przypadek

W sytuacji pojedynczego licznika (gdy używana jest instalacja point-point) - jest on parametryzowany na zakładkach tworzonych przy użyciu zakładki Dlms/Liczniki za pomocą przycisku Dodaj point-to-point.

Zakładka Podstawowe:

R Adres klienta

Znaczenie - opcja określa wartość parametru ’Client Address’ w parametrach połączenia DLMS danego kanału.

Wartość domyślna - domyślnie opcja ma wartość 16.

Wartość opcji:

liczba - adres klienta w postaci dziesiętnej.

R Adres logiczny serwera

Znaczenie - opcja określa wartość parametru ’Physical Server’ w parametrach połączenia DLMS danego kanału. Tzw. 'upper HDLC address'.

Wartość domyślna - domyślnie opcja ma wartość 1.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

R Adres fizyczny serwera

Znaczenie - adres fizyczny serwera w postaci dziesiętnej (tzw. 'lower HDLC address').

Wartość domyślna - domyślnie opcja ma wartość 0.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

Zakładka Zaawansowane:

R Okres uzupełniania danych historycznych

Znaczenie - przy użyciu opcji deklaruje się, jak często drajwer będzie wydawał zapytania w celu uzupełnienia danych historycznych dotyczących profili mocy, okresów obrachunkowych oraz zdarzeń.

Wartość domyślna - domyślnie drajwer uzupełnia dane historyczne wydając zapytania co minutę.

R Synchronizacja czasu

Znaczenie: Pozycja umożliwia załączenie synchronizacji czasu pomiędzy Asixem a sterownikiem, z określeniem odcinków czasu pomiędzy kolejnymi synchronizacjami.

Wartość domyślna: Domyślnie wartość pozycji wynosi 0 - brak synchronizacji czasu.

Parametr:

liczba - czas w minutach.

Zakładka Zawieszenie odczytu:

R Okres zawieszenia odczytu

Znaczenie: Pozycja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Zawieszenie odczytu - dobowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - dekadowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - miesięczne

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Zakładka Diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty generowane w danym kanale.

Wartość domyślna - domyślnie komunikaty generowane w kanale są kierowane do logu drajwera.

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu jest dziedziczony z ustawień dla logu drajwera.

Wartość opcji:

liczba - rozmiar pliku w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest dziedziczona z ustawień dla logu drajwera.

Zakładka Zdarzenia:

R Log zdarzeń

Znaczenie - Zdarzenia odczytane z licznika są zapisywane do pliku tekstowego w formacie ’csv’. Każde zdarzenie jest zapisane w oddzielnej linii. Zdarzenia w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać zdarzenia jest podana poniżej:

P.98;1;2005-05-10 08:14:33;0048;;3;;;F.F;;1.8.0;kWh;024;00000000;0000.0000

Opcja Log zdarzeń pozwala zdefiniować plik, w którym będzie zapisywany log zdarzeń.

Wartość domyślna - domyślnie plik logu zdarzeń nie jest tworzony.

R Rozmiar pliku logu zdarzeń

Znaczenie - opcja służy do określenia rozmiaru pliku logu zdarzeń, zdefiniowanego przy użyciu opcji Log zdarzeń.

Wartość domyślna - domyślnie rozmiar pliku logu zdarzeń wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Bez logu zdarzeń

Znaczenie - przy użyciu opcji można wyłączyć odczyt logu zdarzeń.

Wartość domyślna - domyślnie drajwer odczytuje log zdarzeń.

R Okres odczytu logu zdarzeń

Znaczenie - opcja służy do określenia cyklu odczytu logu zdarzeń z licznika.

Wartość domyślna - domyślnie odczyt logu zdarzeń odbywa się co 1 godzinę.

Wartość opcji:

liczba - cykl odczytu logu zdarzeń (w godzinach).

R Horyzont odczytu historii logu zdarzeń

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii zdarzeń będzie sięgać drajwer przy odczycie logu zdarzeń.

Wartość domyślna - domyślnie drajwer odczytując historię zdarzeń sięga 130 dni wstecz od początku aktualnej doby.

Wartość opcji:

liczba dni

Zakładka Profile mocy:

R Log profili mocy

Znaczenie - profile mocy odczytane z licznika są zapisywane do pliku tekstowego w formacie ’csv’. Każdy profil mocy jest zapisany w oddzielnej linii. Profile mocy w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać pojedynczego profilu mocy jest podana poniżej (dla zwiększenia przejrzystości przykładowy profil został rozbity na dwie linijki tekstu):

P.01;1;2005-05-10 12:45:00;0008;15;6;1.5.0;kW;5.5.0;kvar;8.5.0;kvar;

32.7;V;52.7;V;72.7;V;5.123000;24.2438900;123.654320;---.-;---.-;---.-

Opcja Log profili mocy pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log profili.

Wartość domyślna - domyślnie plik logu profili mocy nie jest tworzony.

R Rozmiar pliku logu profili mocy

Znaczenie - opcja służy do określenia rozmiaru pliku logu profili mocy, zdefiniowanego przy użyciu opcji Log profili mocy.

Wartość domyślna - domyślnie rozmiar pliku logu profili wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Bez logu profili mocy

Znaczenie - przy użyciu opcji można wyłączyć odczyt profili mocy.

Wartość domyślna - domyślnie drajwer odczytuje log profili mocy.

R Okres odczytu logu profili mocy

Znaczenie - opcja służy do określenia cyklu odczytu logu profili mocy z licznika.

Wartość domyślna - domyślnie odczyt logu profili mocy odbywa się co 1 godzinę.

Wartość opcji:

liczba - cykl odczytu logu profili (w godzinach).

R Horyzont odczytu historii logu profili mocy

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii profili mocy będzie sięgać drajwer przy odczycie profili mocy.

Wartość domyślna - domyślnie drajwer odczytując historię profili mocy sięga 32 doby wstecz od początku aktualnej doby.

Zakładka Okresy obrachunkowe:

R Log okresów obrachunkowych

Znaczenie: - dane okresów obrachunkowych są zapisywane do pliku tekstowego w formacie ’csv’. Każdy zestaw danych okresu obrachunkowego jest zapisany w oddzielnej linii. Dane okresów obrachunkowych są uporządkowane wg narastających znaczników czasu. Przykładowa postać danych pojedynczego okresu obrachunkowego jest podana poniżej (dla zwiększenia przejrzystości przykładowy profil został rozbity na kilka linijek tekstu):

P.97;1;2012-06-06 12:03:42;0001;42;1-1:1.8.1*255;Wh;V;1-1:1.8.2*255;Wh;V;1-1:1.8.3*255;Wh;V;1-1:2.8.1*255;Wh;V;1-1:2.8.2*255;Wh;V;1-1:2.8.3*255;Wh;V;1-1:5.8.1*255;varh;V;1-1:5.8.2*255;varh;V;1-1:5.8.3*255;varh;V;1-1:6.8.1*255;varh;V;1-1:6.8.2*255;varh;V;1-1:6.8.3*255;varh;V;1-1:7.8.1*255;varh;V;1-1:7.8.2*255;varh;V;1-1:7.8.3*255;varh;V;1-1:8.8.1*255;varh;V;1-1:8.8.2*255;varh;V;1-1:8.8.3*255;varh;V;1-1:1.6.0*255;W;V;1-1:1.6.0*255;W;T;1-1:2.6.0*255;W;V;1-1:2.6.0*255;W;T;1-1:5.6.0*255;var;V;1-1:5.6.0*255;var;T;1-1:6.6.0*255;var;V;1-1:6.6.0*255;var;T;1-1:7.6.0*255;var;V;1-1:7.6.0*255;var;T;1-1:8.6.0*255;var;V;1-1:8.6.0*255;var;T;1-1:1.8.0*255;Wh;V;1-1:2.8.0*255;Wh;V;1-1:5.8.0*255;varh;V;1-1:6.8.0*255;varh;V;1-1:7.8.0*255;varh;V;1-1:8.8.0*255;varh;V;0-0:96.8.1*255;h;V;0-0:96.8.2*255;h;V;0-0:96.8.3*255;h;V;0-0:96.8.0*255;h;V;1-1:1.8.5*255;Wh;V;0-0:96.8.5*255;h;V;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;02745.000000;00000.000000;01931.000000;04676.000000;00000.000000;00000.000000

Opcja pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log okresów obrachunkowych.

Wartość domyślna - domyślnie plik logu okresów obrachunkowych nie jest tworzony.

R Rozmiar pliku logu okresów obrachunkowych

Znaczenie: - opcja służy do określenia rozmiaru pliku logu okresów obrachunkowych, zdefiniowanego przy użyciu opcji Log okresów obrachunkowych.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu okresów obrachunkowych wynosi 10 MB.

R Bez logu okresów obrachunkowych

Znaczenie - przy użyciu opcji można wyłączyć odczyt logu okresów obrachunkowych.

Wartość domyślna - domyślnie drajwer odczytuje log okresów obrachunkowych.

R Okres odczytu logu okresów obrachunkowych

Znaczenie - opcja służy do określenia cyklu odczytu logu okresów obrachunkowych z licznika.

Wartość opcji:

liczba - cykl odczytu logu okresów obrachunkowych (w godzinach).

Wartość domyślna - domyślnie odczyt logu okresów obrachunkowych odbywa się co 1 godzinę.

R Horyzont odczytu historii logu okresów obrachunkowych

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii okresów obrachunkowych będzie sięgać drajwer przy odczycie okresów obrachunkowych.

Wartość domyślna - domyślnie drajwer odczytując historię okresów obrachunkowych, sięga 130 doby wstecz od początku aktualnej doby.

PRZYKŁAD

Przykładowa parametryzacja licznika w kanale KANAL.

R Plik logu: c:\tmp\CtDlms\kanal.log

R Log zdarzeń: c:\tmp\CtDlms\book.log

R Rozmiar pliku logu zdarzeń: 15

R Okres odczytu logu zdarzeń: 2

R Log profili mocy: c:\tmp\CtDlms\profile.log

R Rozmiar pliku logu profili mocy: 20

R Okres odczytu logu profili mocy: 4

R Log okresów obrachunkowych: c:\tmp\CtDlms\billing.log

R Log telegramów: TAK

R Horyzont odczytu historii logu profili mocy: 40

2 przypadek

W przypadku użycia kilku liczników - są one parametryzowane na zakładkach tworzonych przy użyciu zakładki Dlms/Liczniki za pomocą przycisku Dodaj nowy licznik.

Zakładki i parametry identyczne jak w przypadku 1 (w sytuacji pojedynczego licznika, gdy używana jest instalacja point-point).

R Adres fizyczny serwera

Znaczenie - opcja służy do deklarowania tzw. 'lower HDLC address' licznika, parametru niezbędnego do nawiązania połączenia w konfiguracjach multidrop.

Wartość domyślna - domyślnie opcja ma wartość 1.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

W połączeniach point-to-point 'lower HDLC address' nie ma zastosowania.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.

R Czas ważności danych

Znaczenie - opcja określa czas, przez który wartości zmiennych w kanale zachowują ważność; opcję należy użyć tylko wtedy, gdy czasowy brak danych nie powinien być traktowany jako błąd.

Wartość opcji:

liczba - czas podany w sekundach; należy podać wartość (znacznie) większą niż najdłuższy okres odświeżania zmiennej w kanale.

Wartość domyślna - domyślnie nie ma ustalonego czasu ważności danych.

Dodatkowe parametry kanału

Parametry kanału drajwera CTDLMS deklarowane w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

Parametry drajwera umieszczane są w sekcji o nazwie kanału.

Opcje związane z możliwością zawieszania odczytu licznika w okresie, gdy licznik wylicza zamknięcia dobowe, dekadowe oraz miesięczne.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: OKRES_ZAWIESZENIA_ODCZYTU

R Wartość opcji: liczba_sekund

Znaczenie: Pozycja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_DOBOWE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_DEKADOWE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_MIESIECZNE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: SYNCHRONIZACJA_CZASU

R Wartość opcji: liczba_minut

Znaczenie: Pozycja umożliwia załączenie synchronizacji czasu pomiędzy Asixem a sterownikiem, z określeniem odcinków czasu pomiędzy kolejnymi synchronizacjami.

Wartość domyślna: Domyślnie wartość pozycji wynosi 0 - brak synchronizacji czasu.

Parametr:

liczba - czas w minutach.


DlmsTcpip

Home > 1.25 DlmsTcpip - drajwer liczników energii elektrycznej firmy Landys&Gyr

1.25 DlmsTcpip - drajwer liczników energii elektrycznej firmy Landys&Gyr

Przeznaczenie drajwera

Drajwer protokołu DlmsTcpip służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej przy wykorzystaniu protokołu DLMS. Do komunikacji jest wykorzystywany Ethernet.

Drajwer pozwala na:

  • odczyt rejestrów klasy 1, 3, 4, 5;

  • odczyt profili mocy, okresów obrachunkowych i logu zdarzeń (rejestry klasy 7);

  • rejestrację w plikach tekstowych profili mocy, okresów obrachunkowych i logu zdarzeń.

Parametryzacja drajwera DlmsTcpip realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DlmsTcpip wymaga dodania do

modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DlmsTcpip

Zakładka DlmsTcpip/Parametry kanału:

gdzie:

Adres IP licznika - adres IP licznika,

Port IP licznika - port IP licznika,

Adres IP komputera - adres IP komputera wykorzystywany przez dany kanał; domyślnie przyjmuje się adres przydzielony przez Windows,

Okres - okres czasu (w sekundach) pomiędzy kolejnymi odczytami rejestrów licznika. Domyślna wartość wynosi 10 sekund.

PRZYKŁAD

Przykład deklaracji kanału na porcie COM2:

Adres IP licznika: 176.109.164.62;

Adres IP komputera: 10.10.105.2;

Okres: 60;

Port IP licznika: 8000.

Deklaracja zmiennych bieżących

Adres zmiennej bieżącej ma składnię:

[nazwa_licznika]/kod_OBIS_rejestru

gdzie:

nazwa_licznika - (opcja). Zawiera unikalną nazwę adresową licznika używaną w instalacjach multipoint do identyfikacji poszczególnych liczników.

nazwa_licznika odpowiada 'Device address' wg PN-EN 61107. Przy połączeniu point-point nazwa_licznika może być pominięta,

kod_OBIS_rejestru - kod OBIS rejestru licznika, zgodny z listą odczytową, która została wprowadzona do liczniku przez producenta na etapie parametryzacji. Jeśli ostatnim elementem kodu OBIS (grupa F) jest wartość255, to element ten może być w adresie pominięty.

UWAGA:

Wartości rejestrów przekazujących liczby drajwer konwertuje na liczby typu DOUBLE.

PRZYKŁAD

/* 1-0:0.0.1 - nr identyfikacyjny 1 licznika */

JJ_01, nr identyfikacyjny 1 licznika, "/1-0:0.0.1", KANAL, 1, 1, NIC_FP

/* 1-1:1.8.0 - rejestr pobranej energii czynnej */

JJ_02, rejestr pobranej energii czynnej, "/1-1:1.8.0”, KANAL, 1, 1, NIC_FP

Deklaracja zmiennych profili mocy

Dostęp do wartości profili mocy wymaga utworzenia pliku logu profili, do którego drajwer wpisuje dane profili mocy (odczytywane z licznika przy pomocy odpowiedniego rejestru klasy 7). Dane pochodzące z najmłodszego wpisu w pliku logu profili są udostępniane przez drajwer jako bieżące wartości profili mocy (ze znacznikiem czasu pobranym z logu profili). Starsze wpisy w pliku logu profili są udostępniane jako wartości historyczne profili mocy (poprzez interfejs dostępu do danych historycznych).

Adres zmiennej profilu mocy jest budowany na bazie adresu zmiennej bieżącej poprzez dodanie do niego przyrostka .P.

Składnia adresu zmiennej profilu mocy jest następująca:

[nazwa_licznika]/kod_OBIS_rejestru.P

gdzie:

nazwa_licznika - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

kod_OBIS_rejestru - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

.P - przyrostek używany dla odróżnienia adresu zmiennej profilu mocy od adresu odpowiadającej jej zmiennej bieżącej (o ile taka istnieje).

PRZYKŁAD

Profil_1.4.0, profil 1.4.0, "/1-1:1.4.0.P", KANAL, 1, 1, NIC_FP

Profil_2.4.0, profil 2.4.0, "/1-1:2.4.0.P", KANAL, 1, 1, NIC_FP

Uwaga:

Liczba oraz adresy zmiennych profilu mocy są specyficzne dla każdego licznika i zależą od sposobu sparametryzowania licznika.

Deklaracja zmiennych okresów obrachunkowych

Dostęp do wartości okresów obrachunkowych wymaga utworzenia pliku logu okresów obrachunkowych, do którego drajwer wpisuje dane okresów obrachunkowych (odczytywane z licznika przy pomocy odpowiedniego rejestru klasy 7). Dane pochodzące z najmłodszego wpisu w pliku logu okresów obrachunkowych są udostępniane przez drajwer jako bieżące wartości okresów obrachunkowych (ze znacznikiem czasu pobranym z logu profili). Starsze wpisy w pliku logu okresów obrachunkowych są udostępniane jako wartości historyczne okresów obrachunkowych (poprzez interfejs dostępu do danych historycznych).

Adres zmiennej okresów obrachunkowych jest budowany na bazie adresu zmiennej bieżącej poprzez dodanie do niego przyrostka .A.

Składnia adresu zmiennej okresu obrachunkowego jest następująca:

[nazwa_licznika]/kod_OBIS_rejestru.A

gdzie:

nazwa_licznika - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

kod_OBIS_rejestru - ma to samo znaczenie, jak przy deklaracji zmiennych bieżących,

.A - przyrostek używany dla odróżnienia adresu zmiennej okresu obrachunkowego od adresu odpowiadającej jej zmiennej bieżącej (o ile taka istnieje).

PRZYKŁAD

Period_1.8.1, rejestr arch 1.8.1, "/1-1:1.8.1.A", KANAL, 1, 1, NIC_FP

Period_1.8.2, rejestr arch 1.8.2, "/1-1:1.8.2.A", KANAL, 1, 1, NIC_FP

Uwaga:

Liczba oraz adresy zmiennych okresów obrachunkowych są specyficzne dla każdego licznika i zależą od sposobu sparametryzowania licznika.

Parametryzacja drajwera

Parametry drajwera Dlms deklarowane są na zakładkach DlmsTcpip/Parametry drajwera:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • plik logu historii,

  • timeout odbioru,

  • timeout znaku,

  • Adres IP komputera,

  • Synchronizacja czasu,

  • Okres zawieszenia odczytu,

  • zawieszenie odczytu (dobowe, dekadowe, miesięczne).

Nazwy opcji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku w MB

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i licznikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie log nie jest tworzony.

R Plik logu historii

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o operacjach wykonywanych na interfejsie dostępu do historycznych wartości zmiennych profili mocy i okresów obrachunkowych. Plik logu historii jest wspólny dla wszystkich liczników.

Rozmiar pliku logu historii jest taki sam jak rozmiar pliku logu drajwera.

Wartość domyślna - domyślnie nie tworzy się pliku logu historii.

Parametr:

nazwa pliku

R Timeout odbioru

Znaczenie - opcja określa czas oczekiwania na pierwszy znak odpowiedzi z licznika.

Wartość domyślna - domyślnie wartość opcji wynosi 1000.

Wartość opcji:

liczba - timeout odbioru w milisekundach.

R Timeout znaku

Znaczenie - opcja określa maksymalny czas pomiędzy kolejnymi znakami odpowiedzi z licznika.

Wartość domyślna - domyślnie wartość opcji wynosi 0.

Wartość opcji:

liczba - timeout znaku w milisekundach.

R Adres IP komputera

Znaczenie - opcja służy do określenia adresu karty sieciowej komputera, poprzez którą drajwer komunikuje się z licznikami.

Wartość domyślna - jeśli opcja nie jest zadeklarowana, to drajwer użyje karty sieciowej dostarczonej przez system, co może prowadzić do braku łączności ze sterownikiem.

Wartość opcji:

adres IP - adres karty sieciowej w notacji IPv4.

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Plik logu: d:\tmp\CtDlms\dlms.log

R Rozmiar pliku logu: 10

R Log telegramów: TAK

R Timeout odbioru: 1500

R Adres IP komputera: 10.10.105.2

R Synchronizacja czasu

Znaczenie: Pozycja umożliwia załączenie synchronizacji czasu pomiędzy Asixem a sterownikiem, z określeniem odcinków czasu pomiędzy kolejnymi synchronizacjami.

Wartość domyślna: Domyślnie wartość pozycji wynosi 0 - brak synchronizacji czasu.

Parametr:

liczba - czas w minutach.

Opcje związane z możliwością zawieszania odczytu licznika w okresie, gdy licznik wylicza zamknięcia dobowe, dekadowe oraz miesięczne.

R Okres zawieszenia odczytu

Znaczenie: Opcja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund. W okresie zawieszenia odczytu wartości zmiennych bieżących opatrywane są statusem OPC_QUALITY_UNCERTAIN.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Zawieszenie odczytu - dobowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym. Zawiesza odczyt danych o północy każdego dnia.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - dekadowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym. Zawiesza odczyt danych o północy przy zmianie dekady.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - miesięczne

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym. Zawiesza odczyt danych o północy przy zmianie miesiąca.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Parametryzacja poszczególnych liczników

Licznik jest parametryzowany przy użyciu opcji deklarujących:

  • adres klienta,

  • adres logiczny serwera,

  • adres fizyczny serwera,

  • okres uzupełniania danych historycznych,

  • synchronizacja czasu,

  • okres zawieszenia odczytu,

  • zawieszenie odczytu,

  • nazwa pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • plik logu zdarzeń,

  • rozmiar pliku logu zdarzeń,

  • brak logu zdarzeń,

  • okres odczytu logu zdarzeń,

  • horyzont odczytu historii logu zdarzeń,

  • plik logu profili mocy,

  • rozmiar pliku logu profili mocy,

  • brak logu profili mocy,

  • okres odczytu logu profili mocy,

  • horyzont odczytu historii logu profili mocy,

  • plik logu okresów obrachunkowych,

  • rozmiar pliku logu okresów obrachunkowych,

  • brak logu okresów obrachunkowych,

  • okres odczytu logu okresów obrachunkowych,

  • horyzont odczytu historii logu okresów obrachunkowych.

1 przypadek

W sytuacji pojedynczego licznika (gdy używana jest instalacja point-point) - jest on parametryzowany na zakładkach tworzonych przy użyciu zakładki DlmsTcpip/Liczniki za pomocą przycisku Dodaj point-to-point.

Zakładka Podstawowe:

R Adres klienta

Znaczenie - opcja określa wartość parametru ’Client Address’ w parametrach połączenia DLMS danego kanału.

Wartość domyślna - domyślnie opcja ma wartość 16.

Wartość opcji:

liczba - adres klienta w postaci dziesiętnej.

R Adres logiczny serwera

Znaczenie - adres logiczny serwera w postaci 'upper HDLC address'.

Wartość domyślna - domyślnie opcja ma wartość 1.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

R Adres fizyczny serwera

Znaczenie - adres fizyczny serwera w postaci 'lower HDLC address'.

Wartość domyślna - domyślnie opcja ma wartość 0.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

Zakładka Zaawansowane:

R Okres uzupełniania danych historycznych

Znaczenie - przy użyciu opcji deklaruje się, jak często drajwer będzie wydawał zapytania w celu uzupełnienia danych historycznych dotyczących profili mocy, okresów obrachunkowych oraz zdarzeń.

Wartość domyślna - domyślnie drajwer uzupełnia dane historyczne wydając zapytania co minutę.

R Synchronizacja czasu

Znaczenie: Pozycja umożliwia załączenie synchronizacji czasu pomiędzy Asixem a sterownikiem, z określeniem odcinków czasu pomiędzy kolejnymi synchronizacjami.

Wartość domyślna: Domyślnie wartość pozycji wynosi 0 - brak synchronizacji czasu.

Parametr:

liczba - czas w minutach.

Zakładka Zaawansowane:

R Okres zawieszenia odczytu

Znaczenie: Opcja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund. W okresie zawieszenia odczytu wartości zmiennych bieżących opatrywane są statusem OPC_QUALITY_UNCERTAIN.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Zawieszenie odczytu - dobowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym. Zawiesza odczyt danych o północy każdego dnia.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - dekadowe

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym. Zawiesza odczyt danych o północy przy zmianie dekady.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Zawieszenie odczytu - miesięczne

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym. Zawiesza odczyt danych o północy przy zmianie miesiąca.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Zakładka Diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty generowane w danym kanale.

Wartość domyślna - domyślnie komunikaty generowane w kanale są kierowane do logu drajwera.

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu jest dziedziczony z ustawień dla logu drajwera.

Wartość opcji:

liczba - rozmiar pliku w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest dziedziczona z ustawień dla logu drajwera.

Zakładka Zdarzenia:

R Log zdarzeń

Znaczenie - Zdarzenia odczytane z licznika są zapisywane do pliku tekstowego w formacie ’csv’. Każde zdarzenie jest zapisane w oddzielnej linii. Zdarzenia w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać zdarzenia jest podana poniżej:

P.98;1;2005-05-10 08:14:33;0048;;3;;;F.F;;1.8.0;kWh;024;00000000;0000.0000

Opcja Log zdarzeń pozwala zdefiniować plik, w którym będzie zapisywany log zdarzeń.

Wartość domyślna - domyślnie plik logu zdarzeń nie jest tworzony.

R Rozmiar pliku logu zdarzeń

Znaczenie - opcja służy do określenia rozmiaru pliku logu zdarzeń, zdefiniowanego przy użyciu opcji Log zdarzeń.

Wartość domyślna - domyślnie rozmiar pliku logu zdarzeń wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Bez logu zdarzeń

Znaczenie - przy użyciu opcji można wyłączyć odczyt logu zdarzeń.

Wartość domyślna - domyślnie drajwer odczytuje log zdarzeń.

R Okres odczytu logu zdarzeń

Znaczenie - opcja służy do określenia cyklu odczytu logu zdarzeń z licznika.

Wartość domyślna - domyślnie odczyt logu zdarzeń odbywa się co 1 godzinę.

Wartość opcji:

liczba - cykl odczytu logu zdarzeń (w godzinach).

R Horyzont odczytu historii logu zdarzeń

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii zdarzeń będzie sięgać drajwer przy odczycie logu zdarzeń.

Wartość domyślna - domyślnie drajwer odczytując historię zdarzeń sięga 130 dni wstecz od początku aktualnej doby.

Wartość opcji:

liczba dni

Zakładka Profile mocy:

R Log profili mocy

Znaczenie - profile mocy odczytane z licznika są zapisywane do pliku tekstowego w formacie ’csv’. Każdy profil mocy jest zapisany w oddzielnej linii. Profile mocy w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać pojedynczego profilu mocy jest podana poniżej (dla zwiększenia przejrzystości przykładowy profil został rozbity na dwie linijki tekstu):

P.01;1;2005-05-10 12:45:00;0008;15;6;1.5.0;kW;5.5.0;kvar;8.5.0;kvar;

32.7;V;52.7;V;72.7;V;5.123000;24.2438900;123.654320;---.-;---.-;---.-

Opcja Log profili mocy pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log profili.

Wartość domyślna - domyślnie plik logu profili mocy nie jest tworzony.

R Rozmiar pliku logu profili mocy

Znaczenie - opcja służy do określenia rozmiaru pliku logu profili mocy, zdefiniowanego przy użyciu opcji Log profili mocy.

Wartość domyślna - domyślnie rozmiar pliku logu profili wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Bez logu profili mocy

Znaczenie - przy użyciu opcji można wyłączyć odczyt profili mocy.

Wartość domyślna - domyślnie drajwer odczytuje log profili mocy.

R Okres odczytu logu profili mocy

Znaczenie - opcja służy do określenia cyklu odczytu logu profili mocy z licznika.

Wartość domyślna - domyślnie odczyt logu profili mocy odbywa się co 1 godzinę.

Wartość opcji:

liczba - cykl odczytu logu profili (w godzinach).

R Horyzont odczytu historii logu profili mocy

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii profili mocy będzie sięgać drajwer przy odczycie profili mocy.

Wartość domyślna - domyślnie drajwer odczytując historię profili mocy sięga 32 doby wstecz od początku aktualnej doby.

Zakładka Okresy obrachunkowe:

R Log okresów obrachunkowych

Znaczenie: - dane okresów obrachunkowych są zapisywane do pliku tekstowego w formacie ’csv’. Każdy zestaw danych okresu obrachunkowego jest zapisany w oddzielnej linii. Dane okresów obrachunkowych są uporządkowane wg narastających znaczników czasu. Przykładowa postać danych pojedynczego okresu obrachunkowego jest podana poniżej (dla zwiększenia przejrzystości przykładowy profil został rozbity na kilka linijek tekstu):

P.97;1;2012-06-06 12:03:42;0001;42;1-1:1.8.1*255;Wh;V;1-1:1.8.2*255;Wh;V;1-1:1.8.3*255;Wh;V;1-1:2.8.1*255;Wh;V;1-1:2.8.2*255;Wh;V;1-1:2.8.3*255;Wh;V;1-1:5.8.1*255;varh;V;1-1:5.8.2*255;varh;V;1-1:5.8.3*255;varh;V;1-1:6.8.1*255;varh;V;1-1:6.8.2*255;varh;V;1-1:6.8.3*255;varh;V;1-1:7.8.1*255;varh;V;1-1:7.8.2*255;varh;V;1-1:7.8.3*255;varh;V;1-1:8.8.1*255;varh;V;1-1:8.8.2*255;varh;V;1-1:8.8.3*255;varh;V;1-1:1.6.0*255;W;V;1-1:1.6.0*255;W;T;1-1:2.6.0*255;W;V;1-1:2.6.0*255;W;T;1-1:5.6.0*255;var;V;1-1:5.6.0*255;var;T;1-1:6.6.0*255;var;V;1-1:6.6.0*255;var;T;1-1:7.6.0*255;var;V;1-1:7.6.0*255;var;T;1-1:8.6.0*255;var;V;1-1:8.6.0*255;var;T;1-1:1.8.0*255;Wh;V;1-1:2.8.0*255;Wh;V;1-1:5.8.0*255;varh;V;1-1:6.8.0*255;varh;V;1-1:7.8.0*255;varh;V;1-1:8.8.0*255;varh;V;0-0:96.8.1*255;h;V;0-0:96.8.2*255;h;V;0-0:96.8.3*255;h;V;0-0:96.8.0*255;h;V;1-1:1.8.5*255;Wh;V;0-0:96.8.5*255;h;V;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;2000-01-01 00:00:00;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;00000.000000;02745.000000;00000.000000;01931.000000;04676.000000;00000.000000;00000.000000

Opcja pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log okresów obrachunkowych.

Wartość domyślna - domyślnie plik logu okresów obrachunkowych nie jest tworzony.

R Rozmiar pliku logu okresów obrachunkowych

Znaczenie: - opcja służy do określenia rozmiaru pliku logu okresów obrachunkowych, zdefiniowanego przy użyciu opcji Log okresów obrachunkowych.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu okresów obrachunkowych wynosi 10 MB.

R Bez logu okresów obrachunkowych

Znaczenie - przy użyciu opcji można wyłączyć odczyt logu okresów obrachunkowych.

Wartość domyślna - domyślnie drajwer odczytuje log okresów obrachunkowych.

R Okres odczytu logu okresów obrachunkowych

Znaczenie - opcja służy do określenia cyklu odczytu logu okresów obrachunkowych z licznika.

Wartość opcji:

liczba - cykl odczytu logu okresów obrachunkowych (w godzinach).

Wartość domyślna - domyślnie odczyt logu okresów obrachunkowych odbywa się co 1 godzinę.

R Horyzont odczytu historii logu okresów obrachunkowych

Znaczenie - przy użyciu opcji deklaruje się, jak daleko w przeszłość historii okresów obrachunkowych będzie sięgać drajwer przy odczycie okresów obrachunkowych.

Wartość domyślna - domyślnie drajwer odczytując historię okresów obrachunkowych, sięga 130 doby wstecz od początku aktualnej doby.

PRZYKŁAD

Przykładowa parametryzacja licznika w kanale KANAL.

R Plik logu: c:\tmp\CtDlmsTcpip\kanal.log

R Log zdarzeń: c:\tmp\CtDlmsTcpip\book.log

R Rozmiar pliku logu zdarzeń: 15

R Okres odczytu logu zdarzeń: 2

R Log profili mocy: c:\tmp\CtDlmsTcpip\profile.log

R Rozmiar pliku logu profili mocy: 20

R Okres odczytu logu profili mocy: 4

R Log okresów obrachunkowych: c:\tmp\CtDlmsTcpip\billing.log

R Log telegramów: TAK

R Horyzont odczytu historii logu profili mocy: 40

2 przypadek

W przypadku użycia kilku liczników - są one parametryzowane na zakładkach tworzonych przy użyciu zakładki DlmsTcpip/Liczniki za pomocą przycisku Dodaj nowy licznik.

Zakładki i parametry identyczne jak w przypadku 1 (w sytuacji pojedynczego licznika, gdy używana jest instalacja point-point).

R Adres fizyczny serwera

Znaczenie - opcja służy do deklarowania tzw. 'lower HDLC address' licznika, parametru niezbędnego do nawiązania połączenia w konfiguracjach multidrop.

Wartość domyślna - domyślnie opcja ma wartość 0.

Wartość opcji:

liczba - adres serwera w postaci dziesiętnej.

W połączeniach point-to-point 'lower HDLC address' nie ma zastosowania.


DMS285 - drajwer protokołu analizatorów DURAG DMS 285

Home > 1.26 DMS285 - drajwer protokołu analizatorów DURAG DMS 285

1.26 DMS285 - drajwer protokołu analizatorów DURAG DMS 285

Przeznaczenie drajwera

Drajwer DMS285 służy do ustanowienia komunikacji pomiędzy komputerem Asixa a komputerem monitorowania emisji DURAG D-MS285. Drajwer współpracuje z urządzeniami realizującymi protokół w wersji 1.22.

Parametryzacja drajwera DMS285 realizowana jest przy użyciu programu Architekt.

Definiowanie kanału logicznego

Deklaracja kanału transmisyjnego wykorzystującego drajwer DMS285 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DMS285

Zakładka DMS285 / Parametry kanału:

Parametry kanału:

Port szeregowy

Nazwa

Kod alarmu

gdzie:

Port szeregowy - numer portu szeregowego, do którego podłączona jest sieć sterowników DMS285;

Nazwa - pozwala na zdefiniowanie nazwy stacji DMS28 (nazwa uzupełniana jest spacjami do 8 znaków); domyślnie jako nazwa stacji przyjmowana jest nazwa kanału logicznego;

Kod alarmu - parametr określa numer alarmu generowanego przez drajwer w przypadku utraty i odzyskania łączności ze stacją. Wartość -1 (domyślna) powoduje brak generacji alarmów. W sytuacji utraty połączenia, razem z kodem alarmu, przekazywana jest liczba charakteryzująca przyczynę utraty połączenia:

0 - zupełny brak jakiejkolwiek odpowiedzi ze strony stacji;

1 - timeout;

2 - błędy linii (błędy ramki, parzystości, overrun);

3 - błędy sumy kontrolnej;

4 - inne błędy.

Liczba ta określa status zakończenia ostatniej próby nawiązania łączności.

Wartość domyślna: brak

Parametry drajwera

Parametry drajwera DMS285 deklarowane są na zakładkach Parametry drajwera.

R Nazwa opcji: szybkość lub baud lub bps

R Wartość opcji: liczba

Znaczenie: pozwala na określenie szybkości transmisji.

Wartość opcji:

liczba - wartość określająca szybkość transmisji w Bd.

Wartość domyślna: 9600 Bd.

R Nazwa opcji: parzystość

R Wartość opcji: parametr_parzystości

Znaczenie: pozwala na określenie parzystości.

Wartość domyślna: e.

Parametr:

Parametr_parzystości - dopuszczalne wartości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

e - space.

R Nazwa opcji: bity stopu lub stop

R Wartość opcji: liczba

Znaczenie: pozwala na określenie ilości bitów stop.

Wartość opcji:

liczba - dopuszczalne wartości to 1 i 2.

Wartość domyślna: 1.

R Nazwa opcji: dlugość słowa lub słowo

R Wartość opcji: liczba

Znaczenie: pozwala na określenie długości słowa.

Wartość opcji:

liczba - dopuszczalne wartości mieszczą się w przedziale od 5 do 8.

Wartość domyślna: 8.

R Nazwa opcji: timeout

R Wartość opcji: liczba

Znaczenie: pozwala na określenie czasu oczekiwania na odpowiedź DMS285a.

Wartość opcji:

liczba - wartość czasu wyrażana w sekundach.

Wartość domyślna: 10.

R Nazwa opcji: Log

R Wartość opcji: nazwa_pliku

Znaczenie: parametr określa nazwę pliku, do którego będą zapisywane dodatkowe informacje diagnostyczne. Parametr można umieścić tylko w sekcjach ’DMS285:n’ i ’DMS285’.

Wartość domyślna: brak.

R Nazwa opcji: Klasy Nieważności

R Wartość opcji: klasa1,klasa2,...,klasaN

Znaczenie: opcja określa numery klas, które powodują nieważność danych 44.5K.n i 44.5M.n Numer klasy pobierany jest ze zmiennej 44.1.n (Klassenangabe der Konz.).

Wartość domyślna: brak (-) - wartość klasy nie ma wpływu na ważność odczytanej danej.

Parametry:

klasa1,klasa2,...,klasaN - numery klas.

R Nazwa opcji: Statusy Nieważności

R Wartość opcji: status1,status2,...,statusN

Znaczenie: parametr określa wartości zmiennej 43.3.n (Zustans des Kanals), dla których wartości zmiennych 43.7K.n, 43.7M.n, 43.9K.n, 43.9M.n, 43.10K.n, i 43.10M.n uznaje się za nieważne.

Wartość domyślna: brak (-) - wartość zmiennej 43.3.n nie ma wpływu na ważność odczytanej danej.

Parametry:

status1,status2,...,statusN - wartości zmiennej 43.3.n (Zustans des Kanals).

R Nazwa opcji: Klasy Nieważności 2

R Wartość opcji: klasa1,klasa2,...,klasaN

Znaczenie: parametr określa numery klas, nieważność danych 44.5K.n i 44.5M.n przy obliczaniu średnich 48-godzinnych. Numer klasy pobierany jest ze zmiennej 44.1.n (Klassenangable der Konz).

Wartość domyślna: brak (-) - wartość klasy nie ma wpływu na ważność odczytanej danej.

Parametry:

klasa1,klasa2,...,klasaN - numer klasy.

R Nazwa opcji: Minimalna ilość pomiarów

R Wartość opcji: liczba

Znaczenie: parametr pozwala określić minimalną ilość pomiarów wymaganą do obliczenia średniej 48-godzinnej.

Wartość domyślna: brak.

R Nazwa opcji: Maksymalna Różnica Czasu

R Wartość opcji: liczba

Znaczenie: określa maksymalną różnicę czasu pomiędzy czasem systemu Asix a czasem stacji DMS285, po przekroczeniu której będą wyprowadzane ostrzeżenia do panelu kontrolnego. Czas stacji odczytywany jest tylko podczas odczytu zmiennych typu 43 i8 50.

Wartość opcji:

liczba - określa wartość czasu w sekundach.

Wartość domyślna: 60.

R Nazwa opcji: Auto_sync lub Autosync

R Wartość opcji: liczba

Znaczenie: określa maksymalną różnicę czasu (w sekundach) pomiędzy czasem systemu Asix a czasem stacji DMS285, po przekroczeniu której drajwer ustawi czas stacji na czas systemu Asix. Synchronizacja czasu następuje tylko w czasie odczytu zmiennych ze stacji. Wartość minimalna tego parametru wynosi 10 sekund. Jeśli podano wartość mniejszą ale różną od zera, to zostanie przyjęte 10 sekund.

Wartość opcji:

liczba – określa wartość czasu w sekundach.

Wartość domyślna: brak synchronizacji czasu.

R Nazwa opcji: MaxAutoSync

R Wartość opcji: liczba

Znaczenie: określa maksymalną różnicę czasu pomiędzy czasem systemu Asix a czasem stacji DMS285, po przekroczeniu której drajwer nie będzie synchronizował czasu stacji - nawet jeśli różnica ta przekracza wartość określoną parametrem AutoSync.

Wartość opcji:

liczba - określa wartość czasu w sekundach.

Wartość domyślna: 6800.

R Nazwa opcji: Ogranicznik_czasu

R Wartość opcji: liczba

Znaczenie: określa maksymalną odchyłkę czasu danych w stosunku do bieżącego czasu systemu, której przekroczenie spowoduje uznanie danej za nieważną. Czas danej odczytanej z komputera DURAG musi zawierać się w przedziale czas bieżący +/- odchyłka, aby dana została uznana za ważną. Jeśli parametr ma wartość 0, to czas danych nie jest sprawdzany.

Wartość opcji:

liczba - określa wartość czasu w godzinach.

Wartość domyślna: 24 godziny.

R Nazwa opcji: Kod alarmu

R Wartość opcji: numer_alarmu

Znaczenie: parametr określa numer alarmu generowanego przez drajwer w przypadku utraty i odzyskania łączności ze stacją. Wartość -1 (domyślna) powoduje brak generacji alarmów. W sytuacji utraty połączenia, razem z kodem alarmu, przekazywana jest liczba charakteryzująca przyczynę utraty połączenia:

0 - zupełny brak jakiejkolwiek odpowiedzi ze strony stacji;

1 - timeout;

2 - błędy linii (błędy ramki, parzystości, overrun);

3 - błędy sumy kontrolnej;

4 - inne błędy.

Liczba ta określa status zakończenia ostatniej próby nawiązania łączności.

Wartość domyślna: brak.

Parametr:

numer_alarmu - numer alarmu generowanego przez drajwer.

R Nazwa opcji: Maksymalna historia

R Wartość opcji: liczba

Znaczenie: określa okres czasu liczony od bieżącej chwili wstecz, dla którego będą odczytywane dane historyczne znajdujące się w pamięci stacji.

Wartość opcji:

liczba - określa wartość czasu w dniach.

Wartość domyślna: 20.

R Nazwa opcji: Zmienna 44_1_n

R Wartość opcji: nazwa_zmiennej,typ_archiwum

Znaczenie: pozwala na zadeklarowanie nazwy zmiennej 44.1.n (wraz z typem archiwum), która jest zapamiętywana w archiwum i jednocześnie jest wykorzystywana do obliczania średniej 48-godzinnej 44.105K.n.

Wartość domyślna: brak.

Parametr:

nazwa_zmiennej - określa nazwę zmiennej 44.1.n; n oznacza numer kanału,

typ_archiwum - po nazwie zmiennej należy po przecinku podać typ archiwum.

PRZYKŁAD

Nazwa sekcji: DMS285

Nazwa opcji: Zmienna_44_1_3

Wartość opcji: K3_H_KLAS_Pyl,M

UWAGA Parametryzując zmienną dla programu ASPAD należy bezwzględnie podać opcję NIE_PAKUJ !!! (w definicji zmiennej, w atrybucie Parametry archiwizacji)

R Nazwa opcji: Zmienna 44_5K_n

R Wartość opcji: nazwa_zmiennej,typ_archiwum

Znaczenie: pozwala zadeklarować nazwę zmiennej 44.5K.n (wraz z typem archiwum), która jest zapamiętywana w archiwum i jednocześnie jest wykorzystywana do obliczania średniej 48-godzinnej 44.105K.n.

Wartość domyślna: brak.

Parametr:

nazwa_zmiennej - określa nazwę zmiennej 44.5K.n; n oznacza numer kanału,

typ_archiwum - po nazwie zmiennej należy po przecinku podać typ archiwum.

PRZYKŁAD

Nazwa sekcji: DMS285

Nazwa opcji: Zmienna_44_5K_3

Wartość opcji: K3_H_KONC_Pyl,M

UWAGA Parametryzując zmienną dla programu ASPAD należy bezwzględnie podać opcję NIE_PAKUJ !!! (w definicji zmiennej, w atrybucie Parametry archiwizacji)

PRZYKŁADY

Przykładowe parametry drajwera.

Przykład 1

Deklaracja kanału:

Nazwa: KOMIN 2

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM2

Parametry drajwera:

Nazwa sekcji: DMS285:2

Nazwa opcji: baud

Wartość opcji: 19200

W powyższym przykładzie zdefiniowano stację o nazwie KOMIN 2 podłączoną do portu COM2. Użyta zostanie prędkość transmisji 19200 bitów na sekundę.

Przykład 2

Deklaracje kanałów:

Nazwa: KOMIN 1

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM2

Nazwa: KOMIN 2

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM2

Nazwa: KOMIN 3

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM2

Nazwa: KOMIN 4

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM3

Nazwa: KOMIN 5

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM3

Nazwa: KOMIN 6

Drajwer: DMS285

Parametry kanału:

Port szeregowy: COM4

Parametry drajwera:

Wartości domyślne dla wszystkich stacji

Nazwa sekcji: DMS285

Nazwa opcji: szybkość transmisji

Wartość opcji: 19200

Nazwa sekcji: DMS285

Nazwa opcji: Statusy Nieważności

Wartość opcji: 1, 6, 14

Wartości domyślne dla stacji podłączonych do portu COM3

Nazwa sekcji: DMS285:3

Nazwa opcji: szybkość

Wartość opcji: 9600

Pozostałe parametry

Nazwa sekcji: KOMIN 2

Nazwa opcji: Statusy Nieważności

Wartość opcji: 5

Nazwa sekcji: KOMIN 4

Nazwa opcji: Statusy Nieważności

Wartość opcji: -

W powyższym przykładzie zdefiniowano stacje o nazwach od KOMIN 1 do KOMIN 6. Do portu COM2 podłączone są stacje KOMIN 1, KOMIN 2 i KOMIN 3. Do portu COM3 podłączone są stacje KOMIN 4 i KOMIN 5. Stacja KOMIN 6 podłączona jest do portu COM4. Wszystkie porty szeregowe z wyjątkiem COM3 będą pracować z szybkością 19200 baud. Port COM3 będzie pracował z szybkością 9600 baud. Wszystkie stacje z wyjątkiem stacji KOMIN 2 i KOMIN 4 będą używać statusów nieważności 1, 6 i 14. Stacja KOMIN 2 jako status nieważności wykorzystuje wartość 5. Stacja KOMIN 4 nie wykorzystuje statusów nieważności - podanie parametru ”-” było konieczne aby zmienić wartości domyślne ustalone w sekcji ’DMS285’.

Definiowanie zmiennych

Definicja zmiennej opiera się na opisie protokołu DMS285.

Wykaz wszystkich typów zmiennych podano na końcu niniejszego punktu.

gdzie:

typ - określa typ informacji np.:

43 - wartości chwilowe,

44 - całki,

17 - parametry;

podtyp - numer zadanej informacji, np. 43 dla wartości chwilowych określa aktualne natężenie prądu w danym kanale;

K,P. - koncentracja/ przepływ (tylko jeśli podtyp zawiera dane dla obu tych kategorii);

idx - indeks - tylko dla zmiennych indeksowanych; np. klasyfikacja; indeks jest liczba >= 1;

kanal - numer kanału; numer kanału można podawać tylko dla wartości związanych z kanałem; w przypadku danych ogólnych należy go pominąć.

Mxx - maska bitowa; xx jest liczbą w kodzie szesnastkowym; na danej otrzymanej ze stacji wykonywana jest operacja AND z liczbą xx;

podpole - nazwa podpola; dla danych, które reprezentują czas, zdefiniowane są następujące podpola:

SEK (SEC), MIN, GODZ (HOUR), DZIEN (DAY), MIES (MONTH), ROK (YEAR) - typ DWORD

CZAS (TIME), DATA (DATE), DATACZAS (DATETIME) - typ TEXT

Do wyświetlenia wartości CZAS,DATA,DATACZAS można użyć obiektu NAPIS. Jako funkcje przeliczającą należy użyć NIC_TEXT. Długość wyświetlanego łańcucha znaków podawana jest jako licznik elementów.

PRZYKŁAD

Przykład deklaracji zmiennej:

AKT_CZAS, Aktualna data i czas stacji, 43.1.DATACZAS.1, KANAL-DMS285, 20,30, NIC_TEXT

Format daty i czasu:

dd-mm-rrrr gg:mm:ss.

Przykład:

43.11.1 - aktualna wartość chwilowa prądu dla kanału analogowego 1

43.1.DZIEN - aktualny czas stacji - numer dnia miesiąca

43.7K.1 - aktualna koncentracja dla kanału 1

43.2[2] - wejścia cyfrowe 16-23

Czas danych

Dane są przekazywane przez drajwer do systemu Asix wraz z czasem ich pozyskania (czas stacji DMS285). W przypadku typów innych niż typ 43, które NIE zawierają aktualnego czasu, czas ustalany jest na podstawie poprzednio odebranego pakietu typu 43 (zmienna 43.1) oraz czasu jego odczytu. Zmiennym 44,1, 44.5K.n i 44.5M.n jest przypisywany czas określony zmienną 44.20. Czas zmiennych pakietu 48 jest zaokrąglany w dół do godziny 00:00. Zmienne pakietu 48 przychodzące o godzinie 00:00 +- 2 min. Są traktowane jako nieważne. Zmienne 44.105M.n i 44.105K.n mają czas zawsze 00:00.

Dane historyczne

Dla zmiennych 44.5K oraz 44.5M możliwy jest odczyt danych historycznych.

Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285

c - oznacza numer kanału 1..32

n - oznacza numer wielkości (schadstoff) 1..15

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285.

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285 (c.d.).

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285 (c.d.).

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285 (c.d.).

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285 (c.d.).

Tabela. Wykaz wszystkich typów zmiennych obsługiwanych przez drajwer DMS285 (c.d.).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DMS500 - drajwer protokołu analizatorów DURAG DMS 500

Home > 1.27 DMS500 - drajwer protokołu analizatorów DURAG DMS 500

1.26 DMS500 - drajwer protokołu analizatorów DURAG DMS 500

Przeznaczenie drajwera

Drajwer DMS500 jest wykorzystywany do wymiany danych pomiędzy komputerami emisji D MS500 i systemem Asix przy wykorzystaniu łączy szeregowych. Drajwer obsługuje urządzenia z zaimplementowanym oprogramowaniem firmowym w wersjach DMS500 v. 1.23, 1.55, 1.59.

Parametryzacja drajwera DMS500 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DMS500 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DMS500

Zakładka DMS500 / Parametry kanału:

Parametry kanału:

Port szeregowy - numer portu szeregowego, do którego podłączona jest sieć sterowników DMS285;

Nazwa - pozwala na zdefiniowanie nazwy stacji DMS28 (nazwa uzupełniana jest spacjami do 8 znaków); domyślnie jako nazwa stacji przyjmowana jest nazwa kanału logicznego;

Raport - nazwa drukarki lub nazwa pliku dyskowego; pozwala zadeklarować miejsce, do którego zostanie przesłany raport odczytany z komputera DMS poprzez odpowiednie wysterowanie pseudozmiennej RAPORT. Jako miejsce docelowe raportu można podać:

- nazwę drukarki,

- nazwę pliku dyskowego;

domyślnie raport przesłany z komputera DMS wysyłany jest na drukarkę (LPT1)

Drajwer DMS500 jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Definicja zmiennej procesowej opiera się na opisie protokołu DMS500: "Beschreibung der Kommunikation D-EVA mit DMS500".

Składnia adresu symbolicznego ma następującą postać:

typ.podtyp [K|M] [idx] [.Mxx|.podpole] [.kanał]

gdzie:

typ - określa typ informacji:

43 - wartości chwilowe,

44 - całki,

45 - parametry,

46 - klasyfikacja wejść analogowych - rezultaty aktualne,

47 - klasyfikacja wejść analogowych - rezultaty roczne,

48 - klasyfikacja wejść analogowych - rezultaty dzienne,

56 - klasyfikacja wejść cyfrowych - rezultaty aktualne,

57 - klasyfikacja wejść cyfrowych - rezultaty roczne,

58 - klasyfikacja wejść cyfrowych - rezultaty dzienne;

podtyp - numer żądanej informacji; np. 13 dla wartości chwilowych określa aktualne natężenie prądu w danym kanale;

K,M - koncentracja/przepływ (tylko wtedy, gdy podtyp zawiera dane dla obu tych kategorii);

idx - indeks - tylko dla zmiennych indeksowanych; np. klasyfikacja. Indeks jest liczbą większą lub równą 1;

Mxx - maska bitowa; xx jest liczbą w kodzie szesnastkowym; na danej otrzymanej z komputera DMS wykonywana jest operacja AND z liczbą xx;

Podpole - nazwa podpola; dla wartości czasu zdefiniowane są następujące podpola: SEK,MIN,GODZ,DZIEN,MIES,ROK;

Kanał - numer kanału; numer kanału można podawać tylko dla wartości związanych z kanałem; w przypadku danych ogólnych należy go pominąć.

Przykłady

43.14.1 - aktualna wartość chwilowa prądu dla kanału analogowego 1

43.1.DZIEN - aktualny czas komputera DMS - numer dnia miesiąca

43.17K.1 - aktualna koncentracja dla kanału 1

46.4K[5].1 - aktualna wartość klasy 5 (koncentracja) dla kanału 1

Zmienna specjalna RAPORT

Zmienna specjalna RAPORT jest pseudozmienną typu słowo 16-bitowe. Zapisanie w niej określonej wartości powoduje odczytanie z komputera DMS odpowiedniego raportu określonego tą wartością.

Raport zostanie wysłany do miejsca określonego w opcji RAPORT.

Dostęp do danych historycznych

Drajwer DMS500 umożliwia modułowi archiwizującemu ASPAD dostęp do następujących danych historycznych:

44.9K - numer klasy dla koncentracji,

44.9M - numer klasy dla przepływu,

44.16K - wartość koncentracji,

44.16M - wartość przepływu.

Czas danych

Dane są przekazywane do systemu Asix wraz z czasem ich pozyskania. W przypadku typu 45, dla którego pakiet danych nie zawiera aktualnego czasu (pole nr 1 lub 10 dla typów 56,57,58), czas ustalany jest na podstawie poprzednio odebranego pakietu z czasem oraz czasu jego odczytu.

UWAGA Pakiety danych nie zawierają czasu dla typu 45.

Dane niepoprawne

Dla danych 43.14 i 43.15, komputer DMS przesyła dane statusowe (43.13). Jeżeli jakikolwiek bit (zdefiniowany w opisie protokołu) będzie ustawiony, to taka dana traktowana jest jako niepoprawna.

Parametry drajwera DMS500

Parametry drajwera DMS500 deklarowane są na zakładkach Parametry drajwera.

R Szybkość transmisji

Znaczenie: służy do deklarowania prędkości transmisji.

Wartość opcji:

liczba - prędkość transmisji w bodach.

Wartość domyślna: domyślnie przyjmowana jest prędkość transmisji 9600 Bd.

R Parzystość

Znaczenie: służy do deklarowania sposobu kontroli parzystości.

Wartość domyślna: domyślnie przyjmowana jest kontrola parzystości parzysta.

Parametr:

typ_kontroli - identyfikator sposobu kontroli parzystości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

s - space.

R Bity stopu

Znaczenie: służy do deklarowania liczby bitów stopu.

Wartość opcji:

liczba - liczba bitów stopu: 1 lub 2.

Wartość domyślna: domyślnie przyjmuje się 1 bit stopu.

R Długość słowa

Znaczenie: służy do deklarowania liczby bitów w transmitowanym znaku.

Wartość opcji:

liczba - liczba bitów w znaku (od 5 do 8).

Wartość domyślna: domyślnie przyjmuje się, że transmitowany znak ma 8 bitów.

R Timeout

Znaczenie: służy do deklarowania czasu oczekiwania na odpowiedź z komputera DMS.

Wartość opcji:

liczba - czas oczekiwania na odpowiedź w sekundach.

Wartość domyślna: domyślnie przyjmuje się 10 sekund.

R Automatyczna synchronizacja czasu (Auto sync)

Znaczenie: służy do deklarowania automatycznej synchronizacji zegara komputera systemu Asix z zegarem komputera DMS. Wartość parametru określa maksymalną rozbieżność czasów, po przekroczeniu której następuje synchronizacja. Czas z komputera DMS jest otrzymywany tylko w trakcie odczytu innych danych.

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach; 0 oznacza brak synchronizacji.

Wartość domyślna: domyślnie czas nie jest synchronizowany.

R Czas buforów historii

Znaczenie: służy do deklarowania czasu, po upływie którego będą usuwane bufory zawierające dane historyczne odczytane na potrzeby modułu archiwizującego ASPAD. Czas podaje się w minutach.

Wartość parametru:

liczba - czas w minutach, po którym następuje synchronizacja.

Wartość domyślna: domyślnie bufory historyczne są usuwane po upływie 30 minut.

R Maksymalna ilość buforów historii

Znaczenie: służy do deklarowania maksymalnej ilości buforów, zawierających dane historyczne odczytane na potrzeby modułu archiwizującego. Jeden bufor zawiera dane historyczne dla jednego kanału. Jest on utrzymywany w pamięci przez okres określony w opcji Czas buforów historii. Jeden bufor zajmuje 30 bajtów pamięci. Jeżeli dane archiwalne są pamiętane przez komputer DMS co 30 minut, to na jedną dobę potrzebne jest 48 buforów.

Wartość domyślna: domyślnie używa się 50000 buforów.

R Różnica Czasu

Znaczenie: służy do deklarowania różnicy czasu w sekundach pomiędzy wskazaniami zegara komputera systemu Asix i zegara komputera DMS. Nawet jeśli czas wyświetlany na wyświetlaczu komputera DMS jest taki sam, jak czas komputera Asix, to czas otrzymywany łączem szeregowym, jako ilość sekund od dnia 01.01.1970 r. może różnić się od faktycznego czasu komputera DMS.

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: domyślnie przyjmuje się 3600 sekund.

R Raport

Znaczenie: pozwala zadeklarować miejsce, do którego zostanie przesłany raport odczytany z komputera DMS poprzez odpowiednie wysterowanie pseudozmiennej RAPORT; jako miejsce docelowe raportu można podać:

- nazwę drukarki,

- nazwę pliku dyskowego;

Wartość opcji:

nazwa - nazwa drukarki lub nazwa pliku dyskowego;

Wartość domyślna: domyślnie raport przesłany z komputera DMS wysyłany jest na drukarkę (LPT1).

R Maksymalna historia

Znaczenie: pozwala zadeklarować okres czasu liczony od bieżącej chwili wstecz, dla którego będą odczytywane dane historyczne znajdujące się w pamięci komputera DMS.

Wartość opcji:

liczba - okres czasu w dniach.

Wartość domyślna: domyślnie przyjmuje się okres 35 dni.

Przykłady

Przykład 1

W przykładzie zdefiniowano komputer DMS o nazwie SIERSZA, podłączony do portu COM2. Jeśli różnica pomiędzy czasem komputera systemu Asix i czasem komputera DMS przekroczy 50 sekund, to nastąpi synchronizacja zegarów.

Deklaracja kanału:

Nazwa: SIERSZA

Drajwer: DMS500

Parametry kanału: COM2

Parametry drajwera:

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 50

Przykład 2

W przykładzie zdefiniowano komputery DMS o nazwach:

SIERSZA1,

SIERSZA2,

SIERSZA3,

SIERSZA4,

SIERSZA5,

SIERSZA6.

Do portu COM2 komputera systemu Asix podłączone są komputery DMS o nazwach:

SIERSZA1,

SIERSZA2,

SIERSZA3.

Do portu COM3 komputera systemu Asix podłączone są komputery DMS o nazwach:

SIERSZA4,

SIERSZA5.

Komputer DMS SIERSZA6 podłączony jest do portu COM4.

Porty COM2 i COM4 będą pracować z szybkością 19200 baud. Port COM3 będzie pracować z szybkością 9600 baud.

Zegary wszystkich komputerów DMS (z wyjątkiem SIERSZA6) będą synchronizowane z zegarem komputera systemu Asix, gdy różnica czasu przekroczy 60 sekund. Zegar komputera DMS SIERSZA6 nie będzie synchronizowany.

Raporty odczytywane za pomocą pseudozmiennej RAPORT będą drukowane na drukarce LPT1:. Wyjątkiem jest komputer DMS SIERSZA6, którego raporty będą zapamiętywane w pliku C:\RAP\SIERSZA6.RAP.

Deklaracje kanałów:

Nazwa: SIERSZA1

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM2

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 19200

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 60

***

Nazwa: SIERSZA2

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM2

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 19200

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 60

***

Nazwa: SIERSZA3

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM2

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 19200

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 60

***

Nazwa: SIERSZA4

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM3

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 9600

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 60

***

Nazwa: SIERSZA5

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM3

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 9600

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 60

***

Nazwa: SIERSZA6

Drajwer: DMS500

Parametry kanału:

Port szeregowy: COM4

Raport: C:\RAP\SIERSZA6.RAP

Parametry drajwera:

R Szybkość transmisji

Wartość opcji: 19200

R Automatyczna synchronizacja czasu (Auto sync)

Wartość opcji: 0

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DNP3

Home > 1.28 DNP3 - drajwer protokołu dla elektroenergetycznych systemów sterowania i nadzoru

1.28 DNP3 - drajwer protokołu dla elektroenergetycznych systemów sterowania i nadzoru

Przeznaczenie drajwera

Niniejszy opis dotyczy drajwera protokołu DNP3. Drajwer obsługuje komunikację z wykorzystaniem łącza szeregowego, protokołu TCP oraz UDP.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DNP3 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DNP3

Zakładka DNP3:

Parametry kanału:

parametry_komunikacyjne, adres_lokalny, adres_zdalny

gdzie:

parametry_komunikacyjne - określają sposób komunikacji i są opisane dalej;

adres_lokalny - określa adres DNP3 używany przez drajwer;

adres_zdalny - określa dres DNP3 zdalnego urządzenia.

Parametry komunikacyjne dla łącza szeregowego mają postać:

nazwa_portu_szeregowego[:szybkość:bity_danych:parzystość:bity_stopu]

Na przykład: "COM1:19200:8:n:1"

Parzystość może być literą n (brak kontroli przystości), p (parzystość), o (nieparzystość), m (mark) i s (space).

Jeśli łącze ma pracować z parametrami 9600:8:n:1 to można je pominąć.

Parametry komunikacyjne dla protokołu TCP i UDP mają postać:

nazwa_protokołu:adres_ip[:numer_portu][|[lokalny_adrs_ip]:lokalny_port]

gdzie:

nazwa_protokołu - może mieć wartość TCP lub UDP;

adres_ip - adres IP zdalnego urządzenia (można również podać nazwę w systemie DNS);

numer_portu - numer portu, na którym zdalne urządzenie oczekuje na połączenie;

lokalny_adrs_ip - adres lokalny karty sieciowej, która ma być wykorzystana do nawiązania połączenia;

lokalny_port - lokalny port, który ma być wykorzystany do nawiązania połączenia.

Jeśli zdalne urządzenie oczekuje na port 20000 do nawiązywania połączeń, to parametr numer_portu można pominąć.

Parametr lokalny_adrs_ip podaje się, gdy istnieje wiele kart sieciowych, za pomocą których można nawiązać połączenie i należy wykorzystać jedną konkretną z nich.

Parametr lokalny_port podaje się, gdy zdalne urządzenie oczekuje nawiązania połączenia z użyciem konkretnego portu.

PRZYKŁAD

Przykłady deklaracji kanałów:

DNP3, COM1, 3, 4

Powyższa deklaracja służy do połączenia za pośrednictwem portu szeregowego z urządzeniem o adresie 4. Lokalny adres DNP3 to 3.

DNP3,TCP:192.168.0.15, 3, 4

Powyższa deklaracja służy do połączenia z wykorzystaniem protokołu TCP ze zdalnym urządzeniem znajdującym się pod adresem 192.168.0.15. Zdalne urządzenie oczekuje połączeń na porcie 20000, więc został on pominięty. Zdalne urządzenie ma adres DNP3 4. Lokalny adres DNP3 to 3.

DNP3,UDP:192.168.0.15|:20000, 3, 4

Powyższa deklaracja służy do połączenia z wykorzystaniem protokołu UDP ze zdalnym urządzeniem znajdującym się pod adresem 192.168.0.15. Zdalne urządzenie oczekuje na odbiór pakietów UDP na porcie 20000, więc został on pominięty. Urządzenie kieruje odpowiedzi na odebrane pakiety do portu 20000 i w związku z tym został jawnie podany port, na którym drajwer oczekuje tych odpowiedzi. Zdalne urządzenie ma adres DNP3 4. Lokalny adres DNP3 to 3.

Parametry kanału są wyszczególnione w punkcie Parametry drajwera/kanału.

Deklaracja zmiennych

Dostępne są następujące zmienne:

Tab. Zestawienie zmiennych dla drajwera DNP3.

Symbol

Opis

Rozmiar danej funkcji przeliczającej

In

Stan wejścia binarnego o adresie n. Jeśli bit statusowy "online" ma wartość 0 lub ustawiony jest bit statusowy "communcation lost", to zmienna otrzymuje jakość złą.

1 bajt

In.Onl lub In.0

Stan bitu "online" wejścia binarnego o adresie n.

1 bajt

In.RS lub In.1

Stan bitu "restart" wejścia binarnego o adresie n.

1 bajt

In.CL lub In.2

Stan bitu statusowego "communication lost" wejścia binarnego o adresie n.

1 bajt

In.RF lub In.3

Stan bitu statusowego "remote forced" wejścia binarnego o adresie n.

1 bajt

In.LF lub In.4

Stan bitu statusowego "local forced" wejścia binarnego o adresie n.

1 bajt

In.CF lub In.5

Stan bitu statusowego "chatter filter" wejścia binarnego o adresie n.

1 bajt

In.Res lub In.6

Stan bitu statusowego "reserved" wejścia binarnego o adresie n.

1 bajt

In.ST lub In.7

Stan wejścia binarnego o adresie n. Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

In.FL

Stan wszystkich bitów statusowych (flags) wejścia binarnego o adresie n. Bity mają takie same numery jak w adresach powyżej o adresacji In.m (liczba m). Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

IGn-m

Grupa wejść binarnych o adresach od n do m włącznie. Stan wejścia n zajmuje bit 0 a kolejne bity odpowiadają kolejnym wejściom. Jeśli bit statusowy "communication lost" jest ustawiony dla jakiegokolwiek wejścia lub nie jest ustawiony bit statusowy "online" - to jakość zmiennej jest zła. Podobnie jak dla pojedynczych wejść binarnych, do adresu można dodać kropkę i numer lub nazwę bitu statusowego, aby otrzymać grupę wartości tych statusów.

1, 2 lub 4 bajty w zależności od ilości bitów

DIn

Stan wejścia binarnego 2-bitowego o adresie n. Adresacja tych wejść jest identyczna jak wejść binarnych In, z tym że bit statusowy "reserved" ma wartość drugiego bitu wejścia.

1 bajt

On

Stan wyjścia binarnego o adresie n. Jeśli bit statusowy "online" ma wartość 0 lub ustawiony jest bit statusowy "communcation lost", to zmienna otrzymuje jakość złą.

1 bajt.

On.Onl lub On.0

Stan bitu "online" wyjścia binarnego o adresie n.

1 bajt

On.RS lub On.1

Stan bitu "restart" wyjścia binarnego o adresie n.

1 bajt

On.CL lub On.2

Stan bitu statusowego "communication lost" wyjścia binarnego o adresie n.

1 bajt

On.RF lub On.3

Stan bitu statusowego "remote forced" wyjścia binarnego o adresie n.

1 bajt

On.LF lub On.4

Stan bitu statusowego "local forced" wyjścia binarnego o adresie n.

1 bajt

On.Res1 lub On.5

Stan bitu statusowego "reserved" wyjścia binarnego o adresie n.

1 bajt

On.Res2 lub On.6

Stan bitu statusowego "reserved" wyjścia binarnego o adresie n.

1 bajt

On.ST lub On.7

Stan wyjścia binarnego o adresie n. Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

On.FL

Stan wszystkich bitów statusowych (flags) wyjścia binarnego o adresie n. Bity mają takie same numery jak w adresach powyżej o adresacji In.m (liczba m). Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

On. Code

Określenie sposobu sterowania wyjściem binarnym. Do zmiennej o takim adresie wpisuje się jedną z poniższych wartości:

0 - brak operacji

1 - ustaw wyjście na czas określony przez zmienną o adresie On.OnTime, a następnie wyzeruj go na czas określony przez zmienną On.OffTime (pulse on)

2 - wyzeruj wyjście na czas określony przez zmienną o adresie On.OffTime, a następnie ustaw go na czas określony przez zmienną On.OnTime (pulse off)

3 - ustaw wyjście na 1 (latch on)

4 - ustaw wyjście na 0 (latch off)

1 bajt

On.Close

Określenie sposobu sterowania wyjściem:

0 - brak operacji lub aktywacja wyjścia

1 - wykonanie operacji "close"

2 - wykonanie operacj "trip"

1 bajt

On.Count

Wartość takiej zmiennej określa: ile razy ma być wykonane dane sterowanie (domyślnie 1)

1 bajt

On. Queue

Jeśli wartość zmiennej jest różna od zera, to operacja sterowania jest umieszczana na końcu kolejki do ponownego wykonania. (Wartość domyślna 0)

1 bajt

On.Clear

Jeśli zmienna ma wartość różną od zera, to nastąpi usunięcie istniejących elementów z kolejki sterowań. (Wartość domyślna 0)

1 bajt

On.OnTime

Określa czas ustawienia wyjścia binarnego na 1 dla operacji "pulse on" i "pulse off".

4 bajty

On.OffTime

Określa czas ustawienia wyjścia binarnego na 0 dla operacji "pulse on" i "pulse off".

4 bajty

On.Exec

Zapis odpowiedniej wartości do tej zmiennej powoduje zainicjowanie sterowania. Poszczególne wartości mają następujące znaczenie:

2 - wysteruj bezpośrednio (direct operate)

3 - wysteruj bezpośrednio bez potwierdzenia (direct operate no acknowledge)

4 - wysteruj (operacja musi być poprzedzona operacją wybierz (5)

5 - wybierz (select)

6 - drajwer automatycznie wykona najpierw operację "wybierz"(5), a następnie "wysteruj"(4)

1 bajt

On. CtlSts

Po wysłaniu polecania sterowania urządzenie przesyła zwrotnie status żądania. Zmienna otrzymują wartość równą temu statusowi.

Możliwe wartości statusu:

0 - żądanie sterowania zostało zaakceptowane, zainicjowane lub zakolejkowane

1 - żądanie zostało odrzucone, ponieważ żądanie operacji "wysteruj" (4) zostało wysłane zbyt późno po wysłaniu żądania "wybierz" (5)

2 - żadanie zostało odrzucone, ponieważ operacja "wysteruj" (4) nie została poprzedzona operacją "wybierz" (5)

3 - żądanie zostało odrzucone z powodu błędów formatowania

4 - żądanie zostało odrzucone, ponieważ dane wyjście binarne nie realizuje takiej operacji

5 - żądanie zostało odrzucone, ponieważ kolejka jest pełna lub wyjście jest aktywne

6 - żądanie zostało odrzucone z powodu problemów sprzętowych

1 bajt

AIn

Stan wejścia analogowego o adresie n. Jeśli bit statusowy "online" ma wartość 0 lub ustawiony jest bit statusowy "communcation lost", to zmienna otrzymuje jakość złą.

2 lub 4 bajty w zależności od rozmiaru danych w urządzeniu

AIn.Onl lub AIn.0

Stan bitu "online" wejścia analogowego o adresie n.

1 bajt

AIn.RS lub AIn.1

Stan bitu "restart" wejścia analogowego o adresie n.

1 bajt

AIn.CL lub AIn.2

Stan bitu statusowego "communication lost" wejścia analogowego o adresie n.

1 bajt

AIn.RF lub AIn.3

Stan bitu statusowego "remote forced" wejścia analogowego o adresie n.

1 bajt

AIn.LF lub AIn.4

Stan bitu statusowego "local forced" wejścia analogowego o adresie n.

1 bajt

AIn.OR lub AIn.5

Stan bitu statusowego "over range" wejścia analogowego o adresie n.

1 bajt

AIn.RC lub AIn.6

Stan bitu statusowego "resference check" wejścia analogowego o adresie n.

1 bajt

AIn.Res lub AIn.7

Stan bitu statusowego "reserved" wejścia analogowego o adresie n.

1 bajt

AIn.FL

Stan wszystkich bitów statusowych (flags) wejścia analogowego o adresie n. Bity mają takie same numery jak w adresach powyżej o adresacji AIn.m (liczba m). Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

AIn.Val

Wartość wejścia analogowego niezależna od bitów statusowych "communication lost" oraz "online".

2 lub 4 bajty w zależności od rozmiaru danych w urządzeniu

AOn

Stan wyjścia analogowego o adresie n. Jeśli bit statusowy "online" ma wartość 0 lub ustawiony jest bit statusowy "communcation lost", to zmienna otrzymuje jakość złą.

2 lub 4 bajty w zależności od rozmiaru danych w urządzeniu

AOn.Onl lub AOn.0

Stan bitu "online" wyjścia analogowego o adresie n.

1 bajt

AOn.RS lub AOn.1

Stan bitu "restart" wyjścia analogowego o adresie n.

1 bajt

AOn.CL lub AOn.2

Stan bitu statusowego "communication lost" wyjścia analogowego o adresie n.

1 bajt

AOn.RF lub AOn.3

Stan bitu statusowego "remote forced" wyjścia analogowego o adresie n.

1 bajt

AOn.Res1 lub AOn.4

Stan bitu statusowego "reserved" wyjścia analogowego o adresie n.

1 bajt

AOn.Res2 lub AOn.5

Stan bitu statusowego "reserved" wyjścia analogowego o adresie n.

1 bajt

AOn.Res3 lub AOn.6

Stan bitu statusowego "reserved" wyjścia analogowego o adresie n.

1 bajt

AOn.Res4 lub AOn.7

Stan bitu statusowego "reserved" wyjścia analogowego o adresie n.

1 bajt

AOn.FL

Stan wszystkich bitów statusowych (flags) wyjścia analogowego o adresie n. Bity mają takie same numery jak w adresach powyżej o adresacji AIn.m (liczba m). Jakość zmiennej o tym adresie nie zależy od bitów "communication lost" i "online".

1 bajt

AOn.CtlVal

Nowa wartość wyjścia analogowego

2 lub 4 bajty w zależności od rozmiaru danych w urządzeniu

AOn.Exec

Zapis odpowiedniej wartości do tej zmiennej powoduje zainicjowanie sterowania. Poszczególne wartości mają następujące znaczenie:

2 - wysteruj bezpośrednio (direct operate)

3 - wysteruj bezpośrednio bez potwierdzenia (direct operate no acknowledge)

4 - wysteruj (operacja musi być poprzedzona operacją wybierz (5))

5 - wybierz (select)

6 - drajwer automatycznie wykona najpierw operację "wybierz"(5), a następnie "wysteruj"(4)

1 bajt

AOn.CtlSts

Status operacji sterowania. Znaczenie statusu jest takie samo jak dla wyjść binarnych.

1 bajt

IIN

Internal Indications - zestaw znaczników dołączanych przez urządzenie do każdej przesyłanej informacji na poziomie warstwy aplikacji.

2 bajty

IIN.BCAST lub IIN.0

Urządzenie odebrało komunikat typu "broadcast".

1 bajt

IIN.C1 lub IIN.1

Urządzenie posiada w buforze zdarzenia klas 1.

1 bajt

IIN.C2 lub IIN.2

Urządzenie posiada w buforze zdarzenia klas 2.

1 bajt

IIN.C3 lub IIN.3

Urządzenie posiada w buforze zdarzenia klas 3.

1 bajt

IIN. TSYNC lub IIN.4

Urządzenie żąda synchronizacji czasu.

1 bajt

IIN.LOC lub IIN.5

Niektóre lub wszystkie wejścia binarne są w trybie lokalnym.

1 bajt

IIN. DTRBL lub IIN.6

Urządzenie sygnalizuje problemy.

1 bajt

IIN. RSTRT lub IIN.7

Nastąpiło ponowne uruchomienie urządzenia.

1 bajt

IIN. NIMPL lub IIN.8

Niezaimplementowana funkcja.

1 bajt

IIN. OUNK lub IIN.9

Nieznany obiekt.

1 bajt

IIN. INVPARAM lub IIN.10

Niepoprawny parametr.

1 bajt

IIN. OVRFL lub IIN.11

Przepełnienie bufora zdarzeń.

1 bajt

IIN. EXEC lub IIN.12

Żądanie sterowania jest poprawne ale inne sterowanie jest aktualnie wykonywane.

1 bajt

IIN. CFGCORR lub IIN.13

Urządzenie ma uszkodzoną konfigurację

1 bajt

IIN.Res1 lub IIN.14

Znacznik zarezerwowany.

1 bajt

IIN.Res1 lub IIN.15

Znacznik zarezerwowany.

1 bajt

Sterowanie

Sterowanie wyjściami binarnymi polega na wysłaniu do urządzenia zestawu danych opisujących żądaną operację (control relay output block). Do poszczególnych elementów tego zestawu można przypisać zmienne o adresach: On.Code, On.Close, On.Clear, On.Queue, On.OnTime oraz On.OffTime (n oznacza numer wyjścia binarnego). Przynajmniej zmienna On.Code musi być zdefiniowana. Poprzez zapis określonych wartości do tych zmiennych następuje ustalenie zawartości wysyłanego zestawu danych. Znaczenie tych wartości zostało opisane w punkcie dotyczącym adresacji zmiennych. Dodatkowo, można zdefiniować zmienną o adresie On.CtlSts, która po wysłaniu otrzyma status realizacji sterowania. Wysłanie sterowania inicjowane jest zapisem określonej wartości do zmiennej o adresie On.Exec.

W przypadku wyjść analogowych należy zdefiniować zmienną o adresie AOn.CtlVal, do której wpisuje się nową wartość wyjścia analogowego. Zapis do zmiennej o adresie AOn.Exec odpowiedniej wartości, mającej to samo znaczenie co wartość On.Exec, spowoduje zainicjowanie sterowania. Rezultat operacji zostaje wpisany do zmiennej o adresie AOn.CtlSts.

Sterowanie można zrealizować wykonując akcję złożoną, składającą się z serii operacji składowych ustalających wartości poszczególnych zmiennych. Ostatnia akcja w serii powinna zapisać odpowiednią wartość do zmiennej o adresie On.Exec.

Na przykład sekwencja akcji:

USTAW_WARTOŚĆ nazwa_zmienne_typu_On.Codej 3

USTAW_WARTOŚĆ nazwa_zmienne_typu_On.Exec 2

może służyć do ustawienia danego wyjścia za pomocą operacji ”direct operate”.

Alarmy

Zmianę wartości zmiennej drajwera DNP3 można powiązać z generacją alarmów. W tym celu, do adresu zmiennej należy dodać parametr dodatkowy - definicje alarmów - w tym:

- definicja alarmu może mieć postać:

ABalarm_no bit_no

lub

AXalarm_no bit_no

lub

ALalarm_no relacja wartość

oraz alarmy związane ze sterowaniami, które są opisane dalej.

Alarmy typu AB są podobne do strategii bitowej systemu Asix. Alarm_no definiuje numer pierwszego alarmu. Alarm ten jest skojarzony z bitem bit_no wartości zmiennej. Kolejne bity wartości zmiennej są skojarzone z alarmami o kolejnych numerach. Ustawienie bitu na 1 powoduje wygenerowanie nowego alarmu, a wyzerowanie bitu powoduje zakończenie alarmu.

Alarmy AX działają tak jak alarmy AB, z tym że definicja dotyczy tylko jednego konkretnego bitu bit_no. Pozostałe bity nie są analizowane.

Pierwszy bit wartości ma numer 0.

Alarm typu AL jest generowany, gdy wartość zmiennej spełnia relację.

Możliwe są następujące relacje:

= lub == - równość

!= lub <> - nierówność

> - większe niż

>= - większe lub równe

< - mniejsze niż

<= - mniejsze lub równe

Przykłady:

AI7[AL300=1:AL301=3]

Alarm 301 zostanie wygenerowany, gdy wartość zmiennej (położenie łącznika) wynosi 1 (ON). Alarm 301 zostanie wygenerowany, gdy wartość zmiennej wynosi 3 (pośrednie położenie łącznika).

AI7[AL500>32,76]

Alarm zostanie wygenerowany, gdy wartość zmiennej przekroczy 32,76.

AI7[AX600 1]

Ustawienie bitu nr 1 wartości zmiennej spowoduje wygenerowanie alarmu o numerze 600.

Parametr "Global_alarms" określa rodzaj generowanych alarmów i jeśli ma on wartość "Tak", to generowane są alarmy globalne. Ponieważ parametr dotyczy całego drajwera, to można go umieścić w sekcji [DNP3DRV].

Pierwszy parametr generowanego alarmu ma wartość równą wartości zmiennej.

  • Alarmy związane ze sterowaniem

Wykonanie sterowania wyjściem binarnym i analogowym można powiązać z generacją alarmów.

Alarmy te mają postać:

CAOalarm_no - alarm jest generowany, gdy wykonano operację "latch on", "pulse on" lub gdy nastąpiło sterowanie wyjściem analogowym

CAFalarm_no - alarm jest generowany, gdy wykonano operację "latch off" lub "pulse off"

CATalarm_no - alarm jest generowany, gdy wykonano operację "trip"

CACalarm_no - alarm jest generowany, gdy wykonano operację "close"

Pierwszym parametrem generowanego alarmu jest nazwa użytkownika zalogowanego do sytemu Asix.

Parametry drajwera/kanału

UWAGA: Parametry drajwera można umieszczać w sekcji o nazwie takiej jak nazwa kanału oraz w sekcji o nazwie DNP3DRV. Umieszczenie parametru w sekcji DNP3DRV pozwala uniknąć podawania tego samego parametru dla każdego urządzenia, tzn. parametry umieszczone w sekcji DNP3DRV stają się wartościami domyślnymi dla wszystkich urządzeń. Jeśli jednak jakieś urządzenie musi mieć wartość parametru inną niż ta podana w sekcji DNP3DRV, to należy taki parametr umieścić w sekcji o takiej samej nazwie jak nazwa kanału. Parametry umieszczone w takiej sekcji mają wyższy priorytet niż parametry umieszczone w sekcji DNP3DRV.

Parametry Log oraz Dump mogą zawierać ciąg znaków "%s", który zostanie zastąpiony nazwą kanału dla parametru Log oraz nazwą portu szeregowego dla parametru Dump. Umieszczenie parametru Log zawierającego ciąg "%s" w sekcji DNP3DRV spowoduje utworzenie plików logu dla każdego urządzenia. Jeśli plik logu nie jest potrzebny dla jakiegoś urządzenia, to należy podać "-".

Parametry określające odcinek czasu (np. interwał z jakim wysyłane są zapytania o nowe zdarzenia) mają wartość wyrażoną w milisekundach. Można jednak używać literowych oznaczeń jednostek czasu: d - dni, g i h - godziny, m - minuty, s - sekundy i ms - milisekundy, np. 2g 10m 5s - co oznacza dwie godziny dziesięć minut i 5 sekund.

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: AIPollPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim odczytywane są wejścia analogowe. Jeśli parametr ma wartość 0, to wejścia analogowe nie są odczytywane.

Wartość opcji:

liczba - czas w milisekundach.

Wartość domyślna: Domyślnie wartość opcji wynosi 0

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: AppTmo

R Wartość opcji: liczba

Znaczenie: Czas oczekiwania na odpowiedź urządzenia.

Wartość opcji:

liczba - czas w milisekundach (warstwa aplikacji).

Wartość domyślna: Domyślnie wartość opcji wynosi 3000

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: AppRetries

R Wartość opcji: liczba

Znaczenie: Ilość powtórzeń wysyłania żądania do urządzenia, jeśli poprzednie zakończyły się niepowodzeniem (warstwa aplikacji).

Wartość opcji:

liczba

Wartość domyślna: Domyślnie wartość opcji wynosi 3

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: BIPollPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim odczytywane są wejścia binarne. Jeśli parametr ma wartość 0 to wejścia binarne nie są odczytywane. Parametr stosuje się, jeśli urządzenie nie informuje automatycznie o zmianie stanów wejść binarnych.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 0

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: ConfMode

R Wartość opcji: never/ fragment/ always

Znaczenie: Tryb potwierdzania wiadomości w warstwie łącza danych:

never - drajwer nie wymaga potwierdzania wiadomości przez urządzenie;

fragment - drajwer wymaga potwierdzeń w przypadku wiadomości składającej się z wielu fragmentów;

always - drajwer zawsze wymaga potwierdzania wysłanych wiadomości.

Wartość domyślna: Domyślnie wartość opcji wynosi: never.

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: ConfTmo

R Wartość opcji: liczba

Znaczenie: Czas oczekiwania na odpowiedź urządzenia (warstwa łącza danych). Parametr ma znaczenie tylko wtedy, gdy parametr ConfMode ma wartość różną od "never".

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 2000

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: DFCPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim drajwer wysyła komunikat "Request Link Status" sprawdzający stan urządzenia po otrzymaniu informacji, że jego bufory mogą się przepełnić - tj. wtedy gdy urządzenie ustawiło bit DFC ("data flow control"). Parametr warstwy łącza danych.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 500

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: LTestPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim drajwer wysyła komunikat "Test Link". Komunikat jest wysyłany w przypadku bezczynności łącza. Parametr dotyczy warstwy łącza danych. Wartość 0 wyłącza testowanie łącza.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 1m

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: EventMode

R Wartość opcji: none / poll / detect / unsol

Znaczenie: Tryb obsługi zdarzeń:

none - urządzenie nie generuje zdarzeń;

poll - drajwer odpytuje cyklicznie urządzenie o nowe zdarzenia z interwałem określonym przez parametr EPollPd;

detect - w chwili uruchomienia drajwer wysyła wiadomość pozwalającą określić, czy urządzenie spontanicznie wysyła informację o nowych zdarzeniach;

unsol - urządzenie spontanicznie, z własnej inicjatywy informuje o wystąpieniu nowych zdarzeń.

Wartość domyślna: Domyślnie wartość opcji wynosi: detect.

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: EPollPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim drajwer odpytuje urządzenie o nowe zdarzenia.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 5000

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: IntgPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim drajwer odpytuje urządzenie o bieżący stan wszystkich danych (integrity period). Wartość 0 wyłącza odpytywanie urządzenia; jest to wykonywane przez drajwer w chwili uruchomienia i po restarcie urządzenia.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 0

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: MaxFrame

R Wartość opcji: liczba

Znaczenie: Maksymalna długość komunikatu wysyłanego do urządzenia. Parametr warstwy łącza danych.

Wartość opcji:

liczba

Wartość domyślna: Domyślnie wartość opcji wynosi 255

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: MaxFragment

R Wartość opcji: liczba

Znaczenie: Maksymalna długość fragmentu danych wysyłanego przez urządzenie. Parametr warstwy transportowej.

Wartość opcji:

liczba

Wartość domyślna: Domyślnie wartość opcji wynosi 2048

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: SendInterval

R Wartość opcji: liczba

Znaczenie: Minimalny odcinek czasu pomiędzy kolejnymi komunikatami wysyłanymi do urządzenia. Parametr wartswy łącza danych.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 50

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: Retries

R Wartość opcji: liczba

Znaczenie: Ilość powtórzeń wysyłania komunikatu do urządzenia, jeśli poprzednie próby skończyły się niepowodzeniem. Parametr ma zastosowanie wtedy, gdy parametr ConfMode wymaga potwierdzeń. Parametr warstwy łącza danych.

Wartość opcji:

liczba

Wartość domyślna: Domyślnie wartość opcji wynosi 3

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: TMeasDly

R Wartość opcji: TAK/NIE

Znaczenie: Parametr określa, czy urządzenie posiada funkcję pomiaru opóźnienia transmisji. Pomiar taki wykonywany jest przy uruchomieniu drajwera. Jeśli parametr ma wartość "Nie", to pomiar taki nie jest wykonywany. Wartość opóźnienia można wtedy podać za pomocą parametru.

Wartość domyślna: Domyślnie wartość opcji wynosi TAK

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: TSyncDly

R Wartość opcji: liczba

Znaczenie: Parametr określa odcinek czasu jaki upływa od momentu przygotowania danych przez urządzenie do momentu odebrania ich przez drajwer. Jreśli urządzenie to umożliwia i gdy parametr TMeasDly ma wartość "Tak", to drajwer automatycznie dokonuje pomiaru tego opóźnienia.

Wartość opcji:

liczba - czas w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 0

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: TSyncMode

R Wartość opcji: NoSync / Master / FMaster/ Slave

Znaczenie: Tryb synchronizacji czasu. Parametr może mieć następujące wartości:

NoSync - brak synchronizacji czasu;

Master - drajwer ustawia czas urządzenia wtedy, gdy urządzenie tego żąda;

FMaster - drajwer cyklicznie ustawia czas urządzenia z interwałem określonym przez parametr TSyncPd;

Slave - drajwer cyklicznie odczytuje czas urządzenia w celu określenia różnicy czasów i nadania stempla czasu danym odczytanym z urządzenia, które takiego stempla nie mają.

Wartość domyślna: Domyślnie wartość opcji wynosi: Master.

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: TSyncPd

R Wartość opcji: liczba

Znaczenie: Interwał czasu z jakim drajwer ustawia czas urządzenia lub go odczytuje w zależności od parametru TSyncMode.

Wartość opcji:

liczba - czas w godzinach

Wartość domyślna: Domyślnie wartość opcji wynosi 1g

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: Type

R Wartość opcji: XServer / Mikronika

Znaczenie: Typ urządzenia. Parametr może mieć wartość "XServer" lub "Mikronika". W przypadku innych urządzeń parametru nie należy używać.

Wartość domyślna: brak

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: UTC

R Wartość opcji: TAK/NIE

Znaczenie: Parametr może przyjmować wartości "Tak" lub "Nie" i określa, czy urządzenie obsługuje czas UTC.

Wartość domyślna: Domyślnie wartość opcji wynosi TAK

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: Diag

R Wartość opcji: lista_nazw_grup_informacji

Znaczenie: Parametr określa rodzaj dodatkowych informacji diagnostycznych zapisywanych w pliku określonym parametrem Log. Jest to lista nazw grup informacji oddzielonych przecinkami (np. alhdr, objs, task, hdrs, rsptmr, tsync, iod).

Wartość domyślna: brak

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: Log

R Wartość opcji: nazwa_pliku

Znaczenie: Nazwa pliku, do którego będą zapisywane informacje diagnostyczne opcjonalnie poprzedzoną ścieżką do tego pliku. Po nazwie pliku, po przecinku można podać maxymalny rozmiar pliku w megabajtach.

Wartość domyślna: brak

R Nazwa sekcji: DNP3DRV

R Nazwa opcji: Dump

R Wartość opcji: nazwa_pliku

Znaczenie: Nazwa pliku, do którego będą zapisywane informacje przesyłane do/z urządzenia z wykorzystaniem łącza szeregowego. Po nazwie pliku, po przecinku można podać maxymalny rozmiar pliku w megabajtach. Parametr można umieszczać tylko w sekcji DNP3DRV. Jeśli drajwer wykorzystuje wiele portów szeregowych, to w nazwie pliku można podać ciąg znaków "%s", który zostanie zastąpiony nazwą portu szeregowego. W przypadku użycia sekwencji %s należy dodać do niej inne znaki, ponieważ nazwa pliku nie może być taka sama jak nazwa portu szeregowego (np. %sData.dmp).

Wartość domyślna: brak

Przykładowa parametryzacja drajwera

Kanał 1

Nazwa: DNP3_1

Drajwer: DNP3

Zakładka DNP3:

Parametry kanału:

UDP:192.168.0.31,3,4

Kanał 2

Nazwa: DNP3_2

Drajwer: DNP3

Zakładka DNP3:

Parametry kanału:

UDP:192.168.0.32,3,4

Kanał 3

Nazwa: DNP3_3

Drajwer: DNP3

Zakładka DNP3:

Parametry kanału:

UDP:192.168.0.33,3,4

Parametry zadeklarowane na zakładce Architekt > Obszary i komputery > Pozostałe > Opcje wprowadzane bezpośrednio

Nazwa sekcji | Nazwa parametru | Wartość parametru
DNP3DRV | Log | %s.log
DNP3DRV | EventMode | Poll
DNP3DRV | EPollPd | 10s
DNP3_3 | Log | -
DNP3_2 | EPollPd | 5s

W powyższym przykładzie zostały zdefiniowane trzy kanały: DNP3_1, DNP3_2 i DNP3_3. Dla urządzeń DNP3_1 i DNP3_2 zostaną utworzone pliki logu odpowiednio o nazwach "DNP3_1.log" i "DNP3_2.log". Log nie będzie tworzony dla urządzenia DNP3_3. Wszystkie trzy urządzenia będą cyklicznie odpytywane o zdarzenia - z tym że urządzenia DNP3_1 i DNP3_3 będą odpytywane co 10 sekund, a urządzenie DNP3_2 co 5 sekund.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DP - drajwer protokołu sieci PROFIBUS DP karty PROFIboard

Home > 1.29 DP - drajwer protokołu sieci PROFIBUS DP karty PROFIboard

1.29 DP - drajwer protokołu sieci PROFIBUS DP karty PROFIboard

Przeznaczenie drajwera

Drajwer DP jest wykorzystywany do wymiany danych poprzez sieć PROFIBUS z urządzeniami działającymi wg standardu PROFIBUS DP. Komputer systemu Asix musi być wyposażony w kartę procesora komunikacyjnego PROFIboard NT oraz oprogramowanie PROFIboard NT v 5.20 firmy Softing GmbH.

Parametryzacja drajwera DP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DP

Zakładka DP:

Parametry kanału:

nr_karty, adres, nazwa_sekcji

gdzie:

nr_karty - numer karty PROFIboard NT, przez którą realizowana jest komunikacja z danym urządzeniem DP (slave DP); w obecnej wersji drajwer DP może współpracować z jedną kartą PROFIboard NT;

adres - adres przypisany urządzeniu DP;

nazwa_sekcji - nazwę sekcji w pliku inicjującym aplikacji, w której przekazywane są parametry konfiguracyjne danego urządzenia DP.

Drajwer DP jest ładowany automatycznie jako DLL.

Parametry urządzeń DP

Parametry konfiguracyjne każdego urządzenia DP (slave DP) muszą być zadeklarowane w osobnej sekcji pliku inicjującego aplikacji. Parametry te powinny być dostępne w dokumentacji urządzenia lub w pliku GSD dostarczanym przez producenta wraz z urządzeniem. Nazwa sekcji jest nadawana przez użytkownika i musi być unikalna wśród nazw sekcji występujących w pliku inicjującym aplikacji.

Poszczególne parametry konfiguracyjne są przekazywane w oddzielnych opcjach sekcji. Każda opcja ma następującą postać:

parametr=wartość

gdzie:

parametr - typ parametru konfiguracyjnego,

wartość - wartość parametru (w postaci dziesiętnej !).

Poniżej podane są typy parametrów konfiguracyjnych, które muszą być przekazane przez projektanta aplikacji:

IDENT_NUMBER identyfikator urządzenia (PNO ident. number)

GROUP_IDENT identyfikator grupy (group member bits)

USER_PRM_DATA (prm_user_data)

... zmienna liczba opcji USER_RPM_DATA

.

USER_PRM_DATA (prm_user_data)

MODULE_ID (cfg_data)

... zmienna liczba opcji MODULE_ID

.

MODULE_ID (cfg_data)

Parametry aat_data mają charakter opcjonalny i jeśli nie zostaną zadeklarowane, to są ustawiane na 0.

NUMBER_OF_INPUTS (aat_data)

NUMBER_OF_OUTPUTS (aat_data)

OFFSET_OF_INPUTS (aat_data)

OFFSET_OF_OUTPUTS (aat_data)

Parametry slave_data mają charakter opcjonalny i jeśli nie zostaną zadeklarowane, to są pomijane.

SLAVE_DATA (slave_user_data)

.. zmienna liczba opcji SLAVE_DATA

.

SLAVE_DATA (slave_user_data)

Adresacja zmiennych procesowych

Wartości przekazane z modułów dołączonych do urządzenia DP są wpisywane do bufora wejść i bufora wyjść drajwera DP, w kolejności zgodnej z rozmieszczeniem modułów we/wy w kasecie urządzenia DP. Adresacja zmiennych procesowych polega na wskazaniu:

  • typu bufora (bufor wartości wejść lub bufor wartości wyjść);

  • numeru bajtu (w buforze), w którym przechowywana jest wartość danego wejścia/wyjścia; w zależności od typu zmiennej procesowej wartość zmiennej zajmuje jeden bajt (zmienna typu bajtowego) lub 2 kolejne bajty (zmienna typu 2-bajtowego);

  • rodzaju zmiennej (bajtowa lub 2-bajtowa).

Składnia adresu symbolicznego zmiennej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennych procesowych:

IB - bajt z bufora wejść,

IW - 2 kolejne bajty z bufora wejść traktowane jako liczba stałoprzecinkowa bez znaku w formacie INTELA,

IDW - 4 kolejne bajty z bufora wejść traktowane jako podwójne słowo w formacie INTELA,

IFP - 4 kolejne bajty z bufora wejść traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

IWM - 2 kolejne bajty z bufora wejść traktowane jako liczba stałoprzecinkowa bez znaku w formacie MOTOROLI,

IDWM - 4 kolejne bajty z bufora wejść traktowane jako podwójne słowo w formacie MOTOROLI,

IFPM - 4 kolejne bajty z bufora wejść traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI,

OB - bajt z bufora wyjść,

OW - 2 kolejne bajty z bufora wyjść traktowane jako liczba stałoprzecinkowa bez znaku w formacie INTELA,

ODW - 4 kolejne bajty z bufora wyjść traktowane jako podwójne słowo w formacie INTELA,

OFP - 4 kolejne bajty z bufora wyjść traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

OWM - 2 kolejne bajty z bufora wyjść traktowane jako liczba stałoprzecinkowa bez znaku w formacie MOTOROLI,

ODWM - 4 kolejne bajty z bufora wyjść traktowane jako podwójne słowo w formacie MOTOROLI,

OFPM - 4 kolejne bajty z bufora wyjść traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI;

indeks - numer bajtu w buforze wejścia/wyjścia.

Przykład

IB9 - 9-ty bajt z obszaru wejść

IW2 - słowo powstałe z 2-go i 3-go bajtu obszaru wejść (format INTELA)

IWM2 - słowo powstałe z 3-go i 2-go bajtu obszaru wejść (format MOTOROLI)

IDW5 - podwójne słowo powstałe z 5-go, 6-go, 7-go i 8-go bajtu obszaru wejść (format INTELA)

IDWM5 - podwójne słowo powstałe z 8-go, 7-go, 6-go i 5-go bajtu obszaru wejść (format MOTOROLI)

Parametry drajwera DP

Parametry drajwera DP deklarowane sa w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu DP może być parametryzowany w sekcji DP.

R Nazwa sekcji: DP

R Nazwa opcji: PREDKOSC_TRANSMISJI

R Wartość opcji: nr_sieci,baud_id

Znaczenie: opcja służy do deklarowania prędkości transmisji w sieci PROFIBUS DP.

Wartość domyślna: domyślnie przyjmuje się prędkość transmisji 1,5 MB.

Parametr:

nr_sieci - numer sieci PROFIBUS DP (w obecnej wersji zawsze sieć nr 1),

baud_id - identyfikator prędkości transmisji w sieci PROFIBUS DP:

0 - 9,6 kB

1 - 19,2 kB

2 - 93,75 kB

3 - 187,5 kB

4 - 500 kB

5 - 750 kB

6 - 1,5 MB

7 - 3 MB

8 - 6 MB

9 - 12 MB

11 - 45,45 kB

Przykład

Deklaracja prędkości transmisji 750 kB:

Nazwa sekcji: DP

Nazwa opcji: PREDKOSC_TRANSMISJI

Wartość opcji: 1, 5

R Nazwa sekcji: DP

R Nazwa opcji: CYKL_ODSWIEZANIA

R Wartość opcji: liczba

Znaczenie: opcja służy do deklarowania odstępu czasu pomiędzy kolejnymi odczytami danych z buforów karty PROFIboard NT do struktur drajwera DP;

Wartość opcji:

liczba - ilość 0.5 sekundowych interwałów, które muszą upłynąć pomiędzy kolejnymi odczytami danych z buforów karty PROFIboard NT.

Wartość domyślna: domyślnie drajwer DP czyta dane z buforów karty PROFIboard NT co 0.5 sekundy.

Przykład

Deklaracja odczytu danych co 1 sekundę:

Nazwa sekcju: DP

Nazwa opcji: CYKL_ODSWIEZANIA

Wartość opcji: 2

R Nazwa sekcji: DP

R Nazwa opcji: KONSOLA

R Wartość opcji: TAK|NIE

Znaczenie: pozwala utworzyć okno konsoli, w którym na bieżąco są wyświetlane komunikaty drajwera DP dotyczące stanu komunikacji pomiędzy komputerem systemu Asix oraz urządzeniami DP.

Wartość domyślna: domyślnie okno konsoli nie jest tworzone.

R Nazwa sekcji: DP

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera DP dotyczące stanu komunikacji pomiędzy komputerem systemu Asix oraz urządzeniami DP. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

Przykład

Poniżej podana jest przykładowa opcja deklarująca kanał transmisji wykorzystujący protokół DP do komunikacji z ET200U o numerze 7. Do ET200U są dołączone następujące moduły i/o (wg kolejności umieszczenia na liście):

  • moduł Digital Output (8 wyjść) 6ES5 461-8MA11 (identyfikator 32),

  • moduł Analog Input (4 wejścia) 6ES5 464-8ME11 (identyfikator 83),

  • moduł Digital Input (8 wejść) 6ES5 431-8MA11(identyfikator 16).

  • moduł Digital Output (8 wyjść) 6ES5 461-8MA11 (identyfikator 32).

Deklaracja kanału:

Nazwa: CHAN1

Drajwer: DP

Parametry kanału:

1,7,SIEM8008

Kanał transmisji o nazwie CHAN1 ma zdefiniowane następujące parametry:

  • protokół DP,

  • komunikacja poprzez kartę PROFIboard NT o numerze 1,

  • urządzenie DP ma numer 7 w sieci PROFIBUS DP,

  • parametry konfiguracyjne urządzenia DP są przekazane w sekcji [SIEM8008].

Zawartość sekcji [SIEM8008] definiującej przykładową konfigurację ET200U jest następująca (wszystkie wartości są podane dziesiętnie):

Nazwa sekcji: SIEM8008

Nazwa opcji: IDENT_NR

Wartość opcji: 32776

Nazwa sekcji: SIEM8008

Nazwa opcji: GROUP_IDENT

Wartość opcji: 0

Nazwa sekcji: SIEM8008

Nazwa opcji: USER_PRM_DATA

Wartość opcji: 0

Nazwa sekcji: SIEM8008

Nazwa opcji: MODULE_ID

Wartość opcji: 32

Nazwa sekcji: SIEM8008

Nazwa opcji: MODULE_ID

Wartość opcji: 83

Nazwa sekcji: SIEM8008

Nazwa opcji: MODULE_ID

Wartość opcji: 32

Nazwa sekcji: SIEM8008

Nazwa opcji: MODULE_ID

Wartość opcji: 16

W przedmiotowej konfiguracji obszar wejść ma 9 bajtów. Znaczenie bajtów jest następujące:

  • bajty 1,2 - analog input 1

  • bajty 3,4 - analog input 2

  • bajty 5,6 - analog input 3

  • bajty 7,8 - analog input 4

  • bajt 9 - digital input byte

W przedmiotowej konfiguracji obszar wyjść ma 2 bajty. Znaczenie bajtów jest następujące:

  • bajty 1 - digital output byte (pierwszy moduł 6ES5 451-8MA11)

  • bajty 2 - digital output byte (drugi moduł 6ES5 451-8MA11)

Przykład

Poniżej pokazano przykładowe deklaracje zmiennych procesowych:

# X1 - digital output - 1-szy bajt bufora wyjść

X1, OB1, KANAŁ, 1, 1, NIC_BYTE# X2 - digital output -2-gi bajt bufora wyjść

X2, OB2, KANAŁ, 1, 1, NIC_BYTE

# X3 - digital input -9-ty bajt bufora wejść

X3, IB9, KANAŁ, 1, 1, NIC_BYTE

# X4 - analog input 1 -1-szy i 2-gi bajt bufora wejść

X4, IW1, KANAŁ, 1, 1, NIC

# X5 - analog input 2 -3-ci i 4-ty bajt bufora wejść

X5, IW3, KANAŁ, 1, 1, NIC

# X 6- analog input 3 -5-ty i 6-ty bajt bufora wejść

X6, IW5, KANAŁ, 1, 1, NIC

# X7 - analog input 4 -7-my i 8-my bajt bufora wejść

X7, IW7, KANAŁ, 1, 1, NIC

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DP5412 - drajwer protokołu PROFIBUS DP karty CP5412

Home > 1.30 DP5412 - drajwer protokołu PROFIBUS DP karty CP5412

1.30 DP5412 - drajwer protokołu PROFIBUS DP karty CP5412

Przeznaczenie drajwera

Drajwer DP5412 jest wykorzystywany do wymiany danych z urządzeniami działającymi wg standardu PROFIBUS DP poprzez sieć PROFIBUS. W komputerze systemu Asix musi być zainstalowana karta procesora komunikacyjnego CP5412(A2) oraz pakiet oprogramowania DP-5412 (wersja 4.1 lub wyższa) lub karta CP5613 z pakietem DP-5613 firmy SIEMENS.

Parametryzacja drajwera DP5412 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DP5412 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DP5412

Zakładka DP5412:

Parametry kanału:

nr_karty, adres

gdzie:

nr_karty - numer karty CP5412 (A2) lub CP5613, przez którą realizowana jest komunikacja z danym urządzeniem DP (slave DP); w obecnej wersji drajwer DP5412 może współpracować z jedną kartą CP5412(A2) lub CP5613;

adres - adres przypisany urządzeniu DP.

Drajwer DP5412 jest ładowany automatycznie jako DLL.

Parametry urządzeń DP

Parametryzacja urządzeń DP (slave DP) odbywa się przy pomocy programu COM PROFIBUS, wchodzącego w skład pakietu DP-5412.

Projektant aplikacji musi zapewnić zgodność numerów przypisanych urządzeniom DP w trakcie parametryzacji sieci DP programem COM PROFIBUS oraz numerów urządzeń DP zadeklarowanych w pliku inicjującym systemu Asix.

Adresacja zmiennych procesowych

Wartości przekazane z modułów dołączonych do urządzenia DP są wpisywane do bufora wejść i bufora wyjść drajwera DP5412 w kolejności zgodnej z rozmieszczeniem modułów we/wy w kasecie urządzenia DP. Adresacja zmiennych procesowych polega na wskazaniu:

  • typu bufora (bufor wartości wejść lub bufor wartości wyjść);

  • numeru bajtu (w buforze), w którym przechowywana jest wartość danego wejścia/wyjścia; w zależności od typu zmiennej procesowej wartość zmiennej zajmuje jeden bajt (zmienna typu bajtowego) lub 2 kolejne bajty (zmienna typu 2-bajtowego);

  • rodzaju zmiennej (bajtowa lub 2-bajtowa).

Składnia adresu symbolicznego zmiennej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennych procesowych:

IB - bajt z bufora wejść,

IW - 2 kolejne bajty z bufora wejść traktowane jako liczba stałoprzecinkowa bez znaku w ormacie INTELA,

IDW - 4 kolejne bajty z bufora wejść traktowane jako podwójne słowo w formacie INTELA,

IFP - 4 kolejne bajty z bufora wejść traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

IWM - 2 kolejne bajty z bufora wejść traktowane jako liczba stałoprzecinkowa bez znaku w formacie MOTOROLI,

IDWM - 4 kolejne bajty z bufora wejść traktowane jako podwójne słowo w formacie MOTOROLI,

IFPM - 4 kolejne bajty z bufora wejść traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI,

OB. - bajt z bufora wyjść,

OW - 2 kolejne bajty z bufora wyjść traktowane jako liczba stałoprzecinkowa bez znaku w formacie INTELA,

ODW - 4 kolejne bajty z bufora wyjść traktowane jako podwójne słowo w formacie INTELA,

OFP - 4 kolejne bajty z bufora wyjść traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

OWM - 2 kolejne bajty z bufora wyjść traktowane jako liczba stałoprzecinkowa bez znaku w formacie MOTOROLI,

ODWM - 4 kolejne bajty z bufora wyjść traktowane jako podwójne słowo w formacie MOTOROLI,

OFPM - 4 kolejne bajty z bufora wyjść traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI;

indeks - numer bajtu w buforze wejścia/wyjścia.

Przykład

IB9 - 9-ty bajt z obszaru wejść

IW2 - słowo powstałe z 2-go i 3-go bajtu obszaru wejść (format INTELA)

IWM2 - słowo powstałe z 3-go i 2-go bajtu obszaru wejść (format MOTOROLI)

IDW5 - podwójne słowo powstałe z 5-go, 6-go, 7-go i 8-go bajtu obszaru wejść (format INTELA)

IDWM5 - podwójne słowo powstałe z 8-go, 7-go, 6-go i 5-go bajtu obszaru wejść (format MOTOROLI)

Parametry drajwera DP5412

Parametry drajwera DP5412 deklarowane sa w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu DP5412 może być parametryzowany w sekcji DP5412.

R Nazwa sekcji: DP5412

R Nazwa opcji: CYKL_ODSWIEZANIA

R Wartość opcji: liczba

Znaczenie: służy do deklarowania odstępu czasu pomiędzy kolejnymi odczytami danych z buforów karty CP5412(A2) lub CP5613 do struktur drajwera DP5412.

Wartość opcji:

liczba - ilość 0.5 sekundowych interwałów, które muszą upłynąć pomiędzy kolejnymi odczytami danych z buforów karty CP5412 (A2) lub CP5613

Wartość domyślna: domyślnie drajwer DP5412 czyta dane z buforów karty CP5412(A2) lub CP5613 co 0.5 sekundy.

R Nazwa sekcji: DP5412

R Nazwa opcji: KONSOLA

R Wartość opcji: TAK|NIE

Znaczenie: pozwala utworzyć okno konsoli, w którym na bieżąco są wyświetlane komunikaty drajwera DP5412 dotyczące stanu komunikacji pomiędzy komputerem systemu Asix oraz urządzeniami DP.

Wartość domyślna: domyślnie okno konsoli nie jest tworzone.

R Nazwa sekcji: DP5412

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera DP5412 dotyczące stanu komunikacji pomiędzy komputerem systemu Asix oraz urządzeniami DP. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

PRZYKŁADY

Przykład deklaracji dla DP5412.

Poniżej podana jest przykładowa opcja deklarująca kanał transmisji wykorzystujący protokół DP5412 do komunikacji z ET200U o numerze 7. Do ET200U są dołączone następujące moduły i/o (wg kolejności umieszczenia na liście):

- moduł Digital Output (8 wyjść) 6ES5 461-8MA11,

- moduł Analog Input (4 wejścia) 6ES5 464-8ME11,

- moduł Digital Input (8 wejść) 6ES5 431-8MA11,

- moduł Digital Output (8 wyjść) 6ES5 461-8MA11.

Deklaracja kanału:

Nazwa: KANAŁ

Drajwer: DP5412

Parametry kanału: 1, 7

Kanał transmisji o nazwie KANAŁ ma zdefiniowane następujące parametry:

- protokół DP5412,

- komunikacja poprzez kartę CP5412 (A2) o numerze 1,

- urządzenie DP ma numer 7 w sieci PROFIBUS DP,

W przedmiotowej konfiguracji obszar wejść ma 9 bajtów. Znaczenie bajtów jest następujące:

bajty 1,2 - analog input 1 (moduł 6ES5 431-8ME11),

bajty 3,4 - analog input 2 (moduł 6ES5 431-8ME11),

bajty 5,6 - analog input 3 (moduł 6ES5 431-8ME11),

bajty 7,8 - analog input 4 (moduł 6ES5 431-8ME11),

bajt 9 - digital input byte (moduł 6ES5 431-8MA11).

W przedmiotowej konfiguracji obszar wyjść ma 2 bajty. Znaczenie bajtów jest następujące:

bajty 1 - digital output byte (pierwszy moduł 6ES5 451-8MA11),

bajty 2 - digital output byte (drugi moduł 6ES5 451-8MA11).

Poniżej pokazano przykładowe deklaracje zmiennych procesowych:

# X1 - digital output - 1-szy bajt bufora wyjść

X1, OB1, KANAŁ, 1, 1, NIC_BYTE# X2 - digital output - 2-gi bajt bufora wyjść

X2, OB2, KANAŁ, 1, 1, NIC_BYTE

# X3 - digital input - 9-ty bajt bufora wejść

X3, IB9, KANAŁ, 1, 1, NIC_BYTE

# X4 - analog input 1 - 1-szy i 2-gi bajt bufora wejść

X4, IW1, KANAŁ, 1, 1, NIC

# X5 - analog input 2 - 3-ci i 4-ty bajt bufora wejść

X5, IW3, KANAŁ, 1, 1, NIC

# X 6- analog input 3 - 5-ty i 6-ty bajt bufora wejść

X6, IW5, KANAŁ, 1, 1, NIC

# X7 - analog input 4 - 7-my i 8-my bajt bufora wejść

X7, IW7, KANAŁ, 1, 1, NIC

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DSC - drajwer protokołu sterownika DSC

Home > 1.31 DSC - drajwer protokołu sterownika DSC

1.31 DSC - drajwer protokołu sterownika DSC

Przeznaczenie drajwera

Drajwer DSC jest wykorzystywany do wymiany danych pomiędzy komputerem systemu Asix i sterownikiem DSC 2000. Wymiana danych odbywa się przy wykorzystaniu standardowych łączy szeregowych komputera systemu Asix.

Współpraca systemu Asix ze sterownikiem DSC 2000 nie wymaga opracowania w sterowniku programu obsługującego wymianę danych.

Parametryzacja drajwera DSC realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DSC wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DSC

Zakładka DSC2:

Parametry kanału:

id,port

gdzie:

id - numer przypisany sterownikowi DSC,

port - nazwa portu szeregowego np. COM1.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycie kanału transmisji pracującego według protokołu DSC:

Nazwa/Kanał: CHAN1

Drajwer: DSC

Parametry kanału: 5,COM3

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej jest następująca:

I<indeks>

gdzie:

I - oznaczenie typu zmiennej, jednakowe dla wszystkich zmiennych procesowych protokołu DSC,

indeks - liczba w formacie heksadecymalnym, identyfikująca zmienną procesową. Legalne są jedynie te liczby, które zostały wyspecyfikowane na opcji Nummer w "Beschreibung der Rechnerschnittstelle" str. 3.

Wszystkie zmienne, z wyjątkiem zmiennych I10 oraz I11 (stany alarmów), są zmiennymi, których wartości mogą być czytane oraz zapisywane. Stany alarmów mogą być jedynie czytane.

Wartości wszystkich zmiennych procesowych sterownika DSC 2000 są przesyłane do systemu Asix w postaci 16-bitowej liczby stałoprzecinkowej bez znaku. Zasada ta obowiązuje dla zmiennych stałoprzecinkowych i zmiennoprzecinkowych. Z tego też względu pokazanie właściwej wartości zmiennej procesowej zmiennoprzecinkowej wymaga przeskalowania wartości otrzymanej ze sterownika do postaci zmiennoprzecinkowej przy użyciu funkcji przeliczających (najczęściej ANALOG_FP).

PRZYKŁAD

Przykłady deklaracji zmiennych procesowych:

# wartość zadana chloru - liczba zmiennoprzecinkowa, dwie cyfry po kropce

# dziesiętnejX1, I17, CHAN1, 1, 1, ANALOG_FP,0,1000,0.0,10.0

# wartość zadana pH - liczba zmiennoprzecinkowa, dwie cyfry po kropce

# dziesiętnejX2, I2A, CHAN1, 1, 1, ANALOG_FP,0,1000,0.0,10.0

# alarmy i flagi 1 - liczba stałoprzecinkowa 16-bitowa X3, I10, CHAN1, 1, 1, NIC

# alarmy i flagi 2 - liczba stałoprzecinkowa 16-bitowa X4, I11, CHAN1, 1, 1, NIC

# kod dostępu do pulpitu operatora - liczba stałoprzecinkowa 16-bitowa X5, I15, CHAN1, 1, 1, NIC

Drajwer DSC jest ładowany automatycznie jako DLL.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


DXF351 - drajwer protokołu urządzeń Compart

Home > 1.32 DXF351 - drajwer protokołu urządzeń Compart DXF351

1.32 DXF351 - drajwer protokołu urządzeń Compart DXF351

Przeznaczenie drajwera

Protokół DXF351 jest wykorzystywany do wymiany danych pomiędzy urządzeniami Compart DXF351 firmy Endress+Hauser oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych w standardzie RS232C.

Compart DXF351 musi być ustawiony w następujący tryb:

RS 2323 USAGE - PRINTER

DEVICE ID - dowolne

BAUD RATE - 9600

PARITY - NONE

HANDSHAKE - NONE

Ustawienia w PRINT LIST

ERRORS - NO

ALARMS - NO

Pozostałe pozycje - dowolnie wybrane

PRINT INTERVAL - 00:01 (przesył danych co 1 minutę)

Parametryzacja drajwera DXF351 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer DXF351 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: DXF351

Zakładka DXF351:

Parametr kanału:

port - nazwa portu: COM1, COM2 itd.

Przykład

Deklaracja kanału logicznego o nazwie KANAL1, działającego wg protokołu DXF351 na porcie COM2 jest następująca:

Kanał: KANAL1

Drajwer: DXF351

Parametry kanału: COM2

Drajwer DXF351 jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

P<indeks>

gdzie:

indeks - numer pomiaru na liście PRINT LIST (patrz tabela poniżej).

Tabela. Drajwer DXF351 - PRINT LIST.

DXF351 transmituje jedynie te parametry, które zostały dołączone do listy PRINT LIST przy parametryzacji Compart DXF351 (grupa COMMUNICATION).

Surowe wartości wszystkich zmiennych procesowych są typu FLOAT.

Przykład deklaracji zmiennych:

X1, Mass Flow , P4, KANAL1, 1, 1, NIC_FP

X2, Volume Flow, P10, KANAL1, 1, 1, NIC_FP

X3, Temperature 1, P13, KANAL1, 1, 1, NIC_FP

Parametry drajwera

Parametry drajwera DXF351 deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu DXF351 może być parametryzowany w sekcji DXF351.

R Nazwa sekcji: DXF351

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera DXF351 oraz informacje o zawartości telegramów odebranych przez drajwer SPA. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

Przykład

Nazwa sekcji: DXF351

Nazwa opcji: PLIK_LOGU

Wartość opcji: D:\ASIX\DXF.LOG

R Nazwa sekcji: DXF351

R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: liczba

Znaczenie: pozwala określić maksymalny czas, jaki może upłynąć pomiędzy kolejnymi znakami bloku danych z DXF351. Po przekroczeniu tego czasu drajwer DXF351 uznaje przesyłkę za zakończoną i rozpoczyna analizę jej zawartości.

Wartość opcji:

liczba - wartość czasu wyrażona w milisekundach.

Wartość domyślna: domyślnie opcja przyjmuje wartość 600.

R Nazwa sekcji: DXF351
R Nazwa opcji: LIMIT_BLEDOW
R Wartość opcji: liczba

Znaczenie: pozwala określić liczbę kolejnych błędów transmisji, po przekroczeniu której ustawiany jest status błędu pomiaru.

Wartość domyślna: domyślnie opcja przyjmuje wartość 3.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


E2tangoTcpip

Home > 1.33 E2tangoTcpip - drajwer protokołu sterowników polowych e2TANGO firmy Elektrometal Energetyka

1.33 E2tangoTcpip - drajwer protokołu sterowników polowych e2TANGO firmy Elektrometal Energetyka

Przeznaczenie drajwera

Drajwer E2tangoTcpip służy do wymiany danych pomiędzy systemem ASIX i sterownikiem polowym e2TANGO produkowanym przez firmę Elektrometal Energetyka. Wymiana danych odbywa się poprzez łącze Ethernet.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera E2tangoTcpip wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji

Drajwer: E2tangoTcpip

Zakładka E2tangoTcpip / parametry kanału:

Parametry kanału:

Numer urządzenia w sieci MODBUS - numer nadany sterownikowi w sieci Modbus;

Adres IP urządzenia - adres IP sterownika;

Port - numer portu TCP : 502, 10502, 10503 lub 10504. Domyślnie 502;

Offset alarmów - liczba dodawana do każdego numeru alarmu sygnalizowanego w tym kanale. Domyślnie 0;

PRZYKŁAD

Numer urządzenia w sieci MODBUS: 10

Adres IP urządzenia - 10.10.105.21

Offset alarmów - 100

Deklaracja zmiennych

Drajwer udostępnia następujące adresy symboliczne:

CS - pojedynczy Coil Status (służy tylko do realizacji sterowania)

HR - pojedynczy rejestr HR

HRL - 2 kolejne rejestry HR traktowane jako podwójne słowo w formacie INTELA

HRF - 2 kolejne rejestry HR traktowane jako liczba zmiennoprzecinkowa w formacie INTELA

HRLM - 2 kolejne rejestry HR traktowane jako podwójne słowo w formacie MOTOROLI

HRFM - 2 kolejne rejestry HR traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI

V1 - zmienna wirtualna do pokazywania numeru wyjątku Modbusa podczas ostatniego sterowania typem CS. Wartość 0 oznacza, że sterowanie zakończyło się bez wyjątku Modbusa (zmienna tylko do odczytu)

V2 - zmienna wirtualna pokazująca stan połączenia ze sterownikiem: 1 oznacza, że połączenie ze sterownikiem jest o.k., 0 oznacza brak połączenia

Deklaracja zdarzeń

Definicje zdarzeń sygnalizowanych przez sterownik są przekazywane w pliku xml dostarczanym przez producenta sterownika.

Nazwa pliku xml oraz nazwa katalogu, w którym znajduje się ten plik, są deklarowane w parametrach drajwera, przy czym te deklaracje mogą być przeciążone przez ustawienia w parametrach kanału (np. jeśli sterowniki używają różnych definicji zdarzeń).

Parametry drajwera

Parametry drajwera E2tangoTcpip deklarowane są na zakładkach E2tangoTcpip/Parametry drajwera:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • nazwa katalogu plików z definicjami zdarzeń,

  • nazwa pliku xml z definicjami zdarzeń,

  • okres sprawdzania zdarzeń,

  • okres synchronizacji czasu ze sterownikiem,

  • typ czasu używany podczas synchronizacji czasu ze sterownikiem,

  • adres IP karty komputera, poprzez którą jest obsługiwany sterownik,

  • max. liczbę rejestrów w pojedynczym zapytaniu,

  • liczbę powtórzeń w przypadku błędów transmisji.

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach ASMENa.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

Parametr:

nazwa_pliku_logu - rozmiar pliku logu w MB

R Rozmiar pliku logu
Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB

R Log telegramów

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX

Wartość domyślna: NIE.

Parametr:

wartość logiczna - TAK/NIE

R Timeout odpowiedzi

Znaczenie: Pozycja określa maksymalny czas (w milisekundach), przez który drajwer oczekuje na nadejście odpowiedzi z regulatora.

Wartość domyślna: Domyślnie opcja wynosi 500 milisekund.

Parametr:

liczba - wartość w milisekundach.

R Liczba powtórzeń

Znaczenie: Pozycja służy do określenia liczby powtórzeń zapytania w przypadku błędu/braku odpowiedzi ze sterownika. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia ze sterownikiem.

Wartość domyślna: Domyślnie opcja wynosi 3.

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów/braku odpowiedzi.

R Adres IP komputera

Znaczenie: Pozycja służy do określenia adresu karty sieciowej komputera, poprzez którą wszystkie kanały drajwera będą się komunikować ze sterownikiem.

Wartość domyślna: Jeśli pozycja nie jest zadeklarowana, to zostanie użyta karta sieciowa dostarczona przez system.

Parametr:

adres_IP - adres karty sieciowej w notacji IPv4.

R Maksymalna liczba rejestrów

Znaczenie: Pozycja służy do określenia maksymalnej liczby rejestrów, o których wartości może zapytać drajwer w jednym zapytaniu.

Wartość domyślna: 123.

Parametr:

liczba - maksymalna liczba rejestrów w jednym zapytaniu.

R Ścieżka plików definicji

Znaczenie: Opcja służy do określenia nazwy katalogu, w którym drajwer będzie poszukiwać plików zawierających definicje zdarzeń.

Wartość domyślna: brak.

Parametr:

ścieżka - nazwa katalogu zawierającego pliki z definicjami zdarzeń.

R Plik definicji zdarzeń

Znaczenie: Opcja służy do określenia nazwy pliku zawierającego definicje zdarzeń. Plik jest poszukiwany w katalogu określonym przez opcję Ścieżka plików definicji.

Wartość domyślna: brak.

Parametr:

nazwa - nazwa pliku z definicjami zdarzeń.

R Okres sprawdzania zdarzeń

Znaczenie: Opcja służy do określenia okresu czasu pomiędzy kolejnymi sprawdzeniami obecności nowych zdarzeń. Wartość 0 oznacza, że zdarzenia nie będą sprawdzane.

Wartość domyślna: 10 sekund.

Parametr:

liczba - okres sprawdzania zdarzeń w sekundach.

R Synchronizacja czasu

Znaczenie: Opcja służy do określenia okresu czasu pomiędzy kolejnymi zapisami stempla daty i czasu do sterownika. Wartość 0 oznacza, że czas nie będzie synchronizowany.

Wartość domyślna: 0 (bez synchronizacji czasu).

Parametr:

liczba - okres synchronizacji czasu w minutach.

R Czas UTC

Znaczenie: Opcja służy do określenia typu czasu (lokalny lub UTC) zapisywanego do sterownika podczas operacji synchronizacji czasu.

Wartość domyślna: NIE.

Parametr:

wartość logiczna - TAK/NIE

PRZYKŁAD

Przykładowa deklaracja parametrów drajwera.

Plik logu: d:\tmp\CtE2tangoTcpip\ecl.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Adres IP komputera: 10.10.110.24

Ścieżka plików definicji: d:\EventsDef

Plik definicji zdarzeń: zdarzenia.xml

Parametry kanału

Parametry kanału deklarowane na zakładkach: Parametry kanału 2, Parametry kanału - zdarzenia, Parametry kanału diagnostyka:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • nazwa katalogu plików z definicjami zdarzeń,

  • nazwa pliku xml z definicjami zdarzeń,

  • okres sprawdzania zdarzeń,

  • okres synchronizacji czasu ze sterownikiem,

  • typ czasu używany podczas synchronizacji czasu ze sterownikiem,

  • adres IP karty komputera, poprzez którą jest obsługiwany sterownik,

  • max. liczbę rejestrów w pojedynczym zapytaniu,

  • liczbę powtórzeń w przypadku błędów transmisji.

R Plik logu

Znaczenie: Dla celów diagnostycznych kanału służy tekstowy plik logu, do którego są wpisywane komunikaty zawierające treści telegramów wysyłanych i odbieranych w danym kanale.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w opcjach drajwera.

Parametr:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji Plik logu.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w opcjach drajwera.

Parametr:

liczba - rozmiar pliku logu w MB

R Log telegramów

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych w danym kanale. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w sekcji drajwera.

Parametr:

wartość logiczna - TAK/NIE

R Timeout odpowiedzi

Znaczenie: określa maksymalny czas, przez który w danym kanale oczekuje się na nadejście odpowiedzi z regulatora. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

liczba - wartość timeout’u w milisekundach

R Liczba powtórzeń

Znaczenie: Pozycja służy do określenia liczby powtórzeń zapytania w przypadku błędu/braku odpowiedzi ze sterownika. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia ze sterownikiem. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów/braku odpowiedzi.

R Adres IP komputera

Znaczenie: Pozycja służy do określenia adresu karty sieciowej komputera, poprzez którą kanał komunikuje się z regulatorem. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

adres_IP - adres karty sieciowej w notacji IPv4.

R Maksymalna liczba rejestrów

Znaczenie: Opcja służy do określenia maksymalnej liczby rejestrów, o których wartości może zapytać drajwer w jednym zapytaniu w danym kanale. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

liczba - maksymalna liczba rejestrów w jednym zapytaniu.

R Ścieżka plików definicji

Znaczenie: Opcja służy do określenia nazwy katalogu, w którym drajwer będzie poszukiwać pliku zawierających definicje zdarzeń dla danego kanału. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

ścieżka - nazwa katalogu zawierającego plik z definicjami zdarzeń.

R Plik definicji zdarzeń

Znaczenie: Opcja służy do określenia nazwy pliku zawierającego definicje zdarzeń danego kanału. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera. Plik jest poszukiwany w katalogu określonym przez opcję Ścieżka plików definicji.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

nazwa_pliku - nazwa pliku z definicjami zdarzeń.

R Okres sprawdzania zdarzeń

Znaczenie: Opcja służy do określenia okresu czasu pomiędzy kolejnymi sprawdzeniami obecności nowych zdarzeń w danym kanale. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

liczba - okres sprawdzania zdarzeń w sekundach.

R Synchronizacja czasu

Znaczenie: Opcja służy do określenia okresu czasu pomiędzy kolejnymi zapisami stempla daty i czasu do sterownika. Wartość 0 oznacza, że czas nie będzie synchronizowany.

Wartość domyślna: Domyślnie pozycja przyjmuje wartość zdefiniowaną w parametrach drajwera.

Parametr:

liczba - okres synchronizacji czasu w minutach.

PRZYKŁAD

Przykładowa sekcja kanału:

Plik logu: d:\logi\kanal1.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Adres IP komputera: 10.10.115.25


CtEcl

Home > 1.34 Ecl - drajwer do komunikacji z regulatorami ECL Comfort 210/310 produkowanymi przez firmę Danfoss

1.34 CtEcl - drajwer do komunikacji z regulatorami ECL Comfort 210/310 produkowanymi przez firmę Danfoss

Przeznaczenie drajwera

Drajwer CtEcl służy do wymiany danych pomiędzy systemem ASIX i regulatorami ECL Comfort 210/310 produkowanymi przez firmę Danfoss. Wymiana danych odbywa się poprzez łącze Ethernet w trybie Open Modbus Tcp/Ip.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer CtEcl wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Ecl

Zakładka Ecl / Parametry kanału:

[port=liczba;] serwerIp=adresIP; nr=liczba [;nrAlarmu=liczba]

gdzie:

port - numer portu TCP w regulatorze. Domyślnie 502,

serwerIp - adres IP regulatora,

nr - numer nadany regulatorowi w sieci Modbus,

NrAlarmu - numer alarmu w przypadku braku komunikacji z regulatorem.

Przykład deklaracji kanału transmisji:

serwerIP=10.10.105.21; nr=10; nrAlarmu=100

Deklaracja zmiennych procesowych

Drajwer udostępnia następujące adresy symboliczne:

HR - pojedynczy rejestr HR

HRL - 2 kolejne rejestry HR traktowane jako podwójne słowo w formacie INTELA

HRF - 2 kolejne rejestry HR traktowane jako liczba zmiennoprzecinkowa w formacie INTELA

HRLM - 2 kolejne rejestry HR traktowane jako podwójne słowo w formacie MOTOROLI

HRFM - 2 kolejne rejestry HR traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI

Deklaracja obszarów zawierających ciągły zakres adresów rejestrów

Regulator ECL udostępnia pofragmentowany zakres adresów rejestrów (tzw. PNU), który w dodatku jest specyficzny dla aplikacji realizowanej przez regulator. Jednocześnie implementacja protokołu Modbus w regulatorze wymaga, aby zapytania kierowane do regulatora dotyczyły wyłącznie takich adresów rejestrów, które zostały zdefiniowane w regulatorze. Z tego względu drajwer budując zapytania musi posiadać bazę legalnych zakresów rejestrów regulatora. Baza ta jest dostarczana przez projektanta aplikacji w postaci pliku tekstowego, którego kolejne linie zawierają definicje ciągłych zakresów adresów rejestrów HR lub IR. Mapa nie musi zawierać wszystkich ciągłych zakresów adresów rejestrów regulatora - wystarczy, aby zawierała definicje tych zakresów, do których należą rejestry wykorzystywane przez zmienne procesowe aplikacji systemu Asix.

Postać pojedynczej definicji obszaru jest następująca:

typ, start, end

gdzie:

typ - słowo kluczowe określające typ rejestrów znajdujących się w danym zakresie (HR lub IR),

start - adres pierwszego rejestru w danym zakresie,

end - adres ostatniego rejestru w danym zakresie.

Przykład:

definicje zakresów adresów rejestrów w przypadku, gdy regulator udostępnia rejestry o numerach HR10 ÷ HR14, HR21, HR30 ÷ HR50:

HR, 10, 14

HR, 21, 21

HR, 30, 50

Parametry drajwera

Parametry drajwera ECL deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany przy użyciu osobnej sekcji [CTECL]. W sekcji można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • katalog plików z definicjami ciągłych zakresów adresów rejestrów,

  • timeout odbioru,

  • maksymalna liczba rejestrów w pojedynczym zapytaniu,

  • adres IP karty komputera, poprzez którą jest obsługiwany regulator.

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach ASMEN’a.

R Nazwa sekcji: CTECL

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTECL

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTECL

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i regulatorami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

Katalog plików z definicjami ciągłych zakresów adresów rejestrów

R Nazwa sekcji: CTECL

R Nazwa opcji: SCIEZKA_DEFINICJI_ZAKRESOW

R Wartość opcji: ścieżka

Znaczenie: Pozycja służy do określenia nazwy katalogu, w którym drajwer będzie poszukiwać plików zawierających definicje ciągłych zakresów adresów rejestrów regulatorów.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami zakresów

R Nazwa sekcji: CTECL

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: liczba

Znaczenie: Pozycja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z regulatora.

Wartość opcji:

liczba - wartość timeout’u w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 500 milisekund.

R Nazwa sekcji: CTECL

R Nazwa opcji: MAX_LICZBA_REJESTROW

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia maksymalnej liczby rejestrów, o których wartości może zapytać drajwer w jednym zapytaniu.

Wartość opcji:

liczba - maksymalna liczba rejestrów w jednym zapytaniu

Wartość domyślna: Domyślnie wartość opcji wynosi 123.

R Nazwa sekcji: CTECL

R Nazwa opcji: ADRES_IP

R Wartość opcji: adres_IP

Znaczenie: Pozycja służy do określenia adresu karty sieciowej komputera, poprzez którą wszystkie kanały drajwera będą się komunikować z regulatorami.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4

Wartość domyślna: Jeśli pozycja nie jest zadeklarowana, to zostanie użyta karta sieciowa dostarczona przez system.

Przykładowa sekcja drajwera

Nazwa sekcji: CTECL

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtEcl\ecl.log

Nazwa sekcji: CTECL

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CTECL

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Nazwa sekcji: CTECL

Nazwa opcji: ADRES_IP

Wartość opcji: 10.10.110.24

Nazwa sekcji: CTECL

Nazwa opcji: SCIEZKA_DEFINICJI_ZAKRESOW

Wartość opcji: d:\defZakresow

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu osobnej sekcji o nazwie kanału Asmena. Parametry kanału deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio. W sekcji o nazwie kanału Asmena można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • maksymalna liczba rejestrów w pojedynczym zapytaniu,

  • adres IP karty komputera, poprzez którą jest obsługiwany regulator,

  • nazwa pliku z definicjami ciągłych zakresów adresów rejestrów regulatora.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych kanału służy tekstowy plik logu, do którego są wpisywane komunikaty zawierające treści telegramów wysyłanych i odbieranych w danym kanale.

Wartość opcji:

nazwa_pliku_logu

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych w danym kanale. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie, umieszczoną w sekcji drajwera.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: liczba

Znaczenie: Opcja określa maksymalny czas, przez który w danym kanale oczekuje się na nadejście odpowiedzi z regulatora. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość opcji:

liczba - wartość timeout’u w milisekundach

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: liczba

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z regulatora.

Wartość opcji:

liczba - wartość timeout’u w milisekundach

Wartość domyślna: Domyślnie wartość opcji wynosi 500 milisekund.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: MAX_LICZBA_REJESTROW

R Wartość opcji: liczba

Znaczenie: Opcja służy do określenia maksymalnej liczby rejestrów, o których wartości może zapytać drajwer w jednym zapytaniu. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera

Wartość opcji:

liczba - maksymalna liczba rejestrów w jednym zapytaniu

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ADRES_IP

R Wartość opcji: adres_IP

Znaczenie: Opcja służy do określenia adresu karty sieciowej komputera, poprzez którą kanał komunikuje się z regulatorem. Wartość pozycji przeciąża ustawienie określone przez pozycję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: PLIK_DEFINICJI_ZAKRESOW

R Wartość opcji: nazwa_pliku

Znaczenie: Opcja służy do do przekazania nazwy pliku, z którego zostaną odczytane definicje ciągłych zakresów adresów rejestrów regulatora obsługiwanego przez dany kanał. Plik będzie poszukiwany w katalogu określonym przez pozycję SCIEZKA_DEFINICJI_ZAKRESOW.

Wartość opcji:

nazwa_pliku

W przypadku braku pozycji PLIK_DEFINICJI_ZAKRESOW przyjmuje się, że regulator obsługiwany w danym kanale obsługuje pełny zakres adresowy protokołu MODBUS.

Przykładowa sekcja kanału

Poniżej podano przykładową sekcję dla kanału transmisji o nazwie KANAL1.

[KANAL1]

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\logi\kanal1.log

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: ADRES_IP

Wartość opcji: 10.10.115.25

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: TIMEOUT_ODBIORU

Wartość opcji: 750

Nazwa sekcji: <nazwa_kanału>

Nazwa opcji: PLIK_DEFINICJI_ZAKRESOW

Wartość opcji: kanal1.def

***

Pewne parametry kanału deklarowane są bezpośrednio w module Dane bieżące > <nazwa kanału drajwera ECL> > na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Pewne parametry kanału deklarowane są bezpośrednio w module Dane bieżące > <nazwa kanału drajwera ECL> > na zakładce Zaawansowane 2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtEcoMUZ - drajwer protokołu urządzeń zabezpieczających

Home > 1.35 EcoMUZ - drajwer protokołu urządzeń zabezpieczających ecoMUZ firmy JM Tronik

1.35 EcoMUZ - drajwer protokołu urządzeń zabezpieczających ecoMUZ firmy JM Tronik

Przeznaczenie drajwera

Drajwer protokołu EcoMUZ służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi ecoMUZ firmy JM Tronik. Transmisja realizowana jest łączami szeregowymi przy pomocy standardowych portów szeregowych komputera w standardzie RS-232 lub RS-485, zależnie od typu portu szeregowego ecoMUZa.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer EcoMUZ wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtEcoMUZ

Zakładka CtEcoMUZ:

Parametry kanału:

Port=liczba; Nr=liczba [;Timeout=liczba]

gdzie:

Port - numer portu szeregowego,

Nr - numer ecoMUZ’a obsługiwanego przez ten kanał,

Timeout - max. czas oczekiwania na pierwszy znak odpowiedzi (w milisekundach). Domyślnie 1000 milisekund.

Parametry transmisji są stałe i wynoszą:

prędkość transmisji - 9600 Bd,

liczba bitów w znaku - 8,

bit parzystości,

liczba bitów stopu - 1.

PRZYKŁAD

Przykład deklaracji kanałów transmisji do komunikacji z ecoMUZami nr 1064 i 1125 przy pomocy portu szeregowego COM2 oraz ecoMUZem nr 1068 przy pomocy portu szeregowego COM1:

Nazwa: K1064

Drajwer: CtEcoMUZ

Parametry kanału: Port=2;Nr=1064

Nazwa: K1066

Drajwer: CtEcoMUZ

Parametry kanału: Port=2;Nr=1066

Nazwa: K1068

Drajwer: CtEcoMUZ

Parametry kanału: Port=1;Nr=1068

Deklaracja zmiennych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ>[.<index>]

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu - dotyczy typów:

  • pomiary,

  • nastawy zabezpieczeń,

  • stan urządzenia.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

Typy zmiennych tylko do odczytu:

P - wartości pomiarów (FLOAT), zakres indeksów 1- 4,

Z - nastawy zabezpieczeń (FLOAT), zakres indeksów 1 - 6,

S - stan urządzenia (BYTE), zakres indeksów 1 - 3.

Typy zmiennych tylko do zapisu:

PP - pobudzenie przekaźników (WORD),

KS - kasowanie sygnalizacji (WORD),

ZI - wykonanie testu zabezpieczeń I>> i I>,

ZZ - wykonanie testu zabezpieczenia ziemnozwarciowego.

Wirtualna zmienna tylko do odczytu:

SK - status komunikacji (WORD) (1 - o.k., 0 - brak lub błędy komunikacji)

PRZYKŁAD

Przykłady deklaracji zmiennych - kanał K1064 obsługuje ecoMUZ nr 1064, kanał K1066 obsługuje ecoMUZ nr 1066:

JJ_10, wartość prądu I1 MUZ1064, P1, K1064, 1, 1, NIC_FP

JJ_20, wartość prądu I3 MUZ1066, P3, K1066, 1, 1, NIC_FP

JJ_30, nast. prąd. czł. zwarc. I>> MUZ1064, Z1, K1064, 1, 1, NIC_FP

JJ_40, nast. czasu czł. zwarc. I>> MUZ1066, Z4, K1066, 1, 1, NIC_FP

JJ_50, stan urządzenia MUZ1066, S1, K1066, 1, 1, NIC_BYTE

JJ_60, konfiguracja urządzenia MUZ1064, S2, K1064 1, 1, NIC_BYTE

JJ_70, pobudzenie przekaźnika MUZ1064, PP, K1064, 1, 1, NIC

JJ_80, kasowanie sygnalizacji MUZ1066, KS, K1066, 1, 1, NIC

JJ_90, status komunikacji z MUZ1064, SK, K1064, 1, 1, NIC

JJ_91, status komunikacji z MUZ1066, SK, K1066, 1, 1, NIC

Parametry drajwera

Parametry drajwera EcoMUZ deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany przy użyciu sekcji CTECOMUZ.

R Nazwa sekcji: CTECOMUZ

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTECOMUZ

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLK_LOGU.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: CTECOMUZ

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa deklaracja parametrów drajwera.

Nazwa sekcji: CTECOMUZ

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtEcoMUZ\muz.log

Nazwa sekcji: CTECOMUZ

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CTECOMUZ

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


EcoMuz2

Home > 1.36 EcoMuz2 - drajwer protokołu urządzeń zabezpieczających ecoMUZ-2 firmy JM Tronik

1.36 EcoMuz2 drajwer protokołu urządzeń zabezpieczających ecoMUZ-2 firmy JM Tronik

Przeznaczenie drajwera

Drajwer ecoMuz2 służy do wymiany danych pomiędzy systemem Asixi mikroprocesorowymi urządzeniami zabezpieczającymi typu ecoMuz-2, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany interfejs RS-485 zabezpieczeń.

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt nastaw,

  • odczyt ustawień,

  • odczyt danych identyfikacyjnych

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

  • odczyt zakłóceń i ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp. z o.o.

Drajwer obsługuje następujące typy ecoMuz-2:

2G

BS

LR

PR

SR

TR

Obsługa innego typu zabezpieczenia ecoMuz-2 wymaga zmian w kodzie drajwera.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer ecoMuz2 wymaga dodania

do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: EcoMuz2

Zakładka EcoMuz2:

Parametry kanału:

gdzie:

Numer urządzenia w sieci - sieciowy numer urządzenia,

Typ urządzenia - typ ecoMuz-2. Identyfikatory obsługiwanych typów:

1 - 2G

2 - BS

3 - LR

4 - PR

5 - SR

6 - TR

Po wybraniu typu urządzenia przycisk Pokaż parametry urządzenia wyświetla w oknie przeglądarki (wymagany co najmniej IE6) szczegółowe informacje nt parametrów urządzenia i parametrów zdarzeń danego typu urządzenia. Wystarczy raz uruchomić wspomniane okno, a wybór kolejnych typów urządzenia powodować będzie odświeżanie zawartości okna i podmianę wyświetlanych parametrów adekwatnie do wybranego typu urządzenia.

powiększ >>

Rys. Informacje nt urządzenia EcoMuz2 wg typu urządzenia.

Offset alarmów - offset dodawany do wyliczonego numeru alarmu ASIXA,

Port - nazwa portu szeregowego,

Prędkość transmisji - prędkość transmisji 9600 lub 19200 (dla typu 2G tylko 9600),

Kontrola parzystości - kontrola parzystości even lub none (dla typu 2G tylko none),

Zmienne kontrolne:

Nazwa zmiennej służąca do prezentacji statusu transmisji z ecoMuz-2:

0 - stan transmisji ok,

1 - brak/błędy komunikacji,

2 - wyłączenie ecoMuz-2 z obsługi,

Nazwa zmiennej służąca do sterowania stanem transmisji z ecoMuz-2:

1 - żądanie wyłączenia ecoMuz-2 z obsługi,

0 - włączenie ecoMuz-2 do obsługi.

Synchronizacja czasu - okres synchronizacji czasu z ecoMuz-2 (w sekundach). Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

Uwaga:

a/ zmienne kontrolne muszą należeć do kanału typu NONE.

b/ stałe parametry transmisji: liczba bitów w znaku - 8, liczba bitów stopu - 1.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KSR_67, w którym jest obsługiwany ecoMuz-2 o numerze sieciowym 5, typie LR, na porcie COM1 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Nazwa: KSR_67

Drajwer: ecoMuz2

Numer urządzenia w sieci: 5

Typ urządzenia: 3

Offset alarmów: 200

Port: COM1

Prędkość transmisji: 19200

Kontrola parzystości: parzystość

Nazwa zmiennej służąca do prezentacji statusu transmisji z ecoMuz-2: MuzStat05

Nazwa zmiennej służąca do sterowania stanem transmisji z ecoMuz-2: MuzCtrl05

Synchronizacja czasu: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt),

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis).

oraz wewnętrzne zmienne drajwera:

MN - numer sieciowy ecoMuz-2, z którego jest/był odczytywany rejestrator (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RQ - żądanie odczytu rejestratora (zapis)

RR - status aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RS - powód wyzwolenia rejestratora (odczyt)

RT - czas wyzwolenia rejestratora (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów: MN, RN, RR, RQ i SN,

  2. w przypadku typów RS, RT zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu rejestratora (typ RQ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

  4. zakresy dla typów HR zależą od typu urządzenia,

  5. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_01, wartość I1, HR1, KLR_01, 1, 1, NIC

ZM_02, pobudzenie zabezpieczeń 1, HR6, KLR_01, 1, 1, NIC

ZM_03, ilość nieodczytanych zdarzeń, HR11, KLR_01, 1, 1, NIC

ZM_06, czas wyzwolenia rejestratora 1, RT1, KLR_01, 1,1, DATACZAS_MUZ

Przykład deklaracji zmiennych bez parametrów (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_07, żądanie odczytu rejestratora, RQ, KLR_01,1,1,NIC

ZM_08, nr odczytywanego rejestratora, RN, KLR_01,1,1,NIC

ZM_09, status odczytu rejestratora, RR, KLR_01,1,1,NIC

ZM_10, nr odczytanej próbki z rejestratora, SN, KLR_01,1,1,NIC

ZM_11, nr odczytywanego urządzenia, MN, KLR_01,1,1,NIC

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu AsLogger. Przeglądanie zarejestrowanych zakłócenia jest możliwe wyłącznie przy pomocy programu AsLogger.

W celu uaktywnienia trybu rejestracji zakłóceń należy w parametrach drajwera zaznaczyć opcję Rejestracja zakłóceń w bazie AsLogger, która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych AsLoggera,

w których drajwer będzie zapisywać odczytane zakłócenia.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu ASIX poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z ecoMuz-2 i zapisać do bazy programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego ecoMuz-2,

b/ RN - numer odczytywanego rejestratora,

c/ RR - status odczytu rejestratora:

0 - nieaktywny lub zakończony ok,

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy programu AsLogger następujące parametry zakłócenia:

a/ pełny zestaw punktów planu, w skład którego wchodzą:

prądy: I0, I1, I2, I3 (po stronie wtórnej)

napięcia: U0, U1, U2, U3 (po stronie wtórnej)

kąt: fi0

stany wejść: WE01 ... WE08

stany wyjść: WY01 ... WY08

stany pobudzenia zabezpieczeń 1: PZ01 ... PZ16

stany zadziałania zabezpieczeń 1: ZZ01 ... ZZ16

Zestaw parametrów oraz liczba punktów planu dotyczących stanów pobudzeń zabezpieczeń i zadziałań zabezpieczeń jest specyficzna dla każdego typu ecoMuz-2,

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym zakłóceniu - będą ew. korygowane przy odczycie kolejnych zakłóceń dla danego planu.

Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu '.def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w opcji Katalog plików zawierajacych nazwy planów rejestracji w parametrach drajwera.

Składnia definicji nazwy planu rejestracji umieszczana w pliku '.def' jest następująca:

kanał, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

powód - powód wyzwolenia rejestratora (liczba z przedziału od 0 do 15),

tabela - nazwa planu rejestracji przydzielona zakłóceniu,

komentarz - komentarz;

PRZYKŁAD:

Definicje nazw planów rejestracji dla zakłóceń:

- wyzwolenie od prądu I (powód wyzwolenia nr 0)

- wyzwolenie od prądu I0 (powód wyzwolenia nr 1)

- wyzwolenie od napięcia U0 (powód wyzwolenia nr 2)

- wyzwolenie od logiki (powód wyzwolenia nr 3)

w kanale ASMENA o nazwie KTR_06:

KTR_06, 0, Pole06WyzwolenieI, wyzwolenie od prądu I

KTR_06, 1, Pole06WyzwolenieI0, wyzwolenie od prądu I0

KTR_06, 2, Pole06WyzwolenieU0, wyzwolenie od napięcia U0

KTR_06, 3, Pole06Logika, wyzwolenie od logiki

Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji bazując na poniższej składni:

NrxxxpyyyPowod

gdzie:

xxx - numer sieciowy ecoMuz-2,

yyy - numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w ecoMuz-2 nr 2 i COM5 zostanie zbudowany plan rejestracji o nazwie:

Nr002P005logika

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona opcja Ores sprawdzanai zdarzeń. Zdarzenia odczytywane z ecoMuz-2 są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie przygotowane dla każdego typu ecoMuz-2 oraz offset podany w deklaracji kanału ASMENA. Wyróżnia się dwa typy alarmów Asixa:

a/ tylko tekst,

b/ tekst oraz jeden parametr liczbowy.

Zdarzenia typu 0 są zamieniane na alarmy Asixa typu tekst + jeden parametr liczbowy (typu int) + parametr tekstowy (max 3 znaki), zawierający numery faz.

Zdarzenia ecoMuz-2 o typie nr 2 są zamieniane na alarmy Asixa typu tekst.

Przykład 1:

Zdarzenie Zamknięcie wyłącznika z telemechaniki w ecoMuz-2 typu LR (zdarzenie typu tekst) jest mapowane na numer alarmu Asixa o wartości 8. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 8 = 407):

407, al, zamknięcie wyłącznika z telemechaniki

Przykład 2:

Zdarzenie Zadziałanie zabezpieczenia zwarciowego w ecoMuz-2 typu LR (zdarzenie typu tekst oraz dwa parametry: liczbowy i tekstowy) jest mapowane na numer alarmu Asixa o wartości 0. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 100, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (100 + 0 = 100):

100, al, zadziałanie zabezpieczenia zwarciowego %f, fazy %s

Mapowanie zdarzeń poszczególnych typów ecoMuz-2 na numery alarmów Asixa wyświetlane są w oknie przeglądarki po wybraniu typu urządzenia i kliknięciu na przycisk Pokaż parametry urządzenia.

Parametry drajwera

Drajwer jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry drajwera/Parametry drajwera - diagnostyka. Są to parametry deklarujące:

  • tworzenie pliku logu,

  • tworzenie pliku logu zakłóceń,

  • rozmiar pliku logu,

  • log telegramów,

  • liczbę powtórzeń,

  • timeout odbioru,

  • timeout międzyznakowy,

  • zwłokę transmisji,

  • okres sprawdzania sygnalizacji zdarzeń,

  • rejestrację zakłóceń w bazie programu AsLogger,

  • katalog plików z definicjami planów rejestracji.

Nazwy opcji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa_pliku_logu

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie opcja jest wyłączona.

Wartość opcji:

TAK/NIE

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 3.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z ecoMuz-2. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z EcoMuz-2. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Okres sprawdzania zdarzeń

Znaczenie: Opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna: Domyślnie wartość pozycji wynosi 10 sekund.

Wartość opcji:

liczba - wartość czasu w sekundach.

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametry kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału. Są to parametry deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odbioru,

  • timeout znaku,

  • bez odczytu zdarzeń,

  • bez odczytu rejestratora zakłóceń,

R Plik logu

Znaczenie: Dla kanału można zdefiniować indywidualny plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna: Domyślnie używa się pliku logu drajwera.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu kanału.

Wartość domyślna: Domyślnie używa się rozmiaru pliku logu zdefiniowanego dla drajwera.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu kanału zawartości telegramów przesyłanych w danym kanale. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie używa się ustawienia zdefiniowanego dla drajwera.

Wartość opcji:

TAK/NIE

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z EcoMuz-2. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z EcoMuz-2. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony.

Wartość opcji:

TAK/NIE

R Bez rejestratora

Znaczenie: Opcja służy do wyłączania funkcji odczytu rejestratora zakłóceń w kanale.

Wartość domyślna: Domyślnie odczyt rejestratora zakłóceń jest dozwolony.

Wartość opcji:

TAK/NIE

PRZYKŁAD

Przykładowa parametryzacja drajwera

Drajwer: EcoMuz2

Plik logu: c:\tmp\muz.log

Plik logu zakłóceń: c:\tmp\zaklocenia.log

Rozmiar pliku logu: 30

Log telegramów: TAK

Rejestracja zakłóceń w bazie AsLogger: SERWER_RO6, BAZA_RO6

Katalog plików zawierających nazwy planów rejestracji: c:\tmp\DefZaklocen

PRZYKŁAD

Przykładowa parametryzacja kanału

Nazwa: KANALX

Plik logu: c:\tmp\kanalx.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Timeout znaku: 200

Timeout odpowiedzi: 1500

***

Pewne parametry kanału deklarowane są bezpośrednio w module Dane bieżące > <nazwa kanału drajwera EcoMuz2> > na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Pewne parametry kanału deklarowane są bezpośrednio w module Dane bieżące > <nazwa kanału drajwera EcoMuz2> > na zakładce Zaawansowane 2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


EQABP

Home > 1.37 EQABP - drajwer liczników energii elektrycznej EQABP firmy POZYTON

1.37 EQABP - drajwer liczników energii elektrycznej EQABP firmy POZYTON

Przeznaczenie drajwera

Drajwer służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej typu EQABP, produkowanymi przez Zakład Elektronicznych Urządzeń Pomiarowych POZYTON sp. z o.o. w Częstochowie.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer EQABP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: EQABP

Zakładka EQABP:

Parametry kanału:

Port=numer_portu; Predkosc=predkosc_transmisji; Okres=liczba

gdzie:

numer_portu - numer portu szeregowego, do którego przyłączony jest licznik (COM1-COM256); podanie wartości tego parametru jest obligatoryjne;

predkosc_transmisji - prędkość transmisji między komputerem a urządzeniem w baudach (300, 1200, 2400, 4800, 9600, 19200 lub 38400); domyślna szybkość wynosi 9600;

liczba - okres między kolejnymi odczytami bieżących wskazań licznika w sekundach; domyślna wartość wynosi 10.

Dodatkowa parametryzacja kanału transmisji

Dodatkowe parametry dla kanału należy deklarować w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio w sekcji o nazwie identycznej z nazwą kanału.

R Nazwa sekcji: nazwa_kanału

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie - pozycja służy do deklaracji liczby powtórzeń w przypadku błędów transmisji;

Wartość opcji:

liczba;

Wartość domyślna - domyślnie liczba powtórzeń wynosi 3.

Deklaracja zmiennych

Identyfikatory zmiennych składają się z dwóch części: adresu urządzenia (gdyby kilka było przypiętych do jednego portu) i nazwy zmiennej, połączonych znakiem '/'. Adres urządzenia można pominąć, jeśli do portu przypięte jest tylko jedno urządzenie, jednak znaku '/' pomijać nie można.

Przykładowe deklaracje zmiennych (nazwa kanału logicznego - EQABP):

#liczydła energii P- w strefach 1, 2, 3 i 4:

/1.8.1, /1.8.1, /1.8.1, EQABP, 1, 1, NIC_FP

/1.8.2, /1.8.2, /1.8.2, EQABP, 1, 1, NIC_FP

/1.8.3, /1.8.3, /1.8.3, EQABP, 1, 1, NIC_FP

/1.8.4, /1.8.4, /1.8.4, EQABP, 1, 1, NIC_FP

#liczydło energii P+ w strefach 1, 2, 3, 4 (X=1, 2, 3, 4)

/0.8.X, /0.8.X, /0.8.X, EQABP, 1, 1, NIC_FP

#liczydło energii Q+ w strefach 1, 2, 3, 4 (X=1, 2, 3, 4)

/2.8.X, /2.8.X, /2.8.X, EQABP, 1, 1, NIC_FP

#liczydło energii Q- w strefach 1, 2, 3, 4 (X=1, 2, 3, 4)

/3.8.X, /3.8.X, /3.8.X, EQABP, 1, 1, NIC_FP

#sumy liczydeł energii P-/P+/Q+/Q- we wszystkich strefach (X=1,0,2,3)

/X.8.0, /X.8.0, /X.8.0, EQABP, 1, 1, NIC_FP

#moce w poprzednim cyklu (P+, P-, Q+, Q-)

/0.4.1_0, /0.4.1_0, /0.4.1_0, EQABP, 1, 1, NIC_FP

/0.4.1_1, /0.4.1_1, /0.4.1_1, EQABP, 1, 1, NIC_FP

/0.4.1_2, /0.4.1_2, /0.4.1_2, EQABP, 1, 1, NIC_FP

/0.4.1_3, /0.4.1_3, /0.4.1_3, EQABP, 1, 1, NIC_FP

#napięcia fazowe

/97.5.5_0, /97.5.5_0, /97.5.5_0, EQABP, 1, 1, NIC_FP

/97.5.5_1, /97.5.5_1, /97.5.5_1, EQABP, 1, 1, NIC_FP

/97.5.5_2, /97.5.5_2, /97.5.5_2, EQABP, 1, 1, NIC_FP

#prądy dla każdej z faz

/97.4.4_0, /97.4.4_0, /97.4.4_0, EQABP, 1, 1, NIC_FP

/97.4.4_1, /97.4.4_1, /97.4.4_1, EQABP, 1, 1, NIC_FP

/97.4.4_2, /97.4.4_2, /97.4.4_2, EQABP, 1, 1, NIC_FP

#moce chwilowe czynne dla każdej z faz

/107_1, /107_1, /107_1, EQABP, 1, 1, NIC_FP

/107_2, /107_2, /107_2, EQABP, 1, 1, NIC_FP

/107_3, /107_3, /107_3, EQABP, 1, 1, NIC_FP

#liczydła energii S+ oraz S-

/4.8.0, /4.8.0, /4.8.0, EQABP, 1, 1, NIC_FP

/5.8.0, /5.8.0, /5.8.0, EQABP, 1, 1, NIC_FP

Parametry drajwera

Parametry drajwera EQABP deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany przy użyciu sekcji CTEQABP.

R Nazwa sekcji: CTEQABP

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTEQABP

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie - pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU;

Wartość opcji: liczba - rozmiar pliku logu w MB;

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CTEQABP

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie - pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikam; przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix;

Wartość domyślna - domyślnie wartość pozycji jest ustawiona na NIE.

R Nazwa sekcji: CTEQABP

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie - pozycja służy do deklaracji liczby powtórzeń w przypadku błędów transmisji;

Wartość opcji: liczba;

Wartość domyślna - domyślnie liczba powtórzeń wynosi 3.

PRZYKŁAD

Parametry drajwera:

Nazwa sekcji: CTEQABP

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\test\licznik.log

Nazwa sekcji: CTEQABP

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 3

Nazwa sekcji: CTEQABP

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametryzacja poszczególnych liczników

Drajwer pozwala na przekazanie zestawu indywidualnych parametrów dotyczących obsługi poszczególnych liczników w osobnych sekcjach. Nazwa takiej sekcji jest zbudowana z następujących elementów:

nazwa_kanału:numer_licznika

gdzie:

nazwa_kanału - nazwa kanału ASMENA, w którym jest obsługiwany dany licznik,

numer_licznika - numer licznika.

R Nazwa sekcji: nazwa_kanału:numer_licznika

R Nazwa opcji: TRYB_OBIS

R Wartość opcji: TAK/NIE

Znaczenie - pozycja pozwala na odczyt liczników EQABP z protokołem typu OBIS;

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtEQM

Home > 1.38 EQM - drajwer liczników energii elektrycznej typu EQM firmy POZYTON w Częstochowie

1.38 CtEQM - drajwer liczników energii elektrycznej typu EQM firmy POZYTON w Częstochowie

Przeznaczenie drajwera

Drajwer EQM służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej typu EQM, produkowanymi przez Zakład Elektronicznych Urządzeń Pomiarowych POZYTON sp. z o.o. w Częstochowie. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie RS-232 lub RS-485.

UWAGA:

Licznik EQM musi być wyposażony w firmware w wersji 2.0 lub nowszej.

Parametryzacja drajwera EQM realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer EQM wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: EQM

Zakładka EQM:

Parametry kanału:

Port=numer_portu; Predkosc=predkosc_transmisji

gdzie:

Port - numer portu szeregowego COM.

PredkoscTransmisji - prędkość transmisji między komputerem a licznikiem. Domyślna wartość wynosi 9600 Bd.

Okres - odstęp czasu (w sekundach) pomiędzy kolejnymi odczytami licznika.

Deklaracja zmiennych

Adres zmiennej ma następującą postać:

”numer_licznika/nazwa_rejestru”

gdzie:

numer_licznika - numer licznika odczytany z płyty czołowej o postaci:

XXX[SPACJA]XXXXXXX

gdzie:

X - cyfry numeru licznika

nazwa_rejestru - nazwa rejestru licznika o postaci X.X.X odczytana z tablicy odczytowej licznika.

Przykładowe deklaracje zmiennych (nazwa kanału logicznego - PTY, numer licznika 403 0001128 (spacja pomiędzy cyframi 3 oraz 0 jest znacząca !) ):

KP_01, moc uśredniona P+, "403 0001128/1.5.0", PTY, 1, 1, nic_fp

KP_02, moc uśredniona P-, "403 0001128/2.5.0", PTY, 1, 1, nic_fp

KP_05, moc uśredniona Q1, "403 0001128/5.5.0", PTY, 1, 1, nic_fp

KE_01, liczydło energii P+ T1, "403 0001128/1.8.1", PTY, 1, 1, nic_fp

KE_02, liczydło energii P+ T2, "403 0001128/1.8.2", PTY, 1, 1, nic_fp

JJ_01, licznik kumulacji, "403 0001128/0.1.0", PTY, 1, 1, nic_fp

JJ_02, licznik liczby parametryzacji, "403 0001128/C.2.0", PTY, 1, 1, nic_fp

Parametry drajwera

Parametry drajwera EQM deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTEQM.

R Nazwa sekcji: CTEQM

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTEQM

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji: liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CTEQM

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Nazwa sekcji: CTEQM

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\test\licznik.log

R Nazwa sekcji: CTEQM

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 30

R Nazwa sekcji: CTEQM

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

Parametryzacja poszczególnych liczników

Drajwer pozwala na przekazanie zestawu indywidualnych parametrów dotyczących obsługi poszczególnych liczników w osobnych sekcjach (deklarowanych w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio). Nazwa takiej sekcji jest zbudowana z następujących elementów:

nazwa_kanału:nazwa_licznika

gdzie:

nazwa_kanału - nazwa kanału ASMENA, w którym jest obsługiwany dany licznik,

nazwa_licznika - nazwa adresowa licznika (nazwa używana w adresie zmiennej); nazwa_licznika może być pusta, jeśli używa się instalacji point-point.

Przykład 1:

Nazwa kanału ASMENA KANAL

Nazwa licznika licznik1

Nazwa sekcji KANAL:licznik1

Przykład 2:

Nazwa kanału ASMENA KANAL

Nazwa licznika nie jest używana

Nazwa sekcji KANAL:

Licznik jest parametryzowany przy użyciu poniższych pozycji.

R Nazwa sekcji: nazwa_kanału:nazwa_licznika

R Nazwa opcji: ZNACZNIK_CZASU

R Wartość opcji: kod_rejestru [,kod_rejestru]

Znaczenie: opcja pozwala zdefiniować rejestr (lub dwa rejestry), który zawiera znacznik daty i czasu przekazany z licznika.

Wartość opcji: przyjmuje się, że jeśli jest podany jeden rejestr, to zawiera datę i czas w formacie 'YY-MM-DD hh:mm:ss'. Jeśli jest podana para rejestrów, to przyjmuje się, że pierwszy rejestr zawiera datę w formacie 'YY-MM-DD', a drugi rejestr zawiera czas w formacie 'hh:mm:ss'.

Jeśli opcja nie zostanie użyta, to przyjmuje się, że wartościom przesłanym z licznika zostanie przypisany znacznik daty i czasu PC z chwili zakończenia odbioru przesyłki.

Wartość domyślna: domyślnie przyjmuje się, że wartościom przesłanym z licznika jest przypisywany znacznik daty i czasu PC.

R Nazwa sekcji: nazwa_kanału:nazwa_licznika

R Nazwa opcji: DANE_LOGU_PROFILI

R Wartość opcji: TAK|NIE

Znaczenie: przy użyciu opcji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii logu profili należy zapisać do logu drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie szczegóły parsowania profili nie są zapisywane do logu drajwera.

R Nazwa sekcji: nazwa_kanału:nazwa_licznika

R Nazwa opcji: DANE_ODCZYTOWE

R Wartość opcji: TAK|NIE

Znaczenie: przy użyciu pozycji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii danych odczytowych licznika należy zapisać do logu drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie szczegóły parsowania danych odczytowych nie są zapisywane do logu drajwera.

PRZYKŁAD

Przykładowa deklaracja parametrów licznika:

Poniżej zamieszczona jest przykładowa sekcja opisująca licznik w kanale PTY. Licznik ma numer 403 0001128 (spacja pomiędzy cyframi 3 oraz 0 jest znacząca !).

R Nazwa sekcji: PTY:403 0001128

R Nazwa opcji: ZNACZNIK_CZASU

R Wartość opcji: 0.9.2, 0.9.1

R Nazwa sekcji: PTY:403 0001128

R Nazwa opcji: DANE_LOGU_PROFILI

R Wartość opcji: TAK

R Nazwa sekcji: PTY:403 0001128

R Nazwa opcji: DANE_ODCZYTOWE

R Wartość opcji: NIE

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału CtEQM deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtEsser

Home > 1.39 Esser - drajwer centrali p-poż Esser 8008 firmy Honeywell

1.39 Esser - drajwer centrali p-poż Esser 8008 firmy Honeywell

Przeznaczenie drajwera

Drajwer Esser służy do wymiany danych pomiędzy systemem Asix i centralą p-poż Esser 8008 firmy Honeywell. Komunikacja odbywa się przy wykorzystaniu łącza szeregowego RS-232 centrali ustawionego w tryb ’RA LCD/POSP nie nadzorowany’.

Parametryzacja drajwera Esser realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Esser wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Esser

Zakładka Esser:

Parametry kanału:

Port=nrPortu; Timeout=timeout; Alarm=nrAlarmu

gdzie:

nrPortu - numer portu szeregowego COM.

timeout - czas (w sekundach) pomiędzy dwoma telegramami (z centrali) po przekroczeniu którego nastąpi unieważnienie danych udostępnianych przez drajwer. Domyślna wartość wynosi parametru wynosi 8 sekund,

nrAlarmu - numer alarmu zgłoszonego do systemu alarmów Asixa w przypadku braku komunikacji z centralą.

Transmisja jest realizowana przy stałych ustawieniach:

600 Bd, 8 bitów znaku, bez kontroli parzystości, 1 bit stopu.

Deklaracja zmiennych

Drajwer dostarcza następujące typy zmiennych:

C - stan czujki

G - stan grupy

K - stan linii komunikacyjnej

Z - stan zasilania

Zależnie od typu zmiennej adres zmiennej ma następującą postać:

C.nrGrupy.nrCzujki[.nrAlarmu]

G.nrGrupy[.nrAlarmu]

K[.nrAlarmu]

Z[.nrAlarmu]

gdzie:

nrAlarmu - jest parametrem opcjonalnym, służącym do deklaracji bazowego numeru

alarmu dla wszystkich alarmów, które mogą być wygenerowane dla danej

zmiennej.

Wszystkie zmienne są typu WORD.

Wartością zmiennej jest mapa bitowa wszystkich stanów, jakie są sygnalizowane dla danej zmiennej na interfejsie centrali Esser (wartość bitu równa 1 oznacza, że stan jest sygnalizowany w centrali). Zakres sygnalizowanych stanów zależy od typu zmiennej.

Poniżej podano zestawienie sygnalizowanych stanów zależnie od typu zmiennej wraz z przyporządkowaniem sygnalizowanych stanów poszczególnym bitom wartości zmiennej:

Dla stanu czujki:

Bit 0 - ON ( eingeschaltet )

Bit 1 - OFF ( abgeschaltet )

Bit 2 - TROUBLE ( stoerung )

Bit 3 - FIRE ( feuer )

Bit 4 - FORALARM ( voralarm )

Bit 5 - TECHALARM ( tech alarm )

Dla stanu linii komunikacyjnej:

Bit 0 - TROUBLE ( stoerung )

Dla stanu grupy:

Bit 0 - ON ( eingeschaltet )

Bit 1 - OFF ( abgeschaltet )

Bit 2 - TROUBLE ( stoerung )

Bit 3 - FIRE ( feuer )

Bit 4 - FORALARM ( voralarm )

Bit 5 - TECHALARM ( tech alarm )

Bit 6 - TEST ( pruefbetrieb )

Bit 7 - ALARM_HZ ( alarm HZ-gruppe )

Bit 8 - ACTIVATED ( erregt )

Dla stanu zasilania:

Bit 0 - TROUBLE ( stoerung )

Przykładowe deklaracje zmiennych (jako ostatni parametr w adresie symbolicznym każdej zmiennej podano bazowy numer alarmu; zmienne należą do kanału logicznego KANAL):

JJ_11, stan grupy 1, G.1.1, KANAL, 1, 1, NIC

JJ_12, stan grupy 2, G.2.10, KANAL, 1, 1, NIC

JJ_13, stan grupy 3, G.3.19, KANAL, 1, 1, NIC

JJ_16, stan czujki 1 w grupie 1, C.1.1.28, KANAL, 1, 1, NIC

JJ_17, stan czujki 2 w grupie 1, C.1.2.34, KANAL, 1, 1, NIC

JJ_18, stan czujki 1 w grupie 2, C.2.1.40, KANAL, 1, 1, NIC

JJ_19, status połączenia, K.46, KANAL, 1, 1, NIC

JJ_20, status zasilania, Z.47, KANAL, 1, 1, NIC

Deklaracja alarmów

Jeśli w adresie zmiennej został użyty opcjonalny parametr [nrAlarmu], to drajwer będzie monitorować stany poszczególnych bitów wartości zmiennej zgłaszając do systemu alarmów Asixa:

a/ początek alarmu z chwilą zmiany wartości bitu z 0 na 1,

b/ koniec alarmu z chwilą zmiany wartości bitu z 1 na 0.

Bitowi 0 wartości zmiennej jest przypisany alarm o numerze [nrAlarmu], bitowi 1 alarm o numerze [nrAlarmu] + 1 itd. aż do wyczerpania sygnalizowanych stanów w typie przypisanym danej zmiennej.

Podczas startu aplikacji wartości zmiennych (którym przypisano alarmy) są inicjowane zgodnie ze stanem alarmów odczytanych z tabeli alarmów systemu Asix; status tych zmiennych jest ustawiany na OPC_QUALITY_GOOD. Pozostałe zmienne przyjmują wartość 0 oraz status OPC_QUALITY_OUT_OF_SERVICE.

Parametry drajwera

Parametry drajwera Esser deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTESSER.

R Nazwa sekcji: CTESSER

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTESSER

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji: liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTESSER

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Nazwa sekcji: CTESSER

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\test\centrala.log

R Nazwa sekcji: CTESSER

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 30

R Nazwa sekcji: CTESSER

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


FESTO - drajwer protokołu interfejsu diagnostycznego

Home > 1.40 FESTO - drajwer protokołu interfejsu diagnostycznego sterowników FESTO

1.40 FESTO - drajwer protokołu interfejsu diagnostycznego sterowników FESTO

Przeznaczenie drajwera

Protokół FESTO jest wykorzystywany do wymiany danych ze sterownikami FESTO FST-103, FST-405, FST IPC poprzez interfejs diagnostyczny (diagnose interface). Wymagana wersja firmware: 2.20 lub nowsza. Transmisja realizowana jest łączami szeregowymi w standardzie V24 (RS232C), przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix.

Współpraca systemu Asix ze sterownikami FESTO przy wykorzystaniu interfejsu diagnostycznego nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych.

Parametryzacja drajwera FESTO realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego korzystającego z drajwera FESTO wymaga określenia parametrów danego kanału w module Dane bieżące:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: FESTO

Zakładka FESTO:

Parametry kanału:

port,[body,znak,parzystość,stop,cpu_nr]

gdzie:

port - nazwa portu szeregowego,

body - prędkość transmisji w bodach,,

znak - liczba bitów w transmitowanym znaku,

parzystość - typ kontroli parzystości,

stop - liczba bitów stopu,

cpu_nr - jednostki centralnej w sterowniku.

Parametry body, znak, parzystość, stop, cpu_nr są parametrami opcjonalnymi. W przypadku ich pominięcia przyjmuje się parametry domyślne:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - bez kontroli parzystości,

  • liczba bitów stopu - 1,

  • numer jednostki centralnej - 0.

PRZYKŁADY

Poniżej podane są przykładowe pozycje deklarujące użycie dwóch kanałów transmisji pracujących według protokołu interfejsu diagnostycznego sterowników FESTO. W obu kanałach komunikacja realizowana jest przy użyciu tego samego łącza fizycznego, ale dane wymieniane są z rożnymi jednostkami centralnymi:

Nazwa: CHAN2

Drajwer: FESTO

Parametry kanału: COM1,9600,8,none,1,2,8

Nazwa: CHAN3

Drajwer: FESTO

Parametry kanału: COM1,9600,8,none,1,3,8

W powyższym przykładzie deklaracje kanałów różnią się jedynie numerem jednostki centralnej. Kanał CHAN2 pozwala na wymianę danych z jednostką centralną o numerze 2, natomiast kanał CHAN3 z jednostką centralną numer 3. Pozostałe parametry w deklaracjach kanałów są identyczne:

• port COM1,

• prędkość transmisji 9600 Bd,

• długość transmitowanego znaku - 8 bitów,

• bez kontroli parzystości,

• jeden bit stopu.

Adresacja zmiennej

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych procesowych obsługiwanych przez drajwer FESTO:

TYP_ZMIENNEJ indeks_zmiennej

gdzie:

TYP_ZMIENNEJ - łańcuch identyfikujący typ zmiennej,

indeks_zmiennej - indeks zmiennej w ramach danego typu.

Dozwolone są następujące oznaczenia typów zmiennych procesowych (zakres indeksów zmiennych jest specyficzny dla rożnych typów sterowników):

EW - słowa wejściowe,

AW - słowa wyjściowe,

ESW - słowa statusów wejść,

ASW - słowa statusów wyjść,

MW - słowa pamięci pośredniczących,

TW - wartości aktualne timerów,

TV - wartości zadane timerów,

TA - atrybuty timerów,

T - stan timerów,

ZW - wartości aktualne liczników,

ZV - wartości zadane liczników,

Z - stan liczników,

R - rejestry.

Przykłady

R15 - rejestr numer 15

EW0 - słowo wejściowe 0

AW8 - słowo wyjściowe 8

Wszystkie zmienne procesowe są traktowane jako liczby 16-bitowe bez znaku.

Drajwer FESTO jest ładowany automatycznie jako DLL.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


FILE2ASIX

Home > 1.41 FILE2ASIX

1.41 Drajwer FILE2ASIX

Przeznaczenie drajwera

Drajwer FILE2ASIX przeznaczony jest do importu danych do systemu Asix z plików tekstowych mających następującą strukturę:

Linia otwierająca

Linia zawierająca wartość zmiennej 1

Linia zawierająca wartość zmiennej 2

...

Linia zawierająca wartość zmiennej n

Linia zamykająca

Każda linia ma następującą postać:

P1<sep>P2<sep>P3<sep>P4<sep>P5

gdzie:

<sep> - separator ';’

P1 - dla linii otwierającej i linii zamykającej jest to data i czas zapisu pliku

w formacie UTC;

- dla pozostałych linii jest to czas odczytu zmiennej w formacie UTC;

P2 - adres symboliczny zmiennej (nie może zawierać znaku ’!’);

P3 - jakość zmiennej w postaci jednego z poniższych ciągów znaków:

BAD,

UNCERTAIN,

GOOD;

P4 - wartość zmiennej w postaci zmiennoprzecinkowej (separatorem jest

znak ’.’) lub stałoprzecinkowej,

P5 - nazwa ścieżki do urządzenia.

Dla linii otwierającej i zamykającej pola: P2, P3, P4 i P5 muszą być puste.

Format czasu UTC (zawartość pola P1) jest następujący:

RRRR-MM-DD<SP>GG:NN:SS,MS

gdzie:

RRRR - 4 cyfry oznaczające roku,

MM - 2 cyfry oznaczające miesiąc,

DD - 2 cyfry oznaczające dzień,

SP - znak spacji,

GG - 2 cyfry oznaczające godzinę,

NN - 2 cyfry oznaczające minuty,

SS - 2 cyfry oznaczające sekundy,

MS - 2 cyfry oznaczające milisekundy .

UWAGA Zakłada się, że plik zawiera poprawną zawartość, jeśli pierwsza i ostatnia linia mają identyczną treść.

Parametryzacja drajwera FILE2ASIX realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer FILE2ASIX wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: FILE2ASIX

Zakładka FILE2ASIX:

Parametry kanału:

Plik danych - ścieżka do pliku z wartościami zmiennych,

Okres odczytu - czas (w sekundach) pomiędzy kolejnymi odczytami pliku (domyślnie przyjmuje się 10 sekund).

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu FILE2ASIX:

# odczyt z pliku \\komp\c$\data\data.csv co 5 sekund

Nazwa/Kanał: KANAL1

Drajwer: FILE2ASIX

Plik danych: \\KOMP\C$\Data\Data.csv

Okres odczytu: 5

# odczyt z pliku n:Data\data.csv co 10 sekund (domyślny okres odczytu)

Nazwa/Kanał: KANAL2

Drajwer: FILE2ASIX

Parametry kanału: n:Data\Data.csv

Deklaracja zmiennych procesowych

Adres zmiennej procesowej ASMENa może mieć jedną z poniższych składni:

"ścieżka_dostępu ! adres"

"adres"

gdzie:

ścieżka_dostępu - uogólniona ścieżka dostępu do urządzenia (zawartość pola P5),

adres - adres zmiennej w ramach ścieżki (zawartość pola P2).

Drugą postać adresacji (adres) stosuje się wtedy, gdy ścieżka dostępu jest łańcuchem pustym (zawartość pola P5 jest pusta).

Poprzez plik są przekazywane pojedyncze zmienne, dlatego liczba elementów w deklaracji zmiennej ASMENa musi być równa 1.

Drajwer automatycznie konwertuje typ zmiennej odczytanej z pliku na typ surowy, oczekiwany przez funkcję przeliczającą podaną w deklaracji zmiennej ASMENa.

PRZYKŁAD

Przykład pliku przekazującego wartość zmiennych ZMIENNA_FP i ZMIENNA_WORD:

2002-10-04 12:23:37,004;;;;

2002-10-04 12:23:26,999;ZMIENNA_FP;GOOD;32.4436;PLC:S7[BEL_SPREZ]

2002-10-04 12:23:26,999;ZMIENNA_WORD;GOOD;32;

2002-10-04 12:23:37,004;;;;

PRZYKŁAD

Przykłady deklaracji zmiennych ASMENa dla powyższego pliku:

JJ_1, "PLC:S7[BEL_SPREZ] ! ZMIENNA_FP", KANAL, 1, 1, NIC_FP

JJ_2, "ZMIENNA_WORD", KANAL, 1, 1, NIC

Parametry drajwera

Drajwer jest parametryzowany przy użyciu zakładki Parametry drajwera.

R Plik logu

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Rozmiar pliku logu

Znaczenie: pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Okres ważności danych

Znaczenie: opcja jest używana dla celów kontroli sytuacji, w których nie udaje się odczytać pliku danych z zadanym interwałem. Opcja określa liczbę kolejnych nieudanych prób odczytu, po której status zmiennych zostanie zamieniony na BAD.

Wartość domyślna: domyślnie okres ważności danych jest równy dwóm cyklom odczytu danych z komputera sprzęgu.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


FP1001 - drajwer protokołu mierników firmy METRONIC Kraków

Home > 1.42 FP1001 - drajwer protokołu mierników firmy METRONIC Kraków

1.42 FP1001 - drajwer protokołu mierników firmy METRONIC Kraków

Przeznaczenie drajwera

Drajwer FP1001 jest wykorzystywany do wymiany danych pomiędzy monitorami przepływu FP1001 3.W lub FP1001 3.4 produkowanymi przez METRONIC Kraków oraz komputerem systemu Asix wyposażonym w łącza szeregowe w standardzie RS485.

Parametryzacja drajwera FP1001 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer FP1001 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: FP1001

Zakładka FP1001 / Parametry kanału:

Numer urządzenia

Typ urządzenia - aktualnie zaimplementowane są następujące typy:

  1. FP1001 3.5

  2. FFFP1001 3.W

Port - nazwa portu szeregowego COMi

Prędkość transmisji w bodach - domyślna wartość 9600

Drajwer FP1001 jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Sposób adresacji zmiennych procesowych przedstawiają tabele.

Tabela. Adresacja zmiennych miernika FP1001 3.W (monitora wody).

Tabela. Adresacja zmiennych miernika FP1001 3.W (monitora wody) (c.d.).

Tabela. Adresacja zmiennych miernika FP1001 3.4 (monitora pary).

Tabela. Adresacja zmiennych miernika FP1001 3.4 (monitora pary) (c.d.).

Tabela. Adresacja zmiennych miernika FP1001 3.4 (monitora pary) (c.d.).

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera FP1001, na zakładce FP1001 / Parametry drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie: ścieżka do pliku logu.

Wartość opcji: nazwa pliku logu

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Log telegramów

Znaczenie: zapisywanie do pliku logu

Wartość opcji:

TAK / NIE

Wartość domyślna: domyślnie drajwer FP1001 nie zapisuje treści telegramów do pliku logu.

R Zwłoka transmisji

Znaczenie: przerwa pomiędzy transmisjami.

Wartość opcji:

liczba - jako liczba interwałów o czasie trwania 10 msek.

Wartość domyślna: domyślnie opcja ma wartość 1 (10 msek).

R Aktualizacja

Znaczenie: okres odświeżania wartości zmiennych.

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: domyślnie opcja ma wartość 1 (aktualizacja odbywa się co 1 sekundę).

R Liczba powtórzeń

Znaczenie: liczba powtórzeń w przypadku błędu transmisji.

Wartość domyślna: domyślnie opcja ma wartość 0 (nie ma powtórzeń).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


GFCAN - drajwer protokołu CANBUS dla karty CanCard

Home > 1.43 GFCAN - drajwer protokołu CANBUS dla karty CanCard

1.43 GFCAN - drajwer protokołu CANBUS dla karty CanCard

Przeznaczenie drajwera

Protokół GFCAN jest wykorzystywany do wymiany danych pomiędzy urządzeniami posiadającymi interfejs sieci CAN oraz komputerem systemu Asix wyposażonym w kartę procesora komunikacyjnego sieci CAN firmy Garz & Fricke Industrieautomation GmbH wraz z oprogramowaniem "Garz & Fricke CAN driver for Windows NT" wersja 1.0.

Parametryzacja drajwera GFCAN realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer GFCAN wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: GFCAN

Zakładka GFCAN:

Parametry kanału:

nazwa_logiczna=GFCAN

Drajwer GFCAN jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Wartości zmiennych procesowych przekazywane są w telegramach nadawanych przez sterowniki podłączone do sieci CAN. Każdy telegram składa się maksymalnie z 8-miu bajtów, które mogą być identyfikowane jako:

- bajty o indeksach 1 - 8 (typ BY),

- liczby 16-bitowe o indeksach 1 - 4 (typ WD),

- liczby 32-bitowe o indeksach 1 - 2 (typ DW),

- liczby zmiennoprzecinkowe 32-bitowe o indeksach 1 - 2 (typ FP).

Drajwer GFCAN rozróżnia następujące typy dostępu do zmiennych procesowych:

- tylko odczyt (typ R_),

- tylko zapis (typ W_),

- zapis i odczyt (typ RW_).

Adresacja zmiennych procesowych polega na wskazaniu:

- typu dostępu (R_, W_ lub RW_),

- typu zmiennej (BY, WD, DW, FP),

- numeru telegramu (dla zmiennych o typie dostępu RW_ jest to numer telegramu służącego do odczytu zmiennej),

- indeksu w ramach telegramu (dla zmiennych o typie dostępu RW_ jest to indeks w telegramie służącym do odczytu zmiennej),

- dla zmiennych o typie dostępu RW_ należy zadeklarować dodatkowo:

a/ numer telegramu służącego do zapisu zmiennej,

b/ indeks w telegramie służącym do zapisu zmiennej.

Składnia adresu symbolicznego zmiennej jest następująca:

<typ_dostępu><typ_zmiennej><tel>.<indeks>[.<tel>.<indeks>]

gdzie:

typ_dostępu - typ dostępu do zmiennej procesowej:

R_ - tylko odczyt,

W_ - tylko zapis,

RW_ - odczyt i zapis,

typ_zmiennej - typ zmiennej procesowej:

BY - zmienna typu bajt,

WB - zmienna typu liczba 16-bitowa,

DW - zmienna typu liczba 32-bitowa,

FP - zmienna typu liczba zmiennoprzecinkowa 32-bitowa.

tel - numer telegramu,

indeks - indeks w ramach telegramu.

PRZYKŁAD

X1, bajty 1-4 telegramu 31, R_FP31.2,NONE, 1, 1, NIC_FP

X2, słowo nr 3 telegramu 31, R_WD31.3,NONE, 1, 1, NIC

X3, stan palników, RW_BY31.1.35.3,NONE, 1, 1, NIC_BYTE

X4, nastawa zaworu, RW_WD32.1.34.1,NONE, 1, 1, NIC

Zmienna X1 jest zmienną typu liczba zmiennoprzecinkowa 32-bitowa, przekazywana do systemu Asix poprzez bajty 1,2,3 i 4 telegramu nr 31.

Zmienna X2 jest zmienną typu liczba 16-bitowa, której wartość jest przekazywana do systemu Asix poprzez bajty 5 i 6 (trzecie słowo) telegramu nr 31. Wartość zmiennej X2 nie może być modyfikowana przez aplikację (zmienna tylko do odczytu).

Wartość zmiennej X3 jest przekazywana do systemu Asix poprzez bajt nr 1 telegramu nr 31. Zmiana wartości zmiennej X3 polega na wysłaniu z systemu Asix telegramu nr 35, którego bajt nr 3 zawiera żądany stan zmiennej X3.

Parametry drajwera

Parametry drajwera GFCAN deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu GFCAN może być parametryzowany w sekcji GFCAN.

R Nazwa sekcji: GFCAN
R Nazwa opcji: PREDKOSC_TRANSMISJI
R Wartość opcji: baud_id

Znaczenie: służy do deklarowania prędkości transmisji w sieci CAN.

Wartość domyślna: domyślnie przyjmuje się prędkość transmisji 500 kB.

Parametr:

baud_id identyfikator prędkości transmisji w sieci CAN:

1000 - 1 MB

800 - 800 kB

500 - 500 kB

250 - 250 kB

125 - 125 kB

100 - 100 kB

50 - 50 kB

20 - 20 kB

10 - 10 kB

PRZYKŁAD

Przykład deklaracji prędkości transmisji 125 kB:

Nazwa sekcji: GFCAN

Nazwa opcji: PREDKOSC_TRANSMISJI

Wartość opcji: 125

R Nazwa sekcji: GFCAN
R Nazwa opcji: KONTROLA_SIECI
R Wartość opcji: liczba

Znaczenie: pozwala na testowanie odbioru telegramów z sieci CAN. Określa maksymalny czas pomiędzy odbiorem kolejnych telegramów o tym samym numerze. W przypadku przekroczenia tego czasu zmienne procesowe związane z takim telegramem będą opatrzone statusem błędu. Jeśli dodatkowo w tym samym czasie nie odebrano żadnego telegramu z sieci CAN, to generowany jest komunikat w panelu operatorskim o braku telegramów w sieci.

Wartość opcji: liczba - maksymalna liczba sekund, które mogą upłynąć pomiędzy kolejnymi telegramami o tym samym numerze.

Wartość domyślna: domyślnie drajwer GFCAN nie kontroluje napływu telegramów.

R Nazwa sekcji: GFCAN
R Nazwa opcji: PODGLAD_TELEGRAMU
R Wartość opcji: TAK|NIE

Znaczenie: opcja steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach odebranych z sieci CAN. Komunikat zawiera numer telegramu, liczbę bajtów oraz zawartość poszczególnych bajtów telegramu w postaci heksadecymalnej.

Wartość domyślna: domyślnie nie wyświetla się zawartości telegramów.

PRZYKŁAD

Przykład deklaracji podglądu odbieranych telegramów:

Nazwa sekcji: GFCAN

Nazwa opcji: PODGLAD_TELEGRAMU

Wartośc opcji: TAK

R Nazwa sekcji: GFCAN
R Nazwa opcji: PODGLAD_STEROWANIA
R Wartość opcji: TAK|NIE

Znaczenie - opcja steruje przekazywaniem do panelu operatorskiego komunikatów o telegramach sterujących wysłanych z komputera systemu Asix do sterowników. Komunikat zawiera numer telegramu sterującego, liczbę bajtów oraz zawartość poszczególnych bajtów telegramu w postaci heksadecymalnej.

Wartość domyślna - domyślnie nie wyświetla się zawartości telegramów sterujących.

PRZYKŁAD

Przykład deklaracji podglądu telegramów sterujących:

Nazwa sekcji: GFCAN

Nazwa opcji: PODGLAD_STEROWANIA

Wartość opcji: TAK

R Nazwa sekcji: GFCAN
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera GFCAN oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer GFCAN. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: GFCAN
R Nazwa opcji: MAX_MOTOROLA_TEL
R Wartość opcji: liczba

Znaczenie - pozwala określić maksymalny numer telegramu, którego zawartość będzie konwertowana wg formatu MOTOROLI. Wszystkie telegramy o numerach większych niż zadeklarowany przy pomocy opcji MAX_MOTOROLA_TEL będą konwertowane wg formatu INTELA.

Wartość domyślna - domyślnie przyjmuje się, że wszystkie telegramy są konwertowane wg formatu INTELA.

PRZYKŁAD

Przykład deklaracji, w efekcie której telegramy o numerach do 150 włącznie są konwertowane wg formatu MOTOROLI:

Nazwa sekcji: GFCAN

Nazwa opcji: MAX_MOTOROLA_TEL

Wartość opcji: 150

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtGlobal

Home > 1.44 Global - drajwer do wymiany danych pomiędzy systemem asix oraz plikiem wymiany

1.44 Global - drajwer do wymiany danych pomiędzy systemem Asix oraz plikiem wymiany

Przeznaczenie drajwera

Drajwer Global służy do wymiany danych pomiędzy aplikacją systemu Asix a tzw. plikiem wymiany, będącym kontenerem na aktualne parametry zmiennych drajwera (nazwa, status, wartość, znacznik czasu). W aplikacji składającej się z wielu komputerów zawartość pliku wymiany może być synchronizowana pomiędzy poszczególnymi komputerami. W ten sposób można propagować na wszystkie komputery zmiany wartości zmiennych dokonywane na jednym z nich.

Parametryzacja drajwera CtGlobal realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Global wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtGlobal

Zakładka CtGlobal / Parametry kanału:

Parametry kanału:

Plik wymiany - nazwa pliku wymiany, w którym będą składowane zmienne; domyślna wartość: global.cfg

Katalog innych serwerów - pozycja służy do określenia katalogów, w których drajwer będzie szukać plików wymiany, z którymi należy synchronizować zawartość własnego pliku wymiany; nazwa szukanego pliku wymiany jest z założenia taka sama, jak nazwa własnego pliku wymiany (podana w deklaracji kanału); pozycja ma zastosowanie do instalacji, w których drajwer CtGlobal służy do wymiany danych pomiędzy komputerami;

Okres synchronizacji - okres (w milisekundach) pomiędzy kolejnymi próbami synchronizacji zawartości plików wymiany (istotne dla aplikacji wielokomputerowych). Domyślna wartość wynosi parametru wynosi 1000 milisekund.

Plik logu - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera; domyślna wartość: ctglobal.log.

Rozmiar pliku logu - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu; domyślnie rozmiar pliku logu wynosi 10 MB.

PRZYKŁAD

Nazwa: KANAL

Drajwer: CtGlobal

Parametry kanału:

Katalog innych serwerów:

x:\tmp\Global

y:\tmp\Global

z:\tmp\Global

Plik logu: d:\tmp\test\kanalGlobal.log

Rozmiar pliku logu: 20

Deklaracja kanału transmisji

Drajwer dostarcza zmienne typu skalar oraz tablica. Drajwer określa rozmiar zmiennej określany na bazie typu funkcji przeliczającej.

Adres symboliczny może być dowolnym łańcuchem znaków i jest ignorowany przez drajwer.

Wprowadzono adres symboliczny SYNCH, poprzez który można odczytać stan synchronizacji (liczba UI2) z plikami.

Bit 0 - stan synchronizacji z lokalnym plikiem

Bit 1, 2 ... - stan synchronizacji z plikami innych stacji

Bit o wartości 0 oznacza poprawną synchronizację.

Przykładowe deklaracje zmiennych (zmienne należą do kanału logicznego KANAL):

Nazwa: JJ_1

Opis: zmienna typu WORD

Adres: xxx

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: JJ_2

Opis: zmienna typu INT

Adres: xxx

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_INT

Nazwa: JJ_3

Opis: zmienna typu FLOAT

Adres: xxx

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: JJ_4

Opis: zmienna typu DWORD

Adres: xxx

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_DW

Nazwa: JJ_5

Opis: zmienna typu TEKST

Adres: xxx

Kanał: KANAL

Liczba elementów: 20

Okres próbkowania: 1

Funkcja przeliczająca: NIC_TEXT

Parametry drajwera

Parametry drajwera Global deklarowane są na zakładkach Parametry drajwera.

R Plik logu

Znaczenie: opcja służy do deklarowania ścieżki do pliku logu (ścieżka pełna lub względem katalogu bieżącego).

Wartość domyślna: ctglobal.log.

R Rozmiar pliku logu

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: 10.

PRZYKŁAD

Plik logu: d:\tmp\test\ctGlobal.log

Rozmiar pliku logu: 30

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


iec61850

Home > 1.45 IEC61850 - drajwer protokołu IEC61850

1.45 IEC61850 - drajwer protokołu IEC61850

Przeznaczenie drajwera

Niniejszy dokument dotyczy drajwera protokołu IEC61850.

Deklaracja kanału

Kanał drajwera IEC61850 to grupa zmiennych systemu Asix obsługiwanych w ten sam sposób i których wartości znajdują się w jednym urządzeniu IED (Intelligent electronic device).

Deklaracja kanału w sekcji modułu ASMEN ma postać:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Driver: IEC61850

Zakładka IEC61850:

Parametry kanału:

parametry

Parametry kanału są wyszczególnione w rozdziale Zestawienie parametrów kanału.

Parametry kanału można również umieszczać w sekcji o nazwie takiej jak nazwa
kanału, jednakże parametry definiujące adres zdalnego urządzenia muszą być podane w deklaracji kanału. Parametry definiujące połączenie ze zdalnym urządzeniem to: ip, aeq, apid, psel, ssel oraz tsel.

Jeśli jest dostępny plik typu SCL (Substation Configuration Language) np. plik icd lub cid, to powyższe parametry można zastąpić parametrem scl. Przykładowa deklaracja kanału mogłaby mieć w takim przypadku postać:

IEC1 = IEC61850, scl=Siprotec.icd

Jeśli jednak parametry adresowe zawarte w pliku SCL nie są zgodne z rzeczywistością to można je skorygować podając je w deklaracji kanału. Np. jeśli rzeczywisty adres ip urządzenia jest inny to można go podać w deklaracji:

IEC1 = IEC61850, scl=Turow.cid, IP=192.168.0.5

Niektóre parametry kanału dotyczą połączenia ze zdalnym urządzeniem a nie konkretnego kanału. W takim przypadku muszą być one identyczne we wszystkich deklaracjach kanału lub pominięte z wyjątkiem deklaracji pierwszego kanału dla danego połączenia. Do tych parametrów należą: ied, ied2, log, dump, ExplTmo, itcom.

Z danym urządzeniem IED może być związanych wiele kanałów.

Pliku SCL nie jest wymagany do poprawnej pracy drajwera jednakże jego podawanie jest zalecane.

Wartości zmiennych aplikacji Asix (z wyjątkiem pseudozmiennych) są wartościami atrybutów danych IED. Powiązanie zmiennej aplikacji Asix z określonym atrybutem danej następuje poprzez podanie jako jej adresu nazwy (dokładniej referencji) atrybutu danej. Adresacja zmiennych jest opisana w rozdziale Deklaracja zmiennych.

  • Kanały dla pollingu

Deklaracja kanału nie zawierająca parametrów brcb i urcb określa grupę zmiennych, których wartości będą odczytywane z IED poprzez wysyłanie do urządzenia żądań odczytu zgodnie z określonym dla konkretnej zmiennej okresem próbkowania (polling).

Ze względu na zwiększony ruch w sieci, ten tryb odczytu zmiennych nie jest zalecany.

  • Kanały z raportowaniem

Kanał oparty na raportowaniu odbiera wartości zmiennych wysyłane spontanicznie przez urządzenie w chwili zmiany wartości zmiennej, jej aktualizacji lub zmiany jakości. Deklaracja kanału opartego na raportowaniu musi zawierać parametr brbc lub urcb. Parametr ten określa nazwę (dokładniej referencję) bloku raportowania zawartego w IED. Blok raportowania zawiera wszystkie parametry określające sposób raportowania. Jeden kanał z raportowaniem może być powiązany z dokładnie jednym blokiem raportowania.

DataSet.

Listę zmiennych Asix’a podlegających raportowaniu określa obiekt DataSet zawarty w IED. Zawiera on listę nazw (dokładniej referencji) atrybutów danych urządzenia IED które będą raportowane. Jeden DataSet może być powiązany z wieloma blokami raportowania. Jeśli blok raportowania nie jest na stałe powiązany z jakimś DataSet to jego nazwę należy podać za pomocą parametru ds. W takiej sytuacji drajwer automatycznie powiąże DataSet z blokiem raportowania. Jeśli określony w ten sposób DataSet nie istnieje to drajwer utworzy nowy DataSet. Jeśli lista atrybutów danych zawartych w istniejącym DataSet jest nie obejmuje wszystkich zmiennych aplikacji Asix zdefiniowanych w kanale to drajwer usunie poprzedni DataSet i utworzy nowy. Jeśli istniejący DataSet zawiera nadmiarowe atrybuty danych to drajwer wyprowadzi stosowne ostrzeżenia do panelu kontrolnego aplikacji.

Jeśli urządzenie nie pozwala na dynamiczne tworzenie DataSet to należy podać parametr "ConfDS = Tak", co oznacza, że DataSet jest skonfigurowany na stałe za pomocą odpowiedniego programu lub przez producenta. W takiej sytuacji drajwer będzie wyprowadzał jedynie ostrzeżenia do panelu kontrolnego w przypadku niezgodności zawartości DataSet z listą zmiennych kanału.

Jeśli urządzanie wymaga ręcznego konfigurowania DataSet to należy pamiętać o dołączeniu do niego atrybutów ".q" i ".t" o ile zawiera on atrybuty z którymi skojarzona jest jakość i stempel czasu. Z następującymi nazwami atrybutów skojarzona jest jakość (”.q”):

"stVal", "general", "phsA", "phsB", "phsC", "dirGeneral", "dirPhsA", "dirPhsB", "dirPhsC", "dirNeut", "cnt", "actVal", "mag", "range", "cVal", "instMag", "Har", "phsAHar", ".phsBHar", ".phsCHar", "neutHar", "netHar", "resHar", ”phsABHar", "phsBCHar", "phsCAHar", "valWTr", "setMag", "neut". Z wyjątkiem atrybutu "instCMag" wszystkie te atrybuty mają skojarzony atrybut ".t" będący stemplem czasu. W przypadku niedołączenia atrybutów ".q" i ".t" drajwer przypisze zmiennej czas bieżący i jakość dobrą.

Opcje wyzwalania raportów

Raporty mogą być wyzwalane w wyniku zmiany wartości atrybutu (dchg), jej aktualizacji (dupd), zmiany jakości (qchg), kontroli integralności (integ) oraz żądania odczytu raportowanych wartości (GI - general interrogation). Opcje wyzwalania określa parametr TrgOps, który jest listą nazw opcji podanych powyżej w nawiasach oddzielonych przecinkami. Jeśli nazwa opcji jest poprzedzona znakiem ”-” (minus) to dana opcja jest wyłączona. Opcja GI jest ustalana automatycznie przez drajwer i jej zmiana w wyniku parametryzacji jest nieskuteczna. Podobnie, opcja integ jest ustawiana automatycznie jeśli parametr IntgPd kanału ma wartość większą niż zero. Pozostałe opcje są domyślnie ustawione. Jeśli dana opcja nie jest wymagana to należy ją wymienić w parametrze TrgOps poprzedzając ją znakiem "-" (minus). Np. wg dokumentacji urządzenia MiCOM, raportowania nie da się uruchomić gdy włączona jest opcja dupd. W takim przypadku należy podać "TrgOps = -dupd".

W kanałach z raportowaniem można umieścić zmienną o adresie "@GI" (general interrogation). Zapis niezerowej wartości do tej zmiennej spowoduje wymuszenie przesłania raportu.

Kanały z raportowaniem niebuforowanym

Kanałów z raportowaniem niebuforowanym używamy, gdy ewentualna utrata zmian wartości atrybutów w wyniku zamknięcia aplikacji jest nieistotna. Kanał niebuforowany musi zawierać parametr urcb W przypadku kanałów niebuforowanych DataSet może być tymczasowy, o ile urządzenie na to pozwala. DataSet tymczasowy jest usuwany z IED po zerwaniu połączenia. Drajwer automatycznie tworzy DataSet tymczasowy po nawiązaniu połączenia. Dla DatSet tymczasowego, parametr ds ma postać:

ds = @[nazwa_dataset]

Jeśli nazwa_dataset jest pominięte, to drajwer utworzy DataSet o takiej samej nazwie jak nazwa kanału. Jeśli urządzenie nie obsługuje tymczasowych DataSet to są one obsługiwane tak jak opisano w poprzednim punkcie.

Kanały z raportowaniem buforowanym

Kanałów z raportowaniem buforowanym używamy, gdy należy przechować wszelkie zmiany wartości atrybutów w IED w czasie gdy, aplikacja Asix nie działa. Dotyczy to zwłaszcza zmiennych z którymi skojarzone są alarmy. Kanał z raportowaniem buforowanym musi mieć zdefiniowany parametr brcb.

Z każdym raportem przechowywanym w bloku raportów buforowanych IED związany jest unikalny identyfikator o nazwie EntryId. Identyfikator EntryId jest przekazywany razem z raportem. Jeśli drajwer IEC61850 przetworzy wszystkie dane zawarte w raporcie (także wygeneruje raporty), to wartość tego identyfikatora zapisywana jest w pliku o nazwie:

IEC61850-nazwa_kanału.EntryID

Po zamknięciu aplikacji Asix, plik ten jest odczytywany a jego zawartość przysyłana jest do IED w celu wskazania, które raporty zostały już obsłużone i uniknięcia ich ponownego transferu i generacji fałszywych alarmów. W przypadku zmiany nazwy kanału należy również zmienić odpowiednio nazwę tego pliku. Drajwer może sygnalizować błąd wysyłania identyfikatora do IED, gdy np. urządzenie zostało zresetowane i blok raportowania nie zawierał żadnych raportów.

Uruchomienie aplikacji Asix po pewnej przerwie, powoduje, że przez pewien czas drajwer będzie odbierał raporty dotyczące zdarzeń z przeszłości. Może to spowodować pokazywanie nieaktualnych już stanów zmiennych procesowych. Aby tego uniknąć, drajwer odczytuje identyfikator najnowszego raportu i aktualizuje zmienne dopiero po otrzymaniu aktualnego raportu. To postępowanie jest możliwe tylko w przypadku urządzeń spełniających Technical Issue nr 190. Jeśli urządzenie nie spełnia tego wymagania (np. MiCOM P139), to należy podać parametr "ToESync = Tak". Drajwer wykorzysta wtedy pole TimeOfEntry do synchronizacji. Spowoduje to również przesyłanie dodatkowej wartości z każdym raportem. Aby wyłączyć synchronizację należy podać parametr "BRCBSync = nie".

W kanale buforowanym można zdefiniować pseudozmienną o adresie @BufOvfl (NIC_BYTE), która przyjmie wartość 1 gdy nastąpiło przepełnienie bufora w bloku raportowania i związana z tym utrata danych. Z taką zmienną drajwer może skojarzyć alarm.

W przypadku urządzeń spełniających wymagania Technical Issue 300 (np. SIPROTEC), do uruchomienia raportowania buforowanego konieczne jest przesłanie do urządzenia wartości parametru o nazwie ResvTms. Jest czas wyrażony w sekundach od momentu zerwania połączenia z urządzeniem przez jaki urządzenie będzie rezerwować blok raportowania dla aplikacji nawiązującej połączenie o takim samym adresie jak poprzednio. Po upływie tego czasu dowolna aplikacja w sieci może zarezerwować dany blok raportowania na swoje własne potrzeby. Domyślna wartość tego parametru to 600 sekund. Należy pamiętać, że po zmianie adresu ip na którym jest wykonywana aplikacja nie będzie możliwe uruchomienie raportowania przed upływem tego czasu.

W kanałach z raportowaniem buforowanym można umieścić zmienną o adresie "@Purge". Zapis niezerowej wartości do tej zmiennej spowoduje usunięcie wszystkich raportów z bufora.

  • Przykłady deklaracji kanałów

Deklaracja kanału buforowanego:

Sekcja | parametr | wartość
ASMEN | IEC1 | IEC61850, scl=SIPROTEC.icd, brcb= CTRL/LLN0.brcbA01
IEC1 | ds | CTRL/LLN0.AsixDs
IEC1 | Log | Iec1.log
IEC1 | Dump | Iec1.xml

Powyżej podano deklarację kanału buforowanego. Blok raportowania ma nazwę (referencję) "CTRL/LLN0.brcbA01". Blok raportuje atrybuty zawarte w DataSet o nazwie "CTRL/LLN0.AsixDs". Informacje diagnostyczne będą wyprowadzane do pliku "iec1.log" a szczegółowe informacje dotyczące wymiany danych zostaną zapisane w pliku "iec1.xml".

Deklaracja kanału niebuforowanego.

Sekcja | parametr | Wartość
ASMEN | IEC1 | IEC61850, scl=SIPROTEC.icd, urcb= CTRL/LLN0.urcbA01
IEC1 | ds | @

Powyżej podano deklarację kanału niebuforowanego. Blok raportowania ma nazwę (referencję) "CTRL/LLN0.urcbA01". Blok raportuje atrybuty zawarte w dynamicznie utworzonym tymczasowym DataSet o nazwie "@IEC1".

Deklaracja zmiennych

Deklaracja zmiennej powiązanej z atrybutem danej w IED ma postać:

Referencja_atrybutu_danej[[dodatkowe_parametry]]

Referencja_atrybutu_danej to nazwa logiczna urządzenia znajdującego się w IED zakończona ukośnikiem a następnie nazwa węzła logicznego, nazwa danej i nazwy atrybutów oddzielone kropkami. Nazwa urządzenia logicznego powinna być taka jaka występuje w dokumentacji do danego urządzenia lub plikach SCL tj. nie może być poprzedzona nazwą IED. Np. jeśli w urządzeniu fizycznie znajduje się urządzenie logiczne o nazwie TurowSystem to nazwy zmiennych będą się rozpoczynać od nazwy System. Np.:

Measurements/MmuPriMSTA1.MaxAmps.mag.f

Dodatkowe_parametry mają postać:

Par1:par2:....

Możliwe parametry:

Definicja_alarmu (opisane w rozdziale Alarmy)

P - zmienna obsługiwana w trybie pollingu

CMn - deklaracja modelu sterowania dla zmiennej (opisane w rozdziale Sterowanie)

xb - zmienna jest typu boolean (dotyczy głównie zmiennych do których jest wysyłane sterowanie)

Istotna jest wielkość liter parametrów.

Sterowanie

W przypadku MiCOM P139 można sterować tylko tymi danymi, które zostały odpowiednio do tego celu skonfigurowane za pomocą programu IED Configurator z pakiet MiCOM S1 Studio.

Aby wysterować daną zmienną należy odszukać za pomocą IEC Browsera atrybut tej o nazwie "Oper$ctlVal" i ustalić adres zmiennej Asix’a dla tego atrybutu w sposób opisany w poprzednim punkcie. Do tak ustalonego adresu należy dodać na końcu .@CM.

Np. Control/CSWI1.Pos.Oper.ctlVal.@CM.

Ponieważ w przypadku MiCOM P139 nie można odczytać z urządzenia w jaki sposób ma być wykonane sterowanie, to należy to wskazać dodając do adresu "[CMn]" gdzie "n" jest numerem sposobu sterowania ustalonym przez program IED Configurator. Liczba "n" może przyjmować następujące wartości:

1 - direct-with-normal-security

2 - sbo-with-normal-security

3 - direct-with-enhanced-security

4 - sbo-with-enhanced-security

Na przykład:

Control/CSWI1.Pos.Oper.ctlVal.@CM[CM3]

W przypadku innych urządzeń podawanie parametru CMn nie jest potrzebne o ile urządzenie ma poprawnie ustawioną wartość atrybutu "ctlModel" sterowanej danej.

Zmienna o takim adresie powinna mieć funkcję przeliczającą NIC_BYTE.

Zapis do takiej zmiennej wartości 1 spowoduje wysterowanie do stanu ON a 0 do stanu OFF.

Kanał Asmena w którym znajduje się sterowana zmienna musi mieć podany parametr "Simple_Control=Tak".

W zmiennych sterujących, łańcuch znaków ".Oper" można pominąć (pozostaje tylko jedna kropka).

Wysterowanie zmiennych typu "....-enhanced-security" powoduje wygenerowanie przez urządzenie raportu z rezultatami sterowania. Aby odczytać rezultaty sterowania należy zdefiniować następujące zmienne:

Control/CSWI1.Pos.@Err (funkcja przeliczająca NIC_DW)

oraz

Control/CSWI1.Pos.@AddCause (funkcja przeliczająca NIC_DW)

Wg normy IEC61850 zmienna o adresie ".....@Err " może przyjmować następujące wartości:

(0) No Error

(1) Unknown

(2) Timeout Test Not OK

(3) Operator Test Not OK

Zmienna o adresie "....@AddCause" może przyjmować wartości:

Unknown | 0
Not-supported | 1
Blocked-by-switching-hierarchy | 2
Select-failed | 3
Invalid-position | 4
Position-reached | 5
Parameter-change-in-execution | 6
Step-limit | 7
Blocked-by-Mode | 8
Blocked-by-process | 9
Blocked-by-interlocking | 10
Blocked-by-synchrocheck | 11
Command-already-in-execution | 12
Blocked-by-health | 13
1-of-n-control | 14
Abortion-by-cancel | 15
Time-limit-over | 16
Abortion-by-trip | 17
Object-not-selected | 18

Alarmy

Zmianę wartości zmiennej drajwera IEC61850 można powiązać z generacją alarmów. W tym celu, do adresu zmiennej należy dodać parametr dodatkowy - definicję alarmów:

Definicją alarmu może mieć postać:

ABalarm_no bit_no

lub

AXalarm_no bit_no

lub

ALalarm_no relacja wartość

Alarmy typu AB są podobne do strategii bitowej systemu Asix. Alarm_no definiuje numer pierwszego alarmu. Alarm ten jest skojarzony z bitem bit_no wartości zmiennej. Kolejne bity wartości zmiennej są skojarzone z alarmami o kolejnych numerach. Ustawienie bitu na 1 powoduje wygenerowanie nowego alarmu a wyzerowanie bitu powoduje zakończenie alarmu.

Alarmy AX działają tak jak alarmy AB, z tym, że definicja dotyczy tylko jednego konkretnego bitu bit_no. Pozostałe bity nie są analizowane.

Pierwszy bit wartości ma numer 0.

Alarm typu AL jest generowany gdy, wartość zmiennej spełnia relację.

Możliwe są następujące relacje:

= lub == - równość

!= lub <> - nierówność

> - większe niż

>= - większe lub równe

< - mniejsze niż

<= - mniejsze lub równe

Przykłady:

Control/CSWI2.Pos.stVal[AL300=1:AL301=3]

Alarm 301 zostanie wygenerowany gdy wartość zmiennej (położenie łącznika) wynosi 1 (ON). Alarm 301 zostanie wygenerowany, gdy wartość zmiennej wynosi 3 (pośrednie położenie łącznika).

MEAS/MMXU1.PPV.phsAB.instCVal.mag.f[AL500>32,76]

Alarm zostanie wygenerowany, gdy wartość zmiennej przekroczy 32,76.

CTRL/LLN0.Mod.stVal[AX600 1]

Ustawienie bitu nr 1 wartości zmiennej spowoduje wygenerowanie alarmu o numerze 600.

Parametr "Global_alarms" określa rodzaj generowanych alarmów i jeśli ma on wartość "Tak" to generowane są alarmy globalne. Ponieważ parametr dotyczy całego drajwera to można go umieścić w sekcji [IEC61850].

Przełączanie zestawów nastaw

Aby zmienić numer aktywnego zestawu nastaw należy zdefiniować zmienną o adresie LD/LLN0.SGCB.ActSG.

Gdzie LD - jest nazwą urządzenia logicznego zawierającego zestawy nastaw (np. System/LLN0.SGCB.ActSG)

Zapis określonej wartości do takiej zmiennej spowoduje uaktywnienie odpowiedniego zestawu nastaw.

Zestawienie parametrów kanału

Nazwa | Opis | Wartość domyślna
IP | Adres zdalnego urządzenia IED | brak
aeq | Application entity qualifier | 12
appid | Application identifier | 1.1.1.999.1
psel | Presentation selector | 1
ssel | Session selector | 1
tsel | Transport selector | 1
ExplTmo | Maksymalny okres czasu w sekundach przeznaczony na wstępny odczyt danych z urządzenia | 40
scl | Ścieżka i nazwa pliku konfiguracyjnego SCL | Brak
ied | Nazwa IED | Nazwa IED w pliku *.icd, *.cid
ied2 | Nazwa IED jeśli w pliku SCL podana jest inna nazwa niż rzeczywista nazwa urządzenia | Brak
itcom | Jeśli opcja ma wartość "Tak" to moduł komunikacyjny drajwera IEC61850 zostanie uruchomiony jako oddzielny proces (serwer COM). Opcji należy użyć jeśli istnieje podejrzenie, że drajwer powoduje konflikt z innymi drajwerami systemu Asix korzystającymi z protokołu TCP/UDP. Przed użyciem tej opcji należy zarejestrować program ITLibCOMServer.exe (serwer COM) wykonując komendę ITLibCOMServer.exe .regserver | Nie
origin | Tekst określający obiekt, który wykonuje sterowanie daną | Asix
interlock | Parametr określa, czy w trakcie sterowania ma być użyty interlock. Dopuszczalne wartości: "Tak", "Nie". | Nie
synchrocheck | Parametr określa, czy w trakcie sterowania ma być użyty synchrocheck. Dopuszczalne wartości: "Tak", "Nie". | Nie
test | Parametr określa, czy w trakcie sterowania ma być wykonane w trybie Test. Dopuszczalne wartości: "Tak", "Nie". | Nie
ConfDS | Parametr określa, czy DataSet użyty w kanale z raportowaniem jest prekonfigurowany w urządzoniu, czy też też drajwer powinien go utworzyć. Dopuszczalne wartości: "Tak", "Nie". | Nie
ToESync | Parametr określa, czy do określenia odebranego raportu jako historyczny lub bieżący ma być użyte pole TimeOfEntry raportu zamiast pola EntryID. Dopuszczalne wartości: "Tak", "Nie". | Nie
BRCBSync | Parametr określa, czy do kanał powinien być zsynchronizowany tak, aby brać pod uwagę tylko raporty bieżące do ustalania wartości zmiennych Asixa. Dopuszczalne wartości: "Tak", "Nie". | Tak
TrgOps | Parametr to lista nazw zdarzeń wyzwalających generowanie raportu. Nazwa może być poprzedzona znakiem "-" (minus) co spowoduje jej wyłączenie. Dopuszczalne nazwy zdarzeń wyzwalania raportów: dchg - zmiana wartości danej qchg - zmiana jakości danej dupd - aktualizacja wartości danej GI - ogólne odpytanie integ - odpytanie okresowe all - wszystkie opcje | dchg, dupd, qchg
OptFlds | Parametr to lista nazw składników z jakich ma składać się raport generowany przez IED. Dopuszczalne nazwy zdarzeń wyzwalania raportów: SqN - numer kolejny Toe - czas generacji raportu rc - przyczyna generacji raportu ds. - referencja DataSet dr - referencje danych raportu bo - przepełnienie bufora ei - identyfikator raportu cf - wersja konfiguracji raportów seg - numer segmentu raportu all - wszystkie składniki raportu | Brak
Simple_Control | Parametr określa, czy w kanale ma być stosowane sterowanie uproszczone. Dopuszczalne wartości: "Tak", "Nie". | Nie
ds | Referencja do DataSet | Brak
BufTm | Czas oczekiwania w milisekundach od wystąpienia pierwszego zdarzenia powodującego i wzyzwolenie raportu na kolejne zdarzenia zanim wygenerowany zostanie raport | -1 (parametr nie zostanie ustawiony, tj. zostanie użyty czas uprzedni ustawiony)
IntgPd | Interwał w milisekundach z jakim IED ma przesyłać raporty cykliczne | -1 (parametr nie zostanie ustawiony, tj. zostanie użyty czas uprzedni ustawiony)
ResvTms | Czas w sekundach rezerwacji bloku raportów buforowanych dla konkretnego klienta po utracie połczenia z IED. | 600
Diag | Parametr określa rodzaj dodatkowych informacji diagnostycznych zapisywanych w pliku określonym parametrem "Log". Jest to lista nazw grup informacji oddzielonych przecinkami. | Brak
Log | Nazwa pliku do którego będą zapisywane informacje diagnostyczne opcjonalnie poprzedzoną ścieżką do tego pliku. Po nazwie pliku, po przecinku można podać maxymalny rozmiar pliku w megabajtach. | Brak
Dump | Nazwa pliku do którego będą zapisywane informacje przesyłane do/z IED. Po nazwie pliku, po przecinku można podać maxymalny rozmiar pliku w megabajtach. | Brak
CurrTm | Jeśli parametr ma wartość "Tak" to wszystkie zmienne otrzymają stempel czasu róeny bieżącemu czasowi PC. | Nie
TStampOffset | Zmiana wartości/jakości danej i, co za tym idzie, stempla czasu danej może następować w nieregularnych odstępach czasu co z kolei może powodować powstanie "dziur" w archiwum. Podanie tego parametru powoduje nadanie danej czasu bieżącego jako stempla czasu z pewnym przesunięciem wstecz, tak aby skompensować różnice pomiędzy zegarem urządzenia i PC. Wartością parametru jest przesunięcie wyrażone w sekundach. Wartość 0 oznacza wyłączenie tego mechanizmu. | 0
Type | Określa typ urządzenia. Aktualnie dotyczy tylko urządzeń MiCOM. Możliwe wartości to P139 i P345. | Brak

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


K3N - drajwer protokołu mierników OMRON serii K3N

Home > 1.46 K3N - drajwer protokołu mierników OMRON serii K3N

1.46 K3N - drajwer protokołu mierników OMRON serii K3N

Przeznaczenie drajwera

Drajwer K3N jest wykorzystywany do wymiany danych pomiędzy miernikami serii K3N firmy OMRON oraz komputerem systemu Asix. Komunikacja odbywa się wg protokołu CompoWay/F firmy OMRON przy wykorzystaniu standardowych portów szeregowych komputera Asix.

Parametryzacja drajwera K3N realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego korzystającego z drajwera K3N wymaga określenia parametrów danego kanału w module Dane bieżące:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: K3N

Zakładka K3N:

Parametry kanału:

id, port [, baud, znak, parzystość, stop ]

gdzie:

id - numer sterownika w sieci K3N

port - nazwa portu: COM1, COM2 itd.,

opcjonalne parametry:

baud - prędkość transmisji,

znak - liczba bitów w znaku,

parzystość - sposób kontroli parzystości,

stop - liczba bitów stopu.

Jeśli nie podano parametrów opcjonalnych, to domyślnie przyjmuje się ustawienia fabryczne miernika tzn.:

  • prędkość transmisji 9600 bodów,

  • 7 bitów w znaku,

  • kontrola parzystości parzysta (EVEN),

  • liczba bitów stopu 2.

Przykład

Deklaracja kanału logicznego o nazwie KANAL1 działającego wg protokołu K3N i wymieniającego dane z miernikiem o numerze 1 poprzez port COM2 z domyślnymi parametrami transmisji:

Nazwa: KANAL1

Drajwer: K3N

Parametry kanału: 1, COM2

Drajwer K3N jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ>[.<kategoria>.<indeks>]

gdzie:

typ - typ zmiennej,

kategoria - kategoria w ramach typu (dla niektórych typów),

indeks - indeks w ramach kategorii (dla niektórych typów).

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

VW - wartości zmiennych przekazywanych w postaci liczb 16-bitowych bez znaku (WORD); dotyczy zmiennej Status data (kategoria C0, indeks 3);

VL - wartości zmiennych przekazywanych w postaci liczb 32-bitowych ze znakiem (LONG); dotyczy wszystkich zmiennych kategorii C0 poza zmienną Status data;

PW - wartości parametrów przekazywanych w postaci liczb 16-bitowych bez znaku (WORD); dotyczy wszystkich zmiennych kategorii 8000 oraz 8824;

PL - wartości parametrów przekazywanych w postaci liczb 32-bitowych ze znakiem (LONG); dotyczy wszystkich zmiennych kategorii C00C oraz 8824;

STAT - status trybu pracy (WORD);

INFO - uzupełniająca informacja przekazywana ze statusem trybu pracy (WORD);

RST - wykonanie komendy: reset wartości minimalnych i maksymalnych (WORD);

FCLR - wykonanie komendy ’clear forced-zero setting’ (WORD);

MODE - ustawienie trybu pracy miernika (Run lub Setting Mode) (WORD);

CTRL - ustawienie trybu programowania miernika (Remote programming lub Local programming) (WORD).

Kategoria i indeks muszą być podane dla typów VW, VL, PW, PL. Zestawienie legalnych oznaczeń (numerów) kategorii oraz zakresy indeksów w ramach poszczególnych kategorii zawiera dokumentacja "Communication Output-type Intelligent Signal Processor - OPERATION MANUAL" Cat. No. N96-E1-1 (pkt 1-5 'Memory/Parametrs Area Details’).

Wartości zmiennych typu VW, VL, PW, PL mogą być odczytywane oraz modyfikowane. Poprawny odczyt zmiennych typu VW, VL, PW, PL jest możliwy tylko wtedy, gdy miernik jest ustawiony w tryb RUN mode.

Wartości zmiennych typu INFO, STAT mogą być wyłącznie odczytywane.

Zmienne typu RST, FCLR, MODE, CTRL służą wyłącznie do wykonania komend sterujących trybem pracy miernika i nie można dla nich zrealizować operacji odczytu.

Wysłanie sterowania przy użyciu zmiennej typu MODE powoduje:

  • przełączenie miernika w tryb RUN mode, jeśli wartość sterująca zmiennej jest ustawiona na 0,

  • przełączenie miernika w tryb Setting mode, jeśli wartość sterująca zmiennej jest różna od 0.

Wysłanie sterowania przy użyciu zmiennej typu CTRL powoduje:

  • przełączenie miernika w tryb Local programming mode, jeśli wartość sterująca zmiennej jest ustawiona na 0,

  • przełączenie miernika w tryb Remote programming, jeśli wartość sterująca zmiennej jest różna od 0.

Przykłady deklaracji zmiennych

# wartość bieżąca (Present value): zmienna nr 0 z kategorii C0

JJ_0, VL.C0.0, KANAL1, 1, 1, NIC_LONG

# maximum (Maximum value): zmienna nr 1 z kategorii C0

JJ_1, VL.C0.1, KANAL1, 1, 1, NIC_LONG

# wartość statusu (Status data): zmienna nr 3 z kategorii C0

JJ_2, VW.C0.3, KANAL1, 1, 1, NIC

# aktualny tryb pracy miernika (RUN, Setting mode)

JJ_10, STAT, KANAL1, 1, 1, NIC

# uzupełniające informacje przekazywane razem ze statusem miernika

# ( HOLD status, RESET status, Local/Remote programming )

JJ_11, INFO, KANAL1, 1, 1, NIC

# realizacja komendy: reset wartości minimalnych i maksymalnych miernika

JJ_12, RST, KANAL1, 1, 1, NIC

# realizacja komendy: 'Clear forced-zero setting’

JJ_13, FCLR, KANAL1, 1, 1, NIC

# realizacja komendy: 'Switch mode’

JJ_14, MODE, KANAL1, 1, 1, NIC

# realizacja komendy: 'Remote/Local programming’

JJ_14, CTRL, KANAL1, 1, 1, NIC

# parametr 'input range’ miernika K3NX

JJ_20, PW.8000.0, KANAL1, 1, 1, NIC

# parametr 'scaling display value 2’ miernika K3NX

JJ_21, PL.C00C.1, KANAL1, 1, 1, NIC_LONG

# parametr ’power supply frequency’ miernika K3NX

JJ_22, PW.8824.0, KANAL1, 1, 1, NIC

# parametr ’input mode’ miernika K3NC

JJ_30, PW.8000.0, KANAL1, 1, 1, NIC

# parametr 'power failure memory’ miernika K3NC

JJ_31, PW.8824.1, KANAL1, 1, 1, NIC

# parametr 'compensation value’ miernika K3NC

JJ_32, PW.C82A.0, KANAL1, 1, 1, NIC_LONG

Parametry drajwera

Parametry drajwera K3N deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu K3N może być parametryzowany przy wykorzystaniu sekcji K3N.

R Nazwa sekcji: K3N
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera K3N oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu

R Nazwa sekcji: K3N
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie: pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku w MB.

Wartość domyślna: domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Nazwa sekcji: K3N
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie: pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji z miernikiem. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: K3N
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: id,liczba

Znaczenie: opcja pozwala określić maksymalny czas oczekiwania na nadejście pierwszego znaku odpowiedzi z określonego miernika. Po upływie tego czasu uznaje się, że przedmiotowy miernik jest wyłączony i seans transmisji kończony jest z błędem.

Wartość domyślna: domyślnie przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund.

Parametry:

id - numer miernika w sieci K3N,

liczba - czas w milisekundach (od 100 do 5000).

R Nazwa sekjci: K3N
R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: id,liczba

Znaczenie: pozwala określić maksymalny czas pomiędzy kolejnymi znakami odpowiedzi z określonego miernika. Po przekroczeniu tego czasu uznaje się, że przedmiotowy miernik nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

Wartość domyślna: domyślnie przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 50 milisekund.

Parametry:

id - numer miernika w sieci,

liczba - czas w milisekundach (od 10 do 300).

R Nazwa sekcji: K3N
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie - pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie 0.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


K-BUS - drajwer protokołu regulatorów kotłów serii

Home > 1.47 K-BUS - drajwer protokołu regulatorów kotłów serii

1.47 K-BUS - drajwer protokołu regulatorów kotłów serii Dekamatic VIESSMANN

Przeznaczenie drajwera

Drajwer K-BUS jest wykorzystywany do wymiany danych pomiędzy regulatorami kotłów serii Dekamatic f-my VIESSMANN dołączonymi do koncentratora Dekatel-G (lub Vitocom 200) oraz komputerem systemu Asix.

Parametryzacja drajwera K-BUS realizowana jest przy użyciu programu Architekt.

Deklaracja kanłu transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer K-BUS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: K-BUS

Zakładka K-BUS:

Parametry kanału:

id, port [, alarm_offset]

gdzie:

id - identyfikator regulatora,

port - nazwa portu: COM1, COM2 itd.;

opcjonalne parametry:

alarm_offset - offset dodawany do numeru alarmu przesyłanego z regulatora.

Domyślnie wartość offsetu wynosi 0.

Poniżej podana jest lista identyfikatorów przepisanych poszczególnym regulatorom:

1 - Dekamatic-D1/Dekamatic-DE,

2 - Dekamatic-D2 (Kesselregelung 2. Kessel),

3 - Dekamatic-D2 (Kesselregelung 3. Kessel),

4 - Dekamatic-HK (1. und 2. Heizkreis),

5 - Dekamatic-HK (3. und 4. Heizkreis),

6 - Dekamatic-HK (5. und 6. Heizkreis),

7 - Dekamatic-HK (7. und 8. Heizkreis),

8 - Dekamatic-HK (9. und 10. Heizkreis),

9 - Dekamatic-HK (11. und 12. Heizkreis),

10 - Dekamatic-HK (13. und 14. Heizkreis),

11 - Dekamatic-HK (15. und 16. Heizkreis).

Parametry transmisji są stałe:

- 1200 Bd,

- 8 bitów znaku,

- kontrola parzystości - even,

- jeden bit stopu.

PRZYKŁAD

Deklaracja kanału logicznego o nazwie KANAL1, działającego wg protokołu K-BUS i wymieniającego dane ze regulatorem Dekamatic-DE (id 1) poprzez port COM2 jest następująca:

Nazwa: KANAL1

Drajwer:K-BUS

Parametry kanału: 1, COM2

Drajwer K-BUS jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

V<indeks>

gdzie:

V - stałe oznaczenie typu zmiennej,

indeks - indeks zmiennej zgodny z tabelą adresów zmiennych dla przedmiotowego regulatora (podawany w postaci HEX).

Wartości surowych zmiennych przekazywane są przez drajwer jako liczby typu WORD.

PRZYKŁAD

Przykłady deklaracji zmiennych:

# max temperatura kotła (id 12 HEX)

JJ_1, V12, KANAL1, 1, 1, NIC

# temperatura zewnętrzna (id 25 HEX )

JJ_2, V25, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera K-BUS deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu K-BUS może być parametryzowany przy wykorzystaniu sekcji K-BUS.

R Nazwa sekcji: K-BUS
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie: pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera K-BUS oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: K-BUS
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji z regulatorami. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: K-BUS
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie: opcja pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - wartość wyrażona w MB.

Wartość domyślna: domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Nazwa sekcji: K-BUS
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: id,liczba

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania na nadejście pierwszego znaku odpowiedzi z określonego regulatora. Po upływie tego czasu uznaje się, że przedmiotowy regulator jest wyłączony i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund.

Parametry:

id - identyfikator regulatora,

liczba - czas w milisekundach (od 100 do 5000).

R Nazwa sekjci: K-BUS
R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: id,liczba

Znaczenie - opcja pozwala określić maksymalny czas (w milisekundach) pomiędzy kolejnymi znakami odpowiedzi z określonego regulatora. Po przekroczeniu tego czasu uznaje się, że przedmiotowy regulator nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas pomiędzy kolejnymi znakami odpowiedzi wynosi 50 milisekund.

Parametry:

id - identyfikator regulatora,

liczba - czas w milisekundach (od 10 do 300).

Zwłoka po przemapowaniu danych w koncentratorze Dekatel-G (Vitocom 200)

Dekatel-G (Vitocom 200) pozwalają na jednoczesny odczyt max 8 zmiennych. Tryb pracy z koncentratorem polega na sukcesywnym wykonywaniu poniższych funkcji dla kolejnych grup zmiennych:

  • przesłanie listy max. 8-miu zmiennych do koncentratora (tzw. przemapowanie koncentratora),

  • odczekanie na aktualizację zmiennych w koncentratorze po przemapowaniu,

  • odczyt wartości zmiennych z koncentratora.

R Nazwa sekcji: K-BUS
R Nazwa opcji: ZWLOKA_PO_MAPOWANIU
R Wartość opcji: liczba

Znaczenie: opcja pozwala określić czas, który musi upłynąć pomiędzy przemapowaniem i pierwszym odczytem danych z koncentratora, aby odczytywane dane mogły być uznane za wiarygodne. W przypadku zbyt krótkiego czasu zwłoki istnieje ryzyko odczytania wartości zmiennych, które były zarejestrowane w koncentratorze przed przemapowaniem.

Wartość opcji: liczba - czas w sekundach.

Wartość domyślna: domyślnie parametr przyjmuje wartość 35 sekund.

UWAGA Dokumentacja protokołu nie podaje przepisu na wyliczenie zwłoki po przemapowaniu koncentratora, dlatego parametr ten musi być określony doświadczalnie przez użytkownika.

R Nazwa sekcji: K-BUS
R Nazwa opcji: ALARMY_GLOBALNE
R Wartość opcji: TAK|NIE

Znaczenie - opcja steruje sposobem przekazywania alarmów odczytanych z regulatorów do systemu alarmów systemu Asix.

Wartość domyślna - domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości opcji ALARMY_GLOBALNE na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili().

Parametry:

liczba - czas w sekundach.

R Nazwa sekcji: K-BUS
R Nazwa opcji: LICZBY_ZE_ZNAKIEM
R Wartość opcji: TAK/NIE

Znaczenie - opcja decyduje o sposobie, w jaki interpretowana jest zmienna typu BYTE. Ustawienie wartości opcji na NIE, spowoduje nadanie zmiennej typu BYTE interpretacji UNSIGNED CHAR.

Wartość domyślna - domyślnie oraz w przypadku ustawienia wartości na TAK, zmienna typu BYTE przyjmuje interpretację SIGNED CHAR - umożliwia to przekazywanie wartości ujemnych.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


Lb480

Home > 1.48 Lb480 - drajwer protokołu koncentratorów LB-480 firmy LAB_EL Elektronika Laboratoryjna

1.48 Lb480 - drajwer protokołu koncentratorów LB-480 firmy LAB_EL Elektronika Laboratoryjna

Przeznaczenie drajwera

Drajwer Lb480 służy do odczytu bieżących oraz historycznych danych z koncentratora LB-480, produkowanego przez firmę LAB_EL Elektronika Laboratoryjna (http://www.label.pl/).

Przykładowe zastosowania koncentratora LB-480:

· monitoring serwerowni: pomiar temperatury w różnych punktach, pomiar wilgotności powietrza, czujnik zalania, czujniki otwarcia drzwi z detekcją sabotażu linii czujnika;

· mini stacja meteo: pomiar temperatury i wilgotności powietrza, ciśnienia atmosferycznego, prędkości i kierunku wiatru, nasłonecznienia;

· lokalny pomiar temperatury: możliwość pomiaru temperatury w 8 punktach za pomocą prostych i tanich bezpośrednich sond termistorowych.

Wymiana danych pomiędzy systemem Asix a koncentratorem LB-480 odbywa się poprzez łącze Ethernet przy użyciu protokołu Modbus/TCP, zrealizowanego w trybie UDP.

Deklaracja kanału transmisji

Dla każdego koncentratora należy zdefiniować osobny kanał transmisji drajwera Lb480. Deklaracja takiego kanału transmisyjnego wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa – nazwa logiczna kanału transmisji

Drajwer – Lb480

Zakładka Lb480 / Parametry kanału:

Adres IP urządzenia – adres IP koncentratora,

Numer urządzenia w sieci MODBUS – numer nadany koncentratorowi w sieci MODBUS,

Port - numer portu TCP w koncentratorze; domyślnie: 502,

Przykład

Nazwa: KANAL

Drajwer: Lb480

Adres IP urządzenia:10.10.105.21

Numer urządzenia w sieci MODBUS:10

Deklaracja zmiennych

Składnia adresu symbolicznego jest następująca:

ZM[nrWe].[nrZm]

gdzie:

nrWe - numer wejścia (zakres od 1 – 8)

nrZm - numer zmiennej (zakres 1 – 8) z wejścia określonego przez parametr nrWe

Drajwer akceptuje tylko takie funkcje przeliczające, dla których surowa wartość zmiennej procesowej jest typu DWORD, LONG lub FLOAT.

Jeśli z zastosowanej funkcji przeliczającej wynika, że surowym typem zmiennej procesowej jest DWORD lub LONG, to drajwer odczytuje wartości zmiennych procesowych z obszaru rejestrów 30065 – 30192.

Jeśli z zastosowanej funkcji przeliczającej wynika, że surowym typem zmiennej procesowej jest FLOAT, to drajwer odczytuje wartości zmiennych procesowych z obszaru rejestrów 30193 – 30320.

Przykłady:

; X_ZM1_1 - zmienna do pokazywania stanu wejścia 1, zmiennej 1 w postaci stałoprzecinkowej

X_ZM1_1, ,ZM1.1, KANALX, 1, 1, NIC_DW

; X_ZM3_2 - zmienna do pokazywania stanu wejścia 3, zmiennej 2 w postaci zmiennoprzecinkowej

X_ZM3_2, ,ZM3.2, KANALX, 1, 1, NIC_FP

; X_ZM2_2 - zmienna do pokazywania stanu wejścia 2, zmiennej 2 w postaci zmiennoprzecinkowej

; z użyciem skalowania

X_ZM2_2, ,ZM2.2, KANALX, 1, 1, MNOZNIK_FP, 2.0

Odczyt danych historycznych

Drajwer pozwala na dostęp do danych historycznych gromadzonych w pamięci koncentratora. Odczyt danych historycznych jest realizowany przy pomocy specjalnej funkcji protokołu Modbus, opracowanej przez producenta koncentratora.

Dostęp do danych historycznych jest parametryzowany przy pomocy opcji drajwera (opcje są opisane w punkcie Parametryzacja drajwera).

Uwaga:

Jeżeli w koncentratorze nie jest zainstalowany firmware pozwalający na dostęp do danych historycznych, należy wyłączyć odczyt danych historycznych przy użyciu opcji Dane historyczne.

Parametryzacja drajwera

Parametry drajwera Lb480 deklarowane są na zakładkach Lb480/Parametry drajwera:

· tworzenie pliku logu,

· rozmiar pliku logu,

· log telegramów,

· timeout odbioru,

· adres IP karty komputera, poprzez którą jest obsługiwany koncentrator,

oraz specyficzne pozycje związane z obsługą danych historycznych zgromadzonych w pamięci koncentratora:

· tworzenie pliku logu dla operacji związanych z obsługą danych historycznych,

· log danych historycznych przekazywanych do modułu archiwizacji Aspad,

· wyłączenie odczytu danych historycznych.

R Timeout odpowiedzi

Znaczenie - określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z koncentratora.

Wartość domyślna - 500 ms.

Parametry:

liczba - wartość timeout’u wyrażona w milisekundach.

R Adres IP komputera

Znaczenie: - opcja służy do określenia adresu karty sieciowej komputera, poprzez którą wszystkie kanały drajwera będą się komunikować z koncentratorami.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4.

Wartość domyślna: - jeśli opcja nie jest zadeklarowana, to zostanie użyta karta sieciowa dostarczona przez system.

R Dane historyczne

Znaczenie - opcja pozwala wyłączyć odczyt danych historycznych we wszystkich kanałach.

Wartość domyślna - domyślnie TAK.

Parametr:

TAK/NIE

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

Nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie plik logu ma rozmiar 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i koncentratorami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Parametry:

TAK/NIE

Wartość domyślna - domyślnie plik logu nie jest deklarowany.

R Plik logu historii

Znaczenie - Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty dotyczące dostępu do danych historycznych we wszystkich kanałach dostarczających dane historyczne.

Wartość domyślna - domyślnie nie tworzy się pliku logu historii.

Parametr:

nazwa pliku

R Log danych historycznych Aspada

Znaczenie - opcja określa, czy do pliku logu operacji dostępu do danych historycznych należy wpisywać wartości i stemple czasu poszczególnych próbek przekazywanych do Aspada.

Wartość domyślna - domyślnie NIE.

Parametr:

TAK/NIE

Przykładowa parametryzacja drajwera:

Plik logu: d:\tmp\CtLb480\label.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Adres IP komputera: 10.10.110.24

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu opcji deklarowanych na zakładkach Lb480/Parametry kanału i Parametry kanału - diagnostyka:

· tworzenie pliku logu,

· rozmiar pliku logu,

· log telegramów,

· timeout odbioru,

· adres IP karty komputera, poprzez którą jest obsługiwany koncentrator,

· wyłączenie odczytu danych historycznych.

R Plik logu

Znaczenie - dla celów diagnostycznych kanału służy tekstowy plik logu, do którego są wpisywane komunikaty zawierające treści telegramów wysyłanych i odbieranych w danym kanale.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

Nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie plik logu ma rozmiar określony w parametrach drajwera.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w danym kanale. Wartość opcji przeciąża ustawienie określone przez opcję o tej samej nazwie, umieszczoną w parametrach drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Parametry:

TAK/NIE

Wartość domyślna - domyślnie plik logu nie jest deklarowany.

R Timeout odpowiedzi

Znaczenie - określa maksymalny czas, przez który w danym kanale oczekuje się na nadejście odpowiedzi z koncentratora. Wartość opcji przeciąża ustawienie określone przez opcję o tej samej nazwie zadeklarowaną w parametrach drajwera.

Wartość domyślna - 500 ms.

Parametry:

liczba - wartość timeout’u wyrażona w milisekundach.

R Adres IP komputera

Znaczenie: - opcja służy do określenia adresu karty sieciowej komputera, poprzez którą kanał komunikuje się z koncentratorem. Wartość opcji przeciąża ustawienie określone przez opcję o tej samej nazwie zadeklarowaną w parametrach drajwera.

Wartość opcji:

adres_IP - adres karty sieciowej w notacji IPv4.

Wartość domyślna: - jeśli opcja nie jest zadeklarowana, to zostanie użyta karta sieciowa zadeklarowana przez opcję określoną z parametrach drajwera.

R Dane historyczne

Znaczenie - opcja pozwala wyłączyć odczyt danych historycznych w danym kanale. Wartość opcji przeciąża ustawienie określone przez opcję o tej samej nazwie zadeklarowaną w parametrach drajwera.

Wartość domyślna - domyślnie TAK.

Parametr:

TAK/NIE

Przykładowa parametryzacja kanału:

Nazwa (kanału): KANAL1

Plik logu: d:\logi\kanal1.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Adres IP komputera: 10.10.115.25

Timeout odpowiedzi: 750


CtLG - drajwer dedykowanego protokołu sterowników LG

Home > 1.49 LG - drajwer dedykowanego protokołu sterowników LG Master-K i Glofa GM

1.49 LG - drajwer dedykowanego protokołu sterowników LG Master-K i Glofa GM

Przeznaczenie drajwera

Drajwer LG jest przeznaczony do wymiany danych pomiędzy systemem Asix a sterownikami LG Industrial Systems Master - K i Glofa GM przy użyciu portu RS232. Drajwer pozwala na dostęp do danych sterowników LG adresowanych bezpośrednio poprzez podanie adresu zmiennej w ramach urządzenia. Drajwer pozwala na jednoczesną obsługę wielu sterowników LG.

Parametryzacja drajwera CtLG realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer LG wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtLG

Zakładka LG:

Parametry kanału:

Port=numer_portu; Predkosc=predkosc_transmisji; BityStopu=liczba_bitow_stopu;BitParzystosci=kontrola_parzystosci_ramki; BityDanych=liczba_bitow_danych; LiczbaBlokow=liczba_blokow;

SynchrCzasu=adres[:okres];

gdzie:

Port - numer portu szeregowego COM;

Predkosc - prędkość transmisji między komputerem a urządzeniem; dopuszczalne są następujące prędkości: 1200, 2400, 4800, 9600, 19200, 38400, 56000, 57600, 115200, 128000; wszystkie prędkości wyrażone są w bitach na sekundę czyli bodach; domyślna wartość wynosi 1200 Bd;

BityStopu - liczba bitów stopu: 1 lub 2; dla sterownika GlofaGM6 parametr ten jest zaszyty na stałe w sterowniku i wynosi 1; domyślna wartość parametru wynosi 1;

BitParzystosci - określa sposób kontroli parzystości ramki; możliwe opcje:

brak, kontrola_parzystosci, kontrola_nieparzystosci; jako zamienniki do tych opcji można użyć odpowiednio: 0, 1, 2; dla sterownika GlofaGM6 parametr ten jest zaszyty na stałe w sterowniku i wynosi 0, czyli brak; domyślna wartość parametru to kontrola_parzystosci;

BityDanych - ilość bitów danych w ramce: 7 lub 8; dla sterownika GlofaGM6 parametr ten jest zaszyty na stałe w sterowniku i wynosi 8; domyślna wartość parametru wynosi 8;

LiczbaBlokow - max. ilość bloków specyfikujących zmienne w pojedynczej operacji odczytu; maksymalna wartość parametru wynosi 16; parametr wprowadzono ze względu na to, że sterownik GLOFA realizuje poprawnie zapytania dla max. 4-ech bloków (niezgodnie z dokumentacją); domyślna wartość parametru wynosi 16;

SynchrCzasu - w przypadku sterowników Glofa jest to adres bezpośredni tablicy 9 bajtów (w sterowniku), do której będzie wpisywany czas systemowy PC. Tablica będzie wypełniana liczbami w kodzie BCD w następujący sposób:

czas[0] = dwie młodsze cyfry roku

czas[1] = miesiąc

czas[2] = dzień miesiąca

czas[3] = godzina

czas[4] = minuty

czas[5] = sekundy

czas[6] = dzień tygodnia (poniedziałek - 0, wtorek - 1,... niedziela - 6)

czas[7] = dwie starsze cyfry roku

czas[8] = 1

np. 2001 - 03 - 15 18:30:45 Czwartek: czas[0] = 01, czas[1] = 03, czas[2] = 15, czas[3] = 18, czas[4] = 30, czas[5] = 45, czas[6] = 03, czas[7] = 20,

Po stronie sterownika Glofa należy wykonać rozkaz RTC_SET argument. Argument jest adresem symbolicznym tablicy 8 bajtów. Deklarując tą zmienną należy w polu Memory allocation wybrać opcję Assign(AT) i przypisany adres bezpośredni zmiennej podać w deklaracji kanału transmisji. W chwili przepisania czasu systemowego z PC do sterownika do dziewiątego elementu tablicy wpisywana jest wartość 1.

W przypadku sterownika MASTER-K SynchrCzasu jest adresem pięcioelementowej tablicy typu word w sterowniku N. Tablica wypełniana jest liczbami w kodzie BCD w następujący sposób:

czas[0] = starszy bajt = młodsze 2 cyfry roku, młodszy bajt = miesiąc (1..12)

czas[1] = starszy bajt = dzień miesiąca (1..31), młodszy bajt = godzina

czas[2] = starszy bajt = minuty, młodszy bajt = sekundy

czas[3] = starszy bajt = starsze 2 cyfry roku, młodszy bajt = dzień tygodnia ( niedziela - 0, poniedziałek - 1...sobota - 6 ).

czas[4] = 1

Te słowa za wyjątkiem czas[4] należy przepisać do specjalnego obszaru w pamięci i ustawić odpowiedni bit.

okres - jest parametrem domyślnym, który określa, co ile sekund czas z PC będzie przepisywany do sterownika. Domyślnie okres synchronizacji czasu wynosi 60 sekund.

PRZYKŁAD

Przykład deklaracji kanału, w którym dla sterownika o numerze 6 (typu GLOFA) będzie synchronizowany czas poprzez zapis do obszaru zaczynającego się od MB10 (co 25 sekund):

Nazwa: PLC1

Drajwer: CtLG

Parametry kanału:

Port=2;Predkosc=9600; BityStopu=1; BitParzystosci=kontrola_nieparzystosci; BityDanych=8; SynchrCzasu=6.MB10:25

Adresacja zmiennych

Adresacja zmiennych w rodzinie Master - K

Dopuszcza się tylko adres bezpośredni w postaci:

NrSterownika.TypUrzadzenia.Adres

gdzie:

Numer sterownika - to liczba z zakresu od 0 do 31.

Typ urządzenia - patrz: tabela poniżej.

Tabela. Drajwer CtLG - typy urządzeń.

UWAGA Nie należy używać urządzeń T i C dla adresowania bitowego, ponieważ nie działa ono z powodu błędu w systemie operacyjnym sterownika.

Istnieją dwa typy zmiennych:

  • bit,

  • word.

Adres zmiennej może zawierać do 8 znaków ( nie licząc znaku typu urządzenia i znaku '.’ , o ile występuje w adresie). Adres podajemy w postaci dziesiętnej. Gdy adresujemy bit w obrębie słowa, to numer bitu (od 0 do 15) podajemy po kropce. Wyjątkiem od tej reguły są typy Timer i Counter, co widać w tabelce powyżej, gdzie bity adresowane są od 0 do 255.

Np. 0.M5 - słowo o adresie 5

0.M5.10 - bit jedenasty w słowie o adresie 5

PRZYKŁADY

Przykłady deklaracji zmiennych:

JJ_00, zmienna typu WORD o adresie M1, 0.M1, PLC1, 1, 1, NIC

JJ_01, zmienna typu BIT o adresie M5.10, 0.M5.10, PLC1, 1, 1, NIC

Adresacja zmiennych w rodzinie Glofa - GM

Adres bezpośredni ma postać:

NrSterownika.TypUrzadzenia.TypZmiennej.Adres

gdzie:

NrSterownika - określa numer sterownika i jest liczbą z zakresu od 0 do 31 ;

TypUrządzenia - określa typ urządzenia; dostępne są następujące typy:

  • M (internal memory),

  • Q (output),

  • I (Input).

Zakres adresacji tych urządzeń jest konfigurowalny i zależny od typu urządzenia.

Do wszystkich tych urządzeń można zarówno pisać i czytać.

TypZmiennej - określa typ zmiennej. Dostępne są następujące typy:

  • X - bit,

  • B - bajt,

  • W - word,

  • D - double word.

W przypadku urządzenia M adres jest podawany w postaci dziesiętnej i jego długość może mieć maksymalnie 13 znaków, nie licząc znaku typu urządzenia i typu zmiennej, np.:

3.MW1 - słowo o adresie 1 ze sterownika nr 3

Jeśli chcemy zaadresować bit w urządzeniu M w obrębie bajtu, słowa lub podwójnego słowa, to numer bitu (liczony od 0) w postaci dziesiętnej podajemy po kropce, np.:

4.MW1.14 - bit czternasty w słowie 1 ze sterownika 4

5.MD2.30 - bit trzydziesty w podwójnym słowie 2 ze sterownika 5

Można również zaadresować bit bezpośrednio używając znaku X, np.:

0.MX10 - bit dziesiąty.

W przypadku adresowania urządzeń Q i I adres podajemy w postaci dziesiętnej i są to trzy liczby (baza, slot, numer) rozdzielone znakiem '.’, np.:

2.QX3.1.4 - sterownik nr 2, 3 baza, 1 slot, 4-ty bit,

3.IW2.4.1 - sterownik nr 3, 2 baza, 4 slot, 1-sze słowo.

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_00, zmienna typu WORD o adresie MW1, 0.MW1, PLC1, 1, 1, NIC

JJ_01, zmienna typu BIT o adresie QX3.1.4, 0.QX3.1.4, PLC1, 1, 1, NIC

Znacznik czasu

Wartościom zmiennych odczytanych z LG jest nadawany stempel czasu PC.

Parametry drajwera

Parametry drajwera LG deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy pomocy sekcji o nazwie CTLG.

R Nazwa sekcji: CTLG

R Nazwa opcji: PLIK_LOGU

R Wartośc opcji: nazwa_pliku_logu

Znaczenie: dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTLG

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CTLG

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowe parametry drajwera:

Nazwa sekcji: CTLG

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\ctLG\LG.log

Nazwa sekcji: CTLG

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 3

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtLogo - DRAJWER sterowników Logo OBA5 firmy SIEMENS

Home > 1.50 Logo - DRAJWER sterowników Logo OBA5 firmy SIEMENS

1.50 Logo - Drajwer sterowników Logo OBA5 firmy SIEMENS

Przeznaczenie drajwera

Drajwer protokołu Logo służy do wymiany danych pomiędzy systemem Asix i sterownikiem Logo OBA5 firmy SIEMENS za pomocą łącza programatora przedmiotowego sterownika. Transmisja jest realizowana łączami szeregowymi przy pomocy standardowych portów szeregowych komputera w standardzie RS-232.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Logo wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Logo

Zakładka CtLG:

Parametry kanału:

Port=liczba; Typ=liczba [;Timeout=liczba]

gdzie:

Port - numer portu szeregowego,

Typ - identyfikator typu sterownika Logo. Aktualnie obsługiwane są: Logo OBA5 (identyfikator 1) i Logo OBA6 (identyfikator 2),

Timeout - max. czas oczekiwania na pierwszy znak odpowiedzi (w milisekundach). Domyślnie 1000 milisekund.

Parametry transmisji są stałe i wynoszą:

- prędkość transmisji 9600 Bd,

- 8 bitów znaku,

- kontrola parzystości,

- 1 bit stopu.

PRZYKŁAD

Przykład deklaracji kanału transmisji KLOGO służącego do komunikacji ze sterownikiem Logo OBA5 przy pomocy portu szeregowego COM2:

Nazwa: KLOGO

Drajwer: Logo

Parametry drajwera: Port=2;Typ=1

Deklaracja zmiennych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu.

Zestaw typów oraz zakres indeksów są specyficzne dla określonego typu sterownika Logo.

UWAGA Wartości zmiennych można wyłącznie czytać - protokół nie pozwala na wykonywanie sterowań.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

Typy zmiennych:

DI - digital input (WORD),

DQ - digital output (WORD),

DM - digital flag (WORD),

AI - analog input (WORD),

AQ - analog output (WORD),

AM - analog flag (WORD).

PRZYKŁAD

Przykłady deklaracji zmiennych:

DI1, digital input 1, DI1, KLOGO,1,1,NIC

DQ3, digital output 3, DQ3, KLOGO,1,1,NIC

DM13,digital flag 13, DM13, KLOGO,1,1,NIC

AI2, analog input 2, AI2, KLOGO,1,1,NIC

AQ1, analog output 1, AQ1, KLOGO,1,1,NIC

AM2, analog flag 2, AM2, KLOGO,1,1,NIC

Parametryzacja drajwera

Parametry drajwera Logo deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany przy użyciu sekcji CTLOGO.

R Nazwa sekcji: CTLOGO

R Nazwa opcji: PLIK_LOGU

R Wartośc opcji: nazwa_pliku_logu

Znaczenie: dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTLOGO

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartośc opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu.

Wartość opcji:

liczba - rozmiar pliku w MB.

Wartość domyślna domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTLOGO

R Nazwa opcji: LOG_TELEGRAMOW

R Wartośc opcji: TAK | NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami opcja służy do określenia rozmiaru pliku logu. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa sekcja drajwera:

Nazwa sekcji: CTLOGO

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtLogo\logo.log

Nazwa sekcji: CTLOGO

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CTLOGO

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


LUMBUS - drajwer regulatorów firmy LUMEL

Home > 1.51 LUMBUS - drajwer regulatorów firmy LUMEL

1.51 LUMBUS - drajwer regulatorów firmy LUMEL

Przeznaczenie drajwera

Drajwer LUMBUS jest wykorzystywany do wymiany danych pomiędzy regulatorami RG72 produkowanymi przez Lubuskie Zakłady Aparatów Elektrycznych "LUMEL" w Zielonej Górze oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych w standardzie RS485.

Parametryzacja drajwera LUMBUS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer LUMBUS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: LUMBUS

Zakładka LUMBUS:

Parametry kanału:

numer, port, baud

gdzie:

numer - numer regulatora w sieci,

port - nazwa portu: COM1, COM2 itd.,

baud - prędkość transmisji w przedziale 1200 - 9600 Bd.

Domyślnie przyjmuje się:

  • prędkość transmisji 9600 Bd,

  • liczba bitów znaku - 8,

  • bez kontroli parzystości (PARITY NONE),

  • liczba bitów stopu - 1.

Przykład

Deklaracja kanału logicznego o nazwie KANAL, działającego wg protokołu drajwera LUMBUS i wymieniającego dane z regulatorem RG72 o numerze 1 poprzez port COM2 z prędkością 4800 Bd jest następująca:

Nazwa: KANAL

Drajwer: LUMBUS

Parametry kanału: 1, COM2, 4800

Drajwer LUMBUS jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>[.podindeks]

gdzie:

typ - typ zmiennej; dopuszczalne typy to:

P - pojedynczy pomiar,

PT - tablica pomiarów,

WT - tablica dni wolnych,

DT - tablica terminów ferii.

indeks - zgodnie ze specyfikacją podaną w punkcie 3 instrukcji obsługi "Interfejsu Szeregowego RS-485 w Regulatorze RG7-07/2" dla pojedynczych pomiarów indeks przyjmuje wartość indeksu przypisaną pomiarowi w tabeli; dla wartości przekazywanych w postaci tablic indeks przyjmuje wartość indeksu przypisaną tablicy, a opcja przedmiotowej zmiennej w tablicy jest specyfikowana przez podindeks;

Podindeks - stosuje się do specyfikacji zmiennych przekazywanych w postaci tablicy i określa położenie zmiennej w tablicy; podindeks pierwszego elementu w tablicy przyjmuje wartość 0.

Surowa wartość pomiaru jest typu FLOAT.

Surowa wartość dnia wolnego i terminu ferii jest łańcuchem ASCII o formacie: dd:mm:rrrr

zakończonym zerem (łącznie 11 znaków).

Przykłady

Przykłady deklaracji zmiennych, których wartości są przekazywane pojedynczo:

X13, godzina załączenia obniżenia nocnego, P13, KANAL, 1, 1, NIC_FP

X23, temperatura zadana c.w.u, P23, KANAL, 1, 1, NIC_FP

Przykłady deklaracji zmiennych, których wartości są przekazywane w postaci tablic:

X39, temp zadana w pom. kontrolnym, PT38.0, KANAL, 1, 1, NIC_FP

X40, temp zew(A) - punkt początkowy krzywej, PT38.1, KANAL, 1, 1, NIC_FP

X50, max. dopuszczalna temp. powrotu, PT48.1, KANAL, 1, 1, NIC_FP

X56, strefa nieczułości c.o., PT52.3, KANAL, 1, 1, NIC_FP

X68, oszczędności - święta dzień 1, WT67.0, KANAL, 11, 1, NIC_TEXT

X69, oszczędności - święta dzień 2, WT67.1, KANAL, 11, 1, NIC_TEXT

X70, oszczędności - święta dzień 3, WT67.2, KANAL, 11, 1, NIC_TEXT

X119, pierwszy okres ferii - od, DT119.0, KANAL, 11, 1,NIC_TEXT

X120, pierwszy okres ferii - do, DT119.1, KANAL, 11, 1,NIC_TEXT

X121, drugi okres ferii - od, DT121.0, KANAL, 11, 1,NIC_TEXT

X122, drugi okres ferii - do, DT121.1, KANAL, 11, 1,NIC_TEXT

X123, trzeci okres ferii - od, DT123.0, KANAL, 11, 1,NIC_TEXT

X124, trzeci okres ferii - do, DT123.1, KANAL, 11, 1,NIC_TEXT

Zestawienie adresów symbolicznych

Tabela. Zestawienie adresów symbolicznych dla drajwera LUMBUS.

Tabela. Zestawienie adresów symbolicznych dla drajwera LUMBUS (c.d.).

Tabela. Zestawienie adresów symbolicznych dla drajwera LUMBUS (c.d.).

Tabela. Zestawienie adresów symbolicznych dla drajwera LUMBUS (c.d.).

Parametry drajwera

Parametry drajwera LUMBUS deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer protokołu LUMBUS może być parametryzowany przy wykorzystaniu sekcji LUMBUS.

R Nazwa sekcji: LUMBUS
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie: opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera LUMBUS oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

Przykład

Nazwa sekcji: LUMBUS

Nazwa opcji: PLIK_LOGU

Wartość opcji: D:\ASIX\LUMBUS.LOG

R Nazwa sekcji: LUMBUS
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji z regulatorem RG72. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: LUMBUS
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie: opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna: domyślnie opcja przyjmuje wartość 0 (nie ma powtórzeń).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtLZQM

Home > 1.52 LZQM - drajwer liczników energii elektrycznej typu LZQM

1.52 CtLZQM - drajwer liczników energii elektrycznej typu LZQM

Przeznaczenie drajwera

Drajwer służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej typu LZQM, produkowanymi przez Zakład Elektronicznych Urządzeń Pomiarowych POZYTON sp. z o.o. w Częstochowie. Komunikacja odbywa się przy pomocy łączy szeregowych. w standardzie CLO.

Parametryzacja drajwera LZQM realizowana jest przy użyciu programu Architekt.

Zmiany od wersji LZQM 1.3.1.1:

- Jeśli na porcie jest obsługiwany tylko jeden licznik, to cały okres czasu pomiędzy kolejnymi odczytami tabeli jest wykorzystany na odczyt wielkości chwilowych. Jeśli na porcie są obsługiwane co najmniej 2 liczniki, to drajwer działa tak, jak w poprzednich wersjach, tzn. raz na cykl czyta tabelę oraz wielkości chwilowe poszczególnych liczników.

- Okres czasu pomiędzy kolejnymi odczytami tabeli jest liczony od chwili rozpoczęcia odczytu tabeli. W poprzednich wersjach był liczony od chwili zakończenia odczytu tabeli.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer LZQM wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: LZQM

Zakładka LZQM:

Parametry kanału:

Port=liczba [; PredkoscTransmisji=liczba] [;Okres=liczba]

gdzie:

Port - numer portu szeregowego COM.

PredkoscTransmisji - prędkość transmisji między komputerem a licznikiem. Domyślna wartość wynosi 4800 Bd.

Okres - odstęp czasu (w sekundach) pomiędzy kolejnymi odczytami licznika. Domyślna wartość wynosi 10 sekund

Deklaracja zmiennych

Adres zmiennej ma następującą postać:

"numer_licznika/nazwa_rejestru"

gdzie:

numer_licznika - 8-mio cyfrowy numer licznika (odczytany z płyty czołowej licznika i ew. uzupełniony wiodącymi zerami)

nazwa_rejestru - nazwa rejestru licznika o postaci X.X.X odczytana z tablicy odczytowej licznika.

PRZYKŁAD

Przykładowe deklaracje zmiennych (nazwa kanału logicznego - PTY, numer licznika 121825:

KP_01, stan liczydła energii EP+, "00121825/0.8.0", PTY, 1, 1, nic_fp

KP_02, stan liczydła energii EP-, "00121825/1.8.0", PTY, 1, 1, nic_fp

Deklaracja zmiennych wewnętrznych

Dane zawarte w bloku ostatniego okresu obrachunkowego są zmiennymi wewnętrznymi drajwera. Są one wyliczane na bazie danych bieżących (metki czasowe okresów obrachunkowych) oraz danych okresów obrachunkowych (wartości bilansowe oraz wartości maksymalne). Adres zmiennej wewnętrznej ma następującą postać:

”numer_licznika/nazwa_rejestru.A”

gdzie:

numer_licznika - 8-mio cyfrowy numer licznika (odczytany z płyty czołowej licznika i ew. uzupełniony wiodącymi zerami)

nazwa_rejestru - nazwa rejestru licznika o postaci X.X.X odczytana z tablicy odczytowej licznika.

.A - przyrostek użyty dla wyróżnienia zmiennych wewnętrznych.

PRZYKŁAD

A_0.6.1, moc najwyższa P+ w strefie 1, "00121825//0.6.1.A", PTY, 1, 1, nic_fp

A_0.8.1, stan liczydła energii EP+ w strefie 1, "00121825//0.8.1.A", PTY, 1, 1, nic_fp

Parametry drajwera

Parametry drajwera LZQM deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTLZQM.

R Nazwa sekcji: CtLZQM

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CtLZQM

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CtLZQM

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: Pozycja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa sekcji: CtLZQM

R Nazwa opcji: ZWLOKA_TRANSMISJI

R Wartość opcji: liczba

Znaczenie: Pozycja określa odstęp pomiędzy odbiorem danych i wysłaniem kolejnego zapytania do licznika. Użycie opcji może być konieczne w przypadku odczytu w trybie rejestrowym.

Wartość opcji:

liczba - czas wyrażony w milisekundach.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na 75 ms, ale wg Pozytona może to być czasami za mało.

R Nazwa sekcji: CtLZQM

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie: Pozycja określa liczbę powtórzeń transmisji w przypadku błędów komunikacji. Dotyczy zarówno odczytu tablicy rejestrów jak i wielkości chwilowych.

Wartość opcji:

liczba - ilość powtórzeń.

Wartość domyślna: domyślnie wartość opcji wynosi 0 (bez powtórek).

PRZYKŁAD

[CTLZQM]

PLIK_LOGU=d:\tmp\test\licznik.log

ROZMIAR_PLIKU_LOGU=30

LOG_TELEGRAMOW=TAK

Parametry kanału

Parametry umieszczane w sekcji kanału (w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio).

R Nazwa sekcji: nazwa_kanału

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie: Pozycja określa liczbę powtórzeń transmisji w przypadku błędów komunikacji. Dotyczy zarówno odczytu tablicy rejestrów jak i wielkości chwilowych.

Wartość opcji: liczba - ilość powtórzeń.

Wartość domyślna: domyślnie wartość opcji wynosi 0 (bez powtórek).

Parametryzacja poszczególnych liczników

Drajwer pozwala na przekazanie zestawu indywidualnych parametrów dotyczących obsługi poszczególnych liczników w osobnych sekcjach. Nazwa takiej sekcji jest zbudowana z następujących elementów:

nazwa_kanału:numer_licznika

gdzie:

nazwa_kanału - nazwa kanału ASMENA, w którym jest obsługiwany dany licznik,

numer_licznika - 8-mio cyfrowy numer licznika (z ew. wiodącymi zerami).

Przykład 1:

Nazwa kanału ASMENA KANAL

Nazwa licznika 00121825

Nazwa sekcji KANAL:00121825

Licznik jest parametryzowany przy użyciu pozycji deklarujących:

• znacznik daty/czasu,

• log danych odczytowych.

R Nazwa sekcji: nazwa_kanału:numer_licznika

R Nazwa opcji: ZNACZNIK_CZASU

R Wartość opcji: kod_rejestru [,kod_rejestru]

Znaczenie: Pozycja ZNACZNIK_CZASU pozwala zdefiniować rejestr (lub dwa rejestry), w którym licznik przekazuje swój znacznik daty i czasu. Przyjmuje się, że jeśli jest podany jeden rejestr, to zawiera datę i czas w formacie ’DD-MM-YY hh:mm:ss’. Jeśli jest podana para rejestrów, to przyjmuje się, że pierwszy rejestr zawiera datę w formacie ’DD-MM-YY’, a drugi rejestr zawiera czas w formacie ’hh:mm:ss’.

Jeśli pozycja nie zostanie użyta, to przyjmuje się, że wartościom przesłanym z licznika zostanie przypisany znacznik daty i czasu PC z chwili zakończenia odbioru przesyłki..

Wartość domyślna: Domyślnie przyjmuje się, że wartościom przesłanym z licznika jest przypisywany znacznik daty i czasu PC.

R Nazwa sekcji: nazwa_kanału:numer_licznika

R Nazwa opcji: DANE_ODCZYTOWE

R Wartość opcji: TAK|NIE

Znaczenie: Przy użyciu pozycji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii danych odczytowych licznika należy zapisać do logu drajwera. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: Domyślnie nie zapisuje się szczegółów parsowania danych odczytowych do logu drajwera.

PRZYKŁAD

Poniżej jest przykładowa sekcja opisująca licznik w kanale PTY. Licznik ma numer 00121825.

[PTY:00121825]

ZNACZNIK_CZASU = 29., 28.

DANE_ODCZYTOWE = TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtM200 - drajwer komputera przepływu Spirax Sarco M200

Home > 1.53 CtM200 - drajwer komputera przepływu Spirax Sarco M200

1.53 M200 - drajwer komputera przepływu Spirax Sarco M200

Przeznaczenie drajwera

Drajwer M200 jest przeznaczony do wymiany danych pomiędzy systemem Asix i komputerem przepływu M210G firmy Spirax Sarco. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie RS-232.

Parametryzacja drajwera M200 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer M200 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: M200

Zakładka M200:

Parametry kanału:

Port=liczba [; PredkoscTransmisji=liczba] [;KontrolaParzystosci=liczba] [;BityZnaku=liczba] [;BityStopu=liczba] [;TypObslugi=liczba] [;SynchrCzasu=liczba]

gdzie:

Port - numer portu szeregowego komputera;

PredkoscTransmisji - prędkość transmisji w Bd; domyślnie 9600 Bd;

KontrolaParzystosci - EVEN, ODD lub NONE; domyślnie NONE;

BityZnaku - liczba bitów znaku (7 lub 8); domyślnie 8;

BityStopu - liczba bitów stopu (1 lub 2); domyślnie 1;

TypObslugi - interfejs RS-232 (tryb 1) lub RS-485 z modułami ADAM-4521 (tryb 2); domyślnym trybem jest tryb nr 1;

SynchrCzasu - czas w minutach pomiędzy kolejnymi zapisami czasu do komputera przepływu. Można wyłączyć synchronizację czasu poprzez ustawienie parametru SynchrCzasu na 0. Domyślnie synchronizacja czasu jest wykonywana co 1 minutę.

UWAGA W przypadku użycia modułów adresowalnych ADAM-4521 należy w module ADAM-4521 ustawić następujące parametry:
a/ delimiter - { (ustawiony fabrycznie);
b/ add cr - no (ustawienie fabryczne - yes);
c/ adres w sieci RS-485 (dla każdego modułu inny adres);
d/ baud rate - zgodny z prędkością ustawioną w komputerze przepływu.

Domyślnie przyjmuje się następujące parametry transmisji:

  • prędkość transmisji 9600 Bd,

  • liczba bitów w znaku - 8,

  • bez kontroli parzystości - NONE,

  • liczba bitów stopu - 1,

  • komunikacja poprzez łącze RS-232.

PRZYKŁAD

Przykład deklaracji kanału korzystającego z drajwera M200 na porcie COM2 w trybie RS232 z ustawieniami domyślnymi z synchronizacją czasu co 10 minut:

Nazwa: PLC1

Drajwer: CTM200

Parametry drajwera: Port=2; SynchrCzasu=10

Adresacja zmiennych

Składnia adresu symbolicznego jest następująca:

V.adres.id

gdzie:

adres - adres adresowalnego modułu ADAM-4251, jeśli praca w trybie RS-485. W trybie RS-232 adres nie ma znaczenia, ale musi być podany,

id - identyfikator parametru komputera przepływu. Dopuszczalne są następujące identyfikatory:

B - pressure (odczyt),

C - temperature (odczyt),

T - total (odczyt),

R - flowrate (odczyt),

M - set metric units (zapis),

P - set imperial units (zapis).

W przypadku pomiaru ciepła (heat metering unit) możliwe jest użycie

poniższych identyfikatorów:

E - net energy (odczyt),

N - net power (odczyt),

W - condensate temperature (odczyt).

Wszystkie surowe wartości zmiennych są typu FLOAT.

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_01, flowrate, V.1.R, PLC1, 1, 1, NIC_FP

JJ_02, Total, V.1.T, PLC1, 1, 1, NIC_FP

JJ_03, Pressure, V.1.B, PLC1, 1, 1, NIC_FP

JJ_04, Temperature, V.1.C, PLC1, 1, 1, NIC_FP

Znacznik czasu

Wartościom zmiennych odczytanych z komputera przepływu M210G jest nadawany stempel czasu lokalnego PC.

Parametry drajwera

Parametry drajwera M200 deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTM200.

R Nazwa sekcji: CtM200

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtM200

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CtM200

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MACMAT - drajwer protokołu GAZ-MODEM korektorów przepływu

Home > 1.54 MACMAT - drajwer protokołu GAZ-MODEM korektorów przepływu gazu MACMAT

1.54 MACMAT - drajwer protokołu GAZ-MODEM korektorów przepływu gazu MACMAT

Przeznaczenie drajwera

Drajwer MACMAT służy do komunikacji ze stacją MACMAT. Drajwer współpracuje ze stacjami oznaczonymi jako Korektor Impulsowy 01723 CMK 01 97/01/02 produkowanymi przez COMMON sp. z o.o. oraz ze stacjami oznaczonymi jako PKNMiJ 03-03-93 RP T-Zw5-1 produkowanymi przez firmę PLUM.

Parametryzacja drajwera MACMAT realizowana jest przy użyciu programu Architekt.

Deklaracja kanału logicznego

Deklaracja kanału transmisyjnego wykorzystującego drajwer MACMAT wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MACMAT

Zakładka MACMAT:

Parametry kanału:

adres,COMn

gdzie:

n - numer portu szeregowego, do którego podłączona jest sieć stacji MacMAT,

adres - adres stacji.

Parametry drajwera

Każdy zdefiniowany kanał może mieć swoją sekcję, której nazwa jest jego nazwą logiczną. Także port COMn może mieć swoja sekcję o nazwie MACMAT:n. Wartości zdefiniowane w takiej sekcji stają się wartościami domyślnymi dla wszystkich stacji podłączonych do danego portu. Jeżeli w pliku konfiguracyjnym zadeklarowano sekcję o nazwie MACMAT, to wartości umieszczone w takiej sekcji stają się wartościami domyślnymi dla wszystkich stacji obsługiwanych przez sterownik. Wartości umieszczone w sekcji danej stacji (nazwa_logiczna) mają pierwszeństwo przed wartościami umieszczonymi w sekcji danego portu szeregowego, a te ostatnie mają pierwszeństwo przed wartościami umieszczonymi w sekcji 'MACMAT'. Jeżeli parametr nie występuje w żadnej sekcji, to przyjmowana jest jego wartość domyślna, zgodnie z poniższym opisem. W szczególności, plik konfiguracyjny może nie zawierać żadnych sekcji parametryzujących stacje. Wymagana jest jedynie deklaracja kanałów.

Parametry transmisji po łączu szeregowym nie mogą znajdować się w sekcjach opisanych nazwą logiczną stacji.

Parametry drajwera MACMAT deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

R Nazwa sekcji: MACMAT
R Nazwa opcji: Auto_sync
R Wartość opcji: liczba

Znaczenie: jeżeli parametr jest różny od 0, to zostanie uruchomiona automatyczna synchronizacja zegara komputera z zegarem stacji MACMAT. Wartość parametru określa minimalny czas pomiędzy kolejnymi porównaniami zegarów stacji i komputera. Porównanie zegarów następuje tylko w czasie odczytu innych danych ze stacji.

Wartość opcji:

liczba - wartość czasu w sekundach.

Wartość domyślna: 3600 (1 godz.).

R Nazwa sekcji: NACMAT
R Nazwa opcji: Alt_port
R Wartość opcji: COMm, sposób_przełączania_na_alternatywny, sposób_przełączania_na_podstawowy

Znaczenie: Patrz: Definiowanie portów alternatywnych, poniżej.

R Nazwa sekcji: MACMAT
R Nazwa opcji: AsComm
R Wartość opcji: Tak/Nie

Znaczenie: jeśli podano tak to drajwer będzie wykorzystywał Menadżer Połączeń AsComm do nawiązywania połączeń ze stacjami MACMAT.

Wartośc domyślna: Nie

R Nazwa sekcji: MACMAT
R Nazwa opcji: Bez_Błędów
R Wartość opcji: Tak/Nie

Znaczenie: jeśli podano tak, to drajwer nie będzie wyprowadzał komunikatów o błędach linii oraz timeout. Opcja może być używana zamiennie z opcją Bez_Bledow.

Wartośc domyślna: Nie

R Nazwa sekcji: MACMAT
R Nazwa opcji: Maks_Ilość_Buf_Hist
R Wartość opcji: liczba

Znaczenie: określa maksymalną ilość buforów zawierających dane historyczne odczytane na potrzeby modułu archiwizującego. Jeden bufor zawiera dane historyczne z jednego przedziału czasowego dla jednej zmiennej. Jest on utrzymywany w pamięci przez określony parametrem Czas_Buf_Hist. Jeden bufor zajmuje około 400 bajtów pamięci i może zawierać 50 wartości. Jeżeli dane archiwalne są zapamiętywane przez stacje co 15 min. to na jedna dobę potrzebne są 2 bufory dla jednej zmiennej. Bufory historyczne są wykorzystywane przez program archiwizacji danych ASPAD w czasie uzupełniania archiwum typu B. Po upływie czasu określonego parametrem Usuwanie_Buforow_Historycznych bufory są usuwane z pamięci. Opcja może być używana zamiennie z opcjami: Maks_Ilosc_Buf_Hist,

Maksymalna_Ilość_Buforów_Historycznych, Maksymalna_Ilosc_Buforow_Historycznych.

Wartośc domyślna: 5000

R Nazwa sekcji: MACMAT
R Nazwa opcji: Maksymalna_historia
R Wartość opcji: liczba

Znaczenie: określa okres czasu liczony od bieżącej chwili wstecz, dla którego będą odczytywane dane historyczne znajdujące się w pamięci stacji.

Wartość opcji:

liczba - wartość czasu wyrażona w dniach.

Wartość domyślna: 35

R Nazwa sekcji: MACMAT
R Nazwa opcji: Maks_Różnica_Czasu
R Wartość opcji: liczba

Znaczenie: maksymalna różnica czasu pomiędzy wskazaniami zegara stacji i zegara komputera po przekroczeniu której następuje synchronizacja zegarów. Parametr ma znaczenie tylko wtedy, gdy parametr Auto_sync jest różny od zera. Opcja może być używana zamiennie z opcją Maks_Roznica_Czasu.

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: 60

R Nazwa sekcji: MACMAT
R Nazwa opcji: Maska_Statusu
R Wartość opcji: liczba

Znaczenie: liczba określająca, które wartości statusu zmiennej powodują nieważność wartości zmiennej. Status zmiennej jest odczytywana ze stacji MacMAT razem z jej wartością. Status ten jest maską bitową - znaczenie poszczególnych bitów opisane jest w dokumentacji stacji. Drajwer wykonuje operację logiczną AND na statusie zmiennej, otrzymanym ze sterownika oraz na wartości parametru Maska_Statusu. Jeśli rezultat tej operacji jest różny od zera, to wartość danej jest nieważna. Wartość danej jest również nieważna, jeśli status danej ma wartość 0 (tzn. brak danej).

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach.

Wartośc domyślna: 6. Wartość domyślna 6 oznacza, że unieważniane są wartości przekraczające zakres pomiarowy. Jako wartość parametru należy podać liczbę całkowitą, której poszczególne bity odpowiadają odpowiednim bitom statusu.

R Nazwa sekcji: MACMAT
R Nazwa opcji: Mnoznik_Licznika
R Wartość opcji: liczba

Znaczenie: licznik przepływu gazu jest przesyłany w postaci dwóch liczb zmiennoprzcinkowych Vn0 i Vn1. Dokumentacja protokołu stanowi, że wartość licznika jest obliczana za pomocą wzoru:

Vn0 + Vn1*10000.

Niektóre stacje używają jednak formuły:

Vn0 + Vn1*100000.

Parametr definiuje wartość przez jaką należy pomnożyć wielkość Vn1:

Vn0 + Vn1*Mnożnik_Licznika.

Opcja może być używana zamiennie z pozycją: Mnożnik_Licznika.

Wartość domyślna: 10000.

R Nazwa sekcji: MACMAT
R Nazwa opcji: Mnoznik_P.
R Wartość opcji: liczba

Znaczenie: według dokumentacji stacji MacMAT ciśnienie rejestrowane jest w kPa. Niektóre stacje przesyłają jednak ciśnienie wyrażone w MPa. Dotyczy to tylko danych archiwalnych (rejestrowych). Parametr określa przez jaką liczbę należy pomnożyć ciśnienie przesyłane przez stacje. Opcja może być używana zamiennie z pozycją: Mnożnik_P.

Wartość domyślna: 10000.

R Nazwa sekcji: MACMAT
R Nazwa opcji: szybkość
R Wartość opcji: liczba

Znaczenie: szybkość transmisji. Opcja może być używana zamiennie z opcjami: szybkosc, bps.

Wartośc opcji:

liczba - wartość wyrażana w jednostkach Bd.

Wartość domyślna: 9600 (baud)

R Nazwa sekcji: MACMAT
R Nazwa opcji: parzystość
R Wartość opcji: parametr_parzystości

Znaczenie: opcja określająca typ parzystości. Opcja może być używana zamiennie z pozycją: parzystosc.

Wartość domyślna: n

Parametr:

parametr_parzystości - typ parzystości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

s - space.

R Nazwa sekcji: MACMAT
R Nazwa opcji: powtorzenia
R Wartość opcji: liczba

Znaczenie: ilość powtórzeń transmisji w przypadku błędów transmisji. Opcja może być używana zamiennie z opcjami: ilosc_powtorzen, ilość_powtórzeń.

Wartość domyślna: 5

R Nazwa sekcji: MACMAT
R Nazwa opcji: słowo
R Wartość opcji: liczba

Znaczenie: pozwala zadeklarować długość słowa. Opcja może być używana zamiennie z opcjami: slowo, długość_słowa, długość_slowa.

Wartość opcji:

liczba - długość słowa od 5 do 8 bitów.

Wartość domyślna: 8

R Nazwa sekcji: MACMAT
R Nazwa opcji: timeout
R Wartość opcji: liczba

Znaczenie: czas oczekiwania na odpowiedź stacji. Opcja może być używana zamiennie z opcjami: time-out, time_out.

Wartość opcji:

liczba - wartość czasu wyrażona w sekundach.

Wartość domyślna: 2

R Nazwa sekcji: MACMAT
R Nazwa opcji: Usuwanie_Buforów_Historycznych
R Wartość opcji: liczba

Znaczenie: parametr określa czas po jakim usuwane są bufory zawierające dane historyczne odczytane na potrzeby modułu archiwizującego. Opcja może być używana zamiennie z opcjami:

Usuwanie_Buforow_Historycznych, Czas_Buf_Hist.

Wartość opcji:

liczba - wartość czasu wyrażona w minutach.

Wartość domyślna: 30

R Nazwa sekcji: MACMAT
R Nazwa opcji: Wszystkie_Blędy
R Wartość opcji: tak/nie

Znaczenie: jeśli parametr ma wartość ustawioną na nie, to informacja o błędach timeout będzie pojawiać się w panelu kontrolnym tylko wtedy, gdy transmisja nie udała się pomimo prób jej powtarzania. Jeśli ma wartość tak, to informacja o wszystkich błędach przekazywana jest do panelu kontrolnego.

Wartość domyślna: nie

R Nazwa sekcji: MACMAT
R Nazwa opcji: RTS
R Wartość opcji: tak/nie

Znaczenie: jeśli podano tak, to wysyłanie danych do stacji będzie odbywać się przy linii RTS ustawionej w stan wysoki, a odbiór przy stanie niskim.

Wartość domyślna: nie

R Nazwa sekcji: MACMAT
R Nazwa opcji: Zwłoka_RTS
R Wartość opcji: tak/nie

Znaczenie: czas po jakim linia RTS zostanie wyzerowana po wysłaniu żądania danych do stacji. Parametr ma znaczenie tylko wtedy, gdy włączono sterowanie linią RTS.

Wartość opcji:

liczba - czas podany w milisekundach.

Wartość domyślna: 10

R Nazwa sekcji: MACMAT
R Nazwa opcji: Ignoruj_Adres
R Wartość opcji: tak/nie

Znaczenie: każdy pakiet wysyłany przez stację zawiera adres stacji. Adres stacji podlega weryfikacji przez sterownik. W przypadku niezgodności z numerem stacji jest on odrzucany. Podanie wartości tak spowoduje zaniechanie przez sterownik weryfikacji adresu nadawcy.

Wartość domyślna: nie

PRZYKŁADY

Przykład 1

Deklaracja kanału:

Nazwa: MAC

Drajwer: MACMAT

Parametry kanału: 2,COM2

Parametry drajwera:

Nazwa sekcji: MAC

Nazwa opcji: Auto_Sync

Wartość opcji: 60

Nazwa sekcji: MAC

Nazwa opcji: Maks_Różnica_Czasu

Wartość opcji: 10

W powyższym przykładzie zdefiniowano stacje o nazwie MAC podłączoną do portu COM2. Synchronizacja zegarów stacji i komputera będzie dokonywana co 1 minutę. Jeśli różnica wyniesie co najmniej 10 sekund to nastąpi synchronizacja zegarów.

Przyklad 2

Deklaracje kanałów:

Nazwa: MAC1

Drajwer: MACMAT

Parametry kanału: 1,COM2

Nazwa: MAC2

Drajwer: MACMAT

Parametry kanału: 2,COM2

Nazwa: MAC3

Drajwer: MACMAT

Parametry kanału: 3,COM2

Nazwa: MAC4

Drajwer: MACMAT

Parametry kanału: 4,COM3

Nazwa: MAC5

Drajwer: MACMAT

Parametry kanału: 5,COM3

Nazwa: MAC6

Drajwer: MACMAT

Parametry kanału: 6,COM4

Parametry drajwera:

Wartości domyślne dla wszystkich stacji

Nazwa sekcji: MACMAT

Nazwa opcji: szybkość

Wartość opcji: 19200

Wartości domyślne dla stacji podłączonych do portu COM3

Nazwa sekcji: MACMAT:3

Nazwa opcji: szybkość

Wartość opcji: 9600

Pozostałe parametry:

Nazwa sekcji: MAC6

Nazwa opcji: Auto_Sync

Wartość opcji: 0

W powyższym przykładzie zdefiniowano stacje o nazwach od MAC1 do MAC6. Do portu COM2 podłączone są stacje MAC1,MAC2 i MAC3. Do portu COM3 podłączone są stacje MAC4 i MAC5. Stacja MAC6 podłączona jest do portu COM4. Wszystkie porty szeregowe z wyjątkiem COM3 będą pracować z szybkością 19200 baud. Port COM3 będzie pracował z szybkością 9600 baud. Zegar stacji MAC6 nie będzie synchronizowany.

Definiowanie zmiennych

Bieżące dane pomiarowe

Zmienne pozwalające na dostęp do bieżących danych pomiarowych mają postać:

Bn - gdzie n jest numerem danej zgodnie z dokumentacją stacji:

B1 - wartość licznika przepływu gazu

B2 - Qn

B3 - Qr

..... itd.

Wartością zmiennej Bn jest liczba zmiennoprzecinkowa.

Zmienna B0 nie jest używana.

Dostęp do wartości rejestrowanych

Dla pomiarów bieżących oznaczonych według dokumentacji numerami 0/1 i od 2 do 8, możliwy jest dostęp do ich wartości zapamiętywanych przez stację jako dane rejestrowane lub dobowe (dla licznika przepływu). Wartością bieżącą zmiennej rejestrowanej jest wartość zapamiętana przez stację w ostatnim okresie rejestracji. Dostęp do starszych pomiarów jest możliwy poprzez archiwizację typu B. Zmienne rejestrowane mają postać:

R0 - licznik przepływu gazu (na koniec ostatniej doby)

R2 - Qn

R3 - Qr

. .

R8 - rez2

Dostęp do listy alarmów przy wykorzystaniu numeru kolejnego alarmu na liście

Zmienne pozwalające na dostęp do listy alarmów mają postać:

An.typ

gdzie:

n - numer alarmu,

typ - typ informacji o alarmie według poniższej tabeli.

Tabela. Drajwer MACMAT - typ informacji o alarmie.

Dostęp do listy alarmów za pomocą kodu alarmów

Zmienne pozwalające na dostęp do listy alarmów za pomocą kodu alarmu mają postać:

En lub En.typ

gdzie:

n - kod alarmu według dokumentacji,

typ - typ informacji o alarmie według uprzednio prezentowanej tabeli.

Zmienna E pozwala na dostęp do informacji o alarmie o podanym kodzie. Jeśli lista alarmów nie zawiera kodu żądanego alarmu, to zwracana jest wartość 0 (całkowitoliczbowa -1 bajt). Jeśli lista zawiera wiele alarmów o podanym kodzie, to zwracana jest informacja o alarmie który wystąpił najpóźniej. Jeżeli typ zmiennej został pominięty, to zwracana jest wartość 1 - w przypadku gdy alarm o podanym kodzie jest aktywny, a 0 w przeciwnym wypadku. Jeżeli podano typ zmiennej, to zwracana jest wartość według uprzednio prezentowanej tabeli.

Dostęp do listy alarmów jako maski bitowej

Zmienna ma postać:

EBn - gdzie n to numer bajtu 0-31.

Za pomocą zmiennej EB można odczytać informacje o aktywnych alarmach w grupach po osiem alarmów:

EB0 - alarmy o kodach 0- 7,

EB1 - alarmy o kodach 8-15,

EB2 - alarmy o kodach 16-23,

...

EB31 - alarmy o kodach 248-255.

Wartością zmiennej jest liczba całkowita o długości 1 bajta. Poszczególne bity wartości zmiennej przypisane są odpowiednim alarmom. Jeśli bit jest ustawiony, to odpowiadający mu alarm jest aktywny. Zmienna typu EB pozwala powiązać alarmy ze strategią bitową rozpoznawania alarmów systemu Asix.

Dostęp do danych dobowych

Zmienne pozwalające na dostęp do danych dobowych mają postać:

Dn - gdzie n jest numerem danej zgodnie z dokumentacją stacji.

Zmienna D0 ma takie samo znaczenie jak zmienna R0.

Dostęp do danych statystycznych

Drajwer udostępnia informacje statystyczne dotyczące ilości przetransmitowanych danych, ilość błędów transmisji itp. Zmienne pozwalające na dostęp do danych statystycznych mają postać opisaną w poniższej tabeli.

Tabela. Drajwer MACMAT - zmienne zezwalające na dostęp do danych statystycznych.

Dostęp do danych historycznych (dla wersji z dostępem do danych historycznych)

Sterownik MACMAT umożliwia modułowi archiwizującemu ASPAD dostęp do danych historycznych dla zmiennych od B1 do B8 oraz R0 i od R2 do R8 a także dla wszystkich zmiennych D i X:

- dla zmiennej R0 i B1 odczytywane są dane dobowe;

- dla zmiennych B2 i B3 odczytywane są dane rejestrowe przyrostu przepływu; dane te są skalowane tak, aby wyrażały przepływ na 1 godzinę; dane są skalowane w oparciu o odczytaną za stacji częstość rejestracji;

- dla zmiennej B4 do B8 oraz R2 do R8 odczytywane są odpowiednie historyczne dane rejestrowe.

Współpraca z Menedżerem połączeń AsComm

Aby wykorzystać Menadżer Połączeń AsComm do nawiązywania połączeń ze stacjami MACMAT, należy w pliku konfiguracyjnym aplikacji zadeklarować przy użyciu programu Architekt następujący parametr:

Nazwa sekcji: MACMAT lub MACMAT:n - gdzie n oznacza numer zadeklarowanego portu szeregowego

Nazwa opcji: AsComm

Wartość opcji: Tak

Parametr należy zdefiniować w:

moduł Pozostałe > zakładka Opcje wprowadzane bezpośrednio

W przypadku współpracy z modułem AsComm, numer portu z deklaracji kanału jest wykorzystywany do utworzenia nazwy, jakiej będzie używał drajwer do wymiany danych z modułem AsComm. Nazwa ta ma postać MacMAT-n, gdzie n to numer portu szeregowego z deklaracji kanału.

PRZYKŁAD

Deklaracja kanału:

Nazwa: MAC

Drajwer: MACMAT

Parametry kanału: 2,COM2

Parametry drajwera:

Nazwa sekcji: MACMAT

Nazwa opcji: AsComm

Wartość opcji: Tak

W powyższym przykładzie, drajwer będzie występował pod nazwą MacMAT-2 jako klient modułu AsComm. Nazwa ta jest również nazwą sekcji, w której umieszcza się parametry połączeń nawiązywanych przez moduł AsComm takie jak: nazwa modemu, numer telefoniczny itp. Opis parametrów jakie można umieścić w takiej sekcji znajduje się w dokumentacji modułu AsComm. Należy zwrócić uwagę, że numer portu szeregowego z deklaracji kanału może, ale nie musi odnosić się do fizycznego portu szeregowego. Numer ten oznacza rzeczywisty port szeregowy tylko wtedy, gdy w sekcji parametryzującej nawiązywanie połączeń przez moduł AsComm (o nazwie 'MacMAT-n'), nie podano innych zapisów określających rzeczywiście wykorzystywany port (np. nazwa modemu).

Poniżej podano przykład parametryzacji modułu AsComm dla połączeń komutowanych:

Deklaracja kanału:

...

Nazwa: MAC

Drajwer: MACMAT

Parametry kanału: 2,COM2

...

Parametry drajwera:

...

Nazwa sekcji: MACMAT

Nazwa opcji: AsComm

Wartość opcji: Tak

...

Nazwa sekcji: MACMAT-2

Nazwa opcji: linia_komutowana

Wartość opcji: Tak

Nazwa sekcji: MACMAT-2

Nazwa opcji: Modem

Wartość opcji: Sportster Flash

Nazwa sekcji: MACMAT-2

Nazwa opcji: Interwal

Wartość opcji: 5m

Nazwa sekcji: MACMAT-2

Nazwa opcji: Max_Czas_Polaczenia

Wartość opcji: 2m

Nazwa sekcji: MACMAT-2

Nazwa opcji: Numer

Wartość opcji: 12345678

Do nawiązywania połączeń zostanie wykorzystany modem Sportster Flash. Połączenia będą nawiązywane co 5 minut z numerem 12345678. Maksymalny czas trwania połączenia to dwie minuty.

Definiowanie portów alternatywnych

Drajwer MacMAT pozwala wykorzystać alternatywny port szeregowy w przypadku problemów komunikacyjnych występujących w czasie wykorzystywania portu podstawowego, tj. tego który występuje w definicji kanału logicznego. Parametr deklarujący port alternatywny może wystąpić w sekcji 'MacMAT' lub 'MacMAT:n' i ma postać:

Alt_port = COMm, sposób_przełączania_na_alternatywny, sposób_przełączania_na_podstawowy

A zatem sposób zadeklarowania parametru za pomocą programu Architekt jest następujący:

Nazwa sekcji: MACMAT lub MACMAT:n - gdzie n oznacza numer zadeklarowanego portu szeregowego

Nazwa opcji: Alt_port

Wartość opcji: COMm, sposób_przełączania_na_alternatywny, sposób_przełączania_na_podstawowy

Parametr należy zdefiniować w:

moduł Pozostałe > zakładka Opcje wprowadzane bezpośrednio

Parametr definiuje port szeregowy COMm, który zostanie wykorzystany w przypadku problemów komunikacyjnych na porcie COMn (określonym w definicji kanału logicznego). Parametr może wystąpić tylko jeden raz (tylko jeden port alternatywny jest dozwolony). Port alternatywny COMm nie może pojawić się jako port podstawowy w definicji innego kanału Asmena.

Przełączenie na port alternatywny następuje po spełnieniu warunku sposób_przełączania_na_alternatywny. Warunek ten ma postać:

Ilość_błędów[/okres_czasu]

Przełączenie na kanał alternatywny następuje wtedy, gdy w odcinku czasu okres_czasu wystąpiła ilość nieudanych prób odczytu określona przez Ilość_błędów. Ilość błędów obejmuje również ilość powtórzeń operacji transmisji wykonywanych przez drajwer. Oznacza to, że jeśli warunkiem przełączenia są 3 błędy, a ilość powtórzeń 5, to przełączenie może nastąpić w trakcie realizacji bieżącego zlecenia i zlecenie to ma szansę zakończyć się poprawnie z wykorzystaniem kanału alternatywnego. W przeciwnym wypadku zlecenie zostanie zakończone z błędnym statusem, a przełączenie na kanał alternatywny nastąpi w czasie realizacji kolejnych zleceń Asmena. Parametr okres_czasu może zostać pominięty, w takim przypadku przełączenie nastąpi po wystąpieniu kolejno Ilość_błędów błędów. Okres_czasu wyrażony jest w sekundach.

Powrót do wykorzystywania kanału podstawowego następuje po upływie ilości sekund określonej parametrem sposób_przełączania_na_podstawowy od chwili przełączenia na kanał alternatywny. Nie oznacza to, że przez cały ten czas będzie utrzymywane połączenie modemowe (o ile takim połączeniem jest kanał alternatywny). Połączenie to będzie obsługiwane podobnie jak dotychczas, tj. zostanie rozwiązane w wyniku parametryzacji modułu AsComm lub po realizacji wszystkich zleceń Asmena. Jeśli parametry łącza szeregowego mają być inne niż te stosowane w przypadku portu podstawowego, to należy je zdefiniować w sekcji 'MacMAT:m’.

PRZYKŁAD

Przykład parametryzacji kanału alternatywnego:

Deklaracja kanału:

...

Nazwa: MAC1

Drajwer: MACMAT

Parametry kanału: 220,COM1

...

Parametry drajwera:

Nazwa sekcji: MACMAT

Nazwa opcji: Baud

Wartość opcji: 9600

Przejście na kanał alternatywny po wystąpieniu kolejno 3 błędów i powrót do portu podstawowego po 2 minutach

Nazwa sekcji: MACMAT

Nazwa opcji: Alt_Port

Wartość opcji: COM2, 3, 120

lub przejście na alternatywny po wystąpieniu 15 błędów w ciągu minuty. Powrót jw.

Nazwa sekcji: MACMAT

Nazwa opcji: Alt_Port

Wartość opcji: COM2, 15/60, 120

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtMax1000

Home > 1.55 Max1000 - drajwer protokołu systemu MAX-1000 firmy ULTRAK

1.55 CtMax1000 - drajwer protokołu systemu MAX-1000 firmy ULTRAK

Przeznaczenie drajwera

Drajwer służy do wymiany danych pomiędzy systemem Asix i systemem zarządzającym MAX-1000 firmy ULTRAK zarządzającym pracą kamer, w oparciu o tzw. 'protokół sieciowy’. Drajwer realizuje wyłącznie funkcje przełączania kamer oraz synchronizacji czasu (drajwer jest źródłem czasu). Komunikacja odbywa się przy życiu łącza szeregowego RS-232.

Parametryzacja drajwera CtMax1000 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Max1000 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtMax1000

Zakładka CtMax1000:

Parametry kanału:

Port=nrPortu; Wezel=nrWezla [; Predkosc=baud]

[;WezelSynchr=nrWezlaSynchr [; SynchrUTC=TAK|NIE] ]

gdzie:

Port - numer portu szeregowego COM, poprzez który Asix komunikuje się z siecią MAX-1000,

Wezel - numer węzła nadawczego sieci MAX-1000 przypisany systemowi Asix. Ten numer będzie użyty jako parametr {TX}

w telegramach wysyłanych do systemu MAX 1000 (parametr {RX} będzie pobrany z adresu symbolicznego zmiennej),

Predkosc - parametr opcjonalny. Służy do określenia prędkości transmisji łącza szeregowego. Dopuszczalne parametry to 9600 i 19200. Domyślnie przyjmuje się 19200 Bd,

WezelSynchr - parametr opcjonalny służący do deklaracji synchronizacji czasu z MAX-1000.. Zawiera numer węzła sieci MAX-1000, do którego co minutę będzie wysyłana aktualna data i czas systemu Asix. Domyślnie drajwer nie synchronizuje czasu,

SynchrUTC - parametr opcjonalny służący do określenia typu czasu (UTC lub lokalny) wysyłanego do MAX-1000 w ramach synchronizacji czasu. Domyślnie w ramach synchronizacji czasu drajwer wysyła czas lokalny.

Transmisja jest realizowana przy stałych ustawieniach:

7 bitów znaku, kontroli parzystości parzysta (EVEN), 1 bit stopu.

PRZYKŁAD

Przykład deklaracji kanału, w którym systemowi Asix został przypisany węzeł numer 5 sieci systemu MAX-1000:

Nazwa: KANAL

Drajwer: CtMax1000

Parametry drajwera: Port=1; Wezel=5

Adresacja zmiennych

Drajwer dostarcza tylko jeden typ zmiennych:

K - kamera

Adres zmiennej ma następującą postać:

K.<nrKamery>.<nrWęzła>

gdzie:

nrKamery - globalny numer kamery,

nrWęzła - numer węzła, w którym jest zainstalowana kamera. Parametr będzie użyty jako parametr {RX} polecenia przełączenia kamery.

Wszystkie zmienne są typu WORD.

Zmienne służą wyłącznie do wysyłania sterowań związanych z przełączaniem kamer, dlatego przy odczycie zmiennych zwracana jest wartość 0 oraz status OPC_QUALITY_BAD.

Przy sterowaniach (przełączaniu kamery) jako wartość sterującą należy podać numer monitora, na który ma zostać przełączony obraz kamery przypisanej do danej zmiennej.

PRZYKŁAD

Przykładowe deklaracje zmiennych:

JJ_11, kamera 1 węzeł 1, K.1.1, KANAL, 1, 1, NIC

JJ_12, kamera 2 węzeł 1, K.2.1, KANAL, 1, 1, NIC

JJ_13, kamera 3 węzeł 1, K.3.1, KANAL, 1, 1, NIC

JJ_14, kamera 1 węzeł 2, K.1.2, KANAL, 1, 1, NIC

JJ_15, kamera 2 węzeł 2, K.2.2, KANAL, 1, 1, NIC

JJ_16, kamera 3 węzeł 2, K.3.2, KANAL, 1, 1, NIC

JJ_17, kamera 1 węzeł 3, K.1.3, KANAL, 1, 1, NIC

Parametry drajwera

Parametry drajwera Max1000 deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CtMax1000.

R Nazwa sekcji: CtMax1000

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CtMax1000

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CtMax1000

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: Pozycja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów wysyłanych przez drajwer do systemu MAX-1000. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

[CTMAX1000]

PLIK_LOGU=d:\tmp\test\max1000.log

ROZMIAR_PLIKU_LOGU=30

LOG_TELEGRAMOW=TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


M-BUS - Drajwer protokołu M-BUS

Home > 1.56 M-BUS - Drajwer protokołu M-BUS

1.56 Drajwer protokołu M-BUS

Przeznaczenie drajwera

Standard M-Bus powstał jako standard do komunikacji z licznikami ciepła i w tej branży jest najbardziej rozpowszechniony. Niniejszy protokół został przetestowany i uruchomiony w połączeniu z miernikami ciepła MULTICAL firmy KAMSTRUP A/S.

Parametryzacja drajwera M-BUS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer M-Bus wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: M-Bus

Definiowanie zmiennych

Zestaw zmiennych realizowanych przez drajwer można podzielić na kilka grup:

  • zmienne pozycyjne, czyli zmienne których adres jest numerem kolejnym danej przesyłanej przez urządzenie MBUS,

  • zmienne, których adres zawiera nazwę mierzonej wielkości,

  • zmienne pozwalające na odczyt danych producenta,

  • inne zmienne.

Zmienne pozycyjne

Definicja zmiennych pozycyjnych wymaga znajomości kolejności, w jakiej urządzenie M-BUS wysyła dane pomiarowe.

Adres zmiennych pozycyjnych ma postać:

Pn

gdzie n jest numerem kolejnym danej. Pierwsza dana ma numer 0.

Adresacja za pomocą nazwy wielkości

Adres zmiennej ma postać:

Nazwa[.Un][.Tn][.Sn]

gdzie:

Nazwa nazwa wielkości pomiarowej;

Un n - numer jednostki (jeśli pominięty, to przyjmuje się 0); numer jednostki stosuje się wtedy, gdy urządzenie składa się z kilku jednostek;

Tn n - numer taryfy (jeśli pominięty, to przyjmuje się 0);

Sn n - numer komórki do przechowywania danych historycznych (storage) (jeśli pominięty, to przyjmuje się 0).

Można używać nazw ujętych w poniższej tabeli.

Tabela. Drajwer MBUS - zestaw akceptowalnych nazw zmiennych pomiarowych.

Adresacja danych producenta

Dane producenta to dane, które nie są opisane w definicji protokołu. Do ich odczytu wymagana jest znajomość struktury danych producenta konkretnego urządzenia.

Adres danej producenta ma postać:

Mpozycja.długość

gdzie:

pozycja - numer bajtu w bloku danych producenta, od którego zaczyna się dana wartość; pierwszy bajt ma numer 0;

długość - długość danej w bajtach.

Drajwer zakłada, że dane producenta są wyrażone w kodzie BCD. Jeśli zamiast 'M’ podamy 'X’, to nie będzie wykonywana konwersja z kodu BCD.

Inne dane

Dane przesyłane przez urządzenie M-BUS mogą być opatrzone nagłówkiem.

Zmienne pozwalające na dostęp do danych w nagłówku.

Tabela. Zestaw zmiennych umożliwiających dostęp do danych w nagłówku.

Nie wszystkie urządzenia udostępniają dane H.MANUFACTURER i H.VERSION.

Dostęp do symbolu jednostki pomiarowej

Dla zmiennych pozycyjnych oraz adresowanych za pomocą nazwy wielkości można zdefiniować zmienne zwracające symbol fizycznej jednostki pomiarowej (np. Wh dla energii). W tym celu do adresu zmiennej należy dodać "/UNIT" np. ENERGY/UNIT. Jako funkcję przeliczającą należy podać NIC_TEXT. W celu wyświetlenia jednostki na masce technologicznej można skorzystać z obiektu NAPIS.

Status danych

Urządzenia realizujące protokół M-BUS udostępniają daną o długości 1 bajta, której poszczególne bity określają status urządzenia w sposób określony w tabeli poniżej.

Tabela. Statusy danych dla urządzeń M-BUS.

Statusy o numerze kolejnym od 1 do 5 powodują, że wszystkie dane wysłane przez urządzenie zostają przez drajwer unieważnione tj. otrzymują status dana błędna. Nie dotyczy to danych zawartych w nagłówku opisanym w podpunkcie Inne dane, patrz: powyżej. To domyślne działanie drajwera można zmienić za pomocą parametru statusy_nieważności opisanym w części Parametryzacja drajwera (patrz: poniżej). Daną zawierającą status urządzenia można odczytać poprzez zmienną H.STATUS opisaną w podpunkcie Inne dane, patrz: powyżej. Trzecia kolumna powyższej tabeli określa numer bitu w zmiennej, który dotyczy określonego statusu.

Nie wszystkie urządzenia udostępniają status 1 i 2. Znaczenie statusów 6, 7 i 8 jest określone przez producenta urządzenia.

P arametry kanału

Parametry kanału drajwera M-BUS deklarowane są na zakładkach M-Bus/Parametry kanału....

Zakładka Parametry kanału - transmisja:

Port i parametry transmisji

R Numer portu

Znaczenie - określa port szeregowy wykorzystywany do komunikacji; parametr port jest parametrem obowiązkowym. Jeśli pominięto parametry transmisji, to przyjmowane są wartości domyślne. Numer portu musi być zawsze podany.

Wartość domyślna - COM1.

Parametry:

Szybkość transmisji

Wartość domyślna - 9600.

Długość słowa

Wartość domyślna - 8.

Parzystość - (brak, parzystość, nieparzystość)

Wartość domyślna - parzystość.

Liczba bitów stopu - (1,2)

Wartość domyślna - 1.

R Adres urządzenia M-BUS

Znaczenie - pozwala określić adres urządzenia M-BUS. Parametr jest parametrem obowiązkowym.

Wartość opcji:

liczba - parametr jest liczbą z zakresu od 1 do 250.

Wartość domyślna - brak.

R Adres urządzenia M-BUS

Znaczenie - pozwala określić adres urządzenia M-BUS. Parametr jest parametrem obowiązkowym.

Wartość opcji:

liczba - parametr jest liczbą z zakresu od 1 do 250.

Wartość domyślna - brak.

***

Zakładka Parametry kanału - zaawansowane:

R Okres odczytu

Znaczenie - parametr określa interwał, z jakim drajwer odczytuje dane z urządzenia M-BUS.

Wartość opcji:

liczba - wartość wyrażona w sekundach.

Wartość domyślna - 15.

R Opóźnienie odczytu

Znaczenie - parametr określa minimalny czas pomiędzy kolejnymi odczytami danych z urządzenia M-BUS. Niektóre urządzenia (np. MULTICAL) wymagają znacznego czasu na przygotowanie danych. Parametr określa czas przygotowania danych przez urządzenie M-BUS.

Wartość opcji:

liczba - wartość wyrażona w sekundach.

Wartość domyślna - 12.

R Podwójny odczyt

Znaczenie - niektóre urządzenia (np. MULTICAL) zwracają dane przygotowane po poprzednim odczycie. Jeśli parametr ma wartość Tak, to drajwer będzie wykonywał dwa kolejne odczyty tak, aby otrzymać najbardziej aktualne dane.

Wartość domyślna - TAK.

R Timeout odpowiedzi

Znaczenie - parametr określa maksymalny czas oczekiwania na odpowiedź.

Wartość opcji:

liczba - czas wyrażony w milisekundach.

Wartość domyślna - 0.

R Timeout znaku

Znaczenie - parametr określa maksymalny czas oczekiwania na odbiór jednego znaku.

Wartość opcji:

liczba - czas wyrażony w milisekundach.

Wartość domyślna - 0.

***

Zakładka Parametry kanału - zaawansowane 2:

R Statusy nieważności

Znaczenie - wraz z danymi pomiarowymi, urządzenie M-BUS przesyła bajt statusowy. Każdy z bitów tego bajtu określa określony stan danych. Parametr określa, które bity statusu powodują nieważność otrzymanych danych.

Wartość opcji:

liczba,liczba,... - parametr ma postać zestawu numerów bitów oddzielonych znakiem +. Najmłodszy bit ma numer 1. Wartość domyślna (1+2+3+4+5) oznacza, że dane zostaną uznane za niepoprawne jeśli urządzenie zasygnalizuje błąd "aplikacja zajęta" (1), "błąd aplikacji" (2), "spadek zasilania" (3), "błąd stały" (4) oraz "błąd tymczasowy" (5). Producent może zdefiniować dodatkowe statusy: 6, 7 i 8. Aby wyłączyć sprawdzanie statusu należy podać znak - (myślnik) jako wartość parametru.

Wartość domyślna - 1+2+3+4+5.

***

Zakładka Parametry kanału - alarmy:

R Kod alarmu

Znaczenie - parametr określa numer alarmu w systemie Asix, który będzie generowany przez drajwer po utracie łączności z urządzeniem M-BUS.

Wartość opcji:

liczba

Wartość domyślna - brak (0).

R Alarmy

Znaczenie - jest to zestaw parametrów o nazwach od Alarm0 do Alarm7. Każdy parametr określa numer alarmu systemu Asix, który zostanie przez drajwer wygenerowany po wystąpieniu analogicznego alarmu w urządzeniu M-BUS. Znaczenie alarmów generowanych przez urządzenie M-BUS jest określone przez producenta.

Wartość domyślna - brak (0).

***

Zakładka Parametry kanału - diagnostyka:

R Plik logu

Znaczenie - wartością parametru jest nazwa piku, w którym będą zapisywane informacje diagnostyczne. Parametr może być wykorzystywany tylko do celów diagnostycznych.

Wartość opcji:

nazwa_pliku

Wartość domyślna - brak.

R Plik zrzutu

Znaczenie - wartością parametru jest nazwa pliku, w którym będą zapisywane dane. Parametr może być wykorzystywany tylko do celów diagnostycznych.

Wartość domyślna - brak.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MEC - drajwer protokołu liczników ciepła MEC07 i MEC08

Home > 1.57 MEC - drajwer protokołu liczników ciepła MEC07 i MEC08

1.57 MEC - drajwer protokołu liczników ciepła MEC07 i MEC08

Przeznaczenie drajwera

Drajwer MEC jest przeznaczony do wymiany danych pomiędzy systemem Asix i licznikami ciepła MEC07 i MEC08 wyprodukowanymi przez Instytut Techniki Cieplnej w Łodzi. Wymiana danych odbywa się przy pomocy łączy szeregowych w standardzie RS-232. Do przełączania linii szeregowej pomiędzy licznikami wykorzystywany jest multiplekser sterowany liniami RTS (przełączenie na pierwszy kanał) oraz DTR (przełączenie na kolejny kanał).

Parametryzacja drajwera MEC realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MEC wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MEC

Zakładka MEC:

Parametry kanału:

port [,max_nr]

gdzie:

port - nazwa portu szeregowego podłączonego do multipleksera

liczników ciepła MEC, np. COM1,

max_nr - opcjonalna liczba kanałów multipleksera, do których dołączone

są liczniki ciepła MEC (domyślnie 5).

PRZYKŁAD

Poniżej podano przykład deklaracji kanału transmisji KANAL służącego do komunikacji z licznikami ciepła MEC, podłączonymi do kanałów nultipleksera o numerach od 1 do 8. Wymiana danych odbywa się poprzez port szeregowy COM2.

Nazwa: KANAL

Drajwer: MEC

Parametry kanału: COM2,8

Typy zmiennych procesowych

W drajwerze zdefiniowano jeden typ zmiennych procesowych:

V - wartość przekazywanego pomiaru.

Wszystkie zmienne procesowe są typu FLOAT i mogą być wyłącznie odczytywane. Stempel czasu jest nadawany przez licznik ciepła i przesyłany wraz z wartościami zmiennych procesowych w ramach wspólnego telegramu. Stempel czasu jest podawany z dokładnością do jednej minuty.

Adres zmiennej procesowej ma składnię:

V<nrFabr>.<nrOdb>.<indeks>

gdzie:

nrFabr - numer fabryczny licznika ciepła MEC;

nrOdb - numer odbiornika, z którego jest przekazywany pomiar;

dopuszczalna wartość to 1 lub 2;

indeks - numer zmiennej w tabeli zmiennych przekazywanych z licznika.

Wykaz indeksów oraz odpowiadających im zmiennych procesowych zostały ujęte w poniższych tabelach.

Surowe wartości zmiennych odczytywanych z liczników ciepła powinny być przekształcane wg funkcji przeliczającej NIC_FP lub MNOZNIK_FP. Kolumna Mnożnik w obu tabelach zawiera współczynniki A funkcji przeliczającej MNOZNIK_FP dla pomiarów o znanym sposobie przekształcania surowej wartości (współczynniki B są równe 0). Dla pozostałych pomiarów sposób wyliczenia rzeczywistej wartości pomiaru należy uzgodnić z użytkownikiem liczników ciepła.

Tabela. Zmienne przekazywane z licznika MEC07.

Tabela. Zmienne przekazywane z licznika MEC08.

PRZYKŁAD

Przykłady deklaracji zmiennych.

A0, czas 7502, V7502.1.00, KANAL, 17, 1, DATACZAS_MEC

A1, ciśnienie 7502, V7502.1.04, KANAL, 1, 1, MNOZNIK_FP, 0.001, 0

A2, temp. zas.7502, V7502.1.37, KANAL, 1, 1, MNOZNIK_FP, 0.1, 0

A3, czas sum. 8502, V8502.1.07, KANAL, 1, 1, MNOZNIK_FP, 0.1, 0

A4, nr fabryczny 7502, V7502.1.01, KANAL, 1, 1, NIC_FP

Parametry drajwera

Parametry drajwera MEC deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

Parametry drajwera umieszczane są w sekcji o nazwie MEC.

R Nazwa sekcji: MEC
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - plik logu nie jest tworzony.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MEC
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - 1MB.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MEC
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - NIE.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MEC
R Nazwa opcji: CZAS_WAŻNOŚCI_DANYCH
R Wartość opcji: liczba

Znaczenie - dla każdego licznika MEC sprawdza się czas od ostatniego odczytu. Jeśli przekroczy zadeklarowaną wartość, to dane z aktualnie czytanego licznika MEC otrzymają status błędu.

Wartość domyślna - 1min.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MEC
R Nazwa opcji: CZAS_STROBU
R Wartość opcji: liczba

Znaczenie - pozwala określić czas trwania (w milisekundach) strobu RTS i DTR przy sterowaniu przełączaniem kanałów multipleksera.

Wartość domyślna - 60 ms.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MEC
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie - pozwala określić liczbę prób odbioru na każdym z kanałów multipleksera.

Wartość domyślna - 1 powtórzenie.

Zdefiniowanie - ręcznie.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MegaMuz

Home > 1.58 MegaMuz - drajwer mikroprocesorowych urządzeń zabezpieczających typu megaMuz firmy JM-Tronik

1.58 MegaMuz - drajwer mikroprocesorowych urządzeń zabezpieczających typu megaMuz firmy JM-Tronik w Warszawie

Przeznaczenie drajwera

Drajwer MegaMuz służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany interfejs RS-485 zabezpieczeń.

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt nastaw,

  • odczyt ustawień,

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów ASIXA,

  • odczyt zakłóceń i ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp. z o.o,

  • sterowanie wyjściami.

Drajwer obsługuje następujące typy megaMuz:

CR, CR_87, CR57

LR

LZ, LZ_87, LZ57

PR, PR_87

SR, SR_87

TR, TR_87

UWAGA:

Obsługa innego typu zabezpieczenia megaMuz wymaga zmian w kodzie drajwera.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MegaMuz wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MegaMuz

Zakładka MegaMuz/Parametry kanału:

Numer urządzenia w sieci - sieciowy numer urządzenia,

Typ urządzenia - typ megaMuz. Identyfikatory obsługiwanych typów:

1 - CR

2 - LR

3 - LZ

4 - PR

5 - SR

6 - TR

7 - CR_87

8 - LZ_87

9 - PR_87

10 - SR_87

11 - TR_87

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Port - nazwa portu szeregowego,

Zmienne kontrolne

- zmienna służąca do prezentacji statusu transmisji z megaMuz:

0 - stan transmisji o.k.

1 - brak/błędy komunikacji,

2 - wyłączenie megaMuz z obsługi,

- zmienna służąca do sterowania stanem transmisji z megaMuz:

1 - żądanie wyłączenia megaMuz z obsługi,

0 - włączenie megaMuz do obsługi.

Synchronizacja czasu

- okres synchronizacji czasu z urządzeniem megaMuz (w sekundach). 0 oznacza brak synchronizacji czasu (wartość domyślna).

Uwaga:

a/ zmienne kontrolne muszą należeć do kanału typu NONE.

b/ stałe parametry transmisji: prędkość - 9600 Bd, liczba bitów w znaku - 8, liczba bitów stopu - 1.

c/ opcja Zmienne kontrolne i Okres wymagają zdefiniowania obu zmiennych.

Poniżej podano przykład deklaracji kanału KPR, w którym jest obsługiwany megaMuz o numerze sieciowym 5, typie PR, na porcie COM1 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Numer urządzenia w sieci: 5

Typ urządzenia: 4

Offset alarmów: 200

Port: COM1

zmienna służąca do prezentacji statusu transmisji z megaMuz: MuzStat05

zmienna służąca do sterowania stanem transmisji z megaMuz: MuzCtrl05

Okres: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRLL - 2 rejestry zawierające liczbę typu DWORD (odczyt)

HRFL - 2 rejestry zawierające liczbę typu FLOAT (odczyt)

oraz wewnętrzne zmienne drajwera:

MN - numer sieciowy megaMuz, z którego jest/był odczytywany rejestrator (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RQ - żądanie odczytu rejestratora (zapis)

RR - status aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RS - powód wyzwolenia rejestratora (odczyt)

RT - czas wyzwolenia rejestratora (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora (odczyt)

UDC - służy do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika, dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów: MN, RN, RR, RQ i SN,

  2. w przypadku typów RS, RT zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu rejestratora (typ RQ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

  4. zakresy dla typów HR zależą od typu urządzenia,

  5. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_01, wartość I1, HRFL28, KLR_01, 1, 1, NIC_FP

ZM_02, pobudzenie zabezpieczeń 1, HR19, KLR_01, 1, 1, NIC

ZM_03, ilość nieodczytanych zdarzeń, HR27, KLR_01, 1, 1, NIC

ZM_04, wartość U1, HRFL46, KLR_01, 1, 1, NIC_FP

ZM_06, czas wyzwolenia rejestratora 1, RT1, KLR_01, 1,1, DATACZAS_MUZ

Przykład deklaracji zmiennych bez parametrów (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_07, żądanie odczytu rejestratora, RQ, KLR_01,1,1,NIC

ZM_08, nr odczytywanego rejestratora, RN, KLR_01,1,1,NIC

ZM_09, status odczytu rejestratora, RR, KLR_01,1,1,NIC

ZM_10, nr odczytanej próbki z rejestratora, SN, KLR_01,1,1,NIC

ZM_11, nr odczytywanego urządzenia, MN, KLR_01,1,1,NIC

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu AsLogger. Przeglądanie zarejestrowanych zakłóceń jest możliwe wyłącznie przy pomocy programu AsLogger.

W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń w bazie AsLogger (na zakładce Parametry drajwera), która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych,

w których drajwer będzie zapisywać odczytane zakłócenia.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z megaMuz i zapisać do bazy programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego megaMuz,

b/ RN - numer odczytywanego rejestratora,

c/ RR - status odczytu rejestratora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy programu AsLogger następujące parametry zakłócenia:

a/ pełny zestaw punktów planu, w skład którego wchodzą:

prądy : I0, I1, I2, I3 (po stronie wtórnej)

napięcia : U0, U1, U2, U3 (po stronie wtórnej)

stany wejść : WE01 ... WE24

stany wyjść : WY01 ... WY24

stany pobudzenia zabezpieczeń 1 : PZ01 ... PZ16

stany zadziałania zabezpieczeń 1 : ZZ01 ... ZZ16

Zestaw parametrów oraz liczba punktów planu dotyczących stanów pobudzeń zabezpieczeń i zadziałań zabezpieczeń jest specyficzna dla każdego typu megaMuza,

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym zakłóceniu - będą ew. korygowane przy odczycie kolejnych zakłóceń dla danego planu.

  • Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu '.def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w pozycji SCIEZKA_NAZW_ZAKLOCEN w sekcji MEGAMUZ.

Składnia definicji nazwy planu rejestracji umieszczana w pliku '.def' jest następująca:

kanał, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

powód - powód wyzwolenia rejestratora (liczba z przedziału od 0 do 15),

tabela - nazwa planu rejestracji przydzielona zakłóceniu,

komentarz - komentarz

  • Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji bazując na poniższej składni:

NrxxxpyyyPowod

gdzie:

xxx - numer sieciowy megaMuz,

yyy - numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w megaMuz nr 2 i COM5 zostanie zbudowany plan rejestracji o nazwie:

Nr002P005logika

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona pozycją OKRES_SPRAWDZANIA_ZDARZEN. Zdarzenia odczytywane z megaMuz są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie przygotowane dla każdego typu megaMuz oraz offset podany w deklaracji kanału ASMENA. Wyróżnia się dwa typy alarmów Asixa:

a/ tylko tekst

b/ tekst oraz jeden parametr liczbowy

Zdarzenia typu 0 są zamieniane na alarmy Asixa typu tekst + jeden parametr liczbowy (typu int) + parametr tekstowy (max 3 znaki), zawierający numery faz

Zdarzenia megaMuz o typie nr 2 są zamieniane na alarmy Asixa typu tekst.

Przykład 1

Zdarzenie Zamknięcie wyłącznika z telemechaniki w megaMuz typu LR (zdarzenie typu tekst) jest mapowane na numer alarmu Asixa o wartości 34. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 34 = 434):

434, al, zamknięcie wyłącznika z telemechaniki

Przykład 2

Zdarzenie Zadziałanie zabezpieczenia zwarciowego w megaMuz typu LR (zdarzenie typu tekst oraz dwa parametry: liczbowy i tekstowy) jest mapowane na numer alarmu Asixa o wartości 0. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 100, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (100 + 0 = 100):

100, al, zadziałanie zabezpieczenia zwarciowego %f, fazy %s

Mapowanie zdarzeń poszczególnych typów megaMuz na numery alarmów Asixa zawiera plik NumeryAlarmowAsixa.xls.

Parametryzacja drajwera

Parametry drajwera MegaMuz deklarowane są w module Dane bieżące na zakładce MegaMuz / Parametry drajwera ... kanału działającego według protokołu drajwera MegaMuz.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

(Parametry umieszczone na zakładkach Parametry kanału obowiązują wyłącznie dany kanał.)

Parametry drajwera:

  • tworzenie pliku logu,

  • tworzenie pliku logu zakłóceń,

  • rozmiar pliku logu,

  • log telegramów,

  • liczbę powtórzeń,

  • timeout odpowiedzi,

  • timeout międzyznakowy,

  • okres sprawdzania sygnalizacji zdarzeń,

  • rejestrację zakłóceń w bazie programu AsLogger,

  • katalog plików z definicjami planów rejestracji.

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

Zakładka MegaMuz / Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

Zakładka MegaMuz / Parametry drajwera:

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 3.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z megaMuz. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z megaMuz. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

Wartość opcji:

liczba

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału.

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odpowiedzi,

  • timeout znaku,

  • bez odczytu zdarzeń,

  • bez odczytu rejestratora zakłóceń.

Zakładka MegaMuz / Parametry kanału - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna - domyślnie używany jest plik logu drajwera.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu kanału, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie używa się rozmiaru pliku logu zdefiniowanego dla drajwera.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu kanału (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie używa się ustawienia zdefiniowanego dla drajwera.

Zakładka MegaMuz / Parametry kanału 2:

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z megaMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z megaMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony.

Wartość opcji:

TAK/NIE

R Bez rejestratora

Znaczenie: Opcja służy do wyłączania funkcji odczytu rejestratora zakłóceń w kanale.

Wartość domyślna: Domyślnie odczyt rejestratora zakłóceń jest dozwolony.

Wartość opcji:

TAK/NIE

Przykładowa parametryzacja drajwera

Plik logu =c:\tmp\muz.log

Plik logu zakłóceń =c:\tmp\zaklocenia.log

Rozmiar pliku logu =30

Log telegramów =TAK

Rejestracja zakłóceń w bazie AsLogger =SERWER_RO6, BAZA_RO6

Plik logu zakłóceń =c:\tmp\DefZaklocen

Przykładowa parametryzacja kanału

[KANALX]

Plik logu =c:\tmp\kanalx.log

Rozmiar pliku logu =20

Log telegramów =TAK

Timeout znaku =200

Timeout odpowiedzi =1500

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MegaMuz2

Home > 1.59 MegaMuz2 - drajwer mikroprocesorowych urządzeń zabezpieczających typu megaMuz2 firmy JM-Tronik

1.59 MegaMuz2 - drajwer mikroprocesorowych urządzeń zabezpieczających typu megaMuz2 firmy JM-Tronik w Warszawie

Przeznaczenie drajwera

Drajwer MegaMuz2 służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz2, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU przy pomocy łącza szeregowego.

Drajwer obsługuje następujące typy zabezpieczeń MegaMuz2:

- 01.12

Drajwer realizuje następujące funkcje:

- odczyt aktualnych stanów i pomiarów,

- odczyt zdarzeń i zgłaszanie ich do systemu alarmów ASIXA,

odczyt zakłóceń z rejestratora zakłóceń i rejestratora kryterialnego oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MegaMuz wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MegaMuz

Zakładka MegaMuz/Parametry kanału:

Numer urządzenia w sieci - sieciowy numer urządzenia,

Typ urządzenia - typ megaMuz. Identyfikatory obsługiwanych typów:

1 - 01_12

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Port - nazwa portu szeregowego,

Prędkość transmisji - prędkość transmisji z zakresu 9600 – 115200 Bd,

Zmienne kontrolne

- zmienna służąca do prezentacji statusu transmisji z megaMuz:

0 - stan transmisji o.k.

1 - brak/błędy komunikacji,

2 - wyłączenie megaMuz z obsługi,

- zmienna służąca do sterowania stanem transmisji z megaMuz:

1 - żądanie wyłączenia megaMuz z obsługi,

0 - włączenie megaMuz do obsługi.

Synchronizacja czasu

- okres synchronizacji czasu z urządzeniem megaMuz (w sekundach). 0 oznacza brak synchronizacji czasu (wartość domyślna).

Uwaga:

a/ zmienne kontrolne muszą należeć do kanału typu NONE.

Transmisja jest prowadzona bez kontroli parzystości (w parametrach komunikacji MutliMuz3 należy ustawić PARZ. = NIE).

Poniżej podano przykład deklaracji kanału KSR_67, w którym jest obsługiwany MegaMuz2 o numerze sieciowym 5, poprzez COM12, z prędkością 38400 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Numer urządzenia w sieci: 5

Typ urządzenia: 4

Offset alarmów: 200

Port: COM12

zmienna służąca do prezentacji statusu transmisji z megaMuz: MuzStat05

zmienna służąca do sterowania stanem transmisji z megaMuz: MuzCtrl05

Okres: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora zakłóceń (odczyt)

RQ - żądanie odczytu rejestratora zakłóceń (zapis)

RT - czas wyzwolenia rejestratora zakłóceń (odczyt)

MN - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator zakłóceń (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora zakłóceń (odczyt)

RSKR - powód wyzwolenia rejestratora kryterialnego (odczyt)

RQKR - żądanie odczytu rejestratora kryterialnego (zapis)

RTKR - czas wyzwolenia rejestratora kryterialnego (odczyt)

MNKR - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator kryterialnego (odczyt)

RNKR - numer aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

RRKR - status aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

SNKR - numer ostatnio odczytanej próbki rejestratora kryterialnego (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów : MN, RN, RR, RQ, SN, MNKR, RNKR, RRKR, RQKR i SNKR

  2. w przypadku typów RS, RT, RSKR, RTKR zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu. Indeks o numerze 1 dotyczy najświeższego rejestartora

  3. parametrem żądania odczytu rejestratora (typ RQ, RQKR ) jest numer rejestratora. Rejestratory są numerowane wg czasów wyzwolenia, przy czym najświeższy rejestrator ma numer 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

  4. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych:

ZM_01, wartość RMS prądu I1, HRL3, KLR, 1, 1, NIC_DW

ZM_02, wartość RMS napięcia U1, HRL27,KLR, 1, 1, NIC_DW

ZM_03, pobudzenie zabezpieczeń 1, HRL95,KLR, 1, 1, NIC_DW

ZM_04, zmiana banku nastaw na bank1, CS17, KLR,1,1, NIC

ZM_05, czas wyzwolenia rejestratora zakłóceń 1, RT1, KLR, 1,1, DATACZAS_MUZ

ZM_06, żądanie odczytu rejestratora zakłóceń, RQ, KLR,1,1,NIC

ZM_07, nr odczytywanego rejestratora zakłóceń, RN, KLR,1,1,NIC

ZM_08, status odczytu rejestratora zakłóceń, RR, KLR,1,1,NIC

ZM_09, nr odczytanej próbki z rejestratora zakłóceń, SN, KLR_01,1,1,NIC

ZM_10, żądanie odczytu rejestratora kryterialnego, RQKR, KLR,1,1,NIC

ZM_11, nr odczytywanego rejestratora kryterialnego, RNKR, KLR,1,1,NIC

ZM_12, status odczytu rejestratora kryterialnego, RRKR, KLR,1,1,NIC

ZM_13, nr odczytanej próbki z rejestratora kryterialnego, SNKR, KLR_01,1,1,NIC

Odczyt rejestratorów

Drajwer umożliwia rejestrację zakłóceń oraz rejestratorów w bazie danych programu AsLogger. Przeglądanie zarejestrowanych zakłóceń jest możliwe wyłącznie przy pomocy programu AsLogger.

W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń w bazie AsLogger (na zakładce Parametry drajwera - AsLogger), która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych AsLogger,

w których drajwer będzie zapisywać odczytane zakłócenia.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ (rejestrator zakłóceń) lub RQKR (rejestrator kryterialny). Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z urządzenia i zapisać do bazy programu AsLogger. Wartość sterująca 1 oznacza, że należy odczytać najświeższy rejestrator, wartość k oznacza, że należy odczytać k-ty w kolejności zapisów rejestrator. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN, MNKR - numer urządzenia w sieci MODBUS,

b/ RN, RNKR - numer odczytywanego rejestratora,

c/ RR, RNKR - status odczytu rejestratora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN, SNKR - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w rekordzie rejestratora opisane w dokumentacji protokołu zabezpieczenia:

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu – będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

  • Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu '.def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w opcji Katalog plików zawierających nazwy planów rejestracji na zakładce Parametry drajwera - AsLogger.

Składnia definicji nazwy planu rejestracji umieszczana w pliku '.def' jest następująca:

kanał, typ, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

typ - typ rejestratora (k - kryterialny, Z - zakłóceń),

powód - powód wyzwolenia rejestratora (zgodna ze specyfikacją podaną w opisie protokołu zabezpieczenia),

tabela - nazwa planu rejestracji,

komentarz - komentarz.

Przykład:

Definicje nazw planów rejestracji dla rejestratora zakłóceń:

- zadziałanie zabezpieczenia zwarciowego (powód wyzwolenia nr 2)

- zamknięcie wyłącznika (powód wyzwolenia nr 31)

w kanale ASMENA o nazwie KTR_06:

KTR_06, Z, 2, Pole06ZadzZabezpZwarciowego, zadziałanie zabezpieczenia zwarciowego

KTR_06, Z, 31, Pole06ZamkWylacznika, zamknięcie wyłącznika

  • Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Dla rejestratorów zakłóceń składnia ma postać:

NrxxxpyyyPowod

gdzie:

xxx - numer sieciowy megaMuz,

yyy - numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Dla rejestratorów kryterialnych składnia ma postać:

Nrxxx pkyyyPowod

gdzie:

xxx - trzycyfrowy numer urządzenia w sieci MODBUS,

yyy - trzycyfrowy numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w MultiMuzie3 o numerze 2 w sieci MODBUS oraz komunikacji przez port COM12 zostanie zbudowany plan rejestracji o nazwie:

Nr002pz012wyzw_rej_od_log_użytk

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona pozycją Okres sprawdzania zdarzeń na zakładce Parametry drajwera. Zdarzenia odczytywane z megaMuz są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie podane w pliku NumeryAlarmowAsixaVerxx.xls oraz offset alarmu podany w deklaracji kanału ASMENA. Do alarmów Asixa są przekazywane następujące parametry zdarzeń (wg typów zdarzeń):

a/ typ 01H – wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) zamiast wartość word jest przekazywany tekst opisujący fazy )

b/ typ 02H – wartość int oraz wartość word

c/ typ 04H – wartość int oraz wartość word

d/ typ 08H – wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) wartość word zawiera identyfikator przyczyny zdarzenia)

e/ typ 11H – wartość word

f/ typ 12H – wartość word

g/ typ 14H – wartość word

h/ typ 21H (*2) (*3) – numer łącznika, identyfikator miejsca sterowania

i/ typ 21H (*2) – numer łącznika

j/ typ 21H (*3) – identyfikator miejsca sterowania

k/ typ 21H – wartość word

l/ typ 52H – wartość word

ł/ typ 54H – wartość word

m/ typ 92H – wartość word

n/ typ 94H – wartość word

Przykład 1:

Zdarzenie Zamknięcie wyłącznika z SZR (zdarzenie typu 21H o kodzie 161) jest mapowane na numer alarmu Asixa o wartości 190. Jeśli w deklaracji kanału ASMENA obsługującego dane urządzenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 190 = 590 ):

590, al, zamknięcie wyłącznika z SZR

Parametryzacja drajwera

Parametry drajwera MegaMuz deklarowane są w module Dane bieżące na zakładce MegaMuz2 / Parametry drajwera ... kanału działającego według protokołu drajwera MegaMuz.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

(Parametry umieszczone na zakładkach Parametry kanału obowiązują wyłącznie dany kanał.)

Parametry drajwera:

  • tworzenia pliku logu,

  • rozmiaru pliku logu,

  • logu telegramów,

  • liczby powtórzeń zapytania,

  • okresu sprawdzania sygnalizacji zdarzeń,

  • rejestracji zakłóceń w bazie programu AsLogger,

  • katalogu plików z definicjami planów rejestracji,

  • timeout odbioru odpowiedzi,

  • timeout międzyznakowy przy odbiorze odpowiedzi,

  • zwłoki po braku odpowiedzi

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

Zakładka MegaMuz2 / Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcja jest wyłączona.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

Zakładka MegaMuz2 / Parametry drajwera:

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 3.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z urządzenia.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 50 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

Wartość opcji:

liczba

R Zwłoka po braku odpowiedzi

Znaczenie - opcja określa czas poprzez który drajwer nie wystawia zapytań w kanale, jeśli poprzednie zapytanie w tym kanale zakończyło się brakiem odpowiedzi. W tym okresie wszystkie polecenia kierowane do danego kanału są kończone ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji w kanale).

Wartość domyślna - domyślnie wartość opcji wynosi 0 sekund.

Wartość opcji:

liczba - wartość timeout’u w sekundach.

Zakładka MegaMuz2 / Parametry drajwera - AsLogger:

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału.... Parametry kanału przeciążają parametry drajwera.

  • timeout odbioru odpowiedzi,

  • timeout międzyznakowy przy odbiorze odpowiedzi,

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • nazwy łączników,

  • wyłączenie odczytu zdarzeń.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna - domyślnie używany jest plik logu drajwera.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu kanału, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie używa się rozmiaru pliku logu zdefiniowanego dla drajwera.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu kanału (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie używa się ustawienia zdefiniowanego dla drajwera.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z megaMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 50 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony.

Wartość opcji:

TAK/NIE

R Zwłoka po braku odpowiedzi

Znaczenie: Opcja określa czas (w sekundach), poprzez który nie wystawia się zapytań w kanale, jeśli poprzednie zapytanie w kanale zakończyło się brakiem odpowiedzi. W tym okresie wszystkie polecenia kierowane do danego kanału są kończone ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji w kanale). Pozycja przeciąża wartość wprowadzoną przez pozycję podaną w parametrach drajwera.

Wartość domyślna: Domyślnie odczyt rejestratora zakłóceń jest pobierany z parametrów drajwera.

Wartość opcji:

liczba - wartość timeout’u w sekundach.

R Nazwa łącznika 1 ... 7

Znaczenie: Pozycja służy do określenia nazw łączników, które zostaną przekazane do systemu alarmów. Nazwa łącznika nie może być dłuższa niż 3 znaki. Można zdefiniować nazwy dla max 7-miu łączników o numerach od 1 do 7.

Wartość domyślna: Domyślnie łączniki maja nazwy 1, 2, 3, … 7.

Wartość opcji:

tekst - 3-literowa nazwa łącznika o określonym numerze.

Przykładowa parametryzacja drajwera

Plik logu =c:\tmp\muz.log

Plik logu zakłóceń =c:\tmp\zaklocenia.log

Rozmiar pliku logu =30

Log telegramów =TAK

Rejestracja zakłóceń w bazie AsLogger =SERWER_RO6, BAZA_RO6

Plik logu zakłóceń =c:\tmp\DefZaklocen

Przykładowa parametryzacja kanału

[KANAL]

Plik logu =c:\tmp\kanal_1.log

Rozmiar pliku logu =30

Log telegramów =TAK

Timeout znaku = 60

Timeout odpowiedzi =1500

Nazwa łącznika 1 = L1

Nazwa łącznika 2 = L2

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MegaMuz2_TCPIP

Home > 1.60 MegaMuz2_TCPIP - drajwer do komunikacji przez Ethernet z mikroprocesorowymi urządzeniami zabezpieczającymi

1.60 MegaMuz2_TCPIP - drajwer do komunikacji przez Ethernet z mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz2 firmy JM-Tronik

Przeznaczenie drajwera

Drajwer MegaMuz2_TCPIP służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz2, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU na TCPIP przy pomocy łącza Ethernet i portu 10502.

Drajwer obsługuje następujące typy zabezpieczeń megaMuz2:

01.12

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów ASIXA,

  • odczyt zakłóceń z rejestratora zakłóceń i rejestratora kryterialnego oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Parametryzacja drajwera MegaMuz_TCPIP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MegaMuz2_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MegaMuz2_TCPIP

Zakładka MegaMuz_TCPIP/Parametry kanału:

Numer urządzenia w sieci - numer urządzenia w sieci MODBUS,

Typ urządzenia - typ megaMuz. Identyfikatory obsługiwanych typów:

01_12

Adres IP urządzenia - adres IP urządzenia,

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Zmienne kontrolne

- zmienna służąca do prezentacji statusu transmisji z megaMuz:

0 - stan transmisji ok,

1 - brak/błędy komunikacji,

2 - wyłączenie megaMuz z obsługi,

- zmienna służąca do sterowania stanem transmisji z megaMuz:

1 - żądanie wyłączenia megaMuz z obsługi,

0 - włączenie megaMuz do obsługi.

Synchronizaca czasu... - okres synchronizacji czasu z urządzeniem (w sekundach). Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

Adres IP komputera - adres IP urządzenia, przez który kanał będzie się łączył z urządzeniem.

Uwaga:

- zmienne kontrolne muszą należeć do kanału typu NONE.

Poniżej podano przykład deklaracji kanału KSR_67, w którym jest obsługiwany MegaMuz2 o numerze sieciowym 5, adresie IP 10.10.12.5 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Numer urządzenia w sieci: 5

Offset alarmów: 200

Adres IP urządzenia: 10.10.105.211

zmienna służąca do prezentacji statusu transmisji z megaMuz: MuzStat05

zmienna służąca do sterowania stanem transmisji z megaMuz: MuzCtrl05

Okres: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora zakłóceń (odczyt)

RQ - żądanie odczytu rejestratora zakłóceń (zapis)

RT - czas wyzwolenia rejestratora zakłóceń (odczyt)

MN - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator zakłóceń (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora zakłóceń (odczyt)

RSKR - powód wyzwolenia rejestratora kryterialnego (odczyt)

RQKR - żądanie odczytu rejestratora kryterialnego (zapis)

RTKR - czas wyzwolenia rejestratora kryterialnego (odczyt)

MNKR - numer sieciowy urządzenia, z którego jest/był odczytywany rejestrator kryterialnego (odczyt)

RNKR - numer aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

RRKR - status aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

SNKR - numer ostatnio odczytanej próbki rejestratora kryterialnego (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów : MN, RN, RR, RQ, SN, MNKR, RNKR, RRKR, RQKR i SNKR

  2. w przypadku typów RS, RT, RSKR, RTKR zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu rejestratora (typ RQ, RQKR ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

  4. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych:

ZM_01, wartość RMS prądu I1, HRL3, KLR, 1, 1, NIC_DW

ZM_02, wartość RMS napięcia U1, HRL27,KLR, 1, 1, NIC_DW

ZM_03, pobudzenie zabezpieczeń 1, HRL95,KLR, 1, 1, NIC_DW

ZM_04, zmiana banku nastaw na bank1, CS17, KLR,1,1, NIC

ZM_05, czas wyzwolenia rejestratora zakłóceń 1, RT1, KLR, 1,1, DATACZAS_MUZ

ZM_06, żądanie odczytu rejestratora zakłóceń, RQ, KLR,1,1,NIC

ZM_07, nr odczytywanego rejestratora zakłóceń, RN, KLR,1,1,NIC

ZM_08, status odczytu rejestratora zakłóceń, RR, KLR,1,1,NIC

ZM_09, nr odczytanej próbki z rejestratora zakłóceń, SN, KLR_01,1,1,NIC

ZM_10, żądanie odczytu rejestratora kryterialnego, RQKR, KLR,1,1,NIC

ZM_11, nr odczytywanego rejestratora kryterialnego, RNKR, KLR,1,1,NIC

ZM_12, status odczytu rejestratora kryterialnego, RRKR, KLR,1,1,NIC

ZM_13, nr odczytanej próbki z rejestratora kryterialnego, SNKR, KLR_01,1,1,NIC

Odczyt rejestratorów

Drajwer umożliwia rejestrację zakłóceń oraz rejestratorów w bazie danych programu AsLogger. Przeglądanie zarejestrowanych zakłóceń jest możliwe wyłącznie przy pomocy programu AsLogger.

W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń w bazie AsLogger (na zakładce Parametry drajwera - AsLogger), która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych AsLogger,

w których drajwer będzie zapisywać odczytane zakłócenia.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ (rejestrator zakłóceń) lub RQKR (rejestrator kryterialny). Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z urządzenia i zapisać do bazy programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN, MNKR - numer urządzenia w sieci MODBUS,

b/ RN, RNKR - numer odczytywanego rejestratora,

c/ RR, RNKR - status odczytu rejestratora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN, SNKR - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w rekordzie rejestratora opisane w dokumentacji protokołu zabezpieczenia:

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu – będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

  • Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu '.def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w opcji Katalog plików zawierających nazwy planów rejestracji na zakładce Parametry drajwera - AsLogger.

Składnia definicji nazwy planu rejestracji umieszczana w pliku '.def' jest następująca:

kanał, typ, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

typ - typ rejestratora (k - kryterialny, Z - zakłóceń),

powód - powód wyzwolenia rejestratora (zgodna ze specyfikacją podaną w opisie protokołu zabezpieczenia),

tabela - nazwa planu rejestracji,

komentarz - komentarz.

Przykład:

Definicje nazw planów rejestracji dla rejestratora zakłóceń:

- zadziałanie zabezpieczenia zwarciowego (powód wyzwolenia nr 2)

- zamknięcie wyłącznika (powód wyzwolenia nr 31)

w kanale ASMENA o nazwie KTR_06:

KTR_06, Z, 2, Pole06ZadzZabezpZwarciowego, zadziałanie zabezpieczenia zwarciowego

KTR_06, Z, 31, Pole06ZamkWylacznika, zamknięcie wyłącznika

  • Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Dla rejestratorów zakłóceń składnia ma postać:

NrxxxpyyyPowod

gdzie:

xxx - numer sieciowy megaMuz,

yyy - numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Dla rejestratorów kryterialnych składnia ma postać:

NrxxxpkyyyPowod

gdzie:

xxx - trzycyfrowy numer urządzenia w sieci MODBUS,

yyy - trzycyfrowy numer portu COM,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w MultiMuzie3 o numerze 2 w sieci MODBUS oraz komunikacji przez port COM12 zostanie zbudowany plan rejestracji o nazwie:

Nr002pz012wyzw_rej_od_log_użytk

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona pozycją Okres sprawdzania zdarzeń na zakładce Parametry drajwera. Zdarzenia odczytywane z urządzeń są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie podane w pliku NumeryAlarmowAsixaVerxx.xls oraz offset alarmu podany w deklaracji kanału ASMENA. Do alarmów Asixa są przekazywane następujące parametry zdarzeń (wg typów zdarzeń):

a/ typ 01H – wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) zamiast wartość word jest przekazywany tekst opisujący fazy )

b/ typ 02H – wartość int oraz wartość word

c/ typ 04H – wartość int oraz wartość word

d/ typ 08H – wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) wartość word zawiera identyfikator przyczyny zdarzenia)

e/ typ 11H – wartość word

f/ typ 12H – wartość word

g/ typ 14H – wartość word

h/ typ 21H (*2) (*3) – numer łącznika, identyfikator miejsca sterowania

i/ typ 21H (*2) – numer łącznika

j/ typ 21H (*3) – identyfikator miejsca sterowania

k/ typ 21H – wartość word

l/ typ 52H – wartość word

ł/ typ 54H – wartość word

m/ typ 92H – wartość word

n/ typ 94H – wartość word

Przykład 1:

Zdarzenie Zamknięcie wyłącznika z SZR (zdarzenie typu 21H o kodzie 161) jest mapowane na numer alarmu Asixa o wartości 190. Jeśli w deklaracji kanału ASMENA obsługującego dane urządzenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 190 = 590 ):

590, al, zamknięcie wyłącznika z SZR

Parametryzacja drajwera

Parametry drajwera MegaMuz2_TCPIP deklarowane są w module Dane bieżące na zakładce MegaMuz2_TCPIP / Parametry drajwera ... kanału działającego według protokołu drajwera MegaMuz2_TCPIP.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

(Parametry umieszczone na zakładkach Parametry kanału obowiązują wyłącznie dany kanał.)

Parametry drajwera:

  • tworzenia pliku logu,

  • rozmiaru pliku logu,

  • logu telegramów,

  • liczby powtórzeń zapytania,

  • okresu sprawdzania sygnalizacji zdarzeń,

  • rejestracji zakłóceń w bazie programu AsLogger,

  • katalogu plików z definicjami planów rejestracji.

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

Zakładka MegaMuz2_TCPIP / Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcja jest wyłączona.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

Zakładka MegaMuz2_TCPIP / Parametry drajwera:

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 1.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

Wartość opcji:

liczba

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału...

Parametry drajwera:

  • timeout odbioru odpowiedzi z urządzenia,

  • zwłokę uruchomienia operacji odbioru odpowiedzi z urządzenia,

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • liczbę powtórzeń zapytania w przypadku błędów odpowiedzi,

  • max. liczbę rejestrów w zapytaniu,

  • adres IP karty komputera służącej do komunikacji z urządzeniem,

  • numer portu komputera służący do komunikacji z urządzeniem,

  • nazwy łączników,

  • wyłączenie odczytu zdarzeń.

Zakładka MegaMuz2_TCPIP / Parametry kanału - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna - domyślnie używany jest plik logu drajwera.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu kanału, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie używa się rozmiaru pliku logu zdefiniowanego dla drajwera.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu kanału (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie używa się ustawienia zdefiniowanego dla drajwera.

Zakładka MegaMuz_TCPIP / Parametry kanału 2:

R Port

Znaczenie: Opcja służy do określenia numeru portu komputera, poprzez którą będzie realizowana komunikacja w danym kanale.

Wartość domyślna: Domyślnie wykorzystuje się port przydzielony przez system Windows.

Wartość opcji:

liczba - numer portu.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 500 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Zwłoka odpowiedzi

Znaczenie: Opcja określa czas zwłoki pomiędzy wysłaniem zapytania do urządzenia i uruchomieniem operacji odbioru odpowiedzi. Użycie pozycji ma sens w przypadku znacznego pofragmentowania odpowiedzi.

Wartość domyślna: Domyślna wartość wynosi 20 milisekund.

Wartość opcji:

liczba - wartość zwłoki odbioru w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony (TAK).

Wartość opcji:

TAK/NIE

R Liczba powtórzeń

Znaczenie: Pozycja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Wartość domyślna: liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

R Maksymalna liczba rejestrów

Znaczenie: Opcja służy do określenia max. liczby rejestrów, o które drajwer może zapytać w jednym poleceniu w danym kanale.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 119.

Wartość opcji:

liczba - max. liczba rejestrów w pojedynczym zapytaniu.

R Nazwa łącznika 1 ... 7

Znaczenie: Pozycja służy do określenia nazw łączników, które zostaną przekazane do systemu alarmów. Nazwa łącznika nie może być dłuższa niż 3 znaki. Można zdefiniować nazwy dla max 7-miu łączników o numerach od 1 do 7.

Wartość domyślna: Domyślnie łączniki maja nazwy 1, 2, 3, … 7.

Wartość opcji:

tekst - 3-literowa nazwa łącznika o określonym numerze.

Przykładowa parametryzacja drajwera

Plik logu =c:\tmp\muz.log

Plik logu zakłóceń =c:\tmp\zaklocenia.log

Rozmiar pliku logu =30

Log telegramów =TAK

Rejestracja zakłóceń w bazie AsLogger =SERWER_RO6, BAZA_RO6

Plik logu zakłóceń =c:\tmp\DefZaklocen

Przykładowa parametryzacja kanału

[KANAL]

Plik logu =c:\tmp\kanal_1.log

Rozmiar pliku logu =30

Log telegramów =TAK

Adres IP komputera = 10.10.112.8

Maksymalna liczba rejestrów = 53

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MegaMuz_TCPIP

Home > 1.61 MegaMuz_TCPIP - drajwer do komunikacji przez Ethernet z mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz

1.61 MegaMuz_TCPIP - drajwer do komunikacji przez Ethernet z mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz firmy JM-Tronik

Przeznaczenie drajwera

Drajwer MegaMuz_TCPIP służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu megaMuz, produkowanymi przez firmę JM-Tronik w Warszawie. Do komunikacji jest wykorzystywany Ethernet.

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt nastaw,

  • odczyt ustawień,

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

  • odczyt zakłóceń i ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp. z o.o,

  • sterowanie wyjściami.

Drajwer obsługuje następujące typy megaMuz:

CR, CR_87

LR

LZ, LZ_87

PR, PR_87

SR, SR_87

TR, TR_87

Obsługa innego typu zabezpieczenia megaMuz wymaga zmian w kodzie drajwera.

Parametryzacja drajwera MegaMuz_TCPIP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MegaMuz_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MegaMuz_TCPIP

Zakładka MegaMuz_TCPIP/Parametry kanału:

Numer urządzenia w sieci - sieciowy numer urządzenia,

Typ urządzenia - typ megaMuz. Identyfikatory obsługiwanych typów:

1 - CR

2 - LR

3 - LZ

4 - PR

5 - SR

6 - TR

7 - CR_87

8 - LZ_87

9 - PR_87

10 - SR_87

11 - TR_87

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Numer portu TCP... - numer portu TCP w megaMuzie (lub w bramce, do której jest podłączony megaMuz),

Adres IP urządzenia... - adres IP megaMuza (lub bramki, do której jest podłączony megaMuz),

Zmienne kontrolne

- zmienna służąca do prezentacji statusu transmisji z megaMuz:

0 - stan transmisji ok,

1 - brak/błędy komunikacji,

2 - wyłączenie megaMuz z obsługi,

- zmienna służąca do sterowania stanem transmisji z megaMuz:

1 - żądanie wyłączenia megaMuz z obsługi,

0 - włączenie megaMuz do obsługi.

Okres synchronizacji czasu... - okres synchronizacji czasu z megaMuz (w sekundach). Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

Uwaga:

- zmienne kontrolne muszą należeć do kanału typu NONE.

Poniżej podano przykład deklaracji kanału KPR, w którym jest obsługiwany megaMuz o numerze sieciowym 5, typie PR, komunikacja jest realizowana przy pomocy bramki NPort (port TCP 4004, adres IP 10.10.105.211), offset alarmów wynosi 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Numer urządzenia w sieci: 5

Typ urządzenia: 4

Offset alarmów: 200

Numer portu TCP...: 4004

Adres IP urządzenia: 10.10.105.211

zmienna służąca do prezentacji statusu transmisji z megaMuz: MuzStat05

zmienna służąca do sterowania stanem transmisji z megaMuz: MuzCtrl05

Okres: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRLL - 2 rejestry zawierające liczbę typu DWORD (odczyt)

HRFL - 2 rejestry zawierające liczbę typu FLOAT (odczyt)

oraz wewnętrzne zmienne drajwera:

MN - numer sieciowy megaMuz, z którego jest/był odczytywany rejestrator (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RQ - żądanie odczytu rejestratora (zapis)

RR - status aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RS - powód wyzwolenia rejestratora (odczyt)

RT - czas wyzwolenia rejestratora (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora (odczyt)

UDC - służy do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika, dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów: MN, RN, RR, RQ i SN,

  2. w przypadku typów RS, RT zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu rejestratora (typ RQ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

  4. zakresy dla typów HR zależą od typu urządzenia.,

  5. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_01, wartość I1, HRFL28, KLR_01, 1, 1, NIC_FP

ZM_02, pobudzenie zabezpieczeń 1, HR19, KLR_01, 1, 1, NIC

ZM_03, ilość nieodczytanych zdarzeń, HR27, KLR_01, 1, 1, NIC

ZM_04, wartość U1, HRFL46, KLR_01, 1, 1, NIC_FP

ZM_06, czas wyzwolenia rejestratora 1, RT1, KLR_01, 1,1, DATACZAS_MUZ

Przykład deklaracji zmiennych bez parametrów (wartości zmiennych pochodzą z urządzenia typu LR dostępnego poprzez kanał o nazwie KLR_01):

ZM_07, żądanie odczytu rejestratora, RQ, KLR_01,1,1,NIC

ZM_08, nr odczytywanego rejestratora, RN, KLR_01,1,1,NIC

ZM_09, status odczytu rejestratora, RR, KLR_01,1,1,NIC

ZM_10, nr odczytanej próbki z rejestratora, SN, KLR_01,1,1,NIC

ZM_11, nr odczytywanego urządzenia, MN, KLR_01,1,1,NIC

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu AsLogger. Przeglądanie zarejestrowanych zakłóceń jest możliwe wyłącznie przy pomocy programu AsLogger.

W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń w bazie AsLogger (na zakładce Parametry drajwera), która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych,

w których drajwer będzie zapisywać odczytane zakłócenia.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu ASIX poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z megaMuz i zapisać do bazy programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego megaMuz,

b/ RN - numer odczytywanego rejestratora,

c/ RR - status odczytu rejestratora:

0 - nieaktywny lub zakończony ok

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy programu AsLogger następujące parametry zakłócenia:

a/ pełny zestaw punktów planu, w skład którego wchodzą:

prądy: I0, I1, I2, I3 (po stronie wtórnej)

napięcia: U0, U1, U2, U3 (po stronie wtórnej)

stany wejść: WE01 ... WE24

stany wyjść: WY01 ... WY24

stany pobudzenia zabezpieczeń 1: PZ01 ... PZ16

stany zadziałania zabezpieczeń 1: ZZ01 ... ZZ16

Zestaw parametrów oraz liczba punktów planu dotyczących stanów pobudzeń zabezpieczeń i zadziałań zabezpieczeń jest specyficzna dla każdego typu megaMuza,

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym zakłóceniu - będą ew. korygowane przy odczycie kolejnych zakłóceń dla danego planu.

  • Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu '.def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w pozycji SCIEZKA_NAZW_ZAKLOCEN w sekcji MEGAMUZ_TCPIP.

Składnia definicji nazwy planu rejestracji umieszczana w pliku '.def' jest następująca:

kanał, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

powód - powód wyzwolenia rejestratora (liczba z przedziału od 0 do 15),

tabela - nazwa planu rejestracji przydzielona zakłóceniu,

komentarz - komentarz

  • Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji bazując na poniższej składni:

NrxxxipyyyPowod

gdzie:

xxx - numer sieciowy megaMuza,

yyy - najmłodszy element adresu IP megaMuza,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w megaMuz nr 2 i IP 10.10.105.211 zostanie zbudowany plan rejestracji o nazwie:

Nr002ip211logika

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona pozycją OKRES_SPRAWDZANIA_ZDARZEN. Zdarzenia odczytywane z megaMuz są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie przygotowane dla każdego typu megaMuz oraz offset podany w deklaracji kanału ASMENA. Wyróżnia się dwa typy alarmów Asixa:

a/ tylko tekst

b/ tekst oraz jeden parametr liczbowy

Zdarzenia typu 0 są zamieniane na alarmy Asixa typu tekst + jeden parametr liczbowy (typu int) + parametr tekstowy (max 3 znaki), zawierający numery faz

Zdarzenia megaMuz o typie nr 2 są zamieniane na alarmy Asixa typu tekst.

Przykład 1

Zdarzenie Zamknięcie wyłącznika z telemechaniki w megaMuz typu LR (zdarzenie typu tekst) jest mapowane na numer alarmu Asixa o wartości 34. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 34 = 434):

434, al, zamknięcie wyłącznika z telemechaniki

Przykład 2

Zdarzenie Zadziałanie zabezpieczenia zwarciowego w megaMuz typu LR (zdarzenie typu tekst oraz dwa parametry: liczbowy i tekstowy) jest mapowane na numer alarmu Asixa o wartości 0. Jeśli w deklaracji kanału ASMENA obsługującego to zabezpieczenie podano offset alarmów o wartości 100, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (100 + 0 = 100):

100, al, zadziałanie zabezpieczenia zwarciowego %f, fazy %s

Mapowanie zdarzeń poszczególnych typów megaMuz na numery alarmów Asixa zawiera plik NumeryAlarmowAsixa.xls.

Parametryzacja drajwera

Parametry drajwera MegaMuz_TCPIP deklarowane są w module Dane bieżące na zakładce MegaMuz_TCPIP / Parametry drajwera ... kanału działającego według protokołu drajwera MegaMuz_TCPIP.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

(Parametry umieszczone na zakładkach Parametry kanału obowiązują wyłącznie dany kanał.)

Parametry drajwera:

  • tworzenie pliku logu,

  • tworzenie pliku logu zakłóceń,

  • rozmiar pliku logu,

  • log telegramów,

  • liczbę powtórzeń,

  • timeout odpowiedzi,

  • okres sprawdzania sygnalizacji zdarzeń,

  • rejestrację zakłóceń w bazie programu AsLogger,

  • katalog plików z definicjami planów rejestracji.

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach Asmena.

Zakładka MegaMuz_TCPIP / Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

Zakładka MegaMuz_TCPIP / Parametry drajwera:

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 3.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z megaMuz. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

Wartość opcji:

liczba

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametryzacja kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału.

Parametry drajwera:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout odpowiedzi,

  • bez odczytu zdarzeń,

  • bez odczytu rejestratora zakłóceń.

Zakładka MegaMuz_TCPIP / Parametry kanału - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna - domyślnie używany jest plik logu drajwera.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu kanału, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie używa się rozmiaru pliku logu zdefiniowanego dla drajwera.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu kanału (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie używa się ustawienia zdefiniowanego dla drajwera.

Zakładka MegaMuz_TCPIP / Parametry kanału 2:

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z megaMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony.

Wartość opcji:

TAK/NIE

R Bez rejestratora

Znaczenie: Opcja służy do wyłączania funkcji odczytu rejestratora zakłóceń w kanale.

Wartość domyślna: Domyślnie odczyt rejestratora zakłóceń jest dozwolony.

Wartość opcji:

TAK/NIE

Przykładowa parametryzacja drajwera

Plik logu =c:\tmp\muz.log

Plik logu zakłóceń =c:\tmp\zaklocenia.log

Rozmiar pliku logu =30

Log telegramów =TAK

Rejestracja zakłóceń w bazie AsLogger =SERWER_RO6, BAZA_RO6

Plik logu zakłóceń =c:\tmp\DefZaklocen

Przykładowa parametryzacja kanału

[KANALX]

Plik logu =c:\tmp\kanalx.log

Rozmiar pliku logu =20

Log telegramów =TAK

Timeout odpowiedzi =1500


MELSECA - drajwer dedykowanego protokołu sterowników

Home > 1.62 MELSECA - drajwer dedykowanego protokołu sterowników MITSUBISHI

1.62 MELSECA - drajwer dedykowanego protokołu sterowników MITSUBISHI

Przeznaczenie drajwera

Drajwer MELSECA jest wykorzystywany do wymiany danych z procesorem komunikacyjnym A1SJ71C24-R2 sterowników MITSUBISHI serii MELSEC-A. Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix. Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu MELSECA nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych z systemem Asix.

Parametryzacja drajwera MELSECA realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MELSECA wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MELSECA

Zakładka MELSECA:

Parametry kanału:

typ,pc_cpu,port,[body,znak,parzystość,stop]

gdzie:

typ - zestaw realizowanych komend: ACPU lub AnCPU,

pc_cpu - numer PC CPU. W przypadku połączenia point-to-point należy podać ff ('self PC CPU number'),

port - nazwa portu szeregowego,

body - prędkość transmisji w bodach,

znak - liczba bitów w transmitowanym znaku,

parzystość - typ kontroli parzystości (even,odd,none),

stop - liczba bitów stopu.

Parametry body, znak, parzystość, stop i bufor są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola parzystości (none),

  • liczba bitów stopu - 1.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu MELSECA:

Nazwa:CHAN1

Drajwer: MELSECA

Parametry kanału: AnCPU,ff,COM1,9600,8,even,1

Adresacja zmiennych

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych procesowych należących do kanału MELSECA:

TYP_ZMIENNEJ indeks_zmiennej

gdzie:

TYP_ZMIENNEJ - łańcuch identyfikujący typ zmiennej w protokole MELSECA,

indeks_zmiennej - indeks zmiennej w ramach danego typu.

Dozwolone są następujące oznaczenia typów zmiennych procesowych (w kolumnach po prawej stronie podano zakres indeksów zmiennych dla zestawu komend ACPU i AnCPU):

ACPU AnCPU

X - Input X 0 - 7FF 0 - 7FF

Y - Output Y 0 - 7FF 0 - 7FF

M - Internal relay M. 0 - 2047 0 - 8191

L - Latch relay L 0 - 2047 0 - 8191

S - Step relay S 0 - 2047 0 - 8191

B - Link relay B 0 - 3FF 0 - 0FFF

F - Annunciator F 0 - 255 0 - 2047

TS - Timer (contact) T 0 - 255 0 - 2047

TC - Timer (coil) T 0 - 255 0 - 2047

TN - Timer (present value) T 0 - 255 0 - 2047

CS - Counter (contact) C 0 - 255 0 - 1023

CC - Counter (coil) C 0 - 255 0 - 1023

CN - Counter (present value) C 0 - 255 0 - 1023

MS - Special relay M 9000 - 9255 9000 - 9255

D - Data register D 0 - 1023 0 - 6143

W - Link register W 0 - 3FF 0 - 0FFF

R - File register R 0 - 8191 0 - 8191

DS - Special register D 9000 - 9255 9000 - 9255

Indeks zmiennej dla typów X, Y, B i W podaje się w postaci heksadecymalnej, przy czym indeksy rozpoczynające się od litery należy poprzedzić cyfrą 0, np. poprawna deklaracja wejścia nr E ma postać X0E (deklaracja XE zostanie odrzucona jako błędna).

Indeksy zmiennych pozostałych typów podaje się w postaci dziesiętnej.

Przykłady

X0A2 - stan wejścia numer A2,

D1010 - wartość rejestru D numer 1010.

Wszystkie zmienne procesowe są traktowane jako liczby 16-bitowe.

Poprawna współpraca procesora komunikacyjnego A1SJ71C24-R2 wymaga właściwego ustawienia przełączników SW04 - SW12 oraz przełącznika MODE (tryb pracy) na płycie czołowej. Przełącznik MODE należy bezwarunkowo ustawić na pozycję 1, gdyż drajwer MELSECA bazuje na dedykowanym protokole o numerze 1. Przełącznik SW04 należy ustawić na ON, jeśli aplikacja realizuje sterowania (stan ON przełącznika zezwala na zapis danych w stanie RUN). Przełącznik SW12 należy ustawić na ON (naliczanie i weryfikacja sumy kontrolnej). Stan przełączników SW05 - SW11 należy ustawić zgodnie z parametrami transmisji podanymi w opcji deklarującej kanał transmisji MELSECA:

(prędkość transmisji, liczba znaków w słowie, liczba bitów stopu, sposób kontroli parzystości).

Kabel łączący procesor komunikacyjny A1SJ71C24-R2 z komputerem systemu Asix należy wykonać według schematu podanego dla połączenia z urządzeniem, które nie steruje sygnałem CD, natomiast wykorzystuje sygnały DTR/DSR do kontroli transmisji (patrz rozdział 4.5 "External Wiring" dokumentacji 'Computer Link Module type A1SJ71C24-R2').

Drajwer MELSECA instalowany jest automatycznie jako DLL.

Parametry drajwera

Parametry drajwera MELSECA deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MELSECA
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - deklaracja nazwy pliku logu z komunikatami diagnostycznymi drajwera MELSECA.

Wartość domyślna - plik logu nie jest tworzony.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MELSECA
R Nazwa opcji: SUMA_KONTROLNA
R Wartość opcji: TAK/NIE

Znaczenie - użycie sumy kontrolnej w protokole.

Wartość domyślna - TAK.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MELSECA
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer MELSECA w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji PLIK_LOGU.

Wartość domyślna - NIE.

Zdefiniowanie - ręczne.

R Nazwa sekcji: MELSECA
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - 1 MB.

Zdefiniowanie - ręczne.


MEVAS - drajwer protokołu analizatorów MEVAS

Home > 1.63 MEVAS - drajwer protokołu analizatorów MEVAS

1.63 MEVAS - drajwer protokołu analizatorów MEVAS

Przeznaczenie drajwera

Drajwer MEVAS jest wykorzystywany do wymiany danych pomiędzy komputerami emisyjnymi MEVAS oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych. Drajwer realizuje protokół opisany w "Bedienungsanleitung Rechnerschnittstelle MEVAS (vorlaufige Version 1.00). Telegrammverkehr uber eine serielle Schnittstelle. Stand: 26.03.1993".

Parametryzacja drajwera MEVAS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MEVAS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MEVAS

Zakładka MEVAS:

Parametry kanału:

COMn,Adres_Mevasa

gdzie:

COMn - numer portu szeregowego, do którego podłączona jest sieć sterowników MEVAS;

Adres_Mevasa - numer identyfikujący komputer emisyjny MEVAS. Numer jest przyporządkowywany na etapie parametryzacji komputera emisyjnego MEVAS.

Parametry drajwera

Parametry drajwera MEVAS deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio.

Każdy zdefiniowany kanał może mieć swoją sekcję, której nazwa jest nazwą logiczną kanału. Także dany port COMn może mieć swoją sekcję o nazwie [MEVAS:n]. Wartości zdefiniowane w takiej sekcji staja się wartościami domyślnymi dla poszczególnych stacji. Wartości domyślne dla poszczególnych łącz szeregowych pobierane są z sekcji o nazwie [MEVAS]. Parametry transmisji po łączu szeregowym nie mogą znajdować się w sekcjach dotyczących poszczególnych stacji, tj. mogą wystąpić jedynie w sekcjach [MEVAS] i [MEVAS:n].

R Nazwa sekcji: MEVAS
R Nazwa opcji: Baud
R Wartość opcji: liczba

Znaczenie - określa szybkość transmisji. Opcja może być używana zamiennie z opcjami: bod, szybkosc, bps.

Wartość domyślna - 9600.

Parametr:

liczba - wartość wyrażana w Bd.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Parzystosc
R Wartość opcji: parametr_parzystości

Znaczenie - określa parzystość.

Wartość domyślna - n.

Parametr:

Parametr_parzystości - dopuszczalne wartości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

s - space.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Powtorzenia
R Wartość opcji: liczba

Znaczenie - ilość powtórzeń nieudanych operacji odczytu ze stacji MEVAS.

Wartość domyślna - 3.

R Nazwa sekcji: MEVAS
R Nazwa opcji: bity_stopu
R Wartość opcji: liczba

Znaczenie - określa ilość bitów stop. Opcja może być używana zamiennie z opcjami: stop.

Wartość domyślna - 1.

Parametr:

liczba - dopuszczalne wartości to 1 i 2.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Dlugosc_slowa
R Wartość opcji: liczba

Znaczenie - określa długość słowa. Opcja może być używana zamiennie z pozycją: Slowo.

Wartość domyślna - 8.

Parametr:

liczba - dopuszczalne wartości mieszczą się w przedziale od 5 do 8.

R Nazwa sekcji: MEVAS
R Nazwa opcji: timeout
R Wartość opcji: liczba

Znaczenie - określa czas oczekiwania na odpowiedź z DMS285Aa. Opcja może być używana zamiennie z opcjami: time-out, time_out.

Wartość domyślna - 10000.

Parametr:

liczba - dopuszczalne wartości mieszczą się w przedziale od 5 do 8.

R Nazwa sekcji: MEVAS
R Nazwa opcji: statusy_niewaznosci
R Wartość opcji: status1,status2,...statusN

Znaczenie - określa numery statusów danych, dla których dane są uznawane za nieważne. Status 13 (brak danych) powoduje, że dana jest zawsze traktowana jako nieważna, niezależnie od wartości parametru.

Wartość domyślna - 0,13.

Parametr:

- format: status1,status2,…,statusN lub znak - (brak statusów nieważności , za wyjątkiem 13).

R Nazwa sekcji: MEVAS
R Nazwa opcji: log
R Wartość opcji: plik_logu

Znaczenie - określa nazwę pliku, w którym będą przechowywane dodatkowe informacje diagnostyczne.

Wartość domyślna - brak.

R Nazwa sekcji: MEVAS
R Nazwa opcji: kod_alarmu
R Wartość opcji: numer_alarmu

Znaczenie - określa numer alarmu generowanego przez drajwer w przypadku utraty i odzyskania łączności ze stacją. Wartość -1 (domyślna) powoduje brak generacji alarmów. W sytuacji utraty połączenia razem z kodem alarmu przekazywana jest liczba charakteryzująca przyczynę utraty połączenia:

0 - zupełny brak jakiejkolwiek odpowiedzi ze strony stacji,

1 - timeout,

2 - błędy linii (błędy ramki, parzystości, overrun),

3 - błędy sumy kontrolnej,

4 - inne błędy,

5 - MEVAS został zresetowany,

6 - timeout po stronie MEVAS’a,

7 - błąd sumy kontrolnej po stronie MEVAS’a.

Liczba ta określa status zakończenia ostatniej próby nawiązania łączności.

Wartość domyślna - -1.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Symulacja
R Wartość opcji: liczba

Znaczenie - jeżeli wartością parametry jest 1, to drajwer pracuję w trybie symulacji i nie komunikuję się ze stacją. Wartości wszystkich danych są losowe.

Wartość domyślna - 0.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Odswiez1,...,Odswiez10
R Wartość opcji: liczba

Znaczenie - parametry określają, jak często drajwer ma przesyłać do stacji MEVAS zadania przygotowania nowego zestawu danych do późniejszego odczytu. Każdy parametr odpowiada określonej grupie zmiennych. Parametr Odswiez1 odpowiada wszystkim zmiennym. Parametr ma postać dwóch liczb. Pierwsza liczba określa częstość wysyłania żądania, druga określa przesunięcie w czasie wysyłania żądania. Np.: jeśli podano 60s,10s, to żądania przygotowania nowych danych mogą być wysłane o godzinach:

12:00:10, 12:01:10, 12:02:10 itd.

Parametr określa jedynie maksymalną częstość wysyłania żądań. Jeśli drajwer nie otrzymuje żądań odczytu nowych danych od pozostałych komponentów systemu Asix (ASMEN), to żądania przygotowania nowych danych nie są wysyłane do stacji MEVAS.

Jeśli parametr Odswiez1 oraz jeden z parametrów Odswiez2-Odswiez10 ma wartość niezerową, to żądania przygotowania określonego przez ten ostatni parametr zestawu danych będą wysyłane w chwilach spełniających kryteria, określone przez oba parametry jednocześnie, tzn. z częstością będącą wartością minimalną obu parametrów.

Jeśli parametr Odswiez1 ma wartość 0,0, to odpowiednie z pozostałych parametrów powinny mieć niezerowe wartości. Dane odczytywane ze stacji MEVAS - z wyjątkiem danych D28 (całki) - otrzymują stempel czasu przesłany przez stację MEVAS w chwili otrzymania żądania przygotowania nowego zestawu danych.

Wartość domyślna - 60s,10s (pozostałe parametry mają wartość 0,0.

Parametr:

liczba - obie liczby mają format nnn [s/m/g/h], gdzie nnn określa czas, a znaczenie literowe określa podstawę czasu (odpowiednio: sekunda, minuta, godzina, godzina). Jeżeli zostanie pominięte oznaczenie jednostki czasu, to przyjmowana jest sekunda.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Zaokr_28
R Wartość opcji: tak/nie

Znaczenie - jeżeli parametr ma wartość tak, to czas danych D28 jest zaokrąglany w górę do pełnej godziny. Zaokrąglenie dotyczy tylko danych z czasem w postaci hh: 59:00. Inne wartości czasu nie są zaokrąglane. Aby wyłączyć zaokrąglanie czasu, należy podać nie jako wartość parametru.

Wartość domyślna - tak.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Czas_Zaokr_28
R Wartość opcji: tak/nie

Znaczenie - czas w minutach określający zakres zaokrąglania czasu całek godzinnych. Jeśli czas całki jest zawarty w przedziale - najbliższa pełna godzina +/- wartość parametru, to czas całki zostanie zaokrąglony do najbliższej pełnej godziny. Przykładowo, jeśli wartością parametru jest 15 minut, to czasy całek zakresu 9:45:00 do 10:15:00 zostaną zaokrąglone do 10:00:00. Zaokrąglanie ma miejsce, jeśli wartością parametru Zakr_28 jest tak. Jeśli wartością parametru jest 0, to zaokrąglanie nie następuje.

Wartość domyślna - 15.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Odczyt_Czasu
R Wartość opcji: liczba

Znaczenie - parametr określa interwał czasu, z jakim drajwer aktualizuje czas stacji. Drajwer cyklicznie odczytuje czas stacji z podanym interwałem. Czas stacji MEVAS wykorzystywany jest do ustalenia czasu, w jakim należy wysyłać do stacji MEVAS żądania przygotowania nowych danych.

Wartość domyślna - 3600.

Parametr:

liczba - wartość czasu podawana w sekundach.

R Nazwa sekcji: MEVAS
R Nazwa opcji: Maks_Czas_D28
R Wartość opcji: liczba

Znaczenie - określa sposób reakcji drajwera na brak danych D28 (całki) w czasie uzupełniania danych historycznych. Jest to czas braku danych, po jakim drajwer założy, że dane historyczne nie istnieją i taką informację przekaże do zapisania w archiwum. Parametr ma zastosowanie tylko w sytuacji, gdy stacja MEVAS zgłasza brak jakichkolwiek wartości dotyczących określonego kanału i typu wartości (Knr/Wsl). Parametr nie dotyczy sytuacji, gdy tylko część z możliwych 52 wartości historycznych nie jest dostępna. W tym ostatnim przypadku zakłada się, że sytuacja taka nie ulegnie zmianie w późniejszym czasie.

Wartość domyślna - 4200.

Parametr:

liczba - wartość czasu podawana w sekundach.

PRZYKŁADY

Przykład 1

Deklaracja kanału:

Nazwa: MVS_1

Drajwer: MEVAS

Parametry kanału: COM2,3

Parametry drajwera:

Nazwa sekcji: MEVAS:2

Nazwa opcji: baud

Wartośc opcji: 19200

W powyższym przykładzie zdefiniowano stację o nazwie MVS_1 podłączoną do portu COM2. Użyta zostanie prędkość transmisji 19200 bitów na sekundę. Stacja ma identyfikator 3.

Przykład 2

Deklaracje kanałów:

...

Nazwa: MVS_1

Drajwer: MEVAS

Parametry kanału: COM1,1

Nazwa: MVS_2

Drajwer: MEVAS

Parametry kanału: COM2,2

Nazwa: MVS_3

Drajwer: MEVAS

Parametry kanału: COM3,1

Nazwa: MVS_4

Drajwer: MEVAS

Parametry kanału: COM4,1

Nazwa: MVS_4

Drajwer: MEVAS

Parametry kanału: COM4,1

Nazwa: MVS_5

Drajwer: MEVAS

Parametry kanału: COM5,4

Nazwa: MVS_6

Drajwer: MEVAS

Parametry kanału: COM6,5

...

Parametry drajwera:

Wartości domyślne dla wszystkich stacji

Nazwa sekcji: MEVAS

Nazwa opcji: szybkosc

Wartośc opcji: 19200

Nazwa sekcji: MEVAS

Nazwa opcji: Statusy_Niewaznosci

Wartośc opcji: 1, 6, 14

Wartości domyślne dla stacji podłączonych do portu COM3

Nazwa sekcji: MEVAS:3

Nazwa opcji: szybkosc

Wartośc opcji: 9600

Pozostałe wartości

Nazwa sekcji: MVS_2

Nazwa opcji: Statusy_Niewaznosci

Wartośc opcji: 5

Nazwa sekcji: MVS_3

Nazwa opcji: Statusy_Niewaznosci

Wartośc opcji: 0,13

W powyższym przykładzie zdefiniowano stacje o nazwach od MVS_1 do MVS_6 przyłączone do portów od COM1 do COM6. Wszystkie porty szeregowe z wyjątkiem COM3 będą pracować z szybkością 19200 baud. Port COM3 będzie pracował z szybkością 9600 baud. Wszystkie stacje z wyjątkiem stacji MVS_2 i MVS_3 będą używać statusów nieważności 1, 6 i 14. Stacja MVS_2 jako status nieważności wykorzystuje wartość 5. Stacja MVS_3 nie wykorzystuje statusów nieważności - podanie parametru było konieczne po to, aby zmienić wartości domyślne ustalone w sekcji MEVAS.

Czas danych

Dane inne niż D28 są przekazywane przez drajwer do systemu Asix wraz z czasem otrzymanym ze stacji MEVAS w trakcie realizacji żądania przygotowania przez stację MEVAS nowych danych do odczytu. Częstość wysyłania żądania jest określona parametrami Odswiez1,..., Odswiez10.

Dla danych D28 (całki), stacja MEVAS przesyła zestaw maks. 52 wartości. Każda z tych wartości opatrzona jest własnym czasem, który zazwyczaj ma postać hh:59 (dla 1 godzinnego cyklu całkowania). Czas ten jest przez drajwer zaokrąglany w górę do pełnej godziny. Zaokrąglanie można wyłączyć za pomocą parametru Zaokr_28. Zakres zaokrąglania definiuje parametr Czas_Zokr_28.

Chociaż każda dana D28 posiada swój własny czas, to również w przypadku tego typu zmiennych wymagane jest wysyłanie do stacji MEVAS żądania przygotowania nowych danych, i jeśli parametr Odswiez1 ma wartość 0,0 to parametr Oswiez5 musi mieć wartość niezerową w celu prawidłowego odczytu danych (także historycznych).

Definiowanie zmiennych

Definicja zmiennej opiera się na opisie protokołu MEVAS.

Wykaz wszystkich typów zmiennych podano na końcu.

nazwa[.arg1[.arg2[.arg3]]]

gdzie:

argn - może być: liczbą, liczbą poprzedzoną tekstem lub tekstem.

Nawiasy [ i ] obejmują części które mogą być nieobecne w definicji zmiennej.

Nazwa zmiennej może być numerem wartości opisanej w odpowiednim zapytaniu (typu D) protokołu komunikacji z systemem MEVAS. Numer może być poprzedzony literą D. Zmienne określające dane pozostałych zapytań protokołu są numerami poprzedzonymi typem zapytania tj. X1 do X5 i S1 do S5.

Zapis <n..m> oznacza wartość liczbową z zakresu od n do m. Kreska pionowa "|" oznacza, że można wybrać jeden z tekstów po obu stronach kreski.

W poniższej tabeli umieszczono wszystkie typy zmiennych. Kolumna Numer parametru 'Odswiez’ określa, który z parametrów od Odswiez2 do Odswiez10 dotyczy danej zmiennej. Parametr Odswiez1 dotyczy wszystkich zmiennych. Wartością zmiennych od X1 do X10 jest czas przygotowania określonej grupy danych przez stację MEVAS w wyniku ostatnio przesłanego żądania. Zapis jakiejkolwiek wartości do tych zmiennych powoduje przesłanie do stacji MEVAS żądania przygotowania nowych danych do odczytu.

Jeśli kolumna Status zawiera Tak, to dana zmienna jest przekazywana do systemu Asix ze statusem określonym parametrem Statusy_niewaznosci. Taka zmienna jest udostępniana przez stację MEVAS razem ze statusem określonym protokołem. Status ten jest konwertowany na wartość numeryczną j porównywany z wartościami określonymi parametrem Statusy_niewaznosci. Jeśli wartość przekonwertowanego statusu jest zgodna z jedną z wartości określonej parametrem Statusy_niewaznosci, to dana jest traktowana jako nieważna. Dana ze statusem 13 (brak danych) jest zawsze traktowana jako nieważna.

Tabela. Format nazwy zmiennych dla drajwera MEVAS.

Tabela. Format nazwy zmiennych dla drajwera MEVAS (c.d.).

Tabela. Format nazwy zmiennych dla drajwera MEVAS (c.d.).

Tabela. Wykaz statusów danych.

Dane historyczne

Dostęp do danych historycznych jest możliwy dla typu D28. Dostępne są dane od początku bieżącej doby (maksymalnie 52 wartości). Dane za ostatnią godzinę poprzedniej doby są dostępne tylko w okresie 23:59-00:05 (około). Oznacza to, że przerwa w komunikacji w tym okresie powoduje bezpowrotną utratę wartości za ostatnią godzinę doby. Bieżącą wartość danej (całki) należy pozyskiwać wykorzystując zmienną D28 z parametrem Wnr1.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MicroSmart - drajwer do wymiany danych ze sterownikami

Home > 1.64 MicroSmart - drajwer do wymiany danych ze sterownikami MicroSmart firmy IDEC

1.64 MicroSmart - drajwer do wymiany danych ze sterownikami MicroSmart firmy IDEC

Przeznaczenie drajwera

Drajwer protokołu MicroSmart jest wykorzystywany do wymiany danych ze sterownikami MicroSmart firmy IDEC.

Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix. Współpraca systemu Asix ze sterownikiem MicroSmart nie wymaga ingerencji w program sterownika.

Parametryzacja drajwera MicroSmart realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MicroSmart wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MicroSmart

Zakładka MicroSmart:

Numer urządzenia w sieci - liczba z przedziału 0-31 lub 255; numer 255 można wykorzystać, gdy do portu podłączone jest tylko urządzenie

Port - nazwa portu szeregowego (COM1 ... COM256)

Prędkość transmisji w bodach

Liczba bitów znaku

Kontrola parzystości - typ kontroli parzystości:

- brak kontroli

- kontrola parzysta

- kontrola nieparzysta

- mark

- space

Liczba bitów stopu - wartości: 1; 1.5; 2

Parametry Prędkość transmisji w bodach, Liczba bitów znaku, Kontrola parzystości, Liczba bitów stopu są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

prędkość transmisji - 9600,

liczba bitów w znaku - 7,

typ kontroli parzystości - kontrola parzystości,

liczba bitów stopu - 1

PRZYKŁAD

Przykładowa deklaracja kanału:

Nazwa: MicroSmart

Drajwer: MicroSmart

Numer urządzenia w sieci: 5

Port: COM1

Adresacja zmiennych procesowych

Składnia adresu symbolicznego dla zmiennych należących do kanału MicroSmart jest następująca:

typ_zmiennejindeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w sterowniku;

indeks_zmiennej - indeks zmiennej w ramach danego typu; w przypadku bloków danych jest to numer słowa w bloku danych.

Dozwolone są następujące oznaczenia typów zmiennych procesowych:

Q - stan pojedynczego wejścia

QB - stany wyjść przekazywane w bajtach,

QW - stany wyjść przekazywane w słowach,

I - stan pojedynczego wejścia,

IB - stany wejść przekazywane w bajtach,

IW - stany wejść przekazywane w słowach,

M - stan pojedynczego znacznika (flagi),

MB - stany znaczników (flag) przekazywane w bajtach,

MW - stany znaczników (flag) przekazywane w słowach,

R - stan pojedynczego bitu rejestru przesuwnego,

RB - stany rejestrów przesuwnych przekazywane w bajtach,

RW - stany rejestrów przesuwnych przekazywane w słowach,

T - stan zegara jako bajt o wartości:

0 - gdy zegar odmierza czas

1 - gdy zegar zakończył odmierzanie czasu (timeout)

TC - wartości bieżące zegarów przekazywane w słowach,

TP - wartości nastawcze zegarów przekazywane w słowach,

TS - bajty statusowe zegarów

TPVCS - bajt o wartości 1 gdy wartość nastawcza zegara została zmieniona i 0 w przeciwnym wypadku

C - stan licznika jako bajt o wartości:

0 - gdy licznik zlicza

1 - gdy licznik zakończył odliczanie (countout)

CC - wartości bieżące liczników przekazywane w słowach,

CP - wartości nastawcze liczników przekazywane w słowach,

CS - bajty statusowe liczników

CPVCS - bajt o wartości 1 gdy wartość nastawcza licznika została zmieniona i 0 w przeciwnym wypadku

D - słowo danych

DD - podwójne słowo danych

E - kod błędu jako słowo (indeks może mieć wartości z zakresu 0-5)

PRZYKŁADY

M0003 - znacznik numer 3

MB0005 - bajt zawierający 8 kolejnych znaczników począwszy od znacznika 0005

T1 - stan zegara nr 1

CPVCS7 - bajt określający czy wartość nastawcza licznika 7 została zmieniona

UWAGA
Ostatnia cyfra indeksu zmiennych I,IB,IW,Q,QB,QW,M,MB,MW jest cyfrą oktalną.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MODBUS - drajwer protokołu MODBUS/RTU tryb MASTER

Home > 1.65 MODBUS - drajwer protokołu MODBUS/RTU tryb MASTER

1.65 MODBUS - drajwer protokołu MODBUS/RTU tryb MASTER

Przeznaczenie drajwera

Drawjer MODBUS jest wykorzystywany do wymiany danych ze sterownikami lub urządzeniami wykorzystującymi protokół MODBUS. Transmisja realizowana jest łączami szeregowymi przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix. Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu MODBUS nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych z systemem Asix. Przy implementacji protokołu MODBUS wykorzystano tryb RTU, dający większą przepustowość łącza.

Drajwer MODBUS ma zaimplementowane następujące typy danych:

HR (holding registers),

IR (input registers),

CS (coil status),

IS (input status).

Od wersji Modbus 1.24.1.1 dodano cztery nowe typy 64-bitowe (do obsługi liczb typu double i int64 przekazywanych na czterech rejestrach HR):

HRD - double (najstarszy HR zawiera najstarsze bity liczby)

HRI - int64 (najstarszy HR zawiera najstarsze bity liczby)

HRDM - double (najmłodszy HR zawiera najstarsze bity liczby)

HRIM - int64 (najmłodszy HR zawiera najstarsze bity liczby)

Od wersji Modbus 2.1.0.1 dodano nowy typ:

UDC, służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

UWAGA: Do poprawnego wyłuskiwania zmiennych 64-bitowych z telegramów drajwera wymagany jest Asmen w wersji >= 5.2.

Drajwer MODBUS ma zaimplementowane następujące funkcje protokołu MODBUS:

Read Coil Status (funkcja 01),

Read Input Status (funkcja 02),

Read Holding Registers (funkcja 03),

Read Input Registers (funkcja 04),

Force Single Coil (funkcja 05),

Preset SingleRegister (funkcja 06),

Force Miltiple Coils (funkcja 15),

Preset Multiple Registers (funkcja 16).

Parametryzacja drajwera MODBUS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer MODBUS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MODBUS

Alarm w kanale: nr alarmu zgłaszanego w przypadku zerwania połączenia ze sterownikiem;

Zakładka MODBUS / Parametry kanału:

Identyfikacja:

- Identyfikator urządzenia (slave id)

Parametry transmisji:

- Port - nazwa portu szeregowego (COM1 ... COM256)
- Prędkość transmisji w bodach
- Liczba bitów w znaku - 4; 5; 6; 7; 8
- Kontrola parzystości - typ kontroli: brak, parzystość, nieparzystość
- Liczba bitów stopu - 1; 2

Urządzenie:

- Maksymalna liczba wejść/wyjść, których stan może być przekazany

przez urządzenie w ramach jednego cyklu
- Maksymalna liczba rejestrów, których stan może być przekazany przez

urządzenie w ramach jednego cyklu

Tryb ASCII:

- Włącz obsługę trybu ASCII dla tego urządzenia;

Zapis przy użyciu funkcji 'Write Multiple Register's':

- Zapisuj rejestry przy użyciu funkcji nr 16 (Preset Multiple Registers') zamiast funkcji nr 6 (Preset Single Register) - opcja została wprowadzona, aby umożliwić zapis w miernikach serii N30 firmy LUMEL (firmware tych mierników ma zaimplementowaną wyłącznie funkcję 16); domyślnie zapis realizowany jest przy użyciu funkcji nr 6 (Preset Single Register)

Parametry body, znak, parzystość, stop, max_we/wy, max_rej i bufor są parametrami opcjonalnymi.

W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola parzystości,

  • liczba bitów stopu - 1,

  • domyślna liczba we/wy - 16,

  • domyślna liczba rejestrów - 4.

Poniżej podana jest przykładowa deklaracja użycie kanału transmisji pracującego według protokołu MODBUS:

Nazwa/Kanał: CHAN1

Drajwer: MODBUS

Identyfikator urządzenia: 2

Port: COM1

Prędkość transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: parzystość

Liczba bitów stopu: 1

Maksymalna liczba wej/wyj: 40

Maksymalna liczba rejestrów: 16

Adresacja zmiennej

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych należących do kanału MODBUS:

TYP_ZMIENNEJ indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w protokole MODBUS,

indeks_zmiennej - indeks zmiennej w ramach danego typu.

Dozwolone są następujące oznaczenia typów zmiennych procesowych:

CS - Coil Status (0X reference)

IS - Input Status (1X reference)

HR - Holding Register (4X reference)

IR - Input Register (3X reference)

HRL - 2 kolejne Holding Registers traktowane jako podwójne słowo w formacie INTELA

HRF - 2 kolejne Holding Registers traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

HRLM - 2 kolejne Holding Registers traktowane jako podwójne słowo w formacie MOTOROLI,

HRFM - 2 kolejne Holding Registers traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI,

IRL - 2 kolejne Input Registers traktowane jako podwójne słowo w formacie INTELA,

IRF - 2 kolejne Input Registers traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

IRLM - 2 kolejne Input Registers traktowane jako podwójne słowo w formacie MOTOROLI,

IRFM - 2 kolejne Input Registers traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI.

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

ES - (bez parametru) - służy do odczytu tzw. "Exception Status' (wartość typu BYTE zwracana przez funkcję 07 protokołu Modbus). Do zastosowania w sterownikach obsługujących funkcję 07 protokołu Modbus.

Przykłady

CS22 - Coil 22

IS197 - Input 197

HR118 - Holding Register 118

IR25 - Input Register 25

Drajwer MODBUS jest ładowany automatycznie jako DLL.

Ze względu na pojawienie się sterowników używających 32-bitowych rejestrów drajwer MODBUS został rozszerzony o obsługę 32-bitowych rejestrów HR i IR:

HR32L - 32-bitowy rejestr HR typu DWORD (wymaga funkcji przeliczającejbazującej na DWORD, np. NIC_DW );

HR32F - 32-bitowy rejestr HR typu FLOAT (wymaga funkcji przeliczającej

bazującej na FLOAT, np. NIC_FP );

IR32L - 32-bitowy rejestr typu DWORD (wymaga funkcji przeliczającej

bazującej na DWORD, np. NIC_DW );

IR32F - 32-bitowy rejestr typu FLOAT (wymaga funkcji przeliczającej

bazującej na FLOAT, np. NIC_FP ).

Przykład

X1, rejestr HR nr 10 jako DWORD, HR32L10, KANAL32, 1, 1, NIC_DW

X2, rejestr IR nr 20 jako FLOAT, IR32F20, KANAL32, 1, 1, NIC_FP

Parametry drajwera MODBUS

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera Modbus, na zakładkach Modbus / Parametry drajwera, Modbus / Parametry drajwera 2, Modbus / Parametry drajwera - diagnostyka.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera MODBUS oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer MODBUS. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - brak.

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 1 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych i odbieranych przez drajwer MODBUS w ramach odczytu/zapisu zmiennych procesowych. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się treści telegramów do pliku logu.

R Liczba powtórzeń

Znaczenie - opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie opcja przyjmuje wartość 3.

R Zwłoka transmisji

Znaczenie - opcja pozwala zadeklarować odstęp czasu pomiędzy zakończeniem odbioru odpowiedzi i wysłaniem kolejnego zapytania do urządzenia zdalnego. Maksymalna wartość tej opcji wynosi 55 milisekund.

Wartość domyślna - domyślnie opcja przyjmuje wartość równą czasowi transmisji 3,5 znaków.

R Zwłoka po braku odpowiedzi

Znaczenie - opcja służąca do blokowania zapytań w kanale na okres liczony w milisekundach, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi. W okresie blokowania zapytań wszystkie polecenia kierowane do drajwera kończone są ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie).

Wartość domyślna - domyślnie wartość wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi.

R Odczyt blokowy

Znaczenie - opcja umożliwia ustawienie trybu pracy, w którym wartości rejestrów i cewek są odczytywane pojedynczo (nie jest używana funkcja blokowego odczytu danych). Obowiązuje on dla WSZYSTKICH zmiennych obsługiwanych przez drajwer.

Wartość domyślna - domyślnie wartości zmiennych z każdego slave’a są czytane w trybie blokowym.

Parametry:

- TAK dla wszystkich

- NIE dla wszystkich

- Dla wybranych

R Maksymalny czas operacji odbioru

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście pierwszego znaku odpowiedzi z określonego urządzenia zdalnego. Po upływie tego czasu uznaje się, że przedmiotowe urządzenie nie funkcjonuje poprawnie i seans transmisji zostaje zakończony z błędem.

Wartość domyślna - przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund.

Parametry:

nr_slave’a - nr slave'a znajdującego się w deklaracji kanału transmisji, korzystającego z protokołu MODBUS;

timeout - liczba z zakresu 100 - 65000 milisekund.

Przykład

Timeout odbioru: 2,400

R Maksymalny czas oczekiwania na nadejście kolejnego znaku

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście kolejnego znaku odpowiedzi z określonego urządzenia zdalnego. Po upływie tego czasu uznaje się, że przedmiotowe urządzenie nie funkcjonuje poprawnie i seans transmisji zostaje zakończony z błędem.

Wartość domyślna - przyjmuje się, że maksymalny czas oczekiwania na kolejny znak odpowiedzi wynosi 100 milisekund.

Parametry:

nr_slave’a - nr slave'a znajdującego się w deklaracji kanału transmisji, korzystającego z protokołu MODBUS;

timeout - liczba z zakresu 10 - 2000 milisekund.

Przykład

Timeout znaku: 2,400

R Nie używaj modułu AsComm do nawiązywania połaczeń

Znaczenie - opcja określa użycie modułu AsComm do nawiązywania połączeń dla drajwera MODBUS.

Wartość domyślna - domyślnie opcja przyjmuje wartość NIE - to znaczy, że do nawiązywania połączeń używany jest moduł AsComm.

Połączenie za pomocą modemu

PRZYKŁAD

Protokół MODBUS może również wymieniać dane za pomocą połączenia modemowego.

Kanał drajwera MODBUS jest klientem serwera AsComm o nazwie MODBUS:n, gdzie n jest numerem portu szeregowego pobranym z definicji kanału ASMENa,

np. jeśli nazwa_kanalu=modbus,4,com3,...

to nazwą klienta będzie MODBUS:3.

Aby protokół MODBUS nawiązywał połączenia na łączach komutowanych za pośrednictwem programu AsComm, należy w parametrach kanału wykorzystującego drajwer Modbus (kanału zadeklarowanego w module Dane bieżące programu Architekt) - na zakładce Klient serwera AsComm włączyć parametr Linia komutowana.

Jeśli modem jest przyłączony do innego portu niż COMn, to należy podać numer tego portu za pomocą parametru Port modemu lub określić nazwę modemu za pomocą parametru Nazwa modemu. Należy również podać numer telefoniczny oraz określić inne wymagane parametry. Jeśli drajwer MODBUS ma komunikować się z wieloma sterownikami za pomocą tego samego modemu, to należy zdefiniować odpowiednią ilość kanałów traktując parametr Port modemu jako nazwę wirtualną kanału transmisji, oraz dla każdego kanału określić odpowiedni numer telefoniczny.

PRZYKŁAD

Przykład zawartości pliku konfiguracyjnego.

Deklaracje kanałów:

Nazwa: Kanal1

Drajwer: MODBUS

Identyfikator urządzenia: 1

Port: COM11

Prędkośc transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: none

Liczba bitów stopu: 1

Maksymalna liczba we/wy: 16

Maksymalna liczba rejestrów: 16

Deklaracja Kanału Kanal1 jako klienta serwera AsComm:

Linia komutowana / Używaj modemu do nawiązania połączenia - załączona

Zdefiniuj modem poprzez nazwę: US Robotics

Numer telefonu: 11111111

Nazwa: Kanal2

Drajwer: MODBUS

Identyfikator urządzenia: 1

Port: COM12

Prędkośc transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: none

Liczba bitów stopu: 1

Maksymalna liczba we/wy: 16

Maksymalna liczba rejestrów: 16

Deklaracja Kanału Kanal1 jako klienta serwera AsComm:

Linia komutowana / Używaj modemu do nawiązania połączenia - załączona

Zdefiniuj modem poprzez nazwę: US Robotics

Numer telefonu: 22222222

W powyższym przykładzie Kanal1 będzie komunikował się ze sterownikiem znajdującym się pod numerem telefonicznym 11111111, a Kanal2 ze sterownikiem znajdującym się pod numerem telefonicznym 22222222. Zostanie wykorzystany modem US Robotics. Parametr Nazwa modemu można zastąpić parametrem Port modemu określającym numer portu szeregowego, do którego przyłączony jest modem.

Należy zwrócić uwagę, że powyższy opis wykorzystania drajwera MODBUS na łączach komutowanych nie obejmuje parametryzacji modemu. Parametryzacja modemu zależy od typów wykorzystywanych modemów.

Parametry kanału

Parametry kanału drajwera MODBUS deklarowane na zakładce Modbus / Parametry kanału 2:

R Maksymalny czas operacji odbioru

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście pierwszego znaku odpowiedzi z określonego urządzenia zdalnego. Po upływie tego czasu uznaje się, że przedmiotowe urządzenie nie funkcjonuje poprawnie i seans transmisji zostaje zakończony z błędem.

Parametry:

timeout - liczba z zakresu 100 - 65000 milisekund.

Wartość domyślna - przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund. Jeśli parametr został zadeklarowany w opcjach drajwera, to zamiast wartości domyślnej zostanie użyta wartość opcji z parametrów drajwera.

R Maksymalny czas oczekiwania na nadejście kolejnego znaku

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście kolejnego znaku odpowiedzi z określonego urządzenia zdalnego. Po upływie tego czasu uznaje się, że przedmiotowe urządzenie nie funkcjonuje poprawnie i seans transmisji zostaje zakończony z błędem.

Parametry:

timeout - liczba z zakresu 10 - 2000 milisekund.

Wartość domyślna - przyjmuje się, że maksymalny czas oczekiwania na kolejny znak odpowiedzi wynosi 100 milisekund. Jeśli parametr został zadeklarowany w opcjach drajwera, to zamiast wartości domyślnej zostanie użyta wartość opcji z parametrów drajwera.

R Zwłoka transmisji

Znaczenie - opcja pozwala zadeklarować odstęp czasu pomiędzy zakończeniem odbioru odpowiedzi i wysłaniem kolejnego zapytania do urządzenia zdalnego.

Wartość domyślna - wartość opcji o tej samej nazwie w sekcji drajwera.

R Zwłoka po braku odpowiedzi

Znaczenie - opcja służąca do blokowania zapytań w kanale na okres liczony w milisekundach, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi. W okresie blokowania zapytań wszystkie polecenia kierowane do drajwera kończone są ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie). Opcja przeciąża wartość identycznej opcji zadeklarowanej w opcjach drajwera.

Wartość domyślna - domyślnie wartość wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne danego kanału drajwera MODBUS oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer MODBUS przez dany kanał. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - wartość pobierana z ustawień analogicznego parametru z parametrów drajwera.

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: wartość pobierana z ustawień analogicznego parametru z parametrów drajwera.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów wysyłanych i odbieranych przez drajwer MODBUS w ramach odczytu/zapisu zmiennych procesowych. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - wartość pobierana z ustawień analogicznego parametru z parametrów drajwera.

R Odczyt blokowy

Znaczenie - opcja umożliwia ustawienie trybu pracy, w którym wartości rejestrów i cewek są odczytywane pojedynczo (nie jest używana funkcja blokowego odczytu danych). Obowiązuje on dla WSZYSTKICH zmiennych obsługiwanych przez drajwer w danym kanale.

Wartość domyślna - wartość pobierana z ustawień analogicznego parametru z parametrów drajwera.

Parametry:

- TAK dla wszystkich

- NIE dla wszystkich

- Dla wybranych

Dodatkowa parametryzacja kanału transmisji

Parametr deklarowany przy użyciu osobnej sekcji, której nazwa jest identyczna z nazwą kanału transmisji - parametr należy umieścić w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: OKRES_ZMIENNEJ_KONTROLNEJ
R Wartość opcji: liczba_sekund

Znaczenie - pozycja zmienia okres odczytu zmiennej kontrolnej - użycie pozycji ma sens w przypadku łączy, za których wykorzystanie ponosi się opłaty.

Wartość domyślna - domyślnie okres odczytu zmiennej definiowany jest w bazie definicji zmiennych.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MODBUS_TCPIP - drajwer protokołu MODBUS_TCP/IP wg

Home > 1.66 MODBUS_TCPIP - drajwer protokołu MODBUS_TCP/IP wg standardu OPEN MODBUS/TCP

1.66 MODBUS_TCPIP - drajwer protokołu MODBUS_TCP/IP wg standardu OPEN MODBUS/TCP

Przeznaczenie drajwera

Drajwer MODBUS_TCPIP jest przeznaczony do wymiany danych pomiędzy systemem Asix i innymi komputerami/urządzeniami za pomocą protokołu MODBUS, zrealizowanego w oparciu o sieć Ethernet z protokołem TCP/IP. Domyślnym trybem działania drajwera MODBUS_TCPIP jest tryb Open Modbus/TCP, opracowany na podstawie specyfikacji 'OPEN MODBUS/TCP Specification' Release 1.0, wydanej 29.03.1999 przez firmę Schneider Elektric. Drajwer pozwala na jednoczesną realizacje trybu SLAVE oraz trybu MASTER.

Parametryzacja drajwera MODBUS_TCPIP realizowana jest przy użyciu programu Architekt.

Tryb SLAVE

Tryb SLAVE polega na realizacji poleceń zapisu i odczytu zmiennych ASMENa nadesłanych z innych komputerów/urządzeń, pełniących w sieci MODBUS funkcję MASTER. Możliwa jest jednoczesna obsługa wielu komputerów pełniących funkcję MASTER.

Zmienne ASMENa są udostępniane w trybie SLAVE jako zmienne MODBUSa należące do jednego z niżej wymienionych typów:

  • CS (coil statuses),

  • HR (holding registers),

  • IR (input registers).

Deklaracje przypisania (mapowania) zmiennych ASMENa zmiennym MODBUSa są umieszczane przez projektanta aplikacji w plikach tekstowych, które są odczytywane przez drajwer na etapie startu systemu Asix - przykład w dalszej części rozdziału.

Dodano również typ UDC - który służy do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika, dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

Dla odczytu zmiennych ASMENa zaimplementowano następujące funkcje protokołu MODBUS:

  • Read Coil Statuses (funkcja 01),

  • Read Holding Registers (funkcja 03),

  • Read Input Registers (funkcja 04).

Dla zapisu zmiennych ASMENa zaimplementowano następujące funkcje protokołu MODBUS:

  • Preset Single Coil (funkcja 05),

  • Preset SingleRegister (funkcja 06),

  • Return Query Data (funkcja 08, subfunkcja 00 00)[1]

  • Preset Multiple Coils (funkcja 15),

  • Preset Multiple Registers (funkcja 16).

-------------------------------------------------------------------------------

[1] Obsługa przedmiotowej funkcji jest wymagana do współpracy ASIXA (w trybie MODBUS SLAVE) z systemem Symphony (ABB).

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MODBUS_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MODBUS_TCPIP

Zakładka MODBUS_TCPIP:

Zakładka Tryb: - Slave

Zakładka Parametry kanału:

Numer portu TCP wykorzystywanego przez aplikację Asix

Numer aplikacji Asix w sieci Modbus

UWAGA Można zadeklarować tylko jeden kanał transmisji realizujący tryb SLAVE.

Parametry trybu SLAVE

Parametry drajwera deklarowane są w module Dane bieżące, w definicji kanału działającego wg protokołu drajwera MODBUS_TCPIP, na zakładce MODBUS_TCPIP / Parametry drajwera przy włączonym trybie Slave (zakładka MODBUS_TCPIP /Tryb).

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Adres IP

Znaczenie - adres IP komputera, przez który drajwer komunikuje się ze sterownikiem.

Wartość domyślna - domyślnie drajwer korzysta z adresu IP dostarczonego przez system Windows.

Odświeżanie zmiennych udostępnianych przez drajwer

Drajwer może stosować jedną z dwóch strategii odnośnie obsługi zmiennych eksportowanych z systemu Asix.

Strategia I (domyślna) zakłada, że wszystkie zmienne, których nazwy zostały zadeklarowane w plikach z deklaracjami mapowań są cyklicznie odczytywane przez osobny wątek drajwera z cache’a ASMENa i umieszczane w ogólnodostępnym buforze drajwera. Wątki robocze obsługujące połączenia z klientami budują telegramy odpowiedzi bazując na zawartości tego bufora, bez konieczności odwoływania się do API ASMEN’a.

Okres odczytu z cache’a ASMENa do ogólnodostępnego bufora drajwera jest parametryzowany przy użyciu opcji:

R Okres aktualizacji bufora danych

Znaczenie - pozwala zadeklarować okres odczytu z cache’a ASMENa do ogólnodostępnego bufora drajwera.

Wartość domyślna - domyślnie okres odczytu wynosi 1 sekundę.

Parametr:

liczba - okres odczytu z cache’a ASMENa w sekundach.

Strategia II (opcja) zakłada, że każdy wątek roboczy samodzielnie pobiera dane z cache’a ASMENa w reakcji na zapytania przesłane przez klienta. W efekcie wątek roboczy odczytuje z cache’a ASMENa wyłącznie te dane, które są w danej chwili żądane przez klienta.

Strategia II powinna być również aktywowana w przypadku, gdy system Asix będzie korzystać z drajwera wyłącznie w celu importu danych z innego systemu. W takim trybie cykliczne odświeżanie zawartości buforów drajwera nie ma sensu.

Strategia II jest uaktywniana przy pomocy opcji:

R Odczyt na życzenie

Wartości zmiennych znajdujących się w cache’u ASMENa w chwili realizacji polecenia odczytu mogą być nieaktualne, ponieważ w okresie poprzedzającym zapytanie klienta odświeżanie przedmiotowych zmiennych mogło nie być aktywne (system Asix został dopiero uruchomiony lub też żaden z klientów ASMENa nie był zainteresowany odświeżaniem tych zmiennych). Z tego względu wątek przygotowujący przesyłkę dla klienta będzie sprawdzał stempel czasu aktualnie udostępnianych wartości zmiennych. Jeśli wartość stempla czasu nie będzie się mieściła w zakresie okresu_wiarygodności określonym w deklaracji mapowania zmiennej, to wątek odczyta wartość zmiennej bezpośrednio z drajwera i dopiero wtedy odeśle odpowiedź do klienta.

Domyślnie drajwer realizuje strategię I z częstością aktualizacji zawartości ogólnodostępnego bufora wynoszącą 1 sekundę.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera w trybie SLAVE oraz informacje o zawartości telegramów odebranych/wysłanych przez drajwer w tym trybie. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa pliku

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem pracującym w trybie SLAVE i klientami sieciowymi. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie drajwer nie wpisuje do pliku logu treści telegramów.

R Rozmiar pliku logu

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Deklaracja trybu pracy MODBUS RTU

Znaczenie - obsługa stacji działających wg specyfikacji 'MODBUS RTU' wymaga użycia opcji.

Parametry:

Adres IP - adres stacji pełniącej rolę mastera;

OVATION

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

R Adres IP z opcją Tylko do odczytu

Znaczenie - do systemu Asix mogą się dołączyć wyłącznie ci klienci, którzy posiadają zezwolenie na dostęp.

Wartość domyślna - domyślnie każdy klient ma możliwość odczytu i zapisu zmiennych systemu Asix. Istnieje możliwość ograniczenia uprawnień klientów wyłącznie do odczytu zmiennych poprzez użycie opcji Tylko do odczytu.

W takiej sytuacji próba zapisu jest kwitowana wysłaniem telegramu odpowiedzi typu exception z kodem 1, oznaczającym nielegalną funkcję.

Parametry:

Adres IP - adres IP klienta akceptowanego przez drajwer,

Tylko do odczytu - opcja zezwalająca klientowi wyłącznie na odczyt danych.

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

Liczba deklaracji klientów jest nieograniczona.

PRZYKŁAD

Deklaracja klienta o adresie IP 10.10.10.84 z nieograniczonymi prawami dostępu do systemu Asix:

Adres IP: 10.10.10.84

R Timeout połączenia deklarowany dla danego Adresu IP klienta

Znaczenie - dla każdego dołączonego klienta deklaruje się maksymalny czas, jaki może upłynąć pomiędzy kolejnymi zapytaniami ze strony klienta (tzw. timeout połączenia). Po przekroczeniu timeout’u połączenie z klientem jest zrywane. W przypadku klientów, dla których nie zostanie podana deklaracja time-out’u połączenia, domyślnie przyjmowana będzie wartość 5 minut.

Parametry:

Adres IP - adres IP klienta,

Timeout - wartość timeout’u wyrażona w minutach.

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

PRZYKŁAD

Deklaracja timeout’u połączenia wynoszącego 10 minut dla klienta o adresie IP 10.10.10.84 :

Timeout połączenia:

Adres IP: 10.10.10.84

Timeout: 10

R Przekazywanie statusu zmiennych w osobnych rejestrach i cewkach

Znaczenie - protokół MODBUS nie operuje pojęciem statusu w odniesieniu do przekazywanych wartości rejestrów oraz stanu cewek. Z tego powodu przekazywanie statusu można dołączyć jedynie w sposób sztuczny do standardowej przesyłki MODBUSa. Przedmiotowy drajwer może przekazać status zmiennej Asixa umieszczając go w kolejnym elemencie następującym za elementem, zawierającym wartość zmiennej. Dla rejestrów jest to kolejny rejestr, dla cewek - kolejna cewka. W przypadku rejestrów przestrzeń dla przekazania statusu jest wystarczająca (16 bitów), dla cewek status musi być ograniczony do dwóch stanów (0 - dobry , 1 - zły).

Przykładowo, jeśli wartość zmiennej jest przekazywana jako rejestr 10, to status jest przekazywany jako rejestr 11. Jeśli stan cewki jest przekazywany na bicie 5, to status cewki jest przekazywany na bicie 6.

Użyta metoda pozwala przesłać wartość zmiennej oraz jej status w tym samym telegramie, zapewniając spójność danych.

Tryb przekazywania statusu jest deklarowany indywidualnie dla każdego klienta, oddzielnie dla rejestrów i cewek. Deklaracje umożliwiają:

- przekazywanie statusu rejestrów,

- przekazywanie statusu cewek.

Wartość domyślna - domyślnie status nie jest przekazywany ani dla rejestrów, ani dla cewek

Parametry:

Adres IP - adres IP klienta,

Status rejestrów - przekazywanie statusu rejestrów,

Status cewek - przekazywanie statusu cewek.

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

R Przekazywanie statusu zmiennych bez użycia osobnych rejestrów lub cewek

Znaczenie - w przypadku pracy bez przekazywania statusów w osobnych rejestrach lub cewkach pojawia się problem przekazania informacji o tym, że wartość zmiennej jest nieważna (np. błędy komunikacji ze źródłem danych). Przyjęto konwencję, w myśl której będzie możliwe deklarowanie wartości, przekazywanej w przypadku niepoprawnego statusu dla rejestrów (domyślnie 0xffff ).

Parametry:

Adres IP - adres IP klienta;

Status błędu rejestrów - wartość 16-bitowa (HEX), przekazywana w przypadku niepoprawnego statusu zmiennej.

UWAGA W przypadku cewek, ze względu na dwustanowy charakter zmiennej, nie ma możliwości przekazania informacji o statusie w taki sposób, aby odróżniała się ona od poprawnej wartości zmiennej. Z tego też względu należy przejąć jako zasadę, że w trybie pracy bez przekazywania statusów należy używać rejestry.

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

R Deklaracje mapowania zmiennych MODBUSa na zmienne Asmena

Ze względu na to, że protokół MODBUS nie posługuje się nazwami zmiennych, ale numerami rejestrów i cewek, konieczne jest przygotowanie plików konfiguracyjnych, mapujących zmienne MODBUSa na zmienne Asmena.

Deklaracja mapowania zmiennej MODBUSa na zmienną Asmena ma następującą postać:

nazwa_ASIXa, adres_MODBUSa [, okres_wiarygodności]

gdzie:

nazwa_ASIXa - nazwa zmiennej procesowej systemu Asix; musi mieć swój odpowiednik wśród nazw zmiennych procesowych deklarowanych w plikach ASMENa;

adres_MODBUSa - typ oraz indeks zmiennej MODBUSa, poprzez który będzie udostępniana wartość zmiennej procesowej; w zależności od typu zmiennej MODBUSa jej wartość jest przekazywana poprzez jeden bit, jeden rejestr (zmienna typu SHORT lub USHORT) lub dwa kolejne rejestry (zmienna typu FLOAT, LONG lub ULONG);

okres_wiarygodności - przedział czasu (w sekundach), w którym wartość zmiennej uznawana jest za poprawną. Jest on określany jako różnica czasu pomiędzy stemplem czasu zapytania od klienta i stemplem czasu aktualnie udostępnianej wartości zmiennej. Domyślnie 5 sekund.

Akceptowany format adresu MODBUSa jest następujący:

HR<nr_rej> lub IR<nr_rej> lub CS<nr_cewki>

gdzie:

nr_rej - liczba oznaczająca numer rejestru HR lub IR,

nr_cewki - liczba oznaczająca numer cewki,

Liczba rejestrów MODBUSa wykorzystywana do przesłania wartości zmiennej będzie ściśle skorelowana z typem zmiennej ASMENa:

- dla zmiennych typu WORD będzie to jeden rejestr lub jedna cewka,

- dla zmiennych typu INT16 będzie to jeden rejestr,

- dla zmiennych typu DWORD, LONG lub FLOAT będą to dwa rejestry;

lub w przypadku przesyłania statusów:

- dla zmiennych typu WORD będą to dwa rejestry lub dwie cewki,

- dla zmiennych typu INT16 będą to dwa rejestry,

- dla zmiennych typu DWORD, LONG lub FLOAT będą to trzy rejestry.

Poniżej podano sposób interpretacji zawartości rejestrów dla liczb FLOAT, LONG i ULONG MODBUSa:

Rysunek. Sposób interpretacji zawartości rejestrów dla liczb FLOAT drajwera MODBUS.

Rysunek. Sposób interpretacji zawartości rejestrów dla liczb LONG drajwera MODBUS.

Rysunek. Sposób interpretacji zawartości rejestrów dla liczb ULONG drajwera MODBUS.

PRZYKŁAD

W ASMENie zmienne X_WORD, X_INT, X_DWORD, X_LONG, X_FLOAT są zdefiniowane następująco:

X_WORD, ED120.2, KANAL1, 1, 1, NIC

X_INT, ED130.2, KANAL1, 1, 1, NIC_INT

X_DWORD, EL140.2, KANAL1, 1, 1, NIC_DW

X_LONG, EL150.2, KANAL1, 1, 1, NIC_LONG

X_FLOAT, EG160.2, KANAL1, 1, 1, NIC_FP

Mapowanie wartości tych zmiennych na ciągły obszar rejestrów zaczynający się od rejestru HR1 (bez przesyłania statusów) wygląda następująco:

X_WORD, HR1

X_INT, HR2

X_DWORD, HR3

X_LONG, HR5

X_FLOAT, HR7

Mapowanie wartości tych zmiennych na ciągły obszar rejestrów zaczynający się od rejestru HR1 (z przesyłaniem statusów) wygląda następująco:

X_WORD, HR1

X_INT, HR3

X_DWORD, HR5

X_LONG, HR8

X_FLOAT, HR11

Deklaracje mapowań zmiennych MODBUSa na zmienne ASMENa są umieszczane w plikach tekstowych. Lokalizację plików z deklaracjami mapowań określa się przy użyciu opcji:

R Deklaracja plików mapowania zmiennych MODBUSa na zmienne Asmena

Znaczenie - lokalizacja plików z deklaracjami mapowań.

Parametry:

Adres IP - adres IP klienta,

Plik mapowań - nazwa pliku zawierającego deklaracje mapowań.

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

Liczba opcji z deklaracjami plików mapowań jest nieograniczona.

***

Dodatkowe opcje deklarowane ręcznie za pomocą zakładki:

Architekt > Obszary i komputery > moduł Pozostałe > Opcje wprowadzane bezpośrednio:

R Deklaracja przekazywania znaczników czasu dla indywidualnego klienta

R Nazwa sekcji: MODBUS_TCPIP_SLAVE
R Nazwa opcji: ZNACZNIK_CZASU_REJESTROW_HR
R Wartość opcji: adres_IP

Znaczenie - przy pomocy tej opcji można zadeklarować dla każdego z klientów drajwera Modbus_tcpip z osobna przekazywanie znaczników czasu. Wartość opcji może być przeciążona dla dowolnej zmiennej z pliku mapowań poprzez użycie parametru BEZ_ZNACZNIKA_CZASU w deklaracji mapowanej zmiennej (w pliku mapowań). Możliwy jest również scenariusz, w którym nie będzie się korzystać z opcji ZNACZNIK_CZASU_REJESTROW_HR, natomiast dla wybranych zmiennych będzie się używać parametru ZNACZNIK_CZASU w deklaracji mapowanej zmiennej.

Znacznik czasu jest przekazywany jako liczba 32-bitowa zawierająca ilość sekund, które upłynęły od 01.01.1980 (w UTC). Drajwer umieszczać znacznik czasu w dwóch kolejnych rejestrach, znajdujących się za rejestrem (rejestrami) zawierającymi wartość (i ew. status) mapowanej zmiennej. Młodszy rejestr znacznika czasu zawiera bardziej znaczące 16-bitów znacznika czasu.

Wartość domyślna - domyślnie do klientów nie przekazuje się znacznika czasu.

Parametry:

Adres IP - adres IP klienta,

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

R Nazwa sekcji: MODBUS_TCPIP_SLAVE
R Nazwa opcji: STATUS_OPC
R Wartość opcji: adres_IP

Znaczenie - przy pomocy tej opcji można zadeklarować dla każdego z klientów drajwera Modbus_tcpip z osobna przekazywanie statusu w formacie OPC.

Wartość domyślna - domyślnie przyjmuje się, ze do klientów jest przekazywany status tworzony wg reguły:

status o.k. - 0

status !=0 - 1

Parametry:

Adres IP - adres IP klienta,

(UWAGA: Powiązanie pliku z adresem IP klienta ma na celu umożliwienie niezależnego sposobu mapowania poszczególnym klientom.)

Tryb MASTER

Tryb MASTER jest implementacją funkcji MASTER protokołu sieci MODBUS (w trybie RTU) opartej o Ethernet z protokołem TCP/IP.

Tryb MASTER ma zaimplementowane następujące typy danych:

CS - Coil Statuses,

CSBx - stan 8 kolejnych cewek począwszy od cewki nr x (typ BYTE),

CSDWx - stan 32 kolejnych cewek począwszy od cewki nr x (typ DWORD),

CSWx - stan 16 kolejnych cewek począwszy od cewki nr x (typ WORD),

IS - Input Statuses,

HR - Holding Registers,

IR - Input Registers,

HRL - 2 kolejne Holding Registers traktowane jako podwójne słowo w formacie INTELA,

HRF -2 kolejne Holding Registers traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

HRLM -2 kolejne Holding Registers traktowane jako podwójne słowo w formacie MOTOROLI,

HRFM - 2 kolejne Holding Registers traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI,

IRL - 2 kolejne Input Registers traktowane jako podwójne słowo w formacie INTELA,

IRF - 2 kolejne Input Registers traktowane jako liczba zmiennoprzecinkowa w formacie INTELA,

IRLM - 2 kolejne Input Registers traktowane jako podwójne słowo w formacie MOTOROLI,

IRFM - 2 kolejne Input Registers traktowane jako liczba zmiennoprzecinkowa w formacie MOTOROLI.

Od wersji Modbus_tcpip 2.2.1.5 dodano cztery nowe typy 64-bitowe (do obsługi liczb typu double i int64 przekazywanych na czterech rejestrach HR):

HRD - double (najstarszy HR zawiera najstarsze bity liczby)

HRI - int64 (najstarszy HR zawiera najstarsze bity liczby)

HRDM - double (najmłodszy HR zawiera najstarsze bity liczby)

HRIM - int64 (najmłodszy HR zawiera najstarsze bity liczby)

UWAGA: Do poprawnego wyłuskiwania zmiennych 64-bitowych z telegramów drajwera wymagany jest Asmen w wersji >= 5.2.

Dodano również typ UDC - który służy do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika, dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

Przykłady

CS22 - Coil 22

IS197 - Input 197

HR118 - Holding Register 118

IR25 - Input Register 25

oraz następujące funkcje protokołu MODBUS:

Read Coil Statuses (funkcja 01),

Read Input Statuses (funkcja 02),

Read Holding Registers (funkcja 03),

Read Input Registers (funkcja 04),

Preset Single Coil (funkcja 05),

Preset SingleRegister (funkcja 06),

Preset Multiple Registers (funkcja 16 ograniczona do zapisu pary rejestrów).

Drajwer MODBUS jest ładowany automatycznie jako DLL.

PRZYKŁADY deklaracji zmiennych

Nazwa: X4

Opis: stan 8-miu cewek począwszy od CS nr 7

Kanał: KANALX

Adres: CSB7

LiczbaElementow: 1

Okresprobkowania: 1

FunkcjaPrzeliczajaca: NIC_BYTE

Nazwa: X8

Opis: stan 16-miu cewek począwszy od CS nr 1

Kanał: KANALX

Adres: CSW1

LiczbaElementow: 1

Okresprobkowania: 1

FunkcjaPrzeliczajaca: NIC

Nazwa: X11

Opis: stan 32-ch cewek począwszy od CS nr 5

Kanał: KANALX

Adres: CSDW5

LiczbaElementow: 1

Okresprobkowania: 1

FunkcjaPrzeliczajaca: NIC_DW

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MODBUS_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MODBUS_TCPIP

Zakładka MODBUS_TCPIP:

Zakładka Tryb: - Master

Zakładka Parametry kanału: - Numer portu

- Adres IP komputera

- Numer urządzenia

- Max liczba dwustanów w jednym zapytaniu

- Max liczba rejestrów w jednym zapytaniu

Dla każdego urządzenia typu slave obsługiwanego w trybie MASTER będzie wymagana osobna deklaracja kanału transmisji.

Parametry trybu MASTER

Parametry trybu MASTER drajwera MODBU_TCPIP deklarowane są w module Dane bieżące na zakładce MODBU_TCPIP / Parametry drajwera, MODBU_TCPIP / Parametry drajwera 2, MODBU_TCPIP / Parametry drajwera - log kanału działającego według protokołu drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Adres IP

Znaczenie - adres IP, przez który drajwer komunikuje się ze sterownikiem.

Wartość domyślna - domyślnie drajwer korzysta z adresu IP dostarczonego przez system Windows.

R Czas rozbiegu

Nawiązywanie połączeń ze slave'ami jest realizowane na etapie rozbiegu drajwera. Domyślny czas trwania rozbiegu to 3 sekundy. Może być on modyfikowany przy pomocy opcji:

Znaczenie - czas rozbiegu drajwera, w czasie którego nawiązywane są połączenia ze slav’ami.

Wartość domyślna - 3 s.

Parametr:

Czas rozbiegu

R Zapis przy użyciu funkcji 'Preset Multiple Registers'

Znaczenie - Ustawienie funkcji na TAK powoduje, że zapis pojedynczego rejestru HR jest wykonywany funkcją 16 (a nie funkcją 6).

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R MODBUS RTU

Znaczenie - deklaracja pracy w trybie 'MODBUS RTU'; obsługa stacji działających wg specyfikacji 'MODBUS RTU'.

Parametry:

Adres IP klienta - adres IP urządzenia,

MODBUS RTU

R T imeout odbioru

Znaczenie - deklaracja timeout'u odbioru.

Wartość domyślna - w przypadku urządzeń, dla których nie zostanie podana deklaracja time-out’u odbioru, przyjmuje się domyślnie 5 sekund.

Parametry:

Adres IP klienta - adres IP urządzenia,

Timeout - wartość timeout’u wyrażona w sekundach.

R Zwłoka transmisji

Znaczenie - opcja wprowadza timeout liczba_milisekund pomiędzy zakończeniem odbioru i wysłaniem kolejnego zapytanie do urządzenia o adresie adres_ip.

Wartość domyślna - 0.

Parametr:

adres IP - adres IP urządzenia,

liczba milisekund

R Zwłoka po braku odpowiedzi

Znaczenie - opcja określa minimalny czas, jaki musi upłynąć przed wysłaniem kolejnego zapytania, jeśli bieżące zapytanie zakończyło się brakiem odpowiedzi.

Wartość domyślna - 0.

Parametr:

adres IP - adres IP urządzenia,

liczba sekund

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera generowane w trybie MASTER oraz informacje o zawartości telegramów wysłanych/odebranych przez drajwer w tym trybie. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametry:

nazwa pliku

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem pracującym w trybie MASTER i urządzeniami typu slave. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie drajwer nie wpisuje do pliku logu treści telegramów.

R Rozmiar pliku logu

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Dodatkowa parametryzacja kanału (tryb MASTER)

Indywidualne wartości parametrów kanału drajwera MODBU_TCPIP w trybie MASTER deklarowane są w module Dane bieżące na zakładce MODBU_TCPIP / Parametry kanału 2.

R Adres IP

Znaczenie - adres IP, przez który drajwer komunikuje się ze sterownikiem.

Wartość domyślna - domyślnie drajwer korzysta z adresu IP dostarczonego przez system Windows.

R Timeout odbioru

Znaczenie - maksymalny czas oczekiwania na odpowiedź ze sterownika.

Wartość domyślna - 5.

Parametr:

liczba - czas w sekundach

R Zapis przy użyciu funkcji 'Preset Multiple Registers'

Znaczenie - Ustawienie funkcji na TAK powoduje, że zapis pojedynczego rejestru HR jest wykonywany funkcją 16 (a nie funkcją 6).

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Zwłoka po braku odpowiedzi

Znaczenie - opcja określa minimalny czas, jaki musi upłynąć przed wysłaniem kolejnego zapytania, jeśli bieżące zapytanie zakończyło się brakiem odpowiedzi. Opcja przeciąża opcję o tej samej nazwie, zdefiniowaną w parametrach drajwera.

Wartość domyślna - 0.

Parametr:

liczba sekund

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera generowane w trybie MASTER oraz informacje o zawartości telegramów wysłanych/odebranych przez drajwer w tym trybie. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametry:

nazwa pliku

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem pracującym w trybie MASTER i urządzeniami typu slave. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie drajwer nie wpisuje do pliku logu treści telegramów.

R Rozmiar pliku logu

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

***

Dodatkowe opcje deklarowane ręcznie za pomocą zakładki:

Architekt > Obszary i komputery > moduł Pozostałe > Opcje wprowadzane bezpośrednio:

R Parametryzacja obsługi wyjątku Modbusa o numerze 6

Znaczenie - domyślne zachowanie drajwera polega na sygnalizowaniu wyjątku w panelu kontrolnym oraz ustawieniu status błędu zmiennym dołączonym do polecenia, na które drajwer otrzymał w odpowiedzi wyjątek nr 6. Zachowanie to można zmienić (dla każdego z kanałów drajwera z osobna) poprzez użycie nowych opcji.

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: LICZBA_POWTORZEN_PO_WYJATKU_NR_6
R Wartość opcji: liczba_powtórzeń

Wartość domyślna - 0 (bez powtórzeń).

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: TIMEOUT_PO_WYJATKU_NR_6
R Wartość opcji: liczba_milisekund

Wartość opcji:

liczba_milisekund - liczba w milisekundach

Wartość domyślna - 50.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MODBUSSLV - drajwer protokołu MODBUS/RTU tryb SLAVE

Home > 1.67 MODBUSSLV - drajwer protokołu MODBUS/RTU tryb SLAVE

1.67 MODBUSSLV - drajwer protokołu MODBUS/RTU tryb SLAVE

Przeznaczenie drajwera

Drajwer MODBUSSLV jest wykorzystywany do udostępniania wartości zmiennych procesowych systemu Asix innym systemom przy użyciu łącza szeregowego oraz protokołu MODBUS działającego w trybie RTU. W tak zestawionym połączeniu system Asix działa jako urządzenie podrzędne (SLAVE) protokołu MODBUS.

Drajwer MODBUSSLV ma zaimplementowane następujące typy danych:

HR (holding registers),

IR (input registers),

CS (coil status).

oraz następujące funkcje protokołu MODBUS:

Read Coil Status (funkcja 01),

Read Holding Registers (funkcja 03),

Read Input Registers (funkcja 04),

Force Single Coil (funkcja 05),

Preset SingleRegister (funkcja 06),

Return Query Data (funkcja 08, subfunkcja 00 00)[2],

Force Miltiple Coils (funkcja 15),

Preset Multiple Registers (funkcja 16).

Funkcja Preset Multiple Registers jest ograniczona do zapisu wartości jednej zmiennej procesowej systemu Asix.

Parametryzacja drajwera MODBUSSLV realizowana jest przy użyciu programu Architekt.

-----------------------------------------------------------

[2] Obsługa przedmiotowej funkcji jest wymagana do współpracy ASIXA (w trybie MODBUS SLAVE) z systemem Symphony (ABB).

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MODBUSSLV wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MODBUSSLV

Zakładka MODBUSSLV:

Zakładka Parametry kanału:

Numer urządzenia zdalnego sieci MODBUS (przypisany aplikacji systemu Asix)

Port - nazwa portu szeregowego (COM1 ... COM256)

Prędkość transmisji w bodach - max 115 kBd

Liczba bitów w znaku - 4, 5, 6, 7, 8

Kontrola parzystości - brak, parzystość, nieparzystość

Liczba bitów stopu - 1, 2

Przykład

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu MODBUSSLV:

Nazwa/Kanał: KANAL1

Drajwer: MODBUSSLV

Numer urządzenia zdalnego siecie MODBUS: 1

Port: COM1

Prędkość transmisji w bodach: 9600

Liczba bitów w znaku: 8

Kontrola parzystości: even

Liczba bitów stopu: 1

Drajwer MODBUSSLV jest ładowany automatycznie jako DLL.

Deklaracja udostępnianych zmiennych procesowych

Składnia deklaracji udostępnianej zmiennej procesowej jest następująca:

nazwa, adres [,skala] [,BEZ_STATUSU | ZE_STATUSEM]

gdzie:

nazwa - nazwa zmiennej procesowej systemu Asix; musi mieć swój odpowiednik wśród nazw zmiennych procesowych deklarowanych w plikach ASMENa;

adres - rodzaj oraz numer rejestru, poprzez który będzie udostępniana wartość zmiennej procesowej; w zależności od typu zmiennej procesowej jej wartość jest przekazywana poprzez jeden rejestr (zmienna typu WORD lub INT16) lub dwa kolejne rejestry (zmienna typu FLOAT lub DWORD); dla zmiennych typu FLOAT istnieje możliwość konwersji na zmienną typu INT16;

skala - określa rodzaj operacji (’-’ dzielenie) oraz wykładnik potęgi 10 w przypadku skalowania wartości (opcja skalowania wartości aktualnie dostępna jest dla wszystkich typów zmiennych); używana np. w przypadku konwersji wartości zmiennych typu FLOAT na liczbę typu INT16 z jednoczesnym skalowaniem (mnożeniem lub dzieleniem przez potęgę 10);

BEZ_STATUSU - wartość zmiennej jest przekazywana bez statusu;

ZE_STATUSEM - wartość zmiennej jest przekazywana ze statusem - status zajmuje kolejny rejestr, po ostatnim rejestrze przypisanym zmiennej.

Przykład

Wartość zmiennej X1 jest przekazywana poprzez rejestr HR1. Zmienna jest typu FLOAT i jej wartość jest konwertowana na INT16. Przed konwersją wartość zmiennej jest mnożona przez 100. Niezależnie od wartości opcji PRZEKAZYWANIE_STATUSU za wartością zmiennej przekazywany jest jej status (zajmujący rejestr HR2).

X1, HR1, 2, ZE_STATUSEM

Wartość zmiennej X2 jest przekazywana poprzez rejestr HR2. Zależnie od typu zmiennej zajmuje ona tylko rejestr HR2 (zmienna typu WORD lub INT16) lub rejestr HR2 i HR3 (zmienna typu FLOAT lub DWORD). Wartość zmiennej, niezależnie od wartości opcji PRZEKAZYWANIE_STATUSU, przekazywana jest bez statusu.

X2, HR2, BEZ_STATUSU

Wartość zmiennej X3 jest przekazywana poprzez rejestr HR3 (jeśli zmienna jest typu WORD lub INT16) lub rejestr HR3 i HR4 (jeśli zmienna jest typu FLOAT lub DWORD). Jeśli wartością opcji PRZEKAZYWANIE_STATUSU jest TAK, to w rejestrze HR4 (zmienna typu WORD lub INT16) lub HR5 (zmienna typu FLOAT lub DWORD) przekazywany jest status zmiennej X3.

X3, HR3

Plik z deklaracjami mapowania zmiennych należy podać w parametrze Plik danych (patrz: parametry drajwera).

Parametry drajwera

Parametry drajwera MODBUSSLV deklarowane są w module Dane bieżące na zakładce MODBUSSLV / Parametry drajwera kanału działającego według protokołu drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik danych

Znaczenie - opcja pozwala na deklarację nazwy pliku, w którym będą przekazane deklaracje mapowania zmiennych procesowych systemu Asix na rejestry HR i IR MODBUSA.

Wartość domyślna - brak domyślnego pliku.

Parametry:

nazwa pliku

Deklaracja przekazywania statusu zmiennych

R Przekazywanie statusu

Znaczenie - pozwala określić globalnie sposób przekazywania statusu wartości zmiennych procesowych systemu Asix. Włączona opcja oznacza, że wraz z wartością zmiennej procesowej Asixa będzie przekazywany również status tej zmiennej. Wartość statusu jest przekazywana w rejestrze następującym po ostatnim rejestrze przydzielonym zmiennej procesowej.

Wartość domyślna - domyślnie opcja wyłączona.

Jeśli zmienna X1 jest typu DWORD i została podana deklaracja:

X1, HR3

to status zmiennej zostanie przekazany w rejestrze HR5 (wartość zmiennej X1 jest przekazana w rejestrach HR3 i HR4).

Jeśli zmienna X2 jest typu WORD i została podana deklaracja:

X2, HR3

to status zmiennej zostanie przekazany w rejestrze HR4 (wartość zmiennej X2 jest przekazana w rejestrze HR3).

Wyłączona opcja Przekazywanie statusu oznacza, że status zmiennej procesowej nie będzie przekazywany. Istnieje możliwość sforsowania ustawień globalnych poprzez podanie w deklaracji mapowania zmiennej procesowej składnika ZE_STATUSEM lub BEZ_STATUSU. Deklaracja ZE_STATUSEM oznacza, że niezaleznie od wartości opcji Przekazywanie statusu, rejestr znajdujący się za rejestrami z wartością przedmiotowej zmiennej będzie zawierał status zmiennej. Deklaracja BEZ_STATUSU oznacza, że niezaleznie od wartości opcji Przekazywanie statusu, status zmiennej nie będzie przekazywany.

Rzutowanie zmiennych typu FLOAT na INT16

R Rzutowanie typu zmiennych

Znaczenie - opcja pozwala na konwersję wartości zmiennych typu FLOAT do postaci INT16. Przed konwersją możliwe jest przeskalowanie wartości FLOAT drogą mnożenia przez potęgę liczby 10. Wartość potęgi podawana jest opcjonalnie w deklaracji mapowania zmiennej ASMENa (składnik ’skala’).

Wartość domyślna - domyślnie opcja wyłączona.

Deklaracja:

X1, HR1, -2

oznacza, że wartość zmiennej procesowej X1 zostanie podzielona przez 100, a nastęnie zostanie skonwertowana na liczbę typu INT16, udostępnianą w rejestrze HR1.

Deklaracja:

X2, HR2, 3

oznacza, że wartość zmiennej procesowej X2 zostanie pomnożona przez 1000, a nastęnie zostanie skonwertowana na liczbę typu INT16, udostępnianą w rejestrze HR2.

R Okres aktualizacji danych

Znaczenie - wartości rejestrów są na bieżąco uaktualniane poprzez odczyt danych z ASMENa. Opcja określa cykl odświeżania.

Wartość domyślna - domyślnie cykl odświeżania wynosi 1 sekundę.

Parametr:

liczba - wartość wyrażona w sekundach.

R Czas odpowiedzi

Znaczenie - czas wypracowania odpowiedzi jest kontrolowany przez wartość opcji. Jeśli w okresie podanym przez opcję Czas odpowiedzi drajwer nie zdoła wypracować danych żądanych przez MASTERA, to nie wysyła żadnej odpowiedzi.

Wartość domyślna - domyślnie timeout na wypracowanie odpowiedzi wynosi 200 milisekund.

Parametr:

liczba - wartość wyrażona w milisekundach.

R Liczba rejestrów w przesyłce

Znaczenie - opcja określa maksymalną liczbę rejestrów, o którą może zapytać MASTER w ramach jednego zapytania. W przypadku przekroczenia w zapytaniu liczby rejestrów określonej w przedmiotowej opcji drajwer wysyła odpowiedź typu EXCEPTION z kodem 4 (SLAVE DEVICE FAILURE).

Wartość domyślna - domyślnie dopuszcza się zapytania dotyczące 128 rejestrów włącznie.

Parametr:

liczba

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera MODBUSSLV. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa pliku

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MPI - drajwer protokołu MPI sterowników SIMATIC S7

Home > 1.68 MPI - drajwer protokołu MPI sterowników SIMATIC S7

1.68 MPI - drajwer protokołu MPI sterowników SIMATIC S7

Przeznaczenie drajwera

Drajwer MPI jest wykorzystywany do wymiany danych ze sterownikami SIMATIC S7 poprzez interfejs MPI. Transmisja realizowana jest łączami szeregowymi w standardzie V24 (RS232C), przy wykorzystaniu standardowych portów szeregowych komputera systemu Asix. Współpraca systemu Asix ze sterownikami SIMATIC S7 przy wykorzystaniu interfejsu MPI nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych.

Parametryzacja drajwera MPI realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MPI wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwe: MPI

Zakładka MPI / Parametry kanału:

Identyfikacja:

Port: nazwa portu szeregowego (COM1 ... COM256)

Parametryzacja transmisji:

Adres PC

Adres sterownika na szynie MPI

Prędkość transmisji w bodach

Liczba bitów w znaku: 4, 5, 6, 7, 8

Kontrola parzystości: brak, parzystość, nieparzystość

Liczba bitów stopu: 1, 2

Powyższe parametry są opcjonalne. W przypadku ich pominięcia przyjmuje się parametry domyślne:

  • prędkość transmisji - 19200 Bd,

  • liczba bitów w znaku - 8,

  • typ kontroli parzystości - kontrola nieparzystości,

  • liczba bitów stopu - 1,

  • adres sterownika S7 - 2,

  • adres PC - 0.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu MPI.

Nazwa/Kanał: CHAN2

Drajwer: MPI

Port: COM1

Adres PC: 0

Adres sterownika na szynie MPI: 2

Prędkość transmisji w bodach: 19200

Liczba bitów w znaku: 8

Kontrola parzystości: kontrola nieparzystości

Liczba bitów stopu: 1

Adresacja zmiennej

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych procesowych obsługiwanych przez drajwer MPI:

TYP_ZMIENNEJ indeks_zmiennej

gdzie:

TYP_ZMIENNEJ - łańcuch identyfikujący typ zmiennej w protokole MPI,

indeks_zmiennej - indeks zmiennej w ramach danego typu.

Dozwolone są następujące oznaczenia typów zmiennych procesowych (zakres indeksów zmiennych jest specyficzny dla różnych typów sterowników):

EA - bajty wyjściowe,

EAW - słowa wyjściowe,

EAD - podwójne słowa wyjściowe,

EE - bajty wejściowe,

EEW - słowa wejściowe,

EDI - słowa 16-bitowe w konwencji INTEL’a,

EDD - podwójne słowa wejściowe,

EM - bajty flag,

EMW - słowa flag,

EMD - podwójne słowa flag,

EZ - słowo licznika,

ET - słowo timera,

ED - słowo w bloku danych,

EL - podwójne słowo w bloku danych,

ER - liczba zmiennoprzecinkowa w bloku danych.

W przypadku danych znajdujących się w bloku danych, należy po podaniu typu (EL lub ED) podać numer bloku danych zakończony kropką, a następnie numer słowa.

Przykłady

EMW15 - słowo flag 15

EE0 - słowo wejściowe 0

EAW8 - słowo wyjściowe 8

ED5.3 - słowo DW3 w bloku danych DB5

Drajwer MPI jest ładowany automatycznie jako DLL.

Parametry drajwera

Parametry drajwera MPI deklarowane są w module Dane bieżące na zakładce MPI / Parametry drajwera kanału działającego według protokołu drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Pzesył danych

Znaczenie - w przypadku włączenia opcji, transfer danych 32-bitowych z DB realizowany jest jako przesył dwóch słów 16-bitowych; w przypadku wyłączenia opcji - jako przesył podwójnego słowa;

Wartość domyślna - opcja wyłączona.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

ie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MPS - drawjer protokołu mierników parametrów sieci

Home > 1.69 MPS - drawjer protokołu mierników parametrów sieci energetycznej MPS

1.69 MPS - drawjer protokołu mierników parametrów sieci energetycznej MPS

Przeznaczenie drajwera

Protokół MPS służy do komunikacji po łączu szeregowym z miernikami parametrów sieci energetycznej MPS firmy OBR Metrologii Elektrycznej w Zielonej Górze.

Parametryzacja drajwera MPS realizowana jest przy użyciu programu Architekt.

Definicja kanału logicznego transmisji danych

Deklaracja kanału transmisyjnego działającego według protokołu MPS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MPS

Zakładka MPS:

Parametry kanału:

adres_sterownika,COMn

gdzie:

COMn - numer portu szeregowe, do którego podłączona jest sieć sterowników MPS.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu MPS:

Nazwa: MPS1

Drajwer: MPS

Parametry kanału: 1,COM2

Nazwy zmiennych sterownika MPS

Zmienną można określić poprzez nazwę FCnn gdzie nn numer zmiennej w sterowniku zgodnie z opisem producenta sterownika. Można również używać nazw symbolicznych. Wielkość liter nie ma znaczenia.

Tabela. Nazwy symboliczne zmiennych drajwera MPS.

Definicja wartości znamionowych

W celu poprawnego odczytu wartości pomiarowych należy zdefiniować wartości znamionowe napięcia, prądy i mocy (UL, IL, P, Q, S). Wartości te mogą być podane dla każdej stacji. W tym celu należy je umieścić w pliku inicjującym, w sekcji o nazwie takiej jak nazwa kanału logicznego.

PRZYKŁAD

[ASMEN]

...

MPS1=MPS,1,COM2

MPS2=MPS,2,COM2

...

[MPS1]

UL = 660

IL = 100

...

[MPS2]

UL = 380

IL = 100

...

Parametry drajwera

Parametry drajwera MPS deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MPS

R Nazwa opcji: Oczekiwanie

R Wartość opcji: TAK/NIE

Znaczenie - podanie tak powoduje zmianę sposobu odmierzania krótkich odcinków czasu.

Wartość domyślna - wartość domyślna nie.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MSP1X - drajwer protokołu łącza szeregowego sterowników

Home > 1.70 MSP1X - drajwer protokołu łącza szeregowego sterowników MSP-1x ELMONTEX

1.70 MSP1X - drajwer protokołu łącza szeregowego sterowników MSP-1x ELMONTEX

Przeznaczenie drajwera

Protokół MSP1X jest wykorzystywany do wymiany danych pomiędzy sterownikami MSP1X f-my ELMONTEX oraz komputerem systemu Asix. Komunikacja odbywa się w standardzie RS485 wg protokołu opracowanego dla sterowników MSP1X przez f-mę ELMONTEX (brak oficjalnej dokumentacji).

Parametryzacja drajwera MSP1X realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MSP1X wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MSP1X

Zakładka MSP1X:

Parametry kanału:

nr_grupy, nr_urz, port [, baud]

gdzie:

nr_grupy - numer grupy, do której należy sterownik,

nr_urz - numer sterownika w ramach grupy,

port - nazwa portu: COM1, COM2 itd.,

baud - prędkość transmisji (domyślnie 9600).

Pozostałe parametry są domyślne:

  • 8 bitów w znaku,

  • bez kontroli parzystości (NONE),

  • 1 bit stopu.

PRZYKŁAD

Deklaracja kanału logicznego o nazwie KANAL1, działającego wg protokołu MSP1X i wymieniającego dane ze sterownikiem o numerze 1 w ramach grupy o numerze 5 poprzez port COM2 z domyślnymi parametrami transmisji:

Nazwa: KANAL1

Drajwer: MSP1X

Parametry kanału: 5, 1, COM2

Drajwer MSP1X jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

AI - Analog Input (WORD),

AO - Analog Output (WORD),

BI - Binary Input (WORD),

BO - Binary Output (WORD),

PV - Preset Value (WORD),

PD - Delta Preset Value (WORD),

IS - Binary Input Status (WORD),

OS - Binary Output Status (WORD).

PRZYKŁAD

Przykłady deklaracji zmiennych procesowych:

X4, analog input nr 1, AI1, KANAL1, 1, 1, NIC

X5, binary output nr 15, BO15, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera MSP1X deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MSP1X
R Nazwa opcji: REINICJACJA
R Wartość opcji: TAK/NIE

Znaczenie - pozwala na reinicjalizację portu szeregowego przed każdym seansem łączności ze sterownikiem.

Wartość domyślna - NIE.

R Nazwa sekcji: MSP1X
R Nazwa opcji: ZWLOKA_ZAPISU
R Wartość opcji: liczba

Znaczenie - pozwala określić odstęp czasu (w milisekundach) pomiędzy zapisem danych do sterownika i następnym seansem wymiany danych ze sterownikiem.

Wartość domyślna - 1200.

R Nazwa sekcji: MSP1X
R Nazwa opcji: ZWLOKA_NAGLOWKA
R Wartość opcji: liczba

Znaczenie - pozwala określić odstęp czasu (w milisekundach) pomiędzy znakami polecenia wysyłanego do sterownika z systemu Asix.

Wartość domyślna - 50

R Nazwa sekcji: MSP1X
R Nazwa opcji: ZWLOKA_DTR
R Wartość opcji: liczba

Znaczenie - pozwala określić odstęp czasu (w milisekundach) pomiędzy wysłaniem polecenia do sterownika i ustawieniem DTR, sygnalizującym gotowość do odbioru danych przez system Asix.

Wartość domyślna - 2.

R Nazwa sekcji: MSP1X
R Nazwa opcji: AKTUALIZACJA
R Wartość opcji: liczba

Znaczenie - pozwala określić odstęp czasu (w sekundach), pomiędzy kolejnymi odczytami danych ze sterownika do wewnętrznych buforów drajwera.

Wartość domyślna - 5.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtMuel

Home > 1.71 Muel - drajwer systemu MUEL

1.71 Muel - drajwer systemu MUEL

Przeznaczenie drajwera

Drajwer protokołu Muel służy do wymiany danych pomiędzy systemem Asix i komputerem technicznym systemu MUEL. Transmisja jest realizowana łączami szeregowymi przy pomocy standardowych portów szeregowych komputera w standardzie RS-232

Parametryzacja drajwera Muel realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Muel wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Muel

Zakładka Muel:

Parametry kanału:

Port=liczba

gdzie:

Port - numer portu szeregowego

Parametry transmisji są stałe i wynoszą:

prędkość transmisji 9600 Bd,

8 bitów znaku,

bez kontroli parzystości,

1 bit stopu.

PRZYKŁAD

Przykład deklaracji kanału transmisji:

Port=1

Deklaracja zmiennych

Ogólna składnia adresu symbolicznego zmiennej procesowej jest następująca:

<obiekt><typ>[.<indeks>]

gdzie:

obiekt - numer obiektu,

typ - typ zmiennej,

indeks - indeks w ramach typu;

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

Typy zmiennych z indeksem (odczyt):

AI - napięcie na wejściu analogowym, zakres indeksów 1 - 4 (FLOAT)

DI - stan wejścia cyfrowego, zakres indeksów 1 - 8 (WORD)

DO - stan wyjścia cyfrowego, zakres indeksów 1 - 4 (WORD)

Typy zmiennych bez indeksu (odczyt):

T - wartość temperatury (WORD)

STSA - wartość statusu A (WORD)

STSB - wartość statusu B (WORD)

DI - stan wszystkich wejść cyfrowych (WORD)

DO - stan wszystkich wyjść cyfrowych (WORD)

CON - stan połączenia z obiektem (WORD)

Przykłady deklaracji zmiennych dla obiektu nr 38:

JJ_11, AI nr 1, 38.AI.1, KANAL1, 1, 1, NIC_FP

JJ_13, DI nr 2, 38.DI.2, KANAL1, 1, 1, NIC

JJ_14, DO nr 3, 38.DO.3, KANAL1, 1, 1, NIC

JJ_15, temperatura, 38.T, KANAL1, 1, 1, NIC

JJ_16, wszystkie DI, 38.DI, KANAL1, 1, 1, NIC

JJ_17, wszystkie DO, 38.DO, KANAL1, 1, 1, NIC

JJ_18, status A, 38.STSA, KANAL1, 1, 1, NIC

JJ_19, status B, 38.STSB, KANAL1, 1, 1, NIC

JJ_20, stan połączenia, 38.CON, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera Muel deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTMUEL.

R Nazwa sekcji: CTMUEL

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie log pliku nie jest tworzony.

R Nazwa sekcji: CTMUEL

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTMUEL

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa sekcji: CTMUEL

R Nazwa opcji: OKRES_ODSWIEZANIA

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia maksymalnego czasu (w sekundach), po którym drajwer samodzielnie odczyta dane ze stacji. Opcja może być stosowana w wersji 1.1.2.

Wartość domyślna: domyślnie okres pomiędzy odczytami wynosi 30 sekund.

Wartość opcji:

liczba - okres pomiędzy odczytami w sekundach

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Nazwa sekcji: CTMUEL

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\CtMuel\muel.log

R Nazwa sekcji: CTMUEL

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 20

R Nazwa sekcji: CTMUEL

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MultiMuz - drajwer mikroprocesorowych urządzeń

Home > 1.72 MultiMuz - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ

1.72 MultiMuz - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ firmy JM-Tronik

Przeznaczenie drajwera

Drajwer protokołu MultiMuz służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja realizowana przy pomocy łączy szeregowych.

Drajwer realizuje następujące funkcje:

- odczyt aktualnych stanów i pomiarów,

- odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

- odczyt zakłóceń i ich rejestracja w bazie danych w formacie programu DataLogger opracowanym przez ASKOM Sp z o.o.

Drajwer obsługuje następujące typy MultiMuz’ów:

CR 001

LR 001

LR 001

LR 064

LR 067

LZ 001

PR 001

SR 001

SR 067

SR 072

SR _72A

SR-96

TR 001

Obsługa innego typu MultiMuza wymaga zmian w kodzie drajwera.

Parametryzacja drajwera MultiMuz realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MultiMuz wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MultiMuz

Zakładka MultiMuz / Parametry kanału:

Identyfikacja:

Numer urządzenia w sieci

Typ urządzenia - Identyfikatory obsługiwanych typów:

CR

LR

LR_64

LR_67

LZ

LZ_143_01

PR

SR

SR_67

SR_72

SR_94

SZR

TR

TR_143_01

Po wybraniu typu urządzenia przycisk Pokaż parametry urządzenia wyświetla w oknie przeglądarki (wymagany co najmniej IE6) szczegółowe informacje nt parametrów urządzenia i parametrów zdarzeń danego typu urządzenia. Wystarczy raz uruchomić wspomniane okno, a wybór kolejnych typów urządzenia powodować będzie odświeżanie zawartości okna i podmianę wyświetlanych parametrów adekwatnie do wybranego typu urządzenia.

powiększ >>

Rys. Informacje nt urządzenia MultiMuz wg typu urządzenia.

Parametry transmisji:

Port - numer portu szeregowego COM

Offset alarmów - offset dodawany do wyliczonego numeru alarmu ASIXA,

Zmienne kontrolne:

Nazwa zmiennej służąca do prezentacji statusu transmisji z urządzeniem:

0 - stan transmisji ok,

1 - brak/błędy komunikacji,

2 - wyłączenie urządzenia z obsługi,

Nazwa zmiennej służąca do sterowania stanem transmisji z urządzeniem:

1 - żądanie wyłączenia urządzenia z obsługi,

0 - włączenie urządzenia do obsługi.

Synchronizacja czasu - okres synchronizacji czasu z urządzeniem (w sekundach). Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

UWAGA Zmienne: zmienna służąca do monitorowania stanu kanału i zmienna służąca do wyłączania kanału obsługi muszą należeć do kanału typu NONE.

Parametry transmisji z urządzeniami MultiMuz są stałe:

- 8 bitów znaku,

- kontrola parzystości,

- 1 bit stopu.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KSR_67, w którym jest obsługiwany MultiMuz o numerze sieciowym 5, typie SR 067 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund. Komunikacja odbywa się poprzez COM2:

Nazwa/Kanał: KSR_67

Drajwer: MULTIMUZ

Numer urządzenia w sieci: 5

Typ urządzenia : SR 067

Port: COM2

Offset alarmów: 200

Nazwa zmiennej służącej do monitorowania stanu kanału: MuzStat05

Nazwa zmiennej służąca do sterowania stanem transmisji z urządzeniem: MuzCtrl05

Synchronizacja czasu: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt),

HRF - rejestr 32-bitowy typu FLOAT (odczyt).

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora (odczyt)

RQ - żądanie odczytu rejestratora (zapis)

RT - czas wyzwolenia rejestratora (odczyt)

MN - numer sieciowy MultiMuza, z którego jest/był odczytywany rejestrator (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGA Zmienne: zmienna służąca do monitorowania stanu kanału i zmienna służąca do wyłączania kanału obsługi muszą należeć do kanału typu NONE.
1/ indeksów nie podaje się dla typów: MN, RN, RR, RQ i SN;
2/ w przypadku typów RS, RT zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu;
3/ parametrem żądania odczytu rejestratora (typ RQ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora;
4/ zakresy dla typów HR i HRF zależą od typu urządzenia;
4/ w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

PRZYKŁAD

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą z urządzenia typu LR 001 dostępnego poprzez kanał o nazwie KLR_01):

ZM_01, licznik energii czynnej dodatniej, HRF5, KLR_01, 1, 1, NIC_FP

ZM_02, pobudzenie zabezpieczeń 1, HR19, KLR_01, 1, 1, NIC

ZM_03, pomiar I1, HRF28, KLR_01,1,1,NIC_FP

ZM_04, sterowanie wyłącznikiem, CS2, KLR_01,1,1, NIC

ZM_05, zmiana banku nastaw, CS10, KLR_01,1,1, NIC

ZM_06, czas wyzwolenia rejestratora 1, RT1, KLR_01, 1,1, DATACZAS_MUZ

Przykład deklaracji zmiennych bez parametrów (wartości zmiennych pochodzą z urządzenia typu LR 001 dostępnego poprzez kanał o nazwie KLR_01):

ZM_07, żądanie odczytu rejestratora, RQ, KLR_01,1,1,NIC

ZM_08, nr odczytywanego rejestratora, RN, KLR_01,1,1,NIC

ZM_09, status odczytu rejestratora, RR, KLR_01,1,1,NIC

ZM_10, nr odczytanej próbki z rejestratora, SN, KLR_01,1,1,NIC

ZM_11, nr odczytywanego urządzenia, MN, KLR_01,1,1,NIC

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu DataLogger. W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń na serwerze SQL w bazie programu AsLogger, która określa:

- nazwę serwera MS SQL,

- nazwę bazy danych,

w których drajwer będzie zapisywać odczytane próbki zakłóceń.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z MultiMuza i zapisać do bazy programu DataLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego MultiMuza,

b/ RN - numer odczytywanego rejestratora,

c/ RR - status odczytu rejestratora:

- nieaktywny lub zakończony o.k.

- odczyt w toku,

- odczyt zakończony błędem.

d/ SN - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazw planów rejestracji nie deklaruje się w aplikacji (byłoby to zbyt uciążliwe, zważywszy na liczbę urządzeń w rozdzielniach oraz na to, że każde urządzenie może rejestrować zakłócenia spowodowane kilkunastoma przyczynami). Drajwer zakłada natomiast, że nazwy planów rejestracji dla MultiMuzów mają następującą składnię:

NrxxxpyyPowod

gdzie:

xxx - numer sieciowy MultiMuza

yy - numer portu szeregowego do którego podpięty jest MultiMuz,

Powod - skrót określający powód wyzwolenia rejestratora.

PRZYKŁAD

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w MultiMuzie nr 2 na porcie COM11 zostanie zbudowany plan rejestracji o nazwie:

Nr002p11wyzw_rej_od_log_użytk

Plany rejestracji mogą zostać utworzone przy pomocy programu DataLogger, ale mogą być również utworzone automatycznie przez drajwer w trakcie jego pracy. Drugi przypadek ma miejsce wtedy, gdy po odczycie zakłócenia drajwer nie znajduje w bazie planu rejestracji, którego nazwa odpowiada parametrom odczytanego zakłócenia (NrxxxpyyPowod). W takim przypadku drajwer automatycznie tworzy nowy plan rejestracji o nazwie zgodnej ze składnią NrxxxpyyPowod po czym dodaje do niego :

a/ pełny zestaw punktów planu, w skład którego wchodzą:

prądy: I0, I1, I2, I3

napięcia: U0, U1, U2, U3

stany wejść: WE01 ... WE20

stany wyjść: WY01 ... WY20

stany pobudzenia zabezpieczeń 1: PZ01 ... PZ16

stany zadziałania zabezpieczeń 1: ZZ01 ... ZZ16

Liczba punktów planu dotyczących stanów pobudzeń zabezpieczeń i zadziałań zabezpieczeń jest specyficzna dla każdego typu MultiMuza,

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym zakłóceniu - będą ew. korygowane przy odczycie kolejnych zakłóceń dla danego planu.

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona parametrem Okres sprawdzania zdarzeń. Zdarzenia odczytywane z MultiMuza są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie przygotowane dla każdego typu MultiMuza oraz offset podany w deklaracji kanału ASMENA. Wyróżnia się dwa typy alarmów Asixa:

a/ tylko tekst

b/ tekst oraz jeden parametr liczbowy

Zdarzenia MultiMuza o typie nr 2 są zamieniane na alarmy Asixa typu tekst, pozostałe zdarzenia MultiMuza (typy 0, 1, 3 i 4) są zamieniane na alarmy Asixa typu tekst + jeden parametr liczbowy (typu float)

PRZYKŁAD 1

Zdarzenie Zamknięcie wyłącznika ze sterownika w MultiMuzie typu LR 001 (zdarzenie typu tekst) jest mapowane na numer alarmu Asixa o wartości 160. Jeśli w deklaracji kanału ASMENA obsługującego MultiMuz LR 001 podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 160 = 560):

560, al, zamknięcie wyłącznika ze sterownika

PRZYKŁAD 2

Zdarzenie Zadziałanie zabezpieczenia zwarciowego w MultiMuzie typu SR 067 (zdarzenie typu tekst oraz jeden parametr liczbowy) jest mapowane na numer alarmu Asixa o wartości 0. Jeśli w deklaracji kanału ASMENA obsługującego MultiMuz SR 067 podano offset alarmów o wartości 100, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (100 + 0 = 100):

100, al, zadziałanie zabezpieczenia zwarciowego %f

Mapowanie zdarzeń poszczególnych typów MultiMuzów na numery alarmów Asixa zawiera plik NumeryAlarmowAsixa.xls.

Parametry drajwera

Parametry drajwera MultiMuz deklarowane są w module Dane bieżące na zakładkach MultiMuz / Parametry drajwera ... kanału działającego według protokołu drajwera MultiMuz.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa pliku logu

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia max. liczby powtórzeń w przypadku błędów transmisji.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na 3.

Wartość opcji:

liczba - max. liczba powtórzeń w przypadku błędów transmisji.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z MultiMuza. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z MultiMuza. Opcja ma charakter globalny, a jej wartość może być przeciążona przez indywidualne ustawienia kanału.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

R Zwłoka po braku odpowiedzi

Znaczenie - opcja określa liczbę sekund, przez którą zapytania do drajwera będą blokowane, po tym jak ostatnie zapytanie zakończyło się brakiem odpowiedzi.

Wartość domyślna - domyślnie wartość opcji wynosi 0 - brak blokowania.

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość domyślna: -.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Dodatkowa parametryzacja drajwera

Parametr deklarowany przy użyciu osobnej sekcji, której nazwa jest identyczna z nazwą drajwera - parametr należy umieścić w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MULTIMUZ
R Nazwa opcji: ZWLOKA_PO_BRAKU_ODPOWIEDZI
R Wartość opcji: liczba_sekund

Znaczenie - pozycja służąca do blokowania zapytań w kanale na okres liczony w milisekundach, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi. W okresie blokowania zapytań wszystkie polecenia kierowane do drajwera kończone są ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie).

Wartość domyślna - domyślnie wartość wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi..

Parametry kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału.

R Prędkość transmisji

Znaczenie: Opcja określa prędkość transmisji 9600 lub 19200 (dla typu 2G tylko 9600).

Wartość domyślna: - 9600.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z MultiMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 1000 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi z MultiMuza. Wartość opcji przeciąża ustawienia w opcjach drajwera.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 100 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Bez zdarzeń

Znaczenie: Opcja służy do wyłączania funkcji odczytu zdarzeń w kanale.

Wartość domyślna: Domyślnie odczyt zdarzeń jest włączony.

Wartość opcji:

TAK/NIE

R Bez rejestratora

Znaczenie: Opcja służy do wyłączania funkcji odczytu rejestratora zakłóceń w kanale.

Wartość domyślna: Domyślnie odczyt rejestratora zakłóceń jest dozwolony.

Wartość opcji:

TAK/NIE

PRZYKŁAD

Przykładowe parametry drajwera:

Plik logu: d:\tmp\multimuz\muz.log

Rozmiar pliku logu: 3

Log telegramów: TAK

Rejestracja zakłóceń w bazie AsLogger: SERWER_RO6, BAZA_RO6

Dodatkowa parametryzacja kanału transmisji

Parametr deklarowany przy użyciu osobnej sekcji, której nazwa jest identyczna z nazwą kanału transmisji - parametr należy umieścić w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: ZWLOKA_PO_BRAKU_ODPOWIEDZI
R Wartość opcji: liczba_sekund

Znaczenie - opcja służąca do blokowania zapytań w kanale na okres liczony w milisekundach, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi. W okresie blokowania zapytań wszystkie polecenia kierowane do drajwera kończone są ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie). Opcja przeciąża wartość identycznej opcji zadeklarowanej w opcjach drajwera.

Wartość domyślna - domyślnie wartość wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MultiMuz_tcpip

Home > 1.73 MultiMuz_tcpip - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ firmy JM-Tronik

1.73 MultiMuz_tcpip - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ firmy JM-Tronik

Przeznaczenie drajwera

Drajwer protokołu MultiMuz służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja odbywa się w sieci Ethernet przy użyciu protokołu TCP lub UDP.

Drajwer realizuje następujące funkcje:

- odczyt aktualnych stanów i pomiarów,

- odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

- odczyt zakłóceń i ich rejestracja w bazie danych w formacie programu DataLogger opracowanym przez ASKOM Sp z o.o.

Drajwer obsługuje następujące typy MultiMuz’ów:

CR 001

LR 001

LR 001

LR 064

LR 067

LZ 001

PR 001

SR 001

SR 067

SR-72

SR-72+

SR_73

SR-94

SR-94+

TR 001

megaMUZ TR

megaMUZ TR 082

Obsługa innego typu MultiMuza wymaga zmian w kodzie drajwera.

Parametryzacja drajwera MultiMuz_TCPIP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MultiMuz_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MultiMuz_TCPIP

Zakładka MultiMuz_TCPIP:

Parametry kanału:

Kanał=MultiMuz_tcpip, nr, typ, alarmOff, port, adres_ip, zm_status, zm_kontrolna [,okres]

gdzie:

MultiMuz_tcpip - nazwa drajwera służącego do komunikacji z urządzeniami MultiMuz,

nr - sieciowy numer urządzenia,

typ - typ MultiMuza. Identyfikatory obsługiwanych typów:

1 - CR 001

2 - LR 001

3 - LR 064

4 - LR 067

5 - LZ 001

6 - PR 001

7 - SR 001

8 - SR 067

9 - TR 001

13 - megaMUZ TR

14 - megaMUZ TR 082

alarmOff - offset dodawany do wyliczonego numeru alarmu Asixa,

port - nr portu Tcpip oraz adres IP,

zm_status - zmienna służąca do prezentacji statusu transmisji z MultiMuzem:

0 - stan transmisji o.k.

1 - brak/błędy komunikacji,

2 - wyłączenie MultiMuza z obsługi,

zm_ctrl - zmienna służąca do sterowania stanem transmisji z MultiMuzem:

1 - żądanie wyłączenia MultiMuza z obsługi,

0 - włączenie MultiMuza do obsługi.

okres - okres synchronizacji czasu z MultiMuzem (w sekundach). Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

UWAGA

Zmienne zm_status i zm_ctrl muszą należeć do kanału typu NONE.

Parametry transmisji z urządzeniami MultiMuz są stałe:

- prędkość transmisji 9600 Bd,

- 8 bitów znaku,

- kontrola parzystości,

- 1 bit stopu.

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora (odczyt)

RQ - żądanie odczytu rejestratora (zapis)

RT - czas wyzwolenia rejestratora (odczyt)

MN - numer sieciowy MultiMuza, z którego jest/był odczytywany rejestrator (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora (odczyt)

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej ’Typ’.

UWAGA Zmienne: zmienna służąca do monitorowania stanu kanału i zmienna służąca do wyłączania kanału obsługi muszą należeć do kanału typu NONE.
1/ indeksów nie podaje się dla typów: MN, RN, RR, RQ i SN;
2/ w przypadku typów RS, RT zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu;
3/ parametrem żądania odczytu rejestratora (typ RQ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora;
4/ zakresy dla typów HR i HRF zależą od typu urządzenia;
5/ w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

PRZYKŁAD

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą z urządzenia typu LR 001 dostępnego poprzez kanał o nazwie KLR_01):

ZM_01, licznik energii czynnej dodatniej, HRF5, KLR_01, 1, 1, NIC_FP

ZM_02, pobudzenie zabezpieczeń 1, HR19, KLR_01, 1, 1, NIC

ZM_03, pomiar I1, HRF28, KLR_01,1,1,NIC_FP

ZM_04, sterowanie wyłącznikiem, CS2, KLR_01,1,1, NIC

ZM_05, zmiana banku nastaw, CS10, KLR_01,1,1, NIC

ZM_06, czas wyzwolenia rejestratora 1, RT1, KLR_01, 1,1, DATACZAS_MUZ

Przykład deklaracji zmiennych bez parametrów (wartości zmiennych pochodzą z urządzenia typu LR 001 dostępnego poprzez kanał o nazwie KLR_01):

ZM_07, żądanie odczytu rejestratora, RQ, KLR_01,1,1,NIC

ZM_08, nr odczytywanego rejestratora, RN, KLR_01,1,1,NIC

ZM_09, status odczytu rejestratora, RR, KLR_01,1,1,NIC

ZM_10, nr odczytanej próbki z rejestratora, SN, KLR_01,1,1,NIC

ZM_11, nr odczytywanego urządzenia, MN, KLR_01,1,1,NIC

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu DataLogger. W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję Rejestrowanie zakłóceń na serwerze SQL w bazie programu AsLogger, która określa:

- nazwę serwera MS SQL,

- nazwę bazy danych,

w których drajwer będzie zapisywać odczytane próbki zakłóceń.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z MultiMuza i zapisać do bazy programu DataLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego MultiMuza,

b/ RN - numer odczytywanego rejestratora,

c/ RR - status odczytu rejestratora:

- nieaktywny lub zakończony o.k.

- odczyt w toku,

- odczyt zakończony błędem.

d/ SN - numer ostatnio odczytanej próbki.

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji. Nazw planów rejestracji nie deklaruje się w aplikacji (byłoby to zbyt uciążliwe, zważywszy na liczbę urządzeń w rozdzielniach oraz na to, że każde urządzenie może rejestrować zakłócenia spowodowane kilkunastoma przyczynami). Drajwer zakłada natomiast, że nazwy planów rejestracji dla MultiMuzów mają następującą składnię:

NrxxxpyyPowod

gdzie:

xxx - numer sieciowy MultiMuza

yy - numer portu szeregowego do którego podpięty jest MultiMuz,

Powod - skrót określający powód wyzwolenia rejestratora.

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona parametrem Okres sprawdzania zdarzeń. Zdarzenia odczytywane z MultiMuza są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie przygotowane dla każdego typu MultiMuza oraz offset podany w deklaracji kanału ASMENA. Wyróżnia się dwa typy alarmów Asixa:

a/ tylko tekst

b/ tekst oraz jeden parametr liczbowy

Zdarzenia MultiMuza o typie nr 2 są zamieniane na alarmy Asixa typu tekst, pozostałe zdarzenia MultiMuza (typy 0, 1, 3 i 4) są zamieniane na alarmy Asixa typu tekst + jeden parametr liczbowy (typu float)

PRZYKŁAD 1

Zdarzenie Zamknięcie wyłącznika ze sterownika w MultiMuzie typu LR 001 (zdarzenie typu tekst) jest mapowane na numer alarmu Asixa o wartości 160. Jeśli w deklaracji kanału ASMENA obsługującego MultiMuz LR 001 podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 160 = 560):

560, al, zamknięcie wyłącznika ze sterownika

PRZYKŁAD 2

Zdarzenie Zadziałanie zabezpieczenia zwarciowego w MultiMuzie typu SR 067 (zdarzenie typu tekst oraz jeden parametr liczbowy) jest mapowane na numer alarmu Asixa o wartości 0. Jeśli w deklaracji kanału ASMENA obsługującego MultiMuz SR 067 podano offset alarmów o wartości 100, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (100 + 0 = 100):

100, al, zadziałanie zabezpieczenia zwarciowego %f

Mapowanie zdarzeń poszczególnych typów MultiMuzów na numery alarmów Asixa zawiera plik NumeryAlarmowAsixa.xls.

Parametry drajwera

Parametry drajwera MultiMuz_TCPIP deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MultiMuz_TCPIP
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Nazwa sekcji: MultiMuz_TCPIP
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: MultiMuz_TCPIP
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Nazwa sekcji: MultiMuz_TCPIP
R Nazwa opcji: OKRES_SPRAWDZANIA_ZDARZEN
R Wartość opcji: liczba

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

R Nazwa sekcji: MultiMuz_TCPIP
R Nazwa opcji: REJESTRATOR
R Wartość opcji: NazwaSerwera, NazwaBazy

Znaczenie - opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna - domyślnie zakłócenia nie są rejestrowane.

Parametry:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

PRZYKŁAD

[MULTIMUZ_TCPIP]

PLIK_LOGU=d:\tmp\multimuz\muz.log

ROZMIAR_PLIKU_LOGU=3

LOG_TELEGRAMOW=TAK

REJESTRATOR=SERWER_RO6, BAZA_RO6

Parametry definiowane dla indywidualnych kanałów w sekcjach o nazwie kanału Asmena:

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: LICZBA_POWTÓRZEŃ
R Wartość opcji: liczba

Znaczenie - liczba powtórzeń w przypadku błędów.

Wartość domyślna - brak powtórzeń.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: MAX_LICZBA_REJESTROW
R Wartość opcji: liczba

Znaczenie - maksymalna liczba rejestrów w pojedynczym zapytaniu.

Wartość domyślna - domyślnie wartość opcji wynosi 119.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych przez drajwer.

Wartość domyślna - domyślnie przyjmuje się ustawienia z sekcji drajwera.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: TIMEOUT_ODTWORZENIA_POLACZENIA
R Wartość opcji: liczba_sekund

Znaczenie - timeout na odtworzenie połączenia po wyczerpaniu liczby powtórzeń.

Wartość domyślna - domyślnie po wyczerpaniu liczby powtórzeń drajwer sygnalizuje błąd transmisji.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: PORT
R Wartość opcji: liczba

Znaczenie - numer portu, przez który drajwer komunikuje się ze sterownikiem.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: ADRES_IP
R Wartość opcji: adres_ip

Znaczenie - adres IP karty sieciowej, przez którą drajwer komunikuje się ze sterownikiem.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MultiMuz3

Home > 1.74 MultiMuz3 - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ3

1.74 MultiMuz3 - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ3 firmy JM-Tronik

Przeznaczenie drajwera

Drajwer MultiMuz3 służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie.

Drajwer obsługuje następujące typy zabezpieczeń MultiMuz3:

- 01.07

- 01.09

- 10.02

- 10.11

- 10.12

- 23.01

- 26.01

- MegaMuz2 01.12 (obsługiwany w trybie MultiMuz3)

- LR96

Drajwer realizuje następujące funkcje:

- odczyt aktualnych stanów i pomiarów,

- odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

- odczyt zakłóceń z rejestratora zakłóceń i rejestratora kryterialnego oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MultiMuz3 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MultiMuz3

Zakładka MultiMuz3/Parametry kanału:

Identyfikacja:

Numer urządzenia w sieci - numer urządzenia w sieci MODBUS,

Typ urządzenia - typ urządzenia,

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Parametry transmisji:

Port - nazwa portu (COM1, ...),

Prędkość transmisji - predefiniowana prędkość transmisji.

Zmienne kontrolne:

Zmienna służąca do prezentacji statusu transmisji z urządzeniem:

0 - stan transmisji o.k.

1 - brak/błędy komunikacji,

2 - wyłączenie urządzenia z obsługi,

Zmienna służąca do sterowania stanem transmisji z urządzeniem:

1 - żądanie wyłączenia urządzenia z obsługi,

0 - włączenie urządzenia do obsługi.

Uwaga:

Zmienne muszą należeć do kanału typu NONE.

Synchronizacja czasu:

Okres - okres synchronizacji czasu z urządzeniem (w sekundach).

Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora zakłóceń (odczyt)

RQ - żądanie odczytu rejestratora zakłóceń (zapis)

RT - czas wyzwolenia rejestratora zakłóceń (odczyt)

MN - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator zakłóceń (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora zakłóceń (odczyt)

RSKR - powód wyzwolenia rejestratora kryterialnego (odczyt)

RQKR - żądanie odczytu rejestratora kryterialnego (zapis)

RTKR - czas wyzwolenia rejestratora kryterialnego (odczyt)

MNKR - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator kryterialnego (odczyt)

RNKR - numer aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

RRKR - status aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

SNKR - numer ostatnio odczytanej próbki rejestratora kryterialnego (odczyt)

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

1. indeksów nie podaje się dla typów: MN, RN, RR, RQ, SN, MNKR, RNKR, RRKR, RQKR i SNKR

2. w przypadku typów RS, RT, RSKR, RTKR zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

3. parametrem żądania odczytu rejestratora (typ RQ, RQKR ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

4. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych:

ZM_07, nr odczytywanego rejestratora zakłóceń, RN, KLR,1,1,NIC

ZM_08, status odczytu rejestratora zakłóceń, RR, KLR,1,1,NIC

ZM_09, nr odczytanej próbki z rejestratora zakłóceń, SN, KLR_01,1,1,NIC

ZM_10, żądanie odczytu rejestratora kryterialnego, RQKR, KLR,1,1,NIC

ZM_11, nr odczytywanego rejestratora kryterialnego, RNKR, KLR,1,1,NIC

ZM_12, status odczytu rejestratora kryterialnego, RRKR, KLR,1,1,NIC

ZM_13, nr odczytanej próbki z rejestratora kryterialnego, SNKR, KLR_01,1,1,NIC

Odczyt rejestratorów

Drajwer umożliwia rejestrację przebiegów rejestratorów zakłóceń oraz rejestratorów kryterialnych w bazie danych programu AsLogger. Przeglądanie zarejestrowanych przebiegów jest możliwe wyłącznie przy pomocy programu AsLogger.

Rejestracja przebiegów obu typów rejestratorów wymaga, aby w parametrach drajwera MULTIMUZ3 zadeklarować opcję Rejestracja zakłóceń w bazie AsLogger, która określa:

- nazwę serwera MSSQL,

- nazwę bazy danych,

w których drajwer będzie zapisywać odczytane przebiegi rejestratorów.

Drajwer nie wykonuje automatycznej rejestracji przebiegów - rejestracja przebiegu musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ (rejestrator zakłóceń) lub RQKR (rejestrator kryterialny). Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z urządzenia i zapisać do bazy danych programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN, MNKR - numer urządzenia w sieci MODBUS,

b/ RN, RNKR - numer odczytywanego rejestratora,

c/ RR, RNKR - status odczytu rejestratora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN, SNKR - numer ostatnio odczytanej próbki.

Rejestracja przebiegów rejestratorów odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w rekordzie rejestratora opisane w dokumentacji protokołu wersja 01.07:

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu - będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu ’.def’. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy określić w opcji Katalog plików zawierających nazwy planów rejestracji w parametrach drajwera MULTIMUZ3.

Składnia definicji nazwy planu rejestracji umieszczana w pliku ’.def’ jest następująca:

kanał, typ, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

typ - typ rejestratora (K - kryterialny, Z - zakłóceń),

powód - liczba identyfikująca powód wyzwolenia rejestratora (zgodna ze

specyfikacją podaną w opisie protokołu wersja 01.07)

tabela - nazwa planu rejestracji,

komentarz - komentarz

Przykład:

Definicje nazw planów rejestracji dla rejestratora zakłóceń:

- zadziałanie zabezpieczenia zwarciowego (powód wyzwolenia nr 2)

- zamknięcie wyłącznika (powód wyzwolenia nr 31)

w kanale ASMENA o nazwie KTR_06:

KTR_06, Z, 2, Pole06ZadzZabezpZwarciowego, zadziałanie zabezpieczenia zwarciowego

KTR_06, Z, 31, Pole06ZamkWylacznika, zamknięcie wyłącznika

Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Dla rejestratorów zakłóceń składnia ma postać:

NrxxxipyyyPowod

gdzie:

xxx - numer urządzenia w sieci MODBUS,

yyy - najmłodszy element adresu IP urządzenia,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Dla rejestratorów kryterialnych składnia ma postać:

NrxxxkryyyPowod

gdzie:

xxx - numer urządzenia w sieci MODBUS,

yyy - najmłodszy element adresu IP urządzenia,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w MultiMuzie3 o numerze 2 w sieci MODBUS oraz adresie IP 10.10.12.5 zostanie zbudowany plan rejestracji o nazwie:

Nr002ip005wyzw_rej_od_log_użytk

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona przez globalną opcję Okres sprawdzania zdarzeń. Zdarzenia odczytywane z urządzeń są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie podane w pliku NumeryAlarmowAsixaVerxx.xls oraz offset alarmu podany w deklaracji kanału Asmena. Do alarmów Asixa są przekazywane następujące parametry zdarzeń (wg typów zdarzeń):

a/ typ 01H - wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) zamiast wartość word jest przekazywany tekst opisujący fazy )

b/ typ 02H - wartość int oraz wartość word

c/ typ 04H - wartość int oraz wartość word

d/ typ 08H - wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) wartość word zawiera identyfikator przyczyny zdarzenia)

e/ typ 11H - wartość word

f/ typ 12H - wartość word

g/ typ 14H - wartość word

h/ typ 21H (*2) (*3) - numer łącznika, identyfikator miejsca sterowania

i/ typ 21H (*2) - numer łącznika

j/ typ 21H (*3) - identyfikator miejsca sterowania

k/ typ 21H - wartość word

l/ typ 52H - wartość word

ł/ typ 54H - wartość word

m/ typ 92H - wartość word

n/ typ 94H - wartość word

Przykład 1:

Zdarzenie Zamknięcie wyłącznika z SZR (zdarzenie typu 21H o kodzie 161) jest mapowane na numer alarmu Asixa o wartości 190. Jeśli w deklaracji kanału ASMENA obsługującego dane urządzenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 190 = 590):

590, al, zamknięcie wyłącznika z SZR

Parametryzacja drajwera

Parametry drajwera MultiMuz3 deklarowane są na zakładkach: MultiMuz3/Parametry drajwera, MultiMuz3/Parametry drajwera - AsLogger, MultiMuz3/Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera Asix.

Wartość domyślna - brak.

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcja jest wyłączona.

R Plik logu zakłóceń

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna - brak.

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie - opcja umożliwia rejestrację przebiegów rejestratorów zakłóceń oraz rejestratorów kryterialnych w bazie danych programu AsLogger. Przeglądanie zarejestrowanych przebiegów jest możliwe wyłącznie przy pomocy programu AsLogger.

Parametr:

nazwę serwera MSSQL,

nazwę bazy danych,

w których drajwer będzie zapisywać odczytane przebiegi rejestratorów.

Wartość domyślna - brak.

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie - opcja służy do zadeklarowania ścieżki do katalogu zawierającego pliki z definicjami nazw planów rejestracji.

Parametr:

ścieżka - ścieżka do katalogu.

Wartość domyślna - brak.

R Liczba powtórzeń

Znaczenie - opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna - 3.

R Timeout odpowiedzi

Znaczenie - określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość domyślna - domyślna wartość timeoutu odbioru wynosi 1000 milisekund.

Parametr:

liczba - wartość timeoutu w milisekundach.

R Timeout znaku

Znaczenie - określa czas zwłoki (w milisekundach), pomiędzy wysłaniem zapytania do urządzenia i uruchomieniem operacji odbioru odpowiedzi. Użycie pozycji ma sens w przypadku znacznego pofragmentowania odpowiedzi.

Wartość domyślna - domyślna wartość zwłoki odbioru wynosi 50 milisekund.

Parametr:

liczba - wartość zwłoki odbioru w milisekundach

R Okres sprawdzania zdarzeń

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna - 10.

R Zwłoka po braku odpowiedzi

Znaczenie - czas, przez który zapytania do drajwera będą blokowane po tym jak ostatnie zapytanie zakończyło się brakiem odpowiedzi.

Parametr:

liczba - czas liczony w sekundach.

Wartość domyślna - 0 - brak blokowania.

Parametry definiowane dla indywidualnych kanałów w sekcjach o nazwie kanału Asmena

Parametry kanału drajwera MultiMuz3 deklarowane są na zakładkach: MultiMuz3/Parametry kanału 2, MultiMuz3/Parametry kanału - diagnostyka, MultiMuz3/Parametry kanału - nazwy łączników:

R Timeout odpowiedzi

Znaczenie - określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość domyślna - domyślna wartość timeoutu odbioru wynosi 1000 milisekund.

Parametr:

liczba - wartość timeoutu w milisekundach.

R Timeout znaku

Znaczenie - określa czas zwłoki (w milisekundach), pomiędzy wysłaniem zapytania do urządzenia i uruchomieniem operacji odbioru odpowiedzi. Użycie pozycji ma sens w przypadku znacznego pofragmentowania odpowiedzi.

Wartość domyślna - domyślna wartość zwłoki odbioru wynosi 50 milisekund.

Parametr:

liczba - wartość zwłoki odbioru w milisekundach.

R Bez zdarzeń

Znaczenie - wyłączenie odczytu zdarzeń dla bieżącego kanału.

Wartość domyślna - brak ograniczeń odczytu.

R Zwłoka po braku odpowiedzi

Znaczenie - czas, przez który zapytania do drajwera będą blokowane po tym jak ostatnie zapytanie zakończyło się brakiem odpowiedzi.

Parametr:

liczba - czas liczony w sekundach.

Wartość domyślna - 0 - brak blokowania.

R Nazwa łącznika 1, 2, ...7

Znaczenie - opcja służy do określenia nazw łączników, które zostana przekazane do systemu alarmów. Nazwa łącznika nie może być dłuższa niż 3 znaki. Można zdefiniować nazwy dla max 7-miu łączników o numerach od 1 do 7.

Parametr:

tekst - 3-literowa nazwa łącznika.

Wartość domyślna - domyślnie łączniki mają nazwy 1,2,3, ...7.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy kanału.

Wartość domyślna - brak.

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcja jest wyłączona.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MultiMuz3_TCPIP

Home > 1.75 MultiMuz3_TCPIP - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ3

1.75 MultiMuz3_TCPIP - drajwer mikroprocesorowych urządzeń zabezpieczających typu MultiMUZ3 firmy JM-Tronik

Przeznaczenie drajwera

Drajwer MultiMuz3_TCPIP służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu MultiMUZ3, produkowanymi przez firmę JM-Tronik w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU na TCPIP przy pomocy łącza Ethernet i portu 10502.

Drajwer realizuje następujące funkcje:

- odczyt aktualnych stanów i pomiarów,

- odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

- odczyt zakłóceń z rejestratora zakłóceń i rejestratora kryterialnego oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Drajwer obsługuje następujące typy zabezpieczeń MultiMuz3:

- 01.07

- 01.09

- 10.02

- 10.11

- 10.12

- 23.01

- 26.01

- MegaMuz2 01.12 (obsługiwany w trybie MultiMuz3)

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MultiMuz3_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MultiMuz3_TCPIP

Zakładka MultiMuz3_TCPIP/Parametry kanału:

Identyfikacja:

Numer urządzenia w sieci - numer urządzenia w sieci MODBUS,

Typ urządzenia - typ urządzenia,

Adres IP urządzenia - adres IP urządzenia;

Offset alarmów - offset dodawany do wyliczonego numeru alarmu Asixa,

Zmienne kontrolne:

Zmienna służąca do prezentacji statusu transmisji z urządzeniem:

0 - stan transmisji o.k.

1 - brak/błędy komunikacji,

2 - wyłączenie urządzenia z obsługi,

Zmienna służąca do sterowania stanem transmisji z urządzeniem:

1 - żądanie wyłączenia urządzenia z obsługi,

0 - włączenie urządzenia do obsługi.

Uwaga:

Zmienne muszą należeć do kanału typu NONE.

Synchronizacja czasu:

Okres - okres synchronizacji czasu z urządzeniem (w sekundach).

Wartość 0 oznacza brak synchronizacji czasu (wartość domyślna).

Adres IP komputera - adres IP komputera, poprzez który kanał będzie się łączył ze sterownikiem.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KSR_67, w którym jest obsługiwany MultiMuz3 o numerze sieciowym 5, adresie IP 10.10.12.5 i offsecie alarmów 200. Stan kanału pokazuje zmienna MuzStat05, kontrolę kanału umożliwia zmienna MuzCtrl05, synchronizacja czasu odbywa się co 60 sekund:

Nazwa kanału: KSR_67

Numer urządzenia w sieci: 5

Adres IP urządzenia: 10.10.12.5

Offset alarmów: 200

Zmienna służąca do prezentacji statusu transmisji z urządzeniem: MuzStat05

Zmienna służąca do sterowania stanem transmisji z urządzeniem: MuzCtrl05

Okres: 60

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

CS - wartość binarna (zapis),

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

oraz wewnętrzne zmienne drajwera:

RS - powód wyzwolenia rejestratora zakłóceń (odczyt)

RQ - żądanie odczytu rejestratora zakłóceń (zapis)

RT - czas wyzwolenia rejestratora zakłóceń (odczyt)

MN - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator zakłóceń (odczyt)

RN - numer aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

RR - status aktualnie/ostatnio odczytywanego rejestratora zakłóceń (odczyt)

SN - numer ostatnio odczytanej próbki rejestratora zakłóceń (odczyt)

RSKR - powód wyzwolenia rejestratora kryterialnego (odczyt)

RQKR - żądanie odczytu rejestratora kryterialnego (zapis)

RTKR - czas wyzwolenia rejestratora kryterialnego (odczyt)

MNKR - numer sieciowy urządzenia, z którego jest/był

odczytywany rejestrator kryterialnego (odczyt)

RNKR - numer aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

RRKR - status aktualnie/ostatnio odczytywanego rejestratora kryterialnego (odczyt)

SNKR - numer ostatnio odczytanej próbki rejestratora kryterialnego (odczyt)

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika. (odczyt/zapis)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

1. indeksów nie podaje się dla typów : MN, RN, RR, RQ, SN, MNKR, RNKR, RRKR, RQKR i SNKR

2. w przypadku typów RS, RT, RSKR, RTKR zakres indeksów zależy od liczby rejestratorów zdefiniowanych w urządzeniu,

3. parametrem żądania odczytu rejestratora (typ RQ, RQKR ) jest numer rejestratora. Rejestratory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu rejestratora,

4. w celu prezentacji czasu wyzwolenia rejestratora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

Przykłady deklaracji zmiennych:

ZM_07, nr odczytywanego rejestratora zakłóceń, RN, KLR,1,1,NIC

ZM_08, status odczytu rejestratora zakłóceń, RR, KLR,1,1,NIC

ZM_09, nr odczytanej próbki z rejestratora zakłóceń, SN, KLR_01,1,1,NIC

ZM_10, żądanie odczytu rejestratora kryterialnego, RQKR, KLR,1,1,NIC

ZM_11, nr odczytywanego rejestratora kryterialnego, RNKR, KLR,1,1,NIC

ZM_12, status odczytu rejestratora kryterialnego, RRKR, KLR,1,1,NIC

ZM_13, nr odczytanej próbki z rejestratora kryterialnego, SNKR, KLR_01,1,1,NIC

Odczyt rejestratorów

Drajwer umożliwia rejestrację przebiegów rejestratorów zakłóceń oraz rejestratorów kryterialnych w bazie danych programu AsLogger. Przeglądanie zarejestrowanych przebiegów jest możliwe wyłącznie przy pomocy programu AsLogger.

Rejestracja przebiegów obu typów rejestratorów wymaga, aby w parametrach drajwera MULTIMUZ3_TCPIP zadeklarować opcję Rejestracja zakłóceń z bazie AsLogger, która określa:

- nazwę serwera MSSQL,

- nazwę bazy danych,

w których drajwer będzie zapisywać odczytane przebiegi rejestratorów.

Drajwer nie wykonuje automatycznej rejestracji przebiegów - rejestracja przebiegu musi być każdorazowo zainicjowana przez operatora systemu ASIX poprzez wykonanie sterowania zmienną typu RQ (rejestrator zakłóceń) lub RQKR (rejestrator kryterialny). Jako wartość sterującą podaje się numer rejestratora, którego zawartość należy odczytać z urządzenia i zapisać do bazy danych programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu rejestratora.

W trakcie odczytu rejestratora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN, MNKR - numer urządzenia w sieci MODBUS,

b/ RN, RNKR - numer odczytywanego rejestratora,

c/ RR, RNKR - status odczytu rejestratora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem.

d/ SN, SNKR - numer ostatnio odczytanej próbki.

Rejestracja przebiegów rejestratorów odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w rekordzie rejestratora opisane w dokumentacji protokołu wersja 01.07:

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu - będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu ’.def’. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w danym kanale. Pliki zawierające definicje nazw planów należy zapisać do wspólnej kartoteki. Nazwę tej kartoteki należy umieścić w opcji Katalog plików zawierających nazwy planów rejestracji w parametrach drajwera MULTIMUZ3_TCPIP.

Składnia definicji nazwy planu rejestracji umieszczana w pliku ’.def’ jest następująca:

kanał, typ, powód, tabela [, komentarz]

gdzie:

kanał - nazwa kanału ASMENA,

typ - typ rejestratora (K - kryterialny, Z - zakłóceń),

powód - liczba identyfikująca powód wyzwolenia rejestratora (zgodna ze

specyfikacją podaną w opisie protokołu wersja 01.07)

tabela - nazwa planu rejestracji,

komentarz - komentarz

Przykład:

Definicje nazw planów rejestracji dla rejestratora zakłóceń:

- zadziałanie zabezpieczenia zwarciowego (powód wyzwolenia nr 2)

- zamknięcie wyłącznika (powód wyzwolenia nr 31)

w kanale ASMENA o nazwie KTR_06:

KTR_06, Z, 2, Pole06ZadzZabezpZwarciowego, zadziałanie zabezpieczenia zwarciowego

KTR_06, Z, 31, Pole06ZamkWylacznika, zamknięcie wyłącznika

Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Dla rejestratorów zakłóceń składnia ma postać:

NrxxxipyyyPowod

gdzie:

xxx - numer urządzenia w sieci MODBUS,

yyy - najmłodszy element adresu IP urządzenia,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Dla rejestratorów kryterialnych składnia ma postać:

NrxxxkryyyPowod

gdzie:

xxx - numer urządzenia w sieci MODBUS,

yyy - najmłodszy element adresu IP urządzenia,

Powod - skrót identyfikujący powód wyzwolenia rejestratora.

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w MultiMuzie3 o numerze 2 w sieci MODBUS oraz adresie IP 10.10.12.5 zostanie zbudowany plan rejestracji o nazwie:

Nr002ip005wyzw_rej_od_log_użytk

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona przez globalną opcję Okres sprawdzania zdarzeń. Zdarzenia odczytywane z urządzeń są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o mapowanie podane w pliku NumeryAlarmowAsixaVerxx.xls oraz offset alarmu podany w deklaracji kanału ASMENA. Do alarmów Asixa są przekazywane następujące parametry zdarzeń (wg typów zdarzeń):

a/ typ 01H - wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) zamiast wartość word jest przekazywany tekst opisujący fazy )

b/ typ 02H - wartość int oraz wartość word

c/ typ 04H - wartość int oraz wartość word

d/ typ 08H - wartość int oraz wartość word (dla zdarzeń oznaczonych (*1) wartość word zawiera identyfikator przyczyny zdarzenia)

e/ typ 11H - wartość word

f/ typ 12H - wartość word

g/ typ 14H - wartość word

h/ typ 21H (*2) (*3) - numer łącznika, identyfikator miejsca sterowania

i/ typ 21H (*2) - numer łącznika

j/ typ 21H (*3) - identyfikator miejsca sterowania

k/ typ 21H - wartość word

l/ typ 52H - wartość word

ł/ typ 54H - wartość word

m/ typ 92H - wartość word

n/ typ 94H - wartość word

Przykład 1:

Zdarzenie Zamknięcie wyłącznika z SZR (zdarzenie typu 21H o kodzie 161) jest mapowane na numer alarmu Asixa o wartości 190. Jeśli w deklaracji kanału ASMENA obsługującego dane urządzenie podano offset alarmów o wartości 400, to definicja alarmu w pliku definicji alarmów Asixa będzie miała postać (400 + 190 = 590):

590, al, zamknięcie wyłącznika z SZR

Parametryzacja drajwera

Parametry drajwera MultiMuz3_TCPIP deklarowane są na zakładkach: MultiMuz3_TCPIP/Parametry drajwera, MultiMuz3_TCPIP/Parametry drajwera - diagnostyka:

R Liczba powtórzeń

Znaczenie - opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna - 3.

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: PLIK_LOGU_ZAKLOCEN
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: OKRES_SPRAWDZANIA_ZDARZEN
R Wartość opcji: liczba

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość domyślna - domyślnie wartość opcji wynosi 10 sekund.

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: REJESTRATOR
R Wartość opcji: NazwaSerwera, NazwaBazy

Znaczenie - opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość domyślna - domyślnie zakłócenia nie są rejestrowane.

Parametry:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Nazwa sekcji: MultiMuz3_TCPIP
R Nazwa opcji: SCIEZKA_NAZW_ZAKLOCEN
R Wartość opcji: NazwaSerwera, NazwaBazy

Znaczenie - określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Parametry:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji

Parametry definiowane dla indywidualnych kanałów w sekcjach o nazwie kanału Asmena

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: liczba

Znaczenie - określa maksymalny czas (w milisekundach), przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość domyślna - domyślna wartość timeoutu odbioru wynosi 500 milisekund.

Parametr:

liczba - wartość timeoutu w milisekundach

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: ZWLOKA_ODBIORU
R Wartość opcji: liczba

Znaczenie - określa czas zwłoki (w milisekundach), pomiędzy wysłaniem zapytania do urządzenia i uruchomieniem operacji odbioru odpowiedzi. Użycie pozycji ma sens w przypadku znacznego pofragmentowania odpowiedzi.

Wartość domyślna - domyślna wartość zwłoki odbioru wynosi 20 milisekund.

Parametr:

liczba - wartość zwłoki odbioru w milisekundach

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie komunikaty dotyczące kanału wpisywane są do pliku logu drajwera.

Parametr:

nazwa pliku

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcje jest wyłączona.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: TAK | NIE

Znaczenie - opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Parametr:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna - domyślnie parametr przyjmuje wartość liczby powtórzeń ustawioną w sekcji drajwera.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: MAX_LICZBA_REJESTROW
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia max. liczby rejestrów, o które drajwer może zapytać w jednym poleceniu w danym kanale.

Parametr:

liczba - max. liczba rejestrów w pojedynczym zapytaniu.

Wartość domyślna - domyślnie parametr przyjmuje wartość 119.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: ADRES_IP
R Wartość opcji: adres_karty

Znaczenie - opcja służy do określenia adresu IP karty sieciowej komputera, poprzez którą będzie realizowana komunikacja w danym kanale.

Parametr:

adres karty - adres IP karty sieciowej komputera.

Wartość domyślna - domyślnie wykorzystuje się kartę sieciową przydzieloną przez system Windows.

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: PORT
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia numeru portu komputera, poprzez którą będzie realizowana komunikacja w danym kanale.

Parametr:

liczba - numer portu.

Wartość domyślna - domyślnie wykorzystuje się port przydzielony przez system Windows.

PRZYKŁAD

Przykładowa sekcja drajwera

[MULTIMUZ_TCPIP]

PLIK_LOGU=c:\tmp\muz.log

PLIK_LOGU_ZAKLOCEN=c:\tmp\zaklocenia.log

ROZMIAR_PLIKU_LOGU=20

LOG_TELEGRAMOW=TAK

REJESTRATOR=SERWER_RO6, BAZA_RO6

SCIEZKA_NAZW_ZAKLOCEN=c:\tmp\DefZaklocen

PRZYKŁAD

Przykładowa sekcja kanału

Przykładowa sekcja kanału o nazwie KANAL.

[KANAL]

PLIK_LOGU=c:\tmp\kanal_1.log

ROZMIAR_PLIKU_LOGU=30

LOG_TELEGRAMOW=TAK

ADRES_IP=10.10.112.8

MAX_LICZBA_REJESTROW=53

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MUPASZ - drajwer protokołu sterownika MUPASZ

Home > 1.76 MUPASZ - drajwer protokołu sterownika MUPASZ

1.76 MUPASZ - drajwer protokołu sterownika MUPASZ

Przeznaczenie drajwera

Protokół MUPASZ jest wykorzystywany do wymiany danych pomiędzy urządzeniami MUPASZ lub MUPASZ2000 oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych w standardzie RS232C lub RS485.

Parametryzacja drajwera MUPASZ realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu MUPASZ wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MUPASZ

Zakładka MUPASZ / Parametry kanału:

Urządzenie zdalne:

- Numer urządzenia zdalnego

- Nazwa portu szeregowego: COM1 ... COM256

Alarmy:

- Liczba dodawana do numeru zdarzenia o trybie wykonania sygnalizacjaw celu zbudowania unikalnego numeru alarmu przekazywanego do systemu Asix

- Liczba dodawana do numeru zdarzenia o trybie wykonania wyłączenie w celu zbudowania unikalnego numeru alarmu przekazywanego do systemu Asix

;- Liczba dodawana do numeru zdarzenia o trybie wykonania wyłączenie z blokadą w celu zbudowania unikalnego numeru alarmu przekazywanego do systemu Asix

Przykład

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu MUPASZ:

Nazwał: KANAL1

Drajwer: MUPASZ

Numer urządzenia zdalnego: 4

Port: COM1

Liczba dodawana do numeru zdarzenia sygnalizacja: 100

Liczba dodawana do numeru zdarzenia wyłączenie: 200

Liczba dodawana do numeru zdarzenia wyłączenie z blokadą: 300

Drajwer MUPASZ jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ_zmiennej><kanał>.<indeks>

gdzie:

typ_zmiennej - typ zmiennej procesowej,

indeks - indeks zmiennej procesowej w ramach typu.

Typy zmiennych procesowych:

P - wartości pomiarów (FLOAT),

B - stany blokad przychodzących z pomiarami (WORD),

L - wartości liczników (WORD),

F - statusy przychodzące z pomiarami i zdarzeniami (WORD).

PRZYKŁAD

Przykład deklaracji zmiennych:

X1, prąd Io, P1, KANAL1, 1, 1, NIC_FP

X2, I1 skum., P31, KANAL1, 1, 1, NIC_FP

X3, stan blokady nr 1, B1, KANAL1, 1, 1, NIC

X4, licznik otwarć wyłącznika, L1, KANAL1, 1, 1, NIC

X5, licznik rozruchów silnika, L25, KANAL1, 1, 1, NIC

X6, stan wyłącznika, F1, KANAL1, 1, 1, NIC

Generowanie alarmów

Numery zdarzeń, generowanych przez urządzenia zdalne, mają ten sam zakres zmienności. Aby móc jednoznacznie określić, z którego urządzenia pochodzi przedmiotowe zdarzenie, drajwer MUPASZ dodaje do numeru zdarzenia liczbę, specyfikowaną w deklaracji kanału jako AlSygOf (dla sygnalizacji), AlWyłOf (dla wyłączeń) lub AlBlokOf (dla wyłączeń z blokadą). Tak powstała liczba jest przekazywana do systemu Asix jako numer alarmu.

Dla niektórych alarmów drajwer MUPASZ może przekazać wartości przychodzące ze zdarzeniami (czas pobudzenia lub prąd). Wartości te mogą być odczytane przez podanie łańcucha formatującego (%3.0f) w definicji komunikatu alarmowego.

Do przekazywania alarmów drajwer MUPASZ domyślnie wykorzystuje funkcję AsixAddAlarmGlobalMili(). Opcja ALARMY_GLOBALNE pozwala na zmianę ustawień domyślnych i przekazywania alarmów funkcją AsixAddAlarmMili().

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące na zakładce MUPASZ / Parametry drajwera kanału działającego według protokołu drajwera MUPASZ.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera MUPASZ oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer MUPASZ. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

Parametry:

nazwa pliku

R Zwłoka transmisji

Znaczenie - opcja pozwala określić odstęp czasu (jako wielokrotność 10 msek) pomiędzy kolejnymi operacjami na magistrali MUPASZ.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1 (10 msek).

Parametry:

liczba

R Liczba powtórzeń

Znaczenie - opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie opcja przyjmuje wartość 0 (nie ma powtórzeń).

Parametry:

liczba

R Aktualizacja danych

Znaczenie - opcja pozwala określić okres czasu (w sekundach), po upływie którego należy odświeżyć wartości zmiennych procesowych trzymanych w buforach wewnętrznych drajwera.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1.

Parametry:

liczba

R Aktualizacja czasu

Znaczenie - opcja pozwala określić okres czasu (w sekundach), po upływie którego należy wysłać aktualny czas do urządzeń zdalnych.

Wartość domyślna - domyślnie opcja przyjmuje wartość 60.

Parametry:

liczba

R Alarmy globalne

Znaczenie - opcja steruje sposobem przekazywania alarmów odczytanych z urządzeń zdalnych do systemu alarmów systemu Asix.

Wartość domyślna - domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości opcji Alarmy globalne na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili().

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


1. Drajwery komunikacyjne

Home > 1.77 Mupasz710_RS - drajwer mikroprocesorowych urządzeń zabezpieczających typu Mupasz 710

1.77 Mupasz710_RS - drajwer mikroprocesorowych urządzeń zabezpieczających typu Mupasz 710

Przeznaczenie drajwera

Drajwer Mupasz710_RS służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie. Komunikacja jest realizowana przy użyciu łącza szeregowego oraz protokołu MODBUS.

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

  • odczyt zakłóceń z rejestratora zakłóceń oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Uwaga:

Użycie funkcji związanych z odczytem rejestratora zakłóceń oraz rejestracją zakłóceń w bazie programu AsLogger wymaga posiadania odpowiedniej licencji systemu Asix.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Mupasz710_RS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji
Drajwer: Mupasz710_RS

Zakładka Mupasz710_RS/Parametry kanału:

Adres

Numer urządzenia w sieci MODBUS,

Parametry transmisji

Port - nazwa portu szeregowego,

Prędkość transmisji - prędkość transmisji. Domyślnie 115200 Bd,

Kontrola parzystości - numer alarmu zgłaszanego do systemu alarmów Asixa w przypadku braku komunikacji ze sterownikiem,

Liczba bitów stopu - max. czas (w milisekundach) oczekiwania na odpowiedź ze sterownika.

Offset alarmów

Offset dodawany do wyliczonego numeru alarmu zgłaszanego do systemu Asix

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KANAL, w którym jest obsługiwany Mupasz 710 o numerze 2 na porcie COM3 i offsecie alarmów 200:

Numer urządzenia w sieci MODBUS: 2

Port: COM3

Prędkość transmisji: 9600

Kontrola parzystości: NONE

Liczba bitów stopu: 1

Offset alarmów: 200

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

(odczyt/zapis)

oraz wewnętrzne zmienne drajwera:

MN - numer sieciowy urządzenia, z którego jest odczytywany

lub został odczytany sektor (odczyt)

RN - numer aktualnie/ostatnio odczytywanego sektora (odczyt)

RQ - żądanie odczytu sektora (zapis)

RR - status aktualnie/ostatnio odczytywanego sektora (odczyt)

RS - stan rejestratora (niedostępny/pusty/zapisany) (odczyt)

RT - czas wyzwolenia zakłócenia zapisanego w sektorze (odczyt)

SN - bieżący licznik rejestrów HR odczytywanych z sektora (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej 'Typ'.

UWAGI:

  1. indeksów nie podaje się dla typów: MN, RN, RQ, RR i SN

  2. w przypadku typów RS, RT zakres indeksów zależy od liczby sektorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu sektora (typ RQ ) jest numer sektora. Sektory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu sektora,

  4. w celu prezentacji czasu wyzwolenia sektora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

PRZYKŁAD

Przykłady deklaracji zmiennych:

ZM_01, wartość nominalna Un, HR8235, KLR, 1, 1, NIC

ZM_02, wartość nominalna In, HR8236, KLR, 1, 1, NIC

ZM_03, czas wyzwolenia zakłócenia w sektorze 1, RT1, KLR, 1, 1, DATACZAS_MUZ

ZM_04, żądanie odczytu sektora, RQ, KLR, 1, 1, NIC

ZM_05, nr odczytywanego sektora, RN, KLR, 1, 1, NIC

ZM_06, status odczytu sektora, RR, KLR, 1, 1, NIC

ZM_07, licznik rejestrów odczytanych z sektora, SN, KLR, 1 ,1, NIC_DW

Odczyt rejestratora zakłóceń

Drajwer umożliwia rejestrację przebiegów rejestratora zakłóceń w bazie danych programu AsLogger. Przeglądanie zarejestrowanych przebiegów jest możliwe wyłącznie przy pomocy programu AsLogger.

Rejestracja przebiegów rejestratora zakłóceń wymaga, aby na zakładce Parametry drajwera - AsLogger zdefiniować opcję Rejestracja zakłóceń w bazie AsLogger, która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych AsLogger,

w których drajwer będzie zapisywać odczytane przebiegi rejestratorów.

Drajwer nie wykonuje automatycznej rejestracji przebiegów - rejestracja przebiegu musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer sektora, którego zawartość należy odczytać z urządzenia i zapisać do bazy danych programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu sektora.

W trakcie odczytu sektora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer urządzenia w sieci MODBUS,

b/ RN - numer odczytywanego sektora,

c/ RR - status odczytu sektora:

0 - odczyt nieaktywny lub zakończony o.k.

1 - odczyt uruchomiony

2 - odczyt ostatniej ramki zakończony o.k.

3 - odczyt ostatniej ramki zakończony z błędem

4 - odczyt sektora zakończony z błędem

5 - odczyt sektora zakończony o.k.

6 - odczyt sektora przerwany przez operatora

d/ SN - bieżący licznik rejestrów odczytanych z sektora.

Rejestracja przebiegów rejestratorów odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika w plikach tekstowych, które są czytane przez drajwer na etapie startu aplikacji,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji przebiegu drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w sektorze

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu - będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

Parametr Liczba powtórzeń rejestratora zakłóceń (ustawiany na zakładce Parametry drajwera - AsLogger) pozwala określić liczbę powtórzeń w przypadku błędu transmisji.

  • Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu 'def'. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w tym kanale. Pliki zawierające definicje nazw planów rejestracji należy umieścić we wspólnej kartotece, której nazwę należy podać jako wartość opcji Ścieżka plików nazw zaklóceń na zakładce Parametry drajwera - AsLogger.

Składnia definicji nazwy planu rejestracji umieszczana w pliku 'def' jest następująca:

Kanał, Powód, FormatAi, FormatDi, Tabela [, Komentarz]

gdzie:

Kanał - nazwa kanału ASMENA,

Powód - liczba identyfikująca powód wyzwolenia rejestratora,

FormatAi - maska pomiarów analogowych w zapisie HEX (6 znaków),

FormatDi - maska wejść dwustanowych w zapisie HEX (2 znaki),

Tabela - nazwa planu rejestracji,

Komentarz - komentarz (opcja);

PRZYKŁAD:

Definicja nazwy planu rejestracji dla rejestracji zakłócenia o parametrach:

- wartość napięcia U1 < (powód wyzwolenia nr 1),

- maska analogów 0000FF - rejestracja U1, U2, U3, U0 oraz I1, I2, I3, I0

- maska dwustanów 0001 - rejestracja stanów wejść 1 - 16

w kanale KTR:

KTR, 1, 0000FF, 0001, Pole05SpadekNapieciaU1

  • Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Nazwy planów wygenerowane przez drajwer mają składnię:

NazwaKanału.Powód.FormatAi.FormatDi

gdzie:

NazwaKanału - nazwa kanału Asmena, w którym odczytano zakłócenie,

Powód - identyfikator powodu wyzwolenia rejestratora,

FormatAi - maska pomiarów analogowych w zapisie HEX (6 znaków),

FormatDi - maska wejść dwustanowych w zapisie HEX (2 znaki).

PRZYKŁAD:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w urządzeniu obsługiwanym w kanale Asmena o nazwie KANAL z ustawioną rejestracją:

analogów: U1, U2, U3, U0, I1, I2, I3, I0

oraz

dwustanów: wejścia 1-16, wejścia 17-32, wyjścia 1-16

zostanie zbudowany plan rejestracji o nazwie:

KANAL.29.000FF.0023

  • Identyfikatory powodów wyzwolenia rejestratora

Poniżej podano zestawienie identyfikatorów powodów wyzwolenia rejestratora.

01 U1LE wartość napięcia U1 jako parametr

02 U2LE wartość napięcia U2 jako parametr

03 U3LE wartość napięcia U3 jako parametr

04 U0LE wartość napięcia Uo jako parametr

05 I1LE wartość prądu I1 jako parametr

06 I2LE wartość prądu I2 jako parametr

07 I3LE wartość prądu I3 jako parametr

08 I0LE wartość prądu Io jako parametr

09 I1LESEC wartość prądu I1sec jako parametr

10 I2LESEC wartość prądu I2sec jako parametr

11 I3LESEC wartość prądu I3sec jako parametr

12 I0LESEC wartość prądu Iosec jako parametr

13 U1GT wartość napięcia U1 jako parametr

14 U2GT wartość napięcia U1 jako parametr

15 U3GT wartość napięcia U1 jako parametr

16 U0GT wartość napięcia Uo jako parametr

17 I1GT wartość prądu I1 jako parametr

18 I2GT wartość prądu I2 jako parametr

19 I3GT wartość prądu I3 jako parametr

20 I0GT wartość prądu Io jako parametr

21 I1GTSEC wartość prądu I1sec jako parametr

22 I2GTSEC wartość prądu I2sec jako parametr

23 I3GTSEC wartość prądu I3sec jako parametr

24 I0GTSEC wartość prądu Iosec jako parametr

25 DIN numer wejścia wyzwalającego jako parametr (1..80)

26 DOUT numer wyjścia wyzwalającego jako parametr (1..80)

27 SIG numer rejestru wyzwalającego jako parametr (1..80)

28 OIN numer wejścia wyzwalającego jako parametr (1..8)

29 USER wyzwolenie rejestratora przez użytkownika:

parametr 0 - lokalny, 1 - zdalny

  • Maska pomiarów analogowych

Poniżej podano zestawienie bitów maski pomiarów analogowych, które mogą być zarejestrowane w rejestratorze zakłóceń ( listy LIST_8 oraz LIST_9 w pliku list.xml).

U1 0x0001

U2 0x0002

U3 0x0004

U0 0x0008

I1 0x0010

I2 0x0020

I3 0x0040

I0 0x0080

I1sec 0x0100

I2sec 0x0200

I3sec 0x0400

I0sec 0x0800

Ia_1 0x1000

Ia_2 0x2000

Ia_3 0x4000

Ia_4 0x8000

Ia_5 0x0010000

Temp_1 0x0020000

Temp_2 0x0040000

Temp_3 0x0080000

Temp_4 0x0100000

Temp_5 0x0200000

Temp_6 0x0400000

I0sec 0x0800000

  • Maska dwustanów

Poniżej podano zestawienie bitów maski dwustanów, które mogą być zarejestrowane w rejestratorze zakłóceń (lista LIST_10 w pliku list.xml).

IN_01_16 0x0001

IN_17_32 0x0002

IN_33_48 0x0004

IN_49_64 0x0008

IN_65_80 0x0010

OUT_01_16 0x0020

OUT_17_32 0x0040

OUT_33_48 0x0080

OUT_49_64 0x0100

OUT_65_80 0x0200

SIG_01_16 0x0400

SIG_17_32 0x0800

SIG_33_48 0x1000

SIG_49_64 0x2000

SIG_65_80 0x4000

OIN_01_08 0x8000

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona przez globalną opcję Okres sprawdzania zdarzeń (zakładka Parametry drajwera). Zdarzenia odczytywane z urządzeń są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o następujący algorytm:

- definicje wszystkich zdarzeń oraz sposób ich przetwarzania są odczytywane z plików event.xml oraz format.xml dostarczonych przez producenta urządzenia;

- drajwer przetwarza parametry zdarzenia zgodnie z opisem zawartym w pliku event.xml, rozpoczynając od parametru nr 1 aż do wyczerpania bufora służącego do przekazania parametrów zdarzenia do systemu alarmów Asixa lub do wyczerpania liczby parametrów zdarzenia (drajwer może zgłosić dowolną kombinację parametrów 16-to i 32-bitowych pod warunkiem, że ich łączny rozmiar nie przekroczy 8-iu bajtów);

- drajwer przetwarza wartość każdego parametru zgodnie z regułą określoną przez format danego parametru opisany w pliku format.xml,

- możliwe jest użycie globalnych plików event.xml oraz format.xml poprzez umieszczenie nazw tych plików w globalnych pozycjach Plik definicji zdarzeń i Plik definicji formatów (zakładka Parametry drajwera) - dla każdego urządzenia można zdefiniować specyficzne pliki event.xml oraz format.xml poprzez umieszczenie nazw tych plików w sekcji danego kanału transmisji (używając również opcji Plik definicji zdarzeń i Plik definicji formatów na zakładce Parametry kanału 2).

- drajwer szuka plików event.xml oraz format.xml w kartotece, której nazwa jest podana w globalnej opcji Ścieżka plików nazw zakłóceń (zakładka Parametry drajwera - AsLogger).

Parametry drajwera

Drajwer jest parametryzowany przy użyciu zakładek Parametry drajwera.... Dostępne tam opcje mają zastosowanie do wszystkich urządzeń drajwera. Opcje służą do deklaracji:

· pliku logu drajwera,

· pliku logu rejestratora zakłóceń,

· rozmiaru plików logów,

· logu telegramów,

· hasła do odczytu rejestratora zakłóceń,

· liczby powtórzeń zapytania w przypadku błędów odpowiedzi,

· okresu sprawdzania sygnalizacji zdarzeń,

· katalogu plików z definicjami zdarzeń i formatów,

· pliku z definicjami zdarzeń,

· pliku z definicjami formatów,

· rejestracji zakłóceń w bazie programu AsLogger,

· liczby powtórzeń rejestratora zakłóceń w przypadku błędu transmisji,

· katalogu plików z definicjami planów rejestracji.

Zakładka Parametry drajwera - diagnostyka:

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego wpisywane są komunikaty o stanie pracy drajwera.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu i Plik logu zakłóceń.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

Wartość opcji:

TAK/NIE

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa_pliku_logu

Zakładka Parametry drajwera:

R Hasło

Znaczenie: Pozycja służy do określenia hasła użytkownika zarejestrowanego w urządzeniu Mupasz 710. Hasło jest niezbędne do realizacji odczytu rejestratora zakłóceń. Hasło wprowadzone przy pomocy tej opcji ma charakter globalny, tzn. dotyczy wszystkich urządzeń. Wartość hasła wprowadzona przy pomocy tej opcji może zostać przeciążona przy pomocy opcji zadeklarowanej na zakładce Parametry kanału.

Wartość domyślna: Domyślnie hasło jest tekstem "1111".

Wartość opcji:

hasło - czteroznakowy tekst

R Liczba powtórzeń

Znaczenie: Pozycja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi z urządzenia przy odczycie wszystkich typów danych (nie dotyczy odczytu rejestratora). Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 3.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

R Okres sprawdzania zdarzeń

Znaczenie: Opcja określa, co ile sekund należy wykonać odczyt rejestru zdarzeń.

Wartość domyślna: Domyślnie wartość pozycji wynosi 10 sekund.

Wartość opcji:

liczba - czas w sekundach.

R Ścieżka plików definicji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików definicji zdarzeń (event.xml) oraz plików definicji formatów (format.xml).

ścieżka - pełna ścieżka katalogu plików z definicjami zdarzeń i formatów.

R Plik definicji zdarzeń

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje zdarzeń. Opcja ma charakter globalny, ale może być przeciążona przez opcje o tej samej nazwie definiowane w parametrach kanałów transmisji.

Wartość opcji:

nazwa_pliku

R Plik definicji formatów

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje formatów. Opcja ma charakter globalny, ale może być przeciążona przez opcje o tej samej nazwie definiowane w parametrach kanałów transmisji.

Wartość opcji:

nazwa_pliku

Zakładka Parametry drajwera - AsLogger:

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb zapisu przebiegów rejestratorów do bazy. Opcja definiuje nazwę serwera MS SQL oraz nazwę bazy danych, w której będą rejestrowane próbki rejestratorów zakłóceń oraz rejestratorów kryterialnych.

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

R Liczba powtórzeń rejestratora zakłóceń

Znaczenie: Opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi z urządzenia przy odczycie rejestratora.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 0 (bez powtórzeń).

Wartość opcji:

NazwaSerwera, NazwaBazy

gdzie:

NazwaSerwera - nazwa serwera MS SQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

R Ścieżka plików nazw zakłóceń

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów rejestracji.

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametry kanału

Parametry specyficzne dla kanału transmisji można określać przy użyciu zakładek Parametry kanału.... W sekcji można umieścić pozycje deklarujące:

  • hasło dostępu do urządzenia, pozwalające na odczyt rejestratora zakłóceń,

  • liczbę powtórzeń zapytania w przypadku błędów odpowiedzi,

  • timeout odbioru odpowiedzi z urządzenia,

  • timeout międzyznakowy w odpowiedzi z urządzenia,

  • pliki z definicjami zdarzeń i formatów,

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów.

Zakładka Parametry kanału 2:

R Hasło

Znaczenie: Opcuja służy do określenia hasła użytkownika zarejestrowanego w urządzeniu Mupasz 710. Hasło jest niezbędne do realizacji odczytu rejestratora zakłóceń. Opcja przeciąża pozycję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie hasło jest określone przez opcję Hasło zastosowaną w parametrach drajwera. Jeśli w sekcji drajwera nie określono opcji Hasło, to domyślną wartością hasła jest tekst "1111".

Wartość opcji:

hasło - czteroznakowy tekst

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem. Opcja przeciąża opcję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość domyślna: Domyślnie parametr przyjmuje wartość liczby powtórzeń ustawioną w parametrach drajwera.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 500 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Timeout znaku

Znaczenie: Opcja określa maksymalny czas pomiędzy znakami odpowiedzi.

Wartość domyślna: Domyślna wartość timeout’u międzyznakowego wynosi 50 milisekund.

Wartość opcji:

liczba - wartość timeout’u w milisekundach.

R Plik definicji zdarzeń

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje zdarzeń. Pozycja przeciąża opcję o tej samej nazwie, umieszczoną w parametrach drajwera.

Wartość opcji:

nazwa_pliku - nazwa pliku (ew. ze ścieżką względną).

R Plik definicji formatów

Znaczenie: Opcja nazwę pliku XML zawierającego definicje formatów. Opcja przeciąża opcje o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość opcji:

nazwa_pliku - nazwa pliku (ew. ze ścieżką względną).

Zakładka Parametry kanału - diagnostyka:

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego wpisywane są komunikaty o stanie pracy drajwera.

Wartość domyślna: Domyślnie komunikaty dotyczące kanału wpisywane są do pliku logu drajwera.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu danego kanału.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu (danego kanału) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix. Opcja przeciąża opcję o tej samej nazwie umieszczoną w sekcji drajwera.

Wartość domyślna: Domyślnie parametr przyjmuje wartość ustawioną w parametrach drajwera.

Wartość opcji:

TAK/NIE

Dodatkowe parametry kanału

Dodatkowe opcje deklarowane ręcznie za pomocą zakładki:

Architekt > Obszary i komputery > moduł Pozostałe > Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: <nazwa_kanału>
R Nazwa opcji: ZWLOKA_TRANSMISJI
R Wartość opcji: liczba

Znaczenie - opcja daje możliwość zadeklarowania zwłoki pomiędzy zakończeniem odbioru odpowiedzi ze sterownika i wysłaniem kolejnego zapytania do sterownika.

Wartość domyślna - 0.

Parametry:

liczba - liczba milisekund,

Przykładowa parametryzacja drajwera

Plik logu: c:\tmp\mupasz.log

Plik logu zaklóceń: c:\tmp\zaklocenia.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Okres sprawdzania zdarzeń: 10

Rejestracja zakłóceń w bazie AsLogger: SERWER_RO6, BAZA_RO6

Ścieżka plików nazw zakłóceń: c:\tmp\DefZaklocen

Ścieżka plików definicji: c:\tmp\DefFiles

Hasło: 1234

Przykładowa parametryzacja kanału

Przykładowa sekcja kanału o nazwie KANALX:

Kanał > Nazwa: KANALX

Plik logu: c:\tmp\kanalx.log

Plik definicji zdarzeń: kanalx\Event.xml

Plik definicji formatów: kanalx\Format.xml

Hasło: 4321

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


Mupasz_Rtu

Home > 1.78 MupaszRtu - drajwer urządzeń Mupasz2001G, Mupasz07 oraz Mupasz Compact G01 firmy ITR Warszawa

1.78 MupaszRtu - drajwer urządzeń Mupasz2001G, Mupasz07 oraz Mupasz Compact G01 firmy ITR Warszawa

Przeznaczenie drajwera

Drajwer MupaszRtu służy do wymiany danych pomiędzy systemem Asix i urządzeniami Mupasz2001G, Mupasz07 oraz Mupasz Compact G01 - produkowanymi przez ITR Warszawa. Komunikacja jest realizowana przy pomocy łączy szeregowych w standardzie RS485.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera MupaszRtu wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MupaszRtu

Zakładka MupaszRtu:

Parametry kanału:

nr, typ, defZdarzeń, alOffset, port, baud, znak, parzystość, stop, maxWeWy, maxReg

gdzie:

nr - numer urządzenia w sieci MODBUS,

typ - typ urządzenia:

1 - Mupasz 2001G

2 - Mupasz 07

3 - Mupasz Compact G01

defZdarzeń - plik z definicjami zdarzeń (parametr jest używany wyłącznie dla kanałów obsługujących Mupasz 07 oraz Mupasz Compact G01; dla kanałów obsługujących Mupasz 2001G parametr jest pomijany;

alOffset - offset dodawany do każdego wyliczonego numeru alarmu;

port - nazwa portu szeregowego np. COM1;

baud - prędkość transmisji;

znak - liczba bitów w znaku;

parzystość - kontrola parzystości;

stop - liczba bitów stopu;

maxWeWy - max. liczba wejść/wyjść, które mogą być przekazane w ramach jednego odczytu z urządzenia;

maxReg - max. liczba rejestrów, które mogą być przekazane w ramach jednego odczytu z urządzenia.

PRZYKŁAD

Przykład deklaracji kanału transmisji:

Poniżej podano przykład deklaracji kanału KANAL, w którym jest obsługiwany sterownik Mupasz07 o numerze sieciowym 5. Definicje zdarzeń są w pliku zdarzen_701L2.def, komunikacja odbywa się poprzez COM2:

Parametry kanału:

5,2,zdarzen_701L2.def,200,COM2,115200,8,none,1,112,120

Deklaracja zmiennych procesowych

Drajwer udostępnia te same typy zmiennych co drajwer MODBUS oraz dodatkowo następujące typy:

MN - numer urządzenia, z którego jest aktualnie odczytywany rejestrator (WORD),

RN - numer aktualnie odczytywanego sektora rejestratora (WORD),

RQ - żądanie odczytu sektora (typ używany tylko do zapisu) (WORD),

RR - status realizacji odczytu sektora (WORD),

SN - liczba odczytanych elementów sektora (bajtów lub słów) (DWORD).

Powyższe typy nie posiadają parametrów.

Przykłady deklaracji zmiennych używających specyficznych typów:

# (wartość sterująca != 0 - żądanie odczytu sektora, 0 - kasowanie odczytu sektora)

Nazwa: SECREQ1

Opis: sterowanie odczytem sektora

Adres: RQ

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

# numer sieciowy MUPASZA, z którego jest aktualnie odczytywany sektor

Nazwa: SECSLV1

Opis: numer sieciowy

Adres: MN

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

# numer aktualnie odczytywanego sektora

Nazwa: SECNR1

Opis: numer sektora

Adres: RN

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

# status aktualnego odczytu sektora

Nazwa: SECSTAT1

Opis: status sektora

Adres: RR

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

# licznik odczytanych bajtow/słów z sektora (DWORD !!!)

Nazwa: SECCNT1

Opis: licznik elementów

Adres: SN

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_DW

Rejestracja zakłóceń

Drajwer umożliwia automatyczną rejestrację zakłóceń w bazie danych programu AsLogger. W celu uaktywnienia trybu rejestracji zakłóceń należy zadeklarować opcję REJESTRATOR (patrz poniżej: parametry drajwera), która określa:

- nazwę serwera MSSQL,

- nazwę bazy danych,

- nazwę planu rejestracji,

w których drajwer będzie zapisywać odczytane próbki zakłóceń.

Drajwer nie wykonuje automatycznej rejestracji zakłóceń - rejestracja zakłócenia musi być każdorazowo zainicjowana przez operatora systemu Asix poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer sektora, którego zawartość należy odczytać z Mupasza i zapisać do bazy programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu sektora.

W trakcie odczytu sektora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer odczytywanego Mupasza,

b/ RN - numer odczytywanego sektora,

c/ RR - status odczytu sektora:

0 - nieaktywny lub zakończony o.k.

1 - odczyt w toku,

2 - odczyt zakończony błędem,

d/ SN - liczba odczytanych elementów sektora (bajtów lub słów zależnie od typu Mupasza).

Rejestracja zakłóceń odbywa się zgodnie z planami rejestracji przygotowanymi przy pomocy programu AsLogger. Nazwy planów rejestracji podaje się w opcji REJESTRATOR (patrz poniżej: parametry drajwera).

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona parametrem OKRES_SPRAWDZANIA_ZDARZEN (patrz poniżej: parametry drajwera).

W przypadku Mupasza 2001G zdarzenia odczytywane z Mupasza są zamieniane na odpowiadające im numery alarmów w systemie Asix zgodnie z dokumentacją dziennika zdarzeń Mupasza 2001G.

W przypadku urządzeń Mupasz07 oraz Mupasz Compact G01 definicje zdarzeń są dostarczane w pliku tekstowym, którego nazwa jest podawana w definicji kanału transmisji. Możliwe jest wykorzystywanie tego samego pliku definicji zdarzeń w wielu kanałach transmisji. Składnia definicji zdarzenia ma następującą postać:

nr_zdarz, tekst, par_1, par_2 [,opcja]

gdzie:

nr_zdarz - numer zdarzenia

tekst - tekst zdarzenia

par_1 - nazwa typu pierwszego parametru zdarzenia

par_2 - nazwa typu drugiego parametru zdarzenia

opcja - opcjonalny parametr

Drajwer z definicji zdarzenia wykorzystuje parametry: nr_zdarz, par_1 i par_2. Służą one do określenia sposobu konwersji parametrów przekazywanych ze zdarzeniem. Drajwer akceptuje następujące nazwy typów parametrów jako wartości parametrów par_1 i par_2 (są one zgodne z formatem Typy_Parametrów_Zdarzeń_Format_D urządzeń rodziny Mupasz):

Brak,

Kod,

Numer,

Temperatura,

Cos,

Czas,

Czas1,

Ufaz,

Uo,

Ifaz,

Io,

Iskum,

Licznik,

Admitancja,

Czestotliwosc,

Rezystancja,

Moc,

Operator,

Rwirnika,

MocP,

IrHarm2,

IrHarm5,

IfazInTg,

IfazInPg.

Numer alarmu przekazywany przez drajwer do systemu Asix powstaje z dodania numeru zdarzenia otrzymanego z Mupasza oraz offsetu podanego w deklaracji kanału transmisji Asmena. Parametry zdarzeń są przeliczane na typ FLOAT i przekazywane jako parametry alarmu do systemu alarmów systemu Asix. Zależnie od liczby parametrów zdarzenia alarm przekazywany do systemu Asix zawiera 0, 1 lub 2 parametry.

Parametry drajwera

Parametry drajwera MupaszRtu deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

W sekcji MUPASZRTU można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • okres sprawdzania zdarzeń,

  • ścieżkę definicji zdarzeń,

  • odczyt rejestratorów,

  • liczbę powtórzeń przy odczycie rejestratora,

  • liczbę powtórzeń przy odczycie danych bieżących,

  • blokowanie zapytań w kanale na wyznaczony okres, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi,

  • liczbę rejestrów w pojedynczym zapytaniu przy odczycie rejestratora,

  • timeout zapytania rejestratora.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - Domyślnie wartość pozycji jest ustawiona na NIE.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: OKRES_SPRAWDZANIA_ZDARZEN

R Wartość opcji: liczba

Znaczenie - opcja określa, co ile sekund można wykonać odczyt rejestru zdarzeń kolejnego z urządzeń podpiętych do tego samego portu szeregowego obsługiwanego przez drajwer.

Wartość opcji:

liczba - czas deklarowany w sekundach.

Wartość domyślna - domyślnie wartość pozycji wynosi 10 sekund.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: SCIEZKA_DEFINICJI_ZDARZEN

R Wartość opcji: ścieżka

Znaczenie - opcja określa ścieżkę do katalogu, którym znajdują się pliki z definicjami zdarzeń; opcja ma zastosowanie w przypadku użycia urządzeń typu Mupasz 07 (dla urządzeń typu Mupasz2001G nie ma możliwości definiowania sposobu dekodowania zdarzeń).

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL.

NazwaBazy - nazwa bazy na serwerze NazwaSerwera.

Wartość domyślna - brak.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: REJESTRATOR

R Wartość opcji: NazwaSerwera, NazwaBazy, NazwaPlanu1, ..., NazwaPlanuN

Znaczenie - opcja przełącza drajwer w tryb rejestracji zakłóceń. Opcja definiuje nazwę serwera oraz nazwę bazy danych, w której będą rejestrowane próbki zakłóceń.

Wartość opcji:

NazwaSerwera - nazwa serwera MSSQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

NazwaPlanu1 - N - nazwy planów rejestracji zakłoceń. Musi być podana nazwa przynajmniej jednego planu

Wartość domyślna - domyślnie nie rejestruje się zakłóceń.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LICZBA_POWTORZEN_REJESTRATORA

R Wartość opcji: liczba

Znaczenie - opcja określa liczbę powtórzeń w przypadku błędów transmisji przy odczycie rejestratora.

Wartość opcji:

liczba - liczba powtórzeń przy błędach odczytu rejestratora; wartość parametru równa -1 oznacza, że odczyt należy powtarzać aż do poprawnego wykonania operacji.

Wartość domyślna - domyślnie nie powtarza się odczytu rejestratora w przypadku błędów.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: liczba

Znaczenie - opcja określa liczbę powtórzeń w przypadku błędów transmisji przy odczycie danych bieżących.

Wartość opcji:

liczba - liczba powtórzeń przy błędach odczytu danych bieżących (0 oznacza brak powtórzeń).

Wartość domyślna - domyślnie dopuszcza się 2 powtórzenia w przypadku błędów odczytu danych bieżących (łącznie 3 próby odczytu).

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: ZWLOKA_PO_BRAKU_ODPOWIEDZI

R Wartość opcji: liczba_sekund

Znaczenie - opcja służy do blokowania zapytań w kanale na okres liczba_sekund, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi; opcja deklarowana w sekcji MUPASZRTU obowiązuje dla wszystkich kanałów, opcja deklarowana w sekcji o nazwie kanału obowiązuje wyłącznie dla danego kanału (przeciąża wartość opcji wprowadzoną w sekcji drajwera); w okresie blokowania zapytań wszystkie polecenia kierowane do drajwera s ą kończone ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie).

Wartość opcji:

liczba - liczba sekund.

Wartość domyślna - domyślnie wartość opcji wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: ROZMIAR_ZAPYTANIA_REJESTRATORA

R Wartość opcji: max_liczba_rejestrow_zapytania

Znaczenie - opcja określa maksymalną liczbę rejestrów w pojedynczym zapytaniu przy odczycie rejestratora.

Wartość opcji:

max_liczba_rejestrow_zapytania

Wartość domyślna - 125.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: TIMEOUT_ZAPYTANIA_REJESTRATORA

R Wartość opcji: liczba_milisekund

Znaczenie - wartość równa 0 oznacza, że wątek realizujący odczyt rejestratora będzie miał niższy priorytet niż wątek realizujący zapytania na konto aplikacji, co przy dużej liczbie zapytań na konto aplikacji może spowodować, że odczyt rejestratora będzie trwać kilka godzin (tryb stosowany w dotychczasowych wersjach drajwera). Wartość != 0 oznacza, że wątki realizujące zapytania na konto aplikacji oraz na konto rejestratora będą miały jednakowy priorytet, zapytania kierowane do urządzenia będą się nawzajem przeplatały, a timeout pomiędzy kolejnymi próbami dostępu do portu będzie równy wartości parametru.

Wartość opcji:

liczba_milisekund

Wartość domyślna - domyślnie wartość opcji wynosi 0.

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: MAX_LICZBA_REJESTROW

R Wartość opcji: liczba

Znaczenie - określa maksymalna liczbę rejestrów HR w pojedynczym zapytaniu.

Wartość opcji:

liczba

Wartość domyślna - domyślnie wartość opcji wynosi 120.

Parametry kanału

Parametry kanału drajwera MupaszRtu deklarowane w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: <nazwa_kanalu>

R Nazwa opcji: ZWLOKA_PO_BRAKU_ODPOWIEDZI

R Wartość opcji: liczba_sekund

Znaczenie - opcja służy do blokowania zapytań w kanale na okres liczba_sekund, jeśli ostatnie zapytanie zakończyło się brakiem odpowiedzi; opcja deklarowana w sekcji MUPASZRTU obowiązuje dla wszystkich kanałów, opcja deklarowana w sekcji o nazwie kanału obowiązuje wyłącznie dla danego kanału (przeciąża wartość opcji wprowadzoną w sekcji drajwera); w okresie blokowania zapytań wszystkie polecenia kierowane do drajwera s ą kończone ze statusem wskazującym na brak odpowiedzi (bez wykonywania jakichkolwiek operacji na porcie).

Wartość opcji:

liczba - liczba sekund.

Wartość domyślna - domyślnie wartość opcji wynosi 0 - wtedy drajwer działa bez blokowania transmisji po braku odpowiedzi.

R Nazwa sekcji: <nazwa_kanalu>

R Nazwa opcji: MAX_LICZBA_REJESTROW

R Wartość opcji: liczba

Znaczenie - określa maksymalna liczbę rejestrów HR w pojedynczym zapytaniu.

Wartość opcji:

liczba

Wartość domyślna - domyślnie wartość opcji wynosi 120.

PRZYKŁAD PARAMETRYZACJI DRAJWERA

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\mupasz\drajwer.log

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 3

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: 0

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LICZBA_POWTORZEN

R Wartość opcji: 0

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: LICZBA_POWTORZEN_REJESTRATORA

R Wartość opcji: 1

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: OKRES_SPRAWDZANIA_ZDARZEN

R Wartość opcji: 5

R Nazwa sekcji: MUPASZRTU

R Nazwa opcji: REJESTRATOR

R Wartość opcji: SERWER_DANYCH, BAZA_MUPASZY, PLAN_1t


MupaszRtu_TCPIP - drajwer protokołu urządzeń zabezpieczających

Home > 1.79 MupaszRtu_TCPIP - drajwer protokołu urządzeń zabezpieczających typu Mupasz 710

1.79 MupaszRtu_TCPIP - drajwer protokołu urządzeń zabezpieczających typu Mupasz 710

Przeznaczenie drajwera

Drajwer MupaszRtu_TCPIP służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami zabezpieczającymi typu Mupasz 710, produkowanymi przez Instytut Tele- i Radiotechniczny w Warszawie. Komunikacja jest realizowana w trybie MODBUS RTU na łączu Ethernet poprzez port 502.

Drajwer realizuje następujące funkcje:

  • odczyt aktualnych stanów i pomiarów,

  • odczyt zdarzeń i zgłaszanie ich do systemu alarmów Asixa,

  • odczyt zakłóceń z rejestratora zakłóceń oraz ich rejestracja w bazie danych w formacie programu AsLogger opracowanym przez ASKOM Sp.z o.o.

Uwaga:

Użycie funkcji związanych z odczytem rejestratora zakłóceń oraz rejestracją zakłóceń w bazie programu AsLogger wymaga posiadania odpowiedniej licencji systemu Asix.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera MupaszRtu_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MupaszRtu_TCPIP

Zakładka MupaszRtu_TCPIP / Parametry kanału:

Numer urządzenia w sieci MODBUS - numer urządzenia w sieci MODBUS; Uwaga: dla obecnie produkowanych wersji Mupasza 710 parametr musi mieć wartość 255,

Adres IP urządzenia - adres IP urządzenia,

Offset alarmów - offset dodawany do wyliczonego numeru alarmu ASIXA,

Adres IP komputera, przez który kanał będzie się łączył ze sterownikiem.

Port - numer portu TCP urządzenia,

Tryb Modbus RTU - do wymiany danych w kanale używa formatu Modbus RTU zamiast domyślnego Open Modbus TCPIP.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KANAL, w którym jest obsługiwany Mupasz 710 o adresie IP 10.10.12.5 i offsecie alarmów 200:

Nazwa: KANAL

Drajwer: MupaszRtu_TCPIP

Parametry kanału:

Numer urządzenia w sieci MODBUS: 255

Adres IP urządzenia: 10.10.12.5

Offset alarmów: 200

Deklaracja zmiennych procesowych

Drajwer udostępnia następujące typy zmiennych protokołu MODBUS:

HR - rejestr 16-bitowy (odczyt)

HRF - rejestr 32-bitowy typu FLOAT (odczyt)

HRL - rejestr 32-bitowy typu DWORD/LONG (odczyt)

UDC - typ służący do realizacji poleceń protokołu MODBUS RTU definiowanych przez użytkownika. Dostępny tylko dla kluczy WAUS, WAUW, WDUW lub WDUN. Wartością zmiennej typu UDC jest łańcuch znaków ASCII, którego maksymalna długość wynosi 521 bajtów. Przy zapisie jest to treść polecenia utworzonego przez użytkownika, przy odczycie jest to treść odpowiedzi na ostatnio wysłane polecenie użytkownika.

(odczyt/zapis)

oraz wewnętrzne zmienne drajwera:

MN - numer sieciowy urządzenia, z którego jest odczytywany lub został odczytany sektor (odczyt)

RN - numer aktualnie/ostatnio odczytywanego sektora (odczyt)

RQ - żądanie odczytu sektora (zapis)

RR - status aktualnie/ostatnio odczytywanego sektora (odczyt)

RS - stan rejestratora (niedostępny/pusty/zapisany) (odczyt)

RT - czas wyzwolenia zakłócenia zapisanego w sektorze (odczyt)

SN - bieżący licznik rejestrów HR odczytywanych z sektora (odczyt)

Adres zmiennej ma składnię:

Typ[Indeks]

gdzie:

Typ - typ zmiennej,

Indeks - indeks zmiennej w ramach typu zmiennej ’Typ’.

UWAGI:

  1. indeksów nie podaje się dla typów: MN, RN, RQ, RR i SN

  2. w przypadku typów RS, RT zakres indeksów zależy od liczby sektorów zdefiniowanych w urządzeniu,

  3. parametrem żądania odczytu sektora (typ RQ ) jest numer sektora. Sektory są numerowane począwszy od 1. Jeśli jako parametr zostanie podane 0, oznacza to żądanie przerwania aktualnie realizowanego odczytu sektora,

  4. w celu prezentacji czasu wyzwolenia sektora należy użyć funkcji przeliczającej DATACZAS_MUZ, która przekształca liczbę typu double na łańcuch znaków w formacie:

yyyy-mm-dd hh:nn:ss.zzz

PRZYKŁAD

Przykłady deklaracji zmiennych:

ZM_01, wartość nominalna Un, HR8235, KLR, 1, 1, NIC

ZM_02, wartość nominalna In, HR8236, KLR, 1, 1, NIC

ZM_03, czas wyzwolenia zakłócenia w sektorze 1, RT1, KLR, 1, 1, DATACZAS_MUZ

ZM_04, żądanie odczytu sektora, RQ, KLR, 1, 1, NIC

ZM_05, nr odczytywanego sektora, RN, KLR, 1, 1, NIC

ZM_06, status odczytu sektora, RR, KLR, 1, 1, NIC

ZM_07, licznik rejestrów odczytanych z sektora, SN, KLR, 1 ,1, NIC_DW

Odczyt rejestratora zakłóceń

Drajwer umożliwia rejestrację przebiegów rejestratora zakłóceń w bazie danych programu AsLogger. Przeglądanie zarejestrowanych przebiegów jest możliwe wyłącznie przy pomocy programu AsLogger.

Rejestracja przebiegów rejestratora zakłóceń wymaga, aby w parametrach drajwera zadeklarować opcję Rejestracja zakłóceń w bazie AsLogger (zakładka MupaszRtu_TCPIP / Parametry drajwera - AsLogger), która określa:

  • nazwę serwera MSSQL,

  • nazwę bazy danych,

w których drajwer będzie zapisywać odczytane przebiegi rejestratorów.

Drajwer nie wykonuje automatycznej rejestracji przebiegów - rejestracja przebiegu musi być każdorazowo zainicjowana przez operatora systemu ASIX poprzez wykonanie sterowania zmienną typu RQ. Jako wartość sterującą podaje się numer sektora, którego zawartość należy odczytać z urządzenia i zapisać do bazy danych programu AsLogger. Jeżeli wartość sterująca wynosi 0, to oznacza to żądanie przerwania aktualnie wykonywanego odczytu sektora.

W trakcie odczytu sektora możliwe jest śledzenia stanu odczytu. Służą do tego celu wewnętrzne zmienne drajwera o adresach symbolicznych:

a/ MN - numer urządzenia w sieci MODBUS,

b/ RN - numer odczytywanego sektora,

c/ RR - status odczytu sektora:

0 - odczyt nieaktywny lub zakończony o.k.

1 - odczyt uruchomiony

2 - odczyt ostatniej ramki zakończony o.k.

3 - odczyt ostatniej ramki zakończony z błędem

4 - odczyt sektora zakończony z błędem

5 - odczyt sektora zakończony o.k.

6 - odczyt sektora przerwany przez operatora

d/ SN - bieżący licznik rejestrów odczytanych z sektora.

Rejestracja przebiegów rejestratorów odbywa się zgodnie z planami rejestracji. Nazwy planów rejestracji mogą być:

a/ zdefiniowane przez użytkownika w plikach tekstowych, które są czytane przez drajwer na

etapie startu aplikacji,

b/ wygenerowane automatycznie przez drajwer.

Przy rejestracji przebiegu drajwer zapisuje do bazy danych programu AsLogger:

a/ wszystkie parametry znajdujące się w sektorze

b/ tworzy archiwum planu,

c/ wyznacza max i min wartości dla prądów i napięć w rejestrowanym przebiegu - będą ew. korygowane przy rejestracji kolejnych przebiegów dla danego planu.

Definiowanie nazw planów rejestracji przez użytkownika

Użytkownik może zdefiniować nazwy planów rejestracji w plikach tekstowych o rozszerzeniu ’.def’. W tym celu dla każdego kanału transmisji (kanału ASMENA) należy utworzyć osobny plik i wpisać do niego definicje nazw planów rejestracji dla zakłóceń rejestrowanych w tym kanale. Pliki zawierające definicje nazw planów rejestracji należy umieścić we wspólnej kartotece, której nazwę należy podać jako wartość opcji Katalog plików zawierających nazwy planów rejestracji (zakładka MupaszRtu_TCPIP / Parametry drajwera - AsLogger).

Składnia definicji nazwy planu rejestracji umieszczana w pliku ’.def’ jest następująca:

Kanał, Powód, FormatAi, FormatDi, Fabela [, Fomentarz]

gdzie:

Kanał - nazwa kanału ASMENA,

Powód - liczba identyfikująca powód wyzwolenia rejestratora,

FormatAi - maska pomiarów analogowych w zapisie HEX (6 znaków)

FormatDi - maska wejść dwustanowych w zapisie HEX (2 znaki)

Tabela - nazwa planu rejestracji,

Komentarz - komentarz (opcja)

Przykład:

Definicja nazwy planu rejestracji dla rejestracji zakłócenia o parametrach:

- wartość napięcia U1 < (powód wyzwolenia nr 1),

- maska analogów 0000FF - rejestracja U1, U2, U3, U0 oraz I1, I2, I3, I0

- maska dwustanów 0001 - rejestracja stanów wejść 1 - 16

w kanale KTR:

KTR, 1, 0000FF, 0001, Pole05SpadekNapieciaU1

Domyślne nazwy planów rejestracji

Jeśli użytkownik nie zdefiniował własnych nazw planów rejestracji, to drajwer tworzy samodzielnie nazwę planu rejestracji.

Dla rejestratorów zakłóceń składnia nazwy planów rejestracji zakłóceń wygenerowanych przez drajwer ma następującą składnię:

NazwaKanału.Powód.FormatAi.FormatDi

gdzie:

NazwaKanału - nazwa kanału Asmena, w którym odczytano zakłócenie,

Powód - identyfikator powodu wyzwolenia rejestratora,

FormatAi - maska pomiarów analogowych w zapisie HEX (6 znaków),

FormatDi - maska wejść dwustanowych w zapisie HEX (2 znaki).

Przykład:

Dla zakłócenia spowodowanego wyzwoleniem rejestratora od logiki użytkownika w urządzeniu obsługiwanym w kanale Asmena o nazwie KANAL z ustawioną rejestracją:

- analogów: U1, U2, U3, U0, I1, I2, I3, I0

oraz

- dwustanów: wejścia 1-16, wejścia 17-32, wyjścia 1-16

zostanie zbudowany plan rejestracji o nazwie:

KANAL.29.000FF.0023

Identyfikatory powodów wyzwolenia rejestratora

Poniżej podano zestawienie identyfikatorów powodów wyzwolenia rejestratora.

01 U1LE wartość napięcia U1 jako parametr

02 U2LE wartość napięcia U2 jako parametr

03 U3LE wartość napięcia U3 jako parametr

04 U0LE wartość napięcia Uo jako parametr

05 I1LE wartość prądu I1 jako parametr

06 I2LE wartość prądu I2 jako parametr

07 I3LE wartość prądu I3 jako parametr

08 I0LE wartość prądu Io jako parametr

09 I1LESEC wartość prądu I1sec jako parametr

10 I2LESEC wartość prądu I2sec jako parametr

11 I3LESEC wartość prądu I3sec jako parametr

12 I0LESEC wartość prądu Iosec jako parametr

13 U1GT wartość napięcia U1 jako parametr

14 U2GT wartość napięcia U1 jako parametr

15 U3GT wartość napięcia U1 jako parametr

16 U0GT wartość napięcia Uo jako parametr

17 I1GT wartość prądu I1 jako parametr

18 I2GT wartość prądu I2 jako parametr

19 I3GT wartość prądu I3 jako parametr

20 I0GT wartość prądu Io jako parametr

21 I1GTSEC wartość prądu I1sec jako parametr

22 I2GTSEC wartość prądu I2sec jako parametr

23 I3GTSEC wartość prądu I3sec jako parametr

24 I0GTSEC wartość prądu Iosec jako parametr

25 DIN numer wejścia wyzwalającego jako parametr (1..80)

26 DOUT numer wyjścia wyzwalającego jako parametr (1..80)

27 SIG numer rejestru wyzwalającego jako parametr (1..80)

28 OIN numer wejścia wyzwalającego jako parametr (1..8)

29 USER wyzwolenie rejestratora przez użytkownika:

parametr 0 - lokalny, 1 - zdalny

Maska pomiarów analogowych

Poniżej podano zestawienie bitów maski pomiarów analogowych, które mogą być zarejestrowane w rejestratorze zakłóceń ( listy LIST_8 oraz LIST_9 w pliku list.xml).

U1 0x0001

U2 0x0002

U3 0x0004

U0 0x0008

I1 0x0010

I2 0x0020

I3 0x0040

I0 0x0080

I1sec 0x0100

I2sec 0x0200

I3sec 0x0400

I0sec 0x0800

Ia_1 0x1000

Ia_2 0x2000

Ia_3 0x4000

Ia_4 0x8000

Ia_5 0x0010000

Temp_1 0x0020000

Temp_2 0x0040000

Temp_3 0x0080000

Temp_4 0x0100000

Temp_5 0x0200000

Temp_6 0x0400000

I0sec 0x0800000

Maska dwustanów

Poniżej podano zestawienie bitów maski dwustanów, które mogą być zarejestrowane w rejestratorze zakłóceń (lista LIST_10 w pliku list.xml).

IN_01_16 0x0001

IN_17_32 0x0002

IN_33_48 0x0004

IN_49_64 0x0008

IN_65_80 0x0010

OUT_01_16 0x0020

OUT_17_32 0x0040

OUT_33_48 0x0080

OUT_49_64 0x0100

OUT_65_80 0x0200

SIG_01_16 0x0400

SIG_17_32 0x0800

SIG_33_48 0x1000

SIG_49_64 0x2000

SIG_65_80 0x4000

OIN_01_08 0x8000

Sygnalizacja zdarzeń

Sygnalizacja zdarzeń jest sprawdzana cyklicznie, częstość sprawdzania jest określona przez globalną pozycję Okres sprawdzania zdarzeń (patrz: Parametry drajwera). Zdarzenia odczytywane z urządzeń są zamieniane na odpowiadające im numery alarmów w systemie Asix. Zamiana jest realizowana w oparciu o następujący algorytm:

- definicje wszystkich zdarzeń oraz sposób ich przetwarzania są odczytywane z plików event.xml oraz format.xml dostarczonych przez producenta urządzenia,

- drajwer przetwarza parametry zdarzenia zgodnie z opisem zawartym w pliku event.xml rozpoczynając od parametru nr 1 aż do wyczerpania bufora służącego do przekazania parametrów zdarzenia do systemu alarmu Asixa, lub do wyczerpania liczby parametrów zdarzenia (drajwer może zgłosić dowolną kombinację parametrów 16-to i 32-bitowych pod warunkiem, że ich łączny rozmiar nie przekroczy 8-iu bajtów),

- drajwer przetwarza wartość każdego parametru zgodnie z regułą określoną przez format danego parametru opisany w pliku format.xml,

- możliwe jest użycie globalnych plików event.xml oraz format.xml, poprzez umieszczenie nazw tych plików w globalnych pozycjach Plik definicji zdarzeń (patrz: Parametry drajwera, Parametry kanału) i Plik definicji formatów (patrz: Parametry drajwera, Parametry kanału).

- dla każdego urządzenia można zdefiniować specyficzne pliki event.xml oraz format.xml poprzez umieszczenie nazw tych plików w sekcji danego kanału transmisji (używając również pozycji Plik definicji zdarzeń i Plik definicji formatów).

- drajwer szuka plików event.xml oraz format.xml w kartotece, której nazwa jest podana w globalnej pozycji Katalog plików zawierających nazwy planów rejestracji (zakładka MupaszRtu_TCPIP / Parametry drajwera - AsLogger).

Parametry drajwera

Drajwer jest parametryzowany przy użyciu opcji umieszczonych na zakładkach: MupaszRtu_TCPIP / Parametry drajwera, MupaszRtu_TCPIP / Parametry drajwera - AsLogger, MupaszRtu_TCPIP / Parametry drajwera - diagnostyka. Opcje te mają zastosowanie do wszystkich urządzeń drajwera. Opcje służą do deklaracji:

  • tworzenia plików logów drajwera i rejestratora zakłóceń,

  • rozmiaru pliku logu,

  • logu telegramów,

  • okresu sprawdzania sygnalizacji zdarzeń,

  • rejestracji zakłóceń w bazie programu AsLogger,

  • katalogu plików z definicjami planów rejestracji,

  • katalogu plików z definicjami zdarzeń i formatów,

  • globalnych plików z definicjami zdarzeń i formatów,

  • globalne hasło dostępu do wszystkich urządzeń, pozwalające na odczyt rejestratorów zakłóceń.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu i Plik logu zakłóceń.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Plik logu zakłóceń

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o odczytanych zakłóceniach.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość opcji: TAK/NIE

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

R Hasło

Znaczenie: Opcja służy do określenia hasła użytkownika zarejestrowanego w urządzeniu Mupasz 710. Hasło jest niezbędne do realizacji odczytu rejestratora zakłóceń. Hasło wprowadzone przy pomocy tej opcji ma charakter globalny, tzn. dotyczy wszystkich urządzeń. Wartość hasła wprowadzona przy pomocy tej opcji może zostać przeciążona przy pomocy opcji HASLO zadeklarowanej na zakładce MupaszRtu_TCPIP / Parametry kanału.

Wartość opcji:

hasło - czteroznakowy tekst

Wartość domyślna: Domyślnie hasło jest tekstem "1111".

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi z urządzenia. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 3.

R Okres sprawdzania zdarzeń

Znaczenie: Opcja określa co ile sekund należy wykonać odczyt rejestru zdarzeń.

Wartość opcji:

liczba - liczba sekund.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 10.

R Ścieżka plików definicji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików definicji zdarzeń (event.xml) oraz plików definicji formatów (format.xml).

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami zdarzeń i formatów.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 10.

R Plik definicji zdarzeń

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje zdarzeń. Opcja ma charakter globalny, ale może być przeciążona przez opcję o tej samej nazwie umieszczone w parametrach kanałów (zakładka MupaszRtu_TCPIP / Parametry kanału).

Wartość opcji:

nazwa_pliku - pełna ścieżka katalogu plików z definicjami zdarzeń i formatów.

R Plik definicji formatów

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje formatów. Opcja ma charakter globalny, ale może być przeciążona przez opcje o tej samej nazwie umieszczone w parametrach kanałów transmisji (zakładka MupaszRtu_TCPIP / Parametry kanału).

Wartość opcji:

nazwa_pliku - nazwa pliku.

R Rejestracja zakłóceń w bazie AsLogger

Znaczenie: Opcja przełącza drajwer w tryb zapisu przebiegów rejestratorów do bazy. Pozycja definiuje nazwę serwera MS SQL oraz nazwę bazy danych, w której będą rejestrowane próbki rejestratorów zakłóceń oraz rejestratorów kryterialnych.

Wartość opcji:

NazwaSerwera - nazwa serwera MS SQL

NazwaBazy - nazwa bazy na serwerze NazwaSerwera

Wartość domyślna: Domyślnie nie rejestruje się zakłóceń.

R Liczba powtórzeń rejestratora zakłóceń

Znaczenie: Opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi z urządzenia przy odczycie rejestratora.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna: Domyślnie parametr przyjmuje wartość 0 (bez powtórzeń).

R Katalog plików zawierających nazwy planów rejestracji

Znaczenie: Opcja określa pełną ścieżkę do katalogu, w którym drajwer będzie szukać plików z definicjami nazw planów zakłóceń.

Wartość opcji:

ścieżka - pełna ścieżka katalogu plików z definicjami planów rejestracji.

Parametry kanału

Parametry specyficzne dla kanału transmisji parametryzowane są przy użyciu opcji umieszczonych na zakładkach: MupaszRtu_TCPIP / Parametry kanału. Opcje te mają zastosowanie do wszystkich urządzeń drajwera. Opcje służą do deklaracji:

  • timeout odbioru odpowiedzi z urządzenia,

  • zwłokę uruchomienia operacji odbioru odpowiedzi z urządzenia,

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • liczbę powtórzeń zapytania w przypadku błędów odpowiedzi,

  • max. liczbę rejestrów w zapytaniu,

  • adres IP karty komputera służącej do komunikacji z urządzeniem,

  • hasło dostępu do urządzenia, pozwalające na odczyt rejestratora zakłóceń,

  • pliki z definicjami zdarzeń i formatów.

R Hasło

Znaczenie: Opcja służy do określenia hasła użytkownika zarejestrowanego w urządzeniu Mupasz 710. Hasło jest niezbędne do realizacji odczytu rejestratora zakłóceń.

Wartość opcji:

hasło - czteroznakowy tekst

Wartość domyślna: Domyślnie hasło jest określone przez opcję Hasło zastosowaną w opcjach drajwera. Jeśli w sekcji drajwera nie zastosowano opcji Hasło, to domyślną wartością hasła jest tekst ”1111”.

R Liczba powtórzeń

Znaczenie: Opcja służy do określenia liczby powtórzeń zapytania w przypadku błędu odpowiedzi w danym kanale. Po wyczerpaniu liczby powtórzeń następuje zamknięcie i ponowne nawiązanie połączenia z urządzeniem.

Wartość opcji:

liczba - liczba powtórzeń zapytania w przypadku błędów odpowiedzi.

Wartość domyślna: Domyślnie parametr przyjmuje wartość liczby powtórzeń ustawioną w sekcji drajwera.

R Timeout odpowiedzi

Znaczenie: Opcja określa maksymalny czas, przez który drajwer oczekuje na nadejście odpowiedzi z urządzenia.

Wartość opcji:

liczba - wartość timeout’u w milisekundach

Wartość domyślna: Domyślna wartość timeout’u odbioru wynosi 500 milisekund.

R Zwłoka odpowiedzi

Znaczenie: Opcja określa czas zwłoki pomiędzy wysłaniem zapytania do urządzenia i uruchomieniem operacji odbioru odpowiedzi. Użycie pozycji ma sens w przypadku znacznego pofragmentowania odpowiedzi.

Wartość opcji:

liczba - wartość zwłoki odbioru w milisekundach

Wartość domyślna: Domyślna wartość zwłoki odbioru wynosi 20 milisekund.

R Plik definicji zdarzeń

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje zdarzeń. Pozycja przeciąża opcję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość opcji:

nazwa_pliku - nazwa pliku (ew. ze ścieżką względną)

R Plik definicji formatów

Znaczenie: Opcja określa nazwę pliku XML zawierającego definicje formatów. Pozycja przeciąża opcję o tej samej nazwie umieszczoną w parametrach drajwera.

Wartość opcji:

nazwa_pliku - nazwa pliku (ew. ze ścieżką względną)

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty dotyczące transmisji w danym kanale.

Wartość opcji:

nazwa_pliku_logu

Wartość domyślna: Domyślnie komunikaty dotyczące kanału wpisywane są do pliku logu drajwera.

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu danego kanału.

Wartość opcji:

liczba - rozmiar pliku logu w MB

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji Plik logu danego kanału) zawartości telegramów przesyłanych w danym kanale. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość opcji: TAK/NIE

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE.

Przykładowa parametryzacja drajwera

Drajwer: MupaszRtu_TCPIP

Plik logu=c:\tmp\mupasz.log

Plik logu zakłóceń=c:\tmp\zaklocenia.log

Rozmiar pliku logu=20

Log telegramów=TAK

Okres sprawdzanai zdarzeń=10

Rejestracja zakłóceń w bazie AsLogger=SERWER_RO6, BAZA_RO6

Ścieżka plików nazw zakłóceń=c:\tmp\DefZaklocen

Ścieżka plików definicji=c:\tmp\DefFiles

Hasło=1234

Przykładowa parametryzacja kanału

Przykładowa parametryzacja kanału o nazwie KANALX:

Kanał/Nazwa: KANALX

Plik logu=c:\tmp\kanalx.log

Plik definicji zdarzeń=kanalx\Event.xml

Plik definicji formatów=kanalx\Format.xml

Hasło=4321

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtMus04 - drajwer do wymiany danych z urządzeniami

Home > 1.80 Mus04 - drajwer do wymiany danych z urządzeniami sterującymi MUS-04

1.80 CtMus04 - drajwer do wymiany danych z urządzeniami sterującymi MUS-04 firmy ELEKTORMETAL S.A.

Przeznaczenie drajwera

Drajwer protokołu CtMus04 służy do wymiany danych pomiędzy systemem Asix i mikroprocesorowymi urządzeniami sterującymi MUS-04 firmy ELEKTORMETAL S.A. w Cieszynie. Transmisja jest realizowana łączami szeregowymi przy pomocy standardowych portów szeregowych komputera w standardzie RS-485.

Parametryzacja drajwera CtMus04 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera CtMus04 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtMus04

Zakładka Mus04:

Parametr kanału:

Port=liczba; Nr=liczba [[[;Timeout=liczba];TimeoutZnaku=liczba];ZwlokaTransmisji=liczba]

gdzie:

Port - numer portu szeregowego,

Nr - numer Mus-04 obsługiwanego przez ten kanał,

Timeout - max. czas oczekiwania na pierwszy znak odpowiedzi (w milisekundach); domyślnie 1000 milisekund;

TimeoutZnaku - max. czas pomiędzy znakami odpowiedzi (w milisekundach); domyślnie 100 milisekund;

ZwlokaTransmisji - oznacza przerwę w milisekundach pomiędzy zakończeniem odbioru danych z urządzenia i wysłaniem kolejnego zapytania do urządzenia.

Parametry transmisji są stałe i wynoszą:

  • prędkość transmisji 2400 Bd,

  • 8 bitów znaku,

  • bez bitu parzystości,

  • 1 bit stopu.

PRZYKŁAD

Przykład deklaracji kanałów transmisji do komunikacji z Mus04’ami nr 1 i 2 przy pomocy portu szeregowego COM2 oraz Mus04’em nr 3 przy pomocy portu szeregowego COM1:

Nazwa: K1

Drajwer: CtMus04

Parametry kanału: Port=2;Nr=1

Nazwa: K2

Drajwer: CtMus04

Parametry kanału: Port=2;Nr=2

Nazwa: K3

Drajwer: CtMus04

Parametry kanału: Port=1;Nr=3

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ>.<indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu - dotyczy operacji odczytu zmiennych.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej) omówione zostały poniżej.

Typy zmiennych tylko do odczytu:

R1 - informacje o stanie MUS, zakres indeksów 1- 12, znaczenie indeksów - jak w ramce 161,

R2 - nie jest używany,

R3 - matryca funkcji, zakres indeksów 1- 9, znaczenie indeksów - jak w ramce 163,

R4 - czasy zwłoki, zakres indeksów 1- 8, znaczenie indeksów - jak w ramce 164,

R5 - czasy przetrzymania, zakres indeksów 1- 8, znaczenie indeksów - jak w ramce 164,

R6 - opis wejścia określonego przez indeks, zakres indeksów 1- 8,

R7 - opis wyjścia określonego przez indeks, zakres indeksów 1- 8,

R8 - hasło dostępu, wyłącznie indeks 1,

R9 - ustawienia wejść, zakres indeksów 1- 8, znaczenie indeksów - jak w ramce 169,

R10 - ustawienia wyjść, zakres indeksów 1- 8, znaczenie indeksów - jak w ramce 170,

R11 - ustawienia MW, wyłącznie indeks 1,

R12 - informacja o zmianie ustawień, wyłącznie indeks 1,

R13 - informacja o dodatkowych ustawieniach, wyłącznie indeks 1.

Typy zmiennych tylko do zapisu (sterowania):

W1 - RESET,

W2 - zmiana numeru MUS, nie jest implementowany,

W3 - wysłanie nowej matrycy funkcji - bufor musi mieć format ramki 3,

W4 - wysłanie nowych czasów zwłoki - bufor musi mieć format ramki 4,

W5 - wysłanie nowych czasów przetrzymania - bufor musi mieć format ramki 5,

W6 - wysłanie opisu wejścia - bufor musi mieć format ramki 6,

W7 - wysłanie opisu wyjścia - bufor musi mieć format ramki 7,

W8 - wysłanie hasła dostępu - bufor musi mieć format ramki 8,

W9 - wysłanie nowych ustawień wejść - bufor musi mieć format ramki 9,

W10 - wysłanie nowych ustawień wyjść - bufor musi mieć format ramki 10,

W11 - wysłanie nowych ustawień MW - bufor ma rozmiar 1 bajta,

W12 - skasowanie bitów związanych ze zmianą ustawień - bufor ma rozmiar 1 bajta.

Zapis zmiennych typów W6, W7 i W8 może być realizowany z obiektów NAPIS.

Zapis zmiennych typów W11 i W12 może być realizowany z obiektów LICZBA.

Zapis zmiennych pozostałych typów może być zrealizowany przy pomocy skryptów.

PRZYKŁADY

Przykłady deklaracji zmiennych - kanał K1 obsługuje Mus-04 nr 1, kanał K2 obsługuje Mus-04 nr 2:

JJ_10, stan wejść WE1 Mus-04 nr 1, R1.1, K1, 1, 1, NIC

JJ_11, stan wejść WE8 Mus-04 nr 2, R1.8, K2, 1, 1, NIC

JJ_12, napięcie baterii Mus-04 nr 1, R1.10, K1, 1, 1, NIC_FP

JJ_13, napięcie zasilania Mus-04 nr 2, R1.11, K2, 1, 1, NIC_FP

JJ_14, opis wejścia nr 1 Mus-04 nr 2, R6.1, K2, 1, 1, NIC_TEXT

JJ_15, opis wyjścia nr 5 Mus-04 nr 1, R7.5, K1, 1, 1, NIC_TEXT

JJ_16, czas zwłoki nr 2 Mus-04 nr 1, R4.2, K1, 1, 1, NIC

JJ_16, ustawienia wejść nr 3 Mus-04 nr 1, R9.3, K1, 1, 1, NIC

JJ_17, ustawienia wyjść nr 4 Mus-04 nr 2, R10.4, K2, 1, 1, NIC

Zmienne używane wyłącznie do realizacji sterowań:

JJ_20, wysłanie rozkazu RESET do Mus-04 nr 2, W1, K2, 1, 1, NIC

JJ_21, nowe ustawienia matrycy Mus-04 nr 2, W3, K2, 9, 1, NIC_BYTE

JJ_22, nowe ustawienia czasów zwłoki Mus-04 nr 1, W4, K1, 8, 1, NIC_BYTE

JJ_23, nowe ustawienia wejść Mus-04 nr 1, W9, K1, 8, 1, NIC_BYTE

JJ_24, nowe ustawienia wyjść Mus-04 nr 2, W10, K2, 8, 1, NIC_BYTE

Parametryzacja drajwera

Parametry drajwera CtMus04 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CtMus04
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtMus04
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametry:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: CtMus04
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami; przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁADOWA PARAMETRYZACJA DRAJWERA

Nazwa sekcji: CTMUS04

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtMus04\mus.log

Nazwa sekcji: CTMUS04

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CTMUS04

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


MUZ - drajwer protokołu sterownika MUZ zabezpieczeń

Home > 1.81 MUZ - drajwer protokołu sterownika MUZ zabezpieczeń elektroenergetycznych

1.81 MUZ - drajwer protokołu sterownika MUZ zabezpieczeń elektroenergetycznych

Przeznaczenie drajwera

Drajwer MUZ jest wykorzystywany do wymiany danych pomiędzy
Mikroprocesorowymi Urządzeniami Zabezpieczającymi MUZ typu MUZ-RO
produkowanymi przez f-mę JM Tronik Warszawa oraz komputerem systemu Asix.

W aktualnej wersji drajwera kanały logiczne związane są z portami szeregowymi obsługującymi urządzenia MUZ-RO, a nie z poszczególnymi urządzeniami MUZ-RO z osobna. Takie rozwiązanie pozwala zmniejszyć liczbę kanałów logicznych.

Parametryzacja drajwera MUZ realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera MUZ wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: MUZ

Zakładka MUZ:

Parametry kanału:

port - adres portu szeregowego, przez który będzie realizowane połączenie z urządzeniami MUZ_RO, należącymi do tego kanału.

Dla każdego portu szeregowego używanego przez drajwer MUZ jest wymagana osobna deklaracja kanału logicznego.

Deklaracja urządzenia

Deklaracja wszystkich urządzeń MUZ-RO, obsługiwanych przez drajwer MUZ, odbywa się przy użyciu opcji MUZ deklarowanych dla sekcji MUZ. Dla każdego obsługiwanego urządzenia MUZ-RO należy podać osobną pozycję MUZ.

Opcja MUZ zawiera parametry wykorzystywane w poprzedniej wersji drajwera do deklaracji kanału logicznego. Postać opcji jest następująca:

nazwa_kanału, nr, typ, alarmTxtOff, alarmValOff, zm_status, zm_kontrolna

gdzie:

nazwa_kanału - nazwa kanału logicznego zadeklarowanego dla drajwera, przez który będzie obsługiwany dany MUZ-RO;

nr - numer MUZ-RO;

typ - typ MUZ - dla MUZ-RO jest to liczba 7;

alarmTxtOff - offset alarmu tekstowego;

alarmValOff - offset alarmu z wartością;

zm_status - zmienna pokazująca status transmisji z MUZem;

zm_kontrolna - zmienna sterująca realizacją transmisji z MUZem.

Składnia adresu symbolicznego zmiennej

Dotychczas używany adres symboliczny zmiennej został rozszerzony o przyrostek, zawierający numer urządzenia MUZ‑RO. Postać adresu symbolicznego jest następująca:

Adres.NrMuza

gdzie:

Adres - dotychczas stosowany adres symboliczny zmiennej,

NrMuza - numer urządzenia MUZ-RO, z którego jest pobierana zmienna o adresie Adres.

Adresy symboliczne oraz typy zmiennych procesowych

W poniższych tyabelach podano zestawienie zmiennych procesowych dostępnych w urządzeniu MUZ-RO wraz z ich adresami symbolicznymi oraz typami. Zmienne podzielone są na następujące grupy:

  • wartości pomiarów;

  • wejścia dwustanowe obsługiwane razem z pomiarami (przekazywany jest stan pojedynczych bitów);

  • wejścia dwustanowe obsługiwane razem z pomiarami (przekaywany jest stan kolejnych 16-tu zmiennych SPi);

  • specyficzna zmienna w MUZRO;

  • wartości znamionowe i nastawy zabezpieczeń;

  • wejścia dwustanowe związane z nastawami zab.;

  • zmienne przechowujące stany zdarzeń z wartością;

  • zmienne przechowujące stany zdarzeń tekstowych;

  • zmienne używane do sterowania.

Tabela. Wartości pomiarów.

Tabela. Wejścia dwustanowe obsługiwane razem z pomiarami (przekazywany jest stan pojedynczych bitów).

Tabela. Wejścia dwustanowe obsługiwane razem z pomiarami (przekaywany jest stan kolejnych 16-tu zmiennych SPi).

Tabela. Specyficzna zmienna w MUZRO.

Tabela. Wartości znamionowe i nastawy zabezpieczeń.

Tabela. Wejścia dwustanowe związane z nastawami zab.

Tabela. Zmienne przechowujące stany zdarzeń z wartością.

Tabela. Zmienne przechowujące stany zdarzeń tekstowych.

Tabela. Zmienne używane do sterowania.

Oznaczenia skrótów:

Zab - zabezpieczenie,

Włącz - zab. włączone (1),

Wyłącz - zab. wyłączone (0),

Wył - zab. powoduje otwarcie wyłącznika (1),

Sygn - zab. powoduje pobudzenie sygnalizacji (0),

Zal - zab. czynne, gdy wyłącznik jest zamknięty (0),

Niezal - zab. czynne niezależ.

Deklaracja zezwolenia na sterowanie

Grupowa obsługa urządzeń MUZ-RO w ramach kanałów logicznych ma swoje konsekwencje w zakresie wydawania zezwoleń na sterowanie. Wynika to z faktu, że opcje ASMENa, służące do deklaracji zezwoleń na sterowanie, odnoszą się do poszczególnych kanałów logicznych. W dotychczas stosowanej wersji drajwera MUZ (wersja 1.3.1) kanał logiczny był przypisany do pojedynczego urządzenia MUZ-RO, co pozwalało na wydawanie zezwoleń dla każdego urządzenia MUZ‑RO z osobna. W przedmiotowej (grupowej) wersji drajwera kanał logiczny może grupować kilka urządzeń MUZ‑RO, zatem zezwolenie na sterowanie dotyczy wszystkich urządzeń MUZ-RO, obsługiwanych przez dany kanał logiczny.

Parametry drajwera

Parametry drajwera MUZ deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: MUZ
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: liczba

Znaczenie - opcja określa maksymalny czas, jaki może upłynąć pomiędzy wysłaniem zapytania i otrzymaniem odpowiedzi (tzw. timeout odbioru). Wartość timeout’u jest określana globalnie dla wszystkich obsługiwanych urządzeń MUZ-RO.

Wartość domyślna - domyślnie wartość timeout’u wynosi 1000 milisekund.

Parametr:

liczba - wartość timeout’u wyrażona w milisekundach.

R Nazwa sekcji: MUZ
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku, rozmiar

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera oraz informacje o zawartości telegramów wysłanych/odebranych przez drajwer. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa_pliku - nazwa pliku logu,

rozmiar - rozmiar pliku logu w MB.

R Nazwa sekcji: MUZ
R Nazwa opcji: AKTUALIZACJA_DANYCH
R Wartość opcji: liczba

Znaczenie - opcja określa dopuszczalną różnicę czasu pomiędzy stemplem czasu zmiennej przechowywanej w cach’u drajweja oraz aktualnym czasem systemu. Po przekroczeniu dopuszczalnej różnicy czasu drajwer dokonuje odczytu zmiennej z urządzenia MUZ-RO.

Wartość domyślna - domyślnie opcja przyjmuje wartość 0.

Parametr:

liczba - dopuszczalna różnica czasu w sekundach.

R Nazwa sekcji: MUZ
R Nazwa opcji: AKTUALIZACJA_CZASU
R Wartość opcji: liczba

Znaczenie - opcja określa globalny okres aktualizacji czasu pomiędzy systemem Asix i urządzeniami MUZ-RO.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1.

Parametr:

liczba - okres aktualizacji czasu w minutach.

R Nazwa sekcji: MUZ
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych/odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie drajwer nie wpisuje do pliku logu treści telegramów.

R Nazwa sekcji: MUZ
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić liczbę powtórzeń realizowanych przez drajwer w przypadku błędu transmisji.

Wartość domyślna - domyślnie, w przypadku błędu transmisji powtórzenia nie są realizowane.

Parametr:

liczba - liczba powtórzeń w przypadku błędu transmisji.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtNCP - drajwer dla sterowników serii MN firmy Invensys

Home > 1.82 CtNCP - drajwer dla sterowników serii MN firmy Invensys

1.82 CtNCP - drajwer dla sterowników serii MN firmy Invensys

Przeznaczenie drajwera

Drajwer CtNCP służy do wymiany danych pomiędzy systemem Asix i sterownikami serii MN firmy Invensys (dawniej Satchwell). Komunikacja jest realizowana przy pomocy łączy szeregowych w standardzie RS485.

Parametryzacja drajwera CtNCP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera CtNCP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtNCP

Zakładka NCP:

Parametr kanału:

Port=numer_portu; Nr=numer_slave

gdzie:

Port - numer portu szeregowego COM,

Nr - numer sterownika MN ustawiony na switch’u sterownika.

Parametry transmisji są stałe i wynoszą:

  • prędkość 9600 bps,

  • 8 bitów danych,

  • bez parzystości,

  • 1 bit stopu.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KANAL, w którym jest obsługiwany sterownik MN-440 o numerze sieciowym 5. Komunikacja odbywa się poprzez COM2:

Nazwa: KANAL

Drajwer: CtNCP

Parametry kanału: Port=2; Nr=5

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych:

B - bajt,

R - liczba 16-bitowa,

RL - liczba 32-bitowa,

RF - liczba zmiennoprzecinkowa.

Adres zmiennej ma składnię:

<Typ><NrTab><Index>

gdzie:

Typ - nazwa typu zmiennej,

NrTab - numer tablicy danych w sterowniku,.

Index - numer bajtu w tablicy danych określonej przez ’NrTab’.

PRZYKŁAD

Przykłady deklaracji zmiennych:

X11, bajt 0 z tablicy 114, B114.0, KANAL, 1, 1, NIC_BYTE

X12, WORD zbudowany z bajtów 2 i 3 tablicy 110, R110.2, KANAL, 1, 1, NIC

X13, DWORD zbudowany z bajtów od 4 do 7 tablicy 8, RL8.4, KANAL, 1, 1, NIC_DW

X14, FLOAT zbudowany z bajtów od 8 do 11 tablicy 12, RF12.8, KANAL, 1, 1, NIC_FP

Parametryzacja drajwera

Parametry drajwera CtNCP deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CTNCP
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - do celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTNCP
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - rozmiar pliku logu wynosi 1 MB.

R Nazwa sekcji: CTNCP
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - NIE.

R Nazwa sekcji: CTNCP
R Nazwa opcji: MAX_DLUGOSC_BUFORA
R Wartość opcji: liczba

Znaczenie - pozycja określa maksymalna liczbę bajtów, o które można zapytać w pojedynczym poleceniu odczytu.

Wartość domyślna - domyślnie pozycja ma wartość 64.

PRZYKŁAD

Przykładowa sekcja drajwera:

Nazwa sekcji: CTNCP

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtNcp\ncp.log

Nazwa sekcji: CTNCP

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 3

Nazwa sekcji: CTNCP

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


NetLink - drajwer protokołu MPI/Profibus dla SIMATIC S7

Home > 1.83 NetLink - drajwer protokołu MPI/Profibus dla SIMATIC S7

1.83 NetLink - drajwer protokołu MPI/Profibus dla SIMATIC S7 przy wykorzystaniu modułu NetLink Lite SYSTEME HELMHOLZ

Przeznaczenie drajwera

Drajwer NetLink - służy do komunikacji ze sterownikami SIMATIC S7 poprzez łącze MPI/PROFIBUS.

Zaletą drajwera NetLink jest fakt, iż wykorzystuje on tani i łatwy w konfigurowaniu moduł NetLink Lite, będący bramą sieci Ethernet dla magistrali MPI lub PROFIBUS sterowników S7. Taki sposób komunikacji jest atrakcyjną alternatywą w stosunku do rozwiązań bazujących na oprogramowaniu SOFTNET i kartach CP5611/CP5613 SIEMENSA.

Moduł NetLink Lite jest produkowany przez firmę Systeme Helmholz GmbH, a jego dystrybucję na terenie naszego kraju prowadzi firma MEDIOTECH (www.mediotech.pl).

Zastosowanie modułu NetLink Lite posiada pewne ograniczenia, do których należą:

a/ na połączeniu Ethernet’owym moduł może obsługiwać jednocześnie max. dwa komputery;
b/ przy komunikacji z więcej niż jednym sterownikiem należy uwzględnić czas potrzebny modułowi NetLink na przełączanie się pomiędzy sterownikami (w testowej konfiguracji, składającej się z 3-ech sterowników, czas przełączania wynosił ok. 80 msek/sterownik).

Zastosowanie drajwera NetLink wymaga modułu ASMEN w wersji 4.6.8. lub nowszej.

Parametryzacja drajwera NetLink realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera NetLink wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: NetLink

Zakładka NetLink:

Parametry kanału:

IP, port, adres [,zm_kontr [, nr_alarmu] [, sygnał_błędu]]

gdzie:

IP - adres IP przypisany modułowi NetLink Lite;

port - numer portu (1099);

adres - adres sterownika w sieci MPI/Profibus;

zm_kontr - nazwa zmiennej, służącej do kontroli stanu RUN-STOP sterownika;

nr_alarmu - numer alarmu generowany przy zmianie stanu RUN-STOP sterownika; domyślnie alarm nie jest generowany;

sygnał_błędu - wystawienie statusu błędu dla wszystkich zmiennych w danym
kanale w przypadku przejścia sterownika w stan STOP; domyślnie ustawiany jest status błędu.

Adresacja zmiennych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału transmisji wykorzystującego drajwer NetLink są takie same, jak w przypadku kanału wykorzystującego drajwer SAPIS7 - patrz: SAPIS7 - drajwer protokołu SAPIS7.

Parametryzacja drajwera

Parametry drajwera NetLink deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: NETLINK
R Nazwa opcji: STATYSTYKA
R Wartość opcji: tak/nie

Znaczenie - opcja pozwala na wyświetlanie co minutę informacji o liczbie przeprowadzonych seansów transmisji, średnim czasie transmisji oraz liczbie błędów transmisji. Opcja została zaprojektowana jako wsparcie projektanta na etapie uruchomienia systemu.

Wartość domyślna - domyślnie nie wyświetla się statystyki transmisji.

R Nazwa sekcji: NETLINK
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera NetLink, dotyczące operacji realizowanych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: NETLINK
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: NETLINK
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer NetLink w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji PLIK_LOGU.

Wartośc domyślna - NIE.

Synchronizacja czasu

Patrz: SAPIS7 - drajwer protokołu SAPIS7.

Sygnalizacja stanu STOP sterownika

Patrz: SAPIS7 - drajwer protokołu SAPIS7.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


NetLinkPro - drajwer do komunikacji ze sterownikami S7

Home > 1.84 NetLinkPro - drajwer do komunikacji ze sterownikami S7

1.84 NetLinkPro - drajwer do komunikacji ze sterownikami S7 przy pomocy gateway’a NetLink PRO

Przeznaczenie drajwera

Drajwer NetLinkPro pozwala na komunikację ze sterownikami S7 przy pomocy gateway’a NetLinkPRO (gateway Ethernet <-> MPI/Profibus). Producentem NetLinkPro jest SYSTEME HELMHOLZ (dystrybucja w Polsce - www.mediotech.pl).

Cechy modułu NetLink PRO:

a/ po stronie Ethernetu może obsługiwać jednocześnie max. 6 PC

b/ po stronie MPI/PROFIBUS może obsługiwać jednocześnie max. 12 sterowników

Zastosowanie drajwera NetLink wymaga modułu ASMEN w wersji 4.13.1 lub nowszej.

Parametryzacja drajwera NetLink realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera NetLinkPro wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: NetLinkPro

Zakładka NetLinkPro:

Parametry kanału:

deviceNr, slaveNr [,zm_kontr [, nr_alarmu [, sygnał_błędu]]]

gdzie:

deviceNr - numer nadany modułowi NetLink Pro (przy użyciu oprogramowania konfguracyjnego producenta);

slaveNr - numer sterownika w sieci MPI/PORFIBUS;

zm_kontr - nazwa zmiennej, służącej do kontroli stanu RUN-STOP sterownika;

nr_alarmu - numer alarmu generowany przy zmianie stanu RUN-STOP sterownika; domyślnie nie generuje się alarmu;

sygnał_błędu - wystawienie statusu błędu dla wszystkich zmiennych w danym kanale w przypadku przejścia sterownika w stan STOP.

Adresacja zmiennych procesowych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału transmisji wykorzystującego drajwer NetLinkPro są takie same, jak w przypadku kanału wykorzystującego protokół AS512.

Zestaw typów zmiennych procesowych stosowanych w protokole drajwera NetLinkPro został rozszerzony w stosunku do zestawu oferowanego przez protokół AS512 o następujące elementy:

EDI - słowa 16-bitowe w konwencji INTELa,

ER - zawartość bloków danych traktowana jako liczby zmiennoprzecinkowe,

EB - zawartość bloków danych traktowana jako bajty,

ELI - 4 kolejne bajty z obszaru DB bez zmiany kolejności bajtów.

Drajwer NetLinkPro jest ładowany automatycznie jako DLL.

Parametry drajwera NetLinkPro

Parametry drajwera NetLinkPro deklarowane są w programie Architekt, w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Drajwer jest parametryzowany w osobnej sekcji NETLINKPRO.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera NetLinkPro, dotyczące operacji realizowanych przez drajwer. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK/NIE

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer NetLinkPro w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji PLIK_LOGU.

Wartość domyślna - NIE.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: MAX_DLUGOSC_BUFORA

R Wartość opcji: liczba

Znaczenie - pozwala określić maksymalną długość telegramów akceptowanych przez interfejs MPI; zależy od typu CPU sterowników S7 oraz od realizowanego przez nie programu.

Wartość domyślna - domyślna długość telegramu wynosi 220 bajtów.

Parametr:

liczba - długość telegramów w bajtach.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: KONSOLA

R Wartość opcji: TAK/NIE

Znaczenie - opcja pozwala utworzyć okno konsoli, w którym na bieżąco są wyświetlane komunikaty drajwera NetLinkPro, dotyczące operacji realizowanych przez drajwer.

Wartość domyślna - domyślnie okno konsoli nie jest tworzone.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: STATYSTYKA

R Wartość opcji: TAK/NIE

Znaczenie - opcja pozwala na wyświetlanie co minutę informacji o liczbie przeprowadzonych seansów transmisji, średnim czasie transmisji oraz liczbie błędów transmisji. Opcja została zaprojektowana jako wsparcie projektanta na etapie uruchomienia systemu.

Wartość domyślna - domyślnie nie wyświetla się statystyki transmisji.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: LICZBA_ODCZYTOW_KONTROLNYCH

R Wartość opcji: liczba

Znaczenie - opcja określa minimalną liczbę, kolejno po sobie następujących odczytów zmiennej kontrolnej o niezmienionej wartości, powodujących zasygnalizowanie stanu STOP sterownika.

Wartość domyślna - domyślnie opcja przyjmuje wartość 3.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: SZEREGOWANIE

R Wartość opcji: TAK/NIE

Znaczenie - deklaracja obsługi transmisji z S7 poprzez przesyłanie pojedynczych (TAK) lub wielu zapytań (NIE).

Wartość domyślna - TAK.

R Nazwa sekcji: NETLINKPRO

R Nazwa opcji: BEZ_ZBIORCZEGO_ZAPYTANIA

R Wartość opcji: TAK/NIE

Znaczenie - pozwala zablokować tryb tworzenia zbiorczych zapytań i tym samym umożliwia dzialanie drajwera w trybie pojedynczych zapytań.

Wartość domyślna - NIE; w aktualnej wersji drajwera domyślnie używana jest funkcja s7_multiple_read_req (która pozwala na zbudowanie zbiorczego zapytania) w celu maksymalnego wykorzystania długości bufora telegramu przesyłanego pomiędzy PC i S7.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


NONE

Home > 1.85 NONE

1.85 Drajwer NONE

Przeznaczenie drajwera

Drajwer NONE realizuje specyficzny rodzaj protokołu NONE, obsługiwanego wewnętrznie przez ASMENa. Protokół ten nie realizuje fizycznego połączenia ze sterownikiem. Może być zastosowany w celu:

  • testowania aplikacji w trybie symulacji,

  • umożliwienia wymiany informacji pomiędzy programami systemu Asix za pomocą zmiennych procesowych.

Parametryzacja drajwera NONE realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer NONE wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: NONE

Parametry kanału

Parametry kanału NONE deklarowane na zakładce None:

R Zapis czasu i statusu

Znaczenie - opcja umożliwia zapis wartości zmiennej uzupełnionej czasem i statusem. Do zastosowania w szczególnych przypadkach, kiedy wymagany jest zapis czasu wykonania operacji sterowania.

Status, czas i wartość zmiennej podlegają następującym regułom:

• do chwili pierwszego zapisu przy odczycie zwracany jest status AVD_BAD,

• przy zapisie do zmiennej wpisywane są: czas podany w parametrach zapisu, nowy status, nowa wartość zmiennej,

• odczyt następujący po zapisie zwraca parametry ostatnio wykonanego zapisu (wartość, status oraz czas).

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.

R Kanał pasywny

Znaczenie - opcja pozwala zdefiniować pasywny kanał drajwera NONE.

Opcja ta decyduje, w jaki sposób w systemie Asix będzie interpretowany brak nowych danych w kanale:

- w przypadku kanału pasywnego brak nowych danych oznacza, że poprzednie dane wraz ze statusami są ciągle aktualne.

- w przypadku kanału aktywnego (wartość domyślna) brak nowych danych oznaczą błąd komunikacji.

Opcja ma znaczenie tylko w przypadku jednoczesnego użycia opcji Zapis czasu i statusu (patrz: powyżej).

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.

***

Parametry kanału drajwera NONE deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału drajwera NONE deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtNordicRF

Home > 1.86 NordicRF - drajwer terminala Nordic ID RF 601 firmy NordicID

1.86 NordicRF - drajwer terminala Nordic ID RF 601 firmy NordicID

Przeznaczenie drajwera

Drajwer służy do wymiany danych pomiędzy systemem Asix i czytnikiem kodów kreskowych Nordic ID RF 601. Komunikacja odbywa się przy wykorzystaniu łącza szeregowego RS-232 stacji bazowej.

Parametryzacja drajwera NordicRF realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer NordicRF wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: CtNordicRF

Zakładka CtNordicRF:

Parametry kanału:

Port=nrPortu [;CzasWaznosci=timeout] [;Alarm=nrAlarmu]

gdzie:

Port - numer portu szeregowego COM.

CzasWaznosci - czas (w minutach) pomiędzy dwoma telegramami z terminala po przekroczeniu którego nastąpi unieważnienie danych udostępnianych przez drajwer. Domyślna wartość parametru wynosi 0 (bez unieważniania danych)

Alarm - numer alarmu zgłoszonego do systemu alarmów Asixa w przypadku przekroczenia ’CzasuWażności'.

Transmisja jest realizowana przy stałych ustawieniach:

19200 Bd, 8 bitów znaku, bez kontroli parzystości, 1 bit stopu.

Deklaracja zmiennych

Drajwer dostarcza jeden typ zmiennych:

D - typu tekst

Składnia adresu zmiennej ma następującą postać:

D.<termId>.<pozycja>

gdzie:

termId - identyfikator terminala (liczba 16-bitowa bez znaku)

pozycja - nr pozycji na wyświetlaczu terminala, której wartość zostanie przypisana zmiennej. Domyślne z terminala można odczytać dwa parametry, mające następujące pozycje:

1/ Count - pozycja 26

2/ Code - pozycja 46

UWAGA:

Wszystkie zmienne mają typ BSTR, w związku z tym należy używać funkcji przeliczającej NIC_TEXT.

PRZYKŁAD

Przykładowe deklaracje zmiennych dla terminala o identyfikatorach 30002 i 30004 (zmienne należą do kanału logicznego KANAL):

JJ_11, pole Count, D.30002.26, KANAL, 1, 1, NIC_TEXT

JJ_12, pole Code, D.30002.46, KANAL, 1, 1, NIC_TEXT

JJ_21, pole Count, D.30004.26, KANAL, 1, 1, NIC_TEXT

JJ_22, pole Code, D.30004.46, KANAL, 1, 1, NIC_TEXT

Parametry drajwera

Parametry drajwera NordicRF deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTNORDICRF.

R Nazwa sekcji: CTNORDICRF

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTNORDICRF

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTNORDICRF

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: Pozycja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów odbieranych ze stacji bazowej. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

[CTNORDICRF]

PLIK_LOGU=d:\tmp\test\centrala.log

ROZMIAR_PLIKU_LOGU=30

LOG_TELEGRAMOW=TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


OMRON - drajwer protokołu HOSTLINK dla sterowników OMRON

Home > 1.87 OMRON - drajwer protokołu HOSTLINK dla sterowników OMRON

1.87 OMRON - drajwer protokołu HOSTLINK dla sterowników OMRON

Przeznaczenie drajwera

Drajwer OMRON jest wykorzystywany do wymiany danych ze sterownikami OMRON. Wymiana danych jest realizowana w trybie Host Link przy użyciu komend C MODE (domyślnie) lub FINS. Do transmisji wykorzystuje się standardowe porty szeregowe komputera systemu Asix. Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu OMRON nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych z systemem Asix. Przed realizacją sterowań drajwer przełącza sterownik w tryb MONITOR (jeśli sterownik jest w trybie RUN). Po zakończeniu sterowania sterownik przełączany jest w tryb, w którym znajdował się przed wykonaniem sterowania.

Parametryzacja drajwera OMRON realizowana jest przy użyciu programu Architekt.

Drajwer OMRON jest ładowany automatycznie jako DLL.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera OMRON wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji
Drajwer: OMRON

Zakładka OMRON:

Parametry kanału:

typ[,id],port,[body,znak,parzystość,stop]

gdzie:

typ - typ połączenia - SLINK (single link), MLINK (multi link);

id - identyfikator sterownika (unit number), używany w przypadku, gdy typ połączenia został oznaczony jako MLINK (multi link);

port - nazwa portu szeregowego (COM1 lub COM2);

body - prędkość transmisji w bodach;

znak - liczba bitów w transmitowanym znaku;

parzystość - typ kontroli parzystości (even,odd,none0);

stop - liczba bitów stopu.

Parametry body, znak, parzystość, stop są parametrami opcjonalnymi. W przypadku ich pominięcia jako domyślne przyjmowane są:

  • prędkość transmisji - 9600 Bd,

  • liczba bitów w znaku - 7,

  • typ kontroli parzystości - kontrola parzystości (even),

  • liczba bitów stopu - 2.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu OMRON:

Nazwa: CHAN1

Drajwer: OMRON

Parametry kanału: MLINK,0,COM1,9600,7,even,2

Parametryzacja kanału transmisji

Kanał transmisji jest parametryzowany przy użyciu osobnej sekcji, której nazwa jest identyczna z nazwą kanału transmisji - parametry wraz z nazwą sekcji należy umieszczać w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio. W sekcji kanału można umieścić pozycje deklarujące:

• użycie komend FINS,

• numer sieci, w której znajduje się sterownik,

• numer węzła w sieci przypisany sterownikowi.

Użycie komend FINS

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: PROTOKOL_FINS
R Wartość opcji: TAK/NIE

Znaczenie - forsuje użycie komend FINS przy wymianie danych ze sterownikiem.

Wartość domyślna - NIE. Domyślnie komunikacja odbywa się przy użyciu komend C-MODE.

Jeśli w sekcji kanału nie zostaną użyte pozycje DNA oraz DA1, to dla komunikacji w trybie FINS przyjmuje się, że parametry:

• numer sieci sterownika (DNA),

• numer węzła sterownika (DA1)

mają wartość 0.

Numer sieci sterownika

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: DNA
R Wartość opcji: liczba

Znaczenie - pozycja DNA ustawia numer sieci sterownika na wartość parametru DNA oraz forsuje użycie komend FINS przy wymianie danych ze sterownikiem.

Parametr:

liczba - numer sieci, w której znajduje się sterownik.

Wartość domyślna - domyślna wartość parametru DNA wynosi 0 (local network).

Numer węzła sterownika

R Nazwa sekcji: nazwa_kanału
R Nazwa opcji: DA1
R Wartość opcji: liczba

Znaczenie - pozycja DA1 ustawia numer węzła sterownika na wartość parametru DA1 oraz forsuje użycie komend FINS przy wymianie danych ze sterownikiem.

Parametr:

liczba - numer węzła sterownika.

Wartość domyślna - domyślna wartość parametru DA1 wynosi 0 (internal communication in local PLC).

Adresacja zmiennych

Poniżej przedstawiona jest składnia adresu symbolicznego używanego dla zmiennych procesowych należących do kanału OMRON:

typ_zmiennej indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w protokole OMRON,

indeks_zmiennej - indeks zmiennej w ramach danego typu.

Typy zmiennych dostępnych w trybie C-MODE (w nawiasach podano zakres indeksów zmiennych):

IR - Internal Relay, (0 - 235, 300 - 511),

HR - Holding Relay, (0 - 99),

AR - Auxiliary Relay, (0 - 27),

LR - Link Relay, (0 - 63),

DM - Data Memory, (0 - 6143).

Wszystkie zmienne procesowe są traktowane jako liczby 16-bitowe.

Typy zmiennych dostępnych w trybie FINS:

Typy 16-bitowe (WORD):

CIO - CIO Area

T - Timer Area

C - Counter Area

WR - Work Area

HR - Holding Area

AR - Auxiliary Bit Area

Typy 32-bitowe (DWORD):

ARL - Auxiliary Bit Area

CIOL - CIO Area

CL - Counter Area

DML - DM Area

HRL - Holding Area

TL - Timer Area

WRL - Work Area

Typy 32-bitowe (FLOAT):

ARF - Auxiliary Bit Area

CIOF - CIO Area

CF - Counter Area

DMF - DM Area

HRF - Holding Area

TF - Timer Area

WRF - Work Area

Typy 64-bitowe (DOUBLE):

ARD

CD

CIOD

DMD

HRD

TD

WRD

- Auxiliary Bit Area
- Counter Area

- CIO Area

- DM Area

- Holding Area

- Timer Area

- Work Area

Typy 64-bitowe (INT64):

ARI

CI

CIOI

DMI

HRI

TI

WRI

- Auxiliary Bit Area

- Counter Area

- CIO Area

- DM Area

- Holding Area

- Timer Area

- Work Area

Przykłady

Przykłady deklaracji zmiennych:

Nazwa: JJ_02

(C6 i C7 jako DWORD)

Adres: CL6

Kanał: K1

LiczbaElementow: 1

OkresProbkowania: 1

FunkcjaPrzeliczajaca: NIC_DW

Nazwa: JJ_03

(DM480 i DM481 jako FLOAT)

Adres: DMF480

Kanał: K1

LiczbaElementow: 1

OkresProbkowania: 1

FunkcjaPrzeliczajaca: NIC_FP

Nazwa: JJ_04

(DM480 - DM483 jako DOUBLE)

Adres: DMD480

Kanał: K1

LiczbaElementow: 1

OkresProbkowania: 1

FunkcjaPrzeliczajaca: NIC_DOUBLE

Nazwa: JJ_05

(DM500 - DM503 jako INT64)

Adres: DMI480

Kanał: K1

LiczbaElementow: 1

OkresProbkowania: 1

FunkcjaPrzeliczajaca: NIC_INT64

Parametry drajwera

Parametry drajwera OMRON deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: OMRON
R Nazwa opcji: PLIK_LOGU
R Wartośc opcji: nazwa_pliku

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - plik logu nie jest tworzony.

R Nazwa sekcji: OMRON
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - 1MB.

R Nazwa sekcji: OMRON
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - NIE.

R Nazwa sekcji: OMRON
R Nazwa opcji: MAX_DLUGOSC_BUFORA
R Wartość opcji: liczba

Znaczenie - maksymalna długość telegramów odpowiedzi (liczona w bajtach). Maksymalna wartość wynosi 118.

Wartość domyślna - 118 bajtów.

R Nazwa sekcji: OMRON
R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić maksymalny czas (w milisekundach) pomiędzy kolejnymi znakami odpowiedzi z określonego urządzenia. Po przekroczeniu tego czasu uznaje się, że przedmiotowe urządzenie nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

R Nazwa sekcji: OMRON
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: liczba

Znaczenie - określa maksymalny czas oczekiwania w milisekundach na odpowiedź urządzenia.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtOmronTcpip

Home > 1.88 OmronTcpip - drajwer do wymiany danych ze sterownikami Omron

1.88 OmronTcpip - drajwer do wymiany danych ze sterownikami Omron realizującymi protokół FINS/UDP oraz FINS/TCP

Przeznaczenie drajwera

Drajwer protokołu OmronTcpip służy do wymiany danych pomiędzy systemem Asix i sterownikami Omron realizującymi protokół FINS/UDP oraz FINS/TCP. Drajwer zapewnia komunikację ze sterownikami serii CS/CJ oraz CV.

Parametryzacja drajwera OmronTcpip realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera OmronTcpip wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:
Nazwa: nazwa logiczna kanału transmisji
Drajwer: Omron_Tcpip

Zakładka Omron_Tcpip/Parametry kanału:

Adres IP urządzenia - adres IP sterownika,

Numer węzła sterownika - numer węzła sterownika (tylko dla trybu UDP),

Numer węzła PC - numer węzła PC (tylko dla trybu UDP),

Numer alarmu - numer alarmu zgłaszanego do systemu alarmów Asixa w przypadku braku komunikacji ze sterownikiem,

Timeout - max. czas (w milisekundach) oczekiwania na odpowiedź ze sterownika.

Domyślnie 500 milisekund,

Port - numer portu TCPIP po stronie sterownika, na którym jest realizowany protokół FINS. Domyślnie jest to port 9600.

Synchronizacja czasu - okres synchronizacji czasu w sekundach (domyślnie bez synchronizacji);

Przykład deklaracji kanału transmisji do komunikacji ze sterownikiem o adresie IP 10.10.105.212 w trybie UDP (DA1 = 212, SA1 = 50) z synchronizacją czasu co 1 minutę:

IP=10.10.105.212; DA1=212; SA1=50; Synchronizacja czasu=60

Przykład deklaracji kanału transmisji do komunikacji ze sterownikiem o adresie IP 10.10.105.212 w trybie TCP z synchronizacją czasu co 1 minutę:

IP=10.10.105.212; Synchronizacja czasu=60

Deklaracja zmiennych

Ogólna składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ_zmiennej><indeks_zmiennej>

Lista typów 16-bitowych (typu WORD):

AR - Auxiliary Bit Area

C - Counter Area

CIO - CIO Area

DM - DM Area

HR - Holding Area

T - Timer Area

WR - Work Area

Lista typów 32-bitowych (typu DWORD):

ARL - Auxiliary Bit Area

CL - Counter Area

CIOL - CIO Area

DML - DM Area

HRL - Holding Area

TL - Timer Area

WRL - Work Area

Lista typów 32-bitowych (typu FLOAT):

ARF - Auxiliary Bit Area

CF - Counter Area

CIOF - CIO Area

DMF - DM Area

HRF - Holding Area

TF - Timer Area

WRF - Work Area

Lista typów 64-bitowych (typu DOUBLE):

ARD - Auxiliary Bit Area

CD - Counter Area

CIOD - CIO Area

DMD - DM Area

HRD - Holding Area

TD - Timer Area

WRD - Work Area

Lista typów 64-bitowych (typu INT64):

ARI - Auxiliary Bit Area

CI - Counter Area

CIOI - CIO Area

DMI - DM Area

HRI - Holding Area

TI - Timer Area

WRI - Work Area

Drajwer nie sprawdza poprawności zakresu indeksów zmiennych.

Przykłady deklaracji zmiennych:

JJ_01, HR numer 100 WORD , HR100, K1, 1, 1, NIC

JJ_02, C6 i C7 jako DWORD , CL6, K1, 1, 1, NIC_DW

JJ_03, DM480 i DM481 jako FLOAT, DMF480, K1, 1, 1, NIC_FP

JJ_04, DM480 - DM483 jako DOUBLE, DMD480, K1, 1, 1, NIC_DOUBLE

JJ_05, DM500 - DM503 jako INT64, DMI480, K1, 1, 1, NIC_INT64

Parametry drajwera

Drajwer jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry drajwera.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego wpisywane są komunikaty o stanie pracy drajwera.

Wartość domyślna: Domyślnie plik logu nie jest tworzony.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: Domyślnie opcja jest wyłączona.

Wartość opcji:

TAK/NIE

R Adres IP komputera

Znaczenie: Opcja pozwala na deklarację karty sieciowej, poprzez którą drajwer komunikuje się ze sterownikiem.

Wartość domyślna: Domyślnie wartość opcji ustawiona jest na NIE.

Wartość opcji:

adresIP - adres w notacji IPv4.

Przykładowa parametryzacja drajwera

Plik logu: d:\tmp\CtOmronTcpip\mvi.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Adres IP komputera: 10.10.105.23

Parametry kanału

Kanał jest parametryzowany przy użyciu opcji umieszczonych na zakładkach Parametry kanału 2.

R Plik logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego wpisywane są komunikaty o stanie pracy drajwera.

Wartość domyślna: Domyślnie plik logu zadeklarowany w opcjach drajwera.

Wartość opcji:

nazwa_pliku_logu

R Rozmiar pliku logu

Znaczenie: Opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna: Domyślnie rozmiar pliku logu zadeklarowany w opcjach drajwera.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie: Opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów odbieranych przez drajwer dla danego kanału. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: Domyślnie ustawienia z opcji drajwera.

Wartość opcji:

TAK/NIE

R Tryb UDP

Znaczenie: Opcja pozwala na ustawienie komunikacji w tryb UDP.

Wartość domyślna: NIE; domyślnie komunikacja odbywa się w trybie TCP.

Wartość opcji:

TAK/NIE

R Synchronizacja czasu UTC

Znaczenie: Opcja pozwala na określenie typu czasu przekazywanego do sterownika w ramach synchronizacji czasu.

Wartość domyślna: NIE; domyślnie do sterownika przekazuje się czas lokalny.

Wartość opcji:

TAK/NIE

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


Drajwer OPC

Home > 1.89 OPC

1.89 Drajwer OPC

Przeznaczenie drajwera

Drajwer OPC służy do wymiany danych między systemem Asix a dowolnym sterownikiem przemysłowym lub programem klasy SCADA, dla którego dostępny jest serwer danych zgodny ze specyfikacją OPC 1.0 lub OPC 2.05.

Drajwer OPC systemu Asix obsługuje czytanie ze sterownika oraz wpisywanie do niego:

1. zmiennych prostych, czyli zawierających wartości skalarne takie jak:

a. Bajt - liczba 8-bitowa bez znaku,

b. Słowo (liczba 16-bitowa) ze znakiem lub bez,

c. Podwójne słowo (liczba 32-bitowa) ze znakiem lub bez,

d. Liczba 64-bitowa ze znakiem lub bez,

e. Liczba rzeczywista pojedynczej precyzji (32 bity) i podwójnej precyzji;

2. zmiennych tablicowych jednowymiarowych składających się ze zmiennych prostych - typów wymienionych w punkcie 1;

3. zmiennych tekstowych.

Parametryzacja drajwera OPC realizowana jest przy użyciu programu Architekt.

Definicja kanału logicznego

Deklaracja kanału transmisyjnego działającego według protokołu drajwera OPC wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji

Drajwer: OPC

Alarm w kanale - numer alarmu zgłaszanego w przypadku zerwania połączenia ze sterownikiem

Zakładka OPC / Parametry kanału / Podstawowe:

Identyfikacja:

Identyfikator serwera OPC w systemie Windows

Mechanizm uaktualniania - definiuje mechanizm uaktualniania wartości z serwera OPC. Dostępne opcje:

- Wybór automatyczny,

- Asynchronicznie zgodnie ze specyfikacją OPC 1.0,

- Asynchronicznie zgodnie ze specyfikacją OPC 2.05,

- Synchronicznie.

Blokowanie wszystkich zapisów do serwera OPC - jeżeli TAK to blokowane są wszystkie zapisy do serwera OPC.

Okres odczytu wszystkich pomiarów - okres odczytu w [ms]; opcje należy używać tylko dla serwerów OPC, które zawierają błędy i nie zawsze przesyłają informacje o zmianach wartości zmiennych; okres czasu cyklicznego odczytu powinien być odpowiednio duży (rzędu dziesiątek sekund), aby serwer OPC nie został przeciążony.

PRZYKŁAD

Przykład deklaracji kanału logicznego odwołującego się do serwera OPC o identyfikatorze ”Matrikon.OPC.Simulation":

Nazwa: Matrikon

Drajwer: OPC

Identyfikator serwera OPC: Matrikon.OPC.Simulation

Przykład definicji kanału logicznego korzystającego ze wszystkich opcji:

Nazwa: Matrikon

Drajwer: OPC

Identyfikator serwera OPC: Matrikon.OPC.Simulation

Blokowanie zapisów: tak

Obiekty zawsze aktywne: tak

Wersja OPC: 2

Parametry kanału - zaawansowane

R Zmienna statusu kanału

Znaczenie - opcja pozwala zadeklarować zmienną służącą do sygnalizowania statusu kanału (dostarczana jest informacja na temat uszkodzenia bądź poprawnego działania kanału). Do wyboru są dwie możliwości: zadeklarowanie wartości zmiennej oznaczającej poprawne działanie kanału (wówczas inna wartość zmiennej oznacza błąd w kanale) lub zadeklarowanie wartości sygnalizującej uszkodzenie kanału (wówczas inna wartość zmiennej oznacza poprawne działanie kanału).

R Zmienne zawsze aktywne

Znaczenie - opcja powinna zawsze mieć wartość TAK z wyjątkiem sytuacji, gdy z serwera OPC pobierane są zmienne, które nie są archiwizowane w systemie Asix i nie są używane w skryptach.

Parametry kanału - zdalny serwer

R Zdalny serwer

Znaczenie - w przypadku użycia tej opcji projektant jest całkowicie odpowiedzialny za poprawne skonfigurowanie zabezpieczeń na obu komputerach tak, aby klient i serwer mogły ze sobą wymieniać dane używając DCOM.

Użycie tej opcji wymaga, aby w opcji Identyfikacja na pierwszej zakładce użyć ClassId, ponieważ na komputerze, na którym pracuje system Asix, serwer opc nie jest zarejestrowany. Jeśli nie podano nazwy serwera, to używany będzie komputer lokalny.

R Dane użytkownika, na konto którego będzie uruchomiony serwer OPC

Parametry:

Nazwa domeny lub komputera

Nazwa użytkownika

Hasło użytkownika

Użycie opcji wymaga zadeklarowania nazwy zdalnego serwera (opcja powyżej).

Parametry kanału - diagnostyka - log / Parametry kanału - diagnostyka - śledzenie

Druga grupa opcji deklarowana jest na zakładce OPC / Parametry kanału / Diagnostyka - Log.

R Log udanych inicjalizacji

Znaczenie - w logu umieszczane są informacje o pomyślnej inicjalizacji zmiennej w serwerze.

Wartość domyślna - opcja wyłączona.

R Log pomyślnych zapisów

Znaczenie - w logu umieszczane są informacje o pomyślnej operacji zapisu do serwera.

R Log przesyłanych zmiennych

Znaczenie - w logu umieszczane są nazwy zmiennych przysyłanych przez serwer.

R Log statystyki zmiany danych

Znaczenie - w logu umieszczane są nazwy zmiennych przysyłanych przez serwer.

R Śledzone zmienne

Znaczenie - Lista nazw zmiennych w systemie Asix, których wartości są zapisywane do pliku logu.

Wartość domyślna - opcja wyłączona.

Testowanie komunikacji

Drajwer OPC wpisuje do panel logu systemu Asix informacje o ważnych zdarzeniach takich jak: załadowanie drajwera, dołączenie się drajwera do serwera OPC, wykonanie inicjalizacji zmiennych. Wpisywane są też informacje o ewentualnych błędach na etapie inicjalizacji i podczas pracy drajwera.

Szczegółowe informacje o błędach oraz informacje diagnostyczne umieszczane są w pliku logu drajwera OPC. Plik logu drajwera nosi nazwę UniDriver.<bieżąca data>.log i domyślnie znajduje się w katalogu systemu Asix. Opcje ustalające, jakie informacje mają pojawiać się w pliku logu, podzielone są na dwie grupy. Opcje z pierwszej grupy deklarowane są na zakładce OPC/Parametry drajwera - UniDriver (patrz: poniżej). Druga grupa opcji deklarowana jest na zakładkach OPC / Parametry kanału / Diagnostyka - Log oraz OPC / Parametry kanału / Diagnostyka - Śledzenie (patrz: Parametry kanału - diagnostyka).

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

***

Wszystkie opcje dotyczące testowania komunikacji można zmieniać w trakcie działania systemu Asix. Po modyfikacji i zapisaniu na dysk pliku konfiguracyjnego aplikacji nowe wartości opcji zostaną pobrane z pliku przez drajwer OPC i zaczną mieć wpływ na zakres informacji wpisywanych do pliku logu.

***

Definicja zmiennej

Definiowanie zmiennych w systemie Asix opisane jest w dokumentacji ”Asix - funkcjonalność i zasady działania", w rozdziale 6.2. Deklarowanie zmiennych procesowych).

Definiując zmienną odwołującą się do serwera OPC należy jako adres zmiennej podać identyfikator zmiennej w bazie zmiennych serwera OPC. Składnia identyfikatora jest zależna od konkretnego serwera OPC i opisana w jego dokumentacji. Jeżeli identyfikator zawiera małe litery, przecinek lub spację, należy cały identyfikator ująć w cudzysłowy.

Uwaga: W edytorze bazy definicji zmiennych (w programie Architekt), klikając na komórkę w kolumnie adres można wyświetlić okno wyboru zmiennej z serwera OPC i za jego pomocą skonfigurować adres zmiennej.

Patrz informacje nt importu definicji zmiennych z serwera OPC: Architekt. chm/pdf, rozdz. 3.2.1. Kreator nowej aplikacji w trybie importu bazy z serwera OPC.

Dopasowanie typu zmiennej

Drajwer OPC inicjalizując zmienną w serwerze OPC przesyła mu żądany typ zmiennej. Typ ten wynika z funkcji przeliczającej przypisanej do zmiennej w bazie zmiennych systemu Asix. Jeśli typ zmiennej żądany przez drajwer OPC jest inny od typu zmiennej zapisanego w bazie zmiennych serwera OPC, to serwer OPC z reguły akceptuje żądany typ i przy transmisji danych wykonuje odpowiednią konwersję. Jeżeli serwer OPC nie potrafi wykonywać odpowiedniej konwersji, to zgłasza błąd przy inicjalizacji zmiennej. Fakt ten jest sygnalizowany w panel logu systemu Asix przez komunikat ”Niepoprawny typ zmiennej". Zmienna, której inicjalizacja w serwerze OPC zakończyła się błędem, będzie miała w systemie Asix status zły.

Jeżeli wystąpi błąd związany z niedopasowaniem typów zmiennej w systemie Asix i serwerze OPC, to należy użyć innej funkcji przeliczającej o analogicznym działaniu, ale operującej na typie obsługiwanym przez serwer OPC. Używane przez poszczególne funkcje przeliczające typy zmiennych opisane są w dokumentacji systemu Asix, w rozdziale Asmen/Funkcje przeliczające. W rozdziale tym typ zmiennej żądany od serwera OPC określany jest nazwą Typ zmiennej PLC.

Najczęściej niedopasowanie typu występuje przy funkcjach przeliczających operujących na liczbach całkowitych bez znaku, ponieważ niektóre serwery OPC w ogóle nie obsługują takich liczb. W przypadku napotkania takiego serwera użycie następujących funkcji przeliczających będzie niemożliwe: CZAS, CYRK1, LICZ, MASKA, MNOZNIK, MNOZNIK_DW, NEGBIT, NEGBIT_DW, NIC, NIC_BYTE, NIC_DD, NIC_DW, ON/OFF, PRZESUN_L, PRZESUN_P, SUWAK, SUWAK1, SUWAK1_FP.

Istnieją trzy funkcje przeliczające, które obsługują dowolny typ wartości pobieranej ze sterownika. Funkcje te to: GRADIENT, SREDNIA i TABELA. Ponieważ typem wyjściowym tych funkcji jest liczba zmiennoprzecinkowa, to dla tych funkcji drajwer OPC zawsze żąda od serwera OPC przesyłania wartości zmiennej w postaci liczby zmiennoprzecinkowej.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtPA5 - drajwer protokołu liczników przepływu PA5

Home > 1.90 PA5 - drajwer protokołu liczników przepływu PA5

1.90 PA5 - drajwer protokołu liczników przepływu PA5

Przeznaczenie drajwera

Drajwer protokołu Pa5 służy do wymiany danych pomiędzy systemem Asix i przetwornikami PA-5 produkowanymi przez Fabrykę Wodomierzy POWOGAZ S.A. w Poznaniu.

Komunikacja może być realizowana w dwóch trybach:

A/ point-to-point - pomiędzy system Asix i przetwornikiem jest łącze RS-232,

B/ multidrop - do komunikacji z przetwornikami wykorzystuje się adresowalne moduły ADAM-4521 połączone w sieć RS-485.

Parametryzacja drajwera CtPA5 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Pa5 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji
Drajwer: CtPA5

Zakładka PA5:

Parametry kanału:

Port=liczba [; TimeoutOdbioru=liczba] [;TypObslugi=liczba] [;OkresOdczytu=liczba]

gdzie:

Port - numer portu szeregowego COM komputera;

TimeoutOdbioru - czas oczekiwania (w milisekundach) na pierwszy znak odpowiedzi; domyślnie przyjmuje się 500 milisekund;

TimeoutZnaku - czas (w milisekundach) pomiędzy znakami odpowiedzi; domyślnie przyjmuje się 100 milisekund;

TypObslugi - interfejs RS-232 (tryb 1) lub RS-485 z modułami ADAM-4521 (tryb 2); domyślnym trybem jest tryb nr 2;

OkresOdczytu - czas w sekundach pomiędzy kolejnymi odczytami przetwornika; domyślnie wynosi 30 sekund (zalecany przez producenta). Parametr odnosi się do wszystkich przetworników obsługiwanych w danym kanale.

UWAGA Komunikacja z przetwonikiem odbywa się przy użyciu standardowych parametrów transmisji tzn. prędkości 1200 Bd, 8 bitów znaku i 1 bitu stopu.

UWAGA W przypadku użycia modułów adresowalnych ADAM-4521 należy w module ADAM-4521 ustawić następujące parametry:
a/ delimiter - { (ustawiony fabrycznie);
b/ add cr - yes (ustawiony fabrycznie);
c/ adres w sieci RS-485 (dla każdego modułu inny adres);
d/ baud rate - 1200 Bd (prędkość transmisji używana w przetworniku PA-5).

PRZYKŁAD

Przykład deklaracji kanału transmisji wykorzystującego COM2, tryb pracy z adresowalnymi modułami ADAM-4521 oraz odczytem przetwornika co 40 sekund:

Nazwa: KANAL

Drajwer: CtPA5

Parametry kanału: Port=2; OkresOdczytu=40

Deklaracja zmiennych

Adres zmiennej ma składnię:

V.<adres>.<index>

gdzie:

V - nazwa zmiennej,

adres - adres przetwornika (istotny w sieci RS-485 używającej adresowalne moduły ADAM‑4521. Przy połączeniach RS-232 wartość parametru może być dowolna),

index - przyjmuje wartości od 1 do 4:

1 - liczba porządkowa typu wodomierza,

2 - aktualna wartość procentowa przepływu,

3 - aktualny stan licznika A,

4 - aktualny stan licznika B.

Wszystkie zmienne zwracają wartość typu FLOAT.

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_01, licznik A przetwornika nr 1, V.1.3, KANAL, 1, 1, NIC_FP

JJ_02, licznik B przetwornika nr 2, V.2.4, KANAL, 1, 1, NIC_FP

Parametry drajwera

Parametry drajwera PA5 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CtPA5
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtPA5
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLK_LOGU.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: CtPA5
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowe parametry drajwera:

Nazwa sekcji:CtPA5

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\ctpa5\pa5.log

Nazwa sekcji: CtPA5

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CtPA5

Nazwa opcji: LOG_TELEGRAMOW

Wartośc opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtPD21

Home > 1.91 PD21 - drajwer do wymiany danych z koncentratorem PD21 firmy LUMEL

1.91 PD21 - drajwer do wymiany danych z koncentratorem PD21 firmy LUMEL

Przeznaczenie drajwera

Drajwer protokołu PD21 służy do wymiany danych pomiędzy systemem Asix i koncentratorem PD21 produkowanym przez LUMEL S.A. Zielona Góra. Transmisja jest realizowana łączem RS-232 przy wykorzystaniu protokołu LUMBUS.

Parametryzacja drajwera PD21 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer PD21 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: PD21

Zakładka PD21:

Parametry kanału:

Port=liczba; Nr=liczba; Typ=liczba [;PredkoscTransmisji=liczba]

gdzie:

Port - numer portu szeregowego,

Nr - numer urządzenia podpiętego do PD21 od strony obiektowej

Typ - typ urządzenia podpiętego do PD21 od strony obiektowej:

1 - licznik Multical

2 - miernik NA1

Domyślne parametry transmisji wynoszą:

prędkość transmisji 2400 Bd,

8 bitów znaku,

bez kontroli parzystości,

1 bit stopu.

Przykład deklaracji kanałów transmisji do komunikacji z licznikami Multical o numerach 2 i 3 oraz miernikiem NA1 o numerze 9 poprzez port szeregowy COM2.

K2 = UNIDRIVER, CtPD21, Port=2;Nr=2; Typ=1

K3 = UNIDRIVER, CtPD21, Port=2;Nr=3; Typ=1

K9 = UNIDRIVER, CtPD21, Port=2;Nr=9; Typ=2

Deklaracja zmiennych

Ogólna składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ>[.<index>]

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu - dotyczy tylko typu P (wartości pomiarów)

Wszystkie typy zmiennych są tylko do odczytu.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

P - wartości pomiarów

Zakres indeksów dla licznika Multical:

1 - energia (DWORD)

2 - objętość (DWORD)

3 - licznik godzin (DWORD)

4 - temperatura zasilania (DWORD)

5 - temperatura powrotu (DWORD)

6 - różnica temperatur (DWORD)

7 - moc (DWORD)

8 - przepływ (DWORD)

9 - maximum moc/przepływ (DWORD)

10 - informacja (DWORD)

Zakres indeksów dla miernika NA1:

1 - temperatura (DWORD)

2 - liczba zapalonych segmentów bargrafu (WORD)

3 - status (WORD)

4 - kod wykonania (WORD)

Wirtualna zmienna:

SK - status komunikacji (1 - o.k., 0 - błąd) (WORD)

Przykłady deklaracji zmiennych w kanałach K2 (Multical), K3 (Multical) oraz K9 (NA1):

JJ_01, energia, P1, K2, 1, 1, NIC_DW

JJ_02, objętość, P2, K2, 1, 1, NIC_DW

JJ_03, przepływ, P8, K3, 1, 1, NIC_DW

JJ_04, temperatura, P1, K9, 1, 1, NIC_DW

JJ_04, status, P2, K9, 1, 1, NIC

JJ_05,status komunikacji, SK, K2, 1, 1, NIC

JJ_06,status komunikacji, SK, K3, 1, 1, NIC

JJ_07,status komunikacji, SK, K9, 1, 1, NIC

Parametry drajwera

Parametry drajwera PD21 deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTPD21.

R Nazwa sekcji: CTPD21

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTPD21

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTPD21

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa sekcji: CTPD21

R Nazwa opcji: LICZBA_MASKOWANYCH_BLEDOW

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić max. liczbę kolejno następujących po sobie zapytań, na które koncentrator odpowiada błędem wykonania polecenia, po przekroczeniu której drajwer sygnalizuje błąd danych. Liczbę błędów drajwer nalicza dla każdego urządzenia z osobna.

Wartość domyślna: domyślnie wartość opcji wynosi 3.

Wartość opcji:

liczba - liczba maskowanych błędów

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Nazwa sekcji: CTPD21

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\CtPD21\muz.log

R Nazwa sekcji: CTPD21

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 20

R Nazwa sekcji: CTPD21

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

R Nazwa sekcji: CTPD21

R Nazwa opcji: LICZBA_MASKOWANYCH_BLEDOW

R Wartość opcji: 4

Parametryzacja koncentratora

Koncentrator jest parametryzowany przy użyciu osobnej sekcji, której nazwa składa się z nazwy drajwera, znaku dwukropka oraz numeru portu szeregowego, poprzez który jest realizowana komunikacja z koncentratorem (np. dla koncentratora podłączonego do portu COM1 należy utworzyć sekcję [CTPD21:1] ). W sekcji należy umieścić pozycje deklarujące:

• adres koncentratora w sieci LUMBUS,

• nazwę pliku logu,

• timeout odbioru,

• timeout znaku,

• prędkość transmisji.

Parametry deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

R Nazwa sekcji: CTPD21:numer_portu

R Nazwa opcji: ADRES

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić adres koncentratora PD21 w sieci LUMBUS. Opcja jest obowiązkowa.

Wartość opcji:

liczba - adres koncentratora PD2

R Nazwa sekcji: CTPD21:numer_portu

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić czas oczekiwania na pierwszy znak odpowiedzi z koncentratora PD21.

Wartość domyślna: domyślnie wartość opcji wynosi 1000.

Wartość opcji:

liczba - timeout odbioru w milisekundach.

R Nazwa sekcji: CTPD21:numer_portu

R Nazwa opcji: TIMEOUT_ZNAKU

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić czas pomiędzy kolejnymi znakami odpowiedzi z koncentratora PD21.

Wartość domyślna: domyślnie wartość opcji wynosi 100.

Wartość opcji:

liczba - timeout znaku w milisekundach.

R Nazwa sekcji: CTPD21:numer_portu

R Nazwa opcji: PREDKOSC_TRANSMISJI

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić prędkość transmisji na łączu szeregowym pomiędzy drajwerem i koncentratorem PD21.

Wartość domyślna: domyślnie wartość pozycji wynosi 2400.

Wartość opcji:

liczba - prędkość transmisji w Bd.

R Nazwa sekcji: CTPD21:numer_portu

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie log pliku nie jest tworzony.

PRZYKŁAD

Przykładowa parametryzacja koncentratora

Poniżej podano przykładową sekcję zawierającą deklaracje dla koncentratora dołączonego do portu szeregowego COM2.

R Nazwa sekcji: CTPD21:2

R Nazwa opcji: PREDKOSC_TRANSMISJI

R Wartość opcji: 2400

R Nazwa sekcji: CTPD21:2

R Nazwa opcji: TIMEOUT_ODBIORU

R Wartość opcji: 1500

R Nazwa sekcji: CTPD21:2

R Nazwa opcji: TIMEOUT_ZNAKU

R Wartość opcji: 120

R Nazwa sekcji: CTPD21:2

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\ctpd21\com1.log

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtPmc4000 - drajwer centrali przeciwpożarowej POLON 4800

Home > 1.92 Pmc4000 - drajwer centrali przeciwpożarowej POLON 4800

1.92 Pmc4000 - drajwer centrali przeciwpożarowej POLON 4800 wg protokołu PMC-4000

Przeznaczenie drajwera

Drajwer protokołu Pmc4000 służy do wymiany danych pomiędzy systemem Asix i centralą przeciwpożarową POLON 4800 wg protokołu PMC-4000. Komunikacja jest realizowana przy pomocy łącza szeregowego w standardzie RS-232.

Parametryzacja drajwera Pmc4000 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Pmc4000 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:
Nazwa: nazwa logiczna kanału transmisji
Drajwer: Pmc4000

Zakładka Pmc4000:

Parametry kanału:

Port=liczba; NrCentrali=liczba; Predkosc=liczba

gdzie:

Port - numer portu szeregowego COM komputera,

NrCentrali - numer centrali,

Predkosc - prędkość transmisji (2400, 4800 lub 9600 Bd). Domyślnie 9600 Bd.

PRZYKŁAD

Przykład deklaracji kanału transmisji komunikującego się z centralą ppoż. o numerze 2 przy pomocy portu szeregowego COM2 z domyślną prędkością transmisji (9600 Bd):

Nazwa: KANAL

Drajwer: CtPmc4000

Parametry kanału: Port=2; NrCentrali=2

Deklaracja zmiennych

Adres zmiennej ma składnię:

V.<nrLinii>.<nrElem>.<nrIO>.<nrStrefy>[.<bazowyNrAlarmu>]

gdzie:

V - nazwa zmiennej,

nrLinii - numer linii,

nrElem - numer elementu danej linii,

nrIO - numer we/wy danego elementu,

nrStrefy - numer strefy,

nrAlarmu - numer bazowego alarmu.

Wszystkie zmienne zwracają wartość typu WORD.

Numer linii, elementu, we/wy i strefy są określone przez konfigurację centrali ppoż.

Wartością zmiennej jest mapa bitowa stanu elementu centrali ppoż., którego adres podano w deklaracji zmiennej. Znaczenie bitów jest następujące:

bit 0 - status alarmu pożarowego;

bit 1 - status wysterowania;

bit 2 - status testu;

bit 3 - status blokowania;

bit 4 - status alarmu technicznego;

bit 5 - status uszkodzenia;

bit 6 - status uszkodzenia niemaskowalnego;

bit 7 - 15 - nie są wykorzystywane.

Jeśli wartość bitu wynosi 1, to dany stan jest aktywny.

Dla każdej zmiennej użytkownik może zdefiniować zestaw alarmów, przypisanych do poszczególnych bitów mapy bitowej zmiennej. Alarmy są zgłaszane w chwili zmiany stanu dowolnego z bitów. Poprawne działanie drajwera wymaga, aby przedmiotowe alarmy zajmowały spójny obszar numerów alarmów, zaczynający się od bazowyNrAlarmu. Kolejne numery alarmów, poczynając od bazowyNrAlarmu dotyczą:

+ 0 - alarm pożarowy;

+ 1 - wysterowany;

+ 2 - test;

+ 3 - blokowanie;

+ 4 - alarm techniczny;

+ 5 - uszkodzenie;

+ 6 - uszkodzenie niemaskowalne.

Alarmy Asixa są zgłaszane na zasadzie początek (zmiana z 0 na 1) i koniec (zmiana z 1 na 0). Czas wystąpienia alarmu jest opatrzony znacznikiem czasu centrali ppoż. Nie ma możliwości automatycznego przekazania tekstu alarmu przysłanego z centrali ppoż. do alarmu asixa. Zaleca się, aby teksty alarmów zdefiniowanych w systemie Asix były zgodne z tekstami alarmów zdefiniowanych w centrali ppoż.

Specyficznie obsługiwane zmienne

Specyficznie są obsługiwane zmienne o adresach:

V.0.0.0.0.bazowyAlarm (linia nr 0)

oraz

V.1.0.0.0.bazowyAlarm (linia nr 1)

Stan zmiennej V.0.0.0.0.bazowyAlarm zawiera informację o stanie alarmu II stopnia.

Znaczenie bitów jest następujące:

bit 0 - status alarmu II stopnia

Bazowy numer alarmu przedmiotowej zmiennej służy do generowania następujących alarmów:

+ 0 - sygnalizacja alarmu II stopnia,

+ 1 - odebranie informacji o KASOWANIU z centrali,

+ 2 - odebranie informacji o POTWIERDZENIU z centrali.

Zmiennej można używać do wysłania poleceń do centrali ppoż.:

- zapis do zmiennej wartości 1 powoduje wysłanie do centrali polecenia KASOWANIE,

- zapis do zmiennej wartości 2 powoduje wysłanie do centrali polecenia POTWIERDZENIE.

Stan zmiennej V.1.0.0.0.bazowyAlarm służy do przekazywania alarmów o uszkodzeniach w centrali.

Bazowy numer alarmu przedmiotowej zmiennej służy do generowania 107 alarmów wg specyfikacji podanej w tabeli kodów uszkodzeń centralowych w centrali POLON (”PMC-4000 - Protokół monitoringu cyfrowego standardu POLON 4800"). Pierwszemu alarmowi w specyfikacji zostanie przypisany numer bazowyAlarm, drugiemu - bazowyAlarm + 1, itd.

Wartość zmiennej jest przypadkowa.

PRZYKŁADY

Przykłady deklaracji zmiennych:

# zmienna służąca do pokazywania stanu alarmu II stopnia oraz do wysyłania poleceń

# KASOWANIE i POTWIERDZENIE. Generuje alarmy o numerach zaczynających się od 1

JJ_01, , V.0.0.0.0.1, PMC, 1, 1, NIC

# linia 1001, element 2, we/wy 3, strefa 4, alarmy od numeru 10 poczynając

JJ_02, , V.1001.2.3.4.10, PMC1, 1, 1, NIC

# linia 3002, element 4, we/wy 0, strefa 0, alarmy od numeru 20 poczynając

JJ_03, , V.3002.4.0.0.20, PMC1, 1, 1, NIC

# zmienna służąca do przekazywania alarmów o uszkodzeniach w centrali:

JJ_04, , V.1.0.0.0.1000, PMC, 1, 1, NIC

Definicje alarmów dla zmiennej JJ_01:

1, al, alarm ppoz II stopnia

2, al, informacja o skasowaniu alarmu ppoz z centrali

3, al, informacja o potwierdzeniu zdarzenia lub uszkodzenia

Definicje alarmów dla zmiennej JJ_02:

10, al, alarm pożarowy - linia 1001 elem 2 io 3 strefa 4

11, al, wysterowanie - linia 1001 elem 2 io 3 strefa 4

12, al, test - linia 1001 elem 2 io 3 strefa 4

13, al, blokowanie - linia 1001 elem 2 io 3 strefa 4

14, al, alarm techn. - linia 1001 elem 2 io 3 strefa 4

15, al, uszkodzenie - linia 1001 elem 2 io 3 strefa 4

16, al, uszkodz. niemask. - linia 1001 elem 2 io 3 strefa 4

Definicje alarmów dla zmiennej JJ_03:

20, al, alarm pożarowy - linia 3002 elem 4 io 0 strefa 0

21, al, wysterowanie - linia 3002 elem 4 io 0 strefa 0

22, al, test - linia 3002 elem 4 io 0 strefa 0

23, al, blokowanie - linia 3002 elem 4 io 0 strefa 0

24, al, alarm techn. - linia 3002 elem 4 io 0 strefa 0

25, al, uszkodzenie - linia 3002 elem 2 io 0 strefa 0

26, al, uszkodz. niemask. - linia 3002 elem 2 io 0 strefa 0

Definicje alarmów dla zmiennej JJ_04:

1000,al, system mikroprocesroa uP1

1001,al, system mikroprocesroa uP2

1005,al, pamięć EPROM procesroa uP1

1006,al, pamięć konfiguracji - setup up1

Parametry drajwera

Parametry drajwera Pmc4000 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CtPmc4000
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtPmc4000
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLIK_LOGU. Po przekroczeniu rozmiaru zadeklarowanego przy użyciu przedmiotowej opcji, drajwer zachowuje bieżącą zawartość pliku logu w pliku o nazwie nazwa_pliku_logu.old (nazwa jest budowana z nazwa_pliku_logu podanej w deklaracji PLIK_LOGU oraz rozszerzenia old). W ten sposób użytkownik ma zawsze wgląd do zapisów o rozmiarze równym co najmniej ROZMIAR_PLIKU_LOGU MB.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CtPmc4000
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowe parametry drajwera:

Nazwa sekcji: CtPmc4000
Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\CtPmc4000\pmc.log

Nazwa sekcji: CtPmc4000

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 20

Nazwa sekcji: CtPmc4000

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


PPI - drajwer protokołu PPI sterowników SIMATIC S7 serii

Home > 1.93 PPI - drajwer protokołu PPI sterowników SIMATIC S7 serii

1.93 PPI - drajwer protokołu PPI sterowników SIMATIC S7 serii 200

Przeznaczenie drajwera

Protokół komunikacyjny PPI służy do wymiany danych pomiędzy komputerami z aplikacją Asixa oraz sterownikami SIEMENS S7 serii 200.

Parametryzacja drajwera PPI realizowana jest przy użyciu programu Architekt.

Deklaracja kanału logicznego

Deklaracja kanału transmisyjnego działającego według protokołu drajwera PPI wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: PPI

Zakładka PPI / Parametry kanału:

Port - numer portu szeregowego (COM1 ... COM256)

Adres - sterownika programowalnego

Parametry kanału / drajwera

Parametry drajwera deklarowane są w module Dane bieżące na zakładkach PPI kanału działającego według protokołu drajwera PPI.

Zakładki Parametry kanału obejmują parametry dotyczące ściśle danego kanału, podczas gdy zakładki Parametry drajwera zawierają parametry dotyczące wszystkich utworzonych kanałów, dla których został zadeklarowany drajwer PPI.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany drajwer PPI. Mając zatem utworzonych kilka kanałów działających w oparciu o PPI - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

Zakładka Parametry kanału:

R liczba_powtórzeń

Znaczenie - opcja pozwala określić ilość powtórzeń transmisji w przypadku błędów transmisji. Opcja może być stosowana zamiennie z opcjami: Powtórzenia.

Wartość domyślna - 4.

Parametr:

liczba - ilość powtórzeń.

R timeout

Znaczenie - opcja pozwala określić czas oczekiwania na odpowiedź stacji. Opcja może być stosowana zamiennie z opcjami: time-out, time_out.

Wartość domyślna - 500.

Parametr:

liczba - wartość czasu wyrażana w milisekundach.

R Opóźnienie

Znaczenie - opcja pozwala określić minimalny odstęp czasu pomiędzy transmisjami ramek.

Wartość domyślna - 25.

Parametr:

liczba - wartość czasu wyrażana w milisekundach.

R Wszystkie_Błędy

Znaczenie - jeśli parametr ma wartość nie, to informacja o błędach timeout będzie pojawiać się w panelu kontrolnym tylko wtedy, gdy transmisja nie udała się pomimo prób jej powtarzania. Jeśli wartość ustawiona jest na tak, to informacja o wszystkich błędach przekazywana jest do panel.

Zakładka Parametry kanału 2:

R Ramka_Nadawcza

Znaczenie - określa maksymalną długość ramki nadawczej.

Wartość domyślna - 117.

Parametr:

liczba - wartość wyrażona w bajtach z przedziału 10-260.

R Ramka_Odbiorcza

Znaczenie - określa maksymalną długość ramki odbiorczej.

Wartość domyślna - 117.

Parametr:

liczba - wartość wyrażona w bajtach z przedziału 10-260.

R Zmienne

Znaczenie - określa maksymalną ilość zmiennych przesyłanych jednorazowo.

Wartość domyślna - 8.

R Symulacja

Znaczenie - jeśli podano tak, to odczyt / zapis do / z sterownika programowalnego będzie symulowany.

Wartość domyślna - nie.

R PCAdres

Znaczenie - opcja służy do deklaracji adresu komputera.

Wartość domyślna - 0.

Parametr:

liczba - wartość wyrażona w bajtach z przedziału 0-255.

Zakładka Parametry drajwera:

Parametry transmisji:

R Port - numer portu szeregowego (COM1 ... COM256)

R Szybkość

Znaczenie - opcja pozwala określić szybkość transmisji. Opcja nie jest umieszczana w sekcji parametrów kanału logicznego. Opcja może być stosowana zamiennie z opcjami: Szybkosc, bps.

Wartość domyślna - 9600.

Parametr:

liczba - wartość wyrażana w jednostkach baud.

R Parzystość

Znaczenie - opcja pozwala określić rodzaj kontroli parzystości. Opcja nie jest umieszczana w sekcji parametrów kanału logicznego. Opcja może być stosowana zamiennie z opcjami: parzystosc.

Wartość domyślna - e.

Parametr:

parametr_parzystości - przyjmuje następujące wartości:

n - brak bitu parzystości,

o - kontrola parzystości nieparzysta,

e - kontrola parzystości parzysta,

m - mark,

s - space.

R Dł_Słowa

Znaczenie - opcja pozwala określić długość słowa. Opcja nie jest umieszczana w sekcji parametrów kanału logicznego. Opcja może być stosowana zamiennie z opcjami: Slowo, długość_słowa, długosc_slowa.

Wartość domyślna - 8.

Parametr:

liczba - od 5 do 8 bitów.

R bity_stopu

Znaczenie - opcja pozwala określić ilość bitów stopu. Opcja nie jest umieszczana w sekcji parametrów kanału logicznego. Opcja może być stosowana zamiennie z opcjami: stop.

Wartość domyślna - 1.

Parametr:

liczba - ilość bitów.

R AsComm

Znaczenie - określa, czy drajwer ma współpracować z menedżerem komunikacyjnym AsComm. Opcja nie jest umieszczana w sekcji parametrów kanału logicznego.

Wartość domyślna - nie (od wersji 1.1).

PRZYKŁADY

Przykład 1

Deklaracja kanału:

Nazwa: S7_212

Drajwer: PPI

Parametry kanału:

Port: COM2

Adres sterownika programowalnego: 5

W powyższym przykładzie zdefiniowano stację o nazwie S7_212 podłączoną do portu COM2. Komunikacja ze sterownikiem będzie się odbywać w oparciu o parametry domyślne.

Przykład 2

Stacja S7_1

Deklaracja kanału:

Nazwa: S7_1

Drajwer: PPI

Parametry kanału:

Port: COM2

Adres sterownika programowalnego: 5

Parametry drajwera:

Szybkość: 9600

Stacja S7_2

Deklaracja kanału:

Nazwa: S7_2

Drajwer: PPI

Parametry kanału:

Port: COM2

Adres sterownika programowalnego: 6

Parametry drajwera:

Szybkość: 9600

Stacja S7_3

Deklaracja kanału:

Nazwa: S7_3

Drajwer: PPI

Parametry kanału:

Port: COM2

Adres sterownika programowalnego: 7

Parametry drajwera:

Szybkość: 9600

Stacja S7_4

Deklaracja kanału:

Nazwa: S7_4

Drajwer: PPI

Parametry kanału:

Port: COM3

Adres sterownika programowalnego: 8

Parametry drajwera:

Szybkość: 19200

Stacja S7_5

Deklaracja kanału:

Nazwa: S7_5

Drajwer: PPI

Parametry kanału:

Port: COM3

Adres sterownika programowalnego: 9

Parametry drajwera:

Szybkość: 19200

Stacja S7_6

Deklaracja kanału:

Nazwa: S7_6

Drajwer: PPI

Parametry kanału:

Port: COM4

Adres sterownika programowalnego: 10

Opóźnienie: 15

Parametry drajwera:

Szybkość: 9600

W powyższym przykładzie zdefiniowano stacje o nazwach od S7_1 do S7_6. Do portu COM2 podłączone są stacje S7_1, S7_2 i S7_3. Do portu COM3 podłączone są stacje S7_4 i S7_5. Stacja S7_6 podłączona jest do portu COM4. Wszystkie porty szeregowe z wyjątkiem COM3 będą pracować z szybkością 9600 baud. Port COM3 będzie pracował z szybkością 19200 baud. W czasie wymiany danych ze stacją S7_6 opóźnienie pomiędzy transmisjami zostanie skrócone do 15 milisekund.

UWAGA Drajwer protokołu PPI może współpracować z menedżerem połączeń AsComm. W takim przypadku, drajwer rejestruje się jako klient modułu AsComm o nazwie PPI:n, gdzie n jest numerem łącza szeregowego, poprzez które przebiega komunikacja ze sterownikiem programowalnym.

Definiowanie zmiennych

Dane pomiarowe

Drajwer realizuje dostęp do następujących zmiennych - zobacz tabela poniżej.

Tabela. Zmienne obsługiwane przez drajwer PPI.

Znaczenie symboli umieszczonych w lewej kolumnie (z wyjątkiem symbolu RUN) jest opisane w dokumentacji sterowników S7.

Zmienna RUN przyjmuje wartość 1 jeśli sterownik znajduje się w stanie RUN, a 0 w przeciwnym wypadku. Zapis do zmiennej RUN wartości różnej od zera powoduje uruchomienie sterownika. Zapis wartości 0 do zmiennej RUN powoduje przejście sterownika do trybu STOP. Zmiana stanu sterownika jest możliwa tylko przy odpowiednim ustawianiu przełączników na sterowniku.

Zmienne Cn i Tn umożliwiają dostęp do aktualnej wartości liczników i czasówek. Zmienne Cn.m i Tn.m umożliwiają dostęp do stanu (1 lub 0) liczników i czasówek. Wartość ”m." może być dowolną liczbą z przedziału od 0 do 7.

Aktualna wersja drajwera nie pozwala na zapis do zmiennych Q, AQW,AIW. Zapis do innych zmiennych jest ograniczony przez sterownik (Cm.n, Tm.n).

Dostęp do pseudo-zmiennych

Drajwer protokołu PPI umożliwia dostęp do pseuodo-zmiennych. Dostęp do pseudo-zmiennych nie powoduje fizycznej transmisji po łączu szeregowym. Wartości pseudo-zmiennych związane są z aktualnym stanem połączenia ze sterownikiem.

Tabela. Pseudo-zmienne obsługiwane przez drajwer PPI.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtProtherm300 - drajwer protokołu regulatora PROTHERM 300

Home > 1.94 Protherm300 - drajwer protokołu regulatora PROTHERM 300

1.94 Protherm300 - drajwer protokołu regulatora PROTHERM 300 DIFF

Przeznaczenie drajwera

Drajwer Protherm300 jest przeznaczony do wymiany danych pomiędzy systemem Asix i sterownikiem Protherm 300 DIFF firmy Process-Electronic GmbH. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie RS-422.

Parametryzacja drajwera CtProtherm300 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Protherm300 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: Protherm300

Zakładka Protherm300:

Parametry kanału:

Port=numer_portu [;TimeoutOdbioru=liczba_ms]

gdzie:

numer_portu - numer portu szeregowego (dla COM1 podaje się 1, dla COM2 podaje się 2 itd.);

liczba_ms - timeout oczekiwania na odpowiedź ze sterownika (w milisekundach). Domyślnie przyjmuje się 1000 milisekund.

Domyślnie przyjmuje się następujące parametry transmisji:

  • prędkość transmisji 9600 Bd,

  • liczba bitów w znaku - 7,

  • kontrola parzystości - parzysta (EVEN),

  • liczba bitów stopu - 1.

Od wersji Protherm300 2.0.2.1 dodano dwie zmienne wirtualne służące do kontroli dostępu do portu szeregowego. Zmiennym zostały przypisane następujące indeksy w adresie symbolicznym:

118 - pokazuje aktualny stan dostępu do portu szeregowego (1 - zajęty przez drajwer, 0 - nieużywany przez drajwer)

119 - steruje dostępem do portu szeregowego (1 - żądanie zajęcia portu przez drajwer, 0 - żądanie zwolnienia portu przez drajwer)

PRZYKŁAD

Przykład deklaracji kanału korzystającego z drajwera Protherm300 na porcie COM2 z timeout’em odbioru 2000 ms jest następująca:

Nazwa/Kanał: PLC1

Drajwer: CtProtherm300

Parametry kanału:

Port=2; TimeoutOdbioru=2000

Adresacja zmiennych

Składnia adresu symbolicznego jest następująca:

V.grupa.unit.indeks

gdzie:

grupa - numer grupy, do której należy sterownik (liczba od 0 do 9),

unit - numer przydzielony sterownikowi w ramach grupy (liczba 0 do 9),

indeks - numer zmiennej w sterowniku, wg specyfikacji ’Variablen-Liste fuer PT300’, zawartej w dokumentacji ”Protherm300/Protherm300 Kommunikation".

Surowe zmienne mogą przyjmować jeden z poniższych typów:

  • bajt,

  • tablica bajtów,

  • float.

Typ surowej zmiennej jest określony w specyfikacji ’Variablen-Liste fuer PT300’, zawartej w dokumentacji ”Protherm300/Protherm300 Kommunikation", wydanej przez Process-Electronic, oznaczonej symbolem R411.0.

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_00, wartość CO (FLOAT),V.1.2.6, PLC1, 1, 1, NIC_FP

JJ_01, status STAT3 (BAJT),V.1.2.18, PLC1, 1, 1, NIC_BYTE

JJ_02, tablica 4-ech statusów XRELi (BAJT),V.1.2.14,PLC1, 4, 1, NIC_BYTE

Znacznik czasu

Wartościom zmiennych odczytanych z systemu Protherm300 jest nadawany stempel czasu lokalnego PC.

Parametry drajwera

Parametry drajwera Protherm300 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CtProtherm300
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu

R Nazwa sekcji: CtProtherm300
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślnie - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: CtProtherm300
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych i odbieranych ze sterownika. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie wartość opcji jest ustawiona na NIE.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


PROTRONICPS - drajwer protokołu regulatorów PROTRONICPS

Home > 1.95 PROTRONICPS - drajwer protokołu regulatorów PROTRONICPS

1.95 PROTRONICPS - drajwer protokołu regulatorów PROTRONICPS

Przeznaczenie drajwera

Drajwer PROTRONICPS jest wykorzystywany do wymiany danych pomiędzy regulatorami PROTRONIC PS firmy Hartmann & Braun oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych w standardzie RS422.

Parametryzacja drajwera PROTRONICPS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera PROTRONICPS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: PROTRONICPS

Zakładka PROTRONICPS:

Parametry kanału:

id, port, baud [,znak, parzystość, stop]

gdzie:

id - identyfikator urządzenia (numer regulatora w sieci),

port - nazwa portu szeregowego,

baud - prędkość transmisji,

opcjonalne parametry:

znak - liczba bitów w znaku,

parzystość - sposób kontroli parzystości,

stop - liczba bitów stopu.

Domyślnie przyjmuje się:

  • 8 bitów w znaku,

  • kontrola parzystości parzysta (EVEN),

  • liczba bitów stopu 1.

Drajwer PROTRONICPS jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennej. Dopuszczalne typy to:

STAT - status regulatora,

F - status błędów regulatora,

WA - wartość analogowa,

BV - wartość binarna,

Y - wyjście regulatora;

indeks - indeks w ramach typu (stosowany tylko dla WA, BV i Y):

WA 0 - 255,

BV 0 - 255,

Y 0 - 1.

Zmienne typu STAT i F można wyłącznie czytać.

Zmienne typu Y można wyłącznie zapisywać.

Zmienne typu WA i BV można czytać i zapisywać.

Surowe wartości zmiennych typu STAT, F, WA są typu WORD.

Surowe wartości zmiennych typu BV są typu BYTE.

Surowe wartości zmiennych typu Y są typu SIGNED SHORT.

PRZYKŁADY

Przykład deklaracji zmiennych:

X1, Status kontrolera,STAT, KANAL1, 1, 1, NIC

X2, Status błędów,F, KANAL1, 1, 1, NIC

X3, Bit BV1,BV1, KANAL1, 1, 1, NIC_BYTE

X4, Analog WA3,WA3, KANAL1, 1, 1, NIC

X5, Wyjście regulatora nr 0,Y0, KANAL1, 1, 1, NIC

X6, Wyjście regulatora nr 1,Y1, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera PROTRONICPS deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: PROTRONICPS
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera PROTRONICPS oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: PROTRONICPS
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji z regulatorem PROTRONIC PS. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: PROTRONICPS
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie opcja przyjmuje wartość 0 (nie ma powtórzeń).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


S700 - drajwer protokołu analizatorów gazowych firmy

Home > 1.96 S700 - drajwer protokołu analizatorów gazowych firmy MAIHAK

1.96 S700 - drajwer protokołu analizatorów gazowych firmy MAIHAK

Przeznaczenie drajwera

Drajwer S700 jest wykorzystywany do wymiany danych pomiędzy analizatorami gazu serii S700 firmy Maihak oraz komputerem systemu Asix przy pomocy "protokołu AK".

Komunikacja odbywa się przy wykorzystaniu standardowych portów szeregowych komputera Asix oraz interfejsu szeregowego nr 1 analizatora.

UWAGA Ustawienia Interfejs szeregowy # 1 analizatora muszą mieć następujące wartości:
1/ protokół RTS/CTS - bez protokołu RTS/CTS;
2/ protokół XON/XOFF - bez protokołu XON/XOFF.
Ustawienia Komunikacja # 1 analizatora muszą mieć następujące wartości:
1/ AK-ID aktywne - WŁĄCZ. (1).

Parametryzacja drajwera S700 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera S700 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: S700

Zakładka S700:

Parametry kanału:

id, port [, baud ,znak, parzystość, stop]

gdzie:

id - identyfikator analizatora ( numer AK-ID ),

port - nazwa portu: COM1, COM2 itd.,

opcjonalne parametry:

baud - prędkość transmisji,

znak - liczba bitów w znaku,

parzystość - sposób kontroli parzystości,

stop - liczba bitów stopu.

Jeśli nie podano parametrów opcjonalnych, to domyślnie przyjmuje się:

  • prędkość transmisji 9600 bodów,

  • 8 bitów w znaku,

  • bez kontroli parzystości (NONE),

  • liczba bitów stopu 1.

Przykład

Deklaracja kanału logicznego o nazwie KANAL1, działającego wg protokołu S700 i wymieniającego dane z analizatorem o numerze 1 poprzez port COM2 jest następujaca:

Nazwa/Kanał: KANAL1

Drajwer: S700

Parametry kanału: 1, COM2

Drajwer S700 jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ>[<indeks>][.<element>]

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu (dla niektórych typów zmiennych),

element - element w ramach indeksu (dla niektórych typów zmiennych).

Typy nie używające indeksu (w nawiasie podano typ surowej wartości zmiennej):

CZK - czas pomiaru kalibracyjnego (WORD),

CZO - czas opóźnienia (WORD),

IDA - identyfikator analizatora (do 40 znaków) (BYTE),

MNU - identyfikator języka menu (BYTE),

NRS - numer seryjny analizatora (BYTE),

PGB - pomiar (wprowadzenie) gazu badanego do analizatora (WORD),

SPKK - stan pompy kuwety kalibracyjnej (WORD).

Typy wymagające podania indeksu (w nawiasie podano typ surowej wartości zmiennej):

DWK - dryft wrażliwości po kalibracji (FLOAT),

DZK - dryft punktu zerowego substancji pomiarowej po kalibracji (FLOAT),

NSKK - wartość nominalna substancji pomiarowej w kuwecie kalibracyjnej (FLOAT),

PGKW - pomiar (wprowadzenie) gazu kalibracyjnego wzorcowego do analizatora (WORD),

PGKZ - pomiar (wprowadzenie) gazu kalibracyjnego zerowego do analizatora (WORD),

SKT - kompensacja temperatury substancji pomiarowej (WORD),

SPKW - stan pompy gazu kalibracyjnego wzorcowego (WORD),

SPKZ - stan pompy gazu kalibracyjnego zerowego (WORD),

SPT - nazwa substancji pomiarowej (BYTE),

SPW - aktualnie mierzone wartości substancji pomiarowych (FLOAT),

SPZ - wartość końcowa zakresu pomiarowego substancji pomiarowej (FLOAT),

STA - aktualny stan analizatora (WORD).

Typy wymagające podania indeksu i elementu (w nawiasie podano typ surowej wartości zmiennej):

NSPW - wartość nominalna substancji pomiarowej w gazie kalibracyjnym wzorcowym (FLOAT),

NSPZ - wartość nominalna substancji pomiarowej w gazie kalibracyjnym zerowym (FLOAT).

Typy wyłącznie do odczytu:

DWK - dryft wrażliwości po kalibracji,

DZK - dryft punktu zerowego substancji pomiarowej po kalibracji,

MNU - identyfikator języka menu,

NRS - numer seryjny analizatora,

NSKK - wartość nominalna substancji pomiarowej w kuwecie kalibracyjnej,

SPKK - stan pompy kuwety kalibracyjnej,

SPT - nazwa substancji pomiarowej,

SPW - aktualnie mierzone wartości substancji pomiarowych,

SPZ - wartość końcowa zakresu pomiarowego substancji pomiarowej,

STA - aktualny stan analizatora.

Typy wyłącznie do zapisu:

PGB - pomiar (wprowadzenie) gazu badanego do analizatora,

PGKW - pomiar (wprowadzenie) gazu kalibracyjnego wzorcowego do analizatora,

PGKZ - pomiar (wprowadzenie) gazu kalibracyjnego zerowego do analizatora.

Typy do odczytu i zapisu:

CZO - czas opóźnienia,

CZK - czas pomiaru kalibracyjnego,

IDA - identyfikator analizatora,

NSPW - wartość nominalna substancji pomiarowej w gazie kalibracyjnym wzorcowym,

NSPZ - wartość nominalna substancji pomiarowej w gazie kalibracyjnym zerowym,

SKT - kompensacja temperatury substancji pomiarowej,

SPKW - stan pompy gazu kalibracyjnego wzorcowego,

SPKZ - stan pompy gazu kalibracyjnego zerowego.

Przykłady deklaracji zmiennych

# nazwy typów (SPT) i zakresy (SPZ) substancji pomiarowych - z indeksem

X1, SPT1, KANAL1, 10, 1, NIC_TEXT

X2, SPZ1, KANAL1, 1, 1, NIC_FP

X3, SPT2, KANAL1, 10, 1, NIC_TEXT

X4, SPZ2, KANAL1, 1, 1, NIC_FP

X5, SPT3, KANAL1, 10, 1, NIC_TEXT

X6, SPZ3, KANAL1, 1, 1, NIC_FP

X7, SPT4, KANAL1, 10, 1, NIC_TEXT

X8, SPZ4, KANAL1, 1, 1, NIC_FP

X9, SPT5, KANAL1, 10, 1, NIC_TEXT

X10, SPZ5, KANAL1, 1, 1, NIC_FP

# bajty stanu (STA) analizatora - z indeksem

X11, STA1, KANAL1, 1, 1, NIC

X12, STA2, KANAL1, 1, 1, NIC

X13, STA3, KANAL1, 1, 1, NIC

X14, STA4, KANAL1, 1, 1, NIC

X15, STA5, KANAL1, 1, 1, NIC

X16, STA6, KANAL1, 1, 1, NIC

X17, STA7, KANAL1, 1, 1, NIC

X18, STA8, KANAL1, 1, 1, NIC

# aktualne wartości (SPW) substancji pomiarowych - z indeksem

X21, SPW1, KANAL1, 1, 1, NIC_FP

X22, SPW2, KANAL1, 1, 1, NIC_FP

X23, SPW3, KANAL1, 1, 1, NIC_FP

X24, SPW4, KANAL1, 1, 1, NIC_FP

X25, SPW5, KANAL1, 1, 1, NIC_FP

# przerwy czasowe (CZO i CZK) - bez indeksu

X31, CZO, KANAL1, 1, 1, NIC

X32, CZK, KANAL1, 1, 1, NIC

# wyniki po kalibracji : dryft zera (DZK), dryft wrażliwości (DWK) - bez indeksu

X42, DZK1, KANAL1, 1, 1, NIC_FP

X43, DWK1, KANAL1, 1, 1, NIC_FP

X44, DZK2, KANAL1, 1, 1, NIC_FP

X45, DWK2, KANAL1, 1, 1, NIC_FP

# stan kompensacji temperatury (SKT) - z indeksem

X51, SKT1, KANAL1, 1, 1, NIC

X52, SKT2, KANAL1, 1, 1, NIC

X53, SKT3, KANAL1, 1, 1, NIC

X54, SKT4, KANAL1, 1, 1, NIC

X55, SKT5, KANAL1, 1, 1, NIC

# identyfikator analizatora (IDA) - bez indeksu

X61, IDA, KANAL1, 42, 1, NIC_TEXT

# numer seryjny analizatora (IDA) - bez indeksu

X62, NRS, KANAL1, 20, 1, NIC_TEXT

# język menu analizatora (IDA) - bez indeksu

X63, MNU, KANAL1, 1, 1, NIC_BYTE

# stan pompy gazów kalibr. zerowych (1 i 2) (SPKZ) - z indeksem

X70, SPKZ1, KANAL1, 1, 1, NIC

X80, SPKZ2, KANAL1, 1, 1, NIC

# nominały gazów kalibr. zerowych (1 i 2) (NSPZ) - z indeksem i elementem

X71, NSPZ1.1, KANAL1, 1, 1, NIC_FP

X72, NSPZ1.2, KANAL1, 1, 1, NIC_FP

X73, NSPZ1.3, KANAL1, 1, 1, NIC_FP

X74, NSPZ1.4, KANAL1, 1, 1, NIC_FP

X75, NSPZ1.5, KANAL1, 1, 1, NIC_FP

X81, NSPZ2.1, KANAL1, 1, 1, NIC_FP

X82, NSPZ2.2, KANAL1, 1, 1, NIC_FP

X83, NSPZ2.3, KANAL1, 1, 1, NIC_FP

X84, NSPZ2.4, KANAL1, 1, 1, NIC_FP

X85, NSPZ2.5, KANAL1, 1, 1, NIC_FP

# stan pompy gazów kalibr. wzorcowych (3 - 6) (SPKW) - z indeksem

X90, SPKW3, KANAL1, 1, 1, NIC

X100, SPKW4, KANAL1, 1, 1, NIC

X110, SPKW5, KANAL1, 1, 1, NIC

X120, SPKW6, KANAL1, 1, 1, NIC

# nominały gazów kalibr. wzorcowych (3 - 6) (NSPW) - z indeksem i elementem

X91, NSPW3.1, KANAL1, 1, 1, NIC_FP

X92, NSPW3.2, KANAL1, 1, 1, NIC_FP

X93, NSPW3.3, KANAL1, 1, 1, NIC_FP

X94, NSPW3.4, KANAL1, 1, 1, NIC_FP

X95, NSPW3.5, KANAL1, 1, 1, NIC_FP

X101, NSPW4.1, KANAL1, 1, 1, NIC_FP

X102, NSPW4.2, KANAL1, 1, 1, NIC_FP

X103, NSPW4.3, KANAL1, 1, 1, NIC_FP

X104, NSPW4.4, KANAL1, 1, 1, NIC_FP

X105, NSPW4.5, KANAL1, 1, 1, NIC_FP

X111, NSPW5.1, KANAL1, 1, 1, NIC_FP

X112, NSPW5.2, KANAL1, 1, 1, NIC_FP

X113, NSPW5.3, KANAL1, 1, 1, NIC_FP

X114, NSPW5.4, KANAL1, 1, 1, NIC_FP

X115, NSPW5.5, KANAL1, 1, 1, NIC_FP

X121, NSPW6.1, KANAL1, 1, 1, NIC_FP

X122, NSPW6.2, KANAL1, 1, 1, NIC_FP

X123, NSPW6.3, KANAL1, 1, 1, NIC_FP

X124, NSPW6.4, KANAL1, 1, 1, NIC_FP

X125, NSPW6.5, KANAL1, 1, 1, NIC_FP

# ustawienia kuwety kalibr. (SPKK) - pompa, (NSKK) - nominał

X130, SPKK, KANAL1, 1, 1, NIC

X131, NSKK1, KANAL1, 1, 1, NIC_FP

X132, NSKK2, KANAL1, 1, 1, NIC_FP

X133, NSKK3, KANAL1, 1, 1, NIC_FP

X134, NSKK4, KANAL1, 1, 1, NIC_FP

X135, NSKK5, KANAL1, 1, 1, NIC_FP

# start pomiar gazu kalibracyjnego zerowego (1 i 2)

X201, PGKZ1, KANAL1, 1, 1, NIC

X202, PGKZ2, KANAL1, 1, 1, NIC

# start pomiar gazu kalibracyjnego wzorcowego (3 - 6)

X203, PGKW3, KANAL1, 1, 1, NIC

X204, PGKW4, KANAL1, 1, 1, NIC

X205, PGKW5, KANAL1, 1, 1, NIC

X206, PGKW6, KANAL1, 1, 1, NIC

# start pomiar gazu badanego

X207, PGB, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera S700 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: S700
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera S700 oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: S700
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji z analizatorem S700. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: S700
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Nazwa sekcji: S700
R Nazwa opcji: IGNORUJ_ZNAK_STANU
R Wartość opcji: TAK|NIE

Znaczenie - w każdej odpowiedzi z S700 przesyłany jest bajtu stanu wewnętrznego analizatora. Zawartość tego bajtu decyduje o statusie danych, znajdujących się w przedmiotowej odpowiedzi z analizatora. Jeśli bajt ma zerową wartość, to zmienne otrzymują status poprawny. W przeciwnym razie otrzymują status błędu. Użycie opcji IGNORUJ_ZNAK_STANU o wartości TAK powoduje, że zmiennym nadawany jest status poprawny, niezależnie od zawartości znaku stanu.

Wartość domyślna - domyślnie opcja przyjmuje wartość NIE.

R Nazwa sekcji: S700
R Nazwa opcji: TIMEOUT_ODBIORU
R Wartość opcji: nr_stacji,liczba

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście pierwszego znaku odpowiedzi z określonego analizatora. Po upływie tego czasu uznaje się, że przedmiotowy analizator nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund.

Parametr:

nr_stacji - numer AK-ID analizatora,

liczba - czas w milisekundach (od 100 do 5000).

R Nazwa sekcji: S700
R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: nr_stacji,liczba

Znaczenie - opcja pozwala określić maksymalny czas (w milisekundach) pomiędzy kolejnymi znakami odpowiedzi z określonego analizatora. Po przekroczeniu tego czasu uznaje się, że przedmiotowy analizator nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas pomiędzy kolejnymi znakami odpowiedzi wynosi 50 milisekund.

Parametr:

nr_stacji - numer AK-ID analizatora,

liczba - czas w milisekundach (od 10 do 300).

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


S7_TCPIP - drajwer do wymiany danych ze sterownikami

Home > 1.97 S7_TCPIP - drajwer do wymiany danych ze sterownikami SIMATIC poprzez Ethernet

1.97 S7_TCPIP - drajwer do wymiany danych ze sterownikami SIMATIC poprzez Ethernet

Przeznaczenie drajwera

Drajwer S7_TCPIP jest wykorzystywany do wymiany danych ze sterownikami SIMATIC serii S7 poprzez łącze Ethernet przy wykorzystaniu standardowej karty sieciowej komputera.

Drajwer protokołu S7_TCPIP nie wymaga instalowania na komputerze systemu Asix oprogramowania SIMATIC NET firmy SIEMENS, jak również adaptacji programu w sterowniku dla potrzeb wymiany danych.

Parametryzacja drajwera S7_TCPIP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera S7_TCPIP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: S7_TCPIP

Zakładka S7_TCPIP / Parametry kanału:

Adresy:

Adres IP urządzenia (sterownika)

Lokalny adres TSAP

Zdalny adres TSAP

Adres IP - adres IP karty sieciowej lokalnego komputera, poprzez którą kanał będzie się łączył ze sterownikami;

Synchronizacja UTC - opcja pozwala na synchronizację czasu w danym kanale;

Zakładka S7_TCPIP / Parametry kanału - kontrola:

Zmienna kontrolna - nazwa zmiennej służącej do kontroli stanu RUN-STOP sterownika

Numer alarmu - numer alarmu generowany przy zmianie stanu RUN-STOP sterownika; domyślnie alarm nie jest generowany

Sygnał błędu - wystawienie statusu błędu dla wszystkich zmiennych w danym kanale w przypadku przejścia sterownika w stan

STOP; domyślnie ustawiany jest status błędu

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji wykorzystującego protokół S7_TCPIP:

Nazwa: CHAN1

Drajwer: S7_TCPIP

Adres IP serwera: 10.10.10.40

Lokalny adres TSAP: 10.02

Zdalny adres TSAP: 10.03

Synchronizacja czasu stacji Asixa z czasem sterownika

Wykorzystując drajwer S7_TCPIP można zsynchronizować czas stacji asixa z czasem sterownika. Synchronizacja czasu jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji Synchronizacja czasu dostępnej na zakładce Standardowe.

R Nazwa zmiennej służącej do synchronizacji

Znaczenie - Algorytm synchronizacji czasu polega na cyklicznym zapisie do S7 ramki zawierającej aktualny czas Asixa. Ramka jest wpisywana zgodnie z adresem zmiennej ZMIENNA oraz z częstością odświeżania przypisaną zmiennej ZMIENNA.

Wartość domyślna - domyślnie opcja jest wyłączona.

Parametry:

zmienna - nazwa zmiennej ASMENa należącej do kanału kanał, służącej do synchronizacji czasu.

Zmienna ZMIENNA musi być tablicą o rozmiarze minimum 10 bajtów (taki rozmiar ma ramka czasu).

Format ramki czasu (wszystkie dane w formacie BCD):

Bajt Zawartość Zakres

0 Rok 1990 do 2089 (tylko dwie najmłodsze cyfry)

1 Miesiąc 01 do 12

2 Dzień 1 do 31

3 Godzina 0 do 23

4 Minuta 0 do 59

5 Sekunda 0 do 59

6 milisekundy 00 do 99 dwie najstarsze tetrady milisekund

7 milisekundy 0 do 9 najmłodsza tetrada milisekund, zapisana na starszej tetradzie bajtu 7

7 dzień tygodnia 1 do 7 zapisany na młodszej tetradzie bajtu 7 (niedziela =1)

8 Znacznik nowego czasu 1

9 Nieistotny zawsze 0

PRZYKŁAD

Synchronizacja czasu w kanale KANAL1 odbywa się przy pomocy zmiennej X1. Ramka czasu jest zapisywana co 30 sekund do bloku danych DB100 od bajtu 0 do bajtu 9 włącznie:

deklaracja zmiennej X1 w bazie definicji zmiennych:

Nazwa: X1,

Adres: EB100.0,

Kanał: KANAL1,

Liczba elementów:10,

Okres próbkowania: 30,

Funkcja przeliczająca: NIC_BYTE

deklaracja kanału (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera S7_TCPIP > zakładka Standardowe):

Nazwa: KANAL1

Drajwer: S7_TCPIP

parametry kanału:

Adres IP serwera: 10.10.10.40

Lokalny adres TSAP: 10.02

Zdalny adres TSAP: 10.03

deklaracja synchronizacji czasu przy użyciu zmiennej X1 (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera S7_TCPIP > zakładka Standardowe):

R Nazwa zmiennej służącej do synchronizacji: X1

Sygnalizacja stanu STOP sterownika

W konfiguracji ze sterownikien S7, gdzie praca procesora komunikacyjnego jest niezależna od pracy procesora centralnego, aby w prawidłowy sposób zasygnalizować stan STOP sterownika należy:

- w sterowniku zadeklarować zmienną kontrolną o długości 1 BYTE, której wartość jest zmieniana w czasie pracy procesora;

- tą samą zmienną zadeklarować jako zmienną ASMENa;

- przy deklaracji kanału logicznego zadeklarować kontrolę pracy poprzez sprawdzanie zmian wartości zmiennej kontrolnej.

PRZYKŁAD

Jako zmienna kontrolna zadeklarowana jest dana o nazwie S7_CONN_0 w kanale SINEC1:

Deklaracja zmiennej w bazie definicji zmiennych:

Nazwa: S7_CONN_0

Opis: bajt kontrolny RUN PLC 1

Adres: EM0

Kanał: SINEC1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_BYTE

Deklaracja kanału:

Nazwa: SINEC1

Drajwer: S7_TCPIP

parametry kanału:

Adres IP serwera: 10.10.10.40

Lokalny adres TSAP: 10.02

Zdalny adres TSAP: 10.03

Zmienna kontrolna: S7_CONN_0

Numer alarmu: 1

Sygnał błędu: tak

Adresacja zmiennych procesowych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału transmisji wykorzystującego protokół S7_TCPIP są takie same, jak w przypadku kanału wykorzystującego protokół SAPIS7.

Składnia adresu symbolicznego dla zmiennych należących do kanału S7_TCPIP jest następująca:

typ_zmiennej[numer_db.]indeks_zmiennej

gdzie:

typ_zmiennej - łańcuch identyfikujący typ zmiennej w sterowniku;

numer_db - opcjonalny numer bloku danych; używany jedynie w przypadku zmiennych procesowych będących odwzorowaniem zawartości słów w blokach danych;

indeks_zmiennej - indeks zmiennej w ramach danego typu; w przypadku bloków danych jest to numer bajtu w bloku danych.

Dozwolone są następujące oznaczenia typów zmiennych procesowych:

EA - stany wyjść przekazywane w bajtach,

EE - stany wejść przekazywane w bajtach,

EM - stany znaczników (flag) przekazywane w bajtach,

EMD - obszar flag traktowany jako liczba 32-bitowa bez znaku,

EMR - obszar flag traktowany jako liczba typu float,

EMW - obszar flag traktowany jako liczba 16-bitowa bez znaku,

EZ - stany liczników przekazywane w słowach,

ET - stany zegarów przekazywane w słowach,

ED - wartości słów w blokach danych,

EL - wartości podwójnych słów w blokach danych,

ELI - 4 kolejne bajty z obszaru DB bez zmiany kolejności bajtów,

EG - wartości podwójnych słów w blokach danych, traktowane jako liczba w formacie zmiennoprzecinkowym KG,

EDI - słowa 16-bitowe w konwencji INTEL’a,

ER - zawartość bloków danych traktowana jako liczby zmiennoprzecinkowe,

EB - zawartość bloków danych traktowana jako bajty,

ELW - zawartość bloku danych traktowana jako liczba stałoprzecinkowa 64-bitowa (dostęp do typów LInt oraz ULInt, LWord),

ELR - zawartość bloku danych traktowana jako liczba zmiennoprzecinkowa 64-bitowa (dostęp do typu LReal),

ESTR - zawartość bloku danych traktowana jako tekst (ASCII) w formacie S7 (dostęp do typu String).

PRZYKŁADY

ED10.22 - słowo numer 22 w bloku danych numer 10

EZ100 - licznik numer 100

Parametry drajwera

Parametry drajwera deklarowane w module Dane bieżące na zakładce S7_TCPIP / Parametry drajwera kanału działającego według protokołu drajwera S7_TCPIP:

R Adres IP

Znaczenie - dla drajwera można określić adres IP komputera, przez który wszystkie kanały będą łączyć się ze sterownikami.

Wartość opcji - adres_IP

Wartość domyślna - domyślnie drajwer używa adresu IP dostarczonego przez Windows na etapie funkcji bind().

R Statystyka

Znaczenie - opcja pozwala na wyświetlanie co minutę informacji o liczbie przeprowadzonych seansów transmisji, średnim czasie transmisji oraz liczbie błędów transmisji; opcja została zaprojektowana jako wsparcie projektanta na etapie uruchomienia systemu.

Wartość domyślna - domyślnie nie wyświetla się statystyki transmisji.

R Timeout odbioru

Znaczenie - maksymalny czas oczekiwania na odpowiedź ze sterownika.

Wartość opcji - liczba - czas w ms

Wartość domyślna - domyślnie 1000 ms.

***

Parametry drajwera deklarowane w module Dane bieżące na zakładce S7_TCPIP / Parametry drajwera - logowanie kanału działającego według protokołu drajwera S7_TCPIP:

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera S7_TCPIP, dotyczące operacji realizowanych przez drajwer. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość opcji:

nazwa_pliku

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - liczba w MB

Wartość domyślna - domyślnie opcja przyjmuje wartość 10 MB.

R Log telegramów

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer S7_TCPIP w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji Plik logu.

Wartość opcji: - TAK/NIE

Wartość domyślna - domyślnie opcja jest wyłączona.

R Log treści telegramów

Znaczenie - zapisywanie treści telegramów do pliku logu.

Wartość opcji: - TAK/NIE

Wartość domyślna - domyślnie opcja jest wyłączona.

Parametry kanału

Parametry kanału deklarowane w module Dane bieżące na zakładkach S7_TCPIP / Parametry drajwera...:

R Zmienna kontrolna

Znaczenie - deklaracja zmiennej służącej do kontroli stanu RUN-STOP sterownika.

Wartość opcji - nazwa_zmiennej

Wartość domyślna - brak deklaracji.

R Numer alarmu

Znaczenie - deklaracja numeru alarmu generowanego przy zmianie stanu RUN-STOP sterownika.

Wartość opcji - liczba

Wartość domyślna - brak deklaracji.

R Sygnał błędu

Znaczenie - deklaracja wystawienia statusu błędu dla wszystkich zmiennych w danym kanale w przypadku przejścia sterownika na stan STOP.

Wartość opcji - wartość logiczna TAK/NIE

Wartość domyślna - brak deklaracji.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty S7_TCPIP, dotyczące operacji realizowanych w danym kanale. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość opcji:

nazwa_pliku

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - liczba w MB

Wartość domyślna - domyślnie opcja przyjmuje wartość 1 MB.

R Log telegramów

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer S7_TCPIP w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji Plik logu.

Wartość opcji: - TAK/NIE

Wartość domyślna - domyślnie opcja jest wyłączona.

R Log treści telegramów

Znaczenie - zapisywanie treści telegramów do pliku logu.

Wartość opcji: - TAK/NIE

Wartość domyślna - domyślnie opcja jest wyłączona.

R Redundancja H

Znaczenie - pozwala włączyć redundancję H dla danego kanału. Użycie redundancji jest możliwe jedynie dla sterowników serii S7-400.

Parametry:

lokalizacja statusu redundancji - numer słowa w obszarze markerów (flag) sterownika, w którym program sterownika umieszcza:

- w młodszym bajcie status redundancji,

- w starszym bajcie bieżącą wartość tzw. 'clock byte'.

Adresy:

Adres IP urządzenia (sterownika),

Lokalny adres TSAP,

Zdalny adres TSAP.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1 MB.

Obsługa redundancji H sterowników S7-400

Sposób parametryzacji:

1/ utworzenie kanału typu S7_tcpip dla połączenia Asix <--> Rack_0 sterownika S7-400 (kanał, w którym należ zdefiniować zmienne aplikacji),

2/ utworzenie kanału typu S7_tcpip dla połączenia Asix <--> Rack_1 sterownika S7-400 (wyłącznie dla realizacji redundancji H),

3/ dodanie opcji (w sekcji drajwera S7_tcpip):

R Nazwa sekcji: <S7_tcpip>

R Nazwa opcji: REDUNDANCJA_H

R Wartość opcji: kanal_Rack_0, kanal_Rack_1, nr_MB

Znaczenie - umożliwia skonfigurowanie redundancji H sterowników S7-400.

Wartość opcji:

k anal_Rack_0 - kanał dla połączenia Asix <--> Rack_0 sterownika S7-400

kanal_Rack_1 - kanał dla połączenia Asix <--> Rack_1 sterownika S7-400

nr_MB - numer bajtu w obszarze markerów (flag) sterownika, w którym program sterownika będzie umieszczać bieżący status redundancji H zbudowany na bazie wartości tzw. "status of an H_System". Drajwer zakłada następujące znaczenie bitów w bieżącym statusie redundancji H:

bit_0 H_R0_MSTR // 1 - CPU in rack 0 is master

bit_1 H_R1_MSTR // 1 - CPU in rack 1 is master

bit_2 H_R0_RUN // 1 - CPU in rack 0 is running

bit_3 H_R1_RUN // 1 - CPU in rack 1 is running

bit_4 H_INT_ERR // 1 - internal error

Drajwer zakłada, że w bajcie nr_MB+1 obszaru markerów program sterownika będzie umieszczać bieżącą wartość tzw. clock-byte'a, która będzie używana przez drajwer do detekcji stanu STOP sterownika.

Uwaga:

Zmienne procesowe redundantnego sterownika S7-400 należy definiować wyłącznie w kanale obsługującym połączenie Asix <--> Rack_0.

Parametry zaawansowane kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SAPIS7 - drajwer protokołu SAPIS7

Home > 1.98 SAPIS7 - drajwer protokołu SAPIS7

1.98 SAPIS7 - drajwer protokołu SAPIS7

Przeznaczenie drajwera

Drajwer SAPIS7 jest wykorzystywany do wymiany danych ze sterownikami SIMATIC serii S7 poprzez łącze MPI, poprzez łącze Ethernet lub poprzez procesor komunikacyjny magistrali PROFIBUS. W komputerze systemu Asix jest wykorzystywana karta procesora komunikacyjnego CP5611, CP5412(A2) lub CP5613 firmy SIEMENS. Wymiana danych w protokole SAPIS7 jest oparta na funkcjach S7.

Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu SAPIS7 nie wymaga adaptacji programu w sterowniku dla potrzeb wymiany danych z systemem Asix.

Parametryzacja drajwera SAPIS7 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SAPIS7 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe / Parametry kanału:
Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SAPIS7

Zakładka SAPIS7:

Identyfikacja:

Nazwa aplikacji (VFD)

Nazwa połączenia (connection name)

Zmienna kontrolna - nazwa zmiennej, służącej do kontroli stanu RUN-STOP sterownika

Numer alarmu - numer alarmu generowany przy zmianie stanu RUN-STOP sterownika; domyślnie nie generuje się alarmu

Sygnał błędu - wystawienie statusu błędu dla wszystkich zmiennych w danym kanale w przypadku przejścia sterownika w stan STOP; domyślnie ustawia się status błędu

Synchronizacja UTC - opcja pozwala na synchronizację czasu w danym kanale;

Nazwy VFD i connection name muszą być zgodne z parametrami zadeklarowanymi przy użyciu programu konfiguracyjnego COML S7, dostarczanego wraz z kartą procesora komunikacyjnego.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycie kanału transmisji wykorzystującego protokół SAPIS7:

Nazwa: CHAN1

Drajwer: SAPIS7

Nazwa urządzenia wirtualnego (VFD): VFD1

Nazwa połaczenia (connection name): S7_connection1

Synchronizacja czasu stacji Asixa z czasem sterownika

Wykorzystując drajwer SAPIS7 można zsynchronizować czas stacji Asixa z czasem sterownika. Synchronizacja czasu jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji Synchronizacja czasu dostępnej na zakładce Standardowe.

R Nazwa zmiennej służącej do synchronizacji

Znaczenie - Algorytm synchronizacji czasu polega na cyklicznym zapisie do S7 ramki zawierającej aktualny czas Asixa. Ramka jest wpisywana zgodnie z adresem zmiennej ZMIENNA oraz z częstością odświeżania przypisaną zmiennej ZMIENNA.

Wartość domyślna - domyślnie opcja jest wyłączona.

Parametry:

zmienna - nazwa zmiennej ASMENa należącej do kanału kanał, służącej do synchronizacji czasu.

Zmienna ZMIENNA musi być tablicą o rozmiarze minimum 10 bajtów (taki rozmiar ma ramka czasu).

Format ramki czasu (wszystkie dane w formacie BCD):

Bajt Zawartość Zakres

0 Rok 1990 do 2089 (tylko dwie najmłodsze cyfry)

1 Miesiąc 01 do 12

2 Dzień 1 do 31

3 Godzina 0 do 23

4 Minuta 0 do 59

5 Sekunda 0 do 59

6 milisekundy 00 do 99 dwie najstarsze tetrady milisekund

7 milisekundy 0 do 9 najmłodsza tetrada milisekund, zapisana na starszej tetradzie bajtu 7

7 dzień tygodnia 1 do 7 zapisany na młodszej tetradzie bajtu 7 (niedziela =1)

8 Znacznik nowego czasu 1

9 Nieistotny zawsze 0

PRZYKŁAD

Synchronizacja czasu w kanale KANAL1 odbywa się przy pomocy zmiennej X1. Ramka czasu jest zapisywana co 30 sekund do bloku danych DB100 od bajtu 0 do bajtu 9 włącznie:

deklaracja zmiennej X1 w bazie definicji zmiennych:

Nazwa: X1,

Adres: EB100.0,

Kanał: KANAL1,

Liczba elementów:10,

Okres próbkowania: 30,

Funkcja przeliczająca: NIC_BYTE

deklaracja kanału (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera SAPIS7 > zakładka Standardowe):

Nazwa: KANAL1

Drajwer: SAPIS7

parametry kanału:

Nazwa aplikcaji (VFD): VFD2

Nazwa połączenia (connection name): conn_4

deklaracja synchronizacji czasu przy użyciu zmiennej X1 (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera SAPIS7 > zakładka Standardowe):

R Nazwa zmiennej służącej do synchronizacji: X1

Sygnalizacja stanu STOP sterownika

W konfiguracji ze sterownikien S7, gdzie praca procesora komunikacyjnego jest niezależna od pracy procesora centralnego, aby w prawidłowy sposób zasygnalizawać stan STOP sterownika należy:

- w sterowniku zadeklarować zmienną kontrolną o długości 1 BYTE, której wartość jest zmieniana w czasie pracy procesora;

- tą samą zmienną zadeklarować jako zmienną ASMENa;

- przy deklaracji kanału logicznego zadeklarować kontrolę pracy poprzez sprawdzanie zmian wartości zmiennej kontrolnej.

PRZYKŁAD

Jako zmienna kontrolna zadeklarowana jest dana o nazwie S7_CONN_0 w kanale SINEC1:

Deklaracja zmiennej w bazie definicji zmiennych:

Nazwa: S7_CONN_0

Opis: bajt kontrolny RUN PLC 1

Adres: EM0

Kanał: SINEC1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_BYTE

Deklaracja kanału:

Nazwa: SINEC1

Drajwer: SAPIS7

parametry kanału:

Nazwa aplikcaji (VFD): VFD1

Nazwa połączenia (connection name): SMOLA_OP1

Zmienna kontrolna: S7_CONN_0

Numer alarmu: 1

Sygnał błędu: tak

Adresacja zmiennych procesowych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału transmisji wykorzystującego protokół SAPIS7 są takie same, jak w przypadku kanału wykorzystującego protokół AS512.

Zestaw typów zmiennych procesowych stosowanych w protokole SAPIS7 został rozszerzony w stosunku do zestawu oferowanego przez protokół AS512 o następujące elementy:

EDI - słowa 16-bitowe w konwencji INTELa,

ER - zawartość bloków danych traktowana jako liczby zmiennoprzecinkowe,

EB - zawartość bloków danych traktowana jako bajty,

ELI - 4 kolejne bajty z obszaru DB bez zmiany kolejności bajtów.

Drajwer SAPIS7 jest ładowany automatycznie jako DLL.

Parametry drajwera SAPIS7

Parametry drajwera deklarowane są w module Dane bieżące na zakładkach SAPIS7 / Parametry drajwera kanału działającego według protokołu drajwera SAPIS7.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty drajwera SAPIS7, dotyczące operacji realizowanych przez drajwer. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu tworzony jest w bieżącej kartotece.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Log telegramów

Znaczenie - deklaracja zapisu zawartości telegramów wysyłanych i odbieranych przez drajwer SAPIS7 w ramach odczytu/zapisu zmiennych procesowych do pliku logu, zadeklarowanego w opcji Plik logu.

Wartość domyślna - NIE.

R Maksymalna długość bufora

Znaczenie - pozwala określić maksymalną długość telegramów akceptowanych przez interfejs MPI; zależy od typu CPU sterowników S7 oraz od realizowanego przez nie programu.

Wartość domyślna - domyślna długość telegramu wynosi 220 bajtów.

Parametr:

liczba - długość telegramów w bajtach.

R Konsola

Znaczenie - opcja pozwala utworzyć okno konsoli, w którym na bieżąco są wyświetlane komunikaty drajwera SAPIS7, dotyczące operacji realizowanych przez drajwer.

Wartość domyślna - domyślnie okno konsoli nie jest tworzone.

R Statystyka

Znaczenie - opcja pozwala na wyświetlanie co minutę informacji o liczbie przeprowadzonych seansów transmisji, średnim czasie transmisji oraz liczbie błędów transmisji. Opcja została zaprojektowana jako wsparcie projektanta na etapie uruchomienia systemu.

Wartość domyślna - domyślnie nie wyświetla się statystyki transmisji.

R Liczba odczytów kontrolnych

Znaczenie - opcja określa minimalną liczbę, kolejno po sobie następujących odczytów zmiennej kontrolnej o niezmienionej wartości, powodujących zasygnalizowanie stanu STOP sterownika.

Wartość domyślna - domyślnie opcja przyjmuje wartość 3.

R Szeregowanie

Znaczenie - deklaracja obsługi transmisji z S7 poprzez przesyłanie pojedynczych (TAK) lub wielu zapytań (NIE).

Wartość domyślna - TAK.

R Bez zbiorczych zapytań

Znaczenie - pozwala zablokować tryb tworzenia zbiorczych zapytań i tym samym umożliwia dzialanie drajwera w trybie pojedynczych zapytań.

Wartość domyślna - NIE; w aktualnej wersji drajwera domyślnie używana jest funkcja s7_multiple_read_req (która pozwala na zbudowanie zbiorczego zapytania) w celu maksymalnego wykorzystania długości bufora telegramu przesyłanego pomiędzy PC i S7.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


S-BUS - drajwer protokołu S-BUS łącza szeregowego

Home > 1.99 S-BUS - drajwer protokołu S-BUS łącza szeregowego sterowników SAIA-Burgess Electronics

1.99 S-BUS - drajwer protokołu S-BUS łącza szeregowego sterowników SAIA-Burgess Electronics

Przeznaczenie drajwera

Protokół S-BUS jest wykorzystywany do wymiany danych pomiędzy sterownikami serii PCD firmy SAIA-Burgess Electronics oraz komputerem systemu Asix. Protokół S-BUS jest zgodny ze specyfikacją "SAIA S-Bus for the PCD family", Edition 26/739 E2-05.96, opracowaną przez SAIA-Burgess Electronics.

Dla celów komunikacji z system Asix można wykorzystać następujące interfejsy sterowników serii PCD:

- interfejs programatora PGU (RS-232C),

- dodatkowe interfejsy komunikacyjne, których liczba i rodzaj zależą od typu oraz konfiguracji sterownika. Interfejsy te umożliwiają transmisję danych w jednym z poniższych standardów:

RS-232C,

RS-422,

RS-485,

pętla prądowa 20 mA.

UWAGA Do wymiany danych należy używać kabla wykonanego wg specyfikacji PCD8.K111.

Rysunek. Kabel zgodny ze specyfikacją PCD8.K111.

Parametryzacja drajwera S-BUS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera S-BUS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: S-BUS

Zakładka S-BUS/Parametry kanału:

Parametry kanału:

Numer sterownika w sieci S-BUS - numer sterownika w sieci S-BUS,

Port - nazwa portu: COM1, COM2 itd.,

opcjonalne parametry:

Prędkość transmisji - prędkość transmisji w bodach.

Jeśli nie podano parametrów opcjonalnych, to domyślnie przyjmuje się:

- prędkość transmisji 9600 bodów.

Przykład

Deklaracja kanału logicznego o nazwie KANAL1, działającego wg protokołu S-BUS i wymieniającego dane ze sterownikiem o numerze 1 poprzez port COM2 z prędkością 9600 bodów jest następująca:

Nazwa: KANAL1

Drajwer: S-BUS

Numer sterownika w sieci S-BUS: 1

Port: COM2

Drajwer S-BUS jest ładowany automatycznie jako DLL.

Synchronizacja czasu pomiędzy systemem Asix i sterownikami SAIA

W drajwerze S-BUS został wbudowany mechanizm synchronizacji czasu pomiędzy systemem Asix i sterownikami SAIA. Synchronizacja czasu jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji Synchronizacja czasu dostępnej na zakładce Standardowe.

R Nazwa zmiennej służącej do synchronizacji

Znaczenie - synchronizacja czasu polega na cyklicznym zapisie do sterownika ramki zawierającej aktualny czas Asixa. Ramka jest zapisywana przy użyciu wbudowanej funkcji zapisu czasu protokołu S-BUS, zgodnie z częstością przypisaną zmiennej. Typem zmiennej musi być typ K (obsługa zegara), liczba elementów przypisana zmiennej musi pomieścić ramkę czasu, tzn. musi mieć rozmiar minimum 8 bajtów. Jako funkcji przeliczającej należy użyć NIC_BYTE.

Wartość domyślna - domyślnie opcja jest wyłączona.

Parametry:

zmienna - nazwa zmiennej ASMENa należącej do kanału kanał, służącej do synchronizacji czasu.

Przykład

Definicji synchronizacji czasu co 1 minutę dla kanału KANAL1 przy użyciu zmiennej SYNCHRO1:

deklaracja kanału (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera S-BUS > zakładka Standardowe):

Nazwa: KANAL1
Drajwer: S-BUS

Parametry kanału:

Id: 0,

port: COM1,

baud: 9600.

Deklaracja synchronizacji (Architekt > Dane bieżące > parametry zadeklarowanego kanału drajwera S-BUS > zakładka Standardowe):

R Nazwa zmiennej służącej do synchronizacji: SYNCHRO1

Definicja zmiennej SYNCHRO1 znajduje się w bazie definicji zmiennych i ma następującą postać:

Nazwa: SYNCHRO1

Opis: synchronizacja zegara

Adres: K

Kanał: KANAL1

Liczba elementów: 8

Okres próbkowania: 60

Funkcja przeliczająca: NIC_BYTE

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

C - wartości liczników (DWORD),

F - stany flag (WORD),

I - stany wejść (WORD),

K - aktualna data i czas w postaci tablicy 8-bajtowej (BYTE),

O - stany wyjść (WORD),

RI - wartości rejestrów traktowanych jako 32-bitowa liczba stałoprzecinkowa ze znakiem (LONG),

RF - wartości rejestrów traktowanych jako 32-bitowa liczba zmiennoprzecinkowa w formacie SAIA (FLOAT),

S - statusy (WORD),

T - wartości czasomierzy (DWORD).

Wartości zmiennych typu C, F, O, RI, RF, T mogą być odczytywane oraz

zapisywane.

Wartości zmiennych typu I, S mogą być wyłącznie odczytywane.

Wartości zmiennych typu K są wykorzystywane przez drajwer do synchronizacji czasu z PCD.

Struktura bufora zmiennej typu K jest następująca:

bajt 0 - numer tygodnia w roku,

bajt 1 - numer dnia tygodnia (poniedziałek - 1, niedziela - 7),

bajt 2 - dwie najmłodsze cyfry roku,

bajt 3 - miesiąc,

bajt 4 - dzień,

bajt 5 - godzina,

bajt 6 - minuta,

bajt 7 - sekunda.

Zakresy indeksów dla typu S jest ograniczony do przedziału 20 - 27.

Zmienna określająca stan połączenia ze sterownikiem

Zmienna określona jest adresem ON i przyjmuje wartość 1 w przypadku, gdy ostatnia transmisja zakończyła się poprawnie, oraz 0 gdy ostatnia transmisja zakończyła się niepowodzeniem. Zmienna ma typ WORD i należy użyć funkcji przeliczającej NIC.

PRZYKŁAD

Przykłady deklaracji zmiennych:

# wartości rejestrów traktowane jako FLOAT

JJ_10, RF1, KANAL1, 1, 1, NIC_FP

# wartości rejestrów traktowane jako LONG

JJ_11, RI11, KANAL1, 1, 1, NIC_LONG

# stany flag

JJ_14, F14, KANAL1, 1, 1, NIC

# stany wejść

JJ_14, I14, KANAL1, 1, 1, NIC

# stany wyjść

JJ_14, O14, KANAL1, 1, 1, NIC

# wartości liczników

JJ_21, C21, KANAL1, 1, 1, NIC_DW

# wartości statusów

JJ_40, S20, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące - odpowiednio na zakładkach o nazwie S-BUS / Parametry drajwera...

R Alarm w przypadku utraty i nawiązania połączenia

Znaczenie - drajwer protokołu S-BUS może generować alarm w przypadku utraty oraz nawiązania połączenia. W tym celu należy umieścić w pliku inicjalizacyjnym pozycję ALARM.

Wartość domyślna - domyślnie nie jest generowany alarm.

Parametry:

<nr sterownika>,<nr alarmu>

gdzie:

nr sterownika - numer sterownika w sieci S-BUS,

numer - numer alarmu jaki będzie generowany po utracie i nawiązaniu połączenia.

R Liczba powtórzeń
Znaczenie - opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie opcja przyjmuje wartość 0 (nie ma powtórzeń).

R Tryb

Znaczenie - dotychczas drajwer protokołu S-BUS obsługiwał tryb transmisji zwany PARITY; począwszy od wersji 1.02.000 drajwer obsługuje również tryby BREAK oraz DATA; ustawienia odpowiedniego trybu dokonuje się za pomocą parametru TRYB;

Wartość domyślna - pominięcie opcji TRYB spowoduje, że drajwer użyje trybu PARITY.

Parametry:

<nr sterownika>,{nazwa_trybu}

gdzie:

nr sterownika - numer sterownika w sieci S-BUS,

nazwa_trybu - jedno ze słów: PARITY | BREAK | DATA.

UWAGA Ustawiając odpowiedni tryb należy pamiętać o odpowiedniej parametryzacji sterownika, tak aby wykorzystywał on ten sam tryb.

R Tryb RTS

Znaczenie - opcja ustawia tryb kontroli RTS; stosowane dla konwerterów RS232/RS485.

Wartość domyślna - 1.

Parametry:

numer - jeden z poniższych numerów, który wskazuje tryb kontroli RTS wg API Win32:

0 - RTS_CONTROL_DISABLE

1 - RTS_CONTROL_ENABLE

2 - RTS_CONTROL_HANDSHAKE

3 - RTS_CONTROL_TOGGLE

R Timeout odpowiedzi

Znaczenie - opcja pozwala określić maksymalny czas oczekiwania (w milisekundach) na nadejście pierwszego znaku odpowiedzi z określonego sterownika. Po upływie tego czasu uznaje się, że przedmiotowy sterownik jest wyłączony i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas oczekiwania na pierwszy znak odpowiedzi wynosi 1000 milisekund.

Parametry:

<nr sterownika>,<timeout w ms>

gdzie:

nr sterownika - numer sterownika w sieci S-BUS,

timeout w ms - czas w milisekundach (od 100 do 5000).

R Timeout znaku

Znaczenie - opcja pozwala określić maksymalny czas (w milisekundach) pomiędzy kolejnymi znakami odpowiedzi z określonego sterownika. Po przekroczeniu tego czasu uznaje się, że przedmiotowy sterownik nie funkcjonuje poprawnie i seans transmisji kończony jest z błędem.

Wartość domyślna - domyślnie przyjmuje się, że maksymalny czas pomiędzy kolejnymi znakami odpowiedzi wynosi 50 milisekund.

Parametry:

<nr sterownika>,<timeout w ms>

gdzie:

id - numer sterownika w sieci S-BUS,

liczba - czas w milisekundach (od 10 do 300).

R Timeout adresu

Znaczenie - opcja pozwala określić odstęp czasu (w milisekundach) pomiędzy znakiem adresu i pierwszym znakiem danych w poleceniu wysyłanym do PCD. Odstęp czasu jest niezbędny ze względu na konieczność przestawienia się interfejsu PGU z trybu odbioru adresu na tryb odbioru danych.

Wartość domyślna - domyślnie przyjmuje się, że odstęp czasu pomiędzy znakiem adresu i pierwszym znakiem danych wynosi 25 milisekund.

Parametry:

liczba - czas w milisekundach.

R Plik logu

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera S-BUS oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartośc domyślna - domyślnie nie tworzy się pliku logu.

R Rozmiar pliku logu

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji ze sterownikiem. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się telegramów.

Synchronizacja czasu pomiędzy systemem Asix i sterownikami SAIA

W drajwerze S-BUS został wbudowany mechanizm synchronizacji czasu pomiędzy systemem Asix i sterownikami SAIA. Synchronizacja czasu jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji umieszczanych w sekcji ASMENa za pomocą zakładki Opcje wprowadzane bezpośrednio w module Pozostałe.

R Nazwa sekcji: ASMEN
R Nazwa opcji: SYNCHRONIZACJA_CZASU
R Wartość opcji: kanał, zmienna

Parametry:

kanał - nazwa kanału transmisji służącego do komunikacji z określonym sterownikiem SAIA,

zmienna - nazwa zmiennej ASMENa należącej do kanału kanał, służącej do synchronizacji czasu.

Synchronizacja czasu polega na cyklicznym zapisie do sterownika ramki zawierającej aktualny czas Asixa. Ramka jest zapisywana przy użyciu wbudowanej funkcji zapisu czasu protokołu S-BUS, zgodnie z częstością przypisaną zmiennej. Typem zmiennej musi być typ K (obsługa zegara), liczba elementów przypisana zmiennej musi pomieścić ramkę czasu, tzn. musi mieć rozmiar minimum 8 bajtów. Jako funkcji przeliczającej należy użyć NIC_BYTE.

Połączenie za pomocą modemu

Drajwer protokołu S-BUS może również wymieniać dane za pomocą połączenia modemowego, także z wykorzystaniem złącza PGU.

Obsługa połączeń za pomocą modemu jest możliwa jedynie przy wykorzystaniu trybu transmisji DATA.

Kanał drajwera s-bus jest klientem serwera AsComm o nazwie S-BUS:n,

gdzie n to numer portu szeregowego pobrany z definicji kanału ASMENa,

np. jeśli parametry kanału: 1,com2,...

to nazwą klienta będzie S-BUS:2.

Aby moduł S-BUS nawiązywał połączenia na łączach komutowanych za pośrednictwem programu AsComm, to należy wykorzystać opcję Klient serwera AsComm na zakładce Parametry drajwera - AsComm:

Jeśli modem jest przyłączony do innego portu niż COMn, to należy podać numer tego portu za pomocą parametru Port modemu lub określić nazwę modemu za pomocą parametru Nazwa modemu. Należy również podać numer telefoniczny oraz określić inne wymagane parametry. Jeśli drajwer S-BUS ma komunikować się z wieloma sterownikami za pomocą tego samego modemu, to należy zdefiniować odpowiednią ilość kanałów traktując parametr COMn jako nawę wirtualną kanału transmisji, oraz umieścić odpowiednią ilość pozycji, określając w nich odpowiedni numer telefoniczny.

PRZYKŁAD

Przykład parametryzacji za pomocą programu Architekt:

Deklaracja kanału1:

Nazwa: 'Kanal1’

Numer sterownika w sieci S-BUS: 1

Port: COM11

Prędkość transmisji: 9600

Deklaracja kanału2:

Nazwa: 'Kanal2’

Numer sterownika w sieci S-BUS: 1

Port: COM12

Prędkość transmisji: 9600

S-BUS:11

Linia komutowana: tak

Nazwa modemu: US Robotics

Nr telefonu: 11111111

S-BUS: 12

Linia komutowana: tak

Nazwa modemu: US Robotics

Nr telefonu: 22222222

W powyższym przykładzie Kanal1 będzie komunikował się ze sterownikiem znajdującym się pod numerem telefonicznym 11111111, a Kanal2 ze sterownikiem znajdującym się pod numerem telefonicznym 22222222. Zostanie wykorzystany modem US Robotics. Parametr Modem można zastąpić parametrem Port określającym numer portu szeregowego, do którego przyłączony jest modem.

Należy zwrócić uwagę, że powyższy opis wykorzystania drajwera S-BUS na łączach komutowanych nie obejmuje parametryzacji modemu. Parametryzacja modemu zależy od typu wykorzystywanego modemu.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSbusTcpip - drajwer protokołu S-Bus Ethernet

Home > 1.100 SbusTcpip - drajwer protokołu S-Bus Ethernet

1.100 SbusTcpip - drajwer protokołu S-Bus Ethernet

Przeznaczenie drajwera

Drajwer SbusTcpip służy do wymiany danych pomiędzy systemem Asix i rodziną sterowników PCD SAIA-Burgess przy wykorzystaniu protokołu Ethernet S-Bus.

Parametryzacja drajwera SbusTcpip realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SbusTcpip wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SbusTcpip

Zakładka SbusTcpip / Parametry kanału:

Identyfikacja:

Numer sterownika w sieci S-BUS

Numer portu

Adres IP sterownika

Okres synchronizacji - okres (w sekundach) synchronizacji czasu ze sterownikiem - opcja

Timeout - timeout w milisekundach pomiędzy wysłaniem zapytania i otrzymaniem odpowiedzi - opcja

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu CtSbusTcpip:

Nazwa: KANAL

Drajwer: CtSbusTcpip

Numer sterownika: 3

Numer portu: 5050

Adres IP sterownika: 10.10.10.225

Okres synchronizacji: 20

Deklaracja zmiennych

Deklaracja zmiennych jest identyczna, jak w przypadku drajwera S-BUS.

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ><indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu.

Oznaczenia typów zmiennych (w nawiasie podano typ surowej wartości zmiennej):

C - wartości liczników (DWORD),

F - stany flag (WORD),

I - stany wejść (WORD),

K - aktualna data i czas w postaci tablicy 8-bajtowej (BYTE),

O - stany wyjść (WORD),

RI - wartości rejestrów traktowanych jako 32-bitowa liczba stałoprzecinkowa ze znakiem (LONG),

RF - wartości rejestrów traktowanych jako 32-bitowa liczba zmiennoprzecinkowa w formacie SAIA (FLOAT),

S - statusy (WORD),

T - wartości czasomierzy (DWORD).

Wartości zmiennych typu C, F, O, RI, RF, T mogą być odczytywane oraz zapisywane.

Wartości zmiennych typu I, S mogą być wyłącznie odczytywane.

Zakresy indeksów dla typu S jest ograniczony do przedziału 20 - 27.

PRZYKŁADY

Przykłady deklaracji zmiennych:

# wartości rejestrów traktowane jako FLOAT

JJ_10, , RF1, KANAL1, 1, 1, NIC_FP

# wartości rejestrów traktowane jako LONG

JJ_11, , RI11, KANAL1, 1, 1, NIC_LONG

# stany flag

JJ_14, , F14, KANAL1, 1, 1, NIC

# stany wejść

JJ_14, , I14, KANAL1, 1, 1, NIC

# stany wyjść

JJ_14, , O14, KANAL1, 1, 1, NIC

# wartości liczników

JJ_21, , C21, KANAL1, 1, 1, NIC_DW

# wartości statusów

JJ_40, , S20, KANAL1, 1, 1, NIC

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące na zakładce SbusTcpip / Parametry drajwera kanału działającego według protokołu drajwera SbusTcpip.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

Nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

R Bez statusu PCD

Znaczenie - opcja pozwala sterować modyfikowaniem status zmiennych zależnie od bieżącego statusu sterownika (PCD own status). Jeśli opcja jest ustawiona na TAK, to status zmiennych nie zależy od bieżącej wartości statusu sterownika. Jeśli opcja jest ustawiona na NIE, to status zmiennej zależy od bieżącej wartości statusu sterownika - jeśli jest ona różna od 0x52 (stan RUN), to status zmiennych jest ustawiany na OPC_QUALITY_ COMM_FAILURE.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

R Adres IP komputera

Znaczenie - opcja pozwala określić adres IP komputera, przez który kanały będą się łączyły z urządzeniami.

Wartość domyślna - brak deklaracji.

PRZYKŁAD

Przykładowe parametry drajwera:

Plik logu: d:\tmp\ctsbustcpip\sbus.log

Rozmiar pliku logu: 20

Log telegramów: włączona opcja

Testowanie komunikacji

Zakładka SbusTcpip / Parametry drajwera - UniDriver pozwala określić parametry dotyczące szczegółowych informacji o błędach oraz informacji diagnostycznych. Informacje te zapisywane są w pliku o nazwie UniDriver.<bieżąca data>.log.

Parametry umieszczone na zakładkach Parametry drajwera - UniDriver obowiązują wszystkie kanały, które mają w deklaracji drajwera taką zakładkę. Parametry ustawione na zakładce Parametry drajwera - UniDriver w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera - UniDriver w definicji pozostałych kanałów.

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Okno diagnostyczne

Znaczenie - jeżeli opcja ma wartość Tak, to wyświetlane jest okno diagnostyczne i wszystkie informacje wpisywane do logu pojawiają się też w tym oknie.

Wartość domyślna - opcja wyłączona.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

Parametry kanału

Parametry kanału deklarowane są w module Dane bieżące na zakładce SbusTcpip / Parametry kanału 2 i Parametry kanału - redundancja.

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy w kanale.

Wartość domyślna - domyślnie plik logu deklarowany w parametrach drajwera.

Parametr:

Nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie plik logu deklarowany w parametrach drajwera.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych w kanale.

Wartość domyślna - domyślnie plik logu deklarowany w parametrach drajwera.

R Adres IP komputera

Znaczenie - opcja pozwala określić adres IP komputera, przez który kanał będzie się łączył z urządzeniem.

Wartość domyślna - domyślnie plik logu deklarowany w parametrach drajwera.

R Redundancja PCD3

Znaczenie - opcja pozwala włączyć redundancję PCD3.M6860 dla danego kanału. Użycie redundancji jest możliwe jedynie dla sterowników serii M6860.

Wartość domyślna - Domyślnie redundancja PCD3.M6860 nie jest używana.

Parametry:

Numer flagi zawierającej status redundancji

Numer sterownika w sieci S-BUS

Numer portu TCP sterownika

Adres IP sterownika

Parametry kanału zaawansowane

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SINECH1 - drajwer protokołu sieci Ethernet dla

Home > 1.101 SINECH1 - drajwer protokołu sieci Ethernet dla sterowników SIMATIC S5

1.101 SINECH1 - drajwer protokołu sieci Ethernet dla sterowników SIMATIC S5

Przeznaczenie drajwera

Drajwer SINECH1 jest wykorzystywany do wymiany danych poprzez sieć Ethernet ze sterownikami SIMATIC serii S5 wyposażonymi w procesor komunikacyjny CP 1430. Komputer systemu Asix musi być wyposażony w kartę procesora komunikacyjnego CP1413 firmy SIEMENS.

Współpraca systemu Asix ze sterownikiem przy wykorzystaniu protokołu SINECH1 wymaga opracowania programu w sterowniku obsługującego procesor komunikacyjny CP 1430.

Parametryzacja drajwera SINECH1 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SINECH1 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SINECH1

Zakładka SINECH1:

Parametry kanału:

fTsapPC, fTsapPLC, rTsapPC, rTsapPLC, MAC

gdzie:

fTsapPC - nazwa TSAPa używanego dla operacji odczytu (FETCH) w komputerze Asix,

fTsapPLC - nazwa TSAPa używanego dla operacji odczytu (FETCH) w sterowniku,

rTsapPC - nazwa TSAPa używanego dla operacji zapisu (RECEIVE) w komputerze Asix,

rTsapPLC - nazwa TSAPa używanego dla operacji zapisu (RECEIVE) w sterowniku,

MAC - adres sieciowy MAC przypisany sterownikowi.

Uwaga Nazwy TSAPów są dowolnymi, 8-znakowymi łańcuchami.

UWAGA Nazwy TSAPów zadeklarowane w systemie Asix muszą mieć swoje odpowiedniki wśród TSAPów zadeklarowanych przy pomocy COM 1430 po stronie sterownika.

UWAGA Odczyt i zapis z/do sterownika odbywają się w ramach oddzielnych połączeń.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji wykorzystującego protokół SINECH1:

Nazwa: CHAN1

Drajwer: SINECH1

Parametry kanału: LocFetch,TestFetc,LocRecev,TestRece,08:00:06:01:00:22

Kanał logiczny o nazwie logicznej CHAN1 ma zdefiniowane następujące parametry:

protokół SINECH1,

LocFetch - nazwa TSAPa używanego dla operacji odczytu (FETCH) w systemie Asix,

TestFetc - nazwa TSAPa używanego dla operacji odczytu (FETCH) w sterowniku,

LocRecev - nazwa TSAPa używanego dla operacji zapisu (RECEIVE) w systemie Asix,

TestRece - nazwa TSAPa używanego dla operacji zapisu (RECEIVE) w sterowniku,

08:00:06:01:00:22- MAC adres przypisany sterownikowi.

Adresacja zmiennych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału transmisji wykorzystującego protokół SINECH1 są takie same, jak w przypadku kanału wykorzystującego protokół AS512.

Drajwer SINECH1 jest ładowany automatycznie jako DLL.

Parametry drajwera

Parametry drajwera SINECH1 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: SINECH1
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera SINECH1 oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: SINECH1
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych w ramach komunikacji ze sterownikiem. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: SINECH1
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

R Nazwa sekcji: SINECH1
R Nazwa opcji: TYLKO_ODCZYT
R Wartość opcji: TAK/NIE

Znaczenie - opcja do użycia na okoliczność komunikacji z serwerem dostarczającym tylko kanał do odczytu.

Wartość domyślna - NIE.

R Nazwa sekcji: SINECH1
R Nazwa opcji: SUMA_KONTROLNA
R Wartość opcji: TAK/NIE

Znaczenie - opcja do użycia na okoliczność komunikacji z serwerem, który nie używa sumy kontrolnej.

Wartość domyślna - NIE.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SINECL2 - drajwer prot. PROFIBUS warstwy SEND/RECEIVE

Home > 1.102 SINECL2 - drajwer prot. PROFIBUS warstwy SEND/RECEIVE (FDL) dla SIMATIC S5

1.102 SINECL2 - drajwer prot. PROFIBUS warstwy SEND/RECEIVE (FDL) dla SIMATIC S5

Przeznaczenie drajwera

Drajwer SINECL2 stosowany jest do wymiany danych ze sterownikami SIMATIC serii S5 firmy SIEMENS wyposażonymi w kartę procesora komunikacyjnego CP5430, przy wykorzystaniu sieci lokalnej SINEC L2 w oparciu o protokół FDL (poziom 2-gi standardu PROFIBUS). Komputer systemu Asix musi być wyposażony w kartę procesora komunikacyjnego CP5412 (A2) lub CP5613 oraz oprogramowanie systemowe służące do obsługi tego procesora.

Oprogramowanie sterownika dedykowanego do współpracy z systemem Asix musi spełniać podane poniżej wymagania:

  • program w sterowniku musi zawierać wywołania bloków funkcyjnych realizujących odbiór i nadawanie telegramów poprzez procesor komunikacyjny CP5430, według protokołu FDL,

  • numer węzła, nadany procesorowi komunikacyjnemu CP5430 musi być unikalny w ramach sieci lokalnej SINEC L2,

  • parametry pracy procesora komunikacyjnego CP5430 oraz procesora komunikacyjnego CP5412(A2) lub CP5613 muszą być zgodne.

W każdym kanale transmisji, ustanowionym pomiędzy dowolnym komputerem systemu Asix oraz dowolnym procesorem komunikacyjnym CP5430 można wykorzystywać 10 podkanałów, zwielokrotniając w ten sposób liczbę przesyłanych informacji.

Parametryzacja drajwera SINECL2 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SINECL2 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SINECL2

Zakładka SINECL2:

Parametry kanału:

węzeł_PC,węzeł_PLC[,podkanał]

gdzie:

węzeł_PC - numer węzła przypisany komputerowi aplikacji,

węzeł_PLC - numer węzła przypisany procesorowi CP5430 w sterowniku, z którym ma być realizowane połączenie w danym kanale transmisji,

podkanał - numery podkanałów wykorzystywane w danym kanale transmisji. Brak tego parametru oznacza, że w danym kanale transmisji będą wykorzystywane wszystkie podkanały (od 1 do 10 włącznie).

PRZYKŁAD

Poniżej podane są przykładowe deklaracje użycie kanałów transmisji pracujących według protokołu SINEC L2:

Nazwa: CHAN2

Drajwer: SINECL2

Parametry kanału: 5,1,1,2,3,4

Nazwa: CHAN3

Drajwer: SINECL2

Parametry kanału: 5,2

Adresacja zmiennych

Zasady tworzenia adresów symbolicznych zmiennych należących do kanału typu SINECL2 są takie same jak dla kanałów typu AS512.

Drajwer protokołu SINECL2 wymaga zainstalowania karty procesora komunikacyjnego o symbolu CP5412(A2) lub CP5613 oraz drajwera tej karty, dostarczanego w pakiecie DP‑5412/Windows NT przez firmę SIEMENS.

Drajwer protokołu SINECL2 jest ładowany automatycznie jako DLL.

Parametry drajwera

Parametry drajwera SINECL2 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: SINECL2
R Nazwa opcji: LOG_ALARMOW
R Wartość opcji: TAK|NIE

Znaczenie - deklaracja zapisywania komunikatów o nadejściu telegramów alarmowych do pliku logu.

Wartość domyślna - NIE.

R Nazwa sekcji: SINECL2
R Nazwa opcji: LOG_BLEDOW
R Wartość opcji: TAK|NIE

Znaczenie - deklaracja zapisywania komunikatów o błędach transmisji do pliku logu.

Wartość domyślna - NIE.

R Nazwa sekcji: SINECL2
R Nazwa opcji: MAX_LICZBA_WEZLOW
R Wartość opcji: liczba

Znaczenie - deklaracja maksymalnej liczby węzłów w sieci SINECL2.

Wartość domyślna - 16.

R Nazwa sekcji: SINECL2
R Nazwa opcji: SAP
R Wartość opcji: id, PC_SAP, PLC_SAP

Znaczenie - deklaracja mapowania SAP’ów po stronie PC i PLC, tworzących kanał logiczny o identyfikatorze id.

Wartość domyślna - domyślnie używa się 10 par SAP’ów mapowanych następująco (id, PC_SAP, PLC_SAP):

1, 35, 45

2, 36, 46

3, 37, 47

4, 38, 48

5, 39, 49

6, 40, 50

7, 41, 51

8, 42, 52

9, 43, 53

10, 44, 54

R Nazwa sekcji: SINECL2
R Nazwa opcji: STATYSTYKA
R Wartość opcji: TAK\NIE

Znaczenie - zapisywanie co 1 minutę do pliku logu statystyki transmisji.

Zdefiniowanie - ręczne.

R Nazwa sekcji: SINECL2
R Nazwa opcji: TIMEOUT
R Wartość opcji: liczba

Znaczenie - timeout oczekiwania na odpowiedź ze sterownika wyrażona w tikach o czasie trwania 400 ms.

Wartość domyślna - 3.

R Nazwa sekcji: SINECL2
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa

Znaczenie - deklaracja nazwy pliku logu z komunikatami diagnostycznymi drajwera SINECL2.

Wartość domyślna - plik logu nie jest tworzony.

R Nazwa sekcji: SINECL2
R Nazwa opcji: TYP_CP
R Wartość opcji: liczba

Znaczenie - deklaracja typu karty procesora komunikacyjnego używanego w komputerze systemu Asix. Dozwolone są dwa typy:

1/ CP5613 identyfikowana liczbą 5613,

2/ CP4512 (A2) identyfikowana liczbą 5412;

Wartość domyślna - 5412 (karta CP5412 (A2)).

R Nazwa sekcji: SINECL2
R Nazwa opcji: ZWLOKA
R Wartość opcji: liczba

Znaczenie - deklaracja timeout’u (w milisekundach) po wystąpieniu błędu wysłania telegramu SDA.

Wartość domyślna - 0.

R Nazwa sekcji: SINECL2
R Nazwa opcji: SAP_TELEGRAMOW_AKTYWNYCH
R Wartość opcji: liczba

Znaczenie - deklaracja numeru SAP’a służącego do obsługi telegramów aktywnych.

Wartość domyślna - 0.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSi400 - drajwer protokołu centrali alarmowej Sintony Si

Home > 1.103 Si400 - drajwer protokołu centrali alarmowej Sintony Si 400 firmy SIEMENS

1.103 Si400 - drajwer protokołu centrali alarmowej Sintony Si 400 firmy SIEMENS

Przeznaczenie drajwera

Drajwer Si400 jest przeznaczony do wymiany danych pomiędzy systemem Asix i centralą alarmową Sintony SI 400 firmy SIEMENS. Komunikacja odbywa się przy pomocy łączy szeregowych w standardzie RS-232.

Dodatkowe zalecenia:

Dla zapewnienia poprawnego działania systemu alarmowego, wymagane jest, aby do centrali Sintony podłączony był tylko jeden komputer z wizualizacją (pomimo, iż centrala dysponuje trzema złaczami, w trakcie działania systemu można wykorzystać tylko jendo z nich). Najoptymalniejszym rozwiązaniem jest podłączenie komputera do złącza J7 z wykorzystaniem zalecanego przez firmę SIEMENS kabla SAQ11.

Parametryzacja drajwera Si400 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Si400 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: Si400

Zakładka Si400:

Parametry kanału:

Port=numer_portu [;Predkosc=baud] [;Timeout=liczba_ms] [;OffsetAlarmu=offset]USERID=user_id

gdzie:

Port - numer portu szeregowego (dla COM1 podaje się 1, dla COM2 podaje się 2 itd.);

Predkosc - prędkość transmisji w baudach. Domyślnie przyjmuje się 9600 Bd;

Timeout - timeout oczekiwania na odpowiedź ze sterownika (w milisekundach). Domyślnie przyjmuje się 1000 milisekund;

OffsetAlarmu - offset dodawany do numeru każdego alarmu przekazanego z centrali SINTONY SI 400;

USERID - identyfikator użytkownika, przesyłany do centrali SINTONY SI 400 w ramkach sterujących. Poprawne wartości mieszczą się w przedziale 0-500.

Domyślnie przyjmuje się następujące parametry transmisji:

  1. liczba bitów znaku - 8,

  2. bez kontroli parzystości (NONE),

  3. liczba bitów stopu - 1.

PRZYKŁAD

Przykład deklaracji kanału korzystającego z drajwera CtSi400 na porcie COM2 z timeout’em odbioru 2000 ms oraz offsetem 1500, dodawanym do numeru każdego alarmu, jest następująca:

Nazwa: PLC1

Drajwer: CTSI400

Parametry kanału: Port=2; TimeoutOdbioru=2000; OffsetAlarmu=1500

Adresacja zmiennych

Składnia adresu symbolicznego dla wszystkich zmiennych służących do monitorowania stanu centrali jest następująca:

<typ><indeks>

a dla zmiennych służących do sterowania:

<typ>

lub

<typ><indeks>

lub

<typ><p_indeks>.<r_indeks>

gdzie:

typ - typ zmiennej,

indeks - indeks w ramach typu,

p_indeks - numer partycji (0-15),

r_indeks - numer room'u w ramach partycji (0-7).

Typy zmiennych służące do monitorowania

Wyróżnia się wymienione poniżej typy zmiennych służących do monitorowania. Driver dopuszcza wykonywanie na nich operacji odczytu, natomiast wszelkie operacje zapisu kończą się błędem OPC_E_BADRIGHTS. W poniższej liście bit 0 oznacza najmłodszy bit:

  • IS<indeks> - input status

PState - bity 7-6

Lstate - bity 5-3

Reserved - bity 2-0

  • IP<indeks> - input parameters:

PSL - bity 15-14

V.Address - bity 13-8

Type - bity 7-4,

SubType, - bity 3-1

  • IA<indeks> - input address

room nr - bity 12-9

partition nr - bity 4-0

  • IN<indeks> - input name

  • OS<indeks> - output status

State - bit 7

OutInTest - bit6

BlinkBit - bit 5

NbrPulse - bit 4

Reserved - bity 3-0

  • OP<indeks> - output parameters

Ltype - bity 7-0

  • OA<indeks> - output address

room nr - bity 12-9

partition nr - bity 4-0

  • ON<indeks> - output name

  • RP<indeks> - room parameters

Rset - bity 15-8 (room1 jest na bicie 15, room2 na bicie 14, itd.)

Rarm - bity 7-0 (room1 jest na bicie 7, room2 na bicie 6, itd.)

  • RS<indeks> - room status

room1 - bity 15-14

room2 - bity 13-12

itd.

  • PS<indeks> - partition status

TAMP - bit 15

PA - bit 14

Fire - bit 13

AM - bit 12

Chime - bit 11

Mess - bit 10

Reserved - bity 9-8

Pstate - bity 7-6

PFA - bit 5

PPA - bit 4

PFS - bit 3

PPS - bit 2

PUS - bit 1

BA - bit 0

  • SS<indeks> - system status

ParamCh - bit 15

Evt Overflow - bit 14

Avzone - bity 13 - 8

Mains - bit 7

Batt - bit 6

Fuse - bit 5

Line - bit 4

CMS1 - bit 3

CMS2 - bit 2

InComm - bit 1

Evt queue - bit 0

Typy zmiennych służące do sterowania

Wyróżnia się wymienione poniżej typy zmiennych służących do sterowania. Driver dopuszcza wykonywanie na nich operacji zapisu, natomiast wszelkie operacje odczytu kończą się błędem OPC_E_BADRIGHTS.

  • cIB<indeks> - input bypass (indeks = 0..0xFFFF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla wejścia o numerze indeks.

  • cIS<indeks> - input in soak test (indeks = 0..0xFFFF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla wejścia o numerze indeks.

  • cOT<indeks> - set output in test mode (indeks = 0..0xFFFF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla wyjścia o numerze indeks.

  • cTO<indeks> - toggle output (indeks = 0..0xFFFF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla wyjścia o numerze indeks.

  • cPP<p_indeks> - partition part-set (p_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla partycji o numerze p_indeks.

  • cPF<p_indeks> - partition full-set (p_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla partycji o numerze p_indeks.

  • cPU<p_indeks> - partition unset (p_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla partycji o numerze p_indeks.

  • cCA<p_indeks> - clear alarm memory in partition (p_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla partycji o numerze p_indeks.

  • cRF<p_indeks>.<r_indeks> - room full-set (p_indeks = 0..0xF, r_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla roomu o numerze r_indeks z partycji o numerze p_indeks.

  • cRU<p_indeks>.<r_indeks> - room unset (p_indeks = 0..0xF, r_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla roomu o numerze r_indeks z partycji o numerze p_indeks.

  • cSR<p_indeks> - partition reset sounders/bells (p_indeks = 0..0xF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla partycji o numerze p_indeks.

  • cIP<indeks> - input activation pulse (indeks = 0..0xFFFF)

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy dla wejścia o numerze indeks.

  • cIL<indeks> - input activation latch (indeks = 0..0xFFFF)

Zapisywana wartość musi konwertować się do typu double. Jeśli po konwersji otrzymana zostanie wartość 0, to dla wejścia o numerze indeks zostanie wykonana komenda z parametrem commutaion level = 0, w przeciwnym wypadku parametr będzie miał wartość 1.

  • cAV - new current A/Video zone

Zapisana wartość musi być liczbą całkowitą z przedziału <0; 32>. Wykonanie zapisanie wartości 0 włączy opcję autoswitch.

  • cTC - transmission to CMS

Zapisana wartość musi mieć wartość 1 lub 2 i wskazuje odpowiednio CMS1 lub CMS2.

  • cER - reset the pending event buffer

Zapisanie jakiejkolwiek wartości do zmiennej spowoduje wykonanie komendy.

Zmienne typu IN oraz ON są 16-elemntowymi tablicami typu BYTE. Pozostałe zmienne są typu WORD.

Wszyskie zmienne służące do sterowania są typu WORD.

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_00, input status 1, IS1, PLC1, 1, 1, NIC

JJ_01, output status 10, OS10, PLC1, 1, 1, NIC

JJ_02, nazwa input 2, IN2, PLC1, 16, 1, NIC_BYTE

JJ_03, system status, SS1, PLC1, 1, 1, NIC

cIB3, input 3 bypass, cIB3, PLC1, 1, 1, NIC

cRU1.2, part 1 room 2 unset, cRU1.2, PLC1, 1, 1, NIC

cAV, current A/V zone, cAV, PLC1, 1, 1, NIC

Znacznik czasu

Wartościom zmiennych odczytanych z centrali SINTONY SI 400 nadawany jest stempel czasu lokalnego PC.

Parametryzacja drajwera

Parametry drajwera Si400 deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CTSI400
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTSI400
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametry:

liczba - rozmiar pliku logu w MB.

R Nazwa sekcji: CTSI400
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK/NIE

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych i odbieranych ze sterownika. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa sekcji: CTSI400
R Nazwa opcji: ZWLOKA_PO_OTWARCIU_SESJI
R Wartość opcji: liczba

Znaczenie - pozwala określić timeout pomiędzy nawiązaniem sesji a wysłaniem pierwszego zapytania o dane w ramach tej sesji.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na 100.

Parametry:

liczba - wartość timeout’u w milisekundach.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSNG

Home > 1.104 SNG - drajwer do wymiany danych z urządzeniami SNG

1.104 SNG - drajwer do wymiany danych z urządzeniami SNG

Przeznaczenie drajwera

Drajwer protokołu SNG służy do wymiany danych pomiędzy systemem Asix i urządzeniami instalacji SNG firmy Synergia Tech z Warszawy, poprzez łącze Ethernet.

Parametryzacja drajwera SNG realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer SNG wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: SNG

Zakładka SNG:

Parametry kanału:

SerwerIP=adresIP; [Port=liczba;] SNG=adres; NrAlarmu=liczba; [Timeout=liczba]

gdzie:

SerwerIP - adres IP CommServera instalacji SNG_Synergia

Port - numer portu CommServera instalacji SNG_Synergia. Domyślnie 8888,

SNG - Adres Fizyczny Źródła systemu SNG przypisany kanałowi transmisji,

Timeout - max. czas (w sekundach) pomiędzy dwiema kolejnymi ramkami wysłanymi

przez CommServer (CommServer wysyła ramkę 'heart-beat', jeśli nie ma

ramek generowanych przez urządzenia SNG_Synergia). Domyślnie 15 sek,

NrAlarmu - numer alarmu zgłaszanego do systemu alarmów Asixa w przypadku braku

komunikacji z SNG_Synergia.

PRZYKŁAD

Przykład deklaracji kanałów transmisji do komunikacji z serwerem CommServer o adresie IP 87.205.117.187 i domyślnym porcie 8888. Adres SNG przydzielony kanałowi to 2.1.5:

SerwerIP=87.205.117.187; SNG=2.1.5; NrAlarmu=100

Deklaracja zmiennych

Ogólna składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ_danych>:<adres_grupowy>:<adres_zrodla>:<adres_zwrotny>

gdzie:

typ_danych - liczba z zakresu 1 - 6 określająca typ danej SNG. Należy go podać

wyłącznie wtedy, gdy dana zmienna jest wykorzystywana do sterowania.

adres_grupowy - adres grupowy urządzenia w systemie SNG_Synergia w formacie a/b/c.

Należy go podać wyłącznie wtedy, gdy dana zmienna jest wykorzystywana

do sterowania.

adres_źródła - adres fizyczny źródła w formacie a.b.c , z którego przychodzą komunikaty

'feedback' zasilające wartość bieżącą danej zmiennej. Należy go podać

wyłącznie wtedy, gdy dana zmienne jest zasilana danymi z komunikatów

typu 'feedback',

adres_zwrotny - adres grupowy źródła w formacie a/b/c, z którego przychodzą komunikaty

'feedback' zasilające wartość bieżącą danej zmiennej. Należy go podać

wyłącznie wtedy, gdy dana zmienne jest zasilana danymi z komunikatów

typu 'feedback'.

W zależności od zastosowania zmiennej, jej adres symboliczny może mieć postać:

a/ zmienna wyłącznie do sterowania:

<typ_danych>:<adres_grupowy>

b/ zmienna wyłącznie do monitorowania:

<adres_zrodla>:<adres_zwrotny>

c/ zmienna do sterowania i monitorowania:

<typ_danych>:<adres_grupowy>:<adres_zrodla>:<adres_zwrotny>

Przykłady deklaracji zmiennych:

# JJ_01 służy wyłącznie do sterowania urządzeniem typu On/Off o adresie grupowym 1/2/3

JJ_01, , 1:1/2/3, K1, 1, 1, NIC

# JJ_02 wyłącznie obsługuje 'feedback' z urządzenia o adresie fizycznym źródła 1.2.3 i adresie

# grupowym zwrotnym 1/0/23 (typ danych przychodzi w ramce 'feedback' i nie jest typem Czas

# ani Data)

JJ_02, , 1.2.3:1/0/23, K1, 1, 1, NIC

# JJ_03 służy do sterowania urządzeniem typu Wartość o adresie grupowym 1/2/3 i otrzymuje

# 'feedback' o typie innym niż Czas lub Data z urządzenia o adresie fizycznym źródła 1.5.6

# i adresie grupowym 1/0/44

JJ_03, , 6:.1/2/3:1.5.6:1/0/44, K1, 1, 1, NIC

# JJ_04 wyłącznie obsługuje 'feedback' typu Czas z urządzenia o adresie fizycznym źródła 1.2.3

# i adresie grupowym zwrotnym 1/0/23

JJ_04, , 1.2.3:1/0/23, K1, 10, 1, NIC_TEXT

# JJ_05 wyłącznie obsługuje 'feedback' typu Data z urządzenia o adresie fizycznym źródła 1.2.3

# i adresie grupowym zwrotnym 1/0/23

JJ_05, , 1.2.3:1/0/23, K1, 12, 1, NIC_TEXT

Parametry drajwera

Parametry drajwera SNG deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTSNG.

R Nazwa sekcji: CTSNG

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku_logu

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTSNG

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTSNG

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: Pozycja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa parametryzacja drajwera

R Nazwa sekcji: CTSNG

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\CtSNG\mvi.log

R Nazwa sekcji: CTSNG

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 20

R Nazwa sekcji: CTSNG

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

Parametry kanału

Parametry umieszczane w sekcji kanału (w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio).

W sekcji o nazwie <nazwa_kanału> można umieścić pozycje deklarujące:

• tworzenie pliku logu,

• rozmiar pliku logu,

• log telegramów.

Znaczenie pozycji jest podobne do znaczenia pozycji drajwera, przy czym wszystkie informacje gromadzone w plikach zadeklarowanych w sekcji kanału odnoszą się do pojedynczego kanału drajwera.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SNMP

Home > 1.105 SNMP - drajwer do odczytu i zapisu wartości obiektów protokołu SNMPv1 i SNMPv2c

1.105 SNMP - drajwer do odczytu i zapisu wartości obiektów protokołu SNMPv1 i SNMPv2c

Przeznaczenie drajwera

Drajwer umożliwia odczyt i zapis wartości obiektów protokołu SNMPv1 i SNMPv2c - zarządzania różnymi elementami sieci telekomunikacyjnych, takimi jak routery, przełączniki, komputery, czy centrale telefoniczne. Drajwer realizuje swoje funkcje za pomocą SNMP Management API.

Parametryzacja drajwera SNMP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer SNMP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: SNMP

Zakładka SNMP / Parametry kanału:

Parametry kanału:

Adres zdalnego urządzenia - adres IP zdalnego urządzenia.

Nazwa wspólnoty - nazwa wspólnoty zdefiniowana na zdalnym komputerze; wartość domyślna: public.

Timeout transmisji - timeout transmisji w milisekundach (domyślnie 1000 ms).

Plik logu - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera; domyślna wartość: snmp.log.

Liczba powtórzeń - ilość powtórzeń transmisji (domyślnie 3).

Deklaracja zmiennych

Deklaracja zmiennej ma postać ciągu identyfikatorów numerycznych oddzielonych kropkami np. ”.1.3.6.1.2.1.4.1.0”. Ostatnia cyfra to zero dla wartości skalarnych lub index w tablicy wartości (liczony od 1). Indeks może mieć też bardziej złożoną strukturę w zależności od obiektu. Zamiast identyfikatorów numerycznych występujących w danym adresie, można używać identyfikatorów symbolicznych o są one ile zdefiniowane na lokalnym komputerze (w pliku mib.bin). Na przykład: ”.iso.org.dod.internet.mgmt.mib-2.system.sysDescr.0”. Jeśli adres rozpoczyna się od kropki to jest to adres absolutny. W przeciwnym wypadku jest to adres względem ”iso.org.dod.internet.mgmt.mib-2”. Tzn. można podać tylko ”system.sysDescr.0” aby otrzymać opis systemu.

Typ zmiennej musi być zgodny z typem wartości obiektu.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSNPX - drajwer protokołu SNPX sterowników GE Fanuc

Home > 1.106 SNPX - drajwer protokołu SNPX sterowników GE Fanuc

1.106 SNPX - drajwer protokołu SNPX sterowników GE Fanuc

Przeznaczenie drajwera

Drajwer protokołu SNPX (Series Ninety Protocol) służy do wymiany danych pomiędzy systemem Asix i jednostkami centralnymi sterowników serii 90-30 oraz modułami CMM i PCM serii 90 firmy GE_FANUC. Komunikacja realizowana przy pomocy łączy szeregowych.

Drajwer pozwala na dostęp do następujących typów zmiennych sterownika:

  • Discrete Inputs (%I),

  • Discrete Outputs (%O),

  • Discrete Internals (%M),

  • Analog Inputs (%AI),

  • Analog Outputs (%AO),

  • Registers (%R),

  • Genius Global Data (%G).

Drajwer nie obsługuje następujących typów zmiennych sterownika (systemowe, tymczasowe):

  • %SA Discrete,

  • %SB Discrete,

  • %SC Discrete,

  • %S Discrete,

  • Discrete Temporary (%T).

Parametryzacja drajwera CtSNPX realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SNPX wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SNPX

Zakładka SNPX:

Parametry kanału:

Port=liczba; [Predkosc=liczba;] [BitParzystosci=nazwa_kontroli_parzystosci;]

[SynchrCzasuX=adres[:okres];] [T4=timeout_break;] [T2=timeout_odpowiedzi;] [TBroadCast=timeout_broadcast]

gdzie:

Port - numer portu szeregowego COM,

Predkosc - prędkość transmisji między komputerem a urządzeniem; dopuszczalne są następujące prędkości: 300, 600,1200,2400, 4800, 9600, 19200 Bd; domyślna wartość wynosi 19200 Bd;

BitParzystosci - określa sposób kontroli parzystości ramki; możliwe wartości parametru to: NONE, ODD, EVEN; domyślna wartość parametru to ODD (kontrola_nieparzystosci);

T4 - timeout (w milisekundach) pomiędzy wysłaniem BREAK’a i wysłaniem BROADCAST ATTACH; domyślna wartość wynosi 50 milisekund;

TBroadCast - timeout pomiędzy wysłaniem BROADCAST ATTACH i wysłaniem pierwszego żądania do sterownika; domyślna wartość wynosi 2000 milisekund;

T2 - timeout (w milisekundach) na otrzymanie pierwszego znaku odpowiedzi; domyślna wartość wynosi 2000 milisekund;

SynchrCzasuX - cykliczny (co okres sekund) zapis ramki daty i czasu pod określony adres w sterowniku; można zadeklarować 99 opcji synchronizacji czasu o zakresie nazw od SynchrCzasu1 do SynchrCzasu99; jeśli nie podano parametru okres, to domyślnie przyjmuje się synchronizację co 60 sekund. Struktura ramki daty i czasu ma format zgodny z wymaganiami procedury zapisu daty i czasu SVCREQ 7:

struct dateTime

{

byte Year;

byte Month;

byte Day;

byte Hour;

byte Minute;

byte Second;

byte DayOfWeek;

byte NotUsed; // zawsze 0

word wSynchr; // ustawiane na 1 przy zapisie nowej ramki daty i czasu

};

UWAGA Parametry podane w deklaracji kanału muszą być zgodne z parametrami ustawionymi dla portów komunikacyjnych sterowników obsługiwanych przez ten kanał.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału, w którym są obsługiwane dwa sterowniki o identyfikatorach A123 i B456:

1/ dla sterownika o identyfikatorze A123 czas jest synchronizowany poprzez zapis do obszaru rejestrów zaczynającego się od R10 (co 25 sekund),

2/ dla sterownika o identyfikatorze B456 czas jest synchronizowany poprzez zapis do obszaru rejestrów zaczynającego się od R20 (z domyślną częstością).

Komunikacja ze sterownikami odbywa się poprzez COM2 przy użyciu standardowych parametrów transmisji, tzn. 19200 Bd, kontrola nieparzystości i 1 bit stopu oraz standardowych timeoutów protokołu SNPX.

Nazwa: KANAL

Drajwer: SNPX

Parametry kanału: Port=2; SynchrCzasu1=A123.R10:25; SynchrCzasu2=B456.R20

Deklaracja zmiennych

Drajwer udostępnia następujące typy zmiennych:

I - Discrete Input (%I) w trybie BIT,

IB - Discrete Input (%I) w trybie BYTE,

IW - Discrete Input (%I) w trybie WORD,

Q - Discrete Output (%I) w trybie BIT,

QB - Discrete Output (%I) w trybie BYTE,

QW - Discrete Output (%I) w trybie WORD,

M - Discrete Internal (%I) w trybie BIT,

MB - Discrete Internal (%I) w trybie BYTE,

MW - Discrete Internal (%I) w trybie WORD,

G - Genius Global Data (%G) w trybie BIT,

GB - Genius Global Data (%G) w trybie BYTE,

GW - Genius Global Data (%G) w trybie WORD,

AI - Analog Input (%AI) w trybie WORD,

AO - Analog Output (%AO) w trybie WORD,

R - Register (%R) traktowany jako WORD,

RL - dwa kolejne Registers (%R) traktowane jako DWORD,

RF - dwa kolejne Registers (%R) traktowane jako FLOAT,

Adres zmiennej ma składnię:

[<CpuID>.]<Typ><Index>

gdzie:

CpuID - identyfikator CPU,

Typ - nazwa typu zmiennej,

Index - adres zmiennej w ramach typu zmiennej Typ.

UWAGA CpuID może być pominięty w adresie zmiennej tylko wtedy, gdy na przedmiotowym łączu szeregowym jest podpięty wyłącznie jeden sterownik. W takim przypadku polecenia wysyłane do sterownika zawierają identyfikator ustawiony na NULL (faktyczny identyfikator ustawiony w sterowniku nie ma w tym przypadku znaczenia).

UWAGA Dla zmiennych dyskretnych Index wskazuje numer bitu, od którego rozpoczyna się zakres bitów przypisany zmiennej. W zależności od trybu udostępniania zmiennych dyskretnych Index może przyjmować następujące wartości (na wzór adresacji używanej w VersaPro):
a/ dla trybu BIT - dowolna wartość począwszy od 1;
b/ dla trybu BYTE - wartości 1, 9, 17, i.t.d (numery pierwszego bitu kolejnych bajtów);
c/ dla trybu WORD - wartości 1, 17, 33, i.t.d (numery pierwszego bitu kolejnych słów).

PRZYKŁADY

Przykłady deklaracji zmiennych (wartości zmiennych pochodzą ze sterowników o identyfikatorach A123 i B456):

JJ_01, Rejestr R3, A123.R3, KANAL, 1, 1, NIC

JJ_02, Analog Input 1, A123.AI1, KANAL, 1, 1, NIC

JJ_03, Discrete Input 3, B456.I3, KANAL, 1, 1, NIC

JJ_04, Discrete Output Byte 9 , A123.QB9, KANAL, 1, 1, NIC_BYTE

JJ_05, Genius Global Word 17 , A123.GW17, KANAL, 1, 1, NIC

JJ_06, Discrete Internal Word 33, B456.MW33, KANAL, 1, 1, NIC

Parametry drajwera

Parametry drajwera SNPX deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: CtSNPX
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtSNPX
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji PLK_LOGU.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB

R Nazwa sekcji: CtSNPX
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowe parametry drajwera:

Nazwa sekcji: CtSNPX

Nazwa opcji: PLIK_LOGU

Wartość opcji: d:\tmp\ctLG\LG.log

Nazwa sekcji: CtSNPX

Nazwa opcji: ROZMIAR_PLIKU_LOGU

Wartość opcji: 3

Nazwa sekcji: CtSNPX

Nazwa opcji: LOG_TELEGRAMOW

Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSp100H

Home > 1.107 Sp100H - drajwer sterowników SP-100H centrali deszczowej Aqua Center Industrial 100 H 14-60

1.107 Sp100H - drajwer sterowników SP-100H centrali deszczowej Aqua Center Industrial 100 H 14-60 firmy MARLEy Polska Sp. z o.o.

Przeznaczenie drajwera

Drajwer protokołu Sp100H służy do wymiany danych pomiędzy systemem Asix i sterownikiem SP-100H centrali deszczowej Aqua Center Industrial 100 H 14-60 produkowanej przez firmę MARLEy Polska Sp. z o.o. Transmisja jest realizowana łączami szeregowymi przy pomocy standardowych portów szeregowych komputera w standardzie RS-232.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Sp100H wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Sp100H

Zakładka Sp100H:

Składnia deklaracji kanału transmisji korzystającego z drajwera Sp100H jest następująca:

Port=liczba; liczbaDanych=liczba [;nrAlarmu=liczba] [;czasWaznosci=liczba]

gdzie:

Port - numer portu szeregowego,

liczbaDanych - liczba danych przesyłanych w każdej ramce przesyłanej przez centralą;

domyślna wartość 39;

czasWaznosci - max okres czasu (w minutach) pomiędzy kolejnymi ramkami wysyłanymi

przez centralę; domyślna wartość 1;

nrAlarmu - numer alarmu Asixa generowany w przypadku utraty połączenia z centralą.

Parametry transmisji są stałe i wynoszą:

prędkość transmisji 2400 Bd,

8 bitów znaku,

bez kontroli parzystości,

1 bit stopu.

PRZYKŁAD

Przykład deklaracji kanału transmisji:

Port:1

czasWaznosci:2

nrAlarmu:100

Deklaracja zmiennych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

V<indeks>

gdzie:

indeks - indeks danej w ramce przesłanej z centrali; Pierwszej danej w ramce jest przypisany indeks 0.

Wartości danych przesyłanych z centrali są typu FLOAT oraz INT. Drajwer konwertuje typy danych przesłanych z centrali na typy żądane przez aplikację systemu Asix (o ile jest to możliwe).

Przykłady deklaracji zmiennych:

Nazwa: JJ_1

Opis: level of cisterne in %

Adres: V0

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: JJ_2

Opis: pressure sensor in bar

Adres: V1

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: JJ_3

Opis: mode of using rainwater

Adres: V2

Kanał: KANAL

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_INT

Parametryzacja drajwera

Parametry drajwera Sp100H deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTSP100H.

R Nazwa sekcji: CTSP100H

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CtM200

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: opcja pozwala określić rozmiar pliku logu.

Wartość opcji:

liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CtM200

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

PRZYKŁAD

Przykładowa sekcja drajwera:

R Nazwa sekcji: CTSP100H

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: d:\tmp\CtSp100H\aci.log

R Nazwa sekcji: CtM200

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: 20

R Nazwa sekcji: CtM200

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SPA - drajwer protokołu magistrali SPA zabezpieczeń

Home > 1.108 SPA - drajwer protokołu magistrali SPA zabezpieczeń

1.108 SPA - drajwer protokołu magistrali SPA zabezpieczeń rozdzielni firmy ABB

Przeznaczenie drajwera

Protokół SPA jest wykorzystywany do wymiany danych pomiędzy urządzeniami firmy ABB dołączonymi do magistrali SPA oraz komputerem systemu Asix. Komunikacja odbywa się przy wykorzystaniu łączy szeregowych w standardzie RS232C lub RS485.

Parametryzacja drajwera SPA realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SPA wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SPA

Zakładka SPA:

Parametry kanału:

numer, typ, port, baud, AlTxtOff, AlValOff, hasło

gdzie:

numer - numer nadany urządzeniu zdalnemu,

typ - typ urządzenia zdalnego:

1 - SPAJ 141C,

2 - SPAM 150C,

3 - SACO 16D3,

port - nazwa portu szeregowego,

baud - prędkość transmisji: 9600 lub 4800 - musi być zgodna z ustawieniami w urządzeniu zdalnym,

AlTxtOff - liczba dodawana do numeru zdarzenia tekstowego odczytanego z urządzenia zdalnego w celu zbudowania unikalnego numeru alarmu przekazywanego do systemu Asix,

AlValOff - liczba dodawana do numeru zdarzenia z wartością odczytanego z urządzenia zdalnego w celu zbudowania unikalnego numeru alarmu przekazywanego do systemu Asix,

hasło - hasło zezwalające na wykonywanie zapisów do urządzenia zdalnego - musi być zgodna z ustawieniami w urządzeniu zdalnym.

Przykład

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu SPA:

Nazwa: KANAL1

Drajwer: SPA

Parametry kanału:

4, 2, COM1, 9600, 100, 200, 123

Drajwer SPA jest ładowany automatycznie jako DLL.

Adresacja zmiennych procesowych

Składnia adresu symbolicznego zmiennej procesowej jest następująca:

<typ_zmiennej><kanał>.<indeks>

gdzie:

typ_zmiennej - typ zmiennej procesowej,

kanał - numer kanału w urządzeniu, z którego pozyskiwana jest zmienna procesowa,

indeks - indeks zmiennej procesowej w ramach typu.

Typy zmiennych procesowych:

I - wartości danych kategorii I,

O - wartości danych kategorii O,

S - wartości danych kategorii S,

V - wartości danych kategorii V.

Zakres używanych kanałów, typy dostarczanych zmiennych procesowych, zakres indeksów w ramach każdego z typów oraz znaczenie poszczególnych elementów w ramach typu jest specyficzne dla każdego typu urządzenia zdalnego.

Szczegółowa specyfikacja jest zawarta w dokumentacji urządzenia zdalnego.

UWAGA Surowe wartości wszystkich zmiennych procesowych są typu FLOAT.

PRZYKŁAD

Przykład deklaracji zmiennych dla urządzenia SPAM 150 C (zgodnie z dokumentacją wszystkie zmienne umieszczone są w kanale numer 0):

X1, prąd w fazie L1, I0.1, KANAL1, 1, 1, NIC_FP

X2, pobudzenie stopnia Io>, O0.8, KANAL1, 1, 1, NIC_FP

X3, współczynnik p dla członu termicznego, S0.3, KANAL1, 1, 1, NIC_FP

X4, zmierzony prąd I podczas pobudzenia,V0.21, KANAL1, 1, 1, NIC_FP

X5, zmierzony prąd I podczas zadziałania,V0.41, KANAL1, 1, 1, NIC_FP

Generowanie alarmów

Numery zdarzeń, generowanych przez urządzenia zdalne, mają ten sam zakres zmienności. Aby móc jednoznacznie określić, z którego urządzenia pochodzi przedmiotowe zdarzenie, drajwer SPA dodaje do numeru zdarzenia liczbę, specyfikowaną w deklaracji kanału jako AllTxtOff (dla zdarzeń tekstowych) lub AllValOff (dla zdarzeń z wartością). Tak powstała liczba jest przekazywana do systemu Asix jako numer alarmu.

Oprócz numeru alarmu drajwer SPA przekazuje numer urządzenia zdalnego, z którego pochodzi określone zdarzenie. Numer urządzenia może być wykorzystany w komunikacie związanym z alarmem poprzez podanie łańcucha formatującego (%3.0f) w treści komunikatu alarmowego.

Do przekazywania alarmów drajwer SPA domyślnie wykorzystuje funkcję AsixAddAlarmGlobalMili(). Opcja ALARMY_GLOBALNE pozwala na zmianę ustawień domyślnych i przekazywania alarmów funkcją AsixAddAlarmMili().

Zaimplementowane w drajwerze SPA typy urządzeń zdalnych SPA generują jedynie zdarzenia tekstowe.

Parametry drajwera

Parametry drajwera SPA deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: SPA
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie - opcja pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera SPA oraz informacje o zawartości telegramów odebranych i wysłanych przez drajwer SPA. Jeśli opcja PLIK_LOGU nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: SPA
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych i odbieranych z magistrali SPA w ramach odczytu zmiennych procesowych. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się telegramów.

R Nazwa sekcji: SPA
R Nazwa opcji: ZWLOKA_TRANSMISJI
R Wartość opcji: liczba

Znaczenie - ozycja pozwala określić odstęp czasu (jako wielokrotność 10 msek) pomiędzy kolejnymi operacjami na magistrali SPA.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1 (10 msek).

R Nazwa sekcji: SPA
R Nazwa opcji: LICZBA_POWTORZEN
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić liczbę powtórzeń w przypadku wystąpienia błędu transmisji.

Wartość domyślna - domyślnie opcja przyjmuje wartość 0 (nie ma powtórzeń).

R Nazwa sekcji: SPA
R Nazwa opcji: AKTUALIZACJA_DANYCH
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić okres czasu (w sekundach), po upływie którego należy odświeżyć wartości zmiennych procesowych trzymanych w buforach wewnętrznych drajwera.

Wartość domyślna - domyślnie opcja przyjmuje wartość 5.

R Nazwa sekcji: SPA
R Nazwa opcji: AKTUALIZACJA_CZASU
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić okres czasu (w sekundach), po upływie którego należy wysłać aktualny czas do urządzeń zdalnych.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1.

R Nazwa sekcji: SPA
R Nazwa opcji: AKTUALIZACJA_DATY
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić okres czasu (w sekundach), po upływie którego należy wysłać aktualną datę do urządzeń zdalnych.

Wartość domyślna - domyślnie opcja przyjmuje wartość 30.

R Nazwa sekcji: SPA
R Nazwa opcji: AKTUALIZACJA_ALARMOW
R Wartość opcji: liczba

Znaczenie - opcja pozwala określić okres czasu (w sekundach), który oddziela kolejne cykle odczytu buforów alarmów wszystkich urządzeń zdalnych obsługiwanych przez poszczególne łącza szeregowe.

Wartość domyślna - domyślnie opcja przyjmuje wartość 1.

Zdefiniowanie - ręczne.

R Nazwa sekcji: SPA
R Nazwa opcji: SUMA_KONTROLNA
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala sterować budowaniem sumy kontrolnej w telegramach wysyłanych do magistrali SPA. Jeśli opcja SUMA_KONTROLNA ma wartość nie, to zamiast sumy kontrolnej w telegramie wstawiane są dwa znaki ’X’.

Wartość domyślna - domyślnie suma kontrolna jest budowana.

R Nazwa sekcji: SPA
R Nazwa opcji: WYKLUCZANIE_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie - opcja pozwala wykluczać z listy obsługiwanych telegramów takie telegramy, które zostały skwitowane przez adresowane urządzenie kodem ’N’ (nielegalny zakres zmiennych w telegramie lub nieobsługiwany typ zmiennych). Wykluczanie telegramów pozwala na efektywne wykorzystanie łącza.

Wartość domyślna - domyślnie wyklucza się telegramy.

R Nazwa sekcji: SPA
R Nazwa opcji: ALARMY_GLOBALNE
R Wartość opcji: TAK|NIE

Znaczenie - opcja steruje sposobem przekazywania alarmów odczytanych z urządzeń zdalnych do systemu alarmów systemu Asix.

Wartość domyślna - domyślnie alarmy przekazywane są do systemu alarmów jako alarmy globalne (przekazywane do systemu alarmów funkcją AsixAddAlarmGlobalMili()). Ustawienie wartości opcji ALARMY_GLOBALNE na NIE powoduje, że alarmy są przekazywane do systemu alarmów funkcją AsixAddAlarmMili().

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtSRIO

Home > 1.109 SRIO - drajwer protokołu sterownika SRIO 500M produkcji firmy ABB

1.109 Srio - drajwer protokołu sterownika SRIO 500M produkcji firmy ABB

Przeznaczenie drajwera

Drajwer Srio służy do wymiany danych pomiędzy systemem Asix i sterownikiem SRIO 500M produkcji firmy ABB. Komunikacja jest realizowana przy pomocy łączy szeregowych w standardzie RS232. Warstwa transportu danych jest zrealizowana w oparciu o protokół ANSI X3.28 w trybie full-duplex z sumą kontrolną BCC.

Sterownik SRIO pełni rolę gateway’a pomiędzy siecią zabezpieczeń SPA i komputerem. Sterownik komunikuje się z siecią zabezpieczeń przy pomocy protokołu SPA, a z komputerem przy pomocy protokołu ANSI X3.28.

Zmienne procesowe pochodzące z sieci zabezpieczeń SPA są mapowane w SRIO na tzw. zmienne ANSI. Proces definiowania zmiennych ANSI odbywa się na etapie konfigurowania SRIO i jest wykonywany przy pomocy narzędzi programowych producenta SRIO.

Zmienne ANSI posiadają swój unikalny numer, należący do jednej z 4-ech grup oznaczonych symbolami: DI, DO, AI oraz AO. Sposób obsługi zmiennej na interfejsie z komputerem zależy od grupy, do której należy zmienna. Zmienne DI i DO są traktowane jako liczby 16-bitowe bez znaku, natomiast zmienne AI i AO są traktowane jako liczby 32-bitowe ze znakiem.

Drajwer CtSrio realizuje operacje odczytu i zapisu zmiennych ANSI na żądanie komputera oraz obsługuje spontaniczne komunikaty wysyłane przez sterownik SRIO związane z:

- każdą zmianą wartości zmiennych należących do grupy DI lub DO,

- zmianą wartości zmiennych z grupy AI i AO o wartość większą od wartości 'delta’,

- wystąpieniem zdarzenia lub alarmu w zabezpieczeniu.

Dodatkowo drajwer CtSrio pozwala na:

- konfigurowanie zmiennych ANSI w SRIO,

- konfigurowanie maski zdarzeń urządzeń SPA,

- bezpośrednią komunikację z zabezpieczeniami przy pomocy natywnego protokołu SPA (tzw. SPA messages),

- zapis konfiguracji do urządzeń SPA,

- zapis konfiguracji SRIO do EEPROM,

- podtrzymanie informacji o zdarzeniach w zmiennych wewnętrznych drajwera,

- kasowanie informacji o zdarzeniach w zmiennych wewnętrznych drajwera,

- powiązanie zdarzeń z wybranymi sterowaniami,

- odczyt plików zakłóceń.

Parametryzacja drajwera CtSrio realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego wykorzystującego drajwer Srio wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Srio

Zakładka Srio:

Parametry kanału:

port=liczba; nrPc=liczba; nrSrio=liczba; enq=liczba; timeout=liczba; nrAlarmu=liczba; defAnsi=nazwaPliku; defAlarmow=nazwaPliku [;defSynop=nazwaPliku] [;KartZaklocen=sciezkaKartoteki]

gdzie:

port - numer portu szeregowego COM,

nrPc - parametr ’host num’ ustawiony funkcją ansi_setup terminala SRIO,

nrSrio - parametr ’own num’ ustawiony funkcją ansi_setup terminala SRIO,

enq - max liczba ENQ wysyłanych w przypadku braku DLE ACK/NAK,

timeout - timeout (w milisekundach) oczekiwania na pierwszy znak odpowiedzi na zapytanie,

nrAlarmu - numer alarmu ASIXA zgłaszany w przypadku braku komunikacji,

defAnsi - nazwa (ścieżka) pliku z definicjami punktów ANSI,

defAlarmow - nazwa (ścieżka) pliku z definicjami zdarzeń,

defSynop - nazwa (ścieżka) pliku z definicjami powiązań pomiędzy sterowaniami, spontanicznymi telegramami i zmiennymi stanu migotania,

kartZaklocen - kartoteka, w której będą zapisywane pliki zakłóceń odczytane z rejestratorów zakłóceń. Domyślnie pliki zakłóceń są zapisywane w podkartotece Disturbances (tworzonej przez drajwer w kartotece Asixa).

Parametry transmisji są stałe i wynoszą:

- prędkość 9600 bps,

- 8 bitów danych,

- kontrola parzystości parzysta,

- 1 bit stopu.

Typy zmiennych

Drajwer udostępnia następujące typy zmiennych:

A - zmienna ANSI,

F - zmienna wewnętrzna przechowująca informację o wystąpieniu spontanicznego zdarzenia lub zmiany punktu ANSI, przypisanego do tej zmiennej w pliku definicji zdarzeń.

S - status urządzenia w sieci zabezpieczeń,

Z - zmienna wewnętrzna służąca do podtrzymania informacji o wystąpieniu zdarzenia, przypisanego do tej zmiennej w pliku definicji powiązań pomiędzy sterowaniami, spontanicznymi telegramami i zmiennymi stanu migotania.

Przyjmuje się, że adres zmiennej będzie miał składnię:

<Typ>[.<Nr>[.<Index>] ]

gdzie:

Typ - nazwa typu zmiennej (A, F, S lub Z);

Nr - numer ANSI (dla typu A) lub numer urządzenia w sieci zabezpieczeń (dla typu S). Zmienne wirtualne typu F oraz Z nie wymagają podania parametru Nr;

Index - numer bitu dla zmiennych typu A odnoszących się do DI lub DO.

Zakłada się, że zmienne typu A o adresach 0 - 1999 będą pozwalały na dostęp do rzeczywistych zmiennych ANSI w SRIO:

0 - 499 zmienne typu DI

500 - 999 zmienne typu DO

1000 - 1499 zmienne typu AI

1500 - 1999 zmienne typu AO

Zmienne typu A o adresach 16000 - 16010 będą używane do realizacji funkcji związanych z konfiguracją SRIO oraz bezpośrednią komunikacją z zabezpieczeniami przy pomocy natywnego protokołu SPA (SPA messages):

16000 - nazwa pliku z konfiguracją zmiennych ANSI

16001 - żądanie zapisu pliku z konfiguracją zmiennych ANSI do SRIO

16002 - nazwa pliku z konfiguracją masek zdarzeń urządzeń SPA,

16003 - żądanie zapisu pliku z konfiguracją masek zdarzeń urządzeń SPA,

16004 - nazwa pliku z konfiguracją urządzenia SPA,

16005 - żądanie zapisu pliku z konfiguracją urządzenia do SPA,

16006 - numer aktualnie przetwarzanego elementu polecenia,

16007 - zapis konfiguracji SRIO do EEPROM,

16008 - treść ’SPA message’ wysyłanego do SRIO,

16009 - treść odpowiedzi na ’SPA message’,

16010 - liczba bajtów, o które pytamy przy odczycie z obszaru ’SPA bus reply’

(domyślnie 64 bajty, min. 16 bajtów, max 255 bajtów)

Zmienne typu A o adresach od 16010 do 16019 są używane do realizacji funkcji związanych z obsługą rejestratora zakłóceń:

16011 - adres urządzenia w sieci SPA, którego będą dotyczyły operacje dotyczące rejestratora zakłóceń,

16012 - zapis dowolnej wartości do tej zmiennej powoduje zainicjowanie odczytu kartoteki rejestratora zakłóceń z urządzenia, którego adres (w sieci SPA) wskazuje zmienna o adresie 16011,

16013 - liczba zakłóceń zapisanych w kartotece rejestratora zakłóceń,

16014 - rezerwa

16015 - zapis do zmiennej powoduje zainicjowanie odczytu zakłócenia o numerze równym wartości sterującej,

16016 - zapis do zmiennej dowolnej wartości powoduje usunięcie najstarszego zakłócenia z rejestratora zakłóceń,

16017 - całkowita liczba linii w aktualnie odczytywanym pliku zakłóceń (ustawiany w chwili rozpoczęcia odczytu pliku zakłóceń),

16018 - licznik linii odczytanych z aktualnie odczytywanego pliku zakłóceń (aktualizowany w trakcie realizacji polecenia odczytu pliku zakłóceń),

16019 - współczynnik kompresji stosowany przy odczycie pliku zakłóceń (liczba całkowita w przedziale 0 - 5). Domyślną wartością jest 0 (bez kompresji)

16500 - zapis dowolnej wartości do tej zmiennej powoduje przesłanie aktualnego czasu PC do SRIO. Domyślnie wysyła się czas lokalny

16501 - zapis wartości 1 do zmiennej powoduje forsowanie odświeżania wszystkich zmiennych ANSI. Zapis wartości 0 do zmiennej powoduje

odświeżenie tych zmiennych ANSI, których definicje zostały zmienione/dodane w efekcie wgrania konfiguracji do SRIO.

Zmienne typu A o adresach od 16020 do 16039 są używane do prezentacji nazw plików zakłóceń rejestratora podczas odczytu kartoteki zakłóceń. Nazwy plików są uszeregowane od najstarszego do najmłodszego. Zmienna o adresie 16020 zawiera nazwę najstarszego pliku w kartotece zakłóceń.

Uwaga:

Dla zmiennych o adresach 16020 - 16039 należy używać funkcji przeliczającej NIC_TEXT.

Przykłady deklaracji zmiennych:

DI_90, , A.90, PT, 1, 1, NIC

DI_90_00, , A.90.0, PT, 1, 1, NIC

DI_90_01, , A.90.1, PT, 1, 1, NIC

DO_580, , A.580, PT, 1, 1, NIC

AI_1000, , A.1000, PT, 1, 1, NIC_FP

AO_1502, , A.1502, PT, 1, 1, NIC_FP

SRIO_FILE_NAME, , A.16000, PT, 255, 1, NIC_TEXT

SRIO_FILE_RQ, , A.16001, PT, 1, 1, NIC

SPA_MESS_SD, , A.16008, PT, 80, 1, NIC_TEXT

SPA_MESS_RV, , A.16009, PT, 255, 1, NIC_TEXT

SPA_LEN, , A.16010, PT, 1, 1, NIC

ST_203, , S.203, PT, 1, 1, NIC

ZADZ_01, , Z, PT, 1, 1, NIC

ZADZ_02, , Z, PT, 1, 1, NIC

DIST_UNIT_NR, , A.16011, PT, 1, 1, NIC

DIST_READ_RQ, , A.16015, PT, 1, 1, NIC

DIST_LINES_CNT, , A.16017, PT, 1, 1, NIC

DIST_CURR_LINE, , A.16018, PT, 1, 1, NIC

DIST_FILE_1, , A.16020, PT, 255, 1, NIC_TEXT

DIST_FILE_2, , A.16021, PT, 255, 1, NIC_TEXT

SET_DATE_TIME, , A.16500, PT, 1, 1, NIC

Przetwarzanie zdarzeń

Każde zdarzenie przesyłane ze SRIO do komputera ma następujące parametry:

- numer urządzenia SPA,

- numer kanału w urządzeniu SPA,

- numer zdarzenia,

- znacznik czasu w postaci: minuta, sekunda, milisekunda.

Dla każdego zdarzenia otrzymanego ze SRIO, które ma być zgłoszone do systemu alarmów Asixa, należy określić sposób jego przetworzenia:

a/ czy to tylko zdarzenie Asixa (zgłaszamy jednocześnie początek i koniec alarmu Asixa)?

b/ czy to zdarzenie, które należy potraktować jako alarm Asixa, a jeśli tak, to:

1. czy to sygnalizacja początku alarmu Asixa (którego?)

2. czy to sygnalizacja końca alarmu Asixa (którego?, których?)

3. czy należy to zdarzenie również zgłosić jako zdarzenie Asixa (jednocześnie początek i koniec)?

c/ czy należy podtrzymać fakt pojawienia sie zdarzenia w zmiennej wewnętrznej

Definicje przetwarzania zdarzeń umieszcza się w plikach tekstowych. Dla każdego kanału transmisji (dla każdego SRIO) tworzy się osobny plik, a nazwa tego pliku jest parametrem deklaracji kanału transmisji (parametr DefAlarmow).

Wszystkie pliki z definicjami przetwarzania zdarzeń można umieścić we wspólnej kartotece, której nazwa jest podana przy użyciu pozycji SCIEZKA_DEFINICJI_ZDARZEN w sekcji [CtSRIO].

Definicja przetwarzania zdarzenia otrzymanego ze SRIO

Składnia definicji przetwarzania zdarzenia jest następująca ( wszystkie elementy oddzielone znakiem ’;’ ):

[#] unit ; channel ; eventNr ; [eventSpec] ; [alarmStartSpec] ; [alarmEndSpec [,alarmEndSpec]] ; [ZmZadzialanie[.value]] ; [ZmZapis] ; [AnsiAlarm.bitNr.val]

gdzie:

# - opcjonalny znak pozwalający na dodanie komentarza

Parametry identyfikujące zdarzenie

unit - nr urządzenia SPA

channel - numer kanału,

eventNr - numer zdarzenia,

Parametry określające sposób przetwarzania zdarzenia

eventSpec - definicja alarmu Asixa, który zostanie zgłoszony jako zdarzenie Asixa(alarmStart + alarmEnd z tym samym czasem)

alarmStartSpec - definicja alarmu Asixa, który zostanie zgłoszony jako początek alarmu Asixa,

alarmEndSpec - definicja alarmu/alarmów Asixa, który/które zostanie/zostaną zgłoszone jako koniec alarmu/alarmów Asixa,

ZmZadzialanie - nazwa zmiennej wirtualnej, której wartość zostaje ustawiona na wartość parametru value (domyślnie na 1) po wystąpieniu zdarzenia. Służy do podtrzymania faktu wystąpienia zdarzenia dla operatora. Operator może później modyfikować wartość zmiennejwg własnego uznania.

Specyficzne wykorzystanie definicji zdarzenia do rejestracji sterowań

ZmZapis - jeśli na zmiennej o nazwie ZmZapis wykonano operację zapisu, to skutkuje to wygenerowaniem zdarzenia asixa (chodzi o rejestrację sterowań w historii alarmów). Parametry unit, channel i eventNr są ignorowane.

Specyficzne wykorzystanie definicji zdarzenia do generowania alarmów od zmian dwustanów

AnsiAlarm - jeśli bit bitNr punktu ANSI o numerze AnsiAlarm zmieni wartość, to skutkuje to wygenerowaniem zdarzeń ASIXA wg definicji podanych w alarmStartSpec oraz alarmEndSpec. Dotyczy tylko punktów ANSI o numerach do 999 (dwustany) włącznie. Parametry unit, channel i eventNr są ignorowane. Domyślnie przyjmuje się, że zmiana bitu z 0 na 1 (parametr val = 1) jest początkiem alarmu, a zmiana z 1 na 0 (parametr val = 0) jest końcem alarmu.

UWAGA:

Jeżeli parametry identyfikujące zdarzenie nie zostaną odnalezione w pliku definicji zdarzeń, to zdarzenie zostanie zignorowane przez drajwer.

Definicja alarmu asixa

Definicja alarmu ASIXA ma następującą składnię:

<nrAlarmu>[.K][.N][.U]

gdzie:

nrAlarmu - numer alarmu w systemie Asix

K - numer kanału w zdarzeniu przesłanym ze SRIO,

N - numer zdarzenia w zdarzeniu przesłanym ze SRIO,

U - numer urządzenia w zdarzeniu przesłanym ze SRIO.

Parametry K, N i U są opcjonalne i mogą być użyte do przekazania wraz z alarmem do systemu alarmów Asixa max. 3 parametrów dynamicznych (wszystkie przekazywane parametry są typu WORD).

Kolejność parametrów K, N i U w definicji alarmu ASIXA jest dowolna. Kolejność przekazania parametrów dynamicznych do alarmu ASIXA jest zgodna z kolejnością wystąpienia parametrów w definicji alarmu.

Definicja alarmu ASIXA dla rejestracji sterowania

W przypadku rejestracji sterowania dopuszcza się specjalną składnię parametru alarmStartSpec w definicji alarmu Asixa:

<nrAlarmu>.<value>, . . . ,<nrAlarmu>.<value>

gdzie:

nrAlarmu - numer alarmu w systemie Asix

value - wartość sterująca, której wysłanie do SRIO spowoduje zgłoszenie alarmu o numerze nrAlarmu.

Przykłady definicji przetwarzania zdarzeń

# aktywacja wejścia 8 urządzenia 204 - zgłaszane jest zdarzenie ASIXA 206 wraz # z numerem kanału i numerem urządzenia, podtrzymanie zdarzenia poprzez

# zmienną ZZ_06

204; 8; 1; 206.K.U; ; ; ZZ_06 ; ;

# brak komunikacji z urządzeniem 203 - zgłaszany jest początek alarmu 102 wraz

# z numerem urządzenia, podtrzymanie zdarzenia poprzez zmienną ZZ_02

203; 0; 53; ; 102.U; ; ZZ_02 ; ;

# restart urządzenia 203 - zgłaszany jest początek alarmu 101 wraz

# z numerem urządzenia

203; 0; 50; ; 101.U; ; ; ;

# powrót komunikacji z urządzeniem 203 - zgłaszany jest koniec alarmu 101 i 102

# wraz z numerem urządzenia, podtrzymanie zdarzenia poprzez zmienną ZZ_03

203; 0; 54; ; ;101.U, 102.U ; ZZ_03 ; ;

# sterowanie zmienna ZZ_01 skutkuje zdarzeniem ASIXA o numerze 201

; ; ;201; ; ; ; ZZ_01 ;

# sterowanie zmienna DO_580 skutkuje zdarzeniem ASIXA o numerze 305, jeśli wartość sterująca wynosi 0 lub zdarzeniem 306, jeśli wartość sterująca wynosi 1

; ; ; ;305.0, 306.1 ; ; ; DO_580 ;

; ; ; ;400 ; 400 ; ; ; 90.0.1

# stan bitu 2 w ANSI 90 ustawiony na 1 skutkuje początkiem alarmu 402

# stan bitu 2 w ANSI 90 ustawiony na 0 skutkuje końcem alarmu 402

; ; ; ;402 ; 402 ; ; ; 90.2.1

# stan bitu 5 w ANSI 90 ustawiony na 0 skutkuje początkiem alarmu 405

# stan bitu 5 w ANSI 90 ustawiony na 1 skutkuje końcem alarmu 405

; ; ; ;405 ; 405 ; ; ; 90.5.0

Konfiguracja SRIO i urządzeń SPA

Drajwer pozwala na:

• konfigurację zmiennych ANSI w SRIO,

• konfigurację masek zdarzeń urządzeń SPA nadzorowanych przez

SRIO,

• konfigurację urządzeń SPA,

• zapis aktualnej konfiguracji SRIO do EEPROM.

Parametry użyte przez drajwer przy konfigurowaniu SRIO oraz urządzeń SPA są przekazywane w plikach tekstowych. Format plików jest specyficzny dla każdego typu konfiguracji.

Konfiguracja zmiennych ANSI

Konfigurowanie zmiennych ANSI w SRIO polega na przesłaniu do SRIO zawartości pliku konfiguracyjnego. W procesie wykorzystuje się trzy zmienne wirtualne:

- A.16000 - zmienna zawiera pełną nazwę pliku konfiguracyjnego,

- A.16001 - zmienna służy do rozpoczęcia procesu zapisu konfiguracji do SRIO,

- A.16006 - zmienna służy do monitorowania numeru aktualnie zapisywanej deklaracji z pliku konfiguracyjnego.

Proces konfiguracji zmiennych ANSI polega na wykonaniu następujących czynności:

- przygotowaniu pliku tekstowego z deklaracjami zmiennych ANSI,

- wpisaniu pełnej nazwy pliku z deklaracjami zmiennych ANSI do zmiennej wirtualnej

A.16000,

- zapisie dowolnej wartości do zmiennej wirtualnej A.16001. Zapis ten jest

traktowany przez drajwer jako żądanie zapisu konfiguracji zmiennych ANSI do

SRIO.

Przyjęcie żądania zapisu konfiguracji przez drajwer jest sygnalizowane ustawieniem wartości 1 w zmiennej A.16001 oraz wartości 0 w zmiennej A.16006.

Po zapisie konfiguracji każdej ze zmiennych ANSI do SRIO następuje zwiększenie o 1 wartości zmiennej A.16006.

Po wykonaniu zapisu konfiguracji wszystkich zmiennych do SRIO zmienna A.16001 przyjmuje na okres 1 sekundy wartość 2, po czym wartości zmiennych A.16001 oraz zmiennej A.16006 są ustawiane na 0.

Przed zapisem pliku konfiguracyjnego drajwer dokonuje sprawdzenia spójności konfiguracji punktów ANSI istniejących w SRIO z konfiguracją, którą operator zamierza zapisać do SRIO. Poniżej podano zasady, którymi kieruje się drajwer podczas wykonywania tej operacji:

a/ zakłada się, że w chwili startu aplikacji w SRIO znajdują się te punkty ANSI, które są zdefiniowane w pliku konfiguracyjnym (podanym w deklaracji kanału transmisji),

b/ podczas pracy drajwera do SRIO mogą zostać wpisane wyłącznie:

1/ modyfikacje już istniejących w SRIO punktów ANSI,

2/ definicje nowych punktów ANSI,

c/ definicje tożsame z definicjami istniejącymi w SRIO są ignorowane,

d/ drajwer przechowuje własną mapę punktów ANSI, którą uaktualnia po każdej modyfikacji oraz po każdym zapisie nowego punktu ANSI.

Uwaga:

Drajwer nie uaktualnia zawartości pliku konfiguracyjnego (podanego w deklaracji kanału transmisji). Zakłada się, że wszelkie zmiany w konfiguracji punktów ANSI dokonane podczas pracy aplikacji zostaną uaktualnione w pliku konfiguracyjnym przez inżyniera systemu.

Format deklaracji zmiennej ANSI

Deklaracja zmiennej ANSI musi być zgodna z formatem tworzonym przez program SIGTOOL firmy ABB, tzn. musi być linią tekstu składającego się z 14-tu elementów rozdzielonych znakami spacji i zakończonego znakami CR LF. Linie rozpoczynające się znakiem # lub ; są traktowane są jako linie komentarza.

Znaczenie poszczególnych elementów deklaracji jest następujące:

1 (SNR) - numer SRIO

2 (ITEM) - numer porządkowy deklaracji w pliku deklaracji

3 (ADDR) - identyfikator ANSI przypisany zmiennej

4 (BUS) - numer łącza szeregowego w SRIO

5 (UNIT) - numer urządzenia w sieci SPA

6 (CHS) - numer pierwszego kanału

7 (CHE) - numer ostatniego kanału

8 (IO) - identyfikator kategorii zmiennej (I, O, S, V)

9 (DAT1) - numer pierwszej danej

10 (DAT2) - numer ostatniej danej

11 (DTYPE) - typ zmiennej (0 - DI, 1 - AI, 2 - DI, 3 - AO)

12 (DFORM) - format danej (0 - binarny, 1 - dziesiętny, 2 - heksadecymalny)

13 (DELTA) - maska spontanicznych telegramów

14 (STAT) - status. Poszczególne bity statusu oznaczają:

bit 0 - zezwolenie na aktualizację (update enable),

bit 1 - zezwolenie na ciągłe odpytywanie (continous poll enable),

bit 2 - zezwolenie na cykliczne odpytywanie (timed poll enable),

bit 3 - zezwolenie na spontaniczną sygnalizację zmian wartości

(spontanueous transmission enable).

Przykładowe deklaracje zmiennych ANSI:

;SNR ITEM ADDR BUS UNIT CHS CHE IO DAT1 DAT2 DTYPE DFORM DELTA STATUS

6 1 1342 2 203 0 0 I 15 15 1 1 20 13

6 2 580 2 203 1 1 OI 1 1 2 0 0 11

6 3 92 2 203 0 0 V 6 6 1 1 0 11

6 4 1500 2 203 0 0 S 15 15 0 0 10 13

6 5 91 2 203 7 7 I 2 3 0 0 0 11

6 6 92 2 203 11 11 I 1 1 0 0 0 11

Konfiguracja masek zdarzeń urządzeń SPA

Konfigurowanie masek zdarzeń urządzeń SPA polega na przesłaniu do SRIO zawartości pliku konfiguracyjnego. W procesie wykorzystuje się trzy zmienne wirtualne:

- A.16002 - zmienna zawiera pełną nazwę pliku konfiguracyjnego,

- A.16003 - zmienna służy do rozpoczęcia procesu zapisu konfiguracji do SRIO wg wybranego trybu konfigurowania,

- A.16006 - zmienna służy do monitorowania numeru aktualnie zapisywanej deklaracji z pliku konfiguracyjnego.

Konfiguracja może być zrealizowana w jednym z dwóch trybów:

- dopisania - deklaracje z pliku konfiguracyjnego zostaną dodane do konfiguracji znajdującej się w SRIO. Jeśli urządzenie zadeklarowane w pliku konfiguracyjnym posiada już swoją deklarację w SRIO, to deklaracja w SRIO zostanie zastąpiona deklaracją podaną w pliku konfiguracyjnym,

- nadpisania - wszystkie deklaracje znajdujące się w SRIO zostają usunięte, po czym do SRIO zostają zapisane deklaracje znajdujące się w pliku konfiguracyjnym.

Proces konfiguracji masek zdarzeń urządzeń SPA polega na wykonaniu następujących czynności:

- przygotowaniu pliku tekstowego z deklaracjami masek urządzeń,

- wpisaniu pełnej nazwy pliku z deklaracjami masek urządzeń do zmiennej wirtualnej

A.16002,

- zapisie identyfikatora trybu konfiguracji masek zdarzeń do zmiennej wirtualnej

A.16003. Zapis ten jest traktowany przez drajwer jako żądanie zapisu konfiguracji masek urządzeń do SRIO.

Przyjęcie żądania zapisu konfiguracji przez drajwer jest sygnalizowane ustawieniem wartości 1 w zmiennej A.16003 oraz wartości 0 w zmiennej A.16006.

Po zapisie konfiguracji każdej z masek urządzeń do SRIO następuje zwiększenie o 1 wartości zmiennej A.16006.

Po wykonaniu zapisu konfiguracji wszystkich masek urządzeń do SRIO zmienna A.16003 przyjmuje na okres 1 sekundy wartość 2, po czym wartości zmiennych A.16003 oraz zmiennej A.16006 są ustawiane na 0.

Format deklaracji maski zdarzeń

Deklaracja maski zdarzeń musi być zgodna z formatem tworzonym przez program SIGTOOL firmy ABB, tzn. musi być linią tekstu składającego się z 4-ech elementów rozdzielonych znakami spacji i zakończonego znakami CR LF. Linie rozpoczynające się znakiem # lub ; są traktowane są jako linie komentarza.

Znaczenie poszczególnych elementów deklaracji jest następujące:

1 (SNR) - numer SRIO

2 (BUS) - numer łącza szeregowego w SRIO

3 (UNIT) - numer urządzenia w sieci SPA

4 (UTYPE) - typ urządzenia

Przykładowe deklaracje masek zdarzeń urządzeń:

; SNR BUS UNIT UTYPE

6 2 203 2

6 2 204 3

Konfiguracja urządzeń SPA

Konfigurowanie urządzeń SPA polega na przesłaniu do SRIO komend SPA (tzw. SPA messages) odczytanych z pliku konfiguracyjnego. Komendy wysyłane są wg kolejności umieszczenia w pliku konfiguracyjnym. W procesie wykorzystuje się trzy zmienne wirtualne:

- A.16004 - zmienna zawiera pełną nazwę pliku konfiguracyjnego,

- A.16005 - zmienna służy do rozpoczęcia procesu zapisu konfiguracji do SRIO,

- A.16006 - zmienna służy do monitorowania numeru aktualnie przesyłanej komendy SPA deklaracji z pliku konfiguracyjnego.

Proces konfiguracji urządzeń SPA polega na wykonaniu następujących czynności:

- przygotowaniu pliku tekstowego z komendami SPA, które w procesie konfiguracji zostaną przesłane do SRIO,

- wpisaniu pełnej nazwy pliku z komendami SPA do zmiennej wirtualnej A.16004,

- zapisie dowolnej wartości do zmiennej wirtualnej A.16005. Zapis ten jest traktowany przez drajwer jako żądanie zapisu konfiguracji urządzenia SPA do SRIO.

Przyjęcie żądania zapisu konfiguracji przez drajwer jest sygnalizowane ustawieniem wartości 1 w zmiennej A.16005 oraz wartości 0 w zmiennej A.16006.

Po zapisie każdej z komendy SPA do SRIO następuje zwiększenie o 1 wartości zmiennej A.16006.

Po wykonaniu zapisu wszystkich komend SPA do SRIO zmienna A.16005 przyjmuje na okres 1 sekundy wartość 2, po czym wartości zmiennych A.16005 oraz zmiennej A.16006 są ustawiane na 0.

Format komendy SPA

Komendy używane do konfigurowania urządzeń SPA muszą mieć format komend protokołu SPA z sumą kontrolną zastąpioną przez łańcuch znaków XX.

Linie pliku konfiguracyjnego rozpoczynające się od znaku średnika są traktowane jako komentarz.

Zawartość przykładowego pliku z komendami służącymi do konfiguracji urządzeń SPA:

>204W0V155:255:XX

>204W0V156:0:XX

>204W0V157:0:XX

; STORE COMMANDS

>204WV151:1:XX

Zapis konfiguracji SRIO do pamięci EEPROM

Aby zmiany dokonane w konfiguracji SRIO miały charakter trwały, niezbędne jest zapisanie zmodyfikowanej konfiguracji do pamięci EEPROM.

Zapis konfiguracji do pamięci EEPROM jest inicjowany poprzez wykonanie operacji zapisu na zmiennej wirtualnej A.16007 (wartość sterująca nie ma znaczenia).

Zapis konfiguracji do pamięci EEPROM jest operacją długotrwałą, podczas której drajwer blokuje możliwość wykonania jakichkolwiek zmian w konfiguracji SRIO (próba wykonania zmian w konfiguracji jest kończona błędem).

Odczyt rejestratora zakłóceń

Drajwer pozwala na wykonanie następujących operacji związanych z rejestratorem zakłóceń:

• odczyt kartoteki rejestratora zakłóceń,

• odczyt wybranego pliku z kartoteki rejestratora zakłóceń,

• usunięcie najstarszego pliku z kartoteki rejestratora zakłóceń.

Wszystkie operacje realizowane są przy pomocy komend SPA (tzw. SPA messages) realizowanych współbieżnie z rutynową komunikacją ze SRIO.

Komunikaty o rozpoczęciu i zakończeniu powyższych operacji są wyświetlane w Panelu Kontrolnym aplikacji.

Odczyt kartoteki rejestratora zakłóceń

Odczyt kartoteki rejestratora zakłóceń polega na wykonaniu następujących operacji:

• wpisaniu do zmiennej o adresie A.16011 numeru urządzenia (w sieci SPA), z którego ma być odczytana kartoteka zakłóceń,

• wpisaniu do zmiennej o adresie A.16012 dowolnej wartości - ta operacja zainicjuje odczyt kartoteki zakłóceń z urządzenia, którego numer jest podany w zmiennej A.16011.

W pierwszej fazie operacji zostaje odczytana liczba zakłóceń przechowywanych w urządzeniu (i wpisana do zmiennej o adresie A.16013), po czym, jeśli liczba zakłóceń jest niezerowa, następuje odczyt nazw plików zakłóceń i wpisanie ich po kolei do zmiennych o adresach z zakresu A.16020 wzwyż.

W drajwerze założono, że liczba plików zakłóceń przechowywanych w urządzeniu nie będzie większa niż 20.

Odczyt wybranego pliku z kartoteki rejestratora zakłóceń

Odczyt kartoteki rejestratora zakłóceń polega na wykonaniu następujących operacji:

• wpisaniu do zmiennej o adresie A.16011 numeru urządzenia (w sieci SPA), z którego ma być odczytana kartoteka zakłóceń,

• wpisaniu do zmiennej o adresie A.16019 stopnia kompresji odczytywanego pliku (dopuszczalne wartości to 0, 1, 2, 3, 4, 5). Domyślnie przyjmuje się 0 (bez kompresji),

• wpisaniu do zmiennej o adresie A.16014 numeru pliku zakłóceń, który chcemy odczytać - ta operacja zainicjuje odczyt pliku. Najstarszy plik ma numer 1, najmłodszy plik ma numer równy liczbie plików zakłóceń odczytanych z kartoteki zakłóceń.

W pierwszej fazie operacji zostaje odczytana liczba linii znajdujących się w pliku zakłóceń (i wpisana do zmiennej o adresie A.16017) oraz wyzerowany bieżący licznik linii (zmienna o adresie A.16018).

W kolejnych etapach następuje odczyt kolejnych linii pliku zakłóceń oraz aktualizacja zmiennej A.16018, co pozwala śledzić postęp odczytu.

Po poprawnym odczycie plik zakłóceń zostaje zapisany do kartoteki podanej w deklaracji kanału transmisji (lub do kartoteki domyślnej). Plikowi nadaje się nazwę utworzoną z nazwy pliku zakłóceń poprzedzonego literą ’h’. Pliki zapisywane są w formacie ASCII. Plikowi nadaje się znacznik czasu z chwili zapisu pliku (a nie znacznik czasu utworzenia pliku w rejestratorze).

Usunięcie najstarszego pliku z rejestratora zakłóceń

Usunięcie najstarszego pliku z kartoteki rejestratora zakłóceń polega na wykonaniu następujących operacji:

• wpisaniu do zmiennej o adresie A.16011 numeru urządzenia (w sieci SSPA), z którego ma być odczytana kartoteka zakłóceń,

• wpisaniu do zmiennej o adresie A.16016 dowolnej wartości - ta operacja zainicjuje proces usunięcia najstarszego pliku z rejestratora zakłóceń.

Synchronizacja czasu

Do synchronizacji czasu używana jest zmienna o adresie A.16500. Zapis dowolnej wartości do tej zmiennej powoduje wysłanie do SRIO aktualnego czasu PC. Domyślnie wysyłany jest czas lokalny. Możliwe jest wysyłanie czasu w trybie UTC - w tym celu należy utworzyć sekcję o nazwie kanału ASMENA obsługującego dane SRIO i wpisać do tej sekcji pozycję:

Synchronizacja_Utc = TAK

Parametryzacja drajwera

Parametry drajwera Srio deklarowane są w module Pozostałe, na zakładce Opcje wprowadzane bezpośrednio.

Parametryzacja drajwera odbywa się przy użyciu osobnej sekcji o nazwie CTSRIO.

R Nazwa sekcji: CTSRIO

R Nazwa opcji: PLIK_LOGU

R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie nie tworzy się pliku logu.

R Nazwa sekcji: CTSRIO

R Nazwa opcji: ROZMIAR_PLIKU_LOGU

R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość opcji: liczba - rozmiar pliku logu w MB.

Wartość domyślna: domyślnie rozmiar pliku logu wynosi 10 MB.

R Nazwa sekcji: CTSRIO

R Nazwa opcji: LOG_TELEGRAMOW

R Wartość opcji: TAK|NIE

Znaczenie: Dla celów diagnostycznych w pliku logu można umieszczać zawartość telegramów przesyłanych pomiędzy systemem Asix i SRIO.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa sekcji: CTSRIO

R Nazwa opcji: OKRES_DIAGNOSTYKI

R Wartość opcji: liczba

Znaczenie: Dla celów sprawdzania aktywności SRIO drajwer może okresowo wysyłać komunikaty diagnostyczne.

Wartość opcji: liczba - okres wysyłania komunikatów diagnostycznych (w sekundach).

Wartość domyślna: Domyślnie drajwer wysyła komunikaty diagnostyczne co 10 sekund.

R Nazwa sekcji: CTSRIO

R Nazwa opcji: SCIEZKA_DEFINICJI_ZDARZEN

R Wartość opcji: ścieżka

Znaczenie: Pliki z definicjami zdarzeń mogą być umieszczone we wspólnej kartotece. Nazwa kartoteki deklarowana przy użyciu pozycji SCIEZKA_DEFINICJI_ZDARZEN.

Wartość opcji: sciezka - nazwa kartoteki, w której drajwer będzie szukać plików z definicjami zdarzeń.

Wartość domyślna: domyślnie wartość opcji jest ustawiona na NIE.

Parametry kanału drajwera

W sekcji o nawie kanału transmisji można umieszczać pozycje deklarujące:

• tworzenie pliku logu pojedynczego kanału,

• rozmiar pliku logu pojedynczego kanału,

• log telegramów pojedynczego kanału,

• typ czasu wysyłanego do SRIO w ramach synchronizacji czasu,

• śledzenie sterowań,

• wyłączenie odczytu określonych punktów ANSI,

• wyłączenie rejestracji alarmów od sterowania.

Pierwsze trzy pozycje mają składnię oraz znaczenie takie, jak odpowiadające im pozycje umieszczane w sekcji drajwera [CtSrio], ale dotyczą wyłącznie kanału, dla którego zostały zadeklarowane.

Synchronizacja czasu w trybie UTC

R Nazwa sekcji: <nazwa_kanalu>

R Nazwa opcji: SYNCHRONIZACJA_UTC

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala określić typ czasu przesyłanego do SRIO w ramach synchronizacji. Pozycję należy stosować dla każdego kanału transmisji z osobna. TAK - oznacza wysyłanie czasu UTC. NIE - oznacza wysyłanie czasu lokalneg.

Wartość domyślna: Domyślnie drajwer w ramach synchronizacji wysyła do SRIO czas lokalny.

Śledzenie sterowań

Pozycja pozwala na wyprowadzenie do panela operatorskiego komunikatów dotyczących poszczególnych faz realizacji sterowania. Komunikaty zawierają stempel czasu z dokładnością do milisekund i dotyczą następujących faz sterowania:

• wstawienie polecenia zapisu do kolejki telegramów wysyłanych do SRIO,

• wysłanie polecenia zapisu do SRIO,

• odbiór ze SRIO znaku ACK na polecenie zapisu,

• odbiór ze SRIO znaku NAK na polecenie zapisu,

• timeout oczekiwania na odbiór ze SRIO znaku ACK/NAK na polecenie zapisu wysłane,

• zgłoszenie zakończenia operacji zapisu na poziom aplikacji,

• odbiór spontanicznego telegramu, będącego efektem wykonanego sterowania.

Domyślnie drajwer nie tworzy logu w trakcie realizacji sterowania.

Wyłączenie z listy odczytowej określonych punktów ANSI

R Nazwa sekcji: <nazwa_kanalu>

R Nazwa opcji: ANSI_TYLKO_DO_ODCZYTU

R Wartość opcji: liczba

Znaczenie: Pozycja pozwala wyłączyć z listy odczytowej określony punkt ANSI. Oznacza to, że drajwer nie będzie wysyłać do SRIO zapytań o wartość danego punktu ANSI (ale będzie przyjmować spontaniczne telegramy dotyczące danego punktu).

Pozycję należy stosować dla punktów ANSI, dla których operacja odczytu kończy się błędem o kodzie 0x40 sygnalizowanym przez SRIO.

Dla każdego punktu ANSI, któremu chcemy wyłączyć funkcję odczytu, należy użyć osobnej pozycji.

Wartość opcji: nrANSI - numer punktu ANSI w postaci dziesiętnej.

Wyłączenie rejestracji alarmów od sterowania

R Nazwa sekcji: <nazwa_kanalu>

R Nazwa opcji: BEZ_ALARMOW_OD_STEROWANIA

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja pozwala wyłączyć rejestrację alarmów od sterowania zdefiniowanych w pliku z definicjami przetwarzania zdarzeń.

Pozycja odnosi się do wszystkich alarmów od sterowania zdefiniowanych w tym pliku.

TAK - wyłączenie rejestracji alarmów od sterowania. NIE - rejestracja alarmów od sterowania.

Wartość domyślna: NIE.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


SRTP - drajwer protokołu SRTP

Home > 1.110 SRTP - drajwer protokołu SRTP

1.110 SRTP - drajwer protokołu SRTP

Przeznaczenie drajwera

Drajwer SRTP jest przeznaczony do wymiany danych pomiędzy systemem Asix i sterownikami firmy GE Fanuc Automation serii VersaMax Nano/Micro przy wykorzystaniu konwertera IC200SET001 oraz sterownikami serii WersaMax i Series 90, przy wykorzystaniu modułu komunikacyjnego IC693CMM321, przy pomocy protokołu SRTP (Service Request Transfer Protocol) wykorzystującego sieć Ethernet z protokołem TCP/IP.

Parametryzacja drajwera SRTP realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera SRTP wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: SRTP

Zakładka SRTP / Parametry kanału:

Parametry kanału:

adres_IP [, port]

gdzie:

adres_IP - adres IP przydzielony modułowi komunikacyjnemu IC693CMM321,

Numer portu - opcjonalny numer portu, przez który będzie realizowane połączenie z modułem komunikacyjnym IC693CMM321 (domyślnie 18245).

Dla każdego modułu IC693CMM321 jest wymagana osobna deklaracja kanału transmisji.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału transmisji KANAL służącego do komunikacji z modułem IC693CMM321, posiadającego adres IP 10.10.10.70 oraz korzystającego z domyślnego portu o numerze 18245.

Nazwa: KANAL

Drajwer: SRTP

Parametry kanału: 10.10.10.70

Typy zmiennych procesowych

W drajwerze zdefiniowano następujące typy zmiennych procesowych:

I - Discrete Input (%I) w trybie BIT,

IB - Discrete Input (%I) w trybie BYTE,

IW - Discrete Input (%I) w trybie WORD,

Q - Discrete Output (%Q) w trybie BIT,

QB - Discrete Output (%Q) w trybie BYTE,

QW - Discrete Output (%Q) w trybie WORD,

M - Discrete Internal (%M) w trybie BIT,

MB - Discrete Internal (%M) w trybie BYTE,

MW - Discrete Internal (%M) w trybie WORD,

G - Genius Global Data (%G) w trybie BIT,

GB - Genius Global Data (%G) w trybie BYTE,

GW - Genius Global Data (%G) w trybie WORD,

AI - Analog Input (%AI) w trybie WORD,

AQ - Analog Output (%AQ) w trybie WORD,

R - Register (%R) traktowany jako WORD,

RL - dwa kolejne Registers (%R) traktowane jako DWORD,

RF - dwa kolejne Registers (%R) traktowane jako FLOAT,

TD - aktualny czas i data sterownika.

Wartości zmiennych typu I, IB, IW oraz AI mogą być wyłącznie czytane, natomiast wartości pozostałych zmiennych mogą być czytane oraz zapisywane.

Nie są obsługiwane następujące typy zmiennych (systemowe, tymczasowe):

  • Discrete SA (%SA),

  • Discrete SB (%SB),

  • Discrete SC (%SC),

  • Discrete S (%S),

  • Discrete Temporary (%T).

Adresacja zmiennych

Adres zmiennej procesowej ma składnię:

<Typ><Index>

gdzie:

Typ - nazwa typu zmiennej,

Index - adres zmiennej w ramach typu zmiennej Typ.

Dla zmiennych dyskretnych (I, IB, IW, Q, QB, QW, M, MB, MW, G, GB, GW) Index wskazuje numer bitu, od którego rozpoczyna się zakres bitów przypisany zmiennej. W zależności od trybu udostępniania zmiennych dyskretnych Index może przyjmować następujące wartości:

a/ dla trybu BIT - dowolna wartość począwszy od 1,

b/ dla trybu BYTE - wartości 1, 9, 17, i.t.d (numery pierwszego bitu

kolejnych bajtów),

c/ dla trybu WORD - wartości 1, 17, 33, i.t.d (numery pierwszego bitu

kolejnych słów).

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_1, %R1 i %R2 jako FLOAT, RF1, KANAL,1,1,NIC_FP

JJ_3, %R3 i %R4 jako DWORD, RL3, KANAL,1,1,NIC_DW

JJ_5, %R5 jako WORD, R5, KANAL,1,1,NIC

JJ_31, pojedynczy bit %M1, M1, KANAL,1,1,NIC

JJ_32, bity %Q9 - %Q16 jako jeden bajt, QB9, KANAL,1,1,NIC_BYTE

JJ_33, bity %I17 - %I32 jako jedno słowo, IW17, KANAL,1,1,NIC

JJ_40, zapis daty i czasu do PLC, TD, KANAL,8,15,NIC_BYTE

Synchronizacja daty i czasu ze sterownikiem

W drajwerze został wbudowany mechanizm synchronizacji daty i czasu pomiędzy systemem Asix i sterownikami GE Fanuc. Synchronizacja jest aktywowana dla każdego kanału transmisji z osobna przy pomocy opcji Synchronizacja czasu, deklarowanej przy użyciu programu Architekt:

Architekt > Obszary i komputery > Dane bieżące > zakładka Zaawansowane 2

Składnia opcji:

kanał, zmienna

Parametry:

kanał - nazwa kanału transmisji służącego do komunikacji z określonym modułem IC693CMM321,

zmienna - nazwa zmiennej ASMENa należącej do kanału kanał, służącej do synchronizacji daty i czasu.

Synchronizacja daty i czasu polega na cyklicznym zapisie do sterownika ramki zawierającej aktualną datę i czas asixa. Ramka jest zapisywana przy użyciu wbudowanej funkcji zapisu daty i czasu protokołu SRTP, zgodnie z częstością przypisaną zmiennej. Typem zmiennej musi być typ TD (obsługa daty i czasu), liczba elementów przypisana zmiennej musi mieć rozmiar 8 (rozmiar ramki daty i czasu). Jako funkcji przeliczającej należy użyć NIC_BYTE.

Parametry drajwera

Parametry drajwera SRTP deklarowane są w module Dane bieżące na zakładkach SRTP / Parametry drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera oraz informacje o zawartości telegramów odebranych przez drajwer. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - plik logu nie jest tworzony.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślna - 1MB.

RLog telegramów

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji PLIK_LOGU) zawartości telegramów wysyłanych/odbieranych przez drajwer. Zapis zawartości telegramów do pliku logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - NIE.

R Czas rozbiegu

Znaczenie - pozwala określić czas (w sekundach) przeznaczony na nawiązanie połączeń sieciowych z wszystkimi modułami IC693CMM321 na etapie rozbiegu aplikacji.

Wartość domyślna - 3s.

R Timeout odbioru w sekundach

Znaczenie - dla każdego modułu IC693CMM321 określa się maksymalny czas, jaki może upłynąć pomiędzy wysłaniem zapytania i otrzymaniem odpowiedzi (tzw. timeout odbioru). Po przekroczeniu timeout’u połączenie będzie zrywane (i nawiązywane ponownie). Wartość timeout’u jest określana indywidualnie dla każdego modułu IC693CMM321.

Wartość domyślna - 5s.

Parametry:

adres_IP_klienta - adres IP modułu IC693CMM321,

liczba - wartość timeout’u wyrażona w sekundach.

Parametryzacja redundancji MaxON

1. Należy utworzyć dwa kanały ASMENA, skierowane do sterowników ID_A oraz ID_B tworzących redundancję MaxON.

2. Kanał skierowany do sterownika ID_A jest przeznaczony dla zmiennych aplikacji, kanał skierowany do sterownika ID_B jest wykorzystywany wewnętrznie przez drajwer SRTP (nie powinien być wykorzystywany przez aplikację).

3. W parametrach drajwera należy zadeklarować parametr Redundancja MaxOn, podając nazwy kanałów skierowanych do sterowników ID_A i ID_B, gdzie:

kan_ID_A - nazwa kanału ASMENA skierowanego do sterownika ID_A

kan_ID_B - nazwa kanału ASMENA skierowanego do sterownika ID_B

Architekt > Obszary i Komputery > Dane bieżące / deklaracja kanału działającego wg drajwera SRTP > Zakładka SRTP / Parametry drajwera 2

Zasada działania drajwera przy obsłudze redundancji MaxON, polega na wyborze właściwego kanału (z pary kan_ID_A i kan_ID_B) dla obsługi zmiennych aplikacji. Strategia wyboru bazuje na bieżącym stanie flag statusowych, czytanych z kanałów kan_ID_A i kan_ID_B.

Adresy symboliczne zmiennych systemowych podane niżej oznaczają:

XN1 - status ID_A

XN2 - status ID_B

XN3 - status RUN

XN4 - status MASTER

XN5 - status SYNC

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


TALAS - drajwer protokołu analizatorów TALAS

Home > 1.111 TALAS - drajwer protokołu analizatorów TALAS

1.111 TALAS - drajwer protokołu analizatorów TALAS

Przeznaczenie drajwera

Protokół TALAS jest wykorzystywany do wymiany danych pomiędzy komputerami emisji TALAS i systemem Asix przy wykorzystaniu łączy szeregowych. Drajwer został stworzony do współpracy z urządzeniami z zainstalowanym oprogramowaniem firmowym w wersji v 2.3 (007)22.

Parametryzacja drajwera TALAS realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera TALAS wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: TALAS

Zakładka TALAS:

Parametry kanału:

COMn, baud

gdzie:

COMn - numer portu szeregowego, do którego podłączony jest komputer emisji TALAS,

Baud - prędkość transmisji wyrażona w bodach.

Drajwer TALAS jest ładowany automatycznie jako DLL.

Przykład

Nazwa: CHAN1

Drajwer: TALAS

Parametry kanału:

COM1,9600

Adresacja zmiennych procesowych

Z komputera TALAS odczytuje się tablice danych następujących kategorii:

HM - bieżące dane półminutowe,

PI - bieżące całki częściowe,

AI - wartości aktualne całek półgodzinnych,

HI - całki półgodzinne za dzień bieżący,

DIW - dzienny rozkład całek półgodzinnych z dnia ubiegłego,

YIW - roczny rozkład całek półgodzinnych z dnia ubiegłego,

DMV - rozkład średniej wartości dziennej z dnia ubiegłego,

Z powyższych tablic drajwer TALAS wyłuskuje dane procesowe następujących typów:

ATM - czas aktualny (danych półminutowych) komputera TALAS, przekazywany jako liczba sekund w formacie dword;

VAL - wartość zmiennej w formacie float;

STA - status zmiennej w formacie word;

OTM - 'czas pracy' zmiennej liczony w dziesiątych częściach sekundy, przekazywany w formacie long;

ITM - okres całkowania w sekundach w formacie short;

DCL - klasy klasyfikacji w formacie word;

DCT - tabela klasyfikacji dla zmiennej, zawartości poszczególnych klas w formacie word; maksymalny rozmiar tabeli: 34 elementy;

IVT - tabela całek półgodzinnych dla zmiennej, element jest strukturą zawierającą czas; wartość (float) i status (word); maksymalny rozmiar tabeli: 48 elementów.

Dopuszczalne zestawienia typ-kategoria danych wraz z oczekiwanym formatem łańcucha adresowego podaje poniższa tabela, przy czym "nn" oznacza numer kolejny (a nie identyfikacyjny) zmiennej w wykazie zmiennych komputera TALAS w zakresie <1..128> dla kategorii HM, PI i AI oraz <1..64> dla kategorii HI, DIW, YIW i DMV (zobacz: Tabela. Dopuszczalne zestawienia typ-kategoria danych wraz z oczekiwanym formatem łańcucha adresowego dla drajwera TALAS. ).

Tabela. Dopuszczalne zestawienia typ-kategoria danych wraz z oczekiwanym formatem łańcucha adresowego dla drajwera TALAS.

Parametry drajwera TALAS

Parametry drajwera TALAS deklarowane są w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

R Nazwa sekcji: TALAS
R Nazwa opcji: baud
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania prędkości transmisji. Opcja może być używana zamiennie z opcjami: bod, szybkosc, bps. Wartość opcji ma pierwszeństwo przed prędkością transmisji podaną w definicji kanału logicznego.

Wartość domyślna - domyślnie przyjmowana jest prędkość transmisji 9600 Bd.

Parametr:

liczba - prędkość transmisji w Bd.

R Nazwa sekcji: TALAS
R Nazwa opcji: parity
R Wartość opcji: typ_kontroli

Znaczenie - opcja służy do deklarowania sposobu kontroli parzystości. Opcja może być używana zamiennie z pozycją: parzystosc.

Wartość domyślna - domyślnie przyjmowana jest kontrola parzystości parzysta.

Parametr:

typ_kontroli - identyfikator sposobu kontroli parzystości:

n - brak bitu parzystości

o - kontrola parzystości nieparzysta

e - kontrola parzystości parzysta

m - mark

s - space

Przykład

Nazwa sekcji: TALAS

Nazwa opcji: parity

Wartość opcji: e

R Nazwa sekcji: TALAS
R Nazwa opcji: stop
R Wartość opcji: liczba

Znaczenie - pzycja służy do deklarowania liczby bitów stopu. Opcja może być używana zamiennie z pozycją: bity_stopu.

Wartość domyślna - domyślnie przyjmuje się 1 bit stopu.

Parametr:

liczba - liczba bitów stopu: 1 lub 2.

R Nazwa sekcji: TALAS
R Nazwa opcji: slowo
R Wartość opcji: liczba

Znaczenie - pzycja służy do deklarowania liczby bitów w transmitowanym znaku. Opcja może być używana zamiennie z pozycją: dlugosc_slowa, word, word_length.

Wartość domyślna - domyślnie przyjmuje się, że transmitowany znak ma 8 bitów.

Parametr:

liczba - liczba bitów w znaku (od 5 do 8).

Przykład

Nazwa sekcji: TALAS

Nazwa opcji: slowo

Wartość opcji: 8

R Nazwa sekcji: TALAS
R Nazwa opcji: timeout
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania czasu oczekiwania na odpowiedź z komputera TALAS (w sekundach).

Wartość domyślna - domyślnie przyjmuje się 10 sekund.

Parametr:

liczba - czas oczekiwania na odpowiedź w sekundach.

R Nazwa sekcji: TALAS
R Nazwa opcji: InterwalKM
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania odstępu czasu (w sekundach) pomiędzy odczytami wartości średnich krótkoczasowych i całek częściowych z komputera TALAS. Opcja może być używana zamiennie z pozycją Interwal.

Wartość domyślna - domyślnie przyjmuje się 30 sekund.

Parametr:

liczba - interwał czasu w sekundach.

Przykład

Nazwa sekcji: TALAS

Nazwa opcji: InterwalKM

Wartość opcji: 30

R Nazwa sekcji: TALAS
R Nazwa opcji: InterwalIW
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania odstępu czasu (w minutach) pomiędzy odczytami wartości całek półgodzinnych i całek aktualnych z komputera TALAS.

Wartość domyślna - domyślnie przyjmuje się 30 minut.

Parametr:

liczba - interwał czasu w minutach.

R Nazwa sekcji: TALAS
R Nazwa opcji: InterwalFD
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania odstępu czasu (w minutach) pomiędzy odczytami wartości rozkładów z komputera TALAS.

Wartość domyślna - domyślnie przyjmuje się 60 minut.

Parametr:

liczba - interwał czasu w minutach.

R Nazwa sekcji: TALAS
R Nazwa opcji: log
R Wartość opcji: nazwa

Znaczenie - opcja służy do deklarowania pliku, do którego będą zapisywane informacje diagnostyczne drajwera TALAS. Opcja jest dedykowana dla celów testowych.

Wartość domyślna - domyślnie plik nie jest tworzony.

Parametr:

nazwa - nazwa pliku.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtTwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu

Home > 1.112 TwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu TwinCAT

1.112 TwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu TwinCAT

Przeznaczenie drajwera

Drajwer TwinCAT jest przeznaczony do wymiany danych pomiędzy systemem Asix i systemem TwinCAT firmy Beckhoff Industrie Elektronik. Komunikacja pomiędzy systemami realizowana jest poprzez Ethernet w dwóch trybach, w zależności od tego, w jaki firmware wyposażony jest sterownik Beckhoff.

Istnieją dwie wersje drajwera TwinCAT:

  1. CtTwinCat.dll - korzysta z biblioteki TcAdsDll dostarczanej przez Beckhoffa.

  2. CtTwinCatTcpip.dll - korzysta z interfejsu ADS/AMS over TCPIP (bez użycia bibliotek Beckhoff'a).

Drajwer TwniCAT obsługuje następujące urządzenia:

- sterowniki serii CX1000,

- TwinCAT PLC (PC based control system),

- STEROWNIKI SERII BC9000,

- STEROWNIKI SERII BX9000.

Parametryzacja drajwera TwinCAT realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Drajwer TwinCAT jest ładowany poprzez uniwersalny drajwer systemu Asix - UNIDRIVER.

Deklaracja kanału transmisji korzystającego z drajwera CtTwinCat.dll

Deklaracja kanału transmisyjnego działającego według protokołu drajwera TwinCAT wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: TwinCAT

Zakładka TwinCAT / Parametry kanału:

Numer portu routera systemu TwinCAT

Adres AMS (4 pierwsze elementy) routera systemu TwinCAT

Parametry kanału transmisji korzystającego z drajwera CtTwinCat.dll

Parametry kanału deklarowane są w module Dane bieżące - odpowiednio na zakładce o nazwie TwinCAT / Parametry kanału 2.

R Timeout

Znaczenie - timeout oczekiwania na wykonanie operacji ADS’a w danym kanale.

Wartość domyślnie - domyślna wartość wynosi 5000 ms.

Parametr:

liczba - czas w milisekundach.

R Synchronizacja czasu

Znaczenie - adres w sterowniku, do którego będzie wysyłana ramka czasu.

Wartość domyślnie - brak.

R Okres synchronizacji czasu

Znaczenie - okres czasu, co który ramka czasu będzie wysyłana do sterownika.

Parametr:

liczba - czas w sekundach.

R Typ obsługi

Znaczenie - typ obsługi; dostępne warianty: CX,PC-PLC; BC 9000.

R Numer alarmu stanu Stop

Znaczenie - pozwala na generowanie alarmu przy przejściu PLC na stan STOP.

R Wersja

Znaczenie - wersja oprogramowania w sterowniku (system Asix współpracuje z wersją 0 oraz 1). Opcja ma znaczenie tylko w przypadku, gdy sterownik dostarcza dane historyczne.

Parametr:

liczba - 0 lub 1.

PRZYKŁAD

Przykład deklaracji kanału korzystającego z zasobu RTS1 na komputerze o adresie AMS 10.10.10.254 i timeout-ie 100 ms z synchronizacją czasu poprzez tablicę bajtów, znajdującą się pod adresem symbolicznym .tabWord:

Nazwa: PLC1

Drajwer: CtTwinCAT
Numer portu routera systemu TwinCAT: 801

Adres AMS routera systemu TwinCAT: 10.10.10.254

Timeout: 100

Synchronizacja czasu: .tabWord

Deklaracja kanału transmisji korzystającego z drajwera CtTwinCatTcpip.dll

Deklaracja kanału logicznego transmisji danych działającego według protokołu drajwera TwinCATTcpip wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: TwinCATTcpip

Alarm w kanale: numer alarmu zgłaszanego w przypadku zerwania połączenia ze sterownikiem

Zakładka TwinCATTcpip / Parametry kanału:

AMS Net Id systemu Asix (4 pierwsze elementy) - adres AmsNetId systemu Asix, który wraz z IP komputera, na którym działa Asix, tworzy parę identyfikującą połączenie Asix <--> sterownik; w/w para musi mieć swój odpowiednik w tablicy route'ów projektu sterownika, aby możliwa była wymiana danych; zazwyczaj przyjmuje się (dla uproszczenia parametryzacji połączeń), że adres AmsNetId systemu Asix jest taki sam jak adres IP komputera

Adres IP sterownika

AMS Net Id sterownika

Numer portu sterownika

Adres IP komputera - adres IP komputera, przez który kanał komunikuje się ze sterownikiem. Domyślnie kanał korzysta z adresu IP dostarczonego przez system Windows.

Rozmiar bufora - pozwala określić maksymalną wielkość bufora używanego przy realizacji operacji odczytu i zapisu pomiędzy drajwerem CtTwinCAT oraz systemem TwinCAT

Synchronizacja UTC - synchronizacja czasu stacji Asixa z czasem sterownika w trybie UTC

Parametry kanału transmisji korzystającego z drajwera CtTwinCATTcpip.dll

Parametry kanału deklarowane są w module Dane bieżące - odpowiednio na zakładce o nazwie TwinCATTcpip / Parametry kanału 2.

R Timeout

Znaczenie - timeout oczekiwania na wykonanie operacji ADS’a w danym kanale.

Wartość domyślnie - domyślna wartość wynosi 5000 ms.

Parametr:

liczba - czas w milisekundach.

R Synchronizacja czasu

Znaczenie - adres w sterowniku, do którego będzie wysyłana ramka czasu; adres może być podany w postaci symbolicznej lub bezwzględnej (patrz: adresacja poniżej).

Wartość domyślnie - brak.

R Okres synchronizacji czasu

Znaczenie - okres czasu, co który ramka czasu będzie wysyłana do sterownika.

Parametr:

liczba - czas w sekundach.

Wartość domyślnie - 60

R Typ obsługi

Znaczenie - pozwala na deklarację typu sterownika obsługiwanego na danym połączeniu - typ obsługi: CX,PC-PLC (1), BX9000 (2), BC9000 (2).

Wartość domyślnie - domyślnie przyjmuje się 1

R Nr Alarmu Stanu Stop

Znaczenie - pozwala na generowanie alarmu przy przejściu PLC na stan STOP.

R Wersja

Znaczenie - wersja oprogramowania w sterowniku (Asix współpracuje z wersją 0 oraz 1). Opcja ma znaczenie tylko wtedy, gdy sterownik dostarcza dane historyczne.

PRZYKŁAD

Nazwa: Kanal

Drajwer: TwinCATcpip

Numer portu sterownika: 801

Adres AMS Net Id systemu Asix: 5.0.70.215

Adres IP sterownika: 10.10.10.119

Adres Ams Net Id sterownika: 10.10.10.191

Typ obsługi: 1

Struktura ramki czasu przesyłana do PLC ma następujący format:

struct dateTime

{

word wYear;

word wMonth;

word wDayOfWeek;

word wDay;

word wHour;

word wMinute;

word wSecond;

word wMilliseconds;

word wSynchr;

};

gdzie:

wYear - rok 1970 ~ 2106

wMonth - miesiąc 1 ~ 12 (Styczeń = 1, Luty = 2, itd)

wDayOfWeek - dzień tygodnia 0 ~ 6 (Niedz = 0, Pon = 1, itd)

wDay - dzień miesiąca 1 ~ 31;

wHour - godzina 0 ~ 23;

wMinute - minuta 0 ~ 59;

wSecond - sekunda 0 ~ 59;

wMilliseconds - milisekunda 0 ~ 999;

wSynchr - synchronizacja wpisywane 1 w momencie wysłania

Zakładka TwinCATTcpip / Parametry kanału - historia:

R Numer grupy

Znaczenie - numer grupy (w HEX), w której przechowywane są dane historyczne.

R Offset danych historycznych

Znaczenie - offset w ramach grupy (w HEX), od którego rozpoczyna się obszar danych historycznych.

R Liczba zmiennych

Znaczenie - liczba zmiennych historycznych.

R Offset zapytań

Znaczenie - offset w ramach grupy (w HEX), od którego rozpoczyna się bufor poleceń systemu Asix.

R Offset odpowiedzi

Znaczenie - offset w ramach grupy (w HEX), od którego rozpoczyna się bufor odpowiedzi na polecenia systemu Asix.

R Zwłoka zapytań

Znaczenie - spodziewany czas oczekiwania na wykonanie polecenia odczytu danych historycznych ze sterownika w sekundach.

Zakładka TwinCATTcpip / Parametry kanału - log:

R Plik logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślnie - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) informacji o poleceniach odczytu i zapisu realizowanych przez ADS. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie wartość opcji jest ustawiona na NIE.

R Log treści telegramów

Znaczenie - pozwala na zapisywanie treści telegramów danych do pliku logu.

Adresacja zmiennych

Dopuszcza się dwa rodzaje adresów:

  • symboliczny - poprzez podanie adresu symbolicznego zmiennej w systemie TwinCAT. Składnia adresu symbolicznego jest następująca:

[<tekst1>].<tekst2>

gdzie:

tekst1, tekst2 - łańcuch znaków ASCII

Adresy symboliczne wszystkich zmiennych projektu realizowanego w systemie TwinCAT znajdują się w kartotece przedmiotowego projektu w XML-owym pliku o rozszerzeniu *.tpy - adresy symboliczne znajdują się w sekcjach identyfikowanych przez słowo kluczowe <Symbol>.

  • bezpośredni - poprzez podanie pary liczb, określających numer grupy i numer offsetu w ramach grupy. Obie liczby podane są w formacie HEX i są rozdzielone znakiem dwukropka.

Przykład adresu symbolicznego:

.engine

MAIN.devUP

Przykład adresu bezpośredniego:

F030:03EA

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_00, zmienna typu REAL o nazwie valFloat,.valFloat,PLC1, 1, 1, NIC_FP

JJ_01, zmienna typu WORD o nazwie valWord,.valWord,PLC1, 1, 1, NIC

JJ_02, zmienna typu BOOL o nazwie MAIN.engine,MAIN.engine,PLC1, 1, 1, NIC_BYTE

JJ_03, zmienna typu BYTE o adresie F030:5 (%QB5),F030:5,PLC1, 1, 1, NIC_BYTE

Typy zmiennych

Dla zmiennych adresowanych symbolicznie typ zmiennej jest pobierany z systemu TwinCAT poprzez odczyt mapy symboli. Typ używany w systemie TwinCAT jest następnie konwertowany na typ żądany przez użytkownika.

Dla zmiennych adresowanych bezpośrednio za typ zmiennej jest przyjmowany typ rzeczywisty funkcji przeliczającej zdefiniowanej dla przedmiotowej zmiennej - stosownie do tego typu następuje:

- pobranie odpowiedniej liczby bajtów z systemu TwinCAT z obszaru wskazywanego przez parę grupa:offset,

- konwersja odczytanych bajtów wg typu zdefiniowanego dla zmiennej.

Znacznik czasu

Wartościom zmiennych odczytanych z systemu TwinCAT jest nadawany stempel czasu PC.

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące - odpowiednio na zakładce o nazwie TwinCAT / Parametry drajwera lub TwinCATTcpip / Parametry drajwera w zależności od wersji drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece.Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślnie - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) informacji o poleceniach odczytu i zapisu realizowanych przez ADS. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie wartość opcji jest ustawiona na NIE.

R Log treści telegramów

Znaczenie - pozwala na zapisywanie treści telegramów danych do pliku logu.

R Rozmiar bufora

Znaczenie - pozwala określić maksymalną wielkość bufora używanego przy realizacji operacji odczytu i zapisu pomiędzy drajwerem CtTwinCAT oraz systemem TwinCAT. Ta opcja została dodana do drajwera CtTwinCAT z tego względu, że dokumentacja systemu TwinCAT nie precyzuje tej wartości..

Wartość domyślnie - domyślny rozmiar bufora wynosi 1800 bajtów.

Parametr:

liczba - rozmiar bufora w bajtach.

Testowanie komunikacji

Zakładka TwinCAT / Parametry drajwera - UniDriver (lub TwinCATTcpip / Parametry drajwera - UniDriver) pozwala określić parametry dotyczące szczegółowych informacji o błędach oraz informacji diagnostycznych. Informacje te zapisywane są w pliku o nazwie UniDriver.<bieżąca data>.log.

Parametry umieszczone na zakładkach Parametry drajwera - UniDriver obowiązują wszystkie kanały, które mają w deklaracji drajwera taką zakładkę. Parametry ustawione na zakładce Parametry drajwera - UniDriver w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera - UniDriver w definicji pozostałych kanałów.

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

Funkcja szybkiego odświeżania zmiennych

Standardowo zmienne odświeżane są przez moduł danych bieżących Asmen z częstotliwością wynoszącą minimum 1 sekundę. Funkcja szybkiego odświeżania zmiennych realizowana przez drajwer TwinCATTcpip (od wersji 1.3.5 począwszy) umożliwia odświeżanie zmiennych z maksymalna osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę). Zmienne objęte funkcją szybkiego odświeżania muszą mieć zadeklarowany w bazie definicji zmiennych atrybut FastRefresh, z wartością 1.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtVantage

Home > 1.113 Vantage - drajwer stacji pogodowych rodziny Vantage Pro od Davis Instruments Corp. USA

1.113 Vantage - drajwer stacji pogodowych rodziny Vantage Pro od Davis Instruments Corp. USA

Przeznaczenie drajwera

Drajwer Vantage służy do odczytu bieżących danych ze stacji pogodowych rodziny Vantage Pro produkowanych przez Davis Instruments Corp. USA. Do komunikacji jest wykorzystywany interfejs szeregowy.

Drajwer implementuje wyłącznie komendę ’LPS’ opisaną w dokumencie ’Vantage Pro, Vantage Pro2 and Vantage Vue Serial Communication Reference Manual Rev. 2.6.1 (03/29/2013)’ - Davis Instruments Part Number: 07395.801.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera Vantage wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji

Drajwer: Vantage

Zakładka Vantage/ parametry kanału:

Parametry kanału:

port=liczba; PredkoscTransmisji=liczba; Timeout=liczba; Okres=liczba; nrAlarmu=liczba

gdzie:

port - numer portu szeregowego;

PredkoscTransmisji - prędkość transmisji łącza szeregowego w Bd; domyślnie 19200;

Timeout - timeout oczekiwania na odpowiedź ze stacji (w milisekundach); domyślnie 2000 (ms);

Okres - okres (w sekundach) pomiędzy kolejnymi odczytami stacji; domyślnie 2 (sekundy);

nrAlarmu - numer alarmu Asixa w przypadku braku komunikacji ze stacją; Domyślnie drajwer nie generuje alarmu od braku komunikacji.

PRZYKŁAD

Poniżej podano przykład deklaracji kanału KANAL, w którym komunikacja odbywa się poprzez COM4, prędkość transmisji wynosi 19200 Bd, stacja jest odpytywana co 5 sekund, w przypadku braku komunikacji zgłaszany jest alarm o numerze 100.

Port=4; PredkoscTransmisji=19200; Okres=5; nrAlarmu=100

Deklaracja zmiennych

Adres symboliczny zmiennej ma poniższą składni:

C - stan komunikacji ze stacją (0 brak, 1 - o.k.)

V<offset> - wartość parametru przekazanego na pozycji offset w buforze odpowiedzi na polecenie LPS (LOOP2 Packet Format - strona 25/26 dokumentacji:

’r;Vantage Pro, Vantage Pro2 and Vantage Vue Serial Communication Reference

Manual Rev. 2.6.1 (03/29/2013)’ - Davis Instruments Part Number: 07395.801.)

Uwaga:

Drajwer w wersji 1.0 obsługuje wyłącznie poniższe parametry:

offset 3 // Ciśnienie trend 3-godzinny,

offset 7 // Ciśnienie,

offset 12 // Temperatura zewnętrzna,

offset 14 // WIATR Prędkość chwilowa,

offset 18 // WIATR Prędkość średnia 10 minutowa,

offset 16 // WIATR Kierunek,

offset 22 // WIATR Prędkość 10 minutowych porywów

offset 24 // WIATR Kierunek 10 minutowych porywów

offset 30 // Punkt rosy.

offset 33 // Wilgotność zewnętrzna,

offset 52 // Deszcz ilość opadu dla 15 min okresu czasu.

Przykłady deklaracji zmiennych:

Nazwa: X1

Opis: status komunikacji

Adres: C

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC

Nazwa: X2

Opis: cisnienie_3_godz

Adres: V3

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: X3

Opis: cisnienie

Adres: V7

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Nazwa: X4

Opis: temp zewnetrzna

Adres: V12

Kanał: KANAL1

Liczba elementów: 1

Okres próbkowania: 1

Funkcja przeliczająca: NIC_FP

Parametry drajwera

Drajwer jest parametryzowany przy użyciu osobnej sekcji [CTVANTAGE]. W sekcji można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

Nazwy pozycji związanych z plikiem logu nawiązują do konwencji stosowanej w innych drajwerach ASMENa.

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna: domyślnie plik logu nie jest tworzony.

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie: Pozycja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX

Wartość domyślna: NIE.

Parametry kanału

Parametry specyficzne dla kanału transmisji można określać przy użyciu indywidualnej sekcji mającej nazwę danego kanału. W sekcji można umieścić pozycje deklarujące:

  • tworzenie pliku logu,

  • rozmiar pliku logu,

  • log telegramów,

  • timeout znaku.

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: PLIK_LOGU
R Wartość opcji: nazwa_pliku

Znaczenie: Dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty dotyczące transmisji w danym kanale.

Wartość domyślna: Domyślnie komunikaty dotyczące kanału wpisywane są do pliku logu drajwera.

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: ROZMIAR_PLIKU_LOGU
R Wartość opcji: liczba

Znaczenie: Pozycja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu pozycji PLIK_LOGU danego kanału.

Wartość domyślna: Domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: LOG_TELEGRAMOW
R Wartość opcji: TAK|NIE

Znaczenie: Pozycja LOG_TELEGRAMOW pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu pozycji PLIK_LOGU danego kanału) zawartości telegramów przesyłanych w danym kanale. Wartość pozycji przeciąża Przedmiotowa pozycja powinna być wykorzystywana jedynie w fazie uruchamiania systemu ASIX.

Wartość domyślna: NIE.

R Nazwa sekcji: CTVANTAGE
R Nazwa opcji: TIMEOUT_ZNAKU
R Wartość opcji: TAK|NIE

Znaczenie: Pozycja TIMEOUT_ZNAKU określa maksymalny czas (w milisekundach) pomiędzy znakami odpowiedzi z urządzenia.

Wartość domyślna: Domyślna wartość timeout’u znaku wynosi 75 milisekund.

Parametr:

liczba - wartość timeout’u w milisekundach

PRZYKŁAD

Przykładowa sekcja drajwera:

[CTVANTAGE]

PLIK_LOGU=d:\tmp\CtVantage\stacja.log

ROZMIAR_PLIKU_LOGU=30

Przykładowa sekcja kanału:

[KANAL1]

PLIK_LOGU=d:\tmp\CtVantage\kanal_1.log

ROZMIAR_PLIKU_LOGU=20

LOG_TELEGRAMOW=TAK


CtWago

Home > 1.114 Wago - drajwer protokołu sterowników Wago

1.114 Wago - drajwer protokołu sterowników Wago

Przeznaczenie drajwera

Drajwer protokołu Wago służy do wymiany danych pomiędzy systemem Asix i sterownikami Wago. Wymiana danych odbywa się poprzez łącze Ethernet w trybie UDP w oparciu o ideę zmiennych sieciowych ("Network Variables") opisaną w "Network Functionality in CoDeSys V2.3" - Document Version 1.7.

Konstrukcja drajwera została oparta o następujące założenia:

a/ dla każdego sterownika tworzy się osobny zestaw 'zmiennych sieciowych', służący do komunikacji z drajwerem Wago. Zestaw posiada następujące atrybuty:

• 'Pack variables'

• 'Read'

• 'Write', 'Answer bootup requests'

• 'Transmit on change'

b/ zestaw 'zmiennych sieciowych' jest zapisany w pliku, którego nazwa jest parametrem w deklaracji kanału transmisji drajwera Wago,

c/ dla każdego sterownika definiuje się osobny kanał transmisji drajwera Wago,

d/ drajwer aktualizuje wartości zmiennych procesowych poprzez przechwytywanie ramek 'StateFree' wysyłanych ze sterowników na skutek zmiany wartości zmiennych sieciowych lub w efekcie pobudzenia sterowników przez drajwer ramkami typu 'BootUpRequest',

e/ drajwer wykonuje operacje zapisu wysyłając do sterownika ramkę typu 'StateFree'. Zakłada się, że w odpowiedzi sterownik wyśle ramkę 'StateFree', będącą efektem ustawienia parametru 'Transmit on change'.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu Wago wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału transmisji

Drajwer: Wago

Zakładka Wago/Parametry kanału:

Numer portu IP w sterowniku - numer portu IP w sterowniku. Domyślnie 1202;

Nazwa pliku SYM_XML wygenerowanego dla projektu CoDeSys - nazwa pliku SYM_XML wygenerowanego dla projektu CoDeSys realizowanego przez sterownik. Drajwer importuje z tego pliku definicje wszystkich typów użytych w projekcie CoDeSys. Istotne jest, aby plik SYM_XML został wygenerowany przy uwzględnieniu pliku zmiennych sieciowych - inaczej typy użyte wyłącznie w pliku zmiennych sieciowych nie będą widoczne w pliku SYM_XML;

Nazwa pliku z deklaracjami zmiennych sieciowych sterownika - nazwa pliku z deklaracjami zmiennych sieciowych sterownika (w projekcie CoDeSys realizowanym przez sterownik);

Identyfikator (COB-ID) przypisany zmiennym sieciowym - identyfikator (COB-ID) przypisany zmiennym sieciowym (w projekcie CoDeSys realizowanym przez sterownik);

Adres IP, na który są wysyłane polecenia Bootup Request (adres IP sterownika);

Numer alarmu braku komunikacji ze sterownikiem - numer alarmu w przypadku braku komunikacji ze sterownikiem.

Zakładka Wago/Parametry kanału 2:

Opcje związane z synchronizacją czasu ze sterownikiem:

Synchronizacja czasu - nazwa zmiennej w sterowniku, do której będzie przesyłana ramka czasu,

Struktura ramki czasu przesyłana do PLC ma następujący format:

struct dateTime

{

word wYear;

word wMonth;

word wDayOfWeek;

word wDay;

word wHour;

word wMinute;

word wSecond;

word wMilliseconds;

word wSynchr;

};

gdzie:

wYear - rok 1970 ~ 2106

wMonth - miesiąc 1 ~ 12 (Styczeń = 1, Luty = 2, itd)

wDayOfWeek - dzień tygodnia 0 ~ 6 (Niedz = 0, Pon = 1, itd)

wDay - dzień miesiąca 1 ~ 31;

wHour - godzina 0 ~ 23;

wMinute - minuta 0 ~ 59;

wSecond - sekunda 0 ~ 59;

wMilliseconds - milisekunda 0 ~ 999;

wSynchr - synchronizacja wpisywane 1 w momencie wysłania ramki do

sterownika

Okres synchronizacji czasu - okres czasu (w sekundach), co który ramka czasu będzie wysyłana do sterownika. Domyślnie przyjmuje się 60 sekund,

Synchronizacja czasu w trybie UTC - jeśli pozycja ma wartość TAK, to do synchronizacji czasu jest używany czas UTC. Jeśli pozycja ma wartość NIE, to do synchronizacji czasu jest używany czas lokalny. Domyślnie pozycja ma wartość NIE.

Pozostałe parametry:

Adres karty sieciowej komputera - opcja służy do określenia adresu karty sieciowej komputera, poprzez którą drajwer komunikuje się ze sterownikiem. Jeśli pozycja nie jest zadeklarowana, to drajwer użyje karty sieciowej dostarczonej przez system, co może prowadzić do braku łączności ze sterownikiem. Adres karty sieciowej w notacji IPv4.

Plik logu - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty zawierające treści datagramów wysyłanych i odbieranych ze sterownika.

Rozmiar pliku logu - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

PRZYKŁAD

Przykład deklaracji kanału transmisji:

Kanał/Nazwa: WAGO211

Numer portu IP w sterowniku: 1202

Adres IP sterownika: 255.255.255.255

Nazwa pliku SYM_XML wygenerowanego dla projektu CoDeSys: d:\Proj211.sym_xml

Nazwa pliku z deklaracjami zmiennych sieciowych sterownika: d:\Zm211.exp

Identyfikator (COB-ID) przypisany zmiennym sieciowym: 211

Adres IP, na który są wysyłane polecenia Bootup Request (adres IP sterownika): 10.10.105.211

Numer alarmu braku komunikacji ze sterownikiem: 1211

Synchronizacja czasu: Glob211ArrDt[1]

Okres synchronizacji czasu: 15

Synchronizacja czasu w trybie UTC: TAK

Deklaracja zmiennych

Drajwer akceptuje zmienne procesowe, których adresy symboliczne są zgodne z adresami symbolicznymi zmiennych projektu CoDeSys odczytanymi z pliku definicji zmiennych sieciowych (parametr ’Plik’ w deklaracji kanału transmisji). Adres symboliczny może dotyczyć zmiennych będących typami prostymi, elementami struktur lub tablic.

Uwaga:

W pliku definicji zmiennych sieciowych:

- może wystąpić tylko jedna sekcja VAR_GLOBAL ... VAR_END,

- nie są akceptowane inne sekcje niż VAR_GLOBAL ... VAR_END,

- komentarze mogą być umieszczane wyłącznie jako oddzielne, pojedyncze linie.

W sekcji otwierającej VAR_GLOBAL mogą znaleźć się opcje PERSISTENT oraz RETAIN.

Drajwer akceptuje typy proste CoDeSys o następujących nazwach:

BYTE

WORD

DWORD

UINT16

SINT

USINT

INT

INT16

DINT

REAL

LREAL

STRING

STRING()

TIME

TOD

DATE

DT

Uwaga:

Wartości zmiennych typu TIME, TOD, DATE, DT drajwer zwraca jako DWORD.

Drajwer importuje definicje wszystkich typów używanych w projekcie CoDeSys z pliku SYM_XML. Plik ten należy utworzyć w projekcie CoDeSys korzystając ze funkcji ’Project >Options->SymbolConfiguration->DumpXMLsymbolTable’. Nazwę pliku SYM_XML należy podać jako parametr "Sym” w deklaracji kanału transmisji.

Drajwer akceptuje typy enumeratywne zdefiniowane przez słowo kluczowe TypeEnum. Zakłada się, że składniki typów enumeratywnych są typu WORD.

PRZYKŁAD

Przykłady deklaracji zmiennych procesowych opartych o typy proste:

JJ_1, GlobalWord, Glob211Word, WAGO211, 1, 1, NIC

JJ_2, GlobalDw, Glob211Dw, WAGO211, 1, 1, NIC_DW

JJ_3, GlobalReal, Glob211Real, WAGO211, 1, 1, NIC_FP

JJ_4, GlobalInt, Glob211Int, WAGO211, 1, 1, NIC_INT

JJ_9, GlobalByte, Glob211Byte, WAGO211, 1, 1, NIC_BYTE

JJ_10,GlobalString, Glob211Str, WAGO211, 17, 1, NIC_TEXT

JJ_11,GlobalStringArr2, Glob211StrArr[2], WAGO211, 21, 1, NIC_TEXT

JJ_12,GlobalBool, Glob211Bool, WAGO211, 1, 1, NIC_BYTE

# tablica wykorzystywana do synchronizacji czasu - 9 elementow, typ WORD

JJ_13,GlobalDtArray, Glob211ArrDt[1], WAGO211, 9, 1, NIC

# 1-szy element tablicy wykorzystywanej do synchronizacji czasu

JJ_14,GlobalDtArray0, Glob211ArrDt[1], WAGO211, 1, 1, NIC

Zawartość pliku deklaracji zmiennych sieciowych, w oparciu o który zdefiniowano przekładowe zmienne procesowe:

VAR_GLOBAL

Glob211Bool: BOOL;

Glob211Word: WORD;

Glob211Str: STRING(16):='ala ma kota';

Glob211StrArr: ARRAY [1..4] OF STRING(20);

Glob211Cnt: INT;

Glob211Byte: BYTE;

Glob211Dw: DWORD;

Glob211Int: INT;

Glob211Real: REAL;

Glob211ArrDt: ARRAY [1..9] OF WORD;

END_VAR

PRZYKŁAD

Przykłady deklaracji zmiennych procesowych dla struktur:

TYPE stLevel3:

STRUCT

parL3_1: INT;

parL3_2: ARRAY [1..5] OF WORD;

END_STRUCT

END_TYPE

TYPE stLevel2:

STRUCT

parL2_1: INT;

parL2_2: ARRAY [1..5] OF stLevel3;

END_STRUCT

END_TYPE

TYPE stLevel1:

STRUCT

parL1_1: INT;

parL1_2: ARRAY [1..5] OF stLevel2;

END_STRUCT

END_TYPE

JJ_1, , testLevel[1].parL1_1, KANAL, 1, 1, NIC

JJ_2, , testLevel[2].parL1_2[2].parL2_1, KANAL, 1, 1, NIC

JJ_3, , testLevel[2].parL1_2[2].parL2_2[3].parL3_1, KANAL, 1, 1, NIC

JJ_4, , testLevel[5].parL1_2[5].parL2_2[5].parL3_2[5], KANAL, 1, 1, NIC

Zawartość pliku deklaracji zmiennych sieciowych, w oparciu o który zdefiniowano przekładowe zmienne procesowe dot. struktur:

VAR_GLOBAL

testLevel: ARRAY [1..5] OF stLevel1;

END_VAR

Parametry drajwera

Parametry drajwera Wago deklarowane są na zakładce Parametry drajwera / Parametry drajwera 2.

R Okres testu połączenia ze sterownikami

Znaczenie - opcja służy do określenia maksymalnego dopuszczalnego okresu czasu pomiędzy dwoma kolejnymi telegramami odebranymi ze sterownika. Po przekroczeniu tego czasu drajwer wysyła do sterownika polecenie 'Bootup request' aby wymusić przesłanie odpowiedzi ze sterownika. W przypadku braku odpowiedzi sygnalizowany jest brak połączenia ze sterownikiem.

Parametr:

liczba - max. dopuszczalny okres czasu pomiędzy dwoma kolejnymi telegramami odebranymi ze sterownika wyrażony w sekundach.

Wartość domyślna - domyślnie wartość pozycji wynosi 10 (sekund).

R Timeout odpowiedzi po sterowaniu

Znaczenie - opcja służy do określenia maksymalnego czasu, w którym powinien przyjść telegram typu 'Write on change' w odpowiedzi na sterowanie wysłane do sterownika. Po przekroczeniu tego czasu wysyłany jest telegram 'Bootup request' aby wymusić przesłanie telegramu ze sterownika. W przypadku braku odpowiedzi sygnalizowany jest błąd wykonania sterowania oraz brak połączenia ze sterownikiem.

Parametr:

liczba - max. dopuszczalny okres czasu pomiędzy wysłaniem sterowania i odbiorem telegramu 'Write on change' ze sterownika wyrażony w milisekundach.

Wartość domyślna - domyślnie wartość pozycji wynosi 500 (milisekund).

R Timeout odpowiedzi po żądaniu odświeżenia

Znaczenie - opcja służy do określenia maksymalnego czasu, w którym powinien przyjść telegram odpowiedzi na żądanie 'Bootup request' wysłane przez drajwer do sterownika. W przypadku braku odpowiedzi sygnalizowany jest brak połączenia ze sterownikiem.

Parametr:

liczba - max. dopuszczalny okres czasu pomiędzy wysłaniem 'Bootup request' i odbiorem telegramu odpowiedzi ze sterownika wyrażony w milisekundach.

Wartość domyślna - domyślnie wartość pozycji wynosi 500 (milisekund).

R Timeout pomiędzy poleceniami Bootup Request

Znaczenie - opcja służy do określenia zwłoki pomiędzy kolejnymi telegramami typu 'Bootup request' wysyłanymi na etapie startu drajwera do sterowników. Wartość tego parametru decyduje o czasie trwania rozbiegu aplikacji.

Parametr:

liczba - okres zwłoki pomiędzy kolejnymi telegramami 'Bootup request' wyrażony w milisekundach.

Wartość domyślna - domyślnie wartość pozycji wynosi 20 (milisekund).

R Plik logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

Parametr:

nazwa pliku

R Rozmiar pliku logu

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Parametr:

liczba - rozmiar pliku logu w MB.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

R Log telegramów

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie opcja jest wyłączona.

PRZYKŁAD

Przykładowa parametryzacja drajwera.

Drajwer: Wago

Plik logu: d:\tmp\CtWago\muel.log

Rozmiar pliku logu: 20

Log telegramów: TAK

Okres testu połączenia ze sterownikami: 20

Timeout odpowiedzi po sterowaniu: 700

Timeout odpowiedzi po zadaniu odświeżenia: 600

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

R Redundancja

Znaczenie - użycie tej opcji spowoduje wyszukiwanie kanału redundantnego, gdy w kanale lokalnym zostanie zerwane połączenie ze sterownikiem.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, do których można ograniczyć wyszukiwanie.

Wartość domyślna - domyślnie, po załączeniu opcji, kanał jest szukany na wszystkich komputerach.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


ZdarzenieZmienna

Home > 1.115 ZdarzenieZmienna

1.115 Drajwer ZdarzenieZmienna

Przeznaczenie drajwera

Drajwer ZdarzenieZmienna służy do generowania zmiennych procesowych typu WORD (słowo 16 bitowe) na podstawie bieżących wartości zdarzeń alarmowych w systemie Asix.

Parametryzacja drajwera ZdarzenieZmienna realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera ZdarzenieZmienna wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: ZdarzenieZmienna

Po uruchomieniu systemu Asix drajwer ZdarzenieZmienna otrzymuje od modułu ASMEN kolejno algorytm wyliczania wartości każdej zmiennej procesowej pobrany z bazy danych. Algorytm ten jest wykonywany przy każdym odczycie zmiennej i jego wynik staje się wartością zmiennej procesowej.

Zmienne dostarczane przez drajwer są zmiennymi tylko do odczytu.

Obliczanie wartości zmiennych

Moduł alarmów systemu Asix generuje wartości poszczególnych zdarzeń alarmowych, które są identyfikowane poprzez swój numer w pliku definicji alarmów.

Istnieją dwa sposoby określania wartości zdarzenia alarmowego:

  • zdarzenie alarmowe przyjmuje wartość 1, gdy alarm jest aktywny, 0- gdy nieaktywny;

  • zdarzenie alarmowe przyjmuje wartość 1, gdy alarm jest aktywny i niepotwierdzony, 0 - gdy aktywny i potwierdzony lub nieaktywny.

Zdarzenia alarmowe służą do wyliczenia zmiennych procesowych Asixa, identyfikowanych poprzez ich nazwę w całym systemie.

Definicja zmiennych ASMENa umieszczona w bazie zmiennych zawiera w sobie sposób obliczania wartości poszczególnych zmiennych systemu Asix.

Deklaracja każdej zmiennej ma następującą postać:

nazwa_zmiennej,opis_zmiennej,algorytm wyliczania wartości,kanał,1,częstość,NIC

Szczegółowy opis składowych tej linii znajduje się w: podręcznik ’A six - funkcjonalność i zasady działania’, rozdz. 6.2. Deklarowanie zmiennych procesowych.

Specyficzny dla opisywanego drajwera jest algorytm wyliczania wartości.

Istnieją trzy algorytmy operacji na zdarzeniach alarmowych generujące wartość zmiennej procesowej:

- złożenie zdarzeń alarmowych,

- suma logiczna zdarzeń alarmowych,

- iloczyn logiczny zdarzeń alarmowych.

Zdarzenie alarmowe jest traktowane jako numer alarmu w pliku alarmowym lub numer alarmu z przyrostkiem N. Przyrostek N oznacza, że zdarzenie alarmowe przyjmuje wartość 1 tylko wtedy, gdy alarm o danym numerze jest aktywny i niepotwierdzony.

Złożenie zdarzeń alarmowych

Postać algorytmu:

Złożenie:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

lub

MERGE:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

Wynikiem interpretacji tego algorytmu jest liczba, której bit 0 ma wartość równą pierwszej zmiennej alarmowej, bit 1 drugiej zmiennej alarmowej itd. Algorytm, może zawierać maksymalnie 16 zmiennych alarmowych.

Przykład

MERGE: 11; 12; 13N

W algorytmie można pomijać zmienne alarmowe i wtedy stan bitu odpowiadającego pominiętej zmiennej alarmowej zawsze wynosi 0.

PRZYKŁAD

MERGE: 11; ; 13; ;15; 16

Bity 1 i 3 zawsze będą miały wartość zero.

Suma logiczna zdarzeń alarmowych

Postać algorytmu:

SumaLogiczna:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

lub

OR:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

Wynikiem interpretacji tego algorytmu jest wartość 1, jeżeli choć jedna ze zmiennych alarmowych ma wartość 1, 0 - w przeciwnym wypadku. Algorytm może zawierać maksymalnie 16 zmiennych alarmowych.

Przykład

OR: 11N; 12; 13

Iloczyn logiczny zdarzeń alarmowych

Postac algorytmu:

IloczynLogiczny:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

lub

AND:<Zdarzenie alarmowe>; <Zdarzenie alarmowe>; ...

Wynikiem interpretacji tego algorytmu jest wartość 1, jeżeli wszystkie zmienne alarmowe mają wartość 1, 0 - w pozostałych wypadkach. Algorytm może zawierać maksymalnie 16 zmiennych alarmowych.

Przykład

AND: 11; 12N; 13N

Uzależnianie wartości zdarzeń alarmowych od statusu wartości

Powyższe trzy algorytmy mogą się także posługiwać zdarzeniami alarmowymi, których wartość pobrana z modułu alarmowego jest jeszcze korygowana przez stan innego zdarzenia alarmowego traktowanego jako status. Wówczas należy stosować zapis: zdarzenie alarmowe/status np.101/102. Gdy status jest równy 0 - nie zmienia wartości zdarzenia alarmowego. W przeciwnym przypadku generowany jest błąd pomiaru dla wszystkich zmiennych procesowych Asixa, wyliczanych na podstawie tego statusu.

Przykład

AND: 11/110; 12; 13

lub

OR: 11; 12/120; 13/130

Przykład zastosowania drajwera ZdarzenieZmienna

Zadaniem naszym jest spowodowanie migotania tekstu na masce przy jednoczesnym przekroczeniu ograniczeń dla dwóch temperatur T1 i T2. Sygnały dwustanowe o przekroczeniu odpowiednich temperatur otrzymujemy z obiektu. Zakładamy, że alarmy w systemie są już uruchomione i istnieje plik definicji alarmów.

Deklaracje w pliku konfiguracyjnym aplikacji

W pliku konfiguracyjnym dla aplikacji deklarujemy kanał o nazwie EVENT:

Nazwa: EVENT

Drajwer: ZdarzenieZmienna

Uzupełnienie pliku definicji alarmów

W pliku alarmów należy dopisać dwa alarmy sygnalizujące przekroczenie temperatur T1 i T2. Przykładowo umieszczamy je pod numerami: 101 dla przekroczenia temperatury T1 i 102 dla przekroczenia temperatury T2:

101,AL,Przekroczenie+ temperatury T1

102,AL,Przekroczenie temperatury T2

Zadeklarowanie zmiennych ASMENa

Należy zadeklarować nową zmienną przy wykorzystaniu Architekta.

Zmienna procesowa powinna przyjmować wartość 1, gdy oba alarmy 101 i 102 będą aktywne (przyjmą wartość 1), w przeciwnym przypadku wartość zmiennej procesowej powinna wynosić 0. Nazwijmy ją T1_T2_MAX.

Deklaracja zmiennej powinna zawierać następujące elementy:

T1_T2_MAX,Zmienna procesowa przekroczenia T1 i T2,AND:101;102,EVENT,1,1,NIC

Umieszenie na masce aplikacji obiektu teksty

Po otwarciu maski po Konstruktorem na leży umieścić na niej obiekt teksty i sparametryzować go na naszą zmienną T1_T2_MAX. Obiekt musi posiadać dwa stany. Dla wartości zmiennej monitorowanej 0 wyświetlany jest tekst Temperatury T1 i T2.Dla wartości "1" pojawia się tekst Przekroczenie temperatury T1 i T2 z atrybutem migania.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.


CtZxD400 - drajwer protokołu liczników energii serii

Home > 1.116 ZxD400 - drajwer protokołu liczników energii serii ZxD400 f-my Landys & Gyr

1.116 ZxD400 - drajwer protokołu liczników energii serii ZxD400 f-my Landys & Gyr

Przeznaczenie drajwera

Drajwer protokołu ZxD400 służy do wymiany danych pomiędzy systemem Asix i licznikami energii elektrycznej typu ZxD400 f-my Landys & Gyr poprzez interfejs RS-485 przedmiotowych liczników, a także licznikami A1500 firmy Elster. Drajwer nie jest przystosowany do wymiany danych poprzez złącze optyczne, ponieważ wymaga ono użycia protokołu ze wstępną negocjacją prędkości transmisji.

Drajwer pozwala na odczyt rejestrów rozliczeniowych licznika oraz rejestrację w plikach danych odczytanych komendami Read Log Book oraz Read Load Profile.

Parametryzacja drajwera ZxD400 realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Deklaracja kanału transmisyjnego działającego według protokołu drajwera ZxD400 wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: ZxD400

Zakładka ZxD400 / parametry kanału:

Port szeregowy - numer portu szeregowego COM;

Prędkość transmisji - prędkość transmisji między komputerem a urządzeniem; dopuszczalne są następujące prędkości: 1200,2400, 4800, 9600, 19200, 38400 Bd; domyślna wartość wynosi 2400 Bd;

Okres - okres czasu (w sekundach) pomiędzy kolejnymi odczytami rejestrów licznika. Domyślna wartość wynosi 10 sekund.

PRZYKŁAD

Poniżej podana jest przykładowa deklaracja użycia kanału transmisji pracującego według protokołu CtZxD400:

Nazwa/Kanał: KANAL

Drajwer: CtZxD400

Parametry kanału:

Port szeregowy: 2

Prędkość transmisji: 20

Okres: 9600

Deklaracja zmiennych

Adres zmiennej ma składnię:

"[nazwa_licznika]/kod_rejestru"

gdzie:

nazwa_licznika - (opcja); zawiera unikalną nazwę adresową licznika używaną w instalacjach multipoint do identyfikacji poszczególnych liczników;

nazwa_licznika - odpowiada Device address wg PN-EN 61107; przy połączeniu point-point nazwa_licznika może być pominięta;

kod_rejestru - kod i indeks rejestru licznika, zgodny z listą odczytową, która została wprowadzona do liczniku przez producenta na etapie parametryzacji.

UWAGA Wartości wszystkich zmiennych są typu FLOAT.

PRZYKŁAD

/* C.1.0 - numer identyfikacyjny licznika */

JJ_01, numer identyfikacyjny licznika, "/C.1.0", KANAL, 1, 1, NIC_FP

/* 1.8.0 - rejestr pobranej energii czynnej */

JJ_03, rejestr pobranej energii czynnej, "/1.8.0", KANAL, 1, 1, NIC_FP

/* C.8.0 - całkowity czas pracy */

JJ_03, całkowity czas pracy, "/C.8.0", KANAL, 1, 1, NIC_FP

Parametry drajwera

Parametry drajwera ZxD400 deklarowane są w module Dane bieżące na zakładce ZxD400 / Parametry drajwera kanału działającego według protokołu drajwera ZxD400.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które maja zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Nazwa opcji: Plik logu
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

R Nazwa opcji: Rozmiar pliku logu
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa opcji: Log telegramów
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych pomiędzy drajwerem i sterownikami. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa opcji: Plik logu historii
R Wartość opcji: nazwa_pliku_logu

Znaczenie - opcja pozwala na zapisywanie do pliku logów komunikatów o operacjach wykonywanych na interfejsie dostępu do historycznych wartości zmiennych profilowych. Plik logu historii jest wspólny dla wszystkich liczników. Rozmiar pliku logu historii jest taki sam jak rozmiar pliku logu drajwera.

Wartość domyślna - domyślnie plik logu nie jest tworzony.

PRZYKŁAD

Przykładowa deklaracja.

Drajwer: CtZxD400

Nazwa opcji: Plik logu

Wartość opcji: d:\tmp\CtZxD400\ak.log

Nazwa opcji: Rozmiar pliku logu

Wartość opcji: 3

Nazwa opcji: Log telegramów

Wartość opcji: TAK

Opcje związane z możliwością zawieszania odczytu licznika w okresie, gdy licznik wylicza zamknięcia dobowe, dekadowe oraz miesięczne.

R Nazwa opcji: Okres zawieszenia odczytu

R Wartość opcji: liczba_sekund

Znaczenie: Pozycja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Nazwa opcji: Zawieszenie odczytu - dobowe

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa opcji: Zawieszenie odczytu dekadowe

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa opcji: Zawieszenie odczytu - miesięczne

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Parametry poszczególnych liczników

Drajwer pozwala na przekazanie zestawu indywidualnych parametrów dotyczących obsługi poszczególnych liczników. Parametryzacji takiej dokonuje się na zakładce Liczniki.

R Nazwa opcji: Nazwa licznika

R Nazwa opcji: Znacznik czasu
R Wartość opcji: kod_rejestru [,kod_rejestru]

Znaczenie - opcja pozwala zdefiniować rejestr (lub dwa rejestry), który zawiera znacznik daty i czasu przekazany z licznika. Przyjmuje się, że jeśli jest podany jeden rejestr, to zawiera datę i czas w formacie YY-MM-DD hh:mm:ss. Jeśli jest podana para rejestrów, to przyjmuje się, że pierwszy rejestr zawiera datę w formacie YY-MM-DD, a drugi rejestr zawiera czas w formacie hh:mm:ss.

Jeśli opcja nie zostanie użyta, to przyjmuje się, że wartościom przesłanym z licznika zostanie przypisany znacznik daty i czasu PC z chwili zakończenia odbioru przesyłki.

Wartość domyślna - domyślnie przyjmuje się, że wartościom przesłanym z licznika jest przypisywany znacznik daty i czasu PC.

R Nazwa opcji: Maksymalna długość bufora
R Wartość opcji: liczba

Znaczenie - maksymalny rozmiar bufora odbiornika.

Wartość domyślna - 100000.

Parametr:

liczba - pojemność w bajtach.

R Nazwa opcji: Okres zawieszenia odczytu
R Wartość opcji: liczba

Znaczenie - Pozycja określa czas, przez który zawieszony jest odczyt licznika. Odczyt danych zostaje zawieszony podana liczbę sekund przed północą i wznowiony podaną liczbę sekund po północy. Liczba 0 oznacza brak zawieszenia odczytu. W okresie zawieszenia odczytu wartości zmiennych bieżących opatrywane są statusem OPC_QUALITY_UNCERTAIN.

Wartość domyślna - 0.

R Nazwa opcji: Zawieszenie odczytu - dobowe

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa opcji: Zawieszenie odczytu - dekadowe

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa opcji: Zawieszenie odczytu - miesięczne

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa opcji: Plik logu
R Wartość opcji: nazwa_pliku_logu

Znaczenie - dla celów diagnostycznych służy tekstowy plik logu, do którego są wpisywane komunikaty o stanie pracy licznika.

Wartość domyślna - domyślnie komunikaty zapisywane do pliku logu drajwera.

R Nazwa opcji: Rozmiar pliku logu
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu, zdefiniowanego przy użyciu opcji Plik logu.

Wartość domyślna - domyślnie rozmiar pliku logu wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa opcji: Log telegramów
R Wartość opcji: TAK | NIE

Znaczenie - opcja pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) zawartości telegramów przesyłanych dla danego licznika.

Wartość domyślna - domyślnie wartość opcji jest ustawiona na NIE.

R Nazwa opcji: Log zdarzeń
R Wartość opcji: nazwa_pliku_logu

Znaczenie - zdarzenia odczytane z licznika są zapisywane do pliku tekstowego w formacie csv. Każde zdarzenie jest zapisane w oddzielnej linii. Zdarzenia w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać zdarzenia jest podana poniżej:

P.98;1;2005-05-10 08:14:33;0048;;3;;;F.F;;1.8.0;kWh;024;00000000;0000.0000

Opcja Plik logu zdarzeń pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log zdarzeń.

Wartość domyślna - domyślnie plik logu zdarzeń nie jest tworzony.

R Nazwa opcji: Rozmiar pliku logu zdarzeń
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu zdarzeń, zdefiniowanego przy użyciu opcji Plik logu zdarzeń.

Wartość domyślna - domyślnie rozmiar pliku logu zdarzeń wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa opcji: Bez logu zdarzeń
R Wartość opcji: liczba

Znaczenie - opcja służy do zadeklarowania braku odczytu zdarzeń z licznika i nie zapisywania ich do pliku logu.

Wartość domyślna - domyślnie opcja wyłączona.

R Nazwa opcji: Okres odczytu logu zdarzeń
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia cyklu (w godzinach) odczytu logu zdarzeń z licznika.

Wartość domyślna - domyślnie odczyt logu zdarzeń odbywa się co 1 godzinę.

Parametr:

liczba - cykl odczytu logu zdarzeń (w godzinach).

R Nazwa opcji: Log profili mocy
R Wartość opcji: nazwa_pliku_logu

Znaczenie - profile odczytane z licznika są zapisywane do pliku tekstowego w formacie csv. Każdy profil jest zapisany w oddzielnej linii. Profile w pliku są uporządkowane wg narastających znaczników czasu. Przykładowa postać profilu jest podana poniżej (dla zwiększenia przejrzystości przykładowy profil został rozbity na dwie linijki tekstu):

P.01;1;2005-05-10 12:45:00;0008;15;6;1.5.0;kW;5.5.0;kvar;8.5.0;kvar;

32.7;V;52.7;V;72.7;V;0.0000;0.0000;0.0000;---.-;---.-;---.-

Opcja Plik logu profili pozwala zdefiniować ścieżkę do pliku, w którym będzie zapisywany log profili.

Wartość domyślna - domyślnie plik logu profili nie jest tworzony.

R Nazwa opcji: Rozmiar pliku logu profili
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia rozmiaru pliku logu profili, zdefiniowanego przy użyciu opcji Plik logu profili.

Wartość domyślna - domyślnie rozmiar pliku logu profili wynosi 10 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Nazwa opcji: Bez logu profili mocy
R Wartość opcji: liczba

Znaczenie - opcja służy do zadeklarowania braku odczytu profili mocy z licznika i nie zapisywania ich do pliku logu.

Wartość domyślna - domyślnie opcja wyłączona.

R Nazwa opcji: Okres odczytu logu profili
R Wartość opcji: liczba

Znaczenie - opcja służy do określenia cyklu (w godzinach) odczytu logu profili z licznika.

Wartość domyślna - domyślnie odczyt logu profili odbywa się co 1 godzinę.

Parametr:

liczba - cykl odczytu logu profili (w godzinach).

R Nazwa opcji: Horyzont odczytu historii profili mocy
R Wartość opcji: liczba

Znaczenie - opcja służy do deklarowania okresu historii profili mocy w dniach od początku bieżącej doby.

Wartość domyślna - 2.

Parametr:

liczba - czas wyrażony w dniach.

R Nazwa opcji: Dane logu zdarzeń
R Wartość opcji: TAK|NIE

Znaczenie - przy użyciu opcji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii logu zdarzeń należy zapisać do logu drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się szczegółów parsowania zdarzeń do logu drajwera.

R Nazwa opcji: Dane logu profili
R Wartość opcji: TAK|NIE

Znaczenie - przy użyciu opcji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii logu profili należy zapisać do logu drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się szczegółów parsowania profili do logu drajwera.

R Nazwa opcji: Dane odczytowe
R Wartość opcji: TAK|NIE

Znaczenie - przy użyciu opcji deklaruje się, czy szczegółowy opis parsowania poszczególnych linii danych odczytowych licznika należy zapisać do logu drajwera. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślna - domyślnie nie zapisuje się szczegółów parsowania danych odczytowych do logu drajwera.

PRZYKŁAD

Przykładowa deklaracja licznika.

Licznik w kanale KANAL. Licznikowi nie nadano nazwy.

Nazwa opcji: Znacznik czasu
Wartość opcji: 0.9.2, 0.9.1

Nazwa opcji: Log zdarzeń

Wartość opcji: c:\tmp\ctZxD400\book.log

Nazwa opcji: Rozmiar pliku logu zdarzeń

Wartość opcji: 4

Nazwa opcji: Okres odczytu logu zdarzeń

Wartość opcji: 1

Nazwa opcji: Log profili mocy

Wartość opcji: c:\tmp\ctZxD400\profile.log

Nazwa opcji: Rozmiar pliku logu profili

Wartość opcji: 2

Nazwa opcji: Okres odczytu logu profili

Wartość opcji: 1

Nazwa opcji: Dane logu zdarzeń

Wartość opcji: TAK

Nazwa opcji: Dane logu profili

Wartość opcji: TAK

Testowanie komunikacji

Zakładka ZxD400 / Parametry drajwera - UniDriver pozwala określić parametry dotyczące szczegółowych informacji o błędach oraz informacji diagnostycznych. Informacje te zapisywane są w pliku o nazwie UniDriver.<bieżąca data>.log.

Parametry umieszczone na zakładkach Parametry drajwera - UniDriver obowiązują wszystkie kanały, które mają w deklaracji drajwera taką zakładkę. Parametry ustawione na zakładce Parametry drajwera - UniDriver w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera - UniDriver w definicji pozostałych kanałów.

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

Parametry kanału

Parametry kanału deklarowane na zakładce Zaawansowane:

R Zezwolenie zapisu

Znaczenie - użycie tej opcji zezwoli wszystkim komputerom na zdalne sterowanie w tym kanale (domyślnie tylko lokalne programy mogą modyfikować wartości zmiennych); można tez zadeklarować listę nazw sieciowych komputerów, które uzyskają zezwolenie na zdalne sterowanie.

Wartość opcji:

TAK / NIE

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na zdalne sterowanie (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - NIE - domyślnie tylko lokalne komputery mogą modyfikować wartości zmiennych.

R Ograniczenie odczytu

Znaczenie - użycie tej opcji spowoduje ograniczenie komputerów czytających dane do komputerów o podanych nazwach sieciowych.

Wartość opcji:

nazwa komputera - lista nazw sieciowych komputerów, które będą miały zezwolenie na czytanie danych (nazwy sieciowe mogą zawierać maksymalnie 15 znaków; nazwy oddzielone przecinkami).

Wartość domyślna - domyślnie wszystkie komputery mogą czytać zmienne.

***

Parametry kanału deklarowane na zakładce Zaawansowane2:

R Blokada zapisu lokalnego

Znaczenie - użycie tej opcji blokuje lokalne sterowania w kanale.

Wartość opcji:

TAK / NIE

Wartość domyślna - NIE.

R Czas ważności danych

Znaczenie - opcja określa czas, przez który wartości zmiennych w kanale zachowują ważność; opcję należy użyć tylko wtedy, gdy czasowy brak danych nie powinien być traktowany jako błąd.

Wartość opcji:

liczba - czas podany w sekundach; należy podać wartość (znacznie) większą niż najdłuższy okres odświeżania zmiennej w kanale.

Wartość domyślna - domyślnie nie ma ustalonego czasu ważności danych.

Dodatkowe parametry kanału

Parametry kanału drajwera ZxD400 deklarowane w module Pozostałe na zakładce Opcje wprowadzane bezpośrednio:

Parametry drajwera umieszczane są w sekcji o nazwie kanału.

Opcje związane z możliwością zawieszania odczytu licznika w okresie, gdy licznik wylicza zamknięcia dobowe, dekadowe oraz miesięczne.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: OKRES_ZAWIESZENIA_ODCZYTU

R Wartość opcji: liczba_sekund

Znaczenie: Pozycja określa czas, przez który zawieszony jest odczyt licznika w okolicach północy (tzn. wyłączenie odczytu - liczba_sekund - północ - liczba_sekund - włączenie odczytu). Przy ustalaniu wartości opcji trzeba uwzględnić pewne przesunięcie w czasie momentu wyłączenia odczytu, bo moment wyłączenia może wypaść w trakcie transmisji danych bieżących (kilkanaście sekund ?). Dla pozostałych kategorii danych jest to przesunięcie rzędu kilku sekund. Ustawienia w sekcji kanału przeciążają ustawienia w sekcji drajwera.

Wartość opcji:

liczba_sekund - czas mierzony w sekundach.

Wartość domyślna: Domyślnie opcja ma wartość 0 (tzn. nie zawiesza się odczytu).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_DOBOWE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dobowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

Ustawienia w sekcji kanału przeciążają ustawienia w sekcji drajwera.

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_DEKADOWE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie dekadowym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).

R Nazwa sekcji: <nazwa_kanału>

R Nazwa opcji: ZAWIESZENIE_ODCZYTU_MIESIECZNE

R Wartość opcji: TAK/NIE

Znaczenie: Pozycja umożliwia zawieszenie odczytu licznika w rytmie miesięcznym.

Wartość domyślna: Domyślnie wartość pozycji jest ustawiona na NIE (odczyt nie jest zawieszany).


1.91. CtTwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu

Home > 1.91. CtTwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu

1.91. CtTwinCAT - drajwer protokołu ADS/AMS over TCPIP systemu TwinCAT

Przeznaczenie drajwera

Drajwer CtTwinCAT jest przeznaczony do wymiany danych pomiędzy systemem Asix i systemem TwinCAT firmy Beckhoff Industrie Elektronik. Komunikacja pomiędzy systemami realizowana jest poprzez Ethernet w dwóch trybach, w zależności od tego, w jaki firmware wyposażony jest sterownik Beckhoff.

Istnieją dwie wersje drajwera CtTwinCAT:

  1. CtTwinCat.dll - korzysta z biblioteki TcAdsDll dostarczanej przez Beckhoffa.

  2. CtTwinCatTcpip.dll - korzysta z interfejsu ADS/AMS over TCPIP (bez użycia bibliotek Beckhoff'a).

Drajwer CtTwniCAT obsługuje następujące urządzenia:

- sterowniki serii CX1000,

- TwinCAT PLC (PC based control system),

- STEROWNIKI SERII BC9000,

- STEROWNIKI SERII BX9000.

Parametryzacja drajwera CtTwinCAT realizowana jest przy użyciu programu Architekt.

Deklaracja kanału transmisji

Drajwer CtTwinCAT jest ładowany poprzez uniwersalny drajwer systemu Asix - UNIDRIVER.

Deklaracja kanału transmisji korzystającego z drajwera CtTwinCat.dll

Deklaracja kanału transmisyjnego działającego według protokołu drajwera CtTwinCAT wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: CtTwinCAT

Zakładka TwinCAT / Parametry kanału:

Numer portu routera systemu TwinCAT

Adres AMS (4 pierwsze elementy) routera systemu TwinCAT

Timeout - timeout oczekiwania na wykonanie operacji ADS’a w danym kanale (w milisekundach); domyślna wartość wynosi 5000 ms

Synchronizacja czasu - adres w sterowniku, do którego będzie wysyłana ramka czasu Okres synchronizacji czasu - okres czasu (w sekundach), co który ramka czasu będzie wysyłana do sterownika

Typ obsługi - typ obsługi

Numer alarmu stanu Stop - pozwala na generowanie alarmu przy przejściu PLC na stan STOP

PRZYKŁAD

Przykład deklaracji kanału korzystającego z zasobu RTS1 na komputerze o adresie AMS 10.10.10.254 i timeout-ie 100 ms z synchronizacją czasu poprzez tablicę bajtów, znajdującą się pod adresem symbolicznym .tabWord:

Nazwa: PLC1

Drajwer: CtTwinCAT
Numer portu routera systemu TwinCAT: 801

Adres AMS routera systemu TwinCAT: 10.10.10.254

Timeout: 100

Synchronizacja czasu: .tabWord

Deklaracja kanału transmisji korzystającego z drajwera CtTwinCatTcpip.dll

Deklaracja kanału logicznego transmisji danych działającego według protokołu drajwera CtTwinCATTcpip wymaga dodania do modułu Dane bieżące kanału z następującymi parametrami:

Zakładka Standardowe:

Nazwa: nazwa logiczna kanału logicznego transmisji
Drajwer: CtTwinCATTcpip

Alarm w kanale: numer alarmu zgłaszanego w przypadku zerwania połączenia ze sterownikiem

Zakładka TwinCATTcpip / Parametry kanału:

AMS Net Id systemu Asix (4 pierwsze elementy) - adres AmsNetId systemu Asix, który wraz z IP komputera, na którym działa Asix, tworzy parę identyfikującą połączenie Asix <--> sterownik; w/w para musi mieć swój odpowiednik w tablicy route'ów projektu sterownika, aby możliwa była wymiana danych; zazwyczaj przyjmuje się (dla uproszczenia parametryzacji połączeń), że adres AmsNetId systemu Asix jest taki sam jak adres IP komputera

Adres IP sterownika

AMS Net Id sterownika

Numer portu sterownika

Adres IP komputera - adres IP komputera, przez który kanał komunikuje się ze sterownikiem. Domyślnie kanał korzysta z adresu IP dostarczonego przez system Windows.

Rozmiar bufora - pozwala określić maksymalną wielkość bufora używanego przy realizacji operacji odczytu i zapisu pomiędzy drajwerem CtTwinCAT oraz systemem TwinCAT

Synchronizacja UTC - synchronizacja czasu stacji Asixa z czasem sterownika w trybie UTC

Timeout - timeout oczekiwania na wykonanie operacji ADS’ w danym kanale (w milisekundach)

Synchronizacja czasu - adres w sterowniku, do którego będzie wysyłana ramka czasu; adres może być podany w postaci symbolicznej lub bezwzględnej (pkt 3.)

Okres Synchronizacji Czasu - okres czasu (w sekundach), co który ramka czasu będzie wysyłana do sterownika; domyślnie przyjmuje się 60 sekund

Typ obsługi - pozwala na deklarację typu sterownika obsługiwanego na danym połączeniu - typ obsługi: CX,PC-PLC (1), BX9000 (2), BC9000 (2); domyślnie przyjmuje się 1.

Nr Alarmu Stanu Stop - pozwala na generowanie alarmu przy przejściu PLC na stan STOP.

Wersja - wersja oprogramowania w sterowniku (asix współpracuje z wersja 0 oraz 1). Opcja ma znaczenie tylko wtedy, gdy sterownik dostarcza dane historyczne).

PRZYKŁAD

Nazwa: Kanal

Drajwer: CtTwinCATcpip

Numer portu sterownika: 801

Adres AMS Net Id systemu asix: 5.0.70.215

Adres IP sterownika: 10.10.10.119

Adres Ams Net Id sterownika: 10.10.10.191

Typ obsługi: 1

Struktura ramki czasu przesyłana do PLC ma następujący format:

struct dateTime

{

word wYear;

word wMonth;

word wDayOfWeek;

word wDay;

word wHour;

word wMinute;

word wSecond;

word wMilliseconds;

word wSynchr;

};

gdzie:

wYear - rok 1970 ~ 2106

wMonth - miesiąc 1 ~ 12 (Styczeń = 1, Luty = 2, itd)

wDayOfWeek - dzień tygodnia 0 ~ 6 (Niedz = 0, Pon = 1, itd)

wDay - dzień miesiąca 1 ~ 31;

wHour - godzina 0 ~ 23;

wMinute - minuta 0 ~ 59;

wSecond - sekunda 0 ~ 59;

wMilliseconds - milisekunda 0 ~ 999;

wSynchr - synchronizacja wpisywane 1 w momencie wysłania

Zakładka TwinCATTcpip / Parametry kanału - historia:

Numer grupy - numer grupy (w HEX), w której przechowywane są dane historyczne

Ofset danych historycznych - ofset w ramach grupy (w HEX), od którego rozpoczyna się obszar danych historycznych

Liczba zmiennych - liczba zmiennych historycznych

Ofset zapytań - ofset w ramach grupy (w HEX), od którego rozpoczyna się bufor poleceń systemu Asix

Ofset odpowiedzi - ofset w ramach grupy (w HEX), od którego rozpoczyna się bufor odpowiedzi na polecenia systemu Asix

Zwłoka zapytań - spodziewany czas oczekiwania na wykonanie polecenia odczytu danych historycznych ze sterownika w sekundach

Zakładka TwinCATTcpip / Parametry kanału - log:

R Plik logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece. Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślnie - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) informacji o poleceniach odczytu i zapisu realizowanych przez ADS. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie wartość opcji jest ustawiona na NIE.

R Log treści telegramów

Znaczenie - pozwala na zapisywanie treści telegramów danych do pliku logu.

Adresacja zmiennych

Dopuszcza się dwa rodzaje adresów:

  • symboliczny - poprzez podanie adresu symbolicznego zmiennej w systemie TwinCAT. Składnia adresu symbolicznego jest następująca:

[<tekst1>].<tekst2>

gdzie:

tekst1, tekst2 - łańcuch znaków ASCII

Adresy symboliczne wszystkich zmiennych projektu realizowanego w systemie TwinCAT znajdują się w kartotece przedmiotowego projektu w XML-owym pliku o rozszerzeniu *.tpy - adresy symboliczne znajdują się w sekcjach identyfikowanych przez słowo kluczowe <Symbol>.

  • bezpośredni - poprzez podanie pary liczb, określających numer grupy i numer offsetu w ramach grupy. Obie liczby podane są w formacie HEX i są rozdzielone znakiem dwukropka.

Przykład adresu symbolicznego:

.engine

MAIN.devUP

Przykład adresu bezpośredniego:

F030:03EA

PRZYKŁAD

Przykłady deklaracji zmiennych:

JJ_00, zmienna typu REAL o nazwie valFloat,.valFloat,PLC1, 1, 1, NIC_FP

JJ_01, zmienna typu WORD o nazwie valWord,.valWord,PLC1, 1, 1, NIC

JJ_02, zmienna typu BOOL o nazwie MAIN.engine,MAIN.engine,PLC1, 1, 1, NIC_BYTE

JJ_03, zmienna typu BYTE o adresie F030:5 (%QB5),F030:5,PLC1, 1, 1, NIC_BYTE

Typy zmiennych

Dla zmiennych adresowanych symbolicznie typ zmiennej jest pobierany z systemu TwinCAT poprzez odczyt mapy symboli. Typ używany w systemie TwinCAT jest następnie konwertowany na typ żądany przez użytkownika.

Dla zmiennych adresowanych bezpośrednio za typ zmiennej jest przyjmowany typ rzeczywisty funkcji przeliczającej zdefiniowanej dla przedmiotowej zmiennej - stosownie do tego typu następuje:

- pobranie odpowiedniej liczby bajtów z systemu TwinCAT z obszaru wskazywanego przez parę grupa:offset,

- konwersja odczytanych bajtów wg typu zdefiniowanego dla zmiennej.

Znacznik czasu

Wartościom zmiennych odczytanych z systemu TwinCAT jest nadawany stempel czasu PC.

Parametry drajwera

Parametry drajwera deklarowane są w module Dane bieżące - odpowiednio na zakładce o nazwie CtTwinCAT / Parametry drajwera lub CtTwinCATTcpip / Parametry drajwera w zależności od wersji drajwera.

Parametry umieszczone na zakładkach Parametry drajwera obowiązują wszystkie kanały, które mają zadeklarowany ten sam drajwer. W przypadku kilku kanałów działających w oparciu o wybrany drajwer - parametry ustawione na zakładkach Parametry drajwera w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera w definicji pozostałych kanałów.

R Plik logu

Znaczenie - pozwala na zdefiniowanie pliku, do którego będą zapisywane wszystkie komunikaty diagnostyczne drajwera. Jeśli opcja Plik logu nie definiuje pełnej ścieżki, to plik logu zostanie utworzony w bieżącej kartotece.Plik logu powinien być wykorzystywany jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie nie tworzy się pliku logu.

Parametr:

nazwa_pliku - nazwa pliku logu.

R Rozmiar pliku logu

Znaczenie - pozwala określić rozmiar pliku logu w MB.

Wartość domyślnie - domyślnie opcja przyjmuje, że plik logu ma rozmiar 1 MB.

Parametr:

liczba - rozmiar pliku logu w MB.

R Log telegramów

Znaczenie - pozwala na zapisywanie do pliku logu (zadeklarowanego przy użyciu opcji Plik logu) informacji o poleceniach odczytu i zapisu realizowanych przez ADS. Przedmiotowa opcja powinna być wykorzystywana jedynie w fazie uruchamiania systemu Asix.

Wartość domyślnie - domyślnie wartość opcji jest ustawiona na NIE.

R Log treści telegramów

Znaczenie - pozwala na zapisywanie treści telegramów danych do pliku logu.

R Maksymalna długość bufora

Znaczenie - pozwala określić maksymalną wielkość bufora używanego przy realizacji operacji odczytu i zapisu pomiędzy drajwerem CtTwinCAT oraz systemem TwinCAT. Ta opcja została dodana do drajwera CtTwinCAT z tego względu, że dokumentacja systemu TwinCAT nie precyzuje tej wartości..

Wartość domyślnie - domyślny rozmiar bufora wynosi 1800 bajtów.

Parametr:

liczba - rozmiar bufora w bajtach.

Testowanie komunikacji

Zakładka TwinCAT / Parametry drajwera - UniDriver (lub TwinCATTcpip / Parametry drajwera - UniDriver) pozwala określić parametry dotyczące szczegółowych informacji o błędach oraz informacji diagnostycznych. Informacje te zapisywane są w pliku o nazwie UniDriver.<bieżąca data>.log.

Parametry umieszczone na zakładkach Parametry drajwera - UniDriver obowiązują wszystkie kanały, które mają w deklaracji drajwera taką zakładkę. Parametry ustawione na zakładce Parametry drajwera - UniDriver w definicji jednego z tych kanałów automatycznie wyświetlane są na zakładkach Parametry drajwera - UniDriver w definicji pozostałych kanałów.

R Ścieżka do katalogu, w którym umieszczany będzie plik logu

Znaczenie - jeżeli ta opcja istnieje, to plik logu umieszczany jest w podanym katalogu.

Wartość domyślna - domyślnie plik logu umieszczany jest w katalogu systemu Asix.

Parametr:

ścieżka_do_katalogu - ścieżka do katalogu, w którym umieszczany jest plik logu.

R Śledzone zmienne

Znaczenie - dla każdej zmiennej, której nazwa znajduje się na liście, podczas jej przetwarzania, będą wpisywane do logu informacje o jej wartości, jakości i stemplu.

Wartość domyślna - brak.

Parametr:

lista_zmiennych - lista nazw zmiennych w systemie Asix, oddzielonych przecinkami.

Funkcja szybkiego odświeżania zmiennych

Standardowo zmienne odświeżane są przez moduł danych bieżących Asmen z częstotliwością wynoszącą minimum 1 sekundę. Funkcja szybkiego odświeżania zmiennych realizowana przez drajwer CtTwinCATTcpip (od wersji 1.3.5 począwszy) umożliwia odświeżanie zmiennych z maksymalna osiągalną szybkością łącza (nie wpływa to na archiwizację - zmienne dalej archiwizowane są z częstotliwością wynoszącą minimum 1 sekundę). Zmienne objęte funkcją szybkiego odświeżania muszą mieć zadeklarowany w bazie definicji zmiennych atrybut FastRefresh, z wartością 1.


Definicją alarmu może mieć postać:

Home > Definicją alarmu może mieć postać:

Definicją alarmu może mieć postać:


Deklaracja kanału buforowanego:

Home > Deklaracja kanału buforowanego:

Deklaracja kanału buforowanego:

Sekcja | parametr | wartość
ASMEN | IEC1 | IEC61850, scl=SIPROTEC.icd, brcb= CTRL/LLN0.brcbA01
IEC1 | ds | CTRL/LLN0.AsixDs
IEC1 | Log | Iec1.log
IEC1 | Dump | Iec1.xml

Powyżej podano deklarację kanału buforowanego. Blok raportowania ma nazwę (referencję) „CTRL/LLN0.brcbA01”. Blok raportuje atrybuty zawarte w DataSet o nazwie „CTRL/LLN0.AsixDs”. Informacje diagnostyczne będą wyprowadzane do pliku „iec1.log” a szczegółowe informacje dotyczące wymiany danych zostaną zapisane w pliku „iec1.xml”.

Deklaracja kanału niebuforowanego.

Sekcja | parametr | Wartość
ASMEN | IEC1 | IEC61850, scl=SIPROTEC.icd, urcb= CTRL/LLN0.urcbA01
IEC1 | ds | @


Deklaracja kanału nie zawierająca parametrów brcb i urcb

Home > Deklaracja kanału nie zawierająca parametrów brcb i urcb

Deklaracja kanału nie zawierająca parametrów brcb i urcb określa grupę zmiennych, których wartości będą odczytywane z IED poprzez wysyłanie do urządzenia żądań odczytu zgodnie z określonym dla konkretnej zmiennej okresem próbkowania (polling).


MEAS/MMXU1.PPV.phsAB.instCVal.mag.f[AL500>32,76]

Home > MEAS/MMXU1.PPV.phsAB.instCVal.mag.f[AL500>32,76]

MEAS/MMXU1.PPV.phsAB.instCVal.mag.f[AL500>32,76]


S7_TCPIP - drajwer do wymiany danych ze sterownikami SIMATIC poprzez Ethernet

Type topic text here.