Witamy

Home > Witamy

>> Pomoc dla użytkowników systemu Asix - wersji 9

www.asix.com.pl

Asix Mobile (dla Asix.Evo)

Dok. Nr PLH9E017

Wersja: 2020-07-14


2. Instalacja

Moduł Asix Mobile jest częścią pakietu Asix.Evo i jest instalowany razem z nim.

Do uruchomienia serwera modułu Asix Mobile potrzebny jest system operacyjny Windows Vista/2008 lub nowszy. Musi być też zainstalowana biblioteka .NET w wersji 4.6.2 lub nowszej.

Do uruchomienia klienta modułu Asix Mobile potrzebne jest urządzenie z systemem operacyjnym Android lub iOS. Możliwe jest też uruchomienie klienta w przeglądarce na systemie Windows - obsługiwane przeglądarki to Google Chrome i Mozilla Firefox.


3. Konfiguracja serwera

Home > 3. Konfiguracja serwera > 3.1. Konfiguracja serwera Asix Mobile

3.1. Konfiguracja serwera

Konfigurowanie opcji modułu Asix Mobile odbywa się w ustawieniach stanowiska aplikacji Asix.Evo (AsixEvo.exe > Eksplorator aplikacji > Ustawienia stanowisk), w grupie opcji Asix Mobile.

powiększ >>

Rys. Panel konfiguracji stanowiska - opcje Asix Mobile.

  • Pierwsza czynność to włączenie modułu Asix Mobile przy użyciu opcji Uruchom serwer Asix Mobile.

  • Druga to wybranie dostępnych protokołów: http, https lub obu przy użyciu poniższych opcji:

  • Ustawienia komunikacji zewnętrznej:

  • Zezwalaj tylko na połączenia HTTP,

  • Zezwalaj tylko na połączenia HTTPS,

  • Zezwalaj na połączenia HTTP i HTTPS.

  • Trzecia, opcjonalna, czynność to włączenie bazy alertów i skonfigurowanie powiadomień.

Włączenie opcji Włącz bazę alertów Asix Mobile umożliwia tworzenie w aplikacji bazy alertów. Po włączeniu opcji w aplikacji Asix Mobile pojawia się zakładka Alarmy i dostępne jest okno aktywnych alarmów. W oknie aktywnych alarmów dostępne są polecenia do tworzenia bazy alertów. Włączenie opcji Włącz powiadomienia umożliwia automatyczne wysyłanie do użytkowników powiadomień o zmianach stanów alarmów. Po włączeniu opcji Włącz powiadomienia należy wprowadzić parametry centrum powiadomień. Po ich podaniu i, później, po utworzeniu za pomocą aplikacji Asix Mobile bazy alertów, powiadomienia zaczną być wysyłane. Na parametry centrum powiadomień składają się: identyfikator, klucz i nazwa poddomeny. Aby otrzymać parametry centrum powiadomień, należy zwrócić się do firmy Askom. Firma Askom utworzy dla klienta centrum powiadomień i przekaże jego parametry. Utworzenie centrum powiadomień jest bezpłatne. Wniosek o utworzenie centrum powiadomień należy przesłać pocztą elektroniczną na adres dh@askom.com.pl. We wniosku należy podać numer licencji pakietu Asix.Evo, proponowaną nazwę poddomeny oraz swoje dane adresowe i kontaktowe. Nazwa poddomeny musi składać się ze znaków alfabetu angielskiego, cyfr i myślników. Dla każdej licencji serwerowej pakietu Asix.Evo, który ma pełnić rolę serwera Asix Mobile z funkcją powiadomień, należy utworzyć jedno centrum powiadomień. Parametry centrum nie są powiązane z licencją Asix ani z komputerem i mogą być swobodnie przeniesione na inny komputer. Klucz centrum powiadomień należy traktować jako informację poufną i nigdy nie udostępniać osobom trzecim. Serwer, który ma być używany do wysyłania powiadomień, musi mieć dostęp do Internetu, w tym prawidłowo skonfigurowane adresy serwerów DNS.

Wymagana jest też konfiguracja serwera Asix.Evo dla usługi Asix Mobile. Konfiguracji takiej należy dokonać jednokrotnie i obejmuje ona poniżej wymienione czynności.

  • Konfigurator komunikacji Windows > okno Komunikacja serwera Asix.Evo:

  • wybór użytkownika Windows uruchamiającego aplikację Asix.Evo;

  • rezerwowanie ścieżki Http i Https dla wybranego użytkownika Windows dla usługi AsixMobile;

  • Konfigurowanie certyfikatu SSL dla portu HTTPS usługi Asix Mobile (generowanie testowego certyfikatu SSL dla wskazanego adresu lub domeny lub użycie własnego zainstalowanego certyfikatu SSL).

powiększ >>

Rys. Okno konfiguratora komunikacji Windows.

Protokół http nie wymaga żadnych dodatkowych czynności konfiguracyjnych. Jego wadą jest przesyłanie danych: nazwy użytkownika, hasła i danych procesowych aplikacji w sieci otwartym tekstem.

Protokół https przesyła wszystkie dane w postaci zaszyfrowanej i dlatego jego używanie jest zalecane podczas normalnej eksploatacji. Wymaga jednak do działania skonfigurowania certyfikatu SSL, koniecznego do szyfrowania transmisji.

Najlepszą drogą zdobycia certyfikatu SSL jest jego zakup u jednego z licznych sprzedawców certyfikatów. Po zakupie certyfikat należy umieścić w repozytorium certyfikatów systemu Windows, zgodnie z instrukcją sprzedawcy. Następnie należy użyć program Asix.Evo do powiązania certyfikatu z protokołem https.

Zanim zakupi się certyfikat SSL można użyć programu Asix.Evo do wygenerowania testowego certyfikatu SSL. Po powiązaniu go z protokołem https transmitowane dane są szyfrowanie tak jak dla zwykłego certyfikatu SSL. Jednak przeglądarka użytkownika modułu Asix Mobile będzie informować, że do szyfrowania transmisji używany jest niezaufany certyfikat. Można ten komunikat zignorować lub zainstalować u każdego klienta certyfikat główny testowego certyfikatu SSL. Od tego momentu przeglądarka będzie ufać naszemu certyfikatowi testowemu.

Aby zainstalować u klienta certyfikat główny testowego certyfikatu SSL, należy:

  • uruchomić aplikację Asix Mobile w trybie HTTPS;

  • uruchomić okno informacji o certyfikacie, klikając na ikonę kłódki przed adresem HTTPS; (w Google Chrom okno pojawia się po kliknięciu na link Connection > Certificate information; w Mozilli okno wywołuje polecenie More information... > Security > View certificate)

  • na zakładce Szczegóły w/w okna wybrać opcję Kopiuj do pliku.../ Export (zależnie od przeglądarki), która uruchomi Kreator eksportu certyfikatów / okno zapisu certyfikatu do pliku (zależnie od przeglądarki); należy postępować zgodnie ze wskazówkami kreatora;

  • po wyeksportowaniu certyfikatu do pliku .CER i zapisaniu go lokalnie na dysku, należy wywołać okno Certyfikat, klikając na utworzonym pliku;

  • zainstalować certyfikat, używając polecenia Zainstaluj certyfikat (polecenie znajduje się na zakładce Ogólne).

Wyżej opisana procedura instalacji certyfikatu nie jest wymagana w przypadku posługiwania się certyfikatem zakupionym.

Aby włączyć w aplikacji Asix.Evo możliwość tworzenia notatek, musi być włączony "Centralny system zabezpieczeń" w ustawieniach zabezpieczeń:

Asix.Evo.exe > Eksplorator aplikacji > Zabezpieczenia > Ustawienia

System ten korzysta z bazy Microsoft SQL Server, która przechowuje dane użytkowników i ich notatek.


5.1. Adres aplikacji

Home > 4. Uruchamiania aplikacji > 4.1. Adres aplikacji

4.1. Adres aplikacji

Na komputerze, na którym jest uruchomiony serwer Asix Mobile, można uzyskać dostęp do aplikacji za pomocą przeglądarki, wpisując adres http://localhost/mobile. Dostęp z innych komputerów lub urządzeń mobilnych może być realizowany za pomocą protokołu HTTP lub bezpiecznego HTTPS. Udostępnianie aplikacji za pomocą protokołu HTTPS wymaga skonfigurowania odpowiedniego certyfikatu.

Adres aplikacji Asix Mobile to:

https://adres_serwera_asix_evo/mobile

Jeśli używamy protokół http, to adres brzmi:

http://adres_serwera_asix_evo/mobile

Przykładowo, jeśli adresem serwera Asxi.Evo jest 10.10.2.3, to adres aplikacji Asix Mobile brzmi:

https://10.10.2.3/mobile

Jeśli komputer serwera Asix.Evo posiada adres DNS (np. turbina1.firma.pl), to adres aplikacji Asix Mobile brzmi:

https://turbina1.firma.pl/mobile


7. Nawigacja

Home > 5. Nawigacja

5. Nawigacja

Po zalogowaniu uruchamiany jest diagram startowy, który jeśli ma podpięte diagramy, umożliwia przechodzenie do nich za pomocą łącz symbolizowanych ikoną [image].

Powrót do poprzedniego diagramu należy realizować za pomocą przycisku [image] na górnej belce okna aplikacji. Nigdy nie wolno używać do tego celu nawigacji z przeglądarki internetowej.

Lista wszystkich dostępnych diagramów dostępna jest po wybraniu polecenie Wyświetl listę wszystkich diagramów z menu "hamburger" [image] na górnej belce okna aplikacji.

Po zalogowaniu się uruchamiany jest diagram startowy.

Rys. Okno startowe aplikacji Asix Mobile.

Jeśli diagram startowy zawiera łącza do innych diagramów, możliwe jest przechodzenie do nich za pomocą ikony [image] . Powrót do poprzedniego diagramu należy realizować za pomocą przycisku na górnej belce okna aplikacji [image] . Nigdy nie wolno używać do tego celu nawigacji z przeglądarki internetowej.

Lista wszystkich dostępnych diagramów dostępna jest po wybraniu polecenie Wyświetl listę wszystkich diagramów z menu "hamburger" [image] na górnej belce okna aplikacji. Menu to zawiera też wszystkie dostępne w danym oknie polecenia.

W dolnej części ekranu znajduje się pasek zakładek. Zawiera on przyciski umożliwiające przechodzenie między trzema modułami aplikacji.

Moduł "Aplikacja" służy do wyświetlania i tworzenia diagramów aplikacji.

Moduł "Moje diagramy" służy do wyświetlania i tworzenia diagramów prywatnych diagramów użytkownika.

Moduł "Serwer" zawiera informacje o zalogowanym użytkowniku, używanej wersji oprogramowania i o serwerze Asix Mobile.


8. Tworzenie aplikacji

Home > 6. Tworzenie aplikacji

6. Tworzenie aplikacji

Na stworzenie aplikacji składa się przygotowanie diagramów, wybranie diagramu startowego i ewentualnie dostosowanie domyślnego stylu segmentu. Aby użytkownik mógł wykonać te czynności, musi mieć przydzielone uprawnienie Asix Mobile: Edycja diagramów i opcji.

Wszystkie diagramy i ustawienia aplikacji Asix Mobile są przechowywane na serwerze Asix.Evo. W katalogu aplikacji Asix.Evo znajduje się podkatalog AsixMobile i w nim znajdują się wszystkie dane. Żadne dane aplikacji Asix Mobile nie są przechowywane w przeglądarce.


8.1. Tworzenie diagramu

Home > 6. Tworzenie aplikacji > 6.1. Tworzenie diagramu

6.1. Tworzenie diagramu

Aby utworzyć nowy diagram, należy w menu aplikacji wybrać polecenie Nowy diagram.

Po wybraniu polecenia pojawia się edytor diagramu. Składa się on z dwu zakładek: Właściwości i Segmenty. Dostępne są też przyciski Zapisz i Anuluj.

Naciśnięcie przycisku Zapisz kończy edycję diagramu, zapisując go na serwerze. Naciśnięcie przycisku Anuluj zamyka edytor bez zapisywania diagramu.

W zakładce Właściwości należy wypełnić pole Nazwa diagramu. Pod tą nazwą diagram będzie zapisany na serwerze. Nazwa te będzie też wyświetlana w polu tytułu diagramu. Można wypełnić pole Tytuł diagramu, aby podać tytuł inny niż nazwa diagramu.

Rys. Okno edycji diagramu - zakładka właściwości.

Zawartość diagramu jest edytowana w zakładce Segmenty. Po przejściu do tej zakładki na dole ekranu pojawiają się trzy narzędzia. Narzędzie "krzyżyk" [image] włącza tryb usuwania segmentów, narzędzie "plus" [image] dodaje nowy segment do diagramu, narzędzie "strzałki" [image] służy do włączenia trybu zmiany kolejności segmentów.

Po dodaniu nowego segmentu, należy w niego kliknąć, aby przejść do edytora segmentu.

Rys. Okno edycji diagramu - zakładka segmentów.


8.2. Edycja segmentu

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu

6.2. Edycja segmentu

Aby przejść do edycji diagramu, należy przejść do trybu edycji diagramu (menu aplikacji > Edytuj), na liście segmentów danego diagramu wybrać segment i dwukrotnie na nim kliknąć lewym klawiszem myszki.

Edytor segmentu składa się z dwóch zakładek: Zawartość, Elementy. Dostępne są też przyciski Ok i Anuluj.

Rys. Okno edycji segmentu - widok na zakładkę 'Zawartość'.

Naciśnięcie przycisku Ok kończy edycję segmentu i wraca do edycji diagramu. Naciśnięcie przycisku Anuluj powoduje powrót do edycji diagramu, porzucając zmiany wprowadzone w segmencie.

Zakładka Zawartość zawiera podstawowe opcje określające zawartość segmentu.

Znaczenie ikon edycyjnych:

- wybór zmiennej z bazy definicji zmiennych / diagramu / alarmu z bazy definicji alarmów

- Wybierz atrybut z bazy definicji zmiennych

- Wybierz wielojęzyczny tekst aplikacji

Pierwsza z opcji to Rodzaj segmentu. Dostępne typy danych segmentu to:

  • Zmienna,

  • Alarm,

  • Łącze,

  • Tekst.

W zależności od wybranego rodzaju segmentu udostępniane są dalsze opcje.

Zakładka Elementy umożliwia parametryzowanie elementów wizualizacyjnych segmentu jak równiez wyglad samego segmentu.

Rys. Okno edycji segmentu - widok na zakładkę 'Elementy'.


8.2.1. Segment Tekst

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.1 Segment Tekst

6.2.1. Segment Tekst

Segment Tekst to najprostszy rodzaj segmentu. Jego zawartość składa się tylko z dwu elementów: Tytuł i Opis. Segment Tekst służy do umieszczenia w diagramie dodatkowych informacji tekstowych dla użytkownika lub do wizualnego grupowania segmentów wyświetlających dane procesowe.

Rys. Okno edycji segmentu dla typu danych - Tekst.

Rys. Okno edycji segmentu dla typu danych - Tekst.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Tekst.

Rys. Widok segmentu Tekst.


8.2.3. Segment Alarm

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.3. Segment Alarm

6.2.3. Segment Alarm

Segment Alarm umożliwia wyświetlanie stanu jednego alarmu. Najważniejsze opcje segmentu to Nazwa domeny alarmów, do której należy alarm i Nazwa alarmu. Pozostałe opcje to Tytuł i Opis segmentu.

Parametryzację segmentu można najprościej wykonać naciskając przycisk Szukaj. Pojawia się okno wyboru alarmu zawierające alarmy z bazy definicji alarmów. Na górze okna znajduje się pole wyszukiwania. Po wpisaniu tam fragmentu nazwy lub opisu alarmu zostanie przeszukana baza i zwrócona lista pasujących definicji alarmów. Kliknięcie w wiersz listy powoduje zamknięcie okna i wypełnienie opcji segmentu danymi z wybranego wiersza alarmu.

Rys. Okno edycji segmentu dla typu danych - Alarm.

Rys. Okno edycji segmentu dla typu danych - Alarm.

Opcje etykiet alarmu aktywnego i nieaktywnego umożliwiają podanie tekstu, jaki się pojawi w segmencie jako wartość aktualnego stanu alarmu.

Na zakładce Elementy można wybrać, w jaki sposób ma być pokazywana wartość alarmu. Do wyboru jest etykieta, ikona stanu i ikona potwierdzenia.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Alarm.

Wygląd alarmu definiowany jest na zakładce Elementy > Wygląd segmentu > Alarm. Definicja ta obejmuje wygląd etykiet oraz ikon alarmu.

Rys. Okno edycji wyglądu alarmu dla typu danych - Alarm.

Rys. Widok segmentu alarmu.


8.2.3.1. Stan alarmu

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.3. Segment Alarm > 6.2.3.1. Stan alarmu

6.2.3.1. Stan alarmu

Segment wyświetla w postaci ikon jeden z trzech stanów, w jakim może być alarm:

  • Nieaktywny

  • Aktywny i niepotwierdzony

  • Aktywny i potwierdzony

Istnieje pokaźna baza ikon, które użytkownik może indywidualnie przyporządkować do powyższych stanów.

Kliknięcie w segment alarmu otwiera okno stanu alarmu, gdzie wyświetlone są szczegółowe informacje o stanie alarmu.

Rys. Okno informacji o stanie alarmu.


8232_Potwierdzanie_alarmu

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.3. Segment Alarm > 6.2.3.2. Potwierdzanie alarmu

6.2.3.2. Potwierdzanie alarmu

Do potwierdzania alarmu służy okno potwierdzania. Dostępne jest on po otwarciu okna stanu alarmu i kliknięciu przycisku Chcę potwierdzić. Aby przycisk ten był dostępny, muszą być spełnione następujące warunki:

  • użytkownik musi mieć uprawnienie potwierdzania alarmów,

  • alarm musi być aktywny i niepotwierdzony.

W oknie potwierdzania można opcjonalnie wprowadzić notatkę w polu Notatka. Naciśnięcie przycisku Potwierdź powoduje wysłanie potwierdzenia do aplikacji Asix.Evo. Po chwili niżej pojawi się komunikat informujący o wysłaniu potwierdzenia lub ewentualnie komunikat błędu.

Rys. Okno potwierdzania alarmu z komunikatem o dokonaniu operacji potwierdzenia.


8.2.4. Segment Zmienna

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna

6.2.4. Segment Zmienna

Segment Zmienna umożliwia wyświetlenie stanu jednej zmiennej.

Najważniejsza opcja segmentu to Nazwa zmiennej. Należ też podać Typ zmiennej, w zależności od którego wyświetlone zostaną dodatkowe atrybuty zmiennej, wymagające parametryzacji. Dostępne typy zmiennej to:

  • Liczba,

  • Wartość binarna,

  • Bity,

  • Tekst,

  • Agregat.

Opcje, które występują dla każdego typu zmiennej, to Tytuł segmentu i Opis segmentu.

Parametryzację segmentu można najprościej wykonać naciskając przycisk Szukaj. Pojawia się okno wyboru zmiennej zawierające zmienne z bazy definicji zmiennych. Na górze okna znajduje się pole wyszukiwania. Należy tam wpisać fragment nazwy lub opisu – na podstawie tego kryterium zostanie przeszukana baza i zwrócona lista pasujących definicji zmiennych. Kliknięcie w wiersz listy powoduje zamknięcie okna i wypełnienie opcji segmentu.

Rys. Okno edycji segmentu dla typu danych - Zmienna.

Rys. Okno edycji segmentu dla typu danych - Zmienna.


Zmienna typu Liczba

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.1. Zmienna typu Liczba

6.2.4.1. Zmienna typu Liczba

Dostępne sposoby wizualizacji zmiennej typu Liczba to:

  • Wartość,

  • Miernik,

  • Słupek

  • Wykres.

Okno edycji segmentu Zmienna o typie Liczba umożliwia, poza standardowymi atrybutami segmentu zmiennej, edycję następujących atrybutów typowych dla Liczby:

  • Jednostka,

  • Minimum,

  • Maksimum,

  • Liczba miejsc po przecinku.

Rys. Okno edycji segmentu dla typu danych - Zmienna/Liczba.

Sposoby wizualizacji zmiennej typu Liczba określane są na zakładce Elementy.

Rys. Okno definicji segmentu zmiennej typu Liczba - wybór sposobu wizualizacji.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Liczba.

Wygląd zmiennej definiowany jest na zakładce Elementy > Wygląd segmentu > Zmienna. Definicja ta obejmuje wygląd zmiennej w zależności od przekroczonych limitów oraz wygład elementów zadeklarowanych do prezentacji Liczby.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Liczba.

Wartość wyświetla wartość liczbową zmiennej zaokrągloną do podanej liczby miejsc po przecinku. Pod wartością liczbową wyświetlana jest jednostka.

Rys. Widok segmentu zmiennej typu Liczba - w postaci wartości.

Miernik wyświetla wartość zmiennej w postaci wskazania na skali miernika. Zakres skali miernika jest określony przez opcje Minimum i Maksimum. Dodatkowo, jeśli w bazie definicji zmiennej są podane limity alarmowe i ostrzegawcze, to skala miernika jest kolorowana tak, aby pokazać przedziały wartości alarmowe i ostrzegawcze.

Rys. Widok segmentu zmiennej typu Liczba - w postaci miernika.

Słupek wyświetla wartość zmiennej w postaci wskazania na skali słupka poziomego. Zakres skali słupka jest określony przez opcje Minimum i Maksimum. Dodatkowo, jeśli w aplikacji są podane limity alarmowe i ostrzegawcze, to skala słupka jest kolorowana tak, aby pokazać przedziały wartości alarmowe i ostrzegawcze.

Rys. Widok segmentu zmiennej typu Liczba - w postaci słupka.

Wykres wyświetla historię ostatnich wartości zmiennej w postaci wykresu. Może to być wykres pełny zawierający oprócz przebiegu również osie i siatkę, lub też miniwykres zawierający tylko przebieg.

Postać wykresu wymaga zdefiniowania następujących atrybutów:

  • Typ wykresu (Liniowy, Obszarowy, Liniowy schodkowy, Obszarowy schodkowy),

  • Rodzaj danych,

  • Okres danych.

Rys. Widok segmentu zmiennej typu Liczba - w postaci miniwykresu.

Rys. Widok segmentu zmiennej typu Liczba - w postaci wykresu pełnego.


Zmienna typu Wartość binarna

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.2. Zmienna typu Wartość binarna

6.2.4.2. Zmienna typu Wartość binarna

Dostępne sposoby wizualizacji zmiennej typu Liczba to:

  • Wartość,

  • Wartość jako ikona (przełącznik),

  • Wykres.

Okno edycji segmentu Zmienna o typie Wartość binarna umożliwia, poza standardowymi atrybutami segmentu zmiennej, edycję następujących atrybutów typowych dla Wartości binarnej:

  • Etykieta dla 0,

  • Etykieta dla 1.

Rys. Okno edycji segmentu dla typu danych - Zmienna/Wartość binarna.

Sposoby wizualizacji zmiennej typu Wartość binarna określane są na zakładce Elementy.

Rys. Okno definicji segmentu zmiennej typu Wartość binarna - wybór sposobu wizualizacji.

Wartość wyświetla wartość liczbową zmiennej czyli 0 lub 1. Podając wartości opcji Etykieta dla 0 i Etykieta dla 1 można zastąpić wartości 0/1 własnymi etykietami.

Wartość jako przełącznik wyświetla wartość pomiaru jako ikonę przełącznik, gdzie 0 pokazane jest jako przełącznik rozwarty, a 1 jako przełącznik zwarty.

Wykres wyświetla historię ostatnich wartości zmiennej w postaci wykresu. Może to być wykres pełny zawierający oprócz przebiegu również osie i siatkę, lub też miniwykres zawierający tylko przebieg.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Wartość binarna.

Wygląd zmiennej definiowany jest na zakładce Elementy > Wygląd segmentu > Zmienna. Definicja ta obejmuje wygląd zmiennej w zależności od przekroczonych limitów oraz wygład elementów zadeklarowanych do prezentacji Wartości binarnej.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Wartość binarna.

Rys. Widok segmentu zmiennej typu Wartość binarna - w postaci przełącznika.


Zmienna typu Bity

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.3. Zmienna typu Bity

6.2.4.3. Zmienna typu Bity

Dostępne sposoby wizualizacji zmiennej typu Bity to:

  • tekst stanu,

i /lub

  • i /lub obrazek stanu.

Okno edycji segmentu Zmienna o typie Bity wymaga, poza standardowymi atrybutami segmentu zmiennej, zdefiniowania listy stanów bitów. Aktywny stan jest ustalany przez dopasowanie bieżącej wartości zmiennej do jednego ze stanów. Aktywny stan określa to, co jest wyświetlane w segmencie jako bieżąca wartość zmiennej.

Rys. Okno edycji segmentu dla typu danych - Zmienna/Bity.

Sposób wizualizacji segmentu zmiennej typu Bity określany jest na zakładce Elementy.

Rys. Okno definicji segmentu zmiennej typu Bity - wybór sposobu wizualizacji.

Edycja stanów bitów wymaga dodania na zakładce Zawartość > Stany bitów wiersza stanu bitów za pomocą przycisku [image], a następnie wywołania okna Edytor stanu, uruchamianego poprzez kliknięcie na wiersz stanu bitów.

Rys. Okno edytor stanu bitów.

W skład definicji każdego stanu wchodzi Maska bitowa, Tekst stanu i/lub Obrazek stanu.

Obrazek deklarowany jest poprzez wpisanie nazwy pliku w pole Obrazek stanu. Pliki obrazków należy wcześniej przygotować i wgrać na serwerze do katalogu aplikacji Asix.Evo, do podkatalogu „AsixMobile\Images”.

Można też określić Kolor tekstu i Kolor przycisku.

Maska bitowa to ciąg znaków określających wymagany stan bitów jakie muszą wystąpić w wartości zmiennej, aby stan stał się stanem aktywnym. Dostępne znaki maski to:

- - wartość bitu nie ma znaczenia,

1 - bit musi być ustawiony,

0 - bit musi być wyzerowany.

Tekst stanu to tekst wyświetlany w segmencie, gdy stan jest aktywny.

Jeśli dla stanu włączona jest opcja Stan dostępny przy sterowaniu, to stan ten może być wysłany do zmiennej w oknie sterowania.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Bity.

Wygląd zmiennej definiowany jest na zakładce Elementy > Wygląd segmentu > Zmienna. Definicja ta obejmuje wygląd zmiennej w zależności od przekroczonych limitów oraz wygład elementów zadeklarowanych do prezentacji Bitów.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Bity.


Zmienna typu Tekst

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.4. Zmienna typu Tekst

6.2.4.4. Zmienna typu Tekst

Jedyny dostępny sposób wizualizacji zmiennej typu Tekst to Wartość zmiennej na zakładce Elementy.

Główną różnicą między zmienną typu Tekst a Liczba, oprócz ograniczonej listy elementów wizualizacyjnych, jest inne działanie panelu sterowania zmienną, co jest opisane niżej.

Rys. Okno edycji segmentu dla typu danych - Zmienna/Tekst.

Sposób wizualizacji segmentu zmiennej typu Bity określany jest na zakładce Elementy.

Rys. Okno definicji segmentu zmiennej typu Tekst - wybór sposobu wizualizacji.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Tekst.

Wygląd zmiennej definiowany jest na zakładce Elementy > Wygląd segmentu > Zmienna. Definicja ta obejmuje wygląd zmiennej w zależności od przekroczonych limitów oraz wygląd elementów zadeklarowanych do prezentacji Tekstu.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Tekst.

Rys. Widok segmentu zmiennej typu Tekst.


zmienna_typu_agregat

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.5. Zmienna typu Agregat

6.2.4.5. Zmienna typu Agregat

Dostępne sposoby wizualizacji zmiennej typu Liczba to:

  • Wartość,

  • Miernik,

  • Słupek.

Okno edycji segmentu Zmienna o typie Agregat umożliwia, poza standardowymi atrybutami segmentu zmiennej, edycję następujących atrybutów typowych dla Agregatu:

  • Nazwa agregatu,

  • Okres danych (Agregat kroczący, Podany okres),

  • Długość (lub Początek, Koniec) - w zależności od Okresu danych,

  • Okres wyliczania,

  • Jednostka,

  • Minimum,

  • Maksimum,

  • Liczba miejsc po przecinku.

Rys. Okno edycji segmentu dla typu danych - Zmienna/Agregat.

Sposoby wizualizacji zmiennej typu Agregat określane są na zakładce Elementy.

Rys. Okno definicji segmentu zmiennej typu Agregat - wybór sposobu wizualizacji.

Wartość wyświetla wartość liczbową zmiennej zaokrągloną do podanej liczby miejsc po przecinku. Pod wartością liczbową wyświetlana jest jednostka.

Rys. Widok segmentu zmiennej typu Agregat - w postaci wartości.

Miernik wyświetla wartość zmiennej w postaci wskazania na skali miernika. Zakres skali miernika jest określony przez opcje Minimum i Maksimum. Dodatkowo, jeśli w bazie definicji zmiennej są podane limity alarmowe i ostrzegawcze, to skala miernika jest kolorowana tak, aby pokazać przedziały wartości alarmowe i ostrzegawcze.

Rys. Widok segmentu zmiennej typu Agregat - w postaci miernika.

Słupek wyświetla wartość zmiennej w postaci wskazania na skali słupka poziomego. Zakres skali słupka jest określony przez opcje Minimum i Maksimum. Dodatkowo, jeśli w aplikacji są podane limity alarmowe i ostrzegawcze, to skala słupka jest kolorowana tak, aby pokazać przedziały wartości alarmowe i ostrzegawcze.

Rys. Widok segmentu zmiennej typu Agregat - w postaci słupka.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Agregat.

Wygląd zmiennej definiowany jest na zakładce Elementy > Wygląd segmentu > Zmienna. Definicja ta obejmuje wygląd zmiennej w zależności od przekroczonych limitów oraz wygląd elementów zadeklarowanych do prezentacji Agregatu.

Rys. Okno edycji wyglądu segmentu dla typu danych - Zmienna/Agregat.


Własny tekst Nowa wartość

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.7. Własny tekst "Nowa wartość"

6.2.4.7. Własny tekst "Nowa wartość"

Domyślnie, w oknie sterowania zmienną, pole nowej wartości ma etykietę Nowa wartość. Aby ułatwić użytkownikowi działanie, można w opcjach sterowania (w oknie edycji segmentu zmiennej) podać własny tytuł tego pola (Etykieta dla nowej wartości).

Rys. Okno edycji segmentu zmiennej.

Rys. Własny indywidualny tekst etykiety pola "Etykieta dla nowej wartości".


Zmienna sterująca inna niż zmienna podstawowa

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.8. Zmienna sterująca inna niż zmienna podstawowa

6.2.4.8. Zmienna sterująca inna niż zmienna podstawowa

Domyślnie sterowanie dotyczy tej samej zmiennej, której wartość jest wyświetlana w segmencie. Jeśli jednak włączona jest opcja segmentu Sposób sterowania: Inna zmienna, to pojawiają się opcje umożliwiające wybranie inne zmiennej, której wartością chcemy sterować.

Dla zmiennej sterowania należy określić pola Nazwa zmiennej i jej Typ. Dla typu liczbowego można podać zakres zmiennej. Dla typu binarnego można podać etykiety stanów 0/1.

Typ Bity jest dostępny tylko wtedy gdy zmienna podstawowa też jest typu Bity. Przy sterowaniu dostępne są stany zdefiniowane dla zmiennej podstawowej.


Notatki operatora

Home > 6. Tworzenie aplikacji > 6.3. Notatki Operatora

6.3. Notatki Operatora

Okno Notatek Operatora służy do przeglądania ostatnich notatek i tworzenia nowych przez użytkowników aplikacji. Każda notatka składa się z:

  • Tekstu - dowolna treść wpisana przez użytkownika,

  • Lokalizacji - każda notatka jest łączona z konkretną częścią aplikacji (instalacji),

  • Flagi aktywności - służy do oznaczania nowych notatek.

Notatki tworzone w Asix Mobile są widoczne w stacjonarnej wersji aplikacji Asix. W szczególności, dostępny jest mechanizm powiadamiania o aktywnych notatkach.

Aby utworzyć nową notatkę, należy w menu aplikacji wybrać polecenie Notatki operatora i ponownie z menu Nowa notatka.

Rys. Okno edycyjne nowej notatki operatora.

Uwaga:

Aby włączyć w aplikacji Asix.Evo możliwość tworzenia notatek, musi być włączony "Centralny system zabezpieczeń" w ustawieniach zabezpieczeń:

AsixEvo.exe > Eksplorator aplikacji > Zabezpieczenia > Ustawienia

System ten korzysta z bazy Microsoft SQL Server, która przechowuje dane użytkowników i ich notatek.


8.3. Diagram startowy

Home > 6. Tworzenie aplikacji > 6.4. Diagram startowy

6.4. Diagram startowy

Po zalogowaniu się użytkownika pierwszy wyświetlany diagram to diagram, którego nazwa podana jest w opcjach aplikacji: O pcje z menu "hamburger" [image] na górnej belce okna aplikacji > Diagram początkowy > w polu Diagram początkowy aplikacji. Jeśli opcja jest pusta, to po zalogowaniu się wyświetlana jest lista diagramów. Opcja jest dostępne tylko dla użytkownika, który posiada uprawnienie "Asix Mobile: Edycja diagramów i opcji".


8.4. Dostosowanie domyślnego stylu segmentu

Home > 6. Tworzenie aplikacji > 6.5. Dostosowanie domyślnego stylu segmentu

6.5. Dostosowanie domyślnego stylu segmentu

W menu aplikacji dostępne jest polecenie Aplikacja > Opcje > Wygląd segmentu > Skórka globalna. Po jego wybraniu pojawia się edytor umożliwiający zmianę wyglądu segmentu, zmiennej i alarmu.

Rys. Okno edytora domyślnego wyglądu segmentu.


9.1. Lista diagramów

Home > 7. Tworzenie diagramów użytkownika > 7.1. Lista diagramów

7.1. Lista diagramów

Główne okno sekcji diagramów użytkownika to lista diagramów. Lista jest posortowana alfabetycznie wg nazw diagramów. Kliknięcie w nazwę diagramu powoduje otwarcie diagramu.

Menu listy diagramów umożliwia edycję listy czyli usuwanie niepotrzebnych diagramów oraz utworzenie nowego diagramu.

Menu diagramu zawiera polecenia służące do edycji bieżącego diagramu, utworzenia nowego diagramu i utworzenie kopii bieżącego diagramu.


Tryby wyświetlania Asix Mobile w przeglądarce na Windows

Home > 8. Tryby wyświetlania Asix Mobile w przeglądarce na Windows

8. Tryby wyświetlania Asix Mobile w przeglądarce na Windows

Tryby wyświetlania Asix Mobile w przeglądarce na Windows to: telefon, tablet i okno.

Aby ustawić wymagany tryb wyświetlania Asix Mobile, należy w menu aplikacji wybrać polecenie Opcje > Opcje programu > i z polecenia Widok wybrać odpowiedni tryb.

Rys. Tryb telefon.

Rys. Tryb tablet.

Rys. Tryb okno.


Aplikacja wielojęzyczna

Home > 9. Aplikacja wielojęzyczna

9. Aplikacja wielojęzyczna

Opcja pozwala włączyć obsługę języków aplikacji na podstawie listy języków aplikacji pobranej z serwera:

menu główne "hamburger" aplikacji > Opcje

Rys. Załączenie obsługi aplikacji wielojęzycznej.

Istnieje możliwość utworzenia listy tekstów wielojęzycznych przy użyciu polecenia Nowy tekst menu okna Teksty aplikacji, uruchamianego z menu głównego "hamburger" > Opcje > Teksty aplikacji > menu "hamburger" > Nowy tekst

Rys. Edytor wielojęzycznego tekstu aplikacji.

Wprowadzone teksty wyszukuje się, wpisując hasło w polu wyszukiwania.

Rys. Wyszukiwanie tekstów wielojęzycznych.


Język programu

Home > 10. Język programu

10. Język programu

Funkcja Teksty programu, dostępna z menu głównego "hamburger" > Opcje > Teksty programu, służy do przygotowania na serwerze wersji językowej programu Asix Mobile dla wybranego przez użytkownika języka.

Po naciśnięciu przycisku Utwórz plik, na serwerze zostanie utworzony plik z tekstami programu do przetłumaczenia na język docelowy. Teksty do tłumaczenia będą w wybranym języku źródłowym. Plik generowany jest na podstawie wbudowanych w program tekstów angielskich lub polskich.

Rys. Okno tekstów programu.


10. Informacje o serwerze

Home > 11. Informacje o serwerze

11. Informacje o serwerze

Sekcja programu Asix Mobile dostępna po naciśnięciu przycisku Serwer [image] w dolnej części ekranu służy do wyświetlenia informacji o serwerze, do którego jest zalogowany użytkownik. Wyświetlany jest Adres serwera i U żytkownik zalogowany. Dostępny jest przycisk do wylogowania użytkownika z serwera.

W górniej części ekranu jest wyświetlana wersja programu Asix Mobile oraz przycisk Więcej. Jego naciśnięcie powoduje przejście do ekranu wyświetlające szczegóły dotyczące serwera i klienta Asix Mobile.


Alarmy aktywne

Home > 12. Alarmy, powiadomienia, alerty > 12.1. Alarmy aktywne

12.1. Alarmy aktywne

Okno alarmów aktywnych pozwala użytkownikowi szybko sprawdzić, czy w obiekcie monitorowanym przez aplikację Asix.Evo występują jakieś problemy, które mogą wymagać jego zaangażowania. Z całej puli alarmów aplikacji Asix.Evo każdy użytkownik może wybrać zbiór alarmów, które go interesują. Aktywne alarmy z tego zbioru są wyświetlane w oknie alarmów aktywnych.

Lista alarmów aktywnych jest posortowana po czasie, poczynając od najnowszego. Kolor ikony z lewej strony alarmu przedstawia ważność alarmu. Lista alarmów jest automatycznie odświeżana. Dodatkowo, aktualna liczba alarmów aktywnych jest wyświetlana jako plakietka na pasku zakładek, na przycisku Alarm.

Rys. Okno alarmów aktywnych.


Powiadomienia

Home > 12. Alarmy, powiadomienia, alerty > 12.2. Powiadomienia

12.2. Powiadomienia

System powiadomień pozwala użytkownikowi szybko dowiedzieć się, że w obiekcie monitorowanym przez aplikację Asix.Evo występują jakieś problemy, które mogą wymagać jego zaangażowania. Użytkownik nie musi mieć otwartej aplikacji Asix Mobile ani też mieć odblokowanego telefonu. Z całej puli alarmów aplikacji Asix.Evo każdy użytkownik może wybrać zbiór alarmów, które go interesują. Informacja o zmianie stanu każdego z wybranych alarmów jest wysyłana automatycznie w postaci powiadomienia.

Powiadomienie przesyłane jest jako powiadomienie systemowe, którego wygląd jest zależny od urządzenia odbiorcy. Będzie to plakietka na zablokowanym ekranie, panel u góry ekranu na odblokowanym ekranie lub okienko w prawym dolnym rogu pulpitu Windows. Po kliknięciu na powiadomienie automatycznie otwierany jest Asix Mobile z aktywowaną zakładką Alarmy.

Powiadomienia są przesyłane do wszystkich urządzeń, na których logował się dany użytkownik i włączył otrzymywanie powiadomień. Na danym urządzeniu pojawiają się powiadomienia dla tego użytkownika, który jako ostatni logował się tu do aplikacji Asix Mobile.

Aby powiadomienia mogły być odbierane, na urządzeniu należy jednorazowo włączyć odbieranie powiadomień. W tym celu należy otworzyć okno opcji programu (przejść na zakładkę Aplikacja, otworzyć menu, wybrać polecenie Opcje, wybrać grupę opcji Powiadomienia). Następnie w oknie Powiadomienia należy nacisnąć przycisk Włącz powiadomienia i postępować zgodnie z instrukcjami na ekranie. Przycisk Włącz powiadomienia nie jest dostępny jeśli bieżąca przeglądarka nie obsługuje powiadomień. Aby w przyszłości wyłączyć otrzymywanie powiadomień, należy ponownie otworzyć okno opcji powiadomień i nacisnąć przycisk Wyłącz powiadomienia.

Odbieranie powiadomień nie jest obsługiwane przez aplikację Asix Mobile pracującą w przeglądarce.


Baza alertów

Home > 12. Alarmy, powiadomienia, alerty > 12.3. Baza alertów

12.3. Baza alertów

Alarmy aktywne i powiadomienia są parametryzowane przez stworzenie bazy alertów. Baza alertów składa się z alertów aplikacji i alertów użytkownika. Jeden alert aplikacji składa się z listy nazw monitorowanych alarmów i listy nazw odbiorców zainteresowanych tymi alarmami. Jeden alert użytkownika składa się z listy nazw monitorowanych alarmów - odbiorcą jest sam użytkownik.

Baza alertów składa się z jednej globalnej bazy alertów aplikacji i jednej bazy alertów dla każdego użytkownika. Możliwe jest używanie tylko alertów aplikacji lub tylko alertów użytkowników. Oznacza to, że jeden administrator/projektant może chcieć mieć wszystko scentralizowane i używa tylko bazy alertów aplikacji. Inny może nie chcieć zajmować się tworzeniem alertów i powierza użytkownikowi, który je potrzebuje, zdefiniowanie swoich własnych alertów użytkownika.

Aby edytować bazę alertów aplikacji, należy wybrać zakładkę Alarmy i w menu wybrać polecenie Edytuj alerty aplikacji. Pojawia się okno zawierające listę nazw zdefiniowanych alertów. Przesuwając alert w lewo uzyskuje się dostęp do poleceń Edytuj, Kopiuj i Usuń. W menu okna dostępne jest polecenie Nowy alert. Po wybraniu polecenia Nowy alert pojawia się okno edytora alertu. Składa się ono z trzech zakładek: Właściwości, Alarmy i Odbiorcy.

W zakładce Właściwości należy podać unikalną nazwę alertu i ustawić opcje Aktywny i Wysyła powiadomienia. Jeśli alert jest aktywny, to jest on brany pod uwagę przy generowaniu listy alarmów aktywnych. Jeśli dodatkowo włączona jest opcja Wysyła powiadomienia, to wybrani użytkownicy będą otrzymywać powiadomienia o zmianach stanów wybranych alarmów.

W zakładce Alarmy należy utworzyć listę alarmów. Aby dodać alarm do listy, należy nacisnąć przycisk "+" na dole ekranu. Aby usunąć alarm z listy, należy wybrać przycisk "x" na dole ekranu.

W zakładce Odbiorcy należy utworzyć listę odbiorców. Aby dodać indywidualnego użytkownika, należy nacisnąć przycisk „człowiek +” na dole ekranu. Aby dodać grupę użytkowników (w terminologii Asix Evo zwaną rolą), należy nacisnąć przycisk „ludzie +” na dole ekranu. Aby usunąć odbiorcę z listy, należy wybrać przycisk "x" na dole ekranu.

Aby edytować bazę alertów bieżącego użytkownika, należy wybrać zakładkę Alarmy i w menu wybrać polecenie Edytuj alerty użytkownika. Pojawia się okno zawierające listę nazw zdefiniowanych alertów. Przesuwając alert w lewo, uzyskuje się dostęp do poleceń Edytuj, Kopiuj i Usuń. W menu dostępne jest polecenie Nowy alert. Po wybraniu polecenia Nowy alert pojawia się okno edytora alertu. Składa się ono z dwu zakładek: Właściwości i Alarmy.

W zakładce Właściwości należy podać unikalną nazwę alertu i ustawić opcje Aktywny i Wysyła powiadomienia. Jeśli alert jest aktywny, to jest on brany pod uwagę przy generowaniu listy alarmów aktywnych. Jeśli dodatkowo włączona jest opcja Wysyła powiadomienia, to bieżący użytkownik będzie otrzymywał powiadomienia o zmianach stanów wybranych alarmów.

W zakładce Alarmy należy utworzyć listę alarmów. Aby dodać alarm, należy nacisnąć przycisk "+" na dole ekranu. Aby usunąć alarm z listy, należy wybrać przycisk "x" na dole ekranu.


Powiadomienia – opis techniczny

Home > 12. Alarmy, powiadomienia, alerty > 12.4. Powiadomienia – opis techniczny

12.4. Powiadomienia – opis techniczny

Serwer Asix Mobile zarządza całą bazą alertów. Baza przechowywana jest w plikach w formacie xml w podkatalogu aplikacji Asix Evo.

Serwer Asix Mobile cały czas monitoruje stan wszystkich alarmów zadeklarowanych w bazie alertów. Gdy użytkownik otworzy aplikację Asix Mobile, to na zakładce Alarmy może zobaczyć, które alarmy z jego bazy alertów są obecnie aktywne. Po każdej zmianie stanu alarmu serwer Asix Mobile może wysłać powiadomienie do wszystkich użytkowników, którzy są na liście odbiorców alertu zawierającego dany alarm.

Do rozsyłania powiadomień używana jest platforma Google GCM. Pośrednikiem jest serwer firmy OneSignal. Serwer OneSignal przechowuje informacje o urządzeniach użytkowników, którzy włączyli powiadomienia w aplikacji Asix Mobile. Serwer Asix Evo po wykryciu zmiany stanu alarmu przekazuje do serwera OneSignal polecenie wysłania powiadomienia użytkownikowi.

Serwer OneSignal wysyła do serwisu Google GCM polecenie wysłania powiadomienia do odpowiednich urządzeń użytkownika. Serwer Google GCM wysyła powiadomienie na urządzenie.

Czas od zmiany stanu alarmu do pojawianie się powiadomienia na urządzeniu odbiorcy to zwykle kilka sekund. Jednak należy być świadomym, że o ile serwer Google GCM podejmie maksimum działań, aby dostarczyć powiadomienie, to dostarczenie powiadomienia nie jest gwarantowane. Powiadomienie wysłane z serwera Asix Mobile w rzadkich przypadkach może nie być nigdy dostarczone i serwer Asix Mobile nie otrzyma o tym fakcie żadnej informacji.

Uprzedza się, że w przypadku zakończenia świadczenia usługi przez platformę Google GCM lub serwer OneSignal, powiadomienia przestaną działać bez żadnej winy ze strony firmy Askom. Firma Askom dołoży wszelkich starań w celu stworzenia nowej wersji systemu powiadomień wykorzystującego nowe, aktualnie dostępne centra powiadomień. Nowa wersja systemu powiadomień na pewno pojawi się w bieżącej wersji pakietu Asix Evo . Możliwe, że system powiadomień zostanie uaktualniony również w starszych wersjach pakietu Asix Evo, jednak nie jest to gwarantowane. W każdym przypadku administrator będzie musiał we własnym zakresie zainstalować nową wersję pakietu Asix Evo.


1. Wstęp

Moduł Asix Mobile umożliwia prezentację danych procesowych na urządzeniach mobilnych takich jak smartfony i tablety. W module Asix Mobile dostępne są wszystkie rodzaje danych procesowych, czyli dane bieżące, dane archiwalne i alarmy.

Aplikacja Asix Mobile jest częścią aplikacji Asix Evo. Aplikacja Asix Mobile udostępnia te same dane procesowe, które są dostępne w aplikacji Asix Evo.


4. Konfiguracja uprawnień

Home > 3. Konfiguracja serwera > 3.2. Konfiguracja uprawnień

3.2. Konfiguracja uprawnień

Konfigurowanie uprawnień dla modułu Asix Mobile odbywa się w ustawieniach zabezpieczeń aplikacji Asix.Evo (AsixEvo.exe > Eksplorator aplikacji > Zabezpieczenia), w grupie opcji Role. Dla każdego użytkownika dostępne są następujące uprawnienia systemowe:

  • Asix Mobile: Prawo dostępu

Użytkownik musi posiadać to uprawnienie, aby móc korzystać z modułu Asix Mobile.

  • Asix Mobile: Edycja diagramów i opcji

Uprawnienie zezwala użytkownikowi na edycję diagramów aplikacji, ustalanie diagramu startowego i edycję domyślnego wyglądu diagramu. Użytkownik, który nie posiada tego uprawnienia, może tylko przeglądać diagramy aplikacji.

  • Asix Mobile: Sterowanie zmiennych

Uprawnienie umożliwia wywołanie okna sterowania i zmodyfikowanie wartości zmiennej. Bez tego uprawnienia użytkownik nie ma dostępu do okna sterowania.

  • Asix Mobile: Potwierdzanie alarmów

Uprawnienie umożliwia wywołanie okna potwierdzania alarmu i wysłanie potwierdzenia alarmu. Bez tego uprawnienia użytkownik nie ma dostępu do okna potwierdzania.

powiększ >>

Rys. Okno konfiguracji uprawnień do obsługi Asix Mobile.

Należy również dokonać konfiguracji domeny alarmów. Wymaga to załączenia opcji Zezwalaj na potwierdzanie alarmów z aplikacji Asix Mobile:

AsixEvo.exe > Eksplorator aplikacji > System alarmów > Domena > Ustawienia > Pozostałe ustawienia


5.2. Uruchamianie aplikacji w przeglądarce telefonu/tabletu

Home > 4. Uruchamiania aplikacji > 4.2. Uruchamianie

4.2. Uruchamianie aplikacji w przeglądarce telefonu/tabletu

Na telefonie z systemem Android 4.1+ w należy uruchomić przeglądarkę Chrome, na telefonie iPhone przeglądarkę Safari. Po uruchomieniu przeglądarki należy wpisać w pasku adresu właściwy adres aplikacji Asix Mobile.

Po załadowaniu, aplikacja Asix Mobile jest gotowa do użycia. Jednak paski narzędziowe przeglądarki znacznie ograniczają dostępną przestrzeń. Dlatego należy wykonać jeszcze jeden krok, aby aplikacja uruchamiała się w trybie pełnoekranowym.

W systemie Android należy z menu przeglądarki wybrać polecenie Add to homescreen. Jeżeli w przeglądarce nie ma tego polecenia, to należy pobrać z Google Play aktualną wersję przeglądarki Chrome.

W systemie iOS należy z menu wysyłania przeglądarki wybrać polecenie Do ekranu początkowego. Po wykonaniu tego polecenia na ekranie startowym pojawi się ikona programu Asix Mobile.

Od tego momentu nie trzeba uruchamiać przeglądarki i wpisywać adres, wystarczy kliknąć w ikonę programu.


5.3. Uruchamianie w przeglądarce na systemie Windows

Home > 4. Uruchamiania aplikacji > 4.3. Uruchamianie w przeglądarce na systemie Windows

4.3. Uruchamianie w przeglądarce na systemie Windows

Aplikację można uruchomić w systemie Windows, używając przeglądarki Google Chrome lub Mozilla Firefox. Przeglądarki Internet Explorer i Microsoft Edge nie są obsługiwane.

Po uruchomieniu przeglądarki, należy wpisać w pasku adresu adres aplikacji Asix Mobile. Jeśli przeglądarka jest uruchomiona na tym samym komputerze, na którym pracuje serwer Asix.Evo, to można wpisać adres:

http://127.0.0.1/mobile


Home > 5. Uruchamiania aplikacji

5. Uruchamiania aplikacji


6. Logowanie się

Home > 4. Uruchamiania aplikacji > 4.4. Logowanie się

4.4. Logowanie się

Po pierwszym uruchomieniu aplikacji Asix Mobile pojawia się okno logowania. Należy podać nazwę użytkownika zdefiniowanego w aplikacji Asix.Evo i hasło. Podany użytkownik musi mieć przydzielone prawo do logowania w module Asix Mobile.

Ostatnia opcja to Nie wylogowuj mnie. Jeśli jest włączona, to przy następnym uruchomieniu programu ekran logowania będzie pominięty i od razu zostanie załadowany pierwszy diagram aplikacji.

Rys. Okno logowania.


8.2.2. Segment Łącze

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.2. Segment Łącze

6.2.2. Segment Łącze

Segment typu Łącze umożliwia przechodzenie z diagramu bieżącego do następnego. Służy on do tworzenia diagramów rozprowadzających, prowadzących użytkownika do kolejnych diagramów wyświetlających informacje z wybranego fragmentu aplikacji Asix.Evo.

Oprócz elementów: Tytuł, Opis, segment wymaga podania nazwy diagramu docelowego w polu Nazwa otwieranego diagramu. W końcowym efekcie na diagramie, na którym zostanie umieszczony segment typu Łącze, pojawia się po prawej stronie strzałka sygnalizująca możliwość przejścia do innego diagramu.

Rys. Okno edycji segmentu dla typu danych - Łącze.

Rys. Okno edycji segmentu dla typu danych - Łącze.

Wygląd segmentu definiowany jest na zakładce Elementy > Wygląd segmentu > Segment. Definicja ta obejmuje wygląd tła, tytułu, opisu oraz możliwość dodania ikony w różnych wariantach kolorystycznych.

Rys. Okno edycji wyglądu segmentu dla typu danych - Łącze.

Rys. Widok łącza do innego diagramu.


8.5. Odświeżanie diagramu

Home > 6. Tworzenie aplikacji > 6.6. Odświeżanie diagramu

6.6. Odświeżanie diagramu

Dane bieżące i alarmy wyświetlane na diagramie są automatycznie, periodycznie odświeżane. Należy o tym pamiętać uruchamiając aplikację na urządzeniu, które jest połączone z serwerem Asix.Evo, poprzez łącze komórkowe. Załadowanie diagramu powoduje ciągłe transmitowanie niewielkich porcji danych.

Inaczej jest w przypadku wykresów, czyli wizualizacji danych historycznych. Po załadowaniu diagramu jednokrotnie pobierane są wykresy wyświetlające dane za ostatni, wybrany okres. Aby odświeżyć wykresy, należy wybrać polecenie Odśwież wykresy, dostępne z menu głównego "hamburger".


9. Tworzenie diagramów użytkownika

Home > 7. Tworzenie diagramów użytkownika

7. Tworzenie diagramów użytkownika

Sekcja programu Asix Mobile dostępna po naciśnięciu przycisku Moje diagramy [image] w dolnej części ekranu służy do zarządzania i przeglądania diagramami utworzonymi przez użytkownika.

Diagramy dostępne w tej części programu są inne dla każdego zalogowanego użytkownika, a tworzenie ich nie wymaga żadnych uprawnień. Diagramy użytkownika, tak samo jak diagramy aplikacji, są przechowywane na serwerze. Dlatego niezależnie z jakiego urządzenia użytkownik się zaloguje, ma dostęp do tego samego zbioru diagramów.

Diagramy są tworzone przez użytkownika, jednak mogą wyświetlać tylko te same dane procesowe, które są dostępne w diagramach aplikacji.


Projekt: Numer umowy/zadania

Home > Projekt: Numer umowy/zadania

Pomoc dla użytkowników systemu Asix 8

www.asix.com.pl

Asix.Evo - Asix Mobile

Dok. Nr PLP8E017

Wersja: 2015-09-04

ASKOM® i Asix® to zastrzeżone znaki firmy ASKOM Sp. z o. o., Gliwice. Inne występujące w tekście znaki firmowe bądź towarowe są zastrzeżonymi znakami ich właścicieli.

Wszelkie prawa zastrzeżone. Nieautoryzowane rozpowszechnianie całości lub fragmentu niniejszej publikacji w jakiejkolwiek postaci jest zabronione. Wykonywanie kopii metodą kserograficzną, fotograficzną lub inną powoduje naruszenie praw autorskich niniejszej publikacji.

ASKOM Sp. z o. o. nie bierze żadnej odpowiedzialności za jakiekolwiek szkody wynikłe z wykorzystywania zawartych w publikacji treści.

Copyright © 2015, ASKOM Sp. z o. o., Gliwice

ASKOM Sp. z o. o., ul. Józefa Sowińskiego 13, 44-121 Gliwice,

tel. +48 32 3018100, fax +48 32 3018101,

http://www.askom.com.pl , e-mail: biuro@askom.com.pl

Spis treści

1. Wstęp

2. Instalacja

3. Konfiguracja serwera

4. Konfiguracja uprawnień

5. Uruchamiania aplikacji

5.1. Adres aplikacji

5.2. Uruchamianie aplikacji w przeglądarce telefonu/tabletu

5.3. Uruchamianie w przeglądarce na systemie Windows

6. Logowanie się

7. Nawigacja

8. Tworzenie aplikacji

8.1. Tworzenie diagramu

8.2. Edycja segmentu

8.2.1. Segment Tekst

8.2.2. Segment Łącze

8.2.3. Segment Alarm

8.2.4. Segment Zmienna

8.3. Diagram startowy

8.4. Dostosowanie domyślnego stylu segmentu

8.5. Odświeżanie diagramu

9. Tworzenie diagramów użytkownika

9.1. Lista diagramów

10. Informacje o serwerze


Sterowanie zmienną

Home > 6. Tworzenie aplikacji > 6.2. Edycja segmentu > 6.2.4. Segment Zmienna > 6.2.4.6. Sterowanie zmienną

6.2.4.6. Sterowanie zmienną

Do sterowania zmienną służy okno sterowania. Otwiera się je klikając w segment diagramu. Aby okno sterowania było dostępne, muszą być spełnione następujące warunki:

  • użytkownik musi mieć uprawnienie sterowania,

  • segment musi mieć określony Sposób sterowania.

Jeśli te warunki są spełnione, to segment ma specjalne tło sterowania (domyślnie żółte) dla zaznaczenia, że jest dla niego dostępne okno sterowania.

Sposoby sterowania:

- brak,

- bieżącą zmienną,

- inną zmienną,

- akcją złożoną (jedna akcja z parametrem lub zestaw akcji z parametrami).

Okno sterowania ma inne właściwości dla każdego z typów zmiennej. Dla zmiennej liczbowej można wprowadzić dowolną wartość liczbową z podanego zakresu zmiennej. Wartość można też wybrać przy pomocy suwaka. Naciśnięcie przycisku Potwierdź powoduje wysłanie nowej wartości zmiennej do aplikacji Asix.Evo. Można też wykonać akcję złożoną. Po chwili niżej pojawia się komunikat informujący o wysłaniu sterowania/wykonaniu operacji lub ewentualnie komunikat błędu.

Dla zmiennej tekstowej można wprowadzić dowolny tekst i wysłać go. Można też wykonać akcję złożoną.

Dla zmiennej typu "Wartość binarna" możliwe jest sterowanie dwoma przyciskami dla wartości 0 i 1 lub przy pomocy przełącznika. W edytorze segmentu znajduje się opcja Użyj przełącznika, która umożliwia włączenie sterowania przełącznikiem. Można też wykonać akcję złożoną.

Dla zmiennej typu Bity wyświetlane jest tyle przycisków ile stanów jest dostępnych do sterowania. Można też wykonać akcję złożoną.

Dla zmiennej typu Agregat można wprowadzić dowolną wartość liczbową z podanego zakresu zmiennej. Wartość można też wybrać przy pomocy suwaka. Naciśnięcie przycisku Potwierdź powoduje wysłanie nowej wartości zmiennej do aplikacji Asix.Evo. Można też wykonać akcję złożoną.